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General Safety Summary General Safety Summary

General Safety Summary

Review the following safety precautions to avoid injury and prevent damage to this product or any
products connected to it. To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures. While using this product, you may need to
access other parts of the system.

Read the General Safety Summary in other system manuals for warnings and cautions related to operating
the system .

To avoid Fire and Personal Injury

Use Proper Power Cord. Use only the power cord specified for this product and certified for the country
of use.

Connect and Disconnect Properly. Connect the probe output to the measurement oscilloscope before
connecting the probe to the circuit under test. Disconnect the probe input and the probe ground from the

circuit under test before disconnecting the probe from the measurement oscilloscope.

Ground the Product. This product is indirectly grounded through the grounding conductor of the
mainframe power cord. To avoid electric shock, the grounding conductor must be connected to earth
ground. Before making connections to the input or output terminals of the product, ensure that the product
is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the
product. Consult the product manual for further ratings information before making connections to the
product.

Use Proper AC Adapter. Use only the AC adapter specified for this product.
Use Proper Fuse. Use only the fuse type and rating specified for this product.

Do Not Operate With Suspected Failures. If you suspect there is damage to this product, have it inspected
by qualified service personnel.

Do Not Operate in Wet/Damp Conditions.
Do Not Operate in an Explosive Atmosphere.

Keep Product Surfaces Clean and Dry.

TDSUSB2 Universal Serial Bus Measurements Package 1



General Safety Summary General Safety Summary

Terms in this Manual

These terms may appear in this manual:
WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product
or other property.

Terms on the Product

These terms may appear on the product:

DANGER indicates an injury hazard immediately accessible as you read the marking.
WARNING indicates an injury hazard not immediately accessible as you read the marking.

CAUTION indicates a hazard to property including the product.

Symbols on the Product

The following symbol(s) may appear on the product:

A O @ Xx

CALITION Dl -
foefer in Meanual — Ml st for St bt
the pubdic ieecnm e puldic telecom

munaion etwsk  municaion relsork
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Introduction Welcome to the TDSUSB2 Universal Serial Bus Measurements Package

Welcome to the TDSUSB2 Universal Serial Bus Measurements Package

TDSUSB2
USB 2.0 Compliance Test Software

Copyright 2006, Tektronix, Inc.

TDSUSB2 Universal Serial Bus Measurements Package is a Sun Java-based application that runs on the
supported instruments connected to a PC. You can use the application software with the compliance
test fixture to take the following measurements:

Signal Quality

Inrush

Droop

Drop (supported by the test fixture only)
Receiver Sensitivity

Impedance Measurement using Time Domain Reflectometry (TDR), supported by the application
only with the test fixture

Chirp measurements
Packet Parameter
Resume

Reset from Suspend
Reset from High Speed
Suspend

The application runs on the oscilloscope and displays on the lower part of the screen. The oscilloscope
application runs on the upper part of the screen.

TDSUSB?2 Universal Serial Bus Measurements Package 3



Introduction Online Help and Related Documentation

What do you want to do?
B Online Help and Related Documentation
B [ntroduction and Product Description

® Installing the Application

TIP. 1o return to the Table of Contents, select Help Topics from the Help Topic Menu.

Online Help and Related Documentation

You can access the information on how to operate the application and the oscilloscope through the
following related documents and online help.

Click Start > Programs > TekApplications > TDSUSB2 > Help to access the Online Help.

Click Start > Programs > TekApplications > TDSUSB2 > Help (PDF Version) to access the PDF
version of the Online Help.

Click Start > Programs > TekApplications > TDSUSB2 > Host Test Procedure to access the Host
Test procedure.

Click Start > Programs > TekApplications > TDSUSB2 > Hub Test Procedure to access the Hub
Test procedure.

Click Start > Programs > TekApplications > TDSUSB2 > Device Test Procedure to access the Device
Test procedure.

Click Start > Programs > TekApplications > TDSUSB2 > Quick Reference Card to access the Quick
Reference Card.

See Also

= Conventions

Related Documentation

Contacting Tektronix

Feedback

Printing from the Online Help

Some online help topics have color in the examples of the displayed application. If you want to print
this type of topic on a monochrome printer, some information may not print because of certain colors.
Instead, you should print the topic from the PDF (portable document format) file that corresponds to the

4 TDSUSB?2 Universal Serial Bus Measurements Package



Introduction Conventions

Online Help. You can find the file in the Documents directory on the Optional Applications Software on
Windows-Based Oscilloscopes DVD. The figures of application menus in the PDF file are gray scale and
all of the information prints.

Conventions

Online help uses the following conventions:

m  Refers to the software part of the TDSUSB2 Universal Serial Bus Measurements Package as the
TDSUSB2 application or as the application.

B When steps require a sequence of selections using the application interface, the ">" delimiter marks
each transition between a menu and an option. For example, one of the steps to recall a setup file
would appear as File > Recall.

®  Unit under test (UUT) refers to the USB2.0 device under test, hub under test, host under test, and
port under test.

B SOF refers to the Start of Frames exchanged between the host controller and the device when the
device is connected to the host and enumerated by the test mode software.

Related Documentation

In addition to the Online Help, you can access other information on how to operate the oscilloscope
through the following related documents:

m  Instrument Information: The user manual for your oscilloscope provides general information on how
to operate the oscilloscope.

B Programmer Information: The online help for your oscilloscope provides details on how to use GPIB
commands to control the oscilloscope.

TIP. You can also download the following files, which contain programmer information and examples,
from the Tektronix Web site.

B Optional Applications Software on Windows-Based Oscilloscopes Installation Manual
B TDSUSB2 Universal Serial Bus Measurements Package Reference

m  TDSUSBF USB2.0 Compliance Test Fixture Instructions

For more information on USB2.0 specifications, visit www.usb.org.

Refer to the Optional Applications Software on Windows-Based Oscilloscopes Installation Manual for the
following information:

B Software warranty

TDSUSB?2 Universal Serial Bus Measurements Package 5



Introduction Feedback

® List of all available applications, compatible instruments, and relevant software and firmware version
numbers

B Applying a new label

m [Installation an application

®  Enabling an application

B Downloading updates from the Tektronix Web site

You can find a PDF (portable document format) file of this document in the Documents directory on the
Optional Applications Software on Windows-Based Oscilloscopes DVD. The DVD booklet only contains
information on installing the application from the DVD and on how to apply a new label.

Feedback

Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments about your oscilloscope.

Direct your feedback via email to

techsupport@tektronix.com or FAX at (503) 627-5695

and include the following information. Please be as specific as possible.

General information:

B Instrument model number and hardware options, if any

B Probes used

B Your name, company, mailing address, phone number, FAX number

B Please indicate if you would like to be contacted by Tektronix about your suggestion or comments
Application specific information:

®m  Software version number

m  Description of the problem such that technical support can duplicate the problem

B [fpossible, save the oscilloscope and application setup files as .set files

B [fpossible, save the waveform on which you are performing the measurement as a .wfm file

Once you have gathered this information, you can contact technical support by phone or through e-mail. If
using e-mail, be sure to enter in the subject line "TDSUSB2 Problem," and attach the .set and .wfm files.

6 TDSUSB?2 Universal Serial Bus Measurements Package



Introduction Feedback

TIP. To include screen shots from the oscilloscope menu bar, select File> Export Setup> Image tab or File
> Save > Screen Capture. Save the screen shot in the default directory or you can choose a directory of
your choice. If you want the screen shots in color, select Edit> Copy setup> Images tab or select File

> Save > Screen Capture and select Options to get the Screen Capture Save Option dialog box. Select
the Color, Full Screen and the Normal option buttons. Select Copy. Copy the picture to any Paint editor
software. You can then attach the file to your email (depending on the capabilities of your email editor).

TDSUSB?2 Universal Serial Bus Measurements Package
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Getting Started Introduction and Product Description

Introduction and Product Description

The TDSUSB2 Universal Serial Bus Measurements package, consists of a Java-based application and a
comprehensive test fixture. You can use the application software with the compliance test fixture to take
the following measurements:

Signal Quality

Inrush

Droop

Drop (supported by the test fixture only)
Receiver Sensitivity

Impedance Measurement using Time Domain Reflectometry (TDR), supported by the application
only with the test fixture

Chirp measurements
Packet Parameter
Resume

Reset from Suspend
Reset from High Speed
Suspend

The application performs tests that measure the test signals for USB2.0 compliance, displays eye diagrams
and plots, displays the results as a summary or as details, and generates reports in different formats.

What do you want to do?

Accessories
Compatibility
Requirements and Restrictions

Installing the Application

TDSUSB?2 Universal Serial Bus Measurements Package 9
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Compatibility

For information on oscilloscope compatibility 1, refer to the Optional Applications Software on
Windows-Based Oscilloscopes Installation Manual, Tektronix part number 071-1888-XX. The manual is
also available as a PDF file. The dynamic range of the probes used for Low Speed and Full Speed testing
should be at least & 8 volts. For High Speed testing, the dynamic range should be + 2 volts.

1 For a current list of compatible instruments, see the Software and Drivers category on the Tektronix Web site.

Requirements and Restrictions

You must install Java Run-Time Environment V1.4.2 02 on the supported oscilloscope.

The application uses the Math1 channel for Low Speed and Full Speed mode of operation. You will lose
any information that you have stored in the Math1 channel.

You cannot restore the oscilloscope settings if you select File > Exit from the application.

Accessories

The application includes the following standard accessories:

m  Optional Application Software on Windows-Based Instruments DVD

m  Optional Application Software on Windows-Based Instruments Installation Manual
B TDSUSB2 Universal Serial Bus Measurements Package Reference

B TDSUSBF USB2.0 Compliance Test Fixture Instructions

m  TDSUSBF USB2.0 Compliance Test Fixture (Revision B)

Optional Accessories:

Signal Source (for Receiver Sensitivity Tests):

B DTG5334 or DTG5274 or DTG5078 with a DTGM 21 Output module-Data Generator
B AWGS5000 series (AWG5002) or AWG7000 series 1

m  TDSUSBF USB2.0 Compliance Test Fixture (Revision B)

1 X5 attenuators required when using AWG models.
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Voltage Probes:
B HP62481, P6330- High Bandwidth Differential Probe
= H P6245 or P6243- High Bandwidth Single-ended Active Probe

1 The P6248 probe is approved for compliance testing, higher performance differential probes may be used for design applications. It is
recommended to have an attenuation of divide by 1 for better results.

For DPO7000 series:
®  TDP1500 or TDP3500
m  TAP1500

B P6248, P6330, or P6245 (these require TPA-BNC Adapter on DPO7000 series models)

Current Probes:
= TCP0030
m  TCP202 (requires TPA-BNC Adapter on DPO7000 series models)

TDR Measurements (for Impedance Measurement test):

B Tektronix DSA8000 Sampling Oscilloscope with Time Domain Reflectometer (TDR) Sampling
Module

Deskew Fixture: for supported instrument-Probe Calibration and Deskew Fixture, Tektronix part number
(067-0405-XX)

6-inch AB Cable with USB-IF compliance logo tag

NOTE. Any references to standard cable or standard length of cable in all TDSUSB manuals refers to
"6-inch AB Cable (standard USB cable with USB-IF compliance logo tag)", and references to USB
cable refers to "1-metre USB cable”.

Setting up the Instrument to Take Measurements

To set up the oscilloscope, follow these steps:
1. You must power on the oscilloscope for twenty minutes before you can start to take measurements.
2. You must run the compensation signal path on the oscilloscope.

3. You must make sure that the default factory setup is recalled before you start using the application in
the oscilloscope. To do so, push the recall default setup button on the front-panel of the oscilloscope
to recall the default factory settings.

4. You should always use calibrated probes and degauss the current probes.

TDSUSB?2 Universal Serial Bus Measurements Package 1
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Recommended Instruments and Probes

For information on recommended instruments and probes, refer to the Optional Application Software on
Windows-Based Oscilloscopes Installation Manual.

Installing the Application

Refer to the Optional Applications Software on Windows-Based Instruments Installation Manual for the
following information:

B [nstalling an application

B Applying a new label

m  Enabling an application

®  Downloading updates from the Tektronix Web site

You can find a PDF (portable document format) file of this document in the Documents directory on the
Optional Applications Software on Windows-Based Instruments DVD. The DVD booklet only contains
information on installing the application from the DVD and on how to apply a new label.

Deskewing the Probes and Channels

12

To ensure accurate measurements, you must deskew the probes before you take measurements from your
unit under test. The deskew process is where the oscilloscope adjusts the relative delay between the signals
to accurately time correlate the displayed waveforms.

The application includes an automated deskew utility that you can use to deskew any pair of oscilloscope
channels.

NOTE. It is recommend that you use the deskew fixture specified in the accessories section to perform
deskew. The deskew source can be the built-in probe compensation signal in the oscilloscope or an
external signal source.

NOTE. The oscilloscope has a deskew range of 50 ns.

TDSUSB?2 Universal Serial Bus Measurements Package
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See Also

B Deskewing Probes and Channels on the supported Instruments

Deskewing Probes and Channels on the supported Instruments

To deskew probes and channels on the supported instruments, follow these steps:
1. Connect the probes to Chl and Ch2 on the oscilloscope.

2. Connect the probe compensation signal to the deskew fixture. You can use the probe compensation
signal from the oscilloscope as the source for the deskew fixture.

3. Follow the on-screen prompts for the deskew operation with an external source.

The following figure shows signals before performing the deskew procedure with a single edge.

Fle  Edit ertcal Horgddcg Teg  Display  Cursoes Measswe  Masks  Math  Ublines Help
Tek  Run Sample 11 Sep 01 124802

3 Ch1l Position
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5000my |
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From Slope
Source ReflLevel : Hy=teresis :

m S0 k 5% | ! Select the channels io

deskeny and Confinm.

To

Source RefLevel : Hysteresis ® Edges L

= oL : L3 L
b - o s -
ChZ . S0% 5% | | 1 Fa

Creshen

4. To start the application from a supported oscilloscope, select File > Run Application > USB2.0 Test
Package from the menu bar of the oscilloscope.

5. Select Utilities> Deskew.
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14

10.

11.
12.
13.
14.
15.

Set the channel Source in the From area to Chl. The Source waveform is the reference point to which
the remaining channels are deskewed.

Set the channel Source in the To area to Ch2, to deskew the channel.

Select the Reference Level for Chl and set the reference value. The reference level is the percentage
level of the waveform from which to take the edges to deskew.

Select the Reference Level in the To area for Ch2 and set the reference value.

Select the Hysteresis in the From area for Ch1l. Hysteresis (see page 17) helps to ignore the noise
level in the waveform.

Select the Hysteresis in the To area for Ch2 and set the hysteresis value.

Select the Slope, Rise or Fall, on which to perform the deskew operation.

Select the number of edges used for deskew.

To start the deskew utility, select Utilities> Perform Deskew and confirm the operation.

Without changing the From: Chl channel, deskew the remaining channels.

The next figure shows the results after performing the deskew operation with a single edge. The reference
level is set to 50% for Chl and Ch2, the hysteresis is set to 5%, the number of edges is set to 1, and the
slope is set to the rising edge.

NOTE. The probe compensation signals varies from 0.8 to 1 volt (for all supported TDS instruments)
and from 0.35 to 1 volt (for all supported DPO instruments) rather than swinging from 0 to 1 volt in a
traditional oscilloscope. Set the Reference level and the Hysteresis level appropriately so that the Ref
level is at the middle of the swing on the signal.
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To perform the deskew operation with an external source, follow these steps:
1. Connect the probes to Chl and Ch2 on the oscilloscope.
2. Connect an external source to the deskew fixture.

3. Follow the instructions of the Probe Calibration and Deskew fixture (Tektronix part number:
067-0405-xx) to make the connections.

4. Set up the oscilloscope as follows:

= Use the Horizontal Scale knob to set the oscilloscope to an acquisition rate so that there are two or
more samples on the deskew edge.

= Use the Vertical Scale and Position knobs to adjust the signals to fill the display without missing
any part of the signals.

- Set the Record Length so that there are more samples for the edges in the acquisition. It is
recommended that you set the record length to 25000 points.

5. To start the application from a supported oscilloscope, select File > Run Application > USB2.0 Test
Package from the menu bar of the oscilloscope.

6. Select Utilities > Deskew.
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10.
11.

12.
13.
14.
15.
16.
17.

Set the channel Source in the From area to Chl. The remaining channels are deskewed to the Source
waveform, which is the reference point.

Set the channel Source in the To area to Ch2, the channel to be deskewed.

Select the Reference Level for Chl. The reference level is the percentage level of the waveform from
which to take the edges to deskew.

Select the Reference Level in the To area for Ch2 and set the reference value.

Select the Hysteresis in the From area for Ch1l. Hysteresis (see page 17) helps to ignore the noise
level in the waveform.

Select the Hysteresis in the To area for Ch2 and set the hysteresis value.

Select the Slope, Rise or Fall, on which to perform the deskew operation.

Select the number of edges used for deskew.

To start the deskew utility, select Utilities> Perform Deskew and confirm the operation.
Without changing the From: Chl channel, deskew the remaining channels.

The setup is an acquisition of a square signal at 100 KHz, with the Record length set to 25000 points to
achieve the sample resolution of 1.6 ns.

The next figure shows an example of a deskew setup.
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18. Set the Reference levels for Chl and Ch2 in the application to 50%, the hysteresis to 10%, the number

of edges to 4, and the type to rising edge.

The next figure shows the display after performing the deskew for the multiple edge.
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19. The zoomed section of the waveform available on the lower part of the screen shows the results of
the deskew operation clearly. You will see that after performing the deskew operation, the skew is

automatically removed.

Hysteresis

Hysteresis indicates the noise level in the waveform.

TDSUSB?2 Universal Serial Bus Measurements Package
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About Basic Operations

This section contains information on the following topics and tasks:

Application Interface

Using Basic Oscilloscope Functions
Setting Up the Software

Selecting a Measurement

How to Save and Recall a Setup

Exiting the Application

Application Interface

The application uses a Windows interface. You should refer to your oscilloscope user manual for the
operating details of other controls, such as the front-panel buttons.

NOTE. The oscilloscope screen shrinks and appears in the top half of the display when the application is
running on the supported instruments.

Application Directories and File Names

Application Interface Menu Controls

TDSUSB?2 Universal Serial Bus Measurements Package 19
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Application Interface Menu Controls

Application Interface Menu Controls

Item Description

Menu bar Located at the top of the application display and contains application menus
Tab Labeled group of options containing similar items

Area Visual frame that encloses a set of related options

Option button

Button that defines a particular command or task

List box

Box that contains a list of items from which you can select one item

Box

Box that you can use to type in text, or to enter a value with the Keypad or a Multipurpose
knob

Check Boxes

Square box that you can use to select or clear preferences

Scroll bar Vertical or horizontal bar at the side or bottom of a display area that can be used for
moving around in that area
Browse Displays a window where you can look through a list of directories and files

Command button

Button that initiates an immediate action

Keypad

Keypad appears when you select the box; select and use it to enter a value

MP/GPknob

A line that appears between the knob and the box when the MP or GP knob is selected;
turn the knob and select a value

Using Basic Oscilloscope Functions

20

You can use the Help menu to access information about the oscilloscope. You can also use other
oscilloscope functions and easily return to the application.

The TDSUSB2 application includes Online Help about the application menus and controls.

To display the Online Help, follow these steps:

1. Choose Help from the TDSUSB2 menu.

2. Use the Contents, Table of contents, or Index tabs to navigate through the help.

3. The touch screen mode of operation is enabled by default. You can disable this by using the Touch
Screen OFF button on the oscilloscope front panel.

See Also

®  Minimizing and Maximizing the Application
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® Returning to the Application

Minimizing and Maximizing the Application

To minimize the application, select File > Minimize. When you minimize the oscilloscope, the application
is continually displayed.

To maximize the application, select the TDSUSB2 icon in the Windows taskbar.

Application Directories and File Names

The application uses the directories for several functions, such as save and recall setup files, and uses the
extensions appended to the file names to identify the file type.

The following table lists default directory names for the supported instruments:

Directory Used for

C:\TekApplications\tdsusb2 Home location

C:\TekApplications\tdsusb2\report Report files

C:\TekApplications\tdsusb2\setup Setup files

C:\TekApplications\tdsush2\tsvfilegenerator Default directory for the tsv file generated by the file
generator and for other csv files

C:\TekApplications\tdsusb2\datagen Digital signal generator pattern files for use in Receiver
Sensitivity Test

C:\TekApplications\tdsusb2\images Images of the eye diagram and waveform plots

C:\TekApplications\tdsusb2\temp Temporary files used in the application

See Also

m File Name Extensions
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File Name Extensions

Extensions Description

.Csv Input file is in the .csv (comma separated variable) format and is used to generate a .tsv
(tab separated variable) file. An exported waveform that may be used as a source to
generate a tsv format file

ini Application setup file

.set Instrument setup file with the same name, saved and recalled with .ini and .set file name
extension

Asv Input file in a Tab Separated Variable format

See Also

m  CSV File Format
® TSV File Generator

Returning to the Application

When you access oscilloscope functions, the oscilloscope fills the display. You can access oscilloscope
functions in the following ways:

1. Select the Hide button in the application display.
2. Select the Menu bar or the Toolbar mode on the oscilloscope and access the menus.

3. To return to the application, click the App button on the menu bar of the oscilloscope or click on
Analyze > Restore Application to restore the application.

Exiting the Application

To exit the application, select the Exit button or File > Exit or select the Exit button from the control panel.

When you exit the application, you can keep the oscilloscope setup currently in use or restore the
oscilloscope setup that was present before you started the application.
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E xit

e Settings™

Exit the Application™

Description of the Test Fixture

The TDSUSBF USB2.0 Compliance Test Fixture (Revision B) is a break-out board that enables you
to test live USB2.0 signals, exchanged between the device and the host. For more information on the
compliance test fixture, refer to the TDSUSBF USB2.0 Compliance Test Fixture Instructions shipped
with the test fixture.

The compliance test fixture consists of the following sections:
B SQ Test Section

m  Receiver Sensitivity Test

B Impedance Measurement Test (TDR)

®  Disconnect Detect Test

B Adjacent Trigger and Droop Test

®  Host SQ

®  Inrush Test

B Downstream Sig Qual

TDSUSB?2 Universal Serial Bus Measurements Package
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Setting Up the Device Details

You can enter a unique identifier (ID) and description for the unit under test (device). The identifier and the
description appear in the generated reports for the tests performed on the unit under test. You can either
type in the text directly in the boxes for these fields, or use the keypad or a keyboard. You can also choose
to generate automatic IDs for the unit or enter a prefix using the keypad.

Q'_ll-! Weaswemants | Resuts Utibes Help

TOSUSEZ

Eperd Dawics ID
Signal Quality Che<k fafg_0071

Drawice Daperiptian

Dummy

NOTE. If you check the Generate Automatic ID, the Device ID field is disabled and the Prefix field
is enabled. The report for Inrush Measurement displays details of the Signal Setup with the device
description.
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Setting Up the Software

You can set up the application to take one or more measurements at the same time. In addition, you can
view the results as a summary, details, an eye diagram, and a waveform plot for Signal Quality checks. You
can also generate the reports in one of the three formats: Tektronix Specific, Plug-Fest and CSV formats.

The application runs on the oscilloscope. It is recommended that you connect the keyboard and the
mouse to use the application effectively.

See Also
B View the Default Setup
®  Selecting a Measurement

m Configuring a Measurement

Setting Preferences

The Preferences menu consists of two tabs: General and Advanced. To access the Preferences menu,
select File > Preferences.

TDSUSB2 Preferences

nged since last

‘eform Flat autom
orm-Plot butt
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TDSUSB2 Preferences

Frompt for the Droop test read out during
Report G arn.

Allow user configuration of test limits.
Packet identification by User Using cursors.

Hold Off
Et trigger

1.2us

In the General tab, you can select the following options:

m  Set a warning to indicate that the configuration options were not changed since the last time you ran
the application. If you set this option, the application prompts you to configure the measurements
before acquiring data.

®  Automatically display the Eye Diagram without having to select the Eye Diagram button in the
Results screen.

B Automatically display the Waveform Plot without having to select the Waveform Plot in the Results
screen.

B Prompt for a File name or Device ID before automatically generating reports or data files.
B  Automatically generate .tsv files.

B Display the generated report.

= Always display the waiver mask for High-Speed Near End and Low Speed eye diagrams.

B Do Autoset Every Time.

NOTE. Autoset will happen only for Full-Speed/High Speed SQC measurements.
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In the Advanced tab, you can select the following options:

= FEnable user defined scope BW. When you enable this option, you can set the oscilloscope BW for the
application in DPO series oscilloscopes using the Horiz/Acq menu.

B Prompt during report generation for the Droop test readout. When you enable this option, the
application disables report generation in the Automatic mode.

®  Configure the test limits. The result: PASS or FAIL is determined by the limits you have defined.

m  Place the vertical cursors between the start and end of the single USB2.0 packet. This is used when
more than one USB2.0 packet is displayed on the oscilloscope for Signal Quality measurements.

B Set the trigger holdoff value to capture the USB2.0 high-speed test packet.

NOTE. If you enable the Configure Test Limits options, the Results Summary and Report Generation in
Plug-Fest format is disabled.
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Table of Measurements and Options

Low Speed and Full Speed Measurements

Table of Measurements and Options

Area Option Description

Signal Quality Check Eye Diagram Checks whether the USB signal is aligned with its
corresponding eye diagram

Signal Quality Check Signal Rate Measures the inverse of the average bit-time that
gives the transmission rate of the USB signal

Signal Quality Check Paired JK Jitter Measures the jitter time for paired (JK next to KJ)

differential data transition

Signal Quality Check

Paired KJ Jitter

Measures the jitter time for paired (KJ next to JK)
differential data transition

Signal Quality Check

Consecutive Jitter

Measures the jitter at every consecutive data bit
calculated using the signal rate

Signal Quality Check

EOP Width

Measures the width of the end-of-packet of a USB
signal

Signal Quality Check

Cross-Over voltage

Measures the voltage at which the D+ voltage
crosses the D- voltage

Signal Quality Check

Rising Edge Rate

Measures the Rising Edge/Slew rate in V/ ys and
is calculated using the Rise time as

Rising Edge Rate = Amplitude / Rise Time

Where Amplitude is the peak-to-peak amplitude for
the corresponding signaling rate and the Rise time
is calculated based on the high level of the inner
vertical eye height reference levels

Signal Quality Check

Falling Edge Rate

Measures the Falling Edge/Slew rate in V/ ys and
is calculated using the Fall time as

Falling Edge Rate = Amplitude / Fall Time

Where Amplitude is the peak-to-peak amplitude for
the corresponding signaling rate and the Fall time
is calculated based on the lower level of the inner
vertical eye height reference levels

Inrush Current Check

Inrush Current

Measures the amount of electrical charge drawn
by a device as soon as it is connected to a USB
network

Droop Test Droop Test Measures the difference in the VBUS voltage when
the load switch is open to the lowest value of the
voltage and the load switch

High Speed Measurements

Area Option Description

Signal Quality Check Eye Diagram Checks whether the USB signal is aligned with its

corresponding eye diagram

28
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Table of Measurements and Options
Area Option Description
Signal Quality Check Signal Rate Measures the inverse of the average bit-time that

gives the transmission rate of the Test_Packet

Signal Quality Check

Monotonic Property

Detects when the Signal is Monotonic if and only
if data [i+1] = data [i] in case of consistently
increasing (rising slope), never decreasing data
[i+1] < data [i] when consistently decreasing
(falling slope) and never increasing in value where
i ranges from 0 to n

Signal Quality Check

EOP Width

Measures the width of the end-of-packet pattern of
a Test_Packet

Signal Quality Check

Rising Edge Rate

Measures the Rising Edge/Slew rate in V/ ys and
is calculated using the Rise time as

Rising Edge Rate = Amplitude / Rise Time

Where Amplitude is the peak-to-peak amplitude for
the corresponding signaling rate and the Rise time
is calculated based on the high level of the inner
vertical eye height reference levels

Signal Quality Check

Falling Edge Rate

Measures the Falling Edge/Slew rate in V/ ys and
is calculated using the Fall time as

Falling Edge Rate = Amplitude / Fall Time

Where Amplitude is the peak-to-peak amplitude for
the corresponding signaling rate and the Fall time

is calculated based on the lower level of the inner
vertical eye height reference levels

Inrush Current Check

Inrush Current

Measures the amount of electrical charge drawn
by a device as soon as it is connected to a USB
network

Droop Test

Droop Test

Measures the difference in the VBUS voltage when
the load switch is open to the lowest value of the
voltage and the load switch

Receiver Sensitivity Test

Receiver Sensitivity

Is an indicator of Receiver Sensitivity. A High
Speed capable device must indicate 'packet(Data)
not received’ (squelch) when the input of the
receiver falls below 100 mV differential amplitude.
Similarly the device must not indicate squelch if the
differential amplitude is greater than 150 mV

Chirp Test

Chirp

Checks a part of handshake that occurs during
Reset Protocol for high speed capable hubs and
devices. In this handshake, the hub/host and the
device are required to detect chirp J and K of a
specified minimum duration and amplitude

Suspend Test

Suspend

Measures the time between the end of the last
Start of Frame (SOF) and the rising edge transition
to the Full Speed J state. The acceptable range
should be between 3 ms to 3.125 ms. This is
applicable if you have selected a Host, Device, or
a Hub-Upstream device

TDSUSB?2 Universal Serial Bus Measurements Package
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Area Option Description

Resume Test Resume Resumes the High-speed operation in a device
or a hub, which is indicated by the presence of
High-speed SOF packets (with 400mV nominal
amplitude) following the K state driven by the host
controller. For the Host this is the time between
the falling edge of D+ to the First SOF. This should
not exceed 3.0mS

Rest from High-Speed Test Reset Measures the time between the beginning of the
last SOF and before the reset and the beginning
of Chirp-K. This is between 3.1 ms and 6 ms.
This test will be applicable for Device and HUB
upstream

Reset from Suspend Reset from Suspend Measures the time between the falling edge of
D+ signal and the start of Device chirp-K. This is
between 2.5 us and 3 ms. This test is applicable
for Device and HUB upstream

Packet Parameter Packet Parameter Measures the parameter of the packet such as
Sync Bits, EOP, and Inter-Packet Gap depending
on the selected measurement

Selecting a Measurement

30

To take a measurement, select Measurement from the Measurements menu, which is also the default
opening screen in the application. To access the Select option in the Measurement menu, select
Measurements> Select.

There are three categories of measurements: Low Speed, Full Speed, and High Speed measurements. The
measurements for Low, Full and High Speed signals are Signal Quality Checks, Inrush Current Check,
and Droop Test. The additional measurements for High Speed tests are Receiver Sensitivity, Monotonic
Property, and Chirp Test, Packet Parameter, Suspend, Resume, Reset from Suspend, and Reset from
High Speed.

You need to select the measurements for a particular signal speed of the unit under test. After selecting the
tests, you must configure the application based on Signal Source, Tier, Test Point, and Signal Direction.

You can test the units for the following:

B Devices for Upstream Signal Quality Check

®  Hubs and Hosts for Downstream Signal Quality Check
m  Ports of a Hub for Droop Test

®  Devices for Inrush Current

See Also

B Selecting a Measurement
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B Measurement Menu

B Signal Quality Check

B Inrush Current Check

® Droop Test

B Receiver Sensitivity Measurement
B Chirp Measurement

B Packet Parameter Measurement

B Suspend Measurement

® Resume Measurement

m Reset from Suspend Measurement

B Reset from High Speed Measurement

What do youwantto do?. ®Table of Measurements and Options

B Configuring a Measurement
®  Saving a Setup

B Recalling a Saved Setup

TDSUSB?2 Universal Serial Bus Measurements Package
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Signal Quality Check

Signal Quality Check

The application performs Signal Quality tests that include the following tests:

Area Option Description

Signal Quality Check Eye Diagram Checks whether the USB signal is aligned
with its corresponding eye diagram

Signal Quality Check Signal Rate Measures the inverse of the average bit-time

that gives the transmission rate of the USB
signal

Signal Quality Check

Paired JK Jitter

Measures the jitter time for paired (JK next to
KJ) differential data transition

Signal Quality Check

Paired KJ Jitter

Measures the jitter time for paired (KJ next to
JK) differential data transition

Signal Quality Check

Consecutive Jitter

Measures the jitter at every consecutive data
bit calculated using the signal rate

Signal Quality Check

EOP Width

Measures the width of the end-of-packet of
a USB signal

Signal Quality Check

Cross-Over voltage

Measures the voltage at which the D+ voltage
crosses the D- voltage

Signal Quality Check

Rising Edge Rate

The Rising Edge/Slew rate in (V/us) is
calculated using the Rise time as

Rising Edge Rate = Amplitude / Rise Time

Where Amplitude is the peak-to-peak
amplitude for the corresponding signaling
rate and the Rise time is calculated based on
the high level of the inner vertical eye height
reference levels

Signal Quality Check

Falling Edge Rate

The Falling Edge/Slew rate in (V/us) is
calculated using the Fall time as

Falling Edge Rate = Amplitude / Fall Time

Where Amplitude is the peak-to-peak
amplitude for the corresponding signaling
rate and the Fall time is calculated based on
the lower level of the inner vertical eye height
reference levels

Signal Quality Check

Monotonic Property (For High
Speed only)

Measures the Monotonic Signal if the data

[i] < data [i-1] where data[l] is the record
point in the acquired waveform. This is in
the case of consistently increasing (rising
Slope) only. If the data [i] > data [i-1] in case
of consistently decreasing )falling Slope) and
never increasing in value where i ranges from
0 to n, the signal | is said to be monotonic
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NOTE. The USB2.0 specifications recommend that you should test the signal quality for upstream and
downstream traffic. In upstream testing, the application captures the signals transmitted from the device to
the host. In downstream testing, the application captures the signals transmitted from the host to the device.

Downstream testing is performed on ports of a hub. When testing a hub, you need to connect the USB2.0
unit to Tier 6 to ensure the worst case. Each hub level is referred to as a Tier. The hub under test is
connected to the Tier 5, so that you can test the hub on the Tier 6.

Inrush Current Check

The application can perform an Inrush current check to verify that the unit under test does not draw
current higher than that specified in the USB2.0 specifications when connected to a USB2.0 system. If the
measured current drawn is higher than a specified value, the other USB2.0 devices connected to the bus
may not be able to function properly.

When a unit is connected, there is a sharp intake of current followed by a comparatively less steep decay.
Small humps or perturbations are noticed in the current trace, depending on when the unit resets.

The TDSUSB2 application automatically sets up the oscilloscope. The application gives a direct readout
of Charge (uC) and Capacitance (iF) values. The application displays the details of the results after
comparing the test results with the USB2.0 specifications.
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Probe Degaussing

It is mandatory to perform degauss for the current probe before carrying out inrush measurement. You can
refer to the probe manual for the degaussing procedure.
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Droop Measurement

The Droop voltage is the difference in the Vgys voltage when you apply a no load condition and a 100 mA
load to the port under test (all other ports are fully loaded).

The Droop test evaluates the worst case droop by alternately applying a droop load and no load to the port
under test while all other ports are supplying the maximum load possible. All the V pys measurements
are relative to local ground.

The TDSUSB?2 application automatically sets up the oscilloscope for the specified test configuration.
When you start the application, it acquires the signal, and provides the V proop measurement, and displays
PASS or FAIL.
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NOTE. The TDSUSB?2 application helps to report the Drop test. You can do this by enabling an option in
the File> Preferences> Advanced menu. You can enter the multimeter reading for the Drop test in the
TDSUSB?2 application during report generation for a consolidated report.

Receiver Sensitivity Measurement

34

To improve the performance of the application in a noisy environment, the USB2.0 high speed device
should respond to IN tokens with NAKs when the signaling level is at or above the specified level.

The Receiver Sensitivity test requires a high-speed data simulator, such as the Tektronix DTG5334,
DTG5274, or DTG5078; or the AWGS000 series (AWGS5002) or AWG7000 series generators, to transmit
IN tokens of varying amplitude. The test requires the unit under test to be placed in the Test SE0 NAK
mode. The host is then replaced by the data simulator to continue to transmit IN tokens. The signaling
amplitude is presented to the device under test at a level at or above 150 mV. At these levels, the unit
under test must not be in the squelched mode, responding to IN packets with NAKs. The amplitude of
the signals from data senerator varies less than 100 mV. The unit under test must be squelched and not
respond to IN tokens with NAKs.
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This tests the receiver capability of high speed units (device) to respond to the particular data pattern
generated by the USB2.0 data simulator. The unit under test responds to the data pattern level above the
squelch level (>150 mV) and should not respond when the data pattern level is below the squelch level
(<100 mV).

The TDSUSB2 application provides the procedural steps to perform this measurement. It also provides
Digital signal generator pattern files (AWGSk-HS-USB.zip and DTG _setup.zip are available for
download from www.tektronix.com). Pattern files for other Tektronix data simulators are available from
www.tektronix.com.
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Chirp Measurement

To perform a Chirp test, connect the unit under test and the single-ended probes to acquire data. You can
measure the Data for Chirp K amplitude, Chirp K duration, and Reset duration. You need to manually
verify that there are three K—J pairs in less than 500 pus.
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The TDSUSB2 application automates this process and automatically generates the results (see page 86)
and reports for the results of Chirp-K duration, Chirp-K amplitude, and Reset duration.

Monotonic Property

While performing a USB2.0 High Speed compliance test, you need to verify that the signal to be tested is
monotonic.

The following graph shows the monotonic behavior of a USB2.0 high speed signal with a rise time
of 500 ps.

- -

Monotonic Signal HonMonotonic Signal

To verify the monotonic behavior of a signal, the oscilloscope must have a sample rate high enough to
capture as many sample points as possible on a rising or falling edge. In addition, the oscilloscope should
have enough bandwidth to ensure that the high frequency non-monotonic transition is not attenuated.

The application coupled with a high performance Tektronix oscilloscope automates the process and
ensures repeatability of test results.

Configuring a Measurement

36

To access the Configure: Measurement, go to Measurements> Configure. The application also provides a
Configure option with each measurement area to allow you to configure the selected measurements.

NOTE. Ifyou select the Run button before configuring a measurement, the application displays the message
‘The selected measurements have not been configured. Do you want to continue?.’ In this case, the
application runs with the default settings. If you select the Run button before configuring the measurement
and have enabled the File> Preferences> General option, the application displays the warning message
‘Warn if configuration was not changed since last run, when the run button is pressed.’

TDSUSB?2 Universal Serial Bus Measurements Package



Operating Basics Configure Limits

See Also

B Configuring Signal Quality Measurements

B Configuring Inrush Current Measurements

® Configuring Droop Measurements

B Configuring Receiver Sensitivity Measurements

B Configuring Chirp Measurement

Configure Limits

The application displays the maximum and minimum values for the selected tests. You can use the >’ sign
on the keypad to configure limits for these options.

Option Description

Set Sets the values you enter

Default Restore the default values

Cancel Cancels all the changes you enter

NOTE. The application enables the Configure Limits values when you select the option File> Preferences>
Advanced menu.

Configuring Signal Quality Measurements

To access the Measurement: Configure, go to Measurements> Configure. Be sure to select the relevant
measurements before you configure them. There are two tabs for the Signal Quality Measurements:
Configure and Source.

The Configure tab allows you to select and set the Tier, Signal Direction and the Test Point options. You
must select the Tier (Tier 1 through 6), the direction of signal (Upstream or Downstream) and the Test
Point (Near End or Far End) at which the unit will be tested.

For Low Speed and High Speed signals, you can set Test Point to Near End or Far End. For Full Speed
signals, you can set the Test Point to Far End only.

For Monotonic Property measurement, you can configure the measurement levels.

The Source tab allows you to select the Source of the signal: a live signal or the signal from a file. For a
live signal there are two options: Differential and Single-Ended. For Low Speed and Full Speed devices,
you can test only single-ended signals (D+ and D—). For High Speed devices, it is recommended that
you use a differential probe.
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See Also

B Configure Signal Quality Measurements Parameters
B Signal Quality Configuration Options

B Signal Quality Checks

Configuring Inrush Current Measurements

To access the Measurements: Configure menu, go to the Measurements > Configure.

The Configure tab allows you to set the voltage value on V s and the unit under test. The V 1, can
be entered manually or probed from a channel that is captured from the test fixture. Select this option
from the Source tab of Inrush Configuration menu.

The Tier 1 is always used for testing. The unit under test can be any one of the following types:
®  Hot Plug Attach

B Low Powered Configure

®  Low Powered Resume

®  High Powered Configure

®  High Powered Unconfigure

®m  High Powered Resume

The Hot Plug Attach is the most common unit under test. The Source tab allows you to select the source
of the signal: a live signal or the signal taken from a tsv file. If you choose to manually enter the V gys
voltage, you cannot select the V gys voltage source.

See Also
B Configure Inrush Current Measurement Parameters
m Inrush Current Configuration Options

® Inrush Current Check

Configuring Droop Measurements

38

Select the Droop measurement and configure it. To access the Configure: Measurements menu, go to
Measurements > Configure.

The Configure tab allows you to select the Port (Port 1 through 7), Hub and Source of the signal. The
source of the signal can be live or from a .tsv file. The hubs can either be Self powered or Bus powered.
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See Also
®  View Droop Test Configure Menu
B Droop Test Configuration Options

® Droop Test

Configuring Receiver Sensitivity Measurements

To configure receiver sensitivity measurements, follow these steps:

NOTE. Receiver Sensitivity Tests setup files for AWG and DTG models (AWG5k-HS-USB.zip or
DTG setup.zip) are available for download from www.tektronix.com

1. Select the High Speed measurement tab > More button > Receiver Sensitivity measurement.

2. To access the Configure Measurements menu, select Measurements> Configure.

% File Measurements Results LUtilities Help

TDSUSE2
Configure: Receiver Sensitivity

Source

Chi bt

Select the Source from Chl to Ch4.
Select the Run button.

Select OK and follow the on-screen prompts to perform the tests.

AU

To generate reports, select Utilities > Report Generator.

See Also
B Generating Reports
B Viewing Reports
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® View Configure Receiver Sensitivity
B Selecting a Measurement

B Receiver Sensitivity Measurement

Configuring Chirp Measurement

To configure chirp measurements, follow these steps:

1. Select the High Speed measurement tab > More button > Chirp measurement.

2. To access the Configure Measurements menu, go to Measurements> Configure.

3. In the Configure tab, you can select the DUT (Host or Device) and perform selected tests associated
with it.

% File Measurements Results LUtilities Help
TDSUSE2

Measurements: Configure Chirp

Select DUT Select Test Select Source
Host - EL_z23, b+ Ch1 ¥
° EL 34

E L_S -

4. Select the Host option to display the different tests for the DUT. The available tests are:
= EL 33, EL_34: You can perform two separate measurements on an acquired waveform.

= EL _35: You can perform a single measurement on an acquired waveform.

40 TDSUSB?2 Universal Serial Bus Measurements Package



Operating Basics Configuring Resume Measurement

% File Measurements Results LUtilities Help
TOSUSE2

Measurements: Configure Chirp

Select DUT Select Test Select Source
EL_22.EL_z0 b Ch1 ¥
EL_21

Configure the Chirp

Lewvice

5. Select the Device option to display the different tests for the DUT. The available tests are:
= EL 28, EL 29: You can perform two separate measurements on an acquired waveform.

6. Select the channel source in the D+ and D— fields. Use the drop down arrow in the D+, D- field to set
the source. The available options are:Chl- Ch4 and Ref1-Ref4.

7. Select the Run button.

8. To generate reports, select Utilities > Report Generator.

See Also

®  Generating Reports

B Viewing Reports

® View Configure Chirp Test

®  Chirp Measurement

Configuring Resume Measurement

To configure Resume measurement, follow these steps:

1. Select the High Speed measurement tab > More button > Resume measurement. The device/HUB
resumes the High-Speed operation, which is indicated by the presence of High-speed SOF packets
(with 400 mV nominal amplitude) following the K state driven by the host controller. For the Host,
this is the time between the falling edge of D+ to the First SOF. This should not exceed 3.0 ms.

2. To access the Configure Measurements menu, go to Measurements > Configure.
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o
@ File Measurementsz Resultz LHilities Help

TDSUSB2
Measurements: Configure Resume

Signal Direction Select Source

U [ ) Configur
P o D+ Chl ™ hest and
Stream Stream ast an

3. Set the input Signal Direction to either Upstream or Downstream.

4. Select the channel source in the D+ and D— fields. Use the drop down arrow in the D+, D- field to set
the source. The available options are: Chl- Ch4 and Ref1-Ref4.

5. Select the Run button.

6. To generate reports, select Utilities > Report Generator.

See Also

m  Generating Reports

Configuring Suspend Measurement

To configure Suspend measurement, follow these steps:

1. Select the High Speed measurement tab > More button > Suspend measurement. This measures the
time between the end of the last SOF and the rising edge transition to the Full Speed J state. The
acceptable range is between 3 ms to 3.125 ms.

2. To access the Configure Measurements menu, go to Measurements > Configure.
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% File Measurements Results LUtilities Help
TDSUSE2

Measurements: Configure Suspend

Signal Direction Select Source -
Canfigu Ll

UFI [own O+ Chi L tast - iF .
Stream Stream 25e &l

3. Set the input Signal Direction to either Upstream or Downstream.

4. Select the channel source in the D+ and D— fields. Use the drop down arrow in the D+, D— field to set
the source. The available options are: Chl- Ch4 and Refl1-Ref4.

5. Select the Run button.

6. To generate reports, select Utilities > Report Generator.

See Also

m  Generating Reports

Configuring Reset from Suspend Measurement

To configure Reset from Suspend measurement, follow these steps:

1. Select the High Speed measurement tab > More button > Reset from Suspend measurement. This
measures the time between the falling edge of D+ signal and the start of Device chirp-K. This is
between 2.5 us and 3 ms. This test is applicable for Device and HUB upstream.

2. To access the Configure Measurements menu, go to Measurements > Configure.
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% File Measurements Results LUitilities Help
TDSUSE2

Measurements: Configure Reset From Suspend

Signal Direction Select Source -
Up Crowm D+ A
Stream Stream

3. In the Configure tab, you can set the channel Source.

4. The signal direction is always set to Upstream. This is because you can measure Reset from Suspend
only on an upstream signal. The Downstream option is disabled.

5. Select the channel source in the D+ and D fields. Use the drop down arrow in the D+, D— field to set
the source. The available options are: Chl- Ch4 and Ref1-Ref4.

6. Select the Run button.

7. To generate reports, select Utilities > Report Generator.

See Also

B Generating Reports

Configuring Packet Parameter Measurement

To configure Packet Parameter measurement, follow these steps:
1. Select the High Speed measurement tab > More button > Packet Parameter measurement.
2. To access the Configure Measurements menu, go to Measurements > Configure.

3. In the Configure tab, you can select the DUT (Host or Device) and perform selected tests associated
with it.
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% File Measurements Results Utilites Help

TDSUSB2
Measurements: Configure Packet Parameter

Select DUT Select Test Select Source

EL_Z1, EL_Z3 Configure Packe
- - Ditferential Configure Packet
EL_25 Farameter test and
Chi ™ Fress RUN.
EL_zZ

Dewice

Ready

4. Select the Host option to display the different tests for the DUT. The available tests are:

= EL 21, EL 23, EL 25: You can perform three separate measurements on a single acquired
waveform.

= EL 22: You can perform a single measurement on an acquired waveform.

= EL 55: You can perform a single measurement on an acquired waveform.

% File Measurements Results LUtilities Help

TDSUSB2
Measurements: Configure Packet Parameter

Select DUT Select Test Select Source

Canfigure Pachket

Crifferential
EL 21, EL_22 ' Farameter test and
EL_Z5 - Fress RUN.

Ch1

Device EL 22
-

Ready

5. Select the Device option to display the different tests for the DUT. The available tests are:
- EL 21,EL 22, EL 25: You can perform three separate measurements on an acquired waveform.
= EL 22: You can perform a single measurement on an acquired waveform.

6. Use the drop down arrow in the Differential field to set the channel source. The available options
are: Ch1-Ch4, Refl-Ref4.
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7. Select the Run button.

8. To generate reports, select Utilities > Report Generator.

See Also

B Generating Reports

Packet Parameter Measurement

Packet parameter measurement is for high speed Host controller and Device. There are several important
packet characteristics for upstream and downstream signaling. The measurement calculates the SYNC
field length, EOP length and inter packet gap. The acceptable range of EOP for all transmitted packets
(except SOFs) must be between 7.5 and 8.5 bits. The packet parameter algorithm calculates the EOP
depending on this range.

The acceptable range of inter packet gap is between 88 bits to 192 bits. The SYNC field for all transmitted
packets is calculated by counting the bits to check for 32-bit SYNC field. The inter packet delay and
SYNC status is calculated between the EOP indexes. The EOP width in time is calculated by dividing
the EOP width by 480 Mbps.

Suspend Measurement

46

This test calculates the time between the end of last SOF and the rising edge transition to Full-speed J state
for Host / Device / Hub- upstream. This time must be between 3mS and 3.125mS. To get the Suspend
signal, hot-plug the unit under test (device) and measure the signalling with single-ended probes on both
lines. The application analyzes data for the Suspend Time.
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Resume Measurement

This test calculates the device/HUB resume High-speed operation, indicated by High-speed SOF packets
(with 400 mV nominal amplitude) following the K state driven by the host controller. For the Host, this is
the time between the falling edge of D+ and the First SOF. This should not exceed 3.0 ms. To get the
Suspend signal, hot-plug the unit under test (device) and measure the signaling with single-ended probes
on both lines. The application analyzes data for the following:

®m  Resume Time

B Amplitude
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Reset from Suspend Measurement
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Reset from Suspend Measurement

This test calculates the time between the falling edge of D+ signal and the start of Device chirp-K for
the Device/HUB upstream. This must be between 2.5 us and 3 ms. To get the Reset from Suspend
Measurement signal, hot-plug the unit under test (device), and measure the signaling with single-ended
probes on both lines. The application analyzes data for the Reset From Suspend Time.
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Reset from High Speed Measurement

This test calculates the time between the beginning of the last SOF and before the reset and the beginning
of Chirp-K for Device and HUB upstream. This must be between 3.1 ms and 6 ms. To get the Reset from
High-Speed Measurement signal, hot-plug the unit under test (device) and measure the signaling with
single-ended probes on both lines. The application analyzes data for Reset From High Speed Time.
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Acquiring Data

The application automatically sets the oscilloscope settings for the selected measurements. To acquire data
from the oscilloscope, follow these steps:

1. Select the * command button to run the application.

2. The application displays the message ‘Please press OK when correct waveform is acquired’ for
live signals.
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50

3. [Ifyou select the Cursor Mode, the application displays the message ‘Place the Cursors at the start and
end position of the USB packet. Press OK when done.’

EgﬁPlacE Cursors |

on and end pe on of the U5B packet.

4. Ifyou select the Inrush measurement, the application displays the message in the next figure.

E‘,% Confirm Waveform

OmaA and there is high probability

0. Enzsure corectsignal is acquirzd.

5. If you select the Droop measurement, the application displays the message in the next figure.

gnal and is analyzed after triggering. Lo

appropriate nal for anahy

Enzure that Wbus and Droop tigger lead signals are connected properly and

p OF anlywhen caorrect new weform is acquined.
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6. Ifyou select the Packet Parameter measurement, the application displays the message in the next figure.

Eﬁf’i[unﬁrm Waveform x|

9 Flease press OK when correct wavefarm is acquired

7. The application automatically displays the result after acquiring the data.

8. The application automatically displays the eye diagram and the waveform plot for the acquired signals.
This is possible only if you enable this option in the Preferences > General.

NOTE. You can modify the automatic oscilloscope settings if there is no valid waveform on the oscilloscope

screen. To do so, select the command button to run the application and select OK to
complete the process.

TIP. You may need to adjust the inrush setups, as inrush currents have a wide variety of durations and peak
currents. Use the vertical division settings between 100 mA/division to 5 A/division. Adjust the timebase
appropriately to have a minimum acquisition duration of 100 ms.

Control Menu Options

Option/button Description

Run icon Runs the application

Hide button Hides the application and displays the oscilloscope application on the entire screen
Exit button Exits the application

See Also

® Control Menu

® Control Menu Parameters
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Viewing Results

52

You can view the results in a summary form or in a detailed form. To access the Results: Summary, select
Results > Summary. The application displays one of the following results.

v PASS A PASS indicates that the results of the measurements comply with the USB2.0 specifications.

a el A FAIL indicates that the measured values of the measurements are beyond the waiver limits
and do not comply with the USB2.0 specifications.

™
ﬁ A Conditional PASS indicates that the limits of the tests are within the USB2.0 waiver
limits. A conditional pass is a true pass with allowable waiver limits. These limits are not published to
developers or equipment vendors. However, usb.org encourages developers to design to meet within the
USB?2.0 specifications.

NOTE. The application displays PASS or FAIL based on the limits you set.

To access the Details: select Results > Details. Use the scroll bar to view the results that are not visible
within the display window. The report contains statistical values for the following:

m  Standard deviation (StdDev)

®  Mean

B Peak-to-peak (Pk—Pk)

®  Root mean square (RMS)

B Maximum (Max) and minimum (Min) values

®  Population (the number of cycles used to calculate the statistics). The population used for signal
rates is number of bits.

m  Status (PASS/FAIL/Conditional PASS) for the selected tests
You can also view the eye diagram and the waveform plot for signal quality check.
Eye Diagram

You can select the Eye Diagram option to view the eye diagram for the unit under test. The eye diagram
has the Zoom and Cursor features that you can use to view the results. You can also use the Reset button to
reset the default eye pattern.

The Eye Diagram menu contains the following options:

+
Zoom: You can select the zoom from the menu. Select the J icon to zoom into the area of interest.
Define the area of interest using the mouse and selecting the zoom in area. The selected area is displayed
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in the entire upper half of the oscilloscope. Select the |%| icon to zoom out. You can use the Zoom In and
Zoom Out icons until the application reaches the maximum and the minimum zoom limits.

RIE oo M ] XD _J

oo 1.0 20 an in
-+ Time (x10®-Ths

04

= O [ Gonak, v

a1 i
Tire: (102705

0 Cursors n
Cursors: You can select the Cursors and the vertical cursors

appear.
You can drag the cursors to change the positions, and read the time values on the X-axis.
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O Cursors n n

cursors to change the positions, and read the voltage values on the Y-axis.

Use the mouse to select the Horizontal cursor . You can drag the

Waveform Plot

You can select the Waveform Plot option to view the Waveform Plot for the unit under test. The Waveform
Plot has a Zoom and the Cursor feature that you can use to view the results.

The Waveform Plot has features that enable you to zoom in and out on the waveform, use Vertical and
Horizontal Cursors, Save the Plot, Reset the original plot, and select to display the signals.

To display any or all the signals for the waveform plots menu, you can use the following options:

Zoom: You can select the Zoom from the menu. Select the gl icon to zoom into the area of interest.
Define the area of interest using the mouse and selecting the zoom in area. The entire upper half of the

oscilloscope displays the selected area. Select the ‘@ icon to zoom out. You can use the Zoom In and
Zoom Out icons until the application reaches the maximum and the minimum zoom limit.
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Drag the cursors to change the positions of the cursors, and read the time values on the X-axis.

Cursor: You can select the Cursors and the vertical cursors appear.
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Viewing Results

Select the Horizontal cursors

. You can drag the horizontal cursors

to change the positions, and read the voltage values on the Y-axis.

NOTE. The Zoom and Cursor options are mutually exclusive.

Save: You can use the Save button to save the zoomed in or zoomed out diagram as a .jpg file.

Reset: You can use the Reset button to restore the waveform plot to its original display.

For waveform plots, any or all the signals can be displayed using the following buttons:

m  D+: Use this button

m  D-—: Use this button

D+

to turn on or turn off the display of the D+ signal.

to turn on or turn off the display of the D— signal.

CMD
B CMD: Use this button J to turn on or turn off the display of the Common Mode voltage.

Diff
B Diff: Use this button J to turn on or turn off the display of the Differential signal.

You can use any combination of the Zoom or Cursors, D+, D—, CMD (Common Mode Voltage) and
Diff buttons to view and save the waveform plot.

The annotations at the lower edge of the Waveform Plot classify the signal pulse into different bus states:
J, K, E (EOP), I (IDLE) and Sync ( C).

There are two Results menu options.
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Summary: The application summarizes the results of the measurements. The results are classified as
PASS, FAIL and Conditional PASS. Click on PASS, FAIL and Conditional PASS. The dialog box shows
the Measured Mean, USB2.0 Specifications.

: Monotonic Property

TOSUSBE2

BN

Feecam— oo O H

Heady

NOTE. The application displays the user column in the Results Details only if the User Configurable Limits
are selected in File > Preferences > Advanced tab.

The application disables the Results > Summary and Report generation in Plug-Fest Specific format
when you enable Configure Test Limits.

B View Result Summary

® View Result Details

Generating Reports

To access the Report Generator menu, select Utilities > Report Generator. You can generate the USB IF
report in any one of the three formats:

B Tektronix Specific is the default format used by the TDSUSB?2 application.
B Plug-Fest format is the format used by the USB-IF.

B CSV format report is a user-defined report generated in a comma separated variable format.
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You can generate reports in one of the following modes:

Manual: Select the report format, the directory name, and the file to which the report is saved. Select
the Generate option to generate the report. Specify the file name for the report.

Automatic: The application generates reports automatically without user intervention as soon as

the results are calculated. Select Generate Automatic Ids to enable this option while selecting
measurements. The application uses the prefix that you enter to generate the file. If you select the Ask
for the Filename/Device ID before automatically generating Reports/Data files check box in the File >
Preferences > General tab, you can enter the Device ID/File Name before generating the report. If the
File already exists, the application displays a message box to confirm whether to overwrite the existing
report. If you select Yes, the application overwrites the report; if you select NO, you can enter a new
Device ID/File Name or cancel the report generation. The reports are generated in the following path:

C:\TekAppTlications\tdsusb2\report. The file name is prefix 001 reportformat.csv or
prefix_001_reportformat.htm.

The report contains the device ID, device description, date and result of the test. The report also contains
the following statistical values:

Maximum (Max) and Minimum (Min) values

Mean

Peak-to-peak (Pk—Pk)

Standard deviation (StdDev)

Root mean square (RMS)

Population

Status (PASS/FAIL/Conditional PASS) for the selected tests

User- The application displays this value if you select the "Allow user configuration of test limits" in
the Preferences menu and set the test limits before running the measurement.

The report includes the eye diagram and the waveform plots for the Signal Quality Check. The display on
the oscilloscope screen is embedded in the Droop report.

NOTE. Automatic Report generation is not available if you select the Drop Test readout option in File >
Preferences > Advanced tab.

See Also

® Report Generator Menu Parameters

B Report Generation Options

B View Signal Quality Check Report in Tektronix Specific Format
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® Viewing Reports

B Generating Reports

Viewing Reports

You can use an HTML viewer or a browser to view the Tektronix specific and Plug-Fest format reports.
You can view the .csv (Comma Separated Variable) report in a text editor, spreadsheet, database, or a data
analysis program for further analysis. You can edit the .csv file to suit your needs.

NOTE. All the reports contain the eye diagram and the waveform plot except for the reports generated
in the .csv file format.

See Also

B Report Generator Menu Parameters

m Report Generation Options

B View Signal Quality Check Report in Tektronix Specific Format
B Viewing Reports

m  Generating Reports

TSV File Generator

You can use the TSV File Generator Utility to convert a .csv (Comma Separated Variable) file to a .tsv
(Tab Separated Variable) file. To access TSV File Generator, go to the main menu and select Utilities
> TSV File Generator.

If the Input is a .csv file, then the application enables the CSV Waveform Source area. You can select the
sources based on the Signal type. For a single-ended signal, specify the D+ and D— inputs.

You can specify the directory C:\TekApplications\tdsusb2\tsvfilegenerator for the differential signal from
where the .csv file is taken.

If the Input is a Live signal, you cannot access the CSV Waveform Source area. Select the Live

or Ref as the source file to enable the Live Input option. You can enable the Convert option only

if you take the measurements and display the results. The default directory for the .tsv files is
C:\TekApplications\tdsusb2\tsvfiles. You can also specify the location where the tsv file is to be generated.
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TSV file format description

For Low Speed and Full Speed Signal Quality Check, the input TSV file is an m x 3 matrix with m
rows and three columns. The file has Time values and Voltage values for D+ and D- in the first, second
and third columns respectively.

The input TSV file for High Speed Signal Quality Check is a m x 2 matrix with m rows and two columns.
The file has Time and Voltage values for Differential signals in the first and second columns.

The input TSV files for Inrush and Droop tests are an m x 2 matrix with m rows and 2 columns. For Inrush
tests, the file has Time and Current values in the first and second columns. For Droop test, the file has
Time and Voltage values in the first and second columns.

CSV file format description

Low Speed and Full Speed single-ended signals for Signal Quality Check require two .csv files to generate
the corresponding TSV file. The .csv files have two columns. One .csv file has time and voltage values
for D+ signals, while the second column has the time and the current values for D— signals. Both files
must have the same time values.

Differential signals require one .csv file with two columns, one column for time and another for voltage
values.

If you select Differential for Inrush and Droop signals, the .csv file has two columns: one column for time
values, and another for current and voltage values. You require only one .csv file for Inrush and Droop
tests. This .csv file has two columns: one column for the Time Values and the other for Current (Inrush)
and Voltage (Droop) values. You must use the Differential option for conversion.

B View the TSV file generator

How to Save and Recall a Setup

You can use the Save and Recall menus to save and recall the various configuration setups. To access the
Save and Recall menus, go to the File menu in the menu bar and choose Save or Recall.

NOTE. Do not edit the .ini or the .set files, or the recall setup files generated by the application. This can
cause instability to the application. If you try to edit the.ini of the .set files, you get an error message ‘The
saved file has been corrupted and cannot be recalled.’

See Also
= Saving a Setup

B Recalling a Saved Setup
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m Recalling the Default Setup

® How to Save and Recall a Setup

Saving a Setup

You can save various configuration setups and recall them when needed. To save the application settings to
a setup file, follow these steps:

1.

0 » b

Select File > Save.
Select the Save button.
Browse or enter a file name. The application appends a .ini extension to the name of setup files.

Choose Save to save the setup or Cancel to cancel the action.

NOTE. The application saves the oscilloscope setup to a .set file. The application .ini files and the
oscilloscope .set files have the same file name.

See Also

B Recalling Recently Recalled Setups

B Recalling a Saved Setup

B Recalling the Default Setup

B Recalling Recently Saved Setups

Recalling a Saved Setup

To recall the application settings from a saved setup file, follow these steps:

1.
2.

Select File > Recall.

Browse the directory C:\TekApplications\tdsusb2\setup to recall the .ini files or select the directory
where you have saved the setup file.

Select or enter a .ini file name.

Choose Open to recall the setup or Cancel to cancel the operation.

NOTE. The application recalls the oscilloscope setup from a .set file.

60
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See Also

m Recalling Recently Recalled Setups
B Recalling a Saved Setup

m Recalling the Default Setup

m Recalling Recently Saved Setups

m How to Save and Recall a Setup

Recalling the Default Setup

To recall the application settings from the Default setup file, select File > Recall Default. The application
recalls the default setup and displays the message ‘Default setup recalled successfully.’

Eéf-_,% Meszage

e Default setup recallad =

See Also

® Recalling Recently Recalled Setups
® Recalling a Saved Setup

B Recalling the Default Setup

m Recalling Recently Saved Setups

® How to Save and Recall a Setup

Recently Saved Setup

The application stores the last four saved setups. If you need to modify any of them, follow these steps:
1. Select File > Recently Saved.

2. Select the setup from the list of recently saved setups that are displayed.

NOTE. When you select a file from the list of recently saved files menu, the file becomes the first element
in the list of selections.

TDSUSB?2 Universal Serial Bus Measurements Package 61



Operating Basics

See Also

Recalling Recently Recalled Setups
Recalling a Saved Setup

Recalling the Default Setup
Recalling Recently Saved Setups

How to Save and Recall a Setup

Recently Recalled Setup

62

Recently Recalled Setup

The application stores the last four recalled setups. If you need to recall any of them, follow these steps:

1.

Select File > Recently Recalled.

2. Select the setup from the list of setups displayed.

NOTE. When you select a file from the list of recently saved files popup menu, the file becomes the first
element in the list of selections.

See Also

Recalling Recently Recalled Setups
Recalling a Saved Setup

Recalling the Default Setup
Recalling Recently Saved Setups

How to Save and Recall a Setup

TDSUSB?2 Universal Serial Bus Measurements Package



Tutorial Introduction to the Tutorial

Introduction to the Tutorial

The tutorial teaches you how to set up the application by recalling a .tsv file, take measurements, and
view the results. More operating information is available in the Operating Basics section. Before you
begin the tutorial, you must do the following tasks:

®  Starting the Application

B Recalling a tsv File

Starting the Application

To start the application, select File > Run Application > USB2.0 Test Package or App > USB2.0 Test
Package or Analyze > USB2.0 Test Package.

Recalling a .tsv File

The application distribution includes the .tsv files used with this tutorial. The table below shows the
types of signals that represent these waveforms.

Tsv File name Signal type
C:\TekApplications\tdsusb2\tsv- Low Speed
files\LS_SQC.tsv

C:\TekAppTications\tdsusbh2\tsv- Full Speed
files\FS_sQC. tsv

C:\TekAppTications\tdsusbh2\tsv- High speed
files\HS_sqc.tsv

C:\TekApplications\tdsusb2\tsvfiles\in- Low/Full/High Speed
rush.tsv

Taking a Full Speed Signal Quality Measurement

This section discusses how to take a Full Speed Signal Quality measurement, view the results, and generate
a report. To perform these tasks, the application must be installed and enabled on a supported oscilloscope.
View Installing the application (see page 12) to install the application.

To take a Full Speed Signal Quality measurement, follow these steps:

1. To set the application to default values, select File > Recall Default. The application displays the
message ‘Default setup recalled successfully.” Select OK to view a screen image showing the default
settings.
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Taking a Low Speed Inrush Current Measurement

2. Select all the Signal Quality measurements in the Signal Quality Check area using Select All button.

3. Select the Configure tab or select Measurements > Configure. The Measurements: Configure default
settings display.

4. Select the Measurements: Source . If the source is Live or Ref, configure the appropriate channels for
D+, D— and Qualifier. You have to always select D+ first. If you select any one of the Live channels
CH1-CH4 for D+ source, the remaining Live channels are selected from the D— and the Qualifier
channel source. If you select any one of the Ref channels Ref1-Ref4 for D+ source, the remaining Ref
channels are selected from the D— . There is no Qualifier channel source for the Ref signals.

If the source is from a file, use the browse button to look for the file.

1. Select the file C:\TekAppTications\tdsusb2\tsvfiles\FS_SQC.tsv.

2. Select the x command button to run the application. The application displays the Eye Diagram
(see page 181) and the Waveform Plot.

3. Minimize the eye diagram and waveform plot to view the summary results.

\JPASS

4. The application displays the Results Summary as PASS . You can also select the result to

view the details of the selected test.

5. To view the Results Details (see page 52), select Results > Details in the application menu bar or PASS
command button in the Overall Result area to view the details of each measurement.

6. Select Utilities > Report Generator in the application menu bar to generate the Report.

7. You can view the default screen with the Tektronix Specific Format enabled. The report directory
appears with a default file name. You can change the file name if you want. Click on the Generate
button.

8. Click the Generate button. The application generates an HTML file in C:\TekApp1ications\td-
susb2\report. To view this report, open it in an HTML viewer or a browser.

Taking a Low Speed Inrush Current Measurement
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This section discusses how to take a Low Speed Inrush Current Measurement, view the results, and
generate a report. To perform these tasks, the application must be installed and enabled on a supported
oscilloscope.

1. To set the application to default values, select File > Recall default. The application displays the
message ‘Default setup recalled successfully.’

Select Measurements > Low Speed tab.

Select Inrush Current measurement .

Select Measurements > Configure tab and use the default settings set by the application.

RAEE S

Select the Source tab. Select From File.
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10.
11.
12.
13.

Taking a High Speed Signal Quality Measurement

Select file C:\TekAppTlications\tdsusb2\tsvfiles\LS_inrush.tsv.

Select the x command button to run the application.
The application displays the Results Summary as Conditional PASS.
You can also select the result to view the details of the selected tests .

Select Results > Details from the application menu bar to view Results Details (see page 129).

Select Utilities > Report Generator in the application menu bar to generate a report.
Select the CSV Specific Report and use the default file name. Select the Generate button.

The application displays the sample report file (see page 134) in a browser.

Taking a High Speed Signal Quality Measurement

This section discusses how to take a High Speed Signal Quality measurement, view the results, and
generate the report. To perform these tasks, the application must be installed and enabled on a supported
oscilloscope.

To take a High Speed Signal Quality measurement, follow these steps:

1.

9.

10.
11.

To set the application to default values, select File > Recall Default. The application displays the
message ‘Default setup recalled successfully.’

Select Measurements > High Speed and select all the Signal Quality measurements in the Signal
Quality Check area using Select All button.

Select the Configure option or go to Measurements > Configure.

Select the Source tab > From File > Browse and locate the file.

Select the file C:\TekAppTications\tdsusb2\tsvfiles\HS_sqc.tsv.

Select the - #  command button to run the application. The application automatically displays the
Eye Diagram (see page 131) and the Waveform Plot.

Minimize the eye diagram and the waveform plot button to view the summary results.

Select Results > Details in the application menu bar to view the Results Details. Click the Additional
Information button to display the additional information.

Select Utilities > Generate Report to generate the report.
Select the Report format as Plug-Fest Specific and use the default file name. Select Generate.

The application displays the sample report file (see page 125) in a browser.
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Taking a Low Speed Signal Quality Measurement

Taking a Low Speed Signal Quality Measurement

This section discusses how to take a Low Speed Signal Quality measurement, view the results, and
generate a report. To perform these tasks, the application must be installed and enabled on a supported
oscilloscope. View Installing the application (see page 12) to install the application.

To take a Low Speed Signal Quality measurement, follow these steps:

1.

To set the application to default values, select File > Recall Default. The application displays the
message ‘Default setup recalled successfully.” Select OK to view a screen image showing the default
settings.

Select the Low Speed tab and select the Signal Quality measurements in the Signal Quality Check
area using Select All button.

Select the Configure tab or select Measurements > Configure. The Measurements: Configure default
settings display.

Select the Measurements: Source. If the source is Live or Ref, configure the appropriate channels for
D+, D—and Qualifier. You have to always select D+ first. If you select any one of the Live channels
CH1-CH4 for D+ source, the remaining Live channels are selected from the D— and the Qualifier
channel source. If you select any one of the Ref channels Refl-Ref4 for D+ source, the remaining Ref
channels are selected from the D— . There is no Qualifier channel source for the Ref signals.

If the source is from the file, use the browse button to browse the file.

1.
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Select the file C:\TekApplications\tdsusb2\tsvfiles\LS_SQC.tsv.

Select the - # | command button to run the application. The application displays the Eye Diagram
(see page 131) and the Waveform Plot (see page 130).

Minimize the eye diagram and waveform plot to view the summary results.

\JPAsS

The application displays the Results Summary as PASS . You can also select the result to

view the details of the selected test.

To view the Results Details (see page 130), select Results > Details in the application menu bar or
PASS command button in the Overall Result area to view the details of each measurements.

Select Utilities > Report Generator in the application menu bar to generate the Report.

You can view the default screen with the Tektronix Specific Format enabled. The report directory
appears with a default file name. You can change the file name if you want. Click the Generate button.

Click the generate button. The application generates an HTML file in C:\TekAppTications\td-
sush2\report. To view this report (see page 129), open it in an HTML viewer or a browser.
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About Application Examples

This section presents the application examples. The simplified examples highlight the application
measurements and show how to use the application to solve your test problems.

To use these examples, you must have the TDSUSB?2 application installed and enabled on the oscilloscope.
Connect the probes to your unit under test (UUT), and perform the configuration tasks.

See Also

Starting the Application

Installing the Application

Specifying the EquipmentFull Speed Signal Quality Tests for Upstream Testing

Selecting and Configuring Measurements-Droop Tests

Selecting and Configuring Measurements-Full Speed Signal Quality Tests for Upstream Testing
Selecting and Configuring Measurements-Inrush Current Test

Selecting and Configuring Measurements-Inrush Current Test

Selecting and Configuring Measurements-Signal Quality Tests for High Speed Devices for Upstream

Testing

Specifying the Equipment-Full Speed Signal Quality Downstream Tests

The following equipment is needed for downstream signal quality check on a Full Speed device testing:

Tektronix digital oscilloscope

TDSUSB?2 application

TDSUSBF compliance test fixture (Revision B)

Three of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Full Speed Signal Quality Downstream Tests

To set up the equipment for Full Speed Signal Quality Downstream test, follow these steps:

1.
2.

Set the S6 switch to the Init position.

Use the adapters to connect the A receptacle from Device SQ test section (marked DUT) of the
test fixture to the USB2.0 Low Speed device.

Connect Chl of the D+ probe to the D+ pins on the Device SQ section of the test fixture.
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Selecting and Configuring Measurements-Full Speed Signal Quality Tests

4. Connect Ch2 of the D— probe to the D— pins on the Device SQ section of the test fixture.

5. Connect the Init port of the Device SQ section of the test fixture to any port of the unit under test
(hub) using USB cable.

6. Select the measurement and select the * command button to run the application.

7. Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. Make sure the acquired signal is a valid waveform.
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Selecting and Configuring Measurements-Full Speed Signal Quality

Tests

Follow the steps to select measurements for Full Speed Signal Quality check:

1. From the application menu, select Measurement > Select > Full Speed tab.

68
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2. Select the following signal quality checks:
= Eye Diagram Test
= Signal Rate
= Paired JK Jitter
= Paired KJ Jitter
= Consecutive Jitter
= EOP Width
= Cross-Over Voltage
- Rising Edge Rate
= Falling Edge Rate

3. Select the Select All toggle button to select all the measurements simultaneously. Click on any
measurement button to deselect it.

Configuring the Measurement
Follow the steps to configure the selected measurements :
1. From the application menu, select Measurement > Configure > Configure.

2. Configure the following options:

Option Set to

Tier Tier6

Direction Downstream

Test Point Set the test point to Far End

3. Select the Source tab.
4. Configure the following options:

Option Set to
Live/Ref Single-ended

5. If you select Single-ended, you must select two channels for D+ and D—.

6. Select A to acquire the data.

7. The application automatically displays the eye diagram and waveform plot of the signal acquired
from the unit under test.
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Viewing Results-Full Speed Signal Quality Tests

To view the results of the tests, follow these steps:

1. From the application menu, select Results > Summary.

File Measurements BEesults Ltilities Help
TDSUSB2

Results: Summany Signal Quality Check
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Eye Diagram Test | _ EOP Wicth m Diagram
: : i P Fress the Result Status
Signal Rate m Crossover Voltage m Butt oteflls

that test.

Paired JK Jitter m Additional
_ infarmation
Paired K.J Jitter m Overall Result
Consecutive Jitter m m
! : Reachy

\JPASS

2. Click on any of the test result buttons to get the details of that test.

3. From the application menu, select Results > Details.

File Measurements Eesults tilities Help
- TDSUSB2?
Results: Details Signal Quality Check

e asure ment Min EY: hlean =3 Eve
Ciagram

Scroll the table to see
the result details.

'I.I'I.l'axrefl:-rm
F'I-:-t

Additional
Infarmation
Overall Result
Exit

(-1  J/PAss

4. Click the Eye Diagram (see page 131) option in Results Summary or the Details to view the Eye
Diagram.

5. Click the Waveform Plot (see page 130) option to view the annotated waveform plot.
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Generating Reports-Full Speed Signal Quality Tests

To generate reports of the test results, follow these steps:

1.
2.
3.
4.

From the application menu, select Utilities > Report Generator.
Select any one of the Report Formats: Tektronix Specific, Plug-Fest Specific or CSV format.
Select the manual generation mode.

Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Low Speed Droop Tests

The following equipment is needed to perform a Droop Test for Low Speed device:

Tektronix digital oscilloscope

TDSUSB2 application

TDSUSBF compliance test fixture (Revision B)

Two of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Low Speed Droop Tests

To set up the equipment for Droop test, follow these steps:

1.

Use the Droop and Adjacent Trigger section for the Droop test. Use standard USB cable to connect the
loads on the test fixture to the ports of the unit under test as shown in the next figure.

The setup requires two channels of the oscilloscope: one for the Droop Load Trigger Timer that is
on the Droop test load section, and the other for Vyys that is on the Adjacent Trigger and Droop Test
section of the test fixture. Use the load switch to select appropriate loads for Droop Test.

In the Droop and Adjacent Trigger section on the test fixture, probe Chl from the VBUS and ground
the pins.

In the Droop Test Load section on the test fixture, probe Ch2 from the oscillator (marked OSC)
and ground the pins.

Connect the Droop Trigger Test Load to the Portl of the unit under test (hub).

Connect the Loadl to Port2 of the hub under test.
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72

7. Connect the Load?2 to the A receptacle of the Droop and Adjacent Trigger section on the test fixture.
Connect the A pin dongle from the Droop and Adjacent Trigger section to the Port4 of the unit under
test (hub). Port4 is the port under test of the hub.

8. Connect the Load3 to Port3 of the unit under test (hub). Now all the ports of the unit under test
are connected (hub).

9. Select the measurement and select the w command button to run the application.
10. Select OK when the valid waveform is acquired.

11. Observe the droop in the VBUS when Droop test load is applied.

NOTE. The application automatically sets up the oscilloscope to acquire the Droop signal. If you do not
get a valid signal, set up the oscilloscope accordingly.

NOTE. Use the Load Switch to select 500 mA test loads for Droop testing of a self powered hub and
system. Use the Load Switch to select 100 mA test loads for Droop testing of bus powered hub and system.
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Selecting and Configuring Measurements-Droop Tests

From the application menu, select Measurement > Select > Droop Test.

Configuring the Measurement
Follow the steps to configure the selected measurement:
1. From the application menu, select Measurement > Configure.

2. Configure the following options:
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Viewing Results-Droop Tests

Option Set to

Port Port under test
Source Downstream
VBUS Ch1

Trigger Ch2

Device type Self-powered
3. Select b to acquire the data.

4. After acquiring the data, the application displays the eye diagram and the waveform plot automatically.

Viewing Results-Droop Tests

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, select Results > Summary (see page 183).

RANEE S

Generating Reports-Droop Tests

Click on any of the test result buttons to get the details of that test.

From the application menu, select Results > Details. (see page 183)

Click the Eye Diagram option in Results Summary or Results Details to view the Eye Diagram.

Click the Waveform Plot to view the annotated waveform plot.

To generate reports of the test results, follow these steps:

1. From the application menu, select Utilities > Report Generator.

Select any one of the Report Formats: Tektronix Specific, Plug-Fest Specific or CSV format.

2
3. Select Manual option to generate the report.
4

Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft

Excel.
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Specifying the Equipment-Full Speed Signal Quality Tests for Upstream

Testing

The following equipment is needed for upstream signal quality check on a low or full speed device:

Tektronix digital oscilloscope

TDSUSB2 application

TDSUSBF compliance test fixture (Revision B)

Three of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Full Speed Signal Quality Tests for Upstream

Testing

To set up the equipment for Full Speed Signal Quality test for Upstream, follow these steps:

1.

&

Use the A receptacle to connect the USB unit under test (device) to the Inrush Droop section of
the test fixture.

Connect the Qualifier device to the Adjacent Trigger and Droop section of the test fixture as shown in
the next figure.

Connect Chl of the D+ probe to the D+ pins on the Inrush Droop section of the test fixture.
Connect Ch2 of the D— probe to the D— pins on the Inrush Droop section of the test fixture.

Connect the D+ (D- for Low speed) pin of the Adjacent Trigger and Droop Section of the test fixture
to Ch3 as shown in the next figure.

Use the connectors to connect the A pin dongle from the Adjacent Trigger and Droop section of the
test fixture to one port of the Hub 5. Use the A pin dongle from the Inrush Droop section of the test
fixture to another port of the Hub 5.

Select the measurement and select the * command button to run the application.

Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. Use the standard USB cables to connect between the hubs. Keep the Discharge switch in the
Inrush Droop section in the ON position.
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Configuring Measurements-Full Speed Signal Quality Tests for Upstream Testing

Unit Qualifier  Tektronix Oscilloscope

Microsoft Windows 2000 PC Under Test Device  with Application running
| | | | T
OHCI Port ‘ A 4
= |- | ] @
Test Mode @ @ @
Software
& N

Single-Ended
Voltage Probes

Test Fixture

Selecting and Configuring Measurements-Full Speed Signal Quality
Tests for Upstream Testing

Follow the steps to select measurements for Full Speed Signal Quality check:

1. Select Measurements > Select > Full Speed tab.
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Configuring Measurements-Full Speed Signal Quality Tests for Upstream Testing

2. Select Signal Quality tests:
= Eye Diagram Test
= Signal Rate
= Paired JK Jitter
= Paired KJ Jitter
= Consecutive Jitter
= EOP Width
= Cross-Over Voltage
- Rising Edge Rate
= Falling Edge Rate

3. Select the Select All toggle button to select all the measurements simultaneously. Click any
measurement button to deselect it.

Configuring the Measurement
Follow the steps to configure the selected measurement:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Tier Tier6
Direction Upstream
Test Point Far End

3. Select the Source tab.

4. Configure the following options:

Option Set to
Live/Ref Single-ended Ch1, Ch2
Qualify Channel Ch3

5. Select * to acquire the data.

6. The application automatically displays the Eye Diagram (see page 127) and the Waveform Plot (see
page 128) of the signal acquired from the unit under test.
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Viewing Results-Full Speed Signal Quality Tests for Upstream Testing

To view the results of the tests, follow these steps:

1.

2
3.
4

Run the application and from the application menu, select Results > Summary.
Click any of the test result buttons to get the details of that test.
From the application menu, select Results > Details.

Click the Eye Diagram (see page 131) option in Results Summary or Results Details to view the Eye
Diagram.

Click the Waveform Plot to view the annotated waveform plot.

Generating Reports-Full Speed Signal Quality Tests for Upstream

Testing

To generate reports of the test results, follow these steps:

1.

2
3.
4

From the application menu, select Utilities > Report Generator.
Select any one of the Report Formats: Tektronix, Plug-Fest Specific or CSV format.
Select the Manual option to generate the report.

Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Full Speed Inrush Current Test

The following equipment is needed for Inrush Current Check on a Full Speed Device:

78

Tektronix digital oscilloscope

TDSUSB2 application
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TDSUSBF compliance test fixture (Revision B)
One TCP202 or TCP0030 current probe

Typical Equipment Setup-Inrush Current Test

To set up the equipment for Inrush test, follow these steps:

1.
2.

Use the dongle on the Inrush section of the test fixture to connect it to the host system.

Connect the current probe between the V gys loop wire on the Inrush section on the Test fixture
and Chl of the oscilloscope.

Configure the measurement and select the * command button to run the application.

Connect the unit under test to the A Receptacle of the Inrush section of the test fixture and observe the
Inrush current signal.

Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. To avoid the triggering of Inrush signals and false inrush current by the discharge switch, place
the inrush discharge switch in the ON position and hot-plug the unit under test (device). In case a valid
Inrush signal is not acquired, use the cursor mode in File > Preferences or set up the oscilloscope to
get a valid waveform.
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Tektronix Oscilloscope
Device Under Test with Application running

—

Microsoft Windows 2000 PC @POOO

OHC| Current Prebe

1 | Fort
Host Software % VBUS Loop Wire
] ] b
ol
Bz i
o2 % §
é Test Fixture

Selecting and Configuring Measurements-Inrush Current Test
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From the application menu, select Measurement > Select > Inrush Current.

Configuring the Measurement
Follow the steps to configure the selected measurement:

1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to

Tier Tier is always set to 1

VBUS Enter voltage measured across VBUS manually
Device Type Hot Plug Attach

3. Select the Source tab.
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4. Configure the following options:

Option Set to
Live/Ref Channel acquiring the signal

5. Select Run.

Viewing Results-Inrush Current Test

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary.
Click any of the test result buttons to get the details of that test.

From the application menu, select Results > Details.

Click the Eye Diagram option in Results Summary or Results Details to view the Eye Diagram.

S

Click the Waveform Plot to view the annotated waveform plot.

Generating Reports-Inrush Current Test

To generate reports of the test results, follow these steps:
1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats — Tektronix Specific, Plug-Fest Specific or CSV format (see
page 82).

3. Select the manual report generation mode.

4. Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.
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View Inrush Measurements Report in CSV format

View Inrush Measurements Report in CSV format

82

A B C

—

O~ 0y M e L b | —

13

Device ID hs_001

D

Inrush Report
USBZ.0 Test Package'ersion 3.5.0 Build 1

Device DecHigh Spee Durmnmy Device
Tirme Starr Tue Jul 07 00:20:50 POT 2009

Measurern Unit Charge

Inrush Tes - 26. 237460 5. 0946530 < 51 50000 Pass

Inrugh Regions

Region | Start End
12.0000us 252.00us
2/292.00us |393.00us
345820005 |898.00us
4/1.0010rms | 1.3140ms
51.4020rms | 1.6070ms
§1.8340rms 1.9350ms
711.9730ms | 2.1530ms

M 4 » [\ hs_001-inrush /

I

Capacitant USE Lirnit: Status

Charge

330.66nC
30.060nC
711.1BnG
£30.80nC
410,560
30.060nC
210.42ni
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High Speed Report in Tektronix Format

£ Report Preview

Signal Quality Test Results in Tek format

Device ID: hs_001
Device Description: High Speed, Mear End Device, Up Stream Testing, Tier 1, Dummy Device,
Date: FriJul 02 22:47:13 POT 1999

Overall Result: Pass™
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View Procedural Steps from the Application

Filz  Measuremants Besulis  Ltilities Help
Recemser Sensitnaty Analysis
Positive Hegative

Squelch * Receiver Level 8 000my 45000

— squeich Level 5 0000 54 000 m W m .

Fozitive

EL_1& Respanding kot Responding m m -
’— ) Exit
I Orwwerall Resul PASS

Procedune

Feaihy

Select the View Procedure button to view the procedural steps. Click the Overall Result to display the
figure below
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wer Sen

[IFRERRE onnecting Tes o= [ Gefing Data Simutzior [Pre-Operation | Operation

s to Tthe T t Fixture
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o
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View Waveform Plot for Signal Quality Check High Speed Devices
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View Chirp Measurement Results
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Results: Summary Chirp Test
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Crnrerall Result
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Equipment-Signal Quality Tests for High Speed Devices for Upstream Testing

Eﬁf’ahdditiunal Information

mplitude

Specifying the Equipment-Signal Quality Tests for High Speed Devices
for Upstream Testing

The following equipment is needed for signal quality tests on a High Speed device for upstream testing :

-

Tektronix digital oscilloscope

TDSUSB2 application

TDSUSBF compliance test fixture (Revision B)
One P6248 1 or P6330 differential probe

For best results, use 1X attenuation when using the P6248.

Typical Equipment Setup-Signal Quality Tests for High Speed Devices
for Upstream Testing

To set up the equipment for the High Speed Signal Quality test, follow these steps:

1.
2.
3.

4
5.
6.
7

Set the S6 switch to the Init position.

Connect the standard USB cable between the Device SQ Init port and the host port.

Connect the USB cable from the A receptacle (marked DUT) of the Device SQ test port of the test
fixture to the unit under test (device).

Configure the measurement and select the * command button to run the application.

Place the device in the test mode Test Packet from the host controller.

Set the test Init switch to the test position to isolate the unit under test while maintaining the bus power.

Select OK after acquiring a waveform. Verify that it is a correct waveform.

If the signal is clipped, follow these steps to increase the vertical scale:

1.
2.

In the oscilloscope menu, select Vertical >Vertical Setup to display the Channel screen.

In the Scale field, increase the vertical scale values until the waveform is completely displayed in
the screen.
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Tekironix oscillozcope
with Application running

Microsoft Windows 2000 PC
. QHCI
o .
| W
— Ar 5
software |
o | USBIOSIO0
\ B0 Differential probe
AT
d=on  [m) w1
B )
T ..H‘I I::‘I. g
. H

mne | Test ficture

!

Device Under Test

Selecting and Configuring Measurements-Signal Quality Tests for High
Speed Devices for Upstream Testing

Follow the steps to select measurements for High Speed Signal Quality check:
1. From the application menu, select Measurement > Select > High speed (tab).
2. Select the tests:

= Eye Diagram Test

= Signal Rate

= EOP Width

= Rising Edge Rate

= Falling Edge Rate

= Monotonic Property

3. Select the Select All toggle button to select all the measurements simultaneously. Click on any
measurement button to deselect it.
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Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to

Tier Tier1

Direction Upstream

Test Point Set the test point to Near End

3. Configure the following options in the Source field:

Option Set to
Live/Ref Differential

4. Select x to acquire the data.

5. The application automatically displays the Eye Diagram and Waveform Plot of the signal acquired
from the unit under test. This is possible if you enable the automatic display of the eye diagram
and the waveform plot in the Preferences menu.

Viewing Results-Signal Quality Tests for High Speed Devices for
Upstream Testing

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, select Results > Summary.

% File Measurements Results LUtilities Help
TDSUSB2

Results: Summary iy Quality Check

Eye
Eye Diagram Test Rising Edge Rate
Signal Rate Falling Edge Rate

Monotonic Property Additional
_ information
EQP Width

EOP Width (Bits)

2. Click any one of the test result buttons to get the details of that test.
3. Click the Additional Information button to display the additional information.

4. From the application menu, select Results > Details.
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% File Measurements Results  Utilities Help

. TDSUSB2
Results: Details Signal Quality Check

Measurement li l 3z Mean Std. Drew. Eye
! Ciagram
Wiaveform Scroll the table to see
the result details.

Additional

Infarmation
Overall Result .
Exit

Ready

Kl ]

5. Click on the Eye Diagram in Results Summary or the Results Details to view the eye diagram.

6. Click on the Waveform Plot (see page 86) to view the waveform plot.

Generating Reports-Signal Quality Tests for High Speed Devices for
Upstream Testing

To generate reports of the test results, follow these steps:
1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific (see page 83), Plug-Fest Specific or CSV
format.

3. Select the manual generation mode.

4. Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Packet Parameter Measurement

The following equipment is needed for a Packet Parameter measurement:
m  Tektronix digital oscilloscope
m  TDSUSB?2 application

B TDSUSBF compliance test fixture (Revision B)
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= One P62481 or P6330 differential probe

B  Host Controller (Host controller card with the test mode software on a Microsoft Windows PC)

1 For best results, use 1X attenuation when using the P6248.

See typical equipment setup (see page 203) for the Packet Parameter measurement.

Selecting and Configuring Measurement-Packet Parameter
Measurement

Follow these steps to select measurements for Packet Parameter measurement:
1. From the application menu, select Measurement > Select > High speed tab.
2. Select the More button to display the following tests:

Receiver Sensitivity

= Suspend

= Reset from High Speed
= Packet Parameter

= Chirp

= Resume

= Reset Suspend

3. Select Packet Parameter measurement.

Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Select DUT Host, Device

3. Configure the following options:
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Viewing Results-Packet Parameter Measurement

Option Set to

Host EL_21, EL_23, EL_25
EL_22
EL_55

Device EL_21, EL_22, EL_25
EL_22

Source Ch1-Ch4, Ref1-Ref4

4. Select * to acquire the data.

Viewing Results-Packet Parameter Measurement

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, select Results > Summary.

& File Measurements Results Utllities Help

Hesults: Sumimany

Inter-Packet Gap v PASS

Packet Parameter

2. Click any of the test result buttons to get the details of that test.
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% File Measurements Results Uilities Help
TOsUsE2

Results: Summany Facket Farameter

Ewe
Inter-Packet Gap m Diagram

Fre: tatus
r details of
that tes=t.

Ready

3. From the application menu, select Results > Details.

Generating Reports-Packet Parameter Measurement

Generating Reports-Packet Parameter Measurement
To generate reports of the test results, follow these steps:
1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific, or CSV format.
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Tektronix Specific

i Report Preview

Packet Parameter Test Results in Tek format
Device ID: hs_001
Device Description: High Speed |, Host |, Host PR EL_22 Testing , Dummy Device.
Date:fMon Jul 20 14:52:35 IST 2009

Packet Parameter Test Result: Pass

Measurement Name Measurement USB Limits(bits)
. Status
Value(bits)
Inter-Facket Gap 107 B8 and 192 Pass
Tektronix

Fage Frint &
Setup P review osE
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CSV

@ File Edit Wiew Insert Format Tools Data  Window  Help  Adobe PDF - 7 X
& > arial -0 - B JT U E=E=EEE -b-A- 7
(3 T 4 " g2 .

arEfps i & snaalt |2 window - .

=17 - o
A B c 0] E =

1 Facket Parameter Report =
2 |USB2.0 Test Packageersion 3.5.0 Build 2

3 Device ID h= 0025

4 |Device Description High Speed  |Dummy Device
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10 =
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3.

Plug-Fest Specific

4 Report Preview

Packet Parameter Test Results for hs_001

Renuired Tests

# Packet Pararneter Result: Pass

TOSUEE 2 software versfon: 35,0 Build 2

Fage Frint
) Close
Setup P renvi &t

For detailzs on test setup, methodology, and performance criteria, please cansult the power consumption
reqguirements test description atthe witp:sann usb org/developersicompliances LUSB-IF Compliance Program web page.

# Inter-Packet Gap in bits: 107 and USE Lirnits: 83 and 192

Specifying the Equipment-Resume Measurement

Select the manual generation mode.

4. Seclect the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Resume Measurement

96

The following equipment is needed for the Resume measurement:

Tektronix digital oscilloscope

TDSUSB2 application
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Typical Equipment Setup-Resume Measurement

®  TDSUSBF compliance test fixture (Revision B)

B Two of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Resume Measurement

To set up the Device SQ in the test fixture for the Resume test, follow these steps:

1. Set the S6 switch to the Init position.

2. Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.
Connect one end of the cable to the B receptacle socket connector on the Init port of the Device SQ
section and the other end to the host port A socket.

3. Connect the A receptacle from the Device SQ test port to the unit under test (device).

4. Connect the single-ended probes of the oscilloscope to the D+ and D pins.

5. Select the Resume measurement in the application, configure its options and select the Run button

to run the application.

6. Select OK after acquiring a waveform. Verify that it is a correct waveform.

Microsoft Windows 2000 PC
OHCI
port
Test maode
software
- "

TDSUSB?2 Universal Serial Bus Measurements Package

Tektranix oscllloscope
with Application running
s l. 2
JiT &
o LISEZ 05000
b (5 | o2
Ny o]
: 11436
froos s
f,fim.a.‘ E voltage probes
st 4T B
2 ; = 3
< s | Test fixture
L
Device Under Test
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Selecting and Configuring Measurement-Resume

Follow these steps to select measurements for Resume measurement:
1. From the application menu, select Measurement > Select > High speed (tab).
2. Select the More button to display the following tests:

- Receiver Sensitivity

= Suspend

= Reset from High Speed

= Packet Parameter

= Chirp

= Resume

- Reset Suspend

3. Select the Resume measurement.

Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Signal Direction Upstream, Downstream
Source D+ Ch1-Ch4, Ref1-Ref4

D - Ch1-Ch4, Ref1-Ref4

3. Select A to acquire the data.

Viewing Results-Resume Measurement

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary.
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g Flle  Measurements Resufts Utilites Halp

Tosusae:
Resulls: Summany Rasuma

Resume Test m
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2. Click any of the test result buttons to get the details of that test.

3. From the application menu, select Results > Details.

% File Measurements Resulis LKiliies Help
TOSUSHE?
Results: Detaills

1
Regume Texl o n
F Semll the table to see
thie result datails.

Additional
Information

werall Rasult
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Generating Reports-Resume Measurement

Generating Reports-Resume Measurement
To generate reports of the test results, follow these steps:
1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific, or CSV format.
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3.
4.

Tektronix Specific

Resume Test Results in Tek format
Device 10 ffe_001
Device Desoription Hgh Spesa, Down Stream Testng, Dumimny Deavice.
Dabe: Tru Jun 14 17:08:20 15T 2001

Resurme Test Result: Pass

Rbeasurement MName | Resume Time | USE Limits | Stalus

Ruzsiime Test 4AOSHIBE | L000000MmS | Fa

Aoditonal Infoemation . Asaphiude for e bet e 384 1400mV

Select the manual generation mode.

Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Reset from Suspend Measurement

The following equipment is needed for Reset from Suspend measurement:

Tektronix digital oscilloscope

TDSUSB2 application

TDSUSBF compliance test fixture (Revision B)

Two of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Reset from Suspend Measurement

To set up the Device SQ in the test fixture for the Reset from Suspend test, follow these steps:

1.

Set the S6 switch to the Init position.

2. Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.

TDSUSB?2 Universal Serial Bus Measurements Package 101



Application Examples Selecting and Configuring Measurement-Reset from Suspend Measurement

3. Connect one end of the cable to the B receptacle socket connector on the Init port of the Device SQ
section and the other end to the host port A socket.

4. Connect the A receptacle from the Device SQ test port to the unit under test (device).
5. Connect the single-ended probes of the oscilloscope to the D+ and D- pins.

6. Select the Reset from Suspend measurement from the application, configure its options, and select
the Run button to run the application.

7. Select OK after acquiring a waveform. Verify that it is a correct waveform.

Tektranix oscilloscope
with Application running
Microsaft Windows 2000 PC ¥ ’
OHCI
port
Test mode Jar
softwara o e
p . noly, | 2|35 |82
Ny
- 11435
Jian o
Em | Single-ended
LI 2§ vollage probes
S8 a7 E
SHCE
< o | Tost fixture
T
Device Under Test

Selecting and Configuring Measurement-Reset from Suspend
Measurement

Follow these steps to select measurements for Reset from Suspend measurement:

1. From the application menu, select Measurement > Select > High speed tab.
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2. Select the More button to display the following tests:
= Receiver Sensitivity
= Suspend
= Reset High Speed
= Packet Parameter
= Chirp
= Resume
= Reset From Suspend

3. Select the Reset from Suspend measurement.

Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Signal Direction Upstream
Source D+ Ch1-Ch4, Ref1-Ref4

D - Ch1-Ch4, Ref1-Ref4

3. Select 1o acquire the data.

Viewing Results-Reset from Suspend Measurement

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary.
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Q File Messurements Resulls Utiities Help
TOSUSH?

Resulis: Summanry

Reset From Suspe..

= File Measurements Resulis LHililes Help
TOSUSE?
Resulis: Summany

Resel From Suspe.. v'm
1l Task

Time: 14103645

# File Measurements Results UMiliies Heilp
TOSLUSE2
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Generating Reports-Reset from Suspend Measurement

Generating Reports-Reset from Suspend Measurement

To generate reports of the test results, follow these steps:

1.
2.

From the application menu, select Utilities > Report Generator.

Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific, or CSV format.

Generating Reports-Reset from Suspend Measurement

CSV
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& |Time Stamp Thu Jun 14 172259 15T 2001

B
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3.

Plug-Fest Specific

=9l x|
Reset from Suspend Test Results far fste_001

For datalls on a5t setum, A eritgria, g i = power cansumpton
atihe ke _tasting himi USEHIF Compkance Program

W page.

Required Tests

® Reset from Suspend Test Result: Pass
® Reset from Suspend Tune: 1.410364mS
» USB Linits: 2 500000uS to 3,000000msS

Tektronix Specific

Reset from Suspend Test Results in Tek format
Device ID: fife_001
Device Description: High Spead, Up Stream Testing, Dummy Devica,
Date: Thu Jun 14 17:21:3515T 2001
Reset from Suspend Test Result: Pass

Measurement Narme Reset Time pend USE Limits Status

Resat From SLspend - 2.500000U5 to
Test 1.410364m5 2000000mS

o P Py Temnea |

Select the manual generation mode.

Specifying the Equipment-Suspend Measurement

4. Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Suspend Measurement

106

The following equipment is needed for Suspend measurement:

Tektronix digital oscilloscope

TDSUSB2 application

TDSUSB?2 Universal Serial Bus Measurements Package



Application Examples Typical Equipment Setup-Suspend Measurement

®  TDSUSBF compliance test fixture (Revision B)
B Two of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Suspend Measurement

To set up the Device SQ in the test fixture for the Suspend test, follow these steps:
1. Set the S6 switch to the Init position.
2. Use a standard length of USB cable with an A plug on one end and a B plug on the other end.

3. Connect one end of the cable to the B receptacle socket connector on the Init port of the Device SQ
section and the other end to the host port A socket.

Connect the A receptacle from the Device SQ test port to the unit under test (device).
Connect the single-ended probes of the oscilloscope to the D+ and D— pins.

Select the Suspend measurement, configure its options and select the Run button to run the application.

q S s

Select OK after acquiring a waveform. Verify that it is a correct waveform.

Tekironix oscilloscope
with Application running
Microsaft Windows 2000 PC i )
OHCI
port
Test mode n .
h o LISEZ 05000
- N b5 | e2
Ny
: i1435
Rt :JEH
ia.in - M
LY i voltage probas
&4 el
st 4T B
- Talils 93
< e | Testfixture
T
Device Under Test
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Selecting and Configuring Measurement-Suspend Measurement

Follow these steps to select measurements for Suspend measurement:
1. From the application menu, select Measurement > Select > High speed tab.
2. Select the More button to display the following tests:

= Receiver Sensitivity

= Suspend

- Reset High Speed

= Packet Parameter

= Chirp

= Resume

= Reset From Suspend

3. Select the Suspend measurement.

Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following signal direction options:

Option Set to
Signal Direction Upstream, Downstream
Source D+ Ch1-Ch4, Ref1-Ref4

D - Ch1-Ch4, Ref1-Ref4

3. Select ® to acquire the data.

Viewing Results-Suspend Measurement

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary.
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Q File Measurements Resulis LUtilibes Help
TOSUSE?
Resulls: Summany

Suspend Tegt ‘ PASS

3. From the application menu, select Results > Details.

fg File Measurements Resulis Uliliies Halp

TO5USA2
Results: Details

FA25000mS
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Generating Reports-Suspend Measurement

Generating Reports-Suspend Measurement
To generate reports of the test results, follow these steps:
1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific, or CSV format.

CSv
B]pte Ede Yow Inst Pomet Tooks Dsts Window Help Acrobet =l x|
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Plug-Fest Specific

[+ Remireen

Suspend Test Resulls for fate_D01

Fon detai o les] Setup, mePodilsdy, and perorimands cnléns, please cdedull e piaer COnsurdlan
requirements best dosScriplion ab e iy Messs b o106 wsop st pmpHisn_bestng hamd USE:IF Comgliance Program
wah pags

Required Tests

o Suspend Test Result Fa
o Suspend Time 1 000E00mS
w» USH Linuts: 3 000000mS to 3 125000mS:

Tektronix Specific

Suspend Test Results in Tek format

Drewice 10 Tafe_001
Drevice Descripion: High Spesd, Up Stream Testng, Dummy Desice.
Dhates Thiu Jn 14 16045012 IST 2001

Susperd Test Result: Pass

e T Suspend Time USE Limits Status
3000000mS Bo -
Suspend Tesk A0EEIEmS 3.1 75000MmS Fam

3. Select the manual generation mode.

4. Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft
Excel.

Specifying the Equipment-Reset from High Speed Measurement

The following equipment is needed for Reset from High Speed measurement:

®m  Tektronix digital oscilloscope
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TDSUSB2 application
TDSUSBF compliance test fixture (Revision B)
Two of the following single-ended voltage probes: P6245, P6243, TDP1500, TDP3500, or TAP1500.

Typical Equipment Setup-Reset from High Speed Measurement

12

To set up the Device SQ in the test fixture for the Reset from High Speed test, follow these steps:

1.
2.
3.

Set the S6 switch to the Init position.
Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.

Connect one end of the cable to the B receptacle socket connector on the Init port of the Device SQ
section and the other end to the host port A socket.

Connect the A receptacle from the Device SQ test port to the unit under test (device).
Connect the single-ended probes of the oscilloscope to the D+ and D- pins.

Select the Reset from High Speed from the application, configure its options and select the Run
button to run the application.

Select OK after acquiring a waveform. Verify that it is a correct waveform.
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Application Examples Selecting and Configuring Measurement-Reset from High Speed Measurement

Tekironix oscilloscope
with Application running
Microsaft Windows 2000 PC | e S
OHCI
part
Test mode nr o,
® | | usEzmsgoD
- ., - b e ng
Ny ]
: 1435
jmm | :.l91
ia:n = Single-ended
Pt N voltage probas
&a 77 ;|-
sann_ 43 [ E
2 3
= parugn | Vet fixture
T
Device Under Test

Selecting and Configuring Measurement-Reset from High Speed
Measurement

Follow these steps to select measurements for Reset from High Speed measurement:

1. From the application menu, select Measurement > Select > High speed tab.
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Application Examples Viewing Results -Reset from High Speed Measurement

2. Select the More button to display the following tests:
= Receiver Sensitivity
= Suspend
- Reset High Speed
= Packet Parameter
= Chirp
= Resume
= Reset From Suspend

3. Select the Reset from High Speed measurement.

Configuring the Measurement
Follow these steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Signal Direction Upstream
Source D+ Ch1-Ch4, Ref1-Ref4

D - Ch1-Ch4, Ref1-Ref4

3. Select K to acquire the data.

Viewing Results -Reset from High Speed Measurement

To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary.
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%;— File Measurements Results LUHiliies Halp
TOSUSH2

Reesiullts: Summany

Re<e&l From High 5... n

3. From the application menu, select Results > Details.

% File Measurements Resulls WUlilties Help

Hesults: Details Reset Fram Hig

TOSUSR2

the Lable {0 2es
sulit details
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Generating Reports-Reset from High Speed Measurement

Generating Reports-Reset from High Speed Measurement

To generate reports of the test results, follow these steps:

1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific or CSV format.
CSv
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Plug-Fest Specific

For datalls on a5t setum,

Reset from High Speed Test Results for tsfe_001
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e page

Required Tests
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nee Program

Tektronix Specific

Deewloe IO fafe 001

Date: Thu Jun 14 17:16:33 15T 2001

Reset From High Speed Test Result: Pass

Reset From High Speed Test Results in Tek format

Device Description: High Speed, Up STeam Testing, Dummy Device

3. Select the manual generation mode.

Reset From High Speed B
Beasurerment harme T.“:;' USE Limits Status
Roeset From High Speed . 3. 100000mS 1o §
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Specifying the Equipment-Chirp

4. Select the Generate button to display and view the selected report format.

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft

Excel.

Specifying the Equipment-Chirp

The following equipment is needed to test Chirp measurement:

®m  Tektronix digital oscilloscope

TDSUSB?2 Universal Serial Bus Measurements Package
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Application Examples Typical Equipment Setup-Chirp

m  TDSUSB?2 application
®  TDSUSBF compliance test fixture (Revision B)
B Two P6245 or P6243 or TDP1500 or TDP3500 or TAP1500 single-ended probes

Typical Equipment Setup-Chirp

Tek  Stopped 1 i3
IEEES 2R RN R DR R B

[ost Chirp Response Time -

ChZ  Z50my 20.0pz ChE  Z50mY 20.0p=

Typical Equipment Setup-Chirp

The section used for this device test is Device SQ in the test fixture. To set up the equipment for the
Chirp test, follow these steps:
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1. Set the S6 switch to the Init position.

Typical Equipment Setup-Chirp

2. Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.

3. Connect one end of the cable to the B receptacle socket connector on the Init port of Device SQ
section and the other end to the host port A socket.

4. Connect the A receptacle from the Device SQ test port to the unit under test (device).

5. Connect the single-ended probes of the oscilloscope to the D+ and D- pins.

6. Select the measurement and select the & button to run the application.

7. Run the HS Electrical Test Tool on the connected host. Enumerate the unit under test (device) and
observe the chirp signal on the oscilloscope. Rather than enumerating the device, an alternative method
to generate the chirp signal is to disconnect and reconnect the unit under test (device) to the port.

8. Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. 70 avoid false triggering for the chirp signals while operating the test fixture, it is recommended
that you place the switch in the Init position and connect the unit under test. This disables the switch

bounce to the trigger.

Microsoft Windows 2000 PC
OHCI
port
Test maode
software

TDSUSB?2 Universal Serial Bus Measurements Package

Tektronix oscilloscope

with Application runasng
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Application Examples Selecting and Configuring Measurement-Chirp

Selecting and Configuring Measurement-Chirp

Follow these steps to select measurements for Chirp measurement:
1. From the application menu, select Measurement > Select > High speed tab.
2. Select the More button to display the following tests:

= Receiver Sensitivity

= Suspend

- Reset from High Speed

- Packet Parameter

= Chirp

= Resume

= Reset Suspend

3. Select Chirp measurement.

Configuring the Measurement
Follow the steps to configure the selected measurements:
1. From the application menu, select Measurement > Configure > Configure tab.

2. Configure the following options:

Option Set to
Select DUT Host, Device
Host EL_33, EL_34
EL_35
Device EL_28, EL_29, EL_31
Source Ch1-Ch4, Ref1-Ref4

3. Select K to acquire the data.

Viewing Results-Chirp
To view the results of the tests, follow these steps:

1. Run the application and from the application menu, and select Results > Summary. The next figures
show the result of a Chirp Device measurement.
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?’Q File Measuremeaents Results UHilities

TOsusE2
Resulis Summans Chirp Test

Chirp-KiJ to SOF Ti... 4 PASS

eyl Status
etails of

2. Click any of the test result buttons to get the details of that test.

% File Measurements Resulls Ulilties Help

Results: Summany

Chirp ResponEe Ti..

Chirp-K&.) Duration

<= 100, 0000us

Readty

4. Click here to view the results of the Chirp Host measurement.
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Chirp Host

E’Q File Measurements Results Utilities Help

TOsUsE2
= Surmimang Chirp Test

Chirp-Ki to S0F Ti.. v PASS

ThOEUsE2

Soroll the table fo see

the result details.

Generating Reports-Chirp

To generate reports of the test results, follow these steps:

1. From the application menu, select Utilities > Report Generator.

2. Select any one of the Report formats: Tektronix Specific, Plug-Fest Specific or CSV format.
CSv
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al@l x|

w050 EEBE s WA LAY

m®
Al = = B
A B | [ 1] E G [ H [
1 Chimp Raport |
| 3 |UsEL0 Tes Packagetersion 160
3 |Dmice ID fafe_001
| 4 |Device Descrption High Spagd Dumimy Dervice
| & | Time Stamp Thu Jun 21 11:47:03 15T 2001
[
T |Meassuremen Mame Linit Messuremen Value Ush Limits Status
| 8 |Chipp Rasponsa Time ] 22 TIETEE Time <=100 00000 5 Pass
| 9 [Chig-ka) Duration 5 412055205 & 42 TA0E0L 40.0000005 1o 6O00000uS  Pass
10
11
112
113
14
15
116
17
18
19
|0
121
pr)
|23
|24
F.]
i o}
ol
|28
Fuc]
=0
131
[%
a
)
Ed z
e
(1474 b bl Fsfe_001chirp_host 1./ 11l B |
Plug-Fest Specific
I N aiaix]
Chirp-Test Results for fafe_001
For detaits on fesl setup, methodobogy, #nd perommance ciens, plesses consul Be power congwm pton
RGUIRMANES 195 deECrmhon & B it ur, sag s pare empa an_fagting st LISE-IF Compliance Frogram
wab page
Required Tests
# Chap Test Replt Piss
# Cherp Fesponge Tume 217007505 and USE Lits: Tooe =100, 0000usS
# Chap K& Dumstion: 41, 2005308 & 42 70060uS and USHE Limis 40 00000uS to 60 00000uS
FOSUSED scdtwire wrmot. T ED
Fage | Funt
Prist Cloas
TDSUSB?2 Universal Serial Bus Measurements Package 123



Application Examples

124

Tektronix Specific

Dwewice 10 ffa_001

Chirp Test Result: Pass

Chirp-Test Results in Tek format

Date:Thu Jun 21 11:44:43 [ST 2001

Device Description: High Speed | Host EL_338L_34 Testng , Dumimry Devics,

Measurernent

Zaku b iy

3. Select the manual generation mode.

4. Select the Generate button to display and view the selected report format.

Measurement Value USE Limits Status
P
CHip Resporse Time 22799758 Time =100.0000uS
) 41708525 & 40.00000LE 1o
L+ Duration 42.7908005 £0.00000US
Page Pt R

Generating Reports-Chirp

NOTE. You can view the Plug-Fest specific report format as HTML pages and the .csv format in Microsoft

Excel.
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Application Examples View High Speed Measurement Plug-Fest Specific Format

View High Speed Measurement Plug-Fest Specific Format

|®

Signal Quality Test Results for fsfe_001

For details on test setup, metodoloy, and perfarmance criteria, please consult the signal quality test
descripion gt the kitp S b, argfdave lapessfeomplizn_testing kil LSE-IF Compliance Program web page.

Mear End High Speed Signal Data and Common Mode Voltage

I

= WL
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View Full Speed Measurements Report in Plug-Fest Specific Format

|»

Signhal Quality Test Results for fsfe_001

For details on test setup, methodology, and performance criteria, please consult the signal quality test
description at the http: s ush.argidevelopersicomplian_testing. html USB-IF Compliance Program web page.

Far End Full Speed Signhal Data and Common Mode Voltage
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Application Examples View Signal Quality Check Eye Diagram

View Signal Quality Check Eye Diagram

Uateae 1)

TDSUSB?2 Universal Serial Bus Measurements Package 127



Application Examples

View Signal Quality Check Waveform Plot

View Signal Quality Check Waveform Plot
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View the Report for Full Speed Measurements
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View Waveform Plot for Full Speed Signal Quality Check Measurements
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Application Examples View Eye Diagram for Full Speed Signal Quality Check Measurements

View Eye Diagram for Full Speed Signal Quality Check Measurements
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View Waveform Plot For High Speed Measurements
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View Signal Quality Check Results Details

_lglx]

-

Signal Quality Test Results in Tek format

Device 1D fsfe_001

Device Description: Full Speed, Far End Device, Up Siream Testng, Tier &, Dummy Device,

Date: Fri Jul 09 22:46:28 POT 1999

Overall Result: Pass *

B EG

TDSUSBE2
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View Sample Report File for Inrush Current Check

View Sample Report File for Inrush Current Check

134
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Device ID hs_001

D

Inrush Report
USBZ.0 Test Package'ersion 3.5.0 Build 1

Device DecHigh Spee Durmnmy Device
Tirme Starr Tue Jul 07 00:20:50 POT 2009

Measurern Unit Charge

Inrush Tes - 26. 237460 5. 0946530 < 51 50000 Pass
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12.0000us 252.00us
2/292.00us |393.00us
345820005 |898.00us
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51.4020rms | 1.6070ms
§1.8340rms 1.9350ms
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M 4 » [\ hs_001-inrush /

I

Capacitant USE Lirnit: Status

Charge

330.66nC
30.060nC
711.1BnG
£30.80nC
410,560
30.060nC
210.42ni
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R-GPIB Commands About the R-GPIB Program

About the R-GPIB Program

The R-GPIB feature provides a framework to remotely automate the TDSUSB application to perform
USB compliance testing. The R-GPIB support can be used to select, configure and run all TDSUSB tests;
and it also supports the test reports generation. An example of an R-GPIB program that can execute

the TDSUSB2 measurement is included with the application. The oscilloscope hard disk and optional
applications compact disc both contain the file, TDSUSB2_rgpib. c. On the hard drive, the file resides in
the C:\Program Files\TekApplications\tdsusb2 directory.

This example shows how an R-GPIB program executes the application to do the following tasks:
Start up the application
Recall Full Speed Signal Quality setup

1.

2

3. Run the measurement
4. Generate the reports.
5

Exit the application

R-GPIB Reference Materials

To use the R-GPIB commands with your oscilloscope, refer to the following materials:

B The TDSUSB2_rgpib.c file on the oscilloscope hard drive (located in the C:\Program
Files\TekApplications\tdsusb2 directory) and optional application compact disc for an
example of an R-GPIB command that can execute the application.

m  The R-GPIB Program Example section for guidelines to use while designing the R-GPIB program.

B The programmer information is in the online help of your oscilloscope.

Introduction to R-GPIB commands

With the knowledge of R-GPIB command syntax, you can design an R-GPIB program to do the following
tasks:

m  Start the TDSUSB2 application

B Recognize an active application with R-GPIB protocol
m  Program and read the application setup parameters

B Sequence measurements

®  Generate reports
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Guidelines to R-GPIB Programming

The TDSUSB2 application includes an example of an R-GPIB program for your reference as a program
example. Your R-GPIB program should comply with the following guidelines:

®  The application startup must complete before sending additional R-GPIB commands to the application
(see example).

B To generate reports, first check whether the sequencer state is "Ready".
m  Appropriate delay (for example: 2 secs) should be maintained between commands.

m  The status variable should be checked to ensure that an error has not occurred because of a
measurement command problem.

®  R-GPIB event queue needs to be monitored. Make sure the event queue is clear before sending the
next R-GPIB command to prevent event queue overflow.

B Commands are case and space sensitive. Your program will not operate correctly if you do not follow
the capitalization and spacing precisely.

Launching the Application using R-GPIB

You must manually set up the oscilloscope to launch the application. To start the TDSUSB2 application,
you must send the oscilloscope the following R-GPIB command:

application:activate"USB2.0 Test Package"

The application uses the R-GPIB VARIABLE: VALUE command with arguments to execute some
features. The set of R-GPIB commands includes the variable names and variable values necessary to
select, configure, and run the measurements and to generate reports in the R-GPIB program.

You can select and configure the measurements that you want to use with your R-GPIB program.

NOTE. When using R-GPIB commands, the reports are saved in C:\TekApplications\tdsusb2\reports
directory.

Variable: Value Command
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Variable: Value Command
Description

This command accepts strings arguments for a control or data variable and a value to which to set the
argument.

TDSUSB?2 Universal Serial Bus Measurements Package



R-GPIB Commands Variable: Value TDSUSB2 Command Arguments and Queries- Application

Syntax
VARIABLE:VALUE “<variable name>",“<variable value>”
the arguments <variable name> and <variable value> are required in the order indicated.

VARIABLE:VALUE? “<variable name>” for query.

NOTE. Commands are case and space sensitive. Your program will not operate correctly if you do not
follow the capitalization and spacing precisely.

Variable: Value TDSUSB2 Command Arguments and Queries-
Application

Variable Name Valid Values Function Query Form

Terminating the Application

application exit Setting the value will Returns the name of
terminate the running the currently running
application application

Variable: Value TDSUSB2 Command Arguments and Queries- Sequencer

Variable Name Valid Values Function Query Form

Running Measurements

sequencerState {Sequencing}-for Sets the sequencer state Returns the sequencer
Sequencing state
{Ready, Sequencing}-for
Query

Variable: Value TDSUSB2 Command Arguments and Queries-Confirm
Waveform

Variable Name Valid Values Function Query Form

confirmWaveform OK Sets the Confirm Waveform Returns the status message
message status to “OK” for the Confirm Waveform
to continue executing the message dialog box for
SQC measurements SQC measurements
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Variable: Value TDSUSB2 Command Arguments and Queries- Save/Recall

Variable: Value TDSUSB2 Command Arguments and Queries-

Save/Recall

Variable Name

Valid values

Function

Query Form

setup

{Default, Recall, Save}

Sets the save/recall/default
action

The default value for this
variable is an empty string.
The variable is set to the
selected value momentarily
and after completion of the
task, it returns to its default
value

recallName

It is recommended to have
any string of length 1-8
chars, comprising of A-Z,
a-z, 0-9

Sets the setup recall file
name

Returns the setup recall file
name

saveName

It is recommended to have
any string of length 1-8
chars, comprising of A-Z,
a-z, 0-9

Sets the setup save file
name

Returns the setup save file
name

Variable: Value TDSUSB2 Command Arguments and Queries- Report

Generation

Variable Name

Valid values

Function

Query Form

reportFormat

{tek, plug-fest, csv}

Sets the Report format to
Tektronix specific, plug-fest
specific or CSV format

Returns the current report
format

reportName

It is recommended to have
any string comprising of
A-Z,a-z, 0-9 in the manual
mode. Do not add file
name extension to the
report name

Sets the report file name

Returns the report file name

reportDirectory

It is recommended to have
any string comprising of
A-Z,a-z,0-9 and V. End
the directory name with 'V

Sets the directory to save
the report

Returns the directory to
save report

reportMode {auto, manual} Sets the report generation Returns the report
mode to automatic or generation mode
manual

reportGenerate generate Generates the report in the

manual mode
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Variable: Value TDSUSB2 Command Arguments and Queries- Results

Variable Name

Variable: Value TDSUSB2 Command Arguments and Queries- Results

Valid value

Function

Query Form

resultFor {eye, sigrt, jk, kj, con, eop, Sets the result variables After being set to a
eopbit, cross, rer, fer, mon, with appropriate result measurement value, the
in, pphost1, pphost2, values for that particular query returns "Busy" until
pphost3, ppdevicet test the results are refreshed.

> ’ Returns the selected
ppdevice2,resume,sus- measurement for result
pend, querying
rfr, rfs, chirphost1,
chirphost2,
chirpdevice1}
reset {Result} Clears the active

measurements results

Statistical results- Basic statistics applicable for all SQC measurements

measUnits Units string for the
measurement (for example
“s” - seconds is the unit for
Period)

max Maximum value of the
measurement

mean Mean value of the result

min Minimum value of the
measurement

pkpk Peak-to-peak value of the
measurement

rms RMS value of the result

population Population (number of)
measurements used to
calculate the current
statistics

stdDev Standard deviation
measurement set

status {Pass, Fail, Conditional Returns Pass/Fail result

Pass}

for the selected SQC
measurement

Pass/Fail Status

eyeStatus

{Pass, Fail, Conditional
Pass}

Returns the eye diagram
measurement

sqcOverallStatus

{Pass, Fail, Conditional
Pass}

Returns the overall SQC
measurement result

Inrush

inCharge

Returns the inrush charge
value
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Variable Name

Variable: Value TDSUSB2 Command Arguments and Queries- Results

Valid value Function

Query Form

inCap Returns the inrush
capacitance value
inStatus {Pass, Fail, Conditional Returns the Pass/Fail

Pass} status of inrush
measurement
Packet Parameter
ppOverallStatus {Pass, Fail} Returns the overall
Pass/Fail status of the
selected packet parameter
measurement result
ppHostEL21Status {Pass, Fail} Returns the sync field
Pass/Fail status
ppHostEL23 Returns the interpacket gap
between first two packets
ppHostEL23Status {Pass, Fail} Returns the interpacket gap
Pass/Fail status
ppHostEL25 Returns the EOP width in
bits of the second packet
ppHostEL25Status {Pass, Fail} Returns the EOP width
Pass/Fail status
ppHostEL22 Returns the interpacket gap
ppHostELSS Returns the EOP width in
bits gap between second
and third packet
ppDeviceEL21Status {Pass, Fail} Returns the sync field
Pass/Fail status
ppDeviceEL22 Returns the interpacket gap
ppDeviceEL22Status {Pass, Fail} Returns the interpacket gap
Pass/Fail status
ppDeviceEL25 Returns the EOP width in
bits
ppDeviceEL25Status {Pass, Fail} Returns the EOP width

Pass/Fail status

Reset from Suspend/ Reset from High-Speed/Suspend/Resume

resetSusTime Returns the reset from
Suspend time

resetSusStatus {Pass, Fail} Returns the reset from
Suspend status

susTime Returns the suspend time

susStatus {Pass, Fail} Returns the suspend status

resetHSTime Returns the reset from high
speed time

resetHSStatus {Pass, Fail} Returns the reset from high

speed status
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Variable Name Valid value Function Query Form

resumeTime Returns the resume time
for upstream

resumeAmp Returns the resume
amplitude for downstream

resumeStatus {Pass, Fail} Returns the resume status

Chirp

chirpHostEL33 Returns the host response
time

chirpHostEL33Status {Pass, Fail} Returns the host response
time status

chirpHostKEL34 Returns the host K duration

chirpHostJEL34 Returns the host J duration

chirpHostEL34 Status {Pass, Fail} Returns the host KJ
duration status

chirpHostEL35 Returns the SOF time

chirpHostEL35Status {Pass, Fail} Returns the SOF time
status

chirpDeviceEL28 Returns the device reset
time

chirpDeviceEL28Status {Pass, Fail} Returns the device reset
time status

chirpDeviceEL29 Returns the device K
duration time

chirpDeviceEL29Status {Pass, Fail} Returns the device K
duration time status

chirpOverallStatus {Pass, Fail} Returns the overall

Pass/Fail status of
the selected chirp
measurement result

Additional Result

additionalResult Returns the additional
result, if applicable for
selected measurement
using resultFor

resultFor Commands:

resultFor commands are of the format:
variable:value “<variable name>”,“<value>"
Get or query commands are of the format:

variable:value? “<variable name>"
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Ensure that the order mentioned below is followed for the command script to work correctly. A sample
script is listed here. It recalls a signal quality test setting, selects the test, runs the test, and queries the
result. For example: Measured mean value for rising edge rate test.

It is recommended to give a delay of at least one second between commands.
variable:value “recallName”,“sqc”

variable:value “setup”,”Recall”

variable:value “sequencerState”,“Sequencing”

.....keep polling until it returns a “Ready”

variable:value? “sequencerState”

“Ready”

variable:value “resultFor”,“rer”
variable:value? “resultFor”
“Busy”

.....keep polling until it returns a “rer” the current test for which the result is queried

variable:value? “resultFor”

variable:value? “mean”

1.88n

Sample Program
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/* TDSUSB2
1 This is a reference program to illustrate how to communicate with TDSUSB2

2 Using Remote GPIB facilities.

Typically, the application does the following steps:

1. Start up the application

2. Recall Full Speed Signal Quality setup

3. Run the measurement

4. Generate the report

5. Exit the application

For the current program, we will recall a setup file named as sqcsetup.

You can save setup files according to your own needs using the GUI based interface of
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the application.
3y

#include <windows.h>

#include <stdio.h>

#include <stdlib.h>

#include "decl-32.h"

/* Forward Declarations */

int start_application(int scope);

int exit_application(int scope);

int do_single_test (int scope);

int recall_setup( int scope, char *filename);

void display results(int scope);

/* parameters needed to access the device driver handler */

#define BDINDEX 0 // Board Index

#define PRIMARY ADDR OF DMM 1 // Primary address of device
#define NO_SECONDARY ADDR 0 // Secondary address of device
#define TIMEOUT T10s // Timeout value = 10 seconds

#define EOTMODE 1 // Enable the END message

#define EOSMODE 0 // Disable the EOS mode

char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL", "EADR", "EARG",
"ESAC", "EABO", "ENEB", "EDMA", "",

"EOIP", "ECAP", "EFSO", "", "EBUS",

"ESTB", "ESRQ", "", """, "", "ETAB"};

/%

After each GPIB call, the application checks whether the call
succeeded. If an NI-488.2 call fails, the GPIB driver sets the
corresponding bit in the global status variable. If the call

failed, this procedure prints an error message, takes

the device offline and exits.

*/

void GPIBCleanup(int ud, char* ErrorMsg)
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{
printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n",

ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);

if (ud !=-1)

{

printf("Cleanup: Taking device offline\n");

ibonl(ud, 0);

}

exit(0);

}

int start_application( int scope )

{

char write bufter[100];

char read buffer[100];

char app_name[] = "\"USB2.0 Test Package\"\n";

int status, timer;

/* Start the TDSUSB2 application */
sprintf(write_buffer, "%s", "Application:activate \"USB2.0 Test Package\"");
status = ibwrt(scope, write _buffer, strlen(write buffer));
if (ibsta & ERR)

{

GPIBCleanup(scope, "Unable to start the application");
return 0;

}

timer = 1;

while (1)

{

/* Check whether application has started */
sprintf(write buffer, "%s", "Variable:value? \"application\"");
status = ibwrt(scope, write buffer, strlen(write buffer));

status = ibrd(scope, read_buffer, sizeof(read_buffer));

Sample Program
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read_buffer[ibcnt] = "\0’;

if (strcmp(app_name, read_buffer) == 0)
{

return 1;

}

timer++;

if (timer > 60)

{

return 0;

h
Sleep(1000);

}

return 1;

}

int exit_application(int scope)

{

char write bufter[100];

printf("Exit Application ...\n");

sprintf(write_buffer, "%s", "Variable:value \"application\",\"exit\"");
ibwrt(scope, write_buffer, strlen(write buffer));

return 1;

H

int recall setup(int scope, char* filename)

{

char write buffer[100];

int status;

/* Set Recall file name */

sprintf(write buffer, "%s%s%s", "Variable:value \"recallName\",\"", filename, "\"");
status = ibwrt(scope, write_buffer, strlen(write_buffer));

if (ibsta & ERR)

{
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GPIBCleanup(scope, "Unable to communicate with Scope");
return 0;

h

Sleep(1000);

/* Recall setup */

sprintf(write buffer, "%s", "Variable:value \"setup\",\"Recall\"");
status = ibwrt(scope, write buffer, strlen(write buffer));

if (ibsta & ERR)

{

GPIBCleanup(scope, "Unable to communicate with Scope");
return 0;

}

return 1;

}

int run_test (int scope)

{

char write bufter[100];

char read buffer[100];

int timer;

sprintf(write_buffer, "%s", "Variable:value \"sequencerState\",\"Sequencing\"");
ibwrt(scope, write_buffer, strlen(write buffer));
printf("Executing Test...\n");

Sleep(100);

/* Wait for application to come to Ready State */
timer = 1;

while (1)

{

timer++;

if (timer > 90)

{

printf("******Test Time Out ******\n");

Sample Program
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return 0;

}

sprintf(write buffer, "%s", "Variable:value? \"sequencerState\"");
ibwrt(scope, write buffer, strlen(write buffer));

ibrd(scope, read buffer, 99);

if (ibsta & ERR)

{

GPIBCleanup(scope, "Unable to write to device");

}

read_buffer[ibcnt] = "\0’;

if (strcmp(read_buffer,"\"Ready\"\n") == 0)

{

printf("Test Complete ...\n");

return 1;

}

Sleep(1000);

}

}

void report_generate(int scope,char* reportfilename)

{

char write_bufter[100];

char read_buffer[100];

int status;

/* Set report file name */

sprintf(write buffer, "Variable:value \"reportName\",\"%s\"" reportfilename);
printf("%s",write_buffer);

status = ibwrt(scope, write buffer, strlen(write buffer));

if (ibsta & ERR)

{

GPIBCleanup(scope, "Unable to communicate with Scope");

return;
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H
Sleep(1000);

/*Generate the report*/

sprintf(write buffer, "variable:value \"reportGenerate\",\"generate\"");
printf("%s",write_buffer);

ibwrt(scope, write buffer, strlen(write buffer));

if (ibsta & ERR)

{

GPIBCleanup(scope, "Unable to start the application");
return;

h

Sleep(2000);

printf("\t Full Speed Signal Quality Result stored\n");

}

void main()

{

int Dev;

char write_bufter[100];

int status;

Dev = ibdev (BDINDEX, PRIMARY ADDR OF DMM, NO SECONDARY_ ADDR,
TIMEOUT, EOTMODE, EOSMODE);

if (ibsta & ERR)

{

GPIBCleanup(Dev, "Unable to open device");

}

else

{
printf("My device id - %i", Dev);

h
Sleep(1000);

sprintf(write buffer, "%s", "header off");
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status = ibwrt(Dev, write_buffer, strlen(write buffer));
if (start_application(Dev))

{

printf("\nApplication started....\n");

}

Sleep(10000);
recall_setup(Dev,"sqcsetup");

Sleep(2000);

run_test(Dev);

Sleep(4000);
report_generate(Dev,"fs sqc");
Sleep(2000);

exit_application(Dev);

/* leave the device back elegantly */
printf(""Cleanup: Taking device offline\n");
ibonl(Dev, 0);

h
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Shortcut Keys

This table lists the shortcut keys, that you can use for different tasks.

Action Shortcut Keys
File Menu

Recall Default AltF+D
Recall AltF+R
Save AltF+S
Preferences AltF+P
Recently Recalled AltF+C
Recently Saved AltF+A
Minimize AltF+N
Exit AltF+X
Measurements Menu

Select AltM+S
Configure AltM+C
Results Menu

Summary AltR+S
Details AltR+D
Utilities Menu

Deskew AltU+K
Report Generator AltU+R
TSV File Generator AltU+T
Help Menu

Help Topics AltH+T
About TDSUSB2 AltH+A

NOTE. Use the Alt key with only the first keystroke . Release the Alt key before you press the final
key. For example, to use the shortcut key AltF'+D, press the Alt and F keys together. Release the keys
and then press D.

USB2.0 Specifications

This section gives the USB2.0 values for measurements for Low, Full and High speed signals.
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Low Speed
USB Limits User Configure Limits References !
Measurements Max Min Max. range Min. range
Cross-Over Voltage 20V 13V 1.6-24V 1.04-1.56 V Chapter 7, Table 7-7,
Section 7.1.2.1
Signal Rate 1.5225 Mbps 1.4775 Mbps 1.5675- 1.146- Chapter 7, 7.1.11
1.881 Mbps 1.4325 Mbps
Conse-cutive Jitter <25 ns N/A 20-30 ns N/A Chapter 7, 7.1.13.1
Paired Jitter <10 ns N/A 8-12 ns N/A Chapter 7, 7.1.13.1
Rising Edge Rate 35.2 VI ys 8.8 V/ ps 16-24 ns 3.2-4.8 ns Chapter 7, 7.1.2.1
Falling Edge Rate 35.2 V/ ps 8.8 V/ s 16-24 ns 3.2-4.8 ns Chapter 7, 7.1.2.1
EOP Width 1.5e-6 s 1.25e-6 s 1.2-1.8 1-1.5ns Chapter 7, 7.1.13.2.1

1 The References Section refers to the chapter numbers in the ‘Universal Serial Bus Specifications Revision 2.0-2000’.

NOTE. Results within the USB limit lead to a PASS condition. Results within the waiver limits, but outside
USB limits lead to a Conditional PASS. Results within the user configured limits lead to PASS. When user
configure limits is selected, you can view only the result details.

NOTE. Testing at Tier 6 leads to a PASS. Testing at Tier 5 and 4 leads to a Conditional PASS that is a
Pass within the waiver limits. Testing at Tier 1 to 3 leads to a FAIL .

Full Speed
USB Limits User Configure Limits References !
Measurements Max Min Max range Min range
Cross-OverVoltage 20V 1.3V 1.6-24V 1.04-1.56 V Chapter 7, Table 7-7,
Section 7.1.2.1
Signal Rate 12.03 Mbps 11.97 Mbps 1215 to 9.48- Chapter 7,7.1.13.1
14.8 Mbps 11.85 Mbps
Consecutive Jitter <2ns N/A 1.6-2.4 ns N/A Chapter 7, 7.1.13.1
Paired Jitter <1ns N/A 8-1.2ns N/A Chapter 7, 7.1.13.1
Rising Edge Rate 660 V/ us 132 VI ps 16-24 ns 3.2-48 ns Chapter 7, 7.1.2.1
Falling Edge Rate 660 V/ ps 132 VI ps 16-24 ns 3.2-4.8 ns Chapter 7, 7.1.2.1
EOP Width 175 ns 160 ns 140-210 ns 128-192 ns Chapter 7, 7.1.13.2.1

1 References Section refers to the chapter numbers in the ‘Universal Serial Bus Specifications Revision 2.0-2000’.

NOTE. Results within the USB limits lead to a PASS. Results within the waiver limits, but outside USB
limits lead to a Conditional PASS. Results within the user configured limits lead to a PASS result. If you
select configured limits, you can view only the result details.
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NOTE. Testing at Tier 6 leads to a PASS. Testing at Tier 5 and 4 leads to a Conditional PASS that is a
Pass within the waiver limits. Testing at Tier I to 3 leads to a FAIL.

NOTE. The application uses the USB signal rate limits of Low Speed or Full Speed devices that are not
capable of High Speed. The same limits for Low Speed or Full Speed that are High Speed capable to
decide the result - PASS or FAIL.

High Speed
USB Limits User Configure Limits 80% to References !
120%
Measure- Max Min Max Minrange  USB
ments range Pass/Fail
Signal Rate 480.24 Mbps  479.76 Mbps  480.264- 383.7888- YES Chapter 7,7.1.11
576.3168 Mbps479.736 Mbps
Rising Edge 1422 V/ 0 N/A N/A YES From MATLAB scripts
Rate s
Falling Edge 1422 V/ 0 N/A N/A YES From MATLAB scripts
Rate s
Monotonicity 0 0 N/A N/A N/A N/A
EOP Width 8.5 bit 7.5 bit 8.5-10.2 6-7.5 bit YES Chapter 7, 7.1.13.2.2
times times bit times times

1 The References Section refers to the chapter numbers in the ‘Universal Serial Bus Specifications Revision 2.0-2000’.

NOTE. Results within the USB limits lead to a PASS. Results within the waiver limits, but outside USB
limits lead to a Conditional PASS. Results within the user configured limits lead to PASS. If you select your
configured limits, you can view only the result details.

NOTE. Whenever a high speed device is used in the low speed and full speed mode, the USB limits of the
low speed and full speed devices are used to decide PASS or FAIL.

NOTE. USB2.0 specifications have not specified the maximum rise time and fall time. If rise or fall times
are greater than 0.5 bits, then a wrong, (long) rise or fall time will be captured as an eye diagram failure.
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Inrush Current Check

Error Codes and Warnings

USB Limits User Configure Limits 80%- References
120%
Measure- Max Min Max Min range UsSB
ments Hot range Pass/Fail
Plug Attach
VBUS Default 525V 44V N/A N/A YES Chapter 7, 7.22
Volts 5.15
Inrush Level 100 mA N/A 80-120mA  N/A YES Current Draw.pdf
Droop Test
USB Limits User Configure Limits 80%- References
100%
Measure- Max Min Max Min range USB
ments range Pass/Fail
Droop <330 mV 70.0 m 264- N/A YES Chapter 7, 7.2.4.1
Compliance 396 mV
Voltage

1 References Section refers to the chapter numbers in ‘Universal Serial Bus Specifications Revision 2.0-2000’.

Error Codes and Warnings

This section gives a list of error codes that the application displays and their descriptions.

Error Codes

Error Message

Description

Possible Solutions

Sequencer Errors

E101 Error importing waveform The application is trying Make sure that the
from the oscilloscope to import the waveform(s) application settings
from the selected source(s), are the same as the
but is not able to import the selected oscilloscope
waveform to the application channels. Check the
probe connections and
the compliance test fixture
connections for the live
signal(s)
E102 Error in accessing .tsv file This error occurs whenever Check whether the file

tsv file is selected as the
source file and this file is
not a valid .tsv file

name extension is .tsv.
The selected .tsv source
file may be corrupted. Try
running the application with
a different tsv file
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E103

Mismatch in the .tsv file
format

The .tsv file should match
the file structure mentioned
in Reference section of
this help. For Low and Full
Speed signals, each data
record should have three
values (Timestamp, D+,
D-). For a High Speed .tsv
file, the file should have two
columns (Time, Diff). Use
a valid file

Try generating the .tsv file
using .tsv File Generator
utility that is available in the
Utilities menu

E104

Record length is more. Set
the record length to less
than XXXXXX data points

The record length is too
high for the waveform

Click the "Horiz" button

or "Horiz/Acq" Menu from
the oscilloscope Ul. Go

to Horizontal tab and
decrease the record length

Error in acquiring waveform from oscilloscope

E111 Timeout occurred while This is the GPIB timeout Make sure the probe
acquiring a waveform information that appears and compliance test
when the application is fixture connections are
acquiring the waveform proper. Reacquire the new
waveform
E112 Error in turning on a The application failed to Make sure the probe
channel turn on the live channel and compliance test
selected as source(s) fixture connections are
proper. Reacquire the new
waveform
E113 Error in importing waveform The operation of importing Make sure the probe

from instrument

the waveform from the
acquisition memory failed.
This will fail whenever there
is no valid waveform in the
acquisition memory

and compliance test
fixture connections are
proper. Reacquire the new
waveform

Packet Detection Warning

E201

No EOP region found

Testing will be performed
on an full USB2.0 packet,
which includes an EOP
region. If no EOP region
is found, the results might
be incorrect since testing
will be performed on a
incomplete packet. For
Upstream signal quality
testing, EOP must be
present

Try acquiring the signals
again by pressing Run
button
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E202 Number of record points At least 500 record points Try acquiring the signals
(data points) are too few to are required to perform an again the pressing Run
process operation. The application button

automatically sets the
required record length. The
user should not change the
record length

E203 Idle region is not found As part of the USB2.0 Try acquiring the signals
after EOP packet description, an again by pressing the Run

EOP region follows an idle button
region. If no idle region
is found, it may lead to
incorrect results
E204 Reconfirm acquired data As part of the USB2.0 Try acquiring the signals

before computing the
results

packet description, a
minimum of three J-K or
K-J state transitions are
expected. An absence of
these transitions may lead
to incorrect results

again by pressing the Run
button

Signal rate measurement errors or warning

E301 There should be at least For signal rate calculations, Try acquiring the signals
two Cross-Over time values the application expects a again by pressing the Run
to calculate the signal rate minimum of two Cross-Over  button

points
E306 Device/ File doesn’t match The signal rate should be Please check the speed

with the selected speed

within 30% of the specified
signal rate of the Low, Full
and High Speed signals

of the connected device.
Ensure that the selection in
application is the same. For
example, if a Low Speed
unit is under test, make
sure Low Speed is selected
in the application

JK and KJ Jitter Measurement Errors

E304 Number of bits is not More than four Cross-Over Try acquiring the signal
sufficient to calculate JK points are expected by the again by pressing Run
jitter algorithm button

E305 Number of bits is not More than four Cross-Over Try acquiring the signal

sufficient to calculate KJ
jitter

points are expected by the
algorithm

again by pressing Run
button

Report Generation Errors

E401

Error generating report in
Plug Fest format

This error is generated
if there are no results to
process

Check if the valid directory
and file name is selected for
report generation. Check
if the file name extension
is .htm. Try generating the
report again by pressing
Run button
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E402 Error Generating report in This error is generated Check if the valid directory
Tek format if there are no results to and file name are selected
process for report generation.
Check if the file name
extension is .htm. Try
generating the report again
by pressing Run button.
E403 Error Generating report in This error is generated Check if the valid directory
CSV format if there are no results to and file names are selected
process for report generation.
Check if the file name
extension is .htm. Try
generating the report again
by pressing Run button
E404 No results present to This error is generated if Press the Run button to get
generate report there are no results present  the results and try again
for the USB Inrush, Droop
and Signal Quality Check
Reports
E405 Could not generate a report This error is generated if Press the Run button and
as the Eye diagram is there is no eye diagram perform the measurements
missing found in C:\TekApplica- again
tions\TDSUSB2\temp
E406 Could not generate report This error is generated if Press the Run button and

as Waveform plot is missing

there is no waveform plot
found in C:\TekApplica-

perform the measurements
again

tions\TDSUSB2\temp
Eye Measurements
EGO1 The maximum zoom factor N/A Press the Reset button or
has been reached use the Zoom out feature.
E602 Signal not proper, check This is a check to confirm Try acquiring the correct

the signal

the acquired waveform

waveform

Inrush Measurements

E501 Final data point is still The signal has not fallen Try acquiring the correct
above the inrush threshold below the Inrush threshold waveform
level
E502 Live Vbus Channel Voltage The Live Vbus channel Check the Vbus voltage in
value is not between voltage value for inrush the oscilloscope
4.4 and 5.5 volts, check current measurement is not
the Vbus voltage in the between 4.4 and 5.5 volts
oscilloscope
E503 Insufficient data length - The acquired data length is Try acquiring the correct
A minimum of 100 ms is insufficient for analysis waveform
required for analysis
E504 Sample rate is below the The sample rate of the Increase the sample rate

minimum required rate of
1 MS/sec

signal should be at least
1MS/sec for analysis
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Error Codes and Warnings

Error Codes Error Message Description Possible Solutions
Utilities
E701 Number of edges found in Before starting the deskew Adjust the timebase and
the waveform is less than operation, the application (or) increase the record
required edges (user input) tries to find out if the length. Perform the deskew
to perform the deskew edge(s) available for operation by entering less
operation deskew operation is greater number of edges
than or equal to the number
of edges needed
E702 Propagation delay is more The deskew operation is Check whether the same
than one cycle performed on the same signal source is used
signal source. Check for the "From" and "To"
whether dissimilar signals channels. Check whether
or any external sources the bandwidth of the probes
(like different probes) are is sufficient for the signal
used bandwidth
E701 Number of edges found in Before the deskew Adjust the timebase and
the waveform is less than operation can start, the (or) increase the record
required edges (user input) number of edge(s) available length. Perform the deskew
to perform the deskew for deskew operation must operation by entering less
operation be greater than or equal number of edges
to the number of edges
needed
E702 Propagation delay is more The deskew operation is Check whether the same

than one cycle

performed on the same
signal source. Check
whether dissimilar signals
or any external sources
(like different probes) are
used

signal source is used

for the "From" and "To"
channels. Check whether
the bandwidth of the probes
is sufficient for the signal
bandwidth

TSV File Generator

E721 Error in generating a .tsv This message is generated Check the correctness of
file if there is an error while the input .csv file(s) and the
generating the .tsv file for output .tsv file
the given inputs
E722 Timestamp of the two There will be two separate Try generating the .tsv file

.csv files did not match.
Conversion failed

.csv files, one for D+ and
another for D-. Each of
these files consist of the
time values of the D+ and
D- signal. It is expected
that both the files should
have Data at same time
stamp

with a new set of .csv files
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E725 Invalid CSV file format This happens if the user Check whether the CSV
does not use a valid CSV files are generated using
file format for the CSV-TSV the supported instruments
file conversion and ensure that "Include

waveform scale factors" is
selected while generating a
CSV file

E723 .csv file(s) not found The .csv file(s) are needed Check that the extension
for the .csv source of the file(s) is .csv. Make
mode selection are not sure to press the Enter key
found. Two valid .csv while entering the file name
files are needed for the in the file selection field to
Single-ended signals and update old file names
one valid .csv file is needed
for Differential signals

E724 tsv file not found A valid .tsv file is needed Make sure to press the

as destination file

Enter key while entering
the file name in the file
selection field to update old
file names

Enter the .tsv extension
while entering the file name

Save and Recall

E751 The file name has invalid The application expects the Make sure the valid
characters and could not file names in alphanumeric characters are used in
be saved characters the file names
E754 The file name has invalid The application expects the Make sure that valid
characters and could not file names in alphanumeric characters are used in the
be recalled characters file names
E752 The file does not exist The file name selected for Recall an existing file name
recall does not exist
E753 The saved file has been The application saves the Try recalling a correct file.
corrupted and not recalled application settings with the Store the settings to a
.ini file extension. The data new file and recall it when
inside the file should not be needed
modified by user
E801 The current signal is not a The acquired signal is not Try acquiring the signals
Chirp Signal. Acquire the a correct Chirp Signal. again by pressing Run
correct signal and proceed Correct Chirp Signal is button
required to perform chirp
measurements
E802 No Chirp-K or Chirp-J state ~ As part of the USB2.0 Chirp Press the Run button to

found

description, a minimum of
1 Chirp-K and 1 Chirp-J
state are expected after
Chirp Response timing
calculation

acquire the signals
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E803

There should be at least 3
Chirp-K and 3 Chirp-J state

As part of the USB2.0 Chirp
description, a minimum of
three Chirp-K and three
Chirp-J state are expected
after Chirp Response
timing .An absence of

this may lead to incorrect
results

Press the Run button to
acquire the signals

E804

No Chirp-J state found

As part of the USB2.0 Chirp
description, a minimum

of one Chirp-J state is
expected after Chirp
Response timing. An
absence of this may lead to
incorrect results

Press the Run button to
acquire the signals

E805

No Chirp-K state found

As part of the USB2.0 Chirp
description, a minimum

of one Chirp-K state

is expected after Chirp
Response timing. An
absence of this may lead to
incorrect results

Press the Run button to
acquire the signals

Rising Edge Rate/Falling Edge Rate Measurement

E901 The High level values need This message is displayed Decrease the percentage
to be decreased if no edge is found in the of the high level values of
high level Rising Edge Rate/Falling
Edge Rate
E902 The Low level values need If no edge is found in the Decrease the percentage
to be increased low level the message is of the low level values of
displayed Rising Edge Rate/Falling
Edge Rate
E903 Both the High and Low If no edge is found in the Increase and decrease the
level values need to be high and low level the percentage of the high and
changed message is displayed low level values of Rising
Edge Rate/Falling Edge
Rate
E904 The calculated Rising Edge This warning appears when Increase the lower level
Rate is more than the the calculated Rising Edge and decrease the upper
calculated bit time of the Rate is more than the level of the configure limits
input signal calculated bit time of the of Rising Edge Rate/Falling
input signal Edge Rate
E905 The calculated Falling This warning appears when Increase the lower level

Edge Rate is more than the
calculated bit time of the
input signal

the calculated Falling Edge
Rate is more than the
calculated bit time of the
input signal

and decrease the upper
level of the configure limits
of Rising Edge Rate/Falling
Edge Rate
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Error Codes

Error Message

Description

Error Codes and Warnings

Possible Solutions

E906

The calculated Rising Edge
Rate and Falling Edge Rate
is more than the calculated
bit time of the input signal

This warning appears when
the calculated Rising Edge
Rate and Falling Edge Rate
is more than the calculated
bit time of the input signal

Increase the lower level
and decrease the upper
level of the configure limits
of Rising Edge Rate/Falling
Edge Rate

Miscellaneous

E1000 Invalid device Chirp-K for As part of the USB2.0 Try acquiring the signals
this test description, a minimum of again by pressing Run
3 Chirp-K and 3 Chirp-J button
state are expected after
Chirp Response timing. An
absence of this may lead to
incorrect results
E1001 No SOF found No SOF in D+ and D- Power off the DUT, check
the probe connection and
try acquiring the signal
E1002 The current signal is not Acquired signal is not Try acquiring the signals
a Reset From Suspend a correct Reset From again by pressing Run
signal acquire the correct Suspend signal. Correct button
signal and proceed. Reset From Suspend
Signal is required to
perform the measurement
E1003 The current signal is not a Acquired signal is not a Try acquiring the signals
Resume signal acquire the correct Resume signal. again by pressing Run
correct signal and proceed Correct Resume signal is button
required to perform the
measurement
E1004 The current signal is not a Acquired signal is not a Try acquiring the signals
Suspend signal acquire the correct Suspend signal. again by pressing Run
correct signal and proceed Correct Suspend signal button
is required to perform the
measurement
E1005 There is no falling edge If there is no J state found Try acquiring the signals
transition for this test again by pressing Run
button
E1006 There is no start of Chirp-K If there is no K state found Try acquiring the signals
state for this device again by pressing Run
button
E1007 There is no K State If there is no K state found Try acquiring the signals
transition driven by the host again by pressing Run
controller button
E1008 The current signal is not a The acquired signal is Try acquiring the signals
Reset From Resume signal not a correct Reset From again by pressing Run
acquire the correct signal Resume signal. Correct button

and proceed

Reset From Resume signal
is required to perform the
measurement
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Error Codes Error Message Description Possible Solutions

E1009 Check for probe polarity Sync field is reversed If the probe is reversed,
the sync field pattern is
reversed and hence the
test fails

Settings for the supported Instruments

162

This section gives a list of default oscilloscope settings that the application uses for supported instruments.

The recommended voltage probe for single-ended signals are the P6245 or P6243 or TDP1500 or TDP3500
or TAP1500 probes and for differential signals is the P6248 or P6330 probe. The next table shows the
oscilloscope settings for Low Speed and Full Speed signals for the supported instruments.

Upstream Setups for Low Speed signals

Ch. Vertical SetupPos. Scale Horizontal Trigger SetupTrigger Logic Pattern Repeat
Offset Coupling SetupRecord Main Threshold Trigger type function limit ~ State
Trigger length scale mode
pos.
Ch1(D-) 0 1V 0 DC 5000 2.00 74%  Logic AND >100ns 800mV Nor- Off
E-07s mal
Ch2(D+)0 1V 0 DC N/A N/A N/A N/A N/A N/A 800mV N/A  N/A

Ch3Quald 1V 0 DC NA NA NA NA NA NA 27V NA NA
ify

Upstream Setups for Full Speed Signals
You can test the Full Speed devices at Tier 6. This testing is also known as legacy testing.

When Full Speed and Low Speed device are High Speed capable, the application uses the signal rate limits
of Full Speed/Low Speed devices which are not High Speed capable to determine PASS or FAIL.

Ch. Vertical SetupPos. Scale Horizontal Trigger SetupTrigger Logic Pattern
Offset Coupling SetupRecord Main Threshold Trigger type function Re-

Trigger length scale limit mode peat
pos. State

Ch1(D-) 0 (% 0 DC 5000 25 83%  Logic AND  >100ns 800mV Nor- Off

E-9s mal

Ch2(D+)0 % 0 DC N/A N/A N/A N/A N/A N/A 800mV N/A N/A

Ch3 0 (% 0 DC N/A N/A N/A N/A N/A N/A 27V N/A NA

Qual-

ify
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Downstream Setups for Low Speed Signals

Ch. Vertical SetupPosition Scale Offset Horizontal SetupRecord Trigger SetupTrigger
Coupling Main Trigger length scale Slope Threshold Trigger
pos. type mode
Ch1(D-) 0 i\ 0 DC 2500 5.00 6% Edge Rise 165V  Nor-
E-07s mal
Ch2(D+) 0 i\ 0 DC N/A N/A N/A N/A N/A 800mvV  N/A

Downstream Setups for Full Speed Signals

Ch. Vertical SetupPosition Scale Horizontal Trigger SetupTrigger Slope
Offset Coupling SetupRecord Main Threshold Trigger type mode Re- Hold

Trigger length scale peat  Off
pos. State  State

Ch1 -1.5 1V 0 DC 5000 500 5% N/A N/A N/A N/A N/A 5s

(D-) E-9s

Ch2 -15 1V 0 N/A N/A N/A N/A Edge Rise 1.65V Nor-  Off N/A

(D+) mal

Upstream Setup for High Speed Signals

Probe Function External Attenuation 1.0

Ch. Vertical Horizontal SetupRecord Main Trigger SetupTrigger Re- Hold  Dis-
SetupPosition Scale Trigger Fit to Length scale Threshold peat  Off play
Offset pos. screen TriggerType mode State Mode Mode

Dif- 0 01V 0 20000 2.00 10%  On Edge 176mV Nor-  Off 120 Sin(x)/x

fer- E-07 mal E-06s

en-

tial

Inrush Setup

Vertical SetupPos. Scale Offset Horizontal Trigger SetupTrigger Slope
Coupling SetupRecord Main Threshold Trigger type mode Dis- Hold
Trigger length scale play Off
pos. Mode Mode
-3 1A 0 DC 200000 20.00E-0310% Edge Rise mA Nor- Sin(x)/x 100
20 mal E-09
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Settings for the supported Instruments

Droop Setup
Ch. Vertical SetupPos. Scale Offset Horizontal Ac-
Coupling SetupRecord Main qui-
Trigger length scale Dis- si-
pos. Trigger SetupTrigger play tion
Slope Threshold type Mode Mode
Ch1 2 200mV 5 DC 5000  2.00 50% N/A N/A N/A N/A Av-
(Vbus) E-05 er-
age
16
Points
Ch2 -3 2V 0 DC N/A N/A N/A Edge Rise 25V Sin(x)/x N/A
Droop
Trig-
ger
load
Chirp Device EL_28, EL_29, EL_31 Setup
Ch.  Vertical SetupPos. Scale Horizontal Trigger SetupTrigger Slope
Offset Coupling SetupRecord Main Threshold Trigger type Re- Dis-
Trigger length mode peat Hold play
scale pos. State Off Mode
Ch1 -34 5V 0 DC 5000 4.00E-046% Edge Fall 1.35V Nor-  Off 1.00  Sin(x)/x
(D+) mal E-04
Ch2 -34 5V 0 DC NNA- NA NA NA NA NA NA NA NA NA
(D-)
Chirp Host EL_33, EL_34 Setup
Ch. Vertical SetupPos. Scale Horizontal Trigger SetupTrigger
Offset Coupling SetupRecord Main Slope Threshold Trigger Re- Dis-
Trigger length scale type mode peat Hold play
pos. State Off Mode
Ch1 -34 5V 0 DC 5000 4.00E-04 5% Edge Fall 135V Nor- Off 1.00  Sin(x)/x
(D+) mal E-04
Ch2 -34 5V 0 DC N/A  NA NNA NA NA NA NA NA NA NA

(D)
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Chirp Host EL_35 Setup

Ch.  Vertical SetupPos. Horizontal Setup Trigger Setup
Scale Offset Coupling Record Main Trigger Trigger Polarity Re- Dis-
length scale pos. Threshold Trigger peat Fil- Hold play
type Mode State Widthter Off Mode
Cht -340 5V 0 DC 12500 1.00E-03 10 Edge Fall  1.35VNor- Off 9.0E-9Ac- 5.00 Sin(x)/x
(D+) % mal cept E-5
Ch2 -34 5V 0 DC NA NA N/A N/A- NA NA NA NA NA NA NA NA
(D-)
Suspend Setup
Vertical Setup Horizontal Setup Trigger Setup
Ch. Pos Scale Offset Cpling Reclen Mainscale Trigtype Slope Threshhold Re- Hold Dis-
Trigpos Trigmd peat  Off play
State Mode
Cht -296 .5V 0 DC 20000 4.00E-000% Edge Rise 269V Nor-  Off Auto  Sin(x)/x
(D4) mal

Ch2 172 5V 0 DC NA~ NA NA NA NA NA NA NA NA NA
(D7)

Resume Setup

Vertical Setup Horizontal Setup Trigger Setup
Ch. Pos Scale Offset Cpling Reclen Mainscale Trigtype Slope Threshhold Re- Hold Dis-
Trigpos Trigmd peat Off play
State Mode
Ch1  -340 .5V 0 DC 50000 2.00E-0510% Edge Fall  0.690V Nor-  Off 1.00  Sin(x)/x
(D+) mal E-5

Ch2 -340 5V 0 DC N/A~ N/A NA - NA NA NA NA NA NA NA
(D7)

Reset from High Speed

Vertical Setup Horizontal Setup Trigger Setup
Ch. Pos Scale Offset Cpling Reclen Mainscale Trigtype Slope Threshhold Re- Hold Dis-
Trigpos Trigmd peat  Off play
State Mode
Ch1  -340 .5V 0 DC 25000 1.00E-0¥0% Edge Fall  0.690V Nor-  Off 1.00  Sin(x)/x
(D+) mal E-5

Ch2 -340 5V 0 DC NA NA  NA NA NA NA NA NA NA NA
(D)
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Reset from Suspend

Vertical Setup Horizontal Setup Trigger Setup
Ch. Pos Scale Offset Cpling Reclen Mainscale Trigtype Slope Threshhold Re- Hold- Dis-
Trigpos Trigmd peat Off play
State Mode
Cht  -340 5V 0 DC 50000 1.00E-0315% Edge Fall 1.8V Nor-  Off 1.00  Sin(x)/x
(D+) mal E-5

Ch2 -340 5V 0 DC NA NA NA NA NA NA NA NA NA NA
(D)

Packet Parameter

Vertical Setup Horizontal Setup Trigger Setup
Ch. Pos Scale Offset Cpling Reclen Mainscale Trigtype Slope Threshhold Re- Hold Dis-
Trigpos Trigmd peat Off play
State Mode
Cht 00 02v 0 DC 50000 50 50 Width Fall ~ 360E-3 Nor-  Off 1.00  Sin(x)/x
(D+) mal E-5

cCh2 00 02V 0 DC NA NA NA NA NA NA NA NA NA NA
()

About Application Parameters

This section describes the TDSUSB?2 application parameters, and includes the menu default settings. You
should refer to the user manual for your oscilloscope for operating details of other controls, such as
front-panel buttons. The parameters for the menus and options list the selections or range of values
available for each, and include the default values.

See Also

® File Menu Parameters

m Save and Recall Menu Parameters
B Preferences Parameters

B Measurement Menus

B Configure Signal Quality

B Configure Inrush Current

®  Configure Droop

B Results
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= Utilities

® Control Menu

File Menu Parameters

There are no parameters for the File menu items.

Save and Recall Menu Parameters

There are no parameters for the Save and Recall menu.
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Preferences Parameters

Parameters Selections Default Setting

Warn if the configuration was not On, Off On
changed since last run, when Run
button is pressed

Show the Eye Diagram automatically, On, Off On
without having to press the Eye
Diagram button in the Results screen

Show the Waveform Plot automatically ~ On, Off On
without having to press Waveform Plot
button in the Results screen

Ask for Filename or Device ID before On, Off Off
automatically generating Reports or

Data files

Automatically generate Data files On, Off Off
(TSV)

Show the report when generated On, Off On
Always display the waiver mask for On, Off Off

High Speed Near-end and Low Speed
Eye Diagrams

Do Autoset Every Time On, Off On

LS or FS device with USB2.0 silicon On, Off Off
Allow the user configuration of test On, Off Off
limits

Prompt for the Droop Test readout On, Off Off
during Report Generation

Packet identification by user using On, Off Off
cursors

Modify HoldOff 250 nsto12s 1.2 us

Measurement Menus

The options available under the Measurements menu are as follows:
m Select

= Configure

Measurement Parameters

The next table lists the options in the Select Measurements menu by area:
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Parameters

Selections

Measurement Parameters

Default Setting

Low Speed

Eye Diagram
Signal Rate

EOP Width

Rising Edge Rate
Falling Edge Rate
Cross-Over Voltage
Consecutive Jitter
Paired JK Jitter
Paired KJ Jitter
Inrush Current
Droop test

None

Full Speed

Eye Diagram
Signal Rate

EOP Width

Rising Edge Rate
Falling Edge Rate
Cross-Over Voltage
Consecutive Jitter
Paired JK Jitter
Paired KJ Jitter
Inrush Current
Droop test

Eye Diagram

High Speed

Eye Diagram

Signal Rate

EOP Width

Rising Edge Rate
Falling Edge Rate
Monotonic Property
Chirp

Receiver Sensitivity
Inrush Current
Droop test

Packet Parameter
Suspend

Resume

Reset from High Speed
Reset from Suspend

None

Device ID

User defined or fsfe_001

fsfe_001

Device Description

User defined or Dummy Device

Dummy Device
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Configure Menu

Configure Menu

You can configure the parameters for the selected measurements. The configurations for the Signal Quality,
Inrush, and Droop tests are available as different menus.

See Also

B Configure Signal Quality Measurements Parameters

B Configuring Droop Measurements

m  Configuring Inrush Current Measurements

Configure Signal Quality Measurements Parameters

Configure
Parameters Selections Default Setting
Tier Tier 1, Tier 2, Tier 3, Tier 4, Tier 5, Tier 6
Tier 6
Direction Upstream, Downstream Upstream
Test Point Near End, Far End Far End
Source
Parameters Selections Default Setting
Live/Ref Differential Ch1, Ch2, Ch3, Ch4 Ch1
Ref1, Ref2, Ref, Ref4
Live/RefSingle Ended D+ Ch1, Ch2, Ch3, Ch4 Ch1
Ref1, Ref2, Ref, Ref4
Single Ended D- Ch1, Ch2, Ch3, Ch4 Ch2
Qualifier Ch1, Ch2, Ch3, Ch4 Ch3
Ref1, Ref2, Ref, Ref4
File None C:\TekApplications\tdsusb2\tsv-

files\FS_SQC.tsv
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Configure Inrush Current Measurement Parameters

Configure Inrush Current Measurement Parameters

Configure
Parameters Selections Default Setting
Tier None Tier 1
Vbus Range 515V
Device Type Hot Plug Attach, Low Power Configure Hot Plug Attach
Low Power Resume, High Power
Configure, High Power Unconfigure,
High Power Resume
Source
Parameters Selections Default Setting
Live/Ref Ch1, Ch2, Ch3, Ch4Ref1, Ch4
Ref2, Ref, Ref4
File None C:TekApplications\tdsusb2\tsv-

files\LS_INRUSH.tsv

Configure Droop Test Parameters

Configure
Parameters Selections Default Setting
Port Port 1, Port 2, Port 3, Port 4, Port 5, Port 1
Port 6, Port 7
Device Type Self Powered Hub Bus Powered Hub

Bus Powered Hub
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Configure Receiver Sensitivity

Source
Parameters Selections Default Setting
Live/Ref Ch1, Ch2, Ch3, Ch4 Ch1
VBUS channel Ref1, Ref2, Ref, Ref4 Ch2
Trigger Ch1, Ch2, Ch3, Ch4

Ref1, Ref2, Ref, Ref4

Ch1, Ch2, Ch3, Ch4
File None C:\TekApplications\tdsusb2\tsv-

files\FS_SQC.tsv
VBUS source Ch1, Ch2, Ch3, Ch4 Ch1
Configure Receiver Sensitivity

Parameters Selections Default Setting
Source Ch1, Ch2, Ch3, Ch4 Ch1

Configure Suspend, Reset from High Speed, Resume, Reset from

Suspend
Parameters Selections Default Setting
Signal Direction Upstream, Downstream Upstream
Source D+ Ch1, Ch2, Ch3, Ch4 Ref1, Ref2, Ch1
Ref3, Ref4 D-Ch2, Ch3, Ch4 Ref1, Ch2
Ref2, Ref3, Ref4
Configure Packet Parameter
Parameters Selections Default Setting
DUT Host, Device Host
Host EL_21,EL_23,EL 25EL_55EL 22 EL 21, EL_23,EL_25
Source Ch1, Ch2, Ch3, Ch4 Ref1, Ref2, Ref3,  Ch1
Ref4
Device EL_21,EL_22, EL_25EL 22 EL 21, EL_22,EL_25
Source Ch1, Ch2, Ch3, Ch4 Ref1, Ref2, Ref3,  Ch1

Ref4
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Configure Chirp
Parameters Selections Default Setting
DUT Host, Device Host
Host EL_33,EL_34 EL_35 EL_33, EL_34
Source D+-Ch1, Ch2, Ch3, Ch4 Ref1, Ref2, Ch1
Ref3, Ref4 D--Ch2, Ch3, Ch4 Ref1, Ch2
Ref2, Ref3, Ref4
Device EL_28, EL 29, EL_31 EL 28, EL 29, EL_31
Source D+-Ch1, Ch2, Ch3, Ch4 Ref1, Ref2, Ch1
Ref3, Ref4 D—Ch2, Ch3, Ch4 Ref1, Ch2

Ref2, Ref3, Ref4

Results Menus

There are no parameters for the Results Menus.

Utilities Menus

There are three Utilities menu items:
m Deskew
®m  Report Generator

m TSV File Generator

Deskew
Parameters Selections Default Setting
Source1 Ch1, Ch2, Ch3, Ch4 Ch1
Ref level1 Hysteresis1 0-100 % 50%
0-25% 5%
Source2 Ch1, Ch2, Ch3, Ch4 Ch2
Ref level2 Hysteresis2 0-100 % 50%
0-25% 5%
Slope Rise, Fall Fall
Edges 1to 50 1
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Report Generator Menu Parameters

Report Generator Menu Parameters

Parameters Selections Default Setting
Report Format Tektronix specific, Plug-Fest format, Tektronix specific
CSV format
Generation Automatic, Manual Manual
File name fsfe_001-tek.htm C:\TekApplications\tdsusb2\re-
port\fsfe_001-tek.htm
Report Directory None C:\TekApplications\tdsusb2\report

TSV File Generator Menu Parameters

Parameters Selections Default Setting
Input CSV, Live C:\TekApplications\tdsusb2\csv
files\csvFile001.csv
CSV Waveform Source Single-Ended Single-Ended
(D+ C:\TekApplications\tdsusb2\tsvfilegen-
D-) erator\Dplus.csv
Differential C:\TekApplications\tdsusb2\tsvfilegen-

erator\Dminus.csv

C:\TekApplications\tdsusb2\tsvfilegen-
erator\Differential.csv

TSV File name

TSV Source File

C:\TekApplications\tdsusb2\tsvfilegen-
erator\TsvFile001.tsv

Help Menu

Control Menu Parameters

174

Help Topics - Displays the help file for the TDSUSB2 application.

About TDSUSB2 - Displays a dialog box with information about the current TDSUSB2 application.

Parameters Selections
Run None
Hide None
Exit None
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About Measurement Algorithms

The TDSUSB2 package performs measurements for USB2.0 compliance. This section contains
information about the algorithms used by the application to perform each measurement.

See Also

B CrossOver Voltage for Low Speed and Full Speed Signals
B CrossOver Voltage for High-Speed Signals
® Signal Rate

B EOP Width Calculation

® Consecutive and Paired Jitter

® Eye Diagram

= Eye Violation

B Inrush Current

® Droop Measurement

B Receiver Sensitivity Test

®  Chirp Test for a Device

®  Monotonic Property

B Rising Edge Rate

m Falling Edge Rate

B Packet Parameter

® Resume

®  Suspend

B Reset from Suspend

B Reset from High Speed

Cross-Over Voltage for Low Speed and Full Speed Signals

You can define the Cross-Over point as the point where the Data+ line voltage crosses the Data— line
voltage. The voltage value at this point is called the Cross-Over Voltage and the time value is called
the Cross-Over time.
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In the next figure, C1, C2, C3, C4 and C5 are called Cross-Over Points and R1, R2, R3, R4, R5, R6 and R7
are called Reference points.

I
’ -Cro*]aawer[c:-:}
» -Reférance Cross-over Point (Ry) +—EOP —

|

L Bus Idie

D+

= » Ca C4  JCs | o hEan
R1 Rz R4 R5 Rel R7 RE RT Cross over
Lawvel
: it
ey l =
LOW SPEED / FULL SPEED SIGNAL TIME ——+

The following figure explains the interpolation technique used to find the actual cross over where pl and
p2 are the adjacent data points after q2:

Data

Data

t1 2

The intersection of the four voltage points p1, p2, q1, and g2 gives the Cross-Over point for Voltage level
(y) and time (x). x and y coordinates are obtained by solving the following two equations:

(pl=y)i(x—t1) = (pl-p2)i(t2—11)
(g2-y)ite—x)=iga—gql)/(z2 1)

Where:
pl, p2, ql, and g2 are the consecutive data points of a single-ended signal.

x and y are the Cross-Over coordinates x and y that is given by the intersection of p1, p2, q1, and q2.
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tl and t2 are the time values for the data points p1l and p2.

Cross-Over Voltage for High-Speed Signals

The Cross-Over is defined as that point where the Differential line voltage becomes zero. The voltage
value at this point is called the Cross-Over Voltage and the time value is called the Cross-Over Time.

e

0 level

t1 t2

The following algorithms are used for High Speed signals for Cross-Over voltage.

(P2-y)/E2-x)=(p2- plHi(f2-t1)
v=>0

for High Speed y=0
If,

rlzpl
x= (21— plE2y(p2 - pl)

If,

9

pl=p2
x=(1+£2)/2

Where:

pl and p2 are the consecutive data points of a single-ended signal.
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x and y are the coordinates of the point where the Differential line voltage becomes zero.

tl and t2 are the time values for the data points p1 and p2.

NOTE. Low Speed and Full Speed Signals are acquired with single-ended probes that enable finding
the Cross-Over Voltage.

NOTE. For High Speed devices, the signal is differential, Cross-Over voltage is zero and crossover time is
the interpolation of two data points at zero crossings.

Signal Rate

You can define the signal rate for Low or Full speed signals as the inverse of the average bit time that gives
the transmission rate of the USB2.0 signal. For high speed signals, the signal rate is defined as the inverse
of the average bit time that gives the transmission rate of the Test Packet.

I
’ -Cro*]aawer[c:-:}
» -Reférance Cross-over Point (Ry) +—EOP —

L Bus Idie

D+

| g Mean
RT Cross over
Lawvel

VOLTAGE ———

LOW SPEED / FULL SPEED SIGMAL TIME ——+
The average signal rate is the calculated average of number of bits divided by sum of all periods.

fastgossee S Weights

AveraseSigifatie =
genet = SumlPeriod

BitTime =02 - (1
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Where:

SumWeights is the total number of bits in the packet.

SumPeriod is the sum of all time periods between the cross overs.
C1 and C2 are the Cross-Over points.

Bit time is the difference of the time values of C2 and C1.

EOP Width Calculation

You can define the EOP width for Low or Full speed signals as the width of the end-of-packet of
a USB2.0 signal. For high speed signals, it is defined as the width of the end-of-packet pattern of a
Test Packet.

I
.- l::rofs over (Cx)
» -Reférence Cross-ovar Point (Rx) —EOP —
Ds | f \ __BusIdie
a1 JC2 Ca Cq  JdC5 | Mean
R1 Rzl R3] R4  Ra Rel R7 RE RTi Crogs over
Leve|
; -t
S - | | o
|
LOW SPEED / FULL SPEED SIGMAL TIME ——

EOP Width is calculated as shown below.

EOQOPWidth = (EOF2 - EOFI)

Where:

EOP1 and EOP?2 are the data points on a USB2.0 signal crossing the Mean Cross-Over level. The
Cross-Over level is the mean value of all crossovers in the USB2.0 packet.
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Consecutive and Paired Jitter

You can test two types of Jitter measurements: Consecutive and Paired Jitter. Consecutive jitter measures
the consecutive data bit calculated using the signal rate.

|
. -l::ro?swer[c:-:}
» -Reference Cross-over Point(Rx) — EOP —

. Bus Idi=

D+

S | R Lol Nean
R3] Ra RTi Cross over
Lewe|
g D- I =
[
LOW SPEED / FULL SPEED SIGNAL TME ——

Consecutive jitter is calculated as follows.
Con secrfiveJitter[1] = 1 -1

ConsectitiveJitta{2] = R2- 2

Consecttiveifte] 3] = R3-C3

Consecutivefitta{d] = R4- C4

Where: C1, C2, C3, and C4 are the Cross-Over points.

R1, R2, R3, and R4 are the reference points.

Consecutive jitter is the difference between the time values at Rx and Cx.
Consecutive jitter is calculated for all Cross-Overs of the USB2.0 signal.

Paired JK Jitter is defined as the jitter time for paired (JK next to KJ) differential data transition. Paired
K1 lJitter is defined as the jitter time for paired (KJ next to JK) differential data transition. They are
calculated for all the consecutive jitters as:
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PairedJEjtter[1] = CosectitiveJitta] 2] - Consecutiveittal 4]

Paired it 2] = ConsectitiveJitta{1] - Consecutive Jitta] 3]

and so on till the last Cross-Over.

Eye Diagram

The Eye Diagram checks whether the USB signal is aligned with its corresponding eye diagram. It
represents the whole signal by splicing it into a number of waveforms of unit interval (each waveform is
of one bit time interval) scaled and represented on the eye masks.

oo EIEN e HEN CIEED 0 MM

oo nz LE] Lel] oA i 132
- Time: xi0®-3h=

Eye Violation

An eye violation occurs when an USB signal crosses an eye mask. The results of the eye violation are PASS
if the waveform does not violate the eye masks. The result is FAIL if the waveform violates the Eye Masks.
The result is CONDITIONAL PASS if the waveform violates the eye mask, but is within the waiver mask.

By default, the application displays the waiver mask if the result is either CONDITIONAL PASS or FAIL.
If you select the option "Always show the waiver mask in the eye diagram" in File> Preferences menu, the
waiver mask is displayed irrespective of the result.
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Inrush Current

182

Inrush Current is calculated by recording all the current values above the 100 mA current level throughout
the signal. This signal is integrated to get the total charge greater than 100 mA for all inrush regions in the
signal. This is the charge in Coulombs and is calculated using the integral of:

idt
Where:

11s the current waveform above 100 mA.

Fle  Ede  Weshoal Honzdbcg  Ing [Display Cuesoes Measue Math Lbike: Help
0 AGHs

Capacitance is calculated by using the equation:

O=CV

Where:

C is the capacitance.
Q is the charge.

V is the voltage.

The supply voltage is one of the inputs to Inrush measurement.

Measurement Method

Inrush current is measured for a minimum of 100 milliseconds after attach. Attach is defined as voltage
rising to a valid level on the peripheral’s USB power line. Any current exceeding 100 mA during the

100 ms interval is considered part of the inrush current event. The inrush current is divided into regions. A
region is an interval where the current exceeds 100 mA until the time the current falls below 100 mA for at
least 100 ps. There can be multiple inrush regions during the 100 ms period. Pass/fail is determined by
the region having the highest charge.
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Multiple Regions

A region starts when the current rises above 100 mA and ends when the current is below 100 mA for at
least 100 ps. There may be multiple regions during the 100 ms period. The analysis tool calculates the
charge above 100 mA in each region. The charge of each region is listed in the report. Pass or fail is based
on the region with the largest charge.

Minimum Sample Rate

A minimum sample rate of 1 mega samples per second is required for proper analysis. If the sample rate
is below this value, the program still performs the analysis but will record an error indicating that the
sample rate is too low (E504).

Record Length

A record length of 100 ms or more after the first inrush event is required for the measurement. If the data
record is less than 100 ms, the result will be a failure because of insufficient measurement time.

If the oscilloscope does not have sufficient memory to capture 100 ms of data, then the inrush test will need
to be divided into 30 ms segments. Each time the inrush test is performed, the trigger should be delayed to
capture the next segment. Use USBET to analyze each inrush segment. Repeat until all segments covering
at least 100 ms of inrush data are examined. Each and every individual inrush segment must pass. A
failure in one of the inrush segments consitutes an overall failure.

No Inrush Event Found

If there is no inrush event found, i.e. the current never rises above 100 mA, the result is considered a Pass.
However, the inrush current test should be repeated several times to ensure an accurate measurement.

Droop Test

Droop voltage is the difference between the Vpys value when the droop load is off and the lowest voltage
of the Vpys value when the droop load is powered on.

DroopValtage =VoltageValue 00— LowestVoltage 10,

Receiver Sensitivity Test

You can test the Receiver sensitivity of a high speed device to respond to the particular data pattern
generated by the digital signal generator. Receiver Sensitivity responds whenever the data pattern level of
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the voltage level is greater than 150 mV and does not respond when the voltage level is equal to or less
than 100 mV below the squelch level. The application provides the procedural steps to this test.

File  Edt  “ertical Horzddcg  Trg  Display  Cursors bMeagure  Math  Utiliies  Help

Curs1 Pos
150.0m'

Curs? Pos

-150.0m

See Also

B View Procedural Steps from the Application

Chirp Test for a Device

This test examines the basic timing and voltages of both upstream and downstream ports during the speed
detection protocol. To get the Chirp signal, hot-plug the unit under test (device) and measure the signalling
with single-ended probes on both lines. The application analyzes data for the following:

®  Reset duration
B Chirp-K amplitude
B Chirp-K duration

Tek  Stopped
oo
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NOTE. There must be three K-J pairs after chirp-K that are less than 500 us. This is to check the response
of the device. The response time must be less than 100 us. You can verify this manually.

Host Chirp Test

This test examines the basic timing and voltages of both upstream and downstream ports during the speed
detection protocol. To get the Chirp signal, hot-plug the unit under test (Host) and measure the signalling
with single ended probes on both lines. The application analyzes data for the following:

®m  Chirp Response Timing
B Chirp-K and Chirp-J duration
The application analyzes data for the Chirp J/K to first SOF Time.

Monotonic Property Test

This algorithm calculates the number of monotonic violations that are present from of the start of the signal
to the end of packet (EOP). For the signal to be monotonic, the signal is checked from 15% to 85% of
the Peak to Peak differential signal levels or user specified levels.

Monotonicity is calculated for Rising and Falling slopes as follows:

For Rising slope, f(x) is a differential signal if]

Jle+l) 2 f(x)

signal is monotonic for all values of x till the last data point.

For Falling slope, f(x) is a differential signal if

Jle+D) = f(x)

for all values of x till the last data point.
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Rising Edge Rate

The Rising Edge Rate in V/us is calculated using the following equation:
Rising Edge Rate = Amplitude/Rise Time
Where:

Amplitude is the difference between the positive and negative thresholds that vary for each of the signaling
rates.

Rise time is calculated using the higher level of the inner vertical eye height reference levels and is
~80% of the signal amplitude.

This is applicable both to differential and single-ended waveforms.

Signaling Rates Positive Threshold Negative Threshold
LS 2.8 Vlus 0.4 Vlus

FS 2.5 Vlus 0.8 Vlus

HS 0.175 Vs -0.175 Vlys

Falling Edge Rate

The Falling Edge Rate in V/us is calculated using the following equation:
Falling Edge Rate = Amplitude/Fall Time
Where:

Amplitude is the difference between the positive and negative thresholds that vary for each of the signaling
rates.

Fall time is calculated using the Lower level of the inner vertical eye height reference levels and is ~20%
of the signal amplitude.

This is applicable both to differential and single-ended waveforms.

Signaling Rates Positive Threshold Negative Threshold
LS 2.8 Vs 0.4 Vius

FS 2.5 Vlus 0.8 Vius

HS 0.175 Vs -0.175 Vlys
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Packet Parameter

The algorithm calculates the SYNC field length, EOP length, and the Inter-Packet gap. The acceptable
range of EOP for all transmitted packets (except SOFs) must be between 7.5 and 8.5 bits. The packet
parameter algorithm calculates and verifies the EOP depending on this range.

The acceptable range of inter-packet gap should be between 88 bits to 192 bits. The SYNC field for all
transmitted packets is calculated by counting the bits to check for 32-bit SYNC field. The inter-packet
delay and SYNC status is calculated between the respective EOP indexes of the packets. The EOP width
in time is calculated by dividing the EOP width by the signalling rate of 480 Mbps.

Oscilloscope setup details:

The application sets the oscilloscope automatically to the following values:
®  Horizontal Scale: 400 ns

m  Record Length: 50 K

B Vertical Scale: 200 mV

B Trigger Type Pulse Width

m  Trigger Hold Off: 5s

Resume

This test calculates the device/HUB resume High-speed operation, indicated by High-speed SOF packets
(with 400 mV nominal amplitude) following the K state driven by the host controller. For the Host, this is
the time between the falling edge of D+ and the First SOF. This should not exceed 3.0 ms. To get the
Suspend signal, hot-plug the unit under test (device) and measure the signaling with single-ended probes
on both lines. The application analyzes data for the following:

®  Resume Time

m  Amplitude
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Suspend
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This test calculates the time between the end of last SOF and the rising edge transition to Full-speed J state
for Host / Device / Hub- upstream. This time must be between 3 ms and 3.125 ms. To get the Suspend
signal, hot-plug the unit under test (device) and measure the signalling with single-ended probes on both
lines. The application analyzes data for the Suspend Time.
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E%Flﬂmrl Preview e 5 Il:llll

Bus-Powered Droop Test Results for fafe_001

For details on test setup, melodolocy, and germarmance Criteria, please consull e Bus-Droog
L2 s requIrg mencs [EST deSCrRtan at the Ripitweee. 0 boorgidevel ape rsieom plia n_testing him | USB-IF
Camglizhce Program web page

‘Required Tests

* roop Test Result Fass
» Droop Yoltage = 16.00000my
® USE Limits = <330k

Droop value measured at: Fort 1 of HUT

tEsting Scrpt versian: 066

Fiint Cloze

Fage Frint
Zatu Frawiam

Reset from Suspend

This test calculates the time between the falling edge of D+ signal and the start of Device chirp-K for
the Device/HUB upstream. This must be between 2.5 us and 3 ms. To get the Reset from Suspend
Measurement signal, hot-plug the unit under test (device), and measure the signaling with single-ended
probes on both lines. The application analyzes data for the Reset From Suspend Time.

Tek Sopped 0 dos 17Feh 04 11:4750
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Reset from High Speed

This test calculates the time between the beginning of the last SOF and before the reset and the beginning
of Chirp-K for Device and HUB upstream. This must be between 3.1 ms and 6 ms. To get the Reset from
High-Speed Measurement signal, hot-plug the unit under test (device) and measure the signaling with
single-ended probes on both lines. The application analyzes data for Reset From High Speed Time.

R I 3T

Bus-Powered Droop Test Results in Tek format :
Dievice [D: fsfe_001
Device Description: Ful Speed |, Dummy Device,
Date! Thu Sep 27 2004332 GMT+05:30 2001

Croofy Test Result: Pass

Mleasurement Mame |Measured Dlr\-bup voltage |USE Limits | Status

Lo Test 16 L0000y <330my A
Droop value measured at: Fort 1 of HUT __
Tok frnmniw: ]

Fage Fiint ol
Saiup P rawigm ik

Low Speed Downstream Signal Quality Host Equipment Setup
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To set up the equipment for Low Speed Downstream Signal Quality test, follow these steps:

1. Connect a cable between the A receptacle from the Inrush test section of the test fixture and the
USB device.

2. Connect Chl of the D+ probe to the D+ pins on the Inrush section of the test fixture.

3. Connect Ch2 of the D— probe to the D— pins on the Inrush section of the test fixture.

4. Use the connectors to connect the A pin dongle from the Inrush section of the test fixture to any
port of the unit under test (host or PC).

5. Select the measurement and select the * command button to run the application.

6. Select OK after acquiring a waveform. Verify that it is a correct waveform.
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If the signal is clipped, follow these steps to increase the vertical scale:
1. In the oscilloscope menu, select Vertical>Vertical Setup to display the Channel screen.

2. In the Scale field, increase the vertical scale values until the waveform is completely displayed on

screen.
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Microsofl Windows 2000 PC with Application running
| OHCI Port Unit Under Test ‘ @O0
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I 1
[ ] et
[a]
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Low Speed Signal Quality for HUB Downstream

To set up the equipment for Low Speed Signal Quality (hub) test, follow these steps:

1. Connect the A plug dongle from the Inrush section of the test fixture to the port of the unit under
test (hub).

2. Connect the low speed test device to the A receptacle on the Inrush section of the test fixture. Keep
the Discharge switch always in the ON position.

3. Connect Chl of the D+ probe to the D+ pins on the Inrush section of the test fixture.

4. Connect Ch2 of the D— probe to the D— pins on the Inrush section of the test fixture.

5. Configure the measurement and select the & command button to run the application.
6. Select OK after acquiring a waveform. Verify that it is a correct waveform.

If the signal is clipped, follow these steps to increase the vertical scale:
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1. In the oscilloscope menu, select Vertical>Vertical Setup to display the Channel screen.

2. In the Scale field, increase the vertical scale values until the waveform is completely displayed on

screen.
Tektronix Cscillescope
Microzafl Windows 2000 PC Mesar End with Application running
] Test Device
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Hub 1 —1
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Hub 3 1 % : Woltage probes
Hub & I Test fixture
- =L
i Unit Under Test
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Full Speed Signal Quality HUB Downstream Setup

To set up the equipment for Full Speed Signal Quality Downstream test, follow these steps:
1. Set the S6 switch to the Init position.

2. Use the adapters to connect the A receptacle from Device SQ test section (marked DUT) of the
test fixture to the USB2.0 Low Speed device.

3. Connect Chl of the D+ probe to the D+ pins on the Device SQ section of the test fixture.
4. Connect Ch2 of the D— probe to the D— pins on the Device SQ section of the test fixture.

5. Connect the Init port of the Device SQ section of the test fixture to any port of the unit under test
(hub) using the USB cable.

6. Select the measurement and select the * command button to run the application.

7. Select OK after acquiring a waveform. Verify that it is a correct waveform.

192 TDSUSB?2 Universal Serial Bus Measurements Package



Reference Full Speed Downstream Host Equipment Setup

NOTE. Make sure the acquired signal is a valid waveform.

If the signal is clipped, follow these steps to increase the vertical scale:
1. In the oscilloscope menu, select Vertical>Vertical Setup to display the Channel screen.

2. In the Scale field, increase the vertical scale values until the waveform is completely displayed on

screen.
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Full Speed Downstream Host Equipment Setup

To set up the equipment for Full Speed Downstream (host) test, follow these steps:
1. Set the S6 switch to the Init position.

2. Connect the A receptacle from Device SQ test section (marked DUT) of the test fixture to the hub
system. Connect the Full Speed test device to Hub 5.

3. Connect Chl of the D+ probe to the D+ pins on the Device SQ section of the test fixture.
4. Connect Ch2 of the D— probe to the D— pins on the Device SQ section of the test fixture.

5. Use the standard USB cable to connect the Device SQ section of test fixture to the test port of the
unit under test (host).
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6. Select the measurement and select the w command button to run the application.
7. Select OK after acquiring a waveform. Verify that it is a correct waveform.

If the signal is clipped, follow these steps to increase the vertical scale:

1. In the oscilloscope menu, select Vertical>Vertical Setup to display the Channel screen.

2. In the Scale field, increase the vertical scale values until the waveform is completely displayed on

screen.
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Full Speed Upstream Signal Quality Setup

To set up the equipment for Full Speed Upstream test, follow these steps:
1. Use the A receptacle to connect the USB unit under test (device) to the Inrush section of the test fixture.

2. Connect the Qualifier device to the Adjacent Trigger and Droop section of the test fixture as shown in
the next figure.

3. Connect Chl of the D+ probe to the D+ pins on the Inrush section of the test fixture.
4. Connect Ch2 of the D— probe to the D— pins on the Inrush section of the test fixture.

5. Connect the D+ (D- for Low speed) pin of the Adjacent Trigger and Droop Section of the test fixture
to Ch3 as shown in the next figure.
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6. Use the connectors to connect the A pin dongle from the Adjacent Trigger and Droop section of
the test fixture to one port of Hub 5. Use the A pin dongle from the Inrush Droop section of the

test fixture to another port of Hub 5.

Full Speed Upstream Signal Quality Setup

7. Select the measurement and select the * command button to run the application.

8. Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. Use the standard USB cables to connect between the hubs. Keep the Discharge switch in the

Inrush Droop section in the ON position.

If the signal is clipped, follow these steps to increase the vertical scale:

1. In the oscilloscope menu, select Vertical>Vertical Setup to display the Channel screen.

2. In the Scale field, increase the vertical scale values until the waveform is completely displayed on

screen.
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High Speed Device Signal Quality Setup

To set up the equipment for the High Speed Signal Quality test, follow these steps:

1. Set the S6 switch to the Init position.

2. Connect the standard USB cable between the Device SQ Init port and the host port.

3. Connect the A receptacle (marked DUT) from the Device SQ test port of the test fixture to the unit
under test (device).

Configure the measurement and select the b command button to run the application.

Place the device in the test mode Test Packet from the host controller.

Set the S6 switch to the test position to isolate the unit under test while maintaining the bus power.

A

Select OK after acquiring a waveform. Verify that it is a correct waveform.

Tekironix oscillozcope
with Application running

Microsoft Windows 2000 PC
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Device Under Test

Chirp Test Equipment Setup

The section used for this device test is Device SQ in the test fixture. To set up the equipment for Chirp
test, follow these steps:
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1. Set the S6 switch to the Init position.

2. Use a standard USB cable with an A plug on one end and B plug on the other end. Connect one end
of the cable to the B socket on the Init port of Device SQ section and the other end to the host port
A socket.

3. Connect the A receptacle from the Device SQ test port to the unit under test (device).

4. Connect the single-ended probes of the oscilloscope to the D+ and D— pins.

5. Select the measurement and select the - 9 command button to run the application.

6. Disconnect and connect the unit under test (device) to the port and observe the chirp signal on the
oscilloscope.

7. Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. 7o avoid false triggering for the chirp signals while operating the test fixture, it is recommended
that you place the switch in the Init position and connect the unit under test. This disables the switch
bounce to the trigger.
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Receiver Sensitivity Setup

To set up the equipment for Receiver Sensitivity test, follow the procedural steps (see page 83) in the

application.
Tekironix oscilloscope
with Application runming
Microsoft Windows 2000 PC k.
[:,I;{:I 0G 20 40
Test mode <
software L
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2. Test fixture
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L
»> Device Under Test

Inrush setup

To set up the equipment for Inrush test, follow these steps:
1. Use the dongle on the Inrush section of the test fixture to connect it to the host system.

2. Connect the current probe between the Vpys loop wire on the Inrush section on the Test fixture and
Chl of the oscilloscope.

3. Select the measurement and select the * command button to run the application.
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4. Connect the unit under test to the A Receptacle of the Inrush section of the test fixture and observe the
Inrush current signal.

5. Select OK after acquiring a waveform. Verify that it is a correct waveform.

NOTE. To avoid the triggering of Inrush signals and false inrush current by the discharge switch, place the
inrush discharge switch in the ON position and hot-plug the unit under test (device). If a valid Inrush
signal is not acquired, use the cursor mode in File > Preferences or setup the oscilloscope to get a valid

waveform.

Tekdronix Oscilloscope

Device Under Test with Application running

Microsoft Windows 2000 PC OO0

OHC Current Probe
I ort
Host Software -I—UBUS Loop Wire
1 1

Test Fxture

Resume Test Equipment Setup

To set up the Device SQ in the test fixture for the Resume test, follow these steps:
1. Set the S5 switch to the Init position.

2. Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.
Connect one end of the cable to the B socket on the Init port of the Device SQ section and the other
end to the host port A socket.
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3. Connect the A receptacle from the Device SQ test port to the unit under test (device).
4. Connect the single-ended probes of the oscilloscope to the D+ and D— pins.

5. Select the Resume measurement in the application, configure its options and select the Run button
to run the application.

6. Select OK after acquiring a waveform. Verify that it is a correct waveform.
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Reset from Suspend Test Equipment Setup
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To set up the Device SQ in the test fixture for the Reset from Suspend test, follow these steps:
1. Set the S6 switch to the Init position.
2. Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.

3. Connect one end of the cable to the B socket on the Init port of the Device SQ section and the other
end to the host port A socket.

4. Connect the A receptacle from the Device SQ test port to the unit under test (device).
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Suspend Test Equipment Setup

Connect the single-ended probes of the oscilloscope to the D+ and D- pins.

Select the Reset from Suspend measurement from the application, configure its options, and select
the Run button to run the application.

Select OK after acquiring a waveform. Verify that it is a correct waveform.
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Suspend Test Equipment Setup

To set up the Device SQ in the test fixture for the Suspend test, follow these steps:

1.
2.
3.

Set the S6 switch to the Init position.
Use a standard length of USB cable with an A plug on one end and a B plug on the other end.

Connect one end of the cable to the B socket on the Init port of the Device SQ section and the other
end to the host port A socket.

Connect the A receptacle from the Device SQ test port to the unit under test (device).

Connect the single-ended probes of the oscilloscope to the D+ and D— pins.
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Reset from High Speed Test Equipment Setup

Select the Suspend measurement, configure its options and select the Run button to run the application.

Select OK after acquiring a waveform. Verify that it is a correct waveform.

Microsoft Windows 2000 PC
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with Application runaing

Single-ended
voltage probes

To set up the Device SQ in the test fixture for the Reset from High Speed test, follow these steps:

1.
2.
3.
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Set the S6 switch to the Init position.

Use a standard length of the USB cable with an A plug on one end and a B plug on the other end.

Connect one end of the cable to the B socket on the Init port of the Device SQ section and the other

end to the host port A socket.

Connect the A receptacle from the Device SQ test port to the unit under test (device).

Connect the single-ended probes of the oscilloscope to the D+ and D— pins.
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6. Select the Reset from High Speed from the application, configure its options and select the Run
button to run the application.

7. Select OK after acquiring a waveform. Verify that it is a correct waveform.
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Packet Parameter Test Equipment Setup

Test Fixture Setup

To set up the test fixture, follow these steps:

1. Set the S5 switch to the Init position.

2. Connect the standard USB cable between the Device SQ Init port and the host port.

3. Connect the A receptacle (marked DUT) from the Device SQ test port to the B receptacle device.
4

Apply the power to the test fixture.
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5. Apply the power to the DUT.

6. Attach the differential probe near the device connector on the test fixture.

Set up the Oscilloscope for High Speed Host

1. Select the measurement and run the application. The application automatically sets the oscilloscope
parameters (Horizontal, Vertical, and Trigger) and displays the message,"Press OK when correct
waveform is acquired”. You can see the SOFs on the oscilloscope screen.

2. Ifyou are not able to acquire the waveform automatically, perform Autosetup in the oscilloscope to
display the SOF.

3. Click here to find out how to adjust the trigger manually.

a. Ifyour DUT is EL 21, EL 23, EL 25, select the Single Step Set Feature option from the
HS electrical test tool.

b. If your DUT is EL 22, select the Step button in the HS electrical test tool to acquire the
waveform as shown in the next figure.

HS Electrical Test Tool x|

—Select Tupe Of Test————— 1~ Select Host Controller For Use [n Testing—

" Device PCl buz 1, device 8. function 2 5 Ports

i~ Huh

% Host Controller/S yatem

TEST | E xit |
HS Electrical Test Tool - Host Tesk

— Select Downstream Device———— — Host Port Canfrol
HOHE Port Cantral Puart

[NONE =] |1
Status Wwindow T Disconnect Moty
Cperation Successiul

Enumerate Bus |

— Diawnstreamn Device Control

Address
SINGLE STEP GET DEV DE ~| [0 Retum To Mam|
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You can use the application to perform the following measurements:
High Speed Host: EL._21, EL 23, EL 25 (EOPII-InterPacketI&II)
a. Complete procedures 1 and 2 to set up the test fixture and the oscilloscope.
b. The oscilloscope acquires and displays the waveform as shown in the next figure.
c. "Press OK when correct waveform is acquired”.

d. The application measures the synchronous bits (32) of the first and second packets. This
is EL_21.

e. The application measures the EOP of the second packet (8bits). This is EL_25. As the signal is
differential, the EOP can be a positive or a negative pulse.

f. The application measures the inter-packet gap of the first two packets (88-192 bits). This is
EL_23 as shown in the next figure.

File Edit  “erkical Horizfécg Trig Display Cursors Measure  Masks  Math LItilities Help

1My 01123204

200mY 52
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®  High Speed Host: EL 22 (InterPacketlI&III)
a. Complete procedures 1 and 2 to set up the test fixture and the oscilloscope.
b. Select the Step button in the HS Electrical Test Tool.

c. The oscilloscope acquires and displays the waveform as shown in the next figure.

HS Electrical Test Tool x|

—Select Type Of Test————— — Select Host Controller For Use [n T esting—
" Device FPCl bus 1, device 8, function 2 5 Ports
i Hub

% Host ControllerS yetem

TEST | E xit |
HS Electrical Test Tool - Host Tesk

— Select Downstream Device————— — Host Port Control
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[MONE =
Status Window [ Disconnect Haotify

Dperation Successiul

Enumerate Bus |

— Downztream Device Control

Address
SINGLE STEP GET DEV DE ~| [0 Retum Ta Mam|

d. "Press OK when correct waveform is acquired”.
e. The application displays the waveform as shown in the next figure.

f. The application measures the inter packet gap of the second and the third packet (88-192
bits). This is EL_22.
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®  High speed Host: EL_55 (SOF-EOP)
a. Complete the procedure 1.
b. Run the test mode software and select the Host option.

c. Select the Enumerate button in the HS electrical test tool to identify the device connected to
the host controller.

d. Select the measurement and run the application. The application automatically sets the
oscilloscope parameters (Horizontal, Vertical, and Trigger). You can see the SOFs on the
oscilloscope screen.

File  Edit  Wertical Horigftcg  Trig  Display  Cursors  Measure  Masks  Math  Utilities  Help

27 Moy 03 171966

Ch1 200mYy

To set up the oscilloscope for the High Speed Device EL_21, EL._23, EL 25 (Sync-EOPIII-
InterPacketlI&III) and a High Speed Device EL 22 (InterPacketl&II), follow these steps:

1. Select the measurement and run the application. The application automatically sets the oscilloscope
parameters (Horizontal, Vertical, and Trigger) and displays the message,"Press OK when correct
waveform is acquired”. You can see the SOFs on the oscilloscope screen.
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2. Ifyou are not able to acquire the waveform automatically, perform Autosetup in the oscilloscope to
display the SOF.

3. Click here to find out how to adjust the trigger manually.

a. Ifyour DUT is EL 21, EL 23, EL 25, select the Single Step Set Feature option from the
HS electrical test tool.

b. Ifyour DUT is EL_22, select the Step button in the HS electrical test tool to acquire the
waveform as shown in the next figure.
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You can use the application to perform the following measurements:

208 TDSUSB?2 Universal Serial Bus Measurements Package



Reference Packet Parameter Test Equipment Setup

®  High Speed Device:EL 21, EL 23, EL 25 (Sync-EOPIII-InterPacketlI&III)
a. Complete procedures 1 and 3 to set up the oscilloscope.
b. The oscilloscope acquires and displays the waveform as shown in the next figure.
c. "Press OK when correct waveform is acquired”.
d. The application measures the synchronous bits (32) of the third packet. This is EL_21.

e. The application measures the EOP of the third packet (8bits). This is EL_25. As the signal is
differential, the EOP can be a positive or a negative pulse.

f. The application measures the inter-packet gap between the second and the third packets
(88-192 bits). This is EL_23 as shown in the next figure.

Display  Cursors  Measure  Masks  Math  Utiities  Help

Ref3 Position
0.0div
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®  High Speed Device:EL 22 (InterPacketl&II)
a. Complete procedures 1 and 3 to set up the oscilloscope.

b. Select the Step button in the HS electrical test tool to acquire the waveform as shown in the
next figure.
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¢. The application measures the number of bits (88-192) between the packets.
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Glossary

Cross-Over Points

The Cross-Over point is defined as the intersection of the D+ and D— single-ended signals. For differential
signals, the Cross-Over is zero crossings of the differential signal.

Downstream

The direction of data flow from the host or away from the host. A downstream port is the port on a hub
electrically farthest from the host that generates downstream data traffic from the hub. Downstream ports
receive upstream data traffic.

EOP

End-of-Packet.

EOP (E), Idle (I), J, K

The different bus states of the USB signal.
Eye Pattern

A representation of the USB signal that provides minimum and maximum voltage levels, as well as
the signal jitter.

Eye Violation

Any part of the waveform that crosses the defined eye mask.
Full-speed

USB operation at 12 Mb/s.

High-speed

USB operation at 480 Mb/s.

Host

The host computer system where the USB Host Controller is installed. This includes the host hardware
platform (CPU, bus, etc.) and the operating system in use.

Host Controller
The host’s USB interface.
Hot-Plug

It is the technology that supports automatic configuration of the PC hardware and the attached device. You
can attach a device or hot plug and start working without having to manually configure the device. This is
how it is referred to in the application.

HUT
A Host/Hub Under Test.

TDSUSB2 Universal Serial Bus Measurements Package 213



Glossary Glossary

214

Hub

A USB device that provides additional connections.
Low-speed

USB operation at 1.5 mb/s.

mb/s

It is the transmission rate expressed in megabits per second.
NAK

A handshake packet indicating a negative acknowledgment.
Pulse Diagram

The Plot of the USB signals showing Annotations of J,K, EOP (E), Idle (I), Cross-Over Points (Cov)
and Reference Points (Ref).

Reference point

The simulation of ideal Cross-Over points, which helps calculate jitter.

Reflectometer

An oscilloscope capable of measuring impedance characteristics of the USB signal lines.
Sample Rate

It is the number of samples per second, expressed in Hertz (Hz).

Signal Direction Downstream

It is defined as the direction of data flow away from the host. A downstream port is the port on a hub
farthest from the host that generates downstream data traffic from the hub. Downstream ports receive
upstream data traffic.

Signal Direction Upstream

It is defined as the direction of data flow towards the host. An upstream port is the port on a device closest to
the host that generates upstream data traffic from the hub. Upstream ports receive downstream data traffic.

Tier
The position in the hub where the device is connected to the system.
Test Point

A device is classified as far end or near end depending upon the captive cable. A device with captive cable
is usually called as a far end device, otherwise as a near end device.

Test Fixture

It is the break-out board that helps in probing signals.

UUT

Called as the Unit Under Test. The unit can be a USB device, hub, port or a host.
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Upstream

The direction of data flow towards the host. An upstream port is the port on a device electrically closest to
the host that generates upstream data traffic from the hub. Upstream ports receive downstream data traffic.

\Y% BUS

It is the supply voltage which a function or hub requires to work.
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steps to deskew probes and
channels, 12
Detailed results, 52
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H
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using online help, 174
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monotonic property, 28
Receiver sensitivity, 28
Rise time, 28
Signal rate, 28
High Speed Plug-Fest Specific
Format, 125
High speed signal quality
equipment setup, 87
High Speed Tektronix Report, 83
Hot plug attach, 38
How to Save and Recall
Setups, 59
recalling a Saved Setup, 59
recalling Recently Recalled
Setups, 59
recalling Recently Saved
Setups, 59
recalling the Default
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