Infiniiumオシロスコープの時間相関

Agilent Technologies E5850A時間相関フィクスチャは、クロス・トリガおよび時間相関測定の際の、外部オシロスコープとロジック・アナライザのセットアップ処理を自動化し、簡単にします。E5850A時間相関フィクスチャは、ロジック・アナライザと外部オシロスコープ間のマーカの動きを統一します。

E5850A時間相関フィクスチャは、Agilent 16900シリーズ・ロジック解析システムまたは1680/90シリーズ・ロジック・アナライザ、およびAgilent Infiniium 548XXシリーズ・オシロスコープと動作します。

注記:

E5850A時間相関フィクスチャ・ボックス上の指示は、16700シリーズ・ロジック解析システムにのみ該当します。16900シリーズ・ロジック解析システムまたは1680/90シリーズ・ロジック・アナライザの場合、このオンライン・ヘルプの指示に従ってください。

相関を自動化するには、E5850A時間相関フィクスチャをソフトウェアと一緒に使用する必要があります。このソフトウェアは、上記のロジック・アナライザ上で動作し、LAN接続を介して548XXオシロスコープにコマンドを送信します。

E5850A時間相関フィクスチャの入手方法の詳細については、計測お客様窓口（0120-421-345）にお問い合わせください。

  • Infiniiumオシロスコープの時間相関の測定前の準備
    • ステップ1. オシロスコープとロジック・アナライザのネットワーク接続
    • ステップ2. Add External Oscilloscopeウィザードの実行
    • ステップ3. 測定の実行
  • マーカを使って作業する
  • 構成をロード/保存する
  • 外部オシロスコープのセットアップ・オプションを変更する
  • 外部オシロスコープを削除する
  • トラブルシューティング
    • InfiniiumのIPアドレスを検出する
    • LAN問題
    • 一般的なトリガ問題
    • 予期しない結果や一貫性のない結果
  • リファレンス
    • External Oscilloscope Setupダイアログ
  • 概念
    • 校正
    • 自動スキュー補正操作の動作原理
    • 不確かさ
    • スキュー数値の意味
  • モジュール・コントロール、COMオートメーション
  • モジュール・セットアップ、XMLフォーマット

© Agilent Technologies, Inc. 2001-2004


Infiniiumオシロスコープの時間相関の測定前の準備

E5850A時間相関フィクスチャ・ソフトウェアは、16900シリーズ・ロジック解析システムまたは1680/90シリーズ・ロジック・アナライザにすでにインストールされています。

Infiniium 548XXオシロスコープとロジック・アナライザをネットワークに接続した後、Add External Oscilloscopeウィザードの指示に従ってロジック・アナライザをオシロスコープに接続します。接続後、いつでも測定できます。

  • ステップ1. オシロスコープとロジック・アナライザのネットワーク接続
  • ステップ2. Add External Oscilloscopeウィザードの実行
  • ステップ3. 測定の実行


ステップ1. オシロスコープとロジック・アナライザのネットワーク接続

注記:

ロジック・アナライザと外部オシロスコープがどちらもすでにLANに接続されている場合、このステップをスキップできます。

ロジック・アナライザと外部オシロスコープをまだLANに接続していない場合、測定器間の接続には、単純なポイントツーポイント接続をお勧めします（ポイントツーポイント・ネットワークを使用するを参照してください）。

ポイントツーポイント接続を使用したくない場合は、ネットワークでの測定器のセットアップ方法について、ロジック・アナライザまたは外部オシロスコープのオペレーティング・システムの説明書を参照してください。


ポイントツーポイント・ネットワークを使用する

ロジック・アナライザとオシロスコープ間でポイントツーポイント接続をセットアップするには、E5850A時間相関フィクスチャに付属のクロスオーバー（青）・ケーブルを使って測定器を接続します。

  1. クロスオーバー・ケーブルの一端をロジック・アナライザのネットワーク・インタフェースに接続し、ケーブルのもう一端をオシロスコープのネットワーク・インタフェースに接続します。

  2. オシロスコープでネットワーキング・ソフトウェアを構成します（オシロスコープのポイントツーポイント・ネットワークのセットアップを参照してください）。

  3. ロジック・アナライザでネットワーキング・ソフトウェアを構成します（ロジック・アナライザのポイントツーポイント・ネットワークのセットアップを参照してください）。


オシロスコープのポイントツーポイント・ネットワークのセットアップ

  1. 必要に応じて、オシロスコープ画面の右上隅のマウスをクリックし、オシロスコープのグラフィカル・インタフェースをオンにします。

  2. メニュー・バーから、File>Network>Propertiesを選択します。

  3. TCP/IPコンポーネントがインストールされていることを確認し、Propertiesを選択します。

  4. IP Addressタブで、IPアドレスとサブネット・マスクを設定します。

    1. IPアドレスを192.0.2.231に設定します。

    2. サブネット・マスクを255.255.255.0に設定します。

  5. WINS Configurationタブで、Disable WINS Resolutionを選択します。

  6. Gatewayタブで、インストールされているゲートウェイを削除します。

  7. DNS Configurationタブで、Disable DNSを選択します。

  8. ダイアログを閉じ、リブートを求められたときにYesをクリックします。

関連項目

  • ロジック・アナライザのポイントツーポイント・ネットワークのセットアップ


ロジック・アナライザのポイントツーポイント・ネットワークのセットアップ

  1. Startメニューから、Setting>Network and Dial-up Connectionを選択します。

  2. Local Area Connectionを右クリックし、Propertiesを選択します。

  3. TCP/IPコンポーネントがインストールされていることを確認し、Propertiesを選択します。

  4. Propertiesダイアログで、IPアドレスとサブネット・マスクを設定します。

    1. IPアドレスを192.0.2.232に設定します。

    2. サブネット・マスクを255.255.255.0に設定します。

  5. Advancedタブを選択します。

    1. IP Settingsタブで、インストールされているゲートウェイを削除します。

    2. DNSタブで、リストからすべてのDNSアドレスを削除します。

    3. WINSタブで、リストからすべてのWINSアドレスを削除します。

  6. ダイアログを閉じ、続行を求められたときにYesをクリックします。

関連項目

  • オシロスコープのポイントツーポイント・ネットワークのセットアップ
  • ステップ2. Add External Oscilloscopeウィザードの実行


ステップ2. Add External Oscilloscopeウィザードの実行

時間相関測定には、E5850A時間相関フィクスチャをロジック・アナライザとオシロスコープに接続する必要があります。これらの接続の詳細手順については、Add External Oscilloscopeウィザードを実行してください。

  1. メニュー・バーから、Setup>Advanced>Add External Oscilloscope...を選択します。

  2. ウィザードの指示に従って、時間相関フィクスチャを接続します。

関連項目

  • 追加接続情報
  • 外部オシロスコープを削除する
  • InfiniiumのIPアドレスを検出する


追加接続情報

  • LANの接続
  • BNCケーブルの接続
  • オシロスコープ・プローブの接続
  • ロジック・アナライザの接続
  • 電源の接続

LANの接続

E5850A時間相関フィクスチャ・ソフトウェアは、548XX Infiniiumオシロスコープと1680/90シリーズ・ロジック・アナライザまたは16900シリーズ・ロジック解析システム間のネットワーク接続を使用して、時間相関測定を行います。測定器は、ローカル・エリア・ネットワーク（LAN）で接続するか、クロスオーバー・ケーブル（E5850A時間相関フィクスチャに付属）を使ってポイントツーポイントで接続します。

時間相関測定の場合、システムにオシロスコープを1台だけ接続します。システムに、一度に2台以上のオシロスコープを接続することはできません。

BNCケーブルの接続

BNCケーブルの接続は、使用するInfiniiumオシロスコープのモデルによって異なります。

BNCの接続手順については、Add External Oscilloscopeウィザードを参照してください。

オシロスコープ・プローブの接続

注記:

自動スキュー補正処理には、被試験デバイスで測定するときと同じプローブを使用することが重要です。これにより、スキュー補正の確度が向上します。またグランドも必ず接続するようにしてください。

Agilent Infiniium 548XXオシロスコープのチャネル1プローブを、E5850A時間相関フィクスチャのフロントにある、CALというラベルのポイントに接続します。CALというラベルであれば、どのポイントでも同じです。

例:

  • 被試験デバイスでの測定にグラバ・プローブを使用している場合、グラバ・プローブを時間相関フィクスチャのフロントのCAL端子に接続します。次に、グランド・リードを接続します。

  • 被試験デバイスでの測定にツイン・リード・プローブを使用している場合、ツイン・リード・プローブを時間相関フィクスチャに接続します。次に、グランド・リードを接続します。

  • 被試験デバイスでの測定にシャープ・チップ・プローブを使用している場合、シャープ・チップ・プローブを時間相関フィクスチャのフロントのCAL端子に接続します。

ロジック・アナライザの接続

注記:

自動スキュー補正処理には、被試験デバイスで測定するときと同じプローブを使用することが重要です。これにより、スキュー補正の確度が向上します。またグランドも必ず接続するようにしてください。

時間相関フィクスチャでCAL信号を接続するには、次の3つの方法があります。

  • フライング・リードを使用する
  • 高密度コネクタ（MICTORまたはSamtec）を使用する
  • グラバ・プローブを使用する

フライング・リード（ソケット・プローブ）

使用しているロジック・アナライザのポッド2、チャネル0を、時間相関フィクスチャのフロントにある、CALというラベルのポイントに接続します。複数のカードを使用している場合、マスタ・カードのポッド2を使用します。グランドも接続してください。

高密度コネクタ

被試験デバイスでMICTORコネクタを使用している場合、時間相関フィクスチャの上部にあるMICTORソケットを使用します。MICTORソケットにはCAL接続も含まれます。ロジック・アナライザのポッド2を、MICTOR高密度アダプタ・ケーブルの偶数ソケットに接続してください。終端または未終端の高密度アダプタ・ケーブルを使用できます。

被試験デバイスでSamtecコネクタを使用している場合、時間相関フィクスチャの上部にあるSamtecソケットを使用します。SamtecソケットにはCAL接続も含まれます。

グラバ・プローブ

被試験デバイスでグラバ・プローブを使用している場合、グラバ・プローブをCALというラベルの端子に接続します。グランドも接続してください。

電源の接続

電源を、Add External Oscilloscopeウィザードに示されたように時間相関フィクスチャに接続します。

警告:

感電の危険があります。0950-2546電源および付属の電源コードのみを使用してください。

注意:

機器を損傷するおそれがあります。0950-2546電源および付属の電源コードのみを使用してください。

時間相関測定中は、BNCケーブルと電源を時間相関フィクスチャに接続したままにしておく必要があります。プローブが必要となるのは、自動スキュー補正校正の場合だけです。

注記:

スキューは、ケーブル長、プローブ・タイプ、測定器によって変化します。これらのいずれかを変更した場合、自動スキュー補正をもう一度実行する必要があります。自動スキュー補正を再実行するには、Setupメニュー>External Oscilloscope>Triggerを選択してから、Run Auto-Deskewをクリックします。


ステップ3. 測定の実行

校正を完了したら、次のように測定を続行できます。

  1. Infiniium 548XXオシロスコープ・プローブとロジック・アナライザのリードをE5850Aから外します。

  2. オシロスコープ・プローブとロジック・アナライザのリードを被試験デバイスに接続します。

    BNCケーブルを外さないでください。

  3. トリガ条件をセットアップします。

  4. ロジック・アナライザのフロント・パネルのRunボタンを押します。

  5. Waveformタブを選択し、測定結果を表示します。

ロジック・アナライザによる外部オシロスコープのトリガ

ソフトウェアをLogic Analyzer triggers External Oscilloscope（ロジック・アナライザによる外部オシロスコープのトリガ）に構成すると、ロジック・アナライザでトリガ条件を設定できます。ただし、オシロスコープのトリガ・セットアップを変更しないでください。

外部オシロスコープによるロジック・アナライザのトリガ

ソフトウェアをExternal Oscilloscope triggers Logic Analyzer（外部オシロスコープによるロジック・アナライザのトリガ）に構成すると、オシロスコープでトリガ条件を設定できます。ただし、ロジック・アナライザのトリガ・セットアップを変更しないでください。

関連項目

  • マーカを使って作業する
  • 一般的なトリガ問題


マーカを使って作業する

マーカの移動

ロジック・アナライザとオシロスコープ間で、マーカの移動が統一されています。マーカは、トリガを基準とする時間軸で、測定されたスキューを考慮に入れて統一されます。

ロジック・アナライザでは、Ax(External Scope)とBx(External Scope)と呼ばれるマーカが、測定値を表示しているすべての表示ウィンドウ間で時間相関されます。オシロスコープでは、AxとBxと呼ばれる2つのX軸（時間）マーカがあります。マーカの移動が、Ax(External Scope)とAx間、Bx(External Scope)とBx間で統一されています。Ax(External Scope)とBx間、またはBx(External Scope)とAx間を統一するためのオプションはありません。

マーカ移動が統一されているため、ロジック・アナライザ画面とオシロスコープ画面が分かれている場合にも、トレースのポイントをすばやく識別することができます。Ax(External Scope)マーカとBx(External Scope)マーカのマーカ・プロパティには、Markersメニューからアクセスできます。

オシロスコープのマーカ

Axは、ロジック・アナライザのAx(External Scope)に従います

ロジック・アナライザの波形表示でAx(External Scope)マーカを移動すると、Axマーカを時間軸の同じポイントに配置するため、オシロスコープにコマンドが送信されます。

Bxは、ロジック・アナライザのBx(External Scope)に従います

ロジック・アナライザの波形表示でBx(External Scope)マーカを移動すると、Bxマーカを時間軸の同じポイントに配置するため、オシロスコープにコマンドが送信されます。

ロジック・アナライザのマーカ

Ax(External Scope)は、オシロスコープのAxに従います

オシロスコープでAxマーカを移動すると、ロジック・アナライザの波形表示のAx(External Scope)マーカが、時間軸の同じポイントへ移動します。

Bx(External Scope)は、オシロスコープのBxに従います

オシロスコープでBxマーカを移動すると、ロジック・アナライザの波形表示のBx(External Scope)マーカが、時間軸の同じポイントへ移動します。


構成をロード/保存する

E5850Aを含む構成ファイルを保存するとき、最後のスキュー実行が、Infiniium 548XXオシロスコープのホスト名と一緒に保存されます。オシロスコープのセットアップも、ロジック・アナライザの構成ファイルに保存されます。オシロスコープ・データは、ロジック解析システムの構成ファイルに保存されません。

後から構成をロードすると、ロジック解析システムがInfiniium 548XXオシロスコープに自動的に接続され、保存したセットアップが復元されます。構成をロードしたときにネットワークでオシロスコープが使用できない場合、この自動接続とセットアップは失敗します。

Infiniium 548XXオシロスコープが共有で使用され、別の場所に移動された可能性がある場合、このオプションが、好ましくない結果を生む可能性があります。ネットワーク上に同じホスト名またはIPアドレスを持つオシロスコープがあると、保存した構成がこのオシロスコープにロードされ、セットアップを変更する可能性があります。

注記:

2つのロジック・アナライザを1つのオシロスコープに接続しようとすると、オシロスコープが別のユーザによってロックされていることを伝えるエラー・メッセージが表示されます。


外部オシロスコープのセットアップ・オプションを変更する

  1. Setup>External Oscilloscope-1メニューからコマンドを1つ選択します。

    次のいずれかのタブが選択された状態で、External Oscilloscope Setupダイアログが開きます。

    Connectionタブ

    オシロスコープの名前またはIPアドレス、モデル、シリアル番号を表示します。

    Optionsタブ

    外部オシロスコープのセットアップをロジック・アナライザの構成ファイルと一緒に保存するかどうか、および情報メッセージをオンにするかどうかを指定できます。

    Triggerタブ

    トリガ方向の設定とトリガ・スキュー補正の実行に使用します。

  2. 希望の変更を行います。

  3. OKをクリックします。


外部オシロスコープを削除する

外部オシロスコープを削除するには:

  1. メニュー・バーからSetup>Advanced>Delete External Oscilloscopeを選択します。

関連項目

  • 測定前の準備、ステップ2. Add External Oscilloscopeウィザードの実行


Infiniiumオシロスコープの時間相関のトラブルシューティング

一般的なトラブルシューティング

  • InfiniiumのIPアドレスを検出する
  • LAN問題
  • 一般的なトリガ問題
  • 予期しない結果や一貫性のない結果


InfiniiumのIPアドレスを検出する

時間相関フィクスチャ・ソフトウェアには、InfiniiumのIPアドレスが必要です。InfiniiumのIPアドレスを検出するには:

  1. Infiniiumオシロスコープで、Utilities-> GPIB Setup...を選択します。

  2. Infiniiumアドレスが、ウィンドウのLANインタフェース部分に表示されます。括弧とテキストを無視し、数値のみ（123.45.678.90など）を使用します。Add External Oscilloscopeウィザードで、Infiniium 548XXオシロスコープからの文字列を入力します。

この文字列が正しく入力されていない場合、または誰かがInfiniiumのIPアドレスを変更した場合、ロジック・アナライザは、Infiniium 548XXと通信することができません。この文字列がネットワーク上の別のInfiniium 548XXオシロスコープに対応した場合、ロジック・アナライザは、そのInfiniium 548XXオシロスコープを検出して、接続する可能性があります。この場合、実際には正しく接続されていないにも係らず、正しく接続されたように見えます。

ネットワーク上のどのデバイスにも対応しない文字列を入力すると、ソフトウェアは、デバイスを検索しているあいだの数分間、ハングしたように見える可能性があります。ロジック・アナライザから所定Infiniium 548XXオシロスコープへの1つの接続だけをサポートできます。


LAN問題

LANエラー・メッセージが表示された場合:

  • Infiniiumおよびロジック解析システムへのLAN接続をチェックします。

  • LAN管理者と一緒に、LANが現在機能していることを確認します。ロジック・アナライザのE5850AソフトウェアのConnectionタブで、正しいIPアドレスが入力されていることを確認します。

  • エラーが報告された場合、LAN管理者に、ロジック・アナライザとオシロスコープでネットワークを確立するためのサポートを依頼します。両方の測定器で電源を入れ直します。

  • 問題が持続する場合、Agilent Technologiesからテクニカル・サポートを受けてください。

LAN経由でInfiniiumに接続できるロジック解析システムは1つだけです。

2つのロジック解析システムを同じInfiniiumに接続しようとすると、オシロスコープが別のユーザによってロックされていることを伝えるメッセージが表示されます。1つのロジック解析システムから複数のInfiniiumオシロスコープへの接続は、サポートされていません。

関連項目

  • InfiniiumのIPアドレスを検出する


一般的なトリガ問題

  • ロジック・アナライザによる外部オシロスコープのトリガ
  • 外部オシロスコープによるロジック・アナライザのトリガ
  • 赤いトリガ・マーカが予測どおりに配置されない理由
  • ケーブル接続のチェック
  • プローブ接続のチェック
  • グランドの使用
  • 外部オシロスコープを正しいモードで使用する
  • 外部オシロスコープを同時に共用しない

ロジック・アナライザによる外部オシロスコープのトリガ

ソフトウェアをLogic Analyzer triggers External Oscilloscope（ロジック・アナライザによる外部オシロスコープのトリガ）に構成すると、オシロスコープは、Aux Trig Inの立ち上がりエッジで、1.0Vでトリガするよう構成されます。オシロスコープのトリガを変更すると、次回ロジック・アナライザを実行したとき、ソフトウェアがオシロスコープのトリガ条件を、Aux Trig Inの立ち上がりエッジ、1.0Vでのトリガに自動的に復元します。ロジック・アナライザを使ってオシロスコープをトリガするので、ロジック・アナライザで希望のトリガ条件を設定できます。

外部オシロスコープによるロジック・アナライザのトリガ

ソフトウェアをExternal Oscilloscope triggers Logic Analyzer（外部オシロスコープによるロジック・アナライザのトリガ）に構成すると、アナライザは、外部Trigger Inでトリガするよう構成されます。アナライザのトリガを変更すると、測定器を正しく時間相関できなくなります。オシロスコープを使ってアナライザをトリガするので、オシロスコープで希望のトリガ条件を設定できます。

赤いトリガ・マーカが予測どおりに配置されない理由

E5850Aを使用しているときにはいつでも、複数測定器測定を実行しています。各測定器からの測定値は時間相関されますが、それぞれの測定器は実際のトリガ・ポイントを保持しています。

ケーブル接続のチェック

時間相関機能を使用しているときにはいつでも、ロジック・アナライザ、時間相関フィクスチャ、オシロスコープ間でBNCケーブルを接続したままにしておく必要があります。

プローブ接続のチェック

適切なロジック・アナライザ・ケーブルを使用していることを確認します。アナライザからE5850Aフィクスチャまたは被試験デバイスまでケーブルをトレースします。適切なオシロスコープ・プローブを使用していることも確認します。測定器からE5850Aフィクスチャまたは被試験デバイスまでプローブをたどります。

グランドの使用

時間相関フィクスチャのフロントへの接続に、グランドを含める必要があります。例えば、オシロスコープ・プローブのグランド・クリップをE5850Aフィクスチャ上のグランド端子に接続します。各ロジック・アナライザ・ポッド、およびできれば各ロジック・アナライザ・チャネルのグランド・リードも、E5850Aフィクスチャ上のグランド端子に接続します。

外部オシロスコープを正しいモードで使用する

Single Sweep, Real Time（シングル掃引、リアルタイム）収集の場合だけ、ロジック・アナライザとの意味のある相関が可能です。オシロスコープをEquivalent Time（等価時間）でのサンプリングに設定した場合、またはオシロスコープ掃引をSweep（掃引）またはTriggered Sweep（トリガ掃引）に設定した場合、意味のある相関が行えない可能性があります。

外部オシロスコープを同時に共用しない

誰かほかの人がフロント・パネルから、またはLAN経由で外部オシロスコープを使用していると、ロジック解析システムがオシロスコープを正しく制御できなくなります。


予期しない結果や一貫性のない結果

予期しないスキュー補正結果や一貫性のないスキュー補正結果を得た場合、次の項目をチェックしてください。

  • ケーブル接続のチェック
  • プローブ接続のチェック
  • 外部オシロスコープを正しいモードで使用する
  • 外部オシロスコープを同時に共用しない


Infiniiumオシロスコープの時間相関リファレンス

  • External Oscilloscope Setupダイアログ


External Oscilloscope Setupダイアログ

  • Connectionタブ
  • Optionsタブ
  • Triggerタブ


Connectionタブ

Connectionタブは、Infiniium 548XXオシロスコープの名前またはIPアドレス、モデル、シリアル番号を表示します。オシロスコープが切断された場合、Reconnectをクリックすることにより、Connectionタブから再接続できます。

関連項目

  • Optionsタブ
  • Triggerタブ
  • InfiniiumのIPアドレスを検出する


Optionsタブ

Optionsタブで、外部オシロスコープのセットアップをロジック・アナライザの構成ファイルと一緒に保存するかどうか、および情報メッセージをオンにするかどうかを指定できます。

ロジック・アナライザの構成ファイルを保存するとき、外部オシロスコープの構成設定をE5850Aの設定と一緒に保存する場合には、Save External Oscilloscope Setup With Configurationチェック・ボックスを使用します。ロジック・アナライザの構成ファイルをロードすると、E5850Aが、以前に保存した外部オシロスコープの設定の再ロードを試みます。

注記:

E5850Aは、あるオシロスコープ・モデルのオシロスコープ設定を別のオシロスコープ・モデルへロードしません。例えば、Infiniium 54810Aオシロスコープの設定を、Infiniium 54831Bオシロスコープへロードすることはありません。

E5850Aによって提供される情報ダイアログをオンまたはオフにするには、Enable Information Messagesチェック・ボックスを使用します。

関連項目

  • Connectionタブ
  • Triggerタブ
  • 構成をロード/保存する


Triggerタブ

Triggerタブは、トリガ方向の設定とトリガ・スキュー補正の実行に使用します。

トリガ方向

トリガ方向をLogic Analyzer Triggers External Oscilloscope（ロジック・アナライザによる外部オシロスコープのトリガ）に設定すると、E5850Aは、オシロスコープをトリガするようロジック・アナライザを構成します。ロジック・アナライザがトリガ信号を生成すると、オシロスコープが、オシロスコープ・フレーム上のAux Trig In/Ext Trig接続を介して信号を受信し、データの捕捉を開始します。ロジック・アナライザのトリガは、手動でセットアップする必要があります。

トリガ方向をExternal Oscilloscope Triggers Logic Analyzer（外部オシロスコープによるロジック・アナライザのトリガ）に設定すると、E5850Aは、ロジック・アナライザをトリガするようオシロスコープを構成します。オシロスコープがトリガ信号を生成すると、ロジック・アナライザが、ロジック・アナライザ・フレーム上のTrigger In接続を介して信号を受信し、データの捕捉を開始します。オシロスコープのトリガは、手動でセットアップする必要があります。

Analyzer選択項目で、外部オシロスコープとの時間相関に適したロジック・アナライザ・モジュールを選択できます。

トリガ・スキュー補正

デフォルトで、E5850Aは、初期セットアップ中に実行された校正手順（Automatic）からのスキュー補正結果を使用します。自動スキュー補正では、2つの個別スキュー補正値（各トリガ方向に1つ）が使用可能です。自動スキュー補正を再実行するには、Run Auto-Deskew...ボタンを選択します。

注記:

スキュー補正校正値は、トリガの方向によって異なります。

Manualを選択し、表示された数値フィールドに値を入力することにより、手動スキュー補正値をユーザ入力できます。入力したスキュー補正値が、両方のトリガ方向に使用されます。Manualスキュー補正モードは、各トリガ方向に対して個別の値を保持しないからです。

自動スキュー補正を選択すると、スキュー補正値が、最後の校正手順中に取得された値にリセットされます。

関連項目

  • Connectionタブ
  • Optionsタブ


Infiniiumオシロスコープの時間相関の概念

次の情報ヘルプで、時間相関フィクスチャの動作原理について説明します。

  • 校正
  • 自動スキュー補正操作の動作原理
  • 不確かさ
  • スキュー数値の意味


校正

時間相関ソフトウェアが、Auto Deskew（自動スキュー補正）操作中にスキューを測定します。ソフトウェアは、この後のすべての測定でこのスキュー・ファクタを使用します。

Auto Deskew（自動スキュー補正）の実行後に、E5850A時間相関フィクスチャのフロントからチャネル接続を取り外します。校正完了後は、被試験デバイスのプロービングに、オシロスコープとロジック解析のすべてのチャネルが使用できます。

スキューは、ケーブル長、プローブ・タイプ、および測定器自体によって変化します。これらのいずれかを変更した場合、スキュー補正操作をもう一度実行する必要があります。


自動スキュー補正操作の動作原理

  • 伝搬遅延
  • トリガ・ポイントの違い
  • 目的
  • セットアップ問題
  • Cal信号
  • アナライザによるInfiniiumのトリガ
  • スキューを測定する
  • アベレージングの使用
  • Infiniiumによるアナライザのトリガ
  • セットアップ準備の完了

伝搬遅延

ロジック・アナライザとInfiniium 548XXオシロスコープは、トリガ条件が発生するとシャーシの出力信号をドライブできます。出力信号は、ロジック・アナライザではTrigger Out、オシロスコープではAux Outです。外部信号の受信によるアーム/トリガも可能です。アーム/トリガ信号は、ロジック・アナライザではTrigger In、オシロスコープではAux Trig Inです。どちらの測定器でも、トリガ・イベントが発生したときと出力信号がドライブされたときとのあいだに伝搬時間があり、入力信号が発生したときと測定器が実際にトリガしたときとのあいだに伝搬遅延があります。測定器間のケーブルにも伝搬時間があります。これらの伝搬時間の合計を、測定器間の「スキュー」と呼びます。

トリガ・ポイントの違い

例えば、ロジック・アナライザのTrigger OutからオシロスコープのAux Trig Inまで50Ωケーブルで簡単に接続できます。ロジック・アナライザでトリガ条件を設定し、オシロスコープをAux Trig Inで1.0Vでのエッジ・トリガに設定します。オシロスコープを先にスタートし、ロジック・アナライザを次にスタートさせます。アナライザがトリガした後、オシロスコープがトリガします。どちらの測定器も、そのトリガ・ポイントを識別します。ただしスキューのため、これらのトリガ・ポイントは、時間軸の同じポイントとして表示されません。プローブ対象信号に固有の識別パターンがない限り、1つの測定器のエッジが他の測定器のどのエッジに対応するかを告げることは、非常に困難であるか、不可能です。

目的

自動スキュー補正操作のポイントは、測定器間のスキューを測定し、これらの測定の結果を記憶しておき、後の測定値を表示するときに、この結果を考慮して時間相関マーカを移動できるようにすることです。

セットアップ問題

スキュー測定は、測定に使用するセットアップに固有であることを理解することが重要です。スキューは、ロジック・アナライザのモデルの違いやオシロスコープのモデルの違いによって変わります。使用するオシロスコープ・プローブのタイプや長さによっても変化します。フライング・リード、MICTORコネクタ、Samtecコネクタなど、解析モジュールに使用可能な様々なプロービング・オプションによっても異なります。時間相関確度を向上させるため、被試験デバイスの測定で使用するプロービングと同じプロービングを使って、Auto Deskew（自動スキュー補正）操作を実行する必要があります。

Cal信号

スキューを測定するには、解析モジュールのポッド2、チャネル0とオシロスコープのチャネル1の両方を使って、E5850AのCal信号をプロービングします。Cal信号自体は、低周波発振器（約62kHz、約16usec周期）です。この発振器の周期は、測定器間のスキューより10進数で2桁以上大きいので、トリガに一番近いエッジは、両方の測定器で同じエッジになります。ドライブする測定器がトリガ信号を送信する前に、外部トリガ信号を受信する予定の測定器が動作しており、アームされており、待機していることが非常に重要です。そうでないと、両方の測定器が、発振器の異なるエッジを見る可能性があります。Auto Deskew（自動スキュー補正）操作中および通常の単一または繰り返し測定中、E5850Aは、測定器が常に正しいシーケンスでアームされ、動作していることを確認します。

アナライザによるInfiniiumのトリガ

Analyzer Triggers Infiniium（アナライザによるInfiniiumのトリガ）方向でスキューを測定するため、E5850Aソフトウェアが、ロジック・アナライザとオシロスコープをセットアップします。アナライザは、タイミング・モードで最高サンプリング・レート（最小サンプル周期）に設定されます。E5850A時間相関フィクスチャによって提供される"DeskewEdge"（Cal信号）信号用に、ラベルが定義されます。アナライザは、"DeskewEdge"信号の立ち上がりエッジでトリガするよう構成されます。オシロスコープが、そのAux Trig Inラインでトリガするよう構成され、チャネル1が、オンになり、時間相関フィクスチャからの"DeskewEdge"信号を測定するよう構成されます。シングル掃引、最大サンプリング・レートでのリアルタイム・サンプリング・モード、最大メモリ長用にセットアップされます。

スキューを測定する

スキューを測定するには、最初にオシロスコープをスタートします。オシロスコープはロジック・アナライザからアーミングされた後に、測定を開始します。ロジック･アナライザが"DeskewEdge"の次のエッジでトリガし、Trigger Outをオシロスコープに出力し、次にオシロスコープがトリガします。ソフトウェアは、オシロスコープから捕捉したチャネル1波形を取得し、トリガ・ポイントから波形の立ち上がりエッジまでの時間を測定します。立ち上がりエッジが、トリガよりも時間的に早く発生します。この時間がスキューです。

アベレージングの使用

測定を数回繰り返し、平均をスキューとして取り込みます。複数測定の平均を取る理由は、アナライザが"DeskewEdge"信号を規則的な間隔でサンプリングするからです。エッジが、実際には、アナライザのサンプル周期の先頭付近、または最後近くで発生する可能性があります。オシロスコープも規則的な間隔でサンプリングしますが、通常、はるかに高い周波数（より短い周期）で行います。2つの測定器が異なる非同期のサンプリングを行うので、どのシングル測定でも、+/-1アナライザ・サンプル周期のスキューが発生する可能性があります。

Infiniiumによるアナライザのトリガ

Infiniium Triggers Analyzer（Infiniiumによるアナライザのトリガ）方向でのスキューの測定は、Analyzer Triggers Infiniium（アナライザによるInfiniiumのトリガ）方向の場合と非常に似ています。オシロスコープは、チャネル1の立ち上がりエッジでトリガするようセットアップされ、Aux Out (TTL Trig Out)をロジック解析システムのTrigger Inに接続します。解析モジュールは、Trigger Inでトリガするよう構成されます。測定を開始すると、解析モジュールが最初にスタートし、オシロスコープからのAux Out/Trigger In信号を待ちます。次にオシロスコープがスタートし、オシロスコープがトリガし、トリガ信号をロジック解析システムに出力し、次にロジック解析システムがトリガして、解析メモリにデータを取り込みます。"TTL Trig Out"ポートを持つオシロスコープは、ロジック・アナライザのTrigger In入力を直接ドライブできます。"Aux Out"ポートを持つオシロスコープは、バッファリングのため、E5850Aを介してルートする必要があります。次に、スキューが、立ち上がりエッジが発生したときと、ロジック解析システムでトリガが発生したときのあいだの時間として測定されます。測定が複数回実行され、平均が取り込まれます。

セットアップ準備の完了

アナライザ・ポッドとオシロスコープ・プローブを時間相関フィクスチャから外して、被試験デバイスのプロービングに使用できるようになります。Single Sweep, Real Time（シングル掃引、リアルタイム）収集の場合だけ、ロジック・アナライザとの意味のある相関が可能です。


不確かさ

通常、アナライザとオシロスコープは、異なる時間間隔で信号をサンプリングしており、信号は、可能なサンプル周期関係を持つ時間軸の任意のポイントで遷移できるので、信号が実際に遷移した時間対アナライザが遷移を検出した時間には、常に不確かさが存在します。

不確かさのもう1つのソースとなるのが、異なるモジュールからのトリガ・イベントの時間を相互相関するため、インターモジュール・バス(IMB)によって使用される回路です。この回路の分解能は2nsです。

不確かさは、常に、+/-1タイミング・アナライザ・サンプル周期＋2nsのIMB不確かさ以上です。

Auto Deskew（自動スキュー補正）操作中に、最大スキューと最小スキューが測定されます。最大測定スキューが期待レンジの外にある場合、時間相関フィクスチャに対する1つ以上の接続が、行われなかったか、行われたとしても不正確であった可能性があります。すべての接続をチェックし、Auto Deskew（自動スキュー補正）をもう一度実行することを勧める警告ダイアログが表示されます。


スキュー数値の意味

スキュー（Trigger Setupダイアログ内に表示されます）は、ロジック・アナライザの外部で導入された平均トリガ遅延です。ロジック解析システムの内部で導入される合計スキューの部分は、実行ごとに内部的に補正されます。この内部的な測定スキューは、合計スキューを計算するために表示される固定スキューに追加されます。Infiniium 548XXオシロスコープの場合、合計スキューがトリガ時間に追加され、これにより、そのトリガ位置が、アナライザのトリガ位置と時間相関されます。

アナライザがInfiniiumをトリガするとき、スキュー数値は正です。アナライザがオシロスコープをトリガするときには、アナライザがトリガ条件を見た時間と、Trigger Out信号がオシロスコープのAux Trig Inに到着した時間とのあいだに遅延が発生します。

Infiniiumがアナライザをトリガするとき、スキュー数値は負です。オシロスコープがアナライザをトリガするときには、オシロスコープがトリガ条件を見た時間と、Aux Out信号がロジック・アナライザのTrigger Inに到着した時間とのあいだに遅延が発生します。

Triggerタブで、Manual Trigger Deskew（手動トリガ・スキュー補正）を使用して、合計スキュー計算の固定部を変更できます。この機能は、Auto Deskew（自動スキュー補正）中に測定されなかった固定スキューの除去に使用できます。被試験デバイスのプローブ時とAuto Deskew（自動スキュー補正）の実行時で異なるプロービング・アクセサリを使用すると、追加の固定スキューが発生します。これは、Manual Trigger Deskew（手動トリガ・スキュー補正）が効果的な一例です。


モジュール・コントロール、COMオートメーション

Agilent Logic Analyzerアプリケーションには、COM Automation Serverが含まれています。このソフトウェアを使用すると、ローカル・エリア・ネットワーク（LAN）上のリモート・コンピュータからAgilent Logic Analyzerアプリケーションを制御するプログラムを記述できます。

COMオートメーション・プログラムでは、以下の方法でモジュールを構成できます。

  • （ロジック・アナライザのセットアップ全体を構成する）構成ファイルをロードする。

  • ModuleオブジェクトのDoCommandsメソッドをXMLフォーマット文字列パラメータ付きで使用する（モジュール・セットアップ、XMLフォーマットを参照してください）。

ModuleオブジェクトのQueryCommandメソッドを使って、モジュールの構成に関する情報を取得できます。以下に、Infiniium Oscilloscope Time Correlationモジュールによってサポートされる問合せを示します。

ロジック・アナライザのCOMオートメーションとModuleオブジェクトの一般的な詳細については、COMオートメーションを参照してください。

サポートされているXMLベースの問合せ

Infiniium Oscilloscope Time Correlationモジュールは、次の（ModuleオブジェクトのQueryCommandメソッドを使って行われる）XMLベースの問合せをサポートしています。

問合せ | 説明
GetAllSetup | 現在のセットアップを返します。フル・タグ・セットを使用します。汎用構成ファイルの記述に使用されます（XMLフォーマットのモジュール・セットアップ、XMLフォーマットを参照してください）。

関連項目

  • COMオートメーション
  • モジュール・セットアップ、XMLフォーマット


モジュール・セットアップ、XMLフォーマット

ロジック・アナライザの構成をXMLフォーマット・ファイルへ保存すると、Infiniium Oscilloscope Time Correlationモジュールのセットアップ情報が含まれます。

XMLフォーマット・セットアップ情報は、ロジック・アナライザをリモート・コンピュータから制御するため、COMオートメーション・プログラムを記述するときにも使用されます。

Infiniium Oscilloscope Time CorrelationモジュールのXML要素には、次の階層があります。

<ExtScopeTriggerModel>
<ExtScopeOptionsModel>
<ExtScopeConnectionModel>
<ExtScopeMarkerMgr>
<ExtScopeProgrammer>

関連項目

  • XMLフォーマット
  • モジュール・コントロール、COMオートメーション


<ExtScopeTriggerModel>要素

<ExtScopeTriggerModel>要素は、外部オシロスコープのトリガ・オプションを記述します。

属性

名前 | 説明
Analyzer | '文字列'（オシロスコープを関連付けるロジック・アナライザ・モジュールの名前）
AutoDeskew | 'F'（偽）または'T'（真）
DeskewExtIntTime | 'floating_point_number'（オシロスコープがロジック・アナライザをトリガする場合のスキュー補正時間）
DeskewIntExtTime | 'floating_point_number'（ロジック・アナライザがオシロスコープをトリガする場合のスキュー補正時間）
DeskewTime | 'floating_point_number'（TriggerDirection='LATrigScope'の場合はDeskewIntExtTimeの値、 それ以外の場合はDeskewExtIntTimeの値）
TriggerDirection | 'LATrigScope'または'ScopeTrigLA'

親

この要素は、次の親を持つことができます。<Module>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せによって返ります。Infiniium Oscilloscope Time Correlationモジュールを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<ExtScopeTriggerModel
   TriggerDirection='LATrigScope'
   AutoDeskew='T'
   DeskewTime='0.000000100733000000000000'
   DeskewIntExtTime='1.007333e-007'
   DeskewExtIntTime='-1.733333e-008'
   Analyzer='1680A - 1'
/>


<ExtScopeOptionsModel>要素

<ExtScopeOptionsModel>要素は、外部オシロスコープのセットアップ・オプションを記述します。

属性

名前 | 説明
EnableInfoMsgs | 'F'（偽）または'T'（真）
SaveSetup | 'F'（偽）または'T'（真）

親

この要素は、次の親を持つことができます。<Module>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せによって返ります。Infiniium Oscilloscope Time Correlationモジュールを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<ExtScopeOptionsModel SaveSetup='T' EnableInfoMsgs='T'/>


<ExtScopeConnectionModel>要素

<ExtScopeConnectionModel>要素は、オシロスコープの接続オプションを記述します。

属性

名前 | 説明
LAProbe | 'LAProbeGrabber'、'LAProbeMictor'、'LAProbeSamtec'、または'LAProbeSocket' （アナライザからスキュー補正信号までのプローブ接続）
Name | '文字列'（接続先のオシロスコープのホスト名）
ScopeProbe | '100-pin probe'、'38-pin probe'、'Flying Lead probe'、または'ScopeProbeGrabber'（オシロスコープからスキュー補正信号までのプローブ接続）

親

この要素は、次の親を持つことができます。<Module>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せによって返ります。Infiniium Oscilloscope Time Correlationモジュールを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<ExtScopeConnectionModel Name='Infiniium_Beaux' LAProbe='LAProbeSocket' ScopeProbe='ScopeProbeGrabber'/>


<ExtScopeMarkerMgr>要素

<ExtScopeMarkerMgr>要素は、AxおよびBxオシロスコープ・マーカ名を記述します。

属性

名前 | 説明
AxMarkerName | 'Ax (External Scope)'（ロジック・アナライザのAxマーカの名前）
BxMarkerName | 'Bx (External Scope)'（ロジック・アナライザのBxマーカの名前）

親

この要素は、次の親を持つことができます。<Module>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せによって返ります。Infiniium Oscilloscope Time Correlationモジュールを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<ExtScopeMarkerMgr AxMarkerName='Ax (External Scope)' BxMarkerName='Bx (External Scope)'/>


<ExtScopeProgrammer>要素

<ExtScopeProgrammer>は、オシロスコープとロジック・アナライザのセットアップ情報を記述します。

属性

名前 | 説明
LATrigState | '文字列'（ロジック・アナライザがステート・モードで自動スキュー補正を実行するためのXMLトリガ仕様）
LATrigTiming | '文字列'（ロジック・アナライザがタイミング・モードで自動スキュー補正を実行するためのXMLトリガ仕様）
ScopeEdgeSource | 'Channel1'、'Channel2'、'Channel3'、または'Channel4'（スキュー補正信号のエッジ・ソース）
ScopeTrigMode | 'TriggerModeAdvanced'、'TriggerModeEdge'、または'TriggerModeGlitch'（スキュー補正の際のオシロスコープのトリガ・モード）
ScopeTrigSweep | 'TriggerSweepAuto'、'TriggerSweepSingle'、または'TriggerSweepTriggered'（スキュー補正の際のオシロスコープのトリガ掃引設定）
ScopeAuxExtEdgeSlope | 'SlopeNegative'または'SlopePositive'（オシロスコープのスキュー補正信号のスロープ）
ScopeAuxExtTrigLevel | 'floating_point_number'

親

この要素は、次の親を持つことができます。<Module>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せによって返ります。Infiniium Oscilloscope Time Correlationモジュールを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<ExtScopeProgrammer
   ScopeTrigSweep='TriggerSweepSingle'
   ScopeTrigMode='TriggerModeEdge'
   ScopeEdgeSource='Channel1'
   ScopeAuxExtEdgeSlope='SlopePositive'
   ScopeAuxExtTrigLevel='0.000000e+000'
   LATrigTiming='
<Module>
   <Trigger Mode="Timing">
      <Sequence Level="1">
         <If>
            <Event>
               <Anything/>
            </Event>
            <Occurrence Value="1"/>
            <Action>
               <TriggerAction Operator="Fill Memory"/>
            </Action>
         </If>
      </Sequence>
   </Trigger>
</Module>
   '
   LATrigState='
<Module>
   <Trigger Mode="State">
      <StoreQual>
         <Event>
            <Anything/>
         </Event>
      </StoreQual>
      <Sequence Level="1">
         <If>
            <Event>
               <Anything/>
            </Event>
            <Occurrence Value="1"/>
            <Action>
               <TriggerAction Operator="Fill Memory">
                  <StoreQual>
                     <Event>
                        <Anything/>
                     </Event>
                  </StoreQual>
               </TriggerAction>
            </Action>
         </If>
      </Sequence>
   </Trigger>
</Module>
   '
/>