XML Format

Online Help

Version 04.00.0000

Copyright © 2001-2010 Agilent Technologies, Inc.

Warranty
Technology License
Restricted Rights Legend
Safety Notices
Trademarks

August 26, 2010

Table of Contents

XML Format—At a Glance
Simple XML File Editing
XML Element Hierarchy
XML Element Listing
<Action> Element
<Analog> Element
<And> Element
<And> Element (under FilterExpression Event)
<And> Element (under Find Event)
<Anything/> Element
<Arm/> Element
<Axis> Element
<Burst> Element
<BurstAndedLabelN> Element
<BusSignal> Element (for Listing, Compare, and Source Windows)
<BusSignal> Element (for Waveform Window)
<BusSignal> Element (under Module BusSignals)
<BusSignal> Element (under Event)
<BusSignal> Element (under FilterExpression Event)
<BusSignal> Element (under Find Event)
<BusSignalSetup> Element
<BusSignals> Element (for Listing, Compare, and Source Windows)
<BusSignals> Element (for Waveform Window)
<BusSignals> Element (under BusSignalSetup)
<Channel> Element
<Channels> Element
<Clear/> Element
<Clipped> Element
<ClockGroup> Element
<Column> Element
<Columns> Element
<Config> Element
<Configuration> Element
<CounterAction> Element
<CounterEvent> Element
<Data> Element
<DefaultStore/> Element
<Directory> Element
<Edge> Element
<Edges> Element
<Email> Element
<Event> Element
<Event> Element (under FilterExpression)
<Event> Element (under Find)
<ExcludedLabels> Element
<Favorite> Element
<File> Element
<FileInfo> Element
<FilterAction> Element
<FilterExpression> Element
<Filter> Element
<Find> Element
<FlagEvent> Element
<Folder> Element
<Goto> Element
<If> Element
<Label/> Element
<LabelBurstSampleN> Element
<LogicBitsBlockDataSource> Element
<Marker> Element
<Markers> Element
<Master> Element
<Module> Element (under Configuration Setup)
<Module> Element (under Overview)
<Module> Element (under Overview Probe)
<Module> Element (under Overview Setup)
<NetlistImport/> Element
<Nothing/> Element
<Occurrence> Element
<Occurrence> Element (under PatternNTimes)
<Options> Element
<Or> Element
<Or> Element (under FilterExpression Event)
<Or> Element (under Find Event)
<Overview> Element
<PatternNTimes> Element
<PatternReset> Element
<Pod> Element (under PodAssignment)
<Pod> Element (under PodSettings)
<PodAssignment> Element
<PodSettings> Element
<PresentForGreater> Element
<Probe> Element (under Configuration Setup)
<Probe> Element (under Overview)
<Probe> Element (under Overview Setup)
<Qualifier> Element
<Qualifiers> Element
<ResetOccurrenceCount/> Element
<SamplingSetup> Element
<Sampling> Element (for Waveform Window)
<Sampling> Element (under SamplingSetup)
<Save> Element
<Setup> Element (for VbaView Windows)
<Setup> Element (for Waveform Window)
<Setup> Element (under Configuration)
<Setup> Element (under Overview)
<SetupInfo> Element (for LogicBitsBlockDataSource)
<SetupInfo> Element (for TimeDataSource)
<SetupInfo> Element (for SampleNumberDataSource)
<SampleNumberDataSource> Element
<SamplingPositions> Element
<Slave> Element
<SourceDirectories> Element
<StateClockSpec> Element
<Step> Element
<StoreQual> Element
<Store> Element
<Symbol> Element
<Symbols> Element
<TableSetup> Element
<Template> Element
<TimeDataSource> Element
<TimerAction> Element
<TimerEvent> Element
<TimingZoom> Element
<TimingZoomTable> Element
<Tool> Element (under Configuration Setup)
<Tool> Element (under Module)
<Tool> Element (under Overview Setup)
<TriggerAction> Element
<TriggerFavorites> Element
<Trigger> Element
<VbaProject> Element (for VbaView Windows)
<VbaProject> Element (for VBA Macros)
<VbaProjects> Element
<Window> Element (under Configuration Setup)
<Window> Element (under Module)
<Window> Element (under Overview Setup)
XML Element Values


XML Format—At a Glance

Logic analyzer configurations can be saved to XML-format files (or ALA-format files, see ALA vs. XML, When to Use Each Format). Trigger specifications can be saved to XML-format files. You can use XML-format strings with several of the COM automation remote programming commands.

XML format files and strings have markup like <Tag>data</Tag> where Tag is an element name, <Tag> is a start tag, and </Tag> is an end tag. You can edit XML files using any text editor.

XML elements can have data or child elements; child elements can have data or children, and so on. In logic analyzer configuration files, the <Configuration> element can have the child element <Setup>.

<File Content='Hardware Independent Logic Analyzer Configuration'
      Owner='' Project='' Desc='' Version='01.40.0000'
      Date='Oct 20, 2002 10:58:45'>
   <Configuration>
      <Setup>
         <Overview>
            <Clear/>
            ...
         </Overview>
         ...
      </Setup>
   </Configuration>
</File>

XML elements can have attributes, which are name='value' pairs within the element's start tag. In the example above, the <File> element's Version attribute has the value '01.40.0000' and its Date attribute has the value 'Oct 20, 2002 10:58:45'. Values must be contained in quotes.

Empty tags are used for elements that don't have any data. Empty tags are distinguished from start tags by a closing /> instead of a closing >. For example, in logic analyzer configuration files, <Clear/> is an empty tag. Empty tags can have attributes just like ordinary start tags.

  • XML Element Hierarchy

  • XML Element Listing


Simple XML File Editing

A simple way to edit XML files is:

  1. Open the file with the Internet Explorer web browser.

    Internet Explorer displays XML files in an indented, colorized format. You can also contract and expand elements in the hierarchy by clicking the "-" or "+" symbols.

  2. In the web browser's page display area, right-click and choose View Source from the popup menu.

    This opens the file in the Notepad text editor.

  3. After you have saved your changes and exited Notepad, click Refresh in the web browser (or press the F5 key, or choose the View>Refresh command) to view your changes.


XML Element Hierarchy

  • Configuration Files

  • Trigger Specification Files

  • XMLCommand Setup Strings (Not in Configuration Files)

Configuration Files

  • <File>

    • <Configuration>

      • <Clear/>

      • <Setup>

        • <Overview>

          • <Setup>

            • <Module>

            • <Tool>

            • <Window>

            • <Probe>

          • <Module>

            • <Tool>

              • <Window>

            • <Window>

          • <Probe>

            • <Module>

        • <Module>

          • <PodAssignment>

            • <Clear/>

            • <Pod>

          • <SamplingSetup>

            • <Sampling>

            • <StateClockSpec>

              • <Clear/>

              • <Master>

                • <ClockGroup>

                  • <Edges>

                    • <Edge>

                  • <Qualifiers>

                    • <Qualifier>

              • <Slave>

                • <ClockGroup>

                  • <Edges>

                    • <Edge>

                  • <Qualifiers>

                    • <Qualifier>

            • <TimingZoom>

          • <BusSignalSetup>

            • <PodSettings>

              • <Pod>

                • <SamplingPositions>

                  • <Channel>

            • <BusSignals>

              • <Clear/>

              • <BusSignal>

                • <Channels>

                • <Symbols>

                  • <Clear/>

                  • <Symbol>

              • <Folder>

            • <NetlistImport>

          • <Trigger>

            • <StoreQual>

              • <Event>

                • <BusSignal>

                • <Burst>

                • <Anything/>

                • <TimerEvent>

                • <Nothing/>

                • <CounterEvent>

                • <FlagEvent>

                • <Arm/>

                • <And>

                  • <BusSignal>

                  • <Burst>

                  • <Anything/>

                  • <TimerEvent>

                  • <Nothing/>

                  • <CounterEvent>

                  • <FlagEvent>

                  • <Arm/>

                • <Or>

                  • <BusSignal>

                  • <Burst>

                  • <Anything/>

                  • <TimerEvent>

                  • <Nothing/>

                  • <CounterEvent>

                  • <FlagEvent>

                  • <Arm/>

              • <ExcludedLabels>

                • <Label>

            • <Step>

              • <If>

                • <Event>

                  • <BusSignal>

                  • <Burst>

                  • <Anything/>

                  • <TimerEvent>

                  • <Nothing/>

                  • <CounterEvent>

                  • <FlagEvent>

                  • <Arm/>

                  • <And>

                    • <BusSignal>

                    • <Burst>

                    • <Anything/>

                    • <TimerEvent>

                    • <Nothing/>

                    • <CounterEvent>

                    • <FlagEvent>

                    • <Arm/>

                  • <Or>

                    • <BusSignal>

                    • <Burst>

                    • <Anything/>

                    • <TimerEvent>

                    • <Nothing/>

                    • <CounterEvent>

                    • <FlagEvent>

                    • <Arm/>

                • <Occurrence>

                • <PresentForGreater>

                • <Action>

                  • <CounterAction>

                  • <Goto>

                  • <ResetOccurrenceCount/>

                  • <Store>

                  • <TimerAction>

                  • <TriggerAction>

                    • <Email>

                    • <Goto>

                    • <StoreQual>

                      • <Event>

                        • <DefaultStore/>

                        • <Anything/>

                        • <Nothing/>

                        • <BusSignal>

                        • <Burst>

                        • <And>

                          • <Anything/>

                          • <Nothing/>

                          • <BusSignal>

                          • <Burst>

                        • <Or>

                          • <Anything/>

                          • <Nothing/>

                          • <BusSignal>

                          • <Burst>

            • <PatternNTimes>

              • <Event>

                • <BusSignal>

                • <Anything/>

                • <Nothing/>

                • <FlagEvent>

                • <Arm/>

                • <And>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

                • <Or>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

              • <Occurrence>

            • <PatternReset>

              • <Event>

                • <BusSignal>

                • <Anything/>

                • <Nothing/>

                • <FlagEvent>

                • <Arm/>

                • <And>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

                • <Or>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

              • <Event>

                • <BusSignal>

                • <Anything/>

                • <Nothing/>

                • <FlagEvent>

                • <Arm/>

                • <And>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

                • <Or>

                  • <BusSignal>

                  • <Anything/>

                  • <Nothing/>

                  • <FlagEvent>

                  • <Arm/>

          • <TriggerFavorites>

            • <Favorite>

              • <Trigger> (same hierarchy as <Trigger> above)

          • <Config>

          • <Data>

            • <TableSetup>

              • <SampleNumberDataSource>

                • <SetupInfo>

              • <LogicBitsBlockDataSource>

                • <SetupInfo>

              • <TimeDataSource>

                • <SetupInfo>

            • <TimingZoomTable>

              • <SampleNumberDataSource>

                • <SetupInfo>

              • <LogicBitsBlockDataSource>

                • <SetupInfo>

              • <TimeDataSource>

                • <SetupInfo>

          • <FileInfo>

            • <Columns>

              • <Column>

        • <Tool>

          • <Filter> (for Filter/Colorize Tool)

            • <FilterExpression>

              • <Event>

                • <And>

                • <Or>

                  • <BusSignal>

              • <FilterAction>

        • <Window>

          • <BusSignals> (for Listing, Compare, and Source windows)

            • <BusSignal>

          • <Setup> (for Waveform window)

            • <Sampling>

            • <BusSignals>

              • <Clear/>

              • <BusSignal>

                • <Analog>

                  • <Axis>

                  • <Clipped>

          • <Options> (for Compare window)

          • <SourceDirectories> (for Source window)

            • <Directory>

          • <Setup> (for VbaView windows)

            • <Save>

            • <Template>

            • <VbaProject>

        • <Probe>

      • <VbaProjects>

        • <VbaProject>

Trigger Specification Files

  • <File>

    • <Trigger> (same hierarchy as <Trigger> above)

XMLCommand Setup Strings (Not in Configuration Files)

  • <Find>

    • <Event>

      • <And>

      • <Or>

        • <BusSignal>

  • <Markers>

    • <Marker>


XML Element Listing

<Action>
<Analog>
<And>
<And> (under FilterExpression Event)
<And> (under Find Event)
<Anything>
<Arm>
<Axis>
<Burst> (for 16960 logic analyzer burst pattern triggering)
<BurstAndedLabelN> (for 16960 logic analyzer burst pattern triggering)
<BusSignal> (for Listing, Compare, and Source windows)
<BusSignal> (for Waveform window)
<BusSignal> (under BusSignals)
<BusSignal> (under Event)
<BusSignal> (under FilterExpression Event)
<BusSignal> (under Find Event)
<BusSignalSetup>
<BusSignals> (for Listing, Compare, and Source windows)
<BusSignals> (for Waveform window)
<BusSignals> (under BusSignalSetup)
<Channel>
<Channels>
<Clear>
<Clipped>
<ClockGroup>
<Column>
<Columns>
<Config>
<Configuration>
<CounterAction>
<CounterEvent>
<Data>
<DefaultStore>
<Directory>
<Edge>
<Edges>
<Email>
<Event>
<ExcludedLabels>
<Event> (under FilterExpression)
<Event> (under Find)
<Favorite>
<File>
<FileInfo>
<FilterAction>
<FilterExpression>
<Filter>
<Find>
<FlagEvent>
<Folder>
<Goto>
<If>
<Label>
<LabelBurstSampleN> (for 16960 logic analyzer burst pattern triggering)
<LogicBitsBlockDataSource>
<Marker>
<Markers>
<Master>
<Module> (under Configuration Setup)
<Module> (under Overview)
<Module> (under Overview Probe)
<Module> (under Overview Setup)
<NetlistImport>
<Nothing>
<Occurrence>
<Occurrence> (under PatternNTimes)
<Options>
<Or>
<Or> (under FilterExpression Event)
<Or> (under Find Event)
<Overview>
<PatternNTimes>
<PatternReset>
<Pod> (under PodAssignment)
<Pod> (under PodSettings)
<PodAssignment>
<PodSettings>
<PresentForGreater>
<Probe> (under Configuration Setup)
<Probe> (under Overview)
<Probe> (under Overview Setup)
<Qualifier>
<Qualifiers>
<ResetOccurrenceCount>
<SampleNumberDataSource>
<SamplingSetup>
<Sampling> (for Waveform window)
<Sampling> (under SamplingSetup)
<Save>
<Setup> (for VbaView windows)
<Setup> (for Waveform window)
<Setup> (under Configuration)
<Setup> (under Overview)
<SetupInfo> (for LogicBitsBlockDataSource)
<SetupInfo> (for SampleNumberDataSource)
<SetupInfo> (for TimeDataSource)
<SamplingPositions>
<SourceDirectories>
<Slave>
<StateClockSpec>
<Step>
<StoreQual>
<Store>
<Symbol>
<Symbols>
<TableSetup>
<Template>
<TimeDataSource>
<TimerAction>
<TimerEvent>
<TimingZoom>
<TimingZoomTable>
<Tool> (under Configuration Setup)
<Tool> (under Module)
<Tool> (under Overview Setup)
<TriggerAction>
<TriggerFavorites>
<Trigger>
<VbaProject> (for VbaView windows)
<VbaProject> (for VBA macros)
<VbaProjects>
<Window> (under Configuration Setup)
<Window> (under Module)
<Window> (under Overview Setup)


<Action> Element

The <Action> element specifies an action to take in the trigger sequence.

Children

This element can have the following children: <CounterAction>, <Goto>, <ResetOccurrenceCount/>, <Store>, <TimerAction>, <TriggerAction>.

Parents

This element can have the following parents: <If>.

Example

<Action>
   <TriggerAction Operator='Fill Memory'>
      <StoreQual>
         <Event>
            <Anything/>
         </Event>
      </StoreQual>
   </TriggerAction>
</Action>


<Analog> Element

The <Analog> element contains the properties of an analog signal in the Waveform window.

Attributes

Name | Description
Connected | 'F' (false) or 'T' (true)
Offset | 'number voltage_unit'
PerDivision | 'number voltage_unit'

Children

This element can have the following children: <Axis>, <Clipped>.

Parents

This element can have the following parents: <BusSignal>.

Example

<BusSignal Module='My External Oscilloscope-1' Name='My Scope C1'
      Color='hFFFF00' Height='150'>
   <Analog Connected='T' PerDivision='969 mV' Offset='1.45 V'>
      <Axis Style='Axis' Color='h808080'/>
      <Clipped Show='T' Color='hFF8000'/>
   </Analog>
</BusSignal>


<And> Element

The <And> element is a conjunction combiner for events in the trigger specification.

Children

This element can have the following children: <BusSignal>, <Burst>, <Anything/>, <TimerEvent>, <Nothing/>, <CounterEvent>, <FlagEvent>, <Arm/>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <And>
      <BusSignal Name='ADDR' SymbolName='update_system'
            Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
      <TimerEvent ID='1' Operator='Greater Than or Equal To'
            Value='80 ns'/>
   </And>
</Event>


<And> Element (under FilterExpression Event)

The <And> element combines bus/signal descriptions in a filter event.

Children

This element can have the following children: <BusSignal>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <And>
      <BusSignal Name='ADDR' Value='h000041B0' Operator='Equals'
            Base='Hex'/>
      <BusSignal Name='DATA' Value='h004123D7' Operator='Equals'
            Base='Hex'/>
   </And>
</Event>


<And> Element (under Find Event)

The <And> element combines bus/signal descriptions in a find event.

Children

This element can have the following children: <BusSignal>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <And>
      <BusSignal Name='My Bus 1' Bit='All' Operator='Equals'
            Value='h80'/>
      <BusSignal Name='My Bus 128' Bit='All' Operator='Equals'
            Value='h288080'/>
   </And>
</Event>


<Anything/> Element

The <Anything/> element specifies any sample will cause the event.

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <Anything/>
</Event>


<Arm/> Element

The <Arm/> element specifies that an arming signal from another module or an external trigger source will cause the event.

Attributes

Name | Description
ArmFrom | 'External trigger' or module name 'string'

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <Arm ArmFrom='External trigger'/>
</Event>


<Axis> Element

The <Axis> element describes the axis style and color of an analog signal in the Waveform window.

Attributes

Name | Description
Color | 'hex_RGB_value'
Style | 'Axis', 'Grid', or 'None'

Parents

This element can have the following parents: <Analog>.

Example

<Analog Connected='T' PerDivision='969 mV' Offset='1.45 V'>
   <Axis Style='Axis' Color='h808080'/>
   <Clipped Show='T' Color='hFF8000'/>
</Analog>


<Burst> Element

The <Burst> element contains elements that describe burst patterns in the 16960 logic analyzer advanced triggers.

Attributes

Name | Description
NbrActivePatterns | 'number' (number of samples in the burst, can be 2, 3, or 4)
NbrAndedLabels | 'number' (number of AND'ed bus/signal names in the burst pattern)

Children

This element can have the following children: <BurstAndedLabelN>.

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Burst NbrActivePatterns="4" NbrAndedLabels="2">
   <BurstAndedLabel1>
      <LabelBurstSample0 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="hFFFFEEEEDDDDCCCC" />
      <LabelBurstSample1 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="hBBBBAAAA99998888" />
      <LabelBurstSample2 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="h7777666655554444" />
      <LabelBurstSample3 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="h3333222211110000" />
   </BurstAndedLabel1>
   <BurstAndedLabel2>
      <LabelBurstSample0 Name="My Signal 1" Bit="All" Operator="High" />
      <LabelBurstSample1 Name="My Signal 1" Bit="All" Operator="Low" />
      <LabelBurstSample2 Name="My Signal 1" Bit="All" Operator="High" />
      <LabelBurstSample3 Name="My Signal 1" Bit="All" Operator="Low" />
   </BurstAndedLabel2>
</Burst>


<BurstAndedLabelN> Element

The <BurstAndedLabelN> element contains definitions of the samples in a burst pattern for a particular bus/signal. The N in the element name can be any number.

Children

This element can have the following children: <LabelBurstSampleN>.

Parents

This element can have the following parents: <Burst>.

Example

<Burst NbrActivePatterns="4" NbrAndedLabels="2">
   <BurstAndedLabel1>
      <LabelBurstSample0 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="hFFFFEEEEDDDDCCCC" />
      <LabelBurstSample1 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="hBBBBAAAA99998888" />
      <LabelBurstSample2 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="h7777666655554444" />
      <LabelBurstSample3 Name="My Bus 1" Bit="All" Operator="Equals"
            Value="h3333222211110000" />
   </BurstAndedLabel1>
   <BurstAndedLabel2>
      <LabelBurstSample0 Name="My Signal 1" Bit="All" Operator="High" />
      <LabelBurstSample1 Name="My Signal 1" Bit="All" Operator="Low" />
      <LabelBurstSample2 Name="My Signal 1" Bit="All" Operator="High" />
      <LabelBurstSample3 Name="My Signal 1" Bit="All" Operator="Low" />
   </BurstAndedLabel2>
</Burst>


<BusSignal> Element (for Listing, Compare, and Source Windows)

The <BusSignal> element contains the properties of a bus/signal (or other) column in the Listing window.

Attributes

Name | Description
Alignment | 'Left', 'Center', or 'Right'
Color | 'hex_RGB_value'
DefaultBase | 'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', 'Symbol', 'Voltage' (for analog signals from external oscilloscope module), 'Absolute' (for Time column), 'Relative Previous' (for Time column), or 'Relative Marker' (for Time column)
Module | 'string' (name of module that bus/signal comes from)
Name | 'string' (column name)
Width | 'number_of_pixels'

Parents

This element can have the following parents: <BusSignals>.

Example

<Window Name='Listing-2'>
   <BusSignals>
      <Clear/>
      <BusSignal Module='My 1682D-1' Name='Sample Number'
            Color='hFFFFFF' Alignment='Right' Width='112'/>
      <BusSignal Module='My 1682D-1' Name='My Bus 1' DefaultBase='Hex'
            Color='hFFFFFF' Alignment='Right' Width='113'/>
      <BusSignal Module='My External Oscilloscope-1'
            Name='Sample Number C1' Color='hFFFFFF' Alignment='Right'
            Width='132'/>
      <BusSignal Module='My External Oscilloscope-1' Name='My Scope C1'
            DefaultBase='Voltage' Color='hFFFF00' Alignment='Right'
            Width='98'/>
      <BusSignal Module='My External Oscilloscope-1'
            Name='Sample Number C2' Color='hFFFFFF' Alignment='Right'
            Width='132'/>
      <BusSignal Module='My External Oscilloscope-1' Name='My Scope C2'
            DefaultBase='Voltage' Color='h00FF00' Alignment='Right'
            Width='98'/>
      <BusSignal Name='Time' DefaultBase='Absolute' Color='hFFFFFF'
            Alignment='Right' Width='152'/>
   </BusSignals>
</Window>


<BusSignal> Element (for Waveform Window)

The <BusSignal> element contains the properties of a bus/signal (or other) row in the Waveform window.

Attributes

Name | Description
Color | 'hex_RGB_value'
DefaultBase | 'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', or 'Symbol'
Height | 'number_of_pixels'
Module | 'string' (name of module that bus/signal comes from)
Name | 'string' (row name)

Children

This element can have the following children: <Analog>.

Parents

This element can have the following parents: <BusSignals>.

Example

<Window Name='Waveform-2'>
   <Setup>
      <Sampling PerDivision='5 ns' Delay='0 s'/>
      <BusSignals>
         <Clear/>
         <BusSignal Module='My 1682D-1' Name='My Bus 1'
               DefaultBase='Hex' Color='hFFFFFF' Height='30'/>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C1' Color='hFFFF00' Height='150'>
            <Analog Connected='T' PerDivision='969 mV' Offset='1.45 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C2' Color='h00FF00' Height='150'>
            <Analog Connected='T' PerDivision='683 mV' Offset='2.494 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Name='Time' Color='hFFFFFF' Height='30'/>
      </BusSignals>
   </Setup>
</Window>


<BusSignal> Element (under Module BusSignals)

The <BusSignal> element contains a bus/signal definition.

Attributes

Name | Description
Comment | 'string'
DefaultBase | 'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', or 'Symbol'
Name | 'string'
Polarity | 'Positive' or 'Negative'

Children

This element can have the following children: <Channels>, <Symbols>.

Parents

This element can have the following parents: <BusSignals>, <Folder>.

Example

<BusSignal Name='Motorola PowerQUICC (MPC8XX)\ADDR' Polarity='Positive'
      Comment='' DefaultBase='Hex'>
   <Channels>Pod 2[15:0], Pod 1[15:0]</Channels>
   <Symbols>
      <Clear/>
      <Symbol LowRange='hFFF034D8' Name='update_system'
            Operator='Range' Base='Hex' HighRange='hFFF03557'/>
   </Symbols>
</BusSignal>


<BusSignal> Element (under Event)

The <BusSignal> element defines a bus/signal value that will cause an event.

For more information on symbols and symbol files, see Setting Up Symbols.

Attributes

Name | Description
Base

'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', or 'Symbol'.

This attribute specifies the displayed number base.

Bit | 'All' or comma-separated string of bit numbers.
Edge

'R' (rising), 'F' (falling), 'E' (either), 'G' (glitch), or 'X' (don't care).

This attribute only applies when Operator='Edge'. The attribute value is multiple characters when used with a bus; for example, an 8-bit bus could have the value 'XXRFXXEG'.

HighRange | 'value' (when Operator='In Range' or 'Not In Range')
LowRange | 'value' (when Operator='In Range' or 'Not In Range')
Module | 'string'
Name | 'string'
Operator

For signals (= 1 bit): 'Rising Edge', 'Falling Edge', 'Either Edge', 'Glitch', 'High', 'Low', or 'Dont Care'

For buses (> 1 bit): 'Equals', 'Not Equal To', 'Greater Than', 'Less Than', 'Greater Than or Equal To', 'Less Than or Equal To', 'In Range', 'Not In Range', or 'Edge'.

SymbolFile | 'full_path_to_file' (when Base='Symbol' and the symbol is from a symbol file, can have a leading shell variable)
SymbolFileHighRange | 'full_path_to_file' (when Base='Symbol' and the symbol is from a symbol file, this is the symbol file for the HighRange attribute, can have a leading shell variable)
SymbolName | 'string' (when Base='Symbol')
SymbolNameHighRange | 'string' (when Base='Symbol', this is the symbol name for the HighRange attribute)
SymbolOffset | 'value' or 'End' (when Base='Symbol', this is the offset from the start of SymbolName, 'End' means the end address of the symbol)
SymbolOffsetHighRange | 'value' or 'End' (when Base='Symbol', this is the offset from the start of SymbolNameHighRange, 'End' means the end address of the symbol)
SymbolType | 'Function', 'Label', 'Section', 'User', or 'Variable' (when Base='Symbol' and the symbol is from a symbol file)
SymbolTypeHighRange | 'Function', 'Label', 'Section', 'User', or 'Variable' (when Base='Symbol' and the symbol is from a symbol file, this is the symbol type for the HighRange attribute)
Value | 'value'

Remarks

If a SymbolName is not found and a Value exists, the Value will be used.

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <BusSignal Name='ADDR' SymbolName='update_system'
         Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
</Event>


<BusSignal> Element (under FilterExpression Event)

The <BusSignal> element describes a bus/signal name and value in a filter event.

For more information on symbols and symbol files, see Setting Up Symbols.

Attributes

Name | Description
Base

'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', 'Symbol', 'String', or 'Voltage' (for analog signals)

('String' is only available when filtering on an inverse assembler generated text only column like the one that contains mnemonics; in this case, the Value attribute should be like Value='$string')

Bit | 'All' or 'number'
HighRange | 'value' (when Operator='In Range' or 'Not In Range')
LowRange | 'value' (when Operator='In Range' or 'Not In Range')
Name | 'string'
Operator

For buses (> 1 bit): 'Equals', 'Not Equal To', 'Greater Than', 'Less Than', 'Greater Than or Equal To', 'Less Than or Equal To', 'In Range', or 'Not In Range'

For signals (= 1 bit): 'Dont Care', 'High', or 'Low'

SymbolFile | 'full_path_to_file' (when Base='Symbol' and the symbol is from a symbol file, can have a leading shell variable)
SymbolFileHighRange | 'full_path_to_file' (when Base='Symbol' and the symbol is from a symbol file, this is the symbol file for the HighRange attribute, can have a leading shell variable)
SymbolName | 'string' (when Base='Symbol')
SymbolNameHighRange | 'string' (when Base='Symbol', this is the symbol name for the HighRange attribute)
SymbolOffset | 'value' or 'End' (when Base='Symbol', this is the offset from the start of SymbolName, 'End' means the end address of the symbol)
SymbolOffsetHighRange | 'value' or 'End' (when Base='Symbol', this is the offset from the start of SymbolNameHighRange, 'End' means the end address of the symbol)
SymbolType | 'Function', 'Label', 'Section', 'User', or 'Variable' (when Base='Symbol' and the symbol is from a symbol file)
SymbolTypeHighRange | 'Function', 'Label', 'Section', 'User', or 'Variable' (when Base='Symbol' and the symbol is from a symbol file, this is the symbol type for the HighRange attribute)
Value | 'value'

Parents

This element can have the following parents: <And>, <Event>, <Or>.

Example

<BusSignal Name='Cycle Type-1' SymbolName='overfetch'
   Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
   Operator='Equals' Base='Symbol'/>


<BusSignal> Element (under Find Event)

The <BusSignal> element describes a bus/signal name and value in a find event.

Attributes

Name | Description
Bit | 'All' or 'number'
HighRange | 'value' (when Operator='In Range' or 'Not In Range')
LowRange | 'value' (when Operator='In Range' or 'Not In Range')
Name | 'string'
Operator | For buses (> 1 bit): 'Equals', 'Not Equal To', 'Greater Than', 'Less Than', 'Greater Than or Equal To', 'Less Than or Equal To', 'In Range', or 'Not In Range' For signals (= 1 bit): 'Rising Edge', 'Either Edge', or 'Falling Edge', or 'High', or 'Low' For all buses/signals: 'Entering', 'Exiting', or 'Transitioning'
Value | 'value'

Remarks

In the find Operator:

  • 'Entering' means the first sample of one or more consecutive samples that match the pattern.

  • 'Exiting' means the sample after one or more consecutive samples that match the pattern.

  • 'Transitioning' means entering or exiting one or more consecutive samples that match the pattern.

Parents

This element can have the following parents: <And>, <Event>, <Or>.

Example

<BusSignal Name='My Bus 1' Bit='All' Operator='Equals' Value='h80'/>


<BusSignalSetup> Element

The <BusSignalSetup> element contains a <PodSettings> element and a <BusSignals> element.

Children

This element can have the following children: <BusSignals>, <PodSettings>, <NetlistImport>.

Parents

This element can have the following parents: <Module>.

Example

<BusSignalSetup>
   <PodSettings>
      <Pod Index='1' StateClockSetting='Master Clock'
            ProbeType='General purpose probing' Threshold='TTL'/>
      <Pod Index='2' StateClockSetting='Master Clock'
            ProbeType='General purpose probing' Threshold='TTL'/>
      <Pod Index='3' StateClockSetting='Master Clock'
            ProbeType='General purpose probing' Threshold='TTL'/>
      <Pod Index='4' StateClockSetting='Master Clock'
            ProbeType='General purpose probing' Threshold='TTL'/>
   </PodSettings>
   <BusSignals>
      <Clear/>
      <BusSignal Name='Motorola PowerQUICC (MPC8XX)\VFLS'
            Polarity='Positive' Comment='' DefaultBase='Symbol'>
         <Channels>Pod 3[15:14]</Channels>
         <SamplingPositions>
            <Channel Index="0" SamplePosition="1.25 ns" />
            <Channel Index="1" SamplePosition="1.25 ns" />
         <SamplingPositions/>
         <Symbols>
            <Clear/>
            <Symbol Name='debug' Value='h3' Operator='Equals'
                  Base='Hex'/>
            <Symbol Name='2 flsh' Value='h2' Operator='Equals'
                  Base='Hex'/>
            <Symbol Name='1 flsh' Value='h1' Operator='Equals'
                  Base='Hex'/>
            <Symbol Name='0 flsh' Value='h0' Operator='Equals'
                  Base='Hex'/>
         </Symbols>
      </BusSignal>
   </BusSignals>
   <Probes>
      <Clear/>
      <Probe Name='J2' Type='E5385A - 100 pin single-ended Samtec probe'
            NumberOfPins='80' NumberOfPods='2'>
         <Pod Index='3' Prompt='Odd'/>
         <Pod Index='4' Prompt='Even'/>
      </Probe>
      <Probe Name='J1' Type='E5394A - Soft touch single-ended probe'
            NumberOfPins='54' NumberOfPods='2'>
         <Pod Index='1' Prompt='Odd'/>
         <Pod Index='2' Prompt='Even'/>
      </Probe>
   </Probes>
</BusSignalSetup>


<BusSignals> Element (for Listing, Compare, and Source Windows)

The <BusSignals> element contains the buses/signals that are in the Listing, Compare, or Source window.

Children

This element can have the following children: <Clear/>, <BusSignal>.

Parents

This element can have the following parents: <Window>.

Example

<Window Name='Listing-2'>
   <BusSignals>
      <Clear/>
      <BusSignal Module='My 1682D-1' Name='Sample Number'
            Color='hFFFFFF' Alignment='Right' Width='112'/>
      <BusSignal Module='My 1682D-1' Name='My Bus 1' DefaultBase='Hex'
            Color='hFFFFFF' Alignment='Right' Width='113'/>
      <BusSignal Module='My External Oscilloscope-1'
            Name='Sample Number C1' Color='hFFFFFF' Alignment='Right'
            Width='132'/>
      <BusSignal Module='My External Oscilloscope-1' Name='My Scope C1'
            DefaultBase='Voltage' Color='hFFFF00' Alignment='Right'
            Width='98'/>
      <BusSignal Module='My External Oscilloscope-1'
            Name='Sample Number C2' Color='hFFFFFF' Alignment='Right'
            Width='132'/>
      <BusSignal Module='My External Oscilloscope-1' Name='My Scope C2'
            DefaultBase='Voltage' Color='h00FF00' Alignment='Right'
            Width='98'/>
      <BusSignal Name='Time' DefaultBase='Absolute' Color='hFFFFFF'
            Alignment='Right' Width='152'/>
   </BusSignals>
</Window>


<BusSignals> Element (for Waveform Window)

The <BusSignals> element contains the buses/signals that are in the Waveform window.

Children

This element can have the following children: <Clear/>, <BusSignal>.

Parents

This element can have the following parents: <Window>.

Example

<Window Name='Waveform-2'>
   <Setup>
      <Sampling PerDivision='5 ns' Delay='0 s'/>
      <BusSignals>
         <Clear/>
         <BusSignal Module='My 1682D-1' Name='My Bus 1'
               DefaultBase='Hex' Color='hFFFFFF' Height='30'/>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C1' Color='hFFFF00' Height='150'>
            <Analog Connected='T' PerDivision='969 mV' Offset='1.45 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C2' Color='h00FF00' Height='150'>
            <Analog Connected='T' PerDivision='683 mV' Offset='2.494 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Name='Time' Color='hFFFFFF' Height='30'/>
      </BusSignals>
   </Setup>
</Window>


<BusSignals> Element (under BusSignalSetup)

The <BusSignals> element contains bus/signal definitions.

Children

This element can have the following children: <Clear/>, <Folder>, <BusSignal>.

Parents

This element can have the following parents: <BusSignalSetup>.

Example

<BusSignals>
   <Clear/>
   <BusSignal Name='Motorola PowerQUICC (MPC8XX)\AT2'
         Polarity='Positive' Comment='' DefaultBase='Symbol'>
      <Channels>Pod 3[13]</Channels>
      <SamplingPositions>
         <Channel Index="0" SamplePosition="1.25 ns" />
      <SamplingPositions/>
      <Symbols>
         <Clear/>
         <Symbol Name='----' Operator='High' Base='Symbol'/>
         <Symbol Name='----' Operator='High' Base='Symbol'/>
      </Symbols>
   </BusSignal>
   ...
   <BusSignal Name='Motorola PowerQUICC (MPC8XX)\VFLS'
         Polarity='Positive' Comment='' DefaultBase='Symbol'>
      <Channels>Pod 3[15:14]</Channels>
      <SamplingPositions>
         <Channel Index="0" SamplePosition="1.25 ns" />
         <Channel Index="1" SamplePosition="1.25 ns" />
      <SamplingPositions/>
      <Symbols>
         <Clear/>
         <Symbol Name='debug' Value='h3' Operator='Equals' Base='Hex'/>
         <Symbol Name='2 flsh' Value='h2' Operator='Equals' Base='Hex'/>
         <Symbol Name='1 flsh' Value='h1' Operator='Equals' Base='Hex'/>
         <Symbol Name='0 flsh' Value='h0' Operator='Equals' Base='Hex'/>
      </Symbols>
   </BusSignal>
</BusSignals>


<Channel> Element

The <Channel> element is used when setup/hold values are specified for logic analyzer channels individually.

Attributes

Name | Description
FindEye | 'Off' or 'On'
SamplePosition | 'number time_unit'
Index | 'number'

Parents

This element can have the following parents: <SamplingPositions>

Example

<SamplingPositions'>
   <Channel Index='0' FindEye='On' SamplePosition='615 ps'/>
   <Channel Index='1' FindEye='On' SamplePosition='-517 ps'/>
   <Channel Index='2' FindEye='On' SamplePosition='-366 ps'/>
   <Channel Index='3' FindEye='On' SamplePosition='1.025 ns'/>
   <Channel Index='4' FindEye='On' SamplePosition='439 ps'/>
   <Channel Index='5' FindEye='On' SamplePosition='-79 ps'/>
   <Channel Index='6' FindEye='On' SamplePosition='-79 ps'/>
   <Channel Index='7' FindEye='On' SamplePosition='-38 ps'/>
   <Channel Index='8' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='9' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='10' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='11' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='12' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='13' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='14' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='15' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='16' FindEye='Off' SamplePosition='-800 ps'/>
</SamplingPositions>


<Channels> Element

The <Channels> element specifies the logic analyzer channels assigned to the bus/signal.

Data

This element's data is a string representing the selected channels for a bus/signal (as shown in the user interface — see To reorder bits by editing the Channels Assigned string).

Parents

This element can have the following parents: <BusSignal>.

Example

<Channels>Pod 2[15:0], Pod 1[15:0]</Channels>


<Clear/> Element

The <Clear/> element tells the logic analyzer to clear all the setup information related to the parent element.

Parents

This element can have the following parents: <BusSignals>, <Configuration>, <PodAssignment>, <StateClockSpec>, <Symbols>.

Example

<Configuration>
   <Clear/>
   ...
</Configuration>


<Clipped> Element

The <Clipped> element describes whether clipped portions of an analog signal in the Waveform window are displayed in the defined color.

Attributes

Name | Description
Color | 'hex_RGB_value'
Show | 'F' (false) or 'T' (true)

Parents

This element can have the following parents: <Analog>.

Example

<Analog Connected='T' PerDivision='969 mV' Offset='1.45 V'>
   <Axis Style='Axis' Color='h808080'/>
   <Clipped Show='T' Color='hFF8000'/>
</Analog>


<ClockGroup> Element

The <ClockGroup> element contains edges and qualifier specifications.

Children

This element can have the following children: <Edges>, <Qualifiers>.

Parents

This element can have the following parents: <Master>, <Slave>.

Example

<StateClockSpec Mode='Master/Slave/Demux'>
   <Clear/>
   <Master>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='1' Value='Rising'/>
         </Edges>
         <Qualifiers Operator='And'>
            <Qualifier PodIndex='4' Level='High'/>
            <Qualifier PodIndex='2' Level='Low'/>
         </Qualifiers>
      </ClockGroup>
   </Master>
   <Slave>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='2' Value='Falling'/>
         </Edges>
      </ClockGroup>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='3' Value='Rising'/>
            <Edge PodIndex='4' Value='Either'/>
         </Edges>
      </ClockGroup>
   </Slave>
</StateClockSpec>


<Column> Element

The <Column> element describes a column of data in an import file.

Attributes

Name | Description
Exponent | 'number' (when Type='Time Absolute' or 'Time Relative')
Format | 'Ignored' or 'Voltage'
Index | 'number'
Name | 'string'
Scale | 'number'
Type | 'Line Number', 'Sample Number', 'Time Absolute', 'Time Relative', or 'Value'
Width | 'number' (when Type='Value')

Parents

This element can have the following parents: <Columns>.

Example

<Columns>
   <Column Index="1" Name="Sample Number" Type="Sample Number"
         Format="Ignored" />
   <Column Index="2" Name="My Bus 1" Type="Value" Format="Voltage"
         Width="8" />
   <Column Index="3" Name="Time" Type="Time Absolute" Format=""
         Scale="1e+000" Exponent="-12" />
</Columns>

See Also

  • COLUMN Syntax in Module CSV and Module Binary File Header Format


<Columns> Element

The <Columns> element contains a data import file's column descriptions.

Children

This element can have the following children: <Column>.

Parents

This element can have the following parents: <FileInfo>.

Example

<Columns>
   <Column Index="1" Name="Sample Number" Type="Sample Number"
         Format="Ignored" />
   <Column Index="2" Name="My Bus 1" Type="Value" Format="Voltage"
         Width="8" />
   <Column Index="3" Name="Time" Type="Time Absolute" Format=""
         Scale="1e+000" Exponent="-12" />
</Columns>


<Config> Element

The <Config> element is used when setup/hold values are specified for logic analyzer channels individually.

Attributes

Name | Description
CorrelatedTriggerTime | 'number time_unit' (relative to system trigger time)
SystemTrigger | 'F' (false) or 'T' (true)
TimeOfTrigger | 'number time_unit' (seconds since the epoch)
UserSkewTime | 'number time_unit'

Parents

This element can have the following parents: <Module>.

Example

<Config TimeOfTrigger='1.07412004001872 Gs'
      CorrelatedTriggerTime='43.69575 us' UserSkewTime='0 s'
      SystemTrigger='T'/>


<Configuration> Element

The <Configuration> element contains the logic analyzer setup information.

Children

This element can have the following children: <Clear/>, <Setup>, <VbaProjects>.

Parents

This element can have the following parents: <File>.

Example

<Configuration>
   <Clear/>
   <Setup>
      ...
   </Setup>
</Configuration>


<CounterAction> Element

The <CounterAction> element specifies a counter action.

Attributes

Name | Description
ID | 'counter_number'
Operator | 'Increment' or 'Reset'

Parents

This element can have the following parents: <Action>.

Example

<Action>
   <CounterAction ID='1' Operator='Increment'/>
</Action>


<CounterEvent> Element

The <CounterEvent> element defines a counter value that will cause an event.

Attributes

Name | Description
ID | 'counter_number'
Operator | '&gt;=' or '&lt;' ("greater than or equal to" or "less than")
Value | 'integer'

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <CounterEvent ID='1' Operator='&gt;=' Value='10'/>
</Event>


<Data> Element

When data and setup information are saved to XML format configuration files, the <Data> element contains information about the binary data files that are saved.

Children

This element can have the following children: <TableSetup>, <TimingZoomTable>.

Parents

This element can have the following parents: <Module>.

Example

<Data>
   <TableSetup RowCount='65536' TriggerIndex='0' OffsetTime='0 s'
         TimePrecision='1 ns' FileName='las33_data02of04.mfb'>
      <SampleNumberDataSource Type='Periodic'>
         <SetupInfo RowCount='65536' TriggerIndex='0' SamplePeriod='1'/>
      </SampleNumberDataSource>
      <LogicBitsBlockDataSource Type='Page'>
         <SetupInfo RowCount='65536' BitsPerSample='68' PageSize='32768'
               FileOffset='0'/>
      </LogicBitsBlockDataSource>
      <TimeDataSource Type='Page'>
         <SetupInfo RowCount='65536' PageSize='2048' ValidTime='T'
               FileOffset='589824'/>
      </TimeDataSource>
   </TableSetup>
   <TimingZoomTable RowCount='65519' TriggerIndex='32510'
         OffsetTime='0 s' TimePrecision='10 ps'
         FileName='las33_data02of04.mfb'>
      <SampleNumberDataSource Type='Periodic'>
         <SetupInfo RowCount='65519' TriggerIndex='32510'
               SamplePeriod='1'/>
      </SampleNumberDataSource>
      <LogicBitsBlockDataSource Type='Page'>
         <SetupInfo RowCount='65519' BitsPerSample='68' PageSize='43690'
               FileOffset='1638400'/>
      </LogicBitsBlockDataSource>
      <TimeDataSource Type='Periodic'>
         <SetupInfo RowCount='65519' TriggerIndex='32510'
               SamplePeriod='250 ps'/>
      </TimeDataSource>
   </TimingZoomTable>
</Data>

Binary Data File Format

For each module, there is a single binary data file that contains the module’s data, timing information or time tags, timing zoom data (if appropriate), as well as any hardware filtering information (if applicable). Each section is stored contiguously, with the XML elements under <Data> pointing to the byte offsets within the file for each section. Data is dumped simply by sample/row, starting with the first sample of data, all the way through the last.

If the XML with data file is read back into the system, the paging information in the XML file is used to load the data by pages to increase performance. There is no checksumming of any kind on the data, so data integrity is assumed to be valid whenever these files are loaded. If the file is altered in any way, it should be kept consistent with the format described.

If the number of bits per sample is not a multiple of a byte, then the bytes used for a sample is rounded up to the nearest byte. For example, if a LogicBitsBlockDataSource element specifies 68 bits per sample, then 9 bytes per sample is stored to the file with the upper four bits being undefined.

If you are interested in processing the binary data files saved with XML format configuration files, please contact Agilent Technologies (http://www.agilent.com/find/contactus) for sample parsing code.


<DefaultStore/> Element

The <DefaultStore/> element specifies to use the default storage qualifier when filling memory after a trigger.

Parents

This element can have the following parents: <Event> (within the <TriggerAction> and <StoreQual> element hierarchy).

Example

<TriggerAction Operator='Fill Memory'>
   <StoreQual Mode='Custom'>
      <Event ParensNeeded='F'>
         <DefaultStore / >
      </Event>
   </StoreQual>
</TriggerAction>


<Directory> Element

The <Directory> element specifies a directory in the source directories search path.

Attributes

Name | Description
Path | 'string' (full path)

Parents

This element can have the following parents: <SourceDirectories>.

Example

<SourceDirectories SearchSubdirectories='T'>
   <Directory Path='C:\My Documents\source'/>
   <Directory Path='C:\My Documents\build'/>
</SourceDirectories>


<Edge> Element

The <Edge> element describes a clock edge.

Attributes

Name | Description
PodIndex | 'number'
Value | 'Rising', 'Falling' or 'Either'

Parents

This element can have the following parents: <Edges>.

Example

<Edge PodIndex='2' Value='Falling'/>


<Edges> Element

The <Edges> element describes one or more clock edges. Multiple edges are logically OR'ed.

[Note]

Edges from different pod pairs appear in separate <ClockGroup> elements.

Children

This element can have the following children: <Edge>.

Parents

This element can have the following parents: <ClockGroup>.

Example

<ClockGroup>
   <Edges>
      <Edge PodIndex='2' Value='Falling'/>
   </Edges>
</ClockGroup>
<ClockGroup>
   <Edges>
      <Edge PodIndex='3' Value='Rising'/>
      <Edge PodIndex='4' Value='Either'/>
   </Edges>
</ClockGroup>


<Email> Element

The <Email> element specifies e-mail parameters when a trigger action specifies to "e-mail and fill memory".

Attributes

Name | Description
Body | 'string'
Subject | 'string'
To | 'string'

Parents

This element can have the following parents: <TriggerAction>.

Example

<TriggerAction Operator='Email and Fill Memory'>
   <StoreQual Mode='Custom'>
      <Event>
         <DefaultStore/>
      </Event>
   </StoreQual>
   <Email To='first_last@company.com' Subject='Logic analyzer triggered'
         Body='Here's the message body.'/>
</TriggerAction>


<Event> Element

The <Event> element contains a Boolean combination of individual events, using conjunctions as combiners.

Attributes

Name | Description
ParensNeeded | 'F' (false) or 'T' (true) (whether user-defined parentheses are used in the event list)

Children

This element can have the following children: <BusSignal>, <Burst>, <Anything/>, <TimerEvent>, <Nothing/>, <CounterEvent>, <FlagEvent>, <Arm/>, <And>, <Or>.

Parents

This element can have the following parents: <If>, <StoreQual>.

Example

<Event>
   <And>
      <BusSignal Name='ADDR' SymbolName='update_system'
            Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
      <TimerEvent ID='1' Operator='Greater Than or Equal To'
            Value='80 ns'/>
   </And>
</Event>


<Event> Element (under FilterExpression)

The <Event> element describes a filter event.

Children

This element can have the following children: <BusSignal>, <And>, <Or>.

Parents

This element can have the following parents: <FilterExpression>.

Example

<Event>
   <Or>
      <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
         Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
         Operator='Equals' Base='Symbol'/>
      <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
         Value='bXXXX XXXX XX1X XXXX 1XXX XXXX XXXX XXX1'
         Operator='Equals' Base='Symbol'/>
   </Or>
</Event>


<Event> Element (under Find)

The <Event> element describes a find event.

Children

This element can have the following children: <BusSignal>, <And>, <Or>.

Parents

This element can have the following parents: <Find>.

Example

<Event>
   <And>
      <BusSignal Name='My Bus 1' Bit='All' Operator='Equals'
            Value='h80'/>
      <BusSignal Name='My Bus 128' Bit='All' Operator='Equals'
            Value='h288080'/>
   </And>
</Event>


<ExcludedLabels> Element

The <ExcludedLabels> element contains buses/signals to be excluded from the storage qualifier in the transitional timing mode.

Children

This element can have the following children: <Label/>.

Parents

This element can have the following parents: <StoreQual>.

Example

<StoreQual Mode='Transitional'>
   <ExcludedLabels>
      <Label Name='My Signal 1'/>
      <Label Name='My Signal 2'/>
      <Label Name='My Signal 3'/>
   </ExcludedLabels>
</StoreQual>


<Favorite> Element

The <Favorite> element names and contains a favorite trigger specification.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <Trigger>.

Parents

This element can have the following parents: <TriggerFavorites>.

Example

<Favorite Name='First Trigger'>
   <Trigger Mode='State'>
      ...
   </Trigger>
</Favorite>


<File> Element

Agilent logic analyzer XML-format files begin with a <File> element that indicates:

  • the type of content (configuration file or trigger specification file)

  • owner, project, and description information if saved with the file

  • the Agilent Logic Analyzer version that created the file

  • the date the file was created

Attributes

Name | Description
Content | 'Hardware Independent Logic Analyzer Configuration' or 'Logic Analyzer Trigger Specification'
Date | 'string'
Desc | 'string'
Owner | 'string'
Project | 'string'
Version | 'string'

Children

This element can have the following children: <Configuration> (in configuration files) or <Trigger> (in trigger specification files).

Parents

None. The <File> element must be the first element in any logic analyzer configuration or trigger specification file.

Example

<File Content='Hardware Independent Logic Analyzer Configuration'
      Version='01.40.0000' Desc='' Project='' Owner=''
      Date='Oct 7, 2002 11:08:54'>
   <Configuration>
      ...
   </Configuration>
</File>

<File Content='Logic Analyzer Trigger Specification'
      Version='01.40.0000' Desc='' Project='' Owner=''
      Date='Oct 7, 2002 11:41:37'>
   <Trigger Mode='State'>
      ...
   </Trigger>
</File>


<FileInfo> Element

The <FileInfo> element is used with data import modules.

Attributes

Name | Description
BytesPerRow | 'number'
FillInPolicy | 'string'
Format Description | 'string'
IsBigEndian | 'F' (false) or 'T' (true)
IsBinary | 'F' (false) or 'T' (true)
Name | 'string'
NumRows | 'number'
SamplePeriod | 'number'
Separator | 'string'
TimeColumn | 'string'
tModified | 'number'
tRead | 'number'
TriggerOffset | 'number'
TriggerRow | 'number'

Children

This element can have the following children: <Columns>.

Parents

This element can have the following parents: <Module>.

Example

<FileInfo Name="C:\My Documents\Config Files\large.csv"
      tRead="1131750085" tModified="1131570783"
      FormatDescription="Text (.csv)" IsBinary="F" IsBigEndian="T"
      NumRows="16777216" BytesPerRow="1" TriggerRow="8388608"
      Separator="," TriggerOffset="1.293243909e-002" TimeColumn="Time"
      SamplePeriod="1.67e-009" FillInPolicy="Zeros">
   <Columns>
      <Column Index="1" Name="Sample Number" Type="Sample Number"
            Format="Ignored" />
      <Column Index="2" Name="My Bus 1" Type="Value" Format="Voltage"
            Width="8" />
      <Column Index="3" Name="Time" Type="Time Absolute" Format=""
            Scale="1e+000" Exponent="-12" />
   </Columns>
</FileInfo>

See Also

  • Module CSV and Module Binary File Header Format


<FilterAction> Element

The <FilterAction> element describes a filter action.

Attributes

Name | Description
Color | 'hex_RGB_value' (when Type='Color')
Type | 'Color', 'Hide' or 'Show'

Parents

This element can have the following parents: <FilterExpression>.

Example

<FilterAction Type='Hide'/>

<FilterAction Type='Color' Color='h00ff00'/>


<FilterExpression> Element

The <FilterExpression> element describes a single filter event and action.

Attributes

Name | Description
Enabled | 'F' (false) or 'T' (true)
Name | 'string'

Children

This element can have the following children: <Event>, <FilterAction>.

Parents

This element can have the following parents: <Filter>.

Example

<FilterExpression Name='Overfetch States' Enabled='T'>
   <Event>
      <Or>
         <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
            Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
            Operator='Equals' Base='Symbol'/>
         <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
            Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
            Operator='Equals' Base='Symbol'/>
      </Or>
   </Event>
   <FilterAction Type='Hide'/>
</FilterExpression>


<Filter> Element

The <Filter> element contains setup information for the Filter/Colorize tool.

Attributes

Name | Description
Enabled | 'F' (false) or 'T' (true)

Children

This element can have the following children: <FilterExpression>.

Parents

This element can have the following parents: <Tool>.

Example

<Filter Enabled='T'>
   <FilterExpression Name='Idle/Wait States' Enabled='T'>
      <Event>
         <BusSignal Name='Cycle Type-1' SymbolName='idle'
            Value='bXXXX XXXX XXXX XXXX XXXX XXXX X1XX XXX1'
            Operator='Equals' Base='Symbol'/>
      </Event>
      <FilterAction Type='Hide'/>
   </FilterExpression>
   <FilterExpression Name='Extension Words' Enabled='T'>
      <Event>
         <BusSignal Name='Cycle Type-1' SymbolName='extension'
            Value='bXXXX XXXX XXXX XXXX XXXX XXXX XX1X XXX1'
            Operator='Equals' Base='Symbol'/>
      </Event>
      <FilterAction Type='Hide'/>
   </FilterExpression>
   <FilterExpression Name='Overfetch States' Enabled='T'>
      <Event>
         <Or>
            <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
               Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
               Operator='Equals' Base='Symbol'/>
            <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
               Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
               Operator='Equals' Base='Symbol'/>
         </Or>
      </Event>
      <FilterAction Type='Hide'/>
   </FilterExpression>
</Filter>


<Find> Element

When setting up to find samples in captured data using a COM automation program, the <Find> element is the top element in the XML format string that can be used in the Find method's Event parameter.

Attributes

Name | Description
Direction | 'F' (forward), 'B' (backward)
Duration | 'number time_unit' (when When='Present>', 'Present>=', 'Present<', or 'Present<=')
From | 'Display Center', 'Beginning Of Data', 'End Of Data', 'Trigger', or 'marker_name' (name of currently defined marker)
HighDuration | 'number time_unit' (when When='Present In Range' or 'Not In Range')
LowDuration | 'number time_unit' (when When='Present In Range' or 'Not In Range')
Occurrence | 'number'
When | 'Present', 'Not Present', 'Entering', 'Exiting', 'Transitioning', 'Present>', 'Present>=', 'Present<', 'Present<=', 'Present In Range', or 'Not In Range'

Remarks

In the When find qualifier:

  • 'Entering' means the first sample of one or more consecutive samples that match the pattern.

  • 'Exiting' means the sample after one or more consecutive samples that match the pattern.

  • 'Transitioning' means entering or exiting one or more consecutive samples that match the pattern.

Children

This element can have the following children: <Event>.

Parents

None.

Example

<Find Occurrence='1' From='M1' Direction='F' When='Present'>
   <Event>
      <And>
         <BusSignal Name='My Bus 1' Bit='All' Operator='Equals'
               Value='h80'/>
         <BusSignal Name='My Bus 128' Bit='All' Operator='Equals'
               Value='h288080'/>
      </And>
   </Event>
</Find>


<FlagEvent> Element

The <FlagEvent> element defines a flag value that will cause an event.

Attributes

Name | Description
ID | 'flag_number'
Function | 'Clear' or 'Set'

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <FlagEvent ID='1' Function='Set'/>
</Event>


<Folder> Element

The <Folder> element contains a named group of bus/signal definitions.

Attributes

Name | Description
Comment | 'string'
Name | 'string'

Children

This element can have the following children: <BusSignal>, <Folder>.

Parents

This element can have the following parents: <BusSignals>, <Folder>.

Example

<BusSignals>
   <Clear/>
   <BusSignal Name='My Bus 1' Polarity='Positive' DefaultBase='Hex'
         Comment=''>
      <Channels>Pod 1[7:0]</Channels>
   </BusSignal>
   <Folder Name='My Folder 1' Comment=''>
      <BusSignal Name='My Bus 2' Polarity='Positive' DefaultBase='Hex'
            Comment=''>
         <Channels>Pod 1[15:8]</Channels>
      </BusSignal>
      <Folder Name='My Folder 2' Comment=''>
         <BusSignal Name='My Bus 3' Polarity='Positive'
               DefaultBase='Hex' Comment=''>
            <Channels>Pod 2[7:0]</Channels>
         </BusSignal>
         <Folder Name='My Folder 3' Comment=''>
            <BusSignal Name='My Bus 4' Polarity='Positive'
                  DefaultBase='Hex' Comment=''>
               <Channels>Pod 2[15:8]</Channels>
            </BusSignal>
         </Folder>
      </Folder>
   </Folder>
</BusSignals>


<Goto> Element

The <Goto> element specifies the level to go to in the trigger sequence.

Attributes

Name | Description
Step | 'Next' or 'number'

Parents

This element can have the following parents: <Action>, <TriggerAction>.

Example

<Action>
   <Goto Step='3'/>
</Action>


<If> Element

Each <If> element contains an <Event>, an <Occurrence> or <PresentForGreater>, and an <Action>.

Children

This element can have the following children: <Event>, <Occurrence> or <PresentForGreater>, <Action>.

Parents

This element can have the following parents: <Step>.

Example

<If>
   <Event>
      <BusSignal Name='ADDR' SymbolName='update_system'
            Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
   </Event>
   <Occurrence Value='1'/>
   <Action>
      <TriggerAction Operator='Fill Memory'>
         <StoreQual>
            <Event>
               <Anything/>
            </Event>
         </StoreQual>
      </TriggerAction>
   </Action>
</If>


<Label/> Element

The <Label/> element describes the name of a bus/signal to be excluded from the storage qualifier in the transitional timing mode.

Attributes

Name | Description
Name | 'string'

Parents

This element can have the following parents: <ExcludedLabels>.

Example

<StoreQual Mode='Transitional'>
   <ExcludedLabels>
      <Label Name='My Signal 1'/>
      <Label Name='My Signal 2'/>
      <Label Name='My Signal 3'/>
   </ExcludedLabels>
</StoreQual>


<LabelBurstSampleN> Element

The <LabelBurstSampleN> element defines a sample in a burst pattern for a particular bus/signal. The N in the element name can be 1, 2, 3, or 4.

For more information on symbols and symbol files, see Setting Up Symbols.

Attributes

Name | Description
Base | 'Binary', 'Hex', 'Octal', 'Decimal', 'Signed Decimal', 'ASCII', or 'Symbol'. This attribute specifies the displayed number base.
Bit | 'All'
Name | 'string'
Operator | For signals (= 1 bit): 'High', 'Low', or 'Dont Care' For buses (> 1 bit): 'Equals'.
SymbolFile | 'full_path_to_file' (when Base='Symbol' and the symbol is from a symbol file, can have a leading shell variable)
SymbolName | 'string' (when Base='Symbol')
SymbolOffset | 'value' or 'End' (when Base='Symbol', this is the offset from the start of SymbolName, 'End' means the end address of the symbol)
SymbolType | 'Function', 'Label', 'Section', 'User', or 'Variable' (when Base='Symbol' and the symbol is from a symbol file)
Value | 'value'

Remarks

If a SymbolName is not found and a Value exists, the Value will be used.

Parents

This element can have the following parents: <BurstAndedLabelN>.

Example

<BurstAndedLabel1>
   <LabelBurstSample0 Name="My Bus 1" Bit="All" Operator="Equals"
         Value="hFFFFEEEEDDDDCCCC" />
   <LabelBurstSample1 Name="My Bus 1" Bit="All" Operator="Equals"
         Value="hBBBBAAAA99998888" />
   <LabelBurstSample2 Name="My Bus 1" Bit="All" Operator="Equals"
         Value="h7777666655554444" />
   <LabelBurstSample3 Name="My Bus 1" Bit="All" Operator="Equals"
         Value="h3333222211110000" />
</BurstAndedLabel1>


<LogicBitsBlockDataSource> Element

The <LogicBitsBlockDataSource> element contains information about the module's data from the binary data file.

Attributes

Name | Description
Type | 'Page'

Children

This element can have the following children: <SetupInfo> (for LogicBitsBlockDataSource).

Parents

This element can have the following parents: <TableSetup>, <TimingZoomTable>.

Example

<LogicBitsBlockDataSource Type='Page'>
   <SetupInfo RowCount='65536' BitsPerSample='68' PageSize='32768'
         FileOffset='0'/>
</LogicBitsBlockDataSource>

See Also

  • <SetupInfo> (for LogicBitsBlockDataSource)


<Marker> Element

The <Marker> element describes a marker and its properties.

Attributes

Name | Description
BackgroundColor | 'hex_RGB_value'
Comments | 'string'
ForegroundColor | 'hex_RGB_value'
LockPosition | 'F' (false) or 'T' (true)
Name | 'string'
Position | 'number time_unit'

Parents

This element can have the following parents: <Markers>.

Example

<Marker Name='XML M1' Comments='My Marker' ForegroundColor='hff00ff'
      BackgroundColor='h00ffff' Position='10 ns' LockPosition='T' />


<Markers> Element

When adding or removing markers using a COM automation program, you can use an XML format string to list the markers. The <Markers> element is the top element in the XMLMarkers string parameter of the AddXML and RemoveXML methods.

Children

This element can have the following children: <Marker>.

Parents

None.

Example

<Markers>
   <Marker Name='XML M1' Comments='My Marker' ForegroundColor='hff00ff'
         BackgroundColor='h00ffff' Position='10 ns' LockPosition='T' />
   <Marker Name='XML M2' ForegroundColor='hff00ff'
         BackgroundColor='h00ffff' Position='15 ns' LockPosition='F' />
   <Marker Name='XML M3' BackgroundColor='h00ffff' Position='20 ns'
         LockPosition='T' />
   <Marker Name='XML M4' Position='25 ns' LockPosition='F' />
   <Marker Name='XML M5' LockPosition='T' />
   <Marker Name='XML M6' />
</Markers>


<Master> Element

The <Master> element describes the state mode's master sampling clock.

Children

This element can have the following children: <ClockGroup>.

Parents

This element can have the following parents: <StateClockSpec>.

Example

<Master>
   <ClockGroup>
      <Edges>
         <Edge PodIndex='1' Value='Rising'/>
      </Edges>
      <Qualifiers Operator='And'>
         <Qualifier PodIndex='4' Level='High'/>
         <Qualifier PodIndex='2' Level='Low'/>
      </Qualifiers>
   </ClockGroup>
</Master>


<Module> Element (under Configuration Setup)

The <Module> element describes how the logic analyzer module (hardware) is set up.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <PodAssignment>, <SamplingSetup>, <BusSignalSetup>, <Trigger>, <TriggerFavorites>, <Config>, <Data>, <FileInfo>.

Parents

When used in an XML file, this element can have the following parents: <Setup>.

When used in COM automation, this element is used by the Setup property.

Example

<Module Name='168x/9x Logic Analyzer - 1'>
   <PodAssignment>
      ...
   </PodAssignment>
   <SamplingSetup>
      ...
   </SamplingSetup>
   <BusSignalSetup>
      ...
   </BusSignalSetup>
   <Trigger Mode='State'>
      ...
   </Trigger>
   <TriggerFavorites/>
   <Config ... />
   <Data>
      ...
   </Data>
   <FileInfo>
      ...
   </FileInfo>
</Module>


<Module> Element (under Overview)

The <Module> element is a hierarchy describing how modules, tools, and display windows are connected in the Overview window.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <Tool>, <Window>.

Parents

This element can have the following parents: <Overview>.

Example

<Module Name='168x/9x Logic Analyzer - 1'>
   <Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler - 1'>
      <Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'>
         <Window Name='Listing - 1'/>
         <Window Name='Waveform - 1'/>
      </Tool>
   </Tool>
   <Window Name='Compare - 1'/>
</Module>


<Module> Element (under Overview Probe)

The <Module> element describes a module name in the Overview window hierarchy.

Attributes

Name | Description
Name | 'string'

Parents

This element can have the following parents: <Probe>.

Example

<Module Name='168x/9x Logic Analyzer - 1'/>


<Module> Element (under Overview Setup)

The <Module> element describes the name and type of a module in the Overview window list.

Attributes

Name | Description
Enabled | 'F' (false) or 'T' (true) (optional, corresponds to enabled status in Overview window)
Name | 'string'
NumSlots | 'number' (optional, used for more accurate re-creation of modules when loading XML format configuration files in offline mode)
Split | 'string' (name of other module in split analyzer)
Type | '168x/9x', '1674x/5x', '16753-56', '16910-16911', 'Data Import', or 'Virtual'

Parents

This element can have the following parents: <Setup>.

Example

<Module Name='168x/9x Logic Analyzer - 1' Type='168x/9x'
      Enabled='T' NumSlots='1'/>
<Module Name='168x/9x Logic Analyzer - 2' Type='168x/9x'
      Enabled='T' Split='168x/9x Logic Analyzer - 1' NumSlots='1'/>


<NetlistImport/> Element

The <NetlistImport/> element is an empty element that appears in XML format configuration files.

Parents

This element can have the following parents: <BusSignalSetup>.

Example

<BusSignalSetup>
   ...
   <NetlistImport/>
</BusSignalSetup>


<Nothing/> Element

The <Nothing/> element specifies no sample will cause the event.

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <Nothing/>
</Event>


<Occurrence> Element

The <Occurrence> element specifies the number of times an event must occur and whether the number of events must occur consecutively or eventually.

Attributes

Name | Description
Mode | 'Consecutive' or 'Eventual'
Value | 'number'

Parents

This element can have the following parents: <If>.

Example

<Occurrence Value='1' Mode='Eventual'/>


<Occurrence> Element (under PatternNTimes)

The <Occurrence> element specifies the number of times an event must occur.

Attributes

Name | Description
Value | 'number'

Parents

This element can have the following parents: <PatternNTimes>.

Example

<Occurrence Value='3'/>


<Options> Element

The <Options> element describes Compare window options.

Attributes

Name Description
MaxDifferences

'unsigned_int32'

This attribute is used when stopping the comparison after a specified number of differences.

Range

'marker_name..marker_name'

This attribute is used when comparing the range of samples between the first and second marker. Predefined marker names are:

  • Beginning Of Data

  • End Of Data

  • Trigger

ReferenceOffset

'signed_int32'

This attribute represents the movement of the reference buffer relative to the input.

Parents

When used in an XML file, this element can have the following parents: <Window>.

When used in COM automation, this element is used by the Options property.

Example

<Options ReferenceOffset='-2' Range='M1..M2' MaxDifferences='0'/>


<Or> Element

The <Or> element is a conjunction combiner for events in the trigger specification.

Children

This element can have the following children: <BusSignal>, <Burst>, <Anything/>, <TimerEvent>, <Nothing/>, <CounterEvent>, <FlagEvent>, <Arm/>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <Or>
      <BusSignal Name='ADDR' SymbolName='update_system'
            Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
      <TimerEvent ID='1' Operator='Greater Than or Equal To'
            Value='80 ns'/>
   </Or>
</Event>


<Or> Element (under FilterExpression Event)

The <Or> element combines bus/signal descriptions in a filter event.

Children

This element can have the following children: <BusSignal>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <Or>
      <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
         Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
         Operator='Equals' Base='Symbol'/>
      <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
         Value='bXXXX XXXX XX1X XXXX 1XXX XXXX XXXX XXX1'
         Operator='Equals' Base='Symbol'/>
   </Or>
</Event>


<Or> Element (under Find Event)

The <Or> element combines bus/signal descriptions in a find event.

Children

This element can have the following children: <BusSignal>.

Parents

This element can have the following parents: <Event>.

Example

<Event>
   <Or>
      <BusSignal Name='My Bus 1' Bit='All' Operator='Equals'
            Value='h80'/>
      <BusSignal Name='My Bus 128' Bit='All' Operator='Equals'
            Value='h288080'/>
   </Or>
</Event>


<Overview> Element

The <Overview> element describes the content of and the connection hierarchy in the Overview window.

Children

This element can have the following children: <Setup>, <Module>, <Probe>.

The <Setup> child element lists all the modules, tools, display windows, and probes in the Overview window.

The <Module> child element is a hierarchy describing how modules, tools, and display windows are connected in the Overview window.

The <Probe> child element is a hierarchy describing how probes are connected in the Overview window.

[Note]

Both the <Setup> and <Module> child elements are required in order for display windows to appear.

Parents

When used in an XML file, this element can have the following parents: <Setup>.

When used in COM automation, this element is used by the Overview property.

Example

<Overview>
   <Clear/>
   <Setup>
      <Module Name='168x/9x Logic Analyzer - 1' Type='168x/9x'/>
      <Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler - 1'
         Type='Motorola PowerQUICC (MPC8XX) Inverse Assembler'/>
      <Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'
         Type='Filter/Colorize'/>
      <Window Name='Compare - 1' Type='Compare'/>
      <Window Name='Listing - 1' Type='Listing'/>
      <Window Name='Waveform - 1' Type='Waveform'/>
   </Setup>
   <Module Name='168x/9x Logic Analyzer - 1'>
      <Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler - 1'>
         <Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'>
            <Window Name='Listing - 1'/>
            <Window Name='Waveform - 1'/>
         </Tool>
      </Tool>
      <Window Name='Compare - 1'/>
   </Module>
   <Probe Name='General Purpose Probe-1'>
      <Module Name='168x/9x Logic Analyzer - 1'/>
   </Probe>
</Overview>


<PatternNTimes> Element

The <PatternNTimes> element is used when the <Trigger> element's Mode attribute is 'Turbo'. It contains elements that set up the "Find pattern n times" trigger function.

Children

This element can have the following children: <Event>, <Occurrence>.

Parents

This element can have the following parents: <Trigger>.

Example

<PatternNTimes>
   <Event ParensNeeded='F'>
      <BusSignal Module='My 16950A-1' Name='My Bus 1' Bit='All'
            Operator='Equals' Value='hAA' />
   </Event>
   <Occurrence Value='3' />
</PatternNTimes>


<PatternReset> Element

The <PatternReset> element is used when the <Trigger> element's Mode attribute is 'Turbo'. It contains elements that set up the "Find pattern1, or reset on pattern2" trigger function.

Children

This element can have the following children: <Event>.

Parents

This element can have the following parents: <Trigger>.

Example

<PatternReset>
   <Event ParensNeeded='F'>
      <BusSignal Module='My 16950A-1' Name='My Bus 1' Bit='All'
            Operator='Equals' Value='h55' />
   </Event>
   <Event ParensNeeded='F'>
      <BusSignal Module='My 16950A-1' Name='My Bus 1' Bit='All'
            Operator='Equals' Value='hAA' />
   </Event>
</PatternReset>


<Pod> Element (under PodAssignment)

The <Pod> element lists its index and whether it has inputs for state mode sampling clocks.

Attributes

Name | Description
ClockingPod | 'F' (false) or 'T' (true)
Index | 'number'
ReservedForTagging | 'F' (false) or 'T' (true) (whether the pod is reserved for time tag storage)

Parents

This element can have the following parents: <PodAssignment>.

Example

<Pod Index='1' ClockingPod='T'/>


<Pod> Element (under PodSettings)

The <Pod> element describes a pod's state clock setting, threshold voltage setting, and, if it can be detected, probe type. (If the probe type cannot be detected, "General purpose probing" is used.)

Attributes

Name | Description
ClockThreshold | 'AGP', 'CCT', 'CMOS 5V', 'ECL', 'GTL', 'GTLPlus', 'HSTL', 'LVCMOS 1.5V', 'LVCMOS 1.8V', 'LVCMOS 2.5V', 'LVCMOS 3.3V', 'LVPECL', 'LVTTL', 'PECL', 'SSTL2', 'SSTL3', 'TTL', or 'User' (only available on certain logic analyzers, options vary depending on the probe type detected)
ClockThresholdVoltageValue | 'number voltage_unit' (when ClockThreshold='User')
Index | 'number'
ProbeType | probe name 'string' if the probe type can be detected by the logic analyzer; otherwise, 'General purpose probing'
StateClockSetting | 'Master Clock', 'Slave Clock', 'Demultiplex', 'Dual Sample', or 'Unused'
Threshold | 'AGP', 'CCT', 'CMOS 5V', 'ECL', 'GTL', 'GTLPlus', 'HSTL', 'LVCMOS 1.5V', 'LVCMOS 1.8V', 'LVCMOS 2.5V', 'LVCMOS 3.3V', 'LVPECL', 'LVTTL', 'PECL', 'SSTL2', 'SSTL3', 'TTL', or 'User' (options vary depending on the probe type detected)
ThresholdValue | 'number voltage_unit' (when Threshold='User')

Children

This element can have the following children: <SamplingPositions>.

Parents

This element can have the following parents: <PodSettings>.

Example

<Pod Index='1' StateClockSetting='Master Clock'
      ProbeType='Differential probe' Threshold='Differential'
      ClockThreshold='Differential'>
   <SamplingPositions'>
      <Channel Index='0' FindEye='On' SamplePosition='615 ps'/>
      <Channel Index='1' FindEye='On' SamplePosition='-517 ps'/>
      <Channel Index='2' FindEye='On' SamplePosition='-366 ps'/>
      <Channel Index='3' FindEye='On' SamplePosition='1.025 ns'/>
      <Channel Index='4' FindEye='On' SamplePosition='439 ps'/>
      <Channel Index='5' FindEye='On' SamplePosition='-79 ps'/>
      <Channel Index='6' FindEye='On' SamplePosition='-79 ps'/>
      <Channel Index='7' FindEye='On' SamplePosition='-38 ps'/>
      <Channel Index='8' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='9' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='10' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='11' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='12' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='13' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='14' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='15' FindEye='Off' SamplePosition='-800 ps'/>
      <Channel Index='16' FindEye='Off' SamplePosition='-800 ps'/>
   </SamplingPositions>
<Pod/>


<PodAssignment> Element

The <PodAssignment> element contains <Pod> child elements that describe which of the pods have inputs for state mode sampling clocks.

Children

This element can have the following children: <Clear/>, <Pod>.

Parents

This element can have the following parents: <Module>.

Example

<PodAssignment>
   <Clear/>
   <Pod Index='1' ClockingPod='T'/>
   <Pod Index='2' ClockingPod='T'/>
   <Pod Index='3' ClockingPod='F'/>
   <Pod Index='4' ClockingPod='F'/>
</PodAssignment>


<PodSettings> Element

The <PodSettings> element describes state clock and threshold voltage settings for each pod.

Attributes

Name | Description
SamplingOffset | 'number time_unit'

Children

This element can have the following children: <Pod>.

Parents

This element can have the following parents: <BusSignalSetup>.

Example

<PodSettings>
   <Pod Index='1' StateClockSetting='Master Clock'
         ProbeType='General purpose probing' Threshold='TTL'
         ClockThreshold='TTL'/>
   <Pod Index='2' StateClockSetting='Master Clock'
         ProbeType='General purpose probing' Threshold='TTL'
         ClockThreshold='TTL'/>
   <Pod Index='3' StateClockSetting='Master Clock'
         ProbeType='General purpose probing' Threshold='TTL'
         ClockThreshold='TTL'/>
   <Pod Index='4' StateClockSetting='Master Clock'
         ProbeType='General purpose probing' Threshold='TTL'
         ClockThreshold='TTL'/>
</PodSettings>

<PodSettings SamplingOffset='800 ps'>
   <Pod Index='1' StateClockSetting='Master Clock'
         ProbeType='No probe attached'>
      <SamplingPositions>
         <Channel Index='0' FindEye='Off' SamplePosition='-800 ps' />
         ...
      </SamplingPositions>
   </Pod>
   <Pod Index='2' StateClockSetting='Master Clock'
         ProbeType='No probe attached'>
      <SamplingPositions>
         <Channel Index='0' FindEye='Off' SamplePosition='-800 ps' />
         ...
      </SamplingPositions>
   </Pod>
   <Pod Index='3' StateClockSetting='Master Clock'
         ProbeType='Differential probe' Threshold='Differential'
         ClockThreshold='Differential'>
      <SamplingPositions>
         <Channel Index='0' FindEye='On' SamplePosition='615 ps' />
         ...
      </SamplingPositions>
   </Pod>
   <Pod Index='4' StateClockSetting='Master Clock'
         ProbeType='No probe attached'>
      <SamplingPositions>
         <Channel Index='0' FindEye='Off' SamplePosition='-800 ps' />
         ...
      </SamplingPositions>
   </Pod>
</PodSettings>


<PresentForGreater> Element

The <PresentForGreater> element specifies an amount of time an event must be present for. This element is used in timing mode triggers.

Attributes

Name | Description
Duration | 'number time_unit'

Parents

This element can have the following parents: <If>.

Example

<PresentForGreater Duration='80 ns'/>


<Probe> Element (under Configuration Setup)

The <Probe> element contains setup information for a probe.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children:

  • For information about child elements for probes, see the "Probe Setup, XML Format" topic in the Probe's online help.

Parents

This element can have the following parents: <Setup>.

Example

<Probe Name='General Purpose Probe-1'>
   <Properties>
      <DefinedProbes>
         <Probe Name='J1' Type='E5346A 34-ch Mictor single-ended probe'>
            <Pods>
               <Pod Index='0'/>
               <Pod Index='1'/>
            </Pods>
            <Signals/>
         </Probe>
      </DefinedProbes>
   </Properties>
</Probe>


<Probe> Element (under Overview)

The <Probe> element is a hierarchy describing how probes are connected in the Overview window.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <Module>.

Parents

This element can have the following parents: <Overview>.

Example

<Probe Name='General Purpose Probe-1'>
   <Module Name='168x/9x Logic Analyzer - 1'/>
</Probe>


<Probe> Element (under Overview Setup)

The <Probe> element describes the name and type of a probe in the Overview window list.

Attributes

Name | Description
Enabled | 'F' (false) or 'T' (true) (optional, corresponds to enabled status in Overview window)
Name | 'string'
Type | 'General Purpose Probe', 'FPGA Dynamic Probe', etc.

Parents

This element can have the following parents: <Setup>.

Example

<Probe Name='General Purpose Probe-1' Type='General Purpose Probe'
      Enabled='T'/>


<Qualifier> Element

The <Qualifier> element describes a state mode sampling clock qualifier.

Attributes

Name | Description
Level | 'High' or 'Low'
PodIndex | 'number'

Parents

This element can have the following parents: <Qualifiers>.

Example

<Qualifier PodIndex='2' Level='Low'/>


<Qualifiers> Element

The <Qualifiers> element describes one or more clock qualifiers. The operator for multiple qualifiers is specified as an attribute. (Qualifiers are always logically AND'ed with edges.)

Attributes

Name | Description
Operator | 'And' or 'Or'

Children

This element can have the following children: <Qualifier>.

Parents

This element can have the following parents: <ClockGroup>.

Example

<Qualifiers Operator='And'>
   <Qualifier PodIndex='4' Level='High'/>
   <Qualifier PodIndex='2' Level='Low'/>
</Qualifiers>


<ResetOccurrenceCount/> Element

The <ResetOccurrenceCount/> element specifies a reset of the occurrence counter.

Parents

This element can have the following parents: <Action>.

Example

<Action>
   <ResetOccurrenceCount/>
</Action>


<SamplingSetup> Element

The <SamplingSetup> element describes the logic analyzer sampling mode (state or timing), and if in state mode, describes the sampling clock specification.

Children

This element can have the following children: <Sampling>, <StateClockSpec>, <TimingZoom>.

Parents

This element can have the following parents: <Module>.

Example

Timing mode example:

<SamplingSetup>
   <Sampling ChannelMode='Full' MaxSpeed='400' SamplePeriod='2.5 ns'
      Type='Standard' Acquisition='Timing' AcquisitionDepth='256K'
      TriggerPosition='50'/>
</SamplingSetup>

State mode example:

<SamplingSetup>
   <Sampling ChannelMode='Full' Acquisition='State'
      AcquisitionDepth='256K' MaxSpeed='200' TriggerPosition='50'/>
   <StateClockSpec Mode='Master'>
      <Clear/>
      <Master>
         <ClockGroup>
            <Edges>
               <Edge PodIndex='1' Value='Rising'/>
            </Edges>
            <Qualifiers Operator='And'>
               <Qualifier Level='Low' PodIndex='2'/>
            </Qualifiers>
         </ClockGroup>
      </Master>
   </StateClockSpec>
</SamplingSetup>


<Sampling> Element (for Waveform Window)

The <Sampling> element contains the scale (time/division) and delay settings of a Waveform window.

Attributes

Name | Description
Delay | 'number time_unit'
PerDivision | 'number time_unit'

Parents

This element can have the following parents: <Setup>.

Example

<Sampling PerDivision='5 ns' Delay='0 s'/>


<Sampling> Element (under SamplingSetup)

The <Sampling> element describes the logic analyzer sampling mode (state or timing) and the sampling mode options.

Attributes

Name | Description
Acquisition | 'State' or 'Timing'
AcquisitionDepth | 'string' (as shown in user interface)
ChannelMode | 'Full' or 'Half'
ForcePrestore | 'F' (false) or 'T' (true)
MaxSpeed | 'integer' (in MHz representing maximum sample rate in currently selected mode)
SamplePeriod | 'real_number' (only when Acquisition='Timing')
TriggerPosition | '0-100'
Type | 'Standard' or 'Transitional' only when Acquisition='Timing'

Parents

This element can have the following parents: <SamplingSetup>.

Example

Timing mode example:

<Sampling Acquisition='Timing' Type='Standard' SamplePeriod='2 ns'
   ForcePrestore='T' TriggerPosition='50' AcquisitionDepth='1M'
   ChannelMode='Full' MaxSpeed='500' />

State mode example:

<Sampling Acquisition='State' Type='Normal' ForcePrestore='T'
   TriggerPosition='50' AcquisitionDepth='1M' ChannelMode='Full'
   MaxSpeed='250' />


<Save> Element

The <Save> element contains VbaView window information to be saved with configuration files.

Children

The children of this element are defined by the VbaView window code (for examples, see the sample VbaView windows).

Parents

This element can have the following parents: <Setup>.

Example

<Window Name='Bus vs Bus Sample-1'>
   <Setup>
      <Save>
         <Properties XAxisBusSignal='Sample Number'
               YAxisBusSignal='My Bus 1' StartSample='-1000'
               EndSample='1000' XAxis2sComplement='0'
               YAxis2sComplement='0' ColorGradient='0'/>
      </Save>
      <Template Type='Bus vs Bus Sample'/>
   </Setup>
</Window>


<Setup> Element (for VbaView Windows)

The <Setup> element contains setup information for VbaView windows.

Children

This element can have the following children: <Save>, <Template>, <VbaProject>.

Parents

This element can have the following parents: <Window>.

Example

<Window Name='Bus vs Bus Sample-1'>
   <Setup>
      <Save>
         <Properties XAxisBusSignal='Sample Number'
               YAxisBusSignal='My Bus 1' StartSample='-1000'
               EndSample='1000' XAxis2sComplement='0'
               YAxis2sComplement='0' ColorGradient='0'/>
      </Save>
      <Template Type='Bus vs Bus Sample'/>
   </Setup>
</Window>
<Window Name='Bus vs Bus Sample-2'>
   <Setup>
      <Save>
         <Properties XAxisBusSignal='Sample Number'
               YAxisBusSignal='My Bus 1' StartSample='-1000'
               EndSample='1000' XAxis2sComplement='0'
               YAxis2sComplement='0' ColorGradient='0'/>
      </Save>
      <VbaProject FileName='C:\Documents and Settings\user\My
            Documents\Agilent Technologies\Logic Analyzer\Config
            Files\vbaview_setupVba01.zip'/>
   </Setup>
</Window>


<Setup> Element (for Waveform Window)

The <Setup> element contains setup information for the Waveform window.

Children

This element can have the following children: <Sampling>, <BusSignals>.

Parents

This element can have the following parents: <Window>.

Example

<Window Name='Waveform-2'>
   <Setup>
      <Sampling PerDivision='5 ns' Delay='0 s'/>
      <BusSignals>
         <Clear/>
         <BusSignal Module='My 1682D-1' Name='My Bus 1'
               DefaultBase='Hex' Color='hFFFFFF' Height='30'/>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C1' Color='hFFFF00' Height='150'>
            <Analog Connected='T' PerDivision='969 mV'
                  Offset='1.45 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Module='My External Oscilloscope-1'
               Name='My Scope C2' Color='h00FF00' Height='150'>
            <Analog Connected='T' PerDivision='683 mV'
                  Offset='2.494 V'>
               <Axis Style='Axis' Color='h808080'/>
               <Clipped Show='T' Color='hFF8000'/>
            </Analog>
         </BusSignal>
         <BusSignal Name='Time' Color='hFFFFFF' Height='30'/>
      </BusSignals>
   </Setup>
</Window>


<Setup> Element (under Configuration)

The <Setup> element contains all the configuration information for the logic analyzer and any tools, such as inverse assemblers.

Children

This element can have the following children: <Overview>, <Module>, <Tool>, <Window>, <Probe>.

Parents

This element can have the following parents: <Configuration>.

Remarks

Overview window information and setup appears in the <Overview> element.

Logic analyzer setup information appears in the <Module> element.

Tool setup information appears in the <Tool> element. Each tool must have a unique Name attribute.

Display window setup information appears in the <Window> element.

Example

<Setup>
   <Overview>
      ...
   </Overview>
   <Module Name='168x/9x Logic Analyzer - 1'>
      ...
   </Module>
   <Skew>
      ...
   </Skew>
   <Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler - 1'>
      ...
   </Tool>
   <Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'>
      ...
   </Tool>
   <Window Name='Compare - 1'/>
   <Window Name='Listing - 1'/>
   <Window Name='Waveform - 1'/>
</Setup>


<Setup> Element (under Overview)

The <Setup> element lists all the modules, tools, and display windows in the Overview window.

Children

This element can have the following children: <Module>, <Tool>, <Window>, <Probe>.

Parents

This element can have the following parents: <Overview>.

Example

<Setup>
   <Module Name='MPC860 Demo Board' Type='16910-11' Enabled='T'
         NumSlots='1'/>
   <Module Name='My 16950A-1' Type='16753-56' Enabled='T' NumSlots='1'/>
   <Module Name='My 16750B-1' Type='1674x/5x' Enabled='T' NumSlots='1'/>
   <Module Name='My 16740A-1' Type='1674x/5x' Enabled='T' NumSlots='1'/>
   <Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler-1'
         Type='Motorola PowerQUICC (MPC8XX) Inverse Assembler'
         Enabled='T'/>
   <Tool Name='Packet Decoder-1' Type='Packet Decoder' Enabled='T'/>
   <Tool Name='Filter/Colorize-Motorola PowerQUICC (MPC8XX)'
         Type='Filter/Colorize' Enabled='T'/>
   <Window Name='Listing-2' Type='Listing'/>
   <Window Name='Waveform-2' Type='Waveform'/>
   <Window Name='Listing-3' Type='Listing'/>
   <Window Name='Waveform-3' Type='Waveform'/>
   <Window Name='Listing-4' Type='Listing'/>
   <Window Name='Listing-1' Type='Listing'/>
   <Window Name='Waveform-1' Type='Waveform'/>
   <Window Name='Source-1' Type='Source'/>
   <Probe Name='General Purpose Probe-1' Type='General Purpose Probe'
         Enabled='T'/>
   <Probe Name='General Purpose Probe-2' Type='General Purpose Probe'
         Enabled='T'/>
   <Probe Name='FPGA Dynamic Probe-1' Type='FPGA Dynamic Probe'
         Enabled='T'/>
   <Probe Name='N4220B Packet Analysis Probe-1'
         Type='N4220B Packet Analysis Probe' Enabled='T'/>
</Setup>


<SetupInfo> Element (for LogicBitsBlockDataSource)

The <SetupInfo> element contains additional setup information for the <LogicBitsBlockDataSource> element.

Attributes

Name | Description
BitsPerSample | 'number'
FileOffset | 'number' (bytes within the binary data file where the data begins)
PageSize | 'number' (of bits per page of data)
RowCount | 'number' (of samples)

Parents

This element can have the following parents: <LogicBitsBlockDataSource>.

Example

<LogicBitsBlockDataSource Type='Page'>
   <SetupInfo RowCount='65536' BitsPerSample='68' PageSize='32768'
         FileOffset='0'/>
</LogicBitsBlockDataSource>

See Also

  • <LogicBitsBlockDataSource>


<SetupInfo> Element (for TimeDataSource)

The <SetupInfo> element contains additional setup information for the <TimeDataSource> element.

Attributes

Name | Description
FileOffset | 'number' (bytes within the binary data file where the data begins)
PageSize | 'number' (of bits per page of data)
RowCount | 'number' (of samples)
SamplePeriod | 'number time_unit' (sampling period for the timing data)
TriggerIndex | 'number' (zero-based)
ValidTime | 'F' (false) or 'T' (true)

Parents

This element can have the following parents: <TimeDataSource>.

Examples

<TimeDataSource Type='Page'>
   <SetupInfo RowCount='65536' PageSize='2048' ValidTime='T'
         FileOffset='589824'/>
</TimeDataSource>

<TimeDataSource Type='Periodic'>
   <SetupInfo RowCount='65519' TriggerIndex='32510'
         SamplePeriod='250 ps'/>
</TimeDataSource>

See Also

  • <TimeDataSource>


<SetupInfo> Element (for SampleNumberDataSource)

The <SetupInfo> element contains additional setup information for the <SampleNumberDataSource> element.

Attributes

Name | Description
RowCount | 'number' (of samples)
SamplePeriod | '1'
TriggerIndex | 'number' (zero-based)

Parents

This element can have the following parents: <SampleNumberDataSource>.

Example

<SampleNumberDataSource Type='Periodic'>
   <SetupInfo RowCount='65536' TriggerIndex='0' SamplePeriod='1'/>
</SampleNumberDataSource>

See Also

  • <SampleNumberDataSource>


<SampleNumberDataSource> Element

The <SampleNumberDataSource> element contains information about the sample column in the binary data file.

Attributes

Name | Description
Type | 'Periodic'

Children

This element can have the following children: <SetupInfo> (for SampleNumberDataSource).

Parents

This element can have the following parents: <TableSetup>, <TimingZoomTable>.

Example

<SampleNumberDataSource Type='Periodic'>
   <SetupInfo RowCount='65536' TriggerIndex='0' SamplePeriod='1'/>
</SampleNumberDataSource>

See Also

  • <SetupInfo> (for SampleNumberDataSource)


<SamplingPositions> Element

The <SamplingPositions> element specifies the setup/hold (sampling position) values used for the logic analyzer channels in the bus/signal definition.

Children

This element can have the following children: <Channel>.

Parents

This element can have the following parents: <Pod>.

Example

<SamplingPositions'>
   <Channel Index='0' FindEye='On' SamplePosition='615 ps'/>
   <Channel Index='1' FindEye='On' SamplePosition='-517 ps'/>
   <Channel Index='2' FindEye='On' SamplePosition='-366 ps'/>
   <Channel Index='3' FindEye='On' SamplePosition='1.025 ns'/>
   <Channel Index='4' FindEye='On' SamplePosition='439 ps'/>
   <Channel Index='5' FindEye='On' SamplePosition='-79 ps'/>
   <Channel Index='6' FindEye='On' SamplePosition='-79 ps'/>
   <Channel Index='7' FindEye='On' SamplePosition='-38 ps'/>
   <Channel Index='8' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='9' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='10' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='11' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='12' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='13' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='14' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='15' FindEye='Off' SamplePosition='-800 ps'/>
   <Channel Index='16' FindEye='Off' SamplePosition='-800 ps'/>
</SamplingPositions>


<Slave> Element

The <Slave> element describes the state mode's slave sampling clock.

Children

This element can have the following children: <ClockGroup>.

Parents

This element can have the following parents: <StateClockSpec>.

Example

<Slave>
   <ClockGroup>
      <Edges>
         <Edge PodIndex='2' Value='Falling'/>
      </Edges>
   </ClockGroup>
   <ClockGroup>
      <Edges>
         <Edge PodIndex='3' Value='Rising'/>
         <Edge PodIndex='4' Value='Either'/>
      </Edges>
   </ClockGroup>
</Slave>


<SourceDirectories> Element

The <SourceDirectories> element lists the directories in which to search for source files. It also specifies whether subdirectories are searched.

Attributes

Name | Description
SearchSubdirectories | 'F' (false) or 'T' (true)

Children

This element can have the following children: <Directory>.

Parents

This element can have the following parents: <Window>.

Example

<SourceDirectories SearchSubdirectories='T'>
   <Directory Path='C:\My Documents\source'/>
   <Directory Path='C:\My Documents\build'/>
</SourceDirectories>


<StateClockSpec> Element

The <StateClockSpec> element describes the state mode sampling clock specification.

Attributes

Name | Description
Mode | 'Master', 'Master/Slave/Demux', 'Dual Sample'

Children

This element can have the following children: <Clear/>, <Master>, <Slave>.

Parents

This element can have the following parents: <SamplingSetup>.

Example

<StateClockSpec Mode='Master/Slave/Demux'>
   <Clear/>
   <Master>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='1' Value='Rising'/>
         </Edges>
         <Qualifiers Operator='And'>
            <Qualifier PodIndex='4' Level='High'/>
            <Qualifier PodIndex='2' Level='Low'/>
         </Qualifiers>
      </ClockGroup>
   </Master>
   <Slave>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='2' Value='Falling'/>
         </Edges>
      </ClockGroup>
      <ClockGroup>
         <Edges>
            <Edge PodIndex='3' Value='Rising'/>
            <Edge PodIndex='4' Value='Either'/>
         </Edges>
      </ClockGroup>
   </Slave>
</StateClockSpec>


<Step> Element

The <Step> element's Number attribute is an integer >= 1 specifying the sequence step number of the trigger step. Each "Step" can have multiple "If" children.

Attributes

Name | Description
Number | 'number'

Children

This element can have the following children: <If>.

Parents

This element can have the following parents: <Trigger>.

Example

<Step Number='1'>
   <If>
      <Event>
         <BusSignal Name='ADDR' SymbolName='update_system'
               Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
      </Event>
      <Occurrence Value='1'/>
      <Action>
         <TriggerAction Operator='Fill Memory'>
            <StoreQual>
               <Event>
                  <Anything/>
               </Event>
            </StoreQual>
         </TriggerAction>
      </Action>
   </If>
</Step>


<StoreQual> Element

The <StoreQual> element can have the Not="T" attribute to specify a negation on the store qualifier.

The <StoreQual> element contains an <Event> element to specify the store qualifier.

Attributes

Name | Description
Mode | 'Custom' or 'Transitional'
Not | 'T'

Children

This element can have the following children: <Event>, <ExcludedLabels> (when Mode='Transitional' and you exclude buses/signals).

Parents

This element can have the following parents: <Trigger>, <TriggerAction>.

Example

<StoreQual>
   <Event>
      <Anything/>
   </Event>
</StoreQual>


<Store> Element

The <Store> element specifies what to do with the sample that caused the event to occur or whether to turn default storing on or off.

Attributes

Name | Description
Operator | 'Store sample', 'Don't store sample', 'Turn on default storing', or 'Turn off default storing'

Parents

This element can have the following parents: <Action>.

Example

<Action>
   <Store Operator='Store sample'/>
</Action>


<Symbol> Element

The <Symbol> element describes a symbol name and value.

Examples of Value, LowRange, and HighRange values are: "hff" (hex ff), "b1001" (binary 1001), etc. Base designations are "h", "b", "o", "d".

For more information on symbols and symbol files, see Setting Up Symbols.

Attributes

Name | Description
Base | 'Binary', 'Hex', 'Octal', 'Decimal', or 'Signed Decimal'
File | 'full_path_to_file' (can have a leading shell variable)
HighRange | 'value' (when Operator='Range', can include "X" for don't care digits)
LowRange | 'value' (when Operator='Range', can include "X" for don't care digits)
Name | 'string'
Operator | For buses (> 1 bit): 'Equals' or 'Range' For signals (= 1 bit): 'Dont Care', 'High', or 'Low'
Value | 'value' (can include "X" for don't care digits)

Parents

This element can have the following parents: <Symbols>.

Example

<Symbol File="C:\My Documents\q.elf"/>

<Symbol File="%TMPDIR%\myfile.x"/>

<Symbol LowRange='hFFF034D8' Name='update_system' Operator='Range'
      Base='Hex' HighRange='hFFF03557'/>

<Symbol Name='----' Operator='High'/>

<Symbol Name='4 byte' Value='h0' Operator='Equals' Base='Hex'/>

<Symbol Name='111' Value='h7' Operator='Equals' Base='Hex'/>

<Symbol Name='debug' Value='h3' Operator='Equals' Base='Hex'/>


<Symbols> Element

The <Symbols> element contains the symbols defined for a bus/signal.

Children

This element can have the following children: <Clear/>, <Symbol>.

Parents

When used in an XML file, this element can have the following parents: <BusSignal>.

When used in COM automation, this element is used by the Symbols property.

Example

<Symbols>
   <Clear/>
   <Symbol Name='add_to_history' Operator='Range' LowRange='hFFF03AAC'
         HighRange='hFFF03B0F'/>
   <Symbol Name='boot_q' Operator='Range' LowRange='hFFF02114'
         HighRange='hFFF0241B'/>
   <Symbol Name='clear_hist_buff' Operator='Range' LowRange='hFFF03474'
         HighRange='hFFF034D3'/>
   <Symbol Name='do_sort' Operator='Range' LowRange='hFFF03394'
         HighRange='hFFF0346F'/>
   <Symbol Name='get_targets' Operator='Range' LowRange='hFFF0355C'
         HighRange='hFFF03643'/>
   <Symbol Name='init_system' Operator='Range' LowRange='hFFF03B14'
         HighRange='hFFF03D2B'/>
   <Symbol Name='main' Operator='Range' LowRange='hFFF03164'
         HighRange='hFFF031AF'/>
   <Symbol Name='proc_spec_init' Operator='Range' LowRange='hFFF0407C'
         HighRange='hFFF040C7'/>
   <Symbol Name='proc_specific' Operator='Range' LowRange='hFFF040CC'
         HighRange='hFFF044C7'/>
   <Symbol Name='read_conditions' Operator='Range' LowRange='hFFF03648'
         HighRange='hFFF03787'/>
   <Symbol Name='save_points' Operator='Range' LowRange='hFFF03984'
         HighRange='hFFF03AA7'/>
   <Symbol Name='set_outputs' Operator='Range' LowRange='hFFF0378C'
         HighRange='hFFF03897'/>
   <Symbol Name='update_display' Operator='Range' LowRange='hFFF031B4'
         HighRange='hFFF0338F'/>
   <Symbol Name='update_system' Operator='Range' LowRange='hFFF034D8'
         HighRange='hFFF03557'/>
</Symbols>


<TableSetup> Element

The <TableSetup> element describes the part of the binary data file that contains normal (that is, not TimingZoom) data.

Attributes

Name | Description
FileName | 'relative_path_file_name'
OffsetTime | 'number time_unit'
RowCount | 'number'
TimePrecision | 'number time_unit'
TriggerIndex | 'number'

Children

This element can have the following children: <SampleNumberDataSource>, <LogicBitsBlockDataSource>, <TimeDataSource>.

Parents

This element can have the following parents: <Data>.

Example

<TableSetup RowCount='65536' TriggerIndex='0' OffsetTime='0 s'
      TimePrecision='1 ns' FileName='las33_data02of04.mfb'>
   <SampleNumberDataSource Type='Periodic'>
      <SetupInfo RowCount='65536' TriggerIndex='0' SamplePeriod='1'/>
   </SampleNumberDataSource>
   <LogicBitsBlockDataSource Type='Page'>
      <SetupInfo RowCount='65536' BitsPerSample='68' PageSize='32768'
            FileOffset='0'/>
   </LogicBitsBlockDataSource>
   <TimeDataSource Type='Page'>
      <SetupInfo RowCount='65536' PageSize='2048' ValidTime='T'
            FileOffset='589824'/>
   </TimeDataSource>
</TableSetup>


<Template> Element

The <Template> element identifies the template used to create the VbaView window. This element appears when there have been no modifications to the VbaView window code.

Attributes

Name | Description
Type | 'Bus vs Bus Sample', 'Distribution Sample', 'Export to IE Sample', 'External Scope Web Control', or 'Hello World Sample'

Parents

This element can have the following parents: <Setup>.

Example

<Window Name='Bus vs Bus Sample-1'>
   <Setup>
      <Save>
         <Properties XAxisBusSignal='Sample Number'
               YAxisBusSignal='My Bus 1' StartSample='-1000'
               EndSample='1000' XAxis2sComplement='0'
               YAxis2sComplement='0' ColorGradient='0'/>
      </Save>
      <Template Type='Bus vs Bus Sample'/>
   </Setup>
</Window>


<TimeDataSource> Element

The <TimeDataSource> element contains information about the time column in the binary data file.

Attributes

Name | Description
Type | 'Page' or 'Periodic'

Children

This element can have the following children: <SetupInfo> (for TimeDataSource).

Parents

This element can have the following parents: <TableSetup>, <TimingZoomTable>.

Examples

<TimeDataSource Type='Page'>
   <SetupInfo RowCount='65536' PageSize='2048' ValidTime='T'
         FileOffset='589824'/>
</TimeDataSource>

<TimeDataSource Type='Periodic'>
   <SetupInfo RowCount='65519' TriggerIndex='32510'
         SamplePeriod='250 ps'/>
</TimeDataSource>

See Also

  • <SetupInfo> (for TimeDataSource)


<TimerAction> Element

The <TimerAction> element specifies a timer action.

Attributes

Name | Description
ID | 'timer_number'
Operator | "Start from reset", "Stop and reset", "Pause", or "Resume"

Parents

This element can have the following parents: <Action>.

Example

<Action>
   <TimerAction ID='1' Operator='Stop and reset'/>
</Action>


<TimerEvent> Element

The <TimerEvent> element defines a timer value that will cause an event.

Attributes

Name | Description
ID | 'timer_number'
Operator | '&gt;=' or '&lt;' ("greater than or equal to" or "less than")
Value | 'number time_unit'

Parents

This element can have the following parents: <Event>, <And>, <Or>.

Example

<Event>
   <TimerEvent ID='1' Operator='&gt;=' Value='80 ns'/>
</Event>


<TimingZoom> Element

The <TimingZoom> element describes the timing zoom sampling settings.

Attributes

Name | Description
AlignWithSubModuleNumber | 'number' (specifies the module to be used with when the logic analyzer is split)
Enabled | 'F' (false) or 'T' (true)
SamplePeriod | 'real_number'
TriggerPosition | '0-100'

Parents

This element can have the following parents: <SamplingSetup>.

Example

<TimingZoom Enabled='T' AlignWithSubModuleNumber='0'
      TriggerPosition='50' SamplePeriod='250 ps'/>


<TimingZoomTable> Element

The <TimingZoomTable> element describes the part of the binary data file that contains TimingZoom data.

Attributes

Name | Description
FileName | 'relative_path_file_name'
OffsetTime | 'number time_unit'
RowCount | 'number'
TimePrecision | 'number time_unit'
TriggerIndex | 'number'

Children

This element can have the following children: <SampleNumberDataSource>, <LogicBitsBlockDataSource>, <TimeDataSource>.

Parents

This element can have the following parents: <Data>.

Example

<TimingZoomTable RowCount='65519' TriggerIndex='32510' OffsetTime='0 s'
      TimePrecision='10 ps' FileName='las33_data02of04.mfb'>
   <SampleNumberDataSource Type='Periodic'>
      <SetupInfo RowCount='65519' TriggerIndex='32510'
            SamplePeriod='1'/>
   </SampleNumberDataSource>
   <LogicBitsBlockDataSource Type='Page'>
      <SetupInfo RowCount='65519' BitsPerSample='68' PageSize='43690'
            FileOffset='1638400'/>
   </LogicBitsBlockDataSource>
   <TimeDataSource Type='Periodic'>
      <SetupInfo RowCount='65519' TriggerIndex='32510'
            SamplePeriod='250 ps'/>
   </TimeDataSource>
</TimingZoomTable>


<Tool> Element (under Configuration Setup)

The <Tool> element contains setup information for a tool.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children:

  • <Filter> (for Filter/Colorize Tool)

  • For information about child elements for other add-on tools, see the "Tool Setup, XML Format" topic in the tool's online help.

Parents

This element can have the following parents: <Setup>.

Example

<Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'>
   <Filter Enabled='T'>
      <FilterExpression Name='Idle/Wait States' Enabled='T'>
         <Event>
            <BusSignal Name='Cycle Type-1' SymbolName='idle'
               Value='bXXXX XXXX XXXX XXXX XXXX XXXX X1XX XXX1'
               Operator='Equals' Base='Symbol'/>
         </Event>
         <FilterAction Type='Hide'/>
      </FilterExpression>
      <FilterExpression Name='Extension Words' Enabled='T'>
         <Event>
            <BusSignal Name='Cycle Type-1' SymbolName='extension'
               Value='bXXXX XXXX XXXX XXXX XXXX XXXX XX1X XXX1'
               Operator='Equals' Base='Symbol'/>
         </Event>
         <FilterAction Type='Hide'/>
      </FilterExpression>
      <FilterExpression Name='Overfetch States' Enabled='T'>
         <Event>
            <Or>
               <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
                  Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
                  Operator='Equals' Base='Symbol'/>
               <BusSignal Name='Cycle Type-1' SymbolName='overfetch'
                  Value='bXXXX XXXX XXXX XXXX XX1X XXXX XXX1 XXX1'
                  Operator='Equals' Base='Symbol'/>
            </Or>
         </Event>
         <FilterAction Type='Hide'/>
      </FilterExpression>
   </Filter>
</Tool>


<Tool> Element (under Module)

The <Tool> element describes the name of a tool in the Overview window hierarchy.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <Tool>, <Window>.

Parents

This element can have the following parents: <Module>.

Example

<Tool Name='Motorola PowerQUICC (MPC8XX) Inverse Assembler - 1'>
   <Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'>
      <Window Name='Listing - 1'/>
      <Window Name='Waveform - 1'/>
   </Tool>
</Tool>


<Tool> Element (under Overview Setup)

The <Tool> element describes the name and type of a tool in the Overview window list.

Attributes

Name | Description
Enabled | 'F' (false) or 'T' (true) (optional, corresponds to enabled status in Overview window)
Name | 'string'
Type | 'Filter/Colorize', 'ARM Inverse Assembler', 'IBM PPC405 Inverse Assembler', 'Motorola 6833x7x Inverse Assembler', 'Motorola MPC8260 Inverse Assembler', 'Motorola PowerQUICC (MPC8XX) Inverse Assembler', or 'Motorola PPC6xx-7xx Inverse Assembler'.

Parents

This element can have the following parents: <Setup>.

Example

<Tool Name='Filter/Colorize - Motorola PowerQUICC (MPC8XX)'
      Type='Filter/Colorize'/>


<TriggerAction> Element

The <TriggerAction> element specifies a trigger action to take in the trigger sequence.

Attributes

Name | Description
Operator | 'Fill Memory', 'Goto', or 'Email and Fill Memory'

Children

This element can have the following children: <Email> (if Operator='Email and Fill Memory'), <Goto> (if Operator='Goto'), <StoreQual>.

Parents

This element can have the following parents: <Action>.

Example

<TriggerAction Operator='Fill Memory'>
   <StoreQual>
      <Event>
         <Anything/>
      </Event>
   </StoreQual>
</TriggerAction>

<TriggerAction Operator='Goto'>
   <Goto Step='2'/>
</TriggerAction>

<TriggerAction Operator='Email and Fill Memory'>
   <StoreQual Mode='Custom'>
      <Event>
         <DefaultStore/>
      </Event>
   </StoreQual>
   <Email To='first_last@company.com' Subject='Logic analyzer triggered'
         Body='Here's the message body.'/>
</TriggerAction>


<TriggerFavorites> Element

The <TriggerFavorites> element contains zero or more favorite triggers.

Children

This element can have the following children: <Favorite>.

Parents

This element can have the following parents: <Module>.

Example

<TriggerFavorites>
   <Favorite Name='First Trigger'>
      <Trigger Mode='State'>
         ...
      </Trigger>
   </Favorite>
   <Favorite Name='Second Trigger'>
      <Trigger Mode='State'>
         ...
      </Trigger>
   </Favorite>
</TriggerFavorites>


<Trigger> Element

The <Trigger> element contains a logic analyzer trigger specification.

Attributes

Name | Description
Mode | 'State', 'Turbo', or 'Timing'

Children

This element can have the following children: <StoreQual>, <Step>, <PatternNTimes>, <PatternReset>.

Parents

When used in an XML file, this element can have the following parents: <Favorite>, <File>, <Module>.

When used in COM automation, this element is used by the Trigger property.

Example

<Trigger Mode='State'>
   <StoreQual>
      <Event>
         <Anything/>
      </Event>
   </StoreQual>
   <Step Number='1'>
      <If>
         <Event>
            <BusSignal Name='ADDR' SymbolName='update_system'
                  Value='hFFF034D8' Operator='Equals' Base='Symbol'/>
         </Event>
         <Occurrence Value='1'/>
         <Action>
            <TriggerAction Operator='Fill Memory'>
               <StoreQual>
                  <Event>
                     <Anything/>
                  </Event>
               </StoreQual>
            </TriggerAction>
         </Action>
      </If>
   </Step>
</Trigger>


<VbaProject> Element (for VbaView Windows)

The <VbaProject> element specifies where VbaView window project code is saved.

Attributes

Name | Description
FileName | 'string' (full path)

Parents

This element can have the following parents: <Setup>.

Example

<Window Name='Bus vs Bus Sample-2'>
   <Setup>
      <Save>
         <Properties XAxisBusSignal='Sample Number'
               YAxisBusSignal='My Bus 1' StartSample='-1000'
               EndSample='1000' XAxis2sComplement='0'
               YAxis2sComplement='0' ColorGradient='0'/>
      </Save>
      <VbaProject FileName='C:\Documents and Settings\user\My
            Documents\Agilent Technologies\Logic Analyzer\Config
            Files\vbaview_setupVba01.zip'/>
   </Setup>
</Window>


<VbaProject> Element (for VBA Macros)

The <VbaProject> element specifies where VBA macro project code is saved.

Attributes

Name | Description
FileName | 'string' (full path)
Name | 'MyConfigMacros'

Parents

This element can have the following parents: <VbaProjects>.

Example

<VbaProjects>
   <VbaProject FileName='C:\Documents and Settings\user\My
         Documents\Agilent Technologies\Logic Analyzer\Config
         Files\vbaview_test_setup2Vba01.zip' Name='MyConfigMacros'/>
</VbaProjects>


<VbaProjects> Element

The <VbaProjects> element contains VBA macro project file information.

Children

This element can have the following children: <VbaProject>.

Parents

This element can have the following parents: <Configuration>.

Example

<VbaProjects>
   <VbaProject FileName='C:\Documents and Settings\user\My
         Documents\Agilent Technologies\Logic Analyzer\Config
         Files\vbaview_test_setup2Vba01.zip' Name='MyConfigMacros'/>
</VbaProjects>


<Window> Element (under Configuration Setup)

The <Window> element contains setup information for the display windows. Currently, the window name is the only setup information.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <BusSignals> (for Listing, Compare, and Source windows), <Setup> (for Waveform window), <Options> (for Compare window), <SourceDirectories> (for Source window), <Setup> (for VbaView windows).

Parents

This element can have the following parents: <Setup>.

Example

<Window Name='Compare - 1'/>
<Window Name='Listing - 1'/>
<Window Name='Waveform - 1'/>


<Window> Element (under Module)

The <Window> element describes a window name in the Overview window hierarchy.

Attributes

Name | Description
Name | 'string'

Parents

This element can have the following parents: <Module>, <Tool>.

Example

<Window Name='Compare - 1'/>


<Window> Element (under Overview Setup)

The <Window> element describes the name and type of a window in the Overview window list.

Attributes

Name | Description
Name | 'string'
Type | 'Compare', 'Listing', or 'Waveform'

Parents

This element can have the following parents: <Setup>.

Example

<Window Name='Listing - 1' Type='Listing'/>


XML Element Values

frequency_unit

  • GHz — gigahertz

  • MHz — megahertz

  • kHz — kilohertz

  • Hz — hertz

time_unit

  • ps — picoseconds

  • ns — nanoseconds

  • us — microseconds

  • ms — milliseconds

  • s — seconds

  • Gs — gigaseconds

value

A number with one of the following prefixes:

  • h — hex

  • b — binary

  • o — octal

  • d — decimal

For example: hFFF034D8

voltage_unit

  • mV — millivolts

  • V — volts


Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies' standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.


Safety Notices

[Caution]

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

[Warning]

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.


Technology License

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.


Trademarks

Microsoft®, MS-DOS®, Windows®, Windows 2000®, and Windows XP® are U.S. registered trademarks of Microsoft Corporation.

Adobe®, Acrobat®, and the Acrobat Logo® are trademarks of Adobe Systems Incorporated.


Warranty

The material contained in this document is provided "as is," and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.