Connecting Probes

Online Help

Version 04.00.0000

Copyright © 2001-2010 Agilent Technologies, Inc.

Warranty
Technology License
Restricted Rights Legend
Safety Notices
Trademarks

August 26, 2010

Table of Contents

Connecting Probes Using the Probe Summary
To connect a general-purpose probe
To connect an analysis probe
To add probe information to a configuration file
To find where a probe connects
To calculate pod indexes
Pod Indexes Example
To verify probe definitions
To add probe information to a configuration file using XML
To add a probes section
To define probes in XML


Connecting Probes Using the Probe Summary

Use the Probe Summary to figure out how to connect logic analyzer probes to your target system. It is essential to connect the logic analyzer pods to the right probes, then to the right connectors on your target system. The XML configuration files for some inverse assemblers contain information to help you make the right connections.

To use the probe summary information, you must load a configuration file which contains the appropriate information (such information may not be included with every inverse assembler). In addition, you must use the signal-to-connector mapping recommended by Agilent.

There are two ways to view information from the configuration file about where to plug the logic analyzer pods, depending on the kind of probe you are using:

  • To connect a general-purpose probe takes you straight to the connection information, using the Properties button of the General Purpose Probe tool.

  • To connect an analysis probe takes you to the System Summary dialog, which provides less detail, but which is available regardless of which probe tool is used.

See Also

  • To calculate pod indexes

  • To add probe information to a configuration file


To connect a general-purpose probe

To view information from the configuration file about where to plug the logic analyzer pods into your target system:

  1. Load the XML configuration file.

  2. Select Setup>General Purpose Probe Set>Properties.

  3. Select the the type of probe you are using.

  4. Click Edit Probe....

  5. Connect the pods as shown.

    Note that the screen shown above is a generic example--the connections for your analysis probe will be different.

To connect the probes to the target system

The probes include labels to identify them. The labels can be attached to the cables after the cables have been connected to the target system and logic analyzer. Some probes are also known as "high-density termination cables".

See Also

  • To connect an analysis probe

  • To calculate pod indexes

  • To add probe information to a configuration file

  • Using General Purpose Probes


To connect an analysis probe

To view information from the configuration file about where to plug the logic analyzer pods into an analysis probe:

  1. Load the XML configuration file.

  2. Open the bus/signal setup window for the logic analyzer module you will be using.

  3. Select the System Summary... button.

  4. Select the Probe Summary tab.

    Note that the screen shown above is a generic example--the connections for your analysis probe will be different.

  5. Connect the pods as shown.

To connect the probes to the target system

The probes include labels to identify them. The labels can be attached to the cables after the cables have been connected to the target system and logic analyzer, as shown in the following illustration. Some probes are also known as "high-density termination cables".

See Also

  • To connect a general-purpose probe

  • To calculate pod indexes

  • To add probe information to a configuration file


To add probe information to a configuration file

If your configuration file does not contain probe summary information for your particular setup, it is possible to add this information to the configuration file. Doing this is especially useful if you will be sharing the configuration file with other users who will need to make connections to the same target system you are probing.

It is easiest to use the logic analyzer software to define probes for an inverse assembler, unless the pods will be connected directly to an analysis probe without using a probe cable.

  1. Load an XML configuration file. This configuration file needs to map each required bus or signal to a logic analyzer pod.

  2. Decide what kind of probe you will use to connect the pod to the connector on the target system (or analysis probe).

  3. For each pod defined in the configuration:

    1. Find the pod index of the pod.

    2. Find the same information for any other pods which connect to the same probe.

    3. Find where the probe connects to the target system.

    4. Define the probe.

  4. Save the configuration file.

  5. Verify the changes you made.

See Also

  • To add probe information to a configuration file using XML


To find where a probe connects

There are several ways to find out where a particular probe should be connected, so that you can add this information to the Probe Summary tab:

  • If you have successfully connected the logic analyzer to your target system, look at where the cables are actually connected.

  • If your target system uses the connector definitions recommended by Agilent, look at the data sheet, User's Guide or Design Guide for your inverse assembler. In most cases, these documents can be found at www.agilent.com.

  • Choose any bus or signal which is mapped to the pod in the Buses/Signals setup window, or in the XML configuration file. Next, look at the design of your board to find out which connector carries that signal.


To calculate pod indexes

Configuration files for inverse assemblers use pod indexes to map signals and buses to the pods of the logic analyzer cards.

To calculate the index of a pod when a configuration is loaded

  1. Open the the Buses/Signals setup window.

  2. Scroll to the pod on the far right, and count pods toward the left.

To calculate the index of a pod by looking at cards

  1. Find the master card. If there is only one card, that is the master card. If there are several cards connected together as a module, you can look at the Slot Summary tab.

  2. On the master card, the pods are numbered beginning with 1.

  3. Continue counting with the bottom card in the module, then continue counting upwards.

See the Example.

To look up the index of a pod in an XML file

If you have an XML file which maps buses and signals to logic analyzer pods, you can find find the index of the pod which carries any particular bus or signal.

  1. Open the XML file in a text editor.

  2. Find the <BusSignal> line for the bus or signal.

  3. Look at the corresponding <Channels> line to see the pod index.

Why pod indexes are needed

Normally, pods are referred to using their physical names, such as "Slot A Pod 4." This can make it difficult to refer to a particular pod, when nothing is known about the actual setup of the logic analyzer. Logic analyzer cards can be installed in different slots. Different model cards can also have different numbers of pods per card. Pod indexes provide a way to refer to the pods on a card (or in a multi-card module) without worrying about these factors.


Pod Indexes Example

Here is an example of a 3-card module, along with the pod indexes for each pod. The picture of the cards in your system can be found on the Slot Summary tab.


To verify probe definitions

  1. Open the XML file in a web browser. If there are any errors in the XML syntax, these will be displayed in the browser.

  2. Open the XML file using the logic analyzer software.

  3. Verify that the information in the Probe Summary tab of the System Summary dialog is correct. Verify that all of the connections shown in this tab match the actual physical connections.


To add probe information to a configuration file using XML

  1. Begin with an XML configuration file which maps each required bus or signal to a logic analyzer pod.

  2. Add a <Probes> section to the XML file.

  3. Decide what kind of probe you will use to connect the pod to the connector on the target system (or analysis probe).

  4. For each pod defined in the configuration:

    1. Find the pod index of the pod.

    2. Find the same information for any other pods which connect to the same probe.

    3. Find where the probe connects to the target system.

    4. Define the probe.

  5. Save the configuration file.

  6. Verify the changes you made.


To add a probes section

Where to place the Probes section

Place the Probes section in the <BusSignalSetup> section of <Module>. Make sure that you do not confuse the <BusSignalSetup> section with <BusSignals>, which is a section within <BusSignalSetup>.

- <Configuration>
    <Clear />
  - <Setup>
    + <Overview>
    - <Module Name='Module 1'>
      + <PodAssignment>
      + <SamplingSetup>
      - <BusSignalSetup>
        + <PodSettings>
        + <BusSignals>
        + <Probes>
        </BusSignalSetup>

Clear

The Probes section begins with a "<Clear/>" in order to be sure that any existing definition of probes is cleared out. Then each probe is defined in its own <Probe> section. The parameters for <Probe> are "Name", "Type", and "NumberOfPods".

Name

The "Name" is the name of the Probe or pad and it is used to distinguish between other probes that may be the same type as this one. (For example, it will be quite common for users to have several Soft Touch probes on their board at one time.) This is the name of the Probe or pad on the user’s board. (Make sure that this name and the name defined in the documentation is the same). If this is an analysis probe, there may not be an obvious name for the Probe. Do not just use the part number for the probe because this is the "Type". If there isn’t an obvious Probe name, just use the name of the processor or bus that is being probed.

Type

The "Type" is the part number of the probe and should include a short text description, such as "E5394A – Soft touch single-ended probe". The "Type" does not need to be unique. Indeed, if more than one probe of the same type is used it is important that they all use exactly the same name. For general-purpose probes, use the strings from the following list.

E5339A - MICTOR Adapter
E5351A - MICTOR Adapter
E5346A - MICTOR Adapter
E5378A - 100 pin single-ended Samtec probe
E5379A - 100 pin differential Samtec probe
E5380A - 38 pin single-ended Samtec probe
E5385A - 100 pin single-ended Samtec probe
E5378A connected to two E5386A adapters
E5379A connected to one E5386A adapter
E5390A connected to two E5386A adapters
E5387A connected to one E5386A adapter
E5387A - Soft touch differential probe
E5390A - Soft touch single-ended probe
E5394A - Soft touch single-ended probe

NumberOfPods

The "NumberOfPods" refers to the number of pods that plug into this probe, which could be one or more. For example, some analysis probes may require as many as six or more pods but a general-purpose probe might only require one pod.

Example

If you use the logic analyzer software to create the XML, you may see an additional "NumberOfPins" parameter. It is fine to leave this in.

- <Probes>
    <Clear />
  + <Probe Name='J2' Type='E5394A - Soft touch single-ended probe'
      NumberOfPods='2'>
  + <Probe Name='J1' Type='E5394A - Soft touch single-ended probe'
      NumberOfPods='2'>
  </Probes>


To define probes in XML

Each probe needs to have one or more pods defined for it. These are defined within the <Probes> section. Each Pod is defined with an Index and a Prompt.

Index

The Index is the Pod Index which was discussed earlier.

Prompt

The Prompt is whatever is silkscreened on the probe to differentiate between the pods.

For example, on general-purpose probes with two pods, there is an "Even" and an "Odd". (The "Even" pod is generally A2, A4, A6, etc. and the "Odd" pod is "A1", "A3", "A5", etc.). For analysis probes, sometimes there are "P1", "P2", etc. The point is that the user will need to match up a pod with something physical on the probe. Remember that if a user makes a single mistake in connecting the probes, the measurements will not be accurate. It’s important to give the user as much help as you can in getting the probes connected properly.

Example

- <Probe Name='J1' Type='E5394A - Soft touch single-
    ended probe' NumberOfPods='2'>
    <Pod Index='1' Prompt='Odd' />
    <Pod Index='2' Prompt='Even' />
  </Probe>


Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies' standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.


Safety Notices

[Caution]

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

[Warning]

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.


Technology License

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.


Trademarks

Microsoft®, MS-DOS®, Windows®, Windows 2000®, and Windows XP® are U.S. registered trademarks of Microsoft Corporation.

Adobe®, Acrobat®, and the Acrobat Logo® are trademarks of Adobe Systems Incorporated.


Warranty

The material contained in this document is provided "as is," and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.