通告

Agilent Logic Analyzer 帮助
版本 A.03.30
2005 年 12 月

版权 | © Agilent Technologies, Inc. 2001-2005
担保 | 本文档所包含的资料按“原样”提供，在后续版本中如有更改恕不另行通知。此外，在适用法律所允许的最大程度上，Agilent 声明不提供与本手册及其所包含信息相关的任何明示或隐含担保（包括但不限于商品适销性和特殊用途适用性之隐含担保）。对于与本文档或其中任何信息的提供、使用或执行相关的偶发性或继发性损坏，Agilent 将不承担责任。如果 Agilent 和用户另有书面协议，并且其中的某些担保条款与本文档冲突，则以书面协议中的担保条款为准。
商标 | Microsoft®、MS-DOS®、Windows®、Windows 2000® 和 Windows XP® 是 Microsoft Corporation 的美国注册商标。 Adobe®、Acrobat® 和 Acrobat Logo® 是 Adobe Systems Incorporated 的商标。 ARM® 和 Thumb® 是 ARM Limited 的注册商标，ARM7TDMI(TM) 是它的一个商标。 Intel® 和 Pentium® 是 Intel Corporation 在美国的注册商标。 Java(TM) 是 Sun Microsystems, Inc 在美国的商标。


Agilent Logic Analyzer 帮助

Agilent Logic Analyzer 应用程序用于 16900 系列逻辑分析系统和 1680/1690 系列逻辑分析仪。此外，也可以在 Windows XP/2000 计算机上单独使用该应用程序，以实现 16900 或 1680/1690 系列逻辑分析仪的网络远程访问，或实现 16900、1680/1690 或 16700 系列逻辑分析仪所采集数据的脱机分析。

  • 新增功能
  • 入门
  • 探测被测设备
  • 设置逻辑分析仪
    • 配置逻辑分析仪模块
    • 设置探头
    • 设置逻辑分析仪阈电压
    • 定义总线和信号
    • 选择采样模式
    • 设置符号
    • 安装经授权的硬件升级
  • 从被测设备中采集数据
    • 设置快速（绘制方框）触发
    • 指定简单触发
    • 指定高级触发
    • 从其他模块/仪器触发和向其他模块/仪器发送触发
    • 存储和重新调用触发
    • 开始/停止测量
    • 保存采集的数据（和逻辑分析仪设置）
    • 通过 VBA 扩展采集能力
  • 分析采集的数据
    • 脱机分析（在载入已保存的数据和设置之后）
    • 分析波形数据
    • 分析列表数据
    • 显示总线/信号值的名称（符号）
    • 标记数据点并在数据点之间进行测量
    • 搜索采集的数据
    • 比较采集的数据与参考数据
    • 查看与采集的数据关联的源代码
    • （使用 Overview（概览）窗口）以不同的方式分析相同的数据
    • 设置模块之间的系统触发与偏移
    • 使用显示窗口
    • 打印采集的数据
    • 通过 VBA 扩展数据可视化/分析
  • 使用工具
  • 外部示波器时间相关性和数据显示
  • 使用码型发生器
  • 管理软件许可证
  • 解决问题
  • 概念
  • 参考
  • 术语表
  • COM 自动控制
  • XML 格式

另请参见

  • 16900-Series Logic Analysis System Installation Guide
  • 1680-Series Logic Analyzers Quick Start/Installation Guide
  • 1690-Series Logic Analyzers Quick Start/Installation Guide

© Agilent Technologies, Inc. 2001-2005


新增功能

在此版本，即 Agilent Logic Analyzer 应用程序 A.03.30 版中：

  • 您可以添加一个无时间相关装置的外部示波器。使用了逻辑分析仪和示波器模型的默认（典型）deskew 值。仍可以使用时间相关装置来获取当前使用仪器的最精确 deskew 值。请参见外部示波器时间相关性和数据显示。

  • 可以导入外部示波器数据，由于提高了导入和波形绘制性能，从而可以更快地查看这些数据。

  • 使用新的许可证管理器界面，您可以更轻松地激活软件许可证、访问浮动许可证服务器并借用浮动许可证。请参见管理软件许可证。

  • 可以将外部数据导入逻辑分析系统并以分析逻辑分析仪模块获取的数据的方式对其进行分析。请参见使用数据导入模块。

  • 可以使用这些新的 VBA (Microsoft Visual Basic for Applications) 宏和 VbaView 窗口：

    • SendToExcel VBA 宏，将采集的数据发送到 Microsoft Excel。

    • SendToPatternGeneratorModule VBA 宏，将采集的数据发送到码型发生器模块。

    • Timing Compare VbaView 窗口，使用指定的容差条件比较定时分析仪数据（加或减一定数量的样本）。

    请参见 Tools（工具）菜单、Windows（窗口）菜单和宏或 VbaView 窗口中的联机帮助。

  • 使用新的 MatLab Connectivity and Analysis 程序包可以更轻松地将 MatLab 和逻辑分析系统结合使用。此许可程序包包含以下 VBA 宏和 VbaView 窗口：

    • SendToMatLab VBA 宏，将逻辑分析仪数据发送到 MatLab。

    • MatLab Analysis VbaView 窗口，将逻辑分析仪数据发送到 MatLab 进行处理并在 XY 散点图中显示结果。

    • FFT VbaView 窗口，执行逻辑分析仪数据的快速傅立叶变换并在折线图中显示结果。

    请参见 VBA 宏和 VbaView 窗口中的联机帮助。

  • 利用更新的远程编程界面 (RPI) 兼容程序包可以使用附加远程处理命令。

另请参见

  • A.03.20 版本的新增功能
  • A.03.00 版本的新增功能
  • A.02.50 版本的新增功能
  • A.02.00 版本的新增功能
  • A.01.40 版本的新增功能
  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.03.20 版本的新增功能

在 Agilent Logic Analyzer 应用程序 A.03.20 版中：

  • 16900 系列逻辑分析系统中支持 16760A 逻辑分析仪卡。请参见 16760 逻辑分析仪说明。

  • 可以从外部示波器中导入数据。受支持的示波器列表中添加了 Agilent 6000 系列示波器。此外，新的 VbaView 窗口允许您在 Agilent Logic Analyzer 应用程序中使用示波器的 web 界面。请参见外部示波器时间相关性和数据显示。

  • 引入了 工具，可用于将串行数据流转换为并行总线数据。

  • 更新了 外接软件，以支持自动设置功能。

  • 经码型发生器编译的矢量保存到了 XML 和 ALA 格式配置文件中。请参见使用码型发生器。

  • Microsoft Visual Basic for Applications (VBA) 宏和 VbaView 窗口保存到了 XML 和 ALA 格式配置文件中。请参见分配 VBA 代码。

  • 您可以同时禁用多个模块并选择是否删除它们与工具和显示窗口之间的连接。断开连接时，与禁用模块相关联的总线/信号仍保留在显示窗口中，但不包含任何数据。请参见禁用和启用模块。

另请参见

  • A.03.00 版本的新增功能
  • A.02.50 版本的新增功能
  • A.02.00 版本的新增功能
  • A.01.40 版本的新增功能
  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.03.00 版本的新增功能

在 Agilent Logic Analyzer 应用程序 A.03.00 版中：

  • 16900 系列逻辑分析系统中支持 16720A 码型发生器卡。请参见使用码型发生器。

  • 增强了自动调整状态模式采样位置的眼定位 功能，从而可以自动确定最佳阈电压设置。请参见了解状态模式采样位置。

  • Microsoft Visual Basic for Applications (VBA) 集成到了 Agilent Logic Analyzer 应用程序中，使您可以轻松地自动化测量和增加自定义控制和数据可视化工具。请参见使用 VBA 扩展采集功能和通过 VBA 扩展数据可视化/分析。

另请参见

  • A.02.50 版本的新增功能
  • A.02.00 版本的新增功能
  • A.01.40 版本的新增功能
  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.02.50 版本的新增功能

在 Agilent Logic Analyzer 应用程序 A.02.50 版中：

  • 1680 和 1690 系列逻辑分析仪中添加了在状态模式中自动调整采样位置的眼定位 功能（此功能以前仅限于 16900 系列逻辑分析系统中的逻辑分析仪）。

  • 引入了 外接软件；您可以使用该软件探测 FPGA 内部信号。

  • 增加了 外接软件；您可以使用该软件设置探头定义，从而：

    • 使被测设备 pin/pad 数字出现在 Buses/Signals setup（总线/信号设置）选项卡中。
    • 说明逻辑分析仪盒连接。
    • 准备导入网表文件以自动定义总线/信号。

  • 引入了 外接软件（对于 N4220A/B PCI Express 分析探头），将新的 Packet Decoder 工具用于解码 PCI Express 总线数据。

  • 在 Overview（概览）窗口中，为探头（一般目的、FPGA 动态、PCI Express 等）添加了一个单独的列，通过它可以访问探头属性。

另请参见

  • A.02.00 版本的新增功能
  • A.01.40 版本的新增功能
  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.02.00 版本的新增功能

在 Agilent Logic Analyzer 应用程序 A.02.00 版中：

  • 您可以控制新的 16900 系列逻辑分析系统并访问与它相关的新功能。同一个 Agilent Logic Analyzer 应用程序可控制 1680 和 1690 系列逻辑分析仪，并可在 Windows XP/2000 计算机上单独用于远程访问 或脱机分析。

  • 添加了分离逻辑分析仪模块的功能。使用不同的时钟分析总线时，此功能很有用。

    使用多个逻辑分析仪模块，添加了在模块之间识别系统触发和指定偏移的功能。

  • 对于 16900 系列逻辑分析系统中的逻辑分析仪，添加了在状态模式下自动调整采样位置的眼定位 功能。

  • 添加了从编译器生成的输出文件载入程序符号的功能。

  • 在新的源显示窗口中添加了显示与采集数据相关联的高级语言源代码和根据源代码位置设置触发的功能。

  • 添加了新的双样本状态采样时钟模式，该模式通常用于采集 DDR 内存总线活动。

  • 重新组织了 Netlist Import（网表导入）对话框，并添加了用于定义探测的独立对话框。

  • 添加了用于显示逻辑分析系统有关信息的新的 System Summary and Status（系统摘要和状态）对话框。

  • 提高了性能：波形绘制变得更快，Agilent Logic Analyzer 应用程序成为了多线程应用程序。

另请参见

  • A.01.40 版本的新增功能
  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.01.40 版本的新增功能

Agilent Logic Analyzer 应用程序 A.01.40 版：

  • 允许您通过使用 Overview（概览）窗口（替换上一个 Tool Overview（工具概述）对话框）显示多个窗口中的同一数据；例如，您可以显示在某一列表窗口中筛选而在其他列表窗口中未筛选的同一数据。

  • 在 Buses/Signals（总线/信号）对话框中，您可以重新排列分配给总线/信号名称的位顺序。在被测设备中的总线未经连续逻辑分析仪通道探测的情况下，此功能很有用。

  • 同样在 Buses/Signals（总线/信号）对话框中，您还可以导入网表文件中的总线/信号名称和分配。

  • 允许您使用 E5850A 时间相关装置在由逻辑分析仪采集的数据和由外部 Infiniium 示波器采集的数据之间建立时间关联。

  • 允许您使用与 Instrument COM Automation Server 通讯的远程程序控制逻辑分析仪，该程序包含在 Agilent Logic Analyzer 应用程序中。

  • 允许您将更多的逻辑分析仪配置信息保存到通用 XML 配置文件中。您可以以 XML 格式保存触发设定，并在不同的逻辑分析仪之间进行传送。此外，您还可以使用部分包含若干 COM Automation 命令的通用 XML 配置文件。

  • 允许您显示区间标记中的统计信息、停止重复测量或发送有关特定统计值的电子邮件。

  • 允许您使用 Compare（比较）窗口的属性和 Difference Properties（差异属性）选项卡指定 Run Until（运行截止时间）选项。（Compare（比较）窗口的 Run Until（运行截止时间）按钮已被删除。）

  • 允许您使用快速选择 总线/信号名称选择功能来快速地从最近使用的名称中进行选择。此功能已添加到了 Filter/Colorize Tool Properties（过滤/着色工具属性）对话框和 Advanced Trigger Setup（高级触发设置）对话框中。

  • 将数据导出到逗号分隔值 (CSV) 文件时，您可以选择从所选总线/信号中导出数据。此外，您还可以选择导出数据的数基。

  • 在 Advanced Trigger Setup（高级触发设置）对话框中，可以对事件进行重新分组。

  • 允许您锁定显示窗口（例如，Waveform（波形）、Listing（列表）或 Compare（比较）窗口）上的滚动，以便滚动某一窗口时所有锁定的窗口也会跟着滚动。您可以使用其他窗口属性设置查找 Lock（锁定）属性。

  • 允许您设置重复测量之间的延迟，以便您可以在决定是否停止测量之前查看采集的数据。

另请参见

  • A.01.20 版本的新增功能
  • A.01.10 版本的新增功能


A.01.20 版本的新增功能

Agilent Logic Analyzer 应用程序 A.01.20 版：

  • 允许您在定时（异步）采样模式中在出现多个假信号/时钟沿时触发。

  • 允许您对采集的数据集进行简单比较。

  • 添加了将用户定义的符号保存到 XML 格式的逻辑分析仪配置文件中或从 XML 格式的逻辑分析仪配置文件中载入用户定义的符号的功能。

    这意味着您可以使用文本处理工具来重新设置软件开发工具中的符号信息的格式、将它们插入 XML 格式配置文件中以及将它们载入到 Agilent Logic Analyzer 应用程序中。

  • 包含了 API 和文档以启用反汇编程序和分析工具开发。

  • 使脱机分析功能扩展到了 16700 系列逻辑分析仪。

另请参见

  • A.01.10 版本的新增功能


A.01.10 版本的新增功能

Agilent Logic Analyzer 应用程序 A.01.10 版本：

  • 添加了联机帮助的日语版本。


入门

  • 指南 － 逻辑分析仪入门
  • 测量示例

技巧提示（适用于熟练用户）

  • Quick Start for 16700-Series Users


指南 － 逻辑分析仪入门

以下指南部分帮助您快速了解有关逻辑分析仪的基础知识。除了逻辑分析的概念以外，还可以通过测量概述部分了解有关逻辑分析仪的一些常用功能。最后，会提供一些省时的任务操作方式，可帮助您提高工作效率，迅速达到熟练用户的水平。

逻辑分析基础知识

  • 何时应使用示波器？
  • 何时应使用逻辑分析仪？
  • 什么是逻辑分析仪？

    定时分析仪：

    • 采样时钟
    • 采样
    • 触发

    状态分析仪：

    • 采样时钟
    • 采样
    • 触发

测量概述

以下概述不要求启动被测设备。不过，为了演示数据处理功能，应在第 5 步和第 6 步之间载入一个包含数据的配置文件，以完成练习。

  • 打开逻辑分析仪
  • 连接被测设备
  • 设置总线/信号名称
  • 设置采集模式
  • 设置简单触发
  • 打开指南配置文件
  • 使用标记
  • 放大数据

省时任务

  • 载入和保存配置文件
  • 保存和重新调用触发设置
  • 快速标记测量
  • 搜索数据
  • 工具栏、工具提示和鼠标快捷方式

另请参见

  • 产品概述


打开逻辑分析仪

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

  1. 插入电源电缆并按前面板 On/Off（开/关）按钮。

  2. 在 Windows 的 Start（开始）栏中，单击 Start（开始）> Programs（程序）> Agilent Logic Analyzer > Agilent Logic Analyzer。

NOTE:

可选方法：如果屏幕上有逻辑分析仪快捷方式图标，请双击该图标。


连接被测设备

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

使用逻辑分析仪的第一个步骤是探测被测设备中的信号。

注意：

在本指南中，不需要任何探头连接。在本指南的稍后部分，会要求您载入包含数据的配置文件，用于模拟被测设备探测结果。

有关探测方法的更多信息，请参见探测被测设备。


设置总线/信号名称

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

默认情况下，分析仪会在界面中设置好一条总线 (My Bus 1)。以下练习将清除显示默认值，并为进行新的测量重新配置总线/信号设置。

删除总线/信号名称

  1. 从菜单栏中依次单击 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在弹出的 Analyzer Setup（分析仪设置）对话框中，右键单击 My Bus 1，然后选择 Delete（删除）。重复执行此操作，以删除所有总线信号名称。删除了最后一个总线/信号之后，My Bus 1 会作为默认名称再次出现。

    提示：

    提示：使用 Delete All（全部删除）按钮可以一次删除所有总线/信号配置。

添加新的总线/信号名称

  1. 在 Analyzer Setup（分析仪设置）对话框中，右键单击 My Bus 1，然后选择 Rename（重命名）。

  2. 在出现的弹出键区中，键入新名 counter。

  3. 选择 OK（确定）。

将信号映射到分析仪中

必须让逻辑分析仪知道测量中要包括哪些从被测设备中探测到的信号以及如何对其进行分组。本练习将把 Pod 1 上的通道 0 - 7 分配给 counter。请注意，当把多个通道分配给 counter 时，它就会成为一条总线。

  1. 检查活动指示符，确认仪器与被测设备的连接正确。在 8 个通道上都应看到跳变箭头。

    注意：

    如果连接了实际的被测设备硬件，则会看到下图所示的活动指示符。如果是在载入演示配置文件（本指南后面讲到），则不会看到活动。

  2. 单击 Pod 1 上通道 0 - 7 下面的各个 channel assignment（通道分配）框。请注意，分配通道时配置信息会被更新，以反映该总线/信号的情况。

  3. 单击 OK（确定）。


设置采集模式

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

分析仪采集模式（定时或状态）的设置是在 Analyzer Setup（分析仪设置）对话框的 Sampling（采样）选项卡下进行的。您还可以设置定时选项（如内存深度或采样周期）或状态时钟计时选项。

  1. 从菜单栏中依次单击 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...，或者单击工具栏中的 [image] 图标。

  2. 选择 Timing - Asynchronous Sampling（定时 - 异步采样）。

  3. 单击 OK（确定）。


设置简单触发

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

对于基于总线上的数据码型或基于单个信号（如上升沿或低逻辑电平）的某一属性这一类型的触发，简单触发是快速配置分析仪触发的一种方式。

  1. 在 Simple Trigger（简单触发）栏中，单击 pattern qualifier（码型限定符） [image] 并将其设置为 =。

  2. 在文本输入域 [image] 中单击鼠标，并输入数据码型 E5。


打开指南配置文件

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

在测量中的这一步，正常情况下将运行逻辑分析仪。但是因为没有连接到被测设备，所以还无法采集真实数据。必须载入包含此数据的配置文件。

载入配置文件

  1. 选择 File（文件）> Open（打开）。

  2. 在文件管理器对话框中，从以下目录选择名为 DemoConfig.ala 的文件：
    C:\Documents and Settings\All Users\Documents\Agilent Technologies\Logic Analyzer\Default Configs\Agilent\Help Demo\

  3. 选择 Open（打开）。

查看数据

观察逻辑分析仪如何在数据码型 E5 上发生触发并将其置于显示屏的中央。红线指示触发点位于数据码型 E5 的起点。


使用标记

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

标记用于创建数据中的参考点。在数据中放置标记后，就可以使用它们快速查看设置标记的时间、样本或数值。

创建标记

  1. 从菜单栏中，单击 Markers（标记）> New（新建）。

  2. 在显示的 New Marker（新建标记）对话框中配置新标记，如果需要的话，还需指定其在数据中的特定位置。如果不指定标记的位置，默认情况下标记将被放置在触发点上。

  3. 选择 OK（确定）。

在数据中放置标记

首次创建新标记时，您可选择在特定时间或以特定的样本号在数据中放置标记。以下练习为您展示了在数据中放置标记的其他方法。

  1. 在显示的窗口中，单击标记 M3（您的新标记），同时按下鼠标按钮，将标记 M3 拖动至触发前的 -100ns，然后释放鼠标按钮。请注意，当您移动标记时，标记位置值会随之进行更改。

  2. 从菜单栏中，单击 Markers（标记）> Place On Screen（放置在屏幕上），然后选择 M1 并单击 OK（确定）。请注意 M1 被放置在屏幕中央红色触发线上的方式。

  3. 将鼠标指针放在数据中所需的任何点上，然后右键单击并选择 Place Marker（放置标记）。在显示的 Place Marker（放置标记）对话框中，选择 M2 标记。请注意，标记被放置在鼠标指向的位置。

转至数据中的标记

在数据中设置了标记后，就可以按照下列步骤快速查找其中的任何标记。

  1. 从菜单栏中，单击 Markers（标记）> GoTo（转到）。

  2. 选择要查找的标记，然后单击 OK（确定）。


放大数据

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

定时分析仪中的数据以波形显示（如同在示波器上）在水平时间轴上。要放大或缩小波形，应更改波形的时间轴刻度（时间/段）。

状态和定时分析仪都可以将多个信号组成一条总线。要查看所有信号，可以将总线展开为单独的信号。

展开总线

单击名为“计数器”的总线左侧的“+”号。“计数器”下的信号集合便展开成名为计数器[0] - 计数器[7] 的单独信号。

更改刻度

单击缩小图标将信号展开到需要的位置。


载入和保存配置文件

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

通常，打开具有类似设置的现有配置文件要比从头开始创建新的配置文件要快。只需打开一个类似的文件，对设置进行适当的更改，然后以新文件名保存该文件。

注意：

重命名现有配置文件会保留最初配置文件中保存的触发设置和 Find（查找）搜索收藏夹。

您已了解了如何打开配置文件。在以下练习中，您将用一个新名保存 democonfig 文件。

  1. 从菜单栏依次单击 File（文件）> Save As（另存为）...。

  2. 在弹出的文件管理器对话框中，键入新名 myconfig，然后单击 Save（保存）。


保存和重新调用触发设置

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

每当设置新触发并进行测量时，触发设置都会保存在逻辑分析仪中。重新调用触发设置比每次都重新配置触发设置要快得多。

注意：

存储触发设置以前必须先运行逻辑分析仪。此外，触发设置也可以作为配置文件的一部分来存储。如果载入新配置文件，则随此新文件一起存储的触发设置将覆盖当前触发设置。

重新调用触发设置

  1. 从菜单栏中依次单击 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Recall Trigger（重新调用触发）...。

  2. 从下部的列表中选择所需的触发设置，然后单击 OK（确定）。

    提示：

    提示：当 most recently used triggers（最近使用的触发）列表变长时，可以将最常用的触发存储到上部的收藏夹列表中。


快速标记测量

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

您可以快速读取标记之间的时间间隔或样本数。

  1. 单击 Markers（标记）> New Time Interval Measurement（新建时间间隔测量）。

  2. 配置 Interval（时间间隔）对话框，以显示从 Beginning of Data（数据开头）到 Trigger（触发）之间的时间，如下图所示。

    要（在重复运行之后）显示时间间隔测量统计信息，请单击 Properties（属性）；然后，在 Interval Properties（时间间隔属性）对话框中，选中 Show statistics（显示统计信息）。

    单击 OK（确定）关闭 Interval Properties（时间间隔属性）对话框，再单击 OK（确定）关闭 Time Interval（时间间隔）对话框。

    重复运行之后，时间间隔测量结果显示在标记测量显示栏中。

  3. 单击 Markers（标记）> New Value At Measurement（新建定点值测量）。

  4. 配置 Value At（定点值）对话框，以显示 M1 处的 My Bus 1 Hex（十六进制） 值，如下图所示；然后单击 OK（确定）。

    定点值测量的结果 [image] 显示在标记测量显示栏中。


搜索数据

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

您可以在总线或信号上搜索数据码型；可以选择搜索的开始和结束时间；还可以将搜索标准保存在收藏夹列表中。

  1. 从菜单栏依次单击 Edit（编辑）> Find（查找）...。

  2. 在 Find（查找）对话框中配置搜索标准，如下图所示，查找 AA。

  3. 选择 Find（查找）。

配置 Find（查找）对话框就如同在构造一个从左到右阅读的句子。

"Find the 1st occurrence searching Forward from Display Center, on a bus named My Bus 1, including All bits, a pattern that Equals AA".


工具栏、工具提示和鼠标快捷方式

[ 指南主页 ] [ 上一主题 ]

在完成整个指南的过程中，菜单栏的作用是用于访问功能。除了可以为您节省时间的其他有用提示外，还有两种用来访问功能的其他方式。

工具栏

菜单栏下面是几组图标，它们表示许多对话框和功能的快捷方式。有关更多信息，请参考主要帮助中的工具栏。

鼠标快捷方式

可以使用多种鼠标快捷方式。可以通过将鼠标指向某屏幕元素（如标记或屏幕区域）然后右键单击鼠标直接访问。在波形和列表数据显示区域中鼠标快捷方式尤其有用。

工具指示

工具提示是在操作过程（如移动标记、使用鼠标设置触发或将鼠标停留在总线/信号名称上）中出现的一些小信息显示。将它们用作注释，或用来监控进程或当前位置。


测量示例

以下测量示例显示了设置并运行测量的典型步骤顺序。在查看这些示例时，您会遇到一些具有多种可能选择的步骤，如探测或触发。在这些步骤中，请选择最适合您的测量的探测或触发示例。

  • 进行定时分析仪测量
  • 进行状态分析仪测量
  • 在多重时钟沿或假信号的某一个上触发
  • 按范围触发

另请参见

  • 指南 － 逻辑分析仪入门
  • 定时模式触发函数
  • 状态模式触发函数


进行定时分析仪测量

以下测量示例展示了进行典型的定时分析仪测量时配置和运行逻辑分析仪所必需的步骤。在完成该示例过程中，请从选择列表中选出与您所需的配置类别最相符的选项。

提示：

提示：如果您刚刚接触逻辑分析，请参阅指南 - 认识逻辑分析仪，快速了解有关逻辑分析的概念与测量。

  1. 将探头连接到被测设备（有关更多信息，请参见探测被测设备）。

  2. 打开逻辑分析仪。

总线和信号设置

  3. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  4. 在 Buses/Signals（总线/信号）选项卡中，将总线/信号名称分配给所探测的被测设备信号。可通过两种方式分配名称，重命名现有名称，或者删除现有名称并创建新名称。

  5. 在 Buses/Signals（总线/信号）选项卡中，在适当的盒下为在被测设备上探测的所有总线/信号定义总线和信号。

采集模式设置

  6. 在 Analyzer Setup（分析仪设置）对话框中，选择 Sampling（采样）选项卡。

  7. 在 Sampling（采样）选项卡中，将采集模式设置为 Timing - Asynchronous Sampling（定时 - 异步采样）。

  8. 设置采样选项。

  9. 设置定时模式采样周期。

触发设置

  10. 在采集特定数据时，所需要的触发取决于测量。但触发一般都是以两种方式进行设置。

    • 从数据显示中设置简单触发。
    • 从 Advanced Trigger（高级触发）对话框中设置定时模式的高级触发函数。

运行测量

  11. 运行测量。

另请参见

  • 指定触发位置
  • 设置采集内存深度


进行状态分析仪测量

以下测量示例展示了进行典型的状态分析仪测量时配置和运行逻辑分析仪所必需的步骤。在完成该示例过程中，请从选择列表中选出与您所需的配置类别最相符的选项。

提示：

提示：如果您刚刚接触逻辑分析，请参阅指南 - 认识逻辑分析仪，快速了解有关逻辑分析的概念与测量。

  1. 将探头连接到被测设备（有关更多信息，请参见探测被测设备）。

注意：

一定要将被测设备的时钟信号连接到盒上的时钟通道。任何未使用的时钟通道都可用作新的数据通道，并且不会馈送到状态时钟设置中。

  2. 打开逻辑分析仪。

总线和信号设置

  3. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  4. 在 Buses/Signals（总线/信号）选项卡中，将总线/信号名称分配给所探测的被测设备信号。可通过两种方式分配名称，重命名现有名称，或者删除现有名称并创建新名称。

  5. 在 Buses/Signals（总线/信号）选项卡中，在适当的盒下为在被测设备上探测的所有总线/信号定义总线和信号。

采集模式设置

  6. 在 Analyzer Setup（分析仪设置）对话框中，单击 Sampling（采样）选项卡。

  7. 在 Sampling（采样）选项卡中，将采集模式设置为 State - Synchronous Sampling（状态 - 同步采样）。

  8. 设置状态时钟模式。

  9. 设置状态采样时钟。

  10. 如果必要，设置高级状态时钟计时。

触发设置

  11. 在采集特定数据时，所需要的触发取决于测量。但触发一般都是以两种方式进行设置。

    • 从数据显示中设置简单触发。
    • 从 Advanced Trigger（高级触发）对话框中设置高级触发函数。

运行测量

  12. 运行测量。

另请参见

  • 指定触发位置
  • 设置采集内存深度


在多重时钟沿或假信号的某一个上触发

  1. 在定时采样模式中，设置“高级触发”。

  2. 选择您要查找多个时钟沿或假信号之一的总线。

  3. 选择总线中的 All bits（所有位）。

  4. 选择 Edge（沿）。

  5. 单击 Edge Spec（沿指定）...。

  6. 在 Set Edge/Glitch（设置沿/假信号）对话框中，指定要查找的时钟沿或假信号；使用 Set All（全部设置）按钮来选择总线中的所有信号。

  7. 单击 OK（确定），关闭 Set Edge/Glitch（设置沿/假信号）对话框。

  8. 单击 OK（确定），关闭 Advanced Trigger（高级触发）对话框。

注意：

屏幕上不显示假信号。您需要使用示波器来进一步排查假信号并确定其发生时间。


按范围触发

注意：

要在出现总线值范围时触发，总线应满足以下条件：

  • 不得包含重新排序的位。
  • 不得包含跨盒对的时钟位。
  • 必须跨 2 个或更少的盒对（最多 64 位宽）。

当设置简单触发时

  1. 在总线的 Simple Trigger（简单触发）字段中，单击 [image] 运算符按钮；然后，选择 In Range 或 Not In Range。

    Waveform（波形）显示窗口 Listing（列表）/Compare（比较）/Source（源代码）显示窗口

    总线范围
    触发

  2. 指定范围值，可以通过在下限范围和上限范围文本条字段中输入值来指定范围值，也可以通过在选择了 Symbol（符号）数基时使用 Select Symbol（选择符号）对话框。

  3. 从菜单栏中，选择 Run/Stop（运行/停止）> Run（运行），或单击运行/停止工具栏中的 [image] 图标。

当设置高级触发时

  1. 单击分析仪设置工具栏中的 [image] ，或从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Advance Trigger（高级触发）...。

  2. 在 Advanced Trigger（高级触发）对话框中，选择总线。

    单击 [image] 可以从最近使用的总线/信号名称中选择。单击总线/信号名称按钮上的其他任何位置可以打开 Select（选择）对话框以选择其他名称。

  3. 选择总线上的 All bits（所有位）。

  4. 选择 In Range 或 Not In Range 运算符。

  5. 选择数基（Binary（二进制）、Hex（十六进制）、Octal（八进制）、Decimal（十进制）、Signed Decimal（带符号十进制）、Ascii 或 Symbol（符号））。

  6. 指定范围值，可以通过在下限范围和上限范围文本条字段中输入值来指定范围值，也可以通过在选择了 Symbol（符号）数基时使用 Select Symbol（选择符号）对话框。

  7. 从菜单栏中，选择 Run/Stop（运行/停止）> Run（运行），或单击运行/停止工具栏中的 [image] 图标。


探测被测设备

在对被测设备进行逻辑分析测量以前，必须将逻辑分析通道（即探头）连接到被测设备。

探测被测设备有以下几种方法：

  • 连接到各个 IC 引脚或测试点。— 这叫做通用探测，是通过飞线探头组来完成的。还可以使用那些帮助进行通用探测的附件。

  • 连接到特定 QFP 组件包的所有引脚。— 这叫做 QFP 组件包探测，是通过可用于多种类型 QFP 组件包的可选弹性材料探头适配器和 1/4 软接触适配器产品完成的。

  • 在被测设备中设计连接器（或用于软接触无连接器探头和保留 (retention) 模块的衬垫及安装孔)。— 这叫做目标连接器探测 或软接触无连接器探测，是通过可用于不同信号和连接器类型的可选探头完成的。

  • 使用特定于处理器或总线的探头。— 这些探头叫做分析探头（以前叫做预处理器），可用于许多处理器和总线。分析探头包括用于设置逻辑分析仪的配置文件，还可能包括用于解码采集的数据的反汇编程序或其他后处理工具。

另请参见

有关通用探测、QFP 组件包探测、目标连接器探测和无连接器探测以及其他探测方法的更多信息，请参见：

  • Probing Selection Quick Reference Card
  • Probing Solutions for Logic Analyzers（ [image] 网上最新版本）
  • Logic Analyzer Probing Solutions

有关分析探头及其他处理器和总线解决方案的更多信息，请参见：

  • Processor and Bus Support for Logic Analyzers（ [image] 网上最新版本）
  • Processor, Bus, and FPGA Support for Logic Analyzers

有关探测 FPGA 内部信号或为所用探头设置定义的更多信息，请参见：

  • 设置探头

有关通过逻辑分析系统控制被测设备中的信号的更多信息，请参见：

  • 控制被测设备中的信号


控制被测设备中的信号

16900 系列逻辑分析系统机架 都有一个目标控制端口，这是一种 8 位、3.3V 规格的端口，用于向被测设备发送信号。目标控制端口的工作方式与码型发生器不同，它更像是控制被测设备中开关的远程控件。

使用目标控制端口输出：

  1. 将目标控制端口电缆连接到逻辑分析系统机架。

    目标控制电缆是键控的，因此只能单向插入。将电缆插入目标控制端口，键朝上，电缆朝下。

    目标控制端口电缆线是使用颜色标记的。位 0 是棕色，位 1 是红色，位 2 是橙色，依此类推一直到位 7（灰色）。黑白线都是地线。引脚 0、2、4 和 6 位于连接器顶上，排列顺序和线相同。

  2. 若要使用集电极开路，不要忘记安装最大为 4V 的上拉电阻。输入目标控制端口的最大反向电流为 12mA，并且包括一个 51ohm 的串联电阻。

示例：重置被测设备

本例也适用于可能需要发送给被测设备的其他类型的信号。本例中的重置线是低电平有效的。

  1. 使用适当的终端将目标控制端口电缆中的一根线接到重置线上。

  2. 在 Agilent Logic Analyzer 应用程序中，选择 Setup（设置）> Target Control Port（目标控制端口）...。

  3. 在 Target Control Port（目标控制端口）对话框中，对于要使用的目标控制端口信号选中 Enabled（启用）。

  4. 单击 1，以输出高电平有效。

  5. 当被测设备需要重置时，单击 Pulse（脉冲）。


设置逻辑分析仪

  • 配置逻辑分析仪模块
  • 设置探头
  • 设置逻辑分析仪阈电压
  • 定义总线和信号
  • 选择采样模式
  • 设置符号
  • 安装经授权的硬件升级


配置逻辑分析仪模块

逻辑分析仪模块 是针对单一时基和触发的通道逻辑集合。模块可以是单个卡 或多个卡，一个单卡或多卡模块可拆分为两个模块。模块可提供以下灵活性：

  • 使用多个卡增加逻辑分析仪的通道数。

  • 通过将单个卡拆分为两个模块探测具有不同时域的总线。

组合卡以增加通道计数的过程是在将卡装入机架 时执行的。在卡之间连接电缆。有关更多信息，请参见 [image] 16900-Series Logic Analysis System Installation Guide。

拆分单个卡（或已在安装过程中组合的多个卡）的操作通过 Setup（设置）菜单或在 Overview（概览）窗口中执行。将逻辑分析仪的通道拆分为两个模块：

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Split Analyzer（拆分分析仪）...。

  2. 在 Split Analyzer Setup（拆分分析仪设置）对话框中，拖动通道分配滑块以指定每个分析仪中的通道数。

    如果需要为某个模块分配特定的盒 或盒对，请选中 Advanced Pod Assignment Mode（高级盒分配模式）。

  3. 单击 OK（确定）。

另请参见

  • 禁用和启用模块
  • 合并已拆分的分析仪
  • 内存深度和通道数权衡


禁用和启用模块

默认情况下，逻辑分析系统中的所有模块都处于启用状态；不过，也可以禁用模块，使之不参与测量。

注意：

禁用拆分后的分析仪中的一个模块将导致其两个模块都被禁用。

禁用模块

  1. 在 Overview（概览）窗口中，从模块的菜单中选择 Disable（禁用）...。

    或者，从主菜单中选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Disable（禁用）...。

  2. 在 Disable（禁用）对话框中：

    1. 选择要禁用的模块。

    2. 若要删除模块与工具和窗口的连接，请选中 Delete All Connections（删除所有连接）。这会导致只与禁用模块连接的工具和窗口也被删除。

      若要保留模块与工具和窗口的连接，请取消选中 Delete All Connections（删除所有连接）。禁用模块的总线和信号在工具和窗口中是隐藏的，但重新启用时它们会重新显现。

    3. 单击 OK（确定）。

当模块处于禁用状态时：

  • 它不再运行或不再向下游工具或窗口发送数据，也没有数据保存到配置文件。
  • 在该模块中定义的总线和信号在窗口和工具中是隐藏的。
  • 不能更改该模块的设置。

在 Overview（概览）窗口中，被禁用的模块带有 [image] 图标：

启用模块

  1. 在 Overview（概览）窗口中，从模块的菜单中选择 Enable（启用）...。

    或者，从主菜单中选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Enable（启用）...。

  2. 在 Enable（启用）对话框中：

    1. 选择要启用的模块。

    2. 单击 OK（确定）。

另请参见

  • 配置逻辑分析仪模块


合并已拆分的分析仪

当逻辑分析仪盒被分离为两个模块时，您可以取消分离并再次将盒重新组合到一个模块中。

您可以根据模块之间的“Split”（分离）一词和他们之间额外的线来识别 Overview（概览）窗口中的分离分析仪。

当查看 Overview（概览）窗口时，显示的按钮模块就是在组合中要删除的模块。

小心：

当组合分析仪时，将在整个系统中删除为模块设置的所有总线/信号定义，包括 Windows、触发、过滤器等等。请确保在删除分离分析仪之前没有使用它。

如果您不确定组合将对您的设置产生怎样的影响，请在组合前保存配置。组合之后您将不能“撤销”。

合并已拆分的分析仪：

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Unsplit Analyzer（组合分析仪）...。

  2. 在出现的 warning（警告）对话框中，单击 Yes（确定）。

另请参见

  • 配置逻辑分析仪模块


设置逻辑分析仪阈电压

指定一个与被测设备所用电压相匹配的阈电压非常重要。指定错误的阈电压会导致错误的数据。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在 Buses/Signals Setup（总线/信号设置）对话框中，单击任一 Threshold（阈值）按钮。Threshold（阈值）按钮位于 Pod（盒）或 Clocks（时钟）标签下。

  3. 在 Threshold Settings（阈值设置）对话框中：

    某些逻辑分析仪允许您单独指定时钟通道的阈电压。这在某些情形中很有帮助，例如，数据通道探测单端信号的同时时钟通道探测差分信号的情形。

    1. 如果要将此设置应用于所有盒，请选中 Apply settings to all pods（将设置应用于所有盒）；否则，设置仅应用于所选盒。

    2. 如果要将此设置应用于所有时钟位，请选中 Apply settings to clock bits（将设置应用于所有时钟位）；否则，设置仅应用于数据通道。

    3. 选择 Probe（探头）类型；这可能会影响可以选择的设置。

    4. 指定阈值电平。选项有：

      • Standard（标准）— 可从预定义的阈值电平（显示在括号内）列表中选择。

      • User Defined（用户定义）— 可输入 -6.00 到 6.00 伏之间的某个值。

      • Differential（差分）。

另请参见

  • 盒和通道的命名约定


定义总线和信号

您必须先通过以下操作定义总线和信号，才能使用逻辑分析仪：

  1. 添加总线/信号名称。
  2. 将逻辑分析仪的通道分配给总线/信号名称。

在分析仪的设置工具栏中单击 [image] ，或从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...，打开 Buses/Signals Setup（总线/信号设置）选项卡。

在 Buses/Signals Setup（总线/信号设置）选项卡中可执行下列任务：

  • 添加新的总线或信号
  • 删除总线或信号
  • 重命名总线或信号
  • 以默认位顺序分配通道
  • 通过选择位顺序来分配通道
  • 将时钟通道用作额外数据通道
  • 通过导入网表文件定义总线和信号
  • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
  • 设置默认数基
  • 设置极性
  • 添加用户注释
  • 添加文件夹
  • 为总线/信号设置别名
  • 对总线/信号名称排序

通过 Display（显示）按钮，可以选择显示的总线/信号设置信息（channels assigned（分配的通道）、width（宽度）、polarity（极性）、default base（默认数基）、comment（注释）、threshold（阈值）、activity（活动）或 channel numbers（通道编号））。

Bus/Signal Name（总线/信号名称）列中的总线和信号图标通常为红色，但如果该总线/信号被反汇编程序锁定，则会变为灰色。

注意：

在 Agilent Logic Analyzer 应用程序的早期版本中，Buses/Signals（总线/信号）设置选项卡带有 Define Probes（定义探头）... 按钮；现在探头的定义方式则有所不同（请参见定义探头）。

另请参见

  • 设置逻辑分析仪阈电压
  • 为什么盒会丢失?


添加新的总线或信号

使用添加总线/信号功能可以在配置中添加新的总线和信号。添加到配置中后，新的总线/信号会自动插入数据显示中，并可在任一总线/信号插入功能中使用。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 选择 Add Bus/Signal（添加总线/信号），添加新的总线或信号。

  3. 新的总线/信号出现，并带有一个系统生成的默认名称。如果需要，可以重命名该总线/信号。

    注意：

    要将新的总线/信号添加到配置中，至少要为其分配一个通道。

另请参见

  • 删除总线或信号
  • 重命名总线或信号
  • 以默认位顺序分配通道
  • 通过选择位顺序来分配通道
  • 定义总线和信号


删除总线或信号

删除总线或信号功能允许逐个移除总线和信号或一次全部移除。删除总线或信号功能是通过“设置”菜单或“设置”工具栏来访问的。

  • 删除单个总线或信号
  • 删除所有总线和信号

删除单个总线或信号

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 选中要删除的总线或信号。

  3. 单击 Delete（删除）
    。

删除所有总线和信号

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 单击 Delete All（全部删除）。

注意：

有些工具会“锁定”总线和信号，因为它们要使用总线或信号生成自己的输出。Delete（删除）和 Delete All（全部删除）操作不会删除这些锁定的总线和信号。锁定的总线或信号的名称左边的图标是灰色的，不是红色的。

另请参见

  • 定义总线和信号


重命名总线或信号

使用重命名总线/信号功能可以更改总线和信号名称。为重命名的总线/信号分配的所有通道、盒和时钟都保持不变。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...，或者单击设置工具栏中的 [image] 图标。

  2. 右键单击总线或信号名称，并选择 Rename（重命名）...

  3. 输入新的总线或信号名称。

  4. 选择 OK（确定）。

另请参见

  • 添加新的总线或信号
  • 删除总线或信号
  • 定义总线和信号


以默认位顺序分配通道

要使逻辑分析仪显示与系统的设计相符，就要将逻辑分析仪的物理通道分配给总线和信号名称。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在 Buses/Signals（总线/信号）选项卡中，选择网格中的方块，将通道分配给总线和信号名称。对于在被测设备中探测的每一个信号，在界面中都应有一个黑勾将该通道映射到某一盒和某一信号名称。

    示例：在下图中，通道 0-7 (pod 1) 映射到 My Bus 1，通道 8-15 (pod 1) 映射到 My Bus 2，通道 8 和 9 (pod 2) 分别映射到 My Signal 1 和 2。

提示：

提示：如果时钟通道未连接时钟信号，则可用作额外的数据通道。在通道分配区中，时钟通道集中在最后一个盒后面。

另请参见

  • 通过导入网表文件定义总线和信号
  • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
  • 盒和通道的命名约定


通过选择位顺序来分配通道

如果尚未使用连续逻辑分析通道探测被测设备，则可以按选定的位序将通道分配给某一总线名称。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在 Buses/Signals（总线/信号）选项卡中，右键单击总线名称，选中 Enable Channel Order Selection（启用通道顺序选择）。

  3. 开始选择网格中的方格，从总线的低位序列到高位序列分配通道。

    选择方格时，将显示位编号。

注意：

若选择的位序不是默认位序，则只能对等于 (=) 或不等于 (!=) 总线上某值的样本来触发。不能对小于 (<)、大于 (>)、小于等于 (<=)、大于等于 (>=) 某值的样本进行触发，也不能对在两个值范围内 (in range) 或范围外 (not in range) 的样本进行触发。

重置默认位顺序

在 Bus/Signal Setup（总线/信号）对话框，已分配通道的默认位顺序为左侧具有较高的位，右侧具有较低的位。

重置默认位顺序：

  • 右键单击总线名称，然后取消选中 Enable Channel Order Selection（启用通道顺序选择）。

另请参见

  • 通过导入网表文件定义总线和信号
  • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
  • 盒和通道的命名约定


将时钟通道用作额外数据通道

当时钟通道没有用于状态模式采样时钟输入时，可将他们用作额外数据通道并像普通数据通道一样指定给总线/信号名称（请参见按照默认位顺序指定通道或通过选择位顺序来分配通道）。

注意：

当时钟通道用于状态模式采样时钟输入时，将他们指定给总线/信号名称是没有意义的。

逻辑分析仪模块中的每个盒都有一个时钟通道。在 Buses/Signals Setup（总线/信号设置）对话框中，所有的时钟通道都被聚集在一个虚拟的 Clocks（时钟）盒中。（每个盒的列下只显示普通数据通道。）

注意：

不存在单独的物理时钟盒。每个盒都有一个单一的时钟通道。

时钟盒可以不断扩大，以使包括的通道数量与系统中盒的数量相等。换句话说，如果盒的数量大于 16，则时钟盒拥有的通道数量也可大于 16。

在 Channels Assigned（指定的通道）字符串中，时钟盒的名称为“Clks”，通道的名称为“C1”、“C2”等等。

另请参见

  • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
  • 盒和通道的命名约定


通过导入网表文件定义总线和信号

通过导入网表文件可以创建总线/信号名称和分配逻辑分析仪探头通道。这些网表文件来自用于设计被测设备的电子设计自动化 (EDA) 工具，其中包含了被测设备内置连接器上信号的有关信息，可供逻辑分析仪探头使用。

  1. 如果尚未定义探头，请选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> New Probe（新探头）> General Purpose Probe Set（通用探头设置），并定义连接器在网表文件中有映射的探头（请参见定义探头）。

  2. 在 Bus/Signal Setup（总线/信号设置）对话框中，单击 Netlist Import（网表导入）...。

  3. 然后输入要从中导入总线/信号分配信息的网表文件，并单击 OK（确定）。

    导入网表文件后，连接器引脚数显示在 Bus/Signal Setup（总线/信号设置）对话框中。

    导入的总线/信号定义放在 Netlist Import（网表导入）文件夹中。

    小心：

    每次导入都会删除并重新创建 Netlist Import（网表导入）文件夹。若要保留 Netlist Import（网表导入）文件夹中的定义，请在下次导入网表以前重命名该文件夹，或者将总线/信号定义移出该文件夹。

网表文件中的示例行：

用电子设计自动化 (EDA) 工具创建的网表文件中的行具有以下格式：

    NET '/Bus1(3)' J1-7

其中：

  • Bus1 = 4 位总线。
  • (3) = 第 3 位。
  • J1-7 = 连接器 J1，引脚 7。

另请参见

  • 以默认位顺序分配通道
  • 通过选择位顺序来分配通道
  • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
  • 盒和通道的命名约定


编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序

通过编辑 Channels Assigned（分配的通道）文本字符串，可以更改总线名称中的位顺序（在默认顺序或选定顺序中指定的顺序）。

  1. 在 Analyzer Setup（分析仪设置）对话框的 Buses/Signals（总线/信号）选项卡中，单击为当前总线名称 Channels Assigned（分配的通道）。

  2. 在 Assign Channels（分配通道）对话框中，输入总线中的位顺序。

    示例 | 说明
    Pod B1[0] | 信号包含插槽 B 的第一个盒中的第一个通道。
    Pod B1[15:0] | 总线包含 Pod B1 中的所有十六个通道（默认顺序）。
    Pod B1[7:0], Pod B2[15:8] | 总线的前七个通道来自插槽 B 的第一个盒，后七个通道来自插槽 B 的第二个盒。
    Pod B1[7:0,15:8] | 16 位总线的大尾小尾转换。
    Pod B1[0,1,2,3] | 总线的位为倒序。
    Clks[C2:C1], Pod B1[0], Pod B2[0] | 包括两个时钟盒通道的四位总线。
    Clks[C2M:C1S], Pod B1M[0], Pod B1S[0] | 逆多路复用四位总线。

    要了解 Pod B2 之类名称的命名约定，请参见盒和通道的命名约定。

    通过单击 Switch Big Endian <=> Little Endian（大小尾切换）或 Reverse Channel Order（反转通道顺序）按钮，可以轻松完成相应操作。

  3. 单击 OK（确定）。

    Bus/Signal Setup（总线/信号设置）对话框中将显示重排序位的通道编号。

注意：

若位序已变，则只能对等于 (=) 或不等于 (!=) 总线上某值的样本来触发。不能对小于 (<)、大于 (>)、小于等于 (<=)、大于等于 (>=) 某值的样本进行触发，也不能对在两个值范围内 (in range) 或范围外 (not in range) 的样本进行触发。

重置默认位顺序

在 Bus/Signal Setup（总线/信号）对话框，已分配通道的默认位顺序为左侧具有较高的位，右侧具有较低的位。

重置默认位顺序：

  1. 单击总线名称旁边的 Channels Assigned（分配的通道）。

  2. 在 Assign Channels（分配通道）对话框中，单击 Default Channel Order（默认通道顺序）。

  3. 单击 OK（确定）。

另请参见

  • 以默认位顺序分配通道
  • 通过选择位顺序来分配通道
  • 盒和通道的命名约定


设置默认数基

创建总线时可以设置总线默认数基。默认基数用于在列表和波形视图中显示总线和信号值。默认基数仅影响新的总线和信号；如果更改现有总线或信号的默认基数，则不会实现任何更改，除非向列表或波形视图添加新的总线或信号副本。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在 Bus/Signal Setup（总线/信号设置）对话框中，选择 Display（显示）。

  3. 选择 Default Base（默认基数）。

  4. 要更改总线或信号的默认基数，请单击默认基数值。

  5. 选择一个新值。

  6. 单击 OK（确定），关闭 Bus/Signal（总线/信号）对话框。


设置极性

您可以定义总线和信号以显示负极性或正极性。这将影响值和波形的显示。总线或信号设置为负极性时，将以低波形和逻辑值 0 显示输入的高压。极性反映在所有使用值的位置中，如触发和符号。

默认极性为正（高 = 1）。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在 Bus/Signal Setup（总线/信号设置）对话框中，选择 Display（显示）。

  3. 选择 Polarity（极性）。

  4. 在显示的极性列中，在 +（正）和 -（负）之间切换。


添加用户注释

可以为总线和信号添加注释。当鼠标悬停在波形和列表窗口中某一总线或信号名称上时，注释会出现在工具提示中。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 在出现的 Buses/Signals setup（总线/信号设置）选项卡中选择 Display（显示）。

  3. 选择 Comment（注释）。一个带有 Comment（注释）标签的新列显示出来。

  4. 在该 Comment（注释）列中，键入总线或信号的注释。

  5. 单击 OK（确定），关闭 Analyzer Setup（分析仪设置）对话框。

注意：

注释是用于描述总线/信号名称细节的描述符，而不是记事本。注释的长度最多为 64 个字符。


添加文件夹

Add Folder（添加文件夹）... 功能用于在总线/信号列表中添加窗口风格的文件夹。当反汇编程序中使用许多总线/信号名称时，使用文件夹可以帮助组织这些名称。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 右键单击某一总线/信号名称，然后选择 Add Folder（添加文件夹）。

  3. 新文件夹直接出现在选中的名称下面。默认情况下，新文件夹会有一个系统生成的默认名称。如果需要，可以像重命名总线/信号名称一样重命名新文件夹。

另请参见

  • 为总线/信号设置别名


为总线/信号设置别名

Add Alias（添加别名）... 功能用于为同一总线或信号添加另一个名称（具有相同的通道、极性等分配）。同时使用别名和文件夹可以帮助组织反汇编中所使用的大量总线和信号名称。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）...。

  2. 右键单击要添加别名的总线/信号名称，然后选择 Add Alias（添加别名）。

  3. 新别名直接出现在选中的名称下面。新别名也是可以重命名的，不过，新名称也会应用于原名。

另请参见

  • 添加文件夹


对总线/信号名称排序

您可以对总线/信号名称和文件夹名称进行排序，以便更好地组织它们。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析模块）> Bus/Signal（总线/信号）...。

  2. 右键单击要排序的某个总线/信号或文件夹名称；然后，选择 Sort（排序）> Ascending（升序）或 Sort（排序）> Descending（降序）。

另请参见

  • 添加文件夹


选择采样模式

通过菜单栏的 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））... 命令访问 Sampling（采样）选项卡。Sampling（采样）设置选项卡用于选择和配置采集模式。

在 Timing - Asynchronous Sampling（定时 - 异步采样）采集模式下，可设置采样选项和采样周期。按固定间隔（采样周期）对被测设备进行采样。

在 State - Synchronous Sampling（状态 - 同步采样）采集模式下，可设置采样选项、设置来自被测设备的通知逻辑分析仪何时进行数据采样的时钟计时信号，并相对于采样时钟调整每个通道的采样位置，以确保在数据有效时对其进行采样。

在状态和定时这两种模式下，均可设置采集（内存）深度，以及触发事件在采集内存中的位置。

某些逻辑分析仪具有时序放大功能，该功能用于收集逻辑分析仪触发点附近更多的高速定时数据。

在 Sampling（采样）设置选项卡中可执行下列任务。

  • 选择定时模式（异步采样）

    • 选择定时采集模式
    • 选择定时采样选项
    • 设置定时模式采样周期

  • 选择状态模式（同步采样）

    • 选择状态采集模式
    • 选择状态采样选项
    • 选择状态采样时钟模式
    • 设置状态采样时钟
    • 自动调整状态采样位置和阈电压
    • 手动调整状态采样位置

  • 定时模式或状态模式

    • 指定触发位置
    • 设置采集内存深度

  • 使用时序放大

    • 打开或关闭时序放大
    • 指定时序放大采样周期
    • 指定时序放大触发位置
    • 在拆分的分析仪中校准时序放大

另请参见

  • 内存深度和通道数权衡


选择定时模式（异步采样）

在定时模式 下，逻辑分析仪是基于内部生成的采样时钟异步进行采样的。

  • 选择定时采集模式
  • 选择定时采样选项
  • 设置定时模式采样周期


选择定时采集模式

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...，或单击设置工具栏中的 [image] 图标。

  2. 在 Sampling setup（采样设置）对话框的 Acquisition（采集）区域，选择 Timing - Asynchronous Sampling（定时 - 异步采样）选项。


选择定时采样选项

在定时（异步）采样模式下，您可以：

  • 通过调整通道宽度来加快采样。也就是说，若要缩短采样周期，可以设置逻辑分析仪使用为最多可用通道数的一半数量的通道。

  • 通过选择只存储跳变或其他有存储限定的码型来发挥采集内存的最大功效以及增长总测量时间。

注意：

更改采样选项将影响采样周期，并可能影响总线分配。

选择定时模式采样选项：

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 Timing（定时）采集模式。Timing Options（定时选项）变为可选。

  3. 选择所需的采样选项。不同型号的逻辑分析仪的通道数可能不同。

    Full Channel Timing Mode（全通道定时模式）

    默认。所有通道都是可用的。

    Half Channel Timing Mode（半通道定时模式）

    使用各盒对中的一个盒。

    Transitional / Store Qualified Timing Mode（跳变/存储限定定时模式）

    提供最长的采集持续时间，因为只有检测到上一个值有变时才存储数据。请参见跳变时序。

另请参见

  • 逻辑分析仪说明，定时模式采样选项/周期


设置定时模式采样周期

在定时模式中，逻辑分析仪在每个采样周期抽取一次被测设备的样本。可以在 Sampling Setup（采样设置）选项卡中设置采样周期。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...，或单击设置工具栏中的 [image] 图标。

  2. 选择 Timing - Asynchronous Sampling（定时 - 异步采样）。

  3. 在 Sampling setup（采样设置）对话框的 Timing Mode（定时模式）区域，增长或缩短采样周期。

    注意：

    要可靠地采集信号电平更改，采样周期应小于要测量的最快信号周期的一半。通过计算所需波形区域中的样本数量来进行时间间隔测量。这些测量会出现 +/-1 个样本的误差，因此最大限度地增加样本数量可以提高测量精度。

另请参见

  • 逻辑分析仪说明，定时模式采样选项/周期


选择状态模式（同步采样）

在状态模式 下，逻辑分析仪是基于被测设备中的采样时钟信号同步进行采样的。通常，用于状态模式采样的信号是状态模式下机器的时钟信号或微处理器时钟信号。

  • 选择状态采集模式
  • 选择状态采样选项
  • 选择状态采样时钟模式
  • 设置状态采样时钟
  • 自动调整状态采样位置和阈电压
  • 手动调整状态采样位置


选择状态采集模式

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...，或单击设置工具栏中的 [image] 图标。

  2. 在 Sampling setup（采样设置）对话框的 Acquisition（采集）区域，选择 State - Synchronous Sampling（状态 - 同步采样）选项。


选择状态采样选项

在状态（同步）采样模式下，采样选项指定了状态模式采样时钟匹配来自被测设备的输入时钟沿时可以达到的速度。可以通过降低触发和时钟计时能力来获得更快的状态模式采样速度。

选择状态模式采样选项：

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 State（状态）采集模式。State Sampling Options（状态采样选项）变为可选。

  3. 选择所需的采样选项。

    一般状态模式

    默认。

    涡轮状态模式

    支持更快的状态模式采样速度，但触发和时钟计时受到限制。

另请参见

  • 逻辑分析仪说明，状态模式采样选项


选择状态采样时钟模式

使用状态采样时钟输出可以通过被测设备中的信号来指定数据采集时间。

状态采样时钟模式 指定在采样时如何使用时钟输入。有四种状态采样时钟模式可供选择：

  • Master Only（仅主时钟） — 所有盒采样都基于一个主时钟。
  • Master/Slave（主/从时钟） — 有些盒采样基于主时钟；有些基于从时钟。
  • Demultiplex（逆多路复用） — 盒对中有一个盒的采样基于主时钟和从时钟。
  • Dual Sample（双采样） — 盒对中有一个盒的采样基于主时钟，但存在着不同的延迟。

有关设置这些状态采样时钟模式的说明，请参见：

  • 设置仅主时钟采样时钟模式
  • 设置主/从采样时钟模式
  • 设置逆多路复用采样时钟模式
  • 设置双样本采样时钟模式

另请参见

  • 设置状态采样时钟
  • 设置高级时钟计时
  • 盒和通道的命名约定


仅主时钟的采样时钟模式

在仅主时钟状态采样时钟模式下，有一个采样时钟信号。当时钟沿出现时，会采集数据并将其存入逻辑分析仪内存中的一个样本。

另请参见

  • 设置仅主时钟采样时钟模式


主/从采样时钟模式

在主/从状态采样时钟模式下，可以将在不同时钟沿采集的数据存入逻辑分析仪内存中的同一样本。

当从时钟出现时，从使用从时钟的盒中采集的数据将保存在从寄存器中。随后，当主时钟出现时，从使用主时钟的盒中采集的数据将与从寄存器中的数据一同保存在逻辑分析仪的内存中。如果在下一个主时钟之前出现了多个从时钟，只有最后采集的从数据会存入逻辑分析仪的内存。

另请参见

  • 设置主/从采样时钟模式


逆多路复用采样时钟模式

在逆多路复用状态采样时钟模式下，可以对由一个盒探测的数据进行逆多路复用，存入通常用于两个盒的逻辑分析仪内存中。逆多路复用模式使用主时钟和从时钟进行数据的逆多路复用。

当从时钟出现时，盒中采集的数据将保存在盒对中另一个盒的从寄存器中。随后，当主时钟出现时，盒中采集的数据将与从寄存器中的数据一同保存在逻辑分析仪的内存中。与主/从模式相同，如果在下一个主时钟之前出现多个从时钟，只有最后采集的从数据会存入逻辑分析仪的内存。

另请参见

  • 设置逆多路复用采样时钟模式


双样本采样时钟模式

在双样本状态采样时钟模式下，可以将使用主时钟在两个不同的采样时间采集的数据保存为分析仪内存中的同一样本。

当主时钟出现时，会使用两个单独的采样位置对盒中的数据进行两次采样。这两个采样位置均可使用 Thresholds and Sample Positions（阈值和采样位置）对话框进行设置。

双样本模式通常用于采集 DDR 内存总线活动（将公共总线时钟用作主时钟）。一个采样位置用于采集写数据，另一个用于采集读数据。

另请参见

  • 设置双样本采样时钟模式


设置仅主时钟采样时钟模式

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 State（状态）。

  3. 在 State（状态）选项中，将 Clock Mode（时钟模式）更改为 Master（主）。

  4. 设置主时钟（请参见设置状态采样时钟）。

另请参见

  • 仅主时钟的采样时钟模式


设置主/从采样时钟模式

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 State（状态）。

  3. 在 State（状态）选项中，将 Clock Mode（时钟模式）更改为 Master/Slave/Demux（主/从/逆多路复用）。

  4. 设置主时钟和从时钟（请参见设置状态采样时钟）。

  5. 选择 Buses/Signals（总线/信号）选项卡。

  6. 对于每个盒，单击盒标题下的时钟按钮并选择 Master Clock（主时钟）或 Slave Clock（从时钟）。

另请参见

  • 主/从采样时钟模式


设置逆多路复用采样时钟模式

注意：

要采集逆多路复用数据，请仅使用盒对中的一个盒。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 State（状态）采集模式。

  3. 在 State（状态）选项中，将 Clock Mode（时钟模式）更改为 Master/Slave/Demux（主/从/逆多路复用）。

  4. 设置主时钟和从时钟（请参见设置状态采样时钟）。

  5. 选择 Buses/Signals（总线/信号）选项卡。

  6. 单击盒标题下的时钟按钮并选择 Demultiplex（逆多路复用）。

    盒对中的盒和另一个盒的显示发生更改。例如，如果将盒 1 设置为逆多路复用，那么盒 2 将消失并且会出现两个盒 1 列。第一个盒 1 列标记为盒 1（主时钟），第二列标记为盒 1（从时钟）。

    请注意，通过指定主总线/信号名称和次总线/信号名称可以调整相对于主时钟和从时钟的采样位置。（请注意，Channels Assigned（分配的通道）列中盒上的“M”和“S”后缀表示“主时钟”和“从时钟”。）有关调整采样位置的更多信息，请参见自动调整状态采样位置和阈电压或手动调整状态采样位置。

另请参见

  • 逆多路复用采样时钟模式


设置双样本采样时钟模式

注意：

要采集双样本数据，请仅使用盒对中的一个盒。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 选择 State（状态）。

  3. 在 State（状态）选项中，将 Clock Mode（时钟模式）更改为 Dual Sample（双样本）。

  4. 设置主时钟（请参见设置状态采样时钟）。

  5. 选择 Buses/Signals（总线/信号）选项卡。

  6. 单击盒标题下的时钟按钮并选择 Dual Sample（双样本）。

    盒对中的盒和另一个盒的显示发生更改。例如，如果将盒 1 设置为双样本，那么盒 2 将消失并且会出现两个盒 1 列。第一个盒 1 列标记为盒 1（主样本），第二列标记为盒 1（次样本）。

    注意：

    请注意，时序放大数据仅对所选盒有效。

  7. 将总线/信号名称分配给主样本和次样本的通道。

    分配给主样本的总线/信号名称可能具有与分配给次样本的总线/信号名称不同的采样位置。

  8. 有区别地调整与主样本和次样本相关的总线/信号的状态采样位置（请参见自动调整状态采样位置和阈电压或手动调整状态采样位置）。

    请注意，Channels Assigned（分配的通道）列中盒上的“M”和“S”后缀表示“主样本”和“次样本”。

另请参见

  • 双样本采样时钟模式


设置状态采样时钟

状态时钟的设置应与被测设备上的时钟信号相匹配。逻辑分析仪可以处理最多由四行组成的时钟信号。时钟可以是一个简单的上升沿，也可以是时钟沿与上限或时钟沿与下限的复杂组合。

上图中，时钟涉及盒 1 到 4 上的时钟信号行。根据型号，逻辑分析仪可能有更多的盒。但是，只有前 4 个盒上的时钟行可用于生成状态时钟信号。其他盒上的时钟行可用作常规数据行。

  1. 将逻辑分析仪盒连接到测试设备。时钟信号必须连接到盒 1 到 4 上的时钟行。

  2. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  3. 选择 State - Synchronous Sampling（状态 - 同步采样）。将激活 State Options（状态选项）区域。

  4. 选择状态时钟模式。大多数测量仅使用主时钟。

  5. 设置时钟说明，以与被测设备上的时钟匹配。

    请放心。此时钟中不使用时钟行。

    上升沿。

    下降沿。

    双沿。

    限定符 - 上限。

    限定符 - 下限。

    时钟说明必须至少具有一个时钟沿。

另请参见

  • 选择状态采样时钟模式
  • 自动调整状态采样位置和阈电压
  • 手动调整状态采样位置
  • 设置高级时钟计时


设置高级时钟计时

如果您要指定比选择正常主时钟或从时钟更复杂的时钟设置（例如，如果您要将特定的时钟通道同时用作同一个时钟描述中的时钟沿和限定符），您需要使用高级时钟计时。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> State/Timing (Sampling)（状态/定时（采样））...。

  2. 选择 State（状态）模式。状态选项变为可选。

  3. 在时钟模式旁边，选择 Advanced Clocking（高级时钟计时）。时钟计时替换为一个按钮。

  4. 根据需要，选择 Master Clock（主时钟）...或 Slave Clock（从时钟）...。

  5. 在 Advanced Clocking Setup（高级时钟计时设置）对话框中，选择适当的设置。

    时钟通道可以同时用作主时钟和时钟限定符。

  6. 单击 OK（确定），关闭对话框。Analyzer Setup（分析仪设置）窗口中的时钟描述也会更新。

注意：

如果您取消选择高级时钟计时，将清除所有的限定符。

另请参见

  • 盒和通道的命名约定


自动调整状态采样位置和阈电压

在使用 eye finder 调整状态模式采样位置时，逻辑分析仪会查看来自被测设备的信号，算出产生最宽数据有效时长的阈电压，然后确定数据有效时长相对于采样时钟的位置，并自动设置阈电压和采样位置。

由于 eye finder 会自动设置各个通道上的采样位置，因此它可以校准由探头电缆和电路板跟踪引起的小偏移效应。这样可以缩小逻辑分析仪的建立/保持时间，并以更高的时钟速度准确采集数据。

Eye finder 要求：

  • 在其运行期间每个信号至少要出现 10 个跳变。（可以使用 eye finder 高级设置来延长或缩短运行时间。）

  • 能够控制各个信号的所有设备都可能成为产生激发信号的信号源。

  • 其工作模式与最终的逻辑分析测量相关的被测设备也都可能成为产生激发信号的信号源。

注意：

Eye finder 测量和正常的逻辑分析仪测量不能同时进行。

运行 eye finder

  1. 通过连接逻辑分析仪通道，用探头探测被测设备。

  2. 将总线/信号名称分配给这些逻辑分析仪通道。

  3. 确保被测设备和逻辑分析仪已经预热到其正常的工作温度。

  4. 选择状态（同步采样）模式（请参见选择状态采集模式）。

  5. 在 Sampling Setup（采样设置）对话框中单击 Thresholds and Sample Positions（阈值和采样位置）...。

  6. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中，选择要运行 eye finder 的总线/信号。

    例如，当某些总线信号以（被测设备的）某一种工作模式跳变，而其他总线信号却以另一种工作模式跳变时，可能就需要在通道子集上运行 eye finder。

  7. 选择所需的 eye finder 运行类型：

    • Auto Sample Position Setup（采样位置自动设置）（在当前指定的阈电压下执行全时扫描，以确定最佳的采样位置）。

    • Auto Threshold and Sample Position Setup（阈值和采样位置自动设置）（调整阈电压，同时观察活动指示符，以找到信号活动包络和最佳的阈电压设置；然后在此阈电压下执行全时扫描，以便自动确定最佳的采样位置）。

    • Eye Scan with Threshold and Sample Position Setup（设置阈值和采样位置进行 Eye Scan）（跨整个信号活动包络范围内执行全时扫描，以便显示示波器式的眼图以及最优的阈电压和采样位置设置）。

    • Eye Scan with Sample Position Setup Only（仅设置采样位置进行 Eye Scan）（跨整个信号活动包络执行全时扫描，以便显示示波器式的眼图以及采样位置设置）。

  8. 单击 Run（运行）。

    针对活动检查完时钟和限定符输入以及相应的阈电压后，eye finder 便开始进行测量。

    当 eye finder 在某一通道上发现两个或更多稳定区域时，它会根据当前采样位置来决定应为哪个稳定区域提供采样位置建议。

    如果 eye finder 选择了错误的稳定区域，您可以展开总线/信号，并将“采样位置”条或虚线（在稳定区域中为蓝色，在跳变区域中为红色）拖到正确的稳定域中。为该区域建议的采样位置将显示出来（请参见选择/建议的位置的行为方式）。

    还可以通过拖动“阈值”条或虚线来调整阈电压设置。请注意，这会影响同一盒上的所有通道（有时还会影响该盒上的时钟输入）。

  9. 如果已经移动了采样位置，并想返回建议的位置，请转至 Thresholds and Sample Positions（阈值和采样位置）对话框，右键单击某一总线/信号，然后选择 Set Sampling Position to Suggested（将采样位置设置为建议位置）命令。

    如果已经移动了阈电压设置，并想返回建议的位置，请转至 Thresholds and Sample Positions（阈值和采样位置）对话框，右键单击某一总线/信号，然后选择 Set Threshold to Suggested（将阈值设置为建议阈值）命令。

    要了解有关 eye finder 测量结果的更多信息，请右键单击某一总线/信号并选择 Properties（属性）...，打开 Eye Finder Properties（Eye Finder 属性）对话框。要了解有关 Thresholds and Sample Positions（阈值和采样位置）对话框中信息消息的更多信息，请参见 Eye Finder 信息消息。

Eye finder 会针对实际的特定条件找到最佳的阈电压和采样位置，这些条件包括振幅、偏移量、转换速率和环境温度。因此，在实际的逻辑分析测量条件下运行 eye finder 可以得到最好的结果。

在进行正常的逻辑分析仪测量时，如果自最后一次 eye finder 测量之后采样时钟设置、时针阈值或采样时钟模式发生了变化，则系统会发出警告。

重复运行 eye finder

  1. 在 Thresholds and Sample Positions（阈值和采样位置）话框中单击 Advanced（高级）...。

  2. 在 Eye Finder Advanced Options（Eye Finder 高级选项）对话框中选择 Run Mode（运行模式） 选项卡。

  3. 检查 Run Repetitively（重复运行）。

  4. 单击 OK（确定）。

  5. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中单击 Run（运行）。

    在 Thresholds and Sample Positions（阈值和采样位置）对话框中，可以看到稳定区域和跳变区域是如何随时间变化的。

  6. 要停止重复运行，请单击 Stop（停止）。

从整个总线角度查看 eye finder 数据

如需 eye finder 数据的高级压缩视图：

  1. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中，右键单击某一总线的采样位置图，然后选择 View Bus As Composite（查看整个总线） 命令。

    平均采样位置以及稳定区域和跳变区域显示的是整个总线的情况。这是默认情况。稳定域显示了总线中每个通道都处于稳定状态的那些位置。

从通道堆栈角度查看 eye finder 数据

如需提高 eye finder 数据视图的分辨率：

  1. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中，右键单击某一总线的采样位置图，然后选择 View Bus As Stack Of Channels（从通道堆栈角度查看总线）命令。

    各个采样位置以及总线中所有通道的稳定区域和跳变区域将显示出来。

清除 eye finder 测量数据

  1. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中，右键单击某一总线/信号名称，然后选择 Clear Measurement（清除测量数据）。

另请参见

  • 了解状态模式采样位置
  • Eye Finder Advanced Options（Eye Finder 高级选项）对话框
  • 手动调整状态采样位置


手动调整状态采样位置

在 Thresholds and Sample Positions（阈值和采样位置）对话框中，可以不运行 eye finder，手动调整状态模式采样位置（前者可自动调整状态采样位置）。

  1. 选择状态（同步采样）模式（请参见选择状态采集模式）。

  2. 在 Sampling Setup（采样设置）对话框中单击 Thresholds and Sample Positions（阈值和采样位置）...。

  3. 在 Thresholds and Sample Positions（阈值和采样位置）对话框中，将蓝色采样位置条拖至适当位置。

    可以展开或折叠总线中的通道。

提示：

提示：要同时调整多个总线和信号的采样位置和/或阈电压，可以在 Buses/Signals Setup（总线/信号设置）对话框中将这些总线和信号分组放在一个文件夹中；然后，可以在 Thresholds and Sample Positions（阈值和采样位置）话框中调整该文件夹的内容和结构。

采样位置会随逻辑分析仪配置一起保存（请参见保存配置文件）。

另请参见

  • 了解状态模式采样位置
  • 自动调整状态采样位置和阈电压


定时模式或状态模式

  • 指定触发位置
  • 设置采集内存深度


指定触发位置

触发位置指定触发后采集的样本占用的跟踪内存量。例如，如果选择了 10% 后存储，则 90% 的跟踪内存将用于存储触发前采集的样本。如果选择了 90% 后存储，则 10% 的跟踪内存将用于存储触发前采集的样本。

在定时模式中，触发前和触发后内存量始终是您根据设置预期的数量，即使您的触发条件出现在填充触发前内存之前。出现此情况的原因是：在定时模式中，触发前内存添满之前不启动触发序列器。

但是，这不适用于状态模式。在状态模式中，序列器会立即启动；换句话说，它不会等待存储前内存的填充。因此，在状态模式中，您的触发位置可能不是预期的位置。例如，如果您将触发位置设置为 50%，但是立即查找触发，触发前内存量会少于预期的数量。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...，或单击设置工具栏中的 [image] 图标。

  2. 选择触发位置。

另请参见

  • 了解逻辑分析仪触发，传送带模拟
  • 设置采集内存深度


设置采集内存深度

通过采集深度控制，您可以设置采集数据占用的内存量。可选择的采集深度由当前使用的分析仪中允许的最大内存深度来确定。

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））...。

  2. 设置采集模式和所有状态或定时选项。它们将影响可用内存选项。

  3. 在右侧的 Options（选项）框中，设置 Acquisition Depth（采集深度）。

另请参见

  • 了解逻辑分析仪触发，传送带模拟
  • 内存深度和通道数权衡
  • 指定触发位置


使用时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。

通过 Sampling（采样）选项卡中的 TimingZoom（时序放大）框即可访问时序放大设置。

  • 打开或关闭时序放大
  • 指定时序放大采样周期
  • 指定时序放大触发位置
  • 在拆分的分析仪中校准时序放大

什么是时序放大？

时序放大可将有关逻辑分析仪触发的附加高速定时数据集中在一个窗口中。

由于时序放大的采样率较快，因此您将看到比标准定时模式具有更高分辨率的转变视图。时序放大数据以行显示，且总线/信号名称后显示“(TZ)”。

由于采样率较快，且样本的内存量相对较小，因此显示时序放大采集的时间的整个窗口较小。采集触发点附近的时序放大数据。

另请参见

  • 逻辑分析仪说明，时序放大


打开或关闭时序放大

如果您对测量的时序放大数据不感兴趣，可以通过关闭时序放大来提高逻辑分析仪的性能。

  1. 在 Sampling（采样）选项卡中，选中或取消选中 TimingZoom（时序放大）框中的 Enable（启用）。


指定时序放大采样周期

如果想以不同的采样分辨率查看触发点附近的数据，可以调整时序放大采样周期。

  1. 在 Sampling（采样）选项卡中，选中 TimingZoom（时序放大）框中的 Enable（启用）。

  2. 单击 TimingZoom（时序放大）框中的 Configure（配置）...。

  3. 在 TimingZoom Setup（时序放大设置）对话框中，选择 Sampling Period（采样周期）。

另请参见

  • 逻辑分析仪说明，时序放大


指定时序放大触发位置

  1. 在 Sampling（采样）选项卡中，选中 TimingZoom（时序放大）框中的 Enable（启用）。

  2. 单击 TimingZoom（时序放大）框中的 Configure（配置）...。

  3. 在 TimingZoom Setup（时序放大设置）对话框中，将 Trigger Position（触发位置）滚动条拖到所需设置。

    触发位置指定触发后采集的样本占用的时序放大内存量。例如，如果选择了“10% 后存储”，则 90% 的时序放大内存将用于存储触发前采集的样本。

另请参见

  • 逻辑分析仪说明，时序放大


在拆分的分析仪中校准时序放大

在一些较老的逻辑分析仪模块上，如果拆分了逻辑分析仪，就需要指定应与哪个分析仪的触发时序放大保持一致。

  1. 在 Sampling（采样）选项卡中，选中 TimingZoom（时序放大）框中的 Enable（启用）。

  2. 单击 TimingZoom（时序放大）框中的 Setup（设置）...。

  3. 在 TimingZoom Setup（时序放大设置）对话框中，选择要作为触发参照标准的逻辑分析仪。


设置符号

在以下情况下可以使用符号名来代替总线/信号数据值：

  • 设置触发。
  • 显示采集的数据。
  • 在显示窗口中搜索总线/信号值。
  • 设置 Filter/Colorize（过滤/着色）工具。

符号名可以是：变量名、过程名、函数名、源文件行号等。

您可以手工输入用户定义的符号名，也可以从程序的对象文件或从通用的 ASCII 格式符号文件载入符号名定义。

  • 创建用户定义的符号
  • 从文件载入符号
  • 运行应用程序外部的符号阅读器
  • 创建 ASCII 符号文件
  • 更改符号阅读器选项

用户定义的多个符号可以同名不同值。符号值查找是基于名和值的。

从文件载入符号时不支持多个符号同名。当符号文件有多个同名符号时，接受第一个符号，其余的被忽略。

当两个或两个以上符号同值时，使用与该值匹配的第一个符号名（即使已经选择了其他某个符号名）。

另请参见

  • 输入总线/信号符号值


创建用户定义的符号

您可以为总线/信号值创建用户定义的符号并对其进行编辑。

添加用户定义的符号

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  2. 在 Symbols（符号）对话框中，选择要显示新符号的总线或信号。

    每个符号都是针对一个特定的总线/信号定义的。

  3. 单击 Add（添加）...。

  4. 在 Add Symbol（添加符号）对话框中，定义一个值或值范围。

    符号名中可以包含任意字符。

    可以为一个总线/信号输入多个完全相同的符号，它们都具有唯一或完全相同的值。当通过窗口或工具查找符号时，使用与码型匹配的第一个符号。这就是 Symbol（符号）对话框中提供 Move Up（上移）和 Move Down（下移）按钮以便对符号进行重新排序的原因。

  5. 单击 Apply（应用）。

要在列表或波形显示中查看这些符号，请单击 Symbols（符号）对话框中的 OK（确定），并将总线/信号的基改为 Symbols（符号）。

注意：

由于 XML 格式的逻辑分析仪配置文件会保存和载入用户定义的符号，因此还可以通过以下方法添加符号：(1) 使用文本处理工具重新格式化来自软件开发工具的符号信息，(2) 将它们插入 XML 格式的配置文件，(3) 将该配置文件载入到 Agilent Logic Analyzer 应用程序中（请参见 XML 格式）。

编辑用户定义的符号

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  2. 选择要编辑的符号。

  3. 单击 Edit（编辑）。

删除用户定义的符号

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  2. 选择要删除的符号。

  3. 单击 Delete（删除）。

保存符号

符号会作为配置文件的一部分保存。不管是否在 Save As（另存为）对话框中选择了 Setup only（仅设置），符号都会保存在配置中。

通过将用户定义的符号保存到一个 XML 格式的配置文件，再经过编辑，然后重新载入该文件，可以在总线/信号之间转移用户定义的符号。

另请参见

  • 显示总线/信号值的名称（符号）


从文件载入符号

符号可以从用编译器/链接器或其他软件开发工具创建的对象文件载入，也可以从通用的 ASCII (GPA) 格式符号文件载入。

  1. 创建符号文件：

    • 使用软件开发工具生成包含符号信息的对象文件（请参见符号阅读器支持的对象文件格式）。

    • 通过运行 Agilent Logic Analyzer 应用程序外部的符号阅读器生成 Agilent 符号阅读器 .sym 文件；从 .sym 文件载入符号比从对象文件载入符号快。

    • 如果所用语言工具不能生成逻辑分析仪所支持的对象文件格式，请创建 ASCII 符号文件。

  2. 从 Agilent Logic Analyzer 应用程序的主菜单栏上选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  3. 在 Symbols（符号）对话框中，选择要载入对象文件符号的总线/信号名称。

    大多数情况下都会选择代表正在分析的处理器的地址总线的总线/信号。

  4. 单击 Load（载入）...。

  5. 在 Select Symbol File（选择符号文件）对话框中，选择要载入的符号所在的文件。

  6. 单击 Open（打开）。

保存配置文件时也会保存符号文件的名称。载入配置时会重新载入符号文件。

从文件重新载入符号

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  2. 在 Symbols（符号）对话框中，选择要重新载入的符号所在的符号文件。

  3. 单击 Load（载入）...。

每当重新载入符号文件时，触发序列中正在使用的符号的值都会自动更新。

删除符号文件

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Symbols（符号）...。

  2. 在 Symbols（符号）对话框中，选择要删除的符号所在的符号文件。

  3. 单击 Delete（删除）。

另请参见

  • 符号阅读器支持的对象文件格式


运行应用程序外部的符号阅读器

可以通过运行 Agilent Logic Analyzer 应用程序外部的符号阅读器来生成 Agilent 符号阅读器 .sym 文件，这种文件的载入比对象文件快。

  1. 打开 Command Prompt（命令提示符）窗口。

  2. 运行以下命令：

    agSymbolBuild.exe [-r <readers.ini>] <object_file> <dest_file>.sym

    例如：

    agSymbolBuild.exe q.elf q.sym

    agSymbolBuild.exe 符号阅读器程序所在路径：

    C:\<安装路径>\SymbolReaders\

    例如：

    C:\Program Files\Agilent Technologies\Logic Analyzer\SymbolReaders\

    要更改符号阅读器选项，请从 SymbolReaders 目录中复制 readers.ini 文件，进行编辑，并在运行 agSymbolBuild.exe 程序时使用 -r <readers.ini> 选项。

    有关符号阅读器程序的更多信息，请参见 SymbolReaders 目录中的 README.txt 文件。

另请参见

  • 从文件载入符号
  • 更改符号阅读器选项


创建 ASCII 符号文件

通用的 ASCII (GPA) 符号文件是通过将对象文件符号转换成 GPA 格式的符号文件和/或通过使用文本编辑/处理工具来创建的。

将对象文件符号转换成 GPA 格式的符号文件

当需要将不同的偏移量应用于不同的符号或代码段时，可以将对象文件符号转换成通用的 ASCII (GPA) 格式符号文件。然后，在将 GPA 格式文件载入到 Agilent Logic Analyzer 应用程序以前，可以使用文本编辑/处理工具来调整该文件中的符号或段偏移值。

  1. 打开 Command Prompt（命令提示符）窗口。

  2. 运行以下命令：

    agSymbolQuery.exe -a <object_file> <dest_file>.sym > GPA_file

    例如：

    agSymbolQuery.exe -a q.elf q.sym > q.gpa

    agSymbolQuery.exe 程序位于一下目录：

    C:\<安装路径>\SymbolReaders\

    例如：

    C:\Program Files\Agilent Technologies\Logic Analyzer\SymbolReaders\

    有关 agSymbolQuery.exe 程序的更多信息，请参见 SymbolReaders 目录中的 README.txt 文件。

另请参见

  • 通用 ASCII (GPA) 符号文件格式


更改符号阅读器选项

通过编辑 readers.ini 文件可以更改 ELF/Stabs、Ticoff 或 Coff/Stabs 符号文件的处理方式。

  1. 制作 readers.ini 文件备份。

    readers.ini 文件所在的目录为：

    C:\<安装路径>\SymbolReaders\

    例如：

    C:\Program Files\Agilent Technologies\Logic Analyzer\SymbolReaders\

  2. 编辑 readers.ini 文件。

    有关符号阅读器选项的更多信息，请参见 readers.ini 文件中的注释。

阅读器选项

SectionReloc

使用下列选项可以指定再定位。用自己的段 (section) 名称替换 <sectionname>。用十六进制再定位量（最大 32 位）替换 <hex_relocation_value>。可将段的再定位量设置为一个绝对值，也可以增加一个相对的再定位量。再定位值将通过使用不分正负的 32 位计算来计算。

[SectionReloc]
  将其放在所有再定位选项前。

AddReloc_AllSections=<hex_relocation_value>
  按指定的量再定位所有段。
  如果此命令之后还有再定位命令，
  则后面的命令将覆盖此操作。

AddReloc_<sectionname>=<hex_relocation_value>
  添加相对再定位值。

SetReloc_<sectionname>=<hex_relocation_value>
  将段再定位到指定的绝对地址。

NonReloc_<sectionname>=TRUE
  阻止段的再定位。
  该命令仅在其前有 AddRloc+AllSections 命令时才有效。

C++Demangle

1= 启动 C++ Demangling（默认）
0= 关闭 C++ Demangling

C++DemOptions

803= 标准 Demangling
203= GNU Demangling      (默认 Elf/Stabs)
403= Lucid Demangling
800= 标准 Demangling（没有函数参数）
200= GNU Demangling（没有函数参数）
400= Lucid Demangling（没有函数参数）

MaxSymbolWidth

80= 函数或变量符号的最大列宽度
    大于此列宽度的符号名称将被截断。
    （默认为 80 列）

OutSectionSymbolValid

0= 如果符号的地址不在所定义的段内，
    则符号无效（默认）
1= 如果符号的地址不在所定义的段内，
    则符号有效

必须在 Readers.ini 文件的 Nsr 段指定此选项：

[Nsr]
OutSectionSymbolValid=1

ReadElfSection

2= 处理所有来自 ELF 段的全局变量（默认）
   获取有关局部变量大小的信息
1= 获取有关全局或局部变量大小的信息
   不会读取函数的符号，
   而只是读取 Dwarf 或 stabs 段
   中的那些符号的补充信息。
0= 不读取 Elf 段

如果文件只有一个 ELF 段，则此选项将无效，并且 ELF 段将被完全读取。如果创建的文件没有（生成调试程序信息）标志（通常为 -g），就可能出现这种情况。除了 ELF 段以外，使用 -g 还会创建一个 Dwarf 或 Stabs 调试段。

StabsType

StabsType=0  阅读器将确定 stabs 类型（默认）
StabsType=1  旧式的 stabs
              （对应链接到目标可执行文件的每个文件，
              旧式的 stabs 包含有各个文件的符号表
              对于每个文件来说，每个符号表
              的索引以 0 重新开始）
StabsType=2  新式 stabs
              （新式 stabs 只有一个符号表，
              在该表中，所有符号合并到了
              一个大的符号数组中）。

ReadOnlyTicoffPage

ReadOnlyTicoffPage 指示 ticoff 阅读器只读取与指定页相关的符号（例如，'ReadOnlyTicoffPage=0' 只阅读第 0 页的符号）。-1 表示 ticoff 阅读器要读取与所有页相关的符号。

ReadOnlyTicoffPage=-1 读取与所有 ticoff 页相关的符号
                      （默认）
ReadOnlyTicoffPage=p  只读取与第 p 页相关的符号
                      （p 为 0 到 n 之间
                      的任一整数，n 表示目标
                      文件的最后一页）。

AppendTicoffPage

AppendTicoffPage 指示 ticoff 阅读器将页码附加到符号值上。它假定符号值的宽度为 16 位，而页码是一个比较小的正数，可以通过 OR 运算放入某一地址的高 16 位，从而创建新的 32 位符号地址。例如，如果该页码为十进制数字 10，符号地址为 0xF100，则新的符号地址将为 0xAF100。

AppendTicoffPage=1  将 ticoff 页附加到符号
                    地址
AppendTicoffPage=0  ticoff 页不附加到符号地址
                    （默认）

示例

Elf/Stabs 示例

[ReadersElf]
C++Demangle=0
C++DemOptions=203
MaxSymbolWidth=60
StabsType=2

Coff/Stabs 示例（使用 Ticoff 阅读器）

[ReadersTicoff]
C++Demangle=0
C++DemOptions=203
MaxSymbolWidth=60
StabsType=2

Ticoff 示例

[ReadersTicoff]
C++Demangle=0
C++DemOptions=203
MaxSymbolWidth=60
ReadOnlyTicoffPage=4
AppendTicoffPage=1


输入总线/信号符号值

在设置触发、搜索显示窗口或设置 Filter/Colorize（过滤/着色）工具的同时输入总线/信号值时：

  1. 为总线/信号值选择所需的运算符。

  2. 选择 Symbol（符号）数基。

  3. 单击值按钮。

  4. 在 Select Symbol（选择符号）对话框中，选择要使用的符号。

    当前总线/信号的所有符号不管是什么类型，在该对话框中都是可用的。

  5. 单击 OK（确定）。

另请参见

  • Select Symbol（选择符号）对话框


安装经授权的硬件升级

某些较新的逻辑分析系统卡（如 16910/11A 和 16950A 逻辑分析仪）的硬件特性（如状态速度和内存深度）可通过购买许可证进行升级。

注意：

在安装经授权的硬件升级时，必须在包含要升级的卡的机架设备上运行 Agilent Hardware Update 程序。也就是说：

  • 在多机架逻辑分析系统中，必须在包含要升级的卡的每一个机架上运行 Agilent Hardware Update 程序。

  • 不能通过远程连接安装模块升级。

安装经授权的硬件升级：

  1. 在订购了硬件升级产品/选件并收到了许可证文件以后，将此许可证文件复制到以下目录：

    C:\Program Files\Agilent Technologies\Logic Analyzer\License\

    如果将 Agilent Logic Analyzer 应用程序装在了其他目录下，请将此许可文件复制到：

    C:\<安装路径>\License\

    如果同时为多个卡订购了升级选件，则所有序列号将通过一个许可证文件来提供。

    许可证文件名中必须包含 .lic 扩展名才能正常使用。

  2. 在 Agilent Logic Analyzer 应用程序中：

    1. 选择 Help（帮助）> Module Upgrade（模块升级）...。
    2. 在 Module Upgrade（模块升级）对话框的 How to Install a Module Upgrade（如何安装模块升级）选项卡中，单击 Do upgrade（执行升级）...。

    或者，从 Windows“开始”菜单处依次单击 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> Hardware Update Utility（硬件更新实用工具）。

  3. 在 Agilent Hardware Update（Agilent 硬件更新）对话框中，选择许可证文件所适用的硬件；然后单击 Upgrade（升级）...，并按照说明继续。

    注意：

    对于 1680/1690 系列逻辑分析仪，Agilent Hardware Update（Agilent 硬件更新）对话框中会显示 "No Hardware Found"（未找到硬件），这是因为它们没有可升级模块。这并不表示硬件有问题。

完成硬件升级后，该硬件会保留其新设置，并且可以安装到任何 16900 系列逻辑分析系统机架上。


从被测设备中采集数据

在探测被测设备并设置逻辑分析仪（通过定义总线和信号并选择采样模式）后，便可以通知逻辑分析仪何时采集数据（即设置触发）并运行测量。

可以设置：

  • 快速触发，方法是在显示窗口中作为触发条件的数据周围拖出一个框；
  • 简单触发，方法是在显示窗口中指定作为触发条件的总线/信号值；
  • 高级触发，方法是打开对话框，并在预定义的触发函数 集合中进行选择。

使用高级触发，可以在被测设备中发生一系列事件后触发逻辑分析仪。

设置触发后，便可以运行测量。测量完成后，可以查看采集的数据并对其进行保存（与逻辑分析仪设置信息一同保存）。

  • 设置快速（绘制方框）触发
    • 在 Waveform（波形）窗口中设置快速触发
    • 在 Listing（列表）窗口中设置快速触发
    • 在 Source（源代码）窗口中设置快速触发
  • 指定简单触发
    • 在简单触发中指定总线码型或沿
    • 在简单触发中指定信号沿或电平
  • 指定高级触发
    • 在触发序列步骤中替换或插入触发函数
    • 指定总线/信号码型或沿
    • 指定触发序列步骤的转至或触发操作
    • 指定默认存储
    • 插入或删除事件
    • 取消事件
    • 更改使用 AND/OR 组合的事件的计算顺序
    • （在触发序列步骤中）插入或删除操作
    • 将触发序列步骤显示为高级 If/Then 触发函数
    • 将触发序列步骤转换为高级 If/Then 触发函数
    • 选择事件的持续时间或发生计数（定时模式）
    • 删除触发序列步骤
    • 清除触发序列
  • 从其他模块/仪器触发和向其他模块/仪器发送触发
  • 存储和重新调用触发
    • 存储触发
    • 重新调用触发
    • 设置触发历史记录深度
  • 运行/停止测量
  • 保存采集的数据（和逻辑分析仪设置）
    • 保存配置文件
    • 将数据导出为 CSV 格式文件
  • 通过 VBA 扩展采集能力

另请参见

  • 探测被测设备
  • 设置逻辑分析仪
  • 定义总线和信号
  • 选择采样模式
  • 分析采集的数据


设置快速（绘制方框）触发

在 Waveform（波形）、Listing（列表）和 Source（源代码）窗口中，用鼠标画矩形或右键单击源代码行即可快速设置简单触发。

定义了简单触发并运行分析仪以后，触发便被保存在最近使用的触发列表中，并且可以随时重新调用。

  • 在 Waveform（波形）窗口中设置快速触发
  • 在 Listing（列表）窗口中设置快速触发
  • 在 Source（源代码）窗口中设置快速触发


在 Waveform（波形）窗口中设置快速触发

在波形窗口中，通过用鼠标绘制矩形可以快速设置一个简单触发。

  1. 确保未选中波形窗口的 Fast Zoom In（快速放大）选项。

  2. 用鼠标指向所需触发矩形的左上角。

  3. 按住鼠标按钮，将鼠标指针拖动至所需矩形的右下角，然后释放鼠标按钮。

    由于触发是使用显示的工具提示读出器设置的，您可以在绘制矩形时监视触发。

    从左到右、从上到下移动鼠标时，与矩形左边相连的信号时钟沿/电平或总线值将变为触发。

    只能设置一个沿。

    要将总线扩展为分离信号，应符合以下三个条件：

    1. 如果是在总线上开始画的矩形，则不包含其任一扩展信号。
    2. 如果是在信号上开始画的矩形，则不能包含总线。
    3. 沿和电平是互斥的。也就是说，或者可以设置一个沿，或者可以设置所有电平，但二者不能同时设置。

    注意：

    在 Waveform（波形）显示窗口中，如果没有获得所需的、由矩形的左侧直线指定的触发点，则需要重新绘制矩形。也可以试着从上次画的矩形的左边线向左画个矩形。

  4. 选择 Set Quick Trigger（设置快速触发）。

一般原则

  • 任何含重叠位的总线/信号都不包含在触发设定内。

    示例：为总线 1 分配盒 1 的通道 0 到 7，为总线 2 分配盒 1 的通道 3 到 6。在这种情况下，您为总线 1 和 2 分配了相同的探测信号（盒 1 的通道 3 到 6）。现在绘制包含总线 1 和 2 的矩形。因为总线 1 的通道 3 到 6 在总线 2 上重复（重叠），所以不会包含在触发设定内。

  • 一个绘制的矩形只能定义一个序列步骤。

  • 绘制矩形时，会出现一个工具提示，它显示将要设置的当前触发设定。


在 Listing（列表）窗口中设置快速触发

在 Listing（列表）窗口中，通过用鼠标绘制矩形可以快速设置一个简单触发。

  1. 用鼠标指向要用作快速触发的样本。

  2. 按住鼠标按钮，水平拖动鼠标指针围绕要包括在触发中的总线/信号绘制一个矩形；然后，释放鼠标按钮。

    绘制矩形时，会出现一个工具提示，它显示将要设置的触发。

    垂直拖动鼠标指针并不影响用于快速触发的样本；所用样本始终是绘制矩形的原始样本。

  3. 选择 Set Quick Trigger（设置快速触发）。

一般原则

  • 任何含重叠位的总线/信号都不包含在触发设定内。

    示例：为总线 1 分配盒 1 的通道 0 到 7，为总线 2 分配盒 1 的通道 3 到 6。在这种情况下，您为总线 1 和 2 分配了相同的探测信号（盒 1 的通道 3 到 6）。现在绘制包含总线 1 和 2 的矩形。因为总线 1 的通道 3 到 6 在总线 2 上重复（重叠），所以不会包含在触发设定内。

  • 一个绘制的矩形只能定义一个序列步骤。

  • 绘制矩形时，会出现一个工具提示，它显示将要设置的当前触发设定。


在 Source（源代码）窗口中设置快速触发

  1. 在源代码窗口的源窗格中，右键单击要在其上设置快速触发的源代码行，然后选择 Set Quick Trigger（设置快速触发）。

另请参见

  • 更改“设置快速触发”对齐方式
  • 开始/停止测量
  • 查看与采集的数据关联的源代码


Specifying Simple Triggers（指定简单触发）

使用简单触发可以从显示窗口中快速设置基于沿和总线/信号码型的触发。

 | Waveform（波形）显示窗口 | Listing（列表）/Compare（比较）/Source（源代码）显示窗口
总线 触发 |  |
信号 触发 |  |

使用关系运算符（=、!=、<、>、<=、>=、In Range、Not In Range）将总线与输入的码型值，或与多个沿或假信号（Edge（沿）在定时模式下可用）中的一个进行比较。

信号则与沿（Rising Edge（上升沿）、Falling Edge（下降沿）、Either Edge（任一沿）、Glitch（假信号）在定时模式下可用）或逻辑电平码型（High（高）、Low（低））进行比较。

可以指定多个总线/信号码型值和一个沿，它们的值都必须为真时才能使样本触发逻辑分析仪。（若指定多个沿，则最后指定的沿优先，先前指定的沿要改为 don't care（无关）。）

当多个总线/信号重叠（即将相同的逻辑分析仪通道分配给多个总线/信号）时，最后的更改具有最高的优先级。例如，如果在“总线 A”上指定了一个码型，然后又在“信号 B”上指定了一个上升沿（它是“总线 A”上的“位 0”），则先指定的码型将被删除。

如果所需的触发条件不只是一个简单的 AND 表达式（例如，总线上的一个码型“或”另一个码型，样本序列中的码型，测试定时器或计数器值，等等），则可以选择 Advance Trigger（高级触发）... 来指定高级触发。当高级触发超越了简单触发的功能限制时，简单触发域将消失；要恢复简单触发域，必须对高级触发进行适当更改，使之不超越简单触发的限制，或者单击 Click here for trigger menu（单击此处查看触发菜单）并选择 Simple Trigger（简单触发）... 来重置触发。

  • 在简单触发中指定总线码型或沿
  • 在简单触发中指定信号沿或电平

另请参见

  • 设置快速触发
  • 指定高级触发
  • 存储触发
  • 重新调用触发


在简单触发中指定总线码型或沿

指定简单触发时，可以指定将要触发的总线码型或时钟沿。

 | Waveform（波形）显示窗口 | Listing（列表）/Compare（比较）/Source（源代码）显示窗口
总线 触发 |  |

指定总线码型

  1. 在总线的 Simple Trigger（简单触发）字段，单击运算符按钮 [image] ；然后，选择以下运算符之一：

    • =（等于）
    • !=（不等于）
    • <（小于）
    • <（大于）
    • <=（小于或等于）
    • >=（大于或等于）
    • In Range
    • Not In Range

    注意：

    如果选择了具有重新排序位的总线，则 <、>、<=、>=、In Range 和 Not In Range 运算符不可用。此外，当所选总线包含跨越盒对的时钟位时，这些运算符也不可用。In Range 和 Not In Range 运算符仅限于跨越 2 个或更少的盒对（最多 64 位宽）的总线。

  2. 在文本项字段 [image] 中，输入总线码型值进行比较。

指定总线的一个时钟沿或假信号

  1. 在总线的 Simple Trigger（简单触发）字段，单击运算符按钮 [image] ；然后，选择 Edge（沿）。

  2. 单击 Edge Spec（沿指定）...。

  3. 在 Set Edge/Glitch（设置沿/假信号）对话框中，指定要查找的时钟沿或假信号；使用 Set All（全部设置）按钮来选择总线中的所有信号。

  4. 单击 OK（确定），关闭 Set Edge/Glitch（设置沿/假信号）对话框。

注意：

屏幕上不显示假信号。您需要使用示波器来进一步排查假信号并确定其发生时间。

另请参见

  • 在简单触发中指定信号沿或电平
  • 在多重时钟沿或假信号的某一个上触发


在简单触发中指定信号沿或电平

指定简单触发时，可以指定将要触发的信号时钟沿或电平。

 | Waveform（波形）显示窗口 | Listing（列表）/Compare（比较）/Source（源代码）显示窗口
信号 触发 |  |

指定信号时钟沿/假信号

注意：

在状态采集模式中，时钟沿选项不可用。

  1. 在信号的 Simple Trigger（简单触发）字段，单击时钟沿/电平按钮 [image] ；然后，选择以下选项之一：

    • Rising Edge（上升沿）
    • Falling Edge（下降沿）
    • Either Edge（任一沿）

    • Glitch（假信号）— 当信号中出现最小检测宽度 假信号时，可触发逻辑分析仪。请参见逻辑分析仪的特性，找出最小检测假信号宽度。

      注意：

      屏幕上不显示假信号。您需要使用示波器来进一步排查假信号并确定其发生时间。

指定信号电平

  1. 在信号的 Simple Trigger（简单触发）字段，单击时钟沿/电平按钮 [image] ；然后，选择以下选项之一：

    • High（高）
    • Low（低）

另请参见

  • 在简单触发中指定总线码型或沿


指定高级触发

当需要设置的触发不仅仅是简单地查找特定总线/信号值时（比如当触发需要基于被测设备中的一系列事件时），就需要设置高级触发。

要打开 Advanced Trigger（高级触发）对话框，请单击分析仪设置工具栏中的 [image] ，或从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Advance Trigger（高级触发）...。

指定高级触发的方法是将预定义的触发函数 拖放到触发序列步骤中。如果所需的触发函数不存在，则可以先找到某一关闭的触发函数，再将触发序列步骤转换为高级 If/Then 触发函数，然后编辑此 If/Then 触发函数。

触发序列中的每个步骤都会在从被测设备采集的数据样本中（或在逻辑分析仪定时器、计数器或标志中）查找事件，并在找到这些事件时采取某种操作（如触发或转至序列中的其他步骤）。您也可以为定时器、计数器或标志插入操作。

使用 Default storage（默认存储），可以不必考虑单个触发序列步骤中哪个步骤的采集样本应存储在逻辑分析仪内存中这一问题。另外，您也可以在单个触发序列步骤中插入 storage control（存储控制）操作，指定是否存储样本，或指定应打开还是关闭默认存储。序列步骤存储控制操作会覆盖默认存储的指定。

  • 在触发序列步骤中替换或插入触发函数
  • 指定总线/信号码型或沿
  • 指定触发序列步骤的转至或触发操作
  • 指定默认存储
  • 插入或删除事件
    • 插入定时器事件（另请参见使用定时器）
    • 插入计数器事件（另请参见使用计数器）
    • 插入标志事件（另请参见使用标志）
    • 插入 Arm in from 事件
  • 取消事件
  • 更改使用 AND/OR 组合的事件的计算顺序
  • （在触发序列步骤中）插入或删除操作
    • 插入定时器操作（另请参见使用定时器）
    • 插入计数器操作（另请参见使用计数器）
    • 插入重置发生计数器操作
    • 插入标志操作（另请参见使用标志）
    • 插入存储控制操作
  • 将触发序列步骤显示为高级 If/Then 触发函数
  • 将触发序列步骤转换为高级 If/Then 触发函数
  • 选择事件的持续时间或发生计数（定时模式）
  • 删除触发序列步骤
  • 清除触发序列

另请参见

  • 了解逻辑分析仪触发
  • 状态模式触发函数
  • 定时模式触发函数
  • 指定简单触发


读取事件和操作语句

触发序列步骤中的事件和操作语句是从左到右读取的，如：

Find an event in the device under test; when the event is found, take some action.（在被测设备中查找事件；当找到事件时，采取某种操作。）

或者：

If an event is found in the device under test; then, take an action.（如果在被测设备中找到事件；则采取某种操作。）

例如，假设您想了解从地址 406F5H 执行读取操作之后发生了什么。为此，设置触发来查找 RD（内存读）信号的上升沿和 406F6H（十六进制）的地址总线码型：

设置触发就如同在构造一个从左到右阅读的句子。例如：

Find a Signal named RD with a Rising Edge And a Bus named ADDR with All bits = (equal) to the pattern 406F6 Hex.When found, then Trigger and fill memory.

另请参见

  • 指定高级触发
  • 了解逻辑分析仪触发、序列步骤


使用定时器

定时器类似于秒表。使用定时器可以创建用户定义的延迟，或创建用于计算有效数据持续时间的时间标准。定时器可以从重置处启动，可以停止和重置，可以暂停或继续执行。

定时器注意事项：

  • 定时器重置需要一定的时间；这称为定时器重置等待时间。要想获知所用逻辑分析仪的定时器重置等待时间，请参见其特性描述。

  • 模块中可用定时器的数目取决于所选的采集模式和采样选项：

    采集模式 | 采样选项 | 可用定时器数
    状态模式（同步采样） | 一般状态模式 | 不是保留用于时间标签存储的盒对数
    涡轮状态模式 | 0
    定时模式（异步采样） | 全部 | 不是保留用于时间标签存储的盒对数

    请参阅所用逻辑分析仪的特性，了解可用定时器的实际数目。有关在什么情况下为时间标签存储保留盒对的信息，请参见为何找不到盒？。

  • 定时器是在事件语句中检查，在操作语句中启动的。

  • 必须先启动定时器，然后才能执行检查。为此，或者将带有定时器检查事件的定时器启动操作包含在同一触发步骤中，或者在之前的某一触发步骤中启动定时器。

    以下示例展示了同一触发步骤中的定时器启动操作和检查事件。

  • 定时器事件配置好后，可以通过选择其标识号来重用。对于同一定时器，必须始终使用同一个值对其进行检查。对于不同的持续时间，则要使用不同的定时器。

另请参见

  • 插入定时器操作
  • 插入定时器事件
  • 了解逻辑分析仪触发、定时器


使用计数器

计数器在事件和操作语句中都是可用的，并且和其他事件一样，它们的取值非真 (true) 即假 (false)。使用计数器可以创建用户定义的延迟，或创建用于计算有效数据持续时间的标准。配置好后，计数器在触发序列的所有步骤中均有效。

计数器注意事项：

  • 最多可用两个计数器。

  • 在跳变时序模式下使用计数器时，其中一个计数器是供内部使用的，因此只有一个计数器可在触发序列步骤中使用。

  • 计数器配置好后，可以通过选择其标识号来重用该计数器。每次使用计数器时必须使用同一个值对其进行检查。

注意：

逻辑分析仪也有发生计数器，以及 reset occurrence counter（重置发生计数器）操作。发生计数器只存在于包含 occurs（发生）词语的步骤中，并且不受本页所述的其他计数器操作的影响。

另请参见

  • 插入计数器操作
  • 插入计数器事件
  • 了解逻辑分析仪触发、计数器


使用标志

标志可用于在逻辑分析系统（包括多帧逻辑分析系统）中的模块之间发送信号。

NOTE:

标志在 1680/1690 系列逻辑分析仪中不可用。

有 4 个标志可在所有连接的逻辑分析系统结构之间共享。一个标志可同时被多个模块驱动或接收。

使用标志，在数据采集期间，逻辑分析仪模块在发生触发事件前后均可相互反复多次通信。（相比之下，一个模块在其触发事件发生时仅能与另一模块通信一次。）

默认情况下，标志将被清除。您可以插入操作 以设置、清除、脉冲设置或脉冲清除标志。您可以在不同的逻辑分析仪模块中插入标志事件 以测试标志是否被设置或清除。

NOTE:

标志操作不可用于 Turbo State Mode（涡轮状态模式）；但是，您仍可以使用标志事件来检查标志。

由模块设置的标志将一直保留，直到该模块将其清除。如果多个模块设置了同一标志，所有这些模块都必须清除该标志才能最终清除该标志。

标志还可用于驱动逻辑分析系统的 Port Out（输出端口）信号。

另请参见

  • 插入标志操作
  • 插入标志事件
  • 了解逻辑分析仪触发，标志


在触发序列步骤中替换或插入触发函数

当需要基于被测设备中的一系列事件发生触发时，触发序列中必须有多个步骤。当需要基于被测设备中的一个事件（即其中的单个样本）发生触发时，则只需使用触发序列中的一个步骤。

  1. 在 Advanced Trigger（高级触发）对话框中，将要用的触发函数 拖放到 Trigger Sequence（触发序列）显示区域。

    替换某一现有步骤：

    • 将触发函数拖放到触发序列中某一现有步骤的上方。原函数周围会显示一个红框，表示进行替换操作。

    将触发函数作为一个新步骤插入：

    • 将触发函数拖放到触发序列中某一现有步骤之上或之下位置。当鼠标定位在某一现有步骤之上或之下时，会出现一个红色的插入条，它指示触发函数的相对插入位置。

另请参见

  • 了解逻辑分析仪触发、序列步骤
  • 删除触发序列步骤
  • 状态模式触发函数
  • 定时模式触发函数


指定总线/信号码型或沿

  1. 在 Advanced Trigger（高级触发）对话框中，选择总线或信号。

    单击 [image] 可以从最近使用的总线/信号名称中选择。单击总线/信号名称按钮上的其他任何位置可以打开 Select（选择）对话框以选择其他名称。

  2. 如果已经选择了总线，可以选择该总线上的 All bits（所有位）或选择一个单独的位。

  3. 指定总线/信号值：

    如果已经选择了一个信号或总线的一个位，可以选择信号码型值（High（上限）、Low（下限）或 Dont Care（不限）），或时钟沿值（Rising Edge（上升沿）、Falling Edge（下降沿）、Either Edge（任一沿）或 Glitch（假信号））。在定时模式（异步采样）中您只能选择时钟沿值。

    如果已选择了某总线的所有位：

    1. 选择以下运算符之一：=（等于）、!=（不等于）、<（小于）、>（大于）、<=（小于或等于）、>=（大于或等于）、In Range、Not In Range 或 Edge。

      注意：

      如果选择了具有重新排序位的总线，则 <、>、<=、>=、In Range 和 Not In Range 运算符不可用。此外，当所选总线包含跨越盒对的时钟位时，这些运算符也不可用。In Range 和 Not In Range 运算符仅限于跨越 2 个或更少的盒对（最多 64 位宽）的总线。

      如果选择了 Edge（沿）运算符（仅在定时模式中可用），Edge Spec（沿指定）...按钮将打开 Set Edge/Glitch（设置沿/假信号）对话框，以指定总线上的多个时钟沿或假信号（请参见在多重时钟沿或假信号的某一个上触发）。

    2. 选择数基（Binary（二进制）、Hex（十六进制）、Octal（八进制）、Decimal（十进制）、Signed Decimal（带符号十进制）、Ascii 或 Symbol（符号））。

    3. 键入码型值。

      如果选择了 Symbol（符号）数基，则可以使用 Select Symbol（选择符号）对话框来指定码型值。

另请参见

  • 指定默认存储
  • 插入或删除事件
  • 了解逻辑分析仪触发，时钟沿
  • 了解逻辑分析仪触发，范围


指定触发序列步骤的转至或触发操作

  1. 在序列步骤的 Advanced Trigger（高级触发）对话框中，选择所需的触发操作：

    可以选择：

    • Goto（转到）— 转到另一个触发序列步骤。

    • Trigger and fill memory（触发并写入内存）— 触发逻辑分析仪并填充内存，而不转到触发序列中的其他任何步骤。

    • Trigger and goto（触发并转到）— 触发逻辑分析仪并转到另一个触发序列步骤。（这在使用触发序列步骤指定要存储的样本时很有用。）

    • Trigger, send e-mail, and fill memory（触发、发送电子邮件并填充内存）— 触发逻辑分析仪、发送电子邮件并填充内存，而不转到触发序列中的其他任何步骤。单击 E-Mail Setup（电子邮件设置）...，打开 E-mail（电子邮件）对话框以输入电子邮件地址、主题和信息。

  2. 如果您选择了一个指定 fill memory（填充内存）的操作并处于状态模式或选择了自定义存储的存储限定定时模式中，请输入用于填充内存的存储限定符。

另请参见

  • 插入或删除事件
  • 指定默认存储
  • （在触发序列步骤中）插入或删除操作


指定默认存储

存储限定符用于指定要存储在逻辑分析仪内存中的样本（从被测设备中采集）。通过只存储您关注的样本，可以充分利用可用内存并采集更长时间的活动。

默认存储 意味着“如果未经触发序列步骤中的存储控制 操作或填充内存 存储限定符指定，则进行存储”。触发序列步骤中的存储限定符总是覆盖默认存储。

默认存储限定符在状态采样模式和存储限定（跳变）定时模式中可用。

在跳变/存储限定定时模式中

  1. 选择存储限定类型：Transitional（跳变）或 Custom（自定义）。

    • 如果选择 Transitional（跳变），将存储从以前的样本转变而来的样本。

      如果不希望存储某些总线/信号转变，请单击 Exclude buses/signals（排除总线/信号）...，然后指定要排除的总线/信号。

    • 如果选择 Custom（自定义），则可以编辑或插入应存储（或不应存储）在逻辑分析仪内存中的事件。

在状态模式中

  1. 编辑或插入应存储（或不应存储）在逻辑分析仪内存中的事件。

另请参见

  • 插入或删除事件
  • 取消事件
  • 更改使用 AND/OR 组合的事件的计算顺序
  • 插入存储控制操作（在触发序列步骤中）
  • 指定触发序列步骤的转至或触发操作
  • 了解逻辑分析仪触发，存储限定


插入或删除事件

  1. 在 Advanced Trigger（高级触发）对话框的某个触发序列步骤中，单击与事件关联的 [image] 按钮（在触发序列步骤条件的 Find（查找）或 If 之后，或存储限定符的 Store（存储）或 with 之后），然后选择 Insert Event After（之后插入事件）(AND/OR)、Insert Event Before（之前插入事件）(AND/OR)或 Delete Event（删除事件）。

  2. 如果要插入事件，则需要选择事件的类型。

    根据插入事件的位置，可用的事件类型如下：

    • Bus/Signal（总线/信号）—总线/信号值，请参见 指定总线/信号码型或沿。
    • Anything（任何）—任何样本。
    • Nothing（无）—无样本。
    • Timer（定时器）—定时器值，请参见插入定时器事件。
    • Counter（计数器）—计数器值，请参见插入计数器事件。
    • Flag（标志）—标志值，请参见插入标志事件。
    • Arm in from—来自其他逻辑分析仪模块或外部仪器的激活 (arming) 信号，请参见插入 Arm in from 事件。

  3. 如果要插入事件，则需要指定其是否应与其他事件进行 And（与）或 Or（或）运算。

另请参见

  • 取消事件
  • 更改使用 AND/OR 组合的事件的计算顺序
  • 了解逻辑分析仪触发，布尔表达式


插入定时器事件

  1. 选择要检查的定时器。

  2. 选择定时器比较运算符。

  3. 输入要作为比较参照的定时器值。

注意：

Start from reset（从重置处启动）定时器操作既可以和定时器检查事件放在同一个序列步骤中，又可以放在之前的某一触发步骤中。不启动定时器便进行检查会发生错误。

有关定时器的更多信息，请参见使用定时器。

另请参见

  • 插入或删除事件


插入计数器事件

必须先通过计数器操作启动计数器，然后才能通过计数器事件对其进行计算。

  1. 选择要检查的计数器。

  2. 选择计数器比较运算符。

  3. 输入要作为比较参照的计数器值。

有关计数器的更多信息，请参见使用计数器。

另请参见

  • 插入或删除事件


插入标志事件

注意：

标志在 1680/1690 系列逻辑分析仪中不可用。

  1. 选择要检查的标志。

  2. 输入要作为比较参照的标志值。

大约要经过 100 ns 的延迟，标志事件才能感知到标志操作。

有关标志的更多信息，请参见使用标志。

另请参见

  • 插入或删除事件


插入 Arm in from 事件

  1. 通过选择其他模块或外部触发指定 arming 信号源。

有关将来自其他逻辑分析仪模块或外部仪器的信号作为触发源的更多信息，请参见从其他模块/仪器触发和向其他模块/仪器发送触发。

另请参见

  • 插入或删除事件


取消事件

在 Advanced Trigger（高级触发）对话框中，只要是可以编辑或插入事件的地方，就可以取消这些事件。

  1. 单击与事件关联的 [image] 按钮，并选择 Negate（取消）。

    2. 该对话框中的文本将发生变化，指示事件已取消。

注意：

在 Turbo State Mode（涡轮状态模式）中，对于存储限定符事件不能使用 Negate（取消）。

另请参见

  • 插入或删除事件


更改使用 AND/OR 组合的事件的计算顺序

在指定高级触发时（或在将触发函数转换成高级 if/then 步骤之后）以及在某一事件列表中有多个事件时，可以通过对事件进行分组来指定其计算顺序。

  1. 在 Trigger Sequence（触发序列）区域的 Trigger（触发）选项卡中，选择 If、If not、Else if 或 Else if not 按钮；然后选择 Group Events（事件分组）...。

  2. 在 Parenthesis（括号）对话框中，选择 Add Parens（添加括号） 按钮对事件进行分组，或选择 Remove Parens（删除括号）取消事件分组。

  3. 完成事件分组之后，单击 OK（确定）。

另请参见

  • 插入或删除事件


（在触发序列步骤中）插入或删除操作

  1. 在 Advanced Trigger（高级触发）对话框中的某一触发序列步骤中，单击与某一操作关联的 [image] 按钮（在 Then（然后） 后面），并选择 Insert Action After（在其后插入操作）、Insert Action Before（在其前插入操作）或 Delete Action（删除操作）。

  2. 若要插入操作，请选择操作的类型。

    以下操作类型是可用的：

    • Timer（定时器）— 有关启动、停止、暂停或继续运行定时器的说明，请参见插入定时器操作。
    • Counter（计数器）— 有关递增或重置计数器的说明，请参见插入计数器操作。
    • Reset occurrence Counter（重置发生计数器）— 有关重置发生计数器的说明，请参见插入重置发生计数器操作。
    • Flag（标志）— 有关设置或清除标志的操作，请参见插入标志操作。
    • Storage control（存储控制）— 有关存储或不存储样本，或者打开/关闭默认存储的说明，请参见插入存储控制操作。

另请参见

  • 插入或删除事件


插入定时器操作

  1. 选择要指定操作的定时器。

  2. 通过选择 Start from reset（从重置处启动）、Stop and reset（停止并重置）、Pause（暂停）或 Resume（继续执行），指定定时器操作。

注意：

Start from reset（从重置处启动）定时器操作既可以和定时器检查事件放在同一个序列步骤中，又可以放在之前的某一触发步骤中。不启动定时器便进行检查会发生错误。

有关定时器的更多信息，请参见使用定时器。

另请参见

  • （在触发序列步骤中）插入或删除操作


插入计数器操作

  1. 选择要指定操作的计数器。

  2. 通过选择 Increment（递增）或 Reset（重置）指定计数器操作。

有关计数器的更多信息，请参见使用计数器。

另请参见

  • （在触发序列步骤中）插入或删除操作


插入重置发生计数器操作

下面的触发序列步骤展示了重置发生计数器操作的使用过程。

在搜索一个事件的许多匹配项时，如果找到了另一个事件，则可以重置发生计数器并重新开始搜索。

另请参见

  • （在触发序列步骤中）插入或删除操作
  • 了解逻辑分析仪触发、发生计数器


插入标志操作

注意：

标志在 1680/1690 系列逻辑分析仪中不可用。

  1. 选择要指定操作的标志。

  2. 通过选择 Set（设置）、Clear（清零）、Pulse set（脉冲设置）或 Pulse clear（脉冲清零）指定计数器操作。

    脉冲模式下的标志在未处于脉冲工作状态时会处于相反的状态。如果在一个模块中为某一标志插入了 Pulse set（脉冲设置）操作，则不能在另一个模块中为该标志插入 Pulse clear（脉冲清零）操作。

    注意：

    在一个模块中，同一标志不能在脉冲和电平（Set（设置）/Clear（清零））两种模式下同时使用。如果插入或修改某一标志操作时的模式不同于同一标志的其他操作，则该标志的所有操作都将发生改变，以便与新模式保持一致。

  3. 如果选择了 Pulse set（脉冲设置）或 Pulse clear（脉冲清零），则输入脉冲宽度。

    注意：

    在一个模块中，某一标志的脉冲宽度在该标志的每一个操作中都必须是相同的。只要脉冲宽度在一个标志操作中发生改变，它就会在该标记的其他所有操作中发生改变。

有关标志的更多信息，请参见使用标志。

另请参见

  • （在触发序列步骤中）插入或删除操作


插入存储控制操作

  1. 通过选择 Store sample（存储样本）、Don't store sample（不存储样本）、Turn on default storage（打开默认存储）或 Turn off default storage（关闭默认存储），指定存储控制操作。

有关序列步骤存储和存储控制操作的更多信息，请参见了解逻辑分析仪触发、存储限定。

另请参见

  • （在触发序列步骤中）插入或删除操作


将触发序列步骤显示为高级 If/Then 触发函数

注意：

高级（If/Then 或 N-Way Branch）触发函数不支持其他显示类型。默认情况下，它们以不能更改的扩展图形形式出现。

  1. 在某一触发序列步骤中，单击 Step N（步骤 N）并选择 Show trigger step as if/then (read-only)（将触发步骤显示为 if/then（只读））。

    触发序列步骤将以只读形式显示为与之等同的高级 If/Then 触发函数。

撤消将触发序列步骤显示为高级 If/Then 触发函数的设置

  1. 在某一触发序列步骤中，单击 Step N（步骤 N）并选择已选中的 Show trigger step as if/then (read-only)（将触发步骤显示为 if/then（只读））项，返回触发函数的普通视图。

另请参见

  • 将触发序列步骤转换为高级 If/Then 触发函数


将触发序列步骤转换为高级 If/Then 触发函数

如果所需的触发函数不存在，则可以先找到某一关闭的触发函数，再将触发序列步骤转换为高级 If/Then 触发函数，然后编辑此 If/Then 触发函数。

注意：

高级（If/Then 或 N-Way Branch）触发函数不支持其他显示类型。默认情况下，它们以不能更改的扩展图形形式出现。

  1. 在某一触发序列步骤中，单击 Step N（步骤 N）并选择 Convert trigger step to if/then (can't undo)（将触发步骤转换成 if/then（不能撤消））。

    触发序列步骤将转换成与之等同的高级 If/Then 触发函数。

另请参见

  • 将触发序列步骤显示为高级 If/Then 触发函数
  • 了解逻辑分析仪触发、分支


选择事件的持续时间或发生计数（定时模式）

在定时模式下指定高级触发时，可以指定事件的发生次数，或者指定事件的持续时间。

  1. 在触发序列步骤中，选择 occurs（发生）或 present for（持续）>，以更改设置。

另请参见

  • 将触发序列步骤转换为高级 If/Then 触发函数


删除触发序列步骤

  1. 在某一触发序列步骤中，单击 Step N（步骤 N）并选择 Delete（删除）。

至少应有一个触发序列步骤。


清除触发序列

  1. 在 Advanced Trigger（高级触发）对话框中，单击对话框底部的 Clear（清除）。


从其他模块/仪器触发和向其他模块/仪器发送触发

当逻辑分析系统中有多个模块时，可以从一个模块中触发，从而激活另一模块。您也可以将模块的触发信号发送到外部仪器，或者从外部仪器发送信号以激活模块。

逻辑分析仪（1680 系列的后面板、1690 系列的前面板以及 16900 系列的后面板）上带有 Trigger In 和 Trigger Out BNC 连接器。使用这些连接器可以将分析仪连接到外部仪器，并发送或接收触发信号。

  • 用一个模块的触发激活另一个模块
  • 触发其他仪器 - Trigger Out
  • 从其他仪器触发分析仪 - Trigger In


用一个模块的触发激活另一个模块

  1. 单击分析仪设置工具栏中的 [image] ，或从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Advance Trigger（高级触发）...。

  2. 在 Advanced Trigger（高级触发）对话框中，选择 Other（其他）触发函数选项卡；然后，将 Wait for arm from another module 触发函数拖放到触发序列区域中。

  3. 从模块名下拉列表中选择其触发将用于激活此模块（并且满足触发序列步骤中的事件条件）的另一个模块。

  4. 单击 Advanced Trigger（高级触发）对话框中的 OK（确定），开始进行测量（请参见开始/停止测量）。

    收到来自另一个模块的激活信号 (arm) 时，此模块会执行触发序列步骤中所描述的操作。

相反的情况

还存在这样一种情况，即两个模块在查找触发事件，当任一模块找到其触发事件时，另一个模块应被激活。为此：

  1. 设置第一个模块（如 My 16742A-1）的触发：

  2. 设置第二个模块（如 My 16742A-2）的触发：

    Overview（概览）窗口中的 arming 设置如下所示：

  3. 运行测量。

另请参见

  • Wait for arm from another module（状态）
  • Wait for arm from another module（定时）


触发其他仪器 - Trigger Out

  1. 将一根 BNC 电缆从 Trigger Out BNC 连接到想要触发的外部仪器。

  2. 选择 Setup（设置）> External Trigger（外部触发）...。

  3. 在 External Trigger（外部触发）对话框中：

    1. 如果您正在使用 1680/1690 系列逻辑分析仪，请指定触发是否显示为 Trigger Out BNC 上的上升或下降沿。

      如果您正在使用 16900 系列逻辑分析系统：

      • 启用输出。
      • 选择极性（活动上限或活动下限）。
      • 选择输出模式（使用馈通查看输出的标志设置）。
      • 选择引起 Trigger Out 的触发或标志事件。

    2. 单击 OK（确定）。

  4. 配置逻辑分析仪以便可以正常地进行其他任何测量。

  5. 当分析仪触发序列为真且分析仪启动时，将通过 Trigger Out BNC 向外部仪器发出触发信号。

另请参见

  • External Trigger（外部触发）对话框


从其他仪器触发分析仪 - Trigger In

  1. 使用一根 BNC 电缆将 Trigger In BNC 和可以发送触发信号的外部仪器建立连接。

  2. 选择 Setup（设置）> External Trigger（外部触发）...。

  3. 在 External Trigger（外部触发）对话框中，指定 Trigger In BNC 上的上升或下降沿表示触发，然后，单击 OK（确定）。

  4. 单击分析仪设置工具栏中的 [image] ，或从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Advance Trigger（高级触发）...。

  5. 在 Advanced Trigger（高级触发）对话框中，选择 Other（其他）触发函数选项卡，然后，将 Wait for external arm 触发函数拖放到触发序列区域。

  6. 单击 Advanced Trigger（高级触发）对话框中的 OK（确定），开始进行测量（请参见开始/停止测量）。

  7. 在外部仪器上运行测量。

    当接收到外部仪器的通信时，逻辑分析仪将执行触发序列步骤中所描述的操作。

另请参见

  • Wait for external arm（状态）
  • Wait for external arm （定时）
  • External Trigger（外部触发）对话框


存储和重新调用触发

触发以三种方式存储：

  • 测量开始后自动存储到最近使用项列表。

  • 存储到收藏夹列表。

  • 存储到 XML 格式的触发设定文件。

可以从最近使用项列表、收藏夹列表或 XML 格式的触发设定文件重新调用触发。

可以将最近使用的触发移至收藏夹列表。

通过设置触发历史记录深度，可以控制最近使用项列表和收藏夹列表的长度。

注意：

当前触发设置（和收藏夹列表）还会作为分析仪配置的一部分来存储。如果载入新配置文件，则触发设置（和收藏夹列表）将被覆盖。


存储触发

  1. 选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Store Trigger（存储触发）... 命令，或在 Advanced Trigger（高级触发）对话框中，单击 Store（存储）...。

  2. 在 Store Trigger（存储触发）对话框中：

    要将触发存储在收藏夹列表中，请执行以下操作：

    1. 输入触发名称。
    2. 单击 Store as favorite（存储为喜爱的项）。

    将触发存储在 XML 格式文件中：

    1. 单击 Save to file（保存到文件夹）...。
    2. 在 Save As（另存为）对话框中，输入文件名并单击 Save（保存）。

另请参见

  • 重新调用触发
  • 设置触发历史记录深度


重新调用触发

  1. 从菜单中选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Recall Trigger（重新调用触发）...，或者在 Advanced Trigger（高级触发）对话框中单击 Recall（重新调用）...。

  2. 在 Recall Trigger（重新调用触发）对话框中：

    • 从收藏夹或最近使用项列表中选择要重新调用的触发；然后单击 OK（确定）。

    • 或者，要从以前保存的 XML 格式的触发设定文件中重新调用触发，请单击 Open（打开）... 并选择该文件。

将最近使用的触发移至收藏夹列表

  1. 从菜单栏中，选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Recall Trigger（重新调用触发）...。

  2. 在 Recall Trigger（重新调用触发）对话框中，从最近使用项列表中选择触发。

  3. 单击 Store Selected Recent Trigger To Favorites List（将所选的最近触发存储到收藏夹列表）。

另请参见

  • 存储触发


设置触发历史记录深度

  1. 选择 Edit（编辑）>Options（选项）...命令。

  2. 在 Options（选项）对话框中，输入 Trigger History Depth（触发历史深度）。

    输入的数字既适用于最近使用过的触发列表，也适用于收藏夹列表。

另请参见

  • 存储触发
  • 重新调用触发


开始/停止测量

在单个模式中运行分析仪

单个运行测量可以采集数据并一次填充跟踪内存。单次运行期间存储的数据量等于分配的跟踪内存量。例如，如果跟踪内存为 2M，则在一次运行后的存储数据量等于 2M。

  • 从菜单栏中，选择 Run/Stop（运行/停止）> Run（运行），或单击运行/停止工具栏中的 [image] 图标。

在重复运行模式中运行分析仪

运行重复测量可以采集数据并重复填充跟踪内存。重复运行中存储的数据量与单次运行中的相同。在重复运行期间，一旦跟踪内存填满，系统将清除跟踪内存，然后使用新数据开始重新填充。运行停止之前连续执行此循环。

  • 从菜单栏中，选择 Run/Stop（运行/停止）> Run Repetitive（运行重复），或单击运行/停止工具栏中的 [image] 图标。

注意：

例如，如果您重复进行测量并在触发后某个固定的时间查看数据，则可以更改“go to trigger on run（在运行时转至触发）”行为，这样每次测量后显示的位置不会更改。

查看分析仪运行状态

  • 从菜单栏中，选择 Run/Stop（运行/停止）> Status（状态）...，或单击状态栏中的 Status（状态）...。

    运行状态显示在 Status（状态）对话框的 System Status（系统状态）选项卡中。

停止分析仪

停止测量时，收集的数据量等于停止之前所用的跟踪内存量。例如，如果跟踪内存等于 2M 并且恰好在运行到一半时停止检测，那么跟踪内存中的数据量等于 1M。

  • 从菜单栏中，选择 Run/Stop（运行/停止）> Stop（停止），或单击运行/停止工具栏中的 [image] 图标。

另请参见

  • 更改 "Go to Trigger on Run" 选项


更改 Go to Trigger on Run（在运行时转至触发）选项

测量开始及结束后，默认情况下 Agilent Logic Analyzer 应用程序会显示在系统触发位置附近采集的数据。

如果您在进行重复测量，并在触发之后的某一固定时间查看数据，则可以更改“go to trigger on run（在运行时转至触发）”行为，使正在显示的位置在每一测量之后保持不变。

  1. 选择 Edit（编辑）> Options（选项）...。

  2. 在 Options（选项）对话框中，选中或取消选中 Go to Trigger on Run（在运行时转至触发）复选框。

    选项设置会保存在注册表中；这意味着下次启动 Agilent Logic Analyzer 应用程序时，所作更改会依然存在。


保存采集的数据（和逻辑分析仪设置）

可以将逻辑分析仪设置和采集的数据保存到配置文件。以后，您可以通过打开这些配置文件来设置逻辑分析仪以及重新载入数据。保存配置文件时，可以选择只保存逻辑分析仪设置（即不保存数据）。

也可以将采集的数据保存到逗号分隔值 (CSV) 文件。CSV 文件可以导入到电子表格、数据库或其他数据分析程序。

  • 保存配置文件
  • 将数据导出为标准的 CSV 格式文件
  • 将数据导出为模块 CSV 格式文件
  • 将数据导出为模块二进制 (ALB) 格式文件


保存配置文件

使用保存功能可以保存配置文件，以供以后使用。第一次保存文件时，会出现逻辑分析仪配置文件对话框。使用 Save As（另存为）... 功能可以将现有配置文件以不同文件名保存。

  1. 从菜单栏中，选择 File（文件）> Save（保存），或者选择标准工具栏中的 [image] 图标。

  2. 输入 File name（文件名）。

    小心：

    在向 16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器写数据时，必须将逻辑分析系统水平放置；否则，任何 CD-ROM 驱动器都可能无法读取由此生成的 CD-R/RW 光盘。

  3. 选择 Save as type（保存类型）。

    有关何时使用 ALA (*.ala) 格式文件以及何时使用 XML (*.xml) 格式文件的信息，请参见 ALA 与 XML 的各自使用场合。

  4. 若要保存为 XML 格式的文件，请选择 Source（源）。

    可以保存来自所有模块或个别模块的配置信息和数据。

  5. 如果需要，请填写文件标题信息下面的 Owner（所有者）、Project（项目）和 Description（描述）文本框。当重新打开配置文件时，这些内容可以帮助识别该文件。

  6. 选择文件选项：

    • All Data and Setup（所有数据和设置）— 保存采集的数据和仪器设置。

    • Setup Only（仅设置）— 只保存仪器设置，不保存采集的数据。

    • Range（范围）— 保存仪器设置和某一范围的采集数据。单击 Properties（属性）...；在 Range Properties（范围属性）对话框中指定范围。

    注意：

    包含数据的配置文件比不包含数据的配置文件要大得多。

  7. 单击 Save（保存）。

注意：

如果使用逻辑分析仪时没有键盘，则可以通过选择 Start（开始）> Programs（程序）> Accessories（附件）> Accessibility（辅助工具）> On-Screen Keyboard（屏幕键盘）

另请参见

  • 打开配置文件
  • 脱机分析
  • ALA 与 XML 的各自使用场合
  • ALA 格式
  • XML 格式


将数据导出为标准的 CSV 格式文件

可以将采集的数据导出至标准逗号分隔值 (CSV) 文件。可以将标准 CSV 文件导入电子表格、数据库或其他数据分析程序。

  1. 从菜单栏中，选择 File（文件）> Export（导出）...。

  2. 在 Export（导出）对话框中，选择 Standard CSV text file（标准 CSV 文本文件），然后单击 OK（确定）。

  3. 在下面的 Export（导出）对话框中：

    1. 输入 CSV 文件的名称。

      小心：

      在向 16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器写数据时，必须将逻辑分析系统水平放置；否则，任何 CD-ROM 驱动器都可能无法读取由此生成的 CD-R/RW 光盘。

    2. 选择要从中导出数据的 Source（来源）模块、工具或显示窗口。

    3. 如果要使用逗号以外的分隔符，或要指定写入的行号，请单击 Options（选项）...。在 File Export Options（文件导出选项）对话框中进行选择，然后单击 OK（确定）。

    4. 如果要导出某一范围的数据和/或选定的总线/信号数据，请取消选中 All Data（所有数据）。

    5. 要指定导出某一范围的数据，请单击 Data Range（数据范围）...。在 Range Properties（范围属性）对话框的 Data Range（数据范围）选项卡中，按时间或标记选择范围；然后单击 OK（确定）。

    6. 要选择导出特定的总线/信号数据，请单击 Bus Signal Selection（总线信号选择）...。在 Range Properties（范围属性）对话框的 Bus/Signal Selection（总线/信号选择）选项卡中，选择导出数据的总线/信号源；然后单击 OK（确定）。

      注意：

      仅当已将某个模块或工具选作数据导出的 Source（来源）时，才能选择特定的总线/信号。如果将某个显示窗口选作 Source（来源），则会导出所有总线/信号。（当然，您可以在导出显示窗口的数据之前将不需要的总线/信号从其中删除。）

  4. 单击 Save（保存）。

另请参见

  • 标准 CSV 格式


将数据导出为模块 CSV 格式文件

采集的数据可以导出到模块逗号分隔值 (CSV) 文件。可以使用数据导入模块 对模块 CSV 文件进行后处理，并重新导入逻辑分析系统。

小心：

请勿通过 Microsoft Excel 修改模块 CSV 文件。Excel 在保存文件时会改变 CSV 格式，这样就必须手动进行大量的文本编辑，才能将数据重新导入逻辑分析系统。

  1. 从菜单栏中，选择 File（文件）> Export（导出）...。

  2. 在 Export（导出）对话框中，选择 Module CSV text file（模块 CSV 文本文件）；然后单击 OK（确定）。

  3. 在下面的 Export（导出）对话框中：

    1. 输入 CSV 文件的名称。

      小心：

      在向 16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器写数据时，必须将逻辑分析系统水平放置；否则，任何 CD-ROM 驱动器都可能无法读取由此生成的 CD-R/RW 光盘。

    2. 选择导出数据的 Source（源）模块。

      只能从逻辑分析仪和导入模块将数据导出为模块 CSV 格式文件。虽然可以从逻辑分析仪模块导出时序放大数据，但必须与该模块的主数据分开导出。

    3. 若要使用除逗号以外的其他分隔符，指定被写入的行编号，或者指定不包括标题信息，请单击 Options（选项）...。在 File Export Options（文件导出选项）对话框中进行选择，然后单击OK（确定）。

      要想将数据重新导入逻辑分析系统，必须包括 Header（标题）信息。

    4. 如果要导出某一范围的数据和/或选定的总线/信号数据，请取消选中 All Data（所有数据）。

    5. 要指定导出某一范围的数据，请单击 Data Range（数据范围）...。在 Range Properties（范围属性）对话框的 Data Range（数据范围）选项卡中，按时间或标记选择范围；然后单击 OK（确定）。

    6. 要选择导出特定的总线/信号数据，请单击 Bus Signal Selection（总线信号选择）...。在 Range Properties（范围属性）对话框的 Bus/Signal Selection（总线/信号选择）选项卡中，选择导出数据的总线/信号源；然后单击 OK（确定）。

  4. 单击 Save（保存）。

另请参见

  • 创建数据导入模块
  • 模块 CSV 格式


将数据导出为模块二进制 (ALB) 格式文件

可以将采集的数据导出至模块二进制文件。Agilent Logic Analyzer 应用程序的后续版本将能够使用数据导入模块 将模块二进制文件导入逻辑分析系统。

  1. 从菜单栏中，选择 File（文件）> Export（导出）...。

  2. 在 Export（导出）对话框中，选择 Module binary file（模块二进制文件）；然后单击 OK（确定）。

  3. 在下面的 Export（导出）对话框中：

    1. 输入 ALB 文件名。

      小心：

      在向 16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器写数据时，必须将逻辑分析系统水平放置；否则，任何 CD-ROM 驱动器都可能无法读取由此生成的 CD-R/RW 光盘。

    2. 选择导出数据的 Source（源）模块。

      只能从逻辑分析仪模块将数据导出为模块二进制格式文件。虽然可以从逻辑分析仪模块导出时序放大数据，但必须与该模块的主数据分开导出。

    3. 若要使用除逗号以外的其他分隔符，指定被写入的行编号，或者指定不包括标题信息，请单击 Options（选项）...。在 File Export Options（文件导出选项）对话框中进行选择，然后单击OK（确定）。

    4. 如果要导出某一范围的数据和/或选定的总线/信号数据，请取消选中 All Data（所有数据）。

    5. 要指定导出某一范围的数据，请单击 Data Range（数据范围）...。在 Range Properties（范围属性）对话框的 Data Range（数据范围）选项卡中，按时间或标记选择范围；然后单击 OK（确定）。

    6. 要选择导出特定的总线/信号数据，请单击 Bus Signal Selection（总线信号选择）...。在 Range Properties（范围属性）对话框的 Bus/Signal Selection（总线/信号选择）选项卡中，选择导出数据的总线/信号源；然后单击 OK（确定）。

  4. 单击 Save（保存）。

另请参见

  • 模块二进制 (ALB) 格式


通过 VBA 扩展采集能力

通过集成的 Microsoft Visual Basic for Applications (VBA)，您可以扩展逻辑分析仪的数据采集能力。例如：

  • 当逻辑分析仪无法触发相关事件时，可以运行 VBA 并使用它来分析采集的数据以查找该事件，如果未找到，则重新运行。对于相对频繁发生的事件，此功能可使逻辑分析仪找到因过于复杂而无法定义触发的事件。

  • 如果需要使用大量数据来查找难以定义的错误，则可以设置逻辑分析仪重复运行并保存数据。

  • 您可以在重复运行之间创建动态触发，方法是：执行运行，根据对采集数据的分析结果修改触发，然后重新运行。

以前可以通过逻辑分析仪的 COM 自动控制功能来执行所有这些操作；但现在 Agilent Logic Analyzer 应用程序已与 VBA 相集成，这些操作就更为简单快捷了。

另请参见

  • 使用高级定制环境 (ACE)


分析采集的数据

  • 脱机分析（在载入已保存的数据和设置之后）
  • 分析波形数据
  • 分析列表数据
  • 显示总线/信号值的名称（符号）
  • 标记数据点并在数据点之间进行测量
  • 搜索采集的数据
  • 比较采集的数据与参考数据
  • 查看与采集的数据关联的源代码
  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据
  • 设置模块之间的系统触发与偏移
  • 使用显示窗口
  • 打印采集的数据
  • 通过 VBA 扩展数据可视化/分析


载入已保存的数据和设置

可以通过打开以前保存的配置文件，对逻辑分析仪进行设置并载入数据。这使您可以返回到以前逻辑分析会话的停止点，载入以前保存的数据以进行脱机分析，或者只是载入保存的逻辑分析仪设置。打开包含数据的配置文件时，可以选择只载入逻辑分析仪设置（即不载入数据）。

您可以导入 167xx 快速二进制数据，以便对 16700 系列逻辑分析仪上采集的数据进行脱机分析。

  • 打开配置文件
  • 恢复最近使用的配置文件
  • 导入 167xx 快速二进制数据
  • 从多模块系统获取模块设置/向多模块系统传送模块设置
  • 使用 XML 格式的配置设置多个模块
  • 使用数据导入模块
    • 创建数据导入模块
    • 编辑数据导入模块的总线/信号定义
    • 查看数据导入模块文件信息
    • 重新读取数据导入模块文件

另请参见

  • 脱机分析


打开配置文件

通过打开配置文件，可以返回到以前的逻辑分析会话，载入以前保存的数据以进行脱机分析，或者载入保存的逻辑分析仪设置。

注意：

为了避免在打开配置文件进行脱机分析时出现盒截断，请在 Agilent Logic Analyzer 应用程序的另一个实例（以脱机 模式运行）中打开配置文件。

启动 Agilent Logic Analyzer 应用程序并打开配置文件的一种快捷方式是在 Windows 资源管理器中双击 ALA 格式的配置文件。（.ala 文件扩展名的关联是在安装该应用程序时建立的。）不过，这种方式不能实现部分载入（只载入设置、只载入模块等）。

从 Agilent Logic Analyzer 应用程序中打开配置文件：

  1. 从菜单栏中，选择 File（文件）> Open（打开）...，或者选择标准工具栏中的 [image] 图标。

    Open（打开）对话框的浏览部分的操作方式与其他标准的 Windows 文件浏览对话框相同（即可以从中重命名文件，使用右键单击鼠标操作等）。

  2. 选择要打开的配置文件的类型（*.ala 或 *.xml）。

    有关何时使用 ALA (*.ala) 格式文件以及何时使用 XML (*.xml) 格式文件的信息，请参见 ALA 与 XML 的各自使用场合。

  3. 选择要打开的配置文件的名称。

    Content（内容）、Date（日期）、Version（版本）、Owner（所有者）、Project（项目）和 Description（描述）域显示了所选配置文件的有关信息。创建该文件时所用的 Agilent Logic Analyzer 版本显示在 Version（版本）框中。Date（日期）框显示该配置文件的创建日期。

  4. 选择适当的 Setup/Data（设置/数据）选项。

    • 选择 All Data and Setup（所有数据和设置）可以载入逻辑分析仪设置和数据。

    • 选择 Setup Only（仅设置）则只载入逻辑分析仪设置。

  5. 选择适当的 Tools/Viewers（工具/查看器）选项。

    • 选择 Include Tools/Viewers（包括工具/查看器）可从配置文件载入工具、查看器以及模块。

    • 选择 Setup Only（仅设置）则只从配置文件载入模块信息。

  6. 选择 Open（打开）。

注意：

如果使用逻辑分析仪时没有键盘，则可以通过选择 Start（开始）> Programs（程序）> Accessories（附件）> Accessibility（辅助工具）> On-Screen Keyboard（屏幕键盘）

另请参见

  • 恢复最近使用的配置文件
  • 保存配置文件
  • 从多模块系统获取模块设置/向多模块系统传送模块设置
  • 脱机分析
  • ALA 与 XML 的各自使用场合
  • ALA 格式
  • XML 格式


恢复最近使用的配置文件

  1. 从菜单栏中，选择 File（文件）。

  2. 从提供的列表中选择要打开的配置文件。


导入 167xx 快速二进制数据

注意：

导入 167xx 快速二进制文件以前，先要将它们复制到本地硬盘。与放在网上相比，快速二进制文件放在本地硬盘上时 Agilent Logic Analyzer 应用程序的性能要好得多。

  1. 从菜单栏中，选择 File（文件）> Import（导入）...。

  2. 在 Import（导入）对话框中，选择 16700 Fast Binary Data（16700 快速二进制数据），并单击 OK（确定）。

  3. 在下一个 Import（导入）对话框中，选择或输入要导入的 167xx 快速二进制数据文件的 File name（文件名）。

  4. 单击 Open（打开）。

来自 16700 系列逻辑分析仪快速二进制数据文件的总线/信号名称是基于模块、分析仪和总线/信号名称组织到文件夹层次结构中的。

另请参见

  • 分析 16700 系列逻辑分析仪数据
  • 脱机分析中 16700 盒与位的关联
  • 脱机分析


从多模块系统获取模块设置/向多模块系统传送模块设置

通过将设置保存到配置文件/从配置文件打开设置，可以在逻辑分析系统之间转移逻辑分析仪设置。当系统中有多个模块时，必须对将配置文件中的哪个模块设置载入到逻辑分析系统中的哪个模块进行详细规划。

  1. 确定要载入的设置（配置文件）格式正确：

    • 如果模块是兼容的（比如属于相同或相似的逻辑分析仪系列，如 16740/41/42A 和 16750/51/52A/B），则可以使用 ALA 格式的配置文件在模块间转移设置。

    • 如果模块不兼容，则必须使用 XML 格式的配置文件来转移设置。

  2. 打开配置文件（请参见打开配置文件）。

  3. 载入之前回答关于清除所有模块的问题。

  4. 在 Module Mapping（模块映射）对话框中，选择 Manually specify module mapping（手动指定模块映射）；然后单击 Specify Mapping（指定映射）...。

  5. 在 Specify Mapping（指定映射）对话框中，针对要载入设置的模块，从配置文件中选择要载入的模块设置。

  6. 单击 OK（确定），关闭 Specify Mapping（指定映射）对话框。

  7. 单击 OK（确定），关闭 Module Mapping（模块映射）对话框并载入设置。

    从 XML 格式的配置文件载入模块设置时，信息对话框会对所有解析错误或警告进行描述。

另请参见

  • 保存配置文件
  • 打开配置文件
  • ALA 与 XML 的各自使用场合


使用 XML 格式的配置设置多个模块

随 Agilent Logic Analyzer 应用程序一起提供的还有 Large System Setup（大型系统设置）实用工具，借助该实用工具，您可以使用 XML 格式的配置文件轻松设置大型的多模块逻辑分析系统。例如，如果您的逻辑分析系统有若干个逻辑分析仪模块，并且它们所探测的总线类别相同，那么您就可以借助 Large System Setup（大型系统设置）实用工具使用相同的 XML 格式配置文件来设置各个模块。（在主应用程序中进行同样的设置则需要多个费时的步骤。）

Large System Setup（大型系统设置）实用工具也可以在脱机 模式下使用。在这种情况下，您可以根据需要添加一定数量的逻辑分析仪模块，并为各个模块指定 XML 格式的配置。

使用 Large System Setup（大型系统设置）实用工具：

  1. 如果尚未启动 Agilent Logic Analyzer 应用程序，则先启动该程序，然后将它连接到需要设置的逻辑分析系统，如果要以脱机 模式进行设置，则需进入脱机状态。

  2. 从 Windows“开始”菜单处选择 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> Large System Setup（大型系统设置）。

  3. 如果已经连接到要设置的逻辑分析系统，则转至第 5 步；否则，在脱机模式下，单击 Large System Setup（大型系统设置）对话框中的 Offline Module Setup（脱机模块设置）...。

  4. 在 Offline Module Setup（脱机模块设置）对话框中，对于要添加的每一个模块：

    1. 单击 Add Module（添加模块）...。

    2. 在 Add Module（添加模块）对话框中，选择构成模块的卡的类型和数量。

    3. 单击 OK（确定）。

    单击 Delete All Modules（删除所有模块）可删除所有模块，单击 Delete Selected Module（删除所选模块）可删除选择的模块。

    添加模块完成之后，单击 OK（确定），关闭 Offline Module Setup（脱机模块设置）对话框。

  5. 在 Large System Setup（大型系统设置）对话框中，输入各个模块的 Module Name（模块名称）。

    （不使用 XML 格式配置文件中的模块名称，因为该 XML 文件可能会用于设置多个模块。）

  6. 对于要用 XML 格式配置文件设置的每一个模块，确定选中了 Load File（载入文件）框，然后单击 Browse（浏览）...，选择配置文件名。

  7. 如果这些 XML 格式配置文件包含多个逻辑分析仪模块的设置，请选择要使用的文件模块设置。

  8. 单击 OK（确定），关闭 Large System Setup（大型系统设置）对话框，完成逻辑分析系统的设置。


使用数据导入模块

数据导入模块可读取模块 CSV 文件中的数据并可使其用于工具和显示窗口。模块 CSV 文件可由外部工具创建，或使用主菜单的 File（文件）> Export（导出）... 命令从任一模块中保存。

NOTE:

数据导入模块是已获许可的功能。您可以在没有许可证的情况下使用数据导入模块，但可导入的数据量仅限 16 行。

  • 创建数据导入模块
  • 编辑数据导入模块的总线/信号定义
  • 查看数据导入模块文件信息
  • 重新读取数据导入模块文件

数据导入模块（和导入文件名称）是使用逻辑分析仪配置（ALA 和 XML 格式）进行保存的。如果以“包含数据”的形式保存某配置，然后将其再次打开，将显示导入模块的数据，而不从导入文件中重新读取该数据。如果以“不包含数据”（只带有设置）的形式保存某配置，然后将其再次打开，则必须重新读取数据导入模块文件（请参见重新读取数据导入模块文件）。

另请参见

  • 将数据导出为模块 CSV 格式文件
  • 模块 CSV 格式


创建数据导入模块

注意：

导入模块 CSV 文件以前，先要将它们复制到本地硬盘。与从网络驱动器导入文件相比，从本地硬盘导入文件时 Agilent Logic Analyzer 应用程序的性能要好得多。

  1. 从菜单栏中，选择 File（文件）> Import（导入）...。

  2. 在 Import（导入）对话框中，选择 Module CSV text file（模块 CSV 文本文件），然后单击 OK（确定）。

  3. 在下面的 Import（导入）对话框中：

    1. 选择或输入要导入的数据文件的 File name（文件名）。

    2. 选择该数据文件的导入 Destination（目的地）。可以选择现有的数据导入模块或 <New Data Import Module>（<新的数据导入模块>）。

    3. 单击 Open（打开）。

像其他逻辑分析仪模块一样，数据导入模块会出现在 Overview（概览）窗口中。由于这些数据不是来自逻辑分析仪机架中的采集硬件，因此系统会针对数据导入模块创建一个虚拟 机架。可以向数据导入模块中添加工具和显示窗口，就好像将它们添加到逻辑分析仪模块中一样。

另请参见

  • 编辑数据导入模块的总线/信号定义
  • 查看数据导入模块文件信息
  • 重新读取数据导入模块文件
  • 模块 CSV 格式
  • 将数据导出为模块 CSV 格式文件


编辑数据导入模块的总线/信号定义

  1. 单击数据导入工具栏中的 [image] ，或从主菜单中选择 Setup（设置）> (Data Import Module)（数据导入模块）> Bus/Signals（总线/信号）...。

  2. 在 Import Setup（导入设置）对话框的 Buses/Signals（总线/信号）选项卡中：

    请注意，在导入的数据文件中，盒 是为数据值列创建的。它们与逻辑分析仪模块中的盒类似，只是它们的位宽度没有限制。

    在编辑导入模块中的总线/信号定义时，您可以：

    • 添加新的总线或信号。
    • 删除总线或信号。
    • 重命名总线或信号。
    • 以默认位顺序分配通道。
    • 通过选择位顺序来分配通道
    • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
    • 设置默认数基。
    • 设置极性。
    • 添加注释。
    • 添加文件夹。
    • 为总线/信号设置别名。
    • 排序总线/信号名称

    这些操作与在逻辑分析仪模块中定义总线和信号非常相似（请参见定义总线和信号）。

    通过 Display（显示）按钮，您可以选择显示哪些总线/信号设置信息（channels assigned（分配的通道）、width（宽度）、polarity（极性）、default base（默认数基）、comment（注释）或 channel numbers（通道编号））。

    Bus/Signal Name（总线/信号名称）列中的总线和信号图标通常为红色，但如果该总线/信号被反汇编程序锁定，则会变为灰色。

另请参见

  • 查看数据导入模块文件信息
  • 重新读取数据导入模块文件
  • 模块 CSV 格式


查看数据导入模块文件信息

  1. 单击数据导入工具栏中的 [image] ，或从菜单栏中，选择 Setup（设置）> (Data Import Module)（数据导入模块）> File Info（文件信息）...。

  2. 在 Import Setup（导入设置）对话框的 File Information（文件信息）选项卡中：

    • 显示了文件名和其他文件信息。

    • 显示了时间列和触发行。显示了触发相关偏移。

    • 显示了模块数据导入文件的列名称、宽度、类型和格式。

另请参见

  • 编辑数据导入模块的总线/信号定义
  • 重新读取数据导入模块文件
  • 模块 CSV 格式


重新读取数据导入模块文件

在创建数据导入模块时，数据是从导入的文件读取的。另外，不使用文件选择对话框也可以重读数据导入文件。

重读数据导入文件

执行以下某个操作：

  • 从菜单栏中，选择 Run/Stop（运行/停止）> (Data Import Module)（数据导入模块）> Read（读取）。

  • 在数据导入工具栏或 Overview（概览）窗口的数据导入模块中，单击 [image] 图标。

查看数据导入模块的读状态

  • 从菜单栏中，选择 Run/Stop（运行/停止）> Status（状态）...，或者在状态栏中单击 Status（状态）...。

    读状态显示在 Status（状态）对话框中的 System Status（系统状态）选项卡中。

另请参见

  • 查看数据导入模块文件信息


脱机分析

当逻辑分析仪的数据采集硬件用于其他测量时，可以使用脱机分析来分析采集的数据。

可以在独立的个人计算机、1680/1690 系列逻辑分析仪或 16900 系列逻辑分析系统上使用 Agilent Logic Analyzer 应用程序来进行脱机分析。

若将配置/数据文件放在共享的文件系统上，则可以通过网络进行远程脱机分析。

示例：一种典型的情况是在 16700 系列逻辑分析系统中采集数据，将数据文件载入到 Agilent Logic Analyzer 应用程序中进行脱机分析，然后继续使用 16700 系列逻辑分析系统查找下一个故障或崩溃隐患。通过脱机分析数据，可以在分析上一个测量的同时让逻辑分析仪硬件抓紧时间进行新的测量。

示例：另一种情况是使用 Agilent Logic Analyzer 应用程序配置包含触发设置的逻辑分析仪配置文件，并与现场或远程位置的同事交换这些配置文件。

常规的脱机分析注意事项

  • 要分析来自 16700 系列逻辑分析仪的数据，必须以快速二进制数据格式保存这些数据。这是通过使用文件输出工具 (File Out Tool) 来完成的（请参见分析 16700 系列逻辑分析仪数据）。

  • 进行脱机数据分析时没有数据采集硬件，因此触发、硬件辅助和运行函数之类的功能是不可用的。

  • 可以在逻辑分析仪或个人计算机上并排显示 Agilent Logic Analyzer 应用程序的多个实例，但它们的数据不是时间相关的。

  • 可以将 Agilent Logic Analyzer 应用程序安装在符合最低 PC 要求的任何计算机上；不过，需要获得使用许可的工具要求为运行该工具的每一台计算机提供许可证。

有关脱机分析的更多详细信息，请参见：

  • 分析 16700 系列逻辑分析仪数据
  • 逻辑分析仪上的脱机分析
  • 个人计算机上的脱机分析
  • 返回联机分析

另请参见

  • 脱机文件格式


分析 16700 系列逻辑分析仪数据

在使用 Agilent Logic Analyzer 应用程序分析 16700 系列逻辑分析仪数据之前，您必须使用 File Out（文件输出）工具以快速二进制输出格式保存测量数据。

以下示例显示了要使用的一般过程。请参考 16700 系列逻辑分析系统联机帮助以获取所有特定信息。

  1. 配置 16700 系列逻辑分析仪以采集所需数据。

  2. 连接 File Out（文件输出）工具。

    为脱机分析载入的数据必须显示为一个数据集。双机测量的数据（例如，当使用 Pentium 4 处理器处理数据时）必须在保存为快速二进制输出数据之前进行合并；换句话说，两台计算机必须使用相同的 File Out（文件输出）工具。

  3. 配置 File Out（文件输出）工具，以快速二进制输出格式保存测量数据。

    要获得更强的搜索性能，可通过使用部分快速二进制输出选项来限制快速二进制数据文件的大小。

    NOTE:

    如果您希望 File Out（文件输出）工具将快速二进制输出文件直接保存到共享驱动器，请确保配置所有 LAN 连接以使文件共享。

  4. 运行 16700 系列逻辑分析仪以采集数据。

  5. 将快速二进制数据文件复制到个人计算机的本地硬盘或运行有 Agilent Logic Analyzer 应用程序的逻辑分析仪中。

    当快速二进制数据文件位于本地硬盘上时，Agilent Logic Analyzer 应用程序的性能比文件位于网络上时更强。

  6. 在 Agilent Logic Analyzer 应用程序中，使用 File（文件）> Import（导入）... 命令以从快速二进制数据文件导入。

更多 16700 注意事项

  • 仅以快速二进制输出格式保存总线/信号名称和测量数据。

  • 在 Agilent Logic Analyzer 应用程序中查看时，16700 盒和位关联是折叠的。

  • 导入快速二进制数据文件后，您不能使用 Bus/Signal Setup（总线/信号设置）对话框添加新的总线/信号名称或更改导入的总线/信号名称的指定通道。但是，您可以更改总线/信号极性、重命名或删除总线/信号以及添加注释。

  • 由于 16700 系列逻辑分析仪采样模式选项不能用于设置 1680/1690 系列或 16900 系列逻辑分析仪，因此 Timing/State Sampling Mode Setup（定时/状态采样模式设置）对话框不可用。

另请参见

  • 脱机分析中 16700 盒/位的关联


脱机分析中 16700 盒与位的关联

脱机分析应用程序将以不同方式显示 16700 盒与位的关联。对于任意给定的总线/信号，16700 界面中所有盒范围内的所有指定位将转换为顺序排列的盒下的顺序排列的位，从盒 1 开始。


逻辑分析仪上的脱机分析

通常，您可以使用 1680/1690 系列逻辑分析仪或 16900 系列逻辑分析系统执行脱机分析，方法是：运行第二个 Agilent Logic Analyzer 应用程序实例，然后将先前保存的数据载入该实例。通过运行该应用程序的两个实例，一个处于联机（本地 或远程）模式，另一个处于脱机 模式，您可以在一个实例中执行脱机分析的同时继续在另一实例中进行测量。

您可以对 16700 系列逻辑分析仪中保存的快速二进制数据文件和任何 1680/1690 系列逻辑分析仪或 16900 系列逻辑分析系统的配置文件（.ala 格式）执行脱机分析。

在使用逻辑分析仪或逻辑分析系统执行脱机分析时，请牢记以下内容：

  • 您可以启动多个 Agilent Logic Analyzer 应用程序实例。

    如果存在逻辑分析仪采集硬件，则第一个实例将在联机（本地 或远程）模式下打开。如果不存在采集硬件，则第一个实例将在脱机 模式下打开。

  • 逻辑分析仪运行功能无法在脱机 模式下使用。

  • 在脱机 模式下，您可以继续创建触发并将其保存在可由 Agilent Logic Analyzer 应用程序的其他实例打开的配置文件中。

  • 如果您将 167xx 快速二进制数据导入到 Agilent Logic Analyzer 应用程序的联机（本地 或远程）实例中，则该应用程序将自动切换到脱机 模式，所有硬件功能也都将自动关闭。

  • 如果在 Agilent Logic Analyzer 应用程序的联机（本地 或远程）实例中打开逻辑分析仪配置 (.ala) 文件进行脱机分析，则运行功能将覆盖已载入的数据。

NOTE:

要从共享磁盘驱动器中直接打开、复制文件或直接向其中保存文件，请确保将所有 LAN 连接都配置为启用文件共享。

另请参见

  • 打开配置文件
  • 导入 167xx 快速二进制数据
  • 保存配置文件


个人计算机上的脱机分析

一台安装有 Agilent Logic Analyzer 应用程序的个人计算机 (PC) 可对从 16700 系列逻辑分析仪保存的快速二进制数据文件和从任何 1680/1690 系列逻辑分析仪或 16900 系列逻辑分析系统保存的配置文件（.ala 格式）执行脱机分析。

当在 PC 上单独使用 Agilent Logic Analyzer 应用程序进行脱机分析时：

  • 逻辑分析仪运行功能不可用（因为没有采集硬件）。

  • 您可以将逻辑分析仪设置（包括触发序列）保存到 .ala 格式的配置文件中，并在个人计算机（运行 Agilent Logic Analyzer 应用程序）和其他 1680/1690 系列逻辑分析仪或 16900 系列逻辑分析系统之间传递这些文件。

  • 您可以同时运行多个 Agilent Logic Analyzer 应用程序实例。

  • 已获许可的工具要求运行这些工具的每台计算机具有许可证。

NOTE:

要从共享磁盘驱动器中直接打开、复制文件或直接向其中保存文件，请确保将所有 LAN 连接都配置为启用文件共享。

另请参见

  • 打开配置文件
  • 导入 167xx 快速二进制数据
  • 保存配置文件
  • 最低 PC 要求


最低 PC 要求

执行脱机分析的最低 PC 要求：1 GHz 处理器、512 M 内存

操作系统：Windows® XP/2000


返回联机分析

  1. 选择 File（文件）> Go Online（联机）菜单命令。

  2. 在 Select System to Use（选择要使用的系统）对话框中，选择要访问的系统；然后单击 Connect（连接）。

    逻辑分析系统可以是：

    • 本地的 — 连接到运行 Agilent Logic Analyzer 应用程序的同一计算机或逻辑分析仪。

    • 远程的 — 局域网上的其他地方。

  3. 如果正在连接的逻辑分析系统需要密码（请参见设置远程访问密码），请在 Please enter connection password:（请输入连接密码：）对话框中输入相应的密码，然后单击 OK（确定）。

有关使用 Select System to Use（选择要使用的系统）对话框的更多信息，请参见：

  • 将逻辑分析系统添加到列表
  • 从列表中删除逻辑分析系统
  • 刷新逻辑分析系统列表
  • 查看逻辑分析系统的详细信息
  • 输入“系统使用中”注释
  • 将逻辑分析系统设置为自动连接

另请参见

  • 脱机分析


将逻辑分析系统添加到列表

  1. 在 Select System to Use（选择要使用的系统）对话框（在选择 File（文件）> Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后会显示该对话框）中，单击 Add Remote System（添加远程系统）。

  2. 在该对话框中输入逻辑分析系统机架的主机名或 IP 地址，然后单击 OK（确定）。

另请参见

  • 返回联机分析


从列表中删除逻辑分析系统

  1. 在 Select System to Use（选择要使用的系统）对话框（在选择 File（文件）> Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后会显示该对话框）中，选择要删除的逻辑分析系统。

  2. 单击 Delete Remote System（删除远程系统）。

另请参见

  • 返回联机分析


刷新逻辑分析系统列表

  1. 在 Select System to Use（选择要使用的系统）对话框（在选择 File（文件）> Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后会显示该对话框）中，单击 Refresh（刷新）。

    逻辑分析系统的状态和详细信息被更新。其状态可能是：

    状态 说明

    Available（可用）

    Host offline（主机脱机）

    逻辑分析系统已断电或已断网。

    In use（使用中）

    "System In Use"（系统使用中）注释显示在括号中。

    Incompatible remote service version（远程服务版本不兼容）

    版本信息显示在括号中。逻辑分析系统机器上的 Agilent Logic Analyzer 应用软件需要升级，以便与显示此对话框的机器上所安装的软件的版本匹配。

另请参见

  • 返回联机分析


查看逻辑分析系统的详细信息

  1. 在 Select System to Use（选择要使用的系统）对话框（选择 File（文件）>Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后将会显示）中，选择您想要查看其详细信息的逻辑分析系统。

  2. 单击 Details on Local System（本地系统的详细信息）...或 Details on Selected Remote System（所选远程系统的详细信息）...。

    逻辑分析系统的详细信息将显示在 Frame/Module Information（机架/模块信息）对话框中。

另请参见

  • 返回联机分析


输入“系统使用中”注释

  1. 在 Select System to Use（选择要使用的系统）对话框（在选择 File（文件）> Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后会显示该对话框）中，选择要查看其详细信息的逻辑分析系统。

  2. 单击 Set "System in Use" Comments（设置“系统使用中”注释）。

  3. 在打开的对话框中输入“系统使用中”注释。

    这些注释通常包含联系信息。

另请参见

  • 返回联机分析


将逻辑分析系统设置为自动连接

  1. 在 Select System to Use（选择要使用的系统）对话框（在选择 File（文件）> Go Offline（脱机），然后选择 File（文件）> Go Online（联机）后会显示该对话框）中，选择要查看其详细信息的逻辑分析系统。

  2. 单击 Details on Local System（本地系统的详细信息）...或 Details on Selected Remote System（所选远程系统的详细信息）...。

  3. 在 Frame/Module Information（机架/模块信息）对话框中，单击 Set as Auto-Connect（设置为自动连接）。

另请参见

  • 返回联机分析


设置远程访问密码

通过 Agilent Logic Analyzer 应用程序可以连接到网络上的逻辑分析系统，也可以对网络上的逻辑分析系统进行远程控制。

若要限制远程机架与本地 16900 系列逻辑分析系统或 1680/1690 系列逻辑分析仪的连接，可以设置远程访问密码。

注意：

对于多机架逻辑分析系统，每个机架上的远程访问密码都必须是相同的。

在要限制远程连接的逻辑分析系统上：

  1. 从 Windows“开始”菜单处选择开始 > 程序 > Agilent Logic Analyzer > Utilities（实用工具）> Remote Access Password Utility（远程访问密码实用工具）。

    （也可以通过单击 Select System to Use（选择要使用的系统）对话框中的 Password Protect Local System from Remote Connections（本地系统的远程连接密码保护）来运行此实用工具。）

  2. 在 Remote Access Password Utility（远程访问密码实用工具）对话框中，如果当前已有密码，请单击 Clear Password（清除密码）。

  3. 在 Enter New Password（输入新密码）和 Re-enter New Password（重新输入新密码）域中输入新密码；然后单击 Set Password（设置密码）。

  4. 单击 OK（确定），完成密码更改并关闭对话框。

    密码更改会立即生效；但它们不影响当前已连接到本地机架的用户。

    单击 Cancel（取消）可关闭对话框且不对密码作出更改。

请注意：

  • 远程访问密码与 Windows 用户登录密码是完全不相关的。设置或清除远程访问密码不会影响 Windows 用户登录密码。

  • 远程访问密码是使用单向加密算法加密的，其存储是安全的。

  • 要使用此实用工具设置或清除远程访问密码，当前已登录用户必须具有管理凭证（管理员帐户）。

  • 这种创建远程访问密码的方式不会对通过 Windows Remote Desktop 进行的访问进行密码保护。

另请参见

  • 返回联机分析


脱机文件格式

.ala 格式

可以打开逻辑分析仪配置文件（扩展名为 .ala）来进行脱机分析。这些文件是由 Agilent Logic Analyzer 应用程序保存的。

逻辑分析仪配置 (.ala) 文件格式是 Agilent Logic Analyzer 应用程序用于保存和重新打开设置和数据的一种内部格式。ALA 格式的配置文件包含恢复会话所需要的全部数据（即，重新构建显示外观、仪器设置及采集的数据（可选）的必要信息）。

.xml 格式

在导入快速二进制数据格式文件进行脱机分析时，可以使用通用配置文件（扩展名为 .xml）来设置逻辑分析系统配置。XML 格式的配置文件是由 Agilent Logic Analyzer 应用程序保存的。

通用配置 (.xml) 文件格式是一种可扩展标记语言 (Extensible Markup Language) 格式，可用 ASCII 文本编辑器编辑，用脚本（或其他工具）进行后处理，以及用 Agilent Logic Analyzer 应用程序重新打开。这些文件包含总线/信号、分配给总线/信号的通道和用户定义的符号。

快速二进制数据格式

可以导入快速二进制数据格式文件（没有常用的文件扩展名）来进行脱机分析。这些文件是使用文件输出(File Out) 工具在 16700 系列逻辑分析系统上创建的。这些文件包含来自 16700 系列逻辑分析仪的总线/信号和数据。

CSV 格式

可以将采集的数据导出到 CSV（逗号分隔值）格式文件（扩展名为 .csv），以便在其他应用程序（如 Excel）中进行脱机分析。这些文件包含总线/信号和数据。


分析波形数据

Waveform（波形）窗口以数字波形的形式显示采集的数据。可以配置该窗口，以便在所选总线和信号的数据中显示时间或码型标记。还可以配置总线码型触发和信号触发选项。

通过菜单栏的 Window（窗口）> Waveform（波形）访问 Waveform（波形）窗口。如果已开启 Tabbed Windows（选项卡式窗口），也可以选择窗口底部的选项卡。

  • 更改显示刻度（时间/段)
  • 转至采集数据中的不同位置
  • 重排波形
  • 重叠波形
  • 查找总线/信号行
  • 以图表的形式查看总线数据
  • 显示/隐藏部分波形显示
  • 插入或删除总线/信号
  • 将信号分组并放入总线
  • 展开/折叠总线
  • 更改 Waveform（波形）窗口属性
    • 更改波形背景颜色
    • 更改重叠波形的颜色
    • 更改过滤掉的数据的颜色
    • 更改时序放大背景颜色
    • 更改波形字体大小
    • 更改 Fast Zoom In（快速放大）选项
    • 锁定显示窗口以实现同时滚动
    • 更改波形的工具提示显示内容
  • 更改总线/信号行属性
    • 更改波形的颜色
    • 更改波形的高度
    • 更改总线/信号的数基
    • 显示/隐藏总线/信号的数字数值
  • 更改模拟信号行属性
    • 更改模拟属性

另请参见

  • 定义总线和信号
  • 设置快速（绘制方框）触发
  • 指定简单触发
  • 标记数据点并在数据点之间进行测量
  • 设置符号
  • 显示总线/信号值的名称（符号）
  • 搜索采集的数据


更改显示刻度（时间/段)

Waveform（波形）窗口显示数据的方式与示波器类似，即，在水平时间轴上显示波形。因此，若要缩小或放大波形，只需更改查看波形时使用的时间轴刻度（时间/段）即可。

通过单击缩小/放大按钮更改刻度

  1. 单击缩小/放大按钮可增加/缩短刻度（时间/段）。

    刻度范围为 1 ps/div 至 1 ks/div。

    此外，也可以通过在 Scale（刻度）域中输入数字值更改“时间/段”。

通过在数据中拖制矩形进行放大

  1. 将鼠标移至要查看的区域的左上角，单击并按住鼠标移至右下角，然后放开鼠标按键。

  2. 如果未选择 Fast Zoom In（快速放大）选项，请在弹出菜单中选择 Zoom In（放大）。

    新的显示刻度便会调整为所制矩形框的宽度。

按沿居中

  1. 将鼠标光标移至波形上，置于要作为居中显示基准的沿之间。

  2. 右键单击并选择 Center About（居中基准）> Edges（沿）。

    新的显示刻度便会调整为波形沿的宽度。


转至采集数据中的不同位置

在 Waveform（波形）显示窗口中，可通过以下方式转至采集数据中的不同位置：使用水平滚动条、使用 Delay（延迟）域和按钮、从弹出菜单中选择 Go To（转至）命令。

通过更改延迟转至不同位置

  1. 单击 Delay（延迟）域中的某个按钮，或输入延迟值。

    延迟相对于波形数据调整显示窗口。显示窗口的时间相对位置取决于触发点及数据的起点和终点。使用以下延迟控件可以将窗口置于所需数据处。

    使用键盘输入数字值。如果输入的值大于或小于数据范围的时间，窗口将移至起点或终点限值处。

    移动窗口以显示数据开头。

    向数据开头位置滚动窗口。

    移动窗口以显示触发点。

    向数据结尾位置滚动窗口。

    移动窗口以显示数据结尾。

使用弹出菜单转至不同位置

  1. 右键单击波形显示区域，然后选择某个 Go To（转至）命令。

    或者，单击标记概览栏，然后选择某个 Go To（转至）命令。

    可以选择 Beginning Of Data（数据开头）、End Of Data（数据结尾）、Trigger（触发）、某一标记、某一 Time（时间）或某一 Sample（样本）。


重排波形

  1. 将鼠标指针定位在与要移动的波形关联的总线/信号名称上。

  2. 单击并按住鼠标键。

  3. 将该总线/信号拖放到新位置。

    该名称被放置在出现的红色位置指示符上边。

另请参见

  • 重叠波形
  • 展开/折叠总线


重叠波形

使用“重叠”功能可以将多个总线或信号放置到一行显示数据中。当多个信号重叠时，您可以直观地看到所有信号之间的关系。最先显示的是重叠的总线或信号，最后显示主总线/信号，它会覆盖重叠的总线/信号，从而清楚地显示出它们之间的关系。

  1. 右键单击要被另一个总线或信号覆盖的总线或信号，然后选择 Overlay（重叠）...。

  2. 从显示的 Overlay（重叠）选择对话框中选择要覆盖在选中的总线或信号之上的总线或信号。

    可以用数字信号或其他模拟信号来覆盖（来自外部示波器模块的）某个模拟信号。

    注意：

    第一个模拟信号的缩放比例会用于在它所在行上重叠的所有 信号；因此，如果使用用户定义的缩放比例和偏移值，则重叠的信号可能会看不见。使用自动缩放时，所有 重叠信号的最小和最大电压都会被考虑在内，并且所有信号都是可见的。

  3. 若要更改重叠的总线或数字信号的颜色，请参见更改重叠波形的颜色。

    当模拟信号重叠到其他信号上时，重叠信号的颜色取决于外部示波器模块的设置选项（可以通过右键单击该模拟信号的名称，选择 Assign Channels（分配通道）...，然后选择 Options（选项）选项卡来访问），而不是 Waveform（波形）窗口的重叠颜色设置。


查找总线/信号行

当 Waveform（波形）显示窗口中有许多总线/信号行时，可以搜索某一总线/信号行，而不必逐行滚动。

  1. 在 Waveform（波形）显示窗口中，右键单击任一总线/信号列标题，并选择 Find Bus/Signal（查找总线/信号）...。

  2. 在 Find Bus/Signal（查找总线/信号）对话框中，输入要查找的总线/信号的名称（或名称的一部分）。

  3. 然后单击：

    • Prev（上一个）— 在总线/信号行中往回搜索该字符串。

    • Next（下一个）— 在总线/信号行中往前搜索该字符串。

    • Close（关闭）— 关闭 Find Bus/Signal（查找总线/信号）对话框。


以图表的形式查看总线数据

您可以以图表的形式而非常规的总线形状来查看总线数据值。

  1. 在 Waveform（波形）显示窗口中，右键单击总线名称，并选择 View As Chart（以图表形式查看）...。

    或者，对于 Bus（总线）属性，在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，单击 View As（查看方式）...。

  2. 在 View As（查看方式）对话框中，设置以下选项：

    • Show Axis（显示轴）— 可在波形中心绘制一个很小的轴，该轴代表了显示的值的范围中心。选中此复选框时，您还可以更改轴的颜色。

    • Connect Samples（连接样本）— 可在样本之间绘制线。

    • Lock to Setup（锁定设置）— 根据总线的宽度设置范围限制。例如，将一个 8 位总线的范围设置为 0-255。

    • Max/Min（最大值/最小值）— 设置显示的轴的范围限制。

    • Show Clipped（显示已略内容）— 以用户自定义颜色显示范围以外的数据值。

注意：

由于没有使用硬件加速图表绘制，所以绘制带有图表的波形窗口速度会很慢。您可以将以图表形式查看的总线放入一个单独的波形窗口中。

以总线形式查看总线数据

您可以将总线波形外观返回到常规的总线形状。

  1. 在 Waveform（波形）显示窗口中，右键单击总线名称，然后选择 View As Bus（以总线形式查看）...。

    或者，对于 Bus（总线）属性，在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，单击 View As（查看方式）...。

  2. 在 View As（查看）对话框中，根据需要选中或取消选中以下选项：

    • MSB Ordering（MSB 排序）— 总线中信号的排序将由第一位为最不重要位变为最重要位。

    • Expand into signals（扩展到信号）— 将总线扩展到单独的信号（就好像选择 Expand (+) 字段到总线名称左边。）

另请参见

  • 更改总线/信号行属性


显示/隐藏部分波形显示

  1. 右键单击波形显示的 Bus/Signal（总线/信号）列，然后选择 Display（显示）>。

    然后，选择或取消选择以下选项之一来显示或隐藏部分 Waveform（波形）显示窗口：

    • Activity Indicators（活动指示符）— 下划线（低电平）、上划线（高电平）或跳变箭头（跳变信号）显示在总线/信号名称的左侧。

    • Simple Trigger（简单触发）— Simple Trigger（简单触发）列。

    • Markers（标记）— 标记显示栏。

    • Time Axis（时间轴）— 时间轴（和列标题）。

    您还可以在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡的 Display Options（显示选项）区域中选择这些选项。

另请参见

  • 更改 Waveform（波形）窗口属性


插入或删除总线/信号

插入总线/信号

  1. 在 Waveform（波形）显示窗口中，右键单击某个总线/信号列；然后选择 Insert Row（插入行）...。

  2. 在 Insert（插入）对话框中选择要插入的总线/信号，然后单击 OK（确定）。

删除选择的总线/信号

  1. 在 Bus/Signal（总线/信号）列中，（通过单击、按住 Shift 单击或按住 Ctrl 单击总线/信号名称）选中要删除的总线/信号。

  2. 右键单击 Bus/Signal（总线/信号）列；然后选择 Delete（删除）> Row（行）...。

删除所有总线/信号

  1. 右键单击 Bus/Signal（总线/信号）列；然后选择 Delete（删除）> All Row（所有行）...。

另请参见

  • 定义总线和信号


将信号分组并放入总线

  1. 按下 shift 键的同时，单击所有要放入总线的信号。

  2. 将鼠标指针放在任一选中的信号之上，右键单击并选择 Group into Bus（分组放入总线）。


展开/折叠总线

在 Waveform（波形）显示窗口的总线/信号列中：

  • 单击与某一总线关联的 + 或 - 符号。

  • 右键单击该总线，并选择 Expand（展开）或 Collapse（折叠）。

另请参见

  • 定义总线和信号


更改 Waveform（波形）窗口属性

您可以更改影响整个 Waveform（波形）显示窗口的属性。

  1. 右键单击波形显示的空白区域，然后选择 Properties（属性）...。

    或者，在不选择总线/信号名称的情况下，从主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中：

    可以执行以下操作：

    • 更改波形背景颜色
    • 更改重叠波形的颜色
    • 更改过滤掉的数据的颜色
    • 更改时序放大背景颜色
    • 更改波形字体大小
    • 更改 Fast Zoom In（快速放大）选项
    • 锁定显示窗口以实现同时滚动
    • 更改波形的工具提示显示内容
    • 显示/隐藏部分波形显示

  3. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改总线/信号行属性


更改波形背景颜色

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，选择 Background（背景）颜色，单击选择按钮，并从调色板中选择所需的背景颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改重叠波形的颜色

当总线/信号有重叠时（请参见重叠波形），重叠属性可指定重叠波形的颜色。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，选择 Overlay（重叠）颜色，单击选择按钮，并从调色板中选择所需的重叠波形颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改过滤掉的数据的颜色

在使用过滤工具将数据隐藏在 Waveform（波形）显示窗口之外时，隐藏数据的位置会出现交叉阴影；过滤属性用于指定交叉阴影区的颜色。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，选择 Filter（过滤）颜色，单击选择按钮，并从调色板中选择所需的过滤颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改时序放大背景颜色

可以为由时序放大功能产生的波形指定一种不同于其他波形的背景颜色。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，选择 TimingZoom（时序放大）颜色，单击选择按钮，并从调色板中选择所需的时序放大背景颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改波形字体大小

字体大小属性用于调整数据显示、总线/信号和简单触发文本的大小。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，输入所需的 Font Size（字体大小）：

    字体大小的变化范围为 6 磅到 72 磅。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

字体大小改变时，行高度可以自动增大以适应新的文本大小。

另请参见

  • 更改 Waveform（波形）窗口属性


更改 Fast Zoom In（快速放大）选项

当选中 Fast Zoom In（快速放大）选项时，您可以在要放大的区域上拖动鼠标光标，然后再放开鼠标键，通过这种方式放大该区域，而无需从弹出菜单中选择 Zoom In（放大）。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，选择或取消选择 Fast Zoom In（快速放大）选项。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改显示刻度（时间/段)
  • 在 Waveform（波形）窗口中设置快速触发
  • 快速查找总线信号码型


锁定显示窗口以实现同时滚动

可以锁定显示窗口（如波形窗口、列表窗口、比较窗口等），以便当一个窗口滚动时其他窗口也随之滚动，这样在每个显示窗口中相同的时间会同时显示在中心位置。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡中，单击 Lockstep Windows（同步窗口）...。

  2. 在 Lockstep Windows（同步窗口）对话框中，选择应与此窗口保持滚动锁定的显示窗口，并指定相对于此窗口的偏移量。

  3. 单击 OK（确定），关闭 Lockstep Windows（同步窗口）对话框。

  4. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改波形的工具提示显示内容

当鼠标指针在某一波形上静止停留一秒钟时，就会出现工具提示（即带有文本的小框）。

  1. 在 Waveform Properties（波形属性）对话框的 Window Properties（窗口属性）选项卡的 Tool Tip（工具提示）区域，选中或取消选中 Show Values（显示值），以指定是否以工具提示的方式显示总线/信号值。

    如果选中 Show Values（显示值），则选中或取消选中 Transition Width（跳变宽度）可以指定跳变（或脉冲）宽度值是否包含在工具提示中。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改总线/信号行属性

在 Waveform（波形）显示窗口中，可以更改波形的颜色或尺寸，还可以选择是否随波形显示数字值。

注意：

总线的属性更改将影响总线中的所有信号。例如，如果更改总线的颜色并将其展开，您会看到总线中所有信号的颜色均已更改。

在 Waveform（波形）窗口中更改波形的属性：

  1. 右键单击总线/信号名称或波形，然后选择 Properties（属性）...。

    或者，突出显示希望更改其属性的总线/信号（方法是单击、按住 Shift 单击或按住 Ctrl 单击总线/信号的名称），然后在主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中：

    可以执行以下操作：

    • 选择要应用属性更改的 Bus/Signal（总线/信号）。可以选择：

      • 已分配的任意总线/信号的名称（请参见定义总线和信号）。
      • <all>（所有）总线/信号。
      • <selected>（所选）总线/信号（如果总线/信号列中有多个突出显示的项目）。
    • 更改波形的颜色
    • 更改波形的高度
    • 更改总线/信号的数基
    • 显示/隐藏总线/信号的数字数据值
    • 以图表或总线的形式查看总线数据

  3. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改波形的颜色

  1. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，单击 Color（颜色）选择按钮，并从调色板中选择所需的波形颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改总线/信号行属性
  • 更改模拟信号行属性


更改波形的高度

  1. 在 Waveform（波形）显示窗口的 Bus/Signal（总线/信号）列中，将鼠标指针定位在某一行分隔线上；然后，当鼠标指针变为调整大小指针时，拖动该行边框。

或者：

  1. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，输入以像素为单位的 Height（高度）值。

    最小行高由字体大小来设置（请参见更改波形字体大小）。最大行高为 1000 像素。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改总线/信号行属性
  • 更改模拟信号行属性


更改总线/信号的数基

当显示总线/信号的数字数据值（请参见显示/隐藏总线/信号的数字数据值）时，base（基）属性用于指定要用的数基。

  1. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，选择所需的数 Base（基）：

    • Binary（二进制）
    • Hex（十六进制）
    • Octal（八进制）
    • Decimal（十进制）
    • Signed Decimal（带符号的十进制）
    • Ascii
    • Symbol（符号）（请参见显示总线/信号值的名称（符号））

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改总线/信号行属性


显示/隐藏总线/信号的数字数值

您可以用波形显示数字数值（并指定其颜色）。

注意：

如果波形时间刻度很小，则“...”可能显示在数值中以表示如果展开刻度将显示更多的文本。

  1. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，选择或取消选择 Show Values（显示值）可以使用波形显示或隐藏数字数值。

    如果选择了 Show Values（显示值），单击颜色选择按钮并从调色板中选择所需的数值颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改总线/信号行属性
  • 更改模拟信号行属性


更改模拟信号行属性

在 Waveform（波形）显示窗口中，可以更改模拟信号波形的颜色或尺寸，还可以选择是否随波形显示电压和 volts/division（伏特/段）值。模拟信号来自外部示波器模块（请参见外部示波器的时间相关性和数据显示）。

在 Waveform（波形）窗口中更改模拟信号波形的属性：

  1. 右键单击模拟信号名称或波形，然后选择 Properties（属性）...。

    或者，突出显示希望更改其属性的模拟信号（方法是单击、按住 Shift 单击或按住 Ctrl 单击模拟信号的名称），然后在主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中：

    可以执行以下操作：

    • 选择要应用属性更改的 Bus/Signal（总线/信号）。可以选择：

      • 已分配的任意总线/信号的名称（请参见定义总线和信号）。
      • <all>（所有）总线/信号。
      • <selected>（所选）总线/信号（如果总线/信号列中有多个突出显示的项目）。
    • 更改波形的颜色
    • 更改波形的高度
    • 显示/隐藏信号的数字数据值
    • 更改模拟属性

  3. 单击 OK（确定），应用这些更改并关闭 Waveform Properties（波形属性）对话框。

另请参见

  • 更改 Waveform（波形）窗口属性


更改模拟属性

在 Waveform（波形）显示窗口中可以更改模拟信号的属性。

  1. 在 Waveform Properties（波形属性）对话框的 Row Properties（行属性）选项卡中，单击 Properties（属性）...，以查看 Analog（模拟）属性。

  2. 在 Analog Properties（模拟属性）对话框中，设置以下选项：

    • Scaling（缩放） — 可以选择 Automatic（自动）（自动设置电压刻度和偏移值）或 User Defined（用户定义）（能够设置自定义的电压刻度和偏移值）。注意不要让输入的刻度和偏移值导致波形移出显示区。

    • Grid Style/Color（网格样式/颜色） — 可以选择 None（无）、Axis（轴）（使轴线贯穿波形显示区的中心）或 Grid（网格）（按电压和时间刻度绘制网格线）。如果选择了轴或网格，则还可以指定其颜色。

    • Connect Samples（连接样本） — 指定是否在波形数据采样点之间绘制线条。

    • Show Clipped（显示剪切内容） — 以用户定义的颜色显示超出范围的数据值。

另请参见

  • 更改模拟信号行属性


分析列表数据

Listing（列表）窗口以状态列表的形式显示采集的数据。对该窗口进行配置，可以在若干列中显示选定的总线和信号。可以在列出的数据中插入时间或码型标记。还可以配置总线码型触发和信号触发选项。

Listing（列表）窗口是通过菜单栏的 Window（窗口）> Listing（列表）来访问的。如果已开启 Tabbed Windows（选项卡式窗口），也可以选择窗口底部的选项卡。

  • 转至采集数据中的不同位置
  • 重排总线/信号列
  • 查找总线/信号列
  • 显示/隐藏部分列表显示
  • 插入或删除总线/信号
  • 更改 Listing（列表）窗口属性
    • 更改列表背景颜色
    • 更改时序放大背景颜色
    • 更改列表字体大小
    • 锁定显示窗口以实现同时滚动
    • 显示/隐藏中心矩形
  • 更改总线/信号列属性
    • 更改总线/信号的数据颜色
    • 更改总线/信号列的宽度
    • 更改总线/信号列的对齐方式
    • 更改总线/信号的数基
    • 选择标记以显示相对于该标记的时间

另请参见

  • 定义总线和信号
  • 设置快速（绘制方框）触发
  • 指定简单触发
  • 标记数据点并在数据点之间进行测量
  • 设置符号
  • 显示总线/信号值的名称（符号）
  • 搜索采集的数据


转至采集数据中的不同位置

在 Listing（列表）显示窗口中，通过使用垂直滚动条，使用标准工具栏上的 Go To（转至）按钮，或从弹出菜单中选择 Go To（转至）命令，可以转至采集数据中的不同位置。

使用工具栏按钮转至不同位置

  1. 单击标准工具栏中的某一“转至”按钮。

    转至开头 － 使采集数据的开头居中显示。

    转至触发 — 使采集操作的触发点居中显示。

    转至结尾 — 使采集数据的结尾居中显示。

使用弹出菜单转至不同位置

  1. 右键单击波形显示区域，然后选择某个 Go To（转至）命令。

    或者，单击标记概览栏，然后选择某个 Go To（转至）命令。

    可以选择 Beginning Of Data（数据开头）、End Of Data（数据结尾）、Trigger（触发）、某一标记、某一 Time（时间）或某一 Sample（样本）。


重排总线/信号列

  1. 将鼠标指针定位在与要移动的列关联的总线/信号名称上。

  2. 单击并按住鼠标键。

  3. 将该总线/信号拖放到新位置。

    该名称被放置在出现的红色位置指示符左边。


查找总线/信号列

当 Listing（列表）显示窗口中有许多总线/信号列时，可以搜索某一总线/信号列，而不必逐列滚动。

  1. 在 Listing（列表）显示窗口中，右键单击任一总线/信号列标题，并选择 Find Bus/Signal（查找总线/信号）...。

  2. 在 Find Bus/Signal（查找总线/信号）对话框中，输入要查找的总线/信号的名称（或名称的一部分）。

  3. 然后单击：

    • Prev（上一个）— 在总线/信号列中往回搜索该字符串。

    • Next（下一个）— 在总线/信号列中往前搜索该字符串。

    • Close（关闭）— 关闭 Find Bus/Signal（查找总线/信号）对话框。


显示/隐藏部分列表显示

  1. 右键单击列表显示的 Bus/Signal（总线/信号）列标题，然后选择 Display（显示）>。

    然后，选择或取消选择以下选项之一来显示或隐藏部分 Listing（列表）显示窗口：

    • Activity Indicators（活动指示符）— 下划线（低电平）、上划线（高电平）或跳变箭头（跳变信号）显示在总线/信号名称的左侧。

    • Column Base（列基）— 列标题中的 number base（数基）行。

    • Simple Trigger（简单触发）— 列标题中的 Simple Trigger（简单触发）行（请参见指定简单触发）。

    • Markers（标记）— 标记显示栏。

    您还可以在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡的 Display Options（显示选项）区域中选择这些选项。

另请参见

  • 更改 Listing（列表）窗口属性


插入或删除总线/信号

插入总线/信号

  1. 在 Listing（列表）显示窗口中，右键单击总线/信号列的标题，然后选择 Insert Column（插入列）。

  2. 在 Insert（插入）对话框中选择要插入的总线/信号，然后单击 OK（确定）。

删除选择的总线/信号

  1. 突出显示要删除的总线/信号列的标题（方法是单击、按住 Shift 单击或按住 Ctrl 单击总线/信号的名称）。

  2. 右键单击列标题行的空白区域，然后选择 Delete（删除）> Column（列）。

删除所有总线/信号

  1. 右键单击列标题行中的任意位置，然后选择 Delete（删除）> All Columns（所有列）。

另请参见

  • 定义总线和信号


更改 Listing（列表）窗口属性

您可以更改影响整个Listing（列表）显示窗口的属性。

  1. 右键单击列表显示的空白区域，然后选择 Properties（属性）...。

    或者，在不选择总线/信号名称的情况下，从主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡中：

    可以执行以下操作：

    • 更改列表背景颜色
    • 更改时序放大背景颜色
    • 更改列表字体大小
    • 锁定显示窗口以实现同时滚动
    • 显示/隐藏中心矩形
    • 显示/隐藏部分列表显示

  3. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


更改列表背景颜色

  1. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡中，单击 Background（背景）颜色选择按钮，并从调色板中选择所需的背景颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性


更改时序放大背景颜色

在 Listing（列表）显示窗口中，可以为由时序放大功能产生的列指定一种不同于总线/信号数据列的背景颜色。

  1. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡中，单击 TimingZoom（时序放大）颜色选择按钮，并从调色板中选择所需的时序放大背景颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性


更改列表字体大小

字体大小属性用于调整数据显示、总线/信号和简单触发文本的大小。

  1. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡中，输入所需的 Font Size（字体大小）：

    字体大小的变化范围为 6 磅到 72 磅。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

字体大小改变时，列宽可以自动增大以适应新的文本大小。

另请参见

  • 更改 Listing（列表）窗口属性


锁定显示窗口以实现同时滚动

可以锁定显示窗口（如波形窗口、列表窗口、比较窗口等），以便当一个窗口滚动时其他窗口也随之滚动，这样在每个显示窗口中相同的时间会同时显示在中心位置。

  1. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡中，单击 Lockstep Windows（同步窗口）...。

  2. 在 Lockstep Windows（同步窗口）对话框中，选择应与此窗口保持滚动锁定的显示窗口，并指定相对于此窗口的偏移量。

  3. 单击 OK（确定），关闭 Lockstep Windows（同步窗口）对话框。

  4. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性


显示/隐藏中心矩形

中心矩形是围绕屏幕中心显示的样本而绘制的方框。

  1. 在 Listing Properties（列表属性）对话框的 Window Properties（窗口属性）选项卡的 Center Rectangle（中心矩形）区域中，选择或取消选择 Display Rectangle（显示矩形）以指定显示或隐藏中心矩形。

    如果选择了 Display Rectangle（显示矩形），单击颜色选择按钮并从调色板中选择所需的中心矩形颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性


更改总线/信号列属性

在 Listing（列表）显示窗口中，可以更改总线/信号数据列的颜色、宽度、对齐方式或数基。

在 Listing（列表）窗口中更改总线/信号数据列的属性：

  1. 右键单击总线/信号名称或波形，然后选择 Properties（属性）...。

    或者，突出显示希望更改其属性的总线/信号（方法是单击、按住 Shift 单击或按住 Ctrl 单击总线/信号的名称），然后在主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中：

    可以执行以下操作：

    • 选择要应用属性更改的 Bus/Signal（总线/信号）。可以选择：

      • 已分配的任意总线/信号的名称（请参见定义总线和信号）。
      • <all>（所有）总线/信号。
      • <selected>（所选）总线/信号（如果有多个突出显示的列）。
    • 更改总线/信号的数据颜色
    • 更改总线/信号列的宽度
    • 更改总线/信号列的对齐方式
    • 更改总线/信号的数基
    • 选择标记以显示相对于该标记的时间

  3. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性


更改总线/信号的数据颜色

  1. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中，单击 Color（颜色）选择按钮，并从调色板中选择所需的总线/信号数据颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


更改总线/信号列的宽度

提示：

提示：可以自动调整各列的大小，方法是：将鼠标指针置于列标题框的右边框上；然后，当指针图标变为调整大小指针时双击鼠标。

提示：

提示：如果键盘上有数字小键盘，则可以自动调整所有列的大小，方法是：选中任一列标题框（使之高亮显示）并按 Ctrl 和数字小键盘上的 +。

  1. 在Listing（列表）显示窗口的总线/信号标题行中，将鼠标指针定位在某一列分隔线上；然后，当鼠标指针变为调整大小指针时，拖动该列边框。

或者：

  1. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中，输入以像素为单位的 Width（宽度）值。

    最小列宽为 1 像素，最大列宽为 1000 像素。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


更改总线/信号列的对齐方式

Alignment（对齐）属性用于设置数据在列中的显示方式：居左、居右或居中。

  1. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中，选择 Alignment（对齐方式）：

    • Left（居左）
    • Center（居中）
    • Right（居右）

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


更改总线/信号的数基

Base（基）属性用于指定显示采集的数据时要用的数基。

  1. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中，选择所需的数 Base（基）：

    • Binary（二进制）
    • Hex（十六进制）
    • Octal（八进制）
    • Decimal（十进制）
    • Signed Decimal（带符号的十进制）
    • Ascii
    • Symbol（符号）（请参见显示总线/信号值的名称（符号））

    注意：

    如果选择的是 Time（时间）列而不是数据列，可以选择的选项值将从数字格式变为 Absolute（绝对）、Relative Previous（相对上一个）或 Relative Marker（相对标记）。

    注意：

    如果选择的是来自外部示波器模块（请参见外部示波器的时间关联和数据显示）列的模拟信号而不是数据列，则只能为数基选择 Voltage（电压）。

  2. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


选择标记以显示相对于该标记的时间

在 Listing（列表）窗口中，可以显示相对于标记的时间。

  1. 在 Listing Properties（列表属性）对话框的 Column Properties（列属性）选项卡中，通过选择 Bus/Signal（总线/信号）选择 Time（时间）列。

  2. 对于 Base（基）属性，选择 Relative Marker（相对标记）。

  3. 对于 Marker（标记）属性，选择一个标记，以显示相对于该标记的时间。

  4. 单击 OK（确定），应用这些更改并关闭 Listing Properties（列表属性）对话框。

另请参见

  • 更改总线/信号列属性


显示总线/信号值的名称（符号）

可以使用代表一定含义的名称（而非数字值）显示总线或信号。

符号可以在 Waveform（波形）、Listing（列表）、Compare（比较）和 Source（源代码）窗口中显示。

显示符号：

  1. 设置符号。

  2. 将总线或信号的数基更改为符号。

如果将符号定义为某个范围，该范围内的值将以范围下限值作为偏移量来显示。

如果多个符号的定义发生重叠，Symbols（符号）对话框中列出的第一个符号将具有最高优先级。

在 Waveform（波形）显示窗口中，如果可用的显示空间无法显示符号全名，则会显示“...”。

设置符号后，通常应保存逻辑分析仪的配置。符号定义将作为配置的一部分来存储。

示例

下面是未定义任何符号时“My Bus 1”的显示形式：

定义符号后，它们在 Symbols（符号）对话框中的显示如下：

下面是定义符号后总线的显示形式：


标记数据点并在数据点之间进行测量

创建标记后，当测量间隔或查看标记处的数值时您可以将其用作数据中的参考点。

  • 读取标记显示栏和概览栏
  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 居中显示标记对
  • 更改标记的对齐沿设置
  • 删除标记
  • 创建新的时间间隔测量
  • 创建新的采样间隔测量
  • 创建新的定点值测量
  • 重命名标记
  • 将标记移到后面
  • 更改标记属性
    • 更改标记的背景颜色
    • 更改标记的前景颜色
    • 隐藏/显示标记
    • 更改标记的查看器锁定设置
    • 相对另一个标记锁定某一标记
    • 向标记添加注释
  • （在波形显示中）对模拟信号使用电压标记
    • 创建新的电压标记
    • 放置电压标记
    • 删除电压标记
    • 创建新的电压间隔测量
    • 重命名电压标记
    • 将电压标记移到后面
    • 更改电压标记属性

另请参见

  • 标记显示栏
  • 标记测量显示栏
  • Markers（标记）菜单
  • 标记工具栏


读取标记显示栏和概览栏

在上方的标记显示栏中，标记是彩色的，并且带有指向标记相对于所显示数据的位置的箭头。

在下方的标记概览栏中，标记显示为彩色条，它显示了标记相对于所采集的整个数据集的位置。

在 Waveform（波形）窗口（如上图所示）中，标记显示栏和概览栏分别位于窗口的顶部和底部。在 Listing（列表）窗口中，标记显示栏和概览栏以类似的方式分别位于窗口的左侧和右侧。

提示：

提示：通过单击底部（波形）或右侧（列表）的标记概览栏并从弹出菜单中选择 Go To Here（转至此处），可以快速显示数据的不同区域。


创建新标记

创建新标记时，可以为其命名，指定它的颜色，指定它在数据中的位置，以及添加注释。最多可以创建 1024 个标记。

  1. 从菜单栏中，选择 Markers（标记）> New（新建）...。

  2. 在 New Marker（新建标记）对话框中输入标记名称。

    通过使用 Long name[abbreviated name] 语法，可以同时指定长名称 和缩写名称；如 Location A[A]。如果使用缩写名称，它会显示在标记显示栏中的相应标记上，而长名称则显示在该标记的工具提示 中。

  3. 选择标记的背景和前景颜色。

  4. 按以下方式指定新标记在数据中的位置：

    • Time（时间） － 按来自某一参考点的时间值来确定标记位置。参考点是指触发点、数据开头、数据结尾或另一个标记。

    • Sample（样本） － 按来自某一参考点的样本号来确定标记的位置。参考点是指触发点、数据开头、数据结尾或另一个标记。

    • Value（值） － 将标记放在出现某一总线/信号码型的位置。单击 Occurs（发生）...可以指定总线/信号码型值。

      总线/信号码型的指定与搜索采集的数据时的指定相同。

  5. 输入标记注释。

    注释显示在标记的工具提示 中。

  6. 单击 OK（确定）。

另请参见

  • 在数据中放置标记
  • 转至某一标记
  • 读取标记显示栏和概览栏
  • 居中显示标记对
  • 删除标记
  • 重命名标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


在数据中放置标记

使用 Place Marker（放置标记）可以在数据中快速放置标记。根据使用 Place Marker（放置标记）功能的方式，标记在数据中的放置方式会略有不同。还可以通过鼠标拖动的方式或使用面板旋钮来移动标记。

注意：

在拖放标记或在鼠标光标处放置标记时如果鼠标光标位于某一波形上，若是启用了 Snap to Edge（对齐沿）属性，则会影响标记在 Waveform（波形）窗口中的放置。
  • 在数据中拖放标记
  • 在鼠标光标处放置标记
  • 在屏幕中央放置标记
  • 更改标记的位置属性
  • 也可以在搜索到的数据所在的位置放置标记（请参见指定 found 标记的放置）。

在数据中拖放标记

可以使用拖放功能在数据中移动标记。

  1. 单击要移动的标记并按住鼠标键。

  2. 将鼠标光标移至另一位置。

    在 Waveform（波形）显示窗口中移动标记时，如果鼠标光标位于某一波形上并且启用了 Snap to Edge（对齐沿）属性，则光标会变成绿色的“方向箭头”，并指示下一个有效沿的方向。如果决定放开鼠标键，则要放置标记的沿上会出现一个黄色的“十字准线”标志。如果不想让标记对齐沿，可以在放开鼠标键以前将鼠标光标从波形上移开。

  3. 放开鼠标键，标记即移至另一位置。

在鼠标光标处放置标记

  1. 将鼠标指向显示屏中所需的数据点。

  2. 右键单击鼠标，选择 Place Marker（放置标记）> Time（时间）>（所需的标记）。

    如果鼠标光标位于某一波形上并且启用了该标记的 Snap to Edge（对齐沿）属性，则该标记会被放在最近的波形沿处；否则，该标记被放在鼠标光标位置。

在屏幕中央放置标记

  1. 从菜单栏依次单击 Markers（标记）> Place On Screen（在屏幕上放置）...。

  2. 在 Place Marker（放置标记）对话框中，选择所需的标记。

    单击 Name（名称）、Position（位置）或 Comment（注释）列标题，可对标记列表进行排序。

  3. 单击 OK（确定）。

    标记将被放在屏幕中央。

更改标记的位置属性

  1. 右键单击某一标记，并选择 Properties（属性）...。

    或者，在查看包含标记的显示窗口时从主菜单选择 Markers（标记）> Properties（属性）...。

  2. 在显示窗口属性对话框的 Time Marker Properties（时间标记属性）选项卡中，选择要更改位置属性的 Marker（标记）。

  3. 在 Position（位置）框中选择标记的定位方式：

    • Time（时间） － 按来自某一参考点的时间值来确定标记位置。参考点是指触发点、数据开头、数据结尾或另一个标记。

    • Sample（样本） － 按来自某一参考点的样本号来确定标记的位置。参考点是指触发点、数据开头、数据结尾或另一个标记。

    • Value（值） － 将标记放在出现某一总线/信号码型的位置。单击 Occurs（发生）...可以指定总线/信号码型值。

      总线/信号码型的指定与搜索采集的数据时的指定大致相同，只是这里可以通过单击 Properties（属性）...来打开 Value Properties（值属性）对话框。在 Value Properties（值属性）对话框中：

      • 若要在找到（或未找到）指定的总线/信号码型时停止重复运行，请选中 Stop repetitive run（停止重复运行）。

      • 若要在找到（或未找到）指定的总线/信号码型时发送电子邮件，请选中 Send e-mail（发送电子邮件）；然后单击 E-mail（电子邮件）...按钮。在 E-mail（电子邮件）对话框中，输入电子邮件的接收地址、主题和消息文本。

  4. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 指定 found 标记的放置（在找到数据的地方放置标记）
  • 创建新标记
  • 转至某一标记
  • 读取标记显示栏和概览栏
  • 居中显示标记对
  • 删除标记
  • 重命名标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


转至某一标记

要在数据中快速找到以前设置的标记，或者要转至数据开头、数据结尾或触发点，请：

  • 单击标记显示栏或标记概览栏，然后从弹出菜单中选择 Go To（转至）。

或者：

  1. 从菜单栏中，选择 Markers（标记）> Go To（转至）...，或选择标记工具栏中的 [image] 图标。

  2. 在 Go To Marker（转至标记）对话框中，选择要从提供的列表中查找的标记。

    单击 Name（名称）、Position（位置）或 Comment（注释）列标题，可对标记列表进行排序。

  3. 单击 OK（确定）。

选择的标记出现在显示屏的中央。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 居中显示标记对
  • 删除标记
  • 重命名标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


居中显示标记对

使用居中功能可以居中显示选定的标记对。如果该标记对之间有很长的时间或很多样本，则显示尺寸会自动变大，以使两个标记都显示在屏幕上。

居中功能可以居中显示一对（两个）标记，因此，如果定义了三个或更多的标记，则可以选择任何可能的标记对组合来居中显示。

  1. 从菜单栏中，选择 Markers（标记）> Center About（居中）...。

  2. 在 Center About（居中）对话框中，选择所需的标记组合。

  3. 单击 OK（确定）。

    这两个标记之间的数据显示出来。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 删除标记
  • 重命名标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


更改标记的对齐沿设置

  1. 在带有标记的显示窗口中右键单击标记，并选择 Snap to Edge（对齐沿）。

    或者，在该显示窗口属性对话框的 Time Marker Properties（时间标记属性）选项卡中，选中或取消选中 Snap to Edge（对齐沿），以启用或禁用标记的对齐沿行为。

另请参见

  • 在数据中放置标记
  • 更改标记属性


删除标记

  • 在标记显示栏中，单击要删除的标记，然后从弹出菜单中选择 Delete（删除）（选择 Delete All（全部删除）可以删除所有标记）。

或者：

  1. 从菜单栏中，选择 Markers（标记）> Delete（删除）...。

  2. 在 Delete Marker（删除标记）对话框中，选择要删除的标记。

    单击 Name（名称）、Position（位置）或 Comment（注释）列标题，可对标记列表进行排序。

  3. 单击 OK（确定）。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 居中显示标记对
  • 重命名标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


创建新的时间间隔测量

使用新建时间间隔测量功能可以测定采集的数据中两个指定点之间的时间间隔。测量结果在标记测量显示栏中显示。

  1. 从菜单栏中，选择 Markers（标记）> New Time Interval Measurement（新建时间间隔测量），或者单击标记工具栏中的 [image] 图标。

  2. 在 Time Interval（时间间隔）对话框中，选择用于确定时间测量范围的首尾标记。

    注意：

    如果选择了 System Trigger - (module)（系统触发 -（模块））或 Trigger - (module)（触发 -（模块））标记，则一定要取消选中 Module Skew and System Trigger（模块偏移与系统触发）对话框中的 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）选项。否则，在运行期间，系统触发可能从一个模块切换到另一个模块，从而导致这些模块标记被重新分配以及使用这些标记的所有测量被删除。

  3. 要指定间隔属性，请单击 Properties（属性）...。

    在 Interval Properties（间隔属性）对话框中：

    • 若要在对指定的间隔值进行测量时停止某一重复运行，请单击 Stop repetitive run（停止重复运行）。

    • 若要在测量指定的间隔值时发送电子邮件，请选中 Send e-mail（发送电子邮件）；然后单击 E-mail（电子邮件）...按钮。在 E-mail（电子邮件）对话框中，输入电子邮件的接收地址、主题和消息文本。

    • 若要显示重复运行统计数据，请选中 Show statistics（显示统计数据）。

      小心：

      如果选择 System Trigger - (module)（系统触发 -（模块））或 Trigger - (module)（触发 -（模块））标记作为用于确定时间测量范围的标记中的一个，则一定要取消选中 Module Skew and System Trigger（模块偏移与系统触发）对话框中的 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）选项。否则，在重复运行期间，系统触发可能从一个模块切换到另一个模块，从而导致收集的所有统计数据丢失。

    • 若要显示测得的该时间间隔中的变更频率，请选中 Show as frequency（显示为频率）。

    • 间隔属性的指定完成后，单击 OK（确定）。

  4. 单击 OK（确定），关闭 Time Interval（时间间隔）对话框。

间隔测量的结果显示在标记测量显示栏中：

显示的统计数据中将包含间隔测量结果的低值、高值和平均值。

另请参见

  • 创建新的采样间隔测量
  • 创建新的定点值测量


创建新的采样间隔测量

使用新建采样间隔测量功能可以测定采集的数据中两个指定点之间的样本数。测量结果在标记测量显示栏中显示。

  1. 从菜单栏中，选择 Markers（标记）> New Sample Interval Measurement（新建采样间隔测量），或者单击标记工具栏中的 [image] 图标。

  2. 在 Sample Interval（采样间隔）对话框中，选择两个标记来确定样本测量范围，并选择总线/信号。

    注意：

    如果选择了 System Trigger - (module)（系统触发 -（模块））或 Trigger - (module)（触发 -（模块））标记，则一定要取消选中 Module Skew and System Trigger（模块偏移与系统触发）对话框中的 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）选项。否则，在运行期间，系统触发可能从一个模块切换到另一个模块，从而导致这些模块标记被重新分配以及使用这些标记的所有测量被删除。

  3. 要指定间隔属性，请单击 Properties（属性）...。

    在 Interval Properties（间隔属性）对话框中：

    • 若要在对指定的间隔值进行测量时停止某一重复运行，请单击 Stop repetitive run（停止重复运行）。

    • 若要在测量指定的间隔值时发送电子邮件，请选中 Send e-mail（发送电子邮件）；然后单击 E-mail（电子邮件）...按钮。在 E-mail（电子邮件）对话框中，输入电子邮件的接收地址、主题和消息文本。

    • 若要显示重复运行统计数据，请选中 Show statistics（显示统计数据）。

      小心：

      如果选择 System Trigger - (module)（系统触发 -（模块））或 Trigger - (module)（触发 -（模块））标记作为用于确定样本测量范围的标记中的一个，则一定要取消选中 Module Skew and System Trigger（模块偏移与系统触发）对话框中的 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）选项。否则，在重复运行期间，系统触发可能从一个模块切换到另一个模块，从而导致收集的所有统计数据丢失。

    • 间隔属性的指定完成后，单击 OK（确定）。

  4. 单击 OK（确定），关闭 Sample Interval（采样间隔）对话框。

间隔测量的结果显示在标记测量显示栏中：

显示的统计数据中将包含间隔测量结果的低值和高值。

另请参见

  • 创建新的时间间隔测量
  • 创建新的定点值测量


创建新的定点值测量

使用新建定点值测量功能可以测定采集的数据中某一指定标记位置的总线/信号值。测量结果在标记测量显示栏中显示。

  1. 从菜单栏中，选择 Markers（标记）> New Value At Measurement（新建定点值测量），或者单击标记工具栏中的 [image] 图标。

  2. 在 Value At（定点值）对话框中，选择数据数基、总线/信号和标记。

    注意：

    如果选择了 System Trigger - (module)（系统触发 -（模块））或 Trigger - (module)（触发 -（模块））标记，则一定要取消选中 Module Skew and System Trigger（模块偏移与系统触发）对话框中的 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）选项。否则，在运行期间，系统触发可能从一个模块切换到另一个模块，从而导致这些模块标记被重新分配以及使用这些标记的所有测量被删除。

  3. 单击 OK（确定）。

    定点值测量的结果 [image] 显示在标记测量显示栏中。

另请参见

  • 创建新的时间间隔测量
  • 创建新的采样间隔测量


重命名标记

可以为标记指定任何名称。

  1. 在带有标记的显示窗口中右键单击标记，并选择 Rename（重命名）。

    或者，在显示窗口属性对话框的 Time Marker Properties（时间标记属性）选项卡中选择 Marker（标记），并单击 Rename（重命名）。

  2. 在 Rename（重命名）对话框中输入新的标记名称。

    通过使用 Long name[abbreviated name] 语法，可以同时指定长名称 和缩写名称；如 Location A[A]。如果使用缩写名称，它会显示在标记显示栏中的相应标记上，而长名称则显示在该标记的工具提示 中。

  3. 单击 OK（确定）。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 居中显示标记对
  • 删除标记
  • 将标记移到后面
  • 更改标记的对齐沿设置
  • 更改标记属性


将标记移到后面

当显示的标记重叠时，可以将可见的标记移到后面，以便看到下面的标记。

  1. 单击想移到后面的标记，并从弹出菜单中选择 Send to Back（移到后面）。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 居中显示标记对
  • 删除标记
  • 重命名标记
  • 更改标记的对齐沿设置
  • 更改标记属性


更改标记属性

标记创建之后，可以从 Time Marker Properties（时间标记属性）选项卡中修改其任一属性。

  1. 右键单击某一标记，并选择 Properties（属性）...。

    或者，在查看包含标记的显示窗口时从主菜单选择 Markers（标记）> Properties（属性）...。

  2. 在显示窗口属性对话框的 Time Marker Properties（时间标记属性）选项卡中：

    可以执行以下操作：

    • 选择要更改属性的 Marker（标记）。
    • 重命名标记
    • 更改标记的背景颜色
    • 更改标记的前景颜色
    • 更改标记的位置属性
    • 隐藏/显示标记
    • 更改标记的查看器锁定设置
    • 相对另一个标记锁定某一标记
    • 更改标记的对齐沿设置
    • 向标记添加注释

  3. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 创建新标记
  • 在数据中放置标记
  • 转至某一标记
  • 居中显示标记对
  • 删除标记
  • 重命名标记
  • 将标记移到后面
  • 读取标记显示栏和概览栏


更改标记的背景颜色

  1. 在 Marker Properties（标记属性）选项卡中，单击 Background Color（背景颜色）选择按钮，并从调色板中选择所需的颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性
  • 更改电压标记属性


更改标记的前景颜色

  1. 在 Marker Properties（标记属性）选项卡中，单击 Foreground Color（前景颜色）选择按钮，并从调色板中选择所需的颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性
  • 更改电压标记属性


隐藏/显示标记

  1. 在 Marker Properties（标记属性）选项卡中，选中或取消选中 Hide（隐藏），以隐藏或显示标记。

    当标记隐藏时，它只是从显示视图中隐藏起来，除此以外的其他所有属性都会保留。

  2. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性
  • 更改电压标记属性


更改标记的查看器锁定设置

如果启用某标记的 Lock in Viewer（查看器锁定）设置时，当在一个显示窗口中移动或放置该标记时，其他显示窗口也会随之更新，这样该标记也会出现在其他显示窗口中。

注意：

查看器锁定的行为只有当在即时数据查看区中拖动标记时才适用。若是通过在 Time Markers Properties（时间标记属性）选项卡中定义新位置来移动某一标记，则在其他显示窗口中该标记不一定可见。

  1. 在 Time Marker Properties（时间标记属性）选项卡中，选中或取消选中 Lock in Viewer（查看器锁定），以启用或禁用该设置。

  2. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性


相对另一个标记锁定某一标记

当某一标记是相对另一标记进行定位并且启用了该标记的 Lock to Relative（锁定相对位置）设置时，移动或放置其中任一标记都会导致两个标记的移动，这样两个标记之间的时间就可以保持不变。两个标记必须都是可移动的。

  1. 在 Marker Properties（标记属性）选项卡的 Position（位置）框中：

    1. 选择 Time（时间）。
    2. 选择相对标记。
    3. 输入标记之间的相对时间。

  2. 选中或取消选中 Lock to Relative（锁定相对位置）以锁定或解除锁定相对的标记移动。

  3. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性


向标记添加注释

您可以给标记添加注释，该注释会出现在标记的工具提示 中。

  1. 在 Marker Properties（标记属性）选项卡的 Comments（注释）框中输入注释。

  2. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 更改标记属性
  • 更改电压标记属性


（在波形显示中）对模拟信号使用电压标记

当模拟信号被添加到 Waveform（波形）显示窗口（位于外部示波器模块中）中时，可以添加电压标记和电压区间测量。

  • 创建新的电压标记
  • 放置电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 将电压标记移到后面
  • 更改电压标记属性

另请参见

  • 外部示波器时间相关性和数据显示


创建新的电压标记

创建新的电压标记时，可以为其命名，指定它的颜色，指定它的位置，以及添加注释。

  1. 在模拟信号行的电压标记/纵轴刻度显示栏（在波形左边）中，单击（要放置新标记的位置）并选择 New（新建）...。

    或者，右键单击（要在其处放置新标记的）模拟信号波形并选择 Place Marker（放置标记）> Voltage（电压）> New Marker（新建标记）...。

  2. 在 New Voltage Marker（新建电压标记）对话框中输入标记名称。

    通过使用 Long name[abbreviated name] 语法，可以同时指定长名称 和缩写名称；如 Location A[A]。如果使用缩写名称，它会显示在电压标记显示栏中的相应标记上，而长名称则显示在该标记的工具提示 中。

  3. 选择标记的背景和前景颜色。

  4. 通过指定新电压标记相对于地或另一个电压标记的电压来指定其位置。

  5. 输入该电压标记的注释。

    注释显示在标记的工具提示 中。

  6. 单击 OK（确定）。

另请参见

  • 放置电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 将电压标记移到后面
  • 更改电压标记属性


放置电压标记

使用 Place Marker（放置标记）可以快速放置电压标记。根据使用 Place Marker（放置标记）功能的方式，标记在数据中的放置方式会略有不同。还可以通过鼠标拖动的方式或使用面板旋钮来移动标记。当电压标记与时间标记相交时，可以同时拖动两个标记。

  • 拖放电压标记
  • 在鼠标光标处放置电压标记
  • 更改电压标记的位置属性

拖放电压标记

使用拖放功能可以在数据中移动电压标记。

  1. 单击要移动的标记并按住鼠标键。

  2. 将鼠标光标移至另一位置。

  3. 放开鼠标键，标记即移至另一位置。

在鼠标光标处放置电压标记

  1. 将鼠标指向显示屏中所需的数据点。

  2. 右键单击鼠标，选择 Place Marker（放置标记）> Voltage（电压）>（所需的标记）。

更改电压标记的位置属性

  1. 右键单击某一电压标记，并选择 Properties（属性）...。

    或者，在查看包含电压标记的显示窗口时从主菜单选择 Markers（标记）> Properties（属性）...。

  2. 在 Waveform Properties（波形属性）对话框的 Voltage Marker Properties（电压标记属性）选项卡上，选择要更改位置属性的 Marker（标记）。

  3. 在 Position（位置）框中，通过该标记相对于地或另一个电压标记的电压指定该标记的位置。

  4. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 创建新的电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 将电压标记移到后面
  • 更改电压标记属性


删除电压标记

  • 在模拟信号的电压标记/纵轴刻度显示栏（在波形左边）中，单击要删除的电压标记，并从弹出菜单中选择 Delete（删除）（或选择 Delete All（全部删除），删除所有电压标记）。

或者：

  1. 从菜单栏中，选择 Markers（标记）> Delete（删除）...。

  2. 在 Delete Marker（删除标记）对话框中，选择要删除的标记。

    单击 Name（名称）、Position（位置）或 Comment（注释）列标题，可对标记列表进行排序。

  3. 单击 OK（确定）。

另请参见

  • 创建新的电压标记
  • 放置电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 将电压标记移到后面
  • 更改电压标记属性


创建新的电压间隔测量

使用电压间隔测量功能可以测定两个电压标记之间的电压。测量结果在标记测量显示栏中显示。

  1. 在模拟信号行的电压标记/纵轴刻度显示栏（在波形左边）中，单击并选择 Measurements（测量）> New Voltage Interval Measurement（新建电压间隔测量）。

    或者，右键单击标记测量显示栏，并选择 New Voltage Interval Measurement（新建电压间隔测量）> (analog signal name)（模拟信号名称）。

  2. 在 Voltage Interval（电压间隔）对话框中，选择用于确定电压测量范围的首尾标记。

  3. 单击 OK（确定），关闭 Voltage Interval（电压间隔）对话框。

间隔测量的结果显示在标记测量显示栏中：


重命名电压标记

可以为电压标记指定任何名称。

  1. 在带有电压标记的 Waveform（波形）窗口中右键单击电压标记，并选择 Rename（重命名）。

    或者，在显示窗口属性对话框的 Voltage Marker Properties（电压标记属性）选项卡中选择 Marker（标记），并单击 Rename（重命名）。

  2. 在 Rename（重命名）对话框中输入新的标记名称。

    通过使用 Long name[abbreviated name] 语法，可以同时指定长名称 和缩写名称；如 Location A[A]。如果使用缩写名称，它会显示在电压标记显示栏中的相应标记上，而长名称则显示在该标记的工具提示 中。

  3. 单击 OK（确定）。

另请参见

  • 创建新的电压标记
  • 放置电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 将电压标记移到后面
  • 更改电压标记属性


将电压标记移到后面

当显示的电压标记重叠时，可以将可见的标记移到后面，以便看到下面的标记。

  1. 单击想移到后面的电压标记，并从弹出菜单中选择 Send to Back（移到后面）。

另请参见

  • 创建新的电压标记
  • 放置电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 更改电压标记属性


更改电压标记属性

电压标记创建之后，可以从 Voltage Marker Properties（电压标记属性）选项卡中修改其任一属性。

  1. 右键单击某一电压标记，并选择 Properties（属性）...。

    或者，在查看包含电压标记的 Waveform（波形）显示窗口时从主菜单选择 Markers（标记）> Properties（属性）...。

  2. 在 Waveform Properties（波形属性）对话框的 Voltage Marker Properties（电压标记属性）选项卡中：

    可以执行以下操作：

    • 选择要更改属性的 Marker（标记）。
    • 重命名电压标记
    • 更改标记的背景颜色
    • 更改标记的前景颜色
    • 更改电压标记的位置属性
    • 隐藏/显示标记
    • 向标记添加注释

  3. 单击 OK（确定），应用这些更改并关闭属性对话框。

另请参见

  • 创建新的电压标记
  • 放置电压标记
  • 删除电压标记
  • 创建新的电压间隔测量
  • 重命名电压标记
  • 将电压标记移到后面


搜索采集的数据

可以在采集的数据中搜索总线/信号码型。

  • 快速查找总线信号码型
  • 在采集的数据中查找总线/信号码型
  • 在采集的数据中查找复杂的总线/信号码型
  • 存储、重新调用或删除喜爱的查找码型
  • 指定 found 标记的放置


快速查找总线/信号码型

在 Waveform（波形）或 Listing（列表）窗口中，您可以快速画个矩形，并找到出现该总线/信号码型的下一个或上一个位置。

  1. 在 Waveform（波形）窗口中，确定未选中 Fast Zoom In（快速放大）选项。

  2. 将鼠标指向所需总线/信号码型的左上角。

  3. 按住鼠标键，并将鼠标指针拖至该总线/信号码型的右下角。

    在画矩形的过程中，工具提示会显示所选的总线/信号码型。

    当鼠标从左到右和从上到下移动时，与该矩形左边线相交的信号沿/电平或总线值会成为总线/信号码型。

    只能设置一个沿。

    要将总线扩展为分离信号，应符合以下三个条件：

    1. 如果是在总线上开始画的矩形，则不包含其任一扩展信号。

    2. 如果是在信号上开始画的矩形，则不能包含总线。

    3. 沿和电平是互斥的。也就是说，或者可以设置一个沿，或者可以设置所有电平，但二者不能同时设置。

    注意：

    在 Waveform（波形）显示窗口中，如果矩形左边线所指示的总线/信号码型不是所需的，则可能有必要重画矩形。也可以试着从上次画的矩形的左边线向左画个矩形。

  4. 选定所需的总线/信号码型之后，放开鼠标，并从弹出菜单中选择 Find Next（查找下一个）或 Find Previous（查找上一个）。

  5. 单击 Previous（上一个） [image] 或 Next（下一个） [image] 图标，查看更多匹配项。

一般原则

  • 总线/信号码型中不能包含任何带有重叠位的总线/信号。

    示例： Bus_1 分配到的是盒 1 的通道 0 至通道 7，Bus_2 分配到的是盒 1 的通道 3 至通道 6。因此，Bus_1 和 Bus_2 都分得了相同的探测信号（盒 1 的通道 3 至通道 6）。现在，跨 bus_1 和 bus_2 画个矩形。由于 Bus_1 的通道 3 至通道 6 在 Bus_2 上是重复（重叠）的，因此它们不会包含在总线/信号码型中。

另请参见

  • 在采集的数据中查找总线/信号码型
  • 在采集的数据中查找复杂的总线/信号码型
  • 存储、重新调用或删除喜爱的查找码型


在采集的数据中查找总线/信号码型

此搜索选项用于查找指定的数据码型。可以使用特定的位、数据码型、等式和范围运算符来限定搜索。搜索结果显示在显示屏的中央。

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击标准工具栏中的 [image] 图标。

  2. 在 Find（查找）对话框中，输入希望找到的匹配项数 (occurrence)，并选择是从起始位置往前搜索还是往后搜索；然后选择起始位置。

  3. 指定想要查找的总线/信号码型事件。

    除了常用的码型匹配运算符（=、!=、<、>、<=、>=、In Range 和 Not In Range）以外，还有三个运算符可以使用：

    • Entering — 与该码型匹配的一个或多个连续采样中的第一个样本。（而 = 运算符会考虑作为该码型匹配项而出现的每一个样本。）

    • Exiting — 与该码型匹配的一个或多个连续采样之后的样本。

    • Transitioning — 进入或退出与该码型匹配的一个或多个连续采样。

    在此既可以查找模拟信号值，又可以查找数字信号值。

  4. 选择所需的 When 查找限定符（它用时间范围或其他限定符进一步限定查找条件）：

    • Present
    • Not Present
    • Present>（持续时间）
    • Present>=（持续时间）
    • Present<（持续时间）
    • Present<=（持续时间）
    • Present for Range
    • Not Present for Range
    • Entering
    • Exiting
    • Transitioning

  5. 单击 Find（查找）。

  6. 单击 Previous（上一个） [image] 或 Next（下一个） [image] 图标，查看更多匹配项。

提示：

提示：配置查找功能就如同在构造一个从左到右阅读的句子。例如：

"Find 1 occurrence Forward from the Display Center of a bus named My Bus 1, and on All bits a pattern that Equals XX Hex, display the event When all criteria is Present."

注意：

查找限定符：

  • Present>
  • Present>=
  • Present<
  • Present<=
  • Present for Range
  • Not Present for Range
用于指定一段时间。也就是说将根据指定的时间和运算符来查找在表达式中指定的事件。

其他限定符：

  • Present
  • Not Present
  • Entering
  • Exiting
  • Transitioning
不支持持续时间。

另请参见

  • 快速查找总线信号码型
  • 在采集的数据中查找复杂的总线/信号码型
  • 存储、重新调用或删除喜爱的查找码型
  • 指定 found 标记的放置


在采集的数据中查找复杂的总线/信号码型

可以对搜索条件进行扩充，以便包括多个描述总线/信号码型的事件。

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击标准工具栏中的 [image] 图标。

  2. 在 Find（查找）对话框中，选择希望找到的匹配项数 (occurrence)，并选择是从起始位置往前搜索还是往后搜索；然后选择起始位置。

  3. 选择总线/信号码型事件下拉菜单，然后选择 Insert Event After (AND/OR)（在其后插入事件（和/或））或 Insert Event Before (AND/OR)（在其前插入事件（和/或）），插入新的查找事件。

    只有至少存在两个事件时，才可以使用 Delete Event（删除事件）选项删除当前事件。

  4. 针对所添加的各个事件，选择 And（和）或者 Or（或），指定这些事件码型的组合方式。

    AND（和）关系的搜索查找同时出现两个事件的情况，而 OR（或）关系的搜索则查找两个事件中任一事件出现的情况。

    当使用 AND（和）和 OR（或）关系组合事件时，这些事件上面会出现一个按钮，用于更改事件计算顺序。

  5. 针对各个事件，选择总线或信号名称，并输入要查找的值。

  6. 单击 Find（查找）。

另请参见

  • 快速查找总线信号码型
  • 在采集的数据中查找总线/信号码型
  • 存储、重新调用或删除喜爱的查找码型
  • 指定 found 标记的放置


存储、重新调用或删除喜爱的查找码型

  • 存储喜爱的码型
  • 重新调用喜爱的码型
  • 删除喜爱的码型

存储喜爱的码型

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击 [image] 图标。

  2. 设置要查找的码型（请参见在采集的数据中查找总线/信号码型或在采集的数据中查找复杂的总线/信号码型）。

  3. 单击 Store Favorite（存储喜爱的码型）。

  4. 输入查找码型的名称。

  5. 单击 OK（确定）保存该查找码型。

重新调用喜爱的码型

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击 [image] 图标。

  2. 选择 Recall Favorite（重新调用喜爱的码型）；然后，从下拉菜单中选择要使用的查找码型。

  3. 单击 Find（查找）。

删除喜爱的码型

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击 [image] 图标。

  2. 选择 Recall Favorite（重新调用喜爱的码型）；然后，选择 Delete（删除）...。

  3. 在 Delete Favorites（删除喜爱的码型）对话框中，选择要删除的查找码型；然后，单击 Delete（删除）。

另请参见

  • 搜索采集的数据
  • 指定 found 标记的放置


指定 found 标记的放置

在搜索某个码型时，可以在码型最后一次出现的位置放置现有标记，也可以在其最后一次出现的位置或所有它出现过的位置放置一个新标记。

  1. 从菜单栏中，选择 Edit（编辑）> Find（查找）...，或单击标准工具栏中的 [image] 图标。

  2. 在 Find（查找）对话框中，设置要查找的码型。

  3. 单击 Options（选项）...。

在最后一次出现的位置放置现有标记

  1. 选择 Place（放置）选项。

  2. 从下拉菜单中选择要放置的标记。

  3. 单击 OK（确定）。

放置新标记

  1. 选择 Place new marker named（放置具有以下名称的新标记）:。

  2. 输入新标记的名称。

  3. 选择要 on the last occurrence（在最后一次出现的位置上）还是 on all occurrences（在所有出现过的位置上）放置新标记。

    仅当要查找码型的多个出现位置时，on all occurrences（在所有出现过的位置上）选项才可用。

  4. 单击 OK（确定）。

另请参见

  • 搜索采集的数据
  • 存储、重新调用或删除喜爱的查找码型
  • 在数据中放置标记


比较采集的数据与参考数据

通过比较来自不同采集过程的数据，可以查找已知状态良好的被测设备与有问题的被测设备或在不同条件下运行的被测设备之间的差异。

比较采集的数据与参考数据：

  1. 采集（或载入）要用作参考数据的数据。

  2. 选择 Window（窗口）> New Compare（新建比较）... 打开新的 Compare（比较）显示窗口。

  3. 在 Compare（比较）显示窗口中单击 Copy（复制）... 按钮以选择应复制到参考缓冲区中的当前数据。

  4. 采集（或载入）要与参考数据进行比较的数据。

    Compare（比较）窗口中会突出显示它们的差异。

有关比较采集的数据与参考数据的更多信息，请参见：

  • 将数据复制到参考缓冲区
  • 在比较的数据中查找差异
  • 仅比较一定范围内的样本
  • 偏移参考数据
  • 出现一定数量的比较差异后停止运行
  • 设置 Compare（比较）窗口的属性

另请参见

  • Compare（比较）显示窗口
  • 从被测设备中采集数据
  • 载入已保存的数据和设置


将数据复制到参考缓冲区

  1. 在 Compare（比较）显示窗口中单击 Copy（复制）... 按钮。

  2. 在 Select Buses/Signals（选择总线/信号）对话框中：

    1. 从可用的总线和信号中选择要复制到参考缓冲区中的部分，然后单击 Add>>（添加>>）。

      要将总线和信号从所选列表中移除，请选中它们并单击 <<Remove（<<移除）。

    2. 使用标记选择所有 数据或一定范围内的数据。

  3. 准备好开始复制后，单击 OK（确定）。

    注意：

    复制生成的总线/信号列（如通过反汇编程序或分析工具创建的列）需要较长的时间，这是由于需要额外执行处理来重新创建数据的缘故。

    注意：

    如果逻辑分析仪的内存较深，则需要一段时间才能将数据复制到参考缓冲区。


在比较的数据中查找差异

在 Compare（比较）显示窗口中：

  • 单击 >> 按钮可查找下一差异（在参考中心以下）。

  • 单击 << 按钮可查找上一差异（在参考中心以上）。

  • 单击 Compare Overview（比较概览）栏（位于窗口右侧的垂直滚动条与 Marker Overview（标记概览）栏之间）中的蓝色勾号标记可转至该差异。

注意：

当子行中出现差异时（例如，当数据由分析工具反汇编或编码时），下一差异和上一差异按钮将转至样本行而非子行。


仅比较一定范围内的样本

  1. 在 Compare（比较）显示窗口中单击 Range & Offset（范围与偏移）... 按钮。

  2. 在 Range & Reference（范围与参考）对话框中，选择所有 数据或使用标记选择一定范围内的数据。

  3. 单击 OK（确定）。

注意：

在指定比较范围时，该范围将与参考缓冲区顶部 的数据进行比较（除非已按若干样本对参考数据进行偏移处理），而不是所想象的参考缓冲区中的相同范围。这种处理方式允许将输入数据中的多个数据范围与参考数据进行比较。


偏移参考数据

当在触发前采集的多个样本中存在差异，或者对一定范围内的样本进行比较时，可以偏移参考数据，以便准确对齐所比较的样本。

  1. 在 Compare（比较）显示窗口中单击 Range & Offset（范围与偏移）... 按钮。

  2. 在 Range & Reference Offset（范围与参考偏移）对话框中，输入要对参考数据进行偏移的样本数。

  3. 单击 OK（确定）。

另请参见

  • 仅比较一定范围内的样本


出现一定数量的比较差异后停止运行

通过 Compare （比较）显示窗口可设置在与参考数据相比较时，运行中出现指定数量的差异后停止比较、停止重复运行或发送电子邮件。

  1. 在 Compare（比较）显示窗口中单击 Compare Until（比较至）...。

  2. 在 Compare Properties（比较属性）对话框的 Difference Properties（差异属性）选项卡中，输入将导致停止比较、停止重复运行或发送电子邮件消息的差异数量。

  3. 要在达到该差异数量后停止比较，请选中 Stop comparing（停止比较）复选框。

  4. 要在达到该差异数量后停止重复运行，请选中 Stop repetitive run（停止重复运行）复选框。

  5. 要在达到该差异数量后发送电子邮件，请选中 Send e-mail（发送电子邮件）复选框，然后单击 E-mail（电子邮件）... 按钮。在 E-mail（电子邮件）对话框中，输入电子邮件的接收地址、主题和消息文本。

  6. 在 Compare Properties（比较属性）对话框中单击 OK（确定）。

  7. 启动重复运行测量。

另请参见

  • 开始/停止测量


设置 Compare（比较）窗口的属性

  1. 在 Compare（比较）显示窗口中，右键单击总线/信号列的名称，然后在弹出菜单中选择 Properties（属性）...。

  2. 在 Compare Properties（比较属性）对话框中：

    • 在 Window Properties（窗口属性）选项卡中可以选择参考数据的背景色、用于表示无参考数据的背景色，以及差异数据的前景色和背景色。

    • Column Properties（列属性）选项卡的 Display（显示）域用于选择显示 All（所有）参考数据、仅显示存在差异的参考数据（Difference Pair（差异数据对）），或仅显示所比较数据中突出显示的差异（Input Only（仅输入））。

    • Difference Properties（差异属性）选项卡中的选项用于控制在发现一定数量的比较差异时停止运行。

    所有其他 Compare property（比较属性）选项都与 Listing（列表）窗口相同。

另请参见

  • 设置 Listing（列表）窗口的属性
  • 出现一定数量的比较差异后停止运行


查看与采集的数据关联的源代码

  1. 添加并配置适当的反汇编程序工具（请参见使用反汇编程序工具）。

  2. 载入行号符号（请参见载入文件中的符号）。

  3. 选择 Window（窗口）> New Source（新建源代码）...，打开新的 Source（源代码）显示窗口。

  4. 在对话框后出现的 Add New Window（添加新窗口）中，首先选择反汇编程序工具或 Filter/Colorize（过滤/着色）工具，然后再添加其源代码窗口。

    通常情况下，源代码窗口需要具有与其他显示窗口（列表、波形等）相同的数据。

  5. 在源代码窗口的源代码显示窗格中，右键单击并选择 Properties（属性）...。

  6. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Code Directories（源代码目录）选项卡中，单击 Add（添加）...选项卡。

  7. 在 Browse for Folder（浏览文件夹）对话框中，选择包含源文件的目录，然后单击 OK（确定）。

  8. 单击 OK（确定），关闭 Source Viewer Properties（源代码查看器属性）对话框。

有关查看与采集的数据关联的源代码的更多信息，请参见：

  • 按源代码行单步查看采集的数据
  • 转至与某源代码行关联的采集数据
  • 浏览源文件
  • 在源文件中搜索文本
  • 在 Source（源代码）窗口中设置快速触发
  • 转至与列表中心矩形关联的源代码行
  • 编辑源代码目录列表
  • 选择相关总线
  • 更改 Source（源代码）窗口属性
    • 更改源代码背景颜色
    • 更改源代码文本颜色
    • 更改源代码字体大小
    • 更改源代码选项卡宽度
    • 显示/隐藏源代码行号
    • 更改"设置快速触发"对齐方式

另请参见

  • 分析列表数据
  • Source（源代码）显示窗口


按源代码行单步查看采集的数据

  1. 在源代码窗口的源代码窗格中，单击 [image] 跳到下一个源代码行或单击 [image] 跳到上一个源代码行按钮。

    更新列表窗格可以显示与下一个或上一个源代码行相关的采集数据，更新源代码窗格可以显示下一个或上一个源代码行。

另请参见

  • 查看与采集的数据关联的源代码


转至与某源代码行关联的采集数据

  1. 在 Source（源代码）窗口的源代码窗格中，单击与要查看的采集数据关联的源代码行。

  2. 单击 [image] 查找下一个选定的源代码行或单击 [image] 查找上一个选定的源代码行按钮。

    或者，右键单击选定的源代码行，并选择 Find Next Selected Source Line（查找下一个选定的源代码行）或 Find Prev Selected Source Line（查找上一个选定的源代码行）。

    如果找到与该源代码行关联的采集数据，则列表窗格和源代码窗格都会被更新，并分别显示采集的数据和选定的源代码行。

    如果未找到与该源代码行关联的采集数据，则显示一个信息对话框。

另请参见

  • 查看与采集的数据关联的源代码


浏览源文件

  1. 在 Source（源代码）窗口的源代码窗格中，单击 Browse（浏览）...。

  2. 在 Select Source File to Open（选择要打开的源文件）对话框中，选择要浏览的源文件，并单击 Open（打开）。

    选定的源文件出现在源代码窗格中。

另请参见

  • 在源文件中搜索文本
  • 在 Source（源代码）窗口中设置快速触发
  • 转至与列表中心矩形关联的源代码行
  • 查看与采集的数据关联的源代码


在源文件中搜索文本

  1. 在 Source（源代码）窗口的源代码窗格中，右键单击鼠标并选择 Find in Source（在源代码中查找）...。

  2. 在 Find（查找）对话框中，输入要搜索的文本，选择搜索方向，然后单击 Find Next（查找下一个）。

    如果找到该文本，则相应的源代码行会高亮显示。

    如果未找到该文本，则显示一个信息对话框。

另请参见

  • 在 Source（源代码）窗口中设置快速触发
  • 转至与列表中心矩形关联的源代码行
  • 查看与采集的数据关联的源代码


转至与列表中心矩形关联的源代码行

在浏览或搜索完源文件中的文本以后，接下来可能需要显示与列表窗格中显示的采集数据关联的源代码行。

  1. 在 Source（源代码）窗口的源代码窗格中，单击 [image] 显示关联的源代码行按钮。

    源代码窗格会被更新，显示与列表中央矩形关联的源代码行或显示“No matching symbol found.”（未找到匹配的符号）。

另请参见

  • 查看与采集的数据关联的源代码


编辑源代码目录列表

如果编译和调试是在不同的计算机上进行，在符号文件中指定的源文件路径就不一定有效，所以可以指定源代码所在的目录。

  1. 在 Source（源代码）窗口显示区中，右键单击鼠标并选择 Properties（属性）...。

    2. 或者，从主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Code Directories（源代码目录）选项卡中：

    可以执行以下操作：

    • 通过单击 Add（添加）...将目录添加到搜索列表中。

    • 通过选中或取消选中 Search subdirectories（搜索子目录）来指定是否搜索子目录。

    • 通过选中某一目录并单击 Move Up（上移）或 Move Down（下移）来更改它在搜索列表中的位置顺序。

    • 通过选中目录并单击 Delete（删除）从搜索列表中删除目录。

  3. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 查看与采集的数据关联的源代码


选择相关总线

  1. 在 Source（源代码）窗口显示区中，右键单击鼠标并选择 Properties（属性）...。

    2. 或者，从主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Source Viewer Properties（源代码查看器属性）对话框的 Correlation Bus（关联总线）选项卡中，选择 Source（源代码）窗口应该在哪个总线上查找行号符号。

    通常都是选择反汇编程序工具所生成的“软件地址”总线或另一条地址总线。

  3. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 查看与采集的数据关联的源代码


更改 Source（源代码）窗口属性

您可以更改影响 Source（源代码）显示窗口的源代码窗格的属性。

  1. 在源代码窗口的源显示窗格上，右键单击并选择 Properties（属性）...。

    2. 或者，从主菜单中选择 Edit（编辑）> Window Properties（窗口属性）...。

  2. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中：

    可以执行以下操作：

    • 更改源代码背景颜色
    • 更改源代码文本颜色
    • 更改源代码字体大小
    • 更改源代码选项卡宽度
    • 显示/隐藏源代码行号
    • 更改“设置快速触发”对齐方式

  3. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Listing（列表）窗口属性
  • 更改总线/信号列属性


更改源代码背景颜色

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，单击 Background（背景）颜色选择按钮，并从调色板中选择所需的背景颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Source（源代码）窗口属性


更改源代码文本颜色

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，单击 Source Text（源代码文本）选择按钮，并从调色板中选择所需的颜色。

    如果要使用调色板中没有的颜色，请单击 Other（其他）...，访问自定义颜色对话框。

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Source（源代码）窗口属性


更改源代码字体大小

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，输入所需的 Font Size（字体大小）：

    字体大小的变化范围为 6 磅到 72 磅。

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Source（源代码）窗口属性


更改源代码制表符宽度

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，输入所需的 Tab Width（制表符宽度）：

    制表符宽度的变化范围为 1 到 10 个空格。

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Source（源代码）窗口属性


显示/隐藏源代码行号

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，选择或取消选择 Display Line Numbers（显示行数）以指定显示或隐藏源文件行数。

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 更改 Source（源代码）窗口属性


更改“设置快速触发”对齐方式

对于一次性（只从块边界地址）读取指令块的微处理器，使用地址对齐属性可以在某一源代码行上设置 Quick Triggers（快速触发）时将源代码行符号值调整为在块边界地址上。

  1. 在 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡中，选择所需的 Address Alignment（地址对齐方式）：

  2. 单击 OK（确定），应用这些更改并关闭 Source Viewer Properties（源代码查看器属性）对话框。

另请参见

  • 在 Source（源代码）窗口中设置快速触发
  • 更改 Source（源代码）窗口属性


（使用 Overview（概览）窗口）以不同的方式分析相同的数据

Overview（概览）窗口用于指定如何从逻辑分析仪数据采集模块将数据发送到后处理工具和显示窗口。例如，对于同一数据，可以在一个 Listing（列表）窗口中显示过滤后的数据，而在另一个 Listing（列表）窗口中选择未过滤的数据。

以不同的方式分析同一数据：

  1. 打开或显示 Overview（概览）窗口。

  2. 添加新窗口。

    出现 Add New Window After（在其后添加新窗口）对话框时，选择要在其后放置新窗口的模块或工具。

  3. 添加新工具。

    出现 New Tool（新工具）对话框时，选择要放置新工具的位置。

有关使用 Overview（概览）窗口的更多信息，请参见：

  • 打开或显示 Overview（概览）窗口
  • 添加、复制或删除窗口和工具
  • 编辑窗口或工具属性
  • 重命名窗口、工具和模块
  • 刷新 Overview（概览）窗口
  • 删除 Overview（概览）窗口

另请参见

  • Overview（概览）窗口
  • Waveform（波形）显示窗口
  • Listing（列表）显示窗口
  • Compare（比较）显示窗口
  • Source（源代码）显示窗口
  • Filter/Colorize（过滤/着色）工具
  • 反汇编工具
  • 总线分析工具
  • 工具


打开或显示 Overview（概览）窗口

  • 选择 Tools（工具）> Overview（概览）。

  • 选择 Window（窗口）> Overview（概览）。

  • 如果已经打开 Overview（概览）窗口并且开启了选项卡式窗口，则可以通过选择窗口底部的 Overview（概览）选项卡显示 Overview（概览）窗口。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据


添加、复制或删除窗口和工具

可以在界面中添加新的 Listing（列表）和 Waveform（波形）显示窗口。新窗口添加后，它们会出现从菜单栏中 Window（窗口）下的列表中。活动窗口带有一个勾号。通过菜单栏或通过使用选项卡可以访问所有可用的窗口。

当把一个新工具添加到逻辑分析仪的测量配置中时，其名称会出现在 Tools（工具）菜单底部。这些工具会相互影响，因此您可以逐渐地过滤反汇编列表的数据或颜色部分。

添加新窗口

  • 从菜单栏中，选择 Window（窗口）> New type（新建类型）...。

  • 如果窗口带有选项卡，则还可以右键单击选项卡并选择 Window（窗口）> New type（新建类型）...。

  • 在 Overview（概览）窗口中，右键单击窗口背景，并从弹出菜单中选择 New Window（新建窗口）。

  • 在 Overview（概览）窗口中，从某一模块或工具菜单中选择 New Window（新建窗口）。

    新窗口被放在了该模块或工具的后面。

删除窗口

  • 从菜单栏中的 Window（窗口）菜单中选择 Delete（删除）。

  • 如果窗口带有选项卡，则可以右键单击选项卡并选择 Delete（删除）。

  • 在 Overview（概览）窗口中，从 Window（窗口）菜单中选择 Delete（删除）。

添加新工具

  • 从菜单栏中，选择 Tools（工具）> New type（新建类型）...。

  • 在 Overview（概览）窗口中，右键单击窗口背景，并从弹出菜单中选择 New Tool（新建工具）。

  • 在 Overview（概览）窗口中，从某一模块或工具菜单中选择 New Tool（新建工具）。

    新工具被放在了该模块或工具的后面。

如果所需工具未列出，请确定是否已安装了该工具并获得了使用该工具的许可。

提示：

提示：许多工具都带有一个配置文件。载入该配置文件可以添加该工具，并设置它所使用的总线名称、符号或过滤器。

删除工具

  • 在 Overview（概览）窗口中，从工具的菜单中选择 Delete（删除）。

复制窗口

在 Overview（概览）窗口中，可以通过 Window（窗口）菜单复制窗口。除了新窗口与被复制的窗口具有相同的属性以外，复制窗口与添加新窗口的过程没有其他区别。

删除连接

  1. 在 Overview（概览）窗口中，选择要删除的连接。

  2. 选择 Delete Connection（删除连接）。

    删除连接的同时会删除连接端的窗口或工具。

添加连接

除了添加新窗口或工具以外，没有其他方法可以在模块、工具和窗口之间建立连接。请参见：连接规则。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据
  • 打开/关闭窗口选项卡


编辑窗口或工具属性

编辑窗口属性

  • 在 Overview（概览）窗口中，从 Window（窗口）菜单中选择 Properties（属性）...。

    或者，从菜单栏中，从 Window（窗口）菜单中选择 Properties（属性）... 命令。

    或者，在显示窗口中右键单击鼠标，然后从弹出菜单中选择 Properties（属性）... 命令。

  • 在窗口的属性对话框中进行所需的更改。

  • 选择 OK（确定），应用所作更改并关闭该对话框。

编辑工具属性

添加新工具（如过滤器或反汇编程序）之后，可以在细化数据分析时修改其属性。

  1. 在 Overview（概览）窗口中，单击该工具上的 Properties（属性）。

    或者，从菜单栏中，选择 Tools（工具）> 工具名称。

  2. 在工具的对话框中更改属性。

  3. 选择 OK（确定），应用所作更改并关闭该对话框。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据
  • 设置 waveform（波形）窗口属性
  • 设置 Listing（列表）窗口的属性
  • 设置 Compare（比较）窗口的属性


重命名窗口、工具和模块

  1. 显示 Overview（概览）窗口。

  2. 在 Overview（概览）窗口中，从 window（窗口）、tool（工具）或 module（模块）菜单中选择 Rename（重命名）... 命令。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据


刷新 Overview（概览）窗口

  1. 显示 Overview（概览）窗口。

  2. 选择 Overview（概览）> Redraw（刷新）命令，或者：

    在 Overview（概览）窗口中右键单击鼠标并选择 Redraw（刷新）。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据


删除 Overview（概览）窗口

  1. 显示 Overview（概览）窗口。

  2. 选择 Overview（概览）> Delete（删除）命令，或者：

    如果开启了选项卡式窗口，则右键单击 Overview（概览）选项卡并选择 Delete（删除）。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据


设置模块之间的系统触发与偏移

当逻辑分析仪或逻辑分析系统中存在多个模块 时，对于所有模块，只有一个 Time=0 点。如果某一模块用于激活 (arm) 另一个模块，则第二个模块将有一个相对于第一个模块来说不在 Time=0 的触发。由于 Time=0 的点只有一个，因此如果一个模块在 Time=-435 ns 时采集了一个事件，另一个模块在 -835 ns 时采集了一个事件，则可以知道这两个事件的时间间隔是 400 ns。

这意味着必须要将一个模块的触发参考点指定为系统触发（即 Time=0）。

您可以指定系统触发 和其他模块的触发参考点之间的偏移。当两个模块处理同一数据时，可能就需要指定偏移，以使来自这两个模块的波形排成直线。

在所有显示窗口中，每个模块都有全局不可移动触发标记。系统触发 标记上有一个特殊图标。

每个显示窗口都有自己的数据开头 和数据结尾 标记，它们是基于该窗口中所显示的总线和信号的。例如，如果 Bus1 是在逻辑分析仪-1 上采集的，Bus2 是在逻辑分析仪-2 上采集的，并且两条总线都包含在 Viewer1 中，则数据开头 是逻辑分析仪-1 或逻辑分析仪-2 中最早的样本，而数据结尾 则是逻辑分析仪-1 或逻辑分析仪-2 中最新的样本。如果 Viewer1 只包含来自逻辑分析仪-1 的总线，则其数据开头和结尾只基于逻辑分析仪-1。

要设置模块之间的系统触发和偏移：

  1. 从主菜单选择 Setup（设置）> Skew & System Trigger（偏移与系统触发）...。

  2. 在 Module Skew and System Trigger（模块偏移与系统触发）对话框中，选择触发参考点将为 Time=0 的模块作为系统触发。

  3. 要指定其他模块的偏移，请在它们的 Skew（偏移）域中输入适当的值。

  4. 若要在下一次运行后将系统触发 更改为发生触发的第一个模块，请选中 First module to trigger designates the System Trigger（要触发的第一个模块指定系统触发）。

  5. 单击 OK（确定）。

如果某模块不是系统触发，那么在 Overview（概览）窗口中其图标将是标准的逻辑分析仪图标：

当把某模块指定为系统触发 时，将多出一个红色的 T 图标：


使用显示窗口

  • 添加或删除显示窗口
  • 打开/关闭窗口选项卡

另请参见

  • 更改 "Go to Trigger on Run" 选项


添加或删除显示窗口

可以在界面中添加新的 Listing（列表）和 Waveform（波形）显示窗口。新窗口添加后，它们会出现从菜单栏中 Window（窗口）下的列表中。活动窗口带有一个勾号。通过菜单栏或通过使用选项卡可以访问所有可用的窗口。

添加新显示窗口

  1. 从菜单栏中依次单击 Window（窗口）> New Listing or New Waveform（新建列表或新建波形）。如果窗口带有选项卡，也可以右键单击选项卡并选择 New Listing or New Waveform（新建列表或新建波形）。

删除显示窗口

  1. 从菜单栏依次单击 Window（窗口）> Close（关闭）。如果窗口带有选项卡，也可以右键单击选项卡并选择 Close（关闭）。

另请参见

  • 打开/关闭窗口选项卡


打开/关闭窗口选项卡

默认情况下，为了在不同的屏幕之间轻松切换，以选项卡的形式显示 Listing（列表）显示窗口和 Waveform（波形）显示窗口。

要打开或关闭窗口选项卡，请选择 View（视图）> Tabbed Windows（选项卡式窗口）。

要在选项卡关闭时切换显示窗口，您必须选择 Window（窗口）>“显示窗口名称”。

另请参见

  • 添加或删除显示窗口


打印采集的数据

为测量创建打印文档有三种方式：

  • 打印采集的数据
  • 将文本复制到剪贴板
  • 将屏幕信息复制到剪贴板

另请参见

  • 安装打印机
  • 连接局域网


打印采集的数据

打印采集的数据

  1. 从菜单栏中，选择 File（文件）> Print（打印）...。

    注意：

    第一次访问打印对话框时，系统会要求安装打印机。请按照所显示的打印机安装对话框中的说明进行安装。

  2. 在 Print What（打印内容）部分，选择要打印的显示窗口。

  3. 要更改页眉、页脚或页边距，请单击 Options（选项）...，并在弹出的对话框中进行更改。更改完成之后，单击 OK（确定）。

  4. 在 Print range（打印范围）部分，从以下选项中选择一项：

    • All（全部）
    • Time（时间）范围
    • Sample（样本）范围
    • Marker（标记）范围

    若选择 Time（时间）、Sample（样本）或 Marker（标记），则要通过选择 from（从）和 to（到）值来设置打印范围。

  5. 单击 OK（确定），打印指定的数据。

    数据是按时间/样本编号的从小到大的顺序打印的。

将采集的数据打印到 ASCII 文本文件

设置一台 generic/text only 打印机，它将数据打印到 FILE:（打印到文件）端口。在 Windows 添加打印机向导中：

  1. 选择本地打印机。（请勿选择“自动检测并安装即插即用打印机”。）

  2. 选择 FILE:（打印到文件）端口。

  3. 选择 Generic 厂商以及 Generic / Text Only 打印机型号。

安装完 generic/text only 打印机之后，即可像使用其他打印机一样将采集的数据打印到该打印机了。

请注意，也可以将采集的数据导出到 CSV 格式的 ASCII 文本文件。

另请参见

  • 将数据导出为 CSV 格式文件
  • 安装打印机


将文本复制到剪贴板

  1. 在列表显示区域，将鼠标光标定位到要复制的显示区域左上角。

  2. 单击并按住鼠标左键，然后将鼠标光标拖至右下角。放开鼠标键。所定义区域四周出现了一个矩形（对齐状态线和总线/信号列）。

  3. 从出现的快捷列表中单击 Copy Text（复制文本）。

  4. 打开一个文字处理程序或电子表格程序，将所复制文本粘贴到该程序中，并打印粘贴的数据文本。


将屏幕信息复制到剪贴板

  1. 单击 Edit（编辑）> Copy Screen（复制屏幕信息）。当前显示的窗口被复制到 windows 剪贴板缓冲区。

  2. 将剪贴板缓冲区内容粘贴到所选的图形编辑程序中。

  3. 从图形程序中打印该屏幕信息。


安装打印机

本地和网络打印机是在逻辑分析仪环境外部使用 Windows 打印机安装向导安装的。

  1. 依次单击开始 > 设置 > 打印机。

  2. 单击某一现有打印机，或者单击添加打印机。

  3. 按 Windows 打印机安装向导说明操作。

另请参见

  • 连接局域网


连接局域网

局域网 (LAN) 是在逻辑分析仪环境外部使用 Windows 网络配置向导安装的。

  1. 依次单击开始 > 设置 > 网络和拨号连接。

  2. 单击某一现有连接，或者单击新建连接。

  3. 按 Windows 网络安装向导说明操作。

另请参见

  • 16900-Series Logic Analysis System Installation Guide
  • 1680-Series Logic Analyzers Quick Start/Installation Guide
  • 更改 Windows XP 防火墙设置
  • 网络故障排除指南


通过 VBA 扩展数据可视化/分析

通过集成的 Microsoft Visual Basic for Applications (VBA)，您可以扩展逻辑分析仪的数据可视化和分析功能。例如：

  • 您可以在 VbaView 窗口中以图形方式显示采集的数据。可以创建下列图形：

    • 线图。
    • XY 散点图。
    • 水平和垂直条形图。
    • 水平和垂直堆叠式条形图。
    • 饼图。

    这些图表是在 VbaView 窗口中使用新的 VbaViewWindow 和 VbaViewChart COM 自动控制对象创建的。

    条形图可用于创建总线值的柱状图，从而在分析系统的性能方面提供帮助。

  • 您可以创建宏来针对采集的数据执行分析并计算统计结果。例如，要检测设置和保持问题，可以查看跟踪过程中的两个沿、计算它们之间的时间增量，并列出平均、最小和最大时间增量。此外，您还可以为异常事件自动添加标记。

  • 可以将采集的数据导出至外部应用程序（如 Microsoft Excel、Microsoft Access、Agilent 89600 Vector Signal Analyzer、MathWorks MATLAB 等），以便进行后处理和分析。使用 VbaView 窗口，可以在图表上标示逻辑分析仪中经过后处理的数据。

另请参见

  • 在 VbaView 窗口中显示数据
  • 使用高级定制环境 (ACE)


管理软件许可证

  • 查看有效的软件许可证信息
  • 激活软件许可证
  • 访问浮动许可证服务器
  • 借用浮动许可证和提前归还

从 Agilent Logic Analyzer 应用程序的 3.20 版本开始，您可以为工具及其他外接软件定购浮动（也称为计数）许可证。（以前，所有许可证都是节点锁定 的。）

注意：

对于 Agilent Logic Analyzer 应用程序的 3.20 版本，必须设置 LM_LICENSE_FILE 环境变量才能访问浮动许可证服务器。从 3.30 版本开始，将在 Agilent Logic Analyzer 应用程序中访问浮动许可证服务器，请不要 再使用 LM_LICENSE_FILE 环境变量。

使用浮动许可证之前，需要先对许可证服务器进行设置。

另请参见

  • License Server Installation Guide，了解有关设置 Agilent 16900 系列逻辑分析系统和 1680/1690 系列逻辑分析仪的许可证服务器的更多信息。
  • Software Licensing（软件授权）对话框


查看有效的软件许可证信息

  1. 从主菜单中，选择 Help（帮助）> Software Licensing（软件授权）...。

  2. 在 Software Licensing（软件授权）对话框的 Summary（摘要）选项卡中：

    • 您可以查看所有可供使用的软件许可证。

    • 红色复选标记显示了正在使用的浮动许可证。

    • 红色的“X”表示该软件尚未安装。

    • 您可以选择一个许可证，并单击 Show Details（显示详细信息）...以查看有关此许可证的详细信息。

    • 您可以将所有授权摘要信息复制到剪切板中。

注意：

当使用“Advanced Customization Environment - Development Package”（高级定制环境 － 开发工具包）浮动许可证时，将在整个会话中采用此许可证。您必须打开一个新的配置才能返回此许可证。

注意：

当使用“ASCII Remote Programming Interface Package”（ASCII 远程编程界面工具包）浮动许可证时，将在运行 Agilent Logic Analyzer 应用程序时采用此许可证。您必须关闭这一应用程序才能返回此许可证。

另请参见

  • 激活软件许可证
  • 访问浮动许可证服务器
  • 借用浮动许可证和提前归还


激活软件许可证

  1. 请按购买软件时获得的“授权证书”上的说明操作。

  2. 从 Agilent Logic Analyzer 应用程序的主菜单上选择 Help（帮助）> Software Licensing（软件授权）...。

  3. 在 Software Licensing（软件授权）对话框的 Activation（激活）选项卡中，复制 Licensing Host ID（授权主机 ID）。激活许可证时需要此 ID。

  4. 访问 Agilent 许可证获取网站。“授权证书”上应印有该网站的 URL。

    许可证获取网站会使用该证书上所印的订单号或其他许可证激活码以及上述 Licensing Host ID（授权主机 ID）生成一个许可证文件。该许可证文件将通过电子邮件发送给用户。

  5. 要安装许可证文件并启用该软件，请按包含该许可证文件的电子邮件中的说明操作。

    其中的说明会要求用户将许可证文件安装在逻辑分析系统或浮动许可证服务器的适当目录中，并重启 Agilent Logic Analyzer 应用程序或许可证服务器。在逻辑分析系统上，许可证目录通常为 C:\Program Files\Agilent Technologies\Logic Analyzer\License\。有关许可证服务器上的许可证目录所在位置，请参见 [image] License Server Installation Guide。

    许可证文件必须具有 .lic 扩展名。

另请参见

  • 查看有效的软件许可证信息
  • 访问浮动许可证服务器
  • 借用浮动许可证和提前归还


访问浮动许可证服务器

使用浮动许可证以前，需要先对许可证服务器进行设置（请参见 [image] License Server Installation Guide）。

  1. 打开 Agilent Logic Analyzer 应用程序，并使用默认配置，以便没有浮动许可证在使用中。

  2. 从主菜单选择 Help（帮助）> Software Licensing（软件授权）...。

  3. 选择 Software Licensing（软件授权）对话框的 Floating License Servers（浮动许可证服务器）选项卡。

添加浮动许可证服务器

  1. 单击 Add Server（添加服务器）...。

  2. 在 Add License Server（添加许可证服务器）对话框中，输入浮动许可证服务器的端口号和名称。

    端口号通常为 27000，但也可能是其他端口号，具体取决于浮动许可证服务器的设置。

    小心：

    只能输入属于浮动许可证服务器的计算机（或逻辑分析仪）的名称。否则，许可证管理器界面会尝试确定该计算机是否为浮动许可证服务器，这会导致界面在数分钟内处于挂起状态。

  3. 单击 OK（确定），关闭 Add License Server（添加许可证服务器）对话框。

  4. 在 Software Licensing（软件授权）对话框中，单击 Apply（应用）。

在搜索顺序中上移或下移服务器

  1. 在 License Servers（许可证服务器）列表中，选择要移动的许可证服务器。

  2. 单击 Move Up（上移）或 Move Down（下移）。

  3. 单击 Apply（应用）。

刷新浮动许可证服务器的状态

  1. 单击 Refresh（刷新）。

    绿色或红色的服务器可用性指示符只表明服务器计算机是否在网络上，而不表明许可证服务器软件是否正在该计算机上运行。

删除浮动许可证服务器

  1. 在 License Servers（许可证服务器）列表中，选择要删除的许可证服务器。

  2. 单击 Delete Server（删除服务器）。

  3. 单击 Apply（应用）。

另请参见

  • License Server Installation Guide
  • 查看有效的软件许可证信息
  • 激活软件许可证
  • 借用浮动许可证和提前归还


借用浮动许可证和提前归还

您可以从某服务器借用浮动许可证一段时间，例如，在将逻辑分析仪（或运行 Agilent Logic Analyzer 应用程序的计算机）带出办公室（或者只是断开网络）期间。当借用许可证期满时，许可证会自动返还给服务器。不过也可以提前归还许可证。

访问 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡

  1. 从主菜单选择 Help（帮助）> Software Licensing（软件授权）...。

  2. 选择 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡。

借用浮动许可证

  1. 设置使用需要借用许可证的软件的配置（或打开一个配置文件）。

  2. 访问 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡。

  3. 在 Borrow Licenses（借用许可证）区域，输入所借许可证的归还日期和时间。

    默认期限为七天。最短为十分钟。

  4. 单击 Borrow（借用）。

重复这些步骤可以借用更多的许可证。

提前归还浮动许可证

提前归还借用的浮动许可证时，必须同时归还所有借用的许可证。若有许可证是登记借出（但尚没有借出）的，则不能归还借用的许可证。

  1. 打开 Agilent Logic Analyzer 应用程序（使用默认配置）。

  2. 访问 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡。

  3. 在 Return Borrowed Licenses（归还借用的许可证）区域中，单击 Return（归还）。

另请参见

  • 查看有效的软件许可证信息
  • 激活软件许可证
  • 访问浮动许可证服务器


解决问题

在排除问题或查找更多信息时，请参见：

  • 软件安装问题
  • 如果意外地以脱机模式启动
  • 无法打开 ALA 格式的配置文件
  • 解释错误消息
  • 许可证问题
  • 转换来自其他逻辑分析仪的配置文件
  • 运行自检
  • 访问日文联机帮助 (Windows XP)
  • 访问日文联机帮助 (Windows 2000)
  • 网络故障排除指南
  • 在 16900 系列机架上进行 CD 写入操作时出现问题
  • 不支持休眠

另请参见

  • 更多信息
  • 内部支持
  • Agilent Logic Analyzer 自述文件


软件安装问题

安装 Agilent Logic Analyzer 应用程序时可能出现的一些问题是：

  • 1680 系列逻辑分析仪上的安装错误


1680 系列逻辑分析仪上的安装错误

在 1680 系列逻辑分析仪上安装 Agilent Logic Analyzer 应用程序时，如果硬盘驱动器碎片太多，则可能会导致安装错误；例如，报告采集卡 FPGA 版本的过程可能会太慢，结果导致错误发生。

请尝试对 1680 系列逻辑分析仪磁盘进行碎片整理，并再次进行安装。


如果意外地以脱机模式启动

当在某一逻辑分析系统或逻辑分析仪上启动 Agilent Logic Analyzer 应用程序时，您是想连接到本地硬件。如果已设置为自动连接到远程逻辑分析系统或逻辑分析仪，则是想连接到远程硬件。如果 Agilent Logic Analyzer 应用程序还是以脱机模式启动，则：

  • 可能是 Agilent Logic Analyzer 应用程序已在运行一个本地会话。您可以运行该应用程序的多个实例，但如果已有一个本地会话在运行，则其他实例将以脱机模式启动。

  • 对于 1690 系列逻辑分析仪（无论本地还是远程），这个问题的原因可能是：

    • 逻辑分析仪供电被切断。

    • IEEE 1394 电缆被拔下或未插紧。

    • PC 机中的 IEEE 1394 接口卡有问题。

  • 如果已经设置为自动连接到远程逻辑分析系统或逻辑分析仪，则原因可能是：

    • 远程系统出现掉电或网络中断的情况。如果是这样，则在以脱机模式启动之前，系统会显示关于系统正处于脱机状态的信息。

    • 远程系统的软件已进行了升级。

    • 远程系统软件已经升级，结果造成了“远程服务不兼容”。在这种情况下，请确保本地计算机或逻辑分析系统上安装了相同版本的软件。


无法打开 ALA 格式的配置文件

如果 ALA 格式的配置文件是因为模块不兼容（即不属于相同或相似的逻辑分析仪系列，如 16740/41/42A 和 16750/51/52A/B）而无法打开，则仍可以载入其中的设置信息：

  1. 在脱机模式下载入不兼容的 ALA 格式配置文件。

    （如果只想查看数据，则可以略过以下步骤。）

  2. 将该配置文件的设置信息保存为 XML 格式的配置文件（请参见保存配置文件）。

  3. 重新联机（请参见返回联机分析）。

  4. 打开 XML 格式的配置文件（请参见打开配置文件和从多模块系统获取模块设置/向多模块系统传送模块设置）。

  5. 将载入的设置信息保存到 ALA 格式的配置文件。

该过程可将不兼容的 ALA 格式配置文件转换成兼容的 ALA 格式配置文件。


解释错误消息

要在帮助中查找所收到的错误消息的解释信息，可以使用帮助窗口的 Search（搜索）选项卡来搜索错误消息中的关键字。

  • 错误消息
  • 警告消息
  • 信息消息
  • Eye Finder 信息消息

另请参见

  • 解决问题


错误消息

  • 采集错误
  • 总线/信号错误
  • 文件错误
  • 硬件错误
  • 帮助文件错误
  • 导入/导出和转换器错误
  • 命名错误
  • 工具错误
  • 触发错误

另请参见

  • 解释错误消息


采集错误

由于状态时钟沿发生过密而出现采集错误。这种情况的原因可能是：- 时钟数量（信号完整性）不足。- 探头接地不足（请尝试在时钟信号附近采用多重地线）。- 状态时钟沿间距小于规格允许值。- 选定多个时钟，且间距小于规格允许值。

在状态采集模式下，逻辑分析仪需要清晰的时钟信号，其速度不能高于最大状态时钟速度（请参见规格和特性）。状态时钟数量不足可能是由被测设备的负载导致的。其原因也可能是 Sampling Setup（采样设置）对话框中的时钟设置包含违反时钟规格的若干信号的组合。当时钟设置使用多个时钟沿时，逻辑分析仪的设置/保持时间通常会增加（请参见规格和特性）。如果使用接近规格的时钟速度，建议每两或三个探头连接进行一次接地。


总线/信号错误

Maximum of 128 channels per Bus.

逻辑分析仪无法处理多于 128 个通道（信号）的总线。如果需要更宽的总线，请尝试将总线分为两个或更多总线，例如 Data_HI 和 Data_LO。

Cannot group into Bus. Maximum of 128 channels per Bus.

逻辑分析仪无法处理多于 128 个通道（信号）的总线。如果需要更宽的总线，请尝试将总线分为两个或更多总线，例如 Data_HI 和 Data_LO。

The following Bus/Signals are required to have a specific number of assigned channels because they are locked.Please correct the following Bus/Signals:name (has num1 channels, requires num2 channels)

某些工具可能会“锁定”产生输出所需的总线和信号。对于锁定的总线和信号，可以更改其特定通道分配，但每个总线或信号的通道总数必须保持不变。请更改每个指定总线或信号的通道分配，使宽度变为 num2。此消息有时会与下一则消息一同显示。在这些情况下，可能已更改了某项配置，使用一半的盒来采样。请检查 Sampling（采样）选项卡。

Every Bus/Signal requires at least one assigned channel.Please assign channels to the following Bus/Signals:

每个总线或信号至少需要一个通道。如果看不到错误对话框中提到的总线/信号，请尝试滚动总线/信号列表。某些工具也可能在文件夹中创建总线或信号。如果希望避免在查看器中显示额外信息，请针对总线或信号所在位置删除行或列。此操作会将信息从查看器中删除，而不会丢失总线/信号的设置信息。此消息有时会与上一则消息一同显示。在这些情况下，可能已更改了某项配置，使用一半的盒来采样。请检查 Sampling（采样）选项卡。

Minimum of one Bus/Signal with assigned channels required.Please add a Bus/Signal.

无法关闭总线/信号的设置，因为您已删除所有总线和信号。文件夹只包含总线和信号，而不代表这些总线和信号的数据映射。要关闭该对话框，请选择 Add Bus/Signal（添加总线/信号）。为新的总线或信号至少分配一个通道。或者，也可以选择 Cancel（取消），恢复为原有的总线和信号分配。

name is locked and cannot be deleted because it is required by another tool in the application.In order to unlock it, the following tools must be deleted:tool

某些工具可能会“锁定”产生输出所需的总线和信号。只有通过 Tools（工具）> Overview（概览）删除该工具，才能删除或重命名总线或信号。

name is locked and cannot be renamed because it is required by another tool in the application.In order to unlock it, the following tools must be deleted:tool

某些工具可能会“锁定”产生输出所需的总线和信号。只有通过 Tools（工具）> Overview（概览）删除该工具，才能删除或重命名总线或信号。

Cannot change pod selection while there are locked Bus/Signals.

某些工具可能会“锁定”产生输出所需的总线和信号。只有通过 Tools（工具）> Overview（概览）删除该工具，才能通过更改使用中的盒来修改总线或信号。

Cannot delete folder because it contains one or more locked children.

某些工具可能会“锁定”产生输出所需的总线和信号。您尝试删除的文件夹包含至少一个锁定的总线或信号的唯一副本。可以将锁定的总线或信号移出文件夹，然后删除该文件夹。或者，也可以通过 Tools（工具）> Overview（概览）删除锁定该总线或信号的工具，然后删除该文件夹。

Unable to set setup and hold times for this Bus/Signal since no channels have been assigned.Please assign channels before using setup and hold.

可能的设置和保持值有效范围取决于通道连接的盒所使用的时钟设置。如果不确定哪些盒的通道属于该总线或信号，逻辑分析仪便不能设置相应的范围。请为总线或信号分配通道，然后设定 setup（设置）和 hold（保持）。

Please enter a user threshold value.

系统会将所有盒设置为同一阈值。如果在不设定值的情况下选择 OK（确定），则会保留当前阈值（其中至少有一个与其他值不同）。请检查对话框，确保所有字段均已填写。

Please enter a threshold value.

系统会将所有盒设置为同一阈值。如果在不设定值的情况下选择 OK（确定），则会保留当前阈值（其中至少有一个与其他值不同）。请检查对话框，确保所有字段均已填写。


文件错误

Error trying to remove file: "directory/hardware_log.txt".

当逻辑分析仪启动时，它会替换原有的 hardware_log.txt 文件。由于某些原因，这时无法删除原有硬件日志。这可能表示存储文件的磁盘存在问题。

File "filename" could not be opened.

当逻辑分析仪启动时，它会创建新的 hardware_log.txt 文件。由于某些原因，这时无法打开创建后的日志。这可能表示文件系统或磁盘存在问题。


硬件错误

Analyzer Calibration Failed [time] - Instrument may need service.

逻辑分析仪的测量前校准失败。在收到此错误消息后所收集的任何数据都可能是不正确的。如果此故障是暂时的，则关机后再开机可能会解决此问题。如果此故障不断出现，可以运行 Help（帮助）> Self Test（自检）...，或者请 Agilent 销售部门来帮助进行维护。

High speed system clock failure - Instrument may need service.Sleep Duration and Count:duration, counted.

内部的 100 MHz 时钟未通过初始化测试。任何测量都可能是错误的。请登录 http://www.agilent.com/find/contactus 与 Agilent Technologies 销售或支持部门联系，了解仪器维修事宜。

Contact with the analyzer hardware has been lost.This application will be terminated.You will have an opportunity to save your configuration.

[仅限 1690A 系列分析仪] 由于某种原因，计算机与逻辑分析仪之间的 IEEE-1394 连接中断。将当前工作保存在一个配置 (*.ala) 文件中，然后检查逻辑分析仪硬件的供电以及连接情况。失去的连接无法恢复；需要重启逻辑分析仪应用程序。

I/O Channel Error:Invalid Request Argument.

[仅限 1690A 系列分析仪] 通过 IEEE-1394 连接发送的数据存在问题。

I/O Channel Error:Offset Out of Bounds.

[仅限 1690A 系列分析仪] 通过 IEEE-1394 连接发送的数据存在问题。

I/O Channel Error:Timeout.

[仅限 1690A 系列分析仪] 通过 IEEE-1394 连接发送的数据存在问题。

I/O Channel Error:System I/O Error.

[仅限 1690A 系列分析仪] 通过 IEEE-1394 连接发送的数据存在问题。

I/O Channel Error.

[仅限 1690A 系列分析仪] 通过 IEEE-1394 连接发送的数据存在不确定的问题。


帮助文件错误

Help file information was not found in the registry.You may need to reinstall the tool.

逻辑分析仪找不到与该工具关联的帮助文件的注册表项。如果该工具是采用自定义方式安装的，则还必须安装帮助文件才能访问帮助信息。如果重新安装之后问题依然存在，请登录 http://www.agilent.com/find/contactus 向 Agilent Technologies 销售或支持部门寻求帮助。

Help file information not found in registry.Cannot display help.

逻辑分析仪找不到与该工具关联的帮助文件的注册表项。如果该工具是采用自定义方式安装的，则还必须安装帮助文件才能访问帮助信息。如果重新安装之后问题依然存在，请登录 http://www.agilent.com/find/contactus 向 Agilent Technologies 销售或支持部门寻求帮助。

Help file not found.Cannot display help.

在注册表所指定的位置没有找到帮助文件。该文件可能已被删除或移动了位置。可以在安装逻辑分析仪软件的驱动器上搜索 .chm 文件，或者重新安装该工具。

The HTML Help file "filename" was not found.You may need to re-install the product.

在注册表所指定的位置没有找到帮助文件。该文件可能已被删除或移动了位置。可以在安装逻辑分析仪软件的驱动器上搜索该文件，或者重新安装。要重新安装，请关闭逻辑分析仪应用程序，然后运行逻辑分析仪 CD 上的安装程序。

The HTML Help file "filename" was not found.You may need to re-install the tool.

在注册表所指定的位置没有找到该工具的帮助文件。该文件可能已被删除或移动了位置。可以在安装逻辑分析仪软件的驱动器上搜索 .chm 文件，或者重新安装该工具。


导入/导出和转换器错误

Refer to the import files: file1 and file2 for more details.

配置转换器无法完成转换。file1 或 file2 中“<!--”和“>”分隔符之间的部分给出了相关解释。

The specified file is NOT a 167xG Analyzer configuration file: filename

配置转换器无法转换指定的文件，因为它不理解该文件的格式。配置转换器只转换由 1670G、1671G、1672G 和 1673G 逻辑分析仪生成的配置文件。

Cannot read configuration file filename

配置转换器无法读取消息中所示的配置文件，因为其中有内部错误。

Cannot import an empty file.Import terminated.

试图导入的文件不包含任何内容。

Invalid non-ascii character read.Import terminated.

逻辑分析仪只导入 ASCII 文件，但试图导入的文件包含非 ASCII 字符。可以在任一文本编辑程序（如“记事本”）中编辑该文件，删除此字符。注意不要更改标题数据或采样数。

There are one or more locked bus/signals required by tool(s) currently loaded in the application.In order to unlock any of these bus/signals, you must unload every tool listed for that bus/signal....Import terminated.

某些工具可能会“锁定”产生输出所需的总线和信号。只有通过 Tools（工具）> Overview（概览）删除该工具，才能删除、重命名或修改相应的总线或信号。这种方法有一个缺点，就是无法导入使用了不同总线和信号或分析仪通道数的文件。

There were fewer time data samples than indicated by the NumberOfSamples attribute of Module tag.Import terminated.

导入保存的数据文件时，逻辑分析仪会检查数据的一致性。要修正此错误，可以在任一文本编辑程序（如“记事本”）中编辑该文件。

Syntax error in import file:error.Import terminated.

错误描述表明存在语法问题。大多数情况下，该错误是由不匹配的标记导致的。请检查导入文件，确认是否不小心删除了某些内容。

No bus/signals were valid for importing.Import terminated.

导入文件是在盒对多于当前逻辑分析仪的某一逻辑分析仪上创建的，并且所有总线和信号也都是在当前逻辑分析仪所没有的盒对上定义的。可以通过更改为这些总线和信号分配的通道来尝试修改此文件。还可以使用任一文本编辑程序（如“记事本”）编辑导入文件。有关导入文件格式的更多信息，请参见 XML 格式。

Could not create file for export

逻辑分析仪无法创建此文件。这可能是因为磁盘空间不足，或者是现有权限不足以创建指定的文件。

Could not find required tag1 section contained within tag2 section

导入文件中必须有一个标题为 tag1 的段，并且该段必须全部在 <tag2> 和 </tag2> 之间。通过在 tag2 部分的开头添加 <tag1></tag1>，可以修正导入文件。还可以使用任一文本编辑程序（如“记事本”）编辑导入文件。有关导入文件格式的更多信息，请参见 XML 格式。

Invalid or missing attribute in tag XML tag

导入文件需要 XML 标记来包含 attribute 关键字及其值。例如，如果 attribute 是 Acquisition，tag 是 Sampling，则此文件的 XML 标记形式为 <Sampling></Sampling>，但是要求 <Sampling Acquisition="State"></Sampling>。可以通过将 attribute 添加到指定的标记并为其赋值的方法来修正导入文件。（请试着导出类似的配置，以便查看标准值。）还可以使用任一文本编辑程序（如“记事本”）编辑导入文件。有关导入文件格式的更多信息，请参见 XML 格式。

Invalid attribute value for attribute in tag XML tag

导入文件需要 XML 标记来包含 attribute 关键字及其值。例如，如果 attribute 是 Acquisition，tag 是 Sampling，则此文件的 XML 标记形式可能为 <Sampling Acquisition="Time"></Sampling>，但还要求 <Sampling Acquisition="Timing"></Sampling>。可以通过编辑该值来修正导入文件。（请试着导出类似的配置，以便查看标准值。）还可以使用任一文本编辑程序（如“记事本”）编辑导入文件。有关导入文件格式的更多信息，请参见 XML 格式。


命名错误

The object name cannot be an empty string.

重命名查看器、工具或总线时，其名称中至少应有一个字符。逻辑分析仪不接受空白名或空名。

Object name must be unique.

您已试过了重命名查看器、工具或总线，但输入的名称已在使用，因此未被逻辑分析仪接受。虽然有些总线或信号的名称看似完全相同，但它们或者不是完整的名称，或者是指同一总线（别名）。

The name "toolname" is already in use.Please choose a different name.

您已试过了重命名某一工具，但所选的名称已在使用。如果不重命名此工具，则它将恢复为以前的名称。


工具错误

有关由特定的反汇编程序或总线分析工具产生的错误，请转至相应的工具帮助。

Could not load the component - you may need to reinstall

工具文件存在问题时会发生此错误。可能的原因是重命名工具文件或许可更改导致逻辑分析仪无法打开工具文件。要重新安装工具文件，请关闭逻辑分析仪并运行逻辑分析仪 CD 上的安装程序。

Could not get license information for component

逻辑分析仪试图确定工具是许可使用还是免费使用，但找不到此信息。尝试重新安装该工具。

Could not obtain license information for component

此错误意味着逻辑分析仪丢失了某些它需要用来检查许可证的信息。许可证是由 lmtools.exe 程序创建的。您可以运行此程序来查看丢失的信息并检查许可证。

Could not obtain a license for component

当许可证不在预期目录中时会发生此错误。安装此工具时许可证将被写入预定义的目录中。移动或删除文件使您无法使用组件。如果无法确定许可证已删除，请在硬盘驱动器中检查 *.lic 文件。

License for component is invalid

此错误意味着存在许可证文件，但是其中的信息不匹配。许可证是特定于设备的，您无法将工具或逻辑分析仪的许可证在工具或逻辑分析仪之间转移。

Could not create licensed component

安装过程早期存在一个有效的工具许可证，但是发生了一些故障。重新开始工具安装过程。如果该错误仍存在，请与 Agilent Technologies 销售或支持部门联系或访问网站 http://www.agilent.com/find/contactus 以寻求帮助。

Could not create component - unknown error

适当的目录中存在工具许可证，但内部信息不一致。许可证是特定于设备的，您无法在工具之间或逻辑分析仪之间转移许可证。如果该许可证不正确，请再次尝试重新安装工具。

The stored tool could not be restored from file.The tool may have been uninstalled.

您尝试载入的配置文件包含一个有许可证的工具。逻辑分析仪找不到该工具，因此将丢失某些信息。将载入所有基于物理数据的总线和信号，而不会载入由该工具创建的总线和信号。

The selected tool:名称 could not be loaded.

您尝试载入的配置文件包含一个有许可证的工具。逻辑分析仪找不到该工具，因此将丢失某些信息。将载入所有基于物理数据的总线和信号，而不会载入由该工具创建的总线和信号。

The selected tool could not be loaded.

您尝试载入的配置文件包含一个有许可证的工具。逻辑分析仪找不到该工具，因此将丢失某些信息。将载入所有基于物理数据的总线和信号，而不会载入由该工具创建的总线和信号。

The tool could not be created - you may need to reinstall the tool.

您尝试载入的配置文件包含一个有许可证的工具。逻辑分析仪找不到该工具，因此将丢失某些信息。将载入所有基于物理数据的总线和信号，而不会载入由该工具创建的总线和信号。

The analysis tool (工具名) could not be restored from the configuration file.

您尝试载入的配置文件包含一个有许可证的工具。逻辑分析仪找不到该工具，因此将丢失某些信息。将载入所有基于物理数据的总线和信号，而不会载入由该工具创建的总线和信号。


触发错误

Only one action per timer per branch is allowed.

分支指令是“高级触发”步骤中的“Then”后面的操作集合。某些步骤（如高级双向分支指令）可能有多个分支指令。在一个分支指令中，对于每个定时器中只允许进行“从重置开始”、“停止并重置”、“暂停”或“重新开始”中的一项。有关定时器的更多信息，请参见配置定时器。

Only one action per counter per branch is allowed.

分支指令是“高级触发”步骤中的“Then”后面的操作集合。某些步骤（如高级双向分支指令）可能有多个分支指令。在一个分支中，您无法同时“增加”和“重置”同一个计数器。您可以增加一个计数器而重置另一个计数器。有关计数器的更多信息，请参见配置计数器。

Only one store action per branch is allowed.

分支指令是“高级触发”步骤中的“Then”后面的操作集合。某些步骤（如高级双向分支指令）可能有多个分支指令。在一个分支指令中，您可以设置存储样本或不存储样本，但不能在同一个分支指令中同时设置这两种操作。如果没有指定任何存储操作，则使用默认存储。

Only one reset occurrence counter action per branch is allowed.

分支指令是“高级触发”步骤中的“Then”后面的操作集合。某些步骤（如高级双向分支指令）可能有多个分支指令。在一个分支指令中，您只可以指定重置发生计数器一次。

No more edge resources available for this pod pair.

逻辑分析仪硬件仅可处理全通道定时模式 或半通道定时模式 中每个盒对的两个时钟沿语句，或跳变/存储限定定时模式 中每个盒对的一个时钟沿语句。如果时钟沿处于不同的信号上，请尝试使用另一个盒对上的其他通道来探测其中的一个信号。如果所有时钟沿都正用于相同的信号，请使用“上升沿或下降沿”来替换“任一沿”项。有关如何替换“任一沿”的信息，请参见插入事件。

No more pattern resources available for this pod pair

逻辑分析仪硬件对于每个盒对都有一定数量的码型（总线值）变量。如果检查的值处于不同的总线上，请尝试用另一个盒对来探测其中一个总线。

Branch expression is too complex

对于逻辑分析仪，触发设定中某个分支指令的表达式过于复杂。逻辑分析仪先后将所有的 AND 项和 OR 表达式组合在一起。具有多于 4 个事件的 AND 项将使用该资源两次。尝试改写该分支指令表达式以使用更多的 OR 项或删除某些事件。

导致此错误的一种情况是对于跨 2 个以上盒对的总线使用了 In Range 和 Not In Range 运算符。这些运算符仅限于跨 2 个或更少的盒对（最多 64 位宽）的总线。

Trigger Specification is too complex

尽管没有过于复杂的单个分支指令表达式，但是 AND 和 OR 的总数已经超出了逻辑分析仪的资源。尝试在某些步骤中简化一些表达式，或完全删除步骤。

Replacement failed.Maximum number of sequence steps exceeded.

逻辑分析仪会将您指定的触发转换为内部序列步骤。不同的触发函数使用不同数目的内部序列步骤。此外，每次用于状态采集模式中时 Trigger and fill memory（触发并写入内存）操作需要一个附加的内部序列步骤。简化触发设定的一种可能方法是使用一个“转到 N”的操作（该操作指向一个“查找所有事件，然后触发并写入内存”步骤）来替换所有其他 Trigger and fill memory（触发并写入内存）操作。

Unable to insert step.The maximum number of sequence steps are already allocated.

逻辑分析仪会将您指定的触发转换为内部序列步骤。不同的触发函数使用不同数目的内部序列步骤。此外，每次用于状态采集模式中时 Trigger and fill memory（触发并写入内存）操作需要一个附加的内部序列步骤。简化触发设定的一种可能方法是使用一个“转到 N”的操作（该操作指向一个“查找所有事件，然后触发并写入内存”步骤）来替换所有其他 Trigger and fill memory（触发并写入内存）操作。

Too many sequence steps.

逻辑分析仪会将您指定的触发转换为内部序列步骤。不同的触发函数使用不同数目的内部序列步骤。此外，每次用于状态采集模式中时 Trigger and fill memory（触发并写入内存）操作需要一个附加的内部序列步骤。简化触发设定的一种可能方法是使用一个“转到 N”的操作（该操作指向一个“查找所有事件，然后触发并写入内存”步骤）来替换所有其他 Trigger and fill memory（触发并写入内存）操作。

Goto action specifies an undefined step.

触发序列中的最后步骤包括“转到下一步”操作。由于不存在下一步骤，逻辑分析仪无法运行和查找触发。选择 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Advance Trigger（高级触发）...，然后更改上一个触发步骤中的操作。

Counter event specified both true and false in the same product term

在触发设定中，至少有一个分支指令 AND 包括“总线等于 X”和“总线不等于 X”。因为这种情况永远不会实现，所以逻辑分析仪不会触发并无法开始采集。如果您要在按下“停止”之前一直运行，请使用触发函数 Run Until User Stop（用户停止之前一直运行），该函数位于高级触发中的“Other”（其他）选项卡下。

Cannot use <, <=, >, >= for a bus with clock bits that spans pod pairs

您已经定义了跨盒对并包含时钟位的总线。时钟位的计算方式与其所在的盒相同，且可以将其像其他时钟位那样用作不在相同盒对上的通道。检查 Setup（设置）对话框的 Buses/Signals（总线/信号）选项卡中的通道分配。如果不能解决此问题，逻辑分析仪将无法运行。

Cannot specify a range on a bus with clocks bits that spans pod pairs

您已经定义了跨盒对并包含时钟位的总线。时钟位的计算方式与其所在的盒相同，且可以将其像其他时钟位那样用作不在相同盒对上的通道。检查 Setup（设置）对话框的 Buses/Signals（总线/信号）选项卡中的通道分配。如果不能解决此问题，逻辑分析仪将无法运行。


警告消息

You are currently running "Offline," so running the analyzer is not possible.If you wish to create "fake" data while offline, go to "Edit -> Options" and select "Create Data When Offline".Note:This setting is persistent from session to session.

逻辑分析仪正在脱机模式中运行。脱机模式意味着逻辑分析仪软件无法访问逻辑分析仪或逻辑分析系统硬件。如果已连接逻辑分析仪，请检查连接。有关运行仿真数据的更多信息，请参见 Options（选项）对话框。如果要了解如何使用逻辑分析仪软件，仿真数据非常有用。

This module is already being used by another instance of the application.You are now working Offline.

该逻辑分析仪硬件已连接到一个开放的逻辑分析仪软件实例。如果需要获取数据，请从 Windows 任务栏中查找该实例。本地/远程/脱机指示符位于应用程序窗口的底部。在脱机模式下，仍可以使用已存数据运行软件。

Event specified both true and false in the same product term

在 Advanced Trigger（高级触发）对话框中，某一步骤的某一分支会检查事件既为真又为假。事件可能是等于某个值的总线或信号、过期的定时器或超出某值的计数。由于 AND 组合的原因，分支不能为真。您可能想要将触发修改为使用事件的 OR 组合，或将事件分成不同的分支或步骤。有关构建复杂触发的更多信息，请参见在触发序列步骤中替换或插入触发函数。有关如何解释触发序列的更多信息，请参见读取事件和操作语句。

Timer n value checked as an event, but no start action specified.

在 Advanced Trigger（高级触发）对话框中，触发序列将检查从未启动的定时器的值。定时器需显式在前一触发步骤中明确启动。有关更多信息，请参见配置定时器。

Counter n value checked as an event, but no increment action specified.

在 Advanced Trigger（高级触发）对话框中，触发序列将检查从未增加的计数器的值。计数器需在触发步骤的操作语句中进行增加。有关更多信息，请参见配置计数器。

The Bus/Signals listed below could not be loaded from the configuration file.Please recheck your Trigger since it may have changed.

刚刚载入的配置文件是在具有比此模型更多的盒的逻辑分析仪上创建的。因此，无法载入某些依赖其他盒的总线和信号。如果触发序列中使用这些总线或信号，那么触发序列将发生更改。您可以通过向受影响的总线和信号分配不同的通道并重新创建触发序列来解决此问题。

Slow or missing clock in Trigger Step n...

逻辑分析仪无法检测状态时钟，因此无法抽采样本并评估触发序列。如果被测设备的时钟突然显示，那么这可能是预期行为。如果不是，请检查所有探测连接。要验证是否收到时钟信号，您可以在定时采集模式中向总线分配时钟通道并获取数据。


信息消息

Filling memory after trigger...

逻辑分析仪已经触发并正在填充内存。正如这条消息所示，逻辑分析仪需要足够的时间来填充内存，其原因不是态采集模式下时钟较慢或存在存储限定，就是在只有跳变的定时采集模式下跳变太少。

Trigger inhibited during prestore...

逻辑分析仪正处于定时采集模式。在定时采集模式下，逻辑分析仪会在搜索触发以前填充指定数量的内存。如果显示此消息，则表示逻辑分析仪正在填充内存，并且尚未开始将数据与触发序列作比较。要采集在被测设备的启动序列开始期间发生的触发，就一定要将 Sampling（采样）选项卡中的触发位置设置为 100% poststore（后存储）。

Waiting in Trigger Step n

逻辑分析仪正在等待与在触发序列第 n 步中定义的事件相匹配的样本。有时该事件的发生率很低，结果造成了长时间的等待。如果觉得逻辑分析仪应该已经触发，则可以在 Advance Trigger（高级触发）中检查触发序列。有关触发的更多信息，请参见指定高级触发。


Eye Finder 信息消息

运行 eye finder 测量之后，在 Thresholds and Sample Positions（阈值和采样位置）对话框中可能会显示以下消息。

"Clock signal in Fast State Mode is divided by two."

此消息只在使用 16753/54/55/56 和 16950 逻辑分析仪时显示。

"Demo: Results will not be used for analysis."

如果在 Eye Finder Advanced Options（Eye Finder 高级选项）对话框的 Run Mode（运行模式）选项卡中选择了 Demo Mode (no probes required)（演示模式，无需探头），则会测量此通道。显示的数据是 eye finder 操作的典型数据，但并不使用显示的采样位置设置。（仍使用手动设置。）

"No signal activity. Check connection, threshold, and stimulus."

此通道没有任何信号迹象。

  • 请检查分析仪与被测设备之间的探头连接。

  • 请检查阈电压设置（请参见设置逻辑分析仪阈电压）。

  • 请检查被测设备是否已启动，以及是否正在运行相应诊断程序或其他信号激发程序。

如果上述各项均已正确设置，Analyzer Setup（分析仪设置）对话框的 Buses/Signals（总线/信号）选项卡中将会显示活动。

"No stable regions. Check clock and thresholds."

通常存在以下两种可能性：

  1. 此通道的信号与为逻辑分析仪定义的时钟异步。如果是这种情况，那么在信号切换时间与时钟到达时间之间不存在稳定关系。

    如果希望对信号进行同步采样，则必须重新为此信号定义时钟。

  2. 稳定区域太小，eye finder 检测不到。

    在这种情况下，必须采取以下措施：手动调整采样位置，运行常规的分析仪测量以查看所需的数据值是否获得采样，从而检查该位置的有效性。可以通过选择箭头按钮或在显示窗口中拖放蓝色采样位置指示符来手动调整采样位置。

"No voltage scan: Channel in pod with assigned clock."

"One or more stable regions found."

"Only a few transitions detected. Change stimulus or increase measurement duration."

观察到此通道的信号切换次数少于 500。可以接受当前的特性指标，也可能希望更改被测设备中的信号激发程序或诊断程序，以提高切换速率。

另一种选择是在 Eye Finder Advanced Options（Eye Finder 高级选项）对话框的 Measurement Duration（测量持续时间）选项卡中选择 Long（长）。使用 Long（长）设置不一定保证不出现该消息，但可确保 eye finder 有机会观察到通道中更大数量的信号跳变。

"Stable region at N ns is an estimate."

仅针对某些总线探头（非通用探头）显示此消息。

"The stable region extends beyond the limits of the display."

此通道处于活动状态，但信号没有在时钟之前或之后的 5 ns 以内切换。例如，如果被测设备中从时钟到数据的传递延迟大于 5 ns，且时钟周期大于 10 ns（频率低于 100 MHz），便会出现这种情况。


许可证问题

可能出现的许可证问题有：

  • 许可证不可用
  • 浮动许可证服务器通信超时


许可证不可用

在使用需要许可证的软件功能，如果许可证不可用，则会弹出 License Not Available（许可证不可用）对话框。

根据具体情况，解决此问题有以下几种方式：

  • 如果所有许可证都在使用中，则可以等待其中的某个许可证再次变为可用。如果只有一个许可证，则 License Not Available（许可证不可用）对话框会显示谁在使用该许可证。如果有多个许可证，则可以查看有效的软件许可证信息，了解许可证用户信息。

  • 如果所有许可证都在使用中或者没有许可证，则可以从其他许可证服务器获得许可证（请参见访问浮动许可证服务器）。

  • 如果许可证管理软件检测到某一许可证服务器不可用，则需要确保该许可证服务器所在的计算机或逻辑分析仪在运行，能通过网络访问，并且在运行许可证服务。有关更多信息，请参见 [image] License Server Installation Guide。

  • 如果意外地没有找到某个节点锁定许可证，则需要确保许可证文件在安装目录（通常为 C:\Program Files\Agilent Technologies\Logic Analyzer）下的 License 子目录中，同时确保该许可证文件的控制名为 .lic。

  • 如果决定购买其他许可证，请与 Agilent Technologies 联系（参见 http://www.agilent.com/find/contactus）。获得“授权证书”后，可以使用 License Activation Wizard（许可证激活向导）激活您的许可证（请参见激活软件许可证）。

另请参见

  • 管理软件许可证


浮动许可证服务器通信超时

使用浮动许可证时，许可证子系统每两分钟将检查一次与许可证服务器之间的通信情况。

通信失败 10 分钟（6 次检查）后，将视为失去许可证，系统会显示消息通知您服务器不再进行通信以及哪些功能被禁用。

您也许可以继续使用 Agilent Logic Analyzer 应用程序，也可能必须退出该应用程序，这取决于禁用的功能。无论是何种情况，您都可以将自己的设置和数据保存至配置文件。

如果您能继续使用 Agilent Logic Analyzer 应用程序中已禁用的功能，则系统会继续每两分钟进行一次通信检查。如果重新建立了与许可证服务器的通信，则系统将显示信息对话框，通知您已重新启用的服务器和功能。

如果失去与浮动许可证服务器的通信，请确保基于许可证服务器的计算机或逻辑分析仪正在运行、可通过网络访问，并且正在运行该许可证服务器。有关更多信息，请参见 [image] License Server Installation Guide。


转换来自其他逻辑分析仪的配置文件

Agilent Logic Analyzer 应用程序带有用于转换来自 167xG 和 16700 系列逻辑分析仪的配置文件的实用工具。这些配置文件转换程序会将其他逻辑分析仪配置文件中的设置信息移至可载入 Agilent Logic Analyzer 应用程序的 XML 通用格式配置文件中。

配置文件转换程序可以在没有任何逻辑分析仪硬件的情况下运行。

注意：

只转换设置信息，而不包括保存的数据。

  • 转换 167xG 逻辑分析仪的配置文件
  • 转换 16700 系列逻辑分析仪的配置文件

另请参见

  • XML 格式
  • 打开配置文件


转换 167xG 逻辑分析仪的配置文件

  1. 从 Windows Start（开始）菜单中，选择 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> 167xG Configuration File Translator（167xG 配置文件转换器）。

  2. 在 167xG Configuration File Translator（167xG 配置文件转换器）对话框中，输入您想要转换的 167xG 配置文件名。

    注意：

    167xG 配置文件以 ._A 结尾，但是此后缀也用于其他模型。如果可能，当通过 1670 系列逻辑分析仪进行查看时请确定它包含一个 167xdn_config 文件类型。

  3. 键入您要保存的新的配置文件名。

    • 因为默认情况下 1670 系列逻辑分析仪在两个测量引擎之间分流资源，所以将创建两个输出文件。默认文件名是与 167xG 配置文件名相同，但附带 1.txt 或 2.txt。即使配置只使用了一个测量引擎，也会创建两个文件。

    • 除非另行指定，否则文件将与输入文件保存在相同的目录中。

    • 输出文件是 XML 格式，可以像其他的 XML 配置文件那样打开。

  4. 单击 Convert（转换）。

不能从文件中转换的信息有：

  • 定时采集模式下的采样周期和采样选项。
  • 状态采样模式中的时钟模式和时钟描述。
  • 所有数据。
  • 任何工具信息。
  • 界面布局。
  • 标记信息。


转换 16700 系列逻辑分析仪的配置文件

  1. 从 Windows Start（开始）菜单中，选择 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> 167xx Configuration File Translator（167xx 配置文件转换器）。

  2. 在 16700 Configuration File Translator（配置文件转换器）对话框中，输入您想要转换的 16700 配置文件名。

    如果您拥有模块在插槽 B 和 C 中的 16700 系列的逻辑分析系统，那么保存某种配置时您将获得三个文件：xxx.__B、xxx.__C 和 xxx.___。在这三个文件中，只有 xxx.__B 和 xxx.__C 可以转换为 XML。无法转换 xxx.___。

  3. 键入您要保存的新的配置文件名。

    • 除非另行指定，否则文件将与输入文件保存在相同的目录中。

    • 输出文件是 XML 格式，可以像其他的 XML 配置文件那样打开。

  4. 单击 Convert（转换）。

不能从文件中转换的信息有：

  • 所有数据。
  • 任何工具信息。
  • 界面布局。
  • 标记信息。

转换多模块配置

例如，如果您拥有模块在插槽 B 和 C 上的 16700 系列逻辑分析系统：

  1. 在 16700 系列逻辑分析系统上，将配置保存到文件“setup1”。这会生成文件 setup1.__B、setup1.__C 和 setup1.___。

    （setup1.__B 和 setup1.__C 文件各包含一个单模块的设置。要转换整个双模块配置，您需要转换两个文件。）

  2. 将 setup1.__B 和 setup1.__C 文件复制到逻辑分析仪或运行 Agilent Logic Analyzer 应用程序的个人电脑中。（可以忽略 setup1.___ 文件。）

  3. 使用 setup1.__B 和 setup1.__C 上的配置文件转换器（如上所述）生成文件 setup1B.XML 和 setup1C.XML。

  4. 在 Agilent Logic Analyzer 应用程序中，打开 setup1B.XML 文件。当询问“是否要在载入之前清除所有模块?”时，请单击 Yes（是）。

  5. 打开 setup1C.XML 文件。当询问“是否要在载入之前清除所有模块?”时，请单击 No（否）。

    一般情况下，载入第一个 XML 文件时清除所有模块，而载入子序列 XML 文件时不清除所有模块。


运行自检

Self Test（自检）菜单用于检查逻辑分析仪的主要硬件功能，以验证其是否运行正常。

小心：

由于最近采集的数据会丢失，因此在运行自检之前请务必保存好重要数据。

  1. 从菜单栏中，选择 Help（帮助）> Self Test（自检）...。

    如果已经采集了一些数据，则会出现一条警告消息，"Running self-tests will invalidate acquired data"（运行自检会使采集的数据失效）；单击 OK（确定）继续。

  2. 在 Analysis System Self Tests（分析系统自检）对话框中，选择自检选项：

    • Include interactive tests（包含交互检测） — 让交互检测出现在选择列表中。

    • Run repetitively（重复运行） — 重复运行所选的检测，直到单击 Stop（停止）为止。

    • Stop on fail（遇故障停止） — 如果您在运行多个检测或在重复运行检测，则选中此选项可在遇到故障时终止检测。

    • Double-click item to start（双击启动检测） — 通过双击来启动某一检测。

  3. 设置报告级别。

    设置较高的级别会生成日益冗长的报告内容。

  4. 如果所用的是多机架配置，请选择要检测的仪器。

  5. 如果仪器上有槽，请选择要检测的槽。

  6. 选择要运行的测试。

  7. 单击 Start（开始）。

    运行检测时，检测结果会显示在对话框的下部，并保存到一个日志文件。

    要停止检测，请单击 Stop（停止）。

    要重置自检选项，请单击 Reset（重置）。

    要查看日志文件，请单击 Logs（日志）...，选择要查看的日志文件，然后单击 Open（打开）。

完成自检后如果发现逻辑分析系统存在故障，或者对其性能存在疑虑，请登录 http://www.agilent.com/find/contactus，与 Agilent Technologies 销售或支持部门联系。

另请参见

  • 更多信息


访问日文联机帮助 (Windows XP)

  1. 从 Windows Start（开始）菜单中，选择 Start（开始）> Control Panel（控制面板）> Regional and Language Options（区域和语言选项）。

  2. 在 Regional and Language Options（区域和语言选项）对话框的 Advanced（高级）选项卡中：

    1. 在 Language for non-Unicode programs（非 Unicode 程序的语言）框中选择 Japanese（日语）。

    2. 单击 OK（确定）关闭 Regional and Language Options（区域和语言选项）对话框。

  3. 在显示的对话框中，选择要复制的文件：

    • 在逻辑分析仪或逻辑分析系统中，该对话框将询问您是希望使用现有文件，还是从 Windows CD-ROM 重新复制文件；单击 Yes（是）可使用现有文件。

    • 对于针对 1690 系列逻辑分析仪、脱机分析或远程连接逻辑分析系统运行 Agilent Logic Analyzer 应用程序的个人计算机上，可能必须从 Windows CD-ROM 复制文件。

  4. 系统将显示一个对话框，询问您是否希望重新启动计算机，单击 Yes（是）可重新启动计算机。

  5. 重新启动计算机后，启动 Agilent Logic Analyzer 应用程序，并选择 Help（帮助）> Help Language（帮助语言）> Japanese（日语）。

    这样便可以在访问联机帮助时获得日语版本了。


访问日文联机帮助 (Windows 2000)

  1. 在 Windows Start（开始）菜单中选择 Start（开始）> Settings（设置）> Control Panel（控制面板）。

  2. 在 Control Panel（控制面板）窗口中双击 Regional Options（区域选项）。

  3. 在 Regional Options（区域选项）对话框中：

    1. 在 Language settings for the system（系统的语言设置）框中选择 Japanese（日语）。

    2. 单击 Set default（设置默认值）...。

    3. 在 Select System Locale（选定系统区域设置）对话框中，选择 Japanese（日语）。

    4. 单击 OK（确定）关闭 Regional Options（区域选项）对话框。

  4. 在显示的对话框中，选择要复制的文件：

    • 在逻辑分析仪或逻辑分析系统中，该对话框将询问您是希望使用现有文件，还是从 Windows CD-ROM 重新复制文件；单击 Yes（是）可使用现有文件。

    • 对于针对 1690 系列逻辑分析仪、脱机分析或远程连接逻辑分析系统运行 Agilent Logic Analyzer 应用程序的个人计算机上，可能必须从 Windows CD-ROM 复制文件。

  5. 系统将显示一个对话框，询问您是否希望重新启动计算机，单击 Yes（是）可重新启动计算机。

  6. 重新启动计算机后，启动 Agilent Logic Analyzer 应用程序，并选择 Help（帮助）> Help Language（帮助语言）> Japanese（日语）。

    这样便可以在访问联机帮助时获得日语版本了。


在 16900 系列机架上进行 CD 写入操作时出现问题

小心：

在向 16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器写数据时，必须将逻辑分析系统水平放置；否则，任何 CD-ROM 驱动器都可能无法读取由此生成的 CD-R/RW 光盘。

16900 系列逻辑分析系统的 DVD-ROM 和 CD-R/RW 组合驱动器支持：

  • 24 倍速 CD-R 写入。
  • 24 倍速 CD-RW 写入。
  • 24 倍速 CD-ROM 读取。
  • 8 倍速 DVD-ROM 读取。
  • DVD-RAM、DVD-R 和 DVD-RW 读取。

它还支持以下写入方法：

  • 整盘写入。
  • 区段写入。
  • 轨道写入。
  • 多区段写入。
  • 固定/可变数据包写入。


不支持休眠

16900 系列逻辑分析系统不支持休眠。

电源管理是通过控制面板中的“电源选项”图标来控制的。在“电源选项”对话框中可以找到“休眠”选项卡。此窗口中有一个用于启用/禁用休眠的复选框。请勿选中此复选框。该系列逻辑分析系统出厂时就不支持休眠。

如果启用了休眠，在安装了 16900 系列驱动程序的情况下，当逻辑分析系统试图进入休眠状态时，Windows 会生成以下对话：

    "The device driver for the 'Agilent 16900 Logic Analyzer' device is preventing the machine from entering hibernation.（‘Agilent 16900 逻辑分析仪’的设备驱动程序正防止机器进入休眠状态。）Please close all applications and try again.（请关闭所有的应用程序，再试一次。）If the problem persists, you may need to update this driver."（‘Agilent 16900 逻辑分析仪’的设备驱动程序正防止机器进入休眠状态。请关闭所有的应用程序，再试一次。如果问题仍然存在，您可能需要更新这个驱动程序。）

请注意，此消息只表示 16900 系列逻辑分析系统不支持休眠。


网络故障排除指南

  • 网络设置
  • 网络访问问题
  • 登录问题
  • 使用多机架
  • 网络硬件和配置
  • 网络拓扑
  • 已知的 OS 问题
  • 逻辑分析仪方面的问题
  • 保护系统和及时最新

网络设置

有关在网络上（和多机架配置中）设置 16900 系列逻辑分析系统的信息，请参阅 [image] 16900-Series Logic Analysis System Installation Guide。

  • 是否向 DNS 注册了该逻辑分析系统？
  • 是否向 DHCP 注册了该逻辑分析系统？

网络访问问题
  • 连接活动指示灯必须是亮的。如果这些 LED 不亮，则说明该局域网段可能已断网。
  • 能否通过网络从另一台计算机访问系统？
  • 注意：如果网络上没有 DHCP 服务器，则自动协商配置一个 IP 地址可能需要 5 分钟时间。在进行某一网络活动以前，请先用 ipconfig 确认 IP 地址不是 0.0.0.0。
  • 运行 ping 主机名 后将出现什么 IP 地址？
  • 运行 nslookup 主机名 后将出现什么 IP 地址？
  • 能否在 Windows 资源管理器中通过 UNC（\\主机名）访问系统？
  • 系统是否都在同一子网中？如果不是，它们有没有标准的 IP 地址（即不是以下某个‘不可路由’的 IP 地址）：
    • 10.x.x.x
    • 172.16.x.x
    • 192.168.x.x
    • 224.0.0.0（为多播保留）
  • 是否启用了 Windows XP 网络防火墙？如果是，其配置是否正确？（请参见更改 Windows XP 防火墙设置）

登录问题
  • 您是如何登录的？（是工作组还是域）。
  • 工作组登录和域登录在登录行为上是否有什么不同？

使用多机架
  • 各个系统上是不是都在运行 agLogicSvc.exe 服务？
  • 如果网线有变，则需要重新初始化 agLogicSvc.exe 服务，方法是停止并重启动该服务或重启操作系统。您是否进行了这种尝试？
  • Gb 级局域网上的所有 Gb 级局域网网卡都必须使用相同的“Jumbo Frames”设置（请参见局域网网卡的高级属性对话框）。另外，如果使用了交换机/集线器，则必须确保它们支持同尺寸的“Jumbo Frames”设置。

网络硬件和配置
  • 运行的是哪个 OS？（是 Windows 2000 还是 Windows XP）
  • 有多少网卡？（主板内置 100Base-T、Gb LAN）
  • 从命令提示符处运行 ipconfig /all 可查看详细的配置信息。
  • 从命令提示符处运行 ipconfig /release 可释放当前的 IP 地址。
  • 从命令提示符处运行 ipconfig /renew 可重新获取 IP 地址。

网络拓扑
  • 您用的是公用局域网，还是专用局域网？您用的是交叉线吗？是否存在多个网络？
  • 配置：
    • 单机
    • 1 块网络适配器 - 局域网。
    • 1 块网络适配器 - 交叉线。
    • 1 块网络适配器 - 专用（交换机或集线器）。
    • 2 块网络适配器 - 局域网 + 交叉线。
    • 2 块网络适配器 - 局域网 + 专用（交换机或集线器）。

已知的 OS 问题

  • SSDP 和 UPnP 服务是否在运行？（SSDP = 手动，UPnP = 自动）。

    在某些系统上，SSDP Discovery Service 会突然唤醒并启动，会占用大量 CPU 时间。该服务是一个‘手动’服务，用于侦听“通用即插即用”(Universal Plug-n-Play，UPnP) 请求，因此它会在收到特定的数据包时启动。

    出现这种情况时，SSDPSRW 任务会进入启动、停止、再启动循环过程中。

    要停止该服务，请选择我的电脑 > 管理 > 服务 > SSDP Discovery Service > 属性，并设置为停止。

    然后，将 SSDP 服务重新设置为手动。

    如果不这样做则可能会出现系统记录器淤塞以及其他难以处理的不良后果。

  • Computer Browser 是否在运行？如果所有系统都是 Windows XP，或者网络上有 DHCP 服务器，则可能没有必要运行 Computer Browser。此外，如果域名服务器是 NT 4.0，那么在网络上运行 computer browser 可能会封锁‘真正的’域服务器，无法保证网络用户正常登录。

逻辑分析仪方面的问题
  • 是否发现了与 Agilent Logic Analyzer 应用程序有关的问题（应用或服务）？（出现连接错误对话框、系统崩溃等）。

保护系统和及时最新
  • 使用 Windows Update 及时获得最新的重要更新和服务包。
  • 及时更新杀毒软件中的病毒定义。
  • 使用 InstallShield 包安装 Agilent Logic Analyzer 应用程序更新。
  • 本地管理员密码不要为空。


更多信息

文档

Quick Start/Installation Guide

Quick Start/Installation Guide 为您提供有关如何连接系统外围设备和进行探测的信息。此外，还包括界面概述和有关安装软件升级的信息。使用本指南可快速熟悉分析仪，亦可将其作为将来保证分析仪即时更新和正常运行的参考。

  • 16900-Series Logic Analysis System Installation Guide
  • 1680-Series Logic Analyzers Quick Start/Installation Guide
  • 1690-Series Logic Analyzers Quick Start/Installation Guide

探测文档

有关通用探测、QFP 组件包探测、目标连接器探测和无连接器探测以及其他探测方法的更多信息，请参见：

  • Probing Selection Quick Reference Card
  • Probing Solutions for Logic Analyzers（ [image] 网上最新版本）
  • Logic Analyzer Probing Solutions

有关分析探头及其他处理器和总线解决方案的更多信息，请参见：

  • Processor and Bus Support for Logic Analyzers（ [image] 网上最新版本）
  • Processor, Bus, and FPGA Support for Logic Analyzers

联机帮助系统

联机帮助为您提供产品参考和功能信息。此外，还包括介绍如何进行基本测量的指南，该指南可链接到各种省时的功能和概念。

Agilent Technologies 网站

公司/联系方式

  • 公司 - http://www.agilent.com
  • 联系我们 - http://www.agilent.com/find/contactus
  • 电子邮件更新 - http://www.agilent.com/find/emailupdates

产品信息

  • 逻辑分析 - http://www.agilent.com/find/logic
  • 1680/1690 系列软件下载 - http://www.agilent.com/find/1680-1690_software
  • 16900 系列软件下载 - http://www.agilent.com/find/16900_SW_Download
  • CD 上的软件 - http://software.cos.agilent.com/LogicAnalyzerSW

另请参见

  • 指南 － 逻辑分析仪入门
  • 内部支持


内部支持

因为 Agilent 16900 系列逻辑分析系统和 1680A/AD 系列逻辑分析仪是在 Microsoft Windows XP Professional 环境中工作的，所以内部支持将只涵盖 Agilent Logic Analyzer 应用程序。内部支持还会涵盖 Agilent Logic Analyzer 应用程序所利用的任何 Windows XP Professional 操作系统服务：

  • 通过 Agilent Logic Analyzer 应用程序打印。
  • 联网。
  • 通过 Agilent Logic Analyzer 应用程序进行文件管理。

因为 Agilent 1690A/AD 系列逻辑分析仪在作为其主机的桌面 PC 上运行，所以支持将只涵盖 Agilent Logic Analyzer 应用程序以及连接该 PC 的 IEEE 1394 接口。除上面列出的那些问题以外，内部支持将不涵盖其他 Windows XP Professional 操作系统问题。其他 Windows XP Professional 问题应由 Microsoft 负责解决。

注意：

对于客户在 Agilent 1680A,AD 系列产品上自行安装的任何应用程序，Agilent 都不提供支持。客户必须向相应的软件供应商寻求支持。

另请参见

  • 解决问题
  • 更多信息


概念

逻辑分析基础知识

  • 何时应使用示波器？
  • 何时应使用逻辑分析仪？
  • 什么是逻辑分析仪？

    定时分析仪：

    • 采样时钟
    • 采样
    • 触发

    状态分析仪：

    • 采样时钟
    • 采样
    • 触发

其他逻辑分析概念

  • 盒和通道的命名约定
  • 为什么盒会丢失?
  • 内存深度和通道数权衡
  • 跳变时序
  • 了解状态模式采样位置
  • 了解逻辑分析仪触发
  • ALA 与 XML 的各自使用场合
  • 多机架逻辑分析系统


何时应使用示波器？

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

一般而言，当您需要精确参数信息（如时间间隔和电压读数）时可以使用示波器。

具体来讲：

  • 当您需要测量信号的较小电压偏移（如低于或超出）时。

  • 当您需要较高的时间间隔精度时。示波器能够采集精确的参数信息，如脉冲的上升沿上两点之间的高精度时间。


何时应使用逻辑分析仪？

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

一般而言，逻辑分析仪用于查看多个信号之间的定时关系，或者当您需要在出现逻辑上限和下限码型时触发的情况下使用。当被测设备的信号超过电压阀值时，逻辑分析仪会表现出与逻辑电路相同的反应。它将识别信号的高低。

具体来讲：

  • 当您需要立即查看多个信号时。

    逻辑分析仪可以很好地组织和显示多个信号。一般任务是将多个信号组成一条总线并分配一个自定义名称。地址、数据和控制总线都是有代表性的示例。

  • 当您需要使用与硬件相同的方式查看系统中的信号时。

    信号显示在一个时间轴上，这样您就可以查看相对于其他总线信号或时钟信号的转变的发生时间。

  • 当您需要在出现唯一总线码型或信号时钟沿时触发的情况。

    当一组（总线）信号的上限值或下限值与预定义的码型相匹配时，可以对逻辑分析仪进行配置以存储数据。

    在单个信号上检测到特定时钟沿或电平时，可以对逻辑分析仪进行配置以存储数据。


什么是逻辑分析仪？

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

我们已经简短讨论了逻辑分析仪的一些用法，现在，让我们更详细地了解一下有关逻辑分析仪的概念。到目前为止，我们已经很广泛地使用了“逻辑分析仪”这一术语。实际上，大多数逻辑分析仪中都包含两个分析仪。

什么是定时分析仪？

定时分析仪是逻辑分析仪的一部分，它与示波器相似。事实上，它们之间的关系非常密切。

定时分析仪显示信息的一般形式，这一点与示波器相同，即横轴表示时间，纵轴表示电压振幅。因为两个仪器上的波形都取决于时间，所以这种显示可以说是“时间域”中的显示。

定时分析仪中的基本功能如下：

  • 定时分析仪中的采样时钟
  • 定时采集模式下的采样
  • 触发定时分析仪

什么是状态分析仪？

状态分析仪非常适用于跟踪软件中的缺陷或硬件中的缺陷组件。它有助于确定问题是出现在软件代码中还是出现在某些硬件设备中。

大多数情况下，状态分析仪用于在出现特定时钟信号时查找总线上存在哪些逻辑电平。换句话说，您可以了解在时钟出现且假设数据有效时将显示哪些“活动状态”。内存中采集的数据将以列表格式显示，且带有连接到各个状态的时间标签。

状态分析仪中的基本功能如下：

  • 状态分析仪中的采样时钟
  • 状态采集模式下的采样
  • 触发状态分析仪


定时分析仪中的采样时钟

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

定时分析仪使用自己的内部时钟控制数据采样。这种类型的时钟计时会使逻辑分析仪中的数据采样与被测设备中的时钟异步。

具体来讲：

  • 定时分析仪适用于显示信号活动“相当于其他信号”“何时”发生。

  • 定时分析仪侧重于查看各个信号之间的时序关系，而不是与被测设备中控制执行的信号之间的时序关系。

  • 这就是为什么定时分析仪可以对与被测设备时钟信号“不同步”或异步的数据进行采样。


定时采集模式下的采样

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

在定时采集模式下，逻辑分析仪的工作是对输入波形进行采样，从而确定它们是高电平还是低电平。为了确定高低，逻辑分析仪会将输入信号的电压电平与用户定义的电压阈值进行比较。如果采样时信号高于阈值，则分析仪将信号显示为 1 或高。同样，低于阈值的信号将显示为 0 或低。

下图阐释了当正弦波跨过阈值电平时逻辑分析仪对其进行采样的情况。

之后采样点被存储在内存中，并用于重建方形数字波形。

这种要使一切变成方形的处理方式似乎会限制定时分析仪的用处。不过定时分析仪本来也不是打算用作参数仪器的。若要查看信号的上升时间，可以使用示波器。若需校验几个或几百个信号之间的时序关系，对其同时进行查看，则定时分析仪才是正确的选择。

采样精度

定时分析仪对输入通道进行采样时，该通道信号或者是高电平或者是低电平。如果在进行某一采样时该通道处于某种状态（高或低），而在进行下一采样时变成了相反的状态，则分析仪可以“知道”输入信号已在这两个采样之间的某个时候发生了跳变。但它不知道具体在何时，因此它将跳变点放在了后一个采样上，如下图所示。

对于跳变实际上是在何时发生以及分析仪何时显示跳变，存在着某种含糊性。

假如跳变是在前一个采样点之后立即发生的，这种不确定性最多也就是一个采样周期。

不过对于这种方法，在精度和总采样时间之间也存在着一种折衷。请记住，每个采样点都只使用一个存储位置。因此，精度越高（采样频率越高），采样周期越短。


触发定时分析仪

[ 指南主页 ] [ 下一个主题 ] [ 上一个主题 ]

在测量中的某些点，逻辑分析仪必须了解何时采集（存储）流经其内存的数据。这些点叫做触发点。

使分析仪触发的一种方法是：相应地配置分析仪，使之从一组信号（总线）中查找上限或下限码型，或者查找单个信号的上升或下降时钟沿。当分析仪在数据中发现指定的码型或时钟沿时，它便触发。

码型触发

码型触发用于在总线上查找特定的上限和下限码型。您可以指定不同的标准，如等于、不等于、在或不在某个范围内或者大于/小于。

注意：

示例：您拥有一条包含 8 条信号线的总线。您配置了简单触发 以指定分析仪在输入数据等于“AA”码型时触发。

为了更便于某些用户的使用，大多数分析仪上的触发点不仅可以用十六进制进行设置，还可以用二进制（1 和 0）、八进制、ASCII 或十进制进行设置。例如，十六进制触发值 AA 还可以设置为等价的二进制触发值 1010 1010。但是，在 16、24、32 或 64 位宽的总线上查找时，使用十六进制设置触发点尤其有帮助。

时钟沿触发

时钟沿触发对于习惯使用示波器的用户来说是一个很熟悉的概念。调整示波器上的“trigger level”（触发电平）旋钮时，您可以将其视为设置电压比较仪的电平：当输入电压超过该电平时，电压比较仪会告知示波器触发。定时分析仪的时钟沿触发大体上与此相同，只不过将触发电平预先设置成了一个逻辑阈值。

许多逻辑设备依赖于电平，而这些设备的时钟和控制信号却往往受时钟沿的影响。通过时钟沿触发，您可以在对设备进行定时的同时开始采集数据。

注意：

示例：试想一个未正确移位数据的时钟沿触发移位寄存器。是数据有问题还是时钟沿有问题？为检测设备，我们需要在对其进行定时的同时检验数据（基于时钟沿）。可以告知分析仪在出现时钟沿时（无论上升或下降）采集数据并获取移位寄存器的所有输出。


状态分析仪中的采样时钟

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

状态分析仪需要来自被测设备的采样时钟信号。这种类型的时钟计时可使逻辑分析仪中的数据采样与被测设备中的计时事件同步。

具体来讲：

  • 状态分析仪适用于显示“有效时钟或控制信号”期间的信号活动是“什么”。

  • 状态分析仪侧重于查看指定执行时间内的信号活动，而不是与时序无关的信号活动。

  • 这就是为什么状态分析仪需要对与被测设备时钟信号“同步化”或同步的数据进行采样。


状态采集模式下的采样

[ 指南首页 ] [ 下一主题 ] [ 上一主题 ]

对于微处理器，数据和地址可以出现在相同的信号线上。要采集正确的数据，逻辑分析仪必须对数据采样加以限制，使之只在所需的数据有效并出现在信号线上时进行。为此，它会从相同的信号线上采集数据样本，但使用来自被测设备的不同采样时钟。

注意：

示例：以下时序图表明，要采集地址，分析仪需要在 MREQ 线下降时进行采样。

要采集数据，分析仪需要在 WR 线下降（写周期）或 RD 线下降（读周期）时进行采样。


触发状态分析仪

[ 指南主页 ] [ 下一主题 ] [ 上一主题 ]

与定时分析仪相似，状态分析仪也具有限定要存储的数据的功能。如果我们正在查找地址总线的上限和下限的特定码型，当分析仪找到该码型时，我们可以通知分析仪开始存储，并且只要分析仪的内存未满就一直存储。

简单触发示例

请看下面显示的“D”触发器，在正值的时钟沿出现之前，“D”输入上的数据是无效的。因此，时钟输入为上限时，触发器的状态才有效。

现在，假设我们有并行的八个此类触发器。如下所示，这八个触发器都连接到同一时钟信号。

当时钟线上出现高电平时，所有这八个触发器都会在其“D”输入处采集数据。此外，每次时钟线上出现正电平时都会发生有效状态。

下面的简单触发指示分析仪在时钟线上出现高电平时在 D0 - D7 这几条上收集数据。

高级触发示例

假设您想查看地址值为 406F6 时内存中存储了哪些数据。您对高级触发进行配置，以在地址总线上查找码型 406F6（十六进制）以及在 RD（内存读取）时钟线上查找高电平。

在配置 Edge And Pattern trigger（时钟沿和码型触发）对话框时，尝试将该操作看作是构造从左向右读取的句子。

"Find the first occurrence of a Bus named ADDR, and on All bits a pattern that Equals 406F6 Hex, And a Signal named RD with a High level.Then Trigger and fill memory with Anything.


盒和通道的命名约定

在 16900 系列逻辑分析系统中：

  • 插槽从上到下以 A 至 F 字母命名。

  • 有一条标有 Pod 2 的电缆连接着每一个逻辑分析仪卡。知道某个盒连接到哪个插槽很重要，因为如果在插槽 A 和 B 中都有逻辑分析仪卡，则将有两条盒电缆标有 Pod 2，但 Agilent Logic Analyzer 应用程序会把一条记作 Slot A Pod 2，把另一条记作 Slot B Pod 2。分清这两条电缆很重要。

  • Slot A Pod 2 等于 Pod A2。A2 与 Slot A Pod 2 可互相替代；同样，D1 与 Slot D Pod 1 也可互相替代。

在 16900 系列逻辑分析系统和 1680/1690 系列逻辑分析仪中：

  • 时钟盒 (Clock Pod) 由模块中所有盒的所有时针通道组成。

  • 每个盒各有一个时钟通道。所有时钟通道按 Clk1、Clk2、Clk3 等进行编号。如果某逻辑分析仪模块有两个逻辑分析仪卡，每卡有四个盒，则该逻辑分析仪的时钟通道标记为 Clk1 至 Clk8。

  • 除了 Clk1 外，时钟通道还可标记为 C1。C1 和 Clk1 是一样的。

在 16900 系列逻辑分析系统中，请勿混淆时钟通道 C2 与 Slot C 中的 Pod 2，后者记作 Pod C2。对于时钟通道，C 是 Clock 的缩写，不是 Slot C 的缩写。


为什么盒会丢失?

导致所有盒对逻辑分析仪模块均不可用的原因有多种：

  • 在状态采样模式中，在选择了一般状态模式 采样选项的情况下，选择最大采集内存深度需要将一个盒对保留用于时间标签存储。在这种情况下，将内存深度设置为最大值的一半（或更小）将返回盒。

  • 在状态采样模式中，在选择了涡轮状态模式 采样选项的情况下，会将一个盒对保留用于时间标签存储。

  • 在定时采样模式中，在选择了跳变/存储限定定时模式 采样选项的情况下：

    • 选择了最小采样周期时，会将一个盒对保留用于时间标签存储。

    • 选择了除最小采样周期之外的采样周期时，选择最大采集内存深度需要将一个盒对保留用于时间标签存储。在这种情况下，将内存深度设置为最大值的一半（或更小）将返回盒。

  • 该模块是已分离的逻辑分析仪的一部分。在这种情况下，盒位于分离分析仪的另一半模块中。

另请参见

  • 内存深度和通道数权衡
  • 配置逻辑分析仪模块


内存深度和通道数权衡

本主题将介绍在以下两种模式下通道数、内存深度和触发之间的相互影响：

  • 状态采样模式
  • 跳变时序采样模式

注意：

在 16760 逻辑分析仪中，内存深度和通道数之间的权衡会略有不同（请参见 16760 逻辑分析仪的内存深度和通道数权衡）。

状态采样模式

时间标签存储需要 1 个盒对或 1/2 的采集内存

  • 在 Agilent Logic Analyzer 应用程序中，所有模块都与时间相关；不能关闭 time tag storage（时间标签存储）（虽然以前的 Agilent 逻辑分析系统可以）。

  • 要使用 1/2 以上的模块采集内存，必须将一个盒对 保留用于时间标签存储。要使用所有盒对，内存使用量不能超过模块采集内存的 1/2。

  • 一般来说，可用定时器数与那些不属于为时间标签存储而保留的盒对数相同（请参阅逻辑分析仪特性，了解实际的可用定时器数）。

默认设置

  • 时间标签存储始终处于开启状态（并且不能将其关闭）。
  • 内存深度设置为总采集内存的 1/2。
  • 所有盒对都可用于采集数据。
  • 如果选择整个内存，则要用于时间标签存储的默认盒对是最左边的盒对，但未分配总线或信号的任何盒对都是可以使用的。

在某一盒对未分配任何通道时选择整个内存深度

  • 该盒对自动保留用于时间标签存储。

在所有盒对都分配了通道时选择整个内存深度

系统将显示对话框，发出以下警告：

  • Bus/signals will lose assigned channels.（总线/信号将失去分配的通道。）
  • Trigger specifications that use timer resources may be affected.（使用定时器资源的触发设定可能会受到影响。）

从整个内存深度转为一半内存深度

  • 自动释放为时间标签存储保留的盒对（分配给逻辑分析仪），因此该盒对可用于采集数据。

拆分分析仪

在 Split Analyzer Setup（拆分分析仪设置）对话框中可以：

  • 指定是否应将盒对保留给时间标签存储。

跳变时序采样模式

时间标签存储需要 1 个盒对或 1/2 的采集内存

  • 跳变时序采样模式也需要时间标签存储。

  • 当选择最小采样周期时，必须将一个盒对 保留用于时间标签存储。在这种情况下，不能使用 1/2（或更少）的模块采集内存来替代该盒对。

  • 对于其他采样周期，内存深度和通道数的权衡与状态采样模式下的相同。也就是说，要使用 1/2 以上的模块采集内存，必须将一个盒对 保留用于时间标签存储。要使用所有盒对，内存使用量不能超过模块采集内存的 1/2。

  • 一般来说，可用定时器数与那些不属于为时间标签存储而保留的盒对数相同（请参阅逻辑分析仪特性，了解实际的可用定时器数）。

默认设置

  • 时间标签存储是必需的。
  • 如果选择整个内存，则要用于时间标签存储的默认盒对是最左边的盒对，但未分配总线或信号的任何盒对都是可以使用的。

另请参见

  • 配置逻辑分析仪模块
  • 设置采集内存深度
  • 选择采样模式


跳变时序

在 Transitional / Store qualified（跳变/存储限定）定时模式中，定时分析仪将定期对数据进行采样，但只有当阈电压电平中存在信号转变时才存储数据。每当定义的总线/信号（未排除的）中的任何位发生转变时，都要存储所有通道上的数据。为每个存储数据样本存储一个时间标签，这样稍后就可以重新构建和显示测量。

有关存储转变的更多信息

存储的最小转变量

通常，各个采样点不会发生转变。下面将用时间标签 2、5、7 和 14 来举例说明。当确实发生转变时，为每个转变存储两个样本。因此，存储 1K 的转变，就会带有 2K 内存的样本。必须去除一个起始点必需的转变才能使存储的最小转变量达到 1023。

存储的最大跳变量

如果转变发生的速率很快，例如每个采样点都有一个转变，那么如下图中的时间标签 17 至 21 所示，只为每个转变存储一个样本。如果整个跟踪过程始终保持这种状况，那么存储的转变数量为 2K 样本。此外，必须去除起始点样本，这样才能使存储的最大跳变量不超过 2047。

大多数情况下，当最小转变量和最大转变量都存在时会存储跳变时序跟踪。因此，在此例中存储的实际转变量将在 1023 和 2047 之间。

跳变时序注意事项

数据存储

检测到时钟沿时，在分配给定时分析仪的所有通道中存储两个样本。如果在时钟沿检测器重置之前出现第二个时钟沿（在第一个时钟沿后），为避免数据丢失需要两个样本。

序列步骤分支

在跳变时序中，每个序列步骤只有 2 个分支。

全局计数器

在跳变时序中，只有一个全局计数器可用。

存储时间标签

跳变时序需要有时间标签才能重建数据。通过将时间标签与内存中的测量数据交叉可存储时间标签。

增加存储持续时间（测量的时间长度）

默认情况下，分析仪将查找为逻辑分析仪模块定义的所有总线/信号上的转变。但是，为增加可用内存深度和采集时间，您可以在 Advanced Trigger（高级触发）对话框中选择不存储某些总线/信号转变（如将无用信息添加到测量中的时钟或选通脉冲信号）。

未分配通道上的数据

运行测量时，无论总线/信号是否定义或是否分配给逻辑分析仪通道，都将在所有这些通道上采集数据。在跳变时序模式中，如果定义的 总线/信号（未排除的）上存在转变，将保存采集的样本。

运行跳变时序测量后，如果为以前未分配的逻辑分析仪通道定义新的总线/信号，那么将显示在这些通道上采集的数据，但是不可能存储这些总线/信号上的所有转变；显示的数据好似新的总线/信号在运行测量前就已经被排除了。

触发位置

在跳变时序中，不需要预先存储数据（触发前获得的样本）。因此，与状态模式非常相似的是，触发位置（起始/中心/结束）表明触发后样本占用内存的百分比。触发前获得/显示的样本数量在不同的测量中会有所变化。


了解状态模式采样位置

同步采样（状态模式）逻辑分析仪与触发时钟沿的触发相似，因为它们都需要输入逻辑信号才可以在时钟事件（设置时间）前和时钟事件（维持时间）后的一段时间内保持稳定，以便正确解释逻辑电平。组合设置和维持时间被称为设置/维持窗口。

被测设备（由于其本身的设置/维持要求）可指定数据在某段时间内在总线上有效。这被称为数据有效窗口。一般情况下，大多总线上的数据有效窗口小于总线时间周期的一半。

要精确采集总线上的数据，需符合以下条件：

  • 逻辑分析仪的设置/维持时间必须在数据有效窗口内拟合。

  • 由于与总线时钟有关的数据有效窗口的位置根据总线类型的不同而有所变化，因此逻辑分析仪的设置/维持窗口的位置在数据有效窗口中必须是可调整的（相对于采样时钟，且具有较高分辨率）。例如：

为了将设置/维持窗口（采样位置）放置在数据有效窗口内，逻辑分析仪可在每次采样输入时调整延迟（以定位每个通道的设置/维持窗口）。

单个通道的样本位置调整

如果可以在单个通道上调整采样位置，您可以使逻辑分析仪的设置/维持窗口变小，因为您可以校准由探头电缆和逻辑分析仪的内部电路板跟踪引起的偏移效应，而且您还可以看到逻辑分析仪的内部采样电路的设置/维持要求。

但是，手动定位每个通道的设置/维持窗口需要花费大量时间。对于被测设备中的每个信号和每个逻辑分析仪通道来说，必须测量与总线时钟（带有示波器）相关的数据有效窗口，重复定位设置/维持窗口并运行测量以查看逻辑分析仪是否正确采集数据，最后再将设置/维持窗口定位在错误采集数据的位置之间。

使用具有眼定位 功能的 Agilent Technologies 逻辑分析仪，在手动调整（没有额外的被测设备）的一小段时间内，您可以自动：

  • 定位每个通道上的设置/维持窗口。

  • 针对尽可能宽的数据有效窗口调整阈电压设置。

眼定位 是获得尽可能小的逻辑分析仪设置/维持窗口的一种简单方法。

眼定位概要

对于指定的状态采样时钟，眼定位 可在时钟沿前后的一个固定时间范围内查找数据信号转变（阈电压交叉点），并为您显示相关内容以帮助设置最佳采样位置。

为了了解眼定位 显示，需为每个活动时钟沿拍摄一张有关该时钟沿的数据信号转变的“照片”。将此照片看作快照、定格画面或频闪观测仪（位于时钟沿中心或与时钟沿同步）。到达时钟沿的时间为 T=0。

例如，如果您选择盒 1 上时钟输入的上升沿作为状态采样时钟，每次拍摄“照片”时，都将达到盒 1 时钟上的上升沿。盒 1 时钟沿之间的时间是否相同无关紧要。如果您同时在上升沿和下降沿上进行采样，那么在每一个时钟沿上都会拍摄一张“照片”。此外，在活动沿之间消耗了多少时间也不重要。每一个时钟沿上都要拍摄“照片”。

要构建眼定位 显示，需要将无数张这样的“照片”堆叠在彼此的顶端。每张“照片”都在 T=0 时对齐，此时将达到活动时钟沿。照片拍自上升沿还是下降沿并没有关系；它们会在 T=0 时对齐。构建显示后，您就无法区分给定信号转变区域是与时钟上升沿相关联，还是与下降沿（或两者）相关联。

眼定位的工作方式

通过逻辑分析仪使用少量的偏移延迟对每个通道进行双重采样的功能，以及通过使用独有的 OR 操作比较延迟的样本可进行眼定位 测量。

当独有的 OR 输出很高时，延迟的样本会有所差别，并且会在延迟时间之间检测到转变。

由于采样信号的不稳定和其他变化，眼定位 测量将对每对延迟值的多个时钟进行检查，以便报告两次延迟时间之间发生转变的频率。

然后，检查另一对延迟值，依次类推，直到扫描完转变的整个时间范围。

因为逻辑分析仪可以调整通道的阈电压，所以眼定位 测量可在很多阈电压电平随着时间的推移对转变进行重复扫描。

通过调整阈电压和查看活动指示符，眼定位 可查找信号活动信封并确定最佳阈电压；然后通过在该阈值执行全时扫描，眼定位 可找出样本位置。

您也可以在当前阈电压设置下运行全时扫描，以便仅自动设置采样位置。

自动阈值和采样位置设置扫描通常足以确保正确采集数据，但它还可以识别您想要进一步详细查看的信号（例如，如果您想查看延迟、衰减等）。

通过在整个信号活动信封内执行全时扫描，眼定位 可以显示在时间和电压的小窗口中检测到的转变。这些扫描称为 eye scan。像示波器一样，眼视图用于显示测量数据。每个窗口中的转变数量都会突出显示。这可以使您概览眼型图案，并确定是否需要使用示波器来进一步详细地查看信号。

您可以运行导致自动设置阈电压和采样位置的 eye scan，或运行只导致自动设置采样位置的 eye scan。

眼定位 测量收集数据所基于的通道数量会影响测量时间。当一个模块中存在多个逻辑分析仪卡时将出现异常；在这种情况下，测量将同时并行运行。

另请参见

  • 自动调整状态采样位置和阈电压
  • 手动调整状态采样位置
  • 选择状态模式（同步采样）
  • Thresholds and Sample Positions（阈值和采样位置）对话框


支持差分信号的逻辑分析仪中的 Eye Scan

支持差分信号的逻辑分析仪（如 16753/54/55/56、16760 和 16950 逻辑分析仪）针对输入使用真值差分接收器：

可编程参考电压将计入负输入。这是分析仪采用单端探头时的阈电压。对于差分探测的相关操作，通常将参考电压编写为 0V：

随后将接收器的输出与 0V 进行比较，从差分输入信号产生内部逻辑信号。请注意，最终比较结果将对“差分信号高于 Vref 还是低于 Vref？”的问题作出解答：

对眼隙的 eye scan 测量是通过使用不同 Vref 设置进行一系列 eye finder 测量完成的。差分信号的默认 eye finder 测量使用 Vref=0V。通过将 Vref 增至零以上，我们会找到信号与上升的 Vref 值交叉的位置。如果 Vref 升至足够高，信号的顶部轨迹将通过 Vref，我们便会看到眼的顶端。再将 Vref 升高一点会导致 Vcomp 保持在 Vlo，表示信号不会升至该电平。反之，将 Vref 移至零以下会看到眼的下半部。

eye scan/eye finder 显示窗口会在每个信号的 eye scan 图下方显示 eye finder 交叠部分，以此显示 eye finder 与 eye scan 之间的这一关系。通过在 eye scan 图中将 Vth 水平线向上和向下移动，可以获得距离眼中心该偏移量位置处的 eye finder 视图。

无论用户界面中的阈值如何设置，逻辑分析仪的差分输入将始终 应用于接收器。这意味着您可通过将电压阈值手动设置为非零值允许在差分对中使用公共模式电压。如果信号摆幅中心与地线差距大于 100 mV，eye scan 将自动执行此操作。


了解逻辑分析仪触发

设置逻辑分析仪触发非常困难，而且还需花费大量时间。假设如果您知道如何编程，则应该可以毫不费力地设置逻辑分析仪触发。然而，这是不可能的，因为许多概念对逻辑分析来说都是唯一的。本节的目的就是介绍这些主要概念及如何有效地使用它们。

  • 传送带模拟
  • 触发功能摘要
  • 序列步骤
  • 布尔逻辑表达式
  • 分支
  • 时钟沿
  • 范围
  • 标志
  • 发生计数器和全局计数器
  • 定时器
  • 存储限定
  • 触发的设置策略
  • 总结

另请参见

  • 从被测设备中采集数据


传送带类比

我们可以将逻辑分析仪的内存比作一条很长的传送带，而从被测设备 (DUT) 获取的样本就像是传送带上的箱子。新的箱子被放置在传送带一端，而在另一端落下。换句话说，由于逻辑分析仪内存的深度（样本数量）有限，因此每当采集新样本时，如果内存已满，将会删除内存中现有的最旧的样本。如下图所示。

传送带类比

逻辑分析仪触发就像是放置在传送带（上面放置有多个箱子）起始位置上的箱子一样。它们的任务是“查找特殊的箱子，并在该箱子到达传送带的某一特定位置时停止运行传送带”。在此类比中，特殊的箱子就是触发。逻辑分析仪检测到与触发条件相匹配的样本后，就表示当触发位于内存中的适当位置时应停止继续采集样本。

触发在内存中的位置被称为触发位置。通常，触发位置被设置在中间，以便使触发前后出现的样本的最大数量不超出内存范围。不过，您也可以将触发位置设置在内存中的任意位置。

下表总结了此类比中的概念。

传送带类比到逻辑分析仪的概念映射

传送带类比 | 逻辑分析仪
传送带上的箱子 | 从被测设备采集的样本
传送带上的箱子数 | 内存深度
特殊的箱子 | 触发点

下一节：触发功能摘要


触发功能摘要

由于逻辑分析仪触发提供了大量功能，因此下表将对本文中介绍的功能进行简要概述。该表将对这些功能进行逐一描述。

逻辑分析仪触发功能摘要

功能 示例

时钟沿

If there is rising edge on SIG1 then Trigger
If there is falling edge on SIG1 then Trigger

布尔逻辑表达式

If ADDR = 1000 and DATA = 2000

范围

If ADDR in range 1000 to 2000

存储限定

1. If..
Else If ADDR in range 1000 to 2000 then
Store Sample
Go to 1
Else If ADDR not in range 1000 to 2000 then
Don't Store Sample
Go to 1

计数器

1. If DATA = 1000 Then
Increment Counter 1
Go to 2
2. If Counter 1 > 2 Then
Trigger

定时器

1. If DATA = 1000 Then
Start Timer 1
Go to 2
2. If Timer 1 > 500 ns Then
Trigger

下一节：序列步骤


序列步骤

虽然逻辑分析仪触发通常很简单，但它们却需要复杂的程序。例如，您可能想在某一信号的上升沿后跟另一信号的上升沿时触发。这意味着逻辑分析器必须在开始寻找下一个上升沿之前找到第一个上升沿。由于拥有一个可查找触发的步骤序列，因此它被称为触发序列。序列的每个步骤被称为一个序列步骤。

每个序列步骤由两部分组成：条件和操作。条件是指布尔逻辑表达式，例如“If ADDR = 1000”或“If there is a rising edge on SIG1”。操作是指符合条件时逻辑分析仪应当执行的内容。操作的示例包括触发逻辑分析仪、转至另一序列步骤以及启动定时器。这类似于编程中的 If/Then 语句。

触发序列中的每个步骤都被指定一个数字。执行的第一个序列步骤总是序列步骤 1，但由于“转到”操作，剩余的序列步骤可以以任意顺序执行。

执行一个序列步骤且布尔逻辑表达式均为假时，逻辑分析仪将采集下一样本并再次执行同一序列步骤。例如一个简单的示例，考虑以下触发序列：

1. If DATA = 7000 then Trigger

如果采集以下样本，逻辑分析仪将在采集样本 #6 时触发。

样本号   ADDR  DATA
   1       1000  2000
   2       1010  3000
   3       1020  4000
   4       1030  5000
   5       1040  6000
   6       1050  7000  <- 此处为逻辑分析仪的触发位置
   7       1060  2000

实际上，序列步骤 1 相当于“Keep acquiring more samples until DATA=7000, then trigger”。

如果符合一个序列步骤中的布尔逻辑表达式，那么在执行下一序列步骤之前总是采集另一样本。换句话说，如果一个样本符合序列步骤 1 的条件，在执行序列步骤 2 前将采集另一样本。这意味着一个单独的样本不可能符合多个序列步骤的条件。每个序列步骤都可以看作是代表了在不同点及时发生的事件。两个序列步骤可以从不用于指定同时发生的两个事件。

例如，考虑以下触发序列：

1. If ADDR = 1000 then Go to 2
2. If DATA = 2000 then Trigger

如果采集以下样本，逻辑分析仪将在采集样本 #7 时触发。

样本号   ADDR  DATA
   1       1000  2000  <- 此样本符合序列步骤 #1 中的条件
   2       1010  3000
   3       1020  4000
   4       1030  5000
   5       1040  6000
   6       1050  7000
   7       1060  2000  <- 此处为逻辑分析仪的触发位置

请注意，由于在符合序列步骤 1 中的条件和测试序列步骤 2 中的条件二者之间采集了新的样本，因此逻辑分析仪不会在采集样本 #1 时触发。可将此触发序列看作是“Find ADDR = 1000 followed by DATA = 2000 and then trigger”。触发序列中的多序列步骤暗示了“后接”。

逻辑分析仪触发后，将不会再次触发。换句话说，即使度个样本符合触发条件，逻辑分析仪也只触发一次。例如，使用“ADDR=1000”作为触发，如果逻辑分析器采集以下样本，它将会在采集样本 #2 时触发，并且只在采集样本 #2 时触发。

样本号  ADDR
   1       0000
   2       1000  <- 此处为逻辑分析仪的触发位置
   3       2000
   4       1000  <- 逻辑分析仪不会在此处再次触发
   5       1040

一个经常遇到的问题是“如果不符合序列步骤中的条件会怎样？”例如，有一个条件是“If ADDR = 1000 Then Trigger”，那么如果当前样本是 ADDR = 2000，结果会怎样？逻辑分析仪只采集下一样本并试图再次执行此序列步骤。实际上，如果触发条件是“ADDR = 1000”，这相当于“持续采集样本直到找到条件为 ADDR=1000 的样本”。因此，如果设置一个从不符合的触发条件，逻辑分析器将不会触发。

当符合序列步骤中的条件时，使用“转到”操作时下一步将执行哪个序列步骤将会非常清楚，但是如果没有使用“转到”操作，则不可能知道执行哪个序列步骤。在一些逻辑分析仪上，如果没有“转到”，这意味着应当执行下一序列步骤。在其他逻辑分析仪上，意味着将再次执行同一序列步骤。由于比较混乱，最好使用“转到”操作而不依靠默认。状态和定时模块通过在每个序列步骤中自动包含一个“转到”或“触发”操作来解决这一问题。例如：

If ADDR = 1000 and DATA = 2000 then
Go to 1   <- 这是自动添加的

下一节：布尔逻辑表达式


布尔逻辑表达式

当多个序列步骤表示“后跟”时，可以在序列步骤内使用布尔逻辑表达式。示例：

If ADDR = 1000 and DATA = 2000

此表达式意指在同一样本中 ADDR 必须等于 1000 且 DATA 等于 2000，才能符合此表达式。换句话说，在 ADDR 等于 1000 的同时 DATA 等于 2000。因此，如果要在同时发生两个事件时触发，则应使用布尔逻辑表达式。

常见错误是应使用布尔逻辑表达式时尝试使用两个序列步骤，或者应使用两个序列步骤时尝试使用布尔逻辑表达式。

NOTE:

当多个事件同时发生时使用布尔逻辑表达式，而在一个事件接着一个事件发生时使用多个序列步骤。

下一节：分支


分支

分支类似于 C 编程语言中的 Switch 语句和 Basic 中的 Select Case 语句。分支可提供测试多个条件的方法。每个分支都有其独有的操作。下面是多分支的一个示例：

1. If ADDR < 1000 then Go To 2        <- This is a branch of Level 1
   Else If ADDR > 2000 then Go To 3   <- This is a 2nd branch of Level 1
   Else If DATA = 2000 then Trigger   <- This is a 3rd branch of Level 1
2. If DATA <= 7000 then Trigger
3. If there is a Rising Edge on SIG1, then Trigger

在序列步骤 1 中，存在三个分支，因此存在三个可以采用的操作。

如果符合某一分支的条件，则不对其下面的任何分支进行测试。换句话说，无法根据单个样本执行多个分支，即使该样本可导致符合多个分支条件。也就是说，每个分支都是一个“Else If”。

下一节：沿


沿

沿表示单个信号从下到上或从上到下的转变。通常，沿被指定为“上升沿”、“下降沿”或“任一时钟沿”，其中“上升沿”表示从下到上的转变。在大多数逻辑分析仪上，触发序列中最多可包含两个沿，而有些则只允许包含一个沿。

下一节：范围


范围

指定值的范围是划分范围的一种便捷方式，如“1000 到 2000 范围内的 ADDR”。大多数逻辑分析仪还支持“not in range”功能。范围是一种方便的快捷方式，因此您无需指定“ADDR >= 1000 and ADDR <= 2000”。

下一节：标志


标志

标志是用于从一个模块向另一个模块发送信号的布尔变量。当某种情况在某一模块中发生而稍后被另一模块测试时可以设置标志。在下面的示例中，标志 1 用于跟踪在模块 1 的触发序列中发生的情况，以便在模块 2 中使用此信息。

模块 1 的触发序列：

1. If ADDR < 5000 then
     Set Flag 1
     Trigger and fill memory

模块 2 的触发序列：

1. If DATA = 5000 and Flag 1 is set then Trigger
   Else if DATA = 1000 and not Flag 1 then Trigger

注意：

标志在 1680/1690 系列逻辑分析仪中不可用。

下一节：发生计数器和全局计数器


发生计数器和全局计数器

发生计数器用于想要查找事件的“第 N 次”出现的情况。例如，如果想在 ADDR = 1000 第 5 次出现时触发，可以将触发设置为：

If ADDR = 1000 occurs 5 times then Trigger

全局计数器类似于整数变量。全局计数器比发生计数器更灵活，因为它们可用于为复杂事件（例如一个时钟沿后跟另一时钟沿的事件）计数。可以增加、测试和重新设置全局计数器。默认情况下，全局计数器以零开头并且不需要重新设置，除非已在触发序列中使用了它们。一般情况下，如果可能的话，应使用发生计数器代替全局计数器，原因是发生计数器的用法比较简单，而且全局计数器的数量有限。

下一节：定时器


定时器

定时器用于检查事件之间消耗的时间。例如，如果您想在出现一个时钟沿后的 500 ns 内出现另一个时钟沿的情况下引发触发，请使用定时器。使用定时器时要记住的最关键一点是：先启动定时器，然后再对其进行测试。换句话说，定时器无法自动启动。

设置定时器的关键是确定在何种情况下进行启动和测试。考虑下图中的示例。应在检测 SIG1 上的上升沿时启动定时器，并在 SIG2 上发生上升沿时测试定时器。

后跟一个带有时间限制的时钟沿的时钟沿

设置此测量的触发序列示例为：

1. If there is a Rising Edge on SIG1, then
     Start Timer1
     Go to 2
2. If there is a Rising Edge on SIG2 AND Timer1 < 500ns then
     Trigger

以上触发序列看上去是正确的，但它实际上存在一个严重的漏洞。如果 SIG1 上存在上升沿，而 SIG2 没有在 500 ns 内发生，那么结果会怎样？逻辑分析仪将不再触发，因为定时器 1 将保持运行且不再满足条件“定时器 1 < 500 ns”。稍后发生的 SIG2 上的上升沿在 500 ns 内跟随 SIG1，此 SIG1 上可能存在另一个上升沿，因此这种情况是不可取的。

要解决此问题，当定时器超过 500 ns 且没有触发时，序列就应返回到电平 1 以查找 SIG1 上的其他上升沿。下面显示了一个正确序列示例：

1. If there is a Rising Edge on SIG1, then
     Start Timer1
     Go to 2
2. If there is a Rising Edge on SIG2 AND Timer1 < 500ns then
     Trigger
   Else If Timer1 >= 500ns then
     Reset Timer1
     Go to 1

有时，定时器可能会耗尽。如果逻辑分析仪定期进行采样（即，如果它处于定时采样模式），则可以使用计数器来代替定时器。通过计算所得样本的数量可模拟定时器。例如，如果逻辑分析仪每 10 ns 获取一个新样本，共获得了七个样本，这表示 70 ns。

下一节：存储限定


存储限定

存储限定用于确定应该存储（即，存入内存）还是丢弃已获得的样本。这可以避免不需要的样本占用逻辑分析仪内存。

默认存储

设置存储限定最简单的方法是设置“默认存储”。默认存储表示“如果未经序列步骤指定，则进行存储”。例如，您可能只想在 ADDR 的范围为 1000 到 2000 时存储样本，那么就应将“默认存储”设置为：

ADDR In Range 1000 to 2000

默认情况下，“默认存储”设置为存储所有已获得的样本。您也可以将“默认存储”设置为不存储任何样本，这意味着除非某序列步骤覆盖该默认存储，否则将不存储任何样本。

序列步骤存储

序列步骤存储限定意味着在某个特定的序列步骤内只存储特定的样本。这意味着在使用 Go To（转到）或 Trigger（触发）操作离开此序列步骤之前，应用该存储限定。如果要为每个序列步骤应用不同的存储限定，该存储限定很有用。例如，您可能不希望在 ADDR = 1000 之前存储任何样本，而对于其余的测量，只存储 ADDR 在 1000 到 2000 范围之内的样本。

设置序列步骤存储还需要再使用一条分支指令。例如，在查找 DATA=005E 时，如果您只希望存储 ADDR 在 5000 到 6FFF 范围之内的样本，某些情况下可使用以下序列步骤：

1. If DATA = 005E then Trigger
   Else If ADDR in range 5000 to 6FFF then
     Store Sample
     Go to 1

注意存储样本操作的使用。这表示“立即存储内存中最新获得的样本”。而不 表示“从现在起，开始存储”。应当注意，因为当 ADDR 不在 5000 到 6FFF 范围之内时从不执行存储样本操作，所以该分支指令实质上是指“在此序列步骤中，只存储 ADDR 在 5000 到 6FFF 范围之内的样本”。

上述示例似乎说明将只存储 ADDR 在 5000 到 6FFF 范围之内的样本。但是，这取决于默认存储的设置方式。还是使用上述示例，如果默认存储设置为“Store Everything”（存储所有样本）并且有一个样本不在 5000 到 6FFF 的范围之内，则不会执行 Else If 分支指令，而应用该“默认存储”。实际上，该序列步骤说明了样本值在特定范围内时要执行的操作，但没有说明样本值在此范围之外时应执行的操作。因此，如果要明确指定序列步骤存储，请使用以下指令：

1. If DATA = 005E then Trigger
   Else If ADDR in range 5000 to 6FFF then
     Store Sample
     Go to 1
   Else If ADDR not in range 5000 to 6FFF then
     Don't Store Sample
     Go to 1

此外，如果默认存储设置为“Store Everything”（存储所有样本），可以使用以下指令：

1. If DATA = 005E then Trigger
   Else If ADDR not in range 5000 to 6FFF then
     Don't Store Sample
     Go to 1

总之，序列步骤存储总会覆盖默认存储，但只针对序列步骤存储中特别指定的条件。处理默认存储和序列步骤存储之间的冲突时一定要谨慎。

下一节：触发的设置策略


触发的设置策略

  • 触发函数
  • 设置复杂触发
  • 保存触发序列并为其附加说明


触发函数

虽然设置逻辑分析仪很困难，但触发函数 可以大大降低此过程的难度。触发函数是可以组合起来设置触发的常用构建块。由于这些函数涵盖了大多数普通触发，因此通过选择适当的函数并将其填充到数据中即可设置触发。下图显示了逻辑分析仪触发用户界面。请注意，触发函数位于屏幕左侧的一个醒目位置。

触发用户界面

请注意，鼠标停留在触发函数按钮上时会显示一张图片（对应于所选函数）。

例如，如果要在总线码型后紧跟另一个总线码型时触发，可以将“Pattern1 immediately followed by Pattern2”触发函数拖放到触发序列步骤中，如下图所示。

码型 1 后紧跟码型 2

选择此函数后，您可以很容易地填充总线和码型的名称。将上图与下面这张图进行对比，它是使用 If/Then 语句创建的同一触发。触发函数使用起来比较简单，原因是隐藏了 If/Then 语句的附加详细信息。但是，如果您想查看详细信息，可以将触发步骤显示为 if/then。

与 If/Then 语句相同的触发

您可以修改触发函数。例如，如果从函数“Find Edge”开始，您可以添加另一个事件，且该事件将与“Find Edge and Pattern”相同。因此，不是十分匹配的函数通常可以转换为所需的触发。也可以将触发序列步骤转换为高级 If/Then 触发函数并对其进行修改。

触发函数类似于构建块，因为它们可以在触发序列中一起使用。例如，如果您想将触发设置为“Find edge followed by pattern”，则可以针对电平 1 使用“Find Edge”函数，针对序列电平 2 使用“Find Pattern”函数（参见下图）。因此，函数既可以用作整个触发序列，也可以用作触发序列中的某一步骤。

“查找时钟沿”和“查找码型”同时进行

下一节：设置复杂触发


设置复杂触发

通常，设置复杂触发的最大难题是对问题进行分解。换句话说，就是如何将复杂触发映射到序列步骤、分支和布尔逻辑表达式。下面分步介绍：

  1. 将问题分解为不同时发生的事件。这些事件对应于序列步骤。

  2. 扫描触发函数列表，尝试找出一些与步骤 1 中确定的事件相匹配的函数。

  3. 将所有剩余事件分解为布尔逻辑表达式及其相应操作。各个布尔逻辑表达式/操作对分别对应于序列步骤中的一个单独分支。请记住，可能存在只用于为序列步骤处理存储限定的“存储”分支。

下一节：保存触发序列并为其附加说明


保存触发序列并为其附加说明

如果某个触发序列一度很重要，那么以后它很可能还会发挥重要作用。这就是保存和用文档介绍触发序列的重要意义所在。如果没有附带的解释说明，复杂的触发序列一般难以理解。将触发设定保存到文件时，可以在文件标题信息（参见下图）中输入对触发序列的说明。此外，由于触发设定文件是 XML 格式的，因此应使用附加的 HTML 样式的注释来编辑文件和注释步骤（例如，<!-- Comment.-->）。

保存到文件时触发设定说明

下一节：总结


总结

设置逻辑分析仪触发与编写软件大相径庭。如果使用预定义的触发函数和较早编写的文档完善的触发来完成其他工作，就可大大降低设置逻辑分析仪触发的难度。仅在没有其他可用的资源时，才需要编写您自己的触发设置。最后，当设置较难的触发时，可将问题分解为若干较小的部分，然后逐个解决。


ALA 与 XML 的各自使用场合

需要执行的操作： | 应使用的格式：
保存并从逻辑分析系统中载入会话。 | ALA 格式 — ALA 格式的文件比较完整，此格式对于保存和载入逻辑分析仪的信息较为有效。
查看保存的数据。 | ALA 格式或 XML 格式 — 可以将采集的数据保存为 ALA 或 XML 格式的配置文件。但是，在载入包含数据的 XML 格式文件时，将强制进入脱机模式。
在相似的逻辑分析仪之间传递模块设置信息。 | ALA 格式 — ALA 格式的配置文件只能由带有兼容模块（例如，诸如 16740/41/42A 和 16750/51/52A/B 之类的相同或相似逻辑分析仪系列中的模块）的逻辑分析系统进行载入。
在不同的逻辑分析仪之间传递模块设置信息。 | XML 格式 — 如果需要在不兼容的模块之间传递设置信息，则必须使用 XML 格式的配置文件。
仅传递逻辑分析仪设置的一部分。 | XML 格式 — 可以载入编辑后的 XML 格式配置文件。
使用 COM 自动控制功能远程控制逻辑分析系统。 | XML 格式 — COM 自动控制界面带有通过 XML 格式字符串设置部分逻辑分析系统的命令。可以从 XML 格式的配置文件中获得这些字符串。（您也可以使用 COM 自动控制功能从 ALA 格式的配置文件中载入完整的设置信息。）
通过软件开发工具插入符号信息。 | XML 格式 — 如果无法载入某个由编译器生成的输出文件，则可以将配置另存为 XML 格式的文件，编辑该文件以包含符号信息（该信息已转换为逻辑分析仪的 XML 格式），然后重新打开这个 XML 格式的文件。

另请参见

  • 保存配置文件
  • 打开配置文件
  • 从多模块系统获取模块设置/向多模块系统传送模块设置
  • ALA 格式
  • XML 格式


多机架逻辑分析系统

如果在进行与时间相关的测量时，单个机架不足以提供所需的逻辑分析仪通道，则可以将多个 16900A 和 16902A 逻辑分析系统机架连接在一起。

注意：

16903A 逻辑分析系统机架没有多机架功能，1680/1690 系列逻辑分析仪也没有。

16900-Series Logic Analysis System Installation Guide 介绍了连接多个机架的方法。每个 16900A 或 16902A 机架基本上都有两个多机架连接器，分别标着输入和输出。多机架电缆用于将一个机架的输出连接到另一个机架的输入。用这种方式可以将任意多个机架链接在一起。主机架 是指输入连接器空闲的机架；其他所有机架都是从机架，输出连接器空闲的机架是终端从机架。

小心：

为了确保正确的多机架操作，在连接或改动多机架电缆时一定要切断机架的供电。

除了要连接多机架电缆外，这些机架还必须连接到某一网络。通常是连接到 Gb 级的局域网，专用网也可以。多机架电缆用于时间关联、交叉触发和多机架设置；其他所有的机架间通信都是通过局域网进行的。

Agilent Logic Analyzer 应用程序可运行于主机架、从机架 或另一台个人计算机之上。

使用多机架逻辑分析系统时要考虑的一些事情：

  • 使用 Overview（概览）窗口来了解连接了哪些机架以及每个机架中有哪些模块。

  • 当以外部仪器作为触发源或向外部仪器发送触发时，必须使用主机架 上的 Trigger In（触发入）或 Trigger Out（触发出）BNC 连接器。

  • 当在不同机架的模块之间进行激活 (arm) 时，实际上使用的是未用的标志线。（已在触发设置中使用的或要用于激活 (arm) 外部 Trigger Out（触发出）信号的标志线不被使用。）


参考

  • 菜单
  • 工具栏
  • 标记测量显示栏
  • 窗口
  • 对话框
  • 触发函数
  • 数据格式
  • 符号阅读器支持的对象文件格式
  • 通用 ASCII (GPA) 符号文件格式
  • 产品概述
  • 逻辑分析仪说明
    • 1680/1690 系列逻辑分析仪说明
    • 16740/41/42 逻辑分析仪说明
    • 16750/51/52 逻辑分析仪说明
    • 16753/54/55/56 逻辑分析仪说明
    • 16760 逻辑分析仪说明
    • 16910/11 逻辑分析仪说明
    • 16950 逻辑分析仪说明
  • 规格和特性
    • 1680/1690 系列逻辑分析仪规格和特性
    • 16740/41/42 逻辑分析仪规格和特性
    • 16750/51/52 逻辑分析仪规格和特性
    • 16753/54/55/56 逻辑分析仪规格和特性
    • 16760 逻辑分析仪规格和特性
    • 16910/11 逻辑分析仪规格和特性
    • 16950 逻辑分析仪规格和特性
    • 16900 系列逻辑分析系统机架特性


菜单

  • File（文件）菜单
  • Edit（编辑）菜单
  • View（查看）菜单
  • Setup（设置）菜单
  • Tools（工具）菜单
  • Markers（标记）菜单
  • Run/Stop（运行/停止）菜单
  • Overview（概览）菜单
  • Listing（列表）菜单
  • Waveform（波形）菜单
  • Compare（比较）菜单
  • Source（源代码）菜单
  • VbaView 菜单
  • Window（窗口）菜单
  • Help（帮助）菜单


File（文件）菜单

New（新建） | 创建新的逻辑分析仪配置文件。
Open（打开）... | 打开以前保存的逻辑分析仪配置文件。
Close（关闭） | 询问是否保存数据后，关闭活动窗口。
Save（保存） | 保存对当前打开的配置文件的更改。
Save As（另存为）... | 将当前打开的配置文件另存为新的名称。
Import（导入）... | 打开 Import（导入）对话框，从 16700 系列逻辑分析仪（用于脱机分析）导入快速二进制导出数据，或导入码型发生器激发矢量。
Export（导出）... | 将采集的数据保存到逗号分隔值 (CSV) 文件。CSV 文件可以导入到电子表格、数据库或其他数据分析程序。
Go Offline（脱机） | 将 Agilent Logic Analyzer 应用程序与当前连接的机架断开。
Go Online（联机） | 打开 Select System to Use（选择要使用的系统）对话框，选择 Agilent Logic Analyzer 应用程序要连接到的机架。
Print（打印）... | 打开 Printing Data（打印数据）对话框，打印定义范围内的显示数据。
Recent Configuration Files（最近的配置文件） | 列出最近打开的用于快速参考或访问的文件。
Exit（退出） | 关闭逻辑分析仪的用户界面窗口。


Edit（编辑）菜单

Undo（撤消） | 撤消上一个用户操作。这包括已更改的任何属性，如列颜色、列宽度、列移动、列插入、列删除，等等。不能撤消的操作包括滚动、采集运行和简单触发的修改。
Cut（剪切） | 剪切 Listing（列表）和 Waveform（波形）窗口的字母数字域中的选择内容。较低级别模式的对话框中的字母数字域使用键盘命令（快捷键）进行剪切。所剪切的选择内容将粘贴至剪贴板。
Copy（复制） | 复制 Listing（列表）和 Waveform（波形）窗口的字母数字域中的选择内容。较低级别模式的对话框中的字母数字域使用键盘命令（快捷键）进行复制。所复制的选择内容将粘贴至剪贴板。
Copy Screen（抓屏） | 将当前屏幕复制为位图，并放置在系统剪贴板中。
Paste（粘贴） | 将剪贴板中存储的剪切或复制的数据粘贴至字母数字域中。在较低级别模式的对话框中，使用键盘命令（快捷键）将数据粘贴至字母数字域。
Insert Bus/Signal Into Window（在窗口中插入总线/信号）... | 在显示窗口中插入预定义的总线或信号。
Remove Bus/Signal From Window（从窗口中删除总线/信号） | 将突出显示的总线或信号从显示窗口中删除。
Window Properties（窗口属性）... | 访问 Window Properties（窗口属性）对话框。
Symbols（符号）... | 打开 Symbols（符号）对话框，为所选的总线/信号设置符号。
Find（查找）... | 在采集中查找特定数据。
Find Previous（查找上一个） | 查找指定数据的上一个实例。
Find Next（查找下一个） | 查找指定数据的下一个实例。
Go To Beginning（转至开头） | 将采集的数据跟踪的起始位置置于屏幕中心。
Go To Trigger（转至触发点） | 将触发点置于屏幕中心。
Go To End（转至结尾） | 将采集的数据跟踪的结束位置置于屏幕中心。
Options（选项）... | 访问 System Options（系统选项）对话框。


View（查看）菜单

菜单

View（视图）菜单

Zoom Out Full（缩至最小化） | 最大限度地缩小活动窗口。
Zoom Out（缩小） | 缩小活动窗口。
Zoom In（放大） | 放大活动窗口。
Toolbar（工具栏） | 访问 Toolbar（工具栏）对话窗口。
Full Screen（全屏） | 启用或禁用全屏显示。
Tabbed Window（选项卡式窗口） | 启用或禁用 Listing（列表）和 Waveform（波形）选项卡。
Status Bar（状态栏） | 启用或禁用状态栏。


Setup（设置）菜单

New Probe（新探头） | 为探测 FPGA 内部信号设置 FPGA 动态探头或对所用的其他探头进行定义（请参见设置探头）。
Bus/Signal（总线/信号）... | 访问 Analyzer Setup（分析仪设置）对话框的 Buses/Signals（总线/信号）选项卡。
Timing/State (Sampling)（定时/状态（采样））... | 访问 Analyzer Setup（分析仪设置）对话框的 Sampling（采样）选项卡。
Simple Trigger（简单触发）... | 请参见指定简单触发。
Advance Trigger（高级触发）... | 访问 Advance Trigger（高级触发）对话框。
Store Trigger（存储触发）... | 存储当前触发。
Recall Trigger（重新调用触发）... | 访问一组最近使用的触发。
Symbols（符号）... | 打开 Symbols（符号）对话框，为所选的总线/信号设置符号。
Pod Assignment（盒分配）... | 打开 Pod Assignment（盒分配）对话框，为时间标签存储保留盒或盒对。当某个模块 已拆分为两个模块时，还可以使用此对话框为拆分的模块分配通道。
Split Analyzer（拆分分析仪）... | 打开 Split Analyzer Setup（拆分分析仪设置）对话框，将一个逻辑分析仪模块分成两个模块。
Unsplit Analyzer（取消分析仪拆分）... | 一个逻辑分析仪模块分成两个模块时显示此项；用于将拆分的模块重新合并成一个模块。
Disable（禁用）.../ Enable（启用）... | 禁用某一模块可以防止将它所采集的数据发送给工具和显示窗口；这样可以更快地处理来自其他模块的数据。
Rename（重命名）... | 重命名逻辑分析仪模块。
Add External Scope（添加外部示波器）... | 运行 Add External Oscilloscope（添加外部示波器）向导，将外部示波器连接到逻辑分析仪。
Delete External Scope（删除外部示波器）... | 删除外接示波器的设置。
External Trigger（外部触发）... | 打开 External Trigger（外部触发）对话框，设置逻辑分析仪与其他外部仪器之间的触发。
Target Control Port（目标控制端口）... | 打开 Target Control Port（目标控制端口）对话框，在逻辑分析系统机架的目标控制端口 上输出信号。
Skew & System Trigger（偏移与系统触发）... | 打开 Module Skew and System Trigger（模块偏移与系统触发）对话框，指定哪个模块 是系统触发（即哪个模块的触发参考点是 Time=0），同时指定非系统触发 模块的触发参考点偏移。


Tools（工具）菜单

所有外接工具在 tools（工具）菜单下都分组显示。Agilent Logic Analyzer 应用程序附带一个内置 Filter/Colorize（过滤/着色）。如果您正在使用反汇编程序、总线分析工具或其他第三方工具，这些工具将显示在 Tools（工具）菜单中的 New（新建）下面。

创建工具时，便会将它们添加到 Tools（工具）菜单底部。上面的菜单显示一个活动工具。

New（新建）...

创建新的反汇编、总线分析、过滤器/着色、数据包解码器或串行到并行工具。

Overview（概览）

允许您管理活动工具。

Find（查找）...

在采集中查找特定数据。

External Applications（外部应用程序）>

允许您从 Agilent Logic Analyzer 应用程序菜单中运行外部应用程序。子菜单上的 Setup（设置）... 将打开 External Application Setup（外部应用程序设置）对话框，使用此对话框您可以通过子菜单添加、编辑、排列或删除项目。

Macro（宏）>

允许您：

  • 打开用于选择要运行的 Visual Basic 宏的 Macros（宏）对话框。
  • 打开用于编辑程序的 Visual Basic Editor。
  • 从 .zip 文件中导入 VBA 项目代码。
  • 将 VBA 项目代码导出到 zip 文件。
有关更多信息，请参阅 Visual Basic 联机帮助。

Run Macro（运行宏）>

打开 Add-In Manager（外接程序管理器）对话框，使用此对话框您可以注册一个外接程序（一个可以添加 Visual Basic 开发环境功能的定制工具）、载入或卸载以及设置其载入行为。有关更多信息，请单击 Add-In Manager（外接程序管理器）对话框中的 Help（帮助）。

运行样本宏。出厂子菜单包括：

  • FindEdgesSample（用于显示两个时钟沿之间的时间并在特定的时钟沿对上放置标记的宏）。

  • RepetitiveSaveToFileSample（用于将重复运行中的数据保存到从重复运行到增加的文件名的宏）。

  • SendToExcel（用于将逻辑分析仪数据发送到 Microsoft Excel 的宏）。

  • SendToPatternGeneratorModule（用于将逻辑分析仪数据发送到用作激发矢量的码型发生器模块的宏）。

您可以将自己的 VBA 宏添加到此子菜单中，方法是将 VBA 项目代码 .zip 文件放置到以下目录中：

C:\<安装路径>\VBA\

例如：

C:\Program Files\Agilent Technologies\Logic Analyzer\VBA\

1 工具名称

编辑现有工具。

另请参见

  • 添加新工具
  • 更改工具
  • 删除工具
  • Filter/Colorize（过滤/着色）工具


Markers（标记）菜单

New（新建）... | 创建新标记。
Place on Screen（在屏幕上放置）... | 将新标记或所选（现有）标记置于屏幕中央。
Go To（转至）... | 转至所选的标记。
Center About（居中）... | 居中显示所选标记。
Delete（删除）... | 删除所选标记。
New Time Interval Measurement（新建时间间隔测量） | 创建新的时间间隔测量。
New Sample Interval Measurement（新建采样间隔测量） | 创建新的采样间隔测量。
New Value At Measurement（新建定点值测量） | 创建新的定点值测量。
Hide/Show Measurements List（隐藏/显示测量列表） | 隐藏或显示标记测量显示栏。
Properties（属性）... | 访问标记属性对话框


Run/Stop（运行/停止）菜单

Run（运行） | 开始采样，用触发区域附近的样本填充逻辑分析仪内存，然后停止。
Run Repetitive（重复运行） | 开始采样，用触发区域附近的样本填充逻辑分析仪内存，并重复。
Stop（停止） | 停止正在进行的逻辑分析仪测量。
（码型发生器模块）> | 可访问码型发生器模块的 run/stop（运行/停止）命令。
Cancel（取消） | 进行搜索、使用过滤器或导出采集的数据时，Cancel（取消）可停止这些操作。
Resume（继续执行） | 如果已用 Cancel（取消）停止了一个过滤器工具操作，则 Resume（继续执行）可使该过滤操作继续。
Status（状态）... | 访问 Status（状态）对话框。


Overview（概览）菜单

Redraw（刷新屏幕） | 刷新 Overview（概览）窗口。
System Summary（系统摘要）... | 打开 System Summary（系统摘要）对话框，显示逻辑分析系统中机架、模块、卡 和插槽 的相关信息。
Delete（删除） | 关闭 Overview（概览）窗口。


Listing（列表）菜单

Duplicate（复制）... | 添加一个与当前显示的窗口具有相同属性的新 Listing（列表）窗口。
Delete（删除） | 关闭 Listing（列表）窗口。
Rename（重命名）... | 重命名 Listing（列表）窗口。
Properties（属性）... | 更改 Listing（列表）窗口属性。

另请参见

  • 分析列表数据
  • 设置 Listing（列表）窗口的属性


Waveform（波形）菜单

Duplicate（复制）... | 添加与当前显示的窗口具有相同属性的新波形窗口。
Delete（删除） | 关闭波形窗口。
Rename（重命名）... | 允许您重命名波形窗口。
Properties（属性）... | 允许您更改 Waveform（波形）窗口属性。

另请参见

  • 分析波形数据
  • 设置 waveform（波形）窗口属性


Compare（比较）菜单

Copy（复制）... | 将数据复制到参考缓冲区中。
Range & Offset（范围与偏移）... | 用于比较一定范围内的样本以及偏移参考数据。
Next Difference（下一差异） | 查找下一差异（在参考中心以下）。
Previous Difference（上一差异） | 查找上一差异（在参考中心以上）。
Duplicate（复制）... | 添加一个与当前显示的窗口具有相同属性的新 Compare（比较）窗口。
Delete（删除） | 关闭 Compare（比较）窗口。
Disable（禁用）...，Enable（启用）... | 用于禁用或重新启用 Compare（比较）窗口。
Rename（重命名）... | 用于为 Compare（比较）窗口重新命名。
Properties（属性）... | 用于更改 Compare（比较）窗口的属性。

另请参见

  • Compare（比较）显示窗口
  • 比较采集的数据与参考数据
  • 设置 Compare（比较）窗口的属性


Source（源代码）菜单

Duplicate（复制）... | 添加一个与正在显示的窗口具有相同属性的新 Source（源代码）窗口。
Delete（删除） | 关闭 Source（源代码）窗口。
Rename（重命名）... | 重命名 Source（源代码）窗口。
Properties（属性）... | 更改 Source（源代码）窗口属性。

另请参见

  • Source（源代码）显示窗口
  • 查看与采集的数据关联的源代码
  • 设置 Source（源代码）窗口属性


VbaView 菜单

Redraw（重新绘制） | 在 VbaView 窗口中重新绘制图表。
View Code（查看代码）... | 在 Visual Basic 编辑器中查看与 VbaView 窗口相关联的代码。
Duplicate（复制）... | 添加与当前显示的窗口具有相同属性的新 VbaView 窗口。
Delete（删除） | 关闭 VbaView 窗口。
Disable（禁用）...，Enable（启用）... | 允许您禁用或重新启用 VbaView 窗口。
Rename（重命名）... | 允许您重命名 VbaView 窗口。
Properties（属性）... | 允许您更改 VbaView 窗口属性。

另请参见

  • VbaView 窗口


Window（窗口）菜单

New Compare（新建比较）...

创建一个新的比较窗口。

New Listing（新建列表）...

创建一个附加列表窗口。

New Source（新建源代码）...

创建一个新的源代码窗口。

New VbaView（新建 VbaView）>

创建一个新的 VbaView 窗口并使用自定义代码对其进行填充。出厂子菜单包括：

  • Bus vs Bus Sample（总线与总线样本）...（简单的 XY 散点图示例）。
  • Distribution Sample（分布样本）...（简单的数据分布条形图示例）。
  • Export to IE Sample（导出到 IE 样本）...（将数据导出到另一个应用程序的简单示例）。
  • External Scope Web Control（外部范围 Web 控制）...（打开外部示波器的 web 控制窗口）。
  • Hello World Sample（Hello World 样本）...（简单的文本输出示例）。
  • Timing Compare（定时比较）...（用指定的容差条件比较定时分析仪数据）。

您可以通过将 VBA 项目代码 .zip 文件放置到目录中来将自己的 VbaView 窗口（和代码）添加到此子菜单中：

C:\<安装路径>\VBA\

例如：

C:\Program Files\Agilent Technologies\Logic Analyzer\VBA\

New Waveform（新建波形）...

创建一个附加波形窗口。

Overview（概览）

打开或显示（概览）窗口。

Next（下一个）

显示下一个窗口。

Previous（上一个）

显示上一个窗口。

Cascade（层叠）

以重叠和偏移格式显示所有打开的窗口。

Tile Horizontally（水平平铺）

显示所有打开的窗口以便平均划分水平显示空间。

Tile Vertically（垂直平铺）

显示所有打开的窗口以便平均划分垂直显示空间。

Arrange Icons（排列图标）

所有最小化的列表和波形窗口都排列在分析仪窗口的底部。


Help（帮助）菜单

Help Topics（帮助主题） | 访问联机帮助。
Help On Probes（探头帮助） | 打开探头的联机帮助。
Help On Windows（窗口帮助） | 打开 Waveform（波形）、Listing（列表）、Compare（比较）或 Source（源代码）窗口的帮助。
Help On Tools（工具帮助） | 打开工具的联机帮助。
Help Language（帮助语言） | 选择英文版和日文版的联机帮助（请参见访问日文联机帮助 (Windows XP) 或访问日文联机帮助 (Windows 2000)）。
Self Test（自检）... | 访问 Logic Analyzer Self-Tests（逻辑分析仪自检）对话框（请参见运行自检）。
Module Upgrade（模块升级）... | 访问 Module Upgrade（模块升级）对话框，它为逻辑分析仪模块的硬件升级提供了相关信息。
Software Licensing（软件授权）... | 打开 Software Licensing（软件授权）对话框，管理逻辑分析系统所使用的软件许可证。
About（关于）... | 显示产品版本和版权信息。


工具栏

工具栏位于菜单栏下方，用于快速访问某一功能或执行某一任务。默认情况下，并非显示所有工具栏，或只显示给定工具栏中的个别工具。要获得所有可用工具栏的完整列表，请选择 View（视图）> Toolbars（工具栏）>。要获得给定工具栏中的所有工具的完整列表，请选择 View（视图）> Toolbars（工具栏）> Customize（定制）...；然后，在 Customize（定制）对话框中选择 Commands（命令）选项卡。

  • 标准
  • 码型发生器
  • 分析仪设置
  • 外部示波器设置
  • 数据导入
  • 探头
  • 标记
  • 运行/停止
  • Visual Basic
  • 定制...


标准工具栏

New（新建）－ 创建新的逻辑分析仪配置文件。

Open（打开）－ 打开以前保存的逻辑分析仪配置文件。

Save（保存）－ 保存对当前打开的配置文件的更改。

Print（打印）－ 打印指定范围的显示数据。

Find（查找）－ 在采集的数据中查找指定的数据。

Find Previous（查找上一个）－ 往回查找指定数据的上一个匹配项。

Find Next（查找下一个）－ 往后查找指定数据的下一个匹配项。

Go to Beginning（转至开头）－ 使采集数据的开头居中显示。

Go to Trigger（转至触发）－ 使采集操作的触发点居中显示。

Go to End（转至结尾）－ 使采集数据的结尾居中显示。

Zoom Out（缩小）－ 缩小活动窗口。

Zoom In（放大）－ 放大活动窗口。

Overview（概览）－ 打开或显示 Overview（概览）窗口。

注意：

以下是可选的标准工具栏图标。

剪切所选内容，并放在剪贴板上。

复制所选内容，并放在剪贴板上。

粘贴剪贴板上存储的数据。

提供有关 Agilent Logic Analyzer 应用程序的联机帮助信息。

撤消上一个用户操作。

启用或禁用全屏显示。

激活下一个窗口。

激活上一个窗口。

层叠排列窗口。

水平不重叠排列窗口。

垂直不重叠排列窗口。

另请参见

  • 创建自定义工具栏


码型发生器工具栏

设置码型发生器总线/信号属性。

设置码型发生器时钟属性。

设置码型发生器序列。

设置码型发生器宏。

运行码型发生器。

重复运行码型发生器。

停止码型发生器。

单步运行码型发生器矢量序列。

继续码型发生器矢量序列输出。

将码型发生器矢量序列重置到起始位置。

另请参见

  • 使用码型发生器


Analyzer Setup（分析仪设置）工具栏

Bus/Signal（总线/信号）－ 访问 Setup（设置）对话框的 Buses/Signals（总线/信号）选项卡。

Timing/State (Sampling)（定时/状态（采样））－ 访问 Setup（设置）对话框的 Sampling（采样）选项卡。

Advance Trigger（高级触发）－ 访问 Advance Trigger（高级触发）对话框。

另请参见

  • 创建自定义工具栏


外部示波器设置工具栏

设置外部示波器的连接属性。

设置外部示波器的选项属性。

设置外部示波器的触发属性。

另请参见

  • Infiniium 示波器的时间相关性


数据导入工具栏

用于编辑数据导入模块的总线/信号定义。

显示数据导入模块的文件信息。

重新读取数据导入模块文件。

另请参见

  • 使用数据导入模块


探头工具栏

打开某一探头的属性对话框。


标记工具栏

新建 － 创建新标记。

转至 － 居中显示所选标记。

创建新的定点值测量。

创建新的时间间隔测量。

注意：

以下是可选的标记工具栏图标。

放置标记 － 将新标记或所选（现有）标记置于屏幕中央。

居中 - 居中显示两个选择的标记。

创建新的采样间隔测量。

隐藏或显示标记测量显示栏。

访问标记属性对话框。

另请参见

  • 创建自定义工具栏


Run/Stop（运行/停止）工具栏

开始采样，用样本填充逻辑分析仪内存。

开始采样，用触发区域附近的样本填充逻辑分析仪内存，并重复。

停止正在进行的逻辑分析仪测量，例如，在没有找到触发条件的情况下。

取消当前操作。

恢复取消的操作。

另请参见

  • 创建自定义工具栏


Visual Basic 工具栏

运行 Visual Basic for Applications (VBA) 宏。

打开 Visual Basic 编辑器。

另请参见

  • 使用高级定制环境 (ACE)


自定义工具栏

  • 添加工具栏图标
  • 删除工具栏图标
  • 创建新工具栏
  • 将工具栏恢复到初始图标

添加工具栏图标

  1. 从菜单栏中，选择 View（查看）> Toolbars（工具栏）> Customize（自定义）...。

  2. 选择 Commands（命令）选项卡。

  3. 选择要从中添加图标的 Category（类别）。

  4. 将所需图标从 Buttons（按钮）区域拖至工具栏上的适当位置；然后放开鼠标键，插入该工具图标。

  5. 重复这些步骤，添加其他图标。

删除工具栏图标

  1. 从菜单栏中，选择 View（查看）> Toolbars（工具栏）> Customize（自定义）...。

  2. 选择 Commands（命令）选项卡。

  3. 将图标从工具栏拖放到 Customize（自定义）对话框的 Buttons（按钮）区域。

  4. 重复这些步骤，删除其他图标。

创建新工具栏

  1. 从菜单栏中，选择 View（查看）> Toolbars（工具栏）> Customize（自定义）...。

  2. 在 Customize（自定义）对话框的 Toolbars（工具栏）选项卡中，单击 New（新建）...。

  3. 在 New Toolbar（新建工具栏）对话框中，输入新工具栏的名称，然后单击 OK（确定）。

  4. 将新工具栏窗口拖至工具栏停靠区域的适当位置。

    将某一工具栏拖至某现有工具栏行底端，可以再创建一个工具栏行。

    如果某工具栏因被遮盖而未显示在屏幕上，则可以拖动某一可见工具栏并创建另一工具栏行；然后被遮盖的工具栏便应显示出来。

创建新工具栏后，可以按照上面所述方法添加或删除图标。

将工具栏恢复到初始图标

  1. 从菜单栏中，选择 View（查看）> Toolbars（工具栏）> Customize（自定义）...。

  2. 在 Customize（自定义）对话框的 Toolbars（工具栏）选项卡中，选择要恢复的 Toolbar（工具栏）的名称。

  3. 单击 Reset（重置）。


标记测量显示栏

标记的 interval（间隔）测量和 value at（定点值）测量与其他工具栏一起显示在菜单栏下方。

  • 创建新的时间间隔测量
  • 创建新的采样间隔测量
  • 创建新的定点值测量
  • 隐藏/显示测量显示栏


窗口

  • Waveform（波形）显示窗口
    • 标记显示栏
    • 标记概览栏
  • Listing（列表）显示窗口
  • Compare（比较）显示窗口
  • Source（源代码）显示窗口
  • VbaView 窗口
  • Overview（概览）窗口


Waveform（波形）显示窗口

可通过菜单栏的 Window（窗口）>Waveform（波形）访问波形窗口。如果开启了 Tabbed Windows（选项卡式窗口），还可以选择窗口底部的选项卡。

波形窗口将以数字波形的方式显示采集的数据。可以配置该窗口，以便在所选总线和信号的数据中显示时间或码型标记。还可以配置总线码型触发和信号触发选项。

波形窗口由以下区域组成：

  • Bus/Signal Configuration（总线/信号配置）
  • Simple Trigger（简单触发）
  • Markers Display Bar（标记显示栏）
  • Waveform Display Area（波形显示区域）
  • Markers Overview Bar（标记概览栏）
  • Delay Controls（延迟控制）
  • Scale (time/division) Controls（刻度（时间/分界线）控制）

Bus/Signal Configuration（总线/信号配置）

要访问以下 Bus/Signal configuration（总线/信号配置）选项，请右键单击 Bus/Signal（总线/信号）列中的任一总线或信号名称。

Undo（撤销） | 撤销执行的上一步操作。
Insert Row Before（在其前插入行）... | 在突出显示的行之前插入总线/信号。
Insert Row After（在其后插入行）... | 在突出显示的行之后插入总线/信号。
Delete（删除）> | 删除突出显示的行中的总线/信号或删除所有总线/信号。
Expand（展开） | 将突出显示的总线展开为分别显示的通道。
Collapse（折叠） | 将显示的通道折叠为单独显示的总线。
Assign Channels（分配通道）... | 访问 Analyzer Setup（分析仪设置）对话框的 Buses/Signals（总线/信号）选项卡，将突出显示的总线/信号映射（分配）到探头所需的盒和通道连接。
Rename（重命名）... | 使用键盘，重命名突出显示的总线/信号。
Group into Bus（组成总线） | 将突出显示信号组成总线。
Overlay（覆盖）... | 使用其他所选总线或信号覆盖突出显示的总线或信号。
Overlay Remove（覆盖删除） | 分离重叠的总线/信号。
Symbols（符号）... | 打开 Symbols（符号）对话框，为所选的总线/信号设置符号。
Find（查找）... | 打开 Find（查找）对话框，搜索采集的数据。
Find Bus/Signal（查找总线/信号）... | 搜索总线/信号行。
View As Chart（以图表形式查看）... | 打开 View As（查看方式）对话框，以图表或总线方式查看总线数据。
Display（显示）> | 允许您显示或隐藏部分波形窗口。
Properties（属性）... | 访问波形窗口、总线/信号行、总线/信号列和标记属性的 Properties（属性）对话框。

波形显示区域

要访问波形显示选项，右键单击显示区域中的任何位置。

Undo（撤销） | 撤销执行的上一步操作。
Zoom Out（缩小） |
Zoom In（放大） |
Go To（转至） |
Place Marker（放置标记）> |
Center About（居中）> | 使标记对或波形时钟沿居中显示。
Find（查找）... |
Find Next（查找下一个） |
Find Previous（查找上一个） |
Properties（属性）... |

在数据中绘制矩形

Zoom In（放大） |
Set Quick Trigger（设置快速触发） | 设置简单触发的可选方法。
Find Next（查找下一个） | 矩形左侧时钟沿的数值将变成查找搜索标准，并且该数值的下一个匹配项将出现在屏幕中央。
Find Previous（查找上一个） | 矩形左侧时钟沿的数值将变成查找搜索标准，并且该数值的上一个匹配项将出现在屏幕中央。

另请参见

  • 分析波形数据
  • 标记数据点并在数据点之间进行测量
  • 指定高级触发
  • 设置符号
  • 添加或删除显示窗口
  • 打开/关闭窗口选项卡


标记显示栏

要访问以下任务，请在标记显示栏中右键单击鼠标。

New（新建）... | 创建新标记。
Place（放置） | 在数据中放置标记。
Go To（转至） | 转至某一标记。
Center About（居中）... | 居中显示标记对。
Snap to Edge（对齐沿） | 切换标记的对齐沿属性。
Delete（删除） | 删除标记。
Delete All（全部删除） | 删除所有标记。
Rename（重命名）... | 重命名标记。
Send to Back（移到后面） | 将标记移到后面。
Properties（属性）... | 设置标记属性。

另请参见

  • 读取标记显示栏和概览栏
  • Markers（标记）菜单
  • 标记工具栏
  • 标记概览栏


标记概览栏

要访问以下菜单，请在标记概览栏中单击鼠标。

Go To（转至） | 转至某一标记。
Send to Back（移到后面） | 将标记移到后面。

另请参见

  • 读取标记显示栏和概览栏
  • Markers（标记）菜单
  • 标记工具栏


Listing（列表）显示窗口

Listing（列表）窗口是通过菜单栏的 Window（窗口）> Listing（列表）来访问的。如果已开启 Tabbed Windows（选项卡式窗口），也可以选择窗口底部的选项卡。

Listing（列表）窗口以状态列表的形式显示采集的数据。对该窗口进行配置，可以在若干列中显示选定的总线和信号。可以在列出的数据中插入时间或码型标记。还可以配置总线码型触发和信号触发选项。

Listing（列表）窗口由以下几个区域组成：

  • 列配置
  • 简单触发
  • 标记显示栏
  • 列表显示区
  • 标记概览栏

列配置

要访问以下列配置选项，请右键单击列标题中的任一总线或信号名称。

Undo（撤消） | 撤消上一个操作。
Insert Column Before（在其前插入列）... |
Insert Column After（在其后插入列）... |
Delete（删除）> |
Assign Channels（分配通道）... |
Rename（重命名）... | 使用键盘，重命名突出显示的总线/信号。
Base（基）> |
Symbols（符号）... | 打开 Symbols（符号）对话框，为所选的总线/信号设置符号。
Find（查找）... | 打开 Find（查找）对话框，搜索采集的数据。
Find Bus/Signal（查找总线/信号）... | 搜索某一总线/信号列。
Display（显示）> | 显示或隐藏部分 Listing（列表）窗口。
Properties（属性）... | 访问 Listing（列表）窗口、总线/信号列和标记属性的 properties（属性）对话框。

列表显示区

要访问 Listing（列表）显示选项，请在显示区中右键单击鼠标。

Undo（撤消） | 与 Edit（编辑）> Undo（撤消）相同。
Go To（转至） |
Place Marker（放置标记）> |
Find（查找）... |
Find Next（查找下一个） |
Find Previous（查找上一个） |
Properties（属性）... |

在数据中画矩形

Set Quick Trigger（设置快速触发） | 设置简单触发的另一种方式。
Find Next（查找下一个） | 将矩形上边框处的数据值作为 Find search（查找搜索）条件，并将找到的下一个出现该数据值的位置显示在屏幕中央。
Find Previous（查找上一个） | 将矩形上边框处的数据值作为 Find search（查找搜索）条件，并将找到的上一个出现该数据值的位置显示在屏幕中央。
Copy Text（复制文本） | 将数据作为文本复制到系统剪贴板。

另请参见

  • 分析列表数据
  • 设置符号
  • 标记数据点并在数据点之间进行测量
  • 添加或删除显示窗口
  • 打开/关闭窗口选项卡


Compare（比较）显示窗口

在 Compare（比较）窗口中，您可以将获取的（输入）数据与保存在参考缓冲区中的数据进行比较。参考数据带有彩色背景，并且突出显示输入数据和参考数据之间的差异。

可通过菜单栏的 Window（窗口）> Compare（比较）访问 Compare（比较）窗口。如果开启了 Tabbed Windows（选项卡式窗口），还可以选择窗口底部的选项卡。

除了能够显示采集数据与参考数据之间的差异，以及不能显示着色数据（来自 Filter/Colorize（过滤/着色）工具）外，Compare（比较）窗口与 Listing（列表）窗口无任何差别。

另请参见

  • 比较采集的数据与参考数据
    • 将数据复制到参考缓冲区
    • 在比较的数据中查找差异
    • 仅比较一定范围内的样本
    • 偏移参考数据
    • 出现一定数量的比较差异后停止运行
    • 设置 Compare（比较）窗口的属性
  • 分析列表数据


Source（源代码）显示窗口

使用 Source（源代码）窗口可以查看与所采集数据相关的高级源代码。

Source（源代码）窗口是通过菜单栏的 Window（窗口）> Source（源代码）命令来访问的。如果已开启 Tabbed Windows（选项卡式窗口），也可以选择窗口底部的选项卡。

Source（源代码）窗口有两个窗格：上部窗格显示与所采集数据关联的高级语言源代码，下部窗格与 Listing（列表）窗口相同。

另请参见

  • 查看与采集的数据关联的源代码
    • 按源代码行单步查看采集的数据
    • 转至与某源代码行关联的采集数据
    • 浏览源文件
    • 在源文件中搜索文本
    • 在 Source（源代码）窗口中设置快速触发
    • 转至与列表中心矩形关联的源代码行
    • 编辑源代码目录列表
    • 选择相关总线
    • 更改 Source（源代码）窗口属性
  • 分析列表数据


VbaView 窗口

VbaView 窗口与集成的 Microsoft Visual Basic for Applications (VBA) 一起提供自定义数据可视化图表。

可通过菜单栏的 Window（窗口）> VbaView 命令访问 VbaView 窗口。如果开启了 Tabbed Windows（选项卡式窗口），还可以选择窗口底部的选项卡。

VbaView 窗口包含两个窗格：顶部窗格显示图表，底部窗格显示文本输出。

另请参见

  • 通过 VBA 扩展数据可视化/分析
  • 在 VbaView 窗口中显示数据


Overview（概览）窗口

Overview（概览）窗口用于指定如何从逻辑分析仪数据采集模块将数据发送到后处理工具和显示窗口。

Overview（概览）窗口是通过菜单栏的 Window（窗口）> Overview（概览）命令来访问的。如果已开启 Tabbed Windows（选项卡式窗口），也可以选择窗口底部的选项卡。

连接规则

关于如何才能添加/连接工具和显示数据有几个规则。

  • 规则 1：Fan out to tools（扇出到工具）仅在模块后直接发生。

  • 规则 2：Fan in to tools（扇入到工具）仅在模块后直接发生。

  • 规则 3：显示窗口不能显示同一总线/信号的两个版本。

    不允许，因为 1691D - 2 总线/信号已在来自 Filter/Colorize - 1 的数据中。

另请参见

  • （使用 Overview（概览）窗口）以不同的方式分析相同的数据
  • 打开或显示 Overview（概览）窗口
  • 添加、复制或删除窗口和工具
    • 添加新窗口
    • 删除窗口
    • 添加新工具
    • 删除工具
    • 复制窗口
    • 删除连接
    • 添加连接
  • 编辑窗口或工具属性
  • 重命名窗口、工具和模块
  • 刷新 Overview（概览）窗口
  • 删除 Overview（概览）窗口


对话框

  • Advanced Clocking Setup（高级时钟计时设置）对话框
  • Advanced Trigger（高级触发）对话框
  • Analyzer Setup（分析仪设置）对话框
  • Create a New Configuration（创建新配置）对话框
  • E-mail（电子邮件）对话框
  • Eye Finder Advanced Options（Eye Finder 高级选项）对话框
  • Eye Finder Properties（Eye Finder 属性）对话框
  • Export（导出）对话框
  • Export（导出）文件选择对话框
  • External Application Setup（外部应用程序设置）对话框
  • External Trigger（外部触发）对话框
  • Find（查找）对话框
  • Frame/Module Information（机架/模块信息）对话框
  • Import（导入）对话框
  • Import Setup（导入设置）对话框
  • Module Mapping（模块映射）对话框
  • Module Skew and System Trigger（模块偏移与系统触发）对话框
  • Module Upgrade（模块升级）对话框
  • Netlist Import（网表导入）对话框
  • Offline Startup Options（脱机启动选项）对话框
  • Options（选项）对话框
  • Pod Assignment（盒分配）对话框
  • Printing Data（打印数据）对话框
  • Properties（属性）对话框
  • Range Properties（范围属性）对话框
  • Recall Trigger（重新调用触发）对话框
  • Select Symbol（选择符号）对话框
  • Select System to Use（选择要使用的系统）对话框
  • Software Licensing（软件授权）对话框
  • Source Viewer Properties（源代码查看器属性）对话框
  • Specify Mapping（指定映射）对话框
  • Split Analyzer Setup（拆分分析仪设置）对话框
  • Status（状态）对话框
  • Symbols（符号）对话框
  • System Summary（系统摘要）对话框
  • Target Control Port（目标控制端口）对话框
  • Thresholds and Sample Positions（阈值和采样位置）对话框
  • TimingZoom Setup（时序放大设置）对话框


Advanced Clocking Setup（高级时钟计时设置）对话框

Advanced Clocking Setup（高级时钟计时设置）对话框可用于指定比标准主/从选择更为复杂的时钟设置。如果希望在同一时钟说明中将某个特定时钟通道同时用作时钟沿和限定符，则需要使用高级时钟计时。

Clock spec（时钟说明）： | 时钟计时设置的文字说明。
Edges（沿） | 用于针对每项可用时钟输入选择 Don't Care（无关）、Rising Edge（上升沿）、Falling Edge（下降沿）或 Both Edges（双沿）。
Qualifiers（限定符） | 用于将时钟限定符设置为 Off（关闭），或针对每种时钟限定符资源 (Q1-Q4) 从可用的时钟输入中选择 Low（低）或 High（高）电平。
And/Or（与/或） | 用于切换时钟限定符的布尔运算符。

另请参见

  • 设置高级时钟计时
  • 盒和通道的命名约定


Advanced Trigger（高级触发）对话框

Advanced Trigger（高级触发）对话框可用于建立无法通过简单触发建立的复杂的触发设定（例如，可以按被测设备中的事件顺序进行触发）。

Trigger Functions（触发函数） | 触发函数是用于普通测量的预定义触发设置。按所需顺序将触发函数拖放至 Trigger Sequence（触发序列）区域；然后填写字段以指定要在采样数据中查找的 events（事件）以及找到事件时执行的 actions（操作）。
Trigger Sequence（触发序列） | 触发序列用于说明在搜索将会触发逻辑分析仪的一系列事件时执行的步骤。 Default storage（默认存储）用于指定在触发序列步骤中不出现存储控制 操作的情况下要存储的样本。
Simple Trigger（简单触发）... | 打开介绍如何指定简单触发的信息对话框。
Store（存储）... | 打开 Store Trigger（存储触发）对话框，该对话框用于将触发序列设置作为喜爱的设置保存或将其保存至文件。
Recall（重新调用）... | 打开 Recall Trigger（重新调用触发）对话框，该对话框用于重新调用喜爱的、最近使用的或已存储的触发序列设置。
Clear（清除） | 清除当前的触发序列，并建立一个默认触发序列。

另请参见

  • 指定高级触发
  • 触发函数
  • 指定简单触发
  • 存储和重新调用触发


Analyzer Setup（分析仪设置）对话框

通过菜单栏的 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）... 命令访问 Analyzer Setup（分析仪设置）对话框。

该对话框由以下两个选项卡组成：

  • Buses/Signals（总线/信号）- Buses/Signals（总线/信号）选项卡用于将界面中的总线和信号名称映射至探头的盒和通道连接。此外，您还可以设置盒的阈值，并为总线或信号指定默认数基和极性。请参见 Buses/Signals（总线/信号）选项卡。

  • Sampling（采样）- Sampling（采样）选项卡用于为分析仪命名，以及选择和配置采集模式。在定时采集模式下，可设置通道宽度和采样频率。在状态采集模式下，可配置状态时钟和限定符。请参见 Sampling（采样）选项卡。


Buses/Signals（总线/信号）选项卡

Buses/Signals（总线/信号）选项卡用于将界面中的总线和信号名称映射（分配）至探头的盒和通道连接。还可以使用 Buses/Signal（总线/信号）选项卡设置阈值、极性、默认数基和输入用户注释。

通过菜单栏的 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Bus/Signal（总线/信号）... 命令访问 Buses/Signals（总线/信号）选项卡。

通过 Display（显示）按钮可以选择显示哪些总线/信号设置信息。

Bus/Signal Name（总线/信号名称）列中的总线和信号图标通常为红色，但如果该总线/信号被反汇编程序锁定，则会变为灰色。

只读选项

以下域是只读的，不能进行编辑。通过 Display（显示）按钮可以开启/关闭这些项目的显示。

Width（宽度）

Width（宽度）列显示每条总线上所分配的通道数。

Activity（活动）

Activity（活动）行显示每个通道的信号活动类型。

  • 下划线 = 稳定的低电平。

  • 上划线 = 稳定的高电平。

  • 跳变箭头 = 高低电平之间的活动的信号跳变。

Channel Numbers（通道数）

Channel Numbers（通道数）行显示盒的通道数

注意：

在 Agilent Logic Analyzer 应用程序的早期版本中，Buses/Signals（总线/信号）设置选项卡带有 Define Probes（定义探头）... 按钮；现在探头的定义方式则有所不同（请参见定义探头）。

另请参见

  • 定义总线和信号
    • 添加新的总线或信号
    • 删除总线或信号
    • 重命名总线或信号
    • 以默认位顺序分配通道
    • 通过选择位顺序来分配通道
    • 通过导入网表文件定义总线和信号
    • 编辑 Channels Assigned（分配的通道）字符串来重新排列位顺序
    • 设置默认数基
    • 设置极性
    • 添加用户注释
    • 添加文件夹
    • 为总线/信号设置别名
    • 对总线/信号名称排序
  • 盒和通道的命名约定
  • 为什么盒会丢失?


Sampling（采样）选项卡

Sampling（采样）选项卡是通过菜单栏的 Setup（设置）> (Logic Analyzer Module)（逻辑分析仪模块）> Timing/State (Sampling)（定时/状态（采样））... 命令访问的。Sampling（采样）设置选项卡用于选择和配置采集模式。

在 Timing - Asynchronous Sampling（定时 - 异步采样）模式下可以设置采样周期和通道宽度。还可以设置采集（内存）深度和触发位置。定时模式以固定间隔（采样周期）对被测设备进行采样。

在 State - Synchronous Sampling（状态 - 同步采样）模式下可以配置时钟计时类型以及任何所需的时钟限定。还可以设置采集（内存）深度和触发位置。在状态模式下，对被测设备的采样是在与定义的时钟匹配的信号出现时进行的。

另请参见

  • 选择采样模式


Create a New Configuration（创建新配置）对话框

当处于脱机模式 时会显示 Select Offline Hardware（选择脱机硬件）对话框，可以通过选择 File（文件）> New（新建）命令来创建新的逻辑分析仪配置文件。使用此对话框可以指定要在配置文件中构建的逻辑分析仪硬件的类型。

Type of Card（卡的类型） | 选择要在新的脱机配置文件中使用的逻辑分析硬件的类型。 Virtual Analyzer（虚拟分析仪）是一种无硬件选项的通用逻辑分析仪；它是在导入 16700 系列逻辑分析仪的快速二进制数据以进行脱机分析时所使用的逻辑分析仪的类型。
Number of Cards in（模块中的卡数量） | 指定此硬件模块的卡数。
Starting Slot（起始插槽） | 选择新脱机配置文件中所使用的卡的起始插槽。

另请参见

  • 脱机分析
  • 使用 XML 格式的配置设置多个模块


E-mail（电子邮件）对话框

注意：

要使用此功能，必须首先在运行 Agilent Logic Analyzer 应用程序的计算机中设置电子邮件。有关设置电子邮件的信息，请参考操作系统的联机帮助或邮件应用程序的联机帮助。另请参见在逻辑分析系统上设置 Outlook Express。

某些邮件应用程序会阻止通过运行程序发送的电子邮件，因此请在使用前通过邮件应用程序对此功能进行测试。

To（收件人） | 电子邮件的发送地址。可以使用分号 (;) 分隔多个电子邮件地址来指定多个收件人。
Subject（主题） | 电子邮件的主题。
（消息） | 消息文本。

另请参见

  • 指定触发序列步骤的转至或触发操作
  • 创建新的时间间隔测量
  • 创建新的采样间隔测量
  • 更改标记的位置属性
  • 出现一定数量的比较差异后停止运行


在逻辑分析系统上设置 Outlook Express

Outlook Express 是随 Internet Explorer 和 Windows XP 操作系统一起安装在逻辑分析仪和逻辑分析系统上的。若要使用逻辑分析系统的 e-mail on 功能（基于触发、测量间隔、比较差异数发送电子邮件），则可以使用 Outlook Express。

在逻辑分析系统上设置 Outlook Express：

  1. 将 Outlook Express 设置为 Internet Explorer 中的默认电子邮件程序：

    1. 在 Internet Explorer 中，选择 Tools（工具）> Internet Options（Internet 选项）...。

    2. 在 Internet Options（Internet 选项）对话框的 Programs（程序）选项卡中，对于 E-mail（电子邮件）服务，选择 Outlook Express。

  2. 从网络或系统管理员那里获取电子邮件服务器和帐户信息，并在 Outlook Express 中配置邮件帐户:

    1. 在 Outlook Express 中，选择 Tools（工具）> Accounts （帐户）...。

    2. 在 Internet Accounts（Internet 帐户）对话框的 Mail（邮件）选项卡中，单击 Add（添加）> Mail（邮件）...。

    3. 在 Internet Connection Wizard（Internet 连接向导）中，使用从系统或网络管理员那里获得的电子邮件帐户信息按照向导说明进行设置。

  3. 确定 Security（安全）选项卡中的设置正确无误：

    1. 在 Outlook Express 中，选择 Tools（工具）> Options（选项）...。

    2. 在 Options（选项）对话框的 Security（安全）选项卡中，取消选中 Warn me when other applications try to send mail as me（当别的应用程序试图用我的名义发送电子邮件时警告我）。

  4. 从 Outlook Express 发送测试电子邮件。

  5. 测试逻辑分析系统的某一 e-mail on 功能。

另请参见

  • E-mail（电子邮件）对话框


Export（导出）对话框

使用 Export（导出）对话框可以将某些类型的数据从 Agilent Logic Analyzer 应用程序导出。

Standard CSV text file（标准 CSV 文本文件） | 可用于将数据从模块、工具或窗口中导出至逗号分隔值 (CSV) 格式的文本文件。这种文件类型用于将在外部应用程序（如 Microsoft Excel）中导入并查看的逻辑分析仪数据（请参见将数据导出为标准的 CSV 格式文件）。
Module CSV text file（模块 CSV 文本文件） | 只将数据导出至逗号分隔值 (CSV) 格式的文本文件。这种文件类型用于后处理工具，可使用数据导入模块 将其重新导入逻辑分析系统中（请参见将数据导出为模块 CSV 格式文件）。
Module binary file（模块二进制文件） | 只将模块数据导出至二进制格式的文件（请参见将数据导出为模块二进制 (ALB) 格式文件）。Agilent Logic Analyzer 应用程序的后续版本将能够使用数据导入模块 将模块二进制文件导入逻辑分析系统。
Pattern Generator CSV text file（码型发生器 CSV 文本文件） | 将码型发生器矢量序列导出至逗号分隔值 (CSV) 格式的文件（请参见将矢量序列导出为 CSV 格式文件）。


Export（导出）文件选择对话框

Export（导出）文件选择对话框可用于选择要将数据导出至其中的文件、数据来源、导出选项、数据样本范围，以及要导出的总线/信号。

File name（文件名） | 用于选择要将数据导出至其中的文件。
Save as type（另存类型） | 已根据在先前的 Export（导出）对话框中选择的文件类型选择了适当的类型。
Source（来源） | 用于选择数据来源。可选择的来源列表由在先前的 Export（导出）对话框中选择的文件类型确定。
Options（选项）... | 打开 File Export Options（文件导出选项）对话框，在该对话框中可针对先前 Export（导出）对话框中选择的文件类型选择适当的选项。
All Data（所有数据） | 选中时，将导出所有样本和所有总线/信号中的数据。
Data Range（数据范围）... | 未选中 All Data（所有数据）时，按下此按钮将打开 Range Properties（范围属性）对话框，可在其中选择数据样本导出范围。
Bus Signal Selection（总线信号选择）... | 未选中 All Data（所有数据）时，按下此按钮将打开 Range Properties（范围属性）对话框，可在其中选择导出中包括的总线/信号。

另请参见

  • 将数据导出为标准的 CSV 格式文件
  • 将数据导出为模块 CSV 格式文件
  • 将数据导出为模块二进制 (ALB) 格式文件
  • 将矢量序列导出为 CSV 格式文件


External Application Setup（外部应用程序设置）对话框

External Application Setup（外部应用程序设置）对话框可用于添加、编辑、排列或移除 Tools（工具）> External Applications（外部应用程序）> 菜单中的项。

Add Application（添加应用程序）... | 打开 Add Application（添加应用程序）对话框，指定新菜单项的参数。
Edit Application（编辑应用程序）... | 打开 Edit Application（编辑应用程序）对话框，更改所选菜单项的参数。
Delete Application（删除应用程序） | 从菜单项列表中删除选定的应用程序。
Move Up（上移） Move Down（下移） | 在菜单项列表中，将所选应用程序向上或向下移动。


External Application Add/Edit（外部应用程序添加/编辑）对话框

Add/Edit Application（添加/编辑应用程序）对话框可用于在 Tools（工具）> External Applications（外部应用程序）> 菜单中输入或修改项的参数。

Executable file（可执行文件） | 将在选择该菜单项后执行的文件的名称。
Application name（应用程序名称） | 该菜单项中显示的名称。
Command line（命令行） | 可执行文件的命令行选项。
Application directory（应用程序目录） | 包含可执行文件的目录。
Test Run（测试运行） | 此选项将使用给定的参数执行应用程序，以进行快速测试。


External Trigger（外部触发）对话框

逻辑分析仪（1680 系列的后面板、1690 系列的前面板以及 16900 的后面板）上带有 Trigger In 和 Trigger Out BNC 连接器。这些 BNC 连接器用于将分析仪连接到外部仪器，并发送或接收触发信号。

External Trigger（外部触发）对话框用于设置逻辑分析仪（或逻辑分析系统）与其他外部仪器之间的触发。

Trigger In

用于从其他源触发逻辑分析仪。您可以选择由上升沿或下降沿指示触发。

输入信号特性 | 1680/1690 系列 | 16900 系列
输入信号电平 | TTL，最高 5.5 V | 可选，最高 5.5 V
最小信号振幅 | 500 mV | 500 mV

Trigger Out

当逻辑分析仪触发时，向其他设备发送信号。您可以选择触发将显示为上升沿还是下降沿。

触发输出信号的设计负载为 50 Ohm。为获得良好的信号质量，建议触发输出信号在 50 Ohms 时接地。

对于 16900 系列逻辑分析系统机架，可以执行以下操作：

  • 启用或禁用（三态高阻抗）输出。
  • 选择输出的极性。
  • 选择输出模式为 Pulsed（脉冲）或 Feedthrough（馈通）（用于观察标志设置）。
  • 选择将导致触发信号输出的事件。
输出信号特性 | 1680/1690 系列 | 16900 系列
VOH（高电平输出） | >2.0 V（平均 3.3 V） | >2.0 V（平均 3.3 V）
VOL（低电平输出） | <0.5 V（平均 0 V） | <0.5 V（平均 0 V）
脉冲宽度 | 约 60-140 ns | 约 60-140 ns

另请参见

  • 触发其他仪器 - Trigger Out
  • 从其他仪器触发分析仪 - Trigger In


Find（查找）对话框

Find（查找）对话框可用于在采集的数据中搜索总线/信号码型。可以使用特定的位、数据码型、等式和范围运算符来限定搜索。搜索结果显示在显示屏的中央。

Find N occurrences（查找 N 个匹配项）

指定要搜索的匹配项数。

searching（搜索）

指定搜索方向是 Forward（向前）还是 Backward（向后）。

from（从）

指定搜索起始位置（Display Center（显示中心）、Beginning Of Data（数据开头）、End Of Data（数据结尾）、Trigger（触发点）或某个标记）。

（总线/信号码型事件）

指定想要查找的总线/信号码型事件。

除了常用的码型匹配运算符（=、!=、<、>、<=、>=、In Range 和 Not In Range）以外，还有三个运算符可以使用：

  • Entering — 与该码型匹配的一个或多个连续采样中的第一个样本。（而 = 运算符会考虑作为该码型匹配项而出现的每一个样本。）

  • Exiting — 与该码型匹配的一个或多个连续采样之后的样本。

  • Transitioning — 进入或退出与该码型匹配的一个或多个连续采样。

When（何时）

一种查找限定符（它用时间范围或其他限定符进一步限定查找条件）：

  • Present
  • Not Present
  • Present>（持续时间）
  • Present>=（持续时间）
  • Present<（持续时间）
  • Present<=（持续时间）
  • Present for Range
  • Not Present for Range
  • Entering
  • Exiting
  • Transitioning

使用查找限定符 Present>、Present>=、Present<、Present<=、Present for Range 和 Not Present for Range，可以指定某个持续时间。也就是说将根据指定的时间和运算符来查找在表达式中指定的事件。

其他限定符（Present、Not Present、Entering、Exiting 和 Transitioning）不允许使用持续时间。

Store Favorite（存储喜爱的码型）

用于存储喜爱的查找码型。

Recall Favorite（重新调用喜爱的项）

用于重新调用或删除喜爱的查找码型。

Clear（清除）

清除当前的查找码型。

Options（选项）...

打开 Find Options（查找选项）对话框，该对话框可用于指定 found 标记的放置。

Find（查找）

在不关闭 Find（查找）对话框的情况下执行查找。

Close（关闭）

关闭 Find（查找）对话框。

另请参见

  • 快速查找总线信号码型
  • 在采集的数据中查找总线/信号码型
  • 在采集的数据中查找复杂的总线/信号码型
  • 存储、重新调用或删除喜爱的查找码型
  • 指定 found 标记的放置


Frame/Module Information（机架/模块信息）对话框

Frame/Module Information（机架/模块信息）对话框用于显示有关逻辑分析系统机架 的详细信息。

System Name（系统名称） | 显示系统的主机名或 IP 地址。
System Details（系统详细信息） | 显示有关逻辑分析系统的详细信息。这包括有关机架的总体信息和每个模块的信息。只有基于模的逻辑分析仪（如 16900 系列逻辑分析系统）才能包含多个模块。
Set as Auto-Connect（设置为自动连接） | 将逻辑分析系统机架选为 Agilent Logic Analyzer 应用程序启动时使用的机架。在 Select System to Use（选择要使用的系统）对话框中，选为自动连接的机架的旁边将显示“auto-connect”（自动连接）字样。如果该机架已被设置为自动连接机架，则此按钮将变为“Clear Auto-Connect”（清除自动连接）。
Clear Auto-Connect（清除自动连接） | 按下此按钮后，可指定 Agilent Logic Analyzer 应用程序启动时不自动连接的逻辑分析系统机架。

请注意：

  • 在未建立任何自动连接的情况下，Agilent Logic Analyzer 应用程序会尝试通过本地机架联机，如果没有本地机架，则以脱机状态启动。

  • 自动连接机架的选择是按用户存储的，因此每个登录的用户均可建立不同的自动连接机架。

另请参见

  • 查看逻辑分析系统的详细信息


Import（导入）对话框

使用 Import（导入）对话框可以将某些类型的数据导入 Agilent 逻辑分析仪 应用程序。

Module CSV text file（模块 CSV 文本文件） | 使用数据导入模块 将 CSV 格式文本文件中的数据导入逻辑分析系统（请参见创建数据导入模块）。
Pattern Generator CSV text file（码型发生器 CSV 文本文件） | 将激发矢量导入码型发生器模块（请参见从 CSV 格式文件导入矢量序列）。
Pattern Generator binary file（码型发生器二进制文件） | 将设置信息和大量的激发矢量导入码型发生器模块（请参见导入 PattGen 二进制 (PGB) 格式文件）。
16700 Fast Binary Data（16700 快速二进制数据） | 从 16700 系列逻辑分析系统导入快速二进制数据（请参见导入 167xx 快速二进制数据）。


Import Setup（导入设置）对话框

Import Setup（导入设置）对话框是通过菜单栏的 Setup（设置）> (Data Import Module)（数据导入模块）> Bus/Signals（总线/信号）... 访问的。

该对话框由以下两个选项卡组成：

  • Buses/Signals（总线/信号） － Buses/Signals（总线/信号）选项卡用于在数据导入模块中编辑总线和信号名称。此外，还可用于为总线或信号分配默认数基和极性。请参见 Buses/Signals（总线/信号）选项卡。

  • File Information（文件信息） － File Information（文件信息）选项卡用于描述所导入文件的内容。请参见 File Information（文件信息）选项卡。


Buses/Signals（总线/信号）选项卡

Buses/Signals（总线/信号）选项卡用于在数据导入模块中编辑总线和信号名称。还可以使用 Buses/Signal（总线/信号）选项卡设置极性、设置默认数基和用户注释。

Buses/Signals（总线/信号）选项卡是通过菜单栏的 Setup（设置）> (Data Import Module)（数据导入模块）> Bus/Signals（总线/信号）... 命令访问的。

通过 Display（显示）按钮可以选择显示哪些总线/信号设置信息。

Bus/Signal Name（总线/信号名称）列中的总线和信号图标通常为红色，但如果该总线/信号被反汇编程序锁定，则会变为灰色。

只读选项

以下域是只读的，不能进行编辑。通过 Display（显示）按钮可以开启/关闭这些项目的显示。

Width（宽度）

Width（宽度）列显示每条总线上所分配的通道数。

Activity（活动）

Activity（活动）行显示每个通道的信号活动类型。

  • 下划线 = 稳定的低电平。

  • 上划线 = 稳定的高电平。

  • 跳变箭头 = 高低电平之间的活动的信号跳变。

Channel Numbers（通道数）

Channel Numbers（通道数）行显示盒的通道数

另请参见

  • 编辑数据导入模块的总线/信号定义
  • 使用数据导入模块


File Information（文件信息）选项卡

File Information（文件信息）选项卡用于描述所导入文件的内容。

File Information（文件信息）选项卡是通过菜单栏的 Setup（设置）> (Data Import Module)（数据导入模块）> File Info（文件信息）... 命令访问的。

另请参见

  • 查看数据导入模块文件信息
  • 使用数据导入模块


Module Mapping（模块映射）对话框

使用 Module Mapping（模块映射）对话框可以将当前打开的配置文件中的模块设置信息映射到正在使用的逻辑分析系统模块。

如果打开的是 ALA 格式的配置文件，则模块必须是兼容的，这样才能使用该配置文件中的信息对模块进行设置。如果打开的是 XML 格式的配置文件，则可以使用来自任何模块的设置信息；不过，由于模块之间存在差异，某些设置可能无法映射。

Best-fit algorithm（最佳适应算法） | 将配置文件模块自动映射到当前机架。
手动映射 | Specify Mapping（指定映射）... 按钮用于打开 Specify Mapping（指定映射）对话框，以指定如何将配置文件模块映射到当前机架。
脱机模式 | 在脱机模式 下照原样载入配置文件。

另请参见

  • 从多模块系统获取模块设置/向多模块系统传送模块设置


自动模块映射的最佳适应算法

根据载入的配置文件是 XML 格式还是 ALA 格式，最佳适应算法会稍有不同。

载入 XML 格式的配置文件时：

对于配置文件中的任意给定模块：

  1. 该模块是否已拆分？

  2. 在 Overview（概览）窗口中查找同名模块。如果找到某个模块，则将配置载入该模块。

  3. 查找与配置文件模块具有同一特定 类型的第一个模块（按照 Overview（概览）窗口中显示的顺序自上至下查找）。如果找到某个模块，则将配置载入该模块。

    在此情况下，“特定”是指某类设备的不同系列，如 16750/1/2A/B 逻辑分析仪或 16753/4/5/6A 逻辑分析仪。

  4. 查找与配置文件模块具有同一常规 类型的第一个模块。

    在此情况下，“常规”是指不同类型的设备，如“逻辑分析仪”或“码型发生器”。

  5. 如果找不到上述任何一项，则：

    1. 在联机（本地 或远程）模式下，请勿载入模块。

    2. 在脱机模式下，创建 模块。

载入 ALA 格式的配置文件时：

对于配置文件中的任意给定模块：

  1. 查找与配置文件模块具有同一特定 类型的第一个模块（按照 Overview（概览）窗口中显示的顺序自上至下查找）。如果找到某个模块，则将配置载入该模块。

    在此情况下，“特定”是指某类设备的不同系列，如 16750/1/2A/B 逻辑分析仪或 16753/4/5/6A 逻辑分析仪。

  2. 如果找不到，则跳过此操作。

注意：

在脱机模式下：

    载入 ALA 格式的配置文件时，总是 会在 Overview（概览）窗口中执行一次“清除”。因此，不需要任何匹配算法。

    载入 XML 格式的配置文件时，将使用 XML 的最佳适应算法。

另请参见

  • Module Mapping（模块映射）对话框


Module Skew and System Trigger（模块偏移与系统触发）对话框

此对话框在逻辑分析仪或逻辑分析系统中有多个模块 时可用。可以使用此对话框来：

  • 指定哪个模块是系统触发（即哪个模块的触发参考点是 Time=0）。

  • 为非系统触发 模块指定触发参考点偏移。

当选中 First module to trigger designates the System Trigger（要触发的第一个模块指定为系统触发）时，下一次运行之后要触发的第一个模块将被选作系统触发。取消选中此选项然后再次选中将使当前已第一个触发的模块成为所选的系统触发。

禁用的模块呈灰色。

另请参见

  • 设置模块之间的系统触发与偏移
  • 禁用和启用模块


Module Upgrade（模块升级）对话框

注意：

在安装经授权的硬件升级时，必须在包含要升级的卡的机架设备上运行 Agilent Hardware Update 程序。也就是说：

  • 在多机架逻辑分析系统中，必须在包含要升级的卡的每一个机架上运行 Agilent Hardware Update 程序。

  • 不能通过远程连接安装模块升级。

Determine if a Module is Upgradeable（确定模块是否可升级）选项卡

Show upgrade info（显示升级信息）... | 运行 Agilent Hardware Update 程序，安装经授权的硬件升级。Agilent Hardware Update（Agilent 硬件更新）对话框会显示模块是否可升级。

How to Install a Module Upgrade（如何安装模块升级）选项卡

Do upgrade（执行升级）... | 运行 Agilent Hardware Update 程序，安装经授权的硬件升级。


Netlist Import（网表导入）对话框

借助 Netlist Import（网表导入）对话框，您可以通过导入网表文件来设置总线/信号名称，并将它们分配给逻辑分析仪通道。网表文件来自用于设计被测设备的电子设计自动化 (EDA) 工具，其中包含了被测设备内置连接器上信号的有关信息，可供逻辑分析仪探头使用。

注意：

从网表文件导入总线/信号名称并将它们分配给逻辑分析通道以前，必须使用 Define Probes（定义探头）对话框来确定与逻辑分析仪一起使用的探头。

Netlist File（网表文件） | 用于输入或浏览查找要导入的网表文件的名称。
Trim Bus/Signal（缩短总线/信号名称长度）... | 打开 Trim Bus/Signal Names（缩短总线/信号名称长度）对话框后可以缩短从网表文件导入的总线/信号名称。

另请参见

  • 通过导入网表文件定义总线和信号


Offline Startup Options（脱机启动选项）对话框

在启动 Agilent Logic Analyzer 应用程序并且要以脱机模式 启动时会出现 Offline Startup Options（脱机启动选项）对话框（如果这不是所期望的，请参见如果意外地以脱机模式启动）。此对话框为可在脱机模式下执行的任务提供设置选项。

Go Online（联机）... | 打开 Select System to Use（选择要使用的系统）对话框，选择 Agilent Logic Analyzer 应用程序要连接到的机架。
Open File（打开文件）... | 打开逻辑分析仪配置文件。
Import（导入）... | 打开 Import（导入）对话框，将外来数据导入逻辑分析系统。
Create（创建）... | 打开 Create a New Configuration（创建新配置）对话框，创建新的逻辑分析仪配置文件。

另请参见

  • 如果意外地以脱机模式启动


Options（选项）对话框

要更改系统选项，请从菜单栏中，选择 Edit（编辑）> Options（选项）...。系统选项记录在 Windows 注册表文件中，并且适用于所有会话。

  • 系统选项
  • 总线/信号命名选项
  • 消息对话框/事件记录选项

系统选项

Trigger History Depth（触发历史记录深度）

最多可以保留 50 个最近使用的触发。请参见存储触发，了解有关重用触发的更多信息。触发历史记录保存在配置文件中。默认为 10 个。

Recent File List Entries（最近的文件列表条目）

此选项用于设定在 File（文件）菜单中显示多少个最近载入的配置文件。默认为 4 个。

Repetitive Run Delay（重复运行延迟）

可以利用重复测量之间的延迟来查看采集的数据，并决定在下一测量开始之前是否停止测量。

Start Maximized（以最大化窗口形式启动）

指定启动 Agilent Logic Analyzer 应用程序时是否最大化主窗口。

Create Demo Data when offline（脱机时创建演示数据）

运行分析仪时会创建仿真数据。当学习如何使用逻辑分析仪软件时这种模式很有用。

注意：

一般不通过仿真数据触发逻辑分析仪。不过也可以设置触发，但其结果将与使用实际采集的数据的情况不同。

Go to Trigger on Run（在运行时转至触发）

在进行逻辑分析仪测量时指定是否自动定位显示窗口使其显示触发分析仪的数据附近的内容。

Enable Numeric Grouping（启用数字分组）

数字分组在每四个十六进制和二进制数字之间以及每三个八进制数字之间加入空格，在每三个十进制数字之间加入逗号（如 FFFF FFFF、1111 1111、777 777 和 999,999）。

Default Folders（默认文件夹）...

打开 Default Folders（默认文件夹）对话框，指定配置文件、导出文件和导入文件的默认文件夹位置。

总线/信号命名选项

如果在多个模块中定义了相同的总线/信号名称：

Short（短） | 即使总线/信号名称相同，也只显示总线/信号名称，而不显示模块名称。也就是说可能出现这种情况，显示的两条总线的名称都是 ADDR，但实际上它们并不属于同一条总线。（不过通过将鼠标悬停于总线/信号名称之上，可以在工具提示中看到模块名称。）
Unique（唯一） | 在完全相同的总线/信号名称前附加模块名称，例如，Module 1:ADDR 和 Module 2:ADDR。

消息对话框/事件记录选项

和任何其他程序一样，Agilent Logic Analyzer 应用程序也会生成事件消息。您可以选择显示哪些消息。选中相应的框即表示您希望显示这些对话框。

Show Information Dialogs（显示信息对话框） | 信息对话框提供诸如简单触发的位置之类的提示，不指示故障。
Show Warning Dialogs（显示警告对话框） | 当某设置（如脱机）可能影响数据时会出现警告对话框。
Show Error Dialogs（显示错误对话框） | 当不能按规定完成某一操作时会出现错误对话框。
事件记录 | 可以选择将所有事件记录在一个日志文件中。事件记录会减慢逻辑分析仪的运行速度。通过 Help（帮助）> Status Log（状态日志）可以查看事件日志。请按 Agilent Technologies 支持人员的指示设置事件记录级别。恢复正常使用时一定要关闭事件记录。


Pod Assignment（盒分配）对话框

使用 Pod Assignment（盒分配）对话框可以为时间标签存储保留盒 或盒对。当一个逻辑分析仪模块 分成两个模块时，还可以使用此对话框重新分配盒或盒对。

如果选择 highest acquisition memory depth（最高采集内存深度），并且有一个盒对未分配总线或信号，则该盒对会自动保留用于时间标签存储，而无需使用此对话框。

盒/盒对 | 指示要分配或保留的盒或盒对。
（模块选择） | 针对每一盒或盒对，选择要分得它的模块，或者将其留给时间标签存储。
Master Pods（主盒） | 表示该盒或盒对位于主卡上。

另请参见

  • Split Analyzer Setup（拆分分析仪设置）对话框
  • 内存深度和通道数权衡
  • 盒和通道的命名约定


Printing Data（打印数据）对话框

选择 File（文件）> Print（打印）... 后，可以使用此对话框打印来自显示窗口的当前测量数据。

注意：

第一次访问打印对话框时，系统会要求安装打印机。请按照所显示的打印机安装对话框中的说明进行安装。

Printer（打印机） | 选择打印机，更改其属性，以及预览打印输出。
Print What（打印内容） | 选择打印哪个显示窗口的内容以及指定打印选项。
Scaling（缩放） | 指定在每张纸上打印的页数。
Copies（份数） | 指定打印份数。
Print range（打印范围） | 可以打印 All（全部）数据，或者只打印使用时间、样本编号或标记位置定义的某一范围内的数据。数据是按时间/样本编号的从小到大的顺序打印的。

另请参见

  • 打印采集的数据
  • 安装打印机
  • 连接局域网


Properties（属性）对话框

Properties（属性）对话框是通过菜单栏的 Window（窗口）> Properties（属性）... 来访问的。该对话框用于设置窗口和数据的显示方式。

  • 更改 Waveform（波形）窗口属性
  • 更改 Listing（列表）窗口属性
  • 设置 Compare（比较）窗口的属性
  • 更改 Source（源代码）窗口属性
  • 更改标记属性


Range Properties（范围属性）对话框

Data Range（数据范围）选项卡

指定导出的数据范围。

Time（时间） | 按时间指定导出的数据范围。
Marker（标记） | 按标记指定导出的数据范围。

Bus/Signal Selection（总线/信号选择）选项卡

指定从中导出数据的总线/信号源。

Select All（全选） | 选择所有总线/信号。
Select None（取消全选） | 取消选择所有总线/信号。

另请参见

  • 将数据导出为 CSV 格式文件


Recall Trigger（重新调用触发）对话框

使用 Recall Trigger（重新调用触发）对话框可以：

  • 从以下位置重新调用以前使用的触发：
    • 收藏夹列表。
    • 最近使用项列表。
    • XML 格式的触发设定文件。
  • 将最近使用的触发移至收藏夹列表。
  • 重命名触发。
  • 从收藏夹或最近使用项列表中清除触发。
  • 查看触发详细信息。

注意：

收藏夹列表是和逻辑分析仪配置保存在一起的。如果载入新配置文件，则收藏夹列表将被覆盖。

Rename（重命名）

用于编辑高亮显示的触发的名称。

Clear（清除）

从列表中清除高亮显示的触发。

Clear All（全部清除）

从 recall 列表中清除所有触发。

Details（详细信息）

显示高亮显示的触发的完整定义。

Open（打开）...

重新调用以前保存到 XML 格式触发设定文件的触发。

注意：

当触发存储到 XML 格式的触发设定文件时，触发序列步骤会转换成高级 If/Then 触发函数。因此，从 XML 格式文件重新调用触发时，它看上去可能是不同的；但它等同于所保存的触发。

另请参见

  • 存储触发
  • 重新调用触发
  • 设置触发历史记录深度


Select Symbol（选择符号）对话框

使用 Select Symbol（选择符号）对话框可以选择当数基设置为 Symbols（符号）时要使用的符号。

在以下对话框中使用 Symbols（符号）数基时，Select Symbol（选择符号）对话框将处于可用状态。

  • Find（查找）
  • Filter/Colorize（过滤/着色）
  • Specifying Simple Triggers（指定简单触发）
  • Advanced Trigger（高级触发）对话框

在 Select Symbol（选择符号）对话框中：

Symbol Name to find（要查找的符号名）

通过在此域中键入字符来筛选符号列表。还可以使用通配符：

  • *（星号）代表零个或更多字符。
  • ? （问号）代表单个字符。

单击符号列表中的某一列标题即可按该列进行排序。

Name（名称）

列出了为该总线定义或载入的符号名（请参见设置符号）。

Type（类型）

列出了符号类型（如区段、变量、函数等）。基于该列进行排序时，各个类型对应的符号分别按名称排序。

Value（值）

列出了符号值。

Base（基）

显示了符号值的数基。

File（文件）

显示符号所在的高级语言源代码文件。基于该列进行排序时，各个文件对应的符号分别按值排序。

Select（选择）

当所选符号对应着某一范围的值时，可以选择该范围的 Start Value（起始值）、End Value（结束值），如果所选符号用于范围设置，则可以选择该范围的 Start and End Values（起始值和结束值）。

Add Offset (Hex)（添加偏移（十六进制））

用于给所选符号值添加一个偏移，比如在对代码进行了再定位的情况下。

请注意，在使用偏移时，系统会存储“真实的”值，而不是存储“符号 + 偏移”值。这可能导致“符号 + 偏移”的显示与所输入的内容不同。例如，对于：

     符号            值
------------   ------
RangeSymbol1   00..10
RangeSymbol2   11..20
Symbol3        21
Symbol4        22
Symbol5        FF

  • 如果输入“Symbol3 + 1”，系统会将其解释为 22，同时它也是 Symbol4。因此，即使输入了“Symbol3 + 1”，系统也会显示 Symbol4。

  • 如果输入“RangeSymbol2（结束值）+ 1”，它将显示为 Symbol3。

  • 如果输入“RangeSymbol1（起始值）+ 12”，它将显示为“RangeSymbol2+1”。

  • 符号值可以“回环”，如“Symbol5 + 1”，其结果是 00。在这种情况下，若输入“Symbol5 + 1”，符号结果是 RangeSymbol1。

另请参见

  • 设置符号
  • Symbols（符号）对话框


Select System to Use（选择要使用的系统）对话框

使用 Select System to Use（选择要使用的系统）对话框可以选择要连接的逻辑分析系统机架，并管理机架列表。

本地系统是指与运行 Agilent Logic Analyzer 应用程序的机器相连的机架。远程系统是指与网络上其他位置的机器相连的机架。远程系统列表的管理没有一定之规。远程系统列表是按用户存储的（每个用户都有自己的可定制远程系统列表）。

Host Machine（主机） | 显示列表中机架的主机名。绿色和红色指示符分别表示能够和不能连接到该机架或者能够和不能获得来自该机架的信息。
状态 | 显示机架是处于可用、脱机（即已断电）、当前使用中状态，还是有不兼容的远程服务（即其软件需要升级，以便与显示此对话框的机器上所安装的软件的版本匹配）。
Analyzer Description（分析仪描述） | 显示逻辑分析仪机架的类型。
In Use Comment（使用中注释） | 显示远程系统的“系统使用中”注释。
Connect Local（连接本地）/ Connect Remote（连接远程） | 连接到所选的逻辑分析系统（本地或远程）。
Details on Selected Local/Remote System（所选本地/远程系统的详细信息） | 打开 Frame/Module Information（机架/模块信息）对话框，显示所选逻辑分析系统的详细信息，也可以从中设置或清除该机架的自动连接。
Password Protect Local Systems from Remote Connections（本地系统的远程连接密码保护） | 打开 Remote Access Password Utility（远程访问密码实用工具）对话框，设置远程连接密码。此 Select System to Use（选择要使用的系统）对话框顶部的状态消息会显示当前是否设置了远程访问密码。
Add Remote System（添加远程系统） | 输入要添加到列表的远程系统的主机名或 IP 地址。
Delete Remote System（删除远程系统） | 从远程系统列表中删除选中的系统。
Refresh（刷新） | 更新列表中的逻辑分析系统信息。要刷新此列表，必须单击 Refresh（刷新）。
Set "System In Use" Comments（设置“系统使用中”注释） | 打开一个对话框，以便在连接到所选系统以前从中输入一些注释。如果另一个 Agilent Logic Analyzer 应用程序试图连接到您当前所连接的系统，则会显示您的“系统使用中”注释。这些注释可用于说明使用某一特定系统的原因，提供联系信息，等等。
Close（关闭） | 关闭该对话框，中止与本地系统或远程系统的连接操作。系统将处于“脱机”模式。

另请参见

  • 返回联机分析


Software Licensing（软件授权）对话框

Software Licensing（软件授权）对话框用于管理逻辑分析系统所使用的软件许可证。该对话框有四个选项卡：

  • Summary（摘要）选项卡
  • Activation（激活）选项卡
  • Floating License Servers（浮动许可证服务器）选项卡
  • Borrow（借用）选项卡

另请参见

  • 管理软件许可证


Summary（摘要）选项卡

Software Licensing（软件授权）对话框的 Summary（摘要）选项卡用于显示可在逻辑分析系统中使用的许可证的有关信息。

Active Software Licenses（有效的软件许可证）层次结构中的文件夹显示经授权可以使用的软件。红勾表示当前使用的是浮动许可证。文件夹旁的红 X 表示此软件未安装。

文件夹中显示了各个许可证的状态。

Show Details（显示详细信息）... | 打开一个对话框，显示所选许可证的详细信息。
Copy to Clipboard（复制到剪贴板） | 将软件授权摘要信息复制到剪贴板。

另请参见

  • 查看有效的软件许可证信息


Activation（激活）选项卡

Software Licensing（软件授权）对话框的 Activation（激活）选项卡中包含了激活软件许可证所需的 Licensing Host ID（授权主机 ID）。

Licensing Host ID（授权主机 ID） | 获取软件工具的许可证文件时会用到此 ID。

另请参见

  • 激活软件许可证


Floating License Servers（浮动许可证服务器）选项卡

使用 Software Licensing（软件授权）对话框的 Floating License Servers（浮动许可证服务器）选项卡可以识别和排序提供浮动证的服务器。

当许可证需要登记借出时，License Servers（许可证服务器）列表会被依次搜索，并且会从第一个拥有可用许可证的服务器登记借出许可证。

Add Server（添加服务器）...

打开一个对话框，可在其中输入浮动许可证服务器的计算机名和端口号。

小心：

只能输入属于浮动许可证服务器的计算机（或逻辑分析仪）的名称。否则，许可证管理器界面会尝试确定该计算机是否为浮动许可证服务器，这会导致界面在数分钟内处于挂起状态。

Delete Server（删除服务器）

从列表中删除选中的服务器。

上移

提高所选服务器在搜索顺序中的位次。

下移

降低所选服务器在搜索顺序中的位次。

Refresh（刷新）

更新绿色或红色的服务器可用性指示符。这只表明服务器计算机是否在网络上，而不表明许可证服务器软件是否正在该计算机上运行。

Apply（应用）

要转至 Summary（摘要）或 Borrow（借用）选项卡，必须先应用许可证服务器更改。

另请参见

  • 访问浮动许可证服务器


Borrow（借用）选项卡

使用 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡可以从某服务器借用浮动许可证一段时间，例如，在将逻辑分析仪（或运行 Agilent Logic Analyzer 应用程序的计算机）带出办公室（或者只是离开网络）期间。当借用许可证期满时，许可证会自动返还给服务器。不过也可以使用 Borrow（借用）选项卡提前归还许可证。

Borrow Licenses（借用许可证） | 可以输入许可证的借用期限并借用许可证。默认期限为七天。最短为十分钟。另请参见 Borrow Licenses（借用许可证）区域中的消息。
Return Borrowed Licenses（归还借用的许可证） | 提前归还借用的许可证。所有借用的许可证必须同时归还。若有许可证是登记借出（但尚没有借出）的，则不能归还借用的许可证。另请参见 Return Borrowed Licenses（归还借用的许可证）区域中的消息。

另请参见

  • 借用浮动许可证和提前归还


Borrow Licenses（借用许可证）区域中的消息

这些消息可能出现在 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡中。

Borrowing is not supported while in Demo Center Mode.
使用 Demo Center（演示中心）功能时不能借用许可证。
This configuration is not using any licenses.There is nothing to borrow.
当前没有使用许可证，因此无需借用。
This configuration is not using any floating licenses.There is nothing to borrow.
如果正在使用的许可证都处于节点锁定状态，则没有可以借用的许可证。
The licenses for this configuration cannot be borrowed because some are node-locked.
同时使用浮动许可证和节点锁定许可证时不能借用许可证。
Click on the Borrow button to borrow licenses used by this configuration.
显示此消息时，可以借用当前配置所使用的许可证。
Click on the Borrow button to borrow additional licenses used by this configuration.
显示此消息时，有些许可证已经借用，但可以借用当前配置所使用的其他许可证。
All licenses needed by this configuration are already borrowed.
显示此消息时，使用中的所有许可证都已经被借用。要借用其他许可证，请打开需要许可证的功能部件，返回 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡。


Return Borrowed Licenses（归还借用的许可）区域中的消息

这些消息可能出现在 Software Licensing（软件授权）对话框的 Borrow（借用）选项卡中。

The following licenses cannot be returned while some servers are not configured.
如果许可证是从当前未配置的服务器登记借出的，则不能提前归还。
The following licenses cannot be returned while licenses are still checked out.
若有许可证是登记借出的（不是借用），则不能提前归还借用的许可。
The following licenses are currently borrowed for exclusive use on this system.
显示此消息时，可以提前归还借用的许可。


Source Viewer Properties（源代码查看器属性）对话框

  • Source Properties（源代码属性）选项卡
  • Source Code Directories（源代码目录）选项卡
  • Correlation Bus（关联总线）选项卡

Listing Properties（列表属性）、Column Properties（列属性）和 Marker Properties（标记属性）选项卡与 Listing（列表）窗口中的是相同的。

另请参见

  • 更改 Listing（列表）窗口属性
  • 更改总线/信号列属性


Source Properties（源代码属性）选项卡

使用 Source Viewer Properties（源代码查看器属性）对话框的 Source Properties（源代码属性）选项卡可以设置背景颜色和字体大小以及显示选项（如用于制表符的空格数和是否显示行号等）。

另请参见

  • 更改 Source（源代码）窗口属性
  • Source Viewer Properties（源代码查看器属性）对话框


Source Code Directories（源代码目录）选项卡

使用 Source Viewer Properties（源代码查看器属性）对话框的 Source Code Directories（源代码目录）选项卡可以指定源代码所在目录。这是必要的，因为如果编译和调试在不同的计算机上进行，那么在符号文件中指定的源文件路径就不一定有效。可以指定多个目录并更改其顺序。目录是依次搜索的，也可以指定是否搜索子目录。

另请参见

  • 编辑源代码目录列表
  • Source Viewer Properties（源代码查看器属性）对话框


Correlation Bus（关联总线）选项卡

使用 Source Viewer Properties（源代码查看器属性）对话框的 Correlation Bus（关联总线）选项卡可以指定总线（其行号符号用于源代码关联）。通常都是选择反汇编程序工具所生成的“软件地址”总线或另一条地址总线。

另请参见

  • 选择相关总线
  • Source Viewer Properties（源代码查看器属性）对话框


Specify Mapping（指定映射）对话框

使用 Specify Mapping（指定映射）对话框可以将配置文件中的模块手动映射到逻辑分析系统中的模块。

Specify Mapping（指定映射）对话框顶部列出了正在载入的文件中的模块配置。对话框的下部列出了逻辑分析系统中的模块。选择 Nothing（无）表示不使用任何正在载入的模块配置。

注意：

如果无法将 ALA 格式配置文件中的设置信息载入到某一模块，则说明这些模块不兼容，在这种情况下需要使用 XML 格式配置文件来传递模块设置信息（请参见无法打开 ALA 格式的配置文件）。

另请参见

  • Module Mapping（模块映射）对话框
  • 从多模块系统获取模块设置/向多模块系统传送模块设置
  • ALA 与 XML 的各自使用场合


Split Analyzer Setup（拆分分析仪设置）对话框

一个逻辑分析仪模块 可以拆分成两个逻辑分析仪模块，比如用不同的时钟信号探测两条总线的情况。

注意：

拆分逻辑分析仪模块时，拆分后的模块之中必须有一个处于状态采样模式（不能全是定时采集模式）。

使用 Split Analyzer Setup（拆分分析仪设置）对话框可以指定每个模块中所使用的通道数。

Channel Assignment（通道分配） | 拖动滑块即可在逻辑分析仪模块间拆分通道。
Advanced Pod Assignment Mode（高级盒分配模式） | 选中此选项可以更具体地控制将哪些盒 或盒对 分给各个模块或者保留用于时间标签存储。 Master Pods（主盒）表示盒或盒对位于主卡上。

另请参见

  • 配置逻辑分析仪模块
  • 内存深度和通道数权衡
  • 盒和通道的命名约定


Status（状态）对话框

System Status（系统状态）选项卡

显示逻辑分析系统的状态。

Resume（继续执行） | 恢复取消的所选模块、工具或窗口处理。
Cancel（取消） | 取消对所选模块、工具或窗口的处理。
Details（详细信息）... | 显示所选模块、工具或窗口的详细信息。 例如，模块详细信息包括：触发步骤、发生计数器、全局计数器、标志以及定时器状态。

通过右键单击鼠标并从弹出菜单中选择 Copy（复制），可将模块、工具或窗口的状态复制到剪贴板。

Status Log（状态日志）选项卡

显示逻辑分析系统的状态日志。

可以选择要显示的日志消息的类型，也可以清除日志。

另请参见

  • Options（选项）对话框


Symbols（符号）对话框

使用 Symbols（符号）对话框可以定义、复制和编辑整个系统的符号。

表示用户定义的符号。

表示符号文件。符号文件可以是编译器生成的包含符号的对象文件，也可以是通用的 ASCII (GPA) 格式的符号文件。

Load（载入）... | 如果选择了某一总线/信号，单击此按钮时将打开 Select Symbol File（选择符号文件）对话框，然后可以从编译器生成的对象文件或通用的 ASCII (GPA) 格式的符号文件载入符号。 如果选择了符号文件，则重新载入该文件。
Add（添加）... | 将用户定义的符号添加到选中的总线/信号。
Edit（编辑）... | 编辑选中的用户定义的符号。
Delete（删除） Delete All（全部删除） | 从列表中删除选中的用户定义的符号或符号文件（如果选择了某一总线/信号，则删除所有符号）。
Move Up（上移） Move Down（下移） | 在列表中上移或下移选中的用户定义的符号或符号文件。当系统查找与某一总线/信号值对应的符号时，将使用第一个匹配项。（一个给定的值可能对应多个符号。）

另请参见

  • 设置符号
  • 显示总线/信号值的名称（符号）


System Summary（系统摘要）对话框

System Summary（系统摘要）对话框用于查看系统中所有模块的摘要信息，包括系统中的卡的物理视图（Slot Summary（插槽摘要））、所有模块及其触发时间的列表（Module Summary（模块摘要））以及所有探头的连接方式列表（Probe Summary（探头摘要））。

  • Slot Summary（插槽摘要）选项卡
  • Module Summary（模块摘要）选项卡
  • Probe Summary（探头摘要）选项卡

另请参见

  • Analyzer Setup（分析仪设置）对话框


Slot Summary（插槽摘要）选项卡

对于选定的 frame（机架）（如果有多个机架），Slot Summary（插槽摘要）选项卡显示：该逻辑分析系统机架中的 slots（插槽）、cards（卡） 和 modules（模块），或者独立逻辑分析仪中的 cards（卡） 和 modules（模块）。

另请参见

  • System Summary（系统摘要）对话框


Module Summary（模块摘要）选项卡

对于逻辑分析系统中的各个 模块，Module Summary（模块摘要）选项卡显示该模块所在的 frame（机架）、构成该模块的 cards（卡）、这些卡所在的 slots（插槽）以及发生触发的时间。

另请参见

  • System Summary（系统摘要）对话框


Probe Summary（探头摘要）选项卡

Probe Summary（探头摘要）选项卡显示逻辑分析仪盒和通道、探头类型以及这些盒和通道要连接的被测设备中的连接器或信号。

探头类型可以由其自身定义，也可以在 XML 配置文件中或在导入网表时定义（以便将总线/信号名称分配给逻辑分析仪通道）。如果尚未定义探头类型，则探头默认为飞线探头。

注意：

在将差分探头通道引脚/衬垫/引线对连接到单端信号时，一定要将负引脚/衬垫/引线接地，将正引脚/衬垫/引线接到单端信号。

另请参见

  • 定义探头
  • System Summary（系统摘要）对话框
  • 使用 Probe Summary（探头摘要）连接探头


Target Control Port（目标控制端口）对话框

16900 系列逻辑分析系统机架 都有一个目标控制端口，这是一种 8 位、3.3V 规格的端口，用于向被测设备发送信号。目标控制端口的工作方式与码型发生器不同，它更像是控制被测设备中开关的远程控件。

对于选定的机架（如果有多个机架），使用 Target Control Port（目标控制端口）对话框可以设置目标控制端口上的输出信号电平。

Signal（信号） | 标识目标控制端口信号。
Enabled（启用） | 启用或禁用目标控制端口上的输出信号。禁用时，该信号有一个三态高阻抗输出。启用时，该信号输出标准的 3.3V 逻辑电平，1 表示高，0 表示低。
Write（写） | 提供两个按钮 0 和 1，分别用于将该信号输出值改为标准的 3.3V 逻辑低电平或逻辑高电平。
Observed Value（观测值） | 显示在目标控制端口信号上观测到的信号值。
Toggle（切换） | 切换该信号的设置，并使之保持。例如，如果信号设置为 1，单击 Toggle（切换）时，此设置将变为 0。
Pulse（脉冲） | 使设置翻转一个时钟周期的时间，最短为 16ms。脉冲持续时间可以更长，但不能指定脉冲周期。

另请参见

  • 控制被测设备中的信号


Thresholds and Sample Positions（阈值和采样位置）对话框

Thresholds and Sample Positions（阈值和采样位置）对话框用于定位逻辑分析仪的设置/保持窗口（或采样位置），并指定阈电压，以便准确采集高速总线的数据，即，在数据有效时对其进行采样。

当被测设备的数据有效窗口小于 2.5 ns 时（大约相当于时钟速度 >= 200 MHz），使用 eye finder 定位信号的稳定区域和跳变区域并自动调整采样位置最为简便。

Eye finder 可测量稳定区域边界的位置，并将逻辑分析仪的采样位置置于稳定区域的中心。Eye finder 还可调整阈电压设置，将所测稳定区域的宽度设为最大。

当被测设备的数据有效窗口大于 2.5 ns 时（大约相当于时钟速度 < 200 MHz），手动调整采样位置最为简便，无需使用逻辑分析仪定位信号的稳定区域和跳变区域。

Legend（图例）

描述总线/信号图中显示的项。

Display（显示）

允许您显示或隐藏下列对象：

  • Threshold and Sample Position（阈值和采样位置）列。
  • Messages（消息）列。
  • 电压信息。

Advanced（高级）...

打开 Eye Finder Advanced Options（Eye Finder 高级选项）对话框，设置测量持续时间和运行模式选项。

Buses/Signals（总线/信号）

允许您选择要对其运行 eye finder 的总线/信号。您可以展开或覆盖总线中的信号、选择所有信号或不选择任何信号、选择单个信号或选择多个信号。

如果某个通道出现在多个总线/信号中，那么选择该通道将意味着在所有这些总线/通道中选择它。

运行 eye finder 后，可以右键单击任意总线/信号名称，并选择 Properties（属性）...打开 Eye Finder Properties（Eye Finder 属性）对话框，从而查看有关测量结果的其他信息。

总线/信号图

显示“眼”的数字图，该图将展示针对采样时钟采集的多个数据样本。在采样时钟之前和之后测量的跳变沿将生成眼形图片。

该显示区域将显示以下内容：

  • 信号的跳变区域（深色）和稳定区域（浅色）。色彩强度将显示跳变较普遍（较深的橙色）和较稀少（较浅的橙色）的位置。

  • 建议的采样位置（绿色三角形）。

  • 当前采样位置（稳定区域内的蓝色竖线，跳变区域内的红线）。

  • 显示电压信息时，会显示当前阈电压设置（稳定区域内的蓝色横线，跳变区域内的红线）。如果单击并拖动由采样位置线和阈值设置线组成的“+”号，则会同时调整这项设置；要分别调整每项设置，请单击并拖动相应的虚线。请注意，调整阈值设置将影响同一个盒中的所有通道，（有时还会影响盒的时钟输入）。

为提供有关信号的更多信息，尽管采样位置只能设置为 +/-3.25 ns，但显示范围仍会覆盖 +/-5 ns。

Threshold and Sample Position（阈值和采样位置）

显示阈电压和采样位置设置的数值。单击此列可显示用于调整设置的输入字段。此外，您也可以将采样位置条和阈电压条拖动到新的位置。

Messages（消息）

此列显示以下消息：

  • 信息性消息图标。您可以将鼠标指针移至图标上，以显示弹出消息。
  • 上次运行 eye finder 测量时显示的时间戳信息。

Run（运行）

运行 eye finder，以自动调整状态采样位置和阈电压设置。

(Type of Run)（运行类型）

指定 eye finder 的运行类型。可以从下列各项中进行选择：

  • Auto Sample Position Setup（采样位置自动设置）。指示 eye finder 执行扫描，并且最终只对采样位置进行自动设置。阈电压设置不变。

  • Auto Sample Position Setup（阈值和采样位置自动设置）。指示 eye finder 查找信号活动包络和最佳阈电压（方法是调整阈电压并观察活动指示符），然后在该阈值处执行扫描，并最终自动设置采样位置。例如：

  • Eye Scan with Threshold and Sample Position Setup（设置阈值和采样位置进行 Eye Scan）。指示 eye finder 对整个信号活动包络执行扫描，最终生成总线/信号“眼”图（包含更多电压信息）并自动设置阈电压和采样位置。例如，下面是一个信号的眼扫描：

  • Eye Scan with Sample Position Setup Only（仅设置采样位置进行 Eye Scan）。指示 eye finder 对整个信号活动包络执行扫描，最终生成总线/信号“眼”图（包含更多电压信息），并且仅自动设置采样位置。阈电压设置不变。

另请参见

  • 了解状态模式采样位置
  • 选择/建议的位置的行为方式
  • Eye Finder 信息消息
  • 自动调整状态采样位置和阈电压
  • 手动调整状态采样位置


Eye Finder Advanced Options（Eye Finder 高级选项）对话框

Measurement Duration（测量持续时间）

Short（短） | Eye finder 将对每个通道进行 50,000 个时钟周期的探测，以确定建议的采样位置。此设置需要在所有通道上进行频繁转换。
Medium（中） | Eye finder 将对每个通道进行 500,000 个时钟周期的探测，以确定建议的采样位置。此设置用于以正常速率进行转换的通道。
Long（长） | Eye finder 将对每个通道进行 5,000,000 个时钟周期的探测，以确定建议的采样位置。此设置用于具有偶发转换的某些通道。
Custom（自定义） | 允许您指定在每个采样位置（每个时间点）对每个通道进行采样的时钟周期数。

以下是选择 Eye finder 高级设置时要考虑的一些事项：

  • 较高地址位的转换频率低于较低地址位，并且需要更多时钟周期。

  • 在不同时间由不同电路驱动的数据总线需要足够的时钟周期，才能观察到每个驱动程序对总线的影响。

当不同的通道需要不同的设置时，可以对通道子集运行 eye finder，以避免在大量通道上使用 Long（长）设置。

Run Mode（运行模式）

Run Repetitively（重复运行） | 重复运行 eye finder，以便您能够查看稳定信号和跳变信号如何随时间变化。
Accumulate Results（累积结果） | 如果选择此模式，则会对每次运行的 eye finder 数据进行累积。如果不选择此模式，则会在每次运行之前擦除 eye finder 数据。
Demo Mode（Demo 模式） | 允许您查看 eye finder 的演示数据。Demo 模式不会生成完整的眼扫描数据。


Eye Finder Properties（Eye Finder 属性）对话框

Eye Finder Properties（Eye Finder 属性）对话框用于显示有关 eye finder 测量结果的信息。

Bus/Signal（总线/信号） | 总线/信号的名称。
tPosition | 采样位置。
vThreshold | 阈电压。
vMin | 信号活动包络中的最小电压。
vMax | 信号活动包络中的最大电压。
Time of Measurement（测量时间） | 运行 eye finder 的时间。
# Accum（累计数） | 数据所代表的累计数。
Status（状态） | 来自 eye finder 的状态信息消息（请参见 Eye Finder 信息消息）。
Clock spec（时钟设定） | 确定采样时钟设置。
Sampling Mode（采样模式） | 确定产生采样时钟的插槽和盒，以及使用的状态采样时钟模式。


选择/建议的位置的行为方式

eye finder 的选择和建议的采样位置的行为方式如下：

选择的位置的行为方式

  1. 如果没有运行 eye finder，则可以将选择的位置（稳定区域中的蓝线或跳变区域中的红线）拖至所需位置。

  2. 当在某一通道上运行 eye finder 时，选择的位置会“对齐”建议的位置（绿三角）。

建议的位置的行为方式

  1. 建议的位置（绿三角）只在显示单个通道时显示。

  2. 在已进行测量的通道上只有一个建议的位置。

  3. 建议的位置始终位于最靠近选择的位置（蓝线或红线）的稳定区域中心位置。

  4. 如果将选择的位置移至另一个稳定区域，则建议的位置也会“跳”至该区域中央。

  5. 如果稳定区域是开区域，则建议的位置将与闭合端（可见边界）保持一个固定的距离；如果有多个时钟沿处于活动状态，则此距离会较大。


TimingZoom Setup（时序放大设置）对话框

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。

Sampling Period（采样周期） | 设置不同的采样分辨率，查看触发点附近的数据。
Trigger Position（触发位置） | 确定逻辑分析仪触发事件附近的时序放大采集内存。
Align Trigger With（触发参照标准） | 在一些较老的逻辑分析仪模块中，如果逻辑分析仪被拆分，则通过此选项可以指定应与哪个分析仪的触发时序放大保持一致。

另请参见

  • 使用时序放大
  • 逻辑分析仪说明，时序放大


触发函数

触发函数位于 Advanced Trigger（高级触发）对话框中，向您提供了用于一般测量的预配置触发设置。如果未提供您需要的触发函数，请从一个接近的触发函数开始，将触发序列步骤转换为高级 If/Then 触发函数，然后编辑 If/Then 触发函数。

  • 定时模式触发函数
  • 状态模式触发函数

另请参见

  • 将触发序列步骤显示为高级 If/Then 触发函数
  • 将触发序列步骤转换为高级 If/Then 触发函数
  • 从其他模块/仪器触发和向其他模块/仪器发送触发


定时模式触发函数

在定时采集模式下，以下触发设置示例可在 Advanced Trigger（高级触发）对话框中作为触发函数使用。要在示例测量上下文中查看这些触发设置，请参阅进行定时分析仪测量。

沿

  • Edge
  • "N" number of edges
  • Edge and Pattern
  • Edge followed by edge
  • Edges too far apart
  • Edge followed by pattern
  • Pattern too late after edge

总线码型

  • Pattern
  • Edge and Pattern
  • Pattern present for > "T" time
  • Pattern present for < "T" time
  • Pattern absent for > "T" time
  • Pattern absent for < "T" time
  • Edge followed by pattern
  • Pattern too late after edge

其他

  • Find anything "N" times
  • Width violation on pattern or pulse
  • Wait "T" seconds
  • Run until user stop
  • Wait for external arm
  • Wait for arm from another module

高级

  • Advanced If/Then
  • Advanced 2-Way Branch
  • Advanced 3-Way Branch
  • Advanced 4-Way Branch
  • Pattern "AND" Pattern
  • Pattern "OR" Pattern

另请参见

  • 在触发序列步骤中替换或插入触发函数
  • 状态模式触发函数
  • 存储触发
  • 重新调用触发


沿

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当用户定义的沿出现时，触发分析仪。

编辑此函数

  • 指定高级触发


"N" number of edges

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。分析仪在用户定义的沿出现 N 次时触发。

编辑此函数

  • 指定高级触发


Edge and Pattern

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当用户定义的沿和总线码型同时出现时，将触发分析仪。

编辑此函数

  • 指定高级触发


Edge followed by edge

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当沿 2 在沿 1 之后的指定时间段内出现时，将触发分析仪。

编辑此函数

  • 指定高级触发


Edges too far apart

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当沿 2 没有在沿 1 之后的指定时间段内出现时，将触发分析仪。

编辑此函数

  • 指定高级触发


Edge followed by pattern

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当某个总线码型在某个沿之后的指定时间段内出现时，将触发分析仪。

编辑此函数

  • 指定高级触发


Pattern too late after edge

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果在某沿出现之后的一段指定时间内未出现某一指定的总线码型，则逻辑分析仪触发。

编辑此函数

  • 指定高级触发


Pattern

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果出现指定的总线码型，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern present for > "T" time

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果用户定义的总线码型的存在时间大于指定时间，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern present for < "T" time

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果用户定义的总线码型的存在时间小于指定时间，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern absent for > "T" time

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果用户定义的总线码型的未出现时间大于指定时间，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern absent for < "T" time

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果用户定义的总线码型的未出现时间小于指定时间，则分析仪触发。

编辑此函数

  • 指定高级触发


Find anything "N" times（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当发现任何数据 (Anything) 出现第 N 次时，分析仪将触发。

编辑此函数

  • 指定高级触发


Width violation on pattern or pulse

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当发现过窄或过宽的脉冲或总线码型时，将触发分析仪。

编辑此函数

  • 指定高级触发


Wait "T" seconds

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。指定的时间段结束后将触发分析仪。

您可以输入的时间的最大值取决于逻辑分析仪的采样周期。如果需要等待的时间比允许的最长时间长，您可以使用定时器。

编辑此函数

  • 指定高级触发


Run until user stop（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。此触发函数设置为从不触发。必须选择停止按钮才能查看采集的数据。

编辑此函数

  • 指定高级触发


Wait for external arm （定时）

定时模式触发函数

Wait for external arm（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当外部 Trigger In（触发入）端口显示有外部通信信号时，将触发分析仪（请参见由其他模块/仪器触发和向其他模块/仪器发送触发）。Trigger In（触发入）BNC 连接器位于 1680 系列逻辑分析仪的后面板、1690 系列逻辑分析仪的前面板和 16900 系列逻辑分析系统的后面板上。

编辑此函数

  • 指定高级触发


Wait for arm from another module（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。另一个模块发出通信信号时将触发分析仪（请参见由其他模块/仪器触发和向其他模块/仪器发送触发）。

编辑此函数

  • 指定高级触发


高级 If/Then（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。分析仪在“If”子句变为 true 时触发。

编辑此函数

  • 指定高级触发


高级 2 路分支（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当两种码型中的任何一种（if 或 Else if）或两种同时出现时，二路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


高级 3 路分支（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当三种码型中的任何一种（If 或 Else if）出现时，三路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


高级 4 路分支（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。当四种码型中的任何一种（If 或 Else if）出现时，四路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


Pattern "AND" Pattern（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果 pattern1 和 pattern2 同时出现，并且出现了指定的次数 (occurs)，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern "OR" Pattern（定时）

此触发函数在采集模式设置为 Timing - Asynchronous（定时 - 异步）时可用。如果 pattern1 和 pattern2 之中有一个出现，并且出现了指定的次数 (occurs)，则分析仪触发。

编辑此函数

  • 指定高级触发


状态模式触发函数

在状态采集模式下，以下触发设置示例可在 Advanced Trigger（高级触发）对话框中作为触发函数使用。要在示例测量上下文中查看这些触发设置，请参阅进行状态分析仪测量。

码型

  • Pattern "N" times
  • "N" consecutive samples with Pattern1
  • Pattern1 followed by Pattern2
  • Pattern1 immediately followed by Pattern2
  • Pattern1 followed by Pattern2 before Pattern3
  • Too few states between Pattern1 and Pattern2
  • Too many states between Pattern1 and Pattern2
  • Pattern2 occurring too soon after Pattern1
  • Pattern2 occurring too late after Pattern1

其他

  • Reset and start timer
  • Find anything "N" times
  • Run until user stop
  • Wait for external arm
  • Wait for arm from another module
  • Wait "N" external clock states

高级

  • Advanced If/Then
  • Advanced 2-Way Branch
  • Advanced 3-Way Branch
  • Advanced 4-Way Branch
  • Pattern "AND" Pattern
  • Pattern "OR" Pattern

另请参见

  • 在触发序列步骤中替换或插入触发函数
  • 定时模式触发函数
  • 指定默认存储
  • 存储触发
  • 重新调用触发


Pattern "N" times

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果某一总线码型出现了 n 次（如下图所示），则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


"N" consecutive samples with Pattern1

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果某一总线码型出现了某一指定次数，则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Pattern1 followed by Pattern2

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果 pattern2 最终出现在 pattern 1 之后，则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Pattern1 immediately followed by Pattern2

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果在出现完 pattern 1 后立即出现 pattern 2，则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Pattern1 followed by Pattern2 before Pattern3

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果 pattern2 最终在 pattern 1 之后出现了指定的次数，并且在其间未出现 pattern3，则触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Too few states between Pattern1 and Pattern2

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当码型 1 后跟码型 2，且他们之间的状态数小于指定的“N”时，将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Too many states between Pattern1 and Pattern2

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当码型 1 后跟码型 2，且他们之间的状态数大于指定的“N”时，将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Pattern2 occurring too soon after Pattern1

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果 pattern2 在 pattern1 出现之后的一段指定时间内出现，则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Pattern2 occurring too late after Pattern1

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果在 pattern1 出现之后的一段指定时间内未出现 pattern2，则它将触发逻辑分析仪。

编辑此函数

  • 指定高级触发


Reset and start timer（状态）

注意：

此触发函数在 1683A/AD 和 1693A/AD 型号中不可用，因为它们没有定时器可用。

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。此触发函数用于在指定的时间后重置定时器，然后启动定时器。此触发函数要求在同一触发步骤或之后的触发步骤中设置定时器值。定时器停止时，分析仪触发。有关更多信息，请参阅配置定时器。

编辑此函数

  • 指定高级触发


Find anything "N" times（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。此功能将在任何数据 (Anything) 出现第 N 次时触发逻辑分析仪。通常用于创建即时触发，或用户定义的延迟之后的触发。

编辑此函数

  • 指定高级触发


Run until user stop（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。此触发函数设置为从不触发。必须选择停止按钮才能查看采集的数据。

编辑此函数

  • 指定高级触发


Wait for external arm（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当外部 Trigger In（触发入）端口显示有外部通信信号时，将触发分析仪（请参见由其他模块/仪器触发和向其他模块/仪器发送触发）。Trigger In（触发入）BNC 连接器位于 1680 系列逻辑分析仪的后面板、1690 系列逻辑分析仪的前面板和 16900 系列逻辑分析系统的后面板上。

编辑此函数

  • 指定高级触发


Wait for arm from another module（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。另一个模块发出通信信号时将触发分析仪（请参见由其他模块/仪器触发和向其他模块/仪器发送触发）。

编辑此函数

  • 指定高级触发


Wait "N" external clock states

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当被测设备的外部时钟信号（和任何用户定义的时钟认证）第“N”次出现时将触发分析仪。

编辑此函数

  • 指定高级触发


高级 If/Then（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。分析仪在“If”子句变为 true 时触发。

编辑此函数

  • 指定高级触发


高级 2 路分支（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当两种码型中的任何一种（if 或 Else if）或两种同时出现时，二路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


高级 3 路分支（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当三种码型中的任何一种（If 或 Else if）出现时，三路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


高级 4 路分支（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。当四种码型中的任何一种（If 或 Else if）出现时，四路分支将计算为 true。根据出现为 true 的码型，执行相应的“Then”操作。

编辑此函数

  • 指定高级触发


Pattern "AND" Pattern（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果 pattern1 和 pattern2 同时出现，并且出现了指定的次数 (occurs)，则分析仪触发。

编辑此函数

  • 指定高级触发


Pattern "OR" Pattern（状态）

此触发函数在采集模式设置为 State - Synchronous（状态 - 同步）时可用。如果 pattern1 和 pattern2 之中有一个出现，并且出现了指定的次数 (occurs)，则分析仪触发。

编辑此函数

  • 指定高级触发


数据格式

配置文件格式

  • ALA 格式
  • XML 格式

数据导出/导入格式

  • 标准 CSV 格式
  • 模块 CSV 格式
  • 模块二进制 (ALB) 格式


ALA 格式

Agilent Logic Analyzer (ALA) 格式是保存配置文件的默认格式。ALA 格式是应用程序的自有格式。ALA 格式的配置文件不适于 Agilent Logic Analyzer 应用程序以外的程序读取。

ALA 格式的配置文件包含恢复会话所需要的全部数据（即，重新构建显示外观、仪器设置及采集的数据（可选）的必要信息）。

配置文件通过 File（文件）菜单保存和打开。


标准 CSV 格式

可以将采集的数据导出至 CSV（逗号分隔值）格式的文件，这种文件可由 Excel 等其他应用程序导入。

输出符合标准 CSV 格式，其中，第一行是选择要导出的列的标题（例如，总线/信号名称、样本编号或时间），随后的每一行包含这些列的指定范围内的数据，数据之间以逗号（或其他指定的分隔符）分隔。例如：

"Sample Number","My Bus 1","My Signal 1","Time"
-10,FE,1,-13 ns
-9,FE,1,-10.5 ns
-8,FE,1,-8 ns
-7,FE,1,-5.5 ns
-6,FE,1,-3 ns
-5,FE,1,-500 ps
-4,FE,1,2 ns
-3,FE,1,4.5 ns
-2,FE,1,7 ns
-1,FE,1,9.5 ns
0,FF,1,12 ns
1,FF,1,14.5 ns
2,FF,1,17 ns
3,FF,1,19.5 ns
4,FF,1,22 ns
5,FF,1,24.5 ns
6,FF,1,27 ns
7,FF,1,29.5 ns
8,FF,1,32 ns
9,FF,1,34.5 ns
10,FF,1,37 ns


模块 CSV 格式

可以将采集的数据导出至模块 CSV（逗号分隔值）格式的文件，随后可对这类文件进行后处理并通过数据导入模块 重新导入逻辑分析系统。

小心：

请勿通过 Microsoft Excel 修改模块 CSV 文件。Excel 在保存文件时会改变 CSV 格式，这样就必须手动进行大量的文本编辑，才能将数据重新导入逻辑分析系统。

模块 CSV 格式的文件包含一个标题部分，后面是以逗号分隔的值。例如：

AGILENT_CSV_DATA
HEADER_BEGIN
#
# -------------------------------------------------
#  Created:Dec 5, 2005 15:38:38
#  By:Agilent Logic Analyzer
# -------------------------------------------------
#
VALUE_SEPARATOR=","
VALUE_FILL_IN=ZEROS  # ZEROS, ONES, PREVIOUS, or ERROR
TRIGGER_CORRELATION_OFFSET=0.000000000000000e+000
TRIGGER_ROW=524288
NUM_ROWS=1048576
TIME_SOURCE PERIOD=2.000000000000000e-009
COLUMN "Sample Number" SAMPLE_NUMBER INTEGER
COLUMN "My Bus 1" VALUE UNSIGNED_INTEGER HEX WIDTH_BITS=8
COLUMN "My Bus 2" VALUE UNSIGNED_INTEGER HEX WIDTH_BITS=16
COLUMN "My Bus 3" VALUE UNSIGNED_INTEGER HEX WIDTH_BITS=32
COLUMN "My Signal 1" VALUE UNSIGNED_INTEGER HEX WIDTH_BITS=1
COLUMN "My Signal 2" VALUE UNSIGNED_INTEGER HEX WIDTH_BITS=1
COLUMN "Time" TIME FLOAT EXPONENT=-12 ABSOLUTE
HEADER_END
-524288,53,FFF0,004103E7,1,1,-1048576000
-524287,53,FFF0,004103E7,1,1,-1048574000
-524286,53,FFF0,004103E7,1,1,-1048572000
-524285,53,FFF0,004103E7,1,1,-1048570000
.
.
.

另请参见

  • 模块 CSV 文件和模块二进制文件的标题格式
  • 模块 CSV 格式文件的特性


模块 CSV 文件和模块二进制文件的标题格式

标题节位于模块 CSV 文件或模块二进制 (ALB) 文件的开头。这两种情况下的标题定义略有不同。

AGILENT_CSV_DATA
AGILENT_BINARY_DATA
必需项：用于确认文件类型的关键字标记。第一个用于模块 CSV 文本文件。第二个用于模块二进制 (ALB) 文件。文件开头的 16（或 19）个字符必须为此标记。
#
可选项：注释字符。# 后直到该行末尾的所有文本都会被忽略。所有行（第一行除外）都可以是注释行，但模块二进制 (ALB) 文件除外，其注释只能位于标题中。
HEADER_BEGIN
必需项：用于确定标题开头位置的关键字标记。
TIME_SOURCE PERIOD = <n.nnne-nn>
TIME_SOURCE FREQUENCY = <n.nnne+nn>
TIME_SOURCE COLUMN = "<columnName>"
可选项：如何为每一样本行分配时间标记。PERIOD 用于指定采样周期；FREQUENCY 用于指定采样频率。COLUMN 用于指示包含要使用的时间标记的时间列（如果指定了 PERIOD 或 FREQUENCY 则忽略）。
如果上述三项均未指定，则使用第一个 TIME 列。如果没有 TIME 列，则不能导入文件。无论如何都必须有一个时间轴。
TRIGGER_ROW = <nnnn>
可选项：包含触发样本的行号，该行号是相对于文件的第一个数据行（第 0 行）的编号。如果文件带有一个由 period（周期）或 frequency（频率）定义的时间行，则触发行可能位于该文件的行范围以外，在这种情况下，它将为负（触发在第一个数据行之前发生），或者为正且大于等于文件的数据行数（触发在文件的最后一行之后发生）。
如果未指定，则认为触发行是第 0 行；如果存在带有绝对时间的 TIME 列，则触发行为 T=0 的行；如果存在 SAMPLE_NUMBER 列，则触发行为样本号为 0 的行。
TRIGGER_CORRELATION_OFFSET = <n.nnne-nn>
可选项：在与来自其他模块的数据关联时应用于触发（即应用于 T=0 的参考行）的以秒计的时间偏移量（正或负）。若不指定，则认为是 0.0。该偏移量会舍入到与之最接近的皮秒。
NUM_ROWS = <nnn>
可选项：预期的文件数据行数。如果指定的行数与文件的实际行数不符，则会给出警告。该选项在此用作完整性检查的一种可选方法，用于检测文件截断。
VALUE_SEPARATOR = "<ccc>"
可选项，仅适用于模块 CSV 文件：在每一行中用作值分隔符的一个或多个字符。若不指定，则使用逗号。如果列值丢失（比如出现两个连续的逗号），则其值由 VALUE_FILL_IN 属性确定。分隔字符串中可以包含任何可打印字符以及/或空白和制表符，但以下字符除外：
  • '#' — 注释字符。
  • '-', '+' — 符号字符（带正负号的小数和浮点数）。
  • '.' — 句点，在浮点值中使用。
  • a-f, A-F — 十六进制字符。
  • 0-9 — 数字。
列间空白和/或制表符如果不是分隔字符串的一部分，则会自动跳过。
VALUE_FILL_IN = PREVIOUS | ZEROS | ONES | ERROR
可选项，仅适用于模块 CSV 文件：用于行中被跳过单元格的值。该属性是可选属性。其默认值为 ZEROS。PREVIOUS 与 VCD 文件格式一致，意思是“使用上面单元格中的值”。ERROR 表示任何丢失的值都应视作错误。此设置适用于除 TIME 以外的所有列。任何丢失的时间标记都是错误。
BYTE_ORDER = LITTLE_ENDIAN | BIG_ENDIAN
可选项，仅适用于二进制 (ALB) 文件：多字节值中的字节顺序。Intel 兼容系统将小尾顺序作为其内部格式。这既适用于整数值，又适用于浮点值。其默认值为 LITTLE_ENDIAN。
HEADER_END
必需项：标题的显式结尾。在这里对从标题中获得的信息进行评估，以确定文件是否有意义（例如，定义了一个时间轴和一个或多个列）。
在模块 CSV 文件中，下一非注释行就是数据的第一行。在模块二进制 (ALB) 文件中，数据段始于 HEADER_END 所在行末尾换行符之后的第一个字节。

模块 CSV 文件的所有行（包括标题之后的样本行）都是通过先删除注释字符及其后面的所有字符，然后删除所有前导空白（作为分隔符一部分的空白或制表符除外）来进行处理的。如果处理之后的行成为空行，则会自动跳过。否则将使用标题中 COLUMN 定义所提供的定义来分析每一数据行，这些定义如下所述。

COLUMN 语法

需要一个或多个 COLUMN 定义。标题中的定义顺序与数据段中的列顺序是一致的。其中至少要有一个定义是用来定义 VALUE 列的。COLUMN 语法比其他语句复杂，因此按其组成部分分别进行介绍：

COLUMN "<name>" <CSVcolumnType> | <ALBcolumnType>
以下这些内容是 COLUMN 定义的主要部分。模块 CSV 文件与模块二进制 (ALB) 文件在细节上是不同的。name 可以包含大多数可打印字符，也包括嵌入式引号（单引号或双引号），但前提是要用反斜杠对其进行转义。例如，COLUMN "my \"perfect\" data"。 . .
<CSVcolumnType>:
  • VALUE <CSVformat> WIDTH_BITS = <nnn>
  • TIME <CSVformat> <timeUnit> ABSOLUTE | RELATIVE
  • LINE_NUMBER <CSVformat>
  • SAMPLE_NUMBER <CSVformat>
  • IGNORE
列类型指定了列值的用途。
行号从 0 开始，第 0 行对应第一行，后面的行号依次加 1。
样本编号从 0 开始，编号 0 对应触发行，触发行以上各行的样本编号逐个减 1，以下各行则逐个加 1。
时间列用于指定样本的时间位置。绝对时间位置是指触发行上的 T=0 的位置。相对时间位置指示从获得前一个样本开始到获得该行上带有时间标记的样本为止所经历的时间。
值列中包含了要显示在应用程序查看器中的数据样本。值的位宽度是指分配给总线/信号设置页面中代表该列的盒的宽度。值会被截断（或扩展）以适合此宽度。带正负号的值是用符号扩展的。浮点值转换成宽度适当的整数（如果给出了比例因子，则先应用比例因子）。
<ALBcolumnType>:
  • VALUE NBYTES = <nnn> <ALBformat> WIDTH_BITS = <nnn>
  • TIME NBYTES = <nnn> <ALBformat> <timeUnit> ABSOLUTE | RELATIVE
  • LINE_NUMBER NBYTES = <nnn> <ALBformat>
  • SAMPLE_NUMBER NBYTES = <nnn> <ALBformat>
  • IGNORE NBYTES = <nnn>
这与 <CSVcolumnType> 大致相同，只是 NBYTES 属性是用于指定分配给列的二进制数据的字节数的。
<CSVformat>:
  • INTEGER [HEX | DECIMAL | OCTAL | BINARY]
  • UNSIGNED_INTEGER [HEX | DECIMAL | OCTAL | BINARY]
  • FLOAT [SCALE = <nnn.nnn>]
列格式用于描述值在文件中的表示方式。数基是可选的，若不指定则默认为十六进制。SCALE 也是可选的，默认为 1.0；此项用于在将列值载入到数据输入模块以前按比例调整列值。最终载入的值是列值乘以比例因子，然后进行舍入而得出的与之最接近的整数（时间值除外，它们舍入到与之最接近的 10-24 秒）。所有值都会接受检查，以确定相对于该域的 WIDTH_BITS 来说是否有溢出。行号和样本编号作为 32 位数处理。
<ALBformat>:
  • INTEGER
  • UNSIGNED_INTEGER
  • FLOAT [SCALE = <nnn.nnn>]
与 <CSVformat> 大致相同，只是这里没有数基。浮点值必须符合 IEEE 标准 754，因此其宽度必须是四字节或八字节。
<timeUnit>:
  • EXPONENT = <nnn>
  • EXPONENT = -<nnn>
应用于时间标记值的单位（如果与浮点值一起使用，则还包括比例因子）。例如，EXPONENT = -12 即相当于皮秒时间单位。

标题示例

AGILENT_CSV_DATA
#
# ---------------------------- #
#  Created:2008 Sep 21 21:18  #
#  By:Agilent Logic Analyzer  #
# ---------------------------- #
#
HEADER BEGIN
TIME COLUMN="tSample"
TRIGGER_ROW=100
TRIGGER_CORRELATION_OFFSET=1.24e-9
COLUMN "Sample" SAMPLE_NUMBER INTEGER DECIMAL
COLUMN "Address" VALUE INTEGER HEX WIDTH_BITS=24
COLUMN "Data" VALUE INTEGER HEX WIDTH_BITS=16
COLUMN "Status" VALUE INTEGER BIN WIDTH_BITS=8
COLUMN "DigRF" VALUE FLOAT SCALE=16.0e+3 WIDTH_BITS=16
COLUMN "tSample" TIME INTEGER DECIMAL EXPONENT=-12 RELATIVE
VALUE_SEPARATOR ","
VALUE_FILL_IN PREVIOUS
HEADER END
# Start data
0afc38,ff98,01000110,0.114,5000
0afc3c,055a,,,2500
# embedded comment
0afc38,ff98,01010001,0.116,2500


模块 CSV 格式文件的特性

文件必须定义时间线，以使每个样本与一个时间标签关联。为此，需要一个周期速率，或一个带有绝对或相对时间标签的时间列（请参见文件标题中的 TIME_SOURCE 属性）。需要验证文件中的时间标签是单调增加的。如果存在时间标签列，周期速率的设定值会将其覆盖。

文件必须具有一个或多个数据值列。数据值列包含要载入的数据。其他列（如行号、样本编号和时间标签）属于数据注释，而不作为数据载入。

文件中的数据行的索引从行 0 开始，然后是 1，依此类推。行号是在文件中的编号。它们不同于模块列表中的样本编号。样本编号始终是相对于触发行（而非文件中的第一行）的编号。

文件标题包含属性 TRIGGER_ROW，该属性用于指定文件中与逻辑分析仪触发相关联的行号。触发行定义为时间源，包含 T=0。

在多模块逻辑分析仪中，只有一个模块的触发点为 T=0。所有其他模块都按硬件延迟进行偏移，这些延迟与触发信号从始发模块到接收模块的传递相关。时间延迟通过 TRIGGER_CORRELATION_OFFSET 属性指定。这是必须在文件中每个样本的时间上添加的时间量，用于将每个样本相对于系统其他模块的样本正确置于时间线上。使用此属性，可以将包含从模块导出的数据的文件导入同一系统，并与来自其他模块的数据正确放置（关联）。

如果触发样本不在导出范围内，则会出现有趣的情况。如果时间来源是周期性的，这种情况便会发生。这时，TRIGGER_ROW 值将指示不在文件中的行。例如，如果文件中的第一个数据行是模块中触发样本后的第一个样本，则 TRIGGER_ROW=-1。反之，如果触发样本是导出数据中最后一行之后的第一个样本，TRIGGER_ROW 将等于文件中的行数。如果触发样本是最后一行之后的第二个样本， TRIGGER_ROW 将是文件中的行数加一，依此类推。通过这些调整，导出文件便可以导入并相对于原始主触发样本正确放置，而不会弄错不在文件中的触发样本的位置。样本编号的处理方式与此类似，样本 0 位于触发行。如果触发行不在文件中，样本 0 也不在文件中。

以下有关模块 CSV 文件内容的叙述始终适用：

  • 文件中的第一个数据行为行 0。下一个是 1，接着是 2，依此类推。

  • TRIGGER_ROW 始终是相对于文件中的第一行（行 0）的编号。触发行可能在文件中，也可能不在。

  • 与 TRIGGER_ROW 关联的时间始终为 0。TRIGGER_CORRELATION_OFFSET 属性用于与其他数据集的正确关联。

  • TRIGGER_ROW 处的样本编号（如果存在样本编号列）始终为 0。触发行之后每行的样本编号加一，触发行之前每行减一。样本编号与行号不同。

  • 如果导出至文件，行号总是从 0（行 0）开始，此后每行加一：lineNumber = rowNumber.

T=0 时间标签、样本编号以及 TRIGGER_ROW 属性之间的不一致将按下列顺序解决：

  1. 包含绝对时间标签 0 的数据行为触发行，如有必要则重新校准样本编号，使其在该行从零开始。

  2. 如果时间线是按周期或频率定义的，并已给出样本编号列，那么样本编号为 0 的数据行便是触发行。（触发行不一定包含在文件中）

  3. 最后使用 TRIGGER_ROW 属性。如果使用了时间标签（相对或绝对），则会移动不在文件中的触发行。

另请参见

  • 模块 CSV 文件和模块二进制文件的标题格式


模块二进制 (ALB) 格式

可以将采集的数据导出至模块二进制文件。Agilent Logic Analyzer 应用程序的后续版本将能够使用数据导入模块 将模块二进制文件导入逻辑分析系统。

模块二进制格式的文件包含一个标题部分，后面为二进制数据。例如：

AGILENT_BINARY_DATA
HEADER_BEGIN
#
# -------------------------------------------------
#  Created:Dec 5, 2005 16:14:36
#  By:Agilent Logic Analyzer
# -------------------------------------------------
#
BYTE_ORDER=LITTLE_ENDIAN
TRIGGER_CORRELATION_OFFSET=0.000000000000000e+000
TRIGGER_ROW=524288
NUM_ROWS=1048576
TIME_SOURCE PERIOD=2.000000000000000e-009
COLUMN "Sample Number" SAMPLE_NUMBER NBYTES=4 INTEGER
COLUMN "My Bus 1" VALUE NBYTES=1 UNSIGNED_INTEGER WIDTH_BITS=8
COLUMN "My Bus 2" VALUE NBYTES=2 UNSIGNED_INTEGER WIDTH_BITS=16
COLUMN "My Bus 3" VALUE NBYTES=4 UNSIGNED_INTEGER WIDTH_BITS=32
COLUMN "My Signal 1" VALUE NBYTES=1 UNSIGNED_INTEGER WIDTH_BITS=1
COLUMN "My Signal 2" VALUE NBYTES=1 UNSIGNED_INTEGER WIDTH_BITS=1
COLUMN "Time" TIME NBYTES=8 FLOAT EXPONENT=-12 ABSOLUTE
HEADER_END
<二进制数据>

另请参见

  • 模块 CSV 文件和模块二进制文件的标题格式


符号阅读器支持的对象文件格式

逻辑分析系统能够读取以下格式的符号文件：

  • OMF96
  • OMFx86
  • IEEE-695
  • ELF/DWARF
  • ELF/stabs
  • TI COFF

对于 ELF/DWARF1、ELF/stabs 和 ELF/stabs/Mdebug 文件，C++ 符号已经过解码，因此它们可以原始的 C++ 符号形式显示。为了提高这些 ELF 符号文件的性能，将类型信息处理为与变量无关联。因此，某些变量（通常是一些局部静态变量）可能不显示与其关联的正确大小。其显示的大小可能是 1 字节，而不是其 4 字节甚至更多字节的正确大小。函数范围、行号、全局变量和文件名等其他所有信息都是准确无误的。通过编辑 readers.ini 文件可以更改文件的这些行为。

另请参见

  • 从文件载入符号
  • 更改符号阅读器选项
  • 创建 ASCII 符号文件


通用 ASCII (GPA) 符号文件格式

将通用 ASCII (GPA) 格式文件载入到逻辑分析仪中的方式与载入其他对象文件类似。

如果编译器生成的对象文件不具有支持的格式，或者需要定义对象文件中所没有的符号，则可以创建 ASCII 格式的符号文件。

通常，ASCII 格式的符号文件是使用文本处理工具创建的，这些文本处理工具可对编译器或链接器映射输出文件中的符号表信息进行转换。

不同类型的符号是在 GPA 文件的不同记录中进行定义的。记录头用方括号括起，如 [USER]。有关 GPA 文件记录及相关的符号定义语法，请参阅通用 ASCII (GPA) 记录格式摘要。

符号文件中的每一项都必须包含一个符号名，并且其后面要有一个地址或地址范围。

地址或地址范围必须是十六进制数，并且必须与符号名显示在同一行中，二者之间必须以一个或多个空格或者制表符分隔。地址范围必须具有以下格式：

beginning address..ending address

以下示例定义了两个对应地址范围的符号和一个对应单个地址的符号。

main     00001000..00001009
test     00001010..0000101F
var1     00001E22     #this is a variable

有关 GPA 文件记录和相关的符号定义语法的更详细描述，请参阅以下主题：

  • SECTIONS
  • FUNCTIONS
  • USER
  • VARIABLES
  • SOURCE LINES
  • START ADDRESS
  • 注释


通用 ASCII (GPA) 记录格式摘要

格式

[SECTIONS]
section_name  start..end  attribute

[FUNCTIONS]
func_name  start..end

[USER]
sym_name   value                    base
sym_name   start_value   [size]     base
sym_name   start_value..end_value   base

[VARIABLES]
var_name   start [size]
var_name   start..end

[SOURCE LINES]
File:file_name
line#  address

[START ADDRESS]
address

#注释文本

无前置标题的行被认为是采用某种 [USER] 格式的符号定义。

示例

这是一个包含若干不同类别记录的 GPA 文件示例。

[SECTIONS]
prog     00001000..0000101F
data     40002000..40009FFF
common   FFFF0000..FFFF1000

[FUNCTIONS]
main     00001000..00001009
test     00001010..0000101F

[USER]
bdontcare    00x1     binary
hvalue       00EF     hex
drange       0..99    decimal
srange      -23  20   signed decimal   # The 20 is a decimal value for size.

[VARIABLES]
total    40002000  4
value    40008000  4

[SOURCE LINES]
File:main.c
10       00001000
11       00001002
14       0000100A
22       0000101E

File:test.c
 5       00001010
 7       00001012
11       0000101A


SECTIONS

SECTIONS 用于为内存区域（如节、段或类）定义符号。

注意：

要启用节重定位，节定义必须出现在文件中任何其他定义之前。

注意：

若在 GPA 符号文件中使用节定义，则后面的任何函数或变量都必须在某一定义的节的地址范围之内。不在此范围之内的函数和变量将被忽略。

格式

[SECTIONS]
section_name  start..end  attribute

section_name

代表节名的符号。

start

节的第一个地址（十六进制）。

end

节的最后一个地址（十六进制）。

attribute

可以为以下某个属性（可选）：

  • NORMAL（默认）－ 该节是一个正常的可重定位节，如代码或数据。

  • NONRELOC － 该节包含不能重定位的变量或代码。也就是说，这是一个绝对段。

  • AddReloc reloc_offset － 为重定位节指定偏移值（最多 32 位）。

  • SetReloc reloc_value － 为重定位节指定新基值（最多 32 位）。

示例

[SECTIONS]
prog           00001000..00001FFF
data           00002000..00003FFF
display_io     00008000..0000801F   NONRELOC
sect3          00003000..00003FFF   AddReloc   1000
sect4          00005000..00005FFF   SetReloc   0000F000


FUNCTIONS

FUNCTIONS 用于为程序函数、过程或子例程定义符号。

格式

[FUNCTIONS]
func_name  start..end

func_name | 代表函数名的符号。
start | 函数的第一个地址（十六进制）。
end | 函数的最后一个地址（十六进制）。

示例

[FUNCTIONS]
main     00001000..00001009
test     00001010..0000101F


USER

在 [USER] 记录头下，可以创建带有无关值的符号，并且可以使用非十六进制数基。

USER 是默认的记录类型；这意味着不用任何记录头（[USER]、[VARIABLE] 等）定义的符号都被看作 USER 符号。

USER 符号定义可以包含 128 位的值；其他所有记录类型的符号定义最多只能有 32 位的值。

格式

[USER]
sym_name   value                    base
sym_name   start_value   [size]     base
sym_name   start_value..end_value   base

* use quotes(") around names or values with spaces.

sym_name

符号名。

value

符号值。

base

值的数基；可以为：

  • binary
  • octal
  • hex（hexadecimal 或空白）
  • decimal
  • signed decimal

start_value

范围的下限。

end_value

范围的上限。

size

值的范围大小（十进制）。

示例

[USER]
bdontcare    00x1           binary
bvalue       0011           binary
brange       0000..0011     binary
brange2      0011   9       binary   # The 9 is a decimal value for size.
odontcare    00x7           octal
ovalue       0077           octal
orange       0000..0077     octal
orange2      0000   99      octal    # The 99 is a decimal value for size.
hdontcare    00xF           hex
hvalue       00EF           hex
hrange       0000..00FF     hex
hrange3      0000    99     hex      # The 99 is a decimal value for size.
dvalue       1090           decimal
drange       0..99          decimal
drange2      0   100        decimal    # The 100 is a decimal value for size.
svalue      -23             signed decimal
srange      -23..-5         signed decimal
srange      -23  20         signed decimal  # The 20 is a decimal value for size.
"hvalue with space" "01XX FFFF" hex
"hrange with space" "0100 FFFF".."0400 FFFF" hex  # Applies to other bases also.


VARIABLES

可以使用以下对象为变量指定符号：

  • 变量地址。
  • 变量地址和变量大小。
  • 变量所占用的地址范围。

如果仅指定变量的地址，则认为变量大小是 1 字节。

格式

[VARIABLES]
var_name   start [size]
var_name   start..end

var_name | 代表变量名的符号。
start | 变量的第一个地址（十六进制）。
end | 变量的最后一个地址（十六进制）。
size | 变量的大小（可选），以字节计，为十进制。

示例

[VARIABLES]
subtotal     40002000   4
total        40002004   4
data_array   40003000..4000302F
status_char  40002345


SOURCE LINES

SOURCE LINES 用于建立地址与源文件中行的关联。

格式

[SOURCE LINES]
File:file_name
line#  address

file_name | 文件名。
line# | 源文件中某行的行号（十进制）。
address | 源行的地址（十六进制）。

示例

[SOURCE LINES]
File:main.c
10       00001000
11       00001002
14       0000100A
22       0000101E

另请参见

  • 查看与采集的数据关联的源代码


START ADDRESS

格式

[START ADDRESS]
address

address | 程序入口点的地址（十六进制）。

示例

[START ADDRESS]
00001000


注释

使用 # 可在文件中添加注释。# 之后的所有文本都会被忽略。注释可以单占一行，也可以放在同一行中 s 符号之后。

格式

#注释文本

示例

#This is a comment


产品概述

  • 1680/1690 系列逻辑分析仪产品概述
  • 16900 系列逻辑分析系统产品概述
  • Agilent Logic Analyzer 应用程序产品概述

另请参见

  • 指南 － 逻辑分析仪入门


1680/1690 系列逻辑分析仪产品概述

Agilent Technologies 1680/1690 系列逻辑分析仪可提供多种通道宽度、内存深度以及状态采集速度和定时采集速度（请参见下表）。

  • 1680A/AD 系列带有集成的 12.1 英寸超大彩色纯平显示面板，最多可同时显示 22 组波形。

  • 1690A/AD 系列是基于 PC 的型号系列，该系列通过 IEEE 1394 接口连接到个人计算机；从而允许用户在自己的 PC 环境中开展测量和调试工作。（每台 PC 支持一台 1690 系列逻辑分析仪。）

这两种型号系列都具有类似的基于 Windows 的用户界面，可免去进行逻辑分析仪测量时的复杂性。用户可以通过同一窗口执行所有操作。请参见内部支持。

  • 1680 系列前面板操作
  • 1680 系列显示屏亮度

原装附件

1680A/AD 系列逻辑分析仪：

  • PS/2 鼠标。
  • PS/2 小键盘。
  • 前面板盖。
  • 附件袋。

1690A/AD 系列逻辑分析仪：

  • IEEE 1394 PCI 卡及电缆。
  • 用于便携式计算机的 IEEE 1394 电缆。
  • 附件袋。

可选附件

  • 可选机架安装套件 - 1CM。
  • 附加 IEEE 1394 PCI 卡及电缆。

另请参见

  • 指南 － 逻辑分析仪入门
  • 1680/1690 系列逻辑分析仪特性
  • 1680/1690 系列逻辑分析仪规格


1680 系列前面板操作

前面板界面包括用于设置和运行测量的旋钮和按钮。此外，界面中还有用于快速访问常用对话框的快捷按钮。当某项前面板操作无效时，会发出“嘟嘟”声。

注意：

在逻辑分析仪中运行 Agilent Logic Analyzer 应用程序的多个实例时，前面板的旋钮和按钮仅用于本地 采集硬件所连接的应用程序。

通过前面板旋钮和按钮可实现的所有功能也可以在图形用户界面 (GUI) 中执行。

  • Run/Stop（运行/停止）按钮
  • Open/Save/Default Setup（打开/保存/默认设置）按钮
  • 通用旋钮
  • 字母数字键盘
  • 快捷按钮
  • 垂直旋钮
  • 水平旋钮
  • 标记旋钮/按钮

Run/Stop（运行/停止）按钮

项 | 说明
Run Single | 运行 single acquisition（单次采集）。Run Single（单次运行）按钮变为绿色表示可执行运行操作。在分析仪运行过程中，该指示灯将熄灭。
Run Rep. (Repetitive) | 运行 repetitive acquisition（重复采集）。Run Repetitive（重复运行）按钮变为绿色表示可执行运行重复操作。在分析仪运行过程中，该指示灯将熄灭。
Stop | 停止当前的采集。Stop（停止）按钮在“运行”周期内变为红色表示可执行“停止”操作。

Open/Save/Default Setup（打开/保存/默认设置）按钮

项 | 说明
Open Setup | 访问 Open Configuration（打开配置）对话框。
Save Setup | 访问 Save Configuration（保存配置）对话框。
Default Setup | 将设置重置为默认开机配置。

通用旋钮

通用旋钮用于当前焦点所在的字段。当前焦点所在字段的背景为蓝色。通用旋钮通常用于增加/减小数字值，如波形刻度和延迟。

字母数字键盘

在 OK/Cancel（确定/取消）对话框中，退出键用于取消操作并退出对话框。

项 | 说明
Enter | 接受值或配置的更改，并退出对话框。
Tab | 从左往右或从上往下滚动配置字段。
Backspace（左箭头） | 在字母数字指定字段中将光标退格。
Esc |
Keypad | 用于字母数字录入。
Units | 设置测量单位。

快捷按钮

项 | 说明
Setup | 访问 Analyzer Setup（分析仪设置）对话框中的 Buses/Signals（总线/信号）选项卡。
Waveform | 访问 Waveform（波形）显示窗口。当 Waveform（波形）显示窗口处于活动状态时，该按钮将变为绿色。
Listing | 访问 Listing（列表）显示窗口。当 Listing（列表）显示窗口处于活动状态时，该按钮将变为绿色。
Find | 访问 Advanced Search（高级搜索）对话框。
Trigger | 访问 Advance Trigger（高级触发）对话框。
File Mgr | 访问 Explore file manager（浏览文件管理器）对话框。
Print | 访问 Printing Data（打印数据）对话框。
Help | 访问联机帮助系统的主窗口。该按钮与 F1 键等效。

垂直旋钮

项 | 说明
Size | 调整所有波形行的高度。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Page | 显示“列表”数据时滚动一页。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。
Scroll | 显示“波形”数据时滚动行。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Line | 显示“列表”数据时滚动一行。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。

水平旋钮

项 | 说明
Time/Div | 更改 Waveform（波形）显示窗口的刻度（时间/段）。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Bus/Sig | 在 Listing（列表）显示窗口中从第一列滚动至最后一列。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。
Delay | 更改 Waveform（波形）显示窗口的延迟。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Column | 显示“列表”数据时滚动一列。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。

标记旋钮/按钮

项 | 说明
Move 标记旋钮 | 在显示屏中移动所选标记。
Choose 标记按钮 | 选择用于“Move”（移动）操作的标记。按下该按钮可以在可用标记之间滚动。如果未定义任何标记，按 Choose（选择）将创建一个 M1 标记。

有关标记的更多信息，请参考标记数据点并在数据点之间进行测量。


1680 系列显示屏亮度

1680 系列逻辑分析仪带有显示屏亮度控件。

在 Windows 任务栏中双击 [image] 图标可以切换高低亮度设置。


16900 系列逻辑分析系统产品概述

Agilent Technologies 16900 系列逻辑分析系统是模块式系统，带有逻辑分析仪的插槽及其他类型的测量仪器卡。

 | 16900A | 16902A | 16903A
仪器卡插槽数： | 6 | 6 | 3
多机架连接器： | 有 | 有 | 无
显示屏和分辨率： | 使用外部显示器。最多支持四台外部显示器，最高分辨率为 1600 x 1200（带有 PCI 视频卡） | 内置彩色触摸显示屏，12.1 英寸分辨率为 800 x 600，最多支持四台外部显示器，最高分辨率为 1600 x 1200（带有 PCI 视频卡） | 内置彩色触摸显示屏，12.1 英寸分辨率为 800 x 600，最多支持四台外部显示器，最高分辨率为 1600 x 1200（带有 PCI 视频卡）
前面板旋钮和按钮： | 无 | 有 | 有
PCI 扩展插槽： | 全尺寸 2 个 小尺寸 1 个 | 全尺寸 2 个 小尺寸 1 个 | 全尺寸 1 个 小尺寸 1 个

所有型号系列都具有类似的基于 Windows 的用户界面，可去除进行逻辑分析仪测量时的复杂性。用户可以通过同一窗口执行所有操作。请参见内部支持。

  • 触摸屏使用提示（仅限于 16902/903）
  • 16902/903 前面板操作

小心：

关闭 16900 系列逻辑分析系统的电源时，应等待风扇停止转动（约 15 秒），然后再重新打开逻辑分析系统。这样可确保内部电路重新启动时处于已知状态。（有关关闭逻辑分析系统电源的更多信息，请参见 [image] 16900-Series Logic Analysis System Installation Guide。）

原装附件

  • PS/2 鼠标。
  • PS/2 小键盘。
  • 附件袋。
  • 电源线。
  • 用于目标控制端口 的十芯飞线电缆。

可选附件

  • 多机架电缆 (E5861A)。
  • 1 Gb 小尺寸 LAN 卡（选项 014 或 E5860A）。
  • 探头。

另请参见

  • 指南 － 逻辑分析仪入门
  • 16900 系列逻辑分析系统机架特性


触摸屏使用提示（仅限于 16902/903）

16902A 和 16903A 逻辑分析系统机架带有触摸屏。以下是使用触摸屏的一些提示：

  • 对触摸屏施以稳定均匀的压力。

  • 您可选择使用压感笔。

  • 使用前面板标记旋钮可以设置标记。使用触摸屏很难准确设置标记。（使用 Choose 标记按钮可选择任意标记。）

  • 对于树，将展开 +/- 按钮周围的可触摸区域。

  • 对于选项选择，选项和说明均可触摸。

打开键盘对话框

在 Agilent Logic Analyzer 应用程序内：

  • 在任意编辑字段中按下键盘按钮 [image] 。此操作将打开用于输入字段值的对话框。

在 Agilent Logic Analyzer 应用程序外：

  • 按下前面板的 Keyboard 按钮。此操作将打开 Microsoft 屏幕键盘，以及触摸屏的 Event Selector（事件选择器）。

    （您也可以选择 Start（开始）> All Programs（所有程序）> Accessories（附件）> Accessibility（辅助工具）> On-Screen Keyboard（屏幕键盘）。）

访问鼠标右键行为

在 Agilent Logic Analyzer 应用程序内，通过触摸屏幕即可访问大部分鼠标右键行为。

在 Agilent Logic Analyzer 应用程序外：

  • 按住触摸屏，直到手指周围画出完整的圆形，随后便会出现右键单击的效果。

  • 或者，也可以选择 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> Touch Screen（触摸屏）> Event Selector（事件选择器），打开以下窗口：

    在此窗口内触摸将使下一次触摸变为右键单击。

重新校准触摸屏

  • 如果触摸屏需要重新校准，请选择 Start（开始）> All Programs（所有程序）> Agilent Logic Analyzer > Utilities（实用工具）> Touch Screen（触摸屏）> Calibrate（校准）。

另请参见

  • 16902/903 前面板操作


16902/903 前面板操作

前面板界面包括用于设置和运行测量的触摸屏、旋钮和按钮。此外，界面中还有用于快速访问常用窗口/对话框的快捷按钮。当某项前面板操作无效时，会发出“嘟嘟”声。

注意：

在逻辑分析仪中运行 Agilent Logic Analyzer 应用程序的多个实例时，前面板的旋钮和按钮仅用于本地 采集硬件所连接的应用程序。同样，在多机架配置中，前面板旋钮和按钮仅用于主帧 所运行的应用程序。

通过前面板旋钮和按钮可实现的所有功能也可以在图形用户界面 (GUI) 中执行。

  • Run/Stop（运行/停止）按钮
  • Open/Save/New File（打开/保存/新建文件）按钮
  • 通用旋钮和 Enter 按钮
  • 快捷按钮
  • 垂直旋钮
  • 水平旋钮
  • 标记旋钮/按钮
  • Touch Off 按钮

Run/Stop（运行/停止）按钮

项 | 说明
Run Single | 运行 single acquisition（单次采集）。Run Single（单次运行）按钮变为绿色表示可执行运行操作。在分析仪运行过程中，该指示灯将熄灭。
Run Rep. (Repetitive) | 运行 repetitive acquisition（重复采集）。Run Repetitive（重复运行）按钮变为绿色表示可执行运行重复操作。在分析仪运行过程中，该指示灯将熄灭。
Stop | 停止当前的采集。Stop（停止）按钮在“运行”周期内变为红色表示可执行“停止”操作。

Open/Save/New File（打开/保存/新建文件）按钮

项 | 说明
Open File | 访问 Open Configuration（打开配置）对话框。
Save File | 访问 Save Configuration（保存配置）对话框。
New File | 将设置重置为默认开机配置。

通用旋钮和 Enter 按钮

项 | 说明
通用旋钮 | 通用旋钮用于当前焦点所在的字段。当前焦点所在字段的背景为蓝色。通用旋钮通常用于增加/减小数字值，如波形刻度和延迟。
Enter 按钮 | 接受值或配置的更改，并退出对话框。

快捷按钮

项 | 说明
Waveform | 访问 Waveform（波形）显示窗口。当 Waveform（波形）显示窗口处于活动状态时，该按钮将变为绿色。
Listing | 访问 Listing（列表）显示窗口。当 Listing（列表）显示窗口处于活动状态时，该按钮将变为绿色。
Scope | 运行 Add External Oscilloscope（添加外部示波器）向导，该向导用于使用 E5850A 时间相关固定器将外部 Infiniium 示波器连接到逻辑分析仪。
Mixed | 启用全屏显示并水平排列窗口，或禁用混合窗口设置。
Full Screen | 启用或禁用全屏显示。
Setup | 访问 Analyzer Setup（分析仪设置）对话框中的 Buses/Signals（总线/信号）选项卡。
Trigger | 访问 Advance Trigger（高级触发）对话框。
Find | 访问 Advanced Search（高级搜索）对话框。
Keyboard | 打开键盘对话框，以输入信息。
Help | 访问联机帮助系统的主窗口。该按钮与 F1 键等效。

垂直旋钮

项 | 说明
Size | 调整所有波形行的高度。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Page | 显示“列表”数据时滚动一页。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。
Scroll | 显示“波形”数据时滚动行。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Line | 显示“列表”数据时滚动一行。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。

水平旋钮

项 | 说明
Time/Div | 更改 Waveform（波形）显示窗口的刻度（时间/段）。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Bus/Sig | 在 Listing（列表）显示窗口中从第一列滚动至最后一列。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。
Delay | 更改 Waveform（波形）显示窗口的延迟。选择操作使按钮变为绿色表示所选部分属于波形组，并且该波形组当前处于活动状态。
Column | 显示“列表”数据时滚动一列。选择操作使按钮变为绿色表示所选部分属于列表组，并且该列表组当前处于活动状态。

标记旋钮/按钮

项 | 说明
Move 标记旋钮 | 在显示屏中移动所选标记。
Choose 标记按钮 | 选择用于“Move”（移动）操作的标记。按下该按钮可以在可用标记之间滚动。如果未定义任何标记，按 Choose（选择）将创建一个 M1 标记。

有关标记的更多信息，请参考标记数据点并在数据点之间进行测量。

Touch Off 按钮

项 | 说明
Touch Off | 关闭触摸屏，以防止意外接触对仪器产生影响。

另请参见

  • 触摸屏使用提示（仅限于 16902/903）


Agilent Logic Analyzer 应用程序产品概述

Agilent Logic Analyzer 应用程序是一种基于 Windows 的类似用户界面，使利用逻辑分析仪测量非常简单。用户可以通过同一窗口执行所有操作。请参见内部支持。

Agilent 的简单、快速和高级触发函数使触发过程变得简单。使用 Simple Trigger（简单触发）的下拉菜单可按沿和码型定义事件。使用快速触发，可通过在显示的可疑事件周围拖制框查看其是否重新出现。其余工作均可由快速触发完成！使用高级触发的句式结构拖放图形图标可定制复杂的触发方案。

  • 键盘命令


键盘命令

  • 访问菜单
  • File（文件）操作
  • Edit（编辑）操作
  • Search（搜索）操作
  • View（查看）操作
  • Run/Stop（运行/停止）操作
  • Compare（比较）操作
  • Listing（列表）操作
  • Waveform（波形）操作
  • Window（窗口）操作
  • Help（帮助）操作
  • Miscellaneous（其他）

访问菜单

Alt+F | 访问 File（文件）菜单
Alt+E | 访问 Edit（编辑）菜单
Alt+V | 访问 View（查看）菜单
Alt+S | 访问 Setup（设置）菜单
Alt+T | 访问 Tools（工具）菜单
Alt+M | 访问 Markers（标记）菜单
Alt+R | 访问 Run/Stop（运行/停止）菜单
Alt+W | 访问 Window（窗口）菜单
Alt+H | 访问 Help（帮助）菜单

File（文件）操作

以下操作位于菜单栏中的 File（文件）下面。

Ctrl+N | File（文件）- New（新建）
Ctrl+O | File（文件）- Open（打开）
Ctrl+F4 | File（文件）- Close（关闭）
Ctrl+S | File（文件）- Save（保存）
Ctrl+I | File（文件）- Import（导入）
Shift+E | File（文件）- Export（导出）
Ctrl+P | File（文件）- Print（打印）

Edit（编辑）操作

以下操作位于菜单栏中的 Edit（编辑）下面。

Ctrl+Z | Edit（编辑）- Undo（撤消）
Ctrl+X | Edit（编辑）- Cut（剪切）
Ctrl+C | Edit（编辑）- Copy（复制）
Ctrl+V | Edit（编辑）- Paste（粘贴）
Alt+I | Edit（编辑）- Insert Bus/Signal into Window（将总线/信号插入窗口）
Alt+P | Edit（编辑）- Current Window Properties（当前窗口属性）

Search（搜索）操作

以下操作位于菜单栏中的 Edit（编辑）下面。

Ctrl+F | Edit（编辑）- Find（查找）
Shift+F3 | Edit（编辑）- Find Previous（查找上一个）
F3 | Edit（编辑）- Find Next（查找下一个）
Ctrl+B | Edit（编辑）- Go To Beginning（转至开头）
Ctrl+T | Edit（编辑）- Go To Trigger（转至触发）
Ctrl+E | Edit（编辑）- Go To End（转至结尾）
Ctrl+G | Edit（编辑）- Go To（转至）

View（查看）操作

以下操作位于菜单栏中的 View（查看）下面。

Shift+F | View（查看）- Zoom Out Full（最小化）
Shift+O | View（查看）- Zoom Out（缩小）
Shift+I | View（查看）- Zoom In（放大）
F9 | View（查看）- Full Screen（全屏）
F11 | View（查看）- Toggle Tabbed Windows（切换选项卡式窗口）
F12 | View（查看）- Toggle Status Bar（切换状态栏）

Run/Stop（运行/停止）操作

以下操作位于菜单栏中的 Run/Stop（运行/停止）下面。

F5 | Run/Stop（运行/停止）- Run（运行）
Ctrl+F5 | Run/Stop（运行/停止）- Run Repetitive（重复运行）
F8 | Run/Stop（运行/停止）- Stop（停止）
Shift+F8 | Run/Stop（运行/停止）- Cancel（取消）
Shift+Ctrl+F8 | Run/Stop（运行/停止）- Resume（继续）

Compare（比较）操作

以下操作位于菜单栏中的 Compare（比较）下面。

Alt+P | Compare（比较）- Properties（属性）

Listing（列表）操作

以下操作位于菜单栏中的 Listing（列表）下面。

Alt+P | Listing（列表）- Properties（属性）

Waveform（波形）操作

以下操作位于菜单栏中的 Waveform（波形）下面。

Alt+P | Waveform（波形）- Properties（属性）

Window（窗口）操作

以下操作位于菜单栏中的 Window（窗口）下面。

F6 | Window（窗口）- Toggle to Next（切换到下一窗口）
Shift+F6 | Window（窗口）- Toggle to Previous（切换到上一窗口）

Help（帮助）操作

以下操作位于菜单栏中的 Help（帮助）下面。

F1 | Help（帮助）- Help Topics（帮助主题）

Miscellaneous（其他）

以下操作适用于整个界面。

Ctrl+esc | 显示 Windows“开始”菜单


逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项
  • 状态模式采样选项
  • 时序放大

通道和内存深度

  • 1680/1690 系列逻辑分析仪说明，通道和内存深度
  • 16740/41/42 逻辑分析仪说明，通道和内存深度
  • 16750/51/52 逻辑分析仪说明，通道和内存深度
  • 16753/54/55/56 逻辑分析仪说明，通道和内存深度
  • 16760 逻辑分析仪说明，通道和内存深度
  • 16910/11 逻辑分析仪说明，通道和内存深度
  • 16950 逻辑分析仪说明，通道和内存深度

定时模式采样选项/周期

定时模式采样选项包括 Full Channel Timing Mode（全通道定时模式）（默认）、Half Channel Timing Mode（半通道定时模式）（较快采样）或 Transitional / Store Qualified Timing Mode（跳变/存储限定定时模式）（较长的测量时间）。有关特定逻辑分析仪中这些模式的说明，请参见：

  • 1680/1690 系列逻辑分析仪说明，定时模式采样选项/周期
  • 16740/41/42 逻辑分析仪说明，定时模式采样选项/周期
  • 16750/51/52 逻辑分析仪说明，定时模式采样选项/周期
  • 16753/54/55/56 逻辑分析仪说明，定时模式采样选项/周期
  • 16760 逻辑分析仪说明，定时模式采样选项/周期
  • 16910/11 逻辑分析仪说明，定时模式采样选项/周期
  • 16950 逻辑分析仪说明，定时模式采样选项/周期

状态模式采样选项

通过状态模式采样选项可以选择 General State Mode（一般状态模式）（默认）或 Turbo State Mode（涡轮状态模式）（较快采样）。有关特定逻辑分析仪中这些模式的说明，请参见：

  • 1680/1690 系列逻辑分析仪说明，状态模式
  • 16740/41/42 逻辑分析仪说明，状态模式
  • 16750/51/52 逻辑分析仪说明，状态模式采样选项
  • 16753/54/55/56 逻辑分析仪说明，状态模式采样选项
  • 16760 逻辑分析仪说明，状态模式采样选项
  • 16910/11 逻辑分析仪说明，状态模式采样选项
  • 16950 逻辑分析仪说明，状态模式采样选项

时序放大

  • 1680/1690 系列逻辑分析仪没有时序放大功能。
  • 16740/41/42 逻辑分析仪说明，时序放大
  • 16750/51/52 逻辑分析仪说明，时序放大
  • 16753/54/55/56 逻辑分析仪说明，时序放大
  • 16760 逻辑分析仪没有时序放大功能。
  • 16910/11 逻辑分析仪说明，时序放大
  • 16950 逻辑分析仪说明，时序放大


1680/1690 系列逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式

通道和内存深度

 | 1680A 1690A | 1680AD 1690AD | 1681A 1691A | 1681AD 1691AD | 1682A 1692A | 1682AD 1692AD | 1683A 1693A | 1683AD 1693AD
内存深度 | 512 K | 2 M | 512 K | 2 M | 512 K | 2 M | 512 K | 2 M
通道 | 136 | 136 | 102 | 102 | 68 | 68 | 34 | 34

定时模式采样选项/周期

  • 全通道，400 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 2.5 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

  • 半通道，800 MHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每隔 1.25 ns 对数据进行采样和存储；此频率无法更改。

  • 跳变/存储限定，全通道 400 MHz = 跳变/存储限定定时模式

    当采样频率为 400 MHz 时（采样周期为 2.5 ns），必须将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期范围是 2.5 ns 到 1 ms。请参见跳变时序。

注意：

当选择定时采样模式的 400 MHz 选项（800 MHz 选项）时，采集数据中可能有 1 个样本（3 个样本）没有触发标记。这是因为逻辑分析仪硬件使用了 2 条管线（4 条管线）。当在码型上触发时，引起触发的实际样本可能是触发标记前的 1 个样本（3 个样本之一）。当在时钟沿上触发时，引起触发的实际样本可能是触发标记的 +/-1 个样本（+/-2 个样本）范围内的样本。

状态模式

  • 200 Mb/s 最大时钟速率 = 一般状态模式

    在状态（同步采样）模式下，您可以具有全通道和半内存深度，或者通过为时间标签存储保留一个盒对（34 个通道）获取全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样速度与被测设备的时钟速率相匹配，可高达 200 MHz。

另请参见

  • 1680/1690 系列逻辑分析仪规格
  • 1680/1690 系列逻辑分析仪特性


16740/41/42 逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式
  • 时序放大

通道和内存深度

 | 16740A | 16741A | 16742A
内存深度 | 1 M | 4 M | 16 M
通道 | 68 通道/卡 * 模块中的卡数

定时模式采样选项/周期

  • 全通道，400 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 2.5 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

    注意：

    当采样周期为 2.5 ns 时，数据采集率是触发序列发生器速率的两倍。这意味着数据必须至少在两次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器可能会错过存在时间小于两个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（两个）样本。这意味着可能有一个样本的触发点指示为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

  • 半通道，800 MHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每隔 1.25 ns 对数据进行采样和存储；此频率无法更改。

    注意：

    当采样周期为 1.25 ns 时，数据采集率是触发序列发生器速率的四倍。此特性与其他半通道模式特性共同意味着数据必须至少在五次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器无法检测存在时间小于两个采样周期的数据，并可能错过存在时间小于五个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（四个）样本。这意味着最多可能有三个样本的触发点指示为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

  • 跳变/存储限定，全通道 400 MHz = 跳变/存储限定定时模式

    当采样频率为 400 MHz 时（采样周期为 2.5 ns），必须将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期范围是 2.5 ns 到 1 ms。请参见跳变时序。

状态模式

  • 200 Mb/s 最大时钟速率 = 一般状态模式

    在状态（同步采样）模式下，您可以具有全通道和半内存深度，或者通过为时间标签存储保留一个盒对（34 个通道）获取全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样速度与被测设备的时钟速率相匹配，可高达 200 MHz。

时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。它采用 16K 样本、2 GHz 定时分析仪，几乎每 500 ps 对所有通道进行一次数据采样。

另请参见

  • 16740/41/42 逻辑分析仪规格
  • 16740/41/42 逻辑分析仪特性


16750/51/52 逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式采样选项
  • 时序放大

通道和内存深度

 | 16750A/B | 16751A/B | 16752A/B
内存深度 | 4 M | 16 M | 32 M
通道 | 68 通道/卡 * 模块中的卡数

定时模式采样选项/周期

  • 全通道，400 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 2.5 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

    注意：

    当采样周期为 2.5 ns 时，数据采集率是触发序列发生器速率的两倍。这意味着数据必须至少在两次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器可能会错过存在时间小于两个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（两个）样本。这意味着可能有一个样本的触发点指示为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

  • 半通道，800 MHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每隔 1.25 ns 对数据进行采样和存储；此频率无法更改。

    注意：

    当采样周期为 1.25 ns 时，数据采集率是触发序列发生器速率的四倍。此特性与其他半通道模式特性共同意味着数据必须至少在五次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器无法检测存在时间小于两个采样周期的数据，并可能错过存在时间小于五个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（四个）样本。这意味着最多可能有三个样本的触发点指示为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

  • 跳变/存储限定，全通道 400 MHz = 跳变/存储限定定时模式

    采样频率为 400 MHz（2.5 ns 采样周期）时，必须要将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期范围是 2.5 ns 到 1 ms。请参见跳变时序。

状态模式采样选项

  • 200 MHz = 一般状态模式

    使用此采样选项，则可以获得全通道和半内存深度，也可以通过保留一个用于时间标签存储的盒对（34 个通道）获得全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样速度与被测设备的时钟速率相匹配，可高达 200 MHz。

  • 400 MHz = 涡轮状态模式

    使用此采样选项，则会将一个盒对（34 个通道）保留用于时间标签存储，并可获得全部内存深度。时钟计时仅限于模块主卡 盒 1 的 J 时钟，触发仅限于两种触发函数。

    状态采样速度与被测设备的时钟速率相匹配，可高达 400 MHz。

    注意：

    如果在 400 MHz 状态模式下执行存储限定，则可能出现无法进一步限定占用内存的数据的情况。因此，您会看到不连续的状态列表，以及可用内存的减少量。

时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。它采用 16K 样本、2 GHz 定时分析仪，几乎每 500 ps 对所有通道进行一次数据采样。

注意：

处于“涡轮状态模式”下时，时序放大数据的起点可能出现在实际触发点之后。这种数据偏差是由触发序列发生器在此模式下的运作方式导致的。

分析仪序列发生器用于处理样本对。在序列发生器中输入样本对中的第二个样本之前，它不会对第一个样本进行评估。例如，如果将触发点确定在第一个样本，则分析仪将显示与第二个样本的评估结果相关的时序放大数据。触发点与时序放大数据起点之间的数据显示将反映（样本对中）两个样本之间的所有可见时间差。

如果测量使用脉冲时钟，这种时间差可能十分明显，第一个样本（实际触发点）将在脉冲的最后一个时钟信号处计时，而（样本对中的）第二个样本则在下一脉冲的第一个时钟处计时。时钟脉冲之间的时间差反映为触发点与时序放大数据起点之间的偏差。

有助于缓解这种情况的最佳方法是将时序放大设置为“0% poststore”，从而尽可能多地采集第一个样本附近的数据。

另请参见

  • 16750/51/52 逻辑分析仪规格
  • 16750/51/52 逻辑分析仪特性


16753/54/55/56 逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式采样选项
  • 时序放大

通道和内存深度

 | 16753A | 16754A | 16755A | 16756A
内存深度 | 1 M | 4 M | 16 M | 64 M
通道 | 68 通道/卡 * 模块中的卡数

定时模式采样选项/周期

  • 全通道，600 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 1.67 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

  • 半通道，1.2 GHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每 833 ps 进行一次数据采样和存储；此速率不能更改。

  • 跳变/存储限定，全通道 600 MHz = 跳变/存储限定定时模式

    当采样频率为 600 MHz 时（采样周期为 1.667 ns），必须将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期的范围为 1.667 ns 至 500 us。请参见跳变时序。

状态模式采样选项

  • 300 MHz = 一般状态模式

    使用此采样选项，则可以获得全通道和半内存深度，也可以通过保留一个用于时间标签存储的盒对（34 个通道）获得全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样速率将与被测设备的时钟频率匹配，最高为 300 MHz。

  • 600 MHz = 涡轮状态模式

    使用此采样选项，则会将一个盒对（34 个通道）保留用于时间标签存储，并可获得全部内存深度。时钟计时仅限于模块主卡 盒 1 的 J 时钟，触发仅限于两种触发函数。

    状态采样频率将与被测设备的时钟频率匹配，最高为 600 MHz。

时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。它采用 64K 采样、4 GHz 定时分析仪，可对所有通道进行每 250 ps 一次的数据采样。

另请参见

  • 支持差分信号的逻辑分析仪中的 Eye Scan
  • 16753/54/55/56 逻辑分析仪规格和特性


16760 逻辑分析仪说明

  • 与其他逻辑分析仪之间的区别
  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式采样选项

与其他逻辑分析仪之间的区别

与 16900 系列逻辑分析系统中支持的其他逻辑分析仪相比，16760 逻辑分析仪在以下方面有所不同：

  • 除标准的一般状态模式和涡轮状态模式选项以外，还有其他三种状态模式采样选项。

  • 在状态模式下，时钟输入始终来自盒 1（位于多卡模块中的主卡上）。您不能对包含来自其他盒时钟输入的信号的采样时钟输入进行限定。

  • 您不能拆分 16760 逻辑分析仪模块。

  • 单独分配各个盒，而不是以盒对 为单位（而且只能将盒分配给模块或将其保留用于时间标签存储）。

  • 不存在半通道定时模式。

  • 不提供时序放大功能。

通道和内存深度

 | 16760A
内存深度 | 64 M
通道 | 34 通道/卡 * 模块中的卡数

定时模式采样选项/周期

  • 全通道，800 MHz = 全通道定时模式

    如果选择此采样选项，则可以使用逻辑分析仪卡的全部内存深度，每 1.25 ns 进行一次数据采样和存储。

    注意：

    当采样周期为 1.25 ns 时，数据采集率是触发序列发生器速率的四倍。这意味着数据必须至少在四次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器可能会错过存在时间小于四个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（四个）样本。这意味着可能有三个样本的触发点指示为关闭，并且最多可有四个样本的总线/信号发生次数为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

  • 跳变/存储限定，全通道 400 MHz = 跳变/存储限定定时模式

    当采样频率为 400 MHz 时（采样周期为 2.5 ns），必须要将一个盒（17 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见 16760 逻辑分析仪的内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期的范围为 2.5 ns 至 1 ms。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。请参见跳变时序。

    注意：

    当采样周期为 2.5 ns 时，数据采集率是触发序列发生器速率的两倍。这意味着数据必须至少在两次采样中存在，才能被触发序列发生器稳定检测到。触发序列发生器可能会错过存在时间小于两个采样周期的数据。

    触发序列发生器将每个序列发生器时钟的数据视为一组（两个）样本。这意味着可能有一个样本的触发点指示为关闭，并且最多可有两个样本的总线/信号发生次数为关闭。

    尽管触发序列发生器无法检测所有数据，分析仪仍将正确采集至少存在一个采样周期的所有数据。

状态模式采样选项

对于所有状态模式采样选项，时钟计时仅限于模块主卡 盒 1 的 J 时钟。

  • 200 Mb/s = 一般状态模式

    如果选择此采样选项，则：

    • 可以获得全通道和四分之一内存深度，也可以通过为时间标签存储保留一个盒（17 个通道）来获得一半内存深度（有关更多信息，请参见 16760 逻辑分析仪的内存深度和通道数权衡）。
    • 可以采用上升沿、下降沿或双沿均指示有效数据的时钟。
    • 可以使用全部触发资源（16 种码型、15 种范围、定时器、全局计数器、发生计数器）以及全部触发操作。
    • 状态采样速度与被测设备的时钟速率相匹配，可高达 200 MHz。

  • 400 Mb/s = 涡轮状态模式

    如果选择此采样选项，则：

    • 将保留一个盒（17 个通道）用于时间标签存储。
    • 可以获得一半内存深度。
    • 可以采用上升沿、下降沿或双沿均指示有效数据的时钟。
    • 触发资源仅限于 8 种码型、4 种范围和 2 个发生计数器。触发操作仅限于：转至、触发并写入内存。
    • 状态采样速度与被测设备的时钟速率相匹配，可高达 400 MHz。

  • 800 Mb/s = 800 Mb/s 状态模式

    如果选择此采样选项，则：

    • 将保留一个盒（17 个通道）用于时间标签存储。
    • 可以获得全部内存深度。
    • 必须指定输入时钟信号是周期性还是非周期性的。可以采用上升沿、下降沿或双沿均指示有效数据的时钟。
    • 触发资源仅限于每个盒 4 种码型或 2 种范围。触发操作仅限于触发并写入内存。最多可以有 4 个序列步骤。
    • 状态采样速度与被测设备的时钟速率相匹配，可高达 800 MHz。

  • 1250 Mb/s 半通道 = 1250 Mb/s 状态模式

    如果选择此采样选项，则：

    • 将保留一个盒（17 个通道）用于时间标签存储。仅从编号为偶数的通道（0、2、4 等）采集数据。
    • 可以获得双倍内存深度。
    • 输入时钟信号必须是周期性的，并且双沿均指示有效数据。多卡模块 的扩展器卡 上的时钟输入不能用作备用数据通道。
    • 触发资源仅限于每个盒 3 种码型或 1 种范围。触发操作仅限于触发并写入内存。最多可以有 2 个序列步骤。
    • 状态采样速度与被测设备的时钟速率相匹配，可高达 1250 MHz。

  • 1500 Mb/s 半通道 = 1500 Mb/s 状态模式

    如果选择此采样选项，则：

    • 将保留一个盒（17 个通道）用于时间标签存储。仅从编号为偶数的通道（0、2、4 等）采集数据。
    • 可以获得双倍内存深度。
    • 输入时钟信号必须是周期性的，并且双沿均指示有效数据。多卡模块 的扩展器卡 上的时钟输入不能用作备用数据通道。
    • 触发资源仅限于每个盒 3 种码型或 1 种范围。触发操作仅限于触发并写入内存。最多可以有 2 个序列步骤。
    • 状态采样速度与被测设备的时钟速率相匹配，可高达 1500 MHz。

另请参见

  • 16760 逻辑分析仪的内存深度和通道数权衡
  • 16760 逻辑分析仪中的 Eye Finder 操作
  • 支持差分信号的逻辑分析仪中的 Eye Scan
  • 16760 逻辑分析仪规格和特性


16760 逻辑分析仪的内存深度和通道数权衡

本主题将介绍通道计数、内存深度以及触发在 16760 逻辑分析仪的下列模式中的相互作用：

  • 状态采样模式
  • 跳变时序采样模式

200 Mb/s 一般状态采样模式

（对于所有其他状态模式采样选项，都将保留一个盒（17 个通道）用于时间标签存储。）

时间标签存储需要 1 个盒或 16M 采集内存

  • 在 Agilent Logic Analyzer 应用程序中，所有模块都与时间相关；不能关闭 time tag storage（时间标签存储）（虽然以前的 Agilent 逻辑分析系统可以）。

  • 要使用 32M 的模块采集内存，则必须要将一个盒保留用于时间标签存储。要使用所有盒，则必须使用 16M（或更少）的模块采集内存。

  • 在 16760 逻辑分析仪的 200 Mb/s 状态模式下，可用定时器数 = 2 x (卡数) - 1。

默认设置

  • 时间标签存储始终处于开启状态（并且不能将其关闭）。
  • 内存深度设置为 16M。
  • 所有盒均可用于采集数据。
  • 如果选择 32M 内存，则要用于时间标签存储的默认盒是最左边的盒，但还可以使用未分配总线或信号的任何盒。

在没有为盒分配通道的情况下选择 32M 内存深度

  • 系统将自动保留该盒用于时间标签存储。

在已为所有盒分配通道的情况下选择 32M 内存深度

系统将显示对话框，发出以下警告：

  • Bus/signals will lose assigned channels.（总线/信号将失去分配的通道。）
  • Trigger specifications that use timer resources may be affected.（使用定时器资源的触发设定可能会受到影响。）

从 32M 内存深度变为 16M 内存深度

  • 系统将自动释放为时间标签存储保留的盒（分配给逻辑分析仪），使其可用于采集数据。

跳变时序采样模式

时间标签存储需要 1 个盒或 16M 采集内存

  • 跳变时序采样模式也需要时间标签存储。

  • 如果选择最小采样周期 (2.5 ns)，则必须将一个盒保留用于时间标签存储。在这种情况下，不能使用 16M（或更少）的模块采集内存重新活得该盒。

  • 对于其他采样周期，内存深度和通道数的权衡与状态采样模式下的相同。也就是说，要使用 32M 的模块采集内存，则必须将一个盒保留用于时间标签存储。要使用所有盒，则必须使用 16M（或更少）的模块采集内存。

  • 在 16760 逻辑分析仪的定时模式下，可用定时器数 = 2 x (卡数) - 1。

默认设置

  • 时间标签存储是必需的。
  • 如果选择全部内存，则要用于时间标签存储的默认盒是最左边的盒，但还可以使用未分配总线或信号的任何盒。

另请参见

  • 16760 逻辑分析仪说明
  • 配置逻辑分析仪模块
  • 设置采集内存深度
  • 选择采样模式


16760 逻辑分析仪中的 Eye Finder 操作

有关 eye finder 的一般说明，请参见 eye finder 概述。

在 16760 逻辑分析仪中...

16760 逻辑分析仪中的 eye finder 操作可能产生混淆，因为共有以下五种状态模式采样选项：

状态采样选项 | 采样时钟沿 | 沿对沿时序
200 Mb/s = 一般状态模式 | 上升沿、下降沿或双沿 | 非周期性或周期性
400 Mb/s = 涡轮状态模式 | 上升沿、下降沿或双沿 | 非周期性或周期性
800 Mb/s = 800 Mb/s 状态模式 | 上升沿、下降沿或双沿 | 非周期性或周期性
1250 Mb/s 半通道 = 1250 Mb/s 状态模式 | 双沿 | 周期性
1500 Mb/s 半通道 = 1500 Mb/s 状态模式 | 双沿 | 周期性

200 和 400 Mb/s 模式支持单时钟沿采样（上升或下降），以及双沿采样。对于沿对沿时序的可变性没有限制。

800 Mb/s 模式也支持单沿和双沿时钟计时。系统将显示一个选项，允许您指定时钟是周期性（活动沿间的时间不变）还是非周期性（活动沿间的时间可变）的。此选项不会影响采样操作。它将指示软件如何处理时间标签。

1250 和 1500 Mb/s 模式要求使用周期性时钟，并且仅支持双时钟沿的采样。

16760 逻辑分析仪 Eye Finder 示例

例如，如果被测设备采用非周期性时钟（在 20 ns 与 25 ns 的周期之间切换），则可以使用 200、400 或 800 Mb/s 模式。不能使用 1250 和 1500 Mb/s 模式，因为这些模式要求采用周期性时钟。

您将在 eye finder 中看到的内容受 eye finder 扫描范围的限制。在 200 或 400 Mb/s 模式下，eye finder 扫描范围为时钟沿 (T=0) +/- 5 ns。由于最小时钟周期为 20 ns，因此 eye finder 扫描将看不到前一时钟周期和后一时钟周期的数据转换。

假定有一个上升沿的活动触发器，通过双模式 20/25 ns 时钟进行定时。如果您在 10 ns/div 的无限保持模式下通过示波器查看该时钟和数据，则会看到：

在 200 或 400 Mb/s 模式下的 eye finder 中，您将看到与活动时钟沿 (T=0) 相关的转换，因为 eye finder 的扫描范围为 +/- 5 ns。

如果将采样位置（eye finder 显示中的蓝条）设置为 T=-2 ns 左右，则在本例中您将在时钟沿之前获得较好的数据样本。要在时钟沿之后进行数据采样，请将蓝条置于 T=+2 ns 处。

被测设备中的信号可能具有来自时钟的不同延迟，这将使上述 eye finder 采样显示中检测到的转换的位置发生移动。如果延迟超过 5 ns，则 eye finder 将不会显示任何转换。在这种情况下，在 T=0 处进行采样与任何其他位置进行采样效果一样好。

另请参见

  • 支持差分信号的逻辑分析仪中的 Eye Scan


16910/11 逻辑分析仪说明

  • 通道和内存深度
  • 最大状态采样速度
  • 定时模式采样选项/周期
  • 状态模式采样选项
  • 时序放大

通道和内存深度

 | 选项 256 | 选项 001* | 选项 004* | 选项 016* | 选项 032*
内存深度 | 256 K | 1 M | 4 M | 16 M | 32 M
通道 | 16910A：102 通道/卡 * 模块中的卡数 16911A：68 通道/卡 * 模块中的卡数
* 可以分别使用型号 E5865A 和 E5866A 订购 16910A 和 16911A 逻辑分析仪的升级。（另请参见安装经授权的硬件升级。）

另请参见内存深度和通道数权衡。

最大状态采样速度

 | 选项 250 | 选项 500 *
最大状态时钟频率 | 250 MHz | 450 MHz
最大状态数据速率 | 250 Mb/s | 500 Mb/s
* 可以分别使用型号 E5865A 和 E5866A 订购 16910A 和 16911A 逻辑分析仪的升级。（另请参见安装经授权的硬件升级。）

定时模式采样选项/周期

  • 全通道，500 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 2.0 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

  • 半通道，1 GHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每 1 ns 进行一次数据采样和存储；此速率不能更改。

  • 跳变/存储限定，全通道 500 MHz = 跳变/存储限定定时模式

    当采样频率为 500 MHz 时（采样周期为 2.0 ns），必须将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期的范围为 2.0 ns 至 500 us。请参见跳变时序。

状态模式采样选项

  • 250 MHz = 常规状态模式

    使用此采样选项，则可以获得全通道和半内存深度，也可以通过保留一个用于时间标签存储的盒对（34 个通道）获得全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样频率将与被测设备的时钟频率匹配，最高为 250 MHz。

  • 450 MHz = 涡轮状态模式

    使用此采样选项（对选项 500 可用），则会保留一个盒对（34 个通道）用于时间标签存储，并可获得全部内存深度。时钟计时仅限于模块主卡 盒 1 的 J 时钟，触发仅限于两种触发函数。

    状态采样频率将与被测设备的时钟频率匹配，最高为 450 MHz。

  • 500 MHz = 涡轮状态模式（要求对双时钟沿进行采样）

    此采样选项与 450 MHz 涡轮状态模式类似，区别在于逻辑分析仪只能对输入时钟的双沿进行采样。

    状态采样频率将与被测设备的时钟频率匹配，最高为 500 MHz。

时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。它采用 64K 采样、4 GHz 定时分析仪，可对所有通道进行每 250 ps 一次的数据采样。

另请参见

  • 16910/11 逻辑分析仪规格和特性


16950 逻辑分析仪说明

  • 通道和内存深度
  • 定时模式采样选项/周期
  • 状态模式采样选项
  • 时序放大

通道和内存深度

 | 选项 256 | 选项 001* | 选项 004* | 选项 016* | 选项 032* | 选项 064*
内存深度 | 256 K | 1 M | 4 M | 16 M | 32 M | 64 M
通道 | 68 通道/卡 * 模块中的卡数
* 可以使用型号 E5875A 订购 16950A 逻辑分析仪的升级。（另请参见安装经授权的硬件升级。）

定时模式采样选项/周期

  • 全通道，600 MHz = 全通道定时模式

    使用此采样选项，您可以使用逻辑分析仪卡的全内存深度，以每 1.67 ns 一次的频率对数据进行采样和存储。您可以通过 Sample Period（采样周期）控件设置较低的采样频率。

  • 半通道，1.2 GHz = 半通道定时模式

    使用此采样选项，每个盒对中只有一个盒可用，并且内存深度加倍。忽略为不可用的盒分配的通道。可以通过切换 Format（格式）中的 Pod（盒）字段来指定要使用的盒。

    每 833 ps 进行一次数据采样和存储；此速率不能更改。

  • 跳变/存储限定，全通道 600 MHz = 跳变/存储限定定时模式

    当采样频率为 600 MHz 时（采样周期为 1.667 ns），必须将一个盒对（34 个通道）保留用于时间标签存储。对于较低的采样频率，则可以通过使用模块采集内存深度的 1/2（或更少）获得全通道（有关更多信息，请参见内存深度和通道数权衡）。

    只有当检测到上一个值发生更改时才存储数据，因此跳变/存储限定定时模式可以提供最大的采集时间。采样周期的范围为 1.667 ns 至 500 us。请参见跳变时序。

状态模式采样选项

  • 300 MHz = 常规状态模式

    使用此采样选项，则可以获得全通道和半内存深度，也可以通过保留一个用于时间标签存储的盒对（34 个通道）获得全部内存深度（有关更多信息，请参见内存深度和通道数权衡）。

    状态采样频率将与被测设备的时钟频率匹配，最高为 300 MHz。

  • 600 MHz = 涡轮状态模式

    使用此采样选项，则会将一个盒对（34 个通道）保留用于时间标签存储，并可获得全部内存深度。时钟计时仅限于模块主卡 盒 1 的 J 时钟，触发仅限于两种触发函数。

    状态采样频率将与被测设备的时钟频率匹配，最高为 600 MHz。

时序放大

时序放大用于收集逻辑分析仪触发点附近更多的高速时序数据。它采用 64K 采样、4 GHz 定时分析仪，可对所有通道进行每 250 ps 一次的数据采样。

另请参见

  • 支持差分信号的逻辑分析仪中的 Eye Scan
  • 16950 逻辑分析仪规格和特性


规格和特性

描述支持的逻辑分析仪和逻辑分析系统的规格、特性和要求。

  • 1680/1690 系列逻辑分析仪规格和特性
  • 16740/41/42 逻辑分析仪规格和特性
  • 16750/51/52 逻辑分析仪规格和特性
  • 16753/54/55/56 逻辑分析仪规格和特性
  • 16760 逻辑分析仪规格和特性
  • 16910/11 逻辑分析仪规格和特性
  • 16950 逻辑分析仪规格和特性
  • 16900 系列逻辑分析系统机架特性

另请参见

  • 什么是规格
  • 什么是特性


1680/1690 系列逻辑分析仪规格和特性

介绍 1680A/AD 系列和 1690A/AD 系列逻辑分析仪的规格、特性及使用要求。

  • 1680/1690 系列逻辑分析仪规格
  • 1680/1690 系列逻辑分析仪特性

另请参见

  • 什么是规格
  • 什么是特性


1680/1690 系列逻辑分析仪规格

阈值精度 | ±（65 mV + 设置的 1.5 %）
最小主-主时钟时间 | 5.0 ns
设置/保持时间（单时钟，单沿） | 2.5 ns，窗口可按通道调整（4.5/-2.0 ns 至 -2.0/4.5 ns，增量为 100 ps）
设置/保持时间（多时钟，多沿） | 3.0 ns，窗口可按通道调整（5.0/-2.0 ns 至 -1.5/4.5 ns，增量为 100 ps）


1680/1690 系列逻辑分析仪特性

  • 一般信息
  • 状态分析
  • 定时分析
  • 触发
  • 操作环境特性

一般信息

状态/定时通道： | 1680A/AD、1690A/AD：136 1681A/AD、1691A/AD：102 1682A/AD、1692A/AD：68 1683A/AD、1693A/AD： 34
用户界面： | Windows® XP Professional
打印机： | 可打印到任何 Windows® XP Professional 支持的本地或网络打印机。
尺寸： | 1680 - 257 mm 高（10.14 in），443 mm 宽（17.45 in），385 mm 深（15.15 in） 1690 - 153 mm 高（6.05 in），438 mm 宽（17.23 in），335 mm 深（13.16 in）
重量： | 1680 - 13.2 kg (29.1 lbs) 1690 - 7.5 kg (16.5 lbs)

状态分析

最大状态速度： | 200 MHz
状态内存深度： | 1680/1690A 系列：256K 1680/1690AD 系列：1 M
最小状态时钟脉冲宽度： | 1.2 ns
时间标签分辨率： | 4 ns 或 ±0.1%（取较大者）
状态之间的最大时间计数： | 17 s
状态时钟/限定符 | 4（在 34 通道模型上为 2）
最小主-主时钟： | 5.0 ns
最小主-从时钟： | 2.0 ns
最小从-从时钟： | 5.0 ns

定时分析

最大定时样本率： | 半通道：800 MHz 全通道：400 MHz
定时内存深度： | 1680/1690A 系列，半通道：1 M 1680/1690A 系列，全通道：512 K 1680/1690AD 系列，半通道：4 M 1680/1690AD 系列，全通道：2 M
采样周期，全通道： | 2.5 ns 到 1 ms
采样周期，半通道： | 1.25 ns
采样周期精度： | 采样周期的 ±0.01% ±100 ps
通道间偏移： | 通常 <1.5 ns
时间间隔精度： | ±(采样周期 + 通道间偏移 + 时间间隔读数的 0.01%)

触发

序列器速度： | 200 MHz
发生次数最大值： | 16,777,215
范围宽度： | 32 位
定时器值范围： | 100 ns 到 5497 s
定时器分辨率： | 5 ns
定时器精度： | ±10 ns + 0.01%
触发资源： | 16 模式 15 模式
定时器： | 1680A/AD、1690A/AD：3 1681A/AD、1691A/AD：2 1682A/AD、1692A/AD：1 1683A/AD、1693A/AD： 0
发生计数器： | 每序列步骤 1 个
触发序列步骤： | 16
最小可检测假信号： | 1.5 ns
Trigger In 信号激活逻辑分析仪： | 15 ns，典型延迟
发出 Trigger Out 信号： | 150 ns，典型延迟

操作环境特性

温度： | 仪器：5°C 到 50°C 磁盘介质：10°C 到 40°C 探头引线集和电缆：0°C 到 65°C
湿度： | 仪器：在 40°C 时相对湿度最高达 95% 磁盘介质和硬盘驱动器：相对湿度 8% 到 85%
海拔： | 4,572 m (15,000 ft) 操作 15,300 m (50,000 ft) 非操作


16740/41/42 逻辑分析仪规格和特性

介绍 16740/41/42 逻辑分析仪的规格和特性。

  • 16740/41/42 逻辑分析仪规格
  • 16740/41/42 逻辑分析仪特性

另请参见

  • 什么是规格
  • 什么是特性


16740/41/42 逻辑分析仪规格

最大状态时钟速度 | 200 MHz
阈值精度 | ±(65 mV + 阈值设置的 1.5%)
最小主-主时钟时间 | 5.0 ns（200 MHz 时）
设置/保持时间（单时钟，单沿）1 | 2.5 ns，窗口可按通道调整（4.5/-2.0 ns 至 -2.0/4.5 ns，增量为 100 ps）
设置/保持时间（多时钟，多沿）1 | 3.0 ns，窗口可按通道调整（5.0/-2.0 ns 至 -1.5/4.5 ns，增量为 100 ps）
1 指定用于输入信号：VH = -0.9 V，VL = -1.7 V，阈值 = -1.3 V，摆动速率 = 1 V/ns。


16740/41/42 逻辑分析仪特性

  • 一般信息
  • 状态分析
  • 定时分析
  • 触发
  • 电源要求
  • 操作环境特性
  • 存储

一般信息

通道计数： | 1 卡模块 = 64 数据，4 时钟 2 卡模块 = 132 数据，4 时钟 3 卡模块 = 200 数据，4 时钟 4 卡模块 = 268 数据，4 时钟 5 卡模块 = 336 数据，4 时钟

状态分析

最大状态时钟速度： | 200 MHz
最大内存深度： | 16740A = 1 M 16741A = 4 M 16742A = 16 M
最小设置/保持时间 1： | 2.5 ns，窗口可按通道调整（4.5/-2.0 ns 至 -2.0/4.5 ns，增量为 100 ps）
最小状态时钟脉冲宽度： | 1.2 ns
最小主-主时钟： | 5.0 ns（200 MHz 时）
最小主-从时钟： | 2 ns
最小从-从时钟： | 5.0 ns（200 MHz 时）
状态时钟： | 4
状态时钟限定符： | 4
时间标签分辨率 2： | 4 ns
状态之间的最大时间计数： | 17 s
最大状态标签计数 2： | 2e32
存储限定： | 默认（按每序列步骤）
1 指定用于单沿单时钟采集。多沿设置/保持窗口为 3.0 ns。 2 在使用所有盒时，时间标签或状态标签将平分内存深度。

定时分析

  • 时序放大
  • 传统时序
  • 跳变时序

时序放大

采样频率： | 2 GHz、1 GHz、500 MHz、250 MHz
采样周期精度： | ±50 ps
通道间偏移： | <1.0 ns
定时间隔精度： | ±(采样周期 + 通道间偏移 + 时间间隔读数的 0.01%)
触发位置： | 起点、中心、终点，或由用户定义
内存深度： | 16 K

传统时序

最大采样频率： | 半通道 = 800 MHz 全通道 = 400 MHz
内存深度： | 16740A，半通道 = 每通道采样 2 M 16740A，全通道 = 每通道采样 1 M 16741A，半通道 = 每通道采样 8 M 16741A，全通道 = 每通道采样 4 M 16742A，半通道 = 每通道采样 32 M 16742A，全通道 = 每通道采样 16 M
采样周期精度： | ±(250 ps + 采样周期的 0.01%)
通道间偏移： | <1.5 ns（典型）
定时间隔精度： | ±(采样周期 + 通道间偏移 + 时间间隔读数的 0.01%)
最小数据脉冲宽度： | 1.5 ns（数据采集） 5.0 ns（触发序列）

跳变时序

最大定时分析采样频率： | 400 MHz
最小数据脉冲宽度： | 3.8 ns（数据采集） 5.1 ns（触发序列）
通道数： | 对于小于 400 MHz 的采样频率：68 x (卡数) 对于等于 400 MHz 的采样频率：68 x (卡数) - 34
全局计数器： | 1
假信号/沿识别器： | 每对盒 1 个

触发

最大触发序列发生器速度： | 200 MHz
状态序列步骤： | 16
定时序列步骤： | 16
序列步骤分支： | 任意 4 路“If/then/else”
发生次数最大值： | 16,777,215
码型识别器： | 16
范围识别器： | 15
范围宽度： | 32
发生计数器： | 每序列步骤 1 个
全局计数器： | 2
标志： | 4 个，由连接的所有逻辑分析系统机架共享
将标志设置/重置为计算： | 110 ns（典型）
定时器： | 200 MHz 状态：2 x 卡数 定时：(2 x 卡数) - 1
定时器值范围： | 100 ns 到 5497 s
定时器分辨率： | 5 ns
定时器精度： | ±10 ns + 0.01%
定时器重置延时： | 70 ns
假信号/沿识别器： | 每对盒 2 个（仅限于定时分析）
最小可检测假信号： | 1.5 ns
大于持续时间： | 6 ns 至 100 ms（增量为 6 ns）
小于持续时间： | 12 ns 至 100 ms（增量为 6 ns）
Trigger Out 信号中的数据： | 150 ns（典型）

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

操作环境特性

仅限于室内使用。
温度： | 仪器（磁盘和介质除外）：0°C 至 50°C（+32°F 至 122°F） 探头引线集和电缆：0°C 至 65°C（+32°F 至 65.00°C）
湿度： | 仪器、探头引线集和电缆：在 40°C (+104°F) 时相对湿度最高达 80%
海拔： | 操作状态：4,600 m (15,000 ft) 非操作状态：15,300 m (50,000 ft)
振动： | 操作状态：随机振动 5-500 Hz，每轴 10 min（约为 0.2 g rms） 非操作状态：随机振动 5 至 500 Hz，每轴 10 min（约为 2.41 g rms）；扫频正弦共振搜索 5 至 500 Hz，0.50 g（限定符为 0），每轴 4 次共振时共振驻留为 5 min。

如果在下列范围内进行操作，将提高可靠性：

温度： | +20°C 至 35°C（+68°F 至 95°F）
湿度： | 20% 至 80%（非冷凝）

存储

存储或装运逻辑分析仪的环境限制如下：

温度： | -40°C 至 +75°C
湿度： | 在 65°C 时相对湿度最高达 90%
海拔： | 最高 15,300 m (50,000 ft)

请保护模块，避免其处于极端的温度环境中，以防止仪器上出现冷凝现象。


16750/51/52 逻辑分析仪规格和特性

介绍 16750/51/52 逻辑分析仪的规格和特性。

  • 16750/51/52 逻辑分析仪规格
  • 16750/51/52 逻辑分析仪特性

另请参见

  • 什么是规格
  • 什么是特性


16750/51/52 逻辑分析仪规格

最大状态时钟速度 | 400 MHz
阈值精度 | ±(65 mV + 阈值设置的 1.5%)
最小主-主时钟时间 | 5.0 ns（200 MHz 时） 2.5 ns（400 MHz 时）
设置/保持时间（单时钟，单沿）1 | 2.5 ns，窗口可按通道调整（4.5/-2.0 ns 至 -2.0/4.5 ns，增量为 100 ps）
设置/保持时间（多时钟，多沿）1 | 3.0 ns，窗口可按通道调整（5.0/-2.0 ns 至 -1.5/4.5 ns，增量为 100 ps）
1 指定用于输入信号：VH = -0.9 V，VL = -1.7 V，阈值 = -1.3 V，摆动速率 = 1 V/ns。


16750/51/52 逻辑分析仪特性

  • 一般信息
  • 状态分析
  • 定时分析
  • 触发
  • 电源要求
  • 操作环境特性
  • 存储

一般信息

通道计数： | 1 卡模块 = 64 数据，4 时钟 2 卡模块 = 132 数据，4 时钟 3 卡模块 = 200 数据，4 时钟 4 卡模块 = 268 数据，4 时钟 5 卡模块 = 336 数据，4 时钟

状态分析

最大状态时钟速度： | 400 MHz
最大内存深度： | 16750A/B = 4 M 16751A/B = 16 M 16752A/B = 32 M
最小设置/保持时间 1： | 2.5 ns，窗口可按通道调整（4.5/-2.0 ns 至 -2.0/4.5 ns，增量为 100 ps）
最小状态时钟脉冲宽度： | 1.2 ns
最小主-主时钟： | 5.0 ns（200 MHz 时） 2.5 ns（400 MHz 时）
最小主-从时钟： | 2 ns
最小从-从时钟： | 5.0 ns（200 MHz 时） 2.5 ns（400 MHz 时）
状态时钟： | 4
状态时钟限定符： | 4
时间标签分辨率 2： | 4 ns
状态之间的最大时间计数： | 17 s
最大状态标签计数 2： | 2e32
存储限定： | 默认（按每序列步骤）
1 指定用于单沿单时钟采集。多沿设置/保持窗口为 3.0 ns。 2 在使用所有盒时，时间标签或状态标签将平分内存深度。

定时分析

  • 时序放大
  • 传统时序
  • 跳变时序

时序放大

采样频率： | 2 GHz、1 GHz、500 MHz、250 MHz
采样周期精度： | ±50 ps
通道间偏移： | <1.0 ns
定时间隔精度： | ±(采样周期 + 通道间偏移 + 时间间隔读数的 0.01%)
内存深度： | 16 K

传统时序

最大采样频率： | 半通道 = 800 MHz 全通道 = 400 MHz
内存深度： | 16750A/B，半通道 = 每通道采样 8 M 16750A/B，全通道 = 每通道采样 4 M 16751A/B，半通道 = 每通道采样 32 M 16751A/B，全通道 = 每通道采样 16 M 16752A/B，半通道 = 每通道采样 64 M 16752A/B，全通道 = 每通道采样 32 M
采样周期精度： | ±(250 ps + 采样周期的 0.01%)
通道间偏移： | <1.5 ns（典型）
定时间隔精度： | ±(采样周期 + 通道间偏移 + 时间间隔读数的 0.01%)
最小数据脉冲宽度： | 1.5 ns（数据采集） 5.0 ns（触发序列）

跳变时序

最大定时分析采样频率： | 400 MHz
最小数据脉冲宽度： | 3.7 ns（数据采集） 5.0 ns（触发序列）
通道数： | 对于小于 400 MHz 的采样频率：68 x (卡数) 对于等于 400 MHz 的采样频率：68 x (卡数) - 34
全局计数器： | 1
假信号/沿识别器： | 每对盒 1 个

触发

最大触发序列发生器速度： | 200 MHz
状态序列步骤： | 16
定时序列步骤： | 16
序列步骤分支： | 任意 4 路“If/then/else”
发生次数最大值： | 16,777,215
码型识别器： | 16
范围识别器： | 15
范围宽度： | 32
发生计数器： | 每序列步骤 1 个
全局计数器： | 2
标志： | 4 个，由连接的所有逻辑分析系统机架共享
将标志设置/重置为计算： | 110 ns（典型）
定时器： | 200 MHz 状态：2 x 卡数 定时：(2 x 卡数) - 1
定时器值范围： | 100 ns 到 4397 s
定时器分辨率： | 4 ns
定时器精度： | ±10 ns + 0.01%
定时器重置延时： | 60 ns
假信号/沿识别器： | 每对盒 2 个（仅限于定时分析）
最小可检测假信号： | 1.5 ns
大于持续时间： | 6 ns 至 100 ms（增量为 6 ns）
小于持续时间： | 12 ns 至 100 ms（增量为 6 ns）
Trigger Out 信号中的数据： | 150 ns（典型）

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

操作环境特性

仅限于室内使用。
温度： | 仪器（磁盘和介质除外）：0°C 至 50°C（+32°F 至 122°F） 探头引线集和电缆：0°C 至 65°C（+32°F 至 65.00°C）
湿度： | 仪器、探头引线集和电缆：在 40°C (+104°F) 时相对湿度最高达 80%
海拔： | 操作状态：4,600 m (15,000 ft) 非操作状态：15,300 m (50,000 ft)
振动： | 操作状态：随机振动 5-500 Hz，每轴 10 min（约为 0.2 g rms） 非操作状态：随机振动 5 至 500 Hz，每轴 10 min（约为 2.41 g rms）；扫频正弦共振搜索 5 至 500 Hz，0.50 g（限定符为 0），每轴 4 次共振时共振驻留为 5 min。

如果在下列范围内进行操作，将提高可靠性：

温度： | +20°C 至 35°C（+68°F 至 95°F）
湿度： | 20% 至 80%（非冷凝）

存储

存储或装运逻辑分析仪的环境限制如下：

温度： | -40°C 至 +75°C
湿度： | 在 65°C 时相对湿度最高达 90%
海拔： | 最高 15,300 m (50,000 ft)

请保护模块，避免其处于极端的温度环境中，以防止仪器上出现冷凝现象。


16753/54/55/56 逻辑分析仪规格和特性

介绍 16753/54/55/56 逻辑分析仪的规格和特性。

注意：

标有星号 (*) 的项为规格。其他所有项均为特性。

“典型”表示基于大量单位测量的参数的平均值或中值。
  • 模块通道计数
  • 探头
  • 时序放大
  • 状态（同步）分析模式
  • 定时（异步）分析模式
  • 电源要求
  • 环境特性

模块通道计数

 | 状态分析 | 定时分析
1 卡模块： | 64 数据 + 4 时钟 | 68
2 卡模块： | 132 数据 + 4 时钟 | 136
3 卡模块： | 200 数据 + 4 时钟 | 204
4 卡模块： | 268 数据 + 4 时钟 | 272
5 卡模块： | 336 数据 + 4 时钟 | 340

探头

必须使用探头将逻辑分析仪连接到被测设备。有关特定探头的规格和特性，请参见随探头提供的文档，或在 www.agilent.com 上搜索探头的型号。

时序放大

定时分析采样频率： | 4 GHz
定时间隔精度： | 盒对内：±(750 ps + 时间间隔读数的 0.01%) 盒对间：±(1.5 ns + 时间间隔读数的 0.01%)
内存深度： | 64 K
触发位置： | 起点、中心、终点，或由用户定义
最小数据脉冲宽度： | 750 ps

状态（同步）分析模式

 | 300 Mb/s 状态模式 | 600 Mb/s 状态模式
tWidth *, 1, 2： | 1 ns *，600 ps（典型） | 1 ns *，600 ps（典型）
tSetup： | 0.5 tWidth | 0.5 tWidth
tHold： | 0.5 tWidth | 0.5 tWidth
tSample 范围 3： | -4 ns 至 +4 ns | -4 ns 至 +4 ns
tSample 调整分辨率： | 80 ps（典型） | 80 ps（典型）
tSample 精度（手动调整）： | ±300 ps | ±300 ps 4
每通道最大状态数据速率： | 300 Mb/s | 800 Mb/s
单时基和触发的最大通道数：5 : | 340 - (时钟数) | 306 - (1 时钟)
内存深度 5： | 16753A：采样 1 M 16754A：采样 4 M 16755A：采样 16 M 16756A：采样 64 M | 16753A：采样 1 M 16754A：采样 4 M 16755A：采样 16 M 16756A：采样 64 M
独立分析仪数量 6： | 2 | 1
时钟数 7： | 4 | 1
时钟限定符数 7： | 4 | N/A
活动时钟沿之间的最小时间*, 8： | 3.33 ns | 1.67 ns
最小主-从时钟时间： | 1 ns | N/A
最小从-主时钟时间： | 1 ns | N/A
最小从-从时钟时间： | 3.33 ns | N/A
最小状态时钟脉冲宽度： | 单沿：1.0 ns 多沿：1.0 ns | 单沿：500 ps 多沿：1.67 ns
时钟限定符设置时间： | 500 ps | N/A
时钟限定符保持时间： | 0 | N/A
时间标签分辨率 5： | 2 ns | 1.5 ns
最大存储状态间计时： | 32 天 | 32 天
最大触发序列速度： | 300 MHz | 600 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 2 路 If/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 14 种码型（以 =、≠、>、>=、<、<= 进行计算） 7 种双边界范围（以 in range、not in range 进行计算） 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 存储/不存储样本 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发并写入内存
存储限定： | 默认（全局）并按顺序步骤 | 默认（全局）
全局计数器最大值： | 2E+24 | N/A
发生计数器最大值： | 2E+24 | 2E+24
最大码型宽度： | 128 位 | 128 位
最大范围宽度： | 32 位 | 32 位
定时器值范围： | 40 ns 至 2199 s | N/A
定时器分辨率： | 2 ns | N/A
定时器精度： | ±(5 ns + 0.01%) | N/A
定时器重置延时： | 40 ns | N/A
* 标有星号 (*) 的项为规格。其他所有项均为特性。“典型”表示基于大量单位测量的参数的平均值或中值。 1 被测系统中的最小眼宽度。 2 您对探头的选择将限制系统带宽。选择速率为 600 Mb/s 或更高的探头可保持系统带宽。 3 对于每个数据通道输入，可以分别调整采样位置。负采样位置将导致在每个活动时钟沿之前对输入进行该数量的同步采样。正采样位置将导致在每个活动时钟沿之后对输入进行该数量的同步采样。采样位置为零将导致在每个时钟沿处对输入进行同步采样。 4 在 600 Mb/s 状态模式下建议使用 eye finder。 5 在 300 Mb/s 状态模式下的所有盒均已分配时，内存深度是最大内存深度的一半。如果有一个盒对（34 个通道）未分配，则会获得全部内存深度。在 600 Mb/s 状态模式下，必须为时间标签保留一个未分配的盒对（34 个通道）。 6 独立分析仪可以是状态分析仪，也可以是定时分析仪。选择 600 Mb/s 状态模式时，只能使用一台分析仪。 7 在 300 Mb/s 状态模式下，时钟与限定符的总数为 4。所有时钟和限定符输入都必须在主模块中进行。 8 测试采用输入信号：VH = .9 V，VL = -1.7 V，阈值 = -1.3 V，摆动速率 = 1 V/ns。 9 除非保留一个未分配的盒对（34 个通道），否则将平分跳变时序速度和内存深度。

定时（异步）分析模式

 | 传统时序 | 跳变时序 9
所有通道的采样频率： | 600 MHz | 600 MHz
半通道模式下的采样频率： | 1200 MHz | N/A
通道数： | 68 x (卡数) | 对于小于 600 MHz 的采样速率：68 x (卡数)。 对于 600 MHz 的采样速率：68 x (卡数) - 34。
单时基和触发的最大通道数： | 340 | 340
独立分析仪数量 6： | 2 | 2
采样周期（半通道）： | 833 ps | N/A
采样周期（全通道）： | 1.67 ns | 1.67 ns
最小数据脉冲宽度： | 1 个采样周期 + 500 ps | 1 个采样周期 + 500 ps
时间间隔精度： | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%) | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%)
全通道模式下的内存深度： | 16753A：1 M 16754A：4 M 16755A：16 M 16756A：64 M | 16753A：1 M 16754A：4 M 16755A：16 M 16756A：64 M
半通道模式下的内存深度： | 16753A：2 M 16754A：8 M 16755A：32 M 16756A：128 M | N/A
最大触发序列速度： | 300 MHz | 300 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 任意 4 路 if/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 2 个沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 3 个沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志
全局计数器最大值： | 2E+24 | 2E+24
发生计数器最大值： | 2E+24 | 2E+24
最大范围宽度： | 32 位 | 32 位
最大码型宽度： | 128 位 | 128 位
定时器值范围： | 40 ns 至 2199 s | 40 ns 至 2199 s
定时器分辨率： | 2 ns | 2 ns
定时器精度： | ±(5 ns + 0.01%) | ±(5 ns + 0.01%)
大于持续时间： | 3.33 ns 至 55 ms（增量为 3.3 ns） | 3.33 ns 至 55 ms（增量为 3.3 ns）
小于持续时间： | 6.67 ns 至 55 ms（增量为 3.3 ns） | 6.67 ns 至 55 ms（增量为 3.3 ns）
定时器重置延时： | 40 ns | 40 ns

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

环境特性

仅限于室内使用。

有关探头的环境特性，请参见特定探头的规格和特性。

  • 操作环境
  • 非操作环境

操作环境

温度： | 0°C 至 50°C（+32°F 至 122°F）。如果在下列范围内进行操作，将提高可靠性：+20°C 至 35°C（+68°F 至 95°F）。
湿度： | 0 至 80% 相对湿度（40°C (+104°F) 下）。如果在下列范围内进行操作，将提高可靠性：20% 至 80%（非冷凝）。
海拔： | 0 至 3,000 m (10,000 ft)
振动： | 随机振动 5-500 Hz，每轴 10 min（约为 0.2 g rms）

非操作环境

温度： | -40°C 至 +75°C（-40°F 至 +167°F）。请保护仪器，避免其处于极端的温度环境中，以防止仪器上出现冷凝现象。
湿度： | 0 至 90% 相对湿度（65°C (149°F) 下）。
海拔： | 0 至 15,300 m (50,000 ft)
振动（在装运箱内）： | 随机振动 5 至 500 Hz，每轴 10 min（约为 2.41 g rms）；扫频正弦共振搜索 5 至 500 Hz，0.50 g（限定符为 0），每轴 4 次共振时共振驻留为 5 min。

另请参见

  • 什么是规格
  • 什么是特性


16760 逻辑分析仪规格和特性

介绍 16760 逻辑分析仪的规格和特性。

注意：

标有星号 (*) 的项为规格。其他所有项均为特性。
  • 模块通道计数
  • 探头
  • 状态（同步）分析模式
  • 定时（异步）分析模式
  • 电源要求
  • 环境特性

模块通道计数

 | 状态分析 | 定时分析
1 卡模块： | 32 数据 + 2 时钟 | 34
2 卡模块： | 66 数据 + 2 时钟 | 68
3 卡模块： | 100 数据 + 2 时钟 | 102
4 卡模块： | 134 数据 + 2 时钟 | 136
5 卡模块： | 168 数据 + 2 时钟 | 170

探头

必须使用探头将逻辑分析仪连接到被测设备。有关特定探头的规格和特性，请参见随探头提供的文档，或在 www.agilent.com 上搜索探头的型号。

状态（同步）分析模式

每项输入的规格

 | 800、1250、1500 Mb/s 模式 | 200、400 Mb/s 模式 | 描述/说明
最小 tWidth（数据到时钟）： | 500 ps | 1.25 ns | 被测系统中的眼宽度。2
最小 tSetup（数据到时钟）： | 250 ps | 625 ps | 在 tSample 之前要求有数据设置时间。
最小 tHold（数据到时钟）： | 250 ps | 625 ps | 在 tSample 之后要求有数据保持时间。
最小 vHeight 1（所有输入）： | 100 mV | 100 mV | E5379A 100 针差分探头。3
 | 250 mV | 250 mV | E5378A 100 针单端探头 4，E5382A 单端飞线探头集
 | 300 mV | 300 mV | E5380A 38 针单端探头
* 标有星号的所有规格均为产品测试所依据的性能标准。 1 可以对分析仪进行配置，以便在时钟的上升沿、下降沿或双沿进行采样。如果将双沿用于单端时钟输入，请注意准确设置时钟阈值以避免相位错误。 2 在探头顶端指定了眼的宽度和高度。由分析仪中的 eye finder 测量的眼宽度可以稍小，这时仍可正确采样。 3 针对差分信号的每个方面： 4 E5378A 探头和 E5382A 探头集中的时钟输入可分别连接，也可采用单端。对于分别连接的时钟通道，使用 E5379A 探头 vHeight 规格。

针对每项输入的可由用户调整的设置

 | 调整范围
 | 1500 Mb/s 状态模式 | 1250 Mb/s 状态模式 | 800 Mb/s 状态模式 | 400 Mb/s 状态模式 | 200 Mb/s 状态模式
tSample 5（数据到时钟）： | 0 ns 至 +4 ns，分辨率为 10 ps | -2.5 ns 至 +2.5 ns，分辨率为 10 ps | -2.5 ns 至 +2.5 ns，分辨率为 10 ps | -3.2 ns 至 +3.2 ns，分辨率为 100 ps | -3.5 ns 至 +3 ns，分辨率为 100 ps
vThreshold 6（所有输入）： | -3 V 至 +5 V，分辨率为 10 mV | -3 V 至 +5 V，分辨率为 10 mV | -3 V 至 +5 V，分辨率为 10 mV | -3 V 至 +5 V，分辨率为 10 mV | -3 V 至 +5 V，分辨率为 10 mV
5 对于每个数据通道输入，可以单独调整采样位置。负采样位置将导致在每个活动时钟沿之前对输入进行该数量的同步采样。正采样位置将导致在每个活动时钟沿之后对输入进行该数量的同步采样。采样位置为零将导致在每个活动时钟沿处进行同步采样。 6 阈值适用于单端输入信号。对于每个盒的时钟输入以及每个盒的每组 16 位数据输入，均可分别调整阈值。阈值限制同时适用于内部引用和 E5378A 探头上的外部引用输入。

同步状态分析

 | 1500 Mb/s 状态模式 | 1250 Mb/s 状态模式 | 800 Mb/s 状态模式 | 400 Mb/s 状态模式 | 200 Mb/s 状态模式
每通道最大数据速率 9： | 1.5 Gb/s | 1.25 Gb/s | 800 Mb/s | 400 Mb/s | 200 Mb/s
最小时钟间隔（活动沿到活动沿）*, 9： | 667 ps | 800 ps | 1.25 ns | 2.5 ns | 5 ns
最小状态时钟脉冲宽度（时钟极性为上升或下降）9： | N/A | N/A | 600 ps | 1.5 ns | 1.5 ns
时钟周期性： | 时钟必须是周期性的 | 时钟必须是周期性的 | 周期性或非周期性 | 周期性或非周期性 | 周期性或非周期性
时钟数： | 1 | 1 | 1 | 1 | 1
时钟极性： | 双沿 | 双沿 | 上升沿、下降沿或双沿 | 上升沿、下降沿或双沿 | 上升沿、下降沿或双沿
最小数据脉冲宽度 *： | 600 ps | 750 ps | E5378A、E5379A、E5382A 探头：750 ps E5380A 探头：1.5 ns | 1.5 ns | 1.5 ns
通道数 7： | 16 x (卡数) - 8 | 16 x (卡数) - 8 | 34 x (卡数) - 16 | 34 x (卡数) - 16 | 34 x (卡数)
单时基和触发的最大通道数： | 72（5 张卡） | 72（5 张卡） | 154（5 张卡） | 154（5 张卡） | 170（5 张卡）
最大内存深度： | 采样 128 M | 采样 128 M | 采样 64 M | 采样 32 M | 采样 32 M
时间标签分辨率： | 4 ns 8 | 4 ns 8 | 4 ns 8 | 4 ns 8 | 4 ns
状态之间的最大时间计数： | 17 s | 17 s | 17 s | 17 s | 17 s
触发资源： | 3 种码型（针对一个盒计算为 =、≠、>、>=、<、<=；针对多个盒计算为 =、≠）；或者每个盒 1 种范围 4 个标志 Arm in | 3 种码型（针对一个盒计算为 =、≠、>、>=、<、<=；针对多个盒计算为 =、≠）；或者每个盒 1 种范围 4 个标志 Arm in | 4 种码型（针对一个盒计算为 =、≠、>、>=、<、<=；针对多个盒计算为 =、≠）；或者每个盒 2 种范围 4 个标志 Arm in | 8 种码型（以 =、≠、>、>=、<、<= 进行计算） 4 种范围（以 in range、not in range 进行计算） 2 个发生计数器 4 个标志 Arm in | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 15 种范围（以 in range、not in range 进行计算） 每卡 2 个定时器 - 1 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 Arm in
触发操作： | 触发并写入内存 | 触发并写入内存 | 触发并写入内存 | 转至 触发并写入内存 | 转至 触发、发送电子邮件，并写入内存 触发并转至 存储/不存储样本 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/重置 发生计数器重置 设置/清除标志
最大触发序列步骤数： | 2 | 2 | 4 | 16 | 16
最大触发序列速度： | 1.5 Gb/s | 1.25 Gb/s | 800 MHz | 400 MHz | 200 MHz
存储限定： | 默认 | 默认 | 默认 | 默认 | 默认（按每序列步骤）
全局计数器最大值： | N/A | N/A | N/A | N/A | 16,777,215
发生计数器最大值： | N/A | N/A | N/A | N/A | 16,777,215
最大码型/范围期间宽度： | 32 位 10 | 32 位 10 | 32 位 10 | 32 位 10 | 32 位 10
定时器值范围： | N/A | N/A | N/A | N/A | 100 ns 到 4397 s
定时器分辨率： | N/A | N/A | N/A | N/A | 4 ns
定时器精度： | N/A | N/A | N/A | N/A | ±(10 ns + 0.01%)
定时器重置延时： | N/A | N/A | N/A | N/A | 65 ns
BNC 端口输出的数据延时： | 150 ns | 150 ns | 150 ns | 150 ns | 150 ns
将标志设置/重置为计算延时： | N/A | N/A | N/A | N/A | 110 ns
* 标有星号的所有规格均为产品测试所依据的性能标准。 7 在 1.25 Gb/s 和 1.5 Gb/s 模式下，仅对编号为偶数的通道（0、2、4 等）进行采集。 8 用于分配时间标签的硬件分辨率为 4 ns。将计算中间状态的时间。 9 对探头的选择可以限制系统性能。选择速率等于（或高于）所选模式速度的探头可保持系统带宽。 10 最大总线/信号宽度为 32 位。可以通过对多个总线/信号进行“Anding”操作来创建较宽的码型。

定时（异步）分析模式

 | 传统时序 | 跳变时序
最大定时分析采样频率： | 800 MHz | 400 MHz
通道数： | 34 x (卡数) | 对于小于 400 MHz 的采样频率：34 x（卡数）。 对于等于 400 MHz 的采样频率：34 x (卡数) - 17 11。
单时基和触发的最大通道数： | 170（5 张卡） | 170（5 张卡）
采样周期： | 1.25 ns | 2.5 ns 至 1 ms 11
内存深度： | 采样 64 M | 采样 32 M 11
采样周期精度： | ±(250 ps + 采样周期的 0.01%) | ±(250 ps + 采样周期的 0.01%)
通道间偏移： | <1.5 ns | <1.5 ns
时间间隔精度： | ±[采样周期 + (通道间偏移) + (时间间隔的 0.01%)] | ±[采样周期 + (通道间偏移) + (时间间隔的 0.01%)]
最小数据脉冲宽度： | 1.5 ns（数据采集） 5.1 ns（触发序列） | 3.8 ns（数据采集） 5.1 ns（触发序列）
最大触发序列速度： | 200 MHz | 200 MHz
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 15 种范围（以 in range、not in range 进行计算） 2 个沿/假信号 (每卡 2 个定时器) - 1 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志，arm in | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 15 种范围（以 in range、not in range 进行计算） 2 个沿/假信号 (每卡 2 个定时器) - 1 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志，arm in
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志
全局计数器最大值： | 16,777,215 | 16,777,215
发生计数器最大值： | 16,777,215 | 16,777,215
定时器值范围： | 100 ns 至 4397 s | 100 ns 至 4397 s
定时器分辨率： | 4 ns | 4 ns
定时器精度： | ±(10 ns + 0.01%) | ±(10 ns + 0.01%)
大于持续时间： | 5 ns 至 83 ms（增量为 5 ns） | 5 ns 至 83 ms（增量为 5 ns）
小于持续时间： | 10 ns 至 83 ms（增量为 5 ns） | 10 ns 至 83 ms（增量为 5 ns）
定时器重置延时： | 60 ns | 60 ns
BNC 端口输出的数据延时： | 150 ns | 150 ns
将标志设置/重置为计算延时： | 110 ns | 110 ns
11 当所有盒在跳变/存储限定定时模式下均已分配时，最小采样周期为 5 ns，最大内存深度为采样 16 M。

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

环境特性

仅限于室内使用。

有关探头的环境特性，请参见特定探头的规格和特性。

操作环境

温度： | 0°C 至 45°C（+32°F 至 113°F）。

另请参见

  • 什么是规格
  • 什么是特性


16910/11 逻辑分析仪规格和特性

介绍 16910/11 逻辑分析仪的规格和特性。

注意：

标有星号 (*) 的项为规格。其他所有项均为特性。

“典型”表示基于大量单位测量的参数的平均值或中值。
  • 模块通道计数
  • 探头
  • 时序放大
  • 状态（同步）分析模式
  • 定时（异步）分析模式
  • 电源要求
  • 环境特性

模块通道计数

 | 状态分析 16910A | 状态分析 16911A | 定时分析 16910A | 定时分析 16911A
1 卡模块： | 98 数据 + 4 时钟 | 64 数据 + 4 时钟 | 102 | 68
2-卡模块： | 200 数据 + 4 时钟 | 132 数据 + 4 时钟 | 204 | 136
3-卡模块： | 302 数据 + 4 时钟 | 200 数据 + 4 时钟 | 306 | 204
4-卡模块： | 404 数据 + 4 时钟 | 268 数据 + 4 时钟 | 408 | 272
5-卡模块： | 506 数据 + 4 时钟 | 336 数据 + 4 时钟 | 510 | 340

探头

必须使用探头将逻辑分析仪连接到被测设备。有关特定探头的规格和特性，请参见随探头提供的文档，或在 www.agilent.com 上搜索探头的型号。

时序放大

定时分析采样频率： | 4 GHz
定时间隔精度： | 盒对内：±(1 ns + 时间间隔读数的 0.01%) 盒对间：±(1.75 ns + 时间间隔读数的 0.01%)
内存深度： | 64 K
触发位置： | 起点、中心、终点，或由用户定义
最小数据脉冲宽度： | 1 ns

状态（同步）分析模式

 | 选项 250 | 选项 500
tWidth*, 1 : | TBD*（ [image] 最新数据表） | TBD*（ [image] 最新数据表）
tSetup： | 0.5 tWidth | 0.5 tWidth
tHold： | 0.5 tWidth | 0.5 tWidth
tSample 范围 2： | -4 ns 至 +4 ns | -4 ns 至 +4 ns
tSample 调整分辨率： | 80 ps（典型） | 80 ps（典型）
tSample 精度（手动调整）： | TBD（ [image] 最新数据表） | TBD 3（ [image] 最新数据表）
每通道最大状态数据速率： | 250 Mb/s | 500 Mb/s
单时基和触发的通道数 4： | 16910A：510 - (时钟数) 16911A：340 - (时钟数) | 16910A：510 - (时钟数) 16911A：340 - (时钟数)
内存深度 4： | 选项 256：采样 256 K 选项 001：采样 1 M 选项 004：采样 4 M 选项 016：采样 16 M 选项 032：采样 32 M | 选项 256：采样 256 K 选项 001：采样 1 M 选项 004：采样 4 M 选项 016：采样 16 M 选项 032：采样 32 M
独立分析仪数量 5： | 2 | 1
时钟数 6： | 4 | 1
时钟限定符数 6： | 4 | N/A
活动时钟沿之间的最小时间*, 7： | 4.0 ns | 2.0 ns
最小主-从时钟时间： | 1 ns | N/A
最小从-主时钟时间： | 1 ns | N/A
最小从-从时钟时间： | 4.0 ns | N/A
最小状态时钟脉冲宽度： | 单沿：1.0 ns 多沿：1.0 ns | 单沿：1.0 ns 多沿：2.0 ns
时钟限定符设置时间： | 500 ps | N/A
时钟限定符保持时间： | 0 | N/A
时间标签分辨率： | 2 ns | 1.5 ns
最大存储状态间计时： | 32 天 | 32 天
最大触发序列速度： | 250 MHz | 500 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 2 路 If/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 14 种码型（以 =、≠、>、>=、<、<= 进行计算） 7 种双边界范围（以 in range、not in range 进行计算） 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 存储/不存储样本 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发并写入内存
存储限定： | 默认（全局）并按顺序步骤 | 默认（全局）
全局计数器最大值： | 2E+24 | N/A
发生计数器最大值： | 2E+24 | 2E+24
最大码型宽度： | 128 位 | 128 位
最大范围宽度： | 32 位 | 32 位
定时器值范围： | 60 ns 至 2199 s | N/A
定时器分辨率： | 2 ns | N/A
定时器精度： | ±(5 ns + 0.01%) | N/A
定时器重置延时： | 60 ns | N/A
* 标有星号 (*) 的项为规格。其他所有项均为特性。“典型”表示基于大量单位测量的参数的平均值或中值。 1 被测系统中的最小眼宽度。 2 对于每个数据通道输入，可以分别调整采样位置。负采样位置将导致在每个活动时钟沿之前对输入进行该数量的同步采样。正采样位置将导致在每个活动时钟沿之后对输入进行该数量的同步采样。采样位置为零将导致在每个时钟沿处对输入进行同步采样。 3 在 500 Mb/s 状态模式下建议使用 eye finder。 4 在 250 Mb/s 状态模式下的所有盒均已分配时，内存深度是最大内存深度的一半。如果有一个盒对（34 个通道）未分配，则会获得全部内存深度。在 500 Mb/s 状态模式下，必须为时间标签保留一个未分配的盒对（34 个通道）。 5 独立分析仪可以是状态分析仪，也可以是定时分析仪。选择 500 Mb/s 状态模式时，只能使用一台分析仪。 6 在 250 Mb/s 状态模式下，时钟与限定符的总数为 4。所有时钟和限定符输入都必须在主模块中进行。 7 测试采用输入信号：Vh = 1.25 V，Vl = 0.75 V，阈值 = 1.0 V，tr/tf = 180 ps ±30 ps（10%、90%）。 8 除非保留一个未分配的盒对（34 个通道），否则将平分跳变时序速度和内存深度。

定时（异步）分析模式

 | 传统时序 | 跳变时序 8
所有通道的采样频率： | 500 MHz | 500 MHz
半通道模式下的采样频率： | 1000 MHz | N/A
通道数： | 16910A：102 x (卡数) | 16910A：对于小于 500 MHz 的采样频率：102 x (卡数)。 对于 500 MHz 的采样频率：102 x (卡数) - 34。
 | 16911A：68 x (卡数) | 16911A：对于小于 500 MHz 的采样频率：68 x (卡数)。 对于 500 MHz 的采样频率：68 x (卡数) - 34。
单时基和触发的最大通道数： | 16910A：510 16911A：340 | 16910A：510 16911A：340
独立分析仪数量 5： | 2 | 2
采样周期（半通道）： | 1.0 ns | N/A
采样周期（全通道）： | 2.0 ns | 2.0 ns
最小数据脉冲宽度： | 1 个采样周期 + 1.0 ns | 1 个采样周期 + 1.0 ns
时间间隔精度： | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%) | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%)
全通道模式下的内存深度： | 选项 256：256 K 选项 001：1 M 选项 004：4 M 选项 016：16 M 选项 032：32 M | 选项 256：256 K 选项 001：1 M 选项 004：4 M 选项 016：16 M 选项 032：32 M
半通道模式下的内存深度： | 选项 000：512 K 选项 001：2 M 选项 004：8 M 选项 016：32 M 选项 032：64 M | N/A
最大触发序列速度： | 250 MHz | 250 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 任意 4 路 if/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 3 个时钟沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 15 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 3 个时钟沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志
全局计数器最大值： | 2E+24 | 2E+24
发生计数器最大值： | 2E+24 | 2E+24
最大范围宽度： | 32 位 | 32 位
最大码型宽度： | 128 位 | 128 位
定时器值范围： | 60 ns 至 2199 s | 60 ns 至 2199 s
定时器分辨率： | 2 ns | 2 ns
定时器精度： | ±(5 ns + 0.01%) | ±(5 ns + 0.01%)
大于持续时间： | 4.0 ns 至 67 ms（增量为 4.0 ns） | 4.0 ns 至 67 ms（增量为 4.0 ns）
小于持续时间： | 8.0 ns 至 67 ms（增量为 4.0 ns） | 8.0 ns 至 67 ms（增量为 4.0 ns）
定时器重置延时： | 60 ns | 60 ns

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

环境特性

仅限于室内使用。

有关探头的环境特性，请参见特定探头的规格和特性。

  • 操作环境
  • 非操作环境

操作环境

温度： | 在 16900A 或 16902A 主机中操作时：0°C 至 40°C（+32°F 至 104°F） 在 16903A 主机中操作时：0°C 至 50°C（+32°F 至 122°F）
湿度： | 0 至 80% 相对湿度（40°C (+104°F) 下）。如果在下列范围内进行操作，将提高可靠性：20% 至 80%（非冷凝）。
海拔： | 0 至 3,000 m (10,000 ft)
振动： | 随机振动 5-500 Hz，每轴 10 min（约为 0.2 g rms）

非操作环境

温度： | -40°C 至 +75°C（-40°F 至 +167°F）。请保护仪器，避免其处于极端的温度环境中，以防止仪器上出现冷凝现象。
湿度： | 0 至 90% 相对湿度（65°C (149°F) 下）。
海拔： | 0 至 15,300 m (50,000 ft)
振动（在装运箱内）： | 随机振动 5 至 500 Hz，每轴 10 min（约为 2.41 g rms）；扫频正弦共振搜索 5 至 500 Hz，0.50 g（限定符为 0），每轴 4 次共振时共振驻留为 5 min。

另请参见

  • 什么是规格
  • 什么是特性


16950 逻辑分析仪规格和特性

介绍 16950 逻辑分析仪的规格和特性。

注意：

标有星号 (*) 的项为规格。其他所有项均为特性。

“典型”表示基于大量单位测量的参数的平均值或中值。
  • 模块通道计数
  • 探头
  • 时序放大
  • 状态（同步）分析模式
  • 定时（异步）分析模式
  • 电源要求
  • 环境特性

模块通道计数

 | 状态分析 | 定时分析
1 卡模块： | 64 数据 + 4 时钟 | 68
2-卡模块： | 132 数据 + 4 时钟 | 136
3-卡模块： | 200 数据 + 4 时钟 | 204
4-卡模块： | 268 数据 + 4 时钟 | 272
5-卡模块： | 336 数据 + 4 时钟 | 340

探头

必须使用探头将逻辑分析仪连接到被测设备。有关特定探头的规格和特性，请参见随探头提供的文档，或在 www.agilent.com 上搜索探头的型号。

时序放大

定时分析采样频率： | 4 GHz
定时间隔精度： | 盒对内：±(750 ps + 时间间隔读数的 0.01%) 盒对间：±(1.5 ns + 时间间隔读数的 0.01%)
内存深度： | 64 K
触发位置： | 起点、中心、终点，或由用户定义
最小数据脉冲宽度： | 750 ps

状态（同步）分析模式

 | 300 Mb/s 状态模式 | 600 Mb/s 状态模式
tWidth*, 1, 2： | 1 ns*，600 ps（典型） | 1 ns*，600 ps（典型）
tSetup： | 0.5 tWidth | 0.5 tWidth
tHold： | 0.5 tWidth | 0.5 tWidth
tSample 范围 3： | -4 ns 至 +4 ns | -4 ns 至 +4 ns
tSample 调整分辨率： | 80 ps（典型） | 80 ps（典型）
tSample 精度（手动调整）： | ±300 ps | ±300 ps 4
每通道最大状态数据速率： | 300 Mb/s | 800 Mb/s
单时基和触发的最大通道数： 5 : | 340 - (时钟数) | 306 - (1 时钟)
内存深度 5： | 选项 256：采样 256 K 选项 001：采样 1 M 选项 004：采样 4 M 选项 016：采样 16 M 选项 032：采样 32 M 选项 064：采样 64 M | 选项 256：采样 256 K 选项 001：采样 1 M 选项 004：采样 4 M 选项 016：采样 16 M 选项 032：采样 32 M 选项 064：采样 64 M
独立分析仪数量 6： | 2 | 1
时钟数 7： | 4 | 1
时钟限定符数 7： | 4 | N/A
活动时钟沿之间的最小时间*, 8： | 3.33 ns | 1.67 ns
最小主-从时钟时间： | 1 ns | N/A
最小从-主时钟时间： | 1 ns | N/A
最小从-从时钟时间： | 3.33 ns | N/A
最小状态时钟脉冲宽度： | 单沿：1.0 ns 多沿：1.0 ns | 单沿：500 ps 多沿：1.67 ns
时钟限定符设置时间： | 500 ps | N/A
时钟限定符保持时间： | 0 | N/A
时间标签分辨率 5： | 2 ns | 1.5 ns
最大存储状态间计时： | 32 天 | 32 天
最大触发序列速度： | 300 MHz | 600 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 2 路 If/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 14 种码型（以 =、≠、>、>=、<、<= 进行计算） 7 种双边界范围（以 in range、not in range 进行计算） 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 存储/不存储样本 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发并写入内存
存储限定： | 默认（全局）并按顺序步骤 | 默认（全局）
全局计数器最大值： | 2E+24 | N/A
发生计数器最大值： | 2E+24 | 2E+24
最大码型宽度： | 128 位 | 128 位
最大范围宽度： | 32 位 | 32 位
定时器值范围： | 50 ns 至 2199 s | N/A
定时器分辨率： | 2 ns | N/A
定时器精度： | ±(5 ns + 0.01%) | N/A
定时器重置延时： | 50 ns | N/A
* 标有星号 (*) 的项为规格。其他所有项均为特性。“典型”表示基于大量单位测量的参数的平均值或中值。 1 被测系统中的最小眼宽度。 2 您对探头的选择将限制系统带宽。选择速率为 600 Mb/s 或更高的探头可保持系统带宽。 3 对于每个数据通道输入，可以分别调整采样位置。负采样位置将导致在每个活动时钟沿之前对输入进行该数量的同步采样。正采样位置将导致在每个活动时钟沿之后对输入进行该数量的同步采样。采样位置为零将导致在每个时钟沿处对输入进行同步采样。 4 在 600 Mb/s 状态模式下建议使用 eye finder。 5 在 300 Mb/s 状态模式下的所有盒均已分配时，内存深度是最大内存深度的一半。如果有一个盒对（34 个通道）未分配，则会获得全部内存深度。在 600 Mb/s 状态模式下，必须为时间标签保留一个未分配的盒对（34 个通道）。 6 独立分析仪可以是状态分析仪，也可以是定时分析仪。选择 600 Mb/s 状态模式时，只能使用一台分析仪。 7 在 300 Mb/s 状态模式下，时钟与限定符的总数为 4。所有时钟和限定符输入都必须在主模块中进行。 8 测试采用输入信号：Vh = 1.125 V，Vl = 0.875 V，阈值 = 1.0 V，tr/tf = 180 ps ±30 ps（10%、90%）。 9 除非保留一个未分配的盒对（34 个通道），否则将平分跳变时序速度和内存深度。

定时（异步）分析模式

 | 传统时序 | 跳变时序 9
所有通道的采样频率： | 600 MHz | 600 MHz
半通道模式下的采样频率： | 1200 MHz | N/A
通道数： | 68 x (卡数) | 对于小于 600 MHz 的采样频率：68 x (卡数)。 对于 600 MHz 的采样频率：68 x (卡数) - 34。
单时基和触发的最大通道数： | 340 | 340
独立分析仪数量 6： | 2 | 2
采样周期（半通道）： | 833 ps | N/A
采样周期（全通道）： | 1.67 ns | 1.67 ns
最小数据脉冲宽度： | 1 个采样周期 + 500 ps | 1 个采样周期 + 500 ps
时间间隔精度： | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%) | ±(1 个采样周期 + 1.25 ns + 时间间隔读数的 0.01%)
全通道模式下的内存深度： | 选项 256：256 K 选项 001：1 M 选项 004：4 M 选项 016：16 M 选项 032：32 M 选项 064：64 M | 选项 256：256 K 选项 001：1 M 选项 004：4 M 选项 016：16 M 选项 032：32 M 选项 064：64 M
半通道模式下的内存深度： | 选项 000：512 K 选项 001：2 M 选项 004：8 M 选项 016：32 M 选项 032：64 M 选项 064：128 M | N/A
最大触发序列速度： | 300 MHz | 300 MHz
最大触发序列步骤数： | 16 | 16
触发序列步骤分支： | 任意 4 路 if/then/else | 任意 4 路 if/then/else
触发位置： | 起点、中心、终点，或由用户定义 | 起点、中心、终点，或由用户定义
触发资源： | 16 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 3 个时钟沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志 | 15 种码型（以 =、≠、>、>=、<、<= 进行计算） 14 种双边界范围（以 in range、not in range 进行计算） 3 个时钟沿/假信号 每卡 2 个定时器 2 个全局计数器 每序列步骤 1 个发生计数器 4 个标志
触发资源条件： | 任意布尔组合 | 任意布尔组合
触发操作： | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志 | 转至 触发、发送电子邮件，并写入内存 触发并转至 打开/关闭默认存储 定时器启动/停止/暂停/继续 全局计数器增加/减少/重置 发生计数器重置 设置/清除标志
全局计数器最大值： | 2E+24 | 2E+24
发生计数器最大值： | 2E+24 | 2E+24
最大范围宽度： | 32 位 | 32 位
最大码型宽度： | 128 位 | 128 位
定时器值范围： | 50 ns 至 2199 s | 50 ns 至 2199 s
定时器分辨率： | 2 ns | 2 ns
定时器精度： | ±(5 ns + 0.01%) | ±(5 ns + 0.01%)
大于持续时间： | 3.33 ns 至 55 ms（增量为 3.3 ns） | 3.33 ns 至 55 ms（增量为 3.3 ns）
小于持续时间： | 6.67 ns 至 55 ms（增量为 3.3 ns） | 6.67 ns 至 55 ms（增量为 3.3 ns）
定时器重置延时： | 50 ns | 50 ns

电源要求

由逻辑分析系统主机的背板连接器提供所有必要电源。

环境特性

仅限于室内使用。

有关探头的环境特性，请参见特定探头的规格和特性。

  • 操作环境
  • 非操作环境

操作环境

温度： | 在 16900A 或 16902A 主机中操作时：0°C 至 40°C（+32°F 至 104°F） 在 16903A 主机中操作时：0°C 至 50°C（+32°F 至 122°F）
湿度： | 0 至 80% 相对湿度（40°C (+104°F) 下）。如果在下列范围内进行操作，将提高可靠性：20% 至 80%（非冷凝）。
海拔： | 0 至 3,000 m (10,000 ft)
振动： | 随机振动 5-500 Hz，每轴 10 min（约为 0.2 g rms）

非操作环境

温度： | -40°C 至 +75°C（-40°F 至 +167°F）。请保护仪器，避免其处于极端的温度环境中，以防止仪器上出现冷凝现象。
湿度： | 0 至 90% 相对湿度（65°C (149°F) 下）。
海拔： | 0 至 15,300 m (50,000 ft)
振动（在装运箱内）： | 随机振动 5 至 500 Hz，每轴 10 min（约为 2.41 g rms）；扫频正弦共振搜索 5 至 500 Hz，0.50 g（限定符为 0），每轴 4 次共振时共振驻留为 5 min。

另请参见

  • 什么是规格
  • 什么是特性


16900 系列逻辑分析系统机架特性

  • 一般信息
  • 操作环境特性

一般信息

电源：

16900A：最大 115/230 V，48 至 66 Hz，1300 W。

16902A：最大 115/230 V，48 至 66 Hz，1300 W。

16903A：最大 115/230 V，48 至 66 Hz，900 W。

尺寸：

16900A/16902A/16903A - 高 254 mm (9.99 in)，宽 442 mm (17.38 in)，深 559 mm (22.0 in)

重量：

 | 最大净重 | 最大装运重量
16900A： | 16 kg (35.2 lbs) | 24.6 kg (54.2 lbs)
16902A： | 17.2 kg (37.8 lbs) | 25.8 kg (56.8 lbs)
16903A： | 14.5 kg (32.0 lbs) | 23.2 kg (51.0 lbs)

* 逻辑分析仪或随主机订购的其他仪器卡将增重 0.9 kg（每块卡 2.0 lb）。

用户界面：

Windows® XP Professional

打印机：

可打印到任何 Windows® XP Professional 支持的本地或网络打印机。

操作环境特性

温度： | 16900A 和 16902A：0°C 至 40°C（32°F 至 104°F） 16903A：0°C 至 50°C（32°F 至 122°F）
湿度： | 8 至 80% 相对湿度（40°C (104°F) 下）。
海拔： | 3000 m (10,000 ft)

另请参见

  • 什么是规格
  • 什么是特性


什么是规格

规格是指界定产品参数性能的数值或值范围。产品质量保证书中包含使用规格描述的参数性能信息。出厂产品符合所有规格。另外，发送到 Agilent 客户服务中心进行校准后返回的产品也都符合所有规格。规格是通过校准过程 验证的。

什么是校准过程？

校准过程用于验证产品或系统是否在规格范围内运行。规格所涉及到的参数都有相应的校准过程。校准过程包括性能测试和系统验证过程。校准过程是可追踪的，并且必须指定适当的校准标准。

校准过程通过将测量参数与通过-失败界限进行比较来验证产品是否符合规格。“通过-失败”界限是指规格扣除允许的离差范围。

“校准”是指对参数进行测量并将测量结果提供给校准标准作为参考的过程，不是调整产品以获得最佳性能的过程。

注意：

自检不代表校准。

另请参见

  • 什么是特性


什么是特性？

特性用于描述产品性能，性能对于应用产品会有所帮助，但不在产品的担保范围内。特性描述的是特定产品的典型性能，但不遵循与规格关联的相同标准。特性通过功能测试 进行验证。

什么是功能测试？

功能测试是设计用于验证产品基本运行功能的快速测试。功能测试包括操作员检查和运行功能验证过程。操作员检查通常是用于验证产品基本运行功能的快速测试。运行功能验证过程用于验证某些（而非全部）规格，通常其可信度低于校准过程。

另请参见

  • 什么是规格


术语表

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

acquisition / 采集
是指测量模块收集数据的一个完整周期。例如，如果使用内存深度为 200K 的分析仪，则一个完整的采集周期将采集并在采集内存中存储 200K 容量的状态数据。
acquisition depth / 采集深度
采集深度是指在采集中用于填充数据的内存量。可选择的采集深度由当前使用的分析仪中允许的最大内存深度来确定。
action / 操作
操作是指分析仪在触发过程中作为触发的一部分所执行的处理，比如 Then Trigger and Fill Memory（然后触发并写入内存）或 Start Timer（启动定时器）。
activity indicator / 活动指示符
逻辑分析仪通道旁边的符号，指示信号是处于逻辑高电平、逻辑低电平，还是处于高低电平转换过程。
advanced trigger / 高级触发
高级触发所提供的功能要比简单触发多，但也更复杂。
analysis probe / 分析探头
连接到被测设备中的微处理器或标准总线的探头。分析探头在微处理器或标准总线的信号与逻辑分析仪的输入之间提供接口。
arming / 激活
通常，在选中“运行”或“重复运行”时，仪器会立即被激活 (arm)。例如，逻辑分析仪常用于激活示波器。
asynchronous sampling / 异步采样
逻辑分析仪以异步方式从被测设备采集样本，也就是以固定间隔（如每 100ns）进行采样。这也称为定时模式。

B

beginning of acquisition / 采集开始点
采集开始点是指开始收集数据的时点。
bit / 位
位是指总线中的单个信号。位是从 0 开始编号的。
bus / 总线
总线是指一组关联的信号，如 ADDR 或 DATA。

C

captured data / 采集的数据
逻辑分析仪采作样本并存储在其内存中的信号值。
card / 卡
可插入机架 插槽的逻辑分析仪。卡可与其他部件组合在一起，以增加单时域中可用的通道数。
channel / 通道
逻辑分析仪的单个输入线路。每个通道对应着一根与被测设备相连的引线。每个通道用于获取来自被测设备的一个信号，且仅获取一个信号。
clock channel / 时钟通道
可用于确定逻辑分析仪采样的特殊的逻辑分析仪输入通道。时钟通道在盒上以 CLK 标识。

D

data channel / 数据通道
传送数据的通道。不能使用数据通道对逻辑分析仪进行时钟计时。数据通道使用数字进行编号，而时钟通道则用 CLK 来标识。
default storage / 默认存储
默认存储的意思是“除非序列步骤存储进行了指定，否则这就是应存储的对象”。序列步骤存储总是会覆盖默认存储。
delay / 延迟
延迟是指屏幕上定时分析仪信号波形的水平位置。延迟时间是从触发点测量的，以秒计。
device under test / 被测设备
正在开发的系统，逻辑分析仪采集其数字信号。
don't care / 无关
“无关”的意思是信号状态（高或低）与测量无关。分析仪在确定输入总线/信号上是否出现匹配码型时会忽略此信号的状态。
double-click / 双击
使用鼠标作为指针设备时，所谓双击某一项目，就是将光标放置在该项目上，然后连续两次快速按下并释放鼠标左键的操作。
drag and drop / 拖放
将光标定位在项目上，然后按住鼠标左键。按住鼠标左键的同时移动鼠标，将项目拖到某一新位置。当项目到达所需位置时，放开鼠标左键。

E

edge / 沿
用于检测信号跳变的逻辑分析仪触发资源。可以将沿项设置为检测上升沿、下降沿、任一沿或假信号。
event / 事件
事件是指在被测设备中查找的事项，如 ADDR=0 或 ADDR=5。
external trigger / 外部触发
逻辑分析仪外部用于同步仪器间测量的信号。例如，可以通过来自另一台仪器的信号激活逻辑分析仪。逻辑分析仪常用于通过 BNC 连接来触发示波器。

F

frame / 机架
模块式逻辑分析系统，其背面有插槽，用于插入逻辑分析仪卡。可将多个机架连接在一起来形成一个多机架逻辑分析系统。

G

glitch / 假信号
当两个或多个跳变越过定时分析仪连续采样之间的逻辑阈值时便会出现假信号。

I

inverse assembler / 反汇编程序
用于显示所采集的机器代码的汇编语言指令的工具。

L

logic analyzer / 逻辑分析仪
采集和显示数字信号值的仪器。逻辑分析仪类似于示波器，不过它只显示两个电压电平（一个是逻辑高电平或 1，另一个是逻辑低电平或 0），而不是显示多个电压电平。逻辑分析仪只采集 1 和 0，因此，与需要采集移动电压详细信息的示波器相比，其采样频率相对要低。这也意味着，逻辑分析仪可采集的整体执行时间在量上要比示波器多。

M

macro / 宏
  • 在码型发生器模块中，宏类似于编程语言中的子例程；它们可以带有参数，并可以在矢量序列中多次调用，以生成重复的或相似的输出矢量。
  • 在 Microsoft Visual Basic for Applications (VBA) 中，宏属于子程序，可以通过用户界面运行它来自动控制应用程序。
  • 以前 Agilent 逻辑分析系统中的宏，或称触发宏，就是现在所说的触发函数：用于构建触发序列的预编程组件。
marker / 标记
数据显示中的浮动参考点。标记可用于测量时间间隔或采样间隔。为码型指定标记是为了在数据中查找码型或跟踪状态序列。
menu bar / 菜单栏
在所有窗口中，菜单栏位于窗口顶部。通过它可以选择包含工具或系统选项的下拉菜单。
module / 模块
由连接在一起的逻辑分析仪卡组成的逻辑集合。利用模块可以通过使用多个卡来灵活地增加通道数。一个模块可以是单卡或多卡模块，一个单卡或多卡模块也可以分成两个模块。根据定义，一个模块包含一个单时域。虽然模块可以由单个卡组成，但模块并不是物理实体。

O

occurrence / 发生
“发生”用于在触发中定义采集期间某情况的发生次数。
offline analysis / 脱机分析
在没有数据采集硬件的情况下分析以前采集和保存的逻辑分析数据。换句话说，可以在 Windows XP/2000 计算机上单独使用 Agilent Logic Analyzer 应用程序来分析波形、列表和比较窗口中的数据。

P

pattern / 码型
表示要在总线/信号上查找的单个状态的逻辑分析仪资源；如地址总线上的地址或状态行上的状态。
pod / 盒
卡中逻辑分析仪通道的物理集合。盒只相对于卡进行编号。盒用于将来自被测设备的数据和时钟信号物理连接到分析仪。
pod index / 盒索引
盒的逻辑编号。如果某模块有 20 个盒，则其盒索引是 1 至 20，在卡边界处不重新编号。在多卡模块中，编号从主卡开始，然后自下而上继续。使用盒索引时不必考虑每张卡上有多少个盒，也不必考虑这些卡位于哪些插槽中。
pod pair / 盒对
各包含 16 个数据通道和 1 个时钟通道的两个盒的组合。盒对用于将来自被测设备的数据和时钟信号物理连接到分析仪。在分析仪界面中盒是按对分配的。可用盒对的数量由仪器的通道宽度来决定。
pod truncation / 盒截断
如果打开的配置文件是从比当前模块包含更多盒的逻辑分析仪模块保存的，则会出现这种情况。由于当前模块的盒较少，因此会发生截断。分配给截断的盒的任何总线/信号都是不可用的。
point / 指向
要指向某一项目，请将鼠标光标移至该项目上。
polarity / 极性
当输入的低压以一个高电平波形和逻辑值 1 显示时为正极性。当输入的高压以一个低电平波形和逻辑值 0 显示时为负极性。极性会影响值和波形的显示，但不影响触发。
preprocessor / 预处理器
请参见分析探头。
probe / 探头（探测）
将逻辑分析系统的各种仪器连接到被测设备的器件。探头类型多种多样，具体使用哪一种取决于仪器和数据需求。探测的意思是将探头连接到被测设备。
protocol / 协议
用于在两个设备间传送数据的协定格式。协议确定：错误检测类型、数据压缩、编码方法、发送设备指示完成消息发送的方式以及接收设备指示收到消息的方式。

Q

quick trigger / 快速触发
使用快速触发可以在波形和列表显示中快速设置简单触发，方法是用鼠标在显示区画一个矩形。定义了简单触发并运行分析仪以后，触发便会被存储下来，并且可以随时调用。

R

range pattern / 范围码型
设置表示值范围（如“1000 至 2000 之间的 ADDR”）的码型时使用的逻辑分析仪资源。大多数逻辑分析仪都支持 not in range 运算符和 in range 运算符。范围码型是一种方便的快捷方式，可用于替代使用 AND（和）或 OR（或）连接码型的操作方式，如“ADDR >= 1000 和 ADDR <= 2000”。
repetitive measurement / 重复测量
在这种测量中，仪器搜索逻辑分析仪的触发条件并填充数据存储器的过程会重复进行。
right-click / 右键单击
使用鼠标作为指针设备时，所谓右键单击某一项目，就是将光标放置在该项目上，然后快速按下并放开鼠标右键。
run / 运行
单次运行测量会将采集的数据一次性地保存到跟踪内存。单次运行期间存储的数据量等于分配的跟踪内存量。
run repetitive / 重复运行
重复运行测量会将采集的数据重复保存到跟踪内存。重复运行中存储的数据量与单次运行中的相同。在重复运行期间，一旦跟踪内存被填满，系统就会清除跟踪内存，并开始重新填充新数据。只有运行停止，这一循环才会停止。

S

sample / 样本
数据样本是指单次测量结果。仪器对被测设备进行采样时，它会在数据采集周期内进行单次测量。采集的样本数等于逻辑分析仪的内存深度。
sample period / 采样周期
采样周期是指采样间隔时间。采样周期可以基于内部采样时钟（也称为定时分析或异步采样）。也可以基于被测设备中的信号（也称为状态分析或同步采样）。
sampled data / 采样数据
逻辑分析仪采作样本的信号值（不一定保存）。
sampling / 采样
逻辑分析仪采集数字信号的过程。
search / 搜索
在采集的数据中搜索指定的数据码型或数据值、时间值、样本号或标记。搜索条件可以小到特定的位，大到多个事件，具体取决于所选的搜索选项。
simple trigger / 简单触发
简单触发包括沿码型触发和总线码型触发等。
single measurement / 单次测量
在这种测量中，只进行一次逻辑分析仪触发条件的搜索和数据存储器填充。
skew / 偏移
偏移是指测量通道间通道延迟之差。
slot / 插槽
机架背面可插入卡的槽。这些插槽分别用 A 到 F 字母标注，插槽 A 位于最上面。插槽属于物理实体，始终通过插槽字母来引用。
snap to edge markers / 对齐沿标记
通过对齐沿标记可以将标记轻松放到波形沿上。在数据显示区移动标记时，光标会变成绿色的“方向箭头”，指示下一个有效沿的方向。在要放置标记的下一个沿上会出现一个红色的“有效沿”条。
state analyzer / 状态分析仪
基于被测设备中的时钟信号进行采样的逻辑分析仪。
state measurement / 状态测量
在状态测量中，逻辑分析仪根据来自被测系统的信号进行时钟计时。每当时钟信号有效时，分析仪就会从被测系统采集数据样本。由于分析仪是通过被测系统进行时钟计时，因此状态测量与被测系统是同步的。
state mode / 状态模式
逻辑分析仪以同步方式从被测设备采样，也就是由来自被测设备的信号指示何时进行采样。例如，当来自被测设备的信号出现上升沿时，逻辑分析仪可能会进行采样。用于设置采样的信号通常是状态机器时钟信号或微处理器时钟信号。这也称为同步采样。
stop / 停止
停止当前正在进行的测量。
storage qualification / 存储限定
存储限定只在状态测量中可用，在定时测量中是不可用的。通过存储限定可以指定要存储在内存中的数据的类型（全部样本、无样本或选择的状态）。使用存储限定可以防止内存中被填充不需要的活动数据，如等待循环。借助存储限定还可以在采样过程中滤除特定类型的数据，这样可以节省内存。而过滤器则可以将收集到的数据隐藏起来。
symbols / 符号
分配给特定总线或信号值的名称。在显示采集的数据值时使用符号会易于理解。此外，使用符号可以轻松设置基于特定值的触发。例如，在某一通信协议中，值 FF 可能会显示为“end of file”。
synchronous sampling / 同步采样
逻辑分析仪以同步方式从被测设备采样，也就是由来自被测设备的信号指示何时进行采样。例如，当来自被测设备的信号出现上升沿时，逻辑分析仪可能会进行采样。用于设置采样的信号通常是状态机器时钟信号或微处理器时钟信号。这也称为状态模式。

T

target system / 目标系统
请参见被测设备。
threshold voltage / 阈电压
电压电平，信号必须越过该电平逻辑分析仪才能检测到电压电平的变化。高压电平用“1”表示，低压电平用“0”表示。TTL 和 ECL 是信号必须越过的电压电平的两个例子。
time/division / 时间/段
“时间/段”控制波形的“缩放”显示。增大“时间/段”会缩小显示，减小“时间/段”会放大显示。
timer / 定时器
定时器用于创建用户定义的延迟，或创建用于计算有效数据持续时间的时间标准。
timing analyzer / 定时分析仪
基于内部时钟信号以固定间隔进行采样的逻辑分析仪。
timing measurement / 定时测量
在定时测量中，逻辑分析仪根据定时分析仪内部的时钟信号以固定间隔进行数据采样。由于分析仪是根据与被测设备无关的信号进行时钟计时的，因此定时测量会采集电子设备随时间变化的活动轨迹。这些测量与被测设备是异步的。
timing mode / 定时模式
逻辑分析仪以异步方式从被测设备采样，也就是以固定间隔（如每 100ns）进行采样。这也称为异步采样。
tool tip / 工具提示
在将鼠标悬停于某一波形或总线/信号名称之上、用鼠标移动标记，或用鼠标在数据中画矩形等操作过程中，所显示的小块信息（文本显示）。可在其中显示注释，或用其显示当前位置、波形跳变宽度或触发设定（当用鼠标设置快速触发时）。
trace / 跟踪
请参见采集。
transitional timing / 跳变时序
当逻辑分析仪处于跳变时序模式时，定时分析仪以固定间隔进行数据采样，但只有发生阈值电平跳变（高到低跳变或低到高跳变）时才存储数据。无论电平跳变发生在哪一位上，所有通道上的数据都会被存储。时间标记会和每一个存储的数据样本一起存储，因此以后可以重建和显示该测量。
trigger / 触发
针对该事件对采集的数据进行存储；也就是正在寻找的事件。例如，您可能需要基于某个沿进行触发，以便查看导致该沿的事件以及随后发生的事件。触发逻辑分析仪的事件会变成数据显示中的一个参考点。
trigger function / 触发函数
触发函数是用于构建触发序列的预编程组件。
trigger history / 触发历史记录
每当设置新触发并进行测量时，触发设置都会保存在配置文件中。可以对保存的各个触发进行检索和重用。默认情况下保存 10 个触发。
trigger position / 触发位置
触发事件在跟踪内存中的位置。若要在触发事件发生后、发生时或发生前查看数据，请将触发位置分别设置为跟踪内存的开头、中间或末尾。
trigger sequence / 触发序列
触发序列是用户指定的一系列事件。逻辑分析仪会将此序列与它正在收集的样本进行比较，以确定何时启动触发。

V

value at measurement / 定点值测量
定点值测量用于测量总线或单个信号在数据中某一指定标记位置的值。测量结果在标记测量显示栏中显示。

Z

zooming / 缩放
通过更改“时间/段”域中的值，使波形沿时间轴伸展或收缩。通过此操作可以查看特定波形的特定部分。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

另请参见

  • Agilent Logic Analyzer 与 16700 的术语对照


Agilent Logic Analyzer 与 16700 的术语对照

如果您熟悉 16700 系列逻辑分析系统，请注意 Agilent Logic Analyzer 应用程序中的以下一些术语有所不同：

16700 术语 | Agilent Logic Analyzer 术语
标签 | 总线或信号
工作区 | Overview（概览）窗口
机器 | 分析仪、模块和拆分分析仪
IMB | 准备触发（Advanced Trigger（高级触发）对话框）
源代码相关工具组 | Source（源代码）窗口
Compare（比较）工具 | Compare（比较）窗口
触发电平 | 触发步骤
触发宏 | 触发函数
Config | 盒分配
调用 | 打开
Filter（过滤）工具 | Filter/Colorize（过滤/着色）工具
Chart（图表）工具， Chart display（图表显示）工具， Chart（图表）窗口， 图表模式 | 以图表形式查看波形总线数据，或在 VbaView 窗口中查看图表数据

另请参见

  • Quick Start for 16700-Series Users