外部示波器时间相关性和数据显示

Add External Oscilloscope（添加外部示波器）向导使设置外部示波器和逻辑分析仪到交叉触发的流程自动化和简单化，并执行时间相关性测量（使用标记）。您也可以在逻辑分析仪显示窗口内显示示波器采集的数据。

外部示波器通过下列示波器关联工作，通过 LAN 设置远程控制：

  • Agilent Infiniium 548xx 系列示波器。
  • Agilent Infiniium 548xx 系列示波器。
  • Agilent 6000 系列示波器。

Add External Oscilloscope（添加外部示波器）向导能够为使用的逻辑分析仪和示波器类型提供默认（典型）校直值。您也可以使用 E5850A 时间相关夹具执行校正过程，校正过程为正在使用的实际仪器提供了最精确的校直值。有关获取 E5850A 时间相关夹具的更多信息，请联系您最近的 Agilent Technologies 销售处。

注意：

E5850A 时间相关夹具框上的操作说明仅适用于 16700 系列逻辑分析系统。对于 16900 系列逻辑分析系统或 1680/90 系列逻辑分析仪，请遵循本联机帮助中的操作说明。
  • 外部示波器时间相关性和数据显示入门
    • 步骤 1. 将示波器和逻辑分析仪联网
    • 步骤 2. 运行 Add External Oscilloscope（添加外部示波器）向导
    • 步骤 3. 进行测量
  • 使用标记
  • 显示导入的示波器数据
  • 通过 Web 控制外部示波器
  • 载入和保存配置
  • Changing External Oscilloscope Setup（更改外部示波器设置）选项
  • 删除外部示波器
  • 故障排除
    • 查找外部示波器 IP 地址
    • LAN（局域网）问题
    • 一般触发问题
    • 意外的或不一致的结果
  • 参考
    • External Oscilloscope Setup（外部示波器设置）对话框
  • 概念
    • 触发校直
    • 校正过程工作方法
    • 不确定
    • 偏移数字意味着什么？
  • 外部示波器模块控制，COM 自动控制
  • 外部示波器模块设置，XML 格式

© Agilent Technologies, Inc. 2001-2005


外部示波器时间相关性和数据显示入门

外部示波器时间相关性和数据显示的软件内置在 Agilent Logic Analyzer 应用程序中。

外部示波器和逻辑分析仪联网以后，Add External Oscilloscope（添加外部示波器）向导引导您完成连接逻辑分析仪到示波器的过程。连接过程结束后便可以进行测量。

  • 步骤 1. 将示波器和逻辑分析仪联网
  • 步骤 2. 运行 Add External Oscilloscope（添加外部示波器）向导
  • 步骤 3. 进行测量


步骤 1. 将示波器和逻辑分析仪联网

外部示波器时间相关性和数据显示入门

步骤 1. 将网络示波器和逻辑分析仪联网

注意：

如果您的逻辑分析仪和外部示波器都已经连接到局域网，您可以跳过此步骤。

注意：

使用 6000 系列示波器时，必须选择 LAN（局域网）端口作为 I/O 控制器。（按 Utility（实用工具）按钮，然后按 I/O（输入/输出）软键，使用 Entry knob 选择 LAN（局域网），然后按 Controller（控制器）软键。）

如果您的逻辑分析仪和外部示波器尚未连接到局域网，简单的点对点连接可能是仪器之间最方便的连接（请参见使用点对点网络）。

如果您不想使用点对点连接，请参考逻辑分析仪或外部示波器操作系统操作说明设置网络上的仪器。


使用点对点网络

要在逻辑分析仪和示波器之间设置点对点连接，使用交叉线（蓝色，E5850A 时间相关夹具随附的）连接仪器。

  1. 将交叉线的一端连接到逻辑分析仪上的网络接口，另外一端连接到示波器上的网络接口。

  2. 配置示波器上的联网软件（请参见示波器点对点网络设置）。

  3. 在逻辑分析仪上配置联网软件（请参见逻辑分析仪点对点网络设置）。


示波器点对点网络设置

  1. 请确认在示波器上已启用联网。

  2. 将示波器的 IP 地址设置为 192.0.2.231。

  3. 将子网掩码设置为 255.255.255.0。

  4. 如果有 WINS 解析选项，请禁用该选项。

  5. 移除任何已安装的网关。

  6. 如果有 DNS 选项，请禁用该选项。

  7. 在 6000 系列示波器上，选择 LAN 端口作为 I/O 控制器：

    1. 按 Utility（实用工具）按钮。
    2. 按 I/O（输入/输出）软键。
    3. 使用 Entry knob 选择 LAN 局域网。
    4. 按 Controller（控制器）软键。

另请参见

  • 逻辑分析仪点对点网络设置


逻辑分析仪点对点网络设置

  1. 从 Start（开始）菜单，选择 Setting（设置）> Network and Dial-up Connection（网络和拨号连接）。

  2. 右键单击 Local Area Connection（本地区域连接）并选择 Properties（属性）。

  3. 确保已经安装了 TCP/IP 组件，然后选择 Properties（属性）。

  4. 在 Properties（属性）对话框中设置 IP 地址和“子网掩码”。

    1. 将 IP 地址设置为 192.0.2.232。

    2. 将子网掩码设置为 255.255.255.0。

  5. 选择 Advanced（高级）选项卡。

    1. 在 IP Settings（IP 设置）选项卡中，删除任何安装的网关。

    2. 在 DNS 选项卡中，删除清单中的所有 DNS 地址。

    3. 在 WINS 选项卡中，删除清单中的所有 WINS 地址。

  6. 如果提示继续下一步，请关闭此对话框单击 Yes（是）。

另请参见

  • 示波器点对点网络设置
  • 步骤 2. 运行 Add External Oscilloscope（添加外部示波器）向导


步骤 2. 运行 Add External Oscilloscope（添加外部示波器）向导

有关设置逻辑分析仪和示波器的连接的分步说明，请运行 Add External Oscilloscope（添加外部示波器）向导：

  1. 从菜单栏，选择 Setup（设置）>Add External Scope（添加外部示波器）...。

  2. 按照向导中的说明执行操作。

注意：

一般情况下，外部示波器模块仅随完整的逻辑分析仪模块交叉触发。分割逻辑分析仪模块不会出现在可选交叉触发的模块列表里。

另请参见

  • 附加连接信息
  • 删除外部示波器
  • 查找外部示波器 IP 地址


附加连接信息

  • 连接局域网
  • 连接 BNC 线缆
  • 将示波器探头连接到时间相关夹具
  • 将逻辑分析仪连接到时间相关夹具
  • 将供给电源连接到时间相关夹具

连接局域网

外部示波器模块使用介于示波器和 1680/90 系列的逻辑分析仪或 16900 系列逻辑分析系统之间的网络连接，以产生裁剪采集的测量和导入示波器数据。仪器必须连接到局域网 (LAN) 或者使用交叉线（E5850A 时间相关夹具随附的）连接到点对点网络。

注意：

使用 6000 系列示波器时，局域网端口必须选择为 I/O 控制器。（按 Utility（实用工具）按钮，然后按 I/O（输入/输出）软键，使用 Entry knob 选择 LAN（局域网），然后按 Controller（控制器）软键。）

您只能连接一个示波器到逻辑分析系统进行时间相关性测量。逻辑分析系统不支持同时连接两个或多个示波器。

连接 BNC 线缆

BNC 线缆连接取决于您拥有的外部示波器的型号。

有关连接 BNC 的说明，请参阅 Add External Oscilloscope（添加外部示波器）向导。

将示波器探头连接到时间相关夹具

注意：

校正过程时使用的探头与测试时对设备进行测量使用的探头要相同，这一点是非常重要的。这样最有可能提高校直准确度。所有连接必须包括接地连接。

将外部示波器通道 1 探头连接到 E5850A 时间相关夹具前面标有 CAL 的任何一个点上。任何标有 CAL 的点等同于任何其它标有的点。

  • 如果您使用微分探头，您必须 将 (+) 探头终端连接到 CAL 终端，将 (-) 探头终端连接到时间相关夹具的 GND 连接。

  • 如果您正在使用钩式探头，将钩式探头连接到时间相关夹具的 CAL 终端。然后连接地线。

  • 如果您正在使用双缆探头，将双缆探头连接到时间相关夹具。然后连接地线。

  • 如果您正在使用光敏探头，将光敏探头连接到时间相关夹具的 CAL 终端。

将逻辑分析仪连接到时间相关夹具

注意：

校正过程时使用的探头与测试时对设备进行测量使用的探头要相同，这一点是非常重要的。这样最有可能提高校直准确度。所有连接必须包括接地连接。

连接到时间相关夹具上的 CAL 信号的方式有三种：

  • 使用飞线。
  • 使用高密度连接器（MICTOR 或 Samtec）。
  • 使用钩式探头。

飞线（插口探头)

将您正在使用逻辑分析仪的盒 2，通道 0 连接到 E5850A 时间相关夹具前面标有 CAL 的任何一个点上。如果您正在使用多卡片逻辑分析仪，请使用主卡片的盒 2。包括接地连接。

高密度连接器

如果您正在使用 MICTOR 连接器对设备进行测试，请使用时间相关夹具顶部的 MICTOR 插座（包括 CAL 连接）。请确保将逻辑分析仪的盒 2 连接到 MICTOR 高密度适配器线缆的平插头。您可以使用终结的或未终结的高密度适配器线缆。

如果您正在使用 Samtec 连接器对设备进行测试，请使用时间相关夹具顶部的 Samtec 插座（包括 CAL 连接）。

钩式探头

如果您正在使用钩式探头对设备进行测试，请将钩式探头连接到标有 CAL 的终端。请确保包括接地连接。

将供给电源连接到时间相关夹具

按照 Add External Oscilloscope（添加外部示波器向导）中所示将电源连接到时间相关夹具。

警告：

电击危险。只能使用 0950-2546 电源和电源线。

小心：

设备损坏。只能使用 0950-2546 电源和电源线。

当正在执行时间相关的测量时，BNC 线缆和电源必须保持与时间相关夹具的连接。仅在校正过程需要连接探头。

注意：

请记住偏移受线缆长度、探头类型、和仪器本身影响。如果这些方面有任何更改，您需要重新执行校正过程。要重新执行校正过程，选择 Setup（设置）>(External Oscilloscope)（外部示波器）>Trigger（触发）...，然后在 External Oscilloscope Setup（外部示波器设置）对话框中的 Trigger（触发）选项卡，单击 Run Auto-Deskew（运行自动校直）...。


步骤 3. 进行测量

校正完成以后您可以使用如下测量进行下一步操作：

  1. 如果您使用 E5850A 时间相关夹具校正校直值，请从时间相关夹具断开外部示波器探头和逻辑分析仪的引线。

  2. 将示波器探头和逻辑分析仪引线连接到测试设备。

    请不要断开 BNC 电缆。

  3. 设置触发条件。

  4. 按逻辑分析仪前面板上的 Run（运行）按钮。

  5. 选择 Waveform（波形）选项卡查看测量结果。

逻辑分析仪触发外部示波器

当已经为 Logic Analyzer triggers External Oscilloscope（逻辑分析仪触发外部示波器）配置了软件时，您可以在逻辑分析仪设置所需的任何触发条件。但是请不要更改示波器的触发设置。

外部示波器触发逻辑分析仪

当已经为 External Oscilloscope triggers Logic Analyzer（外部示波器触发逻辑分析仪）配置了软件时，您可以在示波器设置所需的任何触发条件。但是请不要更改逻辑分析仪的触发设置。

另请参见

  • 使用标记
  • 一般触发问题


使用标记

标记位移

在逻辑分析仪和示波器之间标记位移是并列的。考虑到测量的偏移，标记与触发在时间上相对并列。

在逻辑分析仪中，标记（称为 Ax（外部示波器）和 Bx（外部示波器））在所有从给定的运行中显示测量的显示窗口之间是时间相关的，。在示波器上，有两个 X 轴（时间）标记称为 Ax 和 Bx。标记位移在 Ax（外部示波器）与 Ax 之间和 Bx（外部示波器）与 Bx 之间是并列的。并列于 Ax（外部示波器) 与 Bx 之间或 Bx（外部示波器）与 Ax 之间的选项不可用。

并列的标记位移对于快速识别单台逻辑分析仪和示波器显示中跟踪的给定点是非常有用的。Ax（外部示波器）和 Bx（外部示波器）标记的标记属性可以通过 Markers（标记）菜单访问。

示波器标记

Ax 遵循逻辑分析仪的 Ax（外部示波器）

在逻辑分析仪波形显示中移动 Ax（外部示波器）标记时，向示波器发送一条命令以在相同的点及时定位 Ax 标记。

Bx 遵循逻辑分析仪的 Bx（外部示波器）

在逻辑分析仪波形显示中移动 Bx（外部示波器）标记时，向示波器发送一条命令以在相同的点及时定位 Bx 标记。

逻辑分析仪标记

Ax（外部示波器）遵循示波器的 Ax

在示波器中移动 Ax 标记时，逻辑分析仪波形显示中的 Ax（外部示波器）标记及时被移动到相同点。

Bx（外部示波器）遵循示波器的 Bx

在示波器移动 Bx 标记时，逻辑分析仪波形显示中的 Bx（外部示波器）标记及时被移动到相同点。


显示导入的示波器数据

运行 Add External Oscilloscope（添加外部示波器）向导后，外部示波器模块将显示在 Overview（概述）窗口中，显示已连接到新的“波形”窗口。

将导入的示波器数据和逻辑分析仪数据一起显示

要在同一“波形”（或“列表”）窗口中显示导入的示波器数据和采集的逻辑分析仪数据，您可以连接到一个现有的显示窗口：

  1. 单击外部示波器的下拉菜单按钮，选择合适的命令。

    连接到现有窗口之后，示波器采集的数据将显示在该窗口中。例如：

更改导入的示波器数据选项

  1. 单击外部示波器模块的 [image] 选项按钮。

  2. 在 External Oscilloscope Setup（外部示波器设置）对话框的 Channels（通道）选项卡中，您可以：

    • 选择您想导入其数据的示波器通道。
    • 更改示波器通道信号名称。
    • 更改示波器通道信号颜色。
    • 指定其他外部示波器设置选项。

  3. 当您更改完导入的数据选项以后，单击 OK（确定）关闭 External Oscilloscope Setup（外部示波器设置）对话框。


通过 Web 控制外部示波器

External Scope Web Control VbaView 窗口是在外部示波器模块的 Web 接口指出的内嵌 Internet Explorer 窗口。

注意：

External Scope Web Control（外部示波器 Web 控制）窗口与提供 Web 控制接口的外部示波器模块一起工作。当前情况下，这些是 Agilent Infiniium 548xx 系列和 DSO80000 系列示波器。

另请注意，使用示波器 Web 控制接口时示波器性能会降低，我们建议仅临时连接到示波器 Web 控制接口以设置示波器触发等，然后使用外部示波器模块的数据导入功能（请参见显示导入的示波器数据）查看示波器采集的波形。

请确保当外部示波器模块的自动校直校正运行时，示波器的 Web 控制接口已断开。

要使用 External Scope Web Control（外部示波器 Web 控制）窗口，请执行以下操作：

  1. 请确保示波器启用了 Web 控制功能。

  2. 添加完外部示波器（请参见步骤 2. 运行 Add External Oscilloscope（添加外部示波器）向导）以后，选择 Window（窗口）> New VbaView（新建 VbaView）> External Scope Web Control（外部示波器 Web 控制）...。

  3. 在 Add New Window After（在此位置后添加新窗口）对话框，选择外部示波器模块，然后单击 OK（确定）。

  4. 在 External Scope Web Control（外部示波器 Web 控制）窗口，单击 Web Control（Web 控制）导航栏以通过其 Web 接口控制示波器。

    注意：

    如果您无法看到显示内容（例如，如果安装了已移除 Java 虚拟机（JVM）的更新版本 Internet Explorer 或 Windows Service Pack），则需要下载 JVM 来启用 Web 控制功能。例如，您可以从 www.java.com 免费下载 Sun 的 Java 虚拟机。

根据特定示波器的不同，External Scope Web Control（外部示波器 Web 控制）窗口外观如下：


载入和保存配置

当保存包含外部示波器模块的配置时，上次偏移运行与外部示波器的主机名称一同保存。示波器设置（和数据，如果您选择了）也将保存在逻辑分析仪的配置文件中。

当稍后载入配置时，逻辑分析系统将自动连接到外部示波器并恢复保存的设置。如果载入配置时示波器在网络上不可用，则此自动连接和设置将会失败。

如果外部示波器是一个共享资源并可能被移至另外一个位置，则此选项将产生意外影响。如果示波器在网络上有相同的“主机名”或 IP 地址，则将保存的配置载入那个示波器，可能更改其他用户创建的设置。

注意：

如果两个逻辑分析仪试图连接到单个示波器，将显示错误消息表示示波器被另外一个用户锁定。

另请参见

  • 保存配置文件
  • 打开配置文件
  • ALA 与 XML 的各自使用场合


更改外部示波器设置选项

  1. 从 Setup（设置）> (External Oscilloscope)（外部示波器）菜单中选择命令之一。

    当下列选项卡被选中时 External Oscilloscope Setup（外部示波器设置）对话框被打开：

    Channels（通道）选项卡

    Channels（通道）选项卡可以使您选择导出数据的示波器通道，并使您指定其他外部示波器设置。

    Trigger（触发）选项卡

    用作触发方向和运行触发校直。

    Connection（连接）选项卡

    显示示波器的名称或 IP 地址、型号和序列号。

  2. 作出需要的更改。

  3. 单击 OK（确定）。


删除外部示波器

要删除外部示波器，请执行以下操作：

  1. 从菜单栏选择 Setup（设置）> (External Oscilloscope)（外部示波器）> Delete（删除）。

另请参见

  • 入门，步骤 2：运行 Add External Oscilloscope（添加外部示波器）向导


外部示波器故障排除

常见故障排除

  • 查找外部示波器 IP 地址
  • LAN（局域网）问题
  • 一般触发问题
  • 意外的或不一致的结果


查找外部示波器 IP 地址

外部示波器时间相关性和数据显示软件要求外部示波器的 IP 地址。要找到外部示波器的 IP 地址，请执行以下操作：

  • 在 Agilent Infiniium 示波器上, 选择 Utilities->GPIB Setup（实用工具 -> GPIB 设置）...。

    IP 地址显示在窗口的 LAN Interface（LAN 接口）部分。忽视括号和文字，仅使用数字（如 130.29.68.220）。在 Add External Oscilloscope（添加外部示波器）向导中使用字符串。

  • 在 Agilent 6000 系列示波器上，按下前面板 Utilities（实用工具）按钮，然后按下 I/O（输入/输出）软键。

    IP 地址便显示在出现的 I/O 配置信息框的 LAN 部分内。在 Add External Oscilloscope（添加外部示波器）向导中使用 IP 地址字符串。

如果未正确输入此字符串，或者如果其他用户更改了外部示波器的 IP 地址，逻辑分析仪将无法与示波器通讯。如果字符串恰巧对应网络上的另一台示波器，逻辑分析仪可能会找到和连接到此示波器，给出您正确连接的显示，但实际上不是。

如果您输入的字符串不对应网络上的任何设备，则软件可能会显示为挂起几分钟以搜索设备。仅支持从逻辑分析仪到给定示波器的连接。


LAN（局域网）问题

如果您看见 LAN（局域网）错误信息：

  • 如果使用 6000 系列示波器, 请确保选择 LAN（局域网）端口作为 I/O 控制器。（按 Utility（实用工具）按钮，然后按 I/O（输入/输出）软键，使用 Entry knob 选择 LAN（局域网），然后按 Controller（控制器）软键。）

  • 检查外部示波器和逻辑分析系统的局域网连接。

  • 请与局域网管理员确认，确保局域网当前运行正常。在 External Oscilloscope Setup（外部示波器设置）对话框的 Connection（连接）选项卡，确保输入了正确的 IP 地址。

  • 如果已经报告了错误，请要求您的局域网管理员帮助您建立逻辑分析仪和示波器之间的网络。打开并关闭两台仪器的电源。

  • 如果问题仍然存在，请联系 Agilent Technologies 获得技术支持。

只有一个逻辑分析系统可通过 LAN（局域网）连接到外部示波器

如果两个逻辑分析系统试图连接到单个示波器，将显示错误消息表示示波器被另外一个用户锁定。不支持从一个逻辑分析系统连接到多台外部示波器。

另请参见

  • 查找外部示波器 IP 地址


一般触发问题

  • 逻辑分析仪触发外部示波器
  • 外部示波器触发逻辑分析仪
  • 为什么预期的地方不是红色触发标记？
  • 检查电缆连接
  • 检查探头连接
  • 使用接地
  • 外部示波器必须处于正确的模式
  • 确保没有其他人使用外部示波器

逻辑分析仪触发外部示波器

当选中 Logic Analyzer triggers External Oscilloscope（逻辑分析仪触发外部示波器）时，将示波器配置为在 1 伏特下 Aux Trig In 的上升沿触发。 如果您手动更改示波器触发，在下次运行逻辑分析仪时逻辑分析系统会将示波器的触发条件自动恢复为在 1 伏特下 Aux Trig In 的上升沿触发。您可以在逻辑分析仪设置任何所需的触发条件，因为您正在使用该条件触发示波器。

外部示波器触发逻辑分析仪

当选择 External Oscilloscope triggers Logic Analyzer（外部示波器触发逻辑分析仪）以后，将逻辑分析仪配置为触发一个外部 Trigger In。如果您手动更改逻辑分析仪触发，您可能无法改正时间相关性仪器。您可以在示波器设置任何所需的触发条件，因为您正在使用该条件触发逻辑分析仪。

为什么预期的地方不是红色触发标记？

无论何时使用外部示波器模块，表示您正在执行多仪器测量。每个仪器的测试都与时间相关，但每个仪器都保留了其实际触发点。

检查电缆连接

无论何时使用时间相关性功能时，BNC 线缆必须连接在逻辑分析仪、时间相关夹具和示波器之间。

检查探头连接

请确保您正在使用正确的逻辑分析仪电缆。跟踪从逻辑分析仪到 E5850A 时间相关夹具或测试设备之间的电缆。

请确保您正在使用正确的示波器探头。按照连接检查从仪器到 E5850A 时间相关夹具或测试设备的探头连接。

使用接地

与时间相关夹具前面的连接必须包括接地。例如，您应将示波器探头接地夹连接到 E5850A 时间相关夹具上的接地终端。每个逻辑分析仪盒的引线接地，并且每个逻辑分析仪通道也应连接到 E5850A 夹具上的接地终端则更好。

外部示波器必须处于正确的模式

请注意，只有 Single Sweep（单清除）、Real Time（实时）采集可与逻辑分析仪有意关联。如果示波器设置为在 Equivalent Time（相同时间）内采样，或者如果示波器清除被设置为 Sweep（清除）或 Triggered Sweep（触发清除），则不可能有意关联。

确保没有其他人使用外部示波器

如果其他用户正在使用外部示波器，无论从前面板还是通过局域网，逻辑分析系统将无法正确控制示波器。


意外的或不一致的结果

如果您遇到一个未知的或不一致的校直结果，请检查下列项目。

  • 检查电缆连接
  • 检查探头连接
  • 外部示波器必须处于正确的模式
  • 确保没有其他人使用外部示波器


外部示波器参考

  • External Oscilloscope Setup（外部示波器设置）对话框


External Oscilloscope Setup（外部示波器设置）对话框

  • Channels（通道）选项卡
  • Trigger（触发）选项卡
  • Connection（连接）选项卡


Channels（通道）选项卡

利用 Channels（通道）选项卡可以选择导出数据的示波器通道并指定其他外部示波器设置选项。

导入通道

使您选择导入数据的示波器、重命名示波器通道信号并更改与通道数据有关的颜色。

将模拟信号插入到“波形”显示窗口时使用与通道有关的颜色。在此对话框中更改通道的颜色不会影响到当前显示的波形的颜色。

使用配置保存外部示波设置

指定保存逻辑分析仪配置文件时是否将外部示波器配置设置与时间相关设置一同保存。当启用和载入逻辑分析仪配置文件时，逻辑分析系统将尝试重新载入较早保存的外部示波器设置。

注意：

Agilent Logic Analyzer 应用程序不会从一个示波器型号中将外部示波器设置载入另一个示波器型号中。例如，Infiniium 54810A 示波器的设置将不会载入到一个 Infiniium 54831B 示波器中。

限制导入到 N 个示例

用于限制要导入的示波器数据样本数。

另请参见

  • Connection（连接）选项卡
  • Trigger（触发）选项卡
  • 载入和保存配置


Trigger（触发）选项卡

Trigger（触发）选项卡用于设置触发方向和运行触发校直。

触发方向

Logic Analyzer triggers External Oscilloscope（逻辑分析仪触发外部示波器）选项设置逻辑分析仪和示波器，以便当逻辑分析仪生成触发信号时，示波器通过它的 Aux Trig In/Ext Trig 通道接收信号，并开始采集数据。您必须手动设置逻辑分析仪触发。

External Oscilloscope triggers Logic Analyzer（外部示波器触发逻辑分析仪）选项设置逻辑分析仪和示波器，以便当示波器生成触发信号时，逻辑分析仪通过它的 Trigger In 端口接收信号，并开始采集数据。您必须手动设置示波器触发。

选择 Analyzer（分析仪）可以使您使用外部示波器为时间相关性选择合适的逻辑分析仪模块.

注意：

一般情况下，外部示波器模块仅通过未拆分的逻辑分析仪模块交叉触发。拆分逻辑分析仪模块不会出现在可选交叉触发的模块列表里。

触发校直

Automatic（自动）选项指定使用默认校直值还是校正过程确定的校直值。自动校直提供两个单独校直值，每个触发方向都有一个值。要重新运行自动校直，请单击 Run Auto-Deskew（运行自动校直）...。

注意：

请确保当运行自动校直校正过程前，外部示波器的 Web 控制接口已断开。

注意：

校直值因触发方向不同而异。

Manual（手动）选项可以使您在提供的数字字段输入一个校直值。输入的校直值用在两个触发方向（即，手动校直模式不维护每个触发方向的独立的值）。

注意：

当选择 Automatic（自动）校直时，校直值复原到上次校正过程中获得的值。

另请参见

  • Connection（连接）选项卡
  • Channels（通道）选项卡


Connection（连接）选项卡

Connection（连接）外部示波器的名称或 IP 地址、型号和序列号。如果示波器连接断开，您可以通过 Connection（连接）选项卡单击 Reconnect（重新连接）进行重新连接。

另请参见

  • Channels（通道）选项卡
  • Trigger（触发）选项卡
  • 查找外部示波器 IP 地址


外部示波器概念

下列信息帮助解释了外部示波器连接是如何工作的。

  • 触发校直
  • 校正过程工作方法
  • 不确定
  • 偏移数字意味着什么？


触发校直

添加外部示波器或运行自动校直时，触发校直值可以通过如下方式获得：

  • 使用默认校正值 — 在这种情况下，逻辑分析仪和示波器使用默认（典型）值。这对于多数用户已经可以满足。

  • 使用上一校正值 — 这适用于执行了一次校正过程，并且硬件设置（仪器、探头、线缆）没有改变时。使用上一值。

  • 执行校正过程（需要 E5850A 时间相关夹具） — 为提供介于两个仪器之间最可能小的偏移，在校正过程测量偏移。

    运行校正过程以后，您可以从 E5850A 时间相关夹具前面移除通道连接。校正完成以后，所有的示波器和逻辑分析通道都可以测试探测您的设备。

    请记住，偏移受线缆长度、探头类型和仪器本身的影响。如果这些有任何更改，您需要重新执行校正过程。


校正过程工作方法

  • 传输延迟
  • 触发点不同
  • 目标
  • 设置问题
  • CAL 信号
  • 逻辑分析仪触发外部示波器
  • 测量偏移
  • 使用平均值
  • 外部示波器触发逻辑分析仪
  • 设置就绪

传输延迟

当触发条件发生时，逻辑分析仪和外部示波器便可将信号从其底板中驱除。这些信号在逻辑分析仪上为 Trigger Out，在示波器上为 Aux Out。

逻辑分析仪和示波器也能够在收到外部信号时提供和/或触发。这些信号在逻辑分析仪上为 Trigger In ，在示波器上为 Aux Trig In。

在两个仪器上, 在触发事件发生和其输出信息被驱动的时间中间有一个传输时间，在输入信号发生和仪器实际触发之间有一个传输延迟。在仪器之间的电缆中也存在传输时间。我们称这些传输时间的总和为仪器之间的偏移。

触发点不同

例如，您可以进行以下操作：

  1. 从逻辑分析仪 Trigger Out 将一条 50 欧姆电缆连接到示波器 Aux Trig In。
  2. 在逻辑分析仪上设置选择的触发条件。
  3. 在 Aux Trig In 上以 1.0 V 将示波器设置到 Edge（时钟沿）触发。
  4. 运行示波器。
  5. 运行逻辑分析仪。

逻辑分析仪触发以后，示波器将触发。这两台仪器都将识别它们的触发点。不幸的是，由于存在偏移，这些触发点不会及时表示相同点。除非探测到的信号有唯一识别码型，否则很难或者不可能指出哪个仪器上的时钟沿与其它仪器上的时钟沿相对应。

目标

校正过程的目的是测量仪器间的偏移，记住测量结果，当显示后续逻辑分析仪和示波器测量时将考虑这些结果，以便创建时间相关性标记位移。

设置问题

特别要注意偏移测量是特定于测量所用的设置的。偏移根据逻辑分析仪和示波器型号的不同会有所更改。根据所用示波器探头的类型和长度不同，偏移也有所差异。偏移因逻辑分析模块（如飞线、MICTOR 连接器、Samtec 连接器等）的各种可用探测选项的不同而异。对于最有可能的时间相关性，您必须使用稍后用于测量测试设备的相同探测执行校正过程。

CAL 信号

通过利用逻辑分析模块的 Pod 2, Channel 0 和示波器的 Channel 1 探测 E5850A 时间相关夹具的 CAL 信号来测量偏移。

CAL 信号是一个低频振荡器（大约 62 kHz，有 16 usec 周期）。因为此振荡器的周期比仪器间的偏移至少大两个十进制数量级，因此我们知道最接近触发的时钟沿是两台仪器的相同沿。

在驱动仪器发送触发信号以前，接收外部触发信号的仪器正在运行、被触发和正在等待，这是相当重要的。如果不是这种情况，仪器能够非常积极地查找振荡器的不同的时钟沿。

校正过程中以及后续规则的单次和重复运行期间，外部示波器软件确保仪器一直按照正确的序列触发和运行。

分析仪触发外部示波器

要测量 Logic Analyzer triggers External Oscilloscope（逻辑分析仪触发外部示波器）方向的偏移，外部示波器软件将同时设置逻辑分析仪和示波器。逻辑分析仪以最高的采样速率（最短的采样周期）设置为“定时模式”。为 E5850A 时间相关夹具提供的“DeskewEdge”（CAL 信号）定义信号名称。逻辑分析仪配置为在“DeskewEdge”信号的时钟上升沿触发。示波器配置为在它的 Aux Trig In 线上触发，Channel 1 被打开，配置为测量来自时间相关夹具的“DeskewEdge”信号。为其最大“采样速率”和最大“内存深度”处 Single Sweep（单清除）、“实时采样模式”而设置。

测量偏移

第一个运行示波器将测量偏移。触发逻辑分析仪后示波器将运行。逻辑分析仪在“DeskewEdge”的下一个时钟沿上触发，将 Trigger Out 驱动示波器，然后示波器触发。软件从示波器重新获得采集的 Channel 1 波形并测量从触发点到波形的上升沿之间的时间。时钟上升沿将比触发发生的早。此时间即为偏移。

使用平均值

测量重复几次并取平均值作为偏移。取多个测量值的平均值的原因是，逻辑分析仪在正则区间内采样“DeskewEdge”信号。时钟沿可能发生在接近逻辑分析仪的采样周期的开始或者结束。示波器同样在正则区间采样，一般以更高频率（周期更短）采样。由于两台仪器之间取样不同且异步，任意一个测量中都可能出现分析仪采样周期的 +/- 偏移。

外部示波器触发逻辑分析仪

在 External Oscilloscope triggers Logic Analyzer（外部示波器触发逻辑分析仪）方向测量偏移与在 Logic Analyzer triggers External Oscilloscope（逻辑分析仪触发外部示波器）方向测量类似。示波器设置为在 Channel 1 的上升沿触发并将 Aux Out (TTL Trig Out) 驱动到逻辑分析系统 Trigger In。将逻辑分析模块配置为在 Trigger In 触发。当测量运行时，分析模块首先运行以触发并等待来自示波器的 Aux Out/Trigger In 信号。当示波器运行时，它触发并将触发信号驱动到逻辑分析系统，然后触发并填充分析内存。（请注意，具有“TTL Trig Out”端口的示波器可以直接驱动逻辑分析仪的 Trigger In 输入，而具有“Aux Out”端口的示波器必须通过 E5850A 时间相关夹具路由以缓冲。）然后在逻辑分析系统中上升沿和触发发生时测量偏移。运行测量几次后取平均值作为偏移。

设置就绪

现在可以断开分析仪盒和示波器探头与时间相关夹具的连接并用于探测测试设备。

请记住，只有 Single Sweep（单清除）、Real Time（实时）采集可与逻辑分析仪有意关联。


不确定

因为逻辑分析仪在一个持续期间的间隔进行信号采样并且示波器将在一个安全不同的持续期间的间隔采样，因为信号能够在任意以采样周期的任何可能关系中转换，因此总是存在一些关于信号何时进行实际转换与分析仪何时注意到这种转换的不确定的因素。

另外一个不确定因素的来源是，交叉关联不同模块中触发事件的次数的模块间总线 (IMB)。此电路有 2 ns 的解析。

不确定因素至少 +/- 一个定时分析仪采样期周期加减模块间总线不确定因素的 2 ns。

校正过程中将测量最大和最小偏移。如果最大测量的偏移超过预期的范围，可以表示未建立或未正确建立与一个或多个时间相关夹具的连接。将会出现一个警告对话框，建议您检查所有连接并重新运行校正过程。


偏移数字意味着什么？

偏移（在 External Oscilloscope Setup（外部示波器设置）对话框的 Trigger（触发）选项卡中显示的）是将外部信号引入逻辑分析仪的平均触发延迟。逻辑分析系统内的总偏移部分，在每次运行时都能够在内部得到补偿。此内部测量的偏移与显示的恒定偏移相加来计算总偏移。总偏移与外部示波器的触发时间相加，因此其触发位置与分析仪的触发位置时间相关。

当分析仪触发外部示波器时，偏移数字为正数。当分析仪触发示波器时，则分析仪看见触发条件时和 Trigger Out 信号到达示波器 Aux Trig In 之间会发生延迟。

当外部示波器触发分析仪时，偏移数字为负数。当示波器触发分析仪时，在示波器看见触发条件时和 Aux Out 信号到达逻辑分析仪 Trigger In 之间会发生延迟。

在 External Oscilloscope Setup（外部示波器设置）对话框的 Trigger（触发）选项卡中，您可以使用 Manual（手动）触发校直以更改总偏移计算固定的部分。此功能可用于删除 Auto Deskew（自动校直）期间未测量的恒定偏移。如果您使用不同的探测附件而非运行 Auto Deskew（自动校直）来探测测试设备时，则会引起额外的恒定偏移。这是可以用到 Manual（手动）触发校直的一个示例。


外部示波器模块控制，COM 自动控制

Agilent Logic Analyzer 应用程序中包含 COM Automation Server。可以使用该软件编写通过局域网 (LAN) 内的远程计算机来控制 Agilent Logic Analyzer 应用程序的程序。

在 COM 自动控制程序中，可以通过以下方式配置模块：

  • 加载配置文件（该文件给出逻辑分析仪设置的完整设置）。

  • 使用 Module 对象的 DoCommands（字符串参数为 XML 格式）方法（请参见模块设置，XML 格式）。

有关模块配置的信息，可以通过 Module 对象的 QueryCommand 方法获得。外部示波器模块支持的查询如下所示。

有关逻辑分析仪 COM 自动控制和模块对象的总体信息，请参见 COM Automation。

支持的基于 XML 的查询

外部示波器模块支持下列基于 XML 的查询（通过 Module 对象的 QueryCommand 方法）。

查询 | 说明
GetAllSetup | 使用用于编写一般配置文件的完整标签集，返回当前设置（请参见 XML 格式 模块设置，XML 格式）。

另请参见

  • COM 自动控制
  • 模块设置, XML格式


外部示波器模块设置，XML 格式

当您将逻辑分析仪配置保存为 XML 格式文件时，其中包括了外部示波器模块的设置信息。

当编写 COM 自动控制程序以通过远程计算机控制逻辑分析仪时，还需使用此 XML 格式的设置信息。

外部示波器模块的 XML 元素具有下列层级：

<BusSignalSetup>
<BusSignals>
<Folder>
<BusSignal>
<Channels>
<ChannelsSetup>
<TriggerSetup>
<ConnectionSetup>
<Markers>
<Programming>
<Data>
<Channel1/2/3/4>
<Channel1/2/3/4DataTable>
<AnalogDataSource>
<SetupInfo>
<TimeDataSource>
<SetupInfo>
<SampleNumberDataSource>
<SetupInfo>

另请参见

  • XML 格式
  • 模块控制, COM 自动控制


<AnalogDataSource> 元素

<AnalogDataSource> 元素包含二进制数据文件中有关外部示波器通道的电压列的信息。

属性

名称 | 说明
Type | 'Page'

子元素

元素可能有下列子元素：<SetupInfo>（用于 AnalogDataSource）。

父元素

此元素可有下列父元素：<Channel1/2/3/4DataTable>。

示例

<AnalogDataSource Type='Page'>
   <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
         YOrg='-8.55' YRef='0' FileOffset='0'/>
</AnalogDataSource>


<BusSignal> 元素

<BusSignal> 元素包含示波器通道信号定义。

属性

名称 | 说明
Color | '十六进制 RGB 值'（与此通道数据关联的颜色）
Enabled | 'F'（假）或 'T'（真）
Name | '字符串'

子元素

元素可能有下列子元素：<Channels>。

父元素

此元素可有下列父元素：<Folder>。

示例

<BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
   <Channels>1</Channels>
</BusSignal>


<BusSignals> 元素

<BusSignals> 元素包含示波器通道信号定义。

子元素

元素可能有下列子元素：<Folder>。

父元素

此元素可有下列父元素：<BusSignalSetup>。

示例

<BusSignals>
   <Folder Name='Channel 1'>
      <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
         <Channels>1</Channels>
      </BusSignal>
   </Folder>
   <Folder Name='Channel 2'>
      <BusSignal Name='My Scope C2' Enabled='T' Color='h00FF00'>
         <Channels>2</Channels>
      </BusSignal>
   </Folder>
</BusSignals>


<BusSignalSetup> 元素

<BusSignalSetup> 元素包含 <BusSignals> 元素。

子元素

元素可能有下列子元素：<BusSignals>。

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<BusSignalSetup>
   <BusSignals>
      <Folder Name='Channel 1'>
         <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
            <Channels>1</Channels>
         </BusSignal>
      </Folder>
      <Folder Name='Channel 2'>
         <BusSignal Name='My Scope C2' Enabled='T' Color='h00FF00'>
            <Channels>2</Channels>
         </BusSignal>
      </Folder>
   </BusSignals>
</BusSignalSetup>


<Channel1/2/3/4> 元素

<Channel1/2/3/4> 元素描述了包含特定示波器通道数据的二进制数据文件部分。

属性

名称 | 说明
MaxVoltage | '浮点数字'（此通道全部采集的最大电压，以伏特为单位）
MinVoltage | '浮点数字'（此通道全部采集的最小电压，以伏特为单位）
NumBytesPerSample | '数字'（示波器数据中每个样本的字节数）
NumSamples | '数字'（示波器数据中的“点”数和样本数）
Valid | 'F'（假）或 'T'（真，当数据有效时）
XInc | '浮点数字'（按秒计算 X 坐标增长值）
XOrg | '浮点数字'（按秒计算的 X 起始点值）
XRef | '数字'（与 X 起始点相关联的 X 轴增长值）
YInc | '浮点数字'（电压中 Y 坐标增长值）
YOrg | '浮点数字'（电压中 Y 起始点值）
YRef | '数字'（与 Y 起始点相关联的 Y 轴增长值）

子元素

元素可能有下列子元素：<Channel1/2/3/4DataTable>。

父元素

此元素可有下列父元素：<Data>。

示例

<Channel1 Valid='T' XInc='5.000000e-010' XOrg='-2.619995e-004' XRef='0'
      YInc='1.562500e-001' YOrg='-8.550000e+000' YRef='0'
      MinVoltage='-3.080000e+000' MaxVoltage='5.670000e+000'
      NumBytesPerSample='1' NumSamples='1048000'>
   <Channel1DataTable RowCount='1048000' TriggerIndex='523999'
         OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
         FileName='ext_scope_data02of02.mfb'>
      <AnalogDataSource Type='Page'>
         <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
               YOrg='-8.55' YRef='0' FileOffset='0'/>
      </AnalogDataSource>
      <TimeDataSource Type='Periodic'>
         <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
      </TimeDataSource>
      <SampleNumberDataSource Type='Periodic'>
         <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
      </SampleNumberDataSource>
   </Channel1DataTable>
</Channel1>


<Channel1/2/3/4DataTable> 元素

<Channel1/2/3/4DataTable> 元素描述了包含特定示波器通道数据的二进制数据文件部分。

属性

名称 | 说明
FileName | '相对路径文件名'
OffsetTime | '数字时间单位'
RowCount | '数字'
TimePrecision | '数字时间单位'
TriggerIndex | '数字'

子元素

元素可能有下列子元素：<AnalogDataSource>、<TimeDataSource>、<SampleNumberDataSource>。

父元素

此元素可有下列父元素：<Data>。

示例

<Channel1DataTable RowCount='1048000' TriggerIndex='523999'
      OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
      FileName='ext_scope_data02of02.mfb'>
   <AnalogDataSource Type='Page'>
      <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
            YOrg='-8.55' YRef='0' FileOffset='0'/>
   </AnalogDataSource>
   <TimeDataSource Type='Periodic'>
      <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
   </TimeDataSource>
   <SampleNumberDataSource Type='Periodic'>
      <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
   </SampleNumberDataSource>
</Channel1DataTable>


<Channels> 元素

<Channels> 元素指定了分配到信号名称的示波器通道。

数据

此元素的数据表示信号的示波器通道的字符。

父元素

此元素可有下列父元素：<BusSignal>。

示例

<Channels>1</Channels>


<ChannelsSetup> 元素

<ChannelsSetup> 元素描述了外部示波器通道设置选项。

属性

名称 | 说明
MemoryDepth | '数字'（要导入的示波器数据样本数）
NumChannels | '数字'（示波器通道数）
SaveScopeSetup | 'F'（假）或 'T'（真）

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<ChannelsSetup NumChannels='2' SaveScopeSetup='T' MemoryDepth='1048576'/>


<ConnectionSetup> 元素

<ConnectionSetup> 元素描述了示波器连接选项。

属性

名称 | 说明
LAProbe | 'LAProbeGrabber'、'LAProbeMictor'、'LAProbeSamtec' 或 'LAProbeSocket'（从分析仪到校直信号的探头连接）
Name | '字符串'（示波器要连接的主机名）
ScopeProbe | '100 引脚探头'、'38 引脚探头'、'飞线式探头' 或 'ScopeProbeGrabber'（从分析仪到校直信号的探头连接）

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<ConnectionSetup
      Name='130.29.68.220'
      LAProbe='LAProbeSocket'
      ScopeProbe='ScopeProbeGrabber'
/>


<Data> 元素

当数据和设置信息保存到 XML 格式的配置文件后，<Data> 元素便包含了有关保存的二进制文件的信息。

子元素

元素可能有下列子元素：<Channel1/2/3/4>。

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<Data>
   <Channel1 Valid='T' XInc='5.000000e-010' XOrg='-2.619995e-004' XRef='0'
         YInc='1.562500e-001' YOrg='-8.550000e+000' YRef='0'
         MinVoltage='-3.080000e+000' MaxVoltage='5.670000e+000'
         NumBytesPerSample='1' NumSamples='1048000'>
      <Channel1DataTable RowCount='1048000' TriggerIndex='523999'
            OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
            FileName='ext_scope_data02of02.mfb'>
         <AnalogDataSource Type='Page'>
            <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
                  YOrg='-8.55' YRef='0' FileOffset='0'/>
         </AnalogDataSource>
         <TimeDataSource Type='Periodic'>
            <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
         </TimeDataSource>
         <SampleNumberDataSource Type='Periodic'>
            <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
         </SampleNumberDataSource>
      </Channel1DataTable>
   </Channel1>
   <Channel2 Valid='T' XInc='5.000000e-010' XOrg='-2.619995e-004' XRef='0'
         YInc='6.250000e-002' YOrg='6.250000e+000' YRef='0'
         MinVoltage='-5.000000e-001' MaxVoltage='5.375000e+000'
         NumBytesPerSample='1' NumSamples='1048000'>
      <Channel2DataTable RowCount='1048000' TriggerIndex='523999'
            OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
            FileName='ext_scope_data02of02.mfb'>
         <AnalogDataSource Type='Page'>
            <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.0625'
                  YOrg='6.25' YRef='0' FileOffset='2096000'/>
         </AnalogDataSource>
         <TimeDataSource Type='Periodic'>
            <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
         </TimeDataSource>
         <SampleNumberDataSource Type='Periodic'>
            <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
         </SampleNumberDataSource>
      </Channel2DataTable>
   </Channel2>
</Data>

二进制数据文件格式

对于外部示波器模块，存在包含模块的取样数量、电压和时间数据的单个二进制数据文件。每个通道的数据都被连续存储，<Data> 下的 XML 元素在每个通道的文件中都指向字节偏移。数据仅按样本或行转出，从数据的第一个示例开始直到最后一个。

如果带有数据的 XML 文件在系统中重复，使用 XML 文件中的分页信息通过页面调用数据以提高性能。对各种数据都没有进行任何校验和，所以无论何时加载这些数据时都假定数据完整性有效。如果文件发生任何更改，应该与描述的格式保持一致。

如果您想了解使用 XML 格式配置文件处理二进制数据文件的信息，请联系 Agilent Technologies（http://www.agilent.com/find/contactus 以获取有关示例分析代码。


<Folder> 元素

<Folder> 元素包含了示波器通道的总线/信号定义。

属性

名称 | 说明
Name | '字符串'

子元素

元素可能有下列子元素：<BusSignal>。

父元素

此元素可有下列父元素：<BusSignals>。

示例

<Folder Name='Channel 1'>
   <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
      <Channels>1</Channels>
   </BusSignal>
</Folder>


<Markers> 元素

<Markers> 元素描述了与系统触发相关的 Ax 和 Bx 示波器标记时间。

属性

名称 | 说明
MarkerAxTime | '浮点数字'（与系统触发相关）
MarkerBxTime | '浮点数字'（与系统触发相关）

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<Markers
      MarkerAxTime='-0.000000005313333333333328'
      MarkerBxTime='0.000000018166666666666672'
/>


<Programming> 元素

<Programming> 元素描述了示波器和逻辑分析仪的设置信息。

属性

名称 | 说明
LATrigState | '字符串'（XML 触发逻辑分析仪的指定内容以在状态模式执行自动校直）
LATrigTiming | '字符串'（XML 触发逻辑分析仪的指定内容以在定时模式执行自动校直）
ScopeEdgeSource | 'Channel1'、'Channel2'、'Channel3' 或 'Channel4'，（校直信号的切边源）
ScopeTrigMode | 'TriggerModeAdvanced'、'TriggerModeEdge' 或 'TriggerModeGlitch'（校直时示波器的触发模式）
ScopeTrigSweep | 'TriggerSweepAuto'、'TriggerSweepSingle' 或 'TriggerSweepTriggered'（校直时示波器的触发清除设置）
ScopeAuxExtEdgeSlope | 'SlopeNegative' 或 'SlopePositive'（示波器校直信号的斜面）
ScopeAuxExtTrigLevel | '浮点数字'

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<Programming
   ScopeTrigSweep='TriggerSweepSingle'
   ScopeTrigMode='TriggerModeEdge'
   ScopeEdgeSource='Channel1'
   ScopeAuxExtEdgeSlope='SlopePositive'
   ScopeAuxExtTrigLevel='0.000000e+000'
   LATrigTiming='
&lt;Module&gt;
   &lt;Trigger Mode=&quot;Timing&quot;&gt;
      &lt;Sequence Level=&quot;1&quot;&gt;
         &lt;If&gt;
            &lt;Event&gt;
               &lt;Anything/&gt;
            &lt;/Event&gt;
            &lt;Occurrence Value=&quot;1&quot;/&gt;
            &lt;Action&gt;
               &lt;TriggerAction Operator=&quot;Fill Memory&quot;/&gt;
            &lt;/Action&gt;
         &lt;/If&gt;
      &lt;/Sequence&gt;
   &lt;/Trigger&gt;
&lt;/Module&gt;
   '
   LATrigState='
&lt;Module&gt;
   &lt;Trigger Mode=&quot;State&quot;&gt;
      &lt;StoreQual&gt;
         &lt;Event&gt;
            &lt;Anything/&gt;
         &lt;/Event&gt;
      &lt;/StoreQual&gt;
      &lt;Sequence Level=&quot;1&quot;&gt;
         &lt;If&gt;
            &lt;Event&gt;
               &lt;Anything/&gt;
            &lt;/Event&gt;
            &lt;Occurrence Value=&quot;1&quot;/&gt;
            &lt;Action&gt;
               &lt;TriggerAction Operator=&quot;Fill Memory&quot;&gt;
                  &lt;StoreQual&gt;
                     &lt;Event&gt;
                        &lt;Anything/&gt;
                     &lt;/Event&gt;
                  &lt;/StoreQual&gt;
               &lt;/TriggerAction&gt;
            &lt;/Action&gt;
         &lt;/If&gt;
      &lt;/Sequence&gt;
   &lt;/Trigger&gt;
&lt;/Module&gt;
   '
/>


<SampleNumberDataSource> 元素

<SampleNumberDataSource> 元素包含了二进制数据文件中有关外部示波器通道的样本编号列的信息。

属性

名称 | 说明
Type | 'Periodic'

子元素

元素可能有下列子元素：<SetupInfo>（用于 SampleNumberDataSource）。

父元素

此元素可有下列父元素：<Channel1/2/3/4DataTable>。

示例

<SampleNumberDataSource Type='Periodic'>
   <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
</SampleNumberDataSource>


<SetupInfo> 元素（用于 AnalogDataSource）

<SetupInfo> 元素包含 <AnalogDataSource> 元素的附加设置信息。

属性

名称 | 说明
FileOffset | '数字'（二进制数据文件中数据开始位置的字节数）
PageSize | '数字'（每个数据页的字节数）
RowCount | '数字'（样本数）
YInc | '浮点数字'（电压中 Y 坐标增长值）
YOrg | '浮点数字'（电压中 Y 起始点值）
YRef | '数字'（与 Y 起始点相关联的 Y 轴增长值）

父元素

此元素可有下列父元素：<AnalogDataSource>。

示例

<SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
      YOrg='-8.55' YRef='0' FileOffset='0'/>


<SetupInfo> 元素（用于 SampleNumberDataSource）

<SetupInfo> 元素包含了 <SampleNumberDataSource> 元素的其他设置信息。

属性

名称 | 说明
RowCount | '数字'（样本数）
SamplePeriod | '1'
TriggerIndex | '数字'（基于零的）

父元素

此元素可有下列父元素：<SampleNumberDataSource>。

示例

<SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>


<SetupInfo> 元素（用于 TimeDataSource）

<SetupInfo> 元素包含 <TimeDataSource> 元素的额外设置信息。

属性

名称 | 说明
RowCount | '数字'（样本数）
SamplePeriod | '数字时间单位'（定时数据的采样周期）
TriggerIndex | '数字'（基于零的）

父元素

此元素可有下列父元素：<TimeDataSource>。

示例

<SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>


<TimeDataSource> 元素

<TimeDataSource> 元素包含二进制数据文件中有关外部示波器通道的时间列的信息。

属性

名称 | 说明
Type | 'Periodic'

子元素

元素可能有下列子元素：<SetupInfo>（用于 TimeDataSource）。

父元素

此元素可有下列父元素：<Channel1/2/3/4DataTable>。

示例

<TimeDataSource Type='Periodic'>
   <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
</TimeDataSource>


<TriggerSetup> 元素

<TriggerSetup> 元素描述了外部示波器触发选项。

属性

名称 | 说明
Analyzer | '字符串'（与示波器相关的逻辑分析仪模块名称）
AutoDeskew | 'F'（假）或 'T'（真）
AutoDeskewExtIntTime | '浮点数字'（示波器触发逻辑分析仪的校直时间）
AutoDeskewIntExtTime | '浮点数字'（逻辑分析仪触发示波器的校直时间）
ManualDeskewExtIntTime | '浮点数字'（示波器触发逻辑分析仪的校直时间）
ManualDeskewIntExtTime | '浮点数字'（逻辑分析仪触发示波器的校直时间）
TriggerDirection | 'LATrigScope' 或 'ScopeTrigLA'

父元素

此元素可有下列父元素：<Module>。

当 COM 自动控制中用到元素时，该元素由 QueryCommand 方法的 GetAllSetup 查询返回。您也可以将该元素字符串作为 XMLCommand 与 DoCommands 方法配合使用来配置 External Oscilloscope（外部示波器）模块。

示例

<TriggerSetup
      TriggerDirection='LATrigScope'
      AutoDeskew='T'
      Analyzer='My 1682D-1'
      AutoDeskewIntExtTime='9.996667e-008'
      AutoDeskewExtIntTime='-1.150000e-008'
      ManualDeskewIntExtTime='9.996667e-008'
      ManualDeskewExtIntTime='-1.150000e-008'
/>