External Oscilloscope Time Correlation and Data Display

Online Help

Version 04.00.0000

Copyright © 2001-2010 Agilent Technologies, Inc.

Warranty
Technology License
Restricted Rights Legend
Safety Notices
Trademarks

August 26, 2010

Table of Contents

External Oscilloscope Time Correlation and Data Display—At a Glance
Getting Started with External Oscilloscope Time Correlation and Data Display
Step 1. Network the oscilloscope and logic analyzer
Using a Point-to-Point Network
Step 2. Run the Add External Oscilloscope wizard
Additional Connection Information
Step 3. Make a measurement
Working with Markers
Displaying Imported Oscilloscope Data
Controlling the External Oscilloscope via the Web
Loading and Saving Configurations
Changing External Oscilloscope Setup Options
Deleting the External Oscilloscope
External Oscilloscope Troubleshooting
Finding the External Oscilloscope IP Address
LAN Problems
General Triggering Problems
Unexpected or Inconsistent Results
Correlation Drift Over Long Acquisitions
External Oscilloscope Reference
External Oscilloscope Setup Dialog
Channels Tab
Trigger Tab
Connection Tab
External Oscilloscope Concepts
Trigger Deskew
How the Calibration Procedure Works
Uncertainty
What Do the Skew Numbers Mean?
External Oscilloscope Module Control, COM Automation
External Oscilloscope Module Setup, XML Format
<AnalogDataSource> Element
<BusSignal> Element
<BusSignals> Element
<BusSignalSetup> Element
<Channel1/2/3/4> Element
<Channel1/2/3/4DataTable> Element
<Channels> Element
<ChannelsSetup> Element
<ConnectionSetup> Element
<Data> Element
<DigitalChannels> Element
<DigitalChannelsDataTable> Element
<DigitalDataSource> Element
<Folder> Element
<Markers> Element
<Name> Element
<Names> Element
<Pod1/2> Element
<Programming> Element
<SampleNumberDataSource> Element
<SetupInfo> Element (for AnalogDataSource)
<SetupInfo> Element (for DigitalDataSource)
<SetupInfo> Element (for SampleNumberDataSource)
<SetupInfo> Element (for TimeDataSource)
<TimeDataSource> Element
<TriggerSetup> Element
<WaveformData> Element


External Oscilloscope Time Correlation and Data Display—At a Glance

The Add External Oscilloscope wizard automates and simplifies the process of setting up an external oscilloscope and a logic analyzer to cross-trigger and make time-correlated measurements (using markers). You can also display data captured by the oscilloscope in the logic analyzer's display windows. This external oscilloscope correlation and data display feature is sometimes called View Scope.

External oscilloscope correlation works with the following oscilloscopes, set up for remote control via LAN:

  • Agilent InfiniiVision 5000 Series oscilloscopes.

  • Agilent InfiniiVision 6000 Series oscilloscopes.

  • Agilent InfiniiVision 7000 Series oscilloscopes.

  • Agilent Infiniium 548xx Series oscilloscopes.

  • Agilent Infiniium DSO/MSO8000 Series oscilloscopes.

  • Agilent Infiniium DSO/MSO9000 Series oscilloscopes.

  • Agilent Infiniium DSO80000 Series oscilloscopes.

  • Agilent Infiniium DSO90000 Series oscilloscopes.

The Add External Oscilloscope wizard can provide default (typical) deskew values for the type of logic analyzer and oscilloscope being used. You can also use the E5850A time correlation fixture to run a calibration procedure that provides the most accurate deskew values for the actual instruments being used. For more information about obtaining the E5850A time correlation fixture, contact your nearest Agilent Technologies Sales Office.

[Note]

The instructions on the E5850A time correlation fixture box are for 16700-series logic analysis systems only. For 16900-series logic analysis systems or 1680/90-series logic analyzers, follow the instructions in this online help.

In This Book

  • Getting Started with External Oscilloscope Time Correlation and Data Display

    • Step 1. Network the oscilloscope and logic analyzer

    • Step 2. Run the Add External Oscilloscope wizard

    • Step 3. Make a measurement

  • Working with Markers

  • Displaying Imported Oscilloscope Data

  • Controlling the External Oscilloscope via the Web

  • Loading and Saving Configurations

  • Changing External Oscilloscope Setup Options

  • Deleting the External Oscilloscope

  • Troubleshooting

    • Finding the External Oscilloscope IP Address

    • LAN Problems

    • General Triggering Problems

    • Unexpected or Inconsistent Results

    • Correlation Drift Over Long Acquisitions

  • Reference

    • External Oscilloscope Setup Dialog

  • Concepts

    • Trigger Deskew

    • How the Calibration Procedure Works

    • Uncertainty

    • What Do the Skew Numbers Mean?

  • External Oscilloscope Module Control, COM Automation

  • External Oscilloscope Module Setup, XML Format


Getting Started with External Oscilloscope Time Correlation and Data Display

Software for external oscilloscope time correlation and data display is built-in to the Agilent Logic Analyzer application.

After the external oscilloscope and logic analyzer are networked, the Add External Oscilloscope wizard takes you through the process of connecting the logic analyzer to the oscilloscope. Once that is done, you are ready to make a measurement.

  • Step 1. Network the oscilloscope and logic analyzer

  • Step 2. Run the Add External Oscilloscope wizard

  • Step 3. Make a measurement


Step 1. Network the oscilloscope and logic analyzer

[Note]

If your logic analyzer and external oscilloscope are both already connected to a LAN, you can skip this step.

[Note]

When using a 6000-series oscilloscope, the LAN port must be selected as the I/O Controller. (Press the Utility button; then, press the I/O softkey; use the Entry knob to select LAN; then, press the Controller softkey.)

If your logic analyzer and external oscilloscope are not already connected to a LAN, a simple point-to-point connection may be the most convenient connection between the instruments (see Using a Point-to-Point Network).

If you do not want to use a point-to-point connection, refer to the logic analyzer or external oscilloscope operating system instructions for setting up the instrument on the network.


Using a Point-to-Point Network

To set up a point-to-point connection between the logic analyzer and the oscilloscope, use the cross-over (blue) cable (provided with the E5850A time correlation fixture) to connect the instruments.

  1. Connect one end of the cross-over cable to the network interface on the logic analyzer and the other end of the cable to the network interface on the oscilloscope.

  2. Configure the networking software on the oscilloscope (see Oscilloscope Point-to-Point Network Set Up).

  3. Configure the networking software on the logic analyzer (see Logic Analyzer Point-to-Point Network Set Up).


Oscilloscope Point-to-Point Network Set Up

  1. Make sure networking is enabled on the oscilloscope.

  2. Set the oscilloscope's IP Address to 192.0.2.231.

  3. Set the Subnet Mask to 255.255.255.0.

  4. If there is a WINS resolution option, disable it.

  5. Remove any installed gateways.

  6. If there is a DNS option, disable it.

  7. On a 6000-series oscilloscope, select the LAN port as the I/O Controller:

    1. Press the Utility button.

    2. Press the I/O softkey.

    3. Use the Entry knob to select LAN.

    4. Press the Controller softkey.

See Also

  • Logic Analyzer Point-to-Point Network Set Up


Logic Analyzer Point-to-Point Network Set Up

  1. From the Start menu, select Setting>Network and Dial-up Connection.

  2. Right-click on Local Area Connection and select Properties.

  3. Ensure that the TCP/IP component is installed, then select Properties.

  4. In the Properties dialog, set the IP Address and Subnet Mask.

    1. Set the IP Address to 192.0.2.232.

    2. Set the Subnet Mask to 255.255.255.0.

  5. Select the Advanced tab.

    1. In the IP Settings tab, remove any installed gateways.

    2. In the DNS tab, remove all DNS addresses from the list.

    3. In the WINS tab, remove all WINS addresses from the list.

  6. Close the dialogs and click Yes if prompted to continue.

See Also

  • Oscilloscope Point-to-Point Network Set Up

  • Step 2. Run the Add External Oscilloscope wizard


Step 2. Run the Add External Oscilloscope wizard

For step-by-step instructions on setting up the connection between the logic analyzer and the oscilloscope, run the Add External Oscilloscope wizard:

  1. From the menu bar, select Setup>Add External Scope....

  2. Follow the instructions in the wizard.

[Note]

The external oscilloscope module can cross-trigger with split logic analyzer modules; however, the "External Oscilloscope triggers Logic Analyzer" direction will not trigger the second half of a split logic analyzer.

See Also

  • Additional Connection Information

  • Deleting the External Oscilloscope

  • Finding the External Oscilloscope IP Address


Additional Connection Information

  • Connecting the LAN

  • Connecting the BNC Cables

  • Connecting the Oscilloscope Probe to the Time Correlation Fixture

  • Connecting the Logic Analyzer to the Time Correlation Fixture

  • Connecting the Power Supply to the Time Correlation Fixture

Connecting the LAN

An external oscilloscope module uses a network connection between the oscilloscope and the 1680/90-series logic analyzer or the 16900-series logic analysis system to produce time-correlated measurements and to import oscilloscope data. The instruments must be connected on a local area network (LAN) or connected point-to-point with a cross-over cable (which is supplied with the E5850A time correlation fixture).

[Note]

When using a 6000-series oscilloscope, the LAN port must be selected as the I/O Controller. (Press the Utility button; then, press the I/O softkey; use the Entry knob to select LAN; then, press the Controller softkey.)

You can connect only one oscilloscope to the logic analysis system for time-correlated measurements. The logic analysis system does not support the connection of two or more oscilloscopes at once.

Connecting the BNC Cables

BNC cable connections depend on which model external oscilloscope you have.

For instructions for connecting BNC see the Add External Oscilloscope wizard.

Connecting the Oscilloscope Probe to the Time Correlation Fixture

[Note]

It is important to use the same probe for the calibration procedure as you use to make measurements on your device under test. This provides the best possible deskew accuracy. All connections must include a ground connection.

Connect the external oscilloscope channel 1 probe to any point labeled CAL on the front of the E5850A time correlation fixture. Any point labeled CAL is equivalent to any other point labeled CAL.

  • If you are using a differential probe, you must connect the (+) probe terminal to the CAL terminal and the (-) probe terminal to the GND connection on the time correlation fixture.

  • If you are using a grabber probe, connect the grabber probe to the CAL terminal on the front of the time correlation fixture. Then, connect the ground lead.

  • If you are using a twin lead probe, connect the twin lead probe to the time correlation fixture. Then, connect the ground lead.

  • If you are using a sharp-tip probe, connect the sharp tip probe to the CAL terminal on the front of the time correlation fixture.

Connecting the Logic Analyzer to the Time Correlation Fixture

[Note]

It is important to use the same probes for the calibration procedure as you use to make measurements in the device under test. This provides the best possible deskew accuracy. All connections must include a ground connection.

There are three ways to connect to the CAL signals on the time correlation fixture:

  • Using flying leads.

  • Using high-density connectors (MICTOR or Samtec).

  • Using grabber probes.

Flying Leads (Socket Probe)

Connect pod 2, channel 0 of the logic analyzer you are using to any point labeled CAL on the front of the time correlation fixture. If you are using multiple card logic analyzers, use pod 2 of the master card. Include a ground connection.

High-Density Connectors

If you are using a MICTOR connector on your device under test, use the MICTOR receptacle on the top of the time correlation fixture, which includes the CAL connection. Be sure to connect pod 2 of the logic analyzer to the even receptacle of the MICTOR high-density adapter cable. You can use a terminated or an unterminated high-density adapter cable.

If you are using Samtec connectors on your device under test, use the Samtec receptacle on the top of the time correlation fixture, which includes the CAL connection.

Grabber Probe

If you are using a grabber probe on your device under test, connect the grabber probe to the terminal labeled CAL. Be sure to include the ground connection.

Connecting the Power Supply to the Time Correlation Fixture

Connect the power supply to the time correlation fixture as shown in the Add External Oscilloscope wizard.

[Warning]

Shock hazard. Use only the 0950-2546 power supply and cord.

[Caution]

Equipment damage. Use only the 0950-2546 power supply and cord.

The BNC cables and the power supply must remain connected to the time correlation fixture when you are performing a time correlated measurement. The probes only need to be connected during the calibration procedure.

[Note]

Remember that the skew is affected by cable lengths, probe types, and the instruments. If you change any of these, you will need to run the calibration procedure again. To re-run the calibration procedure, select Setup>(External Oscilloscope)>Trigger...; then, in the Trigger tab of the External Oscilloscope Setup dialog, click Run Auto-Deskew....


Step 3. Make a measurement

When the calibration is complete you may proceed with your measurements as follows:

  1. If you used the E5850A time correlation fixture to calibrate deskew values, disconnect the external oscilloscope probe and the logic analyzer leads from the time correlation fixture.

  2. Connect the oscilloscope probe and the logic analyzer leads to your device under test.

    Do not disconnect the BNC cables.

  3. Set up the trigger condition.

  4. Press the Run button on the logic analyzer front panel.

  5. Select the Waveform tab to view your measurement results.

Logic Analyzer Triggers External Oscilloscope

When the software is configured for Logic Analyzer triggers External Oscilloscope, you can set any trigger condition you desire in the logic analyzer. However, do not change the oscilloscope's trigger setup.

External Oscilloscope Triggers Logic Analyzer

When the software is configured for External Oscilloscope triggers Logic Analyzer, you may set any trigger condition you desire in the oscilloscope. However, do not change the logic analyzer's trigger setup.

See Also

  • Working with Markers

  • General Triggering Problems


Working with Markers

Marker Moves

Marker moves are coordinated between the logic analyzer and the oscilloscope. Markers are coordinated in time, relative to the trigger, taking the measured skew into account.

On the logic analyzer, the markers, called Ax(External Scope) and Bx(External Scope), are time correlated among all display windows that are displaying measurements from a given run. On the oscilloscope, there are two X-Axis (time) markers called Ax and Bx. Marker moves are coordinated between Ax(External Scope) and Ax and between Bx(External Scope) and Bx. The option to coordinate between Ax(External Scope) and Bx or Bx(External Scope) and Ax is not available.

Coordinated marker moves are useful for quickly identifying a given point in the trace on the separate logic analyzer and oscilloscope displays. The marker properties for the Ax(External Scope) and Bx(External Scope) markers can be accessed through the Markers menu.

Oscilloscope Markers

Ax Follows the Logic Analyzer's Ax(External Scope). When you move the Ax(External Scope) marker in the logic analyzer waveform display, a command is sent to the oscilloscope to position the Ax marker at the same point in time.

Bx Follows the Logic Analyzer's Bx(External Scope). When you move the Bx(External Scope) marker in the logic analyzer waveform display, a command is sent to the oscilloscope to position the Bx marker at the same point in time.

Logic Analyzer Markers

Ax(External Scope) Follows Oscilloscope's Ax. When you move the Ax marker on the oscilloscope, the Ax(External Scope) marker in the logic analyzer waveform display is moved to the same point in time.

Bx(External Scope) Follows Oscilloscope's Bx. When you move the Bx marker on the oscilloscope, the Bx(External Scope) marker in the logic analyzer waveform display is moved to the same point in time.


Displaying Imported Oscilloscope Data

After running the Add External Oscilloscope wizard, the external oscilloscope module appears in the Overview window with a connection to a new Waveform window.

To display logic analyzer data along with imported oscilloscope data

You can insert rows of data to display captured logic analyzer data in the same Waveform window as imported oscilloscope data:

  1. Right-click on a row in the Waveform window, and choose Insert Row Before... or Insert Row After....

  2. In the Insert dialog, select the logic analyzer data you would like to display with the imported oscilloscope data, and click OK.

    After inserting the row, the captured logic analyzer data appears in the Waveform window along with the imported oscilloscope data. For example:

Note that, in the Waveform window, you can group imported digital channels into buses (see To group signals into a bus).

To change imported oscilloscope data options

  1. Click the external oscilloscope module's [image] options button.

  2. In the External Oscilloscope Setup dialog's Channels tab, you can:

    • Select the oscilloscope channels whose data you want to import, including digital channels and buses from a mixed-signal oscilloscope.

    • Change oscilloscope analog channel signal names.

    • Change oscilloscope channel signal colors.

    • Specify other external oscilloscope setup options.

  3. When you are done changing imported data options, click OK to close the External Oscilloscope Setup dialog.


Controlling the External Oscilloscope via the Web

The External Scope Web Control VbaView window is an embedded Internet Explorer window pointed at the web interface of an external oscilloscope module.

[Note]

Oscilloscope performance slows down when its web control interface is being used; we recommend that you only connect to the oscilloscope's web control interface temporarily, to set up oscilloscope triggers, etc.; then, use the data import feature of the external oscilloscope module (see Displaying Imported Oscilloscope Data) to view the waveforms captured by the oscilloscope.

Make sure the oscilloscope's web control interface is disconnected when running the external oscilloscope module's automatic deskew calibration.

To use the External Scope Web Control window:

  1. Make sure the web control feature is enabled on the oscilloscope.

  2. After you have added the external oscilloscope (see Step 2. Run the Add External Oscilloscope wizard), choose Window>New VbaView>External Scope Web Control....

  3. In the Add New Window After dialog, select the external oscilloscope module, and click OK.

  4. In the External Scope Web Control window, click the Web Control navigation bar to control the oscilloscope via its web interface.

    [Note]

    If you see a blank screen (for example, if you installed a newer version of Internet Explorer or a Windows Service Pack that has removed the Java Virtual Machine (JVM)), you need to download a JVM to enable the web control feature. For example, you can download Sun's Java Virtual Machine freely from www.java.com.

Depending on the particular oscilloscope, the External Scope Web Control window looks something like:

In this case, clicking the Remote Front Panel link results in a window like:


Loading and Saving Configurations

When saving a configuration that includes an external oscilloscope module, the last skew run is saved along with the host name of the external oscilloscope. The oscilloscope setup (and data if you choose) will also be saved in the logic analyzer's configuration file.

When the configuration is loaded at a later time, the logic analysis system will automatically connect to the external oscilloscope and restore the setup that was saved. If the oscilloscope is not available on the network when the configuration is loaded this automatic connection and setup will fail.

If the external oscilloscope is a shared resource and is likely to be moved to another location, this option can have undesired effects. If the oscilloscope is on the network with the same Host Name or IP Address, the saved configuration will be loaded into that oscilloscope, possibly changing a setup that someone else has created.

[Note]

If two logic analyzers attempt to connect to a single oscilloscope, an error message will appear stating that the oscilloscope is locked by another user.

See Also

  • To save a configuration file

  • To open a configuration file

  • ALA vs. XML, When to Use Each Format


Changing External Oscilloscope Setup Options

  1. Choose the one of the commands from the Setup>(External Oscilloscope) menu.

    The External Oscilloscope Setup dialog is opened with one of these tabs selected:

    Channels tab

    Lets you select the oscilloscope channels to import data from and lets you specify other external oscilloscope setup options.

    Trigger tab

    Used for setting the trigger direction and running the trigger deskew.

    Connection tab

    Shows the oscilloscope name or IP address, model, and serial number.

  2. Make the desired changes.

  3. Click OK.


Deleting the External Oscilloscope

To delete the external oscilloscope:

  1. Choose Setup>(External Oscilloscope)>Delete from the menu bar.

See Also

  • Getting Started, Step 2. Run the Add External Oscilloscope wizard


External Oscilloscope Troubleshooting

General Troubleshooting

  • Finding the External Oscilloscope IP Address

  • LAN Problems

  • General Triggering Problems

  • Unexpected or Inconsistent Results

  • Correlation Drift Over Long Acquisitions


Finding the External Oscilloscope IP Address

The external oscilloscope time correlation and data display software requires the external oscilloscope's IP address. To find the external oscilloscope IP address:

  • On an Agilent Infiniium oscilloscope, select Utilities->GPIB Setup....

    The IP address is shown in the LAN Interface portion of the window. Ignore the brackets and text, and use only the numbers (such as 130.29.68.220). Use that string in the Add External Oscilloscope wizard.

  • On an Agilent 6000 Series oscilloscope, press the front panel Utilities button; then, press the I/O softkey.

    The IP address is shown in the LAN portion of the resulting I/O configuration information box. Use that IP address string in the Add External Oscilloscope wizard.

If this string is not entered correctly or if someone changes the external oscilloscope's IP address, the logic analyzer will not be able to communicate with the oscilloscope. If the string happens to correspond to another oscilloscope on the network, the logic analyzer may find and connect to that oscilloscope, giving the appearance that you are correctly connected when in fact you are not.

If you enter a string that does not correspond to any device on your network, the software may appear to hang for several minutes while it searches for the device. Only one connection from a logic analyzer to a given oscilloscope can be supported.


LAN Problems

If you see a LAN error message:

  • If you are using a 6000-series oscilloscope, make sure the LAN port is selected as the I/O Controller. (Press the Utility button; then, press the I/O softkey; use the Entry knob to select LAN; then, press the Controller softkey.)

  • Check the LAN connections to the external oscilloscope and the logic analysis system.

  • Check with your LAN administrator to ensure that the LAN is currently functioning. In the Connection tab of the External Oscilloscope Setup dialog, make sure the correct IP address is entered.

  • If errors are reported, ask your LAN administrator to help you establish networking on the logic analyzer and oscilloscope. Cycle power on both instruments.

  • If problems persist, contact Agilent Technologies for technical support.

Only one logic analysis system may connect to the external oscilloscope via the LAN

If two logic analysis systems try to connect to the same external oscilloscope, a message will appear stating that the oscilloscope is locked by another user. Connection to multiple external oscilloscopes from one logic analysis system is not supported.

See Also

  • Finding the External Oscilloscope IP Address


General Triggering Problems

  • Logic analyzer triggers external oscilloscope

  • External oscilloscope triggers logic analyzer

  • Why isn't the red trigger marker where I expect?

  • Check cable connections

  • Check probe connections

  • Use grounds

  • External oscilloscope must be in the correct mode

  • Ensure no one else is using the external oscilloscope

Logic analyzer triggers external oscilloscope

When Logic Analyzer triggers External Oscilloscope is selected, the oscilloscope is configured to trigger on a rising edge of Aux Trig In at 1.0 V. If you manually change the oscilloscope trigger, the logic analysis system will automatically restore the oscilloscope's trigger condition to trigger on the rising edge of Aux Trig In at 1.0 V the next time you run the logic analyzer. You can set any trigger condition you desire in the logic analyzer because you are using it to trigger the oscilloscope.

External oscilloscope triggers logic analyzer

When External Oscilloscope triggers Logic Analyzer is selected, the logic analyzer is configured to trigger on an external Trigger In. If you manually change the logic analyzer trigger, you will not be able to correctly time-correlate the instruments. You may set any trigger condition you desire in the oscilloscope because you are using it to trigger the logic analyzer.

Why isn't the red trigger marker where I expect?

Whenever you are using the external oscilloscope module, you are performing a multiple instrument measurement. Measurements from each instrument are time correlated, but each instrument retains its actual trigger point.

Check cable connections

The BNC cables must remain connected between the logic analyzer, the time correlation fixture, and the oscilloscope whenever you are using the time correlation feature.

Check probe connections

Be sure you are using the correct logic analyzer cables. Trace the cables from the logic analyzer to the E5850A time correlation fixture or device under test.

Be sure you are using the correct oscilloscope probe. Follow it from the instrument to the E5850A time correlation fixture or the device under test.

Use grounds

Your connections to the front of the time correlation fixture must include grounds. For example, you should connect the oscilloscope probe ground clip to the ground terminal on the E5850A time correlation fixture. Ground leads for each logic analyzer pod, and preferably each logic analyzer channel should be connected to a ground terminal on the E5850A fixture too.

External oscilloscope must be in the correct mode

Note that only Single Sweep, Real Time acquisition can be meaningfully correlated with a logic analyzer. Meaningful correlation may not be possible if the oscilloscope is set to sample in Equivalent Time, or if the oscilloscope sweep is set to Sweep or Triggered Sweep.

Ensure no one else is using the external oscilloscope

If someone else is using the external oscilloscope, either from the front panel or via the LAN, the logic analysis system will not be able to correctly control the oscilloscope.


Unexpected or Inconsistent Results

If you are experiencing unexpected or inconsistent deskew results, check the following items.

  • Check cable connections

  • Check probe connection

  • External oscilloscope must be in the correct mode

  • Ensure no one else is using the external oscilloscope


Correlation Drift Over Long Acquisitions

If you see correlation drift in long acquisitions as markers get farther away from the trigger, you can fix the problem by using the logic analysis system's 10 MHz CLOCK IN input (if present) to keep the oscilloscope and logic analyzer in sync.

The logic analysis system's CLOCK IN input is auto-sensing at power up; therefore, to use this input:

  1. Make sure the logic analysis system is powered off.

  2. Set up the 10 MHz clock source, 5.5 V max pk, either as an output from the oscilloscope or from another source that is fed into both the oscilloscope and logic analysis system.

  3. Connect the clock source to the logic analysis system's CLOCK IN input BNC.

  4. Power on the logic analysis system.


External Oscilloscope Reference

  • External Oscilloscope Setup Dialog


External Oscilloscope Setup Dialog

  • Channels Tab

  • Trigger Tab

  • Connection Tab


Channels Tab

The Channels tab lets you select the oscilloscope channels to import data from and lets you specify other external oscilloscope setup options.

Import Channels

Lets you choose oscilloscope channels to import data from, rename oscilloscope channel signals, and change the color associated with channel data.

The color associated with a channel is used when the analog signal is inserted into a Waveform display window. Changing a channel's color in this dialog does not affect the color of waveforms currently displayed.

Import Digital Channels and Buses

Lets you import digital channels and defined buses from a mixed-signal oscilloscope and change the color associated with digital channel data.

The color associated with digital channels and buses is used when the signals are inserted into a Waveform display window. Changing the color in this dialog does not affect the color of waveforms currently displayed.

Note that, in the Waveform window, you can group imported digital channels into buses (see To group signals into a bus).

Save External Oscilloscope Setup with Configuration

Specifies whether the external oscilloscope's configuration settings will be saved along with the time correlation settings when saving the logic analyzer's configuration file. When enabled and the logic analyzer configuration file is loaded, the logic analysis system will attempt to reload the external oscilloscope settings saved earlier.

Note: The Agilent Logic Analyzer application will not load external oscilloscope settings from one oscilloscope model into a different oscilloscope model. For example, settings for a Infiniium 54810A oscilloscope will not load into a Infiniium 54831B oscilloscope.

Limit Import to N Samples

Used to limit the number of oscilloscope data samples to import.

See Also

  • Connection Tab

  • Trigger Tab

  • Loading and Saving Configurations


Trigger Tab

The Trigger tab is used for setting the trigger direction and running the trigger deskew.

Trigger Direction

The Logic Analyzer triggers External Oscilloscope option sets up the logic analyzer and oscilloscope so that when the logic analyzer generates the trigger signal, the oscilloscope receives the signal through its Aux Trig In/Ext Trig channel and begins capturing data. You must manually set up the logic analyzer trigger.

The External Oscilloscope triggers Logic Analyzer option sets up the logic analyzer and oscilloscope so that when the oscilloscope generates the trigger signal, the logic analyzer receives the signal through its Trigger In port and begins capturing data. You must manually set up the oscilloscope trigger. Note that the oscilloscope will not trigger the second half of a split logic analyzer.

The Analyzer selection lets you choose the appropriate logic analyzer module for time correlation with the external oscilloscope.

Trigger Deskew

The Automatic option specifies that either default deskew values or the deskew values determined by the calibration procedure are used. Automatic deskew gives two separate deskew values, one for each trigger direction. To re-run the automatic deskew, click Run Auto-Deskew....

Note: Make sure the external oscilloscope's web control interface is disconnected before running the automatic deskew calibration procedure.

Note: Deskew calibration values differ depending upon the direction of the trigger.

The Manual options lets you enter a deskew value in the numeric field provided. The deskew value entered is used for both trigger directions (that is, manual deskew mode does not maintain separate values for each trigger direction).

Note: When Automatic deskew is selected, the deskew value is reset to the value obtained during the last calibration procedure.

See Also

  • Connection Tab

  • Channels Tab


Connection Tab

The Connection tab shows the external oscilloscope name or IP address, model, and serial number. If the oscilloscope becomes disconnected, you can reconnect through the Connection tab by clicking Reconnect.

See Also

  • Channels Tab

  • Trigger Tab

  • Finding the External Oscilloscope IP Address


External Oscilloscope Concepts

The following information helps explain how the external oscilloscope connection works.

  • Trigger Deskew

  • How the Calibration Procedure Works

  • Uncertainty

  • What Do the Skew Numbers Mean?


Trigger Deskew

When adding an external oscilloscope or running automatic deskew, trigger deskew values can be obtained by:

  • Using default calibration values — In this case, default (typical) values for the logic analyzer and oscilloscope are used. This is sufficient for most customers.

  • Using previous calibration values — This is appropriate when you have previously performed the calibration procedure and the hardware setup (instruments, probing, and cabling) has not changed. The previous values are used.

  • Performing the calibration procedure (which requires the E5850A time correlation fixture) — To provide the minimum skew possible between the two instruments, the skew is measured by the calibration procedure.

    After you have run the calibration procedure, you can remove the channel connections from the front of the E5850A time correlation fixture. When calibration is complete, all of your oscilloscope and logic analysis channels are available for probing your device under test.

    Remember that the skew is affected by cable lengths, probe types, and the instruments themselves. If any of these change, you need to perform the calibration procedure again.


How the Calibration Procedure Works

  • Propagation Delays

  • Trigger Points are Different

  • The Objective

  • Setup Matters

  • The CAL Signal

  • Logic Analyzer Triggers External Oscilloscope

  • Measuring the Skew

  • An Average is Used

  • External Oscilloscope Triggers Logic Analyzer

  • The Setup is Ready

Propagation Delays

The logic analyzer and the external oscilloscope are able to drive a signal out of their chassis when a trigger condition occurs. These signals are Trigger Out on the logic analyzer and Aux Out on the oscilloscope.

The logic analyzer and the oscilloscope are also able to arm and/or trigger on the receipt of an external signal. These signals are Trigger In on the logic analyzer and Aux Trig In on the oscilloscope.

On both instruments, there is a propagation time between when a trigger event occurs and when its output signal is driven, and a propagation delay between when an input signal occurs and when the instrument actually triggers. There will also be propagation time in the cable between the instruments. We call the sum of all these propagation times the skew between the instruments.

Trigger Points are Different

For example, you can:

  1. Connect a 50 ohm cable from the logic analyzer Trigger Out to the oscilloscope Aux Trig In.

  2. Set a trigger condition of your choice on the logic analyzer.

  3. Set the oscilloscope to Edge trigger on Aux Trig In at 1.0 V.

  4. Run the oscilloscope.

  5. Run the logic analyzer.

After the logic analyzer triggers, the oscilloscope will trigger. Both instruments will identify their trigger point. Unfortunately, because of the skew, these trigger points will not represent the same point in time. Unless the signal(s) being probed have unique identifying patterns, it may be very difficult or impossible to tell which edge(s) on one instrument correspond to which edge(s) on the other instrument.

The Objective

The point of the calibration procedure is to measure the skew between the instruments, remember the results of those measurements, and take those results into account when displaying subsequent logic analyzer and oscilloscope measurements so that time correlated marker moves can be created.

Setup Matters

It is important to be aware that the skew measurement is specific to the setup used for the measurement. The skew will change for different models of logic analyzers and oscilloscopes. Skew will vary based on the type and length of oscilloscope probe used. Skew will vary among the various probing options available for logic analysis modules such as flying leads, MICTOR connectors, Samtec connectors, etc. For the best possible time correlation, you must perform the calibration procedure with the same probing you will later use for measurements on your device under test.

The CAL Signal

The skew is measured by probing the CAL signal of the E5850A time correlation fixture with both Pod 2, Channel 0 of the logic analysis module and Channel 1 of the oscilloscope.

The CAL signal is a low frequency oscillator (approximately 62 kHz, with a 16 usec period). Because the period of this oscillator is at least two decimal orders of magnitude greater than the skew between the instruments, we know that the edge nearest the trigger is the same edge on both instruments.

It is critically important that the instrument that is to receive the external trigger signal is running, armed, and waiting before the driving instrument sends the trigger signal. If that is not the case, the instruments could very well be looking at different edges of the oscillator.

During the calibration procedure, and during subsequent regular single or repetitive runs, the external oscilloscope software ensures that the instruments are always armed and run in the correct sequence.

Analyzer Triggers External Oscilloscope

To measure skew in the Logic Analyzer triggers External Oscilloscope direction, the external oscilloscope software sets up both the logic analyzer and the oscilloscope. The logic analyzer is placed in Timing Mode at its highest sample rate (shortest sample period). A signal name is defined for the "DeskewEdge" (CAL signal) provided by the E5850A time correlation fixture. The logic analyzer is configured to trigger on the rising edge of the "DeskewEdge" signal. The oscilloscope is configured to trigger on its Aux Trig In line, and Channel 1 is turned on and configured to measure the "DeskewEdge" signal from the time correlation fixture. It is set up for Single Sweep, Real Time Sampling Mode at its maximum Sampling Rate and maximum Memory Depth.

Measuring the Skew

The skew is measured by first running the oscilloscope. After the logic analyzer is armed, it is run. The logic analyzer triggers on the next edge of "DeskewEdge", drives Trigger Out to the oscilloscope, which then triggers. The software retrieves the captured Channel 1 waveform from the oscilloscope and measures the time from the trigger point to the rising edge on that waveform. The rising edge will occur earlier in time than the trigger. This time is the skew.

An Average is Used

The measurement is repeated several times and the average is taken to be the skew. The reason for taking the average of multiple measurements is because the logic analyzer is sampling the "DeskewEdge" signal at a regular interval. The edge may actually occur near the beginning or near the end of the logic analyzer's sample period. The oscilloscope is also sampling at a regular interval, generally at a much higher frequency (shorter period). Because of the different and asynchronous sampling between the two instruments, a skew of +/- one analyzer sample period can occur in any single measurement.

External Oscilloscope Triggers Logic Analyzer

Measuring skew in the External Oscilloscope triggers Logic Analyzer direction is very similar to the Logic Analyzer triggers External Oscilloscope direction. The oscilloscope is set up to trigger on a rising edge on Channel 1 and drive Aux Out (TTL Trig Out) to the logic analysis system Trigger In. The logic analysis module is configured to trigger on Trigger In. When the measurement is run, the analysis module is run first so it is armed and waiting for the Aux Out/Trigger In signal from the oscilloscope. When the oscilloscope is run, it triggers and drives the trigger signal to the logic analysis system which then triggers and fills analysis memory. (Note that oscilloscopes that have a "TTL Trig Out" port can drive the logic analyzer's Trigger In input directly, while oscilloscopes that have "Aux Out" ports must be routed through the E5850A time correlation fixture for buffering.) The skew is then measured as the time between when the rising edge occurred and the trigger occurred in the logic analysis system. The measurement is run several times and an average is taken.

The Setup is Ready

The analyzer pod and oscilloscope probe may now be disconnected from the time correlation fixture and used to probe the device under test.

Remember that only Single Sweep, Real Time acquisition can be meaningfully correlated with a logic analyzer.


Uncertainty

Because the logic analyzer samples signals at intervals of one duration and the oscilloscope will usually sample at intervals of an entirely different duration, and because signals can actually transition at any point in time with any possible relation to the sample period(s), there will always be some uncertainty about when the signal actually transitioned versus when the analyzer noticed the transition.

Another source of uncertainty is the circuit used by the intermodule bus (IMB) to cross-correlate the times of trigger events from different modules. This circuitry has a resolution of 2 ns.

The uncertainty will always be at least +/- one timing analyzer sample period plus 2 ns of intermodule bus uncertainty.

During the calibration procedure, the maximum and minimum skew are measured. If the maximum measured skew is outside the expected range, it can indicate that one or more of the connections to the time correlation fixture were not made or were made incorrectly. A warning dialog will appear, suggesting that you check all the connections and run the calibration procedure again.


What Do the Skew Numbers Mean?

The skew (which is displayed within the Trigger tab of the External Oscilloscope Setup dialog) is the average trigger delay that is introduced external to the logic analyzer. The portion of the total skew that is internal to the logic analysis system is compensated for internally on a per-run basis. This internally measured skew is added to the constant skew that is displayed to compute the total skew. The total skew is added to the trigger time for the external oscilloscope, thereby time-correlating its trigger position with the trigger position of the analyzer.

The skew number will be positive when the analyzer triggers the external oscilloscope. When the analyzer triggers the oscilloscope, a delay occurs between the time when the analyzer sees the trigger condition and when the Trigger Out signal arrives at the oscilloscope Aux Trig In.

The skew number will be negative when the external oscilloscope triggers the analyzer. When the oscilloscope triggers the analyzer, a delay occurs between the time when the oscilloscope sees the trigger condition and when the Aux Out signal arrives at the logic analyzer Trigger In.

In the Trigger tab of the External Oscilloscope Setup dialog, you can use the Manual Trigger Deskew to change the fixed part of the total skew computation. This feature can be used to remove constant skew that was not measured during the Auto Deskew. If you use different probing accessories when you probe your device under test than when you ran the Auto Deskew, you will be causing additional constant skew. This is one example of where Manual Trigger Deskew can be useful.


External Oscilloscope Module Control, COM Automation

The Agilent Logic Analyzer application includes the COM Automation Server. This software lets you write programs that control the Agilent Logic Analyzer application from remote computers on the Local Area Network (LAN).

In a COM automation program, you can configure a module by:

  • Loading a configuration file (which configures the complete logic analyzer setup).

  • Using the Module object's DoCommands method with an XML-format string parameter (see Module Setup, XML Format).

You can get information about a module's configuration using the Module object's QueryCommand method. Queries supported by the External Oscilloscope module are listed below.

For more information about logic analyzer COM automation and module objects in general, see COM Automation.

XML-Based Queries Supported

The External Oscilloscope module supports the following XML-based queries (made with the Module object's QueryCommand method).

Query | Description
GetAllSetup | Returns the current setup, using the full tag set, used for writing generic configuration files (see the XML format Module Setup, XML Format).

See Also

  • COM Automation

  • Module Setup, XML Format


External Oscilloscope Module Setup, XML Format

When you save logic analyzer configurations to XML format files, setup information for the External Oscilloscope module is included.

This XML format setup information is also used when writing COM automation programs to control the logic analyzer from a remote computer.

XML elements for the External Oscilloscope module have the following hierarchy:

<BusSignalSetup>
   <BusSignals>
      <Folder>
         <BusSignal>
            <Channels>
            <Names>
               <Name>
<ChannelsSetup>
<TriggerSetup>
<ConnectionSetup>
<Markers>
<Programming>
<Data>
   <Channel1/2/3/4>
      <Channel1/2/3/4DataTable>
         <AnalogDataSource>
            <SetupInfo>
         <TimeDataSource>
            <SetupInfo>
         <SampleNumberDataSource>
            <SetupInfo>
   <DigitalChannels>
      <WaveformData>
         <Pod1/2>
      <DigitalChannelsDataTable>
        <DigitalDataSource>
           <SetupInfo>
        <TimeDataSource>
           <SetupInfo>
         <SampleNumberDataSource>
            <SetupInfo>

See Also

  • XML Format

  • Module Control, COM Automation


<AnalogDataSource> Element

The <AnalogDataSource> element contains information about the external oscilloscope channel's voltage column in the binary data file.

Attributes

Name | Description
Type | 'Page'

Children

This element can have the following children: <SetupInfo> (for AnalogDataSource).

Parents

This element can have the following parents: <Channel1/2/3/4DataTable>.

Example

<AnalogDataSource Type='Page'>
   <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
         YOrg='-8.55' YRef='0' FileOffset='0'/>
</AnalogDataSource>


<BusSignal> Element

The <BusSignal> element contains an oscilloscope channel signal definition.

Attributes

Name | Description
Color | 'hex_RGB_value' (the color associated with this channel's data)
DefaultLabel | 'F' (false) or 'T' (true)
Enabled | 'F' (false) or 'T' (true)
Name | 'string'

Children

This element can have the following children: <Channels>, <Names>.

Parents

This element can have the following parents: <Folder>.

Examples

<BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
   <Channels>1</Channels>
</BusSignal>

<BusSignal Name='My Scope D15-0' DefaultLabel='T'>
   <Channels>D[15:0]</Channels>
   <Names>
      <Name Index='0'>D0</Name>
      <Name Index='1'>D1</Name>
      <Name Index='2'>D2</Name>
      <Name Index='3'>D3</Name>
      <Name Index='4'>D4</Name>
      <Name Index='5'>D5</Name>
      <Name Index='6'>D6</Name>
      <Name Index='7'>D7</Name>
      <Name Index='8'>D8</Name>
      <Name Index='9'>D9</Name>
      <Name Index='10'>D10</Name>
      <Name Index='11'>D11</Name>
      <Name Index='12'>D12</Name>
      <Name Index='13'>D13</Name>
      <Name Index='14'>D14</Name>
      <Name Index='15'>D15</Name>
   </Names>
</BusSignal>


<BusSignals> Element

The <BusSignals> element contains oscilloscope channel signal definitions.

Children

This element can have the following children: <Folder>.

Parents

This element can have the following parents: <BusSignalSetup>.

Example

<BusSignals>
   <Clear />
   <Folder Name='Channel 1'>
      <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
         <Channels>C1</Channels>
      </BusSignal>
   </Folder>
   <Folder Name='Channel 2'>
      <BusSignal Name='My Scope C2' Enabled='T' Color='h00FF00'>
         <Channels>C2</Channels>
      </BusSignal>
   </Folder>
   <Folder Name='Digital Channels' Enabled='T' Color='h00FFFF'>
      <BusSignal Name='My Scope D15-0' DefaultLabel='T'>
         <Channels>D[15:0]</Channels>
            <Names>
               <Name Index='0'>D0</Name>
               <Name Index='1'>D1</Name>
               <Name Index='2'>D2</Name>
               <Name Index='3'>D3</Name>
               <Name Index='4'>D4</Name>
               <Name Index='5'>D5</Name>
               <Name Index='6'>D6</Name>
               <Name Index='7'>D7</Name>
               <Name Index='8'>D8</Name>
               <Name Index='9'>D9</Name>
               <Name Index='10'>D10</Name>
               <Name Index='11'>D11</Name>
               <Name Index='12'>D12</Name>
               <Name Index='13'>D13</Name>
               <Name Index='14'>D14</Name>
            <Name Index='15'>D15</Name>
         </Names>
      </BusSignal>
   </Folder>
</BusSignals>


<BusSignalSetup> Element

The <BusSignalSetup> element contains a <BusSignals> element.

Children

This element can have the following children: <BusSignals>.

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<BusSignalSetup>
   <BusSignals>
      <Clear />
      <Folder Name='Channel 1'>
         <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
            <Channels>C1</Channels>
         </BusSignal>
      </Folder>
      <Folder Name='Channel 2'>
         <BusSignal Name='My Scope C2' Enabled='T' Color='h00FF00'>
            <Channels>C2</Channels>
         </BusSignal>
      </Folder>
      <Folder Name='Digital Channels' Enabled='T' Color='h00FFFF'>
         <BusSignal Name='My Scope D15-0' DefaultLabel='T'>
            <Channels>D[15:0]</Channels>
               <Names>
                  <Name Index='0'>D0</Name>
                  <Name Index='1'>D1</Name>
                  <Name Index='2'>D2</Name>
                  <Name Index='3'>D3</Name>
                  <Name Index='4'>D4</Name>
                  <Name Index='5'>D5</Name>
                  <Name Index='6'>D6</Name>
                  <Name Index='7'>D7</Name>
                  <Name Index='8'>D8</Name>
                  <Name Index='9'>D9</Name>
                  <Name Index='10'>D10</Name>
                  <Name Index='11'>D11</Name>
                  <Name Index='12'>D12</Name>
                  <Name Index='13'>D13</Name>
                  <Name Index='14'>D14</Name>
               <Name Index='15'>D15</Name>
            </Names>
         </BusSignal>
      </Folder>
   </BusSignals>
</BusSignalSetup>


<Channel1/2/3/4> Element

The <Channel1/2/3/4> element describes the part of the binary data file that contains a particular oscilloscope channel's data.

Attributes

Name | Description
MaxVoltage | 'floating_point_number' (maximum voltage for the full acquisition of this channel, represented in volts)
MinVoltage | 'floating_point_number' (minimum voltage for the full acquisition of this channel, represented in volts)
NumBytesPerSample | 'number' (number of bytes per sample in the oscilloscope data)
NumSamples | 'number' (number of "points" or samples in the oscilloscope data)
Valid | 'F' (false) or 'T' (true, when data is valid)
XInc | 'floating_point_number' (the X coordinate increment value in seconds)
XOrg | 'floating_point_number' (the X origin's value in seconds)
XRef | 'number' (the X coordinate value associated with the X origin)
YInc | 'floating_point_number' (the Y coordinate increment value in volts)
YOrg | 'floating_point_number' (the Y origin's value in volts)
YRef | 'number' (the Y coordinate value associated with the Y origin)

Children

This element can have the following children: <Channel1/2/3/4DataTable>.

Parents

This element can have the following parents: <Data>.

Example

<Channel1 Valid='T' XInc='5.000000e-010' XOrg='-2.619995e-004' XRef='0'
      YInc='1.562500e-001' YOrg='-8.550000e+000' YRef='0'
      MinVoltage='-3.080000e+000' MaxVoltage='5.670000e+000'
      NumBytesPerSample='1' NumSamples='1048000'>
   <Channel1DataTable RowCount='1048000' TriggerIndex='523999'
         OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
         FileName='ext_scope_data02of02.mfb'>
      <AnalogDataSource Type='Page'>
         <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
               YOrg='-8.55' YRef='0' FileOffset='0'/>
      </AnalogDataSource>
      <TimeDataSource Type='Periodic'>
         <SetupInfo RowCount='1048000' TriggerIndex='523999'
               SamplePeriod='500 ps'/>
      </TimeDataSource>
      <SampleNumberDataSource Type='Periodic'>
         <SetupInfo RowCount='1048000' TriggerIndex='523999'
               SamplePeriod='1'/>
      </SampleNumberDataSource>
   </Channel1DataTable>
</Channel1>


<Channel1/2/3/4DataTable> Element

The <Channel1/2/3/4DataTable> element describes the part of the binary data file that contains a particular oscilloscope channel's data.

Attributes

Name | Description
FileName | 'relative_path_file_name'
OffsetTime | 'number time_unit'
RowCount | 'number'
TimePrecision | 'number time_unit'
TriggerIndex | 'number'

Children

This element can have the following children: <AnalogDataSource>, <TimeDataSource>, <SampleNumberDataSource>.

Parents

This element can have the following parents: <Data>.

Example

<Channel1DataTable RowCount='1048000' TriggerIndex='523999'
      OffsetTime='99.966666666667 ns' TimePrecision='1 ps'
      FileName='ext_scope_data02of02.mfb'>
   <AnalogDataSource Type='Page'>
      <SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
            YOrg='-8.55' YRef='0' FileOffset='0'/>
   </AnalogDataSource>
   <TimeDataSource Type='Periodic'>
      <SetupInfo RowCount='1048000' TriggerIndex='523999'
            SamplePeriod='500 ps'/>
   </TimeDataSource>
   <SampleNumberDataSource Type='Periodic'>
      <SetupInfo RowCount='1048000' TriggerIndex='523999'
            SamplePeriod='1'/>
   </SampleNumberDataSource>
</Channel1DataTable>


<Channels> Element

The <Channels> element specifies the oscilloscope channel assigned to the signal name.

Data

This element's data is a string representing the oscilloscope channel for the signal.

Parents

This element can have the following parents: <BusSignal>.

Example

<Channels>1</Channels>


<ChannelsSetup> Element

The <ChannelsSetup> element describes the external oscilloscope channels setup options.

Attributes

Name | Description
MemoryDepth | 'number' (the number of oscilloscope data samples to import)
NumChannels | 'number' (the number of oscilloscope channels)
SaveScopeSetup | 'F' (false) or 'T' (true)

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<ChannelsSetup NumChannels='2' SaveScopeSetup='T'
      MemoryDepth='1048576'/>


<ConnectionSetup> Element

The <ConnectionSetup> element describes the oscilloscope connection options.

Attributes

Name | Description
LAProbe | 'LAProbeGrabber', 'LAProbeMictor', 'LAProbeSamtec', or 'LAProbeSocket' (the probe connection from the analyzer to the deskewing signal)
Name | 'string' (hostname of the oscilloscope to connect to)
ScopeProbe | '100-pin probe', '38-pin probe', 'Flying Lead probe', or 'ScopeProbeGrabber' (the probe connection from the oscilloscope to the deskewing signal)

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<ConnectionSetup
      Name='130.29.68.220'
      LAProbe='LAProbeSocket'
      ScopeProbe='ScopeProbeGrabber'
/>


<Data> Element

When data and setup information are saved to XML format configuration files, the <Data> element contains information about the binary data files that are saved.

Children

This element can have the following children: <Channel1/2/3/4>, <DigitalChannels>.

Parents

This element can have the following parents: <Module>.

Example

<Data>
   <Channel1 Valid='T' XInc='5.000000e-010' XOrg='-2.668685e-004'
         XRef='0' YInc='6.250000e-002' YOrg='-4.984000e+000' YRef='0'
         MinVoltage='-1.047000e+000' MaxVoltage='2.016000e+000'
         NumBytesPerSample='1' NumSamples='1048600'>
      <Channel1DataTable RowCount='1048600' TriggerIndex='533737'
            OffsetTime='54 ns' TimePrecision='1 ps'
            FileName='ViewScope2_data03of04.mfb'>
         <AnalogDataSource Type='Page'>
            <SetupInfo RowCount='1048600' PageSize='49152'
                  YInc='0.0625' YOrg='-4.984' YRef='0' YMin='-1.047'
                  YMax='2.016' FileOffset='0' />
         </AnalogDataSource>
         <TimeDataSource Type='Periodic'>
            <SetupInfo RowCount='1048600' TriggerIndex='533737'
                  SamplePeriod='500 ps' />
         </TimeDataSource>
         <SampleNumberDataSource Type='Periodic'>
            <SetupInfo RowCount='1048600' TriggerIndex='533737'
                  SamplePeriod='1' />
         </SampleNumberDataSource>
      </Channel1DataTable>
   </Channel1>
   <Channel2 Valid='T' XInc='5.000000e-010' XOrg='-2.668680e-004'
         XRef='0' YInc='1.562500e-001' YOrg='2.000000e-001' YRef='0'
         MinVoltage='-2.460000e+000' MaxVoltage='5.360000e+000'
         NumBytesPerSample='1' NumSamples='1048600'>
      <Channel2DataTable RowCount='1048600' TriggerIndex='533736'
            OffsetTime='0 s' TimePrecision='10 ps'
            FileName='ViewScope2_data03of04.mfb'>
         <AnalogDataSource Type='Page'>
            <SetupInfo RowCount='1048600' PageSize='49152'
                  YInc='0.15625' YOrg='0.2' YRef='0' YMin='-2.46'
                  YMax='5.36' FileOffset='2097200' />
         </AnalogDataSource>
         <TimeDataSource Type='Periodic'>
            <SetupInfo RowCount='1048600' TriggerIndex='533736'
                  SamplePeriod='500 ps' />
         </TimeDataSource>
         <SampleNumberDataSource Type='Periodic'>
            <SetupInfo RowCount='1048600' TriggerIndex='533736'
                  SamplePeriod='1' />
         </SampleNumberDataSource>
      </Channel2DataTable>
   </Channel2>
   <DigitalChannels>
      <WaveformData>
         <Pod1 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
               XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
               YRef='0' MinVoltage='0.000000e+000'
               MaxVoltage='0.000000e+000' NumBytesPerSample='1'
               NumSamples='524300' />
         <Pod2 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
               XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
               YRef='0' MinVoltage='0.000000e+000'
               MaxVoltage='0.000000e+000' NumBytesPerSample='1'
               NumSamples='524300' />
      </WaveformData>
      <DigitalChannelsDataTable RowCount='524300' TriggerIndex='266849'
            OffsetTime='0 s' TimePrecision='10 ps'
            FileName='ViewScope2_data03of04.mfb'>
         <DigitalDataSource Type='Page'>
            <SetupInfo RowCount='524300' BitsPerSample='16'
                  PageSize='49152' BitsPerBonusBit='16'
                  FileOffset='4194400' />
         </DigitalDataSource>
         <TimeDataSource Type='Periodic'>
            <SetupInfo RowCount='524300' TriggerIndex='266849'
                  SamplePeriod='1 ns' />
         </TimeDataSource>
         <SampleNumberDataSource Type='Periodic'>
            <SetupInfo RowCount='524300' TriggerIndex='266849'
                  SamplePeriod='1' />
         </SampleNumberDataSource>
      </DigitalChannelsDataTable>
   </DigitalChannels>
</Data>

Binary Data File Format

For the external oscilloscope module, there is a single binary data file that contains the module’s sample number, voltage, and time data. Each channel's data is stored contiguously, with the XML elements under <Data> pointing to the byte offsets within the file for each channel. Data is dumped simply by sample/row, starting with the first sample of data, all the way through the last.

If the XML with data file is read back into the system, the paging information in the XML file is used to load the data by pages to increase performance. There is no checksumming of any kind on the data, so data integrity is assumed to be valid whenever these files are loaded. If the file is altered in any way, it should be kept consistent with the format described.

If you are interested in processing the binary data files saved with XML format configuration files, please contact Agilent Technologies (http://www.agilent.com/find/contactus) for sample parsing code.


<DigitalChannels> Element

The <DigitalChannels> element describes the part of the binary data file that contains a particular oscilloscope's digital channels data.

Children

This element can have the following children: <WaveformData>, <DigitalChannelsDataTable>.

Parents

This element can have the following parents: <Data>.

Example

<DigitalChannels>
   <WaveformData>
      <Pod1 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
            XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
            YRef='0' MinVoltage='0.000000e+000'
            MaxVoltage='0.000000e+000' NumBytesPerSample='1'
            NumSamples='524300' />
      <Pod2 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
            XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
            YRef='0' MinVoltage='0.000000e+000'
            MaxVoltage='0.000000e+000' NumBytesPerSample='1'
            NumSamples='524300' />
   </WaveformData>
   <DigitalChannelsDataTable RowCount='524300' TriggerIndex='266849'
         OffsetTime='0 s' TimePrecision='10 ps'
         FileName='ViewScope2_data03of04.mfb'>
      <DigitalDataSource Type='Page'>
         <SetupInfo RowCount='524300' BitsPerSample='16'
               PageSize='49152' BitsPerBonusBit='16'
               FileOffset='4194400' />
      </DigitalDataSource>
      <TimeDataSource Type='Periodic'>
         <SetupInfo RowCount='524300' TriggerIndex='266849'
               SamplePeriod='1 ns' />
      </TimeDataSource>
      <SampleNumberDataSource Type='Periodic'>
         <SetupInfo RowCount='524300' TriggerIndex='266849'
               SamplePeriod='1' />
      </SampleNumberDataSource>
   </DigitalChannelsDataTable>
</DigitalChannels>


<DigitalChannelsDataTable> Element

The <DigitalChannelsDataTable> element describes the part of the binary data file that contains a particular oscilloscope's digital channels data.

Attributes

Name | Description
FileName | 'relative_path_file_name'
OffsetTime | 'number time_unit'
RowCount | 'number'
TimePrecision | 'number time_unit'
TriggerIndex | 'number'

Children

This element can have the following children: <DigitalDataSource>, <TimeDataSource>, <SampleNumberDataSource>.

Parents

This element can have the following parents: <DigitalChannels>.

Example

<DigitalChannelsDataTable RowCount='524300' TriggerIndex='266849'
      OffsetTime='0 s' TimePrecision='10 ps'
      FileName='ViewScope2_data03of04.mfb'>
   <DigitalDataSource Type='Page'>
      <SetupInfo RowCount='524300' BitsPerSample='16'
            PageSize='49152' BitsPerBonusBit='16'
            FileOffset='4194400' />
   </DigitalDataSource>
   <TimeDataSource Type='Periodic'>
      <SetupInfo RowCount='524300' TriggerIndex='266849'
            SamplePeriod='1 ns' />
   </TimeDataSource>
   <SampleNumberDataSource Type='Periodic'>
      <SetupInfo RowCount='524300' TriggerIndex='266849'
            SamplePeriod='1' />
   </SampleNumberDataSource>
</DigitalChannelsDataTable>


<DigitalDataSource> Element

The <DigitalDataSource> element contains information about the external oscilloscope's digital data column in the binary data file.

Attributes

Name | Description
Type | 'Page'

Children

This element can have the following children: <SetupInfo> (for DigitalDataSource).

Parents

This element can have the following parents: <DigitalChannelsDataTable>.

Example

<DigitalDataSource Type='Page'>
   <SetupInfo RowCount='524300' BitsPerSample='16'
         PageSize='49152' BitsPerBonusBit='16'
         FileOffset='4194400' />
</DigitalDataSource>


<Folder> Element

The <Folder> element contains the bus/signal definition for an oscilloscope channel.

Attributes

Name | Description
Name | 'string'

Children

This element can have the following children: <BusSignal>.

Parents

This element can have the following parents: <BusSignals>.

Example

<Folder Name='Channel 1'>
   <BusSignal Name='My Scope C1' Enabled='T' Color='hFFFF00'>
      <Channels>1</Channels>
   </BusSignal>
</Folder>


<Markers> Element

The <Markers> element describes the Ax and Bx oscilloscope marker times relative to the system trigger.

Attributes

Name | Description
MarkerAxTime | 'floating_point_number' (relative to system trigger)
MarkerBxTime | 'floating_point_number' (relative to system trigger)

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<Markers
      MarkerAxTime='-0.000000005313333333333328'
      MarkerBxTime='0.000000018166666666666672'
/>


<Name> Element

The <Name> element gives a name to an individual digital channel imported from an external oscilloscope.

Attributes

Name | Description
Index | 'number'

Parents

This element can have the following parents: <Names>.

Example

<Name Index='0'>D0</Name>


<Names> Element

The <Names> element contains the names of the digital channels imported from an external oscilloscope.

Children

This element can have the following children: <Name>.

Parents

This element can have the following parents: <BusSignal>.

Example

<Names>
   <Name Index='0'>D0</Name>
   <Name Index='1'>D1</Name>
   <Name Index='2'>D2</Name>
   <Name Index='3'>D3</Name>
   <Name Index='4'>D4</Name>
   <Name Index='5'>D5</Name>
   <Name Index='6'>D6</Name>
   <Name Index='7'>D7</Name>
   <Name Index='8'>D8</Name>
   <Name Index='9'>D9</Name>
   <Name Index='10'>D10</Name>
   <Name Index='11'>D11</Name>
   <Name Index='12'>D12</Name>
   <Name Index='13'>D13</Name>
   <Name Index='14'>D14</Name>
   <Name Index='15'>D15</Name>
</Names>


<Pod1/2> Element

The <Pod1/2> element describes the part of the binary data file that contains a particular oscilloscope's digital data.

Attributes

Name | Description
MaxVoltage | 'floating_point_number' (maximum voltage for the full acquisition of this pod, represented in volts)
MinVoltage | 'floating_point_number' (minimum voltage for the full acquisition of this pod, represented in volts)
NumBytesPerSample | 'number' (number of bytes per sample in the oscilloscope data)
NumSamples | 'number' (number of "points" or samples in the oscilloscope data)
Valid | 'F' (false) or 'T' (true, when data is valid)
XInc | 'floating_point_number' (the X coordinate increment value in seconds)
XOrg | 'floating_point_number' (the X origin's value in seconds)
XRef | 'number' (the X coordinate value associated with the X origin)
YInc | 'floating_point_number' (the Y coordinate increment value in volts)
YOrg | 'floating_point_number' (the Y origin's value in volts)
YRef | 'number' (the Y coordinate value associated with the Y origin)

Parents

This element can have the following parents: <Data>.

Example

<Pod1 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
      XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
      YRef='0' MinVoltage='0.000000e+000'
      MaxVoltage='0.000000e+000' NumBytesPerSample='1'
      NumSamples='524300' />
<Pod2 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
      XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
      YRef='0' MinVoltage='0.000000e+000'
      MaxVoltage='0.000000e+000' NumBytesPerSample='1'
      NumSamples='524300' />


<Programming> Element

The <Programming> element describes oscilloscope and logic analyzer setup information.

Attributes

Name | Description
LATrigState | 'string' (the XML trigger specification for the logic analyzer to do auto-deskew in state mode)
LATrigTiming | 'string' (the XML trigger specification for the logic analyzer to do auto-deskew in timing mode)
ScopeEdgeSource | 'Channel1', 'Channel2', 'Channel3', or 'Channel4', (the edge source for the deskewing signal)
ScopeTrigMode | 'TriggerModeAdvanced', 'TriggerModeEdge', or 'TriggerModeGlitch' (the oscilloscope's trigger mode for deskewing)
ScopeTrigSweep | 'TriggerSweepAuto', 'TriggerSweepSingle', or 'TriggerSweepTriggered' (the oscilloscope's trigger sweep setting for deskewing)
ScopeAuxExtEdgeSlope | 'SlopeNegative' or 'SlopePositive' (the slope for the oscilloscope's deskewing signal)
ScopeAuxExtTrigLevel | 'floating_point_number'

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<Programming
   ScopeTrigSweep='TriggerSweepSingle'
   ScopeTrigMode='TriggerModeEdge'
   ScopeEdgeSource='Channel1'
   ScopeAuxExtEdgeSlope='SlopePositive'
   ScopeAuxExtTrigLevel='0.000000e+000'
   LATrigTiming='
&lt;Module&gt;
   &lt;Trigger Mode=&quot;Timing&quot;&gt;
      &lt;Sequence Level=&quot;1&quot;&gt;
         &lt;If&gt;
            &lt;Event&gt;
               &lt;Anything/&gt;
            &lt;/Event&gt;
            &lt;Occurrence Value=&quot;1&quot;/&gt;
            &lt;Action&gt;
               &lt;TriggerAction Operator=&quot;Fill Memory&quot;/&gt;
            &lt;/Action&gt;
         &lt;/If&gt;
      &lt;/Sequence&gt;
   &lt;/Trigger&gt;
&lt;/Module&gt;
   '
   LATrigState='
&lt;Module&gt;
   &lt;Trigger Mode=&quot;State&quot;&gt;
      &lt;StoreQual&gt;
         &lt;Event&gt;
            &lt;Anything/&gt;
         &lt;/Event&gt;
      &lt;/StoreQual&gt;
      &lt;Sequence Level=&quot;1&quot;&gt;
         &lt;If&gt;
            &lt;Event&gt;
               &lt;Anything/&gt;
            &lt;/Event&gt;
            &lt;Occurrence Value=&quot;1&quot;/&gt;
            &lt;Action&gt;
               &lt;TriggerAction Operator=&quot;Fill Memory&quot;&gt;
                  &lt;StoreQual&gt;
                     &lt;Event&gt;
                        &lt;Anything/&gt;
                     &lt;/Event&gt;
                  &lt;/StoreQual&gt;
               &lt;/TriggerAction&gt;
            &lt;/Action&gt;
         &lt;/If&gt;
      &lt;/Sequence&gt;
   &lt;/Trigger&gt;
&lt;/Module&gt;
   '
/>


<SampleNumberDataSource> Element

The <SampleNumberDataSource> element contains information about the external oscilloscope channel's sample number column in the binary data file.

Attributes

Name | Description
Type | 'Periodic'

Children

This element can have the following children: <SetupInfo> (for SampleNumberDataSource).

Parents

This element can have the following parents: <Channel1/2/3/4DataTable>.

Example

<SampleNumberDataSource Type='Periodic'>
   <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>
</SampleNumberDataSource>


<SetupInfo> Element (for AnalogDataSource)

The <SetupInfo> element contains additional setup information for the <AnalogDataSource> element.

Attributes

Name | Description
FileOffset | 'number' (bytes within the binary data file where the data begins)
PageSize | 'number' (of bits per page of data)
RowCount | 'number' (of samples)
YInc | 'floating_point_number' (the Y coordinate increment value in volts)
YOrg | 'floating_point_number' (the Y origin's value in volts)
YRef | 'number' (the Y coordinate value associated with the Y origin)

Parents

This element can have the following parents: <AnalogDataSource>.

Example

<SetupInfo RowCount='1048000' PageSize='49152' YInc='0.15625'
      YOrg='-8.55' YRef='0' FileOffset='0'/>


<SetupInfo> Element (for DigitalDataSource)

The <SetupInfo> element contains additional setup information for the <DigitalDataSource> element.

Attributes

Name | Description
BitsPerBonusBit | 'number'
BitsPerSample | 'number'
FileOffset | 'number' (bytes within the binary data file where the data begins)
PageSize | 'number' (of bits per page of data)
RowCount | 'number' (of samples)

Parents

This element can have the following parents: <DigitalDataSource>.

Example

<SetupInfo RowCount='524300' BitsPerSample='16'
      PageSize='49152' BitsPerBonusBit='16'
      FileOffset='4194400' />


<SetupInfo> Element (for SampleNumberDataSource)

The <SetupInfo> element contains additional setup information for the <SampleNumberDataSource> element.

Attributes

Name | Description
RowCount | 'number' (of samples)
SamplePeriod | '1'
TriggerIndex | 'number' (zero-based)

Parents

This element can have the following parents: <SampleNumberDataSource>.

Example

<SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='1'/>


<SetupInfo> Element (for TimeDataSource)

The <SetupInfo> element contains additional setup information for the <TimeDataSource> element.

Attributes

Name | Description
RowCount | 'number' (of samples)
SamplePeriod | 'number time_unit' (sampling period for the timing data)
TriggerIndex | 'number' (zero-based)

Parents

This element can have the following parents: <TimeDataSource>.

Examples

<SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>


<TimeDataSource> Element

The <TimeDataSource> element contains information about the external oscilloscope channel's time column in the binary data file.

Attributes

Name | Description
Type | 'Periodic'

Children

This element can have the following children: <SetupInfo> (for TimeDataSource).

Parents

This element can have the following parents: <Channel1/2/3/4DataTable>.

Examples

<TimeDataSource Type='Periodic'>
   <SetupInfo RowCount='1048000' TriggerIndex='523999' SamplePeriod='500 ps'/>
</TimeDataSource>


<TriggerSetup> Element

The <TriggerSetup> element describes the external oscilloscope trigger options.

Attributes

Name | Description
Analyzer | 'string' (name of logic analyzer module the oscilloscope is associated with)
AutoDeskew | 'F' (false) or 'T' (true)
AutoDeskewExtIntTime | 'floating_point_number' (the deskew time for the oscilloscope triggering the logic analyzer)
AutoDeskewIntExtTime | 'floating_point_number' (the deskew time for the logic analyzer triggering the oscilloscope)
ManualDeskewExtIntTime | 'floating_point_number' (the deskew time for the oscilloscope triggering the logic analyzer)
ManualDeskewIntExtTime | 'floating_point_number' (the deskew time for the logic analyzer triggering the oscilloscope)
TriggerDirection | 'LATrigScope' or 'ScopeTrigLA'

Parents

This element can have the following parents: <Module>.

When used in COM automation, this element is returned by the QueryCommand method's GetAllSetup query. You can also use this element string as an XMLCommand with the DoCommands method to configure the External Oscilloscope module.

Example

<TriggerSetup
      TriggerDirection='LATrigScope'
      AutoDeskew='T'
      Analyzer='My 1682D-1'
      AutoDeskewIntExtTime='9.996667e-008'
      AutoDeskewExtIntTime='-1.150000e-008'
      ManualDeskewIntExtTime='9.996667e-008'
      ManualDeskewExtIntTime='-1.150000e-008'
/>


<WaveformData> Element

The <WaveformData> element contains information about the data associated with the oscilloscope's digital channels.

Children

This element can have the following children: <Pod1/2>.

Parents

This element can have the following parents: <DigitalChannels>.

Example

<WaveformData>
   <Pod1 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
         XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
         YRef='0' MinVoltage='0.000000e+000'
         MaxVoltage='0.000000e+000' NumBytesPerSample='1'
         NumSamples='524300' />
   <Pod2 Valid='T' XInc='1.000000e-009' XOrg='-2.668490e-004'
         XRef='0' YInc='1.000000e+000' YOrg='0.000000e+000'
         YRef='0' MinVoltage='0.000000e+000'
         MaxVoltage='0.000000e+000' NumBytesPerSample='1'
         NumSamples='524300' />
</WaveformData>


Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies' standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.


Safety Notices

[Caution]

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

[Warning]

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.


Technology License

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.


Trademarks

Microsoft®, MS-DOS®, Windows®, Windows 2000®, and Windows XP® are U.S. registered trademarks of Microsoft Corporation.

Adobe®, Acrobat®, and the Acrobat Logo® are trademarks of Adobe Systems Incorporated.


Warranty

The material contained in this document is provided "as is," and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.