汎用プローブを使用する

汎用プローブを使用すると、以下のようにプローブを定義できます。

  • 被試験デバイスからのピン/パッド数を、ポッド数やチャネル数と一緒に、Bus/Signalタブに表示する。

    これにより、プローブのピン・マッピングを理解する必要なく、スケマティックまたはネットリストからバスと信号を直接定義できます。

  • ポッド接続を文書化する。

    例えば、被試験デバイスの"J1"に接続しているプローブを、Slot A Pod 1とSlot A Pod 2に接続するとします。"J1"を定義すると、対応するポッドが構成ファイルに保存されます。ポッドを再接続する必要がある場合、System Summaryダイアログを開き、どのポッドをどのプローブに差し込むかを指示するProbe Summarｙタブをプリントアウトします。

  • ASCIIネットリスト・ファイルのインポートによって、バス/信号名を割り当てできるようにする。

汎用プローブの使用方法については、以下を参照してください。

  • プローブを定義するには
  • プローブを編集するには
  • プローブを削除するには

関連項目

  • プローブ・コントロール、COMオートメーション
  • プローブ・セットアップ、XMLフォーマット

© Agilent Technologies, Inc. 2001-2004


プローブを定義するには

  1. メイン・メニューから、Setup>(ロジック・アナライザ・モジュール)>New Probe>General Purpose Probeを選択します。

    または、Overviewウィンドウで、ロジック・アナライザ・モジュールのドロップダウン・メニューから、New Probe>General Purpose Probeを選択します。

  2. General Purpose Probe Setダイアログで、被試験デバイス内のボード接続と関連付けるプローブを定義します。

    各プローブに対して:

    1. 追加するプローブのタイプを選択し、Add Probe...をクリックします。

      使用プローブがリストに表示されない場合、Webから最新プローブ定義をダウンロードできます。

      新しいプローブ・タイプを定義するため、XMLフォーマット・ファイルを編集することもできます。

      2. General Purpose Probe Editダイアログで、被試験デバイス内の接続の参照識別子を入力し、プローブに接続するロジック・アナライザのポッドを選択します。

      マウス・ポインタをピン説明フィールドに置くと、割り当てられたバス/信号、ポッド接続、チャネル番号、信号タイプ（シングル・エンドまたは差動）を説明したツールのヒントが表示されます。

      クロック入力のピン番号には、"Clk"というラベルが付いています。

    2. OKをクリックします。

  3. OKをクリックして、Define Probesダイアログを閉じます。

関連項目

  • ネットリスト・ファイルのインポートによりバスと信号を定義するには
  • ポッドとチャネルの命名規則
  • 新しいプローブ・タイプを定義するには


General Purpose Probe Setダイアログ

ネットリスト・ファイルからバス/信号名をインポートし、ロジック・アナライザのチャネルに割り当てるには、Define Probesダイアログを使って、ロジック・アナライザと一緒に使用するプローブを識別する必要があります。

Reference Designator | プローブに対する、被試験デバイス内のボード接続を識別します。
Probe Type | プローブが、ロジック・アナライザのポッドを被試験デバイス内のコネクタに接続します。もっとも一般的に使用されるプローブは、2つのポッドに接続します。プローブ・タイプは、プローブのAgilentモデル番号（例えば、E5346A）です。 使用プローブがリストに表示されない場合、Webから最新プローブ定義をダウンロードできます。 新しいプローブ・タイプを定義するため、XMLフォーマット・ファイルを編集することもできます。
Logic Analyzer Pod | ロジック・アナライザからのチャネルの集合です。

Add Probe... | プローブ定義を追加するための、General Purpose Probe Editダイアログが開きます。
Edit Probe... | 選択したプローブ定義を編集するための、General Purpose Probe Editダイアログが開きます。
Delete Probe | 選択したプローブ定義を削除します。

関連項目

  • プローブを定義するには


General Purpose Probe Editダイアログ

General Purpose Probe Editダイアログで、被試験デバイスのコネクタ（参照識別子）と、プローブに接続されたロジック・アナライザのポッドを識別できます。

Reference Designator | プローブ・コネクタ、コネクタレス・プローブ保持モジュール、フライング・リードによってプローブされるピンの（被試験デバイスにおける）参照識別子を識別します。
Probe Pin/Pad Diagram | プローブ・ピン/パッド、フライング・リード・チャネル、または終端アダプタ・ピンを図で示し、チャネル情報ツールのヒントのためのフィールドを提供します。
Logic Analyzer Slot, Pod | プローブ、フライング・リード、または終端アダプタを接続する、ロジック・アナライザ・モジュールのスロット/ポッドを選択できます。
Show Logic Analyzer Channels | チェックすると、プローブ・ピン/パッド・ダイアグラムで、ピン/パッド番号の横にロジック・アナライザのポッド・チャネル番号が表示されます。

関連項目

  • プローブを定義するには


プローブを編集するには

  1. メイン・メニューから、Setup>(ロジック・アナライザ・モジュール)>(汎用プローブ名)>Propertiesを選択します。

    または、Overviewウィンドウで、汎用プローブのPropertiesボタンをクリックします。

  2. General Purpose Probe Setダイアログで、編集するプローブを選択し、Edit Probe...をクリックします。

  3. General Purpose Probe Editダイアログで、参照識別子の変更や、プローブに接続するロジック・アナライザのポッドの再指定が行えます。

  4. OKをクリックして、General Purpose Probe Editダイアログを閉じます。

  5. OKをクリックして、General Purpose Probe Setダイアログを閉じます。

関連項目

  • プローブを定義するには


プローブを削除するには

  1. メイン・メニューから、Setup>(ロジック・アナライザ・モジュール)>(汎用プローブ名)>Propertiesを選択します。または、Overviewウィンドウで、汎用プローブのPropertiesボタンをクリックします。

  2. General Purpose Probe Setダイアログで、削除するプローブを選択し、Delete Probeをクリックします。

  3. OKをクリックして、Define Probesダイアログを閉じます。

関連項目

  • プローブを定義するには


プローブ・コントロール、COMオートメーション

Agilent Logic Analyzerアプリケーションには、COM Automation Serverが含まれています。このソフトウェアを使用すると、ローカル・エリア・ネットワーク（LAN）上のリモート・コンピュータからAgilent Logic Analyzerアプリケーションを制御するプログラムを記述できます。

COMオートメーション・プログラムでは、以下の方法でプローブを構成できます。

  • （ロジック・アナライザのセットアップ全体を構成する）構成ファイルをロードする。

  • ProbeオブジェクトのDoCommandsメソッドをXMLフォーマット文字列パラメータ付きで使用する（プローブ・セットアップ、XMLフォーマットを参照してください）。

ProbeオブジェクトのQueryCommandメソッドを使って、プローブの構成に関する情報を取得できます。以下に、汎用プローブによってサポートされる問合せを示します。

ロジック・アナライザのCOMオートメーションとProbeオブジェクトの一般的な詳細については、COMオートメーションを参照してください。

サポートされているXMLベースの問合せ

汎用プローブは、次の（ProbeオブジェクトのQueryCommandメソッドによって作成された）XMLベースの問合せをサポートしています。

問合せ | 説明
GetAllSetup | 現在のセットアップを返します。フル・タグ・セットを使用します。汎用構成ファイルの記述に使用されます（XMLフォーマットの<Properties>要素を参照してください）。
GetProperties | 現在のセットアップを返します。フル・タグ・セットを使用します。"GetAllSetup"と同じです（XMLフォーマットの<Properties>要素を参照してください）。

関連項目

  • COMオートメーション
  • プローブ・セットアップ、XMLフォーマット


プローブ・セットアップ、XMLフォーマット

ロジック・アナライザの構成をXMLフォーマット・ファイルへ保存するときには、汎用プローブのセットアップ情報が含まれます。

XMLフォーマット・セットアップ情報は、ロジック・アナライザをリモート・コンピュータから制御するため、COMオートメーション・プログラムを記述するときにも使用されます。

汎用プローブのXML要素には、次の階層があります。

<Properties>
   <DefinedProbes>
      <Probe>
         <Pods>
            <Pod>

関連項目

  • XMLフォーマット
  • プローブ・コントロール、COMオートメーション


<DefinedProbes>要素

<DefinedProbes>要素は、定義されたプローブを含みます。

子

この要素は、次の子を持つことができます。<Probe>

親

この要素は、次の親を持つことができます。<Properties>

例

<DefinedProbes>
   <Probe Name='J1' Type='E5346A 34-ch Mictor single-ended probe'>
      <Pods>
         <Pod Index='1'/>
         <Pod Index='2'/>
      </Pods>
      <Signals/>
   </Probe>
   <Probe Name='J2' Type='E5346A 34-ch Mictor single-ended probe'>
      <Pods>
         <Pod Index='3'/>
         <Pod Index='4'/>
      </Pods>
      <Signals/>
   </Probe>
</DefinedProbes>


<Pod>要素

<Pod>要素は、定義されたプローブ内で使用されるポッド・インデックスを記述します。

属性

名前 | 説明
Index | '数値'

親

この要素は、次の親を持つことができます。<Pods>

例

<Pod Index='1'/>


<Pods>要素

<Pods>要素は、定義されたプローブによって使用されるポッドを含みます。

子

この要素は、次の子を持つことができます。<Pod>

親

この要素は、次の親を持つことができます。<Probe>

例

<Pods>
   <Pod Index='1'/>
   <Pod Index='2'/>
</Pods>


<Probe>要素

<Probe>要素は、定義されたプローブを記述します。

属性

名前 | 説明
Name | '文字列'（被試験デバイス内のコネクタの名前）
Type | '文字列'（プローブの名前）

子

この要素は、次の子を持つことができます。<Pods>

親

この要素は、次の親を持つことができます。<DefinedProbes>

例

<Probe Name='J1' Type='E5346A 34-ch Mictor single-ended probe'>
   <Pods>
      <Pod Index='1'/>
      <Pod Index='2'/>
   </Pods>
   <Signals/>
</Probe>


<Properties>要素

<Properties>要素は、汎用プローブのセットアップ情報を含みます。

子

この要素は、次の子を持つことができます。<DefinedProbes>

親

この要素は、次の親を持つことができます。<Probe>

COMオートメーションで使用するとき、この要素が、QueryCommandメソッドのGetAllSetup問合せとGetProperties問合せによって返ります。汎用プローブを構成するため、この要素文字列を、DoCommandsメソッドを持つXMLCommandとして使用することもできます。

例

<Properties>
   <DefinedProbes>
      <Probe Name='J1' Type='E5346A 34-ch Mictor single-ended probe'>
         <Pods>
            <Pod Index='1'/>
            <Pod Index='2'/>
         </Pods>
         <Signals/>
      </Probe>
   </DefinedProbes>
</Properties>