F Tour

Présentation de la face avant

Voir aussi...

  • Explorez le graphique à l'aide de la souris.

  • Cliquez sur les différentes sections de la face avant pour obtenir plus d'informations.


R Tour

Présentation de la face arrière

Voir aussi...

  • Explorez ce graphique à l'aide de la souris.

  • Cliquez sur les connecteurs pour plus d'informations.


Op Model

Modèle de fonctionnement de l'analyseur

Voir aussi...

L'analyseur dispose du modèle de fonctionnement suivant pour effectuer les mesures.

Voie

Trace

Fenêtre

Limites de fonctionnement

  • Une voie comporte un ensemble d'attributs indépendants associés aux données acquises.

  • Les attributs s'appliquent à toutes les traces attribuées à cette voie.

  • Vous pouvez avoir jusqu'à quatre voies indépendantes.

  • Une voie doit être actif pour modifier les paramètres.

  • Chaque trace comporte des paramètres qui affectent la présentation des données mesurées.

  • Il peut y avoir jusqu'à 16 traces sur l'analyseur. Vous pouvez toutes les attribuer à une seule voie ou les répartir entre quatre voies.

  • Une trace doit être active pour pouvoir modifier les paramètres.

  • Une fenêtre est utilisée pour afficher les traces.

  • L'analyseur peut afficher 1, 2, 3, ou 4 fenêtres sur l'écran.

1 fenêtre | 2 fenêtres
3 fenêtres | 4 fenêtres

  • Afficher des traces provenant de plusieurs voies dans une fenêtre.

  • Afficher des traces provenant de plusieurs voies dans des fenêtres multiples.

Limites de fonctionnement de l'analyseur :

  • Quatre fenêtres par écran

  • Quatre traces de données et quatre traces mémoire par fenêtre

  • 16 traces actives par écran et 16 traces mémoire par écran

  • Quatre voies de mesure indépendants


Meas Seq

Séquence de mesure de base

Voir aussi...

5. Imprimer, enregistrer ou rappeler des données

Etape 1. Configurer les mesures

Prérégler l'analyseur, créer un état de mesure et ajuster l'affichage.

Etape 2. Optimiser les mesures

Améliorer la précision et la capacité de mesure en utilisant des techniques et des fonctions.

Etape 3. Effectuer un étalonnage de mesure

Réduire les erreurs de mesure en effectuant un étalonnage.

Etape 4. Analyser des données

Analyser les résultats de mesure en utilisant des marqueurs, des opérations arithmétiques et des tests par gabarit.

Etape 5. Imprimer, enregistrer ou rappeler des données

Enregistrer ou imprimer des données de mesure.


Interface

Interface utilisateur

Voir aussi...

Interface de face avant

Accès aux fonctions de base

Accès aux boîtes de dialogue

Accès aux menus déroulants

Interface de souris

Interface de face avant : accès aux fonctions de base

Interface de face avant : accès aux boîtes de dialogue

Interface de face avant : accès aux menus déroulants

Interface de souris


Find Info

Recherche d'informations dans l'aide

Voir aussi...

Voici les sources d'informations disponibles dans l'aide :

Page d'accueil et barre d'outils

Index

Sommaire

Glossaire

Boîtes de dialogue

Liens de navigation

Page d'accueil et barre d'outils

Index

Sommaire

Glossaire

Remarque : En cliquant sur un mot affiché en vert dans le texte, vous obtiendrez sa définition tirée du glossaire.

Boîtes de dialogue

Liens de navigation


Print Topic

Imprimer la rubrique d'aide consultée

Voir aussi...


Close Help

Ferme la fenêtre d'aide

Voir aussi...


Size Position

Redimensionner ou repositionner la fenêtre d'aide

Voir aussi...

Il existe plusieurs façons de changer la taille et la position de la fenêtre d'aide.

Rétrécissement ou agrandissement proportionnel

Agrandir ou réduire

Repositionner

Rétrécissement ou agrandissement proportionnel de la fenêtre d'aide

Agrandir ou réduire la fenêtre d'aide

Repositionner la fenêtre d'aide


NewUsers

Ajouter des utilisateurs à l'analyseur de réseau

Voir aussi ...

Lorsque l'analyseur est mis en service, il ouvre automatiquement une session dans Windows 2000 en utilisant le nom d'utilisateur et le mot de passe d'administrateur par défaut. Si l'analyseur est dans l'environnement décrit ci-dessous, alors vous n'aurez que peu et même aucun problème d'administration.

  • Situé dans un environnement sécurisé

  • N'est pas contrôlé en utilisant COM sur le réseau local

  • Aucun utilisateur n'effectue de connexions réseau vers les unités de disque ou les imprimantes de l'instrument en utilisant ses propres nom d'utilisateur et mot de passe

Si l'analyseur se trouve dans un environnement qui nécessite différents niveaux d'utilisateurs, en tant qu'administrateur de l'analyseur de réseau, vous pouvez le configurer pour qu'il soit utilisé par d'autres utilisateurs avec des droits réduits. C'est-à-dire que d'autres personnes peuvent être autorisées à utiliser l'analyseur sans avoir la possibilité d'exécuter toutes les fonctions d'administration auxquelles vous avez accès en tant qu'administrateur.

  1. Dans le menu System de l'analyseur, pointez sur Configure et cliquez sur Control Panel.

  2. Faites défiler vers le bas la fenêtre Control Panel et sélectionnez l'application Users and Passwords.

  3. Dans l'onglet Users, si le bouton Add apparaît en grisé, cochez la case Users must enter a user name and password to use this computer dans la partie supérieure de la fenêtre.

  4. Cliquez sur Add pour entrer les informations concernant le nouvel utilisateur.

  5. Dans la zone de texte User name, entrez un nom d'utilisateur pour le nouvel utilisateur. Dans la zone de texte Full name, entrez le nom complet du nouvel utilisateur.

  6. Dans la zone de texte Description, entrez une description du nouvel utilisateur. Cliquez ensuite sur Next.

  7. Dans la zone de texte Password, le nouvel utilisateur doit taper un mot de passe. Le nouvel utilisateur doit taper de nouveau le mot de passe dans la zone de texte Confirm password. Cliquez ensuite sur Next.

  8. Examinez le niveau d'accès que vous souhaitez accorder à ce nouvel utilisateur. Restricted User n'est pas pris en charge actuellement.

  9. Vous pouvez choisir plusieurs autres niveaux de sécurité dans la liste Other. Une description de chacun des ces niveaux est affichée dans la liste Other lorsqu'elle est sélectionnée.

  10. Sélectionnez le niveau d'accès que vous souhaitez accorder à ce nouvel utilisateur. Cliquez ensuite sur Finish.

  11. Dans la boîte de dialogue Users for this computer, validez le nom d'utilisateur et le groupe de niveau de sécurité du nouvel utilisateur.

  12. Pour que cet utilisateur utilise l'analyseur de réseau sans entrer de mot de passe à chaque utilisation, dévalidez la case à cocher Users must enter a user name and password to use this computer.

  13. Lorsque la fenêtre Automatically Log On est affichée, le nouvel utilisateur doit taper son mot de passe dans la zone de texte Password et le taper de nouveau dans la zone de texte Confirm Password. Cliquez ensuite sur OK.

  14. Cliquez sur OK pour achever l'ajout de ce nouvel utilisateur.

  15. Dans le menu File, cliquez sur Close pour fermer le Control Panel.


Emergency

Disquette de réparation d'urgence

Voir aussi...

En cas d'endommagement du disque dur de l'analyseur, vous avez la possibilité d'en récupérer le contenu si vous avez pris soin de créer une disquette de réparation d'urgence. Vous devez créer cette disquette après avoir configuré l'instrument pour la première fois.

A cet effet, vous avez besoin d'une disquette vierge de 1,44 Mo.

Remarque : Le processus de réparation s'appuie sur les informations enregistrées dans le dossier systemroot\repair. Ne supprimez pas ce dossier et n'en modifiez pas le contenu.

Autres sources d'informations relatives au processus de réparation :

  • Si vous utilisez Windows 2000 Professional, consultez la version en ligne ou imprimée du manuel de mise en route (Getting Started) qui accompagne votre CD-ROM Windows 2000.

  • Si vous utilisez Windows 2000 Server, consultez la section "How to" sous la rubrique Disaster Recover.

Pour créer une disquette de réparation d'urgence

  1. Dans le menu System de l'analyseur, cliquez sur Windows Taskbar.

  2. Cliquez sur Start et pointez sur Programs, Accessories, System Tools, puis cliquez sur Backup.

  3. Dans le menu Tools, cliquez sur Create an Emergency Repair Disk.

  4. Cochez la case Also back up the registry to the repair directory....

  5. Suivez les instructions qui s'affichent à l'écran.


Prérégler analyseur

Voir aussi ...

Préréglage de l'analyseur

Aperçu

Conditions de
préréglage

Conditions
d'hibernation

Conditions de
mise sous tension

L'analyseur peut adopter l'une des conditions de fonctionnement suivantes.
Conditions de préréglage

Conditions d'hibernation

Conditions de mise sous tension

Lorsque vous appuyer sur la touche Preset de la face avant, l'état de l'analyseur est initialisé avec les conditions de préréglage suivantes.
Paramètres fréquentiels

Paramètres de puissance

Paramètres de balayage

Paramètres de balayage de segment

Paramètres de déclenchement

Paramètres d'affichage

Paramètres de réponse

Paramètres d'étalonnage

Paramètres de marquage

Paramètres de contrôle des limites

Paramètres du domaine temporel (Option 010 uniquement)

Paramètres d'affichage généraux

Paramètres fréquentiels :

Paramètre de mesure | S11
Fréquence de départ | 300 kHz
Fréquence de fin | 3 GHz pour le E8356A 6 GHz pour le E8357A 9 GHz pour le E8358A
Fréquence de l'onde continue | 1 GHz

Paramètres de puissance :

Puissance du port de contrôle | 0 dBm (1 mW) pour tous les modèles
Puissance du port couplée | Activé
Atténuation automatique | Activé
Valeur de l'atténuateur | 0 dB
Rampe de puissance | Désactivée
Valeur de la rampe | 0 dB/GHz

Paramètres de balayage :

Type | Fréquence linéaire
Mode | Continu
Génération | Analogique
Temps de balayage automatique | Activé
Nombre de points | 201

Paramètres de balayage de segment :

Segments actifs | 1
Fréquence de départ | 300 kHz
Fréquence de fin | 1 MHz
Nombre de points | 21
Puissance | 0 dBm
Bande de fréquence intermédiaire | 1 kHz
Temps de palier | 0 s

Paramètres de déclenchement

Source | Interne
Mode | Balayage

Paramètres d'affichage :

Format

Amplitude logarithmique

Ces paramètres nécessitent des formats lorsqu'ils sont sélectionnés :

FORMAT | ECHELLE | POSITION DE REFERENCE | VALEUR DE REFERENCE
Amplitude logarithmique | 10 dB/ | 5 | 0 dB
Phase | 10 degrés/ | 5 | 0 degré
Temps de propagation de groupe | 10 s/ | 5 | 0 s
Amplitude linéaire | 10 unités/ | 0 | 0 unité
ROS | 10 unités/ | 0 | 1 unité
Réelle | 10 unités/ | 5 | 0 unité
Imaginaire | 10 unités/ | 5 | 0 unité
Polaire | 1 unité/ | sans objet | 1 unité
Abaque de Smith | 1 unité/ | sans objet | 1 unité

Paramètres de réponse :

Nombre de voies | 1
Bande de fréquence intermédiaire | 35 kHz
Moyennage | Désactivé
Coefficient de moyennage | 1
Lissage | Désactivé
Coefficient de lissage | 1% de l'intervalle de mesure
Retard électrique | 0 s
Coefficient de vitesse | 1.0
Déphasage | 0 degré
Affichage de la trace mathématique/mémoire | Données

Paramètres de correction :

Etat de correction | Désactivé
Etat d'interpolation | Activé
Type d'étalonnage | Aucun
Nombre d'ensembles d'étalonnage | 1
Z0 du système | 50 ohms
Etat des extensions de port | Désactivé
Ext. de port Valeurs Entrée A, B Port 1, 2 | 0

Paramètres de marquage :

Fréquence initiale | Fréquence centrale actuelle
Référence | Aucune
Interpolation | Activée
Format | Trace par défaut
Type | Normal
Fonction | Valeur max
Domaine | Intervalle total de mesure
Table | Vide
Couplage | Toujours non couplé

Paramètres de contrôle des limites :

Contrôle des limites | Désactivé
Affichage des lignes | Désactivé
Alarme sonore | Désactivé

Paramètres de contrôle des limites :

Type (OFF, MAX, MIN) | OFF
Stimulus de départ | 300 kHz
Stimulus de fin | 3 GHz pour le E8356A 6 GHz pour le E8357A 9 GHz pour le E8358A
Réponse de départ | 0
Réponse de fin | 0

Domaine temporel (Option 010 uniquement) :

Etat de la transformation | Désactivé
Mode de transformation | Passe-bande
Début de la transformation | -10 ns
Arrêt de la transformation | 10 ns
Fenêtre | 6.0 (coefficient de Kaiser-Bessel)
Etat de déclenchement | Désactivé
Début du déclenchement | -10 ns
Arrêt du déclenchement | 10 ns
Type de déclenchement | Passe-bande
Forme du déclenchement | Normal

Paramètres d'affichage généraux :

Etat de la trace | Activé
Fréquence/ Stimulus | Désactivé
Lecture des marqueurs | Activé (lorsqu'un marqueur est activé)
Barres d'outils affichées | Entrée active
Etat de la barre d'état | Désactivé

Pour faire passer l'analyseur de l'état de marche à l'hibernation, et vice versa, appuyez sur le commutateur On/Off. Lorsque l'analyseur est dans la condition d'hibernation, le système d'exploitation est en veille. Lorsque l'analyseur est remis dans la condition de marche, le système est ramené dans les conditions précédant la mise en veille.

Dans la condition de marche, le voyant du bouton est vert. Dans la condition d'hibernation, le voyant du bouton est jaune. Ce commutateur de face avant est uniquement un commutateur de mise en attente, ce n'est pas un interupteur de mise sous tension (dispositif de déconnexion). L'état d'hibernation est l'état d'arrêt normal. Une puissance de veille minimale est fournie à l'analyseur en mode d'hibernation. Cette puissance de veille alimente uniquement les circuits de commutation d'alimentation; en veille, aucun circuit de l'unité centrale n'est alimenté.

Lorsque le mode d'hibernation est demandé, l'état de tous les programmes en cours est enregistré sur le disque dur et l'alimentation est automatiquement coupée. Lorsque l'analyseur est ramené dans la condition de marche, le système d'exploitation de l'analyseur recherche et recharge les états mémorisés au cours de l'opération d'hibernation précédente, la procédure de démarrage du système entier est ainsi raccourcie.

Pour mettre l'analyseur dans la condition d'hibernation, appuyez brièvement sur le bouton power.

Attention : Le maintien du commutateur power enfoncé plus de 4 secondes provoque un arrêt immédiat et total de l'alimentation, identique au retrait de la prise de l'instrument. Ceci doit être évité, le système de fichiers peut être endommagé - problèmes identiques à ceux des PC. La plupart du temps, Windows est capable d'éviter la perte de données. Mais cela n'est pas garanti dans la pratique.

Après quelques secondes, le message Ready to Hibernate apparaîtra, rapidement suivi du message Preparing to Hibernate provenant du système d'exploitation Windows. Le voyant du bouton power passe de vert à jaune lorsque l'analyseur est en mode d'hibernation.

Pour remettre en marche l'analyseur, appuyez de nouveau sur le bouton power. Le voyant du bouton power passera de nouveau de jaune à vert pour indiquer la remise en marche. Le retour de l'analyseur dans son état précédent nécessite environ 45 secondes.

N'interrompez l'alimentation de l'analyseur que pour des raisons spécifiques, comme le déplacement ou la maintenance de l'intrument. Si vous interrompez l'alimentation de l'analyseur, les conditions de mise sous tension s'appliquent.

Si vous interrompez l'alimentation de l'analyseur, les conditions de mise sous tension s'appliqueront lorsque l'alimentation sera rétablie et l'analyseur mis en marche. L'état de mise sous tension est identique à celui de préréglage, aux exceptions suivantes :

Addresse GPIB | Dernière valeur active (par défaut en usine = 16)
SCPI sur adresse de réseau local | Dernière valeur active (par défaut en usine = 16)
Mode GPIB | Emetteur/Récepteur
Etat de l'instrument | Identique à celui avant l'arrêt


Select a Measurement State

Configurer des mesures

Voir aussi...

Vous pouvez définir votre mesure en suivant les procédures ci-dessous :
Sélectionner un paramètre de mesure

Définir une plage de fréquences

Définir le niveau de puissance RF

Sélectionner le balayage

Sélectionner le déclenchement

Sélectionner le format et l'échelle des données


Adjust the Display

Réglage de l'écran

Voir aussi...

Pour apprendre à régler l'écran de l'analyseur en vue d'optimiser la lecture des informations affichées, cliquez sur l'un des liens suivants :

Visualiser plusieurs traces et voies de mesure

Personnaliser l'écran de l'analyseur

Afficher ou masquer des résultats de mesure


Accuracy

Améliorer la précision de mesure

Voir aussi...

Cliquez sur l'un des boutons ci-après pour apprendre à optimiser la précision de mesure.

Augmenter la plage dynamique

Augmenter le nombre de points de données

Améliorer la précision de mesure de la phase

Améliorer les mesures des composants électriquement longs

Améliorer la précision de mesure de réflexion sur les quadripôles à faible perte

Améliorer la stabilité de mesure

Réduire le bruit de trace

Réduire la diaphonie du récepteur

Réduire les effets des accessoires


Effects Accy

Voir aussi...

Effets des accessoires

Présentation

Concepts

Comment réduire les effets
des accessoires

Les résultats des mesures d'un composant peuvent être affectés par les accessoires mis en oeuvre dans la configuration de test. Pour limiter les effets de ces accessoires, vous avez le choix entre deux fonctions de l'analyseur.
Concepts

Comment réduire les effets des accessoires

Pour réduire les effets des accessoires, vous pouvez choisir la méthode qui convient le mieux à votre configuration de mesure.

Pente de puissance pour compenser la perte des câbles

Sélection par porte pour la suppression des réponses indésirables

Pente de puissance pour compenser la perte des câbles

Si votre configuration de mesure comprend un câble de grande longueur ou un accessoire introduisant une perte de puissance de plus en plus importante à mesure que la fréquence augmente, appliquez la fonction de pente de puissance (Power Slope) pour compenser cette perte. Cette fonction augmente la puissance de la source de l'analyseur suivant une pente (exprimée en dB/GHz) que vous définissez.

Sélection par porte pour la suppression des réponses indésirables

La sélection par porte (Gating) est une fonction du domaine temporel (option 010) qui permet à l'analyseur de supprimer mathématiquement certaines réponses. Vous pouvez appliquer la fonction de sélection par porte à une réponse de réflexion ou à une réponse de transmission, mais les résultats observés ne seront pas les mêmes dans les deux cas.

  • La sélection par porte appliquée à une réponse de réflexion isole une réponse voulue (par exemple, la perte par réflexion d'un filtre) des réponses indésirables (telles que la réflexion des adaptateurs ou la désadaptation des connecteurs).

  • La sélection par porte appliquée à une réponse de transmission isole un trajet spécifique dans un composant à trajets multiples présentant de grandes longueurs électriques.

Après avoir appliqué la sélection par porte au mode domaine du temps (Time Domain), vous pouvez repasser en mode fréquentiel (c'est-à-dire désactiver la transformée) et étudier la réponse en fréquence du composant avec la porte toujours active. La porte de filtrage temporel peut avoir les formes et les comportements suivants :

  • Passe-bande (Bandpass) : supprime les réponses situées en dehors de la région passe-bande.

  • Coupe-bande (Notch) : supprime les réponses situées à l'intérieur de la région coupe-bande (réjection).

Pour plus de détails, consultez la rubrique Filtre de porte dans le domaine du temps.

Cliquez sur les boutons ci-après pour accéder aux procédures de réduction des effets des accessoires.

Compenser la perte des câbles

Supprimer les réponses indésirables

Compenser la perte des câbles
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Si la fonction de pente de puissance n'est pas déjà active, cochez la case Slope.

  3. Dans le champ dB/GHz, entrez la pente suivant laquelle vous souhaitez voir la puissance de la source augmenter en fonction de la fréquence. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Power.

  2. Dans la barre d'outils de l'entrée active, appuyez sur F4 (Slope).

  3. A l'aide des touches du bloc ENTRY, entrez la pente suivant laquelle vous souhaitez voir la puissance de la source augmenter en fonction de la fréquence. Appuyez ensuite sur Enter.

Supprimer les réponses indésirables (option 010, domaine du temps uniquement)
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Transform.

  2. Cochez la case Transform pour activer le mode transformée.

  3. Sous la rubrique Transform Mode, cliquez sur le mode souhaité.

    • Low Pass Impulse

    • Low Pass Step

    • Band Pass

  4. Si vous avez choisi Low Pass, cliquez sur Set Freq. Low Pass.

  5. Dans la boîte à liste Category, cliquez sur la flèche pour sélectionner Gating.

  6. Dans la boîte à liste Gate Type, cliquez sur la flèche pour sélectionner la forme de porte souhaitée.

    • Bandpass

    • Notch

  7. Définissez les limites de la sélection par porte en utilisant soit les réglages Start et Stop, soit les réglages Center et Span.

  8. Cochez la case Gating pour activer la fonction de sélection par porte. Cliquez sur OK.

  9. Dans le menu Trace, cliquez sur Transform.

  10. Dans la boîte à liste Category, cliquez sur la flèche pour sélectionner Transform. Cliquez sur la case à cocher Transform, puis sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, utilisez la touche Tab à droite et la flèche vers le bas pour accéder au menu Trace puis à l'option Transform. Appuyez sur Click.

  3. Appuyez sur la touche Tab à droite pour accéder à la case Transform, puis appuyez sur Click.

  4. Utilisez la touche Tab à droite et la flèche vers le bas pour accéder à la rubrique Transform Mode et à la sélection voulue.

    • Low Pass Impulse

    • Low Pass Step

    • Band Pass

  5. Si vous avez choisi Low Pass, accédez à Set Freq. Low Pass et appuyez sur Click.

  6. Accédez à la boîte à liste Category et sélectionnez Gating.

  7. Accédez à la boîte à liste Gate Type et sélectionnez la forme de porte souhaitée.

    • Bandpass

    • Notch

  8. Définissez les limites de la sélection par porte en utilisant soit les réglages Start et Stop, soit les réglages Center et Span.

  9. Accédez à la case Gating et appuyez sur Click, puis sur OK.

  10. Accédez à la boîte à liste Category et sélectionnez Transform.

  11. Dans le bloc de touches COMMAND, appuyez sur Menu/Dialog.

  12. Accédez au menu Trace, puis à l'option Transform. Appuyez sur Click.

  13. Accédez à la case Transform et appuyez sur Click, puis sur OK.


Refl Accy

Voir aussi...

Précision de la réflexion sur les composants à 2 ports à faible perte

Présentation

Concepts

Comment mesurer
précisément la réflexion

Pour réaliser des mesures de réflexion précises avec un étalonnage sur 1 port, appliquez une terminaison au port non mesuré.
Concepts

Comment mesurer précisément la réflexion sur les dispositifs à 2 ports

Pour mesurer précisément la réponse en réflexion avec un étalonnage sur 1 port, appliquez une terminaison au port opposé (non mesuré). Ceci s'applique surtout aux composants bidirectionnels à faible perte, tels que les filtres passe-bande et les câbles. Un étalonnage sur 1 port corrige la directivité, l'adaptation de la source et la réponse en fréquence, mais pas l'adaptation de la charge. Aussi, vous devez réduire au maximum l'erreur d'adaptation de la charge.

Remarque : un étalonnage sur 2 ports corrige les 12 termes d'erreur, y compris l'adaptation de la charge.

Vous pouvez appliquer une terminaison au port non mesuré en procédant comme suit :

  • Connectez une charge de terminaison de haute qualité (provenant d'un kit d'étalonnage, par exemple) au port non mesuré de votre composant. Cette technique offre une précision proche de celle d'un étalonnage SOLT complet sur 2 ports.

  • Connectez le port non mesuré de votre composant directement à l'analyseur, en insérant un atténuateur de précision de 10 dB entre la sortie du composant et l'analyseur. Ceci améliore l'adaptation de la charge efficace de l'analyseur d'environ deux fois la valeur de l'atténuateur, soit 20 dB.

Astuce :

  • ne vous préoccupez pas de l'adaptation de la charge si vous mesurez un composant présentant un isolement inversé élevé, tel qu'un amplificateur.

Le graphique ci-après illustre l'incertitude de la mesure qui résulte de la terminaison avec et sans atténuateur de précision de 10 dB à la sortie du composant sous test.

Légende

 | Réflexion du filtre
------------- | Incertitude avec atténuateur
................ | Incertitude sans atténuateur

Les calculs ci-dessous montrent comment l'ajout d'un atténuateur de 10 dB de haute qualité améliore l'adaptation de la charge de l'analyseur.

Remarque : la valeur linéaire correspondante est indiquée entre parenthèses.

Analyseur de réseau : |
Adaptation de la charge (NALM) | = 18 dB (.126)
Directivité (NAD) | = 40 db (.010)
Filtre : |
Perte d'insertion (FIL) | = 1dB (.891)
Perte en réflexion (FRL) | = 16 dB (.158)
Atténuateur : |
Perte d'insertion (AIL) | = 10 dB (.316)
SWR (ASWR) | = 1.05 (.024) Perte de retour de 32,26 dB

Calculs :

 | Avec atténuateur | Sans atténuateur
r NA | = (F IL)*(NA LM)*(F IL) = (.891)*(.126)*(.891) =.100 | = (F IL)*(AIL)*(NA LM)*(AIL)*(F IL) = (.891)*(.316)*(.126)*(.316)*(.891) = .010
r Atténuateur | NA | = (F IL)*(ASWR)*(F IL) = (.891)*(.126)*(.891) = .019
Erreur du cas le plus défavorable (EWC) | = r NA =.1 | = r NA + rAttn. =.01+.019 =.029
Ajouts d'incertitude | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.100)+(.010) = 11.4 dB | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.029)+(.010) = 14.1 dB
Soustractions d'incertitude | = -20log(FRL)-(EWC)-(NAD) =-20log(.158)-(.100)-(.010) = 26.4 dB | = -20log(FRL)-(EWC)-(NAD) = -20log(.158)-(.029)-(.010) = 18.5 dB

Pour réaliser des mesures de réflexion précises sur les composants à 2 ports à faible perte, exécutez l'une des actions suivantes :

  • Connectez une charge de haute qualité à la sortie du composant après avoir exécuté un étalonnage sur 1 port.

  • Insérez un atténuateur de 10 dB entre la sortie du composant et l'analyseur après avoir exécuté un étalonnage sur 1 port.

  • Connectez la sortie du composant directement à l'analyseur après avoir exécuté un étalonnage sur 2 ports.


Dyn Rge

Voir aussi...

Plage dynamique

Présentation

Concepts

Comment augmenter la
plage dynamique

La p lage dynamique est la différence entre la puissance maximale admise par le récepteur de l'analyseur et la plus petite puissance mesurable (plancher de bruit). Une mesure n'est valide que si les signaux d'entrée se situent entre ces deux limites.

Concepts

Comment augmenter la plage dynamique

Il est essentiel d'augmenter la plage dynamique si vous avez besoin de mesurer d'importantes variations d'amplitude du signal, par exemple la réponse d'un filtre passe-bande (partie bande passante et partie réjection). Voici un exemple de mesure illustrant la plage dynamique.

Pour réduire autant que possible l'incertitude de mesure, la plage dynamique de l'analyseur doit être plus étendue que la réponse du composant mesuré. Par exemple, la précision est meilleure lorsque le signal se situe au moins à 10 dB au-dessus du plancher de bruit. Les méthodes suivantes peuvent contribuer à augmenter la plage dynamique.

Augmenter la puissance d'entrée du composant

Réduire le plancher de bruit du récepteur

Réduire la largeur de bande de la FI

Moyenner les balayages ou augmenter le facteur de moyennage existant

Remarque : en raison de l'interdépendance de certains paramètres de l'analyseur, il est possible que l'augmentation de la plage dynamique s'accompagne d'une accroissement du temps de mesure.

Augmenter la puissance d'entrée du composant

  • Augmentez le niveau de puissance fourni au composant testé afin que l'analyseur détecte et mesure plus précisément sa puissance de sortie.

  • Un niveau trop élevé à l'entrée du récepteur de l'analyseur peut provoquer une distorsion par compression, voire endommager le récepteur.

Attention : le niveau d'endommagement du récepteur est de +15 dBm.

Conseil : si l'analyseur est équipé de l'option 015 (dispositif de mesure configurable), vous pouvez étendre encore plus la plage dynamique en amplifiant le signal d'entrée du composant à l'aide d'un amplificateur externe.

Réduire le plancher de bruit du récepteur

Vous pouvez utiliser les techniques suivantes pour abaisser le plancher de bruit et augmenter ainsi la p lage dynamique de l'analyseur.

  • Réduire la largeur de bande de la FI

  • Moyenner les balayages ou augmenter le facteur de moyennage existant

Conseil : lorsque vous mesurez des signaux proches du plancher de bruit de l'analyseur, vous devez faire en sorte de réduire la d iaphonie entre les récepteurs de l'analyseur. (Voir Diaphonie entre récepteurs .)

Réduire la largeur de bande de la FI

  • Le fait de réduire la largeur de bande de la FI du récepteur permet de limiter l'effet du bruit aléatoire affectant la mesure. Chaque division par dix de la largeur de bande de la FI abaisse le plancher de bruit de 10 dB. Cependant, plus la bande FI est étroite, plus le temps de balayage est long.

  • L'analyseur convertit le signal RF/hyperfréquence qu'il reçoit en une fréquence intermédiaire (FI) plus basse, égale à 41,67 kHz. La bande passante du filtre utilisé pour sélectionner la FI est réglable de 40 kHz à 1 Hz.

  • Vous pouvez régler la largeur de bande de la FI indépendamment pour chaque voie ou pour chaque segment d'un balayage par segments.

Effet de la réduction de la largeur de bande de la FI

Moyenner les balayages ou augmenter le facteur de moyennage existant

  • Le moyennage des balayages est un procédé qui vise à réduire l'effet du bruit aléatoire sur une mesure.

  • L'analyseur calcule chaque point de données en faisant la moyenne de plusieurs balayages consécutifs pondérés par un facteur de moyennage que vous spécifiez.

  • Le résultat de chaque nouveau balayage est ajouté à la moyenne des traces précédentes jusqu'à ce que le nombre total de balayages atteigne le facteur de moyennage spécifié.

  • Plus le facteur de moyennage est élevé, meilleure est la réduction du bruit et plus grande est la plage dynamique.

Effet du moyennage de plusieurs balayages consécutifs

Conseils :

  • Vous pouvez configurer la fonction de moyennage individuellement pour chaque voie.

  • Le temps de mesure total augmente avec le nombre de moyennes.

  • Pour minimiser le bruit dans le domaine fréquentiel général, combinez le moyennage des balayages et la réduction de la largeur de bande de la FI.

  • Pour minimiser le bruit à très basse fréquence, le moyennage des balayages se révèle plus efficace que la réduction de la largeur de bande de la FI.

Cliquez sur les boutons ci-après pour accéder aux procédures d'augmentation de la p lage dynamique.
Augmenter la puissance d'entrée du composant

Réduire le plancher de bruit du récepteur

Augmenter la puissance d'entrée du composant

Attention : si le composant testé présente un gain, vous ne devez pas utiliser le niveau de puissance maximal de la source, sous peine d'endommager le récepteur de l'analyseur. Le niveau d'endommagement du récepteur est de +15 dBm.
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Cochez la case Power On.

  3. Sous la rubrique Port Selection, sélectionnez le port que vous utilisez comme source de signal.

  4. Tapez une valeur dans le champ Test Port Power ou cliquez sur la flèche pour sélectionner la valeur souhaitée.

  5. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Power.

  2. Dans le bloc NAVIGATION, appuyez sur F1 (Level).

  3. Tapez la valeur de puissance souhaitée à l'aide des touches du bloc ENTRY, puis appuyez sur Enter.

Réduire le plancher de bruit du récepteur

Réduisez le plancher de bruit du récepteur en diminuant la largeur de bande de la FI.
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Réduire la largeur de bande de la FI

  1. Dans le menu Sweep, cliquez sur IF Bandwidth.

  2. Tapez une valeur dans le champ IF Bandwidth ou cliquez sur la flèche pour sélectionner une valeur de largeur de bande plus petite.

  3. Cliquez sur OK.

Moyenner les balayages ou augmenter le facteur de moyennage existant

  1. Dans le menu Channel, cliquez sur Average.

  2. Cochez la case Average ON pour activer la fonction de moyennage.

  3. Tapez une valeur dans le champ Average Factor ou cliquez sur la flèche pour augmenter le facteur de moyennage à exécuter par l'analyseur.

  4. Cliquez sur OK.

Remarque : cliquez sur Channel, Restart Average pour que l'analyseur exécute une nouvelle série de balayages à moyenner.

Procédure à l'aide des touches de la face avant

Réduire la largeur de bande de la FI

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Dans le bloc de touches NAVIGATION, appuyez sur F3 (Bandwidth).

  3. A l'aide des touches du bloc ENTRY, tapez la valeur de largeur de bande de la FI et appuyez sur Enter.

Moyenner les balayages ou augmenter le facteur de moyennage existant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Average.

  2. Dans le bloc de touches NAVIGATION, appuyez sur F1 (Avg#).

  3. Tapez le nombre de moyennes souhaité à l'aide des touches du bloc ENTRY, puis appuyez sur Enter.

  4. Appuyez sur F2 (Avg on/OFF) pour activer la fonction de moyennage.

Remarque : appuyez sur F4 (Restart) pour que l'analyseur exécute une nouvelle série de balayages à moyenner.


Long Devices

Voir aussi ...

Mesures de composants électriquement longs

Présentation

Concepts

Comment mesurer des
composants électriquement longs

La fréquence d'un signal provenant d'un composant sous test peut ne pas être exactement identique à la fréquence de l'analyseur à un instant donné, cela peut parfois conduire à des résultats de mesure incorrects.

Trois techniques permettent de supprimer ce problème et d'augmenter la précision de la mesure.
Concepts

Comment mesurer des composants électriquement longs

Les informations suivantes permettent de comprendre pourquoi les résultats des mesures peuvent être incorrects et comment il est possible d'y remédier.
Pourquoi le retard dû aux composants peut affecter les résultats

Solutions pour améliorer la précision de la mesure

Ralentir le balayage

Utiliser un balayage par paliers

Ajouter une longueur électrique à la voie R

Pourquoi le retard dû aux composants peut affecter les résultats

Un exemple de cette situation est présenté sur le graphique suivant :

  • Dans l'analyseur de réseau, la source et le récepteur sont verrouillés en phase et balayent simultanément la bande d'analyse.

  • Le signal qui circule à travers le composant sous test (DUT) est montré en différentes couleurs selon les fréquences.

  • Vous pouvez visualiser la propagation des fréquences de stimulus à travers le CST (en anglais DUT ), l'analyseur se cale sur une nouvelle fréquence juste avant la réception du signal par le récepteur. Cela entraîne une mesure im précise.

.

Si l'analyseur effectue une mesure sur un câble long, la fréquence du signal à l'extrémité du câble est en retard par rapport à la fréquence de source de l'analyseur de réseau. Si le décalage de fréquence est appréciable, comparé à la bande passante de détection FI de l'analyseur de réseau (typiquement de quelques kHz), alors le résultat de la mesure présentera une erreur due à l'affaiblissement provoqué par le filtre FI.

Solutions pour améliorer la précision de la mesure

Choisissez une des méthodes suivantes pour compenser le retard introduit par un composant électriquement long.
Ralentir le balayage

Utiliser un balayage par paliers

Ajouter une longueur électrique à la voie R

Ralentir le balayage

Utilisez une des méthodes suivantes pour ralentir la vitesse de balayage.

  • Augmentez le temps de balayage.

  • Diminuez la bande passante FI.

  • Augmentez le nombre de points.

Utiliser un balayage par paliers

  • Vous pouvez ralentir le balayage de l'analyseur en passant d'un balayage analogique à un balayage par paliers, dans ce cas la source de l'analyseur fera un palier à chaque point de mesure.

  • Vous pouvez définir le temps (de maintien) de chaque palier ou point de mesure de l'analyseur.

Ajouter une longueur électrique à la voie R

Au lieu de ralentir le balayage, vous pouvez compenser la longueur électrique d'un câble ou d'un accessoire.

  1. Retirez le cavalier de la voie R situé sur la face avant de l'analyseur.

  2. Remplacez le cavalier par un câble sensiblement de la même longueur que le composant sous test.

  3. Configurez l'analyseur pour qu'il effectue un balayage rapide.

Cette méthode équilibre les retards dans les trajets de référence et de test, de sorte que la mesure de transmission sous forme de rapport de l'analyseur de réseau ne présente aucune erreur due à un décalage de fréquence.

Remarque : cette méthode est efficace si le retard est apporté par un câble ou un accessoire. Pour des composants ayant de longs retards, cette méthode est uniquement adaptée à des mesures sans étalonnage.

Cliquez sur les boutons afin d'accéder aux procédures de compensation des composants électriquement longs.
Ralentir le balayage

Utiliser un balayage par paliers

Ajouter une longueur électrique à la voie R

Ralentir le balayage
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

Augmenter le temps de balayage

  1. Dans le menu Sweep, cliquez sur Sweep Time.

  2. Dans la liste Sweep Time, tapez la valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner la valeur de temps.

  3. Cliquez sur OK.

Diminuer la bande passante FI

  1. Dans le menu Sweep, cliquez sur IF Bandwidth.

  2. Dans la liste IF Bandwidth, tapez la valeur ou cliquez sur le bouton marqué d'une flèche afin de sélectionner une valeur de bande passante étroite.

  3. Cliquez sur OK.

Augmenter le nombre de points

  1. Dans le menu Sweep, cliquez sur Number of Points.

  2. Sélectionnez une des valeurs affichées, ou Custom pour entrer une valeur quelconque.

  3. Cliquez sur OK.

Procédure à l'aide de la face avant

Augmenter le temps de balayage

  1. Appuyer sur Sweep Setup, F1 (Temps).

  2. Tapez la valeur de vitesse de balayage dans la zone ENTRYet appuyez sur Enter.

Diminuer la bande passante FI

  1. Appuyez sur Sweep Setup, F3 (Bande passante).

  2. Introduisez la valeur de bande passante FI dans la zone ENTRY et appuyez sur Enter.

Augmenter le nombre de points

  1. Dans la zone CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Appuyez sur F1 (Points) et sur les Flèches vers le haut et vers le bas pour choisir une valeur et appuyez ensuite sur Click pour la sélectionner. Ou introduisez la valeur dans la zone ENTRY et appuyez sur Enter.

Utiliser un balayage par paliers
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Sweep Setup.

  2. Cochez la case Stepped Sweep.

  3. Dans la liste Dwell Time, tapez un temps ou utilisez les boutons marqués d'une flèche pour entrer le temps de maintien de chaque point de mesure par l'analyseur.

  4. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog. Dans la zone CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Dans la zone NAVIGATION, appuyer sur Tab à droite afin de vous déplacer vers la case à cocher Stepped Sweep, puis appuyez sur Click pour sélectionner le mode de balayage par paliers.

  3. Appuyez sur Tab à droite afin de vous déplacer vers la zone Dwell Time et utilisez les Flèches vers le haut et vers le bas pour introduire un temps de maintien de chaque point de mesure par l'analyseur. Ou, dans la zone ENTRY, entrez une valeur et appuyez sur Enter.

  4. Dans la zone COMMAND, appuyez sur OK.

Ajouter une longueur électrique à la voie R

  1. Recherchez une longueur de câble équivalente à la longueur électrique du composant sous test.

  2. Connectez le câble à la voie R sur la face avant.

    • Ajoutez le câble à la voie R1 pour les mesures de S11 et S21.

    • Ajoutez le câble à la voie R2 pour les mesures de S22 et S12.

Configuration pour les mesures de S22 et S12


Phase Accy

Voir aussi ...

Précision de la mesure de phase

Présentation

Concepts

Comment augmenter la
précision de la phase

Vous pouvez augmenter la précision des mesures de phase en utilisant diverses fonctions de l'analyseur.
Concepts

Comment augmenter la précision de la phase

Les fonctions suivantes contribuent à l'obtention de mesures de phase précises.
Retard électrique

Extensions de port

Décalage de phase

Espacement entre les points de fréquence

Retard électrique

  • Utilisez la fonction retard électrique pour compenser le déphasage linéaire à travers le composant. Cette fonction ne s'adresse qu'à l'écart par rapport à une phase linéaire du composant.

  • Le retard électrique est une fonction mathématique qui simule une longueur variable d'une ligne de transmission sans pertes.

  • Vous pouvez régler le retard électrique indépendamment pour chaque trace de mesure.

Extensions de port

  • Utilisez les extensions de por t pour déplacer électriquement le plan de référence de mesure après un étalonnage . Cela évite d'effectuer un autre étalonnage. Les deux scénarios qui suivent montrent l'utilité des extensions de port.

    • Vous avez déjà effectué un étalonnage et vous décidez qu'il est nécessaire d'ajouter une longueur de câble dans la configuration de mesure. Utilisez les extensions de port pour "informer" l'analyseur de l'ajout de cette longueur de câble à un port spécifique.

    • Vous êtes incapable d'effectuer un étalonnage directement avec votre composant parce qu'il est dans une installation de test. Utilisez les extensions de port pour compenser ce temps de retard (déphasage) occasionné par l'installation.

  • Les extensions de port appliquent automatiquement un retard électrique à toutes les mesures associées à un port particulier.

  • Vous pouvez ajouter une longueur électrique aux récepteurs A et B si vous utilisez les connecteurs d'accès direct du récepteur sur la face avant.

Remarque : Les extensions de port ne compensent PAS les pertes et les désadaptations des câbles, des adapteurs et des installations ; uniquement la longueur électrique ajoutée.

Décalage de phase

D écale mathématiquement la phase d'une mesure d'une valeur spécifiée, jusqu'à 360°. Utilisez cette fonction pour :

  • Améliorer l'affichage d'une mesure de phase. Ceci est similaire à la manière selon laquelle vous changeriez le niveau de référence dans une mesure d'amplitude. Modifiez la réponse en phase pour centrer ou aligner la réponse sur l'écran.

  • Emuler un déphasage projeté de votre mesure. Par exemple, si vous savez que vous devez ajouter un câble et que la longueur de ce câble ajoutera un certain déphasage à votre mesure, vous pouvez ajouter un décalage de phase pour prendre en compte ce déphasage et simuler la mesure complète du composant.

Espacement entre les points de fréquence

  • L'analyseur échantillonne les données à des points de fréquence discrets, relie ensuite les points, créant ainsi une trace sur l'écran.

  • Si le déphasage à l'intérieur du composant est supérieur à 180° entre des points de fréquence contigus, l'affichage peut donner l'impression que la pente de phase est inversée. Cela est dû au fait que les données sont sous-échantillonnées et qu'un repliement se produit.

Si vous mesurez un temps de propagation de groupe et que la pente de la phase est inversée, alors le temps de propagation de groupe changera de signe. Par exemple, le graphique suivant montre une mesure d'un filtre passe-bande à onde acoustique de surface.

  • La première mesure comporte 51 points et indique un temps de propagation de groupe négatif, ce qui est impossible physiquement. C'est-à-dire que la réponse est au-dessous de la ligne de référence de 0 seconde.

  • Dans la seconde mesure, la trace comporte 201 points et indique un temps de propagation de groupe positif. C'est-à-dire que la réponse est au-dessus de la ligne de référence de 0 seconde.

Conseil :

  • Pour contrôler si un repliement s'est produit dans une mesure, diminuez l'espacement entre les points de fréquence et vérifiez si les données sur l'écran de l'analyseur sont modifiées. Si un repliement s'est produit, vous pouvez, soit augmenter le nombre de points, soit réduire la plage de mesure en fréquence.

Cliquez sur les boutons pour accéder aux procédures permettant d'accroître la précision de la mesure de phase.
Compenser un déphasage linéaire

Déplacer le plan de référence électriquement

Décaler la phase mesurée

Vérifier si un repliement s'est produit

Compenser un déphasage linéaire
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Scale, cliquez sur Electrical Delay.

  2. Dans la liste Electrical Delay, tapez la valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner la valeur souhaitée.

  3. Dans la liste Velocity Factor, tapez la valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner une valeur comprise entre 0 et 1,0. Le coefficient de vitesse est celui du milieu du composant en cours de mesure.

  • 1,0 correspond à la vitesse de la lumière dans le vide

  • 0,66 correspond à la vitesse typique de la lumière dans des diélectriques en polyéthylène

  • 0,70 correspond à la vitesse typique de la lumière dans des diélectriques en téflon

  4. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone NAVIGATION, appuyez sur les touches Tab Droit et Flèche Bas pour vous déplacer dans le menu Scale jusqu'à Electrical Delay. Appuyez sur Click.

  2. Dans la liste Electrical Delay, tapez la valeur à l'aide des touches de la zone ENTRY et appuyez sur Enter, ou appuyez sur les touches Flèche vers le haut et Flèche vers le bas pour sélectionner la valeur souhaitée. Appuyez sur Click.

  3. Appuyez sur la touche Tab Droit pour vous déplacer vers la liste Velocity Factor.

  4. Dans la liste Velocity Factor, tapez la valeur à l'aide des touches de la zone ENTRY, ou appuyez sur la touche Flèche vers le bas afin de sélectionner la valeur que vous souhaitez, appuyez ensuite sur Click. Sélectionnez une valeur comprise entre 0 et 1,0. Le coefficient de vitesse est celui du milieu du composant en cours de mesure.

  • 1,0 correspond à la vitesse de la lumière dans le vide

  • 0,66 correspond à la vitesse typique de la lumière dans des diélectriques en polyéthylène

  • 0,70 correspond à la vitesse typique de la lumière dans des diélectriques en téflon

Déplacer le plan de référence électriquement
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Calibration, cliquez sur Port Extensions.

  2. Cochez la case Port Extensions.

  3. Ajoutez la valeur d'extension pour le port où vous souhaitez étendre le plan de référence .

  4. Dans la liste Velocity Factor, sélectionnez une valeur comprise entre 0 et 1,0 pour le coefficient de vitesse du milieu du câble ou du composant que vous avez ajouté après avoir effectué un étalonnage. Cliquez ensuite sur OK.

  • 1,0 correspond à la vitesse de la lumière dans le vide

  • 0,66 correspond à la vitesse typique de la lumière dans des diélectriques en polyéthylène

  • 0,70 correspond à la vitesse typique de la lumière dans des diélectriques en téflon

Conseil :

Pour savoir si vous avez ajouté suffisamment de retard :

  1. Connectez un court-circuit à la place du composant.

  2. Ajustez l'extension de port jusqu'à ce que la réponse en phase soit plate.

Remarque : La plupart des courts-circuits étalons ont un retard non nul. Le réglage du retard par cette méthode résulte donc en une erreur de retard égale à deux fois le retard du court-circuit. Déterminez le retard de décalage du court-circuit d'étalonnage en examinant la définition standard.

A l'aide des touches de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone NAVIGATION, appuyez sur les touches Tab Droit et Flèche vers le bas pour vous déplacer dans le menu Calibration jusqu'à Port Extensions. Appuyez sur Click.

  3. Appuyez sur Click pour cocher la case Port Extensions.

  4. Appuyez sur Tab Droit pour vous déplacer vers la zone de texte de l'entrée ou du port où vous souhaitez étendre le plan de référence . Entrez une valeur et appuyez sur Enter.

  5. Appuyez sur la touche Tab Droit pour vous déplacer vers la liste Velocity Factor.

  6. Dans la liste Velocity Factor, utilisez les flèches du haut et du bas pour sélectionner une valeur comprise entre 0 et 1,0 pour le coefficient de vitesse du milieu du câble ou du composant que vous avez ajouté après avoir effectué un étalonnage. Cliquez sur OK.

  • 1,0 correspond à la vitesse de la lumière dans le vide

  • 0,66 correspond à la vitesse typique de la lumière dans des diélectriques en polyéthylène

  • 0,70 correspond à la vitesse typique de la lumière dans des diélectriques en téflon

Conseil :

Pour savoir si vous avez ajouté suffisamment de retard :

  1. Connectez un court-circuit à la place du composant.

  2. Ajustez l'extension de port jusqu'à ce que la réponse en phase soit plate.

Remarque : La plupart des courts-circuits étalons ont un retard non nul. Le réglage du retard par cette méthode résulte donc en une erreur de retard égale à deux fois le retard du court-circuit. Déterminez le retard de décalage du court-circuit d'étalonnage en examinant la définition standard.

Décaler la phase mesurée
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Scale, cliquez sur Phase Offset.

  2. Dans la liste Phase Offset, tapez la valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner la valeur souhaitée.

  3. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone NAVIGATION, appuyez sur les touches Tab Droit et Flèche vers le bas pour vous déplacer dans le menu Scale jusqu'à Phase Offset. Appuyez sur Click.

  3. Dans la liste Phase Offset tapez la valeur à l'aide des touches de la zone ENTRY et appuyez sur Enter, ou appuyez sur les touches Flèche vers le haut et Flèche vers le bas pour sélectionner la valeur souhaitée. Appuyez sur Enter, OK.

Vérifier si un repliement s'est produit
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Number of Points.

  2. Sélectionnez une des valeurs de la liste ou Custom pour saisir n'importe quelle valeur à partir du clavier ou l a zone ENTRY qui diminue la valeur actuelle.

  3. Cliquez sur OK.

    Si les données affichées changent, vous pouvez, soit augmenter le nombre de points, soit réduire la plage de mesure en fréquence.

A l'aide des touches de la face avant

  1. Dans la zone CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Appuyez sur F2 (Points).

  3. Dans la zone NAVIGATION, appuyer sur les touches Flèche vers le haut et Flèche vers le bas pour diminuer la valeur et appuyez ensuite sur Click pour sélectionner la valeur affichée.

    Si les données affichées changent, vous pouvez, soit augmenter le nombre de points, soit réduire la plage de mesure en fréquence.


Trce Noise

Voir aussi...

Bruit de trace

Présentation

Concepts

Comment réduire
le bruit de trace

Vous pouvez appliquer certaines fonctions de l'analyseur pour réduire le bruit sur la trace de mesure.
Concepts

Comment réduire le bruit de trace

Vous pouvez utiliser les fonctions suivantes de l'analyseur pour tenter de réduire l'effet de bruit sur la trace de données.
Moyennes de balayage

Lissage de trace

Bande passante FI

Moyennes de balayage

  • La moyenne de balayage est un processus qui réduit les effets de bruit aléatoire sur une mesure.

  • L'analyseur calcule chaque point de données en fonction de la moyenne des balayages consécutifs pondérée par le facteur de moyennage que vous spécifiez.

  • Chaque nouveau balayage est ajouté à la moyenne des traces jusqu'à ce que le nombre total de balayages soit égal au facteur de moyennage.

  • Plus le nombre de mesures est élevé (facteur de moyennage), plus le degré de réduction de bruit et la p lage dynamique sont importants.

  • Pour la réduction du bruit, l'application de moyennes de balayage produit le même effet que le rétrécissement de la bande passante FI.

Effet des moyennes de balayage

Lissage de trace

Vous pouvez appliquer le lissage pour réduire des valeurs de bruit crête à crête relativement petites pour des données mesurées sur une large bande. Pour cela, l'analyseur calcule la moyenne des données du voie active sur une portion (ouverture de lissage) de la trace affichée.

Conseils :

  • Utilisez un nombre suffisamment élevé de points d'affichage afin d'éviter d'obtenir des résultats non significatifs.

  • N'utilisez pas le lissage avec les dispositifs à résonance élevée ou les dispositifs présentant de grandes variations de trace car cela pourrait générer des erreurs de mesure.

  • Vous pouvez définir la fonction de lissage indépendamment pour chaque trace.

Effets du lissage sur une trace

Bande passante FI

  • La réduction de la bande passante du récepteur FI réduit l'effet de bruit aléatoire sur une mesure. Chaque réduction de facteur dix de la bande passante FI abaisse le seuil de bruit de 10 dB. Cependant, les bandes passantes FI étroites allongent les temps de balayage.

  • L'analyseur de réseau convertit la fréquence RF/hyperfréquence du signal reçu en une fréquence intermédiaire (FI) plus basse de 41,67 kHz. La bande passante du filtre passe-bande FI, ou bande passante FI, est réglable de 40 kHz à un minimum de 1 Hz.

  • Vous pouvez définir la bande passante FI indépendamment pour chaque voie ou chaque segment balayé.

Effet de la réduction de la bande passante FI

Cliquez sur les boutons suivants pour accéder aux procédures de réduction de bruit de trace correspondantes :
Appliquer ou modifier les moyennes de balayage

Appliquer le lissage de trace

Réduire la bande passante FI

Appliquer ou modifier les moyennes de balayage
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Channel, cliquez sur Average.

  2. Si la fonction Average n'a pas encore été activée, cochez la case Average On.

  3. Dans la zone Average Factor, augmentez le facteur de moyennage jusqu'à la valeur que vous souhaitez que l'analyseur calcule pour la mesure.

  4. Cliquez sur OK.

Remarque : cliquez sur Channel, Restart Average pour que l'analyseur réalise une nouvelle série de balayages et en calcule la moyenne.

A l'aide des touches de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Average.

  2. Si la fonction Average n'a pas encore été activée, appuyez sur la touche F2 (Avg ON/OFF) pour activer la fonction de calcul de la moyenne.

  3. Appuyez sur la touche F1 (Avg#).

  4. Dans le bloc ENTRY, entrez le facteur de moyennage désiré pour la mesure et appuyez sur la touche Entrée.

Remarque : appuyez sur la touche F4 (Restart) pour que l'analyseur réalise une nouvelle série de balayages et en calcule la moyenne.

Appliquer le lissage de trace
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Smoothing.

  2. Si la fonction Smoothing n'a pas encore été activée, cochez la case Smoothing ON.

  3. Choisissez la manière dont vous souhaitez spécifier la valeur de l'ouverture du lissage :

    • Dans la zone Percent of Span, entrez le pourcentage de lissage. (La valeur maximale est de 25 %.)

    • Dans la zone Points, entrez le nombre de points que le lissage doit couvrir. (La valeur maximale est 25 % du nombre total de points défini pour le balayage de mesure.)

  4. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, sélectionnez l'onglet de droite et appuyez sur la flèche vers le bas pour accéder à l'option Smoothing du menu Trace. Puis, appuyez sur Click.

  3. Si la fonction Smoothing n'est pas activée, appuyez sur Click pour cocher la case Smoothing ON.

  4. Sélectionnez l'onglet de droite pour choisir la façon avec laquelle vous souhaitez spécifier la valeur de l'ouverture de lissage :

    • Dans la zone Percent of Span, entrez le pourcentage de lissage. (La valeur maximale est de 25 %.)

    • Dans la zone Points, entrez le nombre de points couverts par le lissage. (La valeur maximale est 25 % du nombre total de points défini pour le balayage de mesure.)

  5. Dans le bloc COMMAND, appuyez sur OK.

Réduire la bande passante FI
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Sweep, cliquez sur IF Bandwidth.

  2. Dans la zone IF Bandwidth, cliquez sur le bouton fléché ou saisissez une valeur pour définir une bande passante étroite.

  3. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le bloc CHANNEL, appuyez sur Sweep Setup.

  2. Dans le bloc NAVIGATION, appuyez sur la touche F3 (Bandwidth).

  3. Dans le bloc ENTRY, entrez la valeur de la bande passante FI et appuyez sur la touche Entrée.


Fast Swp

Voir aussi...

Vitesse de balayage

Présentation

Concepts

Comment obtenir le
balayage le plus rapide

Le maintien d'une vitesse de balayage aussi élevée que possible constitue l'un des aspects entrant en ligne de compte dans l'obtention du meilleur débit de mesure.
Concepts

Comment obtenir le balayage le plus rapide

Vous pouvez obtenir le balayage le plus rapide pour votre application de mesure en agissant sur les facteurs suivants :

Paramètres de balayage

Paramètres de réduction du bruit

Choix d'étalonnage de la mesure

Fonctions inutiles

Paramètres de balayage

Vous pouvez changer les paramètres suivants de la manière indiquée :

  • Bande d'analyse. Limitez-vous à la mesure du domaine de fréquences utile de votre composant.

  • Balayage par segments (Segment Sweep). Utilisez des segments pour ne balayer que les parties qui vous intéressent sur une plage de fréquences donnée.

  • Désactivez le balayage par paliers (Stepped Sweep). Utilisez le mode de balayage linéaire pour minimiser le temps de balayage lorsque cela est possible.

  • Temps de balayage automatique (Auto Sweep Time). Conservez cette valeur par défaut pour que l'analyseur détermine lui-même le temps de balayage le plus rapide compte tenu des autres réglages en vigueur.

  • Nombre de points (Number of Points). Utilisez le plus petit nombre de points nécessaire à votre mesure.

Nombre de points | Temps de cycle (ms)*
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 55

*Etat de l'instrument : conditions de préréglage (Preset), largeur de bande FI = 35 kHz, fréquence centrale = 1 GHz, bande d'analyse = 100 MHz, correction désactivée. Comptez 21 ms supplémentaires si l'écran est actif. Le temps de cycle comprend le temps de balayage et le temps de retour de balayage.

Pour plus de détails sur l'influence du nombre de points et d'autres paramètres sur le temps de cycle, reportez-vous à la description des caractéristiques techniques de l'instrument.

Paramètres de réduction du bruit

En adoptant les réglages suivants, vous pouvez réduire le temps de balayage sans trop compromettre la qualité de la mesure.

  • Largeur de bande de la FI (IF Bandwidth). Utilisez la plus grande largeur de bande permettant d'obtenir un bruit de trace et une p lage dynamique acceptables.

  • Fonction de moyennage (Average). Réduisez le facteur de moyennage ou désactivez la fonction de moyennage.

Choix d'étalonnage de la mesure

  • Choisissez le type d'étalonnage le plus rapide compte tenu du niveau de précision requis.

    • La vitesse de balayage est à peu près la même pour les mesures non corrigées et les mesures corrigées par un étalonnage de réponse ou un étalonnage sur un seul port.

    • Un étalonnage complet sur deux ports (Full 2-port) nécessite un balayage dans le sens direct et un balayage dans le sens inverse pour actualiser les quatre paramètres S en vue de la correction d'erreurs, même lorsqu'un seul paramètre S est affiché.

Pour plus de détails, reportez-vous à la rubrique Etalonnage de mesure.

Fonctions inutiles

L'analyseur doit actualiser les informations de toutes les fonctions actives. Pour obtenir un surcroît de vitesse de balayage, désactivez toutes les fonctions de l'instrument qui ne sont pas utiles à votre application de mesure.

  • Traces inutilisées

  • Marqueurs inutilisés

  • Lissage (Smoothing)

  • Tests par gabarit (Limit Testing)

  • Opérations arithmétiques sur les traces (Trace Math)

  • Affichage

La vitesse de balayage de l'analyseur dépend de divers paramètres de mesure. Expérimentez différentes combinaisons de réglages pour obtenir la vitesse la plus élevée et les résultats de mesure attendus.

Changer les paramètres de balayage

Changer les paramètres de réduction du bruit

Désactiver les fonctions inutiles

Choisir un étalonnage rapide

Changer les paramètres de balayage
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Changer la bande d'analyse

  1. Accédez aux paramètres de stimulus du balayage :

    • Dans le menu Channel, cliquez sur Start/Stop ou Center/Span dans le cas d'un balayage en fréquence.

    • Dans le menu Channel, cliquez sur Power dans le cas d'un balayage en puissance.

  2. Dans le champ Start (ou Center), tapez ou sélectionnez une valeur permettant de réduire la bande d'analyse.

  3. Dans le champ Stop (ou Span), tapez ou sélectionnez une valeur permettant de réduire la bande d'analyse.

  4. Cliquez sur OK.

  5. Reportez-vous à la rubrique Balayage par segments pour changer le type de balayage.

Désactiver le mode de balayage par paliers

  1. Dans le menu Sweep, cliquez sur Sweep Setup.

  2. Cliquez sur la case Stepped Sweep pour la désélectionner, puis cliquez sur OK.

Activer le mode Auto Sweep Time

  1. Dans le menu Sweep, cliquez sur Sweep Time.

  2. Cliquez sur la flèche vers le bas jusqu'à atteindre la plus petite valeur, puis cliquez sur OK.

Changer le nombre de points

  1. Dans le menu Sweep, cliquez sur Number of Points.

  2. Sélectionnez l'une des valeurs prédéfinies ou, pour entrer une valeur particulière, choisissez Customize.

  3. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

Changer la bande d'analyse

  1. Accédez aux paramètres de stimulus du balayage :

    • Dans le bloc de touches CHANNEL SETUP, appuyez sur Start/Center, F1 (Start) ou F3 (Center) dans le cas d'un balayage en fréquence.

    • Dans le bloc de touches CHANNEL SETUP, appuyez sur Power, F1 (Start) dans le cas d'un balayage en puissance.

  2. Tapez une valeur à l'aide des touches du bloc ENTRY, puis appuyez sur Enter.

  3. Appuyez sur F2 (Stop) ou F4 (Span) et tapez une valeur à l'aide des touches du bloc ENTRY, puis appuyez sur Enter.

  4. Reportez-vous à la rubrique Balayage par segments pour changer le type de balayage.

Désactiver le mode de balayage par paliers

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  3. Si la case Stepped Sweep est cochée, appuyez sur la touche Tab à droite pour y accéder, puis sur Clickpour la désélectionner.

  4. Dans le bloc COMMAND, appuyez sur OK.

Activer le mode Auto Sweep Time

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Appuyez sur F1 (Time) et, dans le bloc ENTRY, appuyez sur 0 puis sur Enter.

Changer le nombre de points

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Appuyez sur F2 (Points).

  3. Dans le blocNAVIGATION, appuyez sur la flèche vers le haut ou vers le bas pour faire défiler la liste des valeurs disponibles, puis sur Click pour sélectionner la valeur affichée. Ou alors tapez une valeur à l'aide des touches du bloc ENTRY et appuyez sur Enter.

Changer les paramètres de réduction du bruit
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Changer la largeur de bande de la FI

  1. Dans le menu Sweep, cliquez sur IF Bandwidth.

  2. Dans le champ IF Bandwidth, tapez ou sélectionnez une valeur pour augmenter la largeur de bande.

  3. Cliquez sur OK.

Changer le facteur de moyennage

  4. Dans le menu Channel, cliquez sur Average.

  5. Tapez une valeur dans le champ Average Factor ou cliquez sur la flèche pour réduire le facteur de moyennage à exécuter par l'analyseur.

    • Ou alors désactivez la fonction de moyennage en cliquant sur la case Average On pour la désélectionner.

  6. Cliquez sur OK.

Remarque :Cliquez sur Channel, Restart Average pour que l'analyseur exécute une nouvelle série de balayages à moyenner.

Procédure à l'aide des touches de la face avant

Changer la largeur de bande de la FI

  1. Appuyez sur Sweep Setup, F3 (IF Bandwidth).

  2. Tapez une valeur pour augmenter la largeur de bande de la FI.

  3. Dans le bloc de touches ENTRY, appuyez sur Enter.

Changer le facteur de moyennage

  4. Dans le bloc de touches CHANNEL SETUP, appuyez sur Average.

  5. Appuyez sur F1 (Avg#) et tapez une valeur pour réduire le facteur de moyennage à exécuter par l'analyseur, puis appuyez sur Enter.

    • Ou alors appuyez sur F2 (Avg ON/OFF) pour désactiver la fonction de moyennage.

Remarque : appuyez sur F4 (Restart) pour que l'analyseur exécute une nouvelle série de balayages à moyenner.

Désactiver les fonctions inutiles
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Supprimer les traces non souhaitées

  1. Cliquez sur la barre d'état des traces pour rendre active la trace inutile.

  2. Dans le menu Trace, cliquez sur Delete Trace.

Désactiver les marqueurs non souhaités

  1. Dans le menu Marker, cliquez sur Select Marker et, dans la liste, cliquez sur un marqueur inutile.

    • Si vous souhaitez désactiver tous les marqueurs, cliquez sur All Off.

  2. Si la barre d'outils des marqueurs n'est pas affichée, allez dans le menu View, cliquez sur Toolbars et sélectionnez Marker.

  3. Cliquez sur la case à cocher On pour la désélectionner.

Désactiver le lissage

  1. Dans le menu Trace, cliquez sur Smoothing.

  2. Cliquez sur la case à cocher Smoothing On pour la désélectionner et désactiver ainsi la fonction de lissage. Cliquez sur OK.

Désactiver les tests par gabarit

  1. Dans le menu Trace, cliquez sur Limit Test.

  2. Cliquez sur la case à cocher Limit Test ON pour la désélectionner et désactiver ainsi la fonction de tests par gabarit. Cliquez sur OK.

Désactiver les fonctions arithmétiques

  • Dans le menu Trace, pointez sur la liste Data Math et cliquez sur Data pour limiter l'affichage à la trace de mesure en cours.

Procédure à l'aide des touches de la face avant

Supprimer les traces non souhaitées

  1. Si plusieurs fenêtres sont affichées à l'écran, effectuez l'étape suivante.

    • Dans le bloc de touches DISPLAY, appuyez sur Window, puis sur F2 (Next Window) jusqu'à ce que la fenêtre contenant la trace à supprimer soit sélectionnée.

  2. Dans le bloc de touches DISPLAY, appuyez sur Trace, puis sur F2 (Next Trace) jusqu'à ce que la trace à supprimer soit active.

  3. Appuyez sur F4 (Delete).

Désactiver les marqueurs non souhaités

  1. Dans le bloc de touches TRACE SETUP, appuyez sur Marker.

  2. Sélectionnez le marqueur à désactiver en appuyant sur F1, F2 ou F3 (Marker 1, Marker 2 ou Marker 3). Appuyez à nouveau sur Marker pour faire apparaître les autres marqueurs de la liste.

  3. Appuyez alors sur F4 (Off).

  4. Si vous souhaitez désactiver tous les marqueurs, procédez comme suit.

    1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

    2. Dans le bloc de touches NAVIGATION, appuyez sur la touche Tab à droite puis sur la flèche vers le bas pour accéder au menu Marker et à l'option All Off. Appuyez sur Click.

Désactiver le lissage

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc de touches NAVIGATION, appuyez sur la touche Tab à droite puis sur la flèche vers le bas pour accéder au menu Trace et à l'option Smoothing. Appuyez sur Click,Click.

  3. Dans le bloc COMMAND, appuyez sur OK.

Désactiver les tests par gabarit

  • Dans le bloc de touches TRACE SETUP , appuyez sur Limit Table, F1 (Test ON/OFF).

Désactiver les fonctions arithmétiques

  • Dans le bloc de touches TRACE SETUP , appuyez sur Math/Memory, F3 (Data Only) pour limiter l'affichage à la trace de mesure en cours.

Choisir un étalonnage rapide
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Calibration, cliquez sur Calibration Wizard, Cal Type.

  2. Sélectionnez le type d'étalonnage OPEN Response, SHORT Response, THRU Response ou 1-Port, puis cliquez sur OK.

  3. Cliquez sur Measure Stds... et suivez les instructions de l'assistant d'étalonnage.

Pour plus de détails, reportez-vous à la rubrique Sélection et exécution d'un étalonnage de mesure.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Cal, F1 (Cal Wizard).

  2. Dans le bloc de touches NAVIGATION, utilisez les touches fléchées et la touche Click pour sélectionner l'un des types d'étalonnage OPEN Response, SHORT Response, THRU Response ou 1-Port.

  3. Dans le bloc COMMAND, appuyez sur OK.

  4. Dans le bloc de touches NAVIGATION, appuyez sur la touche Tab à droite pour sélectionner Measure Stds..., puis appuyez sur Click.

  5. Suivez les instructions de l'assistant d'étalonnage.

Pour plus de détails, reportez-vous à la rubrique Sélection et exécution d'un étalonnage de mesure.


Mult Meas

Voir aussi...

Mesures multiples

Présentation

Concepts

Comment effectuer des
mesures multiples plus rapidement

Si vous devez effectuer de multiples mesures pour caractériser un dispositif, vous pouvez augmenter le débit de diverses manières.
Concepts

Comment effectuer des mesures multiples plus rapidement

Expérimentez ces méthodes afin de trouver celle qui correspond le mieux à votre application de mesure.
Configuration des mesures pour augmenter le débit

Regrouper les mesures

Utiliser un balayage de segment

Déclencher les mesures de manière sélective

Automatiser les modifications entre les mesures

Récupération rapide des mesures

Configuration des mesures pour augmenter le débit

Afin d'atteindre le débit optimal nécessaire à des mesures multiples, il est utile de connaître le fonctionnement de l'analyseur. Cette connaissance permet de choisir les scénarios de mesure les plus adaptés à vos applications. Il est possible de combiner les mesures, en utilisant les regroupements suivants.

  • 1 à 4 voies de mesure indépendants

  • 1 à 4 traces par fenêtre

  • 1 à 4 fenêtres par écran

  • 1 à 16 traces de mesure par écran

  • 1 à 16 traces mémoire par écran

Une voie comporte un ensemble d'attributs indépendants associés aux données acquises.

Une trace comporte un ensemble unique d'attributs associés à des traitements mathématiques effectués sur les données acquises.

Une fenêtre est utilisée pour afficher des traces.

Regrouper les mesures

Si vous organisez les mesures afin de maintenir l'ensemble complet des mesures du dispositif dans un même état de l'instrument, vous pouvez les enregistrer afin de pouvoir récupérer un certain nombre de mesures à l'aide d'une seule fonction de récupération. Voir Traces et voies multiples pour plus d'informations.

Lorsque vous effectuez un ensemble de mesures, gardez à l'esprit que vous avez le choix entre :

  • L'affichage de traces provenant de voies multiples dans une seule fenêtre.

  • L'affichage de traces provenant de voies multiples dans des fenêtres multiples.

Utiliser un balayage de segment

Le balayage de segment est utile si vous souhaitez modifier les paramètres suivants pour caractériser un composant en cours de test.

  • Plage de fréquences

  • Niveau de puissance

  • B ande passante de fréquence in termédiaire

  • Nombre de points

Le balayage de segment permet de définir un ensemble de plages de fréquences ayant des attributs indépendants. Cela permet d'utiliser un seul balayage de mesure pour mesurer un composant ayant des caractéristiques variables. Voir Balayage de segment pour plus d'informations.

Déclencher les mesures de manière sélective

Vous pouvez effectuer les mesures en les déclenchant de la manière suivante :

  • Mettre à jour continuellement uniquement les mesures dont les données évoluent rapidement.

  • Mettre à jour occasionellement les mesures dont les données n'évoluent pas fréquemment.

Par exemple, si vous avez quatre voies configurés comme suit :

  • Deux voies pour mesurer les données utilisées pour accorder un filtre

  • Deux voies pour mesurer les données des réponses hors-bande du filtre

Vous pouvez choisir de ne surveiller constamment que les données de mesure utilisées pour accorder le filtre. Si vous effectuez une mise à jour continue de tous les voies, la réponse de l'analyseur peut être ralentie de sorte que vous ne serez pas capable d'accorder le filtre efficacement.

Remarque : Vous devez déclencher les mesures peu fréquentes, soit manuellement, soit à l'aide de commandes d'interface à distance.

Automatiser les modifications entre les mesures

S'il existe de légères différences entre les diverses mesures nécessaires pour caractériser un composant, vous pouvez estimer plus rapide de modifier les paramètres de mesure par automatisation.

Récupération rapide des mesures

  • La récupération des mesures est plus efficace si celles-ci sont récupérées en tant qu'ensemble de mesures (état de l'instrument).

  • La récupération d'un état d'instrument comprenant des mesures multiples ne prend que très peu de temps de plus que la récupération d'un état d'instrument ne comprenant qu'une seule mesure.

  • Un temps est associé à chaque fonction de récupération. Ce temps peut être éliminé en configurant les mesures en tant qu'ensemble afin de les récupérer en tant qu'ensemble.

Cliquez sur les boutons pour accéder aux procédures d'augmentation du débit des dispositifs qui nécessitent des mesures multiples.
Regrouper les mesures

Utiliser un balayage de segment

Déclencher les mesures de manière sélective

Automatiser les modifications entre les mesures

Regrouper les mesures
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Window, cliquez sur Meas Setups, et cliquez sur une des sélections de configuration :

    • Configuration A : configure l'analyseur avec les quatre paramètres S sur une voie, montrés dans une seule fenêtre avec un format d'amplitude logarithmique.

    • Configuration B : configure l'analyseur avec les quatres paramètres S sur une voie, chaque paramètre étant dans une fenêtre distincte avec le format d'amplitude logarithmique.

    • Configuration C : configure l'analyseur avec trois paramètres S (S11, S22, S21) sur une seule voie, chaque paramètre étant dans une fenêtre distincte avec S11 et S22 sous forme d'abaque de Smith et S21 dans le format d'amplitude logarithmique.

    • Configuration D : configure l'analyseur avec deux voies, chacun avec les paramètres S21 et S11 de sorte que chaque voie soit dans une fenêtre distincte avec le format d'amplitude logarithmique.

  2. Modifiez les paramètres pour les adapter aux exigences de vos mesures.

Pour plus d'informations, reportez-vous à Sélectionner un état de mesure.

Procédure à l'aide de la face avant

  1. Dans la zone DISPLAY, appuyez sur Measure Setups et appuyez sur une des touches de sélection des entrées actives (F1, F2, F3, F4) pour configurer un ensemble de mesures :

    • Configuration A : 1 voie, 4 paramètres S, amplitude logarithmique, 1 fenêtre

    • Configuration B : 1 voie, 4 paramètres S, amplitude logarithmique, 4 fenêtres

    • Configuration C : 1 voie, 3 paramètres S, Smith et amplitude logarithmique, 3 fenêtres

    • Configuration D : 2 voies, 2 paramètres S (4 traces), amplitude logarithmique, 2 fenêtres

  2. Modifiez les paramètres pour les adapter aux exigences de vos mesures.

Pour plus d'informations, reportez-vous à Sélectionner un état de mesure.

Déclencher les mesures de manière sélective

Cette procédure montre comment configurer deux mesures différentes avec le comportement suivant :

  • Une mesure met les données à jour continuellement.

  • Une autre mesure met les données à jour occasionnellement.
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Windows, cliquez sur Meas Setups, Setup D.

  2. Modifiez les paramètres afin de les adapter aux exigences de votre mesure, la voie 1 pour la mesure à mettre à jour continuellement et la voie 2 pour la mesure à mettre à jour occasionnellement.

Configurer le déclenchement de la mesure à mettre à jour continuellement

  3. Dans le menu Sweep, cliquez sur Trigger, Trigger....

  4. Dans Trigger Source, cliquez sur Internal.

  5. Dans Channel Trigger State, sélectionnez Channel 1, et cliquez sur Continuous.

Configurer le déclenchement de la mesure à mettre à jour occasionnellement

  6. Dans Channel Trigger State, sélectionnez Channel 2, et cliquez sur Single, OK.

    • Si vous souhaitez que l'analyseur déclenche plus d'un balayage unique, clochez la case Enable Groups et entrez le nombre de balayages.

  7. Dans le menu System , cliquez sur Keys, Trigger.

Mise à jour de la mesure

  8. Cliquez dans la fenêtre inférieure pour faire de la voie 2 la voie active.

  9. Dans la barre d'outils des entrées actives, cliquez sur le type de déclenchement que vous souhaitez.

    • Cliquez sur Single pour que l'analyseur soit configuré pour n'effectuer qu'un seul balayage par déclenchement.

    • Cliquez sur Groups si vous souhaitez de multiples balayages par déclenchement.

Remarque : Une trace doit être active pour lancer un déclenchement de la mesure.

Procédure à l'aide de la face avant

  1. Dans la zone DISPLAY, appuyez sur Measure Setups, F4 (Configuration D).

  2. Modifiez les paramètres afin de les adapter aux exigences de votre mesure, la voie 1 pour la mesure à mettre à jour continuellement et la voie 2 pour la mesure à mettre à jour occasionnellement.

Configurer le déclenchement de la mesure à mettre à jour continuellement

  4. Dans la zone CHANNEL SETUP , appuyez sur Channel, F1 (voie 1).

  5. Appuyez sur Trigger, F1 (Continu).

Configurer le déclenchement de la mesure à mettre à jour occasionnellement

  6. Dans la zone CHANNEL SETUP , appuyez sur Channel, F2 (voie 2).

  7. Appuyez sur Trigger, F2 (Unique).

  8. Si vous souhaitez que l'analyseur déclenche plus d'un balayage, effectuez cette étape :

    1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

    2. Dans la zone CHANNEL SETUP, appuyez sur Trigger.

    3. Dans la zone NAVIGATION, appuyez sur la touche Tab à droite pour vous déplacer vers la case à cocher Enable Groups, et appuyez sur Click.

    4. Appuyez sur la touche Tab à droite pour vous déplacer vers Enable Groups et saisissez le nombre de balayages.

    5. Dans la zone COMMAND, appuyez sur OK.

    6. Pour déclencher l'ensemble des mesures, appuyez sur Trigger, F1 (Groupes).

Mise à jour de la mesure

  9. Dans la zone CHANNEL SETUP , appuyez sur Channel, F2 (voie 2).

  10. Dans la barre d'outils des entrées actives, cliquez sur le type de déclenchement que vous souhaitez.

    • Cliquez sur F2 (Single) pour que l'analyseur soit configuré pour n'effectuer qu'un seul balayage par déclenchement.

    • Cliquez sur F1 (Groupes) si vous souhaitez de multiples balayages par déclenchement.


Data Trnsfr

Voir aussi...

Vitesse de transfert des données

Présentation

Concepts

Comment augmenter la vitesse
de transfert des données

C'est en optimisant la vitesse de transfert des données que vous obtiendrez le meilleur débit de mesure.
Concepts

Comment augmenter la vitesse de transfert des données

Voici les méthodes qui vous permettront d'améliorer la vitesse de transfert des données.

  • Utilisez le mode de balayage unique (Single) ; ainsi, le transfert des données ne commence qu'une fois la mesure terminée.

  • Transférez la quantité minimale de données nécessaire. Par exemple, une trace ne comprenant que quelques points, obtenue au moyen d'un balayage par segments, au lieu d'une trace complète constituée de nombreux points espacés linéairement. Vous pouvez également transférer les données de marqueurs à la place des données de la trace.

  • Choisissez le format de données réel (Real) ; c'est en effet celui qui offre la plus grande vitesse de transfert avec les programmes SCPI utilisés pour les applications automatisées.

  • Utilisez le mode de transfert SCPI sur réseau local (SCPI over LAN) pour les applications automatisées avec des programmes SCPI.

  • Utilisez des programmes COM pour bénéficier de la vitesse de transfert la plus élevée en cas d'utilisation d'une application automatisée. Voir Temps de transfert des données.

Cliquez sur l'un des boutons ci-après pour accéder à la procédure correspondante.
Utiliser le mode de balayage unique (Single)

Transférer la quantité minimale de données en utilisant un balayage par segments

Utiliser le mode de balayage unique (Single)

Cliquez sur l'un des boutons ci-après pour accéder à la procédure de votre choix.
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Trigger, Trigger....

  2. Sous la rubrique Trigger Source, sélectionnez Manual.

  3. Sous la rubrique Channel Trigger State, sélectionnez la voie correspondant à la mesure que vous souhaitez transférer et cliquez sur Continuous, puis surOK.

Pour actualiser la mesure

  4. Dans le menu System, cliquez sur Keys, Trigger.

  5. Dans la barre d'outils de l'entrée active, cliquez sur Single.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Channel, puis sur la touche de fonction (F1,F2,F3,F4) correspondant à la voie qui contient la mesure à transférer.

  2. Appuyez sur Trigger, F2 (Single).

Pour actualiser la mesure sur la voie 2

  8. Dans le bloc de touches CHANNEL SETUP, appuyez sur Trigger, F4 (Restart).


Measurement_Calibration

Voir aussi ...

Présentation de l'étalonnage de mesure

Présentation

Concepts

Comment effectuer un étalonnage

Un étalonnage de mesure est une opération permettant de caractériser les termes d'erreur systématiques en mesurant des étalons connus et en supprimant ensuite les effets de ces erreurs des mesures suivantes. Un étalonnage améliore la précision de l'analyseur en réduisant les erreurs de mesure.
Concepts

Comment effectuer un étalonnage

Cliquez sur le bouton d'une des rubriques suivantes :
Qu'est-ce qu'un étalonnage de mesure ?

Pourquoi l'étalonnage est-il nécessaire ?

Conditions dans lesquelles un étalonnage est conseillé

Qu'est-ce qu'un étalonnage de mesure ?

  • L'étalonnage supprime une ou plusieurs des erreurs systématiques en utilisant une équation appelée modèle d'erreur. Une mesure d'étalons de grande qualité (par exemple, un court-circuit, un circuit ouvert, une charge et une liaison directe) permet à l'analyseur d'identifier les termes d'erreur du modèle d'erreur. Pour plus d'informations sur les erreurs systématiques, voir Erreurs de mesure.

  • Vous pouvez choisir entre différentes méthodes d'étalonnage, en fonction du type de mesure que vous effectuez et du niveau de précision nécessaire à la mesure.

  • La précision des mesures étalonnées dépend de la qualité des étalons du kit d'étalonnage et de la précision avec laquelle les étalons sont définis dans le fichier de définition de kit d'étalonnage. Le fichier de définition de kit d'étalonnage est mémorisé dans l'analyseur. Afin d'effectuer des mesures précises, la définition du kit d'étalonnage doit correspondre au kit d'étalonnage réel utilisé.

  • Si vous réalisez vos propres étalons personnalisés (par exemple, au cours de mesures dans des installations), alors vous devez caractériser les étalons et entrer les définitions dans un fichier de kit d'étalonnage modifié d'utilisateur. Pour plus d'informations sur la modification des fichiers de kit d'étalonnage, voir Etalons.

Pour plus d'informations sur les choix et les procédures d'étalonnage, voir Sélectionner et effectuer un étalonnage de mesure.

Pourquoi l'étalonnage est-il nécessaire ?

  • Il est impossible de réaliser un matériel parfait ne nécessitant aucune forme de c orrection d'e rreur. Même, la réalisation de matériel d'une qualité suffisante pour supprimer le besoin de correction d'erreur pour la plupart des composants serait extrêment coûteuse.

  • La précision de l'analyse de réseau est fortement influencée par des facteurs externes à l'analyseur de réseau. Les composants du montage de mesure, tels que les câbles d'interconnexion et les adaptateurs, introduisent des variations d'amplitude et de phase qui peuvent masquer la réponse réelle du composant sous test.

  • La meilleure qualité possible en pratique sera recherchée pour le matériel avec le meilleur compromis prix-performances. L'étalonnage est donc un outil très utile pour améliorer la précision de mesure.

Conditions dans lesquelles un étalonnage est conseillé

  • Vous souhaitez la meilleure précision possible.

  • Vous adaptez un type ou une impédance de connecteur différent.

  • Vous connectez un câble entre le dispositif de test et un port de test de l'analyseur.

  • Vous effectuez une mesure dans une large bande d'analyse ou d'un composant de grande longueur électrique.

  • Vous connectez un atténuateur ou un autre composant à l'entrée ou à la sortie du dispositif de test.

Si votre montage de test correspond à l'une des conditions ci-dessus, les caractéristiques suivantes du système peuvent être affectées :

  • Amplitude à l'entrée du composant

  • Précision de la R éponse en fréquence

  • D irectivité

  • D iaphonie (isolement)

  • Adaptation de source

  • A daptation de C harge

Voici un aperçu de la procédure d'étalonnage de mesure du composant sous test.

  1. Placez l'analyseur et le composant sous test dans la configuration de mesure.

  2. Optimisez la mesure en sélectionnant les paramètres appropriés de l'analyseur.

  3. Retirez le composant sous test et sélectionnez un type d'étalonnage et un kit d'étalonnage en utilisant l'assistant d'étalonnage.

  4. Tout en suivant les invites de l'assistant d'étalonnage, connectez et mesurez les étalons nécessaires au type d'étalonnage sélectionné.

    • L'analyseur calcule les termes d'erreur à partir des mesures des étalons.

    • A la fin des procédures de l'assistant d'étalonnage, les termes d'erreur sont automatiquement mémorisés en tant que jeux d'étalonnage dans la mémoire de l'analyseur. (Vous pouvez rappeler ces jeux d'étalonnage).

  5. Reconnectez le composant sous test et analysez les données. Les effets des termes d'erreur sont supprimés des mesures du composant lorsque la c orrection d'e rreur est appliquée.


Errors

Voir aussi...

Erreurs de mesure

Présentation

Erreurs de dérive et
erreurs aléatoires

Erreurs
systématiques

Surveillance des
termes d'erreur

Quel que soit le soin qu'on y apporte, une mesure présente toujours un certain degré d'imprécision. Cependant, c'est le niveau de précision souhaité qui détermine l'importance que vous devez accorder aux erreurs de mesure. Par exemple :

  • Si vous souhaitez simplement vérifier qu'un composant est en état de fonctionnement, les mesures réalisées à cet effet n'ont généralement pas besoin d'une grande précision.

  • Si vous tentez de vous assurer de la conformité d'un amplificateur marginal à une spécification de gain, la précision de mesure peut être capitale et vous devez donc tout mettre en oeuvre pour limiter autant que possible les erreurs de mesure.

C'est en comprenant à quoi sont dues les erreurs de mesure que vous apprendrez à améliorer la précision. Cliquez sur les boutons ci-après pour obtenir des informations sur les deux principales sources d'erreur de mesure et savoir comment contrôler les termes d'erreur.

Erreurs de dérive et erreurs aléatoires

Erreurs systématiques

Surveillance des termes d'erreur

Erreurs de dérive

  • Les erreurs de dérive se produisent lorsque les performances de l'instrument ou du système de test changent après l'exécution d'un étalonnage.

  • Les erreurs de dérive sont principalement dues aux caractéristiques de dilatation thermique des câbles d'interconnexion utilisés dans le montage de test et à la stabilité de conversion du convertisseur hyperfréquence. Elles peuvent être éliminées en réalisant un ou plusieurs étalonnages supplémentaires.

  • La durée pendant laquelle un étalonnage reste précis dépend de la vitesse à laquelle le système de test subit cette dérive et donc de la stabilité de son environnement.

Le fait de stabiliser la température ambiante permet généralement de minimiser la dérive. Pour plus de détails, reportez-vous à la rubrique Stabilité de mesure.

Erreurs aléatoires

Les erreurs aléatoires ne sont pas prévisibles et ne peuvent pas être éliminées par la c orrection d'erreur. Cependant, il existe des mesures à prendre pour minimiser leur impact sur la précision de mesure.

On distingue trois sources principales d'erreurs aléatoires :

Erreurs dues au bruit de l'instrument

Erreurs de répétitivité des commutateurs

Erreurs de répétitivité des connecteurs

Erreurs dues au bruit de l'instrument

Le bruit résulte de perturbations électriques générées dans les composants de l'analyseur. Ces perturbations comprennent :

  • un bruit de faible niveau dû au plancher de bruit large bande du récepteur,

  • un bruit ou une gigue de haut niveau affectant la trace de données en raison du plancher de bruit et du bruit de phase de l'oscillateur local (LO) du dispositif de mesure.

Vous pouvez réduire les erreurs dues au bruit en prenant une ou plusieurs des mesures suivantes :

  • Augmentez la puissance du signal source fourni au composant à tester.

  • Réduisez la largeur de bande de la FI.

  • Appliquez la fonction de moyennage à plusieurs balayages de la mesure.

Erreurs de répétitivité des commutateurs

  • Des commutateurs RF mécaniques sont utilisés dans l'analyseur pour combiner les différents atténuateurs qui, ensemble, fournissent l'atténuation demandée pour la source.

  • Parfois, lorsque ces commutateurs mécaniques sont activés, leurs contacts ne se ferment pas exactement comme la fois précédente, ce qui affecte la précision de la mesure.

  • Vous pouvez éviter les erreurs de répétitivité des commutateurs en évitant de changer les réglages d'atténuation lors d'une mesure critique.

Erreurs de répétitivité des connecteurs

L'usure des connecteurs altère les performances électriques. Vous pouvez limiter les erreurs de répétitivité des connexions en respectant les règles de manipulation et d'entretien des connecteurs. Voir Connexions des composants.

Les erreurs systématiques sont dues à des imperfections dans l'analyseur et le montage de test.

  • Elles sont répétitives (et donc prévisibles) et sont supposées ne pas varier dans le temps.

  • Elles peuvent être caractérisées lors du processus d'étalonnage et mathématiquement réduites au cours des mesures qui suivent.

  • Elles ne sont jamais complètement éliminées. Il existe toujours des erreurs résiduelles dues aux limites du processus d'étalonnage. Les erreurs systématiques subsistant après l'étalonnage proviennent :

    • des imperfections des étalons,

    • de l'interface des connecteurs,

    • des câbles d'interconnexion,

    • de l'instrumentation.

Les mesures de réflexion sont sujettes aux trois erreurs systématiques suivantes :

Directivité

Adaptation de la source

Erreur de poursuite de réflexion due à la réponse en fréquence

Les mesures de transmission sont sujettes aux trois erreurs systématiques suivantes :

Isolement

Adaptation de la charge

Erreur de poursuite de transmission due à la réponse en fréquence

Remarque : les figures accompagnant la description des six erreurs systématiques suivantes illustrent la configuration de connexion à mettre en oeuvre pour une mesure dans le sens avant (direct). Pour les mesures dans le sens inverse, une commutation interne à l'analyseur permute la source et le récepteur, de sorte que le port 2 devient la source et le port 1, le récepteur. La voie 'A' devient le récepteur du signal transmis, la voie 'B' le récepteur du signal réfléchi et la voie 'R2' le récepteur du signal de référence. Ces six erreurs systématiques multipliées par les deux sens de mesure donnent lieu à 12 erreurs systématiques dans le cas d'un composant de type quadripôle.

Erreur de directivité

Tous les analyseurs de réseau mesurent la réflexion au moyen de coupleurs ou de ponts directionnels.

Avec un coupleur idéal, seul le signal réfléchi par le CST apparaît sur la voie 'A'. Dans la réalité, une petite quantité du signal incident fuit à travers le trajet avant du coupleur et parvient donc jusqu'à la voie 'A'.

Cette incertitude de mesure est appelée erreur de d irectivité. Elle peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur de directivité

  1. Lors de l'étalonnage, une charge standard (étalon) est connectée au port 1. La réflexion de cette charge est supposée nulle.

  2. Le signal mesuré sur la voie 'A' est la fuite du signal incident à travers le coupleur.

  3. L'erreur de directivité est soustraite des mesures de réflexion qui suivent.

Erreur d'isolement

Idéalement, seul le signal transmis à travers le CST est mesuré sur la voie 'B'.

Dans la réalité, une petite quantité du signal fuit et parvient jusqu'au récepteur de la voie 'B' en empruntant divers trajets à l'intérieur de l'analyseur.

Cette fuite de signal, également connue sous le nom de diaphonie, est l'erreur d'isolement ; elle peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur d'isolement

  1. Lors de l'étalonnage, deux charges standard (étalons) sont connectées aux ports 1 et 2 respectivement.

  2. Le signal mesuré sur la voie 'B' est la fuite de signal empruntant divers trajets à l'intérieur de l'analyseur.

  3. Cette erreur d'isolement est soustraite des mesures de transmission qui suivent.

Erreur d'adaptation de la source

Idéalement, la totalité du signal réfléchi par le CST au cours d'une mesure de réflexion est reçue sur la voie 'A'.

Dans la réalité, une partie du signal réfléchi par le CST est à nouveau réfléchie vers le port 1 et n'est donc pas reçue sur la voie 'A'.

Cette incertitude de mesure est appelée erreur d'adaptation de la source (ou désadaptation de la source) ; elle peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur d'adaptation de la source

  1. Lors de l'étalonnage, un court-circuit standard (étalon) est connecté au port 1. La réflexion connue de cet étalon est mesurée sur la voie 'A' et enregistrée dans l'analyseur.

  2. Un circuit ouvert (étalon) est ensuite connecté au port 1. La réflexion connue de cet étalon est mesurée sur la voie 'A' et enregistrée dans l'analyseur.

  3. L'analyseur compare les deux signaux enregistrés. Leur différence résulte de l'erreur d'adaptation de la source.

  4. L'erreur d'adaptation de la source peut ensuite être soustraite des mesures de réflexion et de transmission qui suivent.

Erreur d'adaptation de la charge

Idéalement, le signal incident passant à travers le CST au cours d'une mesure de transmission est reçu dans son intégralité sur la voie 'B'.

Dans la réalité, une partie du signal est réfléchie par le port 2 et n'est pas mesurée sur la voie 'B'.

Cette incertitude de mesure est appelée erreur d'a daptation de la c harge (ou désadaptation de la charge). Elle peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur d'adaptation de la charge

  1. Les connecteurs des ports de test 1 et 2 sont reliés l'un à l'autre pour établir une connexion directe parfaite, de longueur électrique nulle. (Si cette opération est impossible, notamment parce que les deux connecteurs sont du même sexe, un adaptateur de liaison directe est inséré.) Cela permet de transmettre au port 2 une quantité connue de signal incident.

  2. Le signal mesuré sur la voie 'A' est la réflexion du port 2 et constitue l'erreur d'adaptation de la charge.

  3. L'erreur d'adaptation de la charge peut ensuite être soustraite des mesures de transmission et de réflexion qui suivent.

Erreur de poursuite de réflexion due à la réponse en fréquence

Les mesures de réflexion sont réalisées par comparaison du signal sur la voie 'A' (voie de réflexion) au signal sur la voie 'R1' (voie de référence). C'est ce qu'on appelle la mesure du rapport "A sur R1" (A/R1).

L'idéal serait que la réponse en fréquence du récepteur de la voie 'A' soit identique à celle du récepteur de la voie 'R1'.

Ce n'est malheureusement pas le cas dans la réalité et il en résulte une erreur de poursuite de réflexion due à la réponse en fréquence. Il s'agit de la somme vectorielle de toutes les variations d'amplitude et de phase en fonction de la fréquence. Ces variations sont dues, entre autres :

    • aux dispositifs de séparation des signaux,

    • aux câbles de test,

    • aux adaptateurs,

    • aux différences de trajet des signaux de référence et de test.

L'erreur de poursuite de réflexion due à la réponse en fréquence peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur de poursuite de réflexion due à la réponse en fréquence

  1. Lors de l'étalonnage, un court-circuit standard (étalon) est connecté au port 1. La réflexion connue de cet étalon est mesurée sur la voie 'A' et enregistrée dans l'analyseur.

  2. Un circuit ouvert (étalon) est ensuite connecté au port 1. La réflexion connue de cet étalon est mesurée sur la voie 'A' et enregistrée dans l'analyseur.

  3. L'analyseur fait la moyenne des deux signaux mesurés sur la voie 'A' et enregistrés.

  4. La réponse moyenne ainsi obtenue est comparée à celle du signal de référence mesuré sur la voie 'R1'.

  5. Le résultat est la différence de réponse en fréquence entre les récepteurs de la voie 'A' et de la voie 'R1' (voir le diagramme suivant). Cette erreur de poursuite de réflexion est soustraite des mesures exécutées ensuite sur le CST.

Remarque : dans les étalonnages de mesure de réflexion, un seul étalon (circuit ouvert ou court-circuit) est mesuré et, par conséquent, il est le seul à contribuer à la c orrection des e rreurs.

Erreur de poursuite de transmission due à la réponse en fréquence

Les mesures de transmission sont réalisées par comparaison du signal sur la voie 'B' (voie de transmission) au signal sur la voie 'R1' (voie de référence). C'est ce qu'on appelle la mesure du rapport "B sur R1" (B/R1).

L'idéal serait que la réponse en fréquence du récepteur de la voie 'B' soit identique à celle du récepteur de la voie 'R1'.

Ce n'est malheureusement pas le cas dans la réalité et il en résulte une erreur de poursuite de transmission due à la réponse en fréquence. Il s'agit de la somme vectorielle de toutes les variations d'amplitude et de phase en fonction de la fréquence. Ces variations sont dues, entre autres :

    • aux dispositifs de séparation des signaux,

    • aux câbles de test,

    • aux adaptateurs,

    • aux différences de trajet des signaux de référence et de test.

L'erreur de poursuite de transmission due à la réponse en fréquence peut être mesurée et réduite par l'analyseur.

Comment l'analyseur mesure et réduit l'erreur de poursuite de transmission due à la réponse en fréquence

  1. Lors de l'étalonnage, les connecteurs des ports de test 1 et 2 sont reliés l'un à l'autre pour établir une connexion directe parfaite, de longueur électrique nulle. (Si cette opération est impossible, notamment parce que les deux connecteurs sont du même sexe, un adaptateur de liaison directe est inséré.) Cela permet de transmettre au port 2 une quantité connue de signal incident.

  2. Les signaux reçus sur les voies 'B' et 'R1' sont mesurés et enregistrés.

  3. L'analyseur compare les signaux des voies 'R1' et 'B'.

  4. Le résultat est la différence de réponse en fréquence entre les récepteurs de la voie 'B' et de la voie 'R1' (voir le diagramme suivant). Cette erreur de poursuite de transmission est soustraite des mesures exécutées ensuite sur le composant à tester.

.

L'analyseur enregistre les mesures des erreurs systématiques sous forme de termes d'erreur. Le contrôle de ces termes d'erreur peut vous aider à déterminer la qualité de fonctionnement de l'analyseur et la précision de vos mesures.

En imprimant ou en sauvegardant les termes d'erreur, vous pouvez les comparer périodiquement aux précédents termes obtenus avec le même instrument et le même kit d'étalonnage. Si vous ne disposez pas de termes d'erreur précédemment enregistrés, basez-vous sur les valeurs et les résultats de mesures type figurant dans le chapitre 4, "Error Terms", du guide de maintenance (Service Guide).

  • Dans le cas d'un système stable, les termes d'erreur générés au fil des étalonnages restent identiques pendant environ six mois.

  • Si les termes d'erreur viennent à changer soudainement alors que vous n'avez modifié aucun réglage (plage de fréquences, niveau de puissance et récepteur), cela peut être le signe d'une défaillance d'un composant du système. Pour savoir comment interpréter les changements dans les termes d'erreur, reportez-vous au chapitre 4, "Error Terms", du guide de maintenance (Service Guide).

  • Lorsque les termes d'erreur s'écartent progressivement de leur valeur initiale au fil des mois, cela révèle souvent une dérive ou une usure des connecteurs et des câbles. Généralement, le remède consiste simplement à nettoyer et à ajuster les connecteurs ou à inspecter les câbles. Cliquez sur un bouton ci-dessous pour accéder à l'une des procédures de mesure des termes d'erreur.

Les procédures suivantes indiquent comment rappeler et enregistrer les termes d'erreur dans l'analyseur :

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Procédez à un étalonnage complet sur deux ports (Full SOLT 2-Port). Pour plus de détails, reportez-vous à la rubrique Sélectionner et exécuter un étalonnage de mesure.

  2. Dans le menu System, pointez sur Service, puis sur Utilities. Cliquez sur Evaluate Error Corr Data.

  3. Dans la boîte de dialogue, sélectionnez l'un des termes d'erreur du port 1 ou du port 2.

    • Cliquez sur Apply : la trace du terme d'erreur s'affiche, tandis que la boîte de dialogue reste ouverte pour vous permettre d'effectuer une autre sélection.

    • Cliquez sur OK : la boîte de dialogue se ferme et la trace du terme d'erreur reste affichée.

  4. Dans le menu Scale, cliquez sur Autoscale pour obtenir une mise à l'échelle optimale de la mesure affichée.

  5. Utilisez les marqueurs de l'analyseur pour inspecter les détails de la trace du terme d'erreur.

  6. Si vous suspectez une défaillance subtile ou un léger problème de performances, comparez la trace des termes d'erreur à d'autres traces générées précédemment avec le même instrument et le même kit d'étalonnage. Cette comparaison constitue le moyen le plus sûr et le plus précis d'identifier la cause du problème. Pour plus de détails, ou si vous ne disposez pas de termes d'erreur précédemment enregistrés, consultez le chapitre 4, "Error Terms", du guide de maintenance (Service Guide).

Procédure à l'aide des touches de la face avant

  1. Procédez à un étalonnage complet sur deux ports (Full SOLT 2-Port). Pour plus de détails, reportez-vous à la rubrique Sélectionner et exécuter un étalonnage de mesure.

  2. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  3. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour accéder au menu System.

  4. Appuyez sur la flèche vers le bas pour accéder à Service. Appuyez sur Click.

  5. Appuyez sur la flèche vers le bas pour accéder à Utilities. Appuyez sur Click.

  6. L'option Evaluate Error Corr Data est sélectionnée par défaut. Appuyez sur Click.

  7. Appuyez sur la touche Tab à droite pour sélectionner la partie Port 1 Error Terms ou Port 2 Error Terms de la boîte de dialogue. Utilisez la flèche vers le bas ou vers le haut pour sélectionner l'un des termes d'erreur du port choisi.

    • Appuyez sur la touche Tab à droite pour sélectionner Apply. Appuyez sur Click. La trace du terme d'erreur s'affiche, tandis que la boîte de dialogue reste ouverte pour vous permettre d'effectuer une autre sélection.

    • Appuyez sur la touche Tab à droite pour sélectionner OK. Appuyez sur Click. La boîte de dialogue se ferme et la trace du terme d'erreur reste affichée.

  8. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  9. Appuyez sur la touche Tab à droite pour sélectionner le menu Scale.

  10. L'option Autoscale est sélectionnée par défaut. Appuyez sur Click pour obtenir une mise à l'échelle optimale de la mesure affichée.

  11. Utilisez les marqueurs de l'analyseur pour inspecter les détails de la trace du terme d'erreur.

  12. Si vous suspectez une défaillance subtile ou un léger problème de performances, comparez la trace des termes d'erreur à d'autres traces générées précédemment avec le même instrument et le même kit d'étalonnage. Cette comparaison constitue le moyen le plus sûr et le plus précis d'identifier la cause du problème. Pour plus de détails, ou si vous ne disposez pas de termes d'erreur précédemment enregistrés, consultez le chapitre 4, "Error Terms", du guide de maintenance (Service Guide).

Rappel automatisé des termes d'erreur

Reportez-vous au document Data / Error Terms pour une description des commandes SCPI et COM permettant de rappeler et d'enregistrer les termes d'erreur.


Cal_Stds

Voir aussi...

Etalons

Présentation

Concepts

Comment modifier les étalons

Lors de l'étalonnage, l'analyseur mesure différents étalons et compare mathématiquement les résultats aux "modèles idéaux" de ces étalons. Les différences constatées sont séparées en plusieurs termes d'erreur qui seront soustraits des mesures de composants au cours de la c orrection des e rreurs.
Concepts

Comment modifier les étalons

Tous les étalons ont une définition précise qui comprend le retard électrique, l'impédance et la perte. L'analyseur enregistre ces définitions et les utilise pour calculer les termes de correction d'erreurs.

Kits d'étalonnage

Modification du fichier d'un kit d'étalonnage

Etalons

Menu Modify Calibration Kit

Etalonnage électronique (ECal)

Kits d'étalonnage

Les kits d'étalonnage contiennent des étalons (ou dispositifs d'étalonnage) que l'analyseur mesure au cours du processus d'étalonnage. Ces kits sont disponibles auprès d'Agilent Technologies et existent avec différents types de connecteurs. Chaque kit contient généralement :

  • Un court-circuit

  • Un circuit ouvert

  • Une charge adaptée en impédance

Définitions

  • Un "étalon" (représenté par un numéro de 1 à 8) est un composant physique spécifique et bien défini qui est utilisé pour déterminer les erreurs systématiques. Par exemple, l'étalon 1 est un court-circuit dans le kit d'étalonnage 85033E 3,5 mm.

  • Le "type" d'un étalon est l'un des quatre types de base qui définissent la forme ou la structure du modèle à utiliser avec cet étalon :

    • Court-circuit (Short)

    • Circuit ouvert (Open)

    • Charge (Load)

    • Liaison directe (Thru)

  • L'étalon 1 est du type court-circuit (dans le kit d'étalonnage 3,5 mm).

  • Les "caractéristiques" des étalons sont des données numériques qui déterminent les caractéristiques physiques des étalons utilisés dans le modèle sélectionné.

Dans la plupart des kits nécessitant des adaptateurs pour l'interfaçage mécanique avec les ports de test, les adaptateurs sont appariés en termes de déphasage. Vous pouvez utiliser des étalons qui ne font pas partie d'un kit d'étalonnage en spécifiant leurs caractéristiques dans un kit personnalisé (voir à cet effet la section "Modification du fichier d'un kit d'étalonnage").

Pour obtenir la liste des kits d'étalonnage utilisables avec l'analyseur (comprenant ceux dont les définitions sont stockées dans l'instrument), reportez-vous à la rubrique Accessoires disponibles.

Modification du fichier d'un kit d'étalonnage

Plusieurs situations peuvent vous amener à créer votre propre fichier de kit d'étalonnage :

  • Votre port possède un type de connecteur répertorié sous le menu Cal Kit, mais vos étalons (par exemple, un court-circuit) ont des caractéristiques différentes de celles qui sont définies dans les kits d'étalonnage enregistrés dans l'analyseur.

  • Votre port possède un type de connecteur qui ne correspond à aucune des définitions de kit d'étalonnage enregistrées dans l'analyseur.

  • Vous étalonnez l'analyseur en vue de mesurer un composant non insérable. Voir Etalonnage précis des mesures.

Vous pouvez modifier le fichier d'un kit d'étalonnage prédéfini et l'enregistrer en tant que fichier de kit d'étalonnage personnalisé. Le fichier original du kit prédéfini restera inchangé.

Remarque : le présent texte n'a pas pour objectif de décrire en détail la modification des kits d'étalonnage. Pour des informations plus complètes, rendez-vous sur le site Web www.agilent.com/find/assist et recherchez la note produit (Product Note) 8510-5A, "Specifying Calibration Standards for the HP 8510 Network Analyzer," (référence 5956-4352).

Vous pouvez fabriquer ou modifier des étalons et leurs définitions en appliquant la procédure suivante :

  1. Sélectionnez les étalons.

  2. Utilisez le menu Modify Calibration Kit.

Etalons

En premier lieu, vous devez choisir une méthode d'étalonnage correspondant à la précision exigée. (Pour une présentation des méthodes d'étalonnage disponibles, reportez-vous à la rubrique Sélection et exécution d'un étalonnage de mesure.) Ce choix détermine les étalons dont vous aurez besoin pour effectuer l'étalonnage.

Voici trois étalons couramment employés pour les composants à câblage coaxial :

  • Court-circuit de longueur électrique nulle

  • Circuit ouvert blindé

  • Charge adaptée en impédance (actuellement, l'analyseur n'admet pas les charges coulissantes ou décalées)

Remarque : l'étalon de "liaison directe" (Thru) n'a généralement pas de réalité physique, en ce sens qu'il s'agit d'établir la liaison directe en connectant les ports de test directement l'un à l'autre. Pour plus de détails, reportez-vous à la rubrique "Etalonnage précis des mesures".

Les étalons doivent être dans le même milieu que le composant à tester (par exemple, coaxial, guide d'ondes ou microruban). Pour réaliser l'étalonnage nécessaire, vous pouvez :

  • acheter des étalons ;

  • fabriquer des étalons ;

  • modifier des étalons existants.

Quelle que soit la méthode adoptée, choisissez les étalons en fonction des critères suivants :

  • Une réponse bien définie, reproductible et stable en température.

  • Des impédances distinctes les unes des autres. Par exemple :

    • Un court-circuit de longueur électrique nulle et un circuit ouvert blindé présentent un écart de phase de 180°.

    • Une charge de précision adaptée en impédance présente une différence d'amplitude de 40 à 50 dB par rapport au court-circuit et au circuit ouvert.

  • Une couverture large bande de la gamme de fréquences qui vous intéresse.

Menu Modify Calibration Kit

Explorez le graphique ci-dessous pour vous familiariser avec les différentes fonctions :

La section Calibration Kit de la boîte de dialogue contient les éléments suivants :

  • Un choix de 10 numéros Cal Kit ID (voir le tableau ci-après) :

    • Les ID 1 à 6 sont des kits d'étalonnage prédéfinis. Ne les modifiez pas si vous pensez en avoir besoin pour de futures mesures.

    • Les ID 7 à 10 correspondent aux kits d'étalonnage personnalisables. Modifiez un kit prédéfini et enregistrez-le en tant que kit personnalisé. Le kit prédéfini original restera inchangé.

  • Un champ éditable Cal Kit Name (nom du kit d'étalonnage).

  • Un bouton Restore Default Kit. Celui-ci permet de rétablir les valeurs prédéfinies du kit d'étalonnage sélectionné.

  • Un bouton Restore ALL Default Kits. Celui-ci permet de rétablir les valeurs prédéfinies de tous les kits d'étalonnage.
ID du kit | Port 1 | Port 2 | Nom du kit
1 | Type N (f) | Type N (m) | Type-N Model 85032F
2 | 3,5 mm | 3,5 mm | 3.5 mm Model 85033E
3 | Type N (f) | Type N (m) | Type-N Model 85032B
4 | 3,5 mm | 3,5 mm | 3.5 mm Model 85033D
5 | 7-16 | 7-16 | 7-16 Model 85038A
6 | TRL 3,5 mm | TRL 3,5 mm | TRL 3.5 mm Model 85052C
7 | Type N (f) | Type N (m) | User Cal Kit 7
8 | Type N (f) | Type N (m) | User Cal Kit 8
9 | Type N (f) | Type N (m) | User Cal Kit 9
10 | Type N (f) | Type N (m) | User Cal Kit 10

La section Assign Standards to Ports de la boîte de dialogue contient les éléments suivants :

  • Une zone éditable Port 1 pour la spécification du type de connecteur de ce port.

  • Une zone éditable Port 2 pour la spécification du type de connecteur de ce port.

  • Huit classes (quatre pour chaque port) d'affectation des étalons :
Classes de réflexion (six) | Classes de transmission (deux)
S11A (circuit ouvert - n°8) | S21T (liaison directe - longueur nulle - n°4)
S11B (court-circuit - n°7) | S12T (liaison directe - longueur nulle - n°4)
S11C (charge - n°3) |
S22A (circuit ouvert - n°2) |
S22B (court-circuit - n°1) |
S22C (charge - n°3) |

Remarque : Dans l'exemple ci-dessus, des étalons type N ont été affectés aux différentes classes.

Une classe d'étalonnage établit la corrélation entre un étalon et la place qu'il occupe dans les calculs des termes d'erreur. Les classes A, B et C servent à la résolution des termes suivants :

  • D irectivité (S11C, S22C)

  • Adaptation de la source (S11A, S11B, S22A, S22B)

  • Erreur de poursuite de réflexion (S11A, S11B, S22A, S22B)

Les classes "T" servent à calculer les termes suivants :

  • Erreur de poursuite de transmission (S21T, S12T)

  • A daptation de la c harge (S21T, S12T)

Un étalon doit être affecté à chacune des huit classes d'étalonnage. Les affectations par défaut dans les kits d'étalonnage sont les suivantes :

1. Court-circuit (m) | 5. Liaisons directe (adaptateur personnalisé)
2. Circuit ouvert (m) | 6. Charge bande étroite
3. Charge large bande | 7. Court-circuit (f)
4. Liaison directe (longueur nulle) | 8. Circuit ouvert (f)

La section Modify Standard Definition de la boîte de dialogue contient les éléments suivants (obligatoires pour une définition complète) :

  • Standard number (1 à 8)

  • Minimum Frequency

  • Maximum Frequency

  • ZO (impédance)

  • Delay

  • Loss

  • Type (Open, Short, Load, Thru)

  • Character (Coax, Waveguide)

  • Label

  • Valeurs de capacité (C0, C1, C2, C3) - utilisées uniquement pour caractériser les étalons de type circuit ouvert.

  • Termes d'inductance (L0, L1, L2, L3) - utilisés uniquement pour caractériser les étalons de type court-circuit.

Les définitions du kit d'étalonnage sont les caractéristiques électriques des étalons que vous avez choisis. Ces caractéristiques peuvent être obtenues de deux manières :

  • Elles peuvent être déterminées d'après les dimensions physiques et le matériau de chaque étalon.

  • Elles peuvent être mesurées sur un analyseur de réseau étalonné.

Caractéristiques

  • Z0

    • Le décalage d'impédance entre l'étalon en cours de définition et le plan de mesure réel.

    • Généralement égale à l'impédance caractéristique du système.

  • Delay (retard)

    • Equivaut à une longueur uniforme de ligne de transmission entre l'étalon en cours de définition et le plan de mesure réel.

    • Pour un circuit ouvert, un court-circuit et une charge, le retard exprime le temps de trajet "aller simple", en secondes, entre le plan de mesure et l'étalon.

    • Pour une liaison directe, le retard exprime le temps de trajet "aller simple", en secondes, entre les deux plans de mesure.

    • Le retard peut être soit mesuré, soit déterminé en divisant la longueur physique exacte de l'étalon par le facteur de célérité.

ATTENTION : Si les deux ports doivent être reliés l'un à l'autre par un adaptateur de liaison directe au cours de l'étalonnage, il convient de modifier les kits d'étalonnage respectifs de ces deux ports en y indiquant la même valeur de retard (celle de l'adaptateur).

  • Loss (perte)

    • Caractéristique spécifiant la perte d'énergie résultant de l'effet de peau sur une longueur de câble coaxial.

    • La valeur de perte est indiquée en ohms/seconde à 1 GHz.

    • Dans de nombreux cas, la valeur de perte peut être réglée à zéro sans dégradation notable.

    • Pour calculer la perte caractérisant votre étalon, mesurez le retard en secondes et la perte en dB à 1 GHz. Appliquez ensuite la formule suivante :

  • C0, C1, C2, C3

    • A haute fréquence, un circuit ouvert présente rarement des caractéristiques de réflexion parfaites, car une capacitance de fuite entraîne un décalage de phase qui varie avec la fréquence. Ces effets sont impossibles à éliminer, mais le calcul intégré dans l'analyseur comprend un modèle de capacité de circuit ouvert. Il s'agit d'un polynôme du troisième ordre fonction de la fréquence dont les coefficients sont paramétrables par l'utilisateur.

    • L'équation du modèle de capacité est la suivante :

    • C = (C0) + (C1 x F) + (C2 x F²) + (C3 x F³)

    • (F est la fréquence de mesure).

    • Les termes de l'équation sont définis comme suit lors de la spécification des caractéristiques du circuit ouvert :

      • C0 est la constante du polynôme du troisième ordre, exprimée en Farads.

      • C1 est exprimé en F/Hz (Farads/Herz).

      • C2 est exprimé en F/Hz².

      • C3 est exprimé en F/Hz³.

  • L0, L1, L2, L3

    • A haute fréquence, un court-circuit présente rarement des caractéristiques de réflexion parfaites, car une inductance résiduelle entraîne un décalage de phase qui varie avec la fréquence. Ces effets sont impossibles à éliminer, mais le calcul intégré dans l'analyseur comprend un modèle d'inductance de court-circuit. Il s'agit d'un polynôme du troisième ordre fonction de la fréquence dont les coefficients sont paramétrables par l'utilisateur.

    • L'équation du modèle d'inductance est la suivante :

    • L = (L0) + (L1 x F) + (L2 x F²) + (L3 x F³)

    • (F est la fréquence de mesure).

    • Les termes de l'équation sont définis comme suit lors de la spécification des caractéristiques du court-circuit :

      • L0 est la constante du polynôme du troisième ordre, exprimée en Henries.

      • L1 est exprimé en H/Hz (Henries/Hertz).

      • L2 est exprimé en H/Hz².

      • L3 est exprimé en H/Hz³.

Lorsque vous avez défini les caractéristiques de vos étalons, saisissez-les dans les champs appropriés de la boîte de dialogue.

Dans la plupart des kits d'étalonnage, la même définition est utilisée pour les étalons mâles et femelles des types court-circuit, circuit ouvert et charge.

Dans la plupart des kits existants, la définition de l'étalon "Thru" (généralement le numéro 4) est celle d'une "liaison directe de longueur nulle". Notez que les valeurs de retard et de perte sont égales à zéro. Cela signifie qu'il n'y a pas d'étalon "Thru". L'étalonnage du chemin électrique direct est réalisé en connectant directement les deux ports l'un à l'autre. Pour plus de détails, reportez-vous à la rubrique Etalonnage précis des mesures.

Remarque : La précision de mesure dépend directement de l'exactitude avec laquelle les étalons correspondent à leur définition. Si vos étalons sont endommagés ou usés, les mesures seront moins précises.

Etalonnage électronique (ECal)

  • ECal est une solution d'étalonnage complète et entièrement câblée.

    • Elle facilite et accélère les étalonnages sur un port (réflexion) et sur deux ports.

    • Elle rend l'étalonnage moins vulnérable aux erreurs de l'opérateur.

    • Les différents étalons (situés à l'intérieur du module d'étalonnage) ne s'usent jamais, car ils sont commutés au moyen de diodes PIN ou de transistors à effet de champ (TEC).

  • Les modules d'étalonnage sont caractérisés au moyen d'un analyseur de réseau étalonné suivant la méthode TRL.

  • La précision obtenue avec la solution ECal n'est pas aussi bonne que celle d'un étalonnage TRL.

Pour des informations plus complètes, adressez-vous à votre interlocuteur Agilent.

Cliquez sur l'un des boutons ci-après pour accéder à la procédure de modification du fichier d'un kit d'étalonnage.

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Calibration, cliquez sur Advanced Modify Cal Kit.

  2. Cliquez sur la boîte Cal Kit ID dans la section Calibration Kit de la boîte de dialogue. Tapez une valeur ou cliquez sur la flèche pour sélectionner le numéro (ID) du kit d'étalonnage souhaité.

    • Pour rétablir les valeurs prédéfinies du kit choisi, cliquez sur Restore Default Kit.

    • Pour rétablir les valeurs prédéfinies de tous les kits d'étalonnage, cliquez sur Restore ALL Default Kits.

  3. Dans le champ Cal Kit Name, éditez le nom du kit prédéfini afin de créer un nouveau nom.

Section Assign Standards to Ports

  1. Cliquez sur le champ Port 1 dans la section Assign Standards to Ports de la boîte de dialogue. Editez le type de connecteur.

  2. Editez le type de connecteur dans le champ Port 2.

  3. Tapez un nouveau numéro d'étalon dans chacune des huit boîtes de classe d'étalonnage (par exemple, S11A) ou utilisez le bouton fléché pour sélectionner le numéro souhaité.

Section Modify Standard Definition

  1. Cliquez sur la boîte Standard No. dans la section Modify Standard Definition de la boîte de dialogue. Tapez un nouveau numéro d'étalon ou cliquez sur le bouton fléché pour sélectionner le numéro souhaité.

  2. Entrez toutes les définitions de l'étalon sélectionné à l'étape précédente (par exemple, la fréquence minimale, la fréquence maximale, l'impédance Z0, le retard, la perte, etc.). Tapez les valeurs directement dans les champs ou sélectionnez-les à l'aide des boutons fléchés.

  3. Répétez les étapes 1 et 2 pour chaque numéro d'étalon.

  4. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, utilisez la touche Tab à droite et la flèche vers le bas pour accéder au menu Calibration.

    1. Appuyez sur la flèche vers le bas pour accéder à Advanced Modify Cal.

    2. Appuyez sur Click.

  3. La boîte Cal Kit ID est automatiquement sélectionnée dans la section Calibration Kit de la boîte de dialogue. Tapez une valeur ou utilisez les touches fléchées pour sélectionner le numéro (ID) du kit d'étalonnage souhaité.

  4. Appuyez sur la touche Tab à droite pour accéder au champ Cal Kit Name. Remplacez le nom du kit prédéfini par un nouveau nom.

  5. Appuyez sur la touche Tab à droite pour accéder à Restore Default Kit. Pour rétablir les valeurs prédéfinies du kit choisi, appuyez sur Click.

  6. Appuyez sur la touche Tab à droite pour accéder à Restore ALL Default Kits. Pour rétablir les valeurs prédéfinies de tous les kits d'étalonnage, appuyez sur Click.

Section Assign Standards to Ports

  1. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour sélectionner le champ Port 1 dans la section Assign Standards to Ports de la boîte de dialogue. Editez le type de connecteur.

  2. Appuyez sur la touche Tab à droite pour accéder au champ Port 2. Editez le type de connecteur.

  3. Appuyez sur la touche Tab à droite pour accéder à chacune des huit boîtes de classe d'étalonnage (par exemple, S11A). Tapez un nouveau numéro d'étalon dans chacune de ces boîtes ou utilisez les touches fléchées pour sélectionner le numéro souhaité.

Section Modify Standard Definition

  1. Appuyez sur la touche Tab à droite pour sélectionner la boîte Standard No. dans la section Modify Standard Definition de la boîte de dialogue. Tapez le numéro d'étalon ou utilisez les touches fléchées pour sélectionner le numéro souhaité.

  2. Entrez les définitions de l'étalon sélectionné à l'étape précédente (par exemple, la fréquence minimale, la fréquence maximale, l'impédance Z0, le retard, la perte, etc.). Tapez les valeurs directement dans les champs ou sélectionnez-les à l'aide des touches fléchées.

  3. Répétez les étapes 1 et 2 pour chaque numéro d'étalon.

  4. Dans le bloc COMMAND, appuyez sur OK.


Select_Cal

Voir aussi...

Sélectionner et exécuter un étalonnage de mesure

Présentation

Choix
d'étalonnages

Assistant
et fonctions

Comment réaliser
un étalonnage

L'étalonnage de mesure que vous sélectionnez et exécutez dépend des éléments suivants :

  • La mesure que vous réalisez.

  • Le niveau de précision requis pour l'application de la mesure.
Choix d'étalonnages

Assistant et fonctions d'étalonnage de mesure

Comment réaliser un étalonnage de mesure

Cliquez sur un bouton pour en savoir plus sur les points suivants :
Choix de méthodes d'étalonnage de mesure

Aucune

Réponse OPEN ou SHORT

Réponse THRU

Réponse THRU et isolement

1 port (Réflexion)

SOLT complet sur 2 ports (SHORT, OPEN, LOAD, THRU)

TRL complet sur 2 ports (THRU, REFLECT, LINE)

Récapitulatif des choix d'étalonnages de mesure

Méthodes d'étalonnage de mesure

En général, plus un étalonnage est précis :

  • Plus l'exécution de l'étalonnage prend de temps.

  • Plus la mesure par l'analyseur prend de temps.

Aussi, lorsque vous sélectionnez une méthode d'étalonnage de mesure, il est important de connaître le niveau d'incertitude que vous pouvez tolérer pour votre mesure.

En fonction du paramètre S et du sens de la mesure (vers l'avant, vers l'arrière ou les deux), vous pouvez choisir l'une des méthodes d'étalonnage de mesure suivantes :

Méthode d'étalonnage | Précision générale | Paramètres | Etalons requis
Aucune | Médiocre | TOUS | 0
Réponse OPEN ou SHORT | Bien | S11 ou S22 | Circuit ouvert, Court-circuit
Réponse THRU | Bien | S21 ou S12 | Liaison directe
Réponse THRU et isolement | Bien | S21 ou S12 | Liaison directe, Charge
ECal 1 port (Réflexion) | Mieux | S11 ou S22 | Module ECal
1 port (Réflexion) | Mieux | S11 ou S22 | Court-circuit, Circuit ouvert,, Charge
ECal complet sur 2 ports | Prochain meilleur | TOUS | Module ECal
SOLT complet sur 2 ports | Meilleur | TOUS | Court-circuit, Circuit ouvert, Charge, Liaison directe
TRL complet sur 2 ports | Optimal | TOUS | Liaison directe, Circuit ouvert ou Court-circuit, Ligne

Méthode d'étalonnage : Aucune

  • A utiliser pour toutes les mesures de paramètres S.

  • Ne mesure aucun étalon.

  • Etalonnage extrêmement rapide mais peu précis.

  • A utiliser seulement si votre mesure ne nécessite pas une grande précision.

Correction des erreurs systématiques

  • Aucune

Etalonnage de réponse OPEN ou SHORT (REFLECTION)

  • A utiliser uniquement pour les mesures REFLECTION sur n'importe quel port.

  • Mesure un circuit ouvert ou un court-circuit étalon.

  • Etalonnage très rapide, mais moyennement précis.

Correction des erreurs systématiques

  • Poursuite de la réflexion de la r éponse en fréquence

Remarque : lorsqu'une réflexion est exécutée

Configuration pour un étalonnage de réponse OPEN ou SHORT

Etalonnage de réponse THRU (TRANSMISSION)

  • A utiliser uniquement pour les mesures TRANSMISSION dans n'importe quel sens.

  • Mesure une liaison directe étalon.

  • Etalonnage très rapide, mais moyennement précis.

Correction des erreurs systématiques

  • Poursuite de la transmission de la réponse en fréquence

Remarque : la définition de la liaison directe de l'analyseur pour les kits d'étalonnage prédéfinis suppose une liaison directe de longueur nulle. Si vous utilisez un adaptateur comme une liaison directe, vous devez caractériser la liaison directe pour la précision la plus élevée. Pour plus d'informations, voir Etalonnages de mesure précis.

Configuration pour un étalonnage de réponse Thru

Etalonnage de réponse THRU et d'isolement (TRANSMISSION)

  • A utiliser uniquement pour les mesures TRANSMISSION dans n'importe quel sens.

  • La portion I solement du v sert à mesurer les composants à forte perte d'i nsertion.

  • Mesure une liaison directe et une charge étalons.

  • Etalonnage très rapide, mais moyennement précis.

Correction des erreurs systématiques

  • Isolement

  • Poursuite de la transmission de la réponse en fréquence

Remarque : la définition de la liaison directe de l'analyseur pour les kits d'étalonnage prédéfinis suppose une liaison directe de longueur nulle. Si vous utilisez un adaptateur comme une liaison directe, vous devez caractériser la liaison directe pour la précision la plus élevée. Pour plus d'informations, voir Etalonnages de mesure précis.

Configuration pour un étalonnage de réponse Thru et d'isolement

Etalonnage de la réflexion sur 1 port

  • A utiliser uniquement pour les mesures REFLECTION sur n'importe quel port.

  • Mesure un court-circuit, un circuit ouvert et une charge étalons.

  • Précision élevée pour une mesure sur 1 port.

Correction des erreurs systématiques

  • D irectivité

  • Adaptation de la source

  • Poursuite de la réflexion de la réponse en fréquence

Remarque : lorsque vous exécutez une mesure de réflexion sur un composant à 2 ports, après un étalonnage de réflexion sur 1 port, appliquez une terminaison au port de sortie. Sinon, le signal réfléchi du port de sortie risque de diminuer la précision de la mesure, notamment sur les composants à faible perte d'i nsertion .

Configurations pour un étalonnage sur 1 port (Réflexion)

Etalonnage de la réflexion sur 1 port ECal

  • A utiliser uniquement pour les mesures de réflexion sur n'importe quel port.

  • Mesure un module à semi-conducteurs (connecté au connecteur USB).

  • Précision élevée pour une mesure sur 1 port.

  • Minimise l'usure de la configuration test.

  • Elimine les erreurs de l'opérateur.

  • Ecourte les temps d'étalonnage.

Correction des erreurs systématiques

  • Directivité

  • Adaptation de la source

  • Poursuite de la réflexion de la réponse en fréquence

Remarque : lorsque vous exécutez une mesure de réflexion sur un composant à 2 ports, après un étalonnage de réflexion sur 1 port, appliquez une terminaison au port de sortie. Sinon, le signal réfléchi du port de sortie risque de diminuer la précision de la mesure, notamment sur les composants à faible perte d'insertion.

Configuration pour un étalonnage ECal

Etalonnage SOLT complet sur 2 ports (Short, Open, Load, Thru)

  • A utiliser pour toutes les mesures paramètre S.

  • Mesure un court-circuit, un circuit ouvert, une charge et une liaison directe étalons.

  • Appelé "correction d'erreurs à 12 termes" pour le nombre d'erreurs résolues : 6 erreurs vers l'avant et vers l'arrière.

  • Mesure de très haute précision.

Correction des erreurs systématiques

  • Directivité

  • Isolement

  • Adaptation de la source

  • Adaptation de la charge

  • Poursuite de la réflexion de la réponse en fréquence

  • Poursuite de la transmission de la réponse en fréquence

Remarque : l' étalonnage d'isolement est utile lorsque vous mesurez des composants à forte perte d'i nsertion . Si vous ne mesurez pas des composants à forte perte d'insertion, PASSEZ OUTRE l'étalonnage d'isolement. Des erreurs peuvent se produire lorsque vous mesurez des signaux de bas niveau près du seuil de bruit de l'analyseur lors de l'étalonnage d'isolement.

Configurations pour un étalonnage SOLT complet sur 2 ports

Etalonnage TRL complet sur 2 ports (Thru, Reflect, Line)

  • A utiliser pour toutes les mesures paramètre S.

  • Mesure une liaison directe, une réflexion (court-circuit ou circuit ouvert) et une ligne de transmission étalons.

  • Appelé "correction d'erreurs à 12 termes" pour le nombre d'erreurs résolues : 6 erreurs vers l'avant et vers l'arrière.

  • Meilleure précision de tous les étalonnages

Correction des erreurs systématiques

  • Directivité

  • Isolement

  • Adaptation de la source

  • Adaptation de la charge

  • Poursuite de la réflexion de la réponse en fréquence

  • Poursuite de la transmission de la réponse en fréquence

Remarque : l'étalonnage d'isolement est utile lorsque vous mesurez des composants à forte perte d'insertion. Si vous ne mesurez pas des composants à forte perte d'insertion, passez outre l'étalonnage d'isolement car des erreurs peuvent se produire lorsque vous mesurez des signaux de bas niveau près du seuil de bruit de l'analyseur.

Le seul kit d'étalonnage TRL prédéfini dans la mémoire de l'analyseur est le TRL 3,5 mm modèle 85052C. Pour exécuter un étalonnage TRL avec un type de connecteur différent de 3,5 mm, vous devez d'abord modifier ou créer des standards et des définitions TRL. Pour plus d'informations sur la modification des standards, voir Etalons.

Etalonnage ECal complet sur 2 ports

  • A utiliser pour toutes les mesures paramètre S.

  • Mesure un module à semi-conducteurs (connecté au connecteur USB).

  • Appelé "correction d'erreurs à 12 termes" pour le nombre d'erreurs résolues : 6 erreurs vers l'avant et vers l'arrière.

  • Mesure de très haute précision.

  • Minimise l'usure du dispositif de test.

  • Réduit les erreurs de l'opérateur.

  • Réduit sensiblement le temps d'étalonnage.

Correction des erreurs systématiques

  • Directivité

  • I solement

  • Adaptation de la source

  • Adaptation de la charge

  • Poursuite de la réflexion de la réponse en fréquence

  • Poursuite de la transmission de la réponse en fréquence

Configuration pour un étalonnage ECal

Récapitulatif des choix d'étalonnages de mesure

Type de mesure | Choix d'étalonnages
S11 | Réponse Open Réponse Short 1 port (Réflexion) ECal 1 port (Réflexion) SOLT complet sur 2 ports TRL complet sur 2 ports ECal complet sur 2 ports
S21 | Réponse Thru Réponse Thru et isolement SOLT complet sur 2 ports TRL complet sur 2 ports ECal complet sur 2 ports
S12 | Réponse Thru Réponse Thru et isolement SOLT complet sur 2 ports TRL complet sur 2 ports ECal complet sur 2 ports
S22 | Réponse Open Réponse Short 1 port (Réflexion) ECal sur 1 port (Réflexion) SOLT complet sur 2 ports TRL complet sur 2 ports ECal complet sur 2 ports
Puissance non sous forme de rapport | Fonctions mathématiques/mémoire
Rapport arbitraire | Fonctions mathématiques/mémoire

Cliquez sur un bouton pour en savoir plus sur les points suivants :
Assistant d'étalonnage

Activer/désactiver la correction

Propriétés de l'étalonnage

Stockage des données d'étalonnage

Modification des données d'étalonnage actuelles

Rappel de l'étalonnage de mesure

Assistant d'étalonnage

L'assistant d'é talonnage est une série de boîtes de dialogue qui contribue à simplifier le processus d'étalonnage.

Remarque : les étiquettes du kit d'étalonnage dans l'analyseur indiquent le genre du connecteur du port de test, et non celui du connecteur du standard d'étalonnage.

Le bloc Select Calibration Type contient :

  • Le type d'étalonnage actuellement sélectionné. Dans cet exemple, "Aucune" est sélectionné.

  • La boîte de dialogue Cal Type avec les types d'étalonnage suivants :

    • Réponse OPEN

    • Réponse SHORT

    • Réponse THRU

    • Réponse THRU et isolement

    • 1 port (Réflexion)

    • SOLT complet sur 2 ports

    • TRL complet sur 2 ports

    • Aucune

La boîte de dialogue Cal Type contient également l'option Omit Isolation (2-Port types), qui vous permet d'ignorer la portion Isolement des étalonnages sur 2 ports.

Ce bloc Instrument Settings contient une boîte de dialogue Modify, qui vous permet de modifier les paramètres de fréquence de début/fin de l'analyseur.

Ce bloc Use Electronic calibration contient une boîte de dialogue Measure ECal Stds, qui fournit des graphiques et (si vous le désirez) des invites afin de vous guider à travers le processus ECal.

Ce bloc Use Mechanical Standards contient :

  • Un paramètre 2 Sets of Standards. Ce paramètre permet de mesurer simultanément deux séries d'étalons (par exemple, deux circuits ouverts) sur les ports 1 et 2 lorsque vous réalisez un étalonnage sur 2 ports.

  • Une boîte de dialogue Measure Standards qui fournit :

    • Des graphiques et des invites (si vous le désirez) afin de vous guider à travers le processus d'étalonnage sélectionné à l'aide de d'étalons mécaniques.

    • Un paramètre Show Prompts, qui vous permet de définir les invites qui accompagnent cette partie de l'assistant d'étalonnage à ON ou OFF.

    • Un paramètre Change Port, qui vous permet de modifier les affectations de port du kit d'étalonnage prédéfini et de caractériser une liaison directe/un adaptateur personnalisé(e) (si nécessaire). Ce paramètre vous permet également de sauvegarder vos modifications sous forme de kit d'étalonnage défini par l'utilisateur. Voir Etalonnage précis pour plus d'informations sur les étalons de liaison directe. Voir Etalons pour plus d'informations sur la modification des kits d'étalonnage.

    • Un paramètre Select Calibration Kit offrant les choix de kits d'étalonnage suivants :

ID kit | Port 1 | Port 2 | Nom kit d'étalonnage
1 | Type-N (f) | Type-N (m) | Type-N modèle 85032F
2 | 3,5 mm | 3,5 mm | 3,5 mm modèle 85033E
3 | Type-N (f) | Type-N (m) | Type-N modèle 85032B
4 | 3,5 mm | 3,5 mm | 3,5 mm modèle 85033D
5 | 7-16 | 7-16 | 7 à 16 modèle 85038A
6 | TRL 3,5 mm | TRL 3,5 mm | TRL 3,5 mm modèle 85052C
7 | Type-N (f) | Type-N (m) | Kit d'étalonnage utilisateur 7
8 | Type-N (f) | Type-N (m) | Kit d'étalonnage utilisateur 8
9 | Type-N (f) | Type-N (m) | Kit d'étalonnage utilisateur 9
10 | Type-N (f) | Type-N (m) | Kit d'étalonnage utilisateur 10

Remarque : Les kits 1 à 6 ont des définitions de kit d'étalonnage standard stockées dans l'analyseur.

Activer/désactiver la correction

Il est possible de définir la fonction Correction de l'analyseur à ON ou OFF.

  • En position ON, l'analyseur active la c orrection des e rreurs à l'aide des dernières données d'étalonnage du paramètre affiché. L' annotation C est affichée en bas de l'écran, suivie par le type d'étalonnage en cours (par exemple, 2-P SOLT ). Voir Validité d'un étalonnage de mesure pour plus d'informations sur les annotations affichées pour l'étalonnage.

  • En position OFF, l'analyseur désactive la correction des erreurs. L'annotation No Cor est affichée en bas de l'écran.

Propriétés de l'étalonnage

La fonction View Calibration Properties de l'analyseur affiche les paramètres suivants pour l'étalonnage en cours :

  • Voie

  • Fréquence de fin

  • Date d'étalonnage

  • Bande passante FI

  • Horodatage

  • Points de la trace

  • Type d'étalonnage

  • Temps de balayage

  • Correction

  • Puissance sur le port 1

  • Interpolation

  • Puissance sur le port 2

  • Fréquence de début

  • Type de balayage

Stockage des données d'étalonnage

  • Durant la procédure Cal Wizard, après la mesure des étalons (ou des modules) pour le type d'étalonnage sélectionné, le jeu d'étalonnage et l'état de l'instrument sont automatiquement sauvegardés dans un fichier *.cst. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur.

  • Vous pouvez sauvegarder manuellement le jeu d'étalonnage seulement (sans inclure l'état de l'instrument) dans un fichier *.cal. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur. Pour plus d'informations sur la sauvegarde manuelle des données d'étalonnage, voir Sauvegarder un fichier.

Modification des données d'étalonnage courantes

  • La prédéfinition de l'instrument rappelle le type d'étalonnage "Aucune".

  • La mise sous tension de l'instrument rappelle l'état de l'instrument ainsi que l'étalonnage associé qui était utilisé avant sa mise hors tension. Voir Commutateur de mise sous/hors tension.

Rappel de l'étalonnage de mesure

Remarque : les étalonnages sont spécifiques à la voie. Par exemple, un étalonnage réalisé sur la voie 1 ne peut pas être rappelé sur une autre voie. Voir Modèle de fonctionnement.

Les informations sur l'étalonnage de mesure sont liées à l'état de l'instrument au moment de l'étalonnage. Un jeu d'étalonnage sauvegardé peut être rappelé et utilisé pour différents états de l'instrument à condition que le paramètre de mesure, la plage de fréquences et le nombre de points soient compatibles.

  • Recalling a State and Cal Set (fichier *.cst) rappelle l'état de l'instrument sélectionné ainsi que son étalonnage associé à partir du disque.

  • Recalling a Cal Set (fichier *.cal) rappelle l'étalonnage sélectionné à partir du disque, mais pas l'état de l'instrument associé.

    • Si les paramètres courants de l'analyseur correspondent exactement à ceux utilisés au moment de l'étalonnage, la précision de l'étalonnage est très grande.

    • Lorsque I nterpolation est défini à ON, si les paramètres courants de l'analyseur ne correspondent pas exactement à ceux utilisés au moment de l'étalonnage, la précision de l'étalonnage est altérée. Exception : si la plage de fréquences courante de l'analyseur est plus large que celle utilisée au moment de l'étalonnage, l'étalonnage est défini à OFF.

    • Lorsque Interpolation est défini à OFF, si les paramètres courants de l'analyseur ne correspondent pas exactement à ceux utilisés au moment de l'étalonnage, l'étalonnage est désactivé.

  • Recalling a State Set (*.sta file) rappelle l'état de l'instrument sélectionné à partir de la mémoire, mais pas le jeu d'étalonnage associé. Au lieu de cela, le jeu d'étalonnage courant reste effectif.

    • Si les paramètres rappelés de l'analyseur correspondent exactement à ceux utilisés au moment de l'étalonnage, la précision de l'étalonnage est très grande.

    • Lorsque Interpolation est défini à ON, si les paramètres rappelés de l'analyseur ne correspondent pas exactement à ceux utilisés au moment de l'étalonnage, la précision de l'étalonnage est altérée. Exception : si la plage de fréquences rappelée de l'analyseur est plus large que celle utilisée au moment de l'étalonnage, l'étalonnage est défini à OFF.

    • Lorsque Interpolation est défini à OFF, si les paramètres rappelés de l'analyseur ne correspondent pas exactement à ceux utilisés au moment de l'étalonnage, l'étalonnage est désactivé.

Remarque : pour plus d'informations sur la validité d'un étalonnage après une modification des paramètres de l'analyseur, voir Validité d'un étalonnage de mesure.

Cliquez sur un bouton pour accéder aux procédures suivantes :
Utiliser l'assistant d'étalonnage

Définir la correction à ON ou OFF

Afficher les propriétés de l'étalonnage

Utiliser l'assistant d'étalonnage
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Calibration, cliquez sur Calibration Wizard.

Sélectionner un type d'étalonnage

  1. Cliquez sur Cal Type.

  2. Sélectionnez le type d'étalonnage désiré.

  3. Pour les étalonnages sur 2 ports, la case Omit Isolation (types 2 ports) est cochée par défaut. Si vous souhaitez inclure la portion isolement de l'étalonnage sur 2 ports, cochez la case.

  4. Cliquez sur OK.

Si vous souhaitez modifier les paramètres de fréquence de l'analyseur

  1. Cliquez sur Modify.

  2. Entrez la nouvelle valeur ou cliquez sur les boutons fléchés pour sélectionner les fréquences de début et de fin désirées.

  3. Cliquez sur OK.

Si vous souhaitez sélectionner un étalonnage électronique

  1. Si vous ne l'avez pas encore fait, suivez les étapes "a" à "d" pour connecter et préchauffer le module ECal :

    1. Connectez le module ECal au connecteur USB de l'analyseur. (NE CONNECTEZ PAS le module ECal au connecteur du port parallèle.)

    2. Durant la mise sous tension initiale, le module reste dans l'état WAIT. Seul le voyant rouge (voyant WAIT) est allumé, ce qui indique le module a commencé son cycle de préchauffage. (Le voyant vert peut s'allumer brièvement.)

    3. Environ 14 minutes plus tard, les voyants rouge et vert s'allument. Ceci indique que le module a atteint 95 % de sa température de fonctionnement interne.

    4. Environ une minute plus tard, seul le voyant vert (voyant READY) reste allumé et le voyant rouge s'éteint. Ceci indique que le module a atteint sa température de fonctionnement et qu'il est opérationnel.

  2. Cliquez sur Measure ECal.

    • Cochez la case Show Prompts si vous souhaitez inclure les invites qui vous guident à travers le processus ECal.

Remarque : le temps de préchauffage du module ECal peut varier selon la température ambiante.

Remarque : si un module est temporairement déconnecté après avoir effectué le cycle de préchauffage, il passe plus vite de l'état WAIT à l'état READY que pour la mise sous tension initiale. Cependant, si vous tentez d'utiliser le module alors que les voyants rouge et vert sont allumés (à 95 % du cycle de préchauffage), la qualité de l'étalonnage peut être compromise. Attendez plutôt que le module passe à l'état READY (voyant vert allumé seulement) pour obtenir un étalonnage d'usine.

  3. Cliquez sur Module. Effectuez les connexions comme illustré sur le graphique

  4. Cliquez sur OK. La boîte de dialogue Cal Information s'affiche à l'écran et montre le nom et le chemin du fichier pour le jeu d'étalonnage et l'état de l'instrument qui ont été sauvegardés.

Remarque : après le processus de mesure du module pour le type d'étalonnage sélectionné, le jeu d'étalonnage et l'état de l'instrument sont automatiquement sauvegardés dans un fichier *.cst. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur.

  5. Cliquez sur OK.

Si vous souhaitez sélectionner des étalons mécaniques

  1. Si vous souhaitez utiliser deux jeux d'étalons dans le processus d'étalonnage, cochez la case Have 2 sets of standards dans la partie Use Mechanical Standards de la boîte de dialogue.

  2. Cliquez sur Measure Stds.

    • Cochez la case Show Prompts si vous souhaitez inclure les invites qui vous guident à travers le processus d'étalonnage.

  3. Cliquez sur Select Cal Kit.

  4. Sélectionnez le type de kit d'étalonnage désiré.

  5. Cliquez sur OK.

Si vous souhaitez changer le kit d'étalonnage affecté au(x) port(s) de l'analyseur

  1. Cliquez sur Change Port.

  2. Dans la zone Cal Kit ID, entrez une nouvelle valeur ou cliquez sur le bouton fléché pour sélectionner le numéro d'identification du kit d'étalonnage désiré. (Les numéros d'identification 1 à 6 contiennent les définitions des kits d'étalonnage prédéfinis. (Les numéros d'identification 7 à 10 contiennent les définitions des kits d'étalonnage définis par l'utilisateur.)

  3. Dans la zone Cal Kit Name, modifiez le nom du kit d'étalonnage.

  4. Dans la zone Port 1 Model, cliquez sur le bouton fléché pour sélectionner le modèle de kit d'étalonnage Agilent désiré pour le Port 1. Sélectionnez le genre du connecteur au plan de référence de mesure du Port 1.

  5. Dans la zone Port 2 Model, cliquez sur le bouton fléché pour sélectionner le modèle de kit d'étalonnage Agilent désiré pour le Port 2. Sélectionnez le genre du connecteur au plan de référence de mesure du Port 2.

  6. Dans la zone THRU ou Adapter, cliquez sur le bouton fléché pour sélectionner THRU ou Adapter.

  7. Si Custom Thru/Adapter a été sélectionné à l'étape précédente :

    1. Cliquez sur Specify Custom Thru/Adapter.

    2. Dans la zone Label, modifiez l'étiquette.

    3. Dans la zone Z0, entrez un nombre ou cliquez sur les boutons fléchés pour sélectionner la valeur désirée.

    4. Dans la zone Delay, entrez un nombre ou cliquez sur les boutons fléchés pour sélectionner la valeur désirée.

    5. Dans la zone Loss, entrez un nombre ou cliquez sur les boutons fléchés pour sélectionner la valeur désirée.

    6. Cliquez sur OK.

  8. Cliquez sur OK. La boîte de dialogue Cal Information s'affiche pour confirmer que les nouveaux paramètres ont été sauvegardés sous le numéro d'identification du kit d'étalonnage sélectionné. Cliquez sur OK.

Mesurer les étalons

  1. Cliquez sur chacun des boutons représentant un étalon (par exemple, OPEN, SHORT ou LOAD). Effectuez les connexions comme illustré sur le graphique.

  2. Cliquez sur OK, OK. La boîte de dialogue Cal Information s'affiche à l'écran et montre le nom et le chemin du fichier pour le jeu d'étalonnage et l'état de l'instrument qui ont été sauvegardés.

Remarque : après le processus de mesure des étalons pour le type d'étalonnage sélectionné, le jeu d'étalonnage et l'état de l'instrument sont automatiquement sauvegardés dans un fichier *.cst. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur.

  3. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Cal.

  2. Appuyez sur la touche F1 (Cal Wizard).

Sélectionner un type d'étalonnage

  1. Dans le bloc NAVIGATION, appuyez sur Click pour sélectionner Cal Type.

  2. Appuyez sur les flèches vers le haut et vers le bas pour sélectionner le type d'étalonnage désiré.

  3. Si vous avez sélectionné un étalonnage sur 2 ports, appuyez sur la touche Tab à droite pour cocher la case Omit I solation (types 2-Port). Cette case est cochée par défaut. Si vous souhaitez inclure la portion isolement du processus d'étalonnage sur 2 ports, appuyez sur Click.

  4. Dans le bloc COMMAND, appuyez sur OK.

Si vous souhaitez modifier les paramètres de fréquence de l'analyseur

  1. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour sélectionner Modify.

  2. Appuyez sur Click.

  3. Appuyez sur la touche Tab à droite pour cocher les cases Start et Stop. Entrez une nouvelle valeur ou appuyez sur les flèches vers le haut ou vers le bas pour sélectionner les fréquences de début et de fin désirées.

  4. Dans le bloc COMMAND, appuyez sur OK.

Si vous souhaitez sélectionner l'étalonnage électronique

  1. Si vous ne l'avez pas encore fait, suivez les étapes "a" à "d" pour connecter et préchauffer le module ECal :

    1. Connectez le module ECal au connecteur USB de l'analyseur.

    2. Durant la mise sous tension initiale, le module reste dans l'état WAIT. Seul le voyant rouge (voyant WAIT) est allumé, ce qui indique que le module a commencé son cycle de préchauffage.

    3. Environ quatorze minutes plus tard à 25°C, les voyants rouge et vert s'allument. Ceci indique que le module a atteint 95 % de sa température de fonctionnement interne.

    4. Environ une minute plus tard, seul le voyant vert (voyant READY) reste allumé et le voyant rouge s'éteint. Ceci indique que le module a atteint sa température de fonctionnement et passe à l'état READY.

  2. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite ou à gauche pour sélectionner Measure ECal Stds. Appuyez sur Click.

  3. Appuyez sur la touche Tab à droite pour passer à la case à cocher Show Prompts. Si vous souhaitez inclure les invites qui vous guident à travers le processus ECal, appuyez sur Click.

  4. Appuyez sur la touche Tab à gauche pour sélectionner Module. Appuyez sur le bouton Click et effectuez les connexions comme illustré sur le graphique.

  5. Dans le bloc COMMAND, appuyez sur OK. La boîte de dialogue Cal Information s'affiche à l'écran et montre le nom et le chemin du fichier pour le jeu d'étalonnage et l'état de l'instrument qui ont été sauvegardés.

Remarque : après le processus de mesure du module pour le type d'étalonnage sélectionné, le jeu d'étalonnage et l'état de l'instrument sont automatiquement sauvegardés dans un fichier *.cst. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur.

  6. Appuyez sur OK.

Si vous souhaitez sélectionner les étalons mécaniques

  1. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour passer à la case à cocher Have 2 sets of standards dans la partie Use Mechanical Standards de la boîte de dialogue. Si vous souhaitez utiliser deux jeux d'étalons dans le processus d'étalonnage, appuyez sur Click.

  2. Appuyez sur la touche Tab à gauche pour passer à Measure Stds. Appuyez sur Click.

    • Appuyez sur la touche Tab à gauche pour passer à la case à cocher Show Prompts. Si vous souhaitez inclure les invites qui vous guident à travers le processus d'étalonnage, appuyez sur Click.

  3. Appuyez sur la touche Tab à droite pour passer à Select Cal Kit. Appuyez sur Click.

  4. Utilisez les flèches vers le haut ou vers le bas pour sélectionner le type de kit d'étalonnage désiré.

  5. Dans le bloc COMMAND, appuyez sur OK.

Si vous souhaitez changer le kit d'étalonnage affecté au(x) port(s) de l'analyseur

  1. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour passer à Change Port. Appuyez sur Click.

  2. Dans la zone Cal Kit ID, entrez une nouvelle valeur ou utilisez les flèches vers le haut ou vers le bas pour sélectionner le numéro d'ID du kit d'étalonnage désiré. (Les numéros d'identification 1 à 6 contiennent des définitions de kit d'étalonnage prédéfinies. Les numéros d'identification 7 à 10 contiennent des définitions de kit d'étalonnage définies par l'utilisateur.)

  3. Appuyez sur la touche Tab à droite pour passer à Cal Kit Name. Modifiez le nom du kit d'étalonnage.

  4. Appuyez sur la touche Tab à droite pour passer à la zone Port 1 Model . Utilisez les flèches vers le haut ou vers le bas pour sélectionner le modèle de kit d'étalonnage désiré pour le Port 1.

  5. Appuyez sur la touche Tab à droite, puis utilisez les flèches vers le haut ou vers le bas pour sélectionner le genre du connecteur au plan de référence de mesure du Port 1.

  6. Appuyez sur la touche Tab à droite pour passer à la zone Port 2. Utilisez les flèches vers le haut ou vers le bas pour sélectionner le modèle de kit d'étalonnage désiré pour le Port 2.

  7. Appuyez sur la touche Tab à droite, puis utilisez les flèches vers le haut ou vers le bas pour sélectionner le genre du connecteur au plan de référence de mesure du Port 2.

  8. Appuyez sur la touche Tab à droite pour passer à la zone THRU ou Adapter. Appuyez sur les flèches vers le haut ou vers le bas pour sélectionner THRU ou Adapter.

  9. Si Custom Thru/Adapter a été sélectionné à l'étape précédente :

    1. Appuyez sur la touche Tab à droite pour passer à Specify Custom Thru/Adapter. Appuyez sur Click.

    2. Appuyez sur la touche Tab à droite ou à gauche pour passer à la zone Label. Modifiez l'étiquette.

    3. Appuyez sur la touche Tab à droite pour passer à la zone Z0. Entrez un nombre ou appuyez sur les flèches vers le haut ou vers le bas pour sélectionner la valeur désirée.

    4. Appuyez sur la touche Tab à droite pour passer à la zone Delay. Entrez un nombre ou appuyez sur les flèches vers le haut ou vers le bas pour sélectionner la valeur désirée.

    5. Appuyez sur la touche Tab à droite pour passer à la zone Loss. Entrez un nombre ou appuyez sur les flèches vers le haut ou vers le bas pour sélectionner la valeur désirée.

    6. Dans le bloc COMMAND, appuyez sur OK.

  10. Appuyez sur OK jusqu'à ce que la boîte de dialogue Cal Information s'affiche pour confirmer que les nouveaux paramètres ont été sauvegardés sous l'ID du kit d'étalonnage sélectionné. Appuyez sur OK.

Mesurer les étalons

  1. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite ou à gauche pour passer à chacun des boutons représentant un standard d'étalonnage (par exemple, OPEN, SHORT ou LOAD). Appuyez sur Click. Effectuez les connexions comme illustré sur le graphique.

  2. Dans le bloc COMMAND, appuyez sur OK. La boîte de dialogue Cal Information s'affiche à l'écran et montre le nom et le chemin du fichier pour le jeu d'étalonnage et l'état de l'instrument qui ont été sauvegardés.

Remarque : après le processus de mesure des étalons pour le type d'étalonnage sélectionné, le jeu d'étalonnage et l'état de l'instrument sont automatiquement sauvegardés dans un fichier *.cst. Il est ensuite possible de rappeler ce fichier à l'aide de la fonction de rappel de l'analyseur.

  3. Appuyez sur OK.

Définir la correction à ON ou OFF

Procédure à l'aide de la souris

  1. Dans le menu Calibration, passez à Correction.

  2. Le paramètre de correction par défaut est ON.

    • Si vous souhaitez définir la correction à ON, cliquez la sélection pour afficher Correction ON/off.

    • Si vous souhaitez définir la correction à OFF, cliquez la sélection pour afficher Correction on/OFF.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Cal.

  2. L'état de la fonction Correction de l'analyseur est indiqué dans la zone verte de la barre d'outils Active Entry. Pour changer l'état (par exemple, de OFF à ON), appuyez sur la touche F2 (Corr on/off).

Afficher les propriétés d'étalonnage

Procédure à l'aide de la souris

  1. Dans le menu Calibration, cliquez sur Properties.

  2. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Cal.

  2. Appuyez sur la touche F3 (Properties).

  3. Dans le bloc COMMAND, appuyez sur Cancel.


Accurate

Voir aussi...

Etalonnage précis des mesures

Présentation

Concepts

Procédures

Il existe plusieurs méthodes permettant de garantir l'étalonnage précis des mesures.
Concepts

Comment garantir l'étalonnage précis des mesures

Cliquez sur un bouton pour en savoir plus sur l'un des sujets suivants :
Plan de référence de la mesure

Extension des ports

Effets de l'utilisation d'étalons inadéquats

Etalonnage de composants non insérables

Liaison directe non caractérisée

Liaison directe caractérisée

Permutation de deux adaptateurs égaux

Partie isolement d'un étalonnage sur deux ports

Plan de référence de la mesure

  • Dans la plupart des configurations de mesure, il est impossible de raccorder le composant à tester directement aux connecteurs de la face avant de l'analyseur. Vous devez le plus souvent connecter le composant à des accessoires de test ou à des câbles qui sont eux-mêmes raccordés à l'analyseur.

  • Pour obtenir une mesure aussi précise que possible, il est nécessaire de procéder à l'étalonnage au niveau des points de raccordement du composant à tester. C'est ce que l'on appelle le plan de référence de la mesure (voir l'illustration). Un étalonnage au niveau de ces points permet de mesurer et d'éliminer les erreurs introduites par le montage de test (câbles, accessoires et adaptateurs intercalés entre l'analyseur et le composant).

Extension des ports

  • Après l'étalonnage, utilisez la fonction d'extension des ports afin de compenser le décalage de phase au niveau du plan de référence de mesure étendue résultant de l'insertion de dispositifs tels que :

    • câbles,

    • adaptateurs,

    • accessoires de test.

  • L'e xtension des ports est la méthode préconisée pour compenser le déphasage introduit par les accessoires de test.

    • Par exemple, les accessoires de test peuvent comporter des connecteurs différents de ceux des étalons. Cela rend alors impossible l'étalonnage de la longueur électrique des accessoires. Dans ce cas, l'extension des ports permet de compenser le retard introduit par les accessoires en supprimant le déphasage qu'ils provoquent. Notez cependant qu'elle ne compense pas les désadaptations d'impédance ni les pertes introduites par ces accessoires.

  • Les valeurs de retard que vous entrez pour l'extension des ports seront prises en compte automatiquement dans les mesures de transmission et de réflexion. Par exemple :

    • Lors de la mesure du paramètre S11, le retard de l'extension du port 1 est pris en compte deux fois (en raison de l'aller-retour effectué par le signal mesuré).

    • Lors de la mesure du paramètre S21, le retard de l'extension du port 1 et celui de l'extension du port 2 sont chacun pris en compte une fois.

  • L'extension d'un port est appliquée à toutes les mesures dans lesquelles ce port est impliqué.

Effets de l'utilisation d'étalons inadéquats

  • Normalement, un étalonnage doit être effectué au moyen d'un kit d'étalonnage constitué d'étalons dont les connecteurs sont du même type et du même sexe que ceux du composant à tester.

  • Il se peut cependant que les connecteurs de votre kit d'étalonnage ne soient pas du même type que ceux du composant à tester. Par exemple, le composant peut être muni de connecteurs de 3,5 mm alors que votre kit d'étalonnage possède des connecteurs de type N. Il vous faut donc utiliser un adaptateur pour raccorder les étalons de type N au port de test 3,5 mm.

  • Comme l'adaptateur est utilisé au cours de l'étalonnage, mais pas dans le montage de test, il en résulte une erreur significative dans les mesures de réflexion.

  • Des inexactitudes peuvent aussi résulter de l'utilisation d'étalons autres que ceux qui sont spécifiés lors de la procédure d'étalonnage. Le degré d'inexactitude dépendra alors de la différence plus ou moins marquée entre l'étalon réellement utilisé et celui que vous "déclarez" utiliser.

Pour contrôler la précision d'un étalonnage, consultez la section Validité d'un étalonnage de mesure.

Etalonnage de composants non insérables

Un exemple de composant insérable est illustré ci-après. Ce composant possède deux connecteurs de type N, l'un mâle, l'autre femelle.

  • En cas d'étalonnage réalisé pour un composant insérable, les ports de test au niveau du plan de référence de la mesure se connectent directement l'un à l'autre. Ce type de liaison directe est dite "de longueur nulle". Cela signifie que la définition (ou description électrique) utilisée par l'analyseur dans le processus d'étalonnage spécifie une longueur nulle, aucun retard, aucune perte, aucune capacité et aucune inductance.

  • Il se peut que votre kit d'étalonnage ne comporte pas d'étalon de type liaison directe, car le composant à tester est supposé être insérable.

Si votre composant est non insérable, les ports de test au niveau du plan de référence ne peuvent pas être raccordés directement l'un à l'autre, comme l'illustre la figure ci-dessous. Vous devez donc recourir à un adaptateur pour établir la liaison directe. Cet adaptateur étant utilisé uniquement pour l'étalonnage (il ne fait pas partie du montage de test), il en résulte une certaine réduction de la précision de mesure.

Si le composant à tester est de type non insérable, vous devez choisir l'une des méthodes suivantes pour établir la liaison directe à utiliser au cours de l'étalonnage. Ces méthodes sont répertoriées par ordre de précision croissante (la première est donc la moins précise).

Adaptateur de liaison directe non caractérisé

Adaptateur de liaison directe caractérisé

Etalonnage avec permutation de deux adaptateurs égaux

Adaptateur de liaison directe non caractérisé

Cette méthode d'étalonnage pour la mesure d'un composant non insérable est la plus simple, mais aussi la moins précise. "Non caractérisé" signifie que le retard électrique et la perte induits par l'adaptateur ne sont pas enregistrés dans l'analyseur.

Bien que l'adaptateur soit utilisé pour étalonner le chemin électrique direct, la perte d'insertion et le retard électrique qui lui sont propres ne sont pas soustraits des mesures à venir, car ces caractéristiques sont inconnues.

Adaptateur de liaison directe caractérisé

  • Un adaptateur est dit "caractérisé" lorsque le retard électrique et la perte d'insertion qu'il induit sont connus et spécifiés dans la définition du kit d'étalonnage enregistrée dans l'analyseur.

  • Les valeurs de retard électrique et de perte d'insertion peuvent être fournies par le fabricant de l'adaptateur (qui peut être de type mâle-mâle ou femelle-femelle). Si ce n'est pas le cas, vous pouvez les mesurer. Notez cependant que ces mesures nécessitent un étalonnage précis, l'adaptateur étant lui-même un composant non insérable.

Pour caractériser un adaptateur de liaison directe haute qualité :

  1. Procédez à un étalonnage en appliquant la méthode de permutation de deux adaptateurs égaux (voir la description plus loin).

  2. Caractérisez l'adaptateur de liaison directe.

  3. Modifiez la définition de l'adaptateur dans le kit d'étalonnage en utilisant l'assistant d'étalonnage (Cal Wizard). (De cette manière, vous n'aurez besoin d'effectuer l'étalonnage par permutation de deux adaptateurs égaux qu'une seule fois.)

  4. Etalonnez le chemin électrique direct de votre montage de test avec l'adaptateur caractérisé.

Remarque : l'adaptateur caractérisé n'est utilisé qu'au cours de l'étalonnage du chemin électrique direct du montage de test, et non pendant les mesures proprement dites de vos composants. Cela préserve sa durée de vie. (Comme vous le verrez avec la méthode d'étalonnage par permutation de deux adaptateurs égaux, l'un des adaptateurs caractérisés reste en place dans le montage de test et est utilisé pour mesurer chaque composant.)

Méthode d'étalonnage par permutation de deux adaptateurs égaux

  • Cette méthode est très utile dans le cas de composants possédant des connecteurs de même type et de même sexe (par exemple, SMA aux deux extrémités).

  • Elle fait appel à deux adaptateurs de précision appariés, égaux en performances, mais possédant des connecteurs de sexes opposés.

    • Par exemple, pour la mesure d'un composant muni d'un connecteur SMA femelle à ses deux extrémités avec des câbles de test APC 7 mm, les deux adaptateurs pourraient être respectivement de type 7 mm-à-3,5 mm mâle et 7 mm-à-3,5 mm femelle.

  • Pour garantir l'égalité des adaptateurs, nombre de kits d'étalonnage Agilent comprennent des paires d'adaptateurs dont les caractéristiques suivantes sont identiques :

    • Impédance caractéristique

    • Perte d'insertion

    • Retard électrique

    • Adaptation

Présentation de la méthode d'étalonnage par permutation de deux adaptateurs égaux

  1. La partie transmission d'un étalonnage sur deux ports est effectuée avec l'adaptateur nécessaire à l'établissement de la liaison directe.

  2. Cet adaptateur est ensuite retiré et l'autre adaptateur prend sa place pour la partie réflexion de l'étalonnage, laquelle est exécutée sur les deux ports de test.

  3. La permutation des deux adaptateurs change le sexe de l'un des ports de test, de sorte que le composant à tester peut être inséré et mesuré une fois la procédure d'étalonnage terminée (le second adaptateur étant toujours en place).

  4. Les erreurs subsistant après l'étalonnage correspondent aux différences mineures qui existent entre les deux adaptateurs.

Voyez la procédure détaillée d'étalonnage par permutation de deux adaptateurs égaux.

Partie isolement d'un étalonnage sur deux ports

  • Lors d'un étalonnage sur deux ports, vous avez la possibilité d'omettre la partie isolement.

  • La partie isolement de l'étalonnage vise à corriger la d iaphonie, c'est-à-dire la fuite de signal entre les ports de test en l'absence de composant.

  • Effectuez un étalonnage de l'isolement si vous devez tester un composant à fortes p ertes d'insertion. Par exemple :

    • Certains filtres coupe-bande

    • Un commutateur en position ouverte

  • L'étalonnage de l'isolement ajoute du bruit au modèle d'erreur, car la mesure est très proche du plancher de bruit de l'analyseur. Pour améliorer la précision de mesure :

    • N'effectuez l'étalonnage de l'isolement qu'en cas de nécessité.

    • Utilisez la fonction de moyennage des balayages pour réduire le bruit.

  • La meilleure méthode d'étalonnage de l'isolement consiste à utiliser deux composants à tester, chacun étant branché sur l'un des ports de test de l'analyseur et muni d'un bouchon de terminaison sur son autre extrémité. De cette manière, l'analyseur est connecté à la même impédance que celle à laquelle il sera raccordé lors des mesures qui suivront.

  • Si la méthode précédente est impraticable (en raison des accessoires de test ou parce qu'un seul composant est disponible), la deuxième méthode préconisée consiste à placer un composant muni d'un bouchon de terminaison sur le port source de l'analyseur et à brancher un bouchon de terminaison sur le port de réception (charge).

  • Si le composant à tester n'est pas disponible ou s'il doit être réglé (ce qui changera inévitablement l'adaptation de ses ports), équipez les deux ports de l'analyseur d'un bouchon de terminaison.

Cliquez sur un bouton pour accéder à l'une des procédures suivantes :

Utiliser la fonction d'extension des ports

Caractériser un adaptateur de liaison directe

Appliquer la méthode d'étalonnage par permutation de deux adaptateurs égaux

Utiliser la fonction d'extension des ports
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Exécutez un étalonnage au niveau du plan de référence de la mesure.

  2. Dans le menu Calibration, cliquez sur Port Extensions.

  3. Cochez la case Port Extensions pour activer la fonction d'extension des ports.

  4. Cliquez sur une boîte Input ou Port. Tapez une valeur ou cliquez sur les boutons fléchés pour sélectionner le retard entre le plan de référence de l'entrée ou du port et votre composant. Voici un bon moyen de déterminer si le retard ajouté est suffisant :

    1. Connectez un court-circuit (étalon fermé) à la place du composant à tester.

    2. Réglez l'e xtension du port de manière à obtenir une réponse de phase plate. (N'oubliez pas que la plupart des étalons de court-circuit possèdent un retard électrique non nul. Par conséquent, le réglage du retard à l'aide de cette méthode se traduira par une erreur égale à deux fois le retard du court-circuit utilisé.)

  5. Cliquez sur la boîte Velocity Factor. Tapez une valeur ou cliquez sur les boutons fléchés pour sélectionner le facteur de célérité du support de transmission du composant (par exemple, un câble ou un accessoire de test) qui a été inséré après l'étalonnage. La valeur par défaut du facteur de célérité est 1.0, ce qui correspond à la vitesse de la lumière dans le vide (2,997925 x 108 mètres par seconde).

  6. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Exécutez un étalonnage au niveau du plan de référence de la mesure.

  2. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  3. Dans le bloc NAVIGATION, utilisez la touche Tab à droite et la flèche vers le bas pour accéder au menu Calibration, puis à Port Extensions. Appuyez sur Click.

  4. Pour activer la fonction P ort extensions, appuyez sur Click.

  5. Appuyez sur la touche Tab à droite pour accéder à une boîte InputouPort . Tapez une valeur ou appuyez sur les flèches vers le haut ou vers le bas pour sélectionner le retard entre le plan de référence de l'entrée ou du port et votre composant. Voici un bon moyen de déterminer si le retard ajouté est suffisant :

    1. Connectez un court-circuit (étalon fermé) à la place du composant à tester.

    2. Réglez l'extension du port de manière à obtenir une réponse de phase plate. (N'oubliez pas que la plupart des étalons de court-circuit possèdent un retard électrique non nul. Par conséquent, le réglage du retard à l'aide de cette méthode se traduira par une erreur égale à deux fois le retard du court-circuit utilisé.)

  6. Appuyez sur la touche Tab à droite pour accéder à la boîte Velocity Factor. Entrez le facteur de célérité du support de transmission du composant (par exemple, un câble ou un accessoire de test) qui a été inséré après l'étalonnage. La valeur par défaut du facteur de célérité est 1.0, ce qui correspond à la vitesse de la lumière dans le vide (2,997925 x 108 mètres par seconde).

  7. Appuyez sur OK.

Caractériser un adaptateur de liaison directe

  1. Procédez à un étalonnage complet sur deux ports (Full SOLT 2-Port) en appliquant la méthode de permutation de deux adaptateurs égaux. Vous devez choisir cette méthode car le composant à tester (adaptateur de liaison directe) est un composant non insérable.

  2. Mesurez le retard électrique de l'adaptateur à une fréquence approximativement égale à la fréquence centrale de la bande d'analyse choisie. Notez la valeur obtenue.

  3. Mesurez la p erte d'insertion de l'adaptateur à une fréquence approximativement égale à la fréquence centrale de la bande d'analyse choisie. Notez la valeur obtenue.

  4. Utilisez ces valeurs mesurées pour modifier la définition de l'adaptateur dans le kit d'étalonnage. Pour cela, sélectionnez Change Port dans l'assistant d'étalonnage (Cal Wizard). Voir Sélection et exécution d'un étalonnage de mesure.

  5. Exécutez un étalonnage en utilisant le kit d'étalonnage modifié, qui contient maintenant la définition de l'adaptateur de liaison directe caractérisé.

Appliquer la méthode d'étalonnage par permutation de deux adaptateurs égaux

  1. Dans l'assistant d'étalonnage (Cal Wizard), sélectionnez un étalonnage complet sur deux ports (Full SOLT 2-Port). Pour plus de détails sur cet assistant, consultez la rubrique Sélection et exécution d'un étalonnage de mesure.

  2. Connectez l'adaptateur A entre les ports 1 et 2, comme illustré ci-après.

  3. Sélectionnez Thru (liaison directe) dans la boîte de dialogue Measure Mechanical Standards de l'assistant.

  4. Débranchez l'adaptateur A des ports 1 et 2.

  5. Connectez l'adaptateur B (celui qui possède des connecteurs de sexes différents de ceux de votre composant à tester) au port adéquat (dans cet exemple, il s'agit du port 1). Cet adaptateur fait désormais partie de votre montage de test. Voir l'illustration ci-dessous.

  6. Sélectionnez Open, Short et Load dans la boîte de dialogue Measure Mechanical Standards de l'assistant d'étalonnage.

    1. Lorsque vous y êtes invité, connectez l'étalon choisi pour le port 1 à l'adaptateur B.

    2. Lorsque vous y êtes invité, connectez l'étalon choisi pour le port 2 à l'extrémité du câble raccordé à ce port.

  7. Mesurez votre composant avec l'adaptateur B en place, comme illustré ci-après.

Remarque : l'adaptateur B utilisé au cours de l'étalonnage reste en place et fait donc partie de votre montage de test. Cela signifie que les composants à tester seront reliés directement à cet adaptateur et que celui-ci finira par s'user. Une autre solution consiste à utiliser la méthode de permutation de deux adaptateurs égaux pour caractériser un adaptateur de liaison directe.


Quest_Cal

Voir aussi...

Validité d'un étalonnage de mesure

Présentation

Concepts

Comment valider un étalonnage

Il est possible qu'à certains moments, vous doutiez de la validité de votre étalonnage de mesure. Cette rubrique vous aide à déterminer si vos données d'étalonnage sont valides et si elles fournissent le niveau de précision dont vous avez besoin dans vos résultats de mesure.
Concepts

Comment valider un étalonnage de mesure

Cliquez sur un bouton pour en savoir plus sur les points suivants :
Sans correction (No Cor)

Dégradation potentielle de la correction d'erreur (C*)

Validation de la précision de l'étalonnage

Sans correction (No Cor)

Si la bande d'analyse de l'analyseur est élargie, l'étalonnage courant devient incorrect et la c orrection d'e rreur est désactivée (même si la fonction Interpolation est activée). L'analyseur signale cet état sans correction en affichant "No Cor" dans la barre d'état.

Dégradation potentielle de la correction d'erreur (C*)

Interpolation

La fonction Interpolation est activée par défaut. Si vous changez l'un des paramètres de mesure ci-dessous, la qualité de l'étalonnage courant peut être affectée. L'analyseur signale cet état de correction d'erreur en affichant "C*" dans la barre d'état.

  • Plage de fréquences rétrécie

  • Nombre de points diminué

Lorsque la fonction Interpolation est active, l'analyseur calcule la correction d'erreur pour les nouveaux paramètres à partir des termes d'erreur originaux. Le niveau de dégradation de la précision de la mesure dépend du niveau de changement d'amplitude et du déphasage entre les points de mesure. Plus ce changement est petit, meilleure est la correction d'erreur interpolée. Cependant, les performances système ne sont pas spécifiées lorsque la correction d'erreur interpolée est utilisée.

Remarque : lorsque "C*" apparaît dans la barre d'état, la validité de votre étalonnage n'est pas fiable. Pour déterminer si cela pose problème, vous pouvez comparer une trace de mesure réalisée avec l'étalonnage d'origine (lorsque "C" apparaît dans la barre d'état) avec la trace de mesure courante (lorsque "C*" apparaît dans la barre d'état). Selon la différence de précision entre les deux traces et le degré de précision requis par votre application de mesure, vous pouvez déterminer si l'étalonnage répond à vos besoins. Voir Validation de l'étalonnage de mesure.

Si la fonction Interpolation est désactivée et que vous changez les paramètres ci-dessus, l'étalonnage courant devient incorrect et la correction d'erreur est désactivée. L'analyseur signale cet état sans correction en affichant "No Cor" dans la barre d'état.

Correction d'erreur non fiable

Si vous changez l'un des paramètres de mesure ci-dessous, la qualité de l'étalonnage courant pourra être affectée car il n'existe pas d'algorithme dans l'analyseur correspondant pour la correction d'erreur. L'analyseur signale également un étalonnage non fiable en affichant "C*" dans la barre d'état.

  • Temps de balayage

  • Bande passante FI

  • Puissances/atténuation au port

  • Balayage par paliers activé/désactivé

Remarque : la correction d'erreur de qualité optimale ne s'applique que pour le niveau de puissance auquel un étalonnage de mesure a été réalisé. Cependant, si la puissance est changée dans la même plage d'atténuation que celle à laquelle l'étalonnage de mesure a été réalisé, les mesures de paramètre S ne peuvent être réalisées qu'avec une petite perte de précision. Si une autre plage d'atténuation est sélectionnée, la qualité de la correction d'erreur est affectée dans des proportions plus importantes.

Validation de l'étalonnage de mesure

Vous pouvez valider la précision de l'étalonnage en appliquant l'une des deux méthodes suivantes :

  1. Après avoir réalisé un étalonnage, établissez une connexion directe et sauvegardez la trace de mesure dans la mémoire interne de l'analyseur ou sur une disquette. Ultérieurement, rappelez la trace et comparez-la à la trace de mesure courante (en utilisant les mêmes câbles et la même connexion directe que précédemment). Pour une meilleure précision de la mesure, procédez comme suit et observez la différence :

    • Utilisez les données/la mémoire pour les mesures de transmission.

    • Utilisez les données/la mémoire pour les mesures de réflexion.

Remarque : le rappel des g abarits offre un moyen rapide pour savoir si l'étalonnage est en-deçà de votre seuil de tolérance (et donc s'il est valide).

  2. Vérification rapide

  • Il est possible qu'à certains moments, vous doutiez de la validité d'un étalonnage et que vous envisagiez de le répéter pour être sûr de sa précision. Au lieu de répéter un étalonnage, exécutez plutôt le processus de vérification rapide. S'il s'avère que l'étalonnage est toujours valide, la vérification rapide vous aura fait gagner un temps précieux.

  • Pour vérifier la qualité d'un étalonnage, vous pouvez exécuter une vérification rapide immédiatement après un étalonnage.

  • Si ces vérifications révèlent des problèmes récurrents après les étalonnages, procédez à une vérification à l'aide du kit de vérification (voir le Guide de maintenance).

Remarque : les courts-circuits et les circuits ouverts étalons s'accompagnent d'un certain retard électrique. L'analyseur compense ce retard en décalant les résultats de l'étalonnage en fonction du retard électrique. Aussi, si vous mesurez un étalon après un étalonnage, cet étalon n'apparaîtra pas comme un court-circuit ou un circuit ouvert étalon avec un décalage de longueur nulle. Ceci indique que votre analyseur fonctionne correctement.

Cliquez sur un bouton pour accéder à l'une des procédures suivantes :
Vérification rapide

Définition de l'interpolation à ON ou OFF

Remarque : dans les procédures ci-dessous, un port désigne le port au plan de référence de la mesure. Pour plus d'informations sur le plan de référence de la mesure, voir Etalonnages de mesure précis.

Vérification rapide

Vérification des mesures de réflexion

Remarque : cette procédure décrit la réalisation de mesures de S11 sur le port 1. La même procédure générale s'applique pour la réalisation de mesures de S22 sur le port 2.

Remarque : n'utilisez pas les mêmes étalons que ceux utilisés pour réaliser l'étalonnage d'origine. La mesure de ces mêmes étalons ne fait que vérifier la répétitivité des corrections effectuées durant l'étalonnage d'origine.

  1. Laissez le port 1 déconnecté (aucun étalon branché) et vérifiez que l'amplitude de S11 est proche de 0 dB (± 1 dB).

  2. Connectez une charge étalon au port 1. L'amplitude de S11 doit être inférieure à -30 dB ou -40 dB, selon la charge.

  3. Connectez un circuit ouvert ou un court-circuit étalon au port 1. L'amplitude de S11 doit être proche de 0 dB (à quelques dizièmes de dB près).

Vérification des mesures de transmission

Remarque : cette procédure décrit la réalisation de mesures de S21. La même procédure générale s'applique pour la réalisation de mesures de S12.

  1. Etablissez une connexion directe entre le port 1 et le port 2. L'amplitude de S21 doit être proche de 0 dB (à quelques dizièmes de dB près).

  2. Pour vérifier l'isolement S21, connectez deux charges : une sur le port 1 et une sur le port 2. L'amplitude de S21 doit être inférieure à -60 dB, selon la bande passante FI.

Définition de l'interpolation à ON ou OFF
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Calibration, allez à Interpolation.

  2. Le paramètre par défaut est l'i nterpolation définie à ON.

  3. Si vous souhaitez définir l'interpolation à ON, cliquez sur la sélection pour voir Interpolation ON/off.

  4. Si vous souhaitez définir l'interpolation à OFF, cliquez sur la sélection pour voir Interpolation on/OFF.

Procédure à l'aide de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, appuyez sur la touche Tab à droite pour aller au menu Calibration.

  3. Appuyez sur la flèche vers le bas pour aller à Interpolation.

  4. Par défaut, l'interpolation est définie à ON.

  5. Si vous souhaitez définir l'interpolation à ON, appuyez sur Click pour voir Interpolation ON/off.

  6. Si vous souhaitez définir l'interpolation à OFF, appuyez sur Click pour voir Interpolation on/OFF.


Voir aussi ...

Marqueurs

Présentation

Types de
marqueurs

Fonctions des
marqueurs

Comment les
activer et les
modifier

Comment effectuer des
recherches

Les marqueurs permettent la lecture numérique des données mesurées, la recherche de valeurs spécifiques et la modification des paramètres du stimulus. Cette rubrique examine tous les aspects des marqueurs.
Types de marqueurs, marqueurs de référence et recherche

Fonctions des marqueurs, marqueurs discrets et affichage

Comment les activer, modifier les paramètres, affichage et format

Comment effectuer une recherche et utiliser les marqueurs relatifs

Vous pouvez avoir 10 marqueurs au maximum par trace de mesure.
Types de marqueurs

Normal

Fixe

Marqueur de référence

Recherche à l'aide des marqueurs

Types de recherches

Qu'est-ce-qu'une "crête" ?

Domaine de recherche.

Exécution de la recherche

Types de marqueurs

Il existe deux types de marqueurs : Normal et fixe.

Normal

Un marqueur normal a une position de stimulus fixe (axe X pour le format orthogonal) et réagit aux variations d'amplitude des données (axe Y). Il peut être déplacé à gauche et à droite sur l'axe X en modifiant la valeur de stimulus du marqueur. Utilisez ce type de marqueur avec l'un des types de recherches à l'aide des marqueurs pour localiser les données souhaitées.

Fixe

Un marqueur fixe a une position fixe vis-à-vis des données (axe Y pour le format orthogonal) définie par son emplacement initial sur la trace et ne suit pas les variations de l'amplitude des données de la trace. Il peut être déplacé à gauche et à droite sur l'axe X (pour le format rectangulaire) en modifiant la valeur de stimulus de marqueur, mais sa position selon l'axe Y restera à sa valeur initiale. Utilisez ce type de marqueur pour contrôler rapidement les changements "avant et après" de votre composant sous test. Par exemple, vous pouvez utiliser des marqueurs fixes pour enregistrer la différence entre des résultats de tests avant et après l'accord d'un filtre.

Marqueurs de référence

Vous pouvez afficher les données par rapport à une position de référence.

  • D'abord, placez un marqueur de référence à une première position.

  • Ensuite, placez un second marqueur (marqueur d'écart) à la position suivante.

Les informations de données et de stimulus du marqueur d'écart sont exprimées par rapport aux données et stimulus du marqueur de référence.

Pour définir un marqueur de référence, utilisez le menu et la boîte de dialogue Marker ou la barre d'outils des marqueurs. Vous pouvez également utiliser les commandes S CPI ou COM.

Remarque : si vous créez un marqueur d'écart sans activer d'abord le marqueur de référence, l'analyseur activera automatiquement le marqueur de référence dédié. Vous devrez cependant placer le marqueur de référence à la position souhaitée.

Recherche à l'aide des marqueurs

Vous pouvez utiliser des marqueurs pour rechercher des données de mesure correspondant à des critères spécifiques.

Type de recherche

Il existe sept types de recherches à l'aide des marqueurs.

  • M ax im um :

Le marqueur localise la donnée de plus haute valeur d'amplitude

  • Minim um :

Le marqueur localise la donnée de plus faible valeur d'amplitude

  • Crête suivante :

Le marqueur localise la crête de valeur d'amplitude inférieure suivante, par rapport à sa position de départ.
(Voir "Qu'est-ce qu'une crête ?")

  • Crête à gauche :

Le marqueur localise la crête valide suivante à gauche de sa position de départ sur l'axe X (affichage orthogonal).
(Voir "Qu'est-ce qu'une crête ?")

  • Crête à droite :

Le marqueur localise la crête valide suivante à droite de sa position de départ sur l'axe X (affichage orthogonal).
(Voir "Qu'est-ce qu'une crête ?")

  • Recherche de valeur cible :

L e marqueur localise le point de donnée qui correspond à la valeur de donnée cible spécifiée.

    • Si Discrete Marker est désactivé, le marqueur localise le point de donnée interpolé égal à la valeur cible.

    • Si Discrete Marker est activé et qu'il existe deux points de données de part et d'autre de la valeur cible, le marqueur localise le point de donnée le plus proche de la valeur cible.

Le marqueur trouvera la valeur cible la plus proche à la droite de la position actuelle. Appuyez plusieurs fois sur le bouton Execute pour déplacer le marqueur vers la valeur suivante à droite qui correspond à la valeur cible. Lorsque le marqueur atteint l'extrémité supérieure de la plage de stimulus, il se repositionne à l'extrémité inférieure et reprend sa recherche à partir de ce point (côté gauche de la fenêtre).

  • Bande passante :

Le marqueur localise la bande passante autour de la crête qui a des valeurs d'amplitude de données supérieures à la valeur de seuil (dB) au-dessous du niveau de crête (données > crête - seuil).

Ce type de recherche utilise toujours les marqueurs 1 à 4.
Marqueur 1 : Crête
Marqueur 2 : Valeur de seuil sous la crête, à gauche de la crête
Marqueur 3 : Valeur de seuil sous la crête, à droite de la crête
Marqueur 4 : Fréquence centrale de la bande passante

Cette recherche de bande passante a été effectuée pour trouver la bande passante à 3 dB d'un filtre. Le seuil pour cette recherche était de 3,00 dB (3,00 dB au-dessous de la valeur crête de la bande passante).

Remarque : s'il n'existe aucune donnée valide qui corresponde à l'un des types de recherches de crête ou de valeur cible, le marqueur restera à sa position actuelle.

Qu'est-ce-qu'une "crête" ?

Pour que l'analyseur identifie une "crête", vous devez définir les deux paramètres de critère de crête suivants :

  • Seuil - Amplitude minimum (dB). Pour être considérée comme valide, la crête doit être au-dessus du niveau de seuil. Les vallées des deux côtés peuvent être au-dessous du niveau de seuil.

  • Excursion - La distance verticale (dB) entre la crête et les vallées des deux côtés. Pour que ce soit une crête, les valeurs de données doivent "chuter" des deux côtés de la valeur d'excursion.

Exemple :

Paramètre de seuil : -10dB
Paramètre d'excursion : 1dB
Echelle = 1 dB / division
Crête A = crête valide (au-dessus des paramètres de seuil et d'excursion)
Crête B = crête non valide (au-dessous du paramètre d'excursion)
Crête C = crête non valide (au-dessous du paramètre de seuil)

Domaine de recherche

Les paramètres de domaine de recherche limitent les valeurs de stimulus recherchées le long de l'axe X (cas du format orthogonal) à une bande d'analyse spécifiée. Définissez les paramètres de stimulus de début et de fin des bandes d'analyse d'utilisateur. Si la valeur de début est supérieure à celle de fin, le marqueur ne se déplacera pas. Le graphique ci-dessous montre des exemples de domaines de recherche.

  • Le domaine par défaut de chaque nouveau marqueur est la "bande d'analyse entière".

  • 9 domaines peuvent être définis par les utilisateurs pour chaque voie.

  • Les domaines définis par les utilisateurs peuvent se chevaucher.

  • Un domaine défini peut être utilisé par plus d'un marqueur.

Effectuer une recherche

Vous devez appuyer sur le bouton Execute pour lancer une recherche à l'aide du marqueur. Le bouton Execute doit être utilisé avec tous les types de recherches.

Vous pouvez également cocher la case Tracking pour simuler une pression sur le bouton Execute après chaque balayage, pour une mise à jour continuelle de la recherche.

Remarque : la recherche commence au premier balayage après que la case Tracking ait été cochée, en se basant sur les informations de type de recherche et de domaine actuellement entrées. Lorsque Tracking est activé, assurez-vous que les critères de recherche correspondent à l'état souhaité avant d'utiliser les données.

Remarque : vous ne pouvez pas modifier manuellement les paramètres de stimulus d'un marqueur si Tracking est activé pour ce marqueur.

Cliquez sur les boutons pour afficher les informations.
Fonctions des marqueurs

Début

Fin

Centre

Bande d'analyse

Niveau de référence

Retard

Marqueurs discrets

Affichage des marqueurs

Format des données de marqueurs

Tableau des marqueurs

Fonctions des marqueurs - Modifier les paramètres de l'instrument

Vous pouvez modifier les paramètres suivants de l'instrument à l'aide des marqueurs :

Début :

Le paramètre de stimulus (position sur l'axe X dans le cas du format orthogonal) du marqueur actif devient le paramètre de début de stimulus (fréquence, temps ou puissance).

Fin :

Le paramètre de stimulus (position sur l'axe X dans le cas du format orthogonal) du marqueur actif devient le paramètre de fin de stimulus (fréquence, temps ou puissance).

Centre :

Le paramètre de stimulus (position sur l'axe X dans le cas du format orthogonal) du marqueur actif devient le paramètre de centre de stimulus (fréquence, temps ou puissance). La bande d'analyse reste la même ; les paramètres de début et de fin changent en conséquence.

Bande d'analyse :

Uniquement disponible lorsque le marqueur actif est le marqueur d'écart. La différence entre les paramètres de stimulus (positions sur l'axe X dans le cas du format orthogonal) des deux marqueurs devient le paramètre de bande d'analyse de stimulus. La valeur de marqueur inférieure devient la valeur de début et la valeur de marqueur supérieure devient la valeur de fin. (Cette fonction ne peut être sélectionnée qu'à partir de la boîte de dialogue Marker Functions ou de la barre d'outils des marqueurs.)

Niveau de référence :

Le niveau des données (position sur l'axe Y dans le cas du format orthogonal) du marqueur actif devient le niveau de la ligne de référence de la fenêtre.

Retard :

La pente de phase au niveau de la position de stimulus du marqueur actif est utilisée pour ajuster la longueur de ligne à l'entrée du récepteur. Cela aplatit efficacement la trace de phase autour du marqueur actif. (Des ajustements de retard électrique supplémentaires sont nécessaires pour les composants n'ayant pas un temps de propagation de groupe constant dans la bande d'analyse de la mesure.) Vous pouvez l'utiliser pour mesurer la longueur électrique ou l'écart par rapport à la phase linéaire.

Cette fonction ajoute un retard de phase à la variation de phase en fonction de la fréquence ; par conséquent, elle n'est applicable qu'à des mesures sous forme de rapport. (Voir Paramètres de mesure).

Le marqueur actif apparaît sur l'affichage de l'analyseur sous la forme d'un Ñ. Tous les autres marqueurs sont inactifs et sont représentés sur l'affichage de l'analyseur sous la forme d'un D.

Marqueurs discrets

  • Si Discrete Marker est désactivé, le marqueur localise le point de donnée interpolé pour la valeur de stimulus spécifi&e acute;e.

  • Si Discrete Marker est activé, le marqueur localise le point de donnée actuel le plus proche de la valeur de stimulus spécifiée.

Remarque : il est vraisemblable que la valeur de stimulus sera différente de la valeur spécifiée lorsque Discrete Marker est activé.

Affichage des marqueurs

Vous pouvez modifier l'affichage des informations de marqueur.

Format des données de marqueurs

Le format par défaut des données de lecture des marqueurs est le même que celui de la trace (trace par défaut). Vous pouvez également afficher les données de lecture des marqueurs selon l'un de 12 formats, indépendamment du format d'affichage actuel. Cela pourrait simplifier votre configuration de mesure en réduisant le nombre de fenêtres de mesure nécessaires. Les options de format sont :

  • Trace par défaut

  • Logarithmique / Phase

  • Linéaire / Phase

  • Réel / Imaginaire

  • R + jX

  • G + jB

  • Amplitude logarithmique

  • Amplitude linéaire

  • Phase

  • SWR (ROS)

  • Retard

  • Réel

  • Imaginaire

La figure suivante montre les marqueurs avec différents formats de données.

Tableau des marqueurs

Vous pouvez afficher un tableau qui fournit un résumé des données de marqueurs pour la trace active. Les données de marqueur sont affichées dans le format spécifié pour chaque marqueur, comme montré sur le dessin ci-dessus.

Cliquez sur les boutons pour accéder aux procédures.
Activer un marqueur

Modifier les paramètres de l'analyseur

Afficher les données de marqueurs

Modifier le format des données de marqueurs

Activer un marqueur
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la trace souhaitée pour la sélectionner dans la zone d'affichage Trace Status de la fenêtre. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur l'affichage de l'état des traces).

  2. Dans le menu Marker, cliquez sur Marker.

  3. Dans la partie Marker de la boîte de dialogue, sélectionnez le numéro de marqueur.

  4. Cliquez sur On pour activer le marqueur sélectionné.

  5. Dans la zone Stimulus de la boîte de dialogue, entrez la position de marqueur souhaitée.

  6. Cliquez sur le bouton Advanced. (Les étapes 6 à 9 sont optionnelles)

  7. Choisissez le type de marqueur :

    • Normal (par défaut)

    • Fixe

  8. Choisissez le comportement de marqueur à l'aide de la case à cocher Discrete marker :

    • Interpolé (par défaut, case non cochée)

    • Discret

  9. Cliquez sur OK.

Remarque : si vous activez les marqueurs par la barre d'outils des marqueurs, suivez les étapes 1, 3, 4 et 5 de la procédure ci-dessus. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur la barre d'outils des marqueurs).

Procédure à l'aide de la face avant

  1. Sélectionnez la trace souhaitée en appuyant sur Trace dans la zone DISPLAY. Appuyez sur F2 (Trace suivante) jusqu'à la sélection de la trace souhaitée.

  2. Dans la zone TRACE SETUP, appuyez sur Marker.

  3. Appuyez sur F1 (Marqueur 1) ou F2 (Marqueur 2) ou F3 (Marqueur 3) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

  4. Pour disposer de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP.

  5. Appuyez sur F1 (Marqueur 4) ou F2 (Marqueur 5) ou F3 (Marqueur 6) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

  6. Pour disposer de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP.

  7. Appuyez sur F1 (Marqueur 7) ou F2 (Marqueur 8) ou F3 (Marqueur 9) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

Pour définir le type de marqueur (Normal ou fixe) et le comportement du marqueur (Interpolé ou discret) :

  1. Dans la zone COMMAND, appuyez sur le bouton Menu/Dialog. Appuyez sur Marker dans la zone TRACE SETUP.

  2. Appuyez sur Tab à droite pour sélectionner le bouton Advanced dans la boîte de dialogue Marker. Appuyez sur Click.

  3. Appuyez sur Tab à droite pour choisir la case Discrete marker. Appuyez sur Click pour sélectionner le comportement de marqueur discret (le comportement par défaut est interpolé).

  4. Appuyez sur Tab à droite pour sélectionner la case Marker Type. Appuyez sur Flèche vers le bas pour sélectionner Fixed (l'option par défaut est Normal).

  5. Dans la zone COMMAND, appuyez sur OK.

Modifier les paramètres de l'analyseur à l'aide des marqueurs
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la trace souhaitée pour la sélectionner dans la zone d'affichage Trace Status de la fenêtre. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur l'affichage de l'état des traces).

  2. Dans le menu Marker, cliquez sur Select Marker. Cliquez sur le numéro de marqueur souhaité.

  3. Dans le menu Marker, cliquez sur Marker Function.

  4. Cliquez sur la fonction de l'analyseur à modifier :

    • Début

    • Fin

    • Centre

    • Niveau de référence

    • Retard

  5. Cliquez sur OK.

Remarque : il est possible de modifier les paramètres de l'analyseur avec la barre d'outils des marqueurs (début, fin, centre, et bande d'analyse uniquement). (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur la barre d'outils des marqueurs).

Procédure à l'aide de la face avant

  1. Sélectionnez la trace souhaitée en appuyant sur Trace dans la zone DISPLAY. Appuyez sur F2 (Trace suivante) jusqu'à la sélection de la trace souhaitée.

  2. Dans la zone TRACE SETUP, appuyez sur Marker.

  3. Appuyez sur F1 (Marqueur 1) ou F2 (Marqueur 2) ou F3 (Marqueur 3) pour sélectionner le marqueur souhaité.

  4. Pour disposer de sélections de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP. Appuyez sur F1 (Marqueur 4) ou F2 (Marqueur 5) ou F3 (Marqueur 6) pour sélectionner le marqueur souhaité.

  5. Pour disposer de sélections de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP. Appuyez sur F1 (Marqueur 7) ou F2 (Marqueur 8) ou F3 (Marqueur 9) pour sélectionner le marqueur souhaité.

  6. Dans la zone TRACE SETUP, appuyez sur le bouton Marker Function.

  7. Sélectionnez la fonction à modifier :

    • F1 (Centre)

    • F2 (Niveau de référence)

    • F3 (Retard)

Pour définir d'autres Fonctions de M arqueur (début ou fin) :

  1. Dans la zone COMMAND, appuyez sur le bouton Menu/Dialog. Appuyez sur Marker Function dans la zone TRACE SETUP.

  2. Appuyez sur Tab à droite pour sélectionner la fonction de marqueur souhaitée.

  3. Dans la zone COMMAND, appuyez sur OK.

Afficher les données de marqueurs
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Marker, cliquez sur Marker Table.

  2. Cliquez sur Show Table.

Remarque : Marker Table et Marker Readout peuvent également être activés à partir du menu View. (Voir Personnaliser l'écran de votre analyseur.)

Procédure à l'aide de la face avant

  1. Dans la zone TRACE SETUP, appuyez sur le bouton Marker Table.

  2. Appuyez sur F4 (Masquer) pour masquer le tableau des marqueurs.

Modifier le format des données de marqueurs
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la trace souhaitée pour la sélectionner dans la zone d'affichage Trace Status de la fenêtre. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur l'affichage de l'état des traces).

  2. Dans le menu Marker, cliquez sur Marker. Cliquez ensuite sur Advanced.

  3. Dans la partie Marker de la boîte de dialogue, sélectionnez le numéro de marqueur.

  4. Dans la partie Format de la boîte de dialogue, sélectionnez le format de données de marqueur souhaité.

  5. Cliquez sur OK.

  6. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone COMMAND, appuyez sur le bouton Menu/Dialog. Appuyez sur Marker dans la zone TRACE SETUP.

  2. Appuyez sur Tab à droite pour sélectionner le bouton Advanced dans la boîte de dialogue Marker. Appuyez sur le bouton Click.

  3. Appuyez sur la Flèche vers le bas dans la zone NAVIGATION afin de sélectionner le numéro de marqueur souhaité.

  4. Appuyez sur la touche Tab à droite pour accéder à la liste Format. Appuyez sur Flèche vers le bas pour sélectionner le format de marqueur souhaité.

  5. Dans la zone COMMAND, appuyez sur OK.

  6. Dans la zone COMMAND, appuyez sur OK.

.

Cliquez sur les boutons pour accéder aux procédures.
Recherche de données

Effectuer des mesures relatives

Recherche de données
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la trace souhaitée pour la sélectionner dans la zone d'affichage Trace Status de la fenêtre. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur l'affichage de l'état des traces).

  2. Dans le menu Marker, cliquez sur Marker Search.

  3. Dans la partie Marker de la boîte de dialogue, sélectionnez le numéro de marqueur.

  4. Dans la partie Search Type de la boîte de dialogue, sélectionnez le type de recherche souhaité.

    • Pour Next Peak, Peak Left ou Peak Right: entrez le niveau de seuil et le niveau d'excursion.

    • Pour Target, entrez la valeur de cible.

    • Pour Bandwidth, entrez le niveau.

  5. Dans la partie Search Domain de la boîte de dialogue, sélectionnez le domaine de recherche souhaité. Si un domaine de recherche autre que la bande d'analyse totale (par défaut) est sélectionné, la zone User Span de la boîte de dialogue sera affichée. Entrez les valeurs souhaitées de début et de fin de la bande d'analyse utilisateur.

  6. Pour démarrer la recherche :

    • Manuellement - cliquez sur le bouton Execute.

    • Automatiquement - cliquez sur la case Tracking. (Les recherches sont effectuées lorsque les données marquées par le curseur ont changé).

  7. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Sélectionnez la trace souhaitée en appuyant sur Trace dans la zone DISPLAY. Appuyez sur F2 (Trace suivante) jusqu'à la sélection de la trace souhaitée.

  2. Appuyez sur F1 (Marqueur 1) ou F2 (Marqueur 2) ou F3 (Marqueur 3) pour sélectionner le marqueur souhaité.

  3. Pour disposer de sélections de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP. Appuyez sur F1 (Marqueur 4) ou F2 (Marqueur 5) ou F3 (Marqueur 6) pour sélectionner le marqueur souhaité.

  4. Pour disposer de sélections de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP. Appuyez sur F1 (Marqueur 7) ou F2 (Marqueur 8) ou F3 (Marqueur 9) pour sélectionner le marqueur souhaité.

  5. Dans la zone TRACE SETUP, appuyez sur Marker Search.

  6. Sélectionnez le type de recherche souhaité :

    • F1 (Max)

    • F2 (Min)

    • F3 (Crête à gauche)

    • F4 (Crête à droite)

Pour définir des paramètres supplémentaires de recherche à l'aide des marqueurs :

  1. Dans la zone COMMAND, appuyez sur le bouton Menu/Dialog. Appuyez sur Marker Search dans la zone TRACE SETUP.

  2. Appuyez sur Flèche vers le bas pour sélectionner le numéro de marqueur souhaité.

  3. Appuyez sur Tab à droite pour sélectionner le bouton Search Type dans la boîte de dialogue Marker. Appuyez sur Flèche vers le bas pour sélectionner le type de recherche souhaité. Appuyez sur Tab à droite pour accéder à la liste des entrées pour le type de recherche sélectionné :

    • Pour Next Peak, Peak Left ou Peak Right: entrez le niveau de seuil et le niveau d'excursion.

    • Pour Target, entrez la valeur de cible.

    • Pour Bandwidth, entrez le niveau de seuil.

  4. Appuyez sur Tab à droite pour sélectionner la zone Search Domain dans la boîte de dialogue Marker. Appuyez sur Flèche vers le bas pour sélectionner le domaine de recherche souhaité.

    • Si un domaine de recherche autre que la bande d'analyse totale (par défaut) est sélectionné, la zone User Span de la boîte de dialogue sera affichée. Appuyez sur Tab à droite pour accéder à la zone User Span et entrez les valeurs de début et de fin souhaitées.

  5. Pour démarrer la recherche, appuyez sur Tab à droite pour accéder à l'une des options suivantes. Appuyez sur le bouton Click pour la sélectionner :

    • Manuellement - cliquez sur le bouton Execute.

    • Automatiquement - cliquez sur la case Tracking. (Les recherches sont effectuées lorsque les données marquées par le curseur ont changé).

  6. Dans la zone COMMAND, appuyez sur OK.

Effectuer des mesures relatives avec des marqueurs de référence
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la trace souhaitée pour la sélectionner dans la zone d'affichage Trace Status de la fenêtre. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur l'affichage de l'état des traces).

  2. Dans le menu Marker, cliquez sur Marker.

  3. Dans la partie Marker de la boîte de dialogue, sélectionnez Reference.

  4. Cliquez sur On pour activer le marqueur de référence.

  5. Dans la zone Stimulus de la boîte de dialogue, entrez la position de marqueur de référence souhaitée.

  6. Dans la partie Marker de la boîte de dialogue, sélectionnez le numéro de marqueur pour effectuer des mesures relatives par rapport au marqueur de référence.

  7. Cliquez sur On pour activer le marqueur.

  8. Cliquez sur la case Delta marker pour activer ce marqueur pour que les mesures de données soient exprimées par rapport au marqueur de référence.

Pour définir le comportement de marqueur (Interpolé ou discret) des marqueurs de référence et d'écart :

  1. Cliquez sur le bouton Advanced de la boîte de dialogue Marker.

  2. Dans la partie Marker de la boîte de dialogue, sélectionnez Reference.

  3. Choisissez le comportement de marqueur à l'aide de la case à cocher Discrete marker :

    • Interpolé (par défaut, case non cochée)

    • Discret

  4. Dans la partie Marker de la boîte de dialogue, sélectionnez le numéro de marqueur du marqueur d'écart

  5. Répétez l'étape 3.

  6. Cliquez sur OK.

  7. Cliquez sur OK.

Remarque : les marqueurs destinés à des mesures relatives peuvent également être activés à l'aide de la barre d'outils des marqueurs. (Voir Personnaliser l'écran de votre analyseur pour plus de détails sur la barre d'outils des marqueurs).

Procédure à l'aide de la face avant

  1. Sélectionnez la trace souhaitée en appuyant sur Trace dans la zone DISPLAY. Appuyez sur F2 (Trace suivante) jusqu'à la sélection de la trace souhaitée.

  2. Dans la zone TRACE SETUP, appuyez sur Marker.

  3. Appuyez sur F1 (Marqueur 1) ou F2 (Marqueur 2) ou F3 (Marqueur 3) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

  4. Pour disposer de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP.

  5. Appuyez sur F1 (Marqueur 4) ou F2 (Marqueur 5) ou F3 (Marqueur 6) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

  6. Pour disposer de marqueurs supplémentaires, appuyez sur Marker dans la zone TRACE SETUP.

  7. Appuyez sur F1 (Marqueur 7) ou F2 (Marqueur 8) ou F3 (Marqueur 9) et tapez la valeur ou appuyez sur la Flèche vers le haut ou vers le bas pour définir la position de marqueur souhaitée.

Pour définir le comportement de marqueur souhaité (Interpolé ou discret) :

  1. Dans la zone COMMAND, appuyez sur le bouton Menu/Dialog. Appuyez sur Marker dans la zone TRACE SETUP.

  2. Appuyez sur Tab à droite pour sélectionner le bouton Advanced dans la boîte de dialogue Marker. Appuyez sur le bouton Click.

  3. Appuyez sur la Flèche vers le haut pour sélectionner le marqueur de référence.

  4. Appuyez sur Tab à droite pour sélectionner la case Discrete marker. Appuyez sur Click pour sélectionner le comportement de marqueur discret (le comportement par défaut est interpolé).

  5. Appuyez sur Tab à droite pour sélectionner la case Marker de nouveau. Appuyez sur la Flèche vers le bas pour sélectionner le numéro de marqueur du marqueur d'écart.

  6. Appuyez sur Tab à droite pour sélectionner la case Discrete marker. Appuyez sur Click pour sélectionner le comportement de marqueur discret (le comportement par défaut est interpolé).

  7. Dans la zone COMMAND, appuyez sur OK.


Use Limits to Test Devices

Voir aussi...

Utiliser des limites pour tester des dispositifs

Présentation

Concepts

Comment
réaliser un test par gabarit

Les limites sont les paramètres de performance que vous définissez pour tester votre dispositif. Les gabarits et les tests par gabarit vous permettent de comparer les données de mesure en fonction des contraintes que vous avez définies.
Concepts

Comment configurer et réaliser des tests par gabarit

Limites

Tableau de limites de gabarit

Gabarits

Tests par gabarit

Limites

Les limites sont définies comme suit :

  • Dans les segments, où chaque segment est une portion de la bande d'analyse du stimulus.

  • Comme des limites Maximum ou Minimum, ou réglez sur OFF.

  • Avec les valeurs de stimulus de début et de fin pour chaque segment de gabarit.

  • Avec les valeurs de réponse de début et de fin pour chaque segment de gabarit.

  • Indépendamment pour un maximum de 16 mesures, avec jusqu'à 100 segments pour chaque mesure.

Tableau de limites de gabarit

Les limites peuvent être définies, modifiées, activées et affichées à partir d'un tableau de limites de gabarit.

Gabarits

Les gabarits sont des représentations visuelles sur l'écran de l'analyseur des limites spécifiées pour une voie donnée. Vous pouvez utiliser les gabarits pour :

  • Donner des guides visuels à l'opérateur lors du réglage des dispositifs

  • Fournir des critères standard afin de satisfaire les spécifications d'un dispositif

  • Afficher la comparaison des données et des spécifications

Vous pouvez créer des gabarits :

  • Horizontaux

  • Obliques

  • Ponctuels

Vous pouvez afficher des gabarits à l'écran ou les masquer. Lorsque les gabarits sont affichés :

  • Les traces de mesure sont affichées en vert (la couleur typique des traces de mesure est le vert)

  • Les gabarits sont affichés en orange

Remarque : les limites spécifiées restent valides même si les gabarits ne sont pas affichés.

Test par gabarit

Les tests par gabarit comparent les données mesurées avec les limites définies et renvoient des informations Pass ou Fail pour chaque point de donnée mesuré.

Les limites ne sont vérifiées qu'aux points de données réellement mesurés. Il est possible qu'un dispositif ne satisfasse pas les spécifications sans qu'une indication d'échec des tests par gabarit ne soit donnée si la densité du point est insuffisante. Le graphique ci-dessous montre une mesure utilisant des points minimum.

  • Le début du gabarit descend entre les points A et B le long de l'axe horizontal des fréquences.

  • La fin du gabarit descend entre les points B et C le long de l'axe des fréquences.

Un seul point de mesure est rencontré entre le début et la fin du gabarit. Cet exemple particulier renverrait le résultat des tests par gabarit Pass bien qu'un échec soit possible, car le seul point testé (Point B) réussit les tests par gabarit. Les points A et C échoueraient, mais ils ne sont pas testés avec la limite présentée.

Voici la même mesure réalisée avec 51 points. Cet exemple montre clairement que la mesure "échoue" aux tests par gabarit.

Davantage de points de mesure sont requis pour évaluer cette mesure.

Comme illustré dans le graphique ci-dessus, avec les tests par gabarit définis à ON :

  • Toute portion de la trace de mesure qui échoue aux tests par gabarit est affichée en rouge.

  • Les portions de la trace de mesure qui n'échouent pas restent en vert(aucun changement).

Remarque :les zones de la trace de mesure non bornées par les valeurs limites, bien qu'elles ne soient pas testées, restent en vert.

Vous pouvez afficher les gabarits et utiliser les tests par gabarit simultanément ou indépendamment.

Les gabarits et les tests par gabarit ne sont pas disponibles avec l'abaque de Smith ou le format polaire. Si les gabarits sont définis à ON et que vous passez à l'abaque de Smith ou au format polaire, l'analyseur désactive automatiquement les gabarits et les tests par gabarit.

Remarque : les tests par gabarit sont uniquement réalisés sur la trace de données de mesure. Ils ne peuvent pas être exécutés sur une trace mémoire.

Cliquez sur ces boutons pour accéder aux procédures correspondantes.
Définir des segments de gabarit

Afficher ou masquer le tableau de limites de gabarit

Afficher les gabarits

Activer les tests par gabarit

Définir des segments de gabarit
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Limit Test..., Show Table, OK.

  2. Dans la zone Type du tableau de limites de gabarit, sélectionnez MIN ou MAX pour le segment de gabarit 1.

  3. Cliquez sur la zone BEGIN STIMULUS du segment de gabarit 1. Entrez la valeur désirée.

  4. Cliquez sur la zone END STIMULUS du segment de gabarit 1. Entrez la valeur désirée.

  5. Cliquez sur la zone BEGIN RESPONSE du segment de gabarit 1. Entrez la valeur désirée.

  6. Cliquez sur la zone END STIMULUS du segment de gabarit 1. Entrez la valeur désirée.

  7. Répétez les étapes 4 à 8 pour chaque segment de gabarit désiré.

A l'aide des touches de la face avant

  1. Dans le bloc TRACE SETUP, appuyez sur Limit Table.

  2. Appuyez sur la touche F3 (Afficher) pour afficher le tableau de limites de gabarit.

  3. Dans le bloc NAVIGATION, appuyez sur Click pour afficher les choix de type pour le segment de gabarit 1. Appuyez sur le bouton Down pour sélectionner MIN ou MAX.

  4. Sélectionnez l'onglet de droite pour accéder à la zone BEGIN STIMULUS pour le segment de gabarit 1. Appuyez sur les touches ENTRY pour entrer la valeur désirée. Appuyez sur la touche Entrée.

  5. Sélectionnez l'onglet de droite pour accéder à la zone END STIMULUS pour le segment de gabarit 1. Appuyez sur les touches ENTRY pour entrer la valeur désirée. Appuyez sur la touche Entrée.

  6. Sélectionnez l'onglet de droite pour accéder à la zone BEGIN RESPONSE pour le segment de gabarit 1. Appuyez sur les touches ENTRY pour entrer la valeur désirée. Appuyez sur la touche Entrée.

  7. Sélectionnez l'onglet de droite pour accéder à la zone END RESPONSE pour le segment de gabarit 1. Appuyez sur les touches ENTRY pour entrer la valeur désirée. Appuyez sur la touche Entrée.

  8. Sélectionnez l'onglet de gauche et la flèche vers le bas pour accéder au segment de gabarit suivant.

  9. Répétez les étapes 3 à 8 pour chaque segment de gabarit désiré.

Afficher ou masquer le tableau de limites de gabarit
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Limit Test.

  2. Cliquez sur Show Table ou sur Hide Table.

  3. Cliquez sur OK.

Vous pouvez également afficher ou masquer le tableau de limites de gabarit à l'aide de la souris en procédant comme suit :

  1. Dans le menu View, cliquez sur Tables.

  2. Cliquez sur Limit Table pour changer son état d'affichage.

A l'aide des touches de la face avant

  1. Dans le bloc TRACE SETUP, appuyez sur Limit Table.

  2. Appuyez sur la touche F3 (Afficher) ou sur F4 (Masquer).

Activer les gabarits
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Limit Test.

  2. Cliquez sur Limit Line ON.

  3. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le bloc TRACE SETUP, appuyez sur Limit Table.

  2. Appuyez sur la touche F2 (Line ON/Off) pour afficher les gabarits.

Activer les tests par gabarit
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Limit Test.

  2. Cliquez sur Limit Test ON.

  3. Cliquez sur Sound ON Fail si vous souhaitez qu'un signal sonore soit émis en cas d'échec des tests par gabarit.

  4. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le bloc TRACE SETUP, appuyez sur Limit Table.

  2. Appuyez sur la touche F1 (Test ON/Off) pour activer les tests par gabarit.


Math Operations

Voir aussi...

Opérations arithmétiques

Présentation

Concepts

Comment effectuer des
opérations arithmétiques

Vous pouvez effectuer quatre types d'opérations arithmétiques sur la trace de données active en utilisant une trace en mémoire. Vous pouvez également calculer et afficher les grandeurs statistiques suivantes pour la trace de données active : moyenne, écart type et valeurs crête à crête.
Concepts

Comment effectuer des opérations arithmétiques

Calculs arithmétiques sur les traces

Données / Mémoire

Données - Mémoire

Données * Mémoire

Données + Mémoire

Calculs statistiques sur les traces

Calculs arithmétiques sur les traces

Vous pouvez effectuer quatre types d'opérations arithmétiques sur la trace de données affichée.

  • Données / Mémoire

  • Données - Mémoire

  • Données * Mémoire

  • Données + Mémoire

L'opération arithmétique est effectuée sur les données complexes avant qu'elles ne soient formatées pour être affichées.

Pour effectuer les opérations arithmétiques, vous devez d'abord mémoriser une trace mesurée (ou équivalente) du composant sous test dans la mémoire de voie active. Vous pouvez afficher la trace en mémoire avec la trace de données actuelle en utilisant les options d'affichage des traces.

Remarque : vous pouvez également définir une "trace" qui peut être mise en mémoire par les commandes SCPI ou COM en entrant des paires de données complexes qui correspondent au nombre de points de données de votre trace de données. La trace de données doit être configurée avant de tenter de charger la mémoire. L'analyseur mappe les paires complexes afin qu'elles correspondent aux valeurs du stimulus au niveau des points de mesure réels.

Données / Mémoire

Données / Mémoire est l'opération arithmétique sur les traces la plus commune. Vous pouvez utiliser cette fonction pour obtenir le rapport entre deux traces, par exemple dans le cas de mesures de gain ou d'atténuation.

  1. Pour utiliser cette fonction, vous devez d'abord mémoriser une trace mesurée du composant sous test dans la mémoire de voie active.

  2. Ensuite, exécutez Données / Mémoire afin de diviser les données par la mémoire.

  3. L'analyseur normalise les données en fonction de la mémoire et affiche le résultat.

  4. Affichez les données au format d'amplitude logarithmique pour mesurer efficacement tout écart par rapport à la trace mémorisée.

Données - Mémoire

Données - Mémoire effectue une soustraction vectorielle sur les données de mesure complexes en utilisant une trace mémorisée. Vous pouvez utiliser cette fonction pour mémoriser, par exemple, une erreur vectorielle mesurée et pour soustraire ensuite cette erreur de la mesure du composant.

Données * Mémoire et Données + Mémoire

Données + Mémoire et Données * Mémoire sont des plus utiles pour les formules et algorithmes personnels que vous souhaitez appliquer à une trace de données, moins pour les données mesurées et mémorisées. Par exemple, si vous voulez simuler le gain d'un amplificateur théorique placé en série avant le composant que vous mesurez, vous pouvez :

  1. Créer un algorithme qui caractérise la réponse en fréquence de l'amplificateur.

  2. Entrer des paires de données complexes qui correspondent au nombre de points de données de votre trace de données.

  3. Charger les paires de données en mémoire par les commandes SCPI ou COM.

  4. L'analyseur mappe les paires complexes afin qu'elles correspondent aux valeurs du stimulus au niveau des points de mesure réels.

  5. Ensuite, utilisez la fonction données + mémoire ou données * mémoire pour ajouter ou multiplier la réponse en fréquence et les données mesurées. Voir Commandes COM, méthode PutComplex pour plus d'informations.

Remarque : la trace de données doit être configurée avant de tenter de charger la mémoire.

Calculs statistiques sur les traces

Vous pouvez calculer et afficher les grandeurs statistiques de la trace de données active. Ces grandeurs statistiques sont :

  • Moyenne

  • Ecart type

  • Valeurs crête à crête

Vous pouvez calculer les grandeurs statistiques pour la totalité ou pour une partie de la bande d'analyse de stimulus. Vous pouvez spécifier neuf plages d'utilisateur par voie. Ces plages d'utilisateur sont identiques aux domaines de recherche utilisés lors d'une recherche à l'aide des marqueurs pour cette même voie ; elles utilisent les mêmes registres de mémoire et partagent les mêmes bandes d'analyse de stimulus. Si vous avez spécifié des domaines de recherche d'une recherche effectuée à l'aide des marqueurs pour une voie, vous pouvez rappeler ces mêmes bandes d'analyse en sélectionnant les plages d'analyse d'utilisateur correspondantes. Les plages d'utilisateur d'une voie peuvent se chevaucher.

Une utilisation pratique de ces grandeurs statistiques de trace consiste à obtenir les valeurs crête à crête de l'ondulation de la bande passante sans rechercher séparément les valeurs minimum et maximum.

Les grandeurs statistiques sont calculées sur la base du format utilisé pour afficher les données.

  • Formats orthogonaux des données sont calculés à partir des données scalaires affichées sur l'écran

  • Les formats Polaire ou d'abaque de Smith sont calculés à partir des données telles qu'elles seraient affichées au format d'amplitude logarithmique

Cliquez sur les boutons pour accéder aux procédures.
Sélectionner le type d'opération mathématique sur les traces

Définir les grandeurs statistiques des traces

Calculs arithmétiques sur les traces
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Math/Memory.

  2. Cliquez sur Data>Memory pour mettre la trace souhaitée en mémoire.

  3. Dans la partie Data Math de la boîte de dialogue, sélectionnez l'opération arithmétique souhaitée.

  4. Dans la partie Trace View Options de la boîte de dialogue, sélectionnez l'affichage de la trace souhaitée.

  5. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone TRACE SETUP, appuyez sur Math/Memory.

  2. Appuyez sur F1 (Data>>Mem) pour mettre la trace souhaitée en mémoire.

  3. Appuyez sur F2 (Data/Mem) pour sélectionner Données / Mémoire.

  4. Appuyez sur F3 (Data Only) pour n'afficher que la trace des données.

  5. Appuyez sur F4 (DataMem) pour afficher la trace des données et la trace en mémoire.

Pour sélectionner une opération arithmétique autre que Data/Mem, procédez comme suit.

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone TRACE SETUP, appuyez sur Math/Memory.

  3. Appuyez sur Click pour mettre la trace souhaitée en mémoire.

  4. Appuyez sur Tab à droite pour sélectionner la zone Data Math de la boîte de dialogue. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner l'opération arithmétique sur la trace souhaitée.

  5. Appuyez sur Tab à droite pour sélectionner la zone Trace View Options de la boîte de dialogue. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner l'affichage de la trace souhaitée.

  6. Dans la zone COMMAND, appuyez sur OK.

Définir les grandeurs statistiques des traces
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Trace Statistics.

  2. Cliquez sur Statistics pour activer les grandeurs statistiques des traces.

  3. Sélectionnez la plage d'utilisateur souhaitée.

  4. Dans la zone de texte Start, entrez la valeur de stimulus souhaitée au début de la plage d'utilisateur.

  5. Dans la zone de texte Stop, entrez la valeur de stimulus souhaitée à la fin de la plage d'utilisateur.

  6. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog. Utilisez Tab à droite pour sélectionner le menu Trace. Utilisez la Flèche vers le bas pour sélectionner Trace Statistics. Appuyez sur Click.

  2. Appuyez sur Click pour activer les grandeurs statistiques des traces.

  3. Appuyez sur Tab à droite pour accéder à la zone de sélection User Range de la boîte de dialogue. Appuyez sur Flèche vers le bas pour sélectionner la plage d'utilisateur souhaitée.

  4. Appuyez sur la touche Tab à droite pour accéder à la zone de texte Start. Entrez la valeur de stimulus souhaitée au début de la plage d'utilisateur.

  5. Appuyez sur Tab à droite pour accéder à la zone de texte Stop. Entrez la valeur de stimulus souhaitée à la fin de la plage d'utilisateur.

  6. Dans la zone COMMAND, appuyez sur OK.


Drive Mapping

Voir aussi...

Connexion de lecteurs

Présentation

Concepts

Comment connecter un lecteur

La connexion de lecteurs permet de partager des lecteurs de disque entre l'analyseur et un ordinateur externe.

Concepts

Comment connecter un lecteur

Vous pouvez partager des lecteurs de disque entre l'analyseur et un ordinateur externe à des fins d'enregistrement et de rappel de fichiers.

  • Du point de vue du PC externe, le disque dur de l'analyseur constitue simplement un lecteur supplémentaire.

  • Du point de vue de l'analyseur, le disque dur de l'ordinateur externe constitue simplement un lecteur supplémentaire.

  • Le disque de l'analyseur et celui de l'ordinateur constituent dès lors des sources et des cibles possibles pour la manipulation des fichiers.

Remarque : ces procédures nécessitent une souris et un clavier.
Connexion du lecteur de l'analyseur à un ordinateur externe

Connexion d'un lecteur de l'ordinateur externe à l'analyseur

Remarque : les procédures suivantes exigent que l'ordinateur externe fonctionne sous Windows NT 4.0 (ou version ultérieure).

Connexion du lecteur de l'analyseur à un ordinateur externe

Identification de l'analyseur par un nom d'ordinateur

  1. L'analyseur possède un nom d'ordinateur qui vous sera nécessaire pour exécuter la procédure suivante. Si vous souhaitez afficher ou changer le nom d'ordinateur de l'analyseur, procédez comme suit :

    1. Cliquez sur System, Windows Taskbar, Settings,Control Panel, puis sur l'icône System.

    2. Sélectionnez l'onglet Network Identification. Si nécessaire, notez le nom d'ordinateur. Pour changer le nom d'ordinateur de l'analyseur, cliquez sur Properties et entrez le nouveau nom souhaité. Cliquez sur OK.

Ajout d'un nouvel utilisateur

  2. Cliquez sur Users and Passwords.

  3. Si le bouton Add est grisé, cliquez sur la case "Users must enter a user name and password to use this computer." Cliquez ensuite sur le bouton Add.

  4. Dans le champ User Name, tapez votre nom d'utilisateur (celui que vous utilisez sur l'ordinateur externe). Dans le champ Full Name, entrez votre nom complet. Cliquez sur Next.

  5. Dans le champ Password, tapez votre mot de passe (celui que vous utilisez sur l'ordinateur externe). Tapez-le à nouveau dans le champ Confirm Password. Cliquez sur Next.

  6. Sélectionnez Other en réponse à la question "What level of access do you want to grant this user?", puis sélectionnez l'option par défaut Administrators. Cliquez sur Finish.

Création d'un nom de partage pour le lecteur

  7. Dans la boîte Address, cliquez sur la flèche vers le bas, puis sélectionnez My Computer. Cliquez avec le bouton droit sur le lecteur que vous souhaitez partager avec l'ordinateur externe. Cliquez sur Sharing.

  8. Sélectionnez Share this folder. Tapez un nom de partage dans le champ Share name. Cliquez sur OK.

Connexion de l'ordinateur externe au lecteur partagé

  9. A partir du bureau de l'ordinateur externe, cliquez sur Windows NT Explorer (Explorateur Windows NT). Dans le menu Tools (Outils), sélectionnez Map Network Drive (Connecter un lecteur réseau).

  10. Dans le champ Path (Chemin), tapez un chemin de la forme \\nom_ordinateur\nom_partage.

  11. Dans le champ Connect (Connexion), tapez votre nom d'utilisateur. Cliquez sur OK.

Connexion d'un lecteur de l'ordinateur externe à l'analyseur

  1. A partir du bureau de l'ordinateur externe, cliquez sur Windows NT Explorer (Explorateur Windows NT). Dans la liste des lecteurs, cliquez avec le bouton droit sur le lecteur que vous souhaitez partager. Sélectionnez Sharing (Partager).

  2. Dans la boîte de dialogue, sélectionnez Shared As (Partagé en tant que). Dans le champ Nom de partage, utilisez la touche fléchée ou tapez un nom de partage pour le lecteur (n'importe quel nom convient). Cliquez sur OK.

  3. A partir du bureau de l'analyseur, cliquez sur Windows Explorer. Dans le menu Tools, sélectionnez Map Network Drive.

  4. Dans le champ Folder, tapez un chemin de la forme \\nom_hôte_PC (ou ID)\nom_partage (le nom que vous avez choisi à l'étape 2). Cliquez sur Finish.

  5. Dans le champ Connect as, tapez votre nom d'utilisateur.

  6. Dans le champ Password, tapez votre mot de passe d'ouverture de session (celui que vous utilisez sur l'ordinateur externe). Cliquez sur OK.


SaveRecall

Voir aussi...

Sauvegarder et rappeler un fichier

Présentation

Concepts

Comment sauvegarder et rappeler un fichier

L'analyseur vous permet de sauvegarder des données sur le disque dur interne, une disquette, un lecteur de CD-RW externe, un PC ou un serveur sous divers formats de fichier et de les rappeler.
Concepts

Comment sauvegarder et rappeler un fichier

Cliquez sur un bouton pour en savoir plus sur les points suivants :
Sauvegarde de fichier

Sauvegarde automatique

Sauvegarder sous

Imprimer dans un fichier

Editer un nom de fichier

Rappeler un fichier

Sauvegarde de fichier

Lorsque vous utilisez la fonction Save, l'analyseur sauvegarde des données de fichier binaire sur le disque dur interne en sélectionnant automatiquement le chemin et le nom du fichier courant. S'ils n'ont pas encore été définis, l'analyseur sélectionne automatiquement le chemin par défaut C:\Program Files\Agilent\Network Analyzer\Documents et le nom de fichier "default.cst". Le fichier sera écrasé la prochaine fois que vous utiliserez la fonction Save, à moins que vous ne renommiez et sauvegardiez le fichier en appliquant l'une des méthodes suivantes :

  • Sauvegarde automatique

  • Sauvegarder sous

  • Renommer (à l'aide de l'Explorateur Windows)

Sauvegarde automatique

Lorsque vous utilisez la fonction Auto Save, l'analyseur sauvegarde des données de fichier binaire sur le disque dur interne en sélectionnant automatiquement le chemin courant. S'il n'a pas encore été défini, l'analyseur sélectionne automatiquement le chemin par défaut C:\Program Files\Agilent\Network Analyzer\Documents. En outre, il sélectionne et affiche automatiquement un nouveau nom de fichier .cst. Ceci permet de ne pas écraser le fichier précédemment sauvegardé.

Sauvegarder sous

Lorsque vous utilisez la fonction Save As, l'analyseur sauvegarde des données dans des fichiers binaires ou ASCII à l'un des emplacements suivants désignés par l'utilisateur :

  • Disque dur interne

  • Disquette

  • Lecteur de CD-RW externe, PC ou serveur (à l'aide d'une unité réseau mappée)

Types de fichier binaire

Les types de fichier binaire indiqués ci-dessous sont uniquement utilisés par l'analyseur pour sauvegarder et rappeler des données associées aux mesures. Ces types de fichier ne sont reconnus que par les analyseurs Agilent série PNA.

  • .cst

  • .sta

  • .cal

Les fichiers .cst contiennent les données suivantes :

  • Toutes les mesures configurées sur l'analyseur, y compris les gabarits et les marqueurs

  • Tous les jeux d'étalonnage de mesure configurés sur l'analyseur

  • Mode d'affichage des fenêtres

Il est plus rapide de rappeler un fichier .cst que de rappeler l'état de l'instrument et les fichiers de données d'étalonnage pour chaque mesure.

Les fichiers .sta contiennent les données suivantes :

  • Toutes les mesures configurées sur l'analyseur, y compris les gabarits et les marqueurs

  • Mode d'affichage des fenêtres

Remarque : les fichiers .sta ne contiennent aucun jeu de données d'étalonnage.

Il est plus rapide de rappeler un fichier .sta que de rappeler l'état de l'instrument pour chaque mesure.

Les fichiers .cal ne contiennent que les données de correction de mesure créées par l'analyseur lorsque vous réalisez un étalonnage. Les fichiers .cal ne contiennent pas de données d'état de l'instrument. Les données de correction de mesure sont liées à l'état de l'instrument pour lequel l'étalonnage a été réalisé. Aussi, pour améliorer la précision des mesures lorsqu'un fichier .cal est rappelé, rappelez également les données d'état de l'instrument correspondantes (fichier .sta) utilisées pour réaliser l'étalonnage.

Remarque : la fonction Calibration Properties permet de connaître les paramètres de l'instrument utilisés lors de la sauvegarde du fichier .cal. Pour plus d'informations, voir Sélectionner et exécuter un étalonnage de mesure.

Les étalonnages de mesure sont spécifiques à la voie. Par exemple, un étalonnage exécuté sur la voie 1 ne peut pas être rappelé sur une autre voie.

Types de fichier ASCII

Les types de fichier ASCII indiqués ci-dessous sont sauvegardés sur le disque dur interne de l'analyseur ou sur une disquette. L'analyseur place les fichiers sur votre lecteur de CD-RW externe, PC ou serveur afin de permettre leur utilisation dans des tableurs ou des programmes d'IAO :

  • .prn

  • .s1p

  • .s2p

Remarque : les types de fichier ASCII ne sauvegardent qu'un seul voie active avec une trace active. Vous ne pouvez pas sauvegarder un jeu de mesures dans un même fichier ASCII.

Le format .prn est généralement utilisé par les tableurs, tels que Microsoft® Excel. Les fichiers .prn contiennent des listes formatées de stimulus avec correction d'erreur et de réponse séparés par une virgule pour la trace active courante. Exemple :

"S11 Log Mag" |
"Fréquence (Hz)", "dB" |
3.000000e+005 | -3.528682e+001
4.529850e+007 | -2.817913e+001
9.029700e+007 | -3.216808e+001
1.352955e+008 | -3.101017e+001

L'un des avantages de l'importation des fichiers .prn dans des tableurs est de pouvoir accéder aux formats .prn (Log Mag, Linear Mag, SWR, etc.), et non aux paires réel/imaginaire requises pour les fichiers .s1p et .s2p. De plus, certains tableurs, notamment Excel, peuvent entrer les données des fichiers .prn dans les colonnes d'une feuille de calcul. Les fichiers .prn sont seulement générés ; il ne peuvent pas être lus par l'analyseur.

Les formats .s1p et .s2p (également appelés formats Touchstone) sont généralement utilisés par les applications d'IAO, notamment Microwave Design System (MDS) et Advanced Design System (ADS) d'Agilent. (Vous pouvez également importer des fichiers .s1p et .s2p dans des tableurs, bien que les fichiers .prn soient recommandés.) Les fichiers .s1p et .s2p contiennent des listes de stimulus avec correction d'erreur et de paires réel/imaginaire séparés par un espace pour la trace active courante. Les données représentent le format tableau, y compris les effets de retard électrique et d'e xtensions de port. Ces fichiers sont seulement générés ; il ne peuvent pas être lus par l'analyseur. Les données des fichiers .s1p et .s2p ne peuvent pas afficher de capture d'écran.

Les fichiers .s1p contiennent les données de mesure des composants à 1 port. Ce format renvoie les données corrigées d'un paramètre S sous forme de paires réel/imaginaire pour la trace active courante. Exemple :

!Agilent 835xA : A.O1.01
Fichier !S1P : Mesure : S11 :
Hz S RI R 50.0
3.000000e+005 | 1.644731e-002 | -5.352918e-003
4.529850e+007 | 6.613658e-003 | 3.845622e-002
9.029700e+007 | 1.226958e-002 | 2.139536e-002
1.352955e+008 | 2.736092e-002 | 6.093691e-003
1.802940e+008 | 2.883098e-002 | -4.465516e-002

Remarque : dans les exemples ci-dessus et ci-dessous :

  • Hz = fréquence

  • S = S-paramètres

  • RI = paire réel/imaginaire

  • R 50.0 = impédance de référence

Les fichiers .s2p contiennent les données de mesure des composants à 2 ports. Ce format renvoie les données corrigées de quatre S-paramètres sous forme de paires réel/imaginaire pour la trace active courante. Exemple :

!Agilent 835xA : A.O1.01
Fichier !S2P : Mesure : S11, S21, S12, S22 :
Hz S RI R 50.0
3.000000e+005 | -2.241318e-004 | -1.199616e-006
 | 1.000518e+000 | 5.873038e-004
 | 9.997111e-001 | 3.530481e-005
 | -2.597498e-005 | 8.359684e-005
4.529850e+007 | 4.111997e-004 | -1.182173e-004
 | 1.000306e+000 | -7.713915e-004
 | 9.995822e-001 | 7.192153e-004
 | -3.241569e-005 | 2.542366e-004
9.029700e+007 | 6.449617e-005 | -7.952083e-004
 | 1.000047e+000 | -1.822955e-004
 | 9.990308e-001 | -5.635918e-004
 | 2.029050e-004 | 7.774481e-004
1.352955e+008 | -5.545341e-004 | -1.932054e-004
 | 9.994355e-001 | -4.536113e-004
 | 1.000014e+000 | 8.115917e-004
 | 6.564625e-004 | 5.489338e-004

Pour créer un fichier .s2p valide, l'analyseur doit disposer de la c orrection des e rreurs sur 2 ports. Si la correction des erreurs sur 2 ports est omise, un terme S11, S21, S12 ou S22 ne sera pas disponible et des zéros seront renvoyés dans le champ du paramètre non mesuré. Cependant, l'analyseur créera un fichier .s1p ou .s2p, que toutes les mesures aient été réalisées sur 1 port ou 2 ports ou non.

Imprimer dans un fichier

Lorsque vous utilisez la fonction Print to File, l'analyseur sauvegarde un fichier .bmp (bitmap) d'une capture d'écran à l'un des emplacements désignés par l'utilisateur suivants :

  • Disque dur interne

  • Disquette

  • Lecteur de CD-RW externe, PC ou serveur (à l'aide d'une unité réseau mappée)

L'analyseur sauvegarde automatiquement le fichier .bmp dans le chemin courant. Si vous ne l'avez pas encore défini, l'analyseur sélectionne automatiquement le chemin par défaut C:\Program Files\Agilent\Network Analyzer\.

Comme les fichiers .prn, les fichiers .bmp peuvent être importés dans des applications telles que Microsoft Excel, Word ou Paint pour afficher une capture d'écran.

Editer un nom de fichier

La fonction Edit Filename vous permet de copier un fichier et de lui donner un nouveau nom à l'aide des touches de navigation de l'analyseur. Le fichier et le nom de fichier originaux restent intacts. Cette fonction est accessible à partir de la boîte de dialogue Save As lorsque vous sélectionnez Save As ou Print to File. Voir le graphique ci-dessous.

Remarque : pour plus d'informations sur la gestion des fichiers/dossiers (par exemple, sur les fonctions de copie, suppression, renommage, recherche), voir l'aide de Windows 2000.

Rappeler un fichier

Lorsque vous utilisez la fonction Recall, l'analyseur ne rappelle que les fichiers binaires. Vous pouvez rappeler un fichier .cst ou .sta sous forme de capture d'écran, mais les données doivent avoir été sauvegardées à l'aide du maintien de trace. (Le fichier rappelé ne balaye pas avant d'être déclenché.) Pour plus d'informations sur les types de fichier binaire, voir la partie Sauvegarder sous de cette rubrique.

Lorsque vous utilisez la fonction Recall d'un PC externe, ce dernier ne rappelle que les fichiers ASCII ou bitmap de l'analyseur. Pour rappeler des captures d'écran, rappelez des fichiers .prn ou .bmp dans des applications telles que Microsoft Excel, Word ou Paint. Pour plus d'informations sur les types de fichier ASCII, voir la partie Sauvegarder sous de cette rubrique.

Cliquez sur les boutons ci-dessous pour accéder aux procédures correspondantes.

Remarque : ces procédures nécessitent une souris et un clavier.
Sauvegarder un fichier

Sauvegarder automatiquement un fichier

Sauvegarder un fichier sous un autre nom ou à un autre emplacement

Imprimer dans un fichier

Editer un nom de fichier

Rappeler un fichier sur l'analyseur

Rappeler un fichier sur un ordinateur externe

Sauvegarder un fichier

Procédure à l'aide de la souris

  1. Dans le menu File, cliquez sur Save.

Procédure à l'aide de la face avant

  1. Dans le bloc UTILITY, appuyez sur Save.

  2. Dans la barre d'outils Active Entry, appuyez sur la touche F1 (Save).

Un message s'affiche temporairement à l'écran pour vous indiquer le chemin et le nom de fichier utilisés pour sauvegarder votre fichier.

Remarque : ce fichier sera écrasé la prochaine fois que vous utiliserez la fonction Save, à moins que vous ne renommiez et sauvegardiez le fichier en suivant l'une des méthodes suivantes : Auto Save, Save As, Rename (à l'aide de l'Explorateur Windows)

Sauvegarder automatiquement un fichier

Remarque : cette procédure est réalisée à l'aide des touches de la face avant.

Procédure à l'aide de la face avant

  1. Dans le bloc UTILITY, appuyez sur Save.

  2. Dans la barre d'outils Active Entry, appuyez sur la touche F3 (Auto Save).

Un message s'affiche temporairement à l'écran pour vous indiquer le chemin utilisé pour sauvegarder votre fichier. De plus, l'analyseur sélectionne et affiche automatiquement un nouveau nom de fichier .cst. Ceci permet de ne pas écraser le dernier fichier sauvegardé.

Sauvegarder un fichier sous un autre nom ou à un autre emplacement

Procédure à l'aide de la souris

  1. Dans le menu File, cliquez sur Save As.

  2. Dans la zone Save in de la boîte de dialogue, cliquez sur le bouton fléché pour sélectionner le chemin désiré pour sauvegarder votre fichier.

  3. Dans la zone File name, entrez le nouveau nom de fichier.

  4. Dans la zone Save as type, cliquez sur le bouton fléché pour sélectionner le type de fichier désiré.

  5. Cliquez sur Save.

Procédure à l'aide de la face avant

  1. Dans le bloc UTILITY, appuyez sur Save.

  2. Dans la barre d'outils Active Entry, appuyez sur la touche F2 (Save As).

  3. Appuyez sur la touche Tab de gauche pour aller à la zone Save in. Appuyez sur la flèche vers le bas pour aller au chemin où vous souhaitez sauvegarder votre fichier. Appuyez sur la touche Tab à droite pour sélectionner le chemin.

  4. Dans la zone File name, entrez le nouveau nom de fichier.

  5. Appuyez sur la touche Tab à droite pour aller à la zone Save as. Appuyez sur la flèche vers le bas pour aller au type de fichier désiré. Appuyez sur la touche Tab à droite pour sélectionner le type de fichier.

  6. Appuyez sur la touche Tab à droite pour aller à la zone Save. Appuyez sur Click.

Imprimer dans un fichier

Procédure à l'aide de la souris

  1. Dans le menu File, cliquez sur Print to File.

  2. Dans la zone Save in de la boîte de dialogue, cliquez sur le bouton fléché pour sélectionner le chemin désiré pour sauvegarder votre fichier.

  3. Dans la zone File name, entrez le nouveau nom de fichier.

  4. Cliquez sur Save.

Procédure à l'aide de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, appuyez sur la flèche vers le bas pour aller à Print to File. Appuyez sur Click.

  3. Dans le bloc NAVIGATION, appuyez sur la touche Tab de gauche pour aller à la zone Save in. Appuyez sur la flèche vers le bas pour aller au chemin désiré pour sauvegarder votre fichier. Appuyez sur la touche Tab de droite.

  4. Dans la zone File name, entrez le nouveau nom de fichier.

  5. Appuyez sur la touche Tab de droite pour aller à la zone Save. Appuyez sur Click.

Editer un nom de fichier

Procédure à l'aide de la souris

  1. Dans le menu File, cliquez sur Save As ou Print to File.

  2. Dans la zone Save de la boîte de dialogue, cliquez sur le bouton fléché pour sélectionner le chemin désiré pour votre fichier.

  3. Dans la zone Filepath, sélectionnez votre nom de fichier.

  4. Cliquez sur Edit Filename.

  5. Dans la boîte de dialogue, entrez le nouveau nom de fichier en utilisant l'une des deux méthodes suivantes :

    • Utilisez le clavier externe.

    • Cliquez sur les lettres ou les boutons (<<, Select, Back, >>).

  6. Cliquez sur OK, Save.

Procédure à l'aide de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, appuyez sur la flèche vers le bas pour aller à Save As ou Print to File. Appuyez sur Click.

  3. Appuyez sur la touche Tab de gauche pour aller à la zone Save in. Appuyez sur la flèche vers le bas pour aller au chemin désiré pour votre fichier. Appuyez sur la touche Tab de droite.

  4. Appuyez sur la touche Tab de gauche pour aller à la zone Filepath. Utilisez les flèches vers le haut et vers le bas pour aller à votre nom de fichier. Appuyez sur Click.

  5. Appuyez sur la touche Tab de droite pour aller à la zone Edit Filename. Appuyez sur Click.

  6. Dans la boîte de dialogue, entrez le nouveau nom de fichier en utilisant l'une des deux méthodes suivantes :

    • Utilisez le clavier externe.

    • Appuyez sur les flèches vers le haut ou vers le bas pour aller à la lettre désirée. Appuyez sur Click. Appuyez sur la touche Tab de droite ou de gauche pour aller au bouton désiré (<<, Select, Back, >>). Appuyez sur Click.

  7. Appuyez sur la touche Tab de droite pour aller à OK. Appuyez sur Click.

  8. Appuyez sur la touche Tab de droite pour aller à Save. Appuyez sur Click.

Rappeler un fichier sur l'analyseur

Procédure à l'aide de la souris

  1. Si vous ne l'avez pas encore fait, mappez une unité réseau au périphérique de stockage de données externe (voir Connexion de lecteurs). Ceci fera apparaître le disque dur du périphérique de stockage de données externe dans le répertoire de l'analyseur.

  2. Dans le menu File, cliquez sur Recall.

  3. Dans la zone Look in de la boîte de dialogue, cliquez sur le bouton fléché pour sélectionner le chemin désiré pour rappeler votre fichier.

  4. Dans la zone Files of type, cliquez sur le bouton fléché pour sélectionner le type de fichier désiré.

  5. Dans la zone Filepath, sélectionnez le nom du fichier que vous souhaitez rappeler.

  6. Cliquez sur Recall.

Procédure à l'aide de la face avant

  1. Si vous ne l'avez pas encore fait, mappez une unité réseau au périphérique de stockage de données externe (voir Connexion de lecteurs). Ceci fera apparaître le disque dur du périphérique de stockage de données externe dans le répertoire de l'analyseur.

  2. Dans le bloc UTILITY, appuyez sur Recall.

  3. Dans la barre d'outils Active Entry, appuyez sur la touche F1, F2 ou F3 pour sélectionner l'un des noms de fichier affichés. (Ces noms de fichier apparaissent dans l'ordre alphanumérique.) Si vous souhaitez rappeler un autre fichier, appuyez sur la touche F4 (Open).

  4. Si vous avez sélectionné F4 (Open) à l'étape précédente :

    1. Appuyez sur la touche Tab de gauche pour aller à la zone Look in. Appuyez sur la flèche vers le bas pour aller au chemin désiré pour rappeler votre fichier. Appuyez sur la touche Tab de droite.

    2. Appuyez sur la touche Tab de droite. Dans la zone Files of type, appuyez sur la flèche vers le bas pour aller au type de fichier désiré. Appuyez sur la touche Tab de droite.

    3. Appuyez sur la touche Tab de gauche pour aller à la zone Filepath. Appuyez sur la flèche vers le bas pour aller au type désiré de fichier binaire. Appuyez sur la touche Tab de droite.

    4. Appuyez sur la touche Tab de droite pour aller à la zone Recall. Appuyez sur Click.

Rappeler un fichier sur un ordinateur externe

  1. Si vous ne l'avez pas encore fait, mappez une unité réseau à l'analyseur (voir Connexion de lecteurs). Ceci fera apparaître le disque dur de l'analyseur dans le répertoire du PC.

  2. Utilisez l'Explorateur® Windows de l'ordinateur externe pour rappeler le fichier ASCII ou bitmap désiré depuis l'analyseur.

Pour toute instruction sur l'utilisation de l'Explorateur Windows, reportez-vous au système d'aide de la version de Windows® installée sur l'ordinateur externe.


Print

Impression d'une mesure affichée

Voir aussi...

L'analyseur permet d'imprimer une mesure affichée, soit avec une imprimante réseau, soit avec une imprimante locale. Cliquez sur les boutons pour accéder aux procédures.
Connexion à une imprimante sur un réseau

Connexion d'une imprimante à l'analyseur

Création d'une impression

Connexion à une imprimante sur un réseau

Remarque : Cette procédure nécessite une souris et un clavier.

  1. Connectez un câble de réseau local entre le connecteur LAN du panneau arrière de l'analyseur et la prise LAN du réseau.

  2. Sur le bureau de l'analyseur, cliquez sur Start, Settings, Printers.

  3. Cliquez deux fois sur Add Printer pour démarrer Add Printer Wizard. Cliquez sur Next.

  4. Cliquez sur Network Printer, Next.

  5. Connectez-vous à l'imprimante souhaitée de l'une ou l'autre des manières suivantes :

  • Tapez son nom en utilisant le format suivant, ou cliquez sur Next pour localiser l'imprimante sur le réseau : //printservername/sharename

  • Tapez son URL en utilisant le format suivant : http://printservername/Printers/sharename/.printer

Remarque : si la connexion à votre imprimante n'est pas possible avec les instructions précédentes, veuillez vous reporter à la documentation de l'imprimante ou contacter votre administrateur de réseau.

  6. Suivez les instructions affichées à l'écran pour achever la connexion à l'imprimante réseau.

  7. L'icône de l'imprimante apparaît dans le dossier Imprimantes.

Connexion d'une imprimante à l'analyseur

Remarque : cette procédure nécessite une souris et un clavier.

  1. Connectez l'imprimante au port approprié de l'analyseur conformément aux instructions du fabricant de l'imprimante.

  2. Windows 2000 installera automatiquement la plupart des imprimantes. Cependant, dans le cas d'imprimantes plus anciennes, des informations complémentaires seront peut-être nécessaires pour achever l'installation. Si l'icône de votre imprimante n'est pas ajoutée dans le dossier Imprimantes, choisissez l'une des procédures suivantes, selon le type de votre imprimante.
Installation d'une imprimante compatible port parallèle (LPT)

Installation d'une imprimante compatible USB

Installation d'une imprimante compatible port série (COM)

Installation d'une imprimante compatible port parallèle (LPT)

  1. Connectez l'imprimante à l'analyseur. Un adaptateur (36 broches mâles (1284-C) en 25 broches femelles) est fourni avec les accessoires de l'analyseur afin de permettre une connexion entre le port parallèle et un port Centronics.

ATTENTION ! N'utilisez pas le port de 25 broches femelles marqué Ext. Test Set Interface pour connecter votre imprimante. Les niveaux de tension des lignes de signaux peuvent endommager les E/S de l'imprimante.

  2. Sur le bureau de l'analyseur, cliquez sur Start, Settings, Printers.

  3. Cliquez deux fois sur Add Printer pour démarrer Add Printer Wizard. Cliquez sur Next.

  4. Cliquez sur Local Printer, assurez-vous que les cases Automatically detect et Install my Plug and Play printer sont cochées et cliquez ensuite sur Next.

  5. Selon l'imprimante que vous installez, soit l'Assistant Ajout d'imprimante se poursuit, soit le message Nouveau matériel trouvé, soit l'Assistant Nouveau matériel trouvé apparaît afin de notifier le début de l'installation. Suivez les instructions affichées à l'écran pour achever l'installation de l'imprimante.

    • Sinon, après connexion de votre imprimante, vous pouvez démarrer ou redémarrer l'analyseur pour permettre à Windows 2000 de lancer automatiquement l'assistant Nouveau matériel touvé.

  6. L'icône de l'imprimante sera ajoutée au dossier Imprimantes.

Installation d'une imprimante compatible USB

Connectez l'imprimante au port USB de l'analyseur. Ce type d'imprimante sera détecté par Windows 2000 et l'assistant Nouveau matériel trouvé démarrera automatiquement.

Il n'est pas nécessaire d'arrêter ou de redémarrer l'analyseur. Suivez les instructions affichées à l'écran pour achever l'installation de l'imprimante.

L'icône de l'imprimante sera ajoutée au dossier Imprimantes.

Installation d'une imprimante compatible port série (COM)

  1. Connectez l'imprimante au connecteur série de l'analyseur.

  2. Sur le bureau de l'analyseur, cliquez sur Start, Settings, Printers.

  3. Cliquez deux fois sur Add Printer pour démarrer Add Printer Wizard. Cliquez sur Next.

  4. Cliquez sur Local Printer, assurez-vous que les cases Automatically detect et Install my Plug and Play printer sont cochées et cliquez ensuite sur Next.

  5. Achevez l'installation de l'imprimante en suivant les instructions afin de définir :

  • Le port de l'imprimante

  • Le fabricant et le modèle de votre imprimante

  • Le nom de l'imprimante

  6. L'icône de l'imprimante sera ajoutée au dossier Imprimantes.

Remarque : si vous ajoutez et configurez une imprimante Plug-and-Play (par exemple, USB, ou port parallèle (LPT)), il n'est pas nécessaire que vous ayez des privilèges d'administrateur. Cependant, pour ajouter et configurer une imprimante non Plug-and-Play connectée directement à l'analyseur, vous devez ouvrir une session en tant qu'administrateur ou membre du groupe des administrateurs. Si l'analyseur est connecté à un réseau, les paramètres de la politique de gestion du réseau peuvent empêcher l'achèvement de cette procédure.

Création d'une impression

A l'aide de la souris

  1. Dans le menu File, cliquez sur Print.

  2. Dans la boîte de dialogue Print, déplacez-vous sur Name. Cliquez sur le bouton marqué d'une flèche pour sélectionner l'imprimante souhaitée. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le groupe des touches UTILITY, appuyez sur la touche portant l'icône Print.

  2. Dans le bloc NAVIGATION, appuyez sur la flèche Haut ou Bas pour sélectionner l'imprimante souhaitée dans la boîte de dialogue Name. Cliquez sur OK.

Remarque : pour plus d'informations concernant les choix de la boîte de dialogue Imprimer, consultez l'aide Windows 2000.

Le graphique ci-dessous montre l'impression d'une image de capture d'écran. Remarquez que les données sous forme de texte sont automatiquement incorporées dans l'image de capture d'écran.


Tutorials

Didacticiel sur les mesures

Voir aussi...

Cliquez sur un bouton pour en savoir plus sur les mesures correspondantes.

Référence des mesures de phase

Référence des paramètres d'amplificateur

Conversion AM-PM

Impédance complexe

Ecart de la phase linéaire

Temps de propagation de groupe

Gain et réponse en fréquence (plate)

Compression de gain

Isolement inversé

Composants de forte puissance

Puissance de sortie absolue

Modèle d'adaptation d'impédance

Ondes réfléchies le long d'une ligne de transmission

Domaine temporel


Phase Meas

Référence des mesures de phase

Voir aussi...

En utilisant l'analyseur, vous pouvez effectuer les mesures de phase suivantes pour caractériser un composant :

  • Ecart par rapport à une phase linéaire

  • Temps de propagation de groupe

  • Impédance complexe

  • Conversion AM-PM

L'intégration réussie des composants de niveau supérieur nécessite une connaissance des caractéristiques d'amplitude et de phase.

Cliquez sur les boutons pour accéder aux informations suivantes :

Que sont les mesures de phase ?

Pourquoi mesurer la phase ?

Utilisation du format de la phase de l'analyseur

Types de mesures de phase

Que sont les mesures de phase ?

Les mesures de phase sont effectuées en utilisant les paramètres S, exactement comme les mesures d'amplitude. Une mesure de phase est une mesure relative (rapport) et non une mesure absolue. Les mesures de phase comparent la phase du signal entrant dans un composant (le signal incident) avec la phase du signal de réponse du composant. Le signal de réponse peut être soit refléchi, soit transmis. Si un étalonnage précis a été effectué, la différence de phase (connue en tant que déphasage) entre les deux signaux est fonction des caractéristiques électriq ues du composant en cours de test.

Le graphique suivant montre le déphasage (en temps ou degrés) entre un signal incident et un signal transmis (tel qu'il apparaîtrait sur un écran d'oscilloscope).

Pourquoi mesurer la phase ?

La mesure de phase est un élément critique de l'analyse de réseau. Le graphique suivant énumère cinq raisons de mesurer à la fois l'amplitude et la phase.

Lorsqu'ils sont utilisés pour transmettre des signaux, les composants ou circuits ne doivent pas provoquer de distorsion excessive du signal. Cette distorsion peut être :

  • Linéaire, lorsqu'une amplitude constante et un déphasage linéaire par rapport à la fréquence ne sont pas maintenus dans la bande passante présentant un intérêt.

  • Non linéaire, comme dans le cas d'une conversion AM-PM.

Il est important de mesurer la réflexion provoquée par un composant ou par un circuit, afin de s'assurer qu'il transmet ou absorbe efficacement l'énergie. La mesure de l'impédance complexe d'une antenne en est un bon exemple.

Utilisation du format de la phase de l'analyseur

Le format de phase de l'analyseur présente une mesure de la phase en fonction de la fréquence ou de la phase en fonction de la puissance. L'analyseur ne peut pas mesurer une différence de phase supérieure à ±180 degrés entre les signaux de référence et de test. Ainsi, alors que la phase varie entre +180 degrés et -180 degrés, elle crée la configuration en dent de scie montrée sur le graphique suivant.

La configuration en dent de scie n'atteint pas toujours +180 degrés et -180 degrés. Cela est dû au fait que la mesure est effectuée à des fréquences discrètes et que les points de données à +180 degrés et -180 degrés ne peuvent pas forcément être mesurés pendant le balayage sélectionné.

Types de mesures de phase

  • Les données d'impédance complexe sont des informations telles que des résistances, des réactances, des phases et des amplitudes qui peuvent être déterminées à partir d'une mesure de S11 ou de S22. Les données d'impédance complexe peuvent être affichées en utilisant un diagramme de Smith ou une représentation polaire.

  • La conversion AM-PM est une mesure de la valeur d'écart de phase non souhaité (PM) provoquée par des variations d'amplitude (AM) du système. La conversion AM-PM est habituellement définie comme la variation de la phase de sortie pour une augmentation de 1 dB de la puisance à l'entrée d'un amplificateur (c'est-à-dire au point de compression de gain de 1 dB). Elle est exprimée en degrés par dB (°/dB).

  • L'écart par rapport à une phase linéaire est une mesure de la distortion de phase créée par un composant. De manière idéale, le déphasage à travers le composant est une fonction linéaire de la fréquence. La quantité de variation par rapport à ce déphasage théorique est connue en tant qu'é cart par rapport à une p hase l inéaire (également appelé linéarité de phase).

  • Le temps de propagation est une autre manière de considérer la distortion de phase provoquée par un composant. Il correspond à une mesure du temps de propagation à travers un composant à une fréquence particulière. L'analyseur calcule le temps de propagation de groupe à partir de la dérivée de la réponse en phase mesurée.

Ecart par rapport à une phase linéaire et temps de propagation de groupe

L'analyseur peut mesurer la linéarité du déphasage dans une plage de fréquences et l'exprimer sous deux formes différentes :

  • Directement, en tant qu'écart par rapport à une phase linéaire

  • Valeur dérivée, en tant que temps de propagation de groupe

Avantages des mesures d'écart par rapport à une phase linéaire :

  • Comportent moins de bruit que le temps de propagation de groupe.

  • Capables de caractériser des composants qui transmettent des signaux modulés en phase et présentent des unités de phase plutôt que des unités de secondes.

Avantages des mesures de temps de propagation de groupe :

  • Indication de distorsion de phase plus facile à interpréter que celle de l'é cart par rapport à une p hase l inéaire.

  • Capable de caractériser de manière plus précise un composant en cours de test. Car, pour déterminer le temps de propagation de groupe, l'analyseur calcule la pente de la variation de phase, qui dépend du nombre de fluctuations par unité de fréquence. En comparant deux réponses en phase présentant la même variation de phase crête-à-crête, la réponse ayant la pente de phase la plus grande résulte en :

    • Une variation du retard de phase supérieure.

    • Une distorsion supérieure du signal.


Amp Param

Référence des paramètres d'un amplificateur

Voir aussi...

Gain

Planéité de la courbe de gain

Isolement inversé

Dérive du gain dans le temps

Ecart par rapport à une phase linéaire

Temps de propagation de groupe

Perte par réflexion (SWR, r)

Impédance complexe

Compression du gain

Conversion AM-PM

Gain

Rapport de la puissance de sortie de l'amplificateur (fournie à une charge d'impédance Z0) sur la puissance d'entrée (reçue d'une source d'impédance Z0). Z0 est l' impédance caractéristique , égale à 50 W dans le cas présent.

Pour les petits niveaux de signal, la puissance de sortie de l'amplificateur est proportionnelle à la puissance d'entrée. Le gain dans le domaine des petits signaux est le gain observé dans cette région de fonctionnement linéaire de l'amplificateur.

A mesure que le niveau de la puissance d'entrée augmente et que l'amplificateur approche de la saturation, la puissance de sortie atteint une limite et le gain chute. Le gain dans le domaine des grands signaux est le gain observé dans cette région de fonctionnement non linéaire de l'amplificateur. Voir Compression du gain.

Planéité de la courbe de gain

Variation du gain sur la plage de fréquences de l'amplificateur. Voir Gain dans le domaine des petits signaux et planéité de la courbe de gain.

Isolement inverse

Mesure de la transmission de la sortie vers l'entrée. Son principe est identique à la mesure de gain, à ceci près que le signal (stimulus) est appliqué à la sortie de l'amplificateur. Voir Isolement inverse.

Dérive du gain dans le temps (température, polarisation)

Variation maximale du gain dans le temps lorsque tous les autres paramètres sont maintenus constants. La dérive du gain est également observée en cas de changement de paramètres tels que la température, l'humidité ou la tension de polarisation.

Ecart par rapport à une phase linéaire

Ampleur de variation par rapport à un décalage de phase linéaire. Idéalement, le déphasage subi par le signal en traversant l'amplificateur évolue linéairement par rapport à la fréquence. Voir Ecart par rapport à une phase linéaire.

Temps de propagation de groupe

Mesure du temps de transit à travers l'amplificateur en fonction de la fréquence. Si le déphasage évolue de manière parfaitement linéaire par rapport à la fréquence, le temps de propagation de groupe est constant. Voir Temps de propagation de groupe.

Perte par réflexion (SWR, r)

Mesure de la réflexion à l'entrée ou à la sortie de l'amplificateur résultant de la désadaptation par rapport à l'impédance caractéristique Z0 du système.

Impédance complexe

Impédance complexe (1+G). La quantité d'énergie réfléchie par un amplificateur est directement liée à son impédance. L'impédance complexe est constituée d'une composante résistive et d'une composante réactive. Elle est déterminée d'après l'impédance caractéristique du système et le coefficient de réflexion. Voir Impédance complexe.

Compression du gain

Un amplificateur possède une région de fonctionnement linéaire dans laquelle le gain est indépendant du niveau de la puissance d'entrée (c'est ce qu'on appelle le gain dans le domaine des petits signaux). Lorsque l'on augmente la puissance d'entrée au point de saturer l'amplificateur, le gain décroît.

La compression du gain est déterminée en mesurant le point de compression de 1 dB du gain de l'amplificateur (P 1dB), c'est-à-dire la puissance de sortie pour laquelle le gain chute de 1 dB par rapport au gain de la région linéaire (domaine des petits signaux). Il s'agit d'une mesure courante de performance d'un amplificateur en termes de puissance de sortie. Voir Compression du gain.

Coefficient de conversion AM-PM

Ampleur de la variation de phase observée dans le signal de sortie d'un amplificateur par rapport à un changement d'amplitude du signal d'entrée.

Le coefficient de conversion AM-PM est exprimé en degrés/dB à un niveau de puissance donné (généralement P1dB, qui est le point de compression de 1 dB du gain). Voir Conversion AM-PM.


Comp Imped

Voir aussi...

Impédance complexe

Présentation

Concepts

Comment mesurer
l'impédance complexe

Lors de la mesure du paramètre S11 ou S22 du composant à tester, vous pouvez visualiser des données d'impédance complexe telles que la résistance série et la réactance ainsi que des informations sur la phase et l'amplitude. Les données d'impédance complexe peuvent être visualisées au format abaque de Smith ou au format polaire.

Concepts

Comment mesurer l'impédance complexe

Cliquez sur un bouton pour en savoir plus sur l'un des sujets suivants :
Qu'est-ce que l'impédance complexe ?

Visualiser les données au format abaque de Smith

Visualiser les données au format polaire

Précision

Qu'est-ce que l'impédance complexe ?

Les données d'impédance complexe sont des informations qui peuvent être déterminées à partir de la mesure du paramètre S11 ou S22 de votre composant. Ces informations peuvent être les suivantes :

  • Résistance

  • Réactance

  • Phase

  • Amplitude

La quantité de puissance réfléchie par un composant est directement liée aux impédances respectives de ce composant et du système de mesure. Par exemple, le coefficient de réflexion complexe (G) est égal à 0 lorsque l'impédance du composant et celle du système sont parfaitement identiques (la puissance transmise de la source à la charge est alors à son maximum). A chaque valeur de G correspond une impédance complexe (en fonction de la fréquence), calculée d'après la formule suivante :

ZL= [(1 + G) / (1 - G)] ´ Z0

où ZL est l'impédance du composant testé et Z0, l'impédance caractéristique du système de mesure.

Visualisation des données au format abaque de Smith

La sélection du format abaque de Smith de l'analyseur constitue l'un des moyens de visualiser les données d'impédance complexe à partir de la mesure du paramètre S11 ou S22 d'un composant. L'abaque de Smith est un outil qui établit la relation entre le coefficient de réflexion complexe (G) et l'impédance du composant à tester.

Dans un abaque de Smith, le plan d'impédance complexe forme une grille circulaire à partir de laquelle il est possible de lire la résistance série et la réactance (R + jX). Les fonctions de marqueur de l'analyseur affichent :

  • la résistance (en ohms),

  • la réactance, exprimée en farads si elle est de nature capacitive ou en henrys si elle est de nature inductive.

Etudiez le graphique ci-dessous et lisez les explications qui suivent :

  • L'axe horizontal (trait plein) est la partie réelle de l'impédance, c'est-à-dire la résistance. Le milieu de cet axe correspond toujours à l'impédance caractéristique du système.

  • Les cercles en pointillés qui croisent l'axe horizontal représentent chacun une valeur de résistance constante. Les arcs en pointillés tangents à l'axe horizontal représentent chacun une valeur de réactance constante.

  • La moitié supérieure de l'abaque de Smith est la zone où la composante réactive est positive, donc inductive. La moitié inférieure est la zone où la composante réactive est négative, donc capacitive.

Visualisation des données au format polaire

Le format polaire de l'analyseur permet aussi de visualiser l'amplitude et la phase du coefficient de réflexion (G) obtenu à partir d'une mesure du paramètre S11 ou S22. Les fonctions de marqueur de l'analyseur affichent :

  • l'amplitude linéaire (en unités) ou l'amplitude logarithmique (en dB),

  • la phase (en degrés).

Etudiez le graphique ci-dessous et lisez les explications qui suivent :

  • Les cercles en pointillés représentent chacun une valeur de coefficient de réflexion. Le cercle le plus à l'extérieur correspond à un coefficient de réflexion (G) de 1, c'est-à-dire à une réflexion totale du signal. Le centre du diagramme polaire correspond à un coefficient de réflexion (G) de 0, c'est-à-dire à l'absence de réflexion.

  • Les lignes radiales représentent différents angles de phase du signal réfléchi. La position angulaire la plus à droite correspond à un angle de phase nul (ce qui signifie que le signal réfléchi est à la même phase que le signal incident). Les déphasages de 90°, ±180° et -90° sont figurés respectivement par les positions supérieure, extrême gauche et inférieure.

Précision

  • La meilleure lisibilité de l'abaque de Smith est obtenue avec une valeur de pleine échelle de 1,0.

  • Si vous utilisez des marqueurs pour interpréter un abaque de Smith ou un diagramme polaire, activez le mode Discrete Marker (marqueurs discrets) afin d'optimiser la précision de lecture des données.

  • L'incertitude des mesures de réflexion résulte des facteurs d'erreur suivants :

    • Directivité

    • Poursuite de réflexion

    • Adaptation de la source

    • A daptation de la c harge (avec les composants de type quadripôle)

Un étalonnage sur deux ports permet de limiter l'incidence de ces facteurs. Dans le cas d'un étalonnage sur un port, la même précision peut être obtenue avec une bonne terminaison de la sortie du composant. Etudiez le graphique ci-dessous et lisez les explications qui suivent :

  • Si vous connectez le composant entre les deux ports de l'analyseur, munissez-le d'un atténuateur de 10 dB à sa sortie pour améliorer la précision de mesure. Cette configuration n'est pas nécessaire si vous procédez à un étalonnage sur deux ports, car celui-ci corrige la désadaptation de la charge.

  • Si le composant à tester est un quadripôle et que vous le reliez à un seul port de l'analyseur, il est recommandé d'équiper sa sortie d'une charge de haute qualité (par exemple, un étalon).

  1. Connectez le composant conformément à l'illustration précédente.

  2. Préréglez l'analyseur (touche Preset).

  3. Configurez, étalonnez et exécutez une mesure du paramètre S11 ou S22.

  4. Visualisez les données d'impédance :

    1. Sélectionnez le format abaque de Smith (option Smith Chart).

    2. Réglez l'échelle pour une visualisation optimale de la mesure affichée.

    3. Positionnez le marqueur de manière à lire les composantes résistive et réactive de l'impédance complexe en un point particulier de la trace.

    4. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

  5. Visualisez les données d'admittance (si nécessaire) :

    1. Sélectionnez la fonction de marqueur permettant d'afficher un abaque de Smith inverse.

    2. Réglez l'échelle pour une visualisation optimale de la mesure affichée.

    3. Positionnez le marqueur de manière à lire les valeurs de conductance et de susceptance de l'impédance complexe en un point particulier de la trace. La conductance et la susceptance sont exprimées en siemens (inverse de l'ohm).

    4. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

  6. Visualisez l'amplitude et la phase du coefficient de réflexion :

    1. Sélectionnez le format abaque de Smith (option Smith Chart) ou le format polaire (option Polar).

    2. Sélectionnez le format Lin Marker ou Log Marker.

    3. Réglez l'échelle pour une visualisation optimale de la mesure affichée.

    4. Positionnez le marqueur de manière à lire la fréquence, l'amplitude et la phase du coefficient de réflexion (G) en un point particulier de la trace.

    5. Imprimez les données ou enregistrez-les sur un disque ou une disquette.


Group Delay6_5

Voir aussi...

Temps de propagation de groupe

Présentation

Concepts

Comment effectuer la mesure

Le temps de propagation de groupe est une mesure de la distorsion de la phase. Le temps de propagation de groupe est le temps de propagation d'un signal à travers un composant sous test en fonction de la fréquence. Lors de la spécification d'un temps de propagation de groupe, il est important de spécifier l'ouverture utilisée pour la mesure.
Concepts

Comment effectuer la mesure d'un temps de propagation de groupe

Cliquez sur le bouton d'une des rubriques suivantes
Qu'est-ce que le temps de propagation de groupe ?

Temps de propagation de groupe et écart par rapport à la phase linéaire

Qu'est-ce que l'ouverture ?

Précision

Qu'est-ce que le temps de propagation de groupe ?

Le temps de propagation de groupe est :

• Une mesure de la distorsion de phase d'un composant.
• Le temps de propagation d'un signal à travers un composant, en fonction de la fréquence.
• La dérivée de la caractéristique de phase du composant par rapport à la fréquence.

Référez-vous au graphique ci-dessous au cours de la présentation qui suit :

La caractéristique de phase d'un composant consiste de manière typique en des composantes de déphasage linéaire et d'ordre supérieur (écart par rapport à la phase linéaire).

Composante de déphasage linéaire : | Composante de déphasage d'ordre supérieur :
Représente le temps de propagation moyen du signal. | Représente les variations du temps de propagation aux diverses fréquences.
Attribué à la longueur électrique du composant sous test. | Source de distorsion de signal.

Référez-vous au graphique ci-dessous au cours de la présentation qui suit :

Dans une mesure de temps de propagation de groupe :

  • La composante de déphasage linéaire est convertie en une valeur constante (représentant le temps de propagation moyen).

  • La composante de déphasage d'ordre supérieur est transformée en écarts par rapport à un temps de propagation de groupe constant (ou ondulation de temps de propagation de groupe).

  • Les écarts des temps de propagation de groupe provoquent une distorsion du signal, exactement de la même manière que les écarts par rapport à la phase linéaire.

  • La trace de mesure représente le temps nécessaire à chaque fréquence pour se déplacer à travers le composant sous test.

Référerez-vous à l'équation qui suit pendant cette présentation de la manière dont l'analyseur calcule le temps de propagation de groupe :

  • Les données de phase sont utilisées pour connaître les variations de phase (-df).

  • Une ouverture de fréquence spécifiée est utilisée pour connaître la variation de fréquence (dw).

  • En utilisant les deux valeurs ci-dessus, il est possible de calculer une valeur approchée de l'amplitude de variation de la phase en fonction de la fréquence.

  • Cette approximation représente le temps de propagation de groupe en secondes (en supposant une variation de phase linéaire dans l'ouverture de fréquences spécifiée).

Temps de propagation de groupe et écart par rapport à la phase linéaire

Le temps de propagation de groupe donne souvent une indication plus précise de la distorsion de la phase que l'é cart par rapport à la phase l inéaire .

Les résultats du calcul de l'écart par rapport à la phase linéaire sont affichés dans la partie supérieure du graphique suivant : Le composant 1 et le composant 2 ont la même valeur, malgré des apparences différentes.

Les résultats du calcul du temps de propagation de groupe sont affichés dans la partie inférieure :
Le composant 1 et le composant 2 ont différentes valeurs de temps de propagation de groupe. Ceci est dû au fait que, lors de la détermination du temps de propagation de groupe, l'analyseur calcule la pente de l'ondulation de phase qui dépend du nombre d'ondulations qui apparaissent par unité de fréquence.

Qu'est-ce que l'ouverture ?

Au cours d'une mesure de temps de propagation de groupe, l'analyseur mesure la phase à deux fréquences très proches et calcule ensuite la pente de phase. L'intervalle de fréquences (écart de fréquences) entre deux points de mesure de phase est appelé l'ouverture. Une modification de l'ouverture peut se traduire par différentes valeurs de temps de propagation de groupe. La pente calculée (phase delta) varie alors que l'ouverture augmente. C'est la raison pour laquelle vous devez connaître l'ouverture utilisée pour effectuer les mesures lorsque vous comparez des données de tem ps de propagation de groupe.

Référez-vous au graphique ci-dessous au cours de la présentation qui suit :

Ouverture étroite : | Ouverture large :
Donne des détails plus précis de la linéarité de la phase. | Fournit des détails moins précis de la linéarité de la phase parce que certaines réponses de phase sont moyennées ou non mesurées.
Effectue des mesures sensibles au bruit (rapport signal sur bruit inférieur) et à la résolution du détecteur de phase de l'analyseur. | Effectue des mesures moins sensibles au bruit (rapport signal sur bruit supérieur).

La valeur par défaut de l'ouverture de temps de propagation de groupe de l'analyseur est égale à la bande d'analyse divisée par le nombre de points de l'affichage. Il existe deux moyens pour régler l'ouverture à une valeur différente.

  1. Régler le nombre de points de mesure ou la bande d'analyse.

  • L'augmentation du nombre de points ou la réduction de la bande d'analyse diminue l'ouverture.

  • La diminution du nombre de points et/ou l'augmentation de la bande d'analyse agrandit l'ouverture.

Remarque : si l'ouverture est trop grande (déphasage supérieur à 180° entre deux points de fréquence contigus), les données de temps de propagation de groupe peuvent comporter des erreurs.

  2. Utiliser la fonction de lissage de l'analyseur.

  • Calcule une moyenne mobile, sur un balayage unique, des points de données contigus dans un pourcentage spécifié de la bande d'analyse.

  • Se traduit par une action similaire à une modification de l'intervalle de fréquences entre les points.

  • Permet une ouverture plus large parce qu'un déphasage supérieur à 180° peut exister dans l'ouverture de lissage.

Des mesures de temps de propagation de groupe peuvent être effectuées avec les types de balayage suivants :

  • Fréquence linéaire

  • Liste de segments de balayage de fréquence

L'ouverture de temps de propagation de groupe varie en fonction de l'espacement des fréquences et de la densité des points, donc l'ouverture n'est pas constante au cours d'un balayage de segment. Dans un balayage de segment, des points de fréquence supplémentaires peuvent être définis afin d'avoir l'ouverture souhaitée.

Précision

Il est important que la différence de phase entre deux points de mesure contigus reste inférieure à 180° (voir le graphique suivant). Autrement, les informations de phase et de temps de propagation peuvent être incorrectes. Un sous-échantillonnage peut se produire lors de la mesure de composants ayant des longueurs électriques importantes. Vous pouvez vérifier que la différence de phase entre deux points contigus est inférieure à 180° en réglant les paramètres suivants jusqu'à ce que la trace de mesure n'évolue plus :

  • Augmenter le nombre de points

  • Réduire la bande d'analyse

Le r etard électrique peut également être utilisé pour compenser cet effet.

La réponse en fréquence est l'erreur principale dans un réglage de test de temps de propagation de groupe. En effectuant un étalonnage de la mesure de réponse directe, vous réduirez de manière importante cette erreur. Pour une meilleure précision, effectuez un étalonnage de mesure à deux ports.

Particulièrement dans le cas d'un amplificateur, la réponse peut évoluer différemment selon la température. Les tests doivent être réalisés lorsque l'amplificateur est à la température de fonctionnement souhaitée.

Comment effectuer la mesure d'un temps de propagation de groupe

  1. Préréglez l'analyseur.

  2. Si le composant sous test est un amplificateur, il peut être nécessaire d'ajuster la puissance de la source de l'analyseur :

    • Réglez la puissance de la source de l'analyseur pour qu'elle se situe dans la région linéaire de la réponse de sortie de l'amplificateur (typiquement 10 dB au-dessous du point de compression de 1 dB).

    • Sélectionnez un atténuateur externe (si nécessaire) pour atténuer suffisamment la puissance de sortie de l'amplificateur et éviter une compression du récepteur ou des dommages au port 2 de l'analyseur.

  3. Connectez le composant sous test comme illustré sur le graphique suivant.

  3. Sélectionnez une mesure de S21.

  4. Fixez les paramètres de votre composant sous test comme suit :

    • nombre de points de mesure : maximum

    • format : retard

    • échelle : Autoscale

  5. Retirez le composant sous test et effectuez un étalonnage de la mesure.

  6. Connectez de nouveau le composant sous test.

  7. Réglez l'échelle des mesures affichées pour une visualisation optimale.

  8. Utilisez la fonction de lissage de l'analyseur afin d'augmenter l'ouverture, réduisant ainsi le bruit sur la trace tout en conservant les détails significatifs. Pour augmenter l'ouverture :

    • Activez la fonction de lissage de l'analyseur.

    • Modifiez l'ouverture de lissage (jusqu'à 25% de la bande d'analyse balayée).

  9. Utilisez les marqueurs afin de mesurer le temps de propagation de groupe (exprimé en secondes) à une fréquence particulière présentant un intérêt.

  10. Imprimez les données ou enregistrez-les sur un disque.


Output Pwr

Voir aussi...

Puissance de sortie absolue

Présentation

Concepts

Comment mesurer la
puissance de sortie absolue

Une mesure de puissance de sortie absolue affiche la puissance absolue en fonction de la fréquence.
Concepts

Comment mesurer la puissance de sortie absolue

Cliquez sur le bouton d'une des rubriques suivantes :
Qu'est-ce que la puissance de sortie absolue ?

Pourquoi mesurer la puissance de sortie absolue ?

Considérations de précision

Qu'est-ce que la puissance de sortie absolue ?

Une mesure de la puissance de sortie absolue affiche la puissance présente au niveau du port d'entrée de l'analyseur. Cette puissance est absolue - elle n'est pas définie par rapport à la puissance incidente ou de source. En format d'amplitude logarithmique, les valeurs associées à l'axe vertical de la grille sont données en dBm, qui est la puissance mesurée par rapport à 1 mW.

  • 0 dBm = 1 mW

  • -10 dBm = 100 mW

  • +10 dBm = 10 mW

En format d'amplitude linéaire, les valeurs associées à l'axe verticale de la grille sont exprimées en watts (W).

Pourquoi mesurer la puissance de sortie absolue ?

La puissance de sortie absolue est mesurée lorsque la sortie de l'amplificateur doit être quantifiée par une mesure de puissance absolue plutôt que par une mesure de puissance relative. Par exemple, pendant une mesure de compression de gain, il est habituel de mesurer également la puissance de sortie absolue. Ceci montre la puissance absolue à la sortie de l'amplificateur lorsqu'une compression de 1 dB se produit.

Considérations de précision

  • La puissance de sortie de l'amplificateur doit être suffisamment atténuée, si nécessaire. Trop de puissance de sortie peut :

    • endommager le récepteur de l'analyseur

    • provoquer un dépassement du niveau de compression d'entrée du récepteur de l'analyseur, se traduisant par des mesures imprécises.

  • L'atténuation de la puissance de sortie de l'amplificateur peut être réalisée en utilisant :

    • Des atténuateurs

    • Des coupleurs

  • La réponse de l'amplificateur peut être très différente selon les températures. Les tests doivent être réalisés lorsque l'amplificateur est à la température de fonctionnement souhaitée.

Procédez comme suit pour mesurer la puissance de sortie absolue :

  1. Préréglez l'analyseur.

  2. Sélectionnez une mesure de puissance absolue (récepteur B).

  3. Réglez la puissance de la source de l'analyseur à 0 dBm.

  4. Sélectionnez un atténuateur externe (si nécessaire) pour atténuer suffisamment la puissance de sortie de l'amplificateur et éviter une compression du récepteur ou des dommages au port -2 de l'analyseur.

  5. Connectez l'amplificateur comme montré sur la figure suivante et appliquez la polarisation continue.

  6. Sélectionnez les réglages de l'analyseur pour l'amplificateur en cours de test.

  7. Retirez l'amplificateur et connectez les ports de mesure l'un à l'autre. Enregistrez les données en mémoire. Soyez certain d'inclure l'atténuateur et les câbles dans la configuration de test s'ils doivent être utilisés lors de la mesure de l'amplificateur.

  8. Enregistrez l'état de l'instrument en mémoire.

  9. Connectez de nouveau l'amplificateur.

  10. Sélectionnez la fonction mathématique Data/Memory.

  11. Réglez l'échelle de la mesure affichée pour un affichage optimal et utilisez un marqueur pour mesurer la puissance de sortie absolue à la fréquence souhaitée.

  12. Imprimez les données ou enregistrez-les sur un disque.


Hpower

Voir aussi...

Mesures de composants haute puissance

Présentation

Concepts

Schéma
fonctionnel

Configurations
standard

Opt.
015

Comment effectuer
la mesure

Vous pouvez configurer l'analyseur afin qu'il permette des mesures de composants haute puissance. Les composants haute puissance ont l'un des deux attributs suivants, ou les deux :

  • Nécessiter une puissance d'entrée plus importante que celle pouvant être fournie par l'analyseur

  • Délivrer une puissance de sortie plus importante que celle pouvant être mesurée par un analyseur standard

Par conséquent, les diverses configurations de l'analyseur sont conçues pour :

  • Augmenter l'amplification du signal de stimulus du composant en utilisant un suramplificateur.

  • Augmenter l'atténuation du signal reçu par l'analyseur afin de protéger les composants de l'analyseur d'une puissance excessive.
Concepts

Schémas fonctionnels et guide de sélection de configuration

Configurations d'analyseur standard

Option 015 Configurations d'analyseur

Comment mesurer les composants haute puissance

Cliquez sur le bouton d'une des rubriques suivantes :
En quoi les mesures haute puissance représentent-elles un défi ?

Amplificateurs de station de base haute puissance AMRC

Régulation externe du niveau

Etalonnage des mesures

Test des amplificateurs comportant des boucles CAG

Précision

En quoi les mesures haute puissance représentent-elles un défi ?

Les défis concernant l'utilisation de ces configurations comprennent :

  • Une réception en toute sécurité de signaux de haut niveau et une réception précise des signaux de bas niveau

  • Un é talonnage et des mesures précises

  • Certains types d'étalonnages sont impossibles

  • Le nombre de paramètres mesurables est limité

Par exemple, les paramètres S inverses ne peuvent pas être mesurés dans certaines configurations. Cela a pour conséquence d'empêcher certains étalonnages, limitant ainsi la précision des mesures.

Pour plus d'informations sur les mesures haute puissance en utilisant un analyseur de réseau, consultez la page web d'Agilent à l'adresse http://\www.agilent.com/find/pna. Recherchez la note d'application 1287-6, "Using a Network Analyzer to Characterize High-Power Components" (Référence 5966-3319E).

Amplificateurs de station de base haute puissance AMRC

Le niveau de signal des amplificateurs de station de base haute puissance ARMC doit être suffisamment amplifié pour pallier les pertes inhérentes à une transmission sans fil afin qu'il puisse être reçu par les mobiles. Deux exigences typiques des amplificateurs de station de base AMRC sont :

  • Puissance de sortie comprise entre 8 et 45 W (39 et 46,5 dBm)

  • Gain compris entre 30 et 40 dB

(Ces exigences peuvent différer d'un fabricant à l'autre en fonction de leur conception du système).

Le niveau de puissance de sortie élevée de l'amplificateur AMRC doit être réduit à un niveau qui puisse être traité en toute sécurité par l'analyseur. Une attention particulière doit être portée à la sélection des composants suivants afin de garantir une capacité de traitement des signaux de puissance adéquate (se reporter au graphique ci-dessous).

  • Pour les analyseurs standard, un coupleur haute puissance externe est installé à la sortie du composant sous test. Le coupleur est utilisé pour réduire la puissance de sortie du composant sous test avant qu'elle ne soit appliquée à l'analyseur. Le bras direct du coupleur est équipé d'une charge spéciale capable de dissiper la haute puissance. Le bras couplé est connecté à un atténuateur haute puissance externe fixé à l'entrée de l'analyseur.

  • Pour les analyseurs disposant de l'option 015 (ensemble de test configurable), seuls le coupleur haute puissance externe et la charge mentionnée ci-dessus sont nécessaires. L'atténuateur haute puissance externe n'est pas nécessaire parce que l'option 015 prévoit des atténuateurs par paliers (0 à 35 dB) internes pour protéger les récepteurs.

Remarque : afin de garantir un fonctionnement en toute sécurité de l'analyseur de réseau, la puissance d'entrée maximum au niveau du port de test ne doit pas dépasser +30 dBm (1 Watt).

Les considérations thermiques pendant la mesure devront également être prises en compte afin de garantir la précision des mesures. Par exemple, lors du test d'amplificateurs de station de base AMRC, la charge utilisée au niveau du coupleur de sortie doit :

  • Etre capable d'absorber la puissance délivrée par l'amplificateur sous test. La plupart des charges conçues pour des petits signaux ne peuvent dissiper qu'une puissance d'environ 1 Watt. Au-delà de cette valeur, des charges spéciales pouvant dissiper plus de puissance doivent être utilisées.

  • Pouvoir stabiliser sa température si ses caractéristiques d'impédance évoluent de manière importante avec la température

Régulation externe du niveau

Une régulation externe du niveau peut être utilisée pour compenser les performances non linéaires d'un suramplificateur afin d'augmenter la précision de la mesure. Dans les configurations de mesures avec régulation externe du niveau, le suramplificateur est suivi d'un coupleur dont le bras couplé dirige le signal de référence vers un diviseur de puissance. A partir du diviseur de puissance, le signal de référence est acheminé vers deux endroits :

  • Le récepteur de référence interne de l'analyseur.

  • L'entrée de détecteur externe de face arrière de l'analyseur, par l'intermédiaire des circuits de régulation externe du niveau.

Référez-vous au graphique ci-dessous des circuits de régulation externe du niveau (fournis par l'utilisateur) pour le test suivant :

  • Les circuits de régulation externe du niveau consistent principalement en

    • Une diode de détection

    • Un amplificateur opérationnel

  • Les variations de puissance mesurées par la diode sont détectées par le circuit de l'amplificateur opérationnel. Ce circuit régule la tension à la sortie du détecteur externe, en réduisant la puissance de la source afin d'obtenir une réponse plate au niveau du CST sur une base de temps réel.

  • Pour un fonctionnement correct de la régulation externe du niveau, il est nécessaire que la tension au niveau de l'entrée du détecteur externe soit entre - 0,002 mVcc et - 6 Vcc, selon la fréquence et le niveau de puissance.

  • La fonction de régulation externe du niveau peut devenir inefficace si les variations de puissance du signal de référence, par l'intermédiaire des atténuateurs à paliers internes, sont trop importantes.

Remarque : au cours d'un étalonnage, maintenez la fonction régulation de niveau de la source active, dans les mêmes conditions que celles de la mesure.

Les graphiques ci-dessous présentent deux configurations de mesure haute puissance avec une régulation externe du niveau. Le premier exemple de configuration concerne un analyseur standard avec une puissance importante dans le sens direct uniquement. Le second exemple de configuration concerne un analyseur équipé de l'option 015 (ensemble de test configurable) avec une puissance importante dans les sens direct et inverse.

Dans une configuration de mesure haute puissance, les performances du suramplificateur influencent la précision de mesure du CST. Comme montré sur le graphique suivant, une ondulation au niveau du suramplificateur se traduit par une ondulation au niveau de la réponse du CST.

Parmi les causes d'ondulation du suramplificateur, on trouve :

  • Un suramplificateur de qualité médiocre.

  • Une tension d'alimentation comportant trop de bruit.

  • Un suramplificateur saturé.

Etalonnage des mesures

L'étalonnage de l'analyseur élimine les erreurs systématiques et permet des mesures plus précises. Ce didacticiel a présenté les étalonnages possibles dans les diverses configurations. Les deux types d'étalonnages suivants ont été présentés :

  • Etalonnage sur deux ports : le plus précis parce qu'il supprime toutes les erreurs systématiques dues au montage de mesure, idéal lorsque le CST est connecté à l'analyseur.

  • Etalonnage de la liaison directe : moins précis, élimine uniquement les erreurs de poursuite de fréquence. Les erreurs de poursuite de fréquence concernent les différences existant entre les réponses en fréquence des différentes voies.

Remarque : tout le matériel doit être monté avant d'effectuer un étalonnage. Par exemple, montez tous les suramplificateurs, câbles, atténuateurs ou coupleurs utilisés au cours de la mesure du CST.

Les rubriques suivantes présentent les techniques et les considérations permettant d'obtenir les meilleurs résultats d'étalonnage.

Précision dynamique

En examinant la précision de la réponse dynamique de l'analyseur, vous pouvez optimiser les niveaux de puissance d'étalonnage et de mesure. La précision dynamique concerne les incertitudes liées à l'utilisation de niveaux de signaux différents dans le cas d'un étalonnage et d'une mesure. Les incertitudes sont extrêmement faibles si la puissance du récepteur se trouve entre -10 et -60 dBm indépendamment du niveau de puissance d'étalonnage. Exécutez l'étalonnage et les mesures de sorte que le niveau de signal au niveau du récepteur soit dans cette plage de précision élevée. Aux niveaux de signaux inférieurs, le bruit est un facteur important ; aux niveaux supérieurs, la compression du récepteur est un facteur important.

Niveaux de puissance d'étalonnage

Lors d'une mesure d'un amplificateur, si le niveau de puissance de sortie est supérieur au niveau de puissance d'entrée, à quelle puissance devez-vous effectuer l'étalonnage ? En général, faites l'étalonnage à la puissance la plus élevée possible au-dessous du niveau de début de compression du récepteur afin de réduire le bruit.

Etalonnage à un seul niveau de puissance ou à deux niveaux de puissance

Etalonnage à un seul niveau de puissance :

  • L'étalonnage d'une réponse peut être effectué à un seul niveau de puissance étant donné qu'un seul balayage avant est effectué.

  • Un étalonnage sur deux ports peut également être effectué à un seul niveau de puissance. Le niveau de puissance utilisé peut être déterminé à partir de la caractéristique de précision dynamique (-10 et -60 dBm).

Etalonnage à deux niveaux de puissance :

  • Un étalonnage sur deux ports peut être effectué à différents niveaux de puissance étant donné que des balayages avant et arrière sont effectués.

  • L'étalonnage peut être effectué sur un port en utilisant un premier niveau de puissance et sur l'autre port en utilisant un autre niveau de puissance pour qu'ils correspondent plus précisément aux niveaux de puissance présents au moment de la mesure du CST.

Utilisation d'étalons en haute puissance

Le choix d'un étalon qui corresponde au niveau de puissance utilisé est un des problèmes des étalonnages à des niveaux de puissance élevés :

  • La charge dissipe l'énergie. Par conséquent, assurez-vous que la charge peut supporter le niveau de puissance.

  • Le circuit ouvert, le court-circuit et la liaison directe étalon ne sont pas un problème étant donné qu'ils ne dissipent aucune puissance.

ATTENTION : si vous utilisez un circuit ouvert ou un court-circuit au cours d'un étalonnage , assurez-vous que le niveau de puissance incident est suffisamment faible pour que le signal réfléchi ne dépasse pas le niveau maximum à l'entrée du composant sous test (+30 dBm).

Test des amplificateurs comportant des boucles CAG

Certains amplificateurs contiennent une boucle CAG (commande automatique de gain). Les boucles CAG tentent de maintenir la puissance à la sortie de l'amplificateur constante en ajustant le gain de sorte qu'il prenne en compte les variations à l'entrée de l'amplificateur. Les amplificateurs comportant des boucles CAG posent des problèmes lors d'une mesure avec l'analyseur, particulièrement à des niveaux de puissance élevés.

L'arrêt de la puissance de la source de l'amplificateur est un problème dans le cas des amplificateurs contenant une boucle CAG. L'analyseur maintient la puissance constante pendant le balayage ou le retour de balayage si une seule bande de fréquences est utilisée. Cependant, l'analyseur coupe la puissance de source lorsque les bandes de fréquences sont commutées au cours du balayage ou du retour de balayage. Ces croisements de bandes surviennent aux fréquences suivantes :

  • 10 MHz

  • 750 MHz

  • 1500 MHz

  • 3000 MHz

  • 4500 MHz

  • 6500 MHz

La boucle CAG de l'amplificateur tente de compenser la coupure de la puissance de source de l'analyseur en augmentant le gain afin de conserver le niveau de puissance de sortie constant. Lorsque la coupure de puissance cesse et que le balayage reprend, l'analyseur rétablit le signal et la puissance à l'entrée de l'amplificateur qui a augmenté son gain. Si la réponse de la boucle CAG n'est pas suffisamment rapide, une puissance de sortie momentanément élevée peut endommager ou détruire :

  • L'amplificateur.

  • Le récepteur de l'analyseur.

Soyez conscient des possibilités d'endommagement ou de destruction liées à la coupure de la puissance lors du balayage ou du retour de balayage de l'analyseur à travers des bandes de fréquences multiples.

Précision

  • La réponse du composant haute puissance sous test peut être très différente selon les températures. Les tests doivent être réalisés lorsque le composant est à la température souhaitée.

  • L'i ncertitude de mesure et la flexibilité sont améliorées si la mesure du signal incident est effectuée après le suramplificateur plutôt qu'avant. La mesure du signal incident après le suramplificateur minimise les effets des adaptations de source.

  • Afin de protéger le récepteur de l'analyseur d'une puissance d'entrée trop importante, suivez les étapes suivantes pour ajouter un atténuateur externe ou un coupleur.

    • Déterminez la puissance maximum du signal à l'entrée du récepteur.

    • Soustrayez le niveau de puissance nécessaire au niveau du récepteur.

    • Choisissez la valeur d'atténuation ou le coupleur approprié (ou les deux) afin que le niveau de puissance souhaité soit appliqué à l'entrée du récepteur.

  • La réduction de la bande passante FI ou l'utilisation du moyennage améliore la pr&eacut e;cision de la mesure aux dépens de sa vitesse.

Schéma fonctionnel de l'analyseur standard

Schéma fonctionnel de l'analyseur comportant l'option 015

Guide de sélection de configuration

Schéma fonctionnel de l'analyseur standard

Analyseur comportant l'option 015 de dispositif de test configurable

Avec l'option 015 (dispositif de test configurable) l'analyseur dispose de deux caractéristiques qui permettent la mesure de niveaux de puissance supérieurs à ceux de l'analyseur standard :

  • Des atténuateurs à paliers (0-35 dB) entre les coupleurs et les récepteurs des ports 1 et 2. Ces atténuateurs à paliers ajustent le signal à un niveau de puissance optimal pour le récepteur. Voir Atténuation de la source.

  • Un accès direct (par les voies SOURCE OUT et COUPLER IN) au trajet du stimulus RF au niveau des ports 1 et 2. Cela permet :

    • La mise en place d'un suramplificateur de sorte que l'i solement inverse ne d&eacu te;grade pas la précision de la mesure

    • L'ajout d'isolateurs haute puissance afin de protéger les composants internes de l'analyseur

Guide de sélection de configuration

Les configurations suivantes de ce didacticiel sont classées par précisions et capacités :
Configuration 1 (Analyseur standard) : Haute puissance (unidirectionnel), pas de suramplificateur, avec étalonnage sur deux ports

Configuration 2 (Analyseur standard) : Haute puissance (unidirectionnel) avec étalonnage de la réponse

Configuration 3 (Analyseur standard) : Haute puissance (unidirectionnel) avec étalonnage sur deux ports

Configuration 4 (Analyseur avec option 015) : Haute puissance (unidirectionnel) avec étalonnage de la réponse

Configuration 5 (Analyseur avec option 015) : Haute puissance (unidirectionnel) avec étalonnage sur deux ports

Configuration 6 (Analyseur avec option 015) : Haute puissance (bidirectionnel) avec étalonnage sur deux ports

Afin de sélectionner la configuration d'analyseur de réseau correcte, vous devez prendre en considération :

  • Le composant sous test

  • Les mesures nécessaires

  • La précision nécessaire

Les outils suivants apportent une aide dans le choix de la configuration d'analyseur la plus adaptée à votre application de mesure.

  • Schémas fonctionnels des configurations de test haute puissance

  • Informations concernant :

    • L'équipement

    • Les choix d'étalonnage

    • Les avantages et limites de chaque configuration

  • Tableaux des caractéristiques des configurations pour les analyseurs standard et équipés de l'option 015

Analyseur standard
Mesures haute puissance |  |  |  |  | Etalonnages
Config. | Source suramplifiée | Transmission directe | Transmission directe et réflexion | Directe/ inverse | 2 ports | Liaison directe
1 |  |  |  | X | X | X
2 | X | X |  |  |  | X
3 | X |  | X |  | X | X

Option 015, ensemble de test configurable
Mesures haute puissance |  |  |  |  | Etalonnages
Config. | Source suramplifiée | Transmission directe | Transmission directe et réflexion | Directe/ inverse | 2 ports | Liaison directe
4 | X |  | X |  |  | X
5 | X |  | X |  | X | X
6 | X |  |  | X | X | X

Les configurations suivantes d'un analyseur standard montrées dans ce didacticiel sont classées par précisions et capacités :
Configuration 1 (Analyseur standard) : Haute puissance (unidirectionnel), pas de suramplificateur, avec étalonnage sur deux ports

Configuration 2 (Analyseur standard) : Haute puissance (unidirectionnel) avec étalonnage de la réponse

Configuration 3 (Analyseur standard) : Haute puissance (unidirectionnel) avec étalonnage sur deux ports

Configuration 1 (Analyseur standard) :

Attributs de cette configuration :

  • Mesures haute puissance dans un seul sens

  • Atténuation externe pour le récepteur du port 2 de l'analyseur

  • S11, S12, S21 et S22

  • Etalonnage sur deux ports

  • 1 composant externe

  • P lage dynamique réduite de la perte de puissance au niveau des coupleurs de port

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Ne nécessitent pas une puissance de commande de niveau élevé (c'est-à-dire, dans les spécifications de niveau de puissance de l'analyseur)

    • Testés généralement dans leur région linéaire

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Le CST entre le port 1 de l'analyseur et un atténuateur ou coupleur.

  • Un atténuateur ou coupleur entre le CST et le port 2 de l'analyseur. Etant donné que le CST a un gain élevé, le récepteur doit être protégé contre la puissance de sortie élevée.

Si vous utilisez un coupleur, équipez le bras direct du coupleur d'une charge correspondant à l'impédance caractéristique. Le bras couplé du coupleur envoie une petite partie du signal d'entrée au port 2. Dans le cas d'un coupleur 20 dB, le signal au niveau du bras couplé a une puissance inférieure de 20 dB à celle du signal au niveau de l'entrée.

Choix d'étalonnage

  • 2 ports

  • Réponse de liaison directe

L'atténuation au niveau du port 2 dégrade la d irectivité non corrigée du port 2 de deux fois la valeur d'atténuation. Cela limite la stabilité de l'étalonnage et peut augmenter le bruit lors des mesures de S22. Si une mesure de S22 est nécessaire :

  1. Effectuez l'étalonnage pour des mesures inverses à un niveau de puissance supérieur.

  2. Diminuez le niveau de puissance lors des mesures directes.

  3. Augmentez le niveau de puissance lors des mesures inverses.

Configuration 2 (Analyseur standard) :

Attributs de cette configuration :

  • Mesures haute puissance dans un seul sens

  • Atténuation externe pour le récepteur du port 2 de l'analyseur

  • S21 uniquement (S11 ne peut pas être mesuré du fait du suramplificateur)

  • Etalonnage de la liaison directe

  • Plage dynamique réduite de la perte de puissance dans le coupleur du port 2

  • Aucune perte de puissance de suramplificateur dans le dispositif de test

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Nécessitent un suramplificateur pour les puissances de commande de niveau élevé

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Un suramplificateur sur le port 1 de l'analyseur.

  • Un coupleur entre le suramplificateur et le CST.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R1 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

  • Le CST entre le coupleur et un atténuateur ou coupleur.

  • L'atténuateur ou le coupleur entre la sortie du CST et le port de test de l'analyseur. Etant donné que le CST a un gain élevé, le récepteur doit être protégé contre la puissance de sortie élevée.

Si vous utilisez un coupleur, équipez le bras direct du coupleur d'une charge correspondant à l'impédance caractéristique. Le bras couplé du coupleur envoie une petite partie du signal d'entrée au port 2. Dans le cas d'un coupleur 20 dB, le signal au niveau du bras couplé a une puissance inférieure de 20 dB à celle du signal au niveau de l'entrée.

Configuration 3 (Analyseur standard) :

Attributs de cette configuration :

  • Mesures haute puissance dans un seul sens

  • Atténuation externe pour le récepteur du port 2 de l'analyseur

  • S11, S21

  • Etalonnages sur deux ports et de réponse de liaison directe

  • 6 composants externes

  • P lage dynamique réduite de la perte de puissance dans le coupleur du port 2

  • Aucune perte de puissance de suramplificateur dans l'ensemble de test

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Nécessitent un suramplificateur pour les puissances de commande de niveau élevé

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Un suramplificateur sur le port 1 de l'analyseur.

  • Un coupleur à la sortie du suramplificateur.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R1 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

  • Un coupleur inverse entre le coupleur direct et le CST.

  • Le bras couplé du coupleur inverse vers la voie A IN. Ce montage permet d'effectuer des mesures de réflexion directe.

  • Le CST entre le coupleur inverse et un atténuateur ou coupleur.

  • L'atténuateur ou le coupleur entre la sortie du CST et le port de test de l'analyseur. Etant donné que le CST a un gain élevé, le récepteur doit être protégé contre la puissance de sortie élevée.

Si vous utilisez un coupleur, équipez le bras direct du coupleur d'une charge correspondant à l'impédance caractéristique. Le bras couplé du coupleur envoie une petite partie du signal d'entrée au port 2. Dans le cas d'un coupleur 20 dB, le signal au niveau du bras couplé a une puissance inférieure de 20 dB à celle du signal au niveau de l'entrée.

Les configurations suivantes de ce didacticiel sont classées par précisions et capacités :
Configuration 4 (Analyseur avec option 015) : Haute puissance (unidirectionnel) avec étalonnage de la réponse

Configuration 5 (Analyseur avec option 015) : Haute puissance (unidirectionnel) avec étalonnage sur deux ports

Configuration 6 (Analyseur avec option 015) : Haute puissance (bidirectionnel) avec étalonnage sur deux ports

Configuration 4 (Analyseur avec option 015) :

Attributs de cette configuration :

  • Mesures haute puissance dans un seul sens

  • Utilise le récepteur B de l'analyseur

  • S11, S21

  • Etalonnage de la réponse de liaison directe

  • 3 composants externes

  • La p lage dynamique est maximum avec la voie B IN

  • Plage dynamique réduite de la perte de puissance dans le coupleur du port 1

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Nécessitent un suramplificateur pour les puissances de commande de niveau élevé

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Un suramplificateur vers la voie SOURCE OUT du port 1.

  • Un coupleur entre le suramplificateur et la voie COUPLER IN du port 1.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R1 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

  • Le CST entre le port 1 de l'analyseur et la voie B IN. La plage dynamique est maximum avec la voie B IN, étant donné qu'il n'y a aucune perte de puissance dans le coupleur du port 2.

Etant donné que ces composants ont un gain élevé, le récepteur doit être protégé contre la puissance de sortie élevée. Utilisez l'atténuateur par paliers internes de l'analyseur (0-35 dB) pour protéger le récepteur B.

Configuration 5 (Analyseur avec option 015) :

Attributs de cette configuration :

  • Mesures haute puissance dans un seul sens

  • Isolateur utilisé pour protéger les composants internes de l'analyseur des puissances excessives

  • S11, S21

  • Etalonnage de réponse de liaison directe et sur deux ports

  • 4 composants externes

  • Plage dynamique réduite de la perte de puissance dans les coupleurs de port

  • L'isolateur protège le commutateur et la source

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Nécessitent un suramplificateur pour les puissances de commande de niveau élevé

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Un suramplificateur vers la voie SOURCE OUT du port 1.

  • Un coupleur entre le suramplificateur et la voie COUPLER IN du port 1.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R1 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

  • Le CST entre le port 1 et le port 2 de l'analyseur.

  • Un isolateur entre les voies SOURCE OUT et COUPLER IN du port 2.

Etant donné que ces composants ont un gain élevé, le récepteur doit être protégé contre la puissance de sortie élevée. Utilisez les atténuateurs par paliers internes de l'analyseur (0-35 dB) pour protéger le récepteur B.

Configuration 6 (Analyseur avec option 015) :

Attributs de cette configuration :

  • Mesure haute puissance dans deux sens (direct et inverse)

  • S11, S12, S21 et S22

  • Etalonnage de réponse de liaison directe et sur deux ports

  • 6 composants externes

  • P lage dynamique réduite de la perte de puissance dans les coupleurs de port

  • Pour les composants sous test comportant ces caractéristiques :

    • Gain élevé

    • Nécessitent un suramplificateur pour les puissances de commande de niveau élevé

Equipement

Effectuez les connexions montrées sur le schéma fonctionnel :

  • Un suramplificateur vers la voie SOURCE OUT du port 1.

  • Un coupleur entre le suramplificateur et la voie COUPLER IN du port 1.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R1 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

  • Le CST entre le port 1 et le port 2 de l'analyseur.

  • Un suramplificateur vers la voie SOURCE OUT du port 2.

  • Un coupleur entre le suramplificateur et la voie COUPLER IN du port 2.

  • Un atténuateur sur le bras couplé du coupleur.

  • La partie de bras couplé du signal de source suramplifié vers la voie R2 IN. Ce signal devient le signal de référence utilisé dans la proportionnalisation.

Etant donné que ces composants ont un gain élevé, les récepteurs doivent être protégés contre la puissance de sortie élevée. Utilisez les atténuateurs par paliers internes de l'analyseur (0-35 dB) pour protéger les récepteurs A et B.

Comment mesurer les composants haute puissance

  1. Sélectionnez la configuration d'analyseur qui correspond le mieux à votre CST et à vos besoins de mesure. Ne connectez pas encore le CST.

  2. Préréglez l'analyseur.

  3. Si le composant sous test est un amplificateur, il peut être nécessaire d'ajuster la puissance de la source de l'analyseur :

    • Réglez la puissance de la source de l'analyseur pour qu'elle se situe dans la région linéaire de la réponse de sortie de l'amplificateur (typiquement 10 dB au-dessous du point de compression de 1 dB).

    • Sélectionnez un atténuateur externe (si nécessaire) pour atténuer suffisamment la puissance de sortie de l'amplificateur et éviter une compression du récepteur ou des dommages au port 2 de l'analyseur.

  4. Sélectionnez la mesure souhaitée.

  5. Connectez le CST.

  6. Sélectionnez les paramètres pour le CST.

  7. Retirez le CST et effectuez un étalonnage de la mesure. Assurez-vous que tous les suramplificateurs, câbles, atténuateurs ou coupleurs utilisés au cours de la mesure du CST sont montés.

  8. Enregistrez l'état de l'instrument en mémoire.

  9. Reconnectez le CST.

  10. Réglez l'échelle afin d'optimiser l'affichage des mesures et utilisez les marqueurs pour lire les résultats.

  11. Imprimez les données ou enregistrez-les sur un disque.


AM-PM

Voir aussi...

Conversion AM-PM

Présentation

Concepts

Comment mesurer
la conversion AM-PM

La conversion AM-PM d'un amplificateur est une mesure de l'ampleur de la variation de phase (PM) indésirable provoquée par les variations d'amplitude (AM) inhérentes au système.

Concepts

Comment mesurer la conversion AM-PM

Cliquez sur un bouton pour en savoir plus sur l'un des sujets suivants :
Qu'est-ce que la conversion AM-PM ?

Pourquoi mesurer la conversion AM-PM ?

Précision

Qu'est-ce que la conversion AM-PM ?

La conversion AM-PM est une mesure de l'ampleur de la variation de phase (PM) indésirable provoquée par les variations d'amplitude (AM) du système. Par exemple, dans un système de télécommunications, la variation de phase (PM) indésirable peut avoir l'une des origines suivantes :

  • Variations d'amplitude (AM) non intentionnelles

    • Ondulation de la tension d'alimentation

    • Dérive thermique

    • Affaiblissement dû à la transmission sous plusieurs trajets

  • Modulation intentionnelle de l'amplitude du signal

    • QAM

    • Modulation par salves

La conversion AM-PM est généralement définie comme la variation de phase en sortie pour un incrément de 1 dB du balayage en puissance du signal appliqué en entrée de l'amplificateur (c'est-à-dire au point de compression de 1 dB du gain). Elle est exprimée en degrés par dB (°/dB). Dans un amplificateur idéal, il n'y a pas d'interaction entre la réponse en phase et le niveau de puissance du signal d'entrée.

Pourquoi mesurer la conversion AM-PM ?

La conversion AM-PM est un paramètre critique pour tout système dans lequel la modulation de phase (angulaire) est utilisée. Par exemple :

  • FM

  • QPSK

  • 16QAM

Il s'agit d'un paramètre critique dans la mesure où toute variation de phase (PM) indésirable entraîne une dégradation des signaux analogiques ou une augmentation du taux d'erreurs sur les bits (BER) dans les systèmes de communication numériques. Il est facile de mesurer le BER d'un système de communication numérique, mais cette mesure à elle seule ne permet pas d'identifier la cause sous-jacente des erreurs. Comme la conversion AM-PM est l'une des premières causes d'erreurs sur les bits, il est important de la quantifier dans les systèmes de communication.

Référez-vous au diagramme I/Q suivant, qui illustre comment la conversion AM-PM peut provoquer des erreurs sur les bits.

  • Le changement d'état souhaitable est le passage du petit vecteur en trait plein au grand vecteur en trait plein.

  • Avec la conversion AM-PM, le changement d'état peut en réalité aboutir au grand vecteur en pointillé. Ceci en raison du décalage de phase qui résulte d'un changement du niveau de la puissance d'entrée.

  • Dans le cas du signal 64QAM illustré (un seul quadrant est représenté), on constate que les cercles de bruit qui entourent chaque état se chevauchent, ce qui signifie que, statistiquement, des erreurs sur les bits sont susceptibles de se produire.

Précision

Avec cette méthode de mesure de la conversion AM-PM, la fréquence de modulation est approximativement l'inverse du temps de balayage. Même avec la plus rapide des vitesses de balayage en puissance disponibles sur la plupart des analyseurs de réseau, la fréquence de modulation reste relativement basse (généralement moins de 10 Hz). Cela peut entraîner une légère fluctuation de la température au rythme du balayage, en particulier si l'amplificateur présente une faible inertie thermique, cas typique d'un composant à l'air libre. Les résultats obtenus avec cette méthode peuvent varier légèrement si le comportement de non-linéarité de l'amplificateur est extrêmement sensible aux changements thermiques. (Les analyseurs de la série PNA peuvent produire des balayages en puissance en moins de 1 ms.)

  • L'amplificateur peut répondre très différemment en fonction de la température. Les tests doivent être exécutés lorsque l'amplificateur est à la température de fonctionnement souhaitée.

  • Au besoin, la puissance de sortie de l'amplificateur doit être atténuée dans des proportions suffisantes. Une trop grande puissance de sortie peut :

    • endommager le récepteur de l'analyseur ;

    • dépasser le niveau de compression en entrée du récepteur de l'analyseur et conduire à des mesures inexactes.

  • L'a tténuation de la puissance de sortie de l'amplificateur peut être réalisée au moyen :

    • d'atténuateurs,

    • de coupleurs.

  • Il doit être tenu compte de la réponse en fréquence des atténuateurs et des coupleurs lors de l'étalonnage, car ces composants font partie du système de test. Des techniques de correction d'erreurs appropriées peuvent réduire ou compenser les défauts de linéarité de tels composants.

  • La réponse en fréquence est la principale source d'erreur dans une configuration de mesure de la conversion AM-PM. Cette erreur peut être réduite de manière significative par un étalonnage du chemin électrique direct. Pour une plus grande précision, effectuez un étalonnage sur deux ports.

  1. Préréglez l'analyseur (touche Preset).

  2. Sélectionnez une mesure de paramètre S21 en mode de balayage en puissance.

  3. Entrez les niveaux de puissance de départ et d'arrêt du balayage. Le niveau de départ doit se situer dans la région linéaire de la réponse de l'amplificateur (généralement 10 dB en dessous du point de compression de 1 dB du gain). Le niveau d'arrêt doit se situer dans la région de compression du gain de l'amplificateur.

  4. Si vous devez utiliser un atténuateur externe, choisissez une atténuation suffisante pour éviter de dépasser le niveau de compression du récepteur ou d'endommager le port 2 de l'analyseur.

  5. Connectez l'amplificateur en vous conformant à la figure ci-après et fournissez la tension de polarisation continue.

  6. Réglez l'analyseur de manière à exécuter une mesure de compression du gain en mode puissance balayée à une fréquence choisie. Voir Compression du gain.

  7. Retirez l'amplificateur et procédez à un étalonnage de mesure. Veillez à inclure l'atténuateur et les câbles dans votre montage d'étalonnage s'ils doivent être utilisés pour la mesure de l'amplificateur.

  8. Enregistrez l'état de l'instrument en mémoire.

  9. Reconnectez l'amplificateur.

  10. Utilisez un marqueur de référence pour identifier la puissance d'entrée de l'amplificateur au point de compression de 1 dB du gain. Sélectionnez un deuxième marqueur et réglez sa valeur de stimulus de manière à situer sa réponse à 1 dB en dessous du marqueur de référence.

  11. Pour la mesure du paramètre S21, faites passer l'échelle verticale du format amplitude logarithmique au format phase (vous n'avez pas besoin de procéder à un nouvel étalonnage).

  12. Identifiez le changement de phase entre les deux marqueurs. La valeur mesurée est le coefficient de conversion AM-PM au point de compression de 1 dB du gain.

  13. Imprimez les données ou enregistrez-les sur un disque ou une disquette.


Gain Comp

Voir aussi...

Compression du gain

Présentation

Concepts

Comment mesurer

la compression du gain

La compression du gain caractérise le niveau de puissance d'entrée appliqué à un amplificateur à partir duquel le signal de sortie est distordu. Trois mesures sont utilisées pour déterminer la compression du gain d'un amplificateur :

1) Un mesure balayée en fréquence localise le premier point de fréquence auquel se produit une compression du gain de 1 dB.

2) Une mesure balayée en puissance met en évidence le niveau de puissance d'entrée qui se traduit par une chute de 1 dB du gain lorsque l'on applique une rampe de puissance à une fréquence particulière (déterminée par la mesure 1).

3) Une mesure de puissance absolue permet de déterminer la puissance de sortie absolue (en dBm) dans la région de compression de l'amplificateur.

Concepts

Comment mesurer la compression du gain

Cliquez sur un bouton pour en savoir plus sur l'un des sujets suivants :
Qu'est-ce que la compression du gain ?

Pourquoi mesurer la compression du gain ?

Précision

Qu'est-ce que la compression du gain ?

La compression du gain se produit lorsque l'on augmente la puissance d'entrée d'un amplificateur à un niveau tel que le gain commence à chuter, si bien que la puissance de sortie n'augmente plus linéairement.

L'analyseur permet d'exécuter des balayages en puissance ainsi que des balayages en fréquence. Les balayages en puissance aident à caractériser la non-linéarité d'un amplificateur. Référez-vous à la figure ci-dessous, qui montre la courbe de puissance de sortie d'un amplificateur en fonction de la puissance d'entrée à une fréquence déterminée.

  • Le gain de l'amplificateur en un point particulier est la pente de la courbe en ce point.

  • L'amplificateur possède une région de fonctionnement linéaire, dans laquelle le gain est constant et indépendant du niveau de puissance. Le gain dans cette région est couramment appelé "gain dans le domaine des petits signaux".

  • Passé un certain niveau de puissance d'entrée, le gain semble décroître et l'amplificateur entre alors dans une région de compression.

  • La mesure de compression la plus courante pour un amplificateur est le point de compression de 1 dB. Elle se définit comme la puissance d'entrée (ou parfois la puissance de sortie) à laquelle on observe une chute de 1 dB du gain de l'amplificateur (par rapport au gain constant qu'il produit dans le domaine des petits signaux).

Pourquoi mesurer la compression du gain ?

  • Si l'on applique une sinusoïde à l'entrée de l'amplificateur, la forme du signal en sortie n'est plus sinusoïdale dans la région de compression. Le signal de sortie est restitué en partie sous forme d'harmoniques au lieu d'être constitué uniquement de la fréquence fondamentale du signal d'entrée.

  • Si on augmente encore plus la puissance d'entrée, l'amplificateur sature et la puissance délivrée en sortie reste constante. A ce stade, toute augmentation supplémentaire de la puissance d'entrée n'a plus aucun effet sur la puissance de sortie.

  • Dans certains cas, tels que celui des amplificateurs TWT (tube à ondes progressives), la puissance de sortie chute alors que l'on continue à augmenter la puissance d'entrée une fois passé le point de saturation, ce qui signifie que l'amplificateur possède un gain négatif.

  • Comme le gain est le principal objectif de tout amplificateur, il est important de connaître le niveau de puissance d'entrée au-delà duquel la compression du gain se produit.

Précision

L'analyseur de réseau doit délivrer une puissance suffisante pour saturer l'amplificateur. Si vous avez besoin d'un niveau de puissance plus élevé que ne peut fournir la source de l'analyseur, placez un préamplificateur en amont de l'amplificateur à tester. (Voir Mesure de composants haute puissance.) Si vous utilisez un préamplificateur, vous pouvez augmenter la précision de mesure en procédant comme suit :

  • Utilisez un coupleur à la sortie du préamplificateur de manière à dériver une partie du signal préamplifié vers la voie de référence de l'analyseur. Cette configuration permet de soustraire de la mesure les erreurs de réponse en fréquence et de dérive du préamplificateur (par proportionnalisation).

  • Exécutez un étalonnage du circuit électrique direct en incluant les préamplificateurs, les coupleurs et les atténuateurs dans le montage de test.

Au besoin, la puissance de sortie de l'amplificateur doit être atténuée dans des proportions suffisantes. Une trop grande puissance de sortie peut :

  • endommager le récepteur de l'analyseur ;

  • dépasser le niveau de compression en entrée du récepteur de l'analyseur.

L'a tténuation de la puissance de sortie de l'amplificateur peut être réalisée au moyen :

  • d'atténuateurs,

  • de coupleurs.

Il doit être tenu compte de la réponse en fréquence des atténuateurs et des coupleurs lors de l'étalonnage, car ces composants font partie du système de test. Des techniques de correction d'erreurs appropriées peuvent réduire ou compenser les défauts de linéarité de tels composants.

  • La réponse en fréquence est la principale source d'erreur dans une configuration de mesure de la compression du gain. Cette erreur peut être réduite de manière significative par un étalonnage du chemin électrique direct.

  • L'amplificateur peut répondre très différemment en fonction de la température. Les tests doivent être exécutés lorsque l'amplificateur est à la température d'utilisation souhaitée.

  • La réduction de la largeur de bande de la FI ou le moyennage des mesures améliore la précision, même si cela se fait au détriment de la vitesse de mesure.

Cette procédure montre comment exécuter les trois mesures permettant de déterminer la compression du gain d'un amplificateur :

Mesure de compression du gain avec balayage en fréquence

Mesure de compression du gain avec balayage en puissance

Mesure de puissance absolue

Mesure de compression du gain avec balayage en fréquence

Cette mesure vise à localiser le point de fréquence où la compression de 1 dB du gain se produit en premier.

  1. Préréglez l'analyseur (touche Preset).

  2. Sélectionnez une mesure de paramètre S21.

  3. Réglez la puissance de la source de l'analyseur de manière à la situer dans la région de fonctionnement linéaire de l'amplificateur (généralement 10 dB en dessous du point de compression de 1 dB du gain).

  4. Si vous devez utiliser un atténuateur externe, choisissez une atténuation suffisante pour éviter de dépasser le niveau de compression du récepteur ou d'endommager le port 2 de l'analyseur.

  5. Connectez l'amplificateur en vous conformant à la figure ci-dessous et fournissez la tension de polarisation continue.

  6. Réglez l'analyseur en choisissant des valeurs adaptées à votre amplificateur. Pour réduire les effets du bruit, il peut être utile de réduire la largeur de bande de la FI.

  7. Retirez l'amplificateur et procédez à un étalonnage du chemin électrique direct. Veillez à inclure l'atténuateur et les câbles dans votre montage d'étalonnage s'ils doivent être utilisés pour la mesure de l'amplificateur.

  8. Enregistrez l'état de l'instrument en mémoire.

  9. Reconnectez l'amplificateur.

  10. Positionnez un marqueur à mi-chemin de la bande d'analyse.

  11. Réglez l'échelle verticale de l'analyseur à 1 dB par division.

  12. Enregistrez la trace en mémoire, puis sélectionnez la fonction mathématique Data/Memory.

  13. Augmentez graduellement la puissance de la source jusqu'à observer une réduction du gain de 1 dB vers le début de la trace.

  14. Utilisez des marqueurs pour localiser la fréquence à laquelle cette chute du gain de 1 dB se produit en premier. Notez cette fréquence, car vous en aurez besoin dans la mesure suivante.

  15. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

Mesure de compression du gain avec balayage en puissance

Une mesure balayée en puissance met en évidence le niveau de puissance d'entrée qui se traduit par une chute de 1 dB du gain lorsque l'on applique une rampe de puissance à une fréquence particulière (déterminée à l'étape 13 de la mesure précédente).

  1. Si ce n'est déjà fait, exécutez la mesure précédente (balayage en fréquence).

  2. Configurez une mesure de paramètre S21 en mode de balayage en puissance. Les réglages à adopter sont les suivants :

    • Réglez la fréquence de l'onde entretenue (CW) à la valeur déterminée à l'étape 13 de la précédente mesure (balayage en fréquence).

    • Entrez les niveaux de puissance de départ et d'arrêt du balayage. Le niveau de départ doit se situer dans la région linéaire de la réponse de l'amplificateur (généralement 10 dB en dessous du point de compression de 1 dB du gain). Le niveau d'arrêt doit se situer dans la région de compression du gain de l'amplificateur.

  3. Réglez l'échelle verticale de l'analyseur à 1 dB par division.

  4. Utilisez des marqueurs (l'un d'eux étant le marqueur de référence) pour identifier le niveau de puissance d'entrée conduisant à une chute de 1 dB du gain.

  5. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

Mesure de la puissance de sortie absolue

  1. Cette mesure vise à déterminer la puissance de sortie absolue (en dBm) de l'amplificateur lorsqu'il fonctionne dans sa région de compression.

    • Sélectionnez une mesure de puissance absolue (Unratioed Power). Choisissez l'entrée B si vous utilisez le montage de test illustré précédemment. Les réglages à adopter sont les suivants :

    • Conservez la fréquence d'onde entretenue (CW) utilisée dans la précédente mesure avec balayage en puissance.

  2. Placez un marqueur sur le niveau de puissance d'entrée conduisant à une chute du gain de 1 dB (déterminé à l'étape 4 de la précédente mesure).

  3. Réglez l'échelle pour une visualisation optimale de la mesure affichée.

  4. Lisez la valeur du marqueur pour déterminer la puissance de sortie absolue (en dBm) de l'amplificateur à l'endroit où le gain chute de 1 dB.

  5. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

Remarque : l'étalonnage de mesure ne s'applique pas à la mesure de puissances absolues. Par conséquent, si votre montage comprend une atténuation extérieure à l'analyseur, vous devez en tenir compte dans l'interprétation du résultat de la mesure.


Phase Devi

Voir aussi...

Ecart par rapport à une phase linéaire

Présentation

Concepts

Comment effectuer la mesure

L'écart par rapport à une phase linéaire est une mesure de la distorsion de phase. La caractéristique de retard électrique de l'analyseur est utilisée pour retirer de la mesure la partie linéaire du déphasage. Cela permet un affichage à haute résolution d'une partie non linéaire du déphasage (écart par rapport à une phase linéaire).
Concepts

Comment effectuer une mesure de l'écart par rapport à une phase linéaire

Cliquez sur le bouton d'une des rubriques suivantes :
Qu'est-ce qu'un déphasage linéaire ?

Qu'est-ce qu'un écart par rapport à un déphasage linéaire ?

Pourquoi mesurer l'écart par rapport à un déphasage linéaire ?

Utilisation du retard électrique

Considérations de précision

Qu'est-ce qu'un déphasage linéaire ?

Le d éphasage est dû au fait que les longueurs d'onde qui occupent la longueur électrique du composant deviennent de plus en plus courte alors que la fréquence du s ignal incident augmente. Un déphasage linéaire a lieu lorsque la réponse en phase d'un composant est linéairement proportionnelle à la fréquence. Sur l'écran de l'analyseur, la trace de la mesure de la phase en fonction de la fréquence de ce déphasage linéaire idéal est une droite. La pente est proportionelle à la longueur électrique du composant. Une transmission des signaux sans distorsion nécessite un déphasage linéaire (ainsi qu'une réponse en amplitude plate).

Qu'est-ce qu'un écart par rapport à un déphasage linéaire ?

Dans la réalité, de nombreux composants électriques ou électroniques retardent certaines fréquences plus que d'autres, créant ainsi un déphasage non linéaire (distorsion des signaux constitués de composantes à fréquences multiples). La mesure de l'é cart par rapport à une p hase l inéaire est une manière de quantifier ce déphasage non linéaire.

L'écart par rapport à une phase linéaire étant la seule cause de la distorsion de phase, il est souhaitable de retirer de la mesure la partie linéaire de la réponse en phase. Cela peut être réalisé en utilisant la fonction retard électrique de l'analyseur pour annuler mathématiquement la longueur électrique du composant en cours de test. Seul l'écart par rapport à une phase linéaire subsiste, c'est-à-dire la distorsion de phase.

Pourquoi mesurer l'écart par rapport à un déphasage linéaire ?

La mesure de l'écart par rapport à une phase linéaire permet d'obtenir :

  • des données en unités de phase plutôt qu'en unité de secondes (temps de propagation de groupe). Pour les composants qui transmettent des signaux modulés, les unités de phase peuvent être plus pratiques.

  • des mesures avec moins de bruit que les mesures de temps de propagation de groupe.

Utilisation du retard électrique

La fonction retard électrique est la version électronique de "l'extenseur de ligne à longueur variable" des analyseurs précédents. Cette fonction permet :

  • la simulation d'une ligne de transmission sans perte de longueur variable, qui est ajoutée ou retirée réellement du circuit du signal de référence.

  • la compensation de la longueur électrique du composant en cours de test.

  • l'obtention d'une trace de mesure plus plate sur l'écran de l'analyseur. Cela permet un affichage à haute résolution de la trace afin de visualiser les détails de la non-linéarité de la phase.

  • la mise en oeuvre d'une méthode pratique pour visualiser l'écart par rapport à une phase linéaire du composant en cours de test. Voir le graphique suivant.

Considérations de précision

La réponse en fréquence de la configuration de test est l'erreur principale d'une mesure d'écart par rapport à une phase linéaire. En effectuant un étalonnage de la mesure avec une vraie réponse, vous réduirez de manière importante cette erreur. Pour une meilleure précision, effectuez un étalonnage de mesure à deux ports.

Comment effectuer une mesure de l'écart par rapport à une phase linéaire :

  1. Préréglage de l'analyseur.

  2. Si le composant en cours de test est un amplificateur, il peut être nécessaire d'ajuster la puissance de la source de l'analyseur :

    • Réglez la puissance de la source de l'analyseur pour qu'elle se situe dans la région linéaire de la réponse de sortie de l'amplificateur (typiquement 10 dB au-dessous du point de compression de 1 dB).

    • Sélectionnez un atténuateur externe (si nécesaire) pour atténuer suffisamment la puissance de sortie de l'amplificateur et éviter une compression du récepteur ou des dommages au port 2 de l'analyseur.

  3. Connectez le composant en cours de test comme montré sur le graphique suivant.

  3. Sélectionnez la mesure de S21.

  4. Fixez les paramètres de votre composant en cours de test comme suit :

    • Format : phase

    • Echelle : a utoscale

  5. Retirez le composant et effectuez un étalonnage.

  6. Connectez de nouveau le composant.

  7. Réglez l'échelle des mesures affichées pour une visualisation optimale.

  8. Activez la fonction retard électrique pour aplatir automatiquement la trace de phase. Si vous le souhaitez, réglez manuellement le retard électrique pour ajuster la trace de phase pour qu'elle présente un aspect plat.

  9. Utilisez les marqueurs pour mesurer l'é cart par rapport à une p hase l inéaire crête-à-crête maximal.

  10. Imprimez les données ou enregistrez-les sur un disque.


Rev Isol

Voir aussi...

Isolement inversé

Présentation

Concepts

Comment mesurer
l'isolement inversé

L'i solement inversé est une mesure de la réponse de la transmission inversée de l'amplificateur, de la sortie vers l'entrée.
Concepts

Comment mesurer l'isolement inversé

Cliquez sur un bouton pour en savoir plus sur les points suivants :
Qu'est-ce que l'isolement inversé ?

Pourquoi mesurer l'isolement inversé ?

Considérations relatives à la précision

Qu'est-ce que l'isolement inversé ?

L'isolement inversé mesure à quel point un signal appliqué à la sortie du composant est "isolé" de son entrée.

La mesure de l'isolement inversé est similaire à celle du gain direct, à ceci près que :

  • Le signal du stimulus est appliqué au port de sortie de l'amplificateur.

  • La réponse est mesurée au port d'entrée de l'amplificateur.

Le paramètre S équivalent est S12.

Pourquoi mesurer l'isolement inversé ?

Un amplificateur idéal aurait un isolement inversé infini. Aucun signal ne serait transmis de la sortie vers l'entrée. Cependant, des signaux réfléchis peuvent traverser l'amplificateur dans le sens inverse. Cette transmission inversée indésirable peut générer des interférences entre les signaux réfléchis et le signal fondamental désiré émis dans le sens direct. Aussi, il est important de quantifier l'isolement inversé.

Considérations relatives à la précision

Comme les amplificateurs présentent souvent des pertes élevées dans le sens inverse, il est généralement superflu d'appliquer l'atténuation qui aurait pu être utilisée pour protéger le récepteur du port 2 durant les mesures de transmission vers l'avant. La suppression de l'atténuation :

  • Augmente la p lage dynamique, ce qui améliore la précision de la mesure.

  • Nécessite un nouvel étalonnage pour une précision maximale.

Il est possible d'augmenter la puissance de la source RF afin d'améliorer la plage dynamique et la précision.

Remarque : lorsque l'atténuation est supprimée et que la puissance de la source RF est augmentée, un balayage vers l'avant risque d'endommager le récepteur du port 2 de l'analyseur. N'exécutez pas de balayage vers l'avant ni d'étalonnage sur 2 ports à moins que la puissance directe ait été suffisamment abaissée pour éviter de compresser ou d'endommager le récepteur du port 2.

Si l'isolement de l'amplificateur sous test est très important, le niveau du signal transmis peut être proche du seuil de bruit ou du niveau de diaphonie du récepteur. Pour abaisser le seuil de bruit :

  • Utilisez ou augmentez les moyennes de mesure.

  • Réduisez la bande passante FI de l'analyseur.

Remarque : la réduction de la bande passante FI ou l'utilisation du moyennage améliore la plage dynamique et la précision de la mesure, mais réduit la vitesse de la mesure.

  • Si les niveaux de diaphonie affectent la précision de la mesure, réduisez le terme d'erreur de la diaphonie en effectuant un étalonnage de réponse et d'isolement. Lorsque vous réalisez la partie isolement de l'étalonnage, il est important d'utiliser le même facteur de moyennage et la même bande passante FI durant l'étalonnage et la mesure.

  • La réponse en fréquence de la configuration du test constitue la principale erreur d'une mesure d'isolement inversé. L'exécution d'un étalonnage de mesure de réponse directe réduit significativement cette erreur. Cet étalonnage peut être réalisé dans le cadre de l'étalonnage de réponse et d'isolement.

  • Les réponses de l'amplificateur peuvent considérablement varier à différentes températures. Il est recommandé de réaliser les tests lorsque l'amplificateur se trouve à la température de fonctionnement désirée.

  1. Connectez l'amplificateur comme illustré dans le graphique ci-dessous.

  2. Préconfigurez l'analyseur.

  3. Sélectionnez une mesure de S12.

  4. Sélectionnez les paramètres de l'amplificateur sous test.

  5. Retirez l'amplificateur et effectuez un étalonnage de réponse directe ou un étalonnage de réponse et d'i solement.

  6. Réglez l'échelle de la mesure affichée pour un affichage optimal et utilisez un marqueur pour mesurer l'isolement inversé à la fréquence désirée.

  7. Imprimez ou sauvegardez les données sur une disquette.


Gain Flat

Voir aussi...

Gain dans le domaine des petits signaux et planéité de la courbe de gain

Présentation

Concepts

Comment mesurer

Le gain dans le domaine des petits signaux est le gain observé dans la région de fonctionnement linéaire de l'amplificateur. On le mesure généralement en appliquant une puissance d'entrée constante balayée en fréquence. La planéité de la courbe de gain est la mesure de la variation du gain sur une plage de fréquences spécifique.

Concepts

Comment mesurer le gain et la planéité de la courbe de gain

Cliquez sur un bouton pour en savoir plus sur l'un des sujets suivants :
Qu'est-ce que le gain ?

Qu'est-ce que la planéité de la courbe de gain ?

Pourquoi mesurer le gain et la planéité de la courbe de gain ?

Précision

Qu'est-ce que le gain ?

Le gain d'un amplificateur RF est défini comme la différence de puissance entre le signal de sortie et le signal d'entrée de l'amplificateur. On considère pour cela que les impédances d'entrée et de sortie de l'amplificateur sont toutes deux égales à l'impédance caractéristique du système.

  • Dans la terminologie des paramètres S, le gain est appelé paramètre S21.

  • Le gain est exprimé en dB, unité de mesure logarithmique du rapport de la puissance de sortie sur la puissance d'entrée.

  • Le gain peut être calculé en soustrayant le niveau d'entrée du niveau de sortie lorsque l'un et l'autre sont exprimés en dBm, unité de puissance relative à 1 milliwatt.

  • Le gain d'un amplificateur est le plus souvent spécifié comme une valeur minimale obtenue sur une plage de fréquences déterminée. Pour certains amplificateurs, on spécifie à la fois le gain minimal et le gain maximal pour éviter que les étages en aval ne reçoivent une puissance trop faible ou trop forte.

Qu'est-ce que la planéité de la courbe de gain ?

La p lanéité spécifie l'ampleur de la variation du gain de l'amplificateur sur la plage de fréquences utile. Les variations du gain sur cette plage de fréquences peuvent provoquer une distorsion des signaux passant à travers l'amplificateur.

Pourquoi mesurer le gain dans le domaine des petits signaux et la planéité de la courbe de gain ?

Les variations du gain sur la largeur de bande utile entraînent une distorsion des signaux transmis, car les composantes fréquentielles ne sont pas toutes amplifiées dans les mêmes proportions. La mesure du gain dans le domaine des petits signaux permet de quantifier le gain de l'amplificateur à une fréquence particulière dans un système dont l'impédance caractéristique est de 50 ohms. La mesure de la planéité permet de visualiser les variations du gain de l'amplificateur sur une plage de fréquences déterminée, dans un système dont l'impédance caractéristique est de 50 ohms.

Précision

  • L'amplificateur peut répondre très différemment en fonction de la température. Les tests doivent être exécutés lorsque l'amplificateur est à la température de service souhaitée.

  • Au besoin, la puissance de sortie de l'amplificateur doit être atténuée dans des proportions suffisantes. Une trop grande puissance de sortie peut :

    • endommager le récepteur de l'analyseur ;

    • dépasser le niveau de compression en entrée du récepteur de l'analyseur et conduire à des mesures inexactes.

L'a tténuation de la puissance de sortie de l'amplificateur peut être réalisée au moyen :

    • d'atténuateurs,

    • de coupleurs.

Il doit être tenu compte de la réponse en fréquence et de la désadaptation des atténuateurs et des coupleurs lors de l'étalonnage, car ces dispositifs font partie du système de test. Des techniques de correction d'erreurs appropriées peuvent réduire ou compenser les défauts de tels dispositifs.

  • La réponse en fréquence est la principale source d'erreur dans une configuration de mesure du gain dans le domaine des petits signaux et de la planéité de la courbe de gain. Cette erreur peut être réduite de manière significative par un étalonnage du chemin électrique direct. Pour une plus grande précision, effectuez un étalonnage sur deux ports.

  • La réduction de la largeur de bande de la FI ou l'utilisation de la fonction de moyennage améliore la g amme dynamique et la précision de mesure, même si cela se fait au détriment de la vitesse d'exécution.

Comment mesurer le gain et la planéité de la courbe de gain

  1. Préréglez l'analyseur (touche Preset).

  2. Sélectionnez une mesure de paramètre S21.

  3. Réglez la puissance de la source de l'analyseur de manière à la situer dans la région de fonctionnement linéaire de l'amplificateur (généralement 10 dB en dessous du point de compression de 1 dB du gain).

  4. Si vous devez utiliser un atténuateur externe, choisissez une atténuation suffisante pour éviter de dépasser le niveau de compression du récepteur ou d'endommager le port 2 de l'analyseur.

  5. Connectez l'amplificateur en vous conformant à la figure ci-dessus et fournissez la tension de polarisation continue.

  6. Réglez l'analyseur en choisissant des valeurs adaptées à votre amplificateur.

  7. Retirez l'amplificateur et procédez à un étalonnage de mesure. Veillez à inclure l'atténuateur et les câbles dans votre montage d'étalonnage s'ils doivent être utilisés pour la mesure de l'amplificateur.

  8. Enregistrez l'état de l'instrument en mémoire.

  9. Reconnectez l'amplificateur.

  10. Réglez l'échelle pour une visualisation optimale de la mesure affichée et utilisez un marqueur pour mesurer le gain dans le domaine des petits signaux à une fréquence voulue.

  11. Mesurez la planéité de la courbe de gain sur une plage de fréquences déterminée en utilisant des marqueurs pour mettre en évidence la variation crête à crête.

  12. Imprimez les données ou enregistrez-les sur un disque ou une disquette.

  13. Ce type de mesure peut être automatisé.


Impedance

Cette applet est conçue pour être affichée sur l'écran de l'analyseur. Pour l'afficher ailleurs que sur l'analyseur, copiez les fichiers ci-dessous dans le répertoire C:\WINNT\Help de l'analyseur ou sur le CD-ROM fourni avec l'analyseur et placez-les dans votre répertoire C:\WINNT\Help.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Modèle d'adaptation d'impédance

Voir aussi...

L'adaptation d'impédance est un processus utilisé lors de la conception des circuits pour égaliser les impédances de source et de charge, optimisant ainsi par conséquent la puissance délivrée à la charge par la source. Ce processus se réalise en insérant des réseaux d'adaptation dans un circuit entre la source et la charge.

Présentation du modèle

Modèle d'adaptation d'impédance

Description des excercices

Influence des éléments de circuit sur l'abaque de Smith

Régions interdites de l'abaque de Smith

Présentation

Dans ce modèle, des abaques de Smith sont utilisés pour représenter le processus interactif d'adaptation d'impédance afin d'optimiser la puissance transmise dans des circuits simples. Des réseaux d'adaptation simple à inductance/capacité série/parallèle sont également utilisés et vous pouvez régler les valeurs des composants L et C correspondants de manière interactive. Le réglage des composants du réseau d'adaptation modifie la réflectance du circuit global. La réflectance de chaque partie du circuit est représentée sur l'abaque de Smith par une boule rouge [image] ou bleue [image].

Lorsque vous réglez les verniers pour modifier les valeurs des composants, le modèle calcule de nouvelles valeurs pour la réflectance du circuit et déplace les boules rouge [image] et bleue [image] sur l'abaque de Smith. L'objectif de chaque exercice est de déplacer le point de réflectance depuis le centre de l'abaque de Smith, qui représente la charge ou la source, dans les anneaux [image] rouge et [image] bleu appropriés qui représentent la condition d'adaptation désirée. Vous pouvez sélectionner trois problèmes d'adaptation d'impédance de difficulté croissante en cliquant sur l'un des trois onglets étiquetés.

Modèle d'adaptation d'impédance

Agrandissez cette fenêtre pour un affichage optimal. Cliquez si le modèle d'impédance n'est pas visible.

Description des excercices

Le premier exercice vous permet d'utiliser l'abaque de Smith pour résoudre un problème d'adaptation d'impédance classique entre une source résistive et une charge résistive. Un réseau à inductance série et capacité parallèle simple est utilisé pour adapter une source de 50 ohms à une charge de 300 ohms. La réflectance de source du circuit regardant depuis la charge vers la source représentée par la boule rouge [image], alors que la charge de 300 ohms est représentée par l'anneau rouge fixe [image] .

L'objectif de l'exercice est d'adapter de manière interactive ces deux impédances en réglant les verniers L et C. Le modèle produira une réaction graphique en déplaçant la boule rouge indiquant la réflectance du circuit sur l'abaque de Smith. Réglez les verniers de L série et C parallèle afin de déplacer le point de réflectance [image] depuis le centre de l'abaque de Smith vers la position d'adaptation d'impédance à l'intérieur de l'anneau rouge. Vous pouvez étudier l' influence des éléments de circuit sur l'abaque de Smith ci-dessous pour obtenirs des indices sur la manière selon laquelle les différents éléments de circuit modifient la réflectance de celui-ci sur l'abaque de Smith.

Le deuxième exercice résout le probème en terme d'adaptation d'impédance d'optimisation du gain de transmission de puissance d'un amplificateur à transistor. L'adaptation de la source 50 ohms à la réflectance d'entrée du transistor, s*11 et l'adaptation de la charge 50 ohms à la réflectance de sortie du transistor, s*22, optimise la puissance délivrée par la source vers la charge à travers le transistor. Vous êtes invité à adapter séparément la boule rouge [image] d'entrée et la boule bleue [image] de sortie du transistor. Réglez les valeurs des composants afin de placer les deux points de réflectance dans leur position adéquate à l'intérieur des anneaux rouge [image] et bleu [image].

La troisième partie du modèle d'adaptation d'impédance interactif est un recueil d'exercices mettant en oeuvre un circuit modulaire. Vous commencez par construire un circuit avec l'un ou les deux composants de réseaux d'adaptation modulaires obtenus par un glisser-déplacer. Lorsque les réseaux d'adaptation ont été ajoutés au circuit, les verniers deviennent actifs et vous permettent de régler les valeurs des composants. Vous vous attaquerez alors à l'adaptation d'impédance du circuit que vous venez juste de créer ! Vous pouvez construire 8 circuits différents et il existe 5 paires de valeurs différentes pour s*11 et s*22 sur l'abaque de Smith, constituant un total de 40 exercices d'adaptation d'impédance. Vous constaterez que les réseaux d'adaptation d'impédance ne fonctionnent pas tous ! Pour certains des circuits que vous serez en mesure de construire, vous ne pourrez pas placer la boule rouge [image] à l'intérieur de l'anneau rouge ou la boule bleue [image] à l'intérieur de l'anneau bleu. Pour déterminer à l'avance quels réseaux d'adaptation d'impédance fonctionneront, observez attentivement les Régions interdites de l'abaque de Smith ci-dessous. Il existe 5 paires de lieux différentes pour s*11 et s*22 correspondant à différentes fréquences permettant l'adaptation d'impédance. Utilisez l'indicateur de fréquence pour sélectionner une fréquence de fonctionnement, puis glissez-déplacez les réseaux d'adaptation d'impédance adéquats dans le circuit et réglez les valeurs des composants pour placer les deux points de réflectance à leurs positions adéquates à l'intérieur des anneaux rouge [image] et bleu.

Influence des éléments de circuit sur l'abaque de Smith

Les graphiques ci-dessous illustrent comment les divers composants L et C série et parallèle modifient la réflectance du circuit sur l'abaque de Smith. En supposant que le composant donné est le dernier du réseau d'adaptation d'impédance, la réflectance du circuit se déplacera comme indiqué le long des cercles de résistance constante ou de conductance constante.

Vous pouvez vous imaginer l'adaptation d'impédance à l'aide de l'abaque de Smith comme le fait de conduire une voiture vers une destination particulière dans Smith Ville - ville dans laquelle aucune rue n'est droite ! En réglant les composants du circuit dans l'ordre adéquat, nous pouvons contraindre la réflectance du circuit à suivre les cercles de résistance constante ou de conductance constante. Exactement comme la signalisation routière peut diriger une voiture le long des boulevards circulaires de Smith Ville, nous pouvons atteindre la condition d'adaptation d'impédance d'une manière directe et déterministe.

Régions interdites de l'abaque de Smith

Pour une réflectance de charge donnée, seuls certains réseaux L-C d'adaptation d'impédance seront en mesure d'égaliser l'impédance de source et l'impédance de charge. En fait, pour toute réflectance de charge, exactement deux des quatres réseaux L-C d'adaptation possibles du modèle d'amplificateur à transistor-II ci-dessus seront en mesure de réaliser l'adaptation d'impédance. Mais lesquels des deux ?

Les abaques ci-dessous peuvent servir à déterminer quels réseaux d'adaptation d'impédance fonctionneront pour un configuration de charge donnée. Si la réflectance de charge se situe dans la région interdite de l'abaque de Smith pour le réseau d'adaptation d'impédance indiqué, alors ce réseau ne pourra pas réaliser cette adaptation. Vous ne pourrez pas conduire votre voiture dans les quartiers interdits de Smith Ville ! Ils ne sont pas carrossables !

Utilisez ces abaques pour déterminer le réseau d'adaptation d'impédance qui doit être employé. Tout d'abord, situez visuellement la position de la réflectance de charge du modèle d'amplificateur à transistor II ci-dessus sur chacun des quatre abaques de Smith ci-dessous. Puis, éliminez les deux réseaux dont la région interdite recouvre le point de réflectance et utilisez l'un des deux réseaux restants pour effectuer l'adaptation d'impédance.


Refl Waves

Cette applet est conçue pour être affichée sur l'écran de l'analyseur. Pour l'afficher ailleurs que sur l'analyseur, copiez les fichiers ci-dessous dans le répertoire C:\WINNT\Help de l'analyseur ou sur le CD-ROM fourni avec l'analyseur et placez-les dans votre répertoire C:\WINNT\Help.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Ondes réfléchies le long d'une ligne de transmission

Voir aussi...

Lorsqu'une onde sinusoïdale émise par un générateur de signaux RF est envoyée sur une ligne de transmission, le signal se propage vers la charge. Ce signal, présenté ici en jaune, apparaît comme un jeu de vecteurs tournants à raison d'un à chaque point sur la ligne de transmission.

Agrandissez cette fenêtre pour un affichage optimal. Cliquez si l'applet n'est pas visible.

Dans notre exemple, la ligne de transmission a une impédance caractéristique de 50 ohms. Si nous choisissons une charge de 50 ohms, l'amplitude du signal ne varie pas avec la position le long de la ligne. Seule la phase varie le long de la ligne, comme le montrent les vecteurs tournants en jaune.

Si l'impédance de la charge ne correspond pas exactement à l'impédance caractéristique de la ligne, un signal réfléchi se propage vers la source. A n'importe quel point le long de la ligne de transmission, ce signal apparaît comme une tension constante dont la phase dépend de la position physique le long de la ligne.

La tension affichée à un point donné de la ligne est la somme vectorielle des sinusoïdes transmises et réfléchies. Ceci peut être démontré à l'aide de deux exemples.

Exemple 1 : Adaptation parfaite : 50 Ohms

Réglez la résistance de terminaison à 50 ohms à partir de la boîte de dialogue "down arrow". Observez qu'il n'y a pas de réflexion. Nous avons une adaptation parfaite. Chaque vecteur tournant a une amplitude normalisée de 1. En supposant que nous observions le signal à un point quelconque avec un instrument de mesure parfait, nous verrions des ondes sinusoïdales d'égale amplitude tout au long de la ligne de transmission. Les amplitudes des signaux sont indiquées par la ligne verte.

Exemple 2 : Désadaptation de la charge : 200 Ohms

Créons maintenant intentionnellement une désadaptation de la charge. Réglez la résistance de terminaison à 200 ohms à l'aide de la flèche vers le bas. Appuyez sur le bouton PLAY et observez le changement dans le signal réfléchi. S'il était possible de ne mesurer que l'onde réfléchie, nous verrions que son amplitude ne varie pas avec la position le long de la ligne. La seule différence entre le signal réfléchi (en bleu) aux points z6 et z4 est la phase.

Cependant, l'amplitude du signal résultant, indiqué par l'onde stationnaire (en vert), n'est pas constante tout au long de la ligne car les signaux transmis et réfléchis (en jaune et bleu) se combinent. Comme la phase entre les signaux transmis et réfléchis varie avec la position le long de la ligne, les sommes vectorielles diffèrent, créant une onde dite "stationnaire".

Lorsque l'impédance de la charge est réglée à 200 ohms, un dispositif de mesure placé au point z6 montrerait une onde sinusoïdale d'amplitude constante. L'onde sinusoïdale au point z4 serait également d'amplitude constante, mais son amplitude différerait de celle du signal au point z6. De plus, les deux signaux seraient mutuellement déphasés. Encore une fois, la différence est illustrée par la ligne verte, qui indique l'amplitude à ce point de la ligne de transmission.

L'impédance le long de la ligne change également, comme le montrent les points z1 à z7.


Overview

Voir aussi...

Présentation du domaine temporel

Présentation

Concepts

Comment effectuer une mesure dans le domaine temporel

Si l'analyseur comporte l'option 010 Domaine temporel, vous pouvez visualiser la réponse du composant comme une fonction du temps. Cette rubrique permet de comprendre l'option domaine temporel en fournissant une présentation du fonctionnement.
Concepts

Comment effectuer une mesure dans le domaine temporel

Qu'est-ce qu'une mesure dans le domaine temporel ?

Similarité avec la réflectométrie de domaine temporel

Séquence des mesures dans le domaine temporel

Qu'est-ce qu'une mesure dans le domaine temporel ?

  • En fonctionnement normal, l'analyseur mesure les caractéristiques de fonctionnement RF d'un composant de test en fonction de la fréquence.

  • Lorsque l'analyseur comporte l'option 010 Domaine temporel, il peut utiliser une technique mathématique (la transformée de Fourier inverse) pour transformer des données dans le domaine frequentiel en données dans le domaine temporel.

  • La mesure est montrée avec le temps comme axe d'affichage horizontal.

  • Les valeurs des réponses apparaissent séparées dans le temps, permettant une analyse différente des performances et des limitations du réseau.

Le graphique ci-dessous compare les mêmes données de mesure de réflexion d'un câble dans les domaines fréquentiel et temporel. Le câble a deux torsions, chaque torsion crée une désadaptation ou modification de l'impédance de la ligne.

  • La réponse dans le domaine fréquentiel mesurée au niveau du port d'entrée montre la réponse composite due aux réflexions (fluctuation) provoquée par les interactions entre les désadaptations dans le câble, mais il est difficile de déterminer où ces désadaptations se produisent dans le câble.

  • La réponse dans le domaine temporel est une manière de voir à l'intérieur du câble et de déterminer l'emplacement et l'amplitude de chaque désadaptation. Dans l'exemple ci-dessus, la réponse indique que la seconde torsion du câble est l'emplacement d'une désadaptation importante.

Transformée de Fourier

Avec les réponses dans le domaine temporel, l'analyseur peut également filtrer les réponses non souhaitées, en utilisant la fonction filtrage. L'analyseur peut ensuite effectuer la transformation de la réponse souhaitée dans le domaine fréquentiel. Cela permet de caractériser la réponse du réseau à un signal particulier ou à une forme d'onde modulée sans incorporer les effets des composants externes tels que les connecteurs ou les adaptateurs. L'analyseur utilise les transformées suivantes pour cette opération.

  • Transformée de Fourier inverse -- transforme les données de mesures fréquentielles en données dans le domaine temporel.

  • Transformée de Fourier -- transforme les données dans le domaine temporel de nouveau dans le domaine fréquentiel.

Similarité avec la réflectométrie de domaine temporel

  • Le mode domaine temporel simule une réflectométrie de domaine temporel (TDR) classique qui permet de déterminer les caractéristiques des lignes électriques en observant les formes d'onde réfléchies.

  • Par la forme et l'emplacement des réponses, vous pouvez déterminer l'impédance et la distance de la discontinuité.

Analyse réflectométrique de domaine temporel

  • L'analyse réflectométrique de domaine temporel classique envoie une impulsion ou un échelon dans le composant en cours de test et observe l'énergie réfléchie.

  • L'échelon incident, ainsi que l'onde réfléchie, est affiché sur l'écran du réflectomètre de domaine temporel.

  • En analysant l'amplitude, la durée et la forme de l'onde réfléchie, il est possible de déterminer la nature de la variation d'impédance dans le système de transmission.

Analyse dans le domaine temporel de l'analyseur

  • L'analyseur n'envoie pas d'impulsion ou d'échelon incident réel mais effectue des mesures de réponse à un balayage en fréquence.

  • A partir des données de réponse en fréquence, l'analyseur calcule la réponse à un échelon, à une impulsion ou de p asse-b ande du composant, en fonction de la transformée sélectionnée.

  • L'analyseur affiche les données sous la forme d'une réponse dans le domaine temporel (affichage similaire à celui d'un réflectomètre).

Séquence des mesures dans le domaine temporel

  1. Les données fréquentielles -- sont acquises pendant la mesure par l'analyseur de la réponse du composant dans le domaine fréquentiel.

  2. La sélection mode passe-bande et mode passe-bas -- dépend des caractéristiques en fréquence du composant en cours de test et de l'affichage de la réponse souhaité.

    • Le mode passe-bande est le plus souple des modes. Le mieux adapté aux composants qui ne laissent pas passer toutes les fréquences, tels que les filtres. Seule la réponse impulsionnelle est disponible.

    • Le mode passe-bas simule le réflectomètre de domaine temporel classique. Le mieux adapté aux composants qui laissent passer toutes les fréquences jusqu'au continu, tels que les câbles. Les fréquences du balayage sont liées harmoniquement. Les réponses à une impulsion et à un échelon sont disponibles.

  3. La sélection de la fenêtre -- optimise la réponse dans le domaine temporel en permettant des transitions douces à zéro à la fin de la période d'échantillonnage. Cela retire de la réponse les lobes secondaires non souhaités, rendant les réponses de niveau inférieur visibles. La meilleure résolution et les lobes secondaires les plus élevés sont obtenus avec les fenêtres minimales.

  4. Le filtrage -- consiste en un filtrage temporel qui retire les effets des réponses non souhaitées.

  5. Les données fréquentielles -- peuvent être affichées une fois que l'analyseur a transformé de nouveau les réponses dans le domaine fréquentiel. La mesure ne montre que les effets des réponses particulières qui subsistent après filtrage.

Cliquez sur les boutons pour afficher les étapes générales nécessaires pour effectuer une mesure dans le domaine temporel.
Configuration de la mesure

Optimisation des résultats

Interprétation des données affichées

Configuration de la mesure

  1. Sélectionnez le paramètre de mesure dans le domaine fréquentiel. Voir Configurer une mesure.

  2. Décidez quel mode de transformation utiliser.

    • Si la réponse à la mesure du composant en cours de test va jusqu'au continu, vous devez utiliser le mode passe-bas avec la réponse à un échelon.

    • Si la réponse à la mesure du composant en cours de test ne va pas jusqu'au continu, vous devez utiliser le mode p asse -b ande.

    Voir Modes passe-bande et passe-bas.

  3. Calculez les valeurs des paramètres de mesure suivants pour obtenir la résolution nécessaire pour la réponse et la plage de mesure du composant en cours de test :

    • Plage de fréquences

    • Nombre de points

    • Largeur de la fenêtre

Voir Résolution et plage.

  4. Réglez les valeurs de l'étendue de la mesure des fréquence et le nombre de points calculés à l'étape précédente. Voir Configurer une mesure.

  5. Si vous avez sélectionné le mode passe-bas, procédez comme suit :

    1. Laissez la fréquence de départ à 300 kHz et entrez la fréquence de fin et le nombre de points.

    2. Dans le menu Trace, cliquez sur Transform, Set Freq. Low Pass. Ceci fixe automatiquement toutes les fréquences.

  6. Effectuez une transformation des données dans le domaine temporel et appliquez la valeur de fenêtre calculée à l'étape antérieure. Déterminez si la résolution de la réponse et la plage de mesure sont suffisantes pour votre application de mesure.

    • Si les paramètres actuels ne permettent pas d'obtenir la réponse du composant, modifiez la plage de mesure de fréquence, le nombre de points et la largeur de la fenêtre. Voir Résolution et plage dans le domaine temporel.

  7. Arrêtez la transformation et effectuez un étalonnage de la mesure qui correspond au mieux aux besoins de configuration et de précision de celle-ci. Voir Sélectionner et réaliser un étalonnage de la mesure.

  8. Effectuez une transformation des données dans le domaine temporel.

Optimisation des résultats

  1. Utilisez l'Autoscale de la réponse à la mesure.

  2. Pour obtenir la résolution d'affichage maximale, centrez la réponse présentant un intérêt sur l'écran.

  3. Configurez et activez le filtrage (filtrage temporel) pour retirer les réponses non souhaitées de la mesure affichée. Voir Réponses aux filtrages.

Interprétation des données affichées

  1. Interprétez le type d'impédance au niveau de la discontinuité. Voir Données de mesure de domaine temporel.

  2. Pour afficher les données filtrées dans le domaine temporel, activez la fonction filtrage et désactivez la transformation.


Modes

Voir aussi...

Modes passe-bande et passe-bas du domaine temporel

Présentation

Concepts

Comment configurer le mode domaine temporel

Vous devez sélectionner le mode domaine temporel avant de configurer les valeurs de mesure. La sélection dépend principalement du composant sous test.
Concepts

Comment configurer le mode domaine temporel

Comparaison des modes

Passe-bande

Passe-bas

Choix du mode

Plages de fréquences et points de données

Réponses à une impulsion et à un échelon

Formats de données utiles

Comparaison des modes

Mode passe-bande

  • Le plus facile à utiliser

  • Utile pour mesurer des dispositifs p asse-b ande qui ne fonctionnent pas jusqu'au courant continu (0 Hz)

  • Permet aux fréquences mesurées de faire partie de n'importe quel ensemble de fréquences de début et de fin

  • Ne permet que les réponses à une impulsion parce que les données transformées ne contiennent pas de terme de courant continu

  • Permet les mesures de réflexion et de transmission

  • Permet la localisation de défauts

Mode passe-bas

  • Utile pour la mesure des dispositifs passe-bas qui fonctionnent jusqu'au courant continu

  • Simule un réflectomètre de domaine temporel classique (RDT)

  • Nécessite que les fréquences mesurées soit liées harmoniquement à un terme de courant continu extrapolé à partir des quelques premiers points de données du domaine fréquentiel

  • Permet les réponses à une impulsion et à un échelon parce que les données transformées comprennent un terme de courant continu

  • Permet la localisation de défauts et l'identification du type d'impédance (capacitive, inductive) présent au niveau de la discontinuité

  • Permet les mesures de réflexion et de transmission

  • A une résolution de la réponse supérieure (x 2) au mode passe-bande pour la même bande d'analyse

Le choix du mode dépend du composant sous test

  • Choisir le mode passe-bande -- si le composant sous test se comporte comme un filtre passe-bande, coupe-bande ou passe-haut.

  • Choisir le mode passe-bas -- si le composant sous test laisse passer toutes les fréquences jusqu'au courant continu. Même si la réponse du dispositif chute dans les basses fréquences de la bande d'analyse, choisir tout de même le mode passe-bas.

Plages de fréquences et points de données

Le mode passe-bande

  • Les fréquences de début et de fin peuvent prendre n'importe quelle valeur à l'intérieur de la plage de l'analyseur.

  • L'analyseur fait l'acquisition des données de la fréquence de début à celle de fin.

  • Ne permet que les réponses à des impulsions.

Le mode passe-bas

  • Nécessite un terme continu extrapolé à partir des quelques premiers points de données dans le domaine fréquentiel.

  • Nécessite un espacement égal des points de données.

  • L'analyseur fixe toutes les fréquences de mesure à des harmoniques de la fréquence de début.

  • FSTOP = N X FSTART (N = nombre de points) fixe une limite pour la fréquence de fin pour chaque valeur de N.

Remarque : Parce que la valeur la plus faible possible de FSTART est 300 kHz, FSTOP doit être au moins égal à N X 300 kHz.

Réponses à une impulsion et à un échelon

L'analyseur de réseau peut présenter la réponse dans le domaine temporel comme si le composant sous test avait été stimulé par une fonction impulsion ou échelon.

  • Stimulus impulsionnel -- est une forme d'onde de tension qui passe de zéro à un, puis de nouveau à zéro. La durée de l'impulsion est déterminée par la bande d'analyse utilisée pour la mesure dans le domaine fréquentiel.

  • Stimulus en échelon -- est une forme d'onde de tension qui passe de zéro à un. Le temps de montée en échelon est déterminé par la fréquence la plus élevée de la mesure dans le domaine fréquentiel.

Remarque : L'interprétation des types de discontinuités est plus facile dans le cas d'une réponse à un échelon en mode passe-bas. Cette combination permet également l'affichage RDT des discontinuités inductive et capacitive communément accepté.

  • A partir des données de la réponse fréquentielle, l'analyseur calcule la réponse à un échelon, à une impulsion ou p asse-b ande du dispositif, en fonction de la transformation sélectionnée.

  • L'analyseur affiche les données sous la forme d'une réponse dans le domaine temporel (affichage semblable à un RDT).

Voir Résolution et plage pour plus d'informations concernant l'influence de la bande d'analyse sur la durée de l'impulsion et le temps de montée.

Formats de données utiles

Formats utiles au mode passe-bande

  • Amplitude linéaire

    • Dans le cas de mesures de réflexion, ce format affiche l'amplitude linéaire moyenne du coefficient de réflexion (r) dans la plage de fréquences mesurée.

    • Dans le cas de mesures de transmission, ce format affiche le coefficient de transmission moyen (t) du trajet de transmission dans la plage de fréquences de la mesure.

    • Ce format est utile pour afficher des réponses sensiblement de même amplitude.

  • Amplitude logarithmique

    • Dans le cas de mesures de réflexion, ce format affiche la réponse en unités de perte en réflexion (dB). La valeur affichée représente la perte en réflexion moyenne de la discontinuité dans la plage de fréquences de la mesure.

    • Dans le cas de mesures de transmission, ce format affiche la réponse en unités de perte de transmission ou gain (dB). Cela représente la perte moyenne du trajet de transmission dans la plage des fréquences de la mesure.

    • Ce format est utile pour l'affichage d'une large plage dynamique de réponses de transmission.

  • Rapport d'ondes stationnaires

    • Dans le cas de mesures de réflexion, ce format affiche le rapport d'ondes stationnaires (SWR) de la discontinuité dans la plage de fréquences de la mesure.

Format utile au mode passe-bande

  • Réel

    • Ce format affiche la réponse du dispositif en unités réelles.

Cliquez sur les boutons pour accéder aux procédures de configuration du mode domaine temporel.

    • Si la réponse à la mesure du composant sous test va jusqu'au continu, utilisez le mode passe-bas.

    • Si le composant sous test n'a aucune réponse en continu, utilisez le mode p asse- b ande.
Configuration du mode passe-bas

Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Configuration du mode passe-bande

Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Configuration du mode passe-bas

Procédure à l'aide de la souris

  1. Sélectionnez la configuration d'une mesure. Voir Configuration d'une mesure.

  2. Calculez la bande d'analyse et le nombre de points.

FSTOP = N X FSTART où (N = nombre de points)

Remarque : Etant donné que FSTART est égal à 300 kHz, FSTOP doit être au moins égal à N X 300 kHz.

Nombre de points | Plage de fréquences minimum pour passe-bas uniquement
3 11 26 51 101 201 401 801 1601 | 300 kHz à 0,9 MHz 300 kHz à 3,0 MHz 300 kHz à 7,8 MHz 300 kHz à 15,3 MHz 300 kHz à 30,3 MHz 300 kHz à 60,3 MHz 300 kHz à 120,3 MHz 300 kHz à 240,3 MHz 300 kHz à 480,3 MHz

  3. Dans le menu Sweep, cliquez sur Number of Points et saisissez la valeur.

  4. Configurez la bande d'analyse :

    1. Dans le menu Channel, cliquez sur Start/Stop.

    2. Laissez la fréquence de début à 300 kHz et saisissez la fréquence de fin.

  5. Dans le menu Trace, cliquez sur Transform, et sélectionnez le mode de transformation.

  6. Cliquez sur Set Freq. Low Pass. Cela configure automatiquement toutes les fréquences.

    • Si la fréquence de fin change de manière très importante par rapport à la valeur que vous avez spécifiée, cela signifie que la valeur initiale était inférieure à la plage de fréquences minimum du mode passe-bas. Si c'est le cas, réduisez le nombre de points, réglez de nouveau la bande d'analyse et répétez cette étape.

  7. Cochez la case Transform.

Configuration du mode passe-bas

Procédure à l'aide de la face avant

  1. Sélectionnez la configuration d'une mesure. Voir Configuration d'une mesure.

  2. Calculez la bande d'analyse et le nombre de points.

FSTOP = N X FSTART où (N = nombre de points)

Remarque : Etant donné que FSTART est égal à 300 kHz, FSTOP doit être au moins égal à N X 300 kHz.

Nombre de points | Plage de fréquences minimum pour passe-bas uniquement
3 11 26 51 101 201 401 801 1601 | 300 kHz à 0,9 MHz 300 kHz à 3,0 MHz 300 kHz à 7,8 MHz 300 kHz à 15,3 MHz 300 kHz à 30,3 MHz 300 kHz à 60,3 MHz 300 kHz à 120,3 MHz 300 kHz à 240,3 MHz 300 kHz à 480,3 MHz

  3. Dans la zone CHANNEL, appuyez sur Sweep Setup.

  4. Appuyez sur F2 (Points) et saisissez le nombre de points calculés à l'étape précédente.

  5. Configurez la bande d'analyse :

    1. Dans la zone CHANNEL, appuyez sur Start/Stop.

    2. Laissez la fréquence de début à 300 kHz.

    3. Appuyez sur F2 (Fin) et saisissez la fréquence de fin.

  6. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  7. Dans la zone NAVIGATION, appuyez sur les touches Tab à Droite et Flèches pour vous déplacer dans le menu Trace jusqu'à Transform. Appuyez sur Click.

  8. Appuyez sur la touche Tab à droite pour vous déplacer vers Transform Mode et utilisez les Flèches pour sélectionner le mode.

  9. Appuyez sur la touche Tab à droite pour vous déplacer vers Set Freq. Low Pass. Appuyez sur Click. Cela configure automatiquement toutes les fréquences.

    • Si la fréquence de fin change de manière très importante par rapport à la valeur que vous avez spécifiée, cela signifie que la valeur initiale était inférieure à la plage de fréquences minimum du mode passe-bas. Si c'est le cas, réduisez le nombre de points, réglez de nouveau la bande d'analyse et répétez cette étape.

  10. Appuyez sur la touche Tab à droite pour vous déplacer vers la case à cocher Transform et appuyez sur Click.

Configuration du mode passe-bande

Procédure à l'aide de la souris

  1. Sélectionnez la configuration d'une mesure. Voir Configuration d'une mesure.

  2. Dans le menu Trace, cliquez sur Transform, et sélectionnez le mode de transformation Band Pass.

Procédure à l'aide de la face avant

  1. Sélectionnez la configuration d'une mesure. Voir Configuration d'une mesure.

  2. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  3. Dans la zone NAVIGATION, appuyez sur les touches Tab à droite et Flèches pour vous déplacer dans le menu Trace jusqu'à Transform. Appuyez sur Click.

  4. Appuyez sur la touche Tab à droite pour vous déplacer vers Transform Mode et utilisez les Flèches pour sélectionner le mode passe-bande .

  5. Appuyez sur la touche Tab à droite pour vous déplacer vers la case à cocher Transform et appuyez sur Click.


Res_Rge

Voir aussi...

Résolution et plage dans le domaine temporel

Présentation

Concepts

Comment définir
la résolution et la plage

Cette rubrique explique comment être sûr d'afficher toutes les données disponibles dans le domaine temporel pour une réponse d'un composant. Vous devez déterminer quels paramètres offrent la meilleure résolution et la plage maximale.
Concepts

Comment définir la résolution et la plage

Résolution de la réponse

Résolution d'affichage

Plage de mesure

Résolution de la réponse

La résolution de la réponse dans le domaine temporel est la capacité à distinguer entre deux réponses peu espacées. Plusieurs facteurs déterminent la résolution de la réponse mesurée dans le domaine temporel.
Bande d'analyse

Largeur de la fenêtre

Mode de domaine temporel

Influence de la bande d'analyse sur la résolution de la réponse

Le graphique ci-dessous montre l'effet d'une bande d'analyse étroite et large sur la résolution de la réponse.

  • La réponse mesurée avec une bande d'analyse étroite est superposée sur les réponses individuelles des connecteurs, mesurées avec une bande d'analyse relativement large.

  • La bande d'analyse la plus large permet à l'analyseur de séparer les deux connecteurs en deux réponses distinctes.

  • La relation entre la bande d'analyse et la largeur d'impulsion dans le temps est inversement proportionnelle.

  • Plus la bande d'analyse est large, plus la largeur d'impulsion, ou temps de montée transitoire, est étroite.

  • Pour des réponses de même amplitude, la résolution de la réponse est égale à la largeur d'impulsion, définie comme les points à 50 % (–6 dB), ou au temps de montée transitoire, défini comme les points entre 10 % et 90 %.

Influence de la largeur de la fenêtre sur la résolution de la réponse

  • La résolution de la réponse dépend également de la fenêtre utilisée dans la transformation.

  • Il est possible de calculer la résolution approximative de la réponse à l'aide des formules ci-dessous. Ces formules s'appliquent uniquement pour les réponses de même amplitude et permettent de calculer la largeur d'impulsion à 50 % ou le temps de montée transitoire entre 10 % et 90 %.

Le graphique ci-dessous montre la relation entre la largeur de la fenêtre sélectionnée et les réponses du composant.

  • Pour des signaux de même niveau, utilisez une fenêtre minimale afin d'améliorer la résolution.

  • Pour des signaux de niveaux différents, utilisez une fenêtre maximale afin d'améliorer la p lage dynamique.

Influence du mode du domaine temporel sur la résolution de la réponse

  • Il existe une différence de résolution de la réponse entre les modes b ande p assante et passe bas du domaine temporel.

  • Pour une bande d'analyse et un nombre de points identiques, le mode passe bas a une résolution supérieure et réduit la largeur d'impulsion de moitié par rapport au mode bande passante.

Résolution d'affichage

La résolution d'affichage dans le domaine temporel est la capacité à localiser précisément une réponse dans le temps. Une résolution d'affichage fine vous permet de localiser plus précisément les pics et les valeurs nulles d'une réponse. Cette amélioration est directement influencée par la période et le nombre de points sélectionnés.

Résolution d'affichage = TLargeur / Points – 1

Il existe deux façons d'améliorer la résolution d'affichage :

  • Diminuer la période.

  • Augmenter le nombre de points.

Remarque : l'augmentation du nombre de points peut compromettre votre étalonnage de mesure.

Dans l'exemple ci-dessous, les deux mesures sont réalisées avec 201 points.

  • La résolution de 50 psecondes correspond à une largeur de 10 nsecondes.

  • La résolution de 12,5 psecondes correspond à une largeur de 2,5 nsecondes.

Remarque : la capacité à séparer deux signaux peu espacés n'a pas été affectée. Cependant, si votre mesure est en mode passe bas, le changement du nombre de points peut affecter la bande d'analyse.

Astuces pour optimiser la résolution

  • Il est généralement recommandé de choisir la plus grande bande d'analyse valide pour obtenir la plus haute résolution dans le temps. Cependant, la fréquence doit rester dans la plage de fréquences utile du dispositif sous test.

  • La résolution de la réponse dépend de la bande d'analyse, de la largeur de la fenêtre et du mode de domaine temporel.

Plage de mesure

Dans le domaine temporel, la plage de mesure est définie comme la période de temps pendant laquelle une mesure peut être réalisée sans que la réponse ne se répète.

Remarque : la plage et la résolution de la réponse sont inversement proportionnelles. L'amélioration de l'une altère l'autre.

La répétition de la réponse (ou repliement) se produit à intervalles réguliers. Dans l'exemple ci-dessous, la réponse réelle près de zéro seconde est répétée à environ 60 nanosecondes et à environ 120 nanosecondes.

La plage est liée à l'espacement entre des points de fréquence dans la réponse en fréquence mesurée du composant.

La plage de mesure est proportionnelle au (nombre de points–1) et inversement proportionnelle à la bande d'analyse. Pour augmenter la plage, vous pouvez modifier deux paramètres :

  • Augmenter le nombre de points.

  • Diminuer la bande d'analyse.

Remarque : effectuez l'une de ces modifications avant d'exécuter un étalonnage de mesure.

Pour calculer la plage de mesure en mètres, multipliez l'intervalle de temps par la vitesse de la lumière dans le vide (3 x 108 mètres/seconde). Pour calculer la longueur physique réelle de la plage de mesure, multipliez cette valeur par la vitesse relative du mode de transmission.

  • Vpolyéthylène = 0,66

  • Vtéflon = 0,70

Remarque : la configuration de l'instrument pour la plage la plus longue possible réduit la résolution de la réponse dans le domaine temporel. La plage maximale dépend également de la perte du câble. Si le signal renvoyé est trop petit pour être mesuré, la plage est limitée par cette atténuation indépendamment de la bande d'analyse.

Cliquez sur les boutons ci-dessous pour accéder aux procédures de réglage de la résolution et de la plage dans le domaine temporel.
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

Cette procédure suppose que vous ayez déjà configuré une mesure dans le domaine temporel.

Résolution de la réponse

  1. Pour obtenir la résolution de la réponse nécessaire, calculez la bande d'analyse et la largeur de la fenêtre.

  2. Dans le menu Trace, cliquez sur Transform.

  3. Dans la zone Category, cliquez sur la flèche vers le bas et sélectionnez Window.

  4. Sélectionnez une largeur de fenêtre permettant d'obtenir la résolution requise pour votre application de mesure.

    • Choisissez une fenêtre minimale si vous avez besoin de mesurer des signaux de même amplitude.

    • Choisissez une fenêtre maximale si vous avez besoin de mesurer des signaux d'amplitudes très différentes.

  5. Dans le menu Channel, cliquez sur Start/Stop et entrez des valeurs pour augmenter la plage de fréquences.

  6. Si vous avez besoin d'une résolution de la réponse encore plus grande et que le dispositif sous test fonctionne jusqu'au courant continu, utilisez le mode de transformation passe bas. Voir Modes de domaine temporel.

Résolution d'affichage

  1. Dans le menu Trace, cliquez sur Transform.

  2. Dans la zone Center, entrez une valeur pour placer les réponses que vous mesurez au centre de l'écran.

  3. Dans la zone Span, entrez une valeur pour diminuer la période.

  4. Si vous avez besoin d'une résolution d'affichage encore plus grande, augmentez le nombre de points. Dans le menu Sweep, cliquez sur Number of Points et sélectionnez une valeur supérieure.

Plage de mesure

Lorsqu'une répétition de la réponse, ou un repliement, se produit, il n'est généralement pas possible de distinguer visuellement une réponse réelle d'une réponse de repliement sans procéder à un test.

  1. Augmentez la période et voyez si des répétitions flagrantes se produisent avec des espaces observables entre elles.

  2. Si vous n'êtes toujours pas sûr que la réponse est réelle, centrez la réponse à l'écran et stockez la trace.

  3. Réduisez la bande d'analyse d'environ 5 % et mesurez à nouveau le composant.

  • Si la réponse dans le domaine temporel est valide, elle reste au centre de l'écran.

  • Si la réponse est un repliement, elle se déplace le long de l'axe du temps lorsque la plage de fréquences change.

  4. Calculez la bande d'analyse et le nombre de points produisant la plage de mesure nécessaire.

  5. Dans le menu Sweep, cliquez sur Number of Points et sélectionnez une valeur supérieure.

  6. Dans le menu Channel, cliquez sur Start/Stop et entrez les valeurs du calcul afin de déterminer la plage de mesure nécessaire.

Remarque : après avoir modifié les paramètres de mesure pour obtenir la résolution et la plage nécessaires, arrêtez la transformation, exécutez un étalonnage de mesure et redémarrez la transformation.

Procédure à l'aide de la face avant

Cette procédure suppose que vous ayez déjà configuré une mesure dans le domaine temporel.

Résolution de la réponse

  1. Pour obtenir la résolution de la réponse nécessaire, calculez la bande d'analyse et la largeur de la fenêtre.

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, appuyez sur la touche Tab de droite et sur les flèches pour aller au menu Trace et à l'option Transform. Appuyez sur Click.

  3. Appuyez sur la touche Tab de droite pour aller à la zone Category, cliquez sur la flèche vers le bas et sélectionnez Window.

  4. Sélectionnez une largeur de fenêtre permettant d'obtenir la résolution requise pour votre application de mesure.

    • Choisissez une fenêtre minimale si vous avez besoin de mesurer des signaux de même amplitude.

    • Choisissez une fenêtre maximale si vous avez besoin de mesurer des signaux d'amplitudes très différentes.

  5. Dans le menu Channel, cliquez sur Start/Stop et entrez des valeurs pour augmenter la plage de fréquences.

  6. Si vous avez besoin d'une résolution de la réponse encore plus grande et que le dispositif sous test fonctionne jusqu'au courant continu, utilisez le mode de transformation passe bas. Voir Modes de domaine temporel.

Résolution d'affichage

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, appuyez sur la touche Tab de droite et sur les flèches pour aller au menu Trace et à l'option Transform. Appuyez sur Click.

  3. Appuyez sur la touche Tab de droite pour aller à la zone Center et entrez une valeur pour placer les réponses que vous mesurez au centre de l'écran.

  4. Appuyez sur la touche Tab de droite pour aller à la zone Span et entrez une valeur pour diminuer la période.

  5. Si vous avez besoin d'une résolution d'affichage encore plus grande, augmentez le nombre de points.

    1. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Setup.

    2. Appuyez sur la touche F2 (Points) et sélectionnez une valeur supérieure.

Plage de mesure

Lorsqu'une répétition de la réponse, ou un repliement, se produit, il n'est généralement pas possible de distinguer visuellement une réponse réelle d'une réponse de repliement sans procéder à un test.

  1. Augmentez la période et voyez si des répétitions flagrantes se produisent avec des espaces observables entre elles.

    1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

    2. Dans le bloc NAVIGATION, appuyez sur la touche Tab de droite et sur les flèches pour aller au menu Trace et à l'option Transform. Appuyez sur Click.

    3. Appuyez sur la touche Tab de droite pour aller à la zone Span et entrez une valeur pour augmenter la période.

  2. Si vous n'êtes toujours pas sûr que la réponse est réelle, centrez la réponse à l'écran et stockez la trace.

    1. Appuyez sur la touche Tab de droite pour aller à la zone Center et entrez une valeur pour placer les réponses que vous mesurez au centre de l'écran.

    2. Dans le bloc TRACE SETUP, appuyez sur Math/Memory et F1 (Data>>Mem).

  3. Réduisez la bande d'analyse d'environ 5 % et mesurez à nouveau le composant.

    1. Dans le bloc CHANNEL SETUP, appuyez sur Stop/Span.

    2. Sur l'entrée active, appuyez sur la touche F4 (Span) et entrez une valeur pour diminuer la bande.

  4. Si la réponse dans le domaine temporel est valide, elle reste au centre de l'écran.

  • Si la réponse est un repliement, elle se déplace le long de l'axe du temps lorsque la plage de fréquence change.

  4. Calculez la bande d'analyse et le nombre de points produisant la plage de mesure nécessaire.

  5. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Setup, F2 (Points) et sélectionnez la valeur du calcul.

  6. Dans le bloc CHANNEL SETUP, appuyez sur Start/Stop et entrez les valeurs du calcul afin de déterminer la plage de mesure nécessaire.

Remarque : après avoir modifié les paramètres de mesure pour obtenir la résolution et la plage nécessaires, arrêtez la transformation, exécutez un étalonnage de mesure et redémarrez la transformation.


Wind

Voir aussi...

Filtre de fenêtre pour les données affichées

Présentation

Concepts

Comment définir le filtre de fenêtre

La transformation dans le domaine temporel peut entraîner des limitations de la résolution temporelle dues aux effets de lobe latéral et de largeur d'impulsion. Le filtre de fenêtre permet de modifier ces effets.
Concepts

Comment définir le filtre de fenêtre

L'analyseur intègre une fonction de fenêtrage qui augmente l'utilité des mesures dans le domaine temporel pour isoler et identifier des réponses individuelles. Cette fonction a pour effet de changer la largeur d'impulsion, le niveau du lobe latéral et le temps de montée transitoire des résultats du domaine temporel.
Avantages du filtrage de fenêtre

Valeur de fenêtrage appropriée

Avantages du filtrage de fenêtre

Une mesure dans le domaine de fréquence présente des transitions abruptes aux fréquences de début et de fin, ce qui provoque des suroscillations et des oscillations transitoires dans une réponse dans le domaine temporel. La fonction de fenêtrage permet d'atténuer le caractère abrupt des transitions dans le domaine de fréquence.

  • La largeur d'impulsion ou le temps de montée transitoire -- résulte de la limitation du système de test et restreint la capacité à séparer deux réponses peu espacées. La largeur d'impulsion est inversement proportionnelle à la bande d'analyse de la mesure. Le seul moyen de rétrécir la largeur d'impulsion est d'augmenter la bande d'analyse.

  • Les lobes latéraux impulsionnels -- résultent de l'arrêt brutal à la fréquence d'arrêt. Ils limitent la p lage dynamique de la mesure dans le domaine temporel en cachant les réponses de bas niveau dans le lobe latéral des réponses de haut niveau adjacentes.

Effets du filtrage de fenêtre

  • La résolution de la réponse peut être améliorée en réduisant la largeur d'impulsion, ce qui vous permet de séparer deux réponses peu espacées.

  • La plage dynamique peut être améliorée en réduisant les lobes latéraux impulsionnels, ce qui vous permet de mesurer les réponses de bas niveau.

Vous pouvez faire varier les valeurs de fenêtrage :

Valeur de fenêtrage | Niveaux des lobes latéraux | Largeur d'impulsion | Idéal pour...
Minimum | Supérieur | Plus petite | Résolution de la réponse
Maximum | Inférieur | Plus grande | Plage dynamique

Remarque : la résolution est proportionnelle à la fonction de fenêtrage appliquée et inversement proportionnelle à la bande d'analyse mesurée. Voir Résolution de la réponse et de la gamme.

L'analyseur peut modifier les réponses du composant en appliquant un filtre de fenêtre aux données mesurées, ce qui produit les effets suivants :

  • Dans le stimulus d'impulsion -- les limitations de la résolution temporelle sont modifiées en raison des effets de lobe latéral et de largeur d'impulsion.

  • Dans le stimulus transitoire -- (filtre passe-bas uniquement) les suroscillations et les oscillations transitoires sont réduites.

Valeur de fenêtrage appropriée

Vous pouvez choisir la fenêtre qui convient le mieux pour les types de réponses attendues du composant sous test.

  • Si le composant mesuré a deux réponses de niveau d'amplitude égal, sélectionnez la largeur d'impulsion la plus étroite : fenêtrage minimum pour améliorer la résolution.

  • Si le composant mesuré a deux réponses d'amplitudes différentes, sélectionnez le niveau du lobe latéral le plus bas : fenêtrage maximum pour améliorer la p lage dynamique.

Caractéristiques du fenêtrage

Les dépendances qui suivent existent et sont présentées à titre de valeurs exemples dans le tableau ci-dessous.

Dépendance

Niveaux des lobes latéraux

  • Fenêtre sélectionnée

Temps de montée transitoire et
Largeur d'impulsion

  • Fenêtre sélectionnée

  • Bande d'analyse

Les caractéristiques de la fenêtre exemple sont présentées pour une bande d'analyse de 2,997 GHz.

Caractéristiques de la fenêtre |  | Résolution de la réponse* |  | Plage dynamique
 |  | Temps de montée transitoire (Niveau 10 % - 90 %) | Largeur d'impulsion (Niveau 50 %) | Niveau du lobe latéral
Echelon passe-bas | Minimum | 150 ps |  | –21 dBc
 | Normal | 330 ps |  | –60 dBc
 | Maximum | 494 ps |  | < –70 dBc
Impulsion de filtrage passe-bas | Minimum |  | 200 ps | –13 dBc
 | Normal |  | 320 ps | –44 dBc
 | Maximum |  | 481 ps | < –75 dBc
Impulsion de filtrage passe-bande | Minimum |  | 400 ps | –13 dBc
 | Normal |  | 641 ps | –44 dBc
 | Maximum |  | 961 ps | < –75 dBc

Equations de la résolution de la réponse

Le graphique suivant représente les effets typiques de l'application de plusieurs fenêtres à la réponse d'une mesure de réflexion d'un court-circuit.

Cliquez sur les boutons pour accéder aux procédures de définition du filtre de fenêtre en mode de domaine temporel.
A l'aide de la souris

A l'aide des touches du panneaux avant

A l'aide de la souris

  1. Dans le menu Trace, cliquez sur Transform.

  2. Dans la boîte Category, cliquez sur la flèche vers le bas et sélectionnez Window.

  3. Sélectionnez une fenêtre permettant d'atteindre la résolution requise pour votre application de mesure.

    • Choisissez une fenêtre minimum si vous souhaitez mesurer des signaux de même amplitude afin d'augmenter la résolution de la réponse.

    • Choisissez une fenêtre maximum si vous souhaitez mesurer des signaux d'amplitudes très différentes afin d'augmenter la p lage dynamique.

Remarque : vous pouvez spécifier une valeur de fenêtrage par minimum/maximum, Kaiser Beta ou largeur d'impulsion/temps de montée transitoire.

A l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc NAVIGATION, sélectionnez l'onglet de droite et les flèches pour passer au menu Trace et sélectionner Transform. Appuyez sur Click.

  3. Sélectionnez l'onglet de droite pour passer à la zone Category, cliquez sur la flèche vers le bas et sélectionnez Window.

  4. Sélectionnez une fenêtre permettant d'atteindre la résolution requise pour l'application de mesure.

    • Choisissez une fenêtre minimum si vous souhaitez mesurer des signaux de même amplitude afin d'augmenter la résolution de la réponse.

    • Choisissez une fenêtre maximum si vous souhaitez mesurer des signaux d'amplitudes très différentes afin d'augmenter la plage dynamique.

Remarque : vous pouvez spécifier une valeur de fenêtrage par minimum/maximum, Kaiser Beta ou largeur d'impulsion/temps de montée transitoire.


Gating

Voir aussi...

Filtre de porte dans le domaine temporel

Présentation

Concepts

Comment régler le filtre de porte

La sélection par porte permet de sélectionner et de supprimer mathématiquement (filtrage temporel) certaines réponses dans le domaine temporel. Les réponses qui subsistent après ce filtrage peuvent ensuite être retransformées dans le domaine fréquentiel et visualisées sous cette forme.

Concepts

Comment régler le filtre de porte

Après avoir appliqué la sélection par porte à une réponse dans le domaine temporel (Time Domain), vous pouvez repasser en mode fréquentiel (c'est-à-dire désactiver la transformée) et étudier la réponse en fréquence du composant avec la porte toujours active. Par exemple, dans le cas d'une mesure de transmission, vous pouvez supprimer les effets des multiples trajets de transmission afin de vous concentrer sur la réponse d'un seul trajet. Vous pouvez aussi visualiser individuellement chaque réponse dans le domaine temporel et analyser son effet dans le domaine fréquentiel.

Principe d'utilisation de la sélection par porte

Paramètres de la porte

Formes de porte

Caractéristiques de la porte

Principe d'utilisation de la sélection par porte

  1. Mesurez un composant dans le domaine fréquentiel.

  2. Activez la transformée dans le domaine temporel. L'analyseur de réseau calcule la réponse dans le domaine temporel (passe-bas ou passe-bande).

  3. Définissez les limites de la porte.

    • Pour une porte de type passe-bande (Bandpass) -- centrez la porte sur la ou les réponses que vous souhaitez conserver dans la mesure. Activez la fonction de porte. Les réponses situées en dehors de la porte sont alors supprimées mathématiquement de la mesure affichée.

    • Pour une porte de type coupe-bande (Notch) -- centrez la porte sur la ou les réponses que vous souhaitez supprimer de la mesure. Activez la fonction de porte. Les réponses situées à l'intérieur de la porte sont alors supprimées mathématiquement de la mesure affichée.

  4. Désactivez la transformée dans le domaine temporel pour visualiser la réponse en fréquence dans le domaine fréquentiel et constater l'effet de la suppression des réponses situées en dehors de la durée d'ouverture de la porte (ou à l'intérieur de cette durée s'il s'agit d'une porte de type coupe-bande). L'exemple suivant montre l'effet d'une porte de type passe-bande.

Paramètres de la porte

Vous pouvez définir les limites et le comportement de la porte à l'aide des paramètres suivants :

  • Start et Stop -- temps de coupure à -6 dB.

  • Center -- temps central de la porte.

  • Span -- durée d'ouverture de la porte égale au temps d'arrêt (Stop) moins le temps de départ (Start).

  • Gate Type :

    • Bandpass (passe-bande) -- supprime les réponses situées en dehors des valeurs initiale/finale (Start/Stop) ou de la durée d'ouverture de la porte (Span).

    • Notch (coupe-bande) -- supprime les réponses situées à l'intérieur des valeurs initiale/finale (Start/Stop) ou de la durée d'ouverture de la porte (Span).

Dans l'exemple suivant, le type de porte Bandpass a été sélectionné, ce qui a pour effet de supprimer les réponses situées en dehors de la durée d'ouverture de la porte.

.

Formes de porte

La porte possède également une forme de filtre similaire à celle du filtre de fenêtre décrit à la rubrique Filtre de fenêtre pour les données affichées. Vous pouvez optimiser la mesure en sélectionnant la forme de porte la plus adaptée parmi celles qui sont disponibles : minimum, normal, large (Wide) et maximum.

  • Forme minimum -- possède les lobes latéraux de plus haut niveau, la pente de décroissance la plus abrupte et l'ondulation dans la bande passante la plus importante.

  • Forme maximum -- possède les lobes latéraux de plus bas niveau, la pente de décroissance la plus douce et l'ondulation dans la bande passante la plus faible.

Ondulation dans la bande passante de la porte

La porte est un filtre de la forme passe-bande, et chacune des quatre formes de porte possède des caractéristiques de filtrage différentes. L'illustration suivante compare les ondulations dans la bande passante des quatre formes (l'échelle est de 0,5 dB/division). La porte minimum est celle qui présente l'ondulation la plus importante.

Lobes latéraux de la porte

Le graphique ci-après compare les niveaux des lobes latéraux des quatre formes de porte. Les niveaux les plus bas sont obtenus au prix d'une pente de décroissance moins abrupte, c'est-à-dire d'un temps de coupure plus important.

  • La porte minimum est celle qui possède les lobes latéraux de plus haut niveau et le temps de coupure le plus court. Pour cette raison, elle est idéale pour supprimer une réponse indésirable située à un instant très proche d'une réponse que l'on souhaite conserver pour analyse.

  • La porte maximum présente les lobes latéraux de plus bas niveau et un temps de coupure plus long (pente plus douce). Sa forme est plus évasée et offre une plus grande atténuation des réponses situées en dehors de sa durée d'ouverture.

Caractéristiques de la porte

Chacune des quatre formes de porte disponibles est caractérisée par différents paramètres :

  • Ondulation dans la bande passante et niveaux des lobes latéraux -- caractérisent la forme de la porte.

  • Temps de coupure -- durée s'écoulant entre le point de coupure situé à -6 dB sur le flanc du filtre et la crête du premier lobe latéral.

  • Durée d'ouverture minimale de la porte -- durée égale à deux fois le temps de coupure.

Temps de coupure

Le graphique ci-dessous illustre la forme générale de la porte et indique les caractéristiques propres à chaque variante de cette forme.

  • T1 est la durée d'ouverture de la porte ; elle est égale au temps d'arrêt (Stop) moins le temps de départ (Start).

  • T2 est la durée s'écoulant entre le bord de la bande passante et le point à -6 dB, représentant le temps de coupure du filtre.

  • T3 est le temps s'écoulant entre le point à -6 dB et le bord de la bande coupée de la porte.

Pour toutes les formes de filtre, T2 est égal à T3 et le filtre est symétrique par rapport au temps central.

Durée d'ouverture minimale de la porte

Il existe une durée d'ouverture minimale pour chaque forme de porte. En effet, aussi abrupte que soit la pente de décroissance du filtre, le temps de coupure n'est jamais nul. La durée d'ouverture minimale recommandée est fournie par l'équation suivante, cas extrême dans lequel la bande passante du filtre est égale à 0 seconde.

T1MIN = 2 x T2

Si vous spécifiez une durée d'ouverture (Span) plus petite que la durée minimale recommandée, les effets seront les suivants :

  • forme de porte distordue, dépourvue de toute bande passante,

  • forme distordue,

  • indications erronées aux endroits correspondant aux temps de départ et d'arrêt,

  • possibilité de rehaussement du niveau des lobes latéraux.

Cliquez sur les boutons ci-après pour accéder aux procédures de configuration de la sélection par porte dans le domaine temporel.

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Transform.

  2. Dans la boîte à liste Category, cliquez sur la flèche et sélectionnez Gating.

  3. Dans la boîte à liste Gate Type, sélectionnez le type de filtre de porte.

    • Choisissez Bandpass pour supprimer les réponses situées en dehors de la durée d'ouverture de la porte.

    • Choisissez Notch pour supprimer les réponses situées à l'intérieur de la durée d'ouverture de la porte.

  4. Dans la boîte à liste Gate Shape, sélectionnez la forme du filtre de porte. Il existe une durée d'ouverture minimale pour chaque forme de porte.

  5. Définissez les limites de la porte en utilisant soit les paramètres Start et Stop, soit les paramètres Center et Span.

  6. Cochez la case Gating pour activer la fonction de sélection par porte.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc de touches NAVIGATION, utilisez la touche Tab de droite et les touches fléchées pour accéder au menu Trace, puis à l'option Transform. Appuyez surClick.

  3. Appuyez sur la touche Tab de droite pour accéder à la boîte à liste Category, puis sur la flèche vers le bas pour sélectionner Gating.

  4. Appuyez sur la touche Tab de droite pour accéder à la boîte à liste Gate Type, puis sélectionnez le type de filtre de porte.

    • Choisissez Bandpass pour supprimer les réponses situées en dehors de la durée d'ouverture de la porte.

    • Choisissez Notch pour supprimer les réponses situées à l'intérieur de la durée d'ouverture de la porte.

  5. Appuyez sur la touche Tab de droite pour accéder à la boîte à liste Gate Shape, puis sélectionnez la forme du filtre de porte. Il existe une durée d'ouverture minimale pour chaque forme de porte. Pour plus de détails, voir Caractéristiques de la porte.

  6. Définissez les limites de la porte en utilisant soit les paramètres Start et Stop, soit les paramètres Center et Span.

  7. Appuyez sur la touche Tab de droite pour accéder à la case à cocher Gating et appuyez sur Click pour activer la fonction de sélection par porte.


Tdata

Voir aussi...

Données de mesure dans le domaine temporel

Présentation

Concepts

Comment interpréter les données temporelles

Pour vous aider à comprendre les réponses du composant dans le domaine temporel, cette rubrique présente des exemples de différents types de mesure.
Concepts

Comment interpréter les données de mesure dans le domaine temporel

Masquage

Mesure de la réflexion en mode passe-bande

Mesure de la transmission en mode passe-bande

Localisation des erreurs à l'aide du mode passe-bas

Mesure de la réflexion en mode passe-bas

Mesure de la transmission en mode passe-bas

Masquage

Comme le masquage affecte les réponses que vous visualisez dans une mesure dans le domaine temporel, il est utile de savoir de quoi il s'agit lorsque vous interprétez des données de mesure.

  • Le masquage se produit lorsqu'une discontinuité ou une perte à côté du plan de référence affecte la réponse de chacune des discontinuités suivantes.

  • L'énergie réfléchie ou absorbée par la première discontinuité n'atteint jamais la deuxième discontinuité ni les discontinuités suivantes.

  • Aussi, les réponses suivantes sont plus petites qu'elles ne l'auraient été si la première réponse n'avait pas été présente.

Masquage dû à la réflexion d'énergie

Le masquage dû à la réflexion se produit chaque fois qu'une désadaptation d'impédance survient. Ce phénomène de masquage est illustré dans l'exemple ci-dessous où l'impédance de ligne varie.

  • Une ligne de 50 ohms, connectée à une ligne à air de 25 ohms, connectée à une ligne de 50 ohms

  • La première discontinuité a un coefficient de réflexion d'environ 0,333 (ce qui est correct pour une impédance de 25 ohms)

  • A la fin de la section à 25 ohms, la réponse ne montre pas un coefficient de réflexion de 0,333 (comme elle le devrait à une impédance de 50 ohms). Comme indiqué par les deux marqueurs delta, leurs amplitudes présentent une différence de 35,355 mU. Cela est dû au fait que l'impulsion incidente sur la deuxième réponse a une amplitude de moins d'une unité en raison de l'énergie réflechie dans la première désadaptation d'impédance.

Masquage dû à l'absorption d'énergie

Le masquage dû à l'absorption d'énergie se produit lorsqu'un circuit à fort affaiblissement est mesuré. Ce phénomène de masquage est illustré dans l'exemple ci-après où un câble a pour terminaison un circuit ouvert.

  • La réponse du circuit ouvert présente une perte en réflexion de -2,445 dB à Marker 1 (affiché en format Log Mag).

  • La réponse attendue est la valeur type du circuit ouvert (0 dB).

  • La valeur du marqueur représente la somme des pertes vers l'avant et vers l'arrière.

Mesure de la réflexion en mode passe-bande

Données de l'axe horizontal

  • Durée nécessaire pour qu'une impulsion émise au port de test atteigne une discontinuité et soit réfléchie sur le port de test.

Données de l'axe vertical

  • Perte en réflexion (dB) si le format Log Mag est utilisé

  • Coefficient de réflexion (rho) si le format Lin Mag est utilisé

L'exemple suivant montre une mesure de réflexion en mode p asse-b ande :

  • Une impulsion est émise à l'instant zéro, qui représente le temps de propagation de la première discontinuité (connecteur) rencontrée à la sortie du port de test.

  • Les impulsions suivantes représentent la discontinuité (connecteur) suivante rencontrée par l'impulsion.

Mesure de la transmission en mode passe-bande

Données de l'axe horizontal

  • Délai de propagation à travers le composant sous test

Données de l'axe vertical

  • Perte ou gain de transmission (dB) si le format Log Mag est utilisé

  • Coefficient de transmission (rho) si le format Lin Mag est utilisé

L'exemple suivant montre une mesure de transmission en mode p asse-b ande :

  • Cet exemple montre comment ce mode peut fournir des informations sur différents trajets à l'intérieur d'un filtre SAW (onde acoustique de surface).

  • L'impulsion la plus proche de l'instant zéro représente le temps de propagation du plus court chemin entre l'entrée et la sortie du réseau. Il se peut que cela ne corresponde pas à la plus grande impulsion ou ne représente pas le chemin désiré.

  • Chacune des impulsions suivantes représente un autre chemin possible, de l'entrée à la sortie, qui s'avère être plus long.

Astuce : pour n'afficher que la réponse du chemin principal du filtre SAW, vous pouvez définir la porte de telle manière qu'elle bloque toutes les impulsions, sauf l'impulsion principale. Seule la réponse en fréquence du chemin principal s'affiche alors dans le domaine de fréquence.

Localisation des erreurs à l'aide du mode passe-bas

Le mode passe-bas permet de simuler la réponse TDR (Time Domain Reflectometer) du composant sous test. Cette réponse contient des informations permettant de déterminer quel type de discontinuité est présent.

Le diagramme ci-après montre les réponses passe-bas de discontinuités connues. Chacun des éléments du circuit a été simulé pour montrer le signal correspondant de la réponse S11 dans le domaine temporel passe-bas. Le mode passe-bas vous permet de visualiser une réponse à un stimulus transitoire ou impulsionnel.

Astuce : la réponse à un échelon vous permet d'identifier plus facilement les caractéristiques des discontinuités. Ce mode ressemble beaucoup aux mesures TDR traditionnelles.

Mesure de la réflexion en mode passe-bas

Données de l'axe horizontal

  • Durée nécessaire pour qu'une impulsion émise au port de test atteigne une discontinuité et soit réfléchie sur le port de test.

Remarque : pour déterminer la longueur physique réelle, entrez le coefficient de vitesse approprié.

Données de l'axe vertical

  • Coefficient de réflexion (r) si le format Real est utilisé

L'exemple ci-après montre la même mesure de réflexion en mode passe-bas, présentée avec une réponse en impulsion, sur laquelle se superpose une réponse à un échelon en format Log Mag.

  • L'exemple ci-après montre des mesures de réflexion en mode passe-bas de deux câbles différents en format Real.

  • La réponse passe-bas contient des informations sur la localisation de la discontinuité et le type d'impédance présent.

  • La mesure de gauche -- montre la réponse d'un câble serti présentant une discontinuité capacitive.

  • La mesure de droite -- montre la réponse d'un câble usé présentant une discontinuité inductive.

Mesure de la transmission en mode passe-bas

Données de l'axe horizontal

  • Durée moyenne du transit à travers un composant sur une plage de fréquence

  • R etard électrique d'un composant en temps

Données de l'axe vertical

  • Unités réelles (par exemple, des volts) si le format Real est utilisé

  • Perte ou gain de transmission (dB) si le format Log Mag est utilisé (pour le mode impulsionnel uniquement)

L'exemple ci-après montre la réponse à un échelon passe-bas d'un amplificateur.

  • Le temps moyen de propagation de groupe sur la plage de fréquence de mesure est la différence en temps entre le palier et la réponse de l'amplificateur.

  • Le temps de montée transitoire est proportionnel à la fréquence la plus élevée du balayage du domaine fréquentiel : plus la fréquence est élevée, plus le temps de montée est rapide.

  • Les oscillations transitoires dans la réponse de l'amplificateur dénotent une conception non amortie.

Astuce : pour la réponse à un échelon passe-bas, le format le plus utile est Real (unités de coefficient de réflexion). Pour Impulse, vous pouvez également utiliser le format Real. Cependant, pour que la meilleure p lage dynamique puisse simultanément visualiser les grandes et les petites discontinuités, utilisez le format Log Mag.

Cliquez sur les boutons ci-dessous pour accéder aux procédures de visualisation des résultats de mesure dans le domaine temporel.
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Réglez l'instant de début à –1 s pour visualiser les réponses en commençant par le port de test.

    1. Dans le menu Trace, cliquez sur Transform.

    2. Cliquez sur la zone Start et saisissez –1 s.

  2. Dans le menu Trace, cliquez sur Autoscale pour visualiser l'intégralité de la réponse de la mesure.

  3. Pour obtenir la résolution d'affichage maximale, centrez la réponse pertinente à l'écran et réduisez l'intervalle de temps.

    1. Dans le menu Trace, cliquez sur Transform.

    2. Cliquez sur la zone Start et saisissez –1 s.

  4. Si vous avez besoin d'améliorer la résolution de la réponse, vous pouvez modifier la fenêtre et les paramètres de la mesure. Voir Résolution et plage du domaine temporel.

  5. Pour déterminer le temps et la distance corrects pour les réponses, définissez le coefficient de vitesse correct.

    1. Dans le menu Scale, cliquez sur Electrical Delay.

    2. Dans la zone Velocity Factor, saisissez une valeur comprise entre 0 et 1,0.

      • vitesse de la lumière dans le vide = 1,0

      • Polyéthylène (la plupart des câbles) = 0,66

      • Téflon = 0,7

    3. Utilisez un marqueur pour visualiser la durée (x2) et la longueur électrique (x2) d'une discontinuité.

Remarque : pour déterminer la longueur physique, au lieu de la longueur électrique, remplacez le coefficient de vitesse par celui du composant sous test. Pour que les marqueurs lisent la distance aller réelle d'une discontinuité, au lieu de la distance aller-retour, saisissez la moitié du coefficient de vitesse réel.

  6. Si vous utilisez le mode passe-bas, déterminez l'amplitude et la phase d'un changement d'impédance. Voir Localisation des erreurs à l'aide du mode passe-bas.

A l'aide des touches de la face avant

  1. Réglez l'instant de début à –1 s pour visualiser les réponses en commençant par le port de test.

    1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

    2. Dans le bloc NAVIGATION, sélectionnez l'onglet de droite et appuyez sur les flèches pour sélectionner Transform sous le menu Trace. Appuyez sur Click.

    3. Sélectionnez l'onglet de droite pour accéder à la zone Start et saisissez –1 s.

  2. Dans le bloc TRACE SETUP, appuyez sur la touche F1 (Autoscale) pour visualiser l'intégralité de la réponse de la mesure.

  3. Pour obtenir la résolution d'affichage maximale, centrez la réponse pertinente à l'écran et réduisez l'intervalle de temps.

    1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

    2. Dans le bloc NAVIGATION, sélectionnez l'onglet de droite et appuyez sur les flèches pour sélectionner Transform sous le menu Trace. Appuyez sur Click.

    3. Sélectionnez l'onglet de droite pour accéder à la zone Center et entrez une valeur pour placer la réponse pertinente au centre de l'écran.

    4. Sélectionnez l'onglet de droite pour accéder à la zone Span et entrez une valeur pour réduire la bande d'analyse.

  4. Si vous avez besoin d'améliorer la résolution de la réponse, vous pouvez modifier la fenêtre et les paramètres de la mesure. Voir Résolution et plage du domaine temporel.

  5. Pour déterminer le temps et la distance corrects pour les réponses, définissez le coefficient de vitesse correct.

    1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

    2. Dans le bloc NAVIGATION, sélectionnez l'onglet de droite et appuyez sur la flèche vers le bas pour sélectionner Electrical Delay sous le menu Scale. Appuyez sur Click.

    3. Sélectionnez l'onglet de droite pour accéder à la zone Velocity Factor, puis saisissez une valeur comprise entre 0 et 1,0.

      • vitesse de la lumière dans le vide = 1,0

      • Polyéthylène (la plupart des câbles) = 0,66

      • Téflon = 0,7

    4. Utilisez un marqueur pour visualiser la durée (x2) et la longueur électrique (x2) d'une discontinuité.

Remarque : pour déterminer la longueur physique, au lieu de la longueur électrique, remplacez le coefficient de vitesse par celui du composant sous test. Pour que les marqueurs lisent la distance aller réelle d'une discontinuité, au lieu de la distance aller-retour, saisissez la moitié du coefficient de vitesse réel.

  6. Si vous utilisez le mode passe-bas, déterminez l'amplitude et la phase d'un changement d'impédance. Voir Localisation des erreurs à l'aide du mode passe-bas.


The Analyzer Object Model

See Also...

PNA Object Model

Click on an object box to view details.


Application Object

Description

The Application object is the highest object in the analyzer object model. This object presents methods and properties that affect the entire analyzer, rather than a specific channel or measurement. For example, the application object provides the GetIDString method. There's only one ID string for the instrument, unrelated to the channel or parameter being measured. Likewise, the TriggerSignal Property is global to the instrument. You can elect to use an internally generated (free run) trigger, or a manual trigger. Either way, that type of trigger generation will be used on all measurements, on all channels. Therefore, it is under the Application object.

This object is unique in that you must Create this object rather than just get a handle to it. See Getting a Handle to an Object.

Methods

Description

ActivateWindow

Makes a window object the Active Window.

AllowAllEvents

Monitors all events

AllowEventCategory

Monitors an event category

AllowEventMessage

Monitors an event

AllowEventSeverity

Monitors an event severity level

BuildHybridKit

Defines the user kit as port1kit + port2kit.

SetFailOnOverRange

Channel (object)

CreateMeasurement

Creates a new measurement.

CreateSParameter

Creates a new S-Parameter measurement.

DeleteShortCut

Removes a macro (shortcut) from the list of macros

DisallowAllEvents

Monitors NO events

DoPrint

Prints the screen to the active Printer.

ExecuteShortcut

Executes a macro (shortcut) stored in the analyzer.

GetShortcut

Returns the title and path of the specified macro (shortcut).

ManualTrigger

Triggers the analyzer when TriggerSignal = naTriggerManual.

Preset

Resets the analyzer to factory defined default settings.

PrintToFile

Saves the screen data to bitmap (.bmp) file of the screen.

PutShortcut

Puts a Macro (shortcut) file into the analyzer.

Quit

Ends the Network Analyzer application.

Recall

Restores all cal kits from disk.

RecallKits

Recalls the current state of the calibration kits on disk.

Reset

Removes all existing windows and measurements.

RestoreCalKitDefaults

Restores the factory defaults for the specified kit.

RestoreCalKitDefaultsAll

Restores the factory defaults for all kits.

Save

Saves all cal kits to disk.

SaveKits

Ends the Network Analyzer application.

SetFailOnOverRange

Causes over range values to return an error code

ShowStatusBar

Shows and Hides the Status Bar.

ShowStimulus

Shows and Hides Stimulus information.

ShowTitleBars

Shows and Hides the Title Bars.

ShowToolbar

Shows and Hides the specified Toolbar.

Properties

Description

ActiveCalKit

Returns a pointer to the kit identified by kitNumber.

ActiveChannel

Returns a handle to the Active Channel object.

ActiveMeasurement

Returns a handle to the Active Measurement object.

ActiveNAWindow

Returns a handle to the Active Window object.

ArrangeWindows

Sets or returns the arrangement of all the windows.

CalKitType

Sets the active cal kit.

Channels (collection)

ExternalALC

Sets or returns the source of the analyzer leveling control.

GPIBMode

Makes the analyzer the system controller or a talker/listener.

IDString

Returns the model, serial number and software revision of the analyzer

Measurements (collection)

MessageText

Returns a message for an eventID

NAWindows (collection)

Options

Returns the options on the analyzer

PortExtension (object)

ScpiStringParser (object)

SourcePowerState

Turns Source Power ON and OFF.

SystemImpedanceZ0

Sets the analyzer impedance value

TriggerSignal

Sets or returns the trigger source.

TriggerType

Sets or returns the scope of a trigger signal.

VelocityFactor

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

Visible

Makes the Network Analyzer application visible or not visible. (Default property of this object)

WindowState

Sets or returns the window setting of Maximized, Minimized, or Normal.

Events

Description

OnCalEvent

Triggered by a calibration event.

OnChannelEvent

Triggered by a channel event.

OnDisplayEvent

Triggered by a display event.

OnHardwareEvent

Triggered by a hardware event.

OnMeasurementEvent

Triggered by a measurement event.

OnSCPIEvent

Triggered by a SCPI event.

OnSystemEvent

Triggered by a system event.

OnUserEvent

For future use


Calibrator Object

Description

The Calibrator object is a child of the channel. It is a vehicle to perform calibration.

There must be a measurement present for the calibrator to use or you will receive an error (no measurement found). Therefore, to perform a 2-port cal, you must have any S-parameter measurement on the channel. For a 1-port measurement, you must have the measurement (S11 or S22) on the channel. And likewise for a response measurement.

With the calibrator object, you can take a number of approaches to calibration.You can collect data yourself and download it to the ACQUISITION buffer. The acquisition buffer holds the actual measured data for each standard.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Trigger a sweep

  4. Retrieve the data for the standard

  5. Download the data - calibrator.putStandard

  6. Repeat for each standard

  7. Calibrator.CalculateErrorCoefficients

You can tell the calibrator to acquire a standard. In this case, the calibrator collects the data and places it in the ACQUISITION buffer.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Calibrator.AcquireCalStandard

  4. Repeat for each standard

  5. Calibrator.CalcuateErrorCoefficients

You can put previously-retrieved error terms in the error correction buffer.

  1. PutErrorTerm

  2. Repeat for each term

  3. Measurement.caltype = pick one

You can also "piece together" a 2-port cal from two 1-port cals (S11 and S22) and four response (thru) cals. The system will detect that all the standards needed for a 2-port cal have been acquired even though they may not have gathered at the same time.

The ICalibrator methods can be used from VEE and VBScript as they use automation safe Variant Data. Use the ICalData interface for typed array passing.

Method

Description

AcquireCalStandard

Cause the analyzer to measure a calibration standard.

CalculateErrorCoeffecients

Generates Error Terms from standard and actual data in the error correction buffer.

DoECAL1Port

Completes a 1 port ECAL

DoECAL2Port

Completes a 2 port ECAL

GetECALModuleInfo

Returns information about the attached module

getErrorTerm

Retrieves error term data for the active calibration.

getStandard

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTerm

Puts error term data into the error-correction buffer for the active calibration.

putStandard

Puts data into the acquisition data buffer (before error-terms are applied)

setCalInfo

Specifies the type of calibration and prepares the internal state for the rest of the calibration.

Property

Description

AcquisitionDirection

Specifies the direction in a 2-Port cal

Simultaneous2PortAcquisition

Allows the use of 2 sets of standards at the same time.


CalKit Object

Description

The calkit object provides the properties and methods to access and modify a calibration kit. The calkitType property can be set from either the application object (app.calKitType) or the calKit object (calKit.calKitType). Both of these commands specify or read the calibration kit type. When specified, the cal kit also becomes the Active cal kit. However, to retrieve a pointer to the cal kit, use app.ActiveCalKit.

The calKit object behaves somewhat differently from other objects in the system in that you can only have a pointer to one cal kit (which is also the active calkit).

Therefore, when you change the calkitType (from either of these objects) you may also be changing the object to which you may have several references. This is different from the behavior for most other objects in the system.

For example, the following code specifies two calKitType and, in turn, assigns the "Active cal kit" to two different variables: ck1 and ck2.

Dim app As AgilentPNA835x.Application
Dim ck1 As calKit
Dim ck2 As calKit

Private Sub Form_Load()
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")
app.CalKitType = naCalKit_85032B_N50
Set ck1 = app.ActiveCalKit

app.CalKitType = naCalKit_85038A_7_16
Set ck2 = app.ActiveCalKit

Print "ck1: " & ck1.Name
Print "ck2: " & ck2.Name
End Sub

When the pointer to each of these kits is read (printed), they each have a pointer to the last kit to be assigned to the Active cal kit:

ck1: 7-16 Model 85038
ck2: 7-16 Model 85038

Method

Description

getCalStandard

Returns a handle to a calibration standard for modifying its definitions.

Property

Description

CalKitType

Sets and returns the cal kit type

Name

Sets and returns the name of the cal kit

PortLabel

Labels the ports for the kit; only affects the cal wizard annotation.

StandardForClass

Maps a standard device to a cal class.


CalStandard Object

Description

Contains all of the settings that are required to modify a calibration kit. Get a handle to a standard with the calkit.GetCalStandard Method.

Method

Description

None

Property

Description

C0

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

C1

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

C2

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

C3

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

Delay

Sets and Returns the electrical delay value for the calibration standard.

L0

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

L1

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

L2

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

L3

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

Label

Sets and Returns the label for the calibration standard.

loss

Sets and Returns the insertion loss for the calibration standard.

Maximum
Frequency

Sets and Returns the maximum frequency for the calibration standard.

Medium

Sets and Returns the media type of the calibration standard.

Minimum
Frequency

Sets and Returns the minumum frequency for the calibration standard.

Type

Sets and Returns the type of calibration standard.

Z0

Sets and Returns the characteristic impedance for the calibration standard.


Channel Object

Description

The channel object is like the engine that produces data. Channel settings consist of stimulus values like frequency, power, IF bandwidth, and number of points.

You can get a handle to a channel in a number of ways. But first you have to make sure that the channel exists. When you first startup the analyzer, there is one S11 measurement on channel 1. Thus there is only one channel in existence. You can do the following:

Dim chan as Channel
'
Set chan = pna.ActiveChannel

or

Set chan = pna.Channels( n )

The first method will return the channel object that is driving the active measurement. When you ask for the ActiveChannel, you get the channel that is driving the active measurement. If there is no measurement, there may not be a channel. Once a channel is created, it does not go away. So if there once was a measurement (hence a channel), the channel will still be available. If there is no channel you can create one in a couple ways. Here's one way:

Pna.CreateMeasurement( ch1, "S11", port1, window2)

Here's another:

Pna.Channels.Add (ch2)

The latter will have no visible effect on the analyzer. It will simply create channel 2 if it does not already exist.

Method

Description

Abort

Aborts the current measurement sweep on the channel.

AveragingRestart

Clears and restarts averaging of the measurement data.

Continuous

The channel continuously responds to trigger signals.

GetXAxisValues

Returns the channel's X-axis values into a dimensioned Variant array.

GetXAxisValues2

Returns the channel's X-axis values into a dimensioned NON-Variant array.

Hold

Puts the Channel in Hold - not sweeping.

Next_IFBandwidth

A function that returns the Next higher IF Bandwidth value.

NumberOfGroups

Sets the Number of trigger signals the channel will receive.

Preset

Resets the channel to factory defined settings.

PreviousIFBandwidth

Returns the previous IF Bandwidth value.

Single

Channel responds to one trigger signal from any source (internal, external, or manual). Then channel switches to Hold.

Property

Description

AlternateSweep

Sets sweeps to either alternate or chopped.

Attenuator

Sets or returns the value of the attenuator control for the specified port number.

AttenuatorMode

Sets or returns the mode of operation of the attenuator control for the specified port number.

Averaging

Turns trace averaging ON or OFF for all measurements on the channel.

AveragingFactor

Specifies the number of measurement sweeps to combine for an average.

Calibrator (object)

centerFrequency

Sets or returns the center frequency of the channel.

channelNumber

Returns the Channel number of the Channel or Measurement object.

CouplePorts

Turns ON and OFF port power coupling.

CWFrequency

Set the Continuous Wave (CW) frequency.

DwellTime

Sets or returns the dwell time for the channel.

FrequencySpan

Sets or returns the frequency span of the channel.

IFBandwidth

Sets or returns the IF Bandwidth of the channel.

NumberOfPoints

Sets or returns the Number of Points of the channel.

Parent

Returns a handle to the parent object of the channel.

PowerSlope

Sets or returns the Power Slope value.

ReceiverAttenuator

Sets or returns the value of the specified receiver attenuator control.

Segments (collection)

StartFrequency

Sets or returns the start frequency of the channel.

StartPower

Sets the start power of the analyzer when sweep type is set to Power Sweep.

StopFrequency

Sets or returns the stop frequency of the channel.

StopPower

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep.

SweepGenerationMode

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

SweepTime

Sets the Sweep time of the analyzer.

SweepType

Sets the type of X-axis sweep that is performed on a channel.

TestPortPower

Sets or returns the RF power level for the channel.

TriggerMode

Determines the measurement that occurs when a trigger signal is sent to the channel.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.


Channels Collection

Description

A collection object that provides a mechanism for iterating through the channels

Collections are, by definition, unordered lists of like objects. You cannot assume that Channels.Item(1) is always Channel 1. For more information, see Collections in the Analyzer.

Methods

Description

Add

An alternate way to create a measurement.

Item

Use to get a handle on a channel in the collection.

Properties

Description

Count

Returns the number of channels in the analyzer.

Parent

Returns a handle to the current Application.


Gating Object

Description

Contains the methods and properties that control Time Domain Gating

Methods

Description

None

Property

Description

Center

Sets or returns the Center time.

Shape

Specifies the shape of the gate filter.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

Stop

Sets or returns the Stop time.

Type

Specifies the type of gate filter used.


About Accessing Data

IArrayTransfer Object

Description

Contains methods for putting data in and getting data out of the analyzer using typed data. This interface transfers data more efficiently than the default IMeasurement Interface.

Method

Description

getComplex

Retrieves real and imaginary data from the specified buffer.

getNAComplex

Retrieves typed NAComplex data from the specified buffer.

getPairedData

Retrieves magnitude and phase data pairs from the specified buffer.

getScalar

Retrieves scalar data from the specified buffer.

putComplex

Puts real and imaginary data into the specified buffer.

putNAComplex

Puts typed NAComplex data into the specified buffer.

putScalar

Puts scalar data into the measurement result buffer.

Property

Description

None


About Accessing Data

ICalData Object

Description

Contains methods for putting Calibration data in and getting Calibration data out of the analyzer using typed data. This interface transfers data more efficiently than variant data.

Method

Description

getErrorTermComplex

Retrieves error term data

getStandardComplex

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTermComplex

Puts error term data

putStandardComplex

Puts calibration data into the aquisition data buffer (before error-terms are applied).

Property

Description

None


Limit Test Collection

Description

Child of the Measurement Object. A collection that provides a mechanism for iterating through the Measurement's LimitSegment objects (Limit Lines). The collection has 100 limit lines by default.

The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2 = Application.Measurement.LimitTest(4)

Methods

Description

GetTestResult

Retrieves the Pass/Fail results of the Limit Test (State).

Item

Use to get a handle on a limit line in the collection.

Properties

Description

Count

Returns the number of limit lines used in the measurement.

LineDisplay

Displays the limit lines on the screen.

SoundOnFail

Enables a beep on Limit Test fails.

State

Turns ON and OFF limit testing.


LimitSegment Object

Description

The LimitSegment object is an individual limit line. The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2=Application.Measurement.LimitTest(4)

Methods

Description

None

Properties

Description

BeginResponse

Specifies the Y-axis value that corresponds with Begin Stimulus (X-axis) value.

BeginStimulus

Specifies the beginning X-axis value of the Limit Line.

EndResponse

Specifies the Y-axis value that corresponds with End Stimulus (X-axis) value.

EndStimulus

Specifies the End X-axis value of the Limit Line.

Type

Specifies the Limit Line type.


Marker Object

Description

Contains the methods and properties that control Markers.

To turn ON a marker, you get a handle to the marker. You get a handle to a marker through the measurement object. (There is no markers collection).

If it is not already, this command will activate marker 1.

Measurement.marker(1).Format = naLinMag

You can also set the marker object to an object variable:

Dim m1 As Marker
Set m1 = meas.marker(1)

There are 10 markers available per measurement:

  • 1 reference marker

  • 9 markers for absolute data or data relative to the reference marker (delta markers).

There are two ways to control markers through COM.

  1. The Measurement object has properties that apply to all of the markers for that measurement.

  2. Marker object properties override the Measurement object properties. For example, meas.MarkerFormat = naLinMag applies formatting to all markers. You can then override that setting for an individual marker by specifying mark.Format = naLogMag on the marker object.

Methods

Description

Activate

Makes an object the Active Object.

SearchMax

Searches the marker domain for the maximum value.

SearchMin

Searches the marker domain for the minimum value.

SearchNextPeak

Searches the marker's domain for the next largest peak value.

SearchPeakLeft

Searches the marker's domain for the next VALID peak to the left of the marker.

SearchPeakRight

Searches the marker's domain for the next VALID peak to the right of the marker.

SearchTarget

Searches the marker's domain for the target value.

SearchTargetLeft

Moving to the left of the marker position, searches the marker's domain for the target value.

SearchTargetRight

Moving to the right of the marker position, searches the marker's domain for the target value.

SetCenter

Changes the analyzer's center frequency to the X-axis position of the marker.

SetCW

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

SetElectricalDelay

Changes the measurement's electrical delay to the marker's delay value.

SetReferenceLevel

Changes the measurement's reference level to the marker's Y-axis value.

SetStart

Changes the analyzer's start frequency to the X-axis position of the marker.

SetStop

Changes the analyzer's stop frequency to the X-axis position of the marker.

Property

Description

Bucket Number

Marker data point number

DeltaMarker

Makes a marker relative to the reference marker

Format

Linear, SWR, and so forth

Interpolated

Turn marker interpolation ON and OFF

Number

Read the number of the active marker

PeakExcursion

Sets and reads the peak excursion value for the specified marker.

PeakThreshold

Sets peak threshold for the specified marker.

SearchFunction

Emulates the Tracking function in the marker search dialog box.

Stimulus

Sets and reads the X-Axis value of the marker.

Target Value

Sets the target value for the marker when doing Target Searches.

Tracking

The tracking function finds the selected search function every sweep.

Type

Sets and reads the marker type.

UserRange

Assigns the marker to the specified User Range.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.

Value

Reads the Y-Axis value of the marker.


Measurement Object

Description

The Measurement object is probably the most used object in the model. A measurement object represents the chain of data processing algorithms that take raw data from the channel and make it ready for display, which then becomes the scope of the Trace object.

A Measurement object is defined by it's parameter (S11, S22, A/R1, B and so forth). The measurement object is associated with a channel in that a channel drives the hardware that produces the data that feeds the measurement. The root of a measurement is the raw data. This buffer of complex paired data then flows through a number of processing blocks: error-correction, trace math, phase correction, time domain, gating, formatting. All of these are controlled through the measurement object.

The active measurement determines what ever else is active. The active measurement is best described as the measurement that will be acted upon if you make a setting from the front panel. It is the measurement whose "button" is pressed in the window with the red "active window" frame. If you create a new measurement, that measurement becomes the active measurement.

Therefore, all automation methods with the word "Active" in them refer to the object associated with the Active measurement, whether that object is a Channel, Window, Trace or Limit line.

You can access two other objects through the Measurement object: markers and limit test. For example, because each measurement has its own set of markers, you can set a marker by doing this:

Dim meas as measurement
Set meas = pna.ActiveMeasurement
Meas.marker(1).Stimulus = 900e6
Meas.LimitTest.State = true ' on

Methods

Description

Activate

Makes an object the Active Object.

ActivateMarker

Makes a marker the Active Marker.

ChangeParameter

Changes the parameter of the measurement.

DataToMemory

Stores the active measurement into memory.

Delete

Deletes the measurement object.

DeleteAllMarkers

Deletes all of the markers from the measurement.

DeleteMarker

Deletes a marker from the active measurement.

GetData

Retrieves Complex data from analyzer memory

GetFilterStatistics

Returns all four Filter Statistics

GetReferenceMarker

Returns a handle to the reference marker.

GetTraceStatistics

Returns the Trace Statistics.

InterpolateMarkers

Turns All Marker Interpolation ON and OFF for the measurement.

putDataComplex

Puts complex data into one of five data buffers.

putDataScalar

Puts formatted variant data into the measurement results buffer.

SearchFilterBandwidth

Searches the domain with the current BW target.

Properties

Description

ActiveMarker

Returns a handle to the Active Marker object.

BandwidthTarget

The insertion loss value at which the bandwidth of a filter is measured.

BandwidthTracking

Turns Bandwidth Tracking function ON and OFF.

CalibrationType

Set or get the calibration type for the measurement.

channelNumber

Returns the channel number of a measurement.

ElectricalDelay

Sets electrical delay.

ErrorCorrection

Set or get the state of error correction for the measurement.

FilterBW

Returns the results of the SearchBandwidth method.

FilterCF

Returns the Center Frequency result of the SearchBandwidth method.

FilterLoss

Returns the Loss value of the SearchBandwidth method.

FilterQ

Returns the Q (quality factor) result of the SearchBandwidth method.

Format

Sets display format.

Gating (object)

InterpolateCorrection

Turns ON and OFF the calculation of new error terms when stimulus values change.

LimitTest (collection)

LimitTestFailed

Returns the results of limit testing

marker (object)

MarkerFormat

Sets or returns the format of all the markers in the measurement.

Mean

Returns the mean value of the measurement.

Name

Sets or returns the name of the measurement.

NAWindow (object)

Number

Returns the number of the measurement.

Parameter

Returns the measurement Parameter.

PeakToPeak

Returns the Peak to Peak value of the measurement.

PhaseOffset

Sets the Phase Offset for the active channel.

ReferenceMarkerState

Turns the reference marker ON or OFF

ShowStatistics

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

Smoothing

Turns ON and OFF data smoothing.

SmoothingAperture

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

StandardDeviation

Returns the standard deviation of the measurement.

StatisticsRange

Sets the User Range number for calculating measurement statistics.

Trace (object)

TraceMath

Performs math operations on the measurement object and the trace stored in memory.

Transform (object)

View

Sets (or returns) the type of trace displayed on the screen.


Measurements Collection

Description

A collection object that provides a mechanism for iterating through the Application measurements. See Collections in the Analyzer.

Methods

Description

Add

Adds a Measurement to the collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a measurement from the measurements collection.

Properties

Description

Count

Returns the number of measurements in the analyzer.

Parent

Returns a handle to the current Application.


NAWindow Object

Description

The NAWindow object controls the part of the display the contains the graticule, or what is written on the display.

Methods

Description

Autoscale

Autoscales all measurements in the window.

ShowMarkerReadout

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window object.

ShowTable

Shows or Hides the specified table for the active measurement in the lower part of the window object.

Property

Description

ActiveTrace

Sets a trace to the Active Trace.

Title

Writes or reads a custom title for the window.

TitleState

Turns ON and OFF the window title.

Traces (collection)

WindowState

Maximizes or minimizes a window.


NAWindows Collection

Description

A collection object that provides a mechanism for iterating through the Application windows. See Collections in the Analyzer.

Methods

Description

Add

Adds a window to the NAWindows collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a window from the NAWindows collection.

Properties

Description

Count

Returns the number of windows on the analyzer.

Parent

Returns a handle to the current Application.


Port Extension Object

Port Extensions Object

Description

Contains the methods and properties that control Port Extensions.

Methods

Description

None

Property

Description

Input A

Sets the Input A extension value.

Input B

Sets the Input B extension value.

Port 1

Sets the Port 1 extension value.

Port 2

Sets the Port 2 extension value.

State

Turns Port Extensions ON and OFF.


SCPIStringParser Object

Method

Description

Parse

Provides the ability to send a SCPI command from within the COM command.

Properties

Description

None


Segment Object

Description

Contains the methods and properties that affect a sweep segment.

You can get a handle to a sweep segment through the segments collection.[ segments.item(n).]

Methods

Description

None

Property

Description

centerFrequency

Sets or returns the center frequency of the segment.

DwellTime

Dwell time value.

FrequencySpan

Sets or returns the frequency span of the segment.

IFBandwidth

Sets or returns the IF Bandwidth of the segment.

NumberOfPoints

Sets or returns the Number of Points of the segment.

SegmentNumber

Returns the number of the current segment.

StartFrequency

Sets or returns the start frequency of the segment.

State

Turns On or OFF a segment.

StopFrequency

Sets or returns the stop frequency of the segment.

TestPortPower

Sets or returns the RF power level of the segment.


Segments Collection

Description

A collection object that provides a mechanism for iterating through the sweep segments of a channel.

Sweep segments are a potentially faster method of sweeping the analyzer through only the frequencies of interest. See Collections in the Analyzer

Methods

Description

Add

Adds an item to either the Segments collection.

Item

Use to get a handle to a segment in the collection..

Remove

Removes an item from a collection of objects.

Properties

Description

Count

Returns the number of items in a collection of objects.

IF Bandwidth Option

Enables the IFBandwidth to be set on individual sweep segments.

Parent

Returns a handle to the current naNetworkAnalyzer application..

Source Power Option

Enables setting the Source Power for a segment.


Trace Object

Description

The Trace object takes measurement data and control how the data is painted on the display. You can control scale, reference position, and reference line from the Trace Object.

Methods

Description

Autoscale

Autoscales the trace or all of the traces in the selected window.

Property

Description

Name

Sets or returns the trace name

ReferencePosition

Sets or returns the Reference Position of the active trace.

ReferenceValue

Sets or returns the value of the Y-axis Reference Level of the active trace.

YScale

Sets or returns the Y-axis Per-Division value of the active trace.


Traces Collection

Description

Child of the Application Object. A collection that provides a mechanism for getting a handle to a trace or iterating through the traces in a window.

Methods

Description

Item

Use to get a handle to a trace

Properties

Description

Count

Returns the number of traces in the collection.

Parent

Returns a handle to the current Application.


Transform Object

Description

Contains the methods and properties that control Time Domain transforms.

Methods

Description

SetFrequencyLowPass

Sets low frequencies for low pass.

Property

Description

Center

Sets or returns the Center time.

ImpulseWidth

Sets or returns the Impulse Width of Time Domain transform windows.

KaiserBeta

Sets or returns the Kaiser Beta of Time Domain transform windows.

Mode

Sets the type of transform.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

StepRiseTime

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

Stop

Sets or returns the Stop time.


About Performing a Calibration

AcquisitionDirection Property

Read / Write

Description

Specifies the direction of each part of a 2-port calibration.

VB Syntax

cal.AcquisitionDirection = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(enum NADirection) - Choose from:

0 - naForward - measures the forward direction
1 - naReverse - measures the reverse direction

Return Type

Long Integer

Default

naForward

Examples

cal.AcquisitionDirection = naForward

C++ Syntax

HRESULT AcquisitionDirection(tagNADirection dir)

Interface

ICalibrator


Active Cal Kit Property

About Calibration Kits

ActiveCalKit Property

Read-only

Description

Returns a handle to the Active CalKit object. You can either (1) use the handle directly to access CalKit properties and methods, or (2) set a variable to the CalKit object. The variable retains a handle to the original object if another CalKit becomes active.

VB Syntax

1) app.ActiveCalKit.<setting>
or
2) Set cKit = app.ActiveCalKit

Variable

(Type) - Description

app

(object) - An Application object

<setting>

A CalKit property (or method) and arguments

cKit

(object) - A CalKit object

Return Type

CalKit object

Default

None

Examples

Public cKit as calKit
Set cKit = app.ActiveCalKit 'read

C++ Syntax

HRESULT get_ActiveCalKit (ICalkit * kit)

Interface

IApplication


Active Channel Property

About Channels

ActiveChannel Property

Read-only

Description

Returns a handle to the Active Channel object. You can either (1) use the handle directly to access channel properties and methods, or (2) set a variable to the channel object. The variable retains a handle to the original channel if another channel becomes active.

VB Syntax

(1) app.ActiveChannel.<setting>
or
(2) Set chan = app.ActiveChannel

Variable

(Type) - Description

chan

A Channel (object)

app

An Application (object)

<setting>

A channel property (or method) and arguments

Return Type

Channel object

Default

Not applicable

Examples

1) app.ActiveChannel.Averaging = 1
2) Public chan as Channel
Set chan = app.ActiveChannel

C++ Syntax

HRESULT get_ActiveChannel( IChannel* *pVal)

Interface

IApplication


About Markers

ActiveMarker Property

Read-only

Description

Returns a handle to the Active Marker object. You can either (1) use the handle directly to access Marker properties and methods, or (2) set a variable to the Marker object. The variable retains a handle to the original object if another Marker becomes active.

VB Syntax

1) meas.ActiveMarker.<setting>
or
2) Set mark = meas.ActiveMarker

Variable

(Type) - Description

meas

(object) - An Measurement object

<setting>

A marker property (or method) and arguments

mark

(object) - A marker object

Return Type

marker object

Default

None

Examples

Public mark as marker
Set mark = meas.ActiveMarker

C++ Syntax

HRESULT get_ActiveMarker(IMarker** marker)

Interface

IMeasurement


Active Measurement Property

About Measurement Parameters

ActiveMeasurement Property

Read-only

Description

Returns a handle to the Active Measurement object. You can either (1) use the handle directly to access measurement properties and methods, or (2) set a variable to the measurement object. The variable retains a handle to the original measurement.

VB Syntax

1) app.Active Measurement.<setting>
or
2) Set meas = app.Active Measurement

Variable

(Type) - Description

meas

A Measurement (object)

app

An Application (object)

<setting>

A measurement property (or method) and arguments

Return Type

Measurement object

Default

None

Examples

1) app.ActiveMeasurement.Averaging = 1
2) Public meas as Measurement
Set meas = app.ActiveMeasurement

C++ Syntax

HRESULT get_ActiveMeasurement(IMeasurement **ppMeas)

Interface

IApplication


About Windows

ActiveNAWindow Property

Read-only

Description

Returns a handle to the Active Window object. You can either (1) use the handle directly to access window properties and methods, or (2) set a variable to the window object. The variable retains a handle to the original window if another window becomes active.

VB Syntax

1) app.ActiveNAWindow.<setting>
or
2) Set win = app.ActiveNAWindow

Variable

(Type) - Description

win

A NAWindow (object)

app

An Application (object)

<setting>

A NAWindow property (or method) and arguments

Return Type

A NAWindow object

Default

Not applicable

Examples

Public win as NAWindow
Set win = app.ActiveWindow

C++ Syntax

HRESULT get_ActiveNAWindow(INAWindow **ppWindow)

Interface

IApplication


Active Trace Property

About Traces

ActiveTrace Property

Read-only

Description

Returns a handle to the Active Trace object. You can either (1) use the handle directly to access trace properties and methods, or (2) set a variable to the trace object. The variable retains a handle to the original trace if another trace becomes active.

VB Syntax

1) win.ActiveTrace.<setting>
or
2) Set trce = win.ActiveTrace

Variable

(Type) - Description

trce

A Trace (object)

win

An NAWindow (object)

<setting>

A trace property (or method) and arguments

Return Type

An NAWindow object

Default

None

Examples

1) win.ActiveTrace.Autoscale
2) Public trce as Trace
Set trce = Application.ActiveNAWindow.ActiveTrace

C++ Syntax

HRESULT get_ActiveTrace(ITrace* *pVal)

Interface

INAWindow


Alternate Sweep Property

About Sweeping

AlternateSweep Property

Write/Read

Description

Sets sweeps to either alternate or chopped.

VB Syntax

chan.AlternateSweep = value

Variable

(Type) - Description

chan

A Channel (object)

value

(boolean) - Choose either:

False (0) - Sweep mode set to Chopped - reflection and transmission are measured on the same sweep.
True (1) - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases cycle time.

Return Type

boolean

Default

False (0)

Examples

chan.AlternateSweep = True 'Write

altSwp = chan.AlternateSweep 'Read

C++ Syntax

HRESULT AlternateSweep(VARIANT_BOOL *pVal)
HRESULT AlternateSweep(VARIANT_BOOL newVal)

Interface

IChannel


Application Property

Read-only

Description

Returns the name of the Analyzer making measurements on the channel.

VB Syntax

chan.Application

Variable

(Type) - Description

chan

A Channel (object)

Return Type

object

Default

None

Examples

rfna = chan.Application 'returns the Analyzer name

C++ Syntax

HRESULT get_Application(IApplication** Application)

Interface

IChannel


Arrange Windows Property

About Arrange Windows

ArrangeWindows Property

Write/Read

Description

Sets or returns the arrangement of all the windows. Overlay, Stack2, Split3 and Quad4 will create windows.

To control the state of the one window you have a handle to, use app.WindowState.

VB Syntax

app.ArrangeWindows = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAWindowModes) - Choose from:

0 - naTile
1 - naCascade
2 - naOverlay
3 - naStack2
4 - naSplit3
5 - naQuad4

Return Type

NAWindowModes

Default

naTile

Examples

app.ArrangeWindow = naTile 'Write

arrWin = app.ArrangeWindows 'Read

C++ Syntax

HRESULT put_ArrangeWindows(tagNAWindowModes newVal)

Interface

IApplication


Attenuator Mode Property

About Attenuation

AttenuatorMode Property

Write/Read

Description

Sets or returns the mode of operation of the attenuator control for the specified port number. This command is automatically set to Manual when an Attenuator value is set.

VB Syntax

chan.AttenuatorMode(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long) - Port number (1 or 2) of attenuator control to be changed.

value

(enum NAModes) - Choose from:

0 - naAuto - Attenuator control set to automatic. The analyzer will set the attenuator control appropriately to deliver the specified power at the source.

1 - naManual - Specify the attenuator setting using chan.Attenuator (which automatically sets AttenuatorMode = naManual.

Return Type

NAModes

Default

0 - Auto

Examples

chan.Attenuator(1) = naAuto 'Write

attn = chan.AttenuatorMode(1) 'Read

C++ Syntax

HRESULT get_AttenuatorMode(long port, tagNAModes* pVal)
HRESULT put_AttenuatorMode(long port, tagNAModes newVal)

Interface

IChannel


About Attenuation

Attenuator Property

Write/Read

Description

Sets or returns the value of the attenuator control for the specified port number. Sending this command automatically sets AttenuatorMode to Manual.

VB Syntax

chan.Attenuator(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long integer) - Port number (1 or 2) of attenuator control to be changed.

value

(double) - Attenuator value in dB in 10dB steps. Choose any Long Integer between 0 and 70

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 10 dB attenuation.

Return Type

Double

Default

20 dB

Examples

chan.Attenuator(1) = 20 'Write

attn = chan.Attenuator(cnum) 'Read

C++ Syntax

HRESULT get_Attenuator(long port, double *pVal)
HRESULT put_Attenuator(long port, double newVal)

Interface

IChannel


Averaging Factor Property

About Averaging

AveragingFactor Property

Write/Read

Description

Specifies the number of measurement sweeps to combine for an average. Must also turn averaging ON by setting chan.Averaging = 1. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.AveragingFactor = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Long Integer) - Number of measurement sweeps to average. Choose any number between 1 and 1024.

Return Type

Long Integer

Default

1

Examples

chan.AveragingFactor = 5 'Write

avgfact = chan.AveragingFactor ' doesn't work -Read

C++ Syntax

HRESULT get_AveragingFactor(long *pVal)
HRESULT put_AveragingFactor(long newVal)

Interface

IChannel


About Averaging

Averaging Property

Write/Read

Description

Turns trace averaging ON or OFF for all measurements on the channel. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.Averaging = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns averaging OFF
1 - Turns averaging ON

Return Type

Boolean

Default

0

Examples

chan.Average = 1 'Write

averg = chan.Averaging 'Read

C++ Syntax

HRESULT get_Averaging(BOOL *pVal)
HRESULT put_Averaging(BOOL newVal)

Interface

IChannel


Bandwidth Target Property

About Marker Search

BandwidthTarget Property

Write/Read

Description

Sets the insertion loss value at which the bandwidth of a filter is measured (using BandwidthTracking or SearchFilterBandwidth). For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set BandwidthTarget to -3.

VB Syntax

meas.BandwidthTarget = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(single) - Target value. Choose any number between -500 and 500

Return Type

Single

Default

-3

Examples

meas.BandwidthTarget = -3 'Write

fbw = meas.BandwidthTarget 'Read

C++ Syntax

HRESULT put_BandwidthTarget(float target)
HRESULT get_BandwidthTarget(float* target)

Interface

IMeasurement


Bandwidth Tracking Property

About Marker Search

BandwidthTracking Property

Write/Read

Description

Searches continually (every sweep) for the current BandwidthTarget (default is -3). To search the filter bandwidth for ONE SWEEP only (not continually), use meas.SearchFilterBandwidth.

This feature uses markers 1-4. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To restrict the search to a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.BandwidthTracking = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
1 - Turns bandwidth tracking ON
0 - Turns bandwidth tracking OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.BandwidthTracking = 1 'Write

bwtrack = meas.BandwidthTracking 'Read

C++ Syntax

HRESULT put_BandwidthTracking(VARIANT_BOOL state)
HRESULT get_BandwidthTracking(VARIANT_BOOL* state)

Interface

IMeasurement


Calibration Type (applied) Property

About Performing a Calibration

CalibrationType Property

Write/Read

Description

Specifies the type of calibration to perform or apply to the measurement.

VB Syntax

meas.CalibrationType = type

Variable

(Type) - Description

meas

A Measurement (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Return Type

NACalType

Default

naCalType_None

Examples

meas.CalibrationType = naCalType_Response_Open 'Write

meascal = meas.CalibrationType 'Read

C++ Syntax

HRESULT put_CalibrationType (tagNACalType CalType)
HRESULT get_CalibrationType (tagNACalType* pCalType)

Interface

IMeasurement


About Gating

Center Property

Write/Read

Description

Sets or returns the Center time of either Gating or Time Domain transform windows

VB Syntax

object.Center = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Center time in seconds. Choose any number between:
± (points-1) / frequency span

Return Type

Double

Default

0

Examples

trans.Center = 4.5e-9 'sets the Center time of a transform window -Write
gate.Center = 4.5e-9 'sets the Center time of a gating window -Write

cnt = trans.Center 'Read

C++ Syntax

HRESULT get_Center(double *pVal)
HRESULT put_Center(double newVal)

Interface

ITransform
IGating


CenterFreq Property

About Frequency

CenterFrequency Property

Write/Read

Description

Sets or returns the center frequency of the channel
or
Sets or returns the center frequency of the segment.

VB Syntax

object.centerFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Center frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Center of the frequency range

Examples

chan.centerFrequency = 4.5e9 'sets the center frequency of a linear sweep for the channel object -Write

centfreq = chan.centerFrequency 'Read

C++ Syntax

HRESULT get_CenterFrequency(double *pVal)
HRESULT put_CenterFrequency(double newVal)

Interface

IChannel
ISegment


Channel Number Property

About Channels

ChannelNumber Property

Read-only

Description

Returns the Channel number of the Channel or Measurement object.

VB Syntax

object.ChannelNumber

Variable

(Type) - Description

object

A Channel (object)
or
A Measurement (object)

Return Type

Long Integer

Default

Not applicable

Examples

chanNum = chan.ChannelNumber 'returns the channel number
chanNum = meas.ChannelNumber 'returns the channel number of the measurement

C++ Syntax

HRESULT get_ChannelNumber(long *pVal)

Interface

IChannel
IMeasurement


About Modifying Cal Kits

C0 Property

Write/Read

Description

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

To set the other inductance values, use C1, C2, C3

VB Syntax

calstd.C0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C0 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C0 = 15 'Write the value of C0 to 15picofarads

cap0 = calstd.C0 'Read the value of C0

C++ Syntax

HRESULT get_C0(float *pVal)
HRESULT put_C0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C1 Property

Write/Read

Description

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

To set the other inductance values, use C0, C2, C3

VB Syntax

calstd.C1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C1 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C1 = 15 'Write the value of C1 to 15picofarads

cap1 = calstd.C1 'Read the value of C1

C++ Syntax

HRESULT get_C1(float *pVal)
HRESULT put_C1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C2 Property

Write/Read

Description

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C3

VB Syntax

calstd.C2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C2 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C2 = 15 'Write the value of C2 to 15picofarads

cap2 = calstd.C2 'Read the value of C2

C++ Syntax

HRESULT get_C2(float *pVal)
HRESULT put_C2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C3 Property

Write/Read

Description

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C2

VB Syntax

calstd.C3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C3 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C3 = 15 'Write the value of C3 to 15picofarads

cap3 = calstd.C3 'Read the value of C3

C++ Syntax

HRESULT get_C3(float *pVal)
HRESULT put_C3(float newVal)

Interface

ICalStandard


Count Property

Read-only

Description

Returns the number of items in a collection of objects.

VB Syntax

object.Count

Variable

(Type) - Description

object

Any of the following (objects):

Channels collection
LimitTest collection
Measurements collection
NAWindows collection
Traces collection
Segments collection

Return Type

Long Integer

Default

Not applicable

Examples

numofchans = chans.Count 'return the number of channels -Read

C++ Syntax

HRESULT get_Count(long *p<interface>)

Interface

IChannels
ILimitTest
IMeasurements
NAWindows
ITraces
ISegments


Couple Ports Property

About Power Coupling

CouplePorts Property

Write/Read

Description

Turns ON and OFF port power coupling. ON means the power level is the same for both ports. OFF means the power level may be set independently for each port.

VB Syntax

chan.CouplePorts = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NAStates) Choose from:
NaOff - Turns coupling OFF
NaOn - Turns coupling ON

Return Type

Long Integer
1 - ON
0 - OFF

Default

NaON (1)

Examples

chan.CouplePorts = NaOff 'Write

couplport = chan.CouplePorts 'Read

C++ Syntax

HRESULT get_CouplePorts(tagNAStates *pState)
HRESULT put_CouplePorts(tagNAStates newState)

Interface

IChannel


About CW Frequency

CW Frequency Property

Write/Read

Description

Set the Continuous Wave (CW) frequency. Must first send chan.SweepType = naCWTimeSweep

VB Syntax

chan.CWFrequency = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) CW frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer
Units are Hz

Return Type

Double

Default

1e9

Examples

chan.CWFrequency = 5e9 'Write

cwfreq = chan.CWFrequency 'Read

C++ Syntax

HRESULT put_CWFrequency(double newVal)
HRESULT get_CWFrequency(double *pVal)

Interface

IChannel


About Modifying Cal Kits

Delay Property

Write/Read

Description

Sets and Returns the electrical delay value for the calibration standard.

VB Syntax

calstd.Delay = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Electrical delay in seconds

Return Type

Single

Default

Not Applicable

Examples

calstd.Delay = .00015 'Write the Delay .00015 seconds

stdDelay = calstd.Delay 'Read the value of Delay

C++ Syntax

HRESULT get_Delay(float *pVal)
HRESULT put_Delay(float newVal)

Interface

ICalStandard


About Data Format

Format Property

Write/Read

Description

Sets or returns the display format of the measurement.

VB Syntax

meas.Format = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NADataFormat) - Choose from:

0 - naDataFormat_LinMag
1 - naDataFormat_LogMag
2 - naDataFormat_Phase
3 - naDataFormat_Polar
4 - naDataFormat_Smith
5 - naDataFormat_Delay
6 - naDataFormat_Double
7 - naDataFormat_Imaginary
8 - naDataFormat_SWR

Return Type

Long Integer

Default

1 - naDataFormat_LogMag

Examples

app.TriggerMode = naTriggerModePoint 'Write

fmt = meas.Format 'Read

C++ Syntax

HRESULT get_Format(tagDataFormat *pVal)
HRESULT put_Format(tagDataFormat newVal)

Interface

IMeasurement


Dwell Time Property

About Dwell Time

DwellTime Property

Write/Read

Description

Sets or returns the dwell time at the start of each sweep point for all measurements in a channel. Dwell time is only available with Chan.SweepGenerationMode = naSteppedSweep (not naAnalogSweep).

Sets or returns the dwell time of a specified sweep segment.

VB Syntax

object.DwellTime = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - Dwell Time in seconds. Choose any number between:
0 and 100e-3

Return Type

Double

Default

0

Examples

chan.DwellTime = 3e-3 'sets the dwell time for the channel -Write

segs(3).CenterFrequency = 1e9 'sets the dwell time of segment 3 -Write

dwell = chan.DwellTime 'Read

C++ Syntax

HRESULT get_DwellTime(double *pVal)
HRESULT put_DwellTime(double newVal)

Interface

IChannel
ISegment


Electrical Delay Property

About Electrical Delay

ElectricalDelay Property

Write/Read

Description

Sets the Electrical Delay for the active channel.

VB Syntax

meas.ElectricalDelay = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Electrical Delay in seconds. Choose any number between -9.99 and 9.99

Return Type

Double

Default

0

Examples

meas.ElectricalDelay = 1e-3 'Write

edelay = meas.ElectricalDelay 'Read

C++ Syntax

HRESULT get_ElectricalDelay(double *pVal)
HRESULT put_ElectricalDelay(double newVal)

Interface

IMeasurement


Error Correction Property

About Performing a Calibration

ErrorCorrection Property

Write/Read

Description

Sets (or returns) error correction ON or OFF for the measurement.

VB Syntax

meas.ErrorCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
0 - Turns error correction OFF
1 - Turns error correction ON

Return Type

Boolean

Default

Not Applicable

Examples

meas.ErrorCorrection = 1 'Write

errcorr = meas.ErrorCorrection 'Read

C++ Syntax

HRESULT put_ErrorCorrection (VARIANT_BOOL bState)
HRESULT get_ErrorCorrection (VARIANT_BOOL *bState)

Interface

IMeasurement


External ALC Property

ExternalALC Property

Write/Read

Description

Sets or returns the source of the analyzer leveling control.

VB Syntax

app.ExternalALC = value

Variable

(Type) - Description

app

An Application (object)

value

(boolean) - Choose from:
True (or 1) - Leveling control supplied through the rear panel.
False (or 0) - Leveling control supplied inside the analyzer

Return Type

Boolean

Default

0

Examples

app.ExternalALC = True 'Write

extALC = app.ExternalALC 'Read

C++ Syntax

HRESULT get_ExternalALC(VARIANT_BOOL *pVal)
HRESULT put_ExternalALC(VARIANT_BOOL newVal)

Interface

IApplication


Filter BW Property

About Marker Search

FilterBW Property

Read-only

Description

Returns the results of the SearchBandwidth method.

VB Syntax

filtBW = meas.FilterBW

Variable

(Type) - Description

filtBW

(single) - Variable to store bandwidth data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterBW = meas.FilterBW 'Read

C++ Syntax

HRESULT get_FilterBW(float* bw)

Interface

IMeasurement


Filter CF Property

About Marker Search

FilterCF Property

Read-only

Description

Returns the Center Frequency result of the SearchBandwidth method.

VB Syntax

filtCF = meas.FilterCF

Variable

(Type) - Description

filtCF

(double) - Variable to store bandwidth CF data

meas

A Measurement (object)

Return Type

Double

Default

Not applicable

Examples

filtCF = meas.FilterCF 'Read

C++ Syntax

HRESULT get_FilterCF(double* centerFrequency)

Interface

IMeasurement


Filter Loss Property

About Marker Search

FilterLoss Property

Read-only

Description

Returns the Loss value of the SearchBandwidth method.

VB Syntax

filtLoss = meas.FilterLoss

Variable

(Type) - Description

filtLoss

(single) - Variable to store bandwidth Loss data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterLoss = meas.FilterLoss 'Read

C++ Syntax

HRESULT get_FilterLoss(float* loss)

Interface

IMeasurement


Filter Q Property

About Marker Search

FilterQ Property

Read-only

Description

Returns the Q (quality factor) result of the SearchBandwidth method.

VB Syntax

filtQ = meas.FilterQ

Variable

(Type) - Description

filtQ

(single) - Variable to store bandwidth Q data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filtQ = meas.FilterQ 'Read

C++ Syntax

HRESULT get_FilterQ(float* quality)

Interface

IMeasurement


Frequency Span Property

About Frequency Range

FrequencySpan Property

Write/Read

Description

Sets or returns the frequency span of the channel.

Sets or returns the frequency span of the segment.

VB Syntax

object.FrequencySpan = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Frequency span in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Full frequency span of the analyzer

Examples

chan.FrequencySpan = 4.5e9 'sets the frequency span of a linear sweep for the channel object -Write

freqspan = chan.FrequencySpan 'Read

C++ Syntax

HRESULT get_FrequencySpan(double *pVal)
HRESULT put_FrequencySpan(double newVal)

Interface

IChannel
ISegment


About Gate Filter

Shape Property

Write/Read

Description

Specifies the shape of the gate filter.

VB Syntax

gat.Shape = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateShape) - Choose from:

0 - naGateShapeMaximum
1 - naGateShapeWide
2 - naGateShapeNormal
3 - naGateShapeMinimum

Return Type

NAGateShape

Default

2 - Normal

Examples

gat.Shape = naGateShapeMaximum 'Write

filterShape = gat.Shape 'Read

C++ Syntax

HRESULT get_Shape(tagNAGateShape *pVal)
HRESULT put_Shape(tagNAGateShape newVal)

Interface

IGating


Type (Gate) Property

About Time Domain

Type Property

Write/Read

Description

Specifies the type of gate filter used.

VB Syntax

gat.Type = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateType) - Choose from:
naGateTypeBandpass - Includes (passes) the range between the start and stop times.
naGateTypeNotch - Excludes (attenuates) the range between the start and stop times.

Return Type

NAGateType

Default

Bandpass

Examples

gate.Type = naGateTypeNotch 'Write

filterType = gate.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAGateType *pVal)
HRESULT put_Type(tagNAGateType newVal)

Interface

IGating


About GPIB Fundamentals

GPIBMode Property

Write/Read

Description

Changes the analyzer to a GPIB system controller or a talker/listener on the bus. The analyzer must be the controller if you want to use it to send commands to other instruments. The analyzer must be a talker/listener if you want to send it commands from another PC.

VB Syntax

app.GPIBMode value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAGPIBMode) -Choose either:
0 - naTalkerListener - the analyzer is a talker / listener
1 - naSystemController - the analyzer is the system controller

Return Type

Long Integer

Default

0 - naTalkerListener

Examples

app.GPIBMode = naTalkerListener 'Write

mode = app.GPIBMode 'Read

C++ Syntax

HRESULT get_ScpiMode(tagScpiModeEnum* eScpiMode)
HRESULT put_ScpiMode(tagScpiModeEnum eScpiMode)

Interface

IApplication


IDString Property

Read-only

Description

Returns the ID of the analyzer, including the Model number, Serial Number, and the Software revision number.

VB Syntax

value = app.IDString

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned ID string

Return Type

String

Default

Not Applicable

Examples

id = app.IDString

C++ Syntax

HRESULT IDString(BSTR* IDString)

Interface

IApplication


IF Bandwidth Option Property

About Segment Sweep

IFBandwidthOption Property

Write/Read

Description

Enables the IFBandwidth to be set on individual sweep segments. This property must be set True before seg.IFBandwidth = value is sent. Otherwise, this command will be ignored.

VB Syntax

segs.IFBandwidthOption = value

Variable

(Type) - Description

segs

A Segments collection (object)

value

(boolean)
True - Enables variable IFBandwidth setting for segment sweep
False - Disables variable IFBandwidth setting for segment sweep

Return Type

Boolean

Default

False

Examples

segs.IFBandwidthOption = True 'Write

IFOption = IFBandwidthOption 'Read

C++ Syntax

HRESULT get_IFBandwidthOption(VARIANT_BOOL *pVal)
HRESULT put_IFBandwidthOption(VARIANT_BOOL newVal)

Interface

ISegments


IF Bandwidth Property

About IF Bandwidth

IFBandwidth Property

Write/Read

Description

Sets or returns the IF Bandwidth of the channel.
Sets or returns the IF Bandwidth of the segment.

VB Syntax

object.IFBandwidth = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - IF Bandwidth in Hz. Choose from:

1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1000 | 1500 | 2000 | 3000 | 5000 | 7000 | 10000 | 15000 | 20000 | 30000 | 35000 | 40000 |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Return Type

Double

Default

3500

Examples

chan.IFBandwidth = 3e3 'sets the IF Bandwidth of for the channel object to 3 kHz. -Write
seg.IFBandwidth = 5 'sets the IF Bandwidth of the segment to 5 Hz. -Write

ifbw = chan.IFBandwidth -Read

C++ Syntax

HRESULT get_IFBandwidth(double *pVal)
HRESULT put_IFBandwidth(double newVal)

Interface

IChannel
ISegment


Impulse Width Property

About Time Domain

ImpulseWidth Property

Write/Read

Description

Sets or returns the Impulse Width of Time Domain transform windows

VB Syntax

trans.ImpulseWidth = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Impulse Width in seconds. Range of settings depends on the frequency range of your analyzer.

Return Type

Double

Default

.98 / Default Span

Examples

trans.ImpulseWidth = 200e-12 'sets the Impulse width of a transform window -Write

IW = trans.ImpulseWidth 'Read

C++ Syntax

HRESULT get_ImpulseWidth(double *pVal)
HRESULT put_ImpulseWidth(double newVal)

Interface

ITransform


Input A Property

About Port Extensions

InputA Property

Write/Read

Description

Sets a Port Extension value for Receiver A

VB Syntax

portExt.InputA = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputA = 10e-6 'Write

inA = portExt.InputA 'Read

C++ Syntax

HRESULT get_InputA(double *pVal)
HRESULT put_InputA(double newVal)

Interface

IPortExtension


Input B Property

About Port Extensions

InputB Property

Write/Read

Description

Sets the Port Extension value for Receiver B

VB Syntax

portExt.InputB = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputB = 10e-6 'Write

inB = portExt.InputB 'Read

C++ Syntax

HRESULT get_InputB(double *pVal)
HRESULT put_InputB(double newVal)

Interface

IPortExtension


About Interpolation

Interpolate Correction Property

Write/Read

Description

Turns ON and OFF correction interpolation which calculates new error terms when stimulus values change after calibration.

When this property is ON and error correction is being applied, the calibration subsystem attempts to interpolate the error terms whenever the stimulus parameters are changed.

When this property is OFF under the same circumstances, error correction is turned OFF.

VB Syntax

meas.InterpolateCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Choose from:

True - Turns correction interpolation ON
False - Turns correction interpolation OFF

Return Type

Boolean

Default

True

Examples

meas.InterpolateCorrection = False

calInterpolate = InterpolateCorrection 'Read

C++ Syntax

HRESULT get_InterpolateCorrection(boolean *pVal)
HRESULT put_InterpolateCorrection(boolean newVal)

Interface

IMeasurement


Kaiser Beta Property

About Time Domain

KaiserBeta Property

Write/Read

Description

Sets or returns the Kaiser Beta of Time Domain transform windows

VB Syntax

trans.KaiserBeta = value

Variable

(Type) - Description

trans

A Transform (object)

value

(single) - Kaiser Beta. Choose any number between 0 and 13.

Return Type

Single

Default

0

Examples

trans.KaiserBeta = 6 'sets the Kaiser Beta of a transform window -Write

KB = trans.KaiserBeta 'Read

C++ Syntax

HRESULT get_KaiserBeta(float *pVal)
HRESULT put_KaiserBeta(float newVal)

Interface

ITransform


About Modifying Cal Kits

L0 Property

Write/Read

Description

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

To set the other inductance values, use L1, L2, L3

VB Syntax

calstd.L0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L0 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L0 = 15 'Write the value of L0 = 15picohenries

Induct0 = calstd.L0 'Read the value of L0

C++ Syntax

HRESULT get_L0(float *pVal)
HRESULT put_L0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L1 Property

Write/Read

Description

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

To set the other inductance values, use L0, L2, L3

VB Syntax

calstd.L1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L1 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L1 = 15 'Write the value of L1 = 15picohenries

Induct1 = calstd.L1 'Read the value of L1

C++ Syntax

HRESULT get_L1(float *pVal)
HRESULT put_L1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L2 Property

Write/Read

Description

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L3

VB Syntax

calstd.L2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L2 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L2 = 15 'Write the value of L2 to 15picohenries

Induct2 = calstd.L2 'Read the value of L2

C++ Syntax

HRESULT get_L2(float *pVal)
HRESULT put_L2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L3 Property

Write/Read

Description

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L2

VB Syntax

calstd.L3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L3 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L3 = 15 'Write the value of L3 to 15picohenries

Induct3 = calstd.L3 'Read the value of L3

C++ Syntax

HRESULT get_L3(float *pVal)
HRESULT put_L3(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

Label Property

Write/Read

Description

Sets and Returns the label for the calibration standard. The label is used to prompt the user to connect the specified standard.

VB Syntax

calstd.Label = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(string) - between 1 and 12 characters long. Cannot begin with a numeric.

Return Type

String

Default

Not Applicable

Examples

calstd.Label = "Short" 'Write

stdLabel = calstd.Label 'Read

C++ Syntax

HRESULT get_Label(BSTR *pVal)
HRESULT put_Label(BSTR newVal)

Interface

ICalStandard


Begin Stimulus Property

About Sweeps

BeginStimulus Property

Write/Read

Description

When constructing a limit line, specifies the beginning X-axis value.

VB Syntax

limtseg.BeginStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Stimulus value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.Type = naLimitSegmentType_Maximum
limtseg.BeginStimulus = 3e9
limtseg.EndStimulus = 4e9
limtseg.BeginResponse = 10
limtseg.EndResponse = 10

BegStim = limtseg.BeginStimulus 'Read

C++ Syntax

HRESULT get_BeginStimulus(double *pVal)
HRESULT put_BeginStimulus(double newVal)

Interface

ILimitSegment


End Stimulus Value

About Limits

EndStimulus Property

Write/Read

Description

When constructing a limit line, specifies the stimulus value for the end of the segment.

VB Syntax

limtseg.EndStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - End Stimulus X-axis value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndStimulus = 8e9 'Write

EndStim = limtseg.EndStimulus 'Read

C++ Syntax

HRESULT get_EndStimulus(double *pVal)
HRESULT put_EndStimulus(double newVal)

Interface

ILimitSegment


Begin Response Property

About Sweeps

BeginResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value of the start of a limit segment.

VB Syntax

limtseg.BeginResponse = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Amplitude value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.BeginResponse = 10 'Write

BegResp = limtseg.BeginResponse 'Read

C++ Syntax

HRESULT get_BeginResponse(double *pVal)
HRESULT put_BeginResponse(double newVal)

Interface

ILimitSegment


End Response Property

About Limits

EndResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value at the end of the limit segment.

VB Syntax

limtseg.EndResponse = value

Variable

(Type) - Description

limts

A LimitSegment (object)

value

(double) - Y-axis value of the End Response limit. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndResponse = 10 'Write

EndResp = limtseg.EndResponse 'Read

C++ Syntax

HRESULT get_EndResponse(double *pVal)
HRESULT put_EndResponse(double newVal)

Interface

ILimitSegment


About Limits

Type (limit) Property

Write/Read

Description

Specifies the Limit Line type.

VB Syntax

limt(index).Type = value

Variable

(Type) - Description

limt

A LimitSegment (object)

index

(variant) - Limit line number in the LimitTest collection

value

(enum NALimitSegmentType) - Limit Line type. Choose from:
naLimitSegmentType_Maximum - limit line fails with a data point ABOVE the line
naLimitSegmentType_Minimum - limit line fails with a data point BELOW the line
naLimitSegmentType_OFF - turns limit line OFF

Return Type

Long Integer

Default

0 - OFF

Examples

Set limts = meas.LimitTest
limts.Type = naLimitSegmentType_Maximum 'Write

limitType = limts.Type 'Read

C++ Syntax

HRESULT put_Type(tagNALimitSegmentType *pVal)
HRESULT get_Type(tagNALimitSegmentType newVal)

Interface

ILimitSegment


About Limits

LineDisplay Property

Write/Read

Description

Turns the display of limit lines ON or OFF. To turn limit TESTING On and OFF, use State Property.

Note: Trace data must be ON to view limit lines

VB Syntax

limitst.LineDisplay = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the display of limit lines OFF
1 - Turns the display of limit lines ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.LineDisplay = 1 'Write

lineDsp = Limttest.LineDisplay 'Read

C++ Syntax

HRESULT get_LineDisplay(VARIANT_BOOL *pVal)
HRESULT put_LineDisplay(VARIANT_BOOL newVal)

Interface

ILimitTest


About Modifying Cal Kits

Loss Property

Write/Read

Description

Sets and Returns the insertion loss for the calibration standard.

VB Syntax

calstd.loss = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)

Return Type

Single

Default

Not Applicable

Examples

calstd.loss = 3.5e9 'Write

stdLoss = calstd.loss 'Read the value of Loss

C++ Syntax

HRESULT get_Loss(float *pVal)
HRESULT put_Loss(float newVal)

Interface

ICalStandard


Bucket Number Property

About Markers

BucketNumber Property

Write/Read

Description

Sets or returns the bucket number (data point) for the active marker.

VB Syntax

mark.BucketNumber = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Data point. Choose any number between 0 and the measurement's number of data points - 1.

For example, with Number of points = 201, choose between 0 and 200

Return Type

Long Integer

Default

The first marker is set to the middle of the span. Subsequent markers are set to the bucket number of the previously active marker.

Examples

mark.BucketNumber = 100 'moves the active marker to data point 100 -Write

pointNumber = mark.BucketNumber 'returns the data point number the active marker is currently on. -Read

C++ Syntax

HRESULT get_BucketNumber(long *pVal)
HRESULT put_BucketNumber(long newVal)

Interface

IMarker


Marker Format Property

About Marker Format

MarkerFormat Property

Write/Read

Description

Sets (or returns) the format of all the markers in the measurement. To override this setting for an individual marker, use mark.Format

VB Syntax

meas.MarkerFormat = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

Long Integer

Default

1 - naMarkerFormat_LogMag

Examples

meas.MarkerFormat = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT put_MarkerFormat(tagNAMarkerFormat NewFormat)

Interface

IMeasurement


Format (Marker) Property

About Marker Format

Format Property (marker)

Write/Read

Description

Sets (or returns) the format of the marker.

VB Syntax

mark.Format = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

NAMarkerFormat

Default

1 - naMarkerFormat_LogMag

Examples

mark.Format = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT get_Format(tagNAMarkerFormat *pVal)
HRESULT put_Format(tagNAMarkerFormat newVal)

Interface

IMarker


Interpolate Markers Method

About Markers

InterpolateMarkers Method

Write-only

Description

Turns All Marker Interpolation ON and OFF for the measurement. Marker interpolation enables X-axis resolution between the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. To override this property for individual markers, use the Interpolated property.

VB Syntax

meas.Interpolate = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
False - Turns interpolation OFF for all markers in the measurement
True - Turns interpolation ON for all markers in the measurement

Return Type

Boolean

Default

True (ON)

Examples

meas.Interpolate = 1

C++ Syntax

HRESULT raw_InterpolateMarkers(VARIANT_BOOL bNewVal)

Interface

IMeasurement


About Markers

Interpolated Property

Write/Read

Description

Turns marker Interpolation ON and OFF. Marker interpolation enables X-axis resolution beyond the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. Use meas.Interpolate to change interpolation of all markers in a measurement. This command will override the measurement setting.

VB Syntax

mark.Interpolated = value

Variable

(Type) - Description

mark

A Marker (object)

value

(boolean)
False - Turns interpolation OFF
True - Turns interpolation ON

Return Type

Boolean

Default

True (ON)

Examples

mark.Interpolated = 1 'Write

interpolate = mark.Interpolated 'Read

C++ Syntax

HRESULT get_Interpolated(VARIANT_BOOL *pVal)
HRESULT put_Interpolated(VARIANT_BOOL newVal)

Interface

IMarker


Number (marker) Property

About Markers

Number Property

Read-only

Description

Returns the number of the marker.

VB Syntax

marknum = mark.Number

Variable

(Type) - Description

marknum

(long) - Variable to store marker number

mark

A Marker (object)

Return Type

Long Integer

Default

Not applicable

Examples

marknum = mark.Number 'Read

C++ Syntax

HRESULT get_Number(long *pVal)

Interface

IMarker


About Marker Types

Type (Marker) Property

Write/Read

Description

Sets and reads the marker type.

VB Syntax

mark.Type = value

Variable

(Type) - Description

chan

A Marker (object)

value

(enum NAMarkerType) - Marker Type. Choose from:
naMarkerType_Normal - the X-axis value for a normal marker will always be determined by the measurement data of the marker. naMarkerType_Fixed - retains and keeps its x-axis value at the time the marker type is set.

Return Type

Long Integer

Default

naMarkerType_Normal

Examples

mark.Type = naMarkerType_Normal 'Write

MrkType = mark.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAMarkerType *pVal)
HRESULT put_Type(tagNAMarkerType newVal)

Interface

IMarker


About Markers

Stimulus Property

Write/Read

Description

Sets and reads the X-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

VB Syntax

mark.Stimulus = value

Variable

(Type) - Description

mark

A Marker (object)

value

(double) - X-Axis value. Choose any number within the full span of the channel or User Range (if set).

Return Type

Double

Default

First activated Marker turns ON in the middle of the X-axis range. Subsequent markers turn ON at the position of the most recently active marker.

Examples

mark.Stimulus = 3e9 'Write

XVal = mark.Stimulus 'Read

C++ Syntax

HRESULT get_Stimulus(double *pVal)
HRESULT put_Stimulus(double newVal)

Interface

IMarker


About Markers

Value Property

Read-only

Description

Reads the Y-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

You cannot set the Y-axis value of a marker. The marker remains at the position at the time you set marker.Type.

VB Syntax

YValue = mark.Value (format)

Variable

(Type) - Description

YValue

A variable to store the Y-axis value

mark

A Marker (object)

format

(enum NAMarkerFormat) - The format you would like the marker's Y-axis value. The number in parenthesis following the format is the number of values that are returned in a variant array. Choose from:

naMarkerFormat_LinMag (1)
naMarkerFormat_LogMag (1)
naMarkerFormat_Phase (1)
naMarkerFormat_Delay (1)
naMarkerFormat_Real (1)
naMarkerFormat_Imaginary (1)
naMarkerFormat_SWR (1)
naMarkerFormat_LinMagPhase (2)
naMarkerFormat_LogMagPhase (2)
naMarkerFormat_RealImaginary (2)
naMarkerFormat_ComplexImpedance (3)
naMarkerFormat_ComplexAdmittance (3)

Return Type

Variant - The previous list of formats indicates the number of values that are returned in a variant array

Default

Not applicable

Examples

YVal = mark.Value 'Read

C++ Syntax

HRESULT get_Value(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


About Modifying Cal Kits

MaximumFrequency Property

Write/Read

Description

Sets and Returns the maximum frequency for the calibration standard.

VB Syntax

calstd.MaximumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) - Maximum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MaximumFrequency = 9e9 'Write

maxFrequency = calstd.MaximumFrequency 'Read

C++ Syntax

HRESULT get_MaximumFrequency(double *pVal)
HRESULT put_MaximumFrequency(double newVal)

Interface

ICalStandard


About Trace Statistics

Mean Property

Read-only

Description

Returns the mean value of the measurement . To retrieve all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

average = meas.Mean

Variable

(Type) - Description

average

(single) - Variable to store mean value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

Dim average as Single
average = meas.Mean 'Read

C++ Syntax

HRESULT get_Mean(float* mean)

Interface

IMeasurement


About Modifying Cal Kits

Medium Property

Write/Read

Description

Sets and Returns the media type of the calibration standard.

VB Syntax

calstd.Medium = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardMedium) - Medium of the transmission line of the standard. Choose from:
0 - naCoax - Coaxial Cable
1 - naWaveGuide

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Medium = naCoax 'Write

stdMedium = calstd.Medium 'Read

C++ Syntax

HRESULT get_Medium(tagNACalStandardMedium *pVal)
HRESULT put_Medium(tagNACalStandardMedium newVal)

Interface

ICalStandard


About Modifying Cal Kits

MinimumFrequency Property

Write/Read

Description

Sets and Returns the minumum frequency for the calibration standard.

VB Syntax

calstd.MinimumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) -Minimum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MinimumFrequency = 300e3 'Write

minFrequency = calstd.MinimumFrequency 'Read

C++ Syntax

HRESULT get_MinimumFrequency(double *pVal)
HRESULT put_MinimumFrequency(double newVal)

Interface

ICalStandard


Name (Meas) Property

About Traces

Name (Measurement) Property

Write/Read

Description

Sets (or returns) the Name of the measurement. Measurement names must be unique among the set of measurements. Measurement names cannot be an empty string.

Note: This is the same name as trace.Name; when one changes, the other changes.

VB Syntax

meas.Name = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(string) - A user defined name of the measurement

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

meas.Name = "Filter BPass" 'Write

MName = meas.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

IMeasurement


About Traces

Name (trace) Property

Write/Read

Description

Sets or returns the name of the Trace. Use the trace name to identify the trace and refer to the trace in the collection.

Note: This is the same name as meas.Name; when one changes, the other changes.

VB Syntax

trac.Name = value

Variable

(Type) - Description

trac

A Trace (object)

value

(String) Trace name

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

trace.Name = "myTrace" 'Write

traceName = Name.Trace 'Read

C++ Syntax

HRESULT put_Name(BSTR name)
HRESULT get_Name(BSTR *name)

Interface

ITrace


About Modifying Cal Kits

Name (CalKit) Property

Write/Read

Description

Sets and Returns a name for the selected calibration kit.

VB Syntax

calKit.Name = value

Variable

(Type) - Description

calKit

A CalKit (object).

value

(string) -Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).

Return Type

String

Default

Not Applicable

Examples

calKit.Name = "MyCalKit" 'Write

KitName = calKit.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

ICalKit


Number (meas) Property

About Measurements

Number (Measurement) Property

Read-only

Description

Returns the Number of the measurement. Measurement numbers are assigned internally.

Note: Measurement numbers are NOT the same as their number in the Measurements collection. Measurement number is used to identify the measurement associated with an event.

This property is used to identify measurements when events occur through the OnMeasurementEvent callback. For example:

OnMeasurementEvent (naEventId_MSG_LIMIT_FAILED, 3)

VB Syntax

measNum = meas.Number

Variable

(Type) - Description

measNum

(long) - variable to store the measurement number

meas

A Measurement (object)

Return Type

Long Integer

Default

"1" - number of the default measurement

Examples

measNum = meas.Number

C++ Syntax

HRESULT get_Number(long *MeasurementNumber)

Interface

IMeasurement


Number of Points Property

About Number of Points

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Options

Options Property

Read-only

Description

Returns a string identifying the analyzer option configuration.

VB Syntax

value = app.Options

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned string

Return Type

String

Default

Not Applicable

Examples

availOptions = app.Options

C++ Syntax

HRESULT Options(BSTR* OptionString)

Interface

IApplication


About Measurement Parameters

Parameter Property

Read-only

Description

Returns the measurement Parameter. To change the parameter, use meas.ChangeParameter

VB Syntax

measPar = meas.Parameter

Variable

(Type) - Description

measPar

(string) - Variable to store Parameter string

meas

A Measurement (object)

Return Type

String

Default

Not applicable

Examples

measPar = meas.Parameter 'Read

C++ Syntax

HRESULT get_Parameter(BSTR *pVal)

Interface

IMeasurement


Parent Property

Read-only

Description

Returns a handle to the parent object of the collection object being refered to in the statement. The parent property allows the user to traverse from an object back up the object hierarchy.

VB Syntax

object.Parent

Variable

(Type) - Description

object

Channels collection
Channel object
Measurements collection
NAWindows collection
Traces collection
Segments object

Return Type

Object

Default

Not Applicable

Examples

parentobj = chans.Parent 'returns a handle to the parent object (Application) of the chans collection. -Read

C++ Syntax

HRESULT get_Parent(IApplication* *pApplication)

Interface

IChannels
IChannel
IMeasurements
INAWindows
ITraces
ISegments


Peak Excursion Property

About Marker Search

PeakExcursion Property

Write/Read

Description

Sets and reads the peak excursion value for the specified marker. The Excursion value determines what is considered a "peak".

VB Syntax

mark.PeakExcursion = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Excursion. Choose any number between -500 and 500

Return Type

Single

Default

3

Examples

mark.PeakExcursion = 1 'Write

PkExcur = mark.PeakExcursion 'Read

C++ Syntax

HRESULT get_PeakExcursion(float *pVal)
HRESULT put_PeakExcursion(float newVal)

Interface

IMarker


Peak Threshold Property

About Marker Search

PeakThreshold Property

Write/Read

Description

Sets peak threshold for the specified marker. If a peak (using the criteria set with PeakExcursion) is below this reference value, it will not be considered when searching for peaks.

VB Syntax

mark.PeakThreshold = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Threshold. Choose any number between:
-500 and 500

Return Type

Single

Default

-100db

Examples

mark.PeakThreshold = 1 'Write

PkThresh = mark.PeakThreshold 'Read

C++ Syntax

HRESULT get_PeakThreshold(float *pVal)
HRESULT put_PeakThreshold(float newVal)

Interface

IMarker


About Trace Statistics

PeakToPeak Property

Read-only

Description

Returns the Peak to Peak value of the measurement.To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

pp = meas.PeakToPeak

Variable

(Type) - Description

pp

(single) - Variable to store peak-to-peak value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

pp = meas.PeakToPeak 'Read

C++ Syntax

HRESULT get_PeakToPeak(float* pp)

Interface

IMeasurement


Phase Offset Property

About Phase Offset

PhaseOffset Property

Write/Read

Description

Sets the Phase Offset for the active channel.

VB Syntax

meas.PhaseOffset = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - PhaseOffset in degrees. Choose any number between:
-360 and +360

Return Type

Double

Default

0

Examples

meas.PhaseOffset = 25 'Write

poffset = meas.PhaseOffset 'Read

C++ Syntax

HRESULT get_PhaseOffset(double *pVal)
HRESULT put_PhaseOffset(double newVal)

Interface

IMeasurement


Port 1 Property

About Port Extensions

Port1 Property

Write/Read

Description

Sets a Port Extension value for Port 1

VB Syntax

portExt.Port1 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port1 = 10e-6 'Write

prt1 = portExt.Port1 'Read

C++ Syntax

HRESULT get_Port1(double *pVal)
HRESULT put_Port1(double newVal)

Interface

IPortExtension


Port 2 Property

About Port Extensions

Port2 Property

Write/Read

Description

Sets a Port Extension value for Port 2

VB Syntax

portExt.Port2 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port2 = 10e-6 'Write

prt2 = portExt.Port2 'Read

C++ Syntax

HRESULT get_Port2(double *pVal)
HRESULT put_Port2(double newVal)

Interface

IPortExtension


About Modifying Cal Kits

PortLabel Property

Write/Read

Description

Sets and returns the label on the calibration kit Port for the calibration wizard.

VB Syntax

calKit.Portlabel (portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object)

portNum

(long integer) - number of the port to be labeled. Choose either 1 or 2

value

(string) - Label that is visible in the calibration wizard.

Return Type

String

Default

Depends on the Cal Kit.

Examples

calKit.PortLabel = "MyCalKit" 'Write

kitLabel = calKit.PortLabel 'Read

C++ Syntax

HRESULT get_PortLabel(long port, BSTR *pVal)
HRESULT put_PortLabel(long port, BSTR newVal)

Interface

ICalKit


Power Slope Property

About Power Slope

PowerSlope Property

Write/Read

Description

Sets or returns the Power Slope value. Power Slope function increases or decreases the output power over frequency. Units are db/GHz. For example: PowerSlope = 2 will increase the power 2db/1GHZ.

VB Syntax

app.PowerSlope = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Power Slope. Choose any number between -2 and 2.
No slope = 0

Return Type

Double

Default

0

Examples

app.PowerSlope = 2 'Write

pwrslp = app.PowerSlope 'Read

C++ Syntax

HRESULT get_PowerSlope(double *pVal)
HRESULT put_PowerSlope(double newVal)

Interface

IChannel


Receiver Attenuator Property

About Receiver Attenuation

ReceiverAttenuator Property

Write/Read

Description

Sets or returns the value of the specified receiver attenuator control.

VB Syntax

chan.ReceiverAttenuator(rec) = value

Variable

(Type) - Description

chan

A Channel (object)

rec

(long integer) - Receiver with attenuator control to be changed. Choose from:
0 - Receiver A
1 - Receiver B

value

(double) - Attenuator value in dB. Choose any Long Integer between 0 and 35 in 5dB steps:

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 15 dB attenuation.

Return Type

Double

Default

0 db

Examples

chan.ReceiverAttenuator(1) = 5 'Write

attn = chan.ReceiverAttenuator(rnum) 'Read

C++ Syntax

HRESULT get_ReceiverAttenuator(long lport, double *pVal)
HRESULT put_ReceiverAttenuator(long lport, double newVal)

Interface

IChannel


About Reference Markers

ReferenceMarkerState Property

Write/Read

Description

Turn ON or OFF the reference marker. (can you access marker10?)

VB Syntax

meas.ReferenceMarkerState = state

Variable

(Type) - Description

app

A Measurement (object)

state

(boolean) -
ON (1) turns the reference marker ON
OFF (0) turns the reference marker OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.ReferenceMarkerState = True

reference = meas.ReferenceMarkerState

C++ Syntax

HRESULT get_ReferenceMarkerState(VARIANT_BOOL bState)
HRESULT put_ReferenceMarkerState(VARIANT_BOOL* bState)

Interface

IMeasurement


Reference Position Property

About Reference Position

ReferencePosition Property

Write/Read

Description

Sets or returns the Reference Position of the active trace.

VB Syntax

trce.ReferencePosition = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference position on the screen measured in horizontal graticules from the bottom of the screen. Choose from any number between: 0 and 10.

Return Type

Double

Default

0

Examples

meas.ReferencePosition = 5 'Middle of the screen -Write

rpos = meas.ReferencePosition -Read

C++ Syntax

HRESULT get_ReferencePosition(double *pVal)
HRESULT put_ReferencePosition(double newVal)

Interface

ITrace


Reference Value Property

About Reference Level

ReferenceValue Property

Write/Read

Description

Sets or returns the value of the Y-axis Reference Level of the active trace.

VB Syntax

trce.ReferenceValue = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference Value. Units and range depend on the current data format.

Return Type

Double

Default

Not applicable

Examples

meas.ReferenceValue = 0 'Write

rlev = meas.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(double *pVal)
HRESULT put_ReferenceValue(double newVal)

Interface

ITrace


Search Function Property

About Marker Search

SearchFunction Property

Write/Read

Description

Emulates the Tracking function in the marker search dialog box. The value you choose for SearchFunction will determine the type of search that takes place when the Tracking property is set true.

The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as executing one of the "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.SearchFunction = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFunction) - search function. Choose from:

0 - naMarkerFunction_None
1 - naMarkerFunction_Min
2 - naMarkerFunction_Max
3 - naMarkerFunction_Target
4 - naMarkerFunction_NextPeak
5 - naMarkerFunction_PeakRight
6 - naMarkerFunction_PeakLeft

Return Type

Long Integer

Default

0 - naMarkerFunction_None

Examples

mark.SearchFunction = naMarkerFunction_Target 'When this marker is set to track, it will track the Target value.

searchfunction = mark.SearchFunction 'Read

C++ Syntax

HRESULT get_SearchFunction(tagNAMarkerFunction *pVal)
HRESULT put_SearchFunction(tagNAMarkerFunction newVal)

Interface

IMarker


Segment Number Property

About Segment Sweep

SegmentNumber Property

Read-only

Description

Returns the number of the current segment.

VB Syntax

seg.SegmentNumber

Variable

(Type) - Description

seg

A Segment (object). Get a handle to a segment by refering to the item in the segments collection.

Return Type

Long Integer

Default

Not Applicable

Examples

segNum = seg.SegmentNumber 'returns the segment number -Read

C++ Syntax

HRESULT get_SegmentNumber(long *pVal)

Interface

ISegment


Show Statistics Property

About Trace Statistics

ShowStatistics Property

Write/Read

Description

Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen. To display measurement statistics for a narrower band of the X-axis, use StatisticsRange.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both.

VB Syntax

meas.ShowStatistics = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Boolean value:

1 - Show statistics
0 - Hide statistics

Return Type

Boolean

Default

0 - Hide

Examples

meas.ShowStatistics = True 'Write

showstats = meas.ShowStatistics 'Read

C++ Syntax

HRESULT put_ShowStatistics(VARIANT_BOOL bState)

Interface

IMeasurement


About Performing a Calibration

Simultaneous2PortAcquisition Property

Read / Write

Description

Specifies whether a 2-port calibration will be done simultaneously or one port at a time.

VB Syntax

cal.Simultaneous2PortAcquisition = state

Variable

(Type) - Description

cal

A Calibrator (object)

state

(boolean) - Choose from:

True - measures 2 ports simultaneously
False - measures 1 port at a time

Return Type

Boolean

Default

False

Examples

cal.Simultaneous2PortAcquisition = True

C++ Syntax

HRESULT put_Simultaneous2PortAcquisition( VARIANT_BOOL bTwoSetsOfStandards)

HRESULT Simultaneous2PortAcquisition( VARIANT_BOOL *bTwoSetsOfStandards)

Interface

ICalibrator


Smoothing Aperture Property

About Smoothing

SmoothingAperture Property

Write/Read

Description

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

VB Syntax

meas.SmoothingAperture = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Smoothing Aperture. A ratio of (aperture points / trace points)/100 Choose any number between .01 and .25.

Return Type

Double

Default

.25

Examples

meas.SmoothingAperture = .10 'Write

saperture = meas.SmoothingAperture 'Read

C++ Syntax

HRESULT get_SmoothingAperture(double *pVal)
HRESULT put_SmoothingAperture(double newVal)

Interface

IMeasurement


About Smoothing

Smoothing Property

Write/Read

Description

Turns ON and OFF data smoothing.

VB Syntax

meas.Smoothing = state

Variable

(Type) - Description

meas

A Measurement (object)

state

(boolean)
1 - Turns smoothing ON
0 - Turns smoothing OFF

Return Type

Boolean

Default

0

Examples

meas.Smoothing = 1 'Write

smooth = meas.Smoothing 'Read

C++ Syntax

HRESULT get_Smoothing(VARIANT_BOOL *pVal)
HRESULT put_Smoothing(VARIANT_BOOL newVal)

Interface

IMeasurement


About Limits

SoundOnFail Property

Write/Read

Description

Turns ON or OFF the audio indicator for limit failures.

VB Syntax

limitst.SoundOnFail = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the sound OFF
1 - Turns the sound ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.SoundOnFail = 1 'Write

sound = Limttest.SoundOnFail 'Read

C++ Syntax

HRESULT get_SoundOnFail(VARIANT_BOOL *pVal)
HRESULT put_SoundOnFail(VARIANT_BOOL newVal)

ILimitTest


Source Power Option Property

About Segment Sweep

SourcePowerOption Property

Write/Read

Description

Enables the source power to be set on individual sweep segments. This property must be set True before seg.TestPortPower = value is sent. Otherwise, the test port power command will be ignored.

VB Syntax

segs.SourcePowerOption = state

Variable

(Type) - Description

segs

A Segments collection (object)

state

(boolean)
1 or True - Enables variable TestPortPower to be set segment sweep
0 or False - Disables variable TestPortPower to be set segment sweep

Return Type

Boolean
True - Enabled
False - Disabled

Default

False

Examples

segs.SourcePowerOption = True 'Write

powerOption = SourcePowerOption 'Read

C++ Syntax

HRESULT get_SourcePowerOption(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerOption(VARIANT_BOOL newVal)

Interface

ISegments


Source Power State Property

About Source Power

SourcePowerState Property

Write/Read

Description

Turns Source Power ON and OFF

VB Syntax

app.SourcePowerState = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
False (0) - Turns Source Power OFF
True (1) - Turns Source Power ON

Return Type

Boolean
0 - Power OFF
1 - Power ON

Default

ON (1)

Examples

app.SourcePowerState = True 'Write

pwr = app.SourcePowerState 'Read

C++ Syntax

HRESULT get_SourcePowerState(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerState(VARIANT_BOOL newVal)

Interface

IApplication


About Time Domain

Span Property

Write/Read

Description

Sets or returns the Span time of either Gating or Time Domain transform windows

VB Syntax

object.Span = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Span time in seconds. Choose any number between: 2*[(number of points-1) / frequency span] and 0

Return Type

Double

Default

20ns

Examples

Trans.Span = 4.5e-9 'sets the time span of a transform window -Write
Gate.Span = 4.5e-9 'sets the Span time of a gating window -Write

span = Trans.Span 'Read

C++ Syntax

HRESULT get_Span(double *pVal)
HRESULT put_Span(double newVal)

Interface

ITransform
IGating


Standard Deviation Property

About Trace Statistics

StandardDeviation Property

Read-only

Description

Returns the standard deviation of the measurement.
To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

stdev = meas.StandardDeviation

Variable

(Type) - Description

stdev

(single) - Variable to store standard deviation value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

stdev = meas.StandardDeviation 'Read

C++ Syntax

HRESULT get_StandardDeviation(float* stdDeviation)

Interface

IMeasurement


About Modifying Cal Kits

StandardForClass Property

Write/Read

Description

Sets a standard to a calibration class. Does NOT set or dictate the order for measuring the standards.

VB Syntax

calKit.StandardForClass(class, portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object). Use calKit.GetCalStandard to get a handle to the standard.

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

portNum

(long) - The port number the standard will be connected to. For example, you may have a 3.5mm connector designated for port 1, and Type N designated for port 2.

value

(double) - Calibration class number. Choose a number between 1 and 8. The <value> numbers are associated with the following calibration classes:

<value> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S21T | Thru standard

Return Type

Double

Default

Not Applicable

Examples

calstd.StandardForClass = 7 'Write

StdClass = calstd.StandardForClass 'Read

C++ Syntax

HRESULT put_StandardForClass(tagNACalClass stdclass, long port, long standardNumber)
HRESULT get_StandardForClass(tagNACalClass stdclass, long port, long* standardNumber)

Interface

ICalKit


Start Frequency Property

About Linear Frequency Sweep

StartFrequency Property

Write/Read

Description

Sets or returns the start frequency of the channel
or
Sets or returns the start frequency of the segment.

VB Syntax

object.StartFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Start frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Minimum frequency of the analyzer
Segment - 0

Examples

chan.StartFrequency = 4.5e9 'sets the start frequency of a linear sweep for the channel object -Write

startfreq = Chan.StartFrequency 'Read

C++ Syntax

HRESULT get_StartFrequency(double *pVal)
HRESULT put_StartFrequency(double newVal)

Interface

ISegment


Start Power Property

About Power Sweep

StartPower Property

Write/Read

Description

Sets the start power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency.

VB Syntax

chan.StartPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Start Power in dBm. There is 40 dB of range in power sweep. The values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 dB of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StartPower = -10 'Write

strtpwr = Chan.StartPower 'Read

C++ Syntax

HRESULT get_StartPower(double *pVal)
HRESULT put_StartPower(double newVal)

Interface

IChannel


About Time Domain

Start Property

Write/Read

Description

Sets or returns the start time of either Gating or Time Domain transform windows

VB Syntax

object.Start = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

-10ns

Examples

Trans.Start = 4.5e-9 'sets the start time of a transform window -Write
Gate.Start = 4.5e-9 'sets the start time of a gating window -Write

strt = Trans.Start 'Read

C++ Syntax

HRESULT get_Start(double *pVal)
HRESULT put_Start(double newVal)

Interface

ITransform
IGating


State Property

Write/Read

Description

Turns an Object ON and OFF.

VB Syntax

object.State = value

Variable

(Type) - Description

object

Applies to any of the following:
Gating (object)
LimitTest (object)
Port Extension (object)
Segment (object)
Transform (object)

value

(boolean) -

0 - Turns obj OFF
1 - Turns obj ON

Return Type

Long Integer

Default

Depends on the object:
0 - Gating
0 - LimitTest
0 - Port Extension
1 - Segment
0 - Transform

Examples

Seg.State = 1 'Turns the segment object ON -Write

tran = Trans.State 'returns the state of Transform -Read

C++ Syntax

HRESULT get_State(VARIANT_BOOL *pVal)
HRESULT put_State(VARIANT_BOOL newVal)

Interface

ISegment
ITransform
IGating
ILimitTest
IPortExtension


About User Ranges

Statistics Range Property

Write/Read

Description

Sets the User Range number for calculating measurement statistics. Set the start and stop values for a User Range with chan.UserRangeMin and chan.UserRangeMax.

There are 9 User Ranges per channel. User ranges are applied independently to any measurement.

VB Syntax

meas.StatisticsRange = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(long integer) - Range Number. Choose any number between 0 and 9.
1 - 9 are user-defined ranges
0 is Full Span

Return Type

Long Integer

Default

0

Examples

meas.StatisticsRange = 2 'Write

statrange = meas.StatisticsRange 'Read

C++ Syntax

HRESULT get_StatisticsRange(long* rangeNumber)
HRESULT put_StatisticsRange(long rangeNumber)

Interface

IMeasurement


Step Rise Time Property

About Time Domain

StepRiseTime Property

Write/Read

Description

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

VB Syntax

trans.StepRiseTime = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Rise time in seconds. Choose any number between 5.0e-13 and 1.63e-14.

Return Type

Double

Default

0

Examples

trans.StepRiseTime = 1.0e-14 'sets the step rise time to 100 psec. -Write

rt = trans.StepRiseTime 'Read

C++ Syntax

HRESULT get_StepRiseTime(double *pVal)
HRESULT put_StepRiseTime(double newVal)

Interface

ITransform


Stop Frequency Property

About Linear Frequency Sweep

StopFrequency Property

Write/Read

Description

Sets or returns the stop frequency of the channel
or
Sets or returns the stop frequency of the segment.

VB Syntax

object.StopFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Stop frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Maximum frequency of the analyzer
Segment - 0

Examples

chan.StopFrequency = 4.5e9 'sets the stop frequency of a linear sweep for the channel object -Write

stopfreq = Chan.StopFrequency 'Read

C++ Syntax

HRESULT get_StopFrequency(double *pVal)
HRESULT put_StopFrequency(double newVal)

Interface

IChannel
ISegment


Stop Power Property

About Power Sweep

StopPower Property

Write/Read

Description

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency

VB Syntax

chan.StopPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Stop Power in dB. Start Power in dB. There is 40 dB of range in power sweep. The acceptable values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StopPower = -10 'Write

stppwr = Chan.StopPower 'Read

C++ Syntax

HRESULT get_StopPower(double *pVal)
HRESULT put_StopPower(double newVal)

Interface

IChannel


About Time Domain

Stop Property

Write/Read

Description

Sets or returns the Stop time of either Gating or Time Domain transform windows

VB Syntax

object.Stop = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

10 ns

Examples

Trans.Stop = 4.5e-9 'sets the stop time of a transform window -Write
Gate.Stop = 4.5e-9 'sets the stop time of a gating window -Write

stp = Trans.Stop 'Read

C++ Syntax

HRESULT get_Stop(double *pVal)
HRESULT put_Stop(double newVal)

Interface

ITransform
IGating


Sweep Generation Mode Property

About Stepped Sweep

SweepGenerationMode Property

Write/Read

Description

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

VB Syntax

chan.SweepGenerationMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepGenerationModes) - Choose either:

naSteppedSweep - source frequency is CONSTANT during measurement of eah displayed point. More accurate than Analog. Dwell time can be set in this mode.

naAnalogSweep - source frequency is continuously RAMPING during measurement of each displayed point. Faster than Stepped. Sweep time (not dwell time) can be set in this mode.

Return Type

Long Integer

Default

Analog

Examples

Chan.SweepGenerationMode = naAnalogSweep 'Write

swpgen = Chan.SweepGenerationMode 'Read

C++ Syntax

HRESULT get_SweepGenerationMode(tagNASweepGenerationModes* pVal)
HRESULT put_SweepGenerationMode(tagNASweepGenerationModes newVal)

Interface

IChannel


Sweep Time Property

About Sweep Time

SweepTime Property

Write/Read

Description

Sets the Sweep time of the analyzer. Sweep time is limited so that the analyzer only sweeps as fast as possible for the current frequency range, number of points, and IFbandwidth.

VB Syntax

chan.SweepTime = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Sweep time in seconds. Choose a number between:
0 and 100

Return Type

Double

Default

0

Examples

chan.SweepTime = 3e-3 'Write

swptme = chan.SweepTime 'Read

C++ Syntax

HRESULT get_SweepTime(double *pVal)
HRESULT put_SweepTime(double newVal)

Interface

IChannel


Sweep Type Property

About Sweep Types

SweepType Property

Write/Read

Description

Sets the type of X-axis sweep that is performed on a channel.

VB Syntax

chan.SweepType = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepTypes) - Choose from:

naLinearSweep
naPowerSweep
naCWTimeSweep
naSegmentSweep

Note: Sweep type cannot be set to Segment sweep if there are no segments turned ON. A segment is automatically turned ON when a Application application is created.

Return Type

Long Integer

Default

naLinearSweep

Examples

chan.SweepType = naPowerSweep 'Write

swptyp = chan.SweepType 'Read

C++ Syntax

HRESULT get_SweepType(tagNASweepTypes* pVal)
HRESULT put_SweepType(tagNASweepTypes newVal)

Interface

IChannel


About System Impedance

SystemImpedanceZ0 Property

Write/Read

Description

Sets and returns the impedance for the analyzer.

VB Syntax

app.SystemImpedanceZ0 = value

Variable

(Type) - Description

app

An Application (object)

value

(double) Analyzer Impedance. Choose any number between 0 and 1000 ohms.

Return Type

Double

Default

50

Examples

app.SystemImpedanceZ0 = 75 'Write

z0 = app.SystemImpedanceZ0 'Read

C++ Syntax

HRESULT get_SystemImpedanceZ0(double dSystemZ0)
HRESULT put_SystemImpedanceZ0(double *pdSystemZ0)

Interface

IApplication


About Marker Search

TargetValue Property

Write/Read

Description

Sets the target value for the marker when doing Target Searches ( SearchTargetLeft, SearchTarget, SearchTargetRight).

VB Syntax

mark.TargetValue = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Target value. Choose any number between: -500 and 500

Return Type

Single

Default

0

Examples

mark.TargetValue = 10.5 'Write

target = mark.TargetValue 'Read

C++ Syntax

HRESULT get_TargetValue(float *pVal)
HRESULT put_TargetValue(float newVal)

Interface

IMarker


Test Port Power Property

About Power Level

TestPortPower Property

Write/Read

Description

Sets or returns the RF power level for the channel
or
Sets or returns the RF power level of the segment.

VB Syntax

object.TestPortPower(portNum) = value

Variable

(Type) - Description

object

A Channel (object) - to set coupled power, use chan.CouplePorts. If CouplePorts = False, then each port power can be set independently. Otherwise, chanTestPortPower (1) = value sets power level at both ports.
or
A Segment (object)

portNum

(long integer) - Port number of the source power. Choose from 1 or 2

value

(double) - RF Power in dBm. Choose any number between -90 and 20.

Actual achievable leveled power depends on frequency.

Return Type

Double

Default

0

Examples

chan.TestPortPower(1) = 5 'sets the port 1 RF power level for the channel object -Write

powerlev = Chan.TestPortPower(1) 'Read

C++ Syntax

HRESULT get_TestPortPower(long port, double *pVal)
HRESULT put_TestPortPower(long port, double newVal)

Interface

IChannel
ISegment


About Title

Title Property

Write/Read

Description

Writes or reads a custom title for the window. Newer entries replace (not append) older entries.Turn the title ON and OFF with TitleState

VB Syntax

win.Title = string

Variable

(Type) - Description

win

A NaWindow (object)

string

(long) - Title limited to 50 characters.

Return Type

String

Default

Null

Examples

win.Title = "Hello World" 'Write

titl = win.Title 'Read

C++ Syntax

HRESULT get_Title(BSTR *title)
HRESULT put_Title(BSTR title)

Interface

INAWindow


Title State Property

About Titles

TitleState Property

Write/Read

Description

Turns ON and OFF the window title. Write a window title with Title

VB Syntax

win.TitleState = state

Variable

(Type) - Description

win

A NaWindow (object)

state

(boolean)
True (1) - Title ON
False (0) - Title OFF

Return Type

Long Integer
0 - Title OFF
1 - Title ON

Default

0 - OFF

Examples

win.TitleState = True 'Write

titlestate = win.TitleState 'Read

C++ Syntax

HRESULT get_TitleState(VARIANT_BOOL* bState)
HRESULT put_TitleState(VARIANT_BOOL bState)

Interface

INAWindow


Trace Math Property

About Math Operations

TraceMath Property

Write/Read

Description

Performs math operations on the measurement object and the trace stored in memory. (There MUST be a trace stored in Memory to perform math. See Meas.DataToMemory method.)

VB Syntax

meas.TraceMath = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAMathOperation) - Choose from:

0 - naDataNormal
1 - naDataMinusMemory
2 - naDataPlusMemory
3 - naDataDivMemory
4 - naDataTimesMemory

Return Type

NAMathOperation

Default

Normal (0)

Examples

meas.TraceMath = naDataMinusMemory 'Write

mathOperation = meas.TraceMath 'Read

C++ Syntax

HRESULT get_TraceMath(tagNAMathOperation* pMathOp)
HRESULT put_TraceMath(tagNAMathOperation mathOp)

Interface

IMeasurement


About Marker Search

Tracking Property

Write/Read

Description

This property, when on, executes the search function (marker.SearchFunction) every sweep.

In effect, turning Tracking ON is the same as executing one of the immediate, one-time, "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.Tracking = state

Variable

(Type) - Description

mark

A Marker (object)

state

(boolean) - Tracking state. Choose from:
ON (1)
OFF (0)

Return Type

Boolean
0 - Tracking OFF
1 - Tracking ON

Default

0 - OFF

Examples

mark.Tracking = 1 'Write

markTracking = mark.Type 'Read

C++ Syntax

HRESULT put_Tracking(VARIANT_BOOL bOn)
HRESULT get_Tracking(VARIANT_BOOL * pbOn)

Interface

IMarker


About Time Domain

Mode Property

Write/Read

Description

Sets the type of transform.

VB Syntax

trans.Mode = value

Variable

(Type) - Description

trans

A Transform (object)

value

(enum NATransformMode) - Choose from:

0 - naTransformBandpassImpulse
1 - naTransformLowpassImpulse
2 - naTransformLowpassStep

Return Type

NATransformMode

Default

0 - naTransformBandpassImpulse

Examples

trans.Mode = naTransformLowpassStep 'Write

transmode = trans.Mode 'Read

C++ Syntax

HRESULT get_Mode(tagNATransformMode *pVal)
HRESULT put_Mode(tagNATransformMode newVal)

Interface

ITransform


Trigger Mode Property

About Triggering

TriggerMode Property

Write/Read

Description

Each trigger signal will cause either:
all measurements in the channel to be made or
only a single data point in the channel at a time.

VB Syntax

chan.TriggerMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NATriggerMode) - Choose from:

naTriggerModeMeasurement - all measurements in the channel are made with each trigger signal the channel receives.
naTriggerModePoint - a single data point is measured with each trigger signal the channel receives. Subsequent trigger signals continue to go to the channel in Point mode until the channel measurements are complete.

Note: Point Mode is only available in Manual trigger and TriggerType set to naGlobalTrigger. If you change any channel to TriggerModePoint, TriggerType will be set to naChannelTrigger.

Return Type

Long Integer

Default

0 - naTriggerModeMeasurement

Examples

app.TriggerMode = naTriggerModePoint 'Write

trigtyp = app.TriggerMode 'Read

C++ Syntax

HRESULT get_TriggerMode (tagNATriggerMode *pMode)
HRESULT put_TriggerMode (tagNATriggerMode newMode)

Interface

IChannel


Trigger Signal Property

About Trigger Source

TriggerSignal Property

Write/Read

Description

Sets or returns the trigger source.

VB Syntax

app.TriggerSignal = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerSignal) - Choose from:

naTriggerInternal - free run

naTriggerExternalPositive - an external source that supplies a positive going signal

naTriggerExternalNegative - an external source that triggers on a negative signal

naTriggerManual - manual trigger source; use app.ManualTrigger to send a trigger signal.

Return Type

Long Integer

Default

naTriggerInternal

Examples

app.TriggerSignal = naTriggerExternalPositive 'Write

trigsign = app.TriggerSignal 'Read

C++ Syntax

HRESULT get_TriggerSignal(tagNATriggerSignal *pSignal)
HRESULT put_TriggerSignal(tagNATriggerSignal signal)

Interface

IApplication


Trigger Type Property

About Trigger

TriggerType Property

Write/Read

Description

Sets or returns the trigger type which determines the scope of a trigger signal.

Note: Point (Trigger Mode) is only available in Manual trigger and Channel (Trigger Type). If you change any channel to Global Trigger, Trigger Mode will be set to Measurement.

VB Syntax

app.TriggerType = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerType) - Trigger type. Choose from:
naGlobalTrigger - a trigger signal is applied to all triggerable channels
naChannelTrigger - a trigger signal is applied to the current channel. The next trigger signal will be applied to the next channel; not necessarily channel 1-2-3-4.

Return Type

Long Integer

Default

naGlobalTrigger

Examples

app.TriggerType = naGlobalTrigger 'Write

trigtyp = app.TriggerType 'Read

C++ Syntax

HRESULT get_TriggerType(tagNATriggerType *pTrigger)
HRESULT put_TriggerType(tagNATriggerType trigger)

Interface

IApplication


About Modifying Cal Kits

Type (calstd) Property

Write/Read

Description

Sets and Returns the type of calibration standard.

VB Syntax

calstd.Type = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardType) -Choose from:
0 - naOpen
1 - naShort
2 - naLoad
3 - naThru

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Type = naOpen 'Write

standardtype = calstd.Type 'Read

C++ Syntax

HRESULT get_Type(tagNACalStandardType *pVal)
HRESULT put_Type(tagNACalStandardType newVal)

Interface

ICalStandard


User Range Property

About User Ranges

UserRange Property

Write/Read

Description

Assigns the marker to the specified User Range. This restricts the marker's x-axis travel to the User Range span, specified with Start and Stop values.

  • Each channel has 10 user ranges.

  • Markers and trace statistics can be restricted to any user range.

  • More than one marker can occupy a user range.

  • User ranges can overlap. For example:

    • User range 1 - 3GHz to 5GHz

    • User range 2 - 4GHz to 6GHz

Note: User ranges are especially useful in restricting marker searches to specific areas of the measurement.

VB Syntax

mark.UserRange = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - User Range. Choose any number between:
0 and 9 (0=Full Span)

Return Type

Long Integer

Default

0 - Full Span

Examples

mark.UserRange = 1 'Write

UseRnge = mark.UserRange 'Read

C++ Syntax

HRESULT get_UserRange(long *pRangeNumber)
HRESULT put_UserRange(long lRangeNumber)

Interface

IMarker


User Range Max Property

About User Ranges

UserRangeMax Property

Write/Read

Description

Sets the stimulus stop value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMax(domainType,Mnum) = value
or
mark.UserRangeMax(rnum) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the "DomainType" argument.

domainType

(enum NADomainType) - Choose from:

naDomainFrequency
naDomainPower
naDomainTime

Mnum

(long integer) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Stop value. Choose any number within the full span of the channel

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMax(1) = 3e9 'Write
chan.UserRangeMax(naDomainFrequency,1) = 3e9 'Write

UseRngeMax = mark.UserRangeMax 'Read
UseRngeMax = chan.UserRangeMax 'Read

C++ Syntax

HRESULT put_UserRangeMax(tagNADomainType domain, long rangeNumber, double maxValue)
HRESULT get_UserRangeMax(tagNADomainType domain, long rangeNumber, double *maxValue)

Interface

IChannel


User Range Min Property

About User Ranges

UserRangeMin Property

Write/Read

Description

Sets the stimulus start value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMin(domainType,range) = value
or
mark.UserRangeMin(range) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the DomainType argument

domainType

(enum NADomainType) Type of sweep currently implemented on the channel - Choose from:
naDomainFrequency
naDomainPower
naDomainTime

range

(long) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Start value. Choose any number within the full span of the analyzer

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMin(1) = 3e9 'Write
chan.UserRangeMin(naDomainFrequency,1) = 3e9 'Write

UseRngeMin = mark.UserRangeMin 'Read
UseRngeMin = chan.UserRangeMin 'Read

C++ Syntax

HRESULT put_UserRangeMin(tagNADomainType domain, long rangeNumber, double minValue)
HRESULT get_UserRangeMin(tagNADomainType domain, long rangeNumber, double *minValue)

Interface

IChannel


Velocity Factor Property

About Port Extensions

VelocityFactor Property

Write/Read

Description

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

VB Syntax

app.VelocityFactor = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Velocity factor. Choose a number between: 0 and 10
(.66 polyethylene dielectric; .7 teflon dielectric)

Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.

Return Type

Double

Default

1

Examples

app.VelocityFactor = .66 'Write

RelVel = app.VelocityFactor 'Read

C++ Syntax

HRESULT get_VelocityFactor(double *pVal)
HRESULT put_VelocityFactor(double newVal)

Interface

IApplication


About Math Operations

View Property

Write/Read

Description

Sets (or returns) the type of trace displayed on the screen.

VB Syntax

meas.View = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAView) - Type of trace. Choose from:

0 - naData
1 - naDataAndMemory
2 - naMemory
3 - naNoTrace

Note: The naData trace may reflect the result of a TraceMath operation.

Return Type

NAView

Default

naData

Examples

meas.View = naData 'Write

trceview = meas.View 'Read

C++ Syntax

HRESULT get_View(tagNAView* pView)
HRESULT put_View(tagNAView newView)

Interface

IMeasurement


Visible Property

Write/Read

Description

Makes the Network Analyzer application visible or not visible. In the Not Visible state, the analyzer cycle time for making measurements can be significantly faster because the display does not process data.

VB Syntax

app.Visible = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
0 - Network Analyzer application NOT visible
1 - Network Analyzer application IS visible

Return Type

Boolean
0 - Not visible
1 - visible

Default

1

Examples

app.Visible = 0 'Write

vis = app.Visible 'Read

C++ Syntax

HRESULT get_Visible(VARIANT_BOOL * bVisible)
HRESULT put_Visible(VARIANT_BOOL bVisible)

Interface

IApplication


Window State Property

About Arranging Windows

WindowState Property

Write/Read

Description

Sets or returns the window setting of Maximized, Minimized, or Normal. To arrange all of the windows, use app.ArrangeWindows.

VB Syntax

object.WindowState = value

Variable

(Type) - Description

object

An Application (object) - main window
or
A NaWindow (object) - data windows

value

(enum NAWindowStates) - The window state. Choose from:
naMaximized - Maximizes the window
naMinimized - Minimizes the window to an Icon on the lower toolbar
naNormal - changes the window size to the user defined setting (between Max and Min).

Return Type

Long Integer

Default

naMaximized

Examples

app.WindowState = naMinimized 'changes the Network Analyzer application window to an icon. -Write
win.WindowState = naNormal 'changes the window defined by the win object variable to user defined settings. -Write

winstate = app.WindowState 'Read

C++ Syntax

HRESULT get_WindowState(tagNAWindowStates *pVal)
HRESULT put_WindowState(tagNAWindowStates newVal)

Interface

INAWindow
IApplication


About Scale

YScale Property

Write/Read

Description

Sets or returns the Y-axis Per-Division value of the active trace.

VB Syntax

trace.YScale = value

Variable

(Type) - Description

trace

A Trace (object)

value

(double) - Scale /division number. Units and range depend on the current data format.

Return Type

Double

Default

10 (db)

Examples

trac.YScale = 5 'Write

yscl = trac.YScale 'Read

C++ Syntax

HRESULT get_YScale(double *pVal)
HRESULT put_YScale(double newVal)

Interface

ITrace


About Modifying Cal Kits

Z0 Property

Write/Read

Description

Sets and Returns the characteristic impedance for the calibration standard.

VB Syntax

calstd.Z0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) -Impedance in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.Z0 = 50 'Write

impedance = calstd.Z0 'Read

C++ Syntax

HRESULT get_Z0(float *pVal)
HRESULT put_Z0(float newVal)

Interface

ICalStandard


About Triggering

Abort Method

Write-only

Description

Ends the current measurement sweep on the channel.

VB Syntax

chan.Abort [sync]

Variable

(Type) - Description

chan

(object) - A Channel object

sync

(boolean) - wait (or not) for the analyzer to stop before processing subsequent commands. Optional argument; if unspecified, value is set to False. Choose from:
True - synchronize - the analyzer will not process subsequent commands until the current measurement is aborted.
False - continue processing commands immediately

Return Type

None

Default

None

Examples

chan.abort True
chan.abort

C++ Syntax

HRESULT raw_Abort(VARIANT_BOOL bSynchronize);

Interface

IChannel


Acquire Cal Standard Method

About Calibration Standards

AcquireCalStandard Method

Write-only

Description

Measures the specified standard from the selected calibration kit. The calibration kit is selected using app.CalKitType.

For 2-port calibration, it is also necessary to specify direction with AcquisitionDirection.

VB Syntax

cal.AcquireCalStandard std[,index]

Variable

(Type) - Description

cal

A Calibrator (object)

std

(enum NACalClass) Standard to be measured. Choose from:

naClassA

naClassB

naClassC

naClassD

naClassE

naReferenceRatioLine

naReferenceRatioThru

naSOLT_Isolation

SOLT Standards

naSOLT_Open

naSOLT_Short

naSOLT_Load

naSOLT_Thru

TRL Standards

naTRL_Reflection

naTRL_Line_Reflection

naTRL_Line_Tracking

naTRL_Thru

naTRL_Isolation

index

(long integer) number of the standard. Optional argument - Used if there is more than one standard required to cover the necessary frequency range. If unspecified, value is set to 0.

Return Type

None

Default

Not Applicable

Examples

Cal.AcquireCalStandard naSOLT_Thru 'Write

C++ Syntax

HRESULT raw_AcquireCalStandard(tagNACalClass enumClass, short standardNumber)

Interface

ICalibrator


Activate Method

Write-only

Description

Makes an object the Active Object. When making a measurement active, the channel and window the measurement is contained in becomes the active channel and active window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Getting a Handle to an Object.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

object.Activate

Variable

(Type) - Description

object

Measurement (object)
or
Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Activate
mark.Activate

C++ Syntax

HRESULT raw_Activate()

Interface

IMeasurement
IMarker


Activate Marker Method

About Markers

ActivateMarker Method

Write-only

Description

Makes a marker the Active Marker. Use meas.ActiveMarker to read the number of the active marker.

VB Syntax

meas.ActivateMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long integer) - the number of the marker to make active. Choose any marker number from 1 to 9.

Return Type

None

Default

Not Applicable

Examples

meas.ActivateMarker(1)'Write

C++ Syntax

HRESULT raw_ActivateMarker(long lMarkerNumber)

Interface

IMeasurement

Remarks

Use ReferenceMarkerState to control the Reference marker.


About Windows

ActivateWindow Method

Write-only

Description

Makes a window object the Active Window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Programming the Analyzer Object Model.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

app.ActivateWindow n

Variable

(Type) - Description

app

An Application (object)

n

(long) Number of the window to make active

Return Type

Window Object

Default

Not Applicable

Examples

app.ActivateWindow 4

C++ Syntax

HRESULT raw_ActivateWindow(long WindowNumber)

Interface

IApplication


About Channels

Add (channels) Method

Write-only

Description

Creates a channel and returns a handle to it. If the channel already exists, it returns the handle to the existing channel.

VB Syntax

chans.Add (item)

Variable

(Type) - Description

chans

A Channel collection (object)

item

(variant) - Channel number.

Return Type

Channel

Default

Not Applicable

Examples

chans.Add 3 'Creates channel 3

C++ Syntax

HRESULT raw_Add(VARIANT numVal, IChannel** pChannel)

Interface

IChannels


About Multiple Measurements

Add (measurement) Method

Write-only

Description

Adds a Measurement to the collection.

VB Syntax

meass.Add channel,param,source[,window]

meass

A Measurements collection (object)

channel

(long) - Channel number of the new measurement.

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

source

(long integer) - Source port number; if unspecified, value is set to 1. Only used for non-s-parameter measurements; ignored if s-parameter.

window

(long integer) - Optional - if unspecified, value is set to 0
-1: creates a new window
0 : current window
n : new window number (n) - creates if necessary

Return Type

None

Default

None

Examples

meass.Add 3,"A/R1",1,1 'Adds A/R1 measurement to channel 3 in window 1

C++ Syntax

HRESULT raw_Add(long ChannelNum, BSTR strParameter, long srcPort, VARIANT_BOOL bNewWindow)

Interface

IMeasurements


About Windows

Add (NAWindows) Method

Write-only

Description

Add a window to the display. Does not add a measurement. The window number must not already exist.

VB Syntax

wins.Add [item]

Variable

(Type) - Description

wins

A NAWindow collection (object)

item

(variant) - optional argument; Window number. Range between 1 - 4

Return Type

Object

Default

Not Applicable

Examples

wins.Add 3 'Creates a window number 3

C++ Syntax

HRESULT raw_Add(long windowNumber )

Interface

INAWindows


Add (segments) Method

About Segment Sweep

Add (segment) Method

Write-only

Description

Adds segments to the Segments collection, but does not turn the segments ON.

VB Syntax

segs.Add (item, [size])

segs

A segments collection (object)

item

(variant) Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

None

Examples

Segs.Add 1, 4 'Adds segments 1,2,3,and 4. (does NOT automatically turn segments ON)

C++ Syntax

HRESULT raw_Add(VARIANT index, long size);

Interface

ISegments

Remarks

To ensure predictable results, it is best to remove all segments before defining a segment list. For each segment in the collection, do a seg.Remove.


About Analyzer Events

AllowAllEvents Method

Write/Read

Description

Sets event filtering to monitor all events in the analyzer. This is the default setting when subscribing to events. This could slow the measurement speed of the analyzer significantly.

VB Syntax

app.AllowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowAllEvents

C++ Syntax

HRESULT AllowAllEvents()

Interface

IApplication


About Analyzer Events

AllowEventCategory Method

Write/Read

Description

Sets event filtering to monitor a category of event.

VB Syntax

app.AllowEventCategory, category, state

Variable

(Type) - Description

app

An Application (object)

category

Category to monitor. Choose from list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventCategory

C++ Syntax

HRESULT AllowEventCategory(tagNAEventCategory category, VARIANT_BOOL bAllow )

Interface

IApplication

Type topic text here.


About Analyzer Events

AllowEventMessage Method

Write/Read

Description

Sets event filtering to monitor specific events.

VB Syntax

app.AllowEventMessage event

Variable

(Type) - Description

app

An Application (object)

event

Event to monitor. Refer to list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventMessage

C++ Syntax

HRESULT AllowEventMessage( tagNAEventID eventID, VARIANT_BOOL bAllow)

Interface

IApplication


About Analyzer Events

AllowEventSeverity Method

Write/Read

Description

Sets event filtering to monitor levels of severity.

VB Syntax

app.AllowEventSeverity severity,state

Variable

(Type) - Description

app

An Application (object)

severity

(enum naEventSeverity) Choose from:naEventSeverityERROR
naEventSeverityINFORMATIONAL
naEventSeveritySUCCESS
naEventSeverityWARNING

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventSeverity

C++ Syntax

HRESULT AllowEventSeverity( tagNAEventSeverity severity, VARIANT_BOOL bAllow)

Interface

IApplication


About Display Formatting

Autoscale Method

Write-only

Description

Autoscales the trace (Trace object) or all of the traces (NAWindow object).

VB Syntax

object.Autoscale

Variable

(Type) - Description

object

Trace (object)
or
NAWindow (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Trac.Autoscale 'Autoscales the trace
Win.Autoscale 'Autoscales all the traces in the window -Write

C++ Syntax

HRESULT raw_AutoScale()

Interface

INAWindow
ITrace


Averaging Restart Method

About Averaging

AveragingRestart Method

Write-only

Description

Clears and restarts averaging of the measurement data.

VB Syntax

chan.AveragingRestart

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.AveragingRestart

C++ Syntax

HRESULT raw_AveragingRestart()

Interface

IChannel


Build Hybrid Kit Method

About Modifying Cal Kits

BuildHybridKit Method

Write-only

Description

Use this method when you have different port connectors. This is a convenient way to combine two kits that match the connectors on your DUT.

VB Syntax

app.BuildHybridKit port1Kit,p1sex,port2Kit,p2sex,adapter,user kit

Variable

(Type) - Description

app

An Application (object)

port1Kit
port2Kit

(enum NACalKit) - Specifies the two kits to be used to build the hybrid kit. Choose from:

naCalKit_85032F_N50
naCalKit_85033E_3_5
naCalKit_85032B_N50
naCalKit_85033D_3_5
naCalKit_85038A_7_16
naCalKit_85052C_3_5_TRL
naCalKit_User7
naCalKit_User8
naCalKit_User9
naCalKit_User10

p1sex
p2sex

(enum NAPortSex) - Specifies the sex of the connector at that port. Choose from:
naMale
naFemale
naDon'tCare

adapter

(enum NAAdapter) -Choose from:
naUserkit - the electrical length of the adapter in the userKit specifications
naZeroLength - no adapter

userKit

(enum NACalKit) - The Hybrid kit - Choose from the previous list of kits

Return Type

Not Applicable

Default

Not Applicable

Examples

app.BuildHybridKit naCalKit_85033E_3_5,naMale,naCalKit_85038A_7_16
,naFemale,naUserkit,naCalKit_User8

C++ Syntax

HRESULT raw_BuildHybridKit\(tagNACalKit port1Kit, tagNAPortSex port1Sex, tagNACalKit port2Kit, tagNAPortSex port2Sex, tagNAAdapter adapter, tagNACalKit userKit)

Interface

IApplication


Calculate Error Coefficients Method

About Performing a Calibration

CalculateErrorCoefficients Method

Write-only

Description

This method is the final call in a calibration process. It calculates error-correction terms and turns error-correction ON.

VB Syntax

cal.CalculateErrorCoeffecients

Variable

(Type) - Description

cal

Calibrator (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Cal.CalculateErrorCoeffecients

C++ Syntax

HRESULT raw_CalculateErrorCoefficients()

Interface

ICalibrator


Change Parameter Method

About Measurement Parameters

ChangeParameter Method

Write-only

Description

Changes the parameter of the measurement.

VB Syntax

meas.ChangeParameter(param,sourcePort)

Variable

(Type) - Description

meas

A Measurement (object)

param

(string) - New parameter. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine any 2 of (A,B,R1,R2) in this format: "A/R1"

sourcePort

(long integer) - Port number of the source. Used only for non-sparameter measurements.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.ChangeParameter "S11",1

C++ Syntax

HRESULT raw_ChangeParameter(BSTR parameter, long sourcePort)

Interface

IMeasurement


About Triggering

Continuous Method

Write-only

Description

The channel continuously responds to trigger signals.

Note: This command does NOT change TriggerSignal to Continuous.

VB Syntax

chan.Continuous

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.Continuous

C++ Syntax

HRESULT raw_Continuous()

Interface

IChannel


Create SParameter Method

About Measurement Parameters

CreateS-Parameter Method

Write-only

Description

Creates a new S-Parameter measurement in an existing or new window.

VB Syntax

app.CreateSParameter chan,recvr,source,[window]

Variable

(Type) - Description

app

Application (object)

chan

(long integer) - Channel number of the new measurement

recvr

(long integer) - Port number of the receiver (1 or 2)

source

(long integer) - Port number of the source (1 or 2)

window

(long integer) - Window number of the new measurement. Choose 1 to 4. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateSParameter 1,2,1,1 'Creates a new S21 measurement in channel 1 and New window(1) app.CreateSParameter 1,2,1 'Creates a new S21 measurement in channel 1 and in the active window

C++ Syntax

HRESULT raw_CreateSParameter(long ChannelNum, long RcvPort, long SrcPort, long windowNumber)

Interface

IApplication


About Measurement Parameters

CreateMeasurement Method

Write-only

Description

Creates a new measurement.

VB Syntax

app.CreateMeasurement chanNum,param,src[,window]

Variable

(Type) - Description

app

Application (object)

chanNum

(long) - Channel number of the new measurement; can exist or be a new channel

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

src

(long) - Source Port. Choose 1 or 2 (ignored if param = Sparameter)

window

(long) Optional argument. Number of the window the measurement will be in. Choose 1 to 4. If unspecified, window is the active window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateMeasurement(1,"A/R1",1,0)

C++ Syntax

HRESULT raw_CreateMeasurement(long ChannelNum, BSTR strParameter, long srcPort, long windowNumber)

Interface

IApplication


About Math Operations

DataToMemory Method

Write-only

Description

Stores the active measurement data into memory creating a memory trace. The memory can then be displayed or used in calculations with the measurement data.

VB Syntax

meas.DataToMemory

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DataToMemory

C++ Syntax

HRESULT raw_DataToMemory()

Interface

IMeasurement


About Measurement Parameters

Delete Method

Write-only

Description

Deletes the measurement.

VB Syntax

meas.Delete

Variable

(Type) - Description

meas

The Measurement object to delete (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Delete

C++ Syntax

HRESULT raw_Delete()

Interface

IMeasurement


Delete Marker Method

About Markers

DeleteMarker Method

Write-only

Description

Deletes a marker from the measurement.

VB Syntax

meas.DeleteMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long) - Any existing marker number in the measurement

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteMarker(1)

C++ Syntax

HRESULT raw_DeleteMarker(long lMarkerNumber)

Interface

IMeasurement


About Markers

DeleteAllMarkers Method

Write-only

Description

Deletes all of the markers from the measurement.

VB Syntax

meas.DeleteAllMarkers

Variable

(Type) - Description

meas

(object) - The Measurement object from which markers will be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteAllMarkers

C++ Syntax

HRESULT raw_DeleteAllMarkers()

Interface

IMeasurement


About Macros

DeleteShortCut Method

Write-only

Description

Removes a macro from the list of macros in the analyzer. Does not remove the file.

Note: There are always 12 macro positions. They do not have to be sequential. For example, you can have number 7 but no numbers 1 to 6.

VB Syntax

app.DeleteShortCut item

Variable

(Type) - Description

app

An Application (object)

item

(long integer) number of the macro to be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DeleteShortCut 2

C++ Syntax

HRESULT DeleteShortcut(long Number )

Interface

IApplication


About Reference Markers

DeltaMarker Property

Write/Read

Description

Sets a marker as a delta marker. The reference marker must already be turned ON. See meas.ReferenceMarkerState

VB Syntax

mark.DeltaMarker = state

Variable

(Type) - Description

app

A Marker (object)

state

(boolean) -
ON (1) marker is a delta marker
OFF (0) marker is NOT a delta marker

Return Type

Boolean

Default

OFF (0)

Examples

mark.DeltaMarker = True 'Write

delta = mark.DeltaMarker 'Read

C++ Syntax

HRESULT get_DeltaMarker(VARIANT_BOOL bState)
HRESULT put_DeltaMarker(VARIANT_BOOL *bState)

Interface

IMarker


About Analyzer Events

DisallowAllEvents Method

Write/Read

Description

Sets event filtering to monitor NO eventst.

VB Syntax

app.DisallowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DisallowAllEvents

C++ Syntax

HRESULT raw_DisallowAllEvents()

Interface

IApplication

Type topic text here.


Do Print Method

About Printing

DoPrint Method

Write-only

Description

Prints the screen to the default Printer.

VB Syntax

app.DoPrint

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DoPrint

C++ Syntax

HRESULT raw_DoPrint()

Interface

IApplication


About Calibration

DoECAL1Port Method

Write-only

Description

Does a 1-Port calibration using an ECAL module. You must first have a 1-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL1Port[,port][,module]

Variable

(Type) - Description

app

A Calibrator (object)

port

(long integer) Optional argument - Port number to calibrate. Choose from:
1 - Calibrate port 1 (default if unspecified)
2 - Calibrate port 2

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL1Port,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL1Port(long port, tagNAECALModule ecalModule)

Interface

ICalibrator


About Calibration

DoECAL2Port Method

Write-only

Description

Does a 2-Port calibration using an ECAL module. You must first have a 2-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL2Port[,portA][,portB][,module]

Variable

(Type) - Description

app

A Calibrator (object)

portA

(long integer) Optional argument - Receiver ports to calibrate. Choose from:
1 - port 1 (default if unspecified)
2 - port 2

portB

(long integer) Optional argument - Source port to calibrate. Choose from:
1 - port 1
2 - port 2 (default if unspecified)

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL2Port,1,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL2Port(long rcvport, long srcPort, tagNAECALModule ecalModule)

Interface

ICalibrator


Execute Shortcut Method

About Macros

ExecuteShortcut Method

Write-only

Description

Executes a Macro (shortcut) stored in the analyzer. Use app.getShortcut to list existing macros. Use app.putShortcut to associate the macro number with the file.

VB Syntax

app.ExecuteShortcut index

Variable

(Type) - Description

app

Application (object)

index

(long integer) - Number of the macro stored in the analyzer.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ExecuteShortcut 1

C++ Syntax

HRESULT raw_ExecuteShortcut(long index)

Interface

IApplication


Get Cal Standard Method

About Modifying Cal Kits

GetCalStandard Method

Write-only

Description

Returns a handle to a calibration standard for modifying its definitions. To select a standard for performing a calibration (use Calibrator. AquireCalStandard ).

VB Syntax

calkit.GetCalStandard(index)

Variable

(Type) - Description

calkit

A calKit (object)

index

(long) - Number of calibration standard. Choose 1 to 8; (there are 8 cal standards in every kit).

Return Type

calStandard

Default

Not Applicable

Examples

Dim short As CalStandard
Set short = calKit.getCalStandard(1)
short.label = "myShort"

C++ Syntax

HRESULT raw_GetCalStandard(long standardNumber, ICalStandard **pCalStd)

Interface

ICalKit


Get Complex Method

Data Access Map

GetComplex Method

Read-only

Description

Retrieves complex data from the specified location.
See also getNAComplex , getData , and getPairedData Methods

VB Syntax

measData.getComplex location, numPts, real(), imag()

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the arrays

real

(single) - Array to store the real values

imag

(single) - Array to store the imaginary values

Return Type

Single

Default

Not Applicable

Examples

Dim real(201) AS Single
Dim imag(201) AS Single
Dim pts as Integer
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
measData.getComplex naCorrectedData, pts, real(0), imag(0)

C++ Syntax

HRESULT raw_getComplex(tagNADataStore DataStore, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Data Method

About Accessing Data

GetData Method

Read-only

Description

Retrieves variant data from the specified location in your choice of formats.

Note: This method returns a variant which is less efficient than methods available on the IArrayTransfer interface.

Note: If you plan to Put this data back into analyzer, putDataComplex (variant data) method requires complex, two-dimensional data. Therefore, request the data in Polar format.

VB Syntax

data = meas.GetData location, format

Variable

(Type) - Description

data

Variant array to store the data.

meas

A Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NADataFormat) - Format in which you would like the data. It does not have to be the displayed format. Choose from:

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Polar *

  • naDataFormat_Smith *

  • naDataFormat_Delay

  • naDataFormat_Real

  • naDataFormat_Imaginary

  • naDataFormat_SWR

* Specfiy Smith or Polar formats to obtain complex data pairs, which require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All scalar formats return a single dimension varData(numpts).

Return Type

Variant array - automatically dimensioned to the size of the data

Default

Not Applicable

Examples

Dim varData As Variant
varData = meas.GetData(naMeasResult,naDataFormat_Phase)
'Print Data
For i = 0 to chan.NumberOfPoints-1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_getData(tagNADataStore DataStore, tagDataFormat DataFormat, VARIANT *pData)

Interface

IMeasurement


Get ECAL Module Info Method

GetECALModuleInfo Method

Read-only

Description

Returns the following information about the connected ECAL module: model number, serial number, connector type,calibration date, min and max frequency.

VB Syntax

module = cal.GetECALModuleInfo

Variable

(Type) - Description

module

(string) - variable to store the module information

cal

A Calibrator (object)

Return Type

String - Returned information:

Default

Not Applicable

Examples

info = cal.GetECALModuleInfo

Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F RF2, Calibrated: 5 Jun 2000 , MinFreq: 50000000, MaxFreq: 9100000000

C++ Syntax

HRESULT raw_GetECALModuleInfo(tagNAECALModule ecalModule, BSTR* info)

Interface

ICalibrator


Get Error Term Complex Method

About Accessing Data

GetErrorTermComplex Method

Read-only

Description

Retrieves error term data from the error correction buffer.The data is in complex pairs.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetErrorTerm Method on ICalibrator.

VB Syntax

eData.GetErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

eData

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the error-term. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the error-term. One-dimensional for the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2

Return Type

Single

Default

Not Applicable

Examples

ReDim rel(numpts)
ReDim img(numpts)
Dim eData As ICalData
Set eData = chan.Calibrator
eData.getErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_getErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Error Term Method

About Measurement Calibration

GetErrorTerm Method

Read-only

Description

Retrieves error term data that is used for error correction. The data is complex pairs. Memory for the returned Variant is allocated by the server. The server returns a variant containing a two-dimensional safe Array.

Note: This method returns a variant which is less efficient than getErrorTermComplex on the ICalData interface.

VB Syntax

data = cal.getErrorTermterm, src, rcv

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

term

(enum As NaErrorTerm). Choose from:

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Variant

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.getErrorTerm(naErrorTerm_Tracking,2,1)

C++ Syntax

HRESULT raw_getErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Filter Statistics Method

About Marker Search

GetFilterStatistics Method

Read-only

Description

Returns all four Filter Statistics resulting from a SearchFilterBandwidth.
To retrieve individual filter statistics, use meas.FilterCF, meas.FilterBW, meas.FilterLoss, meas.FilterQ properties.

VB Syntax

meas.GetFilterStatistics cf,bw,loss,q

Variable

(Type) - Description

meas

A Measurement (object)

cf,bw,loss,q

Dimensioned variables to store the returned values

Return Type

(double) cf
(single) bw,loss,q

Default

Not Applicable

Examples

'Dimension variables
Dim cf as Double
Dim bw as Single
Dim loss as Single
Dim q as Single

meas.GetFileterStatistics cf,bw,loss,q

C++ Syntax

HRESULT raw_GetFilterStatistics(double* centerFreq, float* bw, float* loss, float* quality)

Interface

IMeasurement


Get NAComplex Method

About Accessing Data

GetNAComplex Method

Read-only

Description

Retrieves complex data from the specified locations.
See also getComplex and getData Method.

VB Syntax

measData.getNAComplex location, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dComplex array

data

(NAComplex) - A one-dimensional array of NaComplex to store the data.

Return Type

NAComplex

Default

Not Applicable

Examples

Dim dComplex(201) AS NaComplex
Dim measData As IArrayTransfer
Dim pts as Long
Set measData = app.ActiveMeasurement
measData.getNAComplex naCorrectedData, pts, dComplex(0)

Notes

The data is stored as Real and Imaginary (Re and Im) members of the NaComplex user defined type. You can access each number individually by iterating through the array.

For i = 0 to NumPts-1
dReal (i) = dcomplex (i).Re
dImag (i) = dcomplex (i).Im
Next i

C++ Syntax

HRESULT raw_getNAComplex(tagNADataStore DataStore, long* pNumValues, TsComplex* pComplex)

Interface

IArrayTransfer


Get Paired Data Method

About Accessing Data

GetPairedData Method

Read-only

Description

Retrieves pairs of data from specified location.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

VB Syntax

measData.getPairedData location, format, numPts, d1, d2

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NAPairedDataFormat) - Format in which you would like the Paired data. Choose from:

  • naLinMagPhase - Linear magnitude and phase

  • naLogMagPhase - Log magnitude and phase

  • naRealImaginary - Real and Imaginary

Note: Selecting naRealImaginary format is the same as using the getComplex method

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dPaired array

d1

(single) - Array to store the magnitude / real values

d2

(single) - Array to store the phase / imaginary values

Return Type

Two Single arrays

Default

Not Applicable

Examples

Dim logm() As Single
Dim phase() As Single
Public measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts As Long
numPoints = app.ActiveChannel.NumberOfPoints
ReDim logm(numPoints)
ReDim phase(numPoints)

measData.getPairedData naCorrectedData, naLogMagPhase, numPoints, logm(0),
 phase(0)

Print values(0), values(1)

C++ Syntax

HRESULT raw_getPairedData(tagNADataStore DataStore, tagNAPairedDataFormat PairFormat, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Reference Marker Method

About Reference Markers

GetReferenceMarker Method

Write/Read

Description

Returns a handle to the reference marker.

VB Syntax

meas.GetReferenceMarker

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Object

Default

Not Applicable

Examples

meas.GetReferenceMarker

C++ Syntax

HRESULT raw_GetReferenceMarker(IMarker** refMarker)

Interface

IMeasurement


Get Scalar Method

About Accessing Data

GetScalar Method

Read-only

Description

Retrieves scalar data from the specified locations.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

Note: You can NOT use this command to get complex data.

VB Syntax

measData.getScalar location, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum DataFormat) - Scalar format in which you would llike the data. Choose from:

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dScalar array

data

(single) - Array to store the scalar data.

Return Type

Single

Default

Not Applicable

Examples

Dim dScalar() As Single
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts as Long
numpts = app.ActiveChannel.NumberOfPoints
ReDim dScalar(numPoints)

measData.getScalar naCorrectedData, naDataFormat_LogMag, numpts, dScalar(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_getScalar(tagNADataStore DataStore, tagDataFormat DataFormat, long* pNumValues, float* pVals)

Interface

IArrayTransfer


Get Shortcut Method

About Macros

GetShortcut Method

Read-only

Description

Returns the Title, Path, and optional argument strings, of the specified Macro (shortcut). Use this method to list the titles and paths of macros in the analyzer.

VB Syntax

app.GetShortcut index, title, path, arguments

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro. Use a number between 1 and 12.

title

(string) - Title of the specified macro. (Appears in the softkey label)

path

(string) - Pathname of the specified macro.

arguments

(string) - Arguments for the specified macro

Return Type

String

Default

Not Applicable

Example

Dim t As String
Dim p As String
Dim arg As String
Dim i As Integer
For i = 1 to 12
app.GetShortcut i,t,p,arg
Print t,p
Next

C++ Syntax

HRESULT raw_GetShortcut(long Number, BSTR* title, BSTR* pathname, BSTR* arguments)

Interface

IApplication

Remarks

Shortcuts can also be defined and accessed using the macro key on the front panel. However, the benefit of this feature is primarily for the interactive user


Get Standard Method

About Measurement Calibration

GetStandard Method

Read-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method returns a variant which is less efficient than getStandardComplex on the ICalData interface.

VB Syntax

data = cal.getStandardclass,rcv,src

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

(variant) - two-dimensional array (0:1, 0:NumberOfPoints-1)

Default

Not Applicable

Examples

Dim varStd As Variant
varStd = cal.getStandard(naSOLT_Thru,2,1)

C++ Syntax

HRESULT raw_getStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Standard Complex Method

About Accessing Data

GetStandardComplex Method

Write-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetStandard Method on ICalibrator.

VB Syntax

ICalData.getStandardComplex class, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

ICalData

An ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the calibration data. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the calibration data. One-dimensional for the number of data points.

Return Type

(single)

Default

Not Applicable

Examples

Dim rel(200) As Single
Dim img(200) As Single
Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.getStandardComplex naSOLT_Open, 1, 1, numpts, rel(0), img(0)

C++ Syntax

HRESULT raw_getStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Test Result Method

About Limit Testing

GetTestResult Method

Read-only

Description

Returns the result of limit line testing. There are three ways to use this command:

  • If neither optional parameter is specified, limit results for ALL data is returned.

  • If one parameter is specified (start), the limit result for that data point is returned.

  • If both parameters are specified, limit results are returned beginning with start, and ending with (start+size)-1

VB Syntax

testRes = limts.GetTestResult[start,size]

Variable

(Type) - Description

testRes

(enum NALimitTestResult) - A dimensioned variable to store test results

0 - naLimitTestResult_None
1 - naLimitTestResult_Fail
2 - naLimitTestResult_Pass

limts

A LimitTest (object)

start

(long) - Optional argument. A start data point number to return limit test results.

size

(long) - Optional argument. Number of data points from start to return limit test results.

Return Type

Long Integer

Default

Not Applicable

Examples

Dim testRes As NALimitTestResult
testRes = limts.GetTestResult
Select Case testRes

Case 0
Print "No Test Result"

Case 1
Print "Fails"

Case 2
Print "Pass"

End Select

C++ Syntax

HRESULT raw_GetTestResult(long lStart, long lSize, tagNALimitTestResult *pVal)

Interface

ILimitTest


Get Trace Statistics Method

About Trace Statistics

GetTraceStatistics Method

Read-only

Description

Returns all four Trace Statistics. To retreive individual Trace statistics, use Mean, PeakToPeak, StandardDeviation properties. Use ShowStatistics to display the statistics of the screen.

VB Syntax

meas.GetTraceStatistics pp,mean,stdev

Variable

(Type) - Description

meas

A Measurement (object)

pp,mean,stdev

(double) - Dimensioned variables to store the returned values

Return Type

Double

Default

Not Applicable

Examples

'Dimension variables
Dim pp As Double
Dim mean As Double
Dim stdv As Double
meas.GetTraceStatistics pp, mean, stdv

C++ Syntax

HRESULT raw_GetTraceStatistics(double* pp, double* mean, double* stdDeviation)

Interface

IMeasurement


Get X-Axis Values 2

About Segment Sweep

GetX-axisValues2 Method

Write-only

Description

Returns the channel's X-axis values into a dimensioned Typed array. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetXAxisValues Method on IChannels.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

chanData.GetXAxisValues2 numPts,data

Variable

(Type) - Description

chanData

An IArrayTransfer pointer to the channel object.

numPts

(long integer) - Number of data points in the channel

data

(double) single dimensioned array of data matching the number of points in the channel.

Return Type

Double

Default

Not Applicable

Examples

Dim numPoints As Long
Dim values() As Double
numPoints = app.ActiveChannel.NumberOfPoints
ReDim values(numPoints)
app.ActiveChannel.GetXAxisValues2 numPoints, values(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_GetXAxisValues2(long* pNumValues, double* stimulus)

Interface

IChannel


Get X-axis Values Method

About Segment Sweep

GetXAxisValues Method

Read-only

Description

Returns the channel's X-axis values. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method returns a variant which is less efficient than GetXAxisValues2.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

data = chan.GetXAxisValues

Variable

(Type) - Description

data

Variant array to store the data.

chan

A Channel (object)

Return Type

Variant

Default

Not Applicable

Examples

Dim varData As Variant
Dim i As Integer
varData = chan.GetXAxisValues
'Print Data
For i = 0 To chan.numpts - 1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_GetXAxisValues (VARIANT* xData)

Interface

IChannel


About Triggering

Hold Method

Write-only

Description

Puts the Channel in Hold - not sweeping.

VB Syntax

chan.Hold [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) - Optional argument. A variable set to either True or False.

True - program control waits until the channel is in the Hold state.
False - program control continues immediately. You are not guaranteed the channel is in Hold yet.

Return Type

Not Applicable

Default

Not Applicable

Examples

wate = True
chan.Hold wate

C++ Syntax

HRESULT raw_Hold(VARIANT_BOOL bWait)

Interface

IChannel


Item Method

Write-only

Description

Returns an object from the collection of objects.

Note: The order of objects within a collection cannot be assumed.

VB Syntax

Object[.Item](n)

Variable

(Type) - Description

Object

Any of the following (objects):
Channels collection
LimitTest collection
Measurements collection
NaWindows collection
Traces collection
Segments collection

.Item

Optional - Item is the default property of a collections object and therefore can be called implicitly. For example, the following two commands are equivalent:

Channels.Item(3).Averaging = 1
Channels(3).Averaging = 1

n

(variant) - number of the item in the collection.

Note: the Measurements and Traces collections allow you to specify the name of the measurement as a string. For example: measCollection("CH_S11_1").InterpolateMarkers

Return Type

(Object)

Default

Not Applicable

Examples

For i = 1 to Traces.Count -1
Traces.Item(i).YScale = .5dB
Next i

C++ Syntax

HRESULT raw_Item(VARIANT index, <interface>** pItem)

Interface

IChannels
ILimitTest
IMeasurements
INaWindows
ITraces
ISegments


Manual Trigger Method

About Triggering

ManualTrigger Method

Write-only

Description

Triggers the analyzer when TriggerSignal = naTriggerManual.

VB Syntax

app.ManualTrigger [sync]

Variable

(Type) - Description

app

Application (object)

sync

(boolean) - Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim wait as Boolean
wait = True
app.ManualTrigger wait

C++ Syntax

HRESULT raw_ManualTrigger(VARIANT_BOOL bSynchronize, long timeout)

Interface

IApplication


Message Text Method

About Analyzer Events

MessageText Method

Write/Read

Description

Returns text for the specified eventID

VB Syntax

app.MessageText,eventID,message

Variable

(Type) - Description

app

An Application (object)

enentID

(enum naEventID) Choose from the list in Working with the Analyzer's Events

message

(string) - variable to store the returned message

Return Type

String

Default

Not Applicable

Examples

RFNA.MessageText naEventID_ARRANGE_WINDOW_EXCEED_CAPACITY, message

C++ Syntax

HRESULT raw_MessageText( tagNAEventID msgID, BSTR* message)

Interface

IApplication

Type topic text here.


Next IF Bandwidth Method

About Dynamic Range

NextIFBandwidth Method

Write-only

Description

A function that returns the Next higher IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Next_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the Next higher IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

pnBW = chan.IFBandwidth 'put the current IFBW in pnBW
chan.Next_IFBandwidth pnBW 'function returns the Next higher IFBandwidth.
chan.IFBandwidth = pnBW 'set IFBW to the Next value

C++ Syntax

HRESULT raw_Next_IFBandwidth (double *pVal)

Interface

IChannel


Number Of Groups Method

About Triggering

NumberOfGroups Method

Write-only

Description

Sets the Number of trigger signals the channel will receive. After the channels has received that number of trigger signals, the channel switches to Hold mode.

To begin sweeping the number of groups, send app.Continuous

VB Syntax

chan.NumberOfGroups num, sync

Variable

(Type) - Description

chan

A Channel (object)

num

(long integer) Number of trigger signals the channel will receive. Choose any number between 1 and 2 million

sync

(boolean)
Variable set to either:
True - subsequent commands are not processed until the groups are complete. Do not use with manual trigger.
False - subsequent commands are processed immediately

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.NumberOfGroups

C++ Syntax

HRESULT raw_NumberOfGroups(long count, VARIANT_BOOL bWait)

Interface

IChannel


SCPI Command Tree

Parse Method

Write-Read

Description

Executes a SCPI command.

VB Syntax

scpi.Parse ("SCPI command")

Variable

(Type) - Description

scpi

A ScpiStringParser (object)

SCPI command

(string) - Any valid SCPI command

Return Type

String

Default

Not Applicable

Examples

Dim scpi As ScpiStringParser
Set scpi = app.ScpiStringParser
Dim startfreq As Double
startfreq = 100e6
'
scpi.Parse ("Sens:Freq:Start " & startfreq)'Write

Dim str As String
str = scpi.Parse ("Sens:Freq:Start?")'Read

C++ Syntax

HRESULT raw_Parse(BSTR SCPI_Command, BSTR *pQueryResponse)

Interface

IScpiStringParser


Factory Preset Settings

Preset Method

Write-only

Description

Application Object: Deletes all traces and windows. In addition, resets the analyzer to factory defined default settings and creates an S11 measurement named "CH1_S11_1" in window 1.

Channel Object: Resets the channel (object) to factory defined default settings. Does NOT delete the current measurements or add a new measurement.

VB Syntax

app.Preset
chan.Preset

Variable

(Type) - Description

app

An Application (object)

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Preset

C++ Syntax

HRESULT raw_Preset()

Interface

IApplication
IChannel

.


Previous IF Bandwidth Method

About Dynamic Range

PreviousIFBandwidth Method

Write-only

Description

A function that returns the previous IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Previous_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the previous IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

PreBW = chan.IFBandwidth 'put the current IFBW in PreBW
chan.Previous_IFBandwidth PreBW 'function returns the Previous IFBandwidth of the current one.
chan.IFBandwidth = PreBW 'set IFBW to the previous value

C++ Syntax

HRESULT raw_Previous_IFBandwidth (double *pVal)

Interface

IChannel


About Saving to File

PrintToFile Method

Write-only

Description

Saves the screen image to a bitmap (.bmp) file.

VB Syntax

app.PrintToFile filename

Variable

(Type) - Description

app

An Application (object)

filename

(string) Name of the file to save the screen to. If you don't provide a suffix, the analyzer will append .bmp. The file is saved to the current working directory unless a valid full path name is specified.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PrintToFile "myfile"
app.PrintToFile "c:\data\myfile.bmp"

C++ Syntax

HRESULT raw_PrintToFile(BSTR bstrFile)

Interface

IApplication


Put Complex Method

About Accessing Data

PutComplex Method

Write-only

Description

Puts real and imaginary data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in the raw data store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the measurement results store will be overwritten by any measurement attribute changes.

See also putNAComplex

VB Syntax

measData.putComplex location, numPts, real(), imag(), [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

real()

(single) - Array containing real data values

imag()

(single) -Array containing imaginary data values

format

(enum NADataFormat) optional argument - display format of the real and imaginary data. Only used if destination is naMeasResult or naMemoryResult buffer. If unspecified, data is assumed to be in naDataFormat_Polar

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

  • naDataFormat_Smith

  • naDataFormat_Polar

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putComplex naMemoryResult, 201, real(0),imag(0),naDataFormat_SWR

C++ Syntax

HRESULT raw_putComplex( tagNADataStore DataStore, long lNumValues, float* pReal, float* pImag, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Data Complex Method

About Accessing Data

PutDataComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in naRawData (location) will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in naMeasurement (location) will be overwritten by any measurement attribute changes.

VB Syntax

meas.putDataComplex location, data

Variable

(Type) - Description

meas

A measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

data

(variant) - A two-dimensional variant array.

Note: All buffers except naMeasResult and naMemoryResult require Complex data

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.putDataComplex naMeasResult, varData

C++ Syntax

HRESULT raw_putDataComplex(tagNADataStore DataStore, VARIANT complexData)

Interface

IMeasurement


Put Data Scalar Method

About Accessing Data

PutDataScalar Method

Write-only

Description

Puts formatted variant scalar data into the measurement result buffer. The data will be immediately processed and displayed. Subsequent changes to the measurement state will be reflected on the display.

VB Syntax

meas.putDataScalar format, data

Variable

(Type) - Description

meas

A measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
4 - naDataFormat_Polar *
5 - naDataFormat_Smith *
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

* Smith and Polar formats require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All other formats are a single dimension varData(numpts).

data

(variant) - A two-dimensional complex variant data array.

Note: The getData (variant) method includes a "format" argument, which allows scalar (one-dimensional) data. To put data back into the "raw" data buffer using this (putDataComplex) method, specify Polar format when using the getData method.

Return Type

Not Applicable

Default

Not Applicable

Examples

measData.putDataScalar naDataFormat_Real, varData

C++ Syntax

HRESULT raw_putDataScalar(tagNADataStore DataStore, VARIANT complexScalar)

Interface

IMeasurement


Put Error Term Method

About Measurement Calibration

PutErrorTerm Method

Write-only

Description

Puts variant error term data into the error-correction buffer. See Accessing data.

VB Syntax

cal.putErrorTerm(term,src,rcv,data)

Variable

(Type) - Description

cal

A Calibrator (object)

term

(enum As NaErrorTerm)

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

data

(variant) Error term data in a two-dimensional array (0:1, 0:numpts-1).

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.putErrorTerm (naErrorTerm_Tracking,2,1,VarData)

C++ Syntax

HRESULT raw_putErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Error Term Complex Method

About Accessing Data

PutErrorTermComplex Method

Write-only

Description

Puts error term data into the error-correction data buffer.

VB Syntax

data.putErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

data

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the array

real()

(single) - array containing the real part of the calibration data. One-dimensional: the number of data points.

imag()

(single) - array containing the imaginary part of the calibration data. One-dimensional: the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim eData As ICalData
Set eData = chan.Calibrator
eData.putErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Put Scalar Method

About Accessing Data

PutScalar Method

Write-only

Description

Puts Scalar data in the Measurement Result buffer. The putScalar array is not processed by the analyzer; it is just displayed. Any change to the measurement state (changing the format, for example) will cause the putScalar data to be overwritten with the data processed from the raw data buffer.

VB Syntax

measData.putScalar, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

Note: Smith and Polar formats are not allowed.

numPts

(integer) - Number of values. Usually the number of points in the trace (chan.NumberOfPoints).

data

(single) - A one-dimensional array of Scalar data matching the number of points in the current measurement.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putScalar naDataFormat_LogMag, 201, dScalar(0)

C++ Syntax

HRESULT raw_putScalar\(tagDataFormat eFormat, long lNumValues, float* pArrayOfScalar)

Interface

IArrayTransfer


Put NA Complex Method

About Accessing Data

PutNAComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten. The data is processed and displayed.

Data put in the naRawData store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the naMeasResult store will be overwritten by any measurement attribute changes (such as moving a marker).

Note: This method uses NAComplex which is a user-defined data type. If you cannot or prefer not to use this data type, use the putComplex method.

VB Syntax

measData.putNAComplex location, numPts, data, [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

data

(NAComplex) - A one-dimensional array of Complex data matching the number of points in the current measurement.

format

(enum NADisplayFormat) - Optional argument. Format of the data. If unspecified, naDataFormat_Polar is assumed. Only used when the destination store is naMeasResult or naMemoryResult.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putNAComplex naMemoryResult, 201, dRawComplex(0)

C++ Syntax

HRESULT raw_putNAComplex(tagNADataStore DataStore, long lNumValues, TsComplex* pArrayOfComplex, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Shortcut Method

About Macros

PutShortcut Method

Write-only

Description

Defines a Macro (shortcut) file in the analyzer. This command links a file name and path to the Macro file. You still need to put the macro file in the analyzer at the location indicated by this command.

VB Syntax

app.PutShortcut index,title,path

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro to be stored in the analyzer. If the index number already exists, the existing macro is replaced with the new macro.

title

(string) - The name to be assigned to the macro

path

(string) - Full pathname to the existing macro "executable" file.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PutShortcut 1,"Test","C:\Automation\MyTest.vbs"

C++ Syntax

HRESULT raw_PutShortcut(long Number, BSTR title, BSTR pathname)

Interface

IApplication


Put Standard Method

About Accessing Data

PutStandard Method

Write-only

Description

Writes variant data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

cal.putStandard class,rcv,src,data

Variable

(Type) - Description

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long) - Receiver Port

src

(long) - Source Port

data

(variant) Two dimensional array (0:1, 0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varStd (1,200) As Variant
cal.putStandard naSOLT_Thru, 2, 1, varStd

C++ Syntax

HRESULT raw_putStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Standard Complex Method

About Accessing Data

PutStandardComplex Method

Write-only

Description

Writes data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

ICalData.putStandardComplex class,rcv,src, numPts,real(),imag()

Variable

(Type) - Description

ICalData

A ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the arrays being sent.

real()

(single) - one-dimensional array containing the real part of the acquisition data. (0:points-1)

imag()

(single) - one-dimensional array containing the imaginary part of the acquisition data. (0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.putStandardComplex naSOLT_Open, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long lNumValues, float* pReal, float* pImag)

Interface

ICalData


Quit Method

Write-only

Description

Terminates the Network Analyzer application.

VB Syntax

app.Quit

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Quit

C++ Syntax

HRESULT raw_Quit()

Interface

IApplication

Remarks

Under the rules of COM, the server should not exit until all references to it have been released. This method is a brute force way of terminating the application. Be sure to release all references (or terminate the client program) before attempting to restart the Network Analyzer application.

An alternate approach to terminating the application is to make the application invisible (app.Visible = False) and release all references. The server will shutdown.


About Save/Recall

Recall Method

Write-only

Description

Recalls a measurement state, calibration state, or both from the hard drive into the analyzer.

Use app.Save to save the measurement and calibration state.

VB Syntax

app.Recall (filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be recalled.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are stored in the default folder "C:\Program Files\Agilent\Network Analyzer\Documents

To recall from a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Recall (mystate.sta) 'Recalls "mystate.sta" from the default folder
app.Recall ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Recalls "mystate.cst" from the specified folder

C++ Syntax

HRESULT raw_Recall(BSTR bstrFile)

Interface

IApplication


About Modifying Cal Kits

Recall Kits Method

Write-only

Description

Recalls the calibration kits definitions that were stored witht the SaveKits command.

VB Syntax

app.RecallKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RecallKits

C++ Syntax

HRESULT raw_RecallKits()

Interface

IApplication


Remove Method

Write-only

Description

Removes an item from a collection of objects.

VB Syntax

Object.Remove item

Variable

(Type) - Description

Object

Any of the following (objects)

Measurements collection
NAWindows collection
Segments collection

Note: segments has an OPTIONAL argument [size] referring to the number of segments to remove, starting with the item parameter.

item

(variant) - Item number to be removed

Return Type

Not Applicable

Default

Not Applicable

Examples

Measurements.Remove 3 'Removes measurement 3
segments.Remove 2,20 'Removes 20 segments (3 - 22)

C++ Syntax

HRESULT raw_Remove(VARIANT index) //IMeasurements
HRESULT raw_Remove(long windowNumber ) //INaWindows
HRESULT raw_Remove(VARIANT index, long size) //Segments

Interface

IMeasurements
INAWindows
ISegments


About Presetting the Analyzer

Reset Method

Write-only

Description

Removes all existing windows and measurements from the application. (Unlike Preset, does not create a new measurement.)

VB Syntax

app.Reset

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Reset

C++ Syntax

HRESULT raw_Reset()

Interface

IApplication


Restore Cal Kit Defaults Method

About Modifying Cal Kits

RestoreCalKitDefaults Method

Write-only

Description

Restores the original properties of the specified Cal Kit, overwritting the last definition with the factory defaults.

VB Syntax

app.RestoreCalKitDefaults (calKit)

Variable

(Type) - Description

app

Application (object)

calKit

(enum NACalKit) - Calibration Kit to restore. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaults naCalKit_MechKit10

C++ Syntax

HRESULT raw_RestoreCalKitDefaults\(tagNACalKit kit)

Interface

IApplication


Restore Cal Kit Defaults All Method

About Modifying Cal Kits

RestoreCalKitDefaultsAll Method

Write-only

Description

Restores the original properties of ALL of the Cal Kits, overwritting the last definitions with the factory defaults.

VB Syntax

app.RestoreCalKitDefaultsAll

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaultsAll

C++ Syntax

HRESULT raw_RestoreCalKitDefaultsAll()

Interface

IApplication


About Saving Files

Save Method

Write-only

Description

Saves the current measurement state, calibration state, or both, to the analyzer's hard drive. The saved state can be recalled using app.Recall.

VB Syntax

app.Save(filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be saved.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents.

To save to a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Save(mystate.sta) 'Saves "mystate.sta" to the default folder
app.Save("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Saves "mystate.cst" to the specified folder

C++ Syntax

HRESULT raw_Save(BSTR bstrFile)

Interface

IApplication


Save Kits Method

About Modifying Cal Kits

SaveKits Method

Write-only

Description

Saves the cal kits, typically after modifying a calibration kit. To load a cal kit into the analyzer from the hard drive, use app.RecallKits.

VB Syntax

app.SaveKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveKits

C++ Syntax

HRESULT raw_SaveKits()

Interface

IApplication


Search Filter Bandwidth Method

About Marker Search

SearchFilterBandwidth Method

Write-only

Description

Searches the measurement data with the current BandwidthTarget (default is -3). To continually track the filter bandwidth, use BandwidthTracking.

This feature uses markers 1-4. If not already, they are activated. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.SearchFilterBandwidth

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.SearchFilterBandwidth

C++ Syntax

HRESULT raw_SearchFilterBandwidth()

Interface

IMeasurement


Search Max Method

About Marker Search

SearchMax Method

Write-only

Description

Searches the marker domain for the maximum value.

VB Syntax

mark.SearchMax

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMax

C++ Syntax

HRESULT raw_SearchMax()

Interface

IMarker


Search Min Method

About Marker Search

SearchMin Method

Write-only

Description

Searches the marker domain for the minimum value.

VB Syntax

mark.SearchMin

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMin

C++ Syntax

HRESULT raw_SearchMin()

Interface

IMarker


Search Next Peak Method

About Marker Search

SearchNextPeak Method

Write-only

Description

Searches the marker's domain for the next peak value.

VB Syntax

mark.SearchNextPeak

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchNextPeak

C++ Syntax

HRESULT raw_SearchNextPeak()

Interface

IMarker


Search Peak Left Method

About Marker Search

SearchPeakLeft Method

Write-only

Description

Searches the marker's domain for the next VALID peak to the left of the marker.

VB Syntax

mark.SearchPeakLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakLeft

C++ Syntax

HRESULT raw_SearchPeakLeft()

Interface

IMarker


Search Peak Right Method

About Marker Search

SearchPeakRight Method

Write-only

Description

Searches the marker's domain for the next VALID peak
to the right of the marker.

VB Syntax

mark.SearchPeakRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakRight

C++ Syntax

HRESULT raw_SearchPeakRight()

Interface

IMarker


Search Target Method

About Marker Search

SearchTarget Method

Write-only

Description

Searches the marker's domain for the target value (specified with mark.TargetValue). Searches to the right; then at the end of the search domain, begins again at the start of the search domain.

VB Syntax

mark.SearchTarget

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTarget

C++ Syntax

HRESULT raw_SearchTarget()

Interface

IMarker


Search Target Left Method

About Marker Search

SearchTargetLeft Method

Write-only

Description

Moving to the left of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetLeft

C++ Syntax

HRESULT raw_SearchTargetLeft()

Interface

IMarker


Search Target Right Method

About Marker Search

SearchTargetRight Method

Write-only

Description

Moving to the right of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetRight

C++ Syntax

HRESULT raw_SearchTargetRight()

Interface

IMarker


About Performing a Calibration

SetCalInfo Method

Write-only

Description

Specifies the type of calibration. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


Set Center Method

About Marker Functions

SetCenter Method

Write-only

Description

Changes the center stimulus to the stimulus value of the marker. The start stimulus stays the same and the stop is adjusted.

VB Syntax

mark.SetCenter

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCenter

C++ Syntax

HRESULT raw_SetCenter()

Interface

IMarker


Set CW Method

About Markers

SetCW Method

Write-only

Description

Changes the analyzer to sweep type CW mode and sets the CW frequency to the marker's frequency. Does not change anything if current sweep type is other than a frequency sweep.

VB Syntax

mark.SetCW

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCW

C++ Syntax

HRESULT raw_SetCW()

Interface

IMarker


About Marker Functions

SetElectricalDelay Method

Write-only

Description

Changes the measurement's electrical delay to the marker's delay value.

VB Syntax

mark.SetElectricalDelay

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetElectricalDelay

C++ Syntax

HRESULT raw_SetElectricalDelay()

Interface

IMarker


About Analyzer Events

SetFailOnOverRange Method

Write/Read

Description

When set TRUE, configures the analyzer to report outOfRange conditions with an error code. Any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

Note: This method is for the benefit of VB clients. The analyzer automatically adjusts overrange conditions to the closest acceptable setting. The VB user will not See that an overrange occurred because the HRESULT is not returned if it has a success code. For more information, See Events/OverRange.

VB Syntax

app.SetFailOnOverRange state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Overrange conditions report an error code
False (0) - Overrange conditions report a success code

Return Type

Not Applicable

Default

False (0)

VB Example

app.SetFailOnOverRange TRUE
On Error Goto ERRHANDLER

'the following overrange will cause ERRHANDLER to be invoked

channel.StartFrequency = 9.9 GHZ
exit

ERRHANDLER:
print "something failed"

C++ Syntax

HRESULT put_SetFailOnOverRange(VARIANT_BOOL mode)

Interface

IApplication


Set Frequency LowPass Method

About Time Domain

SetFrequencyLowPass Method

Write-only

Description

Set the start frequencies when trans.Mode = LowPass.

VB Syntax

trans.SetFrequencyLowPass

Variable

(Type) - Description

trans

A Transform (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

trans.SetFrequencyLowPass

C++ Syntax

HRESULT raw_SetFrequencyLowPass(void)

Interface

ITransform


About Marker Functions

SetReferenceLevel Method

Write-only

Description

Changes the measurement's reference level to the marker's Y-axis value.

VB Syntax

mark.SetReferenceLevel

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetReferenceLevel

C++ Syntax

HRESULT raw_SetReferenceLevel()

Interface

IMarker


Set Start Method

About Marker Functions

SetStart Method

Write-only

Description

Changes the start stimulus to the stimulus value of the marker. The stop stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStart

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStart

C++ Syntax

HRESULT raw_SetStart()

Interface

IMarker


Set Stop Method

About Marker Functions

SetStop Method

Write-only

Description

Changes the stop stimulus to the stimulus value of the marker. The start stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStop

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStop

C++ Syntax

HRESULT raw_SetStop()

Interface

IMarker


Show Marker Readout Method

About Display Formatting

ShowMarkerReadout Method

Write-only

Description

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window.

VB Syntax

win.ShowMarkerReadout state

Variable

(Type) - Description

win

A NAWindow (object)

state

(boolean) -
True (1) - Show the Marker readout
False (0) - Hide the Marker readout

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowMarkerReadout True

C++ Syntax

HRESULT raw_ShowMarkerReadout(VARIANT_BOOL bState)

Interface

INAWindow


Show Status Bar Method

About Display Formatting

ShowStatusBar Method

Write-only

Description

Shows and Hides the Status Bar. The Status Bar is located across the bottom of the display. The following information is shown for the active measurement:

  • Channel number

  • Parameter

  • Correction On or Off

  • Remote or Local operation

VB Syntax

app.ShowStatusBar state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Status Bar
False (0) - Hide the Status Bar

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStatusBar True

C++ Syntax

HRESULT raw_ShowStatusBar (VARIANT_BOOL bState)

Interface

IApplication


Show Stimulus Method

About Display Formatting

ShowStimulus Method

Write-only

Description

Shows and Hides the Stimulus (X-axis) information located at the bottom of the display. The start and stop stimulus values are shown for the active measurement.

VB Syntax

app.ShowStimulus state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Stimulus information
False (0) - Hide the Stimulus information

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStimulus True

C++ Syntax

HRESULT raw_ShowStimulus(VARIANT_BOOL bState)

Interface

IApplication


Show Table Method

About Display Formatting

ShowTable Method

Write-only

Description

Shows or Hides the specified table for the window's active measurement in the lower part of the window.

VB Syntax

win.ShowTable value

Variable

(Type) - Description

win

A NAWindow (object)

value

(enum naTable) - The table to show or hide. Choose from:

0 - naTable_None
1 - naTable_Marker
2 - naTable_Segment
3 - naTable_Limit

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowTable naTable_limit

C++ Syntax

HRESULT raw_ShowTable (tagNATableType table)

Interface

INAWindow


Show Title Bars Method

About Display Formatting

ShowTitleBars Method

Write-only

Description

Shows and Hides the Title Bars. The Title Bars are across the top of the Network Analyzer Window and each of the measurement windows. The Window name is shown in the Title Bar.

VB Syntax

app.ShowTitleBars state

Variable

(Type) - Description

app

Application (object)

state

(boolean)
True (1) - Show the Title Bars
False (0) - Hide the Title Bars

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowTitleBars True

C++ Syntax

HRESULT raw_ShowTitleBars\(VARIANT_BOOL bState)

Interface

IApplication


Show Toolbar Method

About Display Formatting

ShowToolbar Method

Write-only

Description

Shows and Hides the specified Toolbar.

VB Syntax

app.ShowToolbar toolbar,state

Variable

(Type) - Description

app

Application (object)

toolbar

(enum NAToolbarType) - The toolbar to show or hide. Choose from:

0 - naToolbar_None
1 - naToolbar_ActiveEntry
2 - naToolbar_Markers
3 - naToolbar_Measurement
4 - naToolbar_Stimulus
5 - naToolbar_SweepControl

state

(boolean) -
True (1) - Show the specified toolbar
False (0) - Hide the specified toolbar

Return Type

Not Applicable

Default

1 - naToolbar_ActiveEntry showing; all others hiding.

Examples

app.ShowToolbar 1,1 'shows the active entry toolbar

C++ Syntax

HRESULT raw_ShowToolbar(tagNAToolbarType toolbar, VARIANT_BOOL bState)

Interface

IApplication


About Triggering

Single Method

Write-only

Description

Sets the trigger count to 1, which will cause the channel to respond to exactly one trigger signal from any source (internal, external, or manual).

VB Syntax

chan.Single [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) -Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

sync = True
chan.Single sync

C++ Syntax

HRESULT raw_Single(VARIANT_BOOL bWait)

Interface

IChannel


About Analyzer Events

OnCalEvent

Description

Triggered by a calibration event. See a list of CAL Events.

VB Syntax

Sub app_OnCalEvent(ByVal eventID As Variant, ByVal chanNum As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnCalEvent(ByVal eventID As Variant, ByVal channelNumber As Variant, ByVal measurementNumber As Variant)
'
MsgBox ("A Calibration event has occured")
End Sub

C++ Syntax

HRESULT OnCalEvent(VARIANT eventID, VARIANT channelNumber, VARIANT measurementNumber)

Interface

IApplication


CAL Events (802)

MSG_CAL_STD_NEEDED
Calibration cannot be completed until you have measured all the necessary standards for your selected Cal Type.
HRESULT 0x68020201L

MSG_CAL_REQUIRED
Calibration is required before correction can be turned on. Channel number is <x>, Measurement is <x>.
HRESULT 0x68020203L

MSG_CAL_CORRECTION_TURNED_OFF
Critical parameters in your current instrument state do not match the parameters for the calibration set, therefore correction has been turned off. The critical instrument state parameters are sweep type, start frequency, frequency span, and number of points.
HRESULT 0x68020204L

MSG_CAL_CALTYPE_SET_TO_NONE
Cal Type is set to NONE for Channel <x>, Measurement <x>; please select Calibration menu or press Cal hard key.
HRESULT 0x68020208L

MSG_PROPERTIES_NO_USER_CAL
No user calibration found for this channel.
HRESULT 0x6802020EL

MSG_CAL_DOES_NOT_NEED_STD
You do not need to acquire this standard for this calibration type.
HRESULT 0x6802020FL

MSG_ECAL_COULD_NOT_CONFIGURE
Could not configure the Electronic Calibration system. Check to see if the module is plugged into the proper connector.
HRESULT 0x68020210L

MSG_ECAL_ERROR_1
DATA OUT OF RANGE: Design Limits Exceeded
HRESULT 0x68020211L

MSG_ECAL_ERROR_2
EXECUTION ERROR: Array dimensions mismatched
HRESULT 0x68020212L

MSG_ECAL_ERROR_3
EXECUTION ERROR: Array div by zero
HRESULT 0x68020213L

MSG_ECAL_ERROR_4
EXECUTION ERROR: Array function invalid
HRESULT 0x68020214L

MSG_ECAL_ERROR_5
EXECUTION ERROR: Array index error
HRESULT 0x68020215L

MSG_ECAL_ERROR_6
EXECUTION ERROR: Array index out of range
HRESULT 0x68020216L

MSG_ECAL_ERROR_7
EXECUTION ERROR: Arrays wrong rank
HRESULT 0x68020217L

MSG_ECAL_ERROR_8
EXECUTION ERROR: CPU
HRESULT 0x68020218L

MSG_ECAL_ERROR_9
EXECUTION ERROR: Cannot ERASE module
HRESULT 0x68020219L

MSG_ECAL_ERROR_10
EXECUTION ERROR: Cannot WRITE module
HRESULT 0x6802021AL

MSG_ECAL_ERROR_11
EXECUTION ERROR: Entry Not Found
HRESULT 0x6802021BL

MSG_ECAL_ERROR_12
EXECUTION ERROR: Invalid command while system is busy
HRESULT 0x6802021CL

MSG_ECAL_ERROR_13
Electronic Cal: The Module is NOT in RF path. Please connect it to the port indicated.
HRESULT 0x6802021DL

MSG_ECAL_ERROR_14
EXECUTION ERROR: NO SPACE for NEW CAL, DELETE A CAL
HRESULT 0x6802021EL

MSG_ECAL_ERROR_15
EXECUTION ERROR: No More Room
HRESULT 0x6802021FL

MSG_ECAL_ERROR_16
EXECUTION ERROR: Other array error
HRESULT 0x68020220L

MSG_ECAL_ERROR_17
EXECUTION ERROR: Ranks not equal
HRESULT 0x68020221L

MSG_ECAL_ERROR_18
EXECUTION ERROR: Too few CONSTANT ranks
HRESULT 0x68020222L

MSG_ECAL_ERROR_19
EXECUTION ERROR: Too few VARYing ranks
HRESULT 0x68020223L

MSG_ECAL_ERROR_20
EXECUTION ERROR: Unknown error
HRESULT 0x68020224L

MSG_ECAL_ERROR_21
EXECUTION ERROR: ecaldrvr.dll bug or invalid module #
HRESULT 0x68020225L

MSG_ECAL_ERROR_22
EXECUTION ERROR: unexpected error code from ecal driver
HRESULT 0x68020226L

MSG_ECAL_ERROR_23
EXECUTION ERROR: unexpected internal driver error
HRESULT 0x68020227L

MSG_ECAL_ERROR_24
HARDWARE ERROR: Can't access ECal Interface Module
HRESULT 0x68020228L

MSG_ECAL_ERROR_25
HARDWARE ERROR: Can't release LPT port, reboot
HRESULT 0x68020229L

MSG_ECAL_ERROR_26
HARDWARE ERROR: VNA Error
HRESULT 0x6802022AL

MSG_ECAL_ERROR_27
HARDWARE ERROR: not enough data read from ECal module
HRESULT 0x6802022BL

MSG_ECAL_ERROR_28
OPERATION ABORTED BY HOST COMPUTER
HRESULT 0x6802022CL

MSG_ECAL_ERROR_29
OPERATION ABORTED BY USER
HRESULT 0x6802022DL

MSG_ECAL_ERROR_30
OUT OF MEMORY
HRESULT 0x6802022EL

MSG_ECAL_ERROR_31
QUERY INTERRUPTED:Message(s Abandoned
HRESULT 0x6802022FL

MSG_ECAL_ERROR_32
QUERY UNTERMINATED: INCOMPLETE PROGRAMMessage
HRESULT 0x68020230L

MSG_ECAL_ERROR_33
QUERY UNTERMINATED: NOTHING TO SAY
HRESULT 0x68020231L

MSG_ECAL_ERROR_34
QUEUE OVERFLOW
HRESULT 0x68020232L

MSG_ECAL_ERROR_35
SETTINGS CONFLICT: ADDITIONAL STANDARDS ARE NEEDED
HRESULT 0x68020233L

MSG_ECAL_ERROR_36
SETTINGS CONFLICT: Adapter Cal is NOT possible
HRESULT 0x68020234L

MSG_ECAL_ERROR_37
SETTINGS CONFLICT: COMMAND OUT OF SEQUENCE
HRESULT 0x68020235L

MSG_ECAL_ERROR_38
SETTINGS CONFLICT: Cal STOPPED - VNA SETUP CHANGED
HRESULT 0x68020236L

MSG_ECAL_ERROR_39
SETTINGS CONFLICT: Calibration is NOT in progress
HRESULT 0x68020237L

MSG_ECAL_ERROR_40
SETTINGS CONFLICT: Can't find specified GPIB board
HRESULT 0x68020238L

MSG_ECAL_ERROR_41
SETTINGS CONFLICT: Can't find/load gpib32.dll
HRESULT 0x68020239L

MSG_ECAL_ERROR_42
SETTINGS CONFLICT: Can't find/load sicl32.dll
HRESULT 0x6802023AL

MSG_ECAL_ERROR_43
SETTINGS CONFLICT: Can't initialize VNA (bad address?
HRESULT 0x6802023BL

MSG_ECAL_ERROR_44
SETTINGS CONFLICT: Can't load LPT port driver or USB driver DLL
HRESULT 0x6802023CL

MSG_ECAL_ERROR_45
SETTINGS CONFLICT: Invalid Calibration Sweep Mode.
HRESULT 0x6802023DL

MSG_ECAL_ERROR_46
SETTINGS CONFLICT: Invalid Calibration Type
HRESULT 0x6802023EL

MSG_ECAL_ERROR_47
SETTINGS CONFLICT: Invalid Calibration
HRESULT 0x6802023FL

MSG_ECAL_ERROR_48
SETTINGS CONFLICT: Invalid GPIB board number specified
HRESULT 0x68020240L

MSG_ECAL_ERROR_49
SETTINGS CONFLICT: Invalid GPIB board type specified
HRESULT 0x68020241L

MSG_ECAL_ERROR_50
SETTINGS CONFLICT: Invalid Module Status
HRESULT 0x68020242L

MSG_ECAL_ERROR_51
SETTINGS CONFLICT: Invalid States
HRESULT 0x68020243L

MSG_ECAL_ERROR_52
SETTINGS CONFLICT: LPT port must be between 1 and 4
HRESULT 0x68020244L

MSG_ECAL_ERROR_53
Could not configure the Electronic Calibration system. Check to see if the module is properly connected.
HRESULT 0x68020245L

MSG_ECAL_ERROR_54
SETTINGS CONFLICT: Specified LPT port does not exist
HRESULT 0x68020246L

MSG_ECAL_ERROR_55
SETTINGS CONFLICT: Use frequency domain for cal
HRESULT 0x68020247L

MSG_ECAL_ERROR_56
SETTINGS CONFLICT: Use step sweep type for cal.
HRESULT 0x68020248L

MSG_ECAL_ERROR_57
SETTINGS CONFLICT: VNA address must be between 0 and 30
HRESULT 0x68020249L

MSG_ECAL_ERROR_58
SETTINGS CONFLICT: Wrong LPT port driver or USB driver DLL
HRESULT 0x6802024AL

MSG_ECAL_ERROR_59
SYNTAX ERROR: ECAL:DELAY command must have 2 numbers
HRESULT 0x6802024BL

MSG_ECAL_ERROR_60
SYNTAX ERROR: INCORRECT SYNTAX
HRESULT 0x6802024CL

MSG_ECAL_ERROR_61
SYNTAX ERROR: UNKNOWN COMMAND
HRESULT 0x6802024DL

E_NA_CALTYPE_NONE
CalType not set.
HRESULT 0xE8020260L


About Analyzer Events

OnChannelEvent

Description

Triggered by a channel event. See a list of Channel Events

VB Syntax

Sub app_OnChannelEvent(ByVal eventID As Variant, ByVal chanNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnChannelEvent(ByVal eventID As Variant, ByVal channelNumber As Variant)
MsgBox "A channel event occured"
End Sub

C++ Syntax

HRESULT OnChannelEvent(VARIANT eventID, VARIANT channelNumber)

Interface

IApplication


Channel Events (807)

MSG_CHANNEL_SWEEP_COMPLETE
Sweep Complete.
HRESULT 0x68070700L

MSG_CHANNEL_TRIGGER_COMPLETE
All triggerable acqusitions have completed.
HRESULT 0x68070701L

MSG_CHANNEL_TRIGGER_ABORTED
The last trigger produced an aborted sweep.
HRESULT 0x68070702L

E_NA_NO_CHANNEL
Channel not found.
HRESULT 0xE8070750L

E_NA_SWEEP_SEGMENT_NOT_FOUND
The requested sweep segment was not found.
HRESULT 0xE8070751L


About Analyzer Events

OnDisplayEvent

Description

Triggered by a display event. See a list of Display Events

VB Syntax

Sub app_OnDisplayEvent(ByVal eventID As Variant, ByVal winNum As Variant, ByVal traceNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

winNum

Window Number of the event

traceNum

Trace Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnDisplayEvent(ByVal eventID As Variant, ByVal windowNumber As Variant, ByVal traceNumber As Variant)
MsgBox ("A Display event has occured")
End Sub

C++ Syntax

HRESULT OnDisplayEvent(VARIANT eventID, VARIANT windowNumber, VARIANT traceNumber)

Interface

IApplication


Display Events (806)

MSG_EXCEED_MAX_TRACES
Exceeded the maximum of <x> traces in each window. The trace for <x> will not be added to window <x>.
HRESULT 0xA8060600L

MSG_EXCEED_MAX_DATA_WINDOWS
Exceeded the maximum of <x> data windows. New window will not be created.
HRESULT 0xA8060601L

MSG_NO_DATA_WINDOWS
No Data Windows are present. Unable to complete operation.
HRESULT 0xA8060602L

MSG_NO_TRACE_FOUND
No data traces are present in the selected window. Operation not completed.
HRESULT 0xA8060603L

MSG_ARRANGE_WINDOW_EXCEED_CAPACITY
Cannot complete request to arrange existing measurements in <x> windows due to the limit of <x> traces per window.
HRESULT 0x68060604L

E_NA_NO_WINDOW
Window not found.
HRESULT 0xE8060650L

E_NA_DUPLICATE_WINDOW
Duplicate window ID specified.
HRESULT 0xE8060651L

E_NA_EXCEED_MAX_WINDOWS
Exceeded limit on number of windows.
HRESULT 0xE8060652L

E_NA_EXCEED_MAX_NUM_TRACES
Exceeded limit on number of traces/window.
HRESULT 0xE8060653L

E_NA_NO_TRACE
Trace not found.
HRESULT 0xE8060654L


About Analyzer Events

OnHardwareEvent

Description

Triggered by a hardware event. See a list of Hardware Events

VB Syntax

Sub app_OnHardwareEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnHardwareEvent(ByVal eventID As Variant)
MsgBox ("A Hardware event has occured")
End Sub

C++ Syntax

HRESULT OnHardwareEvent(VARIANT eventID)

Interface

IApplication


Hardware Events (803)

MSG_POWER_TRIPPED
The input power is too high. The source power is shut off.
HRESULT 0xA8030302L

MSG_POWER_TRIP_CORRECTED
The source power has been restored.
HRESULT 0x68030303L

MSG_DSP_BOARD_NOT_FOUND
The spampnp.sys driver is not working. Check system hardware.
! Data will be simulated. !
HRESULT 0xE8030304L

MSG_INSTRUMENT_SERIAL_BUS_BAD
Instrument Serial Bus Not Working.
HRESULT 0xE8030305L

E_NA_PHASELOCK
The hardware has lost phaselock.
HRESULT 0xE8030350L

E_NA_HARDWARE
General Hardware Error.
HRESULT 0xE8030351L

E_NA_DSPCOMM
The CPU cannot communicate with the DSP processor.
HRESULT 0xE8030352L

E_NA_RFPOWEROFF
The RF Power is Off.
HRESULT 0xE8030353L

S_NA_RFPOWERON
The RF Power is On.
HRESULT 0x28030354L

S_NA_HARDWAREOK
The hardware is functioning properly.
HRESULT 0x28030355L

E_NA_UNLEVELED
The source power is unleveled.
HRESULT 0xE8030356L

E_NA_OVERLOAD
Input overload. Please reduce power.
HRESULT 0xE8030357L

E_NA_YIG_CAL_FAILED
The yig oscillator failed to calibrate.
HRESULT 0xE8030358L

E_NA_RAMP_CAL_FAILED
The analog ramp failed to calibrate.
HRESULT 0xE8030359L

E_NA_OVERTEMP
The source temperature is too high. Improve air flow.
HRESULT 0xE803035AL

E_NA_EE_WRT_ERR
Writing to the EEPROM failed.
HRESULT 0xE803035BL

E_NA_SET_EE_WRT_ERR

HRESULT 0xE803035CL

E_NA_CLR_EE_WRT_ERR
E_NA_CLR_EE_WRT_ERR
HRESULT 0xE803035DL

E_NA_SET_RAMP_CAL_FAILED
E_NA_SET_RAMP_CAL_FAILED
HRESULT 0xE803035EL

E_NA_CLR_RAMP_CAL_FAILED

E_NA_CLR_RAMP_CAL_FAILED

#define E_NA_CLR_RAMP_CAL_FAILED ((HRESULT)0xE803035FL)

E_NA_CLR_YIG_CAL_FAILED

E_NA_CLR_YIG_CAL_FAILED

#define E_NA_CLR_YIG_CAL_FAILED ((HRESULT)0xE8030360L)

E_NA_SET_YIG_CAL_FAILED

E_NA_SET_YIG_CAL_FAILED

#define E_NA_SET_YIG_CAL_FAILED ((HRESULT)0xE8030361L)

E_NA_SET_OVER_TEMP

E_NA_SET_OVER_TEMP

#define E_NA_SET_OVER_TEMP ((HRESULT)0xE8030362L)

E_NA_CLR_OVER_TEMP

E_NA_CLR_OVER_TEMP

#define E_NA_CLR_OVER_TEMP ((HRESULT)0xE8030363L)

E_NA_SET_UNLEVEL

E_NA_SET_UNLEVEL

#define E_NA_SET_UNLEVEL ((HRESULT)0xE8030364L)

E_NA_CLR_UNLEVEL

E_NA_CLR_UNLEVEL

#define E_NA_CLR_UNLEVEL ((HRESULT)0xE8030365L)

E_NA_SET_OVERLOAD

E_NA_SET_OVERLOAD

#define E_NA_SET_OVERLOAD ((HRESULT)0xE8030366L)

E_NA_CLR_OVERLOAD

E_NA_CLR_OVERLOAD

#define E_NA_CLR_OVERLOAD ((HRESULT)0xE8030367L)

E_NA_SET_UNLOCK

E_NA_SET_UNLOCK

#define E_NA_SET_UNLOCK ((HRESULT)0xE8030368L)

E_NA_CLR_UNLOCK

E_NA_CLR_UNLOCK

#define E_NA_CLR_UNLOCK ((HRESULT)0xE8030369L)


About Analyzer Events

OnMeasurementEvent

Description

Triggered by a measurement event. See a list of Measurement Events.

VB Syntax

Sub app_OnMeasurementEvent(ByVal eventID As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnMeasurementEvent(ByVal eventID As Variant, ByVal measurementNumber As Variant)

MsgBox ("A Measurement event has occured")

End Sub

C++ Syntax

HRESULT OnMeasurementEvent(VARIANT eventID, VARIANT measurementNumber)

Interface

IApplication


Measure Events (804)

MSG_NO_VALID_MEMORY_TRACE
If you are going to display or otherwise use a memory trace, you must first store a data trace to memory.
HRESULT 0xA8040400L

MSG_MEASUREMENT_DELETE_FAIL
The measurement failed to shut down properly. The application is in a corrupt state and should be shut down and restarted.
HRESULT 0xE8040401L

MSG_MEASUREMENT_WAIT_THREAD_FAIL
The measurement failed to shut down properly. The update thread failed to exit properly.
HRESULT 0xA8040402L

MSG_GROUPDELAY_FORMAT_NOT_VALID
Group Delay format with CW Time or Power sweeps produces invalid data.
HRESULT 0xA8040403L

MSG_LIMIT_FAILED
MSG_LIMIT_FAILED
HRESULT 0x68040404L

MSG_LIMIT_PASSED
MSG_LIMIT_PASSED
HRESULT 0x68040405L

MSG_EXCEED_MAX_MEAS
Exceeded the maximum number of measurements allowed.
HRESULT 0xA8040406L

MSG_NETANA_ERROR_ADDNEWMEAS
Network Analyzer Internal Error. Unexpected error in AddNewMeasurement.
HRESULT 0xA8040407L

MSG_NO_MEASUREMENT_FOUND
No measurement was found to perform the selected operation. Operation not completed.
HRESULT 0xA8040408L

MSG_MARKER_ALL_OFF_FAILED
The Markers All Off command failed.
HRESULT 0xA8040409L

MSG_MEMORY_NOT_SAVED
A memory trace has not been saved for the selected trace. Save a memory trace before attempting trace math operations.
HRESULT 0xA804040AL

MSG_SET_AVERAGE_COMPLETE
MSG_SET_AVERAGE_COMPLETE
HRESULT 0x6804040BL

MSG_CLEAR_AVERAGE_COMPLETE
MSG_CLEAR_AVERAGE_COMPLETE
HRESULT 0x6804040CL

MSG_TIME_DOMAIN_MINIMUM_POINTS
Time Domain transform requires at least %1 input points. The transform has been deactivated.
HRESULT 0x6804040DL

E_NA_EXCEED_MAX_NUM_MEAS
Exceeded limit on number of measurements.
HRESULT 0xE8040450L

E_NA_BAD_PARAMETER
Parameter not valid.
HRESULT 0xE8040451L

E_NA_NO_MEAS
Measurement not found.
HRESULT 0xE8040452L

E_NA_NO_MEMORY_BUFFER
No valid memory trace.
HRESULT 0xE8040453L

E_NA_NO_REFERENCE_MARKER
The reference marker was not found.
HRESULT 0xE8040454L

E_NA_TRACE_MATH_RESET
Data and Memory traces are no longer compatible. Trace Math has been turned off.
HRESULT 0xA8040455L

E_NA_MEMORY_TRACE_NOT_COMPATIBLE
Data and Memory traces are not compatible. For valid trace math operations, memory and data traces must have similar measurement conditions.
HRESULT 0xE8040456L


About Analyzer Events

OnSCPIEvent

Description

Triggered by a SCPI event. See a list of SCPI Events

VB Syntax

Sub app_OnSCPIEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSCPIEvent(ByVal eventID As Variant)
MsgBox ("A SCPI event has occured")
End Sub

C++ Syntax

HRESULT OnSCPIEvent(VARIANT eventID )

Interface

IApplication


Parse Events

MSG_NOTHING_TO_SAY
You have sent a read command to the analyzer without first requesting data with an appropriate output command. The analyzer has no data in the output queue to satisfy the request.
HRESULT 0x68050501L

MSG_ANOTHER_CTRL
You must remove the active controller from the bus or the controller must relinquish the bus before the analyzer can assume the system controller mode.
HRESULT 0xE8050502L

MSG_BLOCK_INPUT_ERROR
The analyzer did not receive a complete data transmission. This is usually caused by an interruption of the bus transaction.
HRESULT 0xE8050503L

MSG_SCPI_STATUS_BYTE_CHANGE
The instrument status byte has changed.
HRESULT 0x68050504L

MSG_BAD_SCPI_COMMAND
The SCPI command received has caused error number <x>: "<x>".
HRESULT 0x68050505L

MSG_PARSER_COMMAND_LOG
Parser got command: <x>
HRESULT 0x680505FFL


About Analyzer Events

OnSystemEvent

Description

Triggered by a system event. See a list of System Events

VB Syntax

Sub app_OnSystemEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSystemEvent(ByVal eventID As Variant)
MsgBox ("A System event has occured")
End Sub

C++ Syntax

HRESULT OnSystemEvent(VARIANT eventID)

Interface

IApplication


General Events (808)

MSG_OPTION_NOT_INSTALLED
The function you requested requires a capability provided by an option to the standard analyzer. That option is not currently installed.
HRESULT 0x68080800L

MSG_FEATURE_NOT_AVAILABLE
The feature you requested is not available on the current instrument.
HRESULT 0x68080801L

MSG_FEATURE_NOT_VALID
The feature you requested is incompatible with the current instrument state.
HRESULT 0x68080802L

MSG_SAVEFILE_OK
<x> has been saved.
HRESULT 0x68080803L

MSG_SAVEFILE_FAIL
Attempt to save <x> failed.
HRESULT 0xA8080804L

MSG_RECALLFILE_FILE_NOT_FOUND
Attempt to recall file failed because <x> was not found.
HRESULT 0x68080805L

MSG_RECALLFILE_BAD_HEADER
<x> has a bad header.
HRESULT 0x68080806L

MSG_POWER_HIBERNATE
Request to enter hibernate state.
HRESULT 0x68080807L

MSG_POWER_HIBERNATE_AUTOMATIC
Power up from automatic hibernate state. Program received PBT_APMRESUMEAUTOMATIC Message.
HRESULT 0x68080808L

MSG_POWER_HIBERNATE_SUSPEND
Power up from suspend hibernate state. Program received PBT_APMRESUMESUSPEND Message.
HRESULT 0x68080809L

MSG_POWER_HIBERNATE_CRITICAL
Power up from suspend hibernate state. Program received PBT_APMRESUMECRITICAL Message.
HRESULT 0xA808080AL

MSG_POWER_HIBERNATE_UIFAILSAFE
Power up from unknown hibernate state UI recovery called. Program received no PBT_Message within the time alloted and is attempting recovery.
HRESULT 0xA808080BL

MSG_SAVEFILE_DUP
<x> already exists. File is being overwritten.
HRESULT 0x6808080CL

MSG_SAVEFILE_NOTDONE
File has not been saved.
HRESULT 0x6808080DL

MSG_RECALLFILE_SUCCESS
File <x> has been recalled.
HRESULT 0x6808080EL

E_NA_INVALIDFORMAT
The specified format is invalid.
HRESULT 0xE8080850L

E_NA_EXCEPTION
WINNT exception caught by Automation layer.
HRESULT 0xE8080851L

E_NA_BADPORT
Bad port specification.
HRESULT 0xE8080852L

E_NA_TRIGGERIGNORED
Manual trigger ignored.
HRESULT 0xE8080854L

E_NA_TRIGGERDENIED
Attempt to set trigger failed.
HRESULT 0xE8080855L

E_NA_DATA_LENGTH
Block data length error.
HRESULT 0xE8080859L

E_NA_DATA_NOT_FOUND
Requested data not found.
HRESULT 0xE808085BL


About Analyzer Events

OnUserEvent

Description

Reserved for future use.

VB Syntax

Sub app_OnUserEvent


Getting Trace Data from the Analyzer

This Visual Basic program:

  • Retrieves Scalar Data from the Analyzer and plots it.

  • Retrieves Paired Data from the Analyzer and plots it.

  • Retrieves Complex Data from the Analyzer and plots it.

To use this code, prepare a form with the following:

  • Two MSCharts named MSChart1 and MSChart2

  • Three buttons named getScalar, getPaired, getComplex

'Put this in a module
Public dlocation As NADataStore
Public numpts As Long
Public fmt As NADataFormat
Public app As Application
Public measData As IArrayTransfer
Public chan As Channel

Sub Form_Load()
'Change analyzerName to your analyzer's full computer name
Set app = CreateObject("AgilentPNA835x", "analyzerName")
Set measData = app.ActiveMeasurement
Set chan = app.ActiveChannel
numpts = chan.NumberOfPoints

'To pick a location to get the data from remove the comment from one of these
dlocation = naRawData
'dlocation = naCorrectedData
'dlocation = naMeasResult
'dlocation = naRawMemory
'dlocation = naMemoryResult

'setup MSchart
'right click on the chart and select:
' - line chart
' - data in rows
End Sub

Sub GetComplex_Click()
ReDim Data(numpts) As NAComplex
Dim Real(201)
Dim Imag(201)
'You cannot change the format of Complex Data
Call trigger
'get data
measData.GetNAComplex dlocation, numpts, Data(0)
'plot data
Dim i As Integer

For i = 0 To numpts - 1
 Real(i) = Data(i).Re
 Imag(i) = Data(i).Im
Next i
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetPaired_Click()
ReDim Real(numpts) As Single
ReDim Imag(numpts) As Single
' To pick a format, remove the comment from one of these
fmt = naLogMagPhase
'fmt = naLinMagPhase
Call trigger
'Get data
measData.getPairedData dlocation, fmt, numpts, Real(0), Imag(0)
'Plot Scalar
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetScalar_Click()
ReDim Data(numpts) As Single
'To pick a format remove the comment from one of these
fmt = naDataFormat_LogMag
'fmt = naDataFormat_LinMag
'fmt = naDataFormat_Phase
'fmt = naDataFormat_Delay
'fmt = naDataFormat_Real
'fmt = naDataFormat_Imaginary
Call trigger
'Get data
measData.GetScalar dlocation, fmt, numpts, Data(0)
'Plot Data
MSChart1 = Data()
MSChart2.Visible = False
Call Sweep
End Sub

Sub trigger()
'The analyzer send continuous trigger signals
app.TriggerSignal = naTriggerInternal
'The channel will only accept one, then go into hold
chan.Single sync
End Sub

Sub Sweep()
'The channel goes back to accepting all triggers
chan.Continuous
End Sub


Limit Line Testing Example with COM

Limit Line Testing with COM

This Visual Basic program:

  • Turns off existing Limit Lines

  • Establishes Limit Lines with the following settings:

    • Frequency range - 4 GHz to 8 GHz

    • Maximum value - (10dB)

    • Minimum value - (-30dB)

  • Turns on Lines, Testing, and Sound

To use this code, prepare a form with the following:

  • None

Public limts As LimitTest
Set limts = meas.LimitTest
'All Off
For i = 1 To 20
limts(i).Type = naLimitSegmentType_OFF
Next i

'Set up Limit Lines
limts(1).Type = naLimitSegmentType_Maximum
limts(1).BeginResponse = 10
limts(1).EndResponse = 10
limts(1).BeginStimulus = 4000000000#
limts(1).EndStimulus = 8000000000#
limts(2).Type = naLimitSegmentType_Minimum
limts(2).BeginResponse = -30
limts(2).EndResponse = -30
limts(2).BeginStimulus = 4000000000#
limts(2).EndStimulus = 8000000000#

'Turn on Lines, Testing, and Sound
limts.LineDisplay = 1
limts.State = 1
limts.SoundOnFail = 1


C++ Example

The following example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries.

Also notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

// An example program to illustrate the use of #import
 to bind to the
// PNA type library.
//
#include "stdafx.h"
#include "stdio.h"
#include "math.h"

/////////////////////////////////////////////
// import the network analyzer type library
/////////////////////////////////////////////
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
 no_namespace, named_guids
/////////////////////////////////////////////
// include the error definitions for the PNA so we can implement
// error handling.
/////////////////////////////////////////////
#include "C:\Program Files\Agilent\Network Analyzer\errorsystemmessage.h"

IApplicationPtr pNA; // top level application pointer
float fScalarData [1601]; // global buffer for data retrieval
float fScalarData2[1601];

DWORD dwCookie;

/////////////////////////////////////////////
// SetupChannel:
//
// input: pointer to the channel
//
// function: sets properties on the channel
/////////////////////////////////////////////
void SetupChannel(IChannelPtr pChannel)
{
pChannel->put_StartFrequency( 1.2E9 );
pChannel->put_StopFrequency ( 4.2E9 );
pChannel->put_NumberOfPoints ( 201);

}

/////////////////////////////////////////////
// AcquireData:
//
// input: pointer to the channel
//
// function: single sweeps the channel
/////////////////////////////////////////////
void AcquireData( IChannelPtr pChannel )
{
pChannel->Single( TRUE );
}

/////////////////////////////////////////////
// ReadData:
//
// input: pointer to the Measurement object
//
// function: reads data from the measurment's formatted
// result data buffer
/////////////////////////////////////////////
void ReadScalarData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pData = fScalarData;

if(pDataTransfer){

pDataTransfer->getScalar( naMeasResult, naDataFormat_LogMag,
 &numVals, pData);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\n",i,pData[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}

void ReadComplexData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pReal= fScalarData;
float* pImag = fScalarData2;

if(pDataTransfer){

pDataTransfer->getPairedData( naRawData, naRealImaginary, &numVals,
 pReal, pImag);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\t%f\n",i,pReal[i], pImag[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}
/////////////////////////////////////////////
// PutData:
//
// input: pointer to the Measurement object
//
// function: writes data to the measurment's raw data
// buffer
/////////////////////////////////////////////
void PutData( IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 201;

if(pDataTransfer){

NAComplex* pComplex = new NAComplex[numVals];

pComplex[0].Im = 0;
pComplex[0].Re = 1;
for (int i = 1; i < numVals; i++)
{
pComplex[i].Im = (float)sin(i)/i;
pComplex[i].Re = (float)cos(i)/i;
}

pDataTransfer->putNAComplex( naRawData, numVals, pComplex, naDataFormat_Polar);
delete [] pComplex;
}
}

/////////////////////////////////////////////
// printError
/////////////////////////////////////////////
void printError( HRESULT hr)
{
BSTR text;

hr = pNA->get_MessageText ((NAEventID) hr, &text);
MessageBox(NULL,text,L"Network Analyzer error",0);
::SysFreeString(text);
}

/////////////////////////////////////////////
// main
/////////////////////////////////////////////
int main(int argc, char* argv[])
{
HRESULT hr;
const long channel1 = 1;
const long window1 = 1;
const long srcport = 1;
IMeasurementPtr pMeasurement;
IChannelPtr pChannel;

// initialize COM libraries
CoInitialize(NULL);

try {
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

pNA->put_Visible(TRUE);
pNA->Reset();

pNA->CreateMeasurement (channel1, "S21",srcport, 5);
hr = pNA->get_ActiveChannel( &pChannel);

if (SUCCEEDED (hr))
{
SetupChannel( pChannel);
AcquireData(pChannel);
}

hr= pNA->get_ActiveMeasurement( &pMeasurement);
if (SUCCEEDED(hr))
{
pMeasurement->put_Format( naDataFormat_Polar);
ReadScalarData( pMeasurement);
ReadComplexData( pMeasurement);
PutData(pMeasurement);
}
if (FAILED(hr))
{
printError(hr);
}

// make sure to release the remaining pointers
// before calling CoUninitialize

pMeasurement.Release();
pChannel.Release();
pNA.Release();
}
catch (_com_error err)
{
printError( err.Error() );
}

CoUninitialize();
return 0;
}


COM Fundamentals

The following is terms are discussed in this topic:

Objects

Collections

Methods

Properties

Events

Note: The information contained in this topic is intended to help an experienced SCPI programmer transition to COM programming. This is NOT a comprehensive tutorial on COM programming.

Objects

The objects of the Network Analyzer (Application) are arranged in a hierarchical order. The Network Analyzer object model lists the objects and their relationship to one another.

In SCPI programming, you must first select a measurement before making settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read settings.

For more information on working with objects, see Getting a Handle to an Object.

Collections

A collection is an object that contains several other objects of the same type. For example, the Channels collection contains all of the channel objects.

Note: In the following examples, the collections are referred to as a variable. Before using a collection object, you must first get an instance of that object. For more information, see Getting a Handle to an Object

Generally, items in a collection can be identified by number or by name. The order for objects in a collection cannot be assumed. They are always unordered and begin with 1. For example, in the following procedure, chans(1) is used to set averaging on the first channel in the Channels collection (not necessarily channel 1).

Sub SetAveraging()
chans(1).AveragingFactor = 10
End Sub

The following procedure uses the measurement string name to set the display format for a measurement in the measurements collection.

meass("CH1_S11_1").Format = 1

You can also manipulate an entire collection of objects if the objects share common methods. For example, the following procedure sets the dwell time on all of the segments in the collection.

Sub setDwell()
segs.DwellTime = 30e-3
End Sub

Methods

A method is an action that is performed on an object. For example, Add is a method that applies to the Channel object. The following procedure uses the Add method to add a new channel named NewChan.

Sub AddChan(newChan as String)
Chan.Add NewChan
End Sub

Properties

A property is an attribute of an object that defines one of the object's characteristics, such as size, color, or screen location. A property can also change an aspect of the object's behavior, such as whether the object is visible. In either case, to change the characteristics of an object, you change the values of its properties.

To change the value of a property, follow the reference to an object with:

  • a period (.)

  • the property name

  • an equal sign (=)

  • the new property value.

For example, the following statement sets the IFBandwidth of a channel.

Chan.IFBandwidth = 1KHz

You can also read the current value of a property. The following statement reads the current IFBandwidth of a channel into the variable Ifbw.

Ifbw = Chan.IFBandwidth

Some properties cannot be set and some cannot be read. The Help topic for each property indicates if you can:

  • Set and read the property (Write/Read)

  • Only read the property (Read-only)

  • Only set the property (Write-only)

Events

An event is an action recognized by an object, such as clicking the mouse or pressing a key. Using events, your program can respond to a user action, program code, or triggered by the analyzer. For example:

OnChannelEvent

For more information, see Working with the Analyzer's Events.


Getting a Handle to an Object

The following are discussed in this topic:

What is a Handle

Declaring an Object Variable

Assigning an Object Variable

Navigating the Object Hierarchy

Getting a Handle to a Collection

What is a Handle

In SCPI programming, you must first select a measurement before changing or reading settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read its settings. The following analogy illustrates this:

A car could be called an object. Like all objects, it has many properties. One of its properties is "Color". You can read (by looking) or set (by painting) the color property of a car object. However, the color value (such as Red or Green) depends on what SPECIFIC car object you are referring to. "Car" is a class of objects. You can only read or set the properties of a specific car object; not the entire car class. Therefore, before reading or setting an object's properties, you need to get "a handle" to a specific object.

You can have handles to many objects at the same time. It does NOT have to be the Active or Selected object.

Note: This process is also called "getting an instance of an object", and "returning an object".

There are two steps for getting a handle to analyzer objects:

  1. Declaring a Variable As an Object

  2. Assigning an Object to the Variable

Note: Before doing this, you must first register the analyzer's type library on your PC. See Connecting to the Analyzer

Declaring a Variable As an Object

Note: The examples in these topics use the Visual Basic Programming Language. The Green text following an apostrophe (') is a comment.

Use the Dim statement or one of the other declaration statements (Public, Private, or Static) to declare a variable. The type of variable that refers to an object must be a Variant, an Object, or a specific type of object. For example, all three of the following declarations are valid:

  • Dim RFNA ' Declare RFNA as Variant data type.

  • Dim RFNA As Object ' Declare RFNA as Object data type.

  • Dim RFNA As AgilentPNA835x.Application ' Declare RFNA As AgilentPNA835x.Application type

Note: If you use a variable without declaring it first, the data type of the variable is Variant by default.

If you know the specific object type, you should declare the object variable as that object type. Declaring specific object types provides automatic type checking, faster code, and improved readability.

Assigning an Object to a Variable

The first and most important object to assign to a variable is the Application object (the Network Analyzer). When assigning an object to a variable, use the Set keyword before the object variable that was declared previously. In the following example, "RFNA" is the variable we declared in the previous examples. So we assign the current AgilentPNA835x Application to "RFNA".

Set RFNA = AgilentPNA835x.Application

However, because the AgilentPNA835x object is the Application server, we must use the CreateObject keyword with the (classname,server name) parameters.

  • The classname for the analyzer object is always "AgilentPNA835x.Application".

  • To find your analyzer's server name, see Sharing Files between your PC and the Analyzer.

For example, the following statements would create an instance of the Analyzer object.

Dim RFNA AS AgilentPNA835x.Application
Set RFNA = CreateObject("AgilentPNA835x.Application", "Analyzer46")

Note: These statements will start the Analyzer application if it is not already running on your instrument.

Once created, you can treat an object variable exactly the same as the object to which it refers. You can set or return the properties of the object or use any of its methods. For example:

RFNA.Visible = True 'Makes the Network Analyzer Application visible on the screen

Navigating the Object Hierarchy

To read and set properties of objects below the Analyzer Application, you do not have to "Create" the object as we did with the Application. But you DO have to navigate the object model hierarchy. (Refer to the Analyzer Object Model).

You could do refer to an object in the hierarchy directly, without declaring and assigning a variables. The following example navigates through the Application object to the Active Measurement which is a 'child' object of the Application. (The ACTIVE measurement is the measurement that is acted on if you change settings from the front panel.)

Application.ActiveMeasurement.SmoothingAperture = 10

You can see that this method makes for a very long statement. Making additional changes to the Active Measurement would require equally long statements.

The following example gets a handle to the Active Measurement object by assigning it to a variable.

The first step is to Declare an object variable:

Public meas AS Measurement

The next step is to Set the object variable:

We already assigned an instance of the (analyzer) Application to the variable RFNA. Therefore, we can use the RFNA variable to refer to a specific instance of the Application object.

Set meas = RFNA.ActiveMeasurement

The variable meas now contains a handle to the Application object (RFNA) and the ActiveMeasurement object. We can now set properties of the ActiveMeasurement as follows:

meas.SmoothingAperature = 10

Getting a Handle to a Collection

The analyzer has several collections of objects which provide a convenient way of setting or reading all of the objects in the collection with a single procedure. Also, there are objects (limit lines for example) that can only be accessed through the collection.

To get a handle to an item in a collection, you can refer to the object by item number or sometimes by name. However, you first have to get a handle to the collection. To assign the collection to a variable, use the same two step process (1. declare the variable, 2. assign the variable using 'Set').

Dim meass As Measurements 'the collection of all measurements currently on the analyzer
Set meass = RFNA.Measurements

Then you can iterate through the entire collection of measurements to read or set properties or execute methods.

meass.Format = naLinMag

Or you can read or set a property on an individual object in the collection:

meass(1).Format = naLinMag

Note: Each object and collection has its own unique way of dealing with item names, and numbers. Refer to the Analyzer Object Model for details.


Collections in the Analyzer

Collections are a gathering of similar objects. They are a convenience item used primarily to iterate through the like objects in order to change their settings. Collections generally provide the following generic methods and properties:

Item(n)
Count
Add(n)
Remove(n)

where (n) represents the number of the item in the collection. Some collections may have unique capabilities pertinent to the objects they collect.

Collections are Dynamic

A collection does not exist until you ask for it. When you request a Channels object (see Getting a Handle to an Object / Collection), handles to each of the channel objects are gathered and placed in an array.

For example, if channels 2 and 4 are the only channels that exist, then the array will contain only 2 items. The command 'channels.Count' will return the number 2, and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 4 object.

The ordering of objects within the collection should not be assumed. If you add a channel to the previous example, as in:

Pna.Channels.Add(3)

'channels.Count' will now return 3 and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 3 object.

  • Channels(3) will contain the channel 4 object.

Primarily, collections are useful for making this type of iteration possible:

Dim ch as Channel
For each ch in pna.Channels
Print ch.Number
Print ch.StartFrequency
Print ch.StopFrequency
Next ch

As soon as this for-each block has been executed, the Channels object goes out of scope.


Configure for COM-DCOM Programming

Voir aussi...

Configuration pour la programmation COM-DCOM

Présentation

Concepts
de l'accès

Procédure
d'accès

Enregistrement

Problèmes ?

Avant de développer ou d'exécuter un programme COM, vous devez d'abord établir une communication entre votre PC et l'analyseur, c'est à dire fournir l'accès à l'analyseur. Vous devez ensuite enregistrer la bibliothèque de types d'analyseur sur votre PC.
Concepts de l'accès

Procédures d'accès

Enregistrement de l'analyseur sur le PC

Problèmes ?

Par défaut, les analyseurs de réseau de série PNA sont configurés en usine afin que Tous les utilisateurs puissent lancer l'application PNA à l'aide de COM/DCOM et y accéder. Le terme Tous les utilisateurs fait référence à un ensemble d'utilisateurs différent selon que le PNA est membre d'un Domaine ou d'un Groupe de travail (il doit être membre de l'un ou l'autre, mais pas des deux).

Remarque : DCOM (Distributed Component Object Model) est utilisé lorsque l'accès à l'application analyseur se fait à partir d'un PC à distance.
COM est utilisé lorsque l'accès à l'analyseur se fait à partir du PC de l'analyseur.

Groupe de travail

L'administrateur PNA établit un groupe de travail. Pour ce faire, il déclare le nom du groupe de travail et l'analyseur en tant que membre de ce groupe. La création du groupe de travail ou le contrôle des membres n'est pas du ressort de l'administrateur réseau.

Tous les utilisateurs n'incluent que les utilisateurs qui ont ouvert des comptes de connexion au PNA.

Par défaut, le PNA est configuré en tant que membre d'un groupe de travail nommé WORKGROUP.

Remarque : pour installer un compte de connexion pour un nouvel utilisateur, consultez Autres utilisateurs.
Pour l'accès DCOM, le nom et le mot de passe du compte utilisateur doivent correspondre EXACTEMENT à ceux du compte de connexion sur le PC.

Domaine

Généralement, un domaine est un ensemble d'ordinateurs. Les administrateurs réseau assurent la maintenance du domaine et la gestion du parc machines.

Tous les utilisateurs signifie les utilisateurs membres du domaine. En outre, les utilisateurs disposant de comptes de connexion peuvent également accéder à l'analyseur.

En résumé :

  • Un groupe de travail ne nécessite aucune maintenance mais n'autorise l'accès DCOM qu'aux utilisateurs disposant d'un compte de connexion au PNA.

  • Un domaine requiert un administrateur mais tous les membres de ce domaine et les utilisateurs disposant de comptes de connexion bénéficient de l'accès DCOM au PNA.

Le niveau de sécurité suivant consiste à n'accorder qu'aux utilisateurs sélectionnés (et non à Tous les utilisateurs) du domaine et du groupe de travail l'accès DCOM et la possibilité de lancer l'analyseur.

Remarque : pour pouvoir exécuter cette procédure, l'utilisateur doit être titulaire d'un compte de connexion au PNA. Voir Autres utilisateurs

Cette procédure est utilisée pour :

  • Accorder l'accès à distance (DCOM) et la possibilité de lancement uniquement aux utilisateurs sélectionnés (pas à tous les utilisateurs). Cette possibilité de lancement permet de démarrer l'application analyseur si elle n'est pas déjà ouverte.

  • Vérifier que vous bénéficiez de l'accès DCOM à l'analyseur.

Pour accorder l'accès et la possibilité de lancement, procédez comme suit :

  1. Sur l'analyseur de réseau, cliquez sur le bouton Démarrer de Windows.

  2. Cliquez sur Exécuter.

  3. Dans la zone de texte Ouvrir :, tapez dcomcnfg.

  4. Cliquez sur OK.

  5. Dans la fenêtre Distributed COM Configuration Properties, sélectionnez Agilent PNA Series (Série PNA d'Agilent) dans la liste Applications. Cliquez ensuite sur le bouton Properties....

  6. Cliquez sur l'onglet Security.

Autorisation d'accès

La procédure suivante permet de configurer le PNA pour accorder à des utilisateurs spécifiques l'accès DCOM à l'application PNA :

Dans la boîte de dialogue Agilent PNA Series Properties :

  1. Cliquez sur Use custom access permissions.

  2. Cliquez sur Edit&ldots; à côté de Use custom access permissions.

  3. Dans Registry Value Permissions, sélectionnez Everyone (Tous les utilisateurs).

  4. Cliquez sur Remove.

  5. Cliquez sur Add.

  6. Vous pouvez accorder l'accès à l'analyseur réseau à un ou plusieurs groupes ou à des utilisateurs spécifiques.

    1. Pour accorder l'accès à un groupe, sélectionnez ce dernier dans la liste.

    2. Pour accorder l'accès à des utilisateurs spécifiques, cliquez sur Show users ou sur Members puis sélectionnez leur nom dans la liste.

  7. Cliquez sur Add.

  8. Cliquez sur OK.

Autorisation de lancement

La procédure suivante permet de configurer l'analyseur pour permettre aux utilisateurs sélectionnés de lancer (démarrer) l'application PNA. Cette procédure est identique à celle permettant d'accorder l'accès à l'analyseur.

Dans la boîte de dialogue Agilent PNA Series Properties :

  1. Cliquez sur Use custom launch permissions.

  2. Cliquez sur Edit&ldots; à côté de Use custom launch permissions.

  3. Dans Registry Value Permissions, sélectionnez Everyone (Tous les utilisateurs).

  4. Cliquez sur Remove.

  5. Cliquez sur Add.

  6. Vous pouvez accorder l'autorisation de lancement à un ou plusieurs de ces groupes ou à des utilisateurs spécifiques.

    1. Pour accorder l'autorisation de lancement à un groupe, sélectionnez ce dernier dans la liste.

    2. Pour accorder l'autorisation de lancement à des utilisateurs spécifiques, cliquez sur Show users ou sur Members puis sélectionnez leur nom dans la liste.

  7. Cliquez sur Add.

  8. Cliquez sur OK.

Dans la boîte de dialogue Agilent PNA Series Properties :

  1. Cliquez sur l'onglet Identity.

  2. Cliquez sur The interactive user. Cette fonction prend en charge les événements dans PNA COM.

Enregistrement de la bibliothèque de types d'analyseur sur le PC

La bibliothèque de types contient le modèle de l'objet analyseur. Sur votre PC, il existe un fichier Registre qui localise les modèles. Vous devez donc enregistrer la bibliothèque de types d'analyseur sur votre PC. Elle sera utilisée pour développer le code et exécuter le programme. Il est recommandé d'enregistrer la bibliothèque de types au moment de la conception, AVANT l'exécution de votre programme COM.

Avant d'exécuter cette procédure, effectuez les deux opérations suivantes :

  1. Connectez votre PC et l'analyseur au réseau local (LAN).

  2. Vous pouvez soit connecter un lecteur à l'analyseur soit copier les fichiers de la bibliothèque de types sur une disquette ou sur un autre support. Pour connecter un lecteur, consultez la rubrique Connexion des lecteurs

Remarque : pour enregistrer la bibliothèque de types sur votre PC, vous devez ouvrir une session sur votre ordinateur en tant qu'administrateur.

Cette procédure suppose qu'un lecteur est connecté de votre PC vers l'analyseur. Cette procédure effectue les opérations suivantes :

  • Enregistrement de l'application Analyseur réseau sur le PC.

  • Copie et enregistrement du fichier 835xps.DLL sur le PC.

  • Copie et enregistrement de la bibliothèque de types (835x.tlb) sur le PC.

  1. Sur votre ordinateur, recherchez le lecteur C: de l'analyseur au moyen de l'Explorateur de Windows. Il ne sera pas désigné par la lettre "C:" sur votre PC mais par la lettre que vous lui avez assignée lors du mappage de lecteur.

  2. Recherchez le répertoire Program Files \ Agilent \ Network Analyzer \ Automation.

  3. Double-cliquez sur Automation.vbs.

Remarque :si la boîte de dialogue "Ouvert par" s'affiche, cela signifie que l'hôte d'écriture de scripts de Windows n'est pas installé sur votre PC. Il est disponible gratuitement sur le site Web de Microsoft dont l'adresse est : http://www.microsoft.com/msdownload/vbscript/scripting.asp

  4. Le programme de script Visual Basic vous demande de fournir le nom de votre analyseur (sur l'analyseur, vous pouvez obtenir ce nom dans Panneau de configuration\Système\Identification réseau\Nom complet de l'ordinateur : ). Tapez le nom de l'analyseur.

  5. Après l'exécution du script, cliquez sur OK. La bibliothèque de types d'analyseur devrait être enregistrée sur votre PC.

Remarque : il se peut que votre environnement de programmation vous demande de définir une référence à la bibliothèque de types sur votre PC.

Après son installation sur l'instrument, l'application et tous les objets qu'elle prend en charge sont enregistrés sur cette machine. L'instrument est désormais prêt à se comporter en tant que serveur à distance.

Toutefois, si l'analyseur ne fonctionne pas correctement, essayez de réenregistrer manuellement l'application et les bibliothèques associées sur l'analyseur en procédant comme suit :

Remarque : l'ordre de la procédure suivante doit être respectée.

A partir de votre PC avec un lecteur connecté vers l'analyseur réseau PNA :

Recherchez le fichier 835x.exe dans C:\Program Files\Agilent\NetworkAnalyzer.

  1. Sélectionnez 835x.exe puis cliquez dessus avec le bouton droit de la souris.

  2. Sélectionnez Register COM Server (Enregistrer Serveur COM) pour enregistrer l'application.

  3. Sélectionnez 835xps.DLL puis cliquez dessus avec le bouton droit de la souris.

  4. Sélectionnez Register COM Server.

A la fin de cette procédure, lancez la "procédure d'accès" (exécutez dcomcnfg).


COM Data Types

The Analyzer uses several data types to communicate with the host computer. Before using a variable, it is best to declare the variable as the type of data it will store. It saves memory and is usually faster to access. The following are the most common data types:

Long Integer

Single Precision (Real)

Double Precision (Real)

Boolean

String

Object

Enumeration

Variant

Long (long integer) variables are stored as signed 32-bit (4-byte) numbers ranging in value from -2,147,483,648 to 2,147,483,647.

Double (double-precision floating-point) variables are stored as IEEE 64-bit (8-byte) floating-point numbers ranging in value from -1.79769313486232E308 to -4.94065645841247E-324 for negative values and from 4.94065645841247E-324 to 1.79769313486232E308 for positive values.

Single (single-precision floating-point) variables are stored as IEEE 32-bit (4-byte) floating-point numbers, ranging in value from -3.402823E38 to -1.401298E-45 for negative values and from 1.401298E-45 to 3.402823E38 for positive values.

Boolean variables are stored as 16-bit (2-byte) numbers, but they can only be True or False. Use the keywords True and False to assign one of the two states to Boolean variables.

When other numeric types are converted to Boolean values, 0 becomes False and all other values become True. When Boolean values are converted to other data types, False becomes 0 and True becomes -1.

String variables hold character information. A String variable can contain approximately 65,535 bytes (64K), is either fixed-length or variable-length, and contains one character per byte. Fixed-length strings are declared to be a specific length. Variable-length strings can be any length up to 64K, less a small amount of storage overhead.

Object variables are stored as 32-bit (4-byte) addresses that refer to objects within the analyzer or within some other application. A variable declared as Object is one that can subsequently be assigned (using the Set statement) to refer to any actual analyzer object.

Enumerations (Enum) are a set of named constant values. They allow the programmer to refer to a constant value by name instead of by number. For example:

Enum DaysOfWeek
Sunday = 0
Monday = 1
Tuesday = 2
Wednesday = 3
Thursday = 4
Friday = 5
Saturday = 6
End Enum

Given this set of enumerations, the programmer can then pass a constant value as follows:
SetTheDay(Monday)
rather than
SetTheDay(1)
where the reader of the code has no idea what the value 1 refers to.

However, the analyzer RETURNS a long integer, not the text.
Day = DaysofWeek(today) 'Day = 1

Variant - If you don't supply a data type, the variable is given the Variant data type. The Variant data type is like a chameleon — it can represent many different data types in different situations.

The analyzer provides and receives Variant data in several instances because there a programming languages that cannot send or receive "typed" data. Variant data transfers at a slower rate than "typed" data.


Working with the Analyzer's Events

Working with Events

What are Events?

Using the Analyzer's Events

Event ID's

Filtering Events

List of Events

Out of Range Errors

Troubleshooting Problems with Events

What are Events?

Windows applications work from user-initiated events such as mouse moves and mouse clicks. A mouse-click produces an event that the programmer can either ignore or "handle" by providing an appropriate subroutine like this:

Sub DoThis_onClick
Perform something
End Sub

If this subroutine were in your program and the mouse-click event occurs on your PC, it would generate a "Callback" to the client and interupt whatever it was doing and handle the event.

A more practical example of an event in the analyzer is Limit test. If limit test is on and the measurement fails, the analyzer produces a '"Limit-failed" event. If the measurement passed, the analyzer produces a "Limit-succeeded" event.

The Analyzer has a very sophisticated Event structure. Your program CAN be notified when one or more events occur. However, it may not be necessary.

For example, the analyzer has an event that will notify your program when a sweep is complete. A simpler alternative is to use a synchronous command which waits for the sweep to complete.

sync = True
app.ManualTrigger sync
chan.StartFrequency = 4.5E6

This would NOT work if you want the controller to do other things while waiting, like setup a power meter or sort some data. In this case you would like a "callback" from the analyzer to let your program know that the sweep has completed.

Another reason to use events is when you want to be notified of several conditions when they occur, such as errors or source unlock conditions. It would not be practical to routinely poll these conditions while executing your program.

Using Events

If you decide to use the COM events to get a callback, your program must do two things:

1. Subscribe to events:

All events in the analyzer are a child of the Application object through the INetworkAnalyzerEvents Interface. You must tell the Application object that you are interested in receiving event callbacks. This process is called subscription.

In Visual Basic, this is done by including "WithEvents" in the declaration statement. The declaration below dimensions an Application object (myPNA) and subscribes to the events produced by the Application.

Dim WithEvents myPNA as AgilentPNA835x.Application

In C++, this is a bit more involved. You must queryInterface for the IconnectionPointContainer interface, locate the InetworkAnalyzerEvents interface via a call to FindConnectionPoint and call Advise().

2. Implement the Event Handler

When an event occurs, the Application object will "callback" to the client through the InetworkAnalyzerEvents interface.

In VB, click on the object window (upper left pane). Find the Application object and click it. The event interfaces will appear in the upper right pane. As you click on them, VB supplies the first line of code. You fill in the rest of the handler routine to service the event. The following is an example of a event handler subroutine.

Note: In C++, you must type the callback.

Private Sub OnChannelEvent( eventID as Variant, channelNumber as Variant)
Select Case (eventID)
Case naEventID_CHANNEL_TRIGGER_COMPLETE:
GetData( channelNumber )
Case naEventID_CHANNEL_TRIGGER_ABORTED:
MsgBox( "Hey don't touch the front panel!")
End Select
End Sub

When the trigger is complete, the application object "fires" the event by making a callback to the event handler Sub OnChannelEvent().

Event IDs

3 | 3 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Sev |  | C | R | Facility |  |  |  |  |  |  |  |  |  |  | Code
Sev | Severity Code
C | Customer code flag (not used)
R | Reserved bit (not used)
Facility | Category code
Code | Event ID

Filtering Events

There are over 140 different events that you subscribe to when you "Dim WithEvents..." (or the equivalent in your programming language). Monitoring all of these conditions slows the speed of the analyzer significantly. The following methods allow you to filter the events so that you only monitor specific conditions.

  • AllowEventMessage - monitor a specific event

  • AllowAllEvents - monitor ALL events

  • DisallowAllEvents - monitor NO events

  • AllowEventCategory - monitor specific event categories (discussed later)

  • AllowEventSeverity - monitor events having one or more of the following severity levels associated with them.
Code | Severity Enumeration
00 | naEventSeveritySUCCESS - the operation completed successfully
01 | naEventSeverityINFORMATIONAL - events that occur without impact on the measurement integrity
10 | naEventSeverityWARNING - events that occur with potential impact on measurement integrity
11 | naEventSeverityERROR - events that occur with serious impact on measurement integrity

List of Events

The following is a list of categories and the general types of events they include. Click the link view the event details.

Category Enumeration | Callback
naEventCategory_PARSER | OnSCPIEvent
naEventCategory_MEASURE | OnMeasurementEvent
naEventCategory_CHANNEL | OnChannelEvent
naEventCategory_HW | OnHardwareEvent
naEventCategory_CAL | OnCalEvent
naEventCategory_USER | OnUserEvent
naEventCategory_DISPLAY | OnDisplayEvent
naEventCategory_GENERAL | OnSystemEvent

Note: Use the MessageText Method to get a text message describing the event.

Out of Range Errors

When you attempt to set a value on an active function that is beyond the range (min or max) of the allowable values, the analyzer limits that value to an appropriate value (min or max) and sets the function to the limited value. From the front panel controls this is visually evident by the limited value in the edit box or by the annotation on the display. An example would be attempting to set the start frequency below 300kHz. The edit control doesn't allow the number to fall below 300kHz.

When the automation user programs a setting (such as start frequency below the allowable limits) the same behavior takes place. The analyzer accepts the limited value. However, in order to learn what setting took place, you have to read the HRESULT.

All automation calls return HRESULTs. By default the HRESULT returned when an overlimit occurs is S_NA_LIMIT_OUTOFRANGE. This value is a success code, meaning that bit 31 in this 32 value is 0. Programmers should check the return code from all automation calls to determine success or failure.

Some C++ macros (like SUCCEEDED(hr) or FAILED(hr) ) only check bit 31. So if you are interested in trapping this outOfRange error you will have to check for S_NA_LIMIT_OUTOFRANGE explicity.

Alternatively, you can configure the analyzer to report outOfRange conditions with an error code. Use the method: App.SetFailOnOverRange (true). With this method set TRUE, any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

This method is provided for the benefit of VB clients. VB users can't detect specific success codes because the VB runtime strips off the HRESULT and only raises a run time error if bit 31 is set, indicating a fail code.

Troubleshooting Problems with Callbacks

When you do callbacks, the client PC becomes the server and the analyzer (server) becomes the client. Callbacks can only take place when both server and client are in the same workgroup or in the same domain. See Configure for COM.


C++ and the COM Interface

Programming The PNA with C++

The programming information contained in this Help system is aimed at the Visual Basic programmer. VB does a lot of work for the programmer when it comes to managing and accessing components. Using a lower level language like C++ requires a more thorough understanding of the underlying tenets of COM. It is not the intent of this section to teach COM programming. The following is intended to acquaint you with some of the basic concepts you need to know in order to program against COM.

Initializing COM

Importing the Type Library

Creating the Application Object

Errors

Events

Additional Reading

Example

Note: The information in this section assumes development on a Windows OS using Microsoft tools.

Initializing COM

The first thing you must do before performing any COM transactions is to initialize the COM library. You can do this in a number of ways. The most basic of these is a call to CoInitialize( ) or CoIntializeEx( ). Alternatively you can use the MFC (Microsoft Foundation Classes) AfxOleInit( ).

Conversely, before your program exits you must uninitialize COM. You can accomplish this with CoUninitialize( ) or the MFC routine AfxOleTerm( ).

Importing the Type Library

To make a component available to the client, the server exports what is called the type library. For the PNA, this file is 835x.tlb. It is located on the PNA's hard drive at C:\Program Files\ Agilent\ Network Analyzer\ Automation. See Configure for COM-DCOM Programming.

The type library can be read and deciphered using another COM interface called ITypeLib. VB uses this interface to present, for example, its object browser. Visual C++ can also read type libraries. This is done by importing the type library into your project with a compiler directive:

#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb", named_guids

When you compile your program with this statement in it, the compiler creates two other files: 835x.tlh and 835x.tli. The first is a header file that contains the type definitions for the PNA's COM interfaces and their methods. The second file contains inline functions that wrap the PNA's interface methods. The wrappers are beneficial in that they contain error reporting for each of the method calls.

The .tlh file defines a smart pointer which you can use to access the PNA's objects. The smart pointer definition looks like this:

_com_smartptr_typedef(Iapplication, _uuidof(Iapplication))

A smart pointer is a term used for a C++ object that encapsulates a pointer used to refer to a COM object. All COM objects derive from the interface IUnknown. This interface has three methods: QueryInterface( ), AddRef( ), and Release( ). The function of the AddRef and Release methods is to maintain a reference count on the object and thus control the object's lifetime. Anytime you copy or create a reference to a COM object, you are responsible for incrementing its reference count. And likewise, when you are finished using that reference, it is your responsibility to Release it. Smart pointers do this work for you, as shown in the example program. In addition, smart pointers will also perform the QueryInterface call when required. QueryInterface is a method that requests a specific interface from an object. In the example program we gain access to the IArrayTransfer interface of the Measurement object. In the ReadMethod routine, we see this:

PTransferData = pMeas;

The assignment operator is overloaded for the smart pointer and in reality, this simple statement does this:

HRESULT hr = pMeas->QueryInterface( IID_IArrayTransfer,(void**)&pTransferData);

Using the existing interface pointer (pMeas) to the object, this call asks the object if it supports the IArrayTransfer interface, and if so to return a pointer to it in pTransferData. Smart pointer makes life easier for the C++ programmer. Read more about smart pointers in Microsoft Developer's Network Library (MSDN).

Creating the Application Object

The only createable object exported by the PNA is the Application object. Typically this would be done with a call to CoCreateInstance:

STDAPI CoCreateInstance(
CLSID__IApplication, //Class identifier (CLSID) of the object
NULL, //Pointer to controlling IUnknown
CLS_CTX_SERVER, //Context for running executable code
IID_IApplication, //Reference to the IID of the interface
(void**)&pNA //Address of output variable that receives
// the interface pointer requested in riid
);

With the smart pointer, this is taken care of with the following call:

IApplicationPtr pNA; // declare the smart pointer
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

Errors

All COM method calls are required to return an HRESULT. This is 32 bit long with a specific format.

  • The most significant bit indicates success(0) or failure(1).

  • The lower 16 bits indicate the specific failure.

Visual Basic strips off the returned HRESULT and raises an error object for non-successful returns. The C++ programmer must himself be diligent about handling errors. You must check the return value of each COM call to ensure its success.

Events

The Application object sources the INetworkAnalyzerEvents interface. This object is the source for all events. To use events in C++, you must do two things:

  1. Implement the INetworkAnalyzerEvents interface - derive an object from INetworkAnalyzerEvents and implement the methods described there.

  2. Subscribe to the IconnectionPoint interface of the Application object. - obtain a pointer to the IConnectionPointContainer interface of the Application object and making the following request:

FindConnectionPoint( IID_InetworkAnalyzerEvents, &pConnection );

A successful call to this interface will return a valid pointer in pConnection. Use this pointer to subscribe to the Application object:

pConnect->Advise( IUnknown* punk, DWORD dwCookie);

This call provides the server object with a callback address. The Iunkown pointer in this call is the IUnkown pointer of the object that implements the INetworkAnalyzerEvents interface. This is the event sink. The application object needs a pointer to this object in order to call your interface when an event occurs. The dwCookie is your subscription key. Use it to unsubscribe (see Unadvise( ) ).

Additional Reading

"MSDN" - Microsoft Developer's Network Library

"Learning DCOM", by Thuan L. Thai, published by O'Reilly(1999)

"Inside COM", by Dale Rogerson, published by Microsoft Press (1997),

"Understanding ActiveX and OLE", by David Chappell, also published by Microsoft Press (1996), and

"Beginning ATL COM Programming", published by Wrox Press (1998).

Example

The example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries. In the example, notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

See the example program.


SCPI Command Tree

:CORRection

Sets Electrical Delay and Phase Offset

:DATA?

Queries measurement data.

:FILTer

Sets time domain gating

:FORMat

Sets the display format

:FUNCtion

Controls Trace Statistics

:LIMit

Controls limit lines for pass / fail testing

:MARKer

Controls the marker settings

:MATH

Performs math on the memory trace

:PARameter

Creates and deletes measurements

:RDATa?

Queries receiver data

:SMOothing

Controls point-to-point smoothing

:TRANsform

Controls time domain transform settings

:AVErage

Sets sweep averaging parameters

:BANDwidth

Specifies the IF filter bandwidth

:CORRection

Provides calibration capability.

:CORR:COLL:CKIT

Defines calibration standards

:COUPle

Sets sweep as Chopped or Alternate

:FREQuency

Controls frequency sweep functions

:POWer

Sets receiver attenuation and overpower protection

:ROSCillator

Returns the source of the reference oscillator.

:SEGMent

Defines the segment sweep settings.

:SWEep

Specifies the sweep modes of the analyzer.

See Also...

SCPI Command Tree

IEEE- 488.2 Common Commands

SCPI Commands

ABORt

Stops all sweeps

CALCulate __Click to show CALC commands

DISPlay

Controls the display settings

FORMat

Sets the format for data transfer

HCOPy

Controls hardcopy printing

INITiate

Sets continuous or manual triggering

MMEMory

Saves and recalls instrument states

OUTPut

Turns RF power ON and OFF

SENSe __Click to show SENSe commands

SOURce

Controls the power to the DUT

STATus

Reads the analyzer status registers

SYSTem

Controls the analyzer defaults

TRIGger

Starts or ends a measurement


About Triggering

Abort Command

ABORt

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep.
Examples | ABOR abort
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:ABORt


Common Commands

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Agilent Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TRG - Trigger

Triggers a sweep on the active measurement channel when in trigger hold mode (ignored if the analyzer is in continuous sweep mode).

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status. An 0 indicates no failures found. Any other value indicates one or more of the following conditions exist. The value returned is the Weight (or sum of the Weights) of the existing conditions. For example:

  • If 4 is returned from *TST?, an Overpower condition exists.

  • If 6 is returned, both Unleveled and Overpower conditions exists.
Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Phase Unlock | the source has lost phaselock. This could be caused by a reference channel open or a hardware failure.
1 | 2 | Unleveled | the source power is unleveled. This could be a source is set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
2 | 4 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
3 | 8 | EE Write Failed | an attempted write to the EEPROM has failed. This is possibly caused by a hardware failure.
4 | 16 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
5 | 32 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
6 | 64 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization


Correction

About Phase Accuracy

Calc:Correction Commands

Controls Electrical Delay and Phase Offset

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. To select the measurement use CALC<ChanNum>:PAR:SEL <MeasName>.

CALCulate<cnum>:CORRection:EDELay:TIME <num>

(Read-Write) Sets the electrical delay for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor.
Examples | CALC1:CORR:EDEL:TIME 1NS calculate2:correction:time 0.5e-12
Query Syntax | CALCulate:CORRection:EDELay:TIME?
Return Type | Character
Overlapped? | No
Default | 0 seconds

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>]

(Read-Write) Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:CORR:OFFS:PHAS 10 calculate:correction:offset:phase 20rad
Query Syntax | CALCulate:CORRection:OFFSet:PHASe?
Return Type | Character, returned value always in degrees
Overlapped? | No
Default | 0 degrees

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:CORRection:EDELay:TIME 10e-12
:CALCulate1:CORRection:EDELay:TIME?
:CALCulate 1:CORRection:OFFSet:PHASe 90deg
:CALCulate 1:CORRection:OFFSet:PHASe?


Data

FDATA - one number per trace point
SDATA - two numbers per trace point
FMEM - one number per trace point
SMEM - two numbers per trace point
All Error Terms - two numbers per trace point

Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflect.Tracking | 1
SCORR4 | Isolation | 1
SCORR5 | Load Match | 1
SCORR6 | Trans.Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflect.Tracking | 2
SCORR10 | Isolation | 2
SCORR11 | Load Match | 2
SCORR12 | Trans.Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflection Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflection Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Reflect.Tracking | 1
SCORR7 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR2 | Reflect.Tracking | 1
SCORR8 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR12 | Transmission Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR4 | Isolation | 1
SCORR12 | Transmission Tracking | 2
SCORR10 | Isolation | 2

See Also...

About Accessing Data

Calc:Data Command

CALCulate<cnum>:DATA <char>

Write Measurement data, Memory data, or Error terms.

CALCulate<cnum>:DATA? <char>
Read Measurement data, Memory data, or Error terms.
Return Data Format:

Parameters

<cnum> - Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char> - To write or read Measurement and Memory Data, choose from:

FDATA - formatted trace data from measResult location
SDATA - corrected complex trace data from rawMeas location
FMEM - formatted memory data from memResult location
SMEM - corrected complex data from rawMemory location

<char> - To write or read Error Terms...

For 2-Port SOLT and TRL calibrations,

For 1-Port calibrations:

For Response Open calibrations:

For Response Short calibrations:

For Response Thru calibrations:

For Response Thru and Isolation calibrations:

EXAMPLE - See an example using this command.

Overlapped? - No

Default - Not Applicable

Notes:

  • When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • When querying error terms, there must be error terms in the analyzer.

  • If interpolation is ON and the number of points changes after the initial calibration, the error terms will then be the interpolated results.

  • To get and put receiver data, see CALC:RDATA?

  • To get uncorrected ratioed data, turn correction OFF and use Calc:Data SDATA.

  • CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Learn more about Error Terms


Filter

About Gating

Calc:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start / stop) or (center / span) commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

(R ead-Write) Sets the gate filter center time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:CENT -5 ns calculate2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

(R ead-Write) Sets the gating filter shape when in time domain. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE - NORMal - MINimum - the narrowest gate filter available
Examples | CALC:FILT:GATE:TIME:SHAP MAX calculate2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

(R ead-Write) Sets the gate filter span time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Time span in seconds; Choose any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:SPAN 5 ns calculate2:filter:time:span maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

(R ead-Write) Turns gating state ON or OFF. Critical Note: Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<boolean> | ON (or 1) - turns gating ON. OFF (or 0) - turns gating OFF.
Examples | CALC:FILT:TIME:STAT ON calculate2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

(R ead-Write) Sets the gate filter start time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STAR 1e-8 calculate2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

(R ead-Write) Sets the gate filter stop time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STOP -1 ns calculate2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

(R ead-Write) Sets the type of gate filter used. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:FILT:TIME BPAS calculate2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Overlapped? | No
Default | BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:FILTer:GATE:TIME:CENTer 10ms
:CALCulate1:FILTer:GATE:TIME:CENTer?
:CALCulate1:FILTer:GATE:TIME:SHAPe MAX
:CALCulate1:FILTer:GATE:TIME:SHAPe?
:CALCulate1:FILTer:GATE:TIME:SPAN 10ms
:CALCulate1:FILTer:GATE:TIME:SPAN?
:CALCulate1:FILTer:GATE:TIME:STARt 10ms
:CALCulate1:FILTer:GATE:TIME:STARt?
:CALCulate1:FILTer:GATE:TIME:STATe ON
:CALCulate1:FILTer:GATE:TIME:STATe?
:CALCulate1:FILTer:GATE:TIME:STOP 10ms
:CALCulate1:FILTer:GATE:TIME:STOP?
:CALCulate1:FILTer:GATE:TIME:TYPE NOTCh
:CALCulate1:FILTer:GATE:TIME:TYPE?


Format Calc

About Data Format

Calc:Format Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

  • See an example us ing this command.

CALCulate<cnum>:FORMat <char>

(Read-Write) Sets the display format for the measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

  • MLINear

  • MLOGarithmic

  • PHASe

  • IMAGinary

  • REAL

  • POLar

  • SMITh

  • SWR

  • GDELay

Examples

CALC:FORM MLIN
calculate2:format polar

Query Syntax

CALCulate<cnum>:FORMat?

Return Type

Character

Overlapped?

No

Default

MLINear

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FORMat MLIN
:CALCulate 1:FORMat?


Function

About Trace Statistics

Calc:Function Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FUNCtion:DATA?

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Return Type

Character

Example

CALCulate2:FUNCtion:DATA?

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

(Read-Write) Sets the range used to calculate trace statistics. Each channel shares 10 domain ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<range>

Range number. Choose from: 0 to 9

  • 0 is Full Span of the current x-axis range

  • 1 to 9 are user-specified ranges

Examples

CALC:FUNC:DOM:USER 4
calculate2:function:domain:user:range 0

Query Syntax

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe]?

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

(Read-Write) Sets the start of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:STOP. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 9
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STAR 1,1e9 calculate2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

(Read-Write) Sets the stop of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:START. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 9
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STOP 4,5e9 calculate2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:FUNCtion:TYPE <char>

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace
Examples | CALC:FUNC:TYPE PTP calculate2:function:type stdev
Query Syntax | CALCulate<cnum>:FUNCtion:TYPE?
Return Type | Character
Overlapped? | No
Default | PTPeak

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FUNCtion:DATA?
:CALCulate 1:FUNCtion:DOMain:USER:RANGe 0
:CALCulate 1:FUNCtion:DOMain:USER:RANGe?
:CALCulate 1:FUNCtion:DOMain:USER:STARt 1, 1e9
:CALCulate 1:FUNCtion:DOMain:USER:STARt? 1
:CALCulate 1:FUNCtion:DOMain:USER:STOP 4, 5e9
:CALCulate 1:FUNCtion:DOMain:USER:STOP? 4
:CALCulate 1:FUNCtion:TYPE PTP
:CALCulate 1:FUNCtion:TYPE?


Limit

About Limit Lines

Calc:Limit Commands

Controls the limit segments used for pass / fail testing.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:LIMit:DATA <block>

(Read-Write) Sets data for limit segments. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

"CALC:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30"

Query Syntax

CALCulate<cnum>:LIMit:DATA?

Return Type

Definite length block - All 100 predefined limit segments are returned.

Overlapped?

No

Default

100 limit segments - all values set to 0

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

(Read-Write) Turns the display of limit segments ON or OFF (if the data trace is turned ON). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns the display of limit segments ON. OFF (or 0) - turns the display of limit segments OFF.
Examples | CALC:LIM:DISP:STAT ON calculate2:limit:display:state off
Query Syntax | CALCulate<cnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STAR 10 calculate2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

(Read-Write) Sets the start (beginning) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:STIM:STAR 10 calculate2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

(Read-Write) Sets the stop (end) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

(Read-Write) Sets the type of limit segment. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:LIM:SEGM:TYPE LMIN calculate2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE?
Return Type | Character
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

(Read-Write) Turns limit testing fail sound ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns sound ON. OFF (or 0) - turns sound OFF.
Examples | CALC:LIM:SOUN ON calculate2:limit:sound:state off
Query Syntax | CALCulate<cnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:STATe <ON | OFF>

(Read-Write) Turns limit segment testing ON or OFF. Use CALC:LIM:DISP to turn ON and OFF the display of limit segments. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns limit testing ON. OFF (or 0) - turns limit testing OFF.
Examples | CALC:LIM:STAT ON calculate2:limit:state off
Query Syntax | CALCulate<cnum>:LIMit:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:LIMit:DATA <block>
:CALCulate1:LIMit:DATA?
:CALCulate 1:LIMit:DISPlay:STATe ON
:CALCulate 1:LIMit:DISPlay:STATe?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt 1e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP 3e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP?
:CALCulate 1:LIMit:SEGMent 1:TYPE LMAX
:CALCulate 1:LIMit:SEGMent 1:TYPE?
:CALCulate 1:LIMit:SOUNd:STATe OFF
:CALCulate 1:LIMit:SOUNd:STATe?
:CALCulate 1:LIMit:STATe ON
:CALCulate 1:LIMit:STATe?


Marker

About Markers

Calc:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Note: The Reference Marker is Marker Number 10

CALCulate<cnum>:MARKer:AOFF

(Write-only) Turns all markers off for selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MARK:AOFF calculate2:marker:aoff
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:MARKer:BWIDth <num>

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

This feature activates markers 1 through 4. To turn off these markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.
Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between:
-500 and 500

Examples

CALC:MARK:BWID -3
calculate2:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Overlapped?

No

Default

-3

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MARK:REF:STATE. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker is a Delta marker OFF (or 0) - Specified marker is an ABSOLUTE marker
Examples | CALC:MARK:DELT ON calculate2:marker8:delta off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DELTa?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker displays the actual data points OFF (or 0) - Specified marker displays calculated data between the actual data points.
Examples | CALC:MARK:DISC ON calculate2:marker8:discrete off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<char> | Choose from: DEFault - The format of the selected measurement MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude IMPedance - (R+jX) ADMittance - (G+jB) PHASe - Phase IMAGinary - Imaginary part (Im) REAL - Real part (Re)l POLar - (Re, Im) GDELay - Group Delay
Examples | CALC:MARK:FORMat MLIN calculate2:marker8:format Character
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FORMat?
Return Type | Character
Overlapped? | No
Default | DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Character
Overlapped? | No
Default | -100

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel shares 10 domain ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<span>

User span. Choose any Integer from 0 to 9.

0 is Full Span of the analyzer
1 to 9 are available for user-defined x-axis span

Examples

CALC:MARK:FUNC:DOM:USER 1
calculate2:marker8:function:domain:user 1

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER?
Returns the user span number that the specified marker is assigned to.

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.
Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MARK:FUNC:DOM:USER:START 500E6
calculate2:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Character

Overlapped?

No

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STARt to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STOP

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<stop>

Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.

Examples

CALC:MARK:FUNC:DOM:USER:STOP 500e6
calculate2:marker8:function:domain1:user:stop 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?

Return Type

Character

Overlapped?

No

Default

The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

(Write-only) Immediately executes (performs) the specified search function. If no function is specified, executes the selected function. Select the function with CALC:MARK:FUNCtion:SEL. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<func>

Optional argument. The function that is to be performed. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right, wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC:EXEC
calculate2:marker2:function:execute maximum

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

(Read-Write) Sets the search function that the specified marker will perform when executed. To execute (or perform) the function, use:
CALC:MARK:FUNC:EXEC or
CALC:MARK:FUNC:TRAC ON to automatically execute the search every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right; wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC MAX
calculate2:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect]?

Overlapped?

No

Default

MAX

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

(Read-Write) Sets the target value for the specified marker when doing Target Searches (CALC:MARK:FUNC:SEL <TARGet | RTARget | LTARget> Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Target value to search for; Units are NOT allowed.
Examples | CALC:MARK:TARG 2.5 calculate2:marker8:target -10.3
Query Syntax | CALCulate<cnum>:MARKer<mkr>:TARGet?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

(Read-Write) Sets the tracking capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MARK:FUNC:EXECute command every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - The specified marker will "Track" (find) the selected function every sweep.

OFF (or 0) - The specified marker will find the selected function only when the CALC:MARK:FUNC:EXECute command is sent.

Examples

CALC:MARK:FUNC:TRAC ON
calculate2:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

(Read-Write) Turns the reference marker (marker 10) ON or OFF. When turned OFF, existing Delta markers revert to absolute markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns reference marker ON OFF (or 0) - turns reference marker ON
Examples | CALC:MARK:REF ON calculate2:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MARKer:REFerence[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer:REFerence:X <num>

(Read-Write) Sets and returns the absolute x-axis value of the reference marker (marker 10). Critical Note:

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

X-axis value. Choose any number within the operating domain of the reference marker.

Examples

CALC:MARK:REF:X 1e9

calculate2:marker:reference:x 1e6

Query Syntax

CALCulate<cnum>:MARKer:REFerence:X?

Return Type

Character

Overlapped?

No

Default

If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MARKer:REFerence:Y?

(Read-only) Returns the absolute Y-axis value of the reference marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:MARK:REF:Y?

calculate2:marker:reference:y?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

(Read-Write) Sets the type of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
NORMal - a marker that stays on the assigned X-axis position unless moved or searching.
FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MARK:TYPE NORM
calculate2:marker2:type fixed

Query Syntax

CALCulate<cnum>:MARKer<mkr>:TYPE?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MARKer<mkr>:SET <char>

(Read-Write) Sets the selected instrument setting to assume the value of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
CENTer - changes center frequency to the value of the marker
SPAN - changes the frequency span to the value of the marker's domain
STARt - changes the start frequency to the value of the marker
STOP - changes the stop frequency to the value of the marker
RLEVel - changes the reference level to the value of the marker
DELay - changes the xxx delay to the value of the marker

Examples

CALC:MARK:SET CENT
calculate2:marker8:set span

Query Syntax

CALCulate<cnum>:MARKer<mkr>:SET?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

(Read-Write) Turns the specified marker ON or OFF. Marker 10 is the Reference Marker. To turn all markers off, use CALC:MARK:AOFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - turns marker ON. OFF (or 0) - turns marker OFF.
Examples | CALC:MARK ON calculate2:marker8 on
Query Syntax | CALCulate<cnum>:MARKer<mkr>:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

CALCulate<cnum>:MARKer<mkr>:X <num>

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Any X-axis position within the measurement span of the marker. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:X 100Mhz calculate2:marker8:x maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:X?
Return Type | Character
Overlapped? | No
Default | First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

CALCulate<cnum>:MARKer<mkr>:Y?

(Read-only) Sets the marker's Y-axis value. The format of the value depends on the current CALC:MARKER:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • All other formats - (Value,0)

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

Examples

CALC:MARK:Y?
calculate2:marker3:y?

Query Syntax | CALCulate<cnum>:MARKer<mkr>:Y?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MARKer:AOFF
:CALCulate 1:MARKer:BWIDth -2.513
:CALCulate 1:MARKer:BWIDth?
:CALCulate 1:MARKer 1:DELTa ON
:CALCulate 1:MARKer 1:DELTa?
:CALCulate 1:MARKer 1:DISCrete ON
:CALCulate 1:MARKer 1:DISCrete?
:CALCulate 1:MARKer 1:FORMat DEF
:CALCulate 1:MARKer 1:FORMat?
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion?
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER 1
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP?
:CALCulate 1:MARKer 1:FUNCtion:EXECute MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect?
:CALCulate 1:MARKer 1:TARGet -10.3
:CALCulate 1:MARKer 1:TARGet?
:CALCulate 1:MARKer 1:FUNCtion:TRACking ON
:CALCulate 1:MARKer 1:FUNCtion:TRACking?
:CALCulate 1:MARKer:REFerence:STATe ON
:CALCulate 1:MARKer:REFerence:STATe?
:CALCulate 1:MARKer:REFerence:X 10
:CALCulate 1:MARKer:REFerence:X?
:CALCulate 1:MARKer:REFerence:Y?
:CALCulate 1:MARKer 1:TYPE NORM
:CALCulate 1:MARKer 1:TYPE?
:CALCulate 1:MARKer 1:SET CENT
:CALCulate 1:MARKer 1:SET?
:CALCulate 1:MARKer 1:STATe ON
:CALCulate 1:MARKer 1:STATe?
:CALCulate 1:MARKer 1:X 1Ghz
:CALCulate 1:MARKer 1:X?
:CALCulate1:MARKer1:Y?


Math Calc

About Math Operations

Calc:Math Commands

Controls math operations on the currently selected measurement and memory.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:MATH:FUNCtion <char>

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

The math operation to be applied. Choose from the following:

NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory

Examples

CALC:MATH:FUNC NORM
calculate2:math:function subtract

Query Syntax

CALCulate<cnum>:MATH:FUNCtion?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MATH:MEMorize

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MATH MEM calculate2:math:memorize
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MATH:FUNCtion NORM
:CALCulate 1:MATH:FUNCtion?
:CALCulate 1:MATH:MEMorize


Parameter

About Measurement Parameters

Calc:Parameter Commands

Lists, creates, selects and deletes measurements

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:PARameter:CATalog?

(Read-only) Returns the names and parameters of existing measurements for the specified channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurements to be listed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:CAT? calculate2:parameter:catalog?
Query Syntax | CALCulate<cnum>:PARameter:CATalog?
Return Type | String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"
Overlapped? | No
Default | "CH1_S11_1,S11"

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>

(Write-only) Creates a measurement but NOT display it.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND<wnum>:TRAC<tnum>:FEED <Mname> to display the measurement.

You must select the measurement (CALC<cnum>:PAR:SEL <mname>) before making additional settings. Critical Note:

Parameters

<cnum>

Channel number of the new measurment. Choose any number between:
1 and 4
If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes

<param>

Parameter; Choose from the following for S-Parameter measurements:
S11 | S12 | S21 | S22

Or choose from the following for non S-Parameter measurements. Specify the source port with SENSe:SWEep:SRCPort <1|2>

A | B | R1 | R2 | A/B | B/A

Examples

CALC:PAR:DEF "Test,S12
calculate2:parameter:define "test,s22

Query Syntax

Not Applicable; see Calc:Par:Cat?

Overlapped?

No

Default

Not Applicable

CALCulate<cnum>:PARameter:DELete <Mname>

(Write-only) Deletes the specified measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement
Examples | CALC:PAR:DEL TEST calculate2:parameter:delete "test"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:SELect <Mname>

(Read-Write) Sets the selected measurement. Most CALC: commands require that this command be sent before a setting change is made. One measurement on each channel can be selected at the same time. To obtain a list of currently named measurements, use CALC:PAR:CAT? Critical Note:
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement. (Do NOT include the parameter name.)
Examples | CALC:PAR:SEL TEST calculate2:parameter:select "test"
Query Syntax | CALCulate:PARameter:SELect?
Return Type | String
Overlapped? | No
Default | No Selection

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:PARameter:CATalog?
:CALCulate 1:PARameter:DEFine "CH1_S21,S21"
:CALCulate 1:PARameter:DELete "CH1_S21"
:CALCulate 1:PARameter:SELect "CH1_S11"
:CALCulate 1:PARameter:SELect?


RData

About Unratioed Measurements

Calc:RData Command

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:RDATA? <char>

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA? Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from receivers: A B R1 R2 REF - returns either R1 or R2 data depending on the source port of the CALC-selected measurement.
Example | GPIB.Write "INITiate:CONTinuous OFF" GPIB.Write "INITiate:IMMediate;*wai" GPIB.Write "CALCulate:RDATA? A"
Return Type | Character - Two numbers per data point
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:RDATA? A


Smoothing Calc

About Smoothing

Calc:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:SMOothing:APERture <num>

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:SMO:APER 2 calculate2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Character
Overlapped? | No
Default | 1.5

CALCulate<cnum>:SMOothing:POINts <num>

(Read-Write) Sets the number of adjacent data points to average. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:SMO:POIN 50 calculate2:smoothing:points 21
Query Syntax | CALCulate<cnum>:SMOothing:POINts?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

(Read-Write) Turns data smoothing ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns smoothing ON. OFF (or 0) - turns smoothing OFF.
Examples | CALC:SMO ON calculate2:smoothing:state off
Query Syntax | CALCulate<cnum>:SMOothing[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:SMOothing:APERture 25
:CALCulate1:SMOothing:APERture?
:CALCulate1:SMOothing:POINts 10
:CALCulate1:SMOothing:POINts?
:CALCulate1:SMOothing:STATe ON
:CALCulate1:SMOothing:STATe?


Transform Calc

About Time Domain

Calc:Transform Commands

Specifies the settings for time domain transform.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

(Read-Write) Sets the center time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:CENT 1e-8 calculate2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDth <num>

(Read-Write) Sets the impulse width for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:TRAN:TIME:IMP:WIDTh 10 calculate2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Character
Overlapped? | No
Default | .98 / Default Span

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

(Read-Write) Sets the parametric window for the Kaiser Bessel window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:TRAN:TIME:KBES 10 calculate2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:KBESsel?
Return Type | Character
Overlapped? | No
Default | 6

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

(Write-only) Sets the start frequencies in LowPass Mode. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:TRAN:TIME:LPFR calculate2:transform:time:lpfrequency
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

(Read-Write) Sets the span time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:SPAN 1e-8 calculate2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:TRANsform:TIME:STARt <num>

(Read-Write) Sets the start time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STAR 1e-8 calculate2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | -10 ns

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

(Read-Write) Turns the time domain transform capability ON or OFF. Critical Note: Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON|OFF> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:TRAN:TIME:STAT ON calculate2:transform:time:state off
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:TRANsform:TIME:STOP <num>

(Read-Write) Sets the stop time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STOP 1e-8 calculate2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

(Read-Write) Sets the step rise time for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:TRAN:TIME:STEP:RTIM 1e-8 calculate2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Character
Overlapped? | No
Default | .99 / Default Span

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:
STEP - simulates a step DUT stimulus
IMPulse - simulates a pulse DUT stimulus

STEP can ONLY be used when CALC:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME:STIM STEP
calculate2:transform:time:stimulus impulse

Query Syntax

CALCulate<cnum>:TRANsform:TIME:STIMulus?

Return Type

Character

Overlapped?

No

Default

IMPulse

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

(Read-Write) Sets the type of time domain measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME LPAS
calculate2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Overlapped?

No

Default

BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:TRANsform:TIME:CENTer 10ms
:CALCulate 1:TRANsform:TIME:CENTer?
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth 110ps
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth?
:CALCulate 1:TRANsform:TIME:KBESsel 6
:CALCulate 1:TRANsform:TIME:KBESsel?
:CALCulate 1:TRANsform:TIME:LPFREQuency
:CALCulate 1:TRANsform:TIME:SPAN 20ms
:CALCulate 1:TRANsform:TIME:SPAN?
:CALCulate 1:TRANsform:TIME:STARt 10ms
:CALCulate 1:TRANsform:TIME:STARt?
:CALCulate 1:TRANsform:TIME:STATe ON
:CALCulate 1:TRANsform:TIME:STATe?
:CALCulate 1:TRANsform:TIME:STEP:RTIMe 110ps
:CALCulate 1:TRANsform:TIME:STEP:RTIMe?
:CALCulate 1:TRANsform:TIME:STIMulus STEP
:CALCulate 1:TRANsform:TIME:STIMulus?
:CALCulate 1:TRANsform:TIME:STOP 20ms
:CALCulate 1:TRANsform:TIME:STOP?
:CALCulate 1:TRANsform:TIME:TYPE LPASs
:CALCulate 1:TRANsform:TIME:TYPE?


Display

About Screen Setup

DISPlay Commands

Controls the settings of the front panel screen.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<ON | OFF> | ON (or 1) - turns frequency annotation ON. OFF (or 0) - turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

(Write-only) Enables and disables error pop-up messages on the display.
Parameters |
<ON | OFF> | ON (or 1) - enables error pop-up messages OFF (or 0) - disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:STATus <ON|OFF>

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<ON | OFF> | ON (or 1) - turns status bar ON. OFF (or 0) - turns status bar OFF.
Examples | DISP:ANN:STAT ON display:annotation:status off
Query Syntax | DISPlay:ANNotation:STATus?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:CATalog?

(Read-only) Returns the existing Window numbers.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Overlapped? | No
Default | Not applicable

DISPlay:ENABLE <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay[:TILE]

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the left of the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the buttons ON. OFF (or 0) - turns the buttons OFF.
Examples | DISP:WIND:ANN:TRAC:STAT ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation:TRACe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Marker data (when markers are ON) on the selected window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns marker data ON. OFF (or 0) - turns marker data OFF.
Examples | DISP:WIND:ANN:MARK:STAT ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:CATalog?

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
Return Type | String of Character values, separated by commas
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

Write to create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between: 1 and 4
<ON | OFF> | ON (or 1) - The window <wnum> is created. OFF (or 0) - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA "hello" display:window2:title:data "hello"
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be redisplayed when turned back ON.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the title string ON. OFF (or 0) - turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

(Write-only) Creates a new trace <tnum> and associates (feed) a measurement <name> to the specified window<wnum>. This command should be executed immediately after creating a new measurement with CALC:PAR:DEF<name>,<parameter>.

To feed the same measurement to multiple traces, create another measurement with the same <name>,<parameter> using the CALC:PAR:DEF command. The analyzer will collect the data only once.

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Trace number to be created. Choose any Integer between:
1 and 4

<name>

Name of the measurement that was defined with CALC:PAR:DEF<name>,<parameter>

Examples

DISP:WIND:TRAC:FEED "test"
display:window2:trace2:feed "test

Query Syntax

Not applicable

Overlapped?

No

Default

"CH1_S11"

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

(Read-Write) Turns the memory trace ON or OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the memory trace ON. OFF (or 0) - turns the memory trace OFF.
Examples | DISP:WIND:TRAC:MEM ON display:window2:trace2:memory:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>:MEMory[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

(Write-only) Activates the specified trace in the specified window for front panel use.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:SEL display:window2:trace2:select
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

(Read-Write) Turns the display of the specified trace in the specified window ON or OFF. When OFF, the measurement behind the trace is still active.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the trace ON. OFF (or 0) - turns the trace OFF.
Examples | DISP:WIND:TRAC ON display:window2:trace2:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

(Write-only) Performs an Autoscale on the specified trace in the specified window, providing the best fit display. Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:Y:AUTO display:window2:trace2:y:scale:auto
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

(Read-Write) Sets the Y axis Per Division value of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:PDIV 1 display:window2:trace2:y:scale:pdivision maximum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision?
Return Type | Character
Overlapped? | No
Default | 10

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

(Read-Write) Sets the Y axis Reference Level of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Reference level value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:RLEV 0 display:window2:trace2:y:scale:rlevel minimum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel?
Return Type | Character
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

(Read-Write) Sets the Reference Position of the specified trace in the specified window

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Any existing trace number; if unspecified, value is set to 1

<num>

Reference position on the screen measured in horizontal graticules from the bottom. The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:WIND:TRAC:Y:RPOS 0
display:window2:trace2:y:rposition maximum

Query Syntax

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition?

Return Type

Character

Overlapped?

No

Default

5

List of all commands in this block:
(Parameters in bold italics)

:DISPlay:ANNotation:FREQuency:STATE ON
:DISPlay:ANNotation:FREQuency:STATE?
:DISPlay:ANNotation:STATus ON
:DISPlay:ANNotation:STATus?
:DISPlay:CATalog?
:DISPlay:ENABLE ON
:DISPlay:ENABLE?
:DISPlay:TILE
:DISPlay:WINDow 1:ANNotation:TRACe:STATe ON
:DISPlay:WINDow 1:ANNotation:TRACe:STATe?
:DISPlay:WINDow 1:ANNotation:MARKer:STATe ON
:DISPlay:WINDow 1:ANNotation:MARKer:STATe?
:DISPlay:WINDow 1:CATalog?
:DISPlay:WINDow 1:ENABle ON
:DISPlay:WINDow 1:ENABle?
:DISPlay:WINDow 1:STATe ON
:DISPlay:WINDow 1:STATe?
:DISPlay:WINDow 1:TABLe OFF
:DISPlay:WINDow 1:TABLe?
:DISPlay:WINDow 1:TITLe:DATA "hello"
:DISPlay:WINDow 1:TITLe:DATA?
:DISPlay:WINDow 1:TITLe:STATe ON
:DISPlay:WINDow 1:TITLe:STATe?
:DISPlay:WINDow 1:TRACe 1:DELete
:DISPlay:WINDow 1:TRACe 1:FEED "test"
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe ON
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe?
:DISPlay:WINDow 1:TRACe 1:SELect
:DISPlay:WINDow 1:TRACe 1:STATe ON
:DISPlay:WINDow 1:TRACe 1:STATe?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:AUTO
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision 20
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition?


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data. These commands will effect data that is transferred with the CALC:DATA and CALC:RDATA commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

FORMat:BORDer <char>

(Write-only) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.

Parameters

<char>

Choose from:
NORMal - Use when your controller is anything other than an IBM compatible computers
SWAPped - for IBM compatible computers

Examples

FORM:BORD SWAP
format:border normal

Query Syntax

FORMat:BORDer?

Overlapped?

No

Default

Normal

FORMat[:DATA] <char>

(Read-Write) Sets the data format for use during transfer of measurement data.
Parameters |
<char> | Choose from: REAL,32 - (default value for REAL) Best for transfering large amounts of measurement data. REAL,64 - Slower but has more significant digits than REAL,32. Use REAL,64 if you have a computer that doesn't support REAL,32. ASCii,0 - The easiest to implement, but very slow. Use if small amounts of data to transfer.
Examples | FORM REAL,64 format:data ascii
Query Syntax | FORMat:DATA?
Return Type | Character,Character
Overlapped? | No
Default | REAL,32

List of all commands in this block:
(Parameters in bold italics)

FORMat:BORDer NORMal
FORMat:BORDer?
FORMat:DATA ASCii,0
FORMat:DATA?


Hardcopy

About Printing

Hardcopy Command

HCOPy[:IMMediate]

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable


Initiate

About Triggering

Initiate Commands

Controls triggering signals

INITiate:CONTinuous <boolean>

(Read-Write) Specifies whether the analyzer sends Continuous sweep triggers to triggerable channels or enables Manual triggering.
Parameters |
<boolean> | ON (or 1) - Continuous sweep mode. OFF (or 0) - Manual sweep mode.
Examples | INIT:CONT ON initiate:continuous off
Query Syntax | INITiate:CONTinuous?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

INITiate<cnum>[:IMMediate]

(Write-only) Stops the current sweeps and immediately sends a trigger to the specified channel. (Same as Sweep \ Trigger \ Restart on the front panel.)

  • If the specified channel is in HOLD, it will sweep one time and return to HOLD when complete.

  • If Trigger:Scope = Global, all channels will receive a trigger.

  • If Trigger:Scope = Channel (only the active channel receives a trigger) and the specified channel is not the active channel, the specified channel will NOT receive a trigger signal.

  • If the specified channel is NOT in Manual trigger (INIT:CONT OFF), the analyzer will return an error.

  • If channel <cnum> does not exist, the analyzer will return an error.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not applicable

Overlapped?

Yes

Default

Not applicable

List of all commands in this block:
(Parameters in bold italics)

:INITiate:CONTinuous ON
:INITiate:CONTinuous?
:INITiate 2:IMMediate


Memory

About Save / Recall

Memory Commands

The memory commands control saving and loading instrument states to the hard drive.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

All MMEM files have an extension according to their type.

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

The default folder is "C:\Program Files\Agilent\Network Analyzer\Documents"

You can change the active directory using MMEMory:CDIRectory, or you can use an absolute path name to specify all MMEM files and folders.

MMEMory:CATalog[:<char>]? [<folder>]

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned.
Parameters |
<char> | The type of files to list. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified then ALL file types (even unknown types) are listed.
<folder> | Any existing folder name. If unspecified C:\Program Files\Agilent\Network Analyzer\Documents is used.
Examples | MMEM:CAT? 'lists all files from the current folder mmemory:catalog:correction? "C:\Program Files\Agilent\Network Analyzer\Documents" 'lists .cal files from the specified folder
Overlapped? | No
Default | Not applicable

MMEMory:CDIRectory <folder>

(Read-Write) Changes the folder name.

Parameters

<folder>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:CDIR Service

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory "\automation" 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory "c:\automation\service"

Query Syntax

MMEMory:CDIRectory? 'Returns the current folder name

Return Type

String

Overlapped?

No

Default

"C:\Program Files\Agilent\Network Analyzer\Documents"

MMEMory:COPY <file1>,<file2>

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | Name of the file to be copied.
<file2> | Name of the file to be created from file1.
Examples | MMEM:COPY "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:DELete <file>

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | Name of the file to be deleted.
Examples | MMEM:DEL "MyFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:LOAD[:<char>] <file>

(Write-only) Loads the specified file.
Parameters |
<char> | The type of file to load. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If <char> is unspecified, the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of the file to be loaded. The default folder is used if unspecified in the filename.
Examples | MMEM:LOAD "MyFile.cst" mmemory:load:state "MyInstState"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MDIRectory <folder>

(Write-only) Makes a folder.
Parameters |
<folder> | Name of the folder to make.
Examples | MMEM:MDIR "MyFolder" mmemory:mdirectory "c:\NewFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MOVE <file1>,<file2>

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | Name of the file to be renamed.
<file2> | Name of the new file.
Examples | MMEM:MOVE "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:RDIRectory <folder>

(Write-only) Removes the specified folder.
Parameters |
<folder> | Name of the folder to remove.
Examples | MMEM:RDIR "MyFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe[:<char>] <file>

(Write-only) Stores the specified file.
Parameters |
<char> | The type of file to store. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified, then the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of any valid file that is not already in existance.
Examples | MMEM:STOR:STAT "myState" mmemory:store "c:\bin\myState.sta"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:MMEMory:CATalog:STATe? "C:\Program Files\Agilent\Network Analyzer\Documents"
:MMEMory:CDIRectory "\documents"
:MMEMory:CDIRectory?
:MMEMory:COPY "myState.sta","yourState"
:MMEMory:DELete "myState.sta"
:MMEMory:LOAD:STATe "myState"
:MMEMory:MDIRectory"myFolder"
:MMEMory:MOVE "myState.sta","yourState.sta"
:MMEMory:RDIRectory "myFolder"
:MMEMory:STORe:STATe "myState"


Output

About Power

Output Command

OUTPut[:STATe] <ON | OFF>

(Read-Write) Turns RF power from the source ON or OFF.
Parameters |
<ON | OFF> | ON (or 1) - turns RF power ON. OFF (or 0) - turns RF power OFF.
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

List of all commands in this block:
(Parameters in bold italics)

:OUTPut:STATe ON?
:OUTPut:STATe?


Average SCPI

About Averaging

Sens:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:AVERage:CLEar

(Write-only) Clears and restarts averaging of the measurement data. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

(Read-Write) Sets the number of measurement sweeps to combine for an average. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurement sweeps to average. Choose any number between: 1 and 1024
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns averaging ON. OFF (or 0) - turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:AVERage:CLEar
:SENSe 1:AVERage:COUNt 10
:SENSe 1:AVERage:COUNt?
:SENSe 1:AVERage:STATe ON
:SENSe 1:AVERage:STATe?


Sense Bandwidth

About IF Bandwidth

Sense:Bandwidth Command

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. The keywords BAND or BWID are interchangeable.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

IF Bandwidth in Hz. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Examples

SENS:BWID 1KHZ
sense2:bandwidth:resolution 1000

Query Syntax

SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:BANDwidth:RESolution 1000
:SENSe 1:BANDwidth:RESolution?


Sense Correction

About Measurement Calibration

Sense:Correction Commands

Performs and applies measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe:CORRection:COEFficient <term>[,port]

(Write-only) Displays the selected error term as trace data. Correction must be turned on.

Note: This command displays error terms for only Channel 1 measurements

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<term>

Error term to be displayed:

Specify this: | to get this Term...
1 | Directivity
2 | Source Match
3 | ReflectionTracking
4 | Isolation
5 | Load Match
6 | Transmission Tracking

[port]

Optional Parameter - Port number of the source drive. If unspecified, value is set to 1.

Examples

SENS:CORR:COEF 1
'Displays the directivity term for port 1 source

SENS:CORR:COEF 2,2
'Displays the source match for port 2 source

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <char>

(Write-only) Measures the specified standard from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

<char> | Measures the standards associated with these class labels:
STAN1 | S11A and S22A
STAN2 | S11B and S22B
STAN3 | S11C and S22C
STAN4 | S21T and S12T - usually the THRU standard
STAN5 | Generic Isolation; not associated with calibration kit definition
ECALA | ECAL module A
ECALB | ECAL module B

Examples

SENS:CORR:COLL STAN1
sense2:correction:collect:acquire stan5

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:METHod <char>

(Read-Write) Sets the calibration method. (Also known as 'Calibration Type' on calibration dialog box.)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
REFL1OPEN | Response Open
REFL1SHORT or REFL1 | Response Short
REFL3 | Full 1 port
TRAN1 | Response Thru
TRAN2 | Response Thru and Isolation
SPARSOLT | Full SOLT 2 port

Examples

SENS:CORR:COLL:METH REFL1
sense2:correction:collect:method sparsolt

Query Syntax

SENSe<cnum>:CORRection:COLLect:METHod?

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

(Write-only) Calculates the error terms using the selected :METHod and applies the error terms to the selected measurement (turns error correction ON.) Does NOT save the calibration error-terms.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:SAVE sense2:correction:collect:save
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:CSET[:SELect] <char>

(Read-Write) Restores a correction data set from memory. The file name is "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: DEF - Presets the analyzer USER01- Restores User01 calibration data USER02 - Restores User02 calibration data through... USER10 - Restores User10 calibration data
Examples | SENS:CORR:CSET DEF sense2:correction:cset:select user02
Query Syntax | SENSe<cnum>:CORRection:CSET[:SELect]?
Return Type | Charact er
Overlapped? | No
Default | DEF

SENSe<cnum>:CORRection:CSET:SAVE <char>

Write a correction data set to memory or Read the last correction set saved. The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: USER01 USER02... USER10
Examples | SENS:CORR:CSET:SAVE USER03 sense2:correction:cset:save user09
Query Syntax | SENSe<cnum>:CORRection:CSET:SAVE? Queries the last correction set saved.
Return Type | Charact er
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified port. Must also set SENS:CORR:EXT ON.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Number of the port that will receive the extension. If unspecified, value is set to 1. Choose from:

1 | Port 1
2 | Port 2

<num>

The port extension in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:PORT 2MS
sense2:correction:extension:port2 .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified receiver. Must also set SENS:CORR:EXT ON .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<Rnum>

Number of the receiver that will receive the extension. If unspecified, value is set to 1
Choose from:

1 | Receiver A
2 | Receiver B

<num>

The electrical length in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:REC 2MS
sense2:correction:extension:receiver2:time .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

(Read-Write) Turns port extensions ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port entensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance: INPut:MAGNitude?
Return Type | Character
Overlapped? | No
Default | 50

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

(Read-Write) Turns correction interpolation ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolation:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

(Read-Write) Turns isolation cal ON or OFF during Full 2-port calibration. If this comand is not sent, the default state is to disable Isolation.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns isolation ON. OFF (or 0) - turns isolation OFF.
Examples | SENS:CORR:ISOL ON sense2:correction:isolation:state off
Query Syntax | SENSe<cnum>:CORRection:ISOLation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF - (Isolation disabled)

SENSe<cnum>:CORRection:RVELocity:COAX <num>

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between: 0 and 10 (.66 polyethylene dielectric; .7 teflon dielectric) Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

(Read-Write) Specifies whether or not correction data is applied to the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the measurement. OFF (or 0) - correction is NOT applied to the measurement.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COEFficient 2,1
:SENSe1:CORRection:COLLect:ACQuire STAN1
:SENSe1:CORRection:COLLect:ACQuire?
:SENSe1:CORRection:COLLect:APPLy
:SENSe1:CORRection:COLLect:AVERage:COUNt 4
:SENSe1:CORRection:COLLect:AVERage:COUNt?
:SENSe1:CORRection:COLLect:METHod SPARSOLT
:SENSe1:CORRection:COLLect:METHod?
:SENSe1:CORRection:COLLect:SAVE
:SENSe1:CORRection:CSET:SELect USER05
:SENSe1:CORRection:CSET:SELect?
:SENSe1:CORRection:CSET:SAVE USER03
:SENSe 1:CORRection:CSET:SAVE?
:SENSe1:CORRection:EXTension:PORT2:TIME 2ms
:SENSe1:CORRection:EXTension:PORT2:TIME?
:SENSe1:CORRection:EXTension:RECeiver2:TIME 2ms
:SENSe1:CORRection:EXTension:RECeiver2:TIME?
:SENSe1:CORRection:EXTension:STATe ON
:SENSe1:CORRection:EXTension:STATe?
:SENSe1:CORRection:INTerpolation:STATe ON
:SENSe1:CORRection:INTerpolation:STATe?
:SENSe1:CORRection:ISOLation:STATe ON
:SENSe1:CORRection:ISOLation:STATe?
:SENSe1:CORRection:RVELocity:COAX .66
:SENSe1:CORRection:RVELocity:COAX?
:SENSe1:CORRection:STATe ON
:SENSe1:CORRection:STATe?


CorrCollCKIT

About Modifying Cal Kits

Sense:Correction:Collect:CKit Commands

Use to change the definitions of calibration kit standards.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL .

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

SENSe:CORRection:COLLect:CKIT:NAME <name>

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME MYAPC35 sense:correction:collect:ckit:name mytypen
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <standard>

(Read-Write) Sets a standard number to a calibration class. Does NOT set or dictate the order for measuring the standards. For more information, see Calibration Standards / Fabricating Calibration Standards / Assigning Standards to a Calibration Class

Parameters

<class>

Number of the calibration class that is assigned to <standard>. Choose a number between:
1 and 8
The <class> numbers are associated with the following calibration classes:

<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard

<standard>

Standard number between 1 and 8

Examples

Assigns standard 3 to S11A class:
SENS:CORR:COLL:CKIT:ORD1 3
Assigns standard 2 to S21T class class:
sense:correction:collect:ckit:order4 2

Query Syntax

SENSe:CORRection:COLLect:CKIT:ORDer?

Return Type

Character; returns the <class> number of the selected standard.

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:RESet <num>

(Write-only) Resets the selected calibration kit to factory default definition values.
Parameters |
<num> | The number of the calibration kit to be reset. Choose any integer between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:RESet 1 sense:correction:collect:ckit:reset 4
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

(Read-Write) Selects (makes active) a calibration kit. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>

Parameters

<num>

The number of the calibration kit. The following are the default settings. Choose from:

<num> | Name | Model
1 | Type N 85032F | 85032F
2 | 3.5mm 85033E | 85033E
3 | Type N | 85032B
4 | 3.5mm 85033D | 85033D
5 | 7-16 85038A | 85038A
6 | 3.5mm TRL | 85052C
7 | User Defined 7 | NA
8 | User Defined 8 | NA
9 | User Defined 9 | NA
10 | User Defined 10 | NA
99 | ECAL module | NA

Examples

SENS:CORR:COLL:CKIT 2
sense2:correction:collect:ckit:select 7

Query Syntax

SENSe:CORRection:COLLect:CKIT?

Return Type

Charact er

Overlapped?

No

Default

1

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard.
Parameters |
<num> | Value for C0 in picofarads
Examples | The following commands set C0=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard.
Parameters |
<num> | Value for C1 in picofarads
Examples | The following two commands set C1=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard.
Parameters |
<num> | Value for C2 in picofarads
Examples | The following two commands set C2=(-15) picofarads: SENS:CORR:COLL:CKIT:STAN:C2 -15 sense:correction:collect:ckit:standard:c2 -15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard.
Parameters |
<num> | Value for C3 in picofarads
Examples | The following two commands set C3=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | String
Overlapped? | No
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in seconds
Examples | SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmax 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

(Read-Write) Sets the minumum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fmin 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Character
Overlapped? | No
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard.
Parameters |
<num> | Value for L0 in picohenries
Examples | The following two commands set L0=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard.
Parameters |
<num> | Value for L1 in picohenries
Examples | The following two commands set L1=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard.
Parameters |
<num> | Value for L2 in picohenries
Examples | The following two commands set L2=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard.
Parameters |
<num> | Value for L3 in picohenries
Examples | The following two commands set L3=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB "OPEN" sense:correction:collect:ckit:standard:label "Short2"
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Character
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD THRU (Through)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COLLect:CKIT:NAME mytypen
:SENSe:CORRection:COLLect:CKIT:NAME?
:SENSe:CORRection:COLLect:CKIT:ORDer 4 2
:SENSe:CORRection:COLLect:CKIT:ORDer?
:SENSe:CORRection:COLLect:CKIT:RESet 1
:SENSe:CORRection:COLLect:CKIT:SELect 7
:SENSe:CORRection:COLLect:CKIT?
:SENSe:CORRection:COLLect:CKIT:STANdard:C0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C0?
:SENSe:CORRection:COLLect:CKIT:STANdard:C1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C1?
:SENSe:CORRection:COLLect:CKIT:STANdard:C2 -15
:SENSe:CORRection:COLLect:CKIT:STANdard:C2?
:SENSe:CORRection:COLLect:CKIT:STANdard:C3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C3?
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter COAX
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay 50ps
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9Ghz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 1khz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50.3
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
:SENSe:CORRection:COLLect:CKIT:STANdard:L0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L0?
:SENSe:CORRection:COLLect:CKIT:STANdard:L1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L1?
:SENSe:CORRection:COLLect:CKIT:STANdard:L2 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L2?
:SENSe:CORRection:COLLect:CKIT:STANdard:L3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L3?
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel "Short2"
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 3.5e9
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT 8
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT?
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE LOAD
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?


Couple

About Alternate Sweep

Sense:Couple Command

SENSe<cnum>:COUPle <ALL | NONE>

(Read-Write) Sets the sweep mode as Chopped or Alternate.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ALL | NONE> | ALL - Sweep mode set to Chopped - reflection and transmission measured on the same sweep. NONE - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases sweep time
Examples | SENS:COUP ALL sense2:couple none
Query Syntax | SENSe<cnum>:COUPle?
Return Type | Character
Overlapped? | No
Default | ALL

List of all commands in this block:
(Parameters in bold italics)

:SENSe1:COUPle ALL
:SENSe1:COUPle?


Frequency

About Frequency Sweep

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:FREQuency:CENTer <num>

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000
sense2:frequency:center 1mhz

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

(Read-Write) Sets the Continuous Wave (or Fixed) frequency. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Character

Overlapped?

No

Default

1 GHz

SENSe<cnum>:FREQuency:SPAN <num>

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span. Choose any number between:
0 (minimum) and the maximum frequency span of the anal yzer.
Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

(Read-Write) Sets the start frequency of the analyzer.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz Note: If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START. Note: This command will accept MIN or M AX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:FREQ:STAR 1000000 sense2:frequency:start MIN
Query Syntax | SENSe<cnum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer. Units are Hz

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

Return Type

Character

Overlapped?

No

Default

Maximum frequency of the analyzer

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:FREQuency:CENTer 1mhz
:SENSe 1:FREQuency:CENTer?
:SENSe1:FREQuency:CW 100e6
:SENSe1:FREQuency:CW?
:SENSe 1:FREQuency:SPAN 10e6
:SENSe 1:FREQuency:SPAN?
:SENSe 1:FREQuency:STARt 10e6
:SENSe 1:FREQuency:STARt?
:SENSe 1:FREQuency:STOP 1e9
:SENSe 1:FREQuency:STOP?


Power

About Receiver Attenuation

Sense:Power Command

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

(Read-Write) Sets the attenuation level for the specified receiver. Note: Attenuation cannot be set with Sweep Type set to Power
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<recvr> | Receiver to get attenuation. Choose from: ARECeiver - receiver A BRECeiver - receiver B
<num> | Choose from: 0 to 35 dB - in 5 dB steps If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 15 dB attenuation.
Examples | SENS:POW:ATT AREC,10 sense2:power: attentuation breceiver,30
Query Syntax | SENSe<cnum>:POWer :ATTenuation? <rec>
Return Type | Character
Overlapped? | No
Default | 0

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:POWer:ATTenuation AREC,10
:SENSe1:POWer:ATTenuation? AREC


Roscillator

About the Reference Osc.

Sense:Roscillator Command

SENSe:ROSCillator:SOURce?

(Read-only) Applying a signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked. EXT is returned when a signal is present at the Reference Oscillator connector. INT is returned when NO signal is present at the Reference Oscillator connector.
Examples | SENS:ROSC:SOUR? sense:roscillator:source?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:ROSCillator:SOURce?


Segment

About Segment Sweep

Sense:Segment Commands

Defines the segment sweep settings. Enable segment sweep with SENS:SWE:TYPE SEGMent.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SEGMent<snum>:ADD

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

(Read-Write) Sets the IFBandwidth for the specified segment. First set SENS:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |
If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ
sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment OFF (or 0) - turns Bandwidth control OFF. Use channel bandwidth setting
Examples | SENS:SEGM:BWID:CONT ON sense2:segment:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent:COUNt?

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Character
Overlapped? | No
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

(Write-only) Deletes the specified sweep segment.
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Number of the segment to delete. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:DELete:ALL

(Write-only) Deletes all sweep segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

(Read-Write) Sets the Start Frequency for the specified sweep segment. Note: All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STAR 1MHZ sense2:segment2:frequency:start minimum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

(Read-Write) Sets the Stop Frequency for the specified sweep segment. Note: All other segment's Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STOP 1MHZ sense2:segment2:frequency:stop maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?
Return Type | Character
Overlapped? | No
Default | If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON. All subsequent segments that are added assume the new Power Level value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<port> | Port number of the source. Choose from 1 or 2. If unspecified, value is set to 1.
<num> | Power level. Choose from any number between: -90 and 20
Examples | SENS:SEGM:POW 0 sense2:segment2:power1:level -10
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Power Level control ON. Power level can be set for each segment. OFF (or 0) - turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF
<ON | OFF> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent[:STATe]? <snum>
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:POIN 51 sense2:segment2:sweep:points maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to sweep the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Sweep time in seconds. Choose a number between 0 and 100 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Sweep Time control ON. Sweep Time can be set for each segment. OFF (or 0) - turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIM:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SEGMent 1:ADD
:SENSe 1:SEGMent 1:BWIDth:RESolution 1000
:SENSe 1:SEGMent 1:BWIDth:RESolution?
:SENSe 1:SEGMent:BANDwidth:CONTrol ON
:SENSe 1:SEGMent:BANDwidth:CONTrol?
:SENSe 1:SEGMent:COUNt?
:SENSe 1:SEGMent 1:DELete
:SENSe 1:SEGMent:DELete:ALL
:SENSe 1:SEGMent 1:FREQuency:CENTer 1e6
:SENSe 1:SEGMent 1:FREQuency:STARt?
:SENSe 1:SEGMent 1:FREQuency:SPAN 1e6
:SENSe 1:SEGMent 1:FREQuency:SPAN?
:SENSe 1:SEGMent 1:FREQuency:START 1e6
:SENSe 1:SEGMent 1:FREQuency:START?
:SENSe 1:SEGMent 1:FREQuency:STOP 1e6
:SENSe 1:SEGMent 1:FREQuency:STOP?
:SENSe 1:SEGMent 1:POWer 1:LEVel -10
:SENSe 1:SEGMent 1:POWer 1:LEVel?
:SENSe 1:SEGMent:POWer:LEVel:CONTrol ON
:SENSe 1:SEGMent:POWer:LEVel:CONTrol?
:SENSe 1:SEGMent 1:STATe ON
:SENSe1:SEGMent1:STATe?
:SENSe 1:SEGMent 1:SWEep:POINts 400
:SENSe 1:SEGMent 1:SWEep:POINts?
:SENSe 1:SEGMent 1:SWEep:TIME .001
:SENSe 1:SEGMent 1:SWEep:TIME?
:SENSe 1:SEGMent:SWEep:TIME:CONTrol ON
:SENSe 1:SEGMent:SWEep:TIME:CONTrol?


Sweep SCPI

About Sweeping

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SWEep:DWELl <num>

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENSe:SWEep:GENeration set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dwell min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Character

Overlapped?

No

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:GENeration <char>

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Overlapped?

No

Default

Analog

SENSe<cnum>:SWEep:GROups:COUNt <num>

(Read-Write) Sets the trigger count (groups) for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:MODE <char>

(Read-Write) Sets the trigger mode for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Trigger mode. Choose from: HOLD - channel will not trigger CONTinuous - channel triggers indefinitely GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>
Examples | SENS:SWE:MODE CONT sense2:sweep:mode hold
Query Syntax | SENSe<cnum>:SWEep:MODE?
Return Type | Character
Overlapped? | YES - SENS:SWE:MODE GROUPS (when INIT:CONT is ON) NO - HOLD and CONTinuous
Default | CONTinuous

SENSe<cnum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SWEep:SRCPort <1 | 2>

(Read-Write) Sets the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<1 | 2> | 1 - Source power comes out Port 1 2 - Source power comes out Port 2
Examples | SENS:SWE:SRCP 1 sense2:sweep:srcport 2
Query Syntax | SENSe<cnum>:S WEep:SRCPort?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to complete one sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Sweep time in seconds. Choose a number between 0 and 86,400 (24hrs) Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:TIME 1ms sense2:sweep:time .001
Query Syntax | SENSe<cnum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | NA

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

(Read-Write) Specifies whether the specified channel will measure one point for each trigger or all of the measurements in the channel. Setting any channel to POINt mode will automatically set the TRIGger:SCOPe = CURRent.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - Channel measures one data point per trigger. OFF (or 0) - All measurements in the channel made per trigger.
Examples | SENS:SWE:TRIG:POIN ON sense2:sweep:trigger:point off
Query Syntax | SENSe<cnum>:SWEep:TRIGger:POINt?
Return Type | Boolean (1 = Point, 0 = Measurement)
Overlapped? | No
Default | 0 - Measurement

SENSe<cnum>:SWEep:TYPE <char>

(Read-Write) Sets the type of analyzer sweep mode.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Overlapped? | No
Default | LINear

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SWEep:DWELL 2ms
:SENSe 1:SWEep:DWELL?
:SENSe 1:SWEep:DWELL:AUTO ON
:SENSe 1:SWEep:DWELL:AUTO?
:SENSe 1:SWEep:GENeration STEP
:SENSe 1:SWEep:GENeration?
:SENSe 1:SWEep:GROups:COUNt 50
:SENSe 1:SWEep:GROups:COUNt?
:SENSe 1:SWEep:MODE CONT
:SENSe 1:SWEep:MODE?
:SENSe 1:SWEep:POINts 201
:SENSe 1:SWEep:POINts?
:SENSe 1:SWEep:SRCPort 1
:SENSe 1:SWEep:SRCPort?
:SENSe 1:SWEep:TIME 2ms
:SENSe 1:SWEep:TIME?
:SENSe 1:SWEep:TIME:AUTO ON
:SENSe 1:SWEep:TIME:AUTO?
:SENSe 1:SWEep:TRIGger:POINt ON
:SENSe 1:SWEep:TRIGger:POINt?
:SENSe 1:SWEep:TYPE LINear
:SENSe 1:SWEep:TYPE?


source

About Power Settings

Source Commands

Controls the power delivered to the DUT.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SOURce<cnum>:POWer<port>:ATTenuation <num>

(Read-Write) Sets the attenuation level for the selected channel. Sending this command turns automatic attenuation control (SOUR:POW:ATT:AUTO) to OFF. If the ports are coupled, changing the attenuation on one port will also change the attenuation on the other port. To turn port coupling OFF use SOURce:POWer:COUPle OFF.

Note: Attenuation cannot be set with Sweep Type set to Power

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Choose a number between 0 and 70 dB, in 10 dB steps.
If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 10 dB attenuation.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW:ATT 10
source2:power:attentuation maximum

Query Syntax

SOURce<cnum>:POWer<port>:ATTenuation?

Return Type

Character

Overlapped?

No

Default

0

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

(Read-Write) Turns automatic attenuation control ON or OFF. Setting an attenuation value (using SOURce:POWer:ATTenuation <num>) sets AUTO OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns coupling ON. The analyzer automatically selects the appropriate attenuation level to meet the specified power level. OFF (or 0) - turns coupling OFF. Attenuation level must be set using SOURce:POWer:ATTenuation <num>.
Examples | SOUR:POW2:ATT:Auto On source2:power: attentuation:auto off
Query Syntax | SOURce<cnum>:POWer:ATTenuation:Auto?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:CENTer <num>

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Choose a number between -90 and 20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:COUPle <ON | OFF>

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns coupling ON. Power level can be set individually for each source port. OFF (or 0) - turns coupling OFF. The same power level is used for both source ports.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

(Read-Write) Sets the source leveling loop as Internal or External.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<INTernal | EXTernal> | INTernal - Internal leveling is applied to the source EXTernal - External leveling is applied to the source through a rear-panel jack.
Examples | SOUR:POW:DET INT source2:power:detector external
Query Syntax | SOURce<cnum>:POWer:DETector?
Return Type | Character
Overlapped? | No
Default | INTernal

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate]
[:AMPLitude] <num>

(Read-Write) Sets the RF power output level.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Source power in dBm. Choose any value between -90 and +20 dBm
Actual achievable leveled power depends on frequency.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW1 5DB
source2:power:level
:immediate:amplitude maximum

Query Syntax

SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

(Read-Write) Sets the RF power slope value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<int> | Slope value in db/GHz. Choose any integer between -2 and 2 (0 is no slope).
Examples | SOUR:POW:SLOP 2 source2:power:slope -2
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Character
Overlapped? | No
Default | 0

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

(Read-Write) Turns Power Slope ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SOURce<cnum>:POWer:SPAN <num>

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Span power. Choose a number between:
-90 and 20 dBm
(actual achievable leveled power depends on frequency)

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer:STARt <num>

(Read-Write) Sets the power sweep start power. Must also set SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:STOP <num>

(Read-Write) Sets the power sweep stop power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Character
Overlapped? | No
Default | 0 dBm

List of all commands in this block:
(Parameters in bold italics)

:SOURce 1:POWer1:ATTenuation 5
:SOURce 1:POWer1:ATTenuation?
:SOURce 1:POWer1:ATTenuation:AUTO ON
:SOURce 1:POWer1:ATTenuation:AUTO?
:SOURce 1:POWer:CENTer -7
:SOURce 1:POWer:CENTer?
:SOURce1:POWer:COUPle ON
:SOURce1:POWer:COUPle?
:SOURce 1:POWer:DETector INTernal
:SOURce 1:POWer:DETector?
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude 5
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude?
:SOURce 1:POWer:LEVel:SLOPe -2
:SOURce 1:POWer:LEVel:SLOPe?
:SOURce 1:POWer:LEVel:SLOPe:STATe ON
:SOURce 1:POWer:LEVel:SLOPe:STATe?
:SOURce 1:POWer:SPAN -7
:SOURce 1:POWer:SPAN?
:SOURce 1:POWer:STARt 0
:SOURce 1:POWer:STARt?
:SOURce 1:POWer:STOP 5
:SOURce 1:POWer:STOP?


Status

About Status Registers

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

Click on a blue register to view the details

Note: Any bit not shown in the registers is not used but may be reserved for future use.

Status Byte Register

Summarizes the states of the other registers and monitors the analyzer's output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

Questionable Summary Register

Summarizes conditions that monitor the quality of measurement data.

STATus:QUEStionable:<keyword>

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

Integrity Summary Register

Summarizes conditions in the Measurement Integrity register.

STATus:QUEStionable:INTegrity <keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
0 | 2 | Hardware Summary | any bit in the Hardware event register is set to 1

Hardware Register

Monitors the status of hardware failures.

STATus:QUEStionable:INTegrity:HARDware<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:HARD:COND?

:ENABle <bits>

STAT:QUES:INT:HARD:ENAB 1024

[:EVENt]?

STAT:QUES:INT:HARD?

:NTRansition <bits>

STAT:QUES:INT:HARD:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:HARD:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Phase Unlock | the source has lost phaselock, possibly caused by a reference channel open or a hardware failure.
2 | 4 | Unleveled | the source power is unleveled. This could be caused by a source set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
3 | 8 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
4 | 16 | EE Write Failed | an attempted write to the EEPROM has failed, possibly caused by a hardware failure.
5 | 32 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
6 | 64 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
7 | 128 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

Measurement Register

Monitors the lag between changing a channel settings and when the data is ready to query out.

When you change the channel state (start/stop freq, bandwidth, and so on), then the questionable bit for that channel gets set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next complete sweep has been taken (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

STATus:QUEStionable:INTegrity:MEASurement<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS?

:NTRansition <bits>

STAT:QUES:INT:MEAS:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Channel1 | a channel1 setting change has occured and the data does not yet reflect that change.
1 | 2 | Channel2 | a channel2 setting change has occured and the data does not yet reflect that change.
2 | 4 | Channel3 | a channel3 setting change has occured and the data does not yet reflect that change.
3 | 8 | Channel4 | a channel4 setting change has occured and the data does not yet reflect that change.

Limit1 Register

Monitors the status of limit line failures and summarizes the Limit2 event register. When a trace fails, or any bit in the Limit2 event register fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note:The '1' on 'LIMit1 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit1<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM1:COND?

:ENABle <bits>

STAT:QUES:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LIM1?

:NTRansition <bits>

STAT:QUES:LIM1:NTR 1024

:NTRansition?

STAT:QUES:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LIM1:PTR 0

:PTRansition?

STAT:QUES:LIM1:PTR?

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Limit 2 Reg summary | any point from limit2 event register fails
1 | 2 | Trace 1 | any point on trace fails the limit test
2 | 4 | Trace 2 | any point on trace fails the limit test
3 | 8 | Trace 3 | any point on trace fails the limit test
4 | 16 | Trace 4 | any point on trace fails the limit test
5 | 32 | Trace 5 | any point on trace fails the limit test
6 | 64 | Trace 6 | any point on trace fails the limit test
7 | 128 | Trace 7 | any point on trace fails the limit test
8 | 256 | Trace 8 | any point on trace fails the limit test
9 | 512 | Trace 9 | any point on trace fails the limit test
10 | 1024 | Trace 10 | any point on trace fails the limit test
11 | 2048 | Trace 11 | any point on trace fails the limit test
12 | 4096 | Trace 12 | any point on trace fails the limit test
13 | 8192 | Trace 13 | any point on trace fails the limit test
14 | 16384 | Trace 14 | any point on trace fails the limit test

Limit2 Register

Monitors the status of limit line failures. When trace 15 or 16 fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note: The '2' on 'LIMit2 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit2<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM2:COND?

:ENABle <bits>

STAT:QUES:LIM2:ENAB 1024

[:EVENt]?

STAT:QUES:LIM2?

:NTRansition <bits>

STAT:QUES:LIM2:NTR 1024

:PTRansition <bits>

STAT:QUES:LIM2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace15 | any point on trace fails the limit test
2 | 4 | Trace16 | any point on trace fails the limit test

Define Summary Register

Summarizes conditions in the Questionable:Define:User<1|2|3> event registers.

STATus:QUEStionable:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:DEF:COND?

:ENABle <bits>

STAT:QUES:DEF:ENAB 1024

[:EVENt]?

STAT:QUES:DEF?

:NTRansition <bits>

STAT:QUES:DEF:NTR 1024

:PTRansition <bits>

STAT:QUES:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Questionable User Registers

Monitors conditions that you define and map in any of the three QUES:DEF:USER event registers.

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:QUES:DEF:USER1:ENABle 1024

[:EVENt]?

STAT:QUES:DEF:USER1?

:MAP <bit>,<error>

STAT:QUES:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

Standard Event Status Register

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

Operation Summary Register

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

STATus:OPERation<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |

Averaging1 Register

Monitors Averaging of Traces 1 to 14 and summarizes Traces 15 and 16.

Note:The '1' on 'AVERaging1 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging1<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | AVER2 summary | any enabled bit in AVERaging2 event register is set to 1
1 | 2 | Trace 1 | Averaging is complete
2 | 4 | Trace 2 | Averaging is complete
3 | 8 | Trace 3 | Averaging is complete
4 | 16 | Trace 4 | Averaging is complete
5 | 32 | Trace 5 | Averaging is complete
6 | 64 | Trace 6 | Averaging is complete
7 | 128 | Trace 7 | Averaging is complete
8 | 256 | Trace 8 | Averaging is complete
9 | 512 | Trace 9 | Averaging is complete
10 | 1024 | Trace 10 | Averaging is complete
11 | 2048 | Trace 11 | Averaging is complete
12 | 4096 | Trace 12 | Averaging is complete
13 | 8192 | Trace 13 | Averaging is complete
14 | 16384 | Trace 14 | Averaging is complete

Averaging2 Register

Monitors Averaging of Traces 15 and 16.

Note:The '2' on 'AVERaging2 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging2<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER2:COND?

:ENABle <bits>

STAT:OPER:AVER2:ENAB 1024

[:EVENt]?

STAT:OPER:AVER2?

:NTRansition <bits>

STAT:OPER:AVER2:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace 15 | Averaging is complete
2 | 4 | Trace 16 | Averaging is complete

Define Summary Register

Summarizes conditions in the OPERation:Define:User<1|2|3> event registers.

STATus:OPERation:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:DEF:COND?

:ENABle <bits>

STAT:OPER:DEF:ENAB 12

[:EVENt]?

STAT:OPER:DEF?

:NTRansition <bits>

STAT:OPER:DEF:NTR 12

:PTRansition <bits>

STAT:OPER:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Operation User Registers

Monitors conditions that you define and map in any of the three OPER:DEF:USER event registers.

STATus:OPERation:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:OPER:DEF:USER1:ENAB 1024

[:EVENt]?

STAT:OPER:DEF:USER1?

:MAP <bit>,<error>

STAT:OPER:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined


System

About Preset

System Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SYSTem:ERRor?

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Examples

SYST:ERR?
system:error?

Overlapped?

No

Default

Not applicable

SYSTem:ERRor:COUNt?

(Read-only) Returns the number of errors in the error queue.Use SYST:ERR? to read an error.
Examples | SYST:ERR:COUN? system:error:count?
Overlapped? | No
Default | Not applicable

SYSTem:PRESet

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Default.
Examples | SYST:PRES system:preset
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SYSTem:ERRor?
:SYSTem:ERRor:COUNt?
:STSTem:PRESet


Trigger SCPI

About Triggering

Trigger Commands

Starts or ends a measurement sequence. These commands are an important part of synchronizing measurements.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

TRIGger[:SEQuence]:SCOPe <char>

(Read-Write) Specifies whether triggers are applied to all channels or the current channel.
Parameters |
<char> | Choose from: ALL - triggers all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels. CURRent - trigger only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel. You can use CURRent only when TRIG:SOURCE = MANual.
Examples | TRIG:SCOP ALL trigger:sequence:scope current
Query Syntax | TRIGger[:SEQuence]:SCOPe?
Return Type | Character
Overlapped? | No
Default | ALL

TRIGger[:SEQuence]:SLOPe <char>

(Read-Write) Triggers either on the positive going or negative going trigger signal edge. This setting only has an effect when TRIG:SOURce EXTernal is selected.
Parameters |
<char> | Choose from: POSitive - external (rear panel) source NEGative - internal source sends indefinite trigger signals
Examples | TRIG:SLOP POS trigger:sequence:source negative
Query Syntax | TRIGger[:SEQuence]:SLOPe?
Return Type | Character
Overlapped? | No
Default | NEGative

TRIGger[:SEQuence]:SOURce <char>

(Read-Write) Sets the source of the sweep trigger signal. This command is a superset of INITiate:CONTinuous, which can NOT set the source to External.
Parameters |
<char> | Choose from: EXTernal - external (rear panel) source IMMediate - internal source sends continuous trigger signals MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.
Examples | TRIG:SOUR EXT trigger:sequence:source immediate
Query Syntax | TRIGger[:SEQuence]:SOURce?
Return Type | Character
Overlapped? | No
Default | IMMediate

List of all commands in this block:
(Parameters in bold italics)

:TRIGger:SEQuence:SCOPe ALL
:TRIGger:SEQuence:SCOPe?
:TRIGger:SEQuence:SLOPe POS
:TRIGger:SEQuence:SLOPe?
:TRIGger:SEQuence:SOURce EXT
:TRIGger:SEQuence:SOURce?


Channels, Windows, and Measurements using GPIB

SOURce and most SENSe commands act on the channel that is specified in the command. Channel 1 is default if not specified. There can be up to four channels present (numbers 1 to 4) in the analyzer at the same time.

Most DISPlay commands act on the window and trace specified in the command. Window1 and Trace1 are default if not specified. There can be up to four windows present (numbers 1 to 4) and up to four traces present in each window (numbers 1 to 4) at the same time.

CALCulate commands act on the selected measurement in the specified channel. Select the measurement for each channel using CALCulate<channel number>:PARameter:SELect <meas name>. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time.

The following Visual Basic program does the following:

  • Presets the analyzer

  • Create 2 windows

  • Create 2 Measurements

  • Feed the measurements to windows / traces

  • Change frequency ranges for channels

  • Select both measurements

  • Turn marker 1 ON for each measurement

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PREset"

'Create Measurements
GPIB.Write "CALCulate1:PARameter:DEFine 'Meas1',S11"
GPIB.Write "CALCulate2:PARameter:DEFine 'Meas2',S21"

' Turn on windows - creates if new
GPIB.Write "DISPlay:WINDow1:STATE ON"
GPIB.Write "DISPlay:WINDow2:STATE ON"

'Associate ("FEED") the measurement name('Meas1') to WINDow(1), and give the new TRACe a number(1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'Meas1'"
GPIB.Write "DISPlay:WINDow2:TRACe2:FEED 'Meas2'"

'Change each channel's frequency range
GPIB.Write "SENSe1:FREQuency:SPAN 1e9"
GPIB.Write "SENSe2:FREQuency:SPAN 2e9"

'Select both measurements
GPIB.Write "CALCulate1:PARameter:SELect 'Meas1'"
GPIB.Write "CALCulate2:PARameter:SELect 'Meas2'"

'Turn marker 1 ON for each measurement
GPIB.Write "CALCulate1:MARKer:STATe ON"
GPIB.Write "CALCulate2:MARKer:STATE ON"


Create a Measurement using GPIB

This Visual Basic program creates a new S21 measurement and displays it on the display. Use the links to see the command details.

To run this program, you need:

  • An established GPIB interface connection

'Preset the analyzer
GPIB.Write "SYSTem:PReset"

' Turn on window 1 - if new, creates it
GPIB.Write "DISPlay:WINDow1:STATE ON"

'Define a measurement name, parameter
GPIB.Write "CALCulate:PARameter:DEFine 'MyMeas',S21"

'Associate ("FEED") the measurement name ('MyMeas') to WINDow (1), and give the new TRACe a number (1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"


Catalog Measurements using GPIB

This Visual Basic Program does the following:

  • Catalogs the currently defined measurements, windows, and traces

  • Selects a measurement for further definition

  • Adds a Title to the window

To run this program, you need:

  • An established GPIB interface connection

Dim Meas as String
Dim Win as String
Dim Trace as String

'Read the current measurements in Channel 1
GPIB.Write "CALCulate1:PARameter:CATalog?"
Meas = GPIB.Read
MsgBox ("Ch1 Measurments: " & Meas)

'Read the current windows
GPIB.Write "DISPlay:CATalog?"
Win = GPIB.Read
MsgBox ("Windows: " & Win)

'Read current traces in window 1
GPIB.Write "DISPlay:WINDow1:CATalog?"
Trace = GPIB.Read
MsgBox ("Traces in Window1: " & Win)


Perform a Calibration using GPIB

This Visual Basic program does a Full 2-Port Calibration, including Isolation

To run this program, you need:

  • An established GPIB interface connection

  • A 2-port measurement set up with desired frequency range, power, and so forth, ready to be calibrated.

Sub SOLTCal()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'Select 2-Port Calibration
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Select a cal kit
Calkitnum = 3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Measure the standards
MsgBox "Connect OPEN's to Ports 1 and 2; then press OK"
Call Measurestandard("stan1")
MsgBox "Connect SHORT's to Ports 1 and 2; then press OK"
Call Measurestandard("stan2")
MsgBox "Connect LOAD's to Ports 1 and 2; then press OK"
Call Measurestandard("stan3")
MsgBox "Connect THRU between Ports 1 and 2; then press OK"
Call Measurestandard("stan4")
MsgBox "Disconnect Ports 1 and 2 for isolation; then press OK"
Call Measurestandard("stan5")

'Compute the coefficients and turn on error correction
GPIB.Write "SENSe:CORRection:COLLect:SAVE"

'Resume continuous sweep.
GPIB.Write "INITialize:CONTinuous ON"
End Sub

Sub Measurestandard(Std$)
'Store the results of a sweep as correction data
GPIB.Write "SENSe:CORRection:COLLect " & Std$

'Take a sweep;return when complete
GPIB.Write "INITiate:IMMediate;*OPC?"
OPCreply = GPIB.Read

End Sub


ECALibrate Using GPIB

The following program does an Electronic Calibration using an Agilent ECAL module
These commands do the following:

  • Acquire the standards

  • Move the error terms back into the analyzer

  • Enable the calibration

Note: A separate :SENS:CORR:COLL:SAVE is not needed.

To run this program, you need:

  • An established GPIB interface connection

Private Sub Command5_Click()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'ECal full 1 port and 2 port
'This program assumes you have already set up the analyzer for an S11 measurement over the frequency range, power, etc. that you want.

'Select the Ecal "Kit"
GPIB.Write "SENSe:CORRection:COLLect:CKIT 99"

'Choose a Calibration Type (comment out one of these)
GPIB.Write "SENSe:CORRection:COLLect:METHod refl3"
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Enable or disable (comment out one) measurement of isolation
GPIB.Write "SENSe:CORRection:ISOLation ON"
GPIB.Write "SENSe:CORRection:ISOLation OFF"

'Prompt for the ECal module
MsgBox ("Connect ECal module to Port 1, then press enter")

'Acquire and store the calibration terms - return (*OPC) when finished
GPIB.Write "SENSe:CORRection:COLLect:ACQuire ECALA;*OPC?"
X = GPIB.Read
MsgBox ("Done with calibration.")

End Sub


Modify a Calibration Kit using GPIB

This Visual Basic program:

  • Modifies Calibration kit number 3

  • Completely defines standard #4 (thru)

To run this program, you need:

  • An established GPIB interface connection

'Modifying cal kit number 3
Calkitnum = 3

'Designate the kit selection to be used for performing cal's
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Reset to factory default values.
GPIB.Write "SENSe:CORRection:COLLect:CKIT:RESet " & Val(Calkitnum)

'Name this kit with your own name
GPIB.Write "SENSe:CORRection:COLLect:CKIT:NAME 'My Cal Kit'"

'Assign standard numbers to calibration classes
'Set Port 1, class 1 (S11A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer1 8"
'Set Port 1, class 2 (S11B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer2 7"
'Set Port 1, class 3 (S11C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer3 3"
'Set Port 1, class 4 (S21T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer4 4"
'Set Port 2, class 1 (S22A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer5 8"
'Set Port 2, class 2 (S22B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer6 7"
'Set Port 2, class 3 (S22C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer7 3"
'Set Port 2, class 4 (S12T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer8 4"

'Set up Standard #4 completely
'Select Standard #4; the rest of the commands act on it
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard 4"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 300KHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9GHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:DELay 1.234 ns"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 23e6"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C0 0"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C1 1"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C2 2"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C3 3"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L0 10"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L1 11"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L2 12"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L3 13"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LABel 'My Special Thru'"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:TYPE THRU"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:CHARacteristic Coax"


Setup Sweep Parameters using GPIB

This Visual Basic program sets up sweep parameters on the Channel 1 measurement.

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"
'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'Set sweep type to linear
GPIB.Write "SENSe1:SWEep:TYPE LIN"

'Set IF Bandwidth to 700 Hz
GPIB.Write "SENSe1:BANDwidth 700"

'Set Center and Span Freq's to 4 GHz
GPIB.Write "SENSe1:FREQuency:CENTer 4ghz"
GPIB.Write "SENSe1:FREQuency:SPAN 4ghz"

'Set number of points to 801
GPIB.Write "SENSe1:SWEep:POINts 801"

'Set sweep generation mode to Analog
GPIB.Write "SENSe1:SWEep:GENeration ANAL"

'Set sweep time to Automatic
GPIB.Write "SENSe1:SWEep:TIME:AUTO ON"

'Query the sweep time
GPIB.Write "SENSe1:SWEep:TIME?
SweepTime = GPIB.Read


Setup the Display using GPIB

This Visual Basic program:

  • Sets data formatting

  • Turns ON the Trace, Title, and Frequency Annotation

  • Autoscales the Trace

  • Queries Per Division, Reference Level, and Reference Position

  • Turn ON and set averaging

  • Turn ON and set smoothing

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Set the Data Format to Log Mag
GPIB.Write ":CALCulate1:FORMat MLOG"

'Turn ON the Trace, Title, and Frequency Annotation
GPIB.Write "Display:WINDow1:TRACe1:STATe ON"
GPIB.Write "DISPlay:WINDow1:TITLe:STATe ON"
GPIB.Write "DISPlay:ANNotation:FREQuency ON"

'Autoscale the Trace
GPIB.Write "Display:WINDow1:TRACe1:Y:Scale:AUTO"

'Query back the Per Division, Reference Level, and Reference Position
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:PDIVision?"
Pdiv = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RLEVel?"
Rlev = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RPOSition?"
Ppos = GPIB.Read

'Turn ON, and average five sweeps
GPIB.Write "SENSe1:AVERage:STATe ON"
GPIB.Write "SENSe1:AVERage:Count 5"

'Turn ON, and set 20% smoothing aperture
GPIB.Write "CALCulate1:SMOothing:STATe ON"
GPIB.Write "CALCulate1:SMOothing:APERture 20"


Getting and Putting Data using GPIB

This Visual Basic Program does the following:

  • Reads data from the analyzer

  • Puts the data back into memory

  • To see the data, on the analyzer after running the program, from the front panel click:

Trace - Math / Memory - Memory Trace

To run this program, you need:

  • An established GPIB interface connection

Note: To change the read and write location of data, removing the comment from the beginning of ONE of the lines, and replace the comment in the beginning of the SDATA and SMEM lines.

Private Sub ReadWrite_Click()
Dim i As Integer
Dim t As Integer
Dim q As Integer
Dim dat As String
Dim cmd As String
Dim datum() As Double

GPIB.Configure
GPIB.Write "SYSTem:PRESet;*wai"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Read the number of data points
GPIB.Write "SENSe1:SWEep:POIN?"
numpts = GPIB.Read

'Turn continuous sweep off
GPIB.Write "INITiate:CONTinuous OFF"

'Take a sweep
GPIB.Write "INITiate:IMMediate;*wai"

'Ask for the Data

'PICK ONE OF THESE TO READ
'GPIB.Write "CALCulate:DATA? FDATA" 'Formatted Meas
'GPIB.Write "CALCulate:DATA? FMEM" 'Formatted Memory
GPIB.Write "CALCulate:DATA? SDATA" 'Corrected, Complex Meas
'GPIB.Write "CALCulate:DATA? SMEM" 'Corrected, Complex Memory
'GPIB.Write "CALCulate:DATA? SCORR1" 'Error-Term Directivity

'Number of values returned per data point
'q = 1 ' Pick this if reading FDATA or FMEM
q = 2 ' Otherwise pick this

'Parse the data
ReDim datum(q, numpts)
For i = 0 To numpts - 1
  For t = 0 To q - 1
  'Read the Data
  dat = GPIB.Read(20)
  'Parse it into an array
  datum(t, i) = Val(dat)
  Next t
Next i

'PUT THE DATA BACK IN
GPIB.Write "format ascii"

'PICK ONE OF THESE LOCATIONS TO PUT THE DATA
'cmd = "CALCulate:DATA FDATA," 'Formatted Meas
'cmd = "CALCulate:DATA FMEM," 'Formatted Memory
'cmd = "CALCulate:DATA SDATA," 'Corrected, Complex Meas
cmd = "CALCulate:DATA SMEM," 'Corrected, Complex Memory
'cmd = "CALCulate:DATA SCORR1," 'Error-Term Directivity

For i = 0 To numpts - 1
  For t = 0 To q - 1
  If i = numpts - 1 And t = q - 1 Then
  cmd = cmd & Format(datum(t, i))
  Else
  cmd = cmd & Format(datum(t, i)) & ","
  End If
  Next t
Next i

GPIB.Write cmd
End Sub


Status Reporting

See Other GPIB Example Programs

Status Reporting using GPIB

This Visual Basic program demonstrates two methods of reading the analyzer's status registers:

  • Polled Bit Method - reads the Limit1 register continuously.

  • SRQ Method - enables an interupt of the program when bit 6 of the status byte is set to 1. The program then queries registers to determine if the limit line failed.

To run this program, you need:

  • An established GPIB interface connection

  • A form with two buttons: Poll and SRQMethod

  • A means of causing the limit line to fail, assuming it passes initially.

Private Sub Poll_Click()
' POLL THE BIT METHOD
' Clear status registers
GPIB.Write "*CLS"

'Loop FOREVER
Do
DoEvents
GPIB.Write "STATus:QUEStionable:LIMit1:EVENt?"
onn = GPIB.Read
Loop Until onn = 2

MsgBox "Limit 1 Failed "
End Sub

--------------------------------------------------------

Private Sub SRQMethod_Click()
'SRQ METHOD
GPIB.Write "SYSTem:PRESet"
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'slow down the trace
GPIB.Write "SENS:BWID 150"

'Setup limit line
GPIB.Write "CALC:LIM:DATA 2,3e9,6e9,-2,-2"
GPIB.Write "CALC:LIMit:DISP ON"
GPIB.Write "CALC:LIMit:STATe ON"

' Clear status registers.
GPIB.Write "*CLS;*wai"
' Clear the Service Request Enable register.
GPIB.Write "*SRE 0"
' Clear the Standard Event Status Enable register.
GPIB.Write "*ESE 0"

' Enable questionable register, bit(10) to report to the status byte.
GPIB.Write "STATus:QUEStionable:ENABle 1024"

' Enable the status byte register bit3 (weight 8) to notify controller
GPIB.Write "*SRE 8"

' Enable the onGPIBNotify event
GPIB.NotifyMask = cwGPIBRQS
GPIB.Notify
End Sub

----------------------------------------------------
Private Sub GPIB_OnGPIBNotify(ByVal mask As Integer)
' check to see what failed
' was it the analyzer?
GPIB.Write "*STB?"
onn = GPIB.Read
If onn <> 0 Then
' If yes, then was it the questionable register?
GPIB.Write "STATus:QUEStionable:EVENt?"
onn = GPIB.Read
' Determine if the limit1 register, bit 8 is set.
If onn = 1024 Then
'if yes, then was it trace 1?
GPIB.Write "STAT:QUES:LIMIT1:EVEN?"
onn = GPIB.Read
If onn = 2 Then MsgBox ("Limit Line1 Failed")
End If
End If
End Sub


GP-IB Fundamentals

GPIB Fundamentals

The General Purpose Interface Bus (GPIB) is a system of hardware and software that allows you to control test equipment to make measurements quickly,Graphical User Interface accurately, and repeatably. This topic contains the following introductory information that explains GPIBhardware and software and how they fit together.

The GPIB Hardware Components

Instruments

Addresses

Controllers

Cables

The GPIB Programming Elements

Commands

Messages

Programming Statements

Instrument Drivers

Specifications

GPIB Interface Capability Codes

Note: All of the topics related to programming assume that you already know how to program, preferably using a language that can control instruments.

The GPIB Hardware Components

The system bus and its associated interface operations are defined by the IEEE 488 standard. The following sections list and describe the main pieces of hardware in a GPIB system:

Instruments

The analyzer is configured as a Talker / Listener by default.

  • Talkers are instruments that can be addressed to send data to the controller.

  • Listeners are instruments that can be addressed to receive a command, and then respond to the command. All devices on the bus are required to listen.

GPIB Addresses

Every GPIB instrument must have its own unique address on the bus. The analyzer address (716) consists of two parts:

  • The Interface select code (typically 7) indicates which GPIB port in the system controller is used to communicate with the device.

  • The primary address (16) is set at the factory. You can change the primary address of any device on the bus to any number between 0 and 30. The analyzer address can be changed through System \ Configure \ SICL-GPIB menu

  • The secondary address is sometimes used to allow access to individual modules in a modular instrument system, such as a VXI mainframe. The analyzer does not have secondary addresses.

Controllers

Controllers specify the instruments that will be the talker and listener in a data exchange. The controller of the bus must have a GPIB interface card to communicate on the GPIB.

  • The Active Controller is the computer or instrument that is currently controlling data exchanges.

  • The System Controller is the only computer or instrument that can take control and give up control of the GPIB to another computer or instrument, which is then called the active controller. Becuase the analyzer cannot be both Talker/Listener and System Controller, you cannot have a GPIB program running on the analyzer (controller) and have the analyzer responding to commands. To accomplish this, use COM programming.

Cables

GPIB Cables are the physical link connecting all of the devices on the bus. There are eight data lines in a GPIB cable that send data from one device to another. There are also eight control lines that manage traffic on the data lines and control other interface operations.

You can connect instruments to the controller in any arrangement with the following limitations:

  • Do not connect more than 15 devices on any GPIB system. This number can be extended with the use of a bus extension.

  • Do not exceed a total of 20 meters of total cable length or 2 meters per device, whichever is less.

  • Avoid stacking more than three connectors on the back panel of an instrument. This can cause unnecessary strain on the rear-panel connector.

The GPIB Programming Elements

The following software programming elements combine to become a GPIB program:

GPIB Commands

Messages

Programming Statements

Instrument Drivers

GPIB Commands

The GPIB command is the basic unit of communication in a GPIB system. The analyzer responds to three types of GPIB commands:

  • IEEE 488.1 Bus-management Commands

  • IEEE 488.2 Common Commands

  • SCPI Commands

IEEE 488.1 Bus-management Commands

These commands are used primarily to tell some or all of the devices on the bus to perform certain interface operations.

All of the functions that can be accomplished with these commands can also be done with IEEE 488.2 or SCPI commands. Therefore, these commands are not documented in this Help system. For a complete list of IEEE 488.1 commands refer to the IEEE 488 standard.

Examples of IEEE 488.1 Commands

  • CLEAR - Clears the bus of any pending operations

  • LOCAL - Returns instruments to local operation

IEEE 488.2 Common Commands

These commands are sent to instruments to perform interface operations. An IEEE 488.2 common command consists of a single mnemonic and is preceded by an asterisk ( * ). Some of the commands have a query form which adds a "?" after the command. These commands ask the instrument for the current setting. For a complete list of the common commands that are recognized by the analyzer, see GPIB Command Finder.

Examples of IEEE 488.2 Common Commands

  • *OPC - Operation Complete

  • *RST - Reset

  • *OPT? - Queries the option configuration

SCPI Commands

The Standard Commands for Programmable Instruments (SCPI) is a set of commands developed in 1990. The standardization provided in SCPI commands helps ensure that programs written for a particular SCPI instrument are easily adapted to work with a similar SCPI instrument. SCPI commands tell instruments to do device specific functions. For example, SCPI commands could tell an instrument to make a measurement and output data to a controller.

The Rules and Syntax of SCPI Commands provides more detail of the SCPI command structure. For a complete list of the SCPI commands that are recognized by the analyzer, see GPIB Command Finder.

Example of SCPI Commands:

  • CALCULATE:AVERAGE:STATE ON

  • SENSE:FREQUENCY:START?

GPIB Messages

A message is made up of one or more GPIB commands, punctuation, data, and an appropriate termination. There are two types of messages:

  • Program messages are sent from the controller to an instrument.

  • Response messages are sent from an instrument to the controller.

Programming Statements

GPIB messages are included with the language specific I/O statements to form program statements. The programming language determines the syntax of the programming statements. GPIB programs can be written in a variety of programming languages such as VEE, HP BASIC, or C++. Because most programmers are familiar with the BASIC language, all of the programming examples in this help system use HP BASIC. To modify these examples to work with your programming language, just substitute your language I/O statements for the HP BASIC OUTPUT and ENTER statements.

The following is an example of a message included in a Visual Basic statement to form a programming statement.

GPIB.Write "SOURCE:FREQUENCY:FIXED 1000 MHz"

sets the source frequency to 1000 Megahertz.

Note about examples

Instrument Drivers

Instrument drivers are subroutines that provide routine functionality and can be reused from program to program. GPIB industry leaders have written standards for use by programmers who develop drivers. When programmers write drivers that comply with the standards, the drivers can be used with predictable results. To comply with the standard, each instrument driver must include documentation describing its functionality and how it should be implemented.

GPIB Specifications

  • Interconnected devices - Up to 15 devices (maximum) on one contiguous bus.

  • Interconnection path - Star or linear (or mixed) bus network, up to 20 meters total transmission path length or 2 meters per device, whichever is less.

  • Message transfer scheme - Byte-serial, bit-parallel, asynchronous data transfer using an interlocking 3-wire handshake.

  • Maximum data rate - 1 megabyte per second over limited distances, 250 to 500 kilobytes per second typical maximum over a full transmission path. The devices on the bus determine the actual data rate.

  • Address capability - Primary addresses, 31 Talk and 31 Listen; secondary addresses, 961 Talk and 961 Listen. There can be a maximum of 1 Talker and up to 14 Listeners at a time on a single bus. See also previous section on GPIB addresses.

GPIB Interface Capability Codes

The IEEE 488.1 standard requires that all GPIB compatible instruments display their interface capabilities on the rear panel using codes. The codes on the analyzer, and their related descriptions, are listed below:

SH1 | full source handshake capability
AH1 | full acceptor handshake capability
T6 | basic talker, serial poll, no talk only, unaddress if MLA (My Listen Address)
TEO | no extended talker capability
L4 | basic listener, no listen only, unaddress if MTA (My Talk Address)
LEO | no extended listener capability
SR1 | full service request capability
RL1 | full remote / local capability
PPO | no parallel poll capability
DC1 | full device clear capability
DT1 | full device trigger capability
C1 | system controller capability
C2 | send IFC (Interface Clear) and take charge controller capability
C3 | send REN (Remote Enable) controller capability
C4 | respond to SRQ (Service Request)


The Rules and Syntax of SCPI Commands

The Rules and Syntax of SCPI

Most of the commands used for controlling instruments on the GPIB are SCPI commands. The following sections will help you learn to use SCPI commands in your programs.

Branches on the Command Tree

Command and Query

Multiple Commands

Command Abbreviation

Bracketed (Optional) Keywords

Vertical Bars (Pipes)

MIN and MAX Parameters

Note: For background information on SCPI Commands, see GPIB Fundamentals / Commands

Branches on the Command Tree

All major functions on the analyzer are assigned keywords which are called ROOT commands. (See GPIB Command Finder for a list of SCPI root commands). Under these root commands are branches that contain one or more keywords. The branching continues until each analyzer function is assigned to a branch. A root command and the branches below it is sometimes known as a subsystem.

For example, the following graphic shows the SOURce subsystem. Under the SOURce and POWer keywords are several brach commands.

Sometimes the same keyword, such as START, is used in several branches of the command tree. To keep track of the current branch, the analyzer's command parser uses the following rules:

  • Power On and Reset - After power is cycled or after *RST, the current path is set to the root level commands.

  • Message Terminators - A message terminator, such as a <NL> character, sets the current path to the root command level. Many programming language output statements send message terminators automatically. Message terminators are described in Sending Messages to the Analyzer.

  • Colon (:) - When a colon is between two command keywords, it moves the current path down one level in the command tree. For example, the colon in :SOURCE:POWER specifies that POWER is one level below SOURCE. When the colon is the first character of a command, it specifies that the following keyword is a root level command. For example, the colon in :SOURCE specifies that source is a root level command.

Note: You can omit the leading colon if the command is the first of a new program line. For example, the following two commands are equivalent:
SOUR:POW:ATT:AUTO
:SOUR:POW:ATT:AUTO

  • <WSP> - Whitespace characters, such as <tab> and <space>, are generally ignored. There are two important exceptions:

    • Whitespace inside a keyword, such as :CALC ULATE, is not allowed.

    • You must use white space to separate parameters from commands. For example, the <WSP> between STATE and ON in the command CALCULATE:SMOOTHING:STATE ON is mandatory. Whitespace does not affect the current path.

  • Comma (,) - If a command requires more than one parameter, you must separate adjacent parameters using a comma. For example, the SYSTEM:TIME command requires three values to set the analyzer clock: one for hours, one for minutes, and one for seconds. A message to set the clock to 8:45 AM would be SYSTEM:TIME 8,45,0. Commas do not affect the current path.

  • Semicolon(;) - A semicolon separates two commands in the same message without changing the current path. See Multiple Commands later in this topic.

  • IEEE 488.2 Common Commands - Common commands, such as *RST, are not part of any subsystem. An instrument interprets them in the same way, regardless of the current path setting.

Command and Query

A SCPI command can be an Event command, Query command (a command that asks the analyzer for information), or both. The following are descriptions and examples of each form of command. GPIB Command Finder lists every SCPI command that is recognized by the analyzer, and its form.

Form | Examples
Event commands - cause an action to occur inside the analyzer. | :INITIATE:IMMEDIATE
Query commands - query only; there is no associated analyzer state to set. | :SYSTem:ERRor?
Command and query - set or query an analyzer setting. The query form appends a question mark (?) to the set form | :FORMat:DATA ! Command :FORMat:DATA? ! Query

Multiple Commands

You can send multiple commands within a single program message. By separating the commands with semicolons the current path does not change. The following examples show three methods to send two commands:

  1. Two program messages:

SOURCE:POWER:START 0DBM
SOURCE:POWER:STOP 10DBM

  2. One long message. A colon follows the semicolon that separates the two commands causing the command parser to reset to the root of the command tree. As a result, the next command is only valid if it includes the entire keyword path from the root of the tree:

SOURCE:POWER:START 0DBM;:SOURCE:POWER:STOP 10DBM

  3. One short message. The command parser keeps track of the position in the command tree. Therefore, you can simplify your program messages by including only the keyword at the same level in the command tree.

SOURCE:POWER:START 0DBM;STOP 10DBM

Common Commands and SCPI Commands

You can send Common commands and SCPI commands together in the same message. (For more information on these types of commands see GP-IB Fundamentals.) As in sending multiple SCPI commands, you must separate them with a semicolon.

Example of Common command and SCPI commands together

*RST;SENSE:FREQUENCY:CENTER 5MHZ;SPAN 100KHZ

Command Abbreviation

Each command has a long form and an abbreviated short form. The syntax used in this Help system use uppercase characters to identify the short form of a particular keyword. The remainder of the keyword is lower case to complete the long form.

SOUR - Short form
SOURce - Long form

Either the complete short form or complete long form must be used for each keyword. However, the keywords used to make a complete SCPI command can be a combination of short form and long form.

The following is unacceptable - The first three keywords use neither short or long form.

SOURc:Powe:Atten:Auto on

The following is acceptable - All keywords are either short form or long form.

SOUR:POWer:ATT:AUTO on

In addition, the analyzer accepts lowercase and uppercase characters as equivalent as shown in the following equivalent commands:

source:POW:att:auto ON
Source:Pow:Att:Auto on

Optional [Bracketed] Keywords

You can omit some keywords without changing the effect of the command. These optional, or default, keywords are used in many subsystems and are identified by brackets in syntax diagrams.

Example of Optional Keywords

The HCOPy subsystem contains the optional keyword IMMediate at its first branching point. Both of the following commands are equivalent:

"HCOPY:IMMEDIATE"
"HCOPY"

The syntax in this Help system looks like this:

HCOPy[:IMMediate]

Vertical Bars | Pipes

Vertical bars, or "pipes", can be read as "or". They are used in syntax diagrams to separate alternative parameter options.

Example of Vertical Bars:

SOURce:POWer:ATTenuation:AUTO <on|off>

Either ON or OFF is a valid parameter option.

MIN and MAX Parameters

The special form parameters "MINimum" and "MAXimum" can be used with numerous commands in the analyzer, as noted in the command documentation. The short form (min) and long form (minimum) of these two keywords are equivalent.

  • MAXimum refers to the largest value that the function can currently be set to

  • MINimum refers to the smallest value that the function can currently be set to.

For example, the following command sets the start frequency to the smallest value that is currently possible:

SENS:FREQ:START MIN

In addition, the max and min values can also be queried for these commands.

For example, the following command returns the smallest value that Start Frequency can currently be set to:

SENS:FREQ:START? MIN

An error will be returned if a numeric parameter is sent that exceeds the MAX and MIN values.

For example, the following command will return an "Out of range" error message.

SENS:FREQ:START 1khz


Getting Data from the Analyzer

Data is sent from the analyzer in response to program queries. Data can be short response messages, such as analyzer settings, or large blocks of measurement data. This topic discusses how to read query responses and measurement data from the analyzer in the most efficient manner.

Response Message Syntax

Clearing the Output Queue

Response Data Types

Numeric Data

Character Data

String Data

Block Data

Transferring Measurement Data

Note: Some PCs use a modification of the IEEE floating point formats with the byte order reversed. To reverse the byte order for data transfer into a PC, the FORMat:BORDer command should be used. See GPIB Command Finder for details.

Response Message Syntax

Responses sent from the analyzer contain data, appropriate punctuation, and message terminators.

<NL><^END> is always sent as a response message terminator. Most programming languages handle these terminators transparent to the programmer.

Response messages use commas and semicolons as separators in the following situations:

  • a comma separates response data items when a single query command returns multiple values

FORM:DATA? 'Query
ASC, +0 'Analyzer Response

  • a semicolon separates response data when multiple queries are sent within the same messages

SENS:FREQ:STAR?;STOP? --Example Query

+1.23000000E+008; +7.89000000E+008<NL><^END> 'Analyzer Response

Clearing the Output Queue

After receiving a query, the analyzer places the response message in it's output queue. Your program should read the response immediately after the query is sent. This ensures that the response is not cleared before it is read. The response is cleared when one of the following conditions occur:

  • When the query is not properly terminated with an ASCII carriage return character or the GPIB <^END> message.

  • When a second program query is sent.

  • When a program message is sent that exceeds the length of the input queue

  • When a response message generates more response data than fits in the output queue.

  • When the analyzer is switched ON.

Response Data Types

The analyzer sends different response data types depending on the parameter being queried. You need to know the type of data that will be returned so that you can declare the appropriate type of variable to accept the data. For more information on declaring variables see your programming language manual. The GPIB Command Finder lists every GPIB command and the return format of data in response to a query. The analyzer returns the following types of data:

Numeric Data

Character Data

String Data

Block Data

Numeric Data

The analyzer sends ASCII character data that looks like numeric data. All numeric data sent over the GPIB is character data.

Character Data

Character data consists of ASCII characters grouped together in mnemonics that represent specific analyzer settings. The analyzer always returns the short form of the mnemonic in upper-case alpha characters. Character data looks like string data. Therefore, refer to the GPIB Command Finder to determine the return format for every command that can be queried.

Example of Character Data

MLOG

String Data

String data consists of ASCII characters. The analyzer always encloses data in double quotes when it returns string data.

Example of String Data

GPIB.Write "DISP:WINDow:TITLe:DATA?"

“This is string response data.”

Block Data

Block data is used to transfer measurement data. Although the analyzer will accept either definite length blocks or indefinite length blocks, it always returns definite length block data in response to queries unless the specified format is ASCII. The following graphic shows the syntax for definite block data:

<num_digits> specifies how many digits are contained in <byte_count>
<byte_count> specifies how many data bytes will follow in <data bytes>

Example of Definite Block Data

#17ABC+XYZ<nl><end>

# - always sent before definite block data

1 - specifies that the byte count is one digit (7)

7 - specifies the number of data bytes that will follow, not counting <NL><END>

<NL><END> - always sent at the end of block data

Transferring Measurement Data

Measurement data is blocks of numbers that result from an analyzer measurement. Measurement data is available from various processing arrays within the analyzer. For more information on the analyzer's data processing flow, see Accessing the Data Arrays. Regardless of which measurement array is read, transferring measurement data is done the same.

When transferring measurement data, there are two data types to choose from:

  • REAL

  • ASCII

The following graphic shows the differences in transfer times between the two:

REAL Data

REAL data (also called floating-point data) types transfer faster. This is because REAL data is binary and takes about half the space of ASCII data. The disadvantage of using REAL data is that it requires a header that must be read. See definite length block data. The binary floating-point formats are defined in the IEEE 754-1985 standard. The following choices are available in REAL format:

  • REAL,32 - IEEE 32-bit format - single precision (not supported by HP BASIC)

  • REAL,64 - IEEE 64-bit format - double precision

These data types are selected using the FORMat SCPI command.

ASCII Data

The easiest and slowest way to transfer measurement data is to use ASCII data. If the data contains both numbers and characters, the setting of FORMat:DATA is ignored. ASCII data is separated by commas.


Understanding Command Synchronization

Thi s program determines which frequency contains the maximum amplitude.

GPIB.Write "ABORT; :INITIATE:IMMEDIATE"! Restart the measurement
GPIB.Write "*OPC?" 'Wait until complete
Meas_done = GPIB.Read 'Read output queue, throw away result
GPIB.Write "CALCULATE:MARKER:MAX" 'Search for max amplitude
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?
Marker_x = GPIB.Read
PRINT "MARKER at " & Marker_x & " Hz"

See Also...

Understanding Command Synchronization

The analyzer takes more time to process some commands than others:

  • Sequential commands are processed quickly and in the order in which they are received.

  • Overlapped commands take longer to process. Therefore, they allow the program to do other tasks while waiting. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

Note: The analyzer has two overlapped commands:
- INITitate:IMMediate
- SENSe:SWEep:MODE GROUPS (when INIT:CONT is ON)

The analyzer's queues store commands and responses waiting to be processed. Using the analyzer's queues and controlling the processing sequence of overlapped commands is called synchronizing the analyzer and the controller. This topic discusses how and when synchronizing should be performed.

Analyzer Queues

Input Queue

Output Queue

Error Queue

Synchronizing Overlapped Commands

Synchronization Methods

When To Synchronize

Analyzer Queues

Queues are memory buffers that store messages until they can be processed. The analyzer has the following queues:

Input Queue

Output Queue

Error Queue

Input Queue

The controller sends statements to the analyzer without regard to the amount of time required to execute the statements. The input queue is very large (31k bytes). It temporarily stores commands and queries from the controller until they are read by the analyzer's command parser. The input queue is cleared when the analyzer is switched ON.

Output Queue

When the analyzer parses a query, the response is placed in the output queue until the controller reads it. Your program should immediately read the response or it may be cleared from the output queue. The following conditions will clear a query response:

  • When a second query is sent before reading the response to the first. This does not apply when multiple queries are sent in the same statement.

  • When a program statement is sent that exceeds the length of the input queue.

  • When a response statement generates more data than fits in the output queue.

  • When the analyzer is switched ON.

Error Queue

Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Synchronizing Overlapped Commands

GPIB commands are executed and processed by the analyzer in the order they are received. Commands can be divided into two broad classes:

  • Overlapped commands generally take extended time to process by the analyzer. Examples of functions that have overlapped commands are printing and making measurements. Because they take longer to process, they allow the execution of subsequent commands while the overlapped command is still in progress. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

  • Sequential commands are generally processed quickly by the analyzer. Therefore, they prevent the processing of subsequent commands until the sequential command has been completely processed. These commands do NOT require synchronization.

Synchronization Methods

When To Synchronize

Synchronization Methods

The following common commands are used to synchronize the analyzer and controller. Examples are included that illustrate the use of each command in a program. See the SCPI command details to determine if a command is an overlapped command.

*WAI

*OPC?

*OPC

*WAI

The *WAI command:

  • Stops the analyzer from processing subsequent device commands until all overlapped commands are completed.

  • It does NOT stop the controller from sending commands to this and other devices on the bus. This is the easiest method of synchronization.

Example of the *WAI command

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "CALCULATE:MARKER:SEARCH:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?

The following timeline shows how the processing times of the three commands relate to each other:

INITIATE:IMMEDIATE is an overlapped command; it allows the immediate processing of the sequential command, CALCULATE:MARKER:SEARCH:MAXIMUM. However, the INITIATE:IMMEDIATE is not considered complete until the measurement is complete. Therefore, the marker searches for maximum amplitude before the measurement completes. The CALCULATE:MARKER:X? query could return an inaccurate value.

To solve the problem, insert a *WAI command.

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "*WAI" 'Wait until complete.
GPIB.Write "CALCULATE:MARKER:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency

The timeline now looks like this:

The *WAI command keeps the MARKER:SEARCH:MAXIMUM from taking place until the measurement is completed. The CALCULATE:MARKER:X? query returns the correct value.

Note: Although *WAI stops the analyzer from processing subsequent commands, it does not stop the controller. The controller could send commands to other devices on the bus.

*OPC?

The *OPC? query stops the controller until all pending overlapped commands are completed.

In the following example, the Read statement following the *OPC? query will not complete until the analyzer responds, which will not happen until all pending overlapped commands have finished. Therefore, the analyzer and other devices receive no subsequent commands. A "1" is placed in the analyzer output queue when the analyzer completes processing an overlapped command. The "1" in the output queue satisfies the Read command and the program continues.

Example of the *OPC? query [image] Click

*OPC

The *OPC command allows the analyzer and the controller to process commands while processing the overlapped command.

When the analyzer completes processing an overlapped command, the *OPC command sets bit 0 of the standard event register to 1 . This requires polling of status bytes or use of the service request (SRQ) capabilities of your controller. See Reading the Analyzer's Status Registers for more information about the standard event status register, generating SRQs, and handling interrupts.

Note: Be careful when sending commands to the analyzer between the time you send *OPC and the time you receive the interrupt. Some commands could jeopardize the integrity of your measurement. It also could affect how the instrument responds to the previously sent *OPC.

Example of polled bit and SRQ processes.

When To Synchronize the Analyzer and Controller

Although a command may be defined as an overlapped command, synchronization may not be required. The need to synchronize depends upon the situation in which the overlapped command is executed. The following section describes situations when synchronization is required to ensure a successful operation.

Completion of a Measurement

Measurements with External Trigger

Averaged Measurements

Completion of a Measurement

To synchronize the analyzer and controller to the completion of a measurement, use the ABORT;INITIATE:IMMEDIATE command sequence to initiate the measurement.

This command sequence forces data collection to start (or restart) under the current measurement configuration. A restart sequence, such as ABORT;INITIATE:IMMEDIATE is an overlapped command. It is complete when all operations initiated by that restart command sequence, including the measurement, are finished. The *WAI,*OPC? and *OPC commands allow you to determine when a measurement is complete. This ensures that valid measurement data is available for further processing.

Measurements with External Trigger

To use an external trigger, synchronize the analyzer and controller before the trigger is supplied to the measurement. Setup the analyzer to receive a trigger from an external source (wired to the EXTERNAL TRIGGER connector on the rear panel. The trigger system is armed by GPIB with INITIATE:IMMEDIATE. (Because the source of the trigger has been specified as external, this command "readies" the analyzer for a trigger but it does not actually generate the trigger.).

Averaged Measurements

Averaged measurements are complete when the average count is reached. The average count is reached when the specified number of individual measurements is combined into one averaged measurement result. Use synchronization to determine when the average count has been reached.

If the analyzer continues to measure and average the results after the average count is reached, use synchronization to determine when each subsequent measurement is complete.


Reading the Analyzer's Status Registers

Status Commands

Reading the Analyzer's Status Register

The analyzer has several status registers that your program can read to know when specific events occur. There are two methods of reading the status registers in the analyzer: the Polled Bit method and the Service Request method.

Polled Bit Method

Service Request Method

Setting and Reading Bits in Status Registers

Positive and Negative Transitions

Most of the status registers in the analyzer are sixteen bits. For simplicity, this topic will illustrate their use with 8-bit registers. Bits in registers represent the status of a different conditions inside of the analyzer. In the following graphic, a register is represented by a row of boxes; each box represents a bit. Bit 3 is ON.

The Polled Bit Method

With the Polled Bit Method, your program continually monitors a bit in the status register that represents the condition of interest to you. When the analyzer sets the bit to 1, your program immediately sees it and responds accordingly.

Advantage: This method requires very little programming.

Disadvantage: This method renders your program unavailable to do anything other than poll the bit of interest until the condition occurs.

Procedure:

1. Decide which condition to monitor. The Status Commands topic lists all of the possible conditions that can be monitored in the analyzer.

2. Determine the command and the bit that will monitor the command.

3. Construct a loop to poll that bit until it is set.

4. Construct the routine to respond when the bit is set.

The Service Request (SRQ) Method

Your program enables the bits in the status registers representing the condition of interest. When the condition occurs, the analyzer actively interupts your program from whatever it is doing, and an event handler in your program responds accordingly. Do this method if you have several conditions you want to monitor or the conditions are such that it is not practical to wait for the condition to occur.

Advantage: This method frees your program to do other things until the condition occurs. The program is interupted to respond to the condition.

Disadvantage: This method can require extensive programming depending on the number and type of conditions that you want to monitor.

Procedure:

1. Decide which conditions to monitor. The Status Commands topic lists all of the possible analyzer conditions that can be monitored.

2. Set the enable bits in the summary registers and the status byte register.

Enabling is like making power available to a light - without power available, the switch can be activated, but the light won't turn ON. In the analyzer, without enabling, the condition may occur, but the controller won't see it unless it is enabled.

The condition, and the bit in the summary registers in the reporting path, must be enabled. Summary This is like streams (conditions) flowing into rivers (summary registers), and rivers flowing into the ocean (controller). See the diagram of status registers in Status Commands.

Bit 6 of the status byte register is the only bit that can interrupt the controller. When any representative bit in the status byte register goes ON, bit 6 is automatically switched ON.

4. Enable your program to interupt the controller, This is done several ways depending on the programming language and GPIB interface card you use. An example program is provided showing how this is done with in Visual Basic with a National Instruments GPIB card.

5. Construct a subroutine to handle the interrupt event. If you are monitoring more than one condition in your system, your event handler must determine which condition caused the interupt. Use the *SPE command to determine the instrument that caused the interupt and then poll the summary registers, and then condition registers to determine the cause of the interupt.

Setting and Reading Bits in Status Registers

Both methods for reading status registers requires that you read bits out of the status registers. Most of the analyzers status registers contain 16 bits, numbered 0 to 15. Each bit has a weighted value. The following example shows how to set the bits in a 8-bit status register.

8-bit register

Bit | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Weight | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128

We want to set bits 4 and 5 in the Standard Event Status Enable register.

Step | Example
1. Read the weighted bit value for these bits | weights 16 and 32 (respectively)
2. Add these values together | 16 + 32 = 48
3. Send this number as an argument in the appropriate command. (see Status Commands) | STAT:QUES:LIMIT1:ENAB 1026

Positive and Negative Transitions

Transition registers control what type of in a condition register will set the corresponding bit in the event register.

  • Positive transitions (0 to 1) are only reported to the event register if the corresponding positive transition bit is set to 1.

  • Negative transitions (1 to 0) are only reported to the event register if the corresponding negative transition bit is set to 1.

  • Setting both transition bits to 1 causes both positive and negative transitions to be reported.

Transition registers are read-write and are unaffected by *CLS (clear status) or queries. They are reset to their default settings at power-up and after *RST and SYSTem:PRESet commands. The following are the default settings for the transition registers:

  • All Positive Transition registers = 1

  • All Negative Transition registers = 0

This means that by default, the analyzer will latch all event registers on the negative to positive transition (0 to 1).

The following is an example of why you would set transitions registers:

A critical measurement requires that you average 10 measurements and then restart averaging. You decide to poll the averaging bit. When averaging is complete, the bit makes a positive transition. After restart, you poll the bit to ensure that it is set back from 1 to 0, a negative transition. You set the negative transition bit for the averaging register.


COM Example Intro

Communicating with Other Applications

See the list of examples.

The analyzer’s support for DCOM (Distributed Component Object Model) over the LAN provides control of the analyzer using a variety of platforms. DCOM acts as an interface to the analyzer for external applications. With DCOM, the programmer can develop an application on an external computer. During development, the application will interface to the analyzer over the LAN through the DCOM interface. Once the developer has finished the application, it can be distributed to (installed on) the analyzer. After it has been distributed to the analyzer, the application interfaces with the analyzer using COM.

The example applications referred to in this topic were developed in a number of different programming languages to show the differences between development platforms. The table below outlines the setup parameters that the applications will use to configure the PNA network analyzer for a measurement.

Parameter | Value
Start Frequency | 1 GHz
Stop Frequency | 2 GHz
Number of Points | 11
Measurement | S 11
Data Storage Area | Uncorrected (Raw Data)
Data Format | Log Magnitude
Trigger Mode | Single
The device tested was a 50 ohm standard load on port 1 of the analyzer

You can download the example programs and obtain more detailed information for each development environment from http://agilent.com/find/pna_applications

The development environment should reference the type library associated with the PNA Series. For example, in Visual Basic, add the Agilent PNA 835x type library as a reference. This will allow the program to “see” the various classes and methods for use with the PNA Series network analyzer during development.

List of Examples

Agilent VEE Example

Microsoft Excel Example

Microsoft Visual Basic Example

Microsoft Visual Basic Script Example

Microsoft Visual C++ Example

Microsoft Word Example

National Instruments LabVIEW Example


Intro to Examples

Agilent VEE Example

Application Configuration

For this example use Agilent VEE version 6.0 or above which contains the Variant data type used to transfer data from the PNA. The type library for the PNA should be referenced in the Agilent VEE development environment.

Using the Agilent VEE Object Browser the developer can see the classes and methods which are available for development of applications for the PNA Series analyzer.

Application Code

There is a runtime version of Agilent VEE that may be used if the application has been saved as “runtime”. A free version of Agilent VEE can be found on the following web site: http://www.agilent.com/find/vee/. The application may be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


Intro to Examples

Microsoft Visual Basic Example

Application Configuration

The type library for the PNA should be referenced in the Visual Basic development environment.

Using the Visual Basic Object Browser the developer can see what classes and methods are available for development of applications for the analyzer.

Application Code

The application code is contained below. To run the application, first generate the executable file. Once this is complete, it can be copied and executed on the analyzer or run on the PC. The application can also be run from the development environment.

Option Explicit

Dim app As AgilentPNA835x.Application
Dim chan As AgilentPNA835x.Channel
Dim meas As AgilentPNA835x.Measurement
Dim result As Variant
Dim i As Integer
Dim num_points As Integer
Dim message As String

Private Sub Main()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCrLf
Next

If MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") Then
Set chan = Nothing
app.Quit
End If

End Sub


Intro to Examples

Microsoft Visual Basic Script Example

Application Configuration

Some operating systems may require that the Visual Basic Scripting engine be installed before running the application on a PC. To download a free copy of a Visual Basic Scripting engine, visit the following web site: http://msdn.microsoft.com/scripting/

Application Code

The application code is contained below. The developer must save the file in a text file (i.e. using notepad) and save it with the “.vbs” extension. The “.vbs” extension will tell the operating system to execute the code using the Visual Basic Scripting engine.

In order to run the application, double-click on the saved .vbs file. The application can be run on a PC or copied and run on the PNA Series network analyzer.

Option Explicit

' Shell objects
Dim app
Dim chan
Dim meas
Dim result
Dim message
Dim num_points
Dim i

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = 3
chan.TriggerMode = 1

' Make the PNA application
 visible
app.Visible = True
' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000)
chan.StopFrequency = (2000000000)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(0, 1)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCRLF
Next

if MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") then
Set chan = Nothing
app.quit

end if


Intro to Examples

Microsoft Visual C++ Example

Application Configuration

Microsoft Visual C++ version 6 was used for this example. In order to perform this example, create a new project in Microsoft Visual C++. Add a C++ file to the project and paste the following code into the file. The path for the type library in the code below should be changed to reference its location on the development PC.

Application Code

The application can be run on a PC or on the PNA.

#include "stdafx.h"

// import the Tsunami type library
//--------------------------
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
no_namespace, named_guids
int main(int argc, char* argv[])
{
// interface pointers to retrieve COM interfaces
IUnknown* pUnk = 0;
IApplication* pNA = 0;
IChannel* pChan = 0;
IMeasurement* pMeas = 0;
IArrayTransfer* pTrans = 0;
int i, num_points = 0;
float* pScalarData;

HRESULT hr;

// Initialize the COM subsystem
CoInitialize(NULL);

// Create an instance of the network analyzer
// Request the NA's IUnknown interface
hr = CoCreateInstance(CLSID_Application,0,
CLSCTX_ALL,IID_IUnknown, (void**) &pUnk);
if (!FAILED(hr)) {

// QueryInterface for the INetworkAnalyzer interface
of the NetworkAnalyzer object
hr = pUnk->QueryInterface(IID_IApplication,
(void**)&pNA);

if (!FAILED(hr)) {

// Reset the analyzer to instrument preset
pNA->Reset();

// Create S11 measurement
pNA->CreateSParameter(1,1,1,1);

// Set pChan variable to point to the active
channel
pNA->get_ActiveChannel(&pChan);

if (pChan) {

// Set pMeas variable to point to the active
measurement
pNA->get_ActiveMeasurement(&pMeas);

if(pMeas) {

// Setup the channel for a single trigger
pChan->Hold(true);
pNA->TriggerSignal = naTriggerManual;
pChan->TriggerMode =
naTriggerModeMeasurement;

// Make the PNA application visible
pNA->put_Visible(true);

// Set channel parameters
pChan->NumberOfPoints = 11;
pChan->StartFrequency = 1e9;
pChan->StopFrequency = 2e9;

// Send a manual trigger to initiate a single
sweep
pChan->Single(true);

// QueryInterface for the IArrayTransfer
interface of the NetworkAnalyzer object
hr = pMeas->QueryInterface(IID_IArray
Transfer, (void**)&pTrans);

if (!FAILED(hr)) {

// Store the data in the "result"
 variable
num_points = pChan->NumberOfPoints;
pScalarData = new float[num_points];
pTrans->getScalar(naRawData, naData
Format_LogMag, (long *)&num_points,
pScalarData);

// Display the result
printf("S11(dB) - Visual C++ COM
Example for PNA\n\n");
for (i = 0; i < num_points; i++)
printf("%f\n",pScalarData[i]);

}
}
}
}

pUnk->Release();
pMeas->Release();
pChan->Release();
pTrans->Release();
pNA->Release();
}
CoUninitialize();
return 0;
}


Intro to Examples

Microsoft Word Example

Application Configuration

Microsoft® Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Word documents. The type library for the PNA Series network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into a table in a Word document. To run the application, open the document using Microsoft Word. Enable the macros when prompted. Once this is complete, the application will execute and update the document. The application can be run on a PC or the analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Document_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
ThisDocument.Tables(1).Cell(i + 2, 2).Range = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


Intro to Examples

Microsoft Excel Example

Application Configuration

Microsoft Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Excel documents. The type library for the PNA network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into cells in the Excel document. The cells are then used to update a graph in the Excel document. To run the application, open the document using Microsoft Excel. Enable macros when prompted by the application. Once this is complete, the application will execute and update the document. It can be run on a PC or the PNA analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Workbook_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints 14

For i = 0 To num_points - 1
Sheet1.Cells(3 + i, 1) = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


National Instruments LabVIEW Example

Intro to Examples

National InstrumentsTM LabVIEW Example

Application Configuration

Use National Instruments™ Lab VIEW version 5.0 or above for this example. See the National Instruments™ LabVIEW documentation for information on using ActiveX objects in the LabVIEW development environment.

Application Code

National Instruments™ LabVIEW 5.0 or higher must be installed to run the application. The application can be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


GPIB using Visual C++

/*
* This example assumes the user's PC has a National Instruments GPIB
 board. The example is comprised of three basic parts:
*
* 1. Initialization
* 2. Main Body
* 3. Cleanup
*
* The Initialization portion consists of getting a handle to the
 PNA and then doing a GPIB clear of the PNA.
*
* The Main Body consists of the PNA SCPI example.
*
* The last step, Cleanup, releases the PNA for front panel control.
*/

#include <stdio.h>
#include <stdlib.h>

/*
* Include the WINDOWS.H and DECL-32.H files. The standard Windows
* header file, WINDOWS.H, contains definitions used by DECL-32.H
 and
* DECL-32.H contains prototypes for the NI GPIB routines and constants.
*/
#include <windows.h>
#include "decl-32.h"

#define ERRMSGSIZE 1024 // Maximum size of SCPI command string
#define ARRAYSIZE 1024 // Size of read buffer

#define BDINDEX 0 // Board Index of GPIB board
#define PRIMARY_ADDR_OF_PNA 16 // GPIB address of PNA
#define NO_SECONDARY_ADDR 0 // PNA has no Secondary address
#define TIMEOUT T10s // Timeout value = 10 seconds
#define EOTMODE 1 // Enable the END message
#define EOSMODE 0 // Disable the EOS mode

int pna;
char ValueStr[ARRAYSIZE + 1];
char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL",
 "EADR", "EARG",
"ESAC", "EABO", "ENEB", "EDMA",
 "",
"EOIP", "ECAP", "EFSO", "",
 "EBUS",
"ESTB", "ESRQ", "", "",
 "", "ETAB"};

void GPIBWrite(char* SCPIcmd);
char *GPIBRead(void);
void GPIBCleanup(int Dev, char* ErrorMsg);

int main()
{

char *opc;
char *result;
char *value;

/*
* =========================================
* INITIALIZATION SECTION
* =========================================
*/

/*
* The application brings the PNA online using ibdev. A device handle,pna,
 is returned and is used in all subsequent calls to the PNA.
*/
pna = ibdev(BDINDEX, PRIMARY_ADDR_OF_PNA, NO_SECONDARY_ADDR,
TIMEOUT, EOTMODE, EOSMODE);
if (ibsta & ERR)
{
printf("Unable to open handle to PNA\nibsta = 0x%x iberr =
 %d\n",
ibsta, iberr);
return 1;
}

/*
* Do a GPIB Clear of the PNA. If the error bit ERR is set in ibsta,
 call GPIBCleanup with an error message.
*/
ibclr (pna);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to perform GPIB clear of the PNA");
return 1;
}

/*
* =========================================
* MAIN BODY SECTION
* =========================================
*/

// Reset the analyzer to instrument preset
GPIBWrite("SYSTem:FPRESET");

// Create S11 measurement
GPIBWrite("CALCulate1:PARameter:DEFine 'My_S11',S11");

// Turn on Window #1
GPIBWrite("DISPlay:WINDow1:STATe ON");

// Put a trace (Trace #1) into Window #1 and 'feed' it from the
 measurement
GPIBWrite("DISPlay:WINDow1:TRACe1:FEED 'My_S11'");

// Setup the channel for single sweep trigger
GPIBWrite("INITiate1:CONTinuous OFF;*OPC?");
opc = GPIBRead();
GPIBWrite("SENSe1:SWEep:TRIGger:POINt OFF");

// Set channel parameters
GPIBWrite("SENSe1:SWEep:POINts 11");
GPIBWrite("SENSe1:FREQuency:STARt 1000000000");
GPIBWrite("SENSe1:FREQuency:STOP 2000000000");

// Send a trigger to initiate a single sweep
GPIBWrite("INITiate1;*OPC?");
opc = GPIBRead();

// Must select the measurement before we can read the data
GPIBWrite("CALCulate1:PARameter:SELect 'My_S11'");

// Read the measurement data into the "result" string
 variable
GPIBWrite("FORMat ASCII");
GPIBWrite("CALCulate1:DATA? FDATA");
result = GPIBRead();

// Print the data to the display console window
printf("S11(dB) - Visual C++ SCPI Example for PNA\n\n");
value = strtok(result, ",");
while (value != NULL)
{
printf("%s\n", value);
value = strtok(NULL, ",");
}

/*
* =========================================
* CLEANUP SECTION
* =========================================
*/

/* The PNA is returned to front panel control. */
ibonl(pna, 0);

return 0;
}

/*
* Write to the PNA
*/
void GPIBWrite(char* SCPIcmd)
{
int length;
char ErrorMsg[ERRMSGSIZE + 1];
length = strlen(SCPIcmd) ;

ibwrt (pna, SCPIcmd, length);
if (ibsta & ERR)
{
strcpy(ErrorMsg, "Unable to write this command to PNA:\n");
strcat(ErrorMsg, SCPIcmd);

GPIBCleanup(pna, ErrorMsg);
exit(1);
}
}

/*
* Read from the PNA
*/
char* GPIBRead(void)
{
ibrd (pna, ValueStr, ARRAYSIZE);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to read from the PNA");
exit(1);
}
else
return ValueStr;
}

/*
* After each GPIB call, the application checks whether the call succeeded.
 If an NI-488.2 call fails, the GPIB driver sets the corresponding bit
 in the global status variable. If the call failed, this procedure prints
 an error message, takes the PNA offline and exits.
*/
void GPIBCleanup(int Dev, char* ErrorMsg)
{
printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n",
ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);
if (Dev != -1)
{
printf("Cleanup: Returning PNA to front panel control\n");
ibonl (Dev, 0);
}
}


GPIB using Visual Basic

To run this program, you need:

  • An established GPIB interface connection

Option Explicit

Dim opc As Integer
Dim result As String
Dim i As Integer
Dim num_points As Integer
Dim commaPosition As Integer
Dim message As String
'
' Program executes when the 'Run' button is clicked.
Private Sub cmdRun_Click()
  ' National Instruments ComponentWorks 'Instr' ActiveX Control, Version 2.0.1

  ' Default board number for National Instruments GPIB boards
  GPIB.BoardNumber = 0

  ' Default GPIB address of PNA
  GPIB.PrimaryAddress = 16

  ' Initialize the GPIB connection
  GPIB.Configure

  ' Reset the analyzer to instrument preset
  GPIB.Write "SYSTem:FPRESET"

  ' Create S11 measurement
  GPIB.Write "CALCulate1:PARameter:DEFine 'My_S11',S11"

  ' Turn on Window #1
  GPIB.Write "DISPlay:WINDow1:STATe ON"

  ' Put a trace (Trace #1) into Window #1 and 'feed' it from the measurement
  GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'My_S11'"

  ' Setup the channel for single sweep trigger
  GPIB.Write "INITiate1:CONTinuous OFF;*OPC?"
  opc = GPIB.Read
  GPIB.Write "SENSe1:SWEep:TRIGger:POINt OFF"

  ' Set channel parameters
  GPIB.Write "SENSe1:SWEep:POINts 11"
  GPIB.Write "SENSe1:FREQuency:STARt 1000000000"
  GPIB.Write "SENSe1:FREQuency:STOP 2000000000"

  ' Send a trigger to initiate a single sweep
  GPIB.Write "INITiate1;*OPC?"
  opc = GPIB.Read

  ' Must select the measurement before we can read the data
  GPIB.Write "CALCulate1:PARameter:SELect 'My_S11'"

  ' Read the measurement data into the "result" string variable
  GPIB.Write "FORMat ASCII"
  GPIB.Write "CALCulate1:DATA? FDATA"
  result = GPIB.Read

  ' Display the result
  GPIB.Write "SENSe1:SWEep:POINts?"
  num_points = GPIB.Read
  For i = 0 To num_points - 2
  commaPosition = InStr(result, ",")
  message = message & Left(result, commaPosition - 1) & vbCrLf
  result = Right(result, Len(result) - commaPosition)
  Next
  message = message & result

  MsgBox message, vbOKOnly, "S11(dB) - VB SCPI Example for PNA"

End Sub
Private Sub cmdExit_Click()
  End
End Sub


COM versus SCPI

There are two methods you can use to remotely control the analyzer: COM and SCPI. The following topics are intended to help you choose the method that best meets your needs:

Software Connection

Physical Connection

Selecting a Method

Programming Languages

Software Connection

COM uses a binary protocol, allowing the user to directly invoke a feature of the Network Analyzer. This is more efficient than SCPI. For example, the following statement calls directly into the Network Analyzer, executing the routine GetIDString.

PNA.GetIDString()

SCPI is a text based instrument language. To retrieve the ID string, you would send the following text string to the network analyzer:

IbWrite( "*IDN?")

The network analyzer's SCPI parser would first decode this text string to determine that the user has asked for the network analyzer to identify itself. Then the parser would call GetIDString().

The Physical Connection

Internal Control

With either COM or SCPI, the best throughput is attained by using the analyzer's internal PC to execute your test code. However, if your test code uses too much system resources (CPU cycles and/or memory), this will slow the Analyzer's performance.

Using the SICL I/O Libraries, you can also connect to the Analyzer from a program running on the Analyzer.

External Control

You can control the analyzer from a remote PC using either COM or SCPI.

COM - (Component Object Model) can be used to access any program like the analyzer (835x.exe) or library (.dll) that exposes its features using a COM compliant object model. These programs or libraries are called "servers". Programs (like your remote program on your PC) that connect to and use the features of these servers are called "clients."

With COM, the server and the client do not need to reside on the same machine. DCOM, or distributed COM, is easy to configure and makes the location of the server transparent to the client. When you access the Analyzer from a remote computer, you are using DCOM. In this case, the mechanical transport is a LAN (local area network).

SCPI - Using a GPIB interface card in a remote computer, you can connect to the instrument using a GPIB cable. There are some constraints on the length of this cable and the number of instruments that can be daisy-chained together.

Using the Agilent SICL I/O libraries, you can connect to the instrument over a LAN connection.

(LAN or INTERNAL) You can send SCPI commands using COM with an object called the ScpiStringParser. This object provides access to the SCPI parser (or command decoder) so that you can send SCPI text commands using automation.

Selecting a Method

You should almost always choose COM for the following reasons:

  • COM executes faster most of the time.

  • COM is generally easier to use. The latest development tools embrace COM and know how to make your life easier with integrated development environments that show automation syntax as you type.

  • As time goes on, more emphasis will be put on the COM as the preferred programming paradigm. As new capability is developed, it may not be made available through SCPI.

But choosing a connection method depends on your situation. Here are some additional things to consider:

  1. If you want to use the Analyzer to control other GPIB instruments, you may want to use COM as the means of talking to the instrument. In GPIB, the analyzer can not be configured as both System Controller and talker/listener. Because the Analyzer does not support pass control mode, only one mode can be used at a time.

  2. If you have legacy code written in SCPI for another network analyzer, you may be able to leverage that code to control to the Analyzer. A word of warning: the PNA uses a different platform than previous Agilent Network Analyzers. Therefore, not all commands have a direct replacement. See the 8753 command finder.

Programming Languages

You can program the Analyzer with either COM or SCPI using several languages. The most common include:

Agilent VEE - With this language you can send text based SCPI commands and also use automation. VEE 6.0 or later is recommended.

Visual Basic - This language has great support for automation objects and can be used to drive SCPI commands. The use of VISA drivers for your GPIB hardware interface will make the task of sending SCPI commands easier.

C++ - This language can do it all. It is not as easy to use as the above two, but more flexible.


Specs

Spécifications techniques

Voir aussi...

Voici la liste complète des spécifications techniques de l'analyseur de réseau série PNA. Pour imprimer ces informations, cliquez sur ce lien afin d'accéder à une version PDF (Portable Document File).

Cliquez sur les boutons ci-après pour afficher les informations correspondantes.

Définitions

Performances système corrigées

Plage dynamique

Connecteurs Type-N

Connecteurs 3,5 mm

Performances système non corrigées

Sortie du port de test (source)

Port de test et entrée du récepteur

Informations générales

Récapitulatif de la capacité de mesure

Définitions

Toutes les spécifications et caractéristiques s'appliquent sur une plage de 25 °C ±5 °C (sauf indication contraire), 90 minutes après la mise sous tension de l'instrument.

Spécifications (spéc.) : performances garanties. Les spécifications incluent les marges de sécurité afin de tenir compte de la distribution des performances statistiques attendues, des incertitudes des mesures et des changements de performance dus aux conditions d'environnement.

Caractéristiques (car.) : paramètre de performance que le produit doit satisfaire avant de quitter l'usine, mais qui n'est ni vérifié sur le terrain, ni couvert par la garantie du produit. Une caractéristique inclut les mêmes marges de sécurité qu'une spécification.

Typique (typ.) : performances attendues d'une unité moyenne n'incluant pas les marges de sécurité. Non couvert par la garantie du produit.

Nominal (nom.) : terme générique et descriptif n'impliquant aucun niveau de performance. Non couvert par la garantie du produit.

Etalonnage : processus consistant à mesurer des étalons connus afin de caractériser les erreurs systématiques (répétitives) d'un analyseur de réseau.

Corrigé (résiduel) : indique les performances après la c orrection des e rreurs (étalonnage). Dépend de la qualité des étalons (s'ils sont "connus"), ainsi que de la répétitivité, de la stabilité et du bruit du système.

Non corrigé (brut) : indique les performances de l'instrument sans correction des erreurs. Les performances non corrigées affectent la stabilité d'un étalonnage.

Standard : s'agissant de l'analyseur, inclut toutes les options, sauf indication contraire.

Performances système corrigées

Les spécifications fournies dans cette section s'appliquent aux mesures réalisées avec l'analyseur série PNA dans les conditions suivantes :

  • Bande passante FI de 10 Hz

  • Aucun moyennage appliqué aux données

  • Température ambiante de 25 °C ±5 °C, avec moins de 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis

Plage dynamique système

Connecteurs Type-N

Connecteurs 3,5 mm

Tableau 1. Plage dynamique système

Description | Spécifications (dB) | Caractéristiques (dB)
Plage dynamiquea (au port de test)
300 kHz à 25 MHzb | 125 |
25 MHz à 3 GHzb | 128 |
3 GHz à 6 GHz | 118 |
6 GHz à 9 GHz | 113 |
Plage dynamiquec (à l'entrée du récepteur)
300 kHz à 25 MHzd |  | 140
25 MHz à 3 GHzd |  | 143
3 GHz à 6 GHz |  | 133
6 GHz à 9 GHz |  | 128

a La plage dynamique du port de test est la différence entre le seuil de bruit efficace du port de test et la puissance de sortie maximale de la source. La plage dynamique effective doit tenir compte des incertitudes des mesures et des signaux parasites.
b Peut être limitée à 100 dB à certaines fréquences inférieures à 750 MHz en raison des résidus parasites du récepteur.
c La plage dynamique de l'entrée du récepteur est la différence entre le seuil de bruit efficace du récepteur et la puissance de sortie maximale de la source. La plage dynamique effective doit tenir compte des incertitudes des mesures et des signaux parasites. Cette configuration ne doit être utilisée que si l'entrée du récepteur ne dépasse pas son niveau d'endommagement. Lorsque l'analyseur est en mode de balayage de segment, il est possible de définir des segments de fréquence avec un niveau de puissance plus élevé si la plage dynamique étendue est requise (la portion de la réponse du dispositif avec une perte d'insertion élevée) et une puissance réduite si des dommages peuvent survenir sur le récepteur (la portion de la réponse du dispositif avec une faibl e perte d'insertion).
d Peut être limitée à 115 dB à certaines fréquences inférieures à 750 MHz en raison des résidus parasites du récepteur.

Performances système corrigées avec des connecteurs Type-N

Kit d'étalonnage 85032F

Option 015 avec le kit d'étalonnage 85032F

Kit d'étalonnage 85092B

Option 015 avec le kit d'étalonnage 85092B

Tableau 2. Performances système corrigées avec des connecteurs Type-N et le kit d'étalonnage 85032F

S'applique à l'analyseur série PNA , au kit d'étalonnage 85032F (Type-N, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHz
D irectivité | 49 | 46 | 40 | 38
Adaptation de la source | 41 | 40 | 36 | 35
A daptation de la c harge | 49 | 46 | 40 | 38
Poursuite de la réflexion | ±0,011 | ±0,021 | ±0,032 | ±0,054
Poursuite de la transmission | ±0,011 | ±0,018 | ±0,040 | ±0,049

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 3. Performances système corrigées avec des connecteurs Type-N et l'option 015 avec le kit d'étalonnage 85032F

S'applique à l'analyseur série PNA avec l'option 015, au kit d'étalonnage 85032F(Type-N, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHz
Directivité | 49 | 46 | 40 | 38
Adaptation de la source | 41 | 40 | 36 | 35
Adaptation de la charge | 49 | 46 | 40 | 38
Poursuite de la réflexion | ±0,011 | ±0,021 | ±0,032 | ±0,054
Poursuite de la transmission | ±0,011 | ±0,023 | ±0,050 | ±0,062

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 4. Performances système corrigées avec des connecteurs Type-N et le module d'étalonnage électronique 85092B

S'applique à l'analyseur série PNA, au module d'étalonnage électronique (ECal) 85092B (Type-N, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHza
Directivité | 52 | 54 | 52 | 47
Adaptation de la source | 45 | 44 | 41 | 34
Adaptation de la charge | 47 | 47 | 44 | 44
Poursuite de la réflexion | ±0,037 | ±0,037 | ±0,068 | ±0,100
Poursuite de la transmission | ±0,060 | ±0,055 | ±0,13 | ±0,23
Poursuite de la transmission typique | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Spécifications basées sur 28 % d'humidité. Des niveaux d'humidité supérieurs risqueraient d'altérer les performances.

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 5. Performances système corrigées avec des connecteurs Type-N et l'option 015 avec le module d'étalonnage électronique 85092B

S'applique à l'analyseur série PNA avec l'option 015, au module d'étalonnage électronique (ECal) 85092B(Type-N, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHza
Directivité | 52 | 54 | 52 | 47
Adaptation de la source | 45 | 44 | 41 | 34
Adaptation de la charge | 47 | 47 | 44 | 39
Poursuite de la réflexion | ±0,037 | ±0,037 | ±0,068 | ±0,100
Poursuite de la transmission | ±0,060 | ±0,055 | ±0,13 | ±0,23
Poursuite de la transmission typique | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Spécifications basées sur 28 % d'humidité. Des niveaux d'humidité supérieurs risqueraient d'altérer les performances.

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Performances système corrigées avec des connecteurs de 3,5 mm

Kit d'étalonnage 85033E

Option 015 avec kit d'étalonnage 85033E

Kit d'étalonnage 85093B

Option 015 avec kit d'étalonnage 85093B

Tableau 6. Performances système corrigées avec un connecteur de 3,5 mm et le kit d'étalonnage 85033E

S'applique à l'analyseur série PNA, au kit d'étalonnage 85033E(3,5 mm, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHz
Directivité | 46 | 44 | 38 | 38
Adaptation de la source | 43 | 40 | 37 | 36
Adaptation de la charge | 46 | 44 | 38 | 38
Poursuite de la réflexion | ±0,006 | ±0,007 | ±0,009 | ±0,010
Poursuite de la transmission | ±0,010 | ±0,020 | ±0,041 | ±0,046

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 7. Performances système corrigées avec un connecteur de 3,5 mm et l'option 015 avec le kit d'étalonnage 85033E

S'applique à l'analyseur série PNA avec l'option 015, au kit d'étalonnage 85033E (3,5 mm, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHz
Directivité | 46 | 44 | 38 | 38
Adaptation de la source | 43 | 40 | 37 | 36
Adaptation de la charge | 46 | 44 | 38 | 38
Poursuite de la réflexion | ±0,006 | ±0,007 | ±0,009 | ±0,010
Poursuite de la transmission | ±0,010 | ±0,025 | ±0,052 | ±0,058

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 8. Performances système corrigées avec un connecteur de 3,5 mm et le module d'étalonnage électronique 85093B

S'applique à l'analyseur série PNA, au module d'étalonnage électronique (ECal) 85093B(3,5 mm, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHza
Directivité | 50 | 52 | 51 | 45
Adaptation de la source | 45 | 43 | 40 | 34
Adaptation de la charge | 47 | 47 | 44 | 39
Poursuite de la réflexion | ±0,043 | ±0,043 | ±0,055 | ±0,100
Poursuite de la transmission | ±0,050 | ±0,045 | ±0,13 | ±0,23
Poursuite de la transmission typique | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Spécifications basées sur 28 % d'humidité. Des niveaux d'humidité supérieurs risqueraient d'altérer les performances.

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 9. Performances système corrigées avec un connecteur de 3,5 mm et l'option 015 avec le module d'étalonnage électronique 85093B

S'applique à l'analyseur série PNA avec l'option 015, au module d'étalonnage électronique (ECal) 85093B (3,5 mm, 50 W), au câble du port de test N6314A et à un étalonnage complet sur deux ports. S'applique également dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Aucun moyennage ap pliqué aux données

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

  • Etalonnage d'isolement non omis
Description | Spécifications (dB)
 | 300 kHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHza
D irectivité | 50 | 52 | 51 | 45
Adaptation de la source | 45 | 43 | 40 | 34
A daptation de la c harge | 47 | 47 | 44 | 39
Poursuite de la réflexion | ±0,043 | ±0,043 | ±0,055 | ±0,100
Poursuite de la transmission | ±0,050 | ±0,045 | ±0,13 | ±0,23
Poursuite de la transmission typique | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Spécifications basées sur 28 % d'humidité. Des niveaux d'humidité supérieurs risqueraient d'altérer les performances.

Cliquez sur une courbe pour l'agrandir.

Incertitude de la transmission (spécification)

Incertitude de la réflexion (spécification)

Tableau 10. Performances système non corrigées

Description | Spécifications (dB)
 | 300 kHz à 1 MHz | 1MHz à 1,3 GHz | 1,3 GHz à 3 GHz | 3 à 6 GHz | 6 à 9 GHz
Directivité | 30 | 33 | 27 | 20 | 13
Adaptation de la source | 20 | 20 | 17 | 15 | 14
Adaptation de la source (Opt. 015) | 20 | 20 | 15 | 13 | 12
Adaptation de la charge | 20 | 20 | 17 | 15 | 15
Adaptation de la charge (Opt. 015) | 20 | 20 | 15 | 13 | 13
Poursuite de la réflexion | ±1,5 | ±1,5 | ±1,5 | ±2,5 | ±3,0
Poursuite de la transmission | ±1,5 | ±1,5 | ±1,5 | ±2,5 | ±3,0

Caractéristiques de la sortie du port de test (source)

Fréquence de sortie

Puissance de sortie

Pureté du signal de sortie

Tableau 11. Fréquence de sortie du port de test

Description | Spécifications | Informations supplémentaires
Plage E8356A E8357A E8358A Résolution | 300 kHz à 3,0 GHz 300 kHz à 6,0 GHz 300 kHz à 9,0 GHz 1 Hz |
Stabilité de la source |  | ±1 ppm, 0° à 40 °C, typique ±0,2 ppm/an, typique
Précision CW | ±1 ppm |

Tableau 12. Puissance de sortie du port de testa

Description | Spécifications | Informations supplémentaires
Précision du niveau 300 kHz à 6 GHz 6 GHz à 9 GHz | ±1,0 dB ±2,0 dB | Ecart de 0 dBm dans la plage de puissance 0 (atténuateur par paliers à 0 dB) ±1,5 dB sous 10 MHz
Linéarité du niveau 300 kHz à 9 GHz 300 kHz à 1 MHz 1 MHz à 6 GHz | ±0,3 dB ±1,0 dB ±0,5 dB | Ecart de 0 dBm dans la plage de puissance 0 -15 à +5 dBm +5 à +10 dBm +5 à +10 dBm
Plageb 300 kHz à 6 GHz 6 GHz à 9 GHz | 85 à +10 dBm 85 à +5 dBm |
Plage de balayage 300 kHz à 6 GHz 6 GHz à 9 GHz | 25 dB 20 dB |
Résolution du niveau | 0,01 dB |

a Performance de sortie de la source sur le port 1 uniquement. La performance de sortie sur le port 2 est une caractéristique.

b Puissance à laquelle la source peut être définie et le verrouillage de phase est assuré.

Tableau 1 3. Pureté du signal de sortie du port de test

Description | Spécifications | Informations supplémentaires
Harmoniques (deuxièmes ou troisièmes) à la puissance de sortie max. à une sortie de 0 dBm à une sortie de 10 dBm |  | < 25 dBc, caractéristiquea < 35 dBc, typique, dans la plage de puissance 0 < 38 dBc, typique, dans la plage de puissance 0 (atténuateur par paliers à 0 dB)
Parasite non harmonique à la sortie max. à une sortie de 10 dBm |  | 30 dBc, typique pour une fréquence décalée > 1 kHz 50 dBc, typique pour une fréquence décalée > 1 kHz

a Typique sous 25 MHz.

Caractéristiques du port de test et de l'entrée du récepteur

Niveaux d'entrée

Seuil de bruit

Bruit de la trace

Niveau de référence et stabilité

Précision dynamique

Temps de propagation de groupe

Tableau 1 4. Niveaux d'entrée du port de test

Description | Spécifications | Informations supplémentaires
Niveau d'entrée maximal du port de test
300 kHz à 25 MHz 25 MHz à 3 GHz 3 GHz à 6 GHz 6 GHz à 9 GHz | +10 dBm +10 dBm +10 dBm +5 dBm | compression < 0,6 dB compression < 0,4 dB compression < 0,7 dB compression < 0,7 dB
Niveau d'endommagement
Port de test 1, 2 R1, R2 IN A, B IN (standard) A, B IN (Opt. 015) Coupleur IN (Opt. 015) |  | +30 dBm ou ±30 VCC, typ. +15 dBm ou ±15 VCC, typ. +15 dBm ou ±15 VCC, typ. +15 dBm ou ±0 VCC, typ. +36 dBm ou ±25 VCC, typ.
Seuil de bruit du port de testa
300 kHz à 25 MHzb Bande passante FI de 10 Hz Bande passante FI de 1 kHz | £ 115 dBm £ 95 dBm |
25 MHz à 3 GHzb Bande passante FI de 10 Hz Bande passante FI de 1 kHz | £ 118 dBm £ 98 dBm |
3 GHz à 9 GHz Bande passante FI de 10 Hz Bande passante FI de 1 kHz | £ 108 dBm £ 88 dBm |
Seuil de bruit du récepteura
300 kHz à 25 MHzc Bande passante FI de 10 Hz Bande passante FI de 1 kHz |  | £ 130 dBm, caractéristique £ 110 dBm, caractéristique
25 MHz à 3 GHzc Bande passante FI de 10 Hz Bande passante FI de 1 kHz |  | £ 133 dBm, caractéristique £ 113 dBm, caractéristique
6 GHz à 9 GHz Bande passante FI de 10 Hz Bande passante FI de 1 kHz |  | £ 123 dBm, caractéristique £ 103 dBm, caractéristique
Diaphonie
300 kHz à 1 MHz 1 MHz à 25 MHz 25 MHz à 3 GHz 3 GHz à 6 GHz 6 GHz à 9 GHz | <120 dB <125 dB <128 dB <118 dB <113 dB | Entre les ports de test 1 et 2, avec des courts circuits aux deux ports ;
Niveau d'entrée du récepteur maximum (A, B, R1, R2)
300 kHz à 6 GHz 6 GHz à 9 GHz |  | 6 dBm, typique 11 dBm, typique
Niveau d'entrée de référence (R1, R2)d
300 kHz à 9 GHz |  | 10 à 35 dBm, typique
Niveau d'entrée du coupleur maximum (Opt 015)
300 kHz à 9 GHz |  | +33 dBm, typique

a Valeur efficace d'une trace d'amplitude linéaire exprimée en dBm.

b Peut être limité à -90 dBm à certaines fréquences inférieures à 750 MHz en raison des résidus parasites du récepteur.

c Peut être limité à -105 dBm à certaines fréquences inférieures à 750 MHz en raison des résidus parasites du récepteur.

d Niveau d'entrée pour maintenir le verrouillage de phase.

Tableau 1 5. Entrée du port de test (bruit de la trace)

Description | Spécifications | Informations supplémentaires
Amplitude du bruit de la tracea
Bande passante FI de 1 kHz Bande passante FI de 10 kHz | < 0,002 dB rms < 0,005 dB rms |
Phase du bruit de la tracea
Bande passante FI de 1 kHz Bande passante FI de 10 kHz | < 0,010° rms < 0,035° rms |

aLe bruit de la trace est la mesure du rapport d'une réflexion directe ou complète avec la source définie à 0 dBm.

Tableau 1 6. Entrée du port de test (niveau de référence et stabilité)

Description | Spécifications | Informations supplémentaires
Amplitude du niveau de référence
Résolution de la gamme | ±200 dB 0,001 dB |
Phase du niveau de référence
Résolution de la gamme | ±500° 0,01° |
Stabilité de l'amplitudea
300 kHz à 3 GHz 3 GHz à 6 GHz 6 GHz à 9 GHz |  | 0,02 dB/°C, typique 0,04 dB/°C, typique 0,06 dB/°C, typique
Stabilité de la phasea
300 kHz à 3 GHz 3 GHz à 6 GHz 6 GHz à 9 GHz |  | 0,2°/°C, typique 0,3°/°C, typique 0,6°/°C, typique

aLa stabilité est la mesure du rapport au port de test.

Tableau 1 7. Entrée du port de test (précision dynamique)

La précision de la lecture de la puissance d'entrée du port de test est relative au niveau de la puissance d'entrée de la référence. S'applique aux ports d'entrée 1 et 2 dans les conditions suivantes :

  • Bande passante FI = 10 Hz

  • Température ambiante de 25° ±5 °C, avec < 1 °C d'écart par rapport à la température d'étalonnage

Cliquez sur une courbe pour l'agrandir.

Spécifications 300 kHz à 3 GHz | Caractéristiques 300 kHz à 3 GHz
300 kHz à 6 GHz | 300 kHz à 6 GHz
300 kHz à 9 GHz | 300 kHz à 9 GHz

Tableau 1 8. Entrée du port de test (temps de propagation de groupe)a

Description

Spécifications

Informations supplémentaires

O uverture (sélectionnable)

(bande d'analyse)/(nombre de points 1)

Ouverture maximale

20 % de la bande d'analyse

Plage

0,5 x (1/ouverture minimale)

Retard maximal

Limité à une mesure sur moins de 180° du déphasage dans l'ouverture minimale.)

Précision

Voir le graphique ci-dessous. Car.

Le graphique ci-après montre la précision du temps de propagation de groupe avec un étalonnage complet sur deux ports type-N et une bande passante FI de 10 Hz. On suppose que la perte d'insertion est < 2 dB et que la longueur électrique est de dix mètres.

Cliquez sur la courbe pour l'agrandir.

En général, la formule ci-après peut être utilisée afin de déterminer la précision, en secondes, d'une mesure du temps de propagation de groupe spécifique :

±Précision de la phase (deg)/[360 × Ouverture (Hz)]

En fonction de l'ouverture et de la longueur du composant, la précision de la phase utilisée est soit la précision de la phase incrémentielle, soit la précision de la phase dans le cas le plus défavorable.

a Le temps de propagation de groupe est calculé en mesurant le déphasage dans un palier de fréquence spécifié (déterminé par la bande d'analyse et le nombre de points par balayage).

Informations générales

Bandes passantes système

Face avant

Face arrière

Environnement et dimensions

Tableau 1 9. Bandes passantes système

Description | Spécifications | Informations supplémentaires
Réglages de la bande passante FI
Plage |  | 1 Hz à 40 kHz Les réglages nominaux sont : 1, 2, 3, 5, 7,10, 15, 20, 30, 50, 70, 100, 150, 200, 300, 500, 700 Hz 1k, 1,5k, 2k 3k, 5k, 7k, 10k, 15k, 20k, 30k, 50k, 35k, 40kHz

Tableau 20. Informations sur la face avant

Description | Informations supplémentaires
Connecteurs RF
Type | Type-N, femelle ; 50 W, nominal
Saillie de la broche centrale | 0,52 à 0,53 cm, caractéristique
Puissance de la sonde
Connecteur | Connecteur à 3 broches, mâle
Alimentation positive | +15 VCC ±2 %, 400 mA, max, caractéristique
Alimentation négative | 12,6 VCC ±5 %, 300 mA, max, caractéristique
Ecran
Taille | Ecran couleur à cristaux liquides avec matrice active et diagonale de visualisation de 21,3 cm ; résolution de 640 (horizontale) X 480 (verticale)
Taux de rafraîchissement | Vertical 59,83 Hz ; Horizontal 31,41 Hz
Plage d'affichage
Amplitude | ±200 dB (à 20 dB/div), max
Phase | ±180°, max
Polarité | 10 pUnités, min 1000 unités, max
Résolution de l'écran
Amplitude | 0,001 dB/div, min
Phase | 0,01°/div, min
Résolution du marqueur
Amplitude | 0,001 dB, min
Phase | 0,01°, min
Polarité | 0,01 mUnité, min ; 0,01°, min

Tableau 21. Informations sur la face avant

Description | Informations supplémentaires
Entrée de polarisation du port de test
Connecteur | BNC, femelle
Tension maximale | ±30 VCC, typique
Courant maximal (aucune dégradation des spécifications RF) | ±200 mA, typique
Courant maximal | ±1 A, typique
Entrée de la référence de 10 MHz
Connecteur | BNC, femelle
Fréquence d'entrée | 10 MHz ± 1 ppm, typique
Niveau d'entrée | 15 dBm à +20 dBm, typique
I mpédance d'entrée | 200 W, nom.
Sortie de la référence de 10 MHz
Connecteur | BNC, femelle
Fréquence de sortiew | 10 MHz ± 1 ppm, typique
Type de signal | Onde sinusoïdale, typique
Niveau de la sortie | +10 dBm ± 4 dB à 50 W, typique
Impédance de la sortie | 50 W, nominal
Harmoniques | <40 dBc, typique
Sortie vidéo VGA
Connecteur | Mini-connecteur D-Sub 15 broches ; écrans compatibles Drives VGA
Périphériques pris en charge Ecran plat (TFT) Ecran plat (DSTN) Ecran à tube cathodique | Résolutions 1024 X 768, 800 X 600, 640 X 480 800 X 600, 640 X 480 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480 Il est possible d'utiliser simultanément l'écran interne et l'écran externe, mais uniquement avec une résolution de 640 X 480. Si vous changez la résolution, vous ne pourrez utiliser que l'écran externe (l'écran interne s'éteindra).
GPIB | Connecteur D-Sub 24 broches (Type D-24), femelle ; compatible IEEE-488.
Port parallèle (LPT1) | Connecteur D-Sub 36 broches (Type 1284-C), femelle ; permet de connecter des imprimantes ou d'autres périphériques ayant un port parallèle
Port série (COM 1) | Connecteur D-Sub 9 broches, mâle ; compatible RS-232
Port USB
Contact 1 Contact 2 Contact 3 Contact 4 | Fiche Universal Serial Bus, configuration Type A (4 contacts en ligne, contact 1 sur la gauche) ; femelle Vcc : 4,75 à 5,25 VCC, 500 mA, maximum -Données +Données Masse
LAN | Ethernet 10/100BaseT, configuration à 8 broches ; sélection automatique de l'un des deux débits de données
Alimentationa
Fréquence | 48 Hz à 66 Hz
Tension pour le réglage 115 V | 90 à 132 VCA ; 120 VCA, nominal
Tension pour le réglage 220 V | 198 à 264 VCA ; 240 VCA, nominal
VA Max | 600 VA max.

a Un fil de masse est requis.

Tableau 22. Informations sur la face arrière

Description | Informations supplémentaires
Entrée AM externe
Description | L'entrée fournit la modulation AM basse fréquence au signal de sortie du port de test ou décale la sortie du port de test. Une entrée de zéro volt fournit le niveau de puissance défini par l'instrument, une tension positive fournit un niveau supérieur et une tension négative fournit un niveau inférieur.
Connecteur | BNC, femelle
Sensibilité de l'entrée | 8 dB/volt, typique
Bande passante | 1 kHz, typique
Impédance de l'entrée | 1 kW, typique
Entrée du détecteur externe
Description | L'entrée d'un détecteur externe avec une diode à polarité négative fournit l'ALC pour un port de test éloigné de la face avant de l'instrument
Connecteur | BNC, femelle
Sensibilité de l'entrée | 500 mV correspond à environ 3 dBm à l'entrée du détecteur, typique
Bande passante | 50 kHz, typique
Impédance de l'entrée | 1 kW, typique
Déclenchement externe
 | Voir Déclenchement

Tableau 2 3. Environnement et dimensions de l'analyseur

Description | Informations supplémentaires
Informations générales sur l'environnement
Susceptibilité RFI/EMI | Définie par CISPR Pub. 11, Groupe 1, Classe A et CEI 50082-1
ESD | Minimise l'application de procédures de travail anti-statiques et l'emploi d'un tapis anti-statique
Poussières | Minimise pour une fiabilité optimale
Environnement de fonctionnement
Température | 0 °C à +40 °C L'instrument se met sous tension, effectue un verrouillage de phase et n'affiche aucun message d'erreur dans cette plage de températures.
Plage de températures avec correction des erreurs | 25°C ± 5°C avec moins de 1°C d'écart par rapport à la température d'étalonnage.
Humidité | 5 % à 95 % à +40 °C
Altitude | 0 à 4500 m
Environnement de stockage hors fonctionnement
Température | -40 °C à +70 °C
Humidité | 0 % à 90 % à +65 °C (sans condensation)
Altitude | 0 à 15 240 m
Dimensions du boîtier
Hauteur x Largeur x Profondeur | 222 x 425 x 426 mm, nominal. Les dimensions du boîtier ne tiennent pas compte des saillies avant et arrière.
Poids
Net | 24 kg, nominal
Livraison | 32 kg, nominal

Récapitulatif de la capacité de mesure

Temps de cycle typique pour la réalisation d'une mesure

Temps de cycle avec changements de la bande passante FI

Temps de cycle avec changements du nombre de points

Temps de transfert de données

Rappel et vitesse de balayage

Tableau 2 4. Temps de cy cle typique a,b (ms)

 | Nombre de points
 | 51 | 201 | 401 | 1601
Début 800 MHz, fin 1000 MHz, bande passante FI de 35 kHz
Non corrigé, étalonnage sur un port | 6 | 10 | 17 | 53
Etalonnage sur deux ports | 18 | 27 | 39 | 113
Début 300 kHz, fin 3 GHz, bande passante FI de 35 kHz
Non corrigé, étalonnage sur un port | 32 | 43 | 52 | 93
Etalonnage sur deux ports | 73 | 97 | 117 | 201
Début 300 kHz, fin 6 GHz, bande passante FI de 35 kHz
Non corrigé, étalonnage sur un port | 40 | 50 | 57 | 98
Etalonnage sur deux ports | 88 | 109 | 125 | 210
Début 300 kHz, fin 9 GHz, bande passante FI de 35 kHz
Non corrigé, étalonnage sur un port | 45 | 55 | 61 | 99
Etalonnage sur deux ports | 99 | 119 | 133 | 212
Domaine temporelc (augmente sur le temps de balayage non corrigé)
Conversions | <1 | <1 | 4 | 13
Sélection par porte | <1 | <1 | 4 | 17

a Performances typiques.
b Inclut le temps de balayage, le temps de retraçage et le temps de croisement de bande. Ecran de l'analyseur allumé avec
DISPLAY:ENABLE OFF. Ajouter 21 ms si l'écran est allumé. Données pour une mesure de trace (S11).
c Option 010 seulement. Ecran de l'analyseur éteint avec DISPLAY:ENABLE OFF. Ajouter 21 ms si l'écran est allumé. Données pour
une mesure de trace (S11).

Tableau 2 5. Temps de cycle et bande passante FIa

S'applique à la condition prédéfinie (201 p oints, sans correction) à l'exception des changements suivants :

  • CF = 1 GHz

  • Bande d'analyse = 100 MHz

  • Ecran éteint (ajouter 21 ms si l'écran est allumé)
Bande passante FI (Hz) | Temps de cycle (ms)b
40 000 | 8
35 000 | 9
30 000 | 11
20 000 | 13
10 000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Performances typiques.
b Le temps de cycle inclut le temps de balayage et de retraçage.

Tableau 26. Temps de cycle et nombre de pointsa

S'applique à la condition prédéfinie (bande passante FI de 35 kHz, sans correction) à l'exception des changements suivants :

  • CF = 1 GHz

  • Bande d'analyse = 100 MHz

  • Ecran éteint (ajouter 21 ms si l'écran est allumé)
Nombre de points | Temps de cycle (ms)b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Performances typiques.
b Le temps de cycle inclut le temps de balayage et de retraçage.

Tableau 27. Temps de transfert de donnéesa(ms)

 | Nombre de points
 | 51 | 201 | 401 | 1601
SCPI sur GPIB (programme exécuté sur un PC externe)b
32 bits en virgule flottante | 4 | 7 | 13 | 41
64 bits en virgule flottante | 7 | 14 | 24 | 81
ASCII | 25 | 98 | 189 | 804
SCPI sur LAN 10 Mbit/s (programme exécuté sur un PC externe)b
32 bits en virgule flottante | 5 | 6 | 8 | 21
64 bits en virgule flottante | 5 | 9 | 22 | 38
ASCII | 18 | 53 | 98 | 362
SCPI sur LAN 100 Mbit/s (programme exécuté sur un PC externe)c
32 bits en virgule flottante | 3 | 5 | 6 | 12
64 bits en virgule flottante | 4 | 6 | 9 | 20
ASCII | 17 | 51 | 92 | 339
SCPI (programme exécuté dans l'analyseur)d
32 bits en virgule flottante | 2 | 3 | 4 | 7
64 bits en virgule flottante | 4 | 5 | 6 | 15
ASCII | 26 | 99 | 198 | 781
COM (programme exécuté dans l'analyseur)e
32 bits en virgule flottante | 1 | 1 | 1 | 2
Type de variable | 1 | 3 | 4 | 19
DCOM sur LAN 10 Mbit/s (programme exécuté sur un PC externe)f
32 bits en virgule flottante | 2 | 3 | 5 | 14
Type de variable | 5 | 14 | 26 | 100
DCOM sur LAN 100 Mbit/s (programme exécuté sur un PC externe)f
32 bits en virgule flottante | 2 | 2 | 2 | 4
Type de variable | 3 | 5 | 9 | 35

a Performances typiques.
b Mesuré à l'aide d'un programme VEE 5.0 exécuté sur un HP Kayak cadencé à 600 MHz, carte GPIB National InstrumentsTM.
Données S11 complexes transférées avec "CALC:DATA?SDATA".
c Mesuré à l'aide d'un programme VEE 5.0 exécuté sur un HP Kayak cadencé à 600 MHz. Données S11 complexes transférées
avec "CALC:DATA?SDATA". Vitesse variable en fonction du trafic sur le LAN, si l'analyseur est connecté au réseau.
d Mesuré à l'aide d'un programme VEE 5.0 exécuté sur l'analyseur PNA Series. Données S11 complexes transférées
avec "CALC:DATA?SDATA".
e Mesuré à l'aide d'un programme Visual Basic 6.0 exécuté sur l'analyseur PNA Series. Données S11 complexes
transférées.

f Mesuré à l'aide d'un programme Visual Basic 6.0 exécuté sur un HP Kayak cadencé à 600 MHz. Données S11 complexes
transférées. Vitesse variable en fonction du trafic sur le LAN, si l'analyseur est connecté au réseau.

g Méthode IArray Transfer.getComplex utilisée pour une configuration 32 bits en virgule flottante.

h Méthode meas.getData utilisée pour le type de données variable.

Tableau 28. Rappel et vitesse de balayage

Opérations | Nombre de fenêtres | Nombre de traces | Temps de rappel (ms)
Rappel | 1 | 1 | 140
Rappel et balayage | 1 | 1 | 198
Rappel | 1 | 2 | 259
Rappel et balayage | 1 | 2 | 341
Rappel | 1 | 4 | 588
Rappel et balayage | 1 | 4 | 723
Rappel | 2 | 2 | 282
Rappel et balayage | 2 | 2 | 373
Rappel | 3 | 4 | 610
Rappel et balayage | 3 | 4 | 788
Rappel | 4 | 4 | 613
Rappel et balayage | 4 | 4 | 790
Rappel | 4 | 8 | 1236
Rappel et balayage | 4 | 8 | 1463


Resources

Autres ressources

Voir aussi...

Les ressources d'analyse de réseau ci-après sont également disponibles.

Ressources documentaires

Ressources de fournisseurs tiers

Ressources documentaires

Notes d'application

Vous pouvez accéder à la plupart des notes d'application mentionnées ci-dessous à partir de l'analyseur.

  1. Dans le menu Help, cliquez sur Product Overview.

  2. La partie Product Overview fournit une présentation. Pour passer outre, cliquez sur Main Menu.

  3. Dans le menu principal, cliquez sur Literature, puis sur un titre pour afficher le document corrspondant.

Vous pouvez également accéder à l'intégralité des notes d'application et de produit ci-après à l'URL suivante :

http://www.agilent.com/find/PNA

  • Application Development with the Agilent PNA Series of Network Analyzers, (référence 5980-2666ENUS).

  • Understanding and Improving Network Analyzer Dynamic Range, note d'application Agilent 1363-1 (référence 5980-2778EN).

  • The "Need for Speed" in Component Manufacturing Test, (référence 5980-2783EN).

  • Generate Component Data Sheets with Agilent's BenchLinkXL, (référence 5980-2781EN).

  • Connectivity Advances in a LAN-enabled Instument, (référence 5980-2782EN).

  • De-embedding and Embedding S-Parameter Networks Using the PNA Series Network Analyzer, note d'application Agilent 1364-1 (référence 5980-2784EN).

  • Advanced Filter Tuning Using TIme Domain, note d'application Agilent 1287-10 (référence 5980-2785EN).

  • Understanding the Fundamental Principles of Vector Network Analysis, note d'application Agilent 1287-1 (référence 5965-7707E).

  • Exploring the Architectures of Network Analyzers, note d'application Agilent 1287-2 (référence 5965-7708E).

  • ApplyingError Correctionto Network Analyzer Measurements, note d'application Agilent 1287-3 (référence 5965-7709E).

  • Network Analyzer Measurements: Filter and Amplifier Examples, note d'application Agilent 1287-4 (référence Agilent 5965-7710E).

  • Improving Throughput in Network Analyzer Applications, note d'application Agilent 1287-5 (référence5966-3317E)

  • Using a Network Analyzer to Characterize High-Power Components, note d'application Agilent 1287-6 (référence5966-3319E)

  • Simplified Filter Tuning Using Time-Domain Analysis, note d'application Agilent 1287-8 (référence 5968-5328E).

  • In-Fixture Measurements Using Vector Network Analysis, note d'application Agilent 1287-9 (référence 5968-5329E).

  • 8 Hints for Making Better Network Analyzer Measurements, note d'application Agilent AN 1291-1 (référence5965-8166E)

  • Specifying Calibration Standards for the Agilent 8510 Network Analyzer, note de produit Agilent 8510-5A, (référence 5956-4352 ou numéro de nomenclature Agilent 08510-90352, février 1988).

  • In-Fixture Microstrip Device Measurements Using TRL* Calibration, note de produit Agilent 8720-2, (référence 5091-1943E, août 1991).

Ressources des fournisseurs tiers

Pour plus d'informations sur les montures de test et les manipulateurs de composants, contactez :

Inter-Continental Microwave
1515 Wyatt Drive
Santa Clara, CA 95054-1524 Etats-Unis
Téléphone : (408) 727-1596
Fax : (408) 727-0105
Site Web : www.icmicrowave.com
Adresse e-mail : icmfixture@aol.com

Pour plus d'informations sur les équipements et les accessoires de contrôle électrique, contactez :

Cascade Microtech, Inc.
2430 NW 206th Avenue
Beaverton, OR 97006 Etats-Unis
Téléphone : (503) 601-1000
Fax : (503) 601-1002
Site Web : www.cascademicrotech.com
Adresse e-mail : sales@cmicro.com

Pour plus d'informations sur les mesures symétriques et multiports, contactez :

ATN Microwave, Inc.
85 Rangeway Road
N. Billerica, MA 01862-2105 Etats-Unis
Téléphone : (978) 667-4200
Fax : (978) 667-8548
Site Web : www.atnmicrowave.com


Options

Options de l'analyseur

Voir aussi ...

Une souris, un clavier, un CD-ROM contenant une copie de l'ensemble des manuels d'utilisation et de programmation, un adapteur mini-parallèle-parallèle et un certificat de garantie de maintenance de trois ans dans les locaux d'Agilent sont livrés avec chaque instrument. Cette rubrique présente les options disponibles.

Options de l'instrument

Options d'extension

Documentation et Langues

Options de maintenance et d'assistance

Options de l'instrument

Option 010 | Fonctionnalités du domaine temporel Pour afficher la réponse d'une mesure de réflexion et de transmission dans le domaine temporel. Voir Présentation du domaine temporel.
Option 015 | Ensemble de test configurable Ajoute un accès en face avant à la sortie de la source et à l'entrée du coupleur sur les ports 1 et 2. Des atténuateurs de 35 dB sont ajoutés entre les coupleurs et les récepteurs. Cette option permet d'améliorer la sensibilité de la mesure et de mesurer des signaux de faible niveau ou d'ajouter des composants et d'autres instruments périphériques pour une large gamme d'applications de mesure. Voir Mesures de composants haute-puissance.
Option 1CM | Kit de montage en rack Ajoute un kit de montage en rack (référence 5063-9216) et un kit de rails (E3663AC) pour une utilisation sans poignées de face avant.
Option 1CP | Kit de montage en rack Ajoute un kit de montage en rack (référence 5063-9236) et un kit de rails (E3663AC) pour une utilisation avec des poignées de face avant.
Option AM8 | Lecteur de CD à lecture-écriture Comprend un lecteur de CD à lecture-écriture avec liaison USB.
Option B30 | Concentrateur USB Comprend un concentrateur USB à quatre ports pour connecter des périphériques USB supplémentaires.

Options d'extension

Des kits d'extension permettent d'ajouter des options après l'achat initial d'un analyseur. Pour commander un kit d'options d'extension pour un E8356A, E8357A ou E8358A, indiquez le numéro de modèle de l'analyseur suivi d'un "U", puis indiquez l'option à ajouter :

Option 010 | Kit d'extension de domaine temporel (référence E8356-60101) Le numéro de série du E8356A, E8357A ou E8358A doit être indiqué lors de la commande. L'installation n'est pas comprise.
Option 015 | Kit d'extension de test configurable (référence E8356-60102) Comprend l'installation dans une agence Agilent.
Option AM8 | Lecteur de CD à lecture-écriture Comprend un lecteur de CD à lecture-écriture avec liaison USB.
Option B30 | Concentrateur USB Comprend un concentrateur USB à quatre ports pour connecter des périphériques USB supplémentaires.
Option 099 | Mise à jour du logiciel (référence E8356-60103) Fournit la dernière mise à jour du logiciel de l'analyseur de la série PNA sur CD-ROM. Le logiciel peut être intallé par l'utilisateur. L'installation nécessite un lecteur de CD-ROM USB ou un ordinateur externe connecté à un réseau local. La dernière version du logiciel est également disponible sur le site Web d'Agilent. Consultez notre page Web à l'adresse www.agilent.com/find/pna. Pour toute aide concernant l'installation, consultez la rubrique Mise à jour du logiciel.

Un devis est établi dans le cas de mises à jour nécessitant des modifications du modèle. Contactez votre agence locale Agilent pour plus d'informations. Voir Agences Agilent.

Documentation et Langues

Option AVK | Ajoute une version imprimée du manuel d'aide qui correspond à la documentation d'utilisateur et de programmeur. (référence E8356-90028)
Option 0BW | Ajoute une version imprimée du manuel de maintenance de l'ensemble. (référence E8356-90002)
Option ABD | Ajoute une version imprimée de l'aide en allemand. (référence E8356-90032)
Option ABE | Ajoute une version imprimée de l'aide en espagnol. (référence E8356-90031)
Option ABF | Ajoute une version imprimée de l'aide en français. (référence E8356-90029)
Option ABJ | Ajoute une version imprimée de l'aide en japonais. (référence E8356-90032)

Options de maintenance et d'assistance

Option W01 | Transforme une garantie de maintenace de trois ans dans les locaux d'Agilent en une maintenance sur site d'un an (vérifiez qu'il existe une agence locale Agilent dans votre région). Voir Agences Agilent.
Option W31 | Transforme une garantie de maintenance de trois ans dans les locaux d'Agilent en une maintenance sur site de trois ans (vérifiez qu'il existe une agence locale Agilent dans votre région). Voir Agences Agilent.
Option W32 | Ajoute un contrat d'étalonnage de trois ans dans les locaux d'Agilent.
Option W34 | Ajoute un contrat d'étalonnage et de mise en conformité de trois ans dans les locaux d'Agilent.
Option W50 | Etend la garantie de maintenance dans les locaux d'Agilent à cinq ans.
Option W51 | Transforme une garantie de maintenance de trois ans dans les locaux d'Agilent en une maintenance sur site de cinq ans (vérifiez qu'il existe une agence locale Agilent dans votre région). Voir Agences Agilent.
Option W52 | Ajoute un contrat d'étalonnage de cinq ans dans les locaux d'Agilent.
Option W54 | Ajoute un contrat d'étalonnage et de mise en conformité de cinq ans dans les locaux d'Agilent.


Tech Supp

Assistance technique

Voir aussi...

    • Cliquez sur la région qui vous intéresse.

  • Pour toute assistance concernant votre instrument de test et mesure, visitez le site www.agilent.com/find/assist

  • Vous pouvez également contacter les experts en test et mesure d'Agilent Technologies.

Etats-Unis :

(tél.) 1 800 452 4844

Canada :

(tél.) 1 877 894 4414

(fax) 1 (905) 206 4120

Europe :

(tél.) (31 20) 547 2000

Japon :

(tél.) (81) 426 56 7832

(fax) (81) 426 56 7840

Amérique Latine :

(tél.) (305) 267 4245

(fax) (305) 267 4286

Australie :

(tél.) 1 800 629 485

(fax) (61 3) 9272 0749

Nouvelle Zélande :

(tél.) 0 800 738 378

(fax) 64 4 495 8950

Asie Pacifique :

(tél.) (852) 3197 7777

(fax) (852) 2506 9284


Tshoot

Dépanner l'analyseur

Voir aussi...

En procédant à quelques vérifications, vous pouvez déterminer si l'analyseur fonctionne correctement. Avant d'appeler Agilent Technologies ou de renvoyer l'instrument au service de réparation, veuillez procéder aux vérifications ci-après.
Vérifications élémentaires

Vérification des conditions d'erreur

Consultation du guide de maintenance

Vérifications élémentaires

Souvent, il est possible de résoudre un problème en réitérant la procédure que vous suiviez lorsque le problème est survenu. Avant d'appeler Agilent Technologies ou de renvoyer l'instrument au service de réparation, veuillez procéder aux vérifications suivantes :

  1. Y-a-t'il du courant à la prise d'alimentation ? L'instrument est-il branché ?

  2. L'instrument est-il sous tension ? Assurez-vous que l'interrupteur secteur de la face avant et qu'au moins un des voyants à côté des ports de test s'allume en vert. Ceci indique que l'instrument est sous tension.

  3. Si d'autres équipements, câbles et connecteurs sont utilisés avec l'instrument, assurez-vous qu'ils soient connectés et qu'ils fonctionnent correctement.

  4. Passez en revue la procédure de mesure que vous exécutiez au moment où le problème est survenu. Tous les paramètres sont-ils corrects ?

  5. Si l'instrument ne fonctionne pas correctement, replacez l'unité dans un état connu en appuyant sur la touche Preset.

  6. La mesure réalisée, et les résultats attendus, sont-ils compatibles avec les spécifications et les fonctionnalités de l'instrument ?

  7. Si vous pensez que le problème est lié au microprogramme, assurez-vous que la dernière version du microprogramme soit installée sur l'instrument avant d'entamer la procédure de dépannage.

  8. Vérifiez que l'étalonnage de la mesure soit correct. Voir Etalonnages précis des mesures pour plus d'informations.

  9. Si l'équipement de test requis est disponible, effectuez le contrôle opérateur et la vérification système décrits au Chapitre 2 du Guide de maintenance PNA, "Tests, vérifications et ajustements système", inclus sur le CD-ROM fourni avec l'analyseur.

Vérification des conditions d'erreur

Si vous imprimez les conditions d'erreur à intervalles réguliers (toutes les semaines, tous les mois, etc.), vous pouvez comparer les conditions d'erreur courantes à vos archives. Un système stable et répétitif doit générer des conditions d'erreur répétitives sur de longs intervalles de temps, par exemple, six mois. Si vous suspectez une panne mineure ou un léger problème de performance, l'amplitude des conditions d'erreur doit être comparée avec les valeurs générées précédemment avec le même instrument et le même kit d'étalonnage. Voir la procédure de surveillance des conditions d'erreur.

  • Une tendance à long terme reflète souvent une dérive, une usure du connecteur et des câbles ou une dégradation progressive. Le cas échéant, vous devez poursuivre vos recherches ainsi que la maintenance préventive. Cependant, le système peut être toujours conforme aux spécifications. La solution se résume souvent à nettoyer et à réenficher les connecteurs ou à inspecter les câbles.

  • Un changement soudain des conditions d'erreur reflète un changement soudain des erreurs systématiques et peut impliquer la nécessité de poursuivre le dépannage.

Gardez bien présents à l'esprit les points suivants durant le dépannage :

  • Tous les composants du système, y compris les câbles et les composants étalons, peuvent générer des erreurs systématiques et avoir un impact sur les conditions d'erreur.

  • Les connecteurs doivent être propres et correctement enfichés, et l'analyse des conditions d'erreur prévue par les spécifications doit être significative. Voir le Chapitre 2 du guide de maintenance PNA pour plus d'informations sur le nettoyage et l'enfichage des connecteurs.

    • Evitez toute torsion ou courbure superflue des câbles après l'étalonnage des mesures afin de minimiser les erreurs dues à l'instabilité des câbles.

    • Appliquez des techniques de connexion adaptées lors de l'étalonnage des mesures. L'interface du connecteur doit être répétitive. Voir le guide de maintenance PNA pour plus d'informations sur les techniques de connexion.

  • Il est souvent utile de réaliser la procédure deux fois (en utilisant deux étalonnages de mesure distincts) pour déterminer le degré de répétitivité. Si les résultats ne semblent pas répétitifs, vérifiez tous les connecteurs et tous les câbles.

  • Utilisez l'analyse des conditions d'erreur pour résoudre les problèmes de performance mineurs. Voir le Chapitre 3, "Dépannage", du guide de maintenance PNA si une panne majeure ou si une importante erreur de mesure survient.

Consultation du guide de maintenance

Consultez le guide de maintenance PNA pour les procédures de dépannage spécifiques afin d'identifier les problèmes. Ce guide est inclus sur le CD-ROM fourni avec votre analyseur. Vous trouverez également un exemplaire du guide de maintenance sur notre site Web à l'adresse suivante : http://www.agilent.com/find/pna


Accessry

Accessoires disponibles

Voir aussi...

Kits d'étalonnage

Kits de vérification

Kits d'adaptateurs de connecteur et d'accessoires

Câbles pour ports de test

Vous trouverez une gamme complète d'accessoires de test RF dans le catalogue Agilent RF and Microwave Test Accessories (numéro de publication 5968-4314EN) ou en visitant la page Web www.agilent.com/find/mta.

Les accessoires sont disponibles dans les variantes de connecteurs suivantes :

  • 50 ohms type N

  • 3,5 mm

  • 7 mm

  • 7-16

Des câbles pour ports de test et un kit d'étalonnage sont nécessaires pour un système de mesure complet. Vous pouvez également vous procurer un kit de vérification pour contrôler les performances du système une fois les corrections appliquées.

Kits d'étalonnage

Type N, 50 ohms Mécanique | Agilent 85032F
Type N, 50 ohms Module d'étalonnage électronique (ECal) RF | Agilent 85092B
3,5 mm Mécanique | Agilent 85033E
3,5 mm Module d'étalonnage électronique (ECal) RF | Agilent 85093B
7 mm | Agilent 85031B
7 mm Module d'étalonnage électronique (ECal) RF | Agilent 85091B
7-16 | Agilent 85038A
7-16 Module d'étalonnage électronique (ECal) RF | Agilent 85098B

Kits de vérification

Type N | Agilent 85055A
3,5 mm | Agilent 85053B

Kits d'adaptateurs de connecteur et d'accessoires

3,5 mm Kit d'adaptateurs | Agilent 11878A
APC-7 à type N (f) Adaptateur coaxial | Agilent 11524A
APC-7 à type N (m) Adaptateur coaxial | Agilent 11525A
7-16 à 7-16 Kit d'adaptateurs | Agilent 11906A
7-16 à type N Kit d'adaptateurs | Agilent 11906B
Kit d'accessoires type N, 50 ohms | Agilent 11853A
Kit d'accessoires BNC, 50 ohms | Agilent 11854A

Câbles pour ports de test

Type N (m-m), 50 ohms, 16 pouces (40,6 cm) | Agilent N3839A
Type N (m-m), 50 ohms, 24 pouces (61 cm) | Agilent N6314A
Type N (m-f), 50 ohms, 16 pouces (40,6 cm) | Agilent N6315A


Instrument_Calibration_and_Verification

Etalonnage de l'instrument et vérification du système

Voir aussi ...

Afin de garantir un fonctionnement correct de l'analyseur, vous pouvez utiliser différents niveaux d'inspection.

Etalonnage de l'instrument

Vérification du système

Etalonnage de l'instrument

Pourquoi l'instrument doit-il être étalonné ?

Avec le temps, les composants actifs de l'analyseur vieillissent et les performances peuvent se dégrader ou dériver. Afin de garantir un fonctionnement de l'analyseur conforme aux caractéristiques publiées, vous devez effectuer périodiquement un étalonnage de l'instrument.

Que se passe-t-il au cours d'un étalonnage de l'instrument ?

Un étalonnage d'instrument est une opération au cours de laquelle les performances de l'analyseur sont mesurées afin de garantir un fonctionnement conforme aux caractéristiques. Si un des paramètres de fonctionnement n'est pas conforme aux caractéristiques publiées, des réglages sont effectués afin de rétablir la conformité.

A quels intervalles de temps faut-il étalonner l'instrument ?

Les caractéristiques de l'instrument sont définies en tenant compte de la dérive des performances qui peut se produire sur une période de douze mois. Par conséquent, en effectuant un étalonnage de l'instrument tous les douze mois, les performances de l'analyseur resteront conformes aux caractéristiques de fonctionnement. Si vous souhaitez que l'analyseur conserve des paramètres de fonctionnement plus conformes, vous pouvez effectuer un étalonnage de l'instrument à des intervalles moins longs que les douze mois suggérés.

Comment faut-il étalonner l'instrument ?

Retournez l'instrument à une agence d'Agilent Technologies pour qu'il soit étalonné. Voir Assistance technique. Si vous souhaitez effectuer l'étalonnage de l'instrument, vous devez disposer des éléments nécessaires suivants :

  • L'équipement de test d'étalonnage de l'instrument

  • Le logiciel de test des performances

Quels sont mes choix d'étalonnage de l'instrument ?

Les types d'étalonnages d'instruments suivants sont disponibles auprès d'Agilent Technologies :

Standard | Comprend un certificat d'étalonnage, indiquant que l'instrument a été étalonné et fonctionne conformément aux caractéristiques publiées.
Option UK6 | Comprend les données des tests d'étalonnage et le certificat standard, indiquant que l'instrument a été étalonné et fonctionne conformément aux caractéristiques publiées.
Option M40 (Spéciale) | Comprend les données des tests d'étalonnage et le certificat, indiquant que l'instrument a été étalonné en utilisant une méthode conforme à la norme ANSI Z540 et fonctionne conformément aux caractéristiques publiées.

Vérification du système

Ce programme vérifie le fonctionnement du système d'analyseur en mesurant automatiquement l'amplitude et la phase des quatre paramètres S de chaque dispositif contenu dans un kit de vérification et en comparant les résultats aux valeurs suivantes :

  • Les données mesurées en usine provenant des fichiers du disque de vérification

  • Les limites basées sur les incertitudes de mesure

Cette méthode garantit que l'analyser peut :

  • Effectuer des mesures dans la plage de fréquence entière.

  • Effectuer des mesures dans la plage dynamique de l'instrument la plus souvent utilisée.

  • Appliquer de manière correcte les données d'étalonnage de mesure.


FW_upgrade

Mise à jour du micrologiciel et de l'aide

Voir aussi...

La dernière mise à jour du micrologiciel des analyseurs de la série PNA est disponible sur le site Web d'Agilent. Vous pouvez y accéder et la télécharger gratuitement. Si vous n'avez pas accès à Internet, la mise à jour du micrologiciel peut vous être fournie sur un CD-ROM. Pour savoir comment commander ce CD-ROM, reportez-vous à la rubrique Options de l'analyseur.

La mise à jour est un fichier InstallShield auto-extractible. Elle comprend les éléments suivants :

  • Application de mesure pour analyseur de réseau

  • Aide en ligne

  • Utilitaires de maintenance

Les fichiers occupent environ 20 Mo une fois extraits. Pour télécharger la mise à jour, vous pouvez utiliser votre analyseur série PNA ou un PC externe.

Procédure de téléchargement à l'aide de l'analyseur série PNA

Utilisez votre analyseur série PNA, un navigateur Web et le réseau local (LAN) pour vous connecter au site Web d'Agilent.

  1. Accédez à la page Web PNA à l'adresse http://www.agilent.com/find/PNA

  2. Cliquez sur Support.

  3. Cliquez sur Download Firmware.

  4. Vous avez alors deux possibilités :

    • Exécuter le programme depuis son emplacement actuel (à partir du serveur). [Recommandé]

    • Enregistrer le programme sur disque (disque dur de votre analyseur).

Si vous choisissez d'enregistrer la mise à jour sur disque, ouvrez le fichier sur l'analyseur et suivez les instructions. Ce fichier est auto-extractible.

Procédure de téléchargement à l'aide d'un PC externe

Si vous ne pouvez pas accéder directement à Internet depuis votre analyseur, vous pouvez télécharger le fichier à partir du site Web d'Agilent en recourant à un PC externe disposant d'un accès à Internet. Vous pouvez ensuite transférer le fichier du PC vers l'analyseur via un réseau local.

  1. Accédez à la page Web PNA à l'adresse http://www.agilent.com/find/PNA

  2. Cliquez sur Support.

  3. Cliquez sur Download Firmware.

  4. Enregistrer le programme sur disque (disque dur de votre PC).

  5. Transférez le fichier du PC vers l'analyseur via un réseau local.

    • Exécutez le programme depuis son emplacement actuel (à partir du PC externe).

    • Enregistrez le programme sur disque (disque dur de votre analyseur).

Avertissement : vous pouvez enregistrer le fichier de mise à jour sur votre PC externe, mais n'y installez pas l'application de l'analyseur de réseau. Cela aurait pour effet de modifier les réglages du système et d'en perturber le fonctionnement.


Glossary

Sommaire

Glossaire

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

12 termes Voir Correction d'erreurs à 12 termes.

2 ports, étalonnage complet Voir Correction d'erreurs à 12 termes.

3 termes Voir Correction d'erreurs à 3 termes.

A

Abaque de Smith Représentation graphique du coefficient de réflexion complexe sous forme d'impédance complexe normalisée. Les cercles de l'abaque représentent chacun une valeur de résistance constante, tandis que les arcs perpendiculaires à ces cercles représentent chacun une valeur de réactance constante. Le centre de l'abaque représente l'impédance caractéristique du système de transmission. A chaque point de l'abaque correspond une impédance complexe unique (association d'une composante résistive et d'une composante réactive). Une ligne droite figurant sur l'abaque représente le changement d'impédance en fonction de la fréquence.

Adaptation de la charge Mesure de l'écart entre l'impédance de charge terminant un composant et l'impédance idéale de la ligne de transmission. L'adaptation est généralement mesurée sous forme de perte de réflexion de la charge ou de rapport d'ondes stationnaires (ROS, ou SWR).

Adaptation de la source Mesure de l'écart entre l'impédance de la source de signal et l'impédance idéale de la ligne de transmission du système de test. L'adaptation est généralement mesurée sous forme de perte de réflexion de la source ou de rapport d'ondes stationnaires (ROS, ou SWR).

A distance Mode d'exploitation dans lequel un autre périphérique (ou ordinateur) contrôle l'instrument via le bus GP-IB. Les touches de la face avant de l'instrument sont alors inopérantes. L'exploitation via les touches de la face avant s'appelle le mode d'exploitation local.

ADM Add-Drop Multiplexer.

Admittance (Y) L'inverse d'une impédance (c'est-à-dire le rapport du courant sur la tension). Les admittances complexes sont de la forme Y = G + jB(t).

Adresse Identification (représentée par un nom, un libellé ou un numéro) d'un registre, d'un emplacement en mémoire ou de toute autre source ou cible de données. Par exemple, désignation ou emplacement d'une station dans un réseau de communication ou d'un périphérique sur le bus GP-IB.

Adresse Ethernet Nombre hexadécimal utilisé pour identifier une machine sur un réseau. Chaque analyseur reçoit une adresse Ethernet unique et immuable, stockée dans sa ROM lors de sa fabrication.

Adresse IP Adresse de protocole Internet : numéro unique attribué à chaque machine (périphérique, ordinateur, etc.) qui doit être connectée à un réseau TCP/IP. Avant toute utilisation de l'analyseur sur un tel réseau, l'administrateur système doit lui attribuer une adresse IP. Il s'agit d'une valeur de 32 bits présentée sous forme de quatre valeurs décimales séparées par des points, chacune de ces valeurs représentant un octet (8 bits).

Affichage Voir Ecran.

Affichage logarithmique Mode d'affichage dans lequel la déviation verticale est une fonction logarithmique de l'amplitude du signal d'entrée. L'utilisateur étalonne l'affichage en sélectionnant la valeur de la position du niveau de référence et le facteur d'échelle, en dB par division.

ALC Abréviation de Automatic Level Control (contrôle automatique de niveau). Voir Contrôle automatique de gain.

AM Abréviation de Amplitude Modulation (modulation d'amplitude).

Analogique Classe générale de composants ou de circuits dont la sortie varie continuellement en fonction de l'entrée.

Analyse de réseau Caractérisation d'un composant, d'un circuit ou d'un système obtenue en comparant un signal d'entrée injecté dans le composant au signal ou aux signaux qui en sortent.

Annotation Etiquetage d'informations spécifiques à l'écran (par exemple, la fréquence ou la puissance).

ANSI American National Standards Institute : organisme nord-américain ouvert aux constructeurs, aux entreprises, aux utilisateurs et aux opérateurs de télécommunication, qui ratifie les normes et standards, accrédite les groupes de développement de normes et les programmes de certification, et représente et coordonne les intérêts des Etats-Unis dans les comités de normalisation non gouvernementaux.

ASCII American Standard Code for Information Interchange.

Atténuation Réduction d'amplitude d'un signal. Différence entre la puissance émise et la puissance reçue due à la perte à travers les équipements, les lignes ou autres composants de transmission. Elle est généralement exprimée en décibels.

Atténuateur Composant RF ou hyperfréquence utilisé pour réduire le niveau de puissance d'un signal dans des proportions précises et incrémentielles sur l'intégralité de sa plage de fréquences.

Atténuateur d'entrée Atténuateur placé entre le connecteur d'entrée et le premier mélangeur d'un analyseur de spectre (également appelé atténuateur RF). Il sert à ajuster le niveau du signal incident reçu par le premier mélangeur et à empêcher la compression de gain due aux signaux de haut niveau ou large bande. Il est également utilisé pour régler la plage dynamique en contrôlant le degré de distorsion générée en interne. Dans le cas de certains analyseurs, le fait de changer l'atténuation en entrée modifie la position verticale du signal à l'écran, ce qui a pour effet de changer le niveau de référence en conséquence. Dans les analyseurs Agilent contrôlés par microprocesseur, le gain de la FI est modifié automatiquement pour compenser les changement s d'atténuation en entrée. Grâce à quoi le signal conserve sa position à l'écran et le niveau de référence reste inchangé.

Atténuation de sortie Possibilité d'atténuer le signal source afin de contrôler son niveau de puissance.

Autoscale (mise à l'échelle automatique) Fonction de l'analyseur qui évalue la forme du signal et agit en conséquence sur les réglages pour stabiliser et améliorer l'affichage.

Autotest Ensemble de tests exécutés à la mise sous tension (ou lors du préréglage) pour vérifier le bon fonctionnement de l'instrument.

AUX Connecteur d'entrée auxiliaire situé en face arrière.

B

Balayage Aptitude de la source à fournir un niveau de signal spécifié et à faire varier sa fréquence sur une plage spécifique en un temps donné. Voir aussi Mode de balayage et Type de balayage.

Bande d'analyse Fréquence d'arrêt (ou finale) moins la fréquence de départ (ou initiale). La bande d'analyse choisie détermine l'échelle de l'axe horizontal de l'écran de l'analyseur.

Bande étroite En analyse de réseau, qualifie la résolution de fréquence du récepteur de l'analyseur lorsqu'elle est suffisamment étroite pour résoudre les caractéristiques d'amplitude et de phase des composants à bande étroite. La réduction de la largeur de bande du récepteur abaisse généralement le plancher de bruit du récepteur et offre ainsi une plus grande plage dynamique pour les mesures d'amplitude.

Bande de fréquence d'analyse Etendue de composante fréquentielle affichée. La bande d'analyse est figurée sur l'axe horizontal de l'écran. Généralement, elle représente la bande balayée sur toute la largeur de l'écran. Certains analyseurs la représentent sous forme de valeur par division.

Bande passante Plage des fréquences qu'un composant laisse passer (par exemple, un filtre). Les fréquences situées en dehors de la bande passante sont limitées ou atténuées. Voir aussi Fréquence de coupure.

Bande passante de résolution Aptitude d'un analyseur de spectre à afficher des réponses adjacentes sous forme de raies distinctes. Ce terme est utilisé pour identifier la largeur du filtre de bande passante de résolution d'un analyseur de spectre à un niveau donné en dessous du point de perte d'insertion minimale (point de déviation maximale à l'écran). Généralement, on spécifie la bande passante de résolution à 3 dB, mais il arrive qu'elle soit spécifiée à 6 dB.

Bande passante vidéo Dans les analyseurs de spectre, fréquence de coupure (à -3 dB) d'un filtre passe-bas réglable dans le circuit vidéo. Lorsque la bande passante vidéo est inférieure ou égale à la bande passante de résolution, le circuit vidéo ne peut pas réagir aux fluctuations rapides de la sortie du détecteur d'enveloppe. Il en résulte un lissage de la trace ou une réduction de l'excursion crête à crête des signaux large bande (bruit ou signaux RF impulsionnels, par exemple) lorsqu'ils sont visualisés en mode large bande. Le degré de moyennage ou de lissage est fonction du rapport de la bande passante vidéo sur la bande passante de résolution.

B/R Rapport des données échantillonnées sur l'entrée B sur les données échantillonnées sur l'entrée R.

Basculer Alterner entre deux états, généralement pour faire passer une fonction de l'état actif à l'état inactif et inversement.

Binaire Méthode de représentation des nombres en base deux (actif ou inactif, niveau haut ou niveau bas, un ou zéro). Format compact d'échange d'informations entre l'analyseur et les autres équipements.

BMP Abréviation de Bit-Mapped (format de fichier en mode points).

Bruit de trace à l'affichage, amplitude Incertitude d'amplitude de la trace, en dB, due au bruit aléatoire dans le système de test.

Bruit de trace à l'affichage, phase Incertitude de phase de la trace, en degrés, due au bruit aléatoire dans le système de test.

BUS Abréviation de Basic Utility System.

Bus Un ou plusieurs conducteurs utilisés comme voie de transmission d'informations entre une source sélectionnée parmi plusieurs et une cible sélectionnée parmi plusieurs.

BW Abréviation de Bandwidth (largeur de bande).

C

CAN Convertisseur analogique-numérique.

CAO Conception assistée par ordinateur.

Caractéristiques supplémentaires Paramètres de performances typiques mais non garantis, dénotés par une mention telle que "typique", "nominal" ou "approximatif".

Carte mémoire Petit composant mémoire dont la forme rappelle celle d'une carte de crédit et dans lequel il est possible de stocker des données ou des programmes.

c.c. Courant continu.

Charge Composant hyperfréquence à un seul port (type dipôle) utilisé pour terminer un trajet sur son impédance caractéristique.

CNA Convertisseur numérique-analogique.

Coefficient de réflexion Rapport de la tension réfléchie sur la tension incidente dans une ligne ou un circuit de transmission. Si la ligne de transmission est terminée par une charge égale à son impédance caractéristique, le coefficient de réflexion est nul. Si la ligne se termine sur un court-circuit ou un circuit ouvert, le coefficient de réflexion est égal à 1. Voir aussi Perte par réflexion et ROS.

Commande Ensemble d'instructions traduites en actions de l'instrument. Ces actions sont généralement constituées d'étapes individuelles qui, ensemble, exécutent une opération.

Composant à bande étroite Composant dont les caractéristiques de transfert sont destinées à un usage sur une plage de fréquences très étroite et sont conçues pour fournir une réponse d'amplitude bien définie dans cette plage. Par exemple, un filtre passe-bande.

Composant à 1 port Composant de type dipôle, c'est-à-dire présentant un seul point d'accès à ses circuits (connecteur ou trajet). Par exemple, un oscillateur ou une charge.

Composant à 2 ports Composant de type quadripôle, c'est-à-dire présentant deux points d'accès à ses circuits (connecteurs ou trajets). Exemples : filtres, composants SAW, atténuateurs, adaptateurs d'impédance, amplificateurs.

Composant large bande Composant fonctionnant sur une très large plage de fréquences et dont la réponse ne présente que de petites variations dans cette plage.

Composant linéaire Composant dont la sortie est continuellement proportionnelle à l'entrée.

Composant non insérable Dans un étalonnage de mesure, composant auquel on ne peut pas substituer un trajet direct de longueur nulle, soit parce que ses deux connecteurs sont du même type et du même sexe, soit parce qu'ils sont de types différents.

Compression du gain dans le domaine des petits signaux Situation observée lorsque l'amplitude mesurée du signal d'entrée est inférieure à l'amplitude réelle de ce signal en raison d'une surcharge du mélangeur d'entrée de l'analyseur de réseau. Ce dernier fonctionne alors de manière non linéaire. En mode de détection large bande, un signal autre que celui qui est testé peut placer l'analyseur dans cette situation de compression du gain, si bien que même la mesure des signaux de faible amplitude est erronée (leur niveau affiché est inférieur à ce qu'il est en réalité). Le mode large bande mesure toute la puissance incidente, et non seulement les signaux situés à la fréquence d'intérêt.

Contrôle automatique de gain (CAG) Circuit utilisé dans les amplificateurs et autres composants actifs pour maintenir le niveau de puissance RF constant lorsque d'autres paramètres tels que la fréquence varient. Synonyme : contrôle automatique de niveau (Automatic Leveling Control : ALC).

Contrôleur Dispositif (équipement, périphérique, etc.) capable de désigner l'émetteur et les récepteurs dans un transfert d'informations. Ordinateur externe relié à un instrument pour en contrôler le fonctionnement.

Correction d'erreurs Dans les analyseurs de spectre, processus qui supprime ou réduit les erreurs de mesure systématiques (répétables) en mesurant des étalons aux caractéristiques connues, faisant partie d'un kit d'étalonnage. Synonyme : étalonnage de mesure.

Correction d'erreurs à 3 termes Utilisée pour supprimer les erreurs de mesure systématiques sur un composant à un seul port (dipôle), par exemple une charge.

Correction d'erreurs à 12 termes Correction pour un composant à deux ports (type quadripôle) portant sur six paramètres :
Directivité
Adaptation de la source
Adaptation de la charge
Réponse en fréquence de réflexion
Réponse en fréquence de transmission
Isolement

Pour la caractérisation complète d'un composant à deux ports, ces six paramètres doivent être déterminés dans le sens direct et dans le sens inverse, ce qui fait un total de 12 termes. L'utilisateur a généralement la possibilité d'omettre la partie isolement du processus de correction. Synonyme : correction d'erreurs complète sur deux ports

Correction d'erreurs sur 1 port Pour un montage de test, corrige les erreurs de directivité, de réponse en fréquence et d'adaptation de la source du port 1 ou du port 2. Ce processus requiert trois étalons connus, par exemple un circuit ouvert, un court-circuit et une charge.

Correction d'erreurs sur deux ports Voir Correction d'erreurs à 12 termes.

Corrigé Terme qualifiant les mesures exécutées après application de la correction d'erreurs.

Couleur, luminosité Voir Luminosité de couleur.

Coupleur Voir Coupleur directionnel.

Coupleur directionnel Dispositif à 3 ports généralement utilisé pour échantillonner séparément le signal inverse (réfléchi) dans une ligne de transmission.

CPU Abréviation de Central Processing Unit (unité centrale ou processeur).

Crête positive Valeur maximale instantanée d'un signal entrant.

CST Composant sous test.

Curseur Pointeur généré électroniquement que l'on déplace sur l'écran pour manipuler des contrôles.

CW Abréviation de Continuous Wave (mode d'onde entretenue) : signal de fréquence fixe et unique (par opposition à un signal balayé en fréquence).

D

Décalage Valeur ou grandeur électrique affectée d'un décalage d'une quantité déterminée. Procédé utilisé dans les instruments pour décaler les fréquences, les limites, le retard, la perte, l'impédance, etc.

Déclenchement Signal qui provoque l'exécution d'une mesure par l'instrument. L'utilisateur dispose de plusieurs options de déclenchement. Par exemple, manuel, continu ou externe (pour synchroniser les mesures avec une source externe).

dB Abréviation de décibel : unité de mesure relative. Le rapport en dB est donné par l'équation : 10 log10 (P1/P2) où P1 et P2 sont des puissances mesurées. Le dB est préféré aux rapports arithmétiques ou aux pourcentages, car lorsque l'on connecte des composants en série, leurs effets sur la puissance, exprimés en dB, peuvent être ajoutés et soustraits arithmétiquement. Par exemple, si un atténuateur de 3 dB est connecté à un amplificateur dont le gain est de 10 dB, le gain net des deux composants est -3 dB + 10 dB = +7 dB.

dBm Unité de mesure absolue en décibels : 0 dBm = 1 mW. Les conventions arithmétiques (ajout et soustraction) applicables au dB le sont également au dBm.

Démodulation Processus consistant à extraire d'une porteuse modulée un signal dont la forme possède essentiellement les mêmes caractéristiques que le signal modulant d'origine. Extraction du signal modulant réalisée par un procédé appelé détection de signal.

Démodulation numérique Technique d'extraction des informations utilisées pour moduler un signal. Des algorithmes de traitement numérique sont utilisés sur le signal une fois celui-ci numérisé (c'est-à-dire converti de sa forme analogique en une forme numérique).

Dérive Variation lente de la fréquence d'un signal.

Détection Processus de démodulation d'une porteuse de signal. Deux méthodes de base sont mises en oeuvre pour réaliser la détection de signal dans les analyseurs de réseau : les détecteurs à diode pour les applications à large bande et la détection cohérente (ou détection hétérodyne) pour les applications à bande étroite.

Diaphonie Occurrence d'un signal sur un port particulier du composant affecté par un signal présent dans n'importe quel autre trajet. L'isolement est la mesure de la diaphonie.

Dimension En programmation, spécifie la taille d'un tableau. Nombre de lignes ou de colonnes d'un tableau.

Diode détectrice Composant utilisé pour convertir un signal RF en un niveau c.c. proportionnel. Si le signal est modulé en amplitude, la diode extrait le signal modulant de la porteuse RF. De nombreuses sources utilisées avec les analyseurs scalaires sont modulées en amplitude avec un signal à 27,778 kHz, puis détectées dans l'analyseur. La détection à diode entraîne la perte des informations de phase de la porteuse.

Directivité Dans un coupleur directionnel à 3 ports, rapport de la puissance présente sur le port auxiliaire lorsque le signal circule dans le sens direct sur la puissance présente sur le port auxiliaire lorsque ce même signal circule dans le sens inverse.

Disque Support magnétique de forme circulaire servant au stockage d'informations.

Disque (ou mémoire de masse) Disque interne ou externe destiné à la sauvegarde de données de test, de réglages de l'instrument, de programmes IBASIC ou d'autres paramètres de mesure. Les formats d'enregistrement comprennent les formats MS-DOS et le format LIF standard de HP. Les données peuvent être de type binaire, PCX, HP-GL ou ASCII.

Distorsion Altération de la qualité du signal due aux caractéristiques non linéaires d'un composant ou de la fonction de transfert d'un système. La mesure de distorsion est une combinaison des changements d'amplitude, de fréquence et de phase du signal à la sortie du composant ou du système considéré par rapport aux mêmes paramètres du signal en entrée.

Distorsion d'intermodulation Composantes fréquentielles indésirables résultant de l'interaction de deux composantes spectrales ou plus traversant un composant dont le comportement est non linéaire (par exemple, un mélangeur ou un amplificateur). Ces composantes indésirables résultent de sommes et de différences arithmétiques des fréquences fondamentales et de leurs harmoniques. L'algorithme est de la forme : f1 ± f2, 2xf1 ± f2, 2xf2 ± f1, 3xf1 ± 2xf2, etc.

DSP Abréviation de Digital Signal Processing (traitement numérique du signal).

DVM Abréviation de Digital Volt Meter (voltmètre numérique).

E

ECal Voir Etalonnage électronique.

Ecart par rapport à la phase linéaire La phase linéaire se rapporte à la nature du décalage de phase subi par un signal passant à travers un composant. La phase est linéaire si le tracé du décalage de phase en fonction de la fréquence est une ligne droite (les échelles des deux axes du tracé étant linéaires). Tout écart par rapport à la phase linéaire entraîne une distorsion du signal.

Echantillonneur Composant électronique qui prélève le niveau et la phase du signal à travers une impédance connue, à une cadence uniforme appelée fréquence d'échantillonnage. Dans les analyseurs de réseau, cette fréquence d'échantillonnage doit être suffisamment élevée et précise pour permettre l'obtention de mesures précises. Les analyseurs de réseau comportent généralement trois ou quatre échantillonneurs ou mélangeurs.

Ecran Surface physique utile d'un tube cathodique ou d'un écran plat sur laquelle sont présentés les résultats des mesures, les données de configuration, la définition des touches de fonction et autres informations de l'instrument.

EMC Abréviation de Electro-Magnetic Compatibility (compatibilité électromagnétique).

EMI Abréviation de Electro-Magnetic Interference (interférences électromagnétiques) : signaux d'interférences non intentionnels générés à l'intérieur ou à l'extérieur des équipements électroniques. Sources type : transitoires sur les lignes d'alimentation secteur, bruit généré par les alimentations à découpage et/ou émissions parasites des oscillateurs. Ces interférences peuvent être éliminées par un filtrage adéquat des lignes secteur, par le blindage des câbles et des châssis, etc.

Enclencher Activer une fonction.

Entrée Trajet destiné à "injecter" un signal dans l'instrument.

La plupart des analyseurs comportent soit trois entrées (libellées A, B et R), soit quatre entrées (libellées A, B, R1 et R2). Ces entrées ne doivent pas être confondues avec les voies de l'analyseur.

Entrer Action d'entrer ou de saisir des informations.

EPROM Abréviation de Electronically Programmable, Read-Only Memory (mémoire morte programmable électroniquement).

ESD Abréviation de Electro Static Discharge (décharge électrostatique).

Etalonnage En instrumentation HP, processus consistant à vérifier périodiquement (généralement une fois par an) qu'un instrument fonctionne conformément à ses spécifications. Un certificat d'étalonnage est délivré après vérification.

Dans les analyseurs de réseau, processus d'élimination des erreurs systématiques affectant les mesures. Voir Correction d'erreurs.

Etalonnages Blackburn Techniques d'étalonnage du trajet de transmission avec adaptation de la source corrigée impliquant 15 termes d'erreur. Synonyme : correction d'erreurs à 15 termes.

Etalonnage complet sur 2 ports Voir Correction d'erreurs à 12 termes.

Etalonnage électronique (ECal) Système d'étalonnage électronique des analyseurs de réseau vectoriels RF et hyperfréquence. Ce système crée un modèle d'erreur sur deux ports à 12 termes, puis fournit un test de fiabilité de l'étalonnage. Il est constitué d'un étalon intégré, répétitif et d'impédance variable, ainsi que d'une unité de contrôle qui s'interface avec les analyseurs de réseau des séries 8510, 8720 et 8753 ou d'un module USB qui s'interface avec les analyseurs de la série PNA.

Etalonnage de réponse en fréquence Procédure de correction d'erreurs la plus simple à mettre en oeuvre, mais ne corrigeant que quelques-uns des douze termes d'erreur systématique. Les corrections de la réponse en fréquence peuvent être appliquées aux mesures de réflexion, de transmission et d'isolement.

Etalonnage sur 2 ports Voir Correction d'erreurs à 12 termes.

Etats en mémoire Nombre de paramètres, de programmes, de traces et autres paramètres qui, à un moment donné, sont disponibles pour être enregistrés, catalogués et rappelés.

Ethernet Réseau conforme à la norme de réseau local IEEE 802.3.

Exploitation en mode local Mode permettant de commander le fonctionnement de l'instrument manuellement, à l'aide des touches de sa face avant.

Extension des ports Redéfinition du plan de référence en un point autre que celui qui est établi à l'étalonnage. Un nouveau plan de référence s'exprime en secondes de retard par rapport au port de test.

F

Facteur de bruit (F) : pour un composant à deux ports (quadripôle), mesure de la dégradation observée à 290 degrés du rapport signal sur bruit d'un signal traversant le composant, dégradation qui résulte du bruit généré à l'intérieur de ce composant (bruit intrinsèque). Elle est généralement exprimée en dB.

Facteur de célérité Constante numérique qui détermine la vitesse de propagation de l'énergie à travers une ligne de transmission suivant le diélectrique dont elle est constituée (0,66 dans le cas du polyéthylène). Utilisé pour les mesures dans le domaine du temps.

Facteur d'échelle Etalonnage de l'axe vertical de l'écran en termes d'unités par division.

FI Fréquence intermédiaire : fréquence à laquelle un signal est traité après mélange.

Fichier de lignes de gabarit Fichier enregistré dans la mémoire utilisateur, qui contient les entrées du tableau de limites de gabarit.

Filtre Composant passif qui laisse passer certaines fréquences et en atténue d'autres, selon son type et ses caractéristiques. Un filtre passe-haut laisse passer les fréquences situées au-dessus de la fréquence de coupure, un filtre passe-bas laisse passer les fréquences situées en dessous de la fréquence de coupure et un filtre passe-bande laisse passer les fréquences comprises entre deux bornes spécifiques.

Filtre vidéo Dans les analyseurs de spectre, filtre passe-bas situé en aval de la détection, qui détermine la bande passante de l'amplificateur vidéo. Il sert à moyenner ou à lisser la trace. Voir aussi Bande passante vidéo.

FM Abréviation de Frequency Modulation (modulation de fréquence).

Fonction Action ou rôle d'un élément spécifique. L'analyseur de réseau contient des fonctions qui peuvent être exécutées via la sélection de touches de la face avant ou au moyen de commandes de programmation. Les caractéristiques de ces fonctions sont déterminées par le micrologiciel de l'instrument. Dans certains cas, l'exécution DLP (Downloadable Program, programme téléchargeable) d'une fonction permet d'exécuter celle-ci depuis la face avant.

Fonctions de marqueur Calcul mathématique ou statistique portant sur les données d'un ou de plusieurs marqueurs pour fournir des informations complémentaires à l'opérateur. Par exemple, la fonction Delta Marker calcule et affiche la différence entre deux marqueurs.

Fonction de transfert Rapport du signal de sortie sur le signal de stimulus, l'un et l'autre étant mesurés en fonction de la fréquence.

Formats d'affichage Formats graphiques d'affichage des données de mesure. Il s'agit des formats monovoie, superposition (plusieurs traces sur un seul graticule) et divisé (chaque trace sur un graticule séparé).

Forme d'onde Représentation graphique de l'amplitude d'un signal en fonction du temps.

Fréquence Nombre d'oscillations périodiques, de vibrations ou d'ondes par unité de temps, généralement exprimé en cycles par seconde ou en hertz (Hz).

Fréquence d'arrêt/départ Termes utilisés en association avec les points d'arrêt et de départ de la plage de mesure de fréquences. Ensemble, ils déterminent l'étendue de la plage de mesure (ou bande d'analyse).

Fréquence de coupure Pour un filtre, fréquence à laquelle l'atténuation est de 3 dB en dessous du niveau de signal obtenu dans la bande passante du filtre.

Fréquence fondamentale Première composante fréquentielle d'un signal de forme quelconque, toutes les autres composantes étant des harmoniques. Une sinusoïde pure possède une seule composante fréquentielle, sa fréquence fondamentale.

G

Gb Gigabit

GHz Gigahertz

GIF Graphics Interchange Format - Format graphique standard pour le stockage de fichiers graphiques en mode point (bitmap).

Giga Préfixe signifiant un milliard.

Go Gigaoctet

GP I/0 General Purpose Input / Output - Connecteur généralement situé à l'arrière d'un instrument, qui permet la communication avec d'autres équipements de test tels que dispositifs de mesure externes, commutateurs et ordinateurs et qui permet à l'instrument d'être déclenché par un appareil externe ou de déclencher lui-même un autre appareil. Il peut par exemple s'agir d'un commutateur commandé au pied qui permet à l'utilisateur de poursuivre ou de relancer une mesure tout en conservant les deux mains sur le matériel de test.

GPIB General Purpose Interface Bus - Bus d'interconnexion et protocole IEEE 488 permettant de relier des instruments à un ordinateur.

Graticule (ou grille) Zone encadrée dans laquelle le signal est affiché à l'écran. Les graduations jalonnant le pourtour ou les axes aident l'opérateur à effectuer des mesures visuelles.

GUI Abréviation de Graphical User Interface (interface utilisateur graphique).

H

Harmoniques de la source Niveau des harmoniques générées par la source de signal de l'analyseur, exprimé en dBc par rapport au niveau de la fréquence fondamentale.

HP Hewlett-Packard Company.

HPGL Hewlett-Packard Graphics Language.

HTTP HyperText Transfer Protocol : protocole utilisé pour transporter le trafic du World Wide Web (WWW).

I

IAO Ingénierie assistée par ordinateur.

I/O Input/Output (entrée/sortie).

I/O Path Input/Output Path (trajet d'entrée/sortie).

IEEE Institute of Electrical and Electronic Engineers.

Impédance Rapport de la tension sur le courant sur un port de circuit, exprimé en ohms.

Impédance caractéristique Impédance "vue" à l'extrémité d'une ligne de transmission infiniment longue et sans perte.

Incertitude de mesure Degré d'erreur quantifié dans une situation de mesure. Les étalonnages sont destinés à réduire le degré d'incertitude. Voici les sources d'erreurs de mesure qui conduisent à une incertitude :

  • Erreurs systématiques (imperfections dans les étalons, les connecteurs, les câbles et l'instrumentation)

  • Erreurs aléatoires (bruit, répétabilité des connecteurs)

  • Dérive (source et instrumentation)

Indication de la fonction active Zone de l'écran où s'affichent les informations et l'état de la fonction active. La fonction active est celle qui a été exécutée par la dernière sélection de touche ou la dernière commande de programmation à distance.

Initialiser (ou formater) Procédé d'attribution d'emplacements d'informations à un disque en vue de préparer le support magnétique à accepter des fichiers.

Intensité Synonyme de luminosité pour un écran ou un affichage.

Interception du troisième ordre (TOI : Third Order Intercept) Niveau de puissance d'entrée d'un composant non linéaire à partir duquel se produit une distorsion du troisième ordre. Le TOI est une mesure qui vise à déterminer les caractéristiques de distorsion d'un mélangeur ou d'un récepteur. Plus sa valeur est élevée, meilleure est l'immunité du récepteur à la distorsion interne.

Interface Connexion permettant à plusieurs instruments de communiquer et d'échanger des informations.

Internet Interconnexion de plusieurs réseaux distincts. Les interconnexions sont souvent réalisées au moyen de passerelles ou de routeurs.

Interpolation Procédure ou algorithme déterminant la valeur d'un signal entre deux points adjacents.

Interpolation (fonction d'étalonnage) Fonction de l'analyseur de réseau que l'utilisateur peut sélectionner pour obtenir de nouveaux termes de correction d'erreurs calculés par interpolation à partir de termes existants en cas de changement de paramètres tels que la largeur de bande de la FI, le niveau de puissance ou le temps de balayage. La correction résultante n'est pas aussi précise que celle qui serait obtenue avec un nouvel étalonnage complet sur 2 ports.

Interpréteur de commandes Lit les messages de programme dans la file d'entrée d'un périphérique dans l'ordre suivant lequel ils ont été reçus du contrôleur. L'interpréteur de commandes détermine les actions que l'analyseur doit entreprendre. L'une de ses fonctions les plus importantes est de déterminer la position d'un message de programme dans l'arborescence des commandes SCPI de l'analyseur. Lorsque l'interpréteur est réinitialisé, le premier élément qu'il reçoit ensuite est supposé provenir de la racine de l'arborescence des commandes de l'analyseur.

IP Internet Protocol.

ISO International Standards Organization.

Isolement Spécification ou mesure de l'immunité d'un signal aux perturbations provoquées par un autre signal adjacent. L'occurrence de ces perturbations s'appelle la diaphonie.

Isolateur Composant RF utilisé pour assurer l'isolement entre des trajets et des composants. Constitué d'un circulateur à 3 ports, le troisième port étant terminé sur une charge de 50 ohms.

J

K

kilo Préfixe signifiant un millier.

Kit d'étalonnage Matériel et logiciel nécessaires à la correction d'erreurs sur un analyseur de réseau pour une mesure et/ou un montage de test spécifiques.

ko Kilo-octet.

ko/s Kilo-octets par seconde.

L

LAN Abréviation de Local Area Network (réseau local).

Largeur de bande (BW) Différence entre les fréquences extrêmes d'une bande continue dans laquelle les performances d'un composant sont conformes aux spécifications énoncées.

LCD Liquid Crystal Display (affichage à cristaux liquides).

LED Light Emitting Diode (diode électroluminescente).

LIF Logical Interchange Format (utilisé pour les lecteurs de disque et ordinateurs HP des anciennes générations).

Lignes de gabarit Lignes que l'utilisateur superpose aux données mesurées par l'analyseur pour permettre la détection automatique des données qui franchissent ces limites. Les tests correspondants (appelés tests par gabarit) peuvent donner lieu à l'affichage d'une annotation Pass/Fail (réussite/échec), à l'émission d'une alarme sonore ou à la génération d'un signal de sortie envoyé à un programme d'ordinateur externe.

Limite de largeur de bande Condition prévalant lorsque la bande passante du système est dépassée et que le signal est distordu au-delà des spécifications.

Limite de test par gabarit Pour une mesure donnée, niveau qui ne doit pas être franchi pour que le résultat du test soit jugé acceptable.

Log Forme abrégée de logarithme ou logarithmique.

LRM Line-Reflect-Match. Voir TRL et LRM (fonction d'étalonnage).

Luminosité de couleur Mesure de l'intensité d'une couleur.

M

Magnitude Amplitude d'un signal mesurée dans son impédance caractéristique sans tenir compte de la phase. Voir aussi Scalaire.

Marqueur Symbole graphique placé le long d'une trace affichée et qui est annoté avec les caractéristiques de mesure du point de données qu'il désigne.

Marqueur actif Le marqueur sur la trace qui peut être repositionné soit par les contrôles de la face avant, soit par des commandes de programmation.

Méga Préfixe signifiant un million.

Mémoire Périphérique, composant ou support d'enregistrement dans lequel des données peuvent être stockées et conservées pour en être extraites ultérieurement.

Mémoire non volatile Mémoire dans laquelle les données sont conservées en l'absence de source d'alimentation secteur. Elle est généralement soutenue par une pile.

Menu Fonctions de l'analyseur apparaissant à l'écran et sélectionnées au moyen des touches de la face avant. Ces sélections peuvent appeler une série d'autres fonctions connexes qui, ensemble, forment un groupe appelé menu.

Message d'erreur Message s'affichant à l'écran pour signaler une erreur. Cette erreur peut être due à un équipement manquant ou défectueux, à une opération incorrecte de l'utilisateur ou à toute autre situation exigeant une intervention. Généralement, l'action ou l'opération demandée ne peut pas être réalisée tant que l'erreur n'est pas corrigée.

Mesure dans le sens inverse Mesure d'un composant de la sortie vers l'entrée.

Mesures de réflexion Mesures qui visent à caractériser le comportement en entrée et/ou en sortie du composant sous test (CST). Elles consistent à mesurer le rapport du signal réfléchi sur le signal incident en fonction de la fréquence. Les paramètres en jeu, tous mesurés en fonction de la fréquence, sont la perte par réflexion, le coefficient de réflexion, l'impédance et le rapport d'ondes stationnaires (ROS, ou SWR en anglais). Voir aussi Paramètres S.

Mesures de transmission Caractérisation de la fonction de transfert d'un composant, c'est-à-dire le rapport du signal de sortie sur le signal incident. Les mesures les plus courantes sont le gain, la perte d'insertion, le coefficient de transmission, la phase d'insertion et le temps de propagation de groupe. Elles sont toutes réalisées en fonction de la fréquence. Voir aussi Paramètres S.

MHz Mégahertz.

Micrologiciel (Egalement appelé "firmware") Ensemble constitué d'une partie matérielle et d'un code d'instructions. Ce matériel et ce code sont intégrés et forment une unité fonctionnelle qui ne peut pas être modifiée lors de l'exploitation normale de l'instrument. Le code d'instructions est stocké dans une mémoire morte (ROM) équipant les circuits de l'instrument. Le micrologiciel détermine les caractéristiques de fonctionnement de l'instrument ou de l'équipement.

milli Préfixe signifiant un millième.

Mo Mégaoctet.

Modes d'affichage Les différents moyens de présenter graphiquement les données mesurées. Sur un analyseur de réseau, les choix disponibles sont les suivants : cartésien/rectiligne (tracé XY avec amplitude logarithmique ou linéaire, phase, temps de propagation de groupe, SWR (rapport d'ondes stationnaires), réel et imaginaire ainsi que dBV, dBmV et dBuV), polaire (amplitude et phase), amplitude et phase, et abaque de Smith. Ces modes ne sont pas tous disponibles sur l'ensemble des analyseurs de réseau. De plus, ces informations peuvent être présentées dans diverses combinaisons de traces. Les modes courants sont Dual (double - possibilité d'afficher plusieurs traces, généralement sur la même plage de fréquences) et Alternate (alterné - possibilité d'afficher plusieurs traces, chacune d'un type différent et sur une plage de fréquences différente).

Mode de balayage Façon dont un balayage est déclenché ou sélectionné. Par exemple, balayage unique (Single), continu (Continuous), alterné (Alternate) ou découpé (Chopped).

Mode de balayage continu Etat de fonctionnement de l'analyseur dans lequel les traces sont mises à jour automatiquement chaque fois que les conditions de déclenchement sont remplies.

Mode de balayage unique Mode dans lequel l'analyseur exécute un seul balayage lorsque les conditions de déclenchement sont remplies. Chaque nouveau balayage est déclenché par une action sur la touche de face avant appropriée ou par l'envoi d'une commande de programmation.

Mode détecteur d'affichage Méthode par laquelle les informations vidéo analogiques sont traitées avant d'être numérisées et stockées en mémoire.

Modem Modulateur/Démodulateur

Modulation Processus ou résultat du processus consistant à faire varier une caractéristique particulière d'une porteuse (par exemple, sa fréquence ou son amplitude) avec un signal lui-même porteur d'informations. Ces informations sont ainsi contenues dans la porteuse. Voir AM et FM.

Modulation d'amplitude Processus ou résultat du processus de variation de l'amplitude d'un signal de porteuse. La porteuse modulée contient des informations qui peuvent être extraites par démodulation. Voir aussi Modulation.

Moniteur Tout écran externe.

Monochrome Constitué d'une seule couleur.

Montage de test Ensemble des accessoires (commutateurs, coupleurs, connecteurs et câbles) qui servent à relier l'entrée et la sortie d'un composant à la source et au récepteur de l'analyseur de réseau en vue d'exécuter la mesure des paramètres S de ce composant.

Moyennage Technique de réduction du bruit qui calcule chaque point de données sur la base de plusieurs balayages consécutifs moyennés et pondérés (le nombre de balayages, appelé facteur de moyennage, est spécifié par l'utilisateur). Le résultat de chaque nouveau balayage est ajouté à la moyenne des traces précédentes jusqu'à ce que le nombre total de balayages atteigne le facteur de moyennage spécifié.

ms Milliseconde.

Multisync Type de moniteur dont le balayage horizontal peut être synchronisé avec diverses fréquences dans une plage spécifique.

mW Milliwatt : un millième de watt.

N

NIST National Institute of Standards and Technology.

Nit Unité de luminance (luminosité photométrique) égale à un candela par mètre carré.

Niveau d'entrée maximal Niveau maximal de puissance qui peut être appliqué en toute sécurité à l'entrée de l'analyseur. Il est généralement de 1 W (+30 dBm) pour les analyseurs de spectre Agilent.

Niveau de référence Fonction de l'instrument qui permet à l'utilisateur de placer la valeur d'amplitude à la position de référence. Sur les analyseurs de réseau, la position de référence est également sélectionnable. Sur certains analyseurs de spectre, la position de référence est fixe et située en haut de l'écran.

Nom d'hôte Nom unique servant à identifier chaque machine hôte sur un réseau. Le nom d'hôte est directement lié à l'adresse IP et peut généralement être utilisé à la place de celle-ci. La création (attribution) du nom d'hôte d'une machine revient généralement à l'utilisateur ou à l'administrateur système.

Non corrigé Terme qualifiant les mesures exécutées sans application préalable de la correction d'erreurs.

Normaliser Soustraire une trace d'une autre pour éliminer les erreurs de données d'étalonnage ou pour obtenir des informations relatives.

Numérique Classe de composants ou de circuits dont la sortie varie par paliers discrets.

O

Octet Groupe de huit bits de données représentant un caractère traité comme un tout.

OL Oscillateur local. Dans un système superhétérodyne, le signal de l'oscillateur local est mélangé avec le signal reçu pour produire une somme ou une différence égale à la fréquence intermédiaire (FI) du récepteur.

Ordinateur hôte Ordinateur ou périphérique d'un réseau qui offre à l'utilisateur final des services tels que moyens de calcul et accès aux bases de données et qui exécute généralement des fonctions de contrôle du réseau.

Ouverture Bande de fréquences de l'analyseur de réseau utilisée pour calculer le temps de propagation de groupe. Plus l'ouverture est étroite, plus la résolution des variations du temps de propagation de groupe est fine. En revanche, l'élargissement de l'ouverture a pour effet de réduire le bruit.

P

Paramètres S (Scattering, ou dispersion) Convention utilisée pour caractériser, à l'aide d'un analyseur de réseau, la manière dont un composant modifie le signal qui lui est appliqué. Un composant à deux ports (quadripôle) est caractérisé par quatre paramètres S : transmission dans le sens direct (S21), transmission dans le sens inverse (S12), réflexion dans le sens direct (S11) et réflexion dans le sens inverse (S22).

Parasites d'intermodulation de transmission Mesure de l'aptitude de l'émetteur à inhiber la génération des produits de distorsion par intermodulation. On parle parfois d'atténuation d'intermodulation.

Par défaut Ensemble connu de conditions utilisé en l'absence de conditions explicitement définies par l'utilisateur.

PC Abréviation de Personal Computer (ordinateur personnel).

PDF Portable Document Format (format utilisé notamment sur le Web).

Perte par réflexion Grandeur exprimée en dB indiquant à quel niveau en dessous du signal incident se situe le signal réfléchi. Si aucun signal n'est réfléchi, l'impédance du composant est égale à l'impédance caractéristique du système de transmission et la valeur de la perte par réflexion est infinie. Si le signal incident est entièrement réfléchi, la valeur de la perte par réflexion est nulle. Voir aussi Paramètres S, Coefficient de réflexion et ROS.

Perte d'insertion Différence entre les puissances mesurées avant et après l'insertion d'un composant. Atténuation entre l'entrée et la sortie d'un composant.

Perte par réflexion structurelle Mauvaise perte par réflexion dans un câble due à un défaut périodique tel qu'une blessure récurrente du câble causée par la chute du touret ou par un étirement trop prononcé lors de la fabrication.

Phase Partie fractionnelle d'un cycle sur laquelle une oscillation a avancé. Elle est mesurée par rapport à un point de départ arbitraire et est généralement exprimée en radians ou en degrés. En analyse de réseau, la réponse de phase du composant testé est le changement de phase (en fonction de la fréquence) observé entre le stimulus d'entrée et la réponse mesurée.

Plage dynamique Dans un récepteur, fourchette des niveaux de signal qui peuvent être mesurés simultanément avec fiabilité. La plage dynamique détermine l'aptitude à mesurer des signaux de faible niveau en présence de signaux de niveau plus élevé. Sa limite haute est généralement déterminée par la puissance que peut délivrer la source ainsi que par le niveau de compression (ou de saturation) du récepteur. Sa limite basse est généralement conditionnée par les réponses résiduelles et le plancher de bruit du récepteur.

Plage dynamique d'affichage Plage d'amplitudes en dB à laquelle s'applique la précision dynamique d'affichage.

Plage dynamique du récepteur Voir Plage dynamique.

Plage dynamique du système Différence entre le niveau d'entrée maximal du récepteur et le plancher de bruit de ce dernier. La plage dynamique du système s'applique uniquement aux mesures de transmission, puisque les mesures de réflexion sont limitées par la directivité.

Plage de fréquences Fourchette de fréquences pour lesquelles les performances d'un composant ou d'un instrument sont spécifiées.

Plan de référence Emplacement électrique que l'analyseur de réseau considère comme point marquant la fin des connecteurs et accessoires de test et le début du CST. Le plan de référence est défini à l'aide d'étalons dont la longueur électrique est connue. Plus le plan de référence est proche du composant sous test (CST), meilleure est la caractérisation du composant du fait de l'élimination des incertitudes du système de test.

Plancher de bruit Bruit interne de l'analyseur qui affecte la mesure affichée. Son niveau détermine souvent la plus petite amplitude de signal mesurable. Dans le cas des analyseurs de réseau, le plancher de bruit est mesuré dans les conditions suivantes : ports de test terminés chacun sur une charge, correction d'erreurs sur deux ports (étalonnage complet sur deux ports), largeur de bande FI de 10 Hz, puissance maximale appliquée au port de test, moyennage des balayages désactivé.

Planéité Réponse d'amplitude et de phase d'un composant sous test (CST), d'une source de signal, d'un récepteur ou d'une combinaison de ces éléments. Voir aussi Réponse en fréquence.

Planéité d'amplitude de la source Planéité de la courbe d'amplitude du signal de puissance délivré par la source, mesurée sur la plage de fréquences spécifiée et exprimée en dB.

Points d'affichage Nombre total de points de mesure générés au cours d'une seule mesure. Les points peuvent être en unités de fréquence, de puissance ou de temps. Le nombre de points conditionne souvent la vitesse de mesure, la résolution et l'ouverture.

Port Connexion physique d'entrée ou de sortie d'un instrument ou d'un composant.

Port de test Voir Port.

Porteuse en salves Porteuse qui est périodiquement coupée et réactivée. Elle peut être modulée ou non.

Port Extension (fonction d'étalonnage) Voir Extension des ports.

PostScript (fichiers .ps) Format d'encapsulation de fichiers graphiques en mode point (bitmap) exploitable directement par les imprimantes PostScript.

Poursuite Aptitude du récepteur de l'analyseur à rester accordé sur la fréquence de la source lorsque celle-ci varie entre les deux limites de la plage de mesure. Une poursuite médiocre se traduit par des erreurs d'amplitude et de phase du fait que les circuits FI du récepteur atténuent et retardent le signal de sortie du composant testé.

Précision d'amplitude de la source Incertitude d'amplitude, en dB, de l'indication de puissance de la source.

Précision de la bande d'analyse Incertitude de l'écart de fréquence indiqué pour deux signaux quelconques affichés à l'écran.

Précision de fréquence Incertitude avec laquelle la fréquence d'un signal ou sa composante spectrale est indiquée, soit dans un sens absolu, soit par rapport à la fréquence d'un autre signal ou de sa composante spectrale. Les précisions de fréquence absolue et relative sont spécifiées indépendamment.

Précision de fréquence de la source Mesure de la stabilité en fréquence de l'analyseur, exprimée en parties par million (ppm ou 1 partie pour 10E6). Par exemple, une stabilité de ±5,0 ppm signifie que l'analyseur pourra mesurer un signal à 1 MHz avec une précision de ±5 x 10-6 x 10E6 Hz = +5 Hz.

Précision dynamique d'affichage Incertitude d'amplitude, généralement en dB, sur la plage dynamique d'affichage.

Précision dynamique de phase à l'affichage Incertitude de mesure de phase, généralement en degrés, pour les mesures exprimées en degrés.

Préfixe du numéro de série Les cinq premiers caractères du numéro de série d'un instrument qui représentent la version du micrologiciel ou le niveau de révision appliqué au matériel.

Préréglage/Prérégler Etat prédéfini de l'instrument (qui déclenche également l'exécution d'un autotest). Action d'appuyer sur la touche Preset.

Programmation à distance Exploitation automatique d'un instrument par un ordinateur, généralement via une liaison GP-IB ou RS-232 ou un réseau local.

Protocole Ensemble de règles et de conventions qui spécifient comment les informations doivent être formatées et transmises sur un réseau et comment les machines de ce réseau doivent communiquer entre elles.

Puissance d'entrée, niveau maximal Limite supérieure de puissance d'entrée pour laquelle une spécification s'applique. Certaines spécifications sont associées à différents niveaux de puissance d'entrée maximale. Par exemple, la limite de compression est généralement située à un niveau plus haut que la limite de distorsion harmonique.

Puissance d'entrée, niveau de sécurité Niveau de puissance d'entrée, généralement exprimé en dBm, au-delà duquel l'instrument risque d'être endommagé.

Q

Q ou facteur Q Rapport de l'énergie stockée sur l'énergie perdue dans un circuit résonnant. Un facteur Q élevé indique une résonance "pointue".

R

r + jx Expression de l'impédance complexe, où r représente la partie résistive et x, la partie réactive.

Raie de l'oscillateur local Réponse observée dans un système superhétérodyne lorsque la première fréquence de l'oscillateur local est égale à la première FI.

RAM Random Access Memory (mémoire vive) : zone de mémoire autorisant un accès direct à l'un quelconque de ses emplacements. Les données peuvent y être écrites et lues, mais leur stockage n'est que temporaire. Elles disparaissent lorsque l'alimentation est coupée. Les informations générées par l'utilisateur et s'affichant à l'écran sont des données stockées en mémoire vive.

Rapport signal sur bruit Rapport de l'amplitude du signal désiré sur l'amplitude des signaux de bruit, généralement exprimé en dB et en termes de valeurs crête pour le bruit impulsionnel ou de valeurs efficaces (RMS) pour le bruit aléatoire.

Rebond de l'échantillonneur Fuite ou diaphonie entre les échantillonneurs d'un analyseur de réseau. Le retard affectant cette diaphonie, dû au temps de propagation de la fuite, donne à l'interférence une apparence de "rebond". Le rebond de l'échantillonneur entraîne une augmentation du niveau de bruit de la voie affectée et réduit la sensibilité de l'analyseur.

Récepteur Circuit ou système conçu pour la réception et/ou la mesure de signaux dans un spectre de fréquences défini.

Recherche de crête Fonction de l'analyseur qui permet de rechercher le point où la réponse est la plus élevée et de placer un marqueur dessus.

Référence horizontale Voir Niveau de référence.

Reference Plane (fonction d'étalonnage) Voir Plan de référence.

Réflexion Phénomène de réflexion d'une partie de l'onde propagée lorsque celle-ci atteint une discontinuité dans le support de transmission.

Réponse en fréquence Variation crête à crête de la réponse d'amplitude affichée sur une plage de fréquences spécifiée, centrée sur une valeur déterminée. La réponse en fréquence est généralement spécifiée en dB par rapport à l'amplitude relevée à mi-parcours de la bande de fréquences considérée.

Requête (ou interrogation) Toute commande de programmation de l'analyseur qui a pour particularité de renvoyer une réponse. Les commandes de ce type peuvent se terminer par un point d'interrogation (?). Les commandes d'interrogation renvoient des informations à l'ordinateur.

Résolution Aptitude d'un récepteur à résoudre (distinguer) deux signaux.

Résolution de fréquence Aptitude d'un analyseur de réseau à mesurer les caractéristiques d'un composant à des fréquences très rapprochées et à les afficher séparément. La résolution de réponses d'amplitudes égales est déterminée par la largeur de bande de la FI. La résolution de réponses d'amplitudes inégales est déterminée par la largeur de bande de la FI et par la sélectivité de la largeur de bande.

Résolution de fréquence de la source La plus petite unité de fréquence qui peut être définie et/ou mesurée, en Hz.

Résolution horizontale Aptitude de l'analyseur à différencier des points de données étroitement espacés dans le sens horizontal sur toute la largeur du balayage.

Résolution verticale Degré avec lequel un instrument peut différencier les amplitudes de deux signaux.

Retard électrique Simulation d'une longueur variable de ligne de transmission sans perte, ajoutée à (ou soustraite de) l'entrée d'un récepteur pour compenser l'incidence des câbles d'interconnexion. Equivalent microprogrammé des "rallongeurs de ligne" mécaniques ou analogiques qui équipent d'autres analyseurs.

Retard Voir Temps de propagation de groupe.

RF Radiofréquence (domaine des fréquences comprises approximativement entre 50 kHz et 3 GHz). Terme généralement utilisé dès lors que le milieu de propagation du signal est l'air ou le vide.

RNIS Réseau numérique à intégration de services : norme de services offrant un ou plusieurs voies de communication commutés, capables de véhiculer de la voix numérisée, des données ou des signaux d'image, ainsi qu'une voie à commutation de paquets pour la signalisation et le contrôle hors bande. La norme RNIS offre également un ensemble de services standard et en option pour le support de productivité de l'utilisateur ainsi qu'une vitesse d'accès à Internet plus rapide que les systèmes analogiques.

ROM Read Only Memory (mémoire morte) : zone de mémoire n'autorisant que la lecture des données. L'utilisateur ne peut pas y écrire ni en modifier le contenu. Dans les instruments de test et mesure, zone de mémoire qui contient le micrologiciel (firmware) d'exploitation.

ROS Rapport d'ondes stationnaires, calculé par la formule (1 + p) / (1 -p) où est le coefficient de réflexion.

S

Sans fil Terme général qualifiant toutes les technologies utilisant les communications radio à la place des liaisons filaires traditionnelles, tant dans le domaine des appareils grand public (téléphones, ordinateurs, etc.) que dans les secteurs professionnels.

Saturation Degré de pureté d'une couleur mesuré sur une échelle allant du blanc à la couleur pure.

Scalaire Qualifie une quantité possédant une composante d'amplitude (ou de magnitude) mais pas de composante de phase. Qualifie un analyseur de réseau capable de mesurer uniquement l'amplitude.

SCPI Standard Commands for Programmable Instruments.

Sélectivité de la largeur de bande Mesure de l'aptitude d'un filtre à résoudre les signaux inégaux en amplitude. Il s'agit du rapport de la largeur de bande à 60 dB sur la largeur de bande à 3 dB pour un filtre de résolution donnée (FI). La sélectivité de la largeur de bande donne une indication de la pente de décroissance du filtre. Elle est parfois appelée facteur de forme.

Sensibilité Niveau de signal d'entrée minimal nécessaire à la production d'un signal de sortie spécifique, ayant un rapport signal sur bruit spécifié ou répondant à d'autres critères.

Sur un analyseur de spectre, niveau de la plus petite sinusoïde qui peut être observée, généralement dans des conditions optimales (notamment une bande passante de résolution minimale, une atténuation de 0 dB en entrée et une bande passante vidéo minimale).

Changement normalisé de la fréquence centrale d'un composant YIG se traduisant par un changement du courant de la bobine d'accord, spécifié en MHz/mA.

Serveur Périphérique configuré pour fournir un service à d'autres périphériques d'un réseau, par exemple l'accès partagé à un système de fichiers ou à une imprimante.

Set Z (fonction d'étalonnage) Règle l'impédance du système (généralement 50 ou 75 ohms).

SGBD Système de gestion de bases de données.

Signal de déclenchement externe Signal TTL pouvant être fourni à l'analyseur pour déclencher un balayage de mesure ou un événement similaire, offrant ainsi la possibilité de synchroniser les mesures avec une source de déclenchement externe.

En mode de traitement de données, série de mesures de points de données consécutifs effectuées avec une suite de valeurs de stimulus.

S/N Abréviation de Signal-to-Noise Ratio (rapport signal sur bruit).

SOLT Abréviation de Short-Open-Load-Through (court-circuit, circuit ouvert, charge, liaison directe). Voir aussi SOLT (fonction d'étalonnage).

SOLT (fonction d'étalonnage) Etalonnage utilisant quatre étalons connus : court-circuit, circuit ouvert, charge et liaison directe (SOLT est l'abréviation de Short-Open-Load-Through). Egalement connu sous les noms d'étalonnage complet sur deux ports et de correction d'erreurs à 12 termes. Voir aussi Correction d'erreurs.

Sortie papier Copie des données sur papier.

Source Dispositif fournissant un signal de puissance ; oscillateur balayé en fréquence ou en puissance ou vobulateur-synthétiseur.

Stabilité de la base de temps de la source Mesure de la précision de la base de temps de l'analyseur au fil du temps et en fonction de la température. Généralement, la précision de la base de temps est spécifiée pour un an. Un valeur de stabilité en température typique est ±10 ppm pour 250 C± 50 C.

Stabilité de fréquence Aptitude d'une composante fréquentielle à conserver sa fréquence ou son amplitude à court terme et à long terme. Elle découle de l'aptitude d'un oscillateur à rester calé (ou verrouillé) sur une fréquence particulière au fil du temps.

Sync Abréviation de synchronisation ou synchronisé.

Syntaxe Ensemble de règles grammaticales qui spécifient la structure à respecter pour les commandes d'un système d'exploitation, d'un langage de programmation ou d'applications.

Système d'étalonnage automatique AutoCal : fonction disponible sur les analyseurs de réseau Rohde&Schwarz.

T

T/R Voir Transmission/Réflexion.

Tableau En programmation, ensemble de nombres ou de caractères qui représentent une fonction donnée.

Tableau de limites de gabarit Les segments d'une ligne de gabarit sont stockés dans le tableau de limites de gabarit. L'utilisateur peut la rappeler pour éditer les segments, puis l'enregistrer dans le fichier de lignes de gabarit.

Tampon Dispositif de stockage (mémoire) utilisé lors de la transmission d'informations pour compenser la différence entre les vitesses de transfert respectives de deux périphériques.

Teinte Dimension d'une couleur par rapport à une échelle de perception des nuances allant du rouge jusqu'au jaune, au vert et au bleu et revenant au rouge. Gradation particulière de couleur, de teinte et d'ombrage.

Temps de propagation de groupe Mesure du temps de transit d'un signal à travers un CST en fonction de la fréquence. Le temps de propagation de groupe peut être calculé en différenciant la réponse de phase d'insertion du CST par rapport à la fréquence. Voir aussi Temps de propagation de groupe AM et Ecart par rapport à la phase linéaire.

Temps de propagation de groupe AM Technique de mesure du temps de propagation de groupe à travers un composant qui utilise une source modulée en amplitude (AM). Remarque : Le retard de l'enveloppe de modulation est mesuré directement à l'aide d'un détecteur scalaire externe. Les composants qui provoquent une distorsion de l'amplitude du signal ne peuvent pas être mesurés. C'est le cas des amplificateurs à contrôle automatique de gain (CAG) et des composants sujets à une saturation ou à une limitation de la puissance.

Terminaison Charge connectée à une ligne de transmission ou à un autre composant.

Thru Nom de la fonction utilisée pour mesurer un étalon de type "liaison directe". Voir SOLT (fonction d'étalonnage).

TOM Thru-Open-Match : terme utilisé par Rohde&Schwarz pour décrire une méthode d'étalonnage.

Touche de commande Touche de la face avant déclenchant une seule fonction de l'analyseur ou présentant un seul menu de touches de fonction.

Touche de face avant Touche équipant la face avant de l'instrument. Elle est pourvue d'un libellé qui identifie sa fonction ou l'action qu'elle déclenche. Les touches du bloc numérique et les touches de progression pas à pas sont des exemples de touches de face avant.

Trace Série de points de données contenant des informations de fréquence et de réponse. Cette série de points de données est souvent appelée tableau (notamment avec les commandes de programmation). Le nombre de traces est spécifique à l'instrument.

Trace active Trace qui est en cours de balayage et qui est mise à jour avec les informations du signal entrant.

Trajet direct de longueur nulle Dans un étalonnage de mesure, cas où les deux câbles de test s'adaptent directement l'un à l'autre sans nécessiter d'adaptateur ni de liaison directe. Voir aussi Composant non insérable.

Transmission Voir Mesures de transmission.

Transmission/Réflexion (T/R) Désigne la succession de mesures réalisées par un analyseur de réseau scalaire ou vectoriel pour caractériser le comportement d'un composant en fonction de la fréquence. Voir aussi Paramètres S.

Transparent Tout ce qui n'est pas perceptible par l'utilisateur. Généralement une procédure exécutée sans que l'utilisateur la déclenche ou en ait connaissance.

TRL Through-Reflect-Line. Voir TRL et LRM (fonction d'étalonnage).

TRL et LRM (fonction d'étalonnage) Technique d'étalonnage utilisée dans les environnements où le CST ne peut pas être connecté directement aux ports de l'analyseur de réseau (MMIC, microruban, diodes à conducteurs-poutres, etc.). Des étalons TRL (Thru-Reflect-Line) et M (Match) sont fabriqués et utilisés parce que l'on ne dispose pas d'étalons de grande qualité aux caractéristiques connues. Le besoin de caractériser ces étalons est moins impérieux, mais l'étalonnage obtenu n'est pas aussi précis qu'avec la technique traditionnelle d'étalonnage sur deux ports utilisant les étalons S-O-L-T (court-circuit, circuit ouvert, charge et liaison directe). Les termes sont utilisés de manière interchangeable (TRL, LRL, LRM, etc.) mais ils s'appuient tous sur la même méthode d'éta lonnage de base.

TTL Transistor-Transistor Logic.

Type d'affichage Fonction d'affichage intégrée à l'analyseur. Les données peuvent être affichées sous forme de matrice de points (comme sur un écran d'ordinateur) ou sous forme de vecteurs (lignes dessinées à l'écran). Le mode peut être monochrome (une seule couleur) ou couleur (plusieurs couleurs). Le standard peut être également spécifié. Par exemple, VGA ou SVGA pour les ordinateurs personnels compatibles IBM.

Type de balayage Méthode de balayage de la source. Par exemple, variation linéaire, logarithmique ou par paliers de fréquence.

U

UNI User-Network Interface : point auquel les utilisateurs se connectent au réseau.

Unité Dimension utilisée pour exprimer une grandeur mesurée. La grandeur la plus souvent concernée est l'amplitude, car elle peut être exprimée dans plusieurs unités. Dans les analyseurs à microprocesseur, les unités disponibles sont les suivantes : dBm (dB relatif à 1 mW de puissance dissipé dans l'impédance d'entrée nominale), dBmV (dB relatif à 1 mV), dBW (dB relatif à 1 W), V (volt), W (watt).

V

Variable Symbole dont la valeur change entre deux itérations successives d'un programme ou au sein de chaque itération d'un programme.

Vecteur Quantité possédant à la fois une composante d'amplitude (ou de magnitude) et une composante de phase.

Le terme "vectoriel" qualifie un analyseur de réseau capable de mesurer à la fois l'amplitude et la phase.

VEE Visual Engineering Environment (produit logiciel d'Agilent).

Verrouillage local Condition ou commande empêchant l'utilisation des touches de la face avant de l'analyseur (y compris celle de la touche Local).

Vidéo Signal électrique contenant des informations de synchronisation, d'intensité (luminance) et souvent de couleur (chrominance) et qui, après décodage, fournit une image sur un écran.

VNA Abréviation de Vector Network Analyzer (analyseur de réseau vectoriel).

Vobulateur Source délivrant un signal dont la fréquence varie continuellement entre deux limites.

Voie active Voie dont l'affichage est en surbrillance et qui est affectée par les fonctions de la face avant.

Voie R Voie de référence.

Voies non couplées Configuration dans laquelle il est possible de régler les paramètres de stimulus ou du récepteur indépendamment pour chaque voie.

W

WWW World Wide Web.

X

Y

Z


Contents

Sommaire

Glossaire


Home

(Rev. 20001220)

Bienvenue dans notre page d'accueil !

Aide de l'analyseur de réseau de la série PNA

Faites une suggestion et GAGNEZ !


Index

Index principal

Index COM

Index SCPI


Suggestions

Vos suggestions sont les bienvenues !

Merci de nous faire connaître ce que vous pensez du système d'aide. Si vous souhaitez participer à un tirage au sort mensuel et tenter de gagner un prix, indiquez-nous votre adresse e-mail. (Offre valable jusqu'au 1er mai 2001.) Envoyez vos commentaires à : pna_help@am.exch.agilent.com

Merci de nous faire part de vos commentaires sur n'importe quel aspect du système d'aide. Voici quelques points que vous pourriez commenter :

  • Avez-vous trouvé des liens rompus ?

  • Avez-vous trouvé ce que vous recherchiez ?

  • Les informations trouvées étaient-elles utiles ?

  • Avez-vous des suggestions susceptibles d'améliorer le système d'aide ?

Vos commentaires sont directement transmis aux concepteurs du système d'aide. Pour plus d'informations sur les questions techniques, veuillez consulter la rubrique Assistance technique.


3.8_GHz_Adjustment

Réglage de la fréquence 3,8 GHz

Cette procédure règle l'oscillateur interne YIG à fréquence fixe à 3,8 GHz en agissant sur une valeur de CNA. Cette valeur est stockée dans la mémoire non volatile de l'analyseur.

Généralement, l'oscillateur peut être réglé à une fréquence située à moins de 12 kHz de la valeur nominale 3,8 GHz ; il n'est pas nécessaire que sa fréquence soit exactement de 3,8 GHz.

Compatibilité des analyseurs de spectre

Cette procédure est compatible avec les analyseurs de spectre Agilent séries 856x et 859x.

Si vous ne possédez pas d'analyseur compatible, sélectionnez "NONE" (aucun) pour l'analyseur de spectre. Vous pourrez régler le CNA manuellement en visualisant le signal à 3,8 GHz sur un autre analyseur.

Procédure (pour analyseurs de spectre compatibles uniquement)

Remarque : le niveau du signal de 3,8 GHz à visualiser est particulièrement bas (généralement aux alentours de -70 dBm). Pour ce réglage, n'utilisez pas d'autre atténuateur que l'atténuation par défaut de 10 dB utilisée dans la plupart des analyseurs de spectre.

  1. Connectez l'entrée de l'analyseur de spectre à la sortie PORT 1 de l'analyseur de réseau.

  2. Connectez un câble GPIB entre l'analyseur de réseau et l'analyseur de spectre. Veillez à ce qu'aucun autre contrôleur ne soit actif sur le même bus.

  1. Réglez l'adresse GPIB de l'analyseur de spectre sur 18.

  2. Dans le menu System de l'analyseur de réseau, pointez sur Service, Adjustments, puis cliquez sur 3.8 GHz Freq. Adjust.

  3. Cliquez sur Begin Adj.. Le programme règle l'oscillateur interne de manière à obtenir une erreur minimale, puis il stocke le résultat en mémoire. Lorsque la zone d'état indique que le réglage est terminé, sélectionnez Exit.

Procédure (pour analyseurs de spectre non compatibles uniquement)

Remarque : le niveau du signal de 3,8 GHz à visualiser est particulièrement bas (généralement aux alentours de -70 dBm). Pour ce réglage, n'utilisez pas d'autre atténuateur que l'atténuation par défaut de 10 dB utilisée dans la plupart des analyseurs de spectre.

  1. Connectez l'entrée de l'analyseur de spectre à la sortie PORT 1 de l'analyseur de réseau.

  2. Configurez l'analyseur de spectre avec les réglages suivants :

    • Fréquence centrale = 3,8 GHz

    • Bande d'analyse (Span) = 100 MHz

    • Largeur de bande = 10 kHz

    • Echelle permettant de visualiser clairement un signal de -70 dBm

  3. Dans le menu System de l'analyseur de réseau, pointez sur Service, Adjustments, puis cliquez sur 3.8 GHz Freq. Adjust.

  4. Sous la rubrique Spectrum Analyzer, sélectionnez l'option NONE pour l'analyseur de spectre.

  5. Cliquez sur Begin Adj.

  6. L'application prérègle le CNA sur une valeur initiale égale à la valeur stockée en mémoire. Visualisez le signal sur l'écran de l'analyseur de spectre et déterminez s'il se situe au-dessus ou en dessous de 3,800 GHz.

    • Si la fréquence du signal est supérieure à 3,8 GHz, déplacez la glissière vers la gauche de manière à réduire la valeur du CNA.

    • Si la fréquence du signal est inférieure à 3,8 GHz, déplacez la glissière vers la droite de manière à augmenter la valeur du CNA.

Remarque : les valeurs du CNA sont comprises entre 0 et 4095. Chaque augmentation ou réduction d'une unité correspond à un déplacement d'environ 23 kHz de la fréquence de l'oscillateur.

  6. Réglez la valeur du CNA de manière à atteindre une fréquence aussi proche que possible de 3,8 GHz. Si vous effectuez d'importants changements de valeur, attendez plusieurs secondes afin que l'effet thermique se stabilise.

  7. Changez les réglages de l'analyseur de spectre de manière à mieux voir le signal :

    • Bande d'analyse (Span) = 500 kHz

    • Largeur de bande = 3 kHz

  8. Changez la valeur du CNA de manière que le signal reste centré à 3,8 GHz.

  9. Lorsque vous avez déterminé la valeur de CNA appropriée, cliquez sur SAVE DAC pour l'enregistrer dans la mémoire non volatile (EEPROM) de l'analyseur de réseau. Cliquez sur Exit.

Remarque : si la nouvelle valeur de CNA présente un écart significatif avec l'ancienne valeur, ce test doit être répété après un laps de temps de 15 à 30 minutes. Ce délai est en effet nécessaire pour permettre à l'effet thermique de se stabiliser complètement.


10_MHz_Adjustment

Réglage de la référence de fréquence à 10 MHz

Cette procédure règle la base de temps interne à exactement 10 MHz en agissant sur une valeur de CNA. Cette valeur est stockée dans la mémoire non volatile de l'analyseur. Son réglage est normalement nécessaire dans les cas suivants uniquement :

  • Le circuit de référence de fréquence est remplacé.

  • La référence à 10 MHz s'est écartée significativement de la valeur réglée en usine.

AVERTISSEMENT : la plage de ce réglage n'est que d'environ 20 Hz. Il est vivement recommandé d'utiliser un étalon très précis pour mesurer ce signal à 10 MHz (par exemple, une référence d'atelier ou une quelconque source stabilisée en température).

Compatibilité avec les fréquencemètres

Cette procédure est compatible avec les fréquencemètres à commandes SCPI tels que l'Agilent 53181A. Elle doit aussi fonctionner avec les fréquencemètres de l'ancienne série 5350.

Si aucun fréquencemètre n'est disponible, sélectionnez le mode d'exploitation manuel ("Manual"). Ce mode vous permettra d'entrer manuellement la fréquence mesurée.

Procédure (pour fréquencemètres compatibles GPIB uniquement)

  1. Connectez l'entrée du fréquencemètre à la sortie de référence 10 MHz, à l'arrière de l'analyseur.

  2. Connectez un câble GPIB entre l'analyseur et le fréquencemètre. Veillez à ce qu'aucun autre contrôleur ne soit actif sur le même bus.

  3. Le cas échéant, connectez l'étalon de fréquence de l'atelier à l'entrée de référence du fréquencemètre.

  4. Réglez l'adresse GPIB du fréquencemètre sur 03. Dans cette procédure, on suppose que tout instrument répondant à une interrogation GPIB à l'adresse spécifiée est un fréquencemètre. Vous devez donc veiller à ce que le seul instrument possédant cette adresse soit un fréquencemètre.

  5. Dans le menu System de l'analyseur, pointez sur Service, Adjustments, puis cliquez sur 10 MHz Freq. Adjust.

  6. Cliquez sur Begin Adj. L'application règle la référence interne de manière à minimiser l'erreur, puis elle enregistre le résultat.

    • Cliquez sur Read Freq pour déclencher une autre lecture du signal à 10 MHz.

    • Cliquez sur Read DAC pour visualiser la valeur de CNA stockée dans la mémoire non volatile de l'analyseur (elle est comprise entre 0 et 4095).

  7. Lorsque la zone d'état indique que le réglage est terminé, cliquez sur Exit.

Procédure (pour fréquencemètres non compatibles GPIB uniquement)

  1. Connectez l'entrée du fréquencemètre à la sortie de référence 10 MHz, à l'arrière de l'analyseur.

  2. Réglez le fréquencemètre de manière à obtenir une résolution d'au moins 1 Hz.

  3. Le cas échéant, connectez l'étalon de fréquence de l'atelier à l'entrée de référence du fréquencemètre.

  4. Dans le menu System de l'analyseur, pointez sur Service, Adjustments, puis cliquez sur 10 MHz Freq. Adjust.

  5. Sous la rubrique Frequency Counter, sélectionnez Manual.

  6. Cliquez sur Begin Adj.

  7. L'application prérègle le CNA sur une valeur initiale. Entrez l'écart de fréquence entre la valeur mesurée et la valeur nominale 10 MHz. Si la fréquence mesurée est inférieure à 10 MHz, utilisez un signe moins (-) pour indiquer que l'erreur est négative.

Par exemple :

  • Si le fréquencemètre indique une valeur de 10000003,5 Hz, entrez 3.5 (ou +3.5) dans la fenêtre indiquée.

  • Si le fréquencemètre indique 9999997,8 Hz, entrez -2.2 dans la fenêtre indiquée.

  6. La procédure de réglage effectue au moins 3 boucles, à moins que la valeur entrée soit exactement zéro.

    • Cliquez sur Read Freq pour déclencher une autre lecture du signal à 10 MHz.

    • Cliquez sur Read DAC pour visualiser la valeur de CNA stockée dans la mémoire non volatile de l'analyseur (elle est comprise entre 0 et 4095).

  7. Lorsque la zone d'état indique que le réglage est terminé, cliquez sur Exit.

Remarque : si la mesure du fréquencemètre est manifestement erronée, il se peut que vous deviez atténuer son signal d'entrée ou régler son impédance d'entrée à 50 ohms (ou effectuer ces deux opérations).


Advanced Marker Setup

Voir aussi...

Permet de définir l'aspect des données des marqueurs.

Marker. Spécifie le marqueur en cours de définition.

ON. Lorsque cette case est cochée, le marqueur est visible à l'écran, ainsi que les données correspondant à sa position.

Format. Permet d'afficher les données du marqueur dans un format de votre choix. Le format du marqueur peut être différent du format de la grille. Dans les réglages par défaut de l'instrument, le format du marqueur et le format de la grille sont identiques.

Discrete Marker.Permet d'alterner entre le mode d'affichage de valeurs correspondant aux seuls points discrets où les données sont effectivement échantillonnées et le mode d'affichage de valeurs calculées par interpolation des points de données.

Marker Type

Normal. Le marqueur apparaît le long de la trace de mesure, à la valeur de stimulus choisie.

Fixed. Le marqueur apparaît à la position correspondant aux coordonnées x et y choisies.


AgileUpdate

Voir aussi...

Cet utilitaire de mise à jour permet de télécharger de nouvelles versions du micrologiciel, des fichiers d'aide, des applications et autres fichiers associés à l'analyseur série PNA.

Mise à jour des fichiers de l'analyseur (procédure de base)

Remarque : pour exécuter cet utilitaire, vous devez disposer de privilèges d'administration de l'analyseur.

Dans la plupart des cas, les quelques étapes suivantes suffisent à télécharger et à installer la nouvelle version des fichiers de l'analyseur série PNA. Une version plus détaillée de cette procédure figure plus loin dans ce document.

  1. Dans le menu System, cliquez sur Service, AgileUpdate.

  2. Cliquez sur Check for Updates.

  3. Cliquez sur Download & Install.

Mise à jour des fichiers de l'analyseur (procédure détaillée)

Configuration de l'équipement

Remarque : pour exécuter cet utilitaire, vous devez disposer de privilèges d'administration de l'analyseur.

  1. Connectez l'analyseur à Internet. Il est conseillé d'utiliser une connexion via un réseau local, car le téléchargement du micrologiciel via une connexion modem peut prendre jusqu'à deux heures.

  2. Sélectionnez le nom et le port du proxy :

    • Si vous utilisez une connexion par réseau local, le programme utilisera le proxy spécifié par Windows (valeur par défaut d'Internet Explorer).

    • Si vous avez besoin d'utiliser un proxy ou un port différent des valeurs par défaut, cliquez sur le menu Configure, puis entrez le nom du proxy et le numéro du port. Le format à utiliser est : nomProxy:numéroPort (le numéro de port du proxy est généralement 8088). Cliquez sur OK.

  3. Sélectionnez le délai imparti à l'établissement de la connexion Internet (timeout) :

    • Si un délai de 30 secondes est suffisant pour établir une connexion Internet, conservez la valeur par défaut.

    • Si vous utilisez un accès réseau à distance pour la connexion à Internet, il est possible que vous deviez augmenter le délai. Cliquez sur le menu Configure et entrez la valeur souhaitée pour le délai (timeout). Cliquez sur OK.

Identification et téléchargement des nouveaux fichiers

  4. Sélectionnez la source à partir de laquelle les fichiers de mise à jour doivent être obtenus.

    • Si vous n'avez pas encore téléchargé les fichiers, sélectionnez Default Website.

    • Si vous avez déjà téléchargé les fichiers sur le disque dur de l'analyseur, sélectionnez Install from File.

    • Si Agilent vous a indiqué d'utiliser un site Web autre que le site par défaut, sélectionnez Other specified URL.

  5. Si Agilent vous a communiqué un code d'accès, entrez-le dans le champ prévu à cet effet.

  6. Cliquez sur Check for Updates. Si la source choisie contient des fichiers plus récents que ceux de l'analyseur, ils sont répertoriés avec leur case cochée. Si vous ne souhaitez pas mettre à jour l'un des fichiers, cliquez sur sa case pour la désélectionner.

Remarque : comme le micrologiciel (firmware) inclut le fichier d'aide, seule la case Firmware est cochée si une nouvelle version du micrologiciel et du fichier d'aide est disponible.

  6. Consultez les informations disponibles :

    1. Cliquez sur l'option de menu Firmware History et lisez la description des précédentes révisions du micrologiciel. Certains changements peuvent être importants pour vos applications de mesure.

    2. Cliquez sur l'option de menu ReadMe si elle est disponible. Lisez le document correspondant, qui peut contenir des détails relatifs aux procédures de mise à jour, aux problèmes connus et à leur solution.

  7. Sélectionnez l'opération à exécuter :

    • Cliquez surDownload & Install si vous voulez que les fichiers téléchargés remplacent automatiquement les fichiers existants de l'analyseur.

    • Cliquez sur Download Onlysi vous voulez télécharger les fichiers sur le disque dur de l'analyseur et les installer plus tard.

Remarque : le programme télécharge les fichiers dans un emplacement désigné du disque dur de l'analyseur. L'exécution à répétition de cet utilitaire peut, à terme, conduire au stockage d'un grand nombre de fichiers sur le disque de l'analyseur. Pour supprimer toutes les versions des fichiers sauf les deux plus récentes, cliquez sur Clean-Up.


Avg

Average

Voir aussi...

Average ON. Lorsque cette case est cochée, l'analyseur calcule et affiche une trace correspondant à la moyenne pondérée de plusieurs balayages successifs afin d'éliminer l'effet du bruit aléatoire.

Average Factor. Permet de spécifier le nombre de balayages à moyenner. Indiquez une valeur comprise entre 1 et 1024.

Restart. Démarre une nouvelle série de mesures (balayages) à utiliser pour la moyenne. Le nombre de mesures est égal au facteur de moyennage (Average Factor).


Calibration Wizard

Calibration Wizard (assistant d'étalonnage)

Voir aussi...

Cet assistant vous guide pas à pas dans le processus d'étalonnage d'une mesure.

Cal Type. Présente une liste de types d'étalonnage. Choisissez celui que vous souhaitez réaliser.

Modify. Présente une boîte de dialogue dans laquelle vous pouvez modifier les paramètres de fréquence avant d'exécuter un étalonnage.

Measure ECal Stds. Présente la partie de l'assistant dans laquelle vous réalisez l'étalonnage en utilisant un module ECal (étalonnage électronique) en guise d'étalon.

Measure Stds. Présente la partie de l'assistant dans laquelle vous réalisez l'étalonnage en utilisant des étalons mécaniques.

Have 2 sets of standards. Permet d'obtenir la mesure simultanée de deux jeux d'étalons (par exemple, deux circuits ouverts) sur les ports 1 et 2 lors d'un étalonnage sur deux ports.


Center and Span Frequencies

Center et Span : Frequency

Voir aussi...

Center. Spécifie la valeur de fréquence située au centre de la bande d'analyse. Cette valeur peut se situer n'importe où dans la plage de fréquences de l'analyseur.

Span. Spécifie la bande d'analyse, c'est-à-dire l'étendue de la plage de fréquences mesurées de part et d'autre de la fréquence centrale.


CW Frequency

Voir aussi...

Permet de définir la fréquence de l'onde entretenue (CW) à utiliser comme source pour un balayage en puissance ou un balayage dans le temps. La fréquence choisie peut être n'importe quelle valeur comprise dans la plage de fréquences de l'analyseur.


Electrical Delay

Electrical Delay (retard électrique)

Voir aussi...

Electrical Delay. Spécifie la valeur du retard à ajouter ou à soustraire, en unité de temps. Cette fonction compense le décalage de phase linéaire subi par le signal en traversant le composant. Le retard électrique peut être réglé individuellement pour chaque trace de mesure.

Velocity Factor. Spécifie le facteur de célérité du milieu de propagation du composant inséré. Sa valeur est 0,66 pour un câble à diélectrique en polyéthylène et 0,7 pour un câble à diélectrique en téflon.


Ext_Trig

External Trigger

Voir aussi...

Positive. Configure l'analyseur pour déclencher lorsque le signal TTL reçu sur le connecteur en face arrière passe de l'état bas (0) à l'état haut (1).

Negative.Configure l'analyseur pour déclencher lorsque le signal TTL reçu sur le connecteur en face arrière passe de l'état haut (1) à l'état bas (0).


Format

Voir aussi...

Log Magnitude. Affiche la perte d'insertion, le gain, le perte par réflexion ou la puissance absolue sous forme d'amplitude en dB mesurée en fonction de la fréquence.

Phase. Affiche le déphasage (en degrés) mesuré en fonction de la fréquence.

Group Delay. Affiche le temps de transit du signal à travers le composant testé. Cette donnée est présentée sous la forme du changement de phase qui se produit entre deux fréquences adjacentes (l'écart entre ces deux fréquences étant appelé "ouverture").

Smith Chart. Affiche les données en termes d'impédance. Les lignes en pointillés qui se croisent sur l'abaque de Smith représentent des valeurs de résistance constantes et des valeurs de réactance constantes, normalisées par rapport à l'impédance caractéristique Z0 du système. Les valeurs de réactance situées dans la moitié supérieure de l'abaque sont positives (composantes inductives) et celles de la moitié inférieure sont négatives (composantes capacitives).

Polar. Affiche chaque point de sorte que sa position corresponde à une combinaison particulière de valeurs d'amplitude et de phase. Les grandeurs sont lues sous forme vectorielle : l'amplitude en un point particulier est déterminée d'après sa distance par rapport au centre (origine, ou valeur zéro), tandis que la phase est représentée par l'angle que forme l'axe x positif avec le rayon considéré, mesuré dans le sens inverse des aiguilles d'une montre. L'échelle d'amplitude est linéaire, la valeur située au niveau du cercle extérieur correspondant généralement à un rapport de 1. Comme il n'y a pas d'axe de fréquence, les données de fréquence sont lues à l'aide des marqueurs. Dans le cas du format polaire, les indications par défaut des marqueurs sont l'amplitude linéaire et la phase.

Linear Magnitude. Affiche une grille pour les mesures sans unité, telles que l'amplitude du coefficient de réflexion ou l'amplitude du coefficient de transmission, ainsi que pour les mesures utilisant des unités linéaires. Les paramètres de conversion et les données de transformée dans le domaine temporel sont également affichés dans ce format.

SWR. Affiche le ROS (rapport d'ondes stationnaires) dérivé d'une mesure de réflexion.

Real. Affiche uniquement la partie réelle (résistive, amplitude) des données mesurées, présentant à la fois les valeurs positives et négatives. Ce format sert principalement à analyser les réponses dans le domaine temporel.

Imaginary. Affiche uniquement la partie imaginaire (réactive, phase) des données mesurées.


IF Bandwidth

Bande passante FI

Voir aussi ...

Fixe la bande passante FI (récepteur) entre 10 Hz et 40 kHz. Des bandes passantes FI étroites diminuent le plancher de bruit mais augmentent le temps de mesures. Des bandes passantes FI larges permettent des vitesses de balayage plus importantes. La valeur par défaut est 35 kHz.


Limit Test

Test par gabarit

Voir aussi ...

Compare les données de mesure à des valeurs (limites) que vous avez définies. Selon les résultats de cette comparaison, l'analyseur indique si le composant a passé le test avec succès ou non.

Limit Test ON. Lorsque cette case est cochée, l'analyseur compare les données de mesure aux limites de gabarit définies.

Limit Line ON. Lorsque cette case est cochée, les limites de gabarit sont visibles sur l'écran.

Sound ON Fail. Lorsque cette case est cochée, l'analyseur émet un son lorsque les résultats de mesure ne se trouvent pas à l'intérieur des limites de gabarit définies.

Show Table. Affiche le tableau qui permet de créer et de modifier les limites de gabarit.

Hide Table. Supprime le tableau des limites de gabarit de l'écran.


LO_Power_Adjustment

Réglage de puissance LO

Ce programme règle la puissance d'entrée LO du récepteur à un niveau spécifique en changeant les valeurs de conversion numérique-analogique. Ces valeurs de conversion numérique-analogique sont ensuite mémorisées dans la mémoire non-volatile de l'analyseur.

La plage de réglage est d'environ ± 3dB. Les niveaux de puissance cibles sont dans une plage de quelques dB autour de 0 dBm, selon la bande.

  • Les bandes 1, 2 et 3 peuvent être réglées

  • La bande 4 utilise les valeurs de la bande 2

  • Les bandes 5 et 6 utilisent la valeur de la bande 3

  • Les bandes 0 et 7 sont définies par la valeur de conversion numérique-analogique fixée

Compatibilité avec les milliwattmètres

Ce programme est UNIQUEMENT compatible avec les milliwattmètres de la série EPM d'Agilent. Ces milliwattmètres DOIVENT également utiliser les sondes de la série "E" (connectés à la voie A si possible). Les données d'étalonnage sont intégrées dans les sondes ce qui élimine le besoin d'entrer les coefficients d'étalonnage. La sélection "None" dans "Power Meter" n'est pas fonctionnelle actuellement.

Procédure

  1. Laissez chauffer l'analyseur et le milliwattmètre pendant 30 minutes.

  2. Faites une remise à zéro manuelle et étalonnez le la sonde de puissance.

  3. Connectez un câble GPIB entre l'analyseur et le milliwattmètre. Assurez-vous qu'aucun autre contrôleur n'est actif sur la même connexion.

  4. Fixez l'adresse GPIB du milliwattmètre à 13.

  5. Retirez le capot externe de l'analyseur.

  6. Déconnectez le câble semi-rigide en A17J70 afin de connecter la sonde de puissance à la sortie LO de l'ensemble de distribution LO (A17J70), en utilisant des adaptateurs si nécessaire. Si vous devez utiliser un câble, utilisez un câble de moins de 25 cm.

  7. Dans le menu System de l'analyseur, pointez sur Service, Adjustments, et cliquez sur LO Power Adjust.

  8. Cliquez sur Begin Adj pour que l'application mesure la puissance LO à diverses fréquences pour les bandes 1, 2 et 3. Le programme ajustera ensuite le niveau de puissance de chaque bande pour qu'il se trouve à l'intérieur de certaines limites. Les changements effectués sont automatiquement mémorisés.

    • Cliquez sur Read DAC pour afficher les valeurs de conversion numérique-analogique actuelles (0-4095) mémorisées dans la mémoire non volatile de l'analyseur pour chaque bande (0 à 7).

  9. Lorsque la zone d'état indique la fin du réglage, cliquez sur Exit.

  10. Reconnectez le câble semi-rigide en A17J70.


Macro

Voir aussi ...

Permet de créer un ensemble de 12 raccourcis à partir desquels vous pouvez lancer d'autres programmes dans l'application de l'analyseur.

Macro Title. Affiche les titres qui apparaissent dans la barre d'outils des entrées actives lorsque vous appuyez sur la touche Macro. Ces titres doivent donner une description des fichiers exécutables auxquels ils sont associés qui permette de les identifier plus facilement. Par exemple, si vous souhaitez lancer la page d'accueil d'Agilent, le titre de l'exécutable pourrait être "Accueil Agilent".

Macro Executable. Donne le chemin complet du fichier exécutable. Si on conserve l'exemple du lancement de la page d'accueil de la série PNA d'Agilent, le chemin du fichier exécutable pourrait être "C:\Program Files\Internet Explorer\iexplore.exe.

Macro Runstring Parameters. Affiche les paramètres passés au programme référencé dans le fichier exécutable. Toujours avec le même exemple de la page d'accueil de la série PNA, vous pouvez passer le paramètre d'exécution "http://www.agilent.com/find/pna"

Edit. Affiche la boîte de dialogue Macro Edit dans laquelle vous pouvez modifier le titre et les paramètres d'exécution et remplacer le fichier exécutable de la macro sélectionnée.

Delete. Supprime les macros sélectionnées.

Up. Permet de réordonner les macros en déplaçant la macro sélectionnée d'une ligne vers le haut. Aux 12 macros possibles correspondent 12 lignes, indiquant l'ordre dans lequel elles apparaissent dans la barre d'outils des entrées actives lorsque vous appuyez sur la touche Macro. Etant donné que quatre titres seulement peuvent être affichés simultanément dans la barre d'outils, la touche Macro permet de remplacer les titres affichés par un ensemble de quatre titres de macro suivant.

Down. Déplace la sélection d'une ligne vers le bas dans la liste des macros.


Macro_Edit

Modification de macro

Voir aussi ...

Permet de modifier le titre et les paramètres d'exécution et de remplacer le fichier exécutable de la macro sélectionnée dans la boîte de dialogue Macro Setup.

Macro Title. Permet de modifier le titre qui apparaît dans la barre d'outils des entrées actives.

Macro Executable. Permet de modifier le chemin complet du fichier exécutable de la macro.

Browse. Permet de parcourir les lecteurs et les répertoires afin de localiser le fichier exécutable de la macro et de définir son chemin complet.

Macro run string parameters. Permet de modifier les paramètres passés au programme référencé dans le fichier exécutable.


Marker Setup

Marqueur

Voir aussi ...

Définit un marqueur qui fournit une lecture numérique des données mesurées.

Marker. Spécifie le marqueur que vous définissez.

Stimulus. Spécifie la valeur de stimulus de l'emplacement du marqueur sur l'axe horizonal.

ON. Lorsque cette case est cochée, le marqueur est affiché sur l'écran avec les données de la position.

Delta Marker.Lorsque cette case est cochée, les données du marqueur sont exprimées en fonction des données d'un autre marqueur déjà défini.

Advanced...Affiche une boîte de dialogue qui permet une définition supplémentaire des données de marqueur.

All Off.Retire tous les marqueurs de la trace active.


Marker Functions

Fonctions des marqueurs

Voir aussi ...

Définit un réglage de stimulus sur la base de la valeur du marqueur actif.

Marker->Start. Définit la valeur du marqueur actif comme début de balayage.

Marker->Stop. Définit la valeur du marqueur actif comme fin de balayage.

Marker->Center. Définit la valeur du marqueur actif comme centre de balayage.

Marker->Ref Level. Définit la valeur du marqueur actif comme niveau de référence de l'écran.

Marker->Start. Définit la valeur du marqueur actif comme retard électrique.

Marker->Start. Définit le balayage de mesure à la bande d'analyse définie par le marqueur d'écart et le marqueur de référence.


Marker Search

Recherche à l'aide des marqueurs

Voir aussi...

Définit le comportement du marqueur et la zone de mesure.

Marker. Spécifie le marqueur que vous définissez.

Search Domain. Définit la zone dans laquelle le marqueur peut se déplacer ou effectuer une recherche. Dans le cas d'une bande d'analyse entière, le marqueur effectue la recherche des valeurs spécifiées dans la bande d'analyse entière. Dans le cas d'une bande d'analyse d'utilisateur, le marqueur effectue la recherche des valeurs spécifiées dans la bande d'analyse que vous définissez.

Type de recherche

Maximum. Le marqueur localise la valeur maximum (la plus élevée) des données.

Minimum. Le marqueur localise la valeur minimum (la plus faible) des données.

Next Peak. Le marqueur localise la crête avec la valeur d'amplitude inférieure suivante.

Threshold. Amplitude minimum (dB) pour être considérée comme valide.

Excursion. La distance verticale (dB) entre la crête et les vallées des deux côtés.

Peak Right. Le marqueur localise la crête valide suivante à droite sur l'axe x.

Peak Left. Le marqueur localise la crête valide suivante à gauche sur l'axe x.

Target. Le marqueur localise le point de donnée qui correspond aux critères de recherche que vous avez définis.

Bandwidth. Les marqueurs localisent une bande passante de filtre.

Execute. Déplace le marqueur à l'emplacement sur la trace de mesure qui correspond aux critères de recherche.

Tracking. Lorsque cette option est cochée, le marqueur recherche les valeurs spécifiées à chaque nouveau balayage.


Math/Memory

Voir aussi...

Data->Memory. Met la trace de données active en mémoire.

Arithmétique sur les données

Data. N'effectue aucune opération arithmétique.

Data / Memory. Effectue une opération dans laquelle les données de mesure actuelles sont divisées par les données en mémoire.

Data * Memory. Effectue une opération dans laquelle les données de mesure actuelles sont multipliées par les données en mémoire.

Data - Memory. Effectue une opération dans laquelle les données en mémoire sont soustraites des données de mesure actuelles.

Data + Memory. Effectue une opération dans laquelle les données de mesure actuelles sont ajoutées aux données en mémoire.

Options d'affichage des traces

Data Trace. Affiche la trace de mesure actuelle.

Memory Trace. Affiche la trace qui a été mise en mémoire.

Data and Memory Trace. Affiche les données de mesure actuelles et la trace qui a été mise en mémoire.


Measure

Mesure

Voir aussi ...

Modifie la trace de mesure active.

Trace Type : S-Parameters. Indique la direction de circulation du signal d'un composant sous test. La convention est S sortie entrée ; où le premier nombre (sortie) fait référence au port du composant sous test d'où sort le signal et le second nombre (entrée) est le port du composant sous test où le signal est entré.

S11. Indique que la mesure correspond au rapport complexe entre le signal sortant du port 1 du composant sous test et le signal entré au niveau du port 1 du composant sous test.

S21.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 2 du composant sous test et le signal entré au niveau du port 1 du composant sous test.

S12.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 1 du composant sous test et le signal entré au niveau du port 2 du composant sous test.

S22.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 2 du composant sous test et le signal entré au niveau du port 2 du composant sous test.


Measure Arbitrary

Mesure : Rapport arbitraire

Voir aussi ...

Modifie la trace de mesure active.

Trace Type : Arbitrary Ratio. Définition d'une mesure de rapport de puissance.

Source Port. Indique quel port de test de l'analyseur émet la puissance de la source de l'analyseur.

Input. Indique le port de test d'entrée de l'analyseur. C'est le port par lequel la réponse du composant sous test est entrée dans l'analyseur. Vous pouvez accéder aux ports d'entrée en retirant les câbles de la face avant.

Reference. Indique le port de référence de l'analyseur. C'est le port à partir duquel une partie du signal de source de l'analyseur est acheminée vers l'entrée de voie R du récepteur. Le signal est ensuite comparé à la réponse provenant du composant sous test. Le niveau de référence doit être compris entre 0 dBm et –35 dBm.


Measure Unratioed

Mesure : Puissance absolue

Voir aussi ...

Modifie la trace de mesure active.

Trace Type : Unratioed Power. Définition d'une entrée unique, uniquement pour la mesure d'amplitude de puissance absolue. Vous ne pouvez pas utiliser le moyennage sur des entrées seules ou effectuer des mesures de phase ou de temps de propagation de groupe.

Source Port. Indique quel port de test de l'analyseur émet la puissance de la source de l'analyseur.

Input. Indique le port de test d'entrée de l'analyseur. C'est le port par lequel la réponse du composant sous test est entrée dans l'analyseur. Vous pouvez accéder aux ports d'entrée en retirant les câbles de la face avant.


Modification du kit d'étalonnage

Voir aussi ...

Permet de modifier les définitions des étalons contenus dans un kit d'étalonnage.

Kit d'étalonnage

Cal Kit ID. Indique le kit d'étalonnage que vous souhaitez modifier. Les kits 1 à 6 correspondent à des définitions de kit d'étalonnage prédéfinies. Les kits 7 à 10 correspondent à des définitions de kit d'étalonnage définies par l'utilisateur.

Cal Kit Name. Indique le type de connecteur et le numéro ou le nom de modèle du kit d'étalonnage que vous souhaitez modifier.

Restore Default Kit. Rétablit les valeurs prédéfinies du kit d'étalonnage actuellement sélectionné.

Restore All Default Kits. Rétablit les valeurs prédéfinies de tous les kits d'étalonnage.

Attribution des étalons aux ports

Port 1, Port 2. Indique le type de connecteur de port.

S11A, S11B, S11C, S21T. Classes pour l'attribution des étalons au Port 1 : trois réflexions et une transmission.

S22A, S22B, S22C, S12T. Classes pour l'attribution des étalons au Port 2 : trois réflexions et une transmission.

Modification de la définition des étalons

Standard No. Indique à quel étalon la définition s'applique.

Min Freq., Max Freq. Indique la plage de fréquences dans laquelle l'étalon fonctionne.

Z0. Indique l'impédance caractéristique du système.

Delay. Spécifie une longueur de ligne de transmission uniforme entre l'étalon défini et le plan de mesure réel.

Loss. Spécifie les pertes d'énergie, dues à l'effet de peau, le long d'une longueur simple d'un câble coaxial.

Type.Indique le type d'étalon que vous modifiez.

Character.Indique si l'étalon est un câble coaxial ou un guide d'onde.

Label.Indique une description de l'étalon que vous modifiez.

C0, C1, C2, C3. Indique la capacitance de distorsion de l'étalon en circuit ouvert.

L0, L1, L2, L3. Indique l'inductance résiduelle de l'étalon en court-circuit.


New Trace

Nouvelle trace

Voir aussi ...

Crée et définit une trace de mesure supplémentaire.

Trace Type : S-Parameters. Indique la direction de circulation du signal du composant en cours de test. La convention est S out in ; où le premier nombre (out) fait référence au port du composant en cours de test d'où sort le signal et le second nombre (in) est le port du composant en cours de test où le signal est entré.

S11. Indique que la mesure correspond au rapport complexe entre le signal sortant du port 1 du composant en cours de test et le signal entré au niveau du port 1 du composant.

S21.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 2 du composant en cours de test et le signal entré au niveau du port 1 du composant.

S12.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 1 du composant en cours de test et le signal entré au niveau du port 2 du composant.

S22.Indique que la mesure correspond au rapport complexe entre le signal sortant du port 2 du composant en cours de test et le signal entré au niveau du port 2 du composant.

Channel Number. Indique quelle voie ajoute la nouvelle trace.

Create in New Window. Lorsque cette case est cochée, une nouvelle trace de mesure de paramètres S est créée dans une nouvelle fenêtre. Lorsqu'elle n'est pas cochée, la trace est créée dans la fenêtre active.


New Trace Arbitrary Ratio

Nouvelle trace : rapport arbitraire

Voir aussi...

Crée et définit une trace de mesure supplémentaire.

Trace Type : Arbitrary Ratio. Définition d'une mesure de rapport de puissance.

Source Port. Indique quel port de test de l'analyseur émet la puissance de la source de l'analyseur.

Input. Indique le port de test d'entrée de l'analyseur. C'est le port par lequel la réponse du composant en cours de test est introduite dans l'analyseur. Vous pouvez accéder aux ports d'entrée en retirant les câbles de la face avant.

Reference. Indique le port de référence de l'analyseur. De ce port, une partie du signal de source de l'analyseur est acheminée vers l'entrée de la voie R du récepteur. Le signal est ensuite comparé à la réponse provenant du composant en cours de test. Le niveau de référence doit être compris entre 0 dBm et –35 dBm.

Channel Number. Indique quelle voie ajoute la nouvelle trace.

Create in New Window. Lorsque cette case est cochée, une nouvelle trace de mesure est créée dans une nouvelle fenêtre. Lorsqu'elle n'est pas cochée, la trace est créée dans la fenêtre active.


New Trace Unratioed

Nouvelle trace : Puissance absolue

Voir aussi ...

Crée et définit une trace de mesure supplémentaire.

Trace Type : Unratioed Power. Définition d'une entrée unique, uniquement pour la mesure d'amplitude de puissance absolue. Vous ne pouvez pas utiliser le moyennage sur des entrées seules ou effectuer des mesures de phase ou de temps de propagation de groupe.

Source Port. Indique quel port de test de l'analyseur émet la puissance de la source de l'analyseur.

Input. Indique le port de test d'entrée de l'analyseur. C'est le port par lequel la réponse du composant en cours de test est introduite dans l'analyseur. Vous pouvez accéder aux ports d'entrée en retirant les câbles de face avant.

Channel Number. Indique la voie dont les attributs seront appliqués à la nouvelle trace.

Create in New Window. Lorsque cette case est cochée, une nouvelle trace de mesure de paramètres S est créée dans une nouvelle fenêtre. Lorsqu'elle n'est pas cochée, la trace est créée dans la fenêtre active.


Number of Points

Nombre de points

Voir aussi...

Définit le nombre de points de données acquis par l'analyseur au cours d'un balayage de mesure. Vous pouvez spécifier n'importe quel nombre compris entre 2 et 1601. La valeur par défaut est 201.


Open

Récupération

Voir aussi ...

Récupération d'un fichier mémorisé dans l'analyseur.

Look in. Permet la sélection du répertoire qui contient le fichier à récupérer.

File name : Affiche le nom du fichier que vous avez tapé ou sélectionné à l'aide de la souris dans l'arborescence des répertoires.

Files of type. Permet l'affichage et la sélection de fichiers d'un type particulier, répertoriés dans des catégories.

Recall. Récupère le fichier correspondant au nom de fichier sélectionné.


Contrôle de l'opérateur

Utilisez Operator's Check pour contrôler les pannes évidentes des parties suivantes de l'analyseur de réseau :

  • Le commutateur RF de l'ensemble de test

  • Les diverses plages d'atténuation des atténuateurs des ports de test

Procédure de contrôle de l'opérateur

  1. Dans le menu System de l'analyseur, pointez sur Service et cliquez sur Operator's Check. La fenêtre Operator's Check s'affiche.

  2. Dans Sequencing, sélectionnez Automatic ou Prompted.

    • Automatic prépare le logiciel aux tests de répétitivité du commutateur et des sept plages d'atténuation avec un intervalle de 0,25 secondes entre chaque test.

    • Prompted demande au logiciel d'attendre une confirmation avant d'exécuter chaque test de plage d'atténuation.

  3. Cliquez sur Start-Port 1. Lorsque vous y êtes invité, connectez un court-circuit étalon issu d'un kit d'étalonnage et le port de test 1.

  • L'analyseur de réseau affiche le message PASS (Réussi) ou FAIL (Echoué) à la fin de chaque test.

  • A la fin des huit tests, la fenêtre Operator's Check réapparaît et présente un résumé des résultats des tests de chaque port. Si certains tests ont échoué, reportez-vous au chapitre 3 du manuel de maintenance.


Option_Enable

Utilitaire de validation d'option

L'utilitaire de validation d'option permet d'exécuter les actions suivantes.

  • Ajouter ou retirer les options logicielles et certaines options matérielles.

  • Récupérer les données d'option en cas de remplacement du disque dur ou d'un autre ensemble contenant des données.

  • Introduire ou modifier un numéro de série.

Cliquez sur les boutons pour afficher les informations.

Mots-clés

Exécution du programme

Retrait d'une option

Installation d'une option

Réparation et récupération des données d'option

Installation ou modification du numéro de série

Mots-clés

Pour ajouter certaines options, vous avez besoin d'un mot-clé fourni par Agilent. Il existe deux types de mots-clés :

  • Les mots-clés d'option pour ajouter une option logicielle.

  • Les mots-clés de modèle qui peuvent être nécessaires si vous remplacez des ensembles multiples.

Options temporaires et permanentes

Toutes les options logicielles peuvent être installées de manière temporaire pour une période de temps spécifiée. Cela permet l'évaluation d'une fonction ou d'une capacité particulière gratuitement.

Si la clé de licence fournie par Agilent comporte une date d'expiration, vous devez sélectionner l'option "temporaire" et entrer la date d'expiration exactement telle que définie dans la licence. Si vous souhaitez rendre cette option permanente, Agilent fournira un nouveau mot-clé qui la convertira en option permanente.

Que ce soit pour des options matérielles ou logicielles, un mot-clé fourni doit être saisi.

Exécution du programme

  1. Dans le menu System de l'analyseur, pointez sur Service et cliquez sur Option Enable.

  2. Le premier écran affichera le numéro du modèle, le numéro de série et toutes les options installées. Pour ajouter ou retirer une option, sélectionnez-la dans la liste déroulante des options disponibles.

    • Si vous ne trouvez pas l'option souhaitée, sélectionnez le dernier choix de la liste intitulé Enter Unlisted Option.

Si vous choisissez une option logicielle, les évènements suivants se produisent.

  • Le bouton "Remove" est activé.

  • La zone d'entrée de mot-clé devient visible.

  • La sélection permanente/temporaire est activée.

Si vous choisissez une option matérielle, les évènements suivants se produisent.

  • Si l'option matérielle est déjà installée, le bouton Remove est activé.

  • Si l'option matérielle n'est pas installée, le bouton Install est activé.

Retrait d'une option

  1. Pour retirer une option, cliquez sur le bouton Remove.

  2. Après le retrait de l'option, redémarrez l'application de l'analyseur de réseau pour que toutes les modifications soient prises en compte.

Installation d'une option

  1. Si la zone d'entrée de mot-clé est visible, entrez le mot-clé. (Les majuscules et minuscules n'ont pas d'importance)

  2. Cliquez sur Install.

  3. Après l'installation de l'option, redémarrez l'application de l'analyseur de réseau pour que toutes les modifications soient prises en compte.

Réparation et récupération des données d'option

Utilisez cette partie de l'utilitaire de validation d'option dans les situations suivantes :

  • Si le disque dur est remplacé

  • Si l'ensemble de référence de fréquence est remplacé

Ce programme rétablit les informations d'option contenues sur le disque dur et sur l'ensemble de référence de fréquence (principal et de sauvegarde).

  1. Sélectionnez Repair dans le barre de menu Option Enable Utility.

Remarque : Si vous n'êtes pas certain que ce programme doit être lancé, faites-le de toute manière, il n'en résultera aucun dommage.

  2. Les numéros de modèle et de série sont affichés, ainsi que quatre cases à cocher.

  3. Cochez les cases qui correspondent à votre cas.

  4. Cliquez sur Begin Repair. Le programme vérifie tous les fichiers de données et effectue toutes les réparations nécessaires. La vérification de certaines informations et de certains traitements peut être demandée.

  5. Si le programme identifie un numéro de modèle incorrect ou non valide, il vous sera demandé de sélectionner le numéro de modèle correct.

    • En plus du numéro de modèle, un mot-clé de modèle sera nécessaire.

    • S'il n'est pas inscrit sur l'analyseur ou autrement connu, contactez Agilent.

    • Après avoir entré les données demandées, cliquez sur Change Model. Ce traitement prend environ 30 secondes.

  6. Après cela, sélectionnez Exit Repair.

  7. Si aucune autre option ne doit être installée, cliquez sur Exit.

Introduction ou modification du numéro de série

Il peut être nécessaire de saisir ou de modifier un numéro de série en cas de remplacement de certains ensembles.

  1. Pour modifier le numéro de série, sélectionnez Change Serial dans la barre de menu Option Enable. Le numéro de série actuel sera affiché. Si aucun numéro de série n'a été précédemment saisi, "NONE" sera affiché.

  2. Tapez le nouveau numéro de série dans l'espace prévu et cliquez sur Change Serial. (Les majuscules et minuscules n'ont pas d'importance)

Remarque : Faites très attention lors de la saisie du numéro de série, un seul essai est autorisé !

  3. Pour modifier un numéro de série incorrect, un mot de passe de code d'effacement sera nécessaire. Contactez Agilent pour obtenir ce code d'effacement et rendre accessible le numéro de série existant.

  4. Pour modifier le numéro de série, saisissez le code d'effacement dans l'espace prévu ainsi que le nouveau numéro de série, cliquez ensuite sur Change Serial.


Déphasage

Voir aussi...

Décale mathématiquement une mesure de phase d'une quantité spécifiée, jusqu'à 360°.


Extensions de port

Voir aussi ...

Etend le plan de référence de la mesure . Il est destiné à une utilisation après un étalonnage, évitant d'avoir à refaire un autre étalonnage.

Port Extensions. Lorsqu'il est coché, applique la fonction d'extension de port au(x) port(s) spécifié(s).

Input A. Définit la distance d'extension du plan de référence de l'entrée A.

Input B. Définit la distance d'extension du plan de référence de l'entrée B.

Port 1.Définit la distance d'extension du plan de référence du port 1.

Port 2. Définit la distance d'extension du plan de référence du port 2.

Velocity Factor. Définit le coefficient de vitesse qui s'applique au milieu du dispositif qui a été inséré après l'étalonnage de la mesure. La valeur pour un câble à diélectrique en polyéthylène est de 0,66 et de 0,7 pour un diélectrique en téflon.


Niveau de puissance

Voir aussi...

Définit et contrôle la puissance de la source de l'analyseur.

Mise en marche. Active et désactive la puissance de la source.

Sélection du port

Port. Définit le port auquel les valeurs sont appliquées.

Puissance du port couplée Permet le basculement entre une puissance de port de test couplée et non couplée. Si les ports sont couplés, les niveaux de puissance sont identiques à chaque port de test. Si les ports ne sont pas couplés, les niveaux de puissance sont différents pour chaque port de test.

Puissance du port de test Règle la valeur de la puissance à la sortie du port de test.

Commande de l'atténuateur

Atténuation à couplage automatique. Permet un basculement entre une commande couplée et non couplée de l'atténuateur et de la puissance de la source. Si l'atténuateur et la puissance de la source sont couplés, n'importe quel niveau de puissance peut être sélectionné dans la plage de fonctionnement de l'analyseur et l'atténuateur commutera automatiquement sur la valeur nécessaire. Si l'atténuateur et la source de puissance ne sont pas couplés, vous pouvez régler séparément la valeur d'atténuation et la puissance de la source.

Atténuation. Définit la valeur d'atténuation placée dans le circuit de sortie de la source. Cela ne s'applique qu'au cas où l'atténuateur et la puissance de la source ne sont pas couplés.

Rampe de puissance

Rampe. Active et désactive la fonction rampe de puissance.

Rampe dB/GHz Compense la perte de puissance dans le composant au cours d'un balayage de la fréquence en augmentant la puissance de sortie de l'analyseur en fonction de la fréquence.


Powerststop

Réglages du balayage de puissance

Voir aussi ...

Start Power. Définit la valeur de puissance au début du balayage.

Stop Power. Définit la valeur de puissance à la fin du balayage.

Attenuation. Définit l'atténuation pour que vous puissiez régler le balayage sur des niveaux de puissance inférieurs.


Receiver Calibration

Etalonnage de réception

L'étalonnage de réception ajuste les récepteurs de l'analyseur de réseau pour une réponse constante sur toute sa plage de fréquences.

Equipement requis

  • Milliwattmètre : HP/Agilent E4419B (recommandé), E4419A ou EPM-442A

  • Sonde de puissance HP/Agilent 8482A

  • Sonde de puissance HP/Agilent E4412A (non requise avec l'analyseur de réseau E8356A)

  • Câble RF HP/Agilent N6314A

  • Adaptateur femelle-femelle Type-N HP/Agilent 1250-0777

Présentation de la procédure

  1. Assurez-vous que les facteurs d'étalonnage de la sonde 8482A aient été entrés dans le tableau nommé HP8482A du milliwattmètre.

  2. Connectez un câble GPIB entre le milliwattmètre et l'analyseur de réseau.

  3. Assurez-vous que la sonde 8482A (et la sonde E4412A pour les analyseurs E8357A/58A) soit connectée au milliwattmètre.

  4. Dans le menu System de l'analyseur, pointez Service, Adjustments et cliquez sur Receiver Calibration.

  5. Le logiciel commence par identifier le type d'analyseur de réseau. Trois choix s'offrent alors à l'utilisateur :

    • Un clic sur le bouton Inspect Flatness permet à l'utilisateur d'observer la constance de la réponse du récepteur par rapport à la fréquence. Si cette action est réalisée avant et après l'étalonnage du récepteur, l'utilisateur devrait pouvoir observer la différence (meilleure constance de la réponse du récepteur par rapport à la fréquence) créée par l'étalonnage du récepteur.

    • Un clic sur le bouton Calibrate démarre le processus d'étalonnage du récepteur. Le logiciel vous invite à connecter les sondes, le câble et l'adaptateur, selon le cas (voir les Figures 1 à 3 ci-dessous).

Connexion de la sonde au port de l'analyseur

Connexion de l'adaptateur et du câble entre la sonde et le port de l'analyseur

Connexion directe à l'aide d'un câble Type-N

Dépannage

Dans l'éventualité où un problème surviendrait lors de l'étalonnage de réception, veuillez consulter le Chapitre 3, Dépannage, du Guide de maintenance de l'analyseur de réseau E8356A/57A/58A.


Save As

Sauvegarder sous

Voir aussi...

Sauvegarde un fichier sous le nom de fichier et à l'emplacement spécifiés.

Save in. Permet de sélectionner le répertoire dans lequel vous souhaitez sauvegarder le fichier.

File name. Affiche le nom de fichier que vous avez saisi ou sur lequel vous avez cliqué dans la zone de contenu du répertoire.

Save as type. Permet de sélectionner l'un des types de fichier que l'analyseur peut sauvegarder à partir d'une liste. *.cst, *.sta et *.cal sont les seuls types de fichier pouvant être rappelés par l'analyseur. (Les traces de mesure doivent être dans l'état Hold pour être sauvegardées.)

Save. Sauvegarde le fichier sous le nom de fichier et dans le répertoire sélectionnés.


Scale Box

Echelle

Voir aussi ...

Spécifie les paramètres requis pour visualiser une réponse de mesure.

Echelle

Per Division. Spécifie la valeur des divisions verticales de la grille de l'écran.

Auto. Règle l'échelle de la trace de données active verticalement afin qu'elle s'inscrive dans la zone de la grille de l'écran.

Auto All. Dans la fenêtre active, met à l'échelle l'ensemble des traces de données verticalement afin qu'elles s'inscrivent dans la zone de la grille de l'écran.

Référence

Level. Spécifie la valeur de la ligne de référence en format Cartésien ou du cercle extérieur en format polaire

Position. Spécifie la position de la ligne de référence, où le haut de la grille est 10 et le bas de la grille est 0. La position par défaut est le milieu de la grille, à 5.


Serial_Bus

Test du bus série

Ce test est prévu pour fonctionner avec l'analyseur de réseau PNA Series tel qu'il était à sa sortie d'usine. Si l'un des composants ci-après a été remplacé dans l'analyseur, il est possible que ce test ne renvoie pas des résultats réussite/échec précis.

  • A8

  • A10

  • A11

  • A12

Ce test analyse séquentiellement les 32 noeuds à 300 kHz, puis tous les noeuds dont les valeurs changent avec la fréquence à 11 autres fréquences. Toutes les valeurs mesurées sont consignées dans un fichier ASCII dans le répertoire de service. Les valeurs mesurées qui dépassent leurs tolérances sont mises en surbrillance dans l'application et le fichier de données.

Les composants testés et leurs numéros de noeud associés sont les suivants :

Carte | Numéros de noeud
Composant source A12 | 111 à 118
Référence de la fréquence A10 | 211 à 218
Verrouillage de phase A11 | 311 à 318
Synthétiseur N fractionnel A8 | 411 à 418

Mise en oeuvre du test du bus série

Dans le menu System de l'analyseur, pointez Service et cliquez sur Serial Bus Test, Run.

Remarque : si un message d'erreur s'affiche, consultez le Guide de maintenance.


SICL_GPIB

SICL/GPIB

Voir aussi...

GPIB

Talker/Listener. Configure l'analyseur pour qu'il reçoive et envoie des messages GPIB/SCPI au contrôleur système (ordinateur externe).

Talker/Listener Address. Définit l'adresse GPIB de l'émetteur/récepteur de l'analyseur.

System Controller. Configure l'analyseur en tant que contrôleur système pour qu'il contrôle les communications GPIB des périphériques externes.

System Controller Address. Définit l'adresse GPIB du contrôleur système de l'analyseur.

SICL

SICL Enabled. Lorsque cette case est cochée, l'analyseur est capable d'exécuter des programmes GPIB sur son ordinateur afin de contrôler les fonctions de l'analyseur. Les programmes doivent être exécutés dans un environnement de programmation compatible GPIB (VEE, Visual Basic). Ce mode ne permet pas de contrôler les instruments GPIB externes.

Address. Définit l'adresse de l'analyseur.

GPIB Command Processor Console. Ouvre une fenêtre permettant d'envoyer des commandes SCPI/GPIB simples.

  • Entrez une commande valide, avec les arguments appropriés, et appuyez sur la touche Entrée.

  • Utilisez les touches fléchées pour rappeler les commandes précédentes.

  • Appuyez sur les touches Ctrl+Z pour fermer la fenêtre de la console.

  • La fenêtre de la console peut s'ouvrir en arrière-plan de l'application de l'analyseur. Appuyez sur les touches Ctrl+Tab pour placer la fenêtre de la console au premier plan.


Smoothing

Lissage

Voir aussi...

Smoothing ON. Lorsque cette case est cochée, la fonction de lissage, qui calcule la moyenne des données, est appliquée sur une portion de la trace affichée.

Per Cent of Span. Spécifie l'ouverture du lissage comme un pourcentage compris entre 1,9 % et 25 % de la bande d'analyse balayée du stimulus.

Points. Spécifie l'ouverture du lissage comme un pourcentage du nombre total de points de mesure dans la bande d'analyse balayée du stimulus.


Source Calibration

Etalonnage de la source

L'étalonnage de la source règle l'analyseur de réseau pour une puissance constante de la source en fonction de la fréquence sur sa plage de fréquences complète.

Equipement requis

  • Milliwattmètre : HP/Agilent E4419B (recommandé), E4419A ou EPM-442A

  • Sonde de puissance HP/Agilent 8482A

  • Sonde de puissance HP/Agilent E4412A (non requise avec l'analyseur de réseau E8356A)

  • Câble HP/Agilent N6314A RF

Procédure

  1. Assurez-vous que les facteurs d'étalonnage corrects ont été entrés pour la sonde 8482A dans le tableau nommé HP8482A sur le milliwattmètre.

  2. Branchez un câble GPIB entre le milliwattmètre et l'analyseur de réseau.

  3. Assurez-vous que la sonde 8482A (et la sonde E4412A pour les analyseurs E8357A/58A) soit connectée au milliwattmètre.

  4. Dans le menu Service de l'analyseur, pointez Adjustments et cliquez sur Source Calibration.

  5. Le logiciel commence par identifier le type d'analyseur de réseau. Trois choix s'offrent alors à l'utilisateur :

    1. Un clic sur le bouton Inspect Linearity permet à l'utilisateur d'observer la linéarité du changement de la puissance de la source sur la plage de fréquences lorsque le niveau de puissance est changé. Si cette opération est réalisée avant et après l'étalonnage de la source, l'utilisateur devrait être capable de voir la différence (la puissance change de façon plus linéaire sur la plage de fréquences lorsque le niveau de puissance est changé) grâce à l'étalonnage de la source.

    2. Un clic sur le bouton Inspect Amplitude permet à l'utilisateur d'observer la constance de la puissance de la source en fonction de la fréquence pour trois niveaux de puissance : -5 dBm, 0 dBm et +5 dBm. Si cette opération est réalisée avant et après l'étalonnage de la source, l'utilisateur devrait être capable de voir la différence (amélioration de la constance de la puissance en fonction de la fréquence à chaque niveau de puissance) grâce à l'étalonnage de la source.

    3. Un clic sur le bouton Calibrate démarre le processus d'étalonnage de la source. Le logiciel demande à l'utilisateur où connecter les sondes et le câble requis (voir les Figures 1 et 2 ci-dessous).

Connexion de la sonde au port de l'analyseur de réseau

Connexion directe à l'aide du câble Type-N spécifié

Complément d'information

L'étalonnage procède alors à l'identification des paramètres DAC utilisant le Port 1 uniquement, car on suppose que les ports sont symétriques.

Remarque : l'étalonnage de la source dure au moins 20 minutes (E8356A), 45 minutes au plus (E8358A).

Dépannage

Dans l'éventualité où un problème surviendrait avec l'étalonnage de la source, veuillez vous reporter au Chapitre 3, Dépannage, du Guide de maintenance de l'analyseur de réseau E8356A/57A/58A.


Start and Stop Frequencies

Fréquences de début et de fin

Voir aussi...

Start. Spécifie la fréquence au début de la plage de mesure balayée.

Stop. Spécifie la fréquence à la fin de la plage de mesure balayée.


Sweep Setup

Configuration du balayage

Voir aussi...

Channel. Spécifie la voie à laquelle s'appliquent les paramètres.

Stepped Sweep. Lorsque cette case est cochée, la source passe à chaque point de mesure par paliers.

Dwell Time. Spécifie le temps durant lequel la source reste sur chaque point de mesure avant que l'analyseur ne collecte les données, lorsqu'il est en mode de balayage par paliers.

Alternate Sweeps. Lorsque cette case est cochée, l'analyseur ne mesure qu'un seul récepteur par balayage.

External ALC. Lorsque cette case est cochée, l'analyseur reçoit le signal externe que vous envoyez pour niveler la sortie de la source. Le connecteur d'entrée du signal ALC externe est l'External Detector Input sur la face arrière.


Sweep Time

Temps de balayage

Voir aussi...

Spécifie la durée d'un balayage de mesure. Par défaut, l'analyseur maintient automatiquement le temps de balayage le plus rapide possible avec les paramètres de mesure sélectionnés. Cependant, vous pouvez également sélectionner un autre temps de balayage compatible avec la capacité de l'instrument. Entrez 0 seconde pour réactiver le temps de balayage automatique sur l'analyseur.


Sweep Type

Type de balayage

Voir aussi...

Channel. Spécifie la voie sur laquelle s'appliquent les paramètres.

Type de balayage

Linear Frequency. Active un balayage en fréquence linéaire affiché sur une grille standard avec dix divisions horizontales égales. Il s'agit du balayage par défaut prédéfini.

Start. Définit la valeur de début du balayage en fréquence.

Stop. Définit la valeur de fin du balayage en fréquence.

Points. Spécifie le nombre de points de données que l'analyseur collecte pendant un balayage de mesure. Vous pouvez définir la valeur entre 2 et 1601. La valeur par défaut est 201.

Power Sweep. Active un balayage en puissance à la fréquence spécifiée. Le balayage en puissance prédéfini commence à -10 dBm et s'arrête à 0 dBm. Vous pouvez définir n'importe quelle plage de puissance < 25 dB.

Start. Définit la valeur de début du balayage en puissance.

Stop. Définit la valeur de fin du balayage en puissance.

CW Frequency. Définit la fréquence sur laquelle l'analyseur reste durant le balayage de mesure.

CW Time. Active un mode où l'analyseur est réglé sur une seule fréquence et où les données sont affichées au lieu du temps.

CW Frequency. Définit la fréquence dans laquelle l'analyseur reste durant la mesure.

Sweep Time. Définit la durée de la mesure.

Points. Spécifie le nombre de points de données que l'analyseur collecte durant une mesure. Vous pouvez définir cette valeur entre 2 et 1601. La valeur par défaut est 201.

Segment Sweep. Active un balayage où l'analyseur collecte des données tout en balayant les points de fréquence définis. Vous pouvez définir jusqu'à 30 sous-balayages de fréquences, appelés segments. Pour chaque segment, vous pouvez définir indépendamment la puissance et la bande passante FI du port de test.

Independent Power Levels. Si coché, permet de définir le niveau de puissance de la source de manière distincte pour chacun des segments.

Independent IF Bandwidth. Si coché, permet de définir la bande passante FI de manière distincte pour chacun des segments.

Independent Sweep Time. Définit la durée de la mesure de chaque segment.

Show Table. Affiche le tableau qui vous permet de créer et de modifier les segments.

Hide Table. Fait disparaître le tableau de segments de l'écran.


System Verification

Vérification du système

Cette routine vérifie le fonctionnement système de l'analyseur en mesurant automatiquement l'amplitude et la phase des quatre paramètres S de chaque dispositif de vérification et en comparant ces valeurs aux valeurs suivantes :

  • Données mesurées en usine des fichiers sur le disque de vérification

  • Gabarits en fonction de l'incertitude de la mesure

Remarque : bien que les performances des quatre paramètres S soient mesurées, les incertitudes de phase sur S11 et S22 sont moins importantes pour vérifier les performances système. Aussi, elles ne sont pas utilisées et n'apparaissent pas sur les sorties imprimées.

Cliquez sur les boutons ci-dessous pour afficher les informations correspondantes.

Equipement utilisé dans la vérification du système

Substitution des câbles

Substitution du kit d'étalonnage

Précautions à prendre avec les lignes à air

Organigramme de procédures

Procédure de vérification système

Si le système échoue au test de vérification

Interprétation des résultats de la vérification

Equipement utilisé dans la vérification du système

Kit d'étalonnage (Type-N)1,2 | 85032F
Module ECal (Type-N)3 | 85092B
Kit de vérification (Type-N) | 85055A
Câble RF (Type-N) | N6314A
1 Utilisez soit le kit d'étalonnage, soit le module ECal.
2 Autre choix possible : kit d'étalonnage 85033E 3,5 mm.
3 Autre choix possible : module ECal 85093B 3,5 mm.

Substitution des câbles

Les câbles du port de test spécifiés pour l'analyseur de réseau ont été conçus pour préserver la stabilité de la phase, l'amplitude et la répétitivité du connecteur malgré la torsion, la perte en réflexion, la perte d'insertion et le vieillissement. Comme les performances des câbles du port de test contribuent de façon importante aux performances système, les câbles de moindre performance augmentent l'incertitude de vos mesures. Il est vivement recommandé de tester régulièrement les câbles du port de test.

Si la vérification système est réalisée avec un câble non Agilent, assurez-vous que ce câble satisfasse ou dépasse les performances du câble N6314A Type-N. Pour plus d'informations, consultez le guide de l'utilisateur N6314A.

Substitution du kit d'étalonnage

Les kits d'étalonnage non Agilent ne sont ni recommandés, ni supportés.

Précautions à prendre avec les lignes à air

Si vous utilisez des lignes à air dans le kit de vérification, suivez les consignes ci-après pour optimiser les techniques de mesure.

  • Prenez garde de ne pas laisser tomber le conducteur central ou externe de la ligne à air. La chute de ces dispositifs risquerait de causer des dommages.

  • Appliquez des procédures ESD (Electro-Static Discharge) correctes.

  • Lavez-vous les mains ou portez des gants. La sueur peut modifier les performances électriques.

Organigramme de procédures

Le flux opérationnel du logiciel est illustré par le diagramme ci-dessous.

Procédure de vérification du système

  1. Connectez un câble au Port 2 de l'analyseur. Si vous souhaitez imprimer les résultats du test, connectez une imprimante à l'analyseur. Laissez l'analyseur préchauffer pendant au moins 30 minutes.

Configuration du test de vérification du système

  2. Insérez la disquette du kit de vérification PNA dans le lecteur de disquette de l'analyseur.

  3. Dans le menu System, pointez Service et cliquez sur System Verification. La fenêtre System Verification apparaît.

Fenêtre System Verification

  4. Dans le zone Calibration Kit, sélectionnez le kit d'étalonnage que vous utilisez. Le kit d'étalonnage correspondant apparaît dans la zone Verification Kit.

  5. Sous Printer Output, cliquez sur l'une des options suivantes :

    • None : pas d'impression des résultats.

    • Tabular Data : imprime les données de vérification sous forme tabulaire avec les données mesurées et les limites d'incertitude. Consultez l'exemple de données tabulaires, plus loin dans cette rubrique.

    • Measurement Plots : imprime les données de vérification sous forme graphique. Le graphique inclut la trace des données mesurées, la trace des données fournies en usine et les limites d'incertitude. Consultez l'exemple de données tracées, plus loin dans cette rubrique.

    • Both : imprime les données de vérification dans les deux formes.

Remarque : si vous désirez des sorties imprimées, assurez-vous d'avoir installé le pilote Windows 2000 correspondant à votre imprimante et d'avoir testé l'impression sur l'imprimante à partir de l'analyseur de réseau. Ce logiciel est conçu pour imprimer sur n'importe quelle imprimante couramment définie comme imprimante par défaut (voir Imprimantes dans le Panneau de configuration de Windows).

  6. Le menu System Verification Configure vous permet d'agir sur la procédure de vérification système de deux manières :

    • Le sous-menu Calibration vous permet de choisir entre deux étalonnages.

      • L'option Perform a calibration (par défaut) prépare le logiciel à vous guider à travers la réalisation d'un étalonnage sur deux ports à l'aide du kit d'étalonnage sélectionné.

      • L'option Load previous calibration prépare le logiciel à vous demander le fichier d'état de l'instrument étalonné (*.cst) précédemment sauvegardé à l'aide du logiciel de vérification système.

    • Le sous-menu Devices to Measure vous permet de sélectionner les étalons qui seront mesurés lors de la procédure de vérification du système. Par défaut, tous les étalons du kit sont sélectionnés. Pour que la vérification du système soit vraiment adéquate, le logiciel doit mesurer tous les étalons du kit.

  7. Cliquez sur Run.

  8. Insérez les étalons comme indiqué lorsqu'ils vous sont demandés durant la vérification du système.

Connexions du dispositif de vérification

Description pas à pas du processus

  1. Selon la sélection faite dans le sous-menu Calibration du menu Configure, soit le système demande à l'utilisateur de rappeler un ancien état de l'instrument étalonné, soit il le guide à travers un étalonnage complet sur deux ports à l'aide du kit d'étalonnage sélectionné. Pour ECal, le module ECal n'est connecté qu'une seule fois. Un message d'attente s'affiche pendant que le logiciel réalise l'étalonnage.

  2. L'utilisateur est invité à connecter le premier étalon de vérification.

  3. Le logiciel lit les données mesurées en usine de ce dispositf et les valeurs d'incertitude de ces données (CITIfiles) à partir de la disquette fournie avec le kit de vérification.

  4. Le logiciel envoie les données mesurées en usine, le kit d'étalonnage et les informations d'état de l'instrument à la DLL de calcul d'incertitude, qui génère des valeurs d'incertitude spécifiques au PNA.

  5. L'analyseur configure d'abord les mesures d'amplitude pour les quatre paramètres S, avec une fenêtre distincte pour chaque paramètre (lin mag pour S11 et S22, log mag pour S21 et S12). Chacun des paramètres S mesuré en usine est placé dans la fenêtre appropriée en tant que trace mémoire. Les décalages de gabarit sont calculés en additionnant les incertitudes des données mesurées en usine et les incertitudes PNA fournies par la DLL. Les limites supérieures et inférieures sont affichées (données mesurées en usine + somme des incertitudes, données mesurées en usine - somme des incertitudes). Le PNA effectue un balayage, le test par gabarit est activé et l'état PASS/FAIL est affiché dans chacune des quatre fenêtres.

  6. L'utilisateur clique sur un bouton lorsqu'il est prêt à visualiser les mesures de phase. Les quatre fenêtres sont mises à jour afin de refléter le format de phase, les traces de mémoire de phase, les limites de phase et le résultat PASS/FAIL.

  7. Si le test par gabarit de l'un des quatre paramètres S (amplitude ou phase) indique un état FAIL, le logiciel suggère des astuces de dépannage et demande à l'utilisateur s'il souhaite réitérer la mesure de ce dispositif ou passer au dispositif suivant. Si l'utilisateur choisit de passer au dispositif suivant, les données mesurées en usine et les incertitudes de ce dispositif sont lues à partir de la disquette, la DLL d'incertitude est appelée avec le jeu suivant de données mesurées en usine et les quatre fenêtres de mesure sont mises à jour afin de refléter la mesure d'amplitude du dispositif suivant.

  8. Le logiciel suit ce même processus jusqu'à ce que tous les étalons sélectionnés aient été mesurés. A ce stade, une fenêtre de récapitulatif s'affiche et présente les résultats PASS/FAIL des quatre paramètres de chaque étalon.

Si le système échoue au test de vérification

IMPORTANT : inspectez toutes les connexions. Ne débranchez pas le câble du port de test de l'analyseur. Ceci aurait pour effet d'annuler le dernier étalonnage.

  1. Répétez ce test de vérification. Réalisez des connexions correctes en respectant les spécifications de serrage pour chaque étalon de vérification.

  2. Déconnectez, nettoyez et reconnectez l'étalon qui a échoué au test de vérification. Puis, mesurez à nouveau ce dispositif.

  3. Si l'analyseur échoue toujours au test, vérifiez l'étalonnage de la mesure en consultant les conditions d'erreur décrites à la section "Front Panel Access to Error Terms", page 4-7 du Guide de maintenance.

  4. Consultez le graphique ci-dessous pour découvrir les autres étapes de dépannage.

Diagramme des échecs de la vérification

Interprétation des résultats de la vérification

Le graphique ci-dessous montre un exemple type de résultats de vérification lorsque Tabular Data est sélectionné dans la zone Printer Output de la fenêtre System Verification. Un graphique plus loin dans cette rubrique montre un exemple type de résultats de vérification avec Measurement Plots sélectionné dans la zone Printer Output de la fenêtre System Verification. Ces sorties imprimées incluent une comparaison des données de vos résultats de mesure avec les données traçables et les spécifications d'incertitude correspondantes. Utilisez ces sorties imprimées pour déterminer si vos données mesurées se trouvent dans les limites d'incertitude totales à toutes les fréquences.

Les données tabulaires comprennent :

  • Fréquence des points de données (en MHz).

  • Gabarit inférieur tel que défini par les spécifications d'incertitude système totale.

  • Résultats de la mesure.

  • Gabarit supérieur tel que défini par les spécifications d'incertitude système totale.

  • Etat du test (PASS ou FAIL) de ce point de mesure.

Sortie imprimée des résultats de vérification tabulaire

Les résultats graphiques imprimés montrent :

  • Les points limites supérieurs tels que définis par les spécifications d'incertitude système totale.

  • Les points limites inférieurs tels que définis par les spécifications d'incertitude système totale.

  • Les données mesurées en usine.

  • Les résultats des mesures.

  • Les noms et les formats des paramètres de mesure (Lin Mag ou Log Mag).

  • Le numéro de série du dispositif (00810).

  • L'étalon actuellement mesuré (atténuateur Sys Ver 20 dB).

Sortie imprimée des résultats de vérification graphique


Trace Statistics

Statistiques sur les traces

Voir aussi...

Statistics. Lorsque cette case est cochée, calcule la valeur moyenne, l'écart type et la valeur crête à crête de la trace active.

Span. Spécifie la bande d'analyse de la trace active dans laquelle des données sont collectées pour une opération mathématique. Vous pouvez définir jusqu'à 9 bandes d'analyse utilisateur pour chaque trace. Vous pouvez également définir les bandes d'analyse utilisateur à partir de la boîte de dialogue Marker Search.

Start. Définit la fréquence de début d'une bande d'analyse utilisateur.

Stop. Définit la fréquence d'arrêt d'une bande d'analyse utilisateur.


Transform

Transformation du domaine temporel

Voir aussi...

Permet de visualiser la réponse d'un composant en fonction du temps.

Transform. Lorsque cette case est cochée, l'analyseur applique une fonction mathématique qui transforme les données de mesure de la fréquence en données de mesure temporelles.

Start. Spécifie le début de la tranche de temps dans laquelle l'analyseur mesure les données. Une heure de début de 0 seconde définit le début de la plage de mesure au plan de référence de la mesure.

Stop. Spécifie la fin de la tranche de temps dans laquelle l'analyseur mesure les données. En fait, il s'agit du temps écoulé depuis l'émission d'un signal de stimulus.

Center. Spécifie la valeur au centre de la plage de mesure. Cette valeur peut se trouver n'importe où dans la plage de l'analyseur.

Span. Spécifie la plage de valeurs mesurées de part et d'autre de la valeur centrale.

Mode de transformation

Low Pass Impulse. Spécifie le mode de mesure des composants fontionnant à partir du courant cc. Affiche les mesures de réponse en impulsion.

Low Pass Step. Spécifie le mode de mesure des composants fontionnant à partir du courant cc. Affiche les mesures de réponse à un échelon.

Band Pass. Spécifie le mode de mesure des composants à largeur de bande limitée ne fontionnant à partir d'un courant cc. Ce mode n'affiche que les mesures de réponse en impulsion.

Set Frequency Low Pass. Distribue les points de mesure équitablement sur la plage en mode passe-bas. Ceci vous permet de réaliser un étalonnage de mesure avant que les données ne soient transformées dans le domaine temporel.


Transform Gate

Porte dans le domaine du temps

Voir aussi...

Permet de sélectionner des réponses dans le domaine temporel pour que l'analyseur les enlève mathématiquement de la mesure affichée.

Gating. Applique un filtre temporel qui supprime les réponses sélectionnées dans le domaine temporel.

Start. Spécifie l'instant de début du filtre temporel.

Stop. Spécifie l'instant de fin du filtre temporel.

Center. Spécifie la valeur au centre de la zone affectée par la fonction de sélection par porte. Cette valeur peut se trouver n'importe où dans la plage de l'analyseur.

Span. Spécifie la plage de part et d'autre de la valeur centrale de la zone affectée par la fonction de sélection par porte.

Gate Type. Définit le type de filtrage qui sera réalisé pour la fonction de sélection par porte.

Gate Shape. Définit les caractéristiques du filtre de la fonction de sélection par porte.


Transform Window

Fenêtre de domaine temporel

Voir aussi...

Applique un filtre qui vous aide à identifier les réponses individuelles en fonction du temps.

Minimum. Spécifie le filtre de fenêtre qui fournit une largeur d'impulsion étroite, ce qui permet d'obtenir une résolution optimale de la réponse.

Maximum. Spécifie le filtre de fenêtre qui abaisse les lobes latéraux d'un signal, ce qui permet d'obtenir une plage dynamique optimale.

Kaiser Beta. Permet de définir les caractéristiques de fenêtrage à l'aide d'une valeur Kaiser Beta.

Impulse Width. Permet de définir les caractéristiques de fenêtrage à l'aide d'une largeur d'impulsion.


Triggr

Déclenchement

Voir aussi...

Définit comment la source de l'analyseur fournit un stimulus à un composant sous test. Voir l'Animation de déclenchement.

Source de déclenchement

Internal. Règle l'analyseur pour qu'il envoie des signaux de déclenchement internes après chaque mesure. Ainsi, les balayages de mesure s'effectuent en continu.

Manual. Règle l'analyseur pour qu'il envoie un signal de déclenchement lorsque vous appuyez sur Trigger.

External. Règle l'analyseur pour qu'il attende un signal de déclenchement d'une source externe.

Etendue du déclenchement (uniquement pour les déclenchements manuels et externes)

Global. Règle l'analyseur pour qu'il effectue un balayage de mesure pour chaque voie, lorsqu'un signal de déclenchement est accepté.

Channel. Règle l'analyseur pour qu'il effectue un balayage de mesure pour une seule voie, lorsqu'un signal de déclenchement est accepté. Le déclenchement suivant entraîne un balayage de l'analyseur sur la voie suivante, et ainsi de suite.

Etat de déclenchement de la voie

Channel. Spécifie la voie sur laquelle les paramètres s'appliquent.

Continuous. Règle la voie pour qu'elle effectue un balayage de mesure chaque fois qu'un signal de déclenchement est accepté.

Enable Groups. Règle la voie pour qu'elle effectue un balayage de mesure lorsqu'un signal de déclenchement est accepté, jusqu'à ce que le nombre de balayages atteigne le nombre que vous aurez spécifié.

Number of Groups. Spécifie le nombre de balayages de mesure réalisés par la voie avant de passer en mode de maintien (Hold).

Single. Règle la voie pour qu'elle n'effectue qu'un seul balayage de mesure avant de passer en mode de maintien (Hold).

Hold. Règle la voie pour qu'elle garde les données de mesure précédentes et qu'elle n'effectue pas d'autre balayage de mesure.

Point Sweep. (Uniquement pour une source de déclenchement manuelle avec l'état de déclenchement de voie.) Positionne l'analyseur sur le point de donnée suivant chaque fois que vous appuyez sur Trigger.


Window Title

Titre de fenêtre

Voir aussi...

Permet d'ajouter un titre à la fenêtre actuelle.


System Z0

Voir aussi...

Permet de changer la valeur par défaut (50 ohms) de l'impédance caracteristique du système afin que l'analyseur puisse effectuer tous les calculs de mesure avec une autre valeur de cette impédance.

Par exemple, si vous souhaitez mesurer des circuits ayant une impédance de 75 ohms :

  • Réglez le paramètre system Z0 à 75 ohms.

  • Connectez des atténuateurs à perte minimum entre l'analyseur et les circuits avec une impédance de 75 ohms.

  • Etalonnez la mesure avec un court-circuit, un circuit ouvert et une charge de 75 ohms où les définitions du kit d'étalonnage décrivent les étalons de 75 ohms.


Connectivity

Raccordement de l'analyseur à un réseau informatique

Voir aussi...

Cliquez sur un bouton pour en savoir plus sur la connectivité de l'analyseur et les possibilités de le raccorder à un réseau informatique.

Ajouter des utilisateurs

Connecter un lecteur réseau

Configurer l'analyseur pour la programmation COM/DCOM

Particularités de Windows 2000


Mise en route

Voir aussi...

Cliquez sur un bouton pour un tour d'horizon rapide de l'analyseur.

Présentation de la face avant

Présentation de la face arrière

Interface utilisateur

Modèle de fonctionnement de l'analyseur

Séquence de mesure type

Utilisation de l'aide

Raccordement de l'analyseur à un réseau informatique

Disquette de réparation d'urgence


Windows 2000 Considerations

Considérations relatives à Windows 2000

Voir aussi...

Cette rubrique met l'accent sur quelques changements notables de l'environnement d'exploitation avec Windows 2000. Pour plus d'informations sur ces changements ou sur d'autres sujets, reportez-vous au système d'aide de Windows 2000.

Utilisation des ports USB

Le PNA possède deux ports USB pour la connexion des périphériques : un sur la face avant et un sur le panneau arrière. Les principaux avantages offerts par les ports USB sont les connexions et les déconnexions “à chaud” et la rapidité des transferts de données. De plus, les modules Electronic Calibration sont maintenant disponibles avec des connexions USB.

La première fois que vous enfichez un périphérique dans un port USB, vous devez patienter un moment. Windows 2000 affiche des messages indiquant que le système identifie le périphérique, recherche le pilote approprié, puis installe le pilote (s'il l'a trouvé).

Si vous branchez à nouveau ce même périphérique sur ce port utérieurement, le processus sera plus simple et plus rapide. Cependant, si vous connectez ce périphérique à un autre port USB, vous devrez à nouveau attendre qu'il soit identifié et que le pilote correspondant soit trouvé.

Stabilité et sécurité du Plug & Play

Les fonctions Plug & Play sont semblables à celles de Win 95 et 98. Elles fournissent un environnement d'exploitation stable et sûr. En outre, vous remarquerez qu'elles réduisent considérablement le nombre de redémarrages.

Connexions LAN

Windows 2000 prend en charge l'adressage DHCP et IP fixe. En outre, la connexion et la déconnexion “à chaud” du câble LAN, ainsi qu'un indicateur visuel de l'état LAN dans la barre d'état système, rendent les connexions LAN plus intuitives. Enfin, l'assistant de matériel aide les utilisateurs à effectuer la configuration matérielle de leur système.

Option de simple et de double clic

Par défaut, Windows 2000 permet de lancer les icônes avec un seul clic. Pour revenir à la méthode du double-clic, sélectionnez Start -> Settings -> Control Panel et cliquez sur Mouse. Dans la boîte de dialogue Mouse Properties, sélectionnez Double click pour ouvrir une option. Puis, cliquez sur OK.


3.5 floppy

Lecteur de disquette 3,5 pouces

Permet d'installer des fichiers sur le disque dur de l'analyseur ou d'exporter des fichiers de données issus de l'instrument. L'accès à ce lecteur s'effectue via l'Explorateur NT.

  • Capacité non formatée : 2 Mo
  • Disquettes compatibles : Haute densité (2HD) et densité normale (2DD)
  • Vitesse de transfert : 500 kbit/seconde

Retour à la face avant


Arrange

Touche Arrange

Permet de choisir une disposition de fenêtres parmi quatre : Overlay, Stack 2, Split 3, Quad 4.


Aux Out 2

Sortie auxiliaire (port 2)

Voir aussi...

Utilisez ces connecteurs SMA (femelles) pour vos mesures personnalisées.

Cavalier d'accès direct au récepteur B

  • Le connecteur "B" supérieur provient du bras couplé du coupleur du port 2.

  • Le connecteur inférieur aboutit directement à l'entrée du récepteur "B". Si l'option 015 est installée, ce connecteur mène directement à un atténuateur commutable, puis à l'entrée du récepteur.

Pour l'entrée du récepteur :

Niveau d'entrée maximal :

-6 dBm ; compression < 0,4 dB (300 kHz à 3 GHz)
-6 dBm ; compression < 0,8 dB (3 GHz à 6 GHz)
-11 dBm ; compression < 0,8 dB (6 GHz à 9 GHz)

Plancher de bruit ; valeurs efficaces (largeur de bande 10 Hz) :

<-133 dBm (300 kHz à 3 GHz)
<-123 dBm (3 GHz à 6 GHz)
<-123 dBm (6 GHz à 9 GHz)

Niveau d'endommagement : +26 dBm

Tension c.c. maximale : 40 V (standard), 0 V (option 015)

Perte par réflexion :

>17 dB (300 kHz à 3 GHz)
>12 dB (3 GHz à 6 GHz)
>7 dB (6 GHz à 9 GHz)

Cavalier de la voie de référence

  • Le connecteur supérieur provient de la sortie de référence 2 du commutateur de transfert.

  • Le connecteur inférieur mène directement à l'entrée du récepteur R2.

Pour l'entrée du récepteur :

Niveau d'entrée maximal :

-6 dBm ; compression < 0,4 dB (300 kHz à 3 GHz)
-6 dBm ; compression < 0,8 dB (3 GHz à 6 GHz)
-11 dBm ; compression < 0,8 dB (6 GHz à 9 GHz)

Niveau d'endommagement : >+26 dBm

Niveau minimal pour le maintien du verrouillage de phase :

-35 dBm (300 kHz à 3 GHz)
-25 dBm (3 GHz à 9 GHz)

Pour la sortie de référence : (avec une entrée externe pour verrouiller la source)

Niveau de sortie :

-5 à -30 dBm (300 kHz à 6 GHz)
-10 à -35 dBm (6 GHz à 9 GHz)

Perte par réflexion due à la désadaptation de la source :

16 dB (300 kHz à 3 GHz)
14 dB (3 GHz à 9 GHz)

Niveau d'endommagement : >+26 dBm

Tension c.c. maximale : 40 V

Cavalier du port de test (option 015 uniquement)

  • Le connecteur "R2" supérieur provient du commutateur de transfert du coupleur du port 2.

  • Le connecteur inférieur mène directement à l'entrée principale du coupleur du port 2. C'est à cet endroit qu'un atténuateur peut être inséré pour protéger le récepteur de l'analyseur.

Pour la sortie de la source :

Niveau de sortie :

+12 à -83 dBm (300 kHz à 6 GHz)
+7 à -88 dBm (6 GHz à 9 GHz)

Désadaptation de la source : 15 dB à 9 GHz

Pour l'entrée du coupleur :

Perte d'insertion vers le port de test 1 :

<3,5 dB à 3 GHz
<5 dB à 9 GHz

Puissance d'entrée maximale : 2 watts, CW (mode d'onde entretenue)

Niveau d'endommagement : 4 watts, CW (mode d'onde entretenue)

Retour à la face avant


Aux Out1

Sortie auxiliaire (port 1)

Voir aussi...

Utilisez ces connecteurs SMA (femelles) pour vos mesures personnalisées.

Cavalier d'accès direct au récepteur A

  • Le connecteur "A" supérieur provient du bras couplé du coupleur du port 1.

  • Le connecteur inférieur aboutit directement à l'entrée du récepteur "A". Si l'option 015 est installée, ce connecteur mène directement à un atténuateur commutable, puis à l'entrée du récepteur.

Pour l'entrée du récepteur :

Niveau d'entrée maximal :

-6 dBm ; compression < 0,4 dB (300 kHz à 3 GHz)
-6 dBm ; compression < 0,8 dB (3 GHz à 6 GHz)
-11 dBm ; compression < 0,8 dB (6 GHz à 9 GHz)

Plancher de bruit ; valeurs efficaces (largeur de bande 10 Hz) :

<-133 dBm (300 kHz à 3 GHz)
<-123 dBm (3 GHz à 6 GHz)
<-123 dBm (6 GHz à 9 GHz)

Niveau d'endommagement : +26 dBm

Tension c.c. maximale : 40 V (standard), 0 V (option 015)

Perte par réflexion :

>17 dB (300 kHz à 3 GHz)
>12 dB (3 GHz à 6 GHz)
>7 dB (6 GHz à 9 GHz)

Cavalier de la voie de référence

  • Le connecteur supérieur provient de la sortie de référence 1 du commutateur de transfert.

  • Le connecteur inférieur mène directement à l'entrée du récepteur R1.

Pour l'entrée du récepteur :

Niveau d'entrée maximal :

-6 dBm ; compression < 0,4 dB (300 kHz à 3 GHz)
-6 dBm ; compression < 0,8 dB (3 GHz à 6 GHz)
-11 dBm ; compression < 0,8 dB (6 GHz à 9 GHz)

Niveau d'endommagement : >+26 dBm

Niveau minimal pour le maintien du verrouillage de phase :

-35 dBm (300 kHz à 3 GHz)
-25 dBm (3 GHz à 9 GHz)

Pour la sortie de référence : (avec une entrée externe pour verrouiller la source)

Niveau de sortie :

-5 à -30 dBm (300 kHz à 6 GHz)
-10 à -35 dBm (6 GHz à 9 GHz)

Perte par réflexion due à la désadaptation de la source :

16 dB (300 kHz à 3 GHz)
14 dB (3 GHz à 9 GHz)

Niveau d'endommagement : >+26 dBm

Tension c.c. maximale : 40 V

Cavalier du port de test (option 015 uniquement)

  • Le connecteur supérieur provient de la source appliquée au port 1.

  • Le connecteur inférieur mène directement à l'entrée principale du coupleur du port 1. C'est à cet endroit qu'un amplificateur de puissance peut être inséré pour augmenter la puissance délivrée par le port de test.

Pour la sortie de la source :

Niveau de sortie :

+12 à -83 dBm (300 kHz à 6 GHz)
+7 à -88 dBm (6 GHz à 9 GHz)

Désadaptation de la source : 15 dB à 9 GHz

Pour l'entrée du coupleur :

Perte d'insertion vers le port de test 1 :

<3,5 dB à 3 GHz
<5 dB à 9 GHz

Puissance d'entrée maximale : 2 watts, CW (mode d'onde entretenue)

Niveau d'endommagement : 4 watts, CW (mode d'onde entretenue)

Retour à la face avant


Average

Touche Average

Permet de faire la moyenne de plusieurs balayages successifs afin de réduire le bruit. L'analyseur calcule une moyenne exponentielle complexe, portant sur un nombre de balayages que vous spécifiez.


Cal Pop

Touche Cal (étalonnage)

Déclenche un étalonnage de mesure. L'assistant d'étalonnage (Calibration Wizard) apparaît si vous appuyez sur Menu/Dialog, puis sur Cal. Sinon, le fait d'appuyer directement sur la touche Cal fait apparaître la barre d'outils de l'entrée d'étalonnage active.


Cancel pop

Touche Cancel

Ferme une boîte de dialogue.


Channel Pop

Touche Channel

Permet de sélectionner une voie active ou de supprimer l'affichage d'une voie. Vous ne pouvez modifier les paramètres d'une voie que si elle est active.


Chnl Set

Touches de configuration de voie (bloc CHANNEL SETUP)

Voir aussi...

Explorez le graphique ci-dessous pour vous familiariser avec les différentes fonctions des touches :

Ces touches permettent :

  • de configurer une voie avec divers paramètres de stimulus ;

  • d'exécuter un étalonnage de mesure.

Retour à la face avant


Cmd Keys

Touches de commande (bloc COMMAND)

Voir aussi...

Explorez le graphique ci-dssous pour vous familiariser avec les différentes fonctions des touches :

Ces touches permettent :

  • d'entrer des commandes dans une boîte de dialogue ;

  • d'afficher des menus ou des boîtes de dialogue ;

  • de lancer l'aide de l'analyseur.

Retour à la face avant


Decimal Pop

Touche "point décimal"

Permet d'insérer un point décimal (équivalent de la virgule) dans les valeurs numériques saisies.


Display Keys

Touches d'affichage (bloc DISPLAY)

Voir aussi...

Ces touches permettent :

  • de gérer et de créer des traces et des fenêtres ;
  • de configurer rapidement un jeu de mesures ;
  • d'organiser l'affichage des mesures en cours.

Retour à la face avant


Enter Pop

Touche Enter

Permet de saisir les valeurs que vous sélectionnez pour les paramètres de mesure.


Entry Keys

Touches d'entrée (bloc ENTRY)

Voir aussi...

Explorez le graphique ci-dessous pour vous familiariser avec les différentes fonctions des touches :

Ces touches permettent de saisir les valeurs des paramètres de mesure.

Retour à la face avant


F keys pop

Touches F1, F2, F3, F4

Ces touches permettent de sélectionner les choix disponibles sur la barre d'outils de l'entrée active. Chaque touche a une couleur différente, qui correspond au choix de la même couleur sur la barre d'outils.


Format Pop

Touche Format

Permet de sélectionner le format que l'analyseur doit utiliser pour afficher les résultats de mesure.


Help pop

Touche Help

Lance l'aide en ligne de l'analyseur (documentation intégrée).


Limit Pop

Touche Limit Table

Affiche le tableau des valeurs qui permet d'effectuer des tests succès/échec en se basant sur ces segments de limites.


Macro Pop

Touche Macro / Local

  • When the analyzer is being controlled through automation, pressing this key allows the analyzer to respond to front panel key presses.

  • Lorsque l'analyseur est en mode normal, une pression sur cette touche permet d'accéder à un ensemble de macros utilisateur qui se présentent sous la forme de fichiers exécutables. Vous pouvez donner un titre et mémoriser 12 macros maximum. Lorsque vous appuyez de manière répétée sur cette touche, les titres défilent dans la barre d'outils des entrées actives par groupe de quatre noms.

Remarque : Vous devez avoir installé sur le disque dur de votre analyseur les applications nécessaires au lancement des exécutables référencés dans les macros.


Math Mem

Touche Math/Memory

Permet de sélectionner les fonctions arithmétiques et de mémoire que l'analyseur applique aux données de mesure.


Meas

Touche Measure

Permet de sélectionner une mesure de paramètre S. La boîte de dialogue vous permet également de sélectionner un rapport arbitraire ou une mesure de puissance non proportionnelle.


Meas Set

Touche Measure Setups

Permet d'effectuer un choix parmi des configurations de mesure prédéfinies.


Menu Di

Touche Menu / Dialog

Permet de naviguer dans les menus grâce aux touches de navigation. Permet également d'afficher des boîtes de dialogue en appuyant sur Menu/Dialog, puis sur une touche de la zone Channel, Trace ou Utility.


Min Max

Touche Agrandissement/Restauration

Affiche la fenêtre sélectionnée en plein écran et le ramène ensuite à sa taille précédente.


Mkr

Touche Marker

Permet d'activer un marqueur et de définir la valeur. Les marqueurs fournissent une valeur numérique des données mesurées.


Mkr Func

Touche Marker Function

Permet de modifier les paramètres de mesure, en se basant sur l'emplacement d'un marqueur actif. Si aucun marqueur n'est affiché, la touche activera un marqueur.


Mkr Sch

Touche Marker Search

Permet l'accès aux fonctions de recherche par marqueur. Si aucun marqueur n'est affiché, la touche activera un marqueur.


Mkr Tbl

Touche Marker Table

La zone de tableau permet l'affichage de trois tableaux : 1) Le tableau des marqueurs, affichant les données lues de tous les marqueurs de la trace active. 2) Le tableau de balayage de segment, affichant les paramètres de chaque segment. 3) Le tableau des limites des gabarits, affichant les paramètres de chacune des limites.


nav_pop

Touches de navigation

Touches de flèches -

Contrôlent l'emplacement du curseur dans les menus et les boîtes de dialogue

Gauche / Droite -

  • Déplace vers la gauche et vers la droite dans les menus

  • Déplace d'une tabulation à droite et d'une tabulation à gauche dans les boîtes de dialogue

Haut / Bas -

  • Déplace vers le haut et vers le bas dans les menus

  • Se comporte comme suit dans une boîte de dialogue :

    • Modifie une valeur numérique

    • Permet de se déplacer parmi les éléments d'une liste déroulante

    • Permet de se déplacer parmi les cases à cocher d'un groupe de cases à cocher

Click -

Effectue une sélection à la manière d'un clic de souris


navkeys2

Touches de navigation

Voir aussi ...

Explorez le graphique pour connaître les fonctions des touches spécifiques :

Ces touches permettent :

  • d'effectuer des choix dans la barre d'outils des entrées actives

  • de naviguer dans les menus et boîtes de dialogue

Retour à la face avant


Numeric

Touches numériques

Sélectionnez les valeurs des paramètres de mesure, puis appuyez sur Enter ou G/n ou M/u pour achever la sélection.


OK pop

Touche OK

Ferme une boîte de dialogue et valide toutes les valeurs introduites dans la boîte de dialogue.


On

Interrupteur

Fait passer l'analyseur des conditions de marche à hibernation, et vice-versa.

  • Dans la condition de marche, le voyant du bouton est vert.

  • Dans la condition d'hibernation, le voyant du bouton est jaune orangé.

  • Pour arrêter l'analyseur, appuyez sur le bouton power ; l'instrument enregistre les états de tous les programmes en cours et coupe la puissance.

  • Si vous appuyez de nouveau sur le bouton, l'instrument charge les états enregistrés au moment de l'arrêt.

Ce commutateur n'est pas relié à l'alimentation.

Retour à la face avant


PMB Pop

Touche Plus - Moins - Retour arrière

  • Permet de saisir une valeur positive ou négative si elle est la première touche pressée dans l'entrée.

  • Ramène le curseur en arrière et efface toute sélection antérieure.


Power Pop

Touche Power

Permet de définir le niveau de puissance de la source.


Preset Pop

Touche Preset

Place l'analyseur dans ses conditions de préréglage (par défaut).


Print Pop

Touche d'impression

Lance une fonction d'impression, permettant de sélectionner les conditions d'impression et l'imprimante.


Probe Pwr

Alimentation des sondes

Les connecteurs 3-broches (m) assurent l'alimentation des sondes actives.

  • Broche supérieure : Masse

  • Broche gauche : +15 Vcc ±2%, 400 mA maximum ; protégée par PTC de 0,5A

  • Broche droite : -12,6 Vcc ±5%, 300 mA maximum ; protégée par PTC de 0,5A

(PTC = fusible à réarmement automatique, temporisé)

Retour à la face avant


Recall Pop

Touche Recall

Permet de rappeler un fichier contenant l'état, l'étalonnage de mesure et les résultats de mesure d'un instrument.


RPG

Bouton rotatif de la face avant

Tourne pour augmenter ou diminuer la valeur de l'entrée active.


Save Pop

Touche Save

Permet de sauvegarder les états, les données d'étalonnage et les données de mesure de l'instrument dans un fichier.


Scale

Touche Scale

Permet de spécifier la valeur utilisée par l'analyseur pour régler l'échelle de la réponse de mesure affichée. Vous pouvez également laisser l'analyseur définir automatiquement une échelle pour l'axe des Y permettant de visualiser l'intégralité de la trace de mesure à l'écran.


Screen

Ecran

Voir aussi...

  • Explorez ce graphique à l'aide de la souris.

Cet écran présente les caractéristiques suivantes :

  • Matrice active (TFT), 8,4 pouces, cristaux liquides

  • Résolution : 640 x 480

  • Fréquence de rafraîchissement vertical : 59,83 Hz

  • Fréquence de rafraîchissement horizontal : 31,41 kHz

  • Luminosité : >250 NIT

Retour à la face avant.


Stop Span

Touche Stop / Span

Permet de saisir une valeur pour la fin ou la bande d'analyse de la plage de mesure.


Strt Cntr

Touche Start / Center

Permet de saisir une valeur pour le début ou le centre d'une plage de mesure.


Swp Set

Touche Sweep Setup

Permet de définir comment la source de l'analyseur fournit un stimulus à un composant sous test.


Swp Type

Touche Sweep Type

Permet de sélectionner la façon dont la source de l'analyseur effectue le balayage et les propriétés associées au balayage.


Test Ports

Ports de test

Voir aussi...

Deux ports type-N (femelles) de 50 ohms basculent entre la source RF de l'analyseur et le récepteur, ce qui vous permet de réaliser des mesures dans deux directions sur votre composant.

  • Un voyant vert caractérise le port source.

  • Un voyant orange caractérise le port récepteur.

Niveaux de dommage des entrées :

Niveau CW : +15 dBm
Niveau de tension CC : ±30 V

Retour à la face avant


Trace pop

Touche Trace

La première pression fait apparaître la barre d'outils active de la trace. Les pressions suivantes vous permettent de faire défiler les traces de mesure dans une fenêtre en les rendant tour à tour actives. Seules les fonctions actives peuvent être modifiées. Cette touche vous permet également de créer ou de supprimer des traces, à l'aide des touches de fonction.


Trace Set

Touches Trace Setup

Voir aussi...

Explorez le graphique pour vous familiariser avec les fonctions offertes par les touches :

Ces touches vous permettent :

  • De configurer un type de mesure.

  • D'extraire des données des résultats.

Retour à la face avant


Trigger Pop

Touche Trigger

Permet d'indiquer comment le démarrage du balayage de mesure est initié.


Units Pop

Touches Units

Ces touches complètent la sélection d'une valeur en affectant une unité de mesure. Appuyez sur la touche Enter pour terminer la saisie d'une valeur.


USB

Connecteur USB

Le connecteur USB (Universal Serial Bus) vous permet de contrôler l'analyseur à partir d'un clavier ou de tout autre dispositif de pointage. De plus, ce connecteur permet de recevoir des modules d'étalonnage électronique.

Contact 1 : Vcc ; 4,75 à 5,25 V CC, 500 mA maximum
Contact 2 : –Données
Contact 3 : +Données
Contact 4 : Masse

Retour à la face avant


Utility Keys

Touches Utility

Voir aussi...

Explorez le graphique pour vous familiariser avec les fonctions offertes par les touches :

Ces touches vous permettent d'exécuter les opérations suivantes :

  • Imprimer les résultats des mesures.

  • Sauvegarder ou rappeler les informations suivantes :

    • Etats de l'instrument

    • Etalonnages de mesure

    • Résultats de mesure

  • Exécuter des macros.

  • Redimensionner les fenêtres.

  • Prérégler l'analyseur.

Retour à la face avant


Window pop

Touche Window

La première pression fait apparaître la barre d'outils active de fenêtrage, à partir de laquelle vous pouvez créer, sélectionner et supprimer des fenêtres à l'aide des touches de fonction. Les pressions suivantes sur cette touche font défiler les fenêtres déjà configurées et activent successivement chaque fenêtre. Vous pouvez modifier les dimensions des fenêtres actives uniquement. En outre, pour faire défiler les traces contenues dans une fenêtre, cette fenêtre doit être active.


How to Use Help

Utilisation de l'aide de l'analyseur

Voir aussi...

L'aide contient la documentation complète de l'analyseur. Cliquez sur un bouton pour comprendre rapidement comment utiliser l'aide et les réponses aux questions concernant l'analyseur.

Recherche d'informations dans l'aide

Impression de la rubrique d'aide actuelle

Dimensionnement ou Déplacement de la fenêtre d'aide

Fermeture de la fenêtre d'aide


Bias In

Connecteurs d'entrée de polarisation

Entrée de polarisation du port de test :

Ce connecteur BNC femelle permet d'appliquer une tension de polarisation externe au port de test.

  • Tension maximale nominale : ±30 V c.c.

  • Courant maximal : ±1 A, (±200 mA sans dégradation des caractéristiques de fonctionnement RF)*

Fusible de l'entrée de polarisation du port de test :

Fusible à deux plots, non retardé, calibré à 1 A, 125 V

*Jusqu'à 200 mA, l'instrument fonctionne conformément à ses spécifications radio-fréquences. Au-delà de cette valeur, la correction des erreurs de directivité et d'adaptation de la source se dégrade, en particulier à basse fréquence (c'est-à-dire en dessous de 100 MHz, mais surtout au-dessus de 10 MHz). Au-dessus de 100 MHz, et jusqu'à 1 A de polarisation, la dégradation de la correction des erreurs de directivité et d'adaptation de la source reste très faible.

Retour à la face arrière


Ext AM

Connecteur d'entrée AM externe (EXT. AM INPUT)

Ce connecteur BNC femelle est une entrée dans laquelle vous pouvez injecter une tension basse fréquence afin de moduler en amplitude le signal de sortie du port de test. Il est aussi possible d'injecter une tension fixe (continue) afin de décaler le niveau de puissance délivré par le port de test. Avec une tension nulle, le niveau de puissance reste inchangé. Avec une tension positive, la puissance délivrée par le port de test augmente. Avec une tension négative, la puissance délivrée par le port de test diminue.

  • Sensibilité de l'entrée : 8 dB/volt, valeur nominale

  • Bande passante : 1 kHz, valeur nominale

  • Impédance d'entrée : 1 kW, valeur nominale

Retour à la face arrière


Ext Det

Connecteur d'entrée de détecteur externe (EXT. DETECTOR INPUT)

Ce connecteur BNC femelle permet d'injecter une tension continue, issue d'un détecteur externe à diode de polarité négative, pour contrôler le niveau de puissance des ports de test. Pour que l'analyseur accepte cette tension externe, vous devez cocher la case External ALC dans la boîte de dialogue Sweep Setup.

  • Sensibilité de l'entrée : -500 mV correspondent à peu près à -3 dBm à l'entrée de détection

  • Bande passante : 50 kHz, valeur nominale

  • Impédance d'entrée : 1 kW, valeur nominale

Retour à la face arrière


ExtTrig

Connecteur d'entrée/sortie auxiliaire

Permet d'injecter un signal externe pour déclencher une mesure de l'analyseur. Pour que l'analyseur puisse détecter ce signal de déclenchement externe, vous devez choisir la source de déclenchement externe (External) et préciser si le signal TTL est en logique positive ou négative.

  • Sortie TTL de déclenchement : broche 18

  • Entrée TTL pour déclenchement externe (logique positive ou négative) : broche 19

Retour à la face arrière


FRef

Connecteurs de la référence de fréquence à 10 MHz

Entrée de référence à 10 MHz

Ce connecteur BNC femelle permet de faire fonctionner l'analyseur avec un signal de référence externe dont les caractéristiques doivent être les suivantes :

  • Fréquence d'entrée : 10 MHz ± 1 ppm, valeur nominale

  • Niveau d'entrée : -15 à +20 dBm, valeur nominale

  • Impédance d'entrée : 200 W, valeur nominale

Sortie de référence à 10 MHz

Ce connecteur BNC femelle fournit un signal de référence de fréquence dont les caractéristiques sont les suivantes :

  • Fréquence de sortie : 10 MHz ±10 ppm

  • Forme du signal : sinusoïdale

  • Niveau de sortie : 10 dBm ±4 dB dans 50 ohms

  • Impédance de sortie : 50 ohms

  • Harmoniques : < -40 dBc

Retour à la face arrière


GPIB

Connecteur GPIB (General Purpose Interface Bus)

Ce connecteur à 24 broches est de type D-24 femelle, compatible avec le standard IEEE-488.

Retour à la face arrière


LAN Connector

Connecteur de réseau local (LAN)

Cette connexion Ethernet 10/100BaseT a une configuration standard de 8 broches et sélectionne automatiquement l'un des deux débits de données.

Retour à la face arrière


Parallel

Connecteur du port d'interface parallèle (LPT1)

Ce connecteur femelle de 36 broches, mini-D, 1284-C, permet la connexion d'une imprimante ou de n'importe quel autre périphérique à port parallèle.

Un adaptateur est prévu pour permettre la connexion entre ce port parallèle et un port Centronics.

Retour à la face arrière


Serial

Connecteur (COM1) du port d'interface série

Ce connecteur mâle D-sub à 9 broches est compatible RS-232.

Retour à la face arrière


USB Connector

Connecteur USB (Universal Serial Bus)

Cette fiche Universal Serial Bus possède une configuration Type A (4 contacts en ligne : contact 1 sur la gauche) femelle :

  • Contact 1 : Vcc : 4,75 à 5,25 V CC, 500 mA maximum

  • Contact 2 : –Données

  • Contact 3 : +Données

  • Contact 4 : Masse

Le contact 1 est protégé par un fusible à réinitialisation automatique de 1 A. Vous pouvez connecter une souris, un clavier, ou tout autre dispositif de pointage USB.

Retour à la face arrière


VGA Output

Connecteur de sortie VGA (Video Graphics Adapter)

Ce connecteur D-sub femelle à 15 broches permet de connecter des écrans VGA externes avec les résolutions indiquées ci-dessous. Vous pouvez simultanément visualiser les écrans internes et externes.

Périphérique | Résolution
Ecran plat (TFT) | 1024 x 768, 800 x 600, 640 x 480
Ecran plat (DSTN) | 800 x 600, 640 x 480
Ecran à tube cathodique | 1280 x 1024, 1024 x 768, 800 x 600, 640 x 480

Remarque : si l'analyseur est réglé sur la résolution par défaut (640 x 480), vous pouvez simultanément visualiser l'analyseur et l'écran externe. Si vous changez la résolution par défaut de l'analyseur via le panneau de commande, vous ne pourrez visualiser que l'écran externe. Pour changer la résolution : dans le menu System, cliquez sur Windows Taskbar, Settings, Control Panel. Puis, cliquez sur l'icône Display et l'onglet Settings.

Retour à la face arrière


Crosstalk

Voir aussi...

Diaphonie entre récepteurs

Présentation

Concepts

Comment réduire
la diaphonie

La diaphonie est une fuite d'énergie entre les trajets des signaux de l'analyseur. Elle peut nuire à la précision des mesures de transmission portant sur des composants à fort affaiblissement. Il est cependant possible d'en réduire les effets en optant pour un mode de balayage et un étalonnage adéquats.
Concepts

Comment réduire la diaphonie entre récepteurs

Les aspects de la diaphonie :

  • La fuite d'énergie entre les trajets des signaux de l'analyseur contribue à fausser les mesures de transmission.

  • La diaphonie peut affecter les mesures suivantes :

    • Composants à fort affaiblissement (par exemple, un commutateur en position ouverte)

    • Composants à grande dynamique (par exemple, un filtre)

Pour réduire la diaphonie entre récepteurs, vous pouvez :

Choisir le mode de balayage alterné

Effectuer un étalonnage de mesure

Choix du mode de balayage alterné

Ce mode de balayage contribue à réduire la d iaphonie entre récepteurs pour les raisons suivantes :

  • La mesure ne porte que sur un seul récepteur par balayage.

  • Lorsque l'un des récepteurs est mesuré, l'autre est désactivé.

Conseils :

  • L'analyseur mesure la réflexion (récepteur A) et la transmission (récepteu r B) au cours de balayages distincts. Par conséquent, lorsque vous effectuez une mesure portant à la fois sur la réflexion et la transmission, le mode de balayage alterné entraîne un doublement de la durée du cycle de mesure.

  • Si votre mesure porte uniquement sur la transmission ou la réflexion, vous pouvez utiliser le mode de balayage alterné pour réduire l'effet de la diaphonie sans affecter la durée du cycle de mesure.

  • Le plancher de bruit doit être abaissé de manière substantielle avant que la diaphonie ne devienne visible. Il est possible que vous deviez utiliser la fonction de moyennage de plusieurs balayages successifs ou réduire la largeur de bande de la FI.

Exécution d'un étalonnage de mesure

Dans le cas des mesures de transmission, l' étalonnage de la mesure de réponse en fréquence et d'isolement contribue à réduire la diaphonie pour les raisons suivantes :

  • L'analyseur mesure puis soustrait le signal de fuite lors de l'étalonnage de la mesure.

  • L'étalonnage améliore l'isolement de sorte qu'il n'est limité que par le plancher de bruit.

Pour connaître les possibilités de réduction de la diaphonie dans le processus d'étalonnage, consultez les rubriques Erreurs systématiques et Isolement.

Conseil :

  • Généralement, l'isolement se situe en dessous du plancher de bruit. Pour cette raison, lorsque vous effectuez un étalonnage de l'isolement, vous devez recourir à une technique de réduction du bruit telle que le moyennage de plusieurs balayages successifs ou la réduction de la largeur de bande de la FI.

Cliquez sur les boutons ci-dessous pour accéder aux procédures de réduction de la d iaphonie entre récepteurs.
Choisir le mode de balayage alterné

Effectuer un étalonnage de la réponse et de l'isolement

Choix du mode de balayage alterné
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Sweep Setup.

  2. Si le mode de balayage alterné n'est pas actif, cochez la case Alternate Sweeps.

  3. Cliquez sur OK.

Remarque : le mode de balayage alterné peut être choisi indépendamment pour chaque voie de mesure. Il est donc possible que vous deviez répéter cette procédure pour chaque voie utilisée dans votre mesure.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  3. Si le mode de balayage alterné n'est pas actif, appuyez sur la touche Tab à droite dans le bloc NAVIGATION pour accéder à la case Alternate Sweeps, puis appuyez sur Click.

  4. Dans le bloc COMMAND, appuyez sur OK.

Remarque : le mode de balayage alterné peut être choisi indépendamment pour chaque voie de mesure. Il est donc possible que vous deviez répéter cette procédure pour chaque voie utilisée dans votre mesure.

Exécution d'un étalonnage de la réponse et de l'isolement
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Remarque : cette procédure concerne uniquement les mesures de transmission.

  1. Dans le menu Calibration, cliquez sur Calibration Wizard.

  2. Sous la rubrique Select Calibration Type, cliquez sur Cal Type.

  3. Cliquez sur THRU Resp and Isol, puis sur OK.

  4. Effectuez la suite de l'étalonnage (sélection des étalons et du type de connecteur, puis mesure des étalons) en vous conformant aux instructions affichées. Pour plus de détails, reportez-vous à la rubrique Sélection et exécution d'un étalonnage de mesure.

Procédure à l'aide des touches de la face avant

Remarque : cette procédure concerne uniquement les mesures de transmission.

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Cal, puis sur F1 (Cal Wizard).

  2. Dans le bloc NAVIGATION, appuyez sur Click et utilisez les touches fléchées pour accéder à l'option THRU Resp and Isol, puis appuyez sur Click.

  3. Dans le bloc COMMAND, appuyez sur OK.

  4. A l'aide des touches du bloc NAVIGATION, effectuez la suite de l'étalonnage (sélection des étalons et du type de connecteur, puis mesure des étalons) en vous conformant aux instructions affichées. Pour plus de détails, reportez-vous à la rubrique Sélection et exécution d'un étalonnage de mesure.


DPoints

Voir aussi...

Nombre de points

Présentation

Concepts

Comment augmenter le
nombre de points

Un point de données (ou plus simplement "point") est un échantillon représentant une mesure effectuée à une valeur de stimulus particulière. Vous pouvez spécifier le nombre de points que l'analyseur doit mesurer au cours d'un balayage.

Concepts

Comment augmenter le nombre de points

  • La plupart des opérations de traitement de données sont réalisées point par point. Un "balayage" est une série de mesures de points de données consécutifs effectuées avec une suite de valeurs de stimulus.

  • Plus les points de données sont nombreux, plus la résolution de la trace est fine et meilleure est la définition de la réponse du composant mesuré.

  • La valeur par défaut est 201 points par balayage.

51 Points | 101 Points | 401 Points

Le temps de balayage de l'analyseur varie proportionnellement au nombre de points. En revanche, la durée globale du cycle de mesure ne change pas. Pour plus de détails sur l'influence du nombre de points et d'autres paramètres sur le temps de balayage, reportez-vous à la description des caractéristiques techniques de l'instrument.

Conseils :

  • Pour obtenir la plus grande résolution de trace, utilisez le nombre maximal de points de données.

  • Si vous souhaitez privilégier la vitesse de mesure, utilisez le plus petit nombre de points de données offrant une précision acceptable.

  • Pour déterminer le nombre de points optimal, recherchez une valeur au-delà de laquelle la mesure ne présente plus de différence significative.

  • Pour garantir la précision de l'étalonnage d'une mesure, effectuez cet étalonnage avec le même nombre de points que celui que vous prévoyez d'utiliser pour la mesure.

Sélectionnez l'un des boutons ci-après pour savoir comment augmenter le nombre de points de données et la précision de mesure.

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Number of Points.

  2. Sélectionnez l'une des valeurs prédéfinies ou, pour entrer une valeur particulière, choisissez Custom.

  3. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Sweep Setup.

  2. Dans le bloc NAVIGATION, appuyez sur F2 (Points) et utilisez les touches fléchées pour sélectionner une valeur, puis appuyez sur Click.

  3. Ou alors, entrez la valeur de votre choix à l'aide des touches du bloc ENTRY, puis appuyez sur Enter.


Meas Thru

Augmentation de la capacité de mesure

Voir aussi ...

Cliquez sur un bouton pour apprendre à optimiser les mesures pour accroître la capacité.

Obtention du balayage le plus rapide

Commutation rapide entre de multiples états de mesure

Obtention de la vitesse de transfert des données la plus élevée


Optimize

Optimiser les mesures

Voir aussi ...

Une mesure comporte de nombreux paramètres interdépendants. Vous pouvez modifier les paramètres afin d'atteindre les objectifs de votre application de mesure : débit supérieur ou données plus précises. Avec un réglage soigneux, il est possible d'ajuster les paramètres afin d'optimiser les résultats de la mesure.
Augmenter le débit de la mesure

Obtenir un balayage plus rapide

Commuter entre de multiples états de mesure

Obtenir une vitesse de transfert des données plus importante
Améliorer la précision de la mesure

Augmenter la plage dynamique

Augmenter le nombre de points de données

Augmenter la précision de la phase

Améliorer la précision de mesure des dispositifs à grande longueur électrique

Augmenter la précision de la réflexion des dispositifs à 2 ports faibles pertes

Augmenter la stabilité de la mesure

Diminuer le bruit de trace

Diminuer les interférences au niveau du récepteur

Réduire les effets des accessoires de test


Stable

Voir aussi...

Stabilité des mesures

Présentation

Concepts

Comment augmenter
la stabilité des mesures

Il existe plusieurs situations pouvant entraîner des mesures instables. Pour être sûr de réaliser des mesures répétitives, vous pouvez appliquer certaines méthodes visant à créer un environnement de mesure stable.
Concepts

Comment augmenter la stabilité des mesures

Les conditions suivantes peuvent nuire à la précision de vos mesures. Cliquez sur un bouton pour accéder à la rubrique correspondante :
Dérive de fréquence

Dérive de température

Etalonnages de mesure incorrects

Connexions des composants

Dérive de fréquence

La précision de la fréquence de l'analyseur repose sur un oscillateur de fréquence interne de 10 MHz. Voir Comprendre les spécifications techniques pour connaître des spécifications relatives à la stabilité et au vieillissement.

Si votre application de mesure a besoin d'une fréquence plus précise et plus stable, vous pouvez passer outre le standard de fréquence interne et fournir votre propre source de fréquence externe ultra-stable via le connecteur Reference Input de 10 MHz situé sur la face arrière.

Dérive de température

L'expansion et la contraction thermique changent les caractéristiques électriques des composants suivants :

  • Composants à l'intérieur de l'analyseur

  • Etalons du kit d'é talonnage

  • Composants de test

  • Câbles

  • Adaptateurs

Pour atténuer les effets de la dérive de température sur vos mesures, procédez comme suit :

  • Travaillez dans un environnement thermo-régulé.

  • Stabilisez la température des étalons du kit d'étalonnage.

  • Evitez toute manipulation superflue des étalons du kit d'étalonnage durant la procédure d'étalonnage.

  • Assurez-vous que la température ambiante soit à ±1°C de la température d'étalonnage des mesures.

Etalonnages de mesure incorrects

Si un étalonnage de mesure est incorrect, vous ne mesurerez pas la vraie réponse d'un composant sous test. Pour être sûr que votre étalonnage est correct, procédez comme suit :

  • Effectuez un étalonnage de mesure aux points où vous connectez le composant sous test, c'est-à-dire le plan de référence .

  • Si vous insérez un autre accessoire (câble, adaptateur, atténuateur) à la configuration du test après avoir réalisé un étalonnage de mesure, utilisez la fonction d'extension de port pour compenser la longueur électrique et le retard supplémentaires.

  • Utilisez les étalons qui correspondent aux définitions utilisées dans le processus d'étalonnage.

Voir Etalonnages de mesure précis pour obtenir des informations plus détaillées.

Connexions des composants

Il est nécessaire de réaliser des connexions correctes pour effectuer des mesures répétitives. Pour réaliser des connexions correctes, procédez comme suit :

  • Inspectez et nettoyez les connecteurs de tous les composants dans la configuration de la mesure.

  • Appliquez des techniques de connexion appropriées.

  • Evitez de bouger les câbles lors des mesures.

Cliquez sur les boutons ci-dessous accéder aux procédures d'amélioration de la stabilité des mesures.
Utiliser une référence de fréquence externe

Contrôler la température de la salle

Stabiliser la température des étalons

Voir Etalonnages de mesure précis

Réaliser des connexions correctes

Utiliser une référence de fréquence externe

  1. Faites entrer le signal de référence de la fréquence externe par le connecteur de la face arrière, comme illustré.

  • Fréquence en entrée : 10 MHz ±10 ppm

  • Niveau d'entrée : –15 à +20 dBm

  • Impédance en entrée : 200 ohms

Contrôler la température de la salle

  1. Mettez sous tension l'analyseur une demi-heure avant de réaliser un étalonnage de mesure ou de mesurer un composant.

  2. Effectuez toutes les mesures dans un environnement thermo-régulé. Toutes les spécifications et caractéristiques s'appliquent sur une plage de 25 °C ±5 °C (sauf indication contraire).

  3. Assurez-vous que la température ambiante soit à ±1°C de la température d' étalonnage des mesures.

Stabiliser la température des standards d'étalonnage

  1. Une heure avant de réaliser un étalonnage de mesure, ouvrez la malette du kit d'étalonnage et sortez les étalons de la mousse de protection.

  2. Lorsque vous réalisez un étalonnage de mesure, évitez toute manipulation superflue des étalons du kit d'étalonnage.

Réaliser des connexions correctes

  1. Inspectez tous les connecteurs à l'aide d'une loupe. Recherchez les signes d'endommagement suivants :

    • Revêtement usé

    • Conducteurs centraux pliés, cassés, non alignés

    • Profondes éraflures, bosselures, côtés arrondis

    • Poussières ou particules métalliques

  2. Nettoyez tous les connecteurs à l'aide d'alcool isopropylique et de tampons non pelucheux.

    1. Laissez s'évaporer l'alcool.

    2. Utilisez de l'air comprimé pour sécher les connecteurs.

  3. Connectez correctement les composants.

    1. Utilisez un tapis et un bracelet anti-statiques pour vous relier à la terre, ainsi que tous les composants.

    2. Alignez les connecteurs et enfichez-les.

    3. Ne tournez que l'écrou du connecteur.

    4. Utilisez une clé dynamométrique pour la connexion finale.


TDGuide

Mesures dans le domaine temporel

Voir aussi...

Si l'analyseur est équipé de la Time Domain Option 010 (Mesure dans le domaine temporel), vous pouvez visualiser la réponse d'un dispositif en fonction du temps. Cliquez sur les boutons ci-dessous pour accéder aux informations correspondantes.
Présentation du domaine temporel

Modes passe-bande et passe-bas du domaine temporel

Résolution et plage du domaine temporel

Filtre de fenêtre des données affichées

Filtre de sélection périodique par porte

Données de mesure du domaine temporel


3_Tab

3-Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4_Tab

4-Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6_Tab

6-Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


Customize Your Analyzer Screen

 Barre d'outils de l'entrée active Barre d'outils de mesure Barre d'outils de contrôle du balayage Barre d'outils de stimulus Barre d'outils des marqueurs Barre d'état de la trace Tables

Voir aussi...

Personnalisation de l'écran de l'analyseur

Présentation

Barres d'outils
et tables

Etat de la
mesure

Comment changer
les réglages de l'écran

Vous pouvez personnaliser l'écran de l'analyseur en affichant ou en masquant divers éléments.

Barres d'outils et tableaux

Etat de la mesure

Comment changer les réglages de l'écran

Explorez le graphique à l'aide de la souris pour vous familiariser avec les différentes parties de l'écran :
Barre d'état

Barres d'outils

Entrée active

Marqueurs

Mesure

Contrôle du balayage

Stimulus

All Off

Tableaux

Tableaux des marqueurs

Tableaux des limites de gabarit

Tableaux des segments

Barre d'état

La barre d'état est affichée dans le bas de l'écran.

Les informations fournies sont les suivantes :

  8. V oie active

  9. Paramètre de mesure représenté par la trace active

  10. C orrection d'erreur pour la trace active

  11. M oyennage pour la voie active (en fonction ou hors fonction)

  12. Etat GPIB (commande locale ou à distance)

Barres d'outils

Vous pouvez afficher jusqu'à six barres d'outils différentes. Elles vous permettent de configurer et de modifier facilement vos mesures.

Barre d'outils de l'entrée active

Cette barre d'outils est affichée en haut de l'écran, sous la barre de menus. Elle donne accès aux sélections de la fonction active.

Elle est composée des éléments suivants :

  • Choix proposés pour la fonction active, correspondant aux quatre touches de fonction de la face avant.

Barre d'outils des marqueurs

Cette barre d'outils est disposée juste au-dessus des fenêtres supérieures de l'écran. Elle permet de configurer et de modifier les marqueurs.

Elle est composée des éléments suivants :

  • Numéro de marqueur

  • Valeur de stimulus

  • Fonctions de marqueur

    • Delta

    • Start/Stop

    • Center/Span

Barre d'outils de mesure

Cette barre d'outils est affichée au-dessus des fenêtres supérieures de l'écran. Elle permet de :

  • Créer une nouvelle trace pour une mesure de paramètres S dans :

    • la fenêtre active,

    • une nouvelle fenêtre.

Barre d'outils de contrôle du balayage

Cette barre d'outils est affichée au-dessus des fenêtres supérieures de l'écran. Dans l'ordre, ses boutons configurent la voie active :

  • en mode de maintien (Hold),

  • en mode de balayage unique (Single), puis en mode de maintien (Hold),

  • en mode de balayage continu (Continuous).

Pour plus de détails, consultez la rubrique Déclenchement.

Barre d'outils de stimulus

Cette barre d'outils est affichée au-dessus des fenêtres supérieures de l'écran. Elle permet de visualiser, de configurer et de modifier le stimulus de balayage.

Les informations fournies sont les suivantes :

  • Valeur de départ (Start)

  • Valeur d'arrêt (Stop)

  • Nombre de points

All Off

Cette sélection permet de masquer toutes les barres d'outils en une seule opération.

Tableaux

Vous pouvez afficher des tableaux de marqueurs, de limites de gabarit ou de segments afin de visualiser, de configurer ou de modifier leurs valeurs (le tableau des marqueurs n'est cependant accessible qu'en consultation).

  • Les tableaux sont affichés dans le bas de la fenêtre sélectionnée.

  • Il n'est possible d'afficher qu'un seul tableau à la fois pour une fenêtre particulière.

Tableau de marqueurs

Vous pouvez afficher un tableau répertoriant les paramètres des marqueurs, à savoir :

  • Numéro de marqueur

  • Référence de marqueur (pour les mesures de deltas)

  • Fréquence

  • Réponse

Tableau des limites de gabarit

Vous pouvez afficher, configurer et modifier un tableau de limites utilisées pour les tests par gabarit. Les informations fournies dans ce tableau sont les suivantes :

  • Type (MIN, MAX ou OFF)

  • Valeurs de stimulus de début et de fin

  • Valeurs de réponse de début et de fin

Tableau de segments

Vous pouvez afficher, configurer et modifier un tableau de paramètres de balayage par segments. Les informations fournies dans ce tableau sont les suivantes :

  • Etat (On/Off)

  • Fréquences initiale et finale

  • Nombre de points

  • L argeur de bande FI (si niveaux indépendants)

  • Niveau de puissance (si niveaux indépendants)

  • Temps de balayage (si niveaux indépendants)

Etat de la mesure

Etat de la trace

Fréquence/Stimulus

Indications chiffrées des marqueurs

Résultats des tests par gabarit

Lignes de gabarit

Titre

Trace de données

Trace mémorisée

Barres de titre

Etat de la mesure

Vous pouvez afficher ou masquer sélectivement six types d'informations de mesure :

  • Etat de la trace

  • Valeurs de fréquence/stimulus

  • Indications chiffrées des marqueurs

  • Résultats des tests par gabarit

  • Lignes de g abarit

  • Titres

Etat de la trace

L'état de la trace est affiché à gauche de chaque fenêtre présente à l'écran.

Les informations fournies sont les suivantes :

  • Paramètre mesuré

  • Format

  • Facteur d'échelle

  • Niveau de référence

Fréquence/Stimulus

Les valeurs de fréquence/stimulus sont affichées dans le bas de chaque fenêtre présente à l'écran. Vous pouvez les masquer pour des raisons de sécurité. Les informations fournies sont les suivantes :

  • Numéro de voie

  • Valeur initiale

  • Valeur finale

Indications chiffrées des marqueurs

Les indications chiffrées des marqueurs sont affichées dans l'angle supérieur droit de chaque fenêtre présente à l'écran. Les informations fournies sont les suivantes :

  • Numéro de marqueur

  • Valeur de stimulus

  • Valeur de réponse au format sélectionné pour le marqueur

Résultats des tests par gabarit

Les résultats des tests par gabarit sont affichés sur le côté droit de la fenêtre concernée. Les informations fournies sont les suivantes :

  • Pass (succès) ou Fail (échec)

Lignes de gabarit

Les lignes de gabarit sont affichées pour la trace active dans la fenêtre considérée. Leur position dépend des facteurs suivants :

  • Niveaux limites

  • Format

  • Echelle

  • Niveau de référence

Titre

Vous pouvez créer et afficher un titre pour une fenêtre. La boîte de dialogue suivante s'affiche pour vous permettre de saisir le titre souhaité.

Votre titre s'affiche ensuite dans l'angle supérieur gauche de la fenêtre concernée.

Trace de données

Vous pouvez masquer une trace de données sélectionnée.

Trace mémorisée

Vous pouvez masquer une trace mémorisée sélectionnée.

Barres de titre

Une barre de titre figure en haut de chaque fenêtre affichée à l'écran. Les informations fournies sont les suivantes :

  • Numéro de fenêtre

Vous pouvez masquer les barres de titre de toutes les fenêtres afin de consacrer plus d'espace à l'affichage des mesures.

Cliquez sur l'un des boutons ci-après pour accéder à la procédure de votre choix.

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu View, cliquez sur l'annotation souhaitée.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog.

  2. Appuyez sur la touche Tab à droite pour sélectionner le menu View.

  3. Appuyez sur la flèche vers le bas pour sélectionner l'annotation souhaitée.

  4. Dans le bloc COMMAND, appuyez sur OK.


Data Format and Scale

Voir aussi...

Format et échelle des données

Présentation

Concepts

Comment régler le
format et l'échelle

On entend par format des données la manière dont l'analyseur présente graphiquement les données qu'il mesure. La fonction Scale (mise à l'échelle) permet quant à elle d'éditer les données de mesure en vue d'optimiser leur visualisation.

Concepts

Comment régler le format et l'échelle des données

Le format de données que vous choisissez doit être adapté à la nature des informations que vous souhaitez obtenir sur le composant à tester. La présente rubrique vous aidera à vous familiariser avec les neuf formats disponibles et à choisir celui qui convient le mieux aux données mesurées. Vous y apprendrez également à régler l'échelle pour optimiser l'affichage des informations.

Formats d'affichage rectangulaires (cartésiens)

Format amplitude logarithmique (Log Mag)

Format Phase

Format temps de propagation de groupe (Group Delay)

Format amplitude linéaire (Linear Mag)

Format SWR (rapport d'ondes stationnaires)

Format réel (Real)

Format imaginaire (Imaginary)

Format polaire (Polar)

Format abaque de Smith (Smith Chart)

Echelle (Scale)

Réglage automatique de l'échelle (Auto Scale)

Réglage automatique de l'échelle automatique de toutes les traces (Auto Scale All)

Niveau de référence (Reference Level)

Position de référence (Reference Position)

Formats d'affichage rectangulaires

Sept des neuf formats disponibles utilisent une représentation rectangulaire des données de mesure. Ce type d'affichage est également connu sous le nom de représentation cartésienne, X/Y ou rectiligne. L'affichage rectangulaire :

  • présente le stimulus (fréquence, puissance ou temps) sur l'axe X, dont l'échelle est linéaire ;

  • présente très clairement les données de réponse en fréquence du composant testé.

Les sept formats de données se distinguent par la nature des données présentées sur l'axe Y.

Format amplitude logarithmique (Log Mag)

  • Affiche l'amplitude (pas de phase)

  • Axe Y : dB

  • Mesures typiques :

    • Perte par réflexion

    • Perte d'insertion ou gain

Format Phase

  • Affiche la phase (pas d'amplitude)

  • Axe Y : phase (en degrés)

  • Mesures typiques :

  • Ecart par rapport à la phase linéaire

Format temps de propagation de groupe (Group Delay)

  • Affiche le temps de transmission (propagation) du signal à travers le composant

  • Axe Y : temps (en secondes)

  • Mesures typiques :

    • Temps de propagation de groupe

Format amplitude linéaire (Linear Mag)

  • Affiche des valeurs positives uniquement

  • Axe Y : sans unité

  • Mesures typiques :

    • Coefficients (amplitudes) de réflexion et de transmission

    • Transfert dans le domaine du temps

Format SWR (rapport d'ondes stationnaires)

  • Affiche les données de mesure de réflexion calculées d'après la formule (1+r)/ (1r) où p est le coefficient de réflexion.

  • S'applique uniquement aux mesures de réflexion.

  • Axe Y : sans unité

  • Mesures typiques :

    • ROS (rapport d'ondes stationnaires)

Format réel (Real)

  • Affiche uniquement la partie réelle (résistive) des données complexes mesurées.

  • Peut présenter à la fois des valeurs positives et négatives.

  • Axe Y : sans unité

  • Mesures typiques :

    • Domaine du temps

    • Signal appliqué à l'entrée auxiliaire (à des fins de maintenance)

Format imaginaire (Imaginary)

  • Affiche uniquement la partie imaginaire (réactive) des données mesurées.

  • Axe Y : sans unité

  • Mesures typiques :

    • Impédance pour la conception de réseaux adaptés

Format polaire (Polar)

Le format polaire présente à la fois des données d'amplitude et de phase. Les grandeurs sont lues sous forme vectorielle de la manière suivante :

  • L'amplitude en un point quelconque est déterminée d'après sa distance par rapport au centre (origine, ou valeur zéro). L'échelle d'amplitude est linéaire, la valeur située au niveau du cercle extérieur correspondant à un rapport de 1.

  • La phase est déterminée par l'angle que forme le rayon considéré avec l'axe x positif.

  • Comme il n'y a pas d'axe de fréquence, les données de fréquence sont lues à l'aide des marqueurs.

Les échelles d'amplitude et de phase sont linéaires. Les formats amplitude logarithmique et réel/imaginaire sont disponibles à partir du menu Marker.

Format abaque de Smith (Smith Chart)

Ce format affiche les données de mesure de réflexion du composant testé sous une forme permettant de déterminer son impédance. L'abaque de Smith est un plan d'impédance calqué sur le plan polaire.

Interpréter l'abaque de Smith

Chaque point de l'abaque de Smith représente une impédance complexe constituée d'une résistance réelle (r) et d'une partie imaginaire ou réactive (r+-jX).

Les cercles en pointillés représentent chacun une valeur de résistance constante. La ligne horizontale passant par le centre de l'abaque est purement résistive (pas de composante réactive).

  • La valeur de résistance située à l'extrémité droite de cette ligne est infinie (circuit ouvert).

  • La valeur de résistance située à l'extrémité gauche de cette ligne est nulle (court-circuit).

Les arcs en pointillés représentent chacun une valeur de réactance constante.

  • Les arcs situés dans la moitié supérieure (positive) de l'abaque représentent des valeurs de réactance inductive.

  • Les arcs situés dans la moitié inférieure (négative) de l'abaque représentent des valeurs de réactance capacitive.

Les valeurs affichées par l'analyseur de réseau sont normalisées par rapport à l'impédance caractéristique du système. Le centre de l'abaque correspond donc à l'impédance caractéristique du système.

Echelle (Scale)

Utilisez cette fonction pour régler l'échelle verticale de la grille affichée. Dans le cas des format s polaire et abaque de Smith, la valeur de pleine échelle correspond au cercle extérieur.

Plage de réglage : 0,001 dB/division à 500 dB/division

Réglage automatique de l'échelle (Autoscale)

Règle automatiquement l'échelle verticale de manière à faire tenir la trace de données dans les limites de la grille affichée. Seules l'échelle et les valeurs de référence sont affectées ; les valeurs de stimulus restent inchangées.

  • L'analyseur détermine le plus petit facteur d'échelle avec lequel les données affichées occupent 80 % de la hauteur de la grille.

  • La valeur de référence est choisie de manière à centrer la trace à l'écran.

Réglage automatique de l'échelle de toutes les traces (Autoscale All)

Fonctionne de manière identique à la fonction Autoscale, à ceci près que le réglage automatique de l'échelle verticale porte sur toutes les traces affichées dans la fenêtre sélectionnée.

Niveau de référence (Reference Level)

Spécifie la valeur de la ligne de référence dans les formats d'affichage cartésiens ou du cercle extérieur dans les formats polaires.

Plage de réglage : -500 dB à 500 dB.

Position de référence (Reference Position)

Dans le cas des formats d'affichage cartésiens, spécifie la position de la ligne de référence sur le graticule (zéro étant la ligne du bas et dix la ligne du haut). La position par défaut est cinq.

Cliquez sur les boutons ci-après pour accéder aux procédures permettant de choisir le format et l'échelle des données.

Sélectionner le format des données

Régler l'échelle manuellement

Régler l'échelle automatiquement

Définir la ligne de référence

Sélectionner le format des données
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Format.

  2. Cliquez sur le format de données souhaité.

  3. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches TRACE SETUP, appuyez sur Format.

  2. Pour sélectionner le format amplitude logarithmique, appuyez surF1 (LogMag).

  3. Pour sélectionner le format abaque de Smith, appuyez surF2 (Smith).

  4. Pour sélectionner le format phase, appuyez surF3 (Phase).

  5. Pour sélectionner le format temps de propagation de groupe, appuyez surF4 (Delay).

  6. Pour sélectionner l'un des cinq autres formats de données, passez à l'étape 7 de cette procédure.

  7. Appuyez sur la touche Menu/Dialog du bloc COMMAND.

  8. Dans le bloc de touches TRACE SETUP, appuyez sur Format.

  9. Dans le bloc de touches NAVIGATION, utilisez la touche Tab de droite pour sélectionner le format souhaité. Appuyez sur la touche OK du bloc COMMAND.

Régler l'échelle manuellement
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Scale, cliquez sur Scale. La boîte de dialogue Scale s'affiche à l'écran.

  2. Dans la partie Scale de la boîte de dialogue, cliquez sur le champ Per Division. Tapez une valeur ou cliquez sur la flèche pour sélectionner le facteur d'échelle.

  3. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches TRACE SETUP, appuyez sur Scale.

  2. Appuyez sur F2 (Scale) et tapez la valeur du facteur d'échelle souhaité, ou alors sélectionnez-la à l'aide des touches fléchées du bloc NAVIGATION.

Régler l'échelle automatiquement
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Scale, cliquez sur Autoscale ou Autoscale All.

Autre moyen de régler l'échelle automatiquement :

  1. Dans le menu Scale, cliquez sur Scale.

  2. Dans la partie Scale de la boîte de dialogue, cliquez sur le bouton AutoScale pour que l'analyseur règle automatiquement l'échelle verticale de la trace sélectionnée. Ou alors cliquez sur le bouton AutoAll si vous souhaitez que le réglage automatique de l'échelle verticale porte sur toutes les traces affichées dans la fenêtre active.

  3. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches TRACE SETUP, appuyez sur Scale.

  2. Appuyez sur F1 (AutoScale) pour que l'analyseur règle automatiquement l'échelle verticale de la trace sélectionnée. Si vous souhaitez que ce réglage automatique porte sur toutes les traces affichées, passez à l'étape 3 de cette procédure.

  3. Appuyez sur la touche Menu/Dialog du bloc COMMAND.

  4. Dans le bloc de touches TRACE SETUP, appuyez sur Scale.

  5. Dans le bloc de touches NAVIGATION, utilisez la touche Tab de droite pour sélectionner le bouton AutoAll. Appuyez sur la touche OK du bloc COMMAND.

Définir la ligne de référence
Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Scale, cliquez sur Scale.

  2. Dans la partie Reference de la boîte de dialogue, cliquez sur le champ Level. Tapez une valeur ou cliquez sur la flèche pour sélectionner le niveau de référence souhaité.

  3. Dans la partie Reference de la boîte de dialogue, cliquez sur le champ Position. Tapez une valeur ou cliquez sur la flèche pour sélectionner la position de référence souhaitée.

  4. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

  1. Dans le bloc de touches TRACE SETUP, appuyez sur Scale.

  2. Appuyez sur F3 (Ref Level) et tapez la valeur du niveau de référence souhaité, ou alors sélectionnez-la à l'aide des touches fléchées du bloc NAVIGATION.

  3. Appuyez sur F3 (Ref Pos) et tapez la valeur de la position de référence souhaitée, ou alors sélectionnez-la à l'aide des touches fléchées du bloc NAVIGATION.


Frequency Range

Voir aussi...

Plage de fréquences

Présentation

Concepts

Comment régler la
plage de fréquences

La plage de fréquences est l'étendue de la bande de fréquences que vous définissez pour une mesure de composant.

Concepts

Comment régler la plage de fréquences

Plage de fréquences

Résolution de fréquence

Fréquences en mode d'onde entretenue (CW)

Plages de fréquences des analyseurs série PNA :

E8356A

300 kHz à 3 GHz

E8357A

300 kHz à 6 GHz

E8358A

300 kHz à 9 GHz

Résolution de fréquence

La résolution de réglage des fréquences est de1 Hz.

Fréquences en mode d'onde entretenue (CW)

Les mesures qui utilisent comme stimulus un balayage dans le temps CW ou un balayage en puissance sont réalisées à une fréquence fixe au lieu de balayer une plage de fréquences.

Remarque :vous avez la possibilité de masquer les valeurs de fréquence pour des raisons de sécurité.

Il existe deux moyens de régler la plage de fréquences :

  • Spécifiez les fréquences initiale et finale de la plage.

  • Spécifiez la fréquence centrale et la bande à couvrir autour de cette fréquence.

Procédure à l'aide de la souris

Procédure à l'aide des touches de la face avant

Procédure à l'aide de la souris

Pour régler la plage de fréquences en spécifiant une fréquence initiale et une fréquence finale :

  1. Dans le menu Channel, cliquez sur Start/Stop....

  2. Cliquez sur le champ Start. Tapez directement la valeur de la fréquence initiale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  3. Cliquez sur le champ Stop. Tapez directement la valeur de la fréquence finale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  4. Cliquez sur OK.

Pour régler la plage de fréquences en spécifiant une fréquence centrale et la bande à couvrir :

  1. Dans le menu Channel, cliquez sur Center/Span....

  2. Cliquez sur le champ Center. Tapez directement la valeur de la fréquence centrale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  3. Cliquez sur le champ Span. Tapez la valeur de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  4. Cliquez sur OK.

Procédure à l'aide des touches de la face avant

Pour régler la plage de fréquences en spécifiant une fréquence initiale et une fréquence finale :

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Start/Center ou Stop/Span.

  2. Appuyez sur F1 (Start).

  3. Tapez directement la valeur de la fréquence initiale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  4. Appuyez sur F2 (Stop).

  5. Tapez directement la valeur de la fréquence finale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  6. Appuyez sur Enter.

Pour régler la plage de fréquences en spécifiant une fréquence centrale et la bande à couvrir :

  1. Dans le bloc de touches CHANNEL SETUP, appuyez sur Start/Center ou Stop/Span.

  2. Appuyez sur F3 (Center).

  3. Tapez directement la valeur de la fréquence centrale de la bande à balayer ou sélectionnez-la à l'aide des touches fléchées.

  4. Appuyez sur F4 (Span).

  5. Tapez directement la valeur de la bande à balayer autour de la fréquence centrale ou sélectionnez-la à l'aide des touches fléchées.

  6. Appuyez sur Enter.


Measurement Parameters

Voir aussi...

Paramètres de mesure

Présentation

Concepts

Comment régler
les paramètres

Vous pouvez configurer l'analyseur afin de mesurer les caractéristiques électriques d'un composant en utilisant les paramètres suivants :

  • Paramètres S (rapports fixes)

  • Rapport arbitraire (choisissez vos propres mesures de rapports)

  • Puissance non proportionnelle (puissance absolue).
Concepts

Comment régler les paramètres de mesure

Paramètres S

Mesures communes avec les paramètres S

Graphique de flux de paramètres S

Rapport arbitraire

Puissance non proportionnelle

Paramètres S

Les paramètres S (paramètres de diffusion) sont utilisés pour caractériser la manière selon laquelle un signal est modifié par un composant. Ils décrivent les propriétés de réflexion et de transmission du composant sous test. La notation des paramètres S identifie le rapport entre deux quantités complexes en utilisant la convention de numérotation suivante :

S out in
où :

out = | la sortie de signal ; port du composant sous test où la réponse est mesurée
in = | l'entrée de signal ; (signal incident) port du composant sous test où le signal est appliqué ou injecté

Déplacez la souris sur le graphique pour explorer le flux du signal pour chaque paramètre S.

L'analyseur comporte deux ports de test et peut mesurer des composants à un ou deux ports. Vous pouvez définir le port de test d'entrée pour les mesures des paramètres S. L'analyseur change automatiquement la direction de la mesure (c'est-à-dire, directe ou inverse) en fonction des sélections. Par conséquent, l'analyseur peut mesurer les quatre paramètres S d'un composant à deux ports avec une seule connexion.

Les paramètres S d'un composant à deux ports sont S11, S21, S12 et S22. Placez la souris sur chaque paramètres S du dessin animé suivant afin d'afficher la relation qui existe entre le flux du signal et les paramètres S.

Les paramètres S d'un composant à deux ports sont illustrés davantage sur le dessin suivant, sur lequel :

  • a = le signal entrant dans le composant

  • b = le signal transmis par le composant.

Remarque : tous les paramètres S sont des valeurs linéaires complexes.

Remarque : la précision de la mesure dépend de la qualité des étalons et des techniques de connexion de mesure utilisées.

Remarque : la précision des mesures de paramètres S dépend en partie de la manière selon laquelle le port de la charge est fermé (le port n'étant pas simulé). Si la charge n'est pas parfaite, la valeur de a 1 ou de a 2 ne sera pas nulle (ce qui n'est pas conforme à la définition des paramètres S). Une c orrection d'e rreur au niveau des deux ports, qui corrige la source et l' a daptation de c harge , est très importante pour l'obtention de mesures de paramètres S précises. Voir Etalonnage pour plus d'informations.

Mesures communes avec les paramètres S

Les paramètres S sont équivalents aux termes de mesure communs suivants.

Paramètre S | Définition | Description | Direction
S11 | b1 / a1 où a2 = 0 | coefficient de réflexion (adaptation d'entrée) | directe
S21 | b2 /a1 où a2 = 0 | coefficient de transmission (gain ou perte) | directe
S12 | b1 /a2 où a1 = 0 | coefficient de transmission (isolement) | inverse
S22 | b2 /a2, a1 = 0 | coefficient de réflexion (adaptation de sortie) | inverse

Les mesures communes avec les paramètres S comprennent :

Les mesures de réflexion

Les mesures de transmission

  • Perte en réflexion

  • Taux d'ondes stationnaires (SWR)

  • Coefficient de réflexion

  • Im pédance

  • S11, S22

  • Perte d'I nsertion

  • Coefficient de transmission

  • Gain/Perte

  • Temps de propagation de groupe

  • Ecart par rapport à une phase linéaire

  • R etard électrique

  • S21, S12

Graphique de flux de paramètre S

Le graphique de flux suivant est une représentation graphique d'un flux de signaux dans un réseau ou un composant à deux ports sous test. Ce graphique de flux est également imprimé sur la face avant de l'analyseur.

Rapport arbitraire

Le rapport arbitraire permet de choisir votre propre rapport entre les signaux d'entrée et de référence en utilisant les récepteurs A, B, R1 et R2. Les utilisations communes de rapport arbitraire sont :

  • Les mesures personnalisées où vous utilisez les trajets directs vers les récepteurs A, B, R1 et R2 et où vous choisissez ensuite vos propres mesures de rapport.

  • Les mesures qui nécessitent une p lage dynamique supérieure à celle fournie par l'analyseur avec les paramètres S.

Les récepteurs A, B, R1 et R2 ont des connexions en face avant de l'analyseur.

  • Les connexions de face avant A (in) et B (in) permettent une connexion directe aux récepteurs A et B. Cela :

    • permet une augmentation de la sensibilité en retirant les coupleurs de port de test du trajet du signal

    • supprime environ 15 dB de perte du trajet du récepteur A ou B.

  • Les connexions de face avant A (out) et B (out) permettent un accès direct aux bras couplés des coupleurs des ports de test 1 et 2.

  • Les connexions de face avant R1 et R2 permettent certains montages de l'instrument tels que la réalisation de tests de haute puissance avec des composants externes en utilisant des amplificateurs et des coupleurs (fournis par l'utilisateur).

Le dessin suivant montre les trajets des signaux dans l'analyseur :

Les dessins suivants montrent l'emplacement de ces connexions sur la face avant de l'analyseur :

Option 015

Avec l'option dispositif de test configurable, les boucles d'accès de face avant sont prévues dans le trajet du signal entre la sortie de la source et l'entrée du coupleur. Des atténuateurs de 35 dB (paliers de 5 dB) sont également ajoutés dans les trajets de récepteur des deux ports. Cette option permet d'améliorer la sensibilité de la mesure et de mesurer des signaux de faible niveau ou d'ajouter des composants ou d'autres instruments périphériques pour une large gamme d'applications de mesure. Voir le didacticiel Mesures de composants haute puissance pour plus d'informations

Puissance non proportionnelle

Le paramètre de puissance non proportionnelle permet d'analyser la puissance absolue d'un composant entrant dans les récepteurs A, B, R1 et R2.

Remarque : les entrées simples ne peuvent pas être utilisées pour les mesures de phase ou de temps de propagation de groupe, ou n'importe quelle autre mesure où le moyennage est activé.

Cliquez sur les boutons pour accéder aux procédures.
Mesure des paramètres S

Mesure à rapport arbitraire

Mesure de puissance non proportionnelle

Mesure des paramètres S
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Measure.

  2. Cliquez sur le paramètre S souhaité.

Procédure à l'aide de la face avant

  1. Dans la zone TRACE SETUP, appuyez sur Measure.

  2. Appuyez sur F1 pour sélectionner S11.

  3. Appuyez sur F2 pour sélectionner S21.

  4. Appuyez sur F3 pour sélectionner S12.

  5. Appuyez sur F4 pour sélectionner S22.

  6. Appuyez sur Enter.

Mesure à rapport arbitraire
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Measure.

  2. Cliquez sur Measure....

  3. Dans la zone Trace Type, sélectionnez Arbitrary Ratio.

  4. Dans la zone Source Port, sélectionnez le port de source souhaité.

  5. Dans la zone Input, sélectionnez l'entrée souhaitée.

  6. Dans la zone Output, sélectionnez la sortie souhaitée.

  7. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone TRACE SETUP, appuyez sur Measure.

  3. Appuyez sur la touche Flèche vers le bas pour sélectionner Arbitrary Ratio dans la liste Trace Type.

  4. Appuyez sur la touche Tab à droite pour obtenir la liste Source Port. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner le port de source souhaité.

  5. Appuyez sur la touche Tab à droite pour obtenir la liste Input. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner l'entrée.

  6. Appuyez sur la touche Tab à droite pour obtenir la liste Output. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner la sortie.

  7. Dans la zone COMMAND, appuyez sur OK.

Mesure de puissance non proportionnelle
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Trace, cliquez sur Measure.

  2. Cliquez sur Measure....

  3. Dans la zone Trace Type, sélectionnez Unratioed Power.

  4. Dans la zone Source Port, sélectionnez le port de source souhaité.

  5. Dans la zone Input, sélectionnez l'entrée souhaitée.

  6. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans la zone COMMAND, appuyez sur Menu/Dialog.

  2. Dans la zone TRACE SETUP, appuyez sur Measure.

  3. Appuyez sur la touche Flèche vers le bas pour sélectionner Unratioed Power dans la liste Trace Type.

  4. Appuyez sur la touche Tab à droite pour obtenir la liste Source Port. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner le port de source souhaité.

  5. Appuyez sur la touche Tab à droite pour obtenir la liste Input. Appuyez sur la touche Flèche vers le haut ou Flèche vers le bas afin de sélectionner l'entrée.

  6. Dans la zone COMMAND, appuyez sur OK.


Multiple Traces and Channels

Voir aussi...

Affichage de traces et de voies multiples

Présentation

Configurations
de la mesure

Organisation de
l'affichage

Comment afficher ...

Vous pouvez configurer des mesures multiples de diverses manières. Une fois que tout est configuré, vous pouvez facilement redimensionner et déplacer les fenêtres afin d'adapter l'affichage de l'instrument à vos exigences de mesure particulières.
Configurations de mesure

Organisation de l'affichage

Comment afficher des traces et des voies multiples

Voies, traces et fenêtres multiples

Limites des mesures

Configurations de mesure prédéfinies

Configuration A : 4 traces, 1 fenêtres

Configuration B : 4 traces, 4 fenêtres

Configuration C : 3 traces, 3 fenêtres

Configuration D : 4 traces, 2 voies, 2 fenêtres

Voies, traces et fenêtres multiples

  • Une voie comporte un ensemble d'attributs indépendants associés aux données acquises. Ces attributs s'appliquent à toutes les traces attribuées à cette voie. Quatre voies indépendantes peuvent être définis.

  • Une trace comporte un ensemble unique d'attributs associés à des traitements mathématiques effectués sur les données acquises. L'analyseur permet de définir 16 traces maximum par écran.

  • Une fenêtre est utilisée pour afficher des traces. L'analyseur peut afficher 1, 2, 3, ou 4 fenêtres sur l'écran.

Vous pouvez créer :

  • De multiples traces et voies afin de mesurer et d'afficher les caractéristiques du dispositif en cours de test

  • De multiples fenêtres pour un meilleur affichage des données de mesure

Limites des mesures

  • Quatre fenêtres par écran

  • Quatre traces de données et quatre traces mémoire par fenêtre

  • 16 traces par écran

  • Quatre voies de mesure indépendants

Configurations de mesure prédéfinies

Cette fonctionnalité permet de créer rapidement des configurations de mesure utilisant des traces, des voies et des fenêtres multiples.

  • Il existe quatre configurations de mesure prédéfinies.

  • Chaque configuration crée de nouvelles traces.

  • Les traces existantes et leurs paramètres seront perdus, à moins qu'ils soient enregistrés avant l'utilisation de cette fonctionnalité.

Configuration A

  • Quatre traces S11, S21, S12, S22

  • Une fenêtre, format d'amplitude logarithmique

  • Une voie

    • S11, S21, S12, S22 dans la fenêtre 1

Configuration B

  • Quatre traces

  • Quatres fenêtres, format d'amplitude logarithmique

  • Une voie

    • S11 dans la fenêtre 1

    • S21 dans la fenêtre 2

    • S12 dans la fenêtre 3

    • S22 dans la fenêtre 4

Configuration C

  • Trois traces

  • Trois fenêtres, deux abaques de Smith et un format d'amplitude logarithmique

  • Une voie

    • S11 dans la fenêtre 1, format d'abaque de Smith

    • S22 dans la fenêtre 2, format d'abaque de Smith

    • S21 dans la fenêtre 3, format d'amplitude logarithmique

Configuration D

  • Quatre traces

  • Deux fenêtres, format d'amplitude logarithmique pour les deux

  • Deux voies

    • S11 et S21 pour la voie 1 de la fenêtre 1

    • S11 et S21 pour la voie 2 de la fenêtre 2

Organisation de l'affichage

Fenêtres : Mosaïque, Cascade, Organisation, Agrandissement/Restauration

Fonction Organisation des fenêtres

Superposition

Empilage 2

Division 3

Quadruple 4

Algorithme de tri

Organisation de l'affichage

L'analyseur permet :

  • De déplacer ou de redimensioner les fenêtres de l'analyseur à l'aide de la souris

  • D'organiser les fenêtres de l'analyseur en utilisant les fonctions Mosaïque, Cascade, Réduction et Agrandissement du menu Window

  • D'organiser les fenêtres de l'analyseur selon quatre configurations différentes grâce à la fonction Organisation des fenêtres

  • De redimensionner ou de masquer les fenêtres de l'analyseur en utilisant les fonctions de Microsoft Windows Maximize, Restore Down et Minimize situées dans le coin supérieur droit de chaque fenêtre

  • D'agrandir une fenêtre unique dans une configuration de fenêtres multiples par :

    • La sous-fenêtre Maximize dans le coin de la fenêtre

    • Les touches de face avant Maximize/Restore dans la zone UTILITY (effectuez la sélection par la touche Window dans le bloc DISPLAY)

Fonction Organisation des fenêtres

La fonction Organisation des fenêtres :

  • Propose quatre organisations de fenêtre

    • Superposition

    • Empilage 2

    • Division 3

    • Quadruple 4

  • Utilise les traces, voies et formats existants

  • Affiche les traces et les voies dans les fenêtres en se basant sur un algorithme de tri.

Organisation Superposition

  • Cette configuration place toutes les traces existantes dans une fenêtre unique, toutes superposées.

  • Si vous avez plus de quatre traces existantes, cette sélection est désactivée.

Organisation Empilage 2

  • Cette configuration place toutes les traces existantes dans deux fenêtres, "empilées" (verticalement).

  • Si vous avez plus de huit traces existantes, cette sélection est désactivée.

Organisation Division 3

  • Cette configuration place toutes les traces existantes dans trois fenêtres, deux dans la partie supérieure et une dans la partie inférieure.

  • Si vous avez plus de douze traces existantes, cette sélection est désactivée.

Organisation Quadruple 4

  • Cette configuration place toutes les traces existantes dans quatre fenêtres, une fenêtre par quadrant d'écran.

Algorithme de tri

L'algorithme de tri de la fonction Organisation des fenêtres est conçu de manière à :

  • Répartir les traces entre les fenêtres en se basant sur leurs propriétés

  • Regrouper les traces ayant des propriétés communes

L'algorithme effectue un tri en se basant sur les propriétés suivantes, par ordre de priorité :

  1. Format : circulaire (polaire ou Smith) ou rectiligne (amplitude logarithmique, amplitude linéaire, temps de propagation de groupe, etc...)

  2. Nombre de voies

  3. Transmission ou réflexion

Remarque : la limitation de l'analyseur à quatre traces par fenêtre est une limitation imposée à l'algorithme.

Cliquez sur les boutons pour accéder aux procédures.
Sélectionner une configuration de mesure prédéfinie

Sélectionner une configuration d'organisation des fenêtres

Agrandir une fenêtre unique dans une configuration de fenêtres multiples

Configuration de mesure prédéfinie
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Window, cliquez sur Meas Setups.

  2. Cliquez sur la configuration de mesure souhaitée.

Procédure à l'aide de la face avant

  1. Dans la zone DISPLAY, appuyez sur Measure Setups.

  2. Appuyez sur F1 (Configuration A) pour sélectionner quatre traces dans une fenêtre.

  3. Appuyez sur F2 (Configuration B) pour sélectionner quatre traces dans quatre fenêtres.

  4. Appuyez sur F3 (Configuration C) pour sélectionner quatre traces dans trois fenêtres.

  5. Appuyez sur F4 (Configuration D) pour sélectionner quatre traces dans deux fenêtres.

Sélectionner une configuration d'organisation des fenêtres
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Window, cliquez sur Arrange.

  2. Cliquez sur l'organisation des fenêtres souhaitée.

Procédure à l'aide de la face avant

  1. Dans la zone DISPLAY, appuyez sur Arrange Windows.

  2. Appuyez sur F1 (Superposition) pour afficher toutes les traces dans une fenêtre.

  3. Appuyez sur F2 (Empilage 2) pour afficher toutes les traces dans deux fenêtres empilées.

  4. Appuyez sur F3 (Configuration C) pour afficher toutes les traces dans trois fenêtres divisées.

  5. Appuyez sur F4 (Configuration D) pour afficher toutes les traces dans quatre fenêtres.

Agrandir une fenêtre unique dans une configuration de fenêtres multiples
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Cliquez sur la sous-fenêtre Maximize dans la fenêtre que vous souhaitez agrandir.

  2. Cliquez de nouveau dans la sous-fenêtre Maximize pour restaurer la taille originale de la fenêtre.

Procédure à l'aide de la face avant

  1. Dans la zone DISPLAY, appuyez sur Window pour sélectionner la fenêtre à agrandir.

  2. Dans la zone UTILITY, appuyez sur la touche Maximize/Restore.

  3. Appuyez de nouveau sur la touche Maximize/Restore pour restaurer la taille originale de la fenêtre.


Voir aussi...

Niveau de puissance

Présentation

Concepts

Comment régler
la puissance

Le niveau de puissance est la puissance du signal de source de l'analyseur au niveau du port de test.
Concepts

Comment régler la puissance

Les rubriques suivantes décrivent en détail les niveaux de puissance. Cliquez sur un bouton pour afficher les informations relatives à ces sujets.
Plage de puissance

Couplage de puissance entre les ports

Atténuation de la source

Atténuation automatique

Atténuation manuelle

Atténuation avec des ports non couplés

Rampe de puissance

Atténuation du récepteur

Plage de puissance

PLAGES ET RESOLUTION DE LA PUISSANCE DE LA SOURCE
Fréquence | Plage de la puissance de la source (dBm) | Résolution de la puissance (dB)
300 kHz - 6 GHz | -85 - +10 | 0.01
>6 GHz - 9 GHz | -85 - +5 | 0,01

Remarque : Voir Plage de fréquence pour les plages spécifiques des modèles d'analyseurs de réseaux.

Couplage de puissance entre les ports

Par défaut, les niveaux de puissance de PORT 1 et de PORT 2 sont couplés; le réglage de la puissance de sortie au niveau de chaque port est identique. Certaines applications de mesure nécessitent des niveaux de puissance différents au niveau du PORT 1 et du PORT 2. L'analyseur permet de ne pas coupler les puissances des ports de sorte que le réglage séparé des puissances de chaque port est possible.

Par exemple, si vous souhaitez mesurer le gain et l'isolement inverse d'un amplificateur à gain élevé, vous devez régler la puissance de chaque port séparément. Ceci est dû au fait que la puissance appliquée au port d'entrée de l'amplificateur est très inférieure à celle appliquée au port de sortie. Voir Atténuation avec des ports non couplés.

ATTENTION ! Les récepteurs de l'analyseur peuvent être endommagés si les niveaux de puissance de sortie dépassent les valeurs maximales : Entrée vers les ports de test : +30 dBm (1,0 Watt) Entrée directe vers les récepteurs : +15 dBm (31,6 mW)

Atténuation de la source

La source de l'analyseur utilise un atténuateur programmable pour couvrir la plage de puissance entière de 95 dB. L'atténuateur ajuste le niveau de puissance du signal de test dans le dispositif de test sans modifier le niveau de la puissance incidente dans le circuit de référence de l'analyseur. Cela permet :

  • Une précision et des performances supérieures pour le signal de source

  • Une adaptation de la source plus précise

L'atténuateur comporte huit positions différentes, permettant un réglage de la puissance dans huit plages de puissance différentes.

  • Chaque plage couvre 25 dB.

  • La plage optimale est une bande de 10 dB située au milieu de chaque plage de puissance. Cette plage fournit les meilleures précision et performances pour le système de régulation de niveau de la source. Voir les graphiques Plage d'atténuation.

  • Une position d'atténuation peut être sélectionnée manuellement ou automatiquement.

Remarque : La correction d'erreur n'est totalement efficace que pour le niveau de puissance auquel un étalonnage de la mesure a été effectué. Cependan t, si la puissance est modifiée dans la plage d'atténuation où l'étalonnage a été effectué, les mesures proportionnelles peuvent être effectuées avec pratiquement le maximum de précision (les mesures non proportionnelles avec moins de précision).

Atténuation automatique

Si la commande d'atténuation est sur Auto (par défaut), l'analyseur

  • Permet la sélection de n'importe quel niveau de puissance dans la plage de fonctionnement totale de l'instrument

  • Sélectionne automatiquement la position d'atténuation et la puisance de la source de sorte que la plage optimale de la plage d'atténuation totale soit utilisée.

Voir Valeurs d'atténuation et points de transition.

Atténuation manuelle

Certaines applications de mesure nécessitent un réglage manuelle de la puissance de la source et de l'atténuation. Celles-ci comprennent :

  • Les tests des amplificateurs à réflexion (oscillateurs ou amplificateurs en permanence instables)

Ceux-ci nécessitent une très bonne adaptation d'impédance avec la source (une perte par réflexion de 20dB) dans une large plage de fréquences. L'atténuateur permet une meilleure adaptation d'impédance que la source non atténuée de l'analyseur au cours d'un test sur une large plage de fréquences. Voir le didacticiel concernant les mesures de composant haute puissance.

    • Choisissez Auto Off et un niveau d'atténuation de 10 ou 20 dB (ou plus) afin de garantir la meilleure adaptation de la source.

  • Balayages de puissance

La commutation du réglage de l'atténuateur n'est pas permise pendant un balayage de la puissance afin d'éviter une usure prématurée provoquée par une commutation continue. Le réglage Auto peut ne pas permettre la couverture de la plage de balayage souhaitée totale.

    • Choisissez Auto Off et une combinaison de plage de puissance de source et de position d'atténuation pour couvrir la plage de balayage totale souhaitée nécessaire à la mesure.

Dans le mode d'atténuation Manuel, vous devez :

  • Sélectionner la puissance de la source.

  • Sélectionner le réglage d'atténuation.

  • Sélectionner les combinaisons dans la plage optimale.

VALEURS D'ATTENUATION, 300 kHz - 6 GHz

VALEURS D'ATTENUATION, 6 GHz -9 GHz

VALEURS D'ATTENUATION ET POINTS DE TRANSITION 300 kHz - 6 GHz
 |  |  | Plage optimale |  |
Attén. Valeur (dB) | Puissance minimale non spécifiée réglable (dBm) | Puissance minimale spécifiée (dBm) | Point de transition inférieur (dBm) | Point de transition supérieur (dBm) | Puissance maximale spécifiée (dBm)
0 | -20 | -15 | -5 | +5 (aucune transition) | +10
10 | -30 | -25 | -15 | -5 | 0
20 | -40 | -35 | -25 | -15 | -10
30 | -50 | -45 | -35 | -25 | -20
40 | -60 | -55 | -45 | -35 | -30
50 | -70 | -65 | -55 | -45 | -40
60 | -80 | -75 | -65 | -55 | -50
70 | -85 | ---- | -85 (aucune transition) | -65 | -60
VALEURS D'ATTENUATION ET POINTS DE TRANSITION 6 GHz - 9 GHz
 |  |  | Plage optimale |  |
Attén. Valeur (dB) | Puissance minimale non spécifiée réglable (dBm) | Puissance minimale spécifiée (dBm) | Point de transition inférieur (dBm) | Point de transition supérieur (dBm) | Puissance maximale spécifiée (dBm)
0 | -20 | -15 | -5 | +5 (aucune transition) | +5
10 | -30 | -25 | -15 | -5 | -5
20 | -40 | -35 | -25 | -15 | -15
30 | -50 | -45 | -35 | -25 | -25
40 | -60 | -55 | -45 | -35 | -35
50 | -70 | -65 | -55 | -45 | -45
60 | -80 | -75 | -65 | -55 | -55
70 | -85 | ---- | -85 (aucune transition) | -65 | -65

Atténuation avec des ports non couplés

La commutation de l'atténuateur peut être effectuée entre les ports 1 et 2 s'il n'y a pas de couplage entre la puissance des ports de test. Pour éviter une usure prématurée de l'atténuateur mécanique, l'analyseur :

  • empêche une commutation continue entre les deux plages de puissance

  • active automatiquement le mode de maintien après une première mesure de chaque voie

Si le moyennage est validé, le mode de maintien ne sera activé que si le nombre de balayages spécifié a été réalisé pour chaque voie.

Rampe de puissance

La rampe de puissance permet la compensation des pertes dans le câble et dans les accessoires de test aux fréquences supérieures.

  • Si la caractéristique de rampe de puissance est activée, la puissance de sortie du port augmente (ou diminue) avec l'augmentation de la fréquence de balayage.

  • La rampe de puissance s'exprime en dB/GHz.

  • Les valeurs de la rampe de puissance sont uniquement 0,5, 1, 1,5 ou 2 (positives ou négatives).

Atténuation du récepteur (avec l'option 015)

ATTENTION ! Les récepteurs de l'analyseur peuvent être endommagés par les niveaux de puissance de sortie qui dépassent les valeurs maximales : Entrée vers les ports de test : +30 dBm (1,0 Watt) Entrée directe vers les récepteurs : +15 dBm (31,6 mW)

Pour éviter d'endommager le récepteur de l'analyseur, il peut être nécessaire d'atténuer le signal de sortie du composant en cours de test. L'option 015 fournit les atténuateurs internes des deux récepteurs.

  • Plage : 0 à 35 dB

  • Résolution : 5 dB

Cliquez sur les boutons pour accéder aux procédures indiquées.
Régler le niveau de puissance

Couper la puissance vers un composant en cours de test

Régler l'atténuation manuellement

Régler la rampe de puissance

Régler le niveau d'atténuation du récepteur de l'analyseur (uniquement avec l'option 015)

Régler le niveau de puissance
Procédure utilisant la souris

Procédure utilisant les touches de la face avant

ATTENTION ! Les récepteurs de l'analyseur peuvent être endommagés par les niveaux de puissance de sortie qui dépassent les valeurs maximales : Entrée vers les ports de test : +30 dBm (1,0 Watt) Entrée directe vers les récepteurs : +15 dBm (31,6 mW)

Procédure utilisant la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Dans la zone de texte Test Port Power, tapez la valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner le niveau de puissance souhaité pour le port 1. Du fait du couplage des puissances (par défaut), la puissance du port 2 est également fixée.

  3. Si vous souhaitez régler de manière individuelle le niveau de puissance de chaque port, cliquez sur la case Port Power Coupled pour retirer le couplage entre les ports. Dans la zone Port, sélectionnez le port souhaité. Répétez l'étape 2 de cette procédure.

  4. Cliquez sur OK.

Procédure utilisant les touches de la face avant

  1. Dans le groupe de touches CHANNEL SETUP, appuyez sur Power.

  2. Appuyez sur F1 (Level) et tapez la valeur ou appuyez sur la flèche vers le haut ou vers le bas pour fixer le niveau de puissance souhaité.

  3. Appuyez sur Enter.

Couper la puissance vers un dispositif en cours de test
Procédure utilisant la souris

Procédure utilisant les touches de la face avant

Procédure utilisant la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Cliquez sur la case Power On pour couper la puissance.

  3. Cliquez sur OK.

Procédure utilisant les touches de la face avant

  1. Dans le groupe de touches CHANNEL SETUP, appuyez sur Power.

  2. Appuyez sur F2 (ON/off) pour couper la puissance.

Régler l'atténuation manuellement
Procédure utilisant la souris

Procédure utilisant les touches de la face avant

Procédure utilisant la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Dans la partie de la boîte de dialogue Attenuator Control, cliquez sur la case Auto pour arrêter la commande automatique d'atténuation et activer la commande manuelle.

  3. Cliquez sur la liste Attenuator Control et entrez la valeur ou cliquez sur le bouton marqué d'un flèche pour sélectionner l'atténuation souhaitée.

  4. Cliquez sur OK.

Procédure utilisant les touches de la face avant

  1. Dans le groupe de touches CHANNEL SETUP, appuyez sur Power.

  2. Appuyez sur F3 (Atten-Auto) pour passer la commande d'atténuation en mode manuel.

  3. Tapez la valeur ou appuyez sur la flèche vers le haut ou vers le bas pour sélectionner l'atténuation souhaitée.

  4. Appuyez sur Enter.

Régler la rampe de puissance
Procédure utilisant la souris

Procédure utilisant les touches de la face avant

Procédure utilisant la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Dans la partie Power Slope de la boîte de dialogue, cliquez sur la case à cocher Slope.

  3. Cliquez sur la liste Slope (dB/GHz) et entrez une valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner la valeur de rampe souhaitée.

  4. Cliquez sur OK.

Procédure utilisant les touches de la face avant

  1. Dans le groupe de touches CHANNEL SETUP, appuyez sur Power.

  2. Appuyez sur F4 (Slope) et tapez la valeur ou appuyez sur la flèche Haut ou Bas pour fixer la valeur de la rampe de puissance souhaitée.

  3. Appuyez sur Enter.

Régler le niveau d'atténuation du récepteur de l'analyseur (uniquement avec l'option 015)
Procédure utilisant la souris

Procédure utilisant les touches de la face avant

ATTENTION ! Les récepteurs de l'analyseur peuvent être endommagés par les niveaux de puissance de sortie qui dépassent les valeurs maximales : Entrée vers les ports de test : +30 dBm (1,0 Watt) Entrée directe vers les récepteurs : +15 dBm (31,6 mW)

Procédure utilisant la souris

  1. Dans le menu Channel, cliquez sur Power.

  2. Dans la partie Receiver Attenuation de la boîte de dialogue, cliquez sur la liste du Récepteur A ou du Récepteur B. Entrez une valeur ou cliquez sur le bouton marqué d'une flèche pour sélectionner la valeur d'atténuation souhaitée du récepteur.

  3. Appuyez sur Enter.

Procédure utilisant les touches de la face avant

  1. Dans le groupe de touches COMMAND, appuyez sur Menu/Dialog.

  2. Dans le groupe de touches CHANNEL SETUP, appuyez sur Power.

  3. Appuyez sur Tab droit pour sélectionner le Récepteur A ou le Récepteur B dans la partie Receiver Attenuation de la boîte de dialogue Power. Tapez la valeur ou appuyez sur la flèche vers le haut ou vers le bas pour sélectionner l'atténuation souhaitée.

  4. Appuyez sur Enter.

  5. Dans le groupe de touches COMMAND, appuyez sur OK.


Step 1 Setting Up

Configurer l'analyseur

Voir aussi...

Cliquez sur l'un des boutons ci-dessous pour apprendre rapidement comment configurer l'analyseur pour réaliser une mesure.
Mettre en réseau et connecter l'analyseur

Prérégler l'analyseur

Configurer des mesures

Sélectionner un paramètre de mesure

Définir une plage de fréquence

Définir le niveau de puissance RF

Sélectionner le balayage

Sélectionner le déclenchement

Sélectionner le format et l'échelle des données

Régler l'écran

Visualiser plusieurs traces et voies

Personnaliser l'écran de l'analyseur

Désactiver la fréquence/les lignes de stimulus de l'affichage


Sweep

Voir aussi...

Balayage

Présentation

Concepts

Comment définir des
balayages linéaires,
en puissance et CW

Comment définir un
balayage de segment

Un balayage est une série de mesures de points de données consécutives réalisées sur une séquence spécifiée de valeurs de stimulus.
Concepts

Comment définir des balayages linéaires, en puissance et CW

Comment définir un balayage de segment

Types de balayage

Fréquence linéaire

Puissance

Temps CW

Balayage de segment

Barre d'outils de contrôle de balayage

Types de balayage

Il existe quatre types de balayage.

Fréquence linéaire

Il s'agit du balayage par défaut. La fréquence est balayée linéairement et en continu sur toute la plage de fréquence.

La figure ci-dessous montre le balayage de fréquence linéaire d'un filtre avec une plage de balayage s'étendant de 50,000 MHz à 200,000 MHz.

Puissance

Le balayage en puissance permet de caractériser les circuits sensibles à la puissance au moyen de mesures telles que la compression du gain ou la pente AGC (Automatic Gain Control).

  • La puissance est balayée depuis une valeur de départ jusqu'à une valeur d'arrêt à la même fréquence.

  • Un balayage en puissance est un balayage par paliers.

    • L'amplitude source augmente par paliers de puissance discrets à chaque point de donnée sur toute la plage de balayage en puissance.

    • Le nombre de points de données et la plage de puissance déterminent la taille des paliers.

  • Choisissez la plage de puissance source et la position de l'atténuateur manuel pour obtenir la plage de balayage en puissance requise pour la mesure.Voir Niveau de puissance .

La figure ci-après montre le balayage en puissance d'un amplificateur, avec une plage de puissance s'étendant de -5,0 dBm à +10 dBm.

Temps CW

Le balayage dans le temps CW est similaire à la fonction d'un oscilloscope.

  • L'analyseur est réglé à une même fréquence.

  • Les données de la réponse sont affichées en fonction du temps.

  • Les données sont continuellement échantillonnées à des intervalles précis et réguliers déterminés par le temps de balayage et le nombre de points moins un.

La figure ci-dessous montre le balayage dans le temps CW d'un amplificateur, avec une plage de temps s'étendant de 0 à 6 ms.

Balayage de segment

Le balayage de segment permet à l'analyseur de balayer une série arbitraire de points de fréquence. Les sous-balayages de fréquence (appelés "segments") peuvent être spécifiés pour un nombre total maximum de 1601 points de données. Un balayage de segment s'applique à toutes les traces d'unen voie. Vous pouvez définir les segments individuellement de telle manière qu'ils aient une plage de fréquence et un nombre de points indépendants. En outre, chaque segment peut avoir :

  • Une bande passante FI indépendante (Voir Optimiser les mesures.)

  • Un niveau de puissance indépendant

  • Un temps de balayage indépendant

Une fois l'étalonnage de la mesure réalisé sur l'intégralité du balayage ou sur tous les segments, vous pouvez effectuer des mesures étalonnées sur un ou plusieurs segments.

L'analyseur de réseau :

  • Trie tous les segments définis afin d'augmenter la fréquence

  • Mesure chaque point

  • Affiche une trace unique combinant toutes les données collectées

Considérations relatives au balayage de segment :

  • La plage de fréquence d'un segment ne doit pas recouvrir la plage de fréquence d'un autre segment.

  • Tous les segments doivent avoir des niveaux de puissance compris dans la même plage d'atténuateur afin d'éviter l'usure prématurée de l'atténuateur mécanique par paliers.Voir Niveau de puissance.

Barre d'outils de contrôle du balayage

La barre d'outils de contrôle de balayage s'affiche au-dessus des fenêtres situées en haut de l'écran. Dans l'ordre, les boutons de cette barre d'outils définissent la voie active pour :

  • Le mode Hold

  • Un balayage Single, puis le mode Hold

  • Un balayage Continuous

Pour plus d'informations, voir Déclenchement.

Cliquez sur les boutons ci-dessous pour accéder aux procédures correspondantes.
Configurer un balayage de fréquence linéaire

Configurer un balayage en puissance

Configurer un balayage dans le temps CW

Balayage de fréquence linéaire
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Sweep Type.

  2. Dans la boîte Sweep Type, cliquez sur Linear Frequency.

  3. Cochez la case Start dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner la fréquence de départ désirée de la plage de balayage.

  4. Cochez la case Stop dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner la fréquence d'arrêt désirée de la plage de balayage.

  5. Cochez la case Points dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le nombre désiré de points de données sur la plage de balayage.

  6. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Type.

  2. Appuyez sur la touche F1 (Linear).

  3. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Setup.

  4. Appuyez sur la touche F2 (Points) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le nombre désiré de points de données.

  5. Appuyez sur la touche Entrée.

Balayage en puissance
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Sweep Type.

  2. Dans la boîte Sweep Type, cliquez sur Power Sweep.

  3. Cochez la case Start dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le niveau de puissance de départ désiré de la plage de balayage.

  4. Cochez la case Stop dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le niveau de puissance d'arrêt désiré de la plage de balayage.

  5. Cochez la case CW Freq dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner la fréquence CW du balayage en puissance.

  6. Cliquez sur OK.

  7. Dans le menu Sweep, cliquez sur Number of Points. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le nombre désiré de points de données sur la plage de puissance du balayage.

  8. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Type.

  2. Appuyez sur la touche F2 (Pwr Sweep).

  3. Dans le bloc CHANNEL SETUP, appuyez sur Power.

  4. Appuyez sur la touche F1 (Start Power) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le niveau de puissance de départ désiré pour le balayage.

  5. Appuyez sur la touche Entrée.

  6. Appuyez sur la touche F2 (Stop Power) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le niveau de puissance d'arrêt désiré pour le balayage.

  7. Appuyez sur la touche Entrée.

  8. Dans le bloc CHANNEL SETUP, appuyez sur Start/Center ou sur Stop/Span.

  9. Appuyez sur la touche F3 (CW Freq) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir la fréquence CW désirée pour le balayage.

  10. Appuyez sur la touche Entrée.

Balayage dans le temps CW
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Sweep Type.

  2. Dans la boîte Sweep Type, cliquez sur CW Time.

  3. Cochez la case CW Freq dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner la fréquence CW désirée pour le balayage.

  4. Cochez la case Sweep Time dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le temps de balayage désiré.

  5. Cochez la case Points dans la zone Sweep Properties de la boîte de dialogue. Entrez la valeur ou cliquez sur les boutons fléchés pour sélectionner le nombre désiré de points de données pour le balayage en puissance.

  6. Cliquez sur OK.

Procédure à l'aide de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Type.

  2. Appuyez sur la touche F3 (CW Time).

  3. Dans le bloc CHANNEL SETUP, appuyez sur Start/Center.

  4. Appuyez sur la touche F1 (CW Freq) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir la fréquence CW désirée pour le balayage.

  5. Appuyez sur la touche Entrée.

  6. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Setup.

  7. Appuyez sur la touche F1 (Time) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le temps de balayage désiré.

  8. Appuyez sur la touche Entrée.

  9. Appuyez sur la touche F2 (Points) et entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le nombre désiré de points de données pour le balayage.

  10. Appuyez sur la touche Entrée.

Procédure de balayage de segment
Procédure à l'aide de la souris

Procédure à l'aide de la face avant

Procédure à l'aide de la souris

Pour sélectionner le balayage de segment :

  1. Dans le menu Sweep, cliquez sur Sweep Type.

  2. Dans la boîte Sweep Type, cliquez sur Segment Sweep.

  3. Si vous souhaitez que les segments du balayage aient des niveaux de puissance indépendants, cochez la case Independent Power Levels dans la zone Sweep Properties de la boîte de dialogue.

  4. Si vous souhaitez que les segments du balayage aient des bandes passantes FI indépendantes, cochez la case Independent IF Bandwidth dans la zone Sweep Properties de la boîte de dialogue.

  5. Si vous souhaitez que les segments du balayage aient des temps de palier indépendants, cochez la case Independent Dwell Time dans la zone Sweep Properties de la boîte de dialogue.

  6. Cochez la case Show Table dans la zone Sweep Properties de la boîte de dialogue pour afficher le tableau de segments.

  7. Cliquez sur OK.

Pour définir des segments :

  1. Pour ajouter un segment, cliquez sur Insert Segment dans le sous-menu Segment Table du menu Sweep.

  2. Pour supprimer un segment, cliquez sur le numéro de segment désiré pour le sélectionner. Cliquez sur Delete Segment dans le sous-menu Segment Table du menu Sweep.

  3. Cochez la case STATE pour le premier segment du tableau de segments. Appuyez sur le bouton fléché pour placer le segment dans l'état ON.

  4. Cochez la case START pour le premier segment du tableau de segments. Entrez la fréquence de départ désirée de ce segment.

  5. Cochez la case STOP pour le premier segment du tableau de segments. Entrez la fréquence d'arrêt désirée de ce segment.

  6. Cochez la case POINTS pour le premier segment du tableau de segments. Entrez le nombre désiré de points de données pour ce segment.

  7. Si vous avez sélectionné des niveaux de puissance indépendants à l'étape 4 de cette procédure, cochez la case POWER pour le premier segment du tableau de segments. Entrez le niveau de puissance désiré pour ce segment.

  8. Si vous avez sélectionné des bandes passantes FI indépendantes à l'étape 5 de cette procédure, cochez la case IFBW pour le premier segment du tableau de segments. Entrez la bande passante FI désirée pour ce segment.

  9. Si vous avez sélectionné des temps de palier indépendants à l'étape 6 de cette procédure, cochez la case DWL TIME pour le premier segment du tableau de segments. Entrez le temps de palier pour ce segment.

  10. Cliquez sur OK.

Procédure à l'aide de la face avant

Pour sélectionner le balayage de segment :

  1. Dans le bloc CHANNEL SETUP, appuyez sur Sweep Type.

  2. Appuyez sur la touche F4 (Segment).

  3. Pour définir ou modifier les caractéristiques du balayage de segment, appuyez sur Menu/Dialog dans le bloc COMMAND, puis appuyez sur Sweep Type dans le bloc CHANNEL SETUP. Ceci a pour effet d'afficher la boîte de dialogue Sweep Type.

  4. Appuyez sur la touche de tabulation de droite pour avancer jusqu'à la zone Sweep Type de la boîte de dialogue. Appuyez sur la flèche vers le bas pour sélectionner Segment Sweep.

  5. Si vous souhaitez que les segments du balayage aient des niveaux de puissance indépendants, appuyez sur la flèche vers la droite pour avancer jusqu'à la case Independent Power Levels dans la zone Sweep Type de la boîte de dialogue. Appuyez sur Click.

  6. Si vous souhaitez que les segments du balayage aient des bandes passantes FI indépendantes, appuyez sur la flèche vers le bas pour avancer jusqu'à la case Independent IF Bandwidth dans la zone Sweep Type de la boîte de dialogue. Appuyez sur Click.

  7. Si vous souhaitez que les segments du balayage aient des temps de palier indépendants, appuyez sur la flèche vers le bas pour avancer jusqu'à la case Independent Dwell Time dans la zone Sweep Type de la boîte de dialogue. Appuyez sur Click.

  8. Appuyez sur la touche de tabulation de droite pour avancer jusqu'à la case Show Table dans la zone Sweep Properties de la boîte de dialogue pour afficher le tableau de segments.

Pour définir des segments :

  1. Appuyez sur Click. Ceci a pour effet de présenter les options STATE : ON et OFF. Utilisez les flèches vers le haut et vers le bas pour avancer jusqu'à l'état désiré.

  2. Appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée START du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir la fréquence de départ désirée pour ce segment du balayage.

  3. Appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée STOP du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir la fréquence d'arrêt désirée pour ce segment du balayage.

  4. Appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée POINTS du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le nombre désiré de points de données pour ce segment du balayage.

  5. Si vous avez coché la case Independent IF Bandwidth dans la boîte de dialogue Sweep Type, appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée IFBW du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir la bande passante FI de ce segment du balayage.

  6. Si vous avez coché la case Independent Power Levels dans la boîte de dialogue Sweep Type, appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée POWER du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le niveau de puissance de ce segment du balayage.

  7. Si vous avez coché la case Independent Dwell Time dans la boîte de dialogue Sweep Type, appuyez sur la touche de tabulation de droite pour avancer jusqu'à l'entrée IFBW du tableau de segments. Entrez la valeur ou appuyez sur les flèches vers le haut ou vers le bas pour définir le temps de palier de ce segment du balayage.

  8. Pour ajouter des segments, appuyez sur la touche de tabulation de droite pour avancer jusqu'au menu Sweep. Appuyez sur la flèche vers le bas pour avancer jusqu'à Segment Table. Appuyez sur la touche de tabulation de droite pour faire apparaître le menu Segment Table. Appuyez sur la flèche vers le bas pour avancer jusqu'à l'entrée Insert Segment. Appuyez sur Click ou sur le bouton OK dans le bloc COMMAND pour sélectionner Insert Segment.

  9. Pour supprimer des segments, sélectionnez un segment dans le tableau de segments à supprimer. Appuyez sur la touche de tabulation de droite pour avancer jusqu'au menu Sweep. Appuyez sur la flèche vers le bas pour avancer jusqu'à Segment Table. Appuyez sur la touche de tabulation de droite pour faire apparaître le menu Segment Table. Appuyez sur la flèche vers le bas pour avancer jusqu'à l'entrée Delete Segment. Appuyez sur Click ou sur le bouton OK dans le bloc COMMAND pour sélectionner Delete Segment.

  10. Répétez les étapes 10 à 16 pour chaque entrée du tableau de segments.

  11. Cliquez sur le bouton OK dans le bloc COMMAND.


Trigger

Voir aussi...

Déclenchement

Présentation

Concepts

Comment définir un déclenchement

Un déclenchement est un signal qui entraîne la réalisation d'un balayage de mesure par l'instrument. De plus, les paramètres de déclenchement déterminent le mode de démarrage du balayage de mesure et quand l'analyseur cessera de balayer pour revenir en état Hold.
Concepts

Comment définir un déclenchement

L'analyseur offre une grande souplesse dans la configuration de la fonction de déclenchement.
Modèle de déclenchement

Source de déclenchement

Interne (Internal)

Manuel (Manual)

Externe (External)

Etendue du déclenchement

Global

Voie (Channel)

Etat de déclenchement de la voie

Continu (Continuous)

Groupe (Group)

Unique (Single)

Mode de maintien (Hold)

Point

Paramètres de déclenchement et RESTART

Modèle de déclenchement

Le modèle de déclenchement animé représente les signaux de déclenchement sous forme de balles. L'objectif est de placer les balles dans les voies. Ce modèle possède trois voies. Lorsqu'une voie accepte une balle, il réalise une mesure. Voir l'animation du modèle de déclenchement.

  • La boîte du haut (Trigger Source) contient les balles. Un événement de déclenchement valide (généré uniquement lorsque l'analyseur n'effectue pas de balayage) libère une balle qui est acheminée vers les voies. Le paramètre Trigger Source indique si les balles proviennent :

    • d'une boîte Interne

    • d'une boîte Externe

    • ou si elles sont introduites Manuellement dans le système, une à une.

  • Lorsque la balle tombe dans la boîte du milieu, le paramètre Trigger Scope détermine comment la balle est introduite dans le système.

    • Si le paramètre est Global, la balle devient trois balles, à raison d'une par voie. Des conduits guident ensuite une à une ces balles vers la voie approprié.

    • Si le paramètre est Channel, la balle est guidée vers la prochaine voie disponible.

  • Le paramètre Channel Trigger State de chaque voie détermine si la voie acceptera les balles et, dans l'affirmative, combien.

Source de déclenchement

Vous pouvez sélectionner l'une des trois sources de signaux de déclenchement offertes par l'analyseur : interne, externe ou manuelle. Une fois le paramètre sélectionné, l'analyseur identifie cette source comme la source de déclenchement de toutes les voies existantes. Voir l'animation du modèle de déclenchement.

  • Un signal de déclenchement valide ne peut être généré que lorsque l'analyseur n'effectue pas de balayage.

Déclenchement interne (par défaut)

  • Contrôlé par l'analyseur

  • Génère un signal de déclenchement dès que l'analyseur a terminé une mesure

Déclenchement manuel

Un signal de déclenchement manuel est généré par l'une des actions suivantes :

  • Un clic sur Trigger! dans le menu ou la boîte de dialogue Trigger

  • L'envoi d'une commande de déclenchement à distance

  • Un appui sur la touche Trigger de la face avant

Si vous tentez d'envoyer un signal de déclenchement manuel alors qu'une mesure est toujours en cours, la demande de déclenchement est ignorée. La mesure doit être terminée (l'analyseur doit cesser le balayage) pour qu'un signal de déclenchement puisse être reconnu.

Déclenchement externe

  • Appliqué via le connecteur Auxiliary I/O du panneau arrière (broche 19).

  • Signal TTL.

  • Sensible au niveau : actif haut ou actif bas.

  • L'impulsion doit être d'au moins 1 us et ne doit pas être plus longue que le temps de balayage. (Les impulsions supérieures au temps de balayage peuvent générer plusieurs déclenchements.)

  • Si le niveau du déclenchement externe est maintenu au niveau du déclenchement, un mode de balayage continu peut être implémenté. Ce mode peut être annulé en sélectionnant le mode déclenchement unique dans le menu de déclenchement externe. Lorsque le paramètre déclenchement unique est sélectionné, l'analyseur réagit à la première transition du signal de déclenchement vers un état valide, puis passe en mode de maintien jusqu'à ce que le déclenchement soit réinitialisé à unique.

Ready for Trigger externe

  • La ligne Ready for Trigger est également accessible via le connecteur Auxiliary I/O du panneau arrière (broche18).

  • Signal TTL actif bas.

  • Lorsque la ligne Ready for Trigger est basse et qu'un signal de déclenchement externe valide est reçu, la ligne Ready for Trigger est maintenue à l'état haut pendant toute la durée de la mesure. Par exemple, si l'analyseur est en mode de balayage alterné et que deux ports sont étalonnés, quatre balayages sont requis pour mettre à jour les données. La ligne Ready for Trigger reste haute (non prêt) jusqu'à ce que les quatre balayages aient été réalisés et que les données aient été mises à jour.

Etendue du balayage

L'étendue du balayage permet de déterminer quelles voies de mesure recevront un signal de déclenchement. Les deux paramètres Trigger Scope sont Global et Channel. Voir l'animation du modèle de déclenchement pour visualiser comment l'étendue du déclenchement affecte le flux du signal de déclenchement.

Global (par défaut)

  • Envoie un signal de déclenchement de la source de déclenchement vers toutes les voies actifs.

  • Acquiert toutes les données de mesure de toutes les voies actives avec un signal de déclenchement unique (sauf pour les voies en mode de maintien).

Channel

  • Envoie un signal de déclenchement de la source de déclenchement vers la voie active uniquement.

  • Sélectionné automatiquement si, pour l'une des voies, l'état de déclenchement est défini à Point.

Lorsque le voie active termine son cycle de mesure, l'analyseur sélectionne automatiquement la voie suivant. Les voies sont sélectionnées séquentiellement, sauf si l'état de déclenchement de la voie est Hold. Si une seule voie est défini ou si une seule voie n'est pas dans l'état Hold, la voie actif reste le même.

Etat de déclenchement de la voie

Vous pouvez sélectionner l'un des quatre états de déclenchement de la voie afin de définir le nombre de signaux de déclenchement qu'une voie acceptera : Continuous, Group, Single et Hold.

  • Une voie accepte les signaux de déclenchement s'il n'est PAS dans l'état Hold.

Chaque signal de déclenchement accepté conduit la voie à initier toutes les mesures dans cette voie (sauf dans l'état Point). Par exemple, s'il existe des mesures S21 et S22 dans la voie 3, un signal de déclenchement initiera les deux mesures. Voir l'animation du modèle de déclenchement pour visualiser comment l'état de déclenchement de la voie affecte le flux du signal de déclenchement.

Une fois qu'une voie a accepté le nombre de signaux de déclenchement spécifié, il :

  • Passe dans l'état Hold désarmé

  • Ignore les signaux de déclenchement

Continuous (par défaut)

La voie accepte un nombre illimité de signaux de déclenchement.

Group

Le voie n'accepte que le nombre spécifié de signaux de déclenchement.

Single

La voie n'accepte qu'un seul signal de déclenchement.

Hold

Les événements de déclenchement sont ignorés. Bien que des déclenchements se produisent toujours, ils n'affectent pas les voies en mode de maintien. La voie n'acquiert pas de nouvelles données dans ce mode. (Vous pouvez toujours mettre à jour les données à l'écran à l'aide des fonctionnalités de post-traitement, telles que le lissage, Time Domain, etc.)

Point

Une voie est balayée point par point. Lorsqu'une voie dans l'état Point reçoit un signal de déclenchement, il acquiert le point de donnée suivant dans le balayage en cours. Une voie dans l'état Point acceptera les signaux de déclenchement jusqu'à ce que toutes les mesures de cette voie soient terminées.

Les états Single et Group fonctionnent de manière différente pour une voie qui se trouve également dans l'état Point.

  • Single : la voie accepte les signaux de déclenchement jusqu'à ce que toutes les mesures de cette voie soient terminées une fois. Par exemple, une voie configuré avec une trace de 101 points de données acceptera 101 signaux de déclenchement.

  • Group : la voie accepte les signaux de déclenchement jusqu'à ce que toutes les mesures de cette voie soient terminées le nombre de fois spécifié. Par exemple, une voie configuré avec une trace de 101 points de données, avec un paramètre Group de 3, acceptera 303 signaux de déclenchement.

L'analyseur mesure les entrées A et B durant chaque balayage. Ainsi :

  • Les mesures S11 et S21 seront effectuées sur le même balayage.

  • Les mesures S12 et S22 seront effectuées sur le même balayage (à partir du port opposé).

Cela signifie que les mesures S11 et S21 (ou S12 et S22) peuvent être réalisées point par point simultanément dans l'état Point.

Remarque : les paramètres de balayage dépendent de la voie. Si la voie est configurée pour un balayage alterné, une seule entrée est mesurée par balayage. Si la voie est configurée pour un balayage alterné, une seule mesure point par point peut être réalisée à la fois.

Remarque : l'état Point n'est pas compatible avec le paramètre Trigger Scope Global. Si l'une des voies est placée dans l'état Point, l'étendue du déclenchement est définie à Channel.

Paramètre de déclenchement et RESTART

La commande RESTART s'applique à toutes les voies existants. Lorsqu'il reçoit la commande RESTART, l'analyseur cesse tout balayage et les états de déclenchement de voie sont affectés de la manière suivante :

  • Toutes les voies qui se trouvent dans l'état Point à la réception de la commande RESTART quittent l'état Point.

  • Si une voie se trouve dans l'état Hold, le compteur de déclenchements est réinitialisé à un (la voie accepte un seul signal de déclenchement).

  • Si une voie se trouve dans l'état Group, le compteur de déclenchements reste tel qu'il était à la réception de la commande RESTART.

  • Si une voie se trouve dans l'état Continuous, il continue à accepter un nombre illimité de signaux de déclenchement.

L'analyseur reprend ensuite le balayage. Si la source de déclenchement est définie à Manual, un seul signal de déclenchement est envoyé. Les voies existantes répondent en fonction de leur état de déclenchement de la voie. Chaque trace à l'écran doit être mise à jour au moins une fois.

Cliquez sur les boutons suivants pour accéder aux procédures correspondantes :
Paramètres de déclenchement unique

Définir le déclenchement

Paramètres de déclenchement unique
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Trigger.

  2. Cliquez sur le paramètre de votre choix : Continuous, Single, Hold ou Restart.

A l'aide des touches de la face avant

  1. Dans le bloc CHANNEL SETUP, appuyez sur Trigger.

  2. Appuyez sur la touche F1 pour sélectionner le paramètre Continuous.

  3. Appuyez sur la touche F2 pour sélectionner le paramètre Single.

  4. Appuyez sur la touche F3 pour sélectionner le paramètre Hold.

  5. Appuyez sur la touche F4 pour sélectionner le paramètre Restart.

Définir le déclenchement
A l'aide de la souris

A l'aide des touches de la face avant

A l'aide de la souris

  1. Dans le menu Sweep, cliquez sur Trigger.

  2. Cliquez sur Trigger...

  3. Dans la zone Trigger Source de la boîte de dialogue, sélectionnez le paramètre de votre choix : Internal, External ou Manual.

  4. Dans la zone Trigger Scope de la boîte de dialogue, sélectionnez le paramètre de votre choix : Global ou Channel.

  5. Dans la zone Trigger State de la boîte de dialogue, sélectionnez la voie de votre choix.

  6. Dans la zone Trigger State de la boîte de dialogue, sélectionnez : Continuous, Enable Groups, Single, Point Sweep ou Hold. Si vous sélectionnez le paramètre Enable Groups, entrez également le nombre de groupes.

  7. Cliquez sur OK.

A l'aide des touches de la face avant

  1. Dans le bloc COMMAND, appuyez sur Menu/Dialog. Dans le bloc CHANNEL SETUP, appuyez sur Trigger.

  2. Dans le bloc NAVIGATION, appuyez sur la flèche vers le bas pour sélectionner le paramètre de votre choix : Internal, External ou Manual.

  3. Sélectionnez l'onglet de droite pour passer à la zone Trigger Scope de la boîte de dialogue.

  4. Appuyez sur la flèche vers le bas pour sélectionner le paramètre de votre choix : Global ou Channel.

  5. Sélectionnez l'onglet de droite pour passer à la zone Trigger State de la boîte de dialogue.

  6. Sélectionnez la voie de votre choix.

  7. Appuyez sur la flèche vers le bas pour sélectionner le paramètre de votre choix : Continuous, Single, Hold, Point Sweep ou Enable Groups. Appuyez sur Click pour faire votre sélection. Si Enable Groups est sélectionné, entrez le nombre désiré de groupes. (Le paramètre Point Sweep ne peut être sélectionné que si les paramètres Manual et Channel sont définis.)

  8. Dans le bloc COMMAND, appuyez sur OK.


Trigger Text

  • La vitesse de réponse au réglage est différente de celle de l'analyseur. Par exemple, le passage en mode manuel se produit immédiatement dans l'analyseur. Le modèle attend que le balayage en cours soit terminé.

  • Le modèle ne comprend pas le déclenchement externe.

Modèle de déclenchement animé

Ce modèle SIMPLIFIE peut vous aider à vous familiariser avec la flexibilité des comportements de déclenchement de l'analyseur. Bien qu'il ne s'agisse PAS d'un modèle exact de l'analyseur, les différences sont subtiles.

Remarque : lorsqu'une voie reçoit un signal de déclenchement, toutes les mesures de la voie sont réalisées, en commençant par les mesures dans le sens direct (S11,S21), qui sont faites simultanément, suivies par les mesures dans le sens inverse (S12,S22). Il existe deux exceptions :
1. Lorsque le balayage en mode Alternate est sélectionné.
2. Lorsque le déclenchement ponctuel est sélectionné.

Les paramètres Trigger Source indiquent d'où proviennent les signaux de déclenchement :

Internal - Les signaux de déclenchement continus sont envoyés par le microprogramme de l'analyseur dès que la mesure précédente est terminée.

Manual - Un signal de déclenchement est envoyé lorsqu'il est appelé par : le bouton Trigger, la barre d'outils active, une commande de programmation.

External - Les signaux de déclenchement sont envoyés via un connecteur BNC situé sur la face arrière. Le déclenchement est sensible au niveau et peut être soit TTL actif haut, soit TTL actif bas.

Les paramètres Trigger Scope indiquent ce qui est déclenché :

Global - Toutes les voies 'déclenchable' reçoivent le signal de déclenchement [réglage par défaut]

Channel - Seule la voie 'déclenchable' suivant reçoit le signal de déclenchement. (Seulement autorisé avec Trigger Source = MANUAL).

Le paramètre Individual Channel Settings indique combien de signaux de déclenchement seront acceptés par la voie :

Continuous - La voie accepte un nombre infini de signaux de déclenchement.

Groups - La voie n'accepte que le nombre spécifié de signaux de déclenchement (Groupes), puis se met mode de maintien (Hold).

Single - La voie accepte UN signal de déclenchement, puis se met en mode de maintien (Hold).

Hold - La voie n'accepte AUCUN signal de déclenchement.

Point - Lorsqu'il est déclenché, la voie mesure le point de donnée suivant du balayage. Les signaux de déclenchement suivants vont vers la même voie jusqu'à ce que toutes ses mesures soient terminées. Puis, la voie déclenchable suivant est déclenché. (Seulement autorisé avec Trigger Source = MANUAL et Trigger Scope = CHANNEL).

Restart - L'analyseur cesse le balayage (le modèle ne s'arrête pas immédiatement). Les paramètres de voie individuelle (déclenchement) sont affectés de la manière suivante :

  • Les voies qui se trouvent dans le balayage Point sont extraits du balayage Point.

  • Les voies en mode Hold sont définies à un déclenchement unique (la voie accepte un signal de déclenchement unique).

Les autres paramètres ne sont pas affectés par la commande RESTART, y compris les compteurs de déclenchement qui sont décrémentés. L'analyseur reprend ensuite le balayage.

Speedometer - Contrôle la vitesse de l'animation :

Cliquez sur - pour ralentir.
Cliquez sur + pour accélérer.


TrigModel

Speedometer | Trigger Source Internal Manual
 | Trigger Scope Global Channel

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point


Analyze Data

Analyse de données

Voir aussi...

Cliquez sur un bouton pour connaître les méthodes d'analyse des données de mesure.
Localisation de données à l'aide de marqueurs

Manipulation de données à l'aide d'opérations mathématiques

Mise en évidence des réussites/échecs à l'aide de gabarits


COM Index

Main Index

COM Index

SCPI Index


Programming Guide

Click a button to access the following Programming topics:

Command Finder

8753 Converter

COM versus SCPI

Analyzer Connectivity

Help Tips

GPIB / SCPI Only

SCPI Command Tree

Example Programs

Create a Measurement

Catalog Measurements

Setup Sweep Parameters

Setup the Display

Getting and Putting Data using GPIB

Status Reporting

ECALibrate using GPIB

Perform a Calibration

Modify a Cal Kit

GPIB Concepts

GPIB Fundamentals

The Rules and Syntax of SCPI

Getting Data from the Analyzer

Reading the Analyzer's Status Register

Understanding Command Synchronization

COM Only

Object Model - Commands

Example Programs

Getting Trace Data from the Analyzer

Limit Line Testing

Communicating with Other Applications

COM Concepts

COM Fundamentals

Getting a Handle to an Object

Collections in the Analyzer

Working with Events

Configure for COM-DCOM Programming

COM Data Types

C++ and the COM Interface


SCPI Index

Main Index

COM Index

SCPI Index


Accessing Data Descriptions

Click a box to view process details:

Raw Measurement Data - Complex trace data which is ratioed if required by the parameter, such as S11 or A/B. Otherwise it is raw receiver data, such as A or B. This data is averaged if Averaging is ON. See Measurement Parameters

Standard Acquisition Data - Raw Complex Data resulting from measuring calibration standards or recalling a calibration. See Measurement Calibration.

Error Term Data - Data that is calculated from Acquisition data using formulas which are appropriate for the selected calibration method.

Error Correction - Error terms are applied to the raw measurement data if error correction is ON. Otherwise this data is identical to Raw Measurement Data.

Trace Math - If turned ON, memory data is combined with measurement data using the selected math function. Available functions are: Data+Mem, Data-Mem, Data*Mem, and Data/Mem. See Math Operations.

Memory Data - Complex trace data resulting from a Data-To-Memory operation. Each measurement can have one memory trace. The memory data parallels the measurement data through the remaining post processing blocks. For example, turning smoothing ON will smooth both the measurement and memory traces.

Gating - If turned ON, Filter Gating is applied to the measurement data. The gates are used to select regions of the trace where a subsequent transform will be applied. See Gating.

Phase Correction - If turned ON, applies electrical delay, phase offset, and port extensions. These are all separate features that are controlled individually. See Phase Measurement Accuracy.

Time Domain - If turned ON, transforms the data from the frequency domain to the time domain. See Time Domain

Formatter - Complex data is converted into scalar data formats for screen display and remote access. For smoothed data, request the data in the same format as the displayed data. See Data Format

Memory Result Data- Memory data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Measurement Result Data - Measurement data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Smoother - If turned ON, removes discontinuities in the measurement and memory trace. See Smoothing.

Display - Displays the processed measurement and / or memory data in the format of your choice. If remotely requested data is the same format as the displayed data, the requested data comes from this buffer.


CalTopic

Perform a Calibration

SENS:CORR:COLL:METH

Set Cal Information

SENS:CORR:COLL:CKIT:SEL

Select a Cal Kit

Get a Handle to the Active Cal Kit

Simultaneous 2-Port Calibration

Acquisition Direction

SENS:CORR:COLL:ACQ

Measure a Standard

SENS:CORR:COLL:SAVE

Calculate Errors

SENS:CORR:COLL:ISOL

Isolation ON|OFF

SENS:CORR:COEF

Display an Error Term

Perform an ECAL

SENS:CORR:COLL:CKIT

Do ECAL 1-Port

SENS:CORR:COLL:CKIT

Do ECAL 2-Port

Get ECAL Module Info

Recall / Save / Apply a Calibration or Error Term

SENS:CORR:CSET

Recall a Calibration

Apply a Calibration to a measurement

SENS:CORR:CSET:SAVE

Save a Calibration

To Save or Recall an Error Term, see DATA

SENS:CORR:COLL:APPLy

Apply an Error Term after Uploading

Correction Settings

SENS:CORR:STAT

Correction ON|OFF for a measurement

SENS:CORR:INT:STAT

Interpolation ON|OFF

SENS:CORR:EXT:STAT

Extensions ON|OFF

SENS:CORR:EXT:PORT

Port 1 Extensions Value

SENS:CORR:EXT:PORT

Port 2 Extensions Value

SENS:CORR:EXT:REC

Receiver A Extensions Value

SENS:CORR:EXT:REC

Receiver B Extensions Value

SENS:CORR:RVEL:COAX

Relative Velocity

Modify Cal Kits

SENS:CORR:COLL:CKIT:SEL

Set a Cal Kit Active

Get a Handle to the Active Cal Kit

Save All Cal Kits after Modifying

Load (Recall) All Cal Kits

SENS:CORR:COLL:CKIT:SEL

Restore Cal Kit Default

Restore ALL Cal Kits Default

Build a Hybrid Cal Kit

SENS:CORR:COLL:CKIT:NAME

Set the Name of a Cal Kit

Get the Number of Cal Kit

Set the Port Label of a Cal Kit

Modify Cal Standards

SENS:CORR:COLL:CKIT:STAN:SEL

Select a Cal Standard

SENS:CORR:COLL:CKIT:ORDER

Assign a Class to a Standard

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Standard Type

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Delay

SENS:CORR:COLL:CKIT:STAN:LOSS

Set Loss

SENS:CORR:COLL:CKIT:STAN:IMP

Set Impedance

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Max Frequency

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Min Frequency

SENS:CORR:COLL:CKIT:NAME

Set Label

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Medium (coax|waveguide)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.C0

Set Capacitance (C0 to C3)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.L0

Set Inductance (L0 to L3)


CFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


ChanTopic

Preset

Start Freq

Stop Freq

Center Freq

Span

CW Frequency

Power Settings

Power ON | OFF

Power Value

Port Selection

Couple Ports OFF | ON

Attenuator Mode Auto|Manual

Attenuation Value

Power Slope Mode Manual | Auto

Power Slope Value

Receiver Attenuation

Averaging

Average ON|OFF

Average Count

Average Restart

Manage Channels

Add

Make Active

Read Channel Number

Read Number of Channels


Data Access Map

 Raw Measurement Data Standard Acquisition Data Calibration Error Terms Memory Measurement Results Memory Results Error Correction Trace Math Filter Gating Phase Correction Time Domain Transform Display Formatting Data Smoothing Display


DataTopic

See a map of the measurement processing chain with data access locations

Retrieve Measurement Data FROM the Analyzer

Retrieve complex data from the specified location.

Retrieve typed NAComplex data from the specified location.

Retrieve data pairs from the specified location.

Retrieve scalar data from the specified location.

Retrieve variant data from the specified location

Specifies ASCII or REAL type for data transfers

Retrieve complex or formatted data from the measurement or memory result buffer

Put Measurement Data INTO the Analyzer

Put complex data into the specified location.

Put typed NAComplex data into the specified location.

Put scalar data into the measurement result location.

Put complex Variant data into the specified location.

Put complex or formatted data into the measurement or memory result buffer

Retrieve Calibration Data FROM the Analyzer

Retrieve complex Error Term data

Retrieve variant Error Term data

Retrieve Error Term data

Retrieve complex Standard aquisition data

Retrieve variant Standard aquisition data

Put Calibration Data INTO the Analyzer

Put complex Error Term data

Put variant Error Term data

Put Error Term data

Put complex Standard aquisition data

Put variant Standard aquisition data


DFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


FileTopic

Save States (Inst | Cal | Both)

Recall States (Inst | Cal | Both)

Manage Files

List Files

Copy Files

Move Files

Delete Files

Manage Folders

Change

Delete

Make

Print

Print

Print to File


Help Tips

Functionality Help

The link in the upper right corner of most commands goes to a help topic about the analyzer function related to the command.

Copy Help

Copy this Help system to your development workstation. The file is located on your PNA hard-drive (C:\ Winnt\ Help\ PNAHelp.chm). It is also on the CDROM that shipped with the PNA.

Copy 'n Paste

Copy and Paste code from this Help system directly into your programming environment. There is paste-able code in the following places:

  • SCPI and COM Example programs.

  • List of SCPI commands at the bottom of each SCPI topic


MarkerTopic

ON|OFF

Delete All Markers

Delete Marker

Interpolate All Markers

Interpolate Individ. Marker

Type (Normal | Fixed)

Marker=> Center, Span, and so forth

Marker=> Center (Freq)

Marker=> CW Freq

Marker=> Start (Freq)

Marker=> Stop (Freq)

Marker=> Elect. Delay

Marker=> Ref. Level

Format All Markers

Format Individ. Marker

Assign Marker to Domain

Domain Range Start

Domain Range Stop

Get a handle to Ref marker

Reference Marker On | Off

Delta Marker

Read/Set Data Point number

Read/Set X-axis value

Read/Set Y-axis value

Search

Execute Search

Select Search Function

Maximum

Minimum

Target (Value)

Excursion Value

Threshold Value

Tracking

Bandwidth (Target)

Search Filter Bandwidth

Read Filter BandWidth

Read Filter Center Freq

Read Filter Loss

Read Filter Q


Refl Meas

Reflection Measurements

Reflection measurements are an important part of network analysis. This topic discusses the following:

What are Reflection Measurements?

Why Make Reflection Measurements?

Expressing Reflected Waves

Return Loss

VSWR

Reflection Coefficient

Impedance

Summary of Expressions

Accuracy Considerations

What are Reflection Measurements?

To understand reflection measurements, it is helpful to think of traveling waves along a transmission line in terms of a lightwave analogy. We can imagine incident light striking some optical component like a clear lens. Some of the light is reflected off the surface of the lens, but most of the light continues on through the lens. If the lens had mirrored surfaces, then most of the light would be reflected and little or none would be transmitted.

With RF energy, reflections occur when the impedance of two mated devices are not the same. A reflection measurement is the ratio of the reflected signal to the incident signal. Network analyzers measure the incident wave with the R (for reference) channel and the reflected wave with the A channel. Therefore, reflection is often shown as the ratio of A over R (A/R). We can completely quantify the reflection characteristics of our device under test (DUT) with the amplitude and phase information available at both the A and R channel. In S-parameter terminology, S11 is a reflection measurement of port1 of the device (the input port); S22 is a reflection measurement of the port 2 (the output port)

Why Make Reflection Measurements?

One reason we make reflection measurements to assure efficient transfer of RF power. We do this because:

  1. RF energy is not cheap. When energy is reflected, that means less energy is transmitted to where it is intended to go.

  2. If the reflected energy is large, it can damage components, like amplifiers.

For example, in the following graphic, the radio station on the left is not operating at peak efficiency. The amplifier impedance is not the same as the transmission line, and the transmission line impedance is not the same as the antenna. Both of these conditions cause high reflected power. This condition results in less transmitted power, and the high reflected power could damage the amplifier.

The radio station on the right installed properly "matched" transmission line and antenna. Very little of the transmitted signal is reflected, resulting in increased broadcast power, more listeners, more advertising revenue, and more profit. The amplifier, transmission, and antenna all need to be measured to ensure that reflected power is minimized.

Expressing Reflected Waves

After making a reflection measurement, the reflection data can be expressed in a number of ways, depending on what you are trying to learn. The various expressions are all calculated by the analyzer from the same reflection measurement data. Each method of expressing reflection data can be graphically displayed in one or more formats. For more information, see display formats.

Return Loss

The easiest way to convey reflection data is return loss. Return loss is expressed in dB, and is a scalar (amplitude only) quantity. Return loss can be thought of as the absolute value or dB that the reflected signal is below the incident signal. Return loss varies between infinity for a perfect impedance match and 0 dB for an open or short circuit, or a lossless reactance. For example, using the log magnitude format on the analyzer, the measured reflection value on the screen may be -18dB. The minus sign is ignored when expressing return loss, so the component is said to have 18dB of return loss.

VSWR

Two waves traveling in opposite directions on the same transmission line cause a "standing wave". This condition can be measured in terms of the voltage standing wave ratio (VSWR or SWR for short). VSWR is defined as the maximum reflected voltage over the minimum reflected voltage at a given frequency. VSWR is a scalar (amplitude only) quantity. VSWR varies between one for a perfect match, and infinity for an open or short circuit or lossless reactance.

Reflection Coefficient

Another way of expressing reflection measurements is reflection coefficient gamma (G). Gamma includes both magnitude and phase.

The magnitude portion of gamma is called rho (r). Reflection coefficient is the ratio of the reflected signal voltage to the incident signal voltage. The range of possible values for r is between zero and one. A transmission line terminated in its characteristic impedance will have all energy transferred to the load; zero energy will be reflected and r = 0. When a transmission line terminated in a short or open circuit, all energy is reflected and r = 1. The value of rho is unitless.

Now for the phase information. At high frequencies, where the wavelength of the signal is smaller than the length of conductors, reflections are best thought of as waves moving in the opposite direction of the incident waves. The incident and reflected waves combine to produce a single "standing" wave with voltage that varies with position along the transmission line.

  • When a transmission line is terminated in its characteristic impedance (Zo) there is no reflected signal. All of the incident signal is transferred to the load. There is energy flowing in one direction along the transmission line.

  • When a transmission line is terminated in a short circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). The voltage across any short circuit is zero volts. Therefore, the voltage of the reflected wave will be 180 degrees out of phase with the incident wave, canceling the voltage at the load.

  • When a transmission line is terminated in an open circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). However, no current can flow in an open circuit. Therefore, the voltage of the reflected wave will be in phase with the voltage of the incident wave.

  • When a transmission line is terminated in a 25 ohm resistor, some but not all of the incident energy will be absorbed, and some will be reflected back towards the source. The reflected wave will have an amplitude 1/3 that of the incident wave and the voltage of the two waves will be out of phase by 180 degrees at the load. The phase relationship will change as a function of distance along the transmission line from the load. The valleys of the standing wave pattern will no longer go to zero, and the peaks will be less than that of the open / short circuit.

For more information, see Phase Measurements.

Impedance

Impedance is another way of expressing reflection data. For more information on Impedance, see Display formats / Smith Chart.

Summary of the Expressions of Reflection Measurements:

Accuracy Considerations

Reflection measurements can be made with the same setup as transmission measurements. If external attenuation is needed for gain measurements, calibrate with the attenuator in the system to remove its effects. Since reflection measurements involve loss instead of gain, power levels are lower at the receiver inputs. Therefore, it may be necessary to increase power levels for reflection measurements.

ANOTHER TAKE

The uncertainty of relection measurement is affected by directivity, source match, load match, and the reflection tracking of the test system. With a full 2-port calibration, the effects of these factors are minimized. A 1-port calibration provides the same accuracy if the output of the amplifier is well terminated. An example using the amplifier described earlier best illustrates this improvement. Total measurement uncertainty of input reutrn loss (worst case):

Response only calibration: ± 3.0 dB

Full 2-port calibration: ± 0.6 dB

Since the magnitude of the mismatch uncertainty depends on the input and output match of an amplifier, a measurement of a better matched amplifier will contain less uncertainty.

AND ANOTHER TAKE


ScaleTopic

AutoScale

AutoScale All

Per Division

Reference Level

Reference Position

Electrical Delay

Phase Offset


SweepTopic

Sweep Time Value

IF Bandwidth

Previous IF Bandwidth

Next IFBandwidth

Number of Points

Sweep Type (Lin | Pwr | CW | Seg)

Sweep Generation (Stepped | Analog)

Dwell Time Value

Alternate Sweeps

External ALC

Power Sweep

Start Power

Stop Power

Center

Span

Segment Sweep

ON|OFF

Add a segment

Delete a segment

Delete all segments

Count the segments

Read the segment number

Segment Center Frequency

Segment Frequency Span

Segment Start Frequency

Segment Stop Frequency

IF Bandwidth

IF Bandwidth Option

Source Power

Source Power Option

Trigger

Source (where trigger comes from)

Trigger Source (Int | Ext | Manual)

Internal | Manual

Trigger! (for Manual Source)

Ext. Trigger Slope (Positive | Negative)

Scope (what is triggered)

Trigger Scope (Global | Channel)

Channel Settings (how the channel responds to triggers)

Cont | Groups | Hold

Continuous

Number of Groups

Hold

Single

Trigger Mode (Point | Measurement)

Restart

Abort


SystemTopic

Quit application

Preset

Reset

Status Commands

Status Registers

*OPC;*WAI

Events

AllowAllEvents Method

AllowEventCategory Method

AllowEventMessage Method

AllowEventSeverity Method

DisallowAllEvents Method

MessageText Method

OnCalEvent

OnChannelEvent

OnDisplayEvent

OnHardwareEvent

OnMeasurementEvent

OnSCPIEvent

OnSystemEvent

OnUserEvent

SetFailOnOverRange

Macro

Execute Macro

Get Macro

Delete Macro

Put Macro


TraceTopic

Create S-Parameter Meas.

Create Measurement

Add Measurement

List Measurements

Delete a Measurement

Get a handle to a Trace

Select a Measurement

Read Channel Number

Read Number of Measurements

Read Measurement Parameter

Set / Read Measurement Name

Read Measurement Number

Change Parameter

Measurement Format

Math

Data Trace ON|OFF

Memory Trace ON|OFF

View Trace Type (Data|Memory|None)

Data =>Memory

Trace Math (Add|Sub|Mult|Div)

Smoothing

Smoothing ON|OFF

Smoothing Aperture

Smoothing Points

Statistics

Statistics ON|OFF

Statistics Range

Domain Range Start

Domain Range Stop

Set Type (Pk-Pk|StdDev|Mean)

Get All Statistics Data

Get Standard Deviation

Get Mean

Get Peak to Peak

Limit Lines

Display Lines ON|OFF

Fail Sound ON|OFF

Testing ON|OFF

Limit Test Failed

Count Limit Lines

Read Test Results

Make Limit Lines

Limit Line Type (Max|Min)

Begin Stimulus

End Stimulus

Begin Response

End Response

Transform

Transform ON|OFF

Mode (LowPass, BandPass)

Start Time

Stop Time

Center

Span

Step Rise Time

Set Low Pass Frequency

Gating

ON|OFF

Type (BandPass, Notch)

Shape

Start

Stop

Center

Span

Window

Kaiser Beta

Impulse Width


ViewTopic

Status Bar On|Off

Toolbars On|Off

Tables On|Off

Title Bars On|Off

X-axis values On|Off

Measurement Trace On|Off

Memory Trace On|Off

Title Annotation On|Off

Make a Title Annotation

Display Update ON|OFF

Window Update ON|OFF

Analyzer Visible

Add a Window

Activate a Window

Arrange Measurement Windows

Analyzer Window (Max|Min|Normal)


53 Finder

Indicates the most common of the network analyzer commands that have been mapped to a corresponding command in PNA. Since the commands listed on this page are base commands, commands that are derived from these base commands may not have a corresponding command in PNA.

Indicates a command that has not been mapped to a corresponding command in PNA, but may be in future revisions. However, this does not always indicate that the required functionality does not exist in PNA. See the 8753 Programming Guide for a description of the command functionality.

Description of Symbol Conventions

Legend

AB

ADAP1

ADDR

ADPT

ALC

ALTAB

ANAB

ANAI

AR

ASEG

ASSS

ATT

AUTO

AUXC

AVER

BACI

BANDPASS

BEEP

BLAD

BR

CAL1

CALF

CALI

CALK

CALN

CALSPORT

CALZ

CBRI

CENT

CHAN

CHOPAB

CLAD

CLASS

CLEA

CLEAL

CLEABIT

CLEASEQ

CLEL

CLES

CLS

COAD

COAX

COLO

COLOR

CONS

CONT

CONV

COPY

CORI

CORR

COU

CSWI

CWFREQ

CWTIME

D1DIVI2

D2XUPCH

D4XUPCH

DATI

DCONV

DEBU

DECRLOOC

DEFC

DEFLPRINT

DEFLTCPIO

DEFS

DEL

DELA

DEMO

DFLT

DIRS

DISC

DISM

DISP

DIVI

DONE

DONM

DOSEQ

DOWN

DUAC

DUPLSEQ

EDIT

ELED

EMIB

ENTO

ERCDONE

ESB?

ESE

ESNB

ESR?

EXTD

EXTM

EXTRCHAN

EXTT

FIXE

FORM

FORMAT

FREQ

FREQOFFS

FRER

FLUP

FWD

GATE

GATS

GOSUB

HARM

HOLD

IDN?

IF

IFBW

IMAG

INCRLOOC

INI

INPU

INSM

INT

INTE

ISO

J

KEY

KITD

KOR?

LAB

LABE

LEF

LIM

LIMI

LIMT

LINFREQ

LINM

LINT

LIS

LISTTYPE

LISV

LO

LOA

LOAD

LOADSEQ

LOGFREQ

LOGM

LOOC

LOWP

LRN

MANTRIG

MARK

MAXF

MEAS

MEASTAT

MENU

MINF

MINMAX

MINU

MODI1

MODS

NEWSEQ

NEXP

NOOP

NUMG

NUMR

OF

OFS

OMII

OPC

OPEP

OUTP

PARA

PARAL

PAUS

PCB

PCOL

PENN

PHAO

PHAS

PLOS

PLOT

PLT

PMTRTTIT

POIN

POL

PORE

PORT

PORTP

POWE

POWL

POWM

POWR

POWS

POWT

PRAN

PREP

PRES

PRI

PRIN

PRINTALL

PRN

PTOS

PURG

PWMC

PWRLOSS

PWRMCAL

PWRR

Q

RAI

RAWOFFS

READ

REAL

RECA

RECO

REF

REFT

REIC

RERCDONE

RESC

RESD

RESPDONE

REST

RETP

REV

RF

RFLP

RIG

RSCO

RST

S

SADD

SAMC

SAV

SAVE

SAVEUSEK

SAVU

SCAL

SCAP

SDEL

SDON

SEA

SEDI

SEG

SEL

SELL

SEQ

SEQWAIT

SET

SHOM

SING

SLI

SLOP

SM8

SMI

SMOO

SOFR

SOFT

SOUP

SPAN

SPEC

SPEG

SPLD

SPLID

SRE

SSEG

STAN

STAR

STB?

STDD

STDT

STEPSWP

STOP

STOR

STORSEQ

STPSIZE

SVCO

SWE

SWPSTART

SWR

TAK

TAKE4

TALKLIST

TESS?

TIMDTRAN

TIMESTAM

TINT

TIT

TITT

TRA

TRACK

TRAP

TRL

TSSWI

TST?

TSTIO

TSTP

TTL

UCONV

UP

USEPASC

USESENS

VELOFACT

VIEM

VOFF

WAIT

WAVD

WAVE

WID

WIND

WRSK


53Banner

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O

P

R

S

T

U

V

W

8753 Cross-Reference


ANotes

AB

8753 Command

Description

Range

Query Response

AB

Measures and displays A/B on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ALTAB

8753 Command

Description

Range

Query Response

ALTAB

Places the analyzer in the alternate inputs measurement mode, where A and B measurements are made on alternate sweeps. See also "CHOPAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Sets sweeps to either alternate or chopped.

PNA COM Equivalent - Notes

Sets sweeps to either alternate or chopped.

AR

8753 Command

Description

Range

Query Response

AR

Measures and displays A/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ASEG

8753 Command

Description

Range

Query Response

ASEG

Uses all segments for list frequency sweep. See also "SSEG".

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turn on each segment to be used with list frequency sweep.

PNA COM Equivalent - Notes

LimitSegment object.

ATT

8753 Command

Description

Range

Query Response

ATTP1><num>[DB]

Selects the amount of attenuation at PORT 1.

0–70 dB

<num><LF

ATTP2><num>[DB]

Selects the amount of attenuation at PORT 2.

0–70 dB

<num><LF

Note: These commands only apply to 8753ES Option 011 analyzers.

PNA SCPI Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

PNA COM Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

AUTO

8753 Command

Description

Range

Query Response

AUTO

Auto scale the active channel.

N/A

N/A

PNA SCPI Equivalent - Notes

Auto scale on the specified trace in the specified window.

PNA COM Equivalent - Notes

Auto scales the trace or all of the traces in the selected window.

AVER

8753 Command

Description

Range

Query Response

AVERREST

Restarts the averaging on the active channel.

N/A

N/A

AVERFACT<num>

Sets the averaging factor on the active channel.

integers 0–999

<num><LF

AVERO<ON|OFF>

Turns averaging on and off on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.

PNA COM Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.


BNotes

BLAD

8753 Command

Description

Range

Query Response

BLAD<ON|OFF>

Blanks the display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Blanks the display information in all windows.

Blanks the display information in a specified window.

PNA COM Equivalent - Notes

Makes the Network Analyzer application visible or not visible.

BR

8753 Command

Description

Range

Query Response

BR

Measures and displays B/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.


CNotes

CALI

CALIERC

CALIRERC

CALIFUL2

CALIRAI

CALIRESP

CALIS111

CALIS221

CALITRL2

8753 Command

Description

Range

Query Response

CALIFUL2

Begins the sequence for a short, load, open, thru (SLOT) 2-port calibration.

N/A

<0|1><LF>

CALIRAI

Begins the sequence for a response and isolation calibration.

N/A

<0|1><LF>

CALIRESP

Begins the sequence for a response calibration.

N/A

<0|1><LF>

CALIS111

Begins the sequence for an S11 1-port calibration (ES models), or a reflection 1-port calibration (ET models).

N/A

<0|1><LF>

CALIS221

Begins the sequence for an S22 1-port calibration.

N/A

<0|1><LF>

CALITRL2

Begins the sequence for a thru, reflect, line or line, reflect, match (TRL*/LRM*) 2-port calibration.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

CALIERC

Begins the sequence for a forward enhanced response calibration.

N/A

<0|1><LF>

CALIRERC

Begins the sequence for a reverse enhanced response calibration.

N/A

<0|1><LF>

Notes

These commands currently are not available.

CALK

8753 Command

Description

Range

Query Response

CALK24MM

Selects a 2.4-mm calibration kit (85056A/D) as the default cal kit.

N/A

<0|1>><LF

CALK292MM

Selects a 2.92-mm calibration kit as the default cal kit.

N/A

<0|1>><LF

CALK292S

Selects a 2.92* calibration kit (85056K) as the default cal kit.

N/A

<0|1>><LF

CALK35MD

Selects a 3.5-mm calibration kit (85052B/D for 8720E series analyzers, and 85033D for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALK35MC

Selects a 3.5-mm calibration kit (85033C) as the default cal kit. CALK35MM selects the 85033C cal kit for the 8752C and 8753D analyzers.

N/A

<0|1>><LF

CALK716

Selects a 7-16 calibration kit (85038) as the default cal kit.

N/A

<0|1>><LF

CALK7MM

Selects a 7-mm calibration kit (85050 series for 8720E series analyzers, and 85031B for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN50

Selects a type-N 50 ohm calibration kit (85054 for 8720E series analyzers, and 85032B/E for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN75

Selects a type-N 75 ohm calibration kit (85036B/E) as the default cal kit.

N/A

<0|1>><LF

CALKTRLK

Selects a TRL 3.5-mm calibration kit (85052C) as the default cal kit.

N/A

<0|1>><LF

CALKUSED

Selects a user-defined calibration kit.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Select the appropriate calibration kit. If the specific calibration kit is not listed, one can be created and stored in the User Defined section.

3 = CALKN50

4 = CALK35MD

5 = CALK716

6 = CALKTRLK

PNA COM Equivalent - Notes

Specifies the type of calibration kit to use in the calibration process.

CALN

8753 Command

Description

Range

Query Response

CALN

Turns calibration type to "off." See also "CORR."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the calibration method. Set to "NONE" to turn calibration off.

PNA COM Equivalent - Notes

Specifies and returns the type of calibration to be applied to the measurement. Set to "NONE" to turn calibration off.

CENT

8753 Command

Description

Range

Query Response

CENT<num>[HZ|DB]

Sets the center stimulus value. If a list frequency segment is being edited, sets the center of the list segment.

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To set the center frequency value.

To set the center frequency value for a segment.

PNA COM Equivalent - Notes

Read-Write the center frequency of all measurements in a channel or for a specified sweep segment.

CHAN

8753 Command

Description

Range

Query Response

CHAN1

Makes channel 1 the active channel. OPC-compatible.

N/A

N/A

CHAN2

Makes channel 2 the active channel. OPC-compatible.

N/A

N/A

CHAN3

Makes channel 3 the active channel. OPC-compatible.

N/A

N/A

CHAN4

Makes channel 4 the active channel. OPC-compatible.

N/A

N/A

Notes

Unlike the 8753 network analyzer, the PNA Series Network Analyzers do not need a separate channel to display each parameter. While the PNA Series has four independent measurement channels, only one channel is needed to display all four measurement parameters. In addition, up to four windows are available to view four active and four memory traces per window.

CHOPAB

8753 Command

Description

Range

Query Response

CHOPAB

Places the analyzer in the chop measurement mode. See also "ALTAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

PNA COM Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

CLASS

8753 Command

Description

Range

Query Response

CLASS11A

S11A: S11 (forward reflection) 1-port, open

N/A

N/A

CLASS11B

S11B: S11 (forward reflection) 1-port, short

N/A

N/A

CLASS11C

S11C: S11 (forward reflection) 1-port, load

N/A

N/A

CLASS22A

S22A: S22 (reverse reflection) 1-port, open

N/A

N/A

CLASS22B

S22B: S22 (reverse reflection) 1-port, short

N/A

N/A

CLASS22C

S22C: S22 (reverse reflection) 1-port, load

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

CLEAL

8753 Command

Description

Range

Query Response

CLEAL

Clears the limit line list. Should be preceded by EDITLIML.

N/A

N/A

PNA SCPI Equivalent - Notes

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF or make a new limit line.

PNA COM Equivalent - Notes

Delete the limit test collection.

CLEL

8753 Command

Description

Range

Query Response

CLEL

Clears the currently selected list. This could be a frequency list, power loss list, or limit test list. Must be preceded by an "EDIT" command.

N/A

N/A

PNA SCPI Equivalent - Notes

Clear a single sweep segment.

Clear all sweep segments.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

CLES

8753 Command

Description

Range

Query Response

CLES

Clears the status byte register, the event-status registers, and the enable registers. Same as CLS.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers.

PNA COM Equivalent - Notes

No equivalent command at present.

CLS

8753 Command

Description

Range

Query Response

CLS

Clears the status byte register, the event-status registers, and the enable registers. Same as CLES.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers. Replace "CLS" with "*CLS".

PNA COM Equivalent - Notes

No equivalent command at present.

CONT

8753 Command

Description

Range

Query Response

CONT

Places the analyzer in continuous sweep trigger mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

CORI

8753 Command

Description

Range

Query Response

CORI<ON|OFF>

Turns interpolative error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write correction interpolation ON or OFF.

PNA COM Equivalent - Notes

No equivalent command at present.

CORR

8753 Command

Description

Range

Query Response

CORR<ON|OFF>

Turns error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether or not correction data is applied to the measurement.

PNA COM Equivalent - Notes

Sets (or returns) error correction ON or OFF

CWFREQ

8753 Command

Description

Range

Query Response

CWFREQ<num>[HZ|DB]

Sets the CW frequency for power sweep and CW frequency modes. While the list frequency table segment is being edited, it sets the center frequency of the current segment. See also "MARKCENT."

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in the analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Continuous Wave (or Fixed) frequency.

PNA COM Equivalent - Notes

CW Frequency property.

CWTIME

8753 Command

Description

Range

Query Response

CWTIME

Selects CW time as the sweep type.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.


DENotes

DATI

8753 Command

Description

Range

Query Response

DATI

Stores the data trace in channel memory. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only the currently selected measurement trace into memory.

PNA COM Equivalent - Notes

Stores the active measurement into memory.

DEL

8753 Command

Description

Range

Query Response

DELO

Turns delta marker mode off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether marker is relative to the reference or not.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

DELR<num>

Makes the indicated marker the delta reference.

Integers 15

<0|1>><LF

DELRFIXM

Makes the fixed marker the delta reference.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If the reference marker is not turned ON, use this command to set the reference marker to ON.

Step 2

Set the reference marker to the correct position.

Step 3

Turn marker delta mode ON for the marker that will report the delta value measured from the reference marker.

PNA COM Equivalent - Notes

No equivalent command at present.

DELA

8753 Command

Description

Range

Query Response

DELA

Displays the data formatted as group delay.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

DISP

8753 Command

Description

Range

Query Response

DISPDATA

Data only.

N/A

<0|1>><LF

DISPDATM

Data and memory.

N/A

<0|1>><LF

DISPDDM

Data divided by memory (linear division, log subtraction). See also "DIVI."

N/A

<0|1>><LF

DISPDMM

Data minus memory (linear subtraction). See also "MINU."

N/A

<0|1>><LF

DISPMEMO

Memory only.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DIVI

8753 Command

Description

Range

Query Response

DIVI

Data divided by memory (linear division, log subtraction). See also "DISPDDM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DONE

8753 Command

Description

Range

Query Response

DONE

Done with a class of standards, during a calibration. Only needed when multiple standards are measured to complete the class.

N/A

N/A

Notes

Since this action is performed automatically in PNA, this command is no longer necessary.

EDIT

8753 Command

Description

Range

Query Response

EDITDONE

Done editing list frequency, limit table, cal sensor table, or power loss list.

N/A

N/A

EDITLIML

Begins editing limit table.

N/A

N/A

EDITLIST

Begins editing list frequency table.

N/A

N/A

Notes

Since these actions are performed automatically in PNA when working with a limit table, these commands are no longer necessary.

ELED

8753 Command

Description

Range

Query Response

ELED<num>[S]

Sets the electrical delay offset.

±10 seconds

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the electrical delay for the selected measurement.

PNA COM Equivalent - Notes

Sets the Electrical Delay

ESE

8753 Command

Description

Range

Query Response

ESE<num>

Enables the selected event-status register bits to be summarized by bit 5 in the status byte. An event-status register bit is enabled when the corresponding bit in the operand <num> is set.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Sets bits in the standard event status enable register. Replace "ESE" with "*ESE".

PNA COM Equivalent - Notes

No equivalent command at present.

ESR?

8753 Command

Description

Range

Query Response

ESR?

Query only. Outputs event-status register.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Returns the results of the standard event enable register. The register is cleared after reading it. Replace "ESR?" with "*ESR?".

PNA COM Equivalent - Notes

No equivalent command at present.

EXTM

8753 Command

Description

Range

Query Response

EXTMDATA

Adds error corrected data (real and imaginary pairs) along with the other files.

N/A

<0|1>><LF

EXTMDATO

Selected data arrays only (real and imaginary pairs), without instrument states or calibrations. Always saves the data array, even if it hasnt been selected.

N/A

<0|1>><LF

EXTMFORM

Formatted trace data. Uses currently selected format for data.

N/A

<0|1>><LF

EXTMRAW

Raw data arrays (real and imaginary pairs).

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data.

PNA COM Equivalent - Notes

Retrieves data.

8753 Command

Description

Range

Query Response

EXTMGRAP

User graphics.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Saves the screen data to bitmap (.bmp) file of the screen.

EXTT

8753 Command

Description

Range

Query Response

EXTT

Activates or deactivates the external trigger mode. OPC-compatible.

N/A

<0|1>><LF

EXTTPOIN

Sets the external trigger to auto-trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the source of the sweep trigger signal.

Read-Write whether the specified channel will measure one point when triggered or all of the measurements in the channel.

PNA COM Equivalent - Notes

Sets or returns the trigger source.

Determines the measurement that occurs when a trigger signal is sent to the channel.

8753 Command

Description

Range

Query Response

EXTTHIGH

Sets the external trigger line high.

N/A

N/A

EXTTLOW

Sets the external trigger line low.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

No equivalent command at present.


FGHNotes

FORM

8753 Command

Description

Range

Query Response

FORM1

The analyzer's internal binary format, 6 bytes-per-data point. The array is preceded by a four-byte header. The first two bytes represent the string "#A", the standard block header. The second two bytes are an integer representing the number of bytes in the block to follow. FORM1 is best applied when rapid data transfers, not to be modified by the computer nor interpreted by the user, are required.

N/A

N/A

FORM2

IEEE 32-bit floating-point format, 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 8-bit biased exponent, and a 23-bit mantissa. FORM2 is the format of choice if your computer is not a PC, but supports single-precision floating-point numbers.

N/A

N/A

FORM3

IEEE 64-bit floating-point format, 8 bytes-per-number, 16 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 11-bit biased exponent, and a 52-bit mantissa. This format may be used with double-precision floating-point numbers. No additional precision is available in the analyzer data, but FORM3 may be a convenient form for transferring data to your computer.

N/A

N/A

FORM4

ASCII floating-point format. The data is transmitted as ASCII numbers. There is no header. The analyzer always uses FORM4 to transfer data that is not related to array transfers (i.e. marker responses and instrument settings). Data is comma delimited.

N/A

N/A

FORM5

PC-DOS 32-bit floating-point format with 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. The byte order is reversed with respect to FORM2 to comply with PC-DOS formats. If you are using a PC-based controller, FORM5 is the most effective format to use.

N/A

N/A

PNA SCPI Equivalent - Notes

FORM1, the 8753 analyzer's internal binary format, is not compatible with PNA.

For FORM2, FORM3, and FORM4, use this SCPI command.

Step 1

For FORM5, format the data to 32-bit with the SCPI command in Step 1. Then, swap the bits with the SCPI command in Step 2.

Step 2

PNA COM Equivalent - Notes

No equivalent command at present.

FRER

8753 Command

Description

Range

Query Response

FRER

Places the analyzer in GPIB free run mode. (Same as continuous sweep trigger mode.) See "CONT."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

FWD

8753 Command

Description

Range

Query Response

FWDI

Selects the forward isolation calibration class during a 2-port calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit. See "STAN5".

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

FWDM

Selects the forward match calibration class during a 2-port calibration sequence.

N/A

N/A

FWDT

Selects the forward transmission calibration class during a 2-port calibration sequence.

N/A

N/A

Notes

Both the forward match and the forward transmission are measured automatically during a 2-port calibration on the PNA Series Network Analyzers.

HOLD

8753 Command

Description

Range

Query Response

HOLD

Puts the sweep trigger into hold mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode. Set the sweep trigger mode to "OFF".

PNA COM Equivalent - Notes

Put the sweep trigger into hold mode.


INotes

IDN?

8753 Command

Description

Range

Query Response

IDN?

Query only. Outputs the identification string: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument.

N/A

See command description.

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer. Replace "IDN?" with "*IDN?".

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

IFBW

8753 Command

Description

Range

Query Response

IFBW<num>[HZ]

Sets the IF bandwidth.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the bandwidth of the digital IF filter to be used in the measurement.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.

IMAG

8753 Command

Description

Range

Query Response

IMAG

Selects the imaginary display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

INPU

INPUCALC

INPUCALK

INPUDATA

INPUFORM

INPULEAS

INPUPMCAL1

INPUPMCAL2

INPURAW1

INPURAW2

INPURAW3

INPURAW4

8753 Command

Description

Range

Query Response

INPUDATA

Inputs an error corrected data array, using the current setting of the FORM command.

N/A

N/A

INPUFORM

Inputs a formatted data array, using the current setting of the FORM command.

N/A

N/A

INPURAW1

Inputs raw data array 1 (S11 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW2

Inputs raw data array 2 (S21 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW3

Inputs raw data array 3 (S12 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW4

Inputs raw data array 4 (S22 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Input the data array.

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

PNA COM Equivalent - Notes

Step 1a

Input raw data.

Step 1b

Input formatted data

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

8753 Command

Description

Range

Query Response

INPUCALC<num><array>

Inputs an error coefficient array <num>.

Two-digit integers 01–12

N/A

INPUCALK<array>

Inputs a cal kit array in FORM1 only. Can be read out with the OUTCALK command. After the transfer, the data should be saved into the user cal kit area with the SAVEUSEK command.

N/A

N/A

INPULEAS<learnstring>

Inputs a learn string in FORM1 only. Can be read out with the OUTPLEAS command, or with INPULEAS?.

N/A

<data><LF >

INPUPMCAL1<array>

Inputs power meter calibration arrays for channel 1 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

INPUPMCAL2<array>

Inputs power meter calibration arrays for channel 2 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

Notes

These commands currently are not available.


LNotes

LIM

8753 Command

Description

Range

Query Response

LIMS

Sets the limit stimulus break point.

Stimulus range.

Currently this command can be queried by sending the command by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the start (beginning) of the X-axis stimulus value.

Read-Write the stop (end) of the X-axis stimulus value.

PNA COM Equivalent - Notes

Specifies the beginning X-axis value of the Limit Line.

Specifies the end X-axis value of the Limit Line.

8753 Command

Description

Range

Query Response

LIMD

Sets the limit delta value while editing a limit line segment.

Amplitude range.

Currently this command can be queried by sending the command by the OUTPACTI command.

LIML

Sets the lower limit value.

Amplitude range.

Same as above.

LIMM

Sets the middle limit value.

Amplitude range.

Same as above.

LIMU

Sets the upper limit value.

Amplitude range.

Same as above.

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LIMI

LIMIAMPO

LIMILINE

LIMIMAOF

LIMISTIO

LIMITEST

8753 Command

Description

Range

Query Response

LIMILINE<ON|OFF>

Turns the display of the limit lines on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display of limit lines ON or OFF.

PNA COM Equivalent - Notes

Turns the display of limit lines ON or OFF.

8753 Command

Description

Range

Query Response

LIMITEST<ON|OFF>

Turns limit testing on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write limit line testing ON or OFF.

PNA COM Equivalent - Notes

Turns an object ON and OFF.

8753 Command

Description

Range

Query Response

LIMIAMPO<num>[HZ|DB]

Enters the limit line amplitude offset.

Amplitude range.

<num>><LF

LIMIMAOF

Marker to limit offset. Centers the limit lines about the current marker position using the limit amplitude offset function.

N/A

N/A

LIMISTIO<num>[HZ|DB]

Enters the stimulus offset of the limit lines.

Stimulus range.

<num>><LF

Notes

These commands currently are not available.

LIMT

8753 Command

Description

Range

Query Response

LIMTFL

Makes the segment a flat line.

N/A

<0|1>><LF

LIMTSL

Makes the segment a sloping line.

N/A

<0|1>><LF

LIMTSP

Makes the segment a single point.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LINFREQ

8753 Command

Description

Range

Query Response

LINFREQ

Selects a linear frequency sweep.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

LINM

8753 Command

Description

Range

Query Response

LINM

Selects the linear magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

LIS

LISFREQ

LISIFBWM

LISPWRM

8753 Command

Description

Range

Query Response

LISFREQ

Selects the list frequency sweep mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the sweep type.

PNA COM Equivalent - Notes

Selects the sweep type.

8753 Command

Description

Range

Query Response

LISIFBWM<ON|OFF>

Enables/disables the IFBW setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether the IF Bandwidth resolution can be set independently for each segment.

Read-Write the IFBandwidth for the specified segment.

PNA COM Equivalent - Notes

Enables the IFBandwidth to be set on individual sweep segments.

Sets or returns the IF Bandwidth of the segment.

8753 Command

Description

Range

Query Response

LISPWRM<ON|OFF>

Enables/disables the power setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether Power Level can be set independently for each segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Enables the source power to be set on individual sweep segments.

Sets or returns the RF power level of the segment.

LISTTYPE

8753 Command

Description

Range

Query Response

LISTTYPELSTP

Selects the stepped list mode for use with a list-frequency table.

N/A

<0|1><LF>

LISTTYPELSWP

Selects the swept list mode for use with a list-frequency table.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Read-Write sweep as Stepped or Analog.

PNA COM Equivalent - Notes

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

LOAD

8753 Command

Description

Range

Query Response

LOAD<num>

Loads the file from disk using the file name provided by the preceding TITF<num>; command. The actual file loaded depends on the file title in the file position specified by the TITF<num> command. Requires pass control mode when using the GPIB port.

integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to load the specified file.

PNA COM Equivalent - Notes

Recalls a measurement state, calibration state, or both.

LOGM

8753 Command

Description

Range

Query Response

LOGM

Selects the log magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


MNotes

MANTRIG

8753 Command

Description

Range

Query Response

MANTRIG

Sets the trigger mode to manual trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

PNA COM Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

MARK

MARK<1|2|3|4|5> | MARKMAXI
MARKBUCK | MARKMIDD
MARKCENT | MARKMINI
MARKCONT | MARKOFF
MARKCOUP | MARKREF
MARKCW | MARKSPAN
MARKDELA | MARKSTAR
MARKDISC | MARKSTIM
MARKFAUV | MARKSTOP
MARKFSTI | MARKUNCO
MARKFVAL | MARKZERO

8753 Command

Description

Range

Query Response

MARK<1|2|3|4|5><num>

Makes the selected marker active and sets its stimulus value.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Set the specified marker ON. Note: CALCulate commands act on the selected measurement. You must have a measurement defined and selected before a marker can be turned on. To define a measurement use CALCulate<cnum>:PARameter:DEFine <Mname>,<param>. Select the measurement for each channel using CALCulate<cnum>:PARameter:SELect <Mname>.

Step 2

Set the marker's X-axis value (frequency, power, or time).

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKBUCK<num>

Places the active marker on a specific sweep point (bucket). <num> is the bucket number.

0 to (number-of-points - 1). For example, on a 201 point sweep, <num> can range from 0 to 200.

<num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Sets or returns the bucket number (data point) for the active marker.

8753 Command

Description

Range

Query Response

MARKCENT

Sets the center stimulus value to that of the active marker's stimulus value.

N/A

N/A

MARKSTAR

Sets the start stimulus to that of the active marker's.

N/A

N/A

MARKSTOP

Sets the stop stimulus to that of the active marker's.

N/A

N/A

MARKREF

Sets the reference value to that of the active marker's amplitude.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the selected instrument setting to assume the value of the specified marker.

PNA COM Equivalent - Notes

Changes the analyzer's center frequency to the X-axis position of the marker. The start frequency stays the same and the stop frequency adjusts.

Changes the analyzer's start frequency to the X-axis position of the marker. The stop frequency stays the same and the frequency span adjusts.

Changes the analyzer's stop frequency to the X-axis position of the marker. The start frequency stays the same and the frequency span adjusts.

Changes the measurement's reference level to the marker's Y-axis value.

8753 Command

Description

Range

Query Response

MARKDELA

Sets electrical length so group delay is zero at the active marker's stimulus.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the measurement's electrical delay value to the marker's delay value.

8753 Command

Description

Range

Query Response

MARKMAXI

Search for trace maximum on the current channel. Same as SEAMAX.

N/A

<0|1>><LF

MARKMINI

Search for trace minimum on the current channel. Same as SEAMIN.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If a marker is not currently turned ON, set marker to ON with this command.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

MARKCONT

Places the markers continuously on the trace, not on discrete points (interpolates the marker values between discrete points).

N/A

<0|1>><LF

MARKDISC

Places the markers on the discrete measurement points.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the specified marker as either interpolate data or not.

PNA COM Equivalent - Notes

Turns All Marker Interpolation ON and OFF for the measurement.

8753 Command

Description

Range

Query Response

MARKOFF

Turns all markers and marker functions off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Write-only all markers off for selected measurement.

PNA COM Equivalent - Notes

Turn markers OFF by deleting all of the markers from the measurement.

8753 Command

Description

Range

Query Response

MARKCW

Sets the CW frequency to the active marker's frequency.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

8753 Command

Description

Range

Query Response

MARKFSTI<num>

Sets the stimulus position of the fixed marker.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

If the marker is not turned ON, set the marker ON.

Step 2

Set the marker type to "Fixed".

Step 3

Set the position of the marker.

PNA COM Equivalent - Notes

Step 1

Sets and reads the marker type.

Step 2

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKMIDD

Makes the marker amplitude the limit segment middle value during a limit segment edit.

N/A

N/A

MARKSPAN

Sets the span for the entire trace to that of the span between the active marker and the delta reference marker.

N/A

N/A

MARKSTIM

During a limit segment edit, sets the limit stimulus break point to that of the active marker's.

N/A

N/A

MARKZERO

Places the fixed marker at the active marker position and makes it the delta reference.

N/A

N/A

Notes

These functions require multiple SCPI or COM commands along with appropriate math calculations.

8753 Command

Description

Range

Query Response

MARKCOUP

Couples the markers between the channels, as opposed to MARKUNCO.

N/A

<0|1>><LF

MARKUNCO

Uncouples the markers between channels, as opposed to MARKCOUP.

N/A

<0|1>><LF

MARKFAUV

Sets the auxiliary value of the fixed marker position. Works in coordination with MARKFVAL and MARKFSTI.

Amplitude range. Same as MARKFVAL.

<num><LF

MARKFVAL

Sets the value of the fixed marker position.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

Notes

These commands are currently not supported.

MEAS

8753 Command

Description

Range

Query Response

MEASA

Measures and displays input A on the active channel.

N/A

<0|1>><LF

MEASB

Measures and displays input B on the active channel.

N/A

<0|1>><LF

MEASR

Measures and displays input R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

MEASTAT

8753 Command

Description

Range

Query Response

MEASTAT<ON|OFF>

Turns trace statistics on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

MINMAX

8753 Command

Description

Range

Query Response

MINMAX<ON|OFF>

Enables/disables min/max recording per segment. Min and max values are recorded per limit segment. Limit testing need not be active.

N/A

<0|1>><LF

Notes

This command is not available on PNA.

MINU

8753 Command

Description

Range

Query Response

MINU

Data minus memory (linear subtraction). See also "DISPDMM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.


NONotes

NUMG

8753 Command

Description

Range

Query Response

NUMG<num>

Activates the indicated number of groups of sweeps. A group is whatever is needed to update the current parameter once. This function restarts averaging if it is enabled. OPC-compatible.

Integers 1999.

N/A

PNA SCPI Equivalent - Notes

Step 1

Set the number of groups.

Step 2

Set the trigger mode to groups.

PNA COM Equivalent - Notes

No equivalent command at present.

OMII

8753 Command

Description

Range

Query Response

OMII

Omits the isolation step of a calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write isolation cal ON or OFF during Full 2-port calibration.

PNA COM Equivalent - Notes

No equivalent command at present.

OPC

8753 Command

Description

Range

Query Response

OPC

Operation complete. Reports the completion of the next command received by setting bit 0 in the event-status register, or by replying to an interrogation if OPC? is issued.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Operation complete command. Replace "OPC" with "*OPC".

Operation complete query. Replace "OPC?" with "*OPC?".

PNA COM Equivalent - Notes

No equivalent command at present.

OUTP

OUTPACTI | OUTPFAIP | OUTPMARK | OUTPRAF
OUTPAMAX | OUTPFORE | OUTPMEMF | OUTPRAW
OUTPAMIN | OUTPFORM | OUTPMEMO | OUTPRFFR
OUTPAPER | OUTPICAL | OUTPMSTA | OUTPSEGAF
OUTPCALC | OUTPIDEN | OUTPMWID | OUTPSEGAM
OUTPCALK | OUTPIPMCL | OUTPMWIL | OUTPSEGF
OUTPCHAN | OUTPKEY | OUTPOPTS | OUTPSEGM
OUTPDATA | OUTPLEAS | OUTPPLOT | OUTPSEQ
OUTPDATF | OUTPLIM | OUTPPMCAL | OUTPSERN
OUTPDATP | OUTPLIMF | OUTPPRE | OUTPSTAT
OUTPDATR | OUTPLIML | OUTPPRIN | OUTPTITL
OUTPERRO | OUTPLIMM | OUTPPRNALL |

8753 Command

Description

Range

Query Response

OUTPAPER

Outputs the smoothing aperture in stimulus units, rather than as a percentage.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

PNA COM Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

8753 Command

Description

Range

Query Response

OUTPCALC

Outputs the selected error coefficient array for the active cal on the active channel.

Two-digit integers 0112

<array><LF

PNA SCPI Equivalent - Notes

Output the error coefficient array.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPCALK

Outputs the currently active calibration kit, as a string of less than 1000 bytes. The data is in FORM1.

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Read-Write a name for the selected calibration kit.

PNA COM Equivalent - Notes

Sets and Returns a name for the selected calibration kit.

8753 Command

Description

Range

Query Response

OUTPDATA

Outputs the error-corrected data from the active channel in real/imaginary pairs.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the error-corrected data array.

PNA COM Equivalent - Notes

Output the error-corrected data array.

8753 Command

Description

Range

Query Response

OUTPFORM

Outputs the formatted display data array from the active channel, in current display units.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPIDEN

Outputs the identification string for the analyzer in the form: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument. (Same as the "IDN?" command.)

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer.

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

8753 Command

Description

Range

Query Response

OUTPLIM

Outputs the status of the limit test for the channel selected with <num>.

Integers 14

<0|1|-1><LF

PNA SCPI Equivalent - Notes

Check status bit to determine status of the limit test.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPLIML

Outputs the limit test results for each point in the sweep. This is an ASCII transfer.

N/A

<array><LF

OUTPLIMM

Outputs the limit test results at the active marker.

N/A

<num,num,num,num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Returns the result of limit line testing.

8753 Command

Description

Range

Query Response

OUTPMARK

Outputs the active marker values. The first two numbers are the marker response values, and the last is the stimulus value.

N/A

<num,num,num><LF >

PNA SCPI Equivalent - Notes

Read-Write the marker's X-axis value (frequency, power, or time).

Read-only the marker's Y-axis value.

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

Reads the Y-Axis value of the marker.

8753 Command

Description

Range

Query Response

OUTPMEMO

Outputs the memory trace from the active channel. The data is in real/imaginary pairs, and can be treated the same as data read with the OUTPDATA command.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data. When querying memory, you must first store a trace into memory using CALCuate<cnum>:MATH:MEMorize

PNA COM Equivalent - Notes

If the data is not in memory, store data into memory.

Output memory data.

8753 Command

Description

Range

Query Response

OUTPMSTA

Outputs the marker statistics in ASCII format: mean, standard deviation, and peak-to-peak variation in that order. If statistics is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num><LF

PNA SCPI Equivalent - Notes

Step 1

Select the statistic TYPE that you can then query.

Step 2

Read the selected trace statistic.

PNA COM Equivalent - Notes

Returns the Trace Statistics.

8753 Command

Description

Range

Query Response

OUTPMWID

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, and Q in that order. If widths is not on, it is turned on to generate current values and then turned off again.

N/A

<num,num,num><LF>

OUTPMWIL

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, Q, and loss in that order. If widths is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num,num><LF>

PNA SCPI Equivalent - Notes

Use command to set and return filter statistics.

PNA COM Equivalent - Notes

Returns the Filter Statistics resulting from a SearchFilterBandwidth method.

8753 Command

Description

Range

Query Response

OUTPOPTS

Outputs an ASCII string of the options installed in the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Returns a string identifying the analyzer option configuration.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPPRIN

Outputs a PCL raster dump of the display, intended for a graphics printer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

8753 Command

Description

Range

Query Response

OUTPRAW

Outputs the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPSERN

Outputs a string that contains the serial number of the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Output the serial number.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPSTAT

Returns the status byte as an ASCII integer (0255) that can be interpreted as the 8-bit status byte. This command is the same as "STB?."

N/A

<num><LF

PNA SCPI Equivalent - Notes

Reads the value of the instrument status byte.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPTITL

Outputs the display title in ASCII format.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

OUTPDATF

Fast data transfer command for OUTPDATA.

N/A

<array><LF

OUTPFORE

Fast data transfer command for OUTPFORM.

N/A

<array><LF

OUTPMEMF

Fast data transfer command for OUTPMEMO.

N/A

<array><LF

OUTPRAF<num>

Fast data transfer of the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

Notes

The PNA Series Network Analyzer outputs data at the fastest possible data rate at all times. Therefore, there are not any commands in the PNA Series that correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPACTI

Outputs the value of the active function, or the last active function if the active entry area is off. The value is returned in ASCII format.

N/A

<$><LF>

OUTPCHAN

Outputs the active channel number: 1, 2, 3, or 4.

N/A

<num><LF

OUTPDATP

Outputs the trace data indexed by point (see "SELPT").

N/A

<num,num><LF

OUTPDATR

Outputs the trace data for a range of points (see "SELMINPT," "SELMAXPT"). This is an ASCII (FORM4) transfer.

N/A

<array><LF

Notes

The PNA Series Network Analyzer has features to output data and state information much different than earlier network analyzers. Therefore, there are not any commands in the PNA Series that directly correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPAMAX

Outputs the max values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPAMIN

Outputs the min values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPLIMF

Outputs the limit test results for each failed point, followed by the number of failed points. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAF

Outputs the segment number and its limit test status for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAM

Outputs the limit test min/max for all segments. Outputs the segment number, max stimulus, max value, min stimulus, min value for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGF

Outputs the limit test status for a specified segment. See also "SELSEG."

N/A

<0|1|-1><L F> Values returned for limit test status are: 0 (fail), 1 (pass), or -1 (no limit).

OUTPSEGM

Outputs limit test min/max for a specified segment. See also "SELSEG."

N/A

<num,num><LF

Notes

These limit and segment commands currently are not available.

8753 Command

Description

Range

Query Response

OUTPERRO

Outputs the oldest error message in the error queue. Sends the error number first, and then the error message itself, as an ASCII (FORM4) string no longer than 50 characters.

N/A

<num,$><LF

OUTPFAIP

This command is similar to OUTPLIMF except that it reports the number of failures first, followed by the stimulus and trace values for each failed point in the test. ASCII format.

N/A

<array><LF

OUTPICAL

Outputs the selected interpolated error coefficient array for the active cal on the active channel.

Two-digit integers 0112.

<array><LF

OUTPIPMCL

Outputs the interpolated power meter calibration array for channel 1 or channel 2. Values are returned as 100 times the interpolated power meter reading in dB. This is an ASCII transfer (FORM4).

Integers 1 or 2.

<array><LF

OUTPKEY

Outputs the key code of the last key pressed in ASCII format. An invalid key is reported with a 63, a knob turn with a -1. See programming manual for additional information.

N/A

<num><LF

OUTPLEAS

Outputs the learn string, which contains the entire front panel state, the limit table, and the list frequency table. It is always in binary format not intended for decoding.

N/A

<learnstring><LF

OUTPPLOT

Outputs the HP-GL plot string in ASCII format to the GPIB port. Can be directed to a plotter, or read into the computer.

N/A

<$><LF>

OUTPPMCAL

Outputs the power meter calibration array for channel 1 or channel 2. See programming manual for additional information.

Integers 1 or 2.

<array><LF

OUTPPRE

Outputs pre-raw data array <num>. See programming manual for additional information.

integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

OUTPPRNALL

Outputs all of the list values or the current page of operating parameters in ASCII format. See programming manual for additional information.

N/A

Rows of data separated by a <LF>. Ends with <LF><LF>.

OUTPRFFR

Outputs the external source RF frequency. The instrument must be in external source mode, using either INSMEXSA or INSMEXSM.

N/A

<num><LF

OUTPSEQ

Outputs the specified sequence listing to the GPIB port.

Integers 16.

<$><LF>

Notes

These commands currently are not available.


PNotes

PHAO

8753 Command

Description

Range

Query Response

PHAO<num>

Sets the phase offset.

0360 degrees

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the phase offset for the selected measurement.

PNA COM Equivalent - Notes

Sets the Phase Offset.

PHAS

8753 Command

Description

Range

Query Response

PHAS

Selects the phase display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

POIN

8753 Command

Description

Range

Query Response

POIN<num>

Sets the number of points in the sweep, or in a sweep segment.

Choose from: 3, 11, 21, 26, 51, 101, 201, 401, 801, 1601

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the number of data points for the measurement.

PNA COM Equivalent - Notes

Sets or returns the Number of Points.

POL

8753 Command

Description

Range

Query Response

POLA

Selects the polar display format.

N/A

<0|1>><LF

POLMLIN

Selects linear as the marker readout format for polar display.

N/A

<0|1>><LF

POLMLOG

Selects log as the marker readout format for polar display.

N/A

<0|1>><LF

POLMRI

Selects real/imaginary as the marker readout format for polar display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the polar display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the polar display format.

Selects the appropriate marker readout format.

PORE

8753 Command

Description

Range

Query Response

PORE<ON|OFF>

Turns port extensions on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write port extensions ON or OFF.

PNA COM Equivalent - Notes

Turns port extensions ON or OFF.

PORT

8753 Command

Description

Range

Query Response

PORT1<num>[S]

Set the port extension length for Port 1

±10 seconds

<0|1>><LF

PORT2<num>[S]

Set the port extension length for Port 2

±10 seconds

<0|1>><LF

PORTA<num>[S]

Set the port extension length for Input A

±10 seconds

<0|1>><LF

PORTB<num>[S]

Set the port extension length for Input B

±10 seconds

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the extension value at the specified port.

Read-Write the extension value at the specified receiver.

PNA COM Equivalent - Notes

Sets the port extension value for Port 1.

Sets the port extension value for Port 2.

Sets the port extension value for Receiver A.

Sets the port extension value for Receiver B.

PORTP

8753 Command

Description

Range

Query Response

PORTP<CPLD|UNCPLD>

Selects either coupled or uncoupled for the port powers of a given channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write Port Power Coupling ON or OFF.

PNA COM Equivalent - Notes

Turns ON and OFF source power coupling.

POWE

8753 Command

Description

Range

Query Response

POWE<num>[DB]

Sets the output power level.

output power range of your analyzer. The output power range of your analyzer depends upon the model and installed options. Refer to your analyzers users guide to determine the power range of your analyzer.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the RF power output level.

PNA COM Equivalent - Notes

Read-Write the RF power output level.

POWR

8753 Command

Description

Range

Query Response

POWR<num>

Sets the source power range. See also "PRAN."

Use two-digit integers 0007.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

POWS

8753 Command

Description

Range

Query Response

POWS

Selects power sweep from the sweep type menu.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

POWT

8753 Command

Description

Range

Query Response

POWT<ON|OFF>

Sets source power on or off. Works the opposite of the SOUP command. Sending POWTON turns source power off. Sending POWTOFF turns source power on.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turns ON and OFF Source Power.

PNA COM Equivalent - Notes

Turns ON and OFF Source Power.

PRAN

8753 Command

Description

Range

Query Response

PRAN<num>

Sets the source power range. See also "POWR."

integers 07.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PRES

8753 Command

Description

Range

Query Response

PRES

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Preset.

PNA COM Equivalent - Notes

Preset

PRIN

8753 Command

Description

Range

Query Response

PRINALL

Copies the display, in raster graphics mode, to a printer. Requires pass control when using the GPIB port. (Use PRINTALL to send ASCII data to the printer.)

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

PWRR

8753 Command

Description

Range

Query Response

PWRR<PMAN|PAUTO>

Selects whether the power range is in auto or manual mode.

N/A

<0|1>><LF 0 = manual mode; 1 = auto mode

PNA SCPI Equivalent - Notes

Read-Write automatic attenuation control ON or OFF. Setting the automatic attenuation control is equivalent to setting the source power range mode.

PNA COM Equivalent - Notes

Sets or returns the mode of operation of the attenuator control. Setting the automatic attenuation control is equivalent to setting the source power range mode.


RNotes

RAI

8753 Command

Description

Range

Query Response

RAID

Completes the response and isolation cal sequence. OPC-compatible.

N/A

N/A

RAIISOL

Calls the isolation class for the response and isolation calibration.

N/A

N/A

RAIRESP

Calls the response class for the response and isolation calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

REAL

8753 Command

Description

Range

Query Response

REAL

Sets the display format to real.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

REF

8753 Command

Description

Range

Query Response

REFP<num>

Enters the reference position. 0 is the bottom, 10 is the top of the graticule.

Integers 0–10

<num><LF

REFV<num>

Enters the reference line value.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Reference Position of the specified trace in the specified window.

Read-Write the Y axis Reference Level of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Reference Position of the active trace.

Sets or returns the value of the Y-axis Reference Level of the active trace.

RESPDONE

8753 Command

Description

Range

Query Response

RESPDONE

Completes the response calibration sequence. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data.

PNA COM Equivalent - Notes

Calculates the correction data.

REST

8753 Command

Description

Range

Query Response

REST

Measurement restart.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Abort the current sweep with the command in Step 1.

Step 2

Initiate a new sweep with the command in Step 2.

PNA COM Equivalent - Notes

No equivalent command at present.

REV

8753 Command

Description

Range

Query Response

REVI

Calls the reverse isolation calibration class during a full 2-port calibration.

N/A

N/A

REVM

Calls the reverse match calibration class during a full 2-port calibration.

N/A

N/A

REVT

Calls the reverse transmission calibration class during a full 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

RST

8753 Command

Description

Range

Query Response

RST

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Executes a device reset and cancels any pending *OPC command or query. Replace "RST" with "*RST".

PNA COM Equivalent - Notes

Resets instrument. Clears all existing windows and measurements.


SNotes

S

8753 Command

Description

Range

Query Response

S11

Forward reflection measurement.

N/A

<0|1>><LF

S12

Reverse transmission measurement.

N/A

<0|1>><LF

S21

Forward transmission measurement.

N/A

<0|1>><LF

S22

Reverse reflection measurement.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

SADD

8753 Command

Description

Range

Query Response

SADD

Adds a new segment to the table during a list-frequency, limit-table, cal sensor table, or power loss table edit.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to add a segment. A segment must be added prior to setting data in the segment.

PNA COM Equivalent - Notes

Add a segment.

SCAL

8753 Command

Description

Range

Query Response

SCAL<num>

Sets the trace scale factor.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Y axis Per Division value of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Y-axis Per Division value of the active trace.

SDEL

8753 Command

Description

Range

Query Response

SDEL

Deletes the current segment while editing a list frequency, a limit table, or a power loss list.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to delete the specified segment number.

Write-only to delete all segments.

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

SEA

SEAL

SEAMAX

SEAMIN

SEAOFF

SEAR

SEATARG

8753 Command

Description

Range

Query Response

SEAL

Search left for next occurrence of the target value.

N/A

N/A

SEAR

Search right for next occurrence of the target value.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Read-Write the target value for the specified marker when doing Target Searches.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Step 1

Sets the target value for the marker when doing Target Searches.

Step 2a

Moving to the left of the marker position, searches the marker's domain for the target value.

Step 2b

Moving to the right of the marker position, searches the marker's domain for the target value.

8753 Command

Description

Range

Query Response

SEAMAX

Search for trace maximum on the current channel.

N/A

<0|1><LF>

SEAMIN

Search for trace minimum on the current channel.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

SEAOFF

Turns the marker search off.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Turn marker search off by turning OFF the marker.

PNA COM Equivalent - Notes

Turn marker search off by turning OFF the marker.

8753 Command

Description

Range

Query Response

SEATARG<num>

Set the search target amplitude.

Amplitude range.

<num><LF>

PNA SCPI Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

PNA COM Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

SEDI

8753 Command

Description

Range

Query Response

SEDI<num>

During either a frequency, limit, or power loss table edit, selects segment <num> for editing.

State dependent. Range for frequency segment = 1 to 30; Range for limit test segment = 1 to 18; Range for power loss table segment = 1 to 12

<num><LF>

PNA SCPI Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. To edit a segment or limit line, see the following commands:

Commands to edit a segment.

Commands to edit a limit line.

PNA COM Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. See the appropriate methods and properties for segments and limit lines.

SEG

8753 Command

Description

Range

Query Response

SEGIFBW<num>

Sets the IFBW for the active segment of a list-frequency table in swept list mode.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000.

see "Note" below

SEGPOWER<num>

Sets the power for the active segment of a list-frequency table in swept list mode.

Output power range of your analyzer. The output power range is dependent upon the model and option configuration of your analyzer. Refer to your analyzers users guide to determine the output power range of your analyzer.

see "Note" below

Note: Currently these commands can be queried by sending the command followed by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the IFBandwidth for the specified segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.
OR
Sets or returns the IF Bandwidth of a specified sweep segment.

Sets or returns the RF power level of all measurements in a channel
or
Sets or returns the RF power level of a specified sweep segment.

SING

8753 Command

Description

Range

Query Response

SING

Single sweep. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

If sweep is not is single sweep mode, put the analyzer in single sweep mode by setting continuous OFF.

Trigger one sweep.

PNA COM Equivalent - Notes

Single sweep.

SMI

8753 Command

Description

Range

Query Response

SMIC

Selects Smith chart display format.

N/A

<0|1>><LF

SMIMGB

Selects G+jB (conductance and susceptance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLIN

Selects linear magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLOG

Selects log magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRI

Selects real/imaginary pairs (resistance and reactance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRX

Selects R + jX marker readout on a Smith chart.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the Smith chart display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the Smith chart display format.

Selects the appropriate marker readout format.

SMOO

8753 Command

Description

Range

Query Response

SMOOAPER<num>

Sets the smoothing aperture as a percent of the trace.

0.05 to 20%

<num><LF

SMOOO<ON|OFF>

Selects whether smoothing is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the amount of smoothing.

Read-Write data smoothing ON or OFF.

PNA COM Equivalent - Notes

Specifies or returns the amount of smoothing.

Turns data smoothing ON and OFF.

SOUP

8753 Command

Description

Range

Query Response

SOUP<ON|OFF>

Selects whether the source power is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write RF power from the source ON or OFF.

PNA COM Equivalent - Notes

Turns source power ON and OFF.

SPAN

8753 Command

Description

Range

Query Response

SPAN<num>[HZ|DB]

Sets the stimulus span value. If a list frequency segment is being edited, sets the span of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the frequency span of the analyzer.

Read-Write the frequency span for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the frequency span of all measurements in a channel
or
Sets or returns the frequency span of a specified sweep segment.

SRE

8753 Command

Description

Range

Query Response

SRE<num>

Service request enable. A bit set in <num> enables the corresponding bit in the status byte to generate an SRQ.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "SRE" with "*SRE".

PNA COM Equivalent - Notes

No equivalent command at present.

SSEG

8753 Command

Description

Range

Query Response

SSEG<num>

Selects the desired segment of the frequency list for a list frequency sweep. See also "ASEG".

Integers 130

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the specified segment ON or OFF.

The segment will not be turned on until the sweep type is set to "SEGMent" sweep with this command.

PNA COM Equivalent - Notes

Segment collection object.

STAR

8753 Command

Description

Range

Query Response

STAR<num>[HZ|DB]

Sets the start stimulus value. If a list frequency segment is being edited, sets the start of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the start frequency of the analyzer.

Read-Write the start frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the start frequency of all measurements in a channel
or
Sets or returns the start frequency of a specified sweep segment.

STB?

8753 Command

Description

Range

Query Response

STB?

Query only. Outputs the status byte in ASCII format (FORM4). Same as OUTPSTAT.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "STB?" with "*STB?".

PNA COM Equivalent - Notes

No equivalent command at present.

STOP

8753 Command

Description

Range

Query Response

STOP<num>[HZ|DB]

Sets the stop stimulus value. If a list frequency segment is being edited, sets the stop of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To Read-Write the stop frequency of the analyzer.

To Read-Write the stop frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the stop frequency of all measurements in a channel
or
Sets or returns the stop frequency of a specified sweep segment.

STOR

8753 Command

Description

Range

Query Response

STOR<num>

Stores the current instrument state to disk using the file name provided by the preceding TITF<num> command.

Integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to store the specified file.

PNA COM Equivalent - Notes

Saves a measurement state, calibration state, or both.

SWE

8753 Command

Description

Range

Query Response

SWEA

Automatically selects the fastest sweep time based on the current analyzer settings for number of points, IF bandwidth, sweep mode, averaging condition and frequency span.

N/A

N/A

SWET<num>[S]

Sets the sweep time. (Setting SWET0 is equivalent to sending the SWEA command.)

086,400 s

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the automatic sweep time function ON or OFF.

Read-Write the time the analyzer takes to complete one sweep.

PNA COM Equivalent - Notes

Sets the Sweep time of the analyzer. Setting sweep time to 0 will result in the fastest possible sweep time with the current settings.

SWR

8753 Command

Description

Range

Query Response

SWR

Selects the SWR display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


Symbol Conventions

Symbol

Description

<num>

Required numerical data.

<a1| a2>

An appendage that is part of the command. For example, FORMAT<DOS|LIF> indicates that the actual commands are FORMATDOS and FORMATLIF.

<$>

Indicates a character string operand which must be enclosed by double quotes.

|

An either/or choice in appendages or optional data.

[ ]

Optional data.

<LF>

Line feed.


TZNotes

TALKLIST

8753 Command

Description

Range

Query Response

TALKLIST

Selects the talker listener mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Selects the talker listener mode.

TIT

8753 Command

Description

Range

Query Response

TITL<$>

Enters a new display title.

48 characters max

N/A

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

TITF

Titles the indicated file numbers.

<num>: 15 <$>: 10 char. max.

N/A

TITP

Titles the plot to disk file.

10 characters max

N/A

TITR

Titles the indicated internal register.

<num>: 15 <$>: 10 char. max.

N/A

TITREG

Titles save/recall registers 01 through 31. TITREG01 through TITREG05 are the same as TITR1 through TITR5.

<num>: 0131 <$>: 10 char. max.

N/A

TITSEQ

Selects the sequence to be titled.

<num>: 16 <$>: 10 char. max.

N/A

TITSQ

Provides access to the sequence title functions.

N/A

N/A

Notes

These commands currently are not available.

TRACK

8753 Command

Description

Range

Query Response

TRACK<ON|OFF>

Turns marker search tracking on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write tracking capability for the specified marker.

PNA COM Equivalent - Notes

Turns marker search tracking on and off.

TRL

8753 Command

Description

Range

Query Response

TRLL1

Measures TRL Line/match for Port 1 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLL2

Measures TRL Line/match for Port 2 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR1

Measures TRL S11 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR2

Measures TRL S22 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLT

Measures TRL thru during a TRL/LRM 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the calibration method.

Write-only to measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Specifies the type of calibration to perform.

Measures the specified standard from the selected calibration kit.

TST?

8753 Command

Description

Range

Query Response

TST?

Query only. Causes a self test and returns a zero if the test is passed.

N/A

<num><LF>

PNA SCPI Equivalent - Notes

Returns the result of a complete self-test. An ASCII 0 indicates no failures found.

PNA COM Equivalent - Notes

No equivalent command at present.

TSTP

8753 Command

Description

Range

Query Response

TSTP<P1|P2>

Selects test port 1 or 2 for non-S-parameter measurements.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.

PNA COM Equivalent - Notes

Create and display the measurement. Method parameter allows one to select the specific port.

VELOFACT

8753 Command

Description

Range

Query Response

VELOFACT<num>

Enters the velocity factor of the transmission medium.

0 to 10

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the velocity factor to be used with Electrical Delay and Port Extensions.

PNA COM Equivalent - Notes

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

WAIT

8753 Command

Description

Range

Query Response

WAIT

Waits for a clean sweep when used with the OPC command.

N/A

N/A

PNA SCPI Equivalent - Notes

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed.

PNA COM Equivalent - Notes

No equivalent command at present.

WID

8753 Command

Description

Range

Query Response

WIDT<ON|OFF>

Turns the bandwidth search on and off.

N/A

<0|1><LF

WIDV<num>

Enters the widths search parameter.

Amplitude range.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Turn ON bandwidth search. Also, can return statistics.

Step 2

Turn marker tracking ON.

Step 3

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

PNA COM Equivalent - Notes

Step 1

Enter the bandwidth target value.

Step 2

Turn ON bandwidth search.

Step 3

Turn marker tracking ON.

The filter statistics can be returned with this method.

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with DeleteMarker method.


Number of Points Property

About ...

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Modifying Cal Kits

CalKitType Property

Write/Read

Description

Sets and returns a calibration kit type for calibration or to be used for kit modification. To get a handle to this kit, use app.ActiveCalKit

VB Syntax

object.CalKitType = value

Variable

(Type) - Description

object

Use either of these:
A calkit (object).
An Application (object).

Note: app.CalKitType and calkit.calKitType perform exactly the same function.

value

(enum naCalKit) - Calibration Kit type. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

naCalKit

Default

Not Applicable

Examples

calkit.CalKitType = naCalKit_85038A_7_16

kitype = app.CalKitType

C++ Syntax

HRESULT get_CalKitType(tagNACalKit *pVal)
HRESULT put_CalKitType(tagNACalKit newVal)

Interface

IApplication
ICalKit


CalType (perform) Property

About Performing a Calibration

SetCalInfo Property

Write-only

Description

Specifies the type of calibration to perform. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


About Limit Testing

LimitTestFailed Property

Read-only

Description

Returns the results of limit testing for the measurement.

VB Syntax

testFailed = meas.LimitTestFailed

Variable

(Type) - Description

testFailed

(boolean) Variable to store the returned value

False (0) - Limit Test Passed
True (1) - Limit Test Failed

meas

A Measurement (object)

Return Type

Boolean

Default

False returned if there is no testing in progress

Examples

Dim testRes As Boolean
testRes = meas.LimitTestFailed
MsgBox (testRes)

C++ Syntax

HRESULT get_LimitTestFailed(VARIANT_BOOL* trueIfFailed)

Interface

IMeasurement


Reference Marker Property

About Reference Markers

ReferenceMarker Property

Write/Read

Description

Sets (or releases) a marker as a Delta marker. A delta marker reads out data relative to the reference marker. If making a marker a delta marker, you must also turn the reference marker (always marker 10) ON using meas.marker(10)

VB Syntax

mark.ReferenceMarker = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Reference Marker number. Choose from:
0 - Makes the marker NOT a delta marker
10 - Makes the marker a delta marker

Return Type

Long Integer

Default

0 - absolute marker

Examples

mark.ReferenceMarker = 0 'makes the active marker absolute (not delta) -Write

refMark = mark.ReferenceMarker 'returns the reference marker number -Read

C++ Syntax

HRESULT get_ReferenceMarker(long *pVal)
HRESULT put_ReferenceMarker(long newVal)

Interface

IMarker


Reference Stimulus Property

About Reference Markers

ReferenceStimulus Property

Write/Read

Description

Sets or Reads the stimulus (X-Axis) value of the reference marker.

VB Syntax

mark.ReferenceStimulus = value

Variable

(Type) - Description

mark

A Marker (object) that is a delta marker.

value

(double) - stimulus value of the reference maker.

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceStimulus = 4.5e9 'Write

RefStim = mark.ReferenceStimulus 'Read

C++ Syntax

HRESULT get_ReferenceStimulus(double *pVal)
HRESULT put_ReferenceStimulus(double newVal)

Interface

IMarker


About Reference Markers

Reference Value (Marker) Property

Read-only

Description

Returns the Y-Axis value of the reference marker.

VB Syntax

yval = mark.ReferenceValue(format)

Variable

(Type) - Description

yvalue

A variable to store the Y-axis value of the reference marker

mark

A Marker (object) that is a delta marker.

format

(enum NAMarkerFormat) -format of the returned value. Choose from:

naMarkerFormat_LinMag
naMarkerFormat_LogMag
naMarkerFormat_Phase
naMarkerFormat_Delay
naMarkerFormat_Real
naMarkerFormat_Imaginary
naMarkerFormat_SWR
naMarkerFormat_LinMagPhase
naMarkerFormat_LogMagPhase
naMarkerFormat_RealImaginary
naMarkerFormat_ComplexImpedance
naMarkerFormat_ComplexAdmittance

value

(double) - Reference Value

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceValue(naMarkerFormat_LinMag) = 10 'Write

RefVal = mark.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


Status Keywords

Status Command Keywords

About Status Registers

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

:CONDition?

:ENABle

:ENABle?

:EVENt?

:MAP

:NTRansition

:PTRansition

:CONDition?

Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

Query only - This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


PowerTrip

If this stuff ever gets implemented, here it is: (The image map is the same file name)

SENSe:POWer:AC:PROTect:CLEar

(Write-only) Clears a power trip
Examples | SENS:POW:AC:PROT CLE sense:power:ac:protect clear
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:POWer:AC:PROTect:STATe <ON | OFF>

(Read-Write) Enables or disables the protection circuit.
Parameters |
<ON | OFF> | ON (or 1) - Protection circuit is enabled OFF(or 0) - Protection circuit is disabled
Examples | SENS:POW:AC:PROT:STAT ON sense:power:ac:protect:state off
Query Syntax | SENSe:POWer:AC:PROTect:STATe?
Return Type | Boolean 1 - Protection circuit is enabled 0 - Protection circuit is disabled
Overlapped? | No
Default | ON

SENSe:POWer:AC:PROTect:TRIPped?

(Read-only) Queries whether the power is OFF due to an overpower condition.
Examples | SENSe:POWer:AC:PROTect:TRIPped? sense:power:ac:protect:tripped?
Query Syntax | SENSe:POWer:AC:PROTect:TRIPped?
Return Type | Boolean
Overlapped? | No
Default | Not Applicable


Calibrate Measurements

Etalonnage des mesures

Voir aussi...

Cliquez sur l'un des boutons ci-après pour apprendre à réduire les erreurs de mesure en exécutant un étalonnage.

Présentation de l'étalonnage

Erreurs de mesure

Etalons

Sélection et exécution d'un étalonnage

Etalonnages précis

Validité d'un étalonnage


Outputting Data

Imprimer, sauvegarder et rappeler les données

Voir aussi...

Cliquez sur un bouton des rubriques suivantes concernant la sortie de données de mesure.

Sauvegarder et rappeler un fichier

Impression d'une mesure affichée

Connexion de lecteurs


6_Tab

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


3 Tab Model

Three Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4 Tab Model

Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6 Tab Model

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


Reference Body

Power can be defined as the energy transfer per unit time averaged over many periods of the lowest frequency (RF or microwave) involved. The term "average power" is used in specifying almost all RF and microwave systems. Power level is expressed in decibels based on 1 milliwatt (dBm) or 1 watt (dBw).

Power Ranges

Automatic mode

Manual mode

Power coupling options

Power slope

Power sweep

Power Ranges

The built-in synthesized source contains a programmable step attenuator that allows you to directly and accurately set power levels in eight different power ranges. Each range has a total span of 25 dB. The eight ranges cover the instrument's full operating range from +10 dBm to -85 dBm. You can select a power range either manually or automatically.

Automatic Mode

You can select any power level within the total operating range of the instrument and the source attenuator will automatically switch to the corresponding range.

Each range overlaps its adjacent ranges by 15 dB, therefore, certain power levels are designated to cause the attenuator to switch to the next range so that optimum (leveled) performance is maintained. These transition points exist at -10 dB from the top of a range and at +5 dB from the bottom of a range. This leaves 10 dB of operating range.

Manual Mode

If you use the manual power range mode, you must first select the power range that corresponds to the power level you want to set. Consequently, you will not be able to set a power level that is outside the range limits. This feature is necessary to maintain accuracy once a measurement error-correction is switched on.

Power Coupling Options

You can couple the measurement channels settings, making the measurement stimulus the same. By default the power at the test ports are coupled, making the power levels at both ports the same. Uncoupling the channels will separate the sources. You can also uncouple the test ports, allowing you to have different power levels on each port.

Power Slope

Power slope compensates for power loss versus the frequency sweep. Starting at the selected power level, the output power increases by sloping the output power upwards proportionally to frequency. Enter the power slope in dB per GHz of sweep.

Power Sweep

Power is swept at a single frequency, from a start power value to a stop power value. You select the start and stop power values, using the start and stop functions. To set the frequency of the power sweep, you use the CW frequency function. The span of the swept power is limited to being equal to or within one of the eight pre-defined power ranges.

The attenuator will not switch to a different power range while in the power sweep mode.

Tell Me More


Reference Mini Guide

Guide to Learning About XYZ

Introduction text goes here...

In this Topic...

You will learn...

Topic Title

the basics of...

Topic Title

when to...

Topic Title

when to...

Topic Title

the basics of...

Topic Title

when to...