F Tour

Descripción del panel frontal

Véase asimismo...

  • Explorar el gráfico con el ratón.

  • Haga clic en las secciones del panel frontal para obtener información.


R Tour

Descripción del panel posterior

Véase asimismo...

  • Explorar el gráfico con el ratón

  • Haga clic en los conectores para obtener información.


Op Model

Modelo de funcionamiento del analizador

Véase asimismo...

El analizador dispone del siguiente modelo de funcionamiento para realizar medidas.

Canal

Traza

Ventana

Límites de funcionamiento

  • Un canal cuenta con una serie de atributos independientes asociados a la recogida de datos.

  • Los atributos se aplican a todas las trazas asignadas a dicho canal.

  • Es posible tener hasta cuatro canales independientes.

  • Para modificar su configuración, un canal debe estar activo.

  • Cada traza cuenta con valores que afectan al modo en el que se presentan los datos medidos.

  • Puede haber hasta 16 trazas presentes en el analizador. Se pueden asignar todas a un canal, o bien dividirlas entre cuatro canales.

  • Para modificar su configuración, una traza debe estar activa.

  • Una ventana se utiliza para visualizar trazas.

  • El analizador puede mostrar 1, 2, 3 o 4 ventanas en la pantalla.

1 ventana | 2 ventanas
3 ventanas | 4 ventanas

  • Visualizar trazas de canales múltiples en una ventana.

  • Visualizar trazas de canales múltiples en múltiples ventanas.

Límites de funcionamiento del analizador:

  • Cuatro ventanas por pantalla

  • Cuatro trazas de datos y cuatro trazas de memoria por ventana

  • 16 trazas activas por pantalla y 16 trazas de memoria por pantalla

  • Cuatro canales de medida independientes


Meas Seq

Secuencia de medida básica

Véase asimismo...

Punto 1. Configurar medidas

Preajustar el analizador, crear un estado de medida y ajustar la pantalla.

Punto 2. Optimizar medidas

Mejorar la precisión y el rendimiento de las medidas mediante técnicas y funciones.

Punto 3. Calibrar medidas

Reducir los errores de medida realizando una calibración.

Punto 4. Analizar datos

Analizar los resultados de medida utilizando marcadores, operaciones matemáticas y pruebas de límites.

Punto 5. Imprimir, guardar o recuperar datos

Guardar o imprimir los datos de medida.


Interface

Interfaz de usuario

Véase asimismo...

Interfaz del panel frontal

Acceso a funciones básicas

Acceso a cuadros de diálogo

Acceso a menús desplegables

Interfaz de ratón

Interfaz del panel frontal: Acceso a funciones básicas

Interfaz del panel frontal: Acceso a cuadros de diálogo

Interfaz del panel frontal: Acceso a menús desplegables

Interfaz de ratón


Find Info

Localizar información en la Ayuda

Véase asimismo...

Se puede encontrar información en los siguientes lugares:

Página principal y barra de herramientas

Índice

Contenido

Glosario

Cuadros de diálogo

Vínculos de exploración

Página principal y barra de herramientas

Índice

Contenido

Glosario

Nota: Si se hace clic en una palabra que aparece en verde, se podrá ver la definición del glosario.

Cuadros de diálogo

Vínculos de exploración


Print Topic

Imprimir el tema actual de la Ayuda

Véase asimismo...


Close Help

Cerrar la ventana de la Ayuda

Véase asimismo...


Size Position

Cambiar el tamaño y la posición de la ventana de la Ayuda

Véase asimismo...

Hay varias maneras de cambiar el tamaño y la posición de la ventana de la Ayuda.

Reducir o ampliar proporcionalmente

Maximizar o minimizar

Cambiar la posición

Ampliar o reducir proporcionalmente la ventana de la Ayuda

Maximizar o minimizar la ventana de la Ayuda

Cambiar la posición de la ventana de la Ayuda


NewUsers

Usuarios adicionales del analizador de redes

Véase asimismo...

Cuando el analizador está encendido, inicia automáticamente Windows 2000 utilizando la contraseña y el nombre de usuario de Administrador predeterminados. Si el analizador se encuentra en uno de los entornos descritos a continuación, apenas será necesario realizar algunas tareas de administración.

  • Está situado en un entorno seguro

  • No está controlado mediante COM en la LAN

  • No cuenta con usuarios que realicen conexiones de red a las unidades de disco de los instrumentos ni a las impresoras utilizando sus propios nombres de usuario y contraseñas.

Si el analizador se encuentra en un entorno que precisa diferentes niveles de usuarios, como el administrador del analizador de redes, se podrá configurar el analizador para permitir que otros usuarios puedan utilizarlo con permisos limitados. Es decir, otros usuarios pueden iniciar una sesión para utilizar el analizador, pero no podrán realizar todas las funciones que puede llevar a cabo el administrador.

  1. En el menú System del analizador, señalar con el cursor del ratón Configure y hacer clic en Control Panel.

  2. En la ventana Control Panel, desplazarse hacia abajo y seleccionar la aplicación Users and Passwords.

  3. En la ficha Users , si el botón Add aparece en gris, seleccionar la casilla de verificación Users must enter a user name and password to use this computer que aparece en la parte superior de la ventana.

  4. Hacer clic en Add para introducir la información del nuevo usuario.

  5. En el cuadro User name, escribir el nombre de usuario para el nuevo usuario. En el cuadro Full name, escribir el nombre completo del nuevo usuario.

  6. En el cuadro Description, escribir una descripción para el nuevo usuario. A continuación, hacer clic en Next.

  7. En el cuadro Password, el nuevo usuario deberá escribir una contraseña. El nuevo usuario deberá volver a escribir la contraseña en el cuadro Confirm password. A continuación, hacer clic en Next.

  8. Determinar el nivel de acceso que se desea otorgar a este nuevo usuario. La opción Restricted User no está disponible en este momento.

  9. Hay varios niveles de seguridad que se pueden conceder en la lista Other. Cuando se selecciona, debajo del cuadro Other aparece una descripción de cada uno de estos niveles.

  10. Seleccionar el nivel de acceso que se desea otorgar a este nuevo usuario. A continuación, hacer clic en Finish.

  11. En el cuadro Users for this computer, validar el nombre de usuario y el grupo de nivel de seguridad del nuevo usuario.

  12. Si se desea que este usuario pueda utilizar el analizador de redes sin tener que introducir la contraseña cada vez que lo utilice, desactivar la casilla de verificación Users must enter a user name and password to use this computer.

  12. Cuando aparezca la ventana Automatically Log On, el nuevo usuario deberá escribir la contraseña en el cuadro Password y volverla a escribir en el cuadro Confirm Password. A continuación, hacer clic en OK.

  13. Hacer clic en OK para finalizar el proceso de incorporación del nuevo usuario.

  14. En el menú File, hacer clic en Close para cerrar el panel de control.


Emergency

Disco de reparación de emergencia

Véase asimismo...

En caso de que el disco duro del analizador sufra daños, podrá recuperarse el contenido del disco duro si se ha creado un disco de recuperación de emergencia. Se debe crear este disco después de configurar por primera vez el instrumento.

Para ello se necesita un disquete en blanco de 1,44 MB para crear el disco de reparación de emergencia.

Nota: El proceso de reparación necesita información que se guarda en la carpeta systemroot\repair. No se debe cambiar ni eliminar esta carpeta.

Hay disponible más información sobre el proceso de reparación:

  • Si se está utilizando Windows 2000 Professional, véase el libro en línea Windows 2000 Professional Getting Started o bien el libro Windows 2000 Professional Getting Started que se incluye con el CD-ROM de Windows 2000.

  • Si se está utilizando Windows 2000 Server, consúltese la sección "How to" de Disaster Recover.

Para crear un disco de reparación de emergencia

  1. Desde el menú System del analizador, hacer clic en Windows Taskbar.

  2. Hacer clic en Start y llevar el cursor del ratón a Programs, Accessories, System Tools, y hacer clic en Backup.

  3. En el menú Tools, hacer clic en Create an Emergency Repair Disk.

  4. Hacer clic en la casilla de verificación Also back up the registry to the repair directory....

  5. Seguir las instrucciones que aparecen en la pantalla.


Véase asimismo...

Preajustar el analizador

Descripción general

Condiciones de
preajuste

Condiciones
de suspensión

Condiciones
de encendido

El analizador puede asumir uno de los siguientes conjuntos de condiciones conocidos.
Condiciones de preajuste

Condiciones de suspensión

Condiciones de encendido

Cuando se pulsa la tecla Preset del panel frontal, el estado de instrumento del analizador se ajusta a las siguientes condiciones de preajuste.
Configuración de frecuencia
Configuración de potencia
Parámetros de barrido
Parámetros de barrido de segmentos
Parámetros de disparo
Configuración de pantalla
Configuración de respuesta
Configuración de calibración
Configuración de marcadores
Configuración de pruebas de límites
Configuración en el dominio del tiempo (sólo Opción 010)
Configuración global de pantalla

Configuración de frecuencia:

Parámetro de medida | S11
Frecuencia de inicio | 300 kHz
Frecuencia de parada | 3 GHz para E8356A 6 GHz para E8357A 9 GHz para E8358A
Frecuencia de CW | 1 GHz

Configuración de potencia:

Potencia del puerto de verificación | 0 dBm (1 mW) para todos los modelos
Potencia de puertos acoplados | Activada
Atenuación automática | Activada
Valor del atenuador | 0 dB
Pendiente de potencia | Desactivada
Valor de pendiente | 0 dB/GHz

Parámetros de barrido:

Tipo | Frecuencia lineal
Modo | Continuo
Generación | Analógico
Tiempo de barrido automático | Activado
Número de puntos | 201

Parámetros de barrido de segmentos:

Segmentos activos | 1
Frecuencia de inicio | 300 kHz
Frecuencia de parada | 1 MHz
Número de puntos | 21
Potencia | 0 dBm
Ancho de banda de IF | 1 kHz
Tiempo de intervalo | 0 s

Parámetros de disparo

Fuente | Interna
Modo | Barrido

Configuración de pantalla:

Formato

Magnitud logarítmica

Esta configuración se aplica a los formatos cuando se seleccionan:

FORMATO | ESCALA | REFERENCIA POSICIóN | REFERENCIA VALOR
Magnitud logarítmica | 10 dB/ | 5 | 0 dB
Fase | 10 grados/ | 5 | 0 grados
Retardo de grupo | 10 s/ | 5 | 0 s
Magnitud lineal | 10 unidades/ | 0 | 0 unidades
SWR | 10 unidades/ | 0 | 1 unidad
Real | 10 unidades/ | 5 | 0 unidades
Imaginario | 10 unidades/ | 5 | 0 unidades
Polar | 1 unidad/ | no procede | 1 unidad
Diagrama de Smith | 1 unidad/ | no procede | 1 unidad

Configuración de respuesta:

Número de canal | 1
Ancho de banda de IF | 35 kHz
Promediado | Desactivado
Factor de promediado | 1
Suavizado | Desactivado
Factor de suavizado | 1% del recorrido
Retardo eléctrico | 0 s
Factor de velocidad | 1.0
Desplazamiento de fase | 0 grados
Visualización de trazas de memoria/matemáticas | Datos

Parámetros de corrección:

Estado de corrección | Desactivado
Estado de interpolación | Activado
Tipo de calibración | Ninguno
Número de kit de calibración | 1
Impedancia Z0 del sistema | 50 ohmios
Estado de extensiones de puertos | Desactivado
Puerto externo Valores Entrada A, B Puerto 1, 2 | 0

Configuración de marcadores:

Frecuencia inicial | Frecuencia central actual
Referencia | Ninguno
Interpolación | Activada
Formato | Valor predeterminado de traza
Tipo | Normal
Función | Valor máximo
Dominio | Recorrido completo
Tabla | Vacía
Acoplamiento | Siempre sin acoplar

Configuración de pruebas de límites:

Pruebas de límites | Desactivado
Visualización de líneas | Desactivada
Sonido al fallar | Desactivado

Configuración de lista de límites:

Tipo (DESACTIVADO, MáXIMO, MíNIMO) | DESACTIVADO
Estímulo de comienzo | 300 kHz
Estímulo final | 3 GHz para E8356A 6 GHz para E8357A 9 GHz para E8358A
Respuesta de comienzo | 0
Respuesta final | 0

Dominio del tiempo (sólo Opción 010):

Estado de transformada | Desactivado
Modo de transformada | Paso de banda
Inicio de transformada | -10 ns
Parada de transformada | 10 ns
Ventana | 6,0 (factor de Kaiser-Bessel)
Estado de puerta de tiempo | Desactivado
Inicio de puerta de tiempo | -10 ns
Parada de puerta de tiempo | 10 ns
Tipo de puerta de tiempo | Paso de banda
Forma de puerta | Normal

Configuración global de pantalla:

Estado de traza | Activado
Frecuencia/estímulo | Desactivado
Lectura de marcador | Activado (cuando está activado un marcador)
Barras de herramientas mostradas | Active Entry
Estado de la barra de estado | Desactivado

El interruptor de encendido/apagado se utiliza para alternar el analizador entre los estados de Encendido y de Suspensión. Cuando el analizador se encuentra en el estado de Suspensión, el sistema operativo del analizador se paraliza. Cuando el analizador vuelve al estado de Encendido, el sistema se reactiva con las mismas condiciones en las que se dejó.

Cuando se encuentra encendido, la luz del botón es verde. Cuando se encuentra en Suspensión, la luz del botón es amarilla. Este interruptor del panel frontal sólo es un conmutador de espera, no es un conmutador de alimentación (dispositivo de desconexión). El estado de suspensión es el estado normal de "apagado". Cuando el analizador se encuentra en modo de suspensión, se le suministra una pequeña cantidad de corriente de reserva. Esta corriente de reserva sólo alimenta los circuitos del interruptor de encendido; durante la espera, ningún otro circuito relacionado con la CPU recibe alimentación.

Cuando se activa la suspensión, se guarda en el disco duro el estado de todos los programas en ejecución y la alimentación se apaga automáticamente. Cuando se vuelve a encender el analizador, el sistema operativo del analizador localiza los estados almacenados por la operación de suspensión anterior y los vuelve a cargar; de esta forma, se ahorra tiempo al no tener que realizar el procedimiento de reinicio completo del sistema.

Para situar el analizador en la condición de Suspensión, pulsar brevemente el botón de encendido.

Precaución: Si se mantiene pulsado el interruptor de encendio durante más de 4 segundos se producirá un apagado inmediato del sistema, igual que si se desenchufara la clavija del instrumento. Esto deberá evitarse, ya que se podría dañar el sistema de archivos; algo que también ocurriría con cualquier otro PC. La mayoría de las veces, Windows es capaz de recuperarse sin que se produzca ninguna pérdida de datos. Esto no significa que se trate de una práctica segura.

Al cabo de unos segundos, aparecerá el título Ready to Hibernate (preparado para suspensión), seguido brevemente del título Preparing to Hibernate (preparándose para suspensión) del sistema operativo Windows. La luz del botón de encendido cambia de verde a amarillo cuando el analizador se encuentra en el modo de suspensión.

Para reactivar el analizador, pulsar de nuevo el botón de encendido. La luz del botón de encendido vuelve a cambiar de amarillo a verde para indicar que se está reactivando. El analizador deberá volver a su estado anterior en aproximadamente 45 segundos.

Sólo se debe desconectar la alimentación del analizador por motivos específicos, como por ejemplo durante el desplazamiento o el mantenimiento del mismo. Si se desconecta la alimentación del analizador, serán aplicables las condiciones de encendido.

Si se desconecta la alimentación del analizador, las condiciones de encendido se aplicarán cuando se restablezca la alimentación y se encienda el analizador. El estado de encendido es igual que el estado de preajuste, con las siguientes excepciones:

Dirección GPIB | último valor activo (valor predeterminado de fábrica = 16)
Dirección SCPI a través de LAN | último valor activo (valor predeterminado de fábrica = 16)
Modo GPIB | Emisor/receptor
Estado del instrumento | El mismo que cuando se apagó


Seleccionar un estado de medida

Configurar medidas

Véase asimismo...

Se puede configurar la medida realizando el siguiente procedimiento:
Seleccionar un parámetro de medida

Ajustar el margen de frecuencias

Ajustar el nivel de potencia de RF

Seleccionar barrido

Seleccionar el activador

Seleccionar el formato de datos y la escala


Ajustar la pantalla

Véase asimismo...

Para aprender a ajustar la pantalla del analizador y obtener una óptima visualización, haga clic en los siguientes vínculos:
Ver trazas y canales múltiples
Personalizar la pantalla del analizador
Mostrar u ocultar información de medidas


Precisión

Mejorar la precisión de las medidas

Véase asimismo...

Haga clic en un botón para obtener información sobre la manera de optimizar una medida para aumentar la precisión.

Aumentar el margen dinámico

Incrementar el número de puntos de datos

Mejorar la precisión de las medidas de fase

Mejorar las medidas de dispositivos eléctricamente largos

Mejorar la precisión de la reflexión en dispositivos de 2 puertos con baja pérdida

Mejorar la estabilidad de las medidas

Reducir el ruido de las trazas

Reducir la diafonía del receptor

Reducir los efectos de los accesorios


Effects Accy

Véase asimismo...

Efectos de los accesorios

Descripción general

Conceptos

Cómo reducir los efectos
de los accesorios

Los accesorios de una configuración podrán afectar a los resultados de la medida de un dispositivo. Se puede elegir una de las dos funciones del analizador que reducen los efectos de los accesorios .
Conceptos

Cómo reducir los efectos de los accesorios

Para reducir los efectos de los accesorios, se puede elegir el método que mejor se adapte a la configuración de medida.
Pendiente de potencia para compensar la pérdida a través del cable
Sistema de puerta para eliminar respuestas selectivamente

Pendiente de potencia para compensar la pérdida a través del cable

Si se utiliza un cable largo u otro accesorio en una configuración de medida en la que se produce una pérdida de potencia a lo largo de la frecuencia, aplicar la función de pendiente de potencia. Esta función aumenta la potencia de la fuente del analizador en una proporción definida por el usuario (dB/GHz).

Sistema de puerta para eliminar respuestas selectivamente

El sistema de puerta es una función en el dominio del tiempo (opción 010) que permite al analizador eliminar respuestas matemáticamente. Se puede ajustar la puerta de tiempo para una respuesta de reflexión o de transmisión, pero se obtendrán resultados diferentes.

  • La aplicación de la puerta de tiempo a una respuesta de reflexión aísla una respuesta deseada (como la pérdida de retorno de un filtro) de respuestas no deseadas (como reflexiones de adaptadores o desadaptaciones de conectores).

  • La aplicación de la puerta de tiempo a una respuesta de transmisión aísla una ruta específica en un dispositivo multirrecorrido que tiene longitudes eléctricas largas.

Después de aplicar el sistema de puerta al modo de dominio en el tiempo, se podrá desactivar la transformada y estudiar la respuesta en frecuencia del dispositivo mientras la puerta de tiempo sigue estando activa. La puerta del filtro de tiempo puede tener las siguientes formas y comportamientos:

  • Forma de paso de banda, que elimina respuestas situadas fuera de la zona de banda de paso.

  • Forma de muesca, que elimina respuestas situadas dentro de la zona de rechazo.

Véase Filtro de puerta para obtener más información al respecto.

Haga clic en los botones para acceder a los procedimientos utilizados para reducir los efectos de los accesorios.
Compensar la pérdida a través del cable
Eliminar respuestas no deseadas

Compensar la pérdida a través del cable
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. Si la función de pendiente todavía no está activada, hacer clic en la casilla de verificación Slope.

  3. En el cuadro dB/GHz, introducir la proporción en la que se desea que aumente la potencia de la fuente a lo largo del barrido de frecuencias. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. En la barra de herramientas Active Entry, pulsar F4 (Pendiente).

  3. En el bloque ENTRY, introducir la proporción en la que se desea que aumente la potencia de la fuente a lo largo del barrido de frecuencias. A continuación, pulsar Enter.

Eliminar respuestas no deseadas (Opción 010, sólo en el dominio del tiempo)
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Transform.

  2. Hacer clic en la casilla de verificación Transform para activar el modo de transformada.

  3. Bajo Transform Mode, hacer clic en el modo deseado.

    • Low Pass Impulse

    • Low Pass Step

    • Band Pass

  4. Si se seleccionó Low Pass, hacer clic en Set Freq. Low Pass.

  5. En el cuadro Category, hacer clic en la flecha hacia abajo para seleccionar Gating.

  6. En el cuadro Gate Type, hacer clic en la flecha hacia abajo para seleccionar la operación de puerta de tiempo.

    • Bandpass

    • Notch

  7. Definir los límites de la puerta de tiempo utilizando los parámetros Start y Stop o Center y Span.

  8. Hacer clic en la casilla de verificación Gating para activar la función de puerta de tiempo. Hacer clic en OK.

  9. En el menú Trace, hacer clic en Transform.

  10. En el cuadro Category, hacer clic en la flecha hacia abajo para seleccionar Transform. Hacer clic en la casilla de verificación Transform y en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND,,pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Trace y desplazarse hasta Transform. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Transform y pulsar Click.

  4. Pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al modo Transform Mode y a la selección deseada.

    • Low Pass Impulse

    • Low Pass Step

    • Band Pass

  5. Si se seleccionó Low Pass, desplazarse hasta Set Freq. Low Pass y pulsar Click.

  6. Pasar al cuadro Category y seleccionar Gating.

  7. Pasar al cuadro Gate Type y seleccionar la operación de puerta de tiempo.

    • Bandpass

    • Notch

  8. Definir los límites de la puerta de tiempo utilizando los parámetros Start y Stop o Center y Span.

  9. Pasar a la casilla de verificación Gating y pulsar Click, OK.

  10. Pasar al cuadro Category y seleccionar Transform.

  11. En el bloque COMMAND, pulsar Menu/Dialog.

  12. Pasar al menú Trace y desplazarse hasta Transform. Pulsar Click.

  13. Desplazarse hasta la casilla de verificación Transform y pulsar Click, OK.


Refl Accy

Véase asimismo...

Precisión de la reflexión en dispositivos de 2 puertos con baja pérdida

Descripción general

Conceptos

Cómo medir la
precisión de la reflexión

Para efectuar medidas precisas de la reflexión que tengan una calibración de 1 puerto, se deberá terminar el puerto no medido.
Conceptos

Cómo medir la reflexión de forma precisa en dispositivos de 2 puertos

Para medir de forma precisa la respuesta de la reflexión con una calibración de 1 puerto se deberá terminar el puerto opuesto (no medido). Esto es aplicable especialmente a los dispositivos bidireccionales con baja pérdida, como cables y bandas de paso de filtros. Una calibración de 1 puerto corrige la directividad, el acoplamiento entre fuentes y la respuesta en frecuencia, pero no la adaptación de carga. Por consiguiente, se deberá reducir al máximo el error de adaptación de carga.

Nota: Una calibración de 2 puertos corrige los doce términos de errores, incluída la adaptación de carga.

Se puede terminar el puerto no medido de la siguiente manera:

  • Conectar una carga de terminación de alta calidad (de un kit de calibración, por ejemplo) al puerto no medido del dispositivo. Esta técnica proporciona una precisión de medida similar a la de una calibración SOLT completa de 2 puertos.

  • Conectar directamente el puerto no medido del dispositivo al analizador, insertando un atenuador de precisión de 10 dB entre la salida del dispositivo y el analizador. Esto aumenta la adaptación de carga efectiva del analizador aproximadamente el doble del valor del atenuador, o 20 dB.

Sugerencia:

  • No es necesario preocuparse por la adaptación de carga cuando se mide un dispositivo con un elevado aislamiento inverso, como un amplificador.

En el siguiente gráfico se muestra la incertidumbre de medida que se obtiene de la terminación con y sin un atenuador de precisión de 10 dB en la salida del dispositivo de prueba.

Clave

 | Reflexión de filtro
------------- | Incertidumbre con atenuador
................ | Incertidumbre sin atenuador

Los cálculos que aparecen a continuación muestran cómo al añadir un atenuador de alta calidad de 10 dB aumenta la adaptación de carga del analizador.

Nota: El valor lineal correspondiente aparece entre paréntesis.

Analizador de redes: |
Adaptación de carga (NA LM) | = 18 dB (0,126)
Directividad (NAD) | = 40 db (0,010)
Filtro: |
Pérdida por inserción (FIL) | = 1 dB (0,891)
Pérdida de retorno (FRL) | = 16 dB (0,158)
Atenuador: |
Pérdida de inserción (AIL) | = 10 dB (0,316)
SWR (ASWR) | = 1.05 (.024) Pérdida de retorno de 32,26 dB

Cálculos:

 | Sin atenuador | Con atenuador
r NA | = (F IL )*(NA LM )*(F IL ) = (.891)*(.126)*(.891) =.100 | = (F IL )*(A IL) *(NA LM )*(AIL) *(F IL ) = (.891)*(.316)*(.126)*(.316)*(.891) = .010
r Atenuador | NA | = (F IL )*(A SWR) *(F IL ) = (.891)*(.126)*(.891) = .019
Error en el peor de los casos (E WC ) | = r NA =0,1 | = r NA + rAten. =.01+.019 =.029
La incertidumbre suma | = -20log(F RL) +(E WC) +(NA D) = -20log(0,158) +(0,100)+(0,010) = 11,4 dB | = -20log(F RL) +(E WC) +(NA D) = -20log(0,158) +(0,029)+(0,010) = 14,1 dB
La incertidumbre resta | = -20log(F RL) -(E WC) -(NA D) =-20log(0,158)-(0,100)-(0,010) = 26,4 dB | = -20log(F RL) -(E WC) -(NA D) = -20log(0,158) -(0,029)-(0,010) = 18.5 dB

Para efectuar medidas de reflexión precisas en dispositivos de 2 puertos con baja pérdida, realizar una de las siguientes acciones:

  • Conectar una carga de alta calidad a la salida del dispositivo despues de realizar una calibración de 1 puerto.

  • Insertar un atenuador de 10 dB entre la salida del dispositivo y el analizador después de realizar una calibración de 1 puerto.

  • Conectar la salida del dispositivo directamente al analizador después de realizar una calibración de medida de 2 puertos.


Dyn Rge

Véase asimismo...

Margen dinámico

Descripción general

Conceptos

Cómo aumentar
el margen dinámico

El m argen dinámico es la diferencia entre la potencia de entrada máxima del receptor del analizador y la potencia mínima que se puede medir (límite inferior del ruido). Para que una medida sea válida, las señales de entrada deben encontrarse dentro de estos límites.
Conceptos

Cómo aumentar el margen dinámico

Es importante aumentar el margen dinámico si se necesita medir variaciones muy grandes de la amplitud de las señales, como el paso de banda y el rechazo de un filtro. El margen dinámico se muestra a continuación para un ejemplo de medida.

Para contribuir a reducir la incertidumbre de las medidas, el margen dinámico del analizador debería ser mayor que la respuesta que muestra el dispositivo. Por ejemplo, la precisión aumenta cuando la señal se encuentra, al menos, 10 dB por encima del límite inferior del ruido. Los métodos siguientes pueden ayudar a aumentar el margen dinámico.
Aumentar la potencia de entrada del dispositivo
Reducir el límite inferior del ruido del receptor

Reducir el ancho de banda de IF

Añadir o cambiar los promedios de barridos

Nota: Debido a la naturaleza interactiva de algunos de los parámetros del analizador, el aumento del margen dinámico podrá provocar un incremento del tiempo de medida.

Aumentar la potencia de entrada del dispositivo

  • Incrementar la potencia que se introduce en un dispositivo sometido a prueba para que el analizador pueda detectar y medir con mayor precisión la potencia de salida del dispositivo.

  • Si las entradas del receptor del analizador son demasiado elevadas, podrán causar distorsión de compresión y, si son suficientemente altas, podrán incluso dañar el receptor.

¡Precaución! Nivel de daños de las entradas del receptor: +15 dBm.

Sugerencia: Si el analizador está provisto de la Opción 015 (equipo de verificación configurable), se podrá aumentar incluso más el margen dinámico incrementando la potencia de entrada que llega al dispositivo sometido a prueba mediante un amplificador reforzador externo.

Reducir el límite inferior del ruido del receptor

Se pueden utilizar las siguientes técnicas para reducir el límite inferior del ruido y aumentar el m argen dinámico del analizador.

  • Reducir el ancho de banda de IF

  • Añadir o cambiar los promedios de barridos

Sugerencia: Cuando se midan señales cerca del límite inferior del ruido del analizador, debería reducirse la d iafonía entre los receptores del analizador. (Véase Diafonía del receptor .)

Reducir el ancho de banda de IF

  • Al reducir el ancho de banda de IF del receptor se reduce el efecto del ruido aleatorio en una medida. Cada vez que se reduce en diez veces el ancho de banda de IF, se reduce el límite inferior del ruido en 10 dB. Sin embargo, los anchos de banda de IF más estrechos alargan los tiempos de barrido.

  • El analizador de redes convierte la señal recibida de su frecuencia de RF/microondas a una frecuencia intermedia, o IF, más baja a 41,67 kHz. El ancho de banda del filtro de paso de banda de IF, o ancho de banda de IF, se puede ajustar desde 40 kHz hasta un mínimo de 1 Hz.

  • El ancho de banda de IF se puede ajustar independientemente para cada canal o cada segmento de un barrido de segmentos.

Efecto de la reducción del ancho de banda de IF

Añadir o cambiar los promedios de barridos

  • El promedio de barridos es un proceso que reduce los efectos del ruido aleatorio en una medida.

  • El analizador calcula cada punto de datos en función del promedio de barridos consecutivos ponderados mediante un factor de promediado especificado por el usuario.

  • Cada nuevo barrido se añade al promedio de trazas hasta que el número total de barridos es igual al factor de promediado.

  • Cuanto mayor sea el número de promedios (factor de promediado), mayor será el grado de reducción del ruido y mayor será el margen dinámico.

Efecto de los promedios de barridos

Sugerencias:

  • Se puede ajustar la función de promedios de medidas independientemente para cada canal.

  • El tiempo de medida total aumenta con el número de promedios.

  • Para reducir el ruido de frecuencia general, utilizar promedios de medida y el ancho de banda de IF para obtener el mismo beneficio de reducción de ruido.

  • Para reducir ruido muy bajo, la utilización de promedios de medidas es más eficaz que la reducción del ancho de banda del sistema.

Haga clic en los botones para acceder a los procedimientos utilizados para aumentar el m argen dinámico.
Aumentar la potencia de entrada del dispositivo
Reducir el límite inferior del ruido del receptor

Aumentar la potencia de entrada del dispositivo

¡Precaución! Si el dispositivo sometido a prueba tiene ganancia, no se podrá utilizar la potencia de salida máxima de la fuente, ya que se dañaría el receptor. Nivel de daños de las entradas del receptor: +15 dBm.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. Seleccionar la casilla de verificación Power On.

  3. Bajo Port Selection, seleccionar el puerto que se está utilizando como salida de la fuente.

  4. En el cuadro Test Port Power, introducir el valor o hacer clic en el botón de flecha para seleccionar el valor deseado.

  5. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. En el bloque NAVIGATION, pulsar F1 (Nivel).

  3. En el bloque ENTRY, introducir el valor de potencia y pulsar Enter.

Reducir el límite inferior del ruido del receptor

Reducir el límite inferior del ruido del receptor reduciendo el ancho de banda de IF.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Reducir el ancho de banda de IF

  1. En el menú Sweep, hacer clic en IF Bandwidth.

  2. En el cuadro IF Bandwidth, introducir el valor o hacer clic en el botón de flecha para seleccionar un valor para un ancho de banda estrecho.

  3. Hacer clic en OK.

Añadir o cambiar los promedios de barridos

  1. En el menú Channel, hacer clic en Average.

  2. Seleccionar la casilla de verificación Average ON, para activar la función de promediado.

  3. En el cuadro Average Factor, introducir el valor o hacer clic en el botón de flecha para incrementar el número de promedios que se desea que tome el analizador para la medida.

  4. Hacer clic en OK.

Nota: Hacer clic en Channel, Restart Average para que el analizador tome una nueva serie de barridos para el promediado.

Procedimiento con las teclas del panel frontal

Reducir el ancho de banda de IF

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. En el bloque NAVIGATION, pulsar F3 (Ancho de banda).

  3. En el bloque ENTRY, introducir el valor del ancho de banda de IF y pulsar Enter.

Añadir o cambiar los promedios de barridos

  1. En el bloque CHANNEL SETUP, pulsar Average.

  2. En el bloque NAVIGATION, pulsar F1 (Nº de promedios).

  3. En el bloque ENTRY, introducir el número de promedios que se desea para la medida y pulsar Enter.

  4. Pulsar F2 (Promediado activado/DESACTIVADO) para activar la función de promediado.

Nota: Pulsar F4 (Reiniciar) para que el analizador tome una nueva serie de barridos para el promediado.


Long Devices

Véase asimismo...

Medidas de dispositivos eléctricamente largos

Descripción general

Conceptos

Cómo medir
dispositivos largos

La frecuencia de una señal procedente de un dispositivo sometido a prueba podrá no ser exactamente igual que la frecuencia del analizador en un momento dado, lo cual puede traducirse en resultados de medida incorrectos.

Se puede elegir una de las tres técnicas disponibles para eliminar esta situación y aumentar la precisión de medida.
Conceptos

Cómo medir con precisión dispositivos eléctricamente largos

La información siguiente puede ayudar a comprender por qué a veces se obtiene resultados de medida incorrectos y cómo se puede subsanar esta situación.
Por qué puede crear resultados incorrectos el retardo del dispositivo
Soluciones para aumentar la precisión de medida

Reducir la velocidad de barrido

Utilizar el barrido por pasos

Añadir longitud eléctrica al canal R

Por qué puede crear resultados incorrectos el retardo del dispositivo

En el gráfico siguiente se muestra un ejemplo de esta situación:

  • En el analizador de redes, la fuente y el receptor están sintonizados en fase y realizan un barrido simultáneamente a lo largo de un recorrido de frecuencias.

  • El flujo de señales a través del dispositivo sometido a prueba se muestra en colores diferentes para distintas frecuencias.

  • Se puede ver cómo a medida que una frecuencia de estímulo se desplaza a través del DUT, el analizador se sintoniza a una nueva frecuencia justo antes de que la señal llegue al receptor. Esto provoca una medida inexacta.

.

Si el analizador está midiendo un cable largo, la frecuencia de la señal en el extremo del cable estará retrasada respecto de la frecuencia de la fuente del analizador de redes. Si el desplazamiento de frecuencia es apreciable en comparación con el ancho de banda de detección de IF del analizador de redes (normalmente, unos pocos kHz), el resultado medido será erróneo debido al desbordamiento del filtro de IF.

Soluciones para aumentar la precisión de medida

Elegir uno de los métodos siguientes para compensar el retardo de un dispositivo eléctricamente largo.
Reducir la velocidad de barrido
Utilizar el barrido por pasos
Añadir longitud eléctrica al canal R

Reducir la velocidad de barrido

Se puede utilizar uno de los siguientes métodos, o todos ellos, para reducir la velocidad de barrido.

  • Aumentar el tiempo de barrido.

  • Reducir el ancho de banda de IF.

  • Incrementar el número de puntos.

Utilizar el barrido por pasos

  • Se puede reducir la velocidad del analizador cambiando del barrido analógico al barrido por pasos, para que la fuente del analizador se detenga paso a paso en cada uno de los puntos de la medida.

  • Se puede ajustar el tiempo (intervalo) que el analizador permanece en cada paso, o punto de la medida.

Añadir longitud eléctrica al canal R

En lugar de reducir la velocidad de barrido, se puede compensar la longitud eléctrica de un cable o dispositivo de pruebas.

  1. Retirar el puente del canal R en el panel frontal del analizador.

  2. Sustituir el puente por un cable que tenga aproximadamente la misma longitud que el dispositivo sometido a prueba.

  3. Ajustar el analizador para realizar un barrido rápido.

Este método compensa los retardos que tienen lugar en las rutas de referencia y de prueba, por lo que en la medida de la transmisión relacionada del analizador de redes no se produce un error de desplazamiento de frecuencia.

Nota: Este método es indicado si el retardo se produce en un cable o un dispositivo de pruebas. Para dispositivos con retardos grandes, este método sólo es adecuado para medidas no calibradas.

Haga clic en los botones para tener acceso a los procedimientos utilizados para compensar dispositivos eléctricamente largos.
Reducir la velocidad de barrido
Utilizar el barrido por pasos
Añadir longitud eléctrica al canal R

Reducir la velocidad de barrido
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Aumentar el tiempo de barrido

  1. En el menú Sweep, hacer clic en Sweep Time.

  2. En el cuadro Sweep Time, introducir el valor o hacer clic en el botón de flecha para seleccionar un valor para el tiempo.

  3. Hacer clic en OK.

Reducir el ancho de banda de IF

  1. En el menú Sweep, hacer clic en IF Bandwidth.

  2. En el cuadro IF Bandwidth, introducir el valor o hacer clic en el botón de flecha para seleccionar un valor para un ancho de banda estrecho.

  3. Hacer clic en OK.

Incrementar el número de puntos

  1. En el menú Sweep, hacer clic en Number of Points.

  2. Seleccionar uno de los valores presentados, o Custom para introducir un valor cualquiera.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

Aumentar el tiempo de barrido

  1. Pulsar Sweep Setup, F1 (Tiempo).

  2. Introducir uno de los valores de velocidad de barrido del bloque ENTRY y pulsar Enter.

Reducir el ancho de banda de IF

  1. Pulsar Sweep Setup, F3 (Ancho de banda).

  2. Introducir uno de los valores de ancho de banda de IF del bloque ENTRY y pulsar Enter.

Incrementar el número de puntos

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. Pulsar F1 (Puntos) y las teclas de flecha hacia arriba y hacia abajo para desplazarse hasta un valor y, a continuación, pulsar Click para seleccionar el valor mostrado. O bien, introducir uno de los valores del bloque ENTRY y pulsar Enter.

Utilizar el barrido por pasos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Sweep Setup.

  2. Hacer clic en la casilla de verificación Stepped Sweep.

  3. En el cuadro Dwell Time, introducir o seleccionar con los botones de flecha el tiempo que se desee que el analizador permanezca en cada punto de la medida.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Stepped Sweep y pulsar Click para seleccionar el modo de barrido por pasos.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Dwell Time y utilizar las teclas de flecha hacia arriba y hacia abajo para introducir el tiempo que se desee que el analizador permanezca en cada punto de la medida. O bien, en el bloque ENTRY, introducir un valor y pulsar Enter.

  4. En el bloque COMMAND, pulsar OK.

Añadir longitud eléctrica al canal R

  1. Obtener un cable cuya longitud sea equivalente a la longitud eléctrica del dispositivo sometido a prueba.

  2. Conectar el cable al canal R a través del panel frontal.

    • Añadir el cable del canal R1 para medidas S11 y S21.

    • Añadir el cable del canal R2 para medidas S22 y S12.

Configuración para medidas S22 y S12.


Phase Accy

Véase asimismo...

Precisión de las medidas de fase

Descripción general

Conceptos

Cómo aumentar
la precisión de fase

Se puede aumentar la precisión de las medidas de fase utilizando diversas funciones del analizador.
Conceptos

Cómo aumentar la precisión de fase

Las siguientes funciones pueden ayudar a realizar medidas de fase precisas.
Retardo eléctrico
Extensiones de puertos
Desviación de fase
Espaciado entre puntos de frecuencia

Retardo eléctrico

  • Utilizar la función de retardo eléctrico para compensar el desplazamiento de fase lineal a través de un dispositivo. Esta función permite examinar únicamente la desviación respecto de la fase lineal del dispositivo.

  • El retardo elétrico es una función matemática que simula una longitud variable de línea de transmisión sin pérdida.

  • Se puede ajustar el retardo eléctrico independientemente para cada traza de la medida.

Extensiones de puertos

  • Utilizar las extensiones de puerto s para mover eléctricamente el plano de referencia de medida después de realizar una calibración. Esto permite evitar tener que realizar otra calibración. Los dos supuestos siguientes muestran cómo pueden ser útiles las extensiones de puertos.

    • Supongamos que ya se ha realizado una calibración y se decide que se necesita añadir una longitud de cable en la configuración de la medida. Se pueden utilizar extensiones de puertos para "informar" al analizador que se ha añadido la longitud de cable a un puerto especificado.

    • Supongamos que no se puede realizar una calibración directamente en el dispositivo porque se encuentra en un dispositivo de pruebas. Se pueden utilizar extensiones de puertos para compensar el retardo (desplazamiento de fase) provocado por el dispositivo de pruebas.

  • Las extensiones de puertos aplican automáticamente un retardo eléctrico a todas las medidas asociadas a un puerto concreto.

  • Se puede añadir longitud eléctrica a los receptores A y B si se están utilizando los conectores de acceso directo del receptor situados en el panel frontal.

Nota: Las extensiones de puertos NO compensan la pérdida ni los errores de desadaptación de los cables, adaptadores y dispositivos de pruebas; sólo compensan la longitud eléctrica añadida.

Desviación de fase

La desviación de f ase ajusta matemáticamente la medida de fase una cantidad especificada, hasta 360°. Esta función se puede utilizar de las siguientes maneras:

  • Mejorar la presentación de una medida de fase. Esto es similar a la manera en que se cambiaría el nivel de referencia en una medida de amplitud. Cambiar la respuesta de fase para centrar o alinear la respuesta en la pantalla.

  • Emular un desplazamiento de fase proyectado en la medida. Por ejemplo, si se sabe que es necesario añadir un cable y que la longitud de ese cable añadirá un determinado desplazamiento de fase a la medida, se podrá utilizar la desviación de fase para añadir esa cantidad y simular la medida completa del dispositivo.

Espaciado entre puntos de frecuencia

  • El analizador muestrea los datos a puntos de frecuencia discretos y, a continuación, une los puntos, creando una traza en la pantalla.

  • Si el desplazamiento de fase a través de un dispositivo es >180° entre puntos de frecuencia adyacentes, la presentación podrá dar la impresión de que la pendiente de fase está invertida. Esto se debe a que los datos están muestreados insuficientemente y está ocurriendo un solapamiento.

Si se está midiendo el retardo de grupo y la pendiente de la fase está invertida, cambiará el signo del retardo de grupo. Por ejemplo, en el siguiente gráfico se muestra una medida de un filtro de paso de banda SAW.

  • La primera medida tiene 51 puntos e indica que el retardo de grupo es negativo, lo cual es imposible físicamente. Es decir, la respuesta está por debajo de la línea de referencia de 0 segundos.

  • La segunda medida muestra un incremento hasta 201 puntos, lo cual indica que el retardo de grupo es positivo. Es decir, la respuesta está por encima de la línea de referencia de 0 segundos.

Sugerencia:

  • Para comprobar si se está produciendo un solapamiento en una medida, reducir el espaciado entre los puntos de frecuencia y ver si cambian los datos en la pantalla del analizador. Si está ocurriendo un solapamiento, se podrá incrementar el número de puntos o reducir el recorrido de frecuencias.

Haga clic en los botones para acceder a los procedimientos utilizados para aumentar la precisión de las medidas de fase.
Compensar el desplazamiento de fase lineal
Mover eléctricamente el plano de referencia
Desviar la fase medida
Comprobar si existe solapamiento

Compensar el desplazamiento de fase lineal
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Scale , hacer clic en Electrical Delay.

  2. En el cuadro Electrical Delay, introducir el valor o hacer clic en el botón de flecha para seleccionar el valor deseado.

  3. En el cuadro Velocity Factor, introducir el valor o hacer clic en el botón de flecha para seleccionar un valor comprendido entre 0 y 1,0. Es el valor del factor de velocidad del medio para el dispositivo que se está midiendo.

  • 1,0 corresponde a la velocidad de la luz en un vacío

  • 0,66 corresponde a la velocidad típica de la luz en dieléctricos de polietileno

  • 0,70 corresponde a la velocidad típica de la luz en dieléctricos de Teflon

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Scale y desplazarse hasta Electrical Delay. Pulsar Click.

  2. En el cuadro Electrical Delay, introducir uno de los valores del bloque ENTRY y pulsar Enter, o bien pulsar las teclas de flecha hacia arriba y hacia abajo para seleccionar el valor deseado. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Velocity Factor.

  4. En la casilla Velocity Factor, introducir uno de los valores del bloque ENTRY, o bien pulsar la tecla de flecha hacia abajo para seleccionar el valor deseado y, a continuación, pulsar Click. Seleccionar un valor comprendido entre 0 y 1,0. Es el valor del factor de velocidad del medio para el dispositivo que se está midiendo.

  • 1,0 corresponde a la velocidad de la luz en un vacío

  • 0,66 corresponde a la velocidad típica de la luz en dieléctricos de polietileno

  • 0,70 corresponde a la velocidad típica de la luz en dieléctricos de Teflon

Mover eléctricamente el plano de referencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Calibration, hacer clic en Port Extensions.

  2. Seleccionar la casilla de verificación Port Extensions.

  3. Añadir el valor de extensión para el puerto en el que se desea extender el plano de referencia .

  4. En el cuadro Velocity Factor seleccionar un valor comprendido entre 0 y 1,0 para el factor de velocidad del medio del cable o dispositivo que se ha añadido después de realizar una calibración. A continuación, hacer clic en OK.

  • 1,0 corresponde a la velocidad de la luz en un vacío

  • 0,66 corresponde a la velocidad típica de la luz en dieléctricos de polietileno

  • 0,70 corresponde a la velocidad típica de la luz en dieléctricos de Teflon

Sugerencia:

Para saber cuándo se ha añadido suficiente retardo:

  1. Conectar un circuito cerrado en lugar del dispositivo.

  2. Ajustar la extensión del puerto hasta que la respuesta de fase sea plana.

Nota: La mayoría de los patrones de calibración de circuito cerrado tienen un retardo distinto de cero. Por consiguiente, al ajustar el retardo con este método se produce un error de retardo igual a dos veces el retardo del circuito cerrado. Determinar el retardo de desplazamiento del circuito cerrado de calibración examinando la definición del patrón.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para desplazarse al menú Calibration y desplazarse hasta Port Extensions. Pulsar Click.

  3. Pulsar Click para seleccionar la casilla de verificación Port Extensions .

  4. Pulsar la tecla de tabulador a la derecha para desplazarse al cuadro correspondiente a la entrada o el puerto en el que se desea extender el plano de referencia . Introducir un valor y pulsar Enter .

  5. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Velocity Factor .

  6. En la casilla Velocity Factor, utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar un valor comprendido entre 0 y 1,0 para el factor de velocidad del medio del cable o dispositivo que se ha añadido después de realizar una calibración. Pulsar OK.

  • 1,0 corresponde a la velocidad de la luz en un vacío

  • 0,66 corresponde a la velocidad típica de la luz en dieléctricos de polietileno

  • 0,70 corresponde a la velocidad típica de la luz en dieléctricos de Teflon

Sugerencia:

Para saber cuándo se ha añadido suficiente retardo:

  1. Conectar un circuito cerrado en lugar del dispositivo.

  2. Ajustar la extensión del puerto hasta que la respuesta de fase sea plana.

Nota: La mayoría de los patrones de calibración de circuito cerrado tienen un retardo distinto de cero. Por consiguiente, al ajustar el retardo con este método se produce un error de retardo igual a dos veces el retardo del circuito cerrado. Determinar el retardo de desplazamiento del circuito cerrado de calibración examinando la definición del patrón.

Desviar la fase medida
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Scale, hacer clic en Phase Offset.

  2. En el cuadro Phase Offset, introducir el valor o hacer clic en el botón de flecha para seleccionar el valor deseado.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para desplazarse al menú Scale y desplazarse hasta Phase Offset. Pulsar Click.

  3. En la casilla Phase Offset, introducir uno de los valores del bloque ENTRY y pulsar Enter, o bien pulsar las teclas de flecha hacia arriba y hacia abajo para seleccionar el valor deseado. Pulsar Enter, OK.

Comprobar si existe solapamiento
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Number of Points.

  2. Seleccionar uno de los valores presentados, o Custom para introducir un valor cualquiera desde el teclado o el bloque ENTRY que reduzca el valor actual.

  3. Hacer clic en OK.

    Si los datos mostrados cambian, incrementar el número de puntos o reducir el recorrido de frecuencias.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. Pulsar F2 (Puntos).

  3. En el bloque NAVIGATION, pulsar las teclas de flecha hacia arriba o hacia abajo para reducir el valor y, a continuación, pulsar Click para seleccionar el valor mostrado.

    Si los datos mostrados cambian, incrementar el número de puntos o reducir el recorrido de frecuencias.


Trce Noise

Véase asimismo...

Ruido de trazas

Descripción general

Conceptos

Cómo reducir el
ruido de trazas

Se pueden utilizar funciones del analizador para reducir el ruido en la traza de la medida.
Conceptos

Cómo reducir el ruido de trazas

Se pueden utilizar las siguientes funciones del analizador para reducir el efecto del ruido en la traza de datos.
Promedios de barridos

Suavizado de trazas

Ancho de banda de IF

Promedios de barridos

  • El promedio de barridos es un proceso que reduce los efectos del ruido aleatorio en una medida.

  • El analizador calcula cada punto de datos en función del promedio de barridos consecutivos ponderados mediante un factor de promediado especificado por el usuario.

  • Cada nuevo barrido se añade al promedio de trazas hasta que el número total de barridos es igual al factor de promediado.

  • Cuanto mayor sea el número de promedios (factor de promediado), mayores serán el grado de reducción del ruido y el m argen dinámico.

  • Para la reducción del ruido, la aplicación de promedios de barridos tiene el mismo efecto que la reducción del ancho de banda de IF.

Efecto de los promedios de barridos

Suavizado de trazas

Se puede aplicar el suavizado para reducir valores relativamente pequeños de ruido entre picos en datos medidos en banda ancha. Para ello, el analizador promedia los datos del canal activo en una parte (apertura de suavizado) de la traza mostrada.

Sugerencias:

  • Utilizar un número de puntos de pantalla suficientemente elevado para evitar resultados engañosos.

  • No utilizar el suavizado para dispositivos de alta resonancia, o dispositivos con grandes variaciones de trazas, ya que podría introducir errores de medida.

  • Se puede ajustar la función de suavizado independientemente para cada traza.

Efectos del suavizado en una traza

Ancho de banda de IF

  • Al reducir el ancho de banda de IF del receptor se reduce el efecto del ruido aleatorio en una medida. Cada vez que se reduce 10 veces el ancho de banda de IF se reduce el límite inferior del ruido en 10 dB. Sin embargo, los anchos de banda de IF más estrechos alargan los tiempos de barrido.

  • El analizador de redes convierte la señal recibida de su frecuencia de RF/microondas a una frecuencia intermedia, o IF, más baja a 41,67 kHz. El ancho de banda del filtro de paso de banda de IF, o ancho de banda de IF, se puede ajustar desde 40 kHz hasta un mínimo de 1 Hz.

  • El ancho de banda de IF se puede ajustar independientemente para cada canal o cada segmento de un barrido de segmentos.

Efecto de la reducción del ancho de banda de IF

Haga clic en los botones para acceder a los procedimientos de reducción del ruido de traza.
Aplicar o cambiar los promedios de barridos
Aplicar el suavizado de trazas
Reducir el ancho de banda de IF

Aplicar o cambiar los promedios de barridos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Average.

  2. Si la función de promediado todavía no está activada, seleccionar la casilla de verificación Average On.

  3. En el cuadro Average Factor, incrementar el valor al número de promedios que se desee que tome el analizador para la medida.

  4. Hacer clic en OK.

Nota: Hacer clic en Channel, Restart Average para que el analizador tome una nueva serie de barridos para promediarlos.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Average.

  2. Si la función de promediado todavía no está activada, pulsar F2 (Promediado ACTIVADO/DESACTIVADO) para activar la función de promediado.

  3. Pulsar F1 (Nº de promedios).

  4. En el bloque ENTRY, introducir el número de promedios que se desea para la medida y pulsar Enter.

Nota: Pulsar F4 (Reiniciar) para que el analizador tome una nueva serie de barridos para promediarlos.

Aplicar el suavizado de trazas
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Smoothing.

  2. Si la función de suavizado todavía no está activada, seleccionar la casilla de verificación Smoothing ON.

  3. Elegir cómo se desea especificar el valor de la apertura de suavizado:

    • En el cuadro Percent of Span, introducir un valor para el porcentaje de suavizado. (El valor máximo es el 25%.)

    • En el cuadro Points, introducir un valor para el número de puntos que abarcará el suavizado. (El valor máximo es el 25% del número total de puntos definidos para el barrido de la medida.)

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Trace y desplazarse hasta Smoothing, y pulsar Click.

  3. Si la función de suavizado no está activada, pulsar Click para seleccionar la casilla de verificación Smoothing ON.

  4. Pulsar la tecla de tabulador a la derecha para elegir cómo se desea especificar el valor de la apertura de suavizado:

    • En el cuadro Percent of Span, introducir un valor para el porcentaje de suavizado. (El valor máximo es el 25%.)

    • En el cuadro Points, introducir un valor para el número de puntos que abarcará el suavizado. (El valor máximo es el 25% del número total de puntos definidos para el barrido de la medida.)

  5. En el bloque COMMAND, pulsar OK.

Reducir el ancho de banda de IF
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en IF Bandwidth.

  2. En el cuadro IF Bandwidth, hacer clic en el botón de flecha o introducir un valor para un ancho de banda estrecho.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL, pulsar Sweep Setup.

  2. En el bloque NAVIGATION, pulsar F3 (Ancho de banda).

  3. En el bloque ENTRY, introducir el valor del ancho de banda de IF y pulsar Enter.


Fast Swp

Véase asimismo...

Velocidad de barrido

Descripción general

Conceptos

Cómo realizar el
barrido más rápido

El mantenimiento del barrido de medida más rápido es un aspecto que influye en la consecución del mayor rendimiento de medida.
Conceptos

Cómo realizar el barrido más rápido

Se puede conseguir que el analizador realice el barrido más rápido para una aplicación de medida ajustando lo siguiente.
Parámetros de barrido
Parámetros de reducción de ruido
Elección de calibración de medidas
Funciones innecesarias

Parámetros de barrido

Debe considerarse la posibilidad de cambiar cada uno de los parámetros siguientes de la manera recomendada.

  • Recorrido de frecuencias. Medir únicamente las frecuencias que sean necesarias para el dispositivo.

  • Barrido de segmentos. Utilizar segmentos para enfocar los datos de prueba únicamente donde se necesiten.

  • Desactivar el barrido por pasos. Utilizar el modo de barrido lineal para reducir el tiempo de barrido siempre que sea posible.

  • Tiempo de barrido automático. Utilizar este valor por defecto para realizar el barrido a la máxima velocidad posible para los parámetros actuales.

  • Número de puntos. Utilizar el mínimo número de puntos necesarios para la medida.

Número de puntos | Tiempo de ciclo (ms)*
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 55

*Estado del instrumento: condición preajustada, ancho de banda de 35 kHz, CF = 1 GHz, recorrido = 100 MHz, corrección desactivada. Añadir 21 ms para pantalla encendida. El tiempo de ciclo incluye el tiempo de barrido y el tiempo de retorno.

Para obtener más información sobre la manera en que el número de puntos y otros parámetros afectan al tiempo de ciclo, véase Comprensión de las especificaciones técnicas.

Parámetros de reducción de ruido

Utilizando una combinación de estos parámetros se podrá reducir el tiempo de barrido y conseguir al mismo tiempo una medida aceptable.

  • Ancho de banda de IF. Utilizar el ancho de banda de IF más amplio que produzca un nivel aceptable de ruido de traza y de m argen dinámico.

  • Promediado Reducir el factor de promediado, o desactivar la función de promediado.

Elección de calibración de medidas

  • Elegir el tipo de calibración más rápido para el nivel de precisión necesario.

    • La velocidad de barrido es aproximadamente la misma para medidas no corregidas y para medidas realizadas utilizando una calibración de la respuesta, o una calibración de un puerto.

    • Una calibración completa de dos puertos necesita barridos en dirección tanto de avance como de retroceso con el fin de actualizar los cuatro parámetros S para la corrección de errores, aunque sólo aparezca un parámetro S.

Véase Calibración de medida para obtener más detalles.

Funciones innecesarias

El analizador debe actualizar información para todas las funciones activas. Para conseguir un aumento adicional de la velocidad de barrido, desactivar todas las funciones del analizador que no sean necesarias para la aplicación de medida.

  • Trazas no utilizadas

  • Marcadores no utilizados

  • Suavizado

  • Pruebas de límites

  • Funciones matemáticas de trazas

  • Pantalla

La velocidad de barrido del analizador depende de diversos parámetros de medida. Conviene experimentar con los parámetros para conseguir el barrido más rápido y los resultados de medida necesarios.
Cambiar los parámetros de barrido
Cambiar los parámetros de reducción de ruido
Desactivar las funciones innecesarias
Elegir una calibración rápida

Cambiar los parámetros de barrido
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Cambiar el recorrido de la medida

  1. Acceder a los parámetros de estímulo de barrido:

    • En el menú Channel, hacer clic en Start/Stop o Center/Span para un barrido de frecuencia.

    • En el menú Channel, hacer clic en Power para un barrido de potencia.

  2. En el cuadro Start (Center), introducir el valor o hacer clic en el botón de flecha para seleccionar un valor que reduzca el recorrido.

  3. En el cuadro Stop (Span), introducir el valor o hacer clic en el botón de flecha para seleccionar un valor que reduzca el recorrido.

  4. Hacer clic en OK.

  5. Véase Barrido de segmentos para cambiar el tipo de barrido.

Desactivar el modo de barrido por pasos

  1. En el menú Sweep, hacer clic en Sweep Setup.

  2. Hacer clic en la casilla Stepped Sweep para desactivarla y, a continuación, hacer clic en OK.

Cambiar a tiempo de barrido automático

  1. En el menú Sweep, hacer clic en Sweep Time.

  2. Hacer clic en el botón de flecha hacia abajo hasta que el valor sea el menor posible y, a continuación, hacer clic en OK.

Cambiar el número de puntos

  1. En el menú Sweep, hacer clic en Number of Points.

  2. Seleccionar uno de los valores presentados, o Customize para seleccionar un valor cualquiera.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

Cambiar el recorrido de frecuencias

  1. Acceder a los parámetros de estímulo de barrido:

    • En el bloque CHANNEL SETUP, pulsar Start/Center, F1 (Inicio) o F3 (Centro) para un barrido de frecuencia.

    • En el bloque CHANNEL SETUP, pulsar Power, F1 (Inicio) para un barrido de potencia.

  2. En el cuadro Active Entry, introducir uno de los valores del bloque ENTRY y pulsar Enter.

  3. Pulsar F2 (Parada) o F4 (Recorrido), introducir uno de los valores del bloque ENTRY y pulsar Enter.

  4. Véase Barrido de segmentos para cambiar el tipo de barrido.

Desactivar el modo de barrido por pasos

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  3. Si la casilla Stepped Sweep está seleccionada, pulsar la tecla de tabulador a la derecha para pasar a la casilla Stepped Sweep, y seguidamente pulsar Click para desactivar la casilla de verificación.

  4. En el bloque COMMAND, pulsar OK.

Cambiar a tiempo de barrido automático

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. Pulsar F1 (Tiempo) y, a continuación, en el bloque ENTRY, pulsar 0, Enter.

Cambiar el número de puntos

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. Pulsar F2 (Puntos).

  3. En el bloque NAVIGATION, pulsar la tecla de flecha hacia arriba o hacia abajo para desplazarse por una lista de valores y, a continuación, pulsar Click para seleccionar el valor mostrado. O bien, introducir uno de los valores del bloque ENTRY y pulsar Enter.

Cambiar los parámetros de reducción de ruido
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Cambiar el ancho de banda de IF

  1. En el menú Sweep, hacer clic en IF Bandwidth.

  2. En el cuadro IF Bandwidth, introducir el valor o hacer clic en el botón de flecha para seleccionar un valor para un ancho de banda amplio.

  3. Hacer clic en OK.

Cambiar el factor de promediado

  4. En el menú Channel, hacer clic en Average.

  5. En el cuadro Average Factor, reducir el valor al número de promedios que se desee que tome el analizador para la medida.

    • O bien, desactivar la función de promediado haciendo clic en la casilla Average On para desactivar la casilla de verificación.

  6. Hacer clic en OK.

Nota: Hacer clic en Channel, Restart Average para que el analizador tome una nueva serie de barridos para promediarlos.

Procedimiento con las teclas del panel frontal

Cambiar el ancho de banda de IF

  1. Pulsar Sweep Setup, F3 (Ancho de banda de IF).

  2. Introducir el valor del ancho de banda de IF para ampliar el ancho de banda de IF.

  3. En el bloque ENTRY, pulsar Enter.

Cambiar el factor de promediado

  4. En el bloque CHANNEL SETUP, pulsar Average.

  5. Pulsar F1 (Nº de promedios) e introducir un número para reducir los promedios, y pulsar Enter.

    • O bien, pulsar F2 (Promediado ACTIVADO/DESACTIVADO) para desactivar la función de promediado.

Nota: Pulsar F4 (Reiniciar) para que el analizador tome una nueva serie de barridos para promediarlos.

Desactivar las funciones innecesarias
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Eliminar trazas no deseadas

  1. Hacer clic en la barra de estado de trazas para activar una traza innecesaria.

  2. En el menú Trace, hacer clic en Delete Trace.

Desactivar marcadores no deseados

  1. En el menú Marker, hacer clic en Select Marker y hacer clic en un marcador no deseado que aparezca en la lista.

    • Si se desea desactivar todos los marcadores, hacer clic en All Off.

  2. Si no aparece la barra de herramientas de marcadores, en el menú View, hacer clic en Toolbars y señalar y hacer clic en Marker.

  3. Hacer clic en la casilla de verificación On para desactivarla.

Desactivar el suavizado

  1. En el menú Trace, hacer clic en Smoothing.

  2. Hacer clic en la casilla de verificación Smoothing On para desactivarla y desactivar así la función de suavizado. Hacer clic en OK.

Desactivar las pruebas de límites

  1. En el menú Trace, hacer clic en Limit Test.

  2. Hacer clic en la casilla de verificación Limit Test ON para desactivarla y desactivar así la función de límites. Hacer clic en OK.

Desactivar las funciones matemáticas

  • En el menú Trace, señalar con el cursor la lista Data Math y hacer clic en Data para mostrar únicamente la traza de la medida actual.

Procedimiento con las teclas del panel frontal

Eliminar trazas no deseadas

  1. Si en la pantalla aparecen varias ventanas, realizar el paso siguiente.

    • En el bloque DISPLAY, pulsar Window, F2 (Ventana siguiente) hasta que la ventana que contiene la traza no deseada aparezca seleccionada.

  2. En el bloque DISPLAY, pulsar Trace, F2 (Traza siguiente) hasta que la traza innecesaria esté activa.

  3. Pulsar F4 (Eliminar).

Desactivar marcadores no deseados

  1. En el bloque TRACE SETUP, pulsar Marker.

  2. Seleccionar el marcador que se desee desactivar pulsando F1 o F2 o F3 (Marcador 1, Marcador 2, Marcador 3). Pulsar Marker de nuevo para mostrar más marcadores.

  3. A continuación, pulsar F4 (Desactivado).

  4. Si se desea desactivar todos los marcadores, realizar el paso siguiente.

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Marker y desplazarse hasta All Off. Pulsar Click.

Desactivar el suavizado

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Trace y desplazarse hasta Smoothing. Pulsar Click, Click.

  3. En el bloque COMMAND, pulsar OK.

Desactivar las pruebas de límites

  • En el bloque TRACE SETUP, pulsar Limit Table, F1 (Prueba ACTIVADA/DESACTIVADA).

Desactivar las funciones matemáticas

  • En el bloque TRACE SETUP, pulsar Math/Memory, F3 (Sólo datos) para mostrar únicamente la traza de la medida actual.

Elegir una calibración rápida
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Calibration, hacer clic en Calibration Wizard, Cal Type.

  2. Seleccionar una de las siguientes calibraciones: OPEN Response, SHORT Response, THRU Responseo 1-Port y, a continuación, hacer clic en OK.

  3. Hacer clic en Measure Stds... y seguir las indicaciones mostradas por el asistente.

Para obtener más información, véase el apartado Seleccionar y realizar una calibración.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Cal, F1 (Asistente para calibración).

  2. En el bloque NAVIGATION, pulsar las teclas de flecha y Click para seleccionar una de las siguientes calibraciones: OPEN Response, SHORT Response, THRU Responseo 1-Port.

  3. En el bloque COMMAND, pulsar OK.

  4. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para seleccionar Measure Stds... y, a continuación, pulsar Click.

  5. Seguir las indicaciones mostradas por el asistente Calibration Wizard.

Para obtener más información, véase el apartado Seleccionar y realizar una calibración.


Mult Meas

Véase asimismo...

Medidas múltiples

Descripción general

Conceptos

Cómo realizar medidas múltiples
con mayor rapidez

Si es necesario realizar medidas múltiples para caracterizar un dispositivo, se podrán utilizar diversos métodos para aumentar el rendimiento.
Conceptos

Cómo realizar medidas múltiples con mayor rapidez

Conviene experimentar con estos métodos para determinar cuál es el más indicado para las necesidades de la aplicación de medida concreta.
Configurar medidas para aumentar el rendimiento

Organizar medidas en conjuntos

Utilizar el barrido de segmentos

Activar las medidas selectivamente
Automatizar los cambios entre medidas
Recuperar las medidas rápidamente

Configurar medidas para aumentar el rendimiento

Para conseguir un rendimiento óptimo con dispositivos que precisan múltiples medidas, resulta útil conocer cómo funciona el analizador. Este conocimiento permitirá configurar los supuestos de medida más indicados para las aplicaciones concretas. Las medidas se pueden organizar en cualquier combinación, utilizando los siguientes módulos.

  • De 1 a 4 canales de medida independientes

  • De 1 a 4 trazas por ventana

  • De 1 a 4 ventanas por pantalla

  • De 1 a 16 trazas de medida por pantalla

  • De 1 a 16 trazas de memoria por pantalla

Un Canal tiene una serie de atributos independientes asociados a la recogida de datos.

Una Traza tiene una serie única de atributos asociados a las operaciones matemáticas realizadas con los datos recogidos.

Una Ventana se utiliza para visualizar trazas.

Organizar medidas en conjuntos

Si se organizan las medidas para mantener el conjunto completo de medidas de un dispositivo en un estado de instrumento, se podrán guardar para poder recuperar más adelante una serie de medidas con una función de recuperación. Véase Trazas y canales múltiples para obtener más información.

Cuando se recopilen los conjuntos de medidas, deberá tenerse en cuenta que es posible hacer lo siguiente:

  • Visualizar trazas de canales múltiples en una ventana.

  • Visualizar trazas de canales múltiples en múltiples ventanas.

Utilizar el barrido de segmentos

El barrido de segmentos resulta útil si se necesita cambiar los siguientes parámetros para caracterizar un dispositivo sometido a prueba.

  • Margen de frecuencias

  • Nivel de potencia

  • An cho de banda de IF

  • Número de puntos

El barrido de segmentos permite definir un conjunto de márgenes de frecuencias que tienen atributos independientes. Esto permite utilizar un barrido de medida para medir un dispositivo que tenga características variables. Véase Barrido de segmentos para obtener más información.

Activar las medidas selectivamente

Se puede utilizar la activación de medidas para realizar medidas de la siguiente manera:

  • Actualizar continuamente sólo aquellas medidas cuyos datos cambien rápidamente.

  • Actualizar ocasionalmente aquellas medidas cuyos datos cambien raramente.

Por ejemplo, si se tuviesen cuatro canales configurados de la siguiente manera:

  • dos canales para medir los datos utilizados para sintonizar un filtro.

  • dos canales para medir los datos de las respuestas fuera de banda del filtro.

se desearía monitorizar constantemente sólo los datos de medida utilizados para sintonizar el filtro. Si se actualizasen continuamente todos los canales, esto podría ralentizar la respuesta del analizador y no sería posible sintonizar el filtro con la misma eficacia.

Nota: Se debe activar la medida poco frecuente manualmente o con comandos de interfaz remotos.

Automatizar los cambios entre medidas

Si hay ligeras diferencias entre las diversas medidas necesarias para caracterizar un dispositivo, podrá resultar más rápido cambiar los parámetros de medida utilizando la automatización.

Recuperar las medidas rápidamente

  • La manera más eficaz de recuperar medidas consiste en recuperarlas como un conjunto de medidas (estado de instrumento).

  • La recuperación de un estado de instrumento que incluya múltiples medidas sólo lleva algo más de tiempo que la recuperación de un estado de instrumento que sólo incluya una medida.

  • Cada función de recuperación tiene un tiempo asociado a la misma. Se puede eliminar ese tiempo configurando las medidas como un conjunto para poder recuperarlas como un conjunto.

Haga clic en los botones para tener acceso a los procedimientos utilizados para aumentar el rendimiento de dispositivos que necesitan medidas múltiples.
Organizar medidas en conjuntos
Utilizar el barrido de segmentos
Activar las medidas selectivamente
Automatizar los cambios entre medidas

Organizar medidas en conjuntos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Window, hacer clic en Meas Setups y hacer clic en una de las selecciones de configuración:

    • Setup A: configura el analizador con los cuatro parámetros S en un canal, mostrado en una ventana con el formato de magnitud logarítmica.

    • Setup B: configura el analizador con los cuatro parámetros S en un canal, mostrando cada parámetro en una ventana independiente con el formato de magnitud logarítmica.

    • Setup C: configura el analizador con tres parámetros S (S11, S22, S21) en un canal, mostrando cada parámetro en una ventana independientemente con los parámetros S 11 y S22 en un diagrama de Smith y el parámetro S21 en el formato de magnitud logarítmica.

    • Setup D: configura el analizador con dos canales, cada uno con los parámetros S21 y S11, de manera que cada canal se muestre en una ventana independiente con el formato de magnitud logarítmica.

  2. Modificar los parámetros para adaptarlos a las necesidades de medida.

Para obtener más información, véase Seleccionar un estado de medida.

Procedimiento con las teclas del panel frontal

  1. En el bloque DISPLAY, pulsar Measure Setups y pulsar una de las teclas correspondientes a las selecciones de Active Entry (F1, F2, F3, F4) para configurar un conjunto de medidas:

    • Setup A: 1 canal, 4 parámetros S, magnitud logarítmica, 1 ventana

    • Setup B: 1 canal, 4 parámetros S, magnitud logarítmica, 4 ventanas

    • Setup C: 1 canal, 3 parámetros S, diagrama de Smith y magnitud logarítmica, 3 ventanas

    • Setup D: 2 canales, 2 parámetros S (4 trazas), magnitud logarítmica, 2 ventanas

  2. Modificar los parámetros para adaptarlos a las necesidades de medida.

Para obtener más información, véase Seleccionar un estado de medida.

Activar las medidas selectivamente

Este procedimiento muestra cómo configurar dos medidas diferentes con el comportamiento siguiente:

  • Una medida actualiza continuamente los datos.

  • Otra medida actualiza ocasionalmente los datos.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Window, hacer clic en Meas Setups, Setup D.

  2. Modificar los parámetros para adaptarlos a las necesidades de medida, utilizando el Canal 1 como la medida que actualiza continuamente y el Canal 2 como la medida que actualiza ocasionalmente.

Configurar una activación de medidas para actualizaciones continuas

  3. En el menú Sweep, hacer clic en Trigger, Trigger....

  4. Bajo Trigger Source, hacer clic en Internal.

  5. Bajo Channel Trigger State, seleccionar Channel 1 y hacer clic en Continuous.

Configurar una activación de medidas para actualizaciones ocasionales

  6. Bajo Channel Trigger State, seleccionar Channel 2 y hacer clic en Single, OK.

    • Si se desea que el analizador active más de un único barrido, hacer clic en la casilla de verificación Enable Groups e introducir el número de barridos.

  7. En el menú System, hacer clic en Keys, Trigger.

Actualizar la medida

  8. Hacer clic en la ventana inferior para convertir el Canal 2 en el canal activo.

  9. En la barra de herramientas Active Entry, hacer clic en el tipo de activación configurado.

    • Hacer clic en Single si se ha configurado el analizador para realizar un único barrido por activación.

    • Hacer clic en Groups si se han configurado barridos múltiples por activación.

Nota: Tiene que haber una traza activa para poder iniciar una activación para esa medida.

Procedimiento con las teclas del panel frontal

  1. En el bloque DISPLAY, pulsar Measure Setups, F4 (Configuración D).

  2. Modificar los parámetros para adaptarlos a las necesidades de medida, utilizando el Canal 1 como la medida que actualiza continuamente y el Canal 2 como la medida que actualiza ocasionalmente.

Configurar una activación de medidas para actualizaciones continuas

  4. En el bloque CHANNEL SETUP, pulsar Channel, F1 (Canal 1).

  5. Pulsar Trigger, F1 (Continuo).

Configurar una activación de medidas para actualizaciones ocasionales

  6. En el bloque CHANNEL SETUP, pulsar Channel, F2 (Canal 2).

  7. Pulsar Trigger, F2 (único).

  8. Si se desea que el analizador active más de un único barrido, realizar este paso:

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque CHANNEL SETUP, pulsar Trigger.

    3. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Enable Groups y pulsar Click.

    4. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Enable Groups e introducir el número de barridos.

    5. En el bloque COMMAND, pulsar OK.

    6. Para activar el conjunto de medidas, pulsar Trigger, F1 (Grupos).

Actualizar la medida

  6. En el bloque CHANNEL SETUP, pulsar Channel, F2 (Canal 2), Trigger.

  10. En la barra de herramientas Active Entry, hacer clic en el tipo de activación configurado.

    • Hacer clic en F2 (único) si se ha configurado el analizador para realizar un único barrido por activación.

    • Hacer clic en F1 (Grupos) si se han configurado barridos múltiples por activación.


Data Trnsfr

Véase asimismo...

Velocidad de transferencia de datos

Descripción general

Conceptos

Cómo aumentar la velocidad
de transferencia de datos

La transferencia de datos más rápida ayuda a conseguir el mejor rendimiento de medida.
Conceptos

Cómo aumentar la velocidad de transferencia de datos

Pueden probarse estos métodos para mejorar la velocidad de transferencia de datos.

  • Utilizar el modo de barrido único para asegurar que haya finalizado una medida antes de iniciar una transferencia de datos.

  • Transferir la cantidad de datos mínima necesaria. Por ejemplo, una traza con pocos puntos, utilizando el barrido de segmentos en lugar de una traza completa con muchos puntos espaciados linealmente. Asimismo, utilizar marcadores en lugar de transferencias de trazas.

  • Utilizar el formato de datos REAL para obtener la velocidad de transferencia más rápida al utilizar programas SCPI para aplicaciones automatizadas.

  • Utilizar SCPI a través de LAN para aplicaciones que se hayan automatizado con programas SCPI.

  • Utilizar programas COM para obtener la velocidad de transferencia más rápida al utilizar una aplicación automatizada. Véase Tiempo de transferencia de datos.

Haga clic en los botones para ver los procedimientos.
Utilizar el modo de barrido único
Transferir una cantidad de datos mínima utilizando el barrido de segmentos

Utilizar el modo de barrido único

Haga clic en los botones para acceder a los procedimientos.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Trigger, Trigger....

  2. Bajo Trigger Source, hacer clic en Manual.

  3. Bajo Channel Trigger State, seleccionar el canal para la medida que se desee transferir y, a continuación, hacer clic en Continuous, OK.

Para actualizar la medida

  4. En el menú System, hacer clic en Keys, Trigger .

  5. En la barra de herramientas Active Entry, hacer clic en Single.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Channel y, a continuación, la tecla de Active Entry ( F1, F2, F3, F4) para el canal que contiene la medida que se desea transferir.

  2. Pulsar Trigger, F2 (único).

Para actualizar la medida del Canal 2

  8. En el bloque CHANNEL SETUP, pulsar Trigger, F4 (Reiniciar).


Calibración de medidas

Véase asimismo...

Descripción general de la calibración de medidas

Descripción general

Conceptos

Cómo realizar una calibración

La calibración de medidas es el proceso consistente en caracterizar términos de error sistemáticos midiendo patrones de calibración conocidos y, a continuación, eliminar los efectos de estos errores de medidas ulteriores. La calibración mejora la precisión del analizador al reducir los errores de medida.
Conceptos

Cómo realizar una calibración

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿En qué consiste la calibración de medidas?
¿Por qué es necesaria la calibración?
Condiciones en las que se recomienda la calibración

¿En qué consiste la calibración de medidas?

  • La calibración elimina uno o más errores sistemáticos utilizando una ecuación que se denomina modelo de errores. La medida de patrones de alta calidad (por ejemplo, un circuito cerrado, un circuito abierto, una carga y un cable pasivo) permite al analizador resolver los términos de error en el modelo de errores. Para obtener más información sobre los errores sistemáticos, véase Errores de medidas.

  • Se pueden elegir diferentes métodos de calibración, dependiendo del tipo de medida que se desee realizar y del nivel de precisión que se necesite para la medida.

  • La precisión de las medidas calibradas depende de la calidad de los patrones contenidos en el kit de calibración y de la exactitud con que se hayan modelado (definido) los patrones en el archivo de definición del kit de calibración. El archivo de definición del kit de calibración está almacenado en el analizador. Para poder realizar medidas exactas, la definición del kit de calibración debe coincidir con el kit de calibración real utilizado.

  • Si se opta por crear patrones de calibración personalizados (por ejemplo, durante medidas en el interior del dispositivo), deberán caracterizarse los patrones de calibración e introducirse la definición en un archivo de kit de calibración modificado por el usuario. Para obtener más información acerca de la manera de modificar los archivos de kits de calibración, véase Patrones de calibración.

Para obtener más información sobre las opciones y los procedimientos de calibración, véase el apartado Seleccionar y realizar una calibración de medida.

¿Por qué es necesaria la calibración?

  • Es imposible construir hardware perfecto que no necesite ninguna forma de c orrección de errores. Aunque el hardware fuese lo suficientemente bueno como para eliminar la necesidad de la corrección de errores, sería sumamente costoso para la mayoría de los dispositivos.

  • La precisión del análisis de redes se ve afectada en gran medida por factores externos al analizador de redes. Los componentes de la configuración de la medida, como los cables de interconexión y adaptadores, introducen variaciones en la magnitud y la fase que pueden enmascarar la respuesta real del dispositivo sometido a prueba.

  • La mejor alternativa consiste en construir el hardware de la mejor manera posible, compensando el rendimiento y el coste. La calibración se convierte entonces en una herramienta muy útil para mejorar la exactitud de las medidas.

Condiciones en las que se recomienda la calibración

  • Se desea la mayor precisión posible.

  • Se está adaptando la medida a un tipo de conector diferente o una impedancia distinta.

  • Se está conectando un cable entre el dispositivo de prueba y un puerto de prueba del analizador.

  • Se está realizando una medida a través de un recorrido de frecuencias amplio o de un dispositivo eléctricamente largo.

  • Se está conectando un atenuador u otro dispositivo similar a la entrada o salida del dispositivo de prueba.

Si la configuración de prueba cumple cualquiera de estas condiciones, podrán verse afectadas las siguientes características del sistema:

  • Amplitud en la entrada del dispositivo

  • La precisión de la respuesta en frecuencia
  • La d irectividad
  • La d iafonía (aislamiento)

  • El acoplamiento entre fuentes

  • La a daptación de carga

éste es un resumen del procedimiento a seguir para realizar una calibración de medida para el dispositivo sometido a prueba.

  1. Definir el analizador y el dispositivo sometido a prueba en la configuración de la medida.

  2. Optimizar la medida seleccionando los ajustes adecuados en el analizador.

  3. Retirar el dispositivo sometido a prueba y seleccionar un tipo de calibración y un kit de calibración utilizando el asistente Cal Wizard.

  4. Seguir las indicaciones mostradas por el asistente Cal Wizard y conectar y medir los patrones de calibración necesarios para el tipo de calibración seleccionado.

    • El analizador calcula los términos de error a partir de las medidas de los patrones de calibración.

    • Una vez realizados los procedimientos indicados por el asistente Cal Wizard, los términos de error se almacenan automáticamente como conjuntos de calibración en la memoria del analizador. (El usuario puede recuperar estos conjuntos de calibración.)

  5. Volver a conectar el dispositivo sometido a prueba y analizar los datos. Los efectos de los términos de error se eliminarán de la medida o las medidas del dispositivo cuando se aplique la c orrección de errores.


Errores

Véase asimismo...

Errores de medidas

Descripción general

Errores de deriva y
errores aleatorios

Errores
sistemáticos

Monitorización de
términos de error

Por mucho cuidado que se tenga, hay un cierto grado de inexactitud en cada medida realizada. Sin embargo, la necesidad de la precisión de medida determina el nivel de preocupación con respecto a los errores de medida. Por ejemplo:

  • Si se desea verificar si un dispositivo está funcionando y sólo es necesario realizar medidas aproximadas, normalmente no habrá ninguna razón para preocuparse por la exactitud de las medidas.

  • Si se está intentando determinar si un amplificador marginal supera una especificación de ganancia, podrá ser mucho mayor la preocupación respecto de la precisión de medida (y, por tanto, la reducción de los errores de medida).

La comprensión de las causas de los errores de medida puede ayudar a determinar cómo se puede mejorar la precisión. Haga clic en los botones para obtener información sobre las dos fuentes básicas de errores de medidas y la manera de monitorizar los términos de error.
Errores de deriva y errores aleatorios

Errores sistemáticos

Monitorización de términos de error

Errores de deriva

  • Los errores de deriva se deben al cambio del rendimiento del instrumento o el sistema de pruebas después de realizar una calibración.

  • Los errores de deriva se deben principalmente a las características de expansión térmica de los cables de interconexión del equipo de verificación y a la estabilidad de conversión del convertidor de frecuencias de microondas, y se pueden eliminar mediante una o más calibraciones posteriores.

  • El periodo de tiempo durante el cual una calibración sigue siendo exacta depende de la tasa de deriva a la que está sometido el sistema de pruebas en el entorno de verificación.

Una temperatura ambiente estable normalmente reduce la deriva. Para obtener más información, véase Estabilidad de medida.

Errores aleatorios

Los errores aleatorios no son previsibles y no se pueden eliminar mediante la c orrección de errores. Sin embargo, se pueden adoptar algunas medidas para reducir sus efectos sobre la precisión de las medidas.

Hay tres fuentes principales de errores aleatorios:

Errores de ruido del instrumento

Errores de repetibilidad de conmutadores

Errores de repetibilidad de conectores

Errores de ruido del instrumento

El ruido se debe a las perturbaciones eléctricas no deseadas que se generan en los componentes del analizador. Estas perturbaciones son:

  • Ruido de bajo nivel debido al límite inferior del ruido de banda ancha del receptor.

  • Ruido de alto nivel o fluctuaciones de los datos de la traza debidas al límite inferior del ruido y al ruido de fase de la fuente de LO en el interior del equipo de verificación.

Los errores de ruido se pueden reducir adoptando una o más de las medidas siguientes:

  • Aumentar la potencia de la fuente que llega al dispositivo que se está midiendo.

  • Estrechar el ancho de banda de la IF.

  • Aplicar varios promedios de barridos de medida.

Errores de repetibilidad de conmutadores

  • Los conmutadores mecánicos de RF se utilizan en el analizador para cambiar los ajustes del atenuador de la fuente.

  • A veces, cuando se activan los conmutadores mecánicos de RF, los contactos se cierran de manera distinta a como lo hicieron cuando se activaron anteriormente. Cuando esto ocurre en el interior del analizador, puede afectar adversamente a la exactitud de una medida.

  • Se pueden reducir los efectos de los errores de repetibilidad de los conmutadores evitando cambiar los ajustes del atenuador durante una medida crítica.

Errores de repetibilidad de conectores

El desgaste de los conectores provoca cambios en el rendimiento eléctrico. Se pueden reducir los errores de repetibilidad de los conectores cuidando debidamente de los conectores. Véase Conexiones de dispositivos .

Los errores sistemáticos se deben a imperfecciones en el analizador y en la configuración de prueba.

  • Son repetibles (y, por tanto, previsibles) y se supone que no varían con el paso del tiempo.

  • Se pueden caracterizar durante el proceso de calibración y reducirse matemáticamente durante las medidas.

  • Nunca se eliminan por completo. Siempre hay algunos errores residuales debidos a las limitaciones del proceso de calibración. Los errores sistemáticos residuales (después de la calibración de la medida) son provocados por:

    • imperfecciones en los patrones de calibración

    • interfaz del conector

    • cables de interconexión

    • instrumentación

Las medidas de la reflexión generan los tres errores sistemáticos siguientes:

Directividad

Acoplamiento entre fuentes

Seguimiento de la reflexión de la respuesta en frecuencia

Las medidas de la transmisión generan los tres errores sistemáticos siguientes:

Aislamiento

Adaptación de carga

Seguimiento de la transmisión de la respuesta en frecuencia

Nota: En las figuras de los seis errores sistemáticos siguientes se muestra el hardware pertinente configurado para una medida progresiva. Para medidas regresivas, la conmutación interna del analizador convierte el Puerto 2 en la fuente y el Puerto 1 en el receptor. El canal "A" se convierte en el receptor transmitido, el canal "B" en el receptor reflejado y el canal "R2" en el receptor de referencia. Estos seis errores sistemáticos, multiplicados por dos direcciones, dan como resultado 12 errores sistemáticos para un dispositivo de dos puertos.

Error de directividad+

Todos los analizadores de redes miden la reflexión utilizando acopladores direccionales o puentes.

Con un acoplador ideal, en el canal "A" sólo aparece la señal reflejada del DUT. En realidad, una pequeña cantidad de señal incidente se escapa por la ruta de avance del acoplador y se introduce en el canal "A".

Este error de medida se denomina error de d irectividad. Se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de directividad.

  1. Durante la calibración , se conecta un patrón de carga al Puerto 1. Se supone que no existen reflexiones desde la carga.

  2. La señal medida en el canal "A" es el resultado de la fuga de la señal incidente a través del acoplador.

  3. El error de directividad se resta de las medidas de reflexión posteriores.

Error de aislamiento

Idealmente, sólo la señal transmitida a través del DUT se mide en el canal "B".

En realidad, una pequeña cantidad de la señal se escapa al receptor del canal "B" a través de diversas rutas del analizador.

La fuga de la señal, denominada asimismo d iafonía, es el error de aislamiento, que se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de aislamiento

  1. Durante la calibración, se conectan patrones de carga al Puerto 1 y al Puerto 2.

  2. La señal medida en el canal "B" es la fuga a través de diversas rutas del analizador.

  3. El error de aislamiento se resta de las medidas de transmisión posteriores.

Error de acoplamiento entre fuentes

Idealmente, en las medidas de la reflexión, toda la señal reflejada desde el DUT se mide en el canal "A".

En realidad, parte de la señal que se refleja del dispositivo sometido a prueba se vuelva a reflejar del Puerto 1 y no se mide en el canal "A".

Este error de medida se denomina error de acoplamiento de las fuentes y se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de acoplamiento de las fuentes

  1. Durante la calibración, se conecta un patrón de circuito cerrado al Puerto 1. La reflexión conocida desde el circuito cerrado se mide en el canal "A" y se almacena en el analizador.

  2. Se conecta un patrón de circuito abierto al Puerto 1. La reflexión conocida desde el circuito abierto se mide en el canal "A" y se almacena en el analizador.

  3. El analizador compara las dos señales almacenadas. La diferencia entre ambas señales se debe a un error de adaptación de las fuentes.

  4. El error de adaptación de las fuentes se resta de las medidas posteriores de la reflexión y la transmisión.

Error de adaptación de carga

Idealmente, en las medidas de la transmisión, se transmite una señal incidente a través del dispositivo sometido a prueba y se mide en el canal "B".

En realidad, parte de la señal se refleja desde el Puerto 2 y no se mide en el canal "B".

Este error de medida se denomina error de a daptación de carga , y se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de adaptación de carga

  1. Los conectores de prueba del Puerto 1 y el Puerto 2 se acoplan entre sí para formar una conexión perfecta de cable pasivo de longitud cero. (Si esto no es posible, se inserta un adaptador de cable pasivo.) Esto permite que una cantidad conocida de señal incidente llegue al Puerto 2.

  2. La señal medida en el canal "A" es la señal de reflexión reflejada del Puerto 2.

  3. El error de adaptación de carga resultante se resta de las medidas posteriores de la transmisión y la reflexión.

Error de seguimiento de la reflexión de la respuesta en frecuencia

La reflexión se mide comparando la señal en el canal "A" (el canal de reflexión) con la señal en el canal "R1" (el canal de referencia). Esto se denomina una medida de relación, o de "A sobre R1" (A/R1).

En una medida ideal de la reflexión, la respuesta en frecuencia de los receptores del canal "A" y del canal "R1" sería idéntica.

En realidad, no lo es, provocando un error de seguimiento de la reflexión de la respuesta en frecuencia. Se trata de la suma vectorial de todas las variaciones de prueba en las que la magnitud y la fase cambian como una función de la frecuencia. Esto incluye variaciones causadas por:

    • dispositivos de separación de señales

    • cables de prueba

    • adaptadores

    • variaciones entre las rutas de las señales de referencia y de prueba

El error de seguimiento de la reflexión de la respuesta en frecuencia se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de seguimiento de la reflexión de la respuesta en frecuencia

  1. Durante la calibración, se conecta un patrón de circuito cerrado al Puerto 1. La reflexión conocida desde el circuito cerrado se mide en el canal "A" y se almacena en el analizador.

  2. Se conecta un patrón de circuito abierto al Puerto 1. La reflexión conocida desde el circuito abierto se mide en el canal "A" y se almacena en el analizador.

  3. El analizador promedia las dos señales almacenadas del canal "A".

  4. El promedio de la respuesta del canal "A" se compara con la señal de referencia medida en el canal "R1".

  5. El resultado es la diferencia de la respuesta en frecuencia de los receptores del canal "A" y del canal "R1" (véase el diagrama siguiente). Este error de seguimiento de la reflexión de la respuesta en frecuencia se resta de las medidas posteriores del DUT.

Nota: En las calibraciones de la respuesta de reflexión, sólo se mide un patrón de calibración (circuito abierto o cerrado) y, por tanto, sólo se utiliza su aportación a la corrección de errores.

Error de seguimiento de la transmisión de la respuesta en frecuencia

La transmisión se mide comparando la señal en el canal "B" (el canal de transmisión) con la señal en el canal "R1" (el canal de referencia). Esto se denomina una medida de relación, o de "B sobre R1" (B/R1).

En una medida ideal de la transmisión, la respuesta en frecuencia de los receptores del canal "B" y del canal "R1" sería idéntica.

En realidad, no lo es, provocando un error de seguimiento de la transmisión de la respuesta en frecuencia . Se trata de la suma vectorial de todas las variaciones de prueba en las que la magnitud y la fase cambian como una función de la frecuencia. Esto incluye variaciones causadas por:

    • dispositivos de separación de señales

    • cables de prueba

    • adaptadores

    • variaciones entre las rutas de las señales de referencia y de prueba

El error de seguimiento de la transmisión de la respuesta en frecuencia se puede medir y reducir mediante el analizador.

Cómo mide y reduce el analizador el error de seguimiento de la transmisión de la respuesta en frecuencia

  1. Durante la calibración, los conectores de prueba del Puerto 1 y el Puerto 2 se acoplan entre sí para formar una conexión perfecta de cable pasivo de longitud cero. (Si esto no es posible, se inserta un adaptador de cable pasivo.) Esto permite que una cantidad conocida de señal incidente llegue el Puerto 2.

  2. Se realizan medidas en el canal "B" y el canal "R1" y se almacenan.

  3. El analizador compara las señales del canal "R1" y del canal "B".

  4. El resultado es la diferencia de la respuesta en frecuencia de los receptores del canal "B" y del canal "R1" (véase el diagrama siguiente). Este error de seguimiento de la transmisión de la respuesta en frecuencia se resta de las medidas posteriores del dispositivo.

.

El analizador guarda la medida de los errores sistemáticos como términos de error. Mediante la monitorización de estos términos de error se puede determinar el "estado de salud" del analizador y la exactitud de las medidas.

Si se imprimen o se guardan los términos de error, se podrán comparar periódicamente los términos de error actuales con el registro de valores generados anteriormente con el mismo instrumento y kit de calibración. Si no hay disponibles valores generados anteriormente, podrán consultarse los valores típicos o los resultados de medida de términos de error típicos que figuran en el Capítulo 4, "Términos de error", de la Guía de Servicio.

  • Un sistema estable debería generar términos de error repetibles durante un periodo de aproximadamente seis meses.

  • Un cambio repentino de los términos de error con los mismos valores de margen de frecuencias, potencia y receptor podría indicar la necesidad de diagnosticar los componentes del sistema. Para obtener información sobre el diagnóstico de términos de error, véase el Capítulo 4, "Términos de error", de la Guía de Servicio.

  • Un cambio sutil a largo plazo de los términos de error indica a menudo la existencia de deriva o el desgaste de los conectores y cables. A menudo, este problema se puede resolver con sólo limpiar y calibrar los conectores o inspeccionar los cables. Haga clic en un botón para tener acceso a un procedimiento de medida de términos de error.

Los procedimientos siguientes muestran cómo recuperar y almacenar términos de error desde el analizador.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Realizar una calibración SOLT completa de 2 puertos. Para obtener más información, véase el apartado Seleccionar y realizar una calibración de medida.

  2. En el menú System, señalar con el cursor Servicey, a continuación, Utilities. Hacer clic en Evaluate Error Corr Data.

  3. En el cuadro de diálogo, seleccionar uno de los términos de error de Port 1 o Port 2.

    • Hacer clic en Apply: la traza del término de error seguirá mostrándose y el cuadro de diálogo permanecerá abierto, permitiendo realizar otra selección.

    • Hacer clic en OK: se cerrará el cuadro de diálogo mientras se sigue mostrando la traza del término de error.

  4. En el menú Scale, hacer clic en Autoscale para ajustar la escala de la medida mostrada para visualizarla de manera óptima.

  5. Utilizar los marcadores del analizador para examinar los detalles de la traza del término de error.

  6. Si se sospecha que se ha producido un fallo sutil o un pequeño problema de rendimiento, debería compararse la magnitud de los términos de error con los valores generados anteriormente con el mismo instrumento y kit de calibración. Esta comparación producirá la imagen más precisa del problema. Si no hay disponibles valores generados anteriormente, o si se desea más información, véase el Capítulo 4, "Términos de error", de la Guía de Servicio.

Procedimiento con las teclas del panel frontal

  1. Realizar una calibración SOLT completa de 2 puertos. Para obtener más información, véase el apartado Seleccionar y realizar una calibración de medida.

  2. En el bloque COMMAND, pulsar Menu/Dialog.

  3. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar al menú System.

  4. Pulsar la tecla hacia abajo para desplazarse a Service. Pulsar Click.

  5. Pulsar la tecla hacia abajo para desplazarse a Utilities. Pulsar Click.

  6. Evaluate Error Corr Data aparece seleccionado por defecto. Pulsar Click.

  7. Pulsar la tecla de tabulador a la derecha para seleccionar la parte Port 1 Error Terms o Port 2 Error Terms del cuadro de diálogo. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar uno de los términos de error del Puerto 1 o el Puerto 2.

    • Pulsar la tecla de tabulador a la derecha para seleccionar Apply. Pulsar Click. La traza del término de error seguirá mostrándose y el cuadro de diálogo permanecerá abierto, permitiendo realizar otra selección.

    • Pulsar la tecla de tabulador a la derecha para seleccionar OK. Pulsar Click. Se cerrará el cuadro de diálogo mientras se sigue mostrando la traza del término de error.

  8. En el bloque COMMAND, pulsar Menu/Dialog.

  9. Pulsar la tecla de tabulador a la derecha para seleccionar el menú Scale.

  10. Autoscale aparece seleccionado por defecto. Pulsar Click para ajustar la escala de la medida mostrada para visualizarla de manera óptima.

  11. Utilizar los marcadores del analizador para examinar los detalles de la traza del término de error.

  12. Si se sospecha que se ha producido un fallo sutil o un pequeño problema de rendimiento, debería compararse la magnitud de los términos de error con los valores generados anteriormente con el mismo instrumento y kit de calibración. Esta comparación producirá la imagen más precisa del problema. Si no hay disponibles valores generados anteriormente, o si se desea más información, véase el Capítulo 4, "Términos de error", de la Guía de Servicio.

Recuperación automatizada de términos de error

Véase Datos / Términos de error para obtener una lista de los comandos SCPI y COM que recuperan y almacenan términos de error.


Cal_Stds

Véase asimismo...

Patrones de calibración

Descripción general

Conceptos

Cómo modificar patrones

Durante la calibración de la medida, el analizador mide patrones y compara matemáticamente los resultados con "modelos ideales" de esos patrones. Las diferencias se separan en términos de error que más tarde se eliminan de las medidas de dispositivos durante la c orrección de errores.
Conceptos

Cómo modificar patrones

Todos los patrones de calibración tienen una definición conocida con precisión que incluye el retardo eléctrico, la impedancia y la pérdida. El analizador almacena estas definiciones y las utiliza para calcular términos de corrección de errores.
Kits de calibración
Modificación de archivos de kits de calibración

Dispositivo estándar

Menú Modify Calibration Kit
Calibración electrónica (ECal)

Kits de calibración

Los kits de calibración contienen patrones (dispositivos) que el analizador mide durante el proceso de calibración. Estos kits están disponibles a través de Agilent Technologies en diversos tipos de conectores. Cada kit contiene normalmente:

  • Un circuito cerrado

  • Un circuito abierto

  • Una carga con impedancia adaptada

Definiciones

  • Un "patrón" de calibración (representado por un número comprendido entre 1 y 8) es un dispositivo físico específico y bien definido utilizado para determinar errores sistemáticos. Por ejemplo, el patrón 1 es un circuito cerrado en el kit de calibración 85033E de 3,5 mm.

  • Un "tipo" de patrón es uno de los cuatro tipos básicos que definen la forma o estructura del modelo que se debe utilizar con ese patrón:

    • Corto

    • Abierto

    • Carga

    • Cable pasivo

  • El patrón 1 es del tipo corto (en el kit de calibración de 3,5 mm).

  • Las "características" de los patrones son las características numéricas y físicas de los patrones utilizadas en el modelo seleccionado.

En la mayoría de los kits que necesitan adaptadores para la conexión con puertos, los adaptadores están adaptados en fase. Es posible utilizar patrones que no formen parte de un kit de calibración, especificando sus características en un kit definido por el usuario, tal y como se describe en la sección "Modificación de kits de calibración".

Para obtener una lista de kits de calibración estándar disponibles para utilizarse con el analizador (incluidos aquéllos con definiciones almacenadas en el analizador), véase Accesorios disponibles.

Modificación de archivos de kits de calibración

Hay varias situaciones en las podrá ser necesario crear un archivo de kit de calibración definido por el usuario:

  • El puerto tiene un tipo de conector que figura en el menú Cal Kit, pero los patrones de calibración (como un circuito cerrado) tienen características distintas de las definiciones del kit de calibración almacenadas en el analizador.

  • El puerto tiene un tipo de conector que no se corresponde con una de las definiciones del kit de calibración almacenadas en el analizador.

  • Se está realizando la calibración para un dispositivo no insertable. Véase Calibraciones precisas de medidas.

Se puede modificar un archivo de kit de calibración predefinido y guardarlo como un archivo de kit de calibración definido por el usuario. El archivo de kit de calibración predefinido original permanecerá inalterado.

Nota: Esta sección no pretende ofrecer un estudio exhaustivo de la modificación de kits de calibración. Para obtener más información, visitar el sitio Web www.agilent.com/find/assist y buscar la nota de producto Product Note 8510-5A, "Specifying Calibration Standards for the HP 8510 Network Analyzer", (nº de referencia 5956-4352).

Es posible construir o modificar patrones de calibración y sus definiciones utilizando el proceso siguiente:

  1. Seleccionar Standard Devices

  2. Utilizar el menú Modify Calibration Kit

Dispositivos estándar

En primer lugar se debe seleccionar un método de calibración de medida que resulte adecuado para satisfacer las necesidades de precisión. (En Seleccionar y realizar una calibración de medida se incluye un análisis de los métodos de calibración disponibles.) Esta decisión determina los dispositivos estándar que serán necesarios para realizar la calibración.

Tres patrones de calibración coaxiales utilizados habitualmente son:

  • Circuito cerrado con longitud eléctrica cero

  • Circuito abierto apantallado

  • Terminación con adaptación de carga (el analizador no admite actualmente cargas deslizantes ni cargas con desplazamiento)

Nota: El "patrón de cable pasivo" normalmente no es un patrón físico, sino un cable pasivo de longitud cero que se crea conectando los puertos de verificación directamente entre sí. Véase "Calibraciones precisas" para obtener más información sobre los patrones de cable pasivo.

El medio de los patrones de calibración debe ser el mismo que el del DUT (por ejemplo, coaxial, guía de ondas o microregleta) para realizar una calibración de medida. Para satisfacer sus necesidades, el usuario puede:

  • adquirir patrones

  • construir patrones

  • modificar patrones existentes

Independientemente del método elegido, deberían utilizarse los siguientes criterios a la hora de elegir patrones de calibración:

  • Una respuesta bien definida que sea repetible y estable a través de un margen de temperaturas.

  • Impedancias claramente diferenciadas las unas de las otras. Por ejemplo:

    • Un circuito cerrado de longitud cero y un circuito abierto apantallado presentan una separación de fase de 180°.

    • Una carga adaptada con precisión proporciona una separación de magnitud de 40 a 50 dB con respecto al circuito cerrado y el circuito abierto.

  • Cobertura de frecuencias de banda ancha a través de todo el margen de frecuencias de interés

Menú Modify Calibration Kit

Examinar el gráfico para familiarizarse con las funciones de cada área específica:

El bloque Calibration Kit contiene lo siguiente:

  • Diez números de identificación de kits de calibración, Cal Kit ID, que pueden elegirse (véase la tabla siguiente):

    • Los números de identificación 1 a 6 contienen definiciones de kits de calibración predefinidas. Las definiciones de estos kits no se deben modificar si se piensa que podrán necesitarse para realizar futuras medidas.

    • Los números de identificación 7 a 10 contienen definiciones de kits de calibración definidas por el usuario. Puede modificarse un kit de calibración predefinido y guardarse como un kit del usuario. El kit de calibración predefinido original permanecerá inalterado.

  • Un nombre de kit de calibración, Cal Kit Name (se puede editar).

  • Restore Default Kit. Restaura los valores predefinidos del kit de calibración seleccionado en ese momento.

  • Restore ALL Default Kits. Restaura los valores predefinidos de todos los kits de calibración.
Identificación de kit | Puerto 1 | Puerto 2 | Nombre del kit de calibración
1 | Tipo N (h) | Tipo N (m) | Tipo N Modelo 85032F
2 | 3,5 mm | 3,5 mm | 3,5 mm Modelo 85033E
3 | Tipo N (h) | Tipo N (m) | Tipo N Modelo 85032B
4 | 3,5 mm | 3,5 mm | 3,5 mm Modelo 85033D
5 | 7-16 | 7-16 | 7-16 Modelo 85038A
6 | TRL 3,5 mm | TRL 3,5 mm | TRL 3,5 mm Modelo 85052C
7 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 7
8 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 8
9 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 9
10 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 10

El bloque Assign Standards to Ports contiene lo siguiente:

  • El tipo de conector Port 1 (se puede editar).

  • El tipo de conector Port 2 (se puede editar).

  • Ocho clases (cuatro para cada puerto) para asignar los patrones.
Clases de reflexión (seis) | Clases de transmisión (dos)
S11A (abierto - nº 8) | S21T (cable pasivo - longitud cero - nº 4)
S11B (corto - nº 7) | S12T (cable pasivo - longitud cero - nº 4)
S11C (carga - nº 3) |
S22A (abierto - nº 2) |
S22B (corto - nº 1) |
S22C (carga - nº 3) |

Nota: En el ejemplo anterior, los patrones de Tipo N se han asignado a las diversas clases.

Una clase de calibración correlaciona un patrón con su posición en los cálculos de términos de error. Las clases A, B y C se utilizan para resolver:

  • D irectividad (S11C, S22C)

  • Acoplamiento entre fuentes (S11A, S11B, S22A, S22B)

  • Error de seguimiento de reflexión (S11A, S11B, S22A, S22B)

Las clases "T" se utilizan para calcular:

  • Error de seguimiento de transmisión (S21T, S12T)

  • A daptación de carga (S21T, S12T)

Debe asignarse un patrón a cada una de las ocho clases de calibración. Los números por defecto de los kits de calibración son los siguientes:

1. Corto (m) | 5. Cable pasivo (adaptador personalizado)
2. Abierto (m) | 6. Carga de banda baja
3. Carga de banda ancha | 7. Corto (h)
4. Cable pasivo (longitud cero) | 8. Abierto (h)

El bloque Modify Standard Definition contiene lo siguiente (necesario para una definición completa):

  • Nº de patrón (1-8)

  • Frecuencia mínima

  • Frecuencia máxima

  • Z 0 (Impedancia)

  • Retardo

  • Pérdida

  • Tipo (Abierto, Cerrado, Carga, Cable pasivo)

  • Carácter (Coaxial, Guía de ondas)

  • Etiqueta

  • Valores de capacitancia ( C0, C1, C2, C3) - sólo se utilizan para caracterizar circuitos abiertos.

  • Los términos de inductancia (L0, L1, L2, L3) - sólo se utilizan para caracterizar circuitos cerrados.

Las definiciones de los kits de calibración son las características eléctricas de los patrones seleccionados. Estas características se obtienen de dos maneras:

  • Derivadas de las dimensiones físicas y el material de cada patrón.

  • Medidas en un analizador de redes calibrado.

Características

  • Z0

    • Impedancia del desplazamiento entre el patrón que se está definiendo y el plano de medida real.

    • Normalmente se ajusta a la impedancia característica del sistema.

  • Retardo

    • Equivalente a una longitud uniforme de una línea de transmisión entre el patrón que se está definiendo y el plano de medida real.

    • Para un circuito abierto, un circuito cerrado y una carga, el retardo se introduce como el tiempo de desplazamiento en un sentido desde el plano de medida hasta el patrón, en segundos.

    • Para un cable pasivo, el retardo se introduce como el tiempo de desplazamiento en un sentido entre los planos de medida, en segundos.

    • El retardo se puede medir o determinar a partir de la longitud física precisa del patrón, dividida por el factor de velocidad.

PRECAUCIóN: Si se van a conectar dos puertos con un adaptador de cable pasivo durante la calibración, deberán modificarse los kits de calibración de cada uno de estos puertos utilizando el valor de retardo idéntico para el adaptador de cable pasivo.

  • Pérdida

    • Se utiliza para especificar la pérdida de energía, debida al efecto pelicular, a lo largo de una longitud unidireccional de cable coaxial.

    • El valor de pérdida se introduce en ohmios/segundo a 1 GHz.

    • Para numerosas aplicaciones, el valor de pérdida se puede ajustar a cero sin que se produzca una degradación sensible.

    • Para calcular la pérdida del patrón, medir el retardo en segundos y la pérdida en dB a 1 GHz. A continuación, calcular:

  • C0, C1, C2, C3

    • A frecuencias elevadas, un circuito abierto raramente tiene características de reflexión perfectas, ya que la capacitancia marginal provoca un desplazamiento de fase que varía con la frecuencia. Es imposible eliminar estos efectos, pero el cálculo incorporado al analizador incluye un modelo de capacitancia de circuito abierto. Este modelo es un polinomio de tercer orden como una función de la frecuencia, en el que los coeficientes polinómicos son definibles por parte del usuario.

    • La ecuación del modelo de capacitancia es la siguiente:

    • C = (C0) + (C1 x F) + (C2 x F²) + (C3 x F³)

    • (F es la frecuencia de medida).

    • Los términos de la ecuación se definen al especificar el circuito abierto de la siguiente manera:

      • El término C0 es el término constante del polinomio de tercer orden y se expresa en faradios.

      • El término C1 se expresa en F/Hz (faradios/Hz).

      • El término C2 se expresa en F/Hz².

      • El término C3 se expresa en F/Hz³.

  • L0, L1, L2, L3

    • A frecuencias elevadas, un circuito cerrado raramente tiene características de reflexión perfectas, ya que la inductancia residual provoca un desplazamiento de fase que varía con la frecuencia. Es imposible eliminar estos efectos, pero el cálculo incorporado al analizador incluye un modelo de inductancia de circuito cerrado. Este modelo es un polinomio de tercer orden como una función de la frecuencia, en el que los coeficientes polinómicos son definibles por parte del usuario.

    • La ecuación del modelo de capacitancia es la siguiente:

    • L = (L0) + (L1 x F) + (L2 x F²) + (L3 x F³)

    • (F es la frecuencia de medida).

    • Los términos de la ecuación se definen al especificar el circuito cerrado de la siguiente manera:

      • El término L0 es el término constante del polinomio de tercer orden y se expresa en henrios.

      • El término L1 se expresa en H/Hz (henrios/Hz).

      • El término L2 se expresa en H/Hz².

      • El término L3 se expresa en H/Hz³.

Cuando se hayan definido los patrones, deberán introducirse en los campos oportunos del cuadro de diálogo.

Se utiliza la misma definición para circuitos cerrados, circuitos abiertos y cargas macho y hembra en la mayoría de los kits de calibración.

En la mayoría de los kits de calibración existentes, la definición del patrón "cable pasivo" (normalmente el patrón número 4) es la definición de un "cable pasivo de longitud cero". Obsérvese que el retardo y la pérdida son cero. Esto significa que no hay un patrón de "cable pasivo". La calibración se realiza conectando ambos puertos de verificación directamente entre sí. Véase el apartado Calibraciones precisas de medidas para obtener más información al respecto.

Nota: La exactitud de las medidas es un resultado directo de lo bien que coinciden los patrones de calibración con sus definiciones. Si se dañan o se desgastan los patrones, se degradará la exactitud de las medidas.

Calibración electrónica (ECal)

  • ECal es una completa solución de calibración basada en semiconductores.

    • Realiza de manera rápida y sencilla calibraciones de medidas de 1 puerto (reflexión) y completas de 2 puertos.

    • Es menos propensa a los errores del operador.

    • Los diversos patrones (situados en el interior del módulo de calibración) nunca se desgastan, puesto que se conmutan mediante conmutadores FET o de diodos PIN.

  • Los módulos de calibración se caracterizan utilizando un analizador de redes calibrado mediante TRL.

  • La precisión de ECal no es tan buena como una calibración TRL exacta.

Para obtener más información, ponerse en contacto con el representante de asistencia de Agilent.

Haga clic en los botones para tener acceso a los procedimientos empleados para modificar un archivo de kit de calibración.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Calibration, hacer clic en Advanced Modify Cal Kit.

  2. Hacer clic en la casilla Cal Kit ID en la parte Calibration Kit del cuadro de diálogo. Introducir el valor o hacer clic en el botón de flecha para seleccionar el número de identificación del kit de calibración deseado.

    • Para restaurar los valores predefinidos del kit de calibración seleccionado en ese momento, hacer clic en Restore Default Kit.

    • Para restaurar los valores predefinidos de todos los kits de calibración, hacer clic en Restore ALL Default Kits.

  3. En el cuadro Cal Kit Name, modificar el nombre del kit de calibración predefinido para crear un nombre nuevo.

Asignar patrones a puertos

  1. Hacer clic en la casilla Port 1 en la parte Assign Standards to Ports del cuadro de diálogo. Editar este tipo de conector.

  2. En el cuadro Port 2, editar este tipo de conector.

  3. En cada uno de los ocho cuadros de clases de calibración (p. ej., S11A), introducir un nuevo número de patrón o hacer clic en el botón de flecha de cada cuadro para seleccionar el número de patrón deseado.

Modificar definición de patrón

  1. Hacer clic en la casilla Standard No. en la parte Modify Standard Definition del cuadro de diálogo. Introducir un nuevo número de patrón o hacer clic en el botón de flecha para seleccionar el número de patrón deseado.

  2. Para el número de patrón seleccionado en el paso anterior, introducir todas las definiciones del patrón (por ejemplo, frecuencia mínima, frecuencia máxima, Z0, retardo, pérdida, etc.). Introducir el valor de la definición o hacer clic en los botones de flecha para seleccionar el valor deseado para cada uno de los cuadros.

  3. Repetir los pasos 1 y 2 para cada número de patrón.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar al menú Calibration.

    1. Pulsar la tecla hacia abajo para desplazarse a Advanced Modify Cal.

    2. Pulsar Click.

  3. La casilla Cal Kit ID se selecciona automáticamente en la parte Calibration Kit del cuadro de diálogo. Introducir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el número de identificación del kit de calibración deseado.

  4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Cal Kit Name. Para modificar el nombre del kit de calibración predefinido, introducir el nombre nuevo.

  5. Pulsar la tecla de tabulador a la derecha para pasar a Restore Default Kit. Para restaurar los valores predefinidos del kit de calibración seleccionado en ese momento, pulsar Click.

  6. Pulsar la tecla de tabulador a la derecha para pasar a Restore ALL Default Kits. Para restaurar los valores predefinidos de todos los kits de calibración, pulsar Click.

Asignar patrones a puertos

  1. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para seleccionar el cuadro Port 1 en la parte Assign Standards to Ports del cuadro de diálogo. Editar el tipo de conector.

  2. Pulsar la tecla de tabulador a la derecha para desplazarse al cuadro Port 2. Editar el tipo de conector.

  3. Pulsar la tecla de tabulador a la derecha para desplazarse a cada uno de los ocho cuadros de clases de calibración (p. ej., S11A). Introducir el número del patrón o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el número de patrón deseado en cada cuadro.

Modificar definición de patrón

  1. Pulsar la tecla de tabulador a la derecha para seleccionar el cuadro Standard No. en la parte Modify Standard Definition del cuadro de diálogo. Introducir el número del patrón o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el número de patrón deseado.

  2. Para el número de patrón seleccionado en el paso anterior, introducir las definiciones del patrón (por ejemplo, frecuencia mínima, frecuencia máxima, Z0, retardo, pérdida, etc.). Introducir el valor de la definición o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el valor deseado para cada uno de los cuadros.

  3. Repetir los pasos 1 y 2 para cada número de patrón.

  4. En el bloque COMMAND, pulsar OK.


Select_Cal

Véase asimismo...

Seleccionar y realizar una calibración de medida

Descripción general

Elecciones de
calibración

Asistente
y funciones

Cómo realizar
una calibración

La calibración de medida que se seleccione y se realice dependerá de:

  • La medida que se esté llevando a cabo.

  • El nivel de precisión necesario para la aplicación de medida.
Elecciones de calibración

Asistente y funciones para la calibración de medidas

Cómo realizar una calibración de medida

Haga clic en un botón para obtener información acerca de los siguientes temas:
Elecciones de métodos de calibración de medidas

Ninguna

Respuesta de circuito ABIERTO o CERRADO

Respuesta de CABLE PASIVO

Respuesta y aislamiento de CABLE PASIVO

1 puerto (Reflexión)

SOLT completa de 2 puertos (CIRCUITO ABIERTO, CIRCUITO CERRADO, CARGA, CABLE PASIVO)

TRL completa de 2 puertos (CABLE PASIVO, REFLEXIÓN, LÍNEA)
Resumen de las elecciones de calibración de medidas

Métodos de calibración de medidas

Por lo general, cuanto más precisa sea una calibración:

  • Más tiempo tardará en realizarse la calibración.

  • Más tiempo necesitará el analizador para realizar la medida.

Por consiguiente, cuando se selecciona un método de calibración de medidas, es importante saber cuánta incertidumbre se puede tolerar en la medida del dispositivo.

Dependiendo del parámetro S y de la dirección de la medida (avance, retroceso o ambas), se pueden elegir los siguientes métodos de calibración de medidas:

Método de calibración | Precisión general | Parámetros | Patrones necesarios
Ninguno | Deficiente | TODOS | 0
Respuesta de circuito ABIERTO o CERRADO | Buena | S11 o S22 | Circuito abierto, circuito cerrado
Respuesta de CABLE PASIVO | Buena | S21 o S12 | Cable pasivo
Respuesta y aislamiento de CABLE PASIVO | Buena | S21 o S12 | Cable pasivo, carga
ECal de 1 puerto (Reflexión) | Mejor | S11 o S22 | Módulo ECal
1 puerto (Reflexión) | Mejor | S11 o S22 | Circuito cerrado, Circuito abierto, Carga
ECal completa de 2 puertos | Siguiente mejor | TODOS | Módulo ECal
SOLT completa de 2 puertos | óptima | TODOS | Circuito abierto, Circuito cerrado, Carga, Cable pasivo
TRL completa de 2 puertos | Máxima | TODOS | Cable pasivo, Circuito abierto o cerrado, Línea

Método de calibración: Ninguno

  • Utilizar para todas las medidas de parámetros S.

  • No mide patrones de calibración.

  • Una calibración muy rápida, pero imprecisa.

  • Utilizar sólo cuando la medida no necesite gran precisión.

Errores sistemáticos corregidos

  • Ninguno

Calibración de respuesta de CIRCUITO ABIERTO o CIRCUITO CERRADO (REFLEXIÓN)

  • Utilizar sólo para medidas de REFLEXIÓN en cualquier puerto.

  • Mide patrones de CIRCUITO ABIERTO o de CIRCUITO CERRADO.

  • Una calibración muy rápida y moderadamente precisa

Errores sistemáticos corregidos

  • Seguimiento de la reflexión de la respuesta en frecuencia

Nota: Cuando se realiza una reflexión

Configuración para una calibración de respuesta de CIRCUITO ABIERTO o CIRCUITO CERRADO

Calibración de respuesta de CABLE PASIVO (TRANSMISIÓN)

  • Utilizar sólo para medidas de TRANSMISIÓN en una dirección.

  • Mide un patrón de CABLE PASIVO.

  • Una calibración muy rápida y moderadamente precisa.

Errores sistemáticos corregidos

  • Seguimiento de la transmisión de la respuesta en frecuencia

Nota: La definición de cable pasivo del analizador para los kits de calibración predefinidos da por sentado que el cable pasivo tiene una longitud cero. Si se está utilizando un adaptador como cable pasivo, deberá caracterizarse el cable pasivo para obtener la más alta precisión. Para obtener más información, véase Calibraciones precisas de medidas.

Configuración para una calibración de respuesta de cable pasivo

Calibración de respuesta y aislamiento de CABLE PASIVO (TRANSMISIÓN)

  • Utilizar sólo para medidas de TRANSMISIÓN en una dirección.

  • La parte de aislamiento de la v se utiliza para medir dispositivos con elevada p érdida por inserción.

  • Mide patrones de CABLE PASIVO y de CARGA.

  • Una calibración muy rápida y moderadamente precisa.

Errores sistemáticos corregidos

  • Aislamiento

  • Seguimiento de la transmisión de la respuesta en frecuencia

Nota: La definición de cable pasivo del analizador para los kits de calibración predefinidos da por sentado que el cable pasivo tiene una longitud cero. Si se está utilizando un adaptador como cable pasivo, deberá caracterizarse el cable pasivo para obtener la más alta precisión. Para obtener más información, véase Calibraciones precisas de medidas.

Configuración para calibración de respuesta y aislamiento de cable pasivo

Calibración de reflexión de 1 puerto

  • Utilizar sólo para medidas de REFLEXIÓN en un puerto.

  • Mide patrones de CIRCUITO CERRADO, CIRCUITO ABIERTO y CARGA.

  • Alta precisión para una medida de 1 puerto.

Errores sistemáticos corregidos

  • D irectividad

  • Acoplamiento entre fuentes

  • Seguimiento de la reflexión de la respuesta en frecuencia

Nota: Cuando se lleve a cabo una medida de la reflexión en un dispositivo de 2 puertos, después de realizar una calibraciónde reflexión de 1 puerto, se deberá terminar el puerto de salida. De lo contrario, la señal reflejada desde el puerto de salida degradará la precisión de la medida, especialmente en dispositivos con baja p érdida por inserción .

Configuraciones para una calibración de 1 puerto (Reflexión)

Calibración ECal de reflexión de 1 puerto

  • Utilizar sólo para medidas de reflexión en un puerto.

  • Mide un módulo basado en semiconductores (conectado al conector USB).

  • Alta precisión para una medida de 1 puerto.

  • Reduce al mínimo el desgaste de la configuración de prueba.

  • Elimina los errores del operador.

  • Reduce el tiempo de calibración.

Errores sistemáticos corregidos

  • Directividad

  • Acoplamiento entre fuentes

  • Seguimiento de la reflexión de la respuesta en frecuencia

Nota: Cuando se lleve a cabo una medida de la reflexión en un dispositivo de 2 puertos, después de realizar una calibración de reflexión de 1 puerto, se deberá terminar el puerto de salida. De lo contrario, la señal reflejada desde el puerto de salida degradará la precisión de la medida, especialmente en dispositivos con baja pérdida por inserción.

Configuración para una calibración ECal

Calibración SOLT completa de 2 puertos (Circuito cerrado, Circuito abierto, Carga, Cable pasivo)

  • Utilizar para todas las medidas de parámetros S.

  • Mide patrones de CIRCUITO CERRADO, CIRCUITO ABIERTO, CARGA y CABLE PASIVO.

  • Conocida como "corrección de errores de 12 términos" por el número de errores eliminados: 6 errores en las direcciones de avance y de retroceso.

  • Precisión de medida muy alta.

Errores sistemáticos corregidos

  • Directividad

  • Aislamiento

  • Acoplamiento entre fuentes

  • Adaptación de carga

  • Seguimiento de la reflexión de la respuesta en frecuencia

  • Seguimiento de la transmisión de la respuesta en frecuencia

Nota: La calibración del aislamiento resulta útil cuando se miden dispositivos con alta p érdida por inserción . Si no se están midiendo dispositivos con elevada pérdida por inserción, se deberá OMITIR la calibración del aislamiento. Pueden introducirse errores al medir las señales de bajo nivel cerca del límite inferior del ruido del analizador, como exige la calibración del aislamiento.

Configuración para una calibración SOLT completa de 2 puertos

Calibración TRL completa de 2 puertos (Cable pasivo, Reflexión, Línea)

  • Utilizar para todas las medidas de parámetros S.

  • Mide patrones de CABLE PASIVO, REFLEXIÓN (circuito cerrado o abierto) y LÍNEA (transmisión).

  • Conocida como "corrección de errores de 12 términos" por el número de errores eliminados: 6 errores en las direcciones de avance y de retroceso.

  • La más alta precisión de calibración

Nota: la calibración del aislamiento resulta útil cuando se miden dispositivos con elevada pérdida por inserción. Si no se están midiendo dispositivos con alta pérdida por inserción, deberá omitirse la calibración del aislamiento, ya que pueden introducirse errores al medir señales de bajo nivel cerca del límite inferior de ruido del analizador.

Errores sistemáticos corregidos

  • Directividad

  • Aislamiento

  • Acoplamiento entre fuentes

  • Adaptación de carga

  • Seguimiento de la reflexión de la respuesta en frecuencia

  • Seguimiento de la transmisión de la respuesta en frecuencia

Nota: La calibración del aislamiento resulta útil cuando se miden dispositivos con alta pérdida por inserción. Si se están midiendo dispositivos con elevada pérdida por inserción, deberá omitirse la calibración del aislamiento, porque podrán introducirse errores al medir señales de bajo nivel cerca del límite inferior del ruido del analizador.

El único kit de calibración TRL predefinido en la memoria del analizador es el TRL Modelo 85052C de 3,5 mm. Para realizar una calibración TRL con un tipo de conector distinto de uno de 3,5 mm, deberán modificarse o crearse antes definiciones y patrones TRL. Para obtener más información acerca de la manera de modificar los patrones, véase Patrones de calibración.

Calibración ECal completa de 2 puertos

  • Utilizar para todas las medidas de parámetros S.

  • Mide un módulo basado en semiconductores (conectado al conector USB).

  • Conocida como "corrección de errores de 12 términos" por el número de errores eliminados: 6 errores en las direcciones de avance y de retroceso.

  • Precisión de medida muy alta.

  • Reduce al mínimo el desgaste de la configuración de prueba.

  • Reduce los errores del operador.

  • Reduce significativamente el tiempo de calibración.

Errores sistemáticos corregidos

  • Directividad

  • Aislamiento

  • Acoplamiento entre fuentes

  • Adaptación de carga

  • Seguimiento de la reflexión de la respuesta en frecuencia

  • Seguimiento de la transmisión de la respuesta en frecuencia

Configuración para una calibración ECal

Resumen de las elecciones de calibración de medidas

Tipo de medida | Elecciones de calibración
S11 | Respuesta de circuito abierto Respuesta de circuito cerrado 1 puerto (Reflexión) ECal de 1 puerto (Reflexión) completa SOLT de 2 puertos completa TRL de 2 puertos ECal completa de 2 puertos
S21 | Respuesta de cable pasivo Respuesta y aislamiento de cable pasivo SOLT completa de 2 puertos TRL completa de 2 puertos ECal completa de 2 puertos
S12 | Respuesta de cable pasivo Respuesta y aislamiento de cable pasivo SOLT completa de 2 puertos TRL completa de 2 puertos ECal completa de 2 puertos
S22 | Respuesta de circuito abierto Respuesta de circuito cerrado 1 puerto (Reflexión) ECal de 1 puerto (Reflexión) SOLT completa de 2 puertos TRL completa de 2 puertos ECal completa de 2 puertos
Potencia no relacionada | Funciones matemáticas/de memoria
Relación arbitraria | Funciones matemáticas/de memoria

Haga clic en un botón para obtener información acerca de los siguientes temas:
Asistente para calibración
Activar/desactivar corrección
Propiedades de calibración
Almacenamiento de datos de calibración
Modificación de datos de calibración actuales
Recuperación de calibraciones de medidas

Asistente para calibración

El asistente para Calibración es una serie de cuadros de diálogo que ayudan a simplificar el proceso de calibración.

Nota: las etiquetas de los kits de calibración del analizador indican el sexo del conector del puerto de prueba, no del conector del patrón de calibración.

El bloque Select Calibration Kit contiene lo siguiente:

  • El tipo de calibración seleccionado en ese momento. En este ejemplo está seleccionado "None".

  • El cuadro de diálogo Cal Type con la siguiente selección de tipos de calibración:

    • OPEN Response

    • SHORT Response

    • THRU Response

    • THRU Response and Isol

    • 1-Port (Reflection)

    • Full SOLT 2-Port

    • Full TRL 2-Port

    • None

Cal Type también ofrece una selección Omit Isolation (2-Port types) que permite omitir la parte de las calibraciones de 2 puertos correspondiente al aislamiento.

Este bloque Instrument Settings contiene un cuadro de diálogo Modify que permite modificar los valores de frecuencia de inicio/parada del analizador.

Este bloque Use Electronic calibration contiene un cuadro de diálogo Measure ECal Stds que proporciona gráficos y (si se desea) indicaciones para guiar al usuario a través del proceso ECal.

Este bloque Use Mechanical Standards contiene:

  • Un parámetro para 2 conjuntos de patrones. Esto permite medir simultáneamente dos conjuntos de patrones (por ejemplo, dos circuitos abiertos) en los puertos 1 y 2 al realizar una calibración de 2 puertos.

  • Un cuadro de diálogo Measure Standards que proporciona:

    • Gráficos e indicaciones (si se desea) para guiar al usuario a través del proceso de calibración seleccionado, utilizando patrones mecánicos.

    • Un parámetro Show Prompts que permite activar y desactivar las indicaciones que acompañan a esta parte del asistente para calibración Calibration Wizard.

    • Un parámetro Change Port que permite modificar las asignaciones de puertos predefinidas del kit de calibración y caracterizar un cable pasivo/adaptador personalizado (si es necesario). Este parámetro también permite guardar las modificaciones como un kit de calibración definido por el usuario. Véase Calibraciones precisas para obtener más información sobre los patrones de cable pasivo. Véase Patrones de calibración para obtener más información sobre la manera de modificar los kits de calibración.

    • Un parámetro Select Calibration Kit que ofrece las siguientes opciones de kit de calibración:

Identificación de kit | Puerto 1 | Puerto 2 | Nombre del kit de calibración
1 | Tipo N (h) | Tipo N (m) | Tipo N Modelo 85032F
2 | 3,5 mm | 3,5 mm | 3,5 mm Modelo 85033E
3 | Tipo N (h) | Tipo N (m) | Tipo N Modelo 85032B
4 | 3,5 mm | 3,5 mm | 3,5 mm Modelo 85033D
5 | 7-16 | 7-16 | 7-16 Modelo 85038A
6 | TRL 3,5 mm | TRL 3,5 mm | TRL 3,5 mm Modelo 85052C
7 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 7
8 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 8
9 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 9
10 | Tipo N (h) | Tipo N (m) | Kit de calibración de usuario 10

Nota: Los kits 1-6 tienen definiciones estándar de kit de calibración almacenadas en el analizador.

Activar/desactivar corrección

La función de corrección del analizador se puede activar o desactivar.

  • Cuando está activada (ON), el analizador activa la c orrección de errores, utilizando los datos de calibración más recientes para el parámetro mostrado. La anotación C aparece en la parte inferior de la pantalla, seguida del tipo de calibración actual (por ejemplo, 2-P SOLT ). Véase Validez de una calibración de medida para obtener más información sobre las anotaciones en pantalla relativas a la calibración.

  • Cuando está desactivada (OFF), el analizador desactiva la corrección de errores. La anotación No Cor aparece en la parte inferior de la pantalla.

Propiedades de calibración

La función View Calibration Properties del analizador muestra los siguientes valores para la calibración actual:

  • Canal

  • Frecuencia de parada

  • Fecha de calibración

  • Ancho de banda de IF

  • Indicación de hora

  • Puntos de traza

  • Tipo de calibración

  • Tiempo de barrido

  • Corrección

  • Potencia del puerto 1

  • Interpolación

  • Potencia del puerto 2

  • Frecuencia de inicio

  • Tipo de barrido

Almacenamiento de datos de calibración

  • Durante el procedimiento Cal Wizard, cuando la medida de los patrones de calibración (o módulos) se realiza para el tipo de calibración seleccionado, el conjunto de calibración y el estado del instrumento se guardan automáticamente como un archivo *.cst. Este archivo se puede recuperar utilizando la función de recuperación del analizador.

  • Se puede guardar manualmente el conjunto de calibración únicamente (sin incluir el estado del instrumento) como un archivo *.cal. Este archivo se puede recuperar utilizando la función de recuperación del analizador. Para obtener información sobre la manera de guardar manualmente los datos de calibración, véase Guardar un archivo.

Modificación de datos de calibración actuales

  • Al preajustar el instrumento se recupera el tipo de calibración "None".

  • Al encender el instrumento se recupera el estado del instrumento y su calibración asociada que se estaba utilizando antes de apagarlo. Véase Interruptor de alimentación.

Recuperación de calibraciones de medidas

Nota: Las calibraciones son específicas de canales. Por ejemplo, una calibración realizada en el canal 1 no se puede recuperar en ningún otro canal. Véase Modelo de funcionamiento.

La información de una calibración de medida se vincula con el estado del instrumento en el momento de realizarse la calibración. Un conjunto de calibración se puede recuperar y utilizar para varios estados de instrumento, siempre y cuando el parámetro de medida, el margen de frecuencia y el número de puntos sean compatibles.

  • La recuperación de un estado y un conjunto de calibración (archivo *.cst) recupera el estado de instrumento seleccionado y su calibración asociada desde el disco.

  • La recuperación de un conjunto de calibración (archivo *.cal) recupera la calibración seleccionada desde el disco, pero no el estado de instrumento asociado.

    • Si la configuración actual del analizador coincide exactamente con la utilizada cuando se realizó la calibración, la precisión de la calibración será muy elevada.

    • Cuando la función I nterpolation está activada, si la configuración actual del analizador no coincide exactamente con la utilizada cuando se realizó la calibración, se degradará la precisión de la calibración. Excepción: si el margen de frecuencias actual del analizador es mayor que el utilizado cuando se realizó la calibración, se desactivará la calibración.

    • Cuando la función Interpolation está desactivada, si la configuración actual del analizador no coincide exactamente con la utilizada cuando se realizó la calibración, se desactivará la calibración.

  • La recuperación de un conjunto de estado (archivo *.sta) recupera el estado de instrumento seleccionado desde la memoria, pero no el conjunto de calibración asociado. En cambio, permanece en efecto el conjunto de calibración actual.

    • Si la configuración de analizador recuperada coincide exactamente con la utilizada cuando se realizó la calibración, la precisión de la calibración será muy elevada.

    • Cuando la función Interpolation está activada, si la configuración de analizador recuperada no coincide exactamente con la utilizada cuando se realizó la calibración, se degradará la precisión de la calibración. Excepción: si el margen de frecuencias recuperado del analizador es mayor que el utilizado cuando se realizó la calibración, se desactivará la calibración.

    • Cuando la función Interpolation está desactivada, si la configuración de analizador recuperada no coincide exactamente con la utilizada cuando se realizó la calibración, se desactivará la calibración.

Nota: Para obtener más información sobre la validez de las calibraciones después de modificar la configuración del analizador, véase Validez de una calibración de medida.

Haga clic en un botón para tener acceso a los siguientes procedimientos:
Utilizar el asistente Calibration Wizard
Activar o desactivar la corrección
Ver propiedades de calibración

Utilizar el asistente Calibration Wizard
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Calibration, hacer clic en Calibration Wizard.

Seleccionar un tipo de calibración.

  1. Hacer clic en Cal Type.

  2. Seleccionar el tipo de calibración deseado.

  3. Para calibraciones de 2 puertos, la casilla de verificación Omit Isolation (2-Port types) está seleccionada por defecto. Si se desea incluir la parte del proceso de calibración de 2 puertos correspondiente al aislamiento, hacer clic en la casilla de verificación.

  4. Hacer clic en OK.

Si se desea cambiar los valores de frecuencia del analizador

  1. Hacer clic en Modify.

  2. Introducir el valor o hacer clic en el botón de flecha para seleccionar las frecuencias de inicio y de parada deseadas.

  3. Hacer clic en OK.

Si se desea seleccionar la calibración electrónica

  1. Si no se ha hecho todavía, seguir los puntos "a" - "d" para conectar y calentar el módulo ECal:

    1. Conectar el módulo ECal al conector USB del analizador. (NO conectar el módulo ECal al conector del puerto paralelo.)

    2. Durante el encendido inicial, el módulo permanece en estado de espera (WAIT). Sólo se enciende el indicador LED rojo (piloto WAIT), indicando que el módulo ha iniciado el ciclo de calentamiento. (El indicador LED verde podrá encenderse brevemente.)

    3. Aproximadamente 14 minutos más tarde, se encenderán los indicadores LED rojo y verde. Esto indica que el módulo se está acercando al 95% de su temperatura de servicio interna.

    4. Aproximadamente 1 minuto más tarde, sólo permanecerá encendido el indicador LED verde (piloto READY) y se apagará el indicador LED rojo. Esto indica que el módulo ha alcanzado su temperatura de servicio y está preparado para utilizarse.

  2. Hacer clic en Measure ECal.

    • Hacer clic en la casilla de verificación Show Prompts si se desea incluir indicaciones que guían al usuario a través del proceso ECal.

Nota: El tiempo de calentamiento del módulo ECal podrá variar dependiendo de la temperatura ambiente.

Nota: Si un módulo ha realizado el ciclo de calentamiento y se desconecta temporalmente, pasará del estado WAIT al estado READY en menos tiempo que durante el encendido inicial. Sin embargo, si se intenta utilizar el módulo mientras están encendidos los indicadores LED rojo y verde (95% del tiempo de calentamiento), podrá verse afectada adversamente la calidad de la calibración. Es necesario esperar hasta que el módulo se encuentre en el estado READY (sólo el indicador LED verde encendido) para obtener una calibración especificada en fábrica.

  3. Hacer clic en Module. Realizar la conexión o las conexiones de la manera mostrada en el gráfico.

  4. Hacer clic en OK. En la pantalla aparecerá el cuadro de diálogo Cal Information, mostrando el nombre de archivo y la ruta de acceso del conjunto de calibración y el estado de instrumento que se guardaron.

Nota: Cuando se realiza el proceso de medida del módulo para el tipo de calibración seleccionado, el conjunto de calibración y el estado del instrumento se guardan automáticamente como un archivo *.cst. Este archivo se puede recuperar utilizando la función de recuperación del analizador.

  5. Hacer clic en OK.

Si se desea seleccionar patrones mecánicos

  1. Si se desea utilizar dos conjuntos de patrones en el proceso de calibración, hacer clic en la casilla de verificación Have 2 sets of standards en la parte Use Mechanical Standards del cuadro de diálogo.

  2. Hacer clic en Measure Stds.

    • Hacer clic en la casilla de verificación Show Prompts si se desea incluir indicaciones que guían al usuario a través del proceso de calibración.

  3. Hacer clic en Select Cal Kit.

  4. Seleccionar el tipo de kit de calibración deseado.

  5. Hacer clic en OK.

Si se desea cambiar el kit de calibración asignado al puerto o los puertos del analizador

  1. Hacer clic en Change Port.

  2. En el cuadro Cal Kit ID, introducir el valor o hacer clic en el botón de flecha para seleccionar el número de identificación del kit de calibración deseado. (Los números de identificación 1 - 6 contienen definiciones de kits de calibración predefinidas. Los números de identificación 7 - 10 contienen definiciones de kits de calibración definidas por el usuario.)

  3. En el cuadro Cal Kit Name, editar el nombre del kit de calibración.

  4. En el cuadro Port 1 Model, hacer clic en el botón de flecha para seleccionar el modelo de kit de calibración Agilent deseado para el Puerto 1. Seleccionar el sexo del conector del plano de referencia de medida del Puerto 1.

  5. En el cuadro Port 2 Model, hacer clic en el botón de flecha para seleccionar el modelo de kit de calibración Agilent deseado para el Puerto 2. Seleccionar el sexo del conector del plano de referencia de medida del Puerto 2.

  6. En el cuadro THRU o Adapter, hacer clic en el botón de flecha para seleccionar el cable pasivo o adaptador deseado.

  7. Si en el punto anterior se seleccionó Custom Thru/Adapter:

    1. Hacer clic en Specify Custom Thru/Adapter.

    2. En el cuadro Label, editar la etiqueta.

    3. En el cuadro Z0, introducir el número o hacer clic en los botones de flecha para seleccionar el valor deseado.

    4. En el cuadro Delay, introducir el número o hacer clic en los botones de flecha para seleccionar el valor deseado.

    5. En el cuadro Loss, introducir el número o hacer clic en los botones de flecha para seleccionar el valor deseado.

    6. Hacer clic en OK.

  8. Hacer clic en OK. Aparecerá el cuadro de diálogo Cal Information para confirmar que los nuevos valores se han guardado con el número de identificación de kit de calibración seleccionado. Hacer clic en OK.

Medir los patrones de calibración

  1. Hacer clic en los botones que representan un patrón de calibración (por ejemplo, OPEN, SHORT o LOAD). Realizar la conexión o las conexiones de la manera mostrada en el gráfico.

  2. Hacer clic en OK. En la pantalla aparecerá el cuadro de diálogo Cal Information, mostrando el nombre de archivo y la ruta de acceso del conjunto de calibración y el estado de instrumento que se guardaron.

Nota: Cuando se realiza el proceso de medida de patrones de calibración para el tipo de calibración seleccionado, el conjunto de calibración y el estado del instrumento se guardan automáticamente como un archivo *.cst. Este archivo se puede recuperar utilizando la función de recuperación del analizador.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Cal.

  2. Pulsar F1 (Asistente para calibración).

Seleccionar un tipo de calibración.

  1. En el bloque NAVIGATION, pulsar Click para seleccionar Cal Type.

  2. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el tipo de calibración deseado.

  3. Si se ha seleccionado una calibración de 2 puertos, pulsar la tecla de tabulador a la derecha para seleccionar la casilla de verificación Omit Insolation (2-Port types). Esta casilla aparece seleccionada por defecto. Si se desea incluir la parte del proceso de calibración de 2 puertos correspondiente al aislamiento, pulsar Click.

  4. En el bloque COMMAND, pulsar OK.

Si se desea cambiar los valores de frecuencia del analizador

  1. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para seleccionar Modify.

  2. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para seleccionar las casillas Start y Stop. Introducir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar las frecuencias de inicio y de parada deseadas.

  4. En el bloque COMMAND, pulsar OK.

Si se desea seleccionar la calibración electrónica

  1. Si no se ha hecho todavía, seguir los puntos "a" - "d" para conectar y calentar el módulo ECal:

    1. Conectar el módulo ECal al conector USB del analizador.

    2. Durante el encendido inicial, el módulo permanece en estado de espera (WAIT). Sólo se enciende el indicador LED rojo (piloto WAIT), indicando que el módulo ha iniciado el ciclo de calentamiento.

    3. Aproximadamente 14 minutos más tarde, a 25 °C, se encenderán los indicadores LED rojo y verde. Esto indica que el módulo se está acercando al 95% de su temperatura de servicio interna.

    4. Aproximadamente 1 minuto más tarde, sólo permanecerá encendido el indicador LED verde (piloto READY) y se apagará el indicador LED rojo. Esto indica que el módulo ha alcanzado su temperatura de servicio y está en estado READY.

  2. En el bloque NAVIGATION , pulsar la tecla de tabulador a la derecha o a la izquierda para seleccionar Measure ECal Stds. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Show Prompts. Si se desea incluir indicaciones que guían al usuario a través del proceso ECal, pulsar Click.

  4. Pulsar la tecla de tabulador a la izquierda para seleccionar Module. Pulsar el botón Click y realizar la conexión o las conexiones de la manera mostrada en el gráfico.

  5. En el bloque COMMAND, pulsar OK. En la pantalla aparecerá el cuadro de diálogo Cal Information, mostrando el nombre de archivo y la ruta de acceso del conjunto de calibración y el estado de instrumento que se guardaron.

Nota: Cuando se realiza el proceso de medida del módulo para el tipo de calibración seleccionado, el conjunto de calibración y el estado del instrumento se guardan automáticamente como un archivo *.cst. Este archivo se puede recuperar utilizando la función de recuperación del analizador.

  6. Pulsar OK.

Si se desea seleccionar patrones mecánicos

  1. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Have 2 sets of standards en la parte Use Mechanical Standards del cuadro de diálogo. Si se desea utilizar dos conjuntos de patrones en el proceso de calibración, pulsar Click.

  2. Pulsar la tecla de tabulador a la izquierda para pasar a Measure Stds. Pulsar Click.

    • Pulsar la tecla de tabulador a la izquierda para pasar a la casilla de verificación Show Prompts. Si se desea incluir indicaciones que guían al usuario a través del proceso de calibración, pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a Select Cal Kit. Pulsar Click.

  4. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el tipo de kit de calibración deseado.

  5. En el bloque COMMAND, pulsar OK.

Si se desea cambiar el kit de calibración asignado al puerto o los puertos del analizador

  1. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar a Change Port. Pulsar Click.

  2. En el cuadro Cal Kit ID, introducir el valor o utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar el número de identificación del kit de calibración deseado. (Los números de identificación 1 - 6 contienen definiciones de kits de calibración predefinidas. Los números de identificación 7 - 10 contienen definiciones de kits de calibración definidas por el usuario.)

  3. Pulsar la tecla de tabulador a la derecha para pasar a Cal Kit Name. Editar el nombre del kit de calibración.

  4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Port 1 Model. Utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar el modelo de kit de calibración deseado para el Puerto 1.

  5. Pulsar la tecla de tabulador a la derecha y, a continuación, utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar el sexo del conector del plano de referencia de medida del Puerto 1.

  6. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Port 2. Utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar el modelo de kit de calibración deseado para el Puerto 2.

  7. Pulsar la tecla de tabulador a la derecha y, a continuación, utilizar las teclas de flecha hacia arriba o hacia abajo para seleccionar el sexo del conector del plano de referencia de medida del Puerto 2.

  8. Pulsar la tecla de tabulador a la derecha para pasar al cuadro THRU o Adapter. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el cable pasivo o adaptador deseado.

  9. Si en el punto anterior se seleccionó Custom Thru/Adapter:

    1. Pulsar la tecla de tabulador a la derecha para pasar a Specify Custom Thru/Adapter. Pulsar Click.

    2. Pulsar la tecla de tabulador a la derecha o a la izquierda para pasar al cuadro Label. Editar la etiqueta.

    3. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Z0. Introducir el número o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el valor deseado.

    4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Delay. Introducir el número o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el valor deseado.

    5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Loss. Introducir el número o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el valor deseado.

    6. En el bloque COMMAND, pulsar OK.

  10. Pulsar OK hasta que aparezca el cuadro de diálogo Cal Information para confirmar que los nuevos valores se han guardado con el número de identificación de kit de calibración seleccionado. Pulsar OK.

Medir los patrones de calibración

  1. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha o a la izquierda para desplazarse hasta cada uno de los botones que representan un patrón de calibración (por ejemplo, OPEN, SHORTo LOAD). Pulsar Click. Realizar la conexión o las conexiones de la manera mostrada en el gráfico.

  2. En el bloque COMMAND, pulsar OK. En la pantalla aparecerá el cuadro de diálogo Cal Information, mostrando el nombre de archivo y la ruta de acceso del conjunto de calibración y el estado de instrumento que se guardaron.

Nota: Cuando se realiza el proceso de medida de patrones de calibración para el tipo de calibración seleccionado, el conjunto de calibración y el estado del instrumento se guardan automáticamente como un archivo *.cst. Este archivo se puede recuperar utilizando la función de recuperación del analizador.

  3. Pulsar OK.

Activar o desactivar la corrección

Procedimiento con el ratón

  1. En el menú Calibration, desplazarse a Correction.

  2. El valor por defecto de la corrección es ON (activada).

    • Si se desea activar la corrección, ON, hacer clic en la selección para mostrar Correction ON/off.

    • Si se desea desactivar la corrección, OFF, hacer clic en la selección para mostrar Correction on/OFF.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Cal.

  2. El estado de la función de corrección del analizador aparece en el cuadro verde de la barra de herramientas Active Entry. Para cambiar el estado (por ejemplo, de OFF a ON), pulsar F2 (Corrección activada/desactivada).

Ver propiedades de calibración

Procedimiento con el ratón

  1. En el menú Calibration, hacer clic en Properties.

  2. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Cal.

  2. Pulsar F3 (Propiedades).

  3. En el bloque COMMAND, pulsar Cancel.


Precisión

 * Precisión

Véase asimismo...

Calibraciones precisas de medidas

Descripción general

Conceptos

Procedimientos

Hay varios métodos que contribuyen a asegurar la precisión de las medidas calibración.
Conceptos

Cómo asegurar que las calibraciones de medidas sean precisas

Haga clic en un botón para obtener información acerca de los siguientes temas:
Plano de referencia de medida
Extensiones de puertos
Efectos de la utilización de patrones de calibración erróneos
Calibraciones de dispositivos no insertables

Cable pasivo no caracterizado

Cable pasivo caracterizado

Intercambio de adaptadores idénticos
Parte de aislamiento de una calibración de 2 puertos

Plano de referencia de medida

  • La mayoría de las configuraciones de medida NO permiten conectar un dispositivo sometido a verificación directamente a los conectores del panel frontal del analizador. Lo más probable es que se conectase a cables o dispositivos de pruebas conectados a su vez al analizador.

  • Para obtener la más alta precisión de medida, la calibración debería realizarse en los puntos a los que se conecta el dispositivo. Esto se denomina el plano de referencia de medida (véase el gráfico). Si se calibra en estos puntos, se medirán los errores asociados a la configuración de prueba (cables, dispositivos de pruebas y adaptadores utilizados entre los puertos del analizador y el plano de referencia) y se eliminarán en el proceso de calibración.

Extensiones de puertos

  • Debería utilizarse la característica de extensiones de puertos después de la calibración para compensar el desplazamiento de fase de un plano de referencia de medida ampliado debido a la incorporación de elementos tales como:

    • Cables

    • Adaptadores

    • Dispositivos de pruebas

  • La extensión de p uertos es el método preferido para compensar el desplazamiento de fase de los dispositivos de pruebas.

    • Por ejemplo, los conectores del dispositivo de pruebas podrán ser diferentes de los de los patrones de calibración. Esta situación imposibilitaría la calibración de la longitud eléctrica en el interior del dispositivo de pruebas. La extensión de puertos permite compensar este retardo en el dispositivo de pruebas eliminando el desplazamiento de fase que lo provoca. Sin embargo, la extensión de puertos no compensa la desadaptación y pérdida del dispositivo de pruebas.

  • Los valores de retardo introducidos para las extensiones de puertos se aplicarán de manera automática y apropiada a las medidas tanto de transmisión como de reflexión. Por ejemplo:

    • Cuando se mide S11, el retardo de la extensión del puerto 1 se aplica dos veces (debido al viaje de ida y vuelta).

    • Cuando se mide S21, el retardo de la extensión del puerto 1 y el retardo de la extensión del puerto 2 se aplican una vez cada uno.

  • La extensión de puertos se aplica a todas las medidas asociadas a ese puerto.

Efectos de la utilización de patrones de calibración erróneos

  • Normalmente, una calibración se lleva a cabo utilizando un kit de calibración que contiene patrones con conectores del mismo tipo y sexo que los del dispositivo sometido a verificación.

  • Sin embargo, el kit de calibración podrá no tener el mismo tipo de conector que el del dispositivo. Por ejemplo, el dispositivo podría tener conectores de 3,5 mm y el kit de calibración ser de Tipo N. Por tanto, se utiliza un adaptador para conectar los patrones de Tipo N al puerto de verificación de 3,5 mm.

  • Puesto que el adaptador forma parte de la calibración y NO de la configuración de prueba, esto provocaría errores significativos en las medidas de reflexión.

  • También podrían producirse errores si se utilizan patrones de calibración que no sean los especificados durante el proceso de calibración. El grado de inexactitud dependerá de cuánto difiere el patrón utilizado del patrón especificado.

Para comprobar la precisión de una calibración, véase Validez de una calibración de medida.

Calibraciones de dispositivos no insertables

A continuación se muestra un ejemplo de un dispositivo insertable. El dispositivo dispone de dos conectores de Tipo N, un puerto macho y otro hembra.

  • Cuando se calibra un dispositivo insertable, los puertos de verificación del plano de referencia de medida se conectan directamente entre sí. Es lo que se denomina un cable pasivo de longitud cero. Esto significa que la definición, o descripción eléctrica que el analizador utiliza en el proceso de calibración, tiene una longitud cero y carece de retardo, de pérdida, de capacitancia y de inductancia.

  • El kit de calibración podrá no disponer de un patrón de cable pasivo, porque se da por sentado que se trata de un dispositivo insertable.

Si el dispositivo es no insertable, los puertos de verificación del plano de referencia de medida no se podrán conectar directamente entre sí, como se muestra en el gráfico siguiente. Por consiguiente, se debe utilizar un adaptador para la conexión de cable pasivo. Este adaptador no se incluye en la medida y, por tanto, reduce la exactitud de la misma.

Si se trata de un dispositivo no insertable, deberá elegirse uno de los métodos siguientes al realizar una conexión de cable pasivo durante la calibración. Los métodos figuran en orden ascendente de exactitud (en primer lugar el menos preciso).
Adaptador de cable pasivo no caracterizado
Adaptador de cable pasivo caracterizado
Método de calibración mediante intercambio de adaptadores idénticos

Adaptador de cable pasivo no caracterizado

éste es el método más sencillo, pero menos exacto, para calibrar un dispositivo no insertable. "No caracterizado" significa que el retardo eléctrico y la pérdida del adaptador de cable pasivo no se registran en el analizador.

Aunque el adaptador se utiliza para calibrar el trayecto pasivo, la pérdida y el retardo no se eliminan de las medidas posteriores, porque son desonocidos.

Adaptador de cable pasivo caracterizado

  • "Adaptador de cable pasivo caracterizado" significa que el retardo eléctrico y la pérdida del adaptador de cable pasivo se especifican en la definición del kit de calibración en el analizador.

  • El fabricante del adaptador podrá facilitar el retardo eléctrico y la pérdida del adaptador macho-macho o hembra-hembra. Si no es así, podrá medirse el retardo eléctrico y la pérdida. Sin embargo, se necesitará una calibración exacta para medir el adaptador de cable pasivo, que es a su vez un dispositivo no insertable.

Para caracterizar un adaptador de cable pasivo de alta calidad:

  1. Realizar una calibración utilizando el método de intercambio de adaptadores idénticos (véase la descripción más adelante).

  2. Caracterizar el adaptador de cable pasivo.

  3. Modificar la definición del adaptador de cable pasivo en el kit de calibración utilizando el asistente Cal Wizard. (De esta manera, sólo será necesario realizar una vez la calibración mediante intercambio de adaptadores idénticos.)

  4. Calibrar con el cable pasivo caracterizado.

Nota: El adaptador de cable pasivo caracterizado sólo se utilizará para realizar la calibración del trayecto pasivo, no durante la verificación de los dispositivos. De esta manera se prolonga la vida útil del adaptador de cable pasivo caracterizado. (Cómo se verá en el método de intercambio de adaptadores idénticos, uno de los adaptadores caracterizados se utiliza para verificar cada dispositivo.)

Método de calibración mediante intercambio de adaptadores idénticos

  • El método de calibración mediante intercambio de adaptadores idénticos resulta muy útil para dispositivos con conectores del mismo tipo y sexo (por ejemplo, SMA hembra en ambos extremos).

  • Es necesario utilizar dos adaptadores acoplados con precisión cuyo rendimiento sea idéntico, pero que dispongan de conectores de sexos diferentes.

    • Por ejemplo, para medir un dispositivo con conectores SMA hembra en ambos extremos utilizando cables de verificación APC de 7 mm, los adaptadores podrían ser de 7 mm a macho de 3,5 mm y de 7 mm a hembra de 3,5 mm.

  • Para asegurar que los adaptadores sean idénticos, muchos kits de calibración de Agilent incluyen adaptadores que reúnen las siguientes características idénticas:

    • Impedancia característica

    • Pérdida por inserción

    • Retardo eléctrico

    • Acoplamiento

Descripción general del método de calibración mediante intercambio de adaptadores idénticos

  1. La parte de una calibración de dos puertos correspondiente a la transmisión se lleva a cabo con el adaptador necesario para realizar la conexión de cable pasivo.

  2. Este adaptador se retira entonces y se utiliza en su lugar el segundo adaptador durante la parte de la calibración correspondiente a la reflexión, que se lleva a cabo en ambos puertos de verificación.

  3. Al intercambiar los adaptadores cambia el sexo de uno de los puertos de verificación, de modo que pueda insertarse y medirse el dispositivo de verificación (con el segundo adaptador todavía conectado) una vez finalizado el procedimiento de calibración.

  4. Los errores que quedan después de la calibración son iguales a la diferencia entre los dos adaptadores.

Véase el procedimiento del método de calibración mediante intercambio de adaptadores idénticos.

Parte de aislamiento de una calibración de 2 puertos

  • Cuando se realiza una calibración de 2 puertos, se tiene la opción de omitir la parte de aislamiento de la calibración.

  • La parte de aislamiento de la calibración corrige la d iafonía, la fuga de señales entre los puertos de verificación cuando no hay un dispositivo presente.

  • Debe realizarse una calibación del aislamiento cuando se someta a prueba un dispositivo con elevada pérdida por i nserción. Por ejemplo:

    • Algunas bandas de parada de filtros.

    • Un interruptor en la posición abierta.

  • La calibración del aislamiento añade ruido al modelo de errores, debido a que la medida está muy próxima al límite inferior del ruido del analizador. Para mejorar la precisión de medida:

    • Realizar la calibración del aislamiento sólo cuando sea necesario hacerlo.

    • Utilizar promedios de barrido para contribuir a reducir el ruido.

  • La mejor manera de realizar una calibración del aislamiento consiste en conectar los dispositivos que se desea medir a cada puerto de verificación del analizador, con terminaciones en los otros dos puertos de dispositivos. De esta manera, el analizador estará conectado a la misma impedancia a la que estará conectado durante medidas posteriores de dispositivos.

  • Si el método descrito anteriormente no resulta práctico (en dispositivos de pruebas, o si sólo hay disponible un dispositivo), el siguiente método recomendado consiste en conectar un dispositivo terminado al puerto de la fuente y una terminación al puerto de carga del analizador.

  • Si no hay disponible ningún dispositivo, o si se va a sintonizar el dispositivo (lo cual cambiará sus correspondencias de puertos), deberán conectarse terminaciones a ambos puertos del analizador.

Haga clic en un botón para tener acceso a los siguientes procedimientos:
Utilizar la característica de extensiones de puertos
Caracterizar un adaptador de cable pasivo
Realizar el método de intercambio de adaptadores idénticos

Utilizar la característica de extensiones de puertos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Realizar una calibración en el plano de referencia de medida.

  2. En el menú Calibration, hacer clic en Port Extensions.

  3. Hacer clic en la casilla de verificación Port Extensions para activar la función.

  4. Hacer clic en una casilla Input o Port. Introducir el valor o hacer clic en los botones de flecha para seleccionar el retardo entre el plano de referencia de medida para la entrada (Input) o el puerto (Port) y el dispositivo. A continuación se indica una buena de manera de saber cuándo se ha añadido suficiente retardo:

    1. Conectar un circuito cerrado en lugar del dispositivo de verificación.

    2. Ajustar la extensión de p uertos hasta que la respuesta en fase sea plana. (Conviene recordar que la mayoría de los patrones de cortocircuito tienen un retardo distinto de cero, por lo que al ajustar el retardo mediante este método se producirá un error de retardo igual a dos veces el retardo en corto.)

  5. Hacer clic en la casilla Velocity Factor. Introducir el valor o hacer clic en los botones de flecha para seleccionar el factor de velocidad del medio de transmisión del dispositivo (por ejemplo, un cable o un dispositivo de pruebas) que se insertó después de la calibración. El valor por defecto del factor de velocidad es 1,0, equivalente a la velocidad de la luz en un espacio libre (2,997925 x 10 8 metros por segundo).

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. Realizar una calibración en el plano de referencia de medida.

  2. En el bloque COMMAND , pulsar Menu/Dialog.

  3. En el bloque NAVIGATION, utilizar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Calibration y desplazarse hasta Port Extensions. Pulsar Click.

  4. Para activar la función de extensión de p uertos, pulsar Click.

  5. Pulsar la tecla de tabulador a la derecha para pasar a una casilla Input o Port . Introducir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el retardo entre el plano de referencia de medida para la entrada (Input) o el puerto (Port) y el dispositivo. A continuación se indica una buena de manera de saber cuándo se ha añadido suficiente retardo:

    1. Conectar un circuito cerrado en lugar del dispositivo de verificación.

    2. Ajustar las extensiones de puertos hasta que la respuesta en fase sea plana. (Conviene recordar que la mayoría de los patrones de cortocircuito tienen un retardo distinto de cero, por lo que al ajustar el retardo mediante este método se producirá un error de retardo igual a dos veces el retardo en corto.)

  6. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Velocity Factor . Introducir el factor de velocidad del medio de transmisión del dispositivo (por ejemplo, un cable o un dispositivo de pruebas) que se insertó después de la calibración. El valor por defecto del factor de velocidad es 1,0, equivalente a la velocidad de la luz en un espacio libre (2,997925 x 10 8 metros por segundo).

  7. Pulsar OK.

Caracterizar un adaptador de cable pasivo

  1. Realizar una calibración SOLT completa de 2 puertos utilizando el método de intercambio de adaptadores idénticos. Se selecciona este método porque el dispositivo de verificación (adaptador de cable pasivo) es un dispositivo no insertable.

  2. Medir el retardo del adaptador de cable pasivo a aproximadamente la mitad del recorrido del valor de margen de frecuencias. Registrar el valor de la medida.

  3. Medir la pérdida por i nserción del adaptador de cable pasivo a aproximadamente la mitad del recorrido del valor de margen de frecuencias. Registrar el valor de la medida.

  4. Utilizar estos valores para modificar la definición del adaptador de cable pasivo en el kit de calibración. Para ello, seleccionar Change Port en el asistente Cal Wizard. Véase Seleccionar y realizar una calibración de medida.

  5. Realizar una calibración utilizando el kit de calibración modificado, que ahora contiene el adaptador de cable pasivo caracterizado.

Realizar el método de calibración mediante intercambio de adaptadores idénticos

  1. En el asistente Cal Wizard, seleccionar una calibración SOLT completa de 2 puertos. Para obtener más información sobre el asistente Cal Wizard, véase el apartado "Seleccionar y realizar una calibración de medida".

  2. Conectar el adaptador A entre el Puerto 1 y el Puerto 2, tal y como se muestra en el gráfico siguiente.

  3. Seleccionar Thru en el cuadro de diálogo Measure Mechanical Standards del asistente Cal Wizard.

  4. Retirar el adaptador A del Puerto 1 y el Puerto 2.

  5. Conectar el adaptador B (el que tiene conectores con sexos distintos de los del dispositivo) al puerto apropiado (en este ejemplo, el Puerto 1). Esto se convierte en parte de la configuración de medida. Véase el gráfico siguiente.

  6. Seleccionar Open, Short y Load en el cuadro de diálogo Measure Mechanical Standards del asistente Cal Wizard.

    1. Conectar el patrón seleccionado para el Puerto 1 al adaptador B cuando así se solicite.

    2. Conectar el patrón seleccionado para el Puerto 2 al extremo del cable conectado al Puerto 2 cuando así se solicite.

  7. Medir el dispositivo con el adaptador B conectado, tal y como se muestra en el gráfico siguiente.

Nota: El adaptador B utilizado en la calibración forma parte de la configuración de medida. Es decir, se conectan dispositivos de verificación directamente al mismo, provocando un desgaste en uno de los adaptadores acoplados con precisión. Como alternativa, se puede utilizar el método de intercambio de adaptadores idénticos para caracterizar un adaptador de cable pasivo.


Quest_Cal

Véase asimismo...

Validez de una calibración de medida

Descripción general

Conceptos

Cómo validar una calibración

Podrá haber veces en que se ponga en duda la validez de la calibración de medida. En este tema se explica cómo determinar si los datos de la calibración son válidos y ofrecen el nivel de precisión que se necesita en los resultados de la medida.
Conceptos

Cómo validar una calibración de medida

Haga clic en un botón para obtener información acerca de los siguientes temas.
Sin corrección (No Cor)
Degradación potencial de la corrección de errores (C*)
Validación de la precisión de la calibración

Sin corrección (No Cor)

Si se extiende el recorrido de frecuencias del analizador, la calibración actual dejará de ser válida y se desactivará la c orrección de errores (aunque la función Interpolation esté activada). El analizador indica este estado de no corrección mostrando "No Cor" en la barra de estado.

Degradación potencial de la corrección de errores (C*)

Interpolation

La función Interpolation está activada por defecto. Si se cambia cualquiera de los siguientes valores de medida, podrá degradarse la calidad de la calibración actual. El analizador indica este estado de corrección de errores mostrando "C*" en la barra de estado.

  • Margen de frecuencias reducido

  • Menor número de puntos

Con la función Interpolation activada, el analizador calcula la corrección de errores para los nuevos valores a partir de los términos de error originales. La cantidad de degradación de la precisión de la medida depende de la cantidad de cambio de amplitud y de desplazamiento de fase entre los puntos de medida. Cuanto menor sea el cambio, mejor será la corrección de errores interpolada. Sin embargo, el rendimiento del sistema no se puede especificar cuando se utiliza la corrección de errores interpolada.

Nota: Cuando aparece " C*" en la barra de estado, la validez de la calibración es dudosa. Para determinar si se trata de un problema, se puede comparar una traza de medida realizada con la calibración original (cuando aparece "C" en la barra de estado) con la traza de la medida actual (cuando aparece " C*" en la barra de estado). Dependiendo de la diferencia de precisión entre ambas trazas y de la necesidad de precisión de la aplicación de medida, se podrá determinar si la calibración satisface las necesidades del usuario. Véase el apartado "Validación de la precisión de la calibración".

Si la función Interpolation está desactivada y se cambian los valores enumerados anteriormente, la calibración actual dejará de ser válida y se desactivará la corrección de errores. El analizador indica este estado de no corrección mostrando "No Cor" en la barra de estado.

Corrección de errores dudosa

Si se cambia cualquiera de los siguientes valores de medida, se podrá degradar la calidad de la calibración actual porque no hay ningún algoritmo correspondiente en el analizador para la corrección de errores. El analizador también indica si una calibración es dudosa mostrando "C*" en la barra de estado.

  • Tiempo de barrido

  • Ancho de banda de IF

  • Potencia/atenuación

  • Barrido por pasos activado/desactivado

Nota: La corrección de errores de más alta calidad sólo es aplicable para el nivel de potencia al que se realizó una calibración de medida. Sin embargo, si se cambia la potencia en el mismo margen de atenuador al que se realizó la calibración de medida, se podrán realizar medidas de parámetros S con tan sólo una pequeña degradación de la precisión. Si se selecciona un margen de atenuador diferente, se degradará incluso más la calidad de la corrección de errores.

Validación de la precisión de la calibración

Se puede validar la precisión de una calibración utilizando cualquiera de los dos métodos siguientes.

  1. Después de realizar una calibración, efectuar una conexión de cable pasivo y guardar la traza de la medida en la memoria interna del analizador o en un disquete. Más adelante, recuperar la traza y compararla con la traza de la medida actual (utilizando los mismos cables y la misma conexión de cable pasivo empleados antes). Para aumentar la precisión de la medida, hacer lo siguiente y observar la diferencia resultante:

    • Realizar datos/memoria para medidas de transmisión.

    • Realizar datos-memoria para medidas de reflexión.

Nota: La recuperación de l íneas límite es una manera rápida de comprobar si la calibración se encuentra dentro de las tolerancias definidas (y, por tanto, si es válida).

  2. Comprobación rápida

  • Podrá haber veces en que se ponga en duda la validez de una calibración realizada y se considere la posibilidad de repetirla para asegurar su exactitud. Antes de dedicar tiempo a repetir una calibración, se puede realizar el proceso de comprobación rápida. La brevedad de una comprobación rápida puede ahorrar bastante tiempo, suponiendo que la calibración siga siendo válida.

  • Para verificar la calidad de una calibración, podrá realizarse una comprobación rápida inmediatamente después de la calibración.

  • Si estas comprobaciones indican la existencia de problemas repetidos después de realizar calibraciones, realizar la verificación completa utilizando un kit de verificación (véase la Guía de Servicio).

Nota: Los patrones de calibración de circuitos cerrados y abiertos tienen una cierta cantidad de retardo eléctrico. El analizador contrarresta este retardo, compensando los resultados de la calibración con la cantidad de retardo eléctrico. Por consiguiente, si se mide un patrón después de calibrar, el patrón no parecerá ser un circuito cerrado o abierto con un desplazamiento de longitud cero. Esto indica que el analizador está funcionando correctamente.

Haga clic en un botón para tener acceso a los siguientes procedimientos:
Comprobación rápida
Activar o desactivar Interpolation

Nota: En los procedimientos siguientes, un puerto se refiere al puerto en el plano de referencia. de medida. Para obtener información acerca del plano de referencia de medida, véase el apartado "Calibraciones precisas de medidas".

Comprobación rápida

Comprobar medidas de reflexión

Nota: En este procedimiento se describe la realización de medidas S11 en el puerto 1. El mismo procedimiento general es aplicable a la realización de medidas S22 en el puerto 2.

Nota: No deben utilizarse los mismos patrones de calibración que se usaron para realizar la calibración original. Las medidas de estos mismos patrones sólo verifican la repetibilidad de las correcciones realizadas durante la calibración original.

  1. Dejar el puerto 1 desconectado (sin un patrón de calibración conectado) y verificar que la magnitud de S11 es próxima a 0 dB (con un margen de aproximadamente ± 1 dB).

  2. Conectar un patrón de calibración de carga al puerto 1. La magnitud de S11 debería ser normalmente inferior a -30 dB - -40 dB, dependiendo de la carga.

  3. Conectar un patrón de calibración de circuito abierto o cerrado al puerto 1. La magnitud de S11 debería ser próxima a 0 dB (con un margen de unas décimas de dB).

Comprobar medidas de transmisión

Nota: En este procedimiento se describe la realización de medidas S21. El mismo procedimiento general es aplicable a la realización de medidas S12.

  1. Realizar una conexión de cable pasivo entre el puerto 1 y el puerto 2. La magnitud de S21 debería ser próxima a 0 dB (con un margen de unas décimas de dB).

  2. Para verificar el aislamiento de S21 , conectar dos cargas: una al puerto 1 y otra al puerto 2. La magnitud de S21 debería ser inferior a -60 dB, dependiendo del ancho de banda de IF.

Activar o desactivar Interpolation
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Calibration, desplazarse a Interpolation.

  2. El valor por defecto es i nterpolación ON (activada).

  3. Si se desea activar la interpolación, ON, hacer clic en la selección para mostrar Interpolation ON/off.

  4. Si se desea desactivar la interpolación, OFF, hacer clic en la selección para mostrar Interpolation on/OFF.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha para pasar al menú Calibration.

  3. Pulsar la tecla hacia abajo para desplazarse a Interpolation.

  4. El valor por defecto de la interpolación es ON (activada).

  5. Si se desea activar la interpolación, ON, pulsar Click para mostrar Interpolation ON/off.

  6. Si se desea desactivar la interpolación, OFF, pulsar Click para mostrar Interpolation on/OFF.


Véase asimismo...

Marcadores

Descripción general

Tipos de
marcadores

Funciones de
marcadores

Cómo
activar y
cambiar

Cómo
buscar

Los marcadores ofrecen una lectura numérica de los datos medidos, buscan valores específicos y cambian la configuración de los estímulos. En este tema se tratan todos los aspectos relativos a los marcadores.
Tipos de marcadores, marcadores de referencia y búsqueda
Funciones de marcador, marcadores discretos y visualización
Cómo activar, cambiar configuración, visualización y formato
Cómo buscar y utilizar marcadores relativos

Se pueden tener hasta 10 marcadores por traza de medida.
Tipos de marcadores

Normal

Fijo
Marcador de referencia
Búsqueda de marcadores

Tipos de búsquedas

¿Qué es un "pico"?

Dominio de búsqueda

Ejecución de una búsqueda

Tipos de marcadores

Hay dos tipos de marcadores: normal y fijo.

Normal

Un marcador normal tiene una posición de estímulo fija (eje X en el formato rectangular) y responde a los cambios de amplitud de datos (eje Y). Puede desplazarse hacia la izquierda y hacia la derecha en el eje X cambiando el valor de estímulo del marcador. Este tipo de marcador se puede utilizar con uno de los tipos de búsqueda de marcador para localizar los datos deseados.

Fijo

Un marcador fijo tiene una posición fija para los datos (eje Y en el formato rectangular) basada en su ubicación inicial en la traza y no se mueve con la amplitud de los datos de la traza. Puede desplazarse hacia la izquierda y hacia la derecha en el eje X (en el formato rectangular) cambiando el valor de estímulo del marcador, pero su posición en el eje Y se mantendrá en su valor inicial. Este tipo de marcador se puede utilizar para monitorizar rápidamente los cambios "anteriores y posteriores" realizados en el dispositivo de verificación. Por ejemplo, se pueden utilizar marcadores fijos para registrar la diferencia de los resultados de la verificación obtenidos antes y después del ajuste de un filtro.

Marcadores de referencia

Se pueden visualizar datos en relación con una posición de referencia.

  • En primer lugar, se coloca un marcador de referencia en la primera posición.

  • A continuación, se coloca un segundo marcador ( marcador Delta) en la siguiente posición.

Los datos y la información del estímulo presentados para el marcador delta se muestran en relación con los datos y el estímulo del marcador de referencia.

Un marcador de referencia puede ajustarse desde el menú y cuadro de diálogo Marker o desde la barra de herramientas de marcadores. También se puede utilizar comandos S CPI o COM.

Nota: Si se crea un marcador delta sin activar antes el marcador de referencia, el analizador activará automáticamente el marcador de referencia dedicado. Pero seguirá siendo necesario colocar el marcador de referencia en la posición deseada.

Búsquedas con marcadores

Se pueden utilizar marcadores para buscar datos de medida con criterios específicos.

Tipo de búsqueda

Hay siete tipos de búsqueda de marcadores.

  • M ax im um:

El marcador localiza el valor de datos de amplitud más elevado

  • Minim um:

El marcador localiza el valor de datos de amplitud más reducido

  • Next Peak:

El marcador localiza el pico con el siguiente valor de amplitud más reducido, en relación con su posición inicial.
(Véase la sección "¿Qué es un "pico"?")

  • Peak Left:

El marcador localiza el siguiente pico válido a la izquierda de su posición inicial en el eje X (pantalla rectangular).
(Véase la sección "¿Qué es un "pico"?")

  • Peak Right:

El marcador localiza el siguiente pico válido a la derecha de su posición inicial en el eje X (en formato de pantalla rectangular).
(Véase la sección "¿Qué es un "pico"?")

  • Target Search:

E l marcador localiza el punto de datos que coincide con el valor de datos objetivo que se especifique.

    • Si Discrete Marker está desactivado (OFF), el marcador localiza el punto de datos interpolado que es igual al valor objetivo.

    • Si Discrete Marker está activado (ON) y hay dos puntos de datos a cada lado del valor objetivo, el marcador localiza punto de datos más próximo al valor objetivo.

El marcador encontrará el valor objetivo más próximo a la derecha de su posición actual. Si se pulsa posteriormente el botón Execute , el marcador se desplazará al siguiente valor de la derecha que coincida con el valor objetivo. Cuando el marcador alcance el extremo superior del margen de estímulo, volverá al principio y continuará la búsqueda desde el extremo inferior del margen de estímulo (lado izquierdo de la ventana).

  • Bandwidth:

El marcador localiza el ancho de banda alrededor del pico que tiene valores de amplitud de datos superiores al valor de umbral (dB) por debajo del nivel de pico (Datos > Pico - Umbral).

Este tipo de búsqueda siempre utiliza los marcadores 1-4.
Marcador 1: Pico
Marcador 2: El valor de umbral por debajo del pico, a la izquierda del pico
Marcador 3: El nivel de umbral por debajo del pico, a la derecha del pico
Marcador 4: Frecuencia central del ancho de banda

Esta búsqueda de ancho de banda se realizó para encontrar el ancho de banda de 3 dB de un filtro. El umbral de la búsqueda fue de 3,00 dB (3,00 dB por debajo del valor de pico de la banda de paso).

Nota: Si no hay una coincidencia válida de datos para cualquiera de los tipos de búsqueda de pico o de objetivo, el marcador no se moverá de su posición actual.

¿Qué es un "pico"?

Lo que el analizador considera un "pico" se define mediante la selección de los dos valores de criterios de picos siguientes:

  • Umbral - Amplitud mínima (dB). Para que se considere válido, el pico debe ser superior al nivel de umbral. El valle a cada lado puede hallarse por debajo del nivel de umbral

  • Excursión - La distancia vertical (dB) entre el pico y los valles a ambos lados. Para que se consideren un pico, los valores de datos deben "caer" del pico a ambos lados en una magnitud igual al valor de excursión.

Ejemplo:

Valor de umbral: -10 dB
Valor de excursión: 1 dB
Escala = 1 dB / División
Pico A = Pico válido (por encima de los valores de umbral y de excursión)
Pico B = Pico no válido (por debajo del valor de excursión)
Pico C = Pico no válido (por debajo del valor de umbral)

Dominio de búsqueda

La configuración del dominio de búsqueda limita los valores de estímulo que se están buscando en el eje X (en el formato rectangular) a un recorrido específico. Establecer los ajustes de estímulo de inicio y de parada de estos recorridos de usuario. Si el valor de inicio es superior al valor de parada, el marcador no se moverá. En el gráfico que aparece a continuación se muestran ejemplos de dominios de búsqueda.

  • El dominio por defecto de cada nuevo marcador es "recorrido completo".

  • Hay 9 dominios definidos por el usuario para cada canal.

  • Los dominios definidos por el usuario pueden solaparse.

  • Más de un marcador puede utilizar un dominio definido.

Ejecutar una búsqueda

Se debe pulsar el botón Execute para iniciar una búsqueda de marcador. El botón Execute debe utilizarse con todos los tipos de búsquedas.

También se puede activar la casilla Tracking para "pulsar" el botón Execute después de cada barrido; de esta forma, se actualiza continuamente la búsqueda.

Nota : Las búsquedas comienzan con el primer barrido después de haber activado la casilla Tracking, en función del tipo de búsqueda y la información de dominio introducida en ese momento. Cuando Tracking esté activado, asegurarse de que el estado de los criterios de búsqueda es el deseado antes de utilizar los datos.

Nota : No se puede cambiar manualmente el ajuste de estímulo de un marcador si está seleccionado Tracking para dicho marcador.

Haga clic en los botones para mostrar la información.
Funciones de marcador

Start

Stop

Center

Span

Ref Level

Delay
Marcadores discretos
Visualización de marcadores

Formato de datos del marcador

Tabla de marcadores

Funciones de marcador - Cambiar configuración del instrumento

Se pueden cambiar los siguientes valores del instrumentos utilizando marcadores:

Start:

El valor de estímulo (posición del eje X en el formato rectangular) del marcador activo se convierte en el valor de estímulo de inicio (frecuencia, tiempo o potencia).

Stop:

El valor de estímulo (posición del eje X en el formato rectangular) del marcador activo se convierte en el valor de estímulo de parada (frecuencia, tiempo o potencia).

Center:

El valor de estímulo (posición del eje X en el formato rectangular) del marcador activo se convierte en el ajuste de estímulo central (frecuencia, tiempo o potencia). El recorrido permanece igual; los valores Start y Stop cambian en consecuencia.

Span:

Disponible sólo cuando el marcador activo es un marcador delta. La diferencia de valores de estímulo (posiciones del eje X en el formato rectangular) que existe entre ambos marcadores se convierte en el valor de estímulo de recorrido. El valor de marcador inferior se convierte en el valor de inicio y el valor de marcador superior, en el valor de parada. (Esta función sólo se puede seleccionar desde el cuadro de diálogo Marker Functions o desde la barra de herramientas de marcadores.)

Ref Level:

El nivel de datos (posición del eje Y en el formato rectangular) del marcador activo se convierte en el nivel de la línea de referencia de la ventana.

Delay:

La pendiente de fase en la posición del estímulo del marcador activo se utiliza para ajustar la longitud de línea a la entrada del receptor. Esto aplana la traza de fase en torno al marcador activo. (Se necesitan ajustes adicionales de retardo eléctrico en dispositivos sin retardo de grupo constante a lo largo del recorrido de frecuencias medido.) Esto se puede utilizar para medir la longitud eléctrica o la desviación respecto de la fase lineal.

Esta función añade retardo de fase a una variación en la fase con respecto a la frecuencia; por lo tanto, sólo es aplicable a medidas relacionadas. (Véase Parámetros de medida.)

El marcador activo aparece en la pantalla del analizador como ñ. El resto de los marcadores aparecen inactivos y están representados en la pantalla del analizador como D.

Discrete Marker

  • Si Discrete Marker está desactivado (OFF), el marcador localiza el punto de datos interpolado del valor de estímulo especificado.

  • Si Discrete Marker está activado (ON), el marcador localiza el punto de datos real más próximo al valor de estímulo especificado.

Nota: El valor de estímulo puede cambiar respecto del valor especificado cuando Discrete Marker esté activado (ON).

Visualización de marcadores

Se puede cambiar el modo en el que aparece la información.

Formato de datos del marcador

El formato predeterminado de los datos de lectura de los marcadores es el mismo formato que el de la traza (valor predeterminado de traza). También se pueden visualizar los datos de lectura de los marcadores en uno de los 12 formatos, independientemente del formato de pantalla actual. Esto podría ayudar a simplificar la configuración de la medida, reduciendo el número de ventanas de medida necesarias. Las opciones de formato son:

  • Trace Default

  • Log / Phase

  • Lin / Phase

  • Re / Im

  • R + jX

  • G + jB

  • Log Magnitude

  • Linear Magnitude

  • Phase

  • SWR

  • Delay

  • Real

  • Imaginary

En la siguiente figura se muestran marcadores con diferentes formatos de datos.

Tabla de marcadores

Se puede visualizar una tabla que ofrece un resumen de los datos de marcador de la traza activa. Los datos de marcador aparecen en el formato especificado para cada marcador, como se muestra en la figura anterior.

Haga clic en los botones para acceder a los procedimientos.
Activar un marcador
Cambiar la configuración del analizador
Visualizar los datos del marcador
Cambiar el formato de datos del marcador

Activar un marcador
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Seleccionar la traza deseada haciendo clic en la misma en la zona Trace Status de la ventana. (Véase Personalizar la pantalla del analizador para obtener información sobre la visualización de Trace Status.)

  2. En el menú Marker, hacer clic en Marker.

  3. En la parte Marker del cuadro de diálogo, seleccionar el número del marcador.

  4. Hacer clic en la casilla On para activar el marcador seleccionado.

  5. En la parte Stimulus del cuadro de diálogo, introducir la posición de marcador deseada.

  6. Hacer clic en el botón Advanced. (los pasos 6 a 9 son opcionales)

  7. Elegir el Marker Type:

    • Normal (por defecto)

    • Fixed

  8. Elegir el comportamiento del marcador, con el cuadro Discrete Marker:

    • Interpolated (por defecto, la casilla aparece desactivada)

    • Discrete

  9. Hacer clic en OK.

Nota: Los marcadores también se pueden activar con la barra de herramientas de marcadores siguiendo los pasos 1, 3, 4 y 5 del procedimiento anterior. (Véase Personalizar la pantalla del analizador para obtener información sobre la barra de herramientas de marcadores.)

Procedimiento con las teclas del panel frontal

  1. Seleccionar la traza deseada pulsando Trace en el bloque DISPLAY. Pulsar F2 (Traza siguiente) hasta que la traza deseada aparezca seleccionada.

  2. En el bloque TRACE SETUP, pulsar Marker.

  3. Pulsar F1 (Marcador 1) o F2 (Marcador 2) o F3 (Marcador 3) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la posición de marcador deseada.

  4. Para definirmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP.

  5. Pulsar F1 (Marcador 4) o F2 (Marcador 5) o F3 (Marcador 6) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la posición de marcador deseada.

  6. Para definirmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP.

  7. Pulsar F1 (Marcador 7) o F2 (Marcador 8) o F3 (Marcador 9) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la posición de marcador deseada.

Para establecer el tipo de marcador (normal o fijo) y el comportamiento del marcador (interpolado o discreto):

  1. En el bloque COMMAND pulsar el botón Menu/Dialog. Pulsar Marker en el bloque TRACE SETUP.

  2. Pulsar la tecla de tabulador a la derecha para seleccionar el botón Advanced en el cuadro de diálogo Marker. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para seleccionar la casilla Discrete Marker. Pulsar Click para seleccionar el comportamiento de marcador Discrete (el valor predeterminado es Interpolated).

  4. Pulsar la tecla de tabulador a la derecha para seleccionar la casilla Marker Type. Pulsar la tecla de flecha hacia abajo para seleccionar Fixed (el valor predeterminado es Normal).

  5. En el bloque COMMAND, pulsar OK.

Cambiar la configuración del analizador con marcadores
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Seleccionar la traza deseada haciendo clic en la misma en la zona Trace Status de la ventana. (Véase Personalizar la pantalla del analizador para obtener información sobre la visualización de Trace Status)

  2. En el menú Marker, hacer clic en Select Marker. Hacer clic en el número de marcador deseado.

  3. En el menú Marker, hacer clic en Marker Function.

  4. Hacer clic en la función del analizador que se desea cambiar:

    • Start

    • Stop

    • Center

    • Ref Level

    • Delay

  5. Hacer clic en OK.

Nota: La configuración del analizador también se puede cambiar con la barra de herramientas de marcadores (Start, Stop, Centery Span únicamente). (Véase Personalizar la pantalla del analizador para obtener información sobre la barra de herramientas de marcadores.)

Procedimiento con las teclas del panel frontal

  1. Seleccionar la traza deseada pulsando Trace en el bloque DISPLAY. Pulsar F2 (Traza siguiente) hasta que la traza deseada aparezca seleccionada.

  2. En el bloque TRACE SETUP, pulsar Marker.

  3. Pulsar F1 (Marcador 1) o F2 (Marcador 2) o F3 (Marcador 3) para seleccionar el marcador deseado.

  4. Para seleccionarmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP. Pulsar F1 (Marcador 4) o F2 (Marcador 5) o F3 (Marcador 6) para seleccionar el marcador deseado.

  5. Para seleccionarmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP. Pulsar F1 (Marcador 7) o F2 (Marcador 8) o F3 (Marcador 9) para seleccionar el marcador deseado.

  6. En el bloque TRACE SETUP, pulsar el botón Marker Function.

  7. Seleccionar la función que se desea cambiar:

    • F1 (Centro)

    • F2 (Nivel de referencia)

    • F3 (Retardo)

Para definir otras funciones de m arcador (Start o Stop):

  1. En el bloque COMMAND, pulsar el botón Menu/Dialog. Pulsar Marker Function en el bloque TRACE SETUP.

  2. Pulsar la tecla de tabulador a la derecha para seleccionar la función de marcador deseada.

  3. En el bloque COMMAND, pulsar OK.

Visualizar los datos del marcador
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Marker, hacer clic en Marker Table.

  2. Hacer clic en Show Table.

Nota: La tabla de marcadores y la lectura de marcador también se pueden activar desde el menú View. (Véase Personalizar la pantalla del analizador.)

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar el botón Marker Table.

  2. Pulsar F4 (Ocultar) para ocultar la tabla de marcadores.

Cambiar el formato de datos del marcador
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Seleccionar la traza deseada haciendo clic en la misma en la zona Trace Status de la ventana. (Véase Personalizar la pantalla del analizador para obtener información sobre la visualización de Trace Status.)

  2. En el menú Marker, hacer clic en Marker. A continuación, hacer clic en Advanced.

  3. En la parte Marker del cuadro de diálogo, seleccionar el número de marcador deseado.

  4. En la parte Format del cuadro de diálogo, seleccionar el formato de datos de marcador deseado.

  5. Hacer clic en OK.

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar el botón Menu/Dialog. Pulsar Marker en el bloque TRACE SETUP.

  2. Pulsar la tecla de tabulador a la derecha para seleccionar el botón Advanced en el cuadro de diálogo Marker. Pulsar el botón Click.

  3. Pulsar la tecla de flecha hacia abajo del bloque NAVIGATION para seleccionar el número de marcador deseado.

  4. Pulsar la tecla de tabulador a la derecha para seleccionar la casilla Format. Pulsar la tecla de flecha hacia abajo para seleccionar el formato de marcador deseado.

  5. En el bloque COMMAND, pulsar OK.

  6. En el bloque COMMAND, pulsar OK.

.

Haga clic en los botones para acceder a los procedimientos.
Buscar datos
Realizar medidas relativas

Buscar datos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Seleccionar la traza deseada haciendo clic en la misma en la zona Trace Status de la ventana. (Véase Personalizar la pantalla del analizador para obtener información sobre la visualización de Trace Status.)

  2. En el menú Marker, hacer clic en Marker Search.

  3. En la parte Marker del cuadro de diálogo, seleccionar el número de marcador deseado.

  4. En la parte Search Type del cuadro de diálogo, seleccionar el tipo de búsqueda deseado.

    • En Next Peak, Peak Left o Peak Right: introducir el nivel de umbral y el nivel de excursión.

    • En Target, introducir el valor objetivo.

    • En Bandwidth, introducir el nivel.

  5. En la parte Search Domain del cuadro de diálogo, seleccionar el dominio de búsqueda deseado. Si está seleccionado un dominio de búsqueda que no sea Full Span (valor predeterminado), aparecerá la zona User Span del cuadro de diálogo. Introducir los valores de inicio y de parada deseados para el recorrido del usuario.

  6. Para iniciar la búsqueda:

    • Manualmente - hacer clic en el botón Execute.

    • Automáticamente - hacer clic en la casilla Tracking. (Las búsquedas se realizan cuando cambian los datos marcados por el marcador.)

  7. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. Seleccionar la traza deseada pulsando Trace en el bloque DISPLAY. Pulsar F2 (Traza siguiente) hasta que la traza deseada aparezca seleccionada.

  2. Pulsar F1 (Marcador 1) o F2 (Marcador 2) o F3 (Marcador 3) para seleccionar el marcador deseado.

  3. Para seleccionarmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP. Pulsar F1 (Marcador 4) o F2 (Marcador 5) o F3 (Marcador 6) para seleccionar el marcador deseado.

  4. Para seleccionarmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP. Pulsar F1 (Marcador 7) o F2 (Marcador 8) o F3 (Marcador 9) para seleccionar el marcador deseado.

  5. En el bloque TRACE SETUP, pulsar Marker Search.

  6. Seleccionar el tipo de búsqueda deseado:

    • F1 (Máx)

    • F2 (Mín)

    • F3 (Pico izquierdo)

    • F4 (Pico derecho)

Para definir parámetros adicionales de búsqueda de marcadores:

  1. En el bloque COMMAND, pulsar el botón Menu/Dialog. Pulsar Marker Search en el bloque TRACE SETUP.

  2. Pulsar la tecla de flecha hacia abajo para seleccionar el número de marcador deseado.

  3. Pulsar la tecla de tabulador a la derecha para seleccionar la zona Search Type del cuadro de diálogo Marker. Pulsar la tecla de flecha hacia abajo para seleccionar el tipo de búsqueda deseado. Pulsar la tecla de tabulador a la derecha para acceder al cuadro o los cuadros de entrada del tipo de búsqueda seleccionado:

    • En Next Peak, Peak Left o Peak Right: introducir el nivel de umbral y el nivel de excursión.

    • En Target, introducir el valor objetivo.

    • En Bandwidth, introducir el nivel de umbral.

  4. Pulsar la tecla de tabulador a la derecha para seleccionar la zona Search Domain del cuadro de diálogo Marker. Pulsar la tecla de flecha hacia abajo para seleccionar el dominio de búsqueda deseado.

    • Si se selecciona un dominio de búsqueda que no sea Full Span (valor predeterminado), aparecerá la zona User Span del cuadro de diálogo. Pulsar la tecla de tabulador a la derecha para acceder a la zona User Span, e introducir los valores de inicio y de parada deseados.

  5. Para iniciar la búsqueda, pulsar la tecla de tabulador a la derecha para acceder a una de las siguientes opciones. Pulsar el botón Click para seleccionarlo:

    • Manualmente - hacer clic en el botón Execute.

    • Automáticamente - hacer clic en la casilla Tracking. (Las búsquedas se realizan cuando cambian los datos marcados por el marcador.)

  6. En el bloque COMMAND, pulsar OK.

Realizar medidas relativas con marcadores de referencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Seleccionar la traza deseada haciendo clic en la misma en la zona Trace Status de la ventana. (Véase Personalizar la pantalla del analizador para obtener información sobre la visualización de Trace Status.)

  2. En el menú Marker, hacer clic en Marker.

  3. En la parte Marker del cuadro de diálogo, seleccionar Reference.

  4. Hacer clic en la casilla On para activar el marcador de referencia.

  5. En la parte Stimulus del cuadro de diálogo, introducir la posición de marcador de referencia deseada.

  6. En la parte Marker del cuadro de diálogo, seleccionar el número de marcador para las medidas en relación con el marcador de referencia.

  7. Hacer clic en la casilla On para activar el marcador.

  8. Hacer clic en la casilla Delta Marker para activar este marcador para datos de medida en relación con el marcador de referencia.

Para definir el comportamiento del marcador (interpolado o discreto) para marcadores Delta y de referencia:

  1. Hacer clic en el botón Advanced del cuadro de diálogo Marker.

  2. En la parte Marker del cuadro de diálogo, seleccionar Reference.

  3. Elegir el comportamiento del marcador, con el cuadro Discrete Marker:

    • Interpolated (por defecto, la casilla aparece desactivada)

    • Discrete

  4. En la parte Marker del cuadro de diálogo, seleccionar el número de marcador del marcador delta

  5. Repetir el paso 3.

  6. Hacer clic en OK.

  7. Hacer clic en OK.

Nota: Los marcadores también se pueden activar para medidas relativas con la barra de herramientas de marcadores. (Véase Personalizar la pantalla del analizador para obtener información sobre la barra de herramientas de marcadores.)

Procedimiento con las teclas del panel frontal

  1. Seleccionar la traza deseada pulsando Trace en el bloque DISPLAY. Pulsar F2 (Traza siguiente) hasta que la traza deseada aparezca seleccionada.

  2. En el bloque TRACE SETUP, pulsar Marker.

  3. Pulsar F1 (Marcador 1) o F2 (Marcador 2) o F3 (Marcador 3) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la posición de marcador deseada.

  4. Para definirmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP.

  5. Pulsar F1 (Marcador 4) o F2 (Marcador 5) o F3 (Marcador 6) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la posición de marcador deseada.

  6. Para definirmarcadores adicionales, pulsar de nuevo Marker en el bloque TRACE SETUP.

  7. Pulsar F1 (Marcador 7) o F2 (Marcador 8) o F3 (Marcador 9) y escribir el valor o pulsar los botones de flecha arriba o hacia abajo para establecer la posición de marcador deseada.

Para definir el comportamiento del marcador (interpolado o discreto):

  1. En el bloque COMMAND, pulsar el botón Menu/Dialog. Pulsar Marker en el bloque TRACE SETUP.

  2. Pulsar la tecla de tabulador a la derecha para seleccionar el botón Advanced en el cuadro de diálogo Marker. Pulsar el botón Click.

  3. Pulsar la tecla de flecha hacia arriba para seleccionar el marcador Reference.

  4. Pulsar la tecla de tabulador a la derecha para seleccionar la casilla Discrete Marker. Pulsar Click para seleccionar el comportamiento de marcador Discrete (el valor predeterminado es Interpolated).

  5. Pulsar de nuevo la tecla de tabulador a la derecha para seleccionar la casilla Marker. Pulsar la tecla de flecha hacia abajo para seleccionar el número de marcador del marcador delta.

  6. Pulsar la tecla de tabulador a la derecha para seleccionar la casilla Discrete Marker. Pulsar Click para seleccionar el comportamiento de marcador Discrete (el valor predeterminado es Interpolated).

  7. En el bloque COMMAND, pulsar OK.


Véase asimismo...

Utilizar límites para someter a prueba dispositivos

Descripción general

Conceptos

Cómo
limitar pruebas

Los límites son parámetros de rendimiento que se definen para someter a prueba un dispositivo. Las líneas límite y las pruebas de límites permiten comparar datos de medida con estas restricciones definidas.
Conceptos

Cómo configurar y ejecutar pruebas de límites

Límites

Tabla de límites
Líneas límite
Pruebas de límites

Límites

Los límites se definen de la siguiente manera:

  • En segmentos, donde cada segmento constituye una parte del recorrido de estímulo.

  • Como límites Máximo o Mínimo, o ajustados a OFF .

  • Con valores de estímulo iniciales y finales para cada segmento de límite.

  • Con valores de respuesta iniciales y finales para cada segmento de límite.

  • Independientemente para un máximo de 16 medidas, con un máximo de 100 segmentos para cada medida.

Tabla de límites

Los límites se definen, modifican, activan y visualizan con una tabla de límites.

Líneas límite

Las líneas límite son representaciones visuales de los límites especificados para un canal mostradas en la pantalla del analizador. Se pueden utilizar líneas límite para:

  • Ofrecer al operador consejos visuales cuando se sintonizan dispositivos

  • Proporcionar criterios estándar para ajustarse a las especificaciones del dispositivo

  • Mostrar la comparación de los datos frente a las especificaciones

Se pueden crear líneas límite que sean:

  • Planas

  • En pendiente

  • De punto único

Se pueden mostrar líneas límite en la pantalla o bien ocultar dichas líneas. Cuando se muestran las líneas límite:

  • Las trazas de medida aparecen en color verde (el color típico de las trazas de medida es el verde)

  • Las líneas límite aparecen en color naranja

Nota: Los límites especificados siguen siendo válidos aunque no se muestren las líneas límite.

Pruebas de límites

La prueba de límites compara los datos medidos con los límites definidos y proporciona información de Superado o Fallido para cada punto de datos medido.

Los límites sólo se comprueban en los puntos de datos medidos reales. Es posible que un dispositivo no se ajuste a las especificaciones sin que haya una indicación de fallo de la prueba de límites si la densidad de puntos no es suficiente. El gráfico que aparece a continuación muestra una medida con puntos mínimos.

  • El inicio de la línea límite queda entre los puntos A y B a lo largo del eje de frecuencia horizontal.

  • El final de la línea límite queda entre los puntos B y C a lo largo del eje de frecuencia.

Sólo se encuentra un punto de medida entre el principio y el final de la línea límite. En este ejemplo concreto, el resultado de la prueba de límites sería Superada cuando en realidad parece que podría resultar fallida, porque el único punto probado (punto B) supera la prueba de límites. Los puntos A y C no superarían la prueba, pero no se prueban con el límite mostrado.

A continuación se ofrece la misma medida utilizando 51 puntos. Esto muestra claramente que la medida "no supera" la prueba de límites.

Se necesitaron más puntos de medida para evaluar esta medida.

Como se muestra en el gráfico anterior, con la prueba de límites ajustada a ON (activada):

  • Todas aquellas partes de la traza de medida que no superan la prueba de límites aparecen en rojo.

  • Las partes de la traza de medida que superan la prueba permanecen en verde (inalteradas).

Nota: Las zonas de la traza de medida que no estén limitadas por los valores de límites, aunque no se hayan sometido a prueba, permanecerán en verde.

Se pueden mostrar líneas límite y utilizar pruebas de límites de forma simultánea o independiente.

Las líneas límite y las pruebas de límites no están disponibles con el formato Polar o de diagrama de Smith. Si las líneas límite están ON (activadas) y se cambia al formato Polar o de diagrama de Smith, el analizador desactivará automáticamente las líneas límite y las pruebas de límites.

Nota: Las pruebas de límites sólo se realizan en la traza de datos de medida. Estas pruebas no se pueden realizar en una traza de memoria.

Haga clic en los botones para acceder a estos procedimientos.
Definir segmentos de límites
Mostrar u ocultar la tabla de límites
Mostrar líneas límite
Activar pruebas de límites

Definir segmentos de límites
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Limit Test..., Show Table, OK.

  2. En la sección Type de la tabla de límites, seleccionar MIN o MAX para el segmento de límite 1.

  3. Hacer clic en la sección BEGIN STIMULUS para el límite de segmento 1. Introducir el valor deseado.

  4. Hacer clic en la sección END STIMULUS para el límite de segmento 1. Introducir el valor deseado.

  5. Hacer clic en la sección BEGIN RESPONSE para el límite de segmento 1. Introducir el valor deseado.

  6. Hacer clic en la sección END STIMULUS para el límite de segmento 1. Introducir el valor deseado.

  7. Repetir los puntos 4 a 8 para cada segmento de límite deseado.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Limit Table.

  2. Pulsar F3 (Mostrar) para visualizar la tabla de límites.

  3. En el bloque NAVIGATION, pulsar Click para ver las opciones de Tipo para el segmento de límite 1. Pulsar el botón de flecha hacia abajo para seleccionar MIN o MAX.

  4. Pulsar la tecla de tabulador a la derecha para acceder a la sección BEGIN STIMULUS para el segmento de límite 1. Pulsar las teclas ENTRY para introducir el valor deseado. Pulsar Enter.

  5. Pulsar la tecla de tabulador a la derecha para acceder a la sección END STIMULUS para el segmento de límite 1. Pulsar las teclas ENTRY para introducir el valor deseado. Pulsar Enter.

  6. Pulsar la tecla de tabulador a la derecha para acceder a la sección BEGIN RESPONSE para el segmento de límite 1. Pulsar las teclas ENTRY para introducir el valor deseado. Pulsar Enter.

  7. Pulsar la tecla de tabulador a la derecha para acceder a la sección END RESPONSE para el segmento de límite 1. Pulsar las teclas ENTRY para introducir el valor deseado. Pulsar Enter.

  8. Pulsar la tecla de tabulador a la izquierda y la tecla de flecha hacia abajo para acceder al siguiente segmento de límite.

  9. Repetir los puntos 3 a 8 para cada segmento de límite deseado.

Mostrar u ocultar la tabla de límites
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Limit Test.

  2. Hacer clic en Show Table o Hide Table.

  3. Hacer clic en OK.

Otra forma de mostrar u ocultar la tabla de límites con el ratón es la siguiente:

  1. En el menú View, hacer clic en Tables.

  2. Hacer clic en Limit Table para cambiar el estado de visualización.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Limit Table.

  2. Pulsar F3 (Mostrar) o F4 (Ocultar).

Activar líneas límite
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Limit Test.

  2. Hacer clic en Limit Line ON.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Limit Table.

  2. Pulsar F2 (Línea ACTIVADA/Desactivada) para mostrar las líneas límite.

Activar pruebas de límites
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Limit Test.

  2. Hacer clic en Limit Test ON.

  3. Hacer clic en Sound ON Fail si se desea que el sistema emita un sonido para indicar que la prueba de límites ha resultado fallida.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Limit Table.

  2. Pulsar F1 (Prueba ACTIVADA/Desactivada) para activar la prueba de límites.


Véase asimismo...

Operaciones matemáticas

Descripción general

Conceptos

Cómo realizar
operaciones matemáticas

Se pueden realizar cuatro tipos de operaciones matemáticas en la traza de datos activa mediante el uso de una traza almacenada en la memoria. También se pueden calcular y visualizar las siguientes estadísticas de la traza de datos activa: media, desviación estándar y valores entre picos.
Conceptos

Cómo realizar operaciones matemáticas

Funciones matemáticas de trazas

Datos / Memoria

Datos - Memoria

Datos * Memoria

Datos + Memoria
Estadísticas de trazas

Funciones matemáticas de trazas

Hay cuatro tipos de operaciones matemáticas que se pueden realizar en la traza de datos visualizada.

  • Datos / Memoria

  • Datos - Memoria

  • Datos * Memoria

  • Datos + Memoria

La operación matemática se realiza con los datos complejos antes de formatearse y visualizarse.

Para realizar cualquiera de las operaciones matemáticas, se debe almacenar antes una traza medida (o equivalente) del dispositivo sometido a prueba en la memoria del canal activo. Se puede visualizar la traza de memoria con la traza de datos actual utilizando las opciones de visualización de trazas.

Nota: También se puede definir una "traza" que pueda almacenarse en memoria con comandos SCPI o COM introduciendo parejas de datos complejos que correspondan al número de puntos de datos de la traza de datos. La traza de datos debe configurarse antes de intentar cargar la memoria. El analizador establece una correspondencia entre las parejas de datos complejos y los valores de estímulo en los puntos de medida reales.

Datos / Memoria

Datos / Memoria es la función matemática de trazas que se utiliza con mayor frecuencia. Se puede utilizar esta función para comparar la relación entre dos trazas, como medidas de ganancia o atenuación.

  1. Para utilizar esta función, en primer lugar se debe almacenar una traza medida del dispositivo sometido a prueba en la memoria del canal activo.

  2. A continuación, se realiza la operación Datos / Memoria para dividir los datos por la memoria.

  3. El analizador normaliza los datos en la memoria y muestra el resultado.

  4. Visualizar los datos en el formato Log Mag para medir cualquier desviación respecto de la traza almacenada.

Datos - Memoria

Datos - Memoria realiza una resta vectorial con datos de medida complejos utilizando una traza almacenada. Se puede utilizar esta función para almacenar un error vectorial medido, por ejemplo, y a continuación restar este error de la medida del dispositivo.

Datos * Memoria y Datos + Memoria

Datos + Memoria y Datos * Memoria resultan más útiles con las fórmulas o algoritmos propios del usuario que se deseen aplicar a una traza de datos, no con los datos almacenados y medidos. Por ejemplo, si se desea simular la ganancia de un amplificador teórico situado en serie antes del dispositivo que se está midiendo, se puede:

  1. Crear un algoritmo que caracterizaría la respuesta en frecuencia del amplificador.

  2. Introducir parejas de datos complejos que se correspondan con el número de puntos de datos de la traza de datos.

  3. Cargar las parejas de datos en la memoria con comandos SCPI o COM.

  4. El analizador establece una correspondencia entre las parejas de datos complejos y los valores de estímulo en los puntos de medida reales.

  5. A continuación, utilizar la función datos + memoria o datos * memoria para sumar o multiplicar la respuesta en frecuencia a/por los datos medidos. Véase Comandos COM, método PutComplex para obtener más información.

Nota: La traza de datos debe configurarse antes de intentar cargar la memoria.

Estadísticas de trazas

Se pueden calcular y visualizar estadísticas de la traza de datos activa. Estas estadísticas son:

  • Media

  • Desviación estándar

  • Valores entre picos

Se pueden calcular estadísticas del recorrido de estímulo completo o de parte del mismo. Se pueden especificar nueve márgenes de usuario por canal. Estos márgenes de usuario son los mismos que los dominios de búsqueda especificados para una búsqueda de marcadores en ese mismo canal; utilizan los mismos registros de memoria y comparten, por lo tanto, los mismos recorridos de estímulo. Si se especifican dominios de búsqueda con búsqueda de marcadores para un canal, se pueden recuperar estos mismos recorridos seleccionando los márgenes de usuario correspondientes. Los márgenes de usuario de un canal pueden solaparse unos con otros.

Un uso práctico de las estadísticas de trazas consiste en encontrar el valor entre picos de la ondulación de banda de paso sin buscar por separado los valores máximo y mínimo.

Las estadísticas de trazas se calculan en función del formato utilizado para visualizar los datos.

  • Los formatos de datos rectangulares se calculan a partir de los datos escalares representados en la pantalla

  • Los formatos Polar o de diagrama de Smith se calculan a partir de los datos tal y como se visualizarían en el formato Log Mag

Haga clic en los botones para acceder a los procedimientos.
Seleccionar tipo de matemáticas de trazas
Establecer estadísticas de trazas

Seleccionar matemáticas de trazas
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Math/Memory.

  2. Hacer clic en Data>Memory para almacenar en la memoria la traza deseada.

  3. En la parte Data Math del cuadro de diálogo, seleccionar la operación matemática deseada.

  4. En la parte Trace View Options del cuadro de diálogo, seleccionar la visualización de trazas deseada.

  5. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Math/Memory.

  2. Pulsar F1 (Datos>>Memoria) para almacenar en la memoria la traza deseada.

  3. Pulsar F2 (Datos/Memoria) para seleccionar Datos/Memoria.

  4. Pulsar F3 (Sólo datos) para visualizar sólo la traza de datos.

  5. Pulsar F4 (DatosMemoria) para visualizar la traza de datos y la traza de memoria.

Para seleccionar una operación matemática que no sea Datos/Memoria, seguir los pasos indicados a continuación.

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque TRACE SETUP, pulsar Math/Memory.

  3. Pulsar Click para almacenar en la memoria la traza deseada.

  4. Pulsar la tecla de tabulador a la derecha para seleccionar la zona Data Math del cuadro de diálogo. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la operación matemática de trazas deseada.

  5. Pulsar la tecla de tabulador a la derecha para seleccionar la zona Trace View Options del cuadro de diálogo. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la visualización de trazas deseada.

  6. En el bloque COMMAND, pulsar OK.

Establecer estadísticas de trazas
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Trace Statistics.

  2. Hacer clic en la casilla Statistics para activar las estadísticas de trazas.

  3. Seleccionar el margen de usuario deseado.

  4. En el cuadro Start, escribir el valor de estímulo deseado para el principio del margen de usuario.

  5. En el cuadro Stop, escribir el valor de estímulo deseado para el final del margen de usuario.

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog. Utilizar la tecla de tabulador a la derecha para seleccionar el menú Trace. Utilizar la tecla de flecha hacia abajo para seleccionar Trace Statistics. Pulsar Click.

  2. Pulsar Click para activar las estadísticas de trazas.

  3. Pulsar la tecla de tabulador a la derecha para acceder a la zona de selección User Range del cuadro de diálogo. Pulsar la tecla de flecha hacia abajo para seleccionar el margen de usuario deseado.

  4. Pulsar la tecla de tabulador a la derecha para acceder al cuadro Start. Escribir el valor de estímulo deseado para el principio del margen de usuario.

  5. Pulsar la tecla de tabulador a la derecha para acceder al cuadro Stop. Escribir el valor de estímulo deseado para el final del margen de usuario.

  6. En el bloque COMMAND, pulsar OK.


Véase asimismo...

Asignación de unidades

Descripción general

Conceptos

Cómo asignar una unidad

La asignación de unidades permite compartir unidades de disco entre el analizador y un ordenador externo.
Conceptos

Cómo asignar una unidad

Mediante la asignación de unidades se pueden compartir unidades de disco entre el analizador y un ordenador externo para guardar y recuperar archivos.

  • La unidad de disco del analizador aparece como si fuese otra unidad en el directorio del PC.

  • La unidad de disco del ordenador aparece como si fuese otra unidad en el directorio del analizador.

  • La unidad de disco del analizador y la unidad de disco del ordenador son entonces opciones de fuente para trabajar con archivos.

Nota: Para realizar estos procedimientos se necesitan un ratón y un teclado.
Asignación de una unidad del analizador a un ordenador externo

Asignación de una unidad de un ordenador externo al analizador

Nota: Para realizar los siguientes procedimientos se necesita Windows NT 4.0 (o una versión posterior) en el ordenador externo.

Asignación de una unidad del analizador a un ordenador externo

Identificar el nombre del ordenador

  1. El analizador tiene un nombre de ordenador que es necesario para realizar los procedimientos siguientes. Para mostrar o cambiar el nombre de ordenador del analizador deben realizarse los dos pasos siguientes.

    1. Hacer clic en System, barra de tareas de Windows, Configuración, Panel de control y el icono Sistema.

    2. Seleccionar la ficha Identificación de la red. Si se desea, apuntar el nombre de ordenador. Para cambiar el nombre de ordenador, hacer clic en Propiedades e introducir un nuevo nombre de ordenador. Hacer clic en Aceptar.

Añadir un nuevo usuario

  2. Hacer clic en Usuarios y contraseñas.

  3. Si el botón Agregar aparece en gris, hacer clic en la casilla de verificación "Los usuarios deben introducir un nombre de usuario y una contraseña para utilizar este equipo." Hacer clic en Agregar.

  4. En el cuadro Nombre de usuario, introducir el nombre de usuario (utilizar el mismo nombre de usuario que se usa en el ordenador externo). En el cuadro Nombre y apellidos, introducir el nombre y los apellidos. Hacer clic en Siguiente.

  5. En el cuadro Contraseña, introducir la contraseña (utilizar la misma contraseña que se usa en el ordenador externo). En el cuadro Confirmar contraseña, volver a introducir la contraseña. Hacer clic en Siguiente.

  6. Cuando aparezca el mensaje "¿Qué nivel de acceso desea conceder a este usuario?", seleccionar Otro y, a continuación, seleccionar la opción predeterminada Administradores. Hacer clic en Finalizar.

Crear un nombre compartido para una unidad

  7. En el cuadro Dirección, hacer clic en la flecha hacia abajo y hacer clic en Mi PC. Hacer clic con el botón derecho del ratón en la unidad que se desee compartir con el ordenador externo. Hacer clic en Compartir.

  8. Seleccionar Compartir esta carpeta. En el cuadro Nombre compartido, introducir un nombre compartido. Hacer clic en Aceptar.

Conectarse a la unidad compartida

  9. En el escritorio del ordenador de sobremesa, hacer clic en Explorador de Windows NT. En el menú Herramientas, hacer clic en Conectar a unidad de red.

  10. En el cuadro Ruta de acceso, introducir \\nombre_de_ordenador\nombre_compartido.

  11. En el cuadro Conectar, introducir el nombre de identificación de usuario. Hacer clic en Aceptar.

Asignación de una unidad de un ordenador externo al analizador

  1. En el escritorio del ordenador de sobremesa, hacer clic en Explorador de Windows NT. En la lista de unidades, hacer clic con el botón derecho del ratón en la unidad que se desee compartir. Hacer clic en Compartir.

  2. En el cuadro de diálogo, seleccionar Compartir como. En el cuadro Nombre compartido, utilizar la tecla de flecha o introducir un nombre compartido para la unidad (cualquier palabra deseada). Hacer clic en Aceptar.

  3. En el escritorio del analizador, hacer clic en Windows Explorer. En el menú Herramientas, hacer clic en Conectar a unidad de red.

  4. En el cuadro Carpeta, introducir \\nombre_del_PC (o número de identificación)\nombre_compartido (la palabra que se haya elegido en el paso 2). Hacer clic en Finalizar.

  5. En el cuadro Conectar como, introducir el nombre de identificación de usuario.

  6. En el cuadro Contraseña, introducir la contraseña de inicio de sesión utilizada en el ordenador externo. Hacer clic en Aceptar.


SaveRecall

Véase asimismo...

Guardar y recuperar un archivo

Descripción general

Conceptos

Cómo guardar y recuperar

El analizador permite guardar y recuperar datos en y desde el disco duro interno, un disquete, una unidad de CD-RW externa, un PC o un servidor en una variedad de formatos de archivo.
Conceptos

Cómo guardar y recuperar un archivo

Haga clic en un botón para obtener información acerca de los siguientes temas:
Guardar archivo

Guardar automáticamente

Guardar como

Imprimir en un archivo

Editar un nombre de archivo

Recuperar archivo

Guardar archivo

Cuando se utiliza la función File Save, el analizador guarda un archivo de datos binarios en el disco duro interno, seleccionando automáticamente la ruta de acceso actual y el nombre de archivo. Si no se han definido anteriormente, el analizador selecciona automáticamente la ruta de acceso por defecto C:\Archivos de programa\Agilent\Network Analyzer\Documents y el nombre de archivo "default.cst". El archivo se sobrescribirá la próxima vez que se utilice la función Save, a menos que se cambie el nombre del archivo y se guarde utilizando uno de los siguientes métodos:

  • Auto Save

  • Save As

  • Cambiar nombre (utilizando el Explorador de Windows)

Guardar automáticamente

Cuando se utiliza la función Auto Save, el analizador guarda un archivo de datos binarios en el disco duro interno, seleccionando automáticamente la ruta de acceso actual. Si no se ha definido anteriormente, el analizador selecciona automáticamente la ruta de acceso por defecto C:\Archivos de programa\Agilent\Network Analyzer\Documents. También selecciona y muestra automáticamente un nuevo nombre de archivo con la extensión .cst. Esto se hace para no sobrescribir el archivo guardado anteriormente.

Guardar como

Cuando se utiliza la función Save As, el analizador guarda los datos en archivos binarios o ASCII en cualquiera de las siguientes ubicaciones designadas por el usuario:

  • El disco duro interno

  • Un disquete

  • Una unidad de CD-RW externa, un PC o un servidor (utilizando una unidad de red asignada)

Tipos de archivos binarios

El analizador únicamente utiliza los siguientes tipos de archivos binarios para guardar y recuperar datos relacionados con medidas. Estos tipos de archivos sólo los reconocen los analizadores Agilent Serie PNA.

  • .cst

  • .sta

  • .cal

Un archivo .cst contiene los siguientes datos:

  • Todas las medidas configuradas en el analizador, incluidas líneas límite y marcadores

  • Todos los conjuntos de calibración para las medidas configuradas en el analizador

  • Disposición de visualización de ventanas

La recuperación de un archivo .cst ahorra tiempo y evita tener que recuperar tanto el estado del instrumento como los archivos de datos de calibración para cada medida.

Un archivo .sta contiene los siguientes datos:

  • Todas las medidas configuradas en el analizador, incluidas líneas límite y marcadores

  • Disposición de visualización de ventanas

Nota: Un archivo .sta no contiene conjuntos de datos de calibración.

La recuperación de un archivo .sta ahorra tiempo y evita tener que recuperar el estado del instrumento para cada medida.

Un archivo .cal sólo contiene los datos de corrección de medidas que el analizador crea cuando se realiza una calibración. Un archivo .cal no contiene datos del estado del instrumento. Los datos de corrección de medidas están vinculados con el estado del instrumento para el que se realizó la calibración. Por consiguiente, para obtener la mayor precisión de medida cuando se recupera un archivo .cal, también deberán recuperarse los datos correspondientes del estado del instrumento (un archivo .sta) que se utilizaron para realizar la calibración.

Nota: Se puede acceder a la función Calibration Properties para mostrar la configuración de instrumento que se utilizó cuando se guardó el archivo .cal. Para obtener más información, véase el apartado "Seleccionar y realizar una calibración de medida".

Las calibraciones de medidas son específicas de canales. Por ejemplo, una calibración realizada en el canal 1 no se puede recuperar en ningún otro canal.

Tipos de archivos ASCII

Los siguientes tipos de archivos ASCII se guardan en el disco duro interno del analizador o en un disquete. El analizador envía los archivos a la unidad de CD-RW externa, el PC o un servidor para permitir su utilización en programas de hoja de cálculo o de CAE.

  • .prn

  • .s1p

  • .s2p

Nota: Los tipos de archivos ASCII sólo guardan un canal activo con una traza activa. No se puede guardar un conjunto de medidas utilizando únicamente un archivo ASCII.

El formato .prn lo utiliza normalmente software de hoja de cálculo, como Microsoft® Excel. Un archivo .prn contiene datos corregidos con formato de estímulos y respuestas en una lista separada por comas para la traza activa actual. Ejemplo:

"S11 Log Mag" |
"Frequency (Hz)", "dB" |
3.000000e+005 | -3.528682e+001
4.529850e+007 | -2.817913e+001
9.029700e+007 | -3.216808e+001
1.352955e+008 | -3.101017e+001

Una ventaja de importar archivos .prn a un programa de hoja de cálculo es tener acceso a formatos .prn (magnitud logarítmica, magnitud lineal, SWR, etc.),en lugar de las parejas reales e imaginarias necesarias para los archivos .s1p y .s2p. Además, algunos programas, como Excel, pueden utilizar los datos de los archivos .prn para introducir datos en columnas de una hoja de cálculo. Un archivo .prn es únicamente una salida - el analizador no lo puede leer.

Los formatos .s1p y .s2p (denominados asimismo formatos Touchstone) los utilizan normalmente programas de aplicación de CAE, como Microwave Design System (MDS) y Advanced Design System (ADS) de Agilent. (También se pueden importar archivos .s1p y .s2p a hojas de cálculo, aunque se recomiendan los archivos .prn.) Los archivos .s1p y .s2p contienen datos de estímulos y de parejas reales/imaginarias con errores corregidos para la traza activa actual en una lista separada por espacios. Los datos representan la matrizde formato, incluidos los efectos del retardo eléctrico y las e xtensiones de puerto s. Estos archivos son únicamente una salida - el analizador no los puede leer. Los datos de los archivos .s1p y .s2p no pueden mostrar una imagen de captura de pantalla.

Un archivo .s1p contiene datos de medidas para componentes de 1 puerto. Este formato devuelve datos corregidos para un parámetro S como parejas reales e imaginarias para la actual traza activa. Ejemplo:

!Agilent 835xA: A.O1.01
!S1P File: Measurement: S11:
Hz S RI R 50.0
3.000000e+005 | 1.644731e-002 | -5.352918e-003
4.529850e+007 | 6.613658e-003 | 3.845622e-002
9.029700e+007 | 1.226958e-002 | 2.139536e-002
1.352955e+008 | 2.736092e-002 | 6.093691e-003
1.802940e+008 | 2.883098e-002 | -4.465516e-002

Nota: En los ejemplos anterior y siguiente:

  • Hz = frecuencia

  • S = parámetros S

  • RI = pareja real e imaginaria

  • R 50.0 = referencia impedancia

Un archivo .s2p contiene datos de medidas para componentes de 2 puertos. Este formato devuelve datos corregidos de cuatro parámetros S como parejas reales e imaginarias para la actual traza activa. Ejemplo:

!Agilent 835xA: A.O1.01
!S2P File: Measurement: S11, S21, S12, S22:
Hz S RI R 50.0
3.000000e+005 | -2.241318e-004 | -1.199616e-006
 | 1.000518e+000 | 5.873038e-004
 | 9.997111e-001 | 3.530481e-005
 | -2.597498e-005 | 8.359684e-005
4.529850e+007 | 4.111997e-004 | -1.182173e-004
 | 1.000306e+000 | -7.713915e-004
 | 9.995822e-001 | 7.192153e-004
 | -3.241569e-005 | 2.542366e-004
9.029700e+007 | 6.449617e-005 | -7.952083e-004
 | 1.000047e+000 | -1.822955e-004
 | 9.990308e-001 | -5.635918e-004
 | 2.029050e-004 | 7.774481e-004
1.352955e+008 | -5.545341e-004 | -1.932054e-004
 | 9.994355e-001 | -4.536113e-004
 | 1.000014e+000 | 8.115917e-004
 | 6.564625e-004 | 5.489338e-004

Para crear un archivo .s2p válido, el analizador debe disponer de c orrección de errores de 2 puertos. Si no se realiza la corrección de errores de 2 puertos, no estará disponible un término S11, S21, S12, o S22, por lo que se devolverán ceros en el campo del parámetro no medido. Sin embargo, el analizador creará un archivo .s1p o .s2p independientemente de que se hayan realizado medidas de 1 o 2 puertos.

Imprimir en un archivo

Cuando se utiliza la función Print to File, el analizador puede guardar un archivo .bmp (mapa de bits) de una imagen de captura de pantalla en cualquiera de las siguientes ubicaciones designadas por el usuario:

  • El disco duro interno

  • Un disquete

  • Una unidad de CD-RW externa, un PC o un servidor (utilizando una unidad de red asignada)

El analizador guarda automáticamente el archivo .bmp en la ruta de acceso actual. Si no se ha definido anteriormente, el analizador selecciona automáticamente la ruta de acceso por defecto C:\Archivos de programa\Agilent\Network Analyzer\.

Al igual que un archivo .prn, un archivo .bmp se puede importar a aplicaciones de software como Microsoft Excel, Word o Paint para mostrar una imagen de captura de pantalla.

Editar un nombre de archivo

La función Edit Filename permite copiar un archivo y asignarle un nombre nuevo utilizando las teclas de desplazamiento del analizador. El archivo y el nombre originales permanecen inalterados. Se accede a esta función en el cuadro de diálogo Save As cuando se utiliza Save As o Print to File. Véase el gráfico siguiente.

Nota: Para obtener información y procedimientos sobre la gestión de archivos/carpetas (por ejemplo, las funciones copiar, eliminar, cambiar nombre o buscar), véase la Ayuda de Windows 2000.

Recuperar archivo

Cuando se utiliza la función Recall del analizador, sólo recupera archivos binarios. Se puede recuperar un archivo .cst o .sta como una imagen de captura de pantalla, pero los datos tienen que haberse guardado utilizando la función de mantenimiento de traza. (El archivo recuperado no barrerá hasta que se active.) Para obtener más información acerca de los tipos de archivos binarios, véase la sección de este tema titulada Save As.

Cuando se utiliza la función Recall de un PC externo, sólo recupera archivos ASCII o de mapa de bits desde el analizador. Para recuperar imágenes de captura de pantalla, pueden recuperarse archivos .prn o .bmp en aplicaciones de software como Microsoft Excel, Word o Paint. Para obtener más información acerca de los tipos de archivos ASCII, véase la sección de este tema titulada Save As.

Haga clic en los botones para acceder a los procedimientos.

Nota: Para realizar estos procedimientos se necesitan un ratón y un teclado.
Guardar un archivo

Guardar automáticamente un archivo

Guardar un archivo con otro nombre o en otra ubicación

Imprimir en un archivo

Editar un nombre de archivo

Recuperar un archivo en el analizador

Recuperar un archivo en un ordenador externo

Guardar un archivo

Procedimiento con el ratón

  1. En el menú File, hacer clic en Save.

Procedimiento con las teclas del panel frontal

  1. En el bloque UTILITY, pulsar Save.

  2. En la barra de herramientas Active Entry, pulsar F1 (Guardar).

En la pantalla aparecerá temporalmente un mensaje indicando la ruta de acceso y el nombre de archivo utilizados para guardar el archivo.

Nota: Este archivo se sobrescribirá la próxima vez que se utilice la función Save, a menos que se cambie el nombre del archivo y se guarde utilizando uno de los siguientes métodos: Guardar automáticamente, Guardar como, Cambiar nombre (utilizando el Explorador de Windows)

Guardar automáticamente un archivo

Nota: Este procedimiento se realiza utilizando las teclas del panel frontal.

Procedimiento con las teclas del panel frontal

  1. En el bloque UTILITY, pulsar Save.

  2. En la barra de herramientas Active Entry, pulsar F3 (Guardar automáticamente).

En la pantalla aparecerá temporalmente un mensaje indicando la ruta de acceso utilizada para guardar el archivo. El analizador también selecciona y muestra automáticamente un nuevo nombre de archivo con la extensión .cst. Esto se hace para no sobrescribir el archivo guardado anteriormente.

Guardar un archivo con otro nombre o en otra ubicación

Procedimiento con el ratón

  1. En el menú File, hacer clic en Save As.

  2. En la sección Save in del cuadro de diálogo, hacer clic en el botón de flecha para seleccionar la ruta de acceso deseada para guardar el archivo.

  3. En el cuadro File name, escribir el nuevo nombre de archivo.

  4. En el cuadro Save as type, hacer clic en el botón de flecha para seleccionar el tipo de archivo deseado.

  5. Hacer clic en Save.

Procedimiento con las teclas del panel frontal

  1. En el bloque UTILITY, pulsar Save.

  2. En la barra de herramientas Active Entry, pulsar F2 (Guardar como).

  3. Pulsar la tecla de tabulador a la izquierda para pasar al cuadro Save in. Pulsar la tecla de flecha hacia abajo para desplazarse a la ruta de acceso deseada para guardar el archivo. Pulsar la tecla de tabulador a la derecha para seleccionar la ruta de acceso.

  4. En el cuadro File name, escribir el nuevo nombre de archivo.

  5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Save as type. Pulsar la tecla de flecha hacia abajo para desplazarse al tipo de archivo deseado. Pulsar la tecla de tabulador a la derecha para seleccionar el tipo de archivo.

  6. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Save. Pulsar Click.

Imprimir en un archivo

Procedimiento con el ratón

  1. En el menú File, hacer clic en Print to File.

  2. En la sección Save in del cuadro de diálogo, hacer clic en el botón de flecha para seleccionar la ruta de acceso deseada para guardar el archivo.

  3. En el cuadro File name, escribir el nuevo nombre de archivo.

  4. Hacer clic en Save.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de flecha hacia abajo para desplazarse a Print to File. Pulsar Click.

  3. En el bloque NAVIGATION, utilizar la tecla de tabulador a la izquierda para pasar al cuadro Save in. Pulsar la tecla de flecha hacia abajo para desplazarse a la ruta de acceso deseada para guardar el archivo. Pulsar la tecla de tabulador a la derecha.

  4. En el cuadro File name, escribir el nuevo nombre de archivo.

  5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Save. Pulsar Click.

Editar un nombre de archivo

Procedimiento con el ratón

  1. En el menú File, hacer clic en Save As o Print to File.

  2. En la sección Save del cuadro de diálogo, hacer clic en el botón de flecha para seleccionar la ruta de acceso en la que se desea guardar el archivo.

  3. En el cuadro Filepath, seleccionar el nombre de archivo.

  4. Hacer clic en Edit Filename.

  5. En el cuadro de diálogo, introducir el nuevo nombre de archivo utilizando uno de los siguientes métodos:

    • Utilizar el teclado externo.

    • Hacer clic en las letras o los botones (<<, Select, Back, >>).

  6. Hacer clic en OK, Save.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de flecha hacia abajo para desplazarse a Save As o Print to File. Pulsar Click.

  3. Pulsar la tecla de tabulador a la izquierda para pasar al cuadro Save in. Pulsar el botón de flecha hacia abajo para desplazarse a la ruta de acceso deseada para guardar el archivo. Pulsar la tecla de tabulador a la derecha.

  4. Pulsar el botón de tabulador a la izquierda para pasar al cuadro Filepath. Utilizar las teclas de flecha hacia arriba y hacia abajo para desplazarse al nombre de archivo. Pulsar Click.

  5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Edit Filename . Pulsar Click.

  6. En el cuadro de diálogo, introducir el nuevo nombre de archivo utilizando uno de los siguientes métodos:

    • Utilizar el teclado externo.

    • Pulsar los botones de flecha hacia arriba y hacia abajo para desplazarse a la letra deseada. Pulsar Click. Pulsar el tabulador a la derecha o a la izquierda para pasar al botón deseado (<<, Select, Back, >>). Pulsar Click.

  7. Pulsar la tecla de tabulador a la derecha para pasar a OK. Pulsar Click.

  8. Pulsar la tecla de tabulador a la derecha para pasar a Save. Pulsar Click.

Recuperar un archivo en el analizador

Procedimiento con el ratón

  1. Si todavía no se ha hecho, asignar una unidad de la red al dispositivo de almacenamiento de datos externo (véase Asignación de unidades). Al hacerlo, la unidad de disco duro del dispositivo de almacenamiento de datos externo aparecerá en el directorio del analizador.

  2. En el menú File, hacer clic en Recall.

  3. En la sección Look in del cuadro de diálogo, hacer clic en el botón de flecha para seleccionar la ruta de acceso deseada para recuperar el archivo.

  4. En el cuadro Files of Type, hacer clic en el botón de flecha para seleccionar el tipo de archivo deseado.

  5. En el cuadro Filepath, seleccionar el nombre del archivo que se desea recuperar.

  6. Hacer clic en Recall.

Procedimiento con las teclas del panel frontal

  1. Si todavía no se ha hecho, asignar una unidad de la red al dispositivo de almacenamiento de datos externo (véase Asignación de unidades). Al hacerlo, la unidad de disco duro del dispositivo de almacenamiento de datos externo aparecerá en el directorio del analizador.

  2. En el bloque UTILITY, pulsar Recall.

  3. En la barra de herramientas Active Entry, pulsar F1, F2o F3 para seleccionar uno de los nombres de archivo mostrados. (Estos nombres de archivo aparecerán en orden alfanumérico.) Si se desea recuperar un archivo diferente, pulsar F4 (Abrir).

  4. Si se seleccionó F4 (Abrir) en el punto anterior:

    1. Pulsar la tecla de tabulador a la izquierda para pasar al cuadro Look in. Pulsar la tecla de flecha hacia abajo para desplazarse a la ruta de acceso deseada para recuperar el archivo. Pulsar la tecla de tabulador a la derecha.

    2. Pulsar la tecla de tabulador a la derecha. En el cuadro Files of type, pulsar la tecla de flecha hacia abajo para desplazarse al tipo de archivo deseado. Pulsar la tecla de tabulador a la derecha.

    3. Pulsar la tecla de tabulador a la izquierda para pasar al cuadro Filepath. Pulsar la tecla de flecha hacia abajo para desplazarse al tipo de archivo binario deseado. Pulsar la tecla de tabulador a la derecha.

    4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Recall. Pulsar Click.

Recuperar un archivo en un ordenador externo

  1. Si no se ha hecho todavía, asignar una unidad de la red al analizador (véase Asignación de unidades). Al hacerlo, la unidad de disco duro del analizador aparecerá en el directorio del PC.

  2. Utilizar el Explorador® de Windows del ordenador externo para recuperar el archivo ASCII o de mapa de bits deseado desde el analizador.

Para obtener instrucciones acerca de la utilización del Explorador de Windows, consúltese el sistema de Ayuda de la versión de Windows® instalada en el ordenador externo.


Imprimir

Imprimir una medida mostrada

Véase asimismo...

El analizador permite utilizar una impresora de la red o una impresora local para imprimir una medida mostrada. Haga clic en los botones para acceder a los procedimientos.
Conexión a una impresora de una red

Conexión de una impresora al analizador

Creación de una salida impresa

Conexión a una impresora de una red

Nota: Para realizar este procedimiento se necesitan un ratón y un teclado.

  1. Conectar un cable de la LAN entre el conector de LAN del panel posterior del analizador y el conector de LAN de la red.

  2. En el escritorio del analizador, hacer clic en Inicio, Configuración, Impresoras.

  3. Hacer doble clic en Agregar impresora para iniciar el Asistente para agregar impresora. Hacer clic en Siguiente.

  4. Hacer clic en Impresora de red, Siguiente.

  5. Conectarse a la impresora deseada de una de las dos maneras siguientes:

  • Escribir su nombre utilizando el formato siguiente o hacer clic en Siguiente para localizar la impresora en la red: \\nombre_del_servidor_de_impresión\nombre_compartido

  • Escribir su dirección URL utilizando el formato siguiente: http://nombre_del_servidor_de_impresión/Impresoras/nombre_compartido/.impresora

Nota: Si no es posible conectarse a la impresora utilizando las instrucciones anteriores, consultar la documentación de la impresora o ponerse en contacto con el administrador de la red.

  6. Seguir las instrucciones mostradas en la pantalla para finalizar la conexión a la impresora de la red.

  7. El icono de la impresora aparecerá en la carpeta Impresoras.

Conexión de una impresora al analizador

Nota: Para realizar este procedimiento se necesitan un ratón y un teclado.

  1. Conectar la impresora al puerto oportuno del analizador de acuerdo con las instrucciones del fabricante de la impresora.

  2. Windows 2000 instala automáticamente la mayoría de las impresoras. Sin embargo, con impresoras más antiguas, tal vez sea necesario facilitar información adicional para realizar la instalación. Si el icono de la impresora no se añade a la carpeta Impresoras, elegir uno de los procedimientos siguientes, dependiendo del tipo de impresora que se vaya a utilizar.
Instalar una impresora compatible con puerto paralelo (LPT)

Instalar una impresora compatible con puerto USB

Instalar una impresora compatible con puerto serie (COM)

Instalar una impresora compatible con puerto paralelo (LPT)

  1. Conectar la impresora al analizador. Con los accesorios del analizador se incluye un adaptador (36 patillas macho (1284-C) a 25 patillas hembra) que permite realizar la conexión entre el puerto paralelo y un puerto Centronics.

PRECAUCIóN: No utilizar el puerto hembra de 25 patillas designado Ext. Test Set Interface para conectar la impresora. Los niveles de tensión de las líneas de señales podrían dañar la E/S de la impresora.

  2. En el escritorio del analizador, hacer clic en Inicio, Configuración, Impresoras.

  3. Hacer doble clic en Agregar impresora para iniciar el Asistente para agregar impresora. Hacer clic en Siguiente.

  4. Hacer clic en Impresora local, asegurarse de que las casillas de verificación Detectar automáticamente e Instalar mi impresora Plug and Play están seleccionadas y, a continuación, hacer clic en Siguiente.

  5. Dependiendo de la impresora que se esté instalando, el Asistente para agregar impresora continuará o aparecerá el mensaje "Nuevo hardware encontrado" o el Asistente para agregar nuevo hardware para notificar que ha comenzado la instalación. Seguir las instrucciones mostradas en la pantalla para instalar la impresora.

    • Como alternativa, después de conectar la impresora, se puede iniciar o reiniciar el analizador para que Windows 2000 inicie automáticamente el Asistente para agregar nuevo hardware.

  6. El icono de la impresora se añadirá a la carpeta Impresoras.

Instalar una impresora compatible con puerto USB

Conectar la impresora al puerto USB del analizador. Windows 2000 detectará este tipo de impresora e iniciará automáticamente el Asistente para agregar nuevo hardware.

No es necesario apagar ni reiniciar el analizador. Seguir las instrucciones mostradas en la pantalla para finalizar la instalación de la impresora.

El icono de la impresora se añadirá a la carpeta Impresoras.

Instalar una impresora compatible con puerto serie (COM)

  1. Conectar la impresora al conector serie del analizador.

  2. En el escritorio del analizador, hacer clic en Inicio, Configuración, Impresoras.

  3. Hacer doble clic en Agregar impresora para iniciar el Asistente para agregar impresora. Hacer clic en Siguiente.

  4. Hacer clic en Impresora local, asegurarse de que las casillas de verificación Detectar automáticamente e Instalar mi impresora Plug and Play están seleccionadas y, a continuación, hacer clic en Siguiente.

  5. Finalizar la instalación de la impresora siguiendo las instrucciones para seleccionar lo siguiente:

  • Puerto de impresora

  • Fabricante y modelo de la impresora

  • Nombre de la impresora

  6. El icono de la impresora se añadirá a la carpeta Impresoras.

Nota: Si se añade y se configura una impresora "Plug and Play" (por ejemplo, USB o puerto paralelo (LPT)), no será necesario disponer de privilegios administrativos. Sin embargo, para añadir y configurar una impresora que no sea "Plug and Play" y que esté conectada directamente al analizador, será necesario identificarse como administrador o como miembro del grupo de administradores. Si el analizador está conectado a una red, los valores de las políticas de la red también podrán impedir que se realice este procedimiento.

Creación de una salida impresa

Procedimiento con el ratón

  1. En el menú Archivo, hacer clic en Imprimir.

  2. En el cuadro de diálogo Imprimir, pasar a Nombre. Hacer clic en el botón de flecha para seleccionar la impresora deseada. Hacer clic en Aceptar.

Procedimiento con las teclas del panel frontal

  1. En el cuadro UTILITY, pulsar la tecla del icono Print.

  2. En el bloque NAVIGATION, pulsar la tecla de flecha hacia arriba o hacia abajo para seleccionar la impresora deseada en el cuadro Name. Pulsar OK.

Nota: Para obtener más información sobre las opciones disponibles en el cuadro de diálogo Imprimir, véase la Ayuda de Windows 2000.

En el gráfico siguiente se muestra cómo aparece una imagen de captura de pantalla cuando se imprime. Obsérvese que los datos en forma de texto se incluyen automáticamente junto con la imagen de la captura de pantalla.


Guías didácticas

Guías didácticas de medida

Véase asimismo...

Haga clic en un botón para obtener más información sobre estas medidas.

Referencia de medidas de fase

Referencia de parámetros del amplificador

Conversión AM-PM

Impedancia compleja

Desviación respecto de fase lineal

Retardo de grupo

Ganancia y planeidad

Compresión de ganancia

Aislamiento inverso

Componentes de alta potencia

Potencia de salida absoluta

Modelo de adaptación de impedancias

Ondas reflejadas a lo largo de una línea de transmisión

Dominio del tiempo


Phase Meas

Referencia de medidas de fase

Véase asimismo...

Se puede utilizar el analizador para realizar las siguientes medidas de la fase con el fin de caracterizar un dispositivo:

  • Desviación respecto de fase lineal

  • Retardo de grupo

  • Impedancia compleja

  • Conversión AM-PM

El conocimiento de las características tanto de magnitud como de fase es necesario para poder realizar satisfactoriamente una integración de componentes a más alto nivel.

Haga clic en los botones para acceder a información acerca de los temas siguientes:

¿En qué consisten las medidas de fase?

¿Por qué se debe medir la fase?

Utilización del formato de fase del analizador

Tipos de medidas de fase

¿En qué consisten las medidas de fase?

Las medidas de fase se realizan utilizando parámetros S, de la misma manera que las medidas de amplitud. Una medida de fase es una medida relativa (relación), y no una medida absoluta. Las medidas de fase comparan la fase de la señal que llega a un dispositivo (la señal incidente) con la fase de la señal de respuesta del dispositivo. La señal de respuesta se puede reflejar o transmitir. Suponiendo que se haya realizado una calibración exacta, la diferencia de fase (conocida como desplazamiento de fase) entre ambas señales es un resultado de las características eléctricas del dispositivo sometido a prueba.

En el siguiente gráfico se muestra el desplazamiento de fase (en tiempo o grados) entre una señal incidente y una señal transmitida (como podría verse en la pantalla de un osciloscopio).

¿Por qué se debe medir la fase?

La medida de la fase es un elemento crítico del análisis de redes. En el siguiente gráfico se enumeran cinco razones para medir tanto la magnitud como la fase.

Cuando se utilizan en comunicaciones para pasar señales, los componentes o circuitos no deben causar una distorsión excesiva de señales. Esta distorsión puede ser:

  • Lineal, cuando la magnitud plana y el desplazamiento de fase lineal frente a la frecuencia no se mantiene a lo largo del ancho de banda de interés.

  • No lineal, como la conversión AM-PM.

Es importante medir el nivel de reflexión de un componente o circuito, con el fin de asegurar que transmite o absorbe eficientemente la energía. La medida de la impedancia compleja de una antena es un buen ejemplo.

Utilización del formato de fase del analizador

El formato de fase del analizador muestra una medida de la fase frente a la frecuencia o de la fase frente a la potencia. El analizador no puede medir una diferencia de fase de más de ±180 grados entre las señales de referencia y de prueba. Por tanto, a medida que el valor de fase varía entre +180 grados y -180 grados, crea el efecto de dientes de sierra mostrado en el siguiente gráfico.

El efecto de dientes de sierra no siempre alcanza +180 grados y -180 grados. Esto se debe a que la medida se realiza a frecuencias discretas, y el punto de datos a +180 grados y -180 grados podrá no medirse para el barrido seleccionado.

Tipos de medidas de fase

  • Los datos de la impedancia compleja son información como la resistencia, reactancia, fase y magnitud que se puede determinar a partir de una medida S11 o S22. Los datos de la impedancia compleja se pueden visualizar utilizando el formato del diagrama de Smith o el formato polar.

  • La conversión AM-PM es una medida de la cantidad de desviación de fase (PM) no deseada provocada por las variaciones de amplitud (AM) del sistema. La conversión AM-PM se define normalmente como el cambio de la fase de salida para un incremento de 1 dB en la potencia de entrada que llega a un amplificador (es decir, al punto de compresión de ganancia de 1 dB). Se expresa en grados por dB (°/dB).

  • La desviación respecto de la fase lineal es una medida de la distorsión de fase provocada por un dispositivo. Idealmente, el desplazamiento de fase a través de un dispositivo es una función lineal de la frecuencia. La cantidad de variación respecto de este desplazamiento de fase teórico se conoce como su d esviación respecto de la f ase l ineal (denominada asimismo linealidad de fase).

  • El retardo de grupo es otra manera de examinar la distorsión de fase causada por un dispositivo. El retardo de grupo es una medida del tiempo de tránsito a través de un dispositivo a una frecuencia concreta. El analizador calcula el retardo de grupo a partir de la derivada de la respuesta en fase medida.

Desviación respecto de la fase lineal frente a retardo de grupo

El analizador puede medir la linealidad del desplazamiento de fase a través de un margen de frecuencias y expresarla de dos maneras diferentes:

  • Directamente, como desviación respecto de la fase lineal

  • Valor derivado, como retardo de grupo

Ventajas para las medidas de la desviación respecto de la fase lineal:

  • Menos ruidoso que el retardo de grupo.

  • Capaz de caracterizar dispositivos que pasan señales con modulación de fase y mostrar unidades de fase en lugar de unidades de segundos.

Ventajas para las medidas de retardo de grupo:

  • Indicación de la distorsión de fase más fácil de interpretar que la d esviación respecto de la f ase l ineal.

  • Capaz de caracterizar con mayor precisión un dispositivo sometido a prueba. Esto se debe a que, al determinar el retardo de grupo, el analizador calcula la pendiente de la ondulación de fase, que depende del número de ondulaciones que ocurren por unidad de frecuencia. Al comparar dos respuestas en fase con la misma ondulación de fase entre picos, la respuesta con la pendiente de fase más grande da como resultado:

    • Más variación del retardo de grupo.

    • Más distorsión de señales.


Amp Param

Referencia de parámetros del amplificador

Véase asimismo...

Ganancia

Planeidad de ganancia

Aislamiento inverso

Deriva de ganancia frente a tiempo

Desviación respecto de fase lineal

Retardo de grupo

Pérdida de retorno (SWR, r)

Impedancia compleja

Compresión de ganancia

Conversión AM-PM

Ganancia

La relación entre la potencia de salida del amplificador (enviada a una carga Z0 ) y la potencia de entrada (enviada desde una fuente Z 0). Z0 es la impedancia característica , en este caso, 50 W.

Para niveles de señales pequeñas, la potencia de salida del amplificador es proporcional a la potencia de entrada. La ganancia de señales pequeñas es la ganancia en esta zona lineal.

A medida que aumenta el nivel de la potencia de entrada y el amplificador se acerca a un punto de saturación, la potencia de salida alcanza un límite y desciende la ganancia. La ganancia de señales grandes es la ganancia en esta zona no lineal. Véase Compresión de ganancia.

Planeidad de ganancia

La variación de la ganancia a través del margen de frecuencias del amplificador. Véase Ganancia y planeidad de señales pequeñas.

Aislamiento inverso

La medida de la transmisión desde la salida a la entrada. Es similar a la medida de la ganancia, salvo que el estímulo de la señal se aplica a la salida del amplificador. Véase Aislamiento inverso.

Deriva de ganancia frente a tiempo (temperatura, polarización)

La variación máxima de la ganancia como función del tiempo, cuando todos los demás parámetros se mantienen constantes. La deriva de la ganancia también se observa con respecto a los cambios de otros parámetros tales como la temperatura, humedad o tensión de polarización.

Desviación respecto de fase lineal

La cantidad de variación respecto de un desplazamiento de fase lineal. Idealmente, el desplazamiento de fase a través de un amplificador es una función lineal de la frecuencia. Véase Desviación respecto de fase lineal.

Retardo de grupo

La medida del tiempo de tránsito a través del amplificador como función de la frecuencia. Un desplazamiento de fase perfectamente lineal tendría un ritmo de cambio constante con respecto a la frecuencia, produciendo un retardo de grupo constante. Véase Retardo de grupo.

Pérdida de retorno (SWR, r )

La medida de la discordancia de la reflexión en la entrada o salida del amplificador en relación con la impedancia característica Z0 del sistema.

Impedancia compleja

Impedancia compleja (1+G). La cantidad de energía reflejada desde un amplificador está relacionada directamente con su impedancia. La impedancia compleja consta de un componente resistivo y uno reactivo. Se obtiene a partir de la impedancia característica del sistema y del coeficiente de reflexión. Véase Impedancia compleja.

Compresión de ganancia

Un amplificador tiene una zona de ganancia lineal en la que la ganancia es independiente del nivel de potencia de entrada (ganancia de señales pequeñas). A medida que aumenta la potencia hasta un nivel que provoca la saturación del amplificador, disminuye la ganancia.

La compresión de ganancia se determina midiendo el punto de compresión de ganancia de 1 dB del amplificador (P 1dB ), que es la potencia de salida a la que la ganancia desciende 1 dB en relación con la ganancia de señales pequeñas. Es una medida habitual de la capacidad de potencia de salida de un amplificador. Véase Compresión de ganancia.

Coeficiente de conversión AM-PM

La cantidad de cambio de fase generado en la señal de salida de un amplificador como consecuencia de un cambio de amplitud de la señal de entrada.

El coeficiente de conversión AM-PM se expresa en unidades de grados/dB a un nivel de potencia dado (normalmente P1dB, que es el punto de compresión de ganancia de 1 dB). Véase Conversión AM-PM.


Comp Imped

Véase asimismo...

Impedancia compleja

Descripción general

Conceptos

Cómo medir la
impedancia compleja

Cuando se realiza una medida S11 o S 22 del dispositivo sometido a prueba, se pueden visualizar datos de impedancia compleja tales como la reactancia y resistencia en serie, así como información sobre la fase y la magnitud. Los datos de la impedancia compleja se pueden visualizar utilizando el formato del diagrama de Smith o el formato polar.
Conceptos

Cómo medir la impedancia compleja

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es la impedancia compleja?
Visualización de datos utilizando el formato del diagrama de Smith
Visualización de datos utilizando el formato polar
Consideraciones relativas a la precisión

¿Qué es la impedancia compleja?

Los datos de la impedancia compleja son información que se puede determinar a partir de una medida S11 o S22 del dispositivo sometido a prueba, como:

  • Resistencia

  • Reactancia

  • Fase

  • Magnitud

La cantidad de potencia reflejada desde un dispositivo está relacionada directamente con la impedancia tanto del dispositivo como del sistema de medida. Por ejemplo, el valor del coeficiente de reflexión compleja ( G) es igual a 0 sólo cuando la impedancia del dispositivo y la impedancia del sistema son exactamente las mismas (es decir, la potencia máxima se transfiere desde la fuente a la carga). Cada valor de G se corresponde de manera únicamente con una impedancia compleja del dispositivo (como una función de la frecuencia), de acuerdo con la siguiente ecuación:

ZL= [(1 + G) / (1 - G)] ´ Z 0

donde ZL es la impedancia del dispositivo y Z0 es la impedancia característica del sistema de medida.

Visualización de datos utilizando el formato del diagrama de Smith

Una manera de visualizar los datos de la impedancia compleja a partir de la medida S11 o S22 del dispositivo sometido a prueba consiste en seleccionar el formato del diagrama de Smith del analizador. El diagrama de Smith es una herramienta que correlaciona el coeficiente de reflexión compleja (G) con la impedancia del dispositivo de verificación.

En un diagrama de Smith, se cambia la forma del plano de impedancia compleja para formar una cuadrícula circular, desde la que se pueden leer la reactancia y resistencia en serie (R + jX). Funciones de marcador en la pantalla del analizador:

  • Resistencia (en unidades de ohmios)

  • Reactancia como una capacitancia (en unidades de faradios) o inductancia (en unidades de henrios) equivalente.

Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente:

  • El eje horizontal (la línea continua) es la parte real de la impedancia - la resistencia. El centro del eje horizontal siempre representa la impedancia del sistema.

  • Los círculos de líneas discontinuas que cruzan el eje horizontal representan la resistencia constante. Los arcos de líneas discontinuas que forman una tangente con el eje horizontal representan la reactancia constante.

  • La mitad superior del diagrama de Smith es el área donde el componente reactivo es positivo y, por consiguiente, inductivo. La mitad inferior es el área donde el componente reactivo es negativo y, por tanto, capacitivo.

Visualización de datos utilizando el formato polar

Además de utilizar el formato del diagrama de Smith, se puede usar el formato polar del analizador para visualizar la magnitud y la fase del coeficiente de reflexión (G) a partir de la medida S11 o S22. Funciones de marcador en la pantalla del analizador:

  • Magnitud lineal (en unidades) o magnitud logarítmica (en dB)

  • Fase (en grados)

Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente:

  • Los círculos de líneas discontinuas representan el coeficiente de reflexión. El círculo situado más al exterior representa un coeficiente de reflexión (G) de 1, o la señal reflejada total. El centro del círculo representa un coeficiente de reflexión (G) de 0, o la ausencia de señal reflejada.

  • Las líneas radiales muestran el ángulo de fase de la señal reflejada. La posición situada más a la derecha corresponde a un ángulo de fase cero (es decir, la señal reflejada se encuentra a la misma fase que la señal incidente). Las diferencias de fase de 90°, ±180° y -90° corresponden a la posición superior, más a la izquierda e inferior en la reprentación polar, respectivamente.

Consideraciones relativas a la precisión

  • El diagrama de Smith se comprende con mayor facilidad cuando se utiliza con un valor de escala completa de 1,0.

  • Para obtener mayor precisión al utilizar marcadores en los formatos polar o del diagrama de Smith, activar el modo de marcador discreto.

  • La incertidumbre de las medidas de la reflexión se ve afectada por:

    • La directividad

    • El seguimiento de la reflexión

    • El acoplamiento entre fuentes

    • A daptación de carga (con dispositivos de 2 puertos)

Con una calibración de dos puertos, se reducen los efectos de estos factores. Una calibración de 1 puerto proporciona la misma precisión si la salida del dispositivo está bien terminada. Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente.

  • Si se conecta el dispositivo entre ambos puertos del analizador, se recomienda utilizar un atenuador de 10 dB en la salida del dispositivo para mejorar la exactitud de la medida. Esto no será necesario si se utiliza una calibración de 2 puertos, ya que corrige la adaptación de carga.

  • Si se conecta un dispositivo de dos puertos a un solo puerto del analizador, se recomienda utilizar una carga de alta calidad (como un patrón de calibración) en la salida del dispositivo.

  1. Conectar el dispositivo de la manera mostrada en el gráfico anterior.

  2. Preajustar el analizador.

  3. Configurar, calibrar y realizar una medida S11 o S22.

  4. Ver los datos de la impedancia:

    1. Seleccionar el formato del diagrama de Smith.

    2. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

    3. Situar el marcador para leer los componentes resistivo y reactivo de la impedancia compleja en cualquier punto de la traza.

    4. Imprimir los datos o guardarlos en un disco.

  5. Visualizar los datos de la admitancia (si se desea).

    1. Seleccionar la función de marcador para mostrar un diagrama de Smith inverso.

    2. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

    3. Situar el marcador para leer los componentes de conductancia y susceptancia de la impedancia compleja en cualquier punto de la traza. Tanto la conductancia como la susceptancia se miden en siemens (lo inverso de ohmios).

    4. Imprimir los datos o guardarlos en un disco.

  6. Ver la magnitud y la fase del coeficiente de reflexión.

    1. Seleccionar el formato del diagrama de Smith o el formato polar.

    2. Seleccionar el formato Lin Marker o Log Marker.

    3. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

    4. Situar el marcador para leer la frecuencia, magnitud y fase del coeficiente de reflexión (G) en cualquier punto de la traza.

    5. Imprimir los datos o guardarlos en un disco.


Group Delay6_5

Véase asimismo...

Retardo de grupo

Descripción general

Conceptos

Cómo medir el retardo de grupo

El retardo de grupo es una medida de la distorsión de fase. El retardo de grupo es el tiempo real de tránsito de una señal a través del dispositivo sometido a prueba como una función de la frecuencia. Cuando se especifica el retardo de grupo, es importante especificar la apertura utilizada para la medida.
Conceptos
Cómo medir el retardo de grupo

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es el retardo de grupo?
Retardo de grupo frente a desviación respecto de la fase lineal
¿Qué es la apertura?
Consideraciones relativas a la precisión

¿Qué es el retardo de grupo?

El retardo de grupo es:

* Una medida de la distorsión de fase del dispositivo.
* El tiempo de tránsito de una señal a través de un dispositivo, frente a la frecuencia.
* La derivada de la característica de fase del dispositivo con respecto a la frecuencia.

Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente:

La característica de fase de un dispositivo normalmente consta de componentes de desplazamiento de fase tanto lineales como de orden superior (desviaciones respecto de la fase lineal).

Componente de desplazamiento de fase lineal: | Componente de desplazamiento de fase de orden superior:
Representa el tiempo de tránsito medio de la señal. | Representa variaciones del tiempo de tránsito para diferentes frecuencias.
Atribuido a la longitud eléctrica del dispositivo de verificación. | Fuente de distorsión de señales.

Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente:

En una medida del retardo de grupo:

  • El componente de desplazamiento de fase lineal se convierte a un valor constante (que representa el retardo medio).

  • El componente de desplazamiento de fase de orden superior se transforma en desviaciones respecto del retardo de grupo constante (u ondulación del retardo de grupo).

  • Las desviaciones del retardo de grupo provocan una distorsión de la señal, de la misma manera que las desviaciones respecto de la fase lineal causan distorsión.

  • La traza de la medida muestra el tiempo que tarda cada frecuencia en desplazarse a través del dispositivo sometido a prueba.

Véase la siguiente ecuación para comprender mejor la explicación de cómo calcula el analizador el retardo de grupo:

  • Los datos de la fase se utilizan para determinar el cambio de fase (-d f).

  • Se utiliza una apertura de frecuencia especificada para determinar el cambio de frecuencia (d w).

  • Utilizando los dos valores anteriores se calcula una aproximación para el ritmo de cambio de la fase con la frecuencia.

  • Esta aproximación representa el retardo de grupo en segundos (suponiendo que se produzca un cambio de fase lineal a través de la apertura de frecuencia especificada).

Retardo de grupo frente a desviación respecto de la fase lineal

El retardo de grupo es a menudo una indicación más exacta de la distorsión de fase que la desviación respecto a la f ase lineal .

Los resultados de la desviación respecto de la fase lineal aparecen en la parte superior del siguiente gráfico: El dispositivo 1 y el dispositivo 2 tienen el mismo valor, a pesar de su aspecto diferente.

Los resultados del retardo de grupo aparecen en la parte inferior:
El dispositivo 1 y el dispositivo 2 tienen valores diferentes de retardo de grupo. Esto se debe a que, al determinar el retardo de grupo, el analizador calcula la pendiente de la ondulación de fase, que depende del número de ondulaciones que ocurren por unidad de frecuencia.

¿Qué es la apertura?

Durante una medida del retardo de grupo, el analizador mide la fase a dos frecuencias muy próximas y, a continuación, calcula la pendiente de la fase. El intervalo de frecuencias (frecuencia delta) entre los dos puntos de medida de la fase se denomina apertura. El cambio de la apertura puede dar como resultado valores diferentes de retardo de grupo. La pendiente calculada (fase delta) varía a medida que se aumenta la apertura. ésta es la razón por la que, al comparar los datos del retardo de grupo, es necesario conocer la apertura que se utilizó para realizar las medidas.

Véase el gráfico mostrado a continuación para entender mejor la explicación siguiente:

Apertura estrecha: | Apertura ancha:
Proporciona más detalle en la linealidad de la fase. | Proporciona menos detalle en la linealidad de la fase, puesto que parte de la respuesta de fase se promedia o no se mide.
Hace que la medida sea susceptible al ruido (relación señal-ruido menor) y a la resolución del detector de fase del analizador. | Hace que la medida sea menos susceptible al ruido (relación señal-ruido mayor).

El valor por defecto del analizador para la apertura de retardo de grupo es el recorrido de frecuencias dividido por el número de puntos a lo ancho de la pantalla. Hay dos maneras de ajustar la apertura a un valor diferente.

  1. Ajustar el número de puntos de medida o el recorrido de frecuencias .

  • Al incrementar el número de puntos o reducir el recorrido de frecuencias se estrecha la apertura.

  • Al reducir el número de puntos y/o aumentar el recorrido de frecuencias se ensancha la apertura.

Nota: si la apertura es demasiado ancha (más de 180° de desplazamiento de fase entre puntos de frecuencia adyacentes), ocurrirán errores en los datos del retardo de grupo.

  2. Utilizar la función de suavizado del analizador.

  • Realiza un barrido único, moviendo el promedio de los puntos de datos adyacentes a lo largo de un porcentaje especificado del recorrido de frecuencias .

  • Tiene como resultado una acción similar a cambiar el intervalo de frecuencias entre puntos.

  • Permite utilizar una apertura más ancha, porque puede ocurrir un desplazamiento de fase de más de 180º a través de la apertura de suavizado.

Se pueden realizar medidas del retardo de grupo en los siguientes tipos de barrido:

  • Frecuencia lineal

  • Indicar segmento de barrido de frecuencia

La apertura del retardo de grupo varía dependiendo del espaciado de frecuencias y de la densidad de puntos, por lo que la apertura no es constante en el barrido de segmentos. En el barrido de segmentos se pueden definir puntos de frecuencia adicionales para asegurar la obtención de la apertura deseada.

Consideraciones relativas a la precisión

Es importante mantener la diferencia de fase entre dos puntos de medida adyacentes a menos de 180° (véase el gráfico siguiente). De lo contrario podrá obtenerse información incorrecta de fase y retardo. Puede producirse un submuestreo al medir dispositivos con una longitud eléctica larga. Se puede comprobar si la diferencia de fase medida entre dos puntos adyacentes es inferior a 180° ajustando los siguientes valores hasta que ya no cambie la traza de la medida:

  • Incrementar el número de puntos

  • Estrechar el recorrido de frecuencias

También se puede utilizar el retardo eléctrico para compensar este efecto.

La respuesta en frecuencia es el error dominante en una configuración de prueba del retardo de grupo. La realización de una calibración de medida de la respuesta del cable pasivo reduce significativamente este error. Para obtener mayor precisión, realizar una calibración de medida de 2 puertos.

Especialmente para un amplificador, la respuesta puede variar de manera diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

Cómo medir el retardo de grupo

  1. Preajustar el analizador.

  2. Si el dispositivo sometido a prueba es un amplificador, podrá ser necesario ajustar la potencia de la fuente del analizador.

    • Ajustar la potencia de la fuente del analizador para que se encuentre en la zona lineal de la respuesta de salida del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB).

    • Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  3. Conectar el dispositivo sometido a prueba de la manera mostrada en el siguiente gráfico.

  3. Seleccionar una medida S21.

  4. Seleccionar los valores para el dispositivo sometido a prueba, incluidos los siguientes:

    • número de puntos de medida: máximo

    • formato: retardo

    • escala: e scala automática

  5. Retirar el dispositivo sometido a prueba y realizar una calibración de medida.

  6. Volver a conectar el dispositivo sometido a prueba.

  7. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

  8. Utilizar la función de suavizado del analizador para aumentar la apertura, reduciendo el ruido en la traza mientras se mantiene un detalle significativo. Para aumentar la apertura:

    • Activar la función de suavizado del analizador.

    • Variar la apertura de suavizado (hasta un 25% del recorrido barrido).

  9. Utilizar los marcadores para medir el retardo de grupo (expresado en segundos) a una frecuencia concreta de interés.

  10. Imprimir los datos o guardarlos en un disco.


Output Pwr

Véase asimismo...

Potencia de salida absoluta

Descripción general

Conceptos

Cómo medir
la potencia de salida absoluta

La medida de la potencia de salida absoluta indica la potencia absoluta comparada con la frecuencia.
Conceptos

Cómo medir la potencia de salida absoluta

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es la potencia de salida absoluta?
¿Por qué se debe medir la potencia de salida absoluta?
Consideraciones relativas a la precisión

¿Qué es la potencia de salida absoluta?

Una medida de la potencia de salida absoluta indica la potencia que hay presente en el puerto de entrada del analizador. Esta potencia es absoluta, es decir, no está referenciada (relacionada) con la potencia incidente o de la fuente. En el formato de magnitud logarítmica, los valores asociados al eje vertical de la cuadrícula se indican en unidades de dBm, que es la potencia medida con referencia a 1 mW.

  • 0 dBm = 1 mW

  • -10 dBm = 100 mW

  • +10 dBm = 10 mW

En el formato de magnitud lineal, los valores asociados al eje vertical de la cuadrícula se indican en unidades de vatios (W).

¿Por qué se debe medir la potencia de salida absoluta?

La potencia de salida absoluta se mide cuando la salida del amplificador se debe cuantificar como potencia absoluta, y no como una medida de potencia relativa relacionada. Por ejemplo, durante una medida de la compresión de ganancia, es normal medir asimismo la potencia de salida absoluta. Esto muestra la potencia absoluta que sale del amplificador en el punto en que ocurre la compresión de 1 dB.

Consideraciones relativas a la precisión

  • La potencia de salida del amplificador debería atenuarse suficientemente, si fuera necesario. Una potencia de salida excesiva podría:

    • dañar el receptor del analizador

    • rebasar el nivel de compresión de entrada del receptor del analizador, provocando medidas inexactas

  • La atenuación de la potencia de salida del amplificador se puede conseguir utilizando:

    • Atenuadores

    • Acopladores

  • El amplificador podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

Realizar el procedimiento siguiente para medir la potencia de salida absoluta:

  1. Preajustar el analizador.

  2. Seleccionar una medida de potencia no relacionada (receptor B).

  3. Ajustar la potencia de la fuente del analizador a 0 dBm.

  4. Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  5. Conectar el amplificador de la manera mostrada en el siguiente gráfico y suministrar la polarización de c.c.

  6. Seleccionar los ajustes del analizador para el amplificador sometido a prueba.

  7. Retirar el amplificador y conectar los puertos de medida entre sí. Almacenar los datos en la memoria. Asegurarse de incluir el atenuador y los cables en la configuración de prueba si se van a utilizar al medir el amplificador.

  8. Guardar el estado del instrumento en la memoria.

  9. Volver a conectar el amplificador.

  10. Seleccionar la función matemática de datos Data/Memory.

  11. Ajustar la escala de la medida mostrada para visualizarla de manera óptima y utilizar un marcador para medir la potencia de salida absoluta a una frecuencia deseada.

  12. Imprimir los datos o guardarlos en un disco.


Hpower

Véase asimismo...

Medidas de componentes de alta potencia

Descripción general

Conceptos

Diagrama de bloques

Configuraciones estándar

Opción 015

Cómo medir

Se puede configurar el analizador para realizar medidas de dispositivos de alta potencia. Los dispositivos de alta potencia tienen uno o ambos de los siguientes atributos:

  • Necesitan una potencia de entrada superior a la que puede proporcionar el analizador

  • Producen una potencia de salida superior a la que puede medir un analizador estándar

Por consiguiente, las diversas configuraciones de analizador tienen como finalidad:

  • Añadir amplificación a la señal de estímulo del dispositivo utilizando un amplificador reforzador.

  • Añadir atenuación a la señal recibida por el analizador para proteger los componentes del analizador de una potencia excesiva.
Conceptos

Diagramas de bloques y guía de selección de configuraciones

Configuraciones estándar de analizador

Configuraciones de analizador con la Opción 015

Cómo medir dispositivos de alta potencia

Haga clic en un botón para obtener información acerca de los siguientes temas:
Por qué pueden plantear un reto las medidas de alta potencia
Amplificadores de estaciones base de alta potencia CDMA
Nivelación externa
Calibración de medida
Verificación de amplificadores con circuitos AGC
Consideraciones relativas a la precisión

Por qué pueden plantear un reto las medidas de alta potencia

Entre los retos que plantea la utilización de estas configuraciones cabe citar los siguientes:

  • Recepción segura de señales de alto nivel y recepción exacta de señales de bajo nivel

  • C alibración y medidas exactas

  • Algunos tipos de calibración son imposibles

  • El número de parámetros que pueden medirse es limitado

Por ejemplo, los parámetros S inversos no se pueden medir en algunas configuraciones. Esto se traduce en una incapacidad para realizar determinadas calibraciones, limitando a exactitud de las medidas.

Para obtener más información sobre las medidas de alta potencia utilizando un analizador de redes, visite la página Web de Agilent en http://\www.agilent.com/find/pna. Busque la nota de aplicación Application Note 1287-6, "Using a Network Analyzer to Characterize High-Power Components" (número de referencia 5966-3319E).

Amplificadores de estaciones base de alta potencia CDMA

El nivel de señal de los amplificadores de las estaciones base de alta potencia CDMA debe amplificarse suficientemente para evitar las pérdidas inherentes que se producen durante la transmisión inalámbrica, con el fin de que los teléfonos móviles puedan recibir la señal. Dos de los requisitos típicos de los amplificadores de las estaciones base CDMA son:

  • Potencia de salida de 8 - 45 W (39 - 46,5 dBm)

  • Ganancia de 30 - 40 dB

(Estos requisitos pueden variar de un fabricante a otro, dependiendo del diseño de sus sistemas.)

El alto nivel de potencia de salida del amplificador CDMA debe reducirse hasta un nivel que pueda manejar con seguridad el analizador. Debe tenerse cuidado al seleccionar los siguientes componentes para asegurar que su capacidad de tratamiento de la potencia sea adecuada (véase el gráfico siguiente).

  • Para analizadores estándar, se instala un acoplador externo de alta potencia en la salida del dispositivo de verificación. El acoplador se utiliza para reducir la potencia de salida del dispositivo de verificación antes de que pase al analizador. El brazo de paso del acoplador está terminado con una carga especial que puede disipar la alta potencia. El brazo acoplado se conecta a un atenuador de alta potencia externo que se conecta a la entrada del analizador.

  • Para analizadores equipados con la Opción 015 (equipo de verificación configurable), sólo se necesitan el acoplador externo de alta potencia y la carga mencionados anteriormente. El atenuador de alta potencia externo no es necesario, puesto que la Opción 015 proporciona atenuadores de etapa internos (0 - 35 dB) para proteger los receptores.

Nota: Para asegurar el funcionamiento seguro del analizador de redes, la potencia de entrada máxima en el puerto de prueba no debe ser superior a +30 dBm (1 vatio).

Para asegurar que las medidas sean exactas, también se deberían tener en cuenta las consideraciones térmicas durante la medida. Por ejemplo, cuando se verifiquen amplificadores de estaciones base CDMA, la carga utilizada en el acoplador de la salida debería:

  • Ser capaz de absorber la potencia producida por el amplificador sometido a prueba. La mayoría de las cargas diseñadas para utilizarse con señales pequeñas sólo admiten un máximo de aproximadamente 1 vatio de potencia. Por encima de este límite, deberán utilizarse cargas especiales que pueden disipar más potencia.

  • Permitir que se estabilice la temperatura si sus características de impedancia cambian significativamente en función de la temperatura.

Nivelación externa

La nivelación externa se puede utilizar para compensar el rendimiento no lineal de un amplificador reforzador con el fin de obtener una mayor exactitud de medida. En configuraciones de medida con nivelación externa, el amplificador reforzador va seguido de un acoplador cuyo brazo acoplado dirige la señal de referencia hasta un bifurcador de potencia. Desde el bifurcador de potencia, la señal de referencia se encamina hasta dos lugares:

  • El receptor de referencia interno del analizador.

  • La entrada del detector externo situado en el panel posterior del analizador, a través de los circuitos de nivelación externa.

Véase el gráfico de los circuitos de nivelación externa (facilitados por el usuario) mostrado a continuación para entender mejor la explicación siguiente:

  • Los circuitos de nivelación externa constan fundamentalmente de

    • Un diodo detector

    • Un amplificador operativo

  • El circuito del amplificador operativo detecta los cambios de potencia medidos por el diodo. Este circuito regula la tensión en la entrada del detector externo, ajustando la potencia de la fuente para conseguir una respuesta plana en el DUT en tiempo real.

  • Para que la nivelación externa funcione correctamente, la tensión en la entrada del detector externo debe estar comprendida entre 0,002 mVcc y -6 Vcc, dependiendo de la frecuencia y del nivel de potencia.

  • Si se realiza un cambio demasiado grande en la potencia de la señal de referencia, a través de los atenuadores de etapa internos, la función de nivelación externa podrá no surtir efecto.

Nota: Cuando se realice una calibración, deberá mantenerse activo el proceso de nivelación de la fuente, de la misma manera que estará activo durante la medida.

Los gráficos siguientes muestran dos configuraciones de medida de alta potencia con nivelación externa. La configuración del primer ejemplo corresponde a un analizador estándar con alta potencia en la dirección de avance únicamente. La configuración del segundo ejemplo corresponde a un analizador equipado con la Opción 015 (equipo de verificación configurable) con alta potencia en las direcciones de avance y de retroceso.

En una configuración de medida de alta potencia, el rendimiento del amplificador reforzador influye en la precisión de medida del DUT. Como se muestra en el gráfico siguiente, la ondulación del amplificador reforzador provoca ondulación en la respuesta del dispositivo sometido a prueba.

A continuación se enumeran algunas causas de la ondulación del amplificador reforzador:

  • Amplificador reforzador de baja calidad.

  • Tensión eléctrica ruidosa.

  • Amplificador reforzador saturado.

Calibración de medida

La calibración de un analizador elimina los errores sistemáticos y aumenta la exactitud de las medidas. En esta guía didáctica se ha indicado qué calibraciones son posibles para diversas configuraciones. Se han descrito los dos tipos siguientes de calibración:

  • Calibración de 2 puertos: la más precisa, ya que elimina todos los errores sistemáticos de la configuración de medida, idealmente hasta el punto en el que el dispositivo sometido a prueba se conecta al analizador.

  • Calibración de la respuesta del cable pasivo: es menos precisa y sólo elimina los errores de seguimiento de la frecuencia. Los errores de seguimiento de la frecuencia están asociados a las diferencias de respuesta en frecuencia entre un canal y otro.

Nota: La calibración debería realizarse con todo el hardware instalado. Por ejemplo, deben incluirse los amplificadores reforzadores, cables, atenuadores o acopladores que se vayan a utilizar al medir el DUT.

En los temas siguientes se abordan técnicas y consideraciones para obtener los mejores resultados de calibración.

Precisión dinámica

Mediante el examen de la respuesta de la precisión dinámica del analizador se pueden optimizar los niveles de potencia para la calibración y la medida. La precisión dinámica se refiere a la incertidumbre que existe cuando se calibra a un nivel de señal y se mide a otro nivel. El analizador muestra una incertidumbre extremadamente baja si la potencia del receptor está comprendida entre -10 y -60 dBm, independientemente del nivel de potencia de la calibración. La calibración y las medidas deben realizarse de modo que el nivel de señal en el receptor se encuentre en este margen de alta precisión. A niveles de señal más bajos, el ruido es un factor a tener en cuenta; a niveles más altos, la compresión del receptor es un factor a tener en cuenta.

Niveles de potencia de calibración

Si se está midiendo un amplificador y el nivel de potencia de salida es superior al nivel de potencia de entrada, ¿a qué nivel de potencia se debería realizar la calibración? Por lo general, se debe calibrar a la potencia más alta posible por debajo del comienzo de la compresión del receptor con el fin de reducir el ruido.

Calibración a un nivel de potencia frente a dos niveles de potencia

Calibración a un nivel de potencia:

  • Una calibración de respuesta se puede realizar a un nivel de potencia, ya que sólo se realiza un barrido en dirección de avance.

  • Una calibración de 2 puertos también se puede realizar a un nivel de potencia. El nivel de potencia utilizado se determinaría a partir de la especificación de precisión dinámica (-10 y -60 dBm).

Calibración a dos niveles de potencia:

  • La calibración de 2 puertos se puede realizar a diferentes niveles de potencia, ya que se realizan barridos en dirección de avance y de retroceso.

  • El analizador puede calibrar un puerto utilizando un nivel de potencia y el otro puerto usando otro nivel de potencia para hacer coincidir con mayor precisión los niveles de potencia presentes durante la medida de un dispositivo sometido a prueba.

Utilización de patrones de calibración a alta potencia

La capacidad de tratamiento de la potencia de uno de los patrones de calibración puede plantear un problema cuando se calibra a elevados niveles de potencia:

  • la carga disipa energía. Como consecuencia, es necesario asegurar que la carga admite el nivel de potencia.

  • Los patrones de circuito abierto, circuito cerrado y cable pasivo no plantean problemas, ya que no disipan energía.

PRECAUCIóN: Cuando se utilice un circuito abierto o cerrado durante la calibración , será necesario asegurar que el nivel de la potencia incidente sea suficientemente bajo, con el fin de que la señal reflejada no supere la entrada máxima a la parte de prueba (+30 dBm).

Verificación de amplificadores con circuitos AGC

Algunos amplificadores contienen un circuito AGC (control automático de ganancia). Los circuitos AGC intentan mantener constante la potencia de salida del amplificador ajustando la ganancia para tener en cuenta las variaciones que se producen en la entrada del amplificador. Los amplificadores con circuitos AGC pueden plantear un problema cuando se miden con el analizador, especialmente a niveles de potencia elevados.

El apagado de la potencia de la fuente del amplificador plantea un problema con los amplificadores que contienen un circuito AGC. El analizador mantiene la potencia constante mientras realiza un barrido o rastreo si sólo se utiliza una banda de frecuencias. Sin embargo, el analizador suprime, o apaga la fuente de alimentación, cuando cambia de una banda de frecuencias a otra mientras realiza barridos o rastreos. Estos cruces de bandas ocurren a las siguientes frecuencias:

  • 10 MHz

  • 750 MHz

  • 1.500 MHz

  • 3.000 MHz

  • 4.500 MHz

  • 6.500 MHz

Cuando se suprime la fuente de alimentación del analizador, el circuito AGC del amplificador intenta compensar este hecho aumentando su ganancia para mantener constante el nivel de la potencia de salida. Cuando finaliza la supresión y vuelve a iniciarse el barrido, el analizador restaura su señal y de pronto vuelve a llegar potencia a la entrada del amplificador, que ha aumentado su ganancia. Si el circuito AGC no puede responder con suficiente rapidez, la elevada potencia de salida momentánea podrá dañar o destruir:

  • el amplificador

  • el receptor del analizador

Hay que tener presente esta posibilidad de daños o destrucción cuando tiene lugar la supresión de la potencia mientras el analizador realiza barridos o rastreos a través de múltiples bandas de frecuencias.

Consideraciones relativas a la precisión

  • El dispositivo de alta potencia sometido a prueba podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el dispositivo se encuentre a la temperatura deseada.

  • La incertidumbre de las medidas y la flexibilidad se pueden mejorar midiendo la señal incidente después del amplificador reforzador, en lugar de hacerlo antes de éste. La medida de la señal incidente después del amplificador reforzador elimina los efectos de las posibles desadaptaciones de la fuente.

  • Para proteger un receptor del analizador contra una potencia de entrada excesiva, deberían seguirse estos pasos si fuese necesario añadir un atenuador o acoplador externo.

    • Determinar la potencia máxima de la señal de entrada del receptor.

    • Restar el nivel de potencia necesario en el receptor.

    • Elegir el valor adecuado para el atenuador o el acoplador (o ambos) para proporcionar el nivel deseado de potencia de entrada del receptor.

  • La reducción del ancho de banda de IF o el uso del promediado aumenta la precisión de la medida, a costa de la velocidad de medida.

Diagrama de bloques de un analizador estándar
Diagrama de bloques de un analizador con la Opción 015
Guía de selección de configuraciones

Diagrama de bloques de un analizador estándar

Analizador con el equipo de verificación configurable Opción 015

El analizador equipado con la Opción 015 (equipo de verificación configurable) proporciona dos funciones que permiten medir niveles de potencia más elevados que con el analizador estándar:

  • Atenuadores de etapa (0 - 35 dB) entre los acopladores y receptores para los puertos 1 y 2. Estos atenuadores de etapa ajustan la señal a un nivel de potencia óptimo para el receptor. Véase Atenuación de la fuente.

  • Acceso directo (a través de los canales SOURCE OUT y COUPLER IN) a las rutas de estímulo de RF en los puertos 1 y 2. Esto permite:

    • Situar un amplificador reforzador de manera que su a islamiento inverso no degrade la precisión de la medida

    • Añadir aisladores de alta potencia para proteger los componentes internos del analizador

Guía de selección de configuraciones

Las siguientes configuraciones mostradas en esta guía didáctica ofrecen diferentes niveles de precisión y capacidad:
Configuración 1 (analizador estándar): alta potencia (unidireccional), sin amplificador reforzador, con calibración de 2 puertos
Configuración 2 (analizador estándar): alta potencia (unidireccional) con calibración de respuesta
Configuración 3 (analizador estándar): alta potencia (unidireccional) con calibración de 2 puertos
Configuración 4 (analizador con Opción 015): alta potencia (unidireccional) con calibración de respuesta
Configuración 5 (analizador con Opción 015): alta potencia (unidireccional) con calibración de 2 puertos
Configuración 6 (analizador con Opción 015): alta potencia (bidireccional) con calibración de 2 puertos

Para seleccionar la configuración de analizador de redes correcta, deberá considerarse lo siguiente:

  • Dispositivo sometido a prueba

  • Medidas necesarias

  • Precisión necesaria

Las herramientas siguientes tienen como finalidad ayudar al usuario a seleccionar la mejor configuración de analizador para su aplicación de medida.

  • Diagramas de bloques de configuraciones de prueba de alta potencia

  • Información sobre los siguientes aspectos:

    • Equipos

    • Elecciones de calibración

    • Ventajas y limitaciones de cada configuración

  • Tablas de características de configuración para los analizadores estándar y equipados con la Opción 015

Analizador estándar
Medidas de alta potencia |  |  |  |  | Calibraciones
Config. | Fuente reforzada | Trans. de avance | Trans. y Refl. de avance | Avance/ Retroceso | 2 puertos | Cable pasivo
1 |  |  |  | X | X | X
2 | X | X |  |  |  | X
3 | X |  | X |  | X | X

Equipo de verificación configurable Opción 015
Medidas de alta potencia |  |  |  |  | Calibraciones
Config. | Fuente reforzada | Trans. de avance | Trans. y Refl. de avance | Avance/ Retroceso | 2 puertos | Cable pasivo
4 | X |  | X |  |  | X
5 | X |  | X |  | X | X
6 | X |  |  | X | X | X

Las siguientes configuraciones de analizador estándar mostradas en esta guía didáctica ofrecen diferentes niveles de precisión y capacidad:
Configuración 1 (analizador estándar): alta potencia (unidireccional), sin amplificador reforzador, con calibración de 2 puertos
Configuración 2 (analizador estándar): alta potencia (unidireccional) con calibración de respuesta
Configuración 3 (analizador estándar): alta potencia (unidireccional) con calibración de 2 puertos

Configuración 1 (analizador estándar)

Atributos de esta configuración:

  • Medidas de alta potencia en una dirección únicamente

  • Atenuación externa para el receptor del puerto 2 del analizador

  • S11, S12, S21y S22

  • Calibración de 2 puertos

  • 1 Componente externo

  • M argen dinámico reducido como consecuencia de pérdida de potencia en los acopladores de los puertos

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • No necesitan altos niveles de potencia de excitación (es decir, dentro de las especificaciones de nivel de potencia del analizador)

    • Normalmente se someten a prueba en su zona lineal

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • El DUT entre el puerto 1 del analizador y un atenuador o acoplador.

  • Un atenuador o acoplador entre el dispositivo sometido a prueba y el puerto 2 del analizador. Puesto que el dispositivo sometido a prueba tiene alta ganancia, el receptor debe estar protegido de la elevada potencia de salida.

Si se está utilizando un acoplador, deberá terminarse su brazo de paso con una carga de impedancia característica. El brazo acoplado del acoplador envía una pequeña parte de la señal de entrada al puerto 2. Para un acoplador de 20 dB, la señal del brazo de acoplamiento es 20 dB inferior a la intensidad de la señal en la entrada.

Elecciones de calibración

  • 2 puertos

  • Respuesta del brazo pasivo

La atenuación en el puerto 2 degrada la d irectividad no corregida del puerto 2 dos veces el valor de la atenuación. Esto limita la estabilidad de la calibración y puede hacer que las medidas S 22 sean muy ruidosas. Si se necesita realizar una medida S22 :

  1. Realizar la calibración para medidas regresivas a un nivel de potencia más alto.

  2. Reducir el nivel de potencia cuando se realicen medidas progresivas.

  3. Elevar el nivel de potencia para realizar medidas regresivas.

Configuración 2 (analizador estándar)

Atributos de esta configuración:

  • Medidas de alta potencia en una dirección únicamente

  • Atenuación externa para el receptor del puerto 2 del analizador

  • S21 únicamente (S11 no es posible debido al amplificador reforzador)

  • Calibración de la respuesta del cable pasivo

  • Margen dinámico reducido debido a la pérdida de potencia a través del acoplador del puerto 2

  • No se producen pérdidas de potencia del amplificador reforzador en el equipo de verificación

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • Necesitan un amplificador reforzador para elevados niveles de potencia de excitación

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • Un amplificador reforzador al puerto 1 del analizador.

  • Un acoplador entre el amplificador reforzador y el dispositivo sometido a prueba.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R1. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

  • El dispositivo sometido a prueba entre el acoplador y un atenuador o acoplador.

  • El atenuador o acoplador entre la salida del dispositivo sometido a prueba y el puerto de prueba del analizador. Puesto que el dispositivo sometido a prueba tiene elevada ganancia, el receptor debe protegerse de la elevada potencia de salida.

Si se está utilizando un acoplador, terminar su brazo de paso con una carga de impedancia característica. El brazo acoplado del acoplador envía una pequeña parte de la señal de entrada al puerto 2. Para un acoplador de 20 dB, la señal del brazo de acoplamiento es 20 dB inferior a la intensidad de la señal en la entrada.

Configuración 3 (analizador estándar)

Atributos de esta configuración:

  • Medidas de alta potencia en una dirección únicamente

  • Atenuación externa para el receptor del puerto 2 del analizador

  • S11, S21

  • Calibraciones de 2 puertos y de respuesta del cable pasivo

  • 6 Componentes externos

  • M argen dinámico reducido debido a la pérdida de potencia a través del acoplador del puerto 2

  • No se producen pérdidas de potencia del amplificador reforzador en el equipo de verificación

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • Necesitan un amplificador reforzador para elevados niveles de potencia de excitación

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • Un amplificador reforzador al puerto 1 del analizador.

  • Un acoplador a la salida del amplificador reforzador.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R1. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

  • Un acoplador inverso entre el acoplador de avance y el DUT.

  • El brazo acoplado del acoplador inverso al canal IN A. Se utiliza para realizar medidas de reflexión de avance.

  • El dispositivo sometido a prueba entre el acoplador inverso y un atenuador o acoplador.

  • El atenuador o acoplador entre la salida del dispositivo sometido a prueba y el puerto de prueba del analizador. Puesto que el dispositivo sometido a prueba tiene elevada ganancia, el receptor debe protegerse de la elevada potencia de salida.

Si se está utilizando un acoplador, terminar su brazo de paso con una carga de impedancia característica. El brazo acoplado del acoplador envía una pequeña parte de la señal de entrada al puerto 2. Para un acoplador de 20 dB, la señal del brazo de acoplamiento es 20 dB inferior a la intensidad de la señal en la entrada.

Las siguientes configuraciones mostradas en esta guía didáctica ofrecen diferentes niveles de precisión y capacidad:
Configuración 4 (analizador con Opción 015): alta potencia (unidireccional) con calibración de respuesta
Configuración 5 (analizador con Opción 015): alta potencia (unidireccional) con calibración de 2 puertos
Configuración 6 (analizador con Opción 015): alta potencia (bidireccional) con calibración de 2 puertos

Configuración 4 (analizador con Opción 015)

Atributos de esta configuración:

  • Medidas de alta potencia en una dirección únicamente

  • Utiliza el receptor B del analizador

  • S11, S21

  • Calibración de la respuesta del cable pasivo

  • 3 Componentes externos

  • El canal IN B permite el máximo m argen dinámico

  • Margen dinámico reducido debido a la pérdida de potencia a través del acoplador del puerto 1

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • Necesitan un amplificador reforzador para elevados niveles de potencia de excitación

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • Un amplificador reforzador al canal SOURCE OUT del puerto 1.

  • Un acoplador entre el amplificador reforzador y el canal COUPLER IN del puerto 1.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R1. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

  • El DUT entre el puerto 1 del analizador y el canal IN B. La utilización del canal IN B permite disponer del máximo margen dinámico, puesto que no se produce ninguna pérdida de potencia a través del acoplador del puerto 2.

Puesto que estos dispositivos tienen elevada ganancia, el receptor debe protegerse de la elevada potencia de salida. Utilizar el atenuador de etapa interno del analizador (0-35 dB) para proteger el receptor B.

Configuración 5 (analizador con Opción 015)

Atributos de esta configuración:

  • Medidas de alta potencia en una dirección únicamente

  • Se utiliza un aislador para proteger los componentes internos del analizador de una potencia excesiva

  • S11, S21

  • Calibraciones de 2 puertos y de respuesta del cable pasivo

  • 4 Componentes externos

  • Margen dinámico reducido debido a la pérdida de potencia a través de los acopladores de los puertos

  • El aislador protege el conmutador y la fuente

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • Necesitan un amplificador reforzador para elevados niveles de potencia de excitación

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • Un amplificador reforzador al canal SOURCE OUT del puerto 1.

  • Un acoplador entre el amplificador reforzador y el canal COUPLER IN del puerto 1.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R1. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

  • El DUT entre el puerto 1 y el puerto 2 del analizador.

  • Un aislador entre los canales SOURCE OUT y COUPLER IN del puerto 2.

Puesto que estos dispositivos tienen elevada ganancia, el receptor debe protegerse de la elevada potencia de salida. Utilizar los atenuadores de etapa internos del analizador (0-35 dB) para proteger el receptor B.

Configuración 6 (analizador con Opción 015)

Atributos de esta configuración:

  • Medidas de alta potencia en dos direcciones (avance y retroceso)

  • S11, S12, S21y S22

  • Calibraciones de 2 puertos y de respuesta del cable pasivo

  • 6 Componentes externos

  • M argen dinámico reducido como consecuencia de la pérdida de potencia a través de los acopladores de los puertos

  • Para dispositivos de prueba con estas características:

    • Elevada ganancia

    • Necesitan un amplificador reforzador para elevados niveles de potencia de excitación

Equipos

Realizar las conexiones siguientes de la manera mostrada en el diagrama de bloques:

  • Un amplificador reforzador al canal SOURCE OUT del puerto 1.

  • Un acoplador entre el amplificador reforzador y el canal COUPLER IN del puerto 1.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R1. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

  • El dispositivo sometido a prueba entre el puerto 1 y el puerto 2 del analizador.

  • Un amplificador reforzador al canal SOURCE OUT del puerto 2.

  • Un acoplador entre el amplificador reforzador y el canal COUPLER IN del puerto 2.

  • Un atenuador al brazo acoplado del acoplador.

  • La parte del brazo acoplado de la señal de fuente reforzada al canal IN R2. Esta señal se convierte en la señal de referencia utilizada en el cálculo de la relación.

Puesto que estos dispositivos tienen elevada ganancia, los receptores deben protegerse de la elevada potencia de salida. Utilizar los atenuadores de etapa internos del analizador (0-35 dB) para proteger los receptores A y B.

Cómo medir dispositivos de alta potencia

  1. Seleccionar la configuración de analizador adecuada para el dispositivo sometido a prueba y las necesidades de medida. No conectar todavía el dispositivo sometido a prueba.

  2. Preajustar el analizador.

  3. Si el dispositivo sometido a prueba es un amplificador, podrá ser necesario ajustar la potencia de la fuente del analizador.

    • Ajustar la potencia de la fuente del analizador para que se encuentre en la zona lineal de la respuesta de salida del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB).

    • Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  4. Seleccionar la medida deseada.

  5. Conectar el dispositivo sometido a prueba.

  6. Seleccionar los ajustes para el dispositivo sometido a prueba.

  7. Retirar el dispositivo sometido a prueba y realizar una calibración de medida. Asegurarse de incluir los amplificadores reforzadores, cables, atenuadores o acopladores que se vayan a utilizar al medir el dispositivo sometido a prueba.

  8. Guardar el estado del instrumento en la memoria.

  9. Volver a conectar el DUT.

  10. Ajustar la escala de la medida mostrada para visualizarla de manera óptima y utilizar marcadores para leer los resultados de la medida.

  11. Imprimir los datos o guardarlos en un disco.


AM-PM

Véase asimismo...

Conversión AM-PM

Descripción general

Conceptos

Cómo medir la
conversión AM-PM

La conversión AM-PM de un amplificador es una medida de la cantidad de desviación de fase (PM) no deseada provocada por variaciones de amplitud (AM) inherentes al sistema.
Conceptos

Cómo medir la conversión AM-PM

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿En qué consiste una conversión AM-PM?

¿Por qué se debe medir la conversión AM-PM?

Consideraciones relativas a la precisión

¿En qué consiste una conversión AM-PM?

La conversión AM-PM mide la cantidad de desviación de fase (PM) no deseada provocada por las variaciones de amplitud (AM) del sistema. Por ejemplo, la desviación de fase (PM) no deseada en un sistema de comunicaciones puede deberse a:

  • Variaciones de amplitud (AM) no intencionadas

    • Ondulación de la fuente de alimentación

    • Deriva térmica

    • Desvanecimiento multirrecorrido

  • Modulación intencionada de la amplitud de la señal

    • QAM

    • Modulación por ráfagas

La conversión AM-PM se define normalmente como el cambio de la fase de salida para un incremento de 1 dB en el barrido de potencia aplicado a la entrada del amplificador (es decir, al punto de compresión de ganancia de 1 dB). Se expresa en grados por dB (°/dB). En un amplificador ideal no se produciría interacción alguna entre su respuesta en fase y el nivel de potencia de la señal de entrada.

¿Por qué se debe medir la conversión AM-PM?

La conversión AM-PM es un parámetro crítico en los sistemas en los que se utiliza la modulación de fase (angular), como:

  • FM

  • QPSK

  • 16QAM

Es un parámetro crítico porque la desviación de fase (PM) no deseada provoca una degradación de las señales analógicas, o mayores tasas de errores en bits (BER) en sistemas de comunicaciones digitales. Aunque es fácil medir la tasa BER de un sistema de comunicaciones digital, esta medida, por sí sola, no ayuda a comprender las causas subyacentes de los errores en bits. La conversión AM-PM es uno de los factores que más contribuyen a la tasa BER y, por consiguiente, es importante cuantificar este parámetro en los sistemas de comunicaciones.

Véase el diagrama de I/Q mostrado a continuación para entender mejor la explicación siguiente de cómo puede la conversión AM-PM causar errores en bits.

  • El cambio de estado deseable es del pequeño vector sólido al gran vector sólido.

  • Con la conversión AM-PM, el vector grande podrá en realidad terminar de la manera mostrada por la línea de puntos. Esto se debe al desplazamiento de fase resultante de un cambio del nivel de potencia de entrada.

  • Para una señal 64QAM como la mostrada (sólo se dibuja un cuadrante), puede verse cómo los círculos de ruido que rodean a cada estado en realidad se solaparían, lo cual significa que, estadísticamente, ocurrirían algunos errores en bits.

Consideraciones relativas a la precisión

Con este método de medida de la conversión AM-PM, la frecuencia de modulación es aproximadamente lo inverso del tiempo de barrido. Incluso con el barrido de potencia más rápido disponible en la mayoría de los analizadores de redes, la frecuencia de modulación termina siendo bastante baja (normalmente inferior a 10 Hz). Esto podría provocar un ligero cambio de temperatura, a medida que avanza el barrido, especialmente si el amplificador tiene una masa térmica baja, algo habitual en un dispositivo no empaquetado. Los resultados obtenidos con este método podrán diferir ligeramente si el comportamiento no lineal de un amplificador es extremadamente sensible a los cambios térmicos. (Los analizadores serie PNA pueden realizar barridos de potencia <1 ms.)

  • El amplificador podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

  • La potencia de salida del amplificador debería atenuarse suficientemente, si fuera necesario. Una potencia de salida excesiva podría:

    • dañar el receptor del analizador

    • rebasar el nivel de compresión de entrada del receptor del analizador, provocando medidas inexactas

  • La a tenuación de la potencia de salida del amplificador se puede conseguir utilizando:

    • Atenuadores

    • Acopladores

  • Deben tenerse en cuenta los efectos de los atenuadores y acopladores sobre la respuesta en frecuencia durante la calibración puesto que forman parte del sistema de pruebas. Las técnicas adecuadas de corrección de errores pueden reducir estos efectos.

  • La respuesta en frecuencia es el error dominante en una configuración de medida de la conversión AM-PM. La realización de una calibración de medida de la respuesta del cable pasivo reduce significativamente este error. Para obtener mayor precisión, realizar una calibración de medida de 2 puertos.

  1. Preajustar el analizador.

  2. Seleccionar una medida S21 en el modo de barrido de potencia.

  3. Introducir los niveles de potencia inicial y de parada para el barrido de potencia del analizador. El nivel de potencia inicial debería encontrarse en la zona lineal de la respuesta del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB). La potencia de parada debería hallarse en la zona de compresión de la respuesta del amplificador.

  4. Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  5. Conectar el amplificador de la manera mostrada en el siguiente gráfico y suministrar la polarización de c.c.

  6. Seleccionar los valores del analizador para el amplificador sometido a prueba con el fin de realizar una medida de la compresión de ganancia del barrido de potencia a una frecuencia elegida. Véase Compresión de ganancia.

  7. Retirar el amplificador y realizar una calibración de medida. Asegurarse de incluir el atenuador y los cables en la configuración de la calibración si se van a utilizar al medir el amplificador.

  8. Guardar el estado del instrumento en la memoria.

  9. Volver a conectar el amplificador.

  10. Utilizar un marcador de referencia para dirigir la potencia de entrada del amplificador al punto de compresión de ganancia de 1 dB. Seleccionar un segundo marcador y ajustar su valor de estímulo hasta que su respuesta sea 1 dB inferior al marcador de referencia.

  11. Cambiar la medida S21 de un formato de magnitud logarítmica a un formato de fase (no se necesita una nueva calibración ).

  12. Localizar el cambio de fase entre los marcadores. El valor es el coeficiente de conversión AM-PM en el punto de compresión de ganancia de 1 dB.

  13. Imprimir los datos o guardarlos en un disco.


Gain Comp

Véase asimismo...

Compresión de ganancia

Descripción general

Conceptos

Cómo medir la

compresión de ganancia

La compresión de ganancia mide el nivel de potencia de entrada aplicada a un amplificador que provocará una salida distorsionada. Se utilizan tres medidas para determinar la compresión de ganancia del amplificador:

1) Una medida de la compresión de ganancia de frecuencia con barrido localiza el primer punto de frecuencia en el que ocurre por primera vez la compresión de ganancia de 1 dB.

2) Una medida de la compresión de ganancia de potencia con barrido muestra la potencia de entrada que da como resultado un descenso de 1 dB en la ganancia a medida que se aplica una rampa de potencia al amplificador a un punto de frecuencia concreto (localizado en la medida 1).

3) Una medida de la potencia absoluta muestra la potencia de salida absoluta (en dBm) en el punto de compresión.
Conceptos

Cómo medir la compresión de ganancia

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es la compresión de ganancia?
¿Por qué se debe medir la compresión de ganancia?
Consideraciones relativas a la precisión

¿Qué es la compresión de ganancia?

La compresión de ganancia ocurre cuando se aumenta la potencia de entrada de un amplificador hasta un nivel que reduce la ganancia del amplificador y provoca un aumento no lineal de la potencia de salida.

El analizador puede realizar barridos de potencia, además de barridos de frecuencia. Los barridos de potencia ayudan a caracterizar el rendimiento no lineal de un amplificador. Véase el gráfico mostrado a continuación (una representación gráfica de la potencia de salida de un amplificador comparada con la potencia de entrada en una única frecuencia) para entender mejor la explicación siguiente.

  • La ganancia del amplificador a cualquier nivel de potencia dado es la pendiente de la curva.

  • El amplificador tiene una zona de funcionamiento lineal en la que la ganancia es constante e independiente del nivel de potencia. La ganancia en esta zona se denomina habitualmente "ganancia de señales pequeñas".

  • En un determinado momento, a medida que se aumenta la potencia de entrada, la ganancia del amplificador parece disminuir, y el amplificador accede al estado de compresión.

  • La medida más habitual de la compresión de un amplificador es el punto de compresión de 1 dB. Se define como la potencia de entrada (o a veces la potencia de salida) que da como resultado una disminución de 1 dB de la ganancia del amplificador (en relación con la ganancia de señales pequeñas del amplificador).

¿Por qué se debe medir la compresión de ganancia?

  • Cuando se controla mediante una curva sinusoide, la salida de un amplificador ya no es sinusoidal en la zona de compresión. Parte de la salida del amplificador aparece en armónicos, en lugar de ocurrir únicamente a la frecuencia fundamental de la señal de entrada.

  • A medida que se incrementa incluso más la potencia de entrada, el amplificador se satura y la potencia de salida permanece constante. En este momento, incrementos adicionales de la potencia de entrada del amplificador no provocarán ningún cambio en la potencia de salida.

  • En algunos casos (como ocurre con amplificadores TWT), la potencia de salida en realidad disminuye con incrementos ulteriores de la potencia de entrada tras la saturación, lo cual significa que el amplificador tiene una ganancia negativa.

  • Puesto que la ganancia es un factor deseado en el funcionamiento del amplificador, es importante conocer el límite de la señal de entrada que provocará la compresión de ganancia.

Consideraciones relativas a la precisión

El analizador de redes debe proporcionar suficiente potencia para poder saturar el amplificador. Si se necesita un nivel de potencia de entrada superior al que puede aportar la fuente del analizador, utilizar un preamplificador para aumentar el nivel de potencia antes del amplificador sometido a prueba. (Véase Medidas de componentes de alta potencia.) Si se utiliza un preamplificador, podrá aumentarse la exactitud de la medida de las siguientes maneras:

  • Utilizar un acoplador en la salida del preamplificador, de manera que una parte de la señal de entrada reforzada pueda utilizarse para el canal de referencia del analizador. Esta configuración elimina de la medida los errores de respuesta en frecuencia y de deriva del preamplificador (mediante el cálculo de la relación).

  • Realizar una calibración de la respuesta del cable pasivo, incluido el preamplificador, los acopladores y los atenuadores de la configuración de prueba.

La potencia de salida del amplificador debería atenuarse suficientemente, si fuera necesario. Una potencia de salida excesiva podría:

  • dañar el receptor del analizador

  • superar el nivel de compresión de entrada del receptor del analizador

La a tenuación de la potencia de salida del amplificador se puede conseguir utilizando:

  • Atenuadores

  • Acopladores

Deben considerarse los efectos de los atenuadores y acopladores sobre la respuesta en frecuencia durante la calibración, puesto que forman parte del sistema de pruebas. Las técnicas adecuadas de corrección de errores pueden reducir estos efectos.

  • La respuesta en frecuencia es el error dominante en una configuración de medida de la compresión de ganancia. La realización de una calibración de medida de la respuesta del cable pasivo reduce significativamente este error.

  • El amplificador podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

  • La reducción del ancho de banda de la IF o el uso de promedios de medida aumenta la precisión, a costa de la velocidad de medida.

Este procedimiento muestra cómo realizar las tres medidas utilizadas para determinar la compresión de ganancia del amplificador.
Compresión de ganancia de frecuencia con barrido
Compresión de ganancia de potencia con barrido
Medida de la potencia absoluta

Compresión de ganancia de frecuencia con barrido

Una medida de la compresión de ganancia de frecuencia con barrido localiza el punto de frecuencia en el que ocurre en primer lugar la compresión de 1 dB.

  1. Preajustar el analizador.

  2. Seleccionar un parámetro de medida S21.

  3. Ajustar la potencia de la fuente del analizador para que se encuentre en la zona lineal de la respuesta de salida del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB).

  4. Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  5. Conectar el amplificador de la manera mostrada en el siguiente gráfico y suministrar la polarización de c.c.

  6. Seleccionar los ajustes del analizador para el amplificador sometido a prueba. Para reducir los efectos del ruido, podrá especificarse un ancho de banda de la IF más estrecho.

  7. Retirar el amplificador y realizar una calibración de la respuesta del cable pasivo. Asegurarse de incluir el atenuador y los cables en la configuración de la calibración si se van a utilizar al medir el amplificador.

  8. Guardar el estado del instrumento en la memoria.

  9. Volver a conectar el amplificador.

  10. Situar un marcador a aproximadamente la mitad del recorrido.

  11. Ajustar la escala del analizador a 1 dB por división.

  12. Almacenar la traza en la memoria y mostrar Data/Mem.

  13. Aumentar gradualmente la potencia de la fuente hasta que se observe una disminución de ganancia de 1 dB en la primera frecuencia a lo largo de parte de la traza.

  14. Utilizar marcadores para localizar la frecuencia en la que ocurre por primera vez la reducción de ganancia de 1 dB. Tomar nota de esta frecuencia para utilizarla en la medida siguiente.

  15. Imprimir los datos o guardarlos en un disco.

Compresión de ganancia de potencia con barrido

Una medida de la compresión de ganancia de potencia con barrido muestra la potencia de entrada que da como resultado un descenso de 1 dB en la ganancia a medida que se aplica una rampa de potencia al amplificador a una frecuencia concreta (localizada en el paso 13 de la medida anterior).

  1. Si no se ha hecho todavía, realizar la medida anterior de la compresión de ganancia de frecuencia con barrido.

  2. Configurar una medida S21 en el modo de barrido de potencia. Incluir los siguientes ajustes:

    • Ajustar la frecuencia de onda continua CW a la frecuencia anotada en el paso 13 de la medida anterior de la compresión de ganancia de frecuencia con barrido.

    • Introducir los niveles de potencia inicial y de parada para el barrido. La potencia inicial debería encontrarse en la zona lineal de la respuesta del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB). La potencia de parada debería hallarse en la zona de compresión de la respuesta del amplificador.

  3. Ajustar la escala a 1 dB por división.

  4. Utilizar marcadores (incluido el marcador de referencia) para localizar la potencia de entrada a la que ocurre la disminución de ganancia de 1 dB.

  5. Imprimir los datos o guardarlos en un disco.

Medida de la potencia de salida absoluta

  1. Una medida de la potencia absoluta muestra la potencia de salida absoluta (en dBm) del amplificador en el punto de compresión.

    • Seleccionar una medida de potencia sin cálculo de relación (absoluta). Elegir la entrada B si se está utilizando la configuración de prueba del gráfico anterior. Incluir los siguientes ajustes:

    • Mantener la frecuencia de onda continua CW utilizada en la medida anterior de la compresión de ganancia de potencia con barrido.

  2. Definir un marcador en el nivel de potencia de entrada en el que ocurre la disminución de ganancia de 1 dB (localizado en el paso 4 de la medida anterior).

  3. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

  4. Leer el valor del marcador para determinar la potencia de salida absoluta del amplificador (en dBm) a la que ocurre la disminución de ganancia de 1 dB.

  5. Imprimir los datos o guardarlos en un disco.

Nota: La calibración de medida no es aplicable a la potencia absoluta. Por tanto, si existe cualquier atenuación externa al analizador, deberá corregirse manualmente.


Phase Devi

Véase asimismo...

Desviación respecto de fase lineal

Descripción general

Conceptos

Cómo medir

La desviación respecto de la fase lineal es una medida de la distorsión de fase. La función de retardo eléctrico del analizador se utiliza para eliminar de la medida la parte lineal del desplazamiento de fase. Esto produce una presentación de alta resolución de la parte no lineal del desplazamiento de fase (desviación respecto de la fase lineal).
Conceptos

Cómo medir la desviación respecto de la fase lineal

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿En qué consiste el desplazamiento de fase lineal?
¿Qué es la desviación respecto de la fase lineal?
¿Por qué se debe medir la desviación respecto de la fase lineal?
Utilización del retardo eléctrico
Consideraciones relativas a la precisión

¿En qué consiste el desplazamiento de fase lineal?

El desplazamiento de f ase ocurre debido a que las longitudes de onda que ocupan la longitud eléctrica del dispositivo se acortan a medida que aumenta la frecuencia de la señal incidente. El desplazamiento de fase lineal ocurre cuando la respuesta en fase de un dispositivo es linealmente proporcional a la frecuencia. Mostrada en el analizador, la traza de medida de la relación fase-frecuencia de este desplazamiento de fase ideal es una línea recta. La pendiente es proporcional a la longitud eléctrica del dispositivo. El desplazamiento de fase lineal es necesario (junto con una respuesta de magnitud plana) para la transmisión no distorsionada de señales.

¿Qué es la desviación respecto de la fase lineal?

En la práctica real, numerosos dispositivos eléctricos o electrónicos retardarán algunas frecuencias más que otras, creando un desplazamiento de fase no lineal (distorsión en las señales consistente en componentes de múltiples frecuencias). La medida de la desviación respecto de la f ase l ineal es una manera de cuantificar este desplazamiento de fase no lineal.

Puesto que es sólo la desviación respecto de la fase lineal la que provoca la distorsión de fase, es deseable eliminar de la medida la parte lineal de la respuesta en fase. Esto se puede conseguir utilizando la función de retardo eléctrico del analizador para cancelar matemáticamente la longitud eléctrica del dispositivo sometido a prueba. Lo que queda es la desviación respecto de la fase lineal, o distorsión de fase.

¿Por qué se debe medir la desviación respecto de la fase lineal?

La medida de la desviación respecto de la fase lineal consigue lo siguiente:

  • Presenta datos en unidades de fase, en lugar de en unidades de segundos (retardo de grupo). Las unidades de fase pueden resultar más prácticas para dispositivos que pasan señales moduladas.

  • Proporciona una medida menos ruidosa que una medida de retardo de grupo.

Utilización del retardo eléctrico

La función de retardo eléctrico es la versión electrónica del "alargador de líneas" mecánico de los analizadores más antiguos. Esta función hace lo siguiente:

  • Simula una línea de transmisión de longitud variable y sin pérdida, que se añade a, o se elimina de la ruta de la señal de referencia.

  • Compensa la longitud eléctrica del dispositivo sometido a prueba.

  • Aplana la traza de la medida en la pantalla del analizador. Esto permite visualizar la traza a alta resolución con el fin de examinar los detalles de la no linealidad de la fase.

  • Proporciona un método práctico para examinar la desviación respecto de la fase lineal del dispositivo sometido a prueba. Véase el gráfico siguiente.

Consideraciones relativas a la precisión

La respuesta en frecuencia de la configuración de prueba es el error dominante en una medida de la desviación respecto de la fase lineal. La realización de una calibración de medida de la respuesta del cable pasivo reduce significativamente este error. Para obtener mayor precisión, realizar una calibración de medida de 2 puertos.

Cómo medir la desviación respecto de la fase lineal:

  1. Preajustar el analizador.

  2. Si el dispositivo sometido a prueba es un amplificador, podrá ser necesario ajustar la potencia de la fuente del analizador.

    • Ajustar la potencia de la fuente del analizador para que se encuentre en la zona lineal de la respuesta de salida del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB).

    • Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  3. Conectar el dispositivo sometido a prueba de la manera mostrada en el siguiente gráfico.

  3. Seleccionar una medida S21.

  4. Seleccionar los valores para el dispositivo sometido a prueba, incluidos los siguientes:

    • Formato: fase

    • Escala: e scala automática

  5. Retirar el dispositivo y realizar una calibración.

  6. Volver a conectar el dispositivo.

  7. Ajustar la escala de la medida mostrada para visualizarla de manera óptima.

  8. Activar la función de retardo eléctrico para aplanar automáticamente la traza de la fase. Si se desea, realizar manualmente un ajuste de precisión del retardo eléctrico para ajustar la planeidad de la traza de la fase.

  9. Utilizar los marcadores para medir la d esviación respecto de la f ase l ineal máxima entre picos.

  10. Imprimir los datos o guardarlos en un disco.


Rev Isol

Véase asimismo...

Aislamiento inverso

Descripción general

Conceptos

Cómo medir el
aislamiento inverso

El a islamiento inverso es una medida de la respuesta de transmisión inversa del amplificador - desde la salida a la entrada.
Conceptos

Cómo medir el aislamiento inverso

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es el aislamiento inverso?
¿Por qué se debe medir el aislamiento inverso?
Consideraciones relativas a la precisión

¿Qué es el aislamiento inverso?

El aislamiento inverso es una medida que indica lo bien que una señal aplicada a la salida del dispositivo se "aísla" de su entrada.

La medida del aislamiento inverso es similar a la de la ganancia de avance, salvo que:

  • La señal de estímulo se aplica al puerto de salida del amplificador.

  • La respuesta se mide en el puerto de entrada del amplificador.

El parámetro S equivalente es S12.

¿Por qué se debe medir el aislamiento inverso?

Un amplificador ideal tendría un aislamiento inverso infinito - no se transmitiría una señal desde la salida a la entrada. Sin embargo, las señales reflejadas pueden pasar a través del amplificador en dirección inversa. Esta transmisión inversa no deseada puede provocar que las señales reflejadas interfieran con la señal fundamental deseada que se desplaza en dirección de avance. Por consiguiente, es importante cuantificar el aislamiento inverso.

Consideraciones relativas a la precisión

Puesto que los amplificadores a menudo muestran una pérdida elevada en la dirección inversa, por lo general no se necesita ninguna atenuación que pueda haberse utilizado para proteger el receptor del puerto 2 durante las medidas de la transmisión de avance. La eliminación de la atenuación:

  • Aumentará el m argen dinámico, con la consiguiente mejora de la precisión de medida.

  • Exigirá una nueva calibración para obtener la máxima precisión.

La potencia de la fuente de RF se puede incrementar para proporcionar mayor margen dinámico y precisión.

Nota: Con la atenuación eliminada y la potencia de la fuente de RF incrementada, un barrido de avance podría dañar el receptor del puerto 2 del analizador. No se debe realizar un barrido de avance ni utilizar una calibración de 2 puertos a menos que la potencia de avance esté ajustada lo suficientemente baja para evitar causar compresión o daños en el receptor del puerto 2.

Si el a islamiento del amplificador sometido a prueba es muy grande, el nivel de la señal podría estar próximo al límite inferior del ruido o al nivel de diafonía del receptor. Para reducir el nivel inferior del ruido:

  • Utilizar o incrementar los promedios de medida.

  • Reducir el ancho de banda de IF del analizador.

Nota: La reducción del ancho de banda de IF o la utilización del promediado aumenta el margen dinámico y la precisión de la medida, a costa de una menor velocidad de medida.

  • Cuando los niveles de diafonía afectan a la precisión de la medida, se debe reducir el término de error de diafonía realizando una calibración de la respuesta y del aislamiento. Cuando se realice la parte de la calibración correspondiente al aislamiento, es importante utilizar el mismo factor promedio y el mismo ancho de banda de IF durante la calibración y la medida.

  • La respuesta en frecuencia de la configuración de prueba es el error dominante en una medida del aislamiento inverso. La realización de una medida de la respuesta del cable pasivo reduce considerablemente este error. Esta calibración se puede realizar como parte de la calibración de la respuesta y del aislamiento.

  • El amplificador podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

  1. Conectar el amplificador de la manera mostrada en el siguiente gráfico.

  2. Preajustar el analizador.

  3. Seleccionar una medida S12.

  4. Seleccionar los ajustes del amplificador sometido a prueba.

  5. Retirar el amplificador y realizar una calibración de la respuesta del cable pasivo o una calibración de la respuesta y del a islamiento.

  6. Ajustar la escala de la medida mostrada para visualizarla de manera óptima y utilizar un marcador para medir el aislamiento inverso a una frecuencia deseada.

  7. Imprimir los datos o guardarlos en un disco.


Gain Flat

Véase asimismo...

Ganancia y planeidad de señales pequeñas

Descripción general

Conceptos

Cómo medir

La ganancia de señales pequeñas es la ganancia en la zona lineal de funcionamiento del amplificador. Normalmente se mide a una potencia de entrada constante a lo largo de una frecuencia de barrido. La planeidad de la ganancia es una medida de la variación de la ganancia a lo largo de un margen de frecuencias especificado.
Conceptos

Cómo medir la ganancia y la planeidad

Haga clic en un botón para obtener información acerca de los siguientes temas:
¿Qué es la ganancia?
¿Qué es la planeidad?
¿Por qué se debe medir la ganancia y la planeidad?
Consideraciones relativas a la precisión

¿Qué es la ganancia?

La ganancia de un amplificador de RF se define como la diferencia de potencia entre la señal de salida del amplificador y la señal de entrada. Se supone que las impedancias tanto de entrada como de salida del amplificador son idénticas a la impedancia característica del sistema.

  • La ganancia se denomina S21 utilizando la terminología de los parámetros S.

  • La ganancia se expresa en dB, una relación logarítmica de la potencia de salida en relación con la potencia de entrada.

  • La ganancia se puede calcular restando el nivel de entrada del nivel de salida cuando ambos se expresan en dBm, que es la potencia en relación con 1 milivatio.

  • La ganancia de un amplificador se especifica normalmente como un valor mínimo a lo largo de un margen de frecuencias especificado. Algunos amplificadores especifican la ganancia tanto mínima como máxima, para asegurar que las fases posteriores de un sistema no se exciten por defecto o por exceso.

¿Qué es la planeidad?

La p laneidad especifica cuánto puede variar la ganancia del amplificador a lo largo del margen de frecuencias especificado. Las variaciones de la planeidad de la ganancia del amplificador pueden provocar una distorsión de las señales que pasan a través del amplificador.

¿Por qué se debe medir la ganancia y la planeidad de las señales pequeñas?

Las desviaciones de la ganancia a lo largo del ancho de banda de interés inducirá distorsión en la señal transmitida, puesto que los componentes de frecuencia no se amplifican por igual. La ganancia de las señales pequeñas permite cuantificar la ganancia del amplificador a una frecuencia concreta en un sistema de 50 ohmios. La planeidad permite ver las desviaciones de la ganancia del amplificador a lo largo de un margen de frecuencias especificado en un sistema de 50 ohmios.

Consideraciones relativas a la precisión

  • El amplificador podrá responder de manera muy diferente a diversas temperaturas. Las pruebas deberían realizarse cuando el amplificador se encuentre a la temperatura de funcionamiento deseada.

  • La potencia de salida del amplificador debería atenuarse suficientemente, si fuera necesario. Una potencia de salida excesiva podría:

    • dañar el receptor del analizador

    • rebasar el nivel de compresión de entrada del receptor del analizador, provocando medidas inexactas

La a tenuación de la potencia de salida del amplificador se puede conseguir utilizando:

    • atenuadores

    • acopladores

Deben tenerse en cuenta los efectos y desadaptaciones de los atenuadores y acopladores sobre la respuesta en frecuencia durante la calibración, puesto que forman parte del sistema de pruebas. Las técnicas adecuadas de corrección de errores pueden reducir estos efectos.

  • La respuesta en frecuencia es el error dominante en una configuación de medida de la ganancia y planeidad de señales pequeñas. La realización de una calibración de medida de la respuesta del cable pasivo reduce significativamente este error. Para obtener mayor precisión, realizar una calibración de medida de 2 puertos.

  • La reducción del ancho de banda de IF o el uso del promediado mejora el m argen dinámico y la precisión de la medida, a costa de la velocidad de medida.

Cómo medir la ganancia y la planeidad

  1. Preajustar el analizador.

  2. Seleccionar un parámetro de medida S21.

  3. Ajustar la potencia de la fuente del analizador para que se encuentre en la zona lineal de la respuesta de salida del amplificador (normalmente 10 dB por debajo del punto de compresión de 1 dB).

  4. Seleccionar un atenuador externo (si es necesario) de manera que la potencia de salida del amplificador esté suficientemente atenuada para evitar causar compresión en el receptor o daños al puerto 2 del analizador.

  5. Conectar el amplificador de la manera mostrada en el siguiente gráfico y suministrar la polarización de c.c.

  6. Seleccionar los ajustes del analizador para el amplificador sometido a prueba.

  7. Retirar el amplificador y realizar una calibración de medida. Asegurarse de incluir el atenuador y los cables en la configuración de la calibración si se van a utilizar al medir el amplificador.

  8. Guardar el estado del instrumento en la memoria.

  9. Volver a conectar el amplificador.

  10. Ajustar la escala de la medida mostrada para visualizarla de manera óptima y utilizar un marcador para medir la ganancia de las señales pequeñas a una frecuencia deseada.

  11. Medir la planeidad de la ganancia a lo largo de un margen de frecuencias utilizando marcadores para visualizar la ondulación entre picos.

  12. Imprimir los datos o guardarlos en un disco.

  13. Este tipo de medida se puede automatizar.


Impedancia

Este subprograma está diseñado para ser visualizado en la pantalla del analizador. Para ver este subprograma en un PC, copiar los siguientes archivos del directorio C:\WINNT\Help del analizador o del CD-ROM que se suministró con el analizador, en el directorio C:\WINNT\Help del PC.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Modelo de adaptación de impedancias

Véase asimismo...

La adaptación de impedancias es un procedimiento utilizado en el diseño de circuitos para adaptar impedancias desiguales de la fuente y de la carga, con el fin de optimizar la potencia enviada a la carga desde la fuente. La adaptación de impedancias se lleva a cabo insertando redes de adaptación en un circuito entre la fuente y la carga.

Introducción al modelo

Modelo de adaptación de impedancias

Descripción de los ejercicios

Rutas de los elementos del circuito en el diagrama de Smith

Zonas prohibidas del diagrama de Smith

Introducción

En este modelo se utilizan diagramas de Smith para visualizar el proceso interactivo de la adaptación de impedancias con el fin optimizar la potencia transmitida en circuitos simples. Se utilizan redes de adaptación simples de serie/derivación e inductancia/capacitancia, y se pueden ajustar de manera interactiva los valores de los componentes L y C correspondientes. Al ajustar los componentes de la red de adaptación, cambia la reflectancia del circuito en su conjunto. La reflectancia de cada pieza del circuito aparece indicada en el diagrama de Smith como una bola roja [image] o azul [image].

A medida que se ajustan las guías deslizantes y se modifican los valores de los componentes, el modelo calcula nuevos valores para la reflectancia del circuito y mueve las bolas de color rojo [image] y azul [image] en el diagrama de Smith. El objetivo de cada ejercicio es mover el punto de reflectancia desde el centro del diagrama de Smith, que representa la carga o la fuente, al interior de los anillos adecuados de color [image] rojo y [image] azul que representan la condición de adaptación deseada. Se pueden seleccionar tres problemas diferentes de adaptación de impedancias de dificultad creciente haciendo clic en una de las tres fichas etiquetadas.

Modelo de adaptación de impedancias

Maximizar esta ventana para una visualización óptima. Hacer clic en si no se puede ver el modelo de impedancias.

Descripción de los ejercicios

El primer ejercicio permite utilizar el diagrama de Smith para realizar una adaptación de impedancias básica entre una fuente resistiva y una carga resistiva. Se utiliza una red simple de serie-inductancia y derivación-capacitancia para adaptar la fuente de 50 ohmios a la carga de 300 ohmios. La reflectancia de la fuente del circuito, según se mira desde la carga hacia la fuente, está representada por la bola roja [image], mientras que la carga de 300 ohmios viene indicada por el [image] anillo rojo estacionario.

El objetivo del ejercicio es adaptar interactivamente estas dos impedancias ajustando las guías deslizantes L y C. El modelo proporcionará información gráfica al mover la bola roja que indica la reflectancia del circuito en el diagrama de Smith. Ajustar las guías deslizantes L de serie y C de derivación para mover el punto de reflectancia [image] desde el centro del diagrama de Smith a la posición de impedancia correspondiente en el interior del anillo rojo . Se pueden estudiar las rutas de los elementos del circuito en el diagrama de Smith , mostradas a continuación, para ver cómo diferentes elementos del circuito cambian la reflectancia del circuito en el diagrama de Smith.

El segundo ejercicio proporciona una experiencia de adaptación de impedancias consistente en optimizar la ganancia de potencia del transductor de un amplificador de transistores. La adaptación de la fuente de 50 ohmios a la reflectancia de entrada del transistor, s* 11 , y la adaptación de la carga de 50 ohmios a la reflectancia de salida del transistor, s* 22 , optimiza la potencia enviada desde la fuente, a través del transistor, a la carga. Es necesario adaptar por separado tanto la bola roja [image] de la entrada como la bola azul [image] de la salida del transistor. Ajustar los valores de los componentes para mover ambos puntos de reflectancia a sus posiciones correctas en los anillos rojo [image] y azul [image].

La tercera parte del modelo interactivo de adaptación de impedancias es una colección de ejercicios relativos a un circuito modular. Se empieza por construir un circuito con uno o dos componentes de redes de adaptación modulares del tipo "arrastrar y soltar". Una vez que se hayan añadido las redes de adaptación al circuito, se activarán las guías deslizantes y permitirán ajustar los valores de los componentes. A continuación se adaptarán las impedancias del circuito que se acaba de crear. Hay 8 circuitos diferentes que se pueden construir y hay 5 parejas de valores distintas para s* 11 y s* 22 en el diagrama de Smith, en total 40 ejercicios de adaptación de impedancias. Se verá que no todas las redes de adaptación funcionan. Para algunos de los circuitos que se pueden construir, no se podrá situar la bola roja [image] dentro del anillo rojo o la bola [image] azul dentro del anillo azul . Para determinar de antemano qué redes de adaptación funcionarán, examinar detenidamente las zonas prohibidas del diagrama de Smith que se muestran a continuación. Hay 5 parejas de posiciones diferentes para s* 11 y s* 22 correspondientes a diferentes frecuencias que se pueden adaptar. Utilizar el indicador de frecuencia para seleccionar una frecuencia de funcionamiento y, a continuación, arrastrar y soltar las redes de adaptación oportunas en el circuito y ajustar los valores de los componentes para mover ambos puntos de reflectancia a sus posiciones correctas en los anillos rojo [image] y azul .

Rutas de los elementos del circuito en el diagrama de Smith

Los gráficos que aparecen a continuación muestran cómo los diversos componentes L y C de derivación y serie cambian la reflectancia del circuito en el diagrama de Smith. Suponiendo que el componente dado sea el último componente de la red de adaptación, la reflectancia del circuito se moverá de la manera indicada formando círculos de resistencia constante o conductancia constante.

La adaptación de impedancias utilizando el diagrama de Smith se puede comparar con la conducción de un vehículo hasta un destino específico en la Ciudad de Smith - una ciudad en la que ninguna de las calles es recta. Si se ajustan los componentes del circuito en un orden adecuado, se podrá limitar la conductancia del circuito a rutas alrededor de círculos de resistencia constante o conductancia constante. De la misma manera que las señales de tráfico pueden orientar al conductor de un vehículo por las calles circulares de la Ciudad de Smith, podemos alcanzar la condición de impedancia adaptada de manera sencilla y determinista.

Zonas prohibidas del diagrama de Smith

Para una reflectancia de carga dada, sólo determinadas redes de adaptación L-C serán capaces de transformar la impedancia de la fuente a la impedancia de la carga. De hecho, para cualquier reflectancia de la carga, exactamente dos de las cuatro redes de adaptación L-C posibles del anterior modelo de Amplificador de transistores-II serán capaces de realizar la tarea de adaptación. Pero,¿cuáles son?

Los diagramas siguientes se pueden utilizar para determinar qué redes de adaptación funcionarán en una situación de carga dada. Si la reflectancia de la carga se encuentra en la región prohibida del diagrama de Smith para la red de adaptación indicada, la red no podrá realizar la operación de adaptación necesaria. No se puede conducir el vehículo en los barrios prohibidos de la Ciudad de Smith. ¡Sus calles no están asfaltadas!

Utilizar estos diagramas para determinar qué red de adaptación se debería utilizar. En primer lugar, localizar visualmente la posición de la reflectancia de lacarga a partir del modelo de Amplificador de transistores-II anterior en cada uno de los cuatro diagramas de Smith en color mostrados a continuación. A continuación, eliminar las dos regiones cuyas zonas prohibidas coincidan parcialmente con el punto de reflectancia, y utilizar una de las dos redes restantes para realizar la adaptación de las impedancias.


Refl Waves

Esta miniaplicación se ha diseñado para visualizarse en la pantalla del analizador. Para visualizarla fuera del analizador, copiar los siguientes archivos del directorio C:\WINNT\Help del analizador o del CD-ROM que se suministró con el analizador, en el directorio C:\WINNT\Help.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Ondas reflejadas a lo largo de una línea de transmisión

Véase asimismo..

Cuando una onda sinusoidal de un generador de señales de RF se sitúa en una línea de transmisión, la señal se propaga hacia la carga. Esta señal, mostrada aquí en amarillo, aparece como un grupo de vectores giratorios, uno en cada punto de la línea de transmisión.

Maximizar esta ventana para obtener una visualización óptima. Hacer clic si no se puede ver la miniaplicación.

En nuestro ejemplo, la línea de transmisión tiene una impedancia característica de 50 ohmios. Si elegimos una carga de 50 ohmios, la amplitud de la señal no variará con la posición a lo largo de la línea. Sólo variará la fase a lo largo de la línea, como muestran los vectores giratorios amarillos.

Si la impedancia de carga no coincide exactamente con la impedancia característica de la línea, se producirá una señal reflejada que se propagará hacia la fuente. En cualquier punto de la línea de transmisión, dicha señal también se muestra como una tensión constante cuya fase depende de la posición física a lo largo de la línea.

La tensión que se muestra en un punto específico de la línea será la suma vectorial de los sinusoides transmitidos y reflejados. Esto se puede demostrar mediante estos dos ejemplos.

Ejemplo 1: Adaptación perfecta: 50 ohmios

Ajustar la resistencia de terminación a 50 ohmios utilizando el cuadro de diálogo de "flecha hacia abajo". Obsérvese que no existe reflexión. La adaptación es perfecta. Cada vector giratorio tiene una amplitud normalizada de 1. Si tuviéramos que observar la forma de onda en cualquier punto con un instrumento de medida perfecto, veríamos amplitudes de onda sinusoidal iguales en cualquier punto de la línea de transmisión. Las amplitudes de señal se indican con la línea verde.

Ejemplo 2: Carga desadaptada: 200 ohmios

Ahora vamos a crear intencionadamente una carga desadaptada. Ajustar la resistencia de terminación a 200 ohmios utilizando la flecha hacia abajo. Pulsar el botón PLAY y observar cómo cambia la forma de onda reflejada. Si se pudiera medir sólo la onda reflejada, se vería que su amplitud no varía con la posición a lo largo de la línea. La única diferencia con la señal reflejada (azul), supongamos que en el punto z6 y en el punto z4, es la fase.

Pero la amplitud de la forma de onda resultante, indicada por la onda estacionaria (verde), no es constante en toda la línea debido a la combinación de las señales transmitidas con las señales reflejadas (amarillas y azules). Puesto que la fase entre las señales transmitidas y reflejadas varía con la posición a lo largo de la línea, las sumas vectoriales serán diferentes y crearán lo que se conoce como "onda estacionaria".

Con la impedancia de carga a 200 ohmios, un dispositivo de medida situado en el punto z6 mostraría una onda sinusoidal de amplitud constante. La onda sinusoidal del punto z4 también tendría una amplitud constante, pero su amplitud diferiría de la de la señal del punto z6. Y ambas estarían fuera de fase con respecto a la otra. Una vez más, la diferencia se muestra con la línea verde, que indica la amplitud en ese punto de la línea de transmisión.

La impedancia a lo largo de la línea también cambia, como muestran los puntos etiquetados z1 a z7.


Overview

Véase asimismo...

Descripción general del dominio del tiempo

Descripción general

Conceptos

Cómo realizar una medida en el dominio del tiempo

Si el analizador dispone de la opción de dominio de tiempo 010, podrá verse una respuesta del dispositivo como función del tiempo. Este tema facilita el conocimiento de la opción de dominio del tiempo al proporcionar una descripción general de su funcionamiento.
Conceptos

Cómo realizar una medida en el dominio del tiempo

¿Qué es una medida en el dominio del tiempo?
Similitud con la reflectometría del dominio del tiempo
Secuencia de las medidas en el dominio del tiempo

¿Qué es una medida en el dominio del tiempo?

  • En el modo de funcionamiento normal, el analizador mide las características de rendimiento de RF de un dispositivo de prueba como función de la frecuencia.

  • Cuando el analizador dispone de la opción de dominio de tiempo 010, puede utilizar una técnica matemática (la transformada de Fourier inversa) para transformar los datos en el dominio de la frecuencia al dominio del tiempo.

  • El eje horizontal de la medida representa el tiempo.

  • Los valores de respuesta aparecen separados en el tiempo, lo que permite un análisis diferenciado del rendimiento de la red y de sus limitaciones.

En el gráfico siguiente se comparan los mismos datos de medida de la reflexión del cable en los dominios de la frecuencia y del tiempo. El cable presenta dos curvas, cada una de las cuales crea un desajuste o cambio en la impedancia de línea.

  • La respuesta en el dominio de la frecuencia medida en el puerto de entrada muestra la respuesta de reflexión compuesta (ondulación) causada por las interacciones entre los desajustes del cable, pero resulta difícil determinar en qué lugar del cable se producen dichos desajustes.

  • La respuesta en el dominio del tiempo ofrece una forma de mirar el interior del cable para determinar tanto la ubicación como la magnitud de cada desajuste. En el ejemplo anterior, la respuesta indica que la segunda curva del cable es la ubicación de un desajuste importante.

Transformada de Fourier

Cuando las respuestas se encuentran en el dominio del tiempo, el analizador también puede filtrar las respuestas no deseadas mediante la función de puerta de tiempo. Después, puede volver a transformar la respuesta deseada al dominio de la frecuencia. Esto permite caracterizar la respuesta de la red a una señal o forma de onda modulada concreta sin incluir los efectos de dispositivos externos tales como conectores o adaptadores. Para este proceso, el analizador utiliza las transformadas siguientes.

  • Transformada de Fourier inversa: convierte los datos de medida de frecuencia en datos en el dominio del tiempo.

  • Transformada de Fourier: vuelve a convertir los datos del dominio del tiempo al dominio de la frecuencia.

Similitud con la reflectometría del dominio del tiempo

  • El modo del dominio del tiempo simula una reflectometría de dominio de tiempo (TDR) tradicional en la que es posible determinar las características de las líneas eléctricas mediante la observación de las formas de onda reflejadas.

  • A partir de la forma y la ubicación de las respuestas se puede determinar la impedancia y la distancia hasta la discontinuidad.

Análisis de reflectometría de dominio de tiempo

  • El análisis TDR tradicional aplica una señal de etapa o impulso real al dispositivo de prueba y observa la energía que se refleja.

  • En la pantalla del TDR se muestra la etapa incidente junto con la forma de onda reflejada.

  • Mediante el análisis de la magnitud, duración y aspecto de la forma de onda reflejada es posible determinar la naturaleza de la variación de impedancia en el sistema de transmisión.

Análisis del dominio del tiempo del analizador

  • El analizador no aplica un impulso o etapa incidente real, sino que realiza medidas de respuesta en frecuencia de barrido.

  • Con los datos de respuesta en frecuencia, el analizador calcula la frecuencia de etapa, impulso o respuesta de p aso de b anda del dispositivo, dependiendo de la transformada seleccionada.

  • El analizador muestra los datos en una respuesta en el dominio del tiempo (visualización tipo TDR).

Secuencia de las medidas en el dominio del tiempo

  1. Datos de frecuencia: se recopilan cuando el analizador mide una respuesta del dispositivo en el dominio de la frecuencia.

  2. Modos de paso de banda y paso bajo: la selección depende de las características de frecuencia del dispositivo sometido a prueba y de la respuesta de visualización deseada.

    • El modo de paso de banda es el más flexible. Resulta idóneo para los dispositivos que no pueden pasar todas las frecuencias, como los filtros. Sólo está disponible la respuesta de impulso.

    • El modo de paso bajo simula el TDR tradicional. Es idóneo para los dispositivos que pueden pasar todas las frecuencias hasta CC, como los cables. Las frecuencias del barrido están relacionadas armónicamente. Están disponibles las respuestas de impulso y de etapa.

  3. Ventana: la selección optimiza la respuesta en el dominio del tiempo al proporcionar transiciones suaves hasta cero al final del periodo de muestreo. Con ello se suprimen los lóbulos laterales no deseados de la respuesta, lo que facilita la visión de las respuestas de niveles inferiores. Las ventanas mínimas proporcionan la mejor resolución y los lóbulos laterales más altos.

  4. Puerta de tiempo: es un filtro de tiempo que elimina los efectos de las respuestas no deseadas.

  5. Datos de frecuencia: son visibles una vez que el analizador ha transformado de nuevo las respuestas al dominio de la frecuencia. La medida muestra los efectos únicamente de las respuestas concretas que permanecen después de aplicar el sistema de puerta.

Haga clic en los botones para ver el procedimiento general para realizar una medida en el dominio del tiempo.
Configuración de la medida
Optimizar los resultados
Interpretar los datos mostrados

Configuración de la medida

  1. Seleccionar la configuración de la medida en el dominio de la frecuencia. Véase Configurar una medida.

  2. Hay que decidir el modo de transformada que se va a utilizar.

    • Si el dispositivo sometido a prueba tiene una respuesta de medida hasta CC, debe utilizarse el modo de paso bajo con la respuesta de etapa.

    • Si el dispositivo sometido a prueba no tiene una respuesta de medida a CC, se debe utilizar el modo de p aso de b anda .

    Véase Modos de paso de banda y paso bajo.

  3. Para obtener la resolución de respuesta y el rango de medida necesarios para el dispositivo sometido a prueba, calcular los valores de la configuración de medida:

    • Margen de frecuencias

    • Número de puntos

    • Anchura de ventana

Véase Resolución y rango.

  4. Definir los valores para el recorrido de frecuencias y el número de puntos que se calculó en el punto anterior. Véase Configurar una medida.

  5. Si se ha seleccionado el modo de paso bajo, llevar a cabo las acciones siguientes:

    1. Dejar la frecuencia de inicio en 300 kHz e introducir la frecuencia de parada y el número de puntos.

    2. En el menú Trace, hacer clic en Transform, Set Freq. Low Pass. Con ello se definen automáticamente todas las frecuencias.

  6. Transformar los datos al dominio del tiempo y aplicar el valor de ventana que se calculó en el punto anterior. Determinar si la resolución de respuesta y el rango de medida son suficientes para la aplicación de medida.

    • Si la configuración actual no permite medir la respuesta del dispositivo, modificar el recorrido de frecuencias, el número de puntos y la anchura de la ventana. Véase Resolución y rango en el dominio del tiempo.

  7. Desactivar la transformada y realizar una calibración de medida que se adecue a las necesidades de configuración y exactitud de la medida. Véase Seleccionar y realizar una calibración de medida.

  8. Transformar los datos al dominio del tiempo.

Optimizar los resultados

  1. Utilizar Autoscale para ajustar automáticamente la escala de la respuesta de medida.

  2. Para obtener la máxima resolución de visualización, se debe centrar en la pantalla la respuesta de interés.

  3. Configurar y activar la puerta de tiempo (filtrado de tiempo) para eliminar las respuestas no deseadas de la medida visualizada. Véase Respuestas de puerta de tiempo.

Interpretar los datos mostrados

  1. Interpretar el tipo de impedancia de la discontinuidad. Véase Datos de medidas en el dominio del tiempo.

  2. Para ver los datos con puerta de tiempo en el dominio de la frecuencia, activar la función de puerta y desactivar la transformada.


Modes

Véase asimismo...

Modos de paso de banda y paso bajo en el dominio del tiempo

Descripción general

Conceptos

Cómo definir el modo de dominio del tiempo

Debe seleccionarse el modo de dominio del tiempo antes de configurar los valores de medida. La selección depende en gran medida del dispositivo sometido a prueba.
Conceptos

Cómo definir el modo de dominio del tiempo

Comparación de los modos

Paso de banda

Paso bajo
Elección del modo
Márgenes de frecuencias y puntos de datos
Respuestas de impulso y de etapa
Formatos de datos útiles

Comparación de los modos

Modo de paso de banda

  • Es el más fácil de utilizar

  • útil para medir dispositivos de p aso de b anda que no funcionan hasta el nivel de CC (0 Hz)

  • Permite que las frecuencias medidas sean cualquier conjunto de frecuencias de inicio y de parada

  • Sólo permite una respuesta de impulso, porque los datos transformados no incluyen un término de CC

  • Funciona para medidas de reflexión y de transmisión

  • Permite la localización de fallos

Modo de paso bajo

  • útil para medir dispositivos de paso bajo que funcionan hasta el nivel de CC

  • Simula el reflectómetro de dominio de tiempo (TDR) tradicional

  • Exige que las frecuencias medidas se relacionen armónicamente con un término de CC extrapolado a partir de los primeros puntos de datos del dominio de la frecuencia

  • Permite respuestas de impulso y de etapa, porque los datos transformados incluyen un término de CC

  • Permite la localización de fallos y la identificación del tipo de impedancia (capacitiva, inductiva) presente en la discontinuidad

  • Funciona para medidas de reflexión y de transmisión

  • Tiene una resolución de respuesta más alta (2 veces mayor) que el modo de paso de banda para el mismo recorrido de frecuencias

La elección del modo depende del dispositivo sometido a prueba

  • Seleccionar el modo de paso de banda si el dispositivo sometido a prueba funciona como paso de banda, rechazo de banda o filtro de paso alto.

  • Seleccionar el modo de paso bajo si el dispositivo sometido a prueba puede pasar todas las frecuencias hasta c.c. Seleccionar el modo de paso bajo aunque la respuesta del dispositivo disminuya en el lado bajo del recorrido de frecuencias.

Márgenes de frecuencias y puntos de datos

El modo de paso de banda

  • Puede seleccionarse cualquier valor para las frecuencias de inicio y de parada que estén incluidas en el rango del analizador.

  • El analizador toma los datos desde la frecuencia de inicio hasta la frecuencia de parada.

  • Ofrece únicamente respuesta de impulso.

El modo de paso bajo

  • Exige un término de CC que se extrapola a partir de los primeros puntos de datos del dominio de la frecuencia.

  • Exige la misma separación entre los puntos de datos.

  • El analizador define todas las frecuencias de medida como armónicos de la frecuencia de inicio.

  • FPARADA = N X FINICIO (N = número de puntos) impone un límite a la frecuencia de parada para cada valor de N.

Nota: Puesto que el menor valor posible de FINICIO es 300 kHz, FPARADA debe ser como mínimo N x 300 kHz.

Respuestas de impulso y de etapa

El analizador de redes puede presentar la respuesta en el dominio del tiempo como si una función de impulso o de etapa estimulara el dispositivo sometido a prueba.

  • Estímulo de impulso: es una forma de onda de tensión que pasa de cero a la unidad y vuelve a cero. La anchura del impulso se determina mediante el recorrido de frecuencias utilizado en la medida en el dominio de la frecuencia.

  • Estímulo de etapa: es una forma de onda de tensión que pasa de cero a la unidad. El tiempo de formación de etapa viene determinado por la frecuencia más alta utilizada en la medida en el dominio de la frecuencia.

Nota: La respuesta de etapa en el modo de paso bajo es el modo más sencillo de utilizar para interpretar los tipos de discontinuidades. Esta combinación también ofrece la visualización TDR comúnmente aceptada de las discontinuidades inductivas y capacitivas.

  • Con los datos de respuesta en frecuencia, el analizador calcula la respuesta de etapa, impulso o p aso de b anda del dispositivo, dependiendo de la transformada seleccionada.

  • El analizador muestra los datos en una respuesta en el dominio del tiempo (visualización tipo TDR).

Véase Resolución y rango para obtener más información sobre la forma en que el recorrido de frecuencias afecta a la anchura del impulso y el tiempo de formación.

Formatos de datos útiles

Formatos útiles para el modo de paso de banda

  • Magnitud lineal

    • Para las medidas de reflexión, este formato muestra la magnitud lineal media del coeficiente de reflexión (r) a lo largo del margen de frecuencias que se ha medido.

    • Para las medidas de transmisión, este formato muestra el coeficiente de transmisión medio (t) para la ruta de transmisión a lo largo del margen de frecuencias de la medida.

    • Este formato es útil para visualizar las respuestas de magnitudes parecidas.

  • Magnitud logarítmica

    • Para las medidas de reflexión, este formato muestra la respuesta en unidades de pérdida de retorno (dB). El valor mostrado representa la pérdida de retorno media de la discontinuidad a lo largo del margen de frecuencias de la medida.

    • Para las medidas de transmisión, este formato muestra la respuesta en unidades de pérdida o ganancia de transmisión (dB). Esto representa la pérdida media de la ruta de transmisión a lo largo del margen de frecuencias de la medida.

    • Este formato es útil para visualizar un margen dinámico amplio de respuestas de transmisión.

  • Relación de onda estacionaria

    • Para las medidas de reflexión, este formato muestra la relación de onda estacionaria (SWR) media de la discontinuidad a lo largo del margen de frecuencias de la medida.

Formatos útiles para el modo de paso bajo

  • Real

    • Este formato muestra la respuesta del dispositivo en unidades reales.

Haga clic en los botones para tener acceso a los procedimientos empleados para definir el modo de dominio del tiempo.

    • Si el dispositivo sometido a prueba tiene una respuesta de medida de hasta CC, utilizar el modo de paso bajo.

    • Si el dispositivo sometido a prueba no tiene una respuesta de medida a CC, utilizar el modo de p aso de b anda .
Definir el modo de paso bajo

Procedimiento con el ratón

Procedimiento con las teclas del panel frontal

Definir el modo de paso de banda

Procedimiento con el ratón

Procedimiento con las teclas del panel frontal

Definir el modo de paso bajo

Procedimiento con el ratón

  1. Seleccionar la configuración de la medida. Véase Configurar una medida.

  2. Calcular el recorrido de frecuencias y el número de puntos.

FPARADA = N X FINICIO, donde (N = número de puntos)

Nota: Puesto que FINICIO es 300 kHz, FPARADA debe ser como mínimo N x 300 kHz.

Número de puntos | Margen de frecuencias mínimo sólo para paso bajo
3 11 26 51 101 201 401 801 1601 | De 300 kHz a 0,9 MHz De 300 kHz a 3,0 MHz De 300 kHz a 7,8 MHz De 300 kHz a 15,3 MHz De 300 kHz a 30,3 MHz De 300 kHz a 60,3 MHz De 300 kHz a 120,3 MHz De 300 kHz a 240,3 MHz De 300 kHz a 480,3 MHz

  3. En el menú Sweep, hacer clic en Number of Points e introducir el valor.

  4. Configurar el recorrido de frecuencias:

    1. En el menú Channel, hacer clic en Start/Stop.

    2. Dejar la frecuencia de inicio en 300 kHz e introducir la frecuencia de parada.

  5. En el menú Trace, hacer clic en Transform y seleccionar el modo de transformada.

  6. Hacer clic en Set Freq. Low Pass. Con ello se definen automáticamente todas las frecuencias.

    • Si la frecuencia de parada cambia a un valor significativamente diferente del especificado, significa que el valor de inicio era inferior al margen de frecuencias mínimo para el modo de paso bajo. En este caso, reducir el número de puntos, configurar de nuevo el recorrido de frecuencias y repetir este punto.

  7. Hacer clic en la casilla de verificación Transform.

Definir el modo de paso bajo

Procedimiento con las teclas del panel frontal

  1. Seleccionar la configuración de la medida. Véase Configurar una medida.

  2. Calcular el recorrido de frecuencias y el número de puntos.

FPARADA = N X FINICIO, donde (N = número de puntos)

Nota: Puesto que FINICIO es 300 kHz, FPARADA debe ser como mínimo N x 300 kHz.

Número de puntos | Margen de frecuencias mínimo sólo para paso bajo
3 11 26 51 101 201 401 801 1601 | De 300 kHz a 0,9 MHz De 300 kHz a 3,0 MHz De 300 kHz a 7,8 MHz De 300 kHz a 15,3 MHz De 300 kHz a 30,3 MHz De 300 kHz a 60,3 MHz De 300 kHz a 120,3 MHz De 300 kHz a 240,3 MHz De 300 kHz a 480,3 MHz

  3. En el bloque CHANNEL, pulsar Sweep Setup.

  4. Pulsar F2 (Puntos) e introducir el número de puntos que se calculó en el punto anterior.

  5. Configurar el recorrido de frecuencias:

    1. En el bloque CHANNEL, pulsar Start/Stop.

    2. Dejar la frecuencia de inicio en 300 kHz.

    3. Pulsar F2 (Parada) e introducir la frecuencia de parada.

  6. En el bloque COMMAND, pulsar Menu/Dialog.

  7. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click .

  8. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Transform Mode y seleccionar el modo con las flechas.

  9. Pulsar la tecla de tabulador a la derecha para pasar a Set Freq. Low Pass. Pulsar Click. Con ello se definen automáticamente todas las frecuencias.

    • Si la frecuencia de parada cambia a un valor significativamente diferente del especificado, significa que el valor de inicio era inferior al margen de frecuencias mínimo para el modo de paso bajo. En este caso, reducir el número de puntos, configurar de nuevo el recorrido de frecuencias y repetir este punto.

  10. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Transform y pulsar Click.

Definir el modo de paso de banda

Procedimiento con el ratón

  1. Seleccionar la configuración de la medida. Véase Configurar una medida.

  2. En el menú Trace, hacer clic en Transform y seleccionar el modo de transformada Band Pass .

Procedimiento con las teclas del panel frontal

  1. Seleccionar la configuración de la medida. Véase Configurar una medida.

  2. En el bloque COMMAND, pulsar Menu/Dialog.

  3. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

  4. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Transform Mode y utilizar las flechas para seleccionar el modo Band Pass .

  5. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Transform y pulsar Click.


Res_Rge

Véase asimismo...

Resolución y rango en el dominio del tiempo

Descripción general

Conceptos

Cómo definir la
resolución y el rango

En este tema se explica cómo puede asegurarse el usuario de que verá todos los datos del dominio del tiempo disponibles para una respuesta del dispositivo. Hay que pensar cuál es la configuración que proporcionará la mejor resolución y el rango máximo.
Conceptos

Cómo definir la resolución y el rango

Resolución de respuesta
Resolución de pantalla
Rango de medida

Resolución de respuesta

La resolución de respuesta en el dominio del tiempo es la capacidad para distinguir entre dos respuestas próximas en el espacio. Existen varios factores que determinan la resolución de la respuesta medida en el dominio del tiempo.
Recorrido de frecuencias
Anchura de ventana
Modo de dominio del tiempo

Influencia del recorrido de frecuencias en la resolución de respuesta

En el gráfico siguiente se muestra el efecto de los recorridos de frecuencias estrechos y amplios en la resolución de respuesta.

  • La respuesta medida con un recorrido de frecuencias estrecho se muestra superpuesta a las respuestas individuales de los conectores, medidas con un recorrido de frecuencias relativamente amplio.

  • El recorrido de frecuencias más amplio permite al analizador resolver los dos conectores en respuestas separadas y diferenciadas.

  • La relación entre el recorrido de frecuencias y la anchura del impulso en el tiempo es inversamente proporcional.

  • Cuanto más amplio es el recorrido de frecuencias, más estrecha es la anchura del impulso o el tiempo de formación de la etapa.

  • Para respuestas de la misma amplitud, la resolución de respuesta es igual a la anchura del impulso, que se define como el 50% (-6 dB) de los puntos, o al tiempo de formación de la etapa, que se define como del 10% al 90% de los puntos.

Influencia de la anchura de la ventana en la resolución de respuesta

  • La resolución de respuesta también es una función de la ventana utilizada en la transformada.

  • Se puede calcular la resolución de respuesta aproximada mediante las fórmulas siguientes. Estas fórmulas se aplican sólo a las respuestas con la misma amplitud y calculan la anchura del impulso del 50% o el tiempo de formación de la etapa del 10% al 90%.

En el gráfico siguiente se muestra cómo la selección de la anchura de la ventana depende de las respuestas del dispositivo.

  • En el caso de señales del mismo nivel, se debe utilizar la ventana mínima para mejorar la resolución.

  • En el caso de señales de niveles distintos, se debe utilizar la ventana máxima para mejorar el m argen dinámico.

Influencia del modo de dominio del tiempo en la resolución de respuesta

  • La resolución de respuesta es diferente entre los modos de p aso de b anda y paso bajo del dominio del tiempo.

  • Para los mismos recorrido de frecuencias y número de puntos, el modo de paso bajo tiene una resolución más alta, lo que reduce la anchura del impulso a la mitad en comparación con el modo de paso de banda.

Resolución de pantalla

La resolución de pantalla en el dominio del tiempo es la capacidad para localizar con exactitud una respuesta en el tiempo. Una resolución de pantalla más fina permite localizar los picos y nulos de una respuesta con mayor exactitud. Sobre esta mejora influyen directamente el intervalo de tiempo y el número de puntos seleccionados.

Resolución de pantalla = TPeriodo / Puntos - 1

La resolución de pantalla se puede mejorar de dos formas:

  • Reduciendo el periodo de tiempo.

  • Aumentando el número de puntos.

Nota: El aumento del número de puntos puede invalidar la calibración de medida.

En el ejemplo siguiente, ambas medidas constan de 201 puntos.

  • La resolución de 50 psegundos tiene un periodo de tiempo de 10 nsegundos.

  • La resolución de 12,5 psegundos tiene un periodo de tiempo de 2,5 nsegundos.

Nota: La capacidad para resolver dos señales próximas en el espacio no resulta afectada. Sin embargo, si la medida está en el modo de paso bajo, el cambio del número de puntos puede afectar al recorrido de frecuencias.

Consejos para optimizar la resolución

  • En la mayoría de los casos, se debe seleccionar el recorrido de frecuencias más largo válido para obtener la resolución más alta en el tiempo. Sin embargo, la frecuencia debe mantenerse dentro del margen de frecuencias útil del dispositivo sometido a prueba.

  • La resolución de respuesta depende del recorrido de frecuencias, la anchura de la ventana y el modo de dominio del tiempo.

Rango de medida

En el dominio del tiempo, el rango de medida se define como el periodo de tiempo a lo largo del cual puede realizarse una medida sin que se encuentre una repetición de la respuesta.

Nota: El rango y las resoluciones de respuesta están inversamente relacionadas. Cuando uno de ellos mejora, el otro empeora.

La repetición de la respuesta (o solapamiento) se produce a intervalos de tiempo periódicos. En el ejemplo siguiente, la respuesta real próxima a cero segundos se repite aproximadamente a los 60 nanosegundos y de nuevo aproximadamente a los 120 nanosegundos.

El rango está relacionado con el espaciado entre los puntos de frecuencia de la respuesta en frecuencia medida del dispositivo.

El rango de medida es directamente proporcional al (número de puntos - 1) e inversamente proporcional al recorrido de frecuencias. Para aumentar el rango pueden modificarse dos parámetros:

  • Aumentar el número de puntos.

  • Reducir el recorrido de frecuencias.

Nota: Cualquiera de estas dos modificaciones debe realizarse antes de efectuar una calibración de medida.

Para averiguar el rango de medida en metros, multiplicar el intervalo de tiempo por la velocidad de la luz en espacio libre (3 x 108 metros por segundo). Para calcular la longitud física real del rango de medida, multiplicar este valor por la velocidad relativa del medio de transmisión.

  • Vpolietileno = 0,66

  • Vteflón = 0,70

Nota: La configuración del instrumento para conseguir el rango más largo posible reduce la resolución de respuesta en el dominio del tiempo. El rango máximo depende también de la pérdida del cable. Si la señal de retorno es demasiado pequeña para poder medirse, el rango se verá limitado por esta atenuación con independencia del recorrido de frecuencias.

Haga clic en los botones para tener acceso a los procedimientos empleados para definir la resolución y el rango en el dominio del tiempo.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Este procedimiento da por sentado que ya se dispone de una medida configurada en el dominio del tiempo.

Resolución de respuesta

  1. Para lograr la resolución de respuesta necesaria, calcular el recorrido de frecuencias y la anchura de la ventana.

  2. En el menú Trace, hacer clic en Transform.

  3. En la casilla Category, hacer clic en la flecha hacia abajo y seleccionar Window.

  4. Seleccionar una anchura de ventana que ayude a lograr la resolución necesaria para la aplicación de medida.

    • Seleccionar una ventana mínima si se necesita medir señales de la misma magnitud.

    • Seleccionar una ventana máxima si se necesita medir señales de magnitudes muy distintas.

  5. En el menú Channel, hacer clic en Start/Stop e introducir los valores para aumentar el margen de frecuencias.

  6. Si aún se necesita más resolución de respuesta y el dispositivo sometido a prueba funciona hasta CC, utilizar el modo de transformada de paso bajo. Véase Modos de dominio del tiempo.

Resolución de pantalla

  1. En el menú Trace, hacer clic en Transform.

  2. En la casilla Center, introducir un valor que coloque las respuestas que se están midiendo en el centro de la pantalla.

  3. En la casilla Span, introducir un valor que reduzca el periodo de tiempo.

  4. Si aún se necesita más resolución de pantalla, aumentar el número de puntos. En el menú Sweep, hacer clic en Number of Points y seleccionar un valor más alto.

Rango de medida

Cuando se produce una repetición de respuesta o solapamiento, generalmente no es posible distinguir visualmente una respuesta real de una respuesta con solapamiento sin realizar una prueba.

  1. Aumentar el periodo de tiempo y ver si existen repeticiones obvias con espacios perceptibles entre ellas.

  2. Si todavía no existe la seguridad de que la respuesta sea real, centrarla en la pantalla y almacenar la traza.

  3. Reducir el recorrido de frecuencias en un 5% aproximadamente y volver a medir el dispositivo.

  • Si la respuesta en el dominio del tiempo es válida, permanecerá en el centro de la pantalla.

  • Si la respuesta es un solapamiento, se moverá a lo largo del eje de tiempo cuando se modifique el margen de frecuencias.

  4. Calcular el recorrido de frecuencias y el número de puntos con el que se consigue el rango de medida necesario.

  5. En el menú Sweep, hacer clic en Number of Points y seleccionar un valor más alto.

  6. En el menú Channel, hacer clic en Start/Stop e introducir los valores del cálculo para lograr el rango de medida necesario.

Nota: Después de haber modificado la configuración de la medida para lograr la resolución y el rango necesarios, desactivar la transformada, realizar una calibración de medida y, a continuación, activar la transformada.

Procedimiento con las teclas del panel frontal

Este procedimiento da por sentado que ya se dispone de una medida configurada en el dominio del tiempo.

Resolución de respuesta

  1. Para lograr la resolución de respuesta necesaria, calcular el recorrido de frecuencias y la anchura de la ventana.

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Category, hacer clic en la flecha hacia abajo y seleccionar Window.

  4. Seleccionar una anchura de ventana que ayude a lograr la resolución necesaria para la aplicación de medida.

    • Seleccionar una ventana mínima si se necesita medir señales de la misma magnitud.

    • Seleccionar una ventana máxima si se necesita medir señales de magnitudes muy distintas.

  5. En el menú Channel, hacer clic en Start/Stop e introducir los valores para aumentar el margen de frecuencias.

  6. Si aún se necesita más resolución de respuesta y el dispositivo sometido a prueba funciona hasta CC, utilizar el modo de transformada de paso bajo. Véase Modos de dominio del tiempo.

Resolución de pantalla

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Center e introducir un valor que coloque las respuestas que se están midiendo en el centro de la pantalla.

  4. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Span e introducir un valor que reduzca el periodo de tiempo.

  5. Si aún se necesita más resolución de pantalla, aumentar el número de puntos.

    1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

    2. Pulsar F2 (Puntos) y seleccionar un valor más alto.

Rango de medida

Cuando se produce una repetición de respuesta o solapamiento, generalmente no es posible distinguir visualmente una respuesta real de una respuesta con solapamiento sin realizar una prueba.

  1. Aumentar el periodo de tiempo y ver si existen repeticiones obvias con espacios perceptibles entre ellas.

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

    3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Span e introducir un valor que aumente el periodo de tiempo.

  2. Si todavía no existe la seguridad de que la respuesta sea real, centrarla en la pantalla y almacenar la traza.

    1. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Center e introducir un valor que coloque las respuestas que se están midiendo en el centro de la pantalla.

    2. En el bloque TRACE SETUP, pulsar Math/Memory y F1 (Datos>>Mem).

  3. Reducir el recorrido de frecuencias en un 5% aproximadamente y volver a medir el dispositivo.

    1. En el bloque CHANNEL SETUP, pulsar Stop/Span.

    2. En la barra de herramientas Active Entry, pulsar F4 (Recorrido) e introducir un valor que reduzca el recorrido.

  4. Si la respuesta en el dominio del tiempo es válida, permanecerá en el centro de la pantalla.

  • Si la respuesta es un solapamiento, se moverá a lo largo del eje de tiempo cuando se modifique el margen de frecuencias.

  4. Calcular el recorrido de frecuencias y el número de puntos con los que se consigue el rango de medida necesario.

  5. En el bloque CHANNEL SETUP, pulsar Sweep Setup, F2 (Puntos) y seleccionar el valor del cálculo.

  6. En el bloque CHANNEL SETUP, pulsar Start/Stop e introducir los valores del cálculo para lograr el rango de medida necesario.

Nota: Después de haber modificado la configuración de la medida para lograr la resolución y el rango necesarios, desactivar la transformada, realizar una calibración de medida y, a continuación, activar la transformada.


Wind

Véase asimismo...

Filtro de ventana para los datos mostrados

Descripción general

Conceptos

Cómo definir el filtro de ventana

La transformación en el dominio del tiempo puede causar limitaciones en la resolución de tiempo debido a los efectos de los lóbulos laterales y la anchura del impulso. Los efectos pueden modificarse mediante el uso del filtro de ventana.
Conceptos

Cómo definir el filtro de ventana

El analizador proporciona una función de visualización en ventana que aumenta la utilidad de las medidas en el dominio del tiempo para aislar e identificar las respuestas individuales. Esta función tiene el efecto de cambiar la anchura del impulso, el nivel de lóbulos laterales y el tiempo de formación de etapa de los resultados en el dominio del tiempo.
Beneficios del filtrado de ventana
Valor de ventana apropiado

Beneficios del filtrado de ventana

Existen transiciones abruptas en las frecuencias de inicio y de parada de una medida en el dominio de la frecuencia que provocan sobreimpulsos y sonido de llamada en una respuesta en el dominio del tiempo. La función de ventana es útil para reducir la brusquedad de las transiciones en el dominio de la frecuencia.

  • La anchura del impulso o el tiempo de formación de la etapa: causados por la naturaleza de banda limitada del sistema de prueba limitan la capacidad para resolver dos respuestas próximas en el espacio. La anchura del impulso es inversamente proporcional al recorrido de frecuencias de la medida, y la única forma de poder estrechar la anchura del impulso es aumentar el recorrido de frecuencias.

  • Los lóbulos laterales del impulso: causados por el corte abrupto en la frecuencia de parada limitan el m argen dinámico de la medida en el dominio del tiempo mediante la ocultación de las respuestas de nivel bajo dentro del lóbulo lateral de las respuestas de nivel superior adyacentes.

Efectos del filtrado de ventana

  • La resolución de respuesta se mejora mediante la reducción de la anchura del impulso, lo que permite resolver dos respuestas próximas en el espacio.

  • El margen dinámico se mejora mediante la reducción de los lóbulos laterales del impulso, lo que permite medir respuestas de nivel bajo.

Pueden variarse los valores de ventana:

Valor de ventana | Niveles de lóbulo lateral | Anchura del impulso | Idóneo para...
Mínimo | Más altos | Más pequeña | Resolución de respuesta
Máximo | Más bajos | Más grande | Margen dinámico

Nota: La resolución es directamente proporcional a la función de ventana aplicada e inversamente proporcional al recorrido de frecuencias medido. Consulte Resolución de rango y respuesta.

El analizador puede modificar las respuestas del dispositivo mediante el uso de un filtro de ventana en los datos medidos, con los efectos siguientes.

  • En el estímulo de impulso: las limitaciones en la resolución de tiempo se alteran debido a los efectos del lóbulo lateral y la anchura del impulso.

  • En el estímulo de etapa: (sólo en paso bajo) se reducen el sobreimpulso y el sonido de llamada.

Valor de ventana apropiado

Puede elegirse la ventana que mejor se adecue a los tipos de respuestas que se espera obtener del dispositivo sometido a prueba.

  • Si el dispositivo medido tiene dos respuestas con el mismo nivel de amplitud, seleccionar la anchura de impulso menor: ventana mínima para mejorar la resolución.

  • Si el dispositivo medido tiene dos respuestas con niveles de amplitud diferentes, seleccionar el nivel de lóbulo lateral inferior: ventana máxima para mejorar el m argen dinámico.

Características de la ventana

Existen las dependencias siguientes, que se muestran como valores de ejemplo en la tabla siguiente.

Dependencia

Niveles de lóbulo lateral

  • Ventana seleccionada

Tiempo de formación de etapa y
anchura del impulso

  • Ventana seleccionada

  • Recorrido de frecuencias

Las características de la ventana de ejemplo se muestran para un recorrido de frecuencias de 2,997 GHz.

Características de la ventana |  | Resolución de respuesta* |  | Margen dinámico
 |  | Tiempo de formación de etapa (10% - 90% de nivel) | Anchura del impulso (50% de nivel) | Nivel de lóbulo lateral
Etapa de paso bajo | Mínima | 150 ps |  | -21 dBc
 | Normal | 330 ps |  | -60 dBc
 | Máxima | 494 ps |  | < -70 dBc
Impulso de paso bajo | Mínimo |  | 200 ps | -13 dBc
 | Normal |  | 320 ps | -44 dBc
 | Máximo |  | 481 ps | < -75 dBc
Impulso de paso de banda | Mínimo |  | 400 ps | -13 dBc
 | Normal |  | 641 ps | -44 dBc
 | Máximo |  | 961 ps | < -75 dBc

Ecuaciones de resolución de respuesta

En el gráfico siguiente se muestran los efectos característicos de diversas ventanas aplicados a la respuesta de una medida de reflexión de circuito cerrado.

Haga clic en los botones para tener acceso a los procedimientos empleados para definir el filtro de ventana en el modo de dominio del tiempo.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Transform.

  2. En la casilla Category, hacer clic en la flecha hacia abajo y seleccionar Window.

  3. Seleccionar una ventana que ayude a lograr la resolución necesaria para la aplicación de medida.

    • Seleccionar una ventana mínima si se necesita medir señales de la misma magnitud para aumentar la resolución de respuesta.

    • Seleccionar una ventana máxima si se necesita medir señales de magnitudes muy distintas para aumentar el m argen dinámico.

Nota: Puede especificarse un valor de ventana por mínimo/máximo, Kaiser Beta o anchura de impulso/tiempo de formación de etapa.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Category, hacer clic en la flecha hacia abajo y seleccionar Window.

  4. Seleccionar una ventana que ayude a lograr la resolución necesaria para la aplicación de medida.

    • Seleccionar una ventana mínima si se necesita medir señales de la misma magnitud para aumentar la resolución de respuesta.

    • Seleccionar una ventana máxima si se necesita medir señales de magnitudes muy distintas para aumentar el margen dinámico.

Nota: Puede especificarse un valor de ventana por mínimo/máximo, Kaiser Beta o anchura de impulso/tiempo de formación de etapa.


Gating

Véase asimismo...

Filtro de puerta de tiempo

Descripción general

Conceptos

Cómo definir el filtro de puerta de tiempo

El sistema de puerta permite seleccionar y eliminar matemáticamente respuestas en el dominio del tiempo (filtro de tiempo). A continuación, el analizador puede transformar de nuevo las respuestas restantes en el dominio del tiempo al dominio de la frecuencia para mostrarlas.
Conceptos

Cómo definir el filtro de puerta de tiempo

Después de aplicar la puerta a la respuesta en el dominio del tiempo, se puede desactivar la transformada y examinar la respuesta en frecuencia del dispositivo con la puerta aún activa. En una medida de la transmisión, por ejemplo, se pueden eliminar los efectos de varias rutas de transmisión. También se puede ver cada respuesta en el dominio del tiempo de forma individual y analizar el efecto de cada una de ellas en el dominio de la frecuencia.
Funcionamiento de la puerta de tiempo
Configuración de la puerta
Formas de puerta
Características de la puerta

Funcionamiento de la puerta de tiempo

  1. Medir un dispositivo en el dominio de la frecuencia.

  2. Activar la transformada en el dominio del tiempo. El analizador de redes calcula la respuesta en el dominio del tiempo (paso bajo o paso de banda).

  3. Configurar los límites de la puerta.

    • Para un tipo de puerta de paso de banda: centrar la puerta en las respuestas que se desee conservar en la medida. Al activar la puerta, las respuestas que queden fuera de la misma se eliminarán matemáticamente de la medida mostrada.

    • Para un tipo de puerta de muesca: centrar la puerta en las respuestas que se desee eliminar de la medida. Al activar la puerta, las respuestas que queden dentro de la misma se eliminarán matemáticamente de la medida mostrada.

  4. Desactivar la transformada en el dominio del tiempo para ver las respuestas en el dominio de la frecuencia y observar los efectos de la eliminación de las respuestas que quedan fuera del tramo de la puerta (o dentro del tramo de la puerta para el tipo de puerta de muesca). En el ejemplo siguiente se muestra el funcionamiento de una puerta con forma de paso de banda.

Configuración de la puerta

Pueden definirse los límites y el comportamiento de la puerta con los parámetros siguientes:

  • Start y Stop: muestran los tiempos de corte de -6 dB.

  • Center: selecciona el tiempo central de la puerta.

  • Span: equivale al tiempo de parada menos el tiempo de inicio de la puerta.

  • Tipo de puerta:

    • Bandpass: elimina las respuestas que quedan fuera de los valores de inicio/parada o de tramo.

    • Notch: elimina las respuestas que quedan dentro de los valores de inicio/parada o de tramo.

En este ejemplo se eligió el tipo de puerta de paso de banda, que elimina las respuestas que quedan fuera del tramo.

.

Formas de puerta

Una puerta también tiene una forma de filtro similar al filtro de ventana que se describe en Filtro de ventana para los datos mostrados. Puede optimizarse la medida mediante la selección de una de las distintas formas de puerta: mínima, normal, amplia y máxima.

  • Forma mínima: tiene los lóbulos laterales más altos, la disminución más brusca y la ondulación de banda de paso más grande.

  • Forma máxima: tiene los lóbulos laterales más bajos, la disminución más lenta y la ondulación de banda de paso más pequeña.

Ondulación de banda de paso de la puerta

La puerta es un filtro con forma de paso de banda y cada una de sus cuatro formas presenta características de filtro diferentes. En el gráfico siguiente se muestra la diferencia en la ondulación de banda de paso para cada una de las cuatro formas de puerta a 0,5 dB/división. La puerta mínima tiene la ondulación más grande.

Lóbulos laterales de la puerta

En el gráfico siguiente se comparan los niveles de los lóbulos laterales de cada una de las cuatro formas de puerta. Los niveles de lóbulos laterales más bajos se consiguen a costa de un aumento de la velocidad de corte.

  • La puerta mínima tiene los niveles de lóbulos laterales más altos, una velocidad de corte rápida y es la más útil para dejar fuera de la puerta una respuesta no deseada que se encuentre próxima en el tiempo a una respuesta deseada.

  • La puerta máxima tiene los niveles de lóbulos laterales más bajos y una velocidad de corte más lenta, lo que da como resultado una forma de puerta más amplia y la mayor atenuación de respuestas fuera del tramo de la puerta.

Características de la puerta

Cada una de las cuatro formas de puerta disponibles presenta características diferentes:

  • Ondulación de banda de paso y niveles de lóbulos laterales: describen la forma de la puerta.

  • Tiempo de corte: es el periodo que transcurre entre el tiempo de parada (-6 dB en la falda del filtro) y el pico del primer lóbulo lateral.

  • Tramo de puerta mínimo: es el doble del tiempo de corte.

Tiempo de corte

En el diagrama siguiente se muestra la forma de puerta global y se enumeran las características de cada forma.

  • T1 es el tramo de la puerta, que equivale al tiempo de parada menos el tiempo de inicio.

  • T2 es el tiempo que transcurre entre el borde de la banda de paso y el punto -6 dB, que representa la velocidad de corte del filtro.

  • T3 es el tiempo que transcurre entre el punto -6 dB y el borde de la banda de parada de la puerta.

Para todas las formas de filtro, T2 es igual a T3y el filtro es igual a ambos lados del tiempo central.

Tramo de puerta mínima

Cada forma de puerta tiene un tramo de puerta mínimo recomendado para que funcione correctamente. Esto es consecuencia de la velocidad de corte finita de la puerta. El tramo de puerta mínimo recomendado se calcula mediante la ecuación siguiente, por la que la banda de paso del filtro equivale a 0 segundos.

T1MíN = 2 x T2

Si se especifica un tramo de puerta inferior al tramo mínimo, el analizador producirá los efectos siguientes:

  • forma de puerta distorsionada que no tiene banda de paso

  • forma distorsionada

  • indicaciones incorrectas de horas de inicio y parada

  • puede tener niveles de lóbulos laterales aumentados

Haga clic en los botones para tener acceso a los procedimientos empleados para configurar la puerta en el dominio del tiempo.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Transform.

  2. En el cuadro Category, hacer clic en la flecha hacia abajo y seleccionar Gating.

  3. En el cuadro Gate Type, seleccionar el tipo de filtro de puerta.

    • Seleccionar Bandpass para eliminar las respuestas mostradas que queden fuera del tramo de la puerta.

    • Seleccionar Notch para eliminar las respuestas mostradas que queden dentro del tramo de la puerta.

  4. En el cuadro Gate Shape, seleccionar la forma del filtro de puerta. Cada forma de puerta tiene un tramo de puerta mínimo recomendado para que funcione correctamente.

  5. Definir los límites de la puerta de tiempo utilizando los parámetros Start y Stop o Center y Span.

  6. Hacer clic en la casilla de verificación Gating para activar la función de puerta.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform . Pulsar Click.

  3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Category, hacer clic en la flecha hacia abajo y seleccionar Gating.

  4. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Gate Type y seleccionar el tipo de filtro de puerta.

    • Seleccionar Bandpass para eliminar las respuestas mostradas que queden fuera del tramo de la puerta.

    • Seleccionar Notch para eliminar las respuestas mostradas que queden dentro del tramo de la puerta.

  5. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Gate Shape y seleccionar la forma del filtro de puerta. Cada forma de puerta tiene un tramo de puerta mínimo recomendado para que funcione correctamente. Véase Características de la puerta.

  6. Definir los límites de la puerta de tiempo utilizando los parámetros Start y Stop o Center y Span.

  7. Pulsar la tecla de tabulador a la derecha para pasar a la casilla de verificación Gating y pulsar Click para activar la función de puerta.


Tdata

Véase asimismo...

Datos de medida en el dominio del tiempo

Descripción general

Conceptos

Cómo interpretar los datos de tiempo

Para facilitar el conocimiento de las respuestas del dispositivo en el dominio del tiempo, en este tema se muestran ejemplos de diversos tipos de medidas.
Conceptos

Cómo interpretar los datos de medidas en el dominio del tiempo

Enmascaramiento
Medida de la reflexión en el modo de paso de banda
Medida de la transmisión en el modo de paso de banda
Localización de fallos utilizando el modo de paso bajo
Medida de la reflexión en el modo de paso bajo
Medida de la transmisión en el modo de paso bajo

Enmascaramiento

Puesto que el enmascaramiento afecta a las respuestas que se ven en una medida en el dominio del tiempo, resulta útil comprender en qué consiste cuando se interpreten los datos de la medida.

  • El enmascaramiento se produce cuando una discontinuidad o pérdida muy próxima al plano de referencia afecta a la respuesta de todas las discontinuidades siguientes.

  • La energía que se refleja o absorbe desde la primera discontinuidad nunca llega a la segunda o las posteriores.

  • El resultado es que todas las respuestas siguientes son más pequeñas de lo que deberían haber sido si no hubiera existido la primera respuesta.

Enmascaramiento debido a la reflexión de energía

El enmascaramiento debido a la reflexión se produce siempre que se encuentra un desajuste importante. Este fenómeno de enmascaramiento se muestra en el ejemplo siguiente, donde la impedancia de línea varía.

  • Una línea de 50 ohmios, conectada a una línea aérea de 25 ohmios, conectada a una línea de 50 ohmios

  • La primera discontinuidad tiene un coeficiente de reflexión de aproximadamente 0,333 (que es correcto para una impedancia de 25 ohmios)

  • Al final de la sección de 25 ohmios, la respuesta no muestra el coeficiente de reflexión de 0,333 (algo que debería hacer con una impedancia de 50 ohmios). Tal y como indican los dos marcadores delta, existe una diferencia de 35,355 mU en sus magnitudes. El motivo es que el impulso incidente en la segunda respuesta tiene una amplitud inferior a la unidad debido a la energía reflejada en el primer desajuste.

Enmascaramiento debido a la absorción de energía

El enmascaramiento debido a la absorción de energía se produce cuando se mide un circuito con pérdidas. Este fenómeno de enmascaramiento se muestra en el ejemplo siguiente, donde un cable está terminado con un circuito abierto.

  • La respuesta del circuito abierto muestra una pérdida de retorno de -2,445 dB en el marcador 1 (visto en el formato de magnitud logarítmica).

  • La respuesta prevista es el valor característico del circuito abierto (0 dB).

  • El valor del marcador representa la suma de las pérdidas de las rutas de avance y retorno.

Medida de la reflexión en el modo de paso de banda

Datos del eje horizontal

  • Tiempo que un impulso aplicado en el puerto de prueba tarda en llegar a una discontinuidad y regresar al puerto de prueba.

Datos del eje vertical

  • Pérdida de retorno (dB) si se utiliza el formato de magnitud logarítmica

  • Coeficiente de reflexión (rho) si se utiliza el formato de magnitud lineal

En el ejemplo siguiente se muestra una medida de la reflexión en el modo de p aso de b anda .

  • Hay un impulso en el punto de tiempo cero que representa el tiempo de propagación de la primera discontinuidad (conector) que se encuentra desde la salida del puerto de prueba.

  • El impulso siguiente representa la próxima discontinuidad (conector) que ha encontrado el impulso.

Medida de la transmisión en el modo de paso de banda

Datos del eje horizontal

  • Retardo de propagación a través del dispositivo sometido a prueba

Datos del eje vertical

  • Pérdida o ganancia de transmisión (dB) si se utiliza el formato de magnitud logarítmica

  • Coeficiente de transmisión (rho) si se utiliza el formato de magnitud lineal

En el ejemplo siguiente se muestra una medida de la transmisión en el modo de p aso de b anda .

  • Se muestra cómo este modo puede proporcionar información sobre varias rutas de desplazamiento dentro de un filtro de onda acústica superficial (SAW).

  • El impulso más próximo al punto de tiempo cero representa el tiempo de propagación de la ruta más corta desde la entrada hasta la salida de la red. Este impulso no tiene que ser necesariamente el más grande ni representar la ruta deseada.

  • Todos los impulsos siguientes representan otras rutas posibles, desde la entrada hasta la salida, que resultan ser más largas que la ruta más corta.

Sugerencia: Para ver únicamente la respuesta de la ruta principal del filtro SAW, se puede definir la puerta de tiempo para que bloquee todos los impulsos excepto el principal. Luego, en el dominio de la frecuencia, sólo se muestra la respuesta en frecuencia de la ruta principal.

Localización de fallos utilizando el modo de paso bajo

El modo de paso bajo puede simular la respuesta del reflectómetro de dominio de tiempo (TDR) del dispositivo de prueba. Esta respuesta contiene información útil para determinar el tipo de discontinuidad existente.

En el gráfico siguiente se muestran las respuestas de paso bajo de las discontinuidades conocidas. Cada elemento del circuito se ha simulado para mostrar la forma de onda de respuesta S11 correspondiente de paso bajo en el dominio del tiempo. El modo de paso bajo permite ver una respuesta al estímulo de etapa o de impulso.

Sugerencia: La respuesta de etapa facilita la identificación de las características de la discontinuidad. Este modo es el que más se asemeja a las medidas TDR tradicionales.

Medida de la reflexión en el modo de paso bajo

Datos del eje horizontal

  • Tiempo que un impulso aplicado en el puerto de prueba tarda en llegar a una discontinuidad y regresar al puerto de prueba.

Nota: Para determinar la longitud física real, introducir el factor de velocidad apropiado.

Datos del eje vertical

  • Coeficiente de reflexión (r) si se utiliza el formato Real

En el ejemplo siguiente se muestra la misma medida de la reflexión en el modo de paso bajo, indicada con una respuesta de impulso y superpuesta con una respuesta de etapa en el formato de magnitud logarítmica.

  • En el ejemplo siguiente se muestran las medidas de la reflexión de paso bajo de dos cables distintos en el formato Real.

  • La respuesta de paso bajo contiene información sobre el lugar en el que está localizada la discontinuidad y el tipo de impedancia que existe.

  • La medida de la izquierda: muestra la respuesta de un cable doblado que tiene una discontinuidad capacitiva.

  • La medida de la derecha: muestra la respuesta de un cable deshilachado que tiene una discontinuidad inductiva.

Medida de la transmisión en el modo de paso bajo

Datos del eje horizontal

  • Tiempo de tránsito medio a través de un dispositivo a lo largo de un margen de frecuencias

  • R etardo eléctrico de un dispositivo en el tiempo

Datos del eje vertical

  • Unidades reales (por ejemplo, voltios) si se utiliza el formato Real

  • Pérdida o ganancia de transmisión (dB) si se utiliza el formato de magnitud logarítmica (sólo para modo de impulso)

En el ejemplo siguiente se muestra la respuesta de etapa de paso bajo de un amplificador.

  • El retardo de grupo medio a lo largo del margen de frecuencias de la medida es la diferencia de tiempo entre la etapa y la respuesta del amplificador.

  • El tiempo de formación de etapa es proporcional a la frecuencia más alta del barrido en el dominio de la frecuencia: cuanto más alta sea la frecuencia, más corto será el tiempo de formación.

  • El sonido de llamada de la respuesta del amplificador indica un diseño con insuficiente amortiguamiento.

Sugerencia: para la respuesta de etapa de paso bajo, el formato más útil es el Real (unidades de coeficiente de reflexión). Para el impulso se puede utilizar también el formato Real, pero si se desea obtener el m argen dinámico óptimo para ver simultáneamente las discontinuidades grandes y pequeñas, debería utilizarse el formato de magnitud logarítmica.

Haga clic en los botones para tener acceso a los procedimientos empleados para ver los resultados de las medidas en el dominio del tiempo.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Definir el tiempo de inicio en -1 segundo para ver las respuestas desde el puerto de prueba.

    1. En el menú Trace, hacer clic en Transform.

    2. Hacer clic en la casilla Start e introducir -1 segundo.

  2. En el menú Trace, hacer clic en Autoscale para ver la respuesta de medida en su totalidad.

  3. Para obtener la máxima resolución de visualización, centrar la respuesta de interés en la pantalla y reducir el periodo de tiempo.

    1. En el menú Trace, hacer clic en Transform.

    2. Hacer clic en la casilla Start e introducir -1 segundo.

  4. Si se necesita una resolución de respuesta mayor, podrá modificarse la configuración de la medida y de la ventana. Véase Resolución y rango en el dominio del tiempo.

  5. Para determinar el tiempo y la distancia correctos de las respuestas, definir el factor de velocidad adecuado.

    1. En el menú Scale, hacer clic en Electrical Delay.

    2. En la casilla Velocity Factor, introducir un valor comprendido entre 0 y 1,0.

      • Velocidad de la luz en el vacío = 1,0

      • Polietileno (la mayoría de los cables) = 0,66

      • Teflón = 0,7

    3. Utilizar un marcador para ver el tiempo (x2) y la longitud eléctrica (x2) hasta una discontinuidad.

Nota: Para determinar la longitud física, en lugar de la longitud eléctrica, cambiar el factor de velocidad al del medio sometido a prueba. Para que los marcadores lean la distancia unidireccional real hasta una discontinuidad, en lugar de la distancia bidireccional, introducir la mitad del factor de velocidad real.

  6. Si se está utilizando el modo de paso bajo, determinar la magnitud y la fase de un cambio de impedancia. Véase Localización de fallos utilizando el modo de paso bajo.

Procedimiento con las teclas del panel frontal

  1. Definir el tiempo de inicio en -1 segundo para ver las respuestas desde el puerto de prueba.

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

    3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Start e introducir -1 segundo.

  2. En el bloque TRACE SETUP, pulsar F1 (Escala automática) para ver la respuesta de la medida en su totalidad.

  3. Para obtener la máxima resolución de visualización, centrar la respuesta de interés en la pantalla y reducir el periodo de tiempo.

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y las teclas de flecha para pasar al menú Trace y desplazarse hasta la opción Transform. Pulsar Click.

    3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Center e introducir un valor que mueva la respuesta de interés al centro de la pantalla.

    4. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Span e introducir un valor que reduzca el periodo de tiempo.

  4. Si se necesita una resolución de respuesta mayor, podrá modificarse la configuración de la medida y de la ventana. Véase Resolución y rango en el dominio del tiempo.

  5. Para determinar el tiempo y la distancia correctos de las respuestas, definir el factor de velocidad adecuado.

    1. En el bloque COMMAND, pulsar Menu/Dialog.

    2. En el bloque NAVIGATION, pulsar la tecla de tabulador a la derecha y la tecla de flecha hacia abajo para pasar al menú Scale y desplazarse hasta la opción Electrical Delay. Pulsar Click.

    3. Pulsar la tecla de tabulador a la derecha para pasar a la casilla Velocity Factor e introducir un valor comprendido entre 0 y 1,0.

      • velocidad de la luz en el vacío = 1,0

      • Polietileno (la mayoría de los cables) = 0,66

      • Teflón = 0,7

    4. Utilizar un marcador para ver el tiempo (x2) y la longitud eléctrica (x2) hasta una discontinuidad.

Nota: Para determinar la longitud física, en lugar de la longitud eléctrica, cambiar el factor de velocidad al del medio sometido a prueba. Para que los marcadores lean la distancia unidireccional real hasta una discontinuidad, en lugar de la distancia bidireccional, introducir la mitad del factor de velocidad real.

  6. Si se está utilizando el modo de paso bajo, determinar la magnitud y la fase de un cambio de impedancia. Véase Localización de fallos utilizando el modo de paso bajo.


The Analyzer Object Model

See Also...

PNA Object Model

Click on an object box to view details.


Application Object

Description

The Application object is the highest object in the analyzer object model. This object presents methods and properties that affect the entire analyzer, rather than a specific channel or measurement. For example, the application object provides the GetIDString method. There's only one ID string for the instrument, unrelated to the channel or parameter being measured. Likewise, the TriggerSignal Property is global to the instrument. You can elect to use an internally generated (free run) trigger, or a manual trigger. Either way, that type of trigger generation will be used on all measurements, on all channels. Therefore, it is under the Application object.

This object is unique in that you must Create this object rather than just get a handle to it. See Getting a Handle to an Object.

Methods

Description

ActivateWindow

Makes a window object the Active Window.

AllowAllEvents

Monitors all events

AllowEventCategory

Monitors an event category

AllowEventMessage

Monitors an event

AllowEventSeverity

Monitors an event severity level

BuildHybridKit

Defines the user kit as port1kit + port2kit.

SetFailOnOverRange

Channel (object)

CreateMeasurement

Creates a new measurement.

CreateSParameter

Creates a new S-Parameter measurement.

DeleteShortCut

Removes a macro (shortcut) from the list of macros

DisallowAllEvents

Monitors NO events

DoPrint

Prints the screen to the active Printer.

ExecuteShortcut

Executes a macro (shortcut) stored in the analyzer.

GetShortcut

Returns the title and path of the specified macro (shortcut).

ManualTrigger

Triggers the analyzer when TriggerSignal = naTriggerManual.

Preset

Resets the analyzer to factory defined default settings.

PrintToFile

Saves the screen data to bitmap (.bmp) file of the screen.

PutShortcut

Puts a Macro (shortcut) file into the analyzer.

Quit

Ends the Network Analyzer application.

Recall

Restores all cal kits from disk.

RecallKits

Recalls the current state of the calibration kits on disk.

Reset

Removes all existing windows and measurements.

RestoreCalKitDefaults

Restores the factory defaults for the specified kit.

RestoreCalKitDefaultsAll

Restores the factory defaults for all kits.

Save

Saves all cal kits to disk.

SaveKits

Ends the Network Analyzer application.

SetFailOnOverRange

Causes over range values to return an error code

ShowStatusBar

Shows and Hides the Status Bar.

ShowStimulus

Shows and Hides Stimulus information.

ShowTitleBars

Shows and Hides the Title Bars.

ShowToolbar

Shows and Hides the specified Toolbar.

Properties

Description

ActiveCalKit

Returns a pointer to the kit identified by kitNumber.

ActiveChannel

Returns a handle to the Active Channel object.

ActiveMeasurement

Returns a handle to the Active Measurement object.

ActiveNAWindow

Returns a handle to the Active Window object.

ArrangeWindows

Sets or returns the arrangement of all the windows.

CalKitType

Sets the active cal kit.

Channels (collection)

ExternalALC

Sets or returns the source of the analyzer leveling control.

GPIBMode

Makes the analyzer the system controller or a talker/listener.

IDString

Returns the model, serial number and software revision of the analyzer

Measurements (collection)

MessageText

Returns a message for an eventID

NAWindows (collection)

Options

Returns the options on the analyzer

PortExtension (object)

ScpiStringParser (object)

SourcePowerState

Turns Source Power ON and OFF.

SystemImpedanceZ0

Sets the analyzer impedance value

TriggerSignal

Sets or returns the trigger source.

TriggerType

Sets or returns the scope of a trigger signal.

VelocityFactor

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

Visible

Makes the Network Analyzer application visible or not visible. (Default property of this object)

WindowState

Sets or returns the window setting of Maximized, Minimized, or Normal.

Events

Description

OnCalEvent

Triggered by a calibration event.

OnChannelEvent

Triggered by a channel event.

OnDisplayEvent

Triggered by a display event.

OnHardwareEvent

Triggered by a hardware event.

OnMeasurementEvent

Triggered by a measurement event.

OnSCPIEvent

Triggered by a SCPI event.

OnSystemEvent

Triggered by a system event.

OnUserEvent

For future use


Calibrator Object

Description

The Calibrator object is a child of the channel. It is a vehicle to perform calibration.

There must be a measurement present for the calibrator to use or you will receive an error (no measurement found). Therefore, to perform a 2-port cal, you must have any S-parameter measurement on the channel. For a 1-port measurement, you must have the measurement (S11 or S22) on the channel. And likewise for a response measurement.

With the calibrator object, you can take a number of approaches to calibration.You can collect data yourself and download it to the ACQUISITION buffer. The acquisition buffer holds the actual measured data for each standard.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Trigger a sweep

  4. Retrieve the data for the standard

  5. Download the data - calibrator.putStandard

  6. Repeat for each standard

  7. Calibrator.CalculateErrorCoefficients

You can tell the calibrator to acquire a standard. In this case, the calibrator collects the data and places it in the ACQUISITION buffer.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Calibrator.AcquireCalStandard

  4. Repeat for each standard

  5. Calibrator.CalcuateErrorCoefficients

You can put previously-retrieved error terms in the error correction buffer.

  1. PutErrorTerm

  2. Repeat for each term

  3. Measurement.caltype = pick one

You can also "piece together" a 2-port cal from two 1-port cals (S11 and S22) and four response (thru) cals. The system will detect that all the standards needed for a 2-port cal have been acquired even though they may not have gathered at the same time.

The ICalibrator methods can be used from VEE and VBScript as they use automation safe Variant Data. Use the ICalData interface for typed array passing.

Method

Description

AcquireCalStandard

Cause the analyzer to measure a calibration standard.

CalculateErrorCoeffecients

Generates Error Terms from standard and actual data in the error correction buffer.

DoECAL1Port

Completes a 1 port ECAL

DoECAL2Port

Completes a 2 port ECAL

GetECALModuleInfo

Returns information about the attached module

getErrorTerm

Retrieves error term data for the active calibration.

getStandard

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTerm

Puts error term data into the error-correction buffer for the active calibration.

putStandard

Puts data into the acquisition data buffer (before error-terms are applied)

setCalInfo

Specifies the type of calibration and prepares the internal state for the rest of the calibration.

Property

Description

AcquisitionDirection

Specifies the direction in a 2-Port cal

Simultaneous2PortAcquisition

Allows the use of 2 sets of standards at the same time.


CalKit Object

Description

The calkit object provides the properties and methods to access and modify a calibration kit. The calkitType property can be set from either the application object (app.calKitType) or the calKit object (calKit.calKitType). Both of these commands specify or read the calibration kit type. When specified, the cal kit also becomes the Active cal kit. However, to retrieve a pointer to the cal kit, use app.ActiveCalKit.

The calKit object behaves somewhat differently from other objects in the system in that you can only have a pointer to one cal kit (which is also the active calkit).

Therefore, when you change the calkitType (from either of these objects) you may also be changing the object to which you may have several references. This is different from the behavior for most other objects in the system.

For example, the following code specifies two calKitType and, in turn, assigns the "Active cal kit" to two different variables: ck1 and ck2.

Dim app As AgilentPNA835x.Application
Dim ck1 As calKit
Dim ck2 As calKit

Private Sub Form_Load()
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")
app.CalKitType = naCalKit_85032B_N50
Set ck1 = app.ActiveCalKit

app.CalKitType = naCalKit_85038A_7_16
Set ck2 = app.ActiveCalKit

Print "ck1: " & ck1.Name
Print "ck2: " & ck2.Name
End Sub

When the pointer to each of these kits is read (printed), they each have a pointer to the last kit to be assigned to the Active cal kit:

ck1: 7-16 Model 85038
ck2: 7-16 Model 85038

Method

Description

getCalStandard

Returns a handle to a calibration standard for modifying its definitions.

Property

Description

CalKitType

Sets and returns the cal kit type

Name

Sets and returns the name of the cal kit

PortLabel

Labels the ports for the kit; only affects the cal wizard annotation.

StandardForClass

Maps a standard device to a cal class.


CalStandard Object

Description

Contains all of the settings that are required to modify a calibration kit. Get a handle to a standard with the calkit.GetCalStandard Method.

Method

Description

None

Property

Description

C0

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

C1

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

C2

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

C3

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

Delay

Sets and Returns the electrical delay value for the calibration standard.

L0

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

L1

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

L2

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

L3

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

Label

Sets and Returns the label for the calibration standard.

loss

Sets and Returns the insertion loss for the calibration standard.

Maximum
Frequency

Sets and Returns the maximum frequency for the calibration standard.

Medium

Sets and Returns the media type of the calibration standard.

Minimum
Frequency

Sets and Returns the minumum frequency for the calibration standard.

Type

Sets and Returns the type of calibration standard.

Z0

Sets and Returns the characteristic impedance for the calibration standard.


Channel Object

Description

The channel object is like the engine that produces data. Channel settings consist of stimulus values like frequency, power, IF bandwidth, and number of points.

You can get a handle to a channel in a number of ways. But first you have to make sure that the channel exists. When you first startup the analyzer, there is one S11 measurement on channel 1. Thus there is only one channel in existence. You can do the following:

Dim chan as Channel
'
Set chan = pna.ActiveChannel

or

Set chan = pna.Channels( n )

The first method will return the channel object that is driving the active measurement. When you ask for the ActiveChannel, you get the channel that is driving the active measurement. If there is no measurement, there may not be a channel. Once a channel is created, it does not go away. So if there once was a measurement (hence a channel), the channel will still be available. If there is no channel you can create one in a couple ways. Here's one way:

Pna.CreateMeasurement( ch1, "S11", port1, window2)

Here's another:

Pna.Channels.Add (ch2)

The latter will have no visible effect on the analyzer. It will simply create channel 2 if it does not already exist.

Method

Description

Abort

Aborts the current measurement sweep on the channel.

AveragingRestart

Clears and restarts averaging of the measurement data.

Continuous

The channel continuously responds to trigger signals.

GetXAxisValues

Returns the channel's X-axis values into a dimensioned Variant array.

GetXAxisValues2

Returns the channel's X-axis values into a dimensioned NON-Variant array.

Hold

Puts the Channel in Hold - not sweeping.

Next_IFBandwidth

A function that returns the Next higher IF Bandwidth value.

NumberOfGroups

Sets the Number of trigger signals the channel will receive.

Preset

Resets the channel to factory defined settings.

PreviousIFBandwidth

Returns the previous IF Bandwidth value.

Single

Channel responds to one trigger signal from any source (internal, external, or manual). Then channel switches to Hold.

Property

Description

AlternateSweep

Sets sweeps to either alternate or chopped.

Attenuator

Sets or returns the value of the attenuator control for the specified port number.

AttenuatorMode

Sets or returns the mode of operation of the attenuator control for the specified port number.

Averaging

Turns trace averaging ON or OFF for all measurements on the channel.

AveragingFactor

Specifies the number of measurement sweeps to combine for an average.

Calibrator (object)

centerFrequency

Sets or returns the center frequency of the channel.

channelNumber

Returns the Channel number of the Channel or Measurement object.

CouplePorts

Turns ON and OFF port power coupling.

CWFrequency

Set the Continuous Wave (CW) frequency.

DwellTime

Sets or returns the dwell time for the channel.

FrequencySpan

Sets or returns the frequency span of the channel.

IFBandwidth

Sets or returns the IF Bandwidth of the channel.

NumberOfPoints

Sets or returns the Number of Points of the channel.

Parent

Returns a handle to the parent object of the channel.

PowerSlope

Sets or returns the Power Slope value.

ReceiverAttenuator

Sets or returns the value of the specified receiver attenuator control.

Segments (collection)

StartFrequency

Sets or returns the start frequency of the channel.

StartPower

Sets the start power of the analyzer when sweep type is set to Power Sweep.

StopFrequency

Sets or returns the stop frequency of the channel.

StopPower

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep.

SweepGenerationMode

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

SweepTime

Sets the Sweep time of the analyzer.

SweepType

Sets the type of X-axis sweep that is performed on a channel.

TestPortPower

Sets or returns the RF power level for the channel.

TriggerMode

Determines the measurement that occurs when a trigger signal is sent to the channel.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.


Channels Collection

Description

A collection object that provides a mechanism for iterating through the channels

Collections are, by definition, unordered lists of like objects. You cannot assume that Channels.Item(1) is always Channel 1. For more information, see Collections in the Analyzer.

Methods

Description

Add

An alternate way to create a measurement.

Item

Use to get a handle on a channel in the collection.

Properties

Description

Count

Returns the number of channels in the analyzer.

Parent

Returns a handle to the current Application.


Gating Object

Description

Contains the methods and properties that control Time Domain Gating

Methods

Description

None

Property

Description

Center

Sets or returns the Center time.

Shape

Specifies the shape of the gate filter.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

Stop

Sets or returns the Stop time.

Type

Specifies the type of gate filter used.


About Accessing Data

IArrayTransfer Object

Description

Contains methods for putting data in and getting data out of the analyzer using typed data. This interface transfers data more efficiently than the default IMeasurement Interface.

Method

Description

getComplex

Retrieves real and imaginary data from the specified buffer.

getNAComplex

Retrieves typed NAComplex data from the specified buffer.

getPairedData

Retrieves magnitude and phase data pairs from the specified buffer.

getScalar

Retrieves scalar data from the specified buffer.

putComplex

Puts real and imaginary data into the specified buffer.

putNAComplex

Puts typed NAComplex data into the specified buffer.

putScalar

Puts scalar data into the measurement result buffer.

Property

Description

None


About Accessing Data

ICalData Object

Description

Contains methods for putting Calibration data in and getting Calibration data out of the analyzer using typed data. This interface transfers data more efficiently than variant data.

Method

Description

getErrorTermComplex

Retrieves error term data

getStandardComplex

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTermComplex

Puts error term data

putStandardComplex

Puts calibration data into the aquisition data buffer (before error-terms are applied).

Property

Description

None


Limit Test Collection

Description

Child of the Measurement Object. A collection that provides a mechanism for iterating through the Measurement's LimitSegment objects (Limit Lines). The collection has 100 limit lines by default.

The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2 = Application.Measurement.LimitTest(4)

Methods

Description

GetTestResult

Retrieves the Pass/Fail results of the Limit Test (State).

Item

Use to get a handle on a limit line in the collection.

Properties

Description

Count

Returns the number of limit lines used in the measurement.

LineDisplay

Displays the limit lines on the screen.

SoundOnFail

Enables a beep on Limit Test fails.

State

Turns ON and OFF limit testing.


LimitSegment Object

Description

The LimitSegment object is an individual limit line. The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2=Application.Measurement.LimitTest(4)

Methods

Description

None

Properties

Description

BeginResponse

Specifies the Y-axis value that corresponds with Begin Stimulus (X-axis) value.

BeginStimulus

Specifies the beginning X-axis value of the Limit Line.

EndResponse

Specifies the Y-axis value that corresponds with End Stimulus (X-axis) value.

EndStimulus

Specifies the End X-axis value of the Limit Line.

Type

Specifies the Limit Line type.


Marker Object

Description

Contains the methods and properties that control Markers.

To turn ON a marker, you get a handle to the marker. You get a handle to a marker through the measurement object. (There is no markers collection).

If it is not already, this command will activate marker 1.

Measurement.marker(1).Format = naLinMag

You can also set the marker object to an object variable:

Dim m1 As Marker
Set m1 = meas.marker(1)

There are 10 markers available per measurement:

  • 1 reference marker

  • 9 markers for absolute data or data relative to the reference marker (delta markers).

There are two ways to control markers through COM.

  1. The Measurement object has properties that apply to all of the markers for that measurement.

  2. Marker object properties override the Measurement object properties. For example, meas.MarkerFormat = naLinMag applies formatting to all markers. You can then override that setting for an individual marker by specifying mark.Format = naLogMag on the marker object.

Methods

Description

Activate

Makes an object the Active Object.

SearchMax

Searches the marker domain for the maximum value.

SearchMin

Searches the marker domain for the minimum value.

SearchNextPeak

Searches the marker's domain for the next largest peak value.

SearchPeakLeft

Searches the marker's domain for the next VALID peak to the left of the marker.

SearchPeakRight

Searches the marker's domain for the next VALID peak to the right of the marker.

SearchTarget

Searches the marker's domain for the target value.

SearchTargetLeft

Moving to the left of the marker position, searches the marker's domain for the target value.

SearchTargetRight

Moving to the right of the marker position, searches the marker's domain for the target value.

SetCenter

Changes the analyzer's center frequency to the X-axis position of the marker.

SetCW

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

SetElectricalDelay

Changes the measurement's electrical delay to the marker's delay value.

SetReferenceLevel

Changes the measurement's reference level to the marker's Y-axis value.

SetStart

Changes the analyzer's start frequency to the X-axis position of the marker.

SetStop

Changes the analyzer's stop frequency to the X-axis position of the marker.

Property

Description

Bucket Number

Marker data point number

DeltaMarker

Makes a marker relative to the reference marker

Format

Linear, SWR, and so forth

Interpolated

Turn marker interpolation ON and OFF

Number

Read the number of the active marker

PeakExcursion

Sets and reads the peak excursion value for the specified marker.

PeakThreshold

Sets peak threshold for the specified marker.

SearchFunction

Emulates the Tracking function in the marker search dialog box.

Stimulus

Sets and reads the X-Axis value of the marker.

Target Value

Sets the target value for the marker when doing Target Searches.

Tracking

The tracking function finds the selected search function every sweep.

Type

Sets and reads the marker type.

UserRange

Assigns the marker to the specified User Range.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.

Value

Reads the Y-Axis value of the marker.


Measurement Object

Description

The Measurement object is probably the most used object in the model. A measurement object represents the chain of data processing algorithms that take raw data from the channel and make it ready for display, which then becomes the scope of the Trace object.

A Measurement object is defined by it's parameter (S11, S22, A/R1, B and so forth). The measurement object is associated with a channel in that a channel drives the hardware that produces the data that feeds the measurement. The root of a measurement is the raw data. This buffer of complex paired data then flows through a number of processing blocks: error-correction, trace math, phase correction, time domain, gating, formatting. All of these are controlled through the measurement object.

The active measurement determines what ever else is active. The active measurement is best described as the measurement that will be acted upon if you make a setting from the front panel. It is the measurement whose "button" is pressed in the window with the red "active window" frame. If you create a new measurement, that measurement becomes the active measurement.

Therefore, all automation methods with the word "Active" in them refer to the object associated with the Active measurement, whether that object is a Channel, Window, Trace or Limit line.

You can access two other objects through the Measurement object: markers and limit test. For example, because each measurement has its own set of markers, you can set a marker by doing this:

Dim meas as measurement
Set meas = pna.ActiveMeasurement
Meas.marker(1).Stimulus = 900e6
Meas.LimitTest.State = true ' on

Methods

Description

Activate

Makes an object the Active Object.

ActivateMarker

Makes a marker the Active Marker.

ChangeParameter

Changes the parameter of the measurement.

DataToMemory

Stores the active measurement into memory.

Delete

Deletes the measurement object.

DeleteAllMarkers

Deletes all of the markers from the measurement.

DeleteMarker

Deletes a marker from the active measurement.

GetData

Retrieves Complex data from analyzer memory

GetFilterStatistics

Returns all four Filter Statistics

GetReferenceMarker

Returns a handle to the reference marker.

GetTraceStatistics

Returns the Trace Statistics.

InterpolateMarkers

Turns All Marker Interpolation ON and OFF for the measurement.

putDataComplex

Puts complex data into one of five data buffers.

putDataScalar

Puts formatted variant data into the measurement results buffer.

SearchFilterBandwidth

Searches the domain with the current BW target.

Properties

Description

ActiveMarker

Returns a handle to the Active Marker object.

BandwidthTarget

The insertion loss value at which the bandwidth of a filter is measured.

BandwidthTracking

Turns Bandwidth Tracking function ON and OFF.

CalibrationType

Set or get the calibration type for the measurement.

channelNumber

Returns the channel number of a measurement.

ElectricalDelay

Sets electrical delay.

ErrorCorrection

Set or get the state of error correction for the measurement.

FilterBW

Returns the results of the SearchBandwidth method.

FilterCF

Returns the Center Frequency result of the SearchBandwidth method.

FilterLoss

Returns the Loss value of the SearchBandwidth method.

FilterQ

Returns the Q (quality factor) result of the SearchBandwidth method.

Format

Sets display format.

Gating (object)

InterpolateCorrection

Turns ON and OFF the calculation of new error terms when stimulus values change.

LimitTest (collection)

LimitTestFailed

Returns the results of limit testing

marker (object)

MarkerFormat

Sets or returns the format of all the markers in the measurement.

Mean

Returns the mean value of the measurement.

Name

Sets or returns the name of the measurement.

NAWindow (object)

Number

Returns the number of the measurement.

Parameter

Returns the measurement Parameter.

PeakToPeak

Returns the Peak to Peak value of the measurement.

PhaseOffset

Sets the Phase Offset for the active channel.

ReferenceMarkerState

Turns the reference marker ON or OFF

ShowStatistics

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

Smoothing

Turns ON and OFF data smoothing.

SmoothingAperture

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

StandardDeviation

Returns the standard deviation of the measurement.

StatisticsRange

Sets the User Range number for calculating measurement statistics.

Trace (object)

TraceMath

Performs math operations on the measurement object and the trace stored in memory.

Transform (object)

View

Sets (or returns) the type of trace displayed on the screen.


Measurements Collection

Description

A collection object that provides a mechanism for iterating through the Application measurements. See Collections in the Analyzer.

Methods

Description

Add

Adds a Measurement to the collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a measurement from the measurements collection.

Properties

Description

Count

Returns the number of measurements in the analyzer.

Parent

Returns a handle to the current Application.


NAWindow Object

Description

The NAWindow object controls the part of the display the contains the graticule, or what is written on the display.

Methods

Description

Autoscale

Autoscales all measurements in the window.

ShowMarkerReadout

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window object.

ShowTable

Shows or Hides the specified table for the active measurement in the lower part of the window object.

Property

Description

ActiveTrace

Sets a trace to the Active Trace.

Title

Writes or reads a custom title for the window.

TitleState

Turns ON and OFF the window title.

Traces (collection)

WindowState

Maximizes or minimizes a window.


NAWindows Collection

Description

A collection object that provides a mechanism for iterating through the Application windows. See Collections in the Analyzer.

Methods

Description

Add

Adds a window to the NAWindows collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a window from the NAWindows collection.

Properties

Description

Count

Returns the number of windows on the analyzer.

Parent

Returns a handle to the current Application.


Port Extension Object

Port Extensions Object

Description

Contains the methods and properties that control Port Extensions.

Methods

Description

None

Property

Description

Input A

Sets the Input A extension value.

Input B

Sets the Input B extension value.

Port 1

Sets the Port 1 extension value.

Port 2

Sets the Port 2 extension value.

State

Turns Port Extensions ON and OFF.


SCPIStringParser Object

Method

Description

Parse

Provides the ability to send a SCPI command from within the COM command.

Properties

Description

None


Segment Object

Description

Contains the methods and properties that affect a sweep segment.

You can get a handle to a sweep segment through the segments collection.[ segments.item(n).]

Methods

Description

None

Property

Description

centerFrequency

Sets or returns the center frequency of the segment.

DwellTime

Dwell time value.

FrequencySpan

Sets or returns the frequency span of the segment.

IFBandwidth

Sets or returns the IF Bandwidth of the segment.

NumberOfPoints

Sets or returns the Number of Points of the segment.

SegmentNumber

Returns the number of the current segment.

StartFrequency

Sets or returns the start frequency of the segment.

State

Turns On or OFF a segment.

StopFrequency

Sets or returns the stop frequency of the segment.

TestPortPower

Sets or returns the RF power level of the segment.


Segments Collection

Description

A collection object that provides a mechanism for iterating through the sweep segments of a channel.

Sweep segments are a potentially faster method of sweeping the analyzer through only the frequencies of interest. See Collections in the Analyzer

Methods

Description

Add

Adds an item to either the Segments collection.

Item

Use to get a handle to a segment in the collection..

Remove

Removes an item from a collection of objects.

Properties

Description

Count

Returns the number of items in a collection of objects.

IF Bandwidth Option

Enables the IFBandwidth to be set on individual sweep segments.

Parent

Returns a handle to the current naNetworkAnalyzer application..

Source Power Option

Enables setting the Source Power for a segment.


Trace Object

Description

The Trace object takes measurement data and control how the data is painted on the display. You can control scale, reference position, and reference line from the Trace Object.

Methods

Description

Autoscale

Autoscales the trace or all of the traces in the selected window.

Property

Description

Name

Sets or returns the trace name

ReferencePosition

Sets or returns the Reference Position of the active trace.

ReferenceValue

Sets or returns the value of the Y-axis Reference Level of the active trace.

YScale

Sets or returns the Y-axis Per-Division value of the active trace.


Traces Collection

Description

Child of the Application Object. A collection that provides a mechanism for getting a handle to a trace or iterating through the traces in a window.

Methods

Description

Item

Use to get a handle to a trace

Properties

Description

Count

Returns the number of traces in the collection.

Parent

Returns a handle to the current Application.


Transform Object

Description

Contains the methods and properties that control Time Domain transforms.

Methods

Description

SetFrequencyLowPass

Sets low frequencies for low pass.

Property

Description

Center

Sets or returns the Center time.

ImpulseWidth

Sets or returns the Impulse Width of Time Domain transform windows.

KaiserBeta

Sets or returns the Kaiser Beta of Time Domain transform windows.

Mode

Sets the type of transform.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

StepRiseTime

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

Stop

Sets or returns the Stop time.


About Performing a Calibration

AcquisitionDirection Property

Read / Write

Description

Specifies the direction of each part of a 2-port calibration.

VB Syntax

cal.AcquisitionDirection = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(enum NADirection) - Choose from:

0 - naForward - measures the forward direction
1 - naReverse - measures the reverse direction

Return Type

Long Integer

Default

naForward

Examples

cal.AcquisitionDirection = naForward

C++ Syntax

HRESULT AcquisitionDirection(tagNADirection dir)

Interface

ICalibrator


Active Cal Kit Property

About Calibration Kits

ActiveCalKit Property

Read-only

Description

Returns a handle to the Active CalKit object. You can either (1) use the handle directly to access CalKit properties and methods, or (2) set a variable to the CalKit object. The variable retains a handle to the original object if another CalKit becomes active.

VB Syntax

1) app.ActiveCalKit.<setting>
or
2) Set cKit = app.ActiveCalKit

Variable

(Type) - Description

app

(object) - An Application object

<setting>

A CalKit property (or method) and arguments

cKit

(object) - A CalKit object

Return Type

CalKit object

Default

None

Examples

Public cKit as calKit
Set cKit = app.ActiveCalKit 'read

C++ Syntax

HRESULT get_ActiveCalKit (ICalkit * kit)

Interface

IApplication


Active Channel Property

About Channels

ActiveChannel Property

Read-only

Description

Returns a handle to the Active Channel object. You can either (1) use the handle directly to access channel properties and methods, or (2) set a variable to the channel object. The variable retains a handle to the original channel if another channel becomes active.

VB Syntax

(1) app.ActiveChannel.<setting>
or
(2) Set chan = app.ActiveChannel

Variable

(Type) - Description

chan

A Channel (object)

app

An Application (object)

<setting>

A channel property (or method) and arguments

Return Type

Channel object

Default

Not applicable

Examples

1) app.ActiveChannel.Averaging = 1
2) Public chan as Channel
Set chan = app.ActiveChannel

C++ Syntax

HRESULT get_ActiveChannel( IChannel* *pVal)

Interface

IApplication


About Markers

ActiveMarker Property

Read-only

Description

Returns a handle to the Active Marker object. You can either (1) use the handle directly to access Marker properties and methods, or (2) set a variable to the Marker object. The variable retains a handle to the original object if another Marker becomes active.

VB Syntax

1) meas.ActiveMarker.<setting>
or
2) Set mark = meas.ActiveMarker

Variable

(Type) - Description

meas

(object) - An Measurement object

<setting>

A marker property (or method) and arguments

mark

(object) - A marker object

Return Type

marker object

Default

None

Examples

Public mark as marker
Set mark = meas.ActiveMarker

C++ Syntax

HRESULT get_ActiveMarker(IMarker** marker)

Interface

IMeasurement


Active Measurement Property

About Measurement Parameters

ActiveMeasurement Property

Read-only

Description

Returns a handle to the Active Measurement object. You can either (1) use the handle directly to access measurement properties and methods, or (2) set a variable to the measurement object. The variable retains a handle to the original measurement.

VB Syntax

1) app.Active Measurement.<setting>
or
2) Set meas = app.Active Measurement

Variable

(Type) - Description

meas

A Measurement (object)

app

An Application (object)

<setting>

A measurement property (or method) and arguments

Return Type

Measurement object

Default

None

Examples

1) app.ActiveMeasurement.Averaging = 1
2) Public meas as Measurement
Set meas = app.ActiveMeasurement

C++ Syntax

HRESULT get_ActiveMeasurement(IMeasurement **ppMeas)

Interface

IApplication


About Windows

ActiveNAWindow Property

Read-only

Description

Returns a handle to the Active Window object. You can either (1) use the handle directly to access window properties and methods, or (2) set a variable to the window object. The variable retains a handle to the original window if another window becomes active.

VB Syntax

1) app.ActiveNAWindow.<setting>
or
2) Set win = app.ActiveNAWindow

Variable

(Type) - Description

win

A NAWindow (object)

app

An Application (object)

<setting>

A NAWindow property (or method) and arguments

Return Type

A NAWindow object

Default

Not applicable

Examples

Public win as NAWindow
Set win = app.ActiveWindow

C++ Syntax

HRESULT get_ActiveNAWindow(INAWindow **ppWindow)

Interface

IApplication


Active Trace Property

About Traces

ActiveTrace Property

Read-only

Description

Returns a handle to the Active Trace object. You can either (1) use the handle directly to access trace properties and methods, or (2) set a variable to the trace object. The variable retains a handle to the original trace if another trace becomes active.

VB Syntax

1) win.ActiveTrace.<setting>
or
2) Set trce = win.ActiveTrace

Variable

(Type) - Description

trce

A Trace (object)

win

An NAWindow (object)

<setting>

A trace property (or method) and arguments

Return Type

An NAWindow object

Default

None

Examples

1) win.ActiveTrace.Autoscale
2) Public trce as Trace
Set trce = Application.ActiveNAWindow.ActiveTrace

C++ Syntax

HRESULT get_ActiveTrace(ITrace* *pVal)

Interface

INAWindow


Alternate Sweep Property

About Sweeping

AlternateSweep Property

Write/Read

Description

Sets sweeps to either alternate or chopped.

VB Syntax

chan.AlternateSweep = value

Variable

(Type) - Description

chan

A Channel (object)

value

(boolean) - Choose either:

False (0) - Sweep mode set to Chopped - reflection and transmission are measured on the same sweep.
True (1) - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases cycle time.

Return Type

boolean

Default

False (0)

Examples

chan.AlternateSweep = True 'Write

altSwp = chan.AlternateSweep 'Read

C++ Syntax

HRESULT AlternateSweep(VARIANT_BOOL *pVal)
HRESULT AlternateSweep(VARIANT_BOOL newVal)

Interface

IChannel


Application Property

Read-only

Description

Returns the name of the Analyzer making measurements on the channel.

VB Syntax

chan.Application

Variable

(Type) - Description

chan

A Channel (object)

Return Type

object

Default

None

Examples

rfna = chan.Application 'returns the Analyzer name

C++ Syntax

HRESULT get_Application(IApplication** Application)

Interface

IChannel


Arrange Windows Property

About Arrange Windows

ArrangeWindows Property

Write/Read

Description

Sets or returns the arrangement of all the windows. Overlay, Stack2, Split3 and Quad4 will create windows.

To control the state of the one window you have a handle to, use app.WindowState.

VB Syntax

app.ArrangeWindows = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAWindowModes) - Choose from:

0 - naTile
1 - naCascade
2 - naOverlay
3 - naStack2
4 - naSplit3
5 - naQuad4

Return Type

NAWindowModes

Default

naTile

Examples

app.ArrangeWindow = naTile 'Write

arrWin = app.ArrangeWindows 'Read

C++ Syntax

HRESULT put_ArrangeWindows(tagNAWindowModes newVal)

Interface

IApplication


Attenuator Mode Property

About Attenuation

AttenuatorMode Property

Write/Read

Description

Sets or returns the mode of operation of the attenuator control for the specified port number. This command is automatically set to Manual when an Attenuator value is set.

VB Syntax

chan.AttenuatorMode(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long) - Port number (1 or 2) of attenuator control to be changed.

value

(enum NAModes) - Choose from:

0 - naAuto - Attenuator control set to automatic. The analyzer will set the attenuator control appropriately to deliver the specified power at the source.

1 - naManual - Specify the attenuator setting using chan.Attenuator (which automatically sets AttenuatorMode = naManual.

Return Type

NAModes

Default

0 - Auto

Examples

chan.Attenuator(1) = naAuto 'Write

attn = chan.AttenuatorMode(1) 'Read

C++ Syntax

HRESULT get_AttenuatorMode(long port, tagNAModes* pVal)
HRESULT put_AttenuatorMode(long port, tagNAModes newVal)

Interface

IChannel


About Attenuation

Attenuator Property

Write/Read

Description

Sets or returns the value of the attenuator control for the specified port number. Sending this command automatically sets AttenuatorMode to Manual.

VB Syntax

chan.Attenuator(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long integer) - Port number (1 or 2) of attenuator control to be changed.

value

(double) - Attenuator value in dB in 10dB steps. Choose any Long Integer between 0 and 70

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 10 dB attenuation.

Return Type

Double

Default

20 dB

Examples

chan.Attenuator(1) = 20 'Write

attn = chan.Attenuator(cnum) 'Read

C++ Syntax

HRESULT get_Attenuator(long port, double *pVal)
HRESULT put_Attenuator(long port, double newVal)

Interface

IChannel


Averaging Factor Property

About Averaging

AveragingFactor Property

Write/Read

Description

Specifies the number of measurement sweeps to combine for an average. Must also turn averaging ON by setting chan.Averaging = 1. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.AveragingFactor = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Long Integer) - Number of measurement sweeps to average. Choose any number between 1 and 1024.

Return Type

Long Integer

Default

1

Examples

chan.AveragingFactor = 5 'Write

avgfact = chan.AveragingFactor ' doesn't work -Read

C++ Syntax

HRESULT get_AveragingFactor(long *pVal)
HRESULT put_AveragingFactor(long newVal)

Interface

IChannel


About Averaging

Averaging Property

Write/Read

Description

Turns trace averaging ON or OFF for all measurements on the channel. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.Averaging = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns averaging OFF
1 - Turns averaging ON

Return Type

Boolean

Default

0

Examples

chan.Average = 1 'Write

averg = chan.Averaging 'Read

C++ Syntax

HRESULT get_Averaging(BOOL *pVal)
HRESULT put_Averaging(BOOL newVal)

Interface

IChannel


Bandwidth Target Property

About Marker Search

BandwidthTarget Property

Write/Read

Description

Sets the insertion loss value at which the bandwidth of a filter is measured (using BandwidthTracking or SearchFilterBandwidth). For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set BandwidthTarget to -3.

VB Syntax

meas.BandwidthTarget = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(single) - Target value. Choose any number between -500 and 500

Return Type

Single

Default

-3

Examples

meas.BandwidthTarget = -3 'Write

fbw = meas.BandwidthTarget 'Read

C++ Syntax

HRESULT put_BandwidthTarget(float target)
HRESULT get_BandwidthTarget(float* target)

Interface

IMeasurement


Bandwidth Tracking Property

About Marker Search

BandwidthTracking Property

Write/Read

Description

Searches continually (every sweep) for the current BandwidthTarget (default is -3). To search the filter bandwidth for ONE SWEEP only (not continually), use meas.SearchFilterBandwidth.

This feature uses markers 1-4. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To restrict the search to a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.BandwidthTracking = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
1 - Turns bandwidth tracking ON
0 - Turns bandwidth tracking OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.BandwidthTracking = 1 'Write

bwtrack = meas.BandwidthTracking 'Read

C++ Syntax

HRESULT put_BandwidthTracking(VARIANT_BOOL state)
HRESULT get_BandwidthTracking(VARIANT_BOOL* state)

Interface

IMeasurement


Calibration Type (applied) Property

About Performing a Calibration

CalibrationType Property

Write/Read

Description

Specifies the type of calibration to perform or apply to the measurement.

VB Syntax

meas.CalibrationType = type

Variable

(Type) - Description

meas

A Measurement (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Return Type

NACalType

Default

naCalType_None

Examples

meas.CalibrationType = naCalType_Response_Open 'Write

meascal = meas.CalibrationType 'Read

C++ Syntax

HRESULT put_CalibrationType (tagNACalType CalType)
HRESULT get_CalibrationType (tagNACalType* pCalType)

Interface

IMeasurement


About Gating

Center Property

Write/Read

Description

Sets or returns the Center time of either Gating or Time Domain transform windows

VB Syntax

object.Center = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Center time in seconds. Choose any number between:
± (points-1) / frequency span

Return Type

Double

Default

0

Examples

trans.Center = 4.5e-9 'sets the Center time of a transform window -Write
gate.Center = 4.5e-9 'sets the Center time of a gating window -Write

cnt = trans.Center 'Read

C++ Syntax

HRESULT get_Center(double *pVal)
HRESULT put_Center(double newVal)

Interface

ITransform
IGating


CenterFreq Property

About Frequency

CenterFrequency Property

Write/Read

Description

Sets or returns the center frequency of the channel
or
Sets or returns the center frequency of the segment.

VB Syntax

object.centerFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Center frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Center of the frequency range

Examples

chan.centerFrequency = 4.5e9 'sets the center frequency of a linear sweep for the channel object -Write

centfreq = chan.centerFrequency 'Read

C++ Syntax

HRESULT get_CenterFrequency(double *pVal)
HRESULT put_CenterFrequency(double newVal)

Interface

IChannel
ISegment


Channel Number Property

About Channels

ChannelNumber Property

Read-only

Description

Returns the Channel number of the Channel or Measurement object.

VB Syntax

object.ChannelNumber

Variable

(Type) - Description

object

A Channel (object)
or
A Measurement (object)

Return Type

Long Integer

Default

Not applicable

Examples

chanNum = chan.ChannelNumber 'returns the channel number
chanNum = meas.ChannelNumber 'returns the channel number of the measurement

C++ Syntax

HRESULT get_ChannelNumber(long *pVal)

Interface

IChannel
IMeasurement


About Modifying Cal Kits

C0 Property

Write/Read

Description

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

To set the other inductance values, use C1, C2, C3

VB Syntax

calstd.C0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C0 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C0 = 15 'Write the value of C0 to 15picofarads

cap0 = calstd.C0 'Read the value of C0

C++ Syntax

HRESULT get_C0(float *pVal)
HRESULT put_C0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C1 Property

Write/Read

Description

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

To set the other inductance values, use C0, C2, C3

VB Syntax

calstd.C1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C1 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C1 = 15 'Write the value of C1 to 15picofarads

cap1 = calstd.C1 'Read the value of C1

C++ Syntax

HRESULT get_C1(float *pVal)
HRESULT put_C1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C2 Property

Write/Read

Description

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C3

VB Syntax

calstd.C2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C2 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C2 = 15 'Write the value of C2 to 15picofarads

cap2 = calstd.C2 'Read the value of C2

C++ Syntax

HRESULT get_C2(float *pVal)
HRESULT put_C2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C3 Property

Write/Read

Description

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C2

VB Syntax

calstd.C3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C3 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C3 = 15 'Write the value of C3 to 15picofarads

cap3 = calstd.C3 'Read the value of C3

C++ Syntax

HRESULT get_C3(float *pVal)
HRESULT put_C3(float newVal)

Interface

ICalStandard


Count Property

Read-only

Description

Returns the number of items in a collection of objects.

VB Syntax

object.Count

Variable

(Type) - Description

object

Any of the following (objects):

Channels collection
LimitTest collection
Measurements collection
NAWindows collection
Traces collection
Segments collection

Return Type

Long Integer

Default

Not applicable

Examples

numofchans = chans.Count 'return the number of channels -Read

C++ Syntax

HRESULT get_Count(long *p<interface>)

Interface

IChannels
ILimitTest
IMeasurements
NAWindows
ITraces
ISegments


Couple Ports Property

About Power Coupling

CouplePorts Property

Write/Read

Description

Turns ON and OFF port power coupling. ON means the power level is the same for both ports. OFF means the power level may be set independently for each port.

VB Syntax

chan.CouplePorts = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NAStates) Choose from:
NaOff - Turns coupling OFF
NaOn - Turns coupling ON

Return Type

Long Integer
1 - ON
0 - OFF

Default

NaON (1)

Examples

chan.CouplePorts = NaOff 'Write

couplport = chan.CouplePorts 'Read

C++ Syntax

HRESULT get_CouplePorts(tagNAStates *pState)
HRESULT put_CouplePorts(tagNAStates newState)

Interface

IChannel


About CW Frequency

CW Frequency Property

Write/Read

Description

Set the Continuous Wave (CW) frequency. Must first send chan.SweepType = naCWTimeSweep

VB Syntax

chan.CWFrequency = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) CW frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer
Units are Hz

Return Type

Double

Default

1e9

Examples

chan.CWFrequency = 5e9 'Write

cwfreq = chan.CWFrequency 'Read

C++ Syntax

HRESULT put_CWFrequency(double newVal)
HRESULT get_CWFrequency(double *pVal)

Interface

IChannel


About Modifying Cal Kits

Delay Property

Write/Read

Description

Sets and Returns the electrical delay value for the calibration standard.

VB Syntax

calstd.Delay = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Electrical delay in seconds

Return Type

Single

Default

Not Applicable

Examples

calstd.Delay = .00015 'Write the Delay .00015 seconds

stdDelay = calstd.Delay 'Read the value of Delay

C++ Syntax

HRESULT get_Delay(float *pVal)
HRESULT put_Delay(float newVal)

Interface

ICalStandard


About Data Format

Format Property

Write/Read

Description

Sets or returns the display format of the measurement.

VB Syntax

meas.Format = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NADataFormat) - Choose from:

0 - naDataFormat_LinMag
1 - naDataFormat_LogMag
2 - naDataFormat_Phase
3 - naDataFormat_Polar
4 - naDataFormat_Smith
5 - naDataFormat_Delay
6 - naDataFormat_Double
7 - naDataFormat_Imaginary
8 - naDataFormat_SWR

Return Type

Long Integer

Default

1 - naDataFormat_LogMag

Examples

app.TriggerMode = naTriggerModePoint 'Write

fmt = meas.Format 'Read

C++ Syntax

HRESULT get_Format(tagDataFormat *pVal)
HRESULT put_Format(tagDataFormat newVal)

Interface

IMeasurement


Dwell Time Property

About Dwell Time

DwellTime Property

Write/Read

Description

Sets or returns the dwell time at the start of each sweep point for all measurements in a channel. Dwell time is only available with Chan.SweepGenerationMode = naSteppedSweep (not naAnalogSweep).

Sets or returns the dwell time of a specified sweep segment.

VB Syntax

object.DwellTime = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - Dwell Time in seconds. Choose any number between:
0 and 100e-3

Return Type

Double

Default

0

Examples

chan.DwellTime = 3e-3 'sets the dwell time for the channel -Write

segs(3).CenterFrequency = 1e9 'sets the dwell time of segment 3 -Write

dwell = chan.DwellTime 'Read

C++ Syntax

HRESULT get_DwellTime(double *pVal)
HRESULT put_DwellTime(double newVal)

Interface

IChannel
ISegment


Electrical Delay Property

About Electrical Delay

ElectricalDelay Property

Write/Read

Description

Sets the Electrical Delay for the active channel.

VB Syntax

meas.ElectricalDelay = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Electrical Delay in seconds. Choose any number between -9.99 and 9.99

Return Type

Double

Default

0

Examples

meas.ElectricalDelay = 1e-3 'Write

edelay = meas.ElectricalDelay 'Read

C++ Syntax

HRESULT get_ElectricalDelay(double *pVal)
HRESULT put_ElectricalDelay(double newVal)

Interface

IMeasurement


Error Correction Property

About Performing a Calibration

ErrorCorrection Property

Write/Read

Description

Sets (or returns) error correction ON or OFF for the measurement.

VB Syntax

meas.ErrorCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
0 - Turns error correction OFF
1 - Turns error correction ON

Return Type

Boolean

Default

Not Applicable

Examples

meas.ErrorCorrection = 1 'Write

errcorr = meas.ErrorCorrection 'Read

C++ Syntax

HRESULT put_ErrorCorrection (VARIANT_BOOL bState)
HRESULT get_ErrorCorrection (VARIANT_BOOL *bState)

Interface

IMeasurement


External ALC Property

ExternalALC Property

Write/Read

Description

Sets or returns the source of the analyzer leveling control.

VB Syntax

app.ExternalALC = value

Variable

(Type) - Description

app

An Application (object)

value

(boolean) - Choose from:
True (or 1) - Leveling control supplied through the rear panel.
False (or 0) - Leveling control supplied inside the analyzer

Return Type

Boolean

Default

0

Examples

app.ExternalALC = True 'Write

extALC = app.ExternalALC 'Read

C++ Syntax

HRESULT get_ExternalALC(VARIANT_BOOL *pVal)
HRESULT put_ExternalALC(VARIANT_BOOL newVal)

Interface

IApplication


Filter BW Property

About Marker Search

FilterBW Property

Read-only

Description

Returns the results of the SearchBandwidth method.

VB Syntax

filtBW = meas.FilterBW

Variable

(Type) - Description

filtBW

(single) - Variable to store bandwidth data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterBW = meas.FilterBW 'Read

C++ Syntax

HRESULT get_FilterBW(float* bw)

Interface

IMeasurement


Filter CF Property

About Marker Search

FilterCF Property

Read-only

Description

Returns the Center Frequency result of the SearchBandwidth method.

VB Syntax

filtCF = meas.FilterCF

Variable

(Type) - Description

filtCF

(double) - Variable to store bandwidth CF data

meas

A Measurement (object)

Return Type

Double

Default

Not applicable

Examples

filtCF = meas.FilterCF 'Read

C++ Syntax

HRESULT get_FilterCF(double* centerFrequency)

Interface

IMeasurement


Filter Loss Property

About Marker Search

FilterLoss Property

Read-only

Description

Returns the Loss value of the SearchBandwidth method.

VB Syntax

filtLoss = meas.FilterLoss

Variable

(Type) - Description

filtLoss

(single) - Variable to store bandwidth Loss data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterLoss = meas.FilterLoss 'Read

C++ Syntax

HRESULT get_FilterLoss(float* loss)

Interface

IMeasurement


Filter Q Property

About Marker Search

FilterQ Property

Read-only

Description

Returns the Q (quality factor) result of the SearchBandwidth method.

VB Syntax

filtQ = meas.FilterQ

Variable

(Type) - Description

filtQ

(single) - Variable to store bandwidth Q data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filtQ = meas.FilterQ 'Read

C++ Syntax

HRESULT get_FilterQ(float* quality)

Interface

IMeasurement


Frequency Span Property

About Frequency Range

FrequencySpan Property

Write/Read

Description

Sets or returns the frequency span of the channel.

Sets or returns the frequency span of the segment.

VB Syntax

object.FrequencySpan = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Frequency span in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Full frequency span of the analyzer

Examples

chan.FrequencySpan = 4.5e9 'sets the frequency span of a linear sweep for the channel object -Write

freqspan = chan.FrequencySpan 'Read

C++ Syntax

HRESULT get_FrequencySpan(double *pVal)
HRESULT put_FrequencySpan(double newVal)

Interface

IChannel
ISegment


About Gate Filter

Shape Property

Write/Read

Description

Specifies the shape of the gate filter.

VB Syntax

gat.Shape = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateShape) - Choose from:

0 - naGateShapeMaximum
1 - naGateShapeWide
2 - naGateShapeNormal
3 - naGateShapeMinimum

Return Type

NAGateShape

Default

2 - Normal

Examples

gat.Shape = naGateShapeMaximum 'Write

filterShape = gat.Shape 'Read

C++ Syntax

HRESULT get_Shape(tagNAGateShape *pVal)
HRESULT put_Shape(tagNAGateShape newVal)

Interface

IGating


Type (Gate) Property

About Time Domain

Type Property

Write/Read

Description

Specifies the type of gate filter used.

VB Syntax

gat.Type = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateType) - Choose from:
naGateTypeBandpass - Includes (passes) the range between the start and stop times.
naGateTypeNotch - Excludes (attenuates) the range between the start and stop times.

Return Type

NAGateType

Default

Bandpass

Examples

gate.Type = naGateTypeNotch 'Write

filterType = gate.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAGateType *pVal)
HRESULT put_Type(tagNAGateType newVal)

Interface

IGating


About GPIB Fundamentals

GPIBMode Property

Write/Read

Description

Changes the analyzer to a GPIB system controller or a talker/listener on the bus. The analyzer must be the controller if you want to use it to send commands to other instruments. The analyzer must be a talker/listener if you want to send it commands from another PC.

VB Syntax

app.GPIBMode value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAGPIBMode) -Choose either:
0 - naTalkerListener - the analyzer is a talker / listener
1 - naSystemController - the analyzer is the system controller

Return Type

Long Integer

Default

0 - naTalkerListener

Examples

app.GPIBMode = naTalkerListener 'Write

mode = app.GPIBMode 'Read

C++ Syntax

HRESULT get_ScpiMode(tagScpiModeEnum* eScpiMode)
HRESULT put_ScpiMode(tagScpiModeEnum eScpiMode)

Interface

IApplication


IDString Property

Read-only

Description

Returns the ID of the analyzer, including the Model number, Serial Number, and the Software revision number.

VB Syntax

value = app.IDString

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned ID string

Return Type

String

Default

Not Applicable

Examples

id = app.IDString

C++ Syntax

HRESULT IDString(BSTR* IDString)

Interface

IApplication


IF Bandwidth Option Property

About Segment Sweep

IFBandwidthOption Property

Write/Read

Description

Enables the IFBandwidth to be set on individual sweep segments. This property must be set True before seg.IFBandwidth = value is sent. Otherwise, this command will be ignored.

VB Syntax

segs.IFBandwidthOption = value

Variable

(Type) - Description

segs

A Segments collection (object)

value

(boolean)
True - Enables variable IFBandwidth setting for segment sweep
False - Disables variable IFBandwidth setting for segment sweep

Return Type

Boolean

Default

False

Examples

segs.IFBandwidthOption = True 'Write

IFOption = IFBandwidthOption 'Read

C++ Syntax

HRESULT get_IFBandwidthOption(VARIANT_BOOL *pVal)
HRESULT put_IFBandwidthOption(VARIANT_BOOL newVal)

Interface

ISegments


IF Bandwidth Property

About IF Bandwidth

IFBandwidth Property

Write/Read

Description

Sets or returns the IF Bandwidth of the channel.
Sets or returns the IF Bandwidth of the segment.

VB Syntax

object.IFBandwidth = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - IF Bandwidth in Hz. Choose from:

1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1000 | 1500 | 2000 | 3000 | 5000 | 7000 | 10000 | 15000 | 20000 | 30000 | 35000 | 40000 |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Return Type

Double

Default

3500

Examples

chan.IFBandwidth = 3e3 'sets the IF Bandwidth of for the channel object to 3 kHz. -Write
seg.IFBandwidth = 5 'sets the IF Bandwidth of the segment to 5 Hz. -Write

ifbw = chan.IFBandwidth -Read

C++ Syntax

HRESULT get_IFBandwidth(double *pVal)
HRESULT put_IFBandwidth(double newVal)

Interface

IChannel
ISegment


Impulse Width Property

About Time Domain

ImpulseWidth Property

Write/Read

Description

Sets or returns the Impulse Width of Time Domain transform windows

VB Syntax

trans.ImpulseWidth = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Impulse Width in seconds. Range of settings depends on the frequency range of your analyzer.

Return Type

Double

Default

.98 / Default Span

Examples

trans.ImpulseWidth = 200e-12 'sets the Impulse width of a transform window -Write

IW = trans.ImpulseWidth 'Read

C++ Syntax

HRESULT get_ImpulseWidth(double *pVal)
HRESULT put_ImpulseWidth(double newVal)

Interface

ITransform


Input A Property

About Port Extensions

InputA Property

Write/Read

Description

Sets a Port Extension value for Receiver A

VB Syntax

portExt.InputA = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputA = 10e-6 'Write

inA = portExt.InputA 'Read

C++ Syntax

HRESULT get_InputA(double *pVal)
HRESULT put_InputA(double newVal)

Interface

IPortExtension


Input B Property

About Port Extensions

InputB Property

Write/Read

Description

Sets the Port Extension value for Receiver B

VB Syntax

portExt.InputB = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputB = 10e-6 'Write

inB = portExt.InputB 'Read

C++ Syntax

HRESULT get_InputB(double *pVal)
HRESULT put_InputB(double newVal)

Interface

IPortExtension


About Interpolation

Interpolate Correction Property

Write/Read

Description

Turns ON and OFF correction interpolation which calculates new error terms when stimulus values change after calibration.

When this property is ON and error correction is being applied, the calibration subsystem attempts to interpolate the error terms whenever the stimulus parameters are changed.

When this property is OFF under the same circumstances, error correction is turned OFF.

VB Syntax

meas.InterpolateCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Choose from:

True - Turns correction interpolation ON
False - Turns correction interpolation OFF

Return Type

Boolean

Default

True

Examples

meas.InterpolateCorrection = False

calInterpolate = InterpolateCorrection 'Read

C++ Syntax

HRESULT get_InterpolateCorrection(boolean *pVal)
HRESULT put_InterpolateCorrection(boolean newVal)

Interface

IMeasurement


Kaiser Beta Property

About Time Domain

KaiserBeta Property

Write/Read

Description

Sets or returns the Kaiser Beta of Time Domain transform windows

VB Syntax

trans.KaiserBeta = value

Variable

(Type) - Description

trans

A Transform (object)

value

(single) - Kaiser Beta. Choose any number between 0 and 13.

Return Type

Single

Default

0

Examples

trans.KaiserBeta = 6 'sets the Kaiser Beta of a transform window -Write

KB = trans.KaiserBeta 'Read

C++ Syntax

HRESULT get_KaiserBeta(float *pVal)
HRESULT put_KaiserBeta(float newVal)

Interface

ITransform


About Modifying Cal Kits

L0 Property

Write/Read

Description

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

To set the other inductance values, use L1, L2, L3

VB Syntax

calstd.L0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L0 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L0 = 15 'Write the value of L0 = 15picohenries

Induct0 = calstd.L0 'Read the value of L0

C++ Syntax

HRESULT get_L0(float *pVal)
HRESULT put_L0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L1 Property

Write/Read

Description

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

To set the other inductance values, use L0, L2, L3

VB Syntax

calstd.L1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L1 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L1 = 15 'Write the value of L1 = 15picohenries

Induct1 = calstd.L1 'Read the value of L1

C++ Syntax

HRESULT get_L1(float *pVal)
HRESULT put_L1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L2 Property

Write/Read

Description

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L3

VB Syntax

calstd.L2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L2 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L2 = 15 'Write the value of L2 to 15picohenries

Induct2 = calstd.L2 'Read the value of L2

C++ Syntax

HRESULT get_L2(float *pVal)
HRESULT put_L2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L3 Property

Write/Read

Description

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L2

VB Syntax

calstd.L3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L3 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L3 = 15 'Write the value of L3 to 15picohenries

Induct3 = calstd.L3 'Read the value of L3

C++ Syntax

HRESULT get_L3(float *pVal)
HRESULT put_L3(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

Label Property

Write/Read

Description

Sets and Returns the label for the calibration standard. The label is used to prompt the user to connect the specified standard.

VB Syntax

calstd.Label = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(string) - between 1 and 12 characters long. Cannot begin with a numeric.

Return Type

String

Default

Not Applicable

Examples

calstd.Label = "Short" 'Write

stdLabel = calstd.Label 'Read

C++ Syntax

HRESULT get_Label(BSTR *pVal)
HRESULT put_Label(BSTR newVal)

Interface

ICalStandard


Begin Stimulus Property

About Sweeps

BeginStimulus Property

Write/Read

Description

When constructing a limit line, specifies the beginning X-axis value.

VB Syntax

limtseg.BeginStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Stimulus value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.Type = naLimitSegmentType_Maximum
limtseg.BeginStimulus = 3e9
limtseg.EndStimulus = 4e9
limtseg.BeginResponse = 10
limtseg.EndResponse = 10

BegStim = limtseg.BeginStimulus 'Read

C++ Syntax

HRESULT get_BeginStimulus(double *pVal)
HRESULT put_BeginStimulus(double newVal)

Interface

ILimitSegment


End Stimulus Value

About Limits

EndStimulus Property

Write/Read

Description

When constructing a limit line, specifies the stimulus value for the end of the segment.

VB Syntax

limtseg.EndStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - End Stimulus X-axis value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndStimulus = 8e9 'Write

EndStim = limtseg.EndStimulus 'Read

C++ Syntax

HRESULT get_EndStimulus(double *pVal)
HRESULT put_EndStimulus(double newVal)

Interface

ILimitSegment


Begin Response Property

About Sweeps

BeginResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value of the start of a limit segment.

VB Syntax

limtseg.BeginResponse = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Amplitude value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.BeginResponse = 10 'Write

BegResp = limtseg.BeginResponse 'Read

C++ Syntax

HRESULT get_BeginResponse(double *pVal)
HRESULT put_BeginResponse(double newVal)

Interface

ILimitSegment


End Response Property

About Limits

EndResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value at the end of the limit segment.

VB Syntax

limtseg.EndResponse = value

Variable

(Type) - Description

limts

A LimitSegment (object)

value

(double) - Y-axis value of the End Response limit. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndResponse = 10 'Write

EndResp = limtseg.EndResponse 'Read

C++ Syntax

HRESULT get_EndResponse(double *pVal)
HRESULT put_EndResponse(double newVal)

Interface

ILimitSegment


About Limits

Type (limit) Property

Write/Read

Description

Specifies the Limit Line type.

VB Syntax

limt(index).Type = value

Variable

(Type) - Description

limt

A LimitSegment (object)

index

(variant) - Limit line number in the LimitTest collection

value

(enum NALimitSegmentType) - Limit Line type. Choose from:
naLimitSegmentType_Maximum - limit line fails with a data point ABOVE the line
naLimitSegmentType_Minimum - limit line fails with a data point BELOW the line
naLimitSegmentType_OFF - turns limit line OFF

Return Type

Long Integer

Default

0 - OFF

Examples

Set limts = meas.LimitTest
limts.Type = naLimitSegmentType_Maximum 'Write

limitType = limts.Type 'Read

C++ Syntax

HRESULT put_Type(tagNALimitSegmentType *pVal)
HRESULT get_Type(tagNALimitSegmentType newVal)

Interface

ILimitSegment


About Limits

LineDisplay Property

Write/Read

Description

Turns the display of limit lines ON or OFF. To turn limit TESTING On and OFF, use State Property.

Note: Trace data must be ON to view limit lines

VB Syntax

limitst.LineDisplay = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the display of limit lines OFF
1 - Turns the display of limit lines ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.LineDisplay = 1 'Write

lineDsp = Limttest.LineDisplay 'Read

C++ Syntax

HRESULT get_LineDisplay(VARIANT_BOOL *pVal)
HRESULT put_LineDisplay(VARIANT_BOOL newVal)

Interface

ILimitTest


About Modifying Cal Kits

Loss Property

Write/Read

Description

Sets and Returns the insertion loss for the calibration standard.

VB Syntax

calstd.loss = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)

Return Type

Single

Default

Not Applicable

Examples

calstd.loss = 3.5e9 'Write

stdLoss = calstd.loss 'Read the value of Loss

C++ Syntax

HRESULT get_Loss(float *pVal)
HRESULT put_Loss(float newVal)

Interface

ICalStandard


Bucket Number Property

About Markers

BucketNumber Property

Write/Read

Description

Sets or returns the bucket number (data point) for the active marker.

VB Syntax

mark.BucketNumber = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Data point. Choose any number between 0 and the measurement's number of data points - 1.

For example, with Number of points = 201, choose between 0 and 200

Return Type

Long Integer

Default

The first marker is set to the middle of the span. Subsequent markers are set to the bucket number of the previously active marker.

Examples

mark.BucketNumber = 100 'moves the active marker to data point 100 -Write

pointNumber = mark.BucketNumber 'returns the data point number the active marker is currently on. -Read

C++ Syntax

HRESULT get_BucketNumber(long *pVal)
HRESULT put_BucketNumber(long newVal)

Interface

IMarker


Marker Format Property

About Marker Format

MarkerFormat Property

Write/Read

Description

Sets (or returns) the format of all the markers in the measurement. To override this setting for an individual marker, use mark.Format

VB Syntax

meas.MarkerFormat = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

Long Integer

Default

1 - naMarkerFormat_LogMag

Examples

meas.MarkerFormat = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT put_MarkerFormat(tagNAMarkerFormat NewFormat)

Interface

IMeasurement


Format (Marker) Property

About Marker Format

Format Property (marker)

Write/Read

Description

Sets (or returns) the format of the marker.

VB Syntax

mark.Format = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

NAMarkerFormat

Default

1 - naMarkerFormat_LogMag

Examples

mark.Format = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT get_Format(tagNAMarkerFormat *pVal)
HRESULT put_Format(tagNAMarkerFormat newVal)

Interface

IMarker


Interpolate Markers Method

About Markers

InterpolateMarkers Method

Write-only

Description

Turns All Marker Interpolation ON and OFF for the measurement. Marker interpolation enables X-axis resolution between the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. To override this property for individual markers, use the Interpolated property.

VB Syntax

meas.Interpolate = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
False - Turns interpolation OFF for all markers in the measurement
True - Turns interpolation ON for all markers in the measurement

Return Type

Boolean

Default

True (ON)

Examples

meas.Interpolate = 1

C++ Syntax

HRESULT raw_InterpolateMarkers(VARIANT_BOOL bNewVal)

Interface

IMeasurement


About Markers

Interpolated Property

Write/Read

Description

Turns marker Interpolation ON and OFF. Marker interpolation enables X-axis resolution beyond the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. Use meas.Interpolate to change interpolation of all markers in a measurement. This command will override the measurement setting.

VB Syntax

mark.Interpolated = value

Variable

(Type) - Description

mark

A Marker (object)

value

(boolean)
False - Turns interpolation OFF
True - Turns interpolation ON

Return Type

Boolean

Default

True (ON)

Examples

mark.Interpolated = 1 'Write

interpolate = mark.Interpolated 'Read

C++ Syntax

HRESULT get_Interpolated(VARIANT_BOOL *pVal)
HRESULT put_Interpolated(VARIANT_BOOL newVal)

Interface

IMarker


Number (marker) Property

About Markers

Number Property

Read-only

Description

Returns the number of the marker.

VB Syntax

marknum = mark.Number

Variable

(Type) - Description

marknum

(long) - Variable to store marker number

mark

A Marker (object)

Return Type

Long Integer

Default

Not applicable

Examples

marknum = mark.Number 'Read

C++ Syntax

HRESULT get_Number(long *pVal)

Interface

IMarker


About Marker Types

Type (Marker) Property

Write/Read

Description

Sets and reads the marker type.

VB Syntax

mark.Type = value

Variable

(Type) - Description

chan

A Marker (object)

value

(enum NAMarkerType) - Marker Type. Choose from:
naMarkerType_Normal - the X-axis value for a normal marker will always be determined by the measurement data of the marker. naMarkerType_Fixed - retains and keeps its x-axis value at the time the marker type is set.

Return Type

Long Integer

Default

naMarkerType_Normal

Examples

mark.Type = naMarkerType_Normal 'Write

MrkType = mark.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAMarkerType *pVal)
HRESULT put_Type(tagNAMarkerType newVal)

Interface

IMarker


About Markers

Stimulus Property

Write/Read

Description

Sets and reads the X-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

VB Syntax

mark.Stimulus = value

Variable

(Type) - Description

mark

A Marker (object)

value

(double) - X-Axis value. Choose any number within the full span of the channel or User Range (if set).

Return Type

Double

Default

First activated Marker turns ON in the middle of the X-axis range. Subsequent markers turn ON at the position of the most recently active marker.

Examples

mark.Stimulus = 3e9 'Write

XVal = mark.Stimulus 'Read

C++ Syntax

HRESULT get_Stimulus(double *pVal)
HRESULT put_Stimulus(double newVal)

Interface

IMarker


About Markers

Value Property

Read-only

Description

Reads the Y-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

You cannot set the Y-axis value of a marker. The marker remains at the position at the time you set marker.Type.

VB Syntax

YValue = mark.Value (format)

Variable

(Type) - Description

YValue

A variable to store the Y-axis value

mark

A Marker (object)

format

(enum NAMarkerFormat) - The format you would like the marker's Y-axis value. The number in parenthesis following the format is the number of values that are returned in a variant array. Choose from:

naMarkerFormat_LinMag (1)
naMarkerFormat_LogMag (1)
naMarkerFormat_Phase (1)
naMarkerFormat_Delay (1)
naMarkerFormat_Real (1)
naMarkerFormat_Imaginary (1)
naMarkerFormat_SWR (1)
naMarkerFormat_LinMagPhase (2)
naMarkerFormat_LogMagPhase (2)
naMarkerFormat_RealImaginary (2)
naMarkerFormat_ComplexImpedance (3)
naMarkerFormat_ComplexAdmittance (3)

Return Type

Variant - The previous list of formats indicates the number of values that are returned in a variant array

Default

Not applicable

Examples

YVal = mark.Value 'Read

C++ Syntax

HRESULT get_Value(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


About Modifying Cal Kits

MaximumFrequency Property

Write/Read

Description

Sets and Returns the maximum frequency for the calibration standard.

VB Syntax

calstd.MaximumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) - Maximum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MaximumFrequency = 9e9 'Write

maxFrequency = calstd.MaximumFrequency 'Read

C++ Syntax

HRESULT get_MaximumFrequency(double *pVal)
HRESULT put_MaximumFrequency(double newVal)

Interface

ICalStandard


About Trace Statistics

Mean Property

Read-only

Description

Returns the mean value of the measurement . To retrieve all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

average = meas.Mean

Variable

(Type) - Description

average

(single) - Variable to store mean value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

Dim average as Single
average = meas.Mean 'Read

C++ Syntax

HRESULT get_Mean(float* mean)

Interface

IMeasurement


About Modifying Cal Kits

Medium Property

Write/Read

Description

Sets and Returns the media type of the calibration standard.

VB Syntax

calstd.Medium = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardMedium) - Medium of the transmission line of the standard. Choose from:
0 - naCoax - Coaxial Cable
1 - naWaveGuide

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Medium = naCoax 'Write

stdMedium = calstd.Medium 'Read

C++ Syntax

HRESULT get_Medium(tagNACalStandardMedium *pVal)
HRESULT put_Medium(tagNACalStandardMedium newVal)

Interface

ICalStandard


About Modifying Cal Kits

MinimumFrequency Property

Write/Read

Description

Sets and Returns the minumum frequency for the calibration standard.

VB Syntax

calstd.MinimumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) -Minimum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MinimumFrequency = 300e3 'Write

minFrequency = calstd.MinimumFrequency 'Read

C++ Syntax

HRESULT get_MinimumFrequency(double *pVal)
HRESULT put_MinimumFrequency(double newVal)

Interface

ICalStandard


Name (Meas) Property

About Traces

Name (Measurement) Property

Write/Read

Description

Sets (or returns) the Name of the measurement. Measurement names must be unique among the set of measurements. Measurement names cannot be an empty string.

Note: This is the same name as trace.Name; when one changes, the other changes.

VB Syntax

meas.Name = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(string) - A user defined name of the measurement

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

meas.Name = "Filter BPass" 'Write

MName = meas.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

IMeasurement


About Traces

Name (trace) Property

Write/Read

Description

Sets or returns the name of the Trace. Use the trace name to identify the trace and refer to the trace in the collection.

Note: This is the same name as meas.Name; when one changes, the other changes.

VB Syntax

trac.Name = value

Variable

(Type) - Description

trac

A Trace (object)

value

(String) Trace name

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

trace.Name = "myTrace" 'Write

traceName = Name.Trace 'Read

C++ Syntax

HRESULT put_Name(BSTR name)
HRESULT get_Name(BSTR *name)

Interface

ITrace


About Modifying Cal Kits

Name (CalKit) Property

Write/Read

Description

Sets and Returns a name for the selected calibration kit.

VB Syntax

calKit.Name = value

Variable

(Type) - Description

calKit

A CalKit (object).

value

(string) -Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).

Return Type

String

Default

Not Applicable

Examples

calKit.Name = "MyCalKit" 'Write

KitName = calKit.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

ICalKit


Number (meas) Property

About Measurements

Number (Measurement) Property

Read-only

Description

Returns the Number of the measurement. Measurement numbers are assigned internally.

Note: Measurement numbers are NOT the same as their number in the Measurements collection. Measurement number is used to identify the measurement associated with an event.

This property is used to identify measurements when events occur through the OnMeasurementEvent callback. For example:

OnMeasurementEvent (naEventId_MSG_LIMIT_FAILED, 3)

VB Syntax

measNum = meas.Number

Variable

(Type) - Description

measNum

(long) - variable to store the measurement number

meas

A Measurement (object)

Return Type

Long Integer

Default

"1" - number of the default measurement

Examples

measNum = meas.Number

C++ Syntax

HRESULT get_Number(long *MeasurementNumber)

Interface

IMeasurement


Number of Points Property

About Number of Points

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Options

Options Property

Read-only

Description

Returns a string identifying the analyzer option configuration.

VB Syntax

value = app.Options

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned string

Return Type

String

Default

Not Applicable

Examples

availOptions = app.Options

C++ Syntax

HRESULT Options(BSTR* OptionString)

Interface

IApplication


About Measurement Parameters

Parameter Property

Read-only

Description

Returns the measurement Parameter. To change the parameter, use meas.ChangeParameter

VB Syntax

measPar = meas.Parameter

Variable

(Type) - Description

measPar

(string) - Variable to store Parameter string

meas

A Measurement (object)

Return Type

String

Default

Not applicable

Examples

measPar = meas.Parameter 'Read

C++ Syntax

HRESULT get_Parameter(BSTR *pVal)

Interface

IMeasurement


Parent Property

Read-only

Description

Returns a handle to the parent object of the collection object being refered to in the statement. The parent property allows the user to traverse from an object back up the object hierarchy.

VB Syntax

object.Parent

Variable

(Type) - Description

object

Channels collection
Channel object
Measurements collection
NAWindows collection
Traces collection
Segments object

Return Type

Object

Default

Not Applicable

Examples

parentobj = chans.Parent 'returns a handle to the parent object (Application) of the chans collection. -Read

C++ Syntax

HRESULT get_Parent(IApplication* *pApplication)

Interface

IChannels
IChannel
IMeasurements
INAWindows
ITraces
ISegments


Peak Excursion Property

About Marker Search

PeakExcursion Property

Write/Read

Description

Sets and reads the peak excursion value for the specified marker. The Excursion value determines what is considered a "peak".

VB Syntax

mark.PeakExcursion = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Excursion. Choose any number between -500 and 500

Return Type

Single

Default

3

Examples

mark.PeakExcursion = 1 'Write

PkExcur = mark.PeakExcursion 'Read

C++ Syntax

HRESULT get_PeakExcursion(float *pVal)
HRESULT put_PeakExcursion(float newVal)

Interface

IMarker


Peak Threshold Property

About Marker Search

PeakThreshold Property

Write/Read

Description

Sets peak threshold for the specified marker. If a peak (using the criteria set with PeakExcursion) is below this reference value, it will not be considered when searching for peaks.

VB Syntax

mark.PeakThreshold = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Threshold. Choose any number between:
-500 and 500

Return Type

Single

Default

-100db

Examples

mark.PeakThreshold = 1 'Write

PkThresh = mark.PeakThreshold 'Read

C++ Syntax

HRESULT get_PeakThreshold(float *pVal)
HRESULT put_PeakThreshold(float newVal)

Interface

IMarker


About Trace Statistics

PeakToPeak Property

Read-only

Description

Returns the Peak to Peak value of the measurement.To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

pp = meas.PeakToPeak

Variable

(Type) - Description

pp

(single) - Variable to store peak-to-peak value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

pp = meas.PeakToPeak 'Read

C++ Syntax

HRESULT get_PeakToPeak(float* pp)

Interface

IMeasurement


Phase Offset Property

About Phase Offset

PhaseOffset Property

Write/Read

Description

Sets the Phase Offset for the active channel.

VB Syntax

meas.PhaseOffset = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - PhaseOffset in degrees. Choose any number between:
-360 and +360

Return Type

Double

Default

0

Examples

meas.PhaseOffset = 25 'Write

poffset = meas.PhaseOffset 'Read

C++ Syntax

HRESULT get_PhaseOffset(double *pVal)
HRESULT put_PhaseOffset(double newVal)

Interface

IMeasurement


Port 1 Property

About Port Extensions

Port1 Property

Write/Read

Description

Sets a Port Extension value for Port 1

VB Syntax

portExt.Port1 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port1 = 10e-6 'Write

prt1 = portExt.Port1 'Read

C++ Syntax

HRESULT get_Port1(double *pVal)
HRESULT put_Port1(double newVal)

Interface

IPortExtension


Port 2 Property

About Port Extensions

Port2 Property

Write/Read

Description

Sets a Port Extension value for Port 2

VB Syntax

portExt.Port2 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port2 = 10e-6 'Write

prt2 = portExt.Port2 'Read

C++ Syntax

HRESULT get_Port2(double *pVal)
HRESULT put_Port2(double newVal)

Interface

IPortExtension


About Modifying Cal Kits

PortLabel Property

Write/Read

Description

Sets and returns the label on the calibration kit Port for the calibration wizard.

VB Syntax

calKit.Portlabel (portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object)

portNum

(long integer) - number of the port to be labeled. Choose either 1 or 2

value

(string) - Label that is visible in the calibration wizard.

Return Type

String

Default

Depends on the Cal Kit.

Examples

calKit.PortLabel = "MyCalKit" 'Write

kitLabel = calKit.PortLabel 'Read

C++ Syntax

HRESULT get_PortLabel(long port, BSTR *pVal)
HRESULT put_PortLabel(long port, BSTR newVal)

Interface

ICalKit


Power Slope Property

About Power Slope

PowerSlope Property

Write/Read

Description

Sets or returns the Power Slope value. Power Slope function increases or decreases the output power over frequency. Units are db/GHz. For example: PowerSlope = 2 will increase the power 2db/1GHZ.

VB Syntax

app.PowerSlope = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Power Slope. Choose any number between -2 and 2.
No slope = 0

Return Type

Double

Default

0

Examples

app.PowerSlope = 2 'Write

pwrslp = app.PowerSlope 'Read

C++ Syntax

HRESULT get_PowerSlope(double *pVal)
HRESULT put_PowerSlope(double newVal)

Interface

IChannel


Receiver Attenuator Property

About Receiver Attenuation

ReceiverAttenuator Property

Write/Read

Description

Sets or returns the value of the specified receiver attenuator control.

VB Syntax

chan.ReceiverAttenuator(rec) = value

Variable

(Type) - Description

chan

A Channel (object)

rec

(long integer) - Receiver with attenuator control to be changed. Choose from:
0 - Receiver A
1 - Receiver B

value

(double) - Attenuator value in dB. Choose any Long Integer between 0 and 35 in 5dB steps:

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 15 dB attenuation.

Return Type

Double

Default

0 db

Examples

chan.ReceiverAttenuator(1) = 5 'Write

attn = chan.ReceiverAttenuator(rnum) 'Read

C++ Syntax

HRESULT get_ReceiverAttenuator(long lport, double *pVal)
HRESULT put_ReceiverAttenuator(long lport, double newVal)

Interface

IChannel


About Reference Markers

ReferenceMarkerState Property

Write/Read

Description

Turn ON or OFF the reference marker. (can you access marker10?)

VB Syntax

meas.ReferenceMarkerState = state

Variable

(Type) - Description

app

A Measurement (object)

state

(boolean) -
ON (1) turns the reference marker ON
OFF (0) turns the reference marker OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.ReferenceMarkerState = True

reference = meas.ReferenceMarkerState

C++ Syntax

HRESULT get_ReferenceMarkerState(VARIANT_BOOL bState)
HRESULT put_ReferenceMarkerState(VARIANT_BOOL* bState)

Interface

IMeasurement


Reference Position Property

About Reference Position

ReferencePosition Property

Write/Read

Description

Sets or returns the Reference Position of the active trace.

VB Syntax

trce.ReferencePosition = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference position on the screen measured in horizontal graticules from the bottom of the screen. Choose from any number between: 0 and 10.

Return Type

Double

Default

0

Examples

meas.ReferencePosition = 5 'Middle of the screen -Write

rpos = meas.ReferencePosition -Read

C++ Syntax

HRESULT get_ReferencePosition(double *pVal)
HRESULT put_ReferencePosition(double newVal)

Interface

ITrace


Reference Value Property

About Reference Level

ReferenceValue Property

Write/Read

Description

Sets or returns the value of the Y-axis Reference Level of the active trace.

VB Syntax

trce.ReferenceValue = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference Value. Units and range depend on the current data format.

Return Type

Double

Default

Not applicable

Examples

meas.ReferenceValue = 0 'Write

rlev = meas.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(double *pVal)
HRESULT put_ReferenceValue(double newVal)

Interface

ITrace


Search Function Property

About Marker Search

SearchFunction Property

Write/Read

Description

Emulates the Tracking function in the marker search dialog box. The value you choose for SearchFunction will determine the type of search that takes place when the Tracking property is set true.

The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as executing one of the "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.SearchFunction = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFunction) - search function. Choose from:

0 - naMarkerFunction_None
1 - naMarkerFunction_Min
2 - naMarkerFunction_Max
3 - naMarkerFunction_Target
4 - naMarkerFunction_NextPeak
5 - naMarkerFunction_PeakRight
6 - naMarkerFunction_PeakLeft

Return Type

Long Integer

Default

0 - naMarkerFunction_None

Examples

mark.SearchFunction = naMarkerFunction_Target 'When this marker is set to track, it will track the Target value.

searchfunction = mark.SearchFunction 'Read

C++ Syntax

HRESULT get_SearchFunction(tagNAMarkerFunction *pVal)
HRESULT put_SearchFunction(tagNAMarkerFunction newVal)

Interface

IMarker


Segment Number Property

About Segment Sweep

SegmentNumber Property

Read-only

Description

Returns the number of the current segment.

VB Syntax

seg.SegmentNumber

Variable

(Type) - Description

seg

A Segment (object). Get a handle to a segment by refering to the item in the segments collection.

Return Type

Long Integer

Default

Not Applicable

Examples

segNum = seg.SegmentNumber 'returns the segment number -Read

C++ Syntax

HRESULT get_SegmentNumber(long *pVal)

Interface

ISegment


Show Statistics Property

About Trace Statistics

ShowStatistics Property

Write/Read

Description

Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen. To display measurement statistics for a narrower band of the X-axis, use StatisticsRange.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both.

VB Syntax

meas.ShowStatistics = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Boolean value:

1 - Show statistics
0 - Hide statistics

Return Type

Boolean

Default

0 - Hide

Examples

meas.ShowStatistics = True 'Write

showstats = meas.ShowStatistics 'Read

C++ Syntax

HRESULT put_ShowStatistics(VARIANT_BOOL bState)

Interface

IMeasurement


About Performing a Calibration

Simultaneous2PortAcquisition Property

Read / Write

Description

Specifies whether a 2-port calibration will be done simultaneously or one port at a time.

VB Syntax

cal.Simultaneous2PortAcquisition = state

Variable

(Type) - Description

cal

A Calibrator (object)

state

(boolean) - Choose from:

True - measures 2 ports simultaneously
False - measures 1 port at a time

Return Type

Boolean

Default

False

Examples

cal.Simultaneous2PortAcquisition = True

C++ Syntax

HRESULT put_Simultaneous2PortAcquisition( VARIANT_BOOL bTwoSetsOfStandards)

HRESULT Simultaneous2PortAcquisition( VARIANT_BOOL *bTwoSetsOfStandards)

Interface

ICalibrator


Smoothing Aperture Property

About Smoothing

SmoothingAperture Property

Write/Read

Description

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

VB Syntax

meas.SmoothingAperture = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Smoothing Aperture. A ratio of (aperture points / trace points)/100 Choose any number between .01 and .25.

Return Type

Double

Default

.25

Examples

meas.SmoothingAperture = .10 'Write

saperture = meas.SmoothingAperture 'Read

C++ Syntax

HRESULT get_SmoothingAperture(double *pVal)
HRESULT put_SmoothingAperture(double newVal)

Interface

IMeasurement


About Smoothing

Smoothing Property

Write/Read

Description

Turns ON and OFF data smoothing.

VB Syntax

meas.Smoothing = state

Variable

(Type) - Description

meas

A Measurement (object)

state

(boolean)
1 - Turns smoothing ON
0 - Turns smoothing OFF

Return Type

Boolean

Default

0

Examples

meas.Smoothing = 1 'Write

smooth = meas.Smoothing 'Read

C++ Syntax

HRESULT get_Smoothing(VARIANT_BOOL *pVal)
HRESULT put_Smoothing(VARIANT_BOOL newVal)

Interface

IMeasurement


About Limits

SoundOnFail Property

Write/Read

Description

Turns ON or OFF the audio indicator for limit failures.

VB Syntax

limitst.SoundOnFail = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the sound OFF
1 - Turns the sound ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.SoundOnFail = 1 'Write

sound = Limttest.SoundOnFail 'Read

C++ Syntax

HRESULT get_SoundOnFail(VARIANT_BOOL *pVal)
HRESULT put_SoundOnFail(VARIANT_BOOL newVal)

ILimitTest


Source Power Option Property

About Segment Sweep

SourcePowerOption Property

Write/Read

Description

Enables the source power to be set on individual sweep segments. This property must be set True before seg.TestPortPower = value is sent. Otherwise, the test port power command will be ignored.

VB Syntax

segs.SourcePowerOption = state

Variable

(Type) - Description

segs

A Segments collection (object)

state

(boolean)
1 or True - Enables variable TestPortPower to be set segment sweep
0 or False - Disables variable TestPortPower to be set segment sweep

Return Type

Boolean
True - Enabled
False - Disabled

Default

False

Examples

segs.SourcePowerOption = True 'Write

powerOption = SourcePowerOption 'Read

C++ Syntax

HRESULT get_SourcePowerOption(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerOption(VARIANT_BOOL newVal)

Interface

ISegments


Source Power State Property

About Source Power

SourcePowerState Property

Write/Read

Description

Turns Source Power ON and OFF

VB Syntax

app.SourcePowerState = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
False (0) - Turns Source Power OFF
True (1) - Turns Source Power ON

Return Type

Boolean
0 - Power OFF
1 - Power ON

Default

ON (1)

Examples

app.SourcePowerState = True 'Write

pwr = app.SourcePowerState 'Read

C++ Syntax

HRESULT get_SourcePowerState(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerState(VARIANT_BOOL newVal)

Interface

IApplication


About Time Domain

Span Property

Write/Read

Description

Sets or returns the Span time of either Gating or Time Domain transform windows

VB Syntax

object.Span = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Span time in seconds. Choose any number between: 2*[(number of points-1) / frequency span] and 0

Return Type

Double

Default

20ns

Examples

Trans.Span = 4.5e-9 'sets the time span of a transform window -Write
Gate.Span = 4.5e-9 'sets the Span time of a gating window -Write

span = Trans.Span 'Read

C++ Syntax

HRESULT get_Span(double *pVal)
HRESULT put_Span(double newVal)

Interface

ITransform
IGating


Standard Deviation Property

About Trace Statistics

StandardDeviation Property

Read-only

Description

Returns the standard deviation of the measurement.
To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

stdev = meas.StandardDeviation

Variable

(Type) - Description

stdev

(single) - Variable to store standard deviation value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

stdev = meas.StandardDeviation 'Read

C++ Syntax

HRESULT get_StandardDeviation(float* stdDeviation)

Interface

IMeasurement


About Modifying Cal Kits

StandardForClass Property

Write/Read

Description

Sets a standard to a calibration class. Does NOT set or dictate the order for measuring the standards.

VB Syntax

calKit.StandardForClass(class, portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object). Use calKit.GetCalStandard to get a handle to the standard.

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

portNum

(long) - The port number the standard will be connected to. For example, you may have a 3.5mm connector designated for port 1, and Type N designated for port 2.

value

(double) - Calibration class number. Choose a number between 1 and 8. The <value> numbers are associated with the following calibration classes:

<value> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S21T | Thru standard

Return Type

Double

Default

Not Applicable

Examples

calstd.StandardForClass = 7 'Write

StdClass = calstd.StandardForClass 'Read

C++ Syntax

HRESULT put_StandardForClass(tagNACalClass stdclass, long port, long standardNumber)
HRESULT get_StandardForClass(tagNACalClass stdclass, long port, long* standardNumber)

Interface

ICalKit


Start Frequency Property

About Linear Frequency Sweep

StartFrequency Property

Write/Read

Description

Sets or returns the start frequency of the channel
or
Sets or returns the start frequency of the segment.

VB Syntax

object.StartFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Start frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Minimum frequency of the analyzer
Segment - 0

Examples

chan.StartFrequency = 4.5e9 'sets the start frequency of a linear sweep for the channel object -Write

startfreq = Chan.StartFrequency 'Read

C++ Syntax

HRESULT get_StartFrequency(double *pVal)
HRESULT put_StartFrequency(double newVal)

Interface

ISegment


Start Power Property

About Power Sweep

StartPower Property

Write/Read

Description

Sets the start power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency.

VB Syntax

chan.StartPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Start Power in dBm. There is 40 dB of range in power sweep. The values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 dB of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StartPower = -10 'Write

strtpwr = Chan.StartPower 'Read

C++ Syntax

HRESULT get_StartPower(double *pVal)
HRESULT put_StartPower(double newVal)

Interface

IChannel


About Time Domain

Start Property

Write/Read

Description

Sets or returns the start time of either Gating or Time Domain transform windows

VB Syntax

object.Start = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

-10ns

Examples

Trans.Start = 4.5e-9 'sets the start time of a transform window -Write
Gate.Start = 4.5e-9 'sets the start time of a gating window -Write

strt = Trans.Start 'Read

C++ Syntax

HRESULT get_Start(double *pVal)
HRESULT put_Start(double newVal)

Interface

ITransform
IGating


State Property

Write/Read

Description

Turns an Object ON and OFF.

VB Syntax

object.State = value

Variable

(Type) - Description

object

Applies to any of the following:
Gating (object)
LimitTest (object)
Port Extension (object)
Segment (object)
Transform (object)

value

(boolean) -

0 - Turns obj OFF
1 - Turns obj ON

Return Type

Long Integer

Default

Depends on the object:
0 - Gating
0 - LimitTest
0 - Port Extension
1 - Segment
0 - Transform

Examples

Seg.State = 1 'Turns the segment object ON -Write

tran = Trans.State 'returns the state of Transform -Read

C++ Syntax

HRESULT get_State(VARIANT_BOOL *pVal)
HRESULT put_State(VARIANT_BOOL newVal)

Interface

ISegment
ITransform
IGating
ILimitTest
IPortExtension


About User Ranges

Statistics Range Property

Write/Read

Description

Sets the User Range number for calculating measurement statistics. Set the start and stop values for a User Range with chan.UserRangeMin and chan.UserRangeMax.

There are 9 User Ranges per channel. User ranges are applied independently to any measurement.

VB Syntax

meas.StatisticsRange = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(long integer) - Range Number. Choose any number between 0 and 9.
1 - 9 are user-defined ranges
0 is Full Span

Return Type

Long Integer

Default

0

Examples

meas.StatisticsRange = 2 'Write

statrange = meas.StatisticsRange 'Read

C++ Syntax

HRESULT get_StatisticsRange(long* rangeNumber)
HRESULT put_StatisticsRange(long rangeNumber)

Interface

IMeasurement


Step Rise Time Property

About Time Domain

StepRiseTime Property

Write/Read

Description

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

VB Syntax

trans.StepRiseTime = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Rise time in seconds. Choose any number between 5.0e-13 and 1.63e-14.

Return Type

Double

Default

0

Examples

trans.StepRiseTime = 1.0e-14 'sets the step rise time to 100 psec. -Write

rt = trans.StepRiseTime 'Read

C++ Syntax

HRESULT get_StepRiseTime(double *pVal)
HRESULT put_StepRiseTime(double newVal)

Interface

ITransform


Stop Frequency Property

About Linear Frequency Sweep

StopFrequency Property

Write/Read

Description

Sets or returns the stop frequency of the channel
or
Sets or returns the stop frequency of the segment.

VB Syntax

object.StopFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Stop frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Maximum frequency of the analyzer
Segment - 0

Examples

chan.StopFrequency = 4.5e9 'sets the stop frequency of a linear sweep for the channel object -Write

stopfreq = Chan.StopFrequency 'Read

C++ Syntax

HRESULT get_StopFrequency(double *pVal)
HRESULT put_StopFrequency(double newVal)

Interface

IChannel
ISegment


Stop Power Property

About Power Sweep

StopPower Property

Write/Read

Description

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency

VB Syntax

chan.StopPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Stop Power in dB. Start Power in dB. There is 40 dB of range in power sweep. The acceptable values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StopPower = -10 'Write

stppwr = Chan.StopPower 'Read

C++ Syntax

HRESULT get_StopPower(double *pVal)
HRESULT put_StopPower(double newVal)

Interface

IChannel


About Time Domain

Stop Property

Write/Read

Description

Sets or returns the Stop time of either Gating or Time Domain transform windows

VB Syntax

object.Stop = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

10 ns

Examples

Trans.Stop = 4.5e-9 'sets the stop time of a transform window -Write
Gate.Stop = 4.5e-9 'sets the stop time of a gating window -Write

stp = Trans.Stop 'Read

C++ Syntax

HRESULT get_Stop(double *pVal)
HRESULT put_Stop(double newVal)

Interface

ITransform
IGating


Sweep Generation Mode Property

About Stepped Sweep

SweepGenerationMode Property

Write/Read

Description

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

VB Syntax

chan.SweepGenerationMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepGenerationModes) - Choose either:

naSteppedSweep - source frequency is CONSTANT during measurement of eah displayed point. More accurate than Analog. Dwell time can be set in this mode.

naAnalogSweep - source frequency is continuously RAMPING during measurement of each displayed point. Faster than Stepped. Sweep time (not dwell time) can be set in this mode.

Return Type

Long Integer

Default

Analog

Examples

Chan.SweepGenerationMode = naAnalogSweep 'Write

swpgen = Chan.SweepGenerationMode 'Read

C++ Syntax

HRESULT get_SweepGenerationMode(tagNASweepGenerationModes* pVal)
HRESULT put_SweepGenerationMode(tagNASweepGenerationModes newVal)

Interface

IChannel


Sweep Time Property

About Sweep Time

SweepTime Property

Write/Read

Description

Sets the Sweep time of the analyzer. Sweep time is limited so that the analyzer only sweeps as fast as possible for the current frequency range, number of points, and IFbandwidth.

VB Syntax

chan.SweepTime = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Sweep time in seconds. Choose a number between:
0 and 100

Return Type

Double

Default

0

Examples

chan.SweepTime = 3e-3 'Write

swptme = chan.SweepTime 'Read

C++ Syntax

HRESULT get_SweepTime(double *pVal)
HRESULT put_SweepTime(double newVal)

Interface

IChannel


Sweep Type Property

About Sweep Types

SweepType Property

Write/Read

Description

Sets the type of X-axis sweep that is performed on a channel.

VB Syntax

chan.SweepType = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepTypes) - Choose from:

naLinearSweep
naPowerSweep
naCWTimeSweep
naSegmentSweep

Note: Sweep type cannot be set to Segment sweep if there are no segments turned ON. A segment is automatically turned ON when a Application application is created.

Return Type

Long Integer

Default

naLinearSweep

Examples

chan.SweepType = naPowerSweep 'Write

swptyp = chan.SweepType 'Read

C++ Syntax

HRESULT get_SweepType(tagNASweepTypes* pVal)
HRESULT put_SweepType(tagNASweepTypes newVal)

Interface

IChannel


About System Impedance

SystemImpedanceZ0 Property

Write/Read

Description

Sets and returns the impedance for the analyzer.

VB Syntax

app.SystemImpedanceZ0 = value

Variable

(Type) - Description

app

An Application (object)

value

(double) Analyzer Impedance. Choose any number between 0 and 1000 ohms.

Return Type

Double

Default

50

Examples

app.SystemImpedanceZ0 = 75 'Write

z0 = app.SystemImpedanceZ0 'Read

C++ Syntax

HRESULT get_SystemImpedanceZ0(double dSystemZ0)
HRESULT put_SystemImpedanceZ0(double *pdSystemZ0)

Interface

IApplication


About Marker Search

TargetValue Property

Write/Read

Description

Sets the target value for the marker when doing Target Searches ( SearchTargetLeft, SearchTarget, SearchTargetRight).

VB Syntax

mark.TargetValue = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Target value. Choose any number between: -500 and 500

Return Type

Single

Default

0

Examples

mark.TargetValue = 10.5 'Write

target = mark.TargetValue 'Read

C++ Syntax

HRESULT get_TargetValue(float *pVal)
HRESULT put_TargetValue(float newVal)

Interface

IMarker


Test Port Power Property

About Power Level

TestPortPower Property

Write/Read

Description

Sets or returns the RF power level for the channel
or
Sets or returns the RF power level of the segment.

VB Syntax

object.TestPortPower(portNum) = value

Variable

(Type) - Description

object

A Channel (object) - to set coupled power, use chan.CouplePorts. If CouplePorts = False, then each port power can be set independently. Otherwise, chanTestPortPower (1) = value sets power level at both ports.
or
A Segment (object)

portNum

(long integer) - Port number of the source power. Choose from 1 or 2

value

(double) - RF Power in dBm. Choose any number between -90 and 20.

Actual achievable leveled power depends on frequency.

Return Type

Double

Default

0

Examples

chan.TestPortPower(1) = 5 'sets the port 1 RF power level for the channel object -Write

powerlev = Chan.TestPortPower(1) 'Read

C++ Syntax

HRESULT get_TestPortPower(long port, double *pVal)
HRESULT put_TestPortPower(long port, double newVal)

Interface

IChannel
ISegment


About Title

Title Property

Write/Read

Description

Writes or reads a custom title for the window. Newer entries replace (not append) older entries.Turn the title ON and OFF with TitleState

VB Syntax

win.Title = string

Variable

(Type) - Description

win

A NaWindow (object)

string

(long) - Title limited to 50 characters.

Return Type

String

Default

Null

Examples

win.Title = "Hello World" 'Write

titl = win.Title 'Read

C++ Syntax

HRESULT get_Title(BSTR *title)
HRESULT put_Title(BSTR title)

Interface

INAWindow


Title State Property

About Titles

TitleState Property

Write/Read

Description

Turns ON and OFF the window title. Write a window title with Title

VB Syntax

win.TitleState = state

Variable

(Type) - Description

win

A NaWindow (object)

state

(boolean)
True (1) - Title ON
False (0) - Title OFF

Return Type

Long Integer
0 - Title OFF
1 - Title ON

Default

0 - OFF

Examples

win.TitleState = True 'Write

titlestate = win.TitleState 'Read

C++ Syntax

HRESULT get_TitleState(VARIANT_BOOL* bState)
HRESULT put_TitleState(VARIANT_BOOL bState)

Interface

INAWindow


Trace Math Property

About Math Operations

TraceMath Property

Write/Read

Description

Performs math operations on the measurement object and the trace stored in memory. (There MUST be a trace stored in Memory to perform math. See Meas.DataToMemory method.)

VB Syntax

meas.TraceMath = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAMathOperation) - Choose from:

0 - naDataNormal
1 - naDataMinusMemory
2 - naDataPlusMemory
3 - naDataDivMemory
4 - naDataTimesMemory

Return Type

NAMathOperation

Default

Normal (0)

Examples

meas.TraceMath = naDataMinusMemory 'Write

mathOperation = meas.TraceMath 'Read

C++ Syntax

HRESULT get_TraceMath(tagNAMathOperation* pMathOp)
HRESULT put_TraceMath(tagNAMathOperation mathOp)

Interface

IMeasurement


About Marker Search

Tracking Property

Write/Read

Description

This property, when on, executes the search function (marker.SearchFunction) every sweep.

In effect, turning Tracking ON is the same as executing one of the immediate, one-time, "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.Tracking = state

Variable

(Type) - Description

mark

A Marker (object)

state

(boolean) - Tracking state. Choose from:
ON (1)
OFF (0)

Return Type

Boolean
0 - Tracking OFF
1 - Tracking ON

Default

0 - OFF

Examples

mark.Tracking = 1 'Write

markTracking = mark.Type 'Read

C++ Syntax

HRESULT put_Tracking(VARIANT_BOOL bOn)
HRESULT get_Tracking(VARIANT_BOOL * pbOn)

Interface

IMarker


About Time Domain

Mode Property

Write/Read

Description

Sets the type of transform.

VB Syntax

trans.Mode = value

Variable

(Type) - Description

trans

A Transform (object)

value

(enum NATransformMode) - Choose from:

0 - naTransformBandpassImpulse
1 - naTransformLowpassImpulse
2 - naTransformLowpassStep

Return Type

NATransformMode

Default

0 - naTransformBandpassImpulse

Examples

trans.Mode = naTransformLowpassStep 'Write

transmode = trans.Mode 'Read

C++ Syntax

HRESULT get_Mode(tagNATransformMode *pVal)
HRESULT put_Mode(tagNATransformMode newVal)

Interface

ITransform


Trigger Mode Property

About Triggering

TriggerMode Property

Write/Read

Description

Each trigger signal will cause either:
all measurements in the channel to be made or
only a single data point in the channel at a time.

VB Syntax

chan.TriggerMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NATriggerMode) - Choose from:

naTriggerModeMeasurement - all measurements in the channel are made with each trigger signal the channel receives.
naTriggerModePoint - a single data point is measured with each trigger signal the channel receives. Subsequent trigger signals continue to go to the channel in Point mode until the channel measurements are complete.

Note: Point Mode is only available in Manual trigger and TriggerType set to naGlobalTrigger. If you change any channel to TriggerModePoint, TriggerType will be set to naChannelTrigger.

Return Type

Long Integer

Default

0 - naTriggerModeMeasurement

Examples

app.TriggerMode = naTriggerModePoint 'Write

trigtyp = app.TriggerMode 'Read

C++ Syntax

HRESULT get_TriggerMode (tagNATriggerMode *pMode)
HRESULT put_TriggerMode (tagNATriggerMode newMode)

Interface

IChannel


Trigger Signal Property

About Trigger Source

TriggerSignal Property

Write/Read

Description

Sets or returns the trigger source.

VB Syntax

app.TriggerSignal = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerSignal) - Choose from:

naTriggerInternal - free run

naTriggerExternalPositive - an external source that supplies a positive going signal

naTriggerExternalNegative - an external source that triggers on a negative signal

naTriggerManual - manual trigger source; use app.ManualTrigger to send a trigger signal.

Return Type

Long Integer

Default

naTriggerInternal

Examples

app.TriggerSignal = naTriggerExternalPositive 'Write

trigsign = app.TriggerSignal 'Read

C++ Syntax

HRESULT get_TriggerSignal(tagNATriggerSignal *pSignal)
HRESULT put_TriggerSignal(tagNATriggerSignal signal)

Interface

IApplication


Trigger Type Property

About Trigger

TriggerType Property

Write/Read

Description

Sets or returns the trigger type which determines the scope of a trigger signal.

Note: Point (Trigger Mode) is only available in Manual trigger and Channel (Trigger Type). If you change any channel to Global Trigger, Trigger Mode will be set to Measurement.

VB Syntax

app.TriggerType = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerType) - Trigger type. Choose from:
naGlobalTrigger - a trigger signal is applied to all triggerable channels
naChannelTrigger - a trigger signal is applied to the current channel. The next trigger signal will be applied to the next channel; not necessarily channel 1-2-3-4.

Return Type

Long Integer

Default

naGlobalTrigger

Examples

app.TriggerType = naGlobalTrigger 'Write

trigtyp = app.TriggerType 'Read

C++ Syntax

HRESULT get_TriggerType(tagNATriggerType *pTrigger)
HRESULT put_TriggerType(tagNATriggerType trigger)

Interface

IApplication


About Modifying Cal Kits

Type (calstd) Property

Write/Read

Description

Sets and Returns the type of calibration standard.

VB Syntax

calstd.Type = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardType) -Choose from:
0 - naOpen
1 - naShort
2 - naLoad
3 - naThru

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Type = naOpen 'Write

standardtype = calstd.Type 'Read

C++ Syntax

HRESULT get_Type(tagNACalStandardType *pVal)
HRESULT put_Type(tagNACalStandardType newVal)

Interface

ICalStandard


User Range Property

About User Ranges

UserRange Property

Write/Read

Description

Assigns the marker to the specified User Range. This restricts the marker's x-axis travel to the User Range span, specified with Start and Stop values.

  • Each channel has 10 user ranges.

  • Markers and trace statistics can be restricted to any user range.

  • More than one marker can occupy a user range.

  • User ranges can overlap. For example:

    • User range 1 - 3GHz to 5GHz

    • User range 2 - 4GHz to 6GHz

Note: User ranges are especially useful in restricting marker searches to specific areas of the measurement.

VB Syntax

mark.UserRange = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - User Range. Choose any number between:
0 and 9 (0=Full Span)

Return Type

Long Integer

Default

0 - Full Span

Examples

mark.UserRange = 1 'Write

UseRnge = mark.UserRange 'Read

C++ Syntax

HRESULT get_UserRange(long *pRangeNumber)
HRESULT put_UserRange(long lRangeNumber)

Interface

IMarker


User Range Max Property

About User Ranges

UserRangeMax Property

Write/Read

Description

Sets the stimulus stop value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMax(domainType,Mnum) = value
or
mark.UserRangeMax(rnum) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the "DomainType" argument.

domainType

(enum NADomainType) - Choose from:

naDomainFrequency
naDomainPower
naDomainTime

Mnum

(long integer) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Stop value. Choose any number within the full span of the channel

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMax(1) = 3e9 'Write
chan.UserRangeMax(naDomainFrequency,1) = 3e9 'Write

UseRngeMax = mark.UserRangeMax 'Read
UseRngeMax = chan.UserRangeMax 'Read

C++ Syntax

HRESULT put_UserRangeMax(tagNADomainType domain, long rangeNumber, double maxValue)
HRESULT get_UserRangeMax(tagNADomainType domain, long rangeNumber, double *maxValue)

Interface

IChannel


User Range Min Property

About User Ranges

UserRangeMin Property

Write/Read

Description

Sets the stimulus start value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMin(domainType,range) = value
or
mark.UserRangeMin(range) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the DomainType argument

domainType

(enum NADomainType) Type of sweep currently implemented on the channel - Choose from:
naDomainFrequency
naDomainPower
naDomainTime

range

(long) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Start value. Choose any number within the full span of the analyzer

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMin(1) = 3e9 'Write
chan.UserRangeMin(naDomainFrequency,1) = 3e9 'Write

UseRngeMin = mark.UserRangeMin 'Read
UseRngeMin = chan.UserRangeMin 'Read

C++ Syntax

HRESULT put_UserRangeMin(tagNADomainType domain, long rangeNumber, double minValue)
HRESULT get_UserRangeMin(tagNADomainType domain, long rangeNumber, double *minValue)

Interface

IChannel


Velocity Factor Property

About Port Extensions

VelocityFactor Property

Write/Read

Description

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

VB Syntax

app.VelocityFactor = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Velocity factor. Choose a number between: 0 and 10
(.66 polyethylene dielectric; .7 teflon dielectric)

Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.

Return Type

Double

Default

1

Examples

app.VelocityFactor = .66 'Write

RelVel = app.VelocityFactor 'Read

C++ Syntax

HRESULT get_VelocityFactor(double *pVal)
HRESULT put_VelocityFactor(double newVal)

Interface

IApplication


About Math Operations

View Property

Write/Read

Description

Sets (or returns) the type of trace displayed on the screen.

VB Syntax

meas.View = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAView) - Type of trace. Choose from:

0 - naData
1 - naDataAndMemory
2 - naMemory
3 - naNoTrace

Note: The naData trace may reflect the result of a TraceMath operation.

Return Type

NAView

Default

naData

Examples

meas.View = naData 'Write

trceview = meas.View 'Read

C++ Syntax

HRESULT get_View(tagNAView* pView)
HRESULT put_View(tagNAView newView)

Interface

IMeasurement


Visible Property

Write/Read

Description

Makes the Network Analyzer application visible or not visible. In the Not Visible state, the analyzer cycle time for making measurements can be significantly faster because the display does not process data.

VB Syntax

app.Visible = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
0 - Network Analyzer application NOT visible
1 - Network Analyzer application IS visible

Return Type

Boolean
0 - Not visible
1 - visible

Default

1

Examples

app.Visible = 0 'Write

vis = app.Visible 'Read

C++ Syntax

HRESULT get_Visible(VARIANT_BOOL * bVisible)
HRESULT put_Visible(VARIANT_BOOL bVisible)

Interface

IApplication


Window State Property

About Arranging Windows

WindowState Property

Write/Read

Description

Sets or returns the window setting of Maximized, Minimized, or Normal. To arrange all of the windows, use app.ArrangeWindows.

VB Syntax

object.WindowState = value

Variable

(Type) - Description

object

An Application (object) - main window
or
A NaWindow (object) - data windows

value

(enum NAWindowStates) - The window state. Choose from:
naMaximized - Maximizes the window
naMinimized - Minimizes the window to an Icon on the lower toolbar
naNormal - changes the window size to the user defined setting (between Max and Min).

Return Type

Long Integer

Default

naMaximized

Examples

app.WindowState = naMinimized 'changes the Network Analyzer application window to an icon. -Write
win.WindowState = naNormal 'changes the window defined by the win object variable to user defined settings. -Write

winstate = app.WindowState 'Read

C++ Syntax

HRESULT get_WindowState(tagNAWindowStates *pVal)
HRESULT put_WindowState(tagNAWindowStates newVal)

Interface

INAWindow
IApplication


About Scale

YScale Property

Write/Read

Description

Sets or returns the Y-axis Per-Division value of the active trace.

VB Syntax

trace.YScale = value

Variable

(Type) - Description

trace

A Trace (object)

value

(double) - Scale /division number. Units and range depend on the current data format.

Return Type

Double

Default

10 (db)

Examples

trac.YScale = 5 'Write

yscl = trac.YScale 'Read

C++ Syntax

HRESULT get_YScale(double *pVal)
HRESULT put_YScale(double newVal)

Interface

ITrace


About Modifying Cal Kits

Z0 Property

Write/Read

Description

Sets and Returns the characteristic impedance for the calibration standard.

VB Syntax

calstd.Z0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) -Impedance in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.Z0 = 50 'Write

impedance = calstd.Z0 'Read

C++ Syntax

HRESULT get_Z0(float *pVal)
HRESULT put_Z0(float newVal)

Interface

ICalStandard


About Triggering

Abort Method

Write-only

Description

Ends the current measurement sweep on the channel.

VB Syntax

chan.Abort [sync]

Variable

(Type) - Description

chan

(object) - A Channel object

sync

(boolean) - wait (or not) for the analyzer to stop before processing subsequent commands. Optional argument; if unspecified, value is set to False. Choose from:
True - synchronize - the analyzer will not process subsequent commands until the current measurement is aborted.
False - continue processing commands immediately

Return Type

None

Default

None

Examples

chan.abort True
chan.abort

C++ Syntax

HRESULT raw_Abort(VARIANT_BOOL bSynchronize);

Interface

IChannel


Acquire Cal Standard Method

About Calibration Standards

AcquireCalStandard Method

Write-only

Description

Measures the specified standard from the selected calibration kit. The calibration kit is selected using app.CalKitType.

For 2-port calibration, it is also necessary to specify direction with AcquisitionDirection.

VB Syntax

cal.AcquireCalStandard std[,index]

Variable

(Type) - Description

cal

A Calibrator (object)

std

(enum NACalClass) Standard to be measured. Choose from:

naClassA

naClassB

naClassC

naClassD

naClassE

naReferenceRatioLine

naReferenceRatioThru

naSOLT_Isolation

SOLT Standards

naSOLT_Open

naSOLT_Short

naSOLT_Load

naSOLT_Thru

TRL Standards

naTRL_Reflection

naTRL_Line_Reflection

naTRL_Line_Tracking

naTRL_Thru

naTRL_Isolation

index

(long integer) number of the standard. Optional argument - Used if there is more than one standard required to cover the necessary frequency range. If unspecified, value is set to 0.

Return Type

None

Default

Not Applicable

Examples

Cal.AcquireCalStandard naSOLT_Thru 'Write

C++ Syntax

HRESULT raw_AcquireCalStandard(tagNACalClass enumClass, short standardNumber)

Interface

ICalibrator


Activate Method

Write-only

Description

Makes an object the Active Object. When making a measurement active, the channel and window the measurement is contained in becomes the active channel and active window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Getting a Handle to an Object.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

object.Activate

Variable

(Type) - Description

object

Measurement (object)
or
Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Activate
mark.Activate

C++ Syntax

HRESULT raw_Activate()

Interface

IMeasurement
IMarker


Activate Marker Method

About Markers

ActivateMarker Method

Write-only

Description

Makes a marker the Active Marker. Use meas.ActiveMarker to read the number of the active marker.

VB Syntax

meas.ActivateMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long integer) - the number of the marker to make active. Choose any marker number from 1 to 9.

Return Type

None

Default

Not Applicable

Examples

meas.ActivateMarker(1)'Write

C++ Syntax

HRESULT raw_ActivateMarker(long lMarkerNumber)

Interface

IMeasurement

Remarks

Use ReferenceMarkerState to control the Reference marker.


About Windows

ActivateWindow Method

Write-only

Description

Makes a window object the Active Window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Programming the Analyzer Object Model.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

app.ActivateWindow n

Variable

(Type) - Description

app

An Application (object)

n

(long) Number of the window to make active

Return Type

Window Object

Default

Not Applicable

Examples

app.ActivateWindow 4

C++ Syntax

HRESULT raw_ActivateWindow(long WindowNumber)

Interface

IApplication


About Channels

Add (channels) Method

Write-only

Description

Creates a channel and returns a handle to it. If the channel already exists, it returns the handle to the existing channel.

VB Syntax

chans.Add (item)

Variable

(Type) - Description

chans

A Channel collection (object)

item

(variant) - Channel number.

Return Type

Channel

Default

Not Applicable

Examples

chans.Add 3 'Creates channel 3

C++ Syntax

HRESULT raw_Add(VARIANT numVal, IChannel** pChannel)

Interface

IChannels


About Multiple Measurements

Add (measurement) Method

Write-only

Description

Adds a Measurement to the collection.

VB Syntax

meass.Add channel,param,source[,window]

meass

A Measurements collection (object)

channel

(long) - Channel number of the new measurement.

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

source

(long integer) - Source port number; if unspecified, value is set to 1. Only used for non-s-parameter measurements; ignored if s-parameter.

window

(long integer) - Optional - if unspecified, value is set to 0
-1: creates a new window
0 : current window
n : new window number (n) - creates if necessary

Return Type

None

Default

None

Examples

meass.Add 3,"A/R1",1,1 'Adds A/R1 measurement to channel 3 in window 1

C++ Syntax

HRESULT raw_Add(long ChannelNum, BSTR strParameter, long srcPort, VARIANT_BOOL bNewWindow)

Interface

IMeasurements


About Windows

Add (NAWindows) Method

Write-only

Description

Add a window to the display. Does not add a measurement. The window number must not already exist.

VB Syntax

wins.Add [item]

Variable

(Type) - Description

wins

A NAWindow collection (object)

item

(variant) - optional argument; Window number. Range between 1 - 4

Return Type

Object

Default

Not Applicable

Examples

wins.Add 3 'Creates a window number 3

C++ Syntax

HRESULT raw_Add(long windowNumber )

Interface

INAWindows


Add (segments) Method

About Segment Sweep

Add (segment) Method

Write-only

Description

Adds segments to the Segments collection, but does not turn the segments ON.

VB Syntax

segs.Add (item, [size])

segs

A segments collection (object)

item

(variant) Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

None

Examples

Segs.Add 1, 4 'Adds segments 1,2,3,and 4. (does NOT automatically turn segments ON)

C++ Syntax

HRESULT raw_Add(VARIANT index, long size);

Interface

ISegments

Remarks

To ensure predictable results, it is best to remove all segments before defining a segment list. For each segment in the collection, do a seg.Remove.


About Analyzer Events

AllowAllEvents Method

Write/Read

Description

Sets event filtering to monitor all events in the analyzer. This is the default setting when subscribing to events. This could slow the measurement speed of the analyzer significantly.

VB Syntax

app.AllowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowAllEvents

C++ Syntax

HRESULT AllowAllEvents()

Interface

IApplication


About Analyzer Events

AllowEventCategory Method

Write/Read

Description

Sets event filtering to monitor a category of event.

VB Syntax

app.AllowEventCategory, category, state

Variable

(Type) - Description

app

An Application (object)

category

Category to monitor. Choose from list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventCategory

C++ Syntax

HRESULT AllowEventCategory(tagNAEventCategory category, VARIANT_BOOL bAllow )

Interface

IApplication

Type topic text here.


About Analyzer Events

AllowEventMessage Method

Write/Read

Description

Sets event filtering to monitor specific events.

VB Syntax

app.AllowEventMessage event

Variable

(Type) - Description

app

An Application (object)

event

Event to monitor. Refer to list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventMessage

C++ Syntax

HRESULT AllowEventMessage( tagNAEventID eventID, VARIANT_BOOL bAllow)

Interface

IApplication


About Analyzer Events

AllowEventSeverity Method

Write/Read

Description

Sets event filtering to monitor levels of severity.

VB Syntax

app.AllowEventSeverity severity,state

Variable

(Type) - Description

app

An Application (object)

severity

(enum naEventSeverity) Choose from:naEventSeverityERROR
naEventSeverityINFORMATIONAL
naEventSeveritySUCCESS
naEventSeverityWARNING

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventSeverity

C++ Syntax

HRESULT AllowEventSeverity( tagNAEventSeverity severity, VARIANT_BOOL bAllow)

Interface

IApplication


About Display Formatting

Autoscale Method

Write-only

Description

Autoscales the trace (Trace object) or all of the traces (NAWindow object).

VB Syntax

object.Autoscale

Variable

(Type) - Description

object

Trace (object)
or
NAWindow (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Trac.Autoscale 'Autoscales the trace
Win.Autoscale 'Autoscales all the traces in the window -Write

C++ Syntax

HRESULT raw_AutoScale()

Interface

INAWindow
ITrace


Averaging Restart Method

About Averaging

AveragingRestart Method

Write-only

Description

Clears and restarts averaging of the measurement data.

VB Syntax

chan.AveragingRestart

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.AveragingRestart

C++ Syntax

HRESULT raw_AveragingRestart()

Interface

IChannel


Build Hybrid Kit Method

About Modifying Cal Kits

BuildHybridKit Method

Write-only

Description

Use this method when you have different port connectors. This is a convenient way to combine two kits that match the connectors on your DUT.

VB Syntax

app.BuildHybridKit port1Kit,p1sex,port2Kit,p2sex,adapter,user kit

Variable

(Type) - Description

app

An Application (object)

port1Kit
port2Kit

(enum NACalKit) - Specifies the two kits to be used to build the hybrid kit. Choose from:

naCalKit_85032F_N50
naCalKit_85033E_3_5
naCalKit_85032B_N50
naCalKit_85033D_3_5
naCalKit_85038A_7_16
naCalKit_85052C_3_5_TRL
naCalKit_User7
naCalKit_User8
naCalKit_User9
naCalKit_User10

p1sex
p2sex

(enum NAPortSex) - Specifies the sex of the connector at that port. Choose from:
naMale
naFemale
naDon'tCare

adapter

(enum NAAdapter) -Choose from:
naUserkit - the electrical length of the adapter in the userKit specifications
naZeroLength - no adapter

userKit

(enum NACalKit) - The Hybrid kit - Choose from the previous list of kits

Return Type

Not Applicable

Default

Not Applicable

Examples

app.BuildHybridKit naCalKit_85033E_3_5,naMale,naCalKit_85038A_7_16
,naFemale,naUserkit,naCalKit_User8

C++ Syntax

HRESULT raw_BuildHybridKit\(tagNACalKit port1Kit, tagNAPortSex port1Sex, tagNACalKit port2Kit, tagNAPortSex port2Sex, tagNAAdapter adapter, tagNACalKit userKit)

Interface

IApplication


Calculate Error Coefficients Method

About Performing a Calibration

CalculateErrorCoefficients Method

Write-only

Description

This method is the final call in a calibration process. It calculates error-correction terms and turns error-correction ON.

VB Syntax

cal.CalculateErrorCoeffecients

Variable

(Type) - Description

cal

Calibrator (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Cal.CalculateErrorCoeffecients

C++ Syntax

HRESULT raw_CalculateErrorCoefficients()

Interface

ICalibrator


Change Parameter Method

About Measurement Parameters

ChangeParameter Method

Write-only

Description

Changes the parameter of the measurement.

VB Syntax

meas.ChangeParameter(param,sourcePort)

Variable

(Type) - Description

meas

A Measurement (object)

param

(string) - New parameter. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine any 2 of (A,B,R1,R2) in this format: "A/R1"

sourcePort

(long integer) - Port number of the source. Used only for non-sparameter measurements.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.ChangeParameter "S11",1

C++ Syntax

HRESULT raw_ChangeParameter(BSTR parameter, long sourcePort)

Interface

IMeasurement


About Triggering

Continuous Method

Write-only

Description

The channel continuously responds to trigger signals.

Note: This command does NOT change TriggerSignal to Continuous.

VB Syntax

chan.Continuous

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.Continuous

C++ Syntax

HRESULT raw_Continuous()

Interface

IChannel


Create SParameter Method

About Measurement Parameters

CreateS-Parameter Method

Write-only

Description

Creates a new S-Parameter measurement in an existing or new window.

VB Syntax

app.CreateSParameter chan,recvr,source,[window]

Variable

(Type) - Description

app

Application (object)

chan

(long integer) - Channel number of the new measurement

recvr

(long integer) - Port number of the receiver (1 or 2)

source

(long integer) - Port number of the source (1 or 2)

window

(long integer) - Window number of the new measurement. Choose 1 to 4. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateSParameter 1,2,1,1 'Creates a new S21 measurement in channel 1 and New window(1) app.CreateSParameter 1,2,1 'Creates a new S21 measurement in channel 1 and in the active window

C++ Syntax

HRESULT raw_CreateSParameter(long ChannelNum, long RcvPort, long SrcPort, long windowNumber)

Interface

IApplication


About Measurement Parameters

CreateMeasurement Method

Write-only

Description

Creates a new measurement.

VB Syntax

app.CreateMeasurement chanNum,param,src[,window]

Variable

(Type) - Description

app

Application (object)

chanNum

(long) - Channel number of the new measurement; can exist or be a new channel

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

src

(long) - Source Port. Choose 1 or 2 (ignored if param = Sparameter)

window

(long) Optional argument. Number of the window the measurement will be in. Choose 1 to 4. If unspecified, window is the active window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateMeasurement(1,"A/R1",1,0)

C++ Syntax

HRESULT raw_CreateMeasurement(long ChannelNum, BSTR strParameter, long srcPort, long windowNumber)

Interface

IApplication


About Math Operations

DataToMemory Method

Write-only

Description

Stores the active measurement data into memory creating a memory trace. The memory can then be displayed or used in calculations with the measurement data.

VB Syntax

meas.DataToMemory

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DataToMemory

C++ Syntax

HRESULT raw_DataToMemory()

Interface

IMeasurement


About Measurement Parameters

Delete Method

Write-only

Description

Deletes the measurement.

VB Syntax

meas.Delete

Variable

(Type) - Description

meas

The Measurement object to delete (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Delete

C++ Syntax

HRESULT raw_Delete()

Interface

IMeasurement


Delete Marker Method

About Markers

DeleteMarker Method

Write-only

Description

Deletes a marker from the measurement.

VB Syntax

meas.DeleteMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long) - Any existing marker number in the measurement

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteMarker(1)

C++ Syntax

HRESULT raw_DeleteMarker(long lMarkerNumber)

Interface

IMeasurement


About Markers

DeleteAllMarkers Method

Write-only

Description

Deletes all of the markers from the measurement.

VB Syntax

meas.DeleteAllMarkers

Variable

(Type) - Description

meas

(object) - The Measurement object from which markers will be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteAllMarkers

C++ Syntax

HRESULT raw_DeleteAllMarkers()

Interface

IMeasurement


About Macros

DeleteShortCut Method

Write-only

Description

Removes a macro from the list of macros in the analyzer. Does not remove the file.

Note: There are always 12 macro positions. They do not have to be sequential. For example, you can have number 7 but no numbers 1 to 6.

VB Syntax

app.DeleteShortCut item

Variable

(Type) - Description

app

An Application (object)

item

(long integer) number of the macro to be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DeleteShortCut 2

C++ Syntax

HRESULT DeleteShortcut(long Number )

Interface

IApplication


About Reference Markers

DeltaMarker Property

Write/Read

Description

Sets a marker as a delta marker. The reference marker must already be turned ON. See meas.ReferenceMarkerState

VB Syntax

mark.DeltaMarker = state

Variable

(Type) - Description

app

A Marker (object)

state

(boolean) -
ON (1) marker is a delta marker
OFF (0) marker is NOT a delta marker

Return Type

Boolean

Default

OFF (0)

Examples

mark.DeltaMarker = True 'Write

delta = mark.DeltaMarker 'Read

C++ Syntax

HRESULT get_DeltaMarker(VARIANT_BOOL bState)
HRESULT put_DeltaMarker(VARIANT_BOOL *bState)

Interface

IMarker


About Analyzer Events

DisallowAllEvents Method

Write/Read

Description

Sets event filtering to monitor NO eventst.

VB Syntax

app.DisallowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DisallowAllEvents

C++ Syntax

HRESULT raw_DisallowAllEvents()

Interface

IApplication

Type topic text here.


Do Print Method

About Printing

DoPrint Method

Write-only

Description

Prints the screen to the default Printer.

VB Syntax

app.DoPrint

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DoPrint

C++ Syntax

HRESULT raw_DoPrint()

Interface

IApplication


About Calibration

DoECAL1Port Method

Write-only

Description

Does a 1-Port calibration using an ECAL module. You must first have a 1-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL1Port[,port][,module]

Variable

(Type) - Description

app

A Calibrator (object)

port

(long integer) Optional argument - Port number to calibrate. Choose from:
1 - Calibrate port 1 (default if unspecified)
2 - Calibrate port 2

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL1Port,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL1Port(long port, tagNAECALModule ecalModule)

Interface

ICalibrator


About Calibration

DoECAL2Port Method

Write-only

Description

Does a 2-Port calibration using an ECAL module. You must first have a 2-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL2Port[,portA][,portB][,module]

Variable

(Type) - Description

app

A Calibrator (object)

portA

(long integer) Optional argument - Receiver ports to calibrate. Choose from:
1 - port 1 (default if unspecified)
2 - port 2

portB

(long integer) Optional argument - Source port to calibrate. Choose from:
1 - port 1
2 - port 2 (default if unspecified)

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL2Port,1,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL2Port(long rcvport, long srcPort, tagNAECALModule ecalModule)

Interface

ICalibrator


Execute Shortcut Method

About Macros

ExecuteShortcut Method

Write-only

Description

Executes a Macro (shortcut) stored in the analyzer. Use app.getShortcut to list existing macros. Use app.putShortcut to associate the macro number with the file.

VB Syntax

app.ExecuteShortcut index

Variable

(Type) - Description

app

Application (object)

index

(long integer) - Number of the macro stored in the analyzer.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ExecuteShortcut 1

C++ Syntax

HRESULT raw_ExecuteShortcut(long index)

Interface

IApplication


Get Cal Standard Method

About Modifying Cal Kits

GetCalStandard Method

Write-only

Description

Returns a handle to a calibration standard for modifying its definitions. To select a standard for performing a calibration (use Calibrator. AquireCalStandard ).

VB Syntax

calkit.GetCalStandard(index)

Variable

(Type) - Description

calkit

A calKit (object)

index

(long) - Number of calibration standard. Choose 1 to 8; (there are 8 cal standards in every kit).

Return Type

calStandard

Default

Not Applicable

Examples

Dim short As CalStandard
Set short = calKit.getCalStandard(1)
short.label = "myShort"

C++ Syntax

HRESULT raw_GetCalStandard(long standardNumber, ICalStandard **pCalStd)

Interface

ICalKit


Get Complex Method

Data Access Map

GetComplex Method

Read-only

Description

Retrieves complex data from the specified location.
See also getNAComplex , getData , and getPairedData Methods

VB Syntax

measData.getComplex location, numPts, real(), imag()

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the arrays

real

(single) - Array to store the real values

imag

(single) - Array to store the imaginary values

Return Type

Single

Default

Not Applicable

Examples

Dim real(201) AS Single
Dim imag(201) AS Single
Dim pts as Integer
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
measData.getComplex naCorrectedData, pts, real(0), imag(0)

C++ Syntax

HRESULT raw_getComplex(tagNADataStore DataStore, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Data Method

About Accessing Data

GetData Method

Read-only

Description

Retrieves variant data from the specified location in your choice of formats.

Note: This method returns a variant which is less efficient than methods available on the IArrayTransfer interface.

Note: If you plan to Put this data back into analyzer, putDataComplex (variant data) method requires complex, two-dimensional data. Therefore, request the data in Polar format.

VB Syntax

data = meas.GetData location, format

Variable

(Type) - Description

data

Variant array to store the data.

meas

A Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NADataFormat) - Format in which you would like the data. It does not have to be the displayed format. Choose from:

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Polar *

  • naDataFormat_Smith *

  • naDataFormat_Delay

  • naDataFormat_Real

  • naDataFormat_Imaginary

  • naDataFormat_SWR

* Specfiy Smith or Polar formats to obtain complex data pairs, which require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All scalar formats return a single dimension varData(numpts).

Return Type

Variant array - automatically dimensioned to the size of the data

Default

Not Applicable

Examples

Dim varData As Variant
varData = meas.GetData(naMeasResult,naDataFormat_Phase)
'Print Data
For i = 0 to chan.NumberOfPoints-1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_getData(tagNADataStore DataStore, tagDataFormat DataFormat, VARIANT *pData)

Interface

IMeasurement


Get ECAL Module Info Method

GetECALModuleInfo Method

Read-only

Description

Returns the following information about the connected ECAL module: model number, serial number, connector type,calibration date, min and max frequency.

VB Syntax

module = cal.GetECALModuleInfo

Variable

(Type) - Description

module

(string) - variable to store the module information

cal

A Calibrator (object)

Return Type

String - Returned information:

Default

Not Applicable

Examples

info = cal.GetECALModuleInfo

Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F RF2, Calibrated: 5 Jun 2000 , MinFreq: 50000000, MaxFreq: 9100000000

C++ Syntax

HRESULT raw_GetECALModuleInfo(tagNAECALModule ecalModule, BSTR* info)

Interface

ICalibrator


Get Error Term Complex Method

About Accessing Data

GetErrorTermComplex Method

Read-only

Description

Retrieves error term data from the error correction buffer.The data is in complex pairs.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetErrorTerm Method on ICalibrator.

VB Syntax

eData.GetErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

eData

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the error-term. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the error-term. One-dimensional for the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2

Return Type

Single

Default

Not Applicable

Examples

ReDim rel(numpts)
ReDim img(numpts)
Dim eData As ICalData
Set eData = chan.Calibrator
eData.getErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_getErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Error Term Method

About Measurement Calibration

GetErrorTerm Method

Read-only

Description

Retrieves error term data that is used for error correction. The data is complex pairs. Memory for the returned Variant is allocated by the server. The server returns a variant containing a two-dimensional safe Array.

Note: This method returns a variant which is less efficient than getErrorTermComplex on the ICalData interface.

VB Syntax

data = cal.getErrorTermterm, src, rcv

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

term

(enum As NaErrorTerm). Choose from:

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Variant

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.getErrorTerm(naErrorTerm_Tracking,2,1)

C++ Syntax

HRESULT raw_getErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Filter Statistics Method

About Marker Search

GetFilterStatistics Method

Read-only

Description

Returns all four Filter Statistics resulting from a SearchFilterBandwidth.
To retrieve individual filter statistics, use meas.FilterCF, meas.FilterBW, meas.FilterLoss, meas.FilterQ properties.

VB Syntax

meas.GetFilterStatistics cf,bw,loss,q

Variable

(Type) - Description

meas

A Measurement (object)

cf,bw,loss,q

Dimensioned variables to store the returned values

Return Type

(double) cf
(single) bw,loss,q

Default

Not Applicable

Examples

'Dimension variables
Dim cf as Double
Dim bw as Single
Dim loss as Single
Dim q as Single

meas.GetFileterStatistics cf,bw,loss,q

C++ Syntax

HRESULT raw_GetFilterStatistics(double* centerFreq, float* bw, float* loss, float* quality)

Interface

IMeasurement


Get NAComplex Method

About Accessing Data

GetNAComplex Method

Read-only

Description

Retrieves complex data from the specified locations.
See also getComplex and getData Method.

VB Syntax

measData.getNAComplex location, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dComplex array

data

(NAComplex) - A one-dimensional array of NaComplex to store the data.

Return Type

NAComplex

Default

Not Applicable

Examples

Dim dComplex(201) AS NaComplex
Dim measData As IArrayTransfer
Dim pts as Long
Set measData = app.ActiveMeasurement
measData.getNAComplex naCorrectedData, pts, dComplex(0)

Notes

The data is stored as Real and Imaginary (Re and Im) members of the NaComplex user defined type. You can access each number individually by iterating through the array.

For i = 0 to NumPts-1
dReal (i) = dcomplex (i).Re
dImag (i) = dcomplex (i).Im
Next i

C++ Syntax

HRESULT raw_getNAComplex(tagNADataStore DataStore, long* pNumValues, TsComplex* pComplex)

Interface

IArrayTransfer


Get Paired Data Method

About Accessing Data

GetPairedData Method

Read-only

Description

Retrieves pairs of data from specified location.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

VB Syntax

measData.getPairedData location, format, numPts, d1, d2

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NAPairedDataFormat) - Format in which you would like the Paired data. Choose from:

  • naLinMagPhase - Linear magnitude and phase

  • naLogMagPhase - Log magnitude and phase

  • naRealImaginary - Real and Imaginary

Note: Selecting naRealImaginary format is the same as using the getComplex method

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dPaired array

d1

(single) - Array to store the magnitude / real values

d2

(single) - Array to store the phase / imaginary values

Return Type

Two Single arrays

Default

Not Applicable

Examples

Dim logm() As Single
Dim phase() As Single
Public measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts As Long
numPoints = app.ActiveChannel.NumberOfPoints
ReDim logm(numPoints)
ReDim phase(numPoints)

measData.getPairedData naCorrectedData, naLogMagPhase, numPoints, logm(0),
 phase(0)

Print values(0), values(1)

C++ Syntax

HRESULT raw_getPairedData(tagNADataStore DataStore, tagNAPairedDataFormat PairFormat, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Reference Marker Method

About Reference Markers

GetReferenceMarker Method

Write/Read

Description

Returns a handle to the reference marker.

VB Syntax

meas.GetReferenceMarker

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Object

Default

Not Applicable

Examples

meas.GetReferenceMarker

C++ Syntax

HRESULT raw_GetReferenceMarker(IMarker** refMarker)

Interface

IMeasurement


Get Scalar Method

About Accessing Data

GetScalar Method

Read-only

Description

Retrieves scalar data from the specified locations.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

Note: You can NOT use this command to get complex data.

VB Syntax

measData.getScalar location, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum DataFormat) - Scalar format in which you would llike the data. Choose from:

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dScalar array

data

(single) - Array to store the scalar data.

Return Type

Single

Default

Not Applicable

Examples

Dim dScalar() As Single
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts as Long
numpts = app.ActiveChannel.NumberOfPoints
ReDim dScalar(numPoints)

measData.getScalar naCorrectedData, naDataFormat_LogMag, numpts, dScalar(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_getScalar(tagNADataStore DataStore, tagDataFormat DataFormat, long* pNumValues, float* pVals)

Interface

IArrayTransfer


Get Shortcut Method

About Macros

GetShortcut Method

Read-only

Description

Returns the Title, Path, and optional argument strings, of the specified Macro (shortcut). Use this method to list the titles and paths of macros in the analyzer.

VB Syntax

app.GetShortcut index, title, path, arguments

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro. Use a number between 1 and 12.

title

(string) - Title of the specified macro. (Appears in the softkey label)

path

(string) - Pathname of the specified macro.

arguments

(string) - Arguments for the specified macro

Return Type

String

Default

Not Applicable

Example

Dim t As String
Dim p As String
Dim arg As String
Dim i As Integer
For i = 1 to 12
app.GetShortcut i,t,p,arg
Print t,p
Next

C++ Syntax

HRESULT raw_GetShortcut(long Number, BSTR* title, BSTR* pathname, BSTR* arguments)

Interface

IApplication

Remarks

Shortcuts can also be defined and accessed using the macro key on the front panel. However, the benefit of this feature is primarily for the interactive user


Get Standard Method

About Measurement Calibration

GetStandard Method

Read-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method returns a variant which is less efficient than getStandardComplex on the ICalData interface.

VB Syntax

data = cal.getStandardclass,rcv,src

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

(variant) - two-dimensional array (0:1, 0:NumberOfPoints-1)

Default

Not Applicable

Examples

Dim varStd As Variant
varStd = cal.getStandard(naSOLT_Thru,2,1)

C++ Syntax

HRESULT raw_getStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Standard Complex Method

About Accessing Data

GetStandardComplex Method

Write-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetStandard Method on ICalibrator.

VB Syntax

ICalData.getStandardComplex class, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

ICalData

An ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the calibration data. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the calibration data. One-dimensional for the number of data points.

Return Type

(single)

Default

Not Applicable

Examples

Dim rel(200) As Single
Dim img(200) As Single
Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.getStandardComplex naSOLT_Open, 1, 1, numpts, rel(0), img(0)

C++ Syntax

HRESULT raw_getStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Test Result Method

About Limit Testing

GetTestResult Method

Read-only

Description

Returns the result of limit line testing. There are three ways to use this command:

  • If neither optional parameter is specified, limit results for ALL data is returned.

  • If one parameter is specified (start), the limit result for that data point is returned.

  • If both parameters are specified, limit results are returned beginning with start, and ending with (start+size)-1

VB Syntax

testRes = limts.GetTestResult[start,size]

Variable

(Type) - Description

testRes

(enum NALimitTestResult) - A dimensioned variable to store test results

0 - naLimitTestResult_None
1 - naLimitTestResult_Fail
2 - naLimitTestResult_Pass

limts

A LimitTest (object)

start

(long) - Optional argument. A start data point number to return limit test results.

size

(long) - Optional argument. Number of data points from start to return limit test results.

Return Type

Long Integer

Default

Not Applicable

Examples

Dim testRes As NALimitTestResult
testRes = limts.GetTestResult
Select Case testRes

Case 0
Print "No Test Result"

Case 1
Print "Fails"

Case 2
Print "Pass"

End Select

C++ Syntax

HRESULT raw_GetTestResult(long lStart, long lSize, tagNALimitTestResult *pVal)

Interface

ILimitTest


Get Trace Statistics Method

About Trace Statistics

GetTraceStatistics Method

Read-only

Description

Returns all four Trace Statistics. To retreive individual Trace statistics, use Mean, PeakToPeak, StandardDeviation properties. Use ShowStatistics to display the statistics of the screen.

VB Syntax

meas.GetTraceStatistics pp,mean,stdev

Variable

(Type) - Description

meas

A Measurement (object)

pp,mean,stdev

(double) - Dimensioned variables to store the returned values

Return Type

Double

Default

Not Applicable

Examples

'Dimension variables
Dim pp As Double
Dim mean As Double
Dim stdv As Double
meas.GetTraceStatistics pp, mean, stdv

C++ Syntax

HRESULT raw_GetTraceStatistics(double* pp, double* mean, double* stdDeviation)

Interface

IMeasurement


Get X-Axis Values 2

About Segment Sweep

GetX-axisValues2 Method

Write-only

Description

Returns the channel's X-axis values into a dimensioned Typed array. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetXAxisValues Method on IChannels.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

chanData.GetXAxisValues2 numPts,data

Variable

(Type) - Description

chanData

An IArrayTransfer pointer to the channel object.

numPts

(long integer) - Number of data points in the channel

data

(double) single dimensioned array of data matching the number of points in the channel.

Return Type

Double

Default

Not Applicable

Examples

Dim numPoints As Long
Dim values() As Double
numPoints = app.ActiveChannel.NumberOfPoints
ReDim values(numPoints)
app.ActiveChannel.GetXAxisValues2 numPoints, values(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_GetXAxisValues2(long* pNumValues, double* stimulus)

Interface

IChannel


Get X-axis Values Method

About Segment Sweep

GetXAxisValues Method

Read-only

Description

Returns the channel's X-axis values. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method returns a variant which is less efficient than GetXAxisValues2.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

data = chan.GetXAxisValues

Variable

(Type) - Description

data

Variant array to store the data.

chan

A Channel (object)

Return Type

Variant

Default

Not Applicable

Examples

Dim varData As Variant
Dim i As Integer
varData = chan.GetXAxisValues
'Print Data
For i = 0 To chan.numpts - 1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_GetXAxisValues (VARIANT* xData)

Interface

IChannel


About Triggering

Hold Method

Write-only

Description

Puts the Channel in Hold - not sweeping.

VB Syntax

chan.Hold [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) - Optional argument. A variable set to either True or False.

True - program control waits until the channel is in the Hold state.
False - program control continues immediately. You are not guaranteed the channel is in Hold yet.

Return Type

Not Applicable

Default

Not Applicable

Examples

wate = True
chan.Hold wate

C++ Syntax

HRESULT raw_Hold(VARIANT_BOOL bWait)

Interface

IChannel


Item Method

Write-only

Description

Returns an object from the collection of objects.

Note: The order of objects within a collection cannot be assumed.

VB Syntax

Object[.Item](n)

Variable

(Type) - Description

Object

Any of the following (objects):
Channels collection
LimitTest collection
Measurements collection
NaWindows collection
Traces collection
Segments collection

.Item

Optional - Item is the default property of a collections object and therefore can be called implicitly. For example, the following two commands are equivalent:

Channels.Item(3).Averaging = 1
Channels(3).Averaging = 1

n

(variant) - number of the item in the collection.

Note: the Measurements and Traces collections allow you to specify the name of the measurement as a string. For example: measCollection("CH_S11_1").InterpolateMarkers

Return Type

(Object)

Default

Not Applicable

Examples

For i = 1 to Traces.Count -1
Traces.Item(i).YScale = .5dB
Next i

C++ Syntax

HRESULT raw_Item(VARIANT index, <interface>** pItem)

Interface

IChannels
ILimitTest
IMeasurements
INaWindows
ITraces
ISegments


Manual Trigger Method

About Triggering

ManualTrigger Method

Write-only

Description

Triggers the analyzer when TriggerSignal = naTriggerManual.

VB Syntax

app.ManualTrigger [sync]

Variable

(Type) - Description

app

Application (object)

sync

(boolean) - Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim wait as Boolean
wait = True
app.ManualTrigger wait

C++ Syntax

HRESULT raw_ManualTrigger(VARIANT_BOOL bSynchronize, long timeout)

Interface

IApplication


Message Text Method

About Analyzer Events

MessageText Method

Write/Read

Description

Returns text for the specified eventID

VB Syntax

app.MessageText,eventID,message

Variable

(Type) - Description

app

An Application (object)

enentID

(enum naEventID) Choose from the list in Working with the Analyzer's Events

message

(string) - variable to store the returned message

Return Type

String

Default

Not Applicable

Examples

RFNA.MessageText naEventID_ARRANGE_WINDOW_EXCEED_CAPACITY, message

C++ Syntax

HRESULT raw_MessageText( tagNAEventID msgID, BSTR* message)

Interface

IApplication

Type topic text here.


Next IF Bandwidth Method

About Dynamic Range

NextIFBandwidth Method

Write-only

Description

A function that returns the Next higher IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Next_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the Next higher IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

pnBW = chan.IFBandwidth 'put the current IFBW in pnBW
chan.Next_IFBandwidth pnBW 'function returns the Next higher IFBandwidth.
chan.IFBandwidth = pnBW 'set IFBW to the Next value

C++ Syntax

HRESULT raw_Next_IFBandwidth (double *pVal)

Interface

IChannel


Number Of Groups Method

About Triggering

NumberOfGroups Method

Write-only

Description

Sets the Number of trigger signals the channel will receive. After the channels has received that number of trigger signals, the channel switches to Hold mode.

To begin sweeping the number of groups, send app.Continuous

VB Syntax

chan.NumberOfGroups num, sync

Variable

(Type) - Description

chan

A Channel (object)

num

(long integer) Number of trigger signals the channel will receive. Choose any number between 1 and 2 million

sync

(boolean)
Variable set to either:
True - subsequent commands are not processed until the groups are complete. Do not use with manual trigger.
False - subsequent commands are processed immediately

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.NumberOfGroups

C++ Syntax

HRESULT raw_NumberOfGroups(long count, VARIANT_BOOL bWait)

Interface

IChannel


SCPI Command Tree

Parse Method

Write-Read

Description

Executes a SCPI command.

VB Syntax

scpi.Parse ("SCPI command")

Variable

(Type) - Description

scpi

A ScpiStringParser (object)

SCPI command

(string) - Any valid SCPI command

Return Type

String

Default

Not Applicable

Examples

Dim scpi As ScpiStringParser
Set scpi = app.ScpiStringParser
Dim startfreq As Double
startfreq = 100e6
'
scpi.Parse ("Sens:Freq:Start " & startfreq)'Write

Dim str As String
str = scpi.Parse ("Sens:Freq:Start?")'Read

C++ Syntax

HRESULT raw_Parse(BSTR SCPI_Command, BSTR *pQueryResponse)

Interface

IScpiStringParser


Factory Preset Settings

Preset Method

Write-only

Description

Application Object: Deletes all traces and windows. In addition, resets the analyzer to factory defined default settings and creates an S11 measurement named "CH1_S11_1" in window 1.

Channel Object: Resets the channel (object) to factory defined default settings. Does NOT delete the current measurements or add a new measurement.

VB Syntax

app.Preset
chan.Preset

Variable

(Type) - Description

app

An Application (object)

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Preset

C++ Syntax

HRESULT raw_Preset()

Interface

IApplication
IChannel

.


Previous IF Bandwidth Method

About Dynamic Range

PreviousIFBandwidth Method

Write-only

Description

A function that returns the previous IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Previous_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the previous IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

PreBW = chan.IFBandwidth 'put the current IFBW in PreBW
chan.Previous_IFBandwidth PreBW 'function returns the Previous IFBandwidth of the current one.
chan.IFBandwidth = PreBW 'set IFBW to the previous value

C++ Syntax

HRESULT raw_Previous_IFBandwidth (double *pVal)

Interface

IChannel


About Saving to File

PrintToFile Method

Write-only

Description

Saves the screen image to a bitmap (.bmp) file.

VB Syntax

app.PrintToFile filename

Variable

(Type) - Description

app

An Application (object)

filename

(string) Name of the file to save the screen to. If you don't provide a suffix, the analyzer will append .bmp. The file is saved to the current working directory unless a valid full path name is specified.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PrintToFile "myfile"
app.PrintToFile "c:\data\myfile.bmp"

C++ Syntax

HRESULT raw_PrintToFile(BSTR bstrFile)

Interface

IApplication


Put Complex Method

About Accessing Data

PutComplex Method

Write-only

Description

Puts real and imaginary data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in the raw data store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the measurement results store will be overwritten by any measurement attribute changes.

See also putNAComplex

VB Syntax

measData.putComplex location, numPts, real(), imag(), [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

real()

(single) - Array containing real data values

imag()

(single) -Array containing imaginary data values

format

(enum NADataFormat) optional argument - display format of the real and imaginary data. Only used if destination is naMeasResult or naMemoryResult buffer. If unspecified, data is assumed to be in naDataFormat_Polar

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

  • naDataFormat_Smith

  • naDataFormat_Polar

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putComplex naMemoryResult, 201, real(0),imag(0),naDataFormat_SWR

C++ Syntax

HRESULT raw_putComplex( tagNADataStore DataStore, long lNumValues, float* pReal, float* pImag, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Data Complex Method

About Accessing Data

PutDataComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in naRawData (location) will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in naMeasurement (location) will be overwritten by any measurement attribute changes.

VB Syntax

meas.putDataComplex location, data

Variable

(Type) - Description

meas

A measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

data

(variant) - A two-dimensional variant array.

Note: All buffers except naMeasResult and naMemoryResult require Complex data

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.putDataComplex naMeasResult, varData

C++ Syntax

HRESULT raw_putDataComplex(tagNADataStore DataStore, VARIANT complexData)

Interface

IMeasurement


Put Data Scalar Method

About Accessing Data

PutDataScalar Method

Write-only

Description

Puts formatted variant scalar data into the measurement result buffer. The data will be immediately processed and displayed. Subsequent changes to the measurement state will be reflected on the display.

VB Syntax

meas.putDataScalar format, data

Variable

(Type) - Description

meas

A measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
4 - naDataFormat_Polar *
5 - naDataFormat_Smith *
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

* Smith and Polar formats require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All other formats are a single dimension varData(numpts).

data

(variant) - A two-dimensional complex variant data array.

Note: The getData (variant) method includes a "format" argument, which allows scalar (one-dimensional) data. To put data back into the "raw" data buffer using this (putDataComplex) method, specify Polar format when using the getData method.

Return Type

Not Applicable

Default

Not Applicable

Examples

measData.putDataScalar naDataFormat_Real, varData

C++ Syntax

HRESULT raw_putDataScalar(tagNADataStore DataStore, VARIANT complexScalar)

Interface

IMeasurement


Put Error Term Method

About Measurement Calibration

PutErrorTerm Method

Write-only

Description

Puts variant error term data into the error-correction buffer. See Accessing data.

VB Syntax

cal.putErrorTerm(term,src,rcv,data)

Variable

(Type) - Description

cal

A Calibrator (object)

term

(enum As NaErrorTerm)

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

data

(variant) Error term data in a two-dimensional array (0:1, 0:numpts-1).

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.putErrorTerm (naErrorTerm_Tracking,2,1,VarData)

C++ Syntax

HRESULT raw_putErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Error Term Complex Method

About Accessing Data

PutErrorTermComplex Method

Write-only

Description

Puts error term data into the error-correction data buffer.

VB Syntax

data.putErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

data

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the array

real()

(single) - array containing the real part of the calibration data. One-dimensional: the number of data points.

imag()

(single) - array containing the imaginary part of the calibration data. One-dimensional: the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim eData As ICalData
Set eData = chan.Calibrator
eData.putErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Put Scalar Method

About Accessing Data

PutScalar Method

Write-only

Description

Puts Scalar data in the Measurement Result buffer. The putScalar array is not processed by the analyzer; it is just displayed. Any change to the measurement state (changing the format, for example) will cause the putScalar data to be overwritten with the data processed from the raw data buffer.

VB Syntax

measData.putScalar, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

Note: Smith and Polar formats are not allowed.

numPts

(integer) - Number of values. Usually the number of points in the trace (chan.NumberOfPoints).

data

(single) - A one-dimensional array of Scalar data matching the number of points in the current measurement.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putScalar naDataFormat_LogMag, 201, dScalar(0)

C++ Syntax

HRESULT raw_putScalar\(tagDataFormat eFormat, long lNumValues, float* pArrayOfScalar)

Interface

IArrayTransfer


Put NA Complex Method

About Accessing Data

PutNAComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten. The data is processed and displayed.

Data put in the naRawData store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the naMeasResult store will be overwritten by any measurement attribute changes (such as moving a marker).

Note: This method uses NAComplex which is a user-defined data type. If you cannot or prefer not to use this data type, use the putComplex method.

VB Syntax

measData.putNAComplex location, numPts, data, [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

data

(NAComplex) - A one-dimensional array of Complex data matching the number of points in the current measurement.

format

(enum NADisplayFormat) - Optional argument. Format of the data. If unspecified, naDataFormat_Polar is assumed. Only used when the destination store is naMeasResult or naMemoryResult.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putNAComplex naMemoryResult, 201, dRawComplex(0)

C++ Syntax

HRESULT raw_putNAComplex(tagNADataStore DataStore, long lNumValues, TsComplex* pArrayOfComplex, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Shortcut Method

About Macros

PutShortcut Method

Write-only

Description

Defines a Macro (shortcut) file in the analyzer. This command links a file name and path to the Macro file. You still need to put the macro file in the analyzer at the location indicated by this command.

VB Syntax

app.PutShortcut index,title,path

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro to be stored in the analyzer. If the index number already exists, the existing macro is replaced with the new macro.

title

(string) - The name to be assigned to the macro

path

(string) - Full pathname to the existing macro "executable" file.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PutShortcut 1,"Test","C:\Automation\MyTest.vbs"

C++ Syntax

HRESULT raw_PutShortcut(long Number, BSTR title, BSTR pathname)

Interface

IApplication


Put Standard Method

About Accessing Data

PutStandard Method

Write-only

Description

Writes variant data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

cal.putStandard class,rcv,src,data

Variable

(Type) - Description

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long) - Receiver Port

src

(long) - Source Port

data

(variant) Two dimensional array (0:1, 0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varStd (1,200) As Variant
cal.putStandard naSOLT_Thru, 2, 1, varStd

C++ Syntax

HRESULT raw_putStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Standard Complex Method

About Accessing Data

PutStandardComplex Method

Write-only

Description

Writes data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

ICalData.putStandardComplex class,rcv,src, numPts,real(),imag()

Variable

(Type) - Description

ICalData

A ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the arrays being sent.

real()

(single) - one-dimensional array containing the real part of the acquisition data. (0:points-1)

imag()

(single) - one-dimensional array containing the imaginary part of the acquisition data. (0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.putStandardComplex naSOLT_Open, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long lNumValues, float* pReal, float* pImag)

Interface

ICalData


Quit Method

Write-only

Description

Terminates the Network Analyzer application.

VB Syntax

app.Quit

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Quit

C++ Syntax

HRESULT raw_Quit()

Interface

IApplication

Remarks

Under the rules of COM, the server should not exit until all references to it have been released. This method is a brute force way of terminating the application. Be sure to release all references (or terminate the client program) before attempting to restart the Network Analyzer application.

An alternate approach to terminating the application is to make the application invisible (app.Visible = False) and release all references. The server will shutdown.


About Save/Recall

Recall Method

Write-only

Description

Recalls a measurement state, calibration state, or both from the hard drive into the analyzer.

Use app.Save to save the measurement and calibration state.

VB Syntax

app.Recall (filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be recalled.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are stored in the default folder "C:\Program Files\Agilent\Network Analyzer\Documents

To recall from a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Recall (mystate.sta) 'Recalls "mystate.sta" from the default folder
app.Recall ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Recalls "mystate.cst" from the specified folder

C++ Syntax

HRESULT raw_Recall(BSTR bstrFile)

Interface

IApplication


About Modifying Cal Kits

Recall Kits Method

Write-only

Description

Recalls the calibration kits definitions that were stored witht the SaveKits command.

VB Syntax

app.RecallKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RecallKits

C++ Syntax

HRESULT raw_RecallKits()

Interface

IApplication


Remove Method

Write-only

Description

Removes an item from a collection of objects.

VB Syntax

Object.Remove item

Variable

(Type) - Description

Object

Any of the following (objects)

Measurements collection
NAWindows collection
Segments collection

Note: segments has an OPTIONAL argument [size] referring to the number of segments to remove, starting with the item parameter.

item

(variant) - Item number to be removed

Return Type

Not Applicable

Default

Not Applicable

Examples

Measurements.Remove 3 'Removes measurement 3
segments.Remove 2,20 'Removes 20 segments (3 - 22)

C++ Syntax

HRESULT raw_Remove(VARIANT index) //IMeasurements
HRESULT raw_Remove(long windowNumber ) //INaWindows
HRESULT raw_Remove(VARIANT index, long size) //Segments

Interface

IMeasurements
INAWindows
ISegments


About Presetting the Analyzer

Reset Method

Write-only

Description

Removes all existing windows and measurements from the application. (Unlike Preset, does not create a new measurement.)

VB Syntax

app.Reset

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Reset

C++ Syntax

HRESULT raw_Reset()

Interface

IApplication


Restore Cal Kit Defaults Method

About Modifying Cal Kits

RestoreCalKitDefaults Method

Write-only

Description

Restores the original properties of the specified Cal Kit, overwritting the last definition with the factory defaults.

VB Syntax

app.RestoreCalKitDefaults (calKit)

Variable

(Type) - Description

app

Application (object)

calKit

(enum NACalKit) - Calibration Kit to restore. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaults naCalKit_MechKit10

C++ Syntax

HRESULT raw_RestoreCalKitDefaults\(tagNACalKit kit)

Interface

IApplication


Restore Cal Kit Defaults All Method

About Modifying Cal Kits

RestoreCalKitDefaultsAll Method

Write-only

Description

Restores the original properties of ALL of the Cal Kits, overwritting the last definitions with the factory defaults.

VB Syntax

app.RestoreCalKitDefaultsAll

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaultsAll

C++ Syntax

HRESULT raw_RestoreCalKitDefaultsAll()

Interface

IApplication


About Saving Files

Save Method

Write-only

Description

Saves the current measurement state, calibration state, or both, to the analyzer's hard drive. The saved state can be recalled using app.Recall.

VB Syntax

app.Save(filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be saved.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents.

To save to a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Save(mystate.sta) 'Saves "mystate.sta" to the default folder
app.Save("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Saves "mystate.cst" to the specified folder

C++ Syntax

HRESULT raw_Save(BSTR bstrFile)

Interface

IApplication


Save Kits Method

About Modifying Cal Kits

SaveKits Method

Write-only

Description

Saves the cal kits, typically after modifying a calibration kit. To load a cal kit into the analyzer from the hard drive, use app.RecallKits.

VB Syntax

app.SaveKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveKits

C++ Syntax

HRESULT raw_SaveKits()

Interface

IApplication


Search Filter Bandwidth Method

About Marker Search

SearchFilterBandwidth Method

Write-only

Description

Searches the measurement data with the current BandwidthTarget (default is -3). To continually track the filter bandwidth, use BandwidthTracking.

This feature uses markers 1-4. If not already, they are activated. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.SearchFilterBandwidth

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.SearchFilterBandwidth

C++ Syntax

HRESULT raw_SearchFilterBandwidth()

Interface

IMeasurement


Search Max Method

About Marker Search

SearchMax Method

Write-only

Description

Searches the marker domain for the maximum value.

VB Syntax

mark.SearchMax

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMax

C++ Syntax

HRESULT raw_SearchMax()

Interface

IMarker


Search Min Method

About Marker Search

SearchMin Method

Write-only

Description

Searches the marker domain for the minimum value.

VB Syntax

mark.SearchMin

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMin

C++ Syntax

HRESULT raw_SearchMin()

Interface

IMarker


Search Next Peak Method

About Marker Search

SearchNextPeak Method

Write-only

Description

Searches the marker's domain for the next peak value.

VB Syntax

mark.SearchNextPeak

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchNextPeak

C++ Syntax

HRESULT raw_SearchNextPeak()

Interface

IMarker


Search Peak Left Method

About Marker Search

SearchPeakLeft Method

Write-only

Description

Searches the marker's domain for the next VALID peak to the left of the marker.

VB Syntax

mark.SearchPeakLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakLeft

C++ Syntax

HRESULT raw_SearchPeakLeft()

Interface

IMarker


Search Peak Right Method

About Marker Search

SearchPeakRight Method

Write-only

Description

Searches the marker's domain for the next VALID peak
to the right of the marker.

VB Syntax

mark.SearchPeakRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakRight

C++ Syntax

HRESULT raw_SearchPeakRight()

Interface

IMarker


Search Target Method

About Marker Search

SearchTarget Method

Write-only

Description

Searches the marker's domain for the target value (specified with mark.TargetValue). Searches to the right; then at the end of the search domain, begins again at the start of the search domain.

VB Syntax

mark.SearchTarget

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTarget

C++ Syntax

HRESULT raw_SearchTarget()

Interface

IMarker


Search Target Left Method

About Marker Search

SearchTargetLeft Method

Write-only

Description

Moving to the left of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetLeft

C++ Syntax

HRESULT raw_SearchTargetLeft()

Interface

IMarker


Search Target Right Method

About Marker Search

SearchTargetRight Method

Write-only

Description

Moving to the right of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetRight

C++ Syntax

HRESULT raw_SearchTargetRight()

Interface

IMarker


About Performing a Calibration

SetCalInfo Method

Write-only

Description

Specifies the type of calibration. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


Set Center Method

About Marker Functions

SetCenter Method

Write-only

Description

Changes the center stimulus to the stimulus value of the marker. The start stimulus stays the same and the stop is adjusted.

VB Syntax

mark.SetCenter

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCenter

C++ Syntax

HRESULT raw_SetCenter()

Interface

IMarker


Set CW Method

About Markers

SetCW Method

Write-only

Description

Changes the analyzer to sweep type CW mode and sets the CW frequency to the marker's frequency. Does not change anything if current sweep type is other than a frequency sweep.

VB Syntax

mark.SetCW

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCW

C++ Syntax

HRESULT raw_SetCW()

Interface

IMarker


About Marker Functions

SetElectricalDelay Method

Write-only

Description

Changes the measurement's electrical delay to the marker's delay value.

VB Syntax

mark.SetElectricalDelay

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetElectricalDelay

C++ Syntax

HRESULT raw_SetElectricalDelay()

Interface

IMarker


About Analyzer Events

SetFailOnOverRange Method

Write/Read

Description

When set TRUE, configures the analyzer to report outOfRange conditions with an error code. Any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

Note: This method is for the benefit of VB clients. The analyzer automatically adjusts overrange conditions to the closest acceptable setting. The VB user will not See that an overrange occurred because the HRESULT is not returned if it has a success code. For more information, See Events/OverRange.

VB Syntax

app.SetFailOnOverRange state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Overrange conditions report an error code
False (0) - Overrange conditions report a success code

Return Type

Not Applicable

Default

False (0)

VB Example

app.SetFailOnOverRange TRUE
On Error Goto ERRHANDLER

'the following overrange will cause ERRHANDLER to be invoked

channel.StartFrequency = 9.9 GHZ
exit

ERRHANDLER:
print "something failed"

C++ Syntax

HRESULT put_SetFailOnOverRange(VARIANT_BOOL mode)

Interface

IApplication


Set Frequency LowPass Method

About Time Domain

SetFrequencyLowPass Method

Write-only

Description

Set the start frequencies when trans.Mode = LowPass.

VB Syntax

trans.SetFrequencyLowPass

Variable

(Type) - Description

trans

A Transform (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

trans.SetFrequencyLowPass

C++ Syntax

HRESULT raw_SetFrequencyLowPass(void)

Interface

ITransform


About Marker Functions

SetReferenceLevel Method

Write-only

Description

Changes the measurement's reference level to the marker's Y-axis value.

VB Syntax

mark.SetReferenceLevel

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetReferenceLevel

C++ Syntax

HRESULT raw_SetReferenceLevel()

Interface

IMarker


Set Start Method

About Marker Functions

SetStart Method

Write-only

Description

Changes the start stimulus to the stimulus value of the marker. The stop stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStart

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStart

C++ Syntax

HRESULT raw_SetStart()

Interface

IMarker


Set Stop Method

About Marker Functions

SetStop Method

Write-only

Description

Changes the stop stimulus to the stimulus value of the marker. The start stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStop

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStop

C++ Syntax

HRESULT raw_SetStop()

Interface

IMarker


Show Marker Readout Method

About Display Formatting

ShowMarkerReadout Method

Write-only

Description

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window.

VB Syntax

win.ShowMarkerReadout state

Variable

(Type) - Description

win

A NAWindow (object)

state

(boolean) -
True (1) - Show the Marker readout
False (0) - Hide the Marker readout

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowMarkerReadout True

C++ Syntax

HRESULT raw_ShowMarkerReadout(VARIANT_BOOL bState)

Interface

INAWindow


Show Status Bar Method

About Display Formatting

ShowStatusBar Method

Write-only

Description

Shows and Hides the Status Bar. The Status Bar is located across the bottom of the display. The following information is shown for the active measurement:

  • Channel number

  • Parameter

  • Correction On or Off

  • Remote or Local operation

VB Syntax

app.ShowStatusBar state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Status Bar
False (0) - Hide the Status Bar

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStatusBar True

C++ Syntax

HRESULT raw_ShowStatusBar (VARIANT_BOOL bState)

Interface

IApplication


Show Stimulus Method

About Display Formatting

ShowStimulus Method

Write-only

Description

Shows and Hides the Stimulus (X-axis) information located at the bottom of the display. The start and stop stimulus values are shown for the active measurement.

VB Syntax

app.ShowStimulus state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Stimulus information
False (0) - Hide the Stimulus information

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStimulus True

C++ Syntax

HRESULT raw_ShowStimulus(VARIANT_BOOL bState)

Interface

IApplication


Show Table Method

About Display Formatting

ShowTable Method

Write-only

Description

Shows or Hides the specified table for the window's active measurement in the lower part of the window.

VB Syntax

win.ShowTable value

Variable

(Type) - Description

win

A NAWindow (object)

value

(enum naTable) - The table to show or hide. Choose from:

0 - naTable_None
1 - naTable_Marker
2 - naTable_Segment
3 - naTable_Limit

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowTable naTable_limit

C++ Syntax

HRESULT raw_ShowTable (tagNATableType table)

Interface

INAWindow


Show Title Bars Method

About Display Formatting

ShowTitleBars Method

Write-only

Description

Shows and Hides the Title Bars. The Title Bars are across the top of the Network Analyzer Window and each of the measurement windows. The Window name is shown in the Title Bar.

VB Syntax

app.ShowTitleBars state

Variable

(Type) - Description

app

Application (object)

state

(boolean)
True (1) - Show the Title Bars
False (0) - Hide the Title Bars

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowTitleBars True

C++ Syntax

HRESULT raw_ShowTitleBars\(VARIANT_BOOL bState)

Interface

IApplication


Show Toolbar Method

About Display Formatting

ShowToolbar Method

Write-only

Description

Shows and Hides the specified Toolbar.

VB Syntax

app.ShowToolbar toolbar,state

Variable

(Type) - Description

app

Application (object)

toolbar

(enum NAToolbarType) - The toolbar to show or hide. Choose from:

0 - naToolbar_None
1 - naToolbar_ActiveEntry
2 - naToolbar_Markers
3 - naToolbar_Measurement
4 - naToolbar_Stimulus
5 - naToolbar_SweepControl

state

(boolean) -
True (1) - Show the specified toolbar
False (0) - Hide the specified toolbar

Return Type

Not Applicable

Default

1 - naToolbar_ActiveEntry showing; all others hiding.

Examples

app.ShowToolbar 1,1 'shows the active entry toolbar

C++ Syntax

HRESULT raw_ShowToolbar(tagNAToolbarType toolbar, VARIANT_BOOL bState)

Interface

IApplication


About Triggering

Single Method

Write-only

Description

Sets the trigger count to 1, which will cause the channel to respond to exactly one trigger signal from any source (internal, external, or manual).

VB Syntax

chan.Single [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) -Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

sync = True
chan.Single sync

C++ Syntax

HRESULT raw_Single(VARIANT_BOOL bWait)

Interface

IChannel


About Analyzer Events

OnCalEvent

Description

Triggered by a calibration event. See a list of CAL Events.

VB Syntax

Sub app_OnCalEvent(ByVal eventID As Variant, ByVal chanNum As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnCalEvent(ByVal eventID As Variant, ByVal channelNumber As Variant, ByVal measurementNumber As Variant)
'
MsgBox ("A Calibration event has occured")
End Sub

C++ Syntax

HRESULT OnCalEvent(VARIANT eventID, VARIANT channelNumber, VARIANT measurementNumber)

Interface

IApplication


CAL Events (802)

MSG_CAL_STD_NEEDED
Calibration cannot be completed until you have measured all the necessary standards for your selected Cal Type.
HRESULT 0x68020201L

MSG_CAL_REQUIRED
Calibration is required before correction can be turned on. Channel number is <x>, Measurement is <x>.
HRESULT 0x68020203L

MSG_CAL_CORRECTION_TURNED_OFF
Critical parameters in your current instrument state do not match the parameters for the calibration set, therefore correction has been turned off. The critical instrument state parameters are sweep type, start frequency, frequency span, and number of points.
HRESULT 0x68020204L

MSG_CAL_CALTYPE_SET_TO_NONE
Cal Type is set to NONE for Channel <x>, Measurement <x>; please select Calibration menu or press Cal hard key.
HRESULT 0x68020208L

MSG_PROPERTIES_NO_USER_CAL
No user calibration found for this channel.
HRESULT 0x6802020EL

MSG_CAL_DOES_NOT_NEED_STD
You do not need to acquire this standard for this calibration type.
HRESULT 0x6802020FL

MSG_ECAL_COULD_NOT_CONFIGURE
Could not configure the Electronic Calibration system. Check to see if the module is plugged into the proper connector.
HRESULT 0x68020210L

MSG_ECAL_ERROR_1
DATA OUT OF RANGE: Design Limits Exceeded
HRESULT 0x68020211L

MSG_ECAL_ERROR_2
EXECUTION ERROR: Array dimensions mismatched
HRESULT 0x68020212L

MSG_ECAL_ERROR_3
EXECUTION ERROR: Array div by zero
HRESULT 0x68020213L

MSG_ECAL_ERROR_4
EXECUTION ERROR: Array function invalid
HRESULT 0x68020214L

MSG_ECAL_ERROR_5
EXECUTION ERROR: Array index error
HRESULT 0x68020215L

MSG_ECAL_ERROR_6
EXECUTION ERROR: Array index out of range
HRESULT 0x68020216L

MSG_ECAL_ERROR_7
EXECUTION ERROR: Arrays wrong rank
HRESULT 0x68020217L

MSG_ECAL_ERROR_8
EXECUTION ERROR: CPU
HRESULT 0x68020218L

MSG_ECAL_ERROR_9
EXECUTION ERROR: Cannot ERASE module
HRESULT 0x68020219L

MSG_ECAL_ERROR_10
EXECUTION ERROR: Cannot WRITE module
HRESULT 0x6802021AL

MSG_ECAL_ERROR_11
EXECUTION ERROR: Entry Not Found
HRESULT 0x6802021BL

MSG_ECAL_ERROR_12
EXECUTION ERROR: Invalid command while system is busy
HRESULT 0x6802021CL

MSG_ECAL_ERROR_13
Electronic Cal: The Module is NOT in RF path. Please connect it to the port indicated.
HRESULT 0x6802021DL

MSG_ECAL_ERROR_14
EXECUTION ERROR: NO SPACE for NEW CAL, DELETE A CAL
HRESULT 0x6802021EL

MSG_ECAL_ERROR_15
EXECUTION ERROR: No More Room
HRESULT 0x6802021FL

MSG_ECAL_ERROR_16
EXECUTION ERROR: Other array error
HRESULT 0x68020220L

MSG_ECAL_ERROR_17
EXECUTION ERROR: Ranks not equal
HRESULT 0x68020221L

MSG_ECAL_ERROR_18
EXECUTION ERROR: Too few CONSTANT ranks
HRESULT 0x68020222L

MSG_ECAL_ERROR_19
EXECUTION ERROR: Too few VARYing ranks
HRESULT 0x68020223L

MSG_ECAL_ERROR_20
EXECUTION ERROR: Unknown error
HRESULT 0x68020224L

MSG_ECAL_ERROR_21
EXECUTION ERROR: ecaldrvr.dll bug or invalid module #
HRESULT 0x68020225L

MSG_ECAL_ERROR_22
EXECUTION ERROR: unexpected error code from ecal driver
HRESULT 0x68020226L

MSG_ECAL_ERROR_23
EXECUTION ERROR: unexpected internal driver error
HRESULT 0x68020227L

MSG_ECAL_ERROR_24
HARDWARE ERROR: Can't access ECal Interface Module
HRESULT 0x68020228L

MSG_ECAL_ERROR_25
HARDWARE ERROR: Can't release LPT port, reboot
HRESULT 0x68020229L

MSG_ECAL_ERROR_26
HARDWARE ERROR: VNA Error
HRESULT 0x6802022AL

MSG_ECAL_ERROR_27
HARDWARE ERROR: not enough data read from ECal module
HRESULT 0x6802022BL

MSG_ECAL_ERROR_28
OPERATION ABORTED BY HOST COMPUTER
HRESULT 0x6802022CL

MSG_ECAL_ERROR_29
OPERATION ABORTED BY USER
HRESULT 0x6802022DL

MSG_ECAL_ERROR_30
OUT OF MEMORY
HRESULT 0x6802022EL

MSG_ECAL_ERROR_31
QUERY INTERRUPTED:Message(s Abandoned
HRESULT 0x6802022FL

MSG_ECAL_ERROR_32
QUERY UNTERMINATED: INCOMPLETE PROGRAMMessage
HRESULT 0x68020230L

MSG_ECAL_ERROR_33
QUERY UNTERMINATED: NOTHING TO SAY
HRESULT 0x68020231L

MSG_ECAL_ERROR_34
QUEUE OVERFLOW
HRESULT 0x68020232L

MSG_ECAL_ERROR_35
SETTINGS CONFLICT: ADDITIONAL STANDARDS ARE NEEDED
HRESULT 0x68020233L

MSG_ECAL_ERROR_36
SETTINGS CONFLICT: Adapter Cal is NOT possible
HRESULT 0x68020234L

MSG_ECAL_ERROR_37
SETTINGS CONFLICT: COMMAND OUT OF SEQUENCE
HRESULT 0x68020235L

MSG_ECAL_ERROR_38
SETTINGS CONFLICT: Cal STOPPED - VNA SETUP CHANGED
HRESULT 0x68020236L

MSG_ECAL_ERROR_39
SETTINGS CONFLICT: Calibration is NOT in progress
HRESULT 0x68020237L

MSG_ECAL_ERROR_40
SETTINGS CONFLICT: Can't find specified GPIB board
HRESULT 0x68020238L

MSG_ECAL_ERROR_41
SETTINGS CONFLICT: Can't find/load gpib32.dll
HRESULT 0x68020239L

MSG_ECAL_ERROR_42
SETTINGS CONFLICT: Can't find/load sicl32.dll
HRESULT 0x6802023AL

MSG_ECAL_ERROR_43
SETTINGS CONFLICT: Can't initialize VNA (bad address?
HRESULT 0x6802023BL

MSG_ECAL_ERROR_44
SETTINGS CONFLICT: Can't load LPT port driver or USB driver DLL
HRESULT 0x6802023CL

MSG_ECAL_ERROR_45
SETTINGS CONFLICT: Invalid Calibration Sweep Mode.
HRESULT 0x6802023DL

MSG_ECAL_ERROR_46
SETTINGS CONFLICT: Invalid Calibration Type
HRESULT 0x6802023EL

MSG_ECAL_ERROR_47
SETTINGS CONFLICT: Invalid Calibration
HRESULT 0x6802023FL

MSG_ECAL_ERROR_48
SETTINGS CONFLICT: Invalid GPIB board number specified
HRESULT 0x68020240L

MSG_ECAL_ERROR_49
SETTINGS CONFLICT: Invalid GPIB board type specified
HRESULT 0x68020241L

MSG_ECAL_ERROR_50
SETTINGS CONFLICT: Invalid Module Status
HRESULT 0x68020242L

MSG_ECAL_ERROR_51
SETTINGS CONFLICT: Invalid States
HRESULT 0x68020243L

MSG_ECAL_ERROR_52
SETTINGS CONFLICT: LPT port must be between 1 and 4
HRESULT 0x68020244L

MSG_ECAL_ERROR_53
Could not configure the Electronic Calibration system. Check to see if the module is properly connected.
HRESULT 0x68020245L

MSG_ECAL_ERROR_54
SETTINGS CONFLICT: Specified LPT port does not exist
HRESULT 0x68020246L

MSG_ECAL_ERROR_55
SETTINGS CONFLICT: Use frequency domain for cal
HRESULT 0x68020247L

MSG_ECAL_ERROR_56
SETTINGS CONFLICT: Use step sweep type for cal.
HRESULT 0x68020248L

MSG_ECAL_ERROR_57
SETTINGS CONFLICT: VNA address must be between 0 and 30
HRESULT 0x68020249L

MSG_ECAL_ERROR_58
SETTINGS CONFLICT: Wrong LPT port driver or USB driver DLL
HRESULT 0x6802024AL

MSG_ECAL_ERROR_59
SYNTAX ERROR: ECAL:DELAY command must have 2 numbers
HRESULT 0x6802024BL

MSG_ECAL_ERROR_60
SYNTAX ERROR: INCORRECT SYNTAX
HRESULT 0x6802024CL

MSG_ECAL_ERROR_61
SYNTAX ERROR: UNKNOWN COMMAND
HRESULT 0x6802024DL

E_NA_CALTYPE_NONE
CalType not set.
HRESULT 0xE8020260L


About Analyzer Events

OnChannelEvent

Description

Triggered by a channel event. See a list of Channel Events

VB Syntax

Sub app_OnChannelEvent(ByVal eventID As Variant, ByVal chanNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnChannelEvent(ByVal eventID As Variant, ByVal channelNumber As Variant)
MsgBox "A channel event occured"
End Sub

C++ Syntax

HRESULT OnChannelEvent(VARIANT eventID, VARIANT channelNumber)

Interface

IApplication


Channel Events (807)

MSG_CHANNEL_SWEEP_COMPLETE
Sweep Complete.
HRESULT 0x68070700L

MSG_CHANNEL_TRIGGER_COMPLETE
All triggerable acqusitions have completed.
HRESULT 0x68070701L

MSG_CHANNEL_TRIGGER_ABORTED
The last trigger produced an aborted sweep.
HRESULT 0x68070702L

E_NA_NO_CHANNEL
Channel not found.
HRESULT 0xE8070750L

E_NA_SWEEP_SEGMENT_NOT_FOUND
The requested sweep segment was not found.
HRESULT 0xE8070751L


About Analyzer Events

OnDisplayEvent

Description

Triggered by a display event. See a list of Display Events

VB Syntax

Sub app_OnDisplayEvent(ByVal eventID As Variant, ByVal winNum As Variant, ByVal traceNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

winNum

Window Number of the event

traceNum

Trace Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnDisplayEvent(ByVal eventID As Variant, ByVal windowNumber As Variant, ByVal traceNumber As Variant)
MsgBox ("A Display event has occured")
End Sub

C++ Syntax

HRESULT OnDisplayEvent(VARIANT eventID, VARIANT windowNumber, VARIANT traceNumber)

Interface

IApplication


Display Events (806)

MSG_EXCEED_MAX_TRACES
Exceeded the maximum of <x> traces in each window. The trace for <x> will not be added to window <x>.
HRESULT 0xA8060600L

MSG_EXCEED_MAX_DATA_WINDOWS
Exceeded the maximum of <x> data windows. New window will not be created.
HRESULT 0xA8060601L

MSG_NO_DATA_WINDOWS
No Data Windows are present. Unable to complete operation.
HRESULT 0xA8060602L

MSG_NO_TRACE_FOUND
No data traces are present in the selected window. Operation not completed.
HRESULT 0xA8060603L

MSG_ARRANGE_WINDOW_EXCEED_CAPACITY
Cannot complete request to arrange existing measurements in <x> windows due to the limit of <x> traces per window.
HRESULT 0x68060604L

E_NA_NO_WINDOW
Window not found.
HRESULT 0xE8060650L

E_NA_DUPLICATE_WINDOW
Duplicate window ID specified.
HRESULT 0xE8060651L

E_NA_EXCEED_MAX_WINDOWS
Exceeded limit on number of windows.
HRESULT 0xE8060652L

E_NA_EXCEED_MAX_NUM_TRACES
Exceeded limit on number of traces/window.
HRESULT 0xE8060653L

E_NA_NO_TRACE
Trace not found.
HRESULT 0xE8060654L


About Analyzer Events

OnHardwareEvent

Description

Triggered by a hardware event. See a list of Hardware Events

VB Syntax

Sub app_OnHardwareEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnHardwareEvent(ByVal eventID As Variant)
MsgBox ("A Hardware event has occured")
End Sub

C++ Syntax

HRESULT OnHardwareEvent(VARIANT eventID)

Interface

IApplication


Hardware Events (803)

MSG_POWER_TRIPPED
The input power is too high. The source power is shut off.
HRESULT 0xA8030302L

MSG_POWER_TRIP_CORRECTED
The source power has been restored.
HRESULT 0x68030303L

MSG_DSP_BOARD_NOT_FOUND
The spampnp.sys driver is not working. Check system hardware.
! Data will be simulated. !
HRESULT 0xE8030304L

MSG_INSTRUMENT_SERIAL_BUS_BAD
Instrument Serial Bus Not Working.
HRESULT 0xE8030305L

E_NA_PHASELOCK
The hardware has lost phaselock.
HRESULT 0xE8030350L

E_NA_HARDWARE
General Hardware Error.
HRESULT 0xE8030351L

E_NA_DSPCOMM
The CPU cannot communicate with the DSP processor.
HRESULT 0xE8030352L

E_NA_RFPOWEROFF
The RF Power is Off.
HRESULT 0xE8030353L

S_NA_RFPOWERON
The RF Power is On.
HRESULT 0x28030354L

S_NA_HARDWAREOK
The hardware is functioning properly.
HRESULT 0x28030355L

E_NA_UNLEVELED
The source power is unleveled.
HRESULT 0xE8030356L

E_NA_OVERLOAD
Input overload. Please reduce power.
HRESULT 0xE8030357L

E_NA_YIG_CAL_FAILED
The yig oscillator failed to calibrate.
HRESULT 0xE8030358L

E_NA_RAMP_CAL_FAILED
The analog ramp failed to calibrate.
HRESULT 0xE8030359L

E_NA_OVERTEMP
The source temperature is too high. Improve air flow.
HRESULT 0xE803035AL

E_NA_EE_WRT_ERR
Writing to the EEPROM failed.
HRESULT 0xE803035BL

E_NA_SET_EE_WRT_ERR

HRESULT 0xE803035CL

E_NA_CLR_EE_WRT_ERR
E_NA_CLR_EE_WRT_ERR
HRESULT 0xE803035DL

E_NA_SET_RAMP_CAL_FAILED
E_NA_SET_RAMP_CAL_FAILED
HRESULT 0xE803035EL

E_NA_CLR_RAMP_CAL_FAILED

E_NA_CLR_RAMP_CAL_FAILED

#define E_NA_CLR_RAMP_CAL_FAILED ((HRESULT)0xE803035FL)

E_NA_CLR_YIG_CAL_FAILED

E_NA_CLR_YIG_CAL_FAILED

#define E_NA_CLR_YIG_CAL_FAILED ((HRESULT)0xE8030360L)

E_NA_SET_YIG_CAL_FAILED

E_NA_SET_YIG_CAL_FAILED

#define E_NA_SET_YIG_CAL_FAILED ((HRESULT)0xE8030361L)

E_NA_SET_OVER_TEMP

E_NA_SET_OVER_TEMP

#define E_NA_SET_OVER_TEMP ((HRESULT)0xE8030362L)

E_NA_CLR_OVER_TEMP

E_NA_CLR_OVER_TEMP

#define E_NA_CLR_OVER_TEMP ((HRESULT)0xE8030363L)

E_NA_SET_UNLEVEL

E_NA_SET_UNLEVEL

#define E_NA_SET_UNLEVEL ((HRESULT)0xE8030364L)

E_NA_CLR_UNLEVEL

E_NA_CLR_UNLEVEL

#define E_NA_CLR_UNLEVEL ((HRESULT)0xE8030365L)

E_NA_SET_OVERLOAD

E_NA_SET_OVERLOAD

#define E_NA_SET_OVERLOAD ((HRESULT)0xE8030366L)

E_NA_CLR_OVERLOAD

E_NA_CLR_OVERLOAD

#define E_NA_CLR_OVERLOAD ((HRESULT)0xE8030367L)

E_NA_SET_UNLOCK

E_NA_SET_UNLOCK

#define E_NA_SET_UNLOCK ((HRESULT)0xE8030368L)

E_NA_CLR_UNLOCK

E_NA_CLR_UNLOCK

#define E_NA_CLR_UNLOCK ((HRESULT)0xE8030369L)


About Analyzer Events

OnMeasurementEvent

Description

Triggered by a measurement event. See a list of Measurement Events.

VB Syntax

Sub app_OnMeasurementEvent(ByVal eventID As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnMeasurementEvent(ByVal eventID As Variant, ByVal measurementNumber As Variant)

MsgBox ("A Measurement event has occured")

End Sub

C++ Syntax

HRESULT OnMeasurementEvent(VARIANT eventID, VARIANT measurementNumber)

Interface

IApplication


Measure Events (804)

MSG_NO_VALID_MEMORY_TRACE
If you are going to display or otherwise use a memory trace, you must first store a data trace to memory.
HRESULT 0xA8040400L

MSG_MEASUREMENT_DELETE_FAIL
The measurement failed to shut down properly. The application is in a corrupt state and should be shut down and restarted.
HRESULT 0xE8040401L

MSG_MEASUREMENT_WAIT_THREAD_FAIL
The measurement failed to shut down properly. The update thread failed to exit properly.
HRESULT 0xA8040402L

MSG_GROUPDELAY_FORMAT_NOT_VALID
Group Delay format with CW Time or Power sweeps produces invalid data.
HRESULT 0xA8040403L

MSG_LIMIT_FAILED
MSG_LIMIT_FAILED
HRESULT 0x68040404L

MSG_LIMIT_PASSED
MSG_LIMIT_PASSED
HRESULT 0x68040405L

MSG_EXCEED_MAX_MEAS
Exceeded the maximum number of measurements allowed.
HRESULT 0xA8040406L

MSG_NETANA_ERROR_ADDNEWMEAS
Network Analyzer Internal Error. Unexpected error in AddNewMeasurement.
HRESULT 0xA8040407L

MSG_NO_MEASUREMENT_FOUND
No measurement was found to perform the selected operation. Operation not completed.
HRESULT 0xA8040408L

MSG_MARKER_ALL_OFF_FAILED
The Markers All Off command failed.
HRESULT 0xA8040409L

MSG_MEMORY_NOT_SAVED
A memory trace has not been saved for the selected trace. Save a memory trace before attempting trace math operations.
HRESULT 0xA804040AL

MSG_SET_AVERAGE_COMPLETE
MSG_SET_AVERAGE_COMPLETE
HRESULT 0x6804040BL

MSG_CLEAR_AVERAGE_COMPLETE
MSG_CLEAR_AVERAGE_COMPLETE
HRESULT 0x6804040CL

MSG_TIME_DOMAIN_MINIMUM_POINTS
Time Domain transform requires at least %1 input points. The transform has been deactivated.
HRESULT 0x6804040DL

E_NA_EXCEED_MAX_NUM_MEAS
Exceeded limit on number of measurements.
HRESULT 0xE8040450L

E_NA_BAD_PARAMETER
Parameter not valid.
HRESULT 0xE8040451L

E_NA_NO_MEAS
Measurement not found.
HRESULT 0xE8040452L

E_NA_NO_MEMORY_BUFFER
No valid memory trace.
HRESULT 0xE8040453L

E_NA_NO_REFERENCE_MARKER
The reference marker was not found.
HRESULT 0xE8040454L

E_NA_TRACE_MATH_RESET
Data and Memory traces are no longer compatible. Trace Math has been turned off.
HRESULT 0xA8040455L

E_NA_MEMORY_TRACE_NOT_COMPATIBLE
Data and Memory traces are not compatible. For valid trace math operations, memory and data traces must have similar measurement conditions.
HRESULT 0xE8040456L


About Analyzer Events

OnSCPIEvent

Description

Triggered by a SCPI event. See a list of SCPI Events

VB Syntax

Sub app_OnSCPIEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSCPIEvent(ByVal eventID As Variant)
MsgBox ("A SCPI event has occured")
End Sub

C++ Syntax

HRESULT OnSCPIEvent(VARIANT eventID )

Interface

IApplication


Parse Events

MSG_NOTHING_TO_SAY
You have sent a read command to the analyzer without first requesting data with an appropriate output command. The analyzer has no data in the output queue to satisfy the request.
HRESULT 0x68050501L

MSG_ANOTHER_CTRL
You must remove the active controller from the bus or the controller must relinquish the bus before the analyzer can assume the system controller mode.
HRESULT 0xE8050502L

MSG_BLOCK_INPUT_ERROR
The analyzer did not receive a complete data transmission. This is usually caused by an interruption of the bus transaction.
HRESULT 0xE8050503L

MSG_SCPI_STATUS_BYTE_CHANGE
The instrument status byte has changed.
HRESULT 0x68050504L

MSG_BAD_SCPI_COMMAND
The SCPI command received has caused error number <x>: "<x>".
HRESULT 0x68050505L

MSG_PARSER_COMMAND_LOG
Parser got command: <x>
HRESULT 0x680505FFL


About Analyzer Events

OnSystemEvent

Description

Triggered by a system event. See a list of System Events

VB Syntax

Sub app_OnSystemEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSystemEvent(ByVal eventID As Variant)
MsgBox ("A System event has occured")
End Sub

C++ Syntax

HRESULT OnSystemEvent(VARIANT eventID)

Interface

IApplication


General Events (808)

MSG_OPTION_NOT_INSTALLED
The function you requested requires a capability provided by an option to the standard analyzer. That option is not currently installed.
HRESULT 0x68080800L

MSG_FEATURE_NOT_AVAILABLE
The feature you requested is not available on the current instrument.
HRESULT 0x68080801L

MSG_FEATURE_NOT_VALID
The feature you requested is incompatible with the current instrument state.
HRESULT 0x68080802L

MSG_SAVEFILE_OK
<x> has been saved.
HRESULT 0x68080803L

MSG_SAVEFILE_FAIL
Attempt to save <x> failed.
HRESULT 0xA8080804L

MSG_RECALLFILE_FILE_NOT_FOUND
Attempt to recall file failed because <x> was not found.
HRESULT 0x68080805L

MSG_RECALLFILE_BAD_HEADER
<x> has a bad header.
HRESULT 0x68080806L

MSG_POWER_HIBERNATE
Request to enter hibernate state.
HRESULT 0x68080807L

MSG_POWER_HIBERNATE_AUTOMATIC
Power up from automatic hibernate state. Program received PBT_APMRESUMEAUTOMATIC Message.
HRESULT 0x68080808L

MSG_POWER_HIBERNATE_SUSPEND
Power up from suspend hibernate state. Program received PBT_APMRESUMESUSPEND Message.
HRESULT 0x68080809L

MSG_POWER_HIBERNATE_CRITICAL
Power up from suspend hibernate state. Program received PBT_APMRESUMECRITICAL Message.
HRESULT 0xA808080AL

MSG_POWER_HIBERNATE_UIFAILSAFE
Power up from unknown hibernate state UI recovery called. Program received no PBT_Message within the time alloted and is attempting recovery.
HRESULT 0xA808080BL

MSG_SAVEFILE_DUP
<x> already exists. File is being overwritten.
HRESULT 0x6808080CL

MSG_SAVEFILE_NOTDONE
File has not been saved.
HRESULT 0x6808080DL

MSG_RECALLFILE_SUCCESS
File <x> has been recalled.
HRESULT 0x6808080EL

E_NA_INVALIDFORMAT
The specified format is invalid.
HRESULT 0xE8080850L

E_NA_EXCEPTION
WINNT exception caught by Automation layer.
HRESULT 0xE8080851L

E_NA_BADPORT
Bad port specification.
HRESULT 0xE8080852L

E_NA_TRIGGERIGNORED
Manual trigger ignored.
HRESULT 0xE8080854L

E_NA_TRIGGERDENIED
Attempt to set trigger failed.
HRESULT 0xE8080855L

E_NA_DATA_LENGTH
Block data length error.
HRESULT 0xE8080859L

E_NA_DATA_NOT_FOUND
Requested data not found.
HRESULT 0xE808085BL


About Analyzer Events

OnUserEvent

Description

Reserved for future use.

VB Syntax

Sub app_OnUserEvent


Getting Trace Data from the Analyzer

This Visual Basic program:

  • Retrieves Scalar Data from the Analyzer and plots it.

  • Retrieves Paired Data from the Analyzer and plots it.

  • Retrieves Complex Data from the Analyzer and plots it.

To use this code, prepare a form with the following:

  • Two MSCharts named MSChart1 and MSChart2

  • Three buttons named getScalar, getPaired, getComplex

'Put this in a module
Public dlocation As NADataStore
Public numpts As Long
Public fmt As NADataFormat
Public app As Application
Public measData As IArrayTransfer
Public chan As Channel

Sub Form_Load()
'Change analyzerName to your analyzer's full computer name
Set app = CreateObject("AgilentPNA835x", "analyzerName")
Set measData = app.ActiveMeasurement
Set chan = app.ActiveChannel
numpts = chan.NumberOfPoints

'To pick a location to get the data from remove the comment from one of these
dlocation = naRawData
'dlocation = naCorrectedData
'dlocation = naMeasResult
'dlocation = naRawMemory
'dlocation = naMemoryResult

'setup MSchart
'right click on the chart and select:
' - line chart
' - data in rows
End Sub

Sub GetComplex_Click()
ReDim Data(numpts) As NAComplex
Dim Real(201)
Dim Imag(201)
'You cannot change the format of Complex Data
Call trigger
'get data
measData.GetNAComplex dlocation, numpts, Data(0)
'plot data
Dim i As Integer

For i = 0 To numpts - 1
 Real(i) = Data(i).Re
 Imag(i) = Data(i).Im
Next i
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetPaired_Click()
ReDim Real(numpts) As Single
ReDim Imag(numpts) As Single
' To pick a format, remove the comment from one of these
fmt = naLogMagPhase
'fmt = naLinMagPhase
Call trigger
'Get data
measData.getPairedData dlocation, fmt, numpts, Real(0), Imag(0)
'Plot Scalar
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetScalar_Click()
ReDim Data(numpts) As Single
'To pick a format remove the comment from one of these
fmt = naDataFormat_LogMag
'fmt = naDataFormat_LinMag
'fmt = naDataFormat_Phase
'fmt = naDataFormat_Delay
'fmt = naDataFormat_Real
'fmt = naDataFormat_Imaginary
Call trigger
'Get data
measData.GetScalar dlocation, fmt, numpts, Data(0)
'Plot Data
MSChart1 = Data()
MSChart2.Visible = False
Call Sweep
End Sub

Sub trigger()
'The analyzer send continuous trigger signals
app.TriggerSignal = naTriggerInternal
'The channel will only accept one, then go into hold
chan.Single sync
End Sub

Sub Sweep()
'The channel goes back to accepting all triggers
chan.Continuous
End Sub


Limit Line Testing Example with COM

Limit Line Testing with COM

This Visual Basic program:

  • Turns off existing Limit Lines

  • Establishes Limit Lines with the following settings:

    • Frequency range - 4 GHz to 8 GHz

    • Maximum value - (10dB)

    • Minimum value - (-30dB)

  • Turns on Lines, Testing, and Sound

To use this code, prepare a form with the following:

  • None

Public limts As LimitTest
Set limts = meas.LimitTest
'All Off
For i = 1 To 20
limts(i).Type = naLimitSegmentType_OFF
Next i

'Set up Limit Lines
limts(1).Type = naLimitSegmentType_Maximum
limts(1).BeginResponse = 10
limts(1).EndResponse = 10
limts(1).BeginStimulus = 4000000000#
limts(1).EndStimulus = 8000000000#
limts(2).Type = naLimitSegmentType_Minimum
limts(2).BeginResponse = -30
limts(2).EndResponse = -30
limts(2).BeginStimulus = 4000000000#
limts(2).EndStimulus = 8000000000#

'Turn on Lines, Testing, and Sound
limts.LineDisplay = 1
limts.State = 1
limts.SoundOnFail = 1


C++ Example

The following example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries.

Also notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

// An example program to illustrate the use of #import
 to bind to the
// PNA type library.
//
#include "stdafx.h"
#include "stdio.h"
#include "math.h"

/////////////////////////////////////////////
// import the network analyzer type library
/////////////////////////////////////////////
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
 no_namespace, named_guids
/////////////////////////////////////////////
// include the error definitions for the PNA so we can implement
// error handling.
/////////////////////////////////////////////
#include "C:\Program Files\Agilent\Network Analyzer\errorsystemmessage.h"

IApplicationPtr pNA; // top level application pointer
float fScalarData [1601]; // global buffer for data retrieval
float fScalarData2[1601];

DWORD dwCookie;

/////////////////////////////////////////////
// SetupChannel:
//
// input: pointer to the channel
//
// function: sets properties on the channel
/////////////////////////////////////////////
void SetupChannel(IChannelPtr pChannel)
{
pChannel->put_StartFrequency( 1.2E9 );
pChannel->put_StopFrequency ( 4.2E9 );
pChannel->put_NumberOfPoints ( 201);

}

/////////////////////////////////////////////
// AcquireData:
//
// input: pointer to the channel
//
// function: single sweeps the channel
/////////////////////////////////////////////
void AcquireData( IChannelPtr pChannel )
{
pChannel->Single( TRUE );
}

/////////////////////////////////////////////
// ReadData:
//
// input: pointer to the Measurement object
//
// function: reads data from the measurment's formatted
// result data buffer
/////////////////////////////////////////////
void ReadScalarData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pData = fScalarData;

if(pDataTransfer){

pDataTransfer->getScalar( naMeasResult, naDataFormat_LogMag,
 &numVals, pData);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\n",i,pData[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}

void ReadComplexData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pReal= fScalarData;
float* pImag = fScalarData2;

if(pDataTransfer){

pDataTransfer->getPairedData( naRawData, naRealImaginary, &numVals,
 pReal, pImag);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\t%f\n",i,pReal[i], pImag[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}
/////////////////////////////////////////////
// PutData:
//
// input: pointer to the Measurement object
//
// function: writes data to the measurment's raw data
// buffer
/////////////////////////////////////////////
void PutData( IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 201;

if(pDataTransfer){

NAComplex* pComplex = new NAComplex[numVals];

pComplex[0].Im = 0;
pComplex[0].Re = 1;
for (int i = 1; i < numVals; i++)
{
pComplex[i].Im = (float)sin(i)/i;
pComplex[i].Re = (float)cos(i)/i;
}

pDataTransfer->putNAComplex( naRawData, numVals, pComplex, naDataFormat_Polar);
delete [] pComplex;
}
}

/////////////////////////////////////////////
// printError
/////////////////////////////////////////////
void printError( HRESULT hr)
{
BSTR text;

hr = pNA->get_MessageText ((NAEventID) hr, &text);
MessageBox(NULL,text,L"Network Analyzer error",0);
::SysFreeString(text);
}

/////////////////////////////////////////////
// main
/////////////////////////////////////////////
int main(int argc, char* argv[])
{
HRESULT hr;
const long channel1 = 1;
const long window1 = 1;
const long srcport = 1;
IMeasurementPtr pMeasurement;
IChannelPtr pChannel;

// initialize COM libraries
CoInitialize(NULL);

try {
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

pNA->put_Visible(TRUE);
pNA->Reset();

pNA->CreateMeasurement (channel1, "S21",srcport, 5);
hr = pNA->get_ActiveChannel( &pChannel);

if (SUCCEEDED (hr))
{
SetupChannel( pChannel);
AcquireData(pChannel);
}

hr= pNA->get_ActiveMeasurement( &pMeasurement);
if (SUCCEEDED(hr))
{
pMeasurement->put_Format( naDataFormat_Polar);
ReadScalarData( pMeasurement);
ReadComplexData( pMeasurement);
PutData(pMeasurement);
}
if (FAILED(hr))
{
printError(hr);
}

// make sure to release the remaining pointers
// before calling CoUninitialize

pMeasurement.Release();
pChannel.Release();
pNA.Release();
}
catch (_com_error err)
{
printError( err.Error() );
}

CoUninitialize();
return 0;
}


COM Fundamentals

The following is terms are discussed in this topic:

Objects

Collections

Methods

Properties

Events

Note: The information contained in this topic is intended to help an experienced SCPI programmer transition to COM programming. This is NOT a comprehensive tutorial on COM programming.

Objects

The objects of the Network Analyzer (Application) are arranged in a hierarchical order. The Network Analyzer object model lists the objects and their relationship to one another.

In SCPI programming, you must first select a measurement before making settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read settings.

For more information on working with objects, see Getting a Handle to an Object.

Collections

A collection is an object that contains several other objects of the same type. For example, the Channels collection contains all of the channel objects.

Note: In the following examples, the collections are referred to as a variable. Before using a collection object, you must first get an instance of that object. For more information, see Getting a Handle to an Object

Generally, items in a collection can be identified by number or by name. The order for objects in a collection cannot be assumed. They are always unordered and begin with 1. For example, in the following procedure, chans(1) is used to set averaging on the first channel in the Channels collection (not necessarily channel 1).

Sub SetAveraging()
chans(1).AveragingFactor = 10
End Sub

The following procedure uses the measurement string name to set the display format for a measurement in the measurements collection.

meass("CH1_S11_1").Format = 1

You can also manipulate an entire collection of objects if the objects share common methods. For example, the following procedure sets the dwell time on all of the segments in the collection.

Sub setDwell()
segs.DwellTime = 30e-3
End Sub

Methods

A method is an action that is performed on an object. For example, Add is a method that applies to the Channel object. The following procedure uses the Add method to add a new channel named NewChan.

Sub AddChan(newChan as String)
Chan.Add NewChan
End Sub

Properties

A property is an attribute of an object that defines one of the object's characteristics, such as size, color, or screen location. A property can also change an aspect of the object's behavior, such as whether the object is visible. In either case, to change the characteristics of an object, you change the values of its properties.

To change the value of a property, follow the reference to an object with:

  • a period (.)

  • the property name

  • an equal sign (=)

  • the new property value.

For example, the following statement sets the IFBandwidth of a channel.

Chan.IFBandwidth = 1KHz

You can also read the current value of a property. The following statement reads the current IFBandwidth of a channel into the variable Ifbw.

Ifbw = Chan.IFBandwidth

Some properties cannot be set and some cannot be read. The Help topic for each property indicates if you can:

  • Set and read the property (Write/Read)

  • Only read the property (Read-only)

  • Only set the property (Write-only)

Events

An event is an action recognized by an object, such as clicking the mouse or pressing a key. Using events, your program can respond to a user action, program code, or triggered by the analyzer. For example:

OnChannelEvent

For more information, see Working with the Analyzer's Events.


Getting a Handle to an Object

The following are discussed in this topic:

What is a Handle

Declaring an Object Variable

Assigning an Object Variable

Navigating the Object Hierarchy

Getting a Handle to a Collection

What is a Handle

In SCPI programming, you must first select a measurement before changing or reading settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read its settings. The following analogy illustrates this:

A car could be called an object. Like all objects, it has many properties. One of its properties is "Color". You can read (by looking) or set (by painting) the color property of a car object. However, the color value (such as Red or Green) depends on what SPECIFIC car object you are referring to. "Car" is a class of objects. You can only read or set the properties of a specific car object; not the entire car class. Therefore, before reading or setting an object's properties, you need to get "a handle" to a specific object.

You can have handles to many objects at the same time. It does NOT have to be the Active or Selected object.

Note: This process is also called "getting an instance of an object", and "returning an object".

There are two steps for getting a handle to analyzer objects:

  1. Declaring a Variable As an Object

  2. Assigning an Object to the Variable

Note: Before doing this, you must first register the analyzer's type library on your PC. See Connecting to the Analyzer

Declaring a Variable As an Object

Note: The examples in these topics use the Visual Basic Programming Language. The Green text following an apostrophe (') is a comment.

Use the Dim statement or one of the other declaration statements (Public, Private, or Static) to declare a variable. The type of variable that refers to an object must be a Variant, an Object, or a specific type of object. For example, all three of the following declarations are valid:

  • Dim RFNA ' Declare RFNA as Variant data type.

  • Dim RFNA As Object ' Declare RFNA as Object data type.

  • Dim RFNA As AgilentPNA835x.Application ' Declare RFNA As AgilentPNA835x.Application type

Note: If you use a variable without declaring it first, the data type of the variable is Variant by default.

If you know the specific object type, you should declare the object variable as that object type. Declaring specific object types provides automatic type checking, faster code, and improved readability.

Assigning an Object to a Variable

The first and most important object to assign to a variable is the Application object (the Network Analyzer). When assigning an object to a variable, use the Set keyword before the object variable that was declared previously. In the following example, "RFNA" is the variable we declared in the previous examples. So we assign the current AgilentPNA835x Application to "RFNA".

Set RFNA = AgilentPNA835x.Application

However, because the AgilentPNA835x object is the Application server, we must use the CreateObject keyword with the (classname,server name) parameters.

  • The classname for the analyzer object is always "AgilentPNA835x.Application".

  • To find your analyzer's server name, see Sharing Files between your PC and the Analyzer.

For example, the following statements would create an instance of the Analyzer object.

Dim RFNA AS AgilentPNA835x.Application
Set RFNA = CreateObject("AgilentPNA835x.Application", "Analyzer46")

Note: These statements will start the Analyzer application if it is not already running on your instrument.

Once created, you can treat an object variable exactly the same as the object to which it refers. You can set or return the properties of the object or use any of its methods. For example:

RFNA.Visible = True 'Makes the Network Analyzer Application visible on the screen

Navigating the Object Hierarchy

To read and set properties of objects below the Analyzer Application, you do not have to "Create" the object as we did with the Application. But you DO have to navigate the object model hierarchy. (Refer to the Analyzer Object Model).

You could do refer to an object in the hierarchy directly, without declaring and assigning a variables. The following example navigates through the Application object to the Active Measurement which is a 'child' object of the Application. (The ACTIVE measurement is the measurement that is acted on if you change settings from the front panel.)

Application.ActiveMeasurement.SmoothingAperture = 10

You can see that this method makes for a very long statement. Making additional changes to the Active Measurement would require equally long statements.

The following example gets a handle to the Active Measurement object by assigning it to a variable.

The first step is to Declare an object variable:

Public meas AS Measurement

The next step is to Set the object variable:

We already assigned an instance of the (analyzer) Application to the variable RFNA. Therefore, we can use the RFNA variable to refer to a specific instance of the Application object.

Set meas = RFNA.ActiveMeasurement

The variable meas now contains a handle to the Application object (RFNA) and the ActiveMeasurement object. We can now set properties of the ActiveMeasurement as follows:

meas.SmoothingAperature = 10

Getting a Handle to a Collection

The analyzer has several collections of objects which provide a convenient way of setting or reading all of the objects in the collection with a single procedure. Also, there are objects (limit lines for example) that can only be accessed through the collection.

To get a handle to an item in a collection, you can refer to the object by item number or sometimes by name. However, you first have to get a handle to the collection. To assign the collection to a variable, use the same two step process (1. declare the variable, 2. assign the variable using 'Set').

Dim meass As Measurements 'the collection of all measurements currently on the analyzer
Set meass = RFNA.Measurements

Then you can iterate through the entire collection of measurements to read or set properties or execute methods.

meass.Format = naLinMag

Or you can read or set a property on an individual object in the collection:

meass(1).Format = naLinMag

Note: Each object and collection has its own unique way of dealing with item names, and numbers. Refer to the Analyzer Object Model for details.


Collections in the Analyzer

Collections are a gathering of similar objects. They are a convenience item used primarily to iterate through the like objects in order to change their settings. Collections generally provide the following generic methods and properties:

Item(n)
Count
Add(n)
Remove(n)

where (n) represents the number of the item in the collection. Some collections may have unique capabilities pertinent to the objects they collect.

Collections are Dynamic

A collection does not exist until you ask for it. When you request a Channels object (see Getting a Handle to an Object / Collection), handles to each of the channel objects are gathered and placed in an array.

For example, if channels 2 and 4 are the only channels that exist, then the array will contain only 2 items. The command 'channels.Count' will return the number 2, and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 4 object.

The ordering of objects within the collection should not be assumed. If you add a channel to the previous example, as in:

Pna.Channels.Add(3)

'channels.Count' will now return 3 and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 3 object.

  • Channels(3) will contain the channel 4 object.

Primarily, collections are useful for making this type of iteration possible:

Dim ch as Channel
For each ch in pna.Channels
Print ch.Number
Print ch.StartFrequency
Print ch.StopFrequency
Next ch

As soon as this for-each block has been executed, the Channels object goes out of scope.


Véase asimismo...

Configurar para programación COM-DCOM

Descripción general

Conceptos relativos
al acceso

Procedimiento
de acceso

Registrar

¿Tiene algún problema?

Antes de desarrollar o de ejecutar un programa COM, debería establecerse antes una comunicación entre el PC y el analizador. Es lo que se denomina proporcionar acceso al analizador. A continuación, debería registrarse la librería de tipos del analizador en el PC.
Conceptos relativos al acceso

Procedimientos de acceso

Registrar el analizador en el PC

¿Tiene algún problema?

De manera predeterminada, los PNAs se suministran de fábrica de modo que todos tengan permiso para iniciar y tener acceso a la aplicación del PNA a través de COM/DCOM. El término todos se refiere a una serie diferente de usuarios, dependiendo de que el PNA sea un miembro de un dominio o de un grupo de trabajo (debe ser uno u otro, no ambos).

Nota: DCOM (Distributed Component Object Model - Modelo distribuido de objetos de componentes) se refiere al acceso a la aplicación del analizador desde un PC remoto.
COM se refiere al acceso al analizador desde el PC del analizador.

Grupo de trabajo

Un grupo de trabajo lo establece el administrador del PNA declarando el nombre del grupo de trabajo y declarando que el PNA es un miembro del grupo de trabajo. No es necesario que un administrador de redes cree un grupo de trabajo ni que controle los miembros del mismo.

Todos sólo incluye aquellos usuarios a quienes se hayan concedido cuentas de inicio de sesión en el PNA.

De manera predeterminada, el PNA se configura como miembro de un grupo de trabajo denominado WORKGROUP.

Nota: para establecer una cuenta de inicio de sesión para un nuevo usuario, véase Usuarios adicionales.
Para el acceso mediante DCOM, el nombre de la cuenta y la contraseña del usuario deben coincidir EXACTAMENTE con el nombre de cuenta y la contraseña de inicio de sesión de su PC.

Dominio

Un dominio es normalmente un gran grupo de ordenadores de una organización. Los administradores de redes mantienen el dominio y controlan qué equipos son miembros del mismo.

Todos incluye aquellas personas que son miembros del dominio. Además, aquellos usuarios que tienen cuentas de inicio de sesión también pueden tener acceso al analizador.

Resumiendo:

  • Un grupo de trabajo no necesita mantenimiento, pero permite el acceso mediante DCOM únicamente a aquellos usuarios que tengan una cuenta de inicio de sesión para el PNA.

  • Un dominio necesita un administrador, pero todos los miembros del dominio y aquéllos que tienen cuentas de inicio de sesión para el analizador pueden tener acceso mediante DCOM al PNA.

El siguiente nivel de seguridad es permitir únicamente a los usuarios seleccionados (no a todos) del dominio y del grupo de trabajo poder utilizar la capacidad de acceso e inicio mediante DCOM del analizador.

Nota: antes de realizar este procedimiento, el usuario deberá tener una cuenta de inicio de sesión en el PNA. Véase Usuarios adicionales

Este procedimiento se utiliza para lo siguiente:

  • Para permitir únicamente a usuarios seleccionados (no a todos) poder utilizar la capacidad de acceso e inicio remotos (DCOM) del analizador. La capacidad de inicio consiste en iniciar la aplicación del analizador si todavía no está abierta.

  • Para verificar que se dispone de acceso mediante DCOM al analizador.

Hacer lo siguiente para las funciones de acceso e inicio:

  1. En el PNA, hacer clic en el botón Inicio de Windows

  2. Hacer clic en Ejecutar

  3. En el cuadro Abrir:, escribir dcomcnfg

  4. Hacer clic en Aceptar

  5. En la ventana Distributed COM Configuration Properties, hacer clic en Agilent PNA Series en la lista Applications. A continuación, hacer clic en Properties... (botón)

  6. Hacer clic en la ficha Security

Capacidad de acceso

El procedimiento siguiente configura el PNA para conceder a usuarios específicos acceso mediante DCOM a la aplicación del PNA:

En el cuadro de diálogo Agilent PNA Series Properties:

  1. Hacer clic en Use custom access permissions

  2. Hacer clic en Edit&ldots; al lado de (Use custom access permissions)

  3. En Registry Value Permissions, seleccionar Everyone

  4. Hacer clic en Remove

  5. Hacer clic en Add

  6. Se podría seleccionar uno o más de estos grupos para que tuviesen acceso al PNA, o bien seleccionar usuarios específicos.

    1. Para dar acceso a grupos, seleccionar el grupo en la lista.

    2. Para dar acceso a usuarios específicos, hacer clic en Show users o en Members y, a continuación, seleccionar el nombre en la lista.

  7. Hacer clic en Add

  8. Hacer clic en Aceptar

Permiso de inicio

El procedimiento siguiente configura el PNA para permitir a los usuarios seleccionados que inicien la aplicación del PNA. Este procedimiento equivale a dar acceso al PNA.

En Agilent PNA Series Properties:

  1. Hacer clic en Use custom launch permissions

  2. Hacer clic en Edit&ldots; (al lado de Use custom launch permissions)

  3. En Registry Value Permissions, seleccionar Everyone

  4. Hacer clic en Remove

  5. Hacer clic en Add

  6. Se podría seleccionar uno o más de estos grupos para que tuviesen permiso de inicio del PNA, o bien seleccionar usuarios específicos.

    1. Para dar permiso de inicio a grupos, seleccionar el grupo en la lista.

    2. Para dar permiso de inicio a usuarios específicos, hacer clic en Show users o en Members y, a continuación, seleccionar el nombre en la lista.

  7. Hacer clic en Add

  8. Hacer clic en Aceptar

En Agilent PNA Series Properties:

  1. Hacer clic en la ficha Identity.

  2. Hacer clic en The interactive user. Esta función admite eventos en PNA COM.

Registrar la librería de tipos del analizador en el PC

La librería de tipos contiene el modelo de objetos del analizador. En el PC hay un archivo de registro que realiza un seguimiento de la ubicación de los modelos de objetos. Por consiguiente, se debe registrar la librería de tipos del analizador en el PC que se vaya a utilizar para desarrollar el código y ejecutar el programa. Es mucho más eficiente registrar la librería de tipos en la fase de diseño, ANTES de ejecutar el programa COM.

Realizar los dos pasos siguientes antes de continuar:

  1. Conectar tanto el PC como el analizador a la LAN.

  2. Se puede asignar una unidad al analizador o copiar los archivos de la librería de tipos en un disquete o en otro soporte. Para asignar una unidad, véase Asignación de unidades.

Nota: para registrar la librería de tipos en el PC, se debe iniciar la sesión como administrador del PC.

Este procedimiento da por sentado que se ha asignado una unidad del PC al analizador. Este procedimiento hará lo siguiente:

  • Registrar la aplicación del analizador de redes en el PC.

  • Copiar y registrar el proxystub (835xps.DLL) al PC.

  • Copiar y registrar la librería de tipos (835x.tlb) en el PC.

  1. Utilizar el Explorador de Windows del PC para encontrar la unidad C: del analizador. La unidad no se llamará "C:" en el PC, sino que aparecerá como una letra definida al asignar una unidad.

  2. Ir a Archivos de programa \ Agilent \ Network Analyzer \ Automation

  3. Hacer doble clic en Automation.vbs

Nota: si aparece el cuadro de diálogo "Open With", significa que el sistema de generación de archivos de comandos de Windows no está instalado en el PC. Se puede transferir desde el sitio Web de Microsoft en: http://www.microsoft.com/msdownload/vbscript/scripting.asp

  4. El programa de generación de archivos de comandos Visual Basic solicitará el nombre del analizador. (Se puede encontrar el nombre del analizador en Panel de control \ Sistema \ Network Identification \ Full Computer name: en el analizador. Escribir el nombre del analizador cuando aparezca la indicación.

  5. Después de que se haya ejecutado el archivo de comandos, hacer clic en Aceptar. La librería de tipos del analizador debería estar registrada en el PC.

Nota: dependiendo del entorno de programación, podrá ser necesario establecer una referencia a la librería de tipos en el PC.

Cuando la aplicación del analizador de redes se instale en el instrumento, la aplicación y todos los objetos a los que da servicio se registrarán en ese equipo. El instrumento debería estar preparado para funcionar como un servidor remoto.

Sin embargo, si el analizador no funciona correctamente, debería intentarse volver a registrar manualmente la aplicación y las librerías asociadas en el analizador siguiendo los pasos enumerados a continuación:

Nota: los pasos siguientes deben realizarse en el orden indicado

Desde el PC con una unidad asignada al analizador de redes PNA:

Localizar 835x.exe en C:\Archivos de programa\Agilent\NetworkAnalyzer

  1. Seleccionar y hacer clic con el botón derecho del ratón en 835x.exe

  2. Seleccionar Register COM Server para registrar la aplicación.

  3. Seleccionar y hacer clic con el botón derecho del ratón en 835xps.DLL

  4. Seleccionar Register COM Server

Después de llevar a cabo estos pasos, realizar el "procedimiento de acceso" (ejecutar dcomcnfg).


COM Data Types

The Analyzer uses several data types to communicate with the host computer. Before using a variable, it is best to declare the variable as the type of data it will store. It saves memory and is usually faster to access. The following are the most common data types:

Long Integer

Single Precision (Real)

Double Precision (Real)

Boolean

String

Object

Enumeration

Variant

Long (long integer) variables are stored as signed 32-bit (4-byte) numbers ranging in value from -2,147,483,648 to 2,147,483,647.

Double (double-precision floating-point) variables are stored as IEEE 64-bit (8-byte) floating-point numbers ranging in value from -1.79769313486232E308 to -4.94065645841247E-324 for negative values and from 4.94065645841247E-324 to 1.79769313486232E308 for positive values.

Single (single-precision floating-point) variables are stored as IEEE 32-bit (4-byte) floating-point numbers, ranging in value from -3.402823E38 to -1.401298E-45 for negative values and from 1.401298E-45 to 3.402823E38 for positive values.

Boolean variables are stored as 16-bit (2-byte) numbers, but they can only be True or False. Use the keywords True and False to assign one of the two states to Boolean variables.

When other numeric types are converted to Boolean values, 0 becomes False and all other values become True. When Boolean values are converted to other data types, False becomes 0 and True becomes -1.

String variables hold character information. A String variable can contain approximately 65,535 bytes (64K), is either fixed-length or variable-length, and contains one character per byte. Fixed-length strings are declared to be a specific length. Variable-length strings can be any length up to 64K, less a small amount of storage overhead.

Object variables are stored as 32-bit (4-byte) addresses that refer to objects within the analyzer or within some other application. A variable declared as Object is one that can subsequently be assigned (using the Set statement) to refer to any actual analyzer object.

Enumerations (Enum) are a set of named constant values. They allow the programmer to refer to a constant value by name instead of by number. For example:

Enum DaysOfWeek
Sunday = 0
Monday = 1
Tuesday = 2
Wednesday = 3
Thursday = 4
Friday = 5
Saturday = 6
End Enum

Given this set of enumerations, the programmer can then pass a constant value as follows:
SetTheDay(Monday)
rather than
SetTheDay(1)
where the reader of the code has no idea what the value 1 refers to.

However, the analyzer RETURNS a long integer, not the text.
Day = DaysofWeek(today) 'Day = 1

Variant - If you don't supply a data type, the variable is given the Variant data type. The Variant data type is like a chameleon — it can represent many different data types in different situations.

The analyzer provides and receives Variant data in several instances because there a programming languages that cannot send or receive "typed" data. Variant data transfers at a slower rate than "typed" data.


Working with the Analyzer's Events

Working with Events

What are Events?

Using the Analyzer's Events

Event ID's

Filtering Events

List of Events

Out of Range Errors

Troubleshooting Problems with Events

What are Events?

Windows applications work from user-initiated events such as mouse moves and mouse clicks. A mouse-click produces an event that the programmer can either ignore or "handle" by providing an appropriate subroutine like this:

Sub DoThis_onClick
Perform something
End Sub

If this subroutine were in your program and the mouse-click event occurs on your PC, it would generate a "Callback" to the client and interupt whatever it was doing and handle the event.

A more practical example of an event in the analyzer is Limit test. If limit test is on and the measurement fails, the analyzer produces a '"Limit-failed" event. If the measurement passed, the analyzer produces a "Limit-succeeded" event.

The Analyzer has a very sophisticated Event structure. Your program CAN be notified when one or more events occur. However, it may not be necessary.

For example, the analyzer has an event that will notify your program when a sweep is complete. A simpler alternative is to use a synchronous command which waits for the sweep to complete.

sync = True
app.ManualTrigger sync
chan.StartFrequency = 4.5E6

This would NOT work if you want the controller to do other things while waiting, like setup a power meter or sort some data. In this case you would like a "callback" from the analyzer to let your program know that the sweep has completed.

Another reason to use events is when you want to be notified of several conditions when they occur, such as errors or source unlock conditions. It would not be practical to routinely poll these conditions while executing your program.

Using Events

If you decide to use the COM events to get a callback, your program must do two things:

1. Subscribe to events:

All events in the analyzer are a child of the Application object through the INetworkAnalyzerEvents Interface. You must tell the Application object that you are interested in receiving event callbacks. This process is called subscription.

In Visual Basic, this is done by including "WithEvents" in the declaration statement. The declaration below dimensions an Application object (myPNA) and subscribes to the events produced by the Application.

Dim WithEvents myPNA as AgilentPNA835x.Application

In C++, this is a bit more involved. You must queryInterface for the IconnectionPointContainer interface, locate the InetworkAnalyzerEvents interface via a call to FindConnectionPoint and call Advise().

2. Implement the Event Handler

When an event occurs, the Application object will "callback" to the client through the InetworkAnalyzerEvents interface.

In VB, click on the object window (upper left pane). Find the Application object and click it. The event interfaces will appear in the upper right pane. As you click on them, VB supplies the first line of code. You fill in the rest of the handler routine to service the event. The following is an example of a event handler subroutine.

Note: In C++, you must type the callback.

Private Sub OnChannelEvent( eventID as Variant, channelNumber as Variant)
Select Case (eventID)
Case naEventID_CHANNEL_TRIGGER_COMPLETE:
GetData( channelNumber )
Case naEventID_CHANNEL_TRIGGER_ABORTED:
MsgBox( "Hey don't touch the front panel!")
End Select
End Sub

When the trigger is complete, the application object "fires" the event by making a callback to the event handler Sub OnChannelEvent().

Event IDs

3 | 3 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Sev |  | C | R | Facility |  |  |  |  |  |  |  |  |  |  | Code
Sev | Severity Code
C | Customer code flag (not used)
R | Reserved bit (not used)
Facility | Category code
Code | Event ID

Filtering Events

There are over 140 different events that you subscribe to when you "Dim WithEvents..." (or the equivalent in your programming language). Monitoring all of these conditions slows the speed of the analyzer significantly. The following methods allow you to filter the events so that you only monitor specific conditions.

  • AllowEventMessage - monitor a specific event

  • AllowAllEvents - monitor ALL events

  • DisallowAllEvents - monitor NO events

  • AllowEventCategory - monitor specific event categories (discussed later)

  • AllowEventSeverity - monitor events having one or more of the following severity levels associated with them.
Code | Severity Enumeration
00 | naEventSeveritySUCCESS - the operation completed successfully
01 | naEventSeverityINFORMATIONAL - events that occur without impact on the measurement integrity
10 | naEventSeverityWARNING - events that occur with potential impact on measurement integrity
11 | naEventSeverityERROR - events that occur with serious impact on measurement integrity

List of Events

The following is a list of categories and the general types of events they include. Click the link view the event details.

Category Enumeration | Callback
naEventCategory_PARSER | OnSCPIEvent
naEventCategory_MEASURE | OnMeasurementEvent
naEventCategory_CHANNEL | OnChannelEvent
naEventCategory_HW | OnHardwareEvent
naEventCategory_CAL | OnCalEvent
naEventCategory_USER | OnUserEvent
naEventCategory_DISPLAY | OnDisplayEvent
naEventCategory_GENERAL | OnSystemEvent

Note: Use the MessageText Method to get a text message describing the event.

Out of Range Errors

When you attempt to set a value on an active function that is beyond the range (min or max) of the allowable values, the analyzer limits that value to an appropriate value (min or max) and sets the function to the limited value. From the front panel controls this is visually evident by the limited value in the edit box or by the annotation on the display. An example would be attempting to set the start frequency below 300kHz. The edit control doesn't allow the number to fall below 300kHz.

When the automation user programs a setting (such as start frequency below the allowable limits) the same behavior takes place. The analyzer accepts the limited value. However, in order to learn what setting took place, you have to read the HRESULT.

All automation calls return HRESULTs. By default the HRESULT returned when an overlimit occurs is S_NA_LIMIT_OUTOFRANGE. This value is a success code, meaning that bit 31 in this 32 value is 0. Programmers should check the return code from all automation calls to determine success or failure.

Some C++ macros (like SUCCEEDED(hr) or FAILED(hr) ) only check bit 31. So if you are interested in trapping this outOfRange error you will have to check for S_NA_LIMIT_OUTOFRANGE explicity.

Alternatively, you can configure the analyzer to report outOfRange conditions with an error code. Use the method: App.SetFailOnOverRange (true). With this method set TRUE, any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

This method is provided for the benefit of VB clients. VB users can't detect specific success codes because the VB runtime strips off the HRESULT and only raises a run time error if bit 31 is set, indicating a fail code.

Troubleshooting Problems with Callbacks

When you do callbacks, the client PC becomes the server and the analyzer (server) becomes the client. Callbacks can only take place when both server and client are in the same workgroup or in the same domain. See Configure for COM.


C++ and the COM Interface

Programming The PNA with C++

The programming information contained in this Help system is aimed at the Visual Basic programmer. VB does a lot of work for the programmer when it comes to managing and accessing components. Using a lower level language like C++ requires a more thorough understanding of the underlying tenets of COM. It is not the intent of this section to teach COM programming. The following is intended to acquaint you with some of the basic concepts you need to know in order to program against COM.

Initializing COM

Importing the Type Library

Creating the Application Object

Errors

Events

Additional Reading

Example

Note: The information in this section assumes development on a Windows OS using Microsoft tools.

Initializing COM

The first thing you must do before performing any COM transactions is to initialize the COM library. You can do this in a number of ways. The most basic of these is a call to CoInitialize( ) or CoIntializeEx( ). Alternatively you can use the MFC (Microsoft Foundation Classes) AfxOleInit( ).

Conversely, before your program exits you must uninitialize COM. You can accomplish this with CoUninitialize( ) or the MFC routine AfxOleTerm( ).

Importing the Type Library

To make a component available to the client, the server exports what is called the type library. For the PNA, this file is 835x.tlb. It is located on the PNA's hard drive at C:\Program Files\ Agilent\ Network Analyzer\ Automation. See Configure for COM-DCOM Programming.

The type library can be read and deciphered using another COM interface called ITypeLib. VB uses this interface to present, for example, its object browser. Visual C++ can also read type libraries. This is done by importing the type library into your project with a compiler directive:

#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb", named_guids

When you compile your program with this statement in it, the compiler creates two other files: 835x.tlh and 835x.tli. The first is a header file that contains the type definitions for the PNA's COM interfaces and their methods. The second file contains inline functions that wrap the PNA's interface methods. The wrappers are beneficial in that they contain error reporting for each of the method calls.

The .tlh file defines a smart pointer which you can use to access the PNA's objects. The smart pointer definition looks like this:

_com_smartptr_typedef(Iapplication, _uuidof(Iapplication))

A smart pointer is a term used for a C++ object that encapsulates a pointer used to refer to a COM object. All COM objects derive from the interface IUnknown. This interface has three methods: QueryInterface( ), AddRef( ), and Release( ). The function of the AddRef and Release methods is to maintain a reference count on the object and thus control the object's lifetime. Anytime you copy or create a reference to a COM object, you are responsible for incrementing its reference count. And likewise, when you are finished using that reference, it is your responsibility to Release it. Smart pointers do this work for you, as shown in the example program. In addition, smart pointers will also perform the QueryInterface call when required. QueryInterface is a method that requests a specific interface from an object. In the example program we gain access to the IArrayTransfer interface of the Measurement object. In the ReadMethod routine, we see this:

PTransferData = pMeas;

The assignment operator is overloaded for the smart pointer and in reality, this simple statement does this:

HRESULT hr = pMeas->QueryInterface( IID_IArrayTransfer,(void**)&pTransferData);

Using the existing interface pointer (pMeas) to the object, this call asks the object if it supports the IArrayTransfer interface, and if so to return a pointer to it in pTransferData. Smart pointer makes life easier for the C++ programmer. Read more about smart pointers in Microsoft Developer's Network Library (MSDN).

Creating the Application Object

The only createable object exported by the PNA is the Application object. Typically this would be done with a call to CoCreateInstance:

STDAPI CoCreateInstance(
CLSID__IApplication, //Class identifier (CLSID) of the object
NULL, //Pointer to controlling IUnknown
CLS_CTX_SERVER, //Context for running executable code
IID_IApplication, //Reference to the IID of the interface
(void**)&pNA //Address of output variable that receives
// the interface pointer requested in riid
);

With the smart pointer, this is taken care of with the following call:

IApplicationPtr pNA; // declare the smart pointer
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

Errors

All COM method calls are required to return an HRESULT. This is 32 bit long with a specific format.

  • The most significant bit indicates success(0) or failure(1).

  • The lower 16 bits indicate the specific failure.

Visual Basic strips off the returned HRESULT and raises an error object for non-successful returns. The C++ programmer must himself be diligent about handling errors. You must check the return value of each COM call to ensure its success.

Events

The Application object sources the INetworkAnalyzerEvents interface. This object is the source for all events. To use events in C++, you must do two things:

  1. Implement the INetworkAnalyzerEvents interface - derive an object from INetworkAnalyzerEvents and implement the methods described there.

  2. Subscribe to the IconnectionPoint interface of the Application object. - obtain a pointer to the IConnectionPointContainer interface of the Application object and making the following request:

FindConnectionPoint( IID_InetworkAnalyzerEvents, &pConnection );

A successful call to this interface will return a valid pointer in pConnection. Use this pointer to subscribe to the Application object:

pConnect->Advise( IUnknown* punk, DWORD dwCookie);

This call provides the server object with a callback address. The Iunkown pointer in this call is the IUnkown pointer of the object that implements the INetworkAnalyzerEvents interface. This is the event sink. The application object needs a pointer to this object in order to call your interface when an event occurs. The dwCookie is your subscription key. Use it to unsubscribe (see Unadvise( ) ).

Additional Reading

"MSDN" - Microsoft Developer's Network Library

"Learning DCOM", by Thuan L. Thai, published by O'Reilly(1999)

"Inside COM", by Dale Rogerson, published by Microsoft Press (1997),

"Understanding ActiveX and OLE", by David Chappell, also published by Microsoft Press (1996), and

"Beginning ATL COM Programming", published by Wrox Press (1998).

Example

The example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries. In the example, notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

See the example program.


SCPI Command Tree

:CORRection

Sets Electrical Delay and Phase Offset

:DATA?

Queries measurement data.

:FILTer

Sets time domain gating

:FORMat

Sets the display format

:FUNCtion

Controls Trace Statistics

:LIMit

Controls limit lines for pass / fail testing

:MARKer

Controls the marker settings

:MATH

Performs math on the memory trace

:PARameter

Creates and deletes measurements

:RDATa?

Queries receiver data

:SMOothing

Controls point-to-point smoothing

:TRANsform

Controls time domain transform settings

:AVErage

Sets sweep averaging parameters

:BANDwidth

Specifies the IF filter bandwidth

:CORRection

Provides calibration capability.

:CORR:COLL:CKIT

Defines calibration standards

:COUPle

Sets sweep as Chopped or Alternate

:FREQuency

Controls frequency sweep functions

:POWer

Sets receiver attenuation and overpower protection

:ROSCillator

Returns the source of the reference oscillator.

:SEGMent

Defines the segment sweep settings.

:SWEep

Specifies the sweep modes of the analyzer.

See Also...

SCPI Command Tree

IEEE- 488.2 Common Commands

SCPI Commands

ABORt

Stops all sweeps

CALCulate __Click to show CALC commands

DISPlay

Controls the display settings

FORMat

Sets the format for data transfer

HCOPy

Controls hardcopy printing

INITiate

Sets continuous or manual triggering

MMEMory

Saves and recalls instrument states

OUTPut

Turns RF power ON and OFF

SENSe __Click to show SENSe commands

SOURce

Controls the power to the DUT

STATus

Reads the analyzer status registers

SYSTem

Controls the analyzer defaults

TRIGger

Starts or ends a measurement


About Triggering

Abort Command

ABORt

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep.
Examples | ABOR abort
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:ABORt


Common Commands

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Agilent Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TRG - Trigger

Triggers a sweep on the active measurement channel when in trigger hold mode (ignored if the analyzer is in continuous sweep mode).

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status. An 0 indicates no failures found. Any other value indicates one or more of the following conditions exist. The value returned is the Weight (or sum of the Weights) of the existing conditions. For example:

  • If 4 is returned from *TST?, an Overpower condition exists.

  • If 6 is returned, both Unleveled and Overpower conditions exists.
Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Phase Unlock | the source has lost phaselock. This could be caused by a reference channel open or a hardware failure.
1 | 2 | Unleveled | the source power is unleveled. This could be a source is set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
2 | 4 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
3 | 8 | EE Write Failed | an attempted write to the EEPROM has failed. This is possibly caused by a hardware failure.
4 | 16 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
5 | 32 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
6 | 64 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization


Correction

About Phase Accuracy

Calc:Correction Commands

Controls Electrical Delay and Phase Offset

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. To select the measurement use CALC<ChanNum>:PAR:SEL <MeasName>.

CALCulate<cnum>:CORRection:EDELay:TIME <num>

(Read-Write) Sets the electrical delay for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor.
Examples | CALC1:CORR:EDEL:TIME 1NS calculate2:correction:time 0.5e-12
Query Syntax | CALCulate:CORRection:EDELay:TIME?
Return Type | Character
Overlapped? | No
Default | 0 seconds

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>]

(Read-Write) Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:CORR:OFFS:PHAS 10 calculate:correction:offset:phase 20rad
Query Syntax | CALCulate:CORRection:OFFSet:PHASe?
Return Type | Character, returned value always in degrees
Overlapped? | No
Default | 0 degrees

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:CORRection:EDELay:TIME 10e-12
:CALCulate1:CORRection:EDELay:TIME?
:CALCulate 1:CORRection:OFFSet:PHASe 90deg
:CALCulate 1:CORRection:OFFSet:PHASe?


Data

FDATA - one number per trace point
SDATA - two numbers per trace point
FMEM - one number per trace point
SMEM - two numbers per trace point
All Error Terms - two numbers per trace point

Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflect.Tracking | 1
SCORR4 | Isolation | 1
SCORR5 | Load Match | 1
SCORR6 | Trans.Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflect.Tracking | 2
SCORR10 | Isolation | 2
SCORR11 | Load Match | 2
SCORR12 | Trans.Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflection Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflection Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Reflect.Tracking | 1
SCORR7 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR2 | Reflect.Tracking | 1
SCORR8 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR12 | Transmission Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR4 | Isolation | 1
SCORR12 | Transmission Tracking | 2
SCORR10 | Isolation | 2

See Also...

About Accessing Data

Calc:Data Command

CALCulate<cnum>:DATA <char>

Write Measurement data, Memory data, or Error terms.

CALCulate<cnum>:DATA? <char>
Read Measurement data, Memory data, or Error terms.
Return Data Format:

Parameters

<cnum> - Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char> - To write or read Measurement and Memory Data, choose from:

FDATA - formatted trace data from measResult location
SDATA - corrected complex trace data from rawMeas location
FMEM - formatted memory data from memResult location
SMEM - corrected complex data from rawMemory location

<char> - To write or read Error Terms...

For 2-Port SOLT and TRL calibrations,

For 1-Port calibrations:

For Response Open calibrations:

For Response Short calibrations:

For Response Thru calibrations:

For Response Thru and Isolation calibrations:

EXAMPLE - See an example using this command.

Overlapped? - No

Default - Not Applicable

Notes:

  • When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • When querying error terms, there must be error terms in the analyzer.

  • If interpolation is ON and the number of points changes after the initial calibration, the error terms will then be the interpolated results.

  • To get and put receiver data, see CALC:RDATA?

  • To get uncorrected ratioed data, turn correction OFF and use Calc:Data SDATA.

  • CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Learn more about Error Terms


Filter

About Gating

Calc:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start / stop) or (center / span) commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

(R ead-Write) Sets the gate filter center time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:CENT -5 ns calculate2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

(R ead-Write) Sets the gating filter shape when in time domain. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE - NORMal - MINimum - the narrowest gate filter available
Examples | CALC:FILT:GATE:TIME:SHAP MAX calculate2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

(R ead-Write) Sets the gate filter span time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Time span in seconds; Choose any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:SPAN 5 ns calculate2:filter:time:span maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

(R ead-Write) Turns gating state ON or OFF. Critical Note: Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<boolean> | ON (or 1) - turns gating ON. OFF (or 0) - turns gating OFF.
Examples | CALC:FILT:TIME:STAT ON calculate2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

(R ead-Write) Sets the gate filter start time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STAR 1e-8 calculate2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

(R ead-Write) Sets the gate filter stop time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STOP -1 ns calculate2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

(R ead-Write) Sets the type of gate filter used. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:FILT:TIME BPAS calculate2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Overlapped? | No
Default | BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:FILTer:GATE:TIME:CENTer 10ms
:CALCulate1:FILTer:GATE:TIME:CENTer?
:CALCulate1:FILTer:GATE:TIME:SHAPe MAX
:CALCulate1:FILTer:GATE:TIME:SHAPe?
:CALCulate1:FILTer:GATE:TIME:SPAN 10ms
:CALCulate1:FILTer:GATE:TIME:SPAN?
:CALCulate1:FILTer:GATE:TIME:STARt 10ms
:CALCulate1:FILTer:GATE:TIME:STARt?
:CALCulate1:FILTer:GATE:TIME:STATe ON
:CALCulate1:FILTer:GATE:TIME:STATe?
:CALCulate1:FILTer:GATE:TIME:STOP 10ms
:CALCulate1:FILTer:GATE:TIME:STOP?
:CALCulate1:FILTer:GATE:TIME:TYPE NOTCh
:CALCulate1:FILTer:GATE:TIME:TYPE?


Format Calc

About Data Format

Calc:Format Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

  • See an example us ing this command.

CALCulate<cnum>:FORMat <char>

(Read-Write) Sets the display format for the measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

  • MLINear

  • MLOGarithmic

  • PHASe

  • IMAGinary

  • REAL

  • POLar

  • SMITh

  • SWR

  • GDELay

Examples

CALC:FORM MLIN
calculate2:format polar

Query Syntax

CALCulate<cnum>:FORMat?

Return Type

Character

Overlapped?

No

Default

MLINear

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FORMat MLIN
:CALCulate 1:FORMat?


Function

About Trace Statistics

Calc:Function Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FUNCtion:DATA?

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Return Type

Character

Example

CALCulate2:FUNCtion:DATA?

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

(Read-Write) Sets the range used to calculate trace statistics. Each channel shares 10 domain ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<range>

Range number. Choose from: 0 to 9

  • 0 is Full Span of the current x-axis range

  • 1 to 9 are user-specified ranges

Examples

CALC:FUNC:DOM:USER 4
calculate2:function:domain:user:range 0

Query Syntax

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe]?

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

(Read-Write) Sets the start of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:STOP. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 9
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STAR 1,1e9 calculate2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

(Read-Write) Sets the stop of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:START. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 9
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STOP 4,5e9 calculate2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:FUNCtion:TYPE <char>

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace
Examples | CALC:FUNC:TYPE PTP calculate2:function:type stdev
Query Syntax | CALCulate<cnum>:FUNCtion:TYPE?
Return Type | Character
Overlapped? | No
Default | PTPeak

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FUNCtion:DATA?
:CALCulate 1:FUNCtion:DOMain:USER:RANGe 0
:CALCulate 1:FUNCtion:DOMain:USER:RANGe?
:CALCulate 1:FUNCtion:DOMain:USER:STARt 1, 1e9
:CALCulate 1:FUNCtion:DOMain:USER:STARt? 1
:CALCulate 1:FUNCtion:DOMain:USER:STOP 4, 5e9
:CALCulate 1:FUNCtion:DOMain:USER:STOP? 4
:CALCulate 1:FUNCtion:TYPE PTP
:CALCulate 1:FUNCtion:TYPE?


Limit

About Limit Lines

Calc:Limit Commands

Controls the limit segments used for pass / fail testing.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:LIMit:DATA <block>

(Read-Write) Sets data for limit segments. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

"CALC:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30"

Query Syntax

CALCulate<cnum>:LIMit:DATA?

Return Type

Definite length block - All 100 predefined limit segments are returned.

Overlapped?

No

Default

100 limit segments - all values set to 0

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

(Read-Write) Turns the display of limit segments ON or OFF (if the data trace is turned ON). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns the display of limit segments ON. OFF (or 0) - turns the display of limit segments OFF.
Examples | CALC:LIM:DISP:STAT ON calculate2:limit:display:state off
Query Syntax | CALCulate<cnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STAR 10 calculate2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

(Read-Write) Sets the start (beginning) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:STIM:STAR 10 calculate2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

(Read-Write) Sets the stop (end) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

(Read-Write) Sets the type of limit segment. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:LIM:SEGM:TYPE LMIN calculate2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE?
Return Type | Character
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

(Read-Write) Turns limit testing fail sound ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns sound ON. OFF (or 0) - turns sound OFF.
Examples | CALC:LIM:SOUN ON calculate2:limit:sound:state off
Query Syntax | CALCulate<cnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:STATe <ON | OFF>

(Read-Write) Turns limit segment testing ON or OFF. Use CALC:LIM:DISP to turn ON and OFF the display of limit segments. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns limit testing ON. OFF (or 0) - turns limit testing OFF.
Examples | CALC:LIM:STAT ON calculate2:limit:state off
Query Syntax | CALCulate<cnum>:LIMit:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:LIMit:DATA <block>
:CALCulate1:LIMit:DATA?
:CALCulate 1:LIMit:DISPlay:STATe ON
:CALCulate 1:LIMit:DISPlay:STATe?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt 1e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP 3e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP?
:CALCulate 1:LIMit:SEGMent 1:TYPE LMAX
:CALCulate 1:LIMit:SEGMent 1:TYPE?
:CALCulate 1:LIMit:SOUNd:STATe OFF
:CALCulate 1:LIMit:SOUNd:STATe?
:CALCulate 1:LIMit:STATe ON
:CALCulate 1:LIMit:STATe?


Marker

About Markers

Calc:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Note: The Reference Marker is Marker Number 10

CALCulate<cnum>:MARKer:AOFF

(Write-only) Turns all markers off for selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MARK:AOFF calculate2:marker:aoff
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:MARKer:BWIDth <num>

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

This feature activates markers 1 through 4. To turn off these markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.
Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between:
-500 and 500

Examples

CALC:MARK:BWID -3
calculate2:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Overlapped?

No

Default

-3

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MARK:REF:STATE. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker is a Delta marker OFF (or 0) - Specified marker is an ABSOLUTE marker
Examples | CALC:MARK:DELT ON calculate2:marker8:delta off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DELTa?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker displays the actual data points OFF (or 0) - Specified marker displays calculated data between the actual data points.
Examples | CALC:MARK:DISC ON calculate2:marker8:discrete off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<char> | Choose from: DEFault - The format of the selected measurement MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude IMPedance - (R+jX) ADMittance - (G+jB) PHASe - Phase IMAGinary - Imaginary part (Im) REAL - Real part (Re)l POLar - (Re, Im) GDELay - Group Delay
Examples | CALC:MARK:FORMat MLIN calculate2:marker8:format Character
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FORMat?
Return Type | Character
Overlapped? | No
Default | DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Character
Overlapped? | No
Default | -100

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel shares 10 domain ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<span>

User span. Choose any Integer from 0 to 9.

0 is Full Span of the analyzer
1 to 9 are available for user-defined x-axis span

Examples

CALC:MARK:FUNC:DOM:USER 1
calculate2:marker8:function:domain:user 1

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER?
Returns the user span number that the specified marker is assigned to.

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.
Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MARK:FUNC:DOM:USER:START 500E6
calculate2:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Character

Overlapped?

No

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STARt to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STOP

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<stop>

Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.

Examples

CALC:MARK:FUNC:DOM:USER:STOP 500e6
calculate2:marker8:function:domain1:user:stop 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?

Return Type

Character

Overlapped?

No

Default

The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

(Write-only) Immediately executes (performs) the specified search function. If no function is specified, executes the selected function. Select the function with CALC:MARK:FUNCtion:SEL. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<func>

Optional argument. The function that is to be performed. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right, wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC:EXEC
calculate2:marker2:function:execute maximum

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

(Read-Write) Sets the search function that the specified marker will perform when executed. To execute (or perform) the function, use:
CALC:MARK:FUNC:EXEC or
CALC:MARK:FUNC:TRAC ON to automatically execute the search every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right; wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC MAX
calculate2:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect]?

Overlapped?

No

Default

MAX

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

(Read-Write) Sets the target value for the specified marker when doing Target Searches (CALC:MARK:FUNC:SEL <TARGet | RTARget | LTARget> Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Target value to search for; Units are NOT allowed.
Examples | CALC:MARK:TARG 2.5 calculate2:marker8:target -10.3
Query Syntax | CALCulate<cnum>:MARKer<mkr>:TARGet?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

(Read-Write) Sets the tracking capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MARK:FUNC:EXECute command every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - The specified marker will "Track" (find) the selected function every sweep.

OFF (or 0) - The specified marker will find the selected function only when the CALC:MARK:FUNC:EXECute command is sent.

Examples

CALC:MARK:FUNC:TRAC ON
calculate2:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

(Read-Write) Turns the reference marker (marker 10) ON or OFF. When turned OFF, existing Delta markers revert to absolute markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns reference marker ON OFF (or 0) - turns reference marker ON
Examples | CALC:MARK:REF ON calculate2:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MARKer:REFerence[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer:REFerence:X <num>

(Read-Write) Sets and returns the absolute x-axis value of the reference marker (marker 10). Critical Note:

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

X-axis value. Choose any number within the operating domain of the reference marker.

Examples

CALC:MARK:REF:X 1e9

calculate2:marker:reference:x 1e6

Query Syntax

CALCulate<cnum>:MARKer:REFerence:X?

Return Type

Character

Overlapped?

No

Default

If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MARKer:REFerence:Y?

(Read-only) Returns the absolute Y-axis value of the reference marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:MARK:REF:Y?

calculate2:marker:reference:y?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

(Read-Write) Sets the type of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
NORMal - a marker that stays on the assigned X-axis position unless moved or searching.
FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MARK:TYPE NORM
calculate2:marker2:type fixed

Query Syntax

CALCulate<cnum>:MARKer<mkr>:TYPE?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MARKer<mkr>:SET <char>

(Read-Write) Sets the selected instrument setting to assume the value of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
CENTer - changes center frequency to the value of the marker
SPAN - changes the frequency span to the value of the marker's domain
STARt - changes the start frequency to the value of the marker
STOP - changes the stop frequency to the value of the marker
RLEVel - changes the reference level to the value of the marker
DELay - changes the xxx delay to the value of the marker

Examples

CALC:MARK:SET CENT
calculate2:marker8:set span

Query Syntax

CALCulate<cnum>:MARKer<mkr>:SET?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

(Read-Write) Turns the specified marker ON or OFF. Marker 10 is the Reference Marker. To turn all markers off, use CALC:MARK:AOFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - turns marker ON. OFF (or 0) - turns marker OFF.
Examples | CALC:MARK ON calculate2:marker8 on
Query Syntax | CALCulate<cnum>:MARKer<mkr>:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

CALCulate<cnum>:MARKer<mkr>:X <num>

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Any X-axis position within the measurement span of the marker. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:X 100Mhz calculate2:marker8:x maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:X?
Return Type | Character
Overlapped? | No
Default | First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

CALCulate<cnum>:MARKer<mkr>:Y?

(Read-only) Sets the marker's Y-axis value. The format of the value depends on the current CALC:MARKER:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • All other formats - (Value,0)

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

Examples

CALC:MARK:Y?
calculate2:marker3:y?

Query Syntax | CALCulate<cnum>:MARKer<mkr>:Y?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MARKer:AOFF
:CALCulate 1:MARKer:BWIDth -2.513
:CALCulate 1:MARKer:BWIDth?
:CALCulate 1:MARKer 1:DELTa ON
:CALCulate 1:MARKer 1:DELTa?
:CALCulate 1:MARKer 1:DISCrete ON
:CALCulate 1:MARKer 1:DISCrete?
:CALCulate 1:MARKer 1:FORMat DEF
:CALCulate 1:MARKer 1:FORMat?
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion?
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER 1
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP?
:CALCulate 1:MARKer 1:FUNCtion:EXECute MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect?
:CALCulate 1:MARKer 1:TARGet -10.3
:CALCulate 1:MARKer 1:TARGet?
:CALCulate 1:MARKer 1:FUNCtion:TRACking ON
:CALCulate 1:MARKer 1:FUNCtion:TRACking?
:CALCulate 1:MARKer:REFerence:STATe ON
:CALCulate 1:MARKer:REFerence:STATe?
:CALCulate 1:MARKer:REFerence:X 10
:CALCulate 1:MARKer:REFerence:X?
:CALCulate 1:MARKer:REFerence:Y?
:CALCulate 1:MARKer 1:TYPE NORM
:CALCulate 1:MARKer 1:TYPE?
:CALCulate 1:MARKer 1:SET CENT
:CALCulate 1:MARKer 1:SET?
:CALCulate 1:MARKer 1:STATe ON
:CALCulate 1:MARKer 1:STATe?
:CALCulate 1:MARKer 1:X 1Ghz
:CALCulate 1:MARKer 1:X?
:CALCulate1:MARKer1:Y?


Math Calc

About Math Operations

Calc:Math Commands

Controls math operations on the currently selected measurement and memory.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:MATH:FUNCtion <char>

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

The math operation to be applied. Choose from the following:

NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory

Examples

CALC:MATH:FUNC NORM
calculate2:math:function subtract

Query Syntax

CALCulate<cnum>:MATH:FUNCtion?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MATH:MEMorize

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MATH MEM calculate2:math:memorize
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MATH:FUNCtion NORM
:CALCulate 1:MATH:FUNCtion?
:CALCulate 1:MATH:MEMorize


Parameter

About Measurement Parameters

Calc:Parameter Commands

Lists, creates, selects and deletes measurements

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:PARameter:CATalog?

(Read-only) Returns the names and parameters of existing measurements for the specified channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurements to be listed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:CAT? calculate2:parameter:catalog?
Query Syntax | CALCulate<cnum>:PARameter:CATalog?
Return Type | String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"
Overlapped? | No
Default | "CH1_S11_1,S11"

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>

(Write-only) Creates a measurement but NOT display it.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND<wnum>:TRAC<tnum>:FEED <Mname> to display the measurement.

You must select the measurement (CALC<cnum>:PAR:SEL <mname>) before making additional settings. Critical Note:

Parameters

<cnum>

Channel number of the new measurment. Choose any number between:
1 and 4
If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes

<param>

Parameter; Choose from the following for S-Parameter measurements:
S11 | S12 | S21 | S22

Or choose from the following for non S-Parameter measurements. Specify the source port with SENSe:SWEep:SRCPort <1|2>

A | B | R1 | R2 | A/B | B/A

Examples

CALC:PAR:DEF "Test,S12
calculate2:parameter:define "test,s22

Query Syntax

Not Applicable; see Calc:Par:Cat?

Overlapped?

No

Default

Not Applicable

CALCulate<cnum>:PARameter:DELete <Mname>

(Write-only) Deletes the specified measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement
Examples | CALC:PAR:DEL TEST calculate2:parameter:delete "test"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:SELect <Mname>

(Read-Write) Sets the selected measurement. Most CALC: commands require that this command be sent before a setting change is made. One measurement on each channel can be selected at the same time. To obtain a list of currently named measurements, use CALC:PAR:CAT? Critical Note:
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement. (Do NOT include the parameter name.)
Examples | CALC:PAR:SEL TEST calculate2:parameter:select "test"
Query Syntax | CALCulate:PARameter:SELect?
Return Type | String
Overlapped? | No
Default | No Selection

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:PARameter:CATalog?
:CALCulate 1:PARameter:DEFine "CH1_S21,S21"
:CALCulate 1:PARameter:DELete "CH1_S21"
:CALCulate 1:PARameter:SELect "CH1_S11"
:CALCulate 1:PARameter:SELect?


RData

About Unratioed Measurements

Calc:RData Command

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:RDATA? <char>

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA? Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from receivers: A B R1 R2 REF - returns either R1 or R2 data depending on the source port of the CALC-selected measurement.
Example | GPIB.Write "INITiate:CONTinuous OFF" GPIB.Write "INITiate:IMMediate;*wai" GPIB.Write "CALCulate:RDATA? A"
Return Type | Character - Two numbers per data point
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:RDATA? A


Smoothing Calc

About Smoothing

Calc:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:SMOothing:APERture <num>

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:SMO:APER 2 calculate2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Character
Overlapped? | No
Default | 1.5

CALCulate<cnum>:SMOothing:POINts <num>

(Read-Write) Sets the number of adjacent data points to average. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:SMO:POIN 50 calculate2:smoothing:points 21
Query Syntax | CALCulate<cnum>:SMOothing:POINts?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

(Read-Write) Turns data smoothing ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns smoothing ON. OFF (or 0) - turns smoothing OFF.
Examples | CALC:SMO ON calculate2:smoothing:state off
Query Syntax | CALCulate<cnum>:SMOothing[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:SMOothing:APERture 25
:CALCulate1:SMOothing:APERture?
:CALCulate1:SMOothing:POINts 10
:CALCulate1:SMOothing:POINts?
:CALCulate1:SMOothing:STATe ON
:CALCulate1:SMOothing:STATe?


Transform Calc

About Time Domain

Calc:Transform Commands

Specifies the settings for time domain transform.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

(Read-Write) Sets the center time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:CENT 1e-8 calculate2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDth <num>

(Read-Write) Sets the impulse width for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:TRAN:TIME:IMP:WIDTh 10 calculate2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Character
Overlapped? | No
Default | .98 / Default Span

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

(Read-Write) Sets the parametric window for the Kaiser Bessel window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:TRAN:TIME:KBES 10 calculate2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:KBESsel?
Return Type | Character
Overlapped? | No
Default | 6

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

(Write-only) Sets the start frequencies in LowPass Mode. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:TRAN:TIME:LPFR calculate2:transform:time:lpfrequency
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

(Read-Write) Sets the span time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:SPAN 1e-8 calculate2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:TRANsform:TIME:STARt <num>

(Read-Write) Sets the start time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STAR 1e-8 calculate2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | -10 ns

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

(Read-Write) Turns the time domain transform capability ON or OFF. Critical Note: Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON|OFF> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:TRAN:TIME:STAT ON calculate2:transform:time:state off
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:TRANsform:TIME:STOP <num>

(Read-Write) Sets the stop time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STOP 1e-8 calculate2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

(Read-Write) Sets the step rise time for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:TRAN:TIME:STEP:RTIM 1e-8 calculate2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Character
Overlapped? | No
Default | .99 / Default Span

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:
STEP - simulates a step DUT stimulus
IMPulse - simulates a pulse DUT stimulus

STEP can ONLY be used when CALC:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME:STIM STEP
calculate2:transform:time:stimulus impulse

Query Syntax

CALCulate<cnum>:TRANsform:TIME:STIMulus?

Return Type

Character

Overlapped?

No

Default

IMPulse

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

(Read-Write) Sets the type of time domain measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME LPAS
calculate2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Overlapped?

No

Default

BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:TRANsform:TIME:CENTer 10ms
:CALCulate 1:TRANsform:TIME:CENTer?
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth 110ps
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth?
:CALCulate 1:TRANsform:TIME:KBESsel 6
:CALCulate 1:TRANsform:TIME:KBESsel?
:CALCulate 1:TRANsform:TIME:LPFREQuency
:CALCulate 1:TRANsform:TIME:SPAN 20ms
:CALCulate 1:TRANsform:TIME:SPAN?
:CALCulate 1:TRANsform:TIME:STARt 10ms
:CALCulate 1:TRANsform:TIME:STARt?
:CALCulate 1:TRANsform:TIME:STATe ON
:CALCulate 1:TRANsform:TIME:STATe?
:CALCulate 1:TRANsform:TIME:STEP:RTIMe 110ps
:CALCulate 1:TRANsform:TIME:STEP:RTIMe?
:CALCulate 1:TRANsform:TIME:STIMulus STEP
:CALCulate 1:TRANsform:TIME:STIMulus?
:CALCulate 1:TRANsform:TIME:STOP 20ms
:CALCulate 1:TRANsform:TIME:STOP?
:CALCulate 1:TRANsform:TIME:TYPE LPASs
:CALCulate 1:TRANsform:TIME:TYPE?


Display

About Screen Setup

DISPlay Commands

Controls the settings of the front panel screen.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<ON | OFF> | ON (or 1) - turns frequency annotation ON. OFF (or 0) - turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

(Write-only) Enables and disables error pop-up messages on the display.
Parameters |
<ON | OFF> | ON (or 1) - enables error pop-up messages OFF (or 0) - disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:STATus <ON|OFF>

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<ON | OFF> | ON (or 1) - turns status bar ON. OFF (or 0) - turns status bar OFF.
Examples | DISP:ANN:STAT ON display:annotation:status off
Query Syntax | DISPlay:ANNotation:STATus?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:CATalog?

(Read-only) Returns the existing Window numbers.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Overlapped? | No
Default | Not applicable

DISPlay:ENABLE <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay[:TILE]

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the left of the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the buttons ON. OFF (or 0) - turns the buttons OFF.
Examples | DISP:WIND:ANN:TRAC:STAT ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation:TRACe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Marker data (when markers are ON) on the selected window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns marker data ON. OFF (or 0) - turns marker data OFF.
Examples | DISP:WIND:ANN:MARK:STAT ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:CATalog?

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
Return Type | String of Character values, separated by commas
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

Write to create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between: 1 and 4
<ON | OFF> | ON (or 1) - The window <wnum> is created. OFF (or 0) - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA "hello" display:window2:title:data "hello"
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be redisplayed when turned back ON.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the title string ON. OFF (or 0) - turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

(Write-only) Creates a new trace <tnum> and associates (feed) a measurement <name> to the specified window<wnum>. This command should be executed immediately after creating a new measurement with CALC:PAR:DEF<name>,<parameter>.

To feed the same measurement to multiple traces, create another measurement with the same <name>,<parameter> using the CALC:PAR:DEF command. The analyzer will collect the data only once.

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Trace number to be created. Choose any Integer between:
1 and 4

<name>

Name of the measurement that was defined with CALC:PAR:DEF<name>,<parameter>

Examples

DISP:WIND:TRAC:FEED "test"
display:window2:trace2:feed "test

Query Syntax

Not applicable

Overlapped?

No

Default

"CH1_S11"

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

(Read-Write) Turns the memory trace ON or OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the memory trace ON. OFF (or 0) - turns the memory trace OFF.
Examples | DISP:WIND:TRAC:MEM ON display:window2:trace2:memory:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>:MEMory[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

(Write-only) Activates the specified trace in the specified window for front panel use.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:SEL display:window2:trace2:select
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

(Read-Write) Turns the display of the specified trace in the specified window ON or OFF. When OFF, the measurement behind the trace is still active.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the trace ON. OFF (or 0) - turns the trace OFF.
Examples | DISP:WIND:TRAC ON display:window2:trace2:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

(Write-only) Performs an Autoscale on the specified trace in the specified window, providing the best fit display. Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:Y:AUTO display:window2:trace2:y:scale:auto
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

(Read-Write) Sets the Y axis Per Division value of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:PDIV 1 display:window2:trace2:y:scale:pdivision maximum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision?
Return Type | Character
Overlapped? | No
Default | 10

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

(Read-Write) Sets the Y axis Reference Level of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Reference level value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:RLEV 0 display:window2:trace2:y:scale:rlevel minimum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel?
Return Type | Character
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

(Read-Write) Sets the Reference Position of the specified trace in the specified window

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Any existing trace number; if unspecified, value is set to 1

<num>

Reference position on the screen measured in horizontal graticules from the bottom. The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:WIND:TRAC:Y:RPOS 0
display:window2:trace2:y:rposition maximum

Query Syntax

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition?

Return Type

Character

Overlapped?

No

Default

5

List of all commands in this block:
(Parameters in bold italics)

:DISPlay:ANNotation:FREQuency:STATE ON
:DISPlay:ANNotation:FREQuency:STATE?
:DISPlay:ANNotation:STATus ON
:DISPlay:ANNotation:STATus?
:DISPlay:CATalog?
:DISPlay:ENABLE ON
:DISPlay:ENABLE?
:DISPlay:TILE
:DISPlay:WINDow 1:ANNotation:TRACe:STATe ON
:DISPlay:WINDow 1:ANNotation:TRACe:STATe?
:DISPlay:WINDow 1:ANNotation:MARKer:STATe ON
:DISPlay:WINDow 1:ANNotation:MARKer:STATe?
:DISPlay:WINDow 1:CATalog?
:DISPlay:WINDow 1:ENABle ON
:DISPlay:WINDow 1:ENABle?
:DISPlay:WINDow 1:STATe ON
:DISPlay:WINDow 1:STATe?
:DISPlay:WINDow 1:TABLe OFF
:DISPlay:WINDow 1:TABLe?
:DISPlay:WINDow 1:TITLe:DATA "hello"
:DISPlay:WINDow 1:TITLe:DATA?
:DISPlay:WINDow 1:TITLe:STATe ON
:DISPlay:WINDow 1:TITLe:STATe?
:DISPlay:WINDow 1:TRACe 1:DELete
:DISPlay:WINDow 1:TRACe 1:FEED "test"
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe ON
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe?
:DISPlay:WINDow 1:TRACe 1:SELect
:DISPlay:WINDow 1:TRACe 1:STATe ON
:DISPlay:WINDow 1:TRACe 1:STATe?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:AUTO
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision 20
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition?


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data. These commands will effect data that is transferred with the CALC:DATA and CALC:RDATA commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

FORMat:BORDer <char>

(Write-only) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.

Parameters

<char>

Choose from:
NORMal - Use when your controller is anything other than an IBM compatible computers
SWAPped - for IBM compatible computers

Examples

FORM:BORD SWAP
format:border normal

Query Syntax

FORMat:BORDer?

Overlapped?

No

Default

Normal

FORMat[:DATA] <char>

(Read-Write) Sets the data format for use during transfer of measurement data.
Parameters |
<char> | Choose from: REAL,32 - (default value for REAL) Best for transfering large amounts of measurement data. REAL,64 - Slower but has more significant digits than REAL,32. Use REAL,64 if you have a computer that doesn't support REAL,32. ASCii,0 - The easiest to implement, but very slow. Use if small amounts of data to transfer.
Examples | FORM REAL,64 format:data ascii
Query Syntax | FORMat:DATA?
Return Type | Character,Character
Overlapped? | No
Default | REAL,32

List of all commands in this block:
(Parameters in bold italics)

FORMat:BORDer NORMal
FORMat:BORDer?
FORMat:DATA ASCii,0
FORMat:DATA?


Hardcopy

About Printing

Hardcopy Command

HCOPy[:IMMediate]

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable


Initiate

About Triggering

Initiate Commands

Controls triggering signals

INITiate:CONTinuous <boolean>

(Read-Write) Specifies whether the analyzer sends Continuous sweep triggers to triggerable channels or enables Manual triggering.
Parameters |
<boolean> | ON (or 1) - Continuous sweep mode. OFF (or 0) - Manual sweep mode.
Examples | INIT:CONT ON initiate:continuous off
Query Syntax | INITiate:CONTinuous?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

INITiate<cnum>[:IMMediate]

(Write-only) Stops the current sweeps and immediately sends a trigger to the specified channel. (Same as Sweep \ Trigger \ Restart on the front panel.)

  • If the specified channel is in HOLD, it will sweep one time and return to HOLD when complete.

  • If Trigger:Scope = Global, all channels will receive a trigger.

  • If Trigger:Scope = Channel (only the active channel receives a trigger) and the specified channel is not the active channel, the specified channel will NOT receive a trigger signal.

  • If the specified channel is NOT in Manual trigger (INIT:CONT OFF), the analyzer will return an error.

  • If channel <cnum> does not exist, the analyzer will return an error.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not applicable

Overlapped?

Yes

Default

Not applicable

List of all commands in this block:
(Parameters in bold italics)

:INITiate:CONTinuous ON
:INITiate:CONTinuous?
:INITiate 2:IMMediate


Memory

About Save / Recall

Memory Commands

The memory commands control saving and loading instrument states to the hard drive.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

All MMEM files have an extension according to their type.

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

The default folder is "C:\Program Files\Agilent\Network Analyzer\Documents"

You can change the active directory using MMEMory:CDIRectory, or you can use an absolute path name to specify all MMEM files and folders.

MMEMory:CATalog[:<char>]? [<folder>]

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned.
Parameters |
<char> | The type of files to list. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified then ALL file types (even unknown types) are listed.
<folder> | Any existing folder name. If unspecified C:\Program Files\Agilent\Network Analyzer\Documents is used.
Examples | MMEM:CAT? 'lists all files from the current folder mmemory:catalog:correction? "C:\Program Files\Agilent\Network Analyzer\Documents" 'lists .cal files from the specified folder
Overlapped? | No
Default | Not applicable

MMEMory:CDIRectory <folder>

(Read-Write) Changes the folder name.

Parameters

<folder>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:CDIR Service

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory "\automation" 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory "c:\automation\service"

Query Syntax

MMEMory:CDIRectory? 'Returns the current folder name

Return Type

String

Overlapped?

No

Default

"C:\Program Files\Agilent\Network Analyzer\Documents"

MMEMory:COPY <file1>,<file2>

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | Name of the file to be copied.
<file2> | Name of the file to be created from file1.
Examples | MMEM:COPY "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:DELete <file>

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | Name of the file to be deleted.
Examples | MMEM:DEL "MyFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:LOAD[:<char>] <file>

(Write-only) Loads the specified file.
Parameters |
<char> | The type of file to load. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If <char> is unspecified, the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of the file to be loaded. The default folder is used if unspecified in the filename.
Examples | MMEM:LOAD "MyFile.cst" mmemory:load:state "MyInstState"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MDIRectory <folder>

(Write-only) Makes a folder.
Parameters |
<folder> | Name of the folder to make.
Examples | MMEM:MDIR "MyFolder" mmemory:mdirectory "c:\NewFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MOVE <file1>,<file2>

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | Name of the file to be renamed.
<file2> | Name of the new file.
Examples | MMEM:MOVE "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:RDIRectory <folder>

(Write-only) Removes the specified folder.
Parameters |
<folder> | Name of the folder to remove.
Examples | MMEM:RDIR "MyFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe[:<char>] <file>

(Write-only) Stores the specified file.
Parameters |
<char> | The type of file to store. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified, then the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of any valid file that is not already in existance.
Examples | MMEM:STOR:STAT "myState" mmemory:store "c:\bin\myState.sta"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:MMEMory:CATalog:STATe? "C:\Program Files\Agilent\Network Analyzer\Documents"
:MMEMory:CDIRectory "\documents"
:MMEMory:CDIRectory?
:MMEMory:COPY "myState.sta","yourState"
:MMEMory:DELete "myState.sta"
:MMEMory:LOAD:STATe "myState"
:MMEMory:MDIRectory"myFolder"
:MMEMory:MOVE "myState.sta","yourState.sta"
:MMEMory:RDIRectory "myFolder"
:MMEMory:STORe:STATe "myState"


Output

About Power

Output Command

OUTPut[:STATe] <ON | OFF>

(Read-Write) Turns RF power from the source ON or OFF.
Parameters |
<ON | OFF> | ON (or 1) - turns RF power ON. OFF (or 0) - turns RF power OFF.
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

List of all commands in this block:
(Parameters in bold italics)

:OUTPut:STATe ON?
:OUTPut:STATe?


Average SCPI

About Averaging

Sens:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:AVERage:CLEar

(Write-only) Clears and restarts averaging of the measurement data. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

(Read-Write) Sets the number of measurement sweeps to combine for an average. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurement sweeps to average. Choose any number between: 1 and 1024
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns averaging ON. OFF (or 0) - turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:AVERage:CLEar
:SENSe 1:AVERage:COUNt 10
:SENSe 1:AVERage:COUNt?
:SENSe 1:AVERage:STATe ON
:SENSe 1:AVERage:STATe?


Sense Bandwidth

About IF Bandwidth

Sense:Bandwidth Command

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. The keywords BAND or BWID are interchangeable.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

IF Bandwidth in Hz. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Examples

SENS:BWID 1KHZ
sense2:bandwidth:resolution 1000

Query Syntax

SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:BANDwidth:RESolution 1000
:SENSe 1:BANDwidth:RESolution?


Sense Correction

About Measurement Calibration

Sense:Correction Commands

Performs and applies measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe:CORRection:COEFficient <term>[,port]

(Write-only) Displays the selected error term as trace data. Correction must be turned on.

Note: This command displays error terms for only Channel 1 measurements

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<term>

Error term to be displayed:

Specify this: | to get this Term...
1 | Directivity
2 | Source Match
3 | ReflectionTracking
4 | Isolation
5 | Load Match
6 | Transmission Tracking

[port]

Optional Parameter - Port number of the source drive. If unspecified, value is set to 1.

Examples

SENS:CORR:COEF 1
'Displays the directivity term for port 1 source

SENS:CORR:COEF 2,2
'Displays the source match for port 2 source

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <char>

(Write-only) Measures the specified standard from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

<char> | Measures the standards associated with these class labels:
STAN1 | S11A and S22A
STAN2 | S11B and S22B
STAN3 | S11C and S22C
STAN4 | S21T and S12T - usually the THRU standard
STAN5 | Generic Isolation; not associated with calibration kit definition
ECALA | ECAL module A
ECALB | ECAL module B

Examples

SENS:CORR:COLL STAN1
sense2:correction:collect:acquire stan5

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:METHod <char>

(Read-Write) Sets the calibration method. (Also known as 'Calibration Type' on calibration dialog box.)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
REFL1OPEN | Response Open
REFL1SHORT or REFL1 | Response Short
REFL3 | Full 1 port
TRAN1 | Response Thru
TRAN2 | Response Thru and Isolation
SPARSOLT | Full SOLT 2 port

Examples

SENS:CORR:COLL:METH REFL1
sense2:correction:collect:method sparsolt

Query Syntax

SENSe<cnum>:CORRection:COLLect:METHod?

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

(Write-only) Calculates the error terms using the selected :METHod and applies the error terms to the selected measurement (turns error correction ON.) Does NOT save the calibration error-terms.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:SAVE sense2:correction:collect:save
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:CSET[:SELect] <char>

(Read-Write) Restores a correction data set from memory. The file name is "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: DEF - Presets the analyzer USER01- Restores User01 calibration data USER02 - Restores User02 calibration data through... USER10 - Restores User10 calibration data
Examples | SENS:CORR:CSET DEF sense2:correction:cset:select user02
Query Syntax | SENSe<cnum>:CORRection:CSET[:SELect]?
Return Type | Charact er
Overlapped? | No
Default | DEF

SENSe<cnum>:CORRection:CSET:SAVE <char>

Write a correction data set to memory or Read the last correction set saved. The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: USER01 USER02... USER10
Examples | SENS:CORR:CSET:SAVE USER03 sense2:correction:cset:save user09
Query Syntax | SENSe<cnum>:CORRection:CSET:SAVE? Queries the last correction set saved.
Return Type | Charact er
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified port. Must also set SENS:CORR:EXT ON.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Number of the port that will receive the extension. If unspecified, value is set to 1. Choose from:

1 | Port 1
2 | Port 2

<num>

The port extension in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:PORT 2MS
sense2:correction:extension:port2 .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified receiver. Must also set SENS:CORR:EXT ON .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<Rnum>

Number of the receiver that will receive the extension. If unspecified, value is set to 1
Choose from:

1 | Receiver A
2 | Receiver B

<num>

The electrical length in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:REC 2MS
sense2:correction:extension:receiver2:time .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

(Read-Write) Turns port extensions ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port entensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance: INPut:MAGNitude?
Return Type | Character
Overlapped? | No
Default | 50

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

(Read-Write) Turns correction interpolation ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolation:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

(Read-Write) Turns isolation cal ON or OFF during Full 2-port calibration. If this comand is not sent, the default state is to disable Isolation.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns isolation ON. OFF (or 0) - turns isolation OFF.
Examples | SENS:CORR:ISOL ON sense2:correction:isolation:state off
Query Syntax | SENSe<cnum>:CORRection:ISOLation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF - (Isolation disabled)

SENSe<cnum>:CORRection:RVELocity:COAX <num>

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between: 0 and 10 (.66 polyethylene dielectric; .7 teflon dielectric) Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

(Read-Write) Specifies whether or not correction data is applied to the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the measurement. OFF (or 0) - correction is NOT applied to the measurement.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COEFficient 2,1
:SENSe1:CORRection:COLLect:ACQuire STAN1
:SENSe1:CORRection:COLLect:ACQuire?
:SENSe1:CORRection:COLLect:APPLy
:SENSe1:CORRection:COLLect:AVERage:COUNt 4
:SENSe1:CORRection:COLLect:AVERage:COUNt?
:SENSe1:CORRection:COLLect:METHod SPARSOLT
:SENSe1:CORRection:COLLect:METHod?
:SENSe1:CORRection:COLLect:SAVE
:SENSe1:CORRection:CSET:SELect USER05
:SENSe1:CORRection:CSET:SELect?
:SENSe1:CORRection:CSET:SAVE USER03
:SENSe 1:CORRection:CSET:SAVE?
:SENSe1:CORRection:EXTension:PORT2:TIME 2ms
:SENSe1:CORRection:EXTension:PORT2:TIME?
:SENSe1:CORRection:EXTension:RECeiver2:TIME 2ms
:SENSe1:CORRection:EXTension:RECeiver2:TIME?
:SENSe1:CORRection:EXTension:STATe ON
:SENSe1:CORRection:EXTension:STATe?
:SENSe1:CORRection:INTerpolation:STATe ON
:SENSe1:CORRection:INTerpolation:STATe?
:SENSe1:CORRection:ISOLation:STATe ON
:SENSe1:CORRection:ISOLation:STATe?
:SENSe1:CORRection:RVELocity:COAX .66
:SENSe1:CORRection:RVELocity:COAX?
:SENSe1:CORRection:STATe ON
:SENSe1:CORRection:STATe?


CorrCollCKIT

About Modifying Cal Kits

Sense:Correction:Collect:CKit Commands

Use to change the definitions of calibration kit standards.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL .

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

SENSe:CORRection:COLLect:CKIT:NAME <name>

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME MYAPC35 sense:correction:collect:ckit:name mytypen
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <standard>

(Read-Write) Sets a standard number to a calibration class. Does NOT set or dictate the order for measuring the standards. For more information, see Calibration Standards / Fabricating Calibration Standards / Assigning Standards to a Calibration Class

Parameters

<class>

Number of the calibration class that is assigned to <standard>. Choose a number between:
1 and 8
The <class> numbers are associated with the following calibration classes:

<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard

<standard>

Standard number between 1 and 8

Examples

Assigns standard 3 to S11A class:
SENS:CORR:COLL:CKIT:ORD1 3
Assigns standard 2 to S21T class class:
sense:correction:collect:ckit:order4 2

Query Syntax

SENSe:CORRection:COLLect:CKIT:ORDer?

Return Type

Character; returns the <class> number of the selected standard.

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:RESet <num>

(Write-only) Resets the selected calibration kit to factory default definition values.
Parameters |
<num> | The number of the calibration kit to be reset. Choose any integer between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:RESet 1 sense:correction:collect:ckit:reset 4
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

(Read-Write) Selects (makes active) a calibration kit. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>

Parameters

<num>

The number of the calibration kit. The following are the default settings. Choose from:

<num> | Name | Model
1 | Type N 85032F | 85032F
2 | 3.5mm 85033E | 85033E
3 | Type N | 85032B
4 | 3.5mm 85033D | 85033D
5 | 7-16 85038A | 85038A
6 | 3.5mm TRL | 85052C
7 | User Defined 7 | NA
8 | User Defined 8 | NA
9 | User Defined 9 | NA
10 | User Defined 10 | NA
99 | ECAL module | NA

Examples

SENS:CORR:COLL:CKIT 2
sense2:correction:collect:ckit:select 7

Query Syntax

SENSe:CORRection:COLLect:CKIT?

Return Type

Charact er

Overlapped?

No

Default

1

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard.
Parameters |
<num> | Value for C0 in picofarads
Examples | The following commands set C0=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard.
Parameters |
<num> | Value for C1 in picofarads
Examples | The following two commands set C1=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard.
Parameters |
<num> | Value for C2 in picofarads
Examples | The following two commands set C2=(-15) picofarads: SENS:CORR:COLL:CKIT:STAN:C2 -15 sense:correction:collect:ckit:standard:c2 -15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard.
Parameters |
<num> | Value for C3 in picofarads
Examples | The following two commands set C3=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | String
Overlapped? | No
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in seconds
Examples | SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmax 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

(Read-Write) Sets the minumum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fmin 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Character
Overlapped? | No
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard.
Parameters |
<num> | Value for L0 in picohenries
Examples | The following two commands set L0=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard.
Parameters |
<num> | Value for L1 in picohenries
Examples | The following two commands set L1=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard.
Parameters |
<num> | Value for L2 in picohenries
Examples | The following two commands set L2=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard.
Parameters |
<num> | Value for L3 in picohenries
Examples | The following two commands set L3=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB "OPEN" sense:correction:collect:ckit:standard:label "Short2"
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Character
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD THRU (Through)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COLLect:CKIT:NAME mytypen
:SENSe:CORRection:COLLect:CKIT:NAME?
:SENSe:CORRection:COLLect:CKIT:ORDer 4 2
:SENSe:CORRection:COLLect:CKIT:ORDer?
:SENSe:CORRection:COLLect:CKIT:RESet 1
:SENSe:CORRection:COLLect:CKIT:SELect 7
:SENSe:CORRection:COLLect:CKIT?
:SENSe:CORRection:COLLect:CKIT:STANdard:C0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C0?
:SENSe:CORRection:COLLect:CKIT:STANdard:C1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C1?
:SENSe:CORRection:COLLect:CKIT:STANdard:C2 -15
:SENSe:CORRection:COLLect:CKIT:STANdard:C2?
:SENSe:CORRection:COLLect:CKIT:STANdard:C3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C3?
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter COAX
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay 50ps
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9Ghz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 1khz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50.3
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
:SENSe:CORRection:COLLect:CKIT:STANdard:L0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L0?
:SENSe:CORRection:COLLect:CKIT:STANdard:L1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L1?
:SENSe:CORRection:COLLect:CKIT:STANdard:L2 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L2?
:SENSe:CORRection:COLLect:CKIT:STANdard:L3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L3?
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel "Short2"
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 3.5e9
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT 8
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT?
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE LOAD
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?


Couple

About Alternate Sweep

Sense:Couple Command

SENSe<cnum>:COUPle <ALL | NONE>

(Read-Write) Sets the sweep mode as Chopped or Alternate.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ALL | NONE> | ALL - Sweep mode set to Chopped - reflection and transmission measured on the same sweep. NONE - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases sweep time
Examples | SENS:COUP ALL sense2:couple none
Query Syntax | SENSe<cnum>:COUPle?
Return Type | Character
Overlapped? | No
Default | ALL

List of all commands in this block:
(Parameters in bold italics)

:SENSe1:COUPle ALL
:SENSe1:COUPle?


Frequency

About Frequency Sweep

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:FREQuency:CENTer <num>

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000
sense2:frequency:center 1mhz

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

(Read-Write) Sets the Continuous Wave (or Fixed) frequency. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Character

Overlapped?

No

Default

1 GHz

SENSe<cnum>:FREQuency:SPAN <num>

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span. Choose any number between:
0 (minimum) and the maximum frequency span of the anal yzer.
Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

(Read-Write) Sets the start frequency of the analyzer.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz Note: If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START. Note: This command will accept MIN or M AX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:FREQ:STAR 1000000 sense2:frequency:start MIN
Query Syntax | SENSe<cnum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer. Units are Hz

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

Return Type

Character

Overlapped?

No

Default

Maximum frequency of the analyzer

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:FREQuency:CENTer 1mhz
:SENSe 1:FREQuency:CENTer?
:SENSe1:FREQuency:CW 100e6
:SENSe1:FREQuency:CW?
:SENSe 1:FREQuency:SPAN 10e6
:SENSe 1:FREQuency:SPAN?
:SENSe 1:FREQuency:STARt 10e6
:SENSe 1:FREQuency:STARt?
:SENSe 1:FREQuency:STOP 1e9
:SENSe 1:FREQuency:STOP?


Power

About Receiver Attenuation

Sense:Power Command

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

(Read-Write) Sets the attenuation level for the specified receiver. Note: Attenuation cannot be set with Sweep Type set to Power
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<recvr> | Receiver to get attenuation. Choose from: ARECeiver - receiver A BRECeiver - receiver B
<num> | Choose from: 0 to 35 dB - in 5 dB steps If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 15 dB attenuation.
Examples | SENS:POW:ATT AREC,10 sense2:power: attentuation breceiver,30
Query Syntax | SENSe<cnum>:POWer :ATTenuation? <rec>
Return Type | Character
Overlapped? | No
Default | 0

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:POWer:ATTenuation AREC,10
:SENSe1:POWer:ATTenuation? AREC


Roscillator

About the Reference Osc.

Sense:Roscillator Command

SENSe:ROSCillator:SOURce?

(Read-only) Applying a signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked. EXT is returned when a signal is present at the Reference Oscillator connector. INT is returned when NO signal is present at the Reference Oscillator connector.
Examples | SENS:ROSC:SOUR? sense:roscillator:source?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:ROSCillator:SOURce?


Segment

About Segment Sweep

Sense:Segment Commands

Defines the segment sweep settings. Enable segment sweep with SENS:SWE:TYPE SEGMent.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SEGMent<snum>:ADD

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

(Read-Write) Sets the IFBandwidth for the specified segment. First set SENS:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |
If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ
sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment OFF (or 0) - turns Bandwidth control OFF. Use channel bandwidth setting
Examples | SENS:SEGM:BWID:CONT ON sense2:segment:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent:COUNt?

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Character
Overlapped? | No
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

(Write-only) Deletes the specified sweep segment.
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Number of the segment to delete. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:DELete:ALL

(Write-only) Deletes all sweep segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

(Read-Write) Sets the Start Frequency for the specified sweep segment. Note: All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STAR 1MHZ sense2:segment2:frequency:start minimum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

(Read-Write) Sets the Stop Frequency for the specified sweep segment. Note: All other segment's Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STOP 1MHZ sense2:segment2:frequency:stop maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?
Return Type | Character
Overlapped? | No
Default | If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON. All subsequent segments that are added assume the new Power Level value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<port> | Port number of the source. Choose from 1 or 2. If unspecified, value is set to 1.
<num> | Power level. Choose from any number between: -90 and 20
Examples | SENS:SEGM:POW 0 sense2:segment2:power1:level -10
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Power Level control ON. Power level can be set for each segment. OFF (or 0) - turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF
<ON | OFF> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent[:STATe]? <snum>
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:POIN 51 sense2:segment2:sweep:points maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to sweep the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Sweep time in seconds. Choose a number between 0 and 100 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Sweep Time control ON. Sweep Time can be set for each segment. OFF (or 0) - turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIM:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SEGMent 1:ADD
:SENSe 1:SEGMent 1:BWIDth:RESolution 1000
:SENSe 1:SEGMent 1:BWIDth:RESolution?
:SENSe 1:SEGMent:BANDwidth:CONTrol ON
:SENSe 1:SEGMent:BANDwidth:CONTrol?
:SENSe 1:SEGMent:COUNt?
:SENSe 1:SEGMent 1:DELete
:SENSe 1:SEGMent:DELete:ALL
:SENSe 1:SEGMent 1:FREQuency:CENTer 1e6
:SENSe 1:SEGMent 1:FREQuency:STARt?
:SENSe 1:SEGMent 1:FREQuency:SPAN 1e6
:SENSe 1:SEGMent 1:FREQuency:SPAN?
:SENSe 1:SEGMent 1:FREQuency:START 1e6
:SENSe 1:SEGMent 1:FREQuency:START?
:SENSe 1:SEGMent 1:FREQuency:STOP 1e6
:SENSe 1:SEGMent 1:FREQuency:STOP?
:SENSe 1:SEGMent 1:POWer 1:LEVel -10
:SENSe 1:SEGMent 1:POWer 1:LEVel?
:SENSe 1:SEGMent:POWer:LEVel:CONTrol ON
:SENSe 1:SEGMent:POWer:LEVel:CONTrol?
:SENSe 1:SEGMent 1:STATe ON
:SENSe1:SEGMent1:STATe?
:SENSe 1:SEGMent 1:SWEep:POINts 400
:SENSe 1:SEGMent 1:SWEep:POINts?
:SENSe 1:SEGMent 1:SWEep:TIME .001
:SENSe 1:SEGMent 1:SWEep:TIME?
:SENSe 1:SEGMent:SWEep:TIME:CONTrol ON
:SENSe 1:SEGMent:SWEep:TIME:CONTrol?


Sweep SCPI

About Sweeping

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SWEep:DWELl <num>

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENSe:SWEep:GENeration set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dwell min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Character

Overlapped?

No

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:GENeration <char>

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Overlapped?

No

Default

Analog

SENSe<cnum>:SWEep:GROups:COUNt <num>

(Read-Write) Sets the trigger count (groups) for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:MODE <char>

(Read-Write) Sets the trigger mode for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Trigger mode. Choose from: HOLD - channel will not trigger CONTinuous - channel triggers indefinitely GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>
Examples | SENS:SWE:MODE CONT sense2:sweep:mode hold
Query Syntax | SENSe<cnum>:SWEep:MODE?
Return Type | Character
Overlapped? | YES - SENS:SWE:MODE GROUPS (when INIT:CONT is ON) NO - HOLD and CONTinuous
Default | CONTinuous

SENSe<cnum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SWEep:SRCPort <1 | 2>

(Read-Write) Sets the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<1 | 2> | 1 - Source power comes out Port 1 2 - Source power comes out Port 2
Examples | SENS:SWE:SRCP 1 sense2:sweep:srcport 2
Query Syntax | SENSe<cnum>:S WEep:SRCPort?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to complete one sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Sweep time in seconds. Choose a number between 0 and 86,400 (24hrs) Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:TIME 1ms sense2:sweep:time .001
Query Syntax | SENSe<cnum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | NA

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

(Read-Write) Specifies whether the specified channel will measure one point for each trigger or all of the measurements in the channel. Setting any channel to POINt mode will automatically set the TRIGger:SCOPe = CURRent.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - Channel measures one data point per trigger. OFF (or 0) - All measurements in the channel made per trigger.
Examples | SENS:SWE:TRIG:POIN ON sense2:sweep:trigger:point off
Query Syntax | SENSe<cnum>:SWEep:TRIGger:POINt?
Return Type | Boolean (1 = Point, 0 = Measurement)
Overlapped? | No
Default | 0 - Measurement

SENSe<cnum>:SWEep:TYPE <char>

(Read-Write) Sets the type of analyzer sweep mode.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Overlapped? | No
Default | LINear

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SWEep:DWELL 2ms
:SENSe 1:SWEep:DWELL?
:SENSe 1:SWEep:DWELL:AUTO ON
:SENSe 1:SWEep:DWELL:AUTO?
:SENSe 1:SWEep:GENeration STEP
:SENSe 1:SWEep:GENeration?
:SENSe 1:SWEep:GROups:COUNt 50
:SENSe 1:SWEep:GROups:COUNt?
:SENSe 1:SWEep:MODE CONT
:SENSe 1:SWEep:MODE?
:SENSe 1:SWEep:POINts 201
:SENSe 1:SWEep:POINts?
:SENSe 1:SWEep:SRCPort 1
:SENSe 1:SWEep:SRCPort?
:SENSe 1:SWEep:TIME 2ms
:SENSe 1:SWEep:TIME?
:SENSe 1:SWEep:TIME:AUTO ON
:SENSe 1:SWEep:TIME:AUTO?
:SENSe 1:SWEep:TRIGger:POINt ON
:SENSe 1:SWEep:TRIGger:POINt?
:SENSe 1:SWEep:TYPE LINear
:SENSe 1:SWEep:TYPE?


source

About Power Settings

Source Commands

Controls the power delivered to the DUT.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SOURce<cnum>:POWer<port>:ATTenuation <num>

(Read-Write) Sets the attenuation level for the selected channel. Sending this command turns automatic attenuation control (SOUR:POW:ATT:AUTO) to OFF. If the ports are coupled, changing the attenuation on one port will also change the attenuation on the other port. To turn port coupling OFF use SOURce:POWer:COUPle OFF.

Note: Attenuation cannot be set with Sweep Type set to Power

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Choose a number between 0 and 70 dB, in 10 dB steps.
If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 10 dB attenuation.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW:ATT 10
source2:power:attentuation maximum

Query Syntax

SOURce<cnum>:POWer<port>:ATTenuation?

Return Type

Character

Overlapped?

No

Default

0

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

(Read-Write) Turns automatic attenuation control ON or OFF. Setting an attenuation value (using SOURce:POWer:ATTenuation <num>) sets AUTO OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns coupling ON. The analyzer automatically selects the appropriate attenuation level to meet the specified power level. OFF (or 0) - turns coupling OFF. Attenuation level must be set using SOURce:POWer:ATTenuation <num>.
Examples | SOUR:POW2:ATT:Auto On source2:power: attentuation:auto off
Query Syntax | SOURce<cnum>:POWer:ATTenuation:Auto?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:CENTer <num>

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Choose a number between -90 and 20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:COUPle <ON | OFF>

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns coupling ON. Power level can be set individually for each source port. OFF (or 0) - turns coupling OFF. The same power level is used for both source ports.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

(Read-Write) Sets the source leveling loop as Internal or External.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<INTernal | EXTernal> | INTernal - Internal leveling is applied to the source EXTernal - External leveling is applied to the source through a rear-panel jack.
Examples | SOUR:POW:DET INT source2:power:detector external
Query Syntax | SOURce<cnum>:POWer:DETector?
Return Type | Character
Overlapped? | No
Default | INTernal

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate]
[:AMPLitude] <num>

(Read-Write) Sets the RF power output level.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Source power in dBm. Choose any value between -90 and +20 dBm
Actual achievable leveled power depends on frequency.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW1 5DB
source2:power:level
:immediate:amplitude maximum

Query Syntax

SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

(Read-Write) Sets the RF power slope value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<int> | Slope value in db/GHz. Choose any integer between -2 and 2 (0 is no slope).
Examples | SOUR:POW:SLOP 2 source2:power:slope -2
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Character
Overlapped? | No
Default | 0

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

(Read-Write) Turns Power Slope ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SOURce<cnum>:POWer:SPAN <num>

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Span power. Choose a number between:
-90 and 20 dBm
(actual achievable leveled power depends on frequency)

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer:STARt <num>

(Read-Write) Sets the power sweep start power. Must also set SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:STOP <num>

(Read-Write) Sets the power sweep stop power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Character
Overlapped? | No
Default | 0 dBm

List of all commands in this block:
(Parameters in bold italics)

:SOURce 1:POWer1:ATTenuation 5
:SOURce 1:POWer1:ATTenuation?
:SOURce 1:POWer1:ATTenuation:AUTO ON
:SOURce 1:POWer1:ATTenuation:AUTO?
:SOURce 1:POWer:CENTer -7
:SOURce 1:POWer:CENTer?
:SOURce1:POWer:COUPle ON
:SOURce1:POWer:COUPle?
:SOURce 1:POWer:DETector INTernal
:SOURce 1:POWer:DETector?
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude 5
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude?
:SOURce 1:POWer:LEVel:SLOPe -2
:SOURce 1:POWer:LEVel:SLOPe?
:SOURce 1:POWer:LEVel:SLOPe:STATe ON
:SOURce 1:POWer:LEVel:SLOPe:STATe?
:SOURce 1:POWer:SPAN -7
:SOURce 1:POWer:SPAN?
:SOURce 1:POWer:STARt 0
:SOURce 1:POWer:STARt?
:SOURce 1:POWer:STOP 5
:SOURce 1:POWer:STOP?


Status

About Status Registers

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

Click on a blue register to view the details

Note: Any bit not shown in the registers is not used but may be reserved for future use.

Status Byte Register

Summarizes the states of the other registers and monitors the analyzer's output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

Questionable Summary Register

Summarizes conditions that monitor the quality of measurement data.

STATus:QUEStionable:<keyword>

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

Integrity Summary Register

Summarizes conditions in the Measurement Integrity register.

STATus:QUEStionable:INTegrity <keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
0 | 2 | Hardware Summary | any bit in the Hardware event register is set to 1

Hardware Register

Monitors the status of hardware failures.

STATus:QUEStionable:INTegrity:HARDware<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:HARD:COND?

:ENABle <bits>

STAT:QUES:INT:HARD:ENAB 1024

[:EVENt]?

STAT:QUES:INT:HARD?

:NTRansition <bits>

STAT:QUES:INT:HARD:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:HARD:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Phase Unlock | the source has lost phaselock, possibly caused by a reference channel open or a hardware failure.
2 | 4 | Unleveled | the source power is unleveled. This could be caused by a source set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
3 | 8 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
4 | 16 | EE Write Failed | an attempted write to the EEPROM has failed, possibly caused by a hardware failure.
5 | 32 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
6 | 64 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
7 | 128 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

Measurement Register

Monitors the lag between changing a channel settings and when the data is ready to query out.

When you change the channel state (start/stop freq, bandwidth, and so on), then the questionable bit for that channel gets set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next complete sweep has been taken (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

STATus:QUEStionable:INTegrity:MEASurement<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS?

:NTRansition <bits>

STAT:QUES:INT:MEAS:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Channel1 | a channel1 setting change has occured and the data does not yet reflect that change.
1 | 2 | Channel2 | a channel2 setting change has occured and the data does not yet reflect that change.
2 | 4 | Channel3 | a channel3 setting change has occured and the data does not yet reflect that change.
3 | 8 | Channel4 | a channel4 setting change has occured and the data does not yet reflect that change.

Limit1 Register

Monitors the status of limit line failures and summarizes the Limit2 event register. When a trace fails, or any bit in the Limit2 event register fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note:The '1' on 'LIMit1 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit1<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM1:COND?

:ENABle <bits>

STAT:QUES:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LIM1?

:NTRansition <bits>

STAT:QUES:LIM1:NTR 1024

:NTRansition?

STAT:QUES:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LIM1:PTR 0

:PTRansition?

STAT:QUES:LIM1:PTR?

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Limit 2 Reg summary | any point from limit2 event register fails
1 | 2 | Trace 1 | any point on trace fails the limit test
2 | 4 | Trace 2 | any point on trace fails the limit test
3 | 8 | Trace 3 | any point on trace fails the limit test
4 | 16 | Trace 4 | any point on trace fails the limit test
5 | 32 | Trace 5 | any point on trace fails the limit test
6 | 64 | Trace 6 | any point on trace fails the limit test
7 | 128 | Trace 7 | any point on trace fails the limit test
8 | 256 | Trace 8 | any point on trace fails the limit test
9 | 512 | Trace 9 | any point on trace fails the limit test
10 | 1024 | Trace 10 | any point on trace fails the limit test
11 | 2048 | Trace 11 | any point on trace fails the limit test
12 | 4096 | Trace 12 | any point on trace fails the limit test
13 | 8192 | Trace 13 | any point on trace fails the limit test
14 | 16384 | Trace 14 | any point on trace fails the limit test

Limit2 Register

Monitors the status of limit line failures. When trace 15 or 16 fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note: The '2' on 'LIMit2 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit2<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM2:COND?

:ENABle <bits>

STAT:QUES:LIM2:ENAB 1024

[:EVENt]?

STAT:QUES:LIM2?

:NTRansition <bits>

STAT:QUES:LIM2:NTR 1024

:PTRansition <bits>

STAT:QUES:LIM2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace15 | any point on trace fails the limit test
2 | 4 | Trace16 | any point on trace fails the limit test

Define Summary Register

Summarizes conditions in the Questionable:Define:User<1|2|3> event registers.

STATus:QUEStionable:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:DEF:COND?

:ENABle <bits>

STAT:QUES:DEF:ENAB 1024

[:EVENt]?

STAT:QUES:DEF?

:NTRansition <bits>

STAT:QUES:DEF:NTR 1024

:PTRansition <bits>

STAT:QUES:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Questionable User Registers

Monitors conditions that you define and map in any of the three QUES:DEF:USER event registers.

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:QUES:DEF:USER1:ENABle 1024

[:EVENt]?

STAT:QUES:DEF:USER1?

:MAP <bit>,<error>

STAT:QUES:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

Standard Event Status Register

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

Operation Summary Register

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

STATus:OPERation<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |

Averaging1 Register

Monitors Averaging of Traces 1 to 14 and summarizes Traces 15 and 16.

Note:The '1' on 'AVERaging1 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging1<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | AVER2 summary | any enabled bit in AVERaging2 event register is set to 1
1 | 2 | Trace 1 | Averaging is complete
2 | 4 | Trace 2 | Averaging is complete
3 | 8 | Trace 3 | Averaging is complete
4 | 16 | Trace 4 | Averaging is complete
5 | 32 | Trace 5 | Averaging is complete
6 | 64 | Trace 6 | Averaging is complete
7 | 128 | Trace 7 | Averaging is complete
8 | 256 | Trace 8 | Averaging is complete
9 | 512 | Trace 9 | Averaging is complete
10 | 1024 | Trace 10 | Averaging is complete
11 | 2048 | Trace 11 | Averaging is complete
12 | 4096 | Trace 12 | Averaging is complete
13 | 8192 | Trace 13 | Averaging is complete
14 | 16384 | Trace 14 | Averaging is complete

Averaging2 Register

Monitors Averaging of Traces 15 and 16.

Note:The '2' on 'AVERaging2 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging2<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER2:COND?

:ENABle <bits>

STAT:OPER:AVER2:ENAB 1024

[:EVENt]?

STAT:OPER:AVER2?

:NTRansition <bits>

STAT:OPER:AVER2:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace 15 | Averaging is complete
2 | 4 | Trace 16 | Averaging is complete

Define Summary Register

Summarizes conditions in the OPERation:Define:User<1|2|3> event registers.

STATus:OPERation:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:DEF:COND?

:ENABle <bits>

STAT:OPER:DEF:ENAB 12

[:EVENt]?

STAT:OPER:DEF?

:NTRansition <bits>

STAT:OPER:DEF:NTR 12

:PTRansition <bits>

STAT:OPER:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Operation User Registers

Monitors conditions that you define and map in any of the three OPER:DEF:USER event registers.

STATus:OPERation:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:OPER:DEF:USER1:ENAB 1024

[:EVENt]?

STAT:OPER:DEF:USER1?

:MAP <bit>,<error>

STAT:OPER:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined


System

About Preset

System Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SYSTem:ERRor?

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Examples

SYST:ERR?
system:error?

Overlapped?

No

Default

Not applicable

SYSTem:ERRor:COUNt?

(Read-only) Returns the number of errors in the error queue.Use SYST:ERR? to read an error.
Examples | SYST:ERR:COUN? system:error:count?
Overlapped? | No
Default | Not applicable

SYSTem:PRESet

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Default.
Examples | SYST:PRES system:preset
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SYSTem:ERRor?
:SYSTem:ERRor:COUNt?
:STSTem:PRESet


Trigger SCPI

About Triggering

Trigger Commands

Starts or ends a measurement sequence. These commands are an important part of synchronizing measurements.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

TRIGger[:SEQuence]:SCOPe <char>

(Read-Write) Specifies whether triggers are applied to all channels or the current channel.
Parameters |
<char> | Choose from: ALL - triggers all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels. CURRent - trigger only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel. You can use CURRent only when TRIG:SOURCE = MANual.
Examples | TRIG:SCOP ALL trigger:sequence:scope current
Query Syntax | TRIGger[:SEQuence]:SCOPe?
Return Type | Character
Overlapped? | No
Default | ALL

TRIGger[:SEQuence]:SLOPe <char>

(Read-Write) Triggers either on the positive going or negative going trigger signal edge. This setting only has an effect when TRIG:SOURce EXTernal is selected.
Parameters |
<char> | Choose from: POSitive - external (rear panel) source NEGative - internal source sends indefinite trigger signals
Examples | TRIG:SLOP POS trigger:sequence:source negative
Query Syntax | TRIGger[:SEQuence]:SLOPe?
Return Type | Character
Overlapped? | No
Default | NEGative

TRIGger[:SEQuence]:SOURce <char>

(Read-Write) Sets the source of the sweep trigger signal. This command is a superset of INITiate:CONTinuous, which can NOT set the source to External.
Parameters |
<char> | Choose from: EXTernal - external (rear panel) source IMMediate - internal source sends continuous trigger signals MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.
Examples | TRIG:SOUR EXT trigger:sequence:source immediate
Query Syntax | TRIGger[:SEQuence]:SOURce?
Return Type | Character
Overlapped? | No
Default | IMMediate

List of all commands in this block:
(Parameters in bold italics)

:TRIGger:SEQuence:SCOPe ALL
:TRIGger:SEQuence:SCOPe?
:TRIGger:SEQuence:SLOPe POS
:TRIGger:SEQuence:SLOPe?
:TRIGger:SEQuence:SOURce EXT
:TRIGger:SEQuence:SOURce?


Channels, Windows, and Measurements using GPIB

SOURce and most SENSe commands act on the channel that is specified in the command. Channel 1 is default if not specified. There can be up to four channels present (numbers 1 to 4) in the analyzer at the same time.

Most DISPlay commands act on the window and trace specified in the command. Window1 and Trace1 are default if not specified. There can be up to four windows present (numbers 1 to 4) and up to four traces present in each window (numbers 1 to 4) at the same time.

CALCulate commands act on the selected measurement in the specified channel. Select the measurement for each channel using CALCulate<channel number>:PARameter:SELect <meas name>. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time.

The following Visual Basic program does the following:

  • Presets the analyzer

  • Create 2 windows

  • Create 2 Measurements

  • Feed the measurements to windows / traces

  • Change frequency ranges for channels

  • Select both measurements

  • Turn marker 1 ON for each measurement

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PREset"

'Create Measurements
GPIB.Write "CALCulate1:PARameter:DEFine 'Meas1',S11"
GPIB.Write "CALCulate2:PARameter:DEFine 'Meas2',S21"

' Turn on windows - creates if new
GPIB.Write "DISPlay:WINDow1:STATE ON"
GPIB.Write "DISPlay:WINDow2:STATE ON"

'Associate ("FEED") the measurement name('Meas1') to WINDow(1), and give the new TRACe a number(1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'Meas1'"
GPIB.Write "DISPlay:WINDow2:TRACe2:FEED 'Meas2'"

'Change each channel's frequency range
GPIB.Write "SENSe1:FREQuency:SPAN 1e9"
GPIB.Write "SENSe2:FREQuency:SPAN 2e9"

'Select both measurements
GPIB.Write "CALCulate1:PARameter:SELect 'Meas1'"
GPIB.Write "CALCulate2:PARameter:SELect 'Meas2'"

'Turn marker 1 ON for each measurement
GPIB.Write "CALCulate1:MARKer:STATe ON"
GPIB.Write "CALCulate2:MARKer:STATE ON"


Create a Measurement using GPIB

This Visual Basic program creates a new S21 measurement and displays it on the display. Use the links to see the command details.

To run this program, you need:

  • An established GPIB interface connection

'Preset the analyzer
GPIB.Write "SYSTem:PReset"

' Turn on window 1 - if new, creates it
GPIB.Write "DISPlay:WINDow1:STATE ON"

'Define a measurement name, parameter
GPIB.Write "CALCulate:PARameter:DEFine 'MyMeas',S21"

'Associate ("FEED") the measurement name ('MyMeas') to WINDow (1), and give the new TRACe a number (1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"


Catalog Measurements using GPIB

This Visual Basic Program does the following:

  • Catalogs the currently defined measurements, windows, and traces

  • Selects a measurement for further definition

  • Adds a Title to the window

To run this program, you need:

  • An established GPIB interface connection

Dim Meas as String
Dim Win as String
Dim Trace as String

'Read the current measurements in Channel 1
GPIB.Write "CALCulate1:PARameter:CATalog?"
Meas = GPIB.Read
MsgBox ("Ch1 Measurments: " & Meas)

'Read the current windows
GPIB.Write "DISPlay:CATalog?"
Win = GPIB.Read
MsgBox ("Windows: " & Win)

'Read current traces in window 1
GPIB.Write "DISPlay:WINDow1:CATalog?"
Trace = GPIB.Read
MsgBox ("Traces in Window1: " & Win)


Perform a Calibration using GPIB

This Visual Basic program does a Full 2-Port Calibration, including Isolation

To run this program, you need:

  • An established GPIB interface connection

  • A 2-port measurement set up with desired frequency range, power, and so forth, ready to be calibrated.

Sub SOLTCal()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'Select 2-Port Calibration
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Select a cal kit
Calkitnum = 3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Measure the standards
MsgBox "Connect OPEN's to Ports 1 and 2; then press OK"
Call Measurestandard("stan1")
MsgBox "Connect SHORT's to Ports 1 and 2; then press OK"
Call Measurestandard("stan2")
MsgBox "Connect LOAD's to Ports 1 and 2; then press OK"
Call Measurestandard("stan3")
MsgBox "Connect THRU between Ports 1 and 2; then press OK"
Call Measurestandard("stan4")
MsgBox "Disconnect Ports 1 and 2 for isolation; then press OK"
Call Measurestandard("stan5")

'Compute the coefficients and turn on error correction
GPIB.Write "SENSe:CORRection:COLLect:SAVE"

'Resume continuous sweep.
GPIB.Write "INITialize:CONTinuous ON"
End Sub

Sub Measurestandard(Std$)
'Store the results of a sweep as correction data
GPIB.Write "SENSe:CORRection:COLLect " & Std$

'Take a sweep;return when complete
GPIB.Write "INITiate:IMMediate;*OPC?"
OPCreply = GPIB.Read

End Sub


ECALibrate Using GPIB

The following program does an Electronic Calibration using an Agilent ECAL module
These commands do the following:

  • Acquire the standards

  • Move the error terms back into the analyzer

  • Enable the calibration

Note: A separate :SENS:CORR:COLL:SAVE is not needed.

To run this program, you need:

  • An established GPIB interface connection

Private Sub Command5_Click()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'ECal full 1 port and 2 port
'This program assumes you have already set up the analyzer for an S11 measurement over the frequency range, power, etc. that you want.

'Select the Ecal "Kit"
GPIB.Write "SENSe:CORRection:COLLect:CKIT 99"

'Choose a Calibration Type (comment out one of these)
GPIB.Write "SENSe:CORRection:COLLect:METHod refl3"
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Enable or disable (comment out one) measurement of isolation
GPIB.Write "SENSe:CORRection:ISOLation ON"
GPIB.Write "SENSe:CORRection:ISOLation OFF"

'Prompt for the ECal module
MsgBox ("Connect ECal module to Port 1, then press enter")

'Acquire and store the calibration terms - return (*OPC) when finished
GPIB.Write "SENSe:CORRection:COLLect:ACQuire ECALA;*OPC?"
X = GPIB.Read
MsgBox ("Done with calibration.")

End Sub


Modify a Calibration Kit using GPIB

This Visual Basic program:

  • Modifies Calibration kit number 3

  • Completely defines standard #4 (thru)

To run this program, you need:

  • An established GPIB interface connection

'Modifying cal kit number 3
Calkitnum = 3

'Designate the kit selection to be used for performing cal's
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Reset to factory default values.
GPIB.Write "SENSe:CORRection:COLLect:CKIT:RESet " & Val(Calkitnum)

'Name this kit with your own name
GPIB.Write "SENSe:CORRection:COLLect:CKIT:NAME 'My Cal Kit'"

'Assign standard numbers to calibration classes
'Set Port 1, class 1 (S11A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer1 8"
'Set Port 1, class 2 (S11B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer2 7"
'Set Port 1, class 3 (S11C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer3 3"
'Set Port 1, class 4 (S21T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer4 4"
'Set Port 2, class 1 (S22A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer5 8"
'Set Port 2, class 2 (S22B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer6 7"
'Set Port 2, class 3 (S22C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer7 3"
'Set Port 2, class 4 (S12T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer8 4"

'Set up Standard #4 completely
'Select Standard #4; the rest of the commands act on it
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard 4"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 300KHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9GHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:DELay 1.234 ns"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 23e6"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C0 0"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C1 1"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C2 2"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C3 3"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L0 10"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L1 11"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L2 12"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L3 13"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LABel 'My Special Thru'"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:TYPE THRU"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:CHARacteristic Coax"


Setup Sweep Parameters using GPIB

This Visual Basic program sets up sweep parameters on the Channel 1 measurement.

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"
'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'Set sweep type to linear
GPIB.Write "SENSe1:SWEep:TYPE LIN"

'Set IF Bandwidth to 700 Hz
GPIB.Write "SENSe1:BANDwidth 700"

'Set Center and Span Freq's to 4 GHz
GPIB.Write "SENSe1:FREQuency:CENTer 4ghz"
GPIB.Write "SENSe1:FREQuency:SPAN 4ghz"

'Set number of points to 801
GPIB.Write "SENSe1:SWEep:POINts 801"

'Set sweep generation mode to Analog
GPIB.Write "SENSe1:SWEep:GENeration ANAL"

'Set sweep time to Automatic
GPIB.Write "SENSe1:SWEep:TIME:AUTO ON"

'Query the sweep time
GPIB.Write "SENSe1:SWEep:TIME?
SweepTime = GPIB.Read


Setup the Display using GPIB

This Visual Basic program:

  • Sets data formatting

  • Turns ON the Trace, Title, and Frequency Annotation

  • Autoscales the Trace

  • Queries Per Division, Reference Level, and Reference Position

  • Turn ON and set averaging

  • Turn ON and set smoothing

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Set the Data Format to Log Mag
GPIB.Write ":CALCulate1:FORMat MLOG"

'Turn ON the Trace, Title, and Frequency Annotation
GPIB.Write "Display:WINDow1:TRACe1:STATe ON"
GPIB.Write "DISPlay:WINDow1:TITLe:STATe ON"
GPIB.Write "DISPlay:ANNotation:FREQuency ON"

'Autoscale the Trace
GPIB.Write "Display:WINDow1:TRACe1:Y:Scale:AUTO"

'Query back the Per Division, Reference Level, and Reference Position
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:PDIVision?"
Pdiv = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RLEVel?"
Rlev = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RPOSition?"
Ppos = GPIB.Read

'Turn ON, and average five sweeps
GPIB.Write "SENSe1:AVERage:STATe ON"
GPIB.Write "SENSe1:AVERage:Count 5"

'Turn ON, and set 20% smoothing aperture
GPIB.Write "CALCulate1:SMOothing:STATe ON"
GPIB.Write "CALCulate1:SMOothing:APERture 20"


Getting and Putting Data using GPIB

This Visual Basic Program does the following:

  • Reads data from the analyzer

  • Puts the data back into memory

  • To see the data, on the analyzer after running the program, from the front panel click:

Trace - Math / Memory - Memory Trace

To run this program, you need:

  • An established GPIB interface connection

Note: To change the read and write location of data, removing the comment from the beginning of ONE of the lines, and replace the comment in the beginning of the SDATA and SMEM lines.

Private Sub ReadWrite_Click()
Dim i As Integer
Dim t As Integer
Dim q As Integer
Dim dat As String
Dim cmd As String
Dim datum() As Double

GPIB.Configure
GPIB.Write "SYSTem:PRESet;*wai"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Read the number of data points
GPIB.Write "SENSe1:SWEep:POIN?"
numpts = GPIB.Read

'Turn continuous sweep off
GPIB.Write "INITiate:CONTinuous OFF"

'Take a sweep
GPIB.Write "INITiate:IMMediate;*wai"

'Ask for the Data

'PICK ONE OF THESE TO READ
'GPIB.Write "CALCulate:DATA? FDATA" 'Formatted Meas
'GPIB.Write "CALCulate:DATA? FMEM" 'Formatted Memory
GPIB.Write "CALCulate:DATA? SDATA" 'Corrected, Complex Meas
'GPIB.Write "CALCulate:DATA? SMEM" 'Corrected, Complex Memory
'GPIB.Write "CALCulate:DATA? SCORR1" 'Error-Term Directivity

'Number of values returned per data point
'q = 1 ' Pick this if reading FDATA or FMEM
q = 2 ' Otherwise pick this

'Parse the data
ReDim datum(q, numpts)
For i = 0 To numpts - 1
  For t = 0 To q - 1
  'Read the Data
  dat = GPIB.Read(20)
  'Parse it into an array
  datum(t, i) = Val(dat)
  Next t
Next i

'PUT THE DATA BACK IN
GPIB.Write "format ascii"

'PICK ONE OF THESE LOCATIONS TO PUT THE DATA
'cmd = "CALCulate:DATA FDATA," 'Formatted Meas
'cmd = "CALCulate:DATA FMEM," 'Formatted Memory
'cmd = "CALCulate:DATA SDATA," 'Corrected, Complex Meas
cmd = "CALCulate:DATA SMEM," 'Corrected, Complex Memory
'cmd = "CALCulate:DATA SCORR1," 'Error-Term Directivity

For i = 0 To numpts - 1
  For t = 0 To q - 1
  If i = numpts - 1 And t = q - 1 Then
  cmd = cmd & Format(datum(t, i))
  Else
  cmd = cmd & Format(datum(t, i)) & ","
  End If
  Next t
Next i

GPIB.Write cmd
End Sub


Status Reporting

See Other GPIB Example Programs

Status Reporting using GPIB

This Visual Basic program demonstrates two methods of reading the analyzer's status registers:

  • Polled Bit Method - reads the Limit1 register continuously.

  • SRQ Method - enables an interupt of the program when bit 6 of the status byte is set to 1. The program then queries registers to determine if the limit line failed.

To run this program, you need:

  • An established GPIB interface connection

  • A form with two buttons: Poll and SRQMethod

  • A means of causing the limit line to fail, assuming it passes initially.

Private Sub Poll_Click()
' POLL THE BIT METHOD
' Clear status registers
GPIB.Write "*CLS"

'Loop FOREVER
Do
DoEvents
GPIB.Write "STATus:QUEStionable:LIMit1:EVENt?"
onn = GPIB.Read
Loop Until onn = 2

MsgBox "Limit 1 Failed "
End Sub

--------------------------------------------------------

Private Sub SRQMethod_Click()
'SRQ METHOD
GPIB.Write "SYSTem:PRESet"
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'slow down the trace
GPIB.Write "SENS:BWID 150"

'Setup limit line
GPIB.Write "CALC:LIM:DATA 2,3e9,6e9,-2,-2"
GPIB.Write "CALC:LIMit:DISP ON"
GPIB.Write "CALC:LIMit:STATe ON"

' Clear status registers.
GPIB.Write "*CLS;*wai"
' Clear the Service Request Enable register.
GPIB.Write "*SRE 0"
' Clear the Standard Event Status Enable register.
GPIB.Write "*ESE 0"

' Enable questionable register, bit(10) to report to the status byte.
GPIB.Write "STATus:QUEStionable:ENABle 1024"

' Enable the status byte register bit3 (weight 8) to notify controller
GPIB.Write "*SRE 8"

' Enable the onGPIBNotify event
GPIB.NotifyMask = cwGPIBRQS
GPIB.Notify
End Sub

----------------------------------------------------
Private Sub GPIB_OnGPIBNotify(ByVal mask As Integer)
' check to see what failed
' was it the analyzer?
GPIB.Write "*STB?"
onn = GPIB.Read
If onn <> 0 Then
' If yes, then was it the questionable register?
GPIB.Write "STATus:QUEStionable:EVENt?"
onn = GPIB.Read
' Determine if the limit1 register, bit 8 is set.
If onn = 1024 Then
'if yes, then was it trace 1?
GPIB.Write "STAT:QUES:LIMIT1:EVEN?"
onn = GPIB.Read
If onn = 2 Then MsgBox ("Limit Line1 Failed")
End If
End If
End Sub


GP-IB Fundamentals

GPIB Fundamentals

The General Purpose Interface Bus (GPIB) is a system of hardware and software that allows you to control test equipment to make measurements quickly,Graphical User Interface accurately, and repeatably. This topic contains the following introductory information that explains GPIBhardware and software and how they fit together.

The GPIB Hardware Components

Instruments

Addresses

Controllers

Cables

The GPIB Programming Elements

Commands

Messages

Programming Statements

Instrument Drivers

Specifications

GPIB Interface Capability Codes

Note: All of the topics related to programming assume that you already know how to program, preferably using a language that can control instruments.

The GPIB Hardware Components

The system bus and its associated interface operations are defined by the IEEE 488 standard. The following sections list and describe the main pieces of hardware in a GPIB system:

Instruments

The analyzer is configured as a Talker / Listener by default.

  • Talkers are instruments that can be addressed to send data to the controller.

  • Listeners are instruments that can be addressed to receive a command, and then respond to the command. All devices on the bus are required to listen.

GPIB Addresses

Every GPIB instrument must have its own unique address on the bus. The analyzer address (716) consists of two parts:

  • The Interface select code (typically 7) indicates which GPIB port in the system controller is used to communicate with the device.

  • The primary address (16) is set at the factory. You can change the primary address of any device on the bus to any number between 0 and 30. The analyzer address can be changed through System \ Configure \ SICL-GPIB menu

  • The secondary address is sometimes used to allow access to individual modules in a modular instrument system, such as a VXI mainframe. The analyzer does not have secondary addresses.

Controllers

Controllers specify the instruments that will be the talker and listener in a data exchange. The controller of the bus must have a GPIB interface card to communicate on the GPIB.

  • The Active Controller is the computer or instrument that is currently controlling data exchanges.

  • The System Controller is the only computer or instrument that can take control and give up control of the GPIB to another computer or instrument, which is then called the active controller. Becuase the analyzer cannot be both Talker/Listener and System Controller, you cannot have a GPIB program running on the analyzer (controller) and have the analyzer responding to commands. To accomplish this, use COM programming.

Cables

GPIB Cables are the physical link connecting all of the devices on the bus. There are eight data lines in a GPIB cable that send data from one device to another. There are also eight control lines that manage traffic on the data lines and control other interface operations.

You can connect instruments to the controller in any arrangement with the following limitations:

  • Do not connect more than 15 devices on any GPIB system. This number can be extended with the use of a bus extension.

  • Do not exceed a total of 20 meters of total cable length or 2 meters per device, whichever is less.

  • Avoid stacking more than three connectors on the back panel of an instrument. This can cause unnecessary strain on the rear-panel connector.

The GPIB Programming Elements

The following software programming elements combine to become a GPIB program:

GPIB Commands

Messages

Programming Statements

Instrument Drivers

GPIB Commands

The GPIB command is the basic unit of communication in a GPIB system. The analyzer responds to three types of GPIB commands:

  • IEEE 488.1 Bus-management Commands

  • IEEE 488.2 Common Commands

  • SCPI Commands

IEEE 488.1 Bus-management Commands

These commands are used primarily to tell some or all of the devices on the bus to perform certain interface operations.

All of the functions that can be accomplished with these commands can also be done with IEEE 488.2 or SCPI commands. Therefore, these commands are not documented in this Help system. For a complete list of IEEE 488.1 commands refer to the IEEE 488 standard.

Examples of IEEE 488.1 Commands

  • CLEAR - Clears the bus of any pending operations

  • LOCAL - Returns instruments to local operation

IEEE 488.2 Common Commands

These commands are sent to instruments to perform interface operations. An IEEE 488.2 common command consists of a single mnemonic and is preceded by an asterisk ( * ). Some of the commands have a query form which adds a "?" after the command. These commands ask the instrument for the current setting. For a complete list of the common commands that are recognized by the analyzer, see GPIB Command Finder.

Examples of IEEE 488.2 Common Commands

  • *OPC - Operation Complete

  • *RST - Reset

  • *OPT? - Queries the option configuration

SCPI Commands

The Standard Commands for Programmable Instruments (SCPI) is a set of commands developed in 1990. The standardization provided in SCPI commands helps ensure that programs written for a particular SCPI instrument are easily adapted to work with a similar SCPI instrument. SCPI commands tell instruments to do device specific functions. For example, SCPI commands could tell an instrument to make a measurement and output data to a controller.

The Rules and Syntax of SCPI Commands provides more detail of the SCPI command structure. For a complete list of the SCPI commands that are recognized by the analyzer, see GPIB Command Finder.

Example of SCPI Commands:

  • CALCULATE:AVERAGE:STATE ON

  • SENSE:FREQUENCY:START?

GPIB Messages

A message is made up of one or more GPIB commands, punctuation, data, and an appropriate termination. There are two types of messages:

  • Program messages are sent from the controller to an instrument.

  • Response messages are sent from an instrument to the controller.

Programming Statements

GPIB messages are included with the language specific I/O statements to form program statements. The programming language determines the syntax of the programming statements. GPIB programs can be written in a variety of programming languages such as VEE, HP BASIC, or C++. Because most programmers are familiar with the BASIC language, all of the programming examples in this help system use HP BASIC. To modify these examples to work with your programming language, just substitute your language I/O statements for the HP BASIC OUTPUT and ENTER statements.

The following is an example of a message included in a Visual Basic statement to form a programming statement.

GPIB.Write "SOURCE:FREQUENCY:FIXED 1000 MHz"

sets the source frequency to 1000 Megahertz.

Note about examples

Instrument Drivers

Instrument drivers are subroutines that provide routine functionality and can be reused from program to program. GPIB industry leaders have written standards for use by programmers who develop drivers. When programmers write drivers that comply with the standards, the drivers can be used with predictable results. To comply with the standard, each instrument driver must include documentation describing its functionality and how it should be implemented.

GPIB Specifications

  • Interconnected devices - Up to 15 devices (maximum) on one contiguous bus.

  • Interconnection path - Star or linear (or mixed) bus network, up to 20 meters total transmission path length or 2 meters per device, whichever is less.

  • Message transfer scheme - Byte-serial, bit-parallel, asynchronous data transfer using an interlocking 3-wire handshake.

  • Maximum data rate - 1 megabyte per second over limited distances, 250 to 500 kilobytes per second typical maximum over a full transmission path. The devices on the bus determine the actual data rate.

  • Address capability - Primary addresses, 31 Talk and 31 Listen; secondary addresses, 961 Talk and 961 Listen. There can be a maximum of 1 Talker and up to 14 Listeners at a time on a single bus. See also previous section on GPIB addresses.

GPIB Interface Capability Codes

The IEEE 488.1 standard requires that all GPIB compatible instruments display their interface capabilities on the rear panel using codes. The codes on the analyzer, and their related descriptions, are listed below:

SH1 | full source handshake capability
AH1 | full acceptor handshake capability
T6 | basic talker, serial poll, no talk only, unaddress if MLA (My Listen Address)
TEO | no extended talker capability
L4 | basic listener, no listen only, unaddress if MTA (My Talk Address)
LEO | no extended listener capability
SR1 | full service request capability
RL1 | full remote / local capability
PPO | no parallel poll capability
DC1 | full device clear capability
DT1 | full device trigger capability
C1 | system controller capability
C2 | send IFC (Interface Clear) and take charge controller capability
C3 | send REN (Remote Enable) controller capability
C4 | respond to SRQ (Service Request)


The Rules and Syntax of SCPI Commands

The Rules and Syntax of SCPI

Most of the commands used for controlling instruments on the GPIB are SCPI commands. The following sections will help you learn to use SCPI commands in your programs.

Branches on the Command Tree

Command and Query

Multiple Commands

Command Abbreviation

Bracketed (Optional) Keywords

Vertical Bars (Pipes)

MIN and MAX Parameters

Note: For background information on SCPI Commands, see GPIB Fundamentals / Commands

Branches on the Command Tree

All major functions on the analyzer are assigned keywords which are called ROOT commands. (See GPIB Command Finder for a list of SCPI root commands). Under these root commands are branches that contain one or more keywords. The branching continues until each analyzer function is assigned to a branch. A root command and the branches below it is sometimes known as a subsystem.

For example, the following graphic shows the SOURce subsystem. Under the SOURce and POWer keywords are several brach commands.

Sometimes the same keyword, such as START, is used in several branches of the command tree. To keep track of the current branch, the analyzer's command parser uses the following rules:

  • Power On and Reset - After power is cycled or after *RST, the current path is set to the root level commands.

  • Message Terminators - A message terminator, such as a <NL> character, sets the current path to the root command level. Many programming language output statements send message terminators automatically. Message terminators are described in Sending Messages to the Analyzer.

  • Colon (:) - When a colon is between two command keywords, it moves the current path down one level in the command tree. For example, the colon in :SOURCE:POWER specifies that POWER is one level below SOURCE. When the colon is the first character of a command, it specifies that the following keyword is a root level command. For example, the colon in :SOURCE specifies that source is a root level command.

Note: You can omit the leading colon if the command is the first of a new program line. For example, the following two commands are equivalent:
SOUR:POW:ATT:AUTO
:SOUR:POW:ATT:AUTO

  • <WSP> - Whitespace characters, such as <tab> and <space>, are generally ignored. There are two important exceptions:

    • Whitespace inside a keyword, such as :CALC ULATE, is not allowed.

    • You must use white space to separate parameters from commands. For example, the <WSP> between STATE and ON in the command CALCULATE:SMOOTHING:STATE ON is mandatory. Whitespace does not affect the current path.

  • Comma (,) - If a command requires more than one parameter, you must separate adjacent parameters using a comma. For example, the SYSTEM:TIME command requires three values to set the analyzer clock: one for hours, one for minutes, and one for seconds. A message to set the clock to 8:45 AM would be SYSTEM:TIME 8,45,0. Commas do not affect the current path.

  • Semicolon(;) - A semicolon separates two commands in the same message without changing the current path. See Multiple Commands later in this topic.

  • IEEE 488.2 Common Commands - Common commands, such as *RST, are not part of any subsystem. An instrument interprets them in the same way, regardless of the current path setting.

Command and Query

A SCPI command can be an Event command, Query command (a command that asks the analyzer for information), or both. The following are descriptions and examples of each form of command. GPIB Command Finder lists every SCPI command that is recognized by the analyzer, and its form.

Form | Examples
Event commands - cause an action to occur inside the analyzer. | :INITIATE:IMMEDIATE
Query commands - query only; there is no associated analyzer state to set. | :SYSTem:ERRor?
Command and query - set or query an analyzer setting. The query form appends a question mark (?) to the set form | :FORMat:DATA ! Command :FORMat:DATA? ! Query

Multiple Commands

You can send multiple commands within a single program message. By separating the commands with semicolons the current path does not change. The following examples show three methods to send two commands:

  1. Two program messages:

SOURCE:POWER:START 0DBM
SOURCE:POWER:STOP 10DBM

  2. One long message. A colon follows the semicolon that separates the two commands causing the command parser to reset to the root of the command tree. As a result, the next command is only valid if it includes the entire keyword path from the root of the tree:

SOURCE:POWER:START 0DBM;:SOURCE:POWER:STOP 10DBM

  3. One short message. The command parser keeps track of the position in the command tree. Therefore, you can simplify your program messages by including only the keyword at the same level in the command tree.

SOURCE:POWER:START 0DBM;STOP 10DBM

Common Commands and SCPI Commands

You can send Common commands and SCPI commands together in the same message. (For more information on these types of commands see GP-IB Fundamentals.) As in sending multiple SCPI commands, you must separate them with a semicolon.

Example of Common command and SCPI commands together

*RST;SENSE:FREQUENCY:CENTER 5MHZ;SPAN 100KHZ

Command Abbreviation

Each command has a long form and an abbreviated short form. The syntax used in this Help system use uppercase characters to identify the short form of a particular keyword. The remainder of the keyword is lower case to complete the long form.

SOUR - Short form
SOURce - Long form

Either the complete short form or complete long form must be used for each keyword. However, the keywords used to make a complete SCPI command can be a combination of short form and long form.

The following is unacceptable - The first three keywords use neither short or long form.

SOURc:Powe:Atten:Auto on

The following is acceptable - All keywords are either short form or long form.

SOUR:POWer:ATT:AUTO on

In addition, the analyzer accepts lowercase and uppercase characters as equivalent as shown in the following equivalent commands:

source:POW:att:auto ON
Source:Pow:Att:Auto on

Optional [Bracketed] Keywords

You can omit some keywords without changing the effect of the command. These optional, or default, keywords are used in many subsystems and are identified by brackets in syntax diagrams.

Example of Optional Keywords

The HCOPy subsystem contains the optional keyword IMMediate at its first branching point. Both of the following commands are equivalent:

"HCOPY:IMMEDIATE"
"HCOPY"

The syntax in this Help system looks like this:

HCOPy[:IMMediate]

Vertical Bars | Pipes

Vertical bars, or "pipes", can be read as "or". They are used in syntax diagrams to separate alternative parameter options.

Example of Vertical Bars:

SOURce:POWer:ATTenuation:AUTO <on|off>

Either ON or OFF is a valid parameter option.

MIN and MAX Parameters

The special form parameters "MINimum" and "MAXimum" can be used with numerous commands in the analyzer, as noted in the command documentation. The short form (min) and long form (minimum) of these two keywords are equivalent.

  • MAXimum refers to the largest value that the function can currently be set to

  • MINimum refers to the smallest value that the function can currently be set to.

For example, the following command sets the start frequency to the smallest value that is currently possible:

SENS:FREQ:START MIN

In addition, the max and min values can also be queried for these commands.

For example, the following command returns the smallest value that Start Frequency can currently be set to:

SENS:FREQ:START? MIN

An error will be returned if a numeric parameter is sent that exceeds the MAX and MIN values.

For example, the following command will return an "Out of range" error message.

SENS:FREQ:START 1khz


Getting Data from the Analyzer

Data is sent from the analyzer in response to program queries. Data can be short response messages, such as analyzer settings, or large blocks of measurement data. This topic discusses how to read query responses and measurement data from the analyzer in the most efficient manner.

Response Message Syntax

Clearing the Output Queue

Response Data Types

Numeric Data

Character Data

String Data

Block Data

Transferring Measurement Data

Note: Some PCs use a modification of the IEEE floating point formats with the byte order reversed. To reverse the byte order for data transfer into a PC, the FORMat:BORDer command should be used. See GPIB Command Finder for details.

Response Message Syntax

Responses sent from the analyzer contain data, appropriate punctuation, and message terminators.

<NL><^END> is always sent as a response message terminator. Most programming languages handle these terminators transparent to the programmer.

Response messages use commas and semicolons as separators in the following situations:

  • a comma separates response data items when a single query command returns multiple values

FORM:DATA? 'Query
ASC, +0 'Analyzer Response

  • a semicolon separates response data when multiple queries are sent within the same messages

SENS:FREQ:STAR?;STOP? --Example Query

+1.23000000E+008; +7.89000000E+008<NL><^END> 'Analyzer Response

Clearing the Output Queue

After receiving a query, the analyzer places the response message in it's output queue. Your program should read the response immediately after the query is sent. This ensures that the response is not cleared before it is read. The response is cleared when one of the following conditions occur:

  • When the query is not properly terminated with an ASCII carriage return character or the GPIB <^END> message.

  • When a second program query is sent.

  • When a program message is sent that exceeds the length of the input queue

  • When a response message generates more response data than fits in the output queue.

  • When the analyzer is switched ON.

Response Data Types

The analyzer sends different response data types depending on the parameter being queried. You need to know the type of data that will be returned so that you can declare the appropriate type of variable to accept the data. For more information on declaring variables see your programming language manual. The GPIB Command Finder lists every GPIB command and the return format of data in response to a query. The analyzer returns the following types of data:

Numeric Data

Character Data

String Data

Block Data

Numeric Data

The analyzer sends ASCII character data that looks like numeric data. All numeric data sent over the GPIB is character data.

Character Data

Character data consists of ASCII characters grouped together in mnemonics that represent specific analyzer settings. The analyzer always returns the short form of the mnemonic in upper-case alpha characters. Character data looks like string data. Therefore, refer to the GPIB Command Finder to determine the return format for every command that can be queried.

Example of Character Data

MLOG

String Data

String data consists of ASCII characters. The analyzer always encloses data in double quotes when it returns string data.

Example of String Data

GPIB.Write "DISP:WINDow:TITLe:DATA?"

“This is string response data.”

Block Data

Block data is used to transfer measurement data. Although the analyzer will accept either definite length blocks or indefinite length blocks, it always returns definite length block data in response to queries unless the specified format is ASCII. The following graphic shows the syntax for definite block data:

<num_digits> specifies how many digits are contained in <byte_count>
<byte_count> specifies how many data bytes will follow in <data bytes>

Example of Definite Block Data

#17ABC+XYZ<nl><end>

# - always sent before definite block data

1 - specifies that the byte count is one digit (7)

7 - specifies the number of data bytes that will follow, not counting <NL><END>

<NL><END> - always sent at the end of block data

Transferring Measurement Data

Measurement data is blocks of numbers that result from an analyzer measurement. Measurement data is available from various processing arrays within the analyzer. For more information on the analyzer's data processing flow, see Accessing the Data Arrays. Regardless of which measurement array is read, transferring measurement data is done the same.

When transferring measurement data, there are two data types to choose from:

  • REAL

  • ASCII

The following graphic shows the differences in transfer times between the two:

REAL Data

REAL data (also called floating-point data) types transfer faster. This is because REAL data is binary and takes about half the space of ASCII data. The disadvantage of using REAL data is that it requires a header that must be read. See definite length block data. The binary floating-point formats are defined in the IEEE 754-1985 standard. The following choices are available in REAL format:

  • REAL,32 - IEEE 32-bit format - single precision (not supported by HP BASIC)

  • REAL,64 - IEEE 64-bit format - double precision

These data types are selected using the FORMat SCPI command.

ASCII Data

The easiest and slowest way to transfer measurement data is to use ASCII data. If the data contains both numbers and characters, the setting of FORMat:DATA is ignored. ASCII data is separated by commas.


Understanding Command Synchronization

Thi s program determines which frequency contains the maximum amplitude.

GPIB.Write "ABORT; :INITIATE:IMMEDIATE"! Restart the measurement
GPIB.Write "*OPC?" 'Wait until complete
Meas_done = GPIB.Read 'Read output queue, throw away result
GPIB.Write "CALCULATE:MARKER:MAX" 'Search for max amplitude
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?
Marker_x = GPIB.Read
PRINT "MARKER at " & Marker_x & " Hz"

See Also...

Understanding Command Synchronization

The analyzer takes more time to process some commands than others:

  • Sequential commands are processed quickly and in the order in which they are received.

  • Overlapped commands take longer to process. Therefore, they allow the program to do other tasks while waiting. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

Note: The analyzer has two overlapped commands:
- INITitate:IMMediate
- SENSe:SWEep:MODE GROUPS (when INIT:CONT is ON)

The analyzer's queues store commands and responses waiting to be processed. Using the analyzer's queues and controlling the processing sequence of overlapped commands is called synchronizing the analyzer and the controller. This topic discusses how and when synchronizing should be performed.

Analyzer Queues

Input Queue

Output Queue

Error Queue

Synchronizing Overlapped Commands

Synchronization Methods

When To Synchronize

Analyzer Queues

Queues are memory buffers that store messages until they can be processed. The analyzer has the following queues:

Input Queue

Output Queue

Error Queue

Input Queue

The controller sends statements to the analyzer without regard to the amount of time required to execute the statements. The input queue is very large (31k bytes). It temporarily stores commands and queries from the controller until they are read by the analyzer's command parser. The input queue is cleared when the analyzer is switched ON.

Output Queue

When the analyzer parses a query, the response is placed in the output queue until the controller reads it. Your program should immediately read the response or it may be cleared from the output queue. The following conditions will clear a query response:

  • When a second query is sent before reading the response to the first. This does not apply when multiple queries are sent in the same statement.

  • When a program statement is sent that exceeds the length of the input queue.

  • When a response statement generates more data than fits in the output queue.

  • When the analyzer is switched ON.

Error Queue

Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Synchronizing Overlapped Commands

GPIB commands are executed and processed by the analyzer in the order they are received. Commands can be divided into two broad classes:

  • Overlapped commands generally take extended time to process by the analyzer. Examples of functions that have overlapped commands are printing and making measurements. Because they take longer to process, they allow the execution of subsequent commands while the overlapped command is still in progress. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

  • Sequential commands are generally processed quickly by the analyzer. Therefore, they prevent the processing of subsequent commands until the sequential command has been completely processed. These commands do NOT require synchronization.

Synchronization Methods

When To Synchronize

Synchronization Methods

The following common commands are used to synchronize the analyzer and controller. Examples are included that illustrate the use of each command in a program. See the SCPI command details to determine if a command is an overlapped command.

*WAI

*OPC?

*OPC

*WAI

The *WAI command:

  • Stops the analyzer from processing subsequent device commands until all overlapped commands are completed.

  • It does NOT stop the controller from sending commands to this and other devices on the bus. This is the easiest method of synchronization.

Example of the *WAI command

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "CALCULATE:MARKER:SEARCH:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?

The following timeline shows how the processing times of the three commands relate to each other:

INITIATE:IMMEDIATE is an overlapped command; it allows the immediate processing of the sequential command, CALCULATE:MARKER:SEARCH:MAXIMUM. However, the INITIATE:IMMEDIATE is not considered complete until the measurement is complete. Therefore, the marker searches for maximum amplitude before the measurement completes. The CALCULATE:MARKER:X? query could return an inaccurate value.

To solve the problem, insert a *WAI command.

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "*WAI" 'Wait until complete.
GPIB.Write "CALCULATE:MARKER:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency

The timeline now looks like this:

The *WAI command keeps the MARKER:SEARCH:MAXIMUM from taking place until the measurement is completed. The CALCULATE:MARKER:X? query returns the correct value.

Note: Although *WAI stops the analyzer from processing subsequent commands, it does not stop the controller. The controller could send commands to other devices on the bus.

*OPC?

The *OPC? query stops the controller until all pending overlapped commands are completed.

In the following example, the Read statement following the *OPC? query will not complete until the analyzer responds, which will not happen until all pending overlapped commands have finished. Therefore, the analyzer and other devices receive no subsequent commands. A "1" is placed in the analyzer output queue when the analyzer completes processing an overlapped command. The "1" in the output queue satisfies the Read command and the program continues.

Example of the *OPC? query [image] Click

*OPC

The *OPC command allows the analyzer and the controller to process commands while processing the overlapped command.

When the analyzer completes processing an overlapped command, the *OPC command sets bit 0 of the standard event register to 1 . This requires polling of status bytes or use of the service request (SRQ) capabilities of your controller. See Reading the Analyzer's Status Registers for more information about the standard event status register, generating SRQs, and handling interrupts.

Note: Be careful when sending commands to the analyzer between the time you send *OPC and the time you receive the interrupt. Some commands could jeopardize the integrity of your measurement. It also could affect how the instrument responds to the previously sent *OPC.

Example of polled bit and SRQ processes.

When To Synchronize the Analyzer and Controller

Although a command may be defined as an overlapped command, synchronization may not be required. The need to synchronize depends upon the situation in which the overlapped command is executed. The following section describes situations when synchronization is required to ensure a successful operation.

Completion of a Measurement

Measurements with External Trigger

Averaged Measurements

Completion of a Measurement

To synchronize the analyzer and controller to the completion of a measurement, use the ABORT;INITIATE:IMMEDIATE command sequence to initiate the measurement.

This command sequence forces data collection to start (or restart) under the current measurement configuration. A restart sequence, such as ABORT;INITIATE:IMMEDIATE is an overlapped command. It is complete when all operations initiated by that restart command sequence, including the measurement, are finished. The *WAI,*OPC? and *OPC commands allow you to determine when a measurement is complete. This ensures that valid measurement data is available for further processing.

Measurements with External Trigger

To use an external trigger, synchronize the analyzer and controller before the trigger is supplied to the measurement. Setup the analyzer to receive a trigger from an external source (wired to the EXTERNAL TRIGGER connector on the rear panel. The trigger system is armed by GPIB with INITIATE:IMMEDIATE. (Because the source of the trigger has been specified as external, this command "readies" the analyzer for a trigger but it does not actually generate the trigger.).

Averaged Measurements

Averaged measurements are complete when the average count is reached. The average count is reached when the specified number of individual measurements is combined into one averaged measurement result. Use synchronization to determine when the average count has been reached.

If the analyzer continues to measure and average the results after the average count is reached, use synchronization to determine when each subsequent measurement is complete.


Reading the Analyzer's Status Registers

Status Commands

Reading the Analyzer's Status Register

The analyzer has several status registers that your program can read to know when specific events occur. There are two methods of reading the status registers in the analyzer: the Polled Bit method and the Service Request method.

Polled Bit Method

Service Request Method

Setting and Reading Bits in Status Registers

Positive and Negative Transitions

Most of the status registers in the analyzer are sixteen bits. For simplicity, this topic will illustrate their use with 8-bit registers. Bits in registers represent the status of a different conditions inside of the analyzer. In the following graphic, a register is represented by a row of boxes; each box represents a bit. Bit 3 is ON.

The Polled Bit Method

With the Polled Bit Method, your program continually monitors a bit in the status register that represents the condition of interest to you. When the analyzer sets the bit to 1, your program immediately sees it and responds accordingly.

Advantage: This method requires very little programming.

Disadvantage: This method renders your program unavailable to do anything other than poll the bit of interest until the condition occurs.

Procedure:

1. Decide which condition to monitor. The Status Commands topic lists all of the possible conditions that can be monitored in the analyzer.

2. Determine the command and the bit that will monitor the command.

3. Construct a loop to poll that bit until it is set.

4. Construct the routine to respond when the bit is set.

The Service Request (SRQ) Method

Your program enables the bits in the status registers representing the condition of interest. When the condition occurs, the analyzer actively interupts your program from whatever it is doing, and an event handler in your program responds accordingly. Do this method if you have several conditions you want to monitor or the conditions are such that it is not practical to wait for the condition to occur.

Advantage: This method frees your program to do other things until the condition occurs. The program is interupted to respond to the condition.

Disadvantage: This method can require extensive programming depending on the number and type of conditions that you want to monitor.

Procedure:

1. Decide which conditions to monitor. The Status Commands topic lists all of the possible analyzer conditions that can be monitored.

2. Set the enable bits in the summary registers and the status byte register.

Enabling is like making power available to a light - without power available, the switch can be activated, but the light won't turn ON. In the analyzer, without enabling, the condition may occur, but the controller won't see it unless it is enabled.

The condition, and the bit in the summary registers in the reporting path, must be enabled. Summary This is like streams (conditions) flowing into rivers (summary registers), and rivers flowing into the ocean (controller). See the diagram of status registers in Status Commands.

Bit 6 of the status byte register is the only bit that can interrupt the controller. When any representative bit in the status byte register goes ON, bit 6 is automatically switched ON.

4. Enable your program to interupt the controller, This is done several ways depending on the programming language and GPIB interface card you use. An example program is provided showing how this is done with in Visual Basic with a National Instruments GPIB card.

5. Construct a subroutine to handle the interrupt event. If you are monitoring more than one condition in your system, your event handler must determine which condition caused the interupt. Use the *SPE command to determine the instrument that caused the interupt and then poll the summary registers, and then condition registers to determine the cause of the interupt.

Setting and Reading Bits in Status Registers

Both methods for reading status registers requires that you read bits out of the status registers. Most of the analyzers status registers contain 16 bits, numbered 0 to 15. Each bit has a weighted value. The following example shows how to set the bits in a 8-bit status register.

8-bit register

Bit | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Weight | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128

We want to set bits 4 and 5 in the Standard Event Status Enable register.

Step | Example
1. Read the weighted bit value for these bits | weights 16 and 32 (respectively)
2. Add these values together | 16 + 32 = 48
3. Send this number as an argument in the appropriate command. (see Status Commands) | STAT:QUES:LIMIT1:ENAB 1026

Positive and Negative Transitions

Transition registers control what type of in a condition register will set the corresponding bit in the event register.

  • Positive transitions (0 to 1) are only reported to the event register if the corresponding positive transition bit is set to 1.

  • Negative transitions (1 to 0) are only reported to the event register if the corresponding negative transition bit is set to 1.

  • Setting both transition bits to 1 causes both positive and negative transitions to be reported.

Transition registers are read-write and are unaffected by *CLS (clear status) or queries. They are reset to their default settings at power-up and after *RST and SYSTem:PRESet commands. The following are the default settings for the transition registers:

  • All Positive Transition registers = 1

  • All Negative Transition registers = 0

This means that by default, the analyzer will latch all event registers on the negative to positive transition (0 to 1).

The following is an example of why you would set transitions registers:

A critical measurement requires that you average 10 measurements and then restart averaging. You decide to poll the averaging bit. When averaging is complete, the bit makes a positive transition. After restart, you poll the bit to ensure that it is set back from 1 to 0, a negative transition. You set the negative transition bit for the averaging register.


COM Example Intro

Communicating with Other Applications

See the list of examples.

The analyzer’s support for DCOM (Distributed Component Object Model) over the LAN provides control of the analyzer using a variety of platforms. DCOM acts as an interface to the analyzer for external applications. With DCOM, the programmer can develop an application on an external computer. During development, the application will interface to the analyzer over the LAN through the DCOM interface. Once the developer has finished the application, it can be distributed to (installed on) the analyzer. After it has been distributed to the analyzer, the application interfaces with the analyzer using COM.

The example applications referred to in this topic were developed in a number of different programming languages to show the differences between development platforms. The table below outlines the setup parameters that the applications will use to configure the PNA network analyzer for a measurement.

Parameter | Value
Start Frequency | 1 GHz
Stop Frequency | 2 GHz
Number of Points | 11
Measurement | S 11
Data Storage Area | Uncorrected (Raw Data)
Data Format | Log Magnitude
Trigger Mode | Single
The device tested was a 50 ohm standard load on port 1 of the analyzer

You can download the example programs and obtain more detailed information for each development environment from http://agilent.com/find/pna_applications

The development environment should reference the type library associated with the PNA Series. For example, in Visual Basic, add the Agilent PNA 835x type library as a reference. This will allow the program to “see” the various classes and methods for use with the PNA Series network analyzer during development.

List of Examples

Agilent VEE Example

Microsoft Excel Example

Microsoft Visual Basic Example

Microsoft Visual Basic Script Example

Microsoft Visual C++ Example

Microsoft Word Example

National Instruments LabVIEW Example


Intro to Examples

Agilent VEE Example

Application Configuration

For this example use Agilent VEE version 6.0 or above which contains the Variant data type used to transfer data from the PNA. The type library for the PNA should be referenced in the Agilent VEE development environment.

Using the Agilent VEE Object Browser the developer can see the classes and methods which are available for development of applications for the PNA Series analyzer.

Application Code

There is a runtime version of Agilent VEE that may be used if the application has been saved as “runtime”. A free version of Agilent VEE can be found on the following web site: http://www.agilent.com/find/vee/. The application may be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


Intro to Examples

Microsoft Visual Basic Example

Application Configuration

The type library for the PNA should be referenced in the Visual Basic development environment.

Using the Visual Basic Object Browser the developer can see what classes and methods are available for development of applications for the analyzer.

Application Code

The application code is contained below. To run the application, first generate the executable file. Once this is complete, it can be copied and executed on the analyzer or run on the PC. The application can also be run from the development environment.

Option Explicit

Dim app As AgilentPNA835x.Application
Dim chan As AgilentPNA835x.Channel
Dim meas As AgilentPNA835x.Measurement
Dim result As Variant
Dim i As Integer
Dim num_points As Integer
Dim message As String

Private Sub Main()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCrLf
Next

If MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") Then
Set chan = Nothing
app.Quit
End If

End Sub


Intro to Examples

Microsoft Visual Basic Script Example

Application Configuration

Some operating systems may require that the Visual Basic Scripting engine be installed before running the application on a PC. To download a free copy of a Visual Basic Scripting engine, visit the following web site: http://msdn.microsoft.com/scripting/

Application Code

The application code is contained below. The developer must save the file in a text file (i.e. using notepad) and save it with the “.vbs” extension. The “.vbs” extension will tell the operating system to execute the code using the Visual Basic Scripting engine.

In order to run the application, double-click on the saved .vbs file. The application can be run on a PC or copied and run on the PNA Series network analyzer.

Option Explicit

' Shell objects
Dim app
Dim chan
Dim meas
Dim result
Dim message
Dim num_points
Dim i

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = 3
chan.TriggerMode = 1

' Make the PNA application
 visible
app.Visible = True
' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000)
chan.StopFrequency = (2000000000)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(0, 1)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCRLF
Next

if MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") then
Set chan = Nothing
app.quit

end if


Intro to Examples

Microsoft Visual C++ Example

Application Configuration

Microsoft Visual C++ version 6 was used for this example. In order to perform this example, create a new project in Microsoft Visual C++. Add a C++ file to the project and paste the following code into the file. The path for the type library in the code below should be changed to reference its location on the development PC.

Application Code

The application can be run on a PC or on the PNA.

#include "stdafx.h"

// import the Tsunami type library
//--------------------------
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
no_namespace, named_guids
int main(int argc, char* argv[])
{
// interface pointers to retrieve COM interfaces
IUnknown* pUnk = 0;
IApplication* pNA = 0;
IChannel* pChan = 0;
IMeasurement* pMeas = 0;
IArrayTransfer* pTrans = 0;
int i, num_points = 0;
float* pScalarData;

HRESULT hr;

// Initialize the COM subsystem
CoInitialize(NULL);

// Create an instance of the network analyzer
// Request the NA's IUnknown interface
hr = CoCreateInstance(CLSID_Application,0,
CLSCTX_ALL,IID_IUnknown, (void**) &pUnk);
if (!FAILED(hr)) {

// QueryInterface for the INetworkAnalyzer interface
of the NetworkAnalyzer object
hr = pUnk->QueryInterface(IID_IApplication,
(void**)&pNA);

if (!FAILED(hr)) {

// Reset the analyzer to instrument preset
pNA->Reset();

// Create S11 measurement
pNA->CreateSParameter(1,1,1,1);

// Set pChan variable to point to the active
channel
pNA->get_ActiveChannel(&pChan);

if (pChan) {

// Set pMeas variable to point to the active
measurement
pNA->get_ActiveMeasurement(&pMeas);

if(pMeas) {

// Setup the channel for a single trigger
pChan->Hold(true);
pNA->TriggerSignal = naTriggerManual;
pChan->TriggerMode =
naTriggerModeMeasurement;

// Make the PNA application visible
pNA->put_Visible(true);

// Set channel parameters
pChan->NumberOfPoints = 11;
pChan->StartFrequency = 1e9;
pChan->StopFrequency = 2e9;

// Send a manual trigger to initiate a single
sweep
pChan->Single(true);

// QueryInterface for the IArrayTransfer
interface of the NetworkAnalyzer object
hr = pMeas->QueryInterface(IID_IArray
Transfer, (void**)&pTrans);

if (!FAILED(hr)) {

// Store the data in the "result"
 variable
num_points = pChan->NumberOfPoints;
pScalarData = new float[num_points];
pTrans->getScalar(naRawData, naData
Format_LogMag, (long *)&num_points,
pScalarData);

// Display the result
printf("S11(dB) - Visual C++ COM
Example for PNA\n\n");
for (i = 0; i < num_points; i++)
printf("%f\n",pScalarData[i]);

}
}
}
}

pUnk->Release();
pMeas->Release();
pChan->Release();
pTrans->Release();
pNA->Release();
}
CoUninitialize();
return 0;
}


Intro to Examples

Microsoft Word Example

Application Configuration

Microsoft® Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Word documents. The type library for the PNA Series network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into a table in a Word document. To run the application, open the document using Microsoft Word. Enable the macros when prompted. Once this is complete, the application will execute and update the document. The application can be run on a PC or the analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Document_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
ThisDocument.Tables(1).Cell(i + 2, 2).Range = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


Intro to Examples

Microsoft Excel Example

Application Configuration

Microsoft Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Excel documents. The type library for the PNA network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into cells in the Excel document. The cells are then used to update a graph in the Excel document. To run the application, open the document using Microsoft Excel. Enable macros when prompted by the application. Once this is complete, the application will execute and update the document. It can be run on a PC or the PNA analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Workbook_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints 14

For i = 0 To num_points - 1
Sheet1.Cells(3 + i, 1) = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


National Instruments LabVIEW Example

Intro to Examples

National InstrumentsTM LabVIEW Example

Application Configuration

Use National Instruments™ Lab VIEW version 5.0 or above for this example. See the National Instruments™ LabVIEW documentation for information on using ActiveX objects in the LabVIEW development environment.

Application Code

National Instruments™ LabVIEW 5.0 or higher must be installed to run the application. The application can be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


GPIB using Visual C++

/*
* This example assumes the user's PC has a National Instruments GPIB
 board. The example is comprised of three basic parts:
*
* 1. Initialization
* 2. Main Body
* 3. Cleanup
*
* The Initialization portion consists of getting a handle to the
 PNA and then doing a GPIB clear of the PNA.
*
* The Main Body consists of the PNA SCPI example.
*
* The last step, Cleanup, releases the PNA for front panel control.
*/

#include <stdio.h>
#include <stdlib.h>

/*
* Include the WINDOWS.H and DECL-32.H files. The standard Windows
* header file, WINDOWS.H, contains definitions used by DECL-32.H
 and
* DECL-32.H contains prototypes for the NI GPIB routines and constants.
*/
#include <windows.h>
#include "decl-32.h"

#define ERRMSGSIZE 1024 // Maximum size of SCPI command string
#define ARRAYSIZE 1024 // Size of read buffer

#define BDINDEX 0 // Board Index of GPIB board
#define PRIMARY_ADDR_OF_PNA 16 // GPIB address of PNA
#define NO_SECONDARY_ADDR 0 // PNA has no Secondary address
#define TIMEOUT T10s // Timeout value = 10 seconds
#define EOTMODE 1 // Enable the END message
#define EOSMODE 0 // Disable the EOS mode

int pna;
char ValueStr[ARRAYSIZE + 1];
char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL",
 "EADR", "EARG",
"ESAC", "EABO", "ENEB", "EDMA",
 "",
"EOIP", "ECAP", "EFSO", "",
 "EBUS",
"ESTB", "ESRQ", "", "",
 "", "ETAB"};

void GPIBWrite(char* SCPIcmd);
char *GPIBRead(void);
void GPIBCleanup(int Dev, char* ErrorMsg);

int main()
{

char *opc;
char *result;
char *value;

/*
* =========================================
* INITIALIZATION SECTION
* =========================================
*/

/*
* The application brings the PNA online using ibdev. A device handle,pna,
 is returned and is used in all subsequent calls to the PNA.
*/
pna = ibdev(BDINDEX, PRIMARY_ADDR_OF_PNA, NO_SECONDARY_ADDR,
TIMEOUT, EOTMODE, EOSMODE);
if (ibsta & ERR)
{
printf("Unable to open handle to PNA\nibsta = 0x%x iberr =
 %d\n",
ibsta, iberr);
return 1;
}

/*
* Do a GPIB Clear of the PNA. If the error bit ERR is set in ibsta,
 call GPIBCleanup with an error message.
*/
ibclr (pna);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to perform GPIB clear of the PNA");
return 1;
}

/*
* =========================================
* MAIN BODY SECTION
* =========================================
*/

// Reset the analyzer to instrument preset
GPIBWrite("SYSTem:FPRESET");

// Create S11 measurement
GPIBWrite("CALCulate1:PARameter:DEFine 'My_S11',S11");

// Turn on Window #1
GPIBWrite("DISPlay:WINDow1:STATe ON");

// Put a trace (Trace #1) into Window #1 and 'feed' it from the
 measurement
GPIBWrite("DISPlay:WINDow1:TRACe1:FEED 'My_S11'");

// Setup the channel for single sweep trigger
GPIBWrite("INITiate1:CONTinuous OFF;*OPC?");
opc = GPIBRead();
GPIBWrite("SENSe1:SWEep:TRIGger:POINt OFF");

// Set channel parameters
GPIBWrite("SENSe1:SWEep:POINts 11");
GPIBWrite("SENSe1:FREQuency:STARt 1000000000");
GPIBWrite("SENSe1:FREQuency:STOP 2000000000");

// Send a trigger to initiate a single sweep
GPIBWrite("INITiate1;*OPC?");
opc = GPIBRead();

// Must select the measurement before we can read the data
GPIBWrite("CALCulate1:PARameter:SELect 'My_S11'");

// Read the measurement data into the "result" string
 variable
GPIBWrite("FORMat ASCII");
GPIBWrite("CALCulate1:DATA? FDATA");
result = GPIBRead();

// Print the data to the display console window
printf("S11(dB) - Visual C++ SCPI Example for PNA\n\n");
value = strtok(result, ",");
while (value != NULL)
{
printf("%s\n", value);
value = strtok(NULL, ",");
}

/*
* =========================================
* CLEANUP SECTION
* =========================================
*/

/* The PNA is returned to front panel control. */
ibonl(pna, 0);

return 0;
}

/*
* Write to the PNA
*/
void GPIBWrite(char* SCPIcmd)
{
int length;
char ErrorMsg[ERRMSGSIZE + 1];
length = strlen(SCPIcmd) ;

ibwrt (pna, SCPIcmd, length);
if (ibsta & ERR)
{
strcpy(ErrorMsg, "Unable to write this command to PNA:\n");
strcat(ErrorMsg, SCPIcmd);

GPIBCleanup(pna, ErrorMsg);
exit(1);
}
}

/*
* Read from the PNA
*/
char* GPIBRead(void)
{
ibrd (pna, ValueStr, ARRAYSIZE);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to read from the PNA");
exit(1);
}
else
return ValueStr;
}

/*
* After each GPIB call, the application checks whether the call succeeded.
 If an NI-488.2 call fails, the GPIB driver sets the corresponding bit
 in the global status variable. If the call failed, this procedure prints
 an error message, takes the PNA offline and exits.
*/
void GPIBCleanup(int Dev, char* ErrorMsg)
{
printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n",
ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);
if (Dev != -1)
{
printf("Cleanup: Returning PNA to front panel control\n");
ibonl (Dev, 0);
}
}


GPIB using Visual Basic

To run this program, you need:

  • An established GPIB interface connection

Option Explicit

Dim opc As Integer
Dim result As String
Dim i As Integer
Dim num_points As Integer
Dim commaPosition As Integer
Dim message As String
'
' Program executes when the 'Run' button is clicked.
Private Sub cmdRun_Click()
  ' National Instruments ComponentWorks 'Instr' ActiveX Control, Version 2.0.1

  ' Default board number for National Instruments GPIB boards
  GPIB.BoardNumber = 0

  ' Default GPIB address of PNA
  GPIB.PrimaryAddress = 16

  ' Initialize the GPIB connection
  GPIB.Configure

  ' Reset the analyzer to instrument preset
  GPIB.Write "SYSTem:FPRESET"

  ' Create S11 measurement
  GPIB.Write "CALCulate1:PARameter:DEFine 'My_S11',S11"

  ' Turn on Window #1
  GPIB.Write "DISPlay:WINDow1:STATe ON"

  ' Put a trace (Trace #1) into Window #1 and 'feed' it from the measurement
  GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'My_S11'"

  ' Setup the channel for single sweep trigger
  GPIB.Write "INITiate1:CONTinuous OFF;*OPC?"
  opc = GPIB.Read
  GPIB.Write "SENSe1:SWEep:TRIGger:POINt OFF"

  ' Set channel parameters
  GPIB.Write "SENSe1:SWEep:POINts 11"
  GPIB.Write "SENSe1:FREQuency:STARt 1000000000"
  GPIB.Write "SENSe1:FREQuency:STOP 2000000000"

  ' Send a trigger to initiate a single sweep
  GPIB.Write "INITiate1;*OPC?"
  opc = GPIB.Read

  ' Must select the measurement before we can read the data
  GPIB.Write "CALCulate1:PARameter:SELect 'My_S11'"

  ' Read the measurement data into the "result" string variable
  GPIB.Write "FORMat ASCII"
  GPIB.Write "CALCulate1:DATA? FDATA"
  result = GPIB.Read

  ' Display the result
  GPIB.Write "SENSe1:SWEep:POINts?"
  num_points = GPIB.Read
  For i = 0 To num_points - 2
  commaPosition = InStr(result, ",")
  message = message & Left(result, commaPosition - 1) & vbCrLf
  result = Right(result, Len(result) - commaPosition)
  Next
  message = message & result

  MsgBox message, vbOKOnly, "S11(dB) - VB SCPI Example for PNA"

End Sub
Private Sub cmdExit_Click()
  End
End Sub


COM versus SCPI

There are two methods you can use to remotely control the analyzer: COM and SCPI. The following topics are intended to help you choose the method that best meets your needs:

Software Connection

Physical Connection

Selecting a Method

Programming Languages

Software Connection

COM uses a binary protocol, allowing the user to directly invoke a feature of the Network Analyzer. This is more efficient than SCPI. For example, the following statement calls directly into the Network Analyzer, executing the routine GetIDString.

PNA.GetIDString()

SCPI is a text based instrument language. To retrieve the ID string, you would send the following text string to the network analyzer:

IbWrite( "*IDN?")

The network analyzer's SCPI parser would first decode this text string to determine that the user has asked for the network analyzer to identify itself. Then the parser would call GetIDString().

The Physical Connection

Internal Control

With either COM or SCPI, the best throughput is attained by using the analyzer's internal PC to execute your test code. However, if your test code uses too much system resources (CPU cycles and/or memory), this will slow the Analyzer's performance.

Using the SICL I/O Libraries, you can also connect to the Analyzer from a program running on the Analyzer.

External Control

You can control the analyzer from a remote PC using either COM or SCPI.

COM - (Component Object Model) can be used to access any program like the analyzer (835x.exe) or library (.dll) that exposes its features using a COM compliant object model. These programs or libraries are called "servers". Programs (like your remote program on your PC) that connect to and use the features of these servers are called "clients."

With COM, the server and the client do not need to reside on the same machine. DCOM, or distributed COM, is easy to configure and makes the location of the server transparent to the client. When you access the Analyzer from a remote computer, you are using DCOM. In this case, the mechanical transport is a LAN (local area network).

SCPI - Using a GPIB interface card in a remote computer, you can connect to the instrument using a GPIB cable. There are some constraints on the length of this cable and the number of instruments that can be daisy-chained together.

Using the Agilent SICL I/O libraries, you can connect to the instrument over a LAN connection.

(LAN or INTERNAL) You can send SCPI commands using COM with an object called the ScpiStringParser. This object provides access to the SCPI parser (or command decoder) so that you can send SCPI text commands using automation.

Selecting a Method

You should almost always choose COM for the following reasons:

  • COM executes faster most of the time.

  • COM is generally easier to use. The latest development tools embrace COM and know how to make your life easier with integrated development environments that show automation syntax as you type.

  • As time goes on, more emphasis will be put on the COM as the preferred programming paradigm. As new capability is developed, it may not be made available through SCPI.

But choosing a connection method depends on your situation. Here are some additional things to consider:

  1. If you want to use the Analyzer to control other GPIB instruments, you may want to use COM as the means of talking to the instrument. In GPIB, the analyzer can not be configured as both System Controller and talker/listener. Because the Analyzer does not support pass control mode, only one mode can be used at a time.

  2. If you have legacy code written in SCPI for another network analyzer, you may be able to leverage that code to control to the Analyzer. A word of warning: the PNA uses a different platform than previous Agilent Network Analyzers. Therefore, not all commands have a direct replacement. See the 8753 command finder.

Programming Languages

You can program the Analyzer with either COM or SCPI using several languages. The most common include:

Agilent VEE - With this language you can send text based SCPI commands and also use automation. VEE 6.0 or later is recommended.

Visual Basic - This language has great support for automation objects and can be used to drive SCPI commands. The use of VISA drivers for your GPIB hardware interface will make the task of sending SCPI commands easier.

C++ - This language can do it all. It is not as easy to use as the above two, but more flexible.


Especificaciones

Especificaciones técnicas

Véase asimismo...

En este apartado se ofrece una lista completa de las especificaciones técnicas del analizador de redes de la serie PNA. Si se desea imprimir esta información, utilizar este vínculo para acceder a la versión PDF.

Haga clic en los botones para visualizar la información mostrada.

Definiciones

Rendimiento corregido del sistema

Margen dinámico

Conectores de Tipo N

Conectores de 3,5 mm

Rendimiento no corregido del sistema

Salida del puerto de verificación (fuente)

Entrada de receptor y puerto de verificación

Información general

Resumen del rendimiento de medida

Definiciones

Todas las especificaciones y características son aplicables en un margen de 25 °C ±5 °C (a menos que se indique lo contrario) y 90 minutos después de que se haya encendido el instrumento.

Especificación (espec.): Rendimiento garantizado. Las especificaciones incluyen bandas de seguridad para tener en cuenta la distribución del rendimiento estadístico previsto, las incertidumbres de medida y los cambios de rendimiento ocasionados por condiciones ambientales.

Característico (car.): Un parámetro de rendimiento que el producto debe cumplir antes de salir de fábrica, pero que no se verifica en el lugar de instalación ni está cubierto por la garantía del producto. Una característica incluye las mismas bandas de seguridad que una especificación.

Típico (típ.): Rendimiento previsto de una unidad media que no incluye bandas de seguridad. No está cubierto por la garantía del producto.

Nominal (nom.): Un término descriptivo general que no implica un nivel de rendimiento. No está cubierto por la garantía del producto.

Calibración: El proceso consistente en medir patrones conocidos para caracterizar los errores sistemáticos (repetibles) de un analizador de redes.

Corregido (residual): Indica el rendimiento después de la corrección d e errores (calibración). Está determinado por la calidad de los patrones de calibración y por lo "conocidos" que son, además del ruido, la estabilidad y la repetibilidad del sistema.

No corregido (sin rectificar): Indica el rendimiento del instrumento sin corrección de errores. El rendimiento no corregido afecta a la estabilidad de una calibración.

Patrón: Cuando se refiere al analizador, incluye todas las opciones, a menos que se indique lo contrario.

Rendimiento corregido del sistema

Las especificaciones de esta sección corresponden a las medidas realizadas con el analizador de la serie PNA con las siguientes condiciones:

  • ancho de banda

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25 °C ±5 °C, con una desviación inferior a 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite

Margen dinámico del sistema

Conectores de Tipo N

Conectores de 3,5 mm

Tabla 1. Margen dinámico del sistema

Descripción | Especificación (dB) | Característica (dB)
Margen dinámico a (en el puerto de verificación)
300 kHz a 25 MHz b | 125 |
25 MHz a 3 GHzb | 128 |
3 GHz a 6 GHz | 118 |
6 GHz a 9 GHz | 113 |
Margen dinámico d (en la entrada del receptor)
300 kHz a 25 MHz m |  | 140
25 MHz a 3 GHzm |  | 143
3 GHz a 6 GHz |  | 133
6 GHz a 9 GHz |  | 128

a El margen dinámico del puerto de verificación se calcula como la diferencia entre el límite inferior de ruido eficaz del puerto de verificación y la potencia de salida máxima de la fuente. El margen dinámico efectivo debe tener en cuenta las incertidumbres de medida y las señales de interferencia.
b Puede limitarse a 100 dB a frecuencias específicas inferiores a 750 MHz debido a la existencia de efectos residuales espúreos del receptor.
c El margen dinámico de la entrada del receptor se calcula como la diferencia entre el límite inferior de ruido eficaz del receptor y la potencia de salida máxima de la fuente. El margen dinámico efectivo debe tener en cuenta las incertidumbres de medida y las señales de interferencia. Esta configuración sólo se deberá utilizar si la entrada del receptor nunca sobrepasa su nivel de daños. Cuando el analizador está en el modo de barrido de segmentos, los segmentos de frecuencia podrán definirse con un nivel de potencia superior cuando se necesite el margen dinámico ampliado (es decir, la parte de la respuesta del dispositivo con una alta pérdida por inserción), y con una potencia reducida cuando puedan producirse daños en el receptor (es decir, la parte de la respuesta del dispositivo con una baja pérdida por inserción).
d Puede limitarse a 115 dB a frecuencias específicas inferiores a 750 MHz debido a la existencia de efectos residuales espúreos del receptor.

Rendimiento corregido del sistema con conectores de Tipo N

Kit de calibración 85032F

Opción 015 con kit de calibración 85032F

Kit de calibración 85092B

Opción 015 con kit de calibración 85092B

Tabla 2. Rendimiento corregido del sistema con conectores de dispositivo de Tipo N, kit de calibración 85032F

Aplicable al analizador de la serie PNA, kit de calibración 85032F (Tipo N, 50 W ), cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
El m irectividad | 49 | 46 | 40 | 38
Acoplamiento entre fuentes | 41 | 40 | 36 | 35
A daptación d e carga | 49 | 46 | 40 | 38
Seguimiento de la reflexión | ±0.011 | ±0.021 | ±0.032 | ±0.054
Seguimiento de la transmisión | ±0.011 | ±0.018 | ±0.040 | ±0.049

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 3. Rendimiento corregido del sistema con conectores de dispositivo de Tipo N, Opción 015 con kit de calibración 85032F

Aplicable al analizador de la serie PNA con opción 015, kit de calibración 85032F (Tipo N, 50 W ), cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 49 | 46 | 40 | 38
Acoplamiento entre fuentes | 41 | 40 | 36 | 35
Adaptación de carga | 49 | 46 | 40 | 38
Seguimiento de la reflexión | ±0.011 | ±0.021 | ±0.032 | ±0.054
Seguimiento de la transmisión | ±0.011 | ±0.023 | ±0.050 | ±0.062

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 4. Rendimiento corregido del sistema con conectores de dispositivo de Tipo N, módulo de calibración electrónica 85092B

Aplicable al analizador de la serie PNA, módulo de calibración electrónica (ECal) 85092B (Tipo N, 50 W ), cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 52 | 54 | 52 | 47
Acoplamiento entre fuentes | 45 | 44 | 41 | 34
Adaptación de carga | 47 | 47 | 44 | 44
Seguimiento de la reflexión | ±0.037 | ±0.037 | ±0.068 | ±0.100
Seguimiento de la transmisión | ±0.060 | ±0.055 | ±0.13 | ±0.23
Seguimiento típico de la transmisión | ±0.028 | ±0.045 | ±0.08 | ±0.105

a Especificación basada en una humedad del 28%. Niveles de humedad superiores pueden degradar el rendimiento.

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 5. Rendimiento corregido del sistema con conectores de dispostivo de Tipo N, opción 015 con módulo de calibración electrónica 85092B

Aplicable al analizador de la serie PNA con opción 015, módulo de calibración electrónica (ECal) 85092B (Tipo N, 50 W ), cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 52 | 54 | 52 | 47
Acoplamiento entre fuentes | 45 | 44 | 41 | 34
Adaptación de carga | 47 | 47 | 44 | 39
Seguimiento de la reflexión | ±0.037 | ±0.037 | ±0.068 | ±0.100
Seguimiento de la transmisión | ±0.060 | ±0.055 | ±0.13 | ±0.23
Seguimiento típico de la transmisión | ±0.028 | ±0.045 | ±0.08 | ±0.105

a Especificación basada en una humedad del 28%. Niveles de humedad superiores pueden degradar el rendimiento.

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Rendimiento corregido del sistema con conectores de 3,5 mm

Kit de calibración 85033E

Option 015 con kit de calibración 85033E

Kit de calibración 85093B

Opción 015 con kit de calibración 85093B

Tabla 6. Rendimiento corregido del sistema con tipo de conectores de dispositivo de 3,5 mm, kit de calibración 85033E

Aplicable al analizador de la serie PNA, kit de calibración 85033E ( 3,5 mm , 50 W ), N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 46 | 44 | 38 | 38
Acoplamiento entre fuentes | 43 | 40 | 37 | 36
Adaptación de carga | 46 | 44 | 38 | 38
Seguimiento de la reflexión | ±0.006 | ±0.007 | ±0.009 | ±0.010
Seguimiento de la transmisión | ±0.010 | ±0.020 | ±0.041 | ±0.046

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 7. Rendimiento corregido del sistema Con tipo de conectores de dispositivo de 3,5 mm, opción 015 con kit de calibración 85033E 85033E

Aplicable al analizador de la serie PNA con opción 015, kit de calibración 85033E ( 3,5 mm , 50 W ), N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 46 | 44 | 38 | 38
Acoplamiento entre fuentes | 43 | 40 | 37 | 36
Adaptación de carga | 46 | 44 | 38 | 38
Seguimiento de la reflexión | ±0.006 | ±0.007 | ±0.009 | ±0.010
Seguimiento de la transmisión | ±0.010 | ±0.025 | ±0.052 | ±0.058

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 8. Rendimiento corregido del sistema Con tipo de conectores de dispositivo de 3,5 mm, módulo de calibración electrónica (ECal) 85093B calibración eléctrica 85093B

Aplicable al analizador de la serie PNA, módulo de calibración electrónica (ECal) 85093B ( 3,5 mm , 50 W ) , cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 50 | 52 | 51 | 45
Acoplamiento entre fuentes | 45 | 43 | 40 | 34
Adaptación de carga | 47 | 47 | 44 | 39
Seguimiento de la reflexión | ±0.043 | ±0.043 | ±0.055 | ±0.100
Seguimiento de la transmisión | ±0.050 | ±0.045 | ±0.13 | ±0.23
Seguimiento típico de la transmisión | ±0.028 | ±0.045 | ±0.08 | ±0.105

a Especificación basada en una humedad del 28%. Niveles de humedad superiores pueden degradar el rendimiento.

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 9. Rendimiento corregido del sistema Con tipo de conectores de dispositivo de 3,5 mm, opción 015 con módulo de calibración electrónica (ECal) 85093B calibración eléctrica 85093B

Aplicable al analizador de la serie PNA co n opción 015 , módulo de calibración electrónica (ECal) 85093B ( 3,5 mm , 50 W ) , cable de puerto de verificación N6314A y una calibración completa de 2 puertos. También es aplicable a las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • No se aplica promediado a los datos

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

  • La calibración del aislamiento no se omite
Descripción | Especificación (dB)
 | 300 kHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
El m irectividad | 50 | 52 | 51 | 45
Acoplamiento entre fuentes | 45 | 43 | 40 | 34
A daptación d e carga | 47 | 47 | 44 | 39
Seguimiento de la reflexión | ±0.043 | ±0.043 | ±0.055 | ±0.100
Seguimiento de la transmisión | ±0.050 | ±0.045 | ±0.13 | ±0.23
Seguimiento típico de la transmisión | ±0.028 | ±0.045 | ±0.08 | ±0.105

a Especificación basada en una humedad del 28%. Niveles de humedad superiores pueden degradar el rendimiento.

Hacer clic sobre una curva para ampliarla.

Incertidumbre de transmisión (especificación)

Incertidumbre de reflexión (especificación)

Tabla 10 . Rendimiento no corregido del sistema

Descripción | Especificación (dB)
 | 300 kHz a 1 MHz | 1 MHz a 1,3 GHz | 1,3 GHz a 3 GHz | 3 a 6 GHz | 6 a 9 GHz
Directividad | 30 | 33 | 27 | 20 | 13
Acoplamiento entre fuentes | 20 | 20 | 17 | 15 | 14
Acoplamiento entre fuentes (opc. 015) | 20 | 20 | 15 | 13 | 12
Adaptación de carga | 20 | 20 | 17 | 15 | 15
Adaptación de carga (opc. 015) | 20 | 20 | 15 | 13 | 13
Seguimiento de la reflexión | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0
Seguimiento de la transmisión | ±1.5 | ±1.5 | ±1.5 | ±2.5 | ±3.0

Características de la salida del puerto de verificación (fuente)

Frecuencia de salida

Potencia de salida

Pureza de la señal de salida

Tabla 11. Frecuencia de salida del puerto de verificación

Descripción | Especificación | Información adicional
Margen E8356A E8357A E8358A Resolución | 300 kHz a 3 GHz 300 kHz a 6 GHz 300 kHz a 9 GHz 1 Hz |
Estabilidad de la fuente |  | ±1 ppm, 0 a 40 °C, típico ±0,2 ppm/año, típico
CW | ±1 ppm |

Tabla 12. Potencia de salida del puerto de verificacióna

Descripción | Especificación | Información adicional
Precisión de nivel 300 kHz a 6 GHz 6 GHz a 9 GHz | ±1.0 dB ±2.0 dB | Variación a partir de 0 dBm en margen de potencia 0 (atenuador de pasos a 0 dB) ±1,5 dB por debajo de 10 MHz
Linealidad de nivel 300 kHz a 9 GHz 300 kHz a 1 MHz 1 MHz a 6 GHz | ±0,3 dB ±1 dB ±0,5 dB | Variación a partir de 0 dBm en margen de potencia 0 -15 a +5 dBm +5 a +10 dBm +5 a +10 dBm
Margenb 300 kHz a 6 GHz 6 GHz a 9 GHz | 85 a +10 dBm 85 a +5 dBm |
Margen de barrido 300 kHz a 6 GHz 6 GHz a 9 GHz | 25 dB 20 dB |
Resolución de nivel | 0,01 dB |

a Rendimiento de salida de la fuente sólo en el puerto 1. El rendimiento de salida del puerto 2 es una característica.

b Potencia a la cual se puede ajustar la fuente y el bloqueo de fase está asegurado.

Tabla 1 3. Pureza de la señal de salida del puerto de verificación

Descripción | Especificación | Información adicional
Armónicos (2º o 3º) a potencia de salida máx. a 0 dBm de salida a 10 dBm de salida |  | < 25 dBc, característicaa < 35 dBc, típico, en margen de potencia 0 < 38 dBc, típico, en margen de potencia 0 (atenuador de pasos a 0 dB)
Espúreo no armónico a salida máx. a 10 dBm de salida |  | 30 dBc, típico para desplazamiento de frecuencia>1 kHz 50 dBc, típico para desplazamiento de frecuencia >1 kHz

a Típico por debajo de 25 MHz.

Características del y de verificación y de la entrada del receptor

Niveles de entrada

Límite inferior del ruido

Ruido de trazas

Estabilidad y nivel de referencia

Precisión dinámica

Retardo de grupo

Tabla 14. Niveles de entrada del puerto de verificación

Descripción | Especificación | Información adicional
Nivel de entrada máximo del puerto de verificación
300 kHz a 25 MHz 25 MHz a 3 GHz 3 GHz a 6 GHz 6 GHz a 9 GHz | +10 dBm +10 dBm +10 dBm +5 dBm | <compresión de 0,6 dB <compresión de 0,4 dB <compresión de 0,7 dB <compresión de 0,7 dB
Nivel de daños
Puerto de verificación 1, 2 R1, R2 IN A, B IN (estándar) A, B IN (opc. 015) Acoplador IN (opc. 015) |  | +30 dBm o ±30 Vcc, típ. +15 dBm o ±15 Vcc, típ. +15 dBm o ±15 Vcc, típ. +15 dBm o ±0 Vcc, típ. +36 dBm o ±25 Vcc, típ.
Límite inferior de ruido del puerto de verificacióna
300 kHz a 25 MHzb Ancho de banda de IF de 10 Hz Ancho banda de IF de 1 kHz | £ 115 dBm £ 95 dBm |
25 MHz a 3 GHzb Ancho de banda de IF de 10 Hz Ancho banda de IF de 1 kHz | £ 118 dBm £ 98 dBm |
3 GHz a 9 GHz Ancho de banda de IF de 10 Hz Ancho de banda de IF de 1 kHz | £ 108 dBm £ 88 dBm |
Límite inferior de ruido del receptora
300 kHz a 25 MHzd 10 Hz IF Bandwidth 1 kHz IF Bandwidth |  | £ 130 dBm, característica £ 110 dBm, característica
25 MHz a 3 GHzd 10 Hz IF Bandwidth 1 kHz IF Bandwidth |  | £ 133 dBm, característica £ 113 dBm, característica
6 GHz a 9 GHz Ancho de banda de IF de 10 Hz Ancho de banda de IF de 1 kHz |  | £ 123 dBm, característica £ 103 dBm, característica
Diafonía
300 kHz a 1 MHz 1 MHz a 25 MHz 25 MHz a 3 GHz 3 GHz a 6 GHz 6 GHz a 9 GHz | <120 dB <125 dB <128 dB <118 dB <113 dB | Entre los puertos de verificación 1 y 2, con circuitos cerrados en ambos puertos;
Nivel máximo de entrada del receptor (A, B, R1, R2)
300 kHz a 6 GHz 6 GHz a 9 GHz |  | 6 dBm, típico 11 dBm, típico
Nivel de entrada de referencia (R1, R2)m
300 kHz a 9 GHz |  | 10 a 35 dBm, típico
Nivel máximo de entrada del acoplador (opc. 015)
300 kHz a 9 GHz |  | + 33 dBm, típico

a valor eficaz de una traza de magnitud lineal expresado en dBm.

b Puede limitarse a -90 dB a frecuencias específicas inferiores a 750 MHz debido a la existencia de efectos residuales espúreos del receptor.

d Puede limitarse a -105 dB a frecuencias específicas inferiores a 750 MHz debido a la existencia de efectos residuales espúreos del receptor.

m Nivel de entrada para mantener el bloqueo de fase.

Tabla 15. Entrada del puerto de verificación (ruido de traza)

Descripción | Especificación | Información adicional
Ruido de trazas a Magnitud
Ancho de banda de IF de 1 kHz Ancho de banda de IF de 10 kHz | < 0,002 dB eficaz < 0,005 dB eficaz |
Ruido de trazas a Fase
Ancho de banda de IF de 1 kHz Ancho de banda de IF de 10 kHz | < 0,010° eficaz < 0,035° eficaz |

a El ruido de traza se define como una medida de relación de una reflexión directa o completa, con la fuente ajustada a 0 dBm.

Tabla 16. Entrada del puerto de verificación (estabilidad y nivel de referencia)

Descripción | Especificación | Información adicional
Magnitud de nivel de referencia
Margen Resolución | ±200 dB 0,001 dB |
Fase de nivel de referencia
Margen Resolución | ±500° 0,01° |
Magnitud de estabilidada
300 kHz a 3 GHz 3 GHz a 6 GHz 6 GHz a 9 GHz |  | 0,02 dB/°C, típico 0,04 dB/°C, típico 0,06 dB/°C, típico
Fase de estabilidada
300 kHz a 3 GHz 3 GHz a 6 GHz 6 GHz a 9 GHz |  | 0,2°/°C, típico 0,3°/°C, típico 0,6°/°C, típico

a La estabilidad se define como una medida de relación en el puerto de verificación.

Tabla 1 7. Entrada del puerto de verificación (precisión dinámica)

La precisión de la lectura de potencia de entrada del puerto de verificación está relacionada con el nivel de potencia de entrada de referencia. Es aplicable a los puertos de entrada 1 y 2 con las siguientes condiciones:

  • Ancho de banda de IF = 10 Hz

  • Temperatura ambiental de 25° ±5 °C, con desviación de < 1 °C respecto de la temperatura de calibración

Hacer clic sobre una curva para ampliarla.

Especificación 300 kHz a 3 GHz | Característica 300 kHz a 3 GHz
300 kHz a 6 GHz | 300 kHz a 6 GHz
300 kHz a 9 GHz | 300 kHz a 9 GHz

Tabla 1 8. Entrada del puerto de verificación (retardo de grupo)a

Descripción

Especificación

Información adicional

A pertura (seleccionable)

(recorrido de frecuencias)/(número de puntos 1)

Apertura máxima

20% del recorrido de frecuencias

Margen

0,5 x (1/apertura mínima)

Retardo máximo

Limitado a medir no más de 180° de cambio de fase dentro de la apertura mínima.)

Precisión

Consultar el gráfico que aparece a continuación. Car.

En el siguiente gráfico se muestra la precisión de retardo de grupo con calibración completa de dos puertos y de tipo N y un ancho de banda. Se supone que la pérdida por inserción es < 2 dB y la longitud eléctrica, de diez metros.

Hacer clic en la curva para ampliarla.

Por lo general, la siguiente fórmula puede utilizarse para determinar la precisión, en segundos, de una medida específica de retardo de grupo:

±Precisión de fase (grados)/[360 × Apertura (Hz)]

En función de la apertura y de la longitud del dispositivo, la precisión de fase utilizada es una precisión de fase incremental o una precisión de fase en el peor de los casos.

a El retardo de grupo se calcula midiendo el cambio de fase en de un paso de frecuencia especificado (determinado por el recorrido de frecuencias y el número de puntos por barrido).

Información general

Anchos de banda del sistema

Información del

Información del

Especificaciones ambientales y dimensiones

Tabla 19. Anchos de banda del sistema

Descripción | Especificación | Información adicional
Ajustes de ancho de banda de IF
Margen |  | 1 Hz a 40 kHz Los valores nominales son: 1, 2, 3, 5, 7, 10, 15, 20, 30, 50, 70, 100, 150, 200, 300, 500, 700 Hz 1k, 1,5k, 2k, 3k, 5k, 7k, 10k, 15k, 20k, 30k, 50k, 35k, 40 kHz

Tabla 20. Información del panel pos terior

Descripción | Información adicional
Conectores de RF
Type | Tipo N, hembra; 50 W, nominal
Saliente de la patilla central | 0,51 a 0,52 cm, característica
Potencia de sonda
Conector | conector de 3 patillas, macho
Fuente de alimentación positiva | +15 Vcc ±2%, 400 mA, máx., característica
Fuente de alimentación negativa | 12,6 Vcc ±5%, 300 mA, máx., característica
Pantalla
Tamaño | LCD de matriz activa en color de 21,3 cm (8,4 pulgadas) en diagonal; resolución 640 (horizontal) x 480 (vertical)
Velocidad de renovación | Vertical 59,83 Hz; horizontal 31,41 Hz
Margen de la pantalla
Magnitud | ±200 dB (a 20 dB/div), máx.
Fase | ±180°, máx.
Polar | 10 pUnidades, mín. 1.000 unidades, máx.
Resolución de pantalla
Magnitud | 0,001 dB/div, mín.
Fase | 0,01°/div, mín.
Resolución de marcador
Magnitud | 0,001 dB, mín.
Fase | 0,01°, mín.
Polar | 0,01 mUnidad, mín.; 0,01°, mín.

Tabla 21. Información del panel pos terior

Descripción

Información adicional

Entrada de polarización del puerto de verificación

Conector

BNC, hembra

Tensión máxima

±30 Vcc, típico

Corriente máxima (sin degradación de las especificaciones de RF)

±200 mA, típico

Corriente máxima

±1 A, típico

Entrada de referencia de 10 MHz

Conector

BNC, hembra

Frecuencia de entrada

10 MHz ± 1 ppm, típico

Nivel de entrada

15 dBm a +20 dBm, típico

I mpedancia de entrada

200 W, nom.

Salida de referencia de 10 MHz

Conector

BNC, hembra

Frecuencia de salida

10 MHz ± 1 ppm, típico

Tipo de señal

Onda sinusoidal, típico

Nivel de salida

+10 dBm ± 4 dB en 50 W, típico

Impedancia de salida

50 W, nominal

Armónicos

<40 dBc, típico

Salida de vídeo VGA

Conector

Mini D-Sub de 15 patillas; admite monitores compatibles con VGA

Dispositivos admitidos

Panel plano (TFT)
Panel plano (DSTN)
Monitor con tubo de imagen

Resoluciones

1.024 x 768, 800 x 600, 640 x 480
800 x 600, 640 x 480
1.280 x 1.024, 1.024 x 768, 800 x 600, 640 x 480

Es posible un funcionamiento simultáneo de las pantallas interna y externa, pero sólo con la resolución de 640 x 480. Si se cambia la resolución, sólo se podrá visualizar la pantalla externa (la pantalla interna se quedará "en blanco").

GPIB

D-sub (tipo D-24) de 24 patillas, hembra; compatible con IEEE-488.

Puerto paralelo (LPT1)

D-sub (tipo 1284-C) de 36 patillas, hembra; permite conectar impresoras u otros periféricos de puerto paralelo

Puerto serie (COM 1)

D-sub de 9 patillas, macho; compatible con RS-232

Puerto USB

Contacto 1
Contacto 2
Contacto 3
Contacto 4

Conector de bus serie universal, configuración de tipo A (4 contactos en línea, contacto 1 a la izquierda); hembra

Vcc: 4,75 a 5,25 Vcc, 500 mA, máximo
-Datos
+Datos
Tierra

LAN

Ethernet 10/100BaseT, configuración de 8 patillas; selección automática entre ambas velocidades de transferencia de datos

Potencia de línea a

Frecuencia

48 Hz a 66 Hz

Tensión ajustada a 115 V

90 132 Vca; 120 Vca, nominal

Tensión ajustada a 220 V

198 a 264 Vca; 240 Vca, nominal

VA máx.

600 VA máx.

a Se necesita una conexión a tierra mediante un tercer cable.

Tabla 22. Información del panel posterior

Descripción | Información adicional
Entrada externa de AM
Descripción | La entrada ofrece modulación AM de baja frecuencia para someter a prueba la señal de salida del puerto, o cambia la salida del puerto de verificación. Una entrada de cero voltios ofrece el nivel de potencia establecido por el instrumento, una tensión positiva ofrece un nivel más elevado y una tensión negativa ofrece un nivel inferior.
Conector | BNC, hembra
Sensibilidad de entrada | 8 dB/voltio, típico
Ancho de banda | 1 kHz, típico
Impedancia de entrada | 1 kW, típico
Entrada de detector externo
Descripción | La entrada desde un detector de diodos externo con polaridad negativa ofrece ALC para un puerto de verificación alejado del panel frontal del instrumento
Conector | BNC, hembra
Sensibilidad de entrada | 500 mV produce aproximadamente 3 dBm en la entrada del detector, típico
Ancho de banda | 50 kHz, típico
Impedancia de entrada | 1 kW, típico
Activador externo
 | Véase Activador

Tabla 23. Especificaciones ambientales y dimensiones del analizador

Descripción | Información adicional
Especificaciones ambientales generales
Susceptibilidad a RFI/EMI | Definido por CISPR Pub. 11, Grupo 1, Clase A y IEC 50082-1
ESD | Minimizar utilizando procedimientos de trabajo con protección antiestática y una alfombrilla antiestática en el banco de pruebas
Polvo | Minimizar para obtener una fiabilidad óptima
Entorno de funcionamiento
Temperatura | 0 a +40 °C El instrumento se enciende, la fase se bloquea y no aparece ningún mensaje de error dentro de este margen de temperatura.
Margen de temperatura con errores corregidos | 25 °C ± 5 °C con una desviación inferior a 1 °C respecto de la temperatura de calibración.
Humedad | 5 al 95% a +40 °C
Altitud | 0 a 4.500 m
Entorno de almacenamiento en reposo
Temperatura | -40 a +70 °C
Humedad | 0 al 90% a +65 °C (sin condensación)
Altitud | 0 a 15.240 m
Dimensiones del chasis
Altura x Anchura x Fondo | 222 x 425 x 426 mm, nominal; las dimensiones del chasis no incluyen los salientes frontales y posteriores.
Peso
Neto | 24 kg, nominal
Envío | 32 kg, nominal

Resumen del rendimiento de medida

Tiempo de ciclo típico para que finalice la medida

Tiempo de ciclo con cambios del ancho de banda de IF

Tiempo de ciclo con cambios del número de puntos

Tiempo de transferencia de datos

Velocidad de recuperación y barrido

Tabla 24. Tiempo de ciclo Tiempoa, b (ms)

 | Número de puntos
 | 51 | 201 | 401 | 1601
Inicio 800 MHz, parada 1.000 MHz, ancho de banda de IF de 35 kHz
No corregido, Cal. de 1 puerto | 6 | 10 | 17 | 53
Cal. de 2 puertos | 18 | 27 | 39 | 113
Inicio 300 kHz, parada 3 GHz, ancho de banda de IF de 35 kHz
No corregido, Cal. de 1 puerto | 32 | 43 | 52 | 93
Cal. de 2 puertos | 73 | 97 | 117 | 201
Inicio 300 kHz, parada 6 GHz, ancho de banda de IF de 35 kHz
No corregido, Cal. de 1 puerto | 40 | 50 | 57 | 98
Cal. de 2 puertos | 88 | 109 | 125 | 210
Inicio 300 kHz, parada 9 GHz, ancho de banda de IF de 35 kHz
No corregido, Cal. de 1 puerto | 45 | 55 | 61 | 99
Cal. de 2 puertos | 99 | 119 | 133 | 212
Dominio del tiempo d (aumento sobre el tiempo de barrido no corregido)
Conversiones | <1 | <1 | 4 | 13
Puerta de tiempo | <1 | <1 | 4 | 17

a Rendimiento típico.
b Incluye tiempo de barrido, tiempo de retorno y tiempo de cruce de bandas. Pantalla del analizador apagada con
DISPLAY:ENABLE OFF. Añadir 21 ms para pantalla encendida. Datos para una medida de traza (S11).
c Sólo opción 010. Pantalla del analizador apagada con DISPLAY:ENABLE OFF. Añadir 21 ms para pantalla encendida. Datos para
una medida de traza (S11).

Tabla 25. Tiempo de ciclo frente a Ancho de banda de IFa

Aplicable al estado preajustado (201 p untos, corrección desactivada) excepto para los siguientes cambios:

  • CF = 1 GHz

  • Recorrido = 100 MHz

  • Pantalla apagada (añadir 21 ms para encender la pantalla)
Ancho de banda de IF (Hz) | Tiempo de ciclo (ms) b
40,000 | 8
35,000 | 9
30,000 | 11
20,000 | 13
10,000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Rendimiento típico.
b El tiempo de ciclo incluye el tiempo de barrido y de retorno.

Tabla 26. Tiempo de ciclo frente a Número de puntos a

Aplicable al estado preajustado ( ancho de banda de IF de 35 kHz, corrección desactivada) excepto para los siguientes cambios:

  • CF = 1 GHz

  • Recorrido = 100 MHz

  • Pantalla apagada (añadir 21 ms para encender la pantalla)
Número de puntos | Tiempo de ciclo (ms) b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Rendimiento típico.
b El tiempo de ciclo incluye el tiempo de barrido y de retorno.

Tabla 27. Tiempo de transferencia de datos a (ms)

 | Número de puntos
 | 51 | 201 | 401 | 1601
SCPI a través de GPIB (programa ejecutado en un PC externo) b
Coma flotante de 32 bits | 4 | 7 | 13 | 41
Coma flotante de 64 bits | 7 | 14 | 24 | 81
ASCII | 25 | 98 | 189 | 804
SCPI a través de LAN de 10 Mbits/s (programa ejecutado en un PC externo) b
Coma flotante de 32 bits | 5 | 6 | 8 | 21
Coma flotante de 64 bits | 5 | 9 | 22 | 38
ASCII | 18 | 53 | 98 | 362
SCPI a través de LAN de 100 Mbits/s (programa ejecutado en un PC externo) d
Coma flotante de 32 bits | 3 | 5 | 6 | 12
Coma flotante de 64 bits | 4 | 6 | 9 | 20
ASCII | 17 | 51 | 92 | 339
SCPI (programa ejecutado en el analizador) m
Coma flotante de 32 bits | 2 | 3 | 4 | 7
Coma flotante de 64 bits | 4 | 5 | 6 | 15
ASCII | 26 | 99 | 198 | 781
COM (programa ejecutado en el analizador) e
Coma flotante de 32 bits | 1 | 1 | 1 | 2
Tipo de variante | 1 | 3 | 4 | 19
DCOM a través de LAN de 10 Mbits/s (programa ejecutado en un PC externo) f
Coma flotante de 32 bits | 2 | 3 | 5 | 14
Tipo de variante | 5 | 14 | 26 | 100
DCOM a través de LAN de 100 Mbits/s (programa ejecutado en un PC externo) f
Coma flotante de 32 bits | 2 | 2 | 2 | 4
Tipo de variante | 3 | 5 | 9 | 35

a Rendimiento típico.
b Medido con un programa VEE 5.0 que se ejecute en un HP Kayak a 600 MHz, tarjeta GPIB de National InstrumentsTM.
Datos S11 complejos transferidos, con "CALC:DATA?SDATA".
c Medido con un programa VEE 5.0 que se ejecute en un HP Kayak a 600 MHz. Datos S11 complejos transferidos,
con "CALC:DATA?SDATA". La velocidad depende del tráfico de la LAN, si está conectado a la red.
d Medido con un programa VEE 5.0 que se ejecute en un analizador de la serie PNA. Datos S11 complejos transferidos,
con "CALC:DATA?SDATA".
e Medido con un programa Visual Basic 6.0 que se ejecute en un analizador de la serie PNA. Datos S11 complejos
transferidos.

f Medido con un programa Visual Basic 6.0 que se ejecute en un HP Kayak a 600 MHz. Datos S11
complejos transferidos. La velocidad depende del tráfico de la LAN, si está conectado a la red.

g Método IArray Transfer.getComplex utilizado para coma flotante de 32 bits.

h Método meas.getData utilizado para tipo de datos de variantes.

Tabla 28. Velocidad de recuperación y barrido

Operaciones | Número de ventanas | Número de trazas | Tiempo de recuperación (ms)
Recuperar | 1 | 1 | 140
Recuperación y barrido | 1 | 1 | 198
Recuperar | 1 | 2 | 259
Recuperación y barrido | 1 | 2 | 341
Recuperar | 1 | 4 | 588
Recuperación y barrido | 1 | 4 | 723
Recuperar | 2 | 2 | 282
Recuperación y barrido | 2 | 2 | 373
Recuperar | 3 | 4 | 610
Recuperación y barrido | 3 | 4 | 788
Recuperar | 4 | 4 | 613
Recuperación y barrido | 4 | 4 | 790
Recuperar | 4 | 8 | 1236
Recuperación y barrido | 4 | 8 | 1463


Recursos

Otros recursos

Véase asimismo...

También están disponibles los siguientes recursos de análisis de redes.

Recursos de documentación

Recursos de otros fabricantes

Recursos de documentación

Notas de aplicación

Se puede acceder a varias de las siguientes notas de aplicación desde el analizador.

  1. En el menú Help, hacer clic en Product Overview.

  2. Product Overview comienza con una introducción. Para saltarse rápidamente esta introducción, hacer clic en Main Menu.

  3. En el menú principal, hacer clic en Literature y, a continuación, en cualquier título de documento que se desee visualizar.

También se puede acceder a todas estas notas de aplicación y de producto a través de esta dirección URL:

http://www.agilent.com/find/PNA

  • Application Development with the Agilent PNA Series of Network Analyzers, (número de documento 5980-2666ENUS).

  • Understanding and Improving Network Analyzer Dynamic Range, nota de aplicación de Agilent 1363-1 (número de documento 5980-2778EN).

  • The " Need for Speed" in Component Manufacturing Test, (número de documento 5980-2783EN).

  • Generate Component Data Sheets with Agilent's BenchLinkXL, (número de documento 5980-2781EN).

  • Connectivity Advances in a LAN-enabled Instument, (número de documento 5980-2782EN).

  • De-embedding and Embedding S-Parameter Networks Using the PNA Series Network Analyzer, nota de aplicación de Agilent 1364-1 (número de documento 5980-2784EN).

  • Advanced Filter Tuning Using Time Domain, nota de aplicación de Agilent 1287-10 (número de documento 5980-2785EN).

  • Understanding the Fundamental Principles of Vector Network Analysis, nota de aplicación de Agilent 1287-1 (número de documento 5965-7707E).

  • Exploring the Architectures of Network Analyzers, nota de aplicación de Agilent 1287-2 (número de documento 5965-7708E).

  • Applying Error Correction to Network Analyzer Measurements, nota de aplicación de Agilent 1287-3 (número de documento 5965-7709E).

  • Network Analyzer Measurements: Filter and Amplifier Examples, nota de aplicación de Agilent 1287-4 (número de documento de Agilent 5965-7710E).

  • Improving Throughput in Network Analyzer Applications, nota de aplicación de Agilent 1287-5 (número de documento 5966-3317E)

  • Using a Network Analyzer to Characterize High-Power Components, nota de aplicación de Agilent 1287-6 (número de documento 5966-3319E)

  • Simplified Filter Tuning Using Time-Domain Analysis, nota de aplicación de Agilent 1287-8 (número de documento 5968-5328E).

  • In-Fixture Measurements Using Vector Network Analysis, nota de aplicación de Agilent 1287-9 (número de documento 5968-5329E).

  • 8 Hints for Making Better Network Analyzer Measurements, nota de aplicación de Agilent AN 1291-1 (número de documento 5965-8166E)

  • Specifying Calibration Standards for the Agilent 8510 Network Analyzer, nota de producto de Agilent 8510-5A, (número de documento 5956-4352 o número de referencia de Agilent 08510-90352, febrero de 1988).

  • In-Fixture Microstrip Device Measurements Using TRL* Calibration, nota de producto de Agilent 8720-2, (número de documento 5091-1943E, agosto de 1991).

Recursos de otros fabricantes

Para obtener información sobre dispositivos de verificación y manipuladores de piezas, ponerse en contacto con:

Inter-Continental Microwave
1515 Wyatt Drive
Santa Clara, CA 95054-1524 EE.UU.
Teléfono: (408) 727-1596
Fax: (408) 727-0105
Sitio Web: www.icmicrowave.com
Correo electrónico: icmfixture@aol.com

Para obtener información sobre equipos y accesorios de sondeo, ponerse en contacto con:

Cascade Microtech, Inc.
2430 NW 206th Avenue
Beaverton, OR 97006 EE.UU.
Teléfono: (503) 601-1000
Fax: (503) 601-1002
Sitio Web: www.cascademicrotech.com
Correo electrónico: sales@cmicro.com

Para obtener información sobre medidas equilibradas y multipuerto, ponerse en contacto con:

ATN Microwave, Inc.
85 Rangeway Road
N. Billerica, MA 01862-2105 EE.UU.
Teléfono: (978) 667-4200
Fax: (978) 667-8548
Sitio Web: www.atnmicrowave.com


Opciones

Opciones del analizador

Véase asimismo...

Con cada instrumento se incluye un ratón, un teclado y un CD-ROM que contiene una copia del conjunto de manuales de programación y funcionamiento, un adaptador miniparalelo a paralelo y una garantía de servicio de tres años con devolución del equipo a Agilent. En este tema se presentan las opciones disponibles.

Opciones del instrumento

Actualizaciones de opciones

Documentación y localización

Opciones de servicio y asistencia

Opciones del instrumento

Opción 010 | Capacidad de dominio del tiempo Para visualizar las respuestas de reflexión y de transmisión en el dominio del tiempo. Véase Descripción general del dominio del tiempo.
Opción 015 | Equipo de verificación configurable Añade acceso a través del panel frontal a la salida de la fuente y la entrada del acoplador en los puertos 1 y 2. Incluye atenuadores de etapa de 35 dB añadidos entre los acopladores y los receptores. Esta opción ofrece la posibilidad de optimizar la sensibilidad de medida para medir señales de bajo nivel, o bien añadir componentes y otros instrumentos periféricos para diversas aplicaciones de medida. Véase la sección Medidas de componentes de alta potencia.
Opción 1CM | Kit de montaje en bastidor Añade un sistema de montaje en bastidor (nº de referencia 5063-9216) y un kit de guías (E3663AC) para utilizar el analizador sin las asas delanteras.
Opción 1CP | Kit de montaje en bastidor Añade un sistema de montaje en bastidor (nº de referencia 5063-9236) y un kit de guías (E3663AC) para utilizar el analizador con las asas delanteras suministradas anteriormente.
Opción AM8 | Unidad de CD RW Incluye una unidad de CD externa de lectura/escritura con un cable USB.
Opción B30 | Hub USB Incluye un hub USB de 4 puertos para conectar periféricos USB adicionales.

Actualizaciones de opciones

Hat disponibles kits de actualización para añadir opciones tras la adquisición inicial de un analizador. Para pedir un kit de actualización para un E8356A, E8357A o E8358A, hay que especificar el número de modelo del analizador seguido de una "U" e indicar a continuación la opción que se va a añadir:

Opción 010 | Kit de actualización de dominio del tiempo (número de referencia E8356-60101) Debe especificarse el número de serie del E8356A, E8357A o E8358A cuando se pida este kit. La instalación no está incluida.
Opción 015 | Kit de actualización de equipo de verificación configurable (número de referencia E8356-60102) Incluye la instalación en un centro de servicio de Agilent.
Opción AM8 | Unidad de CD RW Incluye una unidad de CD externa de lectura/escritura con un cable USB.
Opción B30 | Hub USB Incluye un hub USB de 4 puertos para conectar periféricos USB adicionales.
Opción 099 | Kit de actualización del firmware (número de referencia E8356-60103) Proporciona la revisión más reciente del firmware para el analizador de la serie PNA en CD-ROM. El propio usuario puede instalar el firmware. Para instalarlo se necesita una unidad de CD-ROM USB o un ordenador externo conectado a través de una LAN. El firmware más reciente también está disponible en el sitio Web de Agilent. La dirección de nuestra página Web es www.agilent.com/find/pna. Para obtener ayuda con la instalación, véase Actualización de firmware.

Las actualizaciones que precisan cambios en el número de modelo se basan en un presupuesto que incluye una manipulación especial. Para obtener más información, ponerse en contacto con la oficina local de ventas o de servicio de Agilent. Véase Contactos de Agilent.

Documentación y localización

Opción AVK | Añade una versión impresa de la Ayuda, que es la documentación del usuario y del programador. (número de referencia E8356-90028)
Opción 0BW | Añade una copia impresa del manual de servicio a nivel de conjunto. (número de referencia E8356-90002)
Opción ABD | Añade una versión impresa de la Ayuda en alemán. (número de referencia E8356-90032)
Opción ABE | Añade una versión impresa de la Ayuda en español. (número de referencia E8356-90031)
Opción ABF | Añade una versión impresa de la Ayuda en francés. (número de referencia E8356-90029)
Opción ABJ | Añade una versión impresa de la Ayuda en japonés. (número de referencia E8356-90032)

Opciones de servicio y asistencia

Opción W01 | Convierte la garantía de servicio de tres años con devolución del equipo a Agilent en una garantía de servicio de un año a domicilio (ponerse en contacto con la oficina de ventas o servicio de Agilent para conocer la disponibilidad en cada zona). Véase Contactos de Agilent.
Opción W31 | Convierte la garantía de servicio de tres años con devolución del equipo a Agilent en una garantía de servicio de tres años a domicilio (ponerse en contacto con la oficina de ventas o servicio de Agilent para conocer la disponibilidad en cada zona). Véase Contactos de Agilent.
Opción W32 | Añade el contrato de calibración comercial de tres años con devolución del equipo a Agilent.
Opción W34 | Añade el contrato de calibración basada en estándares de tres años con devolución del equipo a Agilent.
Opción W50 | Amplía a cinco años la garantía de servicio con devolución del equipo a Agilent.
Opción W51 | Convierte la garantía de servicio de tres años con devolución del equipo a Agilent en una garantía de servicio de cinco años a domicilio (ponerse en contacto con la oficina de ventas o servicio de Agilent para conocer la disponibilidad en cada zona). Véase Contactos de Agilent.
Opción W52 | Añade el contrato de calibración comercial de cinco años con devolución del equipo a Agilent.
Opción W54 | Añade el contrato de calibración basada en estándares de cinco años con devolución del equipo a Agilent.


Tech Supp

Asistencia técnica

Véase asimismo...

    • Haga clic en el tema en el que esté interesado.

  • Para obtener ayuda sobre sus necesidades de medida y prueba, visite www.agilent.com/find/assist

  • O bien póngase en contacto con los expertos en medida y prueba de Agilent Technologies.

Estados Unidos:

(tel.) 1 800 452 4844

Canadá

(tel.) 1.877.894 4414

(fax) 1 (905) 206 4120

Europa:

(tel.) (31 20) 547 2000

Japón:

(tel.) (81) 426 56 7832

(fax) (81) 426 56 7840

Latinoamérica:

(tel.) (305) 267 4245

(fax) (305) 267 4286

Australia:

(tel.) 1 800 629 485

(fax) (61 3) 9272 0749

Nueva Zelanda

(tel.) 0 800 738 378

(fax) 64 4 495 8950

Pacífico Asiático:

(tel.) (852) 3197 7777

(fax) (852) 2506 9284


Tshoot

Resolución de problemas del analizador

Véase asimismo...

Si se realizan algunas comprobaciones, se podrá averiguar si el analizador está experimentando un problema. Antes de ponerse en contacto con Agilent Technologies o de enviar el instrumento al centro de servicio, deben realizarse las siguientes comprobaciones.
Comprobar lo esencial

Comprobar los términos de errores

Consultar la Guía de Servicio

Comprobar lo esencial

Un problema puede solucionarse a menudo repitiendo el procedimiento que se estaba realizando cuando se produjo el problema. Antes de ponerse en contacto con Agilent Technologies o de enviar el instrumento al centro de servicio, deben realizarse las siguientes comprobaciones:

  1. ¿Llega electricidad a la toma de corriente? ¿Está enchufado el instrumento?

  2. ¿Está encendido el instrumento? Comprobar si el interruptor de alimentación del panel frontal y, al menos, uno de los anillos de indicadores LED situados alrededor de los puertos de verificación se iluminan en verde. Esto indica que la fuente de alimentación está activada.

  3. Si se están utilizando otros equipos, cables y conectores con el instrumento, habrá que asegurarse de que están conectados de forma adecuada y funcionan correctamente.

  4. Revisar el procedimiento de medida que se estaba realizando cuando surgió el problema. ¿Son correctos todos los ajustes?

  5. Si el instrumento no funciona correctamente, devolver la unidad a un estado conocido pulsando la tecla Preset.

  6. ¿Se ajustan la medida realizada y los resultados esperados a las especificaciones y posibilidades del instrumento?

  7. Si se piensa que el problema puede deberse al firmware, comprobar si el instrumento dispone de la versión más reciente del firmware antes de iniciar el procedimiento de resolución de problemas.

  8. Comprobar si la calibración de la medida es válida. Véase Calibraciones precisas de medidas para obtener más información al respecto.

  9. Si están disponibles los equipos de verificación necesarios, llevar a cabo la verificación del sistema y la comprobación del operador que se describe en el capítulo 2 de la Guía de Servicio de PNA, "Ajustes, verificaciones y pruebas del sistema", que se incluye en el CD-ROM suministrado con el analizador.

Comprobar los términos de errores

Si se imprimen los términos de errores a intervalos establecidos (semanalmente, mensualmente, etc.), se podrán comprobar los términos de errores actuales con estos registros. Un sistema estable y repetible debería generar términos de errores repetibles durante largos intervalos de tiempo, por ejemplo, seis meses. Si se sospecha que se ha producido un fallo sutil o un pequeño problema de rendimiento, debería compararse la magnitud de los términos de errores con los valores generados anteriormente con el mismo instrumento y kit de calibración. Véase el procedimiento para monitorizar los términos de errores.

  • Una tendencia a largo plazo refleja a menudo la existencia de deriva, desgaste de cables y conectores o degradación gradual, lo cual indica la necesidad de investigaciones más profundas y un mantenimiento preventivo adicional. Sin embargo, puede que el sistema siga ajustándose a las especificaciones. A menudo, este problema se puede resolver con sólo limpiar y calibrar los conectores o inspeccionar los cables.

  • Un cambio repentino de los términos de errores refleja un cambio repentino de los errores sistemáticos y puede indicar la necesidad de una resolución de problemas más minuciosa.

Durante la resolución de problemas hay que tener en cuenta que:

  • Todas las piezas del sistema, incluidos los cables y los dispositivos de calibración, pueden contribuir a producir errores sitemáticos y afectar a los términos de errores.

  • Los conectores deberán estar limpios y calibrados, y deberán ajustarse a las especificaciones para que el análisis de los términos de errores sea significativo. Véase el capítulo 2 de la Guía de Servicio de PNA para obtener más información sobre la limpieza y calibración de los conectores.

    • Hay que evitar dobleces y flexiones innecesarias de los cables tras la calibración de medida; de esta forma, se reducirán al máximo los errores de inestabilidad de los cables.

    • Utilizar técnicas correctas de conexión durante la calibración de medidas. La interfaz del conector debe ser repetible. Véase la Guía de Servicio de PNA para obtener información sobre las técnicas de conexión.

  • Con frecuencia, merece la pena realizar el procedimiento dos veces (utilizando dos calibraciones de medida diferentes) para establecer el grado de repetibilidad. Si los resultados no parecen repetibles, comprobar todos los conectores y cables.

  • Utilizar el análisis de términos de errores para resolver problemas de rendimiento sutiles y de poca importancia. Véase el capítulo 3, "Resolución de problemas", de la Guía de Servicio de PNA si surge un fallo obvio o un error de medida grave.

Consultar la Guía de Servicio

Consultar la Guía de Servicio de PNA para conocer procedimientos específicos de resolución de problemas que ayudan a identificar problemas. Se incluye en el CD-ROM que se suministró con el analizador. También se puede obtener un ejemplar de la Guía de Servicio en nuestro sitio Web http://www.agilent.com/find/pna


Accessry

Accesorios disponibles

Véase asimismo...

Kits de calibración

Kits de verificación

Kits de accesorios y adaptadores de conectores

Cables de puertos de verificación

En el Catálogo de accesorios para pruebas de microondas y de RF de Agilent (número de publicación 5968-4314EN) o en el sitio web www.agilent.com/find/mta se ofrece una gama completa de accesorios para pruebas de RF.

Los accesorios están disponibles con estos tipos de conectores:

  • Tipo N, 50 ohmios

  • 3,5 mm

  • 7 mm

  • 7-16

Para contar con un sistema de medida completo se necesita un kit de calibración y cables de puertos de verificación. Para comprobar el rendimiento corregido del sistema se utiliza un kit de verificación.

Kits de calibración

Tipo N, 50 ohmios Mecánico | Agilent 85032F
Tipo N, 50 ohmios Módulo de calibración electrónica (ECal) de RF | Agilent 85092B
3,5 mm Mecánico | Agilent 85033E
3,5 mm Módulo de calibración electrónica (ECal) de RF | Agilent 85093B
7 mm | Agilent 85031B
7 mm Módulo de calibración electrónica (ECal) de RF | Agilent 85091B
7-16 | Agilent 85038A
7-16 Módulo de calibración electrónica (ECal) de RF | Agilent 85098B

Kits de verificación

Tipo N | Agilent 85055A
3,5 mm | Agilent 85053B

Kits de accesorios y adaptadores de conectores

3,5 mm Kit de adaptadores | Agilent 11878A
APC-7 a Tipo N (h) Adaptador coaxial | Agilent 11524A
APC-7 a Tipo N (m) Adaptador coaxial | Agilent 11525A
7-16 a 7-16 Kit de adaptadores | Agilent 11906A
7-16 a Tipo N Kit de adaptadores | Agilent 11906B
Kit de accesorios, Tipo N, 50 ohmios | Agilent 11853A
Kit de accesorios, BNC, 50 ohmios | Agilent 11854A

Cables de puertos de verificación

Tipo N (m-m), 50 ohmios, 16 pulgadas (40,6 cm) | Agilent N3839A
Tipo N (m-m), 50 ohmios, 24 pulgadas (60,96 cm) | Agilent N6314A
Tipo N (m-h), 50 ohmios, 16 pulgadas (40,6 cm) | Agilent N6315A


Instrument_Calibration_and_Verification

Calibración del instrumento y verificación del sistema

Véase asimismo...

Para asegurarse de que el analizador funciona correctamente, se pueden utilizar diferentes niveles de inspección.

Calibración del instrumento

Verificación del sistema

Calibración del instrumento

¿Por qué se debe calibrar un instrumento?

Con el paso del tiempo, los componentes activos del analizador van envejeciendo y el rendimiento del mismo puede degradarse o alterarse. Para garantizar que el analizador funciona conforme a las especificaciones publicadas, se debe realizar periódicamente una calibración del instrumento.

¿En qué consiste la calibración del instrumento?

La calibración del instrumento es un proceso en el que se mide el rendimiento del analizador para garantizar que éste funciona de acuerdo con las especificaciones. Si cualquiera de los parámetros de rendimiento no cumple las especificaciones publicadas, se realizan ajustes para obtener el rendimiento adecuado.

¿Con qué frecuencia se debe calibrar el instrumento?

En las especificaciones del instrumento se tiene en cuenta la variación de rendimiento que puede producirse transcurrido un periodo de 12 meses. Por lo tanto, si se lleva a cabo una calibración del instrumento cada 12 meses se garantizará que el rendimiento del analizador se mantiene dentro de las especificaciones de funcionamiento. Si se necesita que el analizador mantenga unos parámetros de funcionamiento más consistentes, se puede calibrar el instrumento con una frecuencia superior al intervalo de 12 meses recomendado anteriormente.

¿Cómo se calibra un instrumento?

Para calibrar un instrumento, hay que enviarlo a uno de los centros de servicio de Agilent Technologies. Véase Asistencia técnica. Para realizar la calibración del instrumento, se necesita lo siguiente:

  • Equipo de verificación de calibración del instrumento

  • Software de verificación del rendimiento

¿Qué tipos de calibración del instrumento se pueden realizar?

Agilent Technologies ofrece los siguientes tipos de calibración del instrumento:

Estándar | Incluye un certificado de calibración en el que se establece que el instrumento ha sido calibrado y funciona de acuerdo con las especificaciones publicadas.
Opción UK6 | Incluye los datos de verificación de la calibración y el certificado estándar en el que se indica que el instrumento ha sido calibrado y funciona de acuerdo con las especificaciones publicadas.
Opción M40 (especial) | Incluye los datos de verificación de la calibración y un certificado en el que se indica que el instrumento ha sido calibrado mediante un proceso conforme a la norma ANSI Z540 y funciona de acuerdo con las especificaciones publicadas.

Verificación del sistema

Esta rutina comprueba el funcionamiento del sistema analizador midiendo automáticamente la magnitud y la fase de los cuatro parámetros S de cada uno de los dispositivos incluidos en un kit de verificación, y comparando los valores con los siguientes elementos:

  • Datos medidos en fábrica de los archivos contenidos en el disco de verificación

  • Líneas límite en función de la incertidumbre de medida

Este proceso garantiza que el analizador puede:

  • Realizar medidas en todo el margen de frecuencias.

  • Realizar medidas dentro del margen dinámico del instrumento utilizado con mayor frecuencia.

  • Aplicar correctamente datos de calibración de medida.


FW_upgrade

Actualización de firmware y ayuda

Véase asimismo...

La más reciente actualización del firmware del analizador de la serie PNA está disponible en el sitio web de Agilent. Se puede acceder a dicho sitio web y transferir una actualización gratis. Si no se tiene acceso a Internet, las actualizaciones del firmware también se ofrecen en CD-ROM. Véase Opciones del analizador para obtener información sobre el pedido de dicho CD-ROM.

La actualización es un archivo InstallShield autoextraíble. Incluye lo siguiente.

  • Aplicación de medida para analizador de redes

  • Ayuda en línea

  • Utilidades de servicio

El grupo de archivos ocupa aproximadamente 20 MB. Se puede utilizar el analizador de la serie PNA o un PC externo para transferir la actualización.

Procedimiento para utilizar el analizador de la serie PNA

Utilizar el analizador de la serie PNA, el explorador de web y la red local (LAN) integrada para acceder al sitio web de Agilent.

  1. Acceder a la página web de PNA en la dirección http://www.agilent.com/find/PNA< /p>

  2. Hacer clic en Support

  3. Hacer clic en Download Firmware

  4. A continuación, se puede optar por:

    • Ejecutar el programa desde su ubicación actual (desde el servidor). [Opción recomendada]

    • Guardar el programa en el disco (disco duro del analizador)

Si se guarda la actualización en el disco, abrir el archivo en el analizador y seguir las instrucciones. Se trata de un archivo autoextraíble.

Procedimiento para utilizar un PC externo

Si no se puede acceder a Internet directamente con el analizador, también se puede utilizar un PC externo con acceso a Internet para transferir el archivo desde el sitio web de Agilent. A continuación, se puede transferir el archivo del PC al analizador a través de una LAN.

  1. Acceder a la página web de PNA en la dirección http://www.agilent.com/find/PNA< /p>

  2. Hacer clic en Support

  3. Hacer clic en Download Firmware

  4. Guardar el programa en el disco (disco duro del PC)

  5. Transferir el archivo del PC al analizador a través de una LAN

    • Ejecutar el programa desde su ubicación actual (desde el PC externo).

    • Guardar el programa en el disco (disco duro del analizador)

Advertencia: Se puede guardar el archivo de actualización, pero no se debe instalar la aplicación del analizador de redes en el PC externo. De lo contrario, se alteraría la configuración del sistema y éste podría bloquearse.


Glossary

Contenido

Glosario

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

Corrección de errores de 12 términos Véase Corrección de errores, 12 términos.

Dispositivo de 1 puerto Un dispositivo con un único conector o ruta hasta los circuitos del dispositivo. Algunos ejemplos son un oscilador y una carga.

Calibración de 2 puertos, completa Véase Corrección de errores, 12 términos.

Dispositivo de 2 puertos Un dispositivo con dos conectores u otras rutas hasta los circuitos del dispositivo. Algunos ejemplos son filtros, dispositivos de SAW, atenuadores, atenuadores de acoplamiento y amplificadores.

Corrección de errores de 3 términos Véase Corrección de errores, 3 términos.

A

Accionar Activar una función.

Acoplador Véase Acoplador direccional.

Acoplador direccional Un dispositivo de 3 puertos utilizado normalmente para muestrear por separado la onda de retroceso (reflejada) en una línea de transmisión.

Acoplamiento entre fuentes Una medida de la proximidad de la impedancia de la fuente de señales a la impedancia ideal de la línea de transmisión del sistema de verificación. La adaptación normalmente se mide como la pérdida de retorno o relación de onda estacionaria (SWR) de la fuente.

Adaptación de carga Una medida que indica lo próxima que se encuentra la impedancia de carga de terminación del dispositivo a la impedancia ideal de la línea de transmisión. La adaptación normalmente se mide como la pérdida de retorno o relación de onda estacionaria (SWR) de la carga.

ADC (Analog to Digital Converter) Convertidor analógico a digital

ADM (Add-Drop Multiplexer) Multiplexor de extracción/inserción

Admitancia (Y) Lo contrario de la impedancia (es decir, la relación entre corriente y tensión). Las admitancias complejas toman la forma de Y = G + jB(t).

Aislador Un dispositivo de RF que se utiliza como medio de aislamiento entre rutas y componentes. Formado por un circulador de 3 puertos, el tercer puerto está terminado en una carga de 50 ohmios.

Aislamiento Una especificación o medida de la inmunidad de una señal ante los efectos de otra señal adyacente. Este fenómeno se denomina diafonía.

ALC (Automatic Level Control) Control automático de nivel. Véase Control automático de ganancia.

Alimentación de paso del LO La respuesta en un sistema superheterodino cuando la primera frecuencia del oscilador local es igual a la primera IF.

Almacenamiento, disco Un disco de almacenamiento digital externo o interno para guardar datos de pruebas, configuraciones de instrumentos, programas IBASIC y otros parámetros de medida. Entre los formatos de almacenamiento se incluyen MS-DOS (R) y HP LIF con formatos de datos binarios, PCX, HP-GL o ASCII.

AM (Amplitude Modulation) Modulación de amplitud

Análisis de redes La caracterización de un dispositivo, circuito o sistema resultante de comparar la entrada de una señal que llega a un dispositivo con una o más señales que salen del mismo.

Analizador sintáctico, comando Lee los mensajes de programa de la cola de entrada de un dispositivo en el orden en que se recibieron del controlador. El analizador sintáctico determina qué acciones debe realizar el analizador. Una de las funciones más importantes del analizador sintáctico de comandos es determinar la posición de un mensaje del programa en el árbol de comandos SCPI del analizador. Cuando el analizador sintáctico de comandos se reinicia, se espera que el siguiente elemento que reciba provenga de la base del árbol de comandos del analizador.

Analógico Relativo a la clase general de dispositivos o circuitos en los que la salida varía como una función continua de la entrada.

Ancho de banda (BW) La diferencia entre las frecuencias de una banda de frecuencias continua dentro de la cual el rendimiento de un dispositivo se encuentra dentro de las especificaciones.

Ancho de banda de resolución La capacidad de un analizador de espectros para mostrar respuestas adyacentes de forma discreta (hercios, hercios decibelios abajo). Este término se utiliza para identificar el ancho del filtro de ancho de banda de resolución de un analizador de espectros en algún nivel por debajo del punto mínimo de pérdida de inserción (punto de desviación máxima en la pantalla). Normalmente se especifica el ancho de banda de resolución de 3 dB, pero en algunos casos se especifica el ancho de banda de resolución de 6 dB.

Ancho de banda de vídeo En los analizadores de espectros, la frecuencia de corte (punto de 3 dB) de un filtro de paso bajo ajustable en el circuito de vídeo. Cuando el ancho de banda de vídeo es igual o menor que el ancho de banda de la resolución, el circuito de vídeo no puede responder por completo a las fluctuaciones más rápidas de la salida del detector de envolvente. El resultado es un suavizado de la traza, o una reducción de la excursión entre picos, de señales de banda ancha tales como ruido y RF de pulsos cuando se visualizan en el modo de banda ancha. El grado de promediado o suavizado es una función de la relación entre el ancho de banda de vídeo y el ancho de banda de la resolución.

Anotación El etiquetado de información específica en la pantalla (como la frecuencia o la potencia).

ANSI American National Standards Institute (Instituto Nacional Norteamericano de Normalización): Una organización nacional (abierta a fabricantes, organizaciones, usuarios y compañías operadoras de comunicaciones) que aprueba normas, acredita grupos de desarrollo de normas y programas de certificación, y representa y coordina los intereses de Estados Unidos ante organismos de normalización no gubernamentales y no vinculados por tratados.

Apertura El recorrido de frecuencias del analizador de redes utilizado para calcular el retardo de grupo. Cuanto más estrecha sea la apertura, mayor será la resolución de las variaciones del retardo de grupo, pero el ruido se reduce al aumentar la apertura.

Archivo de líneas límite El archivo de memoria del usuario que contiene las entradas de la tabla de líneas límite.

Armónicos de la fuente El nivel de armónicos generados por la fuente de señales del analizador, en dBc desde la fundamental.

ASCII (American Standard Code for Information Interchange) Código estándar norteamericano para el intercambio de información

Atenuación Indica una reducción de la amplitud de una señal. La diferencia entre la potencia recibida y transmitida como consecuencia de la pérdida que se produce a través de equipos, líneas u otros dispositivos de transmisión; normalmente se expresa en decibelios.

Atenuación de salida La capacidad para atenuar la señal, la fuente, para controlar su nivel de potencia.

Atenuador Un dispositivo de microondas o de RF utilizado para reducir el nivel de potencia de una señal en cantidades precisas e incrementales en todo su margen de frecuencias.

Atenuador de entrada Un atenuador situado entre el conector de entrada y el primer mezclador de un analizador de espectros (también denominado un atenuador de RF). El atenuador de entrada se utiliza para ajustar el nivel de señal incidente en el primer mezclador, y para evitar la compresión de ganancia causada por señales de alto nivel o de banda ancha. También se utiliza para ajustar el margen dinámico mediante el control del grado de distorsión generada internamente. En algunos analizadores, al cambiar la configuración del atenuador de entrada cambia la posición vertical de la señal en la pantalla, que a su vez cambia el nivel de referencia en consecuencia. En los analizadores Agilent controlados mediante microprocesadores, la ganancia de IF cambia para compensar los cambios que se producen en la configuración del atenuador de entrada. Por este motivo, las señales permanecen estacionarias en la pantalla, y el nivel de referencia no cambia.

Autoscale Una función del analizador que evalúa las formas de onda y ajusta los mandos para estabilizar y mejorar la visualización.

Autoverificación Un grupo de comprobaciones llevadas a cabo al encender (o preajustar) el instrumento que verifican su correcto funcionamiento.

AUX Auxiliar. Se refiere a un conector de entrada del panel posterior.

B

Banda estrecha En el análisis de redes, la resolución de frecuencia del receptor del analizador que es lo suficientemente estrecha para resolver las características de fase y magnitud de los dispositivos de banda estrecha. El ancho de banda reducido del receptor normalmente disminuye el límite inferior de ruido del receptor, con lo que se amplía el margen de amplitud de medida.

Barrido La capacidad de la fuente para proporcionar un nivel de señal específico en un margen de frecuencias específico en un período de tiempo específico. Véase también Modo de barrido y Tipo de barrido.

En el modo de procesamiento de datos, una serie de medidas de puntos de datos consecutivas tomadas sobre una secuencia de valores de estímulo.

Binario Un método de representación de números en una escala de dos (apagado o encendido, nivel alto o nivel bajo, uno o cero). Un formato rápido y compacto utilizado para transmitir información a y desde el analizador.

Bloqueo local Un estado o comando que impide las entradas desde el panel frontal (y desactiva la tecla local).

BMP (Bit-Mapped) Mapa de bits

B/R La relación entre los datos muestreados en B y los datos muestreados en R.

Buffer Un dispositivo de almacenamiento que se utiliza a la hora de transmitir información para compensar la diferencia de la velocidad de flujo de información entre dos dispositivos.

BUS (Basic Utility System) Sistema de utilidades básicas

Bus Uno o más conductores utilizados como ruta para enviar la información transmitida desde cualquiera de las diferentes fuentes a cualquiera de los diferentes destinos.

Búsqueda de picos Una función de un analizador que busca la respuesta más grande y sitúa un marcador sobre la misma.

BW Ancho de banda

Byte Ocho bits de datos que representan un carácter procesado como una unidad.

C

Cable pasivo Línea de cable pasivo: Un patrón de calibración. Véase Calibración, SOLT.

CAD (Computer Aided Design) Diseño asistido por ordenador

CAE (Computer Aided Engineering) Ingeniería asistida por ordenador

Calibración En la instrumentación de HP, el proceso consistente en verificar periódicamente (normalmente cada año) que un instrumento funciona de acuerdo con las especificaciones. Tras la verificación se otorga un certificado de calibración.

En los analizadores de redes, el proceso consistente en eliminar errores sistemáticos de las medidas. Véase Corrección de errores.

Calibración, 2 puertos Véase Corrección de errores,12 términos.

Calibración, Ajustar Z Establece la impedancia del sistema, normalmente de 50 o 75 ohmios.

Calibración, Blackburn Calibraciones de rutas de transmisión con acoplamiento entre fuentes corregido en las que existen 15 términos de calibración. Sinónimo: Corrección de errores de 15 términos

Calibración completa de 2 puertos Véase Corrección de errores, 12 términos.

Calibración electrónica (ECal) Un sistema de calibración para calibración electrónica de analizadores de redes vectoriales de microondas o RF. El sistema de calibración electrónica crea un modelo de errores de dos puertos y doce términos y a continuación ofrece una comprobación de confianza de la calibración. El sistema ECal consta de un patrón de calibración repetible, de impedancia variable y basado en semiconductores y una unidad de control principal que se conecta a los analizadores de redes de las series 8510, 8720 y 8753, o un módulo USB que se conecta a los analizadores de redes de la serie PNA.

Calibración, Interpolación Una función del analizador de redes, seleccionable por el usuario, que calcula (interpola) nuevos términos de corrección de errores a partir de términos existentes cuando se produce un cambio en los parámetros del analizador de redes, como el ancho de banda de IF, la potencia, o el tiempo de barrido. La corrección de errores resultante no es tan precisa como cuando se lleva a cabo una calibración completa del 2 puertos.

Calibración, Extensión de puertos Véase Extensión de puertos.

Calibración, Plano de referencia Véase Plano de referencia.

Calibración, Respuesta en frecuencia Es el procedimiento de corrección de errores más fácil de realizar, pero sólo corrige algunos de los doce términos de errores sistemáticos posibles. Se pueden realizar correcciones de la respuesta en frecuencia para medidas de reflexión, medidas de transmisión y medidas de aislamiento.

Calibración, SOLT Una calibración que utiliza cuatro patrones conocidos: (Short-Open-Load-Through) Circuito abierto, Circuito cerrado, Carga, Cable pasivo También se conoce como calibración completa de dos puertos y corrección de errores de 12 términos. Véase también Corrección de errores.

Calibración, TRL y LRM Una calibración utilizada en entornos en los que no se puede conectar un dispositivo sometido a prueba directamente a los puertos del analizador de redes (MMIC, microregleta, diodos de haz dirigido, etc.). Los patrones de línea reflectora de cable pasivo (TRL - Thru-Reflect-Line) y de acoplamiento (M - Match) se fabrican y se utilizan porque los patrones de alta calidad conocidos aún no están disponibles. Los requisitos para caracterizar estos patrones son menos rigurosos, pero la calibración no es tan precisa como la calibración tradicional completa de dos puertos que utiliza patrones S-O-L-T. Los términos se utilizan indistintamente (TRL, LRL, LRM, etc.), pero todos ellos se refieren al mismo método de calibración básico.

Canal activo El canal resaltado afectado por las funciones del panel frontal.

Canal R Canal de referencia

Canales no acoplados Valores de receptor o de estímulo que se pueden ajustar de forma independiente para cada canal.

Características adicionales Parámetros de rendimiento típicos, pero no garantizados, denominados "típicos, "nominales" o "aproximados".

Carga Un dispositivo de microondas de un puerto que se utiliza para terminar una ruta en su impedancia característica.

Cifra de ruido (F): En un dispositivo de dos puertos, una medida de cómo el ruido que se genera en el interior del dispositivo degrada la relación señal-ruido de una señal que pasa a través del dispositivo a 290 grados; normalmente se expresa en dB.

Coeficiente de reflexión La relación entre la tensión reflejada y la tensión incidente en un circuito o línea de transmisión. Si una línea de transmisión está terminada en su impedancia característica, el coeficiente de reflexión es cero. Si la línea está cerrada o abierta, el coeficiente es 1. Véase también Pérdida de retorno y SWR.

Comando Un conjunto de instrucciones que se traducen en acciones de instrumento. Las acciones están compuestas normalmente de fases individuales que, juntas, pueden ejecutar una operación.

Compresión de ganancia de señales pequeñas Una situación en la que la amplitud medida de la señal de entrada es menor que su nivel real debido a la sobrecarga del mezclador de entrada del analizador de redes; el analizador funciona de forma no lineal. En los detectores de los analizadores de banda ancha, una señal que no sea la que se somete a prueba puede ajustar el analizador en este modo de compresión de ganancia, por el que aparecen señales de un nivel incluso menor a un nivel más bajo que el real. El modo de banda ancha mide toda la potencia que incide en el analizador, no sólo las señales a la frecuencia de interés.

Conmutar Cambiar de estado, normalmente para cambiar una función de encendido a apagado, o de apagado a encendido.

Consulta Cualquier comando de programación del analizador que tiene la función diferenciada de devolver una respuesta. Estos comandos pueden acabar con un signo de interrogación (?). Los comandos de consulta devuelven información al ordenador.

Copia impresa Copia de datos en papel.

Corrección de errores En los analizadores de redes, un proceso que elimina o reduce errores de medida sistemáticos (repetibles) mediante la medida de patrones conocidos de un kit de calibración. Sinónimo: calibración de medida

Corrección de errores, 1 puerto Corrige en un equipo de verificación la directividad del 1 puerto o del puerto 2, la respuesta en frecuencia y los errores de adaptación de las fuentes. El proceso precisa tres terminaciones de patrones conocidos, por ejemplo, circuito abierto, circuito cerrado y carga.

Corrección de errores de dos puertos Véase Corrección de errores, 12 términos.

Corrección de errores, 3 términos. Se utiliza para eliminar errores de medida sistemáticos en un dispositivo con un puerto, como una carga.

Corrección de errores, 12 términos. Corrección de un dispositivo de dos puertos utilizando seis parámetros:
Directividad
Acoplamiento entre fuentes
Adaptación de carga
Respuesta en frecuencia de reflexión
Respuesta en frecuencia de transmisión
Aislamiento

Para caracterizar completamente un dispositivo de dos puertos, estos seis parámetros deben caracterizarse en las direcciones de avance y de retroceso, resultando un total de 12 términos. El usuario normalmente tiene la opción de omitir el aislamiento del proceso de corrección. Sinónimo: Corrección completa de errores de dos puertos

Corregida Medidas realizadas después de llevar a cabo la corrección de errores.

Controlador Un dispositivo capaz de especificar el emisor y los receptores en una transferencia de información. Un ordenador externo conectado a un instrumento para controlar su funcionamiento.

Control automático de ganancia (AGC) Un circuito utilizado en amplificadores y otros dispositivos activos para mantener constante su nivel de potencia de RF cuando cambian otros parámetros, como la frecuencia. Sinónimo: ALC (Automatic Leveling Control) Control automático de nivel

CPU (Central Processing Unit) Unidad central de procesamiento

Cuadrícula área limitada en la que se muestra la forma de onda en el instrumento. Las pequeñas marcas, en el marco o el eje, son una ayuda de escalado para realizar medidas visuales.

Cursor Un puntero generado electrónicamente que se mueve a través de la pantalla para manipular los controles.

CW (Continuous Wave) Onda continua: Una frecuencia única (en lugar de una frecuencia barrida).

D

DAC (Analog to Digital Converter) Convertidor analógico a digital

dB Decibelio: una unidad de medida relativa. La relación en dB se determina por: 10 log10 (P1/P2) donde P1 y P2 son las potencias medidas. Se prefiere el dB en lugar de las relaciones aritméticas o porcentajes, porque cuando se conectan los componentes en serie, el efecto que ejercen sobre la potencia, expresado en dB, puede sumarse y restarse aritméticamente. Por ejemplo, si un atenuador de 3 dB se conecta a un amplificador de 10 dB, la ganancia neta de los dos componentes es: -3 dB + 10 dB = +7 dB.

dBm Unidad de medida absoluta en decibelios: 0 dBm = 1 mW. Las convenciones del dB (sumar y restar) siguen siendo aplicables.

DBMS (Database Management System) Sistema de gestión de bases de datos

DC (Direct Current) Corriente continua

Demodulación El proceso consistente en recuperar de una portadora modulada información en forma de una señal que tiene esencialmente las mismas características que la señal de modulación original. Recuperación de la señal de modulación realizada mediante detección de señal.

Demodulación digital Describe una técnica de extracción de información utilizada para modular una señal. Se aplican algoritmos de procesado digital de señales a la señal después de convertirla de formato analógico a digital (digitalizada).

Deriva Cambio lento de la frecuencia de la señal.

Desplazamiento Mover o separar una determinada cantidad. Se utiliza en instrumentos para desplazar frecuencias, límites, retardos, pérdidas, impedancias, etc.

Desviación respecto de fase lineal La fase lineal se refiere a la naturaleza del desplazamiento de fase de una señal a través de un dispositivo. La fase es lineal si la representación gráfica del desplazamiento de fase con respecto a la frecuencia es una línea recta con escalas lineales. La desviación respecto de la fase lineal provoca distorsión de señales.

Detección El proceso de demodulación de portadoras de señales. Hay dos maneras básicas de detección de señales en los analizadores de redes: Detectores de diodos (utilizados en aplicaciones de banda ancha) y heterodinación (utilizada en aplicaciones de banda estrecha).

Detector, Diodo Un dispositivo utilizado para convertir una señal de RF a un nivel de CC proporcional. Si la amplitud de la señal está modulada, el diodo elimina la señal portadora de RF de la modulación. La amplitud de muchas fuentes utilizadas con analizadores escalares se modula con una señal de 27,778 kHz y, a continuación, se detecta en el analizador de redes. La información de fase de la portadora de señales se pierde en la detección mediante diodos.

Diafonía Fenómeno que ocurre cuando la señal de una ruta afecta a la señal en un puerto de un dispositivo. El aislamiento es la medida de la diafonía.

Diagrama de Smith Una presentación gráfica del coeficiente de reflexión compleja en la impedancia compleja normalizada. Los círculos del diagrama representan la resistencia constante y las líneas radiantes ortogonales a los círculos representan la reactancia constante. El centro del diagrama representa la impedancia característica del sistema de transmisión. Cualquier punto del diagrama define una impedancia compleja única. Una línea del gráfico representa la impedancia cambiante sobre la frecuencia.

Digital Relativo a la clase de dispositivos o circuitos en los que la salida varía en pasos discretos.

Dimensión Especifica el tamaño de una matriz. El número de columnas o filas de la matriz.

Dirección La identificación (representada por un nombre, etiqueta o número) de un registro, una ubicación en almacenamiento o cualquier otra fuente o destino de datos. Algunos ejemplos son la ubicación de una estación en una red de comunicaciones, o un dispositivo en el bus GP-IB.

Dirección Ethernet Un número hexadecimal que se utiliza para identificar un equipo en una red. A cada analizador se le asigna una dirección Ethernet en la fábrica, que se almacena en la memoria ROM del analizador.

Dirección IP Dirección de protocolo de Internet: un número único que se asigna a cada dispositivo conectado a una red TCP/IP. Antes de utilizar una analizador en una red, el administrador de la red deberá asignar una dirección IP. Una dirección IP está formada por un valor de 32 bits presentado en notación decimal: 4 octetos (bytes) separados por un punto.

Directividad En un acoplador direccional de 3 puertos, la relación entre la potencia presente en el puerto auxiliar cuando la señal se desplaza en dirección de avance y la potencia presente en el puerto auxiliar cuando la misma señal se desplaza en la dirección inversa.

Disco Un medio circular de almacenamiento magnético.

Disparo Una señal que provoca que el instrumento realice una medida. El usuario puede seleccionar varias opciones de disparo, como manual, continuo o externo (para sincronizar medidas con una fuente externa).

Dispositivo de banda ancha Un dispositivo que funciona en un margen de frecuencias muy amplio y muestra sólo pequeñas variaciones de respuesta en ese margen.

Dispositivo de banda estrecha Un dispositivo cuyas características de transferencia están concebidas para que funcionen en un margen de frecuencias muy estrecho y para ofrecer respuestas de amplitud bien definidas en ese margen, como un filtro de paso de banda.

Dispositivo de barrido Una fuente de señales que emite una señal cuya frecuencia varía continuamente.

Dispositivo lineal Un dispositivo en el que la salida es continuamente proporcional a la entrada.

Dispositivos no insertables En la calibración de medidas, un dispositivo que no se puede sustituir por una ruta de cable pasivo de longitud cero. Cuenta con conectores del mismo tipo y sexo en cada puerto, o un tipo diferente de conector en cada puerto.

Distorsión Deterioro de la calidad de una señal debido a las características no lineales de la función de transferencia de un sistema o dispositivo. La distorsión se mide como una combinación de los cambios de amplitud, frecuencia y fase de una señal en la salida de un dispositivo o sistema, en comparación con la señal en la entrada.

Distorsión de intermodulación Componentes de frecuencia no deseados resultantes de la interacción de dos o más componentes espectrales que pasan a través de un dispositivo cuyo comportamiento es no lineal, como un mezclador o un amplificador. Los componentes no deseados están relacionados con los componentes fundamentales mediante sumas y diferencias de los fundamentales y diversos armónicos. El algoritmo es: f1 ±f2, 2xf1 ±f2, 2xf2±f1, 3xf1 ±2x f2, etc.

DSP (Digital Signal Processing) Procesado digital de señales

DUT (Device Under Test) Dispositivo sometido a prueba

DVM (Digital Volt Meter) Voltímetro digital

E

ECal Véase Calibración electrónica.

EMC (Electro-Magnetic Compatibility) Compatibilidad electromagnética

EMI (Electro-Magnetic Interference) Interferencia electromagnética Señales de interferencia no intencionadas generadas dentro o fuera de un equipo electrónico. Las fuentes típicas podrían ser transitorios de líneas de alimentación, ruido de fuentes de alimentación de tipo conmutable y/o radiaciones espúreas de osciladores. La interferencia EMI se elimina mediante el filtrado de las líneas de alimentación, apantallado, etc.

EPROM (Electronically Programmable, Read-Only Memory) Memoria de sólo lectura programable electrónicamente

Entrada Una ruta destinada a la introducción de una señal en un instrumento.

La mayoría de los analizadores de redes cuentan con 3 (denominadas A, B y R) o 4 (denominadas A, B, R1 y R2) entradas. Las entradas no son lo mismo que los canales.

Equipo de verificación La disposición del hardware (conmutadores, acopladores, conectores y cables) que conecta la entrada y salida del dispositivo de verificación a la fuente del analizador de redes y al receptor para realizar medidas de parámetros S.

E/S Entrada/salida

Escalar Una cantidad que tiene magnitud, pero no fase. Un analizador de redes capaz de medir sólo la magnitud.

ESD (Electro Static Discharge) Descarga electrostática

Espúreos de intermodulación de transmisión Una medida de la capacidad de un transmisor para inhibir la generación de productos de distorsión de intermodulación. Los espúreos de intermodulación se denominan a veces atenuación de intermodulación.

Estabilidad de frecuencia Capacidad de un componente de frecuencia para permanecer inalterable en frecuencia o amplitud en períodos de tiempo a largo y corto plazo. La estabilidad se refiere a la capacidad de un oscilador para permanecer fijo a una frecuencia específica a lo largo del tiempo.

Estabilidad de la base de tiempos de la frecuencia de la fuente Una medida de la precisión de la base de tiempos del analizador sobre el tiempo y la temperatura. Normalmente la precisión de la base de tiempos se especificará para un período de 1 año. Una estabilidad de frecuencia de temperatura típica es ±10 ppm para 250 °C ±50 °C.

Estados de almacenamiento El número de configuraciones, programas, trazas y otros parámetros disponibles que se puedan guardar, catalogar y recuperar en cualquier momento.

Ethernet Una red que cumple la norma de redes locales IEEE 802.3.

Extensión de puertos Volver a definir el plano de referencia a otro diferente del establecido en la calibración. Un nuevo plano de referencia se define en segundos de retardo desde el puerto del equipo de verificación.

F

Factor de escala La calibración del eje vertical de visualización en términos de unidades por división.

Factor de velocidad Un valor numérico relacionado con la velocidad de la energía a través de líneas de transmisión con dieléctricos diferentes (0,66 para polietileno). Utilizado para realizar medidas en el dominio del tiempo.

Fase La parte fraccionaria de un ciclo a través del cual ha avanzado una oscilación, medida desde un punto de partida arbitrario; normalmente se mide en radianes o grados. En el análisis de redes, la respuesta de fase de un dispositivo sometido a prueba es el cambio de fase como una función de la frecuencia entre el estímulo de entrada y la respuesta medida.

Filtro Un dispositivo pasivo gracias al cual algunas frecuencias pasan y otras se atenúan, dependiendo del tipo y las especificaciones. Un filtro de paso alto deja pasar frecuencias por encima de la frecuencia de corte, un filtro de paso bajo deja pasar frecuencias por debajo de la frecuencia de corte, y un filtro de paso de banda deja pasar frecuencias entre dos frecuencias específicas.

Filtro de vídeo En los analizadores de espectros, un filtro de paso bajo y posterior a la detección que determina el ancho de banda del amplificador de vídeo. Se utiliza para promediar o suavizar una traza. Consúltese también Ancho de banda de vídeo.

Firmware Un conjunto compuesto por código de instrucciones y de hardware. El código de instrucciones y de hardware se integra y forma un conjunto funcional que no se puede alterar durante el funcionamiento normal. El código de instrucciones, instalado de forma permanente en los circuitos del instrumento, está clasificado como ROM (memoria de sólo lectura). El firmware determina las características de funcionamiento del instrumento o equipo.

FM (Frequency Modulation) Modulación de frecuencia

Forma de onda Una representación de una señal que muestra la amplitud en contraposición al tiempo.

Formatos de visualización Formatos gráficos para visualizar los datos de medidas. Entre ellos se incluyen: canal único, superposición (múltiples trazas en una cuadrícula), división (cada traza en una cuadrícula separada).

Frecuencia El número de oscilaciones, vibraciones u ondas periódicas por unidad de tiempo, normalmente expresado en ciclos por segundos, o hercios (Hz).

Frecuencia de corte En filtros, la frecuencia a la que la atenuación se encuentra 3 dB por debajo del nivel de señal de paso de banda, conocida como los puntos de 3 dB.

Frecuencia de inicio/parada Términos utilizados en relación con los puntos de parada y de inicio del rango de medida de frecuencias. Juntos determinan el recorrido del rango de medida.

Frecuencia fundamental En cualquier forma de onda, el componente de frecuencia más baja; los demás componentes son armónicos. Una curva sinusoidal pura sólo tiene un componente, la frecuencia fundamental.

Fuente Un dispositivo que suministra potencia de señal; un oscilador de barrido o un dispositivo de barrido sintetizado.

Función La acción o finalidad para la que se destina un determinado elemento. El analizador de redes contiene funciones que se pueden ejecutar a través de selecciones de las teclas del panel frontal, o a través de comandos de programación. El firmware del instrumento determina las características de estas funciones. En algunos casos, con una ejecución DLP (programa transferible) de una función se puede ejecutar la función mediante la selección de teclas del panel frontal.

Función de transferencia La relación entre la señal de salida y la señal de estímulo, ambas como una función de la frecuencia.

Funcionamiento local Utilización manual desde el panel frontal.

Funciones de marcador Cálculo estadístico o matemático realizado con los datos de uno o más marcadores para que el operario pueda disponer de más información. Por ejemplo, la función de marcador delta calcula y muestra la diferencia entre dos marcadores.

G

Gb Gigabit

GB Gigabyte

GHz Gigahercio

GIF (Graphics Interchange Format) Formato de intercambio de gráficos - Formato de gráficos estándar para almacenar archivos gráficos de mapa de bits.

Giga Prefijo que indica mil millones.

GP I/0 (General Purpose Input / Output) Entrada/salida de uso general; un conector situado normalmente en la parte posterior de un instrumento que posibilita la comunicación con otros equipos de pruebas, equipos de verificación externos, conmutadores y ordenadores que permiten realizar un disparo sobre el instrumento o que éste realice un disparo sobre un equipo externo. Un ejemplo es un conmutador de pedal que continúa una medida o permite realizarla paso a paso, de manera que el operador pueda utilizar ambas manos en el hardware de verificación.

GPIB (General Purpose Interface Bus) Bus de interfaz de uso general - El bus IEEE 488 es un bus de interconexión y protocolo que permite interconectar instrumentos con un ordenador.

GUI (Graphical User Interface) Interfaz gráfica de usuario

H

HP Hewlett-Packard Company

HPGL (Hewlett-Packard Graphics Language) Lenguaje de gráficos de Hewlett-Packard

GP-IB (Hewlett-Packard Interface Bus) Bus de interfaz de Hewlett-Packard. Una interfaz paralelo que permite el "encadenamiento en margarita" de más de un dispositivo a un puerto de un ordenador o instrumento. El protocolo de interfaz se define en IEEE 488.2; es equivalente al estándar GPIB.

HTTP (HyperText Transfer Protocol) Protocolo de transferencia de hipertexto: Utilizado para transportar el tráfico en World Wide Web (WWW).

I

IEEE (Institute of Electrical and Electronic Engineers) Instituto de ingenieros eléctricos y electrónicos

IF (Intermediate Frequency) Frecuencia intermedia: la frecuencia a la que una señal se procesa después de mezclarse.

Impedancia La relación entre la tensión y la corriente en un puerto de un circuito, expresada en ohmios.

Impedancia característica La impedancia al observar el final de una línea de transmisión sin pérdida de longitud infinita.

Inalámbrico Un término que hace referencia a una amplia variedad de tecnologías que ofrecen comunicaciones móviles para hogares y oficinas, y comunicaciones inalámbricas dentro de un edificio, para ofrecer mayor movilidad en áreas de trabajo, grupos de edificios o complejos empresariales. También se utiliza para designar "celular" en servicios de movilidad dentro o fuera de edificios.

Incertidumbre de medida La cantidad cuantificada de error en una situación de medida. Las calibraciones tienen como finalidad reducir la cantidad de incertidumbre. A continuación se muestran diferentes fuentes de errores de medida que producen incertidumbre:

  • Errores sistemáticos (imperfecciones de los patrones de calibración, conectores, cables e instrumentación)

  • Errores aleatorios (ruido, repetibilidad de conectores)

  • Deriva (fuente e instrumentación)

Inicializar El proceso que asigna ubicaciones de información a un disco para preparar los soportes magnéticos con el fin de aceptar archivos.

Intensidad Véase Intensidad del color.

Intensidad Brillo; luz que se refleja o se emite, luminosidad.

Intensidad del color Una medida de la intensidad de un color.

Interceptación de tercer orden TOI: La entrada de potencia en un dispositivo no lineal que causaría una distorsión de tercer orden al mismo nivel de potencia. TOI es una medida para determinar las características de distorsión de un mezclador o receptor. Cuanto más alto sea el valor, más inmune será el receptor a la distorsión interna.

Interfaz Una conexión que posibilita un enlace de comunicación común entre dos o más instrumentos.

Internet Conexión de dos o más redes diferentes. A menudo se utiliza una puerta de acceso o un router para realizar la conexión.

Interpolar Determinar el valor de una señal entre dos puntos adyacentes mediante un procedimiento o algoritmo.

Introducir Proceso consistente en introducir información.

IP (Internet Protocol) Protocolo de Internet

ISO (International Standards Organization) Organización internacional de normalización

J

K

KB Kilobyte

Kb/s Kilobytes por segundo

Kilo Prefijo que indica mil.

Kit de calibración El hardware y el software necesarios para llevar a cabo correcciones de errores en un analizador de redes para una medida y/o equipo de verificación específico.

L

LAN (Local Area Network) Red local

LANS (Local Area Network System) Sistema de red local

LCD (Liquid Crystal Display) Pantalla de cristal líquido

Lectura de funciones activas La zona de una pantalla en la que se muestra la función activa y su estado. La función activa es aquella que se ha realizado mediante la selección de la última tecla o comando de programación remoto.

LED (Light Emitting Diode) Diodo emisor de luz

LIF (Logical Interchange Format) Formato de intercambio lógico (utilizado para unidades de disco y ordenadores HP más antiguos)

Límite de ancho de banda El estado que impera cuando se supera el ancho de banda del sistema y la distorsión de la señal se produce al sobrepasar las especificaciones.

Límite de verificación Los niveles de resultados aceptables para cualquier medida determinada.

Límite inferior del ruido El ruido interno mostrado del analizador. El nivel de ruido a menudo limita lo pequeña que puede ser la magnitud de la señal para que se pueda medir. En el análisis de redes, el límite inferior del ruido se mide con los puertos de verificación terminados en cargas, con corrección completa de errores de dos puertos, ancho de banda de IF de 10 Hz, potencia máxima del puerto de verificación y sin promediado durante la verificación.

Líneas límite Líneas introducidas por el usuario que se superponen a los datos de medida del analizador para permitir la detección automática de datos que se encuentren fuera del margen aceptable. Se puede activar la anotación de los resultados "superado/fallido", alarmas acústicas o salidas electrónicas para notificar el estado de límite rebasado al operador o al programa del ordenador en línea.

LO (Local Oscillator) Oscilador local. En un sistema superheterodino, el LO se mezcla con la señal recibida para producir una suma o diferencia igual a la frecuencia intermedia (IF) del receptor.

Log Logaritmo

LRM (Line-Reflect-Match) Adaptación de reflexión de línea. Véase Calibración, TRL y LRM.

M

Magnitud La amplitud de una señal medida en su impedancia característica sin tener en cuenta la fase. Véase también Escalar.

Marcador Un símbolo gráfico que se anota a lo largo de una traza de pantalla con características de medida de ese punto de datos específico.

Marcador activo El marcador de una traza que puede volverse a colocar mediante los mandos del panel frontal o bien mediante comandos de programación.

Margen de frecuencias El margen de frecuencias en el que se especifica el rendimiento de un instrumento o dispositivo.

Margen dinámico En un receptor, el margen de niveles de señales, de la mínima a la máxima, que se puede medir simultáneamente y de forma fiable. Con el margen dinámico se pueden mediar señales pequeñas en presencia de señales más grandes. La compresión de la potencia de la fuente y el receptor normalmente restringe el límite máximo del margen dinámico. Las respuestas residuales del receptor y el límite inferior del ruido normalmente restringen el límite mínimo de potencia.

Margen dinámico del receptor Véase Margen dinámico.

Margen dinámico del sistema La diferencia entre el nivel de entrada máximo del receptor y el límite inferior de ruido del receptor. El margen dinámico del sistema se aplica sólo a medidas de transmisión, ya que las medidas de reflexión están limitadas por la directividad.

Margen dinámico de visualización El margen de amplitud, en dB, en el que se aplica la precisión dinámica de visualización.

Matiz Una tonalidad de color; tono.

Matriz Un conjunto de números o caracteres que representa una determinada función.

MB Megabyte

Medidas de reflexión Medidas que caracterizan el comportamiento de entrada y/o salida del dispositivo sometido a prueba. Se mide como la relación entre la señal reflejada y la señal incidente como una función de la frecuencia. Los parámetros se denominan pérdida de retorno, coeficiente de reflexión, impedancia y relación de onda estacionaria (SWR), todos ellos como una función de la frecuencia. Véase también Parámetros S.

Medidas de transmisión La caracterización de la función de transferencia de un dispositivo, es decir, la relación entre la señal de salida y la señal incidente. Las medidas más habituales incluyen la ganancia, la pérdida por inserción, el coeficiente de transmisión, la fase de inserción y el retardo de grupo, todos ellos medidos sobre la frecuencia. Véase también Parámetros S.

Medida regresiva La medida de un dispositivo desde la salida a la entrada.

Mega Prefijo que indica un millón.

Memoria Un medio de almacenamiento, dispositivo o medio de grabación en el que se pueden almacenar datos durante un período de tiempo, y desde el cual se pueden recuperar todos los datos originales.

Memoria no volátil Datos de memoria que se conservan en ausencia de una fuente de alimentación de CA. La memoria normalmente se conserva con una batería. También se refiere a la memoria RAM con batería de reserva.

Mensaje de error Un mensaje en la pantalla que indica que se ha producido un error. Hardware que falle o que no exista, una utilización inadecuada por parte del usuario u otras condiciones que requieran más atención pueden ser la causa de que se produzca un error. Normalmente, la acción u operación que se estaba solicitando no concluirá hasta que se resuelva el error.

Menú Funciones del analizador que aparecen en la pantalla y se seleccionan pulsando las teclas del panel frontal. Con estas selecciones se pueden activar otras funciones relacionadas que forman grupos denominados menús.

MHz Megahercio

mili Prefijo que indica una milésima parte.

Módem Modulador/demodulador

Modo de barrido La manera en que se inicia o se selecciona un barrido, por ejemplo, único, continuo, alterno o cortado.

Modo de barrido único El analizador de espectros realiza un barrido cuando se cumplen las condiciones de disparo. Cada barrido se inicia pulsando la tecla adecuada del panel frontal, o enviando un comando de programación.

Modo de barrido continuo Estado del analizador en el que las trazas se actualizan automáticamente cada vez que se cumplen las condiciones de disparo.

Modo de detector de visualización Modo en el que la información de vídeo analógica se procesa antes de digitalizarse y almacenarse en la memoria.

Modos de visualización Las diferentes maneras en que se pueden presentar gráficamente los datos medidos. En un analizador de redes, las opciones son formato cartesiano/rectilineal (representación XY con magnitud logarítmica o lineal, fase, retardo de grupo, SWR, real e imaginario, y dBV, dBmV y dBuV), polar (magnitud y ángulo), magnitud y fase, y diagrama de Smith. No todos los modos de visualización están disponibles en todos los analizadores de redes. Además, las visualizaciones pueden presentar esta información en diversas combinaciones de trazas. Los modos más habituales son dual (capacidad para mostrar más de una traza, normalmente en el mismo margen de frecuencias) y alterno (capacidad para mostrar más de una traza, cada una con diferentes tipos y márgenes de frecuencias).

Modulación El proceso, o el resultado del proceso, de variar una característica de una señal portadora con una señal que contiene información, de modo que la portadora contenga la información. Véase AM y FM.

Modulación de amplitud El proceso, o resultado del proceso, consistente en variar la amplitud de una señal portadora. La portadora modulada resultante contiene información que puede recuperarse mediante demodulación. Véase también Modulación.

Monitor Cualquier pantalla externa.

Monocromo De un solo color (cromaticidad).

ms Milisegundo

Muestreador Un componente electrónico que captura la fase y el nivel de una señal a través de una impedancia conocida a una velocidad uniforme. En los analizadores de redes, esta velocidad de muestreo debe ser lo suficientemente elevada y estar sincronizada con precisión para obtener medidas exactas. Los analizadores de redes normalmente tienen tres o cuatro muestreadores o mezcladores.

Multisíncrono Un tipo de monitor que puede sincronizar su barrido horizontal a diversas frecuencias dentro de un margen específico.

mW Milivatio: una milésima parte de un vatio

N

NIST (National Institute of Standards and Technology) Instituto nacional de normas y tecnología

Nit La unidad de luminancia (intensidad fotométrica) igual a una candela por metro cuadrado.

Nivel de entrada máximo La máxima potencia de señal que se puede aplicar de forma segura a la entrada de un analizador. El nivel de entrada máximo es normalmente de 1 W (+30 dBm) para los analizadores de espectros Agilent.

Nivel de referencia Una función del instrumento con la que el usuario puede establecer el valor de amplitud en la posición de referencia. En los analizadores de redes también se puede seleccionar la posición de referencia. En algunos analizadores de espectros, la posición de referencia está fijada en la parte superior de la pantalla.

No corregido Medidas realizadas sin llevar a cabo la corrección de errores.

Nombre del sistema Un nombre único que se utiliza para identificar cada equipo en una red. El nombre del sistema está vinculado directamente a la dirección IP y normalmente se puede utilizar en su lugar. El usuario o administrador del sistema es quien normalmente crea el nombre de sistema.

Normalizar Restar una traza de otra para eliminar errores de datos de calibración o para obtener información relativa.

O

Ordenador principal Un ordenador o dispositivo de una red que ofrece a los usuarios finales servicios tales como cálculo y acceso a bases de datos y que normalmente realiza funciones de control de la red.

P

Pantalla La superficie física del tubo de imagen o panel plano sobre la que se presentan los resultados de medida, la información de configuración, las definiciones de teclas programables y otra comunicación del instrumento.

Parámetros S (parámetros de dispersión) Una convención utilizada para caracterizar la manera en que un dispositivo modifica el flujo de señales utilizando un analizador de redes. Un dispositivo de dos puertos tiene cuatro parámetros S: transmisión progresiva (S21), transmisión regresiva (S12), reflexión de progresiva (S11) y reflexión regresiva (S22).

Paso de banda Un margen de frecuencias que pasan a través de un dispositivo, como un filtro. Las frecuencias que no se encuentran dentro del paso de banda se limitan o se atenúan. Véase también Frecuencia de corte.

PC (Personal Computer) Ordenador personal

PDF (Portable Document Format) Formato de documento portátil (utilizado en World Wide Web)

Pérdida de retorno La cantidad de dB por debajo de la señal incidente en que se encuentra la señal reflejada. Si se refleja una señal cero, la impedancia del dispositivo es igual a la impedancia característica del sistema de transmisión, y la pérdida de retorno es infinito. Si se refleja toda la señal incidente, la pérdida de retorno es cero. Véase también Parámetros S, Coeficiente de reflexión y SWR.

Pérdida de retorno estructural Pérdida de retorno deficiente en el cable causada por un fallo periódico, como una deformación periódica causada por caídas de la bobina de cable o por el proceso de estiramiento del cable durante la fabricación.

Pérdida por inserción La diferencia entre la potencia medida antes y después de la inserción de un dispositivo. La atenuación entre la entrada y la salida de un dispositivo.

Pico positivo El valor máximo e instantáneo de una señal entrante.

Planeidad La respuesta de fase y de amplitud de un dispositivo sometido a prueba, una fuente de señales, un receptor o una combinación de todos ellos. Véase también Respuesta en frecuencia.

Planeidad de la amplitud de la fuente La planeidad de amplitud, en dB, de la potencia de la fuente en el margen de frecuencias especificado.

Plano de referencia La ubicación eléctrica en la que un analizador de redes presupone que terminan los conectores del sistema y los extremos de los accesorios de prueba, y comienza el dispositivo sometido a prueba. El plano de referencia se ajusta utilizando patrones de calibración con una longitud eléctrica conocida. Cuanto más cerca esté el plano de referencia del dispositivo sometido a prueba, mejor será la caracterización del dispositivo, debido a la eliminación de las incertidumbres del sistema de verificación.

Portadora por ráfagas Una portadora que se apaga y se enciende de forma periódica. Una portadora por ráfagas puede o no estar modulada.

PostScript (archivos .ps) Almacena archivos de gráficos de mapa de bits en un formato encapsulado para que se puedan utilizar directamente con impresoras PostScript.

Potencia, Entrada de seguridad La potencia de entrada, normalmente en dBm, permitida para que no se produzcan daños en el instrumento.

Potencia, Entrada máxima El límite superior de la potencia de entrada para el que se aplican las especificaciones. Algunas especificaciones pueden tener diferentes niveles de entradas máximas. Por ejemplo, el máximo de potencia de compresión normalmente es mayor que el máximo de distorsión armónica.

Preajuste Un estado de instrumento predefinido (que también realiza una autoverificación del analizador). La acción de pulsar la tecla Preset.

Precisión de la amplitud de la fuente La incertidumbre de amplitud, en dB, de la lectura de potencia de la fuente.

Precisión de la base de tiempos de la frecuencia de la fuente Una medida de la estabilidad de frecuencia del analizador medida en partes por millón (ppm o 1 parte en10E6). Por ejemplo, una estabilidad de ±5,0 ppm significa que un analizador medirá 1 MHz con una precisión de ±5 x 10-6 x 10E6 Hz = +5 Hz.

Precisión de la frecuencia La incertidumbre con la que se indica la frecuencia de una señal o componente espectral, ya sea en sentido absoluto o en relación con otra señal o componente espectral. Las precisiones de frecuencia relativa y absoluta se especifican de forma independiente.

Precisión de recorrido La incertidumbre de la separación de frecuencia indicada de dos señales cualesquiera en la pantalla.

Precisión dinámica de fase de visualización La incertidumbre de medida de fase, normalmente en grados, para medidas que se expresan en unidades de grados.

Precisión dinámica de visualización La incertidumbre de amplitud, normalmente en dB, en el margen dinámico de visualización.

Predeterminado (por defecto) Un conjunto conocido de condiciones que se utiliza cuando no existen condiciones definidas por el usuario.

Prefijo de serie El prefijo de cinco caracteres con el que empieza el número de serie de un instrumento; se utiliza para representar versiones de cambios de hardware o de firmware que hayan ocurrido.

Programación remota El control automático de un instrumento mediante un ordenador, normalmente a través de un enlace GP-IB, LAN o RS-232.

Promediado Una técnica de reducción del ruido que calcula cada punto de datos en función de barridos consecutivos y ponderados mediante un factor de promediado especificado por el usuario. Cada nuevo barrido se promedia en la traza hasta que el número total de barridos es igual al factor de promediado.

Protocolo Un conjunto de convenciones que especifican cómo se formateará y transmitirá la información en una red, y cómo se comunicarán los equipos de una red.

Puerto La conexión física de entrada o salida de un instrumento o dispositivo.

Puerto de verificación Véase Puerto.

Puntos de visualización El número total de puntos de medida tomados en una medida única. Los puntos pueden expresarse en unidades de frecuencia, potencia o tiempo. El número de puntos a menudo determina la velocidad de medida, la resolución y la apertura.

Q

Q o Factor Q La relación entre la energía almacenada y la energía perdida en un circuito resonante. Un factor Q alto indica una respuesta de resonancia aguda sobre la frecuencia.

R

r + jx Expresión de impedancia compleja, donde 'r' representa la parte resistiva y 'x' representa la parte reactiva.

RAM (Random Access Memory) Memoria de acceso aleatorio, o memoria de lectura-escritura: Un área de almacenamiento que permite acceder a cualquiera de sus ubicaciones de almacenamiento. Los datos se pueden escribir en la memoria RAM o recuperarse de la misma, pero el almacenamiento es sólo temporal. Cuando se apaga el dispositivo, la información desaparece. La información que genera el usuario y que aparece en la pantalla son datos de la memoria RAM.

RDSI Red digital de servicios integrados: Una capacidad de servicio digital estándar que incorpora uno o más canales de comunicación con conmutación de circuitos que pueden transportar señales digitales de voz, datos o imágenes, un canal de conmutación de paquetes para control y señalización fuera de banda. Además, la tecnología RDSI ofrece un conjunto de estándares y funciones opcionales para que el usuario pueda sacar más provecho a la información, ya que ofrece un acceso a Internet más rápido que los sistemas analógicos.

Receptor Un circuito o sistema destinado a la recepción y/o medida de señales en un espectro de frecuencias especificado.

Recorrido La frecuencia de parada menos la frecuencia de inicio. La configuración del recorrido determina la escala del eje horizontal de la pantalla del analizador.

Recorrido de frecuencias La magnitud del componente de frecuencia mostrado. El recorrido se representa en el eje horizontal de la pantalla. Normalmente el recorrido de frecuencias se expresa como el recorrido total a través de toda la pantalla. Algunos analizadores representan el recorrido de frecuencias (ancho de exploración) como un valor por división.

Referencia horizontal Véase Nivel de referencia.

Reflexión El fenómeno por el que una onda en movimiento alcanza una discontinuidad y vuelve al medio original.

Relación señal-ruido SNR: La relación entre la amplitud de la señal deseada y la amplitud de las señales de ruido, normalmente expresada en dB y en términos de valores de pico para el ruido de impulso y de valores de media cuadrática para el ruido aleatorio.

Remoto Un modo de funcionamiento en el que otro dispositivo (u ordenador) controla un instrumento a través de GP-IB. En este modo, las teclas del panel frontal del instrumento están desactivadas. El control desde el panel frontal se denomina funcionamiento local.

Resolución La capacidad de un receptor para resolver dos señales.

Resolución de frecuencia La capacidad de un analizador de redes para medir características de un dispositivo a frecuencias muy próximas y mostrarlas por separado. El ancho de banda de IF determina la resolución de respuestas de la misma amplitud. El ancho de banda de IF y la selectividad de ancho de banda determinan la resolución de respuestas de diferente amplitud.

Resolución de frecuencia de la fuente La unidad más pequeña de frecuencia que se puede establecer y/o medir, en Hz.

Resolución horizontal Capacidad del analizador para tomar puntos de datos horizontales muy próximos en el barrido completo.

Resolución vertical El grado en el que un instrumento puede diferenciar la amplitud entre dos señales.

Respuesta en frecuencia La variación entre picos de la respuesta de amplitud mostrada en un margen de frecuencias central específico. La respuesta en frecuencia normalmente se especifica en términos de dB, en relación con el valor que se encuentra a medio camino entre los extremos.

Retardo Véase Retardo de grupo.

Retardo de grupo Una medida del tiempo de tránsito de una señal a través de un dispositivo sometido a prueba, frente a la frecuencia. El retardo de grupo se puede calcular mediante la diferenciación de la respuesta de fase de inserción del dispositivo sometido a prueba con respecto a la frecuencia. Véase también Retardo de grupo de AM y Desviación respecto de fase lineal.

Retardo de grupo de AM Una técnica para medir el retardo de grupo a través de un dispositivo que utiliza una fuente con modulación de amplitud (AM). Nota: El retardo real de la envolvente de modulación se mide directamente con un detector escalar externo. No se pueden medir los dispositivos que distorsionan la amplitud de una señal. Entre éstos se incluyen los amplificadores con control automático de ganancia (AGC) y los dispositivos sometidos a saturación o limitación de potencia.

Retardo eléctrico Una longitud variable simulada de línea de transmisión sin pérdida, añadida o restada a/de la entrada de un receptor, para compensar los cables de interconexión. El equivalente de firmware de los "alargadores de líneas" analógicos o mecánicos de otros analizadores de redes.

RF (Radio Frequency) Radiofrecuencia (desde aproximadamente 50 kHz hasta aproximadamente 3 GHz). Normalmente se refiere a cuando una señal se transmite a través del aire.

ROM (Read Only Memory) Memoria de sólo lectura

ROM (Read Only Memory) Memoria de sólo lectura: Un área de almacenamiento que sólo se puede leer; el usuario no puede escribir en ella ni alterarla. En los instrumentos, el área de almacenamiento que contiene el "cerebro" o la programación de operaciones; el firmware.

Ruido Variaciones aleatorias de energía no deseada o perturbadora en un sistema de comunicaciones causadas por fuentes naturales o creadas por el hombre, que distorsionan o afectan a la información transportada por la señal. Véase también Relación señal-ruido.

Ruido de traza de visualización, Magnitud La incertidumbre de amplitud de la traza, en dB, debido al ruido aleatorio en el sistema de pruebas.

Ruido de traza de visualización, Fase La incertidumbre de fase de la traza, en grados, debido al ruido aleatorio en el sistema de pruebas.

Ruta de cable pasivo de longitud cero En una calibración de medida, cuando los dos cables de verificación se acoplan directamente sin utilizar adaptadores ni cables pasivos. Véase también Dispositivos no insertables.

Ruta de E/S Ruta de entrada/salida

S

S/R Relación señal-ruido

Salto de muestreador La fuga o diafonía entre los muestreadores de un analizador de redes. El retardo de esta diafonía causado por la propagación de la transmisión de la fuga es lo que aporta a la interferencia el aspecto de "salto". El salto del muestreador produce un aumento del nivel de ruido del canal afectado, lo que reduce la sensibilidad del analizador.

Saturación El grado de pureza de color, en una escala de blanco hasta color puro.

SCPI (Standard Commands for Programmable Instruments) Comandos estándar para instrumentos programables

Seguimiento Capacidad del receptor del analizador para ajustarse a la frecuencia de la fuente en el margen de frecuencias de medida. Si se realiza un seguimiento deficiente, se producen errores de fase y amplitud, debido a que los circuitos de IF del receptor atenúan y retardan la salida del dispositivo sometido a prueba.

Selectividad de ancho de banda Una medida de la capacidad de un filtro para resolver señales de distinta amplitud. Es la relación entre el ancho de banda de 60 dB y el ancho de banda de 3 dB para un filtro de resolución dado (IF). La selectividad del ancho de banda indica lo pronunciadas que son las faldas del filtro. La selectividad del ancho de banda se denomina a veces factor de forma.

Sensibilidad La señal de entrada mínima que se necesita para producir una señal de salida especificada que tenga una relación señal-ruido especificada, u otros criterios específicos.

En un analizador de espectros, el nivel de la curva sinusoidal más pequeña que se puede observar, normalmente en condiciones optimizadas de ancho de banda de resolución mínimo, 0 dB de atenuación de entrada y ancho de banda de vídeo mínimo.

El cambio normalizado de la frecuencia central del componente de YIG resultante de un cambio de la corriente de la bobina de sintonía, especificado en MHz/mA.

Señal de disparo externo Una señal TTL que se introduce en un analizador e inicia un barrido de medida o un evento similar, sincronizando las medidas con la fuente de disparo externa.

Servidor Un dispositivo que se configura para prestar un servicio a otros dispositivos en una red, como acceso compartido a un sistema de archivos o a una impresora.

Sinc Sincronización o sincronizado

Sintaxis Las normas gramaticales que especifican cómo se deben estructurar los comandos en un sistema operativo, lenguaje de programación o aplicación.

Sistema de calibración automática AutoCal: Función disponible en los analizadores de redes Rohde&Schwarz.

SOLT (Short-Open-Load-Through) Calibración de Circuito abierto, Circuito cerrado, Carga, Cable pasivo Véase también Calibración, SOLT.

SWR Relación de onda estacionaria, calculada como (1 + p) / (1 - p), donde p es el coeficiente de reflexión.

T

Tabla de líneas límite Los segmentos de línea de una línea límite se almacenan en la tabla de líneas límite. La tabla se puede recuperar para editar los segmentos de línea, y después restaurarse en el archivo de líneas límite.

Tarjeta de memoria Un pequeño dispositivo de memoria con forma de tarjeta de crédito que puede almacenar datos o programas.

Tecla del panel frontal Las teclas que se encuentran en el panel frontal de un instrumento. Las etiquetas de las teclas identifican la función de las teclas. Las teclas numéricas y las teclas de pasos son dos ejemplos de teclas del panel frontal.

Tecla no programable Una tecla del panel frontal que activa una única función del analizador o presenta un único menú de teclas programables.

Terminación Una carga conectada a una línea de transmisión o a otro dispositivo.

Tipo de barrido El método de barrido de la fuente, por ejemplo, lineal, logarítmico o paso de frecuencia.

Tipo de pantalla El tipo de pantalla integrada en el analizador. Los datos pueden visualizarse como un dibujo de barrido (un mapa de puntos similar al generado por un ordenador) o un dibujo de vectores (líneas trazadas en la pantalla). El estándar de visualización y de color también se puede especificar como monocromo (un único color) o de color (dos o más colores). El estándar de formato también se puede especificar como VGA o SVGA, para ordenadores compatibles con IBM.

TOM (Thru-Open-Match) Cable pasivo-Circuito abierto-Acoplamiento: Un término de Rohde&Schwarz que describe un método de calibración.

Tono La dimensión del color referida a una escala de percepciones que va del rojo al amarillo, al verde y al azul, y de nuevo al rojo. Una gradación particular de color, matiz, tonalidad.

Transmisión Véase Medidas de transmisión.

Transmisión/Reflexión (T/R) Se refiere al conjunto de medidas realizadas por un analizador de redes vectorial o escalar para caracterizar el comportamiento de un dispositivo sobre la frecuencia. Véase también Parámetros S.

Transparente Algo invisible al usuario. Normalmente se trata de un procedimiento que ocurre sin que el usuario lo inicie ni tenga conocimiento del mismo.

T/R Véase Transmisión/Reflexión.

Traza Una serie de puntos de datos que contienen información de respuesta y de frecuencia. La serie de puntos de datos se denomina a menudo matriz. El número de trazas es específico del instrumento.

Traza activa Una traza que se barre (actualiza) con información de la señal entrante.

TRL (Through-Reflect-Line) Línea reflectora de cable pasivo. Véase Calibración, TRL y LRM.

TTL (Transistor-Transistor Logic) Lógica de transistor a transistor

U

UNI (User-Network Interface) Interfaz usuario-red: El punto en el que los usuarios se conectan a la red.

Unidades Dimensiones de las cantidades medidas. Las unidades normalmente se refieren a cantidades de amplitud porque se pueden cambiar. En los analizadores con microprocesadores, las unidades disponibles son dBm (dB en relación con 1 mW disipado en la impedancia de entrada nominal), dBmV (dB en relación con 1 mV), dBW (dB en relación con 1 W), V (voltios), W (vatios)./tr>

V

Variable Un símbolo cuyo valor cambia de una iteración de un programa a la siguiente, o en cada iteración de un programa.

Vector Una cantidad que tiene tanto magnitud como fase.

Un analizador de redes es capaz de medir tanto la magnitud como la fase.

VEE (Visual Engineering Environment) Entorno de ingeniería visual (producto de software de Agilent)

Vídeo Una señal eléctrica que contiene información de sincronización, intensidad y a veces color que, cuando se muestra, ofrece una imagen visual.

Visualización/visualizar Acción: Véase Pantalla.

Verbo: Mostrar la anotación y los datos de medida en la pantalla.

Visualización log Modo de visualización en el que la desviación vertical es una función logarítmica de la amplitud de la señal de entrada. Esta visualización también se denomina visualización logarítmica. La calibración de la visualización se establece mediante la selección del valor de la posición del nivel de referencia y el factor de escala en dB por división.

VNA (Vector Network Analyzer) Analizador de redes vectorial

W

WWW World Wide Web

X

Y

Z


Index

Índice principal

Índice COM

Índice SCPI


Contents

Contenido

Glosario


Home

(Rev. 20001220)

¡Bienvenido a la página principal !

Ayuda del analizador de redes Serie PNA

¡Haga una sugerencia y GANE!


Sugerencias

Nos gustaría conocer sus impresiones acerca del uso del sistema de ayuda. Si desea que introduzcamos su nombre en un sorteo mensual para así poder optar a un premio, incluya su dirección de correo electrónico. (Esta oferta finaliza el 1 de mayo del 2001.) Envíe sus comentarios a: pna_help@am.exch.agilent.com

Comente cualquier aspecto del sistema de ayuda. A continuación se citan algunos de los temas que podría tener en cuenta:

  • ¿Parece que hay algo estropeado?

  • ¿Encontró lo que estaba buscando?

  • ¿Le resultó útil la información que encontró?

  • ¿Tiene alguna sugerencia sobre cómo podemos mejorar el sistema de ayuda?

Sus comentarios irán directamente a los autores del sistema de ayuda. Para obtener ayuda referente a cuestiones técnicas, consulte la Asistencia técnica.


3.8_GHz_Adjustment

Ajuste de frecuencia de 3,8 GHz

Esta rutina ajusta el oscilador YIG interno de frecuencia fija a 3,8 GHz cambiando un valor del DAC. Este valor del DAC se almacena en la memoria no volátil del analizador.

Normalmente, el oscilador se puede ajustar a un margen de 12 kHz de 3,8 GHz; no es necesario que sea exactamente 3,8 GHz.

Compatibilidad de analizadores de espectros

Esta rutina es compatible con los analizadores de espectros Agilent 856x y 859x.

Si no se dispone de analizadores compatibles, seleccionar "NONE" para el analizador de espectros. El DAC se puede ajustar manualmente visualizando la señal de 3,8 GHz en otro analizador.

Procedimiento (sólo para analizadores de espectros compatibles)

Nota: El nivel visualizable de la señal de 3,8 GHz será bajo, normalmente de alrededor de -70 dBm. No utilizar ningún atenuador en el ajuste que no sea la atenuación de 10 dB predeterminada que se utiliza en la mayoría de los analizadores de espectros.

  1. Conectar la entrada del analizador de espectros a la salida del PUERTO 1 del analizador de redes.

  2. Conectar el cable GPIB del analizador al contador. Asegurarse de que no haya otros controladores activos en la misma conexión.

  1. Establecer la dirección GPIB del analizador de espectros en 18.

  2. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en 3.8 GHz Freq. Adjust.

  3. Hacer clic en Begin Adj. para que el programa ajuste el oscilador interno de manera que se produzca el mínimo de errores y almacene los resultados. Cuando el área de estado indique que el ajuste ha finalizado, seleccionar Exit.

Procedimiento (sólo para analizadores de espectros no compatibles)

Nota: El nivel visualizable de la señal de 3,8 GHz será bajo, normalmente de alrededor de -70 dBm. No utilizar ningún atenuador en el ajuste que no sea la atenuación de 10 dB predeterminada que se utiliza en la mayoría de los analizadores de espectros.

  1. Conectar la entrada del analizador de espectros a la salida del PUERTO 1 del analizador de redes.

  2. Establecer la configuración del analizador de espectros del siguiente modo:

    • Frecuencia central = 3,8 GHz

    • Recorrido = 100 MHz

    • Ancho de banda = 10 kHz

    • Ajustar la escala donde haya una señal de -70 dBm claramente visible

  3. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en 3.8 GHz Freq. Adjust.

  4. En Spectrum Analyzer, seleccionar la opción NONE para el analizador de espectros.

  5. Hacer clic en Begin Adj.

  6. La aplicación preajusta el DAC a un valor inicial igual al valor actual guardado. Ver el analizador de espectros para comprobar si la señal se encuentra por encima o por debajo de 3,800 GHz.

    • Si la frecuencia de la señal supera 3,8 GHz, desplazar la guía deslizante para ajustar el DAC a un valor más bajo (izquierda).

    • Si la frecuencia de la señal es inferior a 3,8 GHz, desplazar la guía deslizante para ajustar el DAC a un valor más alto (derecha).

Nota: Los valores de DAC válidos se encuentran comprendidos entre 0 y 4095. El oscilador cambiará alrededor de 23 kHz por cada valor del DAC.

  7. Ajustar el valor del DAC hasta alcanzar una frecuencia muy próxima a 3,8 GHz. Si se realizan grandes cambios en los valores del DAC, dejar varios segundos para que se estabilicen los efectos térmicos.

  8. Cambiar la configuración del analizador de espectros para visualizar mejor la señal de frecuencia:

    • Recorrido de frecuencias = 500 kHz

    • Ancho de banda = 3 kHz

  9. Cambiar el valor del DAC para mantener la señal centrada en 3,8 GHz.

  10. Una vez que se haya determinado el valor correcto del DAC, hacer clic en SAVE DAC para guardar permanentemente el valor en la memoria EEPROM. Hacer clic en Exit.

Nota: Si se realizan grandes cambios en el valor existente del DAC, se deberá repetir esta prueba de nuevo transcurridos de 15 a 30 minutos. De este modo se estabilizarán completamente los efectos térmicos.


10_MHz_Adjustment

Ajuste de la referencia de frecuencia a 10 MHz

Esta rutina ajusta la base de tiempos interna a exactamente 10 MHz cambiando un valor del DAC. Este valor del DAC se almacena en la memoria no volátil del analizador. Sólo debe recurrirse a esta rutina en las siguientes situaciones:

  • Cuando se sustituye la unidad de referencia de frecuencia.

  • Cuando la referencia de 10 MHz ha cambiado de manera significativa con respecto al valor ajustado en fábrica.

ADVERTENCIA: El margen de este ajuste es sólo de alrededor de 20 Hz. Se recomienda utilizar un patrón muy preciso para medir esta señal de 10 MHz, por ejemplo, un patrón de referencia propio u otra fuente cuya temperatura se haya estabilizado.

Compatibilidad del contador de frecuencia

Esta rutina es compatible con los contadores de frecuencia basados en SCPI, como el Agilent 53181A. También debería funcionar con las series 5350 más antiguas de contadores.

Si no se dispone de contadores compatibles, seleccionar el modo de operación "Manual". Si se elige el modo manual, se puede introducir manualmente la frecuencia medida.

Procedimiento (sólo para contadores GPIB compatibles)

  1. Conectar la entrada del contador a la salida de referencia de 10 MHz del panel posterior.

  2. Conectar un cable GPIB desde el analizador al contador. Asegurarse de que no haya otros controladores activos en la misma conexión.

  3. Si fuera pertinente, conectar el patrón de frecuencia propio a la entrada de referencia del contador.

  4. Establecer la dirección GPIB del contador en 03. Esta rutina presupone que cualquier dispositivo que corresponda a una petición GPIB en la dirección especificada es un contador de frecuencia. Asegurarse de que el único dispositivo en esta dirección sea un contador.

  5. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en 10 MHz Freq. Adjust.

  6. Hacer clic en Begin Adj. La aplicación ajusta la referencia interna para reducir al mínimo los errores y almacena los resultados.

    • Hacer clic en Read Freq para activar otra lectura de la señal de 10 MHz.

    • Hacer clic en Read DAC para acceder al valor actual del DAC almacenado en la memoria no volátil del analizador (valor = 0 - 4095).

  7. Cuando el área de estado indique que el ajuste ha finalizado, hacer clic en Exit.

Procedimiento (sólo para contadores GPIB no compatibles)

  1. Conectar la entrada del contador a la salida de referencia de 10 MHz del panel posterior.

  2. Ajustar el contador a una resolución de al menos 1 Hz.

  3. Si fuera pertinente, conectar el patrón de frecuencia propio a la entrada de referencia del contador.

  4. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en 10 MHz Freq. Adjust.

  5. En Frequency Counter, seleccionar Manual

  6. Hacer clic en Begin Adj.

  7. La aplicación preajusta el DAC a un valor inicial. Establecer el desplazamiento de frecuencia medida a partir de 10 MHz. Si la frecuencia medida es inferior a 10 MHz, utilizar un signo menos (-) para indicar un error negativo.

Por ejemplo:

  • Si el contador lee 10000003,5 Hz, indicar 3,5 (o +3,5) en la ventana indicada.

  • Si el contador lee 9999997,8 Hz, indicar -2,2 en la ventana indicada.

  6. El ajuste cambia al menos tres veces a menos que el valor introducido sea exactamente cero.

    • Hacer clic en Read Freq para activar otra lectura de la señal de 10 MHz.

    • Hacer clic en Read DAC para acceder al valor actual del DAC almacenado en la memoria no volátil del analizador (valor = 0 - 4095).

  7. Cuando el área de estado indique que el ajuste ha finalizado, hacer clic en Exit.

Nota: Si el contador hace una lectura errónea de la frecuencia, tal vez sea necesario atenuar la entrada, o ajustar la impedancia de entrada a 50 ohmios, o ambas cosas.


Advanced Marker Setup

Configuración avanzada de los marcadores

Véase asimismo...

Define los aspectos de los datos del marcador.

Marker. Especifica el marcador que se está definiendo.

ON. Cuando se selecciona, aparece el marcador en la pantalla y muestra los datos de la posición del marcador.

Format. Muestra los datos del marcador en el formato que se elija. El formato del marcador puede ser diferente al de la cuadrícula. En la configuración por defecto, los formatos de la cuadrícula y del marcador son los mismos.

Discrete Marker. Alterna el marcador entre el modo de visualización de valores sólo en los puntos discretos donde se obtienen los datos, y el modo de visualización de valores que se interpolan a partir de los puntos de datos.

Tipo de marcador

Normal. El marcador aparece a lo largo de la traza de la medida, en el valor de estímulo que se elija.

Fixed. El marcador aparece en la posición del eje X y del eje Y que se elija.


AgileUpdate

Véase asimismo...

Con esta utilidad de actualización se pueden transferir fácilmente nuevas revisiones del firmware, archivos de ayuda, aplicaciones y otros archivos relacionados con el analizador de la serie PNA.

Actualización de los archivos del analizador (procedimiento básico)

Nota: Para ejecutar esta utilidad es necesario poseer privilegios administrativos en el analizador.

En la mayoría de los casos, se podrán realizar los siguientes pasos para transferir e instalar la versión más reciente de los archivos del analizador de la serie PNA. Para obtener una versión más detallada del proceso, consultar el procedimiento que aparece más adelante.

  1. En el menú System, hacer clic en Service, AgileUpdate.

  2. Hacer clic en Check for Updates.

  3. Hacer clic en Download & Install.

Actualización de los archivos del analizador (procedimiento detallado)

Configuración del equipo

Nota: Para ejecutar esta utilidad es necesario poseer privilegios administrativos en el analizador.

  1. Conectar el analizador a Internet. Se recomienda una conexión de red local (LAN) porque la transferencia del firmware con un módem puede tardar hasta dos horas.

  2. Seleccionar el nombre del proxy y el puerto:

    • Si se utiliza una conexión de LAN, el programa utilizará el proxy que especifica Windows (el predeterminado en Internet Explorer).

    • Si es necesario utilizar un proxy o un puerto de proxy que no sea el predeterminado, hacer clic en el menú Configure y escribir el nombre de proxy y el puerto. El formato es el siguiente: nombre_de_proxy:número_de_puerto. (Normalmente el número de puerto proxy es 8088.) Hacer clic en OK.

  3. Seleccionar el tiempo de espera de Internet:

    • Si es suficiente con un tiempo de espera de 30 segundos para realizar una conexión con Internet, dejar el valor predeterminado.

    • Si se está utilizando una conexión con Internet mediante acceso telefónico automático, puede que sea necesario aumentar el tiempo de espera. Hacer clic en el menú Configure e introducir el valor del tiempo de espera. Hacer clic en OK.

Búsqueda y transferencia de nuevos archivos

  4. Seleccionar la fuente que se va a utilizar para obtener los archivos de actualización.

    • Si no se han transferido los archivos, seleccionar Default Website.

    • Si ya se han transferido al disco duro del analizador, seleccionar Install from File.

    • Si Agilent ha indicado que se utilice un sitio web que no sea el que aparece por defecto, seleccionar Other specified URL.

  5. Si Agilent ha facilitado un código de acceso, escribir dicho código en el cuadro del código de acceso.

  6. Hacer clic en Check for Updates. Si existen versiones más recientes de los archivos, aparecerán en una lista con las casillas de verificación seleccionadas. Si no se desea actualizar ninguno de los archivos que aparecen en la lista, hacer clic en la casilla de verificación para eliminar la selección.

Nota: Puesto que el firmware incluye el archivo de ayuda, sólo aparecerá seleccionada la casilla de verificación del firmware si hay disponible una nueva versión del firmware y del archivo de ayuda.

  7. Comprobar la información disponible:

    1. Hacer clic en la selección de menú Firmware History y comprobar la descripción de las versiones anteriores del firmware. Puede que existan cambios importantes para las aplicaciones de medida.

    2. Hacer clic en la selección de menú ReadMe si está disponible, y ver la información que pueda incluir datos referentes a los procedimientos de actualización, problemas conocidos y soluciones.

  8. Seleccionar la actividad de transferencia:

    • Hacer clic en Download & Install si se desea que los archivos actualicen de forma automática los archivos existentes en el analizador.

    • Hacer clic en Download Only si se desea transferir los archivos al disco duro del analizador e instalarlos más adelante.

Nota: El programa transfiere los archivos a una ubicación designada del disco duro del analizador. Si se ejecuta esta utilidad de actualización en repetidas ocasiones, es posible que en el disco duro del analizador se acumule un gran número de archivos. Para eliminar del disco del analizador todos los archivos excepto las dos versiones más recientes, hacer clic en el menú Clean-Up.


Avg

Promedio

Véase asimismo...

Average ON. Cuando está seleccionado, se aplica un promediado ponderado de barridos de medida sucesivos para eliminar los efectos del ruido aleatorio.

Average Factor. Especifica el número de barridos que se promedian. Margen de 1 a 1.024.

Restart. Comienza un nuevo conjunto de medidas que se utilizan para el promedio. Este conjunto de medidas es igual al factor de promediado.


Calibration Wizard

Véase asimismo...

Guía al usuario a través del proceso de calibración de medidas.

Cal Type. Presenta una lista de tipos de calibración en la que se puede seleccionar el tipo de calibración que se desea realizar.

Modify. Presenta un cuadro de diálogo en el que se puede modificar la configuración de la frecuencia antes de llevar a cabo una calibración.

Measure ECal Stds. Presenta la parte del asistente que guía al usuario a través de un proceso de calibración, que utiliza un módulo de calibración electrónica ECal para el patrón de calibración.

Measure Stds. Presenta la parte del asistente que guía al usuario a través de un proceso de calibración, que utiliza patrones de calibración mecánicos.

Have 2 sets of standards. Permite medir simultáneamente dos conjuntos de patrones (por ejemplo, dos circuitos abiertos) en los Puertos 1 y 2 cuando se realiza una calibración de 2 puertos.


Frecuencias centrales y de recorrido

Central y recorrido: Frecuencia

Véase asimismo...

Center. Especifica el valor en el centro del barrido de frecuencia. Este valor puede encontrarse en cualquier lugar del rango del analizador.

Span. Especifica el recorrido de los valores de frecuencia medidos a cada lado de la frecuencia central.


Frecuencia de CW (de onda continua)

Véase asimismo...

Permite ajustar la fuente a una única frecuencia para los tipos de barrido de tiempo de CW y de barrido de potencia. La frecuencia puede ser cualquier valor comprendido en el rango del analizador.


Retardo eléctrico

Véase asimismo...

Electrical Delay. Especifica el valor del retardo añadido o eliminado, en unidades de tiempo. Esto compensa el desplazamiento de fase lineal a través de un dispositivo. Se puede ajustar el retardo eléctrico independientemente para cada traza de medida.

Velocity Factor. Especifica la velocidad relativa del medio del dispositivo insertado. El valor para un cable dieléctrico de polietileno es 0,66, y 0,7 para uno dieléctrico de teflón.


Ext_Trig

Activador externo

Véase asimismo...

Positive. Ajusta el analizador para que se active cuando la señal TTL del panel posterior cambia de 0 (Bajo) a 1 (Alto).

Negative. Ajusta el analizador para que se active cuando la señal TTL del panel posterior cambia de 1 (Alto) a 0 (Bajo).


Formato

Véase asimismo...

Log Magnitude. Muestra medidas, sólo de magnitud, de pérdida por inserción, ganancia, pérdida de retorno o potencia absoluta en dB frente a la frecuencia.

Phase. Muestra el desplazamiento de fase en contraposición a la frecuencia, medido en grados.

Group Delay. Muestra el tiempo de transmisión de la señal a través de un dispositivo de verificación. Se muestra como un cambio de fase a través de una apertura de frecuencia específica.

Smith Chart. Muestra los datos en términos de impedancia. Las líneas de puntos que se entrecruzan en el diagrama de Smith representan valores de resistencia constante y de reactancia constante, normalizados a la impedancia característica (Z0) del sistema. Los valores de reactancia que aparecen en la mitad superior del diagrama de Smith indican una reactancia positiva (inductiva) y los de la mitad inferior representan una reactancia negativa (capacitiva).

Polar. Muestra cada punto de manera que se corresponda con un valor concreto de magnitud y de fase. Las cantidades se leen vectorialmente: la magnitud en cualquier punto se determina por su desplazamiento desde el centro (que tiene un valor cero), y la fase por el ángulo en sentido contrario a las agujas del reloj desde el eje X positivo. La escala de la magnitud se ajusta de forma lineal, con el valor del círculo externo ajustado normalmente a un valor de relación de 1. Al no existir un eje de frecuencia, la información de la frecuencia se lee a partir de los marcadores. La lectura predeterminada del marcador para el formato polar tiene magnitud y fase lineales.

Linear Magnitude. Muestra una cuadrícula para las medidas sin unidades, como la magnitud del coeficiente de reflexión o la magnitud del coeficiente de transmisión, y para las unidades de medidas lineales. En este formato también se muestran los parámetros de conversión y los datos de la transformada en el dominio del tiempo.

SWR. Muestra una medida de reflexión reformateda en su valor equivalente de SWR (relación de onda estacionaria).

Real. Muestra sólo la parte verdadera (resistiva, magnitud) de los datos medidos, mostrando valores tanto positivos como negativos. Se utiliza principalmente para analizar respuestas en el dominio del tiempo.

Imaginary. Muestra sólo la parte imaginaria (reactiva, fase) de los datos medidos.


Ancho de banda de IF

Véase asimismo...

Especifica el ancho de banda de IF (receptor) entre 10 Hz y 40 kHz. Si el ancho de banda de IF es estrecho, disminuye el límite inferior del ruido, pero aumenta el tiempo de medida. Con anchos de banda de IF mayores, se consiguen velocidades de barrido más rápidas. El valor predeterminado es de 35 kHz.


Prueba de límites

Véase asimismo...

Compara los datos de medida con los valores (límites) que se han definido. Dependiendo de los resultados de esta comparación, el analizador puede indicar si el dispositivo supera o no la prueba.

Limit Test ON. Cuando se selecciona, el analizador compara los datos de medida con los límites que se han establecido.

Limit Test ON. Cuando se selecciona, los límites aparecen en la pantalla.

Sound ON Fail. Cuando se selecciona, el analizador emite un sonido si los resultados de la medida no se encuentran dentro de los límites establecidos.

Show Table. Muestra la tabla con la que se pueden crear y editar límites.

Hide Table. Hace que desaparezca de la pantalla la tabla con los límites.


LO_Power_Adjustment

Ajuste de potencia del LO

Esta rutina ajusta a un nivel específico la potencia de entrada del oscilador local del receptor cambiando los valores del DAC. Estos valores del DAC se almacenan en la memoria no volátil del analizador.

El margen de este ajuste es de aproximadamente ±3 dB. Los niveles de potencia objetivo se encuentran a pocos dB de 0dBm, dependiendo de la banda.

  • Las bandas 1, 2 y 3 están ajustadas

  • La banda 4 utiliza el valor de la banda 2

  • Las bandas 5 y 6 utilizan el valor de la banda 3

  • Las bandas 0 y 7 se ajustan a un valor fijo del DAC

Compatibilidad de medidores de potencia

Esta rutina SóLO es compatible con los medidores de potencia Agilent de la serie EPM. Estos medidores de potencia también DEBERáN utilizar los sensores de la serie "E" (conectados al Canal A si fuera pertinente). Estos sensores cuentan con datos de calibración integrados, por lo que no es necesario introducir factores de calibración. La selección de "None" en "Power Meter" no tiene ninguna función en este momento.

Procedimiento

  1. Dejar que el analizador y el medidor de potencia se calienten durante 30 minutos.

  2. Calibrar y ajustar a cero manualmente el sensor de potencia.

  3. Conectar un cable GPIB desde el analizador al medidor de potencia. Asegurarse de que no haya otros controladores activos en la misma conexión.

  4. Establecer la dirección GPIB del medidor de potencia en 13.

  5. Retirar la cubierta exterior del analizador.

  6. Desconectar el cable semirrígido de A17J70 para conectar el sensor de potencia a la salida LO de la unidad de distribución del oscilador local (A17J70), utilizando adaptadores si fuera necesario. Si es necesario utilizar un cable, utilizar a ser posible uno de menos de 25 cm de longitud.

  7. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en LO Power Adjust.

  8. Hacer clic en Begin Adj para que la aplicación mida la potencia del oscilador local a diferentes frecuencias para las bandas 1, 2 y 3. A continuación, la rutina ajusta el nivel de potencia de cada banda para que se encuentre dentro de ciertos límites. Si se realiza cualquier cambio, se guarda automáticamente.

    • Hacer clic en Read DAC para acceder a los valores actuales del DAC (0-4095) almacenados en la memoria no volátil del analizador para cada banda (0 - 7).

  9. Cuando el área de estado indique que el ajuste ha finalizado, hacer clic en Exit.

  10. Volver a conectar el cable semirrígido a A17J70.


Macro

Véase asimismo...

Permite crear un conjunto de 12 accesos directos, de forma que se puedan iniciar otros programas desde la aplicación del analizador.

Macro Title. Muestra los títulos que aparecen en la barra de herramientas Active Entry cuando se pulsa la tecla Macro. Estos títulos están asociados a los archivos ejecutables y deben ser descriptivos para que se puedan identificar fácilmente. Por ejemplo, si se desea iniciar la página principal de Agilent, el ejecutable se podría titular "página de inicio de Agilent".

Macro Executable. Ofrece una lista de la ruta completa de acceso al archivo ejecutable. Para seguir con el ejemplo del inicio de la página principal de la serie PNA de Agilent, la ruta del ejecutable podría ser "C:\Archivos de programa\Internet Explorer\iexplore.exe.

Macro Runstring Parameters. Ofrece una lista de los parámetros que se pasan al programa al que se hace referencia en el archivo ejecutable. Continuando con el ejemplo del inicio de la página principal de la serie PNA, se podrían asignar los parámetros de cadena de ejecución "http://www.agilent.com/find/pna".

Edit. Presenta el cuadro de diálogo Macros Edit, en el que se pueden modificar el título y los parámetros de la cadena de ejecución, y sustituir el archivo ejecutable por la macro que se ha seleccionado.

Delete. Elimina la macro seleccionada.

Up. Permite volver a ordenar las macros, moviendo la macro seleccionada una línea hacia arriba. Para las 12 macros posibles existen 12 líneas que indican el orden en el que aparecen en la barra de herramientas Active Entry al pulsar la tecla Macro. Puesto que existen cuatro títulos que se pueden mostrar al mismo tiempo en la barra de herramientas, cuando se pulsa repetidamente la tecla Macro, la barra de herramientas cambia los títulos de las macros por el siguiente conjunto de cuatro títulos de macros.

Down. Desplaza la selección una línea hacia abajo en la lista de macros.


Macro_Edit

Edición de macros

Véase asimismo...

Permite modificar el título y los parámetros de la cadena de ejecución, y sustituir el archivo ejecutable por la macro que se ha seleccionado en el cuadro de diálogo de Macro Setup.

Macro Title. Permite modificar el título que aparece en la barra de herramientas Active Entry.

Macro Executable. Permite modificar la ruta completa del archivo ejecutable de la macro.

Browse. Permite examinar unidades y directorios para localizar el archivo ejecutable de la macro y establecer la ruta de acceso completa del archivo.

Macro run string parameters. Permite modificar los parámetros que se pasan al programa al que se hace referencia en el archivo ejecutable.


Configuración de marcadores

Marcador

Véase asimismo...

Define un marcador que ofrece lecturas numéricas de los datos medidos.

Marker. Especifica el marcador que se está definiendo.

Stimulus. Especifica el valor del estímulo en el que se encuentra situado el marcador a lo largo del eje horizontal.

ON. Cuando se selecciona, aparece el marcador en la pantalla y muestra los datos de la posición del marcador.

Delta Marker. Cuando se selecciona, un marcador muestra datos en relación con los de otro marcador que ya se ha configurado.

Advanced... Presenta un cuadro de diálogo con el que se puede definir aún más los datos del marcador.

All Off. Desactiva todos los marcadores de la traza activa.


Funciones de marcador

Véase asimismo...

Define una configuración de estímulo, basada en el valor del marcador activo.

Marker->Start. Ajusta el barrido de inicio al valor del marcador activo.

Marker->Stop. Ajusta el barrido de parada al valor del marcador activo.

Marker->Center. Ajusta el centro del barrido al valor del marcador activo.

Marker->Ref Level. Ajusta el nivel de referencia de la pantalla al valor del marcador activo.

Marker->Delay. Ajusta el retardo eléctrico al valor del marcador activo.

Marker->Span. Ajusta el barrido de medida al recorrido definido por el marcador delta y el marcador al que hace referencia.


Búsqueda de marcador

Véase asimismo...

Define el comportamiento del marcador y el área de medida.

Marker. Especifica el marcador que se está definiendo.

Search Domain. Define el área en el que el marcador puede moverse o realizar búsquedas. En el recorrido completo, el marcador busca valores específicos dentro del recorrido de medida completo. En el recorrido del usuario, el marcador busca valores específicos dentro de un recorrido de medida definido.

Tipo de búsqueda

Maximum. El marcador localiza el valor del dato máximo (el más alto).

Minimum. El marcador localiza el valor del dato mínimo (el más bajo).

Next Peak. El marcador localiza el pico con el siguiente valor de amplitud más bajo.

Threshold. Amplitud mínima (dB) que se puede considerar válida.

Excursion. La distancia vertical (dB) entre el pico y los valles en ambos lados.

Peak Right. El marcador localiza el siguiente pico válido a la derecha del eje X.

Peak Left. El marcador localiza el siguiente pico válido a la izquierda del eje X.

Target. El marcador localiza el punto de datos que coincide con los criterios de búsqueda seleccionados.

Bandwidth. Los marcadores localizan el ancho de banda de un filtro.

Execute. Desplaza el marcador hasta la posición en la traza de medida que se ajusta a los criterios de búsqueda.

Tracking. Cuando se selecciona, el marcador busca los valores especificados con cada nuevo barrido.


Memoria matemática

Matemática/Memoria

Véase asimismo...

Data->Memory. Coloca la traza de datos activa en la memoria.

Matemáticas de datos

Data. No realiza ninguna operación matemática.

Data / Memory. Realiza una operación en la que los datos de medida actuales se dividen por los datos de la memoria.

Data * Memory. Realiza una operación en la que los datos de medida actuales se multiplican por los datos de la memoria.

Data - Memory. Realiza una operación en la que los datos de medida actuales se restan de los datos de la memoria.

Data + Memory. Realiza una operación en la que los datos de medida actuales se suman a los datos de la memoria.

Opciones de visualización de trazas

Data Trace. Muestra la traza de medida actual.

Memory Trace. Muestra la traza que se ha colocado en la memoria.

Data and Memory Trace. Muestra tanto los datos de medida actuales como la traza que se ha colocado en la memoria.


Medida

Véase asimismo...

Modifica la traza de medida activa.

Trace Type: S-Parameters. Especifica la dirección del flujo de señales para un dispositivo sometido a prueba. La convención es "S fuera dentro", es decir, el primer número (fuera) se refiere al puerto del dispositivo de verificación de donde sale la señal, y el segundo número (dentro) es el puerto del dispositivo de verificación donde la señal es incidente.

S11. Especifica la medida como la relación compleja entre la señal que sale del puerto 1 del dispositivo de verificación y la entrada de señales en el puerto 1 del dispositivo de verificación.

S21. Especifica la medida como la relación compleja entre la señal que sale del puerto 2 del dispositivo de verificación y la entrada de señales en el puerto 1 del dispositivo de verificación.

S12. Especifica la medida como la relación compleja entre la señal que sale del puerto 1 del dispositivo de verificación y la entrada de señales en el puerto 2 del dispositivo de verificación.

S22. Especifica la medida como la relación compleja entre la señal que sale del puerto 2 del dispositivo de verificación y la entrada de señales en el puerto 2 del dispositivo de verificación.


Medida de la relación arbitraria

Medida: Relación arbitraria

Véase asimismo...

Modifica la traza de medida activa.

Trace Type: Arbitrary Ratio. Definición de una medida de relación de potencia.

Source Port. Especifica el puerto de verificación del analizador que emite la potencia de la fuente del analizador.

Input. Especifica la entrada del puerto de verificación del analizador. Por este punto es por donde entra al analizador la respuesta del dispositivo sometido a prueba. Se puede acceder a los puertos de entrada retirando los cables del panel frontal.

Reference. Especifica el puerto de referencia del analizador. En este punto, una parte de la señal de la fuente del analizador se encamina a la entrada del canal R del receptor. A continuación, la señal se compara con la respuesta del dispositivo sometido a prueba. El nivel de referencia debe encontrarse entre 0 dBm y -35 dBm.


Medida de potencia no relacionada

Medida: Potencia no relacionada

Véase asimismo...

Modifica la traza de medida activa.

Trace Type: Unratioed Power. Definición de una única entrada para medidas de magnitud exclusivamente de la potencia absoluta. No se puede utilizar el promediado con entradas únicas ni realizar medidas de retardo de grupo o de fase.

Source Port. Especifica el puerto de verificación del analizador que emite la potencia de la fuente del analizador.

Input. Especifica la entrada del puerto de verificación del analizador. Por este punto es por donde entra al analizador la respuesta del dispositivo sometido a prueba. Se puede acceder a los puertos de entrada retirando los cables del panel frontal.


Modificar kit de calibración

Véase asimismo...

Permite cambiar las definiciones de los patrones de calibración que contiene un kit de calibración.

Kit de calibración

Cal Kit ID. Indica el kit de calibración que se desea modificar. Los kits 1 a 6 son definiciones de kits de calibración predefinidos. Los kits 7 a 10 son definiciones de kits de calibración definidos por el usuario.

Cal Kit Name. Indica el tipo de conector y el número de modelo o nombre del kit de calibración que se desea modificar.

Restore Default Kit. Vuelve a establecer los valores predefinidos del kit de calibración seleccionado actualmente.

Restore All Default Kits. Vuelve a establecer los valores predefinidos de todos los kits de calibración.

Asignar patrones a los puertos

Port 1, Port 2. Indica el tipo de conector del puerto.

S11A, S11B, S11C, S21T. Clases para la asignación de los patrones al Puerto 1: tres de reflexión y uno de transmisión.

S22A, S22B, S22C, S12T. Clases para la asignación de los patrones al Puerto 2: tres de reflexión y uno de transmisión.

Modificar la definición del patrón

Standard No. Indica a qué patrón de calibración se aplica la definición.

Min Freq., Max Freq. Indica el margen de frecuencias en el que funciona el patrón.

Z0. Indica la impedancia característica del sistema.

Delay. Indica una línea de transmisión de longitud uniforme entre el patrón que se está definiendo y el plano de medida real.

Loss. Indica una pérdida de energía, debida al efecto pelicular, a lo largo de un tramo unidireccional de cable coaxial.

Type. Indica qué tipo de patrón de calibración se está modificando.

Character. Indica si el patrón es coaxial o guía de ondas.

Label. Indica una descripción del patrón que se está modificando.

C0, C1, C2, C3. Indica la capacitancia marginal del patrón de calibración de circuito abierto.

L0, L1, L2, L3. Indica la inductancia residual del patrón de calibración de circuito cerrado.


Nueva traza

Véase asimismo...

Crea y define una traza de medida adicional.

Trace Type: S-Parameters. Especifica la dirección del flujo de señales para un dispositivo sometido a prueba. La convención es "S fuera dentro", es decir, el primer número (fuera) se refiere al puerto del dispositivo de verificación de donde sale la señal, y el segundo número (dentro) es el puerto del dispositivo de verificación por donde entra la señal.

S11. Especifica la medida como la relación compleja entre la señal que sale del puerto 1 del dispositivo de verificación y la entrada de señales en el puerto 1 del dispositivo de verificación.

S21. Especifica la medida como la relación compleja entre la señal que sale del puerto 2 del dispositivo de verificación y la entrada de señales en el puerto 1 del dispositivo de verificación.

S12. Especifica la medida como la relación compleja entre la señal que sale del puerto 1 del dispositivo de verificación y la entrada de señales en el puerto 2 del dispositivo de verificación.

S22. Especifica la medida como la relación compleja entre la señal que sale del puerto 2 del dispositivo de verificación y la entrada de señales en el puerto 2 del dispositivo de verificación.

Channel Number. Indica qué canal añade la nueva traza.

Create in New Window. Cuando se selecciona, se crea una nueva traza de medida del parámetro S en una ventana nueva. Cuando no está seleccionado, la traza se crea en la ventana activa.


Relación arbitraria de traza nueva

Nueva traza: Relación arbitraria

Véase asimismo...

Crea y define una traza de medida adicional.

Trace Type: Arbitrary Ratio. Definición de una medida de relación de potencia.

Source Port. Especifica el puerto de verificación del analizador que emite la potencia de la fuente del analizador.

Input. Especifica la entrada del puerto de verificación del analizador. Por este punto es por donde entra al analizador la respuesta del dispositivo sometido a prueba. Se puede acceder a los puertos de entrada retirando los cables del panel frontal.

Reference. Especifica el puerto de referencia del analizador. En este punto, una parte de la señal de la fuente del analizador se encamina a la entrada del canal R del receptor. A continuación, la señal se compara con la respuesta del dispositivo sometido a prueba. El nivel de referencia debe encontrarse entre 0 dBm y -35 dBm.

Channel Number. Indica qué canal añade la nueva traza.

Create in New Window. Cuando se selecciona, se crea una nueva traza de medida en una ventana nueva. Cuando no está seleccionado, la traza se crea en la ventana activa.


Nueva traza no relacionada

Nueva traza: Potencia no relacionada

Véase asimismo...

Crea y define una traza de medida adicional.

Trace Type: Unratioed Power. Definición de una única entrada para medidas de magnitud exclusivamente de la potencia absoluta. No se puede utilizar el promediado con entradas únicas ni realizar medidas de retardo de grupo o de fase.

Source Port. Especifica el puerto de verificación del analizador que emite la potencia de la fuente del analizador.

Input. Especifica la entrada del puerto de verificación del analizador. Por este punto es por donde entra al analizador la respuesta del dispositivo sometido a prueba. Se puede acceder a los puertos de entrada retirando los cables del panel frontal.

Channel Number. Indica el canal cuyos atributos se aplicarán a la nueva traza.

Create in New Window. Cuando se selecciona, se crea una nueva traza de medida del parámetro S en una ventana nueva. Cuando no está seleccionado, la traza se crea en la ventana activa.


Número de puntos

Véase asimismo...

Indica el número de puntos de datos que el analizador recopila durante un barrido de medida. Se puede especificar cualquier número comprendido entre 2 y 1.601. El valor por defecto es 201.


Circuito abierto

Recuperación

Véase asimismo...

Recupera un archivo en el analizador.

Look in. Permite seleccionar el directorio que contiene el archivo que se desea recuperar.

File name: Muestra el nombre de archivo que se ha escrito o en el que se ha hecho clic en el cuadro de contenido del directorio.

Files of type. Permite visualizar y seleccionar los archivos que aparecen enumerados en categorías de un tipo de archivo.

Recall. Recupera el archivo mostrado en el cuadro de nombres de archivos.


Comprobación del operario

Utilizar la opción Operator's Check para comprobar fallos obvios en las siguientes partes del hardware del analizador de redes:

  • El conmutador de RF del equipo de verificación

  • Los diversos márgenes de atenuación de los atenuadores de los puertos de verificación

Procedimiento de comprobación del operario

  1. En el menú System del analizador, señalar con el cursor Service, y hacer clic en Operator's Check. Aparecerá la ventana Operator's Check.

  2. En Sequencing, seleccionar Automatic o Prompted.

    • Automatic prepara el software para verificar la repetibilidad del conmutador y cada uno de los siete márgenes de atenuador con un intervalo de 0,25 segundos entre cada verificación.

    • Prompted prepara el software para que formule una pregunta antes de ejecutarse la verificación de cada margen de atenuador.

  3. Hacer clic en Start-Port 1. Cuando se indique, conectar un patrón de circuito cerrado de un kit de calibración para verificar el puerto 1.

  • El analizador de redes muestra una indicación de PASS (superada) o FAIL (fallida) al finalizar cada prueba.

  • Una vez realizadas las ocho pruebas, vuelve a aparecer la ventana Operator's Check, y muestra el resumen de los resultados para ese puerto. Si no se supera alguna de las pruebas, consultar el capítulo 3 de la Guía de Servicio.


Option_Enable

Utilidad Option Enable

Con la utilidad Option Enable se pueden realizar las siguientes actividades.

  • Añadir o eliminar opciones de software y algunas opciones de hardware.

  • Recuperar datos de opciones si se sustituye el disco duro u otra unidad que contenga datos.

  • Introducir o cambiar un número de serie.

Haga clic en los botones para mostrar la información.

Palabras clave

Ejecución del programa

Eliminación de una opción

Instalación de una opción

Reparación y recuperación de datos de opciones

Instalación o cambio del número de serie

Palabras clave

Para añadir ciertas opciones, es necesaria una palabra clave que facilita Agilent. Existen dos tipos de palabras clave:

  • Palabras clave de opciones para añadir una opción de software.

  • Palabras clave de modelos que pueden ser necesarias si se desea sustituir varios conjuntos.

Opciones permanentes y temporales

También se puede instalar cualquier opción de software de forma temporal durante un período de tiempo determinado. De este modo es posible evaluar una función o capacidad específica de forma gratuita.

Si la clave de licencia que facilita Agilent tiene una fecha de vencimiento, deberá seleccionarse la opción "temporal" e indicar la fecha de vencimiento exactamente tal y como se indica en la licencia. Si se desea que esta opción sea permanente, Agilent facilitará una nueva palabra clave que convertirá la opción en permanente.

Tanto para las opciones de software temporales como para las permanentes, es necesario introducir una palabra clave facilitada.

Ejecución del programa

  1. En el menú System del analizador, señalar con el cursor Service, y hacer clic en Option Enable.

  2. La primera pantalla mostrará el número del modelo, el número de serie y todas las opciones instaladas. Para añadir o eliminar una opción, seleccionarla en la lista desplegable de las opciones disponibles.

    • Si en la lista no aparece la opción deseada, seleccionar la última opción de la lista, titulada Enter Unlisted Option.

Si se ha seleccionado una opción de software, ocurre lo siguiente.

  • Aparecerá activado el botón "Remove".

  • Aparecerá visible el área de introducción de palabras clave.

  • Se activará la selección de permanente/temporal.

Si se ha seleccionado una opción de hardware, ocurre lo siguiente.

  • Una vez instalada la opción de hardware, se activará el botón "Remove".

  • Si no se ha instalado la opción de hardware, se activará el botón "Install".

Eliminación de una opción

  1. Para eliminar una opción, hacer clic en el botón Remove.

  2. Una vez que se haya eliminado la opción, reiniciar la aplicación del analizador de redes para que surtan efecto los cambios.

Instalación de una opción

  1. Si el área de introducción de palabras clave aparece visible, introducir una palabra clave. (No se distingue entre mayúsculas y minúsculas a la hora de escribir la palabra clave.)

  2. Hacer clic en Install.

  3. Una vez que se haya instalado la opción, reiniciar la aplicación del analizador de redes para que surtan efecto los cambios.

Reparación y recuperación de datos de opciones

Utilizar esta parte de la utilidad Option Enable en las siguientes situaciones:

  • Si se sustituye el disco duro

  • Si se sustituye la unidad de referencia de frecuencia

Esta rutina reconstruye la información de opciones contenida en el disco duro y la unidad de referencia de frecuencia (principal y de reserva).

  1. Seleccionar Repair en la barra de menús Option Enable Utility.

Nota: Si no se sabe con seguridad si es necesario realizar esta rutina, conviene realizarla en cualquier caso, ya que no se producirá ningún daño.

  2. Aparecen los números de serie y de modelo, junto a cuatro casillas de verificación.

  3. Seleccionar las casillas oportunas.

  4. Hacer clic en Begin Repair. La rutina comprueba todos los archivos de datos y realiza las reparaciones necesarias. Puede que se pida verificar ciertas informaciones y procesos.

  5. Si la rutina detecta que el número del modelo es incorrecto o no es válido, se pedirá que se seleccione el número de modelo correcto.

    • Con este número de modelo, será necesario una palabra clave de modelo.

    • Si no está definida en el analizador, o bien no se conoce, se recomienda ponerse en contacto con Agilent.

    • Una vez introducidos los datos solicitados, hacer clic en Change Model. Este proceso tarda alrededor de 30 segundos.

  6. Una vez hecho esto, seleccionar Exit Repair.

  7. Si no se necesita instalar otra opción, hacer clic en Exit.

Instalación o cambio del número de serie

Puede ser necesario instalar o cambiar un número de serie si se sustituyen ciertos conjuntos.

  1. Para cambiar el número de serie, seleccionar Change Serial en la barra de menús Option Enable. Aparecerá el número de serie actual. Si no se ha introducido anteriormente ningún número de serie, aparecerá la palabra "NONE".

  2. Escribir el nuevo número de serie en el espacio destinado a este fin y hacer clic en Change Serial. (No se distingue entre mayúsculas y minúsculas a la hora de escribir el número de serie.)

Nota: Debe prestarse mucha atención al introducir el número de serie, ya que sólo se dispone de una oportunidad para escribirlo.

  3. Para cambiar un número de serie incorrecto, se necesita una contraseña para eliminar el código. Ponerse en contacto con Agilent para obtener este código de eliminación y tener a mano el número de serie existente.

  4. Para cambiar el número de serie, escribir el código de eliminación en el espacio destinado a este fin, junto con el nuevo número de serie y, a continuación, hacer clic en Change Serial.


Phase Offset

Véase asimismo...

Desplaza matemáticamente una medida de fase una cantidad específica, de hasta 360º.


Port Extensions

Véase asimismo...

Amplía el plano de referencia de medida. Esta opción se puede utilizar después de llevar a cabo una calibración, para evitar tener que realizar otra calibración.

Port Extensions. Cuando se selecciona, aplica la función de extensión de puertos al puerto o los puertos especificados.

Input A. Especifica la distancia que se amplía el plano de referencia para la entrada A.

Input B. Especifica la distancia que se amplía el plano de referencia para la entrada B.

Port 1. Especifica la distancia que se amplía el plano de referencia para el puerto 1.

Port 2. Especifica la distancia que se amplía el plano de referencia para el puerto 2.

Velocity Factor. Especifica el factor de velocidad que se aplica al medio del dispositivo que se insertó después de la calibración de medida. El valor para un cable dieléctrico de polietileno es 0,66, y 0,7 para uno dieléctrico de teflón.


Nivel de potencia

Véase asimismo...

Define y controla la potencia de la fuente del analizador.

Power On. Enciende y apaga la potencia de la fuente.

Selección del puerto

Port. Especifica el puerto al que se refieren los valores.

Port Power Coupled. Alterna entre potencia de puertos de verificación acoplados y sin acoplar. Con los puertos acoplados, los niveles de potencia son los mismos en cada puerto de verificación. Con los puertos sin acoplar, se pueden establecer diferentes niveles de potencia para cada puerto de verificación.

Test Port Power. Establece el valor de la potencia en la salida del puerto de verificación.

Control del atenuador

Auto Couple Attenuation. Alterna entre un atenuador acoplado y no acoplado y el control de potencia de la fuente. Al acoplar el atenuador y la potencia de la fuente, se puede seleccionar cualquier nivel de potencia dentro del margen operativo del analizador, y el atenuador cambiará automáticamente al valor necesario. Si no se acopla el atenuador y la potencia de la fuente, se puede establecer el valor del atenuador y la potencia de la fuente por separado.

Attenuation. Especifica el valor de atenuación colocado en la ruta de salida de la fuente. Sólo es pertinente cuando el atenuador y la potencia de la fuente no están acoplados.

Pendiente de potencia

Slope. Activa y desactiva la función de pendiente de potencia.

Slope dB/GHz. Compensa la pérdida de potencia de un dispositivo en un barrido de frecuencia aumentando la potencia de salida del analizador sobre la frecuencia.


Powerststop

Configuración del barrido de potencia

Véase asimismo...

Start Power. Especifica la potencia al principio del margen de potencia barrido.

Stop Power. Especifica la potencia al final del margen de potencia barrido.

Attenuation. Establece la atenuación de modo que se pueda ajustar el barrido de potencia a niveles de potencia más bajos.


Calibración del receptor

La calibración del receptor ajusta los receptores del analizador de redes para obtener una respuesta plana a través de su margen de frecuencias completo.

Equipos necesarios

  • Medidor de potencia: HP/Agilent E4419B (recomendado), E4419A o EPM-442A

  • Sensor de potencia HP/Agilent 8482A

  • Sensor de potencia HP/Agilent E4412A (no es necesario con el analizador de redes E8356A)

  • Cable de RF HP/Agilent N6314A

  • Adaptador hembra a hembra tipo N HP/Agilent 1250-0777

Descripción general del procedimiento

  1. Asegurarse de que se han introducido los factores de calibración adecuados para el sensor 8482A en la tabla denominada HP8482A del medidor de potencia.

  2. Conectar un cable GPIB entre el medidor de potencia y el analizador de redes.

  3. Asegurarse de que el sensor 8482A (y el sensor E4412A para los analizadores E8357A/58A) está conectado al medidor de potencia.

  4. En el menú System del analizador, señalar con el cursor Service, Adjustments, y hacer clic en Receiver Calibration.

  5. El software identifica inicialmente el tipo de analizador de redes. El usuario tiene entonces tres opciones:

    • Si hace clic en el botón Inspect Flatness, el usuario podrá observar la planeidad de la respuesta del receptor en contraposición a la frecuencia. Si se hace antes de realizar la calibración del receptor y nuevamente después de realizar la calibración del receptor, el usuario debería poder ver la diferencia (planeidad mejorada en la respuesta del receptor en contraposición a la frecuencia) debido a la calibración del receptor.

    • Si hace clic en el botón Calibrate, comienza el proceso de calibración del receptor. El software pide al usuario que conecte los sensores, el cable y el adaptador según sea necesario (véanse las figuras 1 a 3 a continuación).

Conexión del sensor de potencia al puerto del analizador

Conexión del adaptador y del cable entre el sensor y el puerto del analizador

Conexión de cable pasivo utilizando un cable de tipo N

Resolución de problemas

En caso de que ocurriese un problema con la calibración del receptor, consúltese el Capítulo 3: Resolución de problemas en la Guía de Servicio de los analizadores de redes E8356A/57A/58A.


Save As

Véase asimismo...

Guarda un archivo con el nombre y en la ubicación que se especifica.

Save in. Permite seleccionar el directorio en el que se desea guardar el archivo.

File name. Muestra el nombre de archivo que se ha escrito o en el que se ha hecho clic en el cuadro de contenido del directorio.

Save as type. Permite hacer una selección en la lista de tipos de archivos que puede guardar el analizador. Los archivos *.cst, *.sta, y *.cal son los únicos tipos de archivo que se pueden volver a recuperar en el analizador. (Las trazas de medida deben encontrarse en el estado Hold para que se puedan guardar.)

Save. Guarda el archivo con el nombre y en el directorio que se ha seleccionado.


Cuadro de escala

Escala

Véase asimismo...

Especifica los valores para visualizar la respuesta de una medida.

Escala

Per Division Especifica el valor de las divisiones verticales de la cuadrícula de la pantalla.

Auto. Ajusta verticalmente la escala de la traza de datos activa para ajustarla a la zona de la cuadrícula de la pantalla.

Auto All. En la ventana activa, ajusta verticalmente la escala de todas las trazas de datos para ajustarlas a la zona de la cuadrícula de la pantalla.

Referencia

Level Especifica el valor de la línea de referencia en formatos cartesianos, o el círculo exterior en los formatos polares

Position. Especifica la posición de la línea de referencia, donde la parte superior de la cuadrícula es 10 y la parte inferior es 0. La posición predeterminada se encuentra en el centro de la cuadrícula en 5.


Serial_Bus

Verificación del bus serie

Esta prueba va destinada al analizador de redes de la serie PNA tal y como se fabricó originalmente. Si se ha sustituido alguno de los siguientes conjuntos en el analizador, puede que esta verificación no muestre resultados exactos.

  • A8

  • A10

  • A11

  • A12

Esta verificación somete a prueba de forma secuencial los 32 nodos a 300 kHz y, a continuación, todos los nodos cuyos valores cambien con la frecuencia, a otras 11 frecuencias. Todos los valores medidos se escriben en un archivo de texto ASCII en el directorio de servicio, y cualquier valor medido que supere sus tolerancias aparecerá resaltado en la aplicación y en el archivo de datos.

Los conjuntos verificados y sus números de nodo asociados son los siguientes:

Conjunto de la tarjeta | Números de nodo
A12 Conjunto de la fuente | 111 a 118
A10 Referencia de frecuencia | 211 a 218
A11 Bloqueo de fase | 311 a 318
A8 Sintetizador fraccionario N | 411 a 418

Realización de la verificación del bus serie

En el menú System del analizador, señalar con el cursor Service, y hacer clic en Serial Bus Test, Run.

Nota: Si ocurre algún error, consúltese la Guía de Servicio.


SICL_GPIB

SICL/GPIB

Véase asimismo...

GPIB

Talker/Listener. Ajusta el analizador para que reciba y envíe mensajes GPIB/SCPI al controlador del sistema (ordenador externo).

Talker/Listener Address. Establece la dirección GPIB del receptor/emisor.

System Controller. Establece el analizador como controlador del sistema, que controla las comunicaciones GPIB de los dispositivos externos.

System Controller Address. Establece la dirección GPIB del controlador del sistema del analizador.

SICL

SICL Enabled. Cuando se selecciona, el analizador puede ejecutar programas GPIB en su ordenador para controlar las funciones del analizador. Los programas deben ejecutarse desde un entorno de programación compatible con GPIB (VEE, Visual Basic). Este modo no permite controlar instrumentos GPIB externos.

Address. Establece la dirección del analizador.

GPIB Command Processor Console. Muestra una ventana que se utiliza para enviar comandos SCPI/GPIB únicos.

  • Escribir un comando válido, con argumentos apropiados, y pulsar Enter.

  • Utilizar las teclas de flecha para recuperar comandos anteriores.

  • Pulsar Control+ Z para cerrar la ventana de la consola.

  • La ventana de la consola puede aparecer detrás de la aplicación del analizador. Pulsar Control+ tabulador para mostrar la ventana de la consola en primer plano.


Suavizado

Véase asimismo...

Smoothing ON. Cuando se selecciona, aplica la función de suavizado que promedia los datos sobre una parte de la traza.

Per Cent of Span. Especifica la apertura de suavizado como un porcentaje del recorrido del estímulo barrido, entre 1,9% y 25%.

Points. Especifica la apertura de suavizado como un porcentaje del número total de puntos de medida en el recorrido del estímulo barrido.


Calibración de la fuente

La calibración de la fuente ajusta el analizador de redes para obtener una potencia de fuente plana a través de su margen de frecuencias completo.

Equipos necesarios

  • Medidor de potencia: HP/Agilent E4419B (recomendado), E4419A o EPM-442A

  • Sensor de potencia HP/Agilent 8482A

  • Sensor de potencia HP/Agilent E4412A (no es necesario con el analizador de redes E8356A)

  • Cable de RF HP/Agilent N6314A

Procedimiento

  1. Asegurarse de que se han introducido los factores de calibración adecuados para el sensor 8482A en la tabla denominada HP8482A del medidor de potencia.

  2. Conectar un cable GPIB entre el medidor de potencia y el analizador de redes.

  3. Asegurarse de que el sensor 8482A (y el sensor E4412A para los analizadores E8357A/58A) está conectado al medidor de potencia.

  4. En el menú Service del analizador, señalar con el cursor Adjustments, y hacer clic en Source Calibration.

  5. El software identifica inicialmente el tipo de analizador de redes. El usuario tiene entonces tres opciones:

    1. Si hace clic en el botón Inspect Linearity, el usuario podrá observar lo lineal que es el cambio de la potencia de la fuente a través del margen de frecuencias cuando se cambia el nivel de potencia. Si esto se hace antes de realizar la calibración de la fuente y nuevamente después de realizar la calibración de la fuente, el usuario debería poder ver la diferencia (la potencia cambia de manera más lineal a través del margen de frecuencias cuando cambia el nivel de potencia) debido a la calibración de la fuente.

    2. Si hace clic en el botón Inspect Amplitude, el usuario podrá observar la planeidad de la potencia de la fuente en contraposición a la frecuencia para tres niveles de potencia: -5 dBm, 0 dBm y +5 dBm. Si se hace antes de realizar la calibración de la fuente y nuevamente después de realizar la calibración de la fuente, el usuario debería poder ver la diferencia (planeidad mejorada de la potencia en cada nivel de potencia) debido a la calibración de la fuente.

    3. Si hace clic en el botón Calibrate, comienza el proceso de calibración de la fuente. El software indica al usuario dónde deben conectarse los sensores y el cable, según sea necesario (véanse las figuras 1 y 2 a continuación).

Conexión del sensor al puerto del analizador de redes

Conexión de cable pasivo utilizando un cable de tipo N especificado

Información adicional

La calibración seguirá determinando la configuración del DAC utilizando el Puerto 1 únicamente, porque se da por sentado que los puertos se comportarán simétricamente.

Nota: La calibración de la fuente tarda en realizarse 20 minutos como mínimo (E8356A), y alrededor de 45 minutos como máximo (E8358A).

Resolución de problemas

En caso de que ocurriese un problema con la calibración de la fuente, consúltese el Capítulo 3: Resolución de problemas, en la Guía de Servicio de los analizadores de redes E8356A/57A/58A.


Frecuencias de inicio y de parada

Véase asimismo...

Start. Especifica la frecuencia al principio del margen de medida barrido.

Stop. Especifica la frecuencia al final del margen de medida barrido.


Configuración de barrido

Véase asimismo...

Channel. Especifica el canal en el que se aplica la configuración.

Stepped Sweep. Cuando se selecciona, la fuente se desplaza por pasos a cada punto de medida.

Dwell Time. Especifica el tiempo que permanece la fuente en cada punto de medida antes de que el analizador tome los datos, cuando se utiliza el barrido por pasos.

Alternate Sweeps. Si se selecciona, el analizador sólo mide un receptor por barrido.

External ALC. Cuando se selecciona, el analizador recibe una señal externa que se utiliza para nivelar la salida de la fuente. El conector de entrada de señales del ALC externo es la entrada del detector externo en el panel posterior.


Sweep Time

Véase asimismo...

Especifica la duración de un barrido de medida. Por defecto, el analizador mantiene automáticamente el tiempo de barrido más rápido posible con la configuración de medida seleccionada. Sin embargo, también se puede seleccionar otro tiempo de barrido que admita el instrumento. Introducir 0 segundos para que el analizador vuelva al tiempo de barrido automático.


Tipo de barrido

Véase asimismo...

Channel. Especifica el canal en el que se aplica la configuración.

Tipo de barrido

Linear Frequency. Activa un barrido de frecuencia lineal que se muestra en una cuadrícula estándar con diez divisiones horizontales iguales. éste es el barrido predeterminado.

Start. Define el valor al comienzo del barrido de frecuencia.

Stop. Define el valor al final del barrido de frecuencia.

Points. Indica la cantidad de puntos de datos que el analizador recopila durante un barrido de medida. Se puede indicar un valor comprendido entre 2 y 1.601. El valor por defecto es 201.

Power Sweep. Activa un barrido de potencia a una única frecuencia especificada por el usuario. El barrido de potencia predeterminado comienza en -10 dBm y se detiene en -10 dBm. Se puede establecer cualquier margen de potencia < 25 dB.

Start. Define el valor al comienzo del barrido de potencia.

Stop. Define el valor al final del barrido de potencia.

CW Frequency. Define la frecuencia única en la que permanece el analizador durante el barrido de medida.

CW Time. Activa un modo en el que el analizador se ajusta a una única frecuencia, y los datos se muestran con respecto al tiempo.

CW Frequency. Define la frecuencia única en la que permanece el analizador durante la medida.

Sweep Time. Define la duración de la medida.

Points. Indica la cantidad de puntos de datos que el analizador recopila durante una medida. Se puede indicar un valor comprendido entre 2 y 1.601. El valor por defecto es 201.

Segment Sweep. Activa un barrido en el que el analizador toma los datos mientras realiza un barrido a través de puntos de frecuencia definidos. Se pueden definir hasta 30 sub-barridos de frecuencia, denominados segmentos. Para cada segmento se puede definir la potencia del puerto de verificación y el ancho de banda de IF de forma independiente.

Independent Power Levels. Cuando se selecciona, el usuario puede establecer un nivel de potencia de la fuente distinto para cada segmento.

Independent IF Bandwidth. Cuando se selecciona, el usuario puede establecer un ancho de banda de IF diferente para cada segmento.

Independent Sweep Time. Define la duración de la medida para cada segmento.

Show Table. Muestra la tabla con la que se pueden crear y editar segmentos.

Hide Table. Hace que desaparezca de la pantalla la tabla con los segmentos.


Verificación del sistema

Esta rutina comprueba el funcionamiento del sistema analizador midiendo automáticamente la magnitud y la fase de los cuatro parámetros S de cada uno de los dispositivos de verificación, y comparando los valores con lo siguiente:

  • Datos medidos en fábrica de los archivos contenidos en el disco de verificación

  • Líneas límite basadas en la incertidumbre de la medida

Nota: Aunque se mide el rendimiento de los cuatro parámetros S, las incertidumbres de la fase de S11 y S22 son menos importantes para la verificación del rendimiento del sistema, y por ello no se utilizan ni aparecerán en las salidas impresas.

Haga clic en los botones para mostrar la información.

Equipos utilizados en la verificación del sistema

Sustitución de cables

Sustitución del kit de calibración

Precauciones al manipular líneas aéreas

Diagrama del procedimiento

Procedimiento de verificación del sistema

Si el sistema no supera la prueba de verificación

Interpretación de los resultados de la verificación

Equipos utilizados en la verificación del sistema

Kit de calibración (Tipo N) 1,2 | 85032F
Módulo ECal (Tipo N) 3 | 85092B
Kit de verificación (Tipo N) | 85055A
Cable de RF (Tipo N) | N6314A
1 Utilizar el kit de calibración o el módulo ECal.
2 Opción alternativa: Kit de calibración de 3,5 mm 85033E.
3 Opción alternativa: Módulo ECal de 3,5 mm 85093B

Sustitución de cables

Los cables del puerto de verificación especificados para el sistema analizador de redes se han caracterizado en cuanto a la repetibilidad, magnitud y estabilidad de fase de los conectores con flexión, pérdida de retorno, pérdida por inserción y grado de deriva con el tiempo. Puesto que el rendimiento del cable del puerto de verificación es un factor importante que contribuye al rendimiento del sistema, los cables de rendimiento inferior aumentarán la incertidumbre de la medida. Se recomienda comprobar periódicamente los cables del puerto de verificación.

Si la verificación del sistema se lleva a cabo con un cable que no sea Agilent, asegurarse de que el funcionamiento del cable sea igual o superior al del cable N6314A de tipo N. Consultar la Guía del Usuario del N6314A para obtener las especificaciones.

Sustitución del kit de calibración

No se recomiendan ni se admiten kits de calibración que no sean Agilent.

Precauciones al manipular líneas aéreas

Cuando se utilicen las líneas aéreas del kit de verificación, observar las siguientes pautas prácticas para garantizar buenas técnicas de medida.

  • Extremar las precauciones para evitar que se caiga el conductor exterior o central de la línea aérea. Si se dejan caer estos dispositivos, se producirán daños.

  • Seguir los procedimientos adecuados de descarga electrostática (ESD).

  • Lavarse las manos o utilizar guantes, ya que la grasa de la piel puede producir cambios en el rendimiento eléctrico.

Diagrama del procedimiento

El siguiente diagrama muestra el flujo de operaciones del software.

Procedimiento de verificación del sistema

  1. Conectar un cable al puerto 2 del analizador. Si se desean imprimir los resultados de la verificación, conectar una impresora al analizador. Dejar que el analizador se caliente durante al menos 30 minutos.

Configuración de la prueba de verificación del sistema

  2. Insertar el disquete del kit de verificación PNA en la unidad de disquetes del analizador.

  3. En el menú System, señalar con el cursor Service y hacer clic en System Verification. Aparecerá la ventana System Verification.

Ventana System Verification

  4. En el cuadro Calibration Kit, seleccionar el kit de calibración que se esté utilizando. El kit de verificación correspondiente que se debe utilizar aparece en el cuadro Verification Kit.

  5. En Printer Output, hacer clic en una de las siguientes opciones.

    • None: No se imprime ningún resultado.

    • Tabular Data: Imprime los datos de verificación en forma de tabla que incluya datos medidos y límites de incertidumbre. Consultar el ejemplo de datos tabulares que se muestra más adelante en este tema.

    • Measurement Plots: Imprime los datos de verificación en formato gráfico. Los gráficos incluyen la traza de los datos medidos, la traza de los datos suministrados de fábrica y los límites de incertidumbre. Consultar el ejemplo de representación gráfica de datos que se muestra más adelante en este tema.

    • Both: Imprime los datos de verificación en ambos formatos.

Nota: Si se desea imprimir los resultados, se da por sentado que ya se ha instalado el controlador de Windows 2000 para la impresora en cuestión, y que se ha comprobado que se puede imprimir desde el analizador de redes en la impresora. Este software está diseñado para imprimir en cualquier impresora que esté configurada como impresora predeterminada (véase Impresoras en el Panel de control de Windows).

  6. Con el menú System Verification Configure se puede modificar el procedimiento de verificación del sistema de dos modos:

    • Con el submenú Calibration se pueden elegir dos modos de calibración.

      • Perform a calibration (predeterminado) prepara el software para guiar al usuario durante una calibración de 2 puertos utilizando el kit de calibración seleccionado.

      • Load previous calibration prepara el software para que pida al usuario que seleccione un archivo de estado de instrumento calibrado (*.cst) que se haya guardado anteriormente, utilizando el software de verificación del sistema.

    • Con el submenú Devices to Measure es posible seleccionar qué dispositivos se medirán durante el procedimiento de verificación del sistema. Por defecto, todos los dispositivos del kit están seleccionados. Para que la verificación del sistema sea realmente eficaz, el software debe medir todos los dispositivos del kit.

  7. Hacer clic en Run.

  8. Cuando se soliciten los dispositivos durante la verificación del sistema, insertar los dispositivos de la manera mostrada.

Conexiones de los dispositivos de verificación

Descripción detallada del proceso

  1. Dependiendo de la opción elegida en el submenú Calibration del menú Configure, el usuario puede recuperar un estado de instrumento calibrado anterior, o bien dejarse guiar a través de una calibración completa de 2 puertos utilizando el kit de calibración seleccionado. Con calibraciones electrónicas, el módulo ECal sólo se conecta una vez; aparece un mensaje de espera mientras el software realiza la calibración.

  2. Se pide al usuario que conecte el primer dispositivo de verificación.

  3. El software lee los datos medidos en fábrica para ese dispositivo y los valores de incertidumbre de esos datos (archivos CITI) desde el disquete suministrado con el kit de verificación.

  4. El software envía la información de los datos medidos en fábrica, del kit de calibración y del estado del instrumento a la DLL del calculador de incertidumbre, que genera valores de incertidumbre específicos para el PNA.

  5. El analizador se configura en primer lugar para realizar medidas de magnitud de los cuatro parámetros S, con cada parámetro en una ventana separada (magnitud lineal para S11 y S 22, magnitud logarítmica para21 y S12). Cada uno de los parámetros S medidos en fábrica se transmite a la ventana apropiada como una traza de memoria. Los desplazamientos de las líneas límite se calculan como la suma de las incertidumbres de los datos medidos en fábrica y las incertidumbres del PNA notificadas por la DLL. Se muestran los límites superior e inferior (datos medidos en fábrica + suma de incertidumbres, datos medidos en fábrica - suma de incertidumbres). El PNA realiza un barrido, se activa la verificación de límites y se informa en cada una de las cuatro ventanas si se ha superado o no la prueba (PASS/FAIL).

  6. El usuario hace clic en un botón cuando está preparado para ver las medidas de fase. Las cuatro ventanas se actualizan para el formato de fase, las trazas de memoria de fase, los límites de fase y el resultado de la prueba (PASS/FAIL).

  7. Si la verificación de límites de cualquiera de los cuatro parámetros S (magnitud o fase) indica un estado FAIL (prueba no superada), el software ofrece sugerencias de resolución de problemas y pregunta al usuario si desea repetir la medida de ese dispositivo o seguir con el siguiente. Si se sigue con el siguiente dispositivo, los datos medidos en fábrica y las incertidumbres para el siguiente dispositivo se leen desde el disquete, se invoca la DLL de incertidumbre con este siguiente conjunto de datos medidos en fábrica y las cuatro ventanas de medida se actualizan para la medida de magnitud del siguiente dispositivo.

  8. El software sigue este mismo proceso hasta que se hayan medido todos los dispositivos seleccionados, y en ese momento aparece una ventana con un resumen que contiene los resultados PASS/FAIL de los cuatro parámetros de cada dispositivo.

Si el sistema no supera la prueba de verificación

IMPORTANTE: Comprobar todas las conexiones. No retirar el cable del puerto de verificación del analizador. Esto anularía la calibración realizada anteriormente.

  1. Repetir esta prueba de verificación. Conectar correctamente con las especificaciones de par adecuadas para cada dispositivo de verificación.

  2. Desconectar, limpiar y volver a conectar el dispositivo que no haya superado la prueba de verificación. Volver a medir el dispositivo de nuevo.

  3. Si el analizador sigue sin superar la prueba, comprobar la calibración de medida revisando los términos de errores de la manera descrita en "Acceso a los términos de errores desde el panel frontal", en las páginas 4 a 7 de la Guía de Servicio.

  4. Consultar el siguiente gráfico para conocer más pasos de resolución de problemas.

Diagrama cuando no se supera la prueba de verificación

Interpretación de los resultados de la verificación

El gráfico que aparece a continuación muestra un ejemplo de resultados de verificación típicos con la opción Tabular Data seleccionada en la zona Printer Output de la ventana System Verification. Otro gráfico que aparece más adelante en este tema muestra un ejemplo de resultados de verificación típicos con la opción Measurement Plots seleccionada en la zona Printer Output de la ventana System Verification. Estas salidas impresas incluyen una comparación de los datos procedentes de los resultados de medida con los datos de referencia y las especificaciones de incertidumbre correspondientes. Utilizar estas salidas impresas para determinar si los datos medidos se encuentran dentro de los límites de incertidumbre totales a todas las frecuencias.

Los datos tabulares incluyen:

  • Frecuencia de los puntos de datos (en MHz).

  • La línea límite inferior tal y como se define por la especificación de incertidumbre total del sistema.

  • Resultados de la medida.

  • La línea límite superior tal y como se define por la especificación de incertidumbre total del sistema.

  • Estado de la verificación (PASS o FAIL) de ese punto de medida.

Salida impresa de los resultados de la verificación en formato tabular

Los resultados gráficos impresos muestran:

  • Los puntos de límite superior tal y como se definen por las especificaciones de incertidumbre total del sistema.

  • Los puntos de límite inferior tal y como se definen por las especificaciones de incertidumbre total del sistema.

  • Datos medidos en fábrica.

  • Resultados de las medidas.

  • Nombres y formatos de los parámetros de medida (magnitud lineal o magnitud logarítmica).

  • Número de serie del dispositivo (00810).

  • El dispositivo que se está midiendo (atenuador Sys Ver de 20 dB).

Salida impresa de los resultados de la verificación en formato gráfico


Estadísticas de trazas

Véase asimismo...

Statistics. Cuando se selecciona, calcula el promedio, la desviación estándar y los valores entre picos de la traza activa.

Span. Especifica el recorrido de la traza activa donde se recopilan los datos para una operación matemática. Se pueden definir hasta 9 recorridos de usuario para cada traza. También se pueden definir los recorridos de usuario desde el cuadro de diálogo Marker Search.

Start. Define la frecuencia de inicio de un recorrido de usuario.

Stop. Define la frecuencia de parada de un recorrido de usuario.


Transformada

Transformada en el dominio del tiempo

Véase asimismo...

Permite visualizar la respuesta de un dispositivo como una función del tiempo.

Transform. Cuando la casilla está seleccionada, el analizador aplica una función matemática para transformar los datos de medidas de frecuencia en datos de medidas de tiempo.

Start. Especifica el comienzo del espacio de tiempo en el que el analizador mide los datos. Un tiempo de inicio de 0 segundos establece el comienzo del margen de medida en el plano de referencia de medida.

Stop. Especifica el final del espacio de tiempo en el que el analizador mide los datos. Es decir, el tiempo transcurrido desde que se emitió una señal de estímulo.

Center. Especifica el valor en el centro del margen de medida. Este valor puede encontrarse en cualquier lugar del rango del analizador.

Span. Especifica el margen de valores medidos a cada lado del valor central.

Modo de transformada

Low Pass Impulse. Especifica el modo de medida para dispositivos que funcionan hasta el nivel de cc. Muestra las medidas de respuesta de impulsos.

Low Pass Step. Especifica el modo de medida para dispositivos que funcionan hasta el nivel de cc. Muestra las medidas de respuesta de pasos.

Band Pass. Especifica el modo de medida para dispositivos que están limitados por banda y no funcionan hasta el nivel de cc. Esto modo sólo muestra las medidas de respuesta de impulsos.

Set Frequency Low Pass. Distribuye los puntos de medida de manera uniforme a lo largo del margen, cuando se utiliza el modo de paso bajo. Permite realizar una calibración de medida, antes de que los datos se transformen al domino del tiempo.


Transform Gate

Puerta en el dominio del tiempo

Véase asimismo...

Permite seleccionar respuestas en el dominio del tiempo para que el analizador las elimine matemáticamente de la medida mostrada.

Gating. Aplica un filtro de tiempo que elimina las respuestas seleccionadas en el dominio del tiempo.

Start. Especifica el tiempo de inicio del filtro de tiempo.

Stop. Especifica el tiempo de parada del filtro de tiempo.

Center. Especifica el valor en el centro del área afectada por la función de puerta de tiempo. Este valor puede encontrarse en cualquier lugar del rango del analizador.

Span. Especifica el margen a cada lado del valor en el centro del área afectada por la función de puerta de tiempo.

Gate Type. Define el tipo de filtrado que se realizará para la función de puerta de tiempo.

Gate Shape. Define las características del filtro de la función de puerta de tiempo.


Transform Window

Ventana de dominio del tiempo

Véase asimismo...

Aplica un filtro que ayuda a identificar respuestas individuales como una función del tiempo.

Minimum. Especifica el filtro de ventana que ofrece un ancho de impulso estrecho, con lo que se consigue la mejor resolución de respuesta.

Maximum. Especifica el filtro de ventana que reduce los lóbulos laterales de una señal, aportando el mejor margen dinámico.

Kaiser Beta. Permite definir las características de una ventana utilizando un valor Kaiser Beta.

Impulse Width. Permite definir las características de la ventana utilizando un valor de ancho de impulso.


Triggr

Activador

Véase asimismo...

Define la manera en que la fuente del analizador aporta un estímulo a un dispositivo sometido a prueba. Véase la Animación del activador.

Fuente del activador

Internal. Ajusta el analizador para enviar señales del activador interno, después de tomar cada medida. Esto provoca barridos de medida continuos.

Manual. Ajusta el analizador para enviar una señal de activador cuando se pulsa Trigger.

External. Ajusta el analizador para que espere una señal del activador desde una fuente externa.

Alcance del activador (sólo es pertinente para Manual y External)

Global. Ajusta el analizador para que realice un barrido de medida para cada canal, cuando se acepta una señal de activador.

Channel. Ajusta el analizador para que realice un barrido de medida para un único canal, cuando se acepta una señal de activador. El siguiente disparo hace que el analizador realice un barrido en el siguiente canal, etc.

Estado del activador de canales

Channel. Especifica el canal en el que se aplica la configuración.

Continuous. Ajusta el canal para que realice un barrido de medida cada vez que se acepte una señal de activador.

Enable Groups. Ajusta el canal para realizar un barrido de medida cuando se acepte una señal del activador, hasta que los barridos alcancen un número especificado por el usuario.

Number of Groups. Especifica el número de barridos de medida que el canal toma antes de pasar a un estado de espera.

Single. Ajusta el canal para realizar un único barrido de medida y después pasar a un estado de espera.

Hold. Ajusta el canal para que conserve los datos de medida anteriores y no realice otro barrido de medida.

Point Sweep. (Sólo es pertinente para la fuente de activador Manual con estado de activador Channel.) Hace que el analizador pase al siguiente punto de datos cada vez que se pulsa Trigger.


Título de ventana

Véase asimismo...

Permite añadir un título a la ventana actual.


SystemZ0

Impedancia Z0 del sistema

Véase asimismo...

Permite cambiar la impedancia predeterminada del sistema (50 ohmios) para que el analizador realice todos los cálculos de medida en otra impedancia de sistema.

Por ejemplo, si se desea medir dispositivos que tienen una impedancia de 75 ohmios:

  • Cambiar la impedancia Z0 del sistema a 75 ohmios.

  • Conectar atenuadores fijos de pérdida mínima entre el analizador y los dispositivos con impedancia de 75 ohmios.

  • Realizar una calibración de medida con un circuito cerrado, un circuito abierto y una carga de 75 ohmios en la que las definiciones del kit de calibración describan los patrones de 75 ohmios.


Connectivity

Integración en red y conexión del analizador

Véase asimismo...

Haga clic en un botón para obtener información rápida sobre la integración en red y conectividad del analizador.

Usuarios adicionales del analizador de redes

Asignación de una unidad conectada a la red

Configurar para programación COM/DCOM

Consideraciones relativas a Windows 2000


Procedimientos iniciales

Comienzo rápido

Véase asimismo...

Haga clic en un botón para obtener información acerca del analizador.

Descripción del panel frontal

Descripción del panel posterior

Interfaz de usuario

Modelo de funcionamiento del analizador

Secuencia de medida básica

Cómo utilizar la Ayuda

Integración en red y conexión del analizador

Disco de reparación de emergencia


Consideraciones relativas a Windows 2000

Véase asimismo...

En este tema se tratan algunos cambios notables en el entorno operativo con Windows 2000. Para obtener información más detallada sobre estos y otros temas, consúltese el sistema de la Ayuda de Windows 2000.

Utilización de USB

El PNA dispone de dos puertos USB para conectar dispositivos: uno en el panel frontal y otro en el panel posterior. Las principales ventajas de los dispositivos USB son que se conectan y se desconectan "en funcionamiento" y alcanzan grandes velocidades de transferencia de datos. Ahora también hay disponibles módulos de calibración electrónica con conexiones USB.

La primera vez que se conecta un dispositivo a un puerto USB hay que esperar durante algún tiempo. Windows 2000 indica que está identificando el hardware, a continuación busca el controlador correcto y después instala el controlador (si se ha encontrado).

Se puede volver a conectar posteriormente ese mismo dispositivo a ese mismo puerto de manera rápida y sencilla, pero si se cambia el dispositivo a un puerto USB diferente, será necesario esperar durante la identificación de hardware y la búsqueda del controlador.

Estabilidad y seguridad de "Plug and Play"

La capacidad "Plug and Play" es similar a la de Windows 95 y 98. Ofrece un entorno operativo seguro y estable. Podrá observarse que también reduce considerablemente las veces que es necesario reiniciar el sistema.

Conexiones de LAN

Windows 2000 admite DHCP y direcciones IP fijas. Además, gracias a la conexión y desconexión en funcionamiento del cable de LAN, y al indicador visual del estado de la LAN en la zona de la barra de tareas del sistema, las conexiones de LAN son más intuitivas. Asimismo, el Asistente para agregar nuevo hardware ayuda a los usuarios a configurar el hardware del sistema.

Opción de un clic y doble clic.

Por defecto, Windows 2000 permite iniciar iconos con un solo clic. Para volver al método de doble clic, ir a Start -> Settings -> Control Panel y hacer clic en Mouse. En el cuadro de diálogo Mouse Properties, seleccionar Double-click para abrir un elemento. A continuación, hacer clic en OK.


Disquete de 3,5"

Unidad de disquetes de 3,5"

Instala archivos en el disco duro del analizador o almacena archivos de datos del analizador. Acceder a la unidad de disquetes utilizando el Explorador de Windows NT.

  • Capacidad de datos sin formato: 2 MB
  • Compatible con: disquetes de alta densidad (2HD) y de densidad normal (2DD)
  • Velocidad de transferencia: 500 Kbits/segundo

Volver al panel frontal


Arrange

Tecla Arrange

Permite elegir entre cuatro organizaciones de ventanas: Superposición, Pila 2, División 3, Cuadrante 4.


Aux Out 2

Salida auxiliar (Puerto 2)

Véase asimismo...

Utilizar estos conectores SMA (hembra) para realizar medidas personalizadas.

Puente de acceso directo al receptor B

  • El conector "B" superior procede del brazo acoplado del acoplador del Puerto 2.

  • El conector inferior va directamente a la entrada del receptor "B". Si está instalada la opción 015, la ruta va directamente a un atenuador conmutable y, a continuación, a la entrada del receptor.

Para la entrada del receptor:

Nivel de entrada máximo:

-6 dBm; <0,4 dB de compresión (de 300 kHz a 3 GHz)
-6 dBm; <0,8 dB de compresión (de 3 GHz a 6 GHz)
-11 dBm; <0,8 dB de compresión (de 6 GHz a 9 GHz)

Límite inferior del ruido; eficaz (ancho de banda de 10 Hz):

<-133 dBm (de 300 kHz a 3 GHz)
<-123 dBm (de 3 GHz a 6 GHz)
<-123 dBm (de 6 GHz a 9 GHz)

Nivel de daños: +26 dBm

Nivel de CC máximo: 40 V (estándar), 0 V (opción 015)

Pérdida de retorno:

>17 dBm (de 300 kHz a 3 GHz)
>12 dBm (de 3 GHz a 6 GHz)
>7 dBm (de 6 GHz a 9 GHz)

Puente del canal de referencia

  • El conector superior procede de la salida de referencia 2 del conmutador de transferencia.

  • El conector inferior va directamente a la entrada del receptor R2.

Para la entrada del receptor:

Nivel de entrada máximo:

-6 dBm; <0,4 dB de compresión (de 300 kHz a 3 GHz)
-6 dBm; <0,8 dB de compresión (de 3 GHz a 6 GHz)
-11 dBm; <0,8 dB de compresión (de 6 GHz a 9 GHz)

Nivel de daños: >+26 dBm

Nivel mínimo para mantener el bloqueo de fase:

-35 dBm (de 300 kHz a 3 GHz)
-25 dBm (de 3 GHz a 9 GHz)

Para la salida de referencia: (con una entrada externa para bloquear la fuente)

Nivel de salida:

de -5 a -30 dBm (de 300 kHz a 6 GHz)
de -10 a -35 dBm (de 6 GHz a 9 GHz)

Pérdida de retorno de acoplamiento entre fuentes:

16 dB (de 300 kHz a 3 GHz)
14 dB (de 3 GHz a 9 GHz)

Nivel de daños: >+26 dBm

Nivel de CC máximo: 40 V

Puente del puerto de verificación (sólo opción 015)

  • El conector "R2" superior procede del conmutador de transferencia del acoplador del Puerto 2.

  • El conector inferior va directamente a la entrada principal del acoplador del Puerto 2. En este punto es donde se puede insertar un atenuador para proteger el receptor del analizador.

Para la salida de la fuente:

Nivel de salida:

De +12 a -83 dBm (de 300 kHz a 6 GHz)
De +7 a -88 dBm (de 6 GHz a 9 GHz)

Acoplamiento entre fuentes: 15 dB a 9 GHz

Para la entrada al acoplador:

Pérdida por inserción al puerto de verificación 1:

<3,5 dB a 3 GHz
<5 dB a 9 GHz

Potencia de entrada máxima: 2 vatios, CW

Nivel de daños: 4 vatios, CW

Volver al panel frontal


Aux Out1

Salida auxiliar (Puerto 1)

Véase asimismo...

Utilizar estos conectores SMA (hembra) para realizar medidas personalizadas.

Puente de acceso directo al receptor A

  • El conector "A" superior procede del brazo acoplado del acoplador del Puerto 1.

  • El conector inferior va directamente a la entrada del receptor "A". Si está instalada la opción 015, la ruta va directamente a un atenuador conmutable y, a continuación, a la entrada del receptor.

Para la entrada del receptor:

Nivel de entrada máximo:

-6 dBm; <0,4 dB de compresión (de 300 kHz a 3 GHz)
-6 dBm; <0,8 dB de compresión (de 3 GHz a 6 GHz)
-11 dBm; <0,8 dB de compresión (de 6 GHz a 9 GHz)

Límite inferior del ruido; eficaz (ancho de banda de 10 Hz):

<-133 dBm (de 300 kHz a 3 GHz)
<-123 dBm (de 3 GHz a 6 GHz)
<-123 dBm (de 6 GHz a 9 GHz)

Nivel de daños: +26 dBm

Nivel de CC máximo: 40 V (estándar), 0 V (opción 015)

Pérdida de retorno:

>17 dBm (de 300 kHz a 3 GHz)
>12 dBm (de 3 GHz a 6 GHz)
>7 dBm (de 6 GHz a 9 GHz)

Puente del canal de referencia

  • El conector superior procede de la salida de referencia 1 del conmutador de transferencia.

  • El conector inferior va directamente a la entrada del receptor R1.

Para la entrada del receptor:

Nivel de entrada máximo:

-6 dBm; <0,4 dB de compresión (de 300 kHz a 3 GHz)
-6 dBm; <0,8 dB de compresión (de 3 GHz a 6 GHz)
-11 dBm; <0,8 dB de compresión (de 6 GHz a 9 GHz)

Nivel de daños: >+26 dBm

Nivel mínimo para mantener el bloqueo de fase:

-35 dBm (de 300 kHz a 3 GHz)
-25 dBm (de 3 GHz a 9 GHz)

Para la salida de referencia: (con una entrada externa para bloquear la fuente)

Nivel de salida:

de -5 a -30 dBm (de 300 kHz a 6 GHz)
de -10 a -35 dBm (de 6 GHz a 9 GHz)

Pérdida de retorno de acoplamiento entre fuentes:

16 dB (de 300 kHz a 3 GHz)
14 dB (de 3 GHz a 9 GHz)

Nivel de daños: >+26 dBm

Nivel de CC máximo: 40 V

Puente del puerto de verificación (sólo opción 015)

  • El conector superior procede de la fuente aplicada al Puerto 1.

  • El conector inferior va directamente a la entrada principal del acoplador del Puerto 1. En este punto es donde se puede insertar un amplificador de potencia para aumentar la potencia del puerto de verificación.

Para la salida de la fuente:

Nivel de salida:

De +12 a -83 dBm (de 300 kHz a 6 GHz)
De +7 a -88 dBm (de 6 GHz a 9 GHz)

Acoplamiento entre fuentes: 15 dB a 9 GHz

Para la entrada al acoplador:

Pérdida por inserción al puerto de verificación 1:

<3,5 dB a 3 GHz
<5 dB a 9 GHz

Potencia de entrada máxima: 2 vatios, CW

Nivel de daños: 4 vatios, CW

Volver al panel frontal


Average

Tecla Average

Permite aplicar promedios de medidas que reducen el ruido. El analizador realiza un promedio exponencial complejo de una serie de barridos especificados.


Cal Pop

Tecla Calibration

Inicia una calibración de medida. Si se pulsa Menu/Dialog, Cal, aparece el asistente para calibración. De lo contrario, si se pulsa la tecla Cal aparece la barra de herramientas Active Entry de calibración.


Cancel pop

Tecla Cancel

Cierra un cuadro de diálogo.


Channel Pop

Tecla Channel

Con esta tecla se puede seleccionar un canal activo o eliminar un canal. Para modificar su configuración, el canal debe estar activo.


Chnl Set

Teclas de configuración de canales

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas se puede:

  • Configurar un canal con diversas configuraciones de estímulo.

  • Realizar una calibración de medida.

Volver al panel frontal


Cmd Keys

Teclas de comandos

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas se puede:

  • Ejecutar comandos en un cuadro de diálogo.

  • Mostrar menús o cuadros de diálogo.

  • Iniciar la Ayuda del analizador

Volver al panel frontal


Decimal Pop

Tecla de coma decimal

Introduce una coma decimal para designar fracciones de números enteros.


Display Keys

Teclas de visualización

Véase asimismo...

Con estas teclas se puede:

  • Gestionar y crear trazas y ventanas.
  • Configurar rápidamente un conjunto de medidas.
  • Ordenar la visualización de las medidas actuales.

Volver al panel frontal


Enter Pop

Tecla Enter

Introduce los valores que se seleccionan para la configuración de medidas.


Entry Keys

Teclas de introducción

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas es posible introducir valores para configurar las medidas.

Volver al panel frontal


F keys pop

Teclas F1, F2, F3, F4

Selecciona las opciones de la barra de herramientas Active Entry. El color de la tecla corresponde a la opción de la barra de herramientas Active Entry.


Format Pop

Tecla Format

Permite seleccionar el formato que utiliza el analizador para mostrar los datos de medida.


Help pop

Tecla Help

Inicia la Ayuda del analizador (documentación integrada).


Limit Pop

Tecla Limit Table

Muestra la tabla de los valores que permiten crear pruebas de tipo superada/fallida en función de estos segmentos límite.


Macro Pop

Tecla Macro / Local

  • Cuando se controla el analizador mediante automatización, al pulsar esta tecla el analizador puede responder cuando se pulsan las teclas del panel frontal.

  • Cuando el analizador está funcionando de forma normal, al pulsar esta tecla se accede a un conjunto de macros de usuario que aparecen en forma de archivos ejecutables. Se pueden titular y almacenar hasta 12 macros. Si se pulsa esta tecla repetidamente, los títulos mostrados en la barra de herramientas Active Entry irán mostrando alternativamente los tres conjuntos de cuatro títulos.

Nota: Es necesario tener instaladas en el disco duro del analizador las aplicaciones necesarias para ejecutar los archivos ejecutables en el conjunto de macros.


Math Mem

Tecla Math / Memory

Con esta tecla es posible seleccionar funciones matemáticas y de memoria que realiza el analizador con los datos de medida.


Meas

Tecla Measure

Permite seleccionar una medida de parámetros S. A través del cuadro de diálogo también se puede seleccionar una relación arbitraria, o una medida de potencia sin cálculo de relación.


Meas Set

Tecla Measure Setups

Con esta tecla es posible elegir entre cuatro configuraciones de medida preconfiguradas.


Menu Di

Tecla Menu / Dialog

Permite examinar los menús con las teclas de desplazamiento. También es posible ver los cuadros de diálogo pulsando Menu/Dialog y, a continuación, una tecla en los bloques Channel, Trace o Utility.


Min Max

Tecla Restore Up/Down

Cambia la ventana seleccionada al tamaño de pantalla de medida completa y, a continuación, la restaura al tamaño de ventana anterior.


Mkr

Tecla Marker

Permite activar un marcador y establecer el valor. Los marcadores ofrecen una lectura numérica de los datos medidos.


Mkr Func

Tecla Marker Function

Permite cambiar las configuraciones de medida, en función de la ubicación de un marcador activo. Si no se muestra ningún marcador, con esta tecla se activará un marcador.


Mkr Sch

Tecla Marker Search

Da acceso a las funciones de búsqueda de marcadores. Si no se muestra ningún marcador, con esta tecla se activará un marcador.


Mkr Tbl

Tecla Marker Table

Con el área de la tabla es posible ver tres tablas: 1) La tabla de marcadores, que muestra la lectura de datos de todos los marcadores en la traza activa. 2) La tabla de barridos de segmentos, que muestra las configuraciones de cada segmento. 3) La tabla de límites, que muestra las configuraciones de cada límite.


nav_pop

Teclas de desplazamiento

Teclas de flecha -

Controlan la ubicación del cursor en los menús y cuadros de diálogo

Izquierda / Derecha -

  • Permiten desplazarse hacia la izquierda y la derecha por los menús

  • Desplazan el tabulador hacia la izquierda y la derecha en los cuadros de diálogo

Arriba /Abajo -

  • Permiten desplazarse hacia arriba y hacia abajo por los menús

  • Su comportamiento en un cuadro de diálogo es el siguiente:

    • Modifica un valor numérico

    • Se desplaza a través de los elementos en una lista desplegable

    • Se mueve a través de los botones de opción en un grupo de botones de opción

Click -

Realiza selecciones de la misma manera que con un clic del ratón


navkeys2

Teclas de desplazamiento

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas se puede:

  • seleccionar las opciones de la barra de herramientas Active Entry

  • desplazarse a través de menús y cuadros de diálogo

Volver al panel frontal


Numeric

Teclas numéricas

Seleccionar los valores de configuración de medida y, a continuación, pulsar Enter o G/n o M/u para completar la selección.


OK pop

Tecla OK

Cierra un cuadro de diálogo e introduce cualquier valor establecido en el cuadro de diálogo.


On

Interruptor de alimentación

Cuando se pulsa, el analizador alterna entre los estados de encendido y suspensión.

  • Cuando se encuentra encendido, el botón se ilumina en verde.

  • Cuando se encuentra en el estado de suspensión, la luz del botón es de color ámbar.

  • Para apagar el analizador, pulsar el botón de alimentación: el instrumento guardará los estados de todos los programas que se estén ejecutando y se apagará.

  • Si se pulsa el botón de nuevo, el instrumento cargará los estados que se guardaron en el momento en que se apagó.

Este interruptor no está conectado a la fuente de alimentación.

Volver al panel frontal


PMB Pop

Tecla Más - Menos - Retroceso

  • Alterna entre una entrada de valor positivo y negativo si es la primera tecla pulsada en la entrada.

  • Hace retroceder el cursor y borra cualquier selección anterior.


Power Pop

Tecla Power

Permite especificar el nivel de potencia de la fuente.


Preset Pop

Tecla Preset

Cambia el analizador a su estado de preajuste (predeterminado).


Print Pop

Tecla Print

Inicia una función de impresión, permitiendo seleccionar las condiciones de impresión y la impresora.


Probe Pwr

Potencia de sonda

Los conectores de 3 patillas (m) suministran alimentación para las sondas activas.

  • Patilla superior: Tierra

  • Patilla izquierda: +15 Vcc ±2%, 400 mA máximo; protegida por PTC a 0,5 A

  • Patilla derecha: -12,6 Vcc ±5%, 300 mA máximo; protegida por PTC a 0,5 A

(PTC = fusible de actuación lenta reiniciable automáticamente)

Volver al panel frontal


Recall Pop

Tecla Recall

Con esta tecla se puede recuperar un archivo que contenga un estado de instrumento, una calibración de medida y datos de medida.


RPG

Mando del panel frontal

Se gira para aumentar o disminuir el valor de la entrada activa.


Save Pop

Tecla Save

Permite guardar en un archivo estados de instrumento, datos de calibración y datos de medida.


Escala

Tecla de escala

Permite especificar el valor que utiliza el analizador para ajustar la respuesta de medida mostrada. También se puede dejar que el analizador ajuste de forma automática las escalas del eje Y axis para adaptarlas a la traza de medida completa de la pantalla.


Pantalla

Véase asimismo...

  • Explorar el gráfico con el ratón.

Esta pantalla tiene las siguientes características:

  • LCD de matriz activa (TFT), 8,4 pulgadas

  • Resolución: resolución de 640 x 480

  • Velocidad de renovación vertical: 59,83 Hz

  • Velocidad de renovación horizontal: 31,41 kHz

  • Brillo: >250 NIT

Volver al panel frontal.


Stop Span

Tecla Stop / Span

Permite introducir un valor para la parada o el recorrido del rango de medida.


Strt Cntr

Tecla Start / Center

Permite introducir un valor para el inicio o el centro del rango de medida.


Swp Set

Tecla Sweep Setup

Permite definir la manera en que la fuente del analizador aporta un estímulo a un dispositivo sometido a prueba.


Swp Type

Tecla Sweep Type

Permite seleccionar la manera en que la fuente del analizador realiza el barrido y las propiedades asociadas al barrido.


Test Ports

Puertos de verificación

Véase asimismo...

Dos puertos de tipo N (hembra) de 50 ohmios cambian entre el receptor y la fuente de RF del analizador, permitiendo medir el dispositivo en dos direcciones.

  • Un piloto verde indica el puerto de la fuente.

  • Un piloto naranja indica el puerto del receptor.

Niveles de daños de las entradas:

Nivel de CW: +15 dBm
Nivel de tensión de CC: ±30 V

Volver al panel frontal


Trace pop

Tecla Trace

Cuando se pulsa por primera vez aparece la barra de herramientas de traza activa. Si se pulsa más veces se puede hacer un recorrido por las trazas de medida de una ventana, activando cada traza alternativamente. Sólo es posible modificar funciones activas. Con esta tecla también es posible crear o eliminar trazas, utilizando las teclas de función.


Configuración de trazas

Teclas de configuración de trazas

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas se puede:

  • Configurar un tipo de medida.

  • Extraer datos de los resultados.

Volver al panel frontal


Trigger Pop

Tecla Trigger

Permite especificar cómo se inicia el barrido de una medida.


Units Pop

Teclas de unidades

Realiza la selección de valores, asignando una unidad de medida. A continuación, pulsar Enter para completar la entrada del valor.


USB

Conector USB

Con el bus serie universal (USB) es posible controlar el analizador utilizando un teclado y otros dispositivos de puntero. Este conector también admite módulos de calibración electrónica.

Contacto 1: Vcc; 4,75 a 5,25 Vcc, 500 mA máximo
Contacto 2: -Datos
Contacto 3: +Datos
Contacto 4: Tierra

Volver al panel frontal


Utility Keys

Teclas de utilidades

Véase asimismo...

Examinar el gráfico para familiarizarse con las funciones de cada tecla específica:

Con estas teclas se puede:

  • Imprimir resultados de medidas.

  • Guardar o recuperar lo siguiente:

    • Estados de instrumento

    • Calibraciones de medida

    • Datos de medidas

  • Ejecutar macros.

  • Cambiar el tamaño de la ventana.

  • Preajustar el analizador.

Volver al panel frontal


Window pop

Tecla Window

Cuando se pulsa por primera vez aparece la barra de herramientas de ventana activa, en la que se puede crear, seleccionar y eliminar ventanas, utilizando las teclas de función. Si se pulsa más veces, se puede hacer un recorrido por las ventanas que están configuradas actualmente, activando cada ventana alternativamente. Sólo es posible modificar el tamaño de la ventana activa. La ventana también deberá estar activa para poder mostrar las trazas en la ventana.


Cómo utilizar la Ayuda

Cómo utilizar la Ayuda del analizador

Véase asimismo...

La Ayuda contiene la documentación completa del analizador. Haga clic en un botón para aprender rápidamente cómo utilizar la ayuda y responder a preguntas sobre el analizador.

Localizar información en la Ayuda

Imprimir el tema actual de la Ayuda

Cambiar el tamaño y la posición de la ventana de la Ayuda

Cerrar la ventana de la Ayuda


Bias In

Conectores de entrada de polarización

Entrada de polarización del puerto de verificación:

Este conector BNC (h) permite aplicar una polarización externa al puerto de verificación.

  • Tensión máxima: ±30 Vcc, típica

  • Corriente máxima: ±1 A (±200 mA sin degradación de las especificaciones de RF)*

Fusible de polarización del puerto de verificación:

Se trata de un fusible sin tiempo de retardo de dos patillas con un régimen de 1 A, 125 V

*Hasta un nivel de 200 mA, el instrumento cumplirá todas sus especificaciones de RF. A medida que se aumente la polarización de CC, especialmente a frecuencias de RF bajas (es decir, normalmente <100 MHz, pero predominantemente >10 MHz), se degradarán el acoplamiento entre fuentes corregido para frecuencias bajas y la directividad. Por encima de una RF de 100 MHz, con una polarización de hasta 1 A, existe muy poca degradación en el acoplamiento entre fuentes corregido y la directividad.

Volver al panel posterior


Ext AM

Conector de entrada de AM externa

Este conector BNC (h) permite introducir una tensión que proporciona modulación de AM de baja frecuencia a la señal de salida del puerto de verificación. También se podría introducir una tensión para desplazar el nivel de potencia de salida del puerto de verificación. Una entrada de 0 voltios no afecta al nivel de potencia. Una entrada de tensión positiva desplaza la potencia del puerto de verificación a un nivel más alto. Una tensión negativa desplaza la potencia a un nivel más bajo.

  • Sensibilidad de entrada: 8 dB/voltio, típica

  • Ancho de banda : 1 kHz, típico

  • Impedancia de entrada: 1 kW, típica

Volver al panel posterior


Ext Det

Conector de entrada de detector externo

Este conector BNC (h) permite introducir CC desde un detector de diodos externo con polaridad negativa para controlar el nivel de potencia en los puertos de verificación. Para que el analizador acepte esta entrada externa, es necesario que la casilla External ALC esté seleccionada en el cuadro de diálogo Sweep Setup.

  • Sensibilidad de entrada: -500 mV aporta aproximadamente -3 dBm en la entrada del detector

  • Ancho de banda: 50 kHz, típico

  • Impedancia de entrada: 1 kW, típica

Volver al panel posterior


ExtTrig

Conector auxiliar de entrada/salida

Permite introducir una señal externa para activar el analizador, iniciando así una medida. Para que el analizador detecte este disparo externo, es necesario ajustar la fuente de disparo a externa y especificar si el nivel TTL tiene una pendiente negativa o positiva.

  • Nivel TTL de salida de preparado para disparo (patilla 18)

  • Nivel TTL de entrada de disparo externo, pendiente positiva o negativa (patilla 19)

Volver al panel posterior


FRef

Conectores de referencia de 10 MHz

Entrada de referencia de 10 MHz

Con este conector BNC (h), el analizador puede funcionar con una señal de referencia externa que tiene las siguientes características:

  • Frecuencia de entrada: 10 MHz ± 1 ppm, típica

  • Nivel de entrada: De -15 a +20 dBm, típico

  • Impedancia de entrada: 200 W, nominal

Salida de referencia de 10 MHz

Este conector BNC (h) aporta una señal de referencia de frecuencia con las siguientes características:

  • Frecuencia de salida: 10 MHz ±10 ppm

  • Tipo de señal: onda sinusoidal

  • Nivel de salida: 10 dBm ±4 dB en 50 ohmios

  • Impedancia de salida: 50 ohmios

  • Armónicos: < -40 dBc

Volver al panel posterior


GPIB

Conector GPIB (General Purpose Interface Bus - Bus de interfaz de uso general)

Este conector hembra de tipo D-24 y 24 patillas es compatible con IEEE-488.

Volver al panel posterior


Conector de LAN

Conector de red local (LAN)

Esta conexión Ethernet 10/100BaseT tiene una configuración estándar de 8 patillas y selecciona automáticamente una de las dos velocidades de transferencia de datos.

Volver al panel posterior


Parallel

Conector del puerto de interfaz paralelo (LPT1)

Este conector mini-D hembra de 36 patillas, 1284-C, permite conectar el analizador a una impresora o a cualquier otro periférico provisto de un puerto paralelo.

Se incluye un adaptador que permite realizar una conexión entre este puerto paralelo y un puerto Centronics.

Volver al panel posterior


Serial

Conector del puerto de interfaz serie (COM1)

Este conector D-sub macho de 9 patillas es compatible con RS-232.

Volver al panel posterior


USB Connector

Conector de bus serie universal (USB)

Este conector de bus serie universal tiene una configuración de tipo A (4 contactos en línea: contacto 1 a la izquierda) hembra:

  • Contacto 1: Vcc: 4,75 a 5,25 Vcc, 500 mA máximo

  • Contacto 2: -Datos

  • Contacto 3: +Datos

  • Contacto 4: Tierra

El contacto 1 está protegido por un fusible reiniciable automáticamente con un régimen de 1 A. Se puede conectar un ratón, un teclado u otro dispositivo de puntero USB.

Volver al panel posterior


VGA Output

Conector de salida del adaptador de gráficos de vídeo (VGA)

Este conector D-sub hembra de 15 patillas permite conectar monitores VGA externos con las siguientes resoluciones. Se pueden visualizar simultáneamente las pantallas externa e interna.

Dispositivo | Resolución
Panel plano (TFT) | 1.024 x 768, 800 x 600, 640 x 480
Panel plano (DSTN) | 800 x 600, 640 x 480
Monitor con tubo de imagen | 1.280 x 1.024, 1.024 x 768, 800 x 600, 640 x 480

Nota: Si el analizador está configurado con la resolución predeterminada (640 x 480), será posible visualizar tanto el analizador como el monitor externo. Si se cambia la resolución del analizador a través del panel de control a una configuración que no sea la predeterminada, sólo se podrá visualizar el monitor externo. Para cambiar la resolución: En el menú System, hacer clic en Windows Taskbar, Settings, Control Panel. A continuación, hacer clic en el icono Display y en la ficha Settings.

Volver al panel posterior


Diafonía

Véase asimismo...

Diafonía del receptor

Descripción general

Conceptos

Cómo reducir
la diafonía

La diafonía es una fuga de energía que se produce entre las rutas de señales del analizador. Puede presentar un problema con las medidas de transmisión con alta pérdida. Sin embargo, se pueden reducir los efectos de la diafonía a través de la elección de una calibración de barrido y de medida.
Conceptos

Cómo reducir la diafonía del receptor

Deben considerarse los siguientes aspectos de la diafonía:

  • La fuga de energía entre las rutas de señales del analizador contribuye a la aparición de errores en una medida de la transmisión.

  • La diafonía puede afectar a las siguientes medidas:

    • Dispositivos con elevada pérdida (como un interruptor en la posición abierta)

    • Dispositivos con alto margen dinámico (como filtros)

Para reducir la diafonía del receptor, debe hacerse lo siguiente:
Ajustar el barrido a alternado

Realizar una calibración de medida

Ajustar el barrido a alternado

Este barrido contribuye a reducir la d iafonía del receptor debido a lo siguiente:

  • El barrido alternado sólo mide un receptor por barrido.

  • Cuando se mide un receptor, el analizador apaga el otro receptor.

Sugerencias:

  • El analizador mide la reflexión ( Receptor A) y la transmisión (Receptor r B) en barridos separados. Por consiguiente, cuando el analizador realiza medidas tanto de reflexión como de transmisión, el barrido alternado duplica el tiempo de ciclo del barrido.

  • Para medidas de transmisión únicamente o de reflexión únicamente, se puede utilizar el barrido alternado para reducir los efectos de la diafonía sin afectar al tiempo de ciclo del barrido.

  • El límite inferior del ruido tiene que reducirse considerablemente para que la diafonía resulte evidente. Tal vez sea necesario utilizar la función de promedio o reducir el ancho de banda de IF.

Realizar una calibración de medida

Para medidas de transmisión, una calibración de medida de la respuesta y el aislamiento contribuye a reducir la diafonía debido a lo siguiente:

  • El analizador mide y, a continuación, resta la señal de fuga durante la calibración de la medida.

  • La calibración mejora el aislamiento de modo que sólo esté limitado por el límite inferior del ruido.

Véase Errores sistemáticos / Aislamiento para obtener información sobre la manera en que se puede reducir la diafonía en el proceso de calibración.

Sugerencia:

  • Por lo general, el aislamiento desciende por debajo del límite inferior del ruido, por lo que cuando se realiza una calibración del aislamiento debería utilizarse una técnica de reducción de ruido, como promedios de barrido o la reducción del ancho de banda de IF.

Haga clic en los botones para acceder a los procedimientos de reducción de la d iafonía del receptor.
Ajustar el barrido a alternado
Realizar una calibración de la respuesta y del aislamiento

Ajustar el barrido a alternado
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Sweep Setup.

  2. Si el barrido alternado no está activado, seleccionar la casilla de verificación Alternate Sweeps.

  3. Hacer clic en OK.

Nota: El modo de barrido alternado se puede ajustar independientemente para cada canal de medida. Si se están utilizando varios canales de medida, tal vez se desee repetir este procedimiento para cada canal.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  3. Si el barrido alternado no está activado, pulsar la tecla de tabulador a la derecha en el bloque NAVIGATION, para pasar a la casilla Alternate Sweeps, y pulsar Click.

  4. En el bloque COMMAND, pulsar OK.

Nota: El modo de barrido alternado se puede ajustar independientemente para cada canal de medida. Si se están utilizando varios canales de medida, tal vez se desee repetir este procedimiento para cada canal.

Realizar una calibración de medida de la respuesta y del aislamiento
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Nota: Este procedimiento sólo se refiere a las medidas de transmisión.

  1. En el menú Calibration, hacer clic en Calibration Wizard.

  2. Bajo Select Calibration Type, hacer clic en Cal Type.

  3. Hacer clic en THRU Resp and Isol, OK.

  4. Seguir las indicaciones para realizar la parte restante de la calibración, seleccionando el tipo de patrones de calibración y el tipo de conector, y midiendo seguidamente los patrones cuando así se solicite. Véase Seleccionar y realizar una calibración de medida para obtener más información al respecto.

Procedimiento con las teclas del panel frontal

Nota: Este procedimiento sólo se refiere a las medidas de transmisión.

  1. En el bloque CHANNEL SETUP, pulsar Cal y, a continuación, F1 (Asistente para calibración).

  2. En el bloque NAVIGATION, pulsar Clicky, a continuación, las teclas de flecha hacia arriba y hacia abajo para pasar a THRU Resp and Isol, y seguidamente pulsar Click.

  3. En el bloque COMMAND, pulsar OK.

  4. Utilizando las teclas de NAVIGATION, seguir las indicaciones para realizar la parte restante de la calibración, seleccionando el tipo de patrones de calibración y el tipo de conector, y midiendo seguidamente los patrones cuando así se solicite. Véase Seleccionar y realizar una calibración de medida para obtener más información al respecto.


DPoints

Véase asimismo...

Número de puntos

Descripción general

Conceptos

Cómo incrementar
el número de puntos

Un punto de datos, o "punto", es una muestra de datos que representa una medida a un único valor de estímulo. Se puede especificar el número de puntos que el analizador mide durante un barrido.
Conceptos

Cómo incrementar el número de puntos

  • La mayoría de las operaciones de procesamiento de datos se realizan punto a punto. Un "barrido" es una serie de medidas consecutivas de puntos de datos, tomadas a lo largo de una secuencia de valores de estímulo.

  • Una gran cantidad de puntos de datos aumenta la resolución de la traza al definir mejor la respuesta del dispositivo.

  • El valor por defecto es 201 puntos por barrido.

51 puntos | 101 puntos | 401 puntos

El tiempo de barrido del analizador cambia proporcionalmente con el número de puntos. Sin embargo, el tiempo de ciclo de la medida en su conjunto no cambia. Véase Comprensión de las especificaciones técnicas para obtener más información sobre la manera en que el número de puntos, y otros valores, afectan al tiempo de barrido.

Sugerencias:

  • Para conseguir la mayor resolución de traza, utilizar el máximo número de puntos de datos.

  • Para conseguir el rendimiento más rápido, utilizar el menor número de puntos de datos que aporten una precisión aceptable.

  • Para determinar un número de puntos optimizado, buscar un valor en el que no haya una diferencia significativa en la medida cuando se incremente el número de puntos.

  • Para asegurar que la calibración de medida sea exacta, realizar la calibración con el mismo número de puntos que se utilizarán para la medida.

Pulsar los botones para acceder a los procedimientos utilizados para incrementar el número de puntos de datos y la precisión de la medida.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el bloque Sweep, hacer clic en Number of Points.

  2. Seleccionar uno de los valores presentados, o Custom para introducir un valor cualquiera.

  3. Click OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  2. En el bloque NAVIGATION, pulsar F2 (Puntos) y las teclas de flecha hacia arriba y hacia abajo para seleccionar un valor y, a continuación, pulsar Click.

  3. O bien, en el bloque ENTRY, introducir un valor cualquiera y, a continuación, pulsar Enter.


Meas Thru

Aumentar el rendimiento de medida

Véase asimismo...

Haga clic en un botón para obtener información sobre la manera de optimizar las medidas para aumentar el rendimiento.

Conseguir el barrido más rápido

Cambiar rápidamente entre varios estados de medida

Conseguir la velocidad de transferencia de datos más rápida


Optimize

Optimizar medidas

Véase asimismo...

Una medida tiene numerosos parámetros interdependientes. Se pueden modificar los parámetros para alcanzar los objetivos de la aplicación de medida: rendimiento más rápido o datos más exactos. Adaptando cuidadosamente la configuración se pueden equilibrar los parámetros para optimizar los resultados de la medida.
Aumentar el rendimiento de medida

Conseguir el barrido más rápido

Cambiar entre varios estados de medida

Conseguir la velocidad de transferencia de datos más rápida
Mejorar la precisión de las medidas

Aumentar el margen dinámico

Incrementar el número de puntos de datos

Mejorar la precisión de fase

Mejorar la precisión de las medidas para dispositivos eléctricamente largos

Mejorar la precisión de la reflexión para dispositivos de 2 puertos con baja pérdida

Aumentar la estabilidad de las medidas

Reducir el ruido de las trazas

Reducir la diafonía del receptor

Reducir los efectos de los accesorios de prueba


Stable

Véase asimismo...

Estabilidad de medida

Descripción general

Conceptos

Cómo aumentar la
estabilidad de las medidas

Hay varias situaciones que pueden provocar medidas inestables. Para asegurar que se están realizando medidas repetibles, se pueden utilizar diversos métodos para crear un entorno de medida estable.
Conceptos

Cómo aumentar la estabilidad de las medidas

Los siguientes factores pueden afectar adversamente a la exactitud de las medidas. Haga clic en un botón para mostrar información acerca de estos temas:
Deriva de frecuencia
Deriva de temperatura
Calibraciones inexactas de medidas
Conexiones de dispositivos

Deriva de frecuencia

La precisión de frecuencia del analizador está basada en un oscilador de frecuencia interno de 10 MHz. Véase Comprensión de las especificaciones técnicas para obtener las especificaciones de estabilidad y de deriva con el tiempo.

Si la aplicación de medida necesita mayor precisión de frecuencia y estabilidad, el usuario podrá anular el patrón de frecuencia interno y aportar su propia fuente de frecuencia externa de alta estabilidad a través del conector Reference Input de 10 MHz situado en la panel posterior.

Deriva de temperatura

La expansión y contracción térmica cambian las características eléctricas de los siguientes componentes:

  • Dispositivos situados en el interior del analizador

  • Patrones de kits de calibración

  • Dispositivos de prueba

  • Cables

  • Adaptadores

Para reducir los efectos de la deriva de temperatura en las medidas, se debe hacer lo siguiente:

  • Utilizar un entorno en el que la temperatura esté controlada.

  • Asegurar la estabilidad de temperatura de los dispositivos del kit de calibración.

  • Evitar manipular innecesariamente los dispositivos del kit de calibración durante el procedimiento de calibración.

  • Asegurar que la diferencia entre la temperatura ambiente y la temperatura de calibración de las medidas sea de ±1 °C.

Calibraciones inexactas de medidas

Si una calibración de medida es inexacta, no se medirá la verdadera respuesta de un dispositivo sometido a prueba. Para asegurar que la calibración sea exacta, deberían considerarse las siguientes prácticas:

  • Realizar una calibración de medida en los puntos en los que se conecta el dispositivo sometido a prueba, es decir, el plano de referencia.

  • Si se inserta cualquier accesorio adicional (cable, adaptador, atenuador) en la configuración de prueba después de haber realizado una calibración de medida, deberá utilizarse la función de extensiones de puerto s para compensar la longitud eléctrica y el retardo añadidos.

  • Utilizar patrones de calibración que coincidan con las definiciones utilizadas en el proceso de calibración.

Véase el apartado Calibraciones precisas de medidas para obtener información más detallada.

Conexiones de dispositivos

Las conexiones correctas son necesarias para poder realizar medidas repetibles. Para realizar conexiones correctas, hacer lo siguiente:

  • Inspeccionar y limpiar los conectores de todos los componentes de la configuración de medida.

  • Utilizar técnicas de conexión adecuadas.

  • Evitar mover los cables durante una medida.

Haga clic en los botones para ver los procedimientos utilizados para aumentar la estabilidad de las medidas.
Utilizar una referencia de frecuencia externa
Controlar la temperatura ambiente
Estabilizar la temperatura de los patrones de calibración
Véase Calibraciones precisas de medidas
Realizar conexiones correctas

Utilizar una referencia de frecuencia externa

  1. Introducir la señal de la referencia de frecuencia externa en el conector del panel posterior de la manera mostrada.

  • Frecuencia de entrada: 10 MHz ±10 ppm

  • Nivel de entrada: de -15 a +20 dBm

  • Impedancia de entrada: 200 ohmios

Controlar la temperatura ambiente

  1. Encender el analizador media hora antes de realizar una calibración de medida o de realizar una medida de un dispositivo.

  2. Realizar medidas de dispositivos en un entorno en el que la temperatura esté controlada.. Todas las especificaciones y características son aplicables en un margen de 25 °C ±5 °C (a menos que se indique lo contrario).

  3. Asegurar que la diferencia entre la temperatura ambiente y la temperatura de calibración de las medidas sea de ±1 °C.

Estabilizar la temperatura de los patrones de calibración

  1. Una hora antes de realizar una calibración de medida, abrir la caja del kit de calibración y extraer los patrones de la espuma protectora.

  2. Cuando se realice una calibración de medida, evitar manipular innecesariamente los dispositivos del kit de calibración.

Realizar conexiones correctas

  1. Inspeccionar todos los conectores, utilizando ampliación. Buscar los siguientes indicios de daños:

    • Chapado desgastado

    • Conductores centrales doblados, rotos o desalineados

    • Rayas profundas, abolladuras, terminales redondeados

    • Suciedad o partículas metálicas

  2. Limpiar todos los conectores con alcohol isopropilo y bastoncillos de algodón que no suelten pelusa.

    1. Dejar que se evapore el alcohol.

    2. Utilizar aire comprimido para secar suavemente el conector.

  3. Conectar los dispositivos correctamente.

    1. Utilizar una almohadilla y una muñequera antiestáticas para conectarse a tierra y conectar también a tierra todos los dispositivos.

    2. Alinear los conectores y acoplarlos correctamente.

    3. Girar únicamente la tuerca del conector.

    4. Utilizar una llave de apriete para realizar la conexión final.


TDGuide

Medidas en el dominio del tiempo

Véase asimismo...

Si el analizador dispone de la opción de dominio de tiempo 010, podrá verse una respuesta del dispositivo como función del tiempo. Haga clic en los botones para tener acceso a la información.
Descripción general del dominio del tiempo
Modos de paso de banda y paso bajo del dominio del tiempo
Resolución y rango en el dominio del tiempo
Filtro de ventana para los datos mostrados
Filtro de puerta de tiempo
Datos de medida en el dominio del tiempo


3_Tab

3-Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4_Tab

4-Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6_Tab

6-Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


 Barra de herramientas Active Entry Barra de herramientas de medida Barra de herramientas de control de barridos Barra de herramientas de estímulo Barra de herramientas de marcadores Barra de estado de trazas Tablas

Véase asimismo...

Personalizar la pantalla del analizador

Descripción general

Barras de herramientas
y tablas

Estado de
medida

Cómo cambiar
la configuración de la pantalla

Se puede personalizar la pantalla del analizador para que se muestren u oculten diversos elementos.
Barras de herramientas y tablas

Estado de medida

Cómo cambiar la configuración de la pantalla

Explore el gráfico con el ratón para conocer las diversas partes de la pantalla:
Barra de estado
Barras de herramientas

Active Entry

Marcadores

Medida

Control de barrido

Estímulo

Desactivar todo
Tablas

Tabla de marcadores

Tabla de límites

Tabla de segmentos

Barra de estado

La barra de estado aparece en la parte inferior de la pantalla.

Muestra:

  1. C anal activo

  2. Parámetro de medida de la traza activa

  3. Estado de corr e cción de errores de la traza activa

  4. Estado de p romediado del canal activo (activado o desactivado)

  5. Estado de GPIB (local o remoto)

Barras de herramientas

Se pueden visualizar hasta seis barras de herramientas diferentes. Permiten configurar y modificar fácilmente las medidas.

Barra de herramientas Active Entry

La barra de herramientas Active Entry (entrada activa) aparece en la parte superior de la pantalla, debajo de la barra de menús. Esta barra permite realizar selecciones desde la función activa.

Muestra:

  • Elecciones de teclas programables para la función activa, para realizar operaciones a través de las teclas del panel frontal

Barra de herramientas de marcadores

La barra de herramientas de marcadores aparece justo encima de las ventanas situadas en la parte superior de la pantalla. Esta barra permite configurar y modificar marcadores.

Muestra:

  • Número de marcador

  • Valor de estimulación

  • Funciones de marcador

    • Delta

    • Start/Stop

    • Center/Span

Barra de herramientas de medida

La barra de herramientas de medida aparece encima de las ventanas situadas en la parte superior de la pantalla. Esta barra permite:

  • Crear una nueva traza para una medida deseada de parámetros S en:

    • la ventana actual

    • una nueva ventana

Barra de herramientas de control de barrido

La barra de herramientas de control de barrido aparece encima de las ventanas situadas en la parte superior de la pantalla. En orden, los botones de esta barra de herramientas ajustan el canal activo a:

  • Modo Hold

  • Barrido Single, después modo Hold

  • Barrido Continuous

Véase Activador para obtener más información.

Barra de herramientas de estímulo

La barra de herramientas de estímulo aparece encima de las ventanas situadas en la parte superior de la pantalla. Esta barra permite visualizar, configurar y modificar el estímulo de barrido.

Muestra:

  • Valor de inicio

  • Valor de parada

  • Número de puntos

Desactivar todo

Permite: ocultar todas las barras de herramientas con una única selección.

Tablas

Se pueden visualizar tablas de marcadores, límites o segmentos que permiten visualizar, configurar y modificar (excepto la tabla de marcadores) su configuración.

  • Las tablas se muestran en la parte inferior de la ventana seleccionada.

  • En una ventana sólo puede mostrarse al mismo tiempo una tabla.

Tabla de marcadores

Se puede visualizar una tabla de configuración de marcadores. Dicha configuración incluye:

  • Número de marcador

  • Referencia de marcador (para medidas delta)

  • Frecuencia

  • Respuesta

Tabla de límites

Se puede visualizar, configurar y modificar una tabla de configuración de pruebas de límites. Dicha configuración incluye:

  • Tipo (MIN, MAX u OFF)

  • Valores de estímulo iniciales y finales

  • Valores de respuesta iniciales y finales

Tabla de segmentos

Se puede visualizar, configurar y modificar una tabla de configuración de barridos de segmentos. Dicha configuración incluye:

  • Estado (activado/desactivado)

  • Frecuencias de inicio y de parada

  • Número de puntos

  • A ncho de banda de IF (si los niveles son independientes)

  • Nivel de potencia (si los niveles son independientes)

  • Tiempo de barrido (si los niveles son independientes)

Estado de medida

Estado de traza

Estímulo de frecuencia

Lectura de marcador

Resultados de prueba de límite

Líneas límite

Título
Traza de datos
Traza de memoria
Barras de título

Estado de medida

Se pueden visualizar u ocultar seis tipos de datos de medidas:

  • Estado de traza

  • Valores de frecuencia/estímulo

  • Valores de lectura de marcador

  • Resultados de prueba de límite

  • Líneas l ímite

  • Títulos

Estado de traza

El estado de traza aparece a la izquierda de cada ventana de la pantalla.

Muestra:

  • Parámetro de medida

  • Formato

  • Factor de escala

  • Nivel de referencia

Frecuencia/estímulo

La información de la frecuencia/estímulo aparece en la parte inferior de cada ventana de la pantalla. Esta información puede ocultarse por motivos de seguridad. Muestra:

  • Número de canal

  • Valor de inicio

  • Valor de parada

Lectura de marcador

La información de la lectura de marcador aparece en la esquina superior derecha de cada ventana de la pantalla. Muestra:

  • Número de marcador

  • Valor de estímulo

  • Valor de respuesta en el formato seleccionado del marcador

Resultados de prueba de límite

Los resultados de prueba de límite aparecen a la derecha de la ventana designada. Estos resultados pueden ser:

  • Superada o Fallida

Líneas límite

Las líneas límite se muestran para la traza activa de la ventana designada. Su posición depende de:

  • Niveles de límite

  • Formato

  • Escala

  • Nivel de referencia

Título

Se puede crear y visualizar un título de una ventana. Aparece el siguiente cuadro de diálogo Title Entry.

El título introducido aparece en la esquina superior izquierda de la ventana designada.

Traza de datos

Se puede ocultar una traza de datos seleccionada.

Traza de memoria

Se puede ocultar una traza de memoria seleccionada.

Barras de título

La información de la barra de título aparece en la parte superior de cada ventana de la pantalla. Muestra:

  • Número de ventana

Si se ocultan las barras de título, se ocultarán las de todas las ventanas de la pantalla; esto permite maximizar el área de la pantalla para mostrar los resultados de la medida.

Haga clic en los botones para acceder a los procedimientos.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú View, hacer clic en la anotación de pantalla deseada.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. Pulsar la tecla de tabulador a la derecha para seleccionar el menú View.

  3. Pulsar el botón de flecha hacia abajo para seleccionar la anotación de pantalla deseada.

  4. En el bloque COMMAND, pulsar OK.


Véase asimismo...

Formato de datos y escala

Descripción general

Conceptos

Cómo ajustar el
formato y la escala

El formato de datos es la forma gráfica en que el analizador presenta los datos de medida. La función Scale permite editar los datos de medida para obtener una óptima visualización.
Conceptos

Cómo ajustar el formato de datos y la escala

Debe elegirse un formato de datos apropiado para la información que se desea obtener sobre el dispositivo de verificación. Este tema facilita el conocimiento de los nueve formatos disponibles para obtener así la máxima información posible sobre los datos de medida. Asimismo, muestra cómo ajustar la escala para conseguir una visualización óptima de la información.
Formatos de pantalla rectangular (cartesiana)

Formato Log Mag

Formato Phase

Formato Group Delay

Formato Linear Mag

Formato SWR

Formato Real

Formato Imaginary
Formato Polar
Formato de diagrama de Smith
Scale

Auto Scale

Auto Scale All

Reference Level

Reference Position

Formatos de pantalla rectangular

Siete de los nueve formatos de datos disponibles utilizan una pantalla rectangular para presentar los datos de medida. Esta pantalla también recibe el nombre de cartesiana, X/Y o rectilineal. La pantalla rectangular:

  • Presenta el estímulo (frecuencia, potencia o tiempo) en el eje X, escalado de forma lineal

  • Presenta la información de respuesta en frecuencia del dispositivo de verificación con gran claridad

Los siete formatos de datos presentan los datos en el eje Y de manera diferente.

Formato Log Mag (magnitud logarítmica)

  • Muestra la magnitud (no la fase)

  • Eje Y: dB

  • Medidas típicas:

    • Pérdida de retorno

    • Pérdida por inserción o ganancia de inserción

Formato Phase

  • Muestra la fase (no la magnitud)

  • Eje Y: Fase (grados)

  • Medidas típicas:

  • Desviación respecto de la fase lineal

Formato Group Delay

  • Muestra el tiempo de transmisión de señales (propagación) a través de un dispositivo

  • Eje Y: Tiempo (segundos)

  • Medidas típicas:

    • Retardo de grupo

Formato Linear Magnitude

  • Sólo muestra valores positivos

  • Eje Y: Sin unidad

  • Medidas típicas:

    • coeficientes de reflexión y transmisión (magnitud)

    • transferencia en el dominio del tiempo

Formato SWR

  • Muestra datos de medida de reflexión calculados a partir de la fórmula (1 + r)/ (1 r) donde p es el coeficiente de reflexión.

  • Válido sólo para medidas de reflexión.

  • Eje Y: Sin unidad

  • Medidas típicas:

    • SWR (coeficiente de onda estacionaria)

Formato Real

  • Muestra sólo la parte real (resistiva) de los datos complejos medidos.

  • Puede mostrar valores tanto positivos como negativos.

  • Eje Y: Sin unidad

  • Medidas típicas:

    • dominio del tiempo

    • señal auxiliar de tensión de entrada para fines de mantenimiento

Formato Imaginary

  • Muestra sólo la parte imaginaria (reactiva) de los datos medidos.

  • Eje Y: Sin unidad

  • Medidas típicas:

    • impedancia para el diseño de la red de adaptación

Formato Polar

El formato polar contiene información de fase y de magnitud. Las cantidades se leen de forma vectorial de la siguiente manera:

  • La magnitud de cualquier punto está determinada por su desplazamiento respecto del centro (o valor cero). La magnitud se escala de forma lineal, con el valor del círculo exterior establecido en un valor de relación de 1.

  • La fase está determinada por el ángulo del eje X positivo.

  • Al no haber eje de frecuencia, la información de frecuencia se lee de los marcadores.

La escala de magnitud y de fase es lineal. Los formatos de magnitud logarítmica y real/imaginario están disponibles en el menú de marcadores polares.

Formato de diagrama de Smith

Para conocer la impedancia del dispositivo sometido a prueba, se utiliza el formato de diagrama de Smith para visualizar los datos de medida de reflexión en impedancia. El diagrama de Smith constituye un plano de impedancia representado sobre el plano polar.

Interpretación del diagrama de Smith

Cada uno de los puntos del diagrama de Smith representa una impedancia compleja formada por una resistencia real (r) y una reactancia imaginaria (r+-jX)

Los círculos de puntos representan una resistencia constante. La línea horizontal del medio es puramente resistiva (sin componente reactivo).

  • En el extremo de la derecha, el valor es infinito ohmios (abierto).

  • En el extremo de la izquierda, el valor es cero ohmios (cerrado).

Los arcos de puntos representan una reactancia constante.

  • Los arcos de reactancia de la mitad superior (positiva) del círculo representan la reactancia inductiva.

  • Los arcos de reactancia de la mitad inferior (negativa) del círculo representan la reactancia capacitiva.

Los valores mostrados en el analizador de redes se normalizan ajustándose a la impedancia característica del sistema. El centro exacto del diagrama es la impedancia característica del sistema.

Scale

Utilizar esta función para ajustar la escala de las divisiones verticales de la cuadrícula mostrada. En los formatos Polar y de diagrama Smit h, ajusta el valor completo de escala en la circunferencia exterior.

Rango: 0,001 dB/div a 500 dB/div

Autoscale

Esta función ajusta de forma automática la escala de la traza de datos verticalmente para ajustarla a la zona de la cuadrícula de la pantalla. Los valores de estímulo no se ven afectados, únicamente los valores de escala y referencia.

  • El analizador determina el factor de escala más pequeño que permitirá que se ajusten todos los datos mostrados al 80% de la cuadrícula vertical.

  • El valor de referencia se elige para centrar la traza en la pantalla.

Autoscale All

Esta función realiza lo mismo que Autoscale únicamente varía en que ajusta automáticamente la escala de todas las trazas de datos que se muestran en la ventana seleccionada para que se ajusten verticalmente a la zona de la cuadrícula de la pantalla.

Reference Level

Reference Level especifica el valor de la línea de referencia en los formatos cartesianos, o el círculo exterior en los formatos polares, en función del formato de datos seleccionado.

Rango: -500 dB a 500 dB.

Reference Position

Reference Position especifica la posición de la línea de referencia en la cuadrícula de una pantalla cartesiana con línea inferior cero y línea superior diez. La posición predeterminada es cinco.

Haga clic en los botones para acceder a los procedimientos utilizados para formatear datos y ajustar la escala.
Seleccionar el formato de datos
Seleccionar la escala manualmente
Seleccionar la escala automáticamente
Ajustar la línea de referencia

Seleccionar el formato de datos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Format.

  2. Hacer clic en el formato de datos deseado.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Format.

  2. Para seleccionar el formato Log Mag, pulsar F1 (Magnitud logarítmica).

  3. Para seleccionar el formato de diagrama Smith, pulsar F2 (Smith).

  4. Para seleccionar el formato Phase, pulsar F3 (Fase).

  5. Para seleccionar el formato Group Delay, pulsar F4 (Retardo).

  6. Para seleccionar uno de los otros cinco formatos de datos, continuar con el paso 7 de este procedimiento.

  7. Pulsar el botón Menu/Dialog del bloque COMMAND.

  8. En el bloque TRACE SETUP, pulsar Format.

  9. Utilizar el botón de tabulador a la derecha de NAVIGATION para seleccionar el formato de datos deseado. Pulsar el botón OK del bloque COMMAND.

Seleccionar la escala manualmente
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Scale, hacer clic en Scale. El cuadro de diálogo Scale aparecerá en la pantalla.

  2. En la parte Scale del cuadro de diálogo, hacer clic en la casilla Per Division. Escribir el valor o hacer clic en el botón de flecha para seleccionar el factor de escala.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Scale.

  2. Pulsar F2 (Escala) y escribir el valor o pulsar los botones de flecha hacia arriba o hacia abajo de NAVIGATION para ajustar el factor de escala deseado.

Seleccionar la escala automáticamente
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Scale, hacer clic en Autoscale o Autoscale All.

Otra forma de seleccionar la escala automáticamente es la siguiente:

  1. En el menú Scale, hacer clic en Scale.

  2. En la parte Scale del cuadro de diálogo, hacer clic en el botón AutoScale para establecer la escala automática para la traza seleccionada. O bien, hacer clic en el botón AutoAll para establecer la escala automática para todas las trazas de la ventana activa.

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Scale.

  2. Pulsar F1 (Escala automática) para establecer la escala automática para la traza seleccionada. Para seleccionar la escala automática para todas las trazas, continuar con el paso 3 de este procedimiento.

  3. Pulsar el botón Menu/Dialog del bloque COMMAND.

  4. En el bloque TRACE SETUP, pulsar el botón Scale.

  5. Utilizar el botón de tabulador a la derecha de NAVIGATION para seleccionar el botón AutoAll. Pulsar el botón OK del bloque COMMAND.

Seleccionar la línea de referencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Scale, hacer clic en Scale.

  2. En la parte Reference del cuadro de diálogo, hacer clic en la casilla Level. Escribir el valor o hacer clic en el botón de flecha para ajustar el nivel de referencia deseado.

  3. En la parte Reference del cuadro de diálogo, hacer clic en la casilla Position. Escribir el valor o hacer clic en el botón de flecha para ajustar la posición de referencia deseada.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Scale.

  2. Pulsar F3 (Nivel de referencia) y escribir el valor o pulsar los botones de flecha hacia arriba o hacia abajo de NAVIGATION para ajustar el nivel de referencia deseado.

  3. Pulsar F3 (Posición de referencia) y escribir el valor o pulsar los botones de flecha hacia arriba o hacia abajo de NAVIGATION para ajustar la posición de referencia deseada.


Véase asimismo...

Margen de frecuencias

Descripción general

Conceptos

Cómo ajustar el
margen de frecuencias

El margen de frecuencias es el recorrido de frecuencias que se especifica para realizar una medida de dispositivo.
Conceptos
Cómo ajustar el margen de frecuencias

Margen de frecuencias

Resolución de frecuencia

Frecuencias de CW

Márgenes de frecuencias para la serie PNA de analizadores:

E8356A
300 kHz a 3 GHz

E8357A
300 kHz a 6 GHz

E8358A
300 kHz a 9 GHz

Resolución de frecuencia

La resolución para ajustar la frecuencia es 1 Hz.

Frecuencias de CW

Medidas con un barrido de tiempo de CW o barrido de potencia ya que los estímulos se realizan a una única frecuencia y no a lo largo de un margen de frecuencias.

Nota:Los valores de frecuencia pueden ocultarse por motivos de seguridad.

Hay dos formas de ajustar el margen de frecuencias.

  • Especificar las frecuencias de inicio y de parada del margen.

  • Especificar la frecuencia central y el recorrido deseado del margen.
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Para ajustar el margen de frecuencias con las frecuencias de inicio y de parada:

  1. En el menú Channel, hacer clic en Start/Stop....

  2. Hacer clic en la casilla Start. Escribir el valor o pulsar los botones de flecha para seleccionar la frecuencia de inicio deseada del margen de barrido.

  3. Hacer clic en la casilla Stop. Escribir el valor o pulsar los botones de flecha para seleccionar la frecuencia de parada deseada del margen de barrido.

  4. Hacer clic en OK.

Para ajustar el margen de frecuencias con una frecuencia central y un recorrido deseado:

  1. En el menú Channel, hacer clic en Center/Span....

  2. Hacer clic en la casilla Center. Escribir el valor o pulsar los botones de flecha para seleccionar la frecuencia central deseada del margen de barrido.

  3. Hacer clic en la casilla Span. Escribir el valor o pulsar los botones de flecha para seleccionar la frecuencia de parada deseada del margen de barrido.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

Para ajustar el margen de frecuencias con las frecuencias de inicio y de parada:

  1. En el bloque CHANNEL SETUP, pulsar Start/Center o Stop/Span.

  2. Pulsar F1 (Inicio).

  3. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la frecuencia de inicio deseada del margen de barrido.

  4. Pulsar F2 (Parada).

  5. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la frecuencia de parada deseada del margen de barrido.

  6. Pulsar Enter.

Para ajustar el margen de frecuencias con una frecuencia central y un recorrido deseado:

  1. En el bloque CHANNEL SETUP, pulsar Start/Center o Stop/Span.

  2. Pulsar F3 (Centro).

  3. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la frecuencia central deseada del margen de barrido.

  4. Pulsar F4 (Recorrido).

  5. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la frecuencia de recorrido deseada del margen de barrido.

  6. Pulsar Enter.


Véase asimismo...

Parámetros de medida

Descripción general

Conceptos

Cómo establecer
parámetros

Se puede configurar el analizador para que mida las características eléctricas de un dispositivo utilizando los siguientes parámetros:

  • Parámetros S (relaciones fijas)

  • Relación arbitraria (el usuario elige sus propias medidas de relación)

  • Potencia sin cálculo de relación (potencia absoluta)
Conceptos

Cómo establecer parámetros de medida

Parámetros S

Medidas habituales con parámetros S

Diagrama de flujo de parámetros S
Relación arbitraria
Potencia sin cálculo de relación

Parámetros S

Los parámetros S (parámetros de dispersión) se utilizan para caracterizar la forma en que un dispositivo modifica una señal. Describen las propiedades de reflexión y de transmisión del dispositivo sometido a prueba. La anotación de los parámetros S identifica la relación de dos cantidades complejas utilizando la siguiente convención numérica:

S "salida entrada"
donde:

salida = | la salida de la señal; puerto del dispositivo de verificación donde se mide la respuesta
entrada = | la entrada de la señal; (señal incidente) puerto del dispositivo de verificación donde se aplica o se inyecta la señal

Desplazar el ratón sobre el gráfico para explorar el flujo de señales de cada parámetro S.

El analizador cuenta con dos puertos de verificación y puede medir dispositivos de uno o dos puertos. Se puede definir el puerto de verificación de entrada de las medidas de parámetros S. El analizador cambia automáticamente la dirección de la medida (esto es, progresiva o regresiva) en función de las selecciones realizadas. Por lo tanto, el analizador puede medir los cuatro parámetros S de un dispositivo de dos puertos con una única conexión.

Los parámetros S de un dispositivo de dos puertos son S11, S21, S12 y S22. Situar el ratón sobre cada uno de los parámetros S mostrados en la siguiente figura animada para ver la relación entre el flujo de señales y los parámetros S.

Los parámetros S de un dispositivo de dos puertos se muestran con más detalle en la siguiente figura, donde:

  • a = señal que entra en el dispositivo

  • b = señal transmitida a través del dispositivo.

Nota: Todos los parámetros S son valores lineales complejos.

Nota: La precisión de medida depende de la calidad de los patrones de calibración y de las técnicas de conexión de medida que se utilicen.

Nota: La precisión de las medidas de parámetros S depende en parte de cómo se termine el puerto de carga (sin estimulación del puerto). A menos que la carga sea perfecta, a1 o a2 no será cero (lo cual infringiría la definición de los parámetros S). Para realizar medidas precisas de parámetros S, es muy importante la c orrección d e errores de dos puertos, que corrige la fuente y la a daptación de carga . Véase la sección Calibración para obtener más información.

Medidas habituales con parámetros S

Los parámetros S son equivalentes a los siguientes términos comunes de medida.

Parámetro S | Definición | Descripción | Dirección
S11 | b1 / a1 donde a2 = 0 | coeficiente de reflexión (adaptación de entrada) | progresiva
S21 | b2 /a1 donde a2 = 0 | coeficiente de transmisión (ganancia o pérdida) | progresiva
S12 | b1 /a2 donde a1 = 0 | coeficiente de transmisión (aislamiento) | regresiva
S22 | b2 /a2, a1 = 0 | coeficiente de reflexión (adaptación de salida) | regresiva

Las medidas habituales con parámetros S incluyen:

Medidas de reflexión

Medidas de transmisión

  • Pérdida de retorno

  • Relación de onda estacionaria (SWR)

  • Coeficiente de reflexión

  • Im pedancia

  • S11, S22

  • Pérdida de i nserción

  • Coeficiente de transmisión

  • Ganancia/Pérdida

  • Retardo de grupo

  • Desviación respecto de la fase lineal

  • R etardo eléctrico

  • S21, S12

Diagrama de flujo de parámetros S

El siguiente diagrama de flujo es una representación gráfica del flujo de señales de un dispositivo de dos puertos o red sometida a prueba. Este diagrama de flujo también aparece impreso en el panel frontal del analizador.

Relación arbitraria

La relación arbitraria permite al usuario elegir su propia relación de señales de entrada y de referencia utilizando los receptores A, B, R1 y R2. Los usos habituales de la relación arbitraria son:

  • Medidas personalizadas en las que se utilizan las rutas directas hacia los receptores A, B, R1 y R2 y, a continuación, se eligen las medidas de relación propias.

  • Medidas que precisan un m argen dinámico superior al que proporciona el analizador con parámetros S.

Los receptores A, B, R1 y R2 cuentan con conexiones en el panel frontal del analizador.

  • Las conexiones A (in) y B (in) del panel frontal permiten una conexión directa con los receptores A y B. Esto:

    • proporciona una sensibilidad mayor al eliminar los acopladores de los puertos de verificación de la ruta de señales

    • elimina aproximadamente 15 dB de pérdida de la ruta del receptor A o B

  • Las conexiones A (out) y B (out) del panel frontal permiten un acceso directo desde los brazos acoplados de los acopladores de los puertos de verificación 1 y 2.

  • Las conexiones R1 y R2 del panel frontal permiten determinadas configuraciones de instrumento, como verificaciones de alta potencia con componentes externos utilizando amplificadores y acopladores (suministrados por el usuario).

En la siguiente figura se muestran las rutas de señales del analizador:

En las siguientes figuras se muestra la ubicación de estas conexiones en el panel frontal del analizador:

Opción 015

Con la opción de equipo de verificación configurable, se proporcionan circuitos de acceso en el panel frontal a la ruta de señales entre la salida de la fuente y la entrada del acoplador. También se añaden atenuadores de 35 dB (incrementos de 5 dB) en las rutas de receptor de ambos puertos. Esto ofrece la posibilidad de optimizar la sensibilidad de medida para medir señales de bajo nivel o añadir componentes u otros instrumentos periféricos para diversas aplicaciones de medida. Véase la guía didáctica Medidas de componentes de alta potencia para obtener más información

Potencia sin cálculo de relación

El parámetro de potencia sin cálculo de relación permite examinar la potencia absoluta de un dispositivo que llega a los receptores A, B, R1 y R2.

Nota: No se pueden utilizar entradas únicas para medidas de retardo de grupo o de fase , o cualquier medida que tenga el promediado activado.

Haga clic en los botones para acceder a los procedimientos.
Medida de parámetros S
Medida de relación arbitraria
Medida de potencia sin cálculo de relación

Medida de parámetros S
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Measure.

  2. Hacer clic en el parámetro S deseado.

Procedimiento con las teclas del panel frontal

  1. En el bloque TRACE SETUP, pulsar Measure.

  2. Pulsar F1 para seleccionar S11.

  3. Pulsar F2 para seleccionar S21.

  4. Pulsar F3 para seleccionar S12.

  5. Pulsar F4 para seleccionar S22.

  6. Pulsar Enter.

Medida de relación arbitraria
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Measure.

  2. Hacer clic en Measure....

  3. En el cuadro Trace Type, seleccionar Arbitrary Ratio.

  4. En el cuadro Source Port, seleccionar el puerto de fuente deseado.

  5. En el cuadro Input, seleccionar la entrada deseada.

  6. En el cuadro Output, seleccionar la salida deseada.

  7. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque TRACE SETUP, pulsar Measure.

  3. Pulsar la tecla de flecha hacia abajo para seleccionar Arbitrary Ratio en el cuadro Trace Type.

  4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Source Port. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el puerto de fuente deseado.

  5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Input. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la entrada.

  6. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Output. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la salida.

  7. En el bloque COMMAND, pulsar OK.

Medida de potencia sin cálculo de relación
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Trace, hacer clic en Measure.

  2. Hacer clic en Measure....

  3. En el cuadro Trace Type, seleccionar Unratioed Power.

  4. En el cuadro Source Port, seleccionar el puerto de fuente deseado.

  5. En el cuadro Input, seleccionar la entrada deseada.

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque TRACE SETUP, pulsar Measure.

  3. Pulsar la tecla de flecha hacia abajo para seleccionar Unratioed Power en el cuadro Trace Type.

  4. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Source Port. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar el puerto de fuente deseado.

  5. Pulsar la tecla de tabulador a la derecha para pasar al cuadro Input. Pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la entrada.

  6. En el bloque COMMAND, pulsar OK.


Trazas y canales múltiples

Véase asimismo...

Ver trazas y canales múltiples

Descripción general

Configuraciones
de medida

Organizar
la pantalla

Cómo visualizar...

Se pueden configurar medidas múltiples de diversas formas. Una vez que todo esté configurado, se pueden mover las ventanas y cambiar su tamaño para personalizar la pantalla del instrumento según las necesidades de visualización específicas.
Configuraciones de medida

Organizar la pantalla

Cómo visualizar trazas y canales múltiples

Canales, trazas y ventanas múltiples

Límites de medida
Configuraciones de medida preconfiguradas

Configuración A: 4 trazas, 1 ventana

Configuración B: 4 trazas, 4 ventanas

Configuración C: 3 trazas, 3 ventanas

Configuración D: 4 trazas, 2 canales, 2 ventanas

Canales, trazas y ventanas múltiples

  • Un canal cuenta con una serie de atributos independientes asociados a la recogida de datos. Estos atributos se aplican a todas las trazas asignadas a dicho canal. El analizador admite cuatro canales independientes.

  • Una traza tiene una serie única de atributos asociados a las operaciones matemáticas realizadas con los datos recogidos. El analizador admite hasta 16 trazas por pantalla.

  • Una ventana se utiliza para visualizar trazas. El analizador puede mostrar 1, 2, 3 o 4 ventanas en la pantalla.

Se pueden crear:

  • Trazas y canales múltiples para medir y visualizar las características del dispositivo que se está sometiendo a prueba

  • Ventanas múltiples para visualizar mejor los datos de medida

Límites de medida

  • Cuatro ventanas por pantalla

  • Cuatro trazas de datos y cuatro trazas de memoria por ventana

  • 16 trazas por pantalla

  • Cuatro canales de medida independientes

Configuraciones de medida preconfiguradas

Esta función ofrece un acceso directo para crear configuraciones de medida habituales utilizando trazas, canales y ventanas múltiples.

  • Hay cuatro configuraciones de medida preconfiguradas.

  • Cada configuración crea nuevas trazas.

  • Las trazas existentes y sus valores se perderán a menos que se guarden antes de utilizar esta función.

Configuración A

  • Cuatro trazas S11, S21, S12, S22

  • Una ventana, formato Log Mag

  • Un canal

    • S11, S21, S12, S22 en ventana 1

Configuración B

  • Cuatro trazas

  • Cuatro ventanas, formato Log Mag

  • Un canal

    • S11 en ventana 1

    • S21 en ventana 2

    • S12 en ventana 3

    • S22 en ventana 4

Configuración C

  • Tres trazas

  • Tres ventanas, dos en el formato de diagrama de Smith y una en formato Log Mag

  • Un canal

    • S11 en ventana 1, formato de diagrama de Smith

    • S22 en ventana 2, formato de diagrama de Smith

    • S21 en ventana 3, formato Log Mag

Configuración D

  • Cuatro trazas

  • Dos ventanas, ambas en formato Log Mag

  • Dos canales

    • S11 y S21 para canal 1 en ventana 1

    • S11 y S21 para canal 2 en ventana 2

Organizar la pantalla

Ventanas: Mosaico, Cascada, Organizar, Maximizar/Restaurar

Función de organización de ventanas

Superposición

Pila 2

División 3

Cuadrante 4

Algoritmo de clasificación

Organizar la pantalla

El analizador permite:

  • Mover o cambiar el tamaño de las ventanas del analizador con el ratón

  • Organizar las ventanas del analizador con las funciones de Mosaico, Cascada, Minimizar y Maximizar del menú Window.

  • Organizar las ventanas del analizador en cuatro configuraciones diferentes con la función Arrange Windows

  • Cambiar el tamaño u ocultar las ventanas del analizador utilizando las funcionesMaximizar, Restaurar y Minimizar de Microsoft Windows situadas en la esquina superior derecha de cada ventana

  • Maximizar una única ventana de una configuración de varias ventanas con:

    • El panel Maximizar situado en la esquina de la ventana

    • La tecla Maximize/Restore del panel frontal en el bloque UTILITY (utilizar la tecla Window del bloque DISPLAY para seleccionar)

Función Arrange Windows

La función Arrange Windows:

  • Ofrece cuatro organizaciones de ventana

    • Superposición

    • Pila 2

    • División 3

    • Cuadrante 4

  • Utiliza trazas, canales y formatos existentes

  • Muestra trazas y canales en las ventanas en función de un algoritmo de clasificación

Organización de Superposición

  • Esta configuración sitúa todas las trazas existentes en una única ventana, todas ellas superpuestas unas sobre otras.

  • Si existen más de cuatro trazas, esta selección se desactiva.

Organización de Pila 2

  • Esta configuración sitúa todas las trazas existentes en dos ventanas, "apiladas" (verticalmente).

  • Si existen más de ocho trazas, esta selección se desactiva.

Organización de División 3

  • Esta configuración sitúa todas las trazas existentes en tres ventanas, dos en la parte superior y una en la parte inferior.

  • Si existen más de doce trazas, esta selección se desactiva.

Organización de Cuadrante 4

  • Esta configuración sitúa todas las trazas existentes en cuatro ventanas, una ventana en cada cuadrante de la pantalla.

Algoritmo de clasificación

El algoritmo de clasificación de la función Arrange Windows está diseñado para:

  • Dividir las trazas entre las ventanas según sus propiedades

  • Agrupar trazas con propiedades comunes

El algoritmo clasifica según las siguientes propiedades de traza, en orden de prioridad:

  1. Formato: circular (polar o diagrama de Smith) frente a rectilineal (magnitud logarítmica, magnitud lineal, retardo de grupo, etc.)

  2. Número de canal

  3. Transmisión frente a reflexión

Nota: La limitación del analizador de cuatro trazas por ventana anula este algoritmo.

Haga clic en los botones para acceder a los procedimientos.
Seleccionar una configuración de medida preconfigurada
Seleccionar una configuración de Arrange Windows
Maximizar una única ventana desde una configuración de ventanas múltiples

Configuración de medida preconfigurada
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Window, hacer clic en Meas Setups.

  2. Hacer clic en la configuración de medida deseada.

Procedimiento con las teclas del panel frontal

  1. En el bloque DISPLAY, pulsar Measure Setups.

  2. Pulsar F1 (Configuración A) para cuatro trazas en una ventana.

  3. Pulsar F2 (Configuración B) para cuatro trazas en cuatro ventanas.

  4. Pulsar F3 (Configuración C) para cuatro trazas en tres ventanas.

  5. Pulsar F4 (Configuración D) para cuatro trazas en dos ventanas.

Seleccionar una configuración de Arrange Windows
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Window, hacer clic en Arrange.

  2. Hacer clic en la organización de ventana deseada.

Procedimiento con las teclas del panel frontal

  1. En el bloque DISPLAY, pulsar Arrange Windows.

  2. Pulsar F1 (Superposición) para todas las trazas en una ventana.

  3. Pulsar F2 (Pila 2) para todas las trazas en dos ventanas apiladas.

  4. Pulsar F3 (Configuración C) para todas las trazas en tres ventanas divididas.

  5. Pulsar F4 (Configuración D) para todas las trazas en cuatro ventanas.

Maximizar una única ventana desde una configuración de ventanas múltiples
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. Hacer clic en el panel Maximizar de la ventana que se desee maximizar.

  2. Volver a hacer clic en el panel Maximizar para restaurar la ventana a su tamaño original.

Procedimiento con las teclas del panel frontal

  1. En el bloque DISPLAY, pulsar Window para seleccionar la ventana que se desee maximizar.

  2. En el bloque UTILITY, pulsar la tecla Maximize/Restore.

  3. Volver a pulsar la tecla Maximize/Restore para restaurar la ventana a su tamaño original.


Power Level

Véase asimismo...

Nivel de potencia

Descripción general

Conceptos

Cómo ajustar la
potencia

El nivel de potencia es la potencia de la señal de fuente del analizador en el puerto de verificación.
Conceptos
Cómo ajustar la potencia

En los siguientes elementos se describen detalles de los niveles de potencia. Haga clic en un botón para mostrar información acerca de estos temas.
Margen de potencia
Acoplamiento de potencia entre puertos
Atenuación de la fuente

Atenuación automática

Atenuación manual

Atenuación con puertos sin acoplar
Pendiente de potencia
Atenuación del receptor

Margen de potencia

MáRGENES DE POTENCIA DE LA FUENTE Y RESOLUCIóN
Frecuencia | Margen de potencia de la fuente (dBm) | Resolución de potencia (dB)
300 kHz - 6 GHz | -85 - +10 | 0.01
>6 GHz - 9 GHz | -85 - +5 | 0.01

Nota: Véase Margen de frecuencias para obtener información sobre los márgenes específicos de los números de modelo de analizadores PNA.

Acoplamiento de potencia entre puertos

Por defecto, los niveles de potencia en el PUERTO 1 y en el PUERTO 2 están acoplados; la configuración de la potencia de salida en cada puerto es la misma. Algunas aplicaciones de medida necesitan diferentes niveles de potencia en el PUERTO 1 y en el PUERTO 2. Con el analizador es posible desacoplar las potencias de los puertos para poder ajustar la potencia en cada puerto por separado.

Por ejemplo, si se desea medir la ganancia y el aislamiento inverso de un amplificador de ganancia alta, es necesario ajustar la potencia de cada puerto por separado. Esto se debe a que la potencia necesaria para el puerto de entrada del amplificador es mucho más baja que la potencia que se necesita para el puerto de salida. Véase Atenuación con puertos sin acoplar.

PRECAUCIóN: Los receptores del analizador pueden resultar dañados si los niveles de potencia de entrada sobrepasan los siguientes valores máximos: Entrada a los puertos de verificación: +30 dBm (1,0 vatio) Entrada directa a los receptores: +15 dBm (31,6 mW)

Atenuación de la fuente

La fuente del analizador utiliza un atenuador de pasos programables para cubrir el margen de potencia completo de 95 dB. El atenuador ajusta el nivel de potencia de la señal de prueba en el dispositivo de verificación sin cambiar el nivel de la potencia incidente en la ruta de referencia del analizador. Esto ofrece:

  • Una mayor precisión y rendimiento de la señal de la fuente

  • Un acoplamiento entre fuentes más exacto

El atenuador tiene ocho posiciones diferentes, por lo que se puede disponer de niveles de potencia en ocho márgenes de potencia diferentes.

  • Cada margen tiene un recorrido total especificado de 25 dB.

  • El rango óptimo de cada margen de potencia es la banda de 10 dB en el centro del margen. Este margen ofrece la mayor precisión y rendimiento del sistema de nivelación de la fuente. Véanse los gráficos del Margen del atenuador.

  • Se puede seleccionar una configuración de atenuador de forma manual o automática.

Nota: La corrección de errores es completamente exacta sólo para el nivel de potencia en el que se ha realizado una calibración de medida. Sin embargo, cuando se cambia la potencia en el mismo margen del atenuador en el que se ha llevado a cabo la calibración de medida, se pueden realizar medidas con cálculo de relación con una precisión casi total (las medidas sin cálculo de relación con menos precisión).

Atenuación automática

Cuando el control del atenuador se encuentra en Auto (valor predeterminado), el analizador

  • permite seleccionar cualquier nivel de potencia dentro del margen total de funcionamiento del instrumento

  • Selecciona automáticamente la posición del atenuador y la potencia de la fuente de manera que se utilice el rango óptimo del margen total del atenuador.

Véase Valores de atenuación y puntos de transición.

Atenuación manual

En algunas aplicaciones de medida podrá ser necesario ajustar la potencia de la fuente y el atenuador de forma manual. Entre estas aplicaciones se incluyen:

  • Verificación de amplificadores de reflexión (osciladores o amplificadores condicionalmente inestables)

Esto precisa una adaptación muy buena de la impedancia con la fuente (pérdida de retorno de 20 dB) en un margen de frecuencias amplio. El atenuador ofrece una mejor adaptación de impedancia que la fuente sin atenuación del analizador cuando se está realizando una verificación en un margen de frecuencias amplio. Véase la guía didáctica Medidas de componentes de alta potencia.

    • Elegir Auto Off, con un nivel de atenuación de 10 o 20 dB (o más) para garantizar el mejor acoplamiento entre fuentes.

  • Barridos de potencia

El atenuador no puede cambiar la configuración del atenuador durante un barrido de potencia, para evitar el desgaste prematuro causado por un cambio continuo. Puede que el ajuste Auto no permita una cobertura total del margen de barrido de potencia deseado.

    • Elegir Auto Off y una combinación de margen de potencia de la fuente y posición del atenuador para obtener el margen de barrido de potencia completo necesario para la medida.

En el modo de atenuador Manual, es necesario:

  • Seleccionar la potencia de la fuente.

  • Seleccionar el valor de atenuación.

  • Seleccionar combinaciones en el margen óptimo.

VALORES DE ATENUACIóN, 300 kHz - 6 GHz

VALORES DE ATENUACIóN, 6 GHz - 9 GHz

VALORES DE ATENUACIóN Y PUNTOS DE TRANSICIóN 300 kHz - 6 GHz
 |  |  | Margen óptimo |  |
Atenuación Valor (dB) | Mínima potencia no especificada ajustable (dBm) | Potencia especificada mínima (dBm) | Punto de transición inferior (dBm) | Punto de transición superior (dBm) | Potencia especificada máxima (dBm)
0 | -20 | -15 | -5 | +5 (sin transición) | +10
10 | -30 | -25 | -15 | -5 | 0
20 | -40 | -35 | -25 | -15 | -10
30 | -50 | -45 | -35 | -25 | -20
40 | -60 | -55 | -45 | -35 | -30
50 | -70 | -65 | -55 | -45 | -40
60 | -80 | -75 | -65 | -55 | -50
70 | -85 | ---- | -85 (sin transición) | -65 | -60
VALORES DE ATENUACIóN Y PUNTOS DE TRANSICIóN 6 GHz - 9 GHz
 |  |  | Margen óptimo |  |
Atenuación Valor (dB) | Mínima potencia no especificada ajustable (dBm) | Potencia especificada mínima (dBm) | Punto de transición inferior (dBm) | Punto de transición superior (dBm) | Potencia especificada máxima (dBm)
0 | -20 | -15 | -5 | +5 (sin transición) | +5
10 | -30 | -25 | -15 | -5 | -5
20 | -40 | -35 | -25 | -15 | -15
30 | -50 | -45 | -35 | -25 | -25
40 | -60 | -55 | -45 | -35 | -35
50 | -70 | -65 | -55 | -45 | -45
60 | -80 | -75 | -65 | -55 | -55
70 | -85 | ---- | -85 (sin transición) | -65 | -65

Atenuación con puertos sin acoplar

El atenuador de pasos se puede cambiar entre el puerto 1 y el puerto 2 cuando la potencia del puerto de verificación no está acoplada. Para evitar el desgaste prematuro del atenuador de pasos mecánico, el analizador:

  • Evita los cambios continuos entre los dos márgenes de potencia

  • Automáticamente cambia al modo de espera después de medir cada canal una vez

Si el promediado está activado, el modo de espera no se activa hasta que se haya realizado el número de barridos especificado para cada canal.

Pendiente de potencia

La pendiente de potencia ayuda a compensar las pérdidas de potencia que se producen en los cables y dispositivos de pruebas a frecuencias mayores.

  • Con la función dependiente de potencia activada, la potencia de salida del puerto aumenta (o disminuye) a medida que aumenta la frecuencia de barrido.

  • Las unidades de pendiente de potencia son dB/GHz.

  • La pendiente de potencia sólo se puede ajustar a valores de 0,5, 1, 1,5 o 2 (positivos o negativos).

Atenuación del receptor (con la Opción 015)

PRECAUCIóN: Los receptores del analizador pueden resultar dañados si los niveles de potencia de entrada sobrepasan los siguientes valores máximos: Entrada a los puertos de verificación: +30 dBm (1,0 vatio) Entrada directa a los receptores: +15 dBm (31,6 mW)

Para evitar que se dañe el receptor del analizador, puede que sea necesario atenuar la señal de salida del dispositivo sometido a prueba. La Opción 015 ofrece atenuadores internos para ambos receptores.

  • Margen: 0 a 35 dB

  • Resolución: 5 dB

Haga clic en los botones para acceder a los procedimientos indicados.
Ajustar el nivel de potencia
Apagar el dispositivo sometido a prueba
Ajustar la atenuación manualmente
Ajustar la pendiente de potencia
Ajustar el nivel de atenuación del receptor del analizador (sólo con la Opción 015)

Ajustar el nivel de potencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

PRECAUCIóN: Los receptores del analizador pueden resultar dañados si los niveles de potencia de entrada sobrepasan los siguientes valores máximos: Entrada a los puertos de verificación: +30 dBm (1,0 vatio) Entrada directa a los receptores: +15 dBm (31,6 mW)

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. En el cuadro Test Port Power, escribir el valor o pulsar el botón de flecha para seleccionar el nivel de potencia deseado para el Puerto 1. La potencia del puerto está acoplada (por defecto), por lo que esto también ajusta la potencia para el Puerto 2.

  3. Si se desea ajustar el nivel de potencia de forma individual para cada puerto, hacer clic en el cuadro Port Power Coupled para desacoplar los puertos. En el cuadro Port, seleccionar el puerto deseado. Repetir el Paso 2 de este procedimiento.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. Pulsar F1 (Nivel) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el nivel de potencia deseado.

  3. Pulsar Enter.

Apagar el dispositivo sometido a prueba
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. Hacer clic en el cuadro Power On para cambiar la potencia al estado de apagado (Off).

  3. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. Pulsar F2 (ACTIVADO/desactivado) para cambiar la potencia al estado de apagado (Off).

Ajustar la atenuación manualmente
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. En la parte Attenuator Control del cuadro de diálogo, hacer clic en la casilla Auto para desactivar el control automático del atenuador y activar el control manual.

  3. Hacer clic en el cuadro Attenuator Control y escribir el valor o hacer clic en el botón de flecha para seleccionar la atenuación deseada.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. Pulsar F3 (Atenuación-Automática) para cambiar el control de atenuación al estado manual.

  3. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la atenuación deseada.

  4. Pulsar Enter.

Ajustar la pendiente de potencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. En la parte Power Slope del cuadro de diálogo, hacer clic en la casilla de verificación Slope.

  3. Hacer clic en el cuadro Slope (dB/GHz) y escribir el valor, o hacer clic en el botón de flecha para seleccionar el valor de pendiente deseado.

  4. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Power.

  2. Pulsar F4 (Pendiente) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el valor de pendiente de potencia deseado.

  3. Pulsar Enter.

Ajustar el nivel de atenuación del receptor del analizador (sólo con la Opción 015)
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

PRECAUCIóN: Los receptores del analizador pueden resultar dañados si los niveles de potencia de entrada sobrepasan los siguientes valores máximos: Entrada a los puertos de verificación: +30 dBm (1,0 vatio) Entrada directa a los receptores: +15 dBm (31,6 mW)

Procedimiento con el ratón

  1. En el menú Channel, hacer clic en Power.

  2. En la parte Receiver Attenuation del cuadro de diálogo, hacer clic en al casilla del Receptor A o del Receptor B. Escribir el valor o hacer clic en el botón flecha para seleccionar la atenuación del receptor deseada.

  3. Pulsar Enter.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog.

  2. En el bloque CHANNEL SETUP, pulsar Power.

  3. Pulsar la tecla de tabulador a la derecha para seleccionar el Receptor A o el Receptor B en la parte Receiver Attenuation del cuadro de diálogo Power. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para seleccionar la atenuación deseada.

  4. Pulsar Enter.

  5. En el bloque COMMAND, pulsar OK.


Punto 1 Configuración

Configurar el analizador

Véase asimismo...

Haga clic en un botón para aprender rápidamente a configurar el analizador para realizar una medida.
Integración en red y conexión del analizador
Preajustar el analizador
Configurar medidas

Seleccionar un parámetro de medida

Ajustar el margen de frecuencias

Ajustar el nivel de potencia de RF

Seleccionar barrido

Seleccionar el activador

Seleccionar el formato de datos y la escala
Ajustar la pantalla

Ver trazas y canales múltiples

Personalizar la pantalla del analizador

Desactivar las líneas de frecuencia/estímulo de la pantalla


Véase asimismo...

Barrido

Descripción general

Conceptos

Cómo ajustar
barridos lineales,
de potencia y de CW

Cómo ajustar
barridos de segmentos

Un barrido es una serie de medidas consecutivas de puntos de datos tomadas en una secuencia especificada de valores de estímulo.
Conceptos

Cómo ajustar un barrido lineal, de potencia y de CW

Cómo ajustar un barrido de segmentos

Tipos de barrido

Frecuencia lineal

Potencia

Tiempo de CW

Barrido de segmentos
Barra de herramientas de control de barridos

Tipos de barrido

Hay disponibles cuatro tipos de barrido.

Frecuencia lineal

Se trata del tipo de barrido predeterminado. La frecuencia se barre de forma lineal y continua a través del margen de frecuencias.

En la siguiente figura se muestra un barrido de frecuencia lineal de un filtro, con un margen de barrido comprendido entre 50.000 MHz y 200.000 MHz.

Potencia

El tipo de barrido de potencia se utiliza para caracterizar circuitos sensibles a la potencia, con medidas tales como compresión de ganancia o pendiente de AGC (control automático de ganancia).

  • La potencia se barre desde un valor de inicio hasta un valor de parada a una única frecuencia.

  • Un barrido de potencia es un barrido por pasos.

    • La amplitud de la fuente aumenta en pasos de potencia discretos en cada punto de datos a través del margen de barrido de potencia.

    • El número de puntos de datos y el margen de potencia determinan el tamaño de estos pasos.

  • Elegir una combinación de margen de potencia de la fuente y posición de atenuador manual para obtener el margen de barrido de potencia necesario para la medida. Véase Nivel de potencia .

En la siguiente figura se muestra un barrido de potencia de un amplificador, con un margen de potencia comprendido entre -5 dBm y +10 dBm.

Tiempo de CW

El tipo de barrido de tiempo de CW es similar a la función que realiza un osciloscopio.

  • El analizador se ajusta a una única frecuencia.

  • Se muestran los datos de respuesta en relación con el tiempo.

  • Los datos se muestrean de forma continua a intervalos de tiempo uniformes y precisos determinados por el tiempo de barrido y el número de puntos menos uno.

En la siguiente figura se muestra un barrido de tiempo de CW de un amplificador, con un margen de tiempo comprendido entre 0 y 6 ms.

Barrido de segmentos

El tipo de barrido de segmentos permite al analizador barrer una lista de puntos de frecuencia arbritraria. Pueden especificarse sub-barridos de frecuencia (denominados "segmentos") para un total máximo de 1.601 puntos de datos. Un barrido de segmentos se aplica a todas las trazas de un canal. Se puede establecer que cada segmento tenga un número de puntos y un margen de frecuencias independiente. Cada segmento puede tener también:

  • Ancho de banda de IF independiente (véase Optimizar medidas.)

  • Nivel de potencia independiente

  • Tiempo de barrido independiente

Una vez que se realiza una calibración de medida en todo el barrido o a través de todos los segmentos, se pueden llevar a cabo medidas calibradas de uno o más segmentos.

El analizador de redes:

  • Ordena todos los segmentos definidos en orden de frecuencia ascendente

  • Mide cada punto

  • Muestra una única traza compuesta por todos los datos tomados

Las consideraciones relativas al tipo de barrido de segmentos incluyen las siguientes:

  • El margen de frecuencias de un segmento no puede solaparse con el margen de frecuencias de cualquier otro segmento.

  • L os niveles de potencia de todos los segmentos deben mantenerse dentro del mismo margen del atenuador para evitar un desgaste prematuro del atenuador de pasos mecánico. Véase Nivel de potencia .

Barra de herramientas de control de barridos

La barra de herramientas de control de barridos aparece encima de las ventanas situadas en la parte superior de la pantalla. En orden, los botones de esta barra de herramientas ajustan el canal activo a:

  • Modo Hold

  • Barrido único, después modo Hold

  • Barrido continuo

Véase Activador para obtener más información.

Haga clic en los botones para acceder a los procedimientos.
Configurar un barrido de frecuencia lineal
Configurar un barrido de potencia
Configurar un barrido de tiempo de CW

Barrido de frecuencia lineal
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Sweep Type.

  2. En el cuadro Sweep Type, hacer clic en Linear Frequency.

  3. Hacer clic en el cuadro Start en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar la frecuencia de inicio deseada del margen de barrido.

  4. Hacer clic en el cuadro Stop en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar la frecuencia de parada deseada del margen de barrido.

  5. Hacer clic en el cuadro Points en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar el número deseado de puntos de datos en el margen de barrido.

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Sweep Type.

  2. Pulsar F1 (Lineal).

  3. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  4. Pulsar F2 (Puntos) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el número deseado de puntos de datos.

  5. Pulsar Enter.

Barrido de potencia
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Sweep Type.

  2. En el cuadro Sweep Type, hacer clic en Power Sweep.

  3. Hacer clic en el cuadro Start en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar el nivel de potencia de inicio deseado del margen de barrido.

  4. Hacer clic en el cuadro Stop en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar el nivel de potencia de parada deseado del margen de barrido.

  5. Hacer clic en el cuadro CW Freq en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar la frecuencia de CW del barrido de potencia.

  6. Hacer clic en OK.

  7. En el menú Sweep, hacer clic en Number of Points. Escribir el valor o hacer clic en los botones de flecha para seleccionar el número deseado de puntos de datos a través del margen de potencia del barrido.

  8. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Sweep Type.

  2. Pulsar F2 (Barrido de potencia).

  3. En el bloque CHANNEL SETUP, pulsar Power.

  4. Pulsar F1 (Potencia de inicio) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el nivel de potencia de inicio deseado para el barrido.

  5. Pulsar Enter.

  6. Pulsar F2 (Potencia de parada) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el nivel de potencia de parada deseado para el barrido.

  7. Pulsar Enter.

  8. En el bloque CHANNEL SETUP, pulsar Start/Center o Stop/Span.

  9. Pulsar F3 (Frecuencia de CW) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la frecuencia de CW deseada para el barrido.

  10. Pulsar Enter.

Barrido de tiempo de CW
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Sweep Type.

  2. En el cuadro Sweep Type, hacer clic en CW Time.

  3. Hacer clic en el cuadro CW Freq en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar la frecuencia de CW deseada del barrido.

  4. Hacer clic en el cuadro Sweep Time en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar el tiempo de barrido deseado.

  5. Hacer clic en el cuadro Points en la parte Sweep Properties del cuadro de diálogo. Escribir el valor o hacer clic en los botones de flecha para seleccionar el número deseado de puntos de datos del barrido de potencia.

  6. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Sweep Type.

  2. Pulsar F3 (Tiempo de CW).

  3. En el bloque CHANNEL SETUP, pulsar Start/Center.

  4. Pulsar F1 (Frecuencia de CW) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la frecuencia de CW deseada para el barrido.

  5. Pulsar Enter.

  6. En el bloque CHANNEL SETUP, pulsar Sweep Setup.

  7. Pulsar F1 (Tiempo) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el tiempo de barrido deseado.

  8. Pulsar Enter.

  9. Pulsar F2 (Puntos) y escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el número deseado de puntos de datos del barrido.

  10. Pulsar Enter.

Procedimiento de barrido de segmentos
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

Para seleccionar el barrido de segmentos:

  1. En el menú Sweep, hacer clic en Sweep Type.

  2. En el cuadro Sweep Type, hacer clic en Segment Sweep.

  3. Si se desea que los segmentos del barrido tengan niveles de potencia independientes, hacer clic en la casilla de verificación Independent Power Levels en la parte Sweep Properties del cuadro de diálogo.

  4. Si se desea que los segmentos del barrido tengan un ancho de banda de IF independiente, hacer clic en la casilla Independent IF Bandwidth en la parte Sweep Properties del cuadro de diálogo.

  5. Si se desea que los segmentos del barrido tengan un tiempo de intervalo independiente, hacer clic en la casilla Independent Dwell Time en la parte Sweep Properties del cuadro de diálogo.

  6. Hacer clic en el cuadro Show Table en la parte Sweep Properties del cuadro de diálogo para visualizar la tabla de segmentos.

  7. Hacer clic en OK.

Para definir segmentos:

  1. Para añadir un segmento, hacer clic en Insert Segment en el submenú Segment Table del menú Sweep.

  2. Para borrar un segmento, hacer clic en el número de segmento deseado para seleccionarlo. Hacer clic en Delete Segment en el submenú Segment Table del menú Sweep.

  3. Hacer clic en el cuadro STATE del primer segmento de la tabla de segmentos. Pulsar el botón de flecha para ajustar el segmento a la condición ON (activado).

  4. Hacer clic en el cuadro START del primer segmento de la tabla de segmentos. Escribir el valor de la frecuencia de inicio deseada para este segmento.

  5. Hacer clic en el cuadro STOP del primer segmento de la tabla de segmentos. Escribir el valor de la frecuencia de parada deseada para este segmento.

  6. Hacer clic en el cuadro POINTS del primer segmento de la tabla de segmentos. Escribir el valor del número deseado de puntos de datos para este segmento.

  7. Si se han seleccionado niveles de potencia independientes en el punto 4 de este procedimiento, hacer clic en el cuadro POWER del primer segmento de la tabla de segmentos. Escribir el valor del nivel de potencia deseado para este segmento.

  8. Si se han seleccionado anchos de banda de IF independientes en el punto 5 de este procedimiento, hacer clic en el cuadro TIME del primer segmento de la tabla de segmentos. Escribir el valor del ancho de banda de IF deseado para este segmento.

  9. Si se han seleccionado tiempos de intervalo independientes en el punto 6 de este procedimiento, hacer clic en el cuadro DWL TIME del primer segmento de la tabla de segmentos. Escribir el valor del tiempo de intervalo deseado para este segmento.

  10. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

Para seleccionar el barrido de segmentos:

  1. En el bloque CHANNEL SETUP, pulsar Sweep Type.

  2. Pulsar F4 (Segmento).

  3. Para definir o cambiar las características del barrido de segmentos, pulsar Menu/Dialog en el bloque COMMAND y, a continuación, pulsar Sweep Type en el bloque CHANNEL SETUP. Aparecerá el cuadro de diálogo Sweep Type.

  4. Pulsar la tecla de tabulador a la derecha para desplazarse a la zona Sweep Type del cuadro de diálogo. Pulsar la tecla de flecha hacia abajo para seleccionar el barrido de segmentos.

  5. Si se desea que los segmentos del barrido tengan niveles de potencia independientes, pulsar la tecla de flecha a la derecha para desplazarse al cuadro Independent Power Levels en la parte Sweep Type del cuadro de diálogo. Pulsar Click.

  6. Si se desea que los segmentos del barrido tengan un ancho de banda de IF independiente, pulsar la tecla de flecha hacia abajo para desplazarse al cuadro Independent IF Bandwidth en la parte Sweep Type del cuadro de diálogo. Pulsar Click.

  7. Si se desea que los segmentos del barrido tengan un tiempo de intervalo independiente, pulsar la tecla de flecha hacia abajo para desplazarse al cuadro Independent Dwell Time en la parte Sweep Type del cuadro de diálogo. Pulsar Click.

  8. Pulsar la tecla de tabulador a la derecha para desplazarse al cuadro Show Table en la parte Sweep Properties del cuadro de diálogo para visualizar la tabla de segmentos.

Para definir segmentos:

  1. Pulsar Click. Aparecerán las opciones de STATE como ON y OFF. Utilizar las teclas de flecha hacia arriba o hacia abajo para desplazarse al estado deseado.

  2. Pulsar la tecla de tabulador a la derecha para desplazarse a la entrada START de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la frecuencia de inicio deseada para este segmento del barrido.

  3. Pulsar la tecla de tabulador a la derecha para desplazarse a la entrada STOP de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer la frecuencia de parada deseada para este segmento del barrido.

  4. Pulsar la tecla de tabulador a la derecha para desplazarse a la entrada POINTS de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el número deseado de puntos de datos para este segmento del barrido.

  5. Si se ha seleccionado la casilla Independent IF Bandwidth en el cuadro de diálogo Sweep Type, pulsar la tecla de tabulador a la derecha para desplazarse a la entrada TIME de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el ancho de banda de IF para este segmento del barrido.

  6. Si se ha seleccionado la casilla Independent Power Levels en el cuadro de diálogo Sweep Type, pulsar la tecla de tabulador a la derecha para desplazarse a la entrada POWER de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el nivel de potencia deseado para este segmento del barrido.

  7. Si se ha seleccionado la casilla Independent Dwell Time en el cuadro de diálogo Sweep Type, pulsar el tabulador a la derecha para desplazarse a la entrada TIME de la tabla de segmentos. Escribir el valor o pulsar las teclas de flecha hacia arriba o hacia abajo para establecer el tiempo de intervalo deseado para este segmento del barrido.

  8. Para añadir segmentos, pulsar la tecla de tabulador a la derecha para desplazarse al menú Sweep. Pulsar la tecla de flecha hacia abajo para desplazarse a Segment Table. Pulsar la tecla de tabulador a la derecha para mostrar el menú Segment Table. Pulsar la tecla de flecha hacia abajo para desplazarse a la entrada Insert Segment. Pulsar el botón Click u OK en el bloque COMMAND para seleccionar Insert Segment .

  9. Para eliminar segmentos, seleccionar el segmento de la tabla de segmentos que se desee eliminar. Pulsar la tecla de tabulador a la derecha para desplazarse al menú Sweep. Pulsar la tecla de flecha hacia abajo para desplazarse a Segment Table. Pulsar la tecla de tabulador a la derecha para mostrar el menú Segment Table. Pulsar la tecla de flecha hacia abajo para desplazarse a la entrada Delete Segment. Pulsar el botón Click u OK en el bloque COMMAND para seleccionar Delete Segment .

  10. Repetir los puntos del 10 al 16 para cada entrada de la tabla de segmentos.

  11. Hacer clic en el botón OK del bloque COMMAND.


Véase asimismo...

Activador

Descripción general

Conceptos

Cómo ajustar el activador

Un disparo es una señal que hace que el instrumento realice un barrido de medida. La configuración del disparo también determina la forma en que se inicia el barrido de medida y el momento en que el analizador finalizará el barrido y volverá al estado Hold.
Conceptos

Cómo ajustar el activador

El analizador ofrece gran flexibilidad a la hora de configurar la función de activador.
Modelo de activador
Fuente de disparo

Interna

Manual

Externa
Alcance del disparo

Global

Channel
Estado del activador de canales

Continuous

Group

Single

Hold

Point
Configuración del activador y RESTART

Modelo de activador

El modelo de activador animado representa las señales del activador en forma de bolas. El objetivo consiste en hacer llegar las bolas a los canales. Este modelo tiene tres canales. Cuando un canal acepta una bola, realiza una medida. Visualizar la animación del modelo de activador.

  • El cuadro superior (Trigger Source) es un cuadro de bolas. Un disparo válido (generado sólo cuando el analizador no está realizando un barrido) libera una bola que se encamina a los canales. El valor Trigger Source determina si las bolas proceden de:

    • un cuadro Interno

    • un cuadro Externo

    • o han sido puestas en el sistema Manualmente, de una en una.

  • Cuando la bola cae en el cuadro del medio, el valor Trigger Scope determina cómo se encamina la bola hasta el sistema.

    • Si el valor es Global, la bola se convierte en tres bolas, una por cada canal. Las rampas guían estas bolas hacia el canal adecuado, de una en una.

    • Si el valor es Channel, la bola es guiada hacia el siguiente canal disponible.

  • El valor Channel Trigger State de cada canal determina si dicho canal aceptará bolas y, en caso afirmativo, cuántas.

Fuente de disparo

Se pueden seleccionar tres fuentes de señales de disparo con el analizador: interna, externa o manual. Una vez seleccionado el valor, el analizador reconoce dicha fuente como la fuente de disparo para todos los canales existentes. Véase la animación del modelo de activador.

  • Una señal de disparo válida sólo puede generarse cuando el analizador no está realizando un barrido.

Disparo interno (predeterminado)

  • Controlado por el analizador

  • Hace que se produzca una señal de disparo tan pronto como el analizador haya finalizado una medida

Disparo manual

La señal de disparo manual se genera al realizar una de estas acciones:

  • Hacer clic en Trigger! en el menú o cuadro de diálogo Trigger

  • Enviar un comando de disparo remoto

  • Pulsar la tecla Trigger del panel frontal

Si se intenta enviar una señal de disparo manual mientras se está realizando una medida, se hará caso omiso de la solicitud de disparo. Se deberá esperar hasta que finalice la medida (cuando el analizador ya no esté realizando ningún barrido) para que se reconozca una señal de disparo.

Disparo externo

  • Aplicado a través del conector de E/S auxiliar del panel posterior (patilla 19).

  • Señal TTL

  • Sensible al nivel: activa alta o activa baja

  • El pulso debe ser de al menos 1 us y no debe ser superior al tiempo de barrido. (Los pulsos superiores al tiempo de barrido pueden ocasionar disparos múltiples.)

  • Si el nivel del disparo externo se mantiene al nivel de disparo, podrá implantarse un mode de barrido continuo. Este modo se puede anular seleccionando el modo simple en el menú de disparo externo. Si se selecciona este modo, el analizador reacciona con la primera transición de la señal de disparo a un estado válido y, a continuación, accede al modo Hold hasta que el disparo se restablezca al modo simple.

Preparado para disparo externo

  • También se puede acceder a la línea de preparado para disparo a través del conector de E/S auxiliar del panel posterior (patilla 18).

  • Señal TTL activa baja.

  • Cuando la línea de preparado para disparo es baja y se recibe una señal de disparo externo válida, la línea de preparado para disparo se cambia a alta mientras dure la medida. Por ejemplo, si el analizador se encuentra en modo de barrido alterno y tiene una calibración de dos puertos, se necesitarán 4 barridos para actualizar los datos. La línea de preparado para disparo permanecerá alta (no preparado) hasta que se hayan tomado los 4 barridos y se hayan actualizado los datos.

Alcance del disparo

El alcance del disparo define qué canales de medida recibirán una señal de disparo. Los dos valores de alcance de disparo son Global y Channel. Véase la animación del modelo de activador para ver cómo afecta el alcance del disparo al flujo de señales de disparo.

Global (por defecto)

  • Envía una señal de disparo desde la fuente de disparo a todos los canales operativos

  • Adquiere todos los datos de medida de todos los canales operativos con una única señal de disparo (a excepción de los canales que se encuentren en el modo Hold)

Channel

  • Envía una señal de disparo desde la fuente de disparo al canal activo únicamente

  • Se selecciona automáticamente si alguno de los canales tiene el estado de disparo ajustado a Point .

Cuando el canal activo finaliza su ciclo de medida, el analizador selecciona automáticamente el siguiente canal. Los canales se seleccionan de forma secuencial, excepto si el estado del activador de canales es Hold. Si únicamente hay configurado un canal o sólo hay un canal que no está en Hold, el canal activo permanece inalterado.

Estado del activador de canales

Se puede elegir entre cuatro estados de activador de canales que determinan el número de señales de disparo que aceptará un canal: Continuous, Group, Single y Hold.

  • Un canal acepta señales de disparo cuando el canal NO está en Hold.

Cada señal de disparo aceptada hace que el canal inicie todas las medidas en dicho canal (excepto en el estado Point ). Por ejemplo, si hay medidas S21 y S22 en el canal 3, una señal de disparo iniciará ambas medidas. Véase la animación del modelo de activador para ver cómo afecta el estado del activador de canales al flujo de señales de disparo.

Cuando un canal ha aceptado el número especificado de señales de disparo:

  • Accede a un estado Hold desarmado

  • Hace caso omiso de las señales de disparo

Continuous (por defecto)

El canal acepta un número ilimitado de señales de disparo.

Group

El canal sólo acepta el número especificado de señales de disparo.

Single

El canal acepta una única señal de disparo.

Hold

Se hace caso omiso de los disparos. Aunque siguen produciéndose disparos, no afectan a ningún canal que se encuentre en el modo Hold. El canal no adquirirá datos nuevos en este modo. (Los datos de la pantalla podrán actualizarse si se manipulan funciones de post-procesamiento, como el suavizado, el dominio del tiempo, etc.)

Point

Un canal se barre punto a punto. Cuando un canal en el estado Point recibe una señal de disparo, adquiere el punto de datos siguiente del barrido actual. Un canal en el estado Point aceptará señales de disparo hasta que todas las medidas de dicho canal hayan finalizado.

Single y Group funcionan de forma diferente para un canal que también se encuentre en estado Point.

  • Single: El canal acepta las señales de disparo hasta que todas las medidas de ese canal se realicen una sola vez. Por ejemplo, un canal configurado con una traza de 101 puntos de datos aceptará 101 señales de disparo.

  • Group: El canal acepta señales de disparo hasta que todas las medidas de ese canal se hayan realizado el número de veces especificado. Por ejemplo, un canal configurado con una traza de 101 puntos de datos , con un valor Group de 3, aceptará 303 señales de disparo.

El analizador mide las entradas A y B durante cada barrido. Por lo tanto:

  • Las medidas S11 y S21 se realizarán en el mismo barrido.

  • Las medidas S12 y S22 se realizarán en el mismo barrido (desde el puerto opuesto).

Esto significa que las medidas S11 y S 21 (o S12 y S22) pueden realizarse punto a punto al mismo tiempo en el estado Point.

Nota: La configuración del barrido depende del canal. Si el canal está configurado en el modo Alternate Sweep, sólo se medirá una entrada por barrido. Si el canal está configurado en modo Alternate Sweep, sólo podrá realizarse una medida punto a punto a la vez.

Nota: El estado Point no es compatible con el valor Trigger Scope de Global. Si algún canal se ajusta al estado Point, el valor Trigger Scope se ajustará a Channel.

Configuración del activador y RESTART

RESTART se aplica a todos los canales existentes. Cuando se recibe el comando RESTART, el analizador detiene el barrido y los estados del activador de canales quedan afectados de la siguiente manera:

  • Todos aquellos canales que se encuentren en el estado Point cuando se recibe el comando RESTART dejarán de estar en el estado Point.

  • Si algún canal se encuentra en el estado Hold, el recuento de disparos se ajustará a uno (el canal acepta una única señal de disparo).

  • Si algún canal se encuentra en el estado Group, el recuento de disparos se mantendrá igual que cuando se recibió el comando RESTART.

  • Si algún canal se encuentra en el estado Continuous, el canal seguirá estandoajustado para aceptar un número ilimitado de señales de disparo.

El analizador reanudará a continuación el barrido. Si la fuente de disparo se ajusta a Manual, se envía una única señal de disparo. Los canales existentes responderán en función de su estado de activador de canales. Cada traza de la pantalla debería actualizarse al menos una vez.

Haga clic en los botones para acceder a estos procedimientos.
Configuración de disparo simple
Ajustar el disparo

Configuración de disparo simple
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Trigger.

  2. Hacer clic en el valor deseado: Continuous, Single, Hold o Restart.

Procedimiento con las teclas del panel frontal

  1. En el bloque CHANNEL SETUP, pulsar Trigger.

  2. Pulsar F1 para Continuous.

  3. Pulsar F2 para Single.

  4. Pulsar F3 para Hold.

  5. Pulsar F4 para Restart.

Ajustar el disparo
Procedimiento con el ratón
Procedimiento con las teclas del panel frontal

Procedimiento con el ratón

  1. En el menú Sweep, hacer clic en Trigger.

  2. Hacer clic en Trigger....

  3. En la parte Trigger Source del cuadro de diálogo, seleccionar el valor deseado: Internal, External o Manual.

  4. En la parte Trigger Scope del cuadro de diálogo, seleccionar el valor deseado: Global o Channel.

  5. En la parte Trigger State del cuadro de diálogo, seleccionar el canal deseado.

  6. En la parte Trigger State del cuadro de diálogo, seleccionar Continuous, Enable Groups, Single, Point Sweep o Hold. En Enable Groups, escribir también el número de grupos.

  7. Hacer clic en OK.

Procedimiento con las teclas del panel frontal

  1. En el bloque COMMAND, pulsar Menu/Dialog. En el bloque CHANNEL SETUP, pulsar Trigger.

  2. En el bloque NAVIGATION, pulsar la tecla de flecha hacia abajo para seleccionar el valor deseado: Internal, External o Manual.

  3. Pulsar la tecla de tabulador a la derecha para desplazarse a la parte Trigger Scope del cuadro de diálogo.

  4. Pulsar la tecla de flecha hacia abajo para seleccionar el valor deseado: Global o Channel.

  5. Pulsar la tecla de tabulador a la derecha para pasar a la zona Trigger State del cuadro de diálogo.

  6. Seleccionar el canal deseado.

  7. Pulsar la tecla de flecha hacia abajo para desplazarse al valor deseado: Continuous, Single, Hold, Point Sweep o Enable Groups. Pulsar Click para seleccionarlo. Si Enable Groups está seleccionado, escribir el número deseado de grupos. (Point Sweep sólo puede seleccionarse con los valores Manual y Channel.)

  8. En el bloque COMMAND, pulsar OK .


Texto del disparo

  • La sincronización de las respuestas de configuración es diferente a la del analizador. Por ejemplo, el cambio al modo Manual se produce de forma inmediata en el analizador. El modelo espera hasta que finalice el barrido actual.

  • El modelo no incluye disparos externos.

Modelo animado de disparo

Este modelo SIMPLIFICADO puede ayudar a conocer el comportamiento de disparo flexible del analizador. Aunque NO es un modelo exacto del analizador, las diferencias son mínimas.

Nota: Cuando un canal recibe una señal de disparo, se realizan todas las medidas del canal; primero se realizan las medidas progresivas (S11, S21) simultáneamente y, a continuación, las medidas regresivas (S12, S22). Hay dos excepciones:
1. Cuando se selecciona el barrido Alternate.
2. Cuando está seleccionado el disparo Point.

La configuración de Trigger Source determina de dónde proceden las señales de disparo:

Internal - El firmware del analizador envía señales de disparo continuas tan pronto como finaliza la medida anterior.

Manual - Se envía una señal de disparo cuando ésta es invocada por: el botón Trigger, la barra de herramientas activa o un comando de programación.

External - Las señales de disparo se envían a través de un conector BNC del panel posterior. El disparo es sensible al nivel y puede ser TTL activa alta o TTL activa baja.

La configuración de Trigger Scope determina sobre qué se dispara:

Global - Todos los canales "susceptibles de disparo" reciben la señal de disparo [ajuste predeterminado]

Channel - Sólo el siguiente canal "susceptible de disparo" recibe la señal de disparo. (Sólo se permite si Trigger Source = MANUAL.)

Individual Channel Settings determina cuántas señales de disparo aceptará el canal:

Continuous - El canal acepta un número infinito de señales de disparo

Groups - El canal sólo acepta el número especificado de señales de disparo (Groups) y después pasa a Hold.

Single - El canal acepta UNA señal de disparo y después pasa a Hold.

Hold - El canal NO acepta ninguna señal de disparo.

Point - Cuando recibe el disparo, el canal mide el siguiente punto de datos del barrido. Las señales de disparo posteriores van al mismo canal hasta que finalicen todas sus medidas. Después se realiza un disparo sobre el siguiente canal susceptible de disparo. (Sólo se permite si Trigger Source = MANUAL y Trigger Scope = CHANNEL.)

Restart - El analizador detiene el barrido (el modelo no se detiene inmediatamente). La configuración del canal individual (disparo) se ve afectada de la siguiente manera:

  • Los canales del barrido Point se eliminan del barrido Point.

  • Los canales que se encuentran en el estado Hold se ajustarán a disparo único (el canal acepta una única señal de disparo).

RESTART no afecta a ninguno de los demás ajustes, incluidos los recuentos de disparos que se estén disminuyendo. El analizador reanuda a continuación el barrido.

El velocímetro - controla la velocidad de la animación:

Hacer clic en - para reducir la velocidad
Hacer clic en + para aumentar la velocidad


Modelo de activador

Speedometer | Trigger Source Internal Manual
 | Trigger Scope Global Channel

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point


Analyze Data

Analizar datos

Véase asimismo..

Hagar clic en un botón para conocer las maneras de analizar datos de medida.
Localizar datos mediante marcadores

Manipular datos mediante operaciones matemáticas

Ver resultados de superado/fallido mediante líneas límite


COM Index

Indice principal

Índice COM

Índice SCPI


Programming Guide

Click a button to access the following Programming topics:

Command Finder

8753 Converter

COM versus SCPI

Analyzer Connectivity

Help Tips

GPIB / SCPI Only

SCPI Command Tree

Example Programs

Create a Measurement

Catalog Measurements

Setup Sweep Parameters

Setup the Display

Getting and Putting Data using GPIB

Status Reporting

ECALibrate using GPIB

Perform a Calibration

Modify a Cal Kit

GPIB Concepts

GPIB Fundamentals

The Rules and Syntax of SCPI

Getting Data from the Analyzer

Reading the Analyzer's Status Register

Understanding Command Synchronization

COM Only

Object Model - Commands

Example Programs

Getting Trace Data from the Analyzer

Limit Line Testing

Communicating with Other Applications

COM Concepts

COM Fundamentals

Getting a Handle to an Object

Collections in the Analyzer

Working with Events

Configure for COM-DCOM Programming

COM Data Types

C++ and the COM Interface


SCPI Index

Índice principal

Índice COM

Índice SCPI


Accessing Data Descriptions

Click a box to view process details:

Raw Measurement Data - Complex trace data which is ratioed if required by the parameter, such as S11 or A/B. Otherwise it is raw receiver data, such as A or B. This data is averaged if Averaging is ON. See Measurement Parameters

Standard Acquisition Data - Raw Complex Data resulting from measuring calibration standards or recalling a calibration. See Measurement Calibration.

Error Term Data - Data that is calculated from Acquisition data using formulas which are appropriate for the selected calibration method.

Error Correction - Error terms are applied to the raw measurement data if error correction is ON. Otherwise this data is identical to Raw Measurement Data.

Trace Math - If turned ON, memory data is combined with measurement data using the selected math function. Available functions are: Data+Mem, Data-Mem, Data*Mem, and Data/Mem. See Math Operations.

Memory Data - Complex trace data resulting from a Data-To-Memory operation. Each measurement can have one memory trace. The memory data parallels the measurement data through the remaining post processing blocks. For example, turning smoothing ON will smooth both the measurement and memory traces.

Gating - If turned ON, Filter Gating is applied to the measurement data. The gates are used to select regions of the trace where a subsequent transform will be applied. See Gating.

Phase Correction - If turned ON, applies electrical delay, phase offset, and port extensions. These are all separate features that are controlled individually. See Phase Measurement Accuracy.

Time Domain - If turned ON, transforms the data from the frequency domain to the time domain. See Time Domain

Formatter - Complex data is converted into scalar data formats for screen display and remote access. For smoothed data, request the data in the same format as the displayed data. See Data Format

Memory Result Data- Memory data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Measurement Result Data - Measurement data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Smoother - If turned ON, removes discontinuities in the measurement and memory trace. See Smoothing.

Display - Displays the processed measurement and / or memory data in the format of your choice. If remotely requested data is the same format as the displayed data, the requested data comes from this buffer.


CalTopic

Perform a Calibration

SENS:CORR:COLL:METH

Set Cal Information

SENS:CORR:COLL:CKIT:SEL

Select a Cal Kit

Get a Handle to the Active Cal Kit

Simultaneous 2-Port Calibration

Acquisition Direction

SENS:CORR:COLL:ACQ

Measure a Standard

SENS:CORR:COLL:SAVE

Calculate Errors

SENS:CORR:COLL:ISOL

Isolation ON|OFF

SENS:CORR:COEF

Display an Error Term

Perform an ECAL

SENS:CORR:COLL:CKIT

Do ECAL 1-Port

SENS:CORR:COLL:CKIT

Do ECAL 2-Port

Get ECAL Module Info

Recall / Save / Apply a Calibration or Error Term

SENS:CORR:CSET

Recall a Calibration

Apply a Calibration to a measurement

SENS:CORR:CSET:SAVE

Save a Calibration

To Save or Recall an Error Term, see DATA

SENS:CORR:COLL:APPLy

Apply an Error Term after Uploading

Correction Settings

SENS:CORR:STAT

Correction ON|OFF for a measurement

SENS:CORR:INT:STAT

Interpolation ON|OFF

SENS:CORR:EXT:STAT

Extensions ON|OFF

SENS:CORR:EXT:PORT

Port 1 Extensions Value

SENS:CORR:EXT:PORT

Port 2 Extensions Value

SENS:CORR:EXT:REC

Receiver A Extensions Value

SENS:CORR:EXT:REC

Receiver B Extensions Value

SENS:CORR:RVEL:COAX

Relative Velocity

Modify Cal Kits

SENS:CORR:COLL:CKIT:SEL

Set a Cal Kit Active

Get a Handle to the Active Cal Kit

Save All Cal Kits after Modifying

Load (Recall) All Cal Kits

SENS:CORR:COLL:CKIT:SEL

Restore Cal Kit Default

Restore ALL Cal Kits Default

Build a Hybrid Cal Kit

SENS:CORR:COLL:CKIT:NAME

Set the Name of a Cal Kit

Get the Number of Cal Kit

Set the Port Label of a Cal Kit

Modify Cal Standards

SENS:CORR:COLL:CKIT:STAN:SEL

Select a Cal Standard

SENS:CORR:COLL:CKIT:ORDER

Assign a Class to a Standard

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Standard Type

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Delay

SENS:CORR:COLL:CKIT:STAN:LOSS

Set Loss

SENS:CORR:COLL:CKIT:STAN:IMP

Set Impedance

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Max Frequency

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Min Frequency

SENS:CORR:COLL:CKIT:NAME

Set Label

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Medium (coax|waveguide)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.C0

Set Capacitance (C0 to C3)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.L0

Set Inductance (L0 to L3)


CFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


ChanTopic

Preset

Start Freq

Stop Freq

Center Freq

Span

CW Frequency

Power Settings

Power ON | OFF

Power Value

Port Selection

Couple Ports OFF | ON

Attenuator Mode Auto|Manual

Attenuation Value

Power Slope Mode Manual | Auto

Power Slope Value

Receiver Attenuation

Averaging

Average ON|OFF

Average Count

Average Restart

Manage Channels

Add

Make Active

Read Channel Number

Read Number of Channels


Data Access Map

 Raw Measurement Data Standard Acquisition Data Calibration Error Terms Memory Measurement Results Memory Results Error Correction Trace Math Filter Gating Phase Correction Time Domain Transform Display Formatting Data Smoothing Display


DataTopic

See a map of the measurement processing chain with data access locations

Retrieve Measurement Data FROM the Analyzer

Retrieve complex data from the specified location.

Retrieve typed NAComplex data from the specified location.

Retrieve data pairs from the specified location.

Retrieve scalar data from the specified location.

Retrieve variant data from the specified location

Specifies ASCII or REAL type for data transfers

Retrieve complex or formatted data from the measurement or memory result buffer

Put Measurement Data INTO the Analyzer

Put complex data into the specified location.

Put typed NAComplex data into the specified location.

Put scalar data into the measurement result location.

Put complex Variant data into the specified location.

Put complex or formatted data into the measurement or memory result buffer

Retrieve Calibration Data FROM the Analyzer

Retrieve complex Error Term data

Retrieve variant Error Term data

Retrieve Error Term data

Retrieve complex Standard aquisition data

Retrieve variant Standard aquisition data

Put Calibration Data INTO the Analyzer

Put complex Error Term data

Put variant Error Term data

Put Error Term data

Put complex Standard aquisition data

Put variant Standard aquisition data


DFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


FileTopic

Save States (Inst | Cal | Both)

Recall States (Inst | Cal | Both)

Manage Files

List Files

Copy Files

Move Files

Delete Files

Manage Folders

Change

Delete

Make

Print

Print

Print to File


Help Tips

Functionality Help

The link in the upper right corner of most commands goes to a help topic about the analyzer function related to the command.

Copy Help

Copy this Help system to your development workstation. The file is located on your PNA hard-drive (C:\ Winnt\ Help\ PNAHelp.chm). It is also on the CDROM that shipped with the PNA.

Copy 'n Paste

Copy and Paste code from this Help system directly into your programming environment. There is paste-able code in the following places:

  • SCPI and COM Example programs.

  • List of SCPI commands at the bottom of each SCPI topic


MarkerTopic

ON|OFF

Delete All Markers

Delete Marker

Interpolate All Markers

Interpolate Individ. Marker

Type (Normal | Fixed)

Marker=> Center, Span, and so forth

Marker=> Center (Freq)

Marker=> CW Freq

Marker=> Start (Freq)

Marker=> Stop (Freq)

Marker=> Elect. Delay

Marker=> Ref. Level

Format All Markers

Format Individ. Marker

Assign Marker to Domain

Domain Range Start

Domain Range Stop

Get a handle to Ref marker

Reference Marker On | Off

Delta Marker

Read/Set Data Point number

Read/Set X-axis value

Read/Set Y-axis value

Search

Execute Search

Select Search Function

Maximum

Minimum

Target (Value)

Excursion Value

Threshold Value

Tracking

Bandwidth (Target)

Search Filter Bandwidth

Read Filter BandWidth

Read Filter Center Freq

Read Filter Loss

Read Filter Q


Refl Meas

Reflection Measurements

Reflection measurements are an important part of network analysis. This topic discusses the following:

What are Reflection Measurements?

Why Make Reflection Measurements?

Expressing Reflected Waves

Return Loss

VSWR

Reflection Coefficient

Impedance

Summary of Expressions

Accuracy Considerations

What are Reflection Measurements?

To understand reflection measurements, it is helpful to think of traveling waves along a transmission line in terms of a lightwave analogy. We can imagine incident light striking some optical component like a clear lens. Some of the light is reflected off the surface of the lens, but most of the light continues on through the lens. If the lens had mirrored surfaces, then most of the light would be reflected and little or none would be transmitted.

With RF energy, reflections occur when the impedance of two mated devices are not the same. A reflection measurement is the ratio of the reflected signal to the incident signal. Network analyzers measure the incident wave with the R (for reference) channel and the reflected wave with the A channel. Therefore, reflection is often shown as the ratio of A over R (A/R). We can completely quantify the reflection characteristics of our device under test (DUT) with the amplitude and phase information available at both the A and R channel. In S-parameter terminology, S11 is a reflection measurement of port1 of the device (the input port); S22 is a reflection measurement of the port 2 (the output port)

Why Make Reflection Measurements?

One reason we make reflection measurements to assure efficient transfer of RF power. We do this because:

  1. RF energy is not cheap. When energy is reflected, that means less energy is transmitted to where it is intended to go.

  2. If the reflected energy is large, it can damage components, like amplifiers.

For example, in the following graphic, the radio station on the left is not operating at peak efficiency. The amplifier impedance is not the same as the transmission line, and the transmission line impedance is not the same as the antenna. Both of these conditions cause high reflected power. This condition results in less transmitted power, and the high reflected power could damage the amplifier.

The radio station on the right installed properly "matched" transmission line and antenna. Very little of the transmitted signal is reflected, resulting in increased broadcast power, more listeners, more advertising revenue, and more profit. The amplifier, transmission, and antenna all need to be measured to ensure that reflected power is minimized.

Expressing Reflected Waves

After making a reflection measurement, the reflection data can be expressed in a number of ways, depending on what you are trying to learn. The various expressions are all calculated by the analyzer from the same reflection measurement data. Each method of expressing reflection data can be graphically displayed in one or more formats. For more information, see display formats.

Return Loss

The easiest way to convey reflection data is return loss. Return loss is expressed in dB, and is a scalar (amplitude only) quantity. Return loss can be thought of as the absolute value or dB that the reflected signal is below the incident signal. Return loss varies between infinity for a perfect impedance match and 0 dB for an open or short circuit, or a lossless reactance. For example, using the log magnitude format on the analyzer, the measured reflection value on the screen may be -18dB. The minus sign is ignored when expressing return loss, so the component is said to have 18dB of return loss.

VSWR

Two waves traveling in opposite directions on the same transmission line cause a "standing wave". This condition can be measured in terms of the voltage standing wave ratio (VSWR or SWR for short). VSWR is defined as the maximum reflected voltage over the minimum reflected voltage at a given frequency. VSWR is a scalar (amplitude only) quantity. VSWR varies between one for a perfect match, and infinity for an open or short circuit or lossless reactance.

Reflection Coefficient

Another way of expressing reflection measurements is reflection coefficient gamma (G). Gamma includes both magnitude and phase.

The magnitude portion of gamma is called rho (r). Reflection coefficient is the ratio of the reflected signal voltage to the incident signal voltage. The range of possible values for r is between zero and one. A transmission line terminated in its characteristic impedance will have all energy transferred to the load; zero energy will be reflected and r = 0. When a transmission line terminated in a short or open circuit, all energy is reflected and r = 1. The value of rho is unitless.

Now for the phase information. At high frequencies, where the wavelength of the signal is smaller than the length of conductors, reflections are best thought of as waves moving in the opposite direction of the incident waves. The incident and reflected waves combine to produce a single "standing" wave with voltage that varies with position along the transmission line.

  • When a transmission line is terminated in its characteristic impedance (Zo) there is no reflected signal. All of the incident signal is transferred to the load. There is energy flowing in one direction along the transmission line.

  • When a transmission line is terminated in a short circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). The voltage across any short circuit is zero volts. Therefore, the voltage of the reflected wave will be 180 degrees out of phase with the incident wave, canceling the voltage at the load.

  • When a transmission line is terminated in an open circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). However, no current can flow in an open circuit. Therefore, the voltage of the reflected wave will be in phase with the voltage of the incident wave.

  • When a transmission line is terminated in a 25 ohm resistor, some but not all of the incident energy will be absorbed, and some will be reflected back towards the source. The reflected wave will have an amplitude 1/3 that of the incident wave and the voltage of the two waves will be out of phase by 180 degrees at the load. The phase relationship will change as a function of distance along the transmission line from the load. The valleys of the standing wave pattern will no longer go to zero, and the peaks will be less than that of the open / short circuit.

For more information, see Phase Measurements.

Impedance

Impedance is another way of expressing reflection data. For more information on Impedance, see Display formats / Smith Chart.

Summary of the Expressions of Reflection Measurements:

Accuracy Considerations

Reflection measurements can be made with the same setup as transmission measurements. If external attenuation is needed for gain measurements, calibrate with the attenuator in the system to remove its effects. Since reflection measurements involve loss instead of gain, power levels are lower at the receiver inputs. Therefore, it may be necessary to increase power levels for reflection measurements.

ANOTHER TAKE

The uncertainty of relection measurement is affected by directivity, source match, load match, and the reflection tracking of the test system. With a full 2-port calibration, the effects of these factors are minimized. A 1-port calibration provides the same accuracy if the output of the amplifier is well terminated. An example using the amplifier described earlier best illustrates this improvement. Total measurement uncertainty of input reutrn loss (worst case):

Response only calibration: ± 3.0 dB

Full 2-port calibration: ± 0.6 dB

Since the magnitude of the mismatch uncertainty depends on the input and output match of an amplifier, a measurement of a better matched amplifier will contain less uncertainty.

AND ANOTHER TAKE


ScaleTopic

AutoScale

AutoScale All

Per Division

Reference Level

Reference Position

Electrical Delay

Phase Offset


SweepTopic

Sweep Time Value

IF Bandwidth

Previous IF Bandwidth

Next IFBandwidth

Number of Points

Sweep Type (Lin | Pwr | CW | Seg)

Sweep Generation (Stepped | Analog)

Dwell Time Value

Alternate Sweeps

External ALC

Power Sweep

Start Power

Stop Power

Center

Span

Segment Sweep

ON|OFF

Add a segment

Delete a segment

Delete all segments

Count the segments

Read the segment number

Segment Center Frequency

Segment Frequency Span

Segment Start Frequency

Segment Stop Frequency

IF Bandwidth

IF Bandwidth Option

Source Power

Source Power Option

Trigger

Source (where trigger comes from)

Trigger Source (Int | Ext | Manual)

Internal | Manual

Trigger! (for Manual Source)

Ext. Trigger Slope (Positive | Negative)

Scope (what is triggered)

Trigger Scope (Global | Channel)

Channel Settings (how the channel responds to triggers)

Cont | Groups | Hold

Continuous

Number of Groups

Hold

Single

Trigger Mode (Point | Measurement)

Restart

Abort


SystemTopic

Quit application

Preset

Reset

Status Commands

Status Registers

*OPC;*WAI

Events

AllowAllEvents Method

AllowEventCategory Method

AllowEventMessage Method

AllowEventSeverity Method

DisallowAllEvents Method

MessageText Method

OnCalEvent

OnChannelEvent

OnDisplayEvent

OnHardwareEvent

OnMeasurementEvent

OnSCPIEvent

OnSystemEvent

OnUserEvent

SetFailOnOverRange

Macro

Execute Macro

Get Macro

Delete Macro

Put Macro


TraceTopic

Create S-Parameter Meas.

Create Measurement

Add Measurement

List Measurements

Delete a Measurement

Get a handle to a Trace

Select a Measurement

Read Channel Number

Read Number of Measurements

Read Measurement Parameter

Set / Read Measurement Name

Read Measurement Number

Change Parameter

Measurement Format

Math

Data Trace ON|OFF

Memory Trace ON|OFF

View Trace Type (Data|Memory|None)

Data =>Memory

Trace Math (Add|Sub|Mult|Div)

Smoothing

Smoothing ON|OFF

Smoothing Aperture

Smoothing Points

Statistics

Statistics ON|OFF

Statistics Range

Domain Range Start

Domain Range Stop

Set Type (Pk-Pk|StdDev|Mean)

Get All Statistics Data

Get Standard Deviation

Get Mean

Get Peak to Peak

Limit Lines

Display Lines ON|OFF

Fail Sound ON|OFF

Testing ON|OFF

Limit Test Failed

Count Limit Lines

Read Test Results

Make Limit Lines

Limit Line Type (Max|Min)

Begin Stimulus

End Stimulus

Begin Response

End Response

Transform

Transform ON|OFF

Mode (LowPass, BandPass)

Start Time

Stop Time

Center

Span

Step Rise Time

Set Low Pass Frequency

Gating

ON|OFF

Type (BandPass, Notch)

Shape

Start

Stop

Center

Span

Window

Kaiser Beta

Impulse Width


ViewTopic

Status Bar On|Off

Toolbars On|Off

Tables On|Off

Title Bars On|Off

X-axis values On|Off

Measurement Trace On|Off

Memory Trace On|Off

Title Annotation On|Off

Make a Title Annotation

Display Update ON|OFF

Window Update ON|OFF

Analyzer Visible

Add a Window

Activate a Window

Arrange Measurement Windows

Analyzer Window (Max|Min|Normal)


53 Finder

Indicates the most common of the network analyzer commands that have been mapped to a corresponding command in PNA. Since the commands listed on this page are base commands, commands that are derived from these base commands may not have a corresponding command in PNA.

Indicates a command that has not been mapped to a corresponding command in PNA, but may be in future revisions. However, this does not always indicate that the required functionality does not exist in PNA. See the 8753 Programming Guide for a description of the command functionality.

Description of Symbol Conventions

Legend

AB

ADAP1

ADDR

ADPT

ALC

ALTAB

ANAB

ANAI

AR

ASEG

ASSS

ATT

AUTO

AUXC

AVER

BACI

BANDPASS

BEEP

BLAD

BR

CAL1

CALF

CALI

CALK

CALN

CALSPORT

CALZ

CBRI

CENT

CHAN

CHOPAB

CLAD

CLASS

CLEA

CLEAL

CLEABIT

CLEASEQ

CLEL

CLES

CLS

COAD

COAX

COLO

COLOR

CONS

CONT

CONV

COPY

CORI

CORR

COU

CSWI

CWFREQ

CWTIME

D1DIVI2

D2XUPCH

D4XUPCH

DATI

DCONV

DEBU

DECRLOOC

DEFC

DEFLPRINT

DEFLTCPIO

DEFS

DEL

DELA

DEMO

DFLT

DIRS

DISC

DISM

DISP

DIVI

DONE

DONM

DOSEQ

DOWN

DUAC

DUPLSEQ

EDIT

ELED

EMIB

ENTO

ERCDONE

ESB?

ESE

ESNB

ESR?

EXTD

EXTM

EXTRCHAN

EXTT

FIXE

FORM

FORMAT

FREQ

FREQOFFS

FRER

FLUP

FWD

GATE

GATS

GOSUB

HARM

HOLD

IDN?

IF

IFBW

IMAG

INCRLOOC

INI

INPU

INSM

INT

INTE

ISO

J

KEY

KITD

KOR?

LAB

LABE

LEF

LIM

LIMI

LIMT

LINFREQ

LINM

LINT

LIS

LISTTYPE

LISV

LO

LOA

LOAD

LOADSEQ

LOGFREQ

LOGM

LOOC

LOWP

LRN

MANTRIG

MARK

MAXF

MEAS

MEASTAT

MENU

MINF

MINMAX

MINU

MODI1

MODS

NEWSEQ

NEXP

NOOP

NUMG

NUMR

OF

OFS

OMII

OPC

OPEP

OUTP

PARA

PARAL

PAUS

PCB

PCOL

PENN

PHAO

PHAS

PLOS

PLOT

PLT

PMTRTTIT

POIN

POL

PORE

PORT

PORTP

POWE

POWL

POWM

POWR

POWS

POWT

PRAN

PREP

PRES

PRI

PRIN

PRINTALL

PRN

PTOS

PURG

PWMC

PWRLOSS

PWRMCAL

PWRR

Q

RAI

RAWOFFS

READ

REAL

RECA

RECO

REF

REFT

REIC

RERCDONE

RESC

RESD

RESPDONE

REST

RETP

REV

RF

RFLP

RIG

RSCO

RST

S

SADD

SAMC

SAV

SAVE

SAVEUSEK

SAVU

SCAL

SCAP

SDEL

SDON

SEA

SEDI

SEG

SEL

SELL

SEQ

SEQWAIT

SET

SHOM

SING

SLI

SLOP

SM8

SMI

SMOO

SOFR

SOFT

SOUP

SPAN

SPEC

SPEG

SPLD

SPLID

SRE

SSEG

STAN

STAR

STB?

STDD

STDT

STEPSWP

STOP

STOR

STORSEQ

STPSIZE

SVCO

SWE

SWPSTART

SWR

TAK

TAKE4

TALKLIST

TESS?

TIMDTRAN

TIMESTAM

TINT

TIT

TITT

TRA

TRACK

TRAP

TRL

TSSWI

TST?

TSTIO

TSTP

TTL

UCONV

UP

USEPASC

USESENS

VELOFACT

VIEM

VOFF

WAIT

WAVD

WAVE

WID

WIND

WRSK


53Banner

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O

P

R

S

T

U

V

W

8753 Cross-Reference


ANotes

AB

8753 Command

Description

Range

Query Response

AB

Measures and displays A/B on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ALTAB

8753 Command

Description

Range

Query Response

ALTAB

Places the analyzer in the alternate inputs measurement mode, where A and B measurements are made on alternate sweeps. See also "CHOPAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Sets sweeps to either alternate or chopped.

PNA COM Equivalent - Notes

Sets sweeps to either alternate or chopped.

AR

8753 Command

Description

Range

Query Response

AR

Measures and displays A/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ASEG

8753 Command

Description

Range

Query Response

ASEG

Uses all segments for list frequency sweep. See also "SSEG".

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turn on each segment to be used with list frequency sweep.

PNA COM Equivalent - Notes

LimitSegment object.

ATT

8753 Command

Description

Range

Query Response

ATTP1><num>[DB]

Selects the amount of attenuation at PORT 1.

0–70 dB

<num><LF

ATTP2><num>[DB]

Selects the amount of attenuation at PORT 2.

0–70 dB

<num><LF

Note: These commands only apply to 8753ES Option 011 analyzers.

PNA SCPI Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

PNA COM Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

AUTO

8753 Command

Description

Range

Query Response

AUTO

Auto scale the active channel.

N/A

N/A

PNA SCPI Equivalent - Notes

Auto scale on the specified trace in the specified window.

PNA COM Equivalent - Notes

Auto scales the trace or all of the traces in the selected window.

AVER

8753 Command

Description

Range

Query Response

AVERREST

Restarts the averaging on the active channel.

N/A

N/A

AVERFACT<num>

Sets the averaging factor on the active channel.

integers 0–999

<num><LF

AVERO<ON|OFF>

Turns averaging on and off on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.

PNA COM Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.


BNotes

BLAD

8753 Command

Description

Range

Query Response

BLAD<ON|OFF>

Blanks the display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Blanks the display information in all windows.

Blanks the display information in a specified window.

PNA COM Equivalent - Notes

Makes the Network Analyzer application visible or not visible.

BR

8753 Command

Description

Range

Query Response

BR

Measures and displays B/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.


CNotes

CALI

CALIERC

CALIRERC

CALIFUL2

CALIRAI

CALIRESP

CALIS111

CALIS221

CALITRL2

8753 Command

Description

Range

Query Response

CALIFUL2

Begins the sequence for a short, load, open, thru (SLOT) 2-port calibration.

N/A

<0|1><LF>

CALIRAI

Begins the sequence for a response and isolation calibration.

N/A

<0|1><LF>

CALIRESP

Begins the sequence for a response calibration.

N/A

<0|1><LF>

CALIS111

Begins the sequence for an S11 1-port calibration (ES models), or a reflection 1-port calibration (ET models).

N/A

<0|1><LF>

CALIS221

Begins the sequence for an S22 1-port calibration.

N/A

<0|1><LF>

CALITRL2

Begins the sequence for a thru, reflect, line or line, reflect, match (TRL*/LRM*) 2-port calibration.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

CALIERC

Begins the sequence for a forward enhanced response calibration.

N/A

<0|1><LF>

CALIRERC

Begins the sequence for a reverse enhanced response calibration.

N/A

<0|1><LF>

Notes

These commands currently are not available.

CALK

8753 Command

Description

Range

Query Response

CALK24MM

Selects a 2.4-mm calibration kit (85056A/D) as the default cal kit.

N/A

<0|1>><LF

CALK292MM

Selects a 2.92-mm calibration kit as the default cal kit.

N/A

<0|1>><LF

CALK292S

Selects a 2.92* calibration kit (85056K) as the default cal kit.

N/A

<0|1>><LF

CALK35MD

Selects a 3.5-mm calibration kit (85052B/D for 8720E series analyzers, and 85033D for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALK35MC

Selects a 3.5-mm calibration kit (85033C) as the default cal kit. CALK35MM selects the 85033C cal kit for the 8752C and 8753D analyzers.

N/A

<0|1>><LF

CALK716

Selects a 7-16 calibration kit (85038) as the default cal kit.

N/A

<0|1>><LF

CALK7MM

Selects a 7-mm calibration kit (85050 series for 8720E series analyzers, and 85031B for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN50

Selects a type-N 50 ohm calibration kit (85054 for 8720E series analyzers, and 85032B/E for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN75

Selects a type-N 75 ohm calibration kit (85036B/E) as the default cal kit.

N/A

<0|1>><LF

CALKTRLK

Selects a TRL 3.5-mm calibration kit (85052C) as the default cal kit.

N/A

<0|1>><LF

CALKUSED

Selects a user-defined calibration kit.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Select the appropriate calibration kit. If the specific calibration kit is not listed, one can be created and stored in the User Defined section.

3 = CALKN50

4 = CALK35MD

5 = CALK716

6 = CALKTRLK

PNA COM Equivalent - Notes

Specifies the type of calibration kit to use in the calibration process.

CALN

8753 Command

Description

Range

Query Response

CALN

Turns calibration type to "off." See also "CORR."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the calibration method. Set to "NONE" to turn calibration off.

PNA COM Equivalent - Notes

Specifies and returns the type of calibration to be applied to the measurement. Set to "NONE" to turn calibration off.

CENT

8753 Command

Description

Range

Query Response

CENT<num>[HZ|DB]

Sets the center stimulus value. If a list frequency segment is being edited, sets the center of the list segment.

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To set the center frequency value.

To set the center frequency value for a segment.

PNA COM Equivalent - Notes

Read-Write the center frequency of all measurements in a channel or for a specified sweep segment.

CHAN

8753 Command

Description

Range

Query Response

CHAN1

Makes channel 1 the active channel. OPC-compatible.

N/A

N/A

CHAN2

Makes channel 2 the active channel. OPC-compatible.

N/A

N/A

CHAN3

Makes channel 3 the active channel. OPC-compatible.

N/A

N/A

CHAN4

Makes channel 4 the active channel. OPC-compatible.

N/A

N/A

Notes

Unlike the 8753 network analyzer, the PNA Series Network Analyzers do not need a separate channel to display each parameter. While the PNA Series has four independent measurement channels, only one channel is needed to display all four measurement parameters. In addition, up to four windows are available to view four active and four memory traces per window.

CHOPAB

8753 Command

Description

Range

Query Response

CHOPAB

Places the analyzer in the chop measurement mode. See also "ALTAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

PNA COM Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

CLASS

8753 Command

Description

Range

Query Response

CLASS11A

S11A: S11 (forward reflection) 1-port, open

N/A

N/A

CLASS11B

S11B: S11 (forward reflection) 1-port, short

N/A

N/A

CLASS11C

S11C: S11 (forward reflection) 1-port, load

N/A

N/A

CLASS22A

S22A: S22 (reverse reflection) 1-port, open

N/A

N/A

CLASS22B

S22B: S22 (reverse reflection) 1-port, short

N/A

N/A

CLASS22C

S22C: S22 (reverse reflection) 1-port, load

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

CLEAL

8753 Command

Description

Range

Query Response

CLEAL

Clears the limit line list. Should be preceded by EDITLIML.

N/A

N/A

PNA SCPI Equivalent - Notes

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF or make a new limit line.

PNA COM Equivalent - Notes

Delete the limit test collection.

CLEL

8753 Command

Description

Range

Query Response

CLEL

Clears the currently selected list. This could be a frequency list, power loss list, or limit test list. Must be preceded by an "EDIT" command.

N/A

N/A

PNA SCPI Equivalent - Notes

Clear a single sweep segment.

Clear all sweep segments.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

CLES

8753 Command

Description

Range

Query Response

CLES

Clears the status byte register, the event-status registers, and the enable registers. Same as CLS.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers.

PNA COM Equivalent - Notes

No equivalent command at present.

CLS

8753 Command

Description

Range

Query Response

CLS

Clears the status byte register, the event-status registers, and the enable registers. Same as CLES.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers. Replace "CLS" with "*CLS".

PNA COM Equivalent - Notes

No equivalent command at present.

CONT

8753 Command

Description

Range

Query Response

CONT

Places the analyzer in continuous sweep trigger mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

CORI

8753 Command

Description

Range

Query Response

CORI<ON|OFF>

Turns interpolative error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write correction interpolation ON or OFF.

PNA COM Equivalent - Notes

No equivalent command at present.

CORR

8753 Command

Description

Range

Query Response

CORR<ON|OFF>

Turns error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether or not correction data is applied to the measurement.

PNA COM Equivalent - Notes

Sets (or returns) error correction ON or OFF

CWFREQ

8753 Command

Description

Range

Query Response

CWFREQ<num>[HZ|DB]

Sets the CW frequency for power sweep and CW frequency modes. While the list frequency table segment is being edited, it sets the center frequency of the current segment. See also "MARKCENT."

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in the analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Continuous Wave (or Fixed) frequency.

PNA COM Equivalent - Notes

CW Frequency property.

CWTIME

8753 Command

Description

Range

Query Response

CWTIME

Selects CW time as the sweep type.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.


DENotes

DATI

8753 Command

Description

Range

Query Response

DATI

Stores the data trace in channel memory. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only the currently selected measurement trace into memory.

PNA COM Equivalent - Notes

Stores the active measurement into memory.

DEL

8753 Command

Description

Range

Query Response

DELO

Turns delta marker mode off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether marker is relative to the reference or not.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

DELR<num>

Makes the indicated marker the delta reference.

Integers 15

<0|1>><LF

DELRFIXM

Makes the fixed marker the delta reference.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If the reference marker is not turned ON, use this command to set the reference marker to ON.

Step 2

Set the reference marker to the correct position.

Step 3

Turn marker delta mode ON for the marker that will report the delta value measured from the reference marker.

PNA COM Equivalent - Notes

No equivalent command at present.

DELA

8753 Command

Description

Range

Query Response

DELA

Displays the data formatted as group delay.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

DISP

8753 Command

Description

Range

Query Response

DISPDATA

Data only.

N/A

<0|1>><LF

DISPDATM

Data and memory.

N/A

<0|1>><LF

DISPDDM

Data divided by memory (linear division, log subtraction). See also "DIVI."

N/A

<0|1>><LF

DISPDMM

Data minus memory (linear subtraction). See also "MINU."

N/A

<0|1>><LF

DISPMEMO

Memory only.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DIVI

8753 Command

Description

Range

Query Response

DIVI

Data divided by memory (linear division, log subtraction). See also "DISPDDM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DONE

8753 Command

Description

Range

Query Response

DONE

Done with a class of standards, during a calibration. Only needed when multiple standards are measured to complete the class.

N/A

N/A

Notes

Since this action is performed automatically in PNA, this command is no longer necessary.

EDIT

8753 Command

Description

Range

Query Response

EDITDONE

Done editing list frequency, limit table, cal sensor table, or power loss list.

N/A

N/A

EDITLIML

Begins editing limit table.

N/A

N/A

EDITLIST

Begins editing list frequency table.

N/A

N/A

Notes

Since these actions are performed automatically in PNA when working with a limit table, these commands are no longer necessary.

ELED

8753 Command

Description

Range

Query Response

ELED<num>[S]

Sets the electrical delay offset.

±10 seconds

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the electrical delay for the selected measurement.

PNA COM Equivalent - Notes

Sets the Electrical Delay

ESE

8753 Command

Description

Range

Query Response

ESE<num>

Enables the selected event-status register bits to be summarized by bit 5 in the status byte. An event-status register bit is enabled when the corresponding bit in the operand <num> is set.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Sets bits in the standard event status enable register. Replace "ESE" with "*ESE".

PNA COM Equivalent - Notes

No equivalent command at present.

ESR?

8753 Command

Description

Range

Query Response

ESR?

Query only. Outputs event-status register.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Returns the results of the standard event enable register. The register is cleared after reading it. Replace "ESR?" with "*ESR?".

PNA COM Equivalent - Notes

No equivalent command at present.

EXTM

8753 Command

Description

Range

Query Response

EXTMDATA

Adds error corrected data (real and imaginary pairs) along with the other files.

N/A

<0|1>><LF

EXTMDATO

Selected data arrays only (real and imaginary pairs), without instrument states or calibrations. Always saves the data array, even if it hasnt been selected.

N/A

<0|1>><LF

EXTMFORM

Formatted trace data. Uses currently selected format for data.

N/A

<0|1>><LF

EXTMRAW

Raw data arrays (real and imaginary pairs).

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data.

PNA COM Equivalent - Notes

Retrieves data.

8753 Command

Description

Range

Query Response

EXTMGRAP

User graphics.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Saves the screen data to bitmap (.bmp) file of the screen.

EXTT

8753 Command

Description

Range

Query Response

EXTT

Activates or deactivates the external trigger mode. OPC-compatible.

N/A

<0|1>><LF

EXTTPOIN

Sets the external trigger to auto-trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the source of the sweep trigger signal.

Read-Write whether the specified channel will measure one point when triggered or all of the measurements in the channel.

PNA COM Equivalent - Notes

Sets or returns the trigger source.

Determines the measurement that occurs when a trigger signal is sent to the channel.

8753 Command

Description

Range

Query Response

EXTTHIGH

Sets the external trigger line high.

N/A

N/A

EXTTLOW

Sets the external trigger line low.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

No equivalent command at present.


FGHNotes

FORM

8753 Command

Description

Range

Query Response

FORM1

The analyzer's internal binary format, 6 bytes-per-data point. The array is preceded by a four-byte header. The first two bytes represent the string "#A", the standard block header. The second two bytes are an integer representing the number of bytes in the block to follow. FORM1 is best applied when rapid data transfers, not to be modified by the computer nor interpreted by the user, are required.

N/A

N/A

FORM2

IEEE 32-bit floating-point format, 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 8-bit biased exponent, and a 23-bit mantissa. FORM2 is the format of choice if your computer is not a PC, but supports single-precision floating-point numbers.

N/A

N/A

FORM3

IEEE 64-bit floating-point format, 8 bytes-per-number, 16 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 11-bit biased exponent, and a 52-bit mantissa. This format may be used with double-precision floating-point numbers. No additional precision is available in the analyzer data, but FORM3 may be a convenient form for transferring data to your computer.

N/A

N/A

FORM4

ASCII floating-point format. The data is transmitted as ASCII numbers. There is no header. The analyzer always uses FORM4 to transfer data that is not related to array transfers (i.e. marker responses and instrument settings). Data is comma delimited.

N/A

N/A

FORM5

PC-DOS 32-bit floating-point format with 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. The byte order is reversed with respect to FORM2 to comply with PC-DOS formats. If you are using a PC-based controller, FORM5 is the most effective format to use.

N/A

N/A

PNA SCPI Equivalent - Notes

FORM1, the 8753 analyzer's internal binary format, is not compatible with PNA.

For FORM2, FORM3, and FORM4, use this SCPI command.

Step 1

For FORM5, format the data to 32-bit with the SCPI command in Step 1. Then, swap the bits with the SCPI command in Step 2.

Step 2

PNA COM Equivalent - Notes

No equivalent command at present.

FRER

8753 Command

Description

Range

Query Response

FRER

Places the analyzer in GPIB free run mode. (Same as continuous sweep trigger mode.) See "CONT."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

FWD

8753 Command

Description

Range

Query Response

FWDI

Selects the forward isolation calibration class during a 2-port calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit. See "STAN5".

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

FWDM

Selects the forward match calibration class during a 2-port calibration sequence.

N/A

N/A

FWDT

Selects the forward transmission calibration class during a 2-port calibration sequence.

N/A

N/A

Notes

Both the forward match and the forward transmission are measured automatically during a 2-port calibration on the PNA Series Network Analyzers.

HOLD

8753 Command

Description

Range

Query Response

HOLD

Puts the sweep trigger into hold mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode. Set the sweep trigger mode to "OFF".

PNA COM Equivalent - Notes

Put the sweep trigger into hold mode.


INotes

IDN?

8753 Command

Description

Range

Query Response

IDN?

Query only. Outputs the identification string: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument.

N/A

See command description.

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer. Replace "IDN?" with "*IDN?".

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

IFBW

8753 Command

Description

Range

Query Response

IFBW<num>[HZ]

Sets the IF bandwidth.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the bandwidth of the digital IF filter to be used in the measurement.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.

IMAG

8753 Command

Description

Range

Query Response

IMAG

Selects the imaginary display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

INPU

INPUCALC

INPUCALK

INPUDATA

INPUFORM

INPULEAS

INPUPMCAL1

INPUPMCAL2

INPURAW1

INPURAW2

INPURAW3

INPURAW4

8753 Command

Description

Range

Query Response

INPUDATA

Inputs an error corrected data array, using the current setting of the FORM command.

N/A

N/A

INPUFORM

Inputs a formatted data array, using the current setting of the FORM command.

N/A

N/A

INPURAW1

Inputs raw data array 1 (S11 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW2

Inputs raw data array 2 (S21 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW3

Inputs raw data array 3 (S12 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW4

Inputs raw data array 4 (S22 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Input the data array.

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

PNA COM Equivalent - Notes

Step 1a

Input raw data.

Step 1b

Input formatted data

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

8753 Command

Description

Range

Query Response

INPUCALC<num><array>

Inputs an error coefficient array <num>.

Two-digit integers 01–12

N/A

INPUCALK<array>

Inputs a cal kit array in FORM1 only. Can be read out with the OUTCALK command. After the transfer, the data should be saved into the user cal kit area with the SAVEUSEK command.

N/A

N/A

INPULEAS<learnstring>

Inputs a learn string in FORM1 only. Can be read out with the OUTPLEAS command, or with INPULEAS?.

N/A

<data><LF >

INPUPMCAL1<array>

Inputs power meter calibration arrays for channel 1 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

INPUPMCAL2<array>

Inputs power meter calibration arrays for channel 2 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

Notes

These commands currently are not available.


LNotes

LIM

8753 Command

Description

Range

Query Response

LIMS

Sets the limit stimulus break point.

Stimulus range.

Currently this command can be queried by sending the command by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the start (beginning) of the X-axis stimulus value.

Read-Write the stop (end) of the X-axis stimulus value.

PNA COM Equivalent - Notes

Specifies the beginning X-axis value of the Limit Line.

Specifies the end X-axis value of the Limit Line.

8753 Command

Description

Range

Query Response

LIMD

Sets the limit delta value while editing a limit line segment.

Amplitude range.

Currently this command can be queried by sending the command by the OUTPACTI command.

LIML

Sets the lower limit value.

Amplitude range.

Same as above.

LIMM

Sets the middle limit value.

Amplitude range.

Same as above.

LIMU

Sets the upper limit value.

Amplitude range.

Same as above.

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LIMI

LIMIAMPO

LIMILINE

LIMIMAOF

LIMISTIO

LIMITEST

8753 Command

Description

Range

Query Response

LIMILINE<ON|OFF>

Turns the display of the limit lines on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display of limit lines ON or OFF.

PNA COM Equivalent - Notes

Turns the display of limit lines ON or OFF.

8753 Command

Description

Range

Query Response

LIMITEST<ON|OFF>

Turns limit testing on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write limit line testing ON or OFF.

PNA COM Equivalent - Notes

Turns an object ON and OFF.

8753 Command

Description

Range

Query Response

LIMIAMPO<num>[HZ|DB]

Enters the limit line amplitude offset.

Amplitude range.

<num>><LF

LIMIMAOF

Marker to limit offset. Centers the limit lines about the current marker position using the limit amplitude offset function.

N/A

N/A

LIMISTIO<num>[HZ|DB]

Enters the stimulus offset of the limit lines.

Stimulus range.

<num>><LF

Notes

These commands currently are not available.

LIMT

8753 Command

Description

Range

Query Response

LIMTFL

Makes the segment a flat line.

N/A

<0|1>><LF

LIMTSL

Makes the segment a sloping line.

N/A

<0|1>><LF

LIMTSP

Makes the segment a single point.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LINFREQ

8753 Command

Description

Range

Query Response

LINFREQ

Selects a linear frequency sweep.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

LINM

8753 Command

Description

Range

Query Response

LINM

Selects the linear magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

LIS

LISFREQ

LISIFBWM

LISPWRM

8753 Command

Description

Range

Query Response

LISFREQ

Selects the list frequency sweep mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the sweep type.

PNA COM Equivalent - Notes

Selects the sweep type.

8753 Command

Description

Range

Query Response

LISIFBWM<ON|OFF>

Enables/disables the IFBW setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether the IF Bandwidth resolution can be set independently for each segment.

Read-Write the IFBandwidth for the specified segment.

PNA COM Equivalent - Notes

Enables the IFBandwidth to be set on individual sweep segments.

Sets or returns the IF Bandwidth of the segment.

8753 Command

Description

Range

Query Response

LISPWRM<ON|OFF>

Enables/disables the power setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether Power Level can be set independently for each segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Enables the source power to be set on individual sweep segments.

Sets or returns the RF power level of the segment.

LISTTYPE

8753 Command

Description

Range

Query Response

LISTTYPELSTP

Selects the stepped list mode for use with a list-frequency table.

N/A

<0|1><LF>

LISTTYPELSWP

Selects the swept list mode for use with a list-frequency table.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Read-Write sweep as Stepped or Analog.

PNA COM Equivalent - Notes

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

LOAD

8753 Command

Description

Range

Query Response

LOAD<num>

Loads the file from disk using the file name provided by the preceding TITF<num>; command. The actual file loaded depends on the file title in the file position specified by the TITF<num> command. Requires pass control mode when using the GPIB port.

integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to load the specified file.

PNA COM Equivalent - Notes

Recalls a measurement state, calibration state, or both.

LOGM

8753 Command

Description

Range

Query Response

LOGM

Selects the log magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


MNotes

MANTRIG

8753 Command

Description

Range

Query Response

MANTRIG

Sets the trigger mode to manual trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

PNA COM Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

MARK

MARK<1|2|3|4|5> | MARKMAXI
MARKBUCK | MARKMIDD
MARKCENT | MARKMINI
MARKCONT | MARKOFF
MARKCOUP | MARKREF
MARKCW | MARKSPAN
MARKDELA | MARKSTAR
MARKDISC | MARKSTIM
MARKFAUV | MARKSTOP
MARKFSTI | MARKUNCO
MARKFVAL | MARKZERO

8753 Command

Description

Range

Query Response

MARK<1|2|3|4|5><num>

Makes the selected marker active and sets its stimulus value.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Set the specified marker ON. Note: CALCulate commands act on the selected measurement. You must have a measurement defined and selected before a marker can be turned on. To define a measurement use CALCulate<cnum>:PARameter:DEFine <Mname>,<param>. Select the measurement for each channel using CALCulate<cnum>:PARameter:SELect <Mname>.

Step 2

Set the marker's X-axis value (frequency, power, or time).

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKBUCK<num>

Places the active marker on a specific sweep point (bucket). <num> is the bucket number.

0 to (number-of-points - 1). For example, on a 201 point sweep, <num> can range from 0 to 200.

<num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Sets or returns the bucket number (data point) for the active marker.

8753 Command

Description

Range

Query Response

MARKCENT

Sets the center stimulus value to that of the active marker's stimulus value.

N/A

N/A

MARKSTAR

Sets the start stimulus to that of the active marker's.

N/A

N/A

MARKSTOP

Sets the stop stimulus to that of the active marker's.

N/A

N/A

MARKREF

Sets the reference value to that of the active marker's amplitude.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the selected instrument setting to assume the value of the specified marker.

PNA COM Equivalent - Notes

Changes the analyzer's center frequency to the X-axis position of the marker. The start frequency stays the same and the stop frequency adjusts.

Changes the analyzer's start frequency to the X-axis position of the marker. The stop frequency stays the same and the frequency span adjusts.

Changes the analyzer's stop frequency to the X-axis position of the marker. The start frequency stays the same and the frequency span adjusts.

Changes the measurement's reference level to the marker's Y-axis value.

8753 Command

Description

Range

Query Response

MARKDELA

Sets electrical length so group delay is zero at the active marker's stimulus.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the measurement's electrical delay value to the marker's delay value.

8753 Command

Description

Range

Query Response

MARKMAXI

Search for trace maximum on the current channel. Same as SEAMAX.

N/A

<0|1>><LF

MARKMINI

Search for trace minimum on the current channel. Same as SEAMIN.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If a marker is not currently turned ON, set marker to ON with this command.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

MARKCONT

Places the markers continuously on the trace, not on discrete points (interpolates the marker values between discrete points).

N/A

<0|1>><LF

MARKDISC

Places the markers on the discrete measurement points.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the specified marker as either interpolate data or not.

PNA COM Equivalent - Notes

Turns All Marker Interpolation ON and OFF for the measurement.

8753 Command

Description

Range

Query Response

MARKOFF

Turns all markers and marker functions off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Write-only all markers off for selected measurement.

PNA COM Equivalent - Notes

Turn markers OFF by deleting all of the markers from the measurement.

8753 Command

Description

Range

Query Response

MARKCW

Sets the CW frequency to the active marker's frequency.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

8753 Command

Description

Range

Query Response

MARKFSTI<num>

Sets the stimulus position of the fixed marker.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

If the marker is not turned ON, set the marker ON.

Step 2

Set the marker type to "Fixed".

Step 3

Set the position of the marker.

PNA COM Equivalent - Notes

Step 1

Sets and reads the marker type.

Step 2

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKMIDD

Makes the marker amplitude the limit segment middle value during a limit segment edit.

N/A

N/A

MARKSPAN

Sets the span for the entire trace to that of the span between the active marker and the delta reference marker.

N/A

N/A

MARKSTIM

During a limit segment edit, sets the limit stimulus break point to that of the active marker's.

N/A

N/A

MARKZERO

Places the fixed marker at the active marker position and makes it the delta reference.

N/A

N/A

Notes

These functions require multiple SCPI or COM commands along with appropriate math calculations.

8753 Command

Description

Range

Query Response

MARKCOUP

Couples the markers between the channels, as opposed to MARKUNCO.

N/A

<0|1>><LF

MARKUNCO

Uncouples the markers between channels, as opposed to MARKCOUP.

N/A

<0|1>><LF

MARKFAUV

Sets the auxiliary value of the fixed marker position. Works in coordination with MARKFVAL and MARKFSTI.

Amplitude range. Same as MARKFVAL.

<num><LF

MARKFVAL

Sets the value of the fixed marker position.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

Notes

These commands are currently not supported.

MEAS

8753 Command

Description

Range

Query Response

MEASA

Measures and displays input A on the active channel.

N/A

<0|1>><LF

MEASB

Measures and displays input B on the active channel.

N/A

<0|1>><LF

MEASR

Measures and displays input R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

MEASTAT

8753 Command

Description

Range

Query Response

MEASTAT<ON|OFF>

Turns trace statistics on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

MINMAX

8753 Command

Description

Range

Query Response

MINMAX<ON|OFF>

Enables/disables min/max recording per segment. Min and max values are recorded per limit segment. Limit testing need not be active.

N/A

<0|1>><LF

Notes

This command is not available on PNA.

MINU

8753 Command

Description

Range

Query Response

MINU

Data minus memory (linear subtraction). See also "DISPDMM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.


NONotes

NUMG

8753 Command

Description

Range

Query Response

NUMG<num>

Activates the indicated number of groups of sweeps. A group is whatever is needed to update the current parameter once. This function restarts averaging if it is enabled. OPC-compatible.

Integers 1999.

N/A

PNA SCPI Equivalent - Notes

Step 1

Set the number of groups.

Step 2

Set the trigger mode to groups.

PNA COM Equivalent - Notes

No equivalent command at present.

OMII

8753 Command

Description

Range

Query Response

OMII

Omits the isolation step of a calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write isolation cal ON or OFF during Full 2-port calibration.

PNA COM Equivalent - Notes

No equivalent command at present.

OPC

8753 Command

Description

Range

Query Response

OPC

Operation complete. Reports the completion of the next command received by setting bit 0 in the event-status register, or by replying to an interrogation if OPC? is issued.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Operation complete command. Replace "OPC" with "*OPC".

Operation complete query. Replace "OPC?" with "*OPC?".

PNA COM Equivalent - Notes

No equivalent command at present.

OUTP

OUTPACTI | OUTPFAIP | OUTPMARK | OUTPRAF
OUTPAMAX | OUTPFORE | OUTPMEMF | OUTPRAW
OUTPAMIN | OUTPFORM | OUTPMEMO | OUTPRFFR
OUTPAPER | OUTPICAL | OUTPMSTA | OUTPSEGAF
OUTPCALC | OUTPIDEN | OUTPMWID | OUTPSEGAM
OUTPCALK | OUTPIPMCL | OUTPMWIL | OUTPSEGF
OUTPCHAN | OUTPKEY | OUTPOPTS | OUTPSEGM
OUTPDATA | OUTPLEAS | OUTPPLOT | OUTPSEQ
OUTPDATF | OUTPLIM | OUTPPMCAL | OUTPSERN
OUTPDATP | OUTPLIMF | OUTPPRE | OUTPSTAT
OUTPDATR | OUTPLIML | OUTPPRIN | OUTPTITL
OUTPERRO | OUTPLIMM | OUTPPRNALL |

8753 Command

Description

Range

Query Response

OUTPAPER

Outputs the smoothing aperture in stimulus units, rather than as a percentage.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

PNA COM Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

8753 Command

Description

Range

Query Response

OUTPCALC

Outputs the selected error coefficient array for the active cal on the active channel.

Two-digit integers 0112

<array><LF

PNA SCPI Equivalent - Notes

Output the error coefficient array.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPCALK

Outputs the currently active calibration kit, as a string of less than 1000 bytes. The data is in FORM1.

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Read-Write a name for the selected calibration kit.

PNA COM Equivalent - Notes

Sets and Returns a name for the selected calibration kit.

8753 Command

Description

Range

Query Response

OUTPDATA

Outputs the error-corrected data from the active channel in real/imaginary pairs.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the error-corrected data array.

PNA COM Equivalent - Notes

Output the error-corrected data array.

8753 Command

Description

Range

Query Response

OUTPFORM

Outputs the formatted display data array from the active channel, in current display units.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPIDEN

Outputs the identification string for the analyzer in the form: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument. (Same as the "IDN?" command.)

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer.

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

8753 Command

Description

Range

Query Response

OUTPLIM

Outputs the status of the limit test for the channel selected with <num>.

Integers 14

<0|1|-1><LF

PNA SCPI Equivalent - Notes

Check status bit to determine status of the limit test.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPLIML

Outputs the limit test results for each point in the sweep. This is an ASCII transfer.

N/A

<array><LF

OUTPLIMM

Outputs the limit test results at the active marker.

N/A

<num,num,num,num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Returns the result of limit line testing.

8753 Command

Description

Range

Query Response

OUTPMARK

Outputs the active marker values. The first two numbers are the marker response values, and the last is the stimulus value.

N/A

<num,num,num><LF >

PNA SCPI Equivalent - Notes

Read-Write the marker's X-axis value (frequency, power, or time).

Read-only the marker's Y-axis value.

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

Reads the Y-Axis value of the marker.

8753 Command

Description

Range

Query Response

OUTPMEMO

Outputs the memory trace from the active channel. The data is in real/imaginary pairs, and can be treated the same as data read with the OUTPDATA command.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data. When querying memory, you must first store a trace into memory using CALCuate<cnum>:MATH:MEMorize

PNA COM Equivalent - Notes

If the data is not in memory, store data into memory.

Output memory data.

8753 Command

Description

Range

Query Response

OUTPMSTA

Outputs the marker statistics in ASCII format: mean, standard deviation, and peak-to-peak variation in that order. If statistics is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num><LF

PNA SCPI Equivalent - Notes

Step 1

Select the statistic TYPE that you can then query.

Step 2

Read the selected trace statistic.

PNA COM Equivalent - Notes

Returns the Trace Statistics.

8753 Command

Description

Range

Query Response

OUTPMWID

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, and Q in that order. If widths is not on, it is turned on to generate current values and then turned off again.

N/A

<num,num,num><LF>

OUTPMWIL

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, Q, and loss in that order. If widths is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num,num><LF>

PNA SCPI Equivalent - Notes

Use command to set and return filter statistics.

PNA COM Equivalent - Notes

Returns the Filter Statistics resulting from a SearchFilterBandwidth method.

8753 Command

Description

Range

Query Response

OUTPOPTS

Outputs an ASCII string of the options installed in the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Returns a string identifying the analyzer option configuration.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPPRIN

Outputs a PCL raster dump of the display, intended for a graphics printer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

8753 Command

Description

Range

Query Response

OUTPRAW

Outputs the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPSERN

Outputs a string that contains the serial number of the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Output the serial number.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPSTAT

Returns the status byte as an ASCII integer (0255) that can be interpreted as the 8-bit status byte. This command is the same as "STB?."

N/A

<num><LF

PNA SCPI Equivalent - Notes

Reads the value of the instrument status byte.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPTITL

Outputs the display title in ASCII format.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

OUTPDATF

Fast data transfer command for OUTPDATA.

N/A

<array><LF

OUTPFORE

Fast data transfer command for OUTPFORM.

N/A

<array><LF

OUTPMEMF

Fast data transfer command for OUTPMEMO.

N/A

<array><LF

OUTPRAF<num>

Fast data transfer of the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

Notes

The PNA Series Network Analyzer outputs data at the fastest possible data rate at all times. Therefore, there are not any commands in the PNA Series that correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPACTI

Outputs the value of the active function, or the last active function if the active entry area is off. The value is returned in ASCII format.

N/A

<$><LF>

OUTPCHAN

Outputs the active channel number: 1, 2, 3, or 4.

N/A

<num><LF

OUTPDATP

Outputs the trace data indexed by point (see "SELPT").

N/A

<num,num><LF

OUTPDATR

Outputs the trace data for a range of points (see "SELMINPT," "SELMAXPT"). This is an ASCII (FORM4) transfer.

N/A

<array><LF

Notes

The PNA Series Network Analyzer has features to output data and state information much different than earlier network analyzers. Therefore, there are not any commands in the PNA Series that directly correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPAMAX

Outputs the max values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPAMIN

Outputs the min values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPLIMF

Outputs the limit test results for each failed point, followed by the number of failed points. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAF

Outputs the segment number and its limit test status for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAM

Outputs the limit test min/max for all segments. Outputs the segment number, max stimulus, max value, min stimulus, min value for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGF

Outputs the limit test status for a specified segment. See also "SELSEG."

N/A

<0|1|-1><L F> Values returned for limit test status are: 0 (fail), 1 (pass), or -1 (no limit).

OUTPSEGM

Outputs limit test min/max for a specified segment. See also "SELSEG."

N/A

<num,num><LF

Notes

These limit and segment commands currently are not available.

8753 Command

Description

Range

Query Response

OUTPERRO

Outputs the oldest error message in the error queue. Sends the error number first, and then the error message itself, as an ASCII (FORM4) string no longer than 50 characters.

N/A

<num,$><LF

OUTPFAIP

This command is similar to OUTPLIMF except that it reports the number of failures first, followed by the stimulus and trace values for each failed point in the test. ASCII format.

N/A

<array><LF

OUTPICAL

Outputs the selected interpolated error coefficient array for the active cal on the active channel.

Two-digit integers 0112.

<array><LF

OUTPIPMCL

Outputs the interpolated power meter calibration array for channel 1 or channel 2. Values are returned as 100 times the interpolated power meter reading in dB. This is an ASCII transfer (FORM4).

Integers 1 or 2.

<array><LF

OUTPKEY

Outputs the key code of the last key pressed in ASCII format. An invalid key is reported with a 63, a knob turn with a -1. See programming manual for additional information.

N/A

<num><LF

OUTPLEAS

Outputs the learn string, which contains the entire front panel state, the limit table, and the list frequency table. It is always in binary format not intended for decoding.

N/A

<learnstring><LF

OUTPPLOT

Outputs the HP-GL plot string in ASCII format to the GPIB port. Can be directed to a plotter, or read into the computer.

N/A

<$><LF>

OUTPPMCAL

Outputs the power meter calibration array for channel 1 or channel 2. See programming manual for additional information.

Integers 1 or 2.

<array><LF

OUTPPRE

Outputs pre-raw data array <num>. See programming manual for additional information.

integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

OUTPPRNALL

Outputs all of the list values or the current page of operating parameters in ASCII format. See programming manual for additional information.

N/A

Rows of data separated by a <LF>. Ends with <LF><LF>.

OUTPRFFR

Outputs the external source RF frequency. The instrument must be in external source mode, using either INSMEXSA or INSMEXSM.

N/A

<num><LF

OUTPSEQ

Outputs the specified sequence listing to the GPIB port.

Integers 16.

<$><LF>

Notes

These commands currently are not available.


PNotes

PHAO

8753 Command

Description

Range

Query Response

PHAO<num>

Sets the phase offset.

0360 degrees

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the phase offset for the selected measurement.

PNA COM Equivalent - Notes

Sets the Phase Offset.

PHAS

8753 Command

Description

Range

Query Response

PHAS

Selects the phase display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

POIN

8753 Command

Description

Range

Query Response

POIN<num>

Sets the number of points in the sweep, or in a sweep segment.

Choose from: 3, 11, 21, 26, 51, 101, 201, 401, 801, 1601

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the number of data points for the measurement.

PNA COM Equivalent - Notes

Sets or returns the Number of Points.

POL

8753 Command

Description

Range

Query Response

POLA

Selects the polar display format.

N/A

<0|1>><LF

POLMLIN

Selects linear as the marker readout format for polar display.

N/A

<0|1>><LF

POLMLOG

Selects log as the marker readout format for polar display.

N/A

<0|1>><LF

POLMRI

Selects real/imaginary as the marker readout format for polar display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the polar display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the polar display format.

Selects the appropriate marker readout format.

PORE

8753 Command

Description

Range

Query Response

PORE<ON|OFF>

Turns port extensions on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write port extensions ON or OFF.

PNA COM Equivalent - Notes

Turns port extensions ON or OFF.

PORT

8753 Command

Description

Range

Query Response

PORT1<num>[S]

Set the port extension length for Port 1

±10 seconds

<0|1>><LF

PORT2<num>[S]

Set the port extension length for Port 2

±10 seconds

<0|1>><LF

PORTA<num>[S]

Set the port extension length for Input A

±10 seconds

<0|1>><LF

PORTB<num>[S]

Set the port extension length for Input B

±10 seconds

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the extension value at the specified port.

Read-Write the extension value at the specified receiver.

PNA COM Equivalent - Notes

Sets the port extension value for Port 1.

Sets the port extension value for Port 2.

Sets the port extension value for Receiver A.

Sets the port extension value for Receiver B.

PORTP

8753 Command

Description

Range

Query Response

PORTP<CPLD|UNCPLD>

Selects either coupled or uncoupled for the port powers of a given channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write Port Power Coupling ON or OFF.

PNA COM Equivalent - Notes

Turns ON and OFF source power coupling.

POWE

8753 Command

Description

Range

Query Response

POWE<num>[DB]

Sets the output power level.

output power range of your analyzer. The output power range of your analyzer depends upon the model and installed options. Refer to your analyzers users guide to determine the power range of your analyzer.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the RF power output level.

PNA COM Equivalent - Notes

Read-Write the RF power output level.

POWR

8753 Command

Description

Range

Query Response

POWR<num>

Sets the source power range. See also "PRAN."

Use two-digit integers 0007.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

POWS

8753 Command

Description

Range

Query Response

POWS

Selects power sweep from the sweep type menu.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

POWT

8753 Command

Description

Range

Query Response

POWT<ON|OFF>

Sets source power on or off. Works the opposite of the SOUP command. Sending POWTON turns source power off. Sending POWTOFF turns source power on.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turns ON and OFF Source Power.

PNA COM Equivalent - Notes

Turns ON and OFF Source Power.

PRAN

8753 Command

Description

Range

Query Response

PRAN<num>

Sets the source power range. See also "POWR."

integers 07.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PRES

8753 Command

Description

Range

Query Response

PRES

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Preset.

PNA COM Equivalent - Notes

Preset

PRIN

8753 Command

Description

Range

Query Response

PRINALL

Copies the display, in raster graphics mode, to a printer. Requires pass control when using the GPIB port. (Use PRINTALL to send ASCII data to the printer.)

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

PWRR

8753 Command

Description

Range

Query Response

PWRR<PMAN|PAUTO>

Selects whether the power range is in auto or manual mode.

N/A

<0|1>><LF 0 = manual mode; 1 = auto mode

PNA SCPI Equivalent - Notes

Read-Write automatic attenuation control ON or OFF. Setting the automatic attenuation control is equivalent to setting the source power range mode.

PNA COM Equivalent - Notes

Sets or returns the mode of operation of the attenuator control. Setting the automatic attenuation control is equivalent to setting the source power range mode.


RNotes

RAI

8753 Command

Description

Range

Query Response

RAID

Completes the response and isolation cal sequence. OPC-compatible.

N/A

N/A

RAIISOL

Calls the isolation class for the response and isolation calibration.

N/A

N/A

RAIRESP

Calls the response class for the response and isolation calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

REAL

8753 Command

Description

Range

Query Response

REAL

Sets the display format to real.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

REF

8753 Command

Description

Range

Query Response

REFP<num>

Enters the reference position. 0 is the bottom, 10 is the top of the graticule.

Integers 0–10

<num><LF

REFV<num>

Enters the reference line value.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Reference Position of the specified trace in the specified window.

Read-Write the Y axis Reference Level of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Reference Position of the active trace.

Sets or returns the value of the Y-axis Reference Level of the active trace.

RESPDONE

8753 Command

Description

Range

Query Response

RESPDONE

Completes the response calibration sequence. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data.

PNA COM Equivalent - Notes

Calculates the correction data.

REST

8753 Command

Description

Range

Query Response

REST

Measurement restart.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Abort the current sweep with the command in Step 1.

Step 2

Initiate a new sweep with the command in Step 2.

PNA COM Equivalent - Notes

No equivalent command at present.

REV

8753 Command

Description

Range

Query Response

REVI

Calls the reverse isolation calibration class during a full 2-port calibration.

N/A

N/A

REVM

Calls the reverse match calibration class during a full 2-port calibration.

N/A

N/A

REVT

Calls the reverse transmission calibration class during a full 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

RST

8753 Command

Description

Range

Query Response

RST

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Executes a device reset and cancels any pending *OPC command or query. Replace "RST" with "*RST".

PNA COM Equivalent - Notes

Resets instrument. Clears all existing windows and measurements.


SNotes

S

8753 Command

Description

Range

Query Response

S11

Forward reflection measurement.

N/A

<0|1>><LF

S12

Reverse transmission measurement.

N/A

<0|1>><LF

S21

Forward transmission measurement.

N/A

<0|1>><LF

S22

Reverse reflection measurement.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

SADD

8753 Command

Description

Range

Query Response

SADD

Adds a new segment to the table during a list-frequency, limit-table, cal sensor table, or power loss table edit.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to add a segment. A segment must be added prior to setting data in the segment.

PNA COM Equivalent - Notes

Add a segment.

SCAL

8753 Command

Description

Range

Query Response

SCAL<num>

Sets the trace scale factor.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Y axis Per Division value of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Y-axis Per Division value of the active trace.

SDEL

8753 Command

Description

Range

Query Response

SDEL

Deletes the current segment while editing a list frequency, a limit table, or a power loss list.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to delete the specified segment number.

Write-only to delete all segments.

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

SEA

SEAL

SEAMAX

SEAMIN

SEAOFF

SEAR

SEATARG

8753 Command

Description

Range

Query Response

SEAL

Search left for next occurrence of the target value.

N/A

N/A

SEAR

Search right for next occurrence of the target value.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Read-Write the target value for the specified marker when doing Target Searches.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Step 1

Sets the target value for the marker when doing Target Searches.

Step 2a

Moving to the left of the marker position, searches the marker's domain for the target value.

Step 2b

Moving to the right of the marker position, searches the marker's domain for the target value.

8753 Command

Description

Range

Query Response

SEAMAX

Search for trace maximum on the current channel.

N/A

<0|1><LF>

SEAMIN

Search for trace minimum on the current channel.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

SEAOFF

Turns the marker search off.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Turn marker search off by turning OFF the marker.

PNA COM Equivalent - Notes

Turn marker search off by turning OFF the marker.

8753 Command

Description

Range

Query Response

SEATARG<num>

Set the search target amplitude.

Amplitude range.

<num><LF>

PNA SCPI Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

PNA COM Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

SEDI

8753 Command

Description

Range

Query Response

SEDI<num>

During either a frequency, limit, or power loss table edit, selects segment <num> for editing.

State dependent. Range for frequency segment = 1 to 30; Range for limit test segment = 1 to 18; Range for power loss table segment = 1 to 12

<num><LF>

PNA SCPI Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. To edit a segment or limit line, see the following commands:

Commands to edit a segment.

Commands to edit a limit line.

PNA COM Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. See the appropriate methods and properties for segments and limit lines.

SEG

8753 Command

Description

Range

Query Response

SEGIFBW<num>

Sets the IFBW for the active segment of a list-frequency table in swept list mode.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000.

see "Note" below

SEGPOWER<num>

Sets the power for the active segment of a list-frequency table in swept list mode.

Output power range of your analyzer. The output power range is dependent upon the model and option configuration of your analyzer. Refer to your analyzers users guide to determine the output power range of your analyzer.

see "Note" below

Note: Currently these commands can be queried by sending the command followed by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the IFBandwidth for the specified segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.
OR
Sets or returns the IF Bandwidth of a specified sweep segment.

Sets or returns the RF power level of all measurements in a channel
or
Sets or returns the RF power level of a specified sweep segment.

SING

8753 Command

Description

Range

Query Response

SING

Single sweep. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

If sweep is not is single sweep mode, put the analyzer in single sweep mode by setting continuous OFF.

Trigger one sweep.

PNA COM Equivalent - Notes

Single sweep.

SMI

8753 Command

Description

Range

Query Response

SMIC

Selects Smith chart display format.

N/A

<0|1>><LF

SMIMGB

Selects G+jB (conductance and susceptance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLIN

Selects linear magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLOG

Selects log magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRI

Selects real/imaginary pairs (resistance and reactance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRX

Selects R + jX marker readout on a Smith chart.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the Smith chart display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the Smith chart display format.

Selects the appropriate marker readout format.

SMOO

8753 Command

Description

Range

Query Response

SMOOAPER<num>

Sets the smoothing aperture as a percent of the trace.

0.05 to 20%

<num><LF

SMOOO<ON|OFF>

Selects whether smoothing is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the amount of smoothing.

Read-Write data smoothing ON or OFF.

PNA COM Equivalent - Notes

Specifies or returns the amount of smoothing.

Turns data smoothing ON and OFF.

SOUP

8753 Command

Description

Range

Query Response

SOUP<ON|OFF>

Selects whether the source power is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write RF power from the source ON or OFF.

PNA COM Equivalent - Notes

Turns source power ON and OFF.

SPAN

8753 Command

Description

Range

Query Response

SPAN<num>[HZ|DB]

Sets the stimulus span value. If a list frequency segment is being edited, sets the span of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the frequency span of the analyzer.

Read-Write the frequency span for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the frequency span of all measurements in a channel
or
Sets or returns the frequency span of a specified sweep segment.

SRE

8753 Command

Description

Range

Query Response

SRE<num>

Service request enable. A bit set in <num> enables the corresponding bit in the status byte to generate an SRQ.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "SRE" with "*SRE".

PNA COM Equivalent - Notes

No equivalent command at present.

SSEG

8753 Command

Description

Range

Query Response

SSEG<num>

Selects the desired segment of the frequency list for a list frequency sweep. See also "ASEG".

Integers 130

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the specified segment ON or OFF.

The segment will not be turned on until the sweep type is set to "SEGMent" sweep with this command.

PNA COM Equivalent - Notes

Segment collection object.

STAR

8753 Command

Description

Range

Query Response

STAR<num>[HZ|DB]

Sets the start stimulus value. If a list frequency segment is being edited, sets the start of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the start frequency of the analyzer.

Read-Write the start frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the start frequency of all measurements in a channel
or
Sets or returns the start frequency of a specified sweep segment.

STB?

8753 Command

Description

Range

Query Response

STB?

Query only. Outputs the status byte in ASCII format (FORM4). Same as OUTPSTAT.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "STB?" with "*STB?".

PNA COM Equivalent - Notes

No equivalent command at present.

STOP

8753 Command

Description

Range

Query Response

STOP<num>[HZ|DB]

Sets the stop stimulus value. If a list frequency segment is being edited, sets the stop of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To Read-Write the stop frequency of the analyzer.

To Read-Write the stop frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the stop frequency of all measurements in a channel
or
Sets or returns the stop frequency of a specified sweep segment.

STOR

8753 Command

Description

Range

Query Response

STOR<num>

Stores the current instrument state to disk using the file name provided by the preceding TITF<num> command.

Integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to store the specified file.

PNA COM Equivalent - Notes

Saves a measurement state, calibration state, or both.

SWE

8753 Command

Description

Range

Query Response

SWEA

Automatically selects the fastest sweep time based on the current analyzer settings for number of points, IF bandwidth, sweep mode, averaging condition and frequency span.

N/A

N/A

SWET<num>[S]

Sets the sweep time. (Setting SWET0 is equivalent to sending the SWEA command.)

086,400 s

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the automatic sweep time function ON or OFF.

Read-Write the time the analyzer takes to complete one sweep.

PNA COM Equivalent - Notes

Sets the Sweep time of the analyzer. Setting sweep time to 0 will result in the fastest possible sweep time with the current settings.

SWR

8753 Command

Description

Range

Query Response

SWR

Selects the SWR display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


Symbol Conventions

Symbol

Description

<num>

Required numerical data.

<a1| a2>

An appendage that is part of the command. For example, FORMAT<DOS|LIF> indicates that the actual commands are FORMATDOS and FORMATLIF.

<$>

Indicates a character string operand which must be enclosed by double quotes.

|

An either/or choice in appendages or optional data.

[ ]

Optional data.

<LF>

Line feed.


TZNotes

TALKLIST

8753 Command

Description

Range

Query Response

TALKLIST

Selects the talker listener mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Selects the talker listener mode.

TIT

8753 Command

Description

Range

Query Response

TITL<$>

Enters a new display title.

48 characters max

N/A

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

TITF

Titles the indicated file numbers.

<num>: 15 <$>: 10 char. max.

N/A

TITP

Titles the plot to disk file.

10 characters max

N/A

TITR

Titles the indicated internal register.

<num>: 15 <$>: 10 char. max.

N/A

TITREG

Titles save/recall registers 01 through 31. TITREG01 through TITREG05 are the same as TITR1 through TITR5.

<num>: 0131 <$>: 10 char. max.

N/A

TITSEQ

Selects the sequence to be titled.

<num>: 16 <$>: 10 char. max.

N/A

TITSQ

Provides access to the sequence title functions.

N/A

N/A

Notes

These commands currently are not available.

TRACK

8753 Command

Description

Range

Query Response

TRACK<ON|OFF>

Turns marker search tracking on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write tracking capability for the specified marker.

PNA COM Equivalent - Notes

Turns marker search tracking on and off.

TRL

8753 Command

Description

Range

Query Response

TRLL1

Measures TRL Line/match for Port 1 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLL2

Measures TRL Line/match for Port 2 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR1

Measures TRL S11 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR2

Measures TRL S22 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLT

Measures TRL thru during a TRL/LRM 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the calibration method.

Write-only to measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Specifies the type of calibration to perform.

Measures the specified standard from the selected calibration kit.

TST?

8753 Command

Description

Range

Query Response

TST?

Query only. Causes a self test and returns a zero if the test is passed.

N/A

<num><LF>

PNA SCPI Equivalent - Notes

Returns the result of a complete self-test. An ASCII 0 indicates no failures found.

PNA COM Equivalent - Notes

No equivalent command at present.

TSTP

8753 Command

Description

Range

Query Response

TSTP<P1|P2>

Selects test port 1 or 2 for non-S-parameter measurements.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.

PNA COM Equivalent - Notes

Create and display the measurement. Method parameter allows one to select the specific port.

VELOFACT

8753 Command

Description

Range

Query Response

VELOFACT<num>

Enters the velocity factor of the transmission medium.

0 to 10

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the velocity factor to be used with Electrical Delay and Port Extensions.

PNA COM Equivalent - Notes

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

WAIT

8753 Command

Description

Range

Query Response

WAIT

Waits for a clean sweep when used with the OPC command.

N/A

N/A

PNA SCPI Equivalent - Notes

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed.

PNA COM Equivalent - Notes

No equivalent command at present.

WID

8753 Command

Description

Range

Query Response

WIDT<ON|OFF>

Turns the bandwidth search on and off.

N/A

<0|1><LF

WIDV<num>

Enters the widths search parameter.

Amplitude range.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Turn ON bandwidth search. Also, can return statistics.

Step 2

Turn marker tracking ON.

Step 3

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

PNA COM Equivalent - Notes

Step 1

Enter the bandwidth target value.

Step 2

Turn ON bandwidth search.

Step 3

Turn marker tracking ON.

The filter statistics can be returned with this method.

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with DeleteMarker method.


Number of Points Property

About ...

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Modifying Cal Kits

CalKitType Property

Write/Read

Description

Sets and returns a calibration kit type for calibration or to be used for kit modification. To get a handle to this kit, use app.ActiveCalKit

VB Syntax

object.CalKitType = value

Variable

(Type) - Description

object

Use either of these:
A calkit (object).
An Application (object).

Note: app.CalKitType and calkit.calKitType perform exactly the same function.

value

(enum naCalKit) - Calibration Kit type. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

naCalKit

Default

Not Applicable

Examples

calkit.CalKitType = naCalKit_85038A_7_16

kitype = app.CalKitType

C++ Syntax

HRESULT get_CalKitType(tagNACalKit *pVal)
HRESULT put_CalKitType(tagNACalKit newVal)

Interface

IApplication
ICalKit


CalType (perform) Property

About Performing a Calibration

SetCalInfo Property

Write-only

Description

Specifies the type of calibration to perform. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


About Limit Testing

LimitTestFailed Property

Read-only

Description

Returns the results of limit testing for the measurement.

VB Syntax

testFailed = meas.LimitTestFailed

Variable

(Type) - Description

testFailed

(boolean) Variable to store the returned value

False (0) - Limit Test Passed
True (1) - Limit Test Failed

meas

A Measurement (object)

Return Type

Boolean

Default

False returned if there is no testing in progress

Examples

Dim testRes As Boolean
testRes = meas.LimitTestFailed
MsgBox (testRes)

C++ Syntax

HRESULT get_LimitTestFailed(VARIANT_BOOL* trueIfFailed)

Interface

IMeasurement


Reference Marker Property

About Reference Markers

ReferenceMarker Property

Write/Read

Description

Sets (or releases) a marker as a Delta marker. A delta marker reads out data relative to the reference marker. If making a marker a delta marker, you must also turn the reference marker (always marker 10) ON using meas.marker(10)

VB Syntax

mark.ReferenceMarker = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Reference Marker number. Choose from:
0 - Makes the marker NOT a delta marker
10 - Makes the marker a delta marker

Return Type

Long Integer

Default

0 - absolute marker

Examples

mark.ReferenceMarker = 0 'makes the active marker absolute (not delta) -Write

refMark = mark.ReferenceMarker 'returns the reference marker number -Read

C++ Syntax

HRESULT get_ReferenceMarker(long *pVal)
HRESULT put_ReferenceMarker(long newVal)

Interface

IMarker


Reference Stimulus Property

About Reference Markers

ReferenceStimulus Property

Write/Read

Description

Sets or Reads the stimulus (X-Axis) value of the reference marker.

VB Syntax

mark.ReferenceStimulus = value

Variable

(Type) - Description

mark

A Marker (object) that is a delta marker.

value

(double) - stimulus value of the reference maker.

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceStimulus = 4.5e9 'Write

RefStim = mark.ReferenceStimulus 'Read

C++ Syntax

HRESULT get_ReferenceStimulus(double *pVal)
HRESULT put_ReferenceStimulus(double newVal)

Interface

IMarker


About Reference Markers

Reference Value (Marker) Property

Read-only

Description

Returns the Y-Axis value of the reference marker.

VB Syntax

yval = mark.ReferenceValue(format)

Variable

(Type) - Description

yvalue

A variable to store the Y-axis value of the reference marker

mark

A Marker (object) that is a delta marker.

format

(enum NAMarkerFormat) -format of the returned value. Choose from:

naMarkerFormat_LinMag
naMarkerFormat_LogMag
naMarkerFormat_Phase
naMarkerFormat_Delay
naMarkerFormat_Real
naMarkerFormat_Imaginary
naMarkerFormat_SWR
naMarkerFormat_LinMagPhase
naMarkerFormat_LogMagPhase
naMarkerFormat_RealImaginary
naMarkerFormat_ComplexImpedance
naMarkerFormat_ComplexAdmittance

value

(double) - Reference Value

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceValue(naMarkerFormat_LinMag) = 10 'Write

RefVal = mark.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


Status Keywords

Status Command Keywords

About Status Registers

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

:CONDition?

:ENABle

:ENABle?

:EVENt?

:MAP

:NTRansition

:PTRansition

:CONDition?

Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

Query only - This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


PowerTrip

If this stuff ever gets implemented, here it is: (The image map is the same file name)

SENSe:POWer:AC:PROTect:CLEar

(Write-only) Clears a power trip
Examples | SENS:POW:AC:PROT CLE sense:power:ac:protect clear
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:POWer:AC:PROTect:STATe <ON | OFF>

(Read-Write) Enables or disables the protection circuit.
Parameters |
<ON | OFF> | ON (or 1) - Protection circuit is enabled OFF(or 0) - Protection circuit is disabled
Examples | SENS:POW:AC:PROT:STAT ON sense:power:ac:protect:state off
Query Syntax | SENSe:POWer:AC:PROTect:STATe?
Return Type | Boolean 1 - Protection circuit is enabled 0 - Protection circuit is disabled
Overlapped? | No
Default | ON

SENSe:POWer:AC:PROTect:TRIPped?

(Read-only) Queries whether the power is OFF due to an overpower condition.
Examples | SENSe:POWer:AC:PROTect:TRIPped? sense:power:ac:protect:tripped?
Query Syntax | SENSe:POWer:AC:PROTect:TRIPped?
Return Type | Boolean
Overlapped? | No
Default | Not Applicable


Calibrar medidas

Véase asimismo...

Haga clic en un botón para aprender a reducir los errores de medidas realizando una calibración de medida.

Descripción general de la calibración

Errores de medidas

Patrones de calibración

Seleccionar y realizar una calibración

Calibraciones precisas

Validez de una calibración


Extracción de datos

Imprimir, guardar y recuperar datos

Véase asimismo...

Haga clic en un botón para obtener información sobre la manera de extraer datos de medidas.

Guardar y recuperar un archivo

Imprimir una medida mostrada

Asignación de unidades


6_Tab

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


3 Tab Model

Three Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4 Tab Model

Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6 Tab Model

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers". The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


Reference Body

Power can be defined as the energy transfer per unit time averaged over many periods of the lowest frequency (RF or microwave) involved. The term "average power" is used in specifying almost all RF and microwave systems. Power level is expressed in decibels based on 1 milliwatt (dBm) or 1 watt (dBw).

Power Ranges

Automatic mode

Manual mode

Power coupling options

Power slope

Power sweep

Power Ranges

The built-in synthesized source contains a programmable step attenuator that allows you to directly and accurately set power levels in eight different power ranges. Each range has a total span of 25 dB. The eight ranges cover the instrument's full operating range from +10 dBm to -85 dBm. You can select a power range either manually or automatically.

Automatic Mode

You can select any power level within the total operating range of the instrument and the source attenuator will automatically switch to the corresponding range.

Each range overlaps its adjacent ranges by 15 dB, therefore, certain power levels are designated to cause the attenuator to switch to the next range so that optimum (leveled) performance is maintained. These transition points exist at -10 dB from the top of a range and at +5 dB from the bottom of a range. This leaves 10 dB of operating range.

Manual Mode

If you use the manual power range mode, you must first select the power range that corresponds to the power level you want to set. Consequently, you will not be able to set a power level that is outside the range limits. This feature is necessary to maintain accuracy once a measurement error-correction is switched on.

Power Coupling Options

You can couple the measurement channels settings, making the measurement stimulus the same. By default the power at the test ports are coupled, making the power levels at both ports the same. Uncoupling the channels will separate the sources. You can also uncouple the test ports, allowing you to have different power levels on each port.

Power Slope

Power slope compensates for power loss versus the frequency sweep. Starting at the selected power level, the output power increases by sloping the output power upwards proportionally to frequency. Enter the power slope in dB per GHz of sweep.

Power Sweep

Power is swept at a single frequency, from a start power value to a stop power value. You select the start and stop power values, using the start and stop functions. To set the frequency of the power sweep, you use the CW frequency function. The span of the swept power is limited to being equal to or within one of the eight pre-defined power ranges.

The attenuator will not switch to a different power range while in the power sweep mode.

Tell Me More


Reference Mini Guide

Guide to Learning About XYZ

Introduction text goes here...

In this Topic...

You will learn...

Topic Title

the basics of...

Topic Title

when to...

Topic Title

when to...

Topic Title

the basics of...

Topic Title

when to...