Übersicht über die Frontplatte

Siehe auch...

  • Erkunden Sie die Grafik mit Hilfe der Maus.

  • Klicken Sie auf die einzelnen Teile der Frontplatte, um nähere Informationen zu erhalten.


Übersicht über die Rückwand

Siehe auch...

  • Erkunden Sie die Grafik mit Hilfe der Maus.

  • Klicken Sie auf die Steckverbinder, um nähere Informationen zu erhalten.


Bedienungskonzept

Siehe auch...

Dem Analysator liegt das folgende Bedienungskonzept zu Grunde.

Kanal

Messkurve

Fenster

Grenzen der Darstellungsmöglichkeiten

  • Ein Kanal besitzt eine Anzahl voneinander unabhängiger Attribute, welche die Messdatenerfassung betreffen.

  • Diese Attribute gelten für alle Messkurven dieses Kanals.

  • Es sind insgesamt vier voneinander unabhängige Kanäle verfügbar.

  • Es können immer nur die Einstellungen für den jeweils aktiven Kanal geändert werden.

  • Für jede Messkurve können Sie Einstellungen vornehmen, welche die Art der Messdatendarstellung beeinflussen.

  • Es können maximal 16 Messkurven gleichzeitig dargestellt werden. Die Messkurven können entweder einem einzigen Kanal oder jeweils unterschiedlichen Kanälen zugeordnet sein.

  • Es können immer nur die Einstellungen für die jeweils aktive Messkurve geändert werden.

  • Die Messkurven werden in einem Fenster dargestellt.

  • Es können wahlweise 1, 2, 3 oder 4 Fenster gleichzeitig auf dem Bildschirm sichtbar sein.

1 Fenster | 2 Fenster
3 Fenster | 4 Fenster

  • Messkurven mehrerer Kanäle können in einem einzigen Fenster dargestellt werden.

  • Messkurven mehrerer Kanäle können in mehreren Fenstern dargestellt werden.

Grenzen der Darstellungsmöglichkeiten:

  • Maximal vier Fenster auf dem Bildschirm

  • Maximal vier aktuelle Messkurven und vier gespeicherte Messkurven pro Fenster.

  • 16 aktuelle Messkurven und 16 gespeicherte Messkurven auf dem Bildschirm

  • Vier voneinander unabhängige Messkanäle


Messprozedur

Allgemeine Messprozedur

Siehe auch...

1. Schritt. Messung einrichten

Bringen Sie den Analysator in die Grundeinstellung (Preset), wählen Sie die gewünschten Messparameter und das gewünschte Darstellungsformat.

2. Schritt. Messgenauigkeit und Messgeschwindigkeit optimieren

Optimieren Sie die Messgenauigkeit und die Messgeschwindigkeit durch Anwendung geeigneter Verfahren und Funktionen.

3. Schritt. Kalibrierung durchführen

Minimieren Sie die Messfehler mittels Kalibrierung.

4. Schritt. Messergebnisse analysieren

Analysieren Sie die Messergebnisse mit Hilfe von Markern, mathematischen Operationen und Grenzwerttests.

5. Schritt. Messdaten ausdrucken, abspeichern oder zurückladen

Speichern Sie die Messdaten ab und/oder drucken Sie sie aus.


Benutzerschnittstelle

Siehe auch...

Tastaturschnittstelle

Zugriff auf die Grundfunktionen

Zugriff auf Dialogfenster

Zugriff auf Drop-Down-Menüs

Mausschnittstelle

Tastaturschnittstelle: Zugriff auf die Grundfunktionen

Tastaturschnittstelle: Zugriff auf Dialogfenster

Tastaturschnittstelle: Zugriff auf Drop-Down-Menüs

Mausschnittstelle


Auffinden von Informationen

Auffinden von Informationen in der Online-Hilfe

Siehe auch...

Sie können von folgenden Stellen aus auf Hilfe-Informationen zugreifen:

Startseite und Symbolleiste

Index

Inhalt

Glossar

Dialogfenster

Links

Startseite und Symbolleiste

Index

Inhalt

Glossar

Hinweis: Wenn Sie auf ein Wort in grüner Farbe klicken, wird der betreffende Begriff erläutert (diese Informationen stammen aus dem Glossar).

Dialogfenster

Links


Thema drucken

Ausdrucken des aktuellen Hilfethemas

Siehe auch...


Schließen des Hilfefensters

Siehe auch...


Größe und Position

Verkleinern/Vergrößern oder Verschieben des Hilfefensters

Siehe auch...

Sie können das Hilfefenster auf verschiedene Weise verkleinern/vergrößern oder verschieben.

Proportionales Verkleinern oder Vergrößern

Maximieren oder Minimieren

Verschieben

Proportionales Verkleinern oder Vergrößern des Hilfefensters

Maximieren oder Minimieren des Hilfefensters

Verschieben des Hilfefensters


Neue Benutzer

Weitere Netzwerkanalysatorbenutzer

Siehe auch...

Nach dem Einschalten des Analysators meldet dieser sich automatisch unter dem Standard-Verwalternamen und dem Standard-Passwort bei Windows 2000 an. Falls die nachfolgenden Bedingungen erfüllt sind, gestaltet sich die Verwaltung sehr einfach oder kann sogar entfallen.

  • Der Analysator wird in einer sicheren Umgebung betrieben;

  • Der Analysator wird nicht über das lokale Netzwerk mittels COM-Befehlen ferngesteuert.

  • Es gibt keine Benutzer, die unter Verwendung eigenen Benutzernamen und Passwörtern Netzwerkverbindungen zu den Laufwerken im Analysator herstellen.

Falls der Analysator von mehreren Personen benutzt werden soll, können Sie als Verwalter uneingeschränkte oder eingeschränkte Zugriffsrechte an die einzelnen Benutzer vergeben. Die anderen Benutzer können dann zwar den Analysator benutzen, haben aber keinen vollen Zugriff auf bestimmte Funktionen, die Ihnen als Verwalter vorbehalten sind.

  1. Zeigen Sie im System-Menü auf Configure und klicken Sie auf Control Panel.

  2. Rollen Sie im Control Panel-Fenster nach unten und wählen Sie die Anwendung Users and Passwords.

  3. Falls in der Registerkarte Users die Schaltfläche Add "abgeblendet" ist, aktivieren Sie das Kontrollkästchen Users must enter a user name and password to use this computer (Zur Benutzung dieses Computers ist die Eingabe eines Benutzernamens und eines Passworts erforderlich) am oberen Rand des Bildschirmfensters an.

  4. Klicken Sie zur Eingabe der Informationen für den neuen Benutzer auf Add.

  5. Geben Sie in das Feld User name einen Benutzernamen für den neuen Benutzer ein. Geben Sie in das Feld Full name den vollständigen Namen des neuen Benutzers ein.

  6. Geben Sie in das Feld Description eine Beschreibung für den neuen Benutzer ein. Klicken Sie anschließend auf Next.

  7. Lassen Sie den neuen Benutzer ein Passwort in das Feld Password eingeben. Lassen Sie den neuen Benutzer zur Bestätigung das gleiche Passwort nochmals in das Feld Confirm password eingeben. Klicken Sie anschließend auf Next.

  8. Legen Sie fest, ob der neue Benutzer eingeschränkten oder uneingeschränkten Zugriff haben soll.Restricted User (Benutzer mit eingeschränktem Zugriff) wird derzeit noch nicht unterstützt.

  9. In der Liste Other können Sie noch diverse andere Zugriffsrechte gewähren. Wenn Sie in dem Feld Other ein Zugriffsrecht wählen, wird dieses unterhalb des Feldes erläutert.

  10. Wählen Sie das Zugriffsrecht für den neuen Benutzer. Klicken Sie anschließend auf Finish.

  11. Überprüfen Sie im Feld Users for this computer den Benutzernamen und das Zugriffsrecht des neuen Benutzers.

  12. Wenn Sie möchten, dass dieser Benutzer den Analysator benutzen kann, ohne jedesmal sein Passwort eingeben zu müssen, deaktivieren Sie das Kontrollkästchen Users must enter a user name and password to use this computer.

  12. Lassen Sie den Benutzer, wenn das Fenster Automatically Log On angezeigt wird, sein Passwort in das Feld Password eingeben und im Feld Confirm Password bestätigen. Klicken Sie anschließend auf OK.

  13. Klicken Sie zum Abschluss der Neuaufnahme eines Benutzer auf OK.

  14. Klicken Sie zum Schließen des "Control Panel"-Fensters im File-Menü auf Close.


Notfalldiskette

Notfall-Wiederherstellungsdiskette

Siehe auch...

Falls das Festplattenlaufwerk Ihres Analysator einmal defekt werden sollte, können Sie dessen Daten eventuell wiederherstellen, falls Sie eine Notfall-Wiederherstellungsdiskette erstellt haben. Sie sollten diese Diskette erstellen, nachdem Sie das Gerät zum ersten Mal konfiguriert haben.

Zum Erstellen einer Notfall-Wiederherstellungsdiskette benötigen Sie eine leere 1,44-MB-Diskette.

Hinweis: Der Wiederherstellungsprozess greift auf Informationen zu, die in dem Verzeichnis "systemroot\repair" abgelegt sind. Dieses Verzeichnis sollten Sie auf keinen Fall verändern oder löschen.

Es sind weitere Informationen über den Wiederherstellungsprozess verfügbar:

  • Falls Sie Windows 2000 Professional verwenden, siehe das Online-Handbuch "Windows 2000 Professional Getting Started" oder das mit der Windows 2000 CDROM gelieferte Handbuch "Windows 2000 Professional Getting Started".

  • Falls Sie Windows 2000 Server verwenden, schauen Sie bitte unter "Disaster Recover – How to" nach.

Erstellen einer Notfall-Wiederherstellungsdiskette

  1. Klicken Sie im System-Menü auf Windows Taskbar .

  2. Klicken Sie auf Start, und zeigen Sie auf Programs, Accessories, System Tools; klicken Sie anschließend auf Backup .

  3. Klicken Sie im Tools-Menü auf Create an Emergency Repair Disk .

  4. Aktivieren Sie das Kontrollkästchen Also back up the registry to the repair directory... .

  5. Befolgen Sie die auf dem Bildschirm angezeigten Hinweise.


Siehe auch...

Analysator-Voreinstellungen

Überblick

"Preset"-
Zustand

"Hibernate"-
Zustand

"Power-Up"-
Zustand

Der Analysator kann einen der folgenden vordefinierten Zustände annehmen:
Preset-Zustand

"Hibernate"-Zustand

"Power-up"-Zustand

Wenn Sie die Taste Preset drücken, wird der Analysator in die Grundeinstellung gebracht. Klicken Sie auf die Schaltflächen, um Informationen über die "Preset"-Werte der verschiedenen Messparameter zu erhalten.
Frequenz-Einstellungen

Signalpegel-Einstellungen

Wobbel-Einstellungen

Segmentwobbelung-Einstellungen

Trigger-Einstellungen

Display-Einstellungen

Response-Einstellungen

Kalibrier-Einstellungen

Marker-Einstellungen

Grenzwerttest-Einstellungen

Zeitbereich-Einstellungen (nur für Geräte mit Option 010)

Globale Display-Einstellungen

Frequenz-Einstellungen:

Messparameter | S11
Start-Frequenz | 300 kHz
Stop-Frequenz | 3 GHz für E8356A 6 GHz für E8357A 9 GHz für E8358A
CW-Frequenz | 1 GHz

Signalpegel-Einstellungen:

"Test Port Power" | 0 dBm (1 mW) für alle Modelle
"Port Power Coupled" | "On"
"Auto Attenuation" | "On"
"Attenuator Value" | 0 dB
"Power Slope" | "Off"
"Slope Value" | 0 dB/GHz

Wobbel-Einstellungen:

"Type" | "Linear Frequency"
"Mode" | "Continuous"
"Generation" | "Analog"
"Auto Sweep Time" | "On"
"Number of Points" | 201

Segmentwobbelung-Einstellungen:

"Active Segments" | 1
"Start Frequency" | 300 kHz
"Stop Frequency" | 1 MHz
"Number of Points" | 21
"Power" | 0 dBm
"IF Bandwidth" | 1 kHz
"Dwell Time" | 0 s

Trigger-Einstellungen

"Source" | "Internal"
"Mode" | "Wobbelung"

Display-Einstellungen:

"Format"

"Log Mag"

Die Werte für "Scale", "Reference Position" und "Reference Value" sind vom jeweils gewählten Format abhängig:

FORMAT | SCALE | REFERENCE POSITION | REFERENCE VALUE
"Log Mag" | 10 dB/ | 5 | 0 dB
"Phase" | "10 degrees/" | 5 | "0 degrees"
"Group Delay" | 10 s/ | 5 | 0 s
"Linear Mag" | "10 units/" | 0 | "0 units"
"SWR" | "10 units/" | 0 | "1 unit"
"Real" | "10 units/" | 5 | "0 units"
"Imaginary" | "10 units/" | 5 | "0 units"
"Polar" | "1 unit/" | – | "1 unit"
"Smith Chart" | "1 unit/" | – | "1 unit"

Response-Einstellungen:

"Channel Number" | 1
"IF Bandwidth" | 35 kHz
"Averaging" | "Off"
"Averaging Factor" | 1
"Smoothing" | "Off"
"Smoothing Factor" | 1% des "Span"-Wertes
"Electrical Delay" | 0 s
"Velocity Factor" | 1.0
"Phase Offset" | "0 degrees"
"Math/Memory Trace View" | "Data"

Fehlerkorrektur-Einstellungen:

"Correction State" | "Off"
"Interpolation State" | "On"
"Calibration Type" | "None"
"Cal Kit Number" | 1
"System Z0" | "50 ohms"
"Port Extensions State" | "Off"
"Port Ext. Values" "Input A, B" "Port 1, 2" | 0

Marker-Einstellungen:

Anfängliche Frequenz | Aktuelle Mittenfrequenz
"Reference" | "None"
"Interpolation" | "On"
"Format" | "Trace Default"
"Type" | "Normal"
"Function" | "Max Value"
"Domain" | "Full Span"
Tabelle | Leer
Kopplung | Immer entkoppelt

Grenzwerttest-Einstellungen:

"Limit Testing" | "Off"
"Line Display" | "Off"
"Sound on Fail" | "Off"

Grenzwertlinien-Einstellungen:

"Type (OFF, MAX, MIN)" | "OFF"
"Begin Stimulus" | 300 kHz
"End Stimulus" | 3 GHz für E8356A 6 GHz für E8357A 9 GHz für E8358A
"Begin Response" | 0
"End Response" | 0

Zeitbereich-Einstellungen (nur für Geräte mit Option 010)

"Transform State" | "Off"
"Transform Mode" | "Band Pass"
"Transform Start" | -10 ns
"Transform Stop" | 10 ns
"Window" | 6.0 (Kaiser-Bessel-Faktor)
"Gating State" | "Off"
"Gating Start" | -10 ns
"Gating Stop" | 10 ns
"Gate Type" | "Band Pass"
"Gate Shape" | "Normal"

Globale Display-Einstellungen:

"Trace Status" | "On"
"Frequency/Stimulus" | Off
Marker-Anzeige | "On" (wenn ein Marker aktiv ist)
Angezeigte Symbolleisten | Aktuelle-Eingabe-Symbolleiste
"Status Bar State" | "Off"

Mit dem Ein-/Aus-Schalter können Sie zwischen den Zuständen "On" (ein) und "Hibernate" (Ruhezustand) umschalten. Wenn Sie auf "Hibernate"-Zustand schalten, wird das Betriebssystem des Analysators "in den Schlaf versetzt". Wenn Sie den Schalter wieder in den "On"-Zustand bringen, "erwacht" das System in dem Zustand, in dem es sich zuletzt befand.

Im "On"-Zustand leuchtet die Kontrollleuchte grün. Im "Hibernate"-Zustand leuchtet die Kontrollleuchte gelb. Der Ein-/Aus-Schalter ist lediglich ein Standby-Schalter und kein Netzschalter, mit dem das Gerät vom Netz getrennt werden kann. Der "Hibernation"-Zustand ist der normale Aus-Zustand des Gerätes. Im "Hibernate"-Zustand verbraucht das Gerät ein wenig Strom. In diesem Zustand steht nur die Schalter-Elektronik unter Betriebsspannung; der restliche Teil der Prozessorbaugruppe ist hingegen stromlos.

Beim Umschalten in den "Hibernate"-Zustand werden die aktuellen Zustände aller laufenden Programme auf die Festplatte gespeichert, und die Betriebsspannung für die Prozessorbaugruppe wird automatisch abgeschaltet. Wenn Sie den Analysator wieder in den "On"-Zustand schalten, lädt das Betriebssystem automatisch die zuvor abgespeicherten Programmzustände. Dies geht schneller vonstatten als ein normaler Systemstart.

Um den Analysator in den "Hibernate"-Zustand zu schalten, müssen Sie den Ein-/Aus-Schalter kurz drücken.

Vorsicht: Wenn Sie den Ein-/Aus-Schalter länger als vier Sekunden drücken, wird der Analysator ohne Warnung "hardwaremäßig" heruntergefahren. Die Wirkung ist die gleiche, wie wenn Sie den Netzstecker ziehen. Dies sollte vermieden werden, weil in diesem Fall – wie bei einem PC – das Dateisystem beschädigt werden kann. In den meisten Fällen kann Windows anschließend neustarten, ohne dass Daten verloren gehen. Darauf sollten Sie sich allerdings nicht verlassen.

Nach einigen Sekunden erscheint der Hinweis Ready to Hibernate (Fertig für Ruhezustand). Danach erscheint kurz der vom Windows-Betriebssystem ausgegebene Hinweis Preparing to Hibernate (Vorbereitung auf den Ruhezustand). Beim Umschalten in den "Hibernate"-Zustand schlägt die Farbe der Ein-/Ausschalt-Kontrollleuchte von grün in gelb um.

Zum "Aufwecken" des Analysators müssen Sie den Ein-/Aus-Schalter nochmals drücken. Die Farbe der Einschalt-Kontrollleuchte ändert sich daraufhin von gelb auf grün. Nach etwa 45 Sekunden befindet sich der Analysator wieder in dem ursprünglichen Zustand.

Trennen Sie den Analysator nur dann vom Netz, wenn dies unbedingt erforderlich ist (beispielsweise wenn er zu einem anderen Arbeitsplatz transportiert oder gewartet werden muss). Wenn Sie den Analysator vom Netz trennen und ihn anschließend wieder an das Netz anschließen und einschalten, geht er in den "Power-Up"-Zustand über.

Wenn Sie den Analysator vom Netz trennen und ihn anschließend wieder an das Netz anschließen und einschalten, geht er in den "Power-Up"-Zustand über. Der "Power-Up"-Zustand ist der gleiche wie der "Preset"-Zustand, mit folgenden Ausnahmen:

GPIB-Adresse | Der zuletzt gültige Wert (Standardeinstellung = 16)
"SCPI over LAN"-Adresse | Der zuletzt gültige Wert (Standardeinstellung = 16)
GPIB-Betriebsart | "Talker/Listener"
Gerätezustand | Wie vor dem Ausschalten


Einrichten von Messungen

Siehe auch...

Eine Messung wird folgendermaßen eingerichtet:
Messparameter wählen

Frequenzbereich wählen

HF-Signalpegel wählen

Wobbelungstyp wählen

Trigger wählen

Darstellungsformat und Skalierung wählen


Einrichten des Bildschirms

Siehe auch...

Klicken Sie auf die Schaltflächen, um zu erfahren, wie Sie den Analysator-Bildschirm für optimale Darstellung der Messergebnisse einrichten.
Anzeigen mehrerer Messkurven und Kanäle

Anpassen des Analysator-Bildschirms

Zeigen oder Verbergen von Messinformationen


Genauigkeit

Verbessern der Messgenauigkeit

Siehe auch...

Klicken Sie auf eine Schaltfläche, um zu erfahren, wie Sie die Messgenauigkeit optimieren können.

Vergrößern des Dynamikbereichs

Vergrößern der Anzahl der Datenpunkte

Verbessern der Phasenmessgenauigkeit

Optimierung der Genauigkeit an Bauteilen mit großer elektrischer Länge

Verbessern der Reflexionsmessgenauigkeit für Zweitor-Bauteile mit geringer Einfügedämpfung

Verbesserung der Stabilität der Messergebnisse

Verringern des Messkurvenrauschens

Verringern des Empfängerübersprechens

Verringern von Nebeneffekten durch Zubehör


Siehe auch...

Einflüsse von Messzubehör

Überblick

Konzepte

Wie verringert man die
Einflüsse von Messzubehör

Messzubehör innerhalb der Messanordnung kann die Ergebnisse von Bauteilmessungen beeinflussen. Der Analysator bietet zwei Funktionen, die es Ihnen ermöglichen, die Einflüsse von Messzubehör zu verringern.
Konzepte

Wie verringert man die Einflüsse von Messzubehör?

Wählen Sie zum Reduzieren der Einflüsse von Messzubehör die Methode, die für Ihre Messanordnung am besten passt.
"Power Slope"-Funktion zur Kompensation der Kabeldämpfung

"Gating"-Funktion zur selektiven Unterdrückung von Teilen der Zeitbereichantwort

"Power Slope"-Funktion zur Kompensation der Kabeldämpfung

Wenn Ihre Messanordnung ein langes Kabel oder sonstiges Messzubehör enthält, das eine frequenzabhängige Signaldämpfung verursacht, können Sie diese mit Hilfe der "Power Slope"-Funktion kompensieren. Diese Funktion erhöht den Messignalpegel mit einer von Ihnen vorgegebenen frequenzabhängigen Rate (dB/GHz).

"Gating"-Funktion zur selektiven Unterdrückung einzelner Reflexionen

"Gating" ist eine Zeitbereichfunktion (Option 010), die es ermöglicht, Teile der Zeitbereichantwort rechnerisch zu unterdrücken. Sie können die "Gating"-Funktion auf Reflexions- oder Transmissionsmessungen anwenden; die Ergebnisse sind jeweils unterschiedlich.

  • Durch Anwenden der "Gating"-Funktion auf eine Reflexionsmessung können Sie eine erwünschte Antwort (beispielsweise Rückflussdämpfung eines Filters) von unerwünschten Antworten (beispielsweise Reflexionen von fehlangepassten Adaptern oder Steckverbindern) trennen.

  • Durch Anwenden der "Gating"-Funktion auf eine Transmissionsmessung können Sie einen bestimmten Pfad in einem Mehrpfad-Bauteil mit großer elektrischer Länge isolieren.

Nach Anwendung der "Gating"-Funktion im Zeitbereich können Sie die Zeitbereichtransformation abschalten und sich den Frequenzgang anschauen, den das Bauteil hätte, wenn die im Zeitbereich unterdrückte Antwort tatsächlich fehlen würde. Für das Zeitbereich-"Gating"-Filter stehen folgende Charakteristiken zur Auswahl:

  • "Bandpass shaped" – die außerhalb des Durchlassbereichs liegenden Antworten werden unterdrückt

  • "Notch shaped" – die innerhalb des Unterdrückungsbereichs liegenden Antworten werden unterdrückt

Weitere Informationen siehe unter Gate Filter.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zur Verringerung der Einflüsse von Messzubehör.
Kompensation der Kabeldämpfung

Unterdrückung unerwünschter Antworten

Kompensation der Kabeldämpfung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Falls die "Slope"-Funktion noch nicht aktiv ist, aktivieren Sie das Kontrollkästchen Slope.

  3. Geben Sie in das Feld dB/GHz die gewünschte "Slope"-Rate für den frequenzabhängigen Signalpegelanstieg ein. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie in der Aktuelle-Eingabe-Symbolleiste F4 (Slope).

  3. Geben Sie über die Tasten im Tastenfeld ENTRY die gewünschte "Slope"-Rate für den frequenzabhängigen Signalpegelanstieg ein. Drücken Sie anschließend Enter.

Unterdrückung unerwünschter Antworten (nur für Geräte mit Option 010, Zeitbereichtransformation)
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Transform.

  2. Klicken Sie zum Aktivieren der Zeitbereichtransformation auf das Kontrollkästchen Transform.

  3. Klicken Sie unter Transform Mode auf die gewünschte Transformationsbetriebsart.

    • "Low Pass Impulse" (Tiefpass-Impuls)

    • "Low Pass Step" (Tiefpass-Stufe)

    • "Band Pass" (Bandpass)

  4. Wenn Sie "Low Pass" gewählt haben, klicken Sie auf Set Freq. Low Pass.

  5. Wählen Sie im Feld Category durch Anklicken des nach unten zeigenden Pfeils die Betriebsart Gating.

  6. Wählen Sie im Feld Gate Type durch Anklicken des nach unten zeigenden Pfeils die gewünschte "Gating"-Charakteristik:

    • "Bandpass"

    • "Notch"

  7. Spezifizieren Sie die "Gating"-Grenzen durch Eingabe entsprechender Werte für Start und Stop oder Center und Span.

  8. Klicken Sie zum Aktivieren der "Gating"-Funktion auf das Kontrollkästchen Gating. Klicken Sie auf OK.

  9. Klicken Sie im Trace-Menü auf Transform.

  10. Wählen Sie im Feld Category durch Anklicken des nach unten zeigenden Pfeils die Betriebsart Transform. Klicken Sie auf das Kontrollkästchen Transform und OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Trace-Menü und zu Transform zu gelangen. Drücken Sie Click.

  3. Drücken Sie die Tab-rechts-Taste, um zum Kontrollkästchen Transform zu gelangen, und drücken Sie Click.

  4. Navigieren Sie mit der Tab-rechts-Taste zu Transform Mode und wählen Sie mit der Pfeil-unten-Taste die gewünschte Transformationsbetriebsart.

    • "Low Pass Impulse" (Tiefpass-Impuls)

    • "Low Pass Step" (Tiefpass-Stufe)

    • "Band Pass"

  5. Wenn Sie "Low Pass" gewählt haben, navigieren Sie zu Set Freq. Low Pass, und drücken Sie Click.

  6. Navigieren Sie zum Feld Category und wählen Sie mit der Pfeil-unten-Taste Gating.

  7. Navigieren Sie zum Feld Gate Type, und wählen Sie mit der Pfeil-unten-Taste die gewünschte "Gating"-Charakteristik:

    • "Bandpass"

    • "Notch"

  8. Spezifizieren Sie die "Gating"-Grenzen durch Eingabe entsprechender Werte für Start und Stop oder Center und Span.

  9. Navigieren Sie zum Kontrollkästchen Gating, und drücken Sie Click, OK.

  10. Navigieren Sie zum Feld Category und wählen Sie mit der Pfeil-unten-Taste Transform.

  11. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  12. Navigieren Sie zum Feld Trace und wählen Sie mit der Pfeil-unten-Taste Transform. Drücken Sie Click.

  13. Navigieren Sie zum Kontrollkästchen Transform, und drücken Sie Click, OK.


Reflexionsmessgenauigkeit

Siehe auch...

Reflexionsmessgenauigkeit für Zweitor-Bauteile mit geringer Einfügedämpfung

Überblick

Konzepte

Wie führt man genaue
Reflexionsmessungen durch?

Wenn Sie nach einer 1-Port-Kalibrierung Reflexionsmessungen an einem Zweitor-Bauteil durchführen, sollten Sie das nicht benutzte Tor des Messobjekts mit der Systemimpedanz abschließen.
Konzepte

Wie führt man genaue Reflexionsmessungen an Zweitor-Bauteilen durch?

Wenn Sie nach einer 1-Port-Kalibrierung genaue Reflexionsmessungen an einem Zweitor-Bauteil durchführen möchten, sollten Sie das jeweils nicht gemessene Bauteiltor mit der Systemimpedanz abschließen. Dies gilt insbesondere für bidirektionale Bauteile mit geringer Einfügedämpfung wie z. B. Filter (bei Messungen im Durchlassbereich) oder Kabel. Eine 1-Port-Kalibrierung korrigiert lediglich die Richtverhältnis-, Quellenanpassungs- und Frequenzgang-fehler, aber nicht den Lastanpassungsfehler. Deshalb muss der Lastanpassungsfehler so klein wie möglich gehalten werden.

Hinweis: Eine 2-Port-Kalibrierung korrigiert alle 12 Fehlerterme einschließlich Lastanpassungsfehler.

Sie können das nicht-gemessene Bauteiltor folgendermaßen abschließen:

  • Schließen Sie eine hochwertige Last (beispielsweise aus einem Kalibrierungs-Kit) an das nicht-gemessene Bauteiltor an. Dadurch erzielen Sie eine Messgenauigkeit, die fast so hoch ist wie nach einer vollständigen SOLT 2-Port-Kalibrierung.

  • Schließen Sie das nicht-gemessene Bauteiltor über einen 10 dB-Präzisions-Stufenabschwächer an den Analysator an. Dadurch verbessert sich die effektive Lastanpassung des Analysators um etwa das Doppelte des Abschwächungsfaktors, also um etwa 20 dB.

Tipp:

  • Sie brauchen sich um die Lastanpassung keine Gedanken zu machen, wenn Sie Messungen an einem Bauteil mit geringer Ausgangsrückwirkung (= hoher Rückwärts-Isolation) durchführen, beispielsweise einem Verstärker.

Die folgende Abbildung verdeutlicht die Messunsicherheit bei Messungen mit bzw. ohne 10 dB-Präzisionsabschwächer am Ausgang des Messobjekts.

Legende

 | Filter-Reflexion
------------- | Messunsicherheit mit Abschwächer
................ | Messunsicherheit ohne Abschwächer

Die Auswirkung eines hochwertigen 10 dB-Abschwächers auf die Lastanpassung lässt sich nach den folgenden Formeln berechnen.

Hinweis: Die entsprechenden linearen Werte sind in Klammern angegeben.

Netzwerkanalysator: |
Lastanpassung (NALM) | = 18 dB (0,126)
Richtverhältnis (NAD) | = 40 dB (0,010)
Filter: |
Einfügedämpfung (FIL) | = 1dB (0,891)
Rückflussdämpfung (FRL) | = 16 dB (0,158)
Abschwächer: |
Einfügedämpfung (AIL) | = 10 dB (0,316)
SWR (ASWR) | = 1,05 (0,024) 32,26 dB Rückflussdämpfung

Berechnungen:

 | Ohne Abschwächer | Mit Abschwächer
r NA | = (F IL)*(NA LM)*(F IL) = (0,891)*(0,126)*(0,891) =0,100 | = (F IL)*(AIL)*(NA LM)*(AIL)*(F IL) = (0,891)*(0,316)*(0,126)*(0,316)*(0,891) = 0,010
r Abschwächer | NA | = (F IL)*(ASWR)*(F IL) = (0,891)*(0,126)*(0,891) = 0,019
"Worst Case"-Fehler (EWC) | = r NA =0,1 | = r NA + rAttn. =0,01+0,019 =0,029
Unsicherheit addiert | = -20log(FRL)+(EWC)+(NAD) = -20log(0,158)+(0,100)+(0,010) = 11,4 dB | = -20log(FRL)+(EWC)+(NAD) = -20log(0,158)+(0,029)+(0,010) = 14,1 dB
Unsicherheit subtrahiert | = -20log(FRL)-(EWC)-(NAD) =-20log(0,158)-(0,100)-(0,010) = 26,4 dB | = -20log(FRL)-(EWC)-(NAD) = -20log(0,158)-(0,029)-(0,010) = 18,5 dB

Wenn Sie genaue Reflexionsmessungen an einem Zweitor-Bauteil mit geringer Einfügedämpfung durchführen möchten, sollten Sie eine der nachfolgenden Maßnahmen ergreifen:

  • Schließen Sie eine hochwertige Last an den Ausgang des Messobjekts an, nachdem Sie eine 1-Port- Kalibrierung durchgeführt haben.

  • Schließen Sie das Messobjekt über einen hochwertigen 10 dB-Abschwächer an den Analysator an, nachdem Sie eine 1-Port-Kalibrierung durchgeführt haben.

  • Schließen Sie den Ausgang des Messobjekts direkt an den Analysator an, nachdem Sie eine 2-Port-Kalibrierung durchgeführt haben.


Siehe auch...

Dynamikbereich

Überblick

Konzepte

Wie vergrößert man
den Dynamikbereich?

Der D ynamikbereich des Analysators ist die Differenz zwischen dem maximal zulässigen Eingangspegel (Übersteuerungsgrenze) und dem kleinsten messbaren Signalpegel (Eigenrauschen). Der Analysator liefert nur dann gültige Messergebnisse, wenn der Eingangssignalpegel innerhalb dieser Grenzen liegt.
Konzepte

Wie vergrößert man den Dynamikbereich?

Wenn der Signalpegel am Empfängereingang während der Messung stark schwankt (wie es beispielsweise bei der Charakterisierung eines Bandpassfilters mit hoher Sperrdämpfung der Fall ist), müssen Sie unter Umständen den Dynamikbereich vergrößern. Die untenstehende Abbildung zeigt ein Beispiel für den Dynamikbereich einer Messung.

Im Interesse einer möglichst geringen Messunsicherheit sollte der Dynamikbereich des Analysators größer sein als die Signalpegelschwankungen am Ausgang des Messobjekts. Wenn der kleinste Signalpegel beispielsweise um 10 dB über dem Eigenrauschpegel liegt, erzielen Sie eine höhere Messgenauigkeit als wenn er nur 5 dB darüber liegt. Nachfolgend werden mehrere Methoden zur Vergrößerung des Dynamikbereichs beschrieben.

Erhöhen des Signalpegels am Eingang des Messobjekts

Reduzieren des Empfängereigenrauschens

Reduzieren der ZF-Bandbreite

Messkurvenmittelung

Hinweis: Weil diverse Analysatoreinstellungen miteinander gekoppelt sind, kann sich beim Vergrößern des Dynamikbereichs eventuell die Messzeit verlängern.

Erhöhen des Signalpegels am Eingang des Messobjekts

  • Erhöhen Sie den Signalpegel am Eingang des Messobjekts; dadurch steigt auch der Pegel am Empfängereingang an, und der Abstand zum Eigenrauschpegel wird entsprechend größer.

  • Wenn der Eingangspegel die Übersteuerungsgrenze überschreitet, können Kompressionsverzerrungen auftreten; wenn der maximal zulässige Eingangspegel überschritten wird, kann der Empfänger beschädigt werden.

Vorsicht! Der maximal zulässige Empfängereingangspegel beträgt: +15 dBm.

Tipp: Wenn Ihr Analysator mit Option 015 (konfigurierbares Testset) ausgestattet ist, können Sie den Dynamikbereich mit Hilfe eines externen Leistungsverstärkers am Eingang des Messobjekts weiter vergrößern.

Reduzieren des Empfängereigenrauschens

Die folgenden Verfahren ermöglichen es Ihnen, das Eigenrauschen des Analysators zu verringern und dadurch den D ynamikbereich zu vergrößern.

  • Reduzieren der ZF-Bandbreite

  • Messkurvenmittelung

Tipp: Wenn Sie sehr schwache Signale messen, deren Pegel in der Nähe des Analysator-Eigenrauschens liegen, sollten Sie das Ü bersprechen zwischen den Analysator-Empfängern reduzieren. (Siehe Empfänger-Übersprechen .)

Reduzieren der ZF-Bandbreite

  • Durch Reduktion der ZF-Bandbreite des Empfängers können Sie den Einfluss des Rauschens auf die Messung reduzieren. Bei einer Reduktion der ZF-Bandbreite um den Faktor 10 verringert sich das Eigenrauschen um 10 dB. Durch das Verkleinern der ZF-Bandbreite verlängert sich allerdings die Wobbelzeit.

  • Der Netzwerkanalysator setzt das Eingangssignal aus dem HF/Mikrowellenbereich in eine niedrigere Zwischenfrequenz (IF, Intermediate Frequency), nämlich 41,67 kHz um. Die Bandbreite des ZF-Bandpassfilters ("ZF-Bandbreite") ist im Bereich von 40 kHz bis 1 Hz einstellbar.

  • Sie können die ZF-Bandbreite für jeden Kanal (und bei Segmentwobbelung für jedes Segment) individuell einstellen.

Auswirkung der Reduktion der ZF-Bandbreite

Messkurvenmittelung

  • Messkurvenmittelung ist ein Verfahren, das die Auswirkungen von Rauschen auf die Messergebnisse verringert.

  • Der Analysator berechnet für jeden Messkurvenpunkt einen gleitenden Mittelwert aus mehreren Messungen; die Anzahl der zur Mittelung herangezogen Messung wird durch den von Ihnen vorgegebenen Mittelungssfaktor bestimmt.

  • Sobald die Anzahl der durchgeführten Messungen größer ist als der Mittelungsfaktor, fallen die jeweils ältesten Messergebnisse aus der Mittelung heraus.

  • Je größer der Mittelungsfaktor, desto stärker ist die Rauschunterdrückung und desto größer der Dynamikbereich.

Auswirkung der Mittelung

Tipps:

  • Sie können die Mittelungsfunktion für jeden Kanal individuell aktivieren und konfigurieren.

  • Die Gesamtmesszeit steigt mit zunehmendem Mittelungsfaktor an.

  • Relativ starkes Rauschen lässt sich etwa gleich gut durch Mittelung oder ZF-Bandbreitenreduktion verringern.

  • Bei sehr schwachem Rauschen ist die Mittelung effektiver als eine ZF-Bandbreitenreduktion.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zur Vergrößerung des D ynamikbereichs.
Erhöhen des Signalpegels am Eingang des Messobjekts

Reduzieren des Empfängereigenrauschens

Erhöhen des Signalpegels am Eingang des Messobjekts

Vorsicht! Bei Messungen an einem Verstärker können Sie die analysatorinterne Stimulussignalquelle nicht mit vollem Ausgangspegel betreiben, da sonst der Empfängereingang beschädigt wird. Der maximal zulässige Empfängereingangspegel beträgt: +15 dBm.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Channel-Menü auf Power.

  2. Aktivieren Sie das Kontrollkästchen Power On.

  3. Wählen Sie unter Port Selection den Port, den Sie als Signalquellenausgang verwenden.

  4. Geben Sie in das Feld Test Port Power den gewünschten Signalpegelwert ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  5. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie im Tastenfeld NAVIGATION die Taste F1 (Level).

  3. Geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Signalpegelwert ein, und drücken Sie Enter.

Reduzieren des Empfängereigenrauschens

Reduzieren Sie das Eigenrauschen des Empfängers, indem Sie die ZF-Bandbreite reduzieren.
Mausprozedur

Tastenprozedur

Mausprozedur

Reduzieren der ZF-Bandbreite

  1. Klicken Sie im Menü Sweep auf IF Bandwidth.

  2. Geben Sie in das Feld IF Bandwidth einem kleineren Bandbreitenwert ein, oder wählen Sie diesen mit der Pfeil-unten-Taste.

  3. Klicken Sie auf OK.

Messkurvenmittelung

  1. Klicken Sie im Menü Channel auf Average.

  2. Klicken Sie zum Aktivieren der Mittelungsfunktion auf das Kontrollkästchen Average ON, sodass ON angezeigt wird.

  3. Geben Sie in das Feld Average Factor einen größeren Mittelungsfaktor ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben-Taste.

  4. Klicken Sie auf OK.

Hinweis: Klicken Sie auf Channel, Restart Average, um eine neue Folge von Messungen für die Mittelung zu starten.

Tastenprozedur

Reduzieren der ZF-Bandbreite

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie im Tastenfeld NAVIGATION die Taste F3 (Bandwidth).

  3. Geben Sie über die Tasten im Tastenfeld ENTRY die gewünschte ZF-Bandbreite ein und drücken Sie Enter.

Messkurvenmittelung

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Average.

  2. Drücken Sie im Tastenfeld NAVIGATIONdie TasteF1 (Avg#).

  3. Geben Sie über die Tasten im Tastenfeld ENTRY die Anzahl den gewünschten Mittelungsfaktor ein, und drücken Sie Enter.

  4. Drücken Sie zum Aktivieren der Mittelungsfunktion die Taste F2 (Avg on/OFF).

Hinweis: Drücken Sie F4 (Restart), um eine neue Folge von Wobbelzyklen für eine Mittelungsmessung zu starten.


Bauteile mit großer elektrischer Länge

Siehe auch...

Messungen an Bauteilen mit großer elektrischer Länge

Überblick

Konzepte

Wie misst man Bauteile
mit großer elektrischer Länge?

Durch die Signallaufzeit innerhalb der Messanordnung kann es vorkommen, dass bei einer Wobbelmessung die Signalfrequenzen am Eingang und am Ausgang des Messobjekts unterschiedlich sind.

Diesen Effekt können Sie auf drei verschiedene Arten kompensieren und dadurch die Messgenauigkeit verbessern.
Konzepte

Wie lassen sich Bauteile mit großer elektrischer Länge genau messen?

Die folgende Informationen helfen Ihnen zu verstehen, warum Sie in bestimmten Situationen ungenaue Messergebnisse erhalten, und wie Sie dies vermeiden können.
Warum kann die Signallaufzeit innerhalb eines Bauteils die Messergebnisse verfälschen?

Möglichkeiten zur Verbesserung der Messgenauigkeit

Wobbelgeschwindigkeit reduzieren

Stufenweise Wobbelung verwenden

Im R-Kanal eine elektrische Länge hinzufügen

Warum kann die Signallaufzeit innerhalb eines Bauteils die Messergebnisse verfälschen?

Die folgende Abbildung zeigt ein Beispiel für eine solche Situation:

  • Die Signalquelle und der Empfänger eines Netzwerkanalysators sind miteinander phasensynchronisiert und werden gemeinsam über einen vorgegebenen Frequenzbereich durchgestimmt (gewobbelt).

  • Der Signalfluss durch das Messobjekt (DUT, Device Under Test) bei verschiedenen Frequenzen ist in verschiedenen Farben dargestellt.

  • Sie können erkennen, dass während ein Stimulussignal mit einer bestimmten Frequenz durch das Messobjekt fließt, der Analysator bereits auf eine neue Frequenz abgestimmt wird – noch bevor das Signal beim Empfänger ankommt. Der Empfänger ist daher nicht exakt auf die Frequenz des aktuellen Signals abgestimmt; dadurch wird das Messergebnis verfälscht.

.

Wenn Sie beispielsweise ein langes Kabel messen, "hinkt" die Signalfrequenz am Ende des Kabels der Stimulussignalfrequenz "hinterher". Wenn diese Frequenzverschiebung signifikant gegenüber der ZF-Detektionsbandbreite (ZF-Bandbreite) des Analysators ist (die typischerweise einige kHz beträgt), wird die Amplitude des Stimulussignals auf der Flanke des ZF-Filters gemessen; es wird daher ein zu kleiner Wert angezeigt.

Möglichkeiten zur Verbesserung der Messgenauigkeit

Sie haben folgende Möglichkeiten, um die Signallaufzeit eines Bauteils mit großer elektrischer Länge zu kompensieren:
Wobbelgeschwindigkeit reduzieren

Stufenweise Wobbelung verwenden

Im R-Kanal eine elektrische Länge hinzufügen

Wobbelgeschwindigkeit reduzieren

Sie können eine oder mehrere der nachfolgend beschriebenen Methoden anwenden.

  • Wobbelgeschwindigkeit reduzieren.

  • ZF-Bandbreite verkleinern.

  • Anzahl der Messpunkte vergrößern.

Stufenweise Wobbelung verwenden

  • Sie können die Wobbelgeschwindigkeit des Analysators reduzieren, indem Sie mit stufenweiser statt analoger (quasi-kontinuierlicher) Wobbelung arbeiten.

  • Dabei können Sie die Verweilzeit ("Dwell") pro Messpunkt vorgeben.

Im R-Kanal eine elektrische Länge hinzufügen

Statt die Wobbelgeschwindigkeit zu reduzieren, können Sie auch die elektrische Länge des Kabels oder Testadapters kompensieren.

  1. Entfernen Sie die R-Kanal-Brücke auf der Frontplatte des Analysators.

  2. Ersetzen Sie die Brücke durch ein Kabel, das etwa die gleiche Länge aufweist wie das Messobjekt.

  3. Stellen Sie den Analysator auf eine hohe Wobbelgeschwindigkeit ein.

Das in den Referenzpfad eingeschleifte Kabel bewirkt, dass die Laufzeit im Referenzpfad gleich der Laufzeit im Messpfad ist und dadurch bei der Transmissionsmessung (die ja eine Verhältnismessung ist) keine Frequenzverschiebung mehr auftritt.

Hinweis: Diese Methode eignet sich gut zur Kompensation der Laufzeit in einem Kabel oder Testadapter. Wenn das Messobjekt selbst eine große elektrische Länge aufweist, eignet sich diese Methode nur für unkalibrierte Messungen.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen der Prozeduren zur Kompensation einer großen elektrischen Länge.
Wobbelgeschwindigkeit reduzieren

Stufenweise Wobbelung verwenden

Im R-Kanal eine elektrische Länge hinzufügen

Wobbelgeschwindigkeit reduzieren
Mausprozedur

Tastenprozedur

Mausprozedur

Wobbelgeschwindigkeit reduzieren.

  1. Klicken Sie im Sweep-Menü auf Sweep Time.

  2. Geben Sie in das Feld Sweep Time den gewünschten Wert ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Klicken Sie auf OK.

Reduzieren der ZF-Bandbreite

  1. Klicken Sie im Sweep-Menü auf IF Bandwidth.

  2. Geben Sie in das Eingabefeld IF Bandwidth einen kleineren Wert ein, oder wählen Sie mit der Pfeil-unten-Taste einen kleineren Wert.

  3. Klicken Sie auf OK.

Anzahl der Messpunkte vergrößern.

  1. Klicken Sie im Sweep-Menü auf Number of Points.

  2. Wählen Sie einen der aufgelisteten Werte oder geben Sie in das Feld Custom einen beliebigen Wert ein.

  3. Klicken Sie auf OK.

Tastenprozedur

Wobbelgeschwindigkeit reduzieren

  1. Drücken Sie Sweep Setup, F1 (Time).

  2. Geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wobbelgeschwindigkeitswert ein, und drücken Sie Enter.

Reduzieren der ZF-Bandbreite

  1. Drücken Sie Sweep Setup, F3 (Bandwidth).

  2. Geben Sie den gewünschten ZF-Bandbreitenwert über die Tasten im Tastenfeld ENTRY ein, und drücken Sie Enter.

Anzahl der Messpunkte vergrößern

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten im Tastenfeld F1 (Points) einen kleineren Wert, und drücken SieClick. Oder geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein, und drücken Sie Enter.

Stufenweise Wobbelung verwenden
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Sweep-Menü auf Sweep Setup.

  2. Klicken Sie auf das Kontrollkästchen Stepped Sweep.

  3. Geben Sie in das Feld Dwell Time die gewünschte Verweilzeit pro Messpunkt ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zum Kontrollkästchen Stepped Sweep zu gelangen, und wählen Sie durch Drücken der Taste Click die Betriebsart stufenweise Wobbelung.

  3. Drücken Sie die Tab-rechts-Taste, um zum Feld Dwell Time zu gelangen, und wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten die gewünschte Verweilzeit. Oder geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein, und drücken Sie Enter.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Im R-Kanal eine elektrische Länge hinzufügen

  1. Besorgen Sie sich ein Kabel, das die gleiche Länge aufweist wie das Messobjekt.

  2. Schließen Sie das Kabel an den R-Kanal-Eingang auf der Frontplatte an.

    • Für S11- und S21-Messungen müssen Sie das Kabel in den R1-Kanal einschleifen.

    • Für S22- und S12-Messungen müssen Sie das Kabel in den R2-Kanal einschleifen.

Konfiguration für S22- und S12-Messungen


Phasengenauigkeit

Siehe auch...

Phasenmessgenauigkeit

Überblick

Konzepte

Wie verbessert man
die Phasenmessgenauigkeit

Sie können die Phasenmessgenauigkeit auf verschiedene Weise verbessern.
Konzepte

Wie verbessert man die Phasenmessgenauigkeit?

Die folgenden Funktionen ermöglichen es Ihnen, die Genauigkeit von Phasenmessungen zu verbessern.
Elektrische Länge

Messebenenverschiebung

Phasenoffset

Anzahl der Messpunkte (pro Wobbelung)

Elektrische Länge

  • Mit Hilfe der "Electrical Delay"-Funktion (elektrische Länge) können Sie die von einem Bauteil verursachte lineare Phasenverschiebung kompensieren. Beachten Sie, dass diese Funktion ausschließlich die Abweichung vom linearen Phaseenfrequenzgang des Bauteils korrigiert.

  • Die elektrische Länge ist ein Algorithmus, der einen verlustfreien Wellenleiter mit einer bestimmten Länge simuliert .

  • Sie können die elektrische Länge für jeden Kanal individuell spezifizieren.

Messebenenverschiebung

  • Mit Hilfe der "Port Extensions"-Funktion (Messebenenverschiebung ) können Sie die Messebene nach Durchführung einer Kalibrierung verschieben. Dadurch können Sie sich eine nochmalige Kalibrierung ersparen. In folgenden Situationen bietet sich eine Messebenenverschiebung an:

    • Sie haben bereits eine Kalibrierung durchgeführt und stellen dann fest, dass Sie noch ein Kabel in die Messanordnung einschleifen müssen. Durch Spezifizieren eines entsprechenden "Port Extension"-Wertes können Sie dem Analysator "mitteilen", dass Sie ein Kabel mit bestimmter Länge vor einem bestimmten Port eingeschleift haben.

    • Sie sind nicht in der Lage, eine Kalibrierung unmittelbar an der Messebene durchzuführen, weil das Messobjekt über einen Testadapter angeschlossen wird. Mit Hilfe der "Port Extensions"-Funktion können Sie die vom Testadapter verursachte Signallaufzeit (frequenzabhängige Phasenverschiebung) kompensieren.

  • Die "Port Extensions"-Funktion wendet die spezifizierte elektrische Länge automatisch auf alle Messungen an, die über den betreffenden Port durchgeführt werden.

  • Wenn Sie die Anschlüsse für den Direktzugriff auf die Empfänger benutzen, können Sie eine elektrische Länge für die Empfänger A und B spezifizieren.

Hinweis: Die "Port Extensions"-Funktion kompensiert ausschließlich die elektrische Länge von Kabeln, Adaptern und Testadaptern, aber NICHT deren Dämpfung und Fehlanpassung.

Phasenoffset

Der P hasenoffset korrigiert Phasenmessungen um einen vorgegebenen (festen) Phasenwinkel bis zu 360°. Diese Funktion können Sie folgendermaßen nutzen:

  • Verbesserung der "Lesbarkeit" der Ergebnisse einer Phasenmessung. Dies ist vergleichbar der Änderung des Referenzpegels bei einer Amplitudenmessung. Sie können den Phasenfrequenzgang auf dem Bildschirm zentrieren oder in einer bestimmten Weise ausrichten.

  • Emulation einer erwarteten Phasenverschiebung in der Messanordnung. Wenn Sie beispielsweise wissen, dass Sie ein Kabel einschleifen müssen und dessen Länge eine bestimmte Phasenverschiebung verursachen wird, können Sie den "Phase Offset"-Funktion dabzu benutzen, diese Phasenverschiebung hinzuzufügen und so die vollständige Messanordnung zu simulieren.

Abstände zwischen den Frequenzpunkten

  • Der Analysator tastet das Empfängereingangssignal an diskreten Frequenzpunkten ab und verbindet dann die einzelnen Punkte auf dem Bildschirm zu einer Messkurve.

  • Wenn die von einem Bauteil verursachte Phasenverschiebung zwischen zwei benachbarten Frequenzpunkten mehr als 180° beträgt, erscheint dies in der Messkurve wie ein abrupter Phasensprung von einem positiven zu einem negativen Wert oder umgekehrt. Die Ursache hierfür ist, dass die Messdaten in diesem Fall "unterabgetastet" ("undersampled") sind und Aliasing auftritt.

Wenn dieser Effekt bei einer Gruppenlaufzeitmessung auftritt, ändert der Gruppenlaufzeit-Messwert sein Vorzeichen. Die folgende Abbildung zeigt als Beispiel das Ergebnis einer Messung an einem SAW-Bandpassfilter.

  • Die erste Messung besteht aus 51 Punkten und zeigt eine negative Gruppenlaufzeit an (was nach den Gesetzen der Physik unmöglich ist). Die Messkurve liegt in diesem Fall unter der Referenzlinie (0 Sekunden).

  • Die zweite Abbildung zeigt die gleiche Messung, jedoch mit 201 Messpunkten; jetzt sind die Gruppenlaufzeitwerte positiv. Die Messkurve liegt jetzt über der Referenzlinie (0 Sekunden).

Tipp:

  • Wenn Sie überprüfen möchten, ob Ihre Messung durch Aliasing verfälscht wird, reduzieren Sie die Anzahl der Messpunkte und kontrollieren Sie, ob sich die Messkurve dadurch wesentlich ändert. Falls Aliasing auftritt, können Sie entweder die Anzahl der Messpunkte vergrößern oder die Wobbelbandbreite reduzieren.

Durch Anklicken der Schaltfläche gelangen Sie zu Beschreibungen von Prozeduren zur Verbesserung der Phasenmessgenauigkeit.
Kompensation einer linearen Phasenverschiebung

Elektrische Messebenenverschiebung

Phasenoffset

Überprüfung auf Aliasing

Kompensation einer linearen Phasenverschiebung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Scale-Menü auf Electrical Delay.

  2. Geben Sie in das Feld Electrical Delay den gewünschten Wert ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Geben Sie in das Eingabefeld Velocity Factor den gewünschten Wert (zwischen 0 und 1.0) ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile. Dies ist die Ausbreitungsgeschwindigkeitsfaktor für das Medium des Messobjekts.

  • 1.0 entspricht der Lichtgeschwindigkeit im Vakuum.

  • 0.66 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Polyethylen-Dielektrikum.

  • 0.70 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Teflon-Dielektrikum.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATIONdie Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Scale-Menü und zu Electrical Delay zu gelangen. Drücken Sie Click.

  2. Geben Sie in das Feld Electrical Delay über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein und drücken Sie Enter, oder wählen Sie den gewünschten Wert mit Hilfe der Pfeil-oben/unten-Tasten. Drücken Sie Click.

  3. Drücken Sie die Tab-rechts-Taste, um zum Feld Velocity Factor zu gelangen.

  4. Geben Sie in das Feld Velocity Factor über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein, oder wählen Sie den gewünschten Wert mit Hilfe der Pfeil-unten-Taste; drücken Sie anschließend Click. Wählen Sie einen Wert zwischen 0 und 1.0. Dies ist die Ausbreitungsgeschwindigkeitsfaktor für das Medium des Messobjekts.

  • 1.0 entspricht der Lichtgeschwindigkeit im Vakuum.

  • 0.66 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Polyethylen-Dielektrikum.

  • 0.70 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Teflon-Dielektrikum.

Elektrische Messebenenverschiebung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Calibration-Menü auf Port Extensions.

  2. Wählen Sie das Kontrollkästchen Port Extensions.

  3. Geben Sie den gewünschten "Extension"-Wert für den Port ein, dessen Messebene Sie verschieben möchten.

  4. Geben Sie in das Feld Velocity Factor den Ausbreitungsgeschwindigkeitsfaktor des Mediums des Kabels oder Bauteils ein, das Sie nach der Kalibrierung hinzugefügt haben; der Wert muss zwischen 0 und 1.0 liegen. Klicken Sie anschließend auf OK.

  • 1.0 entspricht der Lichtgeschwindigkeit im Vakuum.

  • 0.66 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Polyethylen-Dielektrikum.

  • 0.70 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Teflon-Dielektrikum.

Tipp:

So können Sie herausfinden, ob die spezifizierte elektrische Länge ausreicht:

  1. Schließen Sie anstelle des Bauteils einen Kurzschlussstecker an.

  2. Stellen Sie den "Port Extension"-Wert so ein, dass sich ein horizontaler Phasenfrequenzgang ergibt.

Hinweis: Die meisten Kurzschluss-Kalibrierungsnormale haben eine elektrische Länge ungleich null. Wenn Sie die elektrische Länge auf die beschriebene Weise einstellen, resultiert daraus ein Laufzeitfehler mit dem doppelten Wert der Laufzeit des Kurzschlussnormals. Die elektrische Länge des Kurzschlussnormals können Sie der entsprechenden Kalibriernormal-Definition entnehmen.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Calibration-Menü und zu Port Extensions zu gelangen. Drücken Sie Click.

  3. Drücken Sie Click, um das Kontrollkästchen Port Extensions zu aktivieren.

  4. Drücken Sie die Tab-rechts-Taste, um zu dem Feld für den Eingang oder Port zu gelangen, dessen Messebene Sie verschieben möchten. Geben Sie den gewünschten Wert ein und drücken Sie Enter.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Velocity Factor zu gelangen.

  6. Wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten im Feld Velocity Factor den Ausbreitungsgeschwindigkeitsfaktor des Mediums des Kabels oder Bauteils, das Sie nach der Kalibrierung hinzugefügt haben; der Wert muss zwischen 0 und 1.0 liegen. Drücken Sie OK.

  • 1.0 entspricht der Lichtgeschwindigkeit im Vakuum.

  • 0.66 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Polyethylen-Dielektrikum.

  • 0.70 entspricht der typischen Ausbreitungsgeschwindigkeit in einem Teflon-Dielektrikum.

Tipp:

So können Sie herausfinden, ob die spezifizierte elektrische Länge ausreicht:

  1. Schließen Sie anstelle des Bauteils einen Kurzschlussstecker an.

  2. Stellen Sie den "Port Extension"-Wert (Messebenenverschiebung) so ein, dass sich ein horizontaler Phasenfrequengang ergibt.

Hinweis: Die meisten Kurzschluss-Kalibrierungsnormale haben eine elektrische Länge ungleich null. Wenn Sie die elektrische Länge auf die beschriebene Weise einstellen, resultiert daraus ein Laufzeitfehler mit dem doppelten Wert der Laufzeit des Kurzschlussnormals. Die elektrische Länge des Kurzschlussnormals können Sie der entsprechenden Kalibriernormal-Definition entnehmen.

Phasenoffset
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Scale-Menü auf Phase Offset.

  2. Geben Sie in das Feld Phase Offset den gewünschten Wert ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Scale-Menü und zu Phase Offset zu gelangen. Drücken Sie Click.

  3. Geben Sie in das Feld Phase Offset über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein und drücken Sie Enter, oder wählen Sie den gewünschten Wert mit Hilfe der Pfeil-oben/unten-Tasten. Drücken Sie Enter, OK.

Überprüfung auf Aliasing
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Sweep-Menü auf Number of Points.

  2. Wählen Sie einen der aufgelisteten Werte, oder geben Sie in das Feld Custom über die Tasten im Tastenfeld ENTRY einen Wert ein, der kleiner als der aktuelle Wert ist.

  3. Klicken Sie auf OK.

    Falls sich die Messkurve wesentlich ändert, können Sie entweder die Anzahl der Messpunkte vergrößern oder die Wobbelbandbreite reduzieren.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie F2 (Points).

  3. Wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten im Tastenfeld NAVIGATION einen kleineren Wert und drücken Sie Click.

    Falls sich die Messkurve wesentlich ändert, vergrößern Sie entweder die Anzahl der Messpunkte oder reduzieren Sie die Wobbelbandbreite.


Siehe auch...

Messkurvenrauschen

Überblick

Konzepte

Wie verringert man
das Messkurvenrauschen?

Der Analysator bietet verschiedene Möglichkeiten zur Reduktion des Messkurvenrauschens.
Konzepte

Wie verringert man das Messkurvenrauschen?

Sie können die nachfolgenden Analysatorfunktionen dazu verwenden, das Messkurvenrauschen zu reduzieren.
"Sweep Averages" (Messkurvenmittelung)

"Trace Smoothing" (Messkurvenglättung)

"IF Bandwidth" (ZF-Bandbreite)

"Sweep Averages" (Messkurvenmittelung)

  • Messkurvenmittelung ist ein Verfahren, das die Auswirkungen von Rauschen auf die Messergebnisse verringert.

  • Der Analysator berechnet für jeden Messkurvenpunkt einen gleitenden Mittelwert aus mehreren Messungen; die Anzahl der zur Mittelung herangezogen Messungen wird durch den von Ihnen vorgegebenen Mittelungsfaktor bestimmt.

  • Sobald die Anzahl der durchgeführten Messungen größer ist als der Mittelungsfaktor, fallen die jeweils ältesten Messergebnisse aus der Mittelung heraus.

  • Je größer der Mittelungsfaktor, desto stärker ist die Rauschunterdrückung und desto größer der D ynamikbereich .

  • Unter dem Aspekt der Rauschunterdrückung hat Messkurvenmittelung die gleiche Wirkung wie eine Reduktion der ZF-Bandbreite.

Auswirkung der Mittelung

"Trace Smoothing" (Messkurvenglättung)

Sie können die Messkurvenglättung dazu verwenden, relativ kleine Rauschspitzen auf breitbandigen Messdaten zu reduzieren. Die "Trace Smoothing"-Funktion berechnet die Messkurve für den aktiven Kanal punktweise durch Mittelung über eine bestimmte Anzahl von Messkurvenpunkten links und rechts des betreffenden Punktes; die zur Mittelung herangezogene Anzahl der Messkurvenpunkte wird durch den "Smoothing Aperture"-Wert bestimmt.

Tipps:

  • Wählen Sie eine ausreichend große Anzahl von Messkurvenpunkten, um irreführende Ergebnisse zu vermeiden.

  • Wenden Sie die "Trace Smoothing"-Funktion nicht auf Bauteile mit ausgeprägter Resonanz an, da sie in diesem Fall Messfehler verursachen kann.

  • Sie können den "Trace Smoothing"-Funktion für jeden Kanal individuell aktivieren und konfigurieren.

Auswirkung der Messkurvenglättung

"IF Bandwidth" (ZF-Bandbreite)

  • Durch Reduktion der ZF-Bandbreite des Empfängers können Sie den Einfluss des Rauschens auf die Messung reduzieren. Bei einer Reduktion der ZF-Bandbreite um den Faktor 10 verringert sich das Eigenrauschen um 10 dB. Durch das Verkleinern der ZF-Bandbreite verlängert sich allerdings die Wobbelzeit.

  • Der Netzwerkanalysator setzt das Eingangssignal aus dem HF/Mikrowellenbereich in eine niedrigere Zwischenfrequenz (IF, Intermediate Frequency), nämlich 41,67 kHz um. Die Bandbreite des ZF-Bandpassfilters ("ZF-Bandbreite") ist im Bereich von 40 kHz bis 1 Hz einstellbar.

  • Sie können die ZF-Bandbreite für jeden Kanal (und bei Segmentwobbelung für jedes Segment) individuell einstellen.

Auswirkung der Reduktion der ZF-Bandbreite

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zur Reduktion des Messkurvenrauschens.
Messkurvenmittelung

Messkurvenglättung

Reduzieren der ZF-Bandbreite

Messkurvenmittelung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Channel auf Average.

  2. Falls die "Average"-Funktion noch nicht aktiv ist, aktivieren Sie das Kontrollkästchen Average On.

  3. Vergrößern Sie den im Feld Average Factor angezeigten Mittelungsfaktor auf den Wert, den Sie für die Messung verwenden möchten.

  4. Klicken Sie auf OK.

Hinweis: Klicken Sie auf Channel, Restart Average, um eine neue Folge von Messungen für Mittelung zu starten.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Average.

  2. Falls die "Average"-Funktion noch nicht aktiv ist, aktivieren Sie sie durch Drücken der Taste F2 (Avg ON/OFF).

  3. Drücken Sie F1 (Avg#).

  4. Geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Mittelungsfaktor ein, und drücken Sie Enter.

Hinweis: Drücken Sie F4 (Restart), um eine neue Folge von Messungen für die Mittelung zu starten.

Messkurvenglättung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Trace auf Smoothing.

  2. Falls die "Smoothing"-Funktion noch nicht aktiv ist, aktivieren Sie das Kontrollkästchen Smoothing ON.

  3. Entscheiden Sie sich, auf welche Weise Sie den Apertur-Wert spezifizieren möchten:

    • Geben Sie in das Feld Percent of Span einen Wert für den "Smoothing"-Prozentsatz ein. (Der Maximalwert ist 25%.)

    • ODER geben Sie in das Feld Points einen Wert für die Anzahl der zu mittelnden Messkurvenpunkte ein. (Der Maximalwert ist 25% der Anzahl der Messpunkte für den gesamten Wobbelzyklus)

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Klicken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Trace-Menü und zu Smoothing zu gelangen; drücken Sie anschließend Click.

  3. Falls die "Smoothing"-Funktion noch nicht aktiv ist, drücken Sie Click, um das Kontrollkästchen Smoothing ON zu aktivieren.

  4. Wählen Sie mit der Tab-rechts-Taste, auf welche Weise Sie den "Smoothing Aperture"-Wert spezifizieren möchten:

    • Geben Sie in das Feld Percent of Span einen Wert für den "Smoothing"-Prozentsatz ein. (Der Maximalwert ist 25%.)

    • ODER geben Sie in das Feld Points einen Wert für die Anzahl der zu mittelnden Messkurvenpunkte ein. (Der Maximalwert ist 25% der Anzahl der Messpunkte für den gesamten Wobbelzyklus)

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Reduzieren der ZF-Bandbreite
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf IF Bandwidth.

  2. Geben Sie in das Feld IF Bandwidth einem kleineren Bandbreitenwert ein, oder wählen Sie diesen durch Anklicken der Pfeile.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL die Taste Sweep Setup.

  2. Drücken Sie im Tastenfeld NAVIGATION die Taste F3 (Bandwidth).

  3. Geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten ZF-Bandbreitenwert ein, und drücken Sie Enter.


Schnelle Wobbelung

Siehe auch...

Wobbelgeschwindigkeit

Überblick

Konzepte

Wie maximiert man
die Wobbelgeschwindigkeit?

Die Maximierung der Wobbelgeschwindigkeit ist eine von mehreren Möglichkeiten zur Maximierung der Messgeschwindigkeit.
Konzepte

Wie Sie die größtmögliche Wobbelgeschwindigkeit erzielen

Sie können die Wobbelgeschwindigkeit maximieren, indem Sie folgende Einstellungen entsprechend optimieren bzw. Funktionen optimal einsetzen.
Wobbel-Einstellungen

Einstellungen für Rauschreduktion

Kalibrierungsverfahren

Nicht benötigte Funktionen

Wobbel-Einstellungen:

Ändern Sie gegebenenfalls die nachfolgenden Einstellungen wie vorgeschlagen.

  • Wobbelbandbreite. Messen Sie nur bei Frequenzen, die für den Prüfling und dessen Anwendung relevant sind.

  • Segmentwobbelung. Beschränken Sie die Wobbelung auf die relevanten Frequenzbereiche.

  • Schalten Sie die schrittweise Wobbelung aus. Zwecks Minimierung der Wobbelzeit sollten Sie möglichst mit linearer Wobbelung arbeiten.

  • Automatische Wobbelzeitwahl. Die automatisch gewählte Wobbelzeit (dies ist die Standardbetriebsart) gewährleistet die schnellste Wobbelung, die mit den aktuellen Einstellungen möglich ist.

  • Anzahl der Messpunkte. Verwenden Sie die kleinstmögliche Anzahl von Messpunkten, die für die Messung benötigt wird.

"Number of Points" | Wobbelzyklusdauer (ms)*
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 55

*Gerätezustand: Preset-Zustand, 35 kHz Bandbreite, Mittenfrequenz 1 GHz, Wobbelbandbreite 100 MHz, Korrektur aus. Bei eingeschaltetem Bildschirm verlängert sich die Zyklusdauer um 21 ms. Die Wobbelzyklusdauer setzt sich aus der Wobbelzeit und der Rücklaufzeit zusammen.

Weitere Informationen darüber, wie die Anzahl der Messpunkte und andere Einstellungen die Wobbelzyklusdauer beeinflussen, finden Sie unter Erläuterungen zu den Spezifikationen.

Einstellungen für Rauschreduktion

Durch geeignete Kombination dieser Einstellungen können Sie die Wobbelzeit reduzieren und dennoch eine akzeptable Messgenauigkeit erzielen.

  • ZF-Bandbreite. Verwenden Sie die größte ZF-Bandbreite, bei der sich ein akzeptabler Rauschabstand und ein akzeptabler D ynamikbereich ergeben.

  • Mittelung. Reduzieren Sie den Mittelungsfaktor oder schalten Sie die Mittelungsfunktion ab.

Kalibrierungsverfahren

  • Wählen Sie die schnellste Art der Kalibrierung, mit der Sie die geforderte Genauigkeit erzielen.

    • Die Wobbelgeschwindigkeit für Messungen mit Frequenzgangkalibrierung oder Ein-Tor-Kalibrierung ist fast die gleiche wie für nicht-korrigierte Messungen.

    • Bei vollständiger Zwei-Tor-Kalibrierung werden alle vier S-Parameter zur Fehlerkorrektur herangezogen. Das bedeutet, dass auch dann Wobbelmessungen in Vorwärts- und Rückwärtsrichtung erforderlich sind, wenn nur ein einziger S-Parameter angezeigt wird.

Einzelheiten hierzu siehe Kalibrierung.

Nicht-benötigte Funktionen

Für alle aktiven Funktionen muss der Analysator fortwährend die zugehörigen Informationen aktualisieren. Sie können die Wobbelgeschwindigkeit weiter erhöhen, indem Sie alle Analysatorfunktionen abschalten, die für die jeweilige Messung nicht benötigt werden.

  • Nicht-benötigte Messkurven

  • Nicht-benötigte Marker

  • "Smoothing"-Funktion

  • "Limit Test"-Funktion

  • "Trace Math"-Funktionen

  • Bildschirmanzeige

Die Wobbelgeschwindigkeit ist von diversen Einstellungen abhängig. Am besten probieren Sie aus, mit welchen Einstellungen Sie bei der geforderten Messgenauigkeit die größtmögliche Wobbelgeschwindigkeit erzielen.
Ändern der Wobbel-Einstellungen

Ändern der Einstellungen für Rauschreduktion

Abschalten nicht benötigter Funktionen

Wählen eines "schnellen" Kalibrierungsverfahrens

Ändern der Wobbel-Einstellungen
Mausprozedur

Tastenprozedur

Mausprozedur

Ändern der Wobbelbandbreite

  1. Rufen Sie das Menü mit den Wobbel-Einstellungen auf:

    • Für Frequenzwobbelung: Klicken Sie im Channel-Menü auf Start/Stop oder Center/Span.

    • Für Signalpegelwobbelung: Klicken Sie im Menü Channel auf Power.

  2. Geben Sie in das Eingabefeld Start (Center) einen Wert ein, der eine kleinere Wobbelbandbreite ergibt, oder wählen Sie mit der entsprechenden Pfeil-Schaltfläche einen solchen Wert.

  3. Geben Sie in das Eingabefeld Stop (Span) einen Wert ein, der eine kleinere Wobbelbandbreite ergibt, oder wählen Sie mit der entsprechenden Pfeil-Schaltfläche einen solchen Wert.

  4. Klicken Sie auf OK.

  5. Unter Segmentwobbelung wird beschrieben, die Sie den Wobbelungstyp ändern können.

Abschalten der schrittweisen Wobbelung.

  1. Klicken Sie im Menü Sweep auf Sweep Setup.

  2. Klicken Sie in das Eingabefeld Stepped Sweep, um es zu löschen; klicken Sie dann auf OK.

Aktivieren der automatischen Wobbelzeitwahl

  1. Klicken Sie im Menü Sweep auf Sweep Time.

  2. Klicken Sie so oft auf die Pfeil-unten-Schaltfläche, bis der Wert nicht mehr kleiner wird; klicken Sie dann auf OK.

Ändern der Anzahl der Messpunkte

  1. Klicken Sie im Menü Sweep auf Number of Points.

  2. Wählen Sie einen der aufgelisteten Werte oder geben Sie über Customize einen beliebigen Wert ein.

  3. Klicken Sie auf OK.

Tastenprozedur

Ändern der Wobbelbandbreite

  1. Rufen Sie das Menü mit den Wobbel-Einstellungen auf:

    • Für Frequenzwobbelung: Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Center, F1 (Start) oder F3 (Center).

    • Für Signalpegelwobbelung: Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power, F1 (Start).

  2. Geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wert in das Eingabefeld ein, und drücken Sie anschließend Enter.

  3. Drücken Sie F2 (Stop) oder F4 (Span), und geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein; drücken Sie anschließend Enter.

  4. Unter Segmentwobbelung wird beschrieben, wie Sie den Wobbelungstyp ändern können.

Abschalten der schrittweisen Wobbelung.

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  3. Falls das Kontrollkästchen Stepped Sweep aktiviert ist, drücken Sie die Tab-rechts-Taste , um zum Feld Stepped Sweep zu gelangen; drücken Sie anschließend zum Deaktivieren des Kontrollkästchens die Taste Click.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Aktivieren der automatischen Wobbelzeitwahl

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie F1 (Time) und anschließend im Tastenfeld ENTRY die Tasten 0, Enter.

Ändern der Anzahl der Messpunkte

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie F2 (Points).

  3. Wählen Sie im Tastenfeld NAVIGATION mit der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Wert; drücken Sie zum Übernehmen des gewählten Wertes Click. Oder geben Sie über die Tasten im Tastenfeld ENTRY den gewünschten Wert ein, und drücken Sie Enter.

Ändern der Einstellungen für Rauschreduktion
Mausprozedur

Tastenprozedur

Mausprozedur

Ändern der ZF-Bandbreite

  1. Klicken Sie im Menü Sweep auf IF Bandwidth.

  2. Geben Sie in das Eingabefeld IF Bandwidth einen größeren Wert ein, oder wählen Sie mit der Pfeil-oben-Taste einen größeren Wert.

  3. Klicken Sie auf OK.

Ändern des Mittelungsfaktors

  4. Klicken Sie im Menü Channel auf Average.

  5. Verringern Sie den im Feld Average Factor angezeigten Mittelungsfaktor auf den Wert, den Sie für die Messung verwenden möchten.

    • Oder schalten Sie die Mittelungsfunktion ab, indem Sie das Kontrollkästchen Average On durch Anklicken deaktivieren.

  6. Klicken Sie auf OK.

Hinweis: Klicken Sie auf Channel, Restart Average, um eine neue Folge von Wobbelzyklen für eine Mittelungsmessung zu starten.

Tastenprozedur

Ändern der ZF-Bandbreite

  1. Drücken Sie Sweep Setup, F3 (IF Bandwidth).

  2. Geben Sie einen größeren Wert für die ZF-Bandbreite ein.

  3. Drücken Sie im Tastenfeld ENTRY die Taste Enter.

Ändern des Mittelungsfaktors

  4. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Average.

  5. Drücken Sie F1 (Avg#), geben Sie einen kleineren Mittelungsfaktor ein, und drücken Sie Enter.

    • Oder schalten Sie die Mittelungsfunktion durch Drücken der Taste F2 (Avg ON/OFF) ab.

Hinweis: Drücken Sie F4 (Restart), um eine neue Folge von Wobbelzyklen für eine Mittelungsmessung zu starten.

Abschalten nicht benötigter Funktionen
Mausprozedur

Tastenprozedur

Mausprozedur

Abschalten nicht benötigter Messkurven

  1. Klicken Sie zum Aktivieren der nicht benötigten Messkurve, die Sie abschalten möchten, auf die "Trace Status"-Leiste.

  2. Klicken Sie im Menü Trace auf Delete Trace.

Abschalten nicht benötigter Marker

  1. Klicken Sie im Menü Marker auf Select Marker und anschließend auf den nicht benötigten Marker, den Sie abschalten möchten.

    • Wenn Sie alle Marker abschalten möchten, klicken Sie auf All Off.

  2. Falls die "Marker"-Symbolleiste nicht angezeigt wird, klicken Sie im Menü View auf Toolbars und dann auf Marker.

  3. Klicken Sie auf das Kontrollkästchen On, um es zu deaktivieren.

Abschalten der Glättungsfunktion

  1. Klicken Sie im Menü Trace auf Smoothing.

  2. Klicken Sie auf das Kontrollkästchen Smoothing On, um das Kontrollkästchen zu deaktivieren und die Glättungsfunktion abzuschalten. Klicken Sie auf OK.

Abschalten der Grenzwerttestfunktion

  1. Klicken Sie im Menü Trace auf Limit Test.

  2. Klicken Sie auf das Kontrollkästchen Limit Test ON, um das Kontrollkästchen zu deaktivieren und die Grenzwerttestfunktion abzuschalten. Klicken Sie auf OK.

Abschalten der Messkurven-Arithmetik-Funktionen

  • Zeigen Sie im Menü Trace auf die Liste Data Math und klicken Sie auf Data; anschließend wird nur noch die aktuelle Messkurve angezeigt.

Tastenprozedur

Abschalten nicht benötigter Messkurven

  1. Führen Sie diesen Schritt durch, falls mehrere Bildschirmfenster vorhanden sind.

    • Drücken Sie im Tastenfeld DISPLAY so oft die Taste Window, F2 (Next Window), bis das Fenster mit der nicht-benötigten Messkurve gewählt ist.

  2. Drücken Sie im Tastenfeld DISPLAYso oft die Taste Trace, F2 (Next Trace), bis die nicht-benötigte Messkurve gewählt ist.

  3. Drücken Sie F4 (Delete).

Abschalten nicht benötigter Marker

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker.

  2. Wählen Sie durch Drücken der Taste F1 oder F2 oder F3 (Marker 1, Marker 2, Marker 3) den Marker, den Sie abschalten möchten. Wenn Sie nochmals Marker drücken, können Sie weitere Marker sehen.

  3. Drücken Sie anschließend F4 (Off).

  4. Falls Sie alle Marker abschalten möchten, gehen Sie folgendermaßen vor:

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Menü Marker und zu All Off zu gelangen. Drücken Sie Click.

Abschalten der Glättungsfunktion

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Menü Trace und zu Smoothing zu gelangen. Drücken Sie Click, Click.

  3. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Abschalten der Grenzwerttestfunktion

  • Drücken Sie im Tastenfeld TRACE SETUP die Tasten Limit Table, F1 (Test ON/OFF).

Abschalten der Messkurven-Arithmetik-Funktionen

  • Drücken Sie im Tastenfeld TRACE SETUP die Tasten Math/Memory, F3 (Data Only) , damit nur die aktuelle Messkurve angezeigt wird.

Wählen eines "schnellen" Kalibrierungsverfahrens
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Calibration-Menü auf Calibration Wizard, Cal Type.

  2. Wählen Sie eines der folgenden Kalibrierverfahren: OPEN Response, SHORT Response, THRU Response oder 1-Port; klicken Sie anschließend auf OK.

  3. Klicken Sie auf Measure Stds. Folgen Sie den Hinweisen des Kalibrierungsassistenten.

Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Cal, F1 (Cal Wizard).

  2. Wählen Sie mit Hilfe der NAVIGATION-TastenArrows undClick eines der folgenden Kalibrierverfahren: OPEN Response, SHORT Response, THRU Response oder 1-Port.

  3. Drücken Sie im Tastenfeld COMMAND die Taste OK.

  4. Drücken Sie im Tastenfeld NAVIGATIONdie Tab-rechts-Taste, umMeasure Stds... zu wählen. Drücken Sie anschließend auf Click.

  5. Folgen Sie den Hinweisen des Kalibrier-Assistenten.

Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.


Siehe auch...

Mehrfachmessungen

Überblick

Konzepte

Wie beschleunigt man
Mehrfachmessungen?

Falls Sie zur Charakterisierung eines Prüflings mehrere Messungen durchführen müssen, haben Sie verschiedene Möglichkeiten, den Durchsatz zu steigern.
Konzepte

Wie beschleunigt man Mehrfachmessungen?

Am besten probieren Sie aus, welche dieser Methoden für Ihre Anwendung optimal ist.
Maßnahmen zur Steigerung des Durchsatzes

Gruppieren von Messungen

Segmentwobbelung

Selektives Triggern von Messungen

Automatisierung von Einstellungsänderungen zwischen den Messungen

Schnelles Abrufen von Messungen

Maßnahmen zur Steigerung des Durchsatzes

Wenn Ihre Anwendung mehrere unterschiedliche Messungen am gleichen Messobjekt erfordert, können Sie durch geschicktes Organisieren der Messungen den Durchsatz steigern. Zum Organisieren von Messungen stehen folgende "Bausteine" zur Verfügung, die Sie beliebig miteinander kombinieren können:

  • 1 bis 4 voneinander unabhängige Messkanäle

  • 1 bis 4 Messkurven pro Fenster

  • 1 bis 4 Bildschirmfenster

  • 1 bis 16 Messkurven auf dem Bildschirm

  • 1 bis 16 gespeicherte Messkurven auf dem Bildschirm

Ein Kanal besitzt bestimmte, voneinander unabhängige Attribute, welche die Messdatenerfassung betreffen.

Eine Messkurve besitzt bestimmte Attribute, die mathematische Operationen auf der Basis der erfassten Messdaten betreffen.

Die Messkurven werden in einem Fenster dargestellt.

Gruppieren von Messungen

Sie haben die Möglichkeit, eine Gruppe von Messungen als einen einzigen Gerätezustand abzuspeichern und später mit einem einzigen "Recall"-Befehl wieder abzurufen. Weitere Informationen hierzu siehe Mehrere Messkurven und Kanäle.

Sie haben folgende Möglichkeiten zum Gruppieren von Messungen:

  • Messkurven mehrerer Kanäle können in einem einzigen Fenster dargestellt werden.

  • Messkurven mehrerer Kanäle können in mehreren Fenstern dargestellt werden.

Segmentwobbelung

Wenn Sie zur Charakterisierung eines Prüflings während der Messungen einen oder mehreren der folgenden Parameter ändern müssen, können Sie durch Segmentwobbelung Zeit sparen.

  • Frequenzbereich

  • Signalpegel

  • ZF-B andbreite

  • Anzahl der Messpunkte

Für die Segmentwobbelung können Sie mehrere Frequenzbereiche mit jeweils unterschiedlichen Attributen definieren. Auf diese Weise lassen sich auch solche Prüflinge, deren elektrische Eigenschaften (wie z. B. Einfügedämpfung) extrem frequenzabhängig sind, mit einer einzigen Wobbelmessung vollständig charakterisieren. Weitere Informationen hierzu siehe Segmentwobbelung.

Selektives Triggern von Messungen

Durch selektives Triggern von Messungen können Sie deren Häufigkeit in folgender Weise beeinflussen:

  • Kontinuierliche Aktualisierung ausschließlich solcher Messungen, deren Ergebnisse sich schnell ändern.

  • Gelegentliche Aktualisierung von Messungen, deren Ergebnisse sich nur selten ändern.

Nehmen wir beispielsweise an, Sie haben vier Kanäle folgendermaßen konfiguriert:

  • Zwei Kanäle liefern Messdaten, die zum Abgleichen eines Filters benötigt werden.

  • Die beiden übrigen Kanäle dienen zur Charakterisierung des Filter-Frequenzgangs im Sperrbereich.

In diesem Fall ist es zweckmäßig, nur die zum Abgleichen des Filters benötigten Messdaten ständig zu beobachten. Wenn ständig sämtliche Kanäle aktualisiert würden, könnte dies die Messgeschwindigkeit so weit herabsetzen, dass ein zügiger Filterabgleich nicht mehr möglich wäre.

Hinweis: Die nur selten zu aktualisierende Messung muss entweder manuell oder durch einen entsprechenden Fernsteuerungsbefehl getriggert werden.

Automatisierung von Einstellungsänderungen zwischen den Messungen

Wenn zwischen den verschiedenen Messungen, die zur Charakterisierung eines Prüflings erforderlich sind, nur geringfügige Einstellungenänderungen vorgenommen werden müssen, ist es eventuell einfacher, diese Änderungen zu automatisieren.

Schnelles Abrufen von Messungen

  • Am schnellsten und einfachsten lassen sich Messungen abrufen, wenn sie als Gruppe (Gerätezustand) abgespeichert wurden.

  • Das Abrufen eines Gerätezustands, der mehrere Messungen beinhaltet, dauert nur wenig länger als das Abrufen eines Gerätezustands, der nur eine einzige Messung beinhaltet.

  • Jede zusätzliche "Recall"-Operation erfordert eine bestimmte Zeit. Sie können diese Zeit einsparen, indem Sie die benötigten Messungen als eine Gruppe abspeichern und dann mit einer einzigen "Recall"-Operation abrufen.

Durch Anklicken der Schaltfläche gelangen Sie zu einer detaillierten Beschreibung der jeweiligen Prozedur zur Steigerung des Durchsatzes bei Mehrfachmessungen.
Gruppieren von Messungen

Segmentwobbelung

Selektives Triggern von Messungen

Automatisierung von Einstellungsänderungen zwischen den Messungen

Gruppieren von Messungen
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Window auf Meas Setups und anschließend auf eine der Setup-Alternativen:

    • Setup A: konfiguriert den Analysator für die Messung aller vier S-Parameter in einem einzigen Kanal, wobei alle Parameter in einem gemeinsamen Fenster im Format "Log Mag" dargestellt werden.

    • Setup B: konfiguriert den Analysator für die Messung aller vier S-Parameter in einem einzigen Kanal, wobei die einzelnen S-Parameter jeweils in einem separaten Fenster im Format "Log Mag" dargestellt werden.

    • Setup C: konfiguriert den Analysator für die Messung von drei S-Parametern (S11, S22, S21) in einem Kanal, wobei die einzelnen S-Parameter jeweils in einem separaten Fenster dargestellt werden, und zwar S11 und S22 im Format "Smith Chart" und S21 im Format "Log Mag".

    • Setup D: konfiguriert den Analysator für zwei Kanäle, in denen jeweils die Parameter S21 und S11 gemessen werden. Die beiden Kanäle werden in separaten Fenstern im Format "Log Mag" dargestellt.

  2. Passen Sie diese Einstellungen gegebenenfalls Ihren individuellen Anforderungen an.

Weitere Informationen siehe Einrichten von Messungen.

Tastenprozedur

  1. Drücken Sie im Tastenfeld DISPLAY die Taste Measure Setups, und wählen Sie mit den Tasten F1, F2, F3 oder F4 den gewünschten Setup:

    • Setup A: 1 Kanal, 4 S-Parameter, "Log Mag", 1 Fenster

    • Setup B: 1 Kanal, 4 S-Parameter, "Log Mag", 4 Fenster

    • Setup C: 1 Kanal, 3 S-Parameter, "Smith" / Log Mag", 3 Fenster

    • Setup D: 2 Kanäle, 2 S-Parameter (4 Messkurven), "Log Mag", 2 Fenster

  2. Passen Sie diese Einstellungen gegebenenfalls Ihren individuellen Anforderungen an.

Weitere Informationen siehe Einrichten von Messungen.

Selektives Triggern von Messungen

Nachfolgend wird beschrieben, wie Sie zwei unterschiedliche Messungen mit folgenden Eigenschaften einrichten:

  • Bei einer der beiden Messungen werden die Daten kontinuierlich aktualisiert.

  • Bei der anderen Messung werden die Daten nur gelegentlich aktualisiert.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Windows-Menü auf Meas Setups, Setup D.

  2. Ändern Sie die Einstellungen in der Weise ab, dass die Messung in Kanal 1 kontinuierlich aktualisiert wird und die Messung in Kanal 2 nur bei expliziter Triggerung (manuell oder per Fernsteuerungsbefehl).

Einrichten einer Messung, die kontinuierlich aktualisiert wird

  3. Klicken Sie im Menü Sweep auf Trigger, Trigger....

  4. Klicken Sie unter Trigger Source auf Internal.

  5. Wählen Sie unter Channel Trigger State die Alternative Channel 1, und klicken Sie auf Continuous.

Einrichten einer Messung, die nur gelegentlich (nach expliziter Triggerung) aktualisiert wird

  6. Wählen Sie unter Channel Trigger State, die Alternative Channel 2, und klicken Sie auf Single, OK.

    • Wenn Sie möchten, dass der Analysator nach erfolgter Triggerung mehrere Wobbelzyklen ausführt, klicken Sie auf das Kontrollkästchen Enable Groups, und geben Sie die gewünschte Anzahl von Wobbelzyklen ein.

  7. Klicken Sie im System-Menü auf Keys, Trigger.

Aktualisieren der Messung

  8. Klicken Sie auf das untere Fenster, um den Kanal 2 zum aktiven Kanal zu machen.

  9. Klicken Sie in der Aktuelle-Eingabe-Symbolleiste auf den gewünschten Triggertyp.

    • Klicken Sie auf Single, wenn der Analysator nach jedem Trigger einen einzigen Wobbelzyklus ausführen soll.

    • Klicken Sie auf Groups, wenn der Analysator nach jedem Trigger mehrere Wobbelzyklen ausführen soll.

Hinweis: Sie können eine Messung nur dann triggern, wenn eine zugehörige Messkurve aktiv ist.

Tastenprozedur

  1. Drücken Sie im Tastenfeld DISPLAY die Tasten Measure Setups, F4 (Setup D).

  2. Ändern Sie die Einstellungen in der Weise ab, dass die Messung in Kanal 1 kontinuierlich aktualisiert wird und die Messung in Kanal 2 nur bei expliziter Triggerung (manuell oder per Fernsteuerungsbefehl).

Einrichten einer Messung, die kontinuierlich aktualisiert wird

  4. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Channel, F1 (Ch 1).

  5. Drücken Sie Trigger, F1 (Continuous).

Einrichten einer Messung, die nur gelegentlich (nach expliziter Triggerung) aktualisiert wird

  6. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Channel, F2 (Ch 2).

  7. Drücken Sie Trigger, F2 (Single).

  8. Wenn Sie möchten, dass der Analysator nach erfolgter Triggerung mehrere Wobbelzyklen ausführt, gehen Sie folgendermaßen vor:

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Trigger.

    3. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zum Kontrollkästchen Enable Groups zu gelangen, und drücken Sie "Click".

    4. Drücken Sie die Tab-rechts-Taste, um zum Feld Enable Groups zu wechseln, und geben Sie die gewünschte Anzahl von Wobbelzyklen ein.

    5. Drücken Sie im Tastenfeld COMMAND die Taste OK.

    6. Drücken Sie zum Triggern der Messungen Trigger, F1 (Groups).

Aktualisieren der Messung

  6. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Channel, F2 (Ch 2), Trigger.

  10. Klicken Sie in der Aktuelle-Eingabe-Symbolleiste auf den gewünschten Triggertyp.

    • Klicken Sie auf F2 (Single), wenn der Analysator nach jedem Trigger einen einzigen Wobbelzyklus ausführen soll.

    • Klicken Sie auf F1 (Groups), wenn wenn der Analysator nach jedem Trigger mehrere Wobbelzyklen ausführen soll.


Datenübertragung

Siehe auch...

Datenübertragungsgeschwindigkeit

Überblick

Konzepte

Wie erhöht man die
Datenübertragungsgeschwindigkeit?

Eine möglichst hohe Datenübertragungsgeschwindigkeit trägt auch zu einem möglichst hohen Gesamtdurchsatz bei .
Konzepte

Wie erhöht man die Datenübertragungsgeschwindigkeit?

Die Datenübertragungsgeschwindigkeit lässt sich auf verschiedene Weise erhöhen; am besten probieren Sie aus, welche dieser Methoden in der jeweiligen Anwendung die besten Ergebnisse bringt.

  • Verwenden Sie die Betriebsart "Single sweep" mode, um sicherzustellen, dass eine Messung abgeschlossen ist, bevor die Datenübertragung beginnt.

  • Übertragen Sie nur soviele Daten, wie tatsächlich erforderlich sind. Wenn beispielsweise bei einer Messkurve nur wenige Punkte interessieren, sollten Sie mit Segmentwobbelung arbeiten statt mit äquidistanten Frequenzpunkten. Wenn möglich, sollten Sie sich auf die Übertragung von Marker-Daten statt kompletter Messkurvendaten beschränken.

  • Wählen Sie das Datenformat REAL; wenn der Analysator durch SCPI-Befehle ferngesteuert wird, erzielen Sie mit diesem Format die größtmögliche Datenübertragungsgeschwindigkeit.

  • Verwenden Sie "SCPI über LAN" für Anwendungen, die mit Hilfe von SCPI-Programmen automatisiert werden.

  • Verwenden Sie COM-Programme zur Maximierung der Datenübertragungsgeschwindigkeit in Systemanwendungen. Siehe Datenübertragungszeit.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Verwendung der Betriebsart "Use the "Single Sweep Mode

Transfer Minimimum Amount of Data Using Segment Sweep

Verwendung der Betriebsart "Single Sweep"

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Sweep-Menü auf Trigger, Trigger....

  2. Klicken Sie unter Trigger SourceaufManual.

  3. Wählen Sie unter Channel Trigger State den Kanal für die Messung, deren Daten Sie übertragen möchten, und klicken Sie auf Continuous, OK.

Zum Aktualisieren der Messung

  4. Klicken Sie im System-Menü auf Keys, Trigger.

  5. Klicken Sie in der Aktuelle-Eingabe-Symbolleiste auf Single.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Channel, und wählen Sie dann mit den Softkeys F1, F2, F3 oder F4 den Kanal mit der Messung, deren Daten Sie übertragen möchten.

  2. Drücken Sie Trigger, F2 (Single).

Zum Aktualisieren der Messung in Kanal 2

  8. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Trigger, F4 (Restart).


Kalibrierung

Siehe auch...

Überblick über die Kalibrierung

Überblick

Konzepte

Wie wird eine Kalibrierung durchgeführt?

Kalibrierung ist ein Verfahren zur Verbesserung der Messgenauigkeit, bei dem systematische Messfehler durch Referenzmessungen an Kalibriernormalen ermittelt und bei nachfolgenden Messungen durch Anwendung entsprechender Korrekturfaktoren (Fehlerterme) rechnerisch korrigiert werden.

Konzepte

Wie wird eine Kalibrierung durchgeführt?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist Kalibrierung?

Warum ist Kalibrierung notwendig?

Unter welchen Umständen ist eine Kalibrierung erforderlich?

Was ist Kalibrierung?

  • Die Kalibrierung dient dazu, systematische Messfehler mit Hilfe eines mathematischen Fehlermodells rechnerisch zu korrigieren. Bei dem mathematischen Fehlermodell handelt es sich um eine Gleichung mit zahlreichen Termen, deren Werte mit Hilfe von Referenzmessungen an hochwertigen Kalibriernormalen (beispielsweise Kurzschluss-, Leerlauf-, Last- und Durchgangsnormal) bestimmt werden. Weitere Informationen über systematische Messfehler siehe unter Messfehler.

  • Je nach Anwendung und Genauigkeitsanforderungen können Sie zwischen verschiedenen Kalibrierverfahren wählen.

  • Die Genauigkeit der kalibrierten Messungen hängt von der Genauigkeit der verwendeten Kalibriernormale und von der Genauigkeit des (in der Kalibrier-Kit-Definitionsdatei beschriebenen) mathematischen Fehlermodells ab. Die Kalibrier-Kit-Definitionsdatei wird im Analysator gespeichert. Im Interesse einer optimalen Messgenauigkeit muss die Kalibrier-Kit-Definition mit dem verwendeten Kalibrier-Kit übereinstimmen.

  • Wenn Sie (beispielsweise für Messungen unter Verwendung eines Testadapters) selbstgebaute Kalibriernormale verwenden, müssen Sie diese charakterisieren und die Definitionen in eine benutzer-modifizierte Kalibrier-Kit-Definitionsdatei eingeben. Weitere Informationen über das Modifizieren von Kalibrier-Kit-Definitionsdateien siehe Kalibriernormale.

Weitere Informationen über Kalibrierverfahren und Prozeduren siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

Warum ist Kalibrierung notwendig?

  • Es ist prinzipiell unmöglich, eine perfekte Hardware zu bauen, die keinerlei F ehlerkorrektur erfordern würde. Wollte man die Genauigkeit der Mess-Hardware auch nur so weit steigern, dass in der Mehrzahl der Anwendungen keine Fehlerkorrektur erforderlich wäre, so würde auch dadurch schon die Hardware extrem teuer.

  • Die Genauigkeit der Netzwerkanalyse wird in hohem Maße durch Faktoren beeinflusst, die außerhalb des Netzwerkanalysators liegen. Kabel, Adapter und andere Komponenten der Messanordnung verursachen Amplituden- und Phasenfehler, welche die tatsächlichen Charakteristiken des Messobjekts verdecken können.

  • Für Messgeräteentwickler ist es immer wieder eine Herausforderung, die größtmögliche Hardware-Genauigkeit zu erzielen, die im vorgegebenen Kostenrahmen realisierbar ist. Kalibrierung ist dann das Mittel der Wahl zur weiteren Verbesserung der Messgenauigkeit.

Unter welchen Umständen ist eine Kalibrierung erforderlich?

  • Ihre Anwendung erfordert die größtmögliche Messgenauigkeit.

  • Sie verwenden Adapter auf einen anderen Steckverbindertyp oder eine andere Impedanz .

  • Das Messobjekt ist über ein oder mehrere Kabel am Analysator angeschlossen.

  • Sie führen Messungen über eine große Wobbelbandbreite oder an einem Bauteil mit großer elektrischer Länge durch.

  • Im Signalweg zwischen dem Analysator und dem Eingang oder Ausgang des Messobjekts befindet sich ein Abschwächer oder ähnliches Bauteil.

Falls bei Ihrer Messanordnung eine der obigen Bedingungen erfüllt ist, kann sich dies auf folgende Systemparameter negativ auswirken:

  • Amplitude am Eingang des Messobjekts

  • F requenzganggenauigkeit

  • R ichtverhältnis

  • Ü bersprechen (Isolation)

  • Quellenanpassung

  • L ast a npassung

Nachfolgend wird beschrieben, wie Sie eine Kalibrierung für Ihr Messobjekt durchführen.

  1. Schließen Sie das Messobjekt wie erforderlich an den Analysator an.

  2. Wählen Sie die für die Messung geeigneten Analysatoreinstellungen.

  3. Trennen Sie das Messobjekt vom Analysator ab und wählen mit Hilfe des Kalibrierungsassistenten ein Kalibrierverfahren und ein Kalibrier-Kit.

  4. Schließen Sie gemäß den Anweisungen des "Cal Wizard" die für das gewählte Kalibrierverfahren erforderlichen Kalibriernormale an, und führen Sie die Referenzmessungen durch.

    • Der Analysator berechnet aus den Ergebnissen der Referenzmessungen an den Kalibriernormalen die Fehlerterme.

    • Nach Abschluss der "Cal Wizard"-Prozeduren werden die Fehlerterme automatisch als Kalibrierdatensätze im internen Speicher des Analysators abgelegt. (Sie können diese Kalibrierdatensätze später wieder abrufen.)

  5. Schließen Sie das Messobjekt wieder an den Analysator an und führen Sie Ihre Messungen durch. Bei aktiver F ehlerkorrektur werden die Einflüsse der Fehlerterme auf die Messung(en) rechnerisch eliminiert.


Siehe auch...

Messfehler

Überblick

Driftfehler und
zufällige Fehler

Systematische
Fehler

Überwachung der
Fehlerterme

Ganz gleich, wie sorgfältig eine Messung durchgeführt wird – ein gewisses Maß an Ungenauigkeit lässt sich nicht vermeiden. Es hängt von den jeweiligen Anforderungen an die Messgenauigkeit ab, welche Messfehler noch tolerierbar sind und welche nicht. Beispiel:

  • Wenn Sie lediglich überprüfen möchten, ob ein Gerät überhaupt funktioniert, genügt ist eine relativ grobe Messung; in diesem Fall brauchen Sie sich über die Messgenauigkeit keine Gedanken zu machen.

  • Wenn Sie verifizieren möchten, ob ein Verstärker gerade noch innerhalb oder bereits außerhalb der Verstärkungsspezifikation liegt, müssen Sie der Messgenauigkeit große Beachtung schenken (und deshalb die Messfehler auf ein Minimum reduzieren).

Wenn Sie die Ursachen von Messfehlern kennen, können Sie die Messgenauigkeit gezielt verbessern. Klicken Sie auf die Schaltflächen, um Informationen über die beiden wichtigsten Fehlerarten erhalten und zu erfahren, wie Sie die Fehlerterme überwachen können.
Driftfehler und zufällige Fehler

Systematische Fehler

Überwachung der Fehlerterme

Driftfehler

  • Driftfehler sind Messfehler, die sich infolge allmählicher Änderungen von Messgeräte- oder Messaufbau-Eigenschaften nach einer Kalibrierung einschleichen.

  • Driftfehler sind hauptsächlich auf die Wärmeausdehnung von Kabeln im Testset und auf die nicht-perfekte Stabilität des Mikrowellenmischers zurückzuführen; sie lassen sich durch nochmalige (gegebenenfalls mehrfach wiederholte) Kalibrierung reduzieren.

  • Der Zeitraum, über den eine Kalibrierung genau bleibt, hängt davon ab, wie schnell die relevanten Parameter in der jeweiligen Messumgebung driften.

Sie können die Drift minimieren, indem Sie für eine stabile Umgebungstemperatur sorgen. Weitere Informationen siehe Stabilität der Messergebnisse.

Zufällige Fehler

Zufällige Fehler sind nicht vorhersagbar und können durch die F ehlerkorrektur nicht reduziert werden. Ihr Einfluss auf die Messgenauigkeit lässt sich jedoch durch verschiedene Maßnahmen reduzieren.

Die wichtigsten zufälligen Fehler sind:

Fehler durch das Eigenrauschen des Messgerätes

Fehler durch nicht-perfekte Wiederholgenauigkeit der Abschwächerschalter

Fehler durch nicht-perfekte Wiederholgenauigkeit von Steckverbindern

Fehler durch das Eigenrauschen des Messgerätes

Das Eigenrauschen wird durch zufällige Spannungs- oder Stromschwankungen in den Bauteilen des Analysators verursacht. Die wichtigsten dieser Effekte sind:

  • Das relativ schwache Breitband-Grundrauschen des Empfängers.

  • Das relativ starke Messkurvenrauschen aufgrund des Eigenrauschens und des Phasenrauschens des Lokaloszillators im Testset.

Sie können die rauschbedingten Messfehler durch eine oder mehrere der folgenden Maßnahmen reduzieren:

  • Erhöhen des Messignalpegels.

  • Verkleinern der ZF-Bandbreite.

  • Mittelung über mehrere Wobbelzyklen.

Fehler durch nicht-perfekte Wiederholgenauigkeit der Abschwächerschalter

  • Der Abschwächer vor dem HF-Ausgang des Analysators enthält mechanische Schalter.

  • Die Kontaktgabe dieser Schalter ist nicht immer gleichmäßig. Dies kann die Messgenauigkeit beeinträchtigen.

  • Sie können die Fehler durch die nicht-perfekte Wiederholgenauigkeit der Abschwächerschalter reduzieren, indem Sie bei kritischen Messungen auf ein Umschalten der Abschwächung verzichten.

Fehler durch nicht-perfekte Wiederholgenauigkeit von Steckverbindern

Steckverbinder können sich im Laufe der Zeit abnutzen; dadurch können sich deren elektrische Eigenschaften verschlechtern.Durch sorgfältige Behandlung der Steckverbinder können Sie die Fehler durch deren nicht-perfekte Wiederholgenauigkeit reduzieren. Siehe Kabel und Steckverbinder.

Systematische Fehler sind auf Unzulänglichkeiten im Analysator und in der Messanordnung zurückzuführen.

  • Diese Fehler sind reproduzierbar (und daher voraussagbar) und werden als zeit-invariant betrachtet.

  • Sie lassen sich im Zuge der Kalibrierung charakterisieren und bei den anschließenden Messungen rechnerisch reduzieren.

  • Sie lassen sich jedoch niemals vollständig beseitigen. Dies liegt daran, dass auch der Kalibrierungsprozess mit gewissen Restfehlern behaftet ist. Die systematischen Restfehler (nach erfolgter Kalibrierung) werden verursacht durch:

    • Unzulänglichkeiten der Kalibriernormale

    • Steckverbinder

    • Kabel

    • Analysatorinterne Unzulänglichkeiten

Bei Reflexionsmessungen entstehen folgende systematische Fehler:

Richtverhältnis

Quellenanpassung

Reflexions-Frequenzgang-Gleichlauffehler

Bei Transmissionsmessungen entstehen folgende systematische Fehler:

Isolation

Lastanpassung

Transmissions-Frequenzgang-Gleichlauffehler

Hinweis: Die Abbildungen zu den folgenden sechs systematischen Fehlern zeigen den relevanten Teil der Hardware in der Konfiguration für Vorwärts-Messungen. Für Rückwärts-Messungen wird durch einen internen Umschalter der Port 2 als Quelle und der Port 1 als Empfänger konfiguriert. Kanal 'A' wird zum Empfänger für das transmittierte Signal, Kanal 'B' zum Empfänger für das reflektierte Signal, und Kanal 'R2' zum Referenzempfänger. Diese sechs systematischen Fehler pro Messrichtung ergeben für Zweitor-Bauteil insgesamt 12 systematische Messfehler.

Richtverhältnisfehler

Alle Netzwerkanalysatoren verwenden für Reflexionsmessungen entweder einen Richtkoppler oder eine Reflexionsmessbrücke.

Bei einem idealen Richtkoppler erscheint im Kanal 'A' ausschließlich das vom Messobjekt DUT reflektierte Signal. In der Realität lässt sich ein geringfügiges Einstreuen des einfallenden Signals in den Kanal 'A' nicht vermeiden.

Dieser Messfehler wird als R ichtverhältnisfehler bezeichnet. Dieser Fehler lässt sich durch Kalibrierung verringern.

Wie ermittelt und reduziert der Analysator den Richtverhältnisfehler?

  1. Während der Kalibrierung, wird ein Lastnormal an den Port 1 angeschlossen. Es wird vorausgesetzt, dass diese Last keine Reflexionen hervorruft.

  2. Der Kanal 'A' misst in diesem Falle das koppler-interne Übersprechen des einfallenden Signals, also den Richtverhältnisfehler.

  3. Bei nachfolgenden Reflexionsmessungen wird der Richtverhältnisfehler von den Messergebnissen subtrahiert.

Isolationsfehler

Im Idealfall misst der Kanal 'B' ausschließlich das durch vom Messobjekt durchgelassene (transmittiert) Signal.

In der Realität lassen sich geringfügige Signaleinstreuungen (über diverse Wege) in den Kanal 'B' nicht vermeiden.

Diese Einstreuungen, die auch als Ü bersprechen bezeichnet werden, stellen den Isolationsfehler dar; dieser kann vom Analysator im Zuge der Kalibrierung gemessen und anschließend rechnerisch reduziert werden.

Wie ermittelt und reduziert der Analysator den Isolationsfehler?

  1. Während der Kalibrierung werden Lastnormale an die Ports 1 und 2 angeschlossen.

  2. Das dabei im Kanal 'B' gemessene Übersprechsignal ist der Isolationsfehler.

  3. Bei nachfolgenden Transmissionsmessungen wird der Isolationsfehler von den Messergebnissen subtrahiert.

Quellenanpassungsfehler

Im Idealfall misst der Kanal 'A' bei Reflexionsmessungen das gesamte vom Messobjekt reflektierte Signal.

In der Realität wird ein Teil der vom Messobjekt reflektierten Signalleistung von Port 1 zurückreflektiert und nicht im Kanal 'A' gemessen.

Der daraus resultierende Messfehler wird als Quellenanpassungsfehler bezeichnet. Auch dieser Fehler lässt sich durch Kalibrierung reduzieren.

Wie ermittelt und reduziert der Analysator den Quellenanpassungsfehler?

  1. Während der Kalibrierung wird ein Kurzschlussnormal an Port 1 angeschlossen. Dieses Kurzschlussnormal ruft eine Reflexion bekannter Größe hervor, die im Kanal 'A' gemessen und analysatorintern gespeichert wird.

  2. Anschließend wird ein Leerlaufnormal an Port 1 angeschlossen. Dieses Leerlaufnormal ruft eine Reflexion bekannter Größe hervor, die im Kanal 'A' gemessen und analysatorintern gespeichert wird.

  3. Der Analysator vergleicht die beiden gespeicherten Signale miteinander. Aus dem Unterschied zwischen den beiden Signalen berechnet der Analysator den Quellenanpassungsfehler.

  4. Bei nachfolgenden Reflexions- und Transmissionsmessungen wird der Quellenanpassungsfehler von den Messergebnissen subtrahiert.

Lastanpassungsfehler

Im Idealfall misst der Kanal 'B' bei Transmissionsmessungen das gesamte vom Messobjekt (DUT) durchgelassene Signal.

In der Realität wird ein Teil der Signalleistung vom Port 2 zurückreflektiert und nicht im Kanal 'B' gemessen.

Dieser Fehler wird als L astanpassung sfehler bezeichnet; auch dieser Fehler kann vom Analysator im Zuge der Kalibrierung ermittelt und anschließend rechnerisch reduziert werden.

Wie ermittelt und reduziert der Analysator den Lastanpassungsfehler?

  1. Port 1 und Port 2 werden direkt miteinander verbunden und ergeben dadurch eine perfekte Durchgangsverbindung mit der elektrischen Länge Null. (Falls dies nicht möglich ist, werden sie über einen Durchgangsadapter miteinander verbunden.) Dadurch ergibt sich an Port 2 ein einfallendes Signal mit bekannter Leistung.

  2. Im Kanal 'A' wird das von Port 2 rückreflektierte Signal gemessen.

  3. Der resultierende Lastanpassungsfehler wird bei anschließenden Transmissions- und Reflexionsmessungen subtrahiert.

Reflexions-Frequenzgang-Gleichlauffehler

Bei Reflexionsmessungen wird das Signal im Kanal 'A' (Reflexionskanal) mit dem Signal im Kanal 'R1' (Referenzkanal) verglichen. Es handelt sich hierbei um eine Verhältnismessung "A zu R1" (A/R1).

Bei einer idealen Reflexionsmessung hätten die Kanäle 'A' und 'R1' den gleichen Frequenzgang.

In der Realität ist dies nicht der Fall; daraus resultiert ein Reflexions- Frequenzgang-Gleichlauffehler. Dieser ist gleich der vektoriellen Summe aller Messfehler mit frequenzabhängiger Amplitude und Phase. Hierin sind die durch folgende Einflüsse hervorgerufenen Messfehler enthalten:

    • Bauteile zur Signaltrennung

    • Messkabel

    • Adapter

    • Unterschiede zwischen dem Referenzkanal und dem Messsignalkanal

Der Reflexions-Frequenzgang-Gleichlauffehler lässt sich durch Kalibrierung reduzieren.

Wie bestimmt und reduziert der Analysator den Reflexions-Frequenzgang-Gleichlauffehler?

  1. Während der Kalibrierung wird ein Kurzschlussnormal an Port 1 angeschlossen. Dieses Kurzschlussnormal ruft eine Reflexion bekannter Größe hervor, die im Kanal 'A' gemessen und analysatorintern gespeichert wird.

  2. Anschließend wird ein Leerlaufnormal an Port 1 angeschlossen. Dieses Leerlaufnormal ruft eine Reflexion bekannter Größe hervor, die im Kanal 'A' gemessen und analysatorintern gespeichert wird.

  3. Der Analysator mittelt die beiden beiden gespeicherten Kanal-'A'-Signale.

  4. Der gemittelte Kanal-'A'-Frequenzgang wird mit dem im Kanal 'R1' gemessenen Referenzsignal verglichen.

  5. Der Unterschied zwischen dem Frequenzgang des Kanal-'A'-Empfängers und dem des Kanal-'R1'-Empfängers ist der Reflexions-Frequenzgang-Gleichlauffehler (siehe folgendes Diagram). Bei nachfolgenden Messungen am Messobjekt wird der Reflexions-Frequenzgang-Gleichlauffehler von den Messergebnissen subtrahiert.

Hinweis: Bei der Reflexionsfrequenzgang-Kalibrierung wird nur ein einziges Kalibriernormal (Leerlauf oder Kurzschluss) gemessen; daher wird bei der F ehlerkorrektur auch nur dessen Fehlerbeitrag berücksichtigt.

Transmissions-Frequenzgang-Gleichlauffehler

Bei Transmissionsmessungen wird das Signal im Kanal 'B' (Transmissionskanal) mit dem Signal im Kanal 'R1' (Referenzkanal) verglichen. Es handelt sich hierbei um eine Verhältnismessung "B zu R1" (B/R1).

Bei einer idealen Transmissionsmessung hätten die Kanäle 'B' und 'R1' den gleichen Frequenzgang.

In der Realität ist dies nicht der Fall; daraus resultiert ein Transmissions-Frequenzgang-Gleichlauffehler. Dieser ist gleich der vektoriellen Summe aller Messfehler mit frequenzabhängiger Amplitude und Phase. Hierin sind die durch folgende Einflüsse hervorgerufenen Messfehler enthalten:

    • Bauteile zur Signaltrennung

    • Messkabel

    • Adapter

    • Unterschiede zwischen dem Referenzkanal und dem Messsignalkanal

Der Transmissions-Frequenzgang-Gleichlauffehler lässt sich durch Kalibrierung reduzieren.

Wie bestimmt und reduziert der Analysator den Transmissions-Frequenzgang-Gleichlauffehler?

  1. Bei der Kalibrierung werden die Messanschlüsse Port 1 und Port 2 direkt miteinander verbunden und ergeben dadurch eine perfekte Durchgangsverbindung mit der elektrischen Länge null. (Falls dies nicht möglich ist, werden sie über einen Durchgangsadapter miteinander verbunden.) Dadurch ergibt sich an Port 2 ein einfallendes Signal mit bekannter Leistung.

  2. Es werden die Signale in den Kanälen 'B' und 'R1' gemessen und abgespeichert.

  3. Der Analysator vergleicht die Signale in den Kanälen 'R1' und 'B'.

  4. Der Unterschied zwischen dem Frequenzgang des Kanal-'B'-Empfängers und dem des Kanal-'R1'-Empfängers ist der Transmissions-Frequenzgang-Gleichlauffehler (siehe folgendes Diagram). Bei nachfolgenden Messungen wird der Transmissions-Frequenzgang-Gleichlauffehler von den Messergebnissen subtrahiert.

.

Der Analysator speichert die gemessenen systematischen Messfehler als Fehlerterme ab. Durch Überwachen dieser Fehlerterme können Sie feststellen, ob Ihr Analysator noch in einem guten Zustand ist und die volle Messgenauigkeit bietet.

Wenn Sie die Fehlerterme ausdrucken oder abspeichern, können Sie die aktuellen Fehlerterme periodisch mit den Fehlertermen vergleichen, die früher mit dem gleichen Messgerät und dem gleichen Kalibrier-Kit ermittelt wurden. Falls keine früheren Fehlerterme verfügbar sind, können Sie die aktuellen Fehlerterme mit typischen Werten vergleichen. Siehe hierzu Kapitel 4, "Error Terms", des "Service Guide".

  • Bei einem stabilen System sollten die Fehlerterme über einen Zeitraum von sechs Monaten reproduzierbar sein.

  • Wenn sich bei gleichbleibenden Frequenzbereich-, Leistungs- und Empfängereinstellungen die Fehlerterme plötzlich ändern, kann dies auf defekte Systemkomponenten hindeuten. Informationen darüber, was in diesem Fall zu tun ist, finden Sie im Kapitel 4 des "Service Guide" unter "Error Terms".

  • Allmähliche, geringfügige Änderungen der Fehlerterme deuten oft auf Drift oder auf einen Verschleiß von Steckverbindern und Kabeln hin. Oft genügt es, einfach nur die Steckverbinder zu reinigen oder die Kabel genau zu inspizieren, um das Problem zu beheben. Durch Anklicken der Schaltflächen gelangen Sie zu einer Beschreibung der Prozeduren zur Bestimmung der Fehlerterme.

Nachfolgend wird beschrieben, wie Sie Fehlerterme abfragen oder abspeichern können:
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Führen Sie ein vollständige SOLT 2-Port Kalibrierung durch. Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung

  2. Zeigen Sie im System-Menü auf Service und dann auf Utilities. Klicken Sie auf Evaluate Error Corr Data .

  3. Wählen Sie in dem Dialogfenster einen der Fehlerterme von Port 1 oder Port 2.

    • Klicken Sie auf Apply: Die Fehlerterm-Messkurve bleibt weiterhin sichtbar, und das Dialogfenster bleibt geöffnet, sodass Sie eine weitere Auswahl treffen können.

    • Klicken Sie auf OK: Das Dialogfenster schließt sich; die Fehlerterm-Messkurve bleibt weiterhin sichtbar.

  4. Klicken Sie im Scale-Menü auf Autoscale. um die Messkurve im optimalen Maßstab darzustellen.

  5. Analysieren Sie die Details der Fehlerterm-Messkurve mit Hilfe der Marker.

  6. Falls Sie einen subtilen Fehler oder eine subtile Verschlechterung der Genauigkeit vermuten, sollten Sie die Fehlerterme mit früheren Fehlertermen vergleichen, die mit dem gleichen Messgerät und dem gleichen Kalibrier-Kit ermittelt wurden. Ein solcher Vergleich liefert die genauesten Hinweise auf die Problemursache. Falls keine früheren Fehlerterme verfügbar sind, oder falls Sie an weiteren Informationen interessiert sind, siehe Kapitel 4, "Error Terms," des "Service Guide".

Tastenprozedur

  1. Führen Sie ein vollständige SOLT 2-Port Kalibrierung durch. Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

  2. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  3. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zum System-Menü zu gelangen.

  4. Drücken Sie die Pfeil-unten-Taste, um zum Service-Menü zu gelangen. Drücken Sie Click .

  5. Drücken Sie die Pfeil-unten-Taste, um zum Utilities-Menü zu gelangen. Drücken Sie Click .

  6. Evaluate Error Corr Data ist standardmäßig gewählt. Drücken Sie Click .

  7. Wählen Sie durch Drücken der Tab-rechts-Taste den Teil Port 1 Error Terms oder Port 2 Error Terms des Dialogfensters. Wählen Sie durch Drücken der Pfeil-oben- oder Pfeil-unten-Taste einen der Fehlerterme von Port 1 oder Port 2.

    • Wählen Sie durch Drücken der Tab-rechts-Taste Apply. Drücken Sie Click. Die Fehlerterm-Messkurve bleibt weiterhin sichtbar, und das Dialogfenster bleibt geöffnet, sodass Sie eine weitere Auswahl treffen können.

    • Wählen Sie durch Drücken der Tab-rechts-Taste OK. Drücken Sie Click. Das Dialogfenster schließt sich; die Fehlerterm-Messkurve bleibt weiterhin sichtbar.

  8. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  9. Wählen Sie durch Drücken der Tab-rechts-Taste Scale.

  10. Autoscale ist standardmäßig aktiviert. Drücken Sie Click, um die Messkurve im optimalen Maßstab darzustellen.

  11. Analysieren Sie die Details der Fehlerterm-Messkurve mit Hilfe der Marker.

  12. Falls Sie einen subtilen Fehler oder eine subtile Verschlechterung der Genauigkeit vermuten, sollten Sie die Fehlerterme mit früheren Fehlertermen vergleichen, die mit dem gleichen Messgerät und dem gleichen Kalibrier-Kit ermittelt wurden. Ein solcher Vergleich liefert die genauesten Hinweise auf die Problemursache. Falls keine früheren Fehlerterme verfügbar sind, oder falls Sie an weiteren Informationen interessiert sind, siehe Kapitel 4, "Error Terms," des "Service Guide".

Ferngesteuertes Abfragen/Abspeichern von Fehlertermen

Die SCPI- und COM-Befehle zum Abfragen und Abspeichern von Fehlertermen finden Sie unter Messdaten / Fehlerterme.


Siehe auch...

Kalibriernormale

Überblick

Konzepte

Wie ändert man eine Kalibriernormal-Definition?

Bei der Kalibrierung führt der Analysator Messungen an Kalibriernormalen durch und vergleicht deren Ergebnisse mathematisch mit "idealen Modellen" dieser Normale. Aus den Differenzen werden Fehlerterme berechnet, die bei den nachfolgenden Messungen zur F ehlerkorrektur herangezogen werden..
Konzepte

Wie ändert man eine Kalibriernormal-Definition?

Für jedes Kalibriernormal gibt es eine präzise Definition, die Parameter wie elektrische Länge, Impedanz oder Dämpfung beschreibt. Diese Definitionen sind im Analysator gespeichert und werden zur Berechnung der Fehlerterme herangezogen.
Kalibrier-Kits

Änderung der Kalibrier-Kit-Definition

Kalibriernormale

"Modify Calibration Kit"-Menü

Elektronische Kalibrierung (ECal)

Kalibrier-Kits

Ein Kalibrier-Kit enthält die für die Referenzmessungen im Rahmen der Kalibrierung erforderlichen Normale. Agilent Technologies bietet diverse Kalibrier-Kits mit unterschiedlichen Steckverbindertypen an. Jedes dieser Kalibrier-Kits enthält typischerweise:

  • ein Kurzschlussnormal

  • ein Leerlaufnormal

  • eine impedanzangepasste Last

Definitionen

  • Unter einem "Kalibriernormal" ist ein Bauteil mit wohldefinierten physikalischen Eigenschaften zu verstehen, das dazu dient, systematische Fehler zu bestimmen. Innerhalb eines Kalibrier-Kits sind die Kalibriernormale fortlaufend von 1 bis 8 nummeriert. Bei dem 3.5 mm-Kalibrier-Kit 85033E, beispielsweise, ist das Kalibriernormal 1 ein Kurzschlussnormal.

  • Der "Kalibriernormaltyp" beschreibt die Form oder Struktur des mathematischen Modells, das für das betreffende Kalibriernormal anzuwenden ist. Es gibt vier verschiedene Kalibriernormaltypen:

    • Kurzschlussnormal

    • Leerlaufnormal

    • Lastnormal

    • Durchgangsnormal

  • Das Kalibriernormal 1 ist (bei dem 3.5 mm-Kalibrier-Kit) vom Typ Kurzschlussnormal.

  • Die "Charakteristiken" eines Kalibriernormals sind die physikalischen Kenngrößen der in dem gewählten Modell verwendeten Normale.

Bei den meisten Kalibrier-Kits, deren Normale über Adapter an die Analysator-Ports angeschlossen werden müssen, sind die Adapter phasen-gepaart. Sie können auch Kalibriernormale verwenden, die nicht zu einem Kalibrier-Kit gehören. In diesem Fall müssen Sie ein benutzerdefiniertes Kalibrier-Kit erstellen und darin die Charakteristiken Ihrer Kalibriernormale spezifizieren; siehe unter "Änderung der Kalibrier-Kit-Definition" weiter unten.

Eine Liste der von Agilent Technologies angebotenen Kalibrier-Kits für diesen Analysator (einschließlich solcher, deren Definitionen im Analysator gespeichert sind) finden Sie unter Sonderzubehör .

Änderung der Kalibrier-Kit-Definition

In folgenden Fällen müssen Sie ein benutzerdefiniertes Kalibrier-Kit erstellen:

  • Der Steckverbindertyp Ihres Analysators ist zwar im "Cal Kit"-Menü aufgelistet, aber die Charakteristiken Ihrer Kalibriernormale (beispielsweise des Kurzschlussnormals) weichen von den im Analysator gespeicherten Kalibrier-Kit-Definitionen ab.

  • Der Steckverbindertyp Ihres Analysator entspricht keiner der im Analysator gespeicherten Kalibrier-Kit-Definitionen.

  • Sie führen eine Kalibrierung für ein nicht direkt anschließbares Bauteil durch. Siehe Genaue Kalibrierung.

Zum Erstellen eines benutzerdefinierten Kalibrier-Kits ändern Sie eine der standardmäßigen Kalibrier-Kit-Definitionen wie gewünscht ab und speichern sie unter einem anderen Namen als benutzerdefiniertes Kalibrier-Kit ab. Die ursprüngliche Kalibrier-Kit-Definition bleibt dabei erhalten.

Hinweis: Dies ist keine detaillierte Anleitung zur Modifikation von Kalibrier-Kit-Definitionen. Weitere Informationen hierzu finden Sie im Internet unter www.agilent.com/find/assist; suchen Sie nach der Product Note 8510-5A, "Specifying Calibration Standards for the HP 8510 Network Analyzer," (Agilent-Teilenummer 5956-4352).

Wenn Sie ein Kalibrier-Kit erstellen oder modifizieren möchten, gehen Sie folgendermaßen vor:

  1. Wählen Sie eines der vordefinierten Kalibrier-Kits.

  2. Modifizieren Sie das Kalibrier-Kit im "Modify Calibration Kit"-Menü.

Kalibriernor********male

Wählen Sie zunächst ein Kalibrierungsverfahren, das Ihren Genauigkeitsanforderungen genügt. (Eine Übersicht über die verfügbaren Kalibrierverfahren finden Sie unter Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.) Von dieser Entscheidung hängt es ab, welche Kalibriernormale Sie zur Durchführung der Kalibrierung benötigen.

Zur Kalibrierung von Koaxialsystemen werden häufig folgende Kalibriernormale verwendet:

  • Kurzschlussnormal mit der elektrischen Länge Null

  • Geschirmtes Leerlaufnormal

  • Systemimpedanz-Lastnormal (derzeit unterstützt der Analysator keine Gleitlasten oder Offset-Lasten)

Hinweis: Bei dem "Durchgangsnormal" handelt es sich üblicherweise nicht um ein physisches Kalibriernormal, sondern um eine direkte Verbindung (mit der elektrischen Länge null) der beiden Messanschlüsse. Weitere Informationen über Durchgangsnormale finden Sie unter "Genaue Kalibrierung".

Die verwendeten Kalibriernormale müssen hinsichtlich des Mediums (beispielsweise Koaxialkabel, Hohlleiter oder Microstrip) dem späteren Messobjekt entsprechen. Sie können:

  • Kalibriernormale kaufen

  • Kalibriernormale selbst herstellen

  • Vorhandene Kalibriernormale modifizieren

Unabhängig davon, welche dieser Möglichkeiten Sie wählen, sollten Sie darauf achten, dass Ihre Kalibriernormale folgenden Anforderungen genügen:

  • Exakt definierter Frequenzgang, reproduzierbar und temperaturunabhängig.

  • Deutliche Impedanzunterschiede zwischen den verschiedenen Normalen. Beispiel:

    • Ein Kurzschlussnormal mit der elektrischen Länge null verursacht im Vergleich zu einem geschirmten Leerlaufnormal eine Phasenverschiebung von 180°.

    • Eine präzise impedanzangepasste Last verursacht im Vergleich zu einem Kurzschluss- oder Leerlaufnormal eine Amplitudendifferenz von 40 bis 50 dB.

  • Weiter Frequenzbereich (in Relation zu dem Frequenzbereich, über den die Messungen durchgeführt werden).

"Modify Calibration Kit"-Menü

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Bereiche kennenzulernen:

Der Block "Calibration Kit" enthält folgende Felder:

  • Zehn Cal Kit ID-Nummern zur Auswahl (siehe Tabelle weiter unten):

    • Unter den ID-Nummern 1 bis 6 sind vordefinierte Kalibrier-Kit-Definitionen gespeichert. Wenn Sie diese Definitionen später möglicherweise einmal benötigen, dürfen Sie sie nicht modifizieren.

    • Unter den ID-Nummern 7 bis 10 sind benutzerdefinierte Kalibrier-Kit-Definitionen gespeichert. Sie können ein vordefiniertes Kalibrier-Kit je nach Bedarf modifizieren und dann als benutzerdefiniertes Kalibrier-Kit abspeichern. Die ursprüngliche, vordefinierte Kalibrier-Kit-Definition bleibt dabei erhalten.

  • "Cal Kit Name". Dies ist der Name des Kalibrier-Kits. (Diese Information können Sie ändern).

  • Restore Default Kit. Durch Anklicken dieser Schaltfläche können Sie dem gewählten Kalibrier-Kit wieder die vordefinierten Standardwerte zuweisen.

  • Restore ALL Default Kits. Durch Anklicken dieser Schaltfläche können Sie allen Kalibrier-Kits wieder die vordefinierten Standardwerte zuweisen.
Kit ID | Port 1 | Port 2 | "Cal Kit Name"
1 | Type-N (f) | Type-N (m) | Type-N Model 85032F
2 | 3.5 mm | 3.5 mm | 3.5 mm Model 85033E
3 | Type-N (f) | Type-N (m) | Type-N Model 85032B
4 | 3.5 mm | 3.5 mm | 3.5 mm Model 85033D
5 | 7-16 | 7-16 | 7-16 Model 85038A
6 | TRL 3.5 mm | TRL 3.5 mm | TRL 3.5 mm Model 85052C
7 | Type-N (f) | Type-N (m) | User Cal Kit 7
8 | Type-N (f) | Type-N (m) | User Cal Kit 8
9 | Type-N (f) | Type-N (m) | User Cal Kit 9
10 | Type-N (f) | Type-N (m) | User Cal Kit 10

Der Block "Assign Standards to Ports" enthält folgende Felder:

  • Port 1. Dies ist der Steckverbindertyp für Port 2. (Diesen Eintrag können Sie ändern).

  • Port 2. Dies ist der Steckverbindertyp für Port 2. (Diesen Eintrag können Sie ändern).

  • Acht Klassen (je vier für jeden Port) für die Zuordnung der Kalibriernormale:
Reflexionsklassen (sechs) | Transmissionsklassen (zwei)
S11A (Leerlauf - #8) | S21T (Durchgang Länge Null - #4)
S11B (Kurzschluss - #7) | S12T (Durchgang Länge Null - #4)
S11C (Last - #3) |
S22A (Leerlauf - #2) |
S22B (Kurzschluss - #1) |
S22C (Last - #3) |

Hinweis: Im obigen Beispiel wurden sämtlichen Klassen Kalibriernormale mit Type-N-Steckverbinder zugeordnet.

Die Kalibrierungsklassen bestimmen darüber, welche Kalibriernormale für welche Fehlerterm-Berechnungen verwendet werden. Die Klassen A, B und C werden zur Berechnung folgender Fehler verwendet:

  • Richtverhältnis (S11C, S22C)

  • Quellenanpassung (S11A, S11B, S22A, S22B)

  • Reflexions-Frequenzgang-Gleichlauffehler (S11A, S11B, S22A, S22B)

Die "T"-Klassen werden zur Berechnung der folgenden Fehler herangezogen:

  • Transmissions-Frequenzgang-Gleichlauffehler (S21T, S12T)

  • Last anpassung (S21T, S12T)

Jeder der acht Kalibrierungsklassen muss ein Kalibriernormal zugeordnet sein. Die Kalibriernormale in den Kalibrier-Kits sind standardmäßig folgendermaßen nummeriert:

1. Kurzschluss (männlich) | 5. Durchgang (kundenspezifischer Adapter)
2. Leerlauf (männlich) | 6. Last für unteres Frequenzband
3. Breitband-Last | 7. Kurzschluss (weiblich)
4. Durchgang (Länge Null) | 8. Leerlauf (weiblich)

Der Block "Modify Standard Definition" enthält die folgenden, für eine vollständige Definition erforderlichen Felder:

  • Standard number – Kalibriernormalnummer (1 bis 8)

  • Minimale Frequenz

  • Maximale Frequenz

  • ZO (Impedanz)

  • Laufzeit

  • Dämpfung

  • Type – Typ (Leerlauf, Kurzschluss, Last, Durchgang)

  • Character – Medium (Koax, Hohlleiter)

  • Bezeichnung

  • Kapazitätswerte (C0, C1, C2, C3) – nur zur Charakterisierung von Leerlaufnormalen benötigt.

  • Induktivitätswerte (L0, L1, L2, L3) – nur zur Charakterisierung von Kurzschlussnormalen benötigt.

Die Kalibrier-Kit-Definitionen beschreiben die elektrischen Charakteristiken der gewählten Kalibriernormale. Diese elektrischen Charakteristiken können auf zweierlei Weise bestimmt werden:

  • Berechnung auf Grundlage der mechanischen Abmessungen und Materialeigenschaften des jeweiligen Kalibriernormals.

  • Messung mit Hilfe eines kalibrierten Netzwerkanalysators.

Charakteristiken

  • Z0

    • Impedanz des Offsets zwischen dem zu definierenden Kalibriernormal und der tatsächlichen Messebene.

    • Dieser Wert ist normalerweise gleich der Systemimpedanz.

  • Laufzeit

    • Dies ist das Äquivalent zu einem homogenen Wellenleiter bestimmter Länge zwischen dem zu definierenden Kalibriernormal und der tatsächlichen Messebene.

    • Für Leerlauf-, Kurzschluss- und Lastnormale ist die Signallaufzeit (in Sekunden, einfacher Signalweg) von der Messebene bis zum Kalibriernormal einzugeben.

    • Für Durchgangsnormale ist die Laufzeit (in Sekunden, einfacher Signalweg) zwischen den Messebenen einzugeben.

    • Die Laufzeit kann gemessen oder berechnet werden (Laufzeit = mechanische Länge des Kalibriernormals dividiert durch den Ausbreitungsgeschwindigkeitsfaktor).

VORSICHT: Wenn zwei Ports während der Kalibrierung über einen Durchgangsadapter miteinander verbunden werden, müssen die Kalibrier-Kit-Definitionen für diese beiden Ports modifiziert werden; für beide Ports ist der Laufzeitwert des Durchgangsadapters einzugeben.

  • Dämpfung

    • Dieser Wert spezifiziert den Energieverlust infolge des Skin-Effekts entlang eines Signalweges in einem Koaxialkabel.

    • Der Dämpfungswert ist in Ohm/Sekunden einzugeben, bezogen auf eine Frequenz von 1 GHz.

    • In vielen Anwendungen kann der Dämpfungswert ohne signifikanten Messgenauigkeitsverlust als Null angenommen werden.

    • Sie können die Dämpfung Ihres Kalibriernormals folgendermaßen berechnen: Messen Sie die Laufzeit in Sekunden und die Dämpfung in dB bei 1 GHz. Setzen Sie diese Werte dann in die folgende Gleichung ein:

  • C0, C1, C2, C3

    • Ein Kurzschlussnormal weist bei hohen Frequenzen nur selten perfekte Reflexionscharakteristiken auf, weil Restinduktivitäten eine frequenzabhängige Phasenverschiebung verursachen. Diese Effekte lassen sich nicht eliminieren; der vom Analysator angewandte Algorithmus verwendet jedoch ein Leerlaufkapazitätsmodell. Bei diesem Modell handelt es sich um ein Polynom dritten Grades (als Funktion der Frequenz) mit benutzerdefinierbaren Koeffizienten.

    • Die Gleichung für das Kapazitätsmodell lautet:

    • C = (C0) + (C1 x F) + (C2 x F²) + (C3 x F³)

    • (F ist die Messfrequenz).

    • Die Terme dieser Gleichung werden beim Spezifizieren des Leerlaufnormals definiert:

      • C0 ist der konstante Term des Polynoms dritten Grades; dieser Wert ist in Farad einzugeben.

      • C1 ist in F/Hz (Farad/Hz) einzugeben.

      • C2 ist in F/Hz²einzugeben.

      • C3 ist in F/Hz³ einzugeben.

  • L0, L1, L2, L3

    • Ein Kurzschlussnormal weist bei hohen Frequenzen nur selten perfekte Reflexionscharakteristiken auf, weil Restinduktivitäten eine frequenzabhängige Phasenverschiebung verursachen. Diese Effekte lassen sich nicht eliminieren; der vom Analysator angewandte Algorithmus verwendet jedoch ein Kurzschlussinduktivitätsmodell. Bei diesem Modell handelt es sich um ein Polynom dritten Grades (als Funktion der Frequenz) mit benutzerdefinierbaren Koeffizienten.

    • Die Gleichung für das Induktivitätsmodell lautet:

    • L = (L0) + (L1 x F) + (L2 x F²) + (L3 x F³)

    • (F ist die Messfrequenz).

    • Die Terme dieser Gleichung werden beim Spezifizieren des Kurzschlussnormals definiert:

      • L0 ist der konstante Term des Polynoms dritten Grades; dieser Wert ist in Henry einzugeben.

      • L1 ist in H/Hz (Henry/Hz) einzugeben.

      • L2 ist in H/Hz² einzugeben.

      • L3 ist in H/Hz³ einzugeben.

Wenn Sie die Kalibriernormale definiert haben, geben Sie sie anschließend in die entsprechenden Felder des Dialogfensters ein.

Bei den meisten Kalibrier-Kits werden für männliche und weibliche Kurzschluss-, Leerlauf- und Lastnormale die gleichen Definitionen verwendet.

Bei den meisten Kalibrier-Kits ist das "Durchgangsnormal" (normalerweise Standard Nummer 4) als ein Durchgang der elektrischen Länge null definiert. Laufzeit und Dämpfung sind in diesem Fall Null. Das bedeutet, dass es kein physisches Durchgangsnormal gibt. Bei der Kalibrierung werden die beiden Messanschlüsse direkt miteinander verbunden. Weitere Informationen hierzu siehe unter Genaue Kalibrierung.

Hinweis: Die Messgenauigkeit ist direkt davon abhängig, wie genau die Kalibriernormale mit der jeweiligen Definition übereinstimmen. Wenn Ihre Kalibriernormale beschädigt oder abgenutzt sind, leidet darunter die Messgenauigkeit.

Elektronische Kalibrierung (ECal)

  • ECal ist eine vollelektronische Kalibrierlösung auf der Basis von Halbleiterschaltern.

    • Mit ECal lassen sich 1-Tor- (Reflexions-) und vollständige 2-Tor-Kalibrierungen schnell und einfach durchführen.

    • Die elektronische Kalibrierung ist weniger bedienungsfehleranfällig.

    • Die im Kalibriermodul fest installierten Kalibriernormale verschleißen nicht, weil die Signalpfad-Umschaltung durch PIN-Dioden- oder FET-Schalter erfolgt.

  • Die ECal-Module werden mit Hilfe eines TRL-kalibrierten Netzwerkanalysators charakterisiert.

  • Die ECal-Kalibrierung ist nicht ganz so genau wie eine präzise TRL-Kalibrierung.

Weitere Informationen hierzu erhalten Sie durch Ihren Agilent Vertriebsbeauftragten.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zum Modifizieren einer Kalibrier-Kit-Definition.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Calibration-Menü auf Advanced Modify Cal Kit..

  2. Klicken Sie auf das Feld Cal Kit ID im Block Calibration Kit des Dialogfensters. Geben Sie die gewünschte Kalibrier-Kit-Identifikationsnummer ein oder wählen Sie diesen Wert in der Auswahlliste, die beim Anklicken des Pfeils erscheint.

    • Wenn Sie die vordefinierten Standardwerte für den gewählten Kalibrier-Kit wiederherstellen möchten, klicken Sie auf die Schaltfläche Restore Default Kit .

    • Durch Anklicken der Schaltfläche Restore ALL Default Kits können Sie die vordefinierten Standardwerte für sämtliche Kalibrier-Kits wiederherstellen.

  3. Ändern Sie in dem Feld Cal Kit Name den vordefinierten Kalibrier-Kit-Namen wie gewünscht ab.

Zuordnung der Kalibriernormale zu den Ports

  1. Klicken Sie auf das Feld Port 1 im Block Assign Standards to Ports des Dialogfensters. Spezifizieren Sie den Steckverbindertyp für diesen Port.

  2. Spezifizieren Sie im Bereich Port 2 den Steckverbindertyp für diesen Port.

  3. Geben Sie in jedes der acht Kalibrierklassenfelder (beispielsweise S11A) eine Kalibriernormalnummer ein, oder wählen Sie aus der Liste, die nach Anklicken des Pfeils erscheint, die gewünschte Nummer.

Modifikation der Kalibriernormal-Definition

  1. Klicken Sie auf das Feld Standard No im Block Modify Standard Definition des Dialogfensters. Geben Sie die gewünschte Kalibriernormalnummer ein, oder wählen Sie aus der Liste, die nach Anklicken des Pfeils erscheint, die gewünschte Nummer.

  2. Geben Sie für die im vorigen Schritt gewählte Kalibriernormalnummer alle erforderlichen Werte ein: "Minimum Frequency" (minimale Frequenz), "Maximum Frequency" (maximale Frequenz), "Z0" (Systemimpedanz), "Delay" (Laufzeit), "Loss" (Dämpfung) usw. Geben Sie den jeweiligen Wert direkt in das betreffende Feld ein, oder wählen Sie aus der Liste, die nach Anklicken des Pfeils erscheint, den gewünschten Wert.

  3. Wiederholen Sie die Schritte 1 und 2 für jede Kalibriernormalnummer.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zum Calibration-Menü zu gelangen.

    1. Drücken Sie die Pfeil-unten-Taste, um zum Advanced Modify Cal-Menü zu gelangen.

    2. Drücken Sie Click.

  3. Im Block "Calibration Kit" wird automatisch das Feld Cal Kit ID aktiviert. Geben Sie die gewünschte Kalibrier-Kit-Identifikationsnummer ein, oder wählen Sie die gewünschte Nummer mit Hilfe der Pfeiltasten.

  4. Drücken Sie die Tab-rechts-Taste, um zum Feld Cal Kit Name zu gelangen. Geben Sie den neuen Kalibrier-Kit-Namen ein.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Restore Default Kit zu gelangen. Wenn Sie die Standardwerte für das gewählte Kalibrier-Kit wiederherstellen möchten, drücken Sie Click .

  6. Drücken Sie die Tab-rechts-Taste, um zum Feld Restore ALL Default Kits zu gelangen. Wenn Sie die Standardwerte für alle Kalibrier-Kits wiederherstellen möchten, drücken Sie Click .

Zuordnung der Kalibriernormale zu den Ports

  1. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um Port 1 im Block Assign Standards to Ports zu aktivieren. Spezifizieren Sie den Steckverbindertyp für diesen Port.

  2. Drücken Sie die Tab-rechts-Taste, um zum Feld Port 2 zu gelangen. Spezifizieren Sie den Steckverbindertyp für diesen Port.

  3. Drücken Sie die Tab-rechts-Taste, um zu dem gewünschten Kalibrierklassenfeld (beispielsweise S11A) zu gelangen. Geben Sie die gewünschte Kalibriernormalnummer ein, oder wählen Sie die gewünschte Nummer mit Hilfe der Pfeiltasten.

Modifikation der Kalibriernormal-Definition

  1. Drücken Sie die Tab-rechts-Taste, um das Feld Standard No. im Block Modify Standard Definition des Dialogfensters zu aktivieren. Geben Sie die gewünschte Kalibriernormalnummer ein, oder wählen Sie die gewünschte Nummer mit Hilfe der Pfeiltasten.

  2. Geben Sie für die im vorigen Schritt gewählte Kalibriernormalnummer alle erforderlichen Werte ein: "Minimum Frequency" (minimale Frequenz), "Maximum Frequency" (maximale Frequenz), "Z0" (Systemimpedanz), "Delay" (Laufzeit), "Loss" (Dämpfung) usw. Geben Sie den jeweiligen Wert direkt in das betreffende Feld ein, oder wählen Sie mit Hilfe der Pfeiltasten den gewünschten Wert.

  3. Wiederholen Sie die Schritte 1 und 2 für jede Kalibriernormalnummer.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK .


Wahl des Kalibrierverfahrens

Siehe auch...

Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung

Überblick

Kalibrier-
verfahren

Kalibrierungsassistent
und Kalibrierfunktionen

Wie führ man eine
Kalibrierung durch?

Welche Art der Kalibrierung für Ihre Anwendung optimal ist, hängt davon ab,

  • welche Messungen Sie mit dem Analysator durchführen möchten;

  • welche Messgenauigkeit Ihre Anwendung erfordert.
Verfügbare Kalibrierverfahren

Kalibrierungsassistent und Kalibrierfunktionen

Wie führt man eine Kalibrierung durch?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Auswahl des adäquaten Kalibrierverfahrens

"None"

"OPEN Response" oder "SHORT Response"

"THRU Response"

"THRU Response and Isolation"

"1 Port (Reflection)"

"Full SOLT 2-Port (SHORT, OPEN, LOAD, THRU)"

"Full TRL 2-Port (THRU, REFLECT, LINE)"

Übersicht über die verfügbaren Kalibrierverfahren

Kalibrierverfahren

Im allgemeinen gilt: Je genauer die Kalibrierung ist,

  • desto länger dauert die Kalibrierung;

  • desto länger dauern die späteren Messungen.

Deshalb sollten Sie bei der Auswahl des Kalibrierverfahrens berücksichtigen, welche Messunsicherheit Sie in Ihrer Anwendung tolerieren können.

Je nachdem, welche S-Parameter und in welcher Richtung (vorwärts, rückwärts oder bidirektional) Sie messen möchten, können Sie zwischen folgenden Kalibrierverfahren wählen:

Kalibrierverfahren | Genauigkeit | Parameter | Erforderliche Normale
"None" | Gering | Alle | 0
"OPEN Response" oder "SHORT Response" | Gut | S11 oder S22 | Leerlauf, Kurzschluss
"THRU Response" | Gut | S21 oder S12 | Durchgangsnormal
"THRU Response and Isolation" | Gut | S21 oder S12 | Durchgang, Last
"ECal 1-Port (Reflection)" | Noch besser | S11 oder S22 | ECal-Modul
"1-Port (Reflection)" | Noch besser | S11 oder S22 | Kurzschluss, Leerlauf, Last
"ECal Full 2-Port" | Fast sehr gut | Alle | ECal-Modul
"Full SOLT 2-Port" | Sehr gut | Alle | Kurzschluss, Leerlauf, Last, Durchgang
"Full TRL 2-Port" | Größtmöglich | Alle | Durchgang, Leerlauf oder Kurzschluss, Leitung

Kalibrierverfahren: "None"

  • Für alle S-Parameter-Messungen geeignet.

  • Es werden keine Messungen an Kalibriernormalen durchgeführt.

  • Extrem schnelle, aber ungenaue Kalibrierung.

  • Nur geeignet, wenn Ihre Anwendung keine hohe Messgenauigkeit erfordert.

Korrigierte systematische Fehler

  • Keine

"OPEN" oder "SHORT Response Calibration (REFLECTION)"

  • Nur für Reflexionsmessungen an einem Port geeignet.

  • Es werden Messungen an einem Leerlauf- oder Kurzschlussnormal durchgeführt.

  • Sehr schnelles und mäßig genaues Kalibrierverfahren.

Korrigierte systematische Fehler

  • Reflexions-F requenzgang-Gleichlauffehler

Hinweis: Bei Sie nach einer 1-Port-Kalibrierung eine Reflexionsmessung an einem Zweitor-Bauteil durchführen, sollten Sie dessen Ausgang korrekt abschließen, da sonst das vom Ausgang reflektierte Signal die Messgenauigkeit beeinträchtigt; dies gilt insbesondere für Bauteile mit geringer Einfügedämpfung.

Anordnung für eine "OPEN or SHORT Response"-Kalibrierung

"THRU Response Calibration (TRANSMISSION)"

  • Nur für Transmissionsmessungen in einer Richtung geeignet.

  • Es werden Messungen an einem Durchgangsnormal durchgeführt.

  • Sehr schnelles und mäßig genaues Kalibrierverfahren.

Korrigierte systematische Fehler

  • Transmissions-Frequenzgang-Gleichlauffehler

Hinweis: Die vordefinierten Kalibrier-Kits setzen ein Durchgangsnormal mit der Länge Null voraus. Falls Sie einen Adapter als Durchgangsnormal verwenden, müssen Sie diesen charakterisieren, damit Sie die größtmögliche Messgenauigkeit erzielen. Weitere Informationen siehe Genaue Kalibrierung.

Anordnung für eine "Thru Response"-Kalibrierung

"THRU Response and Isolation (TRANSMISSION)"-Kalibrierung

  • Nur für Transmissionsmessungen in einer Richtung geeignet.

  • Der I solationsteil von v eignet sich nur für Messungen an Bauteilen mit hoher E infügedämpfung.

  • Es werden Messungen an Durchgangs- und Lastnormalen durchgeführt.

  • Sehr schnelles und mäßig genaues Kalibrierverfahren.

Korrigierte systematische Fehler

  • Isolation

  • Transmissions-Frequenzgang-Gleichlauffehler

Hinweis: Die vordefinierten Kalibrier-Kits setzen ein Durchgangsnormal mit der Länge Null voraus. Falls Sie einen Adapter als Durchgangsnormal verwenden, müssen Sie diesen charakterisieren, damit Sie die größtmögliche Messgenauigkeit erzielen. Weitere Informationen siehe Genaue Kalibrierung.

Anordnung für "Thru Response and Isolation"-Kalibrierung

"1-Port Reflection"-Kalibrierung

  • Nur für Reflexionsmessungen an einem Port geeignet.

  • Es werden Messungen an Kurzschluss-, Leerlauf- und Lastnormalen durchgeführt.

  • Hohe Genauigkeit bei 1-Port-Messungen.

Korrigierte systematische Fehler

  • R ichtverhältnis

  • Quellenanpassung

  • Reflexions-Frequenzgang-Gleichlauffehler

Hinweis: Wenn Sie nach einer 1-Port-Reflexionskalibrierung Messungen an einem Zweitor-Bauteil durchführen, sollten Sie den Ausgang des Bauteils korrekt abschließen. Anderenfalls verschlechtert das vom Ausgang des Bauteils reflektierte Signal die Messgenauigkeit; dies gilt insbesondere für Bauteile mit geringer E infügedämpfung .

Anordnung für "1-Port (Reflection)"-Kalibrierung

"ECal 1-Port Reflection"-Kalibrierung

  • Nur für Reflexionsmessungen an einem Port geeignet.

  • Es werden Messungen an einem ECal-Modul durchgeführt. Das ECal-Modul enthält die benötigten Kalibriernormale und wird über die USB-Schnittstelle vom Analysator gesteuert; die Umschaltung der Signalpfade erfolgt mit Hilfe von Halbleiterschaltern in dem ECal-Modul.

  • Hohe Genauigkeit bei 1-Port-Messungen.

  • Minimaler Verschleiß der Kalibriereinrichtung.

  • Bedienungsfehler sind so gut wie ausgeschlossen.

  • Besonders schnelle Kalibrierung.

Korrigierte systematische Fehler

  • Richtverhältnis

  • Quellenanpassung

  • Reflexions-Frequenzgang-Gleichlauffehler

Hinweis: Wenn Sie nach einer 1-Port-Reflexions- Kalibrierung Messungen an einem Zweitor-Bauteil durchführen, sollten Sie den Ausgang des Bauteils korrekt abschließen. Anderenfalls beeinträchtigt das vom Ausgang des Bauteils zurückreflektierte Signal die Messgenauigkeit; dies gilt insbesondere für Bauteile mit geringer Einfügedämpfung.

Anordnung für "ECal"-Kalibrierung

"Full 2-Port SOLT (Short, Open, Load, Thru)"-Kalibrierung

  • Für alle S-Parameter-Messungen geeignet.

  • Es werden Messungen an Kurzschluss-, Leerlauf-, Last und Durchgangsnormalen durchgeführt.

  • Dieses Kalibrierverfahren wird auch als "12-Term-Fehlerkorrektur" bezeichnet (es werden jeweils sechs Fehler in Vorwärts- und Rückwärtsrichtung korrigiert).

  • Sehr hohe Messgenauigkeit.

Korrigierte systematische Fehler

  • Richtverhältnis

  • Isolation

  • Quellenanpassung

  • Lastanpassung

  • Reflexions-Frequenzgang-Gleichlauffehler

  • Transmissions-Frequenzgang-Gleichlauffehler

Hinweis: Die Isolations- Kalibrierung eignet sich nur für Messungen an Bauteilen mit hoher E infügedämpfung . Wenn Sie keine Messungen an Bauteilen mit hoher Einfügedämpfung beabsichtigen, sollten Sie auf die Isolationskalibrierung VERZICHTEN. Die Isolationskalibrierung erfordert die Messung sehr schwacher Signale in der Nähe des Analysator-Eigenrauschen s.

Anordnung für "Full SOLT 2-Port"-Kalibrierung

"Full TRL 2-Port (Thru, Reflect, Line)"-Kalibrierung

  • Für alle S-Parameter-Messungen geeignet.

  • Bei der Reflexionskalibrierung werden Messungen an einem Durchgangsnormal sowie einem Kurzschluss- oder Leerlaufnormal durchgeführt; bei der Transmissionskalibrierung werden Messungen an einem Durchgangsnormal und einem Leitungsnormal durchgeführt.

  • Dieses Kalibrierverfahren wird auch als "12-Term-Fehlerkorrektur" bezeichnet (es werden jeweils sechs Fehler in Vorwärts- und Rückwärtsrichtung korrigiert).

  • Das genaueste aller Kalibrierverfahren.

Hinweis: Die Isolationskalibrierung eignet sich nur für Messungen an Bauteilen mit hoher Einfügedämpfung. Wenn Sie keine Messungen an Bauteilen mit hoher Einfügedämpfung durchzuführen beabsichtigen, sollten Sie auf die Isolationskalibrierung verzichten.

Korrigierte systematische Fehler

  • Richtverhältnis

  • Isolation

  • Quellenanpassung

  • Lastanpassung

  • Reflexions-Frequenzgang-Gleichlauffehler

  • Transmissions-Frequenzgang-Gleichlauffehler

Hinweis: Die Isolationskalibrierung eignet sich nur für Messungen an Bauteilen mit hoher Einfügedämpfung. Wenn Sie keine Messungen an Bauteilen mit hoher Einfügedämpfung beabsichtigen, sollten Sie auf die Isolationskalibrierung VERZICHTEN, da diese Kalibrierung die Messung sehr schwacher Signale in der Nähe des Eigenrauschens des Analysators erfordert; hierdurch können Messfehler verursacht werden.

Das einzige im Analysator vordefinierte TRL-Kalibrier-Kit ist das 3.5 mm-TRL-Modell 85052C. Wenn Sie eine TRL-Kalibrierung mit einem anderen Steckverbindertyp als 3.5 mm durchführen möchten, müssen Sie zuerst die Definitionen der TRL-Kalibriernormale entsprechend modifizieren oder ein benutzerdefiniertes Kalibrier-Kit erstellen. Weitere Informationen über das Modifizieren von Kalibrier-Kit-Definitionen siehe Kalibriernormale.

"ECal Full 2-Port"-Kalibrierung

  • Für alle S-Parameter-Messungen geeignet.

  • Es werden Messungen an einem ECal-Modul durchgeführt. Das ECal-Modul enthält die benötigten Kalibriernormale und wird über die USB-Schnittstelle vom Analysator gesteuert; die Umschaltung der Signalpfade erfolgt mit Hilfe von Halbleiterschaltern in dem ECal-Modul.

  • Dieses Kalibrierverfahren wird auch als "12-Term-Fehlerkorrektur" bezeichnet (es werden jeweils sechs Fehler in Vorwärts- und Rückwärtsrichtung korrigiert).

  • Sehr hohe Messgenauigkeit.

  • Minimaler Verschleiß der Kalibriereinrichtung.

  • Bedienungsfehler sind so gut wie ausgeschlossen.

  • Erhebliche Zeitersparnis bei der Kalibrierung.

Korrigierte systematische Fehler

  • Richtverhältnis

  • I solation

  • Quellenanpassung

  • Lastanpassung

  • Reflexions-Frequenzgang-Gleichlauffehler

  • Transmissions-Frequenzgang-Gleichlauffehler

Anordnung für "ECal"-Kalibrierung

Übersicht über die verfügbaren Kalibrierverfahren

Zu messender S-Parameter | Verfügbare Kalibrierverfahren
S11 | "Open Response" "Short Response" "1-Port (Reflection)" "ECal 1-Port (Reflection)" "Full SOLT 2-Port" "Full TRL 2-Port" "ECal Full 2-Port"
S21 | "Thru Response" "Thru Response & Isolation" "Full SOLT 2-Port" "Full TRL 2-Port" "ECal Full 2-Port"
S12 | "Thru Response" "Thru Response & Isolation" "Full SOLT 2-Port" "Full TRL 2-Port" "ECal Full 2-Port"
S22 | "Open Response" "Short Response" "1-Port (Reflection)" "ECal 1-Port (Reflection)" "Full SOLT 2-Port" "Full TRL 2-Port" "ECal Full 2-Port"
Absolutleistung | Mathematische Funktionen/Speicherarithmetik
Leistungsverhältnis | Mathematische Funktionen/Speicherarithmetik

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Kalibrierungsassistent

Fehlerkorrektur aktivieren/deaktivieren

Kalibrier-Einstellungen

Kalibrierdatenspeicherung

Modifikation der aktuellen Kalibrierdaten

Laden von Kalibrierdaten

Kalibrierungsassistent

Der K alibrierungsassistent ist eine Folge von Dialogfenstern, die Sie durch den Kalibrierprozess führen.

Hinweis: Die Angaben "männlich" oder "weiblich" in den vom Analysator angezeigten Kalibrier-Kit-Bezeichnungen beziehen sich auf das Geschlecht des Analysator-Ports (und nicht auf das Geschlecht des Steckverbinders am Kalibriernormal).

Der Block "Select Calibration Type" enthält folgende Felder:

  • Das derzeit gewählte Kalibrierverfahren. In diesem Beispiel ist "None" gewählt.

  • Das Dialogfenster Cal Type, das folgende Kalibrierverfahren zur Auswahl bietet:

    • "OPEN Response"

    • "SHORT Response"

    • "THRU Response"

    • "THRU Response and Isol"

    • "1-Port (Reflection)"

    • "Full SOLT 2-Port"

    • "Full TRL 2-Port"

    • "None"

Der Block Cal Type enthält ein Kontrollkästchen Omit Isolation (2-Port types); wenn Sie dieses Kontrollkästchen anklicken, wird der Isolationsteil der 2-Port-Kalibrierung übersprungen.

Der Block "Instrument Settings" enthält ein Dialogfenster Modify, in dem Sie die Start- und Stop-Frequenzen des Analysators ändern können.

Der Block Use Electronic Calibration enthält ein Dialogfenster Measure ECal Stds mit Grafiken und (falls erwünscht) Hinweisen, die Sie durch den ECal-Kalibrierprozess führen.

Der Block "Use Mechanical Standards" enthält:

  • Ein Kontrollkästchen "Have 2 Sets of Standards". Wenn Sie über zwei Kalibriernormalsätze (beispielsweise zwei Leerlaufnormale) verfügen und dieses Kontrollkästchen anklicken, werden bei einer 2-Port-Kalibrierung die Messungen an Port 1 und 2 gleichzeitig durchgeführt.

  • Ein Dialogfenster Measure Standards mit folgenden Informationen:

    • Grafiken und (falls erforderlich) Hinweise, die Sie durch den zuvor Kalibrierprozess führen.

    • Ein Kontrollkästchen Show Prompts, mit dem Sie die Hinweise, die diesen Teil des Kalibrierungsassistenten begleiten, ein-/ausschalten können.

    • Ein Feld Change Port, das es Ihnen ermöglicht, vordefinierte Kalibrier-Kit-Port-Zuordnungen zu ändern und (falls erforderlich) ein benutzerspezifisches Durchgangsnormal bzw. einen benutzerspezifischen Adapter zu charakterisieren. Hiermit können Sie außerdem Ihre Modifikationen als benutzerdefiniertes Kalibrier-Kit abspeichern. Weitere Informationen über Durchgangsnormale siehe Genaue Kalibrierung. Weitere Informationen über das Modifizieren von Kalibrier-Kit-Definitionen siehe Kalibriernormale.

    • Ein Feld Select Calibration Kit mit folgenden Kalibrier-Kit-Auswahlmöglichkeiten:

Kit ID | Port 1 | Port 2 | "Cal Kit Name"
1 | Type-N (w) | Type-N (m) | Type-N Model 85032F
2 | 3.5 mm | 3.5 mm | 3.5 mm Model 85033E
3 | Type-N (w) | Type-N (m) | Type-N Model 85032B
4 | 3.5 mm | 3.5 mm | 3.5 mm Model 85033D
5 | 7-16 | 7-16 | 7-16 Model 85038A
6 | TRL 3.5 mm | TRL 3.5 mm | TRL 3.5 mm Model 85052C
7 | Type-N (w) | Type-N (m) | User Cal Kit 7
8 | Type-N (w) | Type-N (m) | User Cal Kit 8
9 | Type-N (w) | Type-N (m) | User Cal Kit 9
10 | Type-N (w) | Type-N (m) | User Cal Kit 10

Hinweis: Die Kalibrier-Kit-Definitionen für die Kits 1 bis 6 sind standardmäßig im Analysator gespeichert.

Fehlerkorrektur aktivieren/deaktivieren

Die Fehlerkorrekturfunktion ("Error Correction") des Analysators kann aktiviert (ON) oder deaktiviert (OFF) werden.

  • Bei eingeschalteter F ehlerkorrektur ("Correction ON") werden die aktuellen Messdaten anhand der bei der letzten Kalibrierung ermittelten Kalibrierdaten korrigiert. Am unteren Bildschirmrand erscheint die "C"- Anzeige , gefolgt von dem Code für das jeweilige Kalibrierverfahren (beispielsweise 2-P SOLT ). Weitere Informationen über Bildschirmanzeigen siehe Gültigkeit einer Kalibrierung.

  • In Stellung OFF ist die Fehlerkorrektur abgeschaltet. In diesem Fall erscheint am unteren Bildschirmrand die "No Cor"-Anzeige.

Kalibrier-Einstellungen

Die Funktion "View Calibration Properties" zeigt die Einstellungen an, mit der die aktuelle Kalibrierung durchgeführt wurde:

  • "Channel" (Kanal)

  • "Stop Frequency" (Stop-Frequenz)

  • "Calibration Date" (Kalibrierdatum)

  • "IF Bandwidth" (ZF-Bandbreite)

  • "Timestamp" (Zeitmarke)

  • "Trace Points" (Anzahl der Punkte)

  • "Calibration Type" (Kalibrierverfahren)

  • "Sweep Time" (Wobbelzeit)

  • "Correction" (Korrektur)

  • "Port 1 Power" (Signalpegel an Port 1)

  • Interpolation

  • "Port 2 Power" (Signalpegel an Port 1)

  • "Start Frequency" (Start-Frequenz)

  • "Sweep Type" (Wobbeltyp)

Kalibrierdatenspeicherung

  • Wenn bei einer assistent-unterstützten Kalibrierung die Messungen an den Kalibriernormalen (oder -modulen) abgeschlossen sind, werden die Kalibrierdaten und der Gerätezustand automatisch als "*.cst"-Datei abgespeichert. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen.

  • Sie können die Kalibrierdaten (ohne Analysatoreinstellungen) auch manuell als "*.cal"-Datei abspeichern. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen. Informationen über das manuelle Abspeichern von Kalibrierdaten siehe Abspeichern einer Datei.

Modifikation der aktuellen Kalibrierdaten

  • Bei einem Preset wird automatisch das Kalibrierverfahren "None" (keine Kalibrierung) gewählt.

  • Beim Einschalten des Gerätes werden automatisch die Analysatoreinstellungen und das Kalibrierverfahren wiederhergestellt, die zuletzt vor dem Ausschalten gewählt waren. Siehe Ein/Aus-Schalter.

Laden von Kalibrierdaten

Hinweis: Kalibrierdaten sind kanalspezifisch. Es ist beispielsweise nicht möglich, Kalibrierdaten, die im Kanal 1 gemessen wurden, für einen der anderen Kanäle zu laden. Siehe Bedienungskonzept.

Kalibrierdaten sind stets mit den Analysatoreinstellungen zum Zeitpunkt der Kalibrierung verknüpft. Ein gespeicherter Kalibrierdatensatz kann für unterschiedliche Analysatoreinstellungen geladen und verwendet werden, solange die Messparameter, der Frequenzbereich und die Anzahl der Messpunkte kompatibel sind.

  • Beim Laden eines als "*.cst"-Datei gespeicherten "State and Cal Set" werden die Kalibrierdaten zusammen mit den Analysatoreinstellungen zum Zeitpunkt der Kalibrierung von der Diskette zurückgeladen.

  • Beim Laden eines als "*.cal"-Datei gespeicherten "Cal Set" werden nur die gewählten Kalibrierdaten, aber nicht die Analysatoreinstellungen zurückgeladen.

    • Falls die aktuellen Analysatoreinstellungen exakt mit denen zum Zeitpunkt der Kalibrierung übereinstimmen, ist die Kalibriergenauigkeit sehr hoch.

    • Bei aktiver I nterpolation verringert sich die Kalibriergenauigkeit, falls die aktuellen Analysatoreinstellungen nicht exakt mit denen zum Zeitpunkt der Kalibrierung übereinstimmen. Ausnahme: Falls der aktuelle Frequenzbereich des Analysators größer als zum Zeitpunkt der Kalibrierung ist, wird die Kalibrierung deaktiviert.

    • Bei abgeschalteter Interpolation wird die Kalibrierung deaktiviert, falls die Analysatoreinstellungen nicht exakt mit den Einstellungen zum Zeitpunkt der Kalibrierung übereinstimmen.

  • Beim Laden eines als "*.sta"-Datei gespeicherten "State Set" wird nur der betreffende Analysatorzustand zurückgeladen, nicht jedoch die zugehörigen Kalibrierdaten. In diesem Fall bleiben die aktuellen Kalibrierdaten wirksam.

    • Falls die zurückgeladenen Analysatoreinstellungen exakt mit denen zum Zeitpunkt der Kalibrierung übereinstimmen, ist die Kalibriergenauigkeit sehr hoch.

    • Bei aktiver Interpolation verringert sich die Kalibriergenauigkeit, falls die aktuellen Analysatoreinstellungen nicht exakt mit denen zum Zeitpunkt der Kalibrierung übereinstimmen. Ausnahme: Falls der zurückgeladene Frequenzbereich des Analysators größer als der Frequenzbereich zum Zeitpunkt der Kalibrierung ist, wird die Kalibrierung deaktiviert.

    • Bei abgeschalteter Interpolation wird die Kalibrierung deaktiviert, falls die aktuellen Analysatoreinstellungen nicht exakt mit denen zum Zeitpunkt der Kalibrierung übereinstimmen.

Hinweis: Weitere Informationen über die Gültigkeit der Kalibrierung nach einer Änderung der Analysatoreinstellungen siehe Gültigkeit einer Kalibrierung.

Klicken Sie auf eine der Schaltflächen, um zu einer Beschreibung der jeweiligen Prozedur zu gelangen:
Verwendung des Kalibrierungsassistenten

Aktivieren/deaktivieren der Fehlerkorrektur

Anzeige der Kalibrier-Einstellungen

Verwendung des Kalibrierungsassistenten
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Calibration auf Calibration Wizard.

Auswahl eines Kalibrierverfahrens

  1. Klicken Sie auf Cal Type.

  2. Wählen Sie das gewünschte Kalibrierverfahren.

  3. Bei den 2-Port-Kalibrierverfahren ist das Kontrollkästchen Omit Isolation (2-Port types) standardmäßig aktiviert. Wenn Sie möchten, dass auch eine Isolationskalibrierung durchgeführt wird, müssen Sie dieses Kontrollkästchen durch Anklicken deaktivieren.

  4. Klicken Sie auf OK.

Wenn Sie die Start-/Stop-Frequenzeinstellungen ändern möchten

  1. Klicken Sie auf Modify.

  2. Geben Sie die gewünschten Start- und Stop-Frequenzwerte ein oder wählen Sie diese durch Anklicken der Pfeile.

  3. Klicken Sie auf OK.

Wenn Sie eine elektronische Kalibrierung durchführen möchten

  1. Falls das ECal-Modul noch nicht angeschlossen und warmgelaufen ist, führen Sie die nachfolgenden Schritte "a" bis "d" aus:

    1. Schließen Sie das ECal-Modul an die USB-Schnittstelle des Analysators an. (Schließen Sie das ECal-Modul NICHT an die Parallelschnittstelle des Analysators an.)

    2. Nach dem Einschalten befindet sich das Modul zunächst in einem Wartezustand (WAIT). Es leuchtet nur die rote "WAIT"-LED; diese signalisiert, dass das Modul sich in der Aufwärmphase befindet. (Die grüne LED leuchtet eventuell kurzzeitig auf.)

    3. Nach etwa 14 Minuten leuchtet zusätzlich zu der roten LED auch die grüne LED auf. Dies signalisiert, dass das Modul etwa 95% seiner regulären Betriebstemperatur erreicht hat.

    4. Etwa eine Minute später erlischt die rote LED, und es leuchtet nur noch die grüne "READY"-LED. Dies signalisiert, dass das Modul seine reguläre Betriebstemperatur erreicht hat und betriebsbereit ist.

  2. Klicken Sie auf Measure ECal.

    • Aktivieren Sie das Kontrollkästchen Show Prompts, falls Sie vom Analysator durch den ECal-Prozess geführt werden möchten.

Hinweis: Die Aufwärmzeit des ECal-Moduls ist von der Umgebungstemperatur abhängig.

Hinweis: Wenn das Modul schon einmal aufgewärmt war und dann vorübergehend abgetrennt wird, geht das Aufwärmen anschließend schneller vonstatten als beim ersten Mal. Solange die die grüne und die rote LED leuchten (was bedeutet, dass das Modul 95% seiner regulären Betriebstemperatur erreicht hat), sollten Sie noch nicht mit der Kalibrierung beginnen, da sonst nicht die volle Genauigkeit gewährleistet ist. Um die spezifizierte Kalibriergenauigkeit zu erreichen, müssen Sie warten, bis nur noch die grüne "READY"-LED leuchtet.

  3. Klicken Sie auf Module. Stellen Sie die erforderliche(n) Verbindung(en) her (siehe Abbildung).

  4. Klicken Sie auf OK. Es erscheint das Dialogfenster "Cal Information", in dem der Name und Pfad der Kalibrierdatensatz- und Gerätezustandsdatei angezeigt werden.

Hinweis: Nach Abschluss der Kalibriermessungen werden der Kalibrierdatensatz und Gerätezustand automatisch als *.cst"-Datei abgespeichert. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen.

  5. Klicken Sie auf OK.

Wenn Sie eine Kalibrierung unter Verwendung mechanischer Kalibriernormale durchführen möchten

  1. Wenn Sie über zwei Kalibriernormalen-Sätze verfügen und beide benutzen möchten, aktivieren Sie das Kontrollkästchen Have 2 sets of standards im Bereich "Use Mechanical Standards" des Dialogfensters.

  2. Klicken Sie auf Measure Stds.

    • Aktivieren Sie das Kontrollkästchen Show Prompts, falls Sie vom Analysator durch den Kalibrierprozess geführt werden möchten.

  3. Klicken Sie auf Select Cal Kit.

  4. Wählen Sie das gewünschte Kalibrier-Kit.

  5. Klicken Sie auf OK.

Wenn Sie die Kalibrier-Kit-Zuordnung zu einem oder mehreren Analysator-Ports ändern möchten

  1. Klicken Sie auf Change Port.

  2. Geben Sie in das Feld Cal Kit ID die gewünschte Kalibrier-Kit-Identifikationsnummer ein oder wählen Sie diese durch Anklicken des Pfeils. (Unter den ID-Nummern 1 bis 6 sind vordefinierte Kalibrier-Kit-Definitionen gespeichert. Unter den ID-Nummern 7 bis 10 sind benutzerdefinierte Kalibrier-Kit-Definitionen gespeichert.)

  3. Ändern Sie im Feld Cal Kit Name den Kalibrier-Kit-Namen wie gewünscht ab.

  4. Wählen Sie im Feld Port 1 Model durch Anklicken des Pfeils das gewünschte Agilent-Kalibrier-Kit-Modell für Port 1. Wählen Sie das Geschlecht des Steckverbinders an der Port-1-Messebene.

  5. Wählen Sie im Feld Port 2 Model durch Anklicken des Pfeils das gewünschte Agilent-Kalibrier-Kit-Modell für Port 2. Wählen Sie das Geschlecht des Steckverbinders an der Port-2-Messebene.

  6. Wählen Sie im Feld THRU oder Adapter durch Anklicken des Pfeils das gewünschte Durchgangsnormal oder den gewünschten Adapter.

  7. Wenn Sie im vorigen Schritt "Custom Thru/Adapter" gewählt haben:

    1. Klicken Sie auf Specify Custom Thru/Adapter.

    2. Ändern Sie im Feld Label die Bezeichnung wie gewünscht ab.

    3. Geben Sie in das Feld Z0 den Impedanzwert ein, oder wählen Sie diesen durch Anklicken des Pfeils.

    4. Geben Sie in das Feld Delay den Laufzeitwert ein, oder wählen Sie diesen durch Anklicken des Pfeils.

    5. Geben Sie in das Feld Loss den Dämpfungswert ein, oder wählen Sie diesen durch Anklicken des Pfeils.

    6. Klicken Sie auf OK.

  8. Klicken Sie auf OK. Es erscheint das Dialogfenster "Cal Information", in dem bestätigt wird, dass die neuen Einstellungen unter der gewählten Kalibrier-Kit-Identifikationsnummer gespeichert wurden. Klicken Sie auf OK.

Durchführung der Messungen an den Kalibriernormalen

  1. Klicken Sie nacheinander auf die Schaltflächen für die verschiedenen Kalibriernormale (beispielsweise OPEN, SHORT oder LOAD). Stellen Sie die erforderliche(n) Verbindung(en) her (siehe Abbildung).

  2. Klicken Sie auf OK, OK. Es erscheint das Dialogfenster "Cal Information", in dem der Name und Pfad der Kalibrierdatensatz- und Gerätezustandsdatei angezeigt werden.

Hinweis: Wenn die Messungen an den für die jeweilige Kalibrierung benötigten Normalen abgeschlossen sind, werden der Kalibrierdatensatz und der Gerätezustand automatisch als *.cst"-Datei abgespeichert. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Cal.

  2. Drücken Sie F1 (Cal Wizard).

Auswahl eines Kalibrierverfahrens

  1. Drücken Sie im Tastenfeld NAVIGATION die Taste Click, um ein Kalibrierverfahren zu wählen.

  2. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste das gewünschte Kalibrierverfahren.

  3. Falls Sie eine 2-Port-Kalibrierung gewählt haben, wählen Sie durch Drücken der Tab-rechts-Taste das Kontrollkästchen "Omit I solation (2-Port types)" check box. Dieses Kontrollkästchen ist standardmäßig aktiviert. If you want to include the isolation portion of the 2-Port calibration process, press Click.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Wenn Sie die Start-/Stop-Frequenzeinstellungen ändern möchten

  1. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um Modify zu wählen.

  2. Drücken Sie Click.

  3. Wählen Sie mit der Tab-rechts-Taste das Feld Start bzw. Stop. Geben Sie die gewünschte Start- bzw. Stop-Frequenz ein, oder wählen Sie die gewünschte Nummer mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Wenn Sie eine elektronische Kalibrierung durchführen möchten

  1. Falls das ECal-Modul noch nicht angeschlossen und warmgelaufen ist, führen Sie die nachfolgenden Schritte "a" bis "d" aus:

    1. Schließen Sie das ECal-Modul an die USB-Schnittstelle des Analysators an.

    2. Nach dem Einschalten befindet sich das Modul zunächst in einem Wartezustand (WAIT). Es leuchtet nur die rote "WAIT"-LED; diese signalisiert, dass das Modul sich in der Aufwärmphase befindet.

    3. Nach etwa 14 Minuten (bei 25°C Umgebungstemperatur) leuchtet zusätzlich zu der roten LED auch die grüne LED auf. Dies signalisiert, dass das Modul etwa 95% seiner regulären Betriebstemperatur erreicht hat.

    4. Etwa eine Minute später erlischt die rote LED, und es leuchtet nur noch die grüne "READY"-LED. Dies signalisiert, dass das Modul seine reguläre Betriebstemperatur erreicht hat und betriebsbereit ist.

  2. Drücken Sie im Tastenfeld NAVIGATON die Tab-rechts- oder Tab-links-Taste, um Measure ECal Stds zu wählen. Drücken Sie Click.

  3. Drücken Sie die Tab-rechts-Taste, um zum Feld Show Prompts zu gelangen. Wenn Sie vom Analysator durch den ECal-Prozess geführt werden möchten, drücken Sie Click.

  4. Wählen Sie durch Drücken der Tab-links-Taste Module. Drücken Sie Click, und stellen Sie die erforderliche(n) Verbindung(en) her (siehe Abbildung).

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK. Es erscheint das Dialogfenster "Cal Information", in dem der Name und Pfad der Kalibrierdatensatz- und Gerätezustandsdatei angezeigt werden.

Hinweis: Nach Abschluss der Kalibriermessungen werden der Kalibrierdatensatz und Gerätezustand automatisch als *.cst"-Datei abgespeichert. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen.

  6. Drücken Sie OK.

Wenn Sie eine Kalibrierung unter Verwendung mechanischer Kalibriernormale durchführen möchten

  1. Drücken Sie im Tastenfeld NAVIGATON die Tab-rechts-Taste, um zum Kontrollkästchen Have 2 sets of standards im Bereich Use Mechanical Standards des Dialogfensters zu gelangen. Wenn Sie zur Kalibrierung zwei Kalibriernormalen-Sätze verwenden möchten, drücken Sie Click.

  2. Drücken Sie die Tab-links-Taste, um zu Measure Stds zu gelangen. Drücken Sie Click.

    • Drücken Sie die Tab-links-Taste, um zum Feld Show Prompts zu gelangen. Wenn Sie vom Analysator durch den Kalibrierprozess geführt werden möchten , drücken Sie Click.

  3. Drücken Sie die Tab-rechts-Taste, um zum Feld Select Cal Kit zu gelangen. Drücken Sie Click.

  4. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste das gewünschte Kalibrier-Kit.

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Wenn Sie die Kalibrier-Kit-Zuordnung zu einem oder mehreren Analysator-Ports ändern möchten

  1. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zu Change Port zu gelangen. Drücken Sie Click.

  2. Geben Sie in das Feld Cal Kit ID die gewünschte Kalibrier-Kit-Identifikationsnummer ein oder wählen Sie diese Mit Hilfe der Pfeil-oben/unten-Tasten. (Unter den ID-Nummern 1 bis 6 sind vordefinierte Kalibrier-Kit-Definitionen gespeichert. Unter den ID-Nummern 7 bis 10 sind benutzerdefinierte Kalibrier-Kit-Definitionen gespeichert.)

  3. Drücken Sie die Tab-rechts-Taste, um zum Feld Cal Kit Name zu gelangen. Ändern Sie den Kalibrier-Kit-Namen wie gewünscht ab.

  4. Drücken Sie die Tab-rechts-Taste, um zum Feld Port 1 Model zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste das gewünschte Kalibrier-Kit für Port 1.

  5. Drücken Sie die Tab-rechts-Taste und wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten das Geschlecht des Steckverbinders an der Port-1-Messebene.

  6. Drücken Sie die Tab-rechts-Taste, um zum Feld Port 2 zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste das gewünschte Kalibrier-Kit für Port 2.

  7. Drücken Sie die Tab-rechts-Taste und wählen Sie mit Hilfe der Pfeil-oben/unten-Tasten das Geschlecht des Steckverbinders an der Messebene für die Port-2-Messung.

  8. Drücken Sie die Tab-rechts-Taste, um zum Feld THRU oder Adapter zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste das gewünschte Durchgangsnormal oder den gewünschten Adapter.

  9. Wenn Sie im vorigen Schritt "Custom Thru/Adapter" gewählt haben:

    1. Drücken Sie die Tab-rechts-Taste, um zum Feld Specify Custom Thru/Adapter zu gelangen. Drücken Sie Click.

    2. Drücken Sie die Tab-rechts-Taste oder Tab-links-Taste, um zum Feld Label zu gelangen. Ändern Sie die Bezeichnung wie gewünscht ab.

    3. Drücken Sie die Tab-rechts-Taste, um zum Feld Z0 zu gelangen. Geben Sie den Impedanzwert ein, oder wählen Sie diesen mit Hilfe der Pfeil-oben/unten-Tasten.

    4. Drücken Sie die Tab-rechts-Taste, um zum Feld Delay zu gelangen. Geben Sie den Dämpfungswert ein, oder wählen Sie diesen mit Hilfe der Pfeil-oben/unten-Tasten.

    5. Drücken Sie die Tab-rechts-Taste, um zum Feld Loss zu gelangen. Geben Sie den Dämpfungswert ein, oder wählen Sie diesen mit Hilfe der Pfeil-oben/unten-Tasten.

    6. Drücken Sie im Tastenfeld COMMAND die Taste OK.

  10. Drücken Sie so oft OK, bis das Dialogfenster Cal Information erscheint und bestätigt, dass die neuen Einstellungen unter der gewählten Kalibrier-Kit-Identifikationsnummer gespeichert wurden. Drücken Sie OK.

Durchführung der Messungen an den Kalibriernormalen

  1. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts- oder Tab-links-Taste, um nacheinander zu den Schaltflächen für die verschiedenen Kalibrierungsnormale (beispielsweise OPEN, SHORT oder LOAD zu gelangen). Drücken Sie Click. Stellen Sie die erforderliche(n) Verbindung(en) her (siehe Abbildung).

  2. Drücken Sie im Tastenfeld COMMAND die Taste OK. Es erscheint das Dialogfenster "Cal Information", in dem der Name und Pfad der Kalibrierdatensatz- und Gerätezustandsdatei angezeigt werden.

Hinweis: Wenn die Messungen an den für die jeweilige Kalibrierung benötigten Normalen abgeschlossen sind, werden der Kalibrierdatensatz und der Gerätezustand automatisch als *.cst"-Datei abgespeichert. Diese Datei können Sie mit Hilfe der "Recall"-Funktion des Analysators zurückladen.

  3. Drücken Sie OK.

Aktivieren/deaktivieren der Fehlerkorrektur

Mausprozedur

  1. Wählen Sie im Calibration-Menü die Option Correction.

  2. Die Fehlerkorrekturfunktion ist standardmäßig aktiv (ON).

    • Wenn Sie die Fehlerkorrektur aktivieren möchten (ON), klicken Sie auf die Option, sodass Correction ON/off angezeigt wird.

    • Wenn Sie die Fehlerkorrektur deaktivieren möchten (OFF), klicken Sie auf die Option, sodass Correction on/OFF angezeigt wird.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Cal.

  2. Der Status der Fehlerkorrekturfunktion wird in dem grünen Feld in der Aktuelle-Eingabe-Symbolleiste angezeigt. Wenn Sie den Status ändern möchten (beispielsweise von OFF auf ON), drücken Sie F2 (Corr on/off).

Anzeige der Kalibrier-Einstellungen

Mausprozedur

  1. Klicken Sie im Calibration-Menü auf Properties.

  2. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Cal.

  2. Drücken Sie F3 (Properties).

  3. Drücken Sie im Tastenfeld COMMAND die Taste Cancel.


Siehe auch...

Genaue Kalibrierung

Überblick

Konzepte

Prozeduren

Es gibt verschiedene Methoden, mit denen Sie sicherstellen können, dass Sie eine genaue Kalibrierung durchführen.
Konzepte

Wie stellt man sicher, dass eine Kalibrierung genau ist?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Messebene

Messebenenverschiebung

Messfehler durch Verwendung ungeeigneter Kalibriernormale

Kalibrierung für Messungen an nicht direkt anschließbaren Bauteilen

Nicht-charakterisiertes Durchgangsnormal

Charakterisiertes Durchgangsnormal

Gepaarte Adapter

Isolationskalibrierung im Rahmen einer 2-Port-Kalibrierung

Messebene

  • Die meisten Messanordnungen erlauben es nicht, das Messobjekt DIREKT an die Messanschlüsse auf der Frontplatte des Analysators anzuschließen. Statt dessen wird das Messobjekt oft über einen Testadapter oder über Kabel an den Analysator angeschlossen.

  • Zur Optimierung der Messgenauigkeit sollten Sie das System an den Punkten kalibrieren, an denen das Messobjekt angeschlossen wird. Diese Ebene wird als die Messebene bezeichnet (siehe Grafik). Wenn Sie das System an diesen Punkten kalibrieren, werden auch die von der Messanordnung (Kabel, Testadapter und Adapter im Signalweg zwischen den Analysatoranschlüssen und der Messebene) verursachten Fehler erfasst und bei nachfolgenden Messungen korrigiert.

Messebenenverschiebung

  • Mit Hilfe der "Port Extensions"-Funktion können Sie nach erfolgter Kalibrierung die von externen Komponenten der Messanordnung verursachte Phasenverschiebung relativ zur Messebene kompensieren. Typische Komponenten, die eine solche Phasenverschiebung hervorrufen können, sind beispielsweise:

    • Kabel

    • Adapter

    • Testadapter

  • Die M essebenenverschiebung ist das bevorzugte Verfahren zur Kompensation der von einem Testadapter verursachten Phasenverschiebung.

    • Nehmen wir beispielsweise an, Sie verwenden einen Testadapter, der andere Steckverbinder besitzt als Ihre Kalibriernormale. In diesem Fall ist es nicht möglich, die elektrische Länge des Testadapters "auszukalibrieren". Mit Hilfe der "Port Extension"-Funktion können Sie die Laufzeit innerhalb des Testadapters und die dadurch verursachte Phasenverschiebung kompensieren. Die vom Testadapter verursachten Anpassungs- und Dämpfungsfehler lassen sich jedoch nicht mit Hilfe der "Port Extension"-Funktion kompensieren.

  • Die Laufzeitwerte, die Sie für die Messebenenverschiebung eingeben, werden automatisch sowohl auf Transmissions- als auch Reflexionsmessungen angewandt, wobei bei Reflexionsmessungen berücksichtigt wird, dass das Signal die elektrische Länge zweimal durchläuft. Beispiel:

    • Bei der Messung des Parameters S11 wird der zweifache Wert der "Port Extension"-Laufzeit für Port 1 angewandt (entsprechend dem Hin- und Rückweg des Signals).

    • Bei der Messung des Parameters S21 wird die "Port Extension"-Laufzeit für Port 1 und die "Port Extension"-Laufzeit für Port 2 jeweils einfach angewandt.

  • Die "Port Extension" gilt für alle Messungen über den betreffenden Port.

Messfehler durch Verwendung ungeeigneter Kalibriernormale

  • Normalerweise besitzen die zur Kalibrierung verwendeten Normale die gleichen Steckverbinder (hinsichtlich Typ und Geschlecht) wie das spätere Messobjekt.

  • Je nachdem, welches Kalibrier-Kit Sie verwenden, haben Ihre Kalibriernormale eventuell andere Steckverbinder als das Messobjekt. Beispielsweise könnte es sein, dass Ihr Messobjekt 3.5 mm-Steckverbinder besitzt und die Kalibriernormale in Ihrem Kalibrier-Kit Type-N-Steckverbinder besitzen. In diesem Fall müssen Sie die Kalibriernormale (Type-N) über einen Adapter an die Analysator-Anschlüsse (3.5 mm) anschließen.

  • Weil der Adapter nur Bestandteil der Kalibrieranordnung und NICHT Bestandteil der späteren Messanordnung ist, verursacht er bei Reflexionsmessungen einen erheblichen Messfehler.

  • Ungenauigkeiten können auch dann auftreten, wenn die verwendeten Kalibriernormale nicht mit den während des Kalibrierprozesses spezifizierten Kalibriernormalen übereinstimmen. Das Ausmaß der Ungenauigkeit ist davon abhängig, wie sehr die verwendeten Kalibriernormale von den spezifizierten abweichen.

Informationen darüber, wie Sie die Genauigkeit einer Kalibrierung überprüfen können, finden Sie unter Gültigkeit einer Kalibrierung.

Kalibrierung für Messungen an nicht direkt anschließbaren Bauteilen

Die nachfolgende Abbildung zeigt ein Beispiel für ein direkt anschließbares Bauteil. Dieses Bauteil besitzt zwei Type-N-Steckverbinder, einen männlichen und einen weiblichen.

  • Bei der Kalibrierung für Messungen an einem direkt anschließbaren Bauteil werden die Messanschlüsse an der Messebene direkt miteinander verbunden. Diese direkte Verbindung wird als ein "Durchgangsnormal der Länge Null" bezeichnet. Die zugehörige Kalibriernormaldefinition (d. h. die Beschreibung der elektrischen Kalibriernormal-Charakteristiken, die der Analysator für die Kalibrierung verwendet) lautet: Länge Null, Laufzeit Null, Dämpfung Null, Kapazität Null und Induktivität Null.

  • Eventuell enthält Ihr Kalibrier-Kit kein Durchgangsnormal, weil er zur Kalibrierung für Messungen an direkt anschließbaren Bauteilen vorgesehen ist.

Wenn Ihr Messobjekt nicht direkt anschließbar ist, können die Messanschlüsse an der Messebene nicht direkt miteinander verbunden werden (siehe nachfolgende Abbildung). In diesem Fall müssen Sie für die Durchgangsverbindung einen Adapter verwenden. Dieser Adapter ist bei den späteren Messungen nicht in der Messanordnung enthalten und verringert daher die Messgenauigkeit.

Wenn Sie Messungen an einem nicht direkt anschließbaren Bauteil durchführen möchten, haben Sie bei der Durchgangsnormal-Kalibrierung die drei nachfolgend beschriebenen Möglichkeiten zur Auswahl. Die drei Alternativen sind in der Reihenfolge zunehmender Genauigkeit aufgelistet (die erste Alternative ist die am wenigsten genaue).
Verwendung eines nicht-charakterisierten Durchgangsadapters

Verwendung eines charakterisierten Durchgangsadapters

Verwendung zweier gepaarter Adapter

Verwendung eines nicht-charakterisierten Durchgangsadapters

Dies ist das einfachste, aber auch ungenaueste Verfahren zur Kalibrierung für Messungen an nicht direkt anschließbaren Bauteilen. "Nicht-charakterisiert" bedeutet, dass die elektrische Länge und die Dämpfung des Durchgangsnormals nicht im Analysator gespeichert sind.

Obwohl der Adapter zur Durchgangskalibrierung verwendet wurde, werden dessen Dämpfung und Laufzeit bei den nachfolgenden Messungen nicht korrigiert, weil der Analysator diese Werte nicht kennt.

Charakterisierter Durchgangsadapter

  • "Charakterisierter Durchgangsadapter" bedeutet, dass die elektrische Länge und Dämpfung des Durchgangsadapters in der analysatorinternen Kalibrierungs-Kit-Definition spezifiziert sind.

  • Die elektrische Länge und die Laufzeit des (Männlich/männlich- oder Weiblich/weiblich-) Adapters können Sie normalerweise vom Hersteller des Adapters erfahren. Wenn nicht, können Sie diese Werte messen. Die Kalibrierung des Adapters muss allerdings mit hoher Genauigkeit erfolgen, was nicht ganz einfach ist, weil der Adapter selbst ein nicht direkt anschließbares Bauteil ist.

Einen hochwertigen Durchgangsadapter können Sie folgendermaßen charakterisieren:

  1. Führen Sie eine Kalibrierung unter Verwendung zweier gepaarter Adapter durch (siehe Beschreibung weiter unten).

  2. Charakterisieren Sie den Durchgangsadapter.

  3. Modifizieren Sie die Kalibrier-Kit-Definition des Durchgangsadapters mit Unterstützung durch den Kalibrierungsassistenten. (Dadurch brauchen Sie die Kalibrierung unter Verwendung zweier gepaarter Adapter nur ein einziges Mal durchzuführen).)

  4. Kalibrieren Sie die Messanordnung unter Verwendung des charakterisierten Durchgangsnormals.

Hinweis: Den charakterisierten Durchgangsadapter benötigen Sie nur zur Durchgangskalibrierung und nicht für die späteren Messungen am Messobjekt. Dies minimiert den Verschleiß Ihres charakterisierten Durchgangsadapters. (Der andere Adapter wird – wie später noch erläutert wird – für die späteren Messungen am Messobjekt benötigt.)

Verwendung zweier gepaarter Adapter

  • Die Kalibrierung unter Verwendung zweier gepaarter Adapter eignet sich hervorragend für Messungen an Bauteilen, die auf beiden Seiten exakt gleiche Steckverbinder (beispielsweise weibliche SMA-Steckverbinder) besitzen.)

  • Dieses Kalibrierverfahren erfordert die Verwendung von zwei exakt gepaarten Adaptern, die in ihren elektrischen Charakteristiken übereinstimmen, aber von unterschiedlichem Geschlecht sind.

    • Angenommen, Sie möchten Messungen an einem Bauteil durchführen, das an beiden Enden weibliche SMA-Steckverbinder besitzt und über Kabel mit APC-7-mm-Steckverbindern an den Analysator angeschlossen wird. Dann benötigen Sie für die Kalibrierung zwei zueinander gepaarte Adapter: einen 7-mm-auf-3.5-mm-männlich und einen 7-mm-auf-3.5-mm-weiblich.

  • Damit Sie sicher sein können, dass die Adapter tatsächlich gleiche Charakteristiken aufweisen, enthalten viele Kalibrier-Kits von Agilent Adapter, die hinsichtlich der folgenden Charakteristiken identisch sind:

    • Nennimpedanz

    • Einfügedämpfung

    • Elektrische Länge

    • Anpassung

Überblick über die Kalibrierung unter Verwendung zweier gepaarter Adapter

  1. Für die Transmissionskalibrierung im Rahmen einer 2-Port-Kalibrierung wird der Adapter verwendet, der zur Herstellung der Durchgangsverbindung benötigt wird.

  2. Für die Reflexionskalibrierung wird dieser Adapter durch den zweiten Adapter ersetzt; die Reflexionskalibrierung wird an beiden Messanschlüssen vorgenommen.

  3. Durch das Vertauschen der Adapter ändert sich das Geschlecht eines der beiden Messanschlüsse. Dadurch ist es möglich, nach Abschluss der Kalibrierung das Bauteil in die Messanordnung einzufügen (wobei der zweite Adapter in der Messanordnung verbleibt).

  4. Die nach der Kalibrierung verbleibenden Fehler entsprechen den Unterschieden zwischen den beiden Adaptern.

Siehe Prozedur für Kalibrierung unter Verwendung zweier gepaarte Adapter.

Isolationskalibrierung im Rahmen einer 2-Port-Kalibrierung

  • Bei einer 2-Port-Kalibrierung haben Sie die Möglichkeit, den Isolationsteil der Kalibrierung auszulassen.

  • Der Isolationsteil der Kalibrierung dient zur Bestimmung des bei offenen Messanschlüssen auftretenden Ü bersprechens zwischen den Messanschlüssen.

  • Eine Isolationskalibrierung sollten Sie dann und nur dann durchführen, wenn Sie Messungen an Bauteilen mit hoher E infügedämpfung beabsichtigen. Beispiel:

    • Filter mit hoher Sperrdämpfung.

    • Schalter in der offenen Stellung.

  • Die Isolationskalibrierung erfordert Messungen bei Signalpegeln nahe dem Grundrauschen des Analysators und kann daher das Fehlermodell durch Rauschen verfälschen. Zur Optimierung der Messgenauigkeit sollten Sie:

    • eine Isolationskalibrierung nur dann durchführen, wenn sie tatsächlich notwendig ist;

    • während der Isolationskalibrierung das Rauschen durch Messdatenmittelung reduzieren.

  • Bei der Isolationskalibrierung empfiehlt es sich, je ein Exemplar des zu messenden Bauteils an einen der Messanschlüsse des Analysators anzuschließen und die freien Enden dieser Bauteile jeweils mit der Nennimpedanz abzuschließen. Dadurch sind die Messanschlüsse des Analysators während der Kalibrierung mit der gleichen Impedanz abgeschlossen wie bei den späteren Bauteilmessungen.

  • Falls das beschriebene Verfahren nicht praktikabel ist (bei Verwendung eines Testadapters, beispielsweise, oder wenn nur ein einziges Bauteilexemplar verfügbar ist), wird als zweitbeste Methode empfohlen, den Signalquellenausgang des Analysators mit einem abgeschlossenen Bauteil und den Empfängereingang mit einem Impedanzabschluss abzuschließen.

  • Falls kein Bauteil verfügbar ist oder das Bauteil bei den späteren Messungen abgeglichen wird (wodurch sich seine Anschlussimpedanzen ändern), sollten Sie beide Analysatoranschlüsse jeweils mit einem Impedanzabschluss abschließen.

Klicken Sie auf eine der Schaltflächen, um zu einer Beschreibung der jeweiligen Prozedur zu gelangen:
Anwendung der "Port Extensions"-Funktion

Charakterisierung eines Durchgangsadapters

Durchführung einer Kalibrierung unter Verwendung zweier gepaarter Adapter

Anwendung der "Port Extensions"-Funktion
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Führen Sie eine Kalibrierung an der Messebene durch.

  2. Klicken Sie im "Calibration"-Menü auf Port Extensions.

  3. Klicken Sie auf das Kontrollkästchen Port Extensions, um die Funktion zu aktivieren.

  4. Klicken Sie auf ein Input- oder Port-Feld. Geben Sie die Signallaufzeit zwischen der Messebene für den Eingang bzw. Port und dem zu messenden Bauteil in das Feld ein, oder wählen Sie den Wert durch Anklicken der Pfeile. Folgendermaßen können Sie feststellen, ob der eingegebene Laufzeitwert groß genug ist:

    1. Schließen Sie anstelle des Messobjekts einen Durchgangsadapter an (bzw. verbinden Sie die betreffenden Anschlüsse direkt miteinander).

    2. Stellen Sie den "P ort extension"-Wert so ein, dass sich ein horizontaler Phasenfrequenzgang ergibt. (Beachten Sie, dass die meisten Kurzschlussnormale eine von Null verschiedene Laufzeit aufweisen; wenn Sie die Laufzeit wie beschrieben einstellen, resultiert daraus ein dem Doppelten der Kurzschlussnormal-Laufzeit entsprechender Laufzeitfehler.)

  5. Klicken Sie in das Feld "Velocity Factor". Geben Sie den Ausbreitungsgeschwindigkeitsfaktor des nach der Kalibrierung in die Messanordnung eingefügten Übertragungsmediums (beispielsweise Kabel oder Testadapter) in das Feld ein, oder wählen Sie den Wert durch Anklicken der Pfeile. Der Standardwert für den "velocity factor" ist 1.0; dies entspricht der Lichtgeschwindigkeit im Vakuum (2,997925 x 108 m/s).

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Führen Sie eine Kalibrierung an der Messebene durch.

  2. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  3. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Menü Calibration und zu Port Extensions zu gelangen. Drücken Sie Click.

  4. Drücken Sie zum Aktivieren der "P ort extensions"-Funktion Click.

  5. Drücken Sie die Tab-rechts-Taste, um zu einem Input- oder Port-Feld zu gelangen. Geben Sie die Signallaufzeit zwischen der Messebene für den Eingang bzw. Port und dem zu messenden Bauteil in das Feld ein, oder wählen Sie den Wert durch Anklicken der Pfeile. Folgendermaßen können Sie feststellen, ob der eingegebene Laufzeitwert groß genug ist:

    1. Schließen Sie anstelle des Messobjekts einen Durchgangsadapter an (bzw. verbinden Sie die betreffenden Anschlüsse direkt miteinander).

    2. Stellen Sie den "Port extensions"-Wert so ein, dass sichj ein horizontaler Phasenfrequenzgang ergibt. (Beachten Sie, dass die meisten Kurzschlussnormale eine von Null verschiedene Laufzeit aufweisen; wenn Sie die Laufzeit wie beschrieben einstellen, resultiert daraus ein dem Doppelten der Kurzschlussnormal-Laufzeit entsprechender Laufzeitfehler.)

  6. Drücken Sie die Tab-rechts-Taste, um zum Feld Velocity Factor zu gelangen. Geben Sie den Ausbreitungsgeschwindigkeitsfaktor des nach der Kalibrierung in die Messanordnung eingefügten Übertragungsmediums (beispielsweise Kabel oder Testadapter) ein. Der Standardwert für den "velocity factor" ist 1.0; dies entspricht der Lichtgeschwindigkeit im Vakuum (2,997925 x 108 m/s).

  7. Drücken Sie OK.

Charakterisierung eines Durchgangsadapters

  1. Führen Sie eine vollständige SOLT-2-Port-Kalibrierung unter Verwendung gepaarter Adapter durch. Dieses Verfahren wird deshalb gewählt, weil das Messobjekt (In diesem Fall der Durchgangsadapter) ein nicht direkt anschließbares Bauteil ist.

  2. Messen Sie die Laufzeit des Durchgangsadapters bei etwa der Mittenfrequenz des interessierenden Frequenzbereichs. Notieren Sie den Messwert.

  3. Messen Sie die E infügedämpfung des Durchgangsnormals bei etwa der Mittenfrequenz des interessierenden Frequenzbereichs. Notieren Sie den Messwert.

  4. Tragen Sie die Messwerte in die Kalibrier-Kit-Definition des Durchgangsadapters ein. Wählen Sie hierzu im Kalibrierungsassistenten "Change Port". Siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

  5. Führen Sie eine Kalibrierung unter Verwendung des modifizierten Kalibrier-Kits durch, das jetzt den charakterisierten Durchgangsadapter enthält.

Durchführung einer Kalibrierung unter Verwendung zweier gepaarter Adapter

  1. Wählen Sie im Kalibrierungsassistenten eine vollständige SOLT-2-Port-Kalibrierung. Weitere Informationen über den Kalibrierungsassistenten finden Sie unter "Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung".

  2. Schließen Sie den Adapter A zwischen Port 1 und Port 2 an (siehe nachfolgende Abbildung).

  3. Wählen Sie im Dialogfenster "Measure Mechanical Standards" des Kalibrierungsassistenten den Kalibriernormaltyp "Thru".

  4. Entfernen Sie den Adapter A zwischen Port 1 und Port 2.

  5. Schließen Sie den Adapter B (das ist der Adapter mit dem zu Ihrem Messobjekt komplementären Steckverbinder-Geschlecht) an den passenden Port (in diesem Beispiel Port 1) an. Dieser Adapter wird zum Bestandteil der Messanordnung. Siehe nachfolgende Abbildung.

  6. Wählen Sie im Dialogfenster "Measure Mechanical Standards" des Kalibrierungsassistenten nacheinander die Kalibriernormaltypen "Open", "Short" und "Load".

    1. Schließen Sie, wenn der Kalibrierungsassistent Sie dazu auffordert, das gewählte Kalibriernormal für Port 1 an den Adapter B an.

    2. Verbinden Sie, wenn der Kalibrierungsassistent Sie dazu auffordert, das gewählte Kalibriernormal für Port 2 an das Ende des an Port 2 angeschlossenen Kabels an.

  7. Führen Sie (unter Verwendung des Adapters B) die gewünschten Messungen an Ihrem Messobjekt durch (siehe nachfolgende Grafik).

Hinweis: Der für die Kalibrierung verwendete Adapter B ist Bestandteil der Messanordnung. Das bedeutet, dass einer der beiden präzise gepaarten Adapter durch das Anschließen der Messobjekte mechanisch beansprucht wird und im Laufe der Zeit verschleißt. Alternativ zu dem beschriebenen Verfahren können Sie einen unter Verwendung von zwei gepaarten Adaptern charakterisierten Durchgangsadapter verwenden.


Gültigkeit der Kalibrierung

Siehe auch...

Gültigkeit einer Kalibrierung

Überblick

Konzepte

Wie wird eine Kalibrierung validiert?

Gelegentlich kann es vorkommen, dass Sie die Gültigkeit Ihrer Kalibrierung bezweifeln. Nachfolgend wird beschrieben, wie Sie herausfinden können, ob die Kalibrierdaten gültig sind und die Messgenauigkeit Ihren Anforderungen entspricht.
Konzepte

Wie kann man eine Kalibrierung validieren?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Keine Fehlerkorrektur ("No Cor")

Fehlerkorrektur eventuell ungenau ("C*")

Validierung der Kalibriergenauigkeit

Keine Fehlerkorrektur ("No Cor")

Wenn Sie die Wobbelbandbreite vergrößern, wird die Kalibrierung ungültig, und die F ehlerkorrektur wird deaktiviert (und zwar auch dann, wenn die Interpolationsfunktion aktiv ist). In diesem Fall wird in der Statuszeile der Hinweis "No Cor" (keine Fehlerkorrektur) angezeigt.

Fehlerkorrektur fraglich ("C*")

Interpolation

Die Interpolationsfunktion ist standardmäßig aktiv. Wenn Sie eine der folgenden Einstellungen vornehmen, kann dies die Kalibriergenauigkeit beeinträchtigen. In diesem Fall wird in der Statuszeile der Hinweis "C*" (Fehlerkorrektur fraglich) angezeigt.

  • Wobbelbandbreite verkleinern

  • Anzahl der Messkurvenpunkte verringern

Bei aktiver Interpolationsfunktion berechnet der Analysator automatisch anhand der ursprünglichen Fehlerterme die Fehlerkorrekturdaten für die neuen Einstellungen. Dadurch verschlechtert sich die Messgenauigkeit. Das Ausmaß des Genauigkeitsverlusts hängt von der Stärke der Amplituden- und Phasenschwankungen zwischen den Messkurvenpunkten ab. Je geringer diese Schwankungen sind, desto genauer ist die interpolierte Fehlerkorrektur. Beachten Sie jedoch, dass die Systemgenauigkeit bei Messungen mit interpolierter Fehlerkorrektur nicht spezifiziert ist.

Hinweis: Wenn in der Statuszeile der Hinweis "C*" angezeigt wird, ist die Gültigkeit der Kalibrierung fraglich. Sie können herausfinden, ob dies ein Problem darstellt, indem Sie eine Messkurve, die mit der ursprünglichen Kalibrierung (Statuszeilen-Anzeige "C") erfasst wurde, mit der aktuellen Messkurve (Statuszeilen-Anzeige "C*") vergleichen. Je nachdem, wie sehr sich die beiden Messkurven voneinander unterscheiden und welche Genauigkeit Ihre Anwendung erfordert, können Sie entscheiden, ob die Kalibrierung noch Ihren Anforderungen entspricht oder nicht. Siehe "Validierung der Kalibriergenauigkeit".

Wenn Sie bei deaktivierter Interpolation die oben genannten Einstellungen ändern, wird die Kalibrierung ungültig und die Fehlerkorrektur deaktiviert. In diesem Fall wird in der Statuszeile der Hinweis "No Cor" (keine Fehlerkorrektur) angezeigt.

Fragliche Fehlerkorrektur

Wenn Sie eine der folgenden Einstellungen ändern, kann sich dadurch die Kalibriergenauigkeit verschlechtern, weil kein Algorithmus vorgesehen ist, der den Einfluss dieser Änderungen korrigiert. In diesem Fall wird in der Statuszeile der Hinweis "C*" (Fehlerkorrektur fraglich) angezeigt.

  • Wobbelzeit

  • ZF-Bandbreite

  • Signalpegel (für Port 1 oder 2) / Abschwächung

  • Stufenweise Wobbelung ein/aus

Hinweis: Die höchste Fehlerkorrekturgenauigkeit wird nur dann erzielt, wenn bei der Messung der gleiche Signalpegel verwendet wird wie bei der Kalibrierung. Wenn Sie jedoch den Signalpegel nur innerhalb des bei der Kalibrierung verwendeten Abschwächerbereichs ändern, vermindert sich die Genauigkeit von S-Parameter-Messungen nur geringfügig. Wenn Sie einen anderen Abschwächerbereich wählen, verringert sich dadurch die Messgenauigkeit etwas mehr.

Validierung der Kalibriergenauigkeit

Sie können die Genauigkeit einer Kalibrierung nach einer der beiden nachfolgend beschriebenen Methoden validieren.

  1. Stellen Sie unmittelbar nach erfolgter Kalibrierung eine Durchgangsverbindung zwischen den Messanschlüssen her, und speichern Sie die Messergebnisse im Internspeicher des Analysators oder auf eine Diskette ab. Wenn Sie später die Gültigkeit der Kalibrierung überprüfen möchten, führen Sie die gleiche Messung (unter Verwendung der gleichen Kabel und Durchgangsstecker) nochmals durch, laden die gespeichert Messkurve und verglichen sie mit der aktuellen Messkurve. Bei höheren Anforderungen an die Messgenauigkeit gehen Sie folgendermaßen vor:

    • Vergleichen Sie die Ergebnisse aktueller Transmissionsmessungen mit denen zum Zeitpunkt der Kalibrierung.

    • Vergleichen Sie die Ergebnisse aktueller Reflexionsmessungen mit denen zum Zeitpunkt der Kalibrierung.

Hinweis:Durch Laden von G renzwertlinien können Sie schnell feststellen, ob die Kalibrierung innerhalb der zulässigen Toleranz liegt (und daher gültig ist).

  2. Schnell-Check

  • Gelegentlich kann es vorkommen, dass Sie die Gültigkeit Ihrer Kalibrierung bezweifeln und in Erwägung ziehen, die Kalibrierung zu wiederholen. Bevor Sie sich die Zeit nehmen, eine Kalibrierung zu wiederholen, sollten Sie den nachfolgend beschriebenen Schnell-Check durchführen. Falls sich dabei herausstellt, dass die Kalibrierung noch gültig ist, haben Sie eine Menge Zeit gespart.

  • Zur Überprüfung der Kalibrierqualität können Sie unmittelbar nach einer Kalibrierung den Schnell-Check durchführen.

  • Wenn bei den Schnell-Checks nach der Kalibrierung wiederholt Probleme auftreten, sollten Sie eine vollständige Verifikation unter Verwendung eines Verifikations-Kits durchführen (siehe Service-Handbuch)

Hinweis: Kurzschluss- und Leerlauf-Kalibriernormale besitzen eine gewisse elektrische Länge. Der Analysator kompensiert diese elektrische Länge durch einen entsprechenden Kalibrierdaten-Offset. Wenn Sie ein Kurzschluss- oder Leerlauf-Kalibriernormal nach der Kalibrierung nochmals messen, erscheint es nicht als ein Normal mit der elektrischen Länge null. Dies ist ein Indiz dafür, dass Ihr Analysator ordnungsgemäß funktioniert.

Klicken Sie auf eine der Schaltflächen, um zu einer Beschreibung der jeweiligen Prozedur zu gelangen:
Schnell-Check

Aktivieren/deaktivieren der Interpolation

Hinweis: Bei den folgenden Prozeduren bezieht sich "Port" immer auf die Messebene. Informationen über die Messebene siehe unter "Genaue Kalibrierung".

Schnell-Check

Reflexions-Check

Hinweis: Diese Prozedur beschreibt S11-Messungen an Port 1. Die Prozedur für S22-Messungen an Port 2 ist analog.

Hinweis: Verwenden Sie für diese Prozedur nicht die gleichen Kalibriernormale wie für die ursprüngliche Kalibrierung. Messungen unter Verwendung der gleichen Kalibriernormale würden lediglich die Reproduzierbarkeit der während der ursprünglichen Kalibrierung vorgenommenen Korrekturen bestätigen.

  1. Lassen Sie den Port 1 offen, und vergewissern Sie sich, dass die Amplitude von S11 etwa 0 dB (± 1 dB) beträgt.

  2. Schließen Sie ein Lastnormal an den Port 1 an. Die Amplitude von S11 sollte, je nach Last weniger als –30 dB bis –40 dB betragen.

  3. Schließen Sie ein Leerlauf- oder Kurzschlussnormal an den Port 1 an. Die Amplitude von S11 sollte etwa 0 dB (± einige Zehntel dB) betragen.

Transmissions-Check

Hinweis: Diese Prozedur beschreibt S21-Messungen. Die Prozedur für S12-Messungen ist analog.

  1. Schließen Sie ein Durchgangsnormal zwischen Port 1 und Port 2 an. Die Amplitude von S21 sollte etwa 0 dB (± einige Zehntel dB) betragen.

  2. Schließen Sie zur Überprüfung von S21 (Isolation) zwei Lastnormale an: eines an Port 1 und eines an Port 2. Die Amplitude von S21 sollte, je nach ZF-Bandbreite, weniger als –60 dB betragen.

Aktivieren/deaktivieren der Interpolation
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie im Calibration-Menü die OptionInterpolation.

  2. Die Standardeinstellung ist I nterpolation ON.

  3. Wenn Sie die Interpolation aktivieren möchten (ON), klicken Sie auf die Option, sodass Interpolation ON/off angezeigt wird.

  4. Wenn Sie die Interpolation deaktivieren möchten (OFF), klicken Sie auf die Option, sodass Interpolation on/OFF angezeigt wird.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste, um zum Calibration-Menü zu gelangen.

  3. Drücken Sie die Pfeil-unten-Taste, um zum Interpolation-Menü zu gelangen.

  4. Die Interpolation ist standardmäßig aktiv (ON).

  5. Wenn Sie die Interpolation aktivieren möchten (ON) drücken Sie Click, sodass Interpolation ON/off angezeigt wird.

  6. Wenn Sie die Interpolation deaktivieren möchten (OFF) drücken Sie Click, sodass Interpolation on/OFF angezeigt wird.


Siehe auch...

Marker

Überblick

Marker-
typen

Marker-
funktionen

Wie aktiviert
und ändert man
Marker?

Wie durchsucht man
eine Messkurve?

Die Marker ermöglichen es Ihnen, numerische Messdaten aus einer Messkurve abzulesen, eine Messkurve nach bestimmten Stimulus- oder Response-Werten zu durchsuchen, oder Stimulus-Einstellungen zu ändern. Dieses Thema behandelt sämtliche Aspekte der Marker.
Markertypen, Referenzmarker and Suche

Markerfunktionen, diskrete Marker und Markeranzeige

Wie aktiviert man Marker, ändert man Einstellungen, ändert man das Anzeigeformat?

Wie sucht man bestimmte Daten und wie benutzt man Relativmarker?

Pro Messkurve sind bis zu zehn Marker verfügbar.
Markertypen

"Normal"

"Fixed" (fest)

Referenz-Marker

Marker-Suche

Suche-Typen

Was ist eine "Spitze"?

Suchbereich

Ausführung der Suche

Markertypen

Es gibt zwei Markertypen: "Normal" und "Fixed".

"Normal"

Ein normaler Marker hat eine fest vorgegebene Stimulus-Position (bei rechtwinkligen Koordinatensystemen ist dies die X-Achsen-Position) und reagiert auf Änderungen des Response-Wertes (Y-Achse). Durch Ändern des Stimulus-Wertes kann der Marker in horizontaler Richtung entlang der Messkurve verschoben werden. Dieser Markertyp kann zusammen mit einem der Suche-Typen dazu verwendet werden, interessierende Daten zu lokalisieren.

"Fixed" (fest)

Ein fester Marker besitzt eine fest vorgegebene Response-Position (bei rechtwinkligen Koordinatensystemen ist dies die Y-Achsen-Position) und reagiert nicht auf Änderungen des Response-Wertes. Er kann durch Ändern des Stimulus-Wertes in horizontaler Richtung entlang der Messkurve verschoben werden (bei rechtwinkligen Koordinatensystemen entlang der X-Achse), behält dabei aber seine Y-Achsen-Position bei. Diesen Markertyp können Sie dazu verwenden, nach Änderungen am Messobjekt einen schnellen "Vorher/Nachher"-Vergleich durchzuführen. Mit Hilfe fester Marken können Sie beispielsweise die Unterschiede von Messergebnissen vor und nach dem Abgleich eines Filters bestimmen.

Referenz-Marker

Mit diesem Markertyp können Sie Werte relativ zu einer Referenzposition bestimmen.

  • Setzen Sie zuerst einen Referenz-Marker auf die Position, die zur Referenzposition werden soll.

  • Setzen Sie dann einen zweiten Marker (Delta-Marker) auf die Position, deren Wert relativ zur ersten Position gemessen werden soll.

Die für den Delta-Marker angezeigten Stimulus- und Response-Werte sind auf die Stimulus- und Response-Werte des Referenz-Markers bezogen.

Sie können einen Referenz-Marker wahlweise mit Hilfe des Dialogfensters im Marker-Menü oder mit Hilfe der Marker-Symbolleiste positionieren. Alternativ können Sie hierzu S CPI- oder COM-Befehle verwenden.

Hinweis: Wenn Sie einen Delta-Marker erstellen, ohne zuvor den Referenz-Marker zu aktivieren, wird der Referenz-Marker automatisch aktiviert. Allerdings müssen Sie auch in diesem Fall den Referenz-Marker selbst auf die gewünschte Position setzen.

Marker-Suche

Sie können Marker dazu verwenden, Messkurven nach bestimmten Kriterien zu durchsuchen.

Suche-Typ

Es sind sieben verschiedene Arten der Marker-Suche (sogenannte "Suche-Typen") verfügbar.

  • M ax im um:

Der Marker sucht das Maximum der Messkurve.

  • Minim um:

Der Marker sucht das Minimum der Messkurve.

  • Next Peak:

Der Marker sucht die (im Vergleich zu seiner Startposition) nächstniedrigere Spitze.
(Siehe "Was ist eine Spitze?")

  • Peak Left:

Der Marker sucht die nächste gültige Spitze links von seiner Startposition auf der X-Achse (bei rechtwinkligen Koordinatensystemen).
(Siehe "Was ist eine Spitze?")

  • Peak Right:

Der Marker sucht die nächste gültige Spitze rechts von seiner Startposition auf der X-Achse (bei rechtwinkligen Koordinatensystemen).
(Siehe "Was ist eine Spitze?")

  • Target Search:

D er Marker sucht den Datenpunkt, der dem von Ihnen spezifizierten Zielwert entspricht.

    • In der Betriebsart Discrete Marker OFF sucht der Marker den interpolierten Datenpunkt, der dem Zielwert entspricht.

    • In der Betriebsart Discrete Marker ON sucht der Marker, falls auf jeder Seite des Ziel-Datenwertes je ein passender Datenpunkt vorhanden ist, den Datenpunkt, der dem Zielwert am nächsten ist.

Der Marker sucht den dem Zielwert am nächsten kommenden Datenpunkt rechts von der aktuellen Position. Wenn Sie wiederholt die Taste Execute drücken, wird der Marker jeweils auf den nächsten Punkt rechts von der aktuellen Position gesetzt, der dem Zielwert entspricht. Wenn der Marker die obere Grenze des Stimulusbereichs erreicht hat, springt er an den Anfang des Stimulusbereichs (linker Bildschirmrand), und die Suche beginnt von vorne.

  • Bandwidth:

Der Marker bestimmt die Bandbreite des Bereichs links und rechts von der Spitze, in dem die Response-Werte größer als der Spitzenwert minus dem Schwellenwert (dB) sind (Data > Peak - Threshold).

Dieser Suche-Typ verwendet immer die Marker 1-4.
Marker 1: Spitze
Marker 2: Punkt "Spitzenwert minus Schwellenwert" links von der Spitze
Marker 3: Punkt "Spitzenwert minus Schwellenwert" rechts von der Spitze
Marker 4: Mittenfrequenz des Bandbreitenbereichs

Beispiel für eine Bandbreitensuche: Bestimmung der 3 dB-Bandbreite eines Filters. In diesem Fall beträgt der Schwellenwert 3.00 dB (–3.00 dB bezogen auf den Spitzenwert des Durchlassbereichs).

Hinweis: Falls bei einer der oben beschriebenen Such-Operationen kein dem Suchkriterium entsprechender Datenwert gefunden wird, bleibt der Marker an seiner ursprünglichen Position.

Was ist eine "Spitze"?

Der Analysator bestimmt anhand zweier Kriterien, die Sie selbst definieren können, welche Datenwerte als "Spitze" gewertet werden und welche nicht.

  • Threshold - Minimalpegel (dB). Damit ein Datenpunkt als Spitze gewertet wird, muss der Response-Wert über dem "Threshold"-Wert liegen. Die "Täler" auf beiden Seiten der Spitze können unter dem "Threshold"-Wert liegen.

  • Excursion - Der vertikale Abstand (dB) zwischen der Spitze und den "Tälern" auf beiden Seiten. Damit ein Datenpunkt als Spitze gewertet wird, müssen die Datenpunkte rechts und links von dem betreffenden Punkt mindestens um den "Excursion"-Wert kleiner sein als der betreffende Datenpunkt.

Beispiel:

"Threshold"-Einstellung: -10dB
"Excursion"-Einstellung: 1dB
Skalierung = 1 dB/Skt.
Spitze A = gültige Spitze (über "Threshold"- und "Excursion"-Werten)
"Spitze" B = ungültige Spitze (unter "Excursion"-Wert)
"Spitze" C = ungültige Spitze (unter "Threshold"-Wert)

Suchbereich

Die Suchbereich-Einstellungen beschränken die durchsuchten Stimulus-Werte (X-Achsen-Werte bei rechtwinkligen Koordinatensystemen) auf einen bestimmten Bereich. Sie können solche User-Bereiche durch Eingabe von Start- und Stop-Stimulus-Werte spezifizieren. Wenn der Startwert größer als der Stopwert ist, bleibt der Marker an seiner ursprünglichen Position. Die nachfolgende Abbildung zeigt Beispiele für Suchbereiche.

  • Der Standard-Suchbereich für jeden neuen Marker ist "Full Span" (volle Wobbelbandbreite).

  • In jedem Kanal sind bis zu neun benutzerdefinierte Suchbereiche verfügbar.

  • Die benutzerdefinierten Suchbereiche können einander überlappen.

  • Ein benutzerdefinierter Suchbereich kann von mehreren Markern durchsucht werden.

Durchführung einer Suche

Zum Starten einer Marker-Suche müssen Sie die Taste Execute drücken. Dies gilt für alle Suche-Typen.

Wenn das Kontrollkästchen Tracking aktiviert ist, hat dies die gleiche Wirkung, als wenn Sie nach jedem Wobbelzyklus die Taste Execute drücken: die Suchergebnisse werden dann nach jedem Wobbelzyklus aktualisiert.

Hinweis: Die Suche beginnt mit dem ersten Wobbelzyklus nach dem Anklicken des Kontrollkästchens Tracking; die Suche erfolgt auf der Basis der zuletzt eingegebenen Suche-Typ- und Suchbereich-Informationen. In der Betriebsart Tracking ON sollten Sie sicherstellen, dass die Suchkriterien im gewünschten Zustand sind, bevor Sie die Daten benutzen.

Hinweis: Wenn für einen Marker die Option Tracking gewählt wurde, können Sie den Stimulus-Wert dieses Markers nicht manuell ändern.

Durch Anklicken der Schaltfläche gelangen Sie zu weiteren Informationen.
Marker-Funktionen

"Start"

"Stop"

"Center"

"Span"

"Ref Level"

"Delay"

Diskrete Marker

Marker-Anzeige

Marker-Datenformat

Marker-Tabelle

Markerfunktionen – Ändern von Einstellungen

Sie können folgende Einstellungen mit Hilfe von Markern ändern:

Start:

Der Stimulus-Wert (X-Achsen-Wert bei rechtwinkligen Koordinatensystemen) des aktiven Markers wird zum Start-Stimulus-Wert (Frequenz, Zeit oder Pegel).

Stop:

Der Stimulus-Wert (X-Achsen-Wert bei rechtwinkligen Koordinatensystemen) des aktiven Markers wird zum Stop-Stimulus-Wert (Frequenz, Zeit oder Pegel).

Center:

Der Stimulus-Wert (X-Achsen-Wert bei rechtwinkligen Koordinatensystemen) des aktiven Markers wird zum Mitten-Stimulus-Wert (Frequenz, Zeit oder Pegel). Die Start- und Stopwerte werden automatisch so angepasst, dass die Wobbelbandbreite konstant bleibt.

Span:

Diese Funktion ist nur verfügbar, wenn der aktive Marker ein Delta-Marker ist. Die Differenz der Stimulus-Werte (X-Achsen-Werte bei rechtwinkligen Koordinatensystemen) zwischen den beiden Markern wird zur "Span"-Einstellung. Der untere Marker-Wert wird zum Startwert und der obere zum Stopwert. (Diese Funktion kann nur im Dialogfenster Marker Functions oder in der Marker-Symbolleiste gewählt werden.)

Ref Level:

Der Response-Wert (Y-Achsen-Wert bei rechtwinkligen Koordinatensystemen) des aktiven Markers wird zum Referenzlinienwert für die Referenzlinie des betreffenden Fensters.

Delay:

Die elektrische Länge vor dem Empfängereingang wird anhand der Steilheit der Phasenkurve an der Stelle des aktiven Markers so eingestellt, dass sich im Bereich um den aktiven Marker herum ein horizontaler Phasenfrequenzgang ergibt. (Weitere Elektrische-Länge-Einstellungen sind erforderlich, falls das Messobjekt innerhalb der Wobbelbandbreite keine konstante Gruppenlaufzeit aufweist. ) Sie können diese Funktion dazu verwenden, die elektrische Länge oder die Abweichung vom linearen Phasenfrequenzgang zu bestimmen.

Diese Funktion bewirkt außer einer frequenzabhängigen Phasenkorrektur eine konstante Phasenverschiebung; sie ist daher nur auf Verhältnismessungen anwendbar. (Siehe Messparameter.)

Der aktive Marker wird auf dem Bildschirm durch das Symbol Ñ dargestellt. Alle anderen Marker sind inaktiv und werden durch das Symbol D dargestellt.

"Discrete Marker"

  • In der Betriebsart Discrete Marker OFF sucht der Marker den interpolierten Datenpunkt zu dem spezifizierten Stimulus-Wert.

  • In der Betriebsart Discrete Marker ON sucht der Marker den tatsächlichen Datenpunkt, der dem spezifizierten Stimulus-Wert am nächsten ist.

Hinweis: In der Betriebsart Discrete Marker ON wird der Stimulus-Wert mit einiger Wahrscheinlichkeit vom spezifizierten Wert abweichen.

Marker-Anzeige

Sie können die Art und Weise, wie die Marker-Informationen angezeigt werden, ändern.

Marker-Datenformat

Das Standardformat für die Marker-Anzeige ist das gleiche wie das für die Messkurve ("Trace Default"). Unabhängig von der jeweiligen Messkurvendarstellung können Sie jedoch für die Marker-Anzeige eines von zwölf Formaten frei wählen. Auf diese Weise können Sie unter Umständen die Anzahl der benötigten Bildschirmfenster reduzieren. Es stehen folgende Formate zur Auswahl:

  • "Trace Default"

  • "Log / Phase"

  • "Lin / Phase"

  • "Re / Im"

  • "R + jX"

  • "G + jB"

  • "Log Magnitude"

  • "Linear Magnitude"

  • "Phase"

  • "SWR"

  • "Delay"

  • "Real"

  • "Imaginary"

Die folgende Abbildung zeigt Marker mit unterschiedlichen Datenformaten.

Marker-Tabelle

Sie können eine Tabelle mit einer Zusammenfassung der Marker-Werte für die aktive Messkurve abrufen. Die Marker-Werte werden für jeden Marker in dem spezifizierten Format angezeigt (siehe obige Abbildung).

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Aktivieren eines Markers

Ändern von Analysatoreinstellungen

Anzeigen der Marker-Werte

Ändern des Marker-Anzeigeformats

Aktivieren eines Markers
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie die gewünschte Messkurve, indem Sie im "Trace Status"-Bereich des Fensters darauf klicken. (Informationen über die "Trace Status"-Anzeige siehe Anpassen der Bildschirmanzeigen.)

  2. Klicken Sie im Marker-Menü auf Marker.

  3. Wählen Sie im Marker-Teil des Dialogfensters die Marker-Nummer.

  4. Klicken Sie zum Aktivieren des gewählten Markers auf das Kontrollkästchen On.

  5. Geben Sie im Bereich Stimulus des Dialogfensters die gewünschte Marker-Position ein.

  6. Klicken Sie auf die Schaltfläche Advanced. (Die Schritte 6-9 sind optional).

  7. Wählen Sie den Marker Type:

    • Normal (Standardtyp)

    • Fixed

  8. Wählen Sie im Feld Discrete marker das gewünschte Marker-Verhalten:

    • Interpolated (Standardeinstellung, Kontrollkästchen nicht angekreuzt)

    • Discrete

  9. Klicken Sie auf OK.

Hinweis: Marker können auch über die Marker-Symbolleiste aktiviert werden (siehe Schritte 1, 3, 4 und 5 der obigen Prozedur). (Informationen über die Marker-Symbolleiste siehe Anpassen der Bildschirmanzeigen.)

Tastenprozedur

  1. Wählen Sie die gewünschte Messkurve. Drücken Sie die Taste Trace im Tastenfeld DISPLAY. Drücken Sie so oft F2 (Next Trace), bis die gewünschte Messkurve gewählt ist.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker.

  3. Drücken Sie F1 (Marker 1) oder F2 (Marker 2) oder F3 (Marker 3), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP.

  5. Drücken Sie F1 (Marker 4) oder F2 (Marker 5) oder F3 (Marker 6), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

  6. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP.

  7. Drücken Sie F1 (Marker 7) oder F2 (Marker 8) oder F3 (Marker 9), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

Wählen Sie den Marker Type ("Normal" oder "Fixed") und das Marker-Verhalten ("Interpolated" oder "Discrete"):

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie Marker im Tastenfeld TRACE SETUP.

  2. Wählen Sie mit der Tab-rechts-Taste die Schaltfläche Advanced im Marker-Dialogfenster. Drücken Sie "Click".

  3. Wählen Sie mit der Tab-rechts-Taste das Kontrollkästchen Discrete marker. Drücken Sie zur Wahl des Marker-Verhaltens Discrete die "Click"-Taste. (Die Standardeinstellung ist Interpolated).

  4. Wählen Sie mit der Tab-rechts-Taste das Kontrollkästchen Marker Type. Wählen Sie mit der Pfeil-unten-Taste Fixed. (Die Standardeinstellung ist Normal).

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Ändern von Analysatoreinstellungen mit Hilfe von Markern
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie die gewünschte Messkurve, indem Sie im "Trace Status"-Bereich des Fensters darauf klicken. (Informationen über die "Trace Status"-Anzeige siehe Anpassen der Bildschirmanzeigen.)

  2. Klicken Sie im Marker-Menü auf Select Marker. Klicken Sie auf die gewünschte Marker-Nummer.

  3. Klicken Sie im Marker-Menü auf Marker Function.

  4. Klicken Sie auf die Analysatoreinstellung, die Sie ändern möchten:

    • Start:

    • Stop

    • Center

    • Ref Level

    • Delay

  5. Klicken Sie auf OK.

Hinweis: Analysatoreinstellungen können auch über die Marker-Symbolleiste geändert werden (gilt nur für Start, Stop, Center und Span). (Informationen über die Marker-Symbolleiste siehe Anpassen der Bildschirmanzeigen.)

Tastenprozedur

  1. Wählen Sie die gewünschte Messkurve. Drücken Sie die Taste Trace im Tastenfeld DISPLAY. Drücken Sie so oft F2 (Next Trace), bis die gewünschte Messkurve gewählt ist.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker.

  3. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 1) oder F2 (Marker 2) oder F3 (Marker 3).

  4. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 4) oder F2 (Marker 5) oder F3 (Marker 6).

  5. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 7) oder F2 (Marker 8) oder F3 (Marker 9).

  6. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker Function.

  7. Wählen Sie die Funktion, die Sie ändern möchten:

    • F1 (Center)

    • F2 (Ref Level)

    • F3 (Delay)

Zum Ändern anderer Marker-F unktionen (Start oder Stop) gehen Sie folgendermaßen vor:

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie Marker Function im Tastenfeld TRACE SETUP.

  2. Wählen Sie mit der Tab-rechts-Taste die gewünschte Marker-Funktion.

  3. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Anzeigen der Marker-Werte
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Marker-Menü auf Marker Table.

  2. Klicken Sie auf Show Table.

Hinweis: Die Marker-Tabelle und die Marker-Anzeige können auch im View-Menü aktiviert werden. (Siehe Anpassen der Bildschirmanzeigen.)

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker Table.

  2. Drücken Sie zum Verbergen der Marker-Tabelle F4 (Hide).

Ändern des Marker-Anzeigeformats
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie die gewünschte Messkurve, indem Sie im "Trace Status"-Bereich des Fensters darauf klicken. (Informationen über die "Trace Status"-Anzeige siehe Anpassen der Bildschirmanzeigen.)

  2. Klicken Sie im Marker-Menü auf Marker. Klicken Sie anschließend auf Advanced.

  3. Wählen Sie im Marker-Teil des Dialogfensters die gewünschte Marker-Nummer.

  4. Wählen Sie im Format-Teil des Dialogfensters das gewünschte Marker-Datenformat.

  5. Klicken Sie auf OK.

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie Marker im Tastenfeld TRACE SETUP.

  2. Wählen Sie mit der Tab-rechts-Taste die Schaltfläche Advanced im Marker-Dialogfenster. Drücken Sie die Taste "Click".

  3. Wählen Sie mit der Pfeil-unten-Taste im Tastenfeld NAVIGATION die gewünschte Marker-Nummer.

  4. Wählen Sie mit der Tab-rechts-Taste das Feld Format. Wählen Sie mit der Pfeil-unten-Taste das gewünschte Marker-Format.

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK.

  6. Drücken Sie im Tastenfeld COMMAND die Taste OK.

.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Suche nach Daten

Durchführung von Relativmessungen

Suche nach Daten
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie die gewünschte Messkurve, indem Sie im "Trace Status"-Bereich des Fensters darauf klicken. (Informationen über die "Trace Status"-Anzeige siehe Anpassen der Bildschirmanzeigen.)

  2. Klicken Sie im Marker-Menü auf Marker Search.

  3. Wählen Sie im Marker-Teil des Dialogfensters die gewünschte Marker-Nummer.

  4. Wählen Sie im Search Type-Teil des Dialogfensters den gewünschten Suche-Typ.

    • Für Next Peak, Peak Left oder Peak Right: Geben Sie die gewünschten Threshold- und Excursion-Werte ein.

    • Für Target: Geben Sie den gewünschten Target-Wert ein.

    • Für Bandwidth: Geben Sie den Bezugspegel ein.

  5. Wählen Sie im Search Domain-Teil des Dialogfensters den gewünschten Suchbereich. Wenn Sie einen anderen Suchbereich als Full Span (Standardeinstellung) wählen, erscheint der Bereich User Span des Dialogfensters. Geben Sie die gewünschten Start- und Stop-Werte für den benutzerdefinierten Suchbereich ein.

  6. Starten Sie die Suche:

    • Manuell – klicken Sie auf die Schaltfläche Execute.

    • Automatisch – klicken Sie auf das Kontrollkästchen Tracking. (Wenn die markierten Daten sich ändern, wird automatisch eine neue Suche gestartet.)

  7. Klicken Sie auf OK.

Tastenprozedur

  1. Wählen Sie die gewünschte Messkurve. Drücken Sie die Taste Trace im Tastenfeld DISPLAY. Drücken Sie so oft F2 (Next Trace), bis die gewünschte Messkurve gewählt ist.

  2. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 1) oder F2 (Marker 2) oder F3 (Marker 3).

  3. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 4) oder F2 (Marker 5) oder F3 (Marker 6).

  4. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP. Drücken Sie zum Wählen des gewünschten Markers F1 (Marker 7) oder F2 (Marker 8) oder F3 (Marker 9).

  5. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker Search.

  6. Wählen Sie den gewünschten Suche-Typ:

    • F1 (Max)

    • F2 (Min)

    • F3 (Left Peak)

    • F4 (Right Peak)

So spezifizieren Sie weitere Marker Search-Parameter:

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie Marker Search im Tastenfeld TRACE SETUP.

  2. Wählen Sie mit der Pfeil-unten-Taste die gewünschte Marker-Nummer.

  3. Wählen Sie mit der Tab-rechts-Taste den Bereich Search Type im Marker-Dialogfenster. Wählen Sie mit der Pfeil-unten-Taste den gewünschten Suche-Typ. Navigieren Sie mit der Tab-rechts-Taste zu dem Eingabefeld (oder den Eingabefeldern) für den gewählten Suche-Typ:

    • Für Next Peak, Peak Left oder Peak Right: Geben Sie die gewünschten Threshold- und Excursion-Werte ein.

    • Für Target: Geben Sie den gewünschten Target-Wert ein.

    • Für Bandwidth: Geben Sie den gewünschten Threshold-Wert ein.

  4. Wählen Sie mit der Tab-rechts-Taste den Bereich Search Domain im Marker-Dialogfenster. Wählen Sie mit der Pfeil-unten-Taste den gewünschten Suchbereich.

    • Wenn Sie einen anderen Suchbereich als Full Span (Standardeinstellung) wählen, erscheint der Bereich User Span des Dialogfensters. Navigieren Sie mit der Tab-rechts-Taste zum Bereich User Span, und geben Sie die gewünschten Start- und Stop-Werte ein.

  5. Drücken Sie zum Starten der Suche die Tab-rechts-Taste und wählen Sie durch Drücken der Taste "Click" den gewünschten Modus:

    • Manuell – klicken Sie auf die Schaltfläche Execute.

    • Automatisch – klicken Sie auf das Kontrollkästchen Tracking. (Wenn die markierten Daten sich ändern, wird automatisch eine neue Suche gestartet.)

  6. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Durchführung von Relativmessungen mit Hilfe von Referenz-Markern
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Wählen Sie die gewünschte Messkurve, indem Sie im "Trace Status"-Bereich des Fensters darauf klicken. (Informationen über die "Trace Status"-Anzeige siehe Anpassen der Bildschirmanzeigen.)

  2. Klicken Sie im Marker-Menü auf Marker.

  3. Wählen Sie im Marker-Teil des Dialogfensters Reference.

  4. Klicken Sie zum Aktivieren des Referenz-Markers auf das Kontrollkästchen On.

  5. Geben Sie im Bereich Stimulus des Dialogfensters die gewünschte Referenz-Marker-Position ein.

  6. Wählen Sie im Marker-Bereich des Dialogfensters die Marker-Nummer für Messungen relativ zum Referenz-Marker.

  7. Klicken Sie zum Aktivieren des Markers auf das Kontrollkästchen On.

  8. Klicken Sie zum Aktivieren des Delta-Markers für Messungen relativ zum Referenz auf das Kontrollkästchen Delta marker.

Wählen Sie das Marker-Verhalten ("Interpolated" oder "Discrete") für die Referenz- und Delta-Marker:

  1. Klicken Sie auf die Schaltfläche Advanced im Dialogfenster Marker.

  2. Wählen Sie im Marker-Teil des Dialogfensters Reference.

  3. Wählen Sie im Feld Discrete marker das gewünschte Marker-Verhalten:

    • Interpolated (Standardeinstellung, Kontrollkästchen nicht angekreuzt)

    • Discrete

  4. Wählen Sie im Marker-Bereich des Dialogfensters die Marker-Nummer des Delta-Markers.

  5. Wiederholen Sie Schritt 3.

  6. Klicken Sie auf OK.

  7. Klicken Sie auf OK.

Hinweis: Marker für Relativmessungen können auch über die Marker-Symbolleiste aktiviert werden. (Informationen über die Marker-Symbolleiste siehe Anpassen der Bildschirmanzeigen.)

Tastenprozedur

  1. Wählen Sie die gewünschte Messkurve. Drücken Sie die Taste Trace im Tastenfeld DISPLAY. Drücken Sie so oft F2 (Next Trace), bis die gewünschte Messkurve gewählt ist.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Marker.

  3. Drücken Sie F1 (Marker 1) oder F2 (Marker 2) oder F3 (Marker 3), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP.

  5. Drücken Sie F1 (Marker 4) oder F2 (Marker 5) oder F3 (Marker 6), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

  6. Wenn Sie zusätzliche Marker aktivieren möchten, drücken Sie nochmals Marker im Tastenfeld TRACE SETUP.

  7. Drücken Sie F1 (Marker 7) oder F2 (Marker 8) oder F3 (Marker 9), und geben Sie die gewünschte Marker-Position ein, oder wählen Sie die Position mit Hilfe der Pfeil-oben/unten-Tasten.

Wählen Sie das Marker Verhalten ("Interpolated" oder "Discrete"):

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie Marker im Tastenfeld TRACE SETUP.

  2. Wählen Sie mit der Tab-rechts-Taste die Schaltfläche Advanced im Marker-Dialogfenster. Drücken Sie die Taste "Click".

  3. Wählen Sie mit der Pfeil-oben-Taste den Reference-Marker.

  4. Wählen Sie mit der Tab-rechts-Taste das Kontrollkästchen Discrete Marker. Drücken Sie zur Wahl des Marker-Verhaltens Discrete die "Click"-Taste. (Die Standardeinstellung ist Interpolated).

  5. Wählen Sie mit der Tab-rechts-Taste nochmals das Kontrollkästchen Marker. Wählen Sie mit der Pfeil-unten-Taste die Marker-Nummer des Delta-Markers.

  6. Wählen Sie mit der Tab-rechts-Taste das Kontrollkästchen Discrete Marker. Drücken Sie zur Wahl des Marker-Verhaltens Discrete die "Click"-Taste. (Die Standardeinstellung ist Interpolated).

  7. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Siehe auch...

Automatische Grenzwerttests

Überblick

Konzepte

Wie führt man automatische
Grenzwerttests durch?

Grenzwerte sind Leistungskenngrößen, die Sie für Ihr Messobjekt definieren. Grenzwertlinien und Grenzwerttests ermöglichen es Ihnen, Messdaten automatisch mit diesen Leistungskenngrößen zu vergleichen.
Konzepte

Einrichten und Durchführen von Grenzwerttests

Grenzwerte

Grenzwerttabelle

Grenzwertlinien

Grenzwerttest

Grenzwerte

Grenzwerte werden folgendermaßen definiert:

  • segmentweise, wobei jedes Segment ein Teil des vollen Stimulus-Wertebereichs ist;

  • als Maximum- oder Minimum-Grenzwert oder als OFF (kein Grenzwert);

  • durch Anfangs- und Ende-Stimulus-Werte für jedes Grenzwertsegment;

  • durch Anfangs- und Ende-Response-Werte für jedes Grenzwertsegment;

  • voneinander unabhängig für bis zu 16 Messungen, mit bis zu 100 Segmenten pro Messung.

Grenzwerttabelle

Grenzwerte werden in einer Grenzwerttabelle definiert, bearbeitet, aktiviert und angezeigt.

Grenzwertlinien

Grenzwertlinien zeigen die für den jeweiligen Kanal spezifizierten Grenzwerte auf dem Bildschirm an. Sie können Grenzwertlinien dazu verwenden,

  • um einem Benutzer beim Abgleich von Bauteilen eine visuelle Einstellhilfe zu geben;

  • um Kriterien für die Konformität mit einem Standard anzuzeigen, den ein Bauteil einhalten muss;

  • um Messdaten mit Spezifikationen zu vergleichen.

Sie können folgende Arten von Grenzwertlinien definieren:

  • flache

  • ansteigende/abfallende

  • aus einem einzigen Punkt bestehende

Sie können wählen, ob die Grenzwertlinien auf dem Bildschirm angezeigt oder verborgen werden. Für den Fall, dass die Grenzwertlinien angezeigt werden, gelten folgende Farbkonventionen:

  • Messkurven werden grün dargestellt (dies ist die typische Messkurvenfarbe).

  • Grenzwertlinien werden gelb dargestellt.

Hinweis: Die spezifizierten Grenzwerte sind auch dann gültig, wenn die Grenzwertlinien nicht angezeigt werden.

Grenzwerttest

Ein Grenzwerttest vergleicht die Messdaten automatisch mit den spezifizierten Grenzwerten und liefert eine "Pass"- oder "Fail"-Information (bestanden/nicht bestanden) für jeden einzelnen Datenpunkt.

Es werden nur die tatsächlich gemessenen Datenpunkte mit den Grenzwerten verglichen. Wenn die Messpunkte zu weit voneinander entfernt sind, kann es vorkommen, dass ein Bauteil außerhalb der Spezifikationen liegt, obwohl beim Grenzwerttest keine Grenzwertverletzung angezeigt wird. Die nachfolgende Abbildung zeigt ein Beispiel dafür.

  • Der Anfang der Grenzwertlinie liegt (bezogen auf die X-Achse) zwischen den Messpunkten A und B.

  • Das Ende der Grenzwertlinie liegt (bezogen auf die X-Achse) zwischen den Messpunkten B und C.

Im Bereich zwischen Anfangs- und Endpunkt der Grenzwertlinie liegt nur ein einziger Messpunkt. In diesem Fall liefert der Grenzwerttest das Ergebnis Pass, weil nur der Messpunkt B getestet wird und dieser oberhalb der Grenzwertlinie liegt. Für die Punkte A und C würde der Grenzwerttest das Ergebnis "Fail" liefern, doch werden diese Punkte nicht getestet.

Die folgende Abbildung zeigt die gleiche Messung, jedoch mit 51 Messpunkten. Jetzt liefert der Grenzwerttest die klare Aussage "Fail".

In diesem Fall waren mehr Messpunkte erforderlich, damit der Grenzwerttest eine sinnvolle Aussage liefert.

Aus dem obigen Messdiagramm mit eingeblendeten Grenzwertlinien ist ersichtlich:

  • Alle Teile der Messkurve mit Testergebnis fail sind rot dargestellt.

  • Alle Teile der Messkurve mit Testergebnis pass werden (unverändert) grün dargestellt.

Hinweis: Die nicht getesteten Bereiche der Messkurve werden unverändert grün dargestellt.

Die Grenzwertlinienanzeige und der Grenzwerttest können gleichzeitig oder voneinander unabhängig angewandt werden.

Die Grenzwertlinien- und Grenzwerttestfunktionen sind für die Formate "Smith Chart" und "Polar" nicht verfügbar. Wenn Sie auf das Format "Smith Chart" oder "Polar" umschalten, werden die Grenzwertlinien und die Grenzwerttestfunktion gegebenenfalls automatisch deaktiviert.

Hinweis: Grenzwerttests sind nur auf aktuelle Messkurven anwendbar und nicht auf gespeicherte Messkurven.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Definieren von Grenzwertliniensegmenten

Anzeigen oder Verbergen der Grenzwerttabelle

Anzeigen der Grenzwertlinien

Aktivieren der Grenzwerttestfunktion

Definieren von Grenzwertliniensegmenten
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Limit Test..., Show Table, OK.

  2. Wählen Sie im Bereich Type der Grenzwerttabelle MIN oder MAX für "Limit Segment 1".

  3. Klicken Sie auf den Bereich BEGIN STIMULUS für "Limit Segment 1". Geben Sie den gewünschten Wert ein.

  4. Klicken Sie auf den Bereich END STIMULUS für "Limit Segment 1". Geben Sie den gewünschten Wert ein.

  5. Klicken Sie auf den Bereich BEGIN RESPONSE für "Limit Segment 1". Geben Sie den gewünschten Wert ein.

  6. Klicken Sie auf den Bereich END RESPONSE für "Limit Segment 1". Geben Sie den gewünschten Wert ein.

  7. Wiederholen Sie die Schritte 4 bis 8 für alle gewünschten Segmente.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Limit Table.

  2. Drücken Sie zum Aufrufen der Grenzwerttabelle die Taste F3 (Show).

  3. Drücken Sie im Tastenfeld NAVIGATION die Taste Click; daraufhin werden die für "Limit Segment 1" verfügbaren Typen angezeigt. Wählen Sie mit der Pfeil-unten-Taste MIN oder MAX.

  4. Drücken Sie die Tab-rechts-Taste, um zum Bereich BEGIN STIMULUS für "Limit Segment 1" zu gelangen. Geben Sie über die ENTRY-Tasten den gewünschten Wert ein. Drücken Sie Enter.

  5. Drücken Sie die Tab-rechts-Taste, um zum Bereich END STIMULUS für "Limit Segment 1" zu gelangen. Geben Sie über die ENTRY-Tasten den gewünschten Wert ein. Drücken Sie Enter.

  6. Drücken Sie die Tab-rechts-Taste, um zum Bereich BEGIN RESPONSE für "Limit Segment 1" zu gelangen. Geben Sie über die ENTRY-Tasten den gewünschten Wert ein. Drücken Sie Enter.

  7. Drücken Sie die Tab-rechts-Taste, um zum Bereich END RESPONSE für "Limit Segment 1" zu gelangen. Geben Sie über die ENTRY-Tasten den gewünschten Wert ein. Drücken Sie Enter.

  8. Navigieren Sie mit der Tab-links-Taste und der Pfeil-unten-Taste zum nächsten Grenzwertliniensegment.

  9. Wiederholen Sie die Schritte 3 bis 8 für alle gewünschten Segmente.

Anzeigen oder Verbergen der Grenzwerttabelle
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Limit Test.

  2. Klicken Sie auf Show Table oder Hide Table.

  3. Klicken Sie auf OK.

Hier eine alternative Mausprozedur zum Anzeigen oder Verbergen der Grenzwerttabelle:

  1. Klicken Sie im View-Menü auf Tables.

  2. Klicken Sie auf Limit Table, um den Anzeigestatus zu ändern.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Limit Table.

  2. Drücken Sie F3 (Show) oder F4 (Hide).

Anzeigen der Grenzwertlinien
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Limit Test.

  2. Klicken Sie auf Limit Line ON.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Limit Table.

  2. Drücken Sie F2 (Line ON/Off), um die Grenzwertlinien anzuzeigen.

Aktivieren der Grenzwerttestfunktion
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Limit Test.

  2. Klicken Sie auf Limit Test ON.

  3. Klicken Sie auf Sound ON Fail, wenn Sie möchten, dass ein Signalton ertönt, wenn der Grenzwerttest "fail" ergibt.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Limit Table.

  2. Drücken Sie F1 (Test ON/Off), um den Grenzwerttest zu aktivieren.


Siehe auch...

Mathematische Operationen

Überblick

Konzepte

Wie führt man
mathematische Operationen aus?

Der Analysator kann vier verschiedene mathematische Operationen auf einer Kombination aus der aktiven Messkurve und einer gespeicherten Messkurve ausführen. Weiterhin kann der Analysator folgende statistische Werte für die aktive Messkurve berechnen und anzeigen: Mittelwert, Standardabweichung und Spitze-Spitze-Wert.
Konzepte

Wie führt man mathematische Operationen aus?

"Trace Math"-Funktionen

"Data / Memory"

"Data - Memory"

"Data * Memory"

"Data + Memory"

Messkurvenstatistiken

"Trace Math"-Funktionen

Vier verschiedene mathematische Operationen können auf einer angezeigten Messkurve ausgeführt werden.

  • "Data / Memory"

  • "Data - Memory"

  • "Data * Memory"

  • "Data + Memory"

Alle mathematischen Operationen werden auf den komplexen Messdaten ausgeführt, bevor diese für die Bildschirmdarstellung formatiert werden.

Wenn Sie eine der mathematischen Operationen ausführen möchten, müssen Sie zunächst eine gespeicherte Messkurve des Messobjekts (oder einen äquivalenten Datensatz) in den Speicher für den aktiven Kanal abspeichern. Die "Trace View"-Optionen ermöglichen es Ihnen, die gespeicherte Messkurve zusammen mit der aktuellen Messkurve darzustellen.

Hinweis: Alternativ können Sie mit Hilfe von SCPI- oder COM-Befehlen eine aus komplexen Wertepaaren bestehende "Messkurve" definieren und in den Internspeicher des Analysators abspeichern; diese "Messkurve" muss die gleiche Anzahl von Punkten aufweisen wie die aktuelle Messkurve. Die aktuelle Messung muss konfiguriert werden, bevor Sie die Daten in den Speicher laden. Der Analysator bildet die komplexen Wertepaare auf die Stimulus-Werte der aktuellen Messpunkte ab.

"Data / Memory"

"Data / Memory" ist die am häufigsten verwendete mathematische Operation. Sie können diese Operation dazu verwenden, um das Verhältnis zweier Messungen zu bestimmen; typische Anwendungen sind Verstärkungs- oder Abschwächungsmessungen.

  1. Wenn Sie diese Operation ausführen möchten, müssen Sie zunächst eine gespeicherte Messkurve des Messobjekts in den Speicher für den aktiven Kanal abspeichern.

  2. Anschließend können Sie durch Anwendung der Data / Memory-Funktion die aktuelle Messkurve durch die gespeicherte Messkurve dividieren.

  3. Der Analysator normiert die aktuelle Messkurve auf die gespeicherte Messkurve und zeigt das Ergebnis an.

  4. Stellen Sie die Daten im Format "Log Mag" dar, um die Abweichungen der aktuellen Messkurve von der gespeicherten Messkurve gut messen zu können.

"Data - Memory"

Data - Memory Diese Operation subtrahiert eine gespeicherte Messkurve vektoriell von der aktuellen Messkurve. Sie können diese Operation beispielsweise dazu verwenden, einen zuvor gemessenen vektoriellen Fehler von den Ergebnissen einer Bauteilmessung zu subtrahieren.

"Data * Memory" und "Data + Memory"

"Data + Memory" und "Data * Memory" bieten eine höchst effiziente Möglichkeit, eigene Formeln oder Algorithmen zu definieren und auf eine Messkurve anzuwenden; in diesem Fall enthält "Memory" keine echte Messkurve, sondern von Ihnen definierte Daten. Beispielsweise können Sie die Verstärkung eines hypothetischen Verstärkers im Signalweg vor dem Messobjekt folgendermaßen simulieren:

  1. Erstellen Sie einen Algorithmus, der den Frequenzgang des Verstärkers nachbildet.

  2. Geben Sie entsprechende komplexe Wertepaare ein; die Anzahl der Wertepaare muss der Anzahl der Messpunkte der Messkurve entsprechen.

  3. Laden Sie die Wertepaare mit Hilfe von SCPI- oder COM-Befehlen in den Speicher.

  4. Der Analysator bildet die komplexen Wertepaare auf die Stimulus-Werte der aktuellen Messpunkte ab.

  5. Verwenden Sie dann die Operation Data + Memory oder Data * Memory, um den Frequenzgang zu den Messdaten zu addieren oder ihn mit diesen zu multiplizieren. Weitere Informationen hierzu siehe COM Commands, PutComplex Method.

Hinweis: Die aktuelle Messung muss konfiguriert werden, bevor Sie die Daten in den Speicher laden.

Messkurvenstatistiken

Der Analysator kann folgende statistische Werte für die aktive Messkurve berechnen und anzeigen:

  • Mittelwert

  • Standardabweichung

  • Spitze-Spitze-Werte

Die Statistiken können wahlweise über die volle Wobbelbandbreite oder Teilbereiche davon berechnet werden. Sie können bis zu neun Bereiche pro Kanal spezifizieren. Diese benutzerdefinierten Bereiche sind die gleichen wie die für eine Marker-Suche im gleichen Kanal spezifizierten Suchbereiche; sie verwenden die gleichen Speicherregister und daher auch die gleichen Stimulus-Wertebereiche. Wenn Sie mit Hilfe der "Marker Search"-Funktionen Suchbereiche für einen Kanal spezifiziert haben, können Sie diese für die Statistikfunktionen "wiederverwenden", indem Sie einfach die betreffenden "User Ranges" wählen. Die benutzerdefinierten Bereiche für einen Kanal können einander überlappen.

Mit Hilfe der Statistikfunktionen können Sie beispielsweise den Spitze-Spitze-Wert der Welligkeit eines Filterfrequenzgangs im Durchlassbereich bestimmen, ohne die Minima und Maxima explizit suchen zu müssen.

Die statistischen Werte werden auf der Basis des zur Messkurvendarstellung verwendeten Formats berechnet.

  • Rechtwinklige Datenformate werden aus den Daten so berechnet, wie sie auf dem Bildschirm angezeigt werden.

  • Die Formate Polar oder Smith Chart werden so aus den Daten berechnet, als ob sie im Format Log Mag angezeigt würden.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Auswahl der mathematischen Operation

Einrichten der Statistikfunktionen

Auswahl einer mathematischen Operation
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Math/Memory.

  2. Klicken Sie auf Data>Memory, um die gewünschte Messkurve abzuspeichern.

  3. Wählen Sie im Data Math-Teil des Dialogfensters die gewünschte mathematische Operation.

  4. Wählen Sie im Trace View Options-Teil des Dialogfensters die gewünschte Messkurvenansicht.

  5. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Math/Memory.

  2. Drücken Sie F1 (Data>>Mem), um die gewünschte Messkurve abzuspeichern.

  3. Drücken Sie F2 (Data/Mem), um die Operation "Data/Memory" zu wählen.

  4. Drücken Sie F3 (Data Only), wenn nur die aktuelle Messkurve angezeigt werden soll.

  5. Drücken Sie F4 (DataMem), wenn sowohl die aktuelle als auch die gespeicherte Messkurve angezeigt werden sollen.

Wenn Sie eine andere mathematische Operation als "Data/Mem" wählen möchten, gehen Sie folgendermaßen vor:

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Math/Memory.

  3. Drücken Sie zum Abspeichern der gewünschten Messkurve die Taste "Click".

  4. Drücken Sie die Tab-rechts-Taste, um zum Bereich Data Math des Dialogfensters zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste die gewünschte mathematische Operation.

  5. Drücken Sie die Tab-rechts-Taste, um zum Bereich "Trace View Options" des Dialogfensters zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste die gewünschte Messkurvenansicht.

  6. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Einrichten der Statistikfunktionen
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Trace Statistics.

  2. Klicken Sie zum Aktivieren der Statistikfunktionen auf das Kontrollkästchen Statistics.

  3. Wählen Sie den gewünschten benutzerdefinierten Bereich.

  4. Geben Sie in das Feld Start den gewünschten Stimulus-Wert für den Anfang des benutzerdefinierten Bereichs ein.

  5. Geben Sie in das Feld Stop den gewünschten Stimulus-Wert für das Ende des benutzerdefinierten Bereichs ein.

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Wählen Sie mit der Tab-rechts-Taste das Trace-Menü. Wählen Sie mit der Pfeil-unten-Taste Trace Statistics. Drücken Sie "Click".

  2. Drücken Sie zum Aktivieren der Statistikfunktionen "Click".

  3. Drücken Sie die Tab-rechts-Taste, um zum "User Range"-Auswahlbereich des Dialogfensters zu gelangen. Wählen Sie mit der Pfeil-unten-Taste den gewünschten benutzerdefinierten Bereich.

  4. Wählen Sie mit der Tab-rechts-Taste das Feld Start. Geben Sie den gewünschten Stimulus-Wert für den Anfang des benutzerdefinierten Bereichs ein.

  5. Wählen Sie mit der Tab-rechts-Taste das Feld Stop. Geben Sie den gewünschten Stimulus-Wert für das Ende des benutzerdefinierten Bereichs ein.

  6. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Siehe auch...

Abbilden von Netzlaufwerken

Überblick

Konzepte

Wie bildet man ein Netzlaufwerk ab?

Wenn der Analysator an ein Netzwerk angeschlossen ist, können Sie durch "Abbilden" (engl. "Drive Mapping") von Laufwerken vom Analysator aus auf Dateien zugreifen, die auf einem externen Computer abgelegt sind, und umgekehrt.
Konzepte

Wie bildet man ein Laufwerk ab?

Wenn der Analysator an einem Netzwerk angeschlossen ist, können Sie durch Abbilden von Laufwerken vom Analysator aus auf Dateien zugreifen, die auf einem externen Computer abgelegt sind, und umgekehrt.

  • Das Laufwerk im Analysator erscheint dann im Verzeichnis des Computers wie ein Computer-Laufwerk.

  • Umgekehrt erscheint das Computer-Laufwerk im Verzeichnis des Analysators wie ein Analysator-Laufwerk.

  • Sie können dann wahlweise das analysatorinterne Laufwerk oder das Computer-Laufwerk für Datei-Operationen benutzen.

Hinweis: Für diese Prozeduren benötigen Sie eine Maus und eine Tastatur.
Abbilden eines Analysator-Laufwerks auf einen externen Computer

Abbilden eines Computer-Laufwerks auf dem Analysator

Hinweis: Die folgende Prozedur setzt voraus, dass der externe Computer unter Windows NT 4.0 (oder einer neueren Version) läuft.

Abbilden eines Analysator-Laufwerks auf einen externen Computer

Identifikation des Computernamens

  1. Der Analysator hat einen Computernamen, den Sie kennen müssen, wenn Sie die nachfolgende Prozedur ausführen möchten. Wenn Sie den Computernamen des Analysators herausfinden oder ändern möchten, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf System, Windows Taskbar, Settings, Control Panel und dann auf das Symbol System.

    2. Wählen Sie die Registerkarte Network Identification. Notieren Sie gegebenenfalls den Computernamen. Wenn Sie den Namen ändern möchten, klicken Sie auf Properties, und geben Sie einen neuen Namen ein. Klicken Sie auf OK.

Hinzufügen eines neuen Benutzers

  2. Klicken Sie auf Users and Passwords.

  3. Falls die Schaltfläche Add "abgeblendet" ist, klicken Sie auf das Kontrollkästchen "Users must enter a user name and password to use this computer." Klicken Sie anschließend auf Add.

  4. Geben Sie in das Feld User Name Ihren Benutzernamen ein (verwenden Sie den gleichen Benutzernamen wie auf dem externen Computer). Geben Sie in das Feld Full Name Ihren vollständigen Namen ein. Klicken Sie auf Next.

  5. Geben Sie in das Feld Password Ihr Passwort ein (verwenden Sie das gleiche Passwort wie auf dem externen Computer). Geben Sie zur Bestätigung das Passwort nochmals in das Feld Confirm Password ein. Klicken Sie auf Next.

  6. Sie werden gefragt: "What level of access do you want to grant this user?" (Welches Zugriffsrecht soll dieser Benutzer erhalten?). Wählen Sie Other und dann die Standardvorgabe Administrators (Verwalter). Klicken Sie auf Finish.

Zuordnen eines Laufwerknamens für gemeinsamen Zugriff

  7. Klicken Sie im Feld "Address" auf den Pfeil-nach-unten und anschließend auf My Computer. Klicken Sie mit der rechten Maustaste auf das Laufwerk, das auf dem Analysator und auf dem externen Computer benutzbar sein soll. Klicken Sie auf Sharing.

  8. Wählen Sie Share this folder. Geben Sie in das Feld Share name den gewünschten Freigabenamen für die gemeinsame Benutzung ein. Drücken Sie OK.

Abbilden des Laufwerks auf dem externen Computer

  9. Klicken Sie auf dem Arbeitsplatz des externen Computers auf Windows NT Explorer. Klicken Sie im Extras-Menü auf Netzlaufwerk verbinden.

  10. Geben Sie in das Feld Pfad den Computernamen und den Laufwerk-Freigabenamen ein, und zwar in der Form: \\computername\freigabename.

  11. Geben Sie in das Feld Connect Ihren Benutzernamen ein. Klicken Sie auf OK.

Abbilden eines Computer-Laufwerks auf dem Analysator

  1. Klicken Sie auf dem Arbeitsplatz des externen Computers auf Windows NT Explorer. Klicken Sie in der Laufwerksliste mit der rechten Maustaste auf das Laufwerk, das auch auf dem Analysator benutzbar sein soll. Klicken Sie auf Freigabe.

  2. Aktivieren Sie in dem Dialogfenster Freigegeben als. Geben Sie in das Feld Freigabename den gewünschten Freigabenamen für das Laufwerk ein (dieser Name ist beliebig wählbar), oder wählen Sie mit den Pfeiltasten einen vorhandenen Namen. Klicken Sie auf OK.

  3. Klicken Sie auf dem Arbeitsplatz des Analysators auf Windows Explorer. Klicken Sie im Extras-Menü auf Netzlaufwerk verbinden.

  4. Geben Sie in das Feld Verzeichnis den PC-Hostnamen (oder die ID-Nummer des PCs) und den (in Schritt 2 gewählten) Freigabenamen ein, und zwar in der Form: \\PChostname (oder ID-Nummer)\freigabename. Klicken Sie auf Finish.

  5. Geben Sie in das Feld Connect as Ihren Benutzernamen ein.

  6. Geben Sie in das Feld Password das Passwort ein, das Sie zur Anmeldung bei dem externen Computer benutzen. Klicken Sie auf OK.


Abspeichern/Zurückladen von Messkurven

Siehe auch...

Abspeichern und Zurückladen einer Datei

Überblick

Konzepte

Wie speichert/lädt man eine Datei?

Der Analysator bietet die Möglichkeit, Daten auf das interne Festplattenlaufwerk, eine Diskette, ein externes CD-RW-Laufwerk oder ein abgebildetes Netzlaufwerk eines PCs oder Servers abzuspeichern und von dort wieder zurückzuladen.
Konzepte

Wie speichert man eine Datei ab und lädt sie wieder zurück?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
"File Save"-Funktion

"Auto Save"-Funktion

"Save As"-Funktion

In eine Datei drucken

Dateinamen ändern

"File Recall"-Funktion

"File Save"-Funktion

Mit der "File Save"-Funktion können Sie eine Datei im Binärformat unter dem aktuellen Dateinamen im aktuellen Pfad ablegen. Falls nicht zuvor ein Pfadname und ein Dateiname spezifiziert wurden, wählt der Analysator automatisch den Standardpfad "C:\Program Files\Agilent\Network Analyzer\Documents" und den Standarddateinamen "default.cst.". Wenn Sie später nochmals eine Datei mit "File Save" abspeichern, wird diese Datei überschrieben, es sei denn, Sie ändern den Namen der neuen Datei ab und speichern diese nach einer der folgenden Methoden ab:

  • "Auto Save"-Funktion

  • "Save As"-Funktion

  • Umbenennen (im Windows Explorer)

"Auto Save"-Funktion

Mit der "Auto-Save"-Funktion können Sie eine Datei im Binärformat auf der internen Festplatte im aktuellen Pfad ablegen. Falls nicht zuvor ein anderer Pfad spezifiziert wurde, wählt der Analysator automatisch den Standardpfad "C:\Program Files\Agilent\Network Analyzer\Documents". Außerdem wählt er automatisch einen neuen ".cst"-Dateinamen und zeigt diesen an. Die zuvor abgespeicherte Datei wird nicht überschrieben.

"Save As"-Funktion

Wenn Sie zum Abspeichern einer Datei die "Save As"-Funktion benutzen, können Sie wählen, in welchem Format (binär oder ASCII) die Daten auf welches der folgenden Laufwerke abgespeichert werden:

  • Interne Festplatte

  • Diskette

  • Externes CD-RW-Laufwerk oder abgebildetes Netzlaufwerk eines externen PCs oder Servers

Binäre Dateitypen

Die folgenden binären Dateitypen sind analysator-spezifische Binärdateien zum Speichern von Messdaten. Diese Dateien können nur von Netzwerkanalysatoren der Familie Agilent PNA gelesen werden.

  • .cst

  • .sta

  • .cal

Eine ".cst"-Datei enthält folgende Daten:

  • Alle auf dem Analysator eingerichteten Messungen einschließlich Grenzwertlinien und Markern

  • Alle Kalibrierungsdatensätze für die auf dem Analysator eingerichteten Messungen.

  • Bildschirmfensteranordnung

Das Zurückladen einer ".cst"-Datei geht schneller vonstatten, als wenn Sie die Gerätezustands- und Kalibrierungsdaten-Dateien für jede Messung einzeln zurückladen.

Eine ".sta"-Datei enthält folgende Daten:

  • Alle auf dem Analysator eingerichteten Messungen einschließlich Grenzwertlinien und Markern

  • Bildschirmfensteranordnung

Hinweis: Eine ".sta"-Datei enthält keine Kalibrierungsdatensätze.

Das Zurückladen einer ".sta"-Datei geht schneller vonstatten, als wenn Sie die Gerätezustände für jede Messung einzeln zurückladen.

Eine ".cal"-Datei enthält nur die bei einer Kalibrierung ermittelten Kalibrierdaten. Eine ".cal"-Datei enthält keine Gerätezustandsdaten. Kalibrierdaten gelten stets nur für den Gerätezustand, in dem sich der Analysator zum Zeitpunkt der Kalibrierung befand. Deshalb sollten Sie, wenn es auf größtmögliche Messgenauigkeit ankommt, beim Zurückladen einer ".cal"-Datei stets auch die entsprechende Gerätezustandsdatei (eine ".sta"-Datei) zurückladen, die den Gerätezustand zum Zeitpunkt der Kalibrierung enthält.

Hinweis: Über die "Calibration Properties"-Funktion können Sie den Gerätezustand abfragen, in dem der Analysator sich zum Zeitpunkt der Abspeicherung der ".cal"-Datei befand. Weitere Informationen siehe "Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung".

Kalibrierdaten sind kanalspezifisch. Es ist beispielsweise nicht möglich, Kalibrierdaten, die im Kanal 1 gemessen wurden, für einen der anderen Kanäle zurückzuladen.

ASCII-Dateitypen

Es können die folgenden ASCII-Dateitypen auf die interne Festplatte oder eine Diskette abgespeichert werden. Die Dateien können vom Analysator zu einem externen CD-RW-Laufwerk oder einem abgebildeten Netzlaufwerk eines PCs oder Servers kopiert und dann mit Hilfe von Tabellenkalkulations- oder CAE-Programmen weiterverarbeitet werden.

  • .prn

  • .s1p

  • .s2p

Hinweis: In einer ASCII-Datei können immer nur Daten von einem einzigen aktiven Kanal mit einer einzigen aktiven Messkurve abgelegt werden. Es ist nicht möglich, eine Gruppe von Messungen in einer einzigen ASCII-Datei abzulegen.

Das ".prn"-Format wird von zahlreichen Tabellenkalkulationsprogrammen wie beispielsweise Microsoft® Excel unterstützt. Eine ".prn"-Datei enthält die korrigierten Stimulus- und Response-Daten der aktiven Messkurve in Form einer kommagetrennten Liste. Beispiel:

"S11 Log Mag" |
"Frequency (Hz)", "dB" |
3.000000e+005 | -3.528682e+001
4.529850e+007 | -2.817913e+001
9.029700e+007 | -3.216808e+001
1.352955e+008 | -3.101017e+001

Der Import von ".prn"-Dateien in ein Tabellenkalkulationsprogramm hat den Vorteil, dass Sie direkt auf Daten wie Log Mag, Linear Mag, SWR usw. zugreifen können. (Die Dateitypen ".s1p" und ".s2p" enthalten nur Real-/Imaginärteil-Wertepaare). Einige Tabellenkalkulationsprogramm wie beispielsweise Excel können ".prn"-Daten in die Spalten eines Arbeitsblatts übernehmen. Eine ".prn"-Datei ist eine reine Ausgabedatei, die vom Analysator nicht wieder eingelesen werden kann.

Die (auch als Touchstone-Formate bezeichneten) Formate ".s1p" und ".s2p" werden von vielen CAE-Anwendungen wie z. B. dem Agilent Microwave Design System (MDS) und Agilent Advanced Design System (ADS) verwendet. (Auch ".s1p"- und ".s2p"-Dateien lassen sich in Tabellenkalkulationen importieren; empfohlen wird jedoch das ".prn"-Format. ) ".s1p"- und ".s2p"-Dateien enthalten die fehlerkorrigierten Stimulus- und Real-/Imaginärteil-Wertepaare der aktiven Messkurve in Form einer zwischenraumgetrennten Liste. Die Daten sind als Array abgelegt und "enthalten" die Einflüsse der elektrischen Länge und M essebenenverschiebung. Diese Dateien sind reine Ausgabedateien, die vom Analysator nicht wieder eingelesen werden können. Es ist nicht möglich, Bildschirmgrafiken in eine ".s1p"- oder ".s2p"-Datei abzuspeichern.

Das ".s1p"-Format ist für Daten aus Messungen an Eintor-Bauteilen vorgesehen. Eine ".s1p"-Datei enthält fehlerkorrigierte Daten aus einer einzigen S-Parameter-Messung in Form von Real-/Imaginärteil-Wertepaaren für die aktive Messkurve. Beispiel:

!Agilent 835xA: A.O1.01
!S1P File: Measurement: S11:
Hz S RI R 50.0
3.000000e+005 | 1.644731e-002 | -5.352918e-003
4.529850e+007 | 6.613658e-003 | 3.845622e-002
9.029700e+007 | 1.226958e-002 | 2.139536e-002
1.352955e+008 | 2.736092e-002 | 6.093691e-003
1.802940e+008 | 2.883098e-002 | -4.465516e-002

Hinweis: In den obigen und nachfolgenden Beispielen bedeuten

  • Hz = Frequenz

  • S = S-Parameter

  • RI = Real-/Imaginärteil-Wertepaar

  • R 50.0 = System impedanz

Das ".s2p"-Format ist für Daten aus Messungen an Zweitor-Bauteilen vorgesehen. Eine ".s2p"-Datei enthält fehlerkorrigierte Daten aus vier S-Parameter-Messungen in Form von Real-/Imaginärteil-Wertepaaren für die aktive Messkurve. Beispiel:

!Agilent 835xA: A.O1.01
!S2P File: Measurement: S11, S21, S12, S22:
Hz S RI R 50.0
3.000000e+005 | -2.241318e-004 | -1.199616e-006
 | 1.000518e+000 | 5.873038e-004
 | 9.997111e-001 | 3.530481e-005
 | -2.597498e-005 | 8.359684e-005
4.529850e+007 | 4.111997e-004 | -1.182173e-004
 | 1.000306e+000 | -7.713915e-004
 | 9.995822e-001 | 7.192153e-004
 | -3.241569e-005 | 2.542366e-004
9.029700e+007 | 6.449617e-005 | -7.952083e-004
 | 1.000047e+000 | -1.822955e-004
 | 9.990308e-001 | -5.635918e-004
 | 2.029050e-004 | 7.774481e-004
1.352955e+008 | -5.545341e-004 | -1.932054e-004
 | 9.994355e-001 | -4.536113e-004
 | 1.000014e+000 | 8.115917e-004
 | 6.564625e-004 | 5.489338e-004

Der Analysator kann nur bei aktiver 2-Port-F ehlerkorrektur eine gültige ".s2p"-Datei erstellen. Falls keine 2-Port-Kalibrierung erfolgte, sind die Fehlerterme S11, S21, S12 oder S22 nicht verfügbar, und die Felder für die nicht gemessenen Parameter enthalten Nullen. Der Analysator erstellt ungeachtet dessen eine (in diesem Fall ungültige) ".s1p"- oder ".s2p"-Datei.

In eine Datei drucken

Die "Print to File"-Funktion ermöglicht es, den aktuellen Bildschirminhalt als Bitmap- (".bmp") Datei auf eines der folgenden Laufwerke abzuspeichern:

  • Interne Festplatte

  • Diskette

  • Externes CD-RW-Laufwerk, abgebildetes Netzlaufwerk eines externen PCs oder Servers

Der Analysator legt die ".bmp"-Datei automatisch im aktuellen Pfad ab. Falls nicht zuvor ein anderer Pfad spezifiziert wurde, wählt der Analysator automatisch den Standardpfad "C:\Program Files\Agilent\Network Analyzer\".

".bmp"-Dateien können, wie ".prn"-Dateien, in Anwendungen wie beispielsweise Microsoft Excel, Word oder Paint importiert und dort als Screenshot angezeigt werden.

Dateinamen ändern

Die "Edit Filename"-Funktion ermöglicht es Ihnen, eine Datei zu kopieren und ihr dabei mit Hilfe der Navigationstasten einen neuen Namen zu geben. Die ursprüngliche Datei und der ursprüngliche Dateiname bleiben dabei erhalten. Diese Funktion ist im Dialogfenster "Save As" verfügbar, wenn Sie eine Datei mit Hilfe von Save As oder Print to File abspeichern. Siehe nachfolgende Abbildung.

Hinweis: Informationen über die Verwaltung von Dateien und Verzeichnissen (beispielsweise Kopieren, Löschen, Umbenennen oder Suchen) finden Sie in der Hilfe zu Windows 2000.

"File Recall"-Funktion

Mit der "File Recall"-Funktion können Sie ausschließlich Binärdateien zurückladen. Sie können zwar eine ".cst"- oder ".sta"-Datei als Screenshot zurückladen, aber nur, wenn die Daten in der Betriebsart "Trace Hold" abgespeichert wurden. (Die zurückgeladene Datei wird erst nach Triggerung gewobbelt. ) Weitere Informationen über Binärdateien siehe unter "Save As"-Funktion.

Auf einem externen PC können Sie lediglich vom Analysator erzeugte ASCII- oder Bitmap-Datei laden, nicht jedoch eines der Binärformate. Zum Zurückladen von Screenshots können Sie ".prn"- oder ".bmp"-Dateien in Anwendungen wie Microsoft Excel, Word oder Paint importieren. Weitere Informationen über ASCII-Dateien siehe unter "Save As"-Funktion weiter oben.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.

Hinweis: Für diese Prozeduren benötigen Sie eine Maus und eine Tastatur.
Abspeichern einer Datei

Automatisches Abspeichern einer Datei

Abspeichern einer Datei unter einem anderen Namen oder auf ein anderes Laufwerk

In eine Datei drucken

Dateinamen ändern

Zurückladen einer Datei in den Analysator

Zurückladen einer Datei in einen externen Computer

Abspeichern einer Datei

Mausprozedur

  1. Klicken Sie im "File"-Menü auf "Save".

Tastenprozedur

  1. Drücken Sie im Tastenfeld UTILITY die Taste Save.

  2. Drücken Sie in der Aktuelle-Eingabe-Symbolleiste F1 (Save).

Auf dem Bildschirm werden kurz der Pfad und der Dateiname angezeigt, unter dem die Datei abgespeichert wird.

Hinweis: Wenn Sie das nächste Mal die "Save"-Funktion benutzen, wird diese Datei überschrieben, sofern Sie die neue Datei nicht nach einer der folgenden Methoden unter einem anderen Namen abspeichern: "Auto Save", "Save As", "Rename" (im Windows Explorer)

Automatisches Abspeichern einer Datei

Hinweis: Diese Prozedur kann nur über die Tastatur ausgeführt werden.

Tastenprozedur

  1. Drücken Sie im Tastenfeld UTILITY die Taste Save.

  2. Drücken Sie in der Aktuelle-Eingabe-Symbolleiste "F3 (Auto Save)".

Auf dem Bildschirm wird kurz der Pfad angezeigt, in den die Datei abgespeichert wird. Der Analysator wählt automatisch einen neuen ".cst"-Dateinamen und zeigt diesen an. Die zuvor abgespeicherte Datei wird nicht überschrieben.

Abspeichern einer Datei unter einem anderen Namen oder auf ein anderes Laufwerk

Mausprozedur

  1. Klicken Sie im File-Menü auf Save As.

  2. Wählen Sie im Feld Save in des Dialogfensters durch Anklicken des Pfeils den Pfad, in den die Datei abgespeichert werden soll.

  3. Geben Sie in das Feld File name den neuen Dateinamen ein.

  4. Wählen Sie im Feld Save as type durch Anklicken des Pfeils den gewünschten Dateityp.

  5. Klicken Sie auf Save.

Tastenprozedur

  1. Drücken Sie im Tastenfeld UTILITY die Taste Save.

  2. Drücken Sie in der Aktuelle-Eingabe-Symbolleiste F2 (Save As).

  3. Drücken Sie die Tab-links-Taste, um zum Feld Save in zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu dem Pfad, in dem die Datei abgelegt werden soll. Wählen Sie den Pfad durch Drücken der Tab-rechts-Taste.

  4. Geben Sie in das Feld File name den neuen Dateinamen ein.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Save as zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu gewünschten Dateityp. Wählen Sie den Dateityp durch Drücken der Tab-rechts-Taste.

  6. Drücken Sie die Tab-rechts-Taste, um zum Feld Save zu gelangen. Drücken Sie Click.

In eine Datei drucken

Mausprozedur

  1. Klicken Sie im File-Menü auf Print to File.

  2. Wählen Sie im Feld Save in des Dialogfensters durch Anklicken des Pfeils den Pfad, in dem die Datei abgelegt werden soll.

  3. Geben Sie in das Feld File name den neuen Dateinamen ein.

  4. Klicken Sie auf Save.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Pfeil-unten-Taste, um zu Print to File zu gelangen. Drücken Sie Click.

  3. Drücken Sie im Tastenfeld NAVIGATION die Tab-links-Taste, um zum Feld Save in zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu dem Pfad, in dem die Datei abgelegt werden soll. Drücken Sie die Tab-rechts-Taste.

  4. Geben Sie in das Feld File name den neuen Dateinamen ein.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Save zu gelangen. Drücken Sie Click.

Dateinamen ändern

Mausprozedur

  1. Klicken Sie im File-Menü auf Save As oder Print to File.

  2. Wählen Sie im Feld Save des Dialogfensters durch Anklicken des Pfeils den Pfad, in dem die Datei abgelegt ist.

  3. Wählen Sie im Feld Filepath den Dateinamen.

  4. Klicken Sie auf Edit Filename.

  5. Geben Sie nach einer der folgenden Methoden den neuen Dateinamen ein:

    • Geben Sie den Namen über die externe Tastatur ein.

    • Klicken Sie auf die betreffenden Buchstaben oder Navigations-Schaltflächen ("<<" , "Select", "Back", ">>").

  6. Klicken Sie auf OK, Save.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld NAVIGATION die Pfeil-unten-Taste, um zu Save As oder Print to File zu gelangen. Drücken Sie Click.

  3. Drücken Sie die Tab-links-Taste, um zum Feld Save in zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu dem Pfad, in dem die Datei abgelegt ist. Drücken Sie die Tab-rechts-Taste.

  4. Drücken Sie die Tab-links-Taste, um zum Feld Filepath zu gelangen. Navigieren Sie mit den Pfeil-oben/unten-Tasten zu dem betreffenden Dateinamen. Drücken Sie Click.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Edit Filename zu gelangen. Drücken Sie Click.

  6. Geben Sie nach einer der folgenden Methoden den neuen Dateinamen ein:

    • Geben Sie den Namen über die externe Tastatur ein.

    • Navigieren Sie mit den Pfeil-oben/unten-Tasten zu dem gewünschten Buchstaben. Drücken Sie Click. Navigieren Sie mit der Tab-rechts- oder Tab-links-Taste zu der gewünschten Schaltfläche ("<<" , "Select", "Back", ">>"). Drücken Sie Click.

  7. Navigieren Sie mit der Tab-rechts-Taste zu OK. Drücken Sie Click.

  8. Navigieren Sie mit der Tab-rechts-Taste zu Save. Drücken Sie Click.

Zurückladen einer Datei in den Analysator

Mausprozedur

  1. Bilden Sie ein Netzlaufwerk auf das externe Speichergerät ab, falls dies noch nicht geschehen ist (siehe Abbilden von Netzlaufwerken). Dadurch erscheint das Festplattenlaufwerk des externen Speichergerätes im Laufwerksverzeichnis des Analysators.

  2. Klicken Sie im File-Menü auf Recall.

  3. Wählen Sie im Feld Look in des Dialogfensters durch Anklicken des Pfeils den Pfad, in dem die Datei abgelegt ist.

  4. Wählen Sie im Feld Files of type durch Anklicken des Pfeils den gewünschten Dateityp.

  5. Wählen Sie im Feld Filepath den Namen der Datei, die Sie zurückladen möchten.

  6. Klicken Sie auf Recall.

Tastenprozedur

  1. Falls Sie eine Datei von einem Netzlaufwerk zurückladen möchten, bilden Sie das betreffende Netzlaufwerk auf den Analysator ab, sofern dies noch nicht geschehen ist (siehe Abbilden von Netzlaufwerken). Dadurch erscheint das Festplattenlaufwerk des externen Speichergerätes im Laufwerksverzeichnis des Analysators.

  2. Drücken Sie im Tastenfeld UTILITY die Taste Recall.

  3. Wählen Sie in der Aktuelle-Eingabe-Symbolleiste mit einer der Tasten F1, F2 oder F3 einen der angezeigten Dateinamen. (Die Dateinamen werden in alphabetischer Reihenfolge angezeigt. ) Wenn Sie eine andere Datei zurückladen möchten, drücken Sie F4 (Open).

  4. Wenn Sie im vorigen Schritt F4 (Open) gewählt haben:

    1. Drücken Sie die Tab-links-Taste, um zum Feld Look in zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu dem Pfad, in dem die Datei abgelegt ist. Drücken Sie die Tab-rechts-Taste.

    2. Drücken Sie die Tab-rechts-Taste. Wählen Sie im Feld Files of type durch Anklicken des Pfeils den gewünschten Dateityp. Drücken Sie die Tab-rechts-Taste.

    3. Drücken Sie die Tab-links-Taste, um zum Feld Filepath zu gelangen. Navigieren Sie mit der Pfeil-unten-Taste zu gewünschten Binärdateityp. Drücken Sie die Tab-rechts-Taste.

    4. Drücken Sie die Tab-rechts-Taste, um zum Feld Recall zu gelangen. Drücken Sie Click.

Laden einer Analysator-Datei auf einem externen Computer

  1. Bilden Sie ein Netzlaufwerk auf den Analysator ab, falls dies noch nicht geschehen ist (siehe Abbilden von Netzlaufwerken). Das Festplattenlaufwerk des Analysator erscheint daraufhin im Laufwerksverzeichnis des PCs.

  2. Starten Sie auf dem externen Computer den Windows Explorer® und laden Sie mit den darin verfügbaren Funktionen die gewünschte ASCII- oder Bitmap-Datei zurück.

Informationen zur Benutzung des Windows Explorer finden Sie im Hilfesystem zu der Windows®-Version, unter welcher der externe Computer läuft.


Drucken

Drucken einer angezeigten Messung

Siehe auch...

Der Analysator bietet die Möglichkeit, eine angezeigte Messung über einen lokalen Drucker oder einen Netzwerkdrucker auszudrucken. Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Anschluss eines Druckers an ein Netzwerk

Anschluss eines Druckers an den Analysator

Erstellen eines Ausdrucks

Anschluss eines Druckers an ein Netzwerk

Hinweis: Für diese Prozeduren benötigen Sie eine Maus und eine Tastatur.

  1. Schließen Sie die LAN-Schnittstelle auf der Rückwand des Analysators über ein geeignetes Kabel an Ihr lokales Netzwerk an.

  2. Klicken Sie auf Start, Settings, Printers.

  3. Doppelklicken Sie auf Add Printer, um den Add Printer-Assistenten zu starten. Klicken Sie auf Next.

  4. Klicken Sie auf Network Printer, Next.

  5. Bauen Sie eine Netzwerkverbindung zu dem gewünschten Drucker auf:

  • Geben Sie den Druckernamen im folgenden Format ein, oder klicken Sie auf Next, um den Drucker im Netzwerk zu finden: \\druckservername\freigabename

  • Geben Sie die URL des Druckers im folgenden Format ein: http://druckservername/Drucker/freigabename/.drucker

Hinweis: Falls es Ihnen nicht gelingt, auf die beschriebene Weise eine Netzwerkverbindung zu Ihrem Drucker aufzubauen, lesen Sie bitte in der Dokumentation zu Ihrem Drucker nach oder setzen Sie sich mit Ihrem Netzwerkverwalter in Verbindung.

  6. Folgen Sie den auf dem Bildschirm angezeigten Hinweisen.

  7. Das Druckersymbol erscheint in Ihrem Druckerverzeichnis.

Anschluss eines Druckers an den Analysator

Hinweis: Für diese Prozeduren benötigen Sie eine Maus und eine Tastatur.

  1. Schließen Sie den Drucker an die passende Schnittstelle auf der Rückwand des Analysators an; beachten Sie dabei die Hinweise in der Dokumentation zum Drucker.

  2. Die meisten Drucker werden von Windows 2000 automatisch erkannt und installiert. Bei älteren Druckern müssen Sie unter Umständen zusätzliche Informationen eingeben, damit die Installation abgeschlossen werden kann. Wenn das Symbol für Ihren Drucker nicht im Druckerverzeichnis erscheint, führen Sie (je nachdem, welchen Druckertyp Sie verwenden) eine der folgenden Prozeduren aus.
Installation eines Druckers mit Parallelschnittstelle (LPT)

Installation eines Druckers mit USB-Schnittstelle

Installation eines Druckers mit serieller Schnittstelle (COM)

Installation eines Druckers mit Parallelschnittstelle (LPT)

  1. Schließen Sie den Drucker an den Analysator an. Der Analysator wird mit einem Adapter (36-polig männlich (1284-C) auf 25-polig weiblich) geliefert, der den Anschluss eines Druckers mit Centronics-Schnittstelle an die Parallelschnittstelle des Analysators ermöglicht.

VORSICHT: Schließen Sie den Drucker auf keinen Fall an den mit "Ext. Test Set Interface" beschrifteten Anschluss (25-polige weibliche Steckverbindung) an. Die Spannungen auf den Signalleitungen dieser Schnittstelle können den I/O-Baustein im Drucker beschädigen.

  2. Klicken Sie auf Start, Settings, Printers.

  3. Doppelklicken Sie auf Add Printer, um den Add Printer-Assistenten zu starten. Click Klicken Sie auf Next.

  4. Klicken Sie auf Local Printer und vergewissern Sie sich, dass die Kontrollkästchen Automatically detect und install my Plug and Play printer aktiviert sind; klicken Sie anschließend auf Next.

  5. Je nachdem, welchen Drucker Sie installieren, macht der Drucker-Assistent weiter, oder es erscheint die Meldung "Found New Hardware", oder es erscheint der Hardware-Assistent und informiert Sie darüber, dass die Installation begonnen hat. Folgen Sie den auf dem Bildschirm erscheinenden Hinweisen und führen Sie die Druckerinstallation zu Ende.

    • Alternativ können Sie nach dem Anschließen des Druckers Ihren Analysator starten oder neustarten; in diesem Fall startet Windows 2000 automatisch den Hardware-Assistenten.

  6. Das Druckersymbol wird zu Ihrem Druckerverzeichnis hinzugefügt.

Installation eines Druckers mit USB-Schnittstelle

Schließen Sie den Drucker an die USB-Schnittstelle des Analysators an. Windows 2000 erkennt diesen Druckertyp automatisch und startet den Hardware-Assistenten.

Sie brauchen Ihren Analysator nicht auszuschalten oder neu zu starten. Folgen Sie den auf dem Bildschirm angezeigten Hinweisen zur Druckerinstallation.

Das Druckersymbol wird zu Ihrem Druckerverzeichnis hinzugefügt.

Installation eines Druckers mit serieller Schnittstelle (COM)

  1. Schließen Sie den Drucker an die serielle Schnittstelle des Analysators an.

  2. Klicken Sie auf Start, Settings, Printers.

  3. Doppelklicken Sie auf Add Printer, um den Add Printer-Assistenten zu starten. Klicken Sie auf Next.

  4. Klicken Sie auf Local Printer und vergewissern Sie sich, dass die Kontrollkästchen Automatically detect und install my Plug and Play printer aktiviert sind; klicken Sie anschließend auf Next.

  5. Folgen Sie den auf dem Bildschirm erscheinenden Hinweisen und spezifizieren Sie:

  • die Druckerschnittstelle

  • den Druckerhersteller und das Druckermodell

  • den Druckernamen

  6. Das Druckersymbol wird zu Ihrem Druckerverzeichnis hinzugefügt.

Hinweis: Zur Installation eines Plug-and-Play-Druckers (beispielsweise mit USB- oder Parallelschnittstelle (LPT)) benötigen Sie keine Verwalter-Privilegien. Wenn Sie jedoch einen nicht Plug-and-Play-fähigen Drucker direkt an Ihren Analysator anschließen möchten, müssen Sie sich als Verwalter oder Mitglied der Verwaltergruppe anmelden. Wenn Ihr Analysator an einem lokalen Netzwerk angeschlossen ist, können Sie unter Umständen (je nach Ihrem Netzwerk-Berechtigungsprofil) diese Prozedur nicht ordnungsgemäß abschließen.

Erstellen eines Ausdrucks

Mausprozedur

  1. Klicken Sie im File-Menü auf Print.

  2. Navigieren Sie im Dialogfenster Print zu Name. Wählen Sie durch Anklicken des Pfeils den gewünschten Drucker. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld UTILITY die Taste Print.

  2. Wählen Sie im Feld Name mit den Pfeil-oben/unten-Tasten im Tastenfeld NAVIGATION den gewünschten Drucker. Drücken Sie OK.

Hinweis: Weitere Informationen über die Auswahlmöglichkeiten im Druckerdialogfenster siehe Hilfe zu Windows 2000.

Die folgende Abbildung zeigt einen typischen Ausdruck. Beachten Sie, dass zusammen mit den Messdiagrammen immer auch die zugehörigen numerischen Informationen ausgedruckt werden.


Tutorials

Siehe auch...

Klicken Sie auf eine Schaltfläche, um nähere Informationen über die jeweiligen Messungen zu erhalten.

Phasenmessungen

Verstärkermessungen

Messung der AM-PM-Störmodulation

Messung der komplexen Impedanz

Messung der Phasenlinearitätsabweichung

Gruppenlaufzeitmessungen

Verstärkungs- und Frequenzgangmessungen

Messung der Verstärkungskompression

Messung der Ausgangsrückwirkung

Messungen an Leistungsbauteilen

Absolutleistungsmessungen

Impedanzanpassungsmodell

Reflexionen entlang eines Wellenleiters

Zeitbereichtransformation


Phasenmessungen

Siehe auch...

Der Netzwerkanalysator ermöglicht folgende Phasenmessungen zur Charakterisierung von Bauteilen:

  • Phasenlinearitätsabweichung

  • Gruppenlaufzeit

  • Komplexe Impedanz

  • AM-PM-Störmodulation

Eine genaue Kenntnis der Amplituden- und Phasencharakteristiken eines Bauteils ist eine notwendige Voraussetzung dafür, dass dieses Bauteil innerhalb einer Schaltung wie erwartet funktioniert.

Durch Anklicken der Schaltflächen gelangen Sie zu Informationen über folgende Themen:

Was sind Phasenmessungen?

Warum sind Phasenmessungen erforderlich?

Anwendung des "Phase"-Formats

Verschiedene Arten von Phasenmessungen

Was sind Phasenmessungen?

Phasenmessungen werden, genau wie Amplitudenmessungen, aus S-Parameter-Messungen abgeleitet. Eine Phasenmessung ist eine relative (Verhältnis-) Messung, im Gegensatz zu einer absoluten Messung. Eine Phasenmessung vergleicht die Phase des in das Messobjekt einfallenden Signals (Stimulus) mit der Phase des vom Messobjekt transmittierten oder reflektierten Signals (Response). Unter der Voraussetzung, dass eine genaue Kalibrierung durchgeführt wurde, ist die Phasendifferenz (auch als Phasenverschiebung bezeichnet) zwischen den beiden Signalen ausschließlich auf die elektrischen Charakteristiken des Messobjekts zurückzuführen.

Die folgende Abbildung zeigt die Phasenverschiebung (in Zeiteinheiten oder Grad) zwischen einem einfallenden Signal und einem transmittierten Signal in Form eines Oszillogramms.

Warum sind Phasenmessungen erforderlich?

Phasenmessungen sind ein wichtiger Bestandteil einer Netzwerkanalyse. Die folgende Abbildung nennt fünf Gründe dafür, warum nicht nur Amplituden- sondern auch Phasenmessungen erforderlich sind.

Bauteile und Schaltungen, die zur Signalverarbeitung in Kommunikationssystemen verwendet werden, dürfen keine unzulässig starken Signalverzerrungen verursachen. Es ist zwischen zwei Arten von Verzerrungen zu unterscheiden:

  • Lineare Verzerrungen – Amplitudenfrequenzgang und Gruppenlaufzeit sind über die interessierende Bandbreite nicht konstant.

  • Nichtlineare Verzerrungen – beispielsweise AM-PM-Störmodulation.

Es muss gemessen werden, welchen Anteil der einfallenden Energie ein Bauteil oder eine Schaltung reflektiert, um sicherzustellen, dass die Energie in der gewünschten Weise transmittiert oder absorbiert wird. Die Messung der komplexen Impedanz einer Antenne ist ein gutes Beispiel hierfür.

Anwendung des "Phase"-Formats

Die Messkurvendarstellung im Format Phase zeigt den Verlauf der Phase über der Frequenz oder über dem Signalpegel. Der Analysator kann keine Phasenverschiebungen von mehr als ±180 zwischen dem Messsignal und dem Referenzsignal messen. Sobald die tatsächliche Phasenverschiebung +180 Grad überschreitet, "springt" die gemessene Phasenverschiebung abrupt auf -180 Grad. Dies verursacht das charakteristische Sägezahnmuster im angezeigten Phasenfrequenzgang (siehe nachfolgende Abbildung).

Die Maxima und Minima des Sägezahnmusters erreichen nicht immer +180 Grad bzw. -180 Grad. Dies liegt daran, dass die Messung bei diskreten Frequenzen erfolgt, und die Datenpunkte, an denen die Phasenverschiebung exakt +180 Grad oder -180 Grad beträgt, unter Umständen nicht exakt mit einem Messpunkt zusammenfallen.

Verschiedene Arten von Phasenmessungen

  • Komplexe Impedanz-Messdaten werden aus den Ergebnissen einer S11- oder S22-Messung abgeleitet. Aus der komplexen Impedanz lassen sich Informationen wie z. B. Widerstand, Blindwiderstand (Reaktanz), Phase und Amplitudenbetrag entnehmen. Komplexe Impedanz-Messdaten können im Format "Smith Chart" oder "Polar" dargestellt werden.

  • AM-PM-Störmodulation ist ein Maß für die Stärke der durch Amplitudenschwankungen (AM) hervorgerufenen, unerwünschten Phasenschwankungen (PM). Die AM-PM-Störmodulation ist üblicherweise definiert als die von einer Änderung des Verstärkereingangspegels um 1 dB verursachte Änderung der Phase des Verstärkerausgangssignals. Sie wird daher in Grad pro dB (°/dB) angegeben.

  • Die Phasenlinearitätsabweichung ist ein Maß für die von einem Bauteil verursachten Phasenverzerrungen. Im Idealfall ist die von einem Bauteil verursachte Phasenverschiebung eine lineare Funktion der Frequenz. Die Abweichung von diesem idealen Verlauf wird als Phasenlinearitätsabweichung (häufig auch – etwas irreführend – als Phasenlinearität) bezeichnet.

  • Gruppenlaufzeit ist ebenfalls ein Maß für die von einem Bauteil verursachten Phasenverzerrungen. Die Gruppenlaufzeit gibt an, wie lange ein Signal mit einer bestimmten Frequenz benötigt, um das Bauteil zu durchlaufen. Der Analysator bestimmt die Gruppenlaufzeit, indem er die erste Ableitung der Phase nach der Frequenz berechnet.

Phasenlinearitätsabweichung versus Gruppenlaufzeit

Der Analysator kann die Phasenlinearitätsabweichung in Abhängigkeit von der Frequenz messen und auf zweierlei Arten darstellen:

  • Direkt, als Phasenlinearitätsabweichung

  • Als Gruppenlaufzeit (erste Ableitung der Phase nach der Frequenz)

Vorteile der Phasenlinearitätsabweichungsmessung:

  • Geringeres Rauschen.

  • Auch zur Charakterisierung von Bauteilen geeignet, die für die Übertragung phasenmodulierter Signale vorgesehen sind; die Ergebnisse werden in der Maßeinheit Grad (statt Sekunden) angezeigt.

Vorteile der Gruppenlaufzeitmessung:

  • Phasenverzerrungen sind leichter zu interpretieren als bei der Messung der Phasenlinearitätsabweichung.

  • Höhere Genauigkeit. Der Grund für die höhere Genauigkeit ist, dass der Analysator die Steilheit der Phasenschwankungen berechnet, welche von der Anzahl der Phasendurchgänge pro Frequenzeinheit abhängig ist. Wenn man zwei Phasenfrequenzgänge mit gleicher Spitze-Spitze-Phasenschwankung vergleicht, ergibt derjenige mit der größeren Phasenschwankungssteilheit:

    • Höhere Gruppenlaufzeitschwankungen

    • Stärkere Signalverzerrungen.


Verstärkermessungen

Siehe auch...

Verstärkung

Frequenzgang

Ausgangsrückwirkung

Verstärkungsdrift

Phasenlinearitätsabweichung

Gruppenlaufzeit

Rückflussdämpfung (SWR, r)

Komplexe Impedanz

Verstärkungskompression

AM-PM-Störmodulation

Verstärkung

Das Verhältnis (bzw. im logarithmischen Maßstab die Pegeldifferenz) der Ausgangsleistung des Verstärkers (an einer Z0- Last ) zur Eingangsleistung (aus einer Z0-Quelle). Z0 ist die Systemimpedanz , in diesem Falle 50W.

Bei kleinen Signalpegeln ist die Ausgangsleistung des Verstärkers proportional zur Eingangsleistung. Die "Kleinsignalverstärkung" ist die Verstärkung in diesem linearen Arbeitsbereich.

Ab einem gewissen Eingangspegel gerät der Verstärker in die Sättigung – die Verstärkung nimmt ab, und die Ausgangsleistung nähert sich immer langsamer einem Maximalwert. Die "Großsignalverstärkung" ist die Verstärkung in diesem nichtlinearen Arbeitsbereich. Siehe Verstärkungskompression.

Frequenzgang

Die Änderung der Verstärkung innerhalb des Arbeitsfrequenzbereichs des Verstärkers. Siehe Kleinsignalverstärkung und Frequenzgang.

Ausgangsrückwirkung

Ein Maß für die Signalenergie, die vom Ausgang zum Eingang übertragen wird. Die Messung ist analog zur Verstärkungsmessung, wobei jedoch das Stimulussignal an den Ausgang des Verstärkers angelegt und das Response-Signal an dessen Eingang gemessen wird. Siehe Ausgangsrückwirkung.

Verstärkungsdrift in Abhängigkeit von der Zeit (Temperatur, Bias)

Die maximale Änderung der Verstärkung als Funktion der Zeit, wobei alle übrigen Parameter konstant gehalten werden. Die Verstärkungsdrift wird häufig auch als Funktion anderer Parameter wie Temperatur, Luftfeuchtigkeit oder Bias-Spannung gemessen.

Phasenlinearitätsabweichung

Die Stärke der Abweichung von einem linear mit der Frequenz ansteigenden Phasenfrequenzgang. Im Idealfall ist die von einem Verstärker verursachte Phasenverschiebung eine lineare Funktion der Frequenz. Siehe Phasenlinearitätsabweichung.

Gruppenlaufzeit

Ein Maß für die Zeit, die das Signal zum Durchlaufen des Verstärkers benötigt, als Funktion der Frequenz. Ein perfekt linearer Phasenfrequenzgang ergäbe eine konstante Gruppenlaufzeit. Siehe Gruppenlaufzeit.

Rückflussdämpfung (SWR, r)

Ein Maß für die Reflexionen, die dadurch verursacht werden, dass die Eingangs- oder Ausgangsimpedanz des Verstärkers von Z0, der Systemimpedanz abweicht.

Komplexe Impedanz

Komplexe Impedanz (1+G). Die Stärke der von einem Verstärker verursachten Reflexionen ist unmittelbar von dessen Impedanz (relativ zur Systemimpedanz) abhängig. Die komplexe Impedanz setzt sich aus einer resistiven und einer reaktiven Komponente zusammen. Sie wird aus der Systemimpedanz des Systems und dem Reflexionskoeffizienten des Messobjekts berechnet. Siehe Komplexe Impedanz.

Verstärkungskompression

Ein Verstärker hat einen linearen Arbeitsbereich, in dem die Verstärkung unabhängig vom Eingangssignalpegel ist (dies ist der Bereich der "Kleinsignalverstärkung"). Ab einem gewissen Eingangssignalpegel gerät der Verstärker in die Sättigung, und die Verstärkung nimmt ab; dieser Effekt wird als Verstärkungskompression bezeichnet.

Gemessen wird meist der 1-dB-Verstärkungskompressionspunkt (P 1dB ); dies ist der Signalpegel, bei dem die Verstärkung um 1 dB gegenüber der Kleinsignalverstärkung absinkt. Die Verstärkungskompression ist ein wichtiger Ausgangsparameter von Leistungsverstärkern. Siehe Verstärkungskompression.

AM-PM-Störmodulation

Ein Maß für die von einer Änderung des Eingangssignalpegels verursachte Änderung der Phase des Verstärkerausgangssignals.

Die AM-PM-Störmodulation wird in Grad/dB angegeben und ist auf einen bestimmten Signalpegel (üblicherweise den 1-dB-Verstärkungskompressionspunkt P1dB) bezogen. Siehe AM-PM-Störmodulation.


Siehe auch...

Komplexe Impedanz

Überblick

Konzepte

Wie misst man
die komplexe Impedanz?

Eine S11- oder S22-Messung liefert sowohl Komplexe-Impedanz-Daten wie z. B. Serienwiderstand und -reaktanz als auch Phasen- und Amplitudeninformationen. Komplexe-Impedanz-Daten können im Format "Smith Chart" oder "Polar" dargestellt werden.
Konzepte

Wie misst man die komplexe Impedanz?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die komplexe Impedanz?

Messdatendarstellung im Format "Smith Chart"

Messdatendarstellung im Format "Polar"

Betrachtungen zur Messgenauigkeit

Was ist die komplexe Impedanz?

Die komplexe Impedanz ist eine Größe, die aus den Ergebnissen einer S11- oder S22-Messung berechnet wird und folgende Informationen enthält:

  • Widerstand

  • Blindwiderstand (Reaktanz)

  • Phase

  • Amplitudenbetrag

Die Stärke der von einem Bauteil verursachten Reflexionen ist vom Verhältnis der Impedanz des Bauteils zu der des Messsystems abhängig. Beispielsweise ist der komplexe Reflexionskoeffizient (G) dann und nur dann 0, wenn die Impedanz des Bauteils exakt gleich der Systemimpedanz ist (in diesem Fall wird die gesamte Leistung von der Quelle zur Last übertragen). Der Zusammenhang zwischen G und der komplexen Impedanz wird durch die folgende Gleichung beschrieben:

ZL= [(1 + G) / (1 - G)] ´ Z0

wobei ZL die Impedanz des Messobjekts bezeichnet und Z0 die Systemimpedanz des Messsystems.

Messdatendarstellung im Format "Smith Chart"

Eine Möglichkeit zur Darstellung der komplexen Impedanz-Daten aus der S11- oder S22-Messung ist das Format "Smith Chart". Das Smith-Diagramm bildet den komplexen Reflexionskoeffizienten (G) auf die Impedanz des Messobjekts ab.

Jeder Punkt im Smith-Diagramm (siehe nachfolgende Abbildung) repräsentiert eine komplexe Impedanz, bestehend aus einem resistiven Realteil (R) und einem reaktiven Imaginärteil (jX). Es sind folgende Marker verfügbar:

  • "Resistance" (Widerstand in Ohm)

  • "Reactance" (Kapazität in Farad oder Induktivität in Henry)

Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

  • Die horizontale Achse (durchgezogene Linie) repräsentiert den Realteil (Widerstand) der Impedanz. Der Mittelpunkt der horizontalen Achse entspricht der Systemimpedanz.

  • Die gestrichelten Kreise, die die horizontale Achse schneiden, sind Ortskurven konstanten Widerstands. Die tangential zur horizontalen Achse verlaufenden gestrichelten Kreise sind Ortskurven konstanter Reaktanz.

  • In der oberen Hälfte des Smith-Diagramms ist die reaktive Komponente positiv; dies ist der induktive Bereich. In der unteren Hälfte des Smith-Diagramms ist die reaktive Komponente negativ; dies ist der kapazitive Bereich.

Messdatendarstellung im Format "Polar"

Alternativ zum Format "Smith Chart" können Sie das Format "Polar" verwenden, um den Amplitudenbetrag und die Phase des Reflexionskoeffizienten (G) aus der S11- oder S22-Messung darzustellen. Es sind folgende Marker verfügbar:

  • "Lin mag" (Amplitudenbetrag, dimensionslos) oder "log mag" (Amplitudenbetrag in dB)

  • "Phase" (Phase in Grad)

Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

  • Die gestrichelten Kreise repräsentieren den Reflexionskoeffizienten. Der äußerste Kreis repräsentiert den Reflexionskoeffizienten G=1 (Totalreflexion). Der Mittelpunkt der Kreise repräsentiert den Reflexionskoeffizienten G=0 (keine Reflexion).

  • Die radialen Linien zeigen den Phasenwinkel des reflektierten Signals. Die rechte X-Achse entspricht dem Phasenwinkel 0 Grad (reflektiertes Signal ist in Phase mit dem einfallenden Signal). Die positive Y-Achse, negative X-Achse und negative Y-Achse entsprechen jeweils den Phasenwinkeln 90°, ±180° bzw. -90°.

Betrachtungen zur Messgenauigkeit

  • Das Smith-Diagramm ist am einfachsten zu verstehen, wenn Sie einen Skalenendwert von 1.0 wählen.

  • Wenn Sie das Smith-Diagramm oder ein Polardiagramm mit Hilfe von Markern analysieren, können Sie die Messgenauigkeit durch Wahl der Marker-Betriebsart "Discrete" verbessern.

  • Die Genauigkeit einer Reflexionsmessung wird durch folgende Faktoren beeinflusst:

    • Richtverhältnis

    • Reflexions-Frequenzgang-Gleichlauf

    • Quellenanpassung

    • L ast anpassung (bei Zweitor-Bauteilen)

Durch eine 2-Port-Kalibrierung werden die Einflüsse dieser Fehlerquellen reduziert. Mit einer 1-Port-Kalibrierung erzielen Sie die gleiche Genauigkeit, sofern der Ausgang des Messobjekts korrekt abgeschlossen ist. Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

  • Für den Fall, dass Sie das Messobjekt zwischen die beiden Analysator-Ports anschließen, wird empfohlen, zur Verbesserung der Messgenauigkeit zwischen den Ausgang des Messobjekts und dem Empfängereingang des Analysators einen 10 dB-Abschwächer einzuschleifen. Dies ist nicht erforderlich, falls Sie eine 2-Port-Kalibrierung durchgeführt haben, da diese auch den Lastanpassungsfehler korrigiert.

  • Wenn Sie ein Zweitor-Bauteil nur an einen einzigen Analysator-Port anschließen, sollten Sie den Ausgang des Bauteils mit einer hochwertigen Last (beispielsweise einem Lastnormal aus einem Kalibrier-Kit) abschließen.

  1. Schließen Sie das Bauteil gemäß der obigen Abbildung an den Analysator an.

  2. Bringen Sie den Analysator in den "Preset"-Zustand.

  3. Richten Sie eine S11- oder S22-Messung ein, kalibrieren Sie den Analysator und führen Sie die Messung durch.

  4. Darstellung der Impedanz-Messdaten:

    1. Wählen Sie das Format "Smith Chart".

    2. Wählen Sie eine passende Skalierung.

    3. Bestimmen Sie mit Hilfe des Markers die resistive und die reaktive Komponente der komplexen Impedanz an den interessierenden Messkurvenpunkten.

    4. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

  5. Darstellung der Admittanz- (Scheinleitwert) Messdaten (falls gewünscht):

    1. Wählen Sie die Marker-Funktion zur Darstellung eines inversen Smith-Diagramms.

    2. Wählen Sie eine passende Skalierung.

    3. Bestimmen Sie mit Hilfe des Markers die Konduktanz- (Leitwert-) und Suszeptanz- (Blindleitwert-) Komponenten der komplexen Admittanz an den interessierenden Messkurvenpunkten. Sowohl Konduktanz als auch Suszeptanz werden in der Einheit Siemens (=1/Ohm) gemessen.

    4. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

  6. Darstellung des Amplitudenbetrags und der Phase des Reflexionskoeffizienten:

    1. Wählen Sie das Format "Smith Chart" oder "Polar".

    2. Wählen Sie das Marker-Anzeigeformat "Lin" oder "Log".

    3. Wählen Sie eine passende Skalierung.

    4. Bestimmen Sie mit Hilfe des Markers die Frequenz, den Amplitudenbetrag und die Phase des Reflexionskoeffizienten (G) an den interessierenden Messkurvenpunkten.

    5. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Siehe auch...

Gruppenlaufzeit

Überblick

Konzepte

Wie misst man die Gruppenlaufzeit?

Die Gruppenlaufzeit ist ein Maß für die Phasenverzerrung. Der (frequenzabhängige) Gruppenlaufzeitwert gibt an, wie lange ein Signal mit der betreffenden Frequenz zum Durchlaufen des Messobjekts benötigt. Bei der Angabe von Gruppenlaufzeitwerten sollte stets auch die bei der Messung verwendete Apertur angegeben werden.
Konzepte

Wie misst man die Gruppenlaufzeit?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die Gruppenlaufzeit?

Gruppenlaufzeit versus Phasenlinearitätsabweichung

Was ist die Apertur?

Betrachtungen zur Messgenauigkeit

Was ist die Gruppenlaufzeit?

Die Gruppenlaufzeit ist:

• Ein Maß für die von einem Bauteil verursachte Phasenverzerrung.
• Die Zeit, die ein Signal einer bestimmten Frequenz zum Durchlaufen des Bauteils benötigt.
• Die erste Ableitung der Phase nach der Frequenz.

Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

Der Phasenfrequenzgang eines Bauteils setzt sich typischerweise zusammen aus einer (frequenz-) linearen Phasenverschiebung und einer nichtlinearen Phasenverschiebung (Phasenlinearitätsabweichung).

Lineare Phasenverschiebung: | Phasenlinearitätsabweichung:
Repräsentiert die mittlere Signallaufzeit. | Repräsentiert die Abweichung von der mittleren Signallaufzeit in Abhängigkeit von der Frequenz.
Verursacht durch die elektrische Länge des Bauteils. | Ursache von Signalverzerrungen.

Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

Bei einer Gruppenlaufzeitmessung

  • wird die lineare Phasenverschiebung in einen konstanten Wert transformiert, der die mittlere Signallaufzeit repräsentiert;

  • werden die nichtlinearen Phasenverschiebungen in eine Abweichung von einer konstanten Gruppenlaufzeit (Gruppenlaufzeitwelligkeit) transformiert;

  • verursachen die Abweichungen von einer konstanten Gruppenlaufzeit Signalverzerrungen, so wie die Phasenlinearitätsabweichungen Signalverzerrungen verursachen;

  • zeigt die Messkurve die Zeit, die ein Signal mit der jeweiligen Frequenz zum Durchlaufen des Messobjekts benötigt.

Der Analysator berechnet die Gruppenlaufzeit nach folgender Gleichung:

  • Aus den Phasenmessdaten wird die Phasenänderung (-df) berechnet.

  • Der vorgegebene Apertur -Wert bestimmt die Frequenzänderung (dw).

  • Anhand der beiden obigen Werte wird die erste Ableitung der Phase nach der Frequenz berechnet.

  • Das Ergebnis dieser Approximation ist die Gruppenlaufzeit in Sekunden (es wird vorausgesetzt, dass die Phasenänderung innerhalb der spezifizierten Frequenzapertur linear verläuft).

Gruppenlaufzeit versus Phasenlinearitätsabweichung

Anhand einer Gruppenlaufzeitmessung lassen sich Phasenverzerrung oft deutlicher erkennen als anhand einer Messung der P hasenlinearitätsabweichung.

Der obere Teil der nachfolgenden Abbildung zeigt die Ergebnisse von Messungen der Phasenlinearitätsabweichung: Trotz des unterschiedlichen Aussehens der beiden Messkurven sind die Spitze-Spitze-Werte für die Bauteile 1 und 2 gleich.

Der untere Teil der Abbildung zeigt die Ergebnisse von Gruppenlaufzeitmessungen an den gleichen Bauteilen:
Bei dieser Messung erhält man unterschiedliche Spitze-Spitze-Werte für die Bauteile 1 und 2. Der Grund für die höhere Genauigkeit ist, dass der Analysator die Steilheit der Phasenschwankungen berechnet, welche von der Anzahl der Phasendurchgänge pro Frequenzeinheit abhängig ist.

Was ist die Apertur?

Bei einer Gruppenlaufzeitmessung misst der Analysator die Phase bei zwei nahe benachbarten Frequenzen und berechnet daraus die Steilheit des Phasenverlaufs in diesem Bereich. Das Frequenzintervall zwischen den beiden Phasenmesspunkten (Delta-f) wird als Apertur bezeichnet. Eine Änderung der Apertur kann sich auf die Gruppenlaufzeit-Messergebnisse auswirken. Die berechnete Steilheit (Delta-Phase) ändert sich mit zunehmender Apertur. Beim Vergleichen von Gruppenlaufzeitmessdaten sollten Sie deshalb stets die bei der Messung verwendete Apertur berücksichtigen.

Die folgenden Erläuterungen beziehen sich auf die untenstehende Grafik.

Enge Apertur: | Weite Apertur:
Liefert eine höher auflösende Darstellung der Phasenlinearitätsabweichung. | Liefert eine weniger hoch auflösende Darstellung der Phasenlinearitätsabweichung, weil einige Phasen-Response-Werte ausgemittelt oder nicht gemessen werden.
Erhöht die Rauschanfälligkeit der Messung (bzw. verringert den Signal/Rauschabstand) und erhöht die Abhängigkeit der Messergebnisse von der Phasendetektorauflösung. | Verringert die Rauschanfälligkeit der Messung (bzw. vergrößert den Signal/Rauschabstand).

Die Standardeinstellung für die Gruppenlaufzeit-Apertur ist gleich der Wobbelbandbreite dividiert durch die Anzahl der Messpunkte. Sie können die Apertur auf zweierlei Weise ändern.

  1. Durch Ändern der Anzahl der Messpunkte oder der Wobbelbandbreite.

  • Wenn Sie die Anzahl der Messpunkte vergrößern oder die Wobbelbandbreite verkleinern, verkleinert sich dadurch die Apertur.

  • Wenn Sie die Anzahl der Messpunkte verkleinern oder die Wobbelbandbreite vergrößern, vergrößert sich dadurch die Apertur.

Hinweis: Bei einer zu großen Apertur (mehr als 180° Phasenverschiebung zwischen zwei benachbarten Frequenzpunkten) treten Messfehler auf.

  2. Anwendung der "Smoothing"-Funktion.

  • Der Analysator berechnet (in jedem Wobbelzyklus) den gleitenden Mittelwert aus einer vorgegebenen Anzahl benachbarter Frequenzpunkte; die Anzahl der zur Mittelung herangezogen Frequenzpunkte wird in Prozent der Wobbelbandbreite spezifiziert.

  • Die Ergebnisse sind ähnlich wie bei einer Änderung des Frequenzpunkteabstands.

  • Die "Smoothing"-Funktion ermöglicht eine Vergrößerung der Apertur, weil über die "Smoothing"-Apertur eine Phasenverschiebung von mehr als 180º auftreten darf.

Gruppenlaufzeitmessungen sind auf folgende Wobbelungstypen anwendbar:

  • Lineare Frequenzwobbelung

  • Segmentwobbelung

Bei einer Segmentwobbelung ist die Gruppenlaufzeit-Apertur vom jeweiligen Frequenzpunkteabstand abhängig und daher nicht konstant. Bei Segmentwobbelung können zusätzliche Frequenzpunkte definiert werden, um die gewünschte Apertur zu gewährleisten.

Betrachtungen zur Messgenauigkeit

Es ist wichtig, die Phasendifferenz zwischen zwei benachbarten Messpunkten kleiner als 180° zu halten (siehe folgende Abbildung). Wenn dies nicht der Fall ist, sind die Phasen- und Laufzeitmessdaten ungültig. Bei Messungen an Bauteilen mit großer elektrischer Länge kann es zu einer Unterabtastung ("Undersampling") kommen. Sie können sicherstellen, dass die Phasendifferenz zwischen benachbarten Messpunkten kleiner als 180° ist, indem Sie die folgenden Einstellungen so lange ändern, bis sich die Messkurve nicht mehr signifikant ändert:

  • Vergrößern Sie die Anzahl der Messpunkte.

  • Verkleinern Sie die Wobbelbandbreite.

Die "E lectrical Delay"-Funktion kann ebenfalls zur Kompensation dieses Effekts herangezogen werden.

Die dominante Fehlerquelle bei einer Gruppenlaufzeitmessung ist der Frequenzgang . Durch eine Durchgang/Frequenzgang- Kalibrierung können Sie diesen Fehler deutlich reduzieren. Eine noch höhere Messgenauigkeit erzielen Sie mit einer 2-Port-Kalibrierung.

Insbesondere Verstärker haben oft eine temperaturabhängige Gruppenlaufzeit. Die Messungen sollten deshalb vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

Wie misst man die Gruppenlaufzeit?

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Falls es sich bei dem Messobjekt um einen Verstärker handelt, müssen Sie eventuell den Messignalpegel reduzieren:

    • Der Messignalpegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt).

    • Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  3. Schließen Sie das Messobjekt gemäß der folgenden Abbildung an den Analysator an.

  3. Wählen Sie die Messfunktion S21.

  4. Wählen Sie die passenden Analysatoreinstellungen, insbesondere:

    • "Number of points:" Maximum

    • "Format": "Delay"

    • Skalierung: "A utoscale"

  5. Entfernen Sie das Messobjekt und führen Sie eine Kalibrierung durch.

  6. Schließen Sie das Messobjekt wieder an.

  7. Wählen Sie eine passende Skalierung.

  8. Reduzieren Sie das Rauschen, indem Sie mit Hilfe der "Smoothing"-Funktion die Apertur vergrößern. (Vergrößern Sie die Apertur nur so weit, dass noch genügend Details zu sehen sind). So vergrößern Sie die Apertur:

    • Aktivieren Sie die "Smoothing"-Funktion.

    • Vergrößern Sie die "Smoothing"-Apertur (auf maximal 25% der Wobbelbandbreite).

  9. Messen Sie die Gruppenlaufzeit (in Sekunden) bei den interessierenden Frequenzen mit Hilfe der Marker.

  10. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Ausgangspegel

Siehe auch...

Absolutleistungsmessungen

Überblick

Konzepte

Wie misst man die
Absolutleistung?

Eine Absolutleistungsmessung zeigt die Absolutleistung über der Frequenz.
Konzepte

Wie misst man die Absolutleistung?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die Absolutleistung?

Warum muss die Absolutleistung gemessen werden?

Betrachtungen zur Messgenauigkeit

Was ist die Absolutleistung?

Eine Absolutleistungsmessung zeigt die Leistung am Eingangsport des Analysators. Diese Leistung (bzw. dieser Pegel im logarithmischen Maßstab) ist ein absoluter, nicht auf die einfallende Leistung oder Signalquellenleistung bezogener Wert. Wenn Sie das Format "Log mag" wählen, wird statt der Leistung in Watt der Pegel in dBm (dB bezogen auf 1 mW) angezeigt.

  • 0 dBm = 1 mW

  • -10 dBm = 100 mW

  • +10 dBm = 10 mW

Wenn Sie das Format "Linear mag" wählen, wird die Leistung in Watt (W) angezeigt.

Warum muss die Absolutleistung gemessen werden?

Absolutleistungsmessungen sind erforderlich, wenn die Ausgangsleistung eines Verstärkers als eine (nicht auf die Eingangsleistung bezogene) Absolutleistung quantifiziert werden muss. Bei einer Kompressionsmessung, beispielsweise, wird üblicherweise auch die Absolutleistung am Kompressionspunkt gemessen. Diese Messung liefert die Ausgangsleistung, bei welcher die Verstärkung um 1 dB unter der Kleinsignalverstärkung liegt.

Betrachtungen zur Messgenauigkeit

  • Die Ausgangsleistung des Verstärkers sollte, falls erforderlich, ausreichend abgeschwächt werden. Eine zu hohe Ausgangsleistung könnte

    • den Empfänger im Analysator beschädigen

    • den Eingangskompressionspegel des Analysators überschreiten und dadurch die Messung verfälschen

  • Eine Abschwächung der Ausgangsleistung des Verstärkers können Sie erreichen durch Verwendung eines

    • Abschwächers oder

    • Kopplers

  • Der Verstärker kann sich bei unterschiedlichen Temperaturen höchst unterschiedlich verhalten. Die Messungen sollten vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

So führen Sie eine Absolutleistungsmessung durch:

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Wählen Sie die Messfunktion "Unratioed power" (Empfänger B).

  3. Stellen Sie den Ausgangssignalpegel der internen Signalquelle auf 0 dBm ein.

  4. Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  5. Schließen Sie den Verstärker gemäß der folgenden Abbildung an, und legen Sie die erforderliche DC-Vorspannung an.

  6. Stellen Sie den Analysator so ein, wie es für die Messung an dem jeweiligen Verstärker erforderlich ist.

  7. Entfernen Sie den Verstärker und verbinden Sie die Messanschlüsse direkt miteinander. Speichern Sie die Messkurve ab. Falls Sie zur Verstärkermessung Abschwächer und/oder Kabel verwenden, lassen Sie diese auch während der Kalibrierung im Signalpfad.

  8. Speichern Sie den Gerätezustand ab.

  9. Schließen Sie den Verstärker wieder an.

  10. Wählen Sie die "Data math"-Funktion "Data/Memory".

  11. Wählen Sie eine geeignete Skalierung und messen Sie mit Hilfe eines Markers die Absolutleistung bei der interessierenden Frequenz.

  12. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Leistungsbauteile

Siehe auch...

Messungen an Leistungsbauteilen

Überblick

Konzepte

Block-
schaltbild

Standard-
konfigurationen

Opt.
015

Wie misst man
Leistungsbauteile

Sie können den Analysator für Messungen an Leistungsbauteilen konfigurieren. Unter einem "Leistungsbauteil" ist in diesem Zusammenhang ein Bauteil (oder Gerät) zu verstehen, auf das mindestens eines der beiden folgenden Attribute zutrifft:

  • Die Messungen erfordern einen höheren Eingangssignalpegel, als der Analysator liefern kann.

  • Der Ausgangssignalpegel des Bauteils liegt über dem maximal zulässigen Eingangssignalpegel des Empfängers im Analysator.

Die Konfigurationen für Messungen an Leistungsbauteilen sind zugeschnitten auf:

  • Verstärkung des vom Analysator gelieferten Stimulussignals mit Hilfe eines externen Leistungsverstärkers.

  • Abschwächung des vom Messobjekt gelieferten Ausgangssignals zum Schutz des Analysators vor Überlastung.
Konzepte

Blockschaltbilder und Konfigurations-Auswahlhilfe

Standard-Analysatorkonfigurationen

Analysatorkonfigurationen mit Option 015

Wie misst man Leistungsbauteile?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Warum können Messungen an Leistungsbauteilen eine Herausforderung sein?

Leistungsverstärker für CDMA-Basisstationen

Externe Pegelregelung

Kalibrierung

Messungen an Verstärkern mit automatischer Verstärkungsregelung

Betrachtungen zur Messgenauigkeit

Warum können Messungen an Leistungsbauteilen eine Herausforderung sein?

Die Herausforderungen bestehen u. a. in folgendem:

  • Sichere Messung leistungsstarker Signale und genaue Messung schwacher Signale.

  • K alibrierung und Messgenauigkeit.

  • Bestimmte Kalibrierverfahren sind nicht anwendbar.

  • Nicht alle sonst messbaren Parameter sind messbar.

Einige Konfigurationen erlauben beispielsweise keine Messungen in Rückwärtsrichtung. Deshalb können auch einige Kalibrierverfahren nicht angewandt werden; dies begrenzt die Messgenauigkeit.

Weitere Informationen über Messungen an Leistungsbauteilen mit einem Netzwerkanalysator finden Sie im Internet unter http://\www.agilent.com/find/pna. Suchen Sie nach der Application Note 1287-6, "Using a Network Analyzer to Characterize High-Power Components" (Agilent-Teilenummer 5966-3319E).

Leistungsverstärker für CDMA-Basisstationen

Die Ausgangsleistung von HF-Leistungsverstärkern für CDMA-Basisstationen muss so hoch sein, dass der Sender auch in größerer Entfernung noch von den Mobilstationen empfangen werden kann. Zwei typische Anforderungen an Leistungsverstärker für CDMA-Basisstationen sind:

  • Ausgangsleistung 8 bis 45 W (39 bis 46,5 dBm)

  • Verstärkung 30 bis 40 dB

(Diese Anforderungen können – je nach System-Design – von Hersteller zu Hersteller differieren)

Die hohe Ausgangsleistung eines solchen Verstärkers muss für die Messungen auf einen Pegel reduziert werden, der vom Analysator sicher verarbeitet werden kann. Bei der Auswahl der folgenden Komponenten sollten Sie auf adäquate Leistungsfestigkeit achten (siehe nachfolgende Abbildung).

  • Bei Verwendung eines Analysators in Standardausführung muss am Ausgang des zu testenden Verstärkers ein externer, für hohe Leistungen geeigneter Koppler eingeschleift werden. Dieser Koppler dient dazu, die hohe Ausgangsleistung des Messobjekts auf einen für den Analysator akzeptablen Pegel zu reduzieren. Der Durchgangsarm des Kopplers wird mit einer speziellen, für hohe Verlustleistungen ausgelegten Last abgeschlossen. Der Koppelarm ist über einen externen, für hohe Leistungen ausgelegten Abschwächer an den Analysatoreingang angeschlossen.

  • Bei Verwendung eines Analysators mit Option 015 (konfigurierbares Testset) werden nur der externe Hochleistungskoppler und die oben erwähnte Last benötigt. Der externe Abschwächer wird nicht benötigt, weil Option 015 interne Stufenabschwächer (0 bis 35 dB) zum Schutz des Empfängers beinhaltet.

Hinweis: Der Eingangspegel am Messanschluss des Analysators darf auf keinen Fall +30 dBm (1 Watt) überschreiten.

Im Interesse einer hohen Messgenauigkeit sollten auch thermische Effekte, die bei der Messung eine Rolle spielen könnten, berücksichtigt werden. Bei Messungen an Leistungsverstärkern für CDMA-Basisstationen, beispielsweise, muss die Last am Ausgangskoppler

  • in der Lage sein, die vom Messobjekt gelieferte Leistung zu absorbieren. Die meisten Lasten sind für Kleinsignal-Anwendungen vorgesehen und für Leistungen bis etwa 1 Watt ausgelegt. Für Messungen bei höheren Leistungen müssen spezielle Lasten verwendet werden, die für höhere Verlustleistungen ausgelegt sind.

  • Gelegenheit zur Temperaturstabilisierung haben, falls ihre Impedanz in signifikanter Weise temperaturabhängig ist.

Externe Pegelregelung

Die Nichtlinearitäten eines externen Leistungsverstärkers können durch eine externe Pegelregelung kompensiert werden; dies kommt der Messgenauigkeit zugute. Bei Konfigurationen mit externer Pegelregelung ist dem Booster-Verstärker ein Koppler nachgeschaltet, dessen Koppelarm das Referenzsignal zu einem Leistungsteiler leitet. Vom Leistungsteiler aus wird das Referenzsignal an zwei Stellen weitergeleitet:

  • An den Referenzempfänger im Analysator.

  • Über die externe Schaltung zur Pegelregelung an den "External-detector"-Eingang auf der Rückwand des Analysators.

Die folgenden Erläuterungen beziehen sich auf die untenstehende Abbildung, die eine (vom Benutzer beizustellende) externe Schaltung zur Pegelregelung zeigt.

  • Die externe Schaltung zur Pegelregelung besteht im wesentlichen aus

    • einer Detektordiode

    • einem Operationsverstärker

  • Die Kombination aus Diode und Operationsverstärker liefert eine von der HF-Leistung abhängige Gleichspannung, die über den "External-Detector"-Eingang die Leistung der analysatorinternen Stimulussignalquelle in der Weise nachregelt, dass sich am Messobjekt in Echtzeit ein ebener Frequenzgang ergibt.

  • Damit die externe Pegelregelung ordnungsgemäß funktioniert, muss die Spannung am "External Detector"-Eingang zwischen -0,002 mVDC und -6 VDC betragen (je nach Frequenz und Signalpegel).

  • Bei einer zu großen Änderung des Referenzsignalpegels, bedingt durch eine Einstellungsänderung der internen Stufenabschwächer, kann die externe Pegelregelung unwirksam werden.

Hinweis: Bei einer Kalibrierung muss die externe Pegelregelung in Betrieb sein, genau wie bei den späteren Messungen.

Die untenstehenden Abbildungen zeigen zwei Konfigurationen für Messungen an Leistungsbauteilen mit externer Pegelregelung. Bei der ersten Konfiguration handelt es sich um einen Analysator in Standardausführung, der für Hochleistungsmessungen nur in Vorwärtsrichtung erweitert wurde. Bei der zweiten Konfiguration handelt es sich um einen mit Option 015 (konfigurierbares Testset) ausgestatteten Analysator, der für Hochleistungsmessungen in Vorwärts- und Rückwärtsrichtung erweitert wurde.

In einer Hochleistungskonfiguration beeinflusst die Performance des Booster-Verstärkers die Genauigkeit der Messung am Messobjekt. Wie aus der folgenden Abbildung ersichtlich ist, überträgt sich die Welligkeit im Frequenzgang des Booster-Verstärkers auch auf die Messkurve.

Mögliche Ursachen für die Welligkeit im Frequenzgang des Booster-Verstärkers sind:

  • Minderwertiger Booster-Verstärker.

  • Verrauschte Betriebsspannung.

  • Gesättigter Booster-Verstärker.

Kalibrierung

Durch Kalibrierung können Sie die systematischen Messfehler reduzieren und die Messgenauigkeit verbessern. In diesem Tutorial wird aufgezeigt, welche Kalibrierverfahren auf die diversen Konfigurationen anwendbar sind. Es kommen folgende Kalibrierungsverfahren in Frage:

  • 2-Port-Kalibrierung: Dies ist das genaueste Kalibrierverfahren, denn es eliminiert alle systematischen Fehler der Messanordnung.

  • Durchgang-Frequenzgang-Kalibrierung: weniger genau, eliminiert nur die Frequenzgang-Gleichlauffehler. Die Frequenzgang-Gleichlauffehler resultieren aus den Frequenzgang-Unterschieden zwischen den Kanälen.

Hinweis: Bei der Kalibrierung müssen alle Komponenten, die für die späteren Messungen verwendet werden, im Signalweg enthalten sein. Beispielsweise müssen alle Booster-Verstärker, Kabel, Abschwächer oder Koppler, die bei den späteren Messungen am Messobjekt verwendet werden, im Signalweg enthalten sein.

Nachfolgend werden diverse Verfahren zur Optimierung der Kalibriergenauigkeit erörtert.

Dynamische Genauigkeit

Durch Berücksichtigung der dynamischen Genauigkeit des Analysators können Sie die Signalpegel für Kalibrierung und Messungen optimieren. Die dynamische Genauigkeit betrifft die Unsicherheit, die dadurch entsteht, dass die Messung bei einem anderen Signalpegel erfolgt als die Kalibrierung. Die Messunsicherheit des Analysators ist, unabhängig vom Kalibrierungspegel, bei Empfängereingangspegeln zwischen -10 und -60 dBm extrem gering. Wählen Sie die Signalpegel sowohl bei der Kalibrierung als auch bei den Messungen so, dass der Empfängereingangspegel immer in diesem hochgenauen Bereich liegt. Bei niedrigeren Signalpegeln verschlechtert sich die Messgenauigkeit durch Rauschen, bei höheren Signalpegeln durch Signalkompression m Empfänger.

Kalibriersignalpegel

Wenn – wie es bei Verstärkermessungen der Fall ist – der Ausgangssignalpegel größer als der Eingangssignalpegel ist, stellt sich die Frage, bei welchem Signalpegel die Kalibrierung erfolgen soll. Ganz allgemein sollte die Kalibrierung bei dem größtmöglichen Signalpegel durchgeführt werden, bei dem noch keine Signalkompression im Empfänger stattfindet; dadurch wird das Rauschen bei der Kalibrierung minimiert.

Kalibrierung bei einem einzigen Signalpegel oder bei zwei Signalpegeln?

Kalibrierung bei einem einzigen Signalpegel:

  • Eine Frequenzgangkalibrierung kann bei einem einzigen Signalpegel erfolgen, weil dabei nur eine einzige Wobbelmessung (in Vorwärtsrichtung) durchgeführt wird.

  • Auch eine 2-Port-Kalibrierung kann bei einem einzigen Signalpegel erfolgen. Der dafür optimale Signalpegel lässt sich anhand der "Dynamische-Genauigkeit"-Spezifikation (-10 und -60 dBm) bestimmen.

Kalibrierung bei zwei Signalpegeln:

  • Eine 2-Port-Kalibrierung kann bei unterschiedlichen Signalpegeln erfolgen, weil dabei Wobbelmessungen in Vorwärts- und Rückwärtsrichtung durchgeführt werden.

  • Der Analysator bietet die Möglichkeit, die beiden Ports bei unterschiedlichen Signalpegeln zu kalibrieren und dadurch die Kalibrierbedingungen optimal an die Bedingungen bei den späteren Messungen am Messobjekt anzupassen.

Verwendung von Kalibriernormalen bei hohen Signalpegeln

Bei einer Kalibrierung mit hohem Signalpegel müssen Sie darauf achten, dass das Lastnormal eine ausreichende Leistungsfestigkeit besitzt.

  • Die Last muss in der Lage sein, die ihr zugeführte Energie zu absorbieren.

  • Die Leerlauf-, Kurzschluss- und Durchgangsnormale sind in dieser Hinsicht unproblematisch, weil sie keine Energie absorbieren.

VORSICHT: Bei einer Leerlauf- oder Kurzschluss- Kalibrierung muss der Kalibriersignalpegel so niedrig gewählt werden, dass der Pegel des reflektierten Signals den maximal zulässigen Empfängereingangspegel (+30 dBm) nicht überschreitet.

Messungen an Verstärkern mit automatischer Verstärkungsregelung

Einige Verstärker enthalten eine AGC- (Automatic Gain Control) Schaltung zur automatischen Pegelregelung. Der AGC-Regelkreis versucht, den Ausgangspegel des Verstärkers konstant zu halten, indem er die Verstärkung in Abhängigkeit vom Eingangspegel variiert. Verstärker mit AGC-Schaltung können bei Messungen mit einem Netzwerkanalysator Probleme aufwerfen – insbesondere bei Messungen mit hohen Signalpegeln.

Solche Verstärker können in einen unkontrollierten Zustand geraten, wenn das Eingangssignal abgeschaltet wird. Bei Wobbelmessungen, die auf ein einziges Frequenzband beschränkt sind, stellt dies kein Problem dar, weil der Analysator dann auch während des Wobbelrücklaufs den Messsignalpegel beibehält. Bei einer Wobbelung über mehrere Frequenzbänder wird allerdings das Ausgangssignal während der Bandumschaltung vorübergehend abgeschaltet. Dies gilt sowohl für die Messung als auch für den Wobbelrücklauf. Bandumschaltungen erfolgen bei folgenden Frequenzen:

  • 10 MHz

  • 750 MHz

  • 1500 MHz

  • 3000 MHz

  • 4500 MHz

  • 6500 MHz

Wenn das Messsignal abgeschaltet wird, versucht die AGC-Schaltung des Verstärkers, durch eine Erhöhung der Verstärkung den Ausgangspegel konstant zu halten. Wenn dann das Messsignal plötzlich wieder eingeschaltet wird, besitzt der Verstärker eine hohe Verstärkung und liefert einen entsprechend hohen Ausgangspegel. Falls die AGC-Schaltung nicht schnell genug reagiert, kann der kurzzeitig erhöhte Ausgangspegel folgende Komponenten beschädigen oder zerstören:

  • Verstärker

  • Empfänger im Analysator

Bei Kalibrierungen oder Messungen über mehrere Frequenzbänder hinweg müssen Sie sich dieser Gefahr bewusst sein.

Betrachtungen zur Messgenauigkeit

  • Die elektrischen Charakteristiken von Leistungsbauteilen können in hohem Maße temperaturabhängig sein. Deshalb sollten die Messungen vorgenommen werden, wenn das Bauteil seine normale Betriebstemperatur erreicht hat.

  • Die M essunsicherheit lässt sich verringern, indem man das einfallende Signal hinter (statt vor) dem Booster-Verstärker misst. Dadurch werden die Einflüsse einer etwaigen Quellenfehlanpassung kompensiert.

  • Falls Ihre Anwendung einen externen Abschwächer oder Koppler erfordert, gehen Sie folgendermaßen vor, um eine Überlastung des analysatorinternen Empfängers auszuschließen.

    • Bestimmen Sie den maximalen Signalpegel am Empfängereingang.

    • Subtrahieren Sie davon den am Empfängereingang erforderlichen Signalpegel.

    • Wählen Sie die Abschwächung des Abschwächers oder Kopplers (oder beider Komponenten) so, dass sich der gewünschte Empfängereingangspegel ergibt.

  • Durch Reduzieren der ZF-Bandbreite oder durch Messdatenmittelung können Sie die Messgenauigkeit zu Lasten der Messgeschwindigkeit verbessern.

Blockschaltbild der Standardausführung des Analysators

Blockschaltbild des Analysators mit Option 015

Konfigurations-Auswahlhilfe

Blockschaltbild der Standardausführung des Analysators

Analysator mit Option 015 (konfigurierbares Testset)

Der mit Option 015 (konfigurierbares Testset) ausgestattete Analysator bietet zwei Leistungsmerkmale, die ihn für Messungen bei höheren Signalpegeln qualifizieren:

  • Stufenabschwächer (0 bis 35 dB) zwischen den Kopplern und Empfängern für die Ports 1 und 2. Diese Stufenabschwächer ermöglichen es, den Signalpegel am Empfängereingang zu optimieren. Siehe Ausgangsabschwächer.

  • Direktzugriff (über die Kanäle SOURCE OUT und COUPLER IN) auf die HF-Stimulussignalpfade für die Ports 1 und 2. Dies ermöglicht folgendes:

    • Einschleifen eines Booster-Verstärkers in einer Weise, die eine Beeinträchtigung der Messgenauigkeit durch die A usgangsrückwirkung des Booster-Verstärkers ausschließt.

    • Einschleifen von hochbelastbaren Isolatoren zum Schutz der analysatorinternen Komponenten.

Konfigurations-Auswahlhilfe

Die nachfolgenden Konfigurationen unterscheiden sich hinsichtlich Messgenauigkeit und Funktionalität:
Konfiguration 1 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), kein Booster-Verstärker, 2-Port-Kalibrierung

Konfiguration 2 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), Frequenzgangkalibrierung

Konfiguration 3 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), 2-Port-Kalibrierung

Konfiguration 4 (Analysator mit Option 015): Messungen an Leistungsbauteilen (eine Richtung), Frequenzgangkalibrierung

Konfiguration 5 (Analysator mit Option 015): Messungen an Leistungsbauteilen (eine Richtung), 2-Port-Kalibrierung

Konfiguration 6 (Analysator mit Option 015): Messungen an Leistungsbauteilen (beide Richtungen), 2-Port-Kalibrierung

Bei der Auswahl der passenden Konfiguration müssen Sie folgendes beachten:

  • Eigenschaften des Messobjekts

  • Erforderliche Messungen

  • Geforderte Messgenauigkeit

Die folgenden Hilfen sollen Ihnen die Auswahl der für Ihre Anwendung optimalen Konfiguration erleichtern.

  • Blockschaltbilder der Konfigurationen für Messungen an Leistungsbauteilen

  • Informationen zu folgenden Themen:

    • Erforderliche Geräte

    • Verfügbare Kalibrierverfahren

    • Vorteile und Einschränkungen der einzelnen Konfigurationen

  • Tabellen der Konfigurationscharakteristiken für Analysatoren in Standardausführung und mit Option 015

Analysator in Standardausführung
Messungen an Leistungsbauteilen |  |  |  |  | Kalibrierverfahren
Konfig. | Ausgangs- Booster | Vorw. Transm. | Vorw. Transm. und Refl. | Vorw./ Rückw. | 2 -Port | Durchgang
1 |  |  |  | X | X | X
2 | X | X |  |  |  | X
3 | X |  | X |  | X | X

Option 015, konfigurierbares Testset
Messungen an Leistungsbauteilen |  |  |  |  | Kalibrierverfahren
Konfig. | Ausgangs- Booster | Vorw. Transm. | Vorw. Transm. und Refl. | Vorw./ Rückw. | 2 -Port | Durchgang
4 | X |  | X |  |  | X
5 | X |  | X |  | X | X
6 | X |  |  | X | X | X

Die nachfolgenden Konfigurationen der Standardausführung des Analysators unterscheiden sich hinsichtlich Messgenauigkeit und Funktionalität:
Konfiguration 1 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), kein Booster-Verstärker, 2-Port-Kalibrierung

Konfiguration 2 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), Frequenzgangkalibrierung

Konfiguration 3 (Standardausführung des Analysators): Messungen an Leistungsbauteilen (eine Richtung), 2-Port-Kalibrierung

Konfiguration 1 (Standardausführung des Analysators):

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen sind nur in einer Richtung möglich

  • Externe Abschwächung für den Port-2-Empfänger erforderlich

  • S11, S12, S21 und S22

  • 2-Port-Kalibrierung

  • 1 externe Komponente

  • Verkleinerter D ynamikbereich durch Leistungsverlust an den Port-Kopplern

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Keine hohen Eingangssignalpegel erforderlich (d. h. der Ausgangspegel der analysatorinternen Signalquelle reicht aus)

    • Die Messungen erfolgen typischerweise im linearen Arbeitsbereich des Bauteils

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Messobjekt zwischen dem Analysator-Port 1 und einem Abschwächer oder Koppler.

  • Ein Abschwächer oder Koppler zwischen dem Messobjekt und dem Analysator-Port 2. Da das Messobjekt eine hohe Verstärkung aufweist, muss der Empfängereingang vor Überlastung geschützt werden.

Falls Sie einen Koppler verwenden, schließen Sie dessen Durchgangsarm mit einer Systemimpedanz-Last ab. Der Koppelarm des Kopplers leitet einen kleinen Teil der Eingangssignalleistung an den Port 2. Bei einem 20-dB-Koppler liegt der Signalpegel am Koppelarm um 20 dB unter dem Signalpegel am Eingang.

Verfügbare Kalibrierverfahren

  • 2-Port

  • Durchgang-Frequenzgang

Die Abschwächung an Port 2 verschlechtert das R ichtverhältnis von Port 2 um das Doppelte des Abschwächungsfaktors. Dies begrenzt die Stabilität der Kalibrierung und kann zu einem starken Rauschen bei S22-Messungen führen. Falls S22-Messungen erforderlich sind:

  1. Führen Sie eine Kalibrierung für Rückwärtsmessungen bei hohem Messsignalpegel durch.

  2. Verringern Sie den Messsignalpegel bei Vorwärtsmessungen.

  3. Erhöhen Sie den Messsignalpegel bei Rückwärtsmessungen.

Konfiguration 2 (Standardausführung des Analysators):

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen sind nur in einer Richtung möglich

  • Externe Abschwächung für den Port-2-Empfänger erforderlich

  • Nur S21-Messungen möglich (S11-Messungen wegen des Booster-Verstärkers nicht möglich)

  • Durchgang-Frequenzgang-Kalibrierung

  • Verringerter Dynamikbereich durch Leistungsverlust am Port-2-Koppler

  • Keine Leistungsverluste durch Booster-Verstärker im Testset

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Hoher Eingangssignalpegel erforderlich, der den Einsatz eines Booster-Verstärkers notwendig macht

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Ein Booster-Verstärker vor dem Port 1.

  • Ein Koppler zwischen dem Booster-Verstärker und dem Messobjekt.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R1 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

  • Das Messobjekt liegt zwischen dem Koppler und einem Abschwächer oder Koppler.

  • Der Abschwächer oder Koppler liegt zwischen dem Ausgang des Messobjekts und dem Messanschluss des Analysators. Da das Messobjekt eine hohe Verstärkung aufweist, muss der analysatorinterne Empfänger vor Überlastung geschützt werden.

Falls Sie einen Koppler verwenden, schließen Sie dessen Durchgangsarm mit einer Systemimpedanz-Last ab. Der Koppelarm des Kopplers leitet einen kleinen Teil der Eingangssignalleistung an den Port 2. Bei einem 20-dB-Koppler liegt der Signalpegel am Koppelarm um 20 dB unter dem Signalpegel am Eingang.

Konfiguration 3 (Standardausführung des Analysators):

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen sind nur in einer Richtung möglich

  • Externe Abschwächung für den Port-2-Empfänger erforderlich

  • S11, S21

  • 2-Port- und Durchgang-Frequenzgang-Kalibrierung

  • 6 externe Komponenten

  • Verkleinerter D ynamikbereich durch Leistungsverlust am Port-2-Koppler

  • Keine Leistungsverluste durch Booster-Verstärker im Testset

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Hoher Eingangssignalpegel erforderlich, der den Einsatz eines Booster-Verstärkers notwendig macht

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Ein Booster-Verstärker vor dem Port 1.

  • Ein Koppler am Ausgang des Booster-Verstärkers.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R1 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

  • Ein Rückwärtskoppler zwischen dem Vorwärtskoppler und dem Messobjekt.

  • Der Koppelarm des Rückwärtskopplers ist am Eingang A IN anzuschließen. Dieses Signal wird für Vorwärtsreflexionsmessungen benötigt.

  • Das Messobjekt liegt zwischen dem Rückwärtskoppler und einem Abschwächer oder Koppler.

  • Der Abschwächer oder Koppler liegt zwischen dem Ausgang des Messobjekts und dem Messanschluss des Analysators. Da das Messobjekt eine hohe Verstärkung aufweist, muss der analysatorinterne Empfänger vor Überlastung geschützt werden.

Falls Sie einen Koppler verwenden, schließen Sie dessen Durchgangsarm mit einer Systemimpedanz-Last ab. Der Koppelarm des Kopplers leitet einen kleinen Teil der Eingangssignalleistung an den Port 2. Bei einem 20-dB-Koppler liegt der Signalpegel am Koppelarm um 20 dB unter dem Signalpegel am Eingang.

Die nachfolgenden Konfigurationen unterscheiden sich hinsichtlich Messgenauigkeit und Funktionalität:
Konfiguration 4 (Analysator mit Option 015): Messungen an Leistungsbauteilen (eine Richtung), Frequenzgangkalibrierung

Konfiguration 5 (Analysator mit Option 015): Messungen an Leistungsbauteilen (eine Richtung), 2-Port-Kalibrierung

Konfiguration 6 (Analysator mit Option 015): Messungen an Leistungsbauteilen (beide Richtungen), 2-Port-Kalibrierung

Konfiguration 4 (Analysator mit Option 015)

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen sind nur in einer Richtung möglich

  • Verwendet den analysatorinternen Empfänger B

  • S11, S21

  • Durchgang-Frequenzgang Kalibrierung

  • 3 externe Komponenten

  • Kanal B IN erlaubt größtmöglichen D ynamikbereich

  • Verringerter Dynamikbereich durch Leistungsverlust am Port-1-Koppler

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Hoher Eingangssignalpegel erforderlich, der den Einsatz eines Booster-Verstärkers notwendig macht

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Ein Booster-Verstärker am Kanal Port 1 SOURCE OUT.

  • Ein Koppler zwischen dem Booster-Verstärker und dem Kanal 1 COUPLER IN.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R1 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

  • Messobjekt zwischen dem Analysator-Port 1 und dem Kanal B IN. Die Verwendung des Kanals B IN maximiert den Dynamikbereich, da kein Leistungsverlust durch den Port-2-Koppler auftritt.

Da das Messobjekt eine hohe Verstärkung aufweist, muss der analysatorinterne Empfänger vor Überlastung geschützt werden. Verwenden Sie zum Schutz des Empfängers B den analysatorinternen Stufenabschwächer (0 bis 35 dB).

Konfiguration 5 (Analysator mit Option 015)

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen sind nur in einer Richtung möglich

  • Die analysatorinternen Komponenten werden durch einen externen Isolator vor Überlastung geschützt

  • S11, S21

  • Durchgang-Frequenzgang- und 2-Port-Kalibrierung

  • 4 externe Komponenten

  • Verringerter Dynamikbereich durch Leistungsverlust in den Port-Kopplern

  • Isolator zum Schutz des Schalters und der Signalquelle

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Hoher Eingangssignalpegel erforderlich, der den Einsatz eines Booster-Verstärkers notwendig macht

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Ein Booster-Verstärker am Kanal Port 1 SOURCE OUT.

  • Ein Koppler zwischen dem Booster-Verstärker und dem Kanal 1 COUPLER IN.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R1 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

  • Messobjekt zwischen den Analysator-Ports 1 und 2.

  • Ein Isolator zwischen den Kanälen Port 2 SOURCE OUT und COUPLER IN.

Da das Messobjekt eine hohe Verstärkung aufweist, muss der analysatorinterne Empfänger vor Überlastung geschützt werden. Verwenden Sie zum Schutz des Empfängers B den analysatorinternen Stufenabschwächer (0 bis 35 dB).

Konfiguration 6 (Analysator mit Option 015)

Besonderheiten dieser Konfiguration:

  • Messungen an Leistungsbauteilen in beiden Richtungen (vorwärts und rückwärts) möglich

  • S11, S12, S21 und S22

  • Durchgang-Frequenzgang- und 2-Port-Kalibrierung

  • 6 externe Komponenten

  • Verkleinerter D ynamikbereich durch Leistungsverlust an den Port-Kopplern

  • Geeignet für Messungen an Bauteilen mit folgenden Eigenschaften:

    • Hohe Verstärkung

    • Hoher Eingangssignalpegel erforderlich, der den Einsatz eines Booster-Verstärkers notwendig macht

Erforderliche Geräte

Das Blockschaltbild zeigt die erforderlichen Geräte und deren Verkabelung:

  • Ein Booster-Verstärker am Kanal Port 1 SOURCE OUT.

  • Ein Koppler zwischen dem Booster-Verstärker und dem Kanal 1 COUPLER IN.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R1 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

  • Messobjekt zwischen den Analysator-Ports 1 und 2.

  • Ein Booster-Verstärker am Kanal Port 2 SOURCE OUT.

  • Ein Koppler zwischen dem Booster-Verstärker und dem Kanal 2 COUPLER IN.

  • Ein Abschwächer am Koppelarm des Kopplers.

  • Der ausgekoppelte Teil des booster-verstärkten Stimulussignals wird dem Eingang R2 IN zugeführt. Dieses Signal dient als Referenzsignal für Verhältnismessungen.

Da das Messobjekt eine hohe Verstärkung aufweist, müssen die analysatorinternen Empfänger vor Überlastung geschützt werden. Verwenden Sie zum Schutz der Empfängers A und B die analysatorinternen Stufenabschwächer (0 bis 35 dB).

Wie misst man Leistungsbauteile?

  1. Wählen Sie die für das Messobjekt und Ihre Messanforderungen passende Analysatorkonfiguration. Schließen Sie das Messobjekt noch nicht an.

  2. Bringen Sie den Analysator in den "Preset"-Zustand.

  3. Falls es sich bei dem Messobjekt um einen Verstärker handelt, müssen Sie eventuell den Messignalpegel reduzieren:

    • Der Messignalpegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt).

    • Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  4. Wählen Sie die gewünschte Messfunktion.

  5. Schließen Sie das Messobjekt an.

  6. Nehmen Sie die erforderlichen Einstellungen vor.

  7. Entfernen Sie das Messobjekt und führen Sie eine Kalibrierung durch. Bei der Kalibrierung müssen Komponenten der Messanordnung einschließlich Booster-Verstärkern, Kabeln, Abschwächern oder Kopplern im Signalweg enthalten sein.

  8. Speichern Sie den Gerätezustand ab.

  9. Schließen Sie das Messobjekt wieder an.

  10. Wählen Sie eine passende Skalierung und bestimmen Sie mit Hilfe der Marker die interessierenden Parameter.

  11. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Siehe auch...

AM-PM-Störmodulation

Überblick

Konzepte

Wie misst man die
AM-PM-Störmodulation?

Die AM-PM-Störmodulation ist ein Maß für die Stärke der durch Amplitudenschwankungen (AM) hervorgerufenen, unerwünschten Phasenschwankungen (PM).
Konzepte

Wie misst man die AM-PM-Störmodulation?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist AM-PM-Störmodulation?

Warum muss die AM-PM-Störmodulation gemessen werden?

Betrachtungen zur Messgenauigkeit

Was ist AM-PM-Störmodulation?

AM-PM-Störmodulation ist ein Maß für die Stärke der durch Amplitudenschwankungen (AM) des Eingangssignals hervorgerufenen, unerwünschten Phasenschwankungen (PM) des Ausgangssignals. Bei einem Kommunikationssystem, beispielsweise, kann AM-PM-Störmodulation verursacht werden durch:

  • Unbeabsichtigte Amplitudenschwankungen (AM)

    • Welligkeit der Betriebsspannung

    • Temperaturdrift

    • Mehrwege-Fading

  • Beabsichtigte Amplitudenmodulation

    • QAM

    • Burst-Modulation

Die AM-PM-Störmodulation ist üblicherweise definiert als die von einer Änderung des Verstärkereingangspegels um 1 dB verursachte Änderung der Phase des Verstärkerausgangssignals, gemessen am 1-dB-Verstärkungskompressionspunkt. Der Wert wird in Grad pro dB (°/dB) angegeben. Bei einem idealen Verstärker wäre die Phase des Ausgangssignals in keiner Weise vonm Eingangssignalpegel abhängig; ein solcher Verstärker würde daher keinerlei AM-PM-Störmodulation aufweisen.

Warum muss die AM-PM-Störmodulation gemessen werden?

Die AM-PM-Störmodulation ist ein kritischer Parameter in Systemen, die mit Phasenmodulation (oder verwandten Modulationsverfahren) arbeiten. Typische Beispiele für solche Systeme sind:

  • FM-Systeme

  • QPSK-Systeme

  • 16QAM-Systeme

Die AM-PM-Störmodulation ist deshalb eine kritische Größe, weil unerwünschte Phasenmodulation (PM) die Qualität des übertragenen Analogsignals mindert bzw. in digitalen Systemen zu einer erhöhten Bitfehlerrate (BER) führt. Zwar lässt sich die Bitfehlerrate eines digitalen Kommunikationssystems relativ einfach messen, doch liefert eine solche Messung keinerlei Hinweise auf die Ursachen von Bitfehlern. AM-PM-Störmodulation ist eine der wichtigsten Ursachen für Bitfehler; deshalb ist es bei Kommunikationssystemen unerlässlich, diesen Parameter zu quantifizieren.

Die folgenden Erläuterungen zum Zusammenhang zwischen AM-PM-Störmodulation und Bitfehlern beziehen sich auf das nachfolgende I/Q-Konstellationsmusterdiagramm.

  • In diesem Beispiel ist eine Zustandsänderung vom kleinen "durchgezogenen Vektor" zum großen "durchgezogenen Vektor" erwünscht.

  • Infolge von AM-PM-Störmodulation ergibt sich jedoch die durch den "gestrichelten Vektor" angedeutete Zustandsänderung. Der Fehler ist auf eine unerwünschte Phasenverschiebung zurückzuführen, die durch die Änderung der Eingangsspannung verursacht wird.

  • Bei dem abgebildeten 64QAM-Signal (die Abbildung zeigt nur einen Quadranten) führt dieser Phasenfehler dazu, dass der "Rauschkreis" des betreffenden Zustands einen benachbarten "Rauschkreis" überlappt. Statistisch betrachtet bedeutet dies, dass gelegentlich Bitfehler auftreten werden.

Betrachtungen zur Messgenauigkeit

Bei diesem Verfahren zur Messung der AM-PM-Störmodulation ist die Modulationsfrequenz etwa gleich dem Kehrwert der Wobbelzeit. Auch bei größtmöglicher Wobbelgeschwindigkeit ergibt sich daraus bei den meisten Netzwerkanalysatoren eine ziemlich niedrige Modulationsfrequenz (typischerweise kleiner als 10 Hz). Dadurch kann sich die Temperatur des zu messenden Verstärkers während der Wobbelmessung eventuell geringfügig ändern. (Dies gilt insbesondere für Verstärker mit geringer Temperaturkapazität, beispielsweise für ungehäuste Chips). Bei Verstärkern, deren nichtlineares Verhalten ausgeprägt temperaturabhängig ist, kann dies zu einer geringfügigen Verfälschung der Messergebnisse führen. (Die Netzwerkanalysatoren der Familie PNA benötigen für eine Signalpegelwobbelung weniger als 1 ms.)

  • Der Verstärker kann sich bei unterschiedlichen Temperaturen höchst unterschiedlich verhalten. Die Messungen sollten vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

  • Die Ausgangsleistung des Verstärkers sollte, falls erforderlich, ausreichend abgeschwächt werden. Eine zu hohe Ausgangsleistung könnte

    • den Empfänger im Analysator beschädigen

    • den Eingangskompressionspegel des Analysators überschreiten und dadurch die Messung verfälschen

  • Eine A bschwächung der Ausgangsleistung des Verstärkers können Sie erreichen durch Verwendung eines

    • Abschwächers oder

    • Kopplers

  • Der Frequenzgang des Abschwächers oder Kopplers muss bei der Kalibrierung berücksichtigt werden, da diese Komponenten Bestandteile der Messanordnung sind. Durch sachgemäße Fehlerkorrektur können Sie die Auswirkungen dieser Effekte reduzieren.

  • Der Frequenzgang ist bei AM-PM-Störmodulationsmessungen die dominante Fehlerquelle. Durch eine Durchgang/Frequenzgang-Kalibrierung können Sie diesen Fehler deutlich reduzieren. Eine noch höhere Messgenauigkeit erzielen Sie mit einer 2-Port-Kalibrierung.

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Wählen Sie die Messfunktion "S21" und die Betriebsart "Power-sweep".

  3. Geben Sie die Start- und Stop-Pegel ein. Der Start-Pegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt). Der Stop-Pegel sollte im Kompressionsbereich des Verstärkers liegen.

  4. Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  5. Schließen Sie den Verstärker gemäß der folgenden Abbildung an, und legen Sie die erforderliche DC-Vorspannung an.

  6. Konfigurieren Sie den Analysator für eine Verstärkungskompressionsmessung (mit gewobbeltem Signalpegel) bei der gewünschten Frequenz. Siehe Verstärkungskompression.

  7. Entfernen Sie den Verstärker und führen Sie eine Kalibrierung durch. Falls Sie zur Verstärkermessung Abschwächer und/oder Kabel verwenden, lassen Sie diese auch während der Kalibrierung im Signalpfad.

  8. Speichern Sie den Gerätezustand ab.

  9. Schließen Sie den Verstärker wieder an.

  10. Setzen Sie einen Referenz-Marker auf den Verstärkereingangspegel am 1-dB-Verstärkungskompressionspunkt. Aktivieren Sie einen zweiten Marker und wählen Sie dessen Stimulus-Wert so, dass der Response-Wert um 1 dB unter dem des Referenz-Markers liegt.

  11. Ändern Sie das Anzeigeformat für die 21-Messung von "Log mag" zu "Phase" (diese Änderung macht keine neue Kalibrierung erforderlich).

  12. Bestimmen Sie die Phasendifferenz zwischen den Markern. Dieser Wert ist die AM-PM-Störmodulation am 1-dB-Verstärkungskompressionspunkt.

  13. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Siehe auch...

Verstärkungskompression

Überblick

Konzepte

Wie misst man die

Verstärkungskompression?

Eine Verstärkungskompressionsmessung dient dazu, den Eingangspegel zu bestimmen, ab dem ein Verstärker Verzerrungen produziert. Zur vollständigen Charakterisierung der Verstärkungskompression eines Verstärkers sind drei Messungen erforderlich:

1) Durch eine Messung mit gewobbelter Frequenz wird die Frequenz bestimmt, bei der die 1-dB-Verstärkungskompression zuerst auftritt.

2) Durch eine Messung mit gewobbeltem Signalpegel bei der in Punkt 1 ermittelten Frequenz wird der Eingangspegel bestimmt, bei dem die Verstärkung um 1 dB abfällt.

3) Durch eine Absolutleistungsmessung wird die absolute Ausgangsleistung (in dBm) am Kompressionspunkt bestimmt.
Konzepte

Wie misst man die Verstärkungskompression?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die Verstärkungskompression?

Warum muss man die Verstärkungskompression messen?

Betrachtungen zur Messgenauigkeit

Was ist die Verstärkungskompression?

Verstärkungskompression tritt auf, wenn der Eingangspegel eines Verstärkers dessen linearen Arbeitsbereich überschreitet; mit zunehmendem Eingangspegel nimmt dann die Verstärkung immer weiter ab.

Der Analysator ermöglicht sowohl Messungen mit gewobbelter Frequenz als auch Messungen mit gewobbeltem Signalpegel. Die Betriebsart "Signalpegelwobbelung" eignet sich hervorragend zur Charakterisierung des nichtlinearen Verhaltens eines Verstärkers. Die nachfolgenden Erläuterungen beziehen sich auf die untenstehende Abbildung. (Die Abbildung zeigt den Ausgangspegel eines Verstärkers über dem Eingangspegel bei einer festen Frequenz).

  • Die Verstärkung (bei gegebenem Eingangspegel) entspricht der Steigung der Kurve.

  • Der Verstärker hat einen linearen Arbeitsbereich, in dem die Verstärkung konstant (d. h. vom Eingangspegel unabhängig) ist. Die Verstärkung in diesem Bereich wird üblicherweise als "Kleinsignalverstärkung" bezeichnet.

  • Wenn der Eingangspegel über einen bestimmten Wert hinaus erhöht wird, nimmt die Verstärkung ab, und das Eingangssignal wird komprimiert.

  • Dieser Eingangspegel wird als Verstärkungskompressionspunkt bezeichnet und ist meist auf einen Verstärkungsabfall von 1 dB bezogen. Gelegentlich wird statt des Eingangspegels auch der Ausgangspegel spezifiziert, bei dem die Verstärkung um 1 dB abfällt.

Warum muss man die Verstärkungskompression messen?

  • Wenn ein im Kompressionsbereich betriebener Verstärker mit einem sinusförmigen Signal angesteuert wird, ist das Ausgangssignal nicht mehr sinusförmig. Dadurch entstehen störende Oberwellen.

  • Wenn der Eingangspegel weiter erhöht wird, gerät der Verstärker in die Sättigung, und der Ausgangspegel steigt nicht weiter an. Ab diesem Punkt bewirkt eine weitere Erhöhung des Eingangspegels keine Änderung der Ausgangsleistung mehr.

  • In bestimmten Fällen (beispielsweise bei TWT-Verstärkern) nimmt der Ausgangspegel bei einer weiteren Erhöhung des Eingangspegels sogar ab; die Verstärkung ist dann negativ.

  • Da die Aufgabe eines Verstärkers darin besteht, Signale zu verstärken, ist es wichtig zu wissen, ab welchem Eingangspegel Signalkompression auftritt.

Betrachtungen zur Messgenauigkeit

Der Messsignalpegel muss ausreichen, um den Verstärker in die Sättigung zu treiben. Wenn der Ausgangspegel des Analysators hierfür nicht ausreicht, müssen Sie ihn mit Hilfe eines externen Vorverstärkers verstärken. (Siehe Messungen an Leistungsbauteilen.) Bei Verwendung eines externen Vorverstärkers können Sie die Messgenauigkeit durch verschiedene Maßnahmen verbessern:

  • Verbinden Sie den Vorverstärkerausgang über einen Koppler mit dem Eingang des zu messenden Verstärkers, und verwenden Sie das ausgekoppelte Signal als Referenzsignal für die Messung. Dadurch werden die Frequenzgang- und Driftfehler des Vorverstärkers kompensiert (weil sie sich sowohl auf den Messsignalpfad als auch auf den Referenzsignalpfad auswirken).

  • Führen Sie eine Durchgang-Frequenzgang-Kalibrierung über die gesamte Messanordnung einschließlich Vorverstärker, Koppler und Abschwächer durch.

Die Ausgangsleistung des Verstärkers sollte, falls erforderlich, ausreichend abgeschwächt werden. Eine zu hohe Ausgangsleistung könnte

  • den Empfänger im Analysator beschädigen

  • den Empfänger im Analysator übersteuern

Eine A bschwächung der Ausgangsleistung des Verstärkers können Sie erreichen durch Verwendung eines

  • Abschwächers oder

  • Kopplers

Die Frequenzgänge des Abschwächers und des Kopplers müssen bei der Kalibrierung berücksichtigt werden, da diese Komponenten Bestandteile der Messanordnung sind. Durch sachgemäße Fehlerkorrektur können Sie die Auswirkungen dieser Effekte reduzieren.

  • Die dominierende Fehlerquelle bei Verstärkungskompressionsmessungen ist der Frequenzgang. Durch eine Durchgang/Frequenzgang-Kalibrierung können Sie diesen Fehler deutlich reduzieren.

  • Der Verstärker kann sich bei unterschiedlichen Temperaturen höchst unterschiedlich verhalten. Die Messungen sollten vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

  • Durch Reduzieren der ZF-Bandbreiteoder durch Messdatenmittelung können Sie die Messgenauigkeit zu Lasten der Messgeschwindigkeit verbessern.

Nachfolgend werden die drei zur Bestimmung des Verstärkungskompressionspunktes erforderlichen Messungen beschrieben:
Verstärkungskompressionsmessung mit gewobbelter Frequenz

Verstärkungskompressionsmessung mit gewobbeltem Signalpegel

Absolutleistungsmessung

Verstärkungskompressionsmessung mit gewobbelter Frequenz

Die Messung mit gewobbelter Frequenz dient dazu, die Frequenz zu bestimmen, bei der die 1-dB-Kompression zuerst auftritt.

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Wählen Sie die Messfunktion S21.

  3. Der Messignalpegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt).

  4. Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  5. Schließen Sie den Verstärker gemäß der folgenden Abbildung an, und legen Sie die erforderliche DC-Vorspannung an.

  6. Stellen Sie den Analysator so ein, wie es für die Messung an dem jeweiligen Verstärker erforderlich ist. Eventuell ist es zweckmäßig, zur Reduktion des Rauschens eine kleinere ZF-Bandbreite zu wählen.

  7. Entfernen Sie den Verstärker und führen Sie eine Durchgang-Frequenzgang-Kalibrierung durch. Falls Sie zur Verstärkermessung Abschwächer und/oder Kabel verwenden, lassen Sie diese auch während der Kalibrierung im Signalpfad.

  8. Speichern Sie den Gerätezustand ab.

  9. Schließen Sie den Verstärker wieder an.

  10. Setzen Sie einen Marker etwa auf die Mitte des Wobbelbereichs.

  11. Wählen Sie eine Skalierung von 1 dB pro Skalenteil.

  12. Speichern Sie die Messkurve ab und wählen Sie die Bildschirmbetriebsart "Data/Mem".

  13. Erhöhen Sie den Messsignalpegel allmählich so weit, bis erstmals an einer beliebigen Stelle der Messkurve eine 1-dB-Kompression auftritt.

  14. Bestimmen Sie die Frequenz dieses Punktes mit Hilfe eines Markers. Notieren Sie diese Frequenz. (Diese Information wird bei den nachfolgenden Messungen benötigt).

  15. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

Verstärkungskompressionsmessung mit gewobbeltem Signalpegel

Durch die Messung mit gewobbeltem Signalpegel bei der in Punkt 13 ermittelten Frequenz wird der Eingangspegel bestimmt, bei dem die Verstärkung um 1 dB abfällt.

  1. Falls noch nicht geschehen, führen Sie zuerst die oben beschriebene Messung mit gewobbelter Frequenz durch.

  2. Richten Sie eine S21-Messung mit gewobbeltem Signalpegel ein. Nehmen Sie folgende Einstellungen vor:

    • Stellen Sie die CW-Frequenz auf den in Schritt 13 der vorigen Messung notierten Wert ein.

    • Geben Sie die Start- und Stop-Signalpegel ein. Der Start-Pegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt). Der Stop-Pegel sollte im Kompressionsbereich des Verstärkers liegen.

  3. Wählen Sie eine Skalierung von 1 dB pro Skalenteil.

  4. Bestimmen Sie mit Hilfe von Markern und einem Referenz-Marker den Eingangspegel, bei dem eine Kompensation um 1 dB auftritt.

  5. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

Absolutleistungsmessung

  1. Durch die Absolutleistungsmessung wird die absolute Ausgangsleistung (in dBm) am Kompressionspunkt bestimmt.

    • Wählen Sie die Messfunktion "Absolute Power". Falls Ihre Messanordnung der obigen Abbildung entspricht, verwenden Sie für diese Messung den Eingang B. Nehmen Sie folgende Einstellungen vor:

    • Behalten Sie die in der vorigen Messung verwendete CW-Frequenz bei.

  2. Setzen Sie einen Marker auf den Eingangspegel, bei dem die 1-dB-Kompression auftritt (dieser Eingangspegel wurde in Schritt 4 der vorigen Messung bestimmt).

  3. Wählen Sie eine passende Skalierung.

  4. Lesen Sie den Marker-Pegel ab; dieser entspricht dem Verstärkerausgangspegel (in dBm), bei dem 1 dB Kompression auftritt.

  5. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

Hinweis: Die Kalibrierung gilt nicht für Absolutleistungsmessungen. Deshalb müssen Sie eine etwaige externe Abschwächung manuell korrigieren.


Siehe auch...

Phasenlinearitätsabweichung

Überblick

Konzepte

Wie misst man die Phasenlinearitätsabweichung?

Die Phasenlinearitätsabweichung ist ein Maß für die von einem Bauteil verursachten Phasenverzerrungen. Mit Hilfe der "Electrical Delay"-Funktion lässt sich der frequenzlineare Anteil der Phasenverschiebung kompensieren. Das Ergebnis ist eine hochauflösende Darstellung des nicht-frequenzlinearen Anteils der Phasenverschiebung; dieser wird als Phasenlinearitätsabweichung bezeichnet.
Konzepte

Wie misst man die Phasenlinearitätsabweichung?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was bedeutet "frequenzlineare Phasenverschiebung"?

Was bedeutet "Phasenlinearitätsabweichung"?

Warum muss die Phasenlinearitätsabweichung gemessen werden?

Anwendung der "Electrical Delay"-Funktion

Betrachtungen zur Messgenauigkeit

Was bedeutet "frequenzlineare Phasenverschiebung"?

Eine (frequenz-) lineare P haseverschiebung entsteht dadurch, dass das Signal eine gewisse Zeit benötigt, um die elektrische Länge des Bauteils zu durchlaufen.Wenn ein Bauteil ausschließlich eine lineare Phasenverschiebung verursacht, hat sein Phasenfrequenzgang die Form einer Geraden. Die Steilheit dieser Geraden ist proportional zur elektrischen Länge des Bauteils. Eine notwendige Voraussetzung für eine verzerrungsfreie Signalübertragung ist (außer einem horizontalen Amplitudenfrequenzgang) ein linearer Phasenfrequenzgang.

Was bedeutet "Phasenlinearitätsabweichung"?

In der Praxis verzögern viele Bauteile bestimmte Frequenzen stärker als andere. Dadurch entsteht eine nichtlineare Phasenverschiebung, die bei Signalen, die aus mehreren Frequenzkomponenten bestehen, Verzerrungen hervorruft. Diese nichtlineare Phasenverschiebung lässt sich durch Messung der P hasenlinearitätsabweichung quantifizieren.

Da lediglich die Phasenlinearitätsabweichung (und nicht die lineare Phasenverschiebung) Signalverzerrungen verursacht, ist es zweckmäßig, die lineare Phasenverschiebung bei der Messung zu kompensieren. Diese (rechnerische) Kompensation erfolgt mit Hilfe der "Electrical Delay"-Funktion des Analysators. Was nach der Kompensation übrig bleibt, ist die Phasenlinearitätsabweichung (die auch als Phasenverzerrung bezeichnet wird).

Warum muss die Phasenlinearitätsabweichung gemessen werden?

Die Messung der Phasenlinearitätsabweichung bietet im Vergleich zur Gruppenlaufzeitmessung folgende Vorteile:

  • Die Messdaten werden in Phaseneinheiten statt (wie bei Gruppenlaufzeitmessungen) in Sekunden dargestellt. Zur Charakterisierung von Bauteilen, die modulierte Signale übertragen sollen, sind Phaseneinheiten wesentlich zweckmäßiger.

  • Das Rauschen ist geringer als bei einer Gruppenlaufzeitmessung.

Anwendung der "Electrical Delay"-Funktion

Die "Electrical Delay"-Funktion ist das elektronische Analogon zu den früher üblichen Leitungsstreckern. Diese Funktion bewirkt folgendes:

  • Sie simuliert einen verlustfreien Wellenleiter mit einstellbarer Länge, der in den Referenzsignalpfad eingeschleift werden kann.

  • Sie kompensiert die elektrische Länge des Messobjekts.

  • Sie "egalisiert" die auf dem Bildschirm dargestellte Frequenzgangkurve. Dadurch ist es möglich, die Phasenlinearitätsabweichung hochauflösend darzustellen und zu messen.

  • Sie bietet eine einfache Möglichkeit zur Darstellung der Phasenlinearitätsabweichung des Messobjekts. Siehe folgende Abbildung.

Betrachtungen zur Messgenauigkeit

Die dominante Fehlerquelle bei der Messung der Phasenlinearitätsabweichung ist der Frequenzgang der Messanordnung. Durch eine Durchgang/Frequenzgang-Kalibrierung können Sie diesen Fehler deutlich reduzieren. Eine noch höhere Messgenauigkeit erzielen Sie mit einer 2-Port-Kalibrierung.

Wie misst man die Phasenlinearitätsabweichung?

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Falls es sich bei dem Messobjekt um einen Verstärker handelt, müssen Sie eventuell den Messignalpegel reduzieren:

    • Der Messignalpegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt).

    • Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  3. Schließen Sie das Messobjekt gemäß der folgenden Abbildung an den Analysator an.

  3. Wählen Sie die Messfunktion "S21".

  4. Wählen Sie die passenden Analysatoreinstellungen, insbesondere:

    • "Format": "Phase"

    • "Scale": "A utoscale"

  5. Entfernen Sie das Messobjekt und führen Sie eine Kalibrierung durch.

  6. Schließen Sie das Messobjekt wieder an.

  7. Wählen Sie eine passende Skalierung.

  8. Aktivieren Sie die "Electrical Delay"-Funktion, um den Phasenfrequenzgang zu egalisieren. Falls zweckmäßig, nehmen Sie eine manuelle Feinkorrektur der elektrische Länge vor, um den Phasen-Frequenzgang noch besser zu egalisieren.

  9. Messen Sie mit Hilfe der Marker die Spitze-Spitze-P hasenlinearitätsabweichung.

  10. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Siehe auch...

Ausgangsrückwirkung

Überblick

Konzepte

Wie misst man die
Ausgangsrückwirkung?

Die A usgangsrückwirkung ist ein Maß für die Signalübertragung vom Ausgang eines Verstärkers zu dessen Eingang.
Konzepte

Wie misst man die Ausgangsrückwirkung?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die Ausgangsrückwirkung?

Warum muss man die Ausgangsrückwirkung messen?

Betrachtungen zur Messgenauigkeit

Was ist die Ausgangsrückwirkung?

Die Ausgangsrückwirkung ist ein Maß dafür, wie gut der Eingang des Messobjekts gegenüber einem in den Ausgang des Messobjekts eingespeisten Signal isoliert ist.

Die Messung der Ausgangsrückwirkung ähnelt der Messung der Vorwärtsverstärkung, abgesehen von folgendem:

  • Das Stimulussignal wird in den Ausgang des Verstärkers eingespeist.

  • Das Response-Signal wird am Eingang des Verstärkers gemessen.

Der äquivalente S-Parameter ist S12.

Warum muss man die Ausgangsrückwirkung messen?

Ein idealer Verstärker hätte keinerlei Ausgangsrückwirkung. In der Realität kommt es jedoch vor, dass reflektierte Signale vom Ausgang des Verstärkers zu dessen Eingang zurück gelangen. Diese unerwünschten Signale können mit den erwünschten, in Vorwärtsrichtung fließenden Signalen interferieren. Deshalb ist die Ausgangsrückwirkung eine wichtige Kenngröße, die quantifiziert werden muss.

Betrachtungen zur Messgenauigkeit

Da Verstärker in Rückwärtsrichtung normalerweise eine hohe Dämpfung aufweisen, erfordert diese Messung keine Abschwächung des Messignalpegels. (Der Abschwächer, der eventuell bei der Vorwärtsverstärkungsmessung zum Schutz des Port-2-Empfängers verwendet wurde, wird für diese Messung nicht benötigt). Das Entfernen des Abschwächers hat folgende Konsequenzen:

  • Der D ynamikbereich wird größer; dadurch erhöht sich die Messgenauigkeit.

  • Zur Gewährleistung der Messgenauigkeit ist eine nochmalige Kalibrierung erforderlich.

Zur Vergrößerung des Dynamikbereichs und Verbesserung der Messgenauigkeit können Sie den Messsignalpegel erhöhen.

Hinweis: Wenn Sie den Abschwächer entfernen und den Messsignalpegel erhöhen, kann bei einer Vorwärtsverstärkungsmessung der Port-2-Empfänger beschädigt werden. Überzeugen Sie sich vor einer Vorwärtsverstärkungsmessung oder 2-Port-Kalibrierung davon, dass der Messsignalpegel auf einen für den Port-2-Empfänger sicheren Wert reduziert wurde.

Falls die Ausgangsrückwirkung des gemessenen Verstärkers sehr gering (bzw. die Isolation sehr hoch) ist, kann das transmittierte Signal im Eigenrauschen oder Übersprechen des Empfängers untergehen. Sie können das Eigenrauschen folgendermaßen reduzieren:

  • Verwenden Sie Messdatenmittelung bzw. erhöhen Sie den Mittelungsfaktor.

  • Reduzieren Sie die ZF-Bandbreite.

Hinweis: Durch Reduzieren der ZF-Bandbreite oder durch Mittelung können Sie den Dynamikbereich vergrößern und die Messgenauigkeit verbessern; dies geht jedoch zu Lasten der Messgeschwindigkeit.

  • Falls die Messgenauigkeit durch Übersprechen beeinträchtigt wird, können Sie den Übersprechen-Fehlerterm mit Hilfe einer Frequenzgang- und Isolationskalibrierung reduzieren. Bei der Durchführung des Isolationsteils der Kalibrierung müssen Sie unbedingt den gleichen Mittelungsfaktor und die gleiche ZF-Bandbreite wie bei den späteren Messungen verwenden.

  • Die dominante Fehlerquelle bei der Messung der Ausgangsrückwirkung ist der Frequenzgang der Messanordnung. Durch eine Durchgang/Frequenzgang-Kalibrierung können Sie diesen Fehler deutlich reduzieren. Diese Kalibrierung kann im Rahmen einer Frequenzgang- und Isolationskalibrierung erfolgen.

  • Der Verstärker kann sich bei unterschiedlichen Temperaturen höchst unterschiedlich verhalten. Die Messungen sollten vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

  1. Schließen Sie den Verstärker gemäß der folgenden Abbildung an den Analysator an.

  2. Bringen Sie den Analysator in den "Preset"-Zustand.

  3. Wählen Sie die Messfunktion "S12".

  4. Stellen Sie den Analysator so ein, wie es für die Messung an dem jeweiligen Verstärker erforderlich ist.

  5. Entfernen Sie den Verstärker und führen Sie eine Durchgang-Frequenzgang-Kalibrierung oder eine Frequenzgang- und I solationskalibrierung durch.

  6. Wählen Sie eine geeignete Skalierung und messen Sie mit Hilfe eines Markers die Ausgangsrückwirkung bei der interessierenden Frequenz.

  7. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.


Verstärkungsfrequenzgang

Siehe auch...

Kleinsignalverstärkung und Frequenzgang

Überblick

Konzepte

Wie misst man diese Größen?

Die "Kleinsignalverstärkung" ist die Verstärkung im linearen Arbeitsbereich eines Verstärkers. Normalerweise misst man den Frequenzgang der Kleinsignalverstärkung bei konstantem Signalpegel. Der Verstärkungs-Frequenzgang ist ein Maß für die Schwankungen der Verstärkung über einen gegebenen Frequenzbereich.
Konzepte

Wie misst man die Verstärkung und den Frequenzgang?

Klicken Sie auf eine Schaltfläche, um nähere Informationen über folgende Themen zu erhalten:
Was ist die Verstärkung?

Was ist der Frequenzgang?

Warum müssen die Verstärkung und der Frequenzgang gemessen werden?

Betrachtungen zur Messgenauigkeit

Was ist die Verstärkung?

Die Verstärkung eines HF-Verstärkers ist definiert als das Verhältnis (bzw. die Differenz im logarithmischen Maßstab) der Ausgangsleistung zur Eingangsleistung des Verstärkers. Es wird vorausgesetzt, dass die Eingangs- und Ausgangsimpedanzen des Verstärkers gleich der Systemimpedanz des Messsystems sind.

  • In der S-Parameter-Terminologie wird die Verstärkung als S21 bezeichnet.

  • Die Verstärkung wird in dB angegeben (Verhältnis der Ausgangsleistung zur Eingangsleistung im logarithmischen Maßstab).

  • Die Verstärkung lässt sich berechnen, indem man den Eingangspegel (in dBm) Ausgangspegel (in dBm) subtrahiert. 0 dBm entspricht einer Leistung von 1 Milliwatt.

  • Die Verstärkung wird meist als Mindestwert über einen bestimmten Frequenzbereich spezifiziert. Für einige Verstärker werden sowohl die minimale als auch die maximale Verstärkung spezifiziert, um sicherzustellen, dass nachfolgende Stufen weder unter- noch übersteuert werden.

Was ist der Frequenzgang?

Der F requenzgang gibt an, in welchem Ausmaß die Verstärkung innerhalb des spezifizierten Frequenzbereichs schwanken kann. Ein nichtlinearer Frequenzgang kann Signalverzerrungen verursachen.

Warum müssen die Kleinsignalverstärkung und der Frequenzgang gemessen werden?

Verstärkungsschwankungen innerhalb der interessierenden Bandbreite verursachen bei Signalen, die aus mehreren Frequenzkomponenten bestehen, Verzerrungen, weil die verschiedenen Frequenzkomponenten unterschiedlich stark verstärkt werden. Die Kleinsignalverstärkungsmessung dient zur Charakterisierung der Verstärkung bei einer bestimmten Frequenz. Die Frequenzgangmessung dient zur Charakterisierung der maximalen Verstärkungsschwankungen über einen bestimmten Frequenzbereich.

Betrachtungen zur Messgenauigkeit

  • Der Verstärker kann sich bei unterschiedlichen Temperaturen höchst unterschiedlich verhalten. Die Messungen sollten vorgenommen werden, wenn der Verstärker seine normale Betriebstemperatur erreicht hat.

  • Die Ausgangsleistung des Verstärkers sollte, falls erforderlich, ausreichend abgeschwächt werden. Eine zu hohe Ausgangsleistung könnte

    • den Empfänger im Analysator beschädigen

    • den Eingangskompressionspegel des Analysators überschreiten und dadurch die Messung verfälschen

Eine A bschwächung der Ausgangsleistung des Verstärkers können Sie erreichen durch Verwendung eines

    • Abschwächers

    • Kopplers

Der Frequenzgang des Abschwächers oder Kopplers muss bei der Kalibrierung berücksichtigt werden, da diese Komponenten Bestandteile der Messanordnung sind. Durch sachgemäße Fehlerkorrektur können Sie die Auswirkungen dieser Effekte reduzieren.

  • Der Frequenzgang ist die dominante Fehlerquelle bei Kleinsignalverstärkungs- und Frequenzgang-Messungen. Durch eine Durchgang/Frequenzgang-Kalibrierung können Sie diesen Fehler deutlich reduzieren. Eine noch höhere Messgenauigkeit erzielen Sie mit einer 2-Port-Kalibrierung.

  • Durch Reduzieren der ZF-Bandbreite oder durch Messdatenmittelung können Sie den D ynamikbereich vergrößern und die Messgenauigkeit verbessern; dies geht jedoch zu Lasten der Messgeschwindigkeit.

Wie misst man die Verstärkung und den Frequenzgang?

  1. Bringen Sie den Analysator in den "Preset"-Zustand.

  2. Wählen Sie die Messfunktion "S21".

  3. Der Messignalpegel sollte im linearen Arbeitsbereich des Verstärkers liegen (typischerweise 10 dB unter dem 1-dB-Verstärkungskompressionspunkt).

  4. Verwenden Sie (falls erforderlich) einen externen Abschwächer, um eine Signalkompression im Port-2-Empfänger oder eine Beschädigung des Empfängers zu vermeiden.

  5. Schließen Sie den Verstärker gemäß der folgenden Abbildung an, und legen Sie die erforderliche DC-Vorspannung an.

  6. Stellen Sie den Analysator so ein, wie es für die Messung an dem jeweiligen Verstärker erforderlich ist.

  7. Entfernen Sie den Verstärker und führen Sie eine Kalibrierung durch. Falls Sie zur Verstärkermessung Abschwächer und/oder Kabel verwenden, lassen Sie diese auch während der Kalibrierung im Signalpfad.

  8. Speichern Sie den Gerätezustand ab.

  9. Schließen Sie den Verstärker wieder an.

  10. Wählen Sie eine geeignete Skalierung und messen Sie mit Hilfe eines Markers die Kleinsignalverstärkung bei der interessierenden Frequenz.

  11. Bestimmen Sie den Verstärkungs-Frequenzgang über den interessierenden Frequenzbereich, indem Sie mit Hilfe von Markern die Spitze-Spitze-Welligkeit messen.

  12. Drucken Sie das Messergebnis aus oder speichern Sie es in eine Datei ab.

  13. Diese Art von Messung lässt sich automatisieren.


Impedanz

Dieses Applet ist dazu bestimmt, auf dem Bildschirm des Analysators betrachtet zu werden. Wenn Sie es außerhalb des Analysators betrachten möchten, kopieren Sie die folgenden Dateien aus dem Verzeichnis C:\WINNT\Help auf der Festplatte des Analysators oder der mit dem Analysator gelieferten CDROM in Ihr Verzeichnis C:\WINNT\Help.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Impedanzanpassungsmodell

Siehe auch...

Impedanzanpassung ist ein bei der Schaltungsentwicklung angewandtes Verfahren, das dazu dient, eine Signalquelle und eine Last, die ungleiche Impedanzen aufweisen, so aneinander anzupassen, dass die von der Signalquelle gelieferte Leistung möglichst vollständig an die Last abgegeben wird. Hierzu wird zwischen der Signalquelle und der Last ein passend dimensioniertes Anpassungsnetzwerk eingefügt.

Einführung in das Modell

Impedanzanpassungsmodell

Beschreibung der Übungen

"Pfade" im Smith-Diagramm

Verbotene Bereiche des Smith-Diagramms

Einführung

Dieses Modell visualisiert den interaktiven Prozess der Impedanzanpassung mit Hilfe des Smith-Diagramms; Ziel der Impedanzanpassung ist die Maximierung der an die Last abgegebenen Leistung. Am Beispiel einfacher Anpassungsnetzwerke aus Serien- und Parallel-Induktivitäten und Kapazitäten können Sie die Werte für L und C interaktiv variieren und beobachten, wie sich dies auf das Schaltungsverhalten auswirkt. Beim Ändern der Bauteilwerte des Anpassungsnetzwerks ändert sich der Reflexionskoeffizient der gesamten Schaltung. Der Reflexionskoeffizient am Eingang und am Ausgang der Schaltung ist im Smith-Diagramm als eine rote [image] oder blaue [image] Kugel dargestellt.

Wenn Sie die Bauteilwerte mit Hilfe des simulierten Einstellers ändern, berechnet das Modell den neuen Reflexionskoeffizienten und verschiebt die rote [image] und die blaue [image] Kugel im Smith-Diagramm. Der Zweck der Übungen besteht darin, die Kugel aus der Mitte des Smith-Diagramms, das entweder die Last oder die Quelle repräsentiert, in den entsprechenden [image] roten bzw. blauen Ring zu verschieben; diese Ringe repräsentieren die gewünschte Anpassung. Durch Anklicken der "Registerkarten" können Sie zwischen drei verschiedenen Impedanzanpassungsproblemen unterschiedlicher Schwierigkeitsgrade wählen.

Impedanzanpassungsmodell

Maximieren Sie dieses Fenster, um die Darstellung besser sehen zu können. Klicken Sie hier , falls das Impedanzmodell nicht zu sehen ist.

Beschreibung der Übungen

Bei der ersten Übung führen Sie anhand des Smith-Diagramms eine einfache Impedanzanpassung zwischen einer resistiven Quelle und einer resistiven Last durch. Die 50 Ohm-Quelle wird mit Hilfe eines einfachen Netzwerks aus einer Serieninduktivität und einer Parallelkapazität an die 300 Ohm-Last angepasst. Der Quellen-Reflexionskoeffizient der Schaltung, betrachtet von der Last in Richtung Quelle, wird durch die rote Kugel [image] repräsentiert; die 300 Ohm-Last wird durch den stationären [image] roten Ring repräsentiert.

Zweck der Übung ist es, diese beiden Impedanzen durch Ändern der L- und C-Werte interaktiv anzupassen. Das Modell visualisiert die Auswirkungen dieser Änderungen durch eine entsprechende Verschiebung der roten Kugel im Smith-Diagramm, welche den Reflexionskoeffizienten repräsentiert. Schieben Sie die Einsteller für die Serieninduktivität und den Parallelwiderstand in der Weise, dass die Kugel [image] von der Mitte des Smith-Diagramms zur Anpassungsposition im roten Ring wandert. Im Abschnitt Smith-Diagramm-Schaltungselemente-Pfade (weiter unten) wird erläutert, wie sich bestimmte Änderungen von Bauteilwerten im Smith-Diagramm auswirken.

Bei der zweiten Übung wird die Leistungsverstärkung eines Transistorverstärkers maximiert. Durch Anpassen der 50 Ohm-Quelle an den Eingangsreflexionskoeffizienten des Transistors, s*11, und Anpassen der 50 Ohm-Last an den Ausgangsreflexionskoeffizienten des Transistors, s*22, wird die von der Quelle über den Transistor an die Last gelieferte Leistung maximiert. Bei dieser Übung müssen Sie die rote Kugel [image] (Eingang) und die blaue Kugel [image] (Ausgang) separat verschieben. Stellen Sie die Bauteilwerte so ein, dass beide Kugeln innerhalb des roten [image] bzw. blauen [image] Rings liegen.

Der dritte Teil des interaktiven Impedanzanpassungsmodells beinhaltet eine Reihe von Übungen mit Schaltungsmodulen, die Sie auf unterschiedliche Weise kombinieren können. Zunächst entwerfen Sie eine Schaltung mit einem oder zwei Anpassungsnetzwerk-Komponenten, die Sie durch Ziehen mit der Maus zur Schaltung hinzufügen. Anschließend funktionieren die Einsteller zum Ändern der Bauteilwerte. Jetzt können Sie die Impedanzanpassung für die soeben entworfene Schaltung durchführen! Es stehen insgesamt acht verschiedene Schaltungen und fünf verschiedene Wertepaare für s*11 und s*22 zur Auswahl; das bedeutet, dass Sie insgesamt 40 Fälle "durchspielen" können. Sie werden feststellen, dass nicht alle Anpassungsnetzwerke funktionieren! Bei einigen Schaltungen wird es Ihnen nicht gelingen, die rote Kugel [image] in den roten Ring oder die blaue Kugel [image] in den blauen Ring zu schieben. Im Abschnitt verbotene Bereiche des Smith-Diagramms (weiter unten) wird beschrieben, wie Sie vorab herausfinden können, welche Anpassungsnetzwerke funktionieren und welche nicht. Es gibt fünf verschiedene Positionspaare für s*11 und s*22, die verschiedenen Anpassungsfrequenzen entsprechen.Wählen Sie mit der Frequenzanzeige die gewünschte Betriebsfrequenz, ziehen Sie mit der Maus die geeigneten Anpassungsnetzwerke in die Schaltung, und stellen Sie die Bauteilwerte so ein, dass beide Kugeln sich im roten [image] bzw. blauen Ring befinden.

"Pfade" im Smith-Diagramm

Die folgenden Grafiken zeigen, wie sich die verschiedenen Parallel- und Serien-Induktivitäten/Widerstände auf das Smith-Diagramm auswirken. Angenommen, das gegebene Bauteil ist das letzte Bauteil im Anpassungsnetzwerk, dann bewegt sich der Reflexionsgrad-Punkt im Smith-Diagramm wie gezeigt entlang einer kreisförmigen Ortskurve konstanten Widerstandes oder konstanten Leitwertes.

Die Impedanzanpassung mit Hilfe des Smith-Diagramms ist damit vergleichbar, in einer Stadt namens Smith Town, in der es keine geraden Straßen gibt, mit einem Auto zu einem bestimmten Haus zu fahren. Indem Sie die Bauteilwerte in der passenden Reihenfolge einstellen, können Sie den Reflexionsgradwert auf einem Pfad konstanten Widerstands oder Leitwertes halten. Ähnlich wie unser Auto in der Stadt ohne gerade Straßen durch Verkehrsschilder zum richtigen Ort geleitet wird, können wir auch systematisch zur Impedanzanpassung gelangen.

Verbotene Bereiche des Smith-Diagramms

Bei gegebenem Lastreflexionsgrad sind nur ganz bestimmte L-C-Anpassungsnetzwerke in der Lage, die Quellenimpedanz in die Lastimpedanz zu überführen. Konkret: Bei gegebenem Lastreflexionsgrad sind genau zwei der vier möglichen L-C-Anpassungsnetzwerke in dem obigen Transistorverstärker-II-Modell geeignet, die Anpassung herbeizuführen. Aber welche zwei?

Anhand der folgenden Diagramme können Sie bestimmen, welche Anpassungsnetzwerke bei einer gegebenen Lastsituation funktionieren. Wenn der Lastreflexionsgrad innerhalb des für das angegebene Anpassungsnetzwerk verbotenen Bereichs des Smith-Diagramms liegt, kann mit diesem Netzwerk keine Anpassung erzielt werden. Sie können mit Ihrem Auto nicht in die verbotenen Bereiche von Smith Town fahren! In diesen Bereichen gibt es keine befahrbaren Straßen!

Stellen Sie anhand dieser Diagramme fest, welche Anpassungsnetzwerke in der gegebenen Situation geeignet sind. Um auf das obige Beispiel mit dem Transistorverstärker-II-Modell zurückzukommen: Stellen Sie zunächst fest, wo der Lastreflexionsgrad in jedem der vier farbigen Smith-Diagramme liegt. Verwerfen Sie dann die beiden Netzwerke, in deren verbotenem Bereich der Reflexionsgrad-Punkt liegt, und führen Sie die Impedanzanpassung unter Verwendung eines der beiden übrigen Netzwerke durch.


Stehende Wellen

Dieses Applet ist dazu bestimmt, auf dem Bildschirm des Analysators betrachtet zu werden. Wenn Sie es außerhalb des Analysators betrachten möchten, kopieren Sie die folgenden Dateien aus dem Verzeichnis C:\WINNT\Help auf der Festplatte des Analysators oder der mit dem Analysator gelieferten CDROM in Ihr Verzeichnis C:\WINNT\Help.

  • DemoTimer.class

  • DisplaySim.class

  • DisplayXLine.class

  • imatch.class

  • MessageSim.class

  • ParamXLine.class

  • Postit.class

  • RunSim.class

  • SpecAnimation.class

  • SymbolButton.class

  • XLine.class

Stehende Wellen durch Reflexionen

Siehe auch...

Wenn eine sinusförmige Welle von einem HF-Signalgenerator in einen Wellenleiter eingespeist wird, pflanzt sich das Signal in Richtung Last fort. Dieses hier in gelber Farbe dargestellte Signal kann als eine unendliche Menge rotierender Vektoren angesehen werden, die über die gesamte Länge des Wellenleiters verteilt sind.

Maximieren Sie dieses Fenster, um die Darstellung besser sehen zu können. Klicken Sie hier, falls das Applet nicht zu sehen ist.

In unserem Beispiel besitzt der Wellenleiter einen Wellenwiderstand von 50 Ohm. Wenn die Last ebenfalls einen Widerstand von 50 Ohm besitzt, ist die Signalamplitude entlang des Wellenleiters konstant. In diesem Fall ändert sich nur die Phase entlang des Wellenleiters (wie aus den rotierenden gelben Vektoren ersichtlich ist).

Falls die Lastimpedanz nicht exakt mit dem Wellenwiderstand des Wellenleiters übereinstimmt, ensteht ein Reflexionssignal, das sich von der Last in Richtung Signalquelle fortpflanzt. An einem beliebigen Punkt entlang des Wellenleiters erscheint auch dieses Signal als eine konstante Spannung, deren Phase von der jeweiligen Position entlang des Wellenleiters abhängig ist.

Die Spannung an einer bestimmten Stelle des Wellenleiters ist gleich der vektoriellen Summe der Spannungen des transmittierten und des reflektierten Signals. Dies soll an zwei Beispielen demonstriert werden.

Beispiel 1: Perfekte Anpassung: 50 Ohm

Wählen Sie mit Hilfe des nach unten zeigenden Pfeils einen Abschlusswiderstand von 50 Ohm. Beachten Sie, dass keine Reflexion stattfindet. Es besteht eine perfekte Anpassung. Jeder der rotierenden Vektoren hat die normierte Amplitude 1. Wenn wir das Signal an einem beliebigen Punkt mit Hilfe eines perfekten Messgerätes beobachten könnten, würden wir an jeder Stelle entlang des Wellenleiters Sinussignale gleicher Amplitude sehen. Die Signalamplituden sind durch die grüne Linie angedeutet.

Beispiel 2: Fehlangepasste Last: 200 Ohm

Als nächstes wollen wir eine Fehlanpassung simulieren. Wählen Sie mit Hilfe des nach unten zeigenden Pfeils einen Abschlusswiderstand von 200 Ohm. Drücken Sie die PLAY-Taste und beobachten Sie, wie sich das reflektierte Signal ändert. Wenn es möglich wäre, das reflektierte Signal alleine zu messen, würden wir sehen, dass dessen Amplitude sich entlang des Wellenleiters nicht ändert. Das reflektierte Signal (blau) am Punkt z6 unterscheidet sich von dem reflektierten Signal am Punkt z4 (um willkürlich zwei Punkte herauszugreifen) nur durch seine Phasenlage.

Die Amplitude der resultierenden stehenden Welle (grün) ist entlang des Wellenleiters nicht konstant, weil das transmittierte Signal (gelb) und das reflektierte Signal (blau) sich überlagern. Da sich die Phase zwischen dem transmittierten und dem reflektierten Signal entlang des Wellenleiters ändert, sind auch die vektoriellen Summen positionsabhängig; dadurch entsteht eine "stehende Welle".

Bei einer Lastimpedanz von 200 Ohm würde ein an den Punkt z6 angeschlossenes Messgerät ein Sinussignal mit konstanter Amplitude anzeigen. Das Sinussignal am Punkt z4 hätte ebenfalls eine konstante Amplitude, jedoch eine andere als das Signal am Punkt z6. Die beiden Signale wären gegeneinander phasenverschoben. Die Differenz wird wieder durch die grüne Linie angedeutet, die die Amplitude an dem betreffenden Punkt entlang des Wellenleiters anzeigt.

Auch die Impedanz ändert sich entlang des Wellenleiters (siehe Punkte z1 bis z7).


Überblick

Siehe auch...

Überblick über Zeitbereichmessungen

Überblick

Konzepte

Wie führt man eine Zeitbereichmessung durch?

Falls Ihr Analysator mit der Zeitbereich-Option 010 ausgestattet ist, können Sie damit das Zeitbereichverhalten eines Bauteils analysieren. Dieses Kapitel gibt einen allgemeinen Überblick über Zeitbereichmessungen.
Konzepte

Wie führt man eine Zeitbereichmessung durch?

Was ist eine Zeitbereichmessung?

Ähnlichkeiten mit der Zeitbereich-Reflektometrie

Zeitbereich-Messprozedur

Was ist eine Zeitbereichmessung?

  • Normalerweise misst der Analysator die HF-Eigenschaften eines Messobjekts als Funktion der Frequenz.

  • Wenn Ihr Analysator mit der Zeitbereich-Option 010 ausgestattet ist, kann er die Messdaten mittels inverser Fourier-Transformation aus dem Frequenzbereich in den Zeitbereich transformieren.

  • In der Betriebsart "Zeitbereich" ist die X-Achse der Zeit zugeordnet.

  • Die Response-Werte zeigen die Zeitbereichantwort des Messobjekts; dieses Darstellungsformat ermöglicht es, die Eigenschaften und Unzulänglichkeiten eines Netzwerks aus einer anderen Perspektive heraus zu untersuchen.

Die nachfolgenden Abbildungen zeigen die gleiche Kabelreflexionsmessung, einmal im Frequenzbereich und einmal im Zeitbereich. Das Kabel enthält zwei Biegungen, die jeweils eine Impedanz änderung hervorrufen.

  • Die Frequenzbereichantwort zeigt eine Welligkeit, die durch Interaktionen zwischen den Impedanzänderungen im Kabel zustande kommt. Aus der Messkurve kann man nicht ersehen, an welchen Stellen des Kabels sich die Impedanz ändert.

  • Die Zeitbereichantwort ermöglicht es, sowohl das Ausmaß als auch die Position jeder einzelnen Impedanzänderung zu bestimmen. Im obigen Beispiel ist aus der Zeitbereichmesskurve ersichtlich, dass die zweite Biegung des Kabels eine signifikante Impedanzänderung verursacht.

Fourier-Transformation

Aus der Zeitbereichantwort lassen sich unerwünschte Reflexionen, beispielsweise von Steckverbindern und Adaptern, mit Hilfe der "Gating"-Funktion (Zeittor) "ausblenden". Anschließend kann der Analysator die so manipulierte Antwort wieder in den Frequenzbereich zurücktransformieren. Auf diese Weise können Sie untersuchen, wie sich das Messobjekt im Frequenzbereich verhalten würde, wenn die Steckverbinder oder Adapter nicht vorhanden wären. Der Analysator verwendet für diesen Prozess folgende Transformationen:

  • Inverse Fourier-Transformation -- für die Transformation der Frequenzbereichdaten in den Zeitbereich.

  • Fourier-Transformation -- für die Rücktransformation der Zeitbereichdaten in den Frequenzbereich.

Ähnlichkeiten mit der Zeitbereich-Reflektometrie

  • Die Zeitbereich-Betriebsart simuliert das herkömmliche Zeitbereich-Reflektometrie-Messverfahren (TDR), das die elektrischen Eigenschaften von Wellenleitern anhand der gemessenen Reflexionen bestimmt.

  • Durch Analysieren der Formen und Zeitpunkte der Antworten lassen sich die Impedanzen und Entfernungen der Störstellen bestimmen.

Zeitbereichanalyse mit einem Reflektometer

  • Ein herkömmliches TDR sendet ein Impuls- oder Sprungsignal in das Messobjekt und misst das Reflexionssignal.

  • Dieses wird, zusammen mit dem Stimulussignal, auf dem TDR-Bildschirm dargestellt.

  • Durch Analysieren der Größe, Dauer und Form der Reflexionen können Sie die Natur der zugrunde liegenden Impedanzänderungen bestimmen.

Zeitbereichanalyse mit dem Netzwerkanalysator

  • Der Netzwerkanalysator sendet kein Impuls- oder Sprungsignal in das Messobjekt, sondern führt statt dessen eine gewobbelte Frequenzgangmessung durch.

  • Anschließend berechnet er aus den Frequenzgang-Messdaten die Sprung-, Impuls- oder B andpass-Antwort des Messobjekts (je nachdem, welche Transformation Sie gewählt haben).

  • Die Ergebnisse dieser Transformation werden als Zeitbereichdiagramm (ähnlich wie bei einem TDR) dargestellt.

Zeitbereich-Messprozedur

  1. Die Frequenzdaten werden im Zuge einer Frequenzgangmessung erfasst.

  2. "Band Pass"- und "Low Pass"-Betriebsarten -- Welche dieser Betriebsarten sich am besten eignet, hängt von den Frequenzcharakteristiken des Messobjekts ab und davon, welche Antwort (Impuls- und/oder Sprungantwort) dargestellt werden soll.

    • "Band Pass" ist die flexiblere der beiden Betriebsarten. Sie eignet sich am besten für frequenzselektive Bauteile wie z. B. Filter. In dieser Betriebsart kann nur die Impulsantwort dargestellt werden.

    • Die "Low Pass"-Betriebsart simuliert das herkömmliche TDR-Messverfahren. Diese Betriebsart eignet sich am besten für Bauteile, die alle Frequenzen bis hinab zu DC durchlassen, beispielsweise für Kabel. Die Frequenzen in der Wobbelung stehen in einem harmonischen Verhältnis zueinander. In dieser Betriebsart ist sowohl die Impulsantwort als auch die Sprungantwort verfügbar.

  3. "Window" -- Die Fensterfunktion sorgt an den Enden der Abtastperiode für sanfte Übergänge zur Null-Linie. Durch Wahl der optimalen Fensterfunktion können Sie die Genauigkeit der Zeitbereichantwort verbessern. Durch die Fensterung werden unerwünschte Seitenkeulen in der Zeitbereichantwort unterdrückt; dadurch sind schwache Reflexionen leichter erkennbar. Das "Minimum"-Fenster bietet die bestmögliche Auflösung, aber auch die ausgeprägtesten Seitenkeulen.

  4. "Gating" -- dies ist ein Zeittor zur Unterdrückung unerwünschter Reflexionen.

  5. Die Frequenzdaten können nach der Rücktransformation der Zeitbereichdaten in den Frequenzbereich wieder in den gewohnten Formaten dargestellt werden. Die Messkurve zeigt dann, wie sich das Messobjekt im Frequenzbereich verhalten würde, wenn nur die außerhalb des Zeittors liegenden Reflexionen vorhanden wären.

Klicken Sie auf die Schaltflächen, um zu einer Beschreibung der allgemeinen Prozedur für Zeitbereichmessungen zu gelangen.
Messanordnung

Optimierung der Ergebnisse

Interpretation der Messergebnisse

Messanordnung

  1. Wählen Sie die Einstellungen für eine Frequenzbereichmessung. Siehe Einrichten von Messungen.

  2. Entscheiden Sie, welche Transformation verwendet werden soll.

    • Falls das Messobjekt Frequenzen bis hinab zu DC durchlässt, sollten Sie die Betriebsarten "Low pass" und "Step response" wählen.

    • Falls das Messobjekt eine untere Grenzfrequenz besitzt, sollten Sie die Betriebsart "B and p ass" wählen.

    Siehe Betriebsarten "Band Pass" und "Low Pass".

  3. Berechnen Sie die adäquaten Werte der folgenden Parameter. ("Adäquat" bedeutet, dass die resultierende Auflösung und der resultierende Messbereich den Anforderungen der jeweiligen Anwendung entsprechen).

    • Frequenzbereich

    • Anzahl der Messpunkte

    • Fensterbreite

Siehe Auflösung und Bereich.

  4. Geben Sie für Wobbelbandbreite und Anzahl der Messpunkte die im vorigen Schritt berechneten Werte ein. Siehe Einrichten von Messungen.

  5. Wenn Sie die Betriebsart "Low pass" gewählt haben, gehen Sie folgendermaßen vor:

    1. Lassen Sie die Start-Frequenz auf 300 kHz eingestellt und geben Sie die Stop-Frequenz und die Anzahl der Messpunkte ein.

    2. Klicken Sie im Trace-Menü auf Transform, Set Freq. Low Pass. Dadurch werden automatisch alle Frequenzen eingestellt.

  6. Transformieren Sie die Messdaten in den Zeitbereich und wenden Sie den in einem früheren Schritt berechneten "Window"-Wert an. Entscheiden Sie, ob Auflösung und Messbereich für Ihre Anwendung ausreichend sind.

    • Falls die aktuellen Einstellungen es nicht erlauben, die Zeitbereichantwort des Messobjekts zu messen, ändern Sie die Wobbelbandbreite, Anzahl der Messpunkte und Fensterbreite entsprechend ab. Siehe Zeitbereichauflösung und -bereich.

  7. Schalten Sie die Transformation ab und führen Sie eine Kalibrierung durch; wählen Sie das für Ihre Messanordnung und Ihre Genauigkeitsanforderungen bestgeeignete Kalibrierverfahren. Siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

  8. Transformieren Sie die Daten in den Zeitbereich.

Optimierung der Ergebnisse

  1. Skalieren Sie die Zeitbereichantwort mit Hilfe der "Autoscale"-Funktion.

  2. Zentrieren Sie die interessierende Antwort auf dem Bildschirm, um die Auflösung zu maximieren.

  3. Konfigurieren und aktivieren Sie die "Gating"-Funktion (Zeittorfilter), um unerwünschte Antworten aus der Messkurve zu entfernen. Siehe "Gate"-Filter .

Interpretation der Messergebnisse

  1. Interpretieren Sie die Impedanz an der Störstelle. Siehe Zeitbereichmessdaten.

  2. Um die zeittorgefilterten Daten wieder im Frequenzbereich darzustellen, müssen Sie die "Gating"-Funktion aktivieren und die Transformation deaktivieren.


Betriebsarten

Siehe auch...

Zeitbereichbetriebsarten "Band Pass" und "Low Pass"

Überblick

Konzepte

Wie richtet man die Zeitbereichbetriebsart ein?

Bevor Sie die Messparameter wählen, müssen Sie die Zeitbereichbetriebsart wählen. Welche dieser Betriebsarten adäquat ist, hängt in hohem Maße vom jeweiligen Messobjekt ab.
Konzepte

Wie wählt man die Zeitbereichbetriebsart?

Vergleich der beiden Betriebsarten

"Band Pass"

"Low Pass"

Wahl der Betriebsart

Frequenzbereiche und Datenpunkte

Impuls- und Sprungantworten

Verfügbare Datenformate

Vergleich der beiden Betriebsarten

Betriebsart "Band Pass"

  • Am einfachsten anzuwenden

  • Geeignet zur Charakterisierung von Bauteilen mit B andpass verhalten und einer unteren Grenzfrequenz größer als 0 Hz.

  • Erlaubt beliebige Start- und Stop-Frequenzen

  • Erlaubt nur die Darstellung der Impulsantwort, weil die transformierten Daten keinen DC-Term enthalten

  • Ist auf Reflexions- und Transmissionsmessungen anwendbar

  • Ermöglicht Fehlerlokalisierung

Betriebsart "Low Pass"

  • Geeignet für die Charakterisierung von Tiefpass-Bauteilen, die Frequenzen bis hinab zu 0 Hz durchlassen.

  • Simuliert herkömmliche Zeitbereich-Reflektometrie (TDR)

  • Erfordert einen harmonischen Zusammenhang der gemessenen Frequenzen mit einem DC-Term, der aus den ersten paar Frequenzbereich-Datenpunkten extrapoliert wird.

  • Ermöglicht die Darstellung sowohl der Impuls- als auch der Sprungantwort, weil die transformierten Daten einen DC-Term enthalten.

  • Ermöglicht Fehlerlokalisierung und Identifizierung der Natur der Impedanz (kapazitiv oder induktiv) an der Störstelle.

  • Ist auf Reflexions- und Transmissionsmessungen anwendbar

  • Bietet (zweifach) höhere Auflösung als Betriebsart "Band pass" bei gleicher Wobbelbandbreite

Passende Betriebsart vom Messobjekt abhängig

  • Wählen Sie die Betriebsart "Band pass" -- wenn das Messobjekt die Eigenschaften eines Bandpass-, Bandsperre- oder Hochpassfilters besitzt.

  • Wählen Sie die Betriebsart "Low pass" -- wenn das Messobjekt alle Frequenzen bis hinab zu 0 Hz durchlässt. Wählen Sie auch dann die Betriebsart "Low pass", wenn der Frequenzgang an der unteren Grenze der Wobbelbandbreite abfällt.

Frequenzbereiche und Datenpunkte

Betriebsart "Band Pass"

  • Für die Start- und Stop-Frequenzen können Sie beliebige Werte innerhalb des vom Analysator abgedeckten Frequenzbereichs wählen.

  • Der Analysator erfasst Daten im Bereich zwischen der Start-Frequenz und der Stop-Frequenz.

  • Es kann nur die Impulsantwort dargestellt werden.

Betriebsart "Low Pass"

  • Erfordert einen DC-Term, der aus den ersten paar Frequenzbereich-Datenpunkten extrapoliert wird.

  • Erfordert äquidistante Datenpunkte.

  • Der Analysator stellt alle Messfrequenzen auf Oberwellen der Start-Frequenz ein.

  • Maximale Stop-Frequenz FSTOP = N X FSTART (N = Anzahl der Messpunkte).

Hinweis: Der kleinstmögliche Wert für FSTART ist 300 kHz; FSTOP ist daher mindestens N X 300 kHz.

Impuls- und Sprungantworten

Der Netzwerkanalysator kann die Zeitbereichantwort auf einen impulsförmigen oder einen sprungförmigen Stimulus berechnen.

  • Der Impulse-Stimulus -- ist ein Spannungssprung von Null auf Eins und wieder zurück auf Null. Die Impulsbreite wird durch die für die Frequenzbereichmessung verwendete Wobbelbandbreite bestimmt.

  • Der Stufen-Stimulus -- ist ein Spannungssprung von Null auf Eins. Die Anstiegszeit der Sprungantwort wird durch die höchste in der Frequenzbereichmessung verwendete Frequenz bestimmt.

Hinweis: Anhand der in der Betriebsart "Low pass" berechneten Sprungantwort lässt sich die Natur von Störstellen am einfachsten interpretieren. Diese Kombination liefert auch die gängige TDR-Darstellung induktiver und kapazitiver Störstellen.

  • Aus den Frequenzgangdaten berechnet der Analysator die Sprung-, Impuls- oder B andpass-Antwort des Messobjekts (je nachdem, welche Transformation Sie gewählt haben).

  • Die Ergebnisse dieser Transformation werden als Zeitbereichdiagramm (ähnlich wie bei einem TDR) dargestellt.

Weitere Informationen darüber, wie die Wobbelbandbreite die Impulsbreite und Anstiegszeit beeinflusst, siehe Auflösung und Bereich.

Verfügbare Datenformate

Verfügbare Datenformate für die Betriebsart "Band Pass"

  • "Linear Magnitude"

    • Bei Reflexionsmessungen zeigt dieses Format den mittleren Amplitudenbetrag des Reflexionskoeffizienten (r) im linearen Maßstab über den gemessenen Frequenzbereich.

    • Bei Transmissionsmessungen zeigt dieses Format den mittleren Transmissionskoeffizienten (t) des Übertragungspfades über den Frequenzbereich der Messung.

    • Dieses Format eignet sich zur Analyse von Antworten, die sich im Betrag nur wenig voneinander unterscheiden.

  • "Log Magnitude"

    • Bei Reflexionsmessungen zeigt dieses Format die Antwort in Rückflussdämpfungseinheiten (dB). Der angezeigte Wert repräsentiert die mittlere Rückflussdämpfung der Störstelle über den Frequenzbereich der Messung.

    • Bei Transmissionsmessungen zeigt dieses Format die Antwort in Dämpfungs- oder Verstärkungseinheiten (dB). Der Wert repräsentiert die mittlere Dämpfung im Übertragungspfad über den Frequenzbereich der Messung.

    • Dieses Format eignet sich zur Analyse von Transmissionsantworten, die sich über einen weiten Dynamikbereich erstrecken.

  • "Standing Wave Ratio"

    • Bei Reflexionsmessungen zeigt dieses Format das mittlere Stehwellenverhältnis (SWR) der Störstelle über den Frequenzbereich der Messung.

Verfügbare Datenformate für die Betriebsart "Low Pass"

  • "Real"

    • Dieses Format zeigt die Zeitbereichantwort in reellen Einheiten.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zum Einrichten der Zeitbereichbetriebsart.

    • Falls das Messobjekt Frequenzen bis hinab zu DC durchlässt, sollten Sie die Betriebsart "Low pass" wählen.

    • Falls das Messobjekt eine untere Grenzfrequenz größer als Null besitzt, sollten Sie die Betriebsart "B and p ass" wählen.
Einrichten der Betriebsart "Low Pass"

Mausprozedur

Tastenprozedur

Einrichten der Betriebsart "Band Pass"

Mausprozedur

Tastenprozedur

Einrichten der Betriebsart "Low Pass"

Mausprozedur

  1. Wählen Sie die Einstellungen für die Frequenzbereichmessung. Siehe Einrichten von Messungen.

  2. Berechnen Sie geeignete Werte für die Wobbelbandbreite und die Anzahl der Messpunkte.

FSTOP = N X FSTART, wobei N = Anzahl der Messpunkte

Hinweis: Der kleinstmögliche Wert für FSTART ist 300 kHz; FSTOP beträgt daher mindestens N X 300 kHz.

Anzahl der Punkte | Minimale Frequenz Bereich nur für "Low Pass"
3 11 26 51 101 201 401 801 1601 | 300 kHz bis 0,9 MHz 300 kHz bis 3,0 MHz 300 kHz bis 7,8 MHz 300 kHz bis 15,3 MHz 300 kHz bis 30,3 MHz 300 kHz bis 60,3 MHz 300 kHz bis 120,3 MHz 300 kHz bis 240,3 MHz 300 kHz bis 480,3 MHz

  3. Klicken Sie im Sweep-Menü auf Number of Points und geben Sie den gewünschten Wert ein.

  4. Einstellen der Wobbelbandbreite:

    1. Klicken Sie im Channel-Menü auf Start/Stop.

    2. Lassen Sie die Start-Frequenz auf 300 kHz eingestellt und geben Sie die gewünschte Stop-Frequenz ein.

  5. Klicken Sie im Trace-Menü auf Transform und wählen Sie die gewünschte Transformation.

  6. Klicken Sie auf Set Freq. Low Pass. Dadurch werden alle Frequenzen automatisch eingestellt.

    • Falls die Stop-Frequenz auf einen Wert abgeändert wird, der signifikant von dem von Ihnen spezifizierten Wert abweicht, war der ursprüngliche Wert kleiner als der minimale Frequenzbereich für die Betriebsart "Low pass". Falls dies geschieht, reduzieren Sie die Anzahl der Messpunkte, richten Sie die Wobbelbandbreite nochmals neu ein und wiederholen Sie diesen Schritt.

  7. Klicken Sie auf das Kontrollkästchen Transform.

Einrichten der Betriebsart "Low Pass"

Tastenprozedur

  1. Wählen Sie die Einstellungen für die Frequenzbereichmessung. Siehe Einrichten von Messungen.

  2. Berechnen Sie geeignete Werte für die Wobbelbandbreite und die Anzahl der Messpunkte.

FSTOP = N X FSTART, wobei N = Anzahl der Messpunkte

Hinweis: Der kleinstmögliche Wert für FSTART ist 300 kHz; FSTOP beträgt daher mindestens N X 300 kHz.

Anzahl der Punkte | Minimale Frequenz Bereich nur für "Low Pass"
3 11 26 51 101 201 401 801 1601 | 300 kHz bis 0,9 MHz 300 kHz bis 3,0 MHz 300 kHz bis 7,8 MHz 300 kHz bis 15,3 MHz 300 kHz bis 30,3 MHz 300 kHz bis 60,3 MHz 300 kHz bis 120,3 MHz 300 kHz bis 240,3 MHz 300 kHz bis 480,3 MHz

  3. Drücken Sie im Tastenfeld CHANNEL die Taste Sweep Setup.

  4. Drücken Sie F2 (Points) und geben Sie die in einem früheren Schritt berechnete Anzahl der Messpunkte ein.

  5. Einstellen der Wobbelbandbreite:

    1. Drücken Sie im Tastenfeld CHANNEL die Taste Start/Stop.

    2. Lassen Sie die Start-Frequenz auf 300 kHz eingestellt.

    3. Drücken Sie F2 (Stop) und geben Sie die Stop-Frequenz ein.

  6. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  7. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  8. Navigieren Sie mit der Tab-rechts-Taste zu Transform Mode und wählen Sie mit den Pfeiltasten die gewünschte Transformation.

  9. Navigieren Sie mit der Tab-rechts-Taste zu Set Freq. Low Pass. Drücken Sie Click. Dadurch werden automatisch alle Frequenzen eingestellt.

    • Falls die Stop-Frequenz auf einen Wert abgeändert wird, der signifikant von dem von Ihnen spezifizierten Wert abweicht, war der ursprüngliche Wert kleiner als der minimale Frequenzbereich für die Betriebsart "Low pass". Falls dies geschieht, reduzieren Sie die Anzahl der Messpunkte, richten Sie die Wobbelbandbreite nochmals ein, und wiederholen Sie diesen Schritt.

  10. Drücken Sie die Tab-rechts-Taste, um zum Kontrollkästchen Transform zu gelangen, und drücken Sie Click.

Einrichten der Betriebsart "Band Pass"

Mausprozedur

  1. Wählen Sie die Einstellungen für die Frequenzbereichmessung. Siehe Einrichten von Messungen.

  2. Klicken Sie im Trace-Menü auf Transform und wählen Sie die Transformation Band Pass.

Tastenprozedur

  1. Wählen Sie die Einstellungen für die Frequenzbereichmessung. Siehe Einrichten von Messungen.

  2. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  3. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  4. Navigieren Sie mit der Tab-rechts-Taste zu Transform Mode und wählen Sie mit den Pfeiltasten die Betriebsart Band Pass .

  5. Drücken Sie die Tab-rechts-Taste, um zum Kontrollkästchen Transform zu gelangen, und drücken Sie Click.


Auflösung und Bereich

Siehe auch...

Auflösung und Bereich bei Zeitbereichmessungen

Überblick

Konzepte

Wie richtet man die
Auflösung und den Bereich ein?

Nachfolgend wird beschrieben, wie Sie sicherstellen können, dass Sie alle verfügbaren Daten einer Zeitbereichantwort sehen können. Sie lernen, mit welchen Einstellungen Sie die bestmögliche Auflösung und den größtmöglichen Bereich erzielen.
Konzepte

Wie richtet man die Auflösung und den Bereich ein?

Auflösung der Zeitbereichantwort

Bildschirmauflösung

Messbereich

Auflösung der Zeitbereichantwort

Die Auflösung der Zeitbereichantwort bestimmt den Mindestabstand, den zwei Antworten haben müssen, damit sie voneinander unterschieden werden können. Die Auflösung der Zeitbereichantwort wird von mehreren Faktoren bestimmt.
Wobbelbandbreite

Fensterbreite

Zeitbereichbetriebsart

Einfluss der Wobbelbandbreite auf die Auflösung der Zeitbereichantwort

Die folgende Abbildung zeigt den Einfluss der Wobbelbandbreite auf die Auflösung der Zeitbereichantwort.

  • Die Ergebnisse einer Messung mit einer kleinen Wobbelbandbreite und mit einer relativ großen Wobbelbandbreite sind überlagert dargestellt.

  • Die mit der größeren Wobbelbandbreite gemessene Zeitbereichantwort löst die Reflexionen von zwei Steckverbindern als separate Antworten auf; die andere Messung lässt kaum erkennen, dass es sich um zwei Antworten handelt.

  • Die für Zeitbereichmessungen verwendete Impulsbreite ist umgekehrt proportional zur Wobbelbandbreite.

  • Je größer die Wobbelbandbreite, desto kleiner die Impulsbreite bzw. Sprunganstiegszeit.

  • Die Antwortauflösung für zwei Antworten gleicher Amplitude ist gleich der (auf die 50%-Punkte bezogenen) Impulsbreite bzw. gleich der auf die 10%- und 90%-Punkte bezogenen Sprunganstiegszeit.

Einfluss der Fensterbreite auf die Antwortauflösung

  • Die Antwortauflösung ist auch eine Funktion des für die Transformation verwendeten Fensters.

  • Die Antwortauflösung kann näherungsweise nach den unten angegebenen Formeln berechnet werden. Diese Formeln gelten nur für Antworten gleicher Amplitude; die Impulsbreite ist auf die 50%-Punkte bezogen, die Sprunganstiegszeit auf die 10%- und 90%-Punkte.

Die folgende Abbildung verdeutlicht, wie sich die Fensterbreite auf die Antworten auswirkt.

  • Die Auflösung für Antworten gleicher Amplitude können Sie durch Wahl der minimalen Fensterbreite verbessern.

  • Zur Messung von Antworten unterschiedlicher Amplitude können Sie den D ynamikbereich durch Wahl der maximalen Fensterbreite verbessern.

Einfluss der Zeitbereichbetriebsart auf die Antwortauflösung

  • Die Zeitbereichbetriebsarten "B and p ass" und "Low pass" bieten unterschiedliche Antwortauflösungen.

  • Bei gleicher Wobbelbandbreite und Anzahl von Messpunkten bietet die Betriebsart "Low pass" eine höhere Auflösung und eine im Vergleich zur Betriebsart "Band pass" halb so große Impulsbreite.

Bildschirmauflösung

Die Bildschirmauflösung in der Zeitbereichbetriebsart ist ausschlaggebend dafür, wie genau die Position einer einzelnen Antwort bestimmt werden kann. Je feiner die Bildschirmauflösung, desto genauer lassen sich die Spitzen und Nullstellen einer Antwort lokalisieren. Die Bildschirmauflösung steht in einem direkten Zusammenhang mit der Messzeitspanne und der Anzahl der Messpunkte:

Bildschirmauflösung = TSpanne / Punkte – 1

Sie können die Bildschirmauflösung auf zweierlei Weise verbessern:

  • Zeitspanne verringern.

  • Anzahl der Messpunkte vergrößern.

Hinweis: Durch das Vergrößern der Anzahl der Messpunkte kann die Kalibrierung ungültig werden.

Beide unten abgebildete Messungen wurden mit 201 Punkten durchgeführt.

  • Bei der Messung mit 50 ps Auflösung beträgt die Zeitspanne 10 ns.

  • Bei der Messung mit 12,5 ps Auflösung beträgt die Zeitspanne 2,5 ns.

Hinweis: Die Fähigkeit, zwei nahe benachbarte Signale aufzulösen, wird durch die Bildschirmauflösung nicht beeinflusst. Bei Messungen in der Betriebsart "Low pass" kann sich die Änderung der Anzahl der Messpunkte jedoch auf die Wobbelbandbreite auswirken.

Tipps zur Optimierung der Auflösung

  • In den meisten Fällen empfieht es sich, die größte gültige Wobbelbandbreite zu wählen, um die größtmögliche Auflösung im Zeitbereich zu erzielen. Die Messfrequenzen müssen jedoch innerhalb des nutzbaren Frequenzbereichs des Messobjekts bleiben.

  • Die Zeitbereichauflösung ist von der Wobbelbandbreite, der Fensterbreite und der Zeitbereichbetriebsart abhängig.

Messbereich

Im Zeitbereich ist der Messbereich definiert als die Zeitdauer, über die eine Messung durchgeführt werden kann, ohne dass die Antwort sich wiederholt.

Hinweis: Bereich und Antwortauflösung verhalten sich gegenläufig: Wenn sich der eine Parameter verbessert, verschlechtert sich der andere.

Antwortwiederholung (Aliasing) tritt in regelmäßigen Zeitabständen auf. Im nachfolgenden Beispiel wiederholt sich die echte Antwort (in der Nähe von 0 s) bei etwa 60 ns und nochmals bei etwa 120 ns.

Der Bereich ist vom Abstand zwischen den Frequenzpunkten der Frequenzgangmessung abhängig.

Der Messbereich ist proportional zu (Anzahl der Messpunkte–1) und umgekehrt proportional zur Wobbelbandbreite. Sie können den Bereich vergrößern, indem Sie

  • die Anzahl der Messpunkte vergrößern oder

  • die Wobbelbandbreite verkleinern

Hinweis: Diese Änderungen sollten Sie vornehmen, bevor Sie eine Kalibrierung durchführen.

Den Messbereich in Metern erhalten Sie, indem Sie das Zeitintervall mit der Lichtgeschwindigkeit im Vakuum (3 x 108 m/s) multiplizieren. Zur Berechnung der tatsächlichen mechanischen Länge des Messbereichs müssen Sie diesen Wert mit der relativen Lichtgeschwindigkeit im Übertragungsmedium multiplizieren.

  • Vpolyethylen = 0,66

  • Vteflon = 0,70

Hinweis: Wenn Sie den Analysator für den größtmöglichen Messbereich einrichten, verschlechtert sich dadurch eventuell die Antwortauflösung im Zeitbereich. Der maximale Bereich ist auch von der Kabeldämpfung abhängig. Wenn das reflektierte Signal so schwach ist, dass es nicht gemessen werden kann, wird der Messbereich durch diese Abschwächung begrenzt (unabhängig von der Wobbelbandbreite).

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zum Einrichten von Zeitbereichauflösung und -bereich.
Mausprozedur

Tastenprozedur

Mausprozedur

Diese Prozedur setzt voraus, dass Sie bereits eine Zeitbereichmessung eingerichtet haben.

Antwortauflösung

  1. Berechnen Sie die für die gewünschte Antwortauflösung erforderliche Wobbelbandbreite und Fensterbreite.

  2. Klicken Sie im Trace-Menü auf Transform.

  3. Wählen Sie im Feld Category durch Anklicken des nach unten zeigenden Pfeils die Betriebsart Window.

  4. Wählen Sie eine Fensterbreite, mit der Sie die gewünschte Auflösung erzielen.

    • Wählen Sie die kleinste Fensterbreite, wenn Sie Antworten mit ähnlicher Amplitude messen möchten.

    • Wählen Sie die größte Fensterbreite, wenn Sie Antworten mit stark unterschiedlichen Amplituden messen möchten.

  5. Klicken Sie im Channel-Menü auf Start/Stop, und geben Sie Werte ein, die eine größere Wobbelbandbreite ergeben.

  6. Wenn Sie eine noch höhere Antwortauflösung benötigen und das Messobjekt Frequenzen bis hinab zu 0 Hz durchlässt, verwenden Sie die Transformationsbetriebsart "Low pass". Siehe Zeitbereichbetriebsarten.

Bildschirmauflösung

  1. Klicken Sie im Trace-Menü auf Transform.

  2. Geben Sie in das Feld Center einen Wert ein, bei dem die interessierende Antwort in der Bildschirmmitte angezeigt wird.

  3. Geben Sie in das Feld Span einen Wert für eine kleinere Zeitspanne ein.

  4. Falls Sie eine noch höhere Bildschirmauflösung benötigen, vergrößern Sie die Anzahl der Messpunkte. Klicken Sie im Sweep-Menü auf Number of Points und geben Sie einen größeren Wert ein.

Messbereich

Wenn Antworten mehrfach angezeigt werden (Aliasing), ist es im allgemeinen nicht möglich, echte Antworten von "Phantomantworten" zu unterscheiden, ohne spezielle Tests durchzuführen.

  1. Vergrößern Sie die Zeitspanne und kontrollieren Sie, ob mehrere gleich große Antworten in konstanten Abständen zu sehen sind.

  2. Wenn Sie immer noch nicht sicher sind, dass die Antwort echt ist, zentrieren Sie die Antwort auf dem Bildschirm und speichern Sie die Messkurve ab.

  3. Reduzieren Sie die Wobbelbandbreite um etwa 5% und wiederholen Sie die Messung.

  • Falls die Zeitbereichantwort gültig ist, bleibt sie in der Bildschirmmitte.

  • Falls es sich um eine Phantomantwort handelt, verschiebt sie sich beim Ändern des Frequenzbereichs entlang der X-Achse.

  4. Berechnen Sie die für den gewünschten Messbereich erforderliche Wobbelbandbreite und Anzahl der Messpunkte.

  5. Klicken Sie im Sweep-Menü auf Number of Points und geben Sie einen größeren Wert ein.

  6. Klicken Sie im Channel-Menü auf Start/Stop, und geben Sie die berechneten Werte ein.

Hinweis: Nachdem Sie die Einstellungen geändert haben, um die gewünschte Auflösung und den gewünschten Messbereich zu erzielen, deaktivieren Sie die Transformation, führen Sie eine Kalibrierung durch und reaktivieren Sie danach wieder die Transformation.

Tastenprozedur

Diese Prozedur setzt voraus, dass Sie bereits eine Zeitbereichmessung eingerichtet haben.

Antwortauflösung

  1. Berechnen Sie die für die gewünschte Antwortauflösung erforderliche Wobbelbandbreite und Fensterbreite.

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Category und wählen Sie mit der Pfeil-unten-Taste Window.

  4. Wählen Sie eine Fensterbreite, mit der Sie die gewünschte Auflösung erzielen.

    • Wählen Sie die kleinste Fensterbreite, wenn Sie Antworten mit ähnlicher Amplitude messen möchten.

    • Wählen Sie die größte Fensterbreite, wenn Sie Antworten mit stark unterschiedlichen Amplituden messen möchten.

  5. Klicken Sie im Channel-Menü auf Start/Stop, und geben Sie Werte ein, die eine größere Wobbelbandbreite ergeben.

  6. Wenn Sie eine noch höhere Antwortauflösung benötigen und das Messobjekt Frequenzen bis hinab zu 0 Hz durchlässt, verwenden Sie die Transformationsbetriebsart "Low pass". Siehe Zeitbereichbetriebsarten.

Bildschirmauflösung

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Center und geben Sie einen Wert ein, bei dem die interessierende Antwort in der Bildschirmmitte angezeigt wird.

  4. Navigieren Sie mit der Tab-rechts-Taste zum Feld Span und geben Sie einen Wert für eine kleinere Zeitspanne ein.

  5. Falls Sie eine noch höhere Bildschirmauflösung benötigen, vergrößern Sie die Anzahl der Messpunkte.

    1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

    2. Drücken Sie F2 (Points) und wählen Sie einen größeren Wert.

Messbereich

Wenn Antworten mehrfach angezeigt werden (Aliasing), ist es im allgemeinen nicht möglich, echte Antworten von "Phantomantworten" zu unterscheiden, ohne spezielle Tests durchzuführen.

  1. Vergrößern Sie die Zeitspanne und kontrollieren Sie, ob mehrere gleich große Antworten in konstanten Abständen zu sehen sind.

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

    3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Span und geben Sie einen Wert für eine größere Zeitspanne ein.

  2. Wenn Sie immer noch nicht sicher sind, dass die Antwort echt ist, zentrieren Sie die Antwort auf dem Bildschirm und speichern Sie die Messkurve ab.

    1. Navigieren Sie mit der Tab-rechts-Taste zum Feld Center und geben Sie einen Wert ein, bei dem die interessierende Antwort in der Bildschirmmitte angezeigt wird.

    2. Drücken Sie im Tastenfeld TRACE SETUP die Tasten Math/Memory und F1 (Data>>Mem).

  3. Reduzieren Sie die Wobbelbandbreite um etwa 5% und wiederholen Sie die Messung.

    1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Stop/Span.

    2. Drücken Sie in der Aktuelle-Eingabe-Symbolleiste F4 (Span) und geben Sie einen Wert für eine kleinere Wobbelbandbreite ein.

  4. Falls die Zeitbereichantwort gültig ist, bleibt sie in der Bildschirmmitte.

  • Falls es sich um eine Phantomantwort handelt, verschiebt sie sich beim Ändern des Frequenzbereichs entlang der X-Achse.

  4. Berechnen Sie die für den gewünschten Messbereich erforderliche Wobbelbandbreite und Anzahl der Messpunkte.

  5. Drücken Sie im Tastenfeld CHANNEL SETUP die Tasten Sweep Setup, F2 (Points) und wählen Sie den berechneten Wert.

  6. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Stop und geben Sie die berechneten Werte ein, mit denen Sie den gewünschten Messbereich erzielen.

Hinweis: Nachdem Sie die Einstellungen geändert haben, um die gewünschte Auflösung und den gewünschten Messbereich zu erzielen, deaktivieren Sie die Transformation, führen Sie eine Kalibrierung durch und reaktivieren Sie danach wieder die Transformation.


Siehe auch...

Fensterfilter

Überblick

Konzepte

Wie richtet man das Fensterfilter ein?

Die Auflösung im Zeitbereich wird durch Seitenkeulen- und Impulsbreiteneffekte begrenzt. Diese Effekte können mit Hilfe eines Fensterfilters abgemildert werden.
Konzepte

Wie richtet man das Fensterfilter ein?

Der Analysator bietet eine Fensterungsfunktion, die es ermöglicht, einzelne Antworten besser zu isolieren und zu identifizieren. Diese Funktion beeinflusst die Impulsbreite, die Seitenkeulenamplitude und die Anstiegszeit der Zeitbereichantwort.
Vorteile des Fensterfilters

Passender "Window"-Wert

Vorteile des Fensterfilters

Bei einer Frequenzbereich-Messung treten an den Start- und Stop-Frequenzen abrupte Übergänge auf, die in der Zeitbereichantwort Überschwingen und Nachschwingen verursachen. Das Fensterfilter macht diese Übergänge weniger abrupt.

  • Die (wegen der begrenzten Bandbreite des Messsystems) endliche Impulsbreite oder Sprunganstiegszeit begrenzt die Fähigkeit des Systems, zwei nahe benachbarte Antworten separat aufzulösen. Die Impulsbreite ist umgekehrt proportional zur Wobbelbandbreite; die Impulsbreite lässt sich nur durch Vergrößern der Wobbelbandbreite verringern.

  • Die (von dem abrupten Übergang bei der Stop-Frequenz verursachten) Impuls-Seitenkeulen begrenzen den D ynamikbereich der Zeitbereichmessung, weil die Seitenkeulen amplitudenstarker Antworten benachbarte schwache Antworten verdecken können.

Fensterfiltereffekte

  • Die Auflösung der Zeitbereichantwort verbessert sich durch das Verkleinern der Impulsbreite; dadurch können nahe benachbarte Antworten besser aufgelöst werden.

  • Der Dynamikbereich vergrößert sich durch die Verringerung der Seitenkeulen; dadurch verbessert die die Messempfindlichkeit.

Sie können den "Window"-Wert wählen:

"Window"-Wert | Seitenkeulenamplitude | Impulsbreite | Am besten geeignet für...
Minimum | Höher | Kleinstmöglich | Hohe Antwortauflösung
Maximum | Geringer | Größtmöglich | Großer Dynamikbereich

Hinweis: Die Auflösung ist proportional zur angewandten Fensterfunktion und umgekehrt proportional zur Wobbelbandbreite. Siehe Auflösung und Bereich.

Der Analysator kann bei der Zeitbereichtransformation ein Filter auf die Messdaten anwenden, das folgendes bewirkt:

  • Beim Impuls-Stimulus -- die Einschränkungen hinsichtlich der Zeitauflösung ändern sich durch den Einfluss des Filters auf die Seitenkeulen- und Impulsbreiteneffekte.

  • Beim Sprung-Stimulus -- (nur für Betriebsart "Low pass") verringern sich das Überschwingen und Nachschwingen.

Passender "Window"-Wert

Sie können den für die erwarteten Zeitbereichantworten optimalen "Window"-Wert wählen.

  • Wenn zwei nahe benachbarte Antworten mit ähnlichen Amplituden zu erwarten sind, wählen Sie das Fenster, das die kleinstmögliche Impulsbreite ergibt: "Minimum"-Fenster für bessere Auflösung.

  • Wenn zwei Antworten mit stark unterschiedlichen Amplituden zu erwarten sind, wählen Sie das Fenster, das die niedrigste Seitenkeulenamplitude ergibt: "Maximum"-Fenster für größeren D ynamikbereich.

Fenstercharakteristiken

Es bestehen die folgenden Abhängigkeiten; die Tabelle weiter unten enthält einige Beispiele mit konkreten Werten.

Abhängigkeiten

Seitenkeulenamplituden

  • Fenstercharakteristik

Anstiegszeit und
Impulsbreite

  • Fenstercharakteristik

  • Wobbelbandbreite

Die nachfolgenden Werte gelten für eine Wobbelbandbreite von 2,997 GHz.

Fenstercharakteristiken |  | Auflösung der Zeitbereichantwort* |  | Dynamikbereich
 |  | Sprunganstiegszeit (10%- und 90%-Punkte) | Impulsbreite (50%-Punkt) | Seitenkeulen- Amplitude
"Low Pass Step | "Minimum" | 150 ps |  | –21 dBc
 | "Normal" | 330 ps |  | –60 dBc
 | "Maximum" | 494 ps |  | < –70 dBc
"Low Pass Impulse" | "Minimum" |  | 200 ps | –13 dBc
 | "Normal" |  | 320 ps | –44 dBc
 | "Maximum" |  | 481 ps | < –75 dBc
"Band Pass Impulse" | "Minimum" |  | 400 ps | –13 dBc
 | "Normal" |  | 641 ps | –44 dBc
 | "Maximum" |  | 961 ps | < –75 dBc

Gleichungen zur Berechnung der Auflösung der Zeitbereichantwort

Die folgende Grafik zeigt die typischen Auswirkungen der verschiedenen Fenster auf die Zeitbereichantwort einer Kurzschluss-Reflexionsmessung.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zum Einrichten des Fensterfilters in der Zeitbereichbetriebsart.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Transform.

  2. Wählen Sie im Feld Category durch Anklicken des nach unten zeigenden Pfeils die Betriebsart Window.

  3. Wählen Sie ein Fenster, mit dem Sie die erforderliche Auflösung erzielen.

    • Wenn Sie Antworten mit ähnlicher Amplitude messen möchten, wählen Sie zur Verbesserung der Antwortauflösung die kleinste Fensterbreite.

    • Wenn Sie Antworten mit stark unterschiedlichen Amplituden messen möchten, wählen Sie zur Vergrößerung des D ynamikbereichs das größte Fenster.

Hinweis: Sie können einen Fensterwert durch "Minimum/maximum", "Kaiser Beta" oder "Impulse width/step rise time" spezifizieren.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Category und wählen Sie mit der Pfeil-unten-Taste Window.

  4. Wählen Sie ein Fenster, mit dem Sie die erforderliche Auflösung erzielen.

    • Wenn Sie Antworten mit ähnlicher Amplitude messen möchten, wählen Sie zur Verbesserung der Antwortauflösung die kleinste Fensterbreite.

    • Wenn Sie Antworten mit stark unterschiedlichen Amplituden messen möchten, wählen Sie zur Vergrößerung des Dynamikbereichs die größte Fensterbreite,

Hinweis: Sie können einen Fensterwert durch "Minimum/maximum", "Kaiser Beta" oder "Impulse width/step rise time" spezifizieren.


Zeittor

Siehe auch...

Zeittorfilter

Überblick

Konzepte

Wie richtet man das Zeittorfilter ein?

Das Zeittorfilter ("Gate"-Funktion) ermöglicht es Ihnen, einzelne Zeitbereichantworten rechnerisch zu entfernen. Anschließend können die so manipulierten Zeitbereichdaten wieder in den Frequenzbereich zurücktransformiert und als Frequenzgang dargestellt werden.
Konzepte

Wie richtet man das Zeittorfilter ein?

Nach Anwendung der Zeittorfilterfunktion können Sie die Zeitbereichtransformation deaktivieren und sich den Frequenzgang anschauen, den das Messobjekt hätte, wenn die im Zeitbereich unterdrückte Antwort tatsächlich fehlen würde. Beispielsweise können Sie bei einer Transmissionsmessung die Einflüsse von Mehrwege-Signalpfaden eliminieren. Alternativ können Sie eine einzelne Antwort isolieren und in den Frequenzbereich zurücktransformieren, um sich deren Auswirkungen auf den Frequenzgang anzuschauen.
Vorgehensweise

Zeittoreinstellungen

Zeittorformen

Zeittorcharakteristiken

Vorgehensweise

  1. Führen Sie eine Messung im Frequenzbereich durch.

  2. Aktivieren Sie die Zeitbereich-Transformation. Der Netzwerkanalysator berechnet die Zeitbereichantwort (Betriebsart "Low pass" oder "Bandpass").

  3. Richten Sie die Zeittorgrenzen ein.

    • Für Tortyp "Bandpass" -- zentrieren Sie das Zeittor über der Antwort oder den Antworten, die in der Messung verbleiben sollen. Aktivieren Sie die "Gate"-Funktion; die außerhalb des Zeittors liegenden Antworten verschwinden aus der transformierten Messkurve.

    • Für Tortyp "Notch" -- zentrieren Sie das Zeittor über der Antwort oder den Antworten, die aus der Messung entfernt werden sollen. Aktivieren Sie die "Gate"-Funktion; die innerhalb des Zeittors liegenden Antworten verschwinden aus der transformierten Messkurve.

  4. Deaktivieren Sie die Zeitbereich-Transformation und schauen Sie sich die in den Frequenzbereich zurücktransformierten Messdaten an. Es wird jetzt der Frequenzgang angezeigt, den das Messobjekt hätte, wenn die außerhalb des Zeittors (für Tortyp "Bandpass") bzw. innerhalb des Zeittors (für Tortyp "Notch") liegenden Antworten nicht vorhandenen wären. Das folgende Beispiel zeigt die Wirkung eines "Bandpass"-Zeittors.

Zeittoreinstellungen

Sie können die Zeittorgrenzen und die Charakteristiken des Zeittors innerhalb dieser Grenzen definieren:

  • Start und Stop -- dies sind die –6-dB-Zeiten.

  • Center -- dies ist die Mittelzeit.

  • Span -- dies ist die Torzeitspanne (Stop-Zeit minus Start-Zeit).

  • Gate Type:

    • Bandpass -- die außerhalb des Start/Stop- bzw. Span-Bereichs liegenden Antworten werden unterdrückt.

    • Notch -- die innerhalb des Start/Stop- bzw. Span-Bereichs liegenden Antworten werden unterdrückt.

In diesem Beispiel wurden die außerhalb der Spanne liegenden Antworten durch ein "Bandpass"-Zeittor unterdrückt.

.

Zeittorformen

Ein Zeittor besitzt, ähnlich wie das Fensterfilter, eine Filterform. Sie können die Messung optimieren, indem Sie die passende Zeittorform wählen: "Minimum", "normal", "wide" oder "maximum".

  • Minimum Shape -- hat folgende Eigenschaften: größte Seitenkeulenamplituden, größte Flankensteilheit und größte Welligkeit im Durchlassbereich.

  • Minimum Shape -- hat folgende Eigenschaften: kleinste Seitenkeulenamplituden, geringste Flankensteilheit und geringste Welligkeit im Durchlassbereich.

Welligkeit im Durchlassbereich

Das Zeittor ist ein Bandpassfilter; jede der vier Filterformen besitzt unterschiedliche Charakteristiken. Die folgende Grafik verdeutlicht die Unterschiede zwischen den vier Filterformen hinsichtlich der Welligkeit im Durchlassbereich (Y-Skala: 0,5 dB/Skt). Das "Minimum"-Zeittor weist die größte Welligkeit auf.

Seitenkeulen

Die folgende Grafik zeigt die Seitenkeulenamplituden der vier Filterformen im Vergleich. Je geringer die Seitenkeulenamplitude ist, desto geringer ist auch die Flankensteilheit.

  • Das "Minimum"-Zeittor produziert die größten Seitenkeulenamplituden, bietet dafür aber die größte Flankensteilheit; es eignet sich insbesondere zur Unterdrückung einer unerwünschten Antwort in unmittelbarer Nähe einer erwünschten Antwort.

  • Das "Maximum"-Zeittor zeichnet sich durch besonders geringe Seitenkeulenamplituden und optimale Abschwächung von Antworten außerhalb der Spanne aus, bietet dafür aber eine geringere Flankensteilheit.

Zeittorcharakteristiken

Hier eine kurze Zusammenfassung der Charakteristiken der vier Zeittorformen:

  • Die Welligkeit im Durchlassbereich und die Seitenkeulenamplitude beschreiben die Form des Zeittors.

  • Die Grenzzeit ist das Zeitintervall zwischen der Stop-Zeit (–6-dB-Punkt der Filterflanke) und dem Gipfel der ersten Seitenkeule.

  • Die Minimale Zeittorspanne ist das Doppelte der Grenzzeit.

Grenzzeit

Das folgende Diagramm zeigt die allgemeine Form eines Zeittors und erläutert die verschiedenen Zeittor-Parameter.

  • T1 ist die Zeittorspanne; diese ist gleich der Stop-Zeit minus der Start-Zeit.

  • T2 ist das Zeitintervall vom Rand des Durchlassbereichs bis zum –6-dB-Punkt; diese Zeit ist ein Maß für die Flankensteilheit.

  • T3 ist das Zeitintervall vom –6-dB-Punkt bis zum Rand des Sperrbereichs.

Bei allen Filterformen ist T2 gleich T3; alle Filter sind symmetrisch zur Mittenzeit.

Minimale Spanne

Für jede Zeittorform wird eine minimale Zeittorspanne empfohlen, die eingehalten werden muss, wenn das Filter korrekt funktionieren soll. Dies ist eine Konsequenz aus der endlichen Flankensteilheit des Zeittors. Die empfohlene minimale Zeittorspanne ergibt sich aus der folgenden Gleichung:

T1MIN = 2 x T2

Wenn Sie eine Zeittorspanne spezifizieren, die kleiner ist als die minimale Spanne, produziert der Analysator folgende Effekte:

  • verzerrte Zeittorform ohne Durchlassbereich

  • verzerrte Form

  • falsche Anzeigen für Start- und Stop-Zeiten

  • eventuell erhöhte Seitenkeulenamplituden

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zum Einrichten des Zeittors.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Trace-Menü auf Transform.

  2. Wählen Sie im Feld Category durch Anklicken des nach unten zeigenden Pfeils die Betriebsart Gating.

  3. Wählen Sie im Feld Gate Type den gewünschten Zeittor-Filtertyp.

    • Wählen Sie Bandpass, wenn die außerhalb der Zeittorspanne liegenden Antworten unterdrückt werden sollen.

    • Wählen Sie Bandpass, wenn die innerhalb der Zeittorspanne liegenden Antworten unterdrückt werden sollen.

  4. Wählen Sie im Feld Gate Shape die gewünschte Zeittorform. Für jede Zeittorform wird eine minimale Zeittorspanne empfohlen, die eingehalten werden muss, wenn das Filter korrekt funktionieren soll.

  5. Spezifizieren Sie die Zeittorgrenzen durch Eingabe entsprechender Werte für Start und Stop oder Center und Span.

  6. Klicken Sie zum Aktivieren des Zeittors auf das Kontrollkästchen Gating.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

  3. Navigieren Sie mit der Tab-rechts-Taste zu Category und wählen Sie mit der Pfeil-unten-Taste Gating.

  4. Navigieren Sie mit der Tab-rechts-Taste zu Gate Type und wählen Sie den gewünschten Zeittor-Filtertyp.

    • Wählen Sie Bandpass, wenn die außerhalb der Zeittorspanne liegenden Antworten unterdrückt werden sollen.

    • Wählen Sie Bandpass, wenn die innerhalb der Zeittorspanne liegenden Antworten unterdrückt werden sollen.

  5. Navigieren Sie mit der Tab-rechts-Taste zum Feld Gate Shape und wählen Sie die gewünschte Zeittorform. Für jede Zeittorform wird eine minimale Zeittorspanne empfohlen, die eingehalten werden muss, wenn das Filter korrekt funktionieren soll. Siehe Zeittor-Charakteristiken.

  5. Spezifizieren Sie die Zeittorgrenzen durch Eingabe entsprechender Werte für Start und Stop oder Center und Span.

  6. Navigieren Sie mit der Tab-rechts-Taste zum Kontrollkästchen Gating und drücken Sie zum Aktivieren der Zeittorfunktion die Taste Click.


Siehe auch...

Zeitbereichmessdaten

Überblick

Konzepte

Wie interpretiert man Zeitbereichmessdaten?

Nachfolgend werden einige Beispiele für verschiedene Arten von Zeitbereichmessungen beschrieben, die Ihnen helfen sollen, das Verhalten von Bauteilen im Zeitbereich besser zu verstehen.
Konzepte

Wie interpretiert man Zeitbereichmessdaten?

Maskierung

Reflexionsmessung in der Betriebsart "Band Pass"

Transmissionsmessung in der Betriebsart "Band Pass"

Störstellenlokalisierung in der Betriebsart "Low Pass"

Reflexionsmessung in der Betriebsart "Low Pass"

Transmissionsmessung in der Betriebsart "Low Pass"

Maskierung

Bei Zeitbereichmessungen kann es vorkommen, dass Antworten maskiert werden. Deshalb bedürfen Zeitbereichmessdaten einer sorgfältigen Interpretation.

  • Maskierung tritt auf, wenn die der Messebene nächstgelegene Störstelle (sei sie reflektiv oder absorbierend) die Antworten aus dem dahinter liegenden Bereich beeinflusst.

  • Die von der ersten Störstelle reflektierte oder absorbierte Energie gelangt niemals zur zweiten oder einer späteren Störstelle.

  • Dadurch erscheinen die nachfolgenden Antworten schwächer, als wenn die erste Antwort nicht vorhanden wäre.

Maskierung infolge von Reflexion

Maskierung infolge von Reflexion tritt auf, wenn eine grobe Fehlanpassung vorliegt. Das folgende Beispiel zeigt eine solche Maskierung infolge einer Änderung der Leitungsimpedanz.

  • Eine 50-Ohm-Leitung ist über eine 25-Ohm-Rohrleitung wiederum an eine 50-Ohm-Leitung angeschlossen.

  • Die erste Störstelle hat einen Reflexionskoeffizienten von etwa 0,333 (wie es am Übergang zu einer Impedanz von 25 Ohm zu erwarten ist).

  • Die Antwort vom Ende des 25-Ohm-Abschnitts zeigt einen kleineren Reflexionskoeffizienten (obwohl auch dieser Reflexionskoeffizient 0,333 betragen müsste). Aus der Delta-Marker-Anzeige ist ersichtlich, dass die Amplituden der beiden Antworten um 35.355 mU differieren. Der Grund dafür ist, dass der Messimpuls beim Eintreffen an der zweiten Reflexionsstelle nicht mehr die volle Energie besitzt, weil ein Teil davon an der ersten Reflexionsstelle reflektiert wurde.

Maskierung infolge von Absorption

Maskierung infolge von Absorption tritt bei Messungen an verlustbehafteten Messobjekten auf. Die folgende Abbildung zeigt als Beispiel für eine solche Maskierung eine Messung an einem Kabel mit offenem Ende.

  • Der Marker 1 zeigt für die Rückflussdämpfung am offenen Kabelende einen Wert von –2.445 dB an (Format "Log Mag").

  • Zu erwarten wäre ein Wert von 0 dB (Totalreflexion).

  • Der Marker-Wert entspricht der Summe der Dämpfungen in den Vorwärts- und Rückwärtspfaden.

Reflexionsmessung in der Betriebsart "Band Pass"

X-Werte

  • Der X-Wert gibt die Zeit an, die der Messimpuls benötigt, um von der Messebene bis zu der betreffenden Störstelle und wieder zurück zu gelangen.

Y-Werte

  • Rückflussdämpfung (dB) bei Darstellung im Format "Log Mag"

  • Reflexionskoeffizient (rho) bei Darstellung im Format "Lin Mag"

Das folgende Beispiel zeigt eine Reflexionsmessung in der Betriebsart "B and pass".

  • Die erste Antwort (Zeitpunkt Null) repräsentiert die Laufzeit der – vom Stimulussignalausgang gesehen – ersten Störstelle (Steckverbinder).

  • Die darauffolgende Antwort entspricht der nächsten Störstelle (Steckverbinder), auf die der Messimpuls trifft.

Transmissionsmessung in der Betriebsart "Band Pass"

X-Werte

  • Signallaufzeit durch das Messobjekt

Y-Werte

  • Dämpfung oder Verstärkung (dB) bei Darstellung im Format "Log Mag"

  • Transmissionskoeffizient (rho) bei Darstellung im Format "Lin Mag"

Das folgende Beispiel zeigt eine Transmissionsmessung in der Betriebsart "B and pass".

  • Dieses Beispiel zeigt, wie Sie mit einer Zeitbereichmessung Mehrwege-Signalpfade in einem akustischen Oberflächenwellenfilter (SAW) erkennen und charakterisieren können.

  • Die erste Antwort nahe bei Null entspricht der Laufzeit im kürzesten Pfad vom Eingang bis zum Ausgang des Filters. Diese Antwort kann (muss aber nicht) die stärkste Antwort sein oder den gewünschten Pfad repräsentieren.

  • Die weiteren Antworten entsprechen anderen, längeren Signalpfaden vom Eingang zum Ausgang.

Tipp: Wenn Sie nur die Antwort aus dem Hauptsignalpfad sehen möchten, können Sie mit Hilfe eines entsprechenden Zeittors alle übrigen Antworten unterdrücken. Anschließend können Sie sich im Frequenzbereich den Frequenzgang ansehen, den das Bauteil hätte, wenn das Signal nur über den Hauptsignalpfad vom Eingang zum Ausgang gelangen würde.

Störstellenlokalisierung in der Betriebsart "Low Pass"

Die Betriebsart "Low pass" kann zur Simulation einer TDR- (Zeitbereich-Reflektometer) Messung verwendet werden. Die Zeitbereichantwort enthält Informationen, die es ermöglichen, die Natur einer Störstelle zu bestimmen.

Die folgende Abbildung zeigt die charakteristischen "Low pass"-Antworten verschiedener Arten von Störstellen. Die Diagramme zeigen die Ergebnisse von S11-Messungen in simulierter Zeitbereichdarstellung. Die Betriebsart "Low pass" ermöglicht es, die Reaktion des Messobjekts auf einen Sprung- oder Impuls-Stimulus darzustellen.

Tipp: Mit dem Sprung-Stimulus lassen sich die Eigenschaften von Störstellen schneller und einfacher bestimmen. Diese Betriebsart hat die meisten Ähnlichkeit mit herkömmlichen TDR-Messungen.

Reflexionsmessung in der Betriebsart "Low Pass"

X-Werte

  • Der X-Wert gibt die Zeit an, die der Messimpuls benötigt, um von der Messebene bis zu der betreffenden Störstelle und wieder zurück zu gelangen.

Hinweis: Um die tatsächliche mechanische Länge bestimmen zu können, müssen Sie den korrekten Ausbreitungsgeschwindigkeitsfaktor ("Velocity factor") eingeben.

Y-Werte

  • Reflexionskoeffizient (r) bei Darstellung im Format "Real"

Die folgende Abbildung zeigt (überlagert) die Ergebnisse von zwei Reflexionsmessungen in der Betriebsart "Low pass", einmal mit einem Impuls-Stimulus und einmal mit einem Sprung-Stimulus; das Darstellungsformat ist beide Male "Log Mag".

  • Die folgenden Abbildungen zeigen die Ergebnisse von Reflexionsmessungen an zwei unterschiedlichen Kabeln; die Messungen wurden in der Betriebsart "Low pass" durchgeführt, das Darstellungsformat ist "Real".

  • Die "Low pass"-Zeitbereichantwort enthält Informationen über den Ort der Störstelle und die Natur der Impedanz.

  • Das Diagramm links zeigt die Zeitbereichantwort eines eingedrückten Kabels mit einer kapazitiven Störstelle.

  • Das Diagramm rechts zeigt die Zeitbereichantwort eines durchgescheuerten Kabels mit einer induktiven Störstelle.

Transmissionsmessung in der Betriebsart "Low Pass"

X-Werte

  • Mittlere Signallaufzeit (innerhalb eines bestimmten Frequenzbereichs) durch das Messobjekt

  • E lektrische Länge eines Bauteils in Zeiteinheiten

Y-Werte

  • "Real"-Einheiten (beispielsweise Volt) bei Darstellung im Format "Real"

  • Dämpfung oder Verstärkung (dB) bei Darstellung im Format "Log Mag" (nur für Impuls-Stimulus)

Die folgende Abbildung zeigt die Zeitbereichantwort eines Verstärkers in der Betriebsart "Low pass" mit Sprung-Stimulus.

  • Die Zeitdifferenz zwischen dem Sprung und der Antwort des Verstärkers entspricht der mittleren Gruppenlaufzeit über den Messfrequenzbereich.

  • Die Anstiegszeit der Sprungantwort wird durch die höchste in der Frequenzbereichmessung verwendete Frequenz bestimmt. Je höher die Stop-Frequenz, desto kürzer die Anstiegszeit.

  • Das Überschwingen in der Zeitbereichantwort deutet auf eine nicht ausreichend bedämpfte Resonanz hin.

Tipp: Das zweckmäßigste Format für die Darstellung von "Low pass"-Zeitbereichmessungen mit Sprung-Stimulus ist "Real" (Reflexionskoeffizient-Einheiten). Das Format "Real" ist auch für Messungen mit Impuls-Stimulus geeignet, den größten D ynamikbereich erzielen Sie jedoch mit dem Format "Log Mag"; ein großer Dynamikbereich ist wichtig, wenn Sie gleichzeitig sowohl stark als auch schwach reflektierende oder absorbierende Störstellen messen möchten.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren für die Darstellung von Zeitbereich-Messergebnissen.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Stellen Sie die Start-Zeit auf –1 s ein, damit Sie auch die Reflexion am Messanschluss erkennen können.

    1. Klicken Sie im Trace-Menü auf Transform.

    2. Klicken Sie auf das Feld Start und geben Sie "–1 sec" ein.

  2. Klicken Sie im Trace-Menü auf Autoscale, damit die gesamte Zeitbereichantwort angezeigt wird.

  3. Zentrieren Sie die interessierende Antwort auf dem Bildschirm und reduzieren Sie die Zeitspanne, um die Auflösung zu maximieren.

    1. Klicken Sie im Trace-Menü auf Transform.

    2. Klicken Sie auf das Feld Start und geben Sie "–1 sec" ein.

  4. Wenn Sie eine bessere Antwortauflösung benötigen, können Sie das Fenster und die Messparameter ändern. Siehe Zeitbereichauflösung und -bereich.

  5. Geben Sie den korrekten Ausbreitungsgeschwindigkeitsfaktor ein, damit die mechanischen Positionen der Störstellen richtig angezeigt werden.

    1. Klicken Sie im Scale-Menü auf Electrical Delay.

    2. Geben Sie in das Feld Velocity Factor den Ausbreitungsgeschwindigkeitsfaktor ein; der Wert muss zwischen 0 und 1.0 betragen.

      • Lichtgeschwindigkeit im Vakuum = 1.0

      • Polyethylen (meistverwendetes Kabel-Dielektrikum) = 0.66

      • Teflon = 0.7

    3. Bestimmen Sie mit Hilfe eines Markers die Zeit und die elektrische Länge von der Messebene bis zu der interessierenden Störstelle (beide Werte beziehen den Hin- und Rückweg ein).

Hinweis: Zur Bestimmung der mechanischen (statt der elektrischen) Länge müssen Sie für "Velocity factor" den Ausbreitungsgeschwindigkeitsfaktor des jeweiligen Mediums eingeben. Wenn Sie möchten, dass die Marker statt der Länge des Hin- und Rückwegs die tatsächliche Entfernung der Störstelle anzeigen, geben Sie die Hälfte des tatsächlichen Ausbreitungsgeschwindigkeitsfaktors ein.

  6. Falls Sie die Messung in der Betriebsart "Low pass" durchführen, bestimmen Sie den Betrag und die Phase der interessierenden Impedanz-Änderung. Siehe Störstellenlokalisierung in der Betriebsart "Low Pass".

Tastenprozedur

  1. Stellen Sie die Start-Zeit auf –1 s ein, damit Sie auch die Reflexion am Messanschluss erkennen können.

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

    3. Drücken Sie die Tab-rechts-Taste, um zum Feld Start zu gelangen, und geben Sie den Wert "–1 sec" ein.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste F1 (Autoscale), damit die gesamte Zeitbereichantwort angezeigt wird.

  3. Zentrieren Sie die interessierende Antwort auf dem Bildschirm und reduzieren Sie die Zeitspanne, um die Auflösung zu maximieren.

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Navigieren Sie im Tastenfeld NAVIGATION mit der Tab-rechts-Taste und den Pfeiltasten zum Trace-Menü und zu Transform. Drücken Sie Click.

    3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Center und geben Sie einen Wert ein, bei dem die interessierende Antwort in der Bildschirmmitte angezeigt wird.

    4. Navigieren Sie mit der Tab-rechts-Taste zum Feld Span und geben Sie einen Wert für eine kleinere Zeitspanne ein.

  4. Wenn Sie eine bessere Antwortauflösung benötigen, können Sie das Fenster und die Messparameter ändern. Siehe Zeitbereichauflösung und -bereich.

  5. Geben Sie den korrekten Ausbreitungsgeschwindigkeitsfaktor ein, damit die mechanischen Positionen der Störstellen richtig angezeigt werden.

    1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

    2. Drücken Sie im Tastenfeld NAVIGATION die Tab-rechts-Taste und die Pfeil-unten-Taste, um zum Scale-Menü und zu Electrical Delay zu gelangen. Drücken Sie Click.

    3. Navigieren Sie mit der Tab-rechts-Taste zum Feld Velocity Factor und geben Sie den Ausbreitungsgeschwindigkeitsfaktor ein; der Wert muss zwischen 0 und 1.0 betragen.

      • Lichtgeschwindigkeit im Vakuum = 1.0

      • Polyethylen (meistverwendetes Kabel-Dielektrikum) = 0.66

      • Teflon = 0.7

    4. Bestimmen Sie mit Hilfe eines Markers die Zeit und die elektrische Länge von der Messebene bis zu der interessierenden Störstelle (beide Werte beziehen den Hin- und Rückweg ein).

Hinweis: Zur Bestimmung der mechanischen (statt der elektrischen) Länge müssen Sie für "Velocity factor" den Ausbreitungsgeschwindigkeitsfaktor des jeweiligen Mediums eingeben. Wenn Sie möchten, dass die Marker statt der Länge des Hin- und Rückwegs die tatsächliche Entfernung der Störstelle anzeigen, geben Sie die Hälfte des tatsächlichen Ausbreitungsgeschwindigkeitsfaktors ein.

  6. Falls Sie die Messung in der Betriebsart "Low pass" durchführen, bestimmen Sie den Betrag und die Phase der interessierenden Impedanz-Änderung. Siehe Störstellenlokalisierung in der Betriebsart "Low Pass".


The Analyzer Object Model

See Also...

PNA Object Model

Click on an object box to view details.


Application Object

Description

The Application object is the highest object in the analyzer object model. This object presents methods and properties that affect the entire analyzer, rather than a specific channel or measurement. For example, the application object provides the GetIDString method. There's only one ID string for the instrument, unrelated to the channel or parameter being measured. Likewise, the TriggerSignal Property is global to the instrument. You can elect to use an internally generated (free run) trigger, or a manual trigger. Either way, that type of trigger generation will be used on all measurements, on all channels. Therefore, it is under the Application object.

This object is unique in that you must Create this object rather than just get a handle to it. See Getting a Handle to an Object.

Methods

Description

ActivateWindow

Makes a window object the Active Window.

AllowAllEvents

Monitors all events

AllowEventCategory

Monitors an event category

AllowEventMessage

Monitors an event

AllowEventSeverity

Monitors an event severity level

BuildHybridKit

Defines the user kit as port1kit + port2kit.

SetFailOnOverRange

Channel (object)

CreateMeasurement

Creates a new measurement.

CreateSParameter

Creates a new S-Parameter measurement.

DeleteShortCut

Removes a macro (shortcut) from the list of macros

DisallowAllEvents

Monitors NO events

DoPrint

Prints the screen to the active Printer.

ExecuteShortcut

Executes a macro (shortcut) stored in the analyzer.

GetShortcut

Returns the title and path of the specified macro (shortcut).

ManualTrigger

Triggers the analyzer when TriggerSignal = naTriggerManual.

Preset

Resets the analyzer to factory defined default settings.

PrintToFile

Saves the screen data to bitmap (.bmp) file of the screen.

PutShortcut

Puts a Macro (shortcut) file into the analyzer.

Quit

Ends the Network Analyzer application.

Recall

Restores all cal kits from disk.

RecallKits

Recalls the current state of the calibration kits on disk.

Reset

Removes all existing windows and measurements.

RestoreCalKitDefaults

Restores the factory defaults for the specified kit.

RestoreCalKitDefaultsAll

Restores the factory defaults for all kits.

Save

Saves all cal kits to disk.

SaveKits

Ends the Network Analyzer application.

SetFailOnOverRange

Causes over range values to return an error code

ShowStatusBar

Shows and Hides the Status Bar.

ShowStimulus

Shows and Hides Stimulus information.

ShowTitleBars

Shows and Hides the Title Bars.

ShowToolbar

Shows and Hides the specified Toolbar.

Properties

Description

ActiveCalKit

Returns a pointer to the kit identified by kitNumber.

ActiveChannel

Returns a handle to the Active Channel object.

ActiveMeasurement

Returns a handle to the Active Measurement object.

ActiveNAWindow

Returns a handle to the Active Window object.

ArrangeWindows

Sets or returns the arrangement of all the windows.

CalKitType

Sets the active cal kit.

Channels (collection)

ExternalALC

Sets or returns the source of the analyzer leveling control.

GPIBMode

Makes the analyzer the system controller or a talker/listener.

IDString

Returns the model, serial number and software revision of the analyzer

Measurements (collection)

MessageText

Returns a message for an eventID

NAWindows (collection)

Options

Returns the options on the analyzer

PortExtension (object)

ScpiStringParser (object)

SourcePowerState

Turns Source Power ON and OFF.

SystemImpedanceZ0

Sets the analyzer impedance value

TriggerSignal

Sets or returns the trigger source.

TriggerType

Sets or returns the scope of a trigger signal.

VelocityFactor

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

Visible

Makes the Network Analyzer application visible or not visible. (Default property of this object)

WindowState

Sets or returns the window setting of Maximized, Minimized, or Normal.

Events

Description

OnCalEvent

Triggered by a calibration event.

OnChannelEvent

Triggered by a channel event.

OnDisplayEvent

Triggered by a display event.

OnHardwareEvent

Triggered by a hardware event.

OnMeasurementEvent

Triggered by a measurement event.

OnSCPIEvent

Triggered by a SCPI event.

OnSystemEvent

Triggered by a system event.

OnUserEvent

For future use


Calibrator Object

Description

The Calibrator object is a child of the channel. It is a vehicle to perform calibration.

There must be a measurement present for the calibrator to use or you will receive an error (no measurement found). Therefore, to perform a 2-port cal, you must have any S-parameter measurement on the channel. For a 1-port measurement, you must have the measurement (S11 or S22) on the channel. And likewise for a response measurement.

With the calibrator object, you can take a number of approaches to calibration.You can collect data yourself and download it to the ACQUISITION buffer. The acquisition buffer holds the actual measured data for each standard.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Trigger a sweep

  4. Retrieve the data for the standard

  5. Download the data - calibrator.putStandard

  6. Repeat for each standard

  7. Calibrator.CalculateErrorCoefficients

You can tell the calibrator to acquire a standard. In this case, the calibrator collects the data and places it in the ACQUISITION buffer.

  1. Calibrator.SetCalInfo

  2. Connect a standard

  3. Calibrator.AcquireCalStandard

  4. Repeat for each standard

  5. Calibrator.CalcuateErrorCoefficients

You can put previously-retrieved error terms in the error correction buffer.

  1. PutErrorTerm

  2. Repeat for each term

  3. Measurement.caltype = pick one

You can also "piece together" a 2-port cal from two 1-port cals (S11 and S22) and four response (thru) cals. The system will detect that all the standards needed for a 2-port cal have been acquired even though they may not have gathered at the same time.

The ICalibrator methods can be used from VEE and VBScript as they use automation safe Variant Data. Use the ICalData interface for typed array passing.

Method

Description

AcquireCalStandard

Cause the analyzer to measure a calibration standard.

CalculateErrorCoeffecients

Generates Error Terms from standard and actual data in the error correction buffer.

DoECAL1Port

Completes a 1 port ECAL

DoECAL2Port

Completes a 2 port ECAL

GetECALModuleInfo

Returns information about the attached module

getErrorTerm

Retrieves error term data for the active calibration.

getStandard

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTerm

Puts error term data into the error-correction buffer for the active calibration.

putStandard

Puts data into the acquisition data buffer (before error-terms are applied)

setCalInfo

Specifies the type of calibration and prepares the internal state for the rest of the calibration.

Property

Description

AcquisitionDirection

Specifies the direction in a 2-Port cal

Simultaneous2PortAcquisition

Allows the use of 2 sets of standards at the same time.


CalKit Object

Description

The calkit object provides the properties and methods to access and modify a calibration kit. The calkitType property can be set from either the application object (app.calKitType) or the calKit object (calKit.calKitType). Both of these commands specify or read the calibration kit type. When specified, the cal kit also becomes the Active cal kit. However, to retrieve a pointer to the cal kit, use app.ActiveCalKit.

The calKit object behaves somewhat differently from other objects in the system in that you can only have a pointer to one cal kit (which is also the active calkit).

Therefore, when you change the calkitType (from either of these objects) you may also be changing the object to which you may have several references. This is different from the behavior for most other objects in the system.

For example, the following code specifies two calKitType and, in turn, assigns the "Active cal kit" to two different variables: ck1 and ck2.

Dim app As AgilentPNA835x.Application
Dim ck1 As calKit
Dim ck2 As calKit

Private Sub Form_Load()
Set app = CreateObject("AgilentPNA835x.Application", "analyzerName")
app.CalKitType = naCalKit_85032B_N50
Set ck1 = app.ActiveCalKit

app.CalKitType = naCalKit_85038A_7_16
Set ck2 = app.ActiveCalKit

Print "ck1: " & ck1.Name
Print "ck2: " & ck2.Name
End Sub

When the pointer to each of these kits is read (printed), they each have a pointer to the last kit to be assigned to the Active cal kit:

ck1: 7-16 Model 85038
ck2: 7-16 Model 85038

Method

Description

getCalStandard

Returns a handle to a calibration standard for modifying its definitions.

Property

Description

CalKitType

Sets and returns the cal kit type

Name

Sets and returns the name of the cal kit

PortLabel

Labels the ports for the kit; only affects the cal wizard annotation.

StandardForClass

Maps a standard device to a cal class.


CalStandard Object

Description

Contains all of the settings that are required to modify a calibration kit. Get a handle to a standard with the calkit.GetCalStandard Method.

Method

Description

None

Property

Description

C0

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

C1

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

C2

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

C3

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

Delay

Sets and Returns the electrical delay value for the calibration standard.

L0

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

L1

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

L2

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

L3

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

Label

Sets and Returns the label for the calibration standard.

loss

Sets and Returns the insertion loss for the calibration standard.

Maximum
Frequency

Sets and Returns the maximum frequency for the calibration standard.

Medium

Sets and Returns the media type of the calibration standard.

Minimum
Frequency

Sets and Returns the minumum frequency for the calibration standard.

Type

Sets and Returns the type of calibration standard.

Z0

Sets and Returns the characteristic impedance for the calibration standard.


Channel Object

Description

The channel object is like the engine that produces data. Channel settings consist of stimulus values like frequency, power, IF bandwidth, and number of points.

You can get a handle to a channel in a number of ways. But first you have to make sure that the channel exists. When you first startup the analyzer, there is one S11 measurement on channel 1. Thus there is only one channel in existence. You can do the following:

Dim chan as Channel
'
Set chan = pna.ActiveChannel

or

Set chan = pna.Channels( n )

The first method will return the channel object that is driving the active measurement. When you ask for the ActiveChannel, you get the channel that is driving the active measurement. If there is no measurement, there may not be a channel. Once a channel is created, it does not go away. So if there once was a measurement (hence a channel), the channel will still be available. If there is no channel you can create one in a couple ways. Here's one way:

Pna.CreateMeasurement( ch1, "S11", port1, window2)

Here's another:

Pna.Channels.Add (ch2)

The latter will have no visible effect on the analyzer. It will simply create channel 2 if it does not already exist.

Method

Description

Abort

Aborts the current measurement sweep on the channel.

AveragingRestart

Clears and restarts averaging of the measurement data.

Continuous

The channel continuously responds to trigger signals.

GetXAxisValues

Returns the channel's X-axis values into a dimensioned Variant array.

GetXAxisValues2

Returns the channel's X-axis values into a dimensioned NON-Variant array.

Hold

Puts the Channel in Hold - not sweeping.

Next_IFBandwidth

A function that returns the Next higher IF Bandwidth value.

NumberOfGroups

Sets the Number of trigger signals the channel will receive.

Preset

Resets the channel to factory defined settings.

PreviousIFBandwidth

Returns the previous IF Bandwidth value.

Single

Channel responds to one trigger signal from any source (internal, external, or manual). Then channel switches to Hold.

Property

Description

AlternateSweep

Sets sweeps to either alternate or chopped.

Attenuator

Sets or returns the value of the attenuator control for the specified port number.

AttenuatorMode

Sets or returns the mode of operation of the attenuator control for the specified port number.

Averaging

Turns trace averaging ON or OFF for all measurements on the channel.

AveragingFactor

Specifies the number of measurement sweeps to combine for an average.

Calibrator (object)

centerFrequency

Sets or returns the center frequency of the channel.

channelNumber

Returns the Channel number of the Channel or Measurement object.

CouplePorts

Turns ON and OFF port power coupling.

CWFrequency

Set the Continuous Wave (CW) frequency.

DwellTime

Sets or returns the dwell time for the channel.

FrequencySpan

Sets or returns the frequency span of the channel.

IFBandwidth

Sets or returns the IF Bandwidth of the channel.

NumberOfPoints

Sets or returns the Number of Points of the channel.

Parent

Returns a handle to the parent object of the channel.

PowerSlope

Sets or returns the Power Slope value.

ReceiverAttenuator

Sets or returns the value of the specified receiver attenuator control.

Segments (collection)

StartFrequency

Sets or returns the start frequency of the channel.

StartPower

Sets the start power of the analyzer when sweep type is set to Power Sweep.

StopFrequency

Sets or returns the stop frequency of the channel.

StopPower

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep.

SweepGenerationMode

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

SweepTime

Sets the Sweep time of the analyzer.

SweepType

Sets the type of X-axis sweep that is performed on a channel.

TestPortPower

Sets or returns the RF power level for the channel.

TriggerMode

Determines the measurement that occurs when a trigger signal is sent to the channel.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.


Channels Collection

Description

A collection object that provides a mechanism for iterating through the channels

Collections are, by definition, unordered lists of like objects. You cannot assume that Channels.Item(1) is always Channel 1. For more information, see Collections in the Analyzer.

Methods

Description

Add

An alternate way to create a measurement.

Item

Use to get a handle on a channel in the collection.

Properties

Description

Count

Returns the number of channels in the analyzer.

Parent

Returns a handle to the current Application.


Gating Object

Description

Contains the methods and properties that control Time Domain Gating

Methods

Description

None

Property

Description

Center

Sets or returns the Center time.

Shape

Specifies the shape of the gate filter.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

Stop

Sets or returns the Stop time.

Type

Specifies the type of gate filter used.


About Accessing Data

IArrayTransfer Object

Description

Contains methods for putting data in and getting data out of the analyzer using typed data. This interface transfers data more efficiently than the default IMeasurement Interface.

Method

Description

getComplex

Retrieves real and imaginary data from the specified buffer.

getNAComplex

Retrieves typed NAComplex data from the specified buffer.

getPairedData

Retrieves magnitude and phase data pairs from the specified buffer.

getScalar

Retrieves scalar data from the specified buffer.

putComplex

Puts real and imaginary data into the specified buffer.

putNAComplex

Puts typed NAComplex data into the specified buffer.

putScalar

Puts scalar data into the measurement result buffer.

Property

Description

None


About Accessing Data

ICalData Object

Description

Contains methods for putting Calibration data in and getting Calibration data out of the analyzer using typed data. This interface transfers data more efficiently than variant data.

Method

Description

getErrorTermComplex

Retrieves error term data

getStandardComplex

Retrieves calibration data from the aquisition data buffer (before error-terms are applied).

putErrorTermComplex

Puts error term data

putStandardComplex

Puts calibration data into the aquisition data buffer (before error-terms are applied).

Property

Description

None


Limit Test Collection

Description

Child of the Measurement Object. A collection that provides a mechanism for iterating through the Measurement's LimitSegment objects (Limit Lines). The collection has 100 limit lines by default.

The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2 = Application.Measurement.LimitTest(4)

Methods

Description

GetTestResult

Retrieves the Pass/Fail results of the Limit Test (State).

Item

Use to get a handle on a limit line in the collection.

Properties

Description

Count

Returns the number of limit lines used in the measurement.

LineDisplay

Displays the limit lines on the screen.

SoundOnFail

Enables a beep on Limit Test fails.

State

Turns ON and OFF limit testing.


LimitSegment Object

Description

The LimitSegment object is an individual limit line. The only way to get a handle to an individual limit line is by using the LimitTest collection. You can either 1) set the property directly, or 2) set a variable a limit line in the LimitTest collection.

Examples

1)LimitTest(4).BeginResponse=.5
2)Set lim2=Application.Measurement.LimitTest(4)

Methods

Description

None

Properties

Description

BeginResponse

Specifies the Y-axis value that corresponds with Begin Stimulus (X-axis) value.

BeginStimulus

Specifies the beginning X-axis value of the Limit Line.

EndResponse

Specifies the Y-axis value that corresponds with End Stimulus (X-axis) value.

EndStimulus

Specifies the End X-axis value of the Limit Line.

Type

Specifies the Limit Line type.


Marker Object

Description

Contains the methods and properties that control Markers.

To turn ON a marker, you get a handle to the marker. You get a handle to a marker through the measurement object. (There is no markers collection).

If it is not already, this command will activate marker 1.

Measurement.marker(1).Format = naLinMag

You can also set the marker object to an object variable:

Dim m1 As Marker
Set m1 = meas.marker(1)

There are 10 markers available per measurement:

  • 1 reference marker

  • 9 markers for absolute data or data relative to the reference marker (delta markers).

There are two ways to control markers through COM.

  1. The Measurement object has properties that apply to all of the markers for that measurement.

  2. Marker object properties override the Measurement object properties. For example, meas.MarkerFormat = naLinMag applies formatting to all markers. You can then override that setting for an individual marker by specifying mark.Format = naLogMag on the marker object.

Methods

Description

Activate

Makes an object the Active Object.

SearchMax

Searches the marker domain for the maximum value.

SearchMin

Searches the marker domain for the minimum value.

SearchNextPeak

Searches the marker's domain for the next largest peak value.

SearchPeakLeft

Searches the marker's domain for the next VALID peak to the left of the marker.

SearchPeakRight

Searches the marker's domain for the next VALID peak to the right of the marker.

SearchTarget

Searches the marker's domain for the target value.

SearchTargetLeft

Moving to the left of the marker position, searches the marker's domain for the target value.

SearchTargetRight

Moving to the right of the marker position, searches the marker's domain for the target value.

SetCenter

Changes the analyzer's center frequency to the X-axis position of the marker.

SetCW

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

SetElectricalDelay

Changes the measurement's electrical delay to the marker's delay value.

SetReferenceLevel

Changes the measurement's reference level to the marker's Y-axis value.

SetStart

Changes the analyzer's start frequency to the X-axis position of the marker.

SetStop

Changes the analyzer's stop frequency to the X-axis position of the marker.

Property

Description

Bucket Number

Marker data point number

DeltaMarker

Makes a marker relative to the reference marker

Format

Linear, SWR, and so forth

Interpolated

Turn marker interpolation ON and OFF

Number

Read the number of the active marker

PeakExcursion

Sets and reads the peak excursion value for the specified marker.

PeakThreshold

Sets peak threshold for the specified marker.

SearchFunction

Emulates the Tracking function in the marker search dialog box.

Stimulus

Sets and reads the X-Axis value of the marker.

Target Value

Sets the target value for the marker when doing Target Searches.

Tracking

The tracking function finds the selected search function every sweep.

Type

Sets and reads the marker type.

UserRange

Assigns the marker to the specified User Range.

UserRangeMax

Sets the stimulus stop value for the specified User Range.

UserRangeMin

Sets the stimulus start value for the specified User Range.

Value

Reads the Y-Axis value of the marker.


Measurement Object

Description

The Measurement object is probably the most used object in the model. A measurement object represents the chain of data processing algorithms that take raw data from the channel and make it ready for display, which then becomes the scope of the Trace object.

A Measurement object is defined by it's parameter (S11, S22, A/R1, B and so forth). The measurement object is associated with a channel in that a channel drives the hardware that produces the data that feeds the measurement. The root of a measurement is the raw data. This buffer of complex paired data then flows through a number of processing blocks: error-correction, trace math, phase correction, time domain, gating, formatting. All of these are controlled through the measurement object.

The active measurement determines what ever else is active. The active measurement is best described as the measurement that will be acted upon if you make a setting from the front panel. It is the measurement whose "button" is pressed in the window with the red "active window" frame. If you create a new measurement, that measurement becomes the active measurement.

Therefore, all automation methods with the word "Active" in them refer to the object associated with the Active measurement, whether that object is a Channel, Window, Trace or Limit line.

You can access two other objects through the Measurement object: markers and limit test. For example, because each measurement has its own set of markers, you can set a marker by doing this:

Dim meas as measurement
Set meas = pna.ActiveMeasurement
Meas.marker(1).Stimulus = 900e6
Meas.LimitTest.State = true ' on

Methods

Description

Activate

Makes an object the Active Object.

ActivateMarker

Makes a marker the Active Marker.

ChangeParameter

Changes the parameter of the measurement.

DataToMemory

Stores the active measurement into memory.

Delete

Deletes the measurement object.

DeleteAllMarkers

Deletes all of the markers from the measurement.

DeleteMarker

Deletes a marker from the active measurement.

GetData

Retrieves Complex data from analyzer memory

GetFilterStatistics

Returns all four Filter Statistics

GetReferenceMarker

Returns a handle to the reference marker.

GetTraceStatistics

Returns the Trace Statistics.

InterpolateMarkers

Turns All Marker Interpolation ON and OFF for the measurement.

putDataComplex

Puts complex data into one of five data buffers.

putDataScalar

Puts formatted variant data into the measurement results buffer.

SearchFilterBandwidth

Searches the domain with the current BW target.

Properties

Description

ActiveMarker

Returns a handle to the Active Marker object.

BandwidthTarget

The insertion loss value at which the bandwidth of a filter is measured.

BandwidthTracking

Turns Bandwidth Tracking function ON and OFF.

CalibrationType

Set or get the calibration type for the measurement.

channelNumber

Returns the channel number of a measurement.

ElectricalDelay

Sets electrical delay.

ErrorCorrection

Set or get the state of error correction for the measurement.

FilterBW

Returns the results of the SearchBandwidth method.

FilterCF

Returns the Center Frequency result of the SearchBandwidth method.

FilterLoss

Returns the Loss value of the SearchBandwidth method.

FilterQ

Returns the Q (quality factor) result of the SearchBandwidth method.

Format

Sets display format.

Gating (object)

InterpolateCorrection

Turns ON and OFF the calculation of new error terms when stimulus values change.

LimitTest (collection)

LimitTestFailed

Returns the results of limit testing

marker (object)

MarkerFormat

Sets or returns the format of all the markers in the measurement.

Mean

Returns the mean value of the measurement.

Name

Sets or returns the name of the measurement.

NAWindow (object)

Number

Returns the number of the measurement.

Parameter

Returns the measurement Parameter.

PeakToPeak

Returns the Peak to Peak value of the measurement.

PhaseOffset

Sets the Phase Offset for the active channel.

ReferenceMarkerState

Turns the reference marker ON or OFF

ShowStatistics

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

Smoothing

Turns ON and OFF data smoothing.

SmoothingAperture

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

StandardDeviation

Returns the standard deviation of the measurement.

StatisticsRange

Sets the User Range number for calculating measurement statistics.

Trace (object)

TraceMath

Performs math operations on the measurement object and the trace stored in memory.

Transform (object)

View

Sets (or returns) the type of trace displayed on the screen.


Measurements Collection

Description

A collection object that provides a mechanism for iterating through the Application measurements. See Collections in the Analyzer.

Methods

Description

Add

Adds a Measurement to the collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a measurement from the measurements collection.

Properties

Description

Count

Returns the number of measurements in the analyzer.

Parent

Returns a handle to the current Application.


NAWindow Object

Description

The NAWindow object controls the part of the display the contains the graticule, or what is written on the display.

Methods

Description

Autoscale

Autoscales all measurements in the window.

ShowMarkerReadout

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window object.

ShowTable

Shows or Hides the specified table for the active measurement in the lower part of the window object.

Property

Description

ActiveTrace

Sets a trace to the Active Trace.

Title

Writes or reads a custom title for the window.

TitleState

Turns ON and OFF the window title.

Traces (collection)

WindowState

Maximizes or minimizes a window.


NAWindows Collection

Description

A collection object that provides a mechanism for iterating through the Application windows. See Collections in the Analyzer.

Methods

Description

Add

Adds a window to the NAWindows collection.

Item

Use to get a handle to a channel in the collection.

Remove

Removes a window from the NAWindows collection.

Properties

Description

Count

Returns the number of windows on the analyzer.

Parent

Returns a handle to the current Application.


Port Extension Object

Port Extensions Object

Description

Contains the methods and properties that control Port Extensions.

Methods

Description

None

Property

Description

Input A

Sets the Input A extension value.

Input B

Sets the Input B extension value.

Port 1

Sets the Port 1 extension value.

Port 2

Sets the Port 2 extension value.

State

Turns Port Extensions ON and OFF.


SCPIStringParser Object

Method

Description

Parse

Provides the ability to send a SCPI command from within the COM command.

Properties

Description

None


Segment Object

Description

Contains the methods and properties that affect a sweep segment.

You can get a handle to a sweep segment through the segments collection.[ segments.item(n).]

Methods

Description

None

Property

Description

centerFrequency

Sets or returns the center frequency of the segment.

DwellTime

Dwell time value.

FrequencySpan

Sets or returns the frequency span of the segment.

IFBandwidth

Sets or returns the IF Bandwidth of the segment.

NumberOfPoints

Sets or returns the Number of Points of the segment.

SegmentNumber

Returns the number of the current segment.

StartFrequency

Sets or returns the start frequency of the segment.

State

Turns On or OFF a segment.

StopFrequency

Sets or returns the stop frequency of the segment.

TestPortPower

Sets or returns the RF power level of the segment.


Segments Collection

Description

A collection object that provides a mechanism for iterating through the sweep segments of a channel.

Sweep segments are a potentially faster method of sweeping the analyzer through only the frequencies of interest. See Collections in the Analyzer

Methods

Description

Add

Adds an item to either the Segments collection.

Item

Use to get a handle to a segment in the collection..

Remove

Removes an item from a collection of objects.

Properties

Description

Count

Returns the number of items in a collection of objects.

IF Bandwidth Option

Enables the IFBandwidth to be set on individual sweep segments.

Parent

Returns a handle to the current naNetworkAnalyzer application..

Source Power Option

Enables setting the Source Power for a segment.


Trace Object

Description

The Trace object takes measurement data and control how the data is painted on the display. You can control scale, reference position, and reference line from the Trace Object.

Methods

Description

Autoscale

Autoscales the trace or all of the traces in the selected window.

Property

Description

Name

Sets or returns the trace name

ReferencePosition

Sets or returns the Reference Position of the active trace.

ReferenceValue

Sets or returns the value of the Y-axis Reference Level of the active trace.

YScale

Sets or returns the Y-axis Per-Division value of the active trace.


Traces Collection

Description

Child of the Application Object. A collection that provides a mechanism for getting a handle to a trace or iterating through the traces in a window.

Methods

Description

Item

Use to get a handle to a trace

Properties

Description

Count

Returns the number of traces in the collection.

Parent

Returns a handle to the current Application.


Transform Object

Description

Contains the methods and properties that control Time Domain transforms.

Methods

Description

SetFrequencyLowPass

Sets low frequencies for low pass.

Property

Description

Center

Sets or returns the Center time.

ImpulseWidth

Sets or returns the Impulse Width of Time Domain transform windows.

KaiserBeta

Sets or returns the Kaiser Beta of Time Domain transform windows.

Mode

Sets the type of transform.

Span

Sets or returns the Span time.

Start

Sets or returns the Start time.

State

Turns an Object ON and OFF.

StepRiseTime

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

Stop

Sets or returns the Stop time.


About Performing a Calibration

AcquisitionDirection Property

Read / Write

Description

Specifies the direction of each part of a 2-port calibration.

VB Syntax

cal.AcquisitionDirection = value

Variable

(Type) - Description

cal

A Calibrator (object)

value

(enum NADirection) - Choose from:

0 - naForward - measures the forward direction
1 - naReverse - measures the reverse direction

Return Type

Long Integer

Default

naForward

Examples

cal.AcquisitionDirection = naForward

C++ Syntax

HRESULT AcquisitionDirection(tagNADirection dir)

Interface

ICalibrator


Active Cal Kit Property

About Calibration Kits

ActiveCalKit Property

Read-only

Description

Returns a handle to the Active CalKit object. You can either (1) use the handle directly to access CalKit properties and methods, or (2) set a variable to the CalKit object. The variable retains a handle to the original object if another CalKit becomes active.

VB Syntax

1) app.ActiveCalKit.<setting>
or
2) Set cKit = app.ActiveCalKit

Variable

(Type) - Description

app

(object) - An Application object

<setting>

A CalKit property (or method) and arguments

cKit

(object) - A CalKit object

Return Type

CalKit object

Default

None

Examples

Public cKit as calKit
Set cKit = app.ActiveCalKit 'read

C++ Syntax

HRESULT get_ActiveCalKit (ICalkit * kit)

Interface

IApplication


Active Channel Property

About Channels

ActiveChannel Property

Read-only

Description

Returns a handle to the Active Channel object. You can either (1) use the handle directly to access channel properties and methods, or (2) set a variable to the channel object. The variable retains a handle to the original channel if another channel becomes active.

VB Syntax

(1) app.ActiveChannel.<setting>
or
(2) Set chan = app.ActiveChannel

Variable

(Type) - Description

chan

A Channel (object)

app

An Application (object)

<setting>

A channel property (or method) and arguments

Return Type

Channel object

Default

Not applicable

Examples

1) app.ActiveChannel.Averaging = 1
2) Public chan as Channel
Set chan = app.ActiveChannel

C++ Syntax

HRESULT get_ActiveChannel( IChannel* *pVal)

Interface

IApplication


About Markers

ActiveMarker Property

Read-only

Description

Returns a handle to the Active Marker object. You can either (1) use the handle directly to access Marker properties and methods, or (2) set a variable to the Marker object. The variable retains a handle to the original object if another Marker becomes active.

VB Syntax

1) meas.ActiveMarker.<setting>
or
2) Set mark = meas.ActiveMarker

Variable

(Type) - Description

meas

(object) - An Measurement object

<setting>

A marker property (or method) and arguments

mark

(object) - A marker object

Return Type

marker object

Default

None

Examples

Public mark as marker
Set mark = meas.ActiveMarker

C++ Syntax

HRESULT get_ActiveMarker(IMarker** marker)

Interface

IMeasurement


Active Measurement Property

About Measurement Parameters

ActiveMeasurement Property

Read-only

Description

Returns a handle to the Active Measurement object. You can either (1) use the handle directly to access measurement properties and methods, or (2) set a variable to the measurement object. The variable retains a handle to the original measurement.

VB Syntax

1) app.Active Measurement.<setting>
or
2) Set meas = app.Active Measurement

Variable

(Type) - Description

meas

A Measurement (object)

app

An Application (object)

<setting>

A measurement property (or method) and arguments

Return Type

Measurement object

Default

None

Examples

1) app.ActiveMeasurement.Averaging = 1
2) Public meas as Measurement
Set meas = app.ActiveMeasurement

C++ Syntax

HRESULT get_ActiveMeasurement(IMeasurement **ppMeas)

Interface

IApplication


About Windows

ActiveNAWindow Property

Read-only

Description

Returns a handle to the Active Window object. You can either (1) use the handle directly to access window properties and methods, or (2) set a variable to the window object. The variable retains a handle to the original window if another window becomes active.

VB Syntax

1) app.ActiveNAWindow.<setting>
or
2) Set win = app.ActiveNAWindow

Variable

(Type) - Description

win

A NAWindow (object)

app

An Application (object)

<setting>

A NAWindow property (or method) and arguments

Return Type

A NAWindow object

Default

Not applicable

Examples

Public win as NAWindow
Set win = app.ActiveWindow

C++ Syntax

HRESULT get_ActiveNAWindow(INAWindow **ppWindow)

Interface

IApplication


Active Trace Property

About Traces

ActiveTrace Property

Read-only

Description

Returns a handle to the Active Trace object. You can either (1) use the handle directly to access trace properties and methods, or (2) set a variable to the trace object. The variable retains a handle to the original trace if another trace becomes active.

VB Syntax

1) win.ActiveTrace.<setting>
or
2) Set trce = win.ActiveTrace

Variable

(Type) - Description

trce

A Trace (object)

win

An NAWindow (object)

<setting>

A trace property (or method) and arguments

Return Type

An NAWindow object

Default

None

Examples

1) win.ActiveTrace.Autoscale
2) Public trce as Trace
Set trce = Application.ActiveNAWindow.ActiveTrace

C++ Syntax

HRESULT get_ActiveTrace(ITrace* *pVal)

Interface

INAWindow


Alternate Sweep Property

About Sweeping

AlternateSweep Property

Write/Read

Description

Sets sweeps to either alternate or chopped.

VB Syntax

chan.AlternateSweep = value

Variable

(Type) - Description

chan

A Channel (object)

value

(boolean) - Choose either:

False (0) - Sweep mode set to Chopped - reflection and transmission are measured on the same sweep.
True (1) - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases cycle time.

Return Type

boolean

Default

False (0)

Examples

chan.AlternateSweep = True 'Write

altSwp = chan.AlternateSweep 'Read

C++ Syntax

HRESULT AlternateSweep(VARIANT_BOOL *pVal)
HRESULT AlternateSweep(VARIANT_BOOL newVal)

Interface

IChannel


Application Property

Read-only

Description

Returns the name of the Analyzer making measurements on the channel.

VB Syntax

chan.Application

Variable

(Type) - Description

chan

A Channel (object)

Return Type

object

Default

None

Examples

rfna = chan.Application 'returns the Analyzer name

C++ Syntax

HRESULT get_Application(IApplication** Application)

Interface

IChannel


Arrange Windows Property

About Arrange Windows

ArrangeWindows Property

Write/Read

Description

Sets or returns the arrangement of all the windows. Overlay, Stack2, Split3 and Quad4 will create windows.

To control the state of the one window you have a handle to, use app.WindowState.

VB Syntax

app.ArrangeWindows = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAWindowModes) - Choose from:

0 - naTile
1 - naCascade
2 - naOverlay
3 - naStack2
4 - naSplit3
5 - naQuad4

Return Type

NAWindowModes

Default

naTile

Examples

app.ArrangeWindow = naTile 'Write

arrWin = app.ArrangeWindows 'Read

C++ Syntax

HRESULT put_ArrangeWindows(tagNAWindowModes newVal)

Interface

IApplication


Attenuator Mode Property

About Attenuation

AttenuatorMode Property

Write/Read

Description

Sets or returns the mode of operation of the attenuator control for the specified port number. This command is automatically set to Manual when an Attenuator value is set.

VB Syntax

chan.AttenuatorMode(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long) - Port number (1 or 2) of attenuator control to be changed.

value

(enum NAModes) - Choose from:

0 - naAuto - Attenuator control set to automatic. The analyzer will set the attenuator control appropriately to deliver the specified power at the source.

1 - naManual - Specify the attenuator setting using chan.Attenuator (which automatically sets AttenuatorMode = naManual.

Return Type

NAModes

Default

0 - Auto

Examples

chan.Attenuator(1) = naAuto 'Write

attn = chan.AttenuatorMode(1) 'Read

C++ Syntax

HRESULT get_AttenuatorMode(long port, tagNAModes* pVal)
HRESULT put_AttenuatorMode(long port, tagNAModes newVal)

Interface

IChannel


About Attenuation

Attenuator Property

Write/Read

Description

Sets or returns the value of the attenuator control for the specified port number. Sending this command automatically sets AttenuatorMode to Manual.

VB Syntax

chan.Attenuator(portNum) = value

Variable

(Type) - Description

chan

A Channel (object)

portNum

(long integer) - Port number (1 or 2) of attenuator control to be changed.

value

(double) - Attenuator value in dB in 10dB steps. Choose any Long Integer between 0 and 70

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 10 dB attenuation.

Return Type

Double

Default

20 dB

Examples

chan.Attenuator(1) = 20 'Write

attn = chan.Attenuator(cnum) 'Read

C++ Syntax

HRESULT get_Attenuator(long port, double *pVal)
HRESULT put_Attenuator(long port, double newVal)

Interface

IChannel


Averaging Factor Property

About Averaging

AveragingFactor Property

Write/Read

Description

Specifies the number of measurement sweeps to combine for an average. Must also turn averaging ON by setting chan.Averaging = 1. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.AveragingFactor = value

Variable

(Type) - Description

chan

A Channel (object)

value

(Long Integer) - Number of measurement sweeps to average. Choose any number between 1 and 1024.

Return Type

Long Integer

Default

1

Examples

chan.AveragingFactor = 5 'Write

avgfact = chan.AveragingFactor ' doesn't work -Read

C++ Syntax

HRESULT get_AveragingFactor(long *pVal)
HRESULT put_AveragingFactor(long newVal)

Interface

IChannel


About Averaging

Averaging Property

Write/Read

Description

Turns trace averaging ON or OFF for all measurements on the channel. Averaging is only allowed on ratioed measurements; not on single input measurements.

VB Syntax

chan.Averaging = state

Variable

(Type) - Description

chan

A Channel (object)

state

(boolean)
0 - Turns averaging OFF
1 - Turns averaging ON

Return Type

Boolean

Default

0

Examples

chan.Average = 1 'Write

averg = chan.Averaging 'Read

C++ Syntax

HRESULT get_Averaging(BOOL *pVal)
HRESULT put_Averaging(BOOL newVal)

Interface

IChannel


Bandwidth Target Property

About Marker Search

BandwidthTarget Property

Write/Read

Description

Sets the insertion loss value at which the bandwidth of a filter is measured (using BandwidthTracking or SearchFilterBandwidth). For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set BandwidthTarget to -3.

VB Syntax

meas.BandwidthTarget = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(single) - Target value. Choose any number between -500 and 500

Return Type

Single

Default

-3

Examples

meas.BandwidthTarget = -3 'Write

fbw = meas.BandwidthTarget 'Read

C++ Syntax

HRESULT put_BandwidthTarget(float target)
HRESULT get_BandwidthTarget(float* target)

Interface

IMeasurement


Bandwidth Tracking Property

About Marker Search

BandwidthTracking Property

Write/Read

Description

Searches continually (every sweep) for the current BandwidthTarget (default is -3). To search the filter bandwidth for ONE SWEEP only (not continually), use meas.SearchFilterBandwidth.

This feature uses markers 1-4. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To restrict the search to a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.BandwidthTracking = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
1 - Turns bandwidth tracking ON
0 - Turns bandwidth tracking OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.BandwidthTracking = 1 'Write

bwtrack = meas.BandwidthTracking 'Read

C++ Syntax

HRESULT put_BandwidthTracking(VARIANT_BOOL state)
HRESULT get_BandwidthTracking(VARIANT_BOOL* state)

Interface

IMeasurement


Calibration Type (applied) Property

About Performing a Calibration

CalibrationType Property

Write/Read

Description

Specifies the type of calibration to perform or apply to the measurement.

VB Syntax

meas.CalibrationType = type

Variable

(Type) - Description

meas

A Measurement (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Return Type

NACalType

Default

naCalType_None

Examples

meas.CalibrationType = naCalType_Response_Open 'Write

meascal = meas.CalibrationType 'Read

C++ Syntax

HRESULT put_CalibrationType (tagNACalType CalType)
HRESULT get_CalibrationType (tagNACalType* pCalType)

Interface

IMeasurement


About Gating

Center Property

Write/Read

Description

Sets or returns the Center time of either Gating or Time Domain transform windows

VB Syntax

object.Center = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Center time in seconds. Choose any number between:
± (points-1) / frequency span

Return Type

Double

Default

0

Examples

trans.Center = 4.5e-9 'sets the Center time of a transform window -Write
gate.Center = 4.5e-9 'sets the Center time of a gating window -Write

cnt = trans.Center 'Read

C++ Syntax

HRESULT get_Center(double *pVal)
HRESULT put_Center(double newVal)

Interface

ITransform
IGating


CenterFreq Property

About Frequency

CenterFrequency Property

Write/Read

Description

Sets or returns the center frequency of the channel
or
Sets or returns the center frequency of the segment.

VB Syntax

object.centerFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Center frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Center of the frequency range

Examples

chan.centerFrequency = 4.5e9 'sets the center frequency of a linear sweep for the channel object -Write

centfreq = chan.centerFrequency 'Read

C++ Syntax

HRESULT get_CenterFrequency(double *pVal)
HRESULT put_CenterFrequency(double newVal)

Interface

IChannel
ISegment


Channel Number Property

About Channels

ChannelNumber Property

Read-only

Description

Returns the Channel number of the Channel or Measurement object.

VB Syntax

object.ChannelNumber

Variable

(Type) - Description

object

A Channel (object)
or
A Measurement (object)

Return Type

Long Integer

Default

Not applicable

Examples

chanNum = chan.ChannelNumber 'returns the channel number
chanNum = meas.ChannelNumber 'returns the channel number of the measurement

C++ Syntax

HRESULT get_ChannelNumber(long *pVal)

Interface

IChannel
IMeasurement


About Modifying Cal Kits

C0 Property

Write/Read

Description

Sets and Returns the C0 (C-zero) value (the first capacitance value) for the calibration standard.

To set the other inductance values, use C1, C2, C3

VB Syntax

calstd.C0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C0 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C0 = 15 'Write the value of C0 to 15picofarads

cap0 = calstd.C0 'Read the value of C0

C++ Syntax

HRESULT get_C0(float *pVal)
HRESULT put_C0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C1 Property

Write/Read

Description

Sets and Returns the C1 value (the second capacitance value) for the calibration standard.

To set the other inductance values, use C0, C2, C3

VB Syntax

calstd.C1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C1 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C1 = 15 'Write the value of C1 to 15picofarads

cap1 = calstd.C1 'Read the value of C1

C++ Syntax

HRESULT get_C1(float *pVal)
HRESULT put_C1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C2 Property

Write/Read

Description

Sets and Returns the C2 value (the third capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C3

VB Syntax

calstd.C2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C2 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C2 = 15 'Write the value of C2 to 15picofarads

cap2 = calstd.C2 'Read the value of C2

C++ Syntax

HRESULT get_C2(float *pVal)
HRESULT put_C2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

C3 Property

Write/Read

Description

Sets and Returns the C3 value (the fourth capacitance value) for the calibration standard.

To set the other inductance values, use C0, C1, C2

VB Syntax

calstd.C3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for C3 in picofarads

Return Type

Single

Default

Not Applicable

Examples

calstd.C3 = 15 'Write the value of C3 to 15picofarads

cap3 = calstd.C3 'Read the value of C3

C++ Syntax

HRESULT get_C3(float *pVal)
HRESULT put_C3(float newVal)

Interface

ICalStandard


Count Property

Read-only

Description

Returns the number of items in a collection of objects.

VB Syntax

object.Count

Variable

(Type) - Description

object

Any of the following (objects):

Channels collection
LimitTest collection
Measurements collection
NAWindows collection
Traces collection
Segments collection

Return Type

Long Integer

Default

Not applicable

Examples

numofchans = chans.Count 'return the number of channels -Read

C++ Syntax

HRESULT get_Count(long *p<interface>)

Interface

IChannels
ILimitTest
IMeasurements
NAWindows
ITraces
ISegments


Couple Ports Property

About Power Coupling

CouplePorts Property

Write/Read

Description

Turns ON and OFF port power coupling. ON means the power level is the same for both ports. OFF means the power level may be set independently for each port.

VB Syntax

chan.CouplePorts = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NAStates) Choose from:
NaOff - Turns coupling OFF
NaOn - Turns coupling ON

Return Type

Long Integer
1 - ON
0 - OFF

Default

NaON (1)

Examples

chan.CouplePorts = NaOff 'Write

couplport = chan.CouplePorts 'Read

C++ Syntax

HRESULT get_CouplePorts(tagNAStates *pState)
HRESULT put_CouplePorts(tagNAStates newState)

Interface

IChannel


About CW Frequency

CW Frequency Property

Write/Read

Description

Set the Continuous Wave (CW) frequency. Must first send chan.SweepType = naCWTimeSweep

VB Syntax

chan.CWFrequency = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) CW frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer
Units are Hz

Return Type

Double

Default

1e9

Examples

chan.CWFrequency = 5e9 'Write

cwfreq = chan.CWFrequency 'Read

C++ Syntax

HRESULT put_CWFrequency(double newVal)
HRESULT get_CWFrequency(double *pVal)

Interface

IChannel


About Modifying Cal Kits

Delay Property

Write/Read

Description

Sets and Returns the electrical delay value for the calibration standard.

VB Syntax

calstd.Delay = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Electrical delay in seconds

Return Type

Single

Default

Not Applicable

Examples

calstd.Delay = .00015 'Write the Delay .00015 seconds

stdDelay = calstd.Delay 'Read the value of Delay

C++ Syntax

HRESULT get_Delay(float *pVal)
HRESULT put_Delay(float newVal)

Interface

ICalStandard


About Data Format

Format Property

Write/Read

Description

Sets or returns the display format of the measurement.

VB Syntax

meas.Format = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NADataFormat) - Choose from:

0 - naDataFormat_LinMag
1 - naDataFormat_LogMag
2 - naDataFormat_Phase
3 - naDataFormat_Polar
4 - naDataFormat_Smith
5 - naDataFormat_Delay
6 - naDataFormat_Double
7 - naDataFormat_Imaginary
8 - naDataFormat_SWR

Return Type

Long Integer

Default

1 - naDataFormat_LogMag

Examples

app.TriggerMode = naTriggerModePoint 'Write

fmt = meas.Format 'Read

C++ Syntax

HRESULT get_Format(tagDataFormat *pVal)
HRESULT put_Format(tagDataFormat newVal)

Interface

IMeasurement


Dwell Time Property

About Dwell Time

DwellTime Property

Write/Read

Description

Sets or returns the dwell time at the start of each sweep point for all measurements in a channel. Dwell time is only available with Chan.SweepGenerationMode = naSteppedSweep (not naAnalogSweep).

Sets or returns the dwell time of a specified sweep segment.

VB Syntax

object.DwellTime = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - Dwell Time in seconds. Choose any number between:
0 and 100e-3

Return Type

Double

Default

0

Examples

chan.DwellTime = 3e-3 'sets the dwell time for the channel -Write

segs(3).CenterFrequency = 1e9 'sets the dwell time of segment 3 -Write

dwell = chan.DwellTime 'Read

C++ Syntax

HRESULT get_DwellTime(double *pVal)
HRESULT put_DwellTime(double newVal)

Interface

IChannel
ISegment


Electrical Delay Property

About Electrical Delay

ElectricalDelay Property

Write/Read

Description

Sets the Electrical Delay for the active channel.

VB Syntax

meas.ElectricalDelay = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Electrical Delay in seconds. Choose any number between -9.99 and 9.99

Return Type

Double

Default

0

Examples

meas.ElectricalDelay = 1e-3 'Write

edelay = meas.ElectricalDelay 'Read

C++ Syntax

HRESULT get_ElectricalDelay(double *pVal)
HRESULT put_ElectricalDelay(double newVal)

Interface

IMeasurement


Error Correction Property

About Performing a Calibration

ErrorCorrection Property

Write/Read

Description

Sets (or returns) error correction ON or OFF for the measurement.

VB Syntax

meas.ErrorCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
0 - Turns error correction OFF
1 - Turns error correction ON

Return Type

Boolean

Default

Not Applicable

Examples

meas.ErrorCorrection = 1 'Write

errcorr = meas.ErrorCorrection 'Read

C++ Syntax

HRESULT put_ErrorCorrection (VARIANT_BOOL bState)
HRESULT get_ErrorCorrection (VARIANT_BOOL *bState)

Interface

IMeasurement


External ALC Property

ExternalALC Property

Write/Read

Description

Sets or returns the source of the analyzer leveling control.

VB Syntax

app.ExternalALC = value

Variable

(Type) - Description

app

An Application (object)

value

(boolean) - Choose from:
True (or 1) - Leveling control supplied through the rear panel.
False (or 0) - Leveling control supplied inside the analyzer

Return Type

Boolean

Default

0

Examples

app.ExternalALC = True 'Write

extALC = app.ExternalALC 'Read

C++ Syntax

HRESULT get_ExternalALC(VARIANT_BOOL *pVal)
HRESULT put_ExternalALC(VARIANT_BOOL newVal)

Interface

IApplication


Filter BW Property

About Marker Search

FilterBW Property

Read-only

Description

Returns the results of the SearchBandwidth method.

VB Syntax

filtBW = meas.FilterBW

Variable

(Type) - Description

filtBW

(single) - Variable to store bandwidth data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterBW = meas.FilterBW 'Read

C++ Syntax

HRESULT get_FilterBW(float* bw)

Interface

IMeasurement


Filter CF Property

About Marker Search

FilterCF Property

Read-only

Description

Returns the Center Frequency result of the SearchBandwidth method.

VB Syntax

filtCF = meas.FilterCF

Variable

(Type) - Description

filtCF

(double) - Variable to store bandwidth CF data

meas

A Measurement (object)

Return Type

Double

Default

Not applicable

Examples

filtCF = meas.FilterCF 'Read

C++ Syntax

HRESULT get_FilterCF(double* centerFrequency)

Interface

IMeasurement


Filter Loss Property

About Marker Search

FilterLoss Property

Read-only

Description

Returns the Loss value of the SearchBandwidth method.

VB Syntax

filtLoss = meas.FilterLoss

Variable

(Type) - Description

filtLoss

(single) - Variable to store bandwidth Loss data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filterLoss = meas.FilterLoss 'Read

C++ Syntax

HRESULT get_FilterLoss(float* loss)

Interface

IMeasurement


Filter Q Property

About Marker Search

FilterQ Property

Read-only

Description

Returns the Q (quality factor) result of the SearchBandwidth method.

VB Syntax

filtQ = meas.FilterQ

Variable

(Type) - Description

filtQ

(single) - Variable to store bandwidth Q data

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

filtQ = meas.FilterQ 'Read

C++ Syntax

HRESULT get_FilterQ(float* quality)

Interface

IMeasurement


Frequency Span Property

About Frequency Range

FrequencySpan Property

Write/Read

Description

Sets or returns the frequency span of the channel.

Sets or returns the frequency span of the segment.

VB Syntax

object.FrequencySpan = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Frequency span in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Full frequency span of the analyzer

Examples

chan.FrequencySpan = 4.5e9 'sets the frequency span of a linear sweep for the channel object -Write

freqspan = chan.FrequencySpan 'Read

C++ Syntax

HRESULT get_FrequencySpan(double *pVal)
HRESULT put_FrequencySpan(double newVal)

Interface

IChannel
ISegment


About Gate Filter

Shape Property

Write/Read

Description

Specifies the shape of the gate filter.

VB Syntax

gat.Shape = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateShape) - Choose from:

0 - naGateShapeMaximum
1 - naGateShapeWide
2 - naGateShapeNormal
3 - naGateShapeMinimum

Return Type

NAGateShape

Default

2 - Normal

Examples

gat.Shape = naGateShapeMaximum 'Write

filterShape = gat.Shape 'Read

C++ Syntax

HRESULT get_Shape(tagNAGateShape *pVal)
HRESULT put_Shape(tagNAGateShape newVal)

Interface

IGating


Type (Gate) Property

About Time Domain

Type Property

Write/Read

Description

Specifies the type of gate filter used.

VB Syntax

gat.Type = value

Variable

(Type) - Description

gat

A Gating (object)

value

(enum NAGateType) - Choose from:
naGateTypeBandpass - Includes (passes) the range between the start and stop times.
naGateTypeNotch - Excludes (attenuates) the range between the start and stop times.

Return Type

NAGateType

Default

Bandpass

Examples

gate.Type = naGateTypeNotch 'Write

filterType = gate.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAGateType *pVal)
HRESULT put_Type(tagNAGateType newVal)

Interface

IGating


About GPIB Fundamentals

GPIBMode Property

Write/Read

Description

Changes the analyzer to a GPIB system controller or a talker/listener on the bus. The analyzer must be the controller if you want to use it to send commands to other instruments. The analyzer must be a talker/listener if you want to send it commands from another PC.

VB Syntax

app.GPIBMode value

Variable

(Type) - Description

app

An Application (object)

value

(enum NAGPIBMode) -Choose either:
0 - naTalkerListener - the analyzer is a talker / listener
1 - naSystemController - the analyzer is the system controller

Return Type

Long Integer

Default

0 - naTalkerListener

Examples

app.GPIBMode = naTalkerListener 'Write

mode = app.GPIBMode 'Read

C++ Syntax

HRESULT get_ScpiMode(tagScpiModeEnum* eScpiMode)
HRESULT put_ScpiMode(tagScpiModeEnum eScpiMode)

Interface

IApplication


IDString Property

Read-only

Description

Returns the ID of the analyzer, including the Model number, Serial Number, and the Software revision number.

VB Syntax

value = app.IDString

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned ID string

Return Type

String

Default

Not Applicable

Examples

id = app.IDString

C++ Syntax

HRESULT IDString(BSTR* IDString)

Interface

IApplication


IF Bandwidth Option Property

About Segment Sweep

IFBandwidthOption Property

Write/Read

Description

Enables the IFBandwidth to be set on individual sweep segments. This property must be set True before seg.IFBandwidth = value is sent. Otherwise, this command will be ignored.

VB Syntax

segs.IFBandwidthOption = value

Variable

(Type) - Description

segs

A Segments collection (object)

value

(boolean)
True - Enables variable IFBandwidth setting for segment sweep
False - Disables variable IFBandwidth setting for segment sweep

Return Type

Boolean

Default

False

Examples

segs.IFBandwidthOption = True 'Write

IFOption = IFBandwidthOption 'Read

C++ Syntax

HRESULT get_IFBandwidthOption(VARIANT_BOOL *pVal)
HRESULT put_IFBandwidthOption(VARIANT_BOOL newVal)

Interface

ISegments


IF Bandwidth Property

About IF Bandwidth

IFBandwidth Property

Write/Read

Description

Sets or returns the IF Bandwidth of the channel.
Sets or returns the IF Bandwidth of the segment.

VB Syntax

object.IFBandwidth = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(double) - IF Bandwidth in Hz. Choose from:

1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1000 | 1500 | 2000 | 3000 | 5000 | 7000 | 10000 | 15000 | 20000 | 30000 | 35000 | 40000 |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Return Type

Double

Default

3500

Examples

chan.IFBandwidth = 3e3 'sets the IF Bandwidth of for the channel object to 3 kHz. -Write
seg.IFBandwidth = 5 'sets the IF Bandwidth of the segment to 5 Hz. -Write

ifbw = chan.IFBandwidth -Read

C++ Syntax

HRESULT get_IFBandwidth(double *pVal)
HRESULT put_IFBandwidth(double newVal)

Interface

IChannel
ISegment


Impulse Width Property

About Time Domain

ImpulseWidth Property

Write/Read

Description

Sets or returns the Impulse Width of Time Domain transform windows

VB Syntax

trans.ImpulseWidth = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Impulse Width in seconds. Range of settings depends on the frequency range of your analyzer.

Return Type

Double

Default

.98 / Default Span

Examples

trans.ImpulseWidth = 200e-12 'sets the Impulse width of a transform window -Write

IW = trans.ImpulseWidth 'Read

C++ Syntax

HRESULT get_ImpulseWidth(double *pVal)
HRESULT put_ImpulseWidth(double newVal)

Interface

ITransform


Input A Property

About Port Extensions

InputA Property

Write/Read

Description

Sets a Port Extension value for Receiver A

VB Syntax

portExt.InputA = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputA = 10e-6 'Write

inA = portExt.InputA 'Read

C++ Syntax

HRESULT get_InputA(double *pVal)
HRESULT put_InputA(double newVal)

Interface

IPortExtension


Input B Property

About Port Extensions

InputB Property

Write/Read

Description

Sets the Port Extension value for Receiver B

VB Syntax

portExt.InputB = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.InputB = 10e-6 'Write

inB = portExt.InputB 'Read

C++ Syntax

HRESULT get_InputB(double *pVal)
HRESULT put_InputB(double newVal)

Interface

IPortExtension


About Interpolation

Interpolate Correction Property

Write/Read

Description

Turns ON and OFF correction interpolation which calculates new error terms when stimulus values change after calibration.

When this property is ON and error correction is being applied, the calibration subsystem attempts to interpolate the error terms whenever the stimulus parameters are changed.

When this property is OFF under the same circumstances, error correction is turned OFF.

VB Syntax

meas.InterpolateCorrection = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Choose from:

True - Turns correction interpolation ON
False - Turns correction interpolation OFF

Return Type

Boolean

Default

True

Examples

meas.InterpolateCorrection = False

calInterpolate = InterpolateCorrection 'Read

C++ Syntax

HRESULT get_InterpolateCorrection(boolean *pVal)
HRESULT put_InterpolateCorrection(boolean newVal)

Interface

IMeasurement


Kaiser Beta Property

About Time Domain

KaiserBeta Property

Write/Read

Description

Sets or returns the Kaiser Beta of Time Domain transform windows

VB Syntax

trans.KaiserBeta = value

Variable

(Type) - Description

trans

A Transform (object)

value

(single) - Kaiser Beta. Choose any number between 0 and 13.

Return Type

Single

Default

0

Examples

trans.KaiserBeta = 6 'sets the Kaiser Beta of a transform window -Write

KB = trans.KaiserBeta 'Read

C++ Syntax

HRESULT get_KaiserBeta(float *pVal)
HRESULT put_KaiserBeta(float newVal)

Interface

ITransform


About Modifying Cal Kits

L0 Property

Write/Read

Description

Sets and Returns the L0 (L-zero) value (the first inductance value) for the calibration standard.

To set the other inductance values, use L1, L2, L3

VB Syntax

calstd.L0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L0 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L0 = 15 'Write the value of L0 = 15picohenries

Induct0 = calstd.L0 'Read the value of L0

C++ Syntax

HRESULT get_L0(float *pVal)
HRESULT put_L0(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L1 Property

Write/Read

Description

Sets and Returns the L1 value (the second inductance value) for the calibration standard.

To set the other inductance values, use L0, L2, L3

VB Syntax

calstd.L1 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L1 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L1 = 15 'Write the value of L1 = 15picohenries

Induct1 = calstd.L1 'Read the value of L1

C++ Syntax

HRESULT get_L1(float *pVal)
HRESULT put_L1(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L2 Property

Write/Read

Description

Sets and Returns the L2 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L3

VB Syntax

calstd.L2 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L2 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L2 = 15 'Write the value of L2 to 15picohenries

Induct2 = calstd.L2 'Read the value of L2

C++ Syntax

HRESULT get_L2(float *pVal)
HRESULT put_L2(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

L3 Property

Write/Read

Description

Sets and Returns the L3 value (the third inductance value) for the calibration standard.

To set the other inductance values, use L0, L1, L2

VB Syntax

calstd.L3 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Value for L3 in picohenries

Return Type

Single

Default

Not Applicable

Examples

calstd.L3 = 15 'Write the value of L3 to 15picohenries

Induct3 = calstd.L3 'Read the value of L3

C++ Syntax

HRESULT get_L3(float *pVal)
HRESULT put_L3(float newVal)

Interface

ICalStandard


About Modifying Cal Kits

Label Property

Write/Read

Description

Sets and Returns the label for the calibration standard. The label is used to prompt the user to connect the specified standard.

VB Syntax

calstd.Label = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(string) - between 1 and 12 characters long. Cannot begin with a numeric.

Return Type

String

Default

Not Applicable

Examples

calstd.Label = "Short" 'Write

stdLabel = calstd.Label 'Read

C++ Syntax

HRESULT get_Label(BSTR *pVal)
HRESULT put_Label(BSTR newVal)

Interface

ICalStandard


Begin Stimulus Property

About Sweeps

BeginStimulus Property

Write/Read

Description

When constructing a limit line, specifies the beginning X-axis value.

VB Syntax

limtseg.BeginStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Stimulus value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.Type = naLimitSegmentType_Maximum
limtseg.BeginStimulus = 3e9
limtseg.EndStimulus = 4e9
limtseg.BeginResponse = 10
limtseg.EndResponse = 10

BegStim = limtseg.BeginStimulus 'Read

C++ Syntax

HRESULT get_BeginStimulus(double *pVal)
HRESULT put_BeginStimulus(double newVal)

Interface

ILimitSegment


End Stimulus Value

About Limits

EndStimulus Property

Write/Read

Description

When constructing a limit line, specifies the stimulus value for the end of the segment.

VB Syntax

limtseg.EndStimulus = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - End Stimulus X-axis value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndStimulus = 8e9 'Write

EndStim = limtseg.EndStimulus 'Read

C++ Syntax

HRESULT get_EndStimulus(double *pVal)
HRESULT put_EndStimulus(double newVal)

Interface

ILimitSegment


Begin Response Property

About Sweeps

BeginResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value of the start of a limit segment.

VB Syntax

limtseg.BeginResponse = value

Variable

(Type) - Description

limtseg

A LimitSegment (object)

value

(double) - Amplitude value. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.BeginResponse = 10 'Write

BegResp = limtseg.BeginResponse 'Read

C++ Syntax

HRESULT get_BeginResponse(double *pVal)
HRESULT put_BeginResponse(double newVal)

Interface

ILimitSegment


End Response Property

About Limits

EndResponse Property

Write/Read

Description

When constructing a limit line, specifies the amplitude value at the end of the limit segment.

VB Syntax

limtseg.EndResponse = value

Variable

(Type) - Description

limts

A LimitSegment (object)

value

(double) - Y-axis value of the End Response limit. No units

Return Type

Double

Default

0

Examples

Set limtseg = meas.LimitTest(1)
limtseg.EndResponse = 10 'Write

EndResp = limtseg.EndResponse 'Read

C++ Syntax

HRESULT get_EndResponse(double *pVal)
HRESULT put_EndResponse(double newVal)

Interface

ILimitSegment


About Limits

Type (limit) Property

Write/Read

Description

Specifies the Limit Line type.

VB Syntax

limt(index).Type = value

Variable

(Type) - Description

limt

A LimitSegment (object)

index

(variant) - Limit line number in the LimitTest collection

value

(enum NALimitSegmentType) - Limit Line type. Choose from:
naLimitSegmentType_Maximum - limit line fails with a data point ABOVE the line
naLimitSegmentType_Minimum - limit line fails with a data point BELOW the line
naLimitSegmentType_OFF - turns limit line OFF

Return Type

Long Integer

Default

0 - OFF

Examples

Set limts = meas.LimitTest
limts.Type = naLimitSegmentType_Maximum 'Write

limitType = limts.Type 'Read

C++ Syntax

HRESULT put_Type(tagNALimitSegmentType *pVal)
HRESULT get_Type(tagNALimitSegmentType newVal)

Interface

ILimitSegment


About Limits

LineDisplay Property

Write/Read

Description

Turns the display of limit lines ON or OFF. To turn limit TESTING On and OFF, use State Property.

Note: Trace data must be ON to view limit lines

VB Syntax

limitst.LineDisplay = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the display of limit lines OFF
1 - Turns the display of limit lines ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.LineDisplay = 1 'Write

lineDsp = Limttest.LineDisplay 'Read

C++ Syntax

HRESULT get_LineDisplay(VARIANT_BOOL *pVal)
HRESULT put_LineDisplay(VARIANT_BOOL newVal)

Interface

ILimitTest


About Modifying Cal Kits

Loss Property

Write/Read

Description

Sets and Returns the insertion loss for the calibration standard.

VB Syntax

calstd.loss = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) - Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)

Return Type

Single

Default

Not Applicable

Examples

calstd.loss = 3.5e9 'Write

stdLoss = calstd.loss 'Read the value of Loss

C++ Syntax

HRESULT get_Loss(float *pVal)
HRESULT put_Loss(float newVal)

Interface

ICalStandard


Bucket Number Property

About Markers

BucketNumber Property

Write/Read

Description

Sets or returns the bucket number (data point) for the active marker.

VB Syntax

mark.BucketNumber = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Data point. Choose any number between 0 and the measurement's number of data points - 1.

For example, with Number of points = 201, choose between 0 and 200

Return Type

Long Integer

Default

The first marker is set to the middle of the span. Subsequent markers are set to the bucket number of the previously active marker.

Examples

mark.BucketNumber = 100 'moves the active marker to data point 100 -Write

pointNumber = mark.BucketNumber 'returns the data point number the active marker is currently on. -Read

C++ Syntax

HRESULT get_BucketNumber(long *pVal)
HRESULT put_BucketNumber(long newVal)

Interface

IMarker


Marker Format Property

About Marker Format

MarkerFormat Property

Write/Read

Description

Sets (or returns) the format of all the markers in the measurement. To override this setting for an individual marker, use mark.Format

VB Syntax

meas.MarkerFormat = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

Long Integer

Default

1 - naMarkerFormat_LogMag

Examples

meas.MarkerFormat = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT put_MarkerFormat(tagNAMarkerFormat NewFormat)

Interface

IMeasurement


Format (Marker) Property

About Marker Format

Format Property (marker)

Write/Read

Description

Sets (or returns) the format of the marker.

VB Syntax

mark.Format = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFormat) - Choose from:

0 - naMarkerFormat_LinMag
1 - naMarkerFormat_LogMag
2 - naMarkerFormat_Phase
3 - naMarkerFormat_Delay
4 - naMarkerFormat_Real
5 - naMarkerFormat_Imaginary
6 - naMarkerFormat_SWR
7 - naMarkerFormat_LinMagPhase
8 - naMarkerFormat_LogMagPhase
9 - naMarkerFormat_RealImaginary
10 - naMarkerFormat_ComplexImpedance
11 - naMarkerFormat_ComplexAdmittance

Return Type

NAMarkerFormat

Default

1 - naMarkerFormat_LogMag

Examples

mark.Format = naMarkerFormat_SWR 'Write

fmt = mark.Format 'Read

C++ Syntax

HRESULT get_Format(tagNAMarkerFormat *pVal)
HRESULT put_Format(tagNAMarkerFormat newVal)

Interface

IMarker


Interpolate Markers Method

About Markers

InterpolateMarkers Method

Write-only

Description

Turns All Marker Interpolation ON and OFF for the measurement. Marker interpolation enables X-axis resolution between the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. To override this property for individual markers, use the Interpolated property.

VB Syntax

meas.Interpolate = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean)
False - Turns interpolation OFF for all markers in the measurement
True - Turns interpolation ON for all markers in the measurement

Return Type

Boolean

Default

True (ON)

Examples

meas.Interpolate = 1

C++ Syntax

HRESULT raw_InterpolateMarkers(VARIANT_BOOL bNewVal)

Interface

IMeasurement


About Markers

Interpolated Property

Write/Read

Description

Turns marker Interpolation ON and OFF. Marker interpolation enables X-axis resolution beyond the discrete data values. The analyzer will calculate the x and y-axis data values between discrete data points. Use meas.Interpolate to change interpolation of all markers in a measurement. This command will override the measurement setting.

VB Syntax

mark.Interpolated = value

Variable

(Type) - Description

mark

A Marker (object)

value

(boolean)
False - Turns interpolation OFF
True - Turns interpolation ON

Return Type

Boolean

Default

True (ON)

Examples

mark.Interpolated = 1 'Write

interpolate = mark.Interpolated 'Read

C++ Syntax

HRESULT get_Interpolated(VARIANT_BOOL *pVal)
HRESULT put_Interpolated(VARIANT_BOOL newVal)

Interface

IMarker


Number (marker) Property

About Markers

Number Property

Read-only

Description

Returns the number of the marker.

VB Syntax

marknum = mark.Number

Variable

(Type) - Description

marknum

(long) - Variable to store marker number

mark

A Marker (object)

Return Type

Long Integer

Default

Not applicable

Examples

marknum = mark.Number 'Read

C++ Syntax

HRESULT get_Number(long *pVal)

Interface

IMarker


About Marker Types

Type (Marker) Property

Write/Read

Description

Sets and reads the marker type.

VB Syntax

mark.Type = value

Variable

(Type) - Description

chan

A Marker (object)

value

(enum NAMarkerType) - Marker Type. Choose from:
naMarkerType_Normal - the X-axis value for a normal marker will always be determined by the measurement data of the marker. naMarkerType_Fixed - retains and keeps its x-axis value at the time the marker type is set.

Return Type

Long Integer

Default

naMarkerType_Normal

Examples

mark.Type = naMarkerType_Normal 'Write

MrkType = mark.Type 'Read

C++ Syntax

HRESULT get_Type(tagNAMarkerType *pVal)
HRESULT put_Type(tagNAMarkerType newVal)

Interface

IMarker


About Markers

Stimulus Property

Write/Read

Description

Sets and reads the X-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

VB Syntax

mark.Stimulus = value

Variable

(Type) - Description

mark

A Marker (object)

value

(double) - X-Axis value. Choose any number within the full span of the channel or User Range (if set).

Return Type

Double

Default

First activated Marker turns ON in the middle of the X-axis range. Subsequent markers turn ON at the position of the most recently active marker.

Examples

mark.Stimulus = 3e9 'Write

XVal = mark.Stimulus 'Read

C++ Syntax

HRESULT get_Stimulus(double *pVal)
HRESULT put_Stimulus(double newVal)

Interface

IMarker


About Markers

Value Property

Read-only

Description

Reads the Y-Axis value of the marker. If the marker is a delta marker, the value will be relative to the reference marker.

You cannot set the Y-axis value of a marker. The marker remains at the position at the time you set marker.Type.

VB Syntax

YValue = mark.Value (format)

Variable

(Type) - Description

YValue

A variable to store the Y-axis value

mark

A Marker (object)

format

(enum NAMarkerFormat) - The format you would like the marker's Y-axis value. The number in parenthesis following the format is the number of values that are returned in a variant array. Choose from:

naMarkerFormat_LinMag (1)
naMarkerFormat_LogMag (1)
naMarkerFormat_Phase (1)
naMarkerFormat_Delay (1)
naMarkerFormat_Real (1)
naMarkerFormat_Imaginary (1)
naMarkerFormat_SWR (1)
naMarkerFormat_LinMagPhase (2)
naMarkerFormat_LogMagPhase (2)
naMarkerFormat_RealImaginary (2)
naMarkerFormat_ComplexImpedance (3)
naMarkerFormat_ComplexAdmittance (3)

Return Type

Variant - The previous list of formats indicates the number of values that are returned in a variant array

Default

Not applicable

Examples

YVal = mark.Value 'Read

C++ Syntax

HRESULT get_Value(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


About Modifying Cal Kits

MaximumFrequency Property

Write/Read

Description

Sets and Returns the maximum frequency for the calibration standard.

VB Syntax

calstd.MaximumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) - Maximum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MaximumFrequency = 9e9 'Write

maxFrequency = calstd.MaximumFrequency 'Read

C++ Syntax

HRESULT get_MaximumFrequency(double *pVal)
HRESULT put_MaximumFrequency(double newVal)

Interface

ICalStandard


About Trace Statistics

Mean Property

Read-only

Description

Returns the mean value of the measurement . To retrieve all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

average = meas.Mean

Variable

(Type) - Description

average

(single) - Variable to store mean value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

Dim average as Single
average = meas.Mean 'Read

C++ Syntax

HRESULT get_Mean(float* mean)

Interface

IMeasurement


About Modifying Cal Kits

Medium Property

Write/Read

Description

Sets and Returns the media type of the calibration standard.

VB Syntax

calstd.Medium = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardMedium) - Medium of the transmission line of the standard. Choose from:
0 - naCoax - Coaxial Cable
1 - naWaveGuide

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Medium = naCoax 'Write

stdMedium = calstd.Medium 'Read

C++ Syntax

HRESULT get_Medium(tagNACalStandardMedium *pVal)
HRESULT put_Medium(tagNACalStandardMedium newVal)

Interface

ICalStandard


About Modifying Cal Kits

MinimumFrequency Property

Write/Read

Description

Sets and Returns the minumum frequency for the calibration standard.

VB Syntax

calstd.MinimumFrequency = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(double) -Minimum frequency in Hertz.

Return Type

Double

Default

Not Applicable

Examples

calstd.MinimumFrequency = 300e3 'Write

minFrequency = calstd.MinimumFrequency 'Read

C++ Syntax

HRESULT get_MinimumFrequency(double *pVal)
HRESULT put_MinimumFrequency(double newVal)

Interface

ICalStandard


Name (Meas) Property

About Traces

Name (Measurement) Property

Write/Read

Description

Sets (or returns) the Name of the measurement. Measurement names must be unique among the set of measurements. Measurement names cannot be an empty string.

Note: This is the same name as trace.Name; when one changes, the other changes.

VB Syntax

meas.Name = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(string) - A user defined name of the measurement

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

meas.Name = "Filter BPass" 'Write

MName = meas.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

IMeasurement


About Traces

Name (trace) Property

Write/Read

Description

Sets or returns the name of the Trace. Use the trace name to identify the trace and refer to the trace in the collection.

Note: This is the same name as meas.Name; when one changes, the other changes.

VB Syntax

trac.Name = value

Variable

(Type) - Description

trac

A Trace (object)

value

(String) Trace name

Return Type

String

Default

"CH1_S11_1" - name of the default measurement

Examples

trace.Name = "myTrace" 'Write

traceName = Name.Trace 'Read

C++ Syntax

HRESULT put_Name(BSTR name)
HRESULT get_Name(BSTR *name)

Interface

ITrace


About Modifying Cal Kits

Name (CalKit) Property

Write/Read

Description

Sets and Returns a name for the selected calibration kit.

VB Syntax

calKit.Name = value

Variable

(Type) - Description

calKit

A CalKit (object).

value

(string) -Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).

Return Type

String

Default

Not Applicable

Examples

calKit.Name = "MyCalKit" 'Write

KitName = calKit.Name 'Read

C++ Syntax

HRESULT get_Name(BSTR *pVal)
HRESULT put_Name(BSTR newVal)

Interface

ICalKit


Number (meas) Property

About Measurements

Number (Measurement) Property

Read-only

Description

Returns the Number of the measurement. Measurement numbers are assigned internally.

Note: Measurement numbers are NOT the same as their number in the Measurements collection. Measurement number is used to identify the measurement associated with an event.

This property is used to identify measurements when events occur through the OnMeasurementEvent callback. For example:

OnMeasurementEvent (naEventId_MSG_LIMIT_FAILED, 3)

VB Syntax

measNum = meas.Number

Variable

(Type) - Description

measNum

(long) - variable to store the measurement number

meas

A Measurement (object)

Return Type

Long Integer

Default

"1" - number of the default measurement

Examples

measNum = meas.Number

C++ Syntax

HRESULT get_Number(long *MeasurementNumber)

Interface

IMeasurement


Number of Points Property

About Number of Points

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Options

Options Property

Read-only

Description

Returns a string identifying the analyzer option configuration.

VB Syntax

value = app.Options

Variable

(Type) - Description

app

An Application (object)

value

(string) - variable to contain the returned string

Return Type

String

Default

Not Applicable

Examples

availOptions = app.Options

C++ Syntax

HRESULT Options(BSTR* OptionString)

Interface

IApplication


About Measurement Parameters

Parameter Property

Read-only

Description

Returns the measurement Parameter. To change the parameter, use meas.ChangeParameter

VB Syntax

measPar = meas.Parameter

Variable

(Type) - Description

measPar

(string) - Variable to store Parameter string

meas

A Measurement (object)

Return Type

String

Default

Not applicable

Examples

measPar = meas.Parameter 'Read

C++ Syntax

HRESULT get_Parameter(BSTR *pVal)

Interface

IMeasurement


Parent Property

Read-only

Description

Returns a handle to the parent object of the collection object being refered to in the statement. The parent property allows the user to traverse from an object back up the object hierarchy.

VB Syntax

object.Parent

Variable

(Type) - Description

object

Channels collection
Channel object
Measurements collection
NAWindows collection
Traces collection
Segments object

Return Type

Object

Default

Not Applicable

Examples

parentobj = chans.Parent 'returns a handle to the parent object (Application) of the chans collection. -Read

C++ Syntax

HRESULT get_Parent(IApplication* *pApplication)

Interface

IChannels
IChannel
IMeasurements
INAWindows
ITraces
ISegments


Peak Excursion Property

About Marker Search

PeakExcursion Property

Write/Read

Description

Sets and reads the peak excursion value for the specified marker. The Excursion value determines what is considered a "peak".

VB Syntax

mark.PeakExcursion = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Excursion. Choose any number between -500 and 500

Return Type

Single

Default

3

Examples

mark.PeakExcursion = 1 'Write

PkExcur = mark.PeakExcursion 'Read

C++ Syntax

HRESULT get_PeakExcursion(float *pVal)
HRESULT put_PeakExcursion(float newVal)

Interface

IMarker


Peak Threshold Property

About Marker Search

PeakThreshold Property

Write/Read

Description

Sets peak threshold for the specified marker. If a peak (using the criteria set with PeakExcursion) is below this reference value, it will not be considered when searching for peaks.

VB Syntax

mark.PeakThreshold = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Peak Threshold. Choose any number between:
-500 and 500

Return Type

Single

Default

-100db

Examples

mark.PeakThreshold = 1 'Write

PkThresh = mark.PeakThreshold 'Read

C++ Syntax

HRESULT get_PeakThreshold(float *pVal)
HRESULT put_PeakThreshold(float newVal)

Interface

IMarker


About Trace Statistics

PeakToPeak Property

Read-only

Description

Returns the Peak to Peak value of the measurement.To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

pp = meas.PeakToPeak

Variable

(Type) - Description

pp

(single) - Variable to store peak-to-peak value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

pp = meas.PeakToPeak 'Read

C++ Syntax

HRESULT get_PeakToPeak(float* pp)

Interface

IMeasurement


Phase Offset Property

About Phase Offset

PhaseOffset Property

Write/Read

Description

Sets the Phase Offset for the active channel.

VB Syntax

meas.PhaseOffset = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - PhaseOffset in degrees. Choose any number between:
-360 and +360

Return Type

Double

Default

0

Examples

meas.PhaseOffset = 25 'Write

poffset = meas.PhaseOffset 'Read

C++ Syntax

HRESULT get_PhaseOffset(double *pVal)
HRESULT put_PhaseOffset(double newVal)

Interface

IMeasurement


Port 1 Property

About Port Extensions

Port1 Property

Write/Read

Description

Sets a Port Extension value for Port 1

VB Syntax

portExt.Port1 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port1 = 10e-6 'Write

prt1 = portExt.Port1 'Read

C++ Syntax

HRESULT get_Port1(double *pVal)
HRESULT put_Port1(double newVal)

Interface

IPortExtension


Port 2 Property

About Port Extensions

Port2 Property

Write/Read

Description

Sets a Port Extension value for Port 2

VB Syntax

portExt.Port2 = value

Variable

(Type) - Description

portExt

A Port Extension (object)

value

(double) - Port Extension value in seconds. Choose any number between -10 and 10

Return Type

Double

Default

0

Examples

portExt.Port2 = 10e-6 'Write

prt2 = portExt.Port2 'Read

C++ Syntax

HRESULT get_Port2(double *pVal)
HRESULT put_Port2(double newVal)

Interface

IPortExtension


About Modifying Cal Kits

PortLabel Property

Write/Read

Description

Sets and returns the label on the calibration kit Port for the calibration wizard.

VB Syntax

calKit.Portlabel (portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object)

portNum

(long integer) - number of the port to be labeled. Choose either 1 or 2

value

(string) - Label that is visible in the calibration wizard.

Return Type

String

Default

Depends on the Cal Kit.

Examples

calKit.PortLabel = "MyCalKit" 'Write

kitLabel = calKit.PortLabel 'Read

C++ Syntax

HRESULT get_PortLabel(long port, BSTR *pVal)
HRESULT put_PortLabel(long port, BSTR newVal)

Interface

ICalKit


Power Slope Property

About Power Slope

PowerSlope Property

Write/Read

Description

Sets or returns the Power Slope value. Power Slope function increases or decreases the output power over frequency. Units are db/GHz. For example: PowerSlope = 2 will increase the power 2db/1GHZ.

VB Syntax

app.PowerSlope = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Power Slope. Choose any number between -2 and 2.
No slope = 0

Return Type

Double

Default

0

Examples

app.PowerSlope = 2 'Write

pwrslp = app.PowerSlope 'Read

C++ Syntax

HRESULT get_PowerSlope(double *pVal)
HRESULT put_PowerSlope(double newVal)

Interface

IChannel


Receiver Attenuator Property

About Receiver Attenuation

ReceiverAttenuator Property

Write/Read

Description

Sets or returns the value of the specified receiver attenuator control.

VB Syntax

chan.ReceiverAttenuator(rec) = value

Variable

(Type) - Description

chan

A Channel (object)

rec

(long integer) - Receiver with attenuator control to be changed. Choose from:
0 - Receiver A
1 - Receiver B

value

(double) - Attenuator value in dB. Choose any Long Integer between 0 and 35 in 5dB steps:

If an invalid value is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered the analyzer will select 15 dB attenuation.

Return Type

Double

Default

0 db

Examples

chan.ReceiverAttenuator(1) = 5 'Write

attn = chan.ReceiverAttenuator(rnum) 'Read

C++ Syntax

HRESULT get_ReceiverAttenuator(long lport, double *pVal)
HRESULT put_ReceiverAttenuator(long lport, double newVal)

Interface

IChannel


About Reference Markers

ReferenceMarkerState Property

Write/Read

Description

Turn ON or OFF the reference marker. (can you access marker10?)

VB Syntax

meas.ReferenceMarkerState = state

Variable

(Type) - Description

app

A Measurement (object)

state

(boolean) -
ON (1) turns the reference marker ON
OFF (0) turns the reference marker OFF

Return Type

Boolean

Default

0 - OFF

Examples

meas.ReferenceMarkerState = True

reference = meas.ReferenceMarkerState

C++ Syntax

HRESULT get_ReferenceMarkerState(VARIANT_BOOL bState)
HRESULT put_ReferenceMarkerState(VARIANT_BOOL* bState)

Interface

IMeasurement


Reference Position Property

About Reference Position

ReferencePosition Property

Write/Read

Description

Sets or returns the Reference Position of the active trace.

VB Syntax

trce.ReferencePosition = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference position on the screen measured in horizontal graticules from the bottom of the screen. Choose from any number between: 0 and 10.

Return Type

Double

Default

0

Examples

meas.ReferencePosition = 5 'Middle of the screen -Write

rpos = meas.ReferencePosition -Read

C++ Syntax

HRESULT get_ReferencePosition(double *pVal)
HRESULT put_ReferencePosition(double newVal)

Interface

ITrace


Reference Value Property

About Reference Level

ReferenceValue Property

Write/Read

Description

Sets or returns the value of the Y-axis Reference Level of the active trace.

VB Syntax

trce.ReferenceValue = value

Variable

(Type) - Description

trce

A Trace (object)

value

(double) - Reference Value. Units and range depend on the current data format.

Return Type

Double

Default

Not applicable

Examples

meas.ReferenceValue = 0 'Write

rlev = meas.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(double *pVal)
HRESULT put_ReferenceValue(double newVal)

Interface

ITrace


Search Function Property

About Marker Search

SearchFunction Property

Write/Read

Description

Emulates the Tracking function in the marker search dialog box. The value you choose for SearchFunction will determine the type of search that takes place when the Tracking property is set true.

The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as executing one of the "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.SearchFunction = value

Variable

(Type) - Description

mark

A Marker (object)

value

(enum NAMarkerFunction) - search function. Choose from:

0 - naMarkerFunction_None
1 - naMarkerFunction_Min
2 - naMarkerFunction_Max
3 - naMarkerFunction_Target
4 - naMarkerFunction_NextPeak
5 - naMarkerFunction_PeakRight
6 - naMarkerFunction_PeakLeft

Return Type

Long Integer

Default

0 - naMarkerFunction_None

Examples

mark.SearchFunction = naMarkerFunction_Target 'When this marker is set to track, it will track the Target value.

searchfunction = mark.SearchFunction 'Read

C++ Syntax

HRESULT get_SearchFunction(tagNAMarkerFunction *pVal)
HRESULT put_SearchFunction(tagNAMarkerFunction newVal)

Interface

IMarker


Segment Number Property

About Segment Sweep

SegmentNumber Property

Read-only

Description

Returns the number of the current segment.

VB Syntax

seg.SegmentNumber

Variable

(Type) - Description

seg

A Segment (object). Get a handle to a segment by refering to the item in the segments collection.

Return Type

Long Integer

Default

Not Applicable

Examples

segNum = seg.SegmentNumber 'returns the segment number -Read

C++ Syntax

HRESULT get_SegmentNumber(long *pVal)

Interface

ISegment


Show Statistics Property

About Trace Statistics

ShowStatistics Property

Write/Read

Description

Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen. To display measurement statistics for a narrower band of the X-axis, use StatisticsRange.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both.

VB Syntax

meas.ShowStatistics = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(boolean) - Boolean value:

1 - Show statistics
0 - Hide statistics

Return Type

Boolean

Default

0 - Hide

Examples

meas.ShowStatistics = True 'Write

showstats = meas.ShowStatistics 'Read

C++ Syntax

HRESULT put_ShowStatistics(VARIANT_BOOL bState)

Interface

IMeasurement


About Performing a Calibration

Simultaneous2PortAcquisition Property

Read / Write

Description

Specifies whether a 2-port calibration will be done simultaneously or one port at a time.

VB Syntax

cal.Simultaneous2PortAcquisition = state

Variable

(Type) - Description

cal

A Calibrator (object)

state

(boolean) - Choose from:

True - measures 2 ports simultaneously
False - measures 1 port at a time

Return Type

Boolean

Default

False

Examples

cal.Simultaneous2PortAcquisition = True

C++ Syntax

HRESULT put_Simultaneous2PortAcquisition( VARIANT_BOOL bTwoSetsOfStandards)

HRESULT Simultaneous2PortAcquisition( VARIANT_BOOL *bTwoSetsOfStandards)

Interface

ICalibrator


Smoothing Aperture Property

About Smoothing

SmoothingAperture Property

Write/Read

Description

Specifies or returns the amount of smoothing as a ratio of the number of data points in the measurement trace.

VB Syntax

meas.SmoothingAperture = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(double) - Smoothing Aperture. A ratio of (aperture points / trace points)/100 Choose any number between .01 and .25.

Return Type

Double

Default

.25

Examples

meas.SmoothingAperture = .10 'Write

saperture = meas.SmoothingAperture 'Read

C++ Syntax

HRESULT get_SmoothingAperture(double *pVal)
HRESULT put_SmoothingAperture(double newVal)

Interface

IMeasurement


About Smoothing

Smoothing Property

Write/Read

Description

Turns ON and OFF data smoothing.

VB Syntax

meas.Smoothing = state

Variable

(Type) - Description

meas

A Measurement (object)

state

(boolean)
1 - Turns smoothing ON
0 - Turns smoothing OFF

Return Type

Boolean

Default

0

Examples

meas.Smoothing = 1 'Write

smooth = meas.Smoothing 'Read

C++ Syntax

HRESULT get_Smoothing(VARIANT_BOOL *pVal)
HRESULT put_Smoothing(VARIANT_BOOL newVal)

Interface

IMeasurement


About Limits

SoundOnFail Property

Write/Read

Description

Turns ON or OFF the audio indicator for limit failures.

VB Syntax

limitst.SoundOnFail = state

Variable

(Type) - Description

limitst

A LimitTest (object)

state

(boolean)
0 - Turns the sound OFF
1 - Turns the sound ON

Return Type

Long Integer

Default

1 - ON

Examples

Limttest.SoundOnFail = 1 'Write

sound = Limttest.SoundOnFail 'Read

C++ Syntax

HRESULT get_SoundOnFail(VARIANT_BOOL *pVal)
HRESULT put_SoundOnFail(VARIANT_BOOL newVal)

ILimitTest


Source Power Option Property

About Segment Sweep

SourcePowerOption Property

Write/Read

Description

Enables the source power to be set on individual sweep segments. This property must be set True before seg.TestPortPower = value is sent. Otherwise, the test port power command will be ignored.

VB Syntax

segs.SourcePowerOption = state

Variable

(Type) - Description

segs

A Segments collection (object)

state

(boolean)
1 or True - Enables variable TestPortPower to be set segment sweep
0 or False - Disables variable TestPortPower to be set segment sweep

Return Type

Boolean
True - Enabled
False - Disabled

Default

False

Examples

segs.SourcePowerOption = True 'Write

powerOption = SourcePowerOption 'Read

C++ Syntax

HRESULT get_SourcePowerOption(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerOption(VARIANT_BOOL newVal)

Interface

ISegments


Source Power State Property

About Source Power

SourcePowerState Property

Write/Read

Description

Turns Source Power ON and OFF

VB Syntax

app.SourcePowerState = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
False (0) - Turns Source Power OFF
True (1) - Turns Source Power ON

Return Type

Boolean
0 - Power OFF
1 - Power ON

Default

ON (1)

Examples

app.SourcePowerState = True 'Write

pwr = app.SourcePowerState 'Read

C++ Syntax

HRESULT get_SourcePowerState(VARIANT_BOOL *pVal)
HRESULT put_SourcePowerState(VARIANT_BOOL newVal)

Interface

IApplication


About Time Domain

Span Property

Write/Read

Description

Sets or returns the Span time of either Gating or Time Domain transform windows

VB Syntax

object.Span = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Span time in seconds. Choose any number between: 2*[(number of points-1) / frequency span] and 0

Return Type

Double

Default

20ns

Examples

Trans.Span = 4.5e-9 'sets the time span of a transform window -Write
Gate.Span = 4.5e-9 'sets the Span time of a gating window -Write

span = Trans.Span 'Read

C++ Syntax

HRESULT get_Span(double *pVal)
HRESULT put_Span(double newVal)

Interface

ITransform
IGating


Standard Deviation Property

About Trace Statistics

StandardDeviation Property

Read-only

Description

Returns the standard deviation of the measurement.
To retreive all 3 statistics value at the same time, use meas.GetTraceStatistics

VB Syntax

stdev = meas.StandardDeviation

Variable

(Type) - Description

stdev

(single) - Variable to store standard deviation value

meas

A Measurement (object)

Return Type

Single

Default

Not applicable

Examples

stdev = meas.StandardDeviation 'Read

C++ Syntax

HRESULT get_StandardDeviation(float* stdDeviation)

Interface

IMeasurement


About Modifying Cal Kits

StandardForClass Property

Write/Read

Description

Sets a standard to a calibration class. Does NOT set or dictate the order for measuring the standards.

VB Syntax

calKit.StandardForClass(class, portNum) = value

Variable

(Type) - Description

calKit

A CalKit (object). Use calKit.GetCalStandard to get a handle to the standard.

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

portNum

(long) - The port number the standard will be connected to. For example, you may have a 3.5mm connector designated for port 1, and Type N designated for port 2.

value

(double) - Calibration class number. Choose a number between 1 and 8. The <value> numbers are associated with the following calibration classes:

<value> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S21T | Thru standard

Return Type

Double

Default

Not Applicable

Examples

calstd.StandardForClass = 7 'Write

StdClass = calstd.StandardForClass 'Read

C++ Syntax

HRESULT put_StandardForClass(tagNACalClass stdclass, long port, long standardNumber)
HRESULT get_StandardForClass(tagNACalClass stdclass, long port, long* standardNumber)

Interface

ICalKit


Start Frequency Property

About Linear Frequency Sweep

StartFrequency Property

Write/Read

Description

Sets or returns the start frequency of the channel
or
Sets or returns the start frequency of the segment.

VB Syntax

object.StartFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Start frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Minimum frequency of the analyzer
Segment - 0

Examples

chan.StartFrequency = 4.5e9 'sets the start frequency of a linear sweep for the channel object -Write

startfreq = Chan.StartFrequency 'Read

C++ Syntax

HRESULT get_StartFrequency(double *pVal)
HRESULT put_StartFrequency(double newVal)

Interface

ISegment


Start Power Property

About Power Sweep

StartPower Property

Write/Read

Description

Sets the start power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency.

VB Syntax

chan.StartPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Start Power in dBm. There is 40 dB of range in power sweep. The values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 dB of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StartPower = -10 'Write

strtpwr = Chan.StartPower 'Read

C++ Syntax

HRESULT get_StartPower(double *pVal)
HRESULT put_StartPower(double newVal)

Interface

IChannel


About Time Domain

Start Property

Write/Read

Description

Sets or returns the start time of either Gating or Time Domain transform windows

VB Syntax

object.Start = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

-10ns

Examples

Trans.Start = 4.5e-9 'sets the start time of a transform window -Write
Gate.Start = 4.5e-9 'sets the start time of a gating window -Write

strt = Trans.Start 'Read

C++ Syntax

HRESULT get_Start(double *pVal)
HRESULT put_Start(double newVal)

Interface

ITransform
IGating


State Property

Write/Read

Description

Turns an Object ON and OFF.

VB Syntax

object.State = value

Variable

(Type) - Description

object

Applies to any of the following:
Gating (object)
LimitTest (object)
Port Extension (object)
Segment (object)
Transform (object)

value

(boolean) -

0 - Turns obj OFF
1 - Turns obj ON

Return Type

Long Integer

Default

Depends on the object:
0 - Gating
0 - LimitTest
0 - Port Extension
1 - Segment
0 - Transform

Examples

Seg.State = 1 'Turns the segment object ON -Write

tran = Trans.State 'returns the state of Transform -Read

C++ Syntax

HRESULT get_State(VARIANT_BOOL *pVal)
HRESULT put_State(VARIANT_BOOL newVal)

Interface

ISegment
ITransform
IGating
ILimitTest
IPortExtension


About User Ranges

Statistics Range Property

Write/Read

Description

Sets the User Range number for calculating measurement statistics. Set the start and stop values for a User Range with chan.UserRangeMin and chan.UserRangeMax.

There are 9 User Ranges per channel. User ranges are applied independently to any measurement.

VB Syntax

meas.StatisticsRange = value

Variable

(Type) - Description

meas

A Measurement (object)

value

(long integer) - Range Number. Choose any number between 0 and 9.
1 - 9 are user-defined ranges
0 is Full Span

Return Type

Long Integer

Default

0

Examples

meas.StatisticsRange = 2 'Write

statrange = meas.StatisticsRange 'Read

C++ Syntax

HRESULT get_StatisticsRange(long* rangeNumber)
HRESULT put_StatisticsRange(long rangeNumber)

Interface

IMeasurement


Step Rise Time Property

About Time Domain

StepRiseTime Property

Write/Read

Description

Sets or returns the Rise time of the stimulus in Low Pass Step Mode.

VB Syntax

trans.StepRiseTime = value

Variable

(Type) - Description

trans

A Transform (object)

value

(double) - Rise time in seconds. Choose any number between 5.0e-13 and 1.63e-14.

Return Type

Double

Default

0

Examples

trans.StepRiseTime = 1.0e-14 'sets the step rise time to 100 psec. -Write

rt = trans.StepRiseTime 'Read

C++ Syntax

HRESULT get_StepRiseTime(double *pVal)
HRESULT put_StepRiseTime(double newVal)

Interface

ITransform


Stop Frequency Property

About Linear Frequency Sweep

StopFrequency Property

Write/Read

Description

Sets or returns the stop frequency of the channel
or
Sets or returns the stop frequency of the segment.

VB Syntax

object.StopFrequency = value

Variable

(Type) - Description

object

A Channel (object)
or
A Segment (object)

value

(double) - Stop frequency in Hertz. Choose any number between the minimum and maximum frequencies of the analyzer.

Return Type

Double

Default

Channel - Maximum frequency of the analyzer
Segment - 0

Examples

chan.StopFrequency = 4.5e9 'sets the stop frequency of a linear sweep for the channel object -Write

stopfreq = Chan.StopFrequency 'Read

C++ Syntax

HRESULT get_StopFrequency(double *pVal)
HRESULT put_StopFrequency(double newVal)

Interface

IChannel
ISegment


Stop Power Property

About Power Sweep

StopPower Property

Write/Read

Description

Sets the Stop Power of the analyzer when sweep type is set to Power Sweep. Frequency of the measurement is set with chan.CWFrequency

VB Syntax

chan.StopPower = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Stop Power in dB. Start Power in dB. There is 40 dB of range in power sweep. The acceptable values of start and stop depend on the amount of attenuation that you specify. With 0 dB of attenuation, the range is -20 dBm to +20 dBm. With 10 of attenuation, the range is -30 dBm to +10 dBm, and so forth. Auto attenuation is not allowed in Power Sweep.

Return Type

Double

Default

0

Examples

Chan.StopPower = -10 'Write

stppwr = Chan.StopPower 'Read

C++ Syntax

HRESULT get_StopPower(double *pVal)
HRESULT put_StopPower(double newVal)

Interface

IChannel


About Time Domain

Stop Property

Write/Read

Description

Sets or returns the Stop time of either Gating or Time Domain transform windows

VB Syntax

object.Stop = value

Variable

(Type) - Description

object

(object) As Gating
or
(object) As Transform

value

(double) - Start time in seconds. Choose any number between:
± (number of points-1) / frequency span

Return Type

Double

Default

10 ns

Examples

Trans.Stop = 4.5e-9 'sets the stop time of a transform window -Write
Gate.Stop = 4.5e-9 'sets the stop time of a gating window -Write

stp = Trans.Stop 'Read

C++ Syntax

HRESULT get_Stop(double *pVal)
HRESULT put_Stop(double newVal)

Interface

ITransform
IGating


Sweep Generation Mode Property

About Stepped Sweep

SweepGenerationMode Property

Write/Read

Description

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

VB Syntax

chan.SweepGenerationMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepGenerationModes) - Choose either:

naSteppedSweep - source frequency is CONSTANT during measurement of eah displayed point. More accurate than Analog. Dwell time can be set in this mode.

naAnalogSweep - source frequency is continuously RAMPING during measurement of each displayed point. Faster than Stepped. Sweep time (not dwell time) can be set in this mode.

Return Type

Long Integer

Default

Analog

Examples

Chan.SweepGenerationMode = naAnalogSweep 'Write

swpgen = Chan.SweepGenerationMode 'Read

C++ Syntax

HRESULT get_SweepGenerationMode(tagNASweepGenerationModes* pVal)
HRESULT put_SweepGenerationMode(tagNASweepGenerationModes newVal)

Interface

IChannel


Sweep Time Property

About Sweep Time

SweepTime Property

Write/Read

Description

Sets the Sweep time of the analyzer. Sweep time is limited so that the analyzer only sweeps as fast as possible for the current frequency range, number of points, and IFbandwidth.

VB Syntax

chan.SweepTime = value

Variable

(Type) - Description

chan

A Channel (object)

value

(double) - Sweep time in seconds. Choose a number between:
0 and 100

Return Type

Double

Default

0

Examples

chan.SweepTime = 3e-3 'Write

swptme = chan.SweepTime 'Read

C++ Syntax

HRESULT get_SweepTime(double *pVal)
HRESULT put_SweepTime(double newVal)

Interface

IChannel


Sweep Type Property

About Sweep Types

SweepType Property

Write/Read

Description

Sets the type of X-axis sweep that is performed on a channel.

VB Syntax

chan.SweepType = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NASweepTypes) - Choose from:

naLinearSweep
naPowerSweep
naCWTimeSweep
naSegmentSweep

Note: Sweep type cannot be set to Segment sweep if there are no segments turned ON. A segment is automatically turned ON when a Application application is created.

Return Type

Long Integer

Default

naLinearSweep

Examples

chan.SweepType = naPowerSweep 'Write

swptyp = chan.SweepType 'Read

C++ Syntax

HRESULT get_SweepType(tagNASweepTypes* pVal)
HRESULT put_SweepType(tagNASweepTypes newVal)

Interface

IChannel


About System Impedance

SystemImpedanceZ0 Property

Write/Read

Description

Sets and returns the impedance for the analyzer.

VB Syntax

app.SystemImpedanceZ0 = value

Variable

(Type) - Description

app

An Application (object)

value

(double) Analyzer Impedance. Choose any number between 0 and 1000 ohms.

Return Type

Double

Default

50

Examples

app.SystemImpedanceZ0 = 75 'Write

z0 = app.SystemImpedanceZ0 'Read

C++ Syntax

HRESULT get_SystemImpedanceZ0(double dSystemZ0)
HRESULT put_SystemImpedanceZ0(double *pdSystemZ0)

Interface

IApplication


About Marker Search

TargetValue Property

Write/Read

Description

Sets the target value for the marker when doing Target Searches ( SearchTargetLeft, SearchTarget, SearchTargetRight).

VB Syntax

mark.TargetValue = value

Variable

(Type) - Description

mark

A Marker (object)

value

(single) - Target value. Choose any number between: -500 and 500

Return Type

Single

Default

0

Examples

mark.TargetValue = 10.5 'Write

target = mark.TargetValue 'Read

C++ Syntax

HRESULT get_TargetValue(float *pVal)
HRESULT put_TargetValue(float newVal)

Interface

IMarker


Test Port Power Property

About Power Level

TestPortPower Property

Write/Read

Description

Sets or returns the RF power level for the channel
or
Sets or returns the RF power level of the segment.

VB Syntax

object.TestPortPower(portNum) = value

Variable

(Type) - Description

object

A Channel (object) - to set coupled power, use chan.CouplePorts. If CouplePorts = False, then each port power can be set independently. Otherwise, chanTestPortPower (1) = value sets power level at both ports.
or
A Segment (object)

portNum

(long integer) - Port number of the source power. Choose from 1 or 2

value

(double) - RF Power in dBm. Choose any number between -90 and 20.

Actual achievable leveled power depends on frequency.

Return Type

Double

Default

0

Examples

chan.TestPortPower(1) = 5 'sets the port 1 RF power level for the channel object -Write

powerlev = Chan.TestPortPower(1) 'Read

C++ Syntax

HRESULT get_TestPortPower(long port, double *pVal)
HRESULT put_TestPortPower(long port, double newVal)

Interface

IChannel
ISegment


About Title

Title Property

Write/Read

Description

Writes or reads a custom title for the window. Newer entries replace (not append) older entries.Turn the title ON and OFF with TitleState

VB Syntax

win.Title = string

Variable

(Type) - Description

win

A NaWindow (object)

string

(long) - Title limited to 50 characters.

Return Type

String

Default

Null

Examples

win.Title = "Hello World" 'Write

titl = win.Title 'Read

C++ Syntax

HRESULT get_Title(BSTR *title)
HRESULT put_Title(BSTR title)

Interface

INAWindow


Title State Property

About Titles

TitleState Property

Write/Read

Description

Turns ON and OFF the window title. Write a window title with Title

VB Syntax

win.TitleState = state

Variable

(Type) - Description

win

A NaWindow (object)

state

(boolean)
True (1) - Title ON
False (0) - Title OFF

Return Type

Long Integer
0 - Title OFF
1 - Title ON

Default

0 - OFF

Examples

win.TitleState = True 'Write

titlestate = win.TitleState 'Read

C++ Syntax

HRESULT get_TitleState(VARIANT_BOOL* bState)
HRESULT put_TitleState(VARIANT_BOOL bState)

Interface

INAWindow


Trace Math Property

About Math Operations

TraceMath Property

Write/Read

Description

Performs math operations on the measurement object and the trace stored in memory. (There MUST be a trace stored in Memory to perform math. See Meas.DataToMemory method.)

VB Syntax

meas.TraceMath = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAMathOperation) - Choose from:

0 - naDataNormal
1 - naDataMinusMemory
2 - naDataPlusMemory
3 - naDataDivMemory
4 - naDataTimesMemory

Return Type

NAMathOperation

Default

Normal (0)

Examples

meas.TraceMath = naDataMinusMemory 'Write

mathOperation = meas.TraceMath 'Read

C++ Syntax

HRESULT get_TraceMath(tagNAMathOperation* pMathOp)
HRESULT put_TraceMath(tagNAMathOperation mathOp)

Interface

IMeasurement


About Marker Search

Tracking Property

Write/Read

Description

This property, when on, executes the search function (marker.SearchFunction) every sweep.

In effect, turning Tracking ON is the same as executing one of the immediate, one-time, "Search..." methods (such as SearchMin, SearchMax) for every sweep.

VB Syntax

mark.Tracking = state

Variable

(Type) - Description

mark

A Marker (object)

state

(boolean) - Tracking state. Choose from:
ON (1)
OFF (0)

Return Type

Boolean
0 - Tracking OFF
1 - Tracking ON

Default

0 - OFF

Examples

mark.Tracking = 1 'Write

markTracking = mark.Type 'Read

C++ Syntax

HRESULT put_Tracking(VARIANT_BOOL bOn)
HRESULT get_Tracking(VARIANT_BOOL * pbOn)

Interface

IMarker


About Time Domain

Mode Property

Write/Read

Description

Sets the type of transform.

VB Syntax

trans.Mode = value

Variable

(Type) - Description

trans

A Transform (object)

value

(enum NATransformMode) - Choose from:

0 - naTransformBandpassImpulse
1 - naTransformLowpassImpulse
2 - naTransformLowpassStep

Return Type

NATransformMode

Default

0 - naTransformBandpassImpulse

Examples

trans.Mode = naTransformLowpassStep 'Write

transmode = trans.Mode 'Read

C++ Syntax

HRESULT get_Mode(tagNATransformMode *pVal)
HRESULT put_Mode(tagNATransformMode newVal)

Interface

ITransform


Trigger Mode Property

About Triggering

TriggerMode Property

Write/Read

Description

Each trigger signal will cause either:
all measurements in the channel to be made or
only a single data point in the channel at a time.

VB Syntax

chan.TriggerMode = value

Variable

(Type) - Description

chan

A Channel (object)

value

(enum NATriggerMode) - Choose from:

naTriggerModeMeasurement - all measurements in the channel are made with each trigger signal the channel receives.
naTriggerModePoint - a single data point is measured with each trigger signal the channel receives. Subsequent trigger signals continue to go to the channel in Point mode until the channel measurements are complete.

Note: Point Mode is only available in Manual trigger and TriggerType set to naGlobalTrigger. If you change any channel to TriggerModePoint, TriggerType will be set to naChannelTrigger.

Return Type

Long Integer

Default

0 - naTriggerModeMeasurement

Examples

app.TriggerMode = naTriggerModePoint 'Write

trigtyp = app.TriggerMode 'Read

C++ Syntax

HRESULT get_TriggerMode (tagNATriggerMode *pMode)
HRESULT put_TriggerMode (tagNATriggerMode newMode)

Interface

IChannel


Trigger Signal Property

About Trigger Source

TriggerSignal Property

Write/Read

Description

Sets or returns the trigger source.

VB Syntax

app.TriggerSignal = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerSignal) - Choose from:

naTriggerInternal - free run

naTriggerExternalPositive - an external source that supplies a positive going signal

naTriggerExternalNegative - an external source that triggers on a negative signal

naTriggerManual - manual trigger source; use app.ManualTrigger to send a trigger signal.

Return Type

Long Integer

Default

naTriggerInternal

Examples

app.TriggerSignal = naTriggerExternalPositive 'Write

trigsign = app.TriggerSignal 'Read

C++ Syntax

HRESULT get_TriggerSignal(tagNATriggerSignal *pSignal)
HRESULT put_TriggerSignal(tagNATriggerSignal signal)

Interface

IApplication


Trigger Type Property

About Trigger

TriggerType Property

Write/Read

Description

Sets or returns the trigger type which determines the scope of a trigger signal.

Note: Point (Trigger Mode) is only available in Manual trigger and Channel (Trigger Type). If you change any channel to Global Trigger, Trigger Mode will be set to Measurement.

VB Syntax

app.TriggerType = value

Variable

(Type) - Description

app

An Application (object)

value

(enum NATriggerType) - Trigger type. Choose from:
naGlobalTrigger - a trigger signal is applied to all triggerable channels
naChannelTrigger - a trigger signal is applied to the current channel. The next trigger signal will be applied to the next channel; not necessarily channel 1-2-3-4.

Return Type

Long Integer

Default

naGlobalTrigger

Examples

app.TriggerType = naGlobalTrigger 'Write

trigtyp = app.TriggerType 'Read

C++ Syntax

HRESULT get_TriggerType(tagNATriggerType *pTrigger)
HRESULT put_TriggerType(tagNATriggerType trigger)

Interface

IApplication


About Modifying Cal Kits

Type (calstd) Property

Write/Read

Description

Sets and Returns the type of calibration standard.

VB Syntax

calstd.Type = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(enum NACalStandardType) -Choose from:
0 - naOpen
1 - naShort
2 - naLoad
3 - naThru

Return Type

Long Integer

Default

Not Applicable

Examples

calstd.Type = naOpen 'Write

standardtype = calstd.Type 'Read

C++ Syntax

HRESULT get_Type(tagNACalStandardType *pVal)
HRESULT put_Type(tagNACalStandardType newVal)

Interface

ICalStandard


User Range Property

About User Ranges

UserRange Property

Write/Read

Description

Assigns the marker to the specified User Range. This restricts the marker's x-axis travel to the User Range span, specified with Start and Stop values.

  • Each channel has 10 user ranges.

  • Markers and trace statistics can be restricted to any user range.

  • More than one marker can occupy a user range.

  • User ranges can overlap. For example:

    • User range 1 - 3GHz to 5GHz

    • User range 2 - 4GHz to 6GHz

Note: User ranges are especially useful in restricting marker searches to specific areas of the measurement.

VB Syntax

mark.UserRange = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - User Range. Choose any number between:
0 and 9 (0=Full Span)

Return Type

Long Integer

Default

0 - Full Span

Examples

mark.UserRange = 1 'Write

UseRnge = mark.UserRange 'Read

C++ Syntax

HRESULT get_UserRange(long *pRangeNumber)
HRESULT put_UserRange(long lRangeNumber)

Interface

IMarker


User Range Max Property

About User Ranges

UserRangeMax Property

Write/Read

Description

Sets the stimulus stop value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMax(domainType,Mnum) = value
or
mark.UserRangeMax(rnum) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the "DomainType" argument.

domainType

(enum NADomainType) - Choose from:

naDomainFrequency
naDomainPower
naDomainTime

Mnum

(long integer) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Stop value. Choose any number within the full span of the channel

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMax(1) = 3e9 'Write
chan.UserRangeMax(naDomainFrequency,1) = 3e9 'Write

UseRngeMax = mark.UserRangeMax 'Read
UseRngeMax = chan.UserRangeMax 'Read

C++ Syntax

HRESULT put_UserRangeMax(tagNADomainType domain, long rangeNumber, double maxValue)
HRESULT get_UserRangeMax(tagNADomainType domain, long rangeNumber, double *maxValue)

Interface

IChannel


User Range Min Property

About User Ranges

UserRangeMin Property

Write/Read

Description

Sets the stimulus start value for the specified User Range.

This property uses different arguments for the channel and marker objects.

VB Syntax

chan.UserRangeMin(domainType,range) = value
or
mark.UserRangeMin(range) = value

Variable

(Type) - Description

chan

A Channel (object)

mark

A Marker (object)
To assign a marker to a User Range, use the UserRange Property.

Note: The Marker object does not require the DomainType argument

domainType

(enum NADomainType) Type of sweep currently implemented on the channel - Choose from:
naDomainFrequency
naDomainPower
naDomainTime

range

(long) - User Range number. Choose any number between 1 and 9 (0=Full Span)

value

(double) - Start value. Choose any number within the full span of the analyzer

Return Type

Double

Default

The current stimulus setting for the channel

Examples

mark.UserRangeMin(1) = 3e9 'Write
chan.UserRangeMin(naDomainFrequency,1) = 3e9 'Write

UseRngeMin = mark.UserRangeMin 'Read
UseRngeMin = chan.UserRangeMin 'Read

C++ Syntax

HRESULT put_UserRangeMin(tagNADomainType domain, long rangeNumber, double minValue)
HRESULT get_UserRangeMin(tagNADomainType domain, long rangeNumber, double *minValue)

Interface

IChannel


Velocity Factor Property

About Port Extensions

VelocityFactor Property

Write/Read

Description

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

VB Syntax

app.VelocityFactor = value

Variable

(Type) - Description

app

An Application (object)

value

(double) - Velocity factor. Choose a number between: 0 and 10
(.66 polyethylene dielectric; .7 teflon dielectric)

Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.

Return Type

Double

Default

1

Examples

app.VelocityFactor = .66 'Write

RelVel = app.VelocityFactor 'Read

C++ Syntax

HRESULT get_VelocityFactor(double *pVal)
HRESULT put_VelocityFactor(double newVal)

Interface

IApplication


About Math Operations

View Property

Write/Read

Description

Sets (or returns) the type of trace displayed on the screen.

VB Syntax

meas.View = value

Variable

(Type) - Description

meas

A measurement (object)

value

(enum NAView) - Type of trace. Choose from:

0 - naData
1 - naDataAndMemory
2 - naMemory
3 - naNoTrace

Note: The naData trace may reflect the result of a TraceMath operation.

Return Type

NAView

Default

naData

Examples

meas.View = naData 'Write

trceview = meas.View 'Read

C++ Syntax

HRESULT get_View(tagNAView* pView)
HRESULT put_View(tagNAView newView)

Interface

IMeasurement


Visible Property

Write/Read

Description

Makes the Network Analyzer application visible or not visible. In the Not Visible state, the analyzer cycle time for making measurements can be significantly faster because the display does not process data.

VB Syntax

app.Visible = state

Variable

(Type) - Description

app

An Application (object)

state

(boolean)
0 - Network Analyzer application NOT visible
1 - Network Analyzer application IS visible

Return Type

Boolean
0 - Not visible
1 - visible

Default

1

Examples

app.Visible = 0 'Write

vis = app.Visible 'Read

C++ Syntax

HRESULT get_Visible(VARIANT_BOOL * bVisible)
HRESULT put_Visible(VARIANT_BOOL bVisible)

Interface

IApplication


Window State Property

About Arranging Windows

WindowState Property

Write/Read

Description

Sets or returns the window setting of Maximized, Minimized, or Normal. To arrange all of the windows, use app.ArrangeWindows.

VB Syntax

object.WindowState = value

Variable

(Type) - Description

object

An Application (object) - main window
or
A NaWindow (object) - data windows

value

(enum NAWindowStates) - The window state. Choose from:
naMaximized - Maximizes the window
naMinimized - Minimizes the window to an Icon on the lower toolbar
naNormal - changes the window size to the user defined setting (between Max and Min).

Return Type

Long Integer

Default

naMaximized

Examples

app.WindowState = naMinimized 'changes the Network Analyzer application window to an icon. -Write
win.WindowState = naNormal 'changes the window defined by the win object variable to user defined settings. -Write

winstate = app.WindowState 'Read

C++ Syntax

HRESULT get_WindowState(tagNAWindowStates *pVal)
HRESULT put_WindowState(tagNAWindowStates newVal)

Interface

INAWindow
IApplication


About Scale

YScale Property

Write/Read

Description

Sets or returns the Y-axis Per-Division value of the active trace.

VB Syntax

trace.YScale = value

Variable

(Type) - Description

trace

A Trace (object)

value

(double) - Scale /division number. Units and range depend on the current data format.

Return Type

Double

Default

10 (db)

Examples

trac.YScale = 5 'Write

yscl = trac.YScale 'Read

C++ Syntax

HRESULT get_YScale(double *pVal)
HRESULT put_YScale(double newVal)

Interface

ITrace


About Modifying Cal Kits

Z0 Property

Write/Read

Description

Sets and Returns the characteristic impedance for the calibration standard.

VB Syntax

calstd.Z0 = value

Variable

(Type) - Description

calstd

A CalStandard (object). Use calKit.GetCalStandard to get a handle to the standard.

value

(single) -Impedance in Ohms

Return Type

Single

Default

Not Applicable

Examples

calstd.Z0 = 50 'Write

impedance = calstd.Z0 'Read

C++ Syntax

HRESULT get_Z0(float *pVal)
HRESULT put_Z0(float newVal)

Interface

ICalStandard


About Triggering

Abort Method

Write-only

Description

Ends the current measurement sweep on the channel.

VB Syntax

chan.Abort [sync]

Variable

(Type) - Description

chan

(object) - A Channel object

sync

(boolean) - wait (or not) for the analyzer to stop before processing subsequent commands. Optional argument; if unspecified, value is set to False. Choose from:
True - synchronize - the analyzer will not process subsequent commands until the current measurement is aborted.
False - continue processing commands immediately

Return Type

None

Default

None

Examples

chan.abort True
chan.abort

C++ Syntax

HRESULT raw_Abort(VARIANT_BOOL bSynchronize);

Interface

IChannel


Acquire Cal Standard Method

About Calibration Standards

AcquireCalStandard Method

Write-only

Description

Measures the specified standard from the selected calibration kit. The calibration kit is selected using app.CalKitType.

For 2-port calibration, it is also necessary to specify direction with AcquisitionDirection.

VB Syntax

cal.AcquireCalStandard std[,index]

Variable

(Type) - Description

cal

A Calibrator (object)

std

(enum NACalClass) Standard to be measured. Choose from:

naClassA

naClassB

naClassC

naClassD

naClassE

naReferenceRatioLine

naReferenceRatioThru

naSOLT_Isolation

SOLT Standards

naSOLT_Open

naSOLT_Short

naSOLT_Load

naSOLT_Thru

TRL Standards

naTRL_Reflection

naTRL_Line_Reflection

naTRL_Line_Tracking

naTRL_Thru

naTRL_Isolation

index

(long integer) number of the standard. Optional argument - Used if there is more than one standard required to cover the necessary frequency range. If unspecified, value is set to 0.

Return Type

None

Default

Not Applicable

Examples

Cal.AcquireCalStandard naSOLT_Thru 'Write

C++ Syntax

HRESULT raw_AcquireCalStandard(tagNACalClass enumClass, short standardNumber)

Interface

ICalibrator


Activate Method

Write-only

Description

Makes an object the Active Object. When making a measurement active, the channel and window the measurement is contained in becomes the active channel and active window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Getting a Handle to an Object.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

object.Activate

Variable

(Type) - Description

object

Measurement (object)
or
Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Activate
mark.Activate

C++ Syntax

HRESULT raw_Activate()

Interface

IMeasurement
IMarker


Activate Marker Method

About Markers

ActivateMarker Method

Write-only

Description

Makes a marker the Active Marker. Use meas.ActiveMarker to read the number of the active marker.

VB Syntax

meas.ActivateMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long integer) - the number of the marker to make active. Choose any marker number from 1 to 9.

Return Type

None

Default

Not Applicable

Examples

meas.ActivateMarker(1)'Write

C++ Syntax

HRESULT raw_ActivateMarker(long lMarkerNumber)

Interface

IMeasurement

Remarks

Use ReferenceMarkerState to control the Reference marker.


About Windows

ActivateWindow Method

Write-only

Description

Makes a window object the Active Window.

In order to change properties on any of the active objects, you must first have a "handle" to the active object using the Set command. For more information, See Programming the Analyzer Object Model.

You do not have to make an object "Active" to set or read its properties remotely. But an object must be "Active" to change its values from the front panel.

VB Syntax

app.ActivateWindow n

Variable

(Type) - Description

app

An Application (object)

n

(long) Number of the window to make active

Return Type

Window Object

Default

Not Applicable

Examples

app.ActivateWindow 4

C++ Syntax

HRESULT raw_ActivateWindow(long WindowNumber)

Interface

IApplication


About Channels

Add (channels) Method

Write-only

Description

Creates a channel and returns a handle to it. If the channel already exists, it returns the handle to the existing channel.

VB Syntax

chans.Add (item)

Variable

(Type) - Description

chans

A Channel collection (object)

item

(variant) - Channel number.

Return Type

Channel

Default

Not Applicable

Examples

chans.Add 3 'Creates channel 3

C++ Syntax

HRESULT raw_Add(VARIANT numVal, IChannel** pChannel)

Interface

IChannels


About Multiple Measurements

Add (measurement) Method

Write-only

Description

Adds a Measurement to the collection.

VB Syntax

meass.Add channel,param,source[,window]

meass

A Measurements collection (object)

channel

(long) - Channel number of the new measurement.

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

source

(long integer) - Source port number; if unspecified, value is set to 1. Only used for non-s-parameter measurements; ignored if s-parameter.

window

(long integer) - Optional - if unspecified, value is set to 0
-1: creates a new window
0 : current window
n : new window number (n) - creates if necessary

Return Type

None

Default

None

Examples

meass.Add 3,"A/R1",1,1 'Adds A/R1 measurement to channel 3 in window 1

C++ Syntax

HRESULT raw_Add(long ChannelNum, BSTR strParameter, long srcPort, VARIANT_BOOL bNewWindow)

Interface

IMeasurements


About Windows

Add (NAWindows) Method

Write-only

Description

Add a window to the display. Does not add a measurement. The window number must not already exist.

VB Syntax

wins.Add [item]

Variable

(Type) - Description

wins

A NAWindow collection (object)

item

(variant) - optional argument; Window number. Range between 1 - 4

Return Type

Object

Default

Not Applicable

Examples

wins.Add 3 'Creates a window number 3

C++ Syntax

HRESULT raw_Add(long windowNumber )

Interface

INAWindows


Add (segments) Method

About Segment Sweep

Add (segment) Method

Write-only

Description

Adds segments to the Segments collection, but does not turn the segments ON.

VB Syntax

segs.Add (item, [size])

segs

A segments collection (object)

item

(variant) Number of the new segment. If it already exists, a new segment is inserted at the requested position.

size

(long integer) Optional argument. The number of segments to add, starting with item. If unspecified, value is set to 1.

Return Type

None

Default

None

Examples

Segs.Add 1, 4 'Adds segments 1,2,3,and 4. (does NOT automatically turn segments ON)

C++ Syntax

HRESULT raw_Add(VARIANT index, long size);

Interface

ISegments

Remarks

To ensure predictable results, it is best to remove all segments before defining a segment list. For each segment in the collection, do a seg.Remove.


About Analyzer Events

AllowAllEvents Method

Write/Read

Description

Sets event filtering to monitor all events in the analyzer. This is the default setting when subscribing to events. This could slow the measurement speed of the analyzer significantly.

VB Syntax

app.AllowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowAllEvents

C++ Syntax

HRESULT AllowAllEvents()

Interface

IApplication


About Analyzer Events

AllowEventCategory Method

Write/Read

Description

Sets event filtering to monitor a category of event.

VB Syntax

app.AllowEventCategory, category, state

Variable

(Type) - Description

app

An Application (object)

category

Category to monitor. Choose from list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventCategory

C++ Syntax

HRESULT AllowEventCategory(tagNAEventCategory category, VARIANT_BOOL bAllow )

Interface

IApplication

Type topic text here.


About Analyzer Events

AllowEventMessage Method

Write/Read

Description

Sets event filtering to monitor specific events.

VB Syntax

app.AllowEventMessage event

Variable

(Type) - Description

app

An Application (object)

event

Event to monitor. Refer to list in Working with the Analyzer's Events

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventMessage

C++ Syntax

HRESULT AllowEventMessage( tagNAEventID eventID, VARIANT_BOOL bAllow)

Interface

IApplication


About Analyzer Events

AllowEventSeverity Method

Write/Read

Description

Sets event filtering to monitor levels of severity.

VB Syntax

app.AllowEventSeverity severity,state

Variable

(Type) - Description

app

An Application (object)

severity

(enum naEventSeverity) Choose from:naEventSeverityERROR
naEventSeverityINFORMATIONAL
naEventSeveritySUCCESS
naEventSeverityWARNING

state

(boolean)
True - monitor
False - do not monitor

Return Type

Not Applicable

Default

Not Applicable

Examples

app.AllowEventSeverity

C++ Syntax

HRESULT AllowEventSeverity( tagNAEventSeverity severity, VARIANT_BOOL bAllow)

Interface

IApplication


About Display Formatting

Autoscale Method

Write-only

Description

Autoscales the trace (Trace object) or all of the traces (NAWindow object).

VB Syntax

object.Autoscale

Variable

(Type) - Description

object

Trace (object)
or
NAWindow (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Trac.Autoscale 'Autoscales the trace
Win.Autoscale 'Autoscales all the traces in the window -Write

C++ Syntax

HRESULT raw_AutoScale()

Interface

INAWindow
ITrace


Averaging Restart Method

About Averaging

AveragingRestart Method

Write-only

Description

Clears and restarts averaging of the measurement data.

VB Syntax

chan.AveragingRestart

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.AveragingRestart

C++ Syntax

HRESULT raw_AveragingRestart()

Interface

IChannel


Build Hybrid Kit Method

About Modifying Cal Kits

BuildHybridKit Method

Write-only

Description

Use this method when you have different port connectors. This is a convenient way to combine two kits that match the connectors on your DUT.

VB Syntax

app.BuildHybridKit port1Kit,p1sex,port2Kit,p2sex,adapter,user kit

Variable

(Type) - Description

app

An Application (object)

port1Kit
port2Kit

(enum NACalKit) - Specifies the two kits to be used to build the hybrid kit. Choose from:

naCalKit_85032F_N50
naCalKit_85033E_3_5
naCalKit_85032B_N50
naCalKit_85033D_3_5
naCalKit_85038A_7_16
naCalKit_85052C_3_5_TRL
naCalKit_User7
naCalKit_User8
naCalKit_User9
naCalKit_User10

p1sex
p2sex

(enum NAPortSex) - Specifies the sex of the connector at that port. Choose from:
naMale
naFemale
naDon'tCare

adapter

(enum NAAdapter) -Choose from:
naUserkit - the electrical length of the adapter in the userKit specifications
naZeroLength - no adapter

userKit

(enum NACalKit) - The Hybrid kit - Choose from the previous list of kits

Return Type

Not Applicable

Default

Not Applicable

Examples

app.BuildHybridKit naCalKit_85033E_3_5,naMale,naCalKit_85038A_7_16
,naFemale,naUserkit,naCalKit_User8

C++ Syntax

HRESULT raw_BuildHybridKit\(tagNACalKit port1Kit, tagNAPortSex port1Sex, tagNACalKit port2Kit, tagNAPortSex port2Sex, tagNAAdapter adapter, tagNACalKit userKit)

Interface

IApplication


Calculate Error Coefficients Method

About Performing a Calibration

CalculateErrorCoefficients Method

Write-only

Description

This method is the final call in a calibration process. It calculates error-correction terms and turns error-correction ON.

VB Syntax

cal.CalculateErrorCoeffecients

Variable

(Type) - Description

cal

Calibrator (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

Cal.CalculateErrorCoeffecients

C++ Syntax

HRESULT raw_CalculateErrorCoefficients()

Interface

ICalibrator


Change Parameter Method

About Measurement Parameters

ChangeParameter Method

Write-only

Description

Changes the parameter of the measurement.

VB Syntax

meas.ChangeParameter(param,sourcePort)

Variable

(Type) - Description

meas

A Measurement (object)

param

(string) - New parameter. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine any 2 of (A,B,R1,R2) in this format: "A/R1"

sourcePort

(long integer) - Port number of the source. Used only for non-sparameter measurements.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.ChangeParameter "S11",1

C++ Syntax

HRESULT raw_ChangeParameter(BSTR parameter, long sourcePort)

Interface

IMeasurement


About Triggering

Continuous Method

Write-only

Description

The channel continuously responds to trigger signals.

Note: This command does NOT change TriggerSignal to Continuous.

VB Syntax

chan.Continuous

Variable

(Type) - Description

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.Continuous

C++ Syntax

HRESULT raw_Continuous()

Interface

IChannel


Create SParameter Method

About Measurement Parameters

CreateS-Parameter Method

Write-only

Description

Creates a new S-Parameter measurement in an existing or new window.

VB Syntax

app.CreateSParameter chan,recvr,source,[window]

Variable

(Type) - Description

app

Application (object)

chan

(long integer) - Channel number of the new measurement

recvr

(long integer) - Port number of the receiver (1 or 2)

source

(long integer) - Port number of the source (1 or 2)

window

(long integer) - Window number of the new measurement. Choose 1 to 4. If unspecified, the S-Parameter will be created in the Active Window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateSParameter 1,2,1,1 'Creates a new S21 measurement in channel 1 and New window(1) app.CreateSParameter 1,2,1 'Creates a new S21 measurement in channel 1 and in the active window

C++ Syntax

HRESULT raw_CreateSParameter(long ChannelNum, long RcvPort, long SrcPort, long windowNumber)

Interface

IApplication


About Measurement Parameters

CreateMeasurement Method

Write-only

Description

Creates a new measurement.

VB Syntax

app.CreateMeasurement chanNum,param,src[,window]

Variable

(Type) - Description

app

Application (object)

chanNum

(long) - Channel number of the new measurement; can exist or be a new channel

param

(string) - Parameter of the new measurement. Choose from:

  • "S11"

  • "S22"

  • "S21"

  • "S12"

  • "A"

  • "B"

  • "R1"

  • "R2"
or

  • combine 2 of (A,B,R1,R2) in this format: "A/R1"

src

(long) - Source Port. Choose 1 or 2 (ignored if param = Sparameter)

window

(long) Optional argument. Number of the window the measurement will be in. Choose 1 to 4. If unspecified, window is the active window.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.CreateMeasurement(1,"A/R1",1,0)

C++ Syntax

HRESULT raw_CreateMeasurement(long ChannelNum, BSTR strParameter, long srcPort, long windowNumber)

Interface

IApplication


About Math Operations

DataToMemory Method

Write-only

Description

Stores the active measurement data into memory creating a memory trace. The memory can then be displayed or used in calculations with the measurement data.

VB Syntax

meas.DataToMemory

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DataToMemory

C++ Syntax

HRESULT raw_DataToMemory()

Interface

IMeasurement


About Measurement Parameters

Delete Method

Write-only

Description

Deletes the measurement.

VB Syntax

meas.Delete

Variable

(Type) - Description

meas

The Measurement object to delete (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.Delete

C++ Syntax

HRESULT raw_Delete()

Interface

IMeasurement


Delete Marker Method

About Markers

DeleteMarker Method

Write-only

Description

Deletes a marker from the measurement.

VB Syntax

meas.DeleteMarker(Mnum)

Variable

(Type) - Description

meas

A Measurement (object)

Mnum

(long) - Any existing marker number in the measurement

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteMarker(1)

C++ Syntax

HRESULT raw_DeleteMarker(long lMarkerNumber)

Interface

IMeasurement


About Markers

DeleteAllMarkers Method

Write-only

Description

Deletes all of the markers from the measurement.

VB Syntax

meas.DeleteAllMarkers

Variable

(Type) - Description

meas

(object) - The Measurement object from which markers will be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.DeleteAllMarkers

C++ Syntax

HRESULT raw_DeleteAllMarkers()

Interface

IMeasurement


About Macros

DeleteShortCut Method

Write-only

Description

Removes a macro from the list of macros in the analyzer. Does not remove the file.

Note: There are always 12 macro positions. They do not have to be sequential. For example, you can have number 7 but no numbers 1 to 6.

VB Syntax

app.DeleteShortCut item

Variable

(Type) - Description

app

An Application (object)

item

(long integer) number of the macro to be deleted.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DeleteShortCut 2

C++ Syntax

HRESULT DeleteShortcut(long Number )

Interface

IApplication


About Reference Markers

DeltaMarker Property

Write/Read

Description

Sets a marker as a delta marker. The reference marker must already be turned ON. See meas.ReferenceMarkerState

VB Syntax

mark.DeltaMarker = state

Variable

(Type) - Description

app

A Marker (object)

state

(boolean) -
ON (1) marker is a delta marker
OFF (0) marker is NOT a delta marker

Return Type

Boolean

Default

OFF (0)

Examples

mark.DeltaMarker = True 'Write

delta = mark.DeltaMarker 'Read

C++ Syntax

HRESULT get_DeltaMarker(VARIANT_BOOL bState)
HRESULT put_DeltaMarker(VARIANT_BOOL *bState)

Interface

IMarker


About Analyzer Events

DisallowAllEvents Method

Write/Read

Description

Sets event filtering to monitor NO eventst.

VB Syntax

app.DisallowAllEvents

Variable

(Type) - Description

app

An Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DisallowAllEvents

C++ Syntax

HRESULT raw_DisallowAllEvents()

Interface

IApplication

Type topic text here.


Do Print Method

About Printing

DoPrint Method

Write-only

Description

Prints the screen to the default Printer.

VB Syntax

app.DoPrint

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.DoPrint

C++ Syntax

HRESULT raw_DoPrint()

Interface

IApplication


About Calibration

DoECAL1Port Method

Write-only

Description

Does a 1-Port calibration using an ECAL module. You must first have a 1-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL1Port[,port][,module]

Variable

(Type) - Description

app

A Calibrator (object)

port

(long integer) Optional argument - Port number to calibrate. Choose from:
1 - Calibrate port 1 (default if unspecified)
2 - Calibrate port 2

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL1Port,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL1Port(long port, tagNAECALModule ecalModule)

Interface

ICalibrator


About Calibration

DoECAL2Port Method

Write-only

Description

Does a 2-Port calibration using an ECAL module. You must first have a 2-port measurement active to perform the calibration.

VB Syntax

cal.DoECAL2Port[,portA][,portB][,module]

Variable

(Type) - Description

app

A Calibrator (object)

portA

(long integer) Optional argument - Receiver ports to calibrate. Choose from:
1 - port 1 (default if unspecified)
2 - port 2

portB

(long integer) Optional argument - Source port to calibrate. Choose from:
1 - port 1
2 - port 2 (default if unspecified)

module

(enum NAEcalModule) Optional argument - ECAL module. Choose from:

naECALModule_A - (default if unspecified)
naECALModule_B

Return Type

Not Applicable

Default

Not Applicable

Examples

cal.DoECAL2Port,1,2,naECALModule_B

C++ Syntax

HRESULT raw_DoECAL2Port(long rcvport, long srcPort, tagNAECALModule ecalModule)

Interface

ICalibrator


Execute Shortcut Method

About Macros

ExecuteShortcut Method

Write-only

Description

Executes a Macro (shortcut) stored in the analyzer. Use app.getShortcut to list existing macros. Use app.putShortcut to associate the macro number with the file.

VB Syntax

app.ExecuteShortcut index

Variable

(Type) - Description

app

Application (object)

index

(long integer) - Number of the macro stored in the analyzer.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ExecuteShortcut 1

C++ Syntax

HRESULT raw_ExecuteShortcut(long index)

Interface

IApplication


Get Cal Standard Method

About Modifying Cal Kits

GetCalStandard Method

Write-only

Description

Returns a handle to a calibration standard for modifying its definitions. To select a standard for performing a calibration (use Calibrator. AquireCalStandard ).

VB Syntax

calkit.GetCalStandard(index)

Variable

(Type) - Description

calkit

A calKit (object)

index

(long) - Number of calibration standard. Choose 1 to 8; (there are 8 cal standards in every kit).

Return Type

calStandard

Default

Not Applicable

Examples

Dim short As CalStandard
Set short = calKit.getCalStandard(1)
short.label = "myShort"

C++ Syntax

HRESULT raw_GetCalStandard(long standardNumber, ICalStandard **pCalStd)

Interface

ICalKit


Get Complex Method

Data Access Map

GetComplex Method

Read-only

Description

Retrieves complex data from the specified location.
See also getNAComplex , getData , and getPairedData Methods

VB Syntax

measData.getComplex location, numPts, real(), imag()

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the arrays

real

(single) - Array to store the real values

imag

(single) - Array to store the imaginary values

Return Type

Single

Default

Not Applicable

Examples

Dim real(201) AS Single
Dim imag(201) AS Single
Dim pts as Integer
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
measData.getComplex naCorrectedData, pts, real(0), imag(0)

C++ Syntax

HRESULT raw_getComplex(tagNADataStore DataStore, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Data Method

About Accessing Data

GetData Method

Read-only

Description

Retrieves variant data from the specified location in your choice of formats.

Note: This method returns a variant which is less efficient than methods available on the IArrayTransfer interface.

Note: If you plan to Put this data back into analyzer, putDataComplex (variant data) method requires complex, two-dimensional data. Therefore, request the data in Polar format.

VB Syntax

data = meas.GetData location, format

Variable

(Type) - Description

data

Variant array to store the data.

meas

A Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NADataFormat) - Format in which you would like the data. It does not have to be the displayed format. Choose from:

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Polar *

  • naDataFormat_Smith *

  • naDataFormat_Delay

  • naDataFormat_Real

  • naDataFormat_Imaginary

  • naDataFormat_SWR

* Specfiy Smith or Polar formats to obtain complex data pairs, which require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All scalar formats return a single dimension varData(numpts).

Return Type

Variant array - automatically dimensioned to the size of the data

Default

Not Applicable

Examples

Dim varData As Variant
varData = meas.GetData(naMeasResult,naDataFormat_Phase)
'Print Data
For i = 0 to chan.NumberOfPoints-1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_getData(tagNADataStore DataStore, tagDataFormat DataFormat, VARIANT *pData)

Interface

IMeasurement


Get ECAL Module Info Method

GetECALModuleInfo Method

Read-only

Description

Returns the following information about the connected ECAL module: model number, serial number, connector type,calibration date, min and max frequency.

VB Syntax

module = cal.GetECALModuleInfo

Variable

(Type) - Description

module

(string) - variable to store the module information

cal

A Calibrator (object)

Return Type

String - Returned information:

Default

Not Applicable

Examples

info = cal.GetECALModuleInfo

Example return string:

ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F RF2, Calibrated: 5 Jun 2000 , MinFreq: 50000000, MaxFreq: 9100000000

C++ Syntax

HRESULT raw_GetECALModuleInfo(tagNAECALModule ecalModule, BSTR* info)

Interface

ICalibrator


Get Error Term Complex Method

About Accessing Data

GetErrorTermComplex Method

Read-only

Description

Retrieves error term data from the error correction buffer.The data is in complex pairs.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetErrorTerm Method on ICalibrator.

VB Syntax

eData.GetErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

eData

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the error-term. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the error-term. One-dimensional for the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2

Return Type

Single

Default

Not Applicable

Examples

ReDim rel(numpts)
ReDim img(numpts)
Dim eData As ICalData
Set eData = chan.Calibrator
eData.getErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_getErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Error Term Method

About Measurement Calibration

GetErrorTerm Method

Read-only

Description

Retrieves error term data that is used for error correction. The data is complex pairs. Memory for the returned Variant is allocated by the server. The server returns a variant containing a two-dimensional safe Array.

Note: This method returns a variant which is less efficient than getErrorTermComplex on the ICalData interface.

VB Syntax

data = cal.getErrorTermterm, src, rcv

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

term

(enum As NaErrorTerm). Choose from:

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Variant

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.getErrorTerm(naErrorTerm_Tracking,2,1)

C++ Syntax

HRESULT raw_getErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Filter Statistics Method

About Marker Search

GetFilterStatistics Method

Read-only

Description

Returns all four Filter Statistics resulting from a SearchFilterBandwidth.
To retrieve individual filter statistics, use meas.FilterCF, meas.FilterBW, meas.FilterLoss, meas.FilterQ properties.

VB Syntax

meas.GetFilterStatistics cf,bw,loss,q

Variable

(Type) - Description

meas

A Measurement (object)

cf,bw,loss,q

Dimensioned variables to store the returned values

Return Type

(double) cf
(single) bw,loss,q

Default

Not Applicable

Examples

'Dimension variables
Dim cf as Double
Dim bw as Single
Dim loss as Single
Dim q as Single

meas.GetFileterStatistics cf,bw,loss,q

C++ Syntax

HRESULT raw_GetFilterStatistics(double* centerFreq, float* bw, float* loss, float* quality)

Interface

IMeasurement


Get NAComplex Method

About Accessing Data

GetNAComplex Method

Read-only

Description

Retrieves complex data from the specified locations.
See also getComplex and getData Method.

VB Syntax

measData.getNAComplex location, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dComplex array

data

(NAComplex) - A one-dimensional array of NaComplex to store the data.

Return Type

NAComplex

Default

Not Applicable

Examples

Dim dComplex(201) AS NaComplex
Dim measData As IArrayTransfer
Dim pts as Long
Set measData = app.ActiveMeasurement
measData.getNAComplex naCorrectedData, pts, dComplex(0)

Notes

The data is stored as Real and Imaginary (Re and Im) members of the NaComplex user defined type. You can access each number individually by iterating through the array.

For i = 0 to NumPts-1
dReal (i) = dcomplex (i).Re
dImag (i) = dcomplex (i).Im
Next i

C++ Syntax

HRESULT raw_getNAComplex(tagNADataStore DataStore, long* pNumValues, TsComplex* pComplex)

Interface

IArrayTransfer


Get Paired Data Method

About Accessing Data

GetPairedData Method

Read-only

Description

Retrieves pairs of data from specified location.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

VB Syntax

measData.getPairedData location, format, numPts, d1, d2

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum NAPairedDataFormat) - Format in which you would like the Paired data. Choose from:

  • naLinMagPhase - Linear magnitude and phase

  • naLogMagPhase - Log magnitude and phase

  • naRealImaginary - Real and Imaginary

Note: Selecting naRealImaginary format is the same as using the getComplex method

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dPaired array

d1

(single) - Array to store the magnitude / real values

d2

(single) - Array to store the phase / imaginary values

Return Type

Two Single arrays

Default

Not Applicable

Examples

Dim logm() As Single
Dim phase() As Single
Public measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts As Long
numPoints = app.ActiveChannel.NumberOfPoints
ReDim logm(numPoints)
ReDim phase(numPoints)

measData.getPairedData naCorrectedData, naLogMagPhase, numPoints, logm(0),
 phase(0)

Print values(0), values(1)

C++ Syntax

HRESULT raw_getPairedData(tagNADataStore DataStore, tagNAPairedDataFormat PairFormat, long* pNumValues, float* pReal, float* pImag)

Interface

IArrayTransfer


Get Reference Marker Method

About Reference Markers

GetReferenceMarker Method

Write/Read

Description

Returns a handle to the reference marker.

VB Syntax

meas.GetReferenceMarker

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Object

Default

Not Applicable

Examples

meas.GetReferenceMarker

C++ Syntax

HRESULT raw_GetReferenceMarker(IMarker** refMarker)

Interface

IMeasurement


Get Scalar Method

About Accessing Data

GetScalar Method

Read-only

Description

Retrieves scalar data from the specified locations.

Note: This method exists on a non-default interface. If you cannot access this method, use the Get Data Method on IMeasurement.

Note: You can NOT use this command to get complex data.

VB Syntax

measData.getScalar location, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) - Where the data you want is residing. Choose from:

0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

format

(enum DataFormat) - Scalar format in which you would llike the data. Choose from:

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

numPts

(long integer) - Number of data points requested
[out] - specifies number of data elements returned
[in] - specifies the data being requested or the capacity of the dScalar array

data

(single) - Array to store the scalar data.

Return Type

Single

Default

Not Applicable

Examples

Dim dScalar() As Single
Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement
Dim numpts as Long
numpts = app.ActiveChannel.NumberOfPoints
ReDim dScalar(numPoints)

measData.getScalar naCorrectedData, naDataFormat_LogMag, numpts, dScalar(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_getScalar(tagNADataStore DataStore, tagDataFormat DataFormat, long* pNumValues, float* pVals)

Interface

IArrayTransfer


Get Shortcut Method

About Macros

GetShortcut Method

Read-only

Description

Returns the Title, Path, and optional argument strings, of the specified Macro (shortcut). Use this method to list the titles and paths of macros in the analyzer.

VB Syntax

app.GetShortcut index, title, path, arguments

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro. Use a number between 1 and 12.

title

(string) - Title of the specified macro. (Appears in the softkey label)

path

(string) - Pathname of the specified macro.

arguments

(string) - Arguments for the specified macro

Return Type

String

Default

Not Applicable

Example

Dim t As String
Dim p As String
Dim arg As String
Dim i As Integer
For i = 1 to 12
app.GetShortcut i,t,p,arg
Print t,p
Next

C++ Syntax

HRESULT raw_GetShortcut(long Number, BSTR* title, BSTR* pathname, BSTR* arguments)

Interface

IApplication

Remarks

Shortcuts can also be defined and accessed using the macro key on the front panel. However, the benefit of this feature is primarily for the interactive user


Get Standard Method

About Measurement Calibration

GetStandard Method

Read-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method returns a variant which is less efficient than getStandardComplex on the ICalData interface.

VB Syntax

data = cal.getStandardclass,rcv,src

Variable

(Type) - Description

data

Variant array to store the data.

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

Return Type

(variant) - two-dimensional array (0:1, 0:NumberOfPoints-1)

Default

Not Applicable

Examples

Dim varStd As Variant
varStd = cal.getStandard(naSOLT_Thru,2,1)

C++ Syntax

HRESULT raw_getStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT* pData)

Interface

ICalibrator


Get Standard Complex Method

About Accessing Data

GetStandardComplex Method

Write-only

Description

Retrieves data that was acquired for a specific cal standard. This method returns the actual measurement data - not the calculated error terms.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetStandard Method on ICalibrator.

VB Syntax

ICalData.getStandardComplex class, rcv, src, numPts, real(), imag()

Variable

(Type) - Description

ICalData

An ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - on input, max number of data points to return;
on output: indicates the actual number of data points returned.

real()

(single) - array to accept the real part of the calibration data. One-dimensional for the number of data points.

imag()

(single) - array to accept the imaginary part of the calibration data. One-dimensional for the number of data points.

Return Type

(single)

Default

Not Applicable

Examples

Dim rel(200) As Single
Dim img(200) As Single
Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.getStandardComplex naSOLT_Open, 1, 1, numpts, rel(0), img(0)

C++ Syntax

HRESULT raw_getStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Get Test Result Method

About Limit Testing

GetTestResult Method

Read-only

Description

Returns the result of limit line testing. There are three ways to use this command:

  • If neither optional parameter is specified, limit results for ALL data is returned.

  • If one parameter is specified (start), the limit result for that data point is returned.

  • If both parameters are specified, limit results are returned beginning with start, and ending with (start+size)-1

VB Syntax

testRes = limts.GetTestResult[start,size]

Variable

(Type) - Description

testRes

(enum NALimitTestResult) - A dimensioned variable to store test results

0 - naLimitTestResult_None
1 - naLimitTestResult_Fail
2 - naLimitTestResult_Pass

limts

A LimitTest (object)

start

(long) - Optional argument. A start data point number to return limit test results.

size

(long) - Optional argument. Number of data points from start to return limit test results.

Return Type

Long Integer

Default

Not Applicable

Examples

Dim testRes As NALimitTestResult
testRes = limts.GetTestResult
Select Case testRes

Case 0
Print "No Test Result"

Case 1
Print "Fails"

Case 2
Print "Pass"

End Select

C++ Syntax

HRESULT raw_GetTestResult(long lStart, long lSize, tagNALimitTestResult *pVal)

Interface

ILimitTest


Get Trace Statistics Method

About Trace Statistics

GetTraceStatistics Method

Read-only

Description

Returns all four Trace Statistics. To retreive individual Trace statistics, use Mean, PeakToPeak, StandardDeviation properties. Use ShowStatistics to display the statistics of the screen.

VB Syntax

meas.GetTraceStatistics pp,mean,stdev

Variable

(Type) - Description

meas

A Measurement (object)

pp,mean,stdev

(double) - Dimensioned variables to store the returned values

Return Type

Double

Default

Not Applicable

Examples

'Dimension variables
Dim pp As Double
Dim mean As Double
Dim stdv As Double
meas.GetTraceStatistics pp, mean, stdv

C++ Syntax

HRESULT raw_GetTraceStatistics(double* pp, double* mean, double* stdDeviation)

Interface

IMeasurement


Get X-Axis Values 2

About Segment Sweep

GetX-axisValues2 Method

Write-only

Description

Returns the channel's X-axis values into a dimensioned Typed array. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method exists on a non-default interface. If you cannot access this method, use the GetXAxisValues Method on IChannels.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

chanData.GetXAxisValues2 numPts,data

Variable

(Type) - Description

chanData

An IArrayTransfer pointer to the channel object.

numPts

(long integer) - Number of data points in the channel

data

(double) single dimensioned array of data matching the number of points in the channel.

Return Type

Double

Default

Not Applicable

Examples

Dim numPoints As Long
Dim values() As Double
numPoints = app.ActiveChannel.NumberOfPoints
ReDim values(numPoints)
app.ActiveChannel.GetXAxisValues2 numPoints, values(0)
Print values(0), values(1)

C++ Syntax

HRESULT raw_GetXAxisValues2(long* pNumValues, double* stimulus)

Interface

IChannel


Get X-axis Values Method

About Segment Sweep

GetXAxisValues Method

Read-only

Description

Returns the channel's X-axis values. GetXAxisValues is a convenient method for determining the frequency of each point when the points are not linearly spaced - as in segment sweep.

Note: This method returns a variant which is less efficient than GetXAxisValues2.

Note: In Segment Sweep, chan.NumberofPoints will return the total number of data points for the combined segments.

VB Syntax

data = chan.GetXAxisValues

Variable

(Type) - Description

data

Variant array to store the data.

chan

A Channel (object)

Return Type

Variant

Default

Not Applicable

Examples

Dim varData As Variant
Dim i As Integer
varData = chan.GetXAxisValues
'Print Data
For i = 0 To chan.numpts - 1
Print varData(i)
Next i

C++ Syntax

HRESULT raw_GetXAxisValues (VARIANT* xData)

Interface

IChannel


About Triggering

Hold Method

Write-only

Description

Puts the Channel in Hold - not sweeping.

VB Syntax

chan.Hold [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) - Optional argument. A variable set to either True or False.

True - program control waits until the channel is in the Hold state.
False - program control continues immediately. You are not guaranteed the channel is in Hold yet.

Return Type

Not Applicable

Default

Not Applicable

Examples

wate = True
chan.Hold wate

C++ Syntax

HRESULT raw_Hold(VARIANT_BOOL bWait)

Interface

IChannel


Item Method

Write-only

Description

Returns an object from the collection of objects.

Note: The order of objects within a collection cannot be assumed.

VB Syntax

Object[.Item](n)

Variable

(Type) - Description

Object

Any of the following (objects):
Channels collection
LimitTest collection
Measurements collection
NaWindows collection
Traces collection
Segments collection

.Item

Optional - Item is the default property of a collections object and therefore can be called implicitly. For example, the following two commands are equivalent:

Channels.Item(3).Averaging = 1
Channels(3).Averaging = 1

n

(variant) - number of the item in the collection.

Note: the Measurements and Traces collections allow you to specify the name of the measurement as a string. For example: measCollection("CH_S11_1").InterpolateMarkers

Return Type

(Object)

Default

Not Applicable

Examples

For i = 1 to Traces.Count -1
Traces.Item(i).YScale = .5dB
Next i

C++ Syntax

HRESULT raw_Item(VARIANT index, <interface>** pItem)

Interface

IChannels
ILimitTest
IMeasurements
INaWindows
ITraces
ISegments


Manual Trigger Method

About Triggering

ManualTrigger Method

Write-only

Description

Triggers the analyzer when TriggerSignal = naTriggerManual.

VB Syntax

app.ManualTrigger [sync]

Variable

(Type) - Description

app

Application (object)

sync

(boolean) - Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim wait as Boolean
wait = True
app.ManualTrigger wait

C++ Syntax

HRESULT raw_ManualTrigger(VARIANT_BOOL bSynchronize, long timeout)

Interface

IApplication


Message Text Method

About Analyzer Events

MessageText Method

Write/Read

Description

Returns text for the specified eventID

VB Syntax

app.MessageText,eventID,message

Variable

(Type) - Description

app

An Application (object)

enentID

(enum naEventID) Choose from the list in Working with the Analyzer's Events

message

(string) - variable to store the returned message

Return Type

String

Default

Not Applicable

Examples

RFNA.MessageText naEventID_ARRANGE_WINDOW_EXCEED_CAPACITY, message

C++ Syntax

HRESULT raw_MessageText( tagNAEventID msgID, BSTR* message)

Interface

IApplication

Type topic text here.


Next IF Bandwidth Method

About Dynamic Range

NextIFBandwidth Method

Write-only

Description

A function that returns the Next higher IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Next_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the Next higher IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

pnBW = chan.IFBandwidth 'put the current IFBW in pnBW
chan.Next_IFBandwidth pnBW 'function returns the Next higher IFBandwidth.
chan.IFBandwidth = pnBW 'set IFBW to the Next value

C++ Syntax

HRESULT raw_Next_IFBandwidth (double *pVal)

Interface

IChannel


Number Of Groups Method

About Triggering

NumberOfGroups Method

Write-only

Description

Sets the Number of trigger signals the channel will receive. After the channels has received that number of trigger signals, the channel switches to Hold mode.

To begin sweeping the number of groups, send app.Continuous

VB Syntax

chan.NumberOfGroups num, sync

Variable

(Type) - Description

chan

A Channel (object)

num

(long integer) Number of trigger signals the channel will receive. Choose any number between 1 and 2 million

sync

(boolean)
Variable set to either:
True - subsequent commands are not processed until the groups are complete. Do not use with manual trigger.
False - subsequent commands are processed immediately

Return Type

Not Applicable

Default

Not Applicable

Examples

chan.NumberOfGroups

C++ Syntax

HRESULT raw_NumberOfGroups(long count, VARIANT_BOOL bWait)

Interface

IChannel


SCPI Command Tree

Parse Method

Write-Read

Description

Executes a SCPI command.

VB Syntax

scpi.Parse ("SCPI command")

Variable

(Type) - Description

scpi

A ScpiStringParser (object)

SCPI command

(string) - Any valid SCPI command

Return Type

String

Default

Not Applicable

Examples

Dim scpi As ScpiStringParser
Set scpi = app.ScpiStringParser
Dim startfreq As Double
startfreq = 100e6
'
scpi.Parse ("Sens:Freq:Start " & startfreq)'Write

Dim str As String
str = scpi.Parse ("Sens:Freq:Start?")'Read

C++ Syntax

HRESULT raw_Parse(BSTR SCPI_Command, BSTR *pQueryResponse)

Interface

IScpiStringParser


Factory Preset Settings

Preset Method

Write-only

Description

Application Object: Deletes all traces and windows. In addition, resets the analyzer to factory defined default settings and creates an S11 measurement named "CH1_S11_1" in window 1.

Channel Object: Resets the channel (object) to factory defined default settings. Does NOT delete the current measurements or add a new measurement.

VB Syntax

app.Preset
chan.Preset

Variable

(Type) - Description

app

An Application (object)

chan

A Channel (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Preset

C++ Syntax

HRESULT raw_Preset()

Interface

IApplication
IChannel

.


Previous IF Bandwidth Method

About Dynamic Range

PreviousIFBandwidth Method

Write-only

Description

A function that returns the previous IF Bandwidth value. Use to retrieve the list of available IFBandwidth settings.

VB Syntax

chan.Previous_IFBandwidth bw

Variable

(Type) - Description

chan

A Channel (object)

bw

(double) - The argument that you use to send an IFBandwidth. The function uses this argument to return the previous IFbandwidth.

Return Type

Double

Default

Not Applicable

Examples

Public pnbw As Double 'declare variable outside of procedure

PreBW = chan.IFBandwidth 'put the current IFBW in PreBW
chan.Previous_IFBandwidth PreBW 'function returns the Previous IFBandwidth of the current one.
chan.IFBandwidth = PreBW 'set IFBW to the previous value

C++ Syntax

HRESULT raw_Previous_IFBandwidth (double *pVal)

Interface

IChannel


About Saving to File

PrintToFile Method

Write-only

Description

Saves the screen image to a bitmap (.bmp) file.

VB Syntax

app.PrintToFile filename

Variable

(Type) - Description

app

An Application (object)

filename

(string) Name of the file to save the screen to. If you don't provide a suffix, the analyzer will append .bmp. The file is saved to the current working directory unless a valid full path name is specified.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PrintToFile "myfile"
app.PrintToFile "c:\data\myfile.bmp"

C++ Syntax

HRESULT raw_PrintToFile(BSTR bstrFile)

Interface

IApplication


Put Complex Method

About Accessing Data

PutComplex Method

Write-only

Description

Puts real and imaginary data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in the raw data store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the measurement results store will be overwritten by any measurement attribute changes.

See also putNAComplex

VB Syntax

measData.putComplex location, numPts, real(), imag(), [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

real()

(single) - Array containing real data values

imag()

(single) -Array containing imaginary data values

format

(enum NADataFormat) optional argument - display format of the real and imaginary data. Only used if destination is naMeasResult or naMemoryResult buffer. If unspecified, data is assumed to be in naDataFormat_Polar

  • naDataFormat_Delay

  • naDataFormat_Imaginary

  • naDataFormat_LinMag

  • naDataFormat_LogMag

  • naDataFormat_Phase

  • naDataFormat_Real

  • naDataFormat_SWR

  • naDataFormat_Smith

  • naDataFormat_Polar

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putComplex naMemoryResult, 201, real(0),imag(0),naDataFormat_SWR

C++ Syntax

HRESULT raw_putComplex( tagNADataStore DataStore, long lNumValues, float* pReal, float* pImag, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Data Complex Method

About Accessing Data

PutDataComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten.

Data put in naRawData (location) will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in naMeasurement (location) will be overwritten by any measurement attribute changes.

VB Syntax

meas.putDataComplex location, data

Variable

(Type) - Description

meas

A measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

data

(variant) - A two-dimensional variant array.

Note: All buffers except naMeasResult and naMemoryResult require Complex data

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.putDataComplex naMeasResult, varData

C++ Syntax

HRESULT raw_putDataComplex(tagNADataStore DataStore, VARIANT complexData)

Interface

IMeasurement


Put Data Scalar Method

About Accessing Data

PutDataScalar Method

Write-only

Description

Puts formatted variant scalar data into the measurement result buffer. The data will be immediately processed and displayed. Subsequent changes to the measurement state will be reflected on the display.

VB Syntax

meas.putDataScalar format, data

Variable

(Type) - Description

meas

A measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
4 - naDataFormat_Polar *
5 - naDataFormat_Smith *
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

* Smith and Polar formats require a two-dimensional array varData (numpts, 2) to accomodate both real and imaginary data.

All other formats are a single dimension varData(numpts).

data

(variant) - A two-dimensional complex variant data array.

Note: The getData (variant) method includes a "format" argument, which allows scalar (one-dimensional) data. To put data back into the "raw" data buffer using this (putDataComplex) method, specify Polar format when using the getData method.

Return Type

Not Applicable

Default

Not Applicable

Examples

measData.putDataScalar naDataFormat_Real, varData

C++ Syntax

HRESULT raw_putDataScalar(tagNADataStore DataStore, VARIANT complexScalar)

Interface

IMeasurement


Put Error Term Method

About Measurement Calibration

PutErrorTerm Method

Write-only

Description

Puts variant error term data into the error-correction buffer. See Accessing data.

VB Syntax

cal.putErrorTerm(term,src,rcv,data)

Variable

(Type) - Description

cal

A Calibrator (object)

term

(enum As NaErrorTerm)

naErrorTerm_Directivity_Isolation
naErrorTerm_Match
naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

data

(variant) Error term data in a two-dimensional array (0:1, 0:numpts-1).

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varError As Variant
varError = cal.putErrorTerm (naErrorTerm_Tracking,2,1,VarData)

C++ Syntax

HRESULT raw_putErrorTerm(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Error Term Complex Method

About Accessing Data

PutErrorTermComplex Method

Write-only

Description

Puts error term data into the error-correction data buffer.

VB Syntax

data.putErrorTermComplex term, src, rcv, numPts, real(), imag()

Variable

(Type) - Description

data

An ICalData pointer to the Calibrator object

term

(enum NAErrorTerm) - The error term to be retrieved. Choose from:

  • naErrorTerm_Directivity_Isolation

  • naErrorTerm_Match

  • naErrorTerm_Tracking

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the array

real()

(single) - array containing the real part of the calibration data. One-dimensional: the number of data points.

imag()

(single) - array containing the imaginary part of the calibration data. One-dimensional: the number of data points.

To get this | Specify these parameters:
Error Term | term | src | rcv
Fwd Directivity | naET_Directivity Isolation | 1 | 1
Rev Directivity | naET_Directivity Isolation | 2 | 2
Fwd Isolation | naET_Directivity Isolation | 1 | 2
Rev Isolation | naET_Directivity Isolation | 2 | 1
Fwd Source Match | naErrorTerm_Match | 1 | 1
Rev Source Match | naErrorTerm_Match | 2 | 2
Fwd Load Match | naErrorTerm_Match | 1 | 2
Rev Load Match | naErrorTerm_Match | 2 | 1
Fwd Reflection Tracking | naErrorTerm_Tracking | 1 | 1
Rev Reflection Tracking | naErrorTerm_Tracking | 2 | 2
Fwd Trans Tracking | naErrorTerm_Tracking | 1 | 2
Rev Trans Tracking | naErrorTerm_Tracking | 2 | 1

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim eData As ICalData
Set eData = chan.Calibrator
eData.putErrorTermComplex naErrorTerm_Directivity_Isolation, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putErrorTermComplex(tagNAErrorTerm ETerm, long ReceivePort, long SourcePort, long* pNumValues, float* pReal, float* pImag)

Interface

ICalData


Put Scalar Method

About Accessing Data

PutScalar Method

Write-only

Description

Puts Scalar data in the Measurement Result buffer. The putScalar array is not processed by the analyzer; it is just displayed. Any change to the measurement state (changing the format, for example) will cause the putScalar data to be overwritten with the data processed from the raw data buffer.

VB Syntax

measData.putScalar, format, numPts, data

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

format

(enum NADataFormat) Format of the data. Choose from:

1 - naDataFormat_LinMag
2 - naDataFormat_LogMag
3 - naDataFormat_Phase
6 - naDataFormat_Delay
7 - naDataFormat_Real
8 - naDataFormat_Imaginary
9 - naDataFormat_SWR

Note: Smith and Polar formats are not allowed.

numPts

(integer) - Number of values. Usually the number of points in the trace (chan.NumberOfPoints).

data

(single) - A one-dimensional array of Scalar data matching the number of points in the current measurement.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putScalar naDataFormat_LogMag, 201, dScalar(0)

C++ Syntax

HRESULT raw_putScalar\(tagDataFormat eFormat, long lNumValues, float* pArrayOfScalar)

Interface

IArrayTransfer


Put NA Complex Method

About Accessing Data

PutNAComplex Method

Write-only

Description

Puts complex data into the specified location. This method forces the channel into Hold mode to prevent the input data from being overwritten. The data is processed and displayed.

Data put in the naRawData store will be re-processed whenever a change is made to the measurement attributes such as format or correction.

Data put in the naMeasResult store will be overwritten by any measurement attribute changes (such as moving a marker).

Note: This method uses NAComplex which is a user-defined data type. If you cannot or prefer not to use this data type, use the putComplex method.

VB Syntax

measData.putNAComplex location, numPts, data, [format]

Variable

(Type) - Description

measData

An IArrayTransfer pointer to the Measurement (object)

location

(enum NADataStore) Where the Data will be put. Choose from:
0 - naRawData
1 - naCorrectedData
2 - naMeasResult
3 - naRawMemory
4 - naMemoryResult

See the Data Access Map

numPts

(long integer) - Number of data points in the channel

data

(NAComplex) - A one-dimensional array of Complex data matching the number of points in the current measurement.

format

(enum NADisplayFormat) - Optional argument. Format of the data. If unspecified, naDataFormat_Polar is assumed. Only used when the destination store is naMeasResult or naMemoryResult.

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim measData As IArrayTransfer
Set measData = app.ActiveMeasurement

measData.putNAComplex naMemoryResult, 201, dRawComplex(0)

C++ Syntax

HRESULT raw_putNAComplex(tagNADataStore DataStore, long lNumValues, TsComplex* pArrayOfComplex, tagDataFormat displayFormat)

Interface

IArrayTransfer


Put Shortcut Method

About Macros

PutShortcut Method

Write-only

Description

Defines a Macro (shortcut) file in the analyzer. This command links a file name and path to the Macro file. You still need to put the macro file in the analyzer at the location indicated by this command.

VB Syntax

app.PutShortcut index,title,path

Variable

(Type) - Description

app

Application (object)

index

(long) - Number of the macro to be stored in the analyzer. If the index number already exists, the existing macro is replaced with the new macro.

title

(string) - The name to be assigned to the macro

path

(string) - Full pathname to the existing macro "executable" file.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.PutShortcut 1,"Test","C:\Automation\MyTest.vbs"

C++ Syntax

HRESULT raw_PutShortcut(long Number, BSTR title, BSTR pathname)

Interface

IApplication


Put Standard Method

About Accessing Data

PutStandard Method

Write-only

Description

Writes variant data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

cal.putStandard class,rcv,src,data

Variable

(Type) - Description

cal

A Calibrator (object)

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE
naReferenceRatioLine
naReferenceRatioThru
naSOLT_Isolation
naSOLT_Load
naSOLT_Open
naSOLT_Short
naSOLT_Thru
naTRL_Isolation
naTRL_Line_Reflection
naTRL_Line_Tracking
naTRL_Reflection
naTRL_Thru

rcv

(long) - Receiver Port

src

(long) - Source Port

data

(variant) Two dimensional array (0:1, 0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim varStd (1,200) As Variant
cal.putStandard naSOLT_Thru, 2, 1, varStd

C++ Syntax

HRESULT raw_putStandard(tagNACalClass stdclass, long ReceivePort, long SourcePort, VARIANT varData)

Interface

ICalibrator


Put Standard Complex Method

About Accessing Data

PutStandardComplex Method

Write-only

Description

Writes data to the error correction buffer holding measurement data acquired for a specific standard.

VB Syntax

ICalData.putStandardComplex class,rcv,src, numPts,real(),imag()

Variable

(Type) - Description

ICalData

A ICalData pointer to the Calibrator object

class

(enum As naCalClass) Calibration standard class. Choose from:

naClassA
naClassB
naClassC
naClassD
naClassE

rcv

(long integer) - Receiver Port

src

(long integer) - Source Port

numPts

(long integer) - number of data points in the arrays being sent.

real()

(single) - one-dimensional array containing the real part of the acquisition data. (0:points-1)

imag()

(single) - one-dimensional array containing the imaginary part of the acquisition data. (0:points-1)

Return Type

Not Applicable

Default

Not Applicable

Examples

Dim sdata As ICalData
Set sdata = chan.Calibrator
sdata.putStandardComplex naSOLT_Open, 1, 1, 201, rel(0), img(0)

C++ Syntax

HRESULT raw_putStandardComplex(tagNACalClass stdclass, long ReceivePort, long SourcePort, long lNumValues, float* pReal, float* pImag)

Interface

ICalData


Quit Method

Write-only

Description

Terminates the Network Analyzer application.

VB Syntax

app.Quit

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Quit

C++ Syntax

HRESULT raw_Quit()

Interface

IApplication

Remarks

Under the rules of COM, the server should not exit until all references to it have been released. This method is a brute force way of terminating the application. Be sure to release all references (or terminate the client program) before attempting to restart the Network Analyzer application.

An alternate approach to terminating the application is to make the application invisible (app.Visible = False) and release all references. The server will shutdown.


About Save/Recall

Recall Method

Write-only

Description

Recalls a measurement state, calibration state, or both from the hard drive into the analyzer.

Use app.Save to save the measurement and calibration state.

VB Syntax

app.Recall (filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be recalled.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are stored in the default folder "C:\Program Files\Agilent\Network Analyzer\Documents

To recall from a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Recall (mystate.sta) 'Recalls "mystate.sta" from the default folder
app.Recall ("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Recalls "mystate.cst" from the specified folder

C++ Syntax

HRESULT raw_Recall(BSTR bstrFile)

Interface

IApplication


About Modifying Cal Kits

Recall Kits Method

Write-only

Description

Recalls the calibration kits definitions that were stored witht the SaveKits command.

VB Syntax

app.RecallKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RecallKits

C++ Syntax

HRESULT raw_RecallKits()

Interface

IApplication


Remove Method

Write-only

Description

Removes an item from a collection of objects.

VB Syntax

Object.Remove item

Variable

(Type) - Description

Object

Any of the following (objects)

Measurements collection
NAWindows collection
Segments collection

Note: segments has an OPTIONAL argument [size] referring to the number of segments to remove, starting with the item parameter.

item

(variant) - Item number to be removed

Return Type

Not Applicable

Default

Not Applicable

Examples

Measurements.Remove 3 'Removes measurement 3
segments.Remove 2,20 'Removes 20 segments (3 - 22)

C++ Syntax

HRESULT raw_Remove(VARIANT index) //IMeasurements
HRESULT raw_Remove(long windowNumber ) //INaWindows
HRESULT raw_Remove(VARIANT index, long size) //Segments

Interface

IMeasurements
INAWindows
ISegments


About Presetting the Analyzer

Reset Method

Write-only

Description

Removes all existing windows and measurements from the application. (Unlike Preset, does not create a new measurement.)

VB Syntax

app.Reset

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Reset

C++ Syntax

HRESULT raw_Reset()

Interface

IApplication


Restore Cal Kit Defaults Method

About Modifying Cal Kits

RestoreCalKitDefaults Method

Write-only

Description

Restores the original properties of the specified Cal Kit, overwritting the last definition with the factory defaults.

VB Syntax

app.RestoreCalKitDefaults (calKit)

Variable

(Type) - Description

app

Application (object)

calKit

(enum NACalKit) - Calibration Kit to restore. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaults naCalKit_MechKit10

C++ Syntax

HRESULT raw_RestoreCalKitDefaults\(tagNACalKit kit)

Interface

IApplication


Restore Cal Kit Defaults All Method

About Modifying Cal Kits

RestoreCalKitDefaultsAll Method

Write-only

Description

Restores the original properties of ALL of the Cal Kits, overwritting the last definitions with the factory defaults.

VB Syntax

app.RestoreCalKitDefaultsAll

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.RestoreCalKitDefaultsAll

C++ Syntax

HRESULT raw_RestoreCalKitDefaultsAll()

Interface

IApplication


About Saving Files

Save Method

Write-only

Description

Saves the current measurement state, calibration state, or both, to the analyzer's hard drive. The saved state can be recalled using app.Recall.

VB Syntax

app.Save(filename.ext)

Variable

(Type) - Description

app

Application (object)

filename.ext

(string) - Filename and extension of the file to be saved.

Extensions:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

Files are saved to the default folder "C:\Program Files\Agilent\Network Analyzer\Documents.

To save to a different folder, specify the pathname in the filename.ext. argument.

Return Type

Not Applicable

Default

Not Applicable

Examples

app.Save(mystate.sta) 'Saves "mystate.sta" to the default folder
app.Save("C:\Program Files\Agilent\Network Analyzer\Documents\Newfolder\MyState.cst) 'Saves "mystate.cst" to the specified folder

C++ Syntax

HRESULT raw_Save(BSTR bstrFile)

Interface

IApplication


Save Kits Method

About Modifying Cal Kits

SaveKits Method

Write-only

Description

Saves the cal kits, typically after modifying a calibration kit. To load a cal kit into the analyzer from the hard drive, use app.RecallKits.

VB Syntax

app.SaveKits

Variable

(Type) - Description

app

Application (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

app.SaveKits

C++ Syntax

HRESULT raw_SaveKits()

Interface

IApplication


Search Filter Bandwidth Method

About Marker Search

SearchFilterBandwidth Method

Write-only

Description

Searches the measurement data with the current BandwidthTarget (default is -3). To continually track the filter bandwidth, use BandwidthTracking.

This feature uses markers 1-4. If not already, they are activated. To turn off these markers, either turn them off individually or DeleteAllMarkers.

The bandwidth statistics are displayed on the analyzer screen. To get the bandwidth statistics, use either GetFilterStatistics or FilterBW, FilterCF , FilterLoss ,or FilterQ.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a UserRange with the bandwidth search, first activate marker 1 and set the desired UserRange. Then send the SearchFilterBandwidth command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

VB Syntax

meas.SearchFilterBandwidth

Variable

(Type) - Description

meas

A Measurement (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

meas.SearchFilterBandwidth

C++ Syntax

HRESULT raw_SearchFilterBandwidth()

Interface

IMeasurement


Search Max Method

About Marker Search

SearchMax Method

Write-only

Description

Searches the marker domain for the maximum value.

VB Syntax

mark.SearchMax

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMax

C++ Syntax

HRESULT raw_SearchMax()

Interface

IMarker


Search Min Method

About Marker Search

SearchMin Method

Write-only

Description

Searches the marker domain for the minimum value.

VB Syntax

mark.SearchMin

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchMin

C++ Syntax

HRESULT raw_SearchMin()

Interface

IMarker


Search Next Peak Method

About Marker Search

SearchNextPeak Method

Write-only

Description

Searches the marker's domain for the next peak value.

VB Syntax

mark.SearchNextPeak

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchNextPeak

C++ Syntax

HRESULT raw_SearchNextPeak()

Interface

IMarker


Search Peak Left Method

About Marker Search

SearchPeakLeft Method

Write-only

Description

Searches the marker's domain for the next VALID peak to the left of the marker.

VB Syntax

mark.SearchPeakLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakLeft

C++ Syntax

HRESULT raw_SearchPeakLeft()

Interface

IMarker


Search Peak Right Method

About Marker Search

SearchPeakRight Method

Write-only

Description

Searches the marker's domain for the next VALID peak
to the right of the marker.

VB Syntax

mark.SearchPeakRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchPeakRight

C++ Syntax

HRESULT raw_SearchPeakRight()

Interface

IMarker


Search Target Method

About Marker Search

SearchTarget Method

Write-only

Description

Searches the marker's domain for the target value (specified with mark.TargetValue). Searches to the right; then at the end of the search domain, begins again at the start of the search domain.

VB Syntax

mark.SearchTarget

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTarget

C++ Syntax

HRESULT raw_SearchTarget()

Interface

IMarker


Search Target Left Method

About Marker Search

SearchTargetLeft Method

Write-only

Description

Moving to the left of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetLeft

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetLeft

C++ Syntax

HRESULT raw_SearchTargetLeft()

Interface

IMarker


Search Target Right Method

About Marker Search

SearchTargetRight Method

Write-only

Description

Moving to the right of the marker position, searches the marker's domain for the target value (specified with mark.TargetValue).

VB Syntax

mark.SearchTargetRight

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SearchTargetRight

C++ Syntax

HRESULT raw_SearchTargetRight()

Interface

IMarker


About Performing a Calibration

SetCalInfo Method

Write-only

Description

Specifies the type of calibration. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


Set Center Method

About Marker Functions

SetCenter Method

Write-only

Description

Changes the center stimulus to the stimulus value of the marker. The start stimulus stays the same and the stop is adjusted.

VB Syntax

mark.SetCenter

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCenter

C++ Syntax

HRESULT raw_SetCenter()

Interface

IMarker


Set CW Method

About Markers

SetCW Method

Write-only

Description

Changes the analyzer to sweep type CW mode and sets the CW frequency to the marker's frequency. Does not change anything if current sweep type is other than a frequency sweep.

VB Syntax

mark.SetCW

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetCW

C++ Syntax

HRESULT raw_SetCW()

Interface

IMarker


About Marker Functions

SetElectricalDelay Method

Write-only

Description

Changes the measurement's electrical delay to the marker's delay value.

VB Syntax

mark.SetElectricalDelay

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetElectricalDelay

C++ Syntax

HRESULT raw_SetElectricalDelay()

Interface

IMarker


About Analyzer Events

SetFailOnOverRange Method

Write/Read

Description

When set TRUE, configures the analyzer to report outOfRange conditions with an error code. Any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

Note: This method is for the benefit of VB clients. The analyzer automatically adjusts overrange conditions to the closest acceptable setting. The VB user will not See that an overrange occurred because the HRESULT is not returned if it has a success code. For more information, See Events/OverRange.

VB Syntax

app.SetFailOnOverRange state

Variable

(Type) - Description

app

An Application (object)

state

(boolean) -
True (1) - Overrange conditions report an error code
False (0) - Overrange conditions report a success code

Return Type

Not Applicable

Default

False (0)

VB Example

app.SetFailOnOverRange TRUE
On Error Goto ERRHANDLER

'the following overrange will cause ERRHANDLER to be invoked

channel.StartFrequency = 9.9 GHZ
exit

ERRHANDLER:
print "something failed"

C++ Syntax

HRESULT put_SetFailOnOverRange(VARIANT_BOOL mode)

Interface

IApplication


Set Frequency LowPass Method

About Time Domain

SetFrequencyLowPass Method

Write-only

Description

Set the start frequencies when trans.Mode = LowPass.

VB Syntax

trans.SetFrequencyLowPass

Variable

(Type) - Description

trans

A Transform (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

trans.SetFrequencyLowPass

C++ Syntax

HRESULT raw_SetFrequencyLowPass(void)

Interface

ITransform


About Marker Functions

SetReferenceLevel Method

Write-only

Description

Changes the measurement's reference level to the marker's Y-axis value.

VB Syntax

mark.SetReferenceLevel

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetReferenceLevel

C++ Syntax

HRESULT raw_SetReferenceLevel()

Interface

IMarker


Set Start Method

About Marker Functions

SetStart Method

Write-only

Description

Changes the start stimulus to the stimulus value of the marker. The stop stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStart

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStart

C++ Syntax

HRESULT raw_SetStart()

Interface

IMarker


Set Stop Method

About Marker Functions

SetStop Method

Write-only

Description

Changes the stop stimulus to the stimulus value of the marker. The start stimulus stays the same and the span is adjusted.

VB Syntax

mark.SetStop

Variable

(Type) - Description

mark

A Marker (object)

Return Type

Not Applicable

Default

Not Applicable

Examples

mark.SetStop

C++ Syntax

HRESULT raw_SetStop()

Interface

IMarker


Show Marker Readout Method

About Display Formatting

ShowMarkerReadout Method

Write-only

Description

Shows and Hides the Marker readout for the active marker in the upper-right corner of the window.

VB Syntax

win.ShowMarkerReadout state

Variable

(Type) - Description

win

A NAWindow (object)

state

(boolean) -
True (1) - Show the Marker readout
False (0) - Hide the Marker readout

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowMarkerReadout True

C++ Syntax

HRESULT raw_ShowMarkerReadout(VARIANT_BOOL bState)

Interface

INAWindow


Show Status Bar Method

About Display Formatting

ShowStatusBar Method

Write-only

Description

Shows and Hides the Status Bar. The Status Bar is located across the bottom of the display. The following information is shown for the active measurement:

  • Channel number

  • Parameter

  • Correction On or Off

  • Remote or Local operation

VB Syntax

app.ShowStatusBar state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Status Bar
False (0) - Hide the Status Bar

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStatusBar True

C++ Syntax

HRESULT raw_ShowStatusBar (VARIANT_BOOL bState)

Interface

IApplication


Show Stimulus Method

About Display Formatting

ShowStimulus Method

Write-only

Description

Shows and Hides the Stimulus (X-axis) information located at the bottom of the display. The start and stop stimulus values are shown for the active measurement.

VB Syntax

app.ShowStimulus state

Variable

(Type) - Description

app

Application (object)

state

(boolean) -
True (1) - Show the Stimulus information
False (0) - Hide the Stimulus information

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowStimulus True

C++ Syntax

HRESULT raw_ShowStimulus(VARIANT_BOOL bState)

Interface

IApplication


Show Table Method

About Display Formatting

ShowTable Method

Write-only

Description

Shows or Hides the specified table for the window's active measurement in the lower part of the window.

VB Syntax

win.ShowTable value

Variable

(Type) - Description

win

A NAWindow (object)

value

(enum naTable) - The table to show or hide. Choose from:

0 - naTable_None
1 - naTable_Marker
2 - naTable_Segment
3 - naTable_Limit

Return Type

Not Applicable

Default

Not Applicable

Examples

win.ShowTable naTable_limit

C++ Syntax

HRESULT raw_ShowTable (tagNATableType table)

Interface

INAWindow


Show Title Bars Method

About Display Formatting

ShowTitleBars Method

Write-only

Description

Shows and Hides the Title Bars. The Title Bars are across the top of the Network Analyzer Window and each of the measurement windows. The Window name is shown in the Title Bar.

VB Syntax

app.ShowTitleBars state

Variable

(Type) - Description

app

Application (object)

state

(boolean)
True (1) - Show the Title Bars
False (0) - Hide the Title Bars

Return Type

Not Applicable

Default

Not Applicable

Examples

app.ShowTitleBars True

C++ Syntax

HRESULT raw_ShowTitleBars\(VARIANT_BOOL bState)

Interface

IApplication


Show Toolbar Method

About Display Formatting

ShowToolbar Method

Write-only

Description

Shows and Hides the specified Toolbar.

VB Syntax

app.ShowToolbar toolbar,state

Variable

(Type) - Description

app

Application (object)

toolbar

(enum NAToolbarType) - The toolbar to show or hide. Choose from:

0 - naToolbar_None
1 - naToolbar_ActiveEntry
2 - naToolbar_Markers
3 - naToolbar_Measurement
4 - naToolbar_Stimulus
5 - naToolbar_SweepControl

state

(boolean) -
True (1) - Show the specified toolbar
False (0) - Hide the specified toolbar

Return Type

Not Applicable

Default

1 - naToolbar_ActiveEntry showing; all others hiding.

Examples

app.ShowToolbar 1,1 'shows the active entry toolbar

C++ Syntax

HRESULT raw_ShowToolbar(tagNAToolbarType toolbar, VARIANT_BOOL bState)

Interface

IApplication


About Triggering

Single Method

Write-only

Description

Sets the trigger count to 1, which will cause the channel to respond to exactly one trigger signal from any source (internal, external, or manual).

VB Syntax

chan.Single [sync]

Variable

(Type) - Description

chan

A Channel (object)

[sync]

(boolean) -Optional argument. A variable set to either True or False.

True - The analyzer waits until the trigger is completed to process subsequent commands.
False - Subsequent commands are processed immediately.

Return Type

Not Applicable

Default

Not Applicable

Examples

sync = True
chan.Single sync

C++ Syntax

HRESULT raw_Single(VARIANT_BOOL bWait)

Interface

IChannel


About Analyzer Events

OnCalEvent

Description

Triggered by a calibration event. See a list of CAL Events.

VB Syntax

Sub app_OnCalEvent(ByVal eventID As Variant, ByVal chanNum As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnCalEvent(ByVal eventID As Variant, ByVal channelNumber As Variant, ByVal measurementNumber As Variant)
'
MsgBox ("A Calibration event has occured")
End Sub

C++ Syntax

HRESULT OnCalEvent(VARIANT eventID, VARIANT channelNumber, VARIANT measurementNumber)

Interface

IApplication


CAL Events (802)

MSG_CAL_STD_NEEDED
Calibration cannot be completed until you have measured all the necessary standards for your selected Cal Type.
HRESULT 0x68020201L

MSG_CAL_REQUIRED
Calibration is required before correction can be turned on. Channel number is <x>, Measurement is <x>.
HRESULT 0x68020203L

MSG_CAL_CORRECTION_TURNED_OFF
Critical parameters in your current instrument state do not match the parameters for the calibration set, therefore correction has been turned off. The critical instrument state parameters are sweep type, start frequency, frequency span, and number of points.
HRESULT 0x68020204L

MSG_CAL_CALTYPE_SET_TO_NONE
Cal Type is set to NONE for Channel <x>, Measurement <x>; please select Calibration menu or press Cal hard key.
HRESULT 0x68020208L

MSG_PROPERTIES_NO_USER_CAL
No user calibration found for this channel.
HRESULT 0x6802020EL

MSG_CAL_DOES_NOT_NEED_STD
You do not need to acquire this standard for this calibration type.
HRESULT 0x6802020FL

MSG_ECAL_COULD_NOT_CONFIGURE
Could not configure the Electronic Calibration system. Check to see if the module is plugged into the proper connector.
HRESULT 0x68020210L

MSG_ECAL_ERROR_1
DATA OUT OF RANGE: Design Limits Exceeded
HRESULT 0x68020211L

MSG_ECAL_ERROR_2
EXECUTION ERROR: Array dimensions mismatched
HRESULT 0x68020212L

MSG_ECAL_ERROR_3
EXECUTION ERROR: Array div by zero
HRESULT 0x68020213L

MSG_ECAL_ERROR_4
EXECUTION ERROR: Array function invalid
HRESULT 0x68020214L

MSG_ECAL_ERROR_5
EXECUTION ERROR: Array index error
HRESULT 0x68020215L

MSG_ECAL_ERROR_6
EXECUTION ERROR: Array index out of range
HRESULT 0x68020216L

MSG_ECAL_ERROR_7
EXECUTION ERROR: Arrays wrong rank
HRESULT 0x68020217L

MSG_ECAL_ERROR_8
EXECUTION ERROR: CPU
HRESULT 0x68020218L

MSG_ECAL_ERROR_9
EXECUTION ERROR: Cannot ERASE module
HRESULT 0x68020219L

MSG_ECAL_ERROR_10
EXECUTION ERROR: Cannot WRITE module
HRESULT 0x6802021AL

MSG_ECAL_ERROR_11
EXECUTION ERROR: Entry Not Found
HRESULT 0x6802021BL

MSG_ECAL_ERROR_12
EXECUTION ERROR: Invalid command while system is busy
HRESULT 0x6802021CL

MSG_ECAL_ERROR_13
Electronic Cal: The Module is NOT in RF path. Please connect it to the port indicated.
HRESULT 0x6802021DL

MSG_ECAL_ERROR_14
EXECUTION ERROR: NO SPACE for NEW CAL, DELETE A CAL
HRESULT 0x6802021EL

MSG_ECAL_ERROR_15
EXECUTION ERROR: No More Room
HRESULT 0x6802021FL

MSG_ECAL_ERROR_16
EXECUTION ERROR: Other array error
HRESULT 0x68020220L

MSG_ECAL_ERROR_17
EXECUTION ERROR: Ranks not equal
HRESULT 0x68020221L

MSG_ECAL_ERROR_18
EXECUTION ERROR: Too few CONSTANT ranks
HRESULT 0x68020222L

MSG_ECAL_ERROR_19
EXECUTION ERROR: Too few VARYing ranks
HRESULT 0x68020223L

MSG_ECAL_ERROR_20
EXECUTION ERROR: Unknown error
HRESULT 0x68020224L

MSG_ECAL_ERROR_21
EXECUTION ERROR: ecaldrvr.dll bug or invalid module #
HRESULT 0x68020225L

MSG_ECAL_ERROR_22
EXECUTION ERROR: unexpected error code from ecal driver
HRESULT 0x68020226L

MSG_ECAL_ERROR_23
EXECUTION ERROR: unexpected internal driver error
HRESULT 0x68020227L

MSG_ECAL_ERROR_24
HARDWARE ERROR: Can't access ECal Interface Module
HRESULT 0x68020228L

MSG_ECAL_ERROR_25
HARDWARE ERROR: Can't release LPT port, reboot
HRESULT 0x68020229L

MSG_ECAL_ERROR_26
HARDWARE ERROR: VNA Error
HRESULT 0x6802022AL

MSG_ECAL_ERROR_27
HARDWARE ERROR: not enough data read from ECal module
HRESULT 0x6802022BL

MSG_ECAL_ERROR_28
OPERATION ABORTED BY HOST COMPUTER
HRESULT 0x6802022CL

MSG_ECAL_ERROR_29
OPERATION ABORTED BY USER
HRESULT 0x6802022DL

MSG_ECAL_ERROR_30
OUT OF MEMORY
HRESULT 0x6802022EL

MSG_ECAL_ERROR_31
QUERY INTERRUPTED:Message(s Abandoned
HRESULT 0x6802022FL

MSG_ECAL_ERROR_32
QUERY UNTERMINATED: INCOMPLETE PROGRAMMessage
HRESULT 0x68020230L

MSG_ECAL_ERROR_33
QUERY UNTERMINATED: NOTHING TO SAY
HRESULT 0x68020231L

MSG_ECAL_ERROR_34
QUEUE OVERFLOW
HRESULT 0x68020232L

MSG_ECAL_ERROR_35
SETTINGS CONFLICT: ADDITIONAL STANDARDS ARE NEEDED
HRESULT 0x68020233L

MSG_ECAL_ERROR_36
SETTINGS CONFLICT: Adapter Cal is NOT possible
HRESULT 0x68020234L

MSG_ECAL_ERROR_37
SETTINGS CONFLICT: COMMAND OUT OF SEQUENCE
HRESULT 0x68020235L

MSG_ECAL_ERROR_38
SETTINGS CONFLICT: Cal STOPPED - VNA SETUP CHANGED
HRESULT 0x68020236L

MSG_ECAL_ERROR_39
SETTINGS CONFLICT: Calibration is NOT in progress
HRESULT 0x68020237L

MSG_ECAL_ERROR_40
SETTINGS CONFLICT: Can't find specified GPIB board
HRESULT 0x68020238L

MSG_ECAL_ERROR_41
SETTINGS CONFLICT: Can't find/load gpib32.dll
HRESULT 0x68020239L

MSG_ECAL_ERROR_42
SETTINGS CONFLICT: Can't find/load sicl32.dll
HRESULT 0x6802023AL

MSG_ECAL_ERROR_43
SETTINGS CONFLICT: Can't initialize VNA (bad address?
HRESULT 0x6802023BL

MSG_ECAL_ERROR_44
SETTINGS CONFLICT: Can't load LPT port driver or USB driver DLL
HRESULT 0x6802023CL

MSG_ECAL_ERROR_45
SETTINGS CONFLICT: Invalid Calibration Sweep Mode.
HRESULT 0x6802023DL

MSG_ECAL_ERROR_46
SETTINGS CONFLICT: Invalid Calibration Type
HRESULT 0x6802023EL

MSG_ECAL_ERROR_47
SETTINGS CONFLICT: Invalid Calibration
HRESULT 0x6802023FL

MSG_ECAL_ERROR_48
SETTINGS CONFLICT: Invalid GPIB board number specified
HRESULT 0x68020240L

MSG_ECAL_ERROR_49
SETTINGS CONFLICT: Invalid GPIB board type specified
HRESULT 0x68020241L

MSG_ECAL_ERROR_50
SETTINGS CONFLICT: Invalid Module Status
HRESULT 0x68020242L

MSG_ECAL_ERROR_51
SETTINGS CONFLICT: Invalid States
HRESULT 0x68020243L

MSG_ECAL_ERROR_52
SETTINGS CONFLICT: LPT port must be between 1 and 4
HRESULT 0x68020244L

MSG_ECAL_ERROR_53
Could not configure the Electronic Calibration system. Check to see if the module is properly connected.
HRESULT 0x68020245L

MSG_ECAL_ERROR_54
SETTINGS CONFLICT: Specified LPT port does not exist
HRESULT 0x68020246L

MSG_ECAL_ERROR_55
SETTINGS CONFLICT: Use frequency domain for cal
HRESULT 0x68020247L

MSG_ECAL_ERROR_56
SETTINGS CONFLICT: Use step sweep type for cal.
HRESULT 0x68020248L

MSG_ECAL_ERROR_57
SETTINGS CONFLICT: VNA address must be between 0 and 30
HRESULT 0x68020249L

MSG_ECAL_ERROR_58
SETTINGS CONFLICT: Wrong LPT port driver or USB driver DLL
HRESULT 0x6802024AL

MSG_ECAL_ERROR_59
SYNTAX ERROR: ECAL:DELAY command must have 2 numbers
HRESULT 0x6802024BL

MSG_ECAL_ERROR_60
SYNTAX ERROR: INCORRECT SYNTAX
HRESULT 0x6802024CL

MSG_ECAL_ERROR_61
SYNTAX ERROR: UNKNOWN COMMAND
HRESULT 0x6802024DL

E_NA_CALTYPE_NONE
CalType not set.
HRESULT 0xE8020260L


About Analyzer Events

OnChannelEvent

Description

Triggered by a channel event. See a list of Channel Events

VB Syntax

Sub app_OnChannelEvent(ByVal eventID As Variant, ByVal chanNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnChannelEvent(ByVal eventID As Variant, ByVal channelNumber As Variant)
MsgBox "A channel event occured"
End Sub

C++ Syntax

HRESULT OnChannelEvent(VARIANT eventID, VARIANT channelNumber)

Interface

IApplication


Channel Events (807)

MSG_CHANNEL_SWEEP_COMPLETE
Sweep Complete.
HRESULT 0x68070700L

MSG_CHANNEL_TRIGGER_COMPLETE
All triggerable acqusitions have completed.
HRESULT 0x68070701L

MSG_CHANNEL_TRIGGER_ABORTED
The last trigger produced an aborted sweep.
HRESULT 0x68070702L

E_NA_NO_CHANNEL
Channel not found.
HRESULT 0xE8070750L

E_NA_SWEEP_SEGMENT_NOT_FOUND
The requested sweep segment was not found.
HRESULT 0xE8070751L


About Analyzer Events

OnDisplayEvent

Description

Triggered by a display event. See a list of Display Events

VB Syntax

Sub app_OnDisplayEvent(ByVal eventID As Variant, ByVal winNum As Variant, ByVal traceNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

winNum

Window Number of the event

traceNum

Trace Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Sub pna_OnDisplayEvent(ByVal eventID As Variant, ByVal windowNumber As Variant, ByVal traceNumber As Variant)
MsgBox ("A Display event has occured")
End Sub

C++ Syntax

HRESULT OnDisplayEvent(VARIANT eventID, VARIANT windowNumber, VARIANT traceNumber)

Interface

IApplication


Display Events (806)

MSG_EXCEED_MAX_TRACES
Exceeded the maximum of <x> traces in each window. The trace for <x> will not be added to window <x>.
HRESULT 0xA8060600L

MSG_EXCEED_MAX_DATA_WINDOWS
Exceeded the maximum of <x> data windows. New window will not be created.
HRESULT 0xA8060601L

MSG_NO_DATA_WINDOWS
No Data Windows are present. Unable to complete operation.
HRESULT 0xA8060602L

MSG_NO_TRACE_FOUND
No data traces are present in the selected window. Operation not completed.
HRESULT 0xA8060603L

MSG_ARRANGE_WINDOW_EXCEED_CAPACITY
Cannot complete request to arrange existing measurements in <x> windows due to the limit of <x> traces per window.
HRESULT 0x68060604L

E_NA_NO_WINDOW
Window not found.
HRESULT 0xE8060650L

E_NA_DUPLICATE_WINDOW
Duplicate window ID specified.
HRESULT 0xE8060651L

E_NA_EXCEED_MAX_WINDOWS
Exceeded limit on number of windows.
HRESULT 0xE8060652L

E_NA_EXCEED_MAX_NUM_TRACES
Exceeded limit on number of traces/window.
HRESULT 0xE8060653L

E_NA_NO_TRACE
Trace not found.
HRESULT 0xE8060654L


About Analyzer Events

OnHardwareEvent

Description

Triggered by a hardware event. See a list of Hardware Events

VB Syntax

Sub app_OnHardwareEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnHardwareEvent(ByVal eventID As Variant)
MsgBox ("A Hardware event has occured")
End Sub

C++ Syntax

HRESULT OnHardwareEvent(VARIANT eventID)

Interface

IApplication


Hardware Events (803)

MSG_POWER_TRIPPED
The input power is too high. The source power is shut off.
HRESULT 0xA8030302L

MSG_POWER_TRIP_CORRECTED
The source power has been restored.
HRESULT 0x68030303L

MSG_DSP_BOARD_NOT_FOUND
The spampnp.sys driver is not working. Check system hardware.
! Data will be simulated. !
HRESULT 0xE8030304L

MSG_INSTRUMENT_SERIAL_BUS_BAD
Instrument Serial Bus Not Working.
HRESULT 0xE8030305L

E_NA_PHASELOCK
The hardware has lost phaselock.
HRESULT 0xE8030350L

E_NA_HARDWARE
General Hardware Error.
HRESULT 0xE8030351L

E_NA_DSPCOMM
The CPU cannot communicate with the DSP processor.
HRESULT 0xE8030352L

E_NA_RFPOWEROFF
The RF Power is Off.
HRESULT 0xE8030353L

S_NA_RFPOWERON
The RF Power is On.
HRESULT 0x28030354L

S_NA_HARDWAREOK
The hardware is functioning properly.
HRESULT 0x28030355L

E_NA_UNLEVELED
The source power is unleveled.
HRESULT 0xE8030356L

E_NA_OVERLOAD
Input overload. Please reduce power.
HRESULT 0xE8030357L

E_NA_YIG_CAL_FAILED
The yig oscillator failed to calibrate.
HRESULT 0xE8030358L

E_NA_RAMP_CAL_FAILED
The analog ramp failed to calibrate.
HRESULT 0xE8030359L

E_NA_OVERTEMP
The source temperature is too high. Improve air flow.
HRESULT 0xE803035AL

E_NA_EE_WRT_ERR
Writing to the EEPROM failed.
HRESULT 0xE803035BL

E_NA_SET_EE_WRT_ERR

HRESULT 0xE803035CL

E_NA_CLR_EE_WRT_ERR
E_NA_CLR_EE_WRT_ERR
HRESULT 0xE803035DL

E_NA_SET_RAMP_CAL_FAILED
E_NA_SET_RAMP_CAL_FAILED
HRESULT 0xE803035EL

E_NA_CLR_RAMP_CAL_FAILED

E_NA_CLR_RAMP_CAL_FAILED

#define E_NA_CLR_RAMP_CAL_FAILED ((HRESULT)0xE803035FL)

E_NA_CLR_YIG_CAL_FAILED

E_NA_CLR_YIG_CAL_FAILED

#define E_NA_CLR_YIG_CAL_FAILED ((HRESULT)0xE8030360L)

E_NA_SET_YIG_CAL_FAILED

E_NA_SET_YIG_CAL_FAILED

#define E_NA_SET_YIG_CAL_FAILED ((HRESULT)0xE8030361L)

E_NA_SET_OVER_TEMP

E_NA_SET_OVER_TEMP

#define E_NA_SET_OVER_TEMP ((HRESULT)0xE8030362L)

E_NA_CLR_OVER_TEMP

E_NA_CLR_OVER_TEMP

#define E_NA_CLR_OVER_TEMP ((HRESULT)0xE8030363L)

E_NA_SET_UNLEVEL

E_NA_SET_UNLEVEL

#define E_NA_SET_UNLEVEL ((HRESULT)0xE8030364L)

E_NA_CLR_UNLEVEL

E_NA_CLR_UNLEVEL

#define E_NA_CLR_UNLEVEL ((HRESULT)0xE8030365L)

E_NA_SET_OVERLOAD

E_NA_SET_OVERLOAD

#define E_NA_SET_OVERLOAD ((HRESULT)0xE8030366L)

E_NA_CLR_OVERLOAD

E_NA_CLR_OVERLOAD

#define E_NA_CLR_OVERLOAD ((HRESULT)0xE8030367L)

E_NA_SET_UNLOCK

E_NA_SET_UNLOCK

#define E_NA_SET_UNLOCK ((HRESULT)0xE8030368L)

E_NA_CLR_UNLOCK

E_NA_CLR_UNLOCK

#define E_NA_CLR_UNLOCK ((HRESULT)0xE8030369L)


About Analyzer Events

OnMeasurementEvent

Description

Triggered by a measurement event. See a list of Measurement Events.

VB Syntax

Sub app_OnMeasurementEvent(ByVal eventID As Variant, ByVal measNum As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

measNum

Measurement Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnMeasurementEvent(ByVal eventID As Variant, ByVal measurementNumber As Variant)

MsgBox ("A Measurement event has occured")

End Sub

C++ Syntax

HRESULT OnMeasurementEvent(VARIANT eventID, VARIANT measurementNumber)

Interface

IApplication


Measure Events (804)

MSG_NO_VALID_MEMORY_TRACE
If you are going to display or otherwise use a memory trace, you must first store a data trace to memory.
HRESULT 0xA8040400L

MSG_MEASUREMENT_DELETE_FAIL
The measurement failed to shut down properly. The application is in a corrupt state and should be shut down and restarted.
HRESULT 0xE8040401L

MSG_MEASUREMENT_WAIT_THREAD_FAIL
The measurement failed to shut down properly. The update thread failed to exit properly.
HRESULT 0xA8040402L

MSG_GROUPDELAY_FORMAT_NOT_VALID
Group Delay format with CW Time or Power sweeps produces invalid data.
HRESULT 0xA8040403L

MSG_LIMIT_FAILED
MSG_LIMIT_FAILED
HRESULT 0x68040404L

MSG_LIMIT_PASSED
MSG_LIMIT_PASSED
HRESULT 0x68040405L

MSG_EXCEED_MAX_MEAS
Exceeded the maximum number of measurements allowed.
HRESULT 0xA8040406L

MSG_NETANA_ERROR_ADDNEWMEAS
Network Analyzer Internal Error. Unexpected error in AddNewMeasurement.
HRESULT 0xA8040407L

MSG_NO_MEASUREMENT_FOUND
No measurement was found to perform the selected operation. Operation not completed.
HRESULT 0xA8040408L

MSG_MARKER_ALL_OFF_FAILED
The Markers All Off command failed.
HRESULT 0xA8040409L

MSG_MEMORY_NOT_SAVED
A memory trace has not been saved for the selected trace. Save a memory trace before attempting trace math operations.
HRESULT 0xA804040AL

MSG_SET_AVERAGE_COMPLETE
MSG_SET_AVERAGE_COMPLETE
HRESULT 0x6804040BL

MSG_CLEAR_AVERAGE_COMPLETE
MSG_CLEAR_AVERAGE_COMPLETE
HRESULT 0x6804040CL

MSG_TIME_DOMAIN_MINIMUM_POINTS
Time Domain transform requires at least %1 input points. The transform has been deactivated.
HRESULT 0x6804040DL

E_NA_EXCEED_MAX_NUM_MEAS
Exceeded limit on number of measurements.
HRESULT 0xE8040450L

E_NA_BAD_PARAMETER
Parameter not valid.
HRESULT 0xE8040451L

E_NA_NO_MEAS
Measurement not found.
HRESULT 0xE8040452L

E_NA_NO_MEMORY_BUFFER
No valid memory trace.
HRESULT 0xE8040453L

E_NA_NO_REFERENCE_MARKER
The reference marker was not found.
HRESULT 0xE8040454L

E_NA_TRACE_MATH_RESET
Data and Memory traces are no longer compatible. Trace Math has been turned off.
HRESULT 0xA8040455L

E_NA_MEMORY_TRACE_NOT_COMPATIBLE
Data and Memory traces are not compatible. For valid trace math operations, memory and data traces must have similar measurement conditions.
HRESULT 0xE8040456L


About Analyzer Events

OnSCPIEvent

Description

Triggered by a SCPI event. See a list of SCPI Events

VB Syntax

Sub app_OnSCPIEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSCPIEvent(ByVal eventID As Variant)
MsgBox ("A SCPI event has occured")
End Sub

C++ Syntax

HRESULT OnSCPIEvent(VARIANT eventID )

Interface

IApplication


Parse Events

MSG_NOTHING_TO_SAY
You have sent a read command to the analyzer without first requesting data with an appropriate output command. The analyzer has no data in the output queue to satisfy the request.
HRESULT 0x68050501L

MSG_ANOTHER_CTRL
You must remove the active controller from the bus or the controller must relinquish the bus before the analyzer can assume the system controller mode.
HRESULT 0xE8050502L

MSG_BLOCK_INPUT_ERROR
The analyzer did not receive a complete data transmission. This is usually caused by an interruption of the bus transaction.
HRESULT 0xE8050503L

MSG_SCPI_STATUS_BYTE_CHANGE
The instrument status byte has changed.
HRESULT 0x68050504L

MSG_BAD_SCPI_COMMAND
The SCPI command received has caused error number <x>: "<x>".
HRESULT 0x68050505L

MSG_PARSER_COMMAND_LOG
Parser got command: <x>
HRESULT 0x680505FFL


About Analyzer Events

OnSystemEvent

Description

Triggered by a system event. See a list of System Events

VB Syntax

Sub app_OnSystemEvent(ByVal eventID As Variant)

Variable

(Type) - Description

app

An Application (object)

eventID

Code number of the event which occurred

chanNum

Channel Number of the event

Return Type

Not Applicable

Default

Not Applicable

Examples

Private Sub pna_OnSystemEvent(ByVal eventID As Variant)
MsgBox ("A System event has occured")
End Sub

C++ Syntax

HRESULT OnSystemEvent(VARIANT eventID)

Interface

IApplication


General Events (808)

MSG_OPTION_NOT_INSTALLED
The function you requested requires a capability provided by an option to the standard analyzer. That option is not currently installed.
HRESULT 0x68080800L

MSG_FEATURE_NOT_AVAILABLE
The feature you requested is not available on the current instrument.
HRESULT 0x68080801L

MSG_FEATURE_NOT_VALID
The feature you requested is incompatible with the current instrument state.
HRESULT 0x68080802L

MSG_SAVEFILE_OK
<x> has been saved.
HRESULT 0x68080803L

MSG_SAVEFILE_FAIL
Attempt to save <x> failed.
HRESULT 0xA8080804L

MSG_RECALLFILE_FILE_NOT_FOUND
Attempt to recall file failed because <x> was not found.
HRESULT 0x68080805L

MSG_RECALLFILE_BAD_HEADER
<x> has a bad header.
HRESULT 0x68080806L

MSG_POWER_HIBERNATE
Request to enter hibernate state.
HRESULT 0x68080807L

MSG_POWER_HIBERNATE_AUTOMATIC
Power up from automatic hibernate state. Program received PBT_APMRESUMEAUTOMATIC Message.
HRESULT 0x68080808L

MSG_POWER_HIBERNATE_SUSPEND
Power up from suspend hibernate state. Program received PBT_APMRESUMESUSPEND Message.
HRESULT 0x68080809L

MSG_POWER_HIBERNATE_CRITICAL
Power up from suspend hibernate state. Program received PBT_APMRESUMECRITICAL Message.
HRESULT 0xA808080AL

MSG_POWER_HIBERNATE_UIFAILSAFE
Power up from unknown hibernate state UI recovery called. Program received no PBT_Message within the time alloted and is attempting recovery.
HRESULT 0xA808080BL

MSG_SAVEFILE_DUP
<x> already exists. File is being overwritten.
HRESULT 0x6808080CL

MSG_SAVEFILE_NOTDONE
File has not been saved.
HRESULT 0x6808080DL

MSG_RECALLFILE_SUCCESS
File <x> has been recalled.
HRESULT 0x6808080EL

E_NA_INVALIDFORMAT
The specified format is invalid.
HRESULT 0xE8080850L

E_NA_EXCEPTION
WINNT exception caught by Automation layer.
HRESULT 0xE8080851L

E_NA_BADPORT
Bad port specification.
HRESULT 0xE8080852L

E_NA_TRIGGERIGNORED
Manual trigger ignored.
HRESULT 0xE8080854L

E_NA_TRIGGERDENIED
Attempt to set trigger failed.
HRESULT 0xE8080855L

E_NA_DATA_LENGTH
Block data length error.
HRESULT 0xE8080859L

E_NA_DATA_NOT_FOUND
Requested data not found.
HRESULT 0xE808085BL


About Analyzer Events

OnUserEvent

Description

Reserved for future use.

VB Syntax

Sub app_OnUserEvent


Getting Trace Data from the Analyzer

This Visual Basic program:

  • Retrieves Scalar Data from the Analyzer and plots it.

  • Retrieves Paired Data from the Analyzer and plots it.

  • Retrieves Complex Data from the Analyzer and plots it.

To use this code, prepare a form with the following:

  • Two MSCharts named MSChart1 and MSChart2

  • Three buttons named getScalar, getPaired, getComplex

'Put this in a module
Public dlocation As NADataStore
Public numpts As Long
Public fmt As NADataFormat
Public app As Application
Public measData As IArrayTransfer
Public chan As Channel

Sub Form_Load()
'Change analyzerName to your analyzer's full computer name
Set app = CreateObject("AgilentPNA835x", "analyzerName")
Set measData = app.ActiveMeasurement
Set chan = app.ActiveChannel
numpts = chan.NumberOfPoints

'To pick a location to get the data from remove the comment from one of these
dlocation = naRawData
'dlocation = naCorrectedData
'dlocation = naMeasResult
'dlocation = naRawMemory
'dlocation = naMemoryResult

'setup MSchart
'right click on the chart and select:
' - line chart
' - data in rows
End Sub

Sub GetComplex_Click()
ReDim Data(numpts) As NAComplex
Dim Real(201)
Dim Imag(201)
'You cannot change the format of Complex Data
Call trigger
'get data
measData.GetNAComplex dlocation, numpts, Data(0)
'plot data
Dim i As Integer

For i = 0 To numpts - 1
 Real(i) = Data(i).Re
 Imag(i) = Data(i).Im
Next i
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetPaired_Click()
ReDim Real(numpts) As Single
ReDim Imag(numpts) As Single
' To pick a format, remove the comment from one of these
fmt = naLogMagPhase
'fmt = naLinMagPhase
Call trigger
'Get data
measData.getPairedData dlocation, fmt, numpts, Real(0), Imag(0)
'Plot Scalar
MSChart1 = Real()
MSChart2.Visible = True
MSChart2 = Imag()
Call Sweep
End Sub

Sub GetScalar_Click()
ReDim Data(numpts) As Single
'To pick a format remove the comment from one of these
fmt = naDataFormat_LogMag
'fmt = naDataFormat_LinMag
'fmt = naDataFormat_Phase
'fmt = naDataFormat_Delay
'fmt = naDataFormat_Real
'fmt = naDataFormat_Imaginary
Call trigger
'Get data
measData.GetScalar dlocation, fmt, numpts, Data(0)
'Plot Data
MSChart1 = Data()
MSChart2.Visible = False
Call Sweep
End Sub

Sub trigger()
'The analyzer send continuous trigger signals
app.TriggerSignal = naTriggerInternal
'The channel will only accept one, then go into hold
chan.Single sync
End Sub

Sub Sweep()
'The channel goes back to accepting all triggers
chan.Continuous
End Sub


Limit Line Testing Example with COM

Limit Line Testing with COM

This Visual Basic program:

  • Turns off existing Limit Lines

  • Establishes Limit Lines with the following settings:

    • Frequency range - 4 GHz to 8 GHz

    • Maximum value - (10dB)

    • Minimum value - (-30dB)

  • Turns on Lines, Testing, and Sound

To use this code, prepare a form with the following:

  • None

Public limts As LimitTest
Set limts = meas.LimitTest
'All Off
For i = 1 To 20
limts(i).Type = naLimitSegmentType_OFF
Next i

'Set up Limit Lines
limts(1).Type = naLimitSegmentType_Maximum
limts(1).BeginResponse = 10
limts(1).EndResponse = 10
limts(1).BeginStimulus = 4000000000#
limts(1).EndStimulus = 8000000000#
limts(2).Type = naLimitSegmentType_Minimum
limts(2).BeginResponse = -30
limts(2).EndResponse = -30
limts(2).BeginStimulus = 4000000000#
limts(2).EndStimulus = 8000000000#

'Turn on Lines, Testing, and Sound
limts.LineDisplay = 1
limts.State = 1
limts.SoundOnFail = 1


C++ Example

The following example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries.

Also notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

// An example program to illustrate the use of #import
 to bind to the
// PNA type library.
//
#include "stdafx.h"
#include "stdio.h"
#include "math.h"

/////////////////////////////////////////////
// import the network analyzer type library
/////////////////////////////////////////////
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
 no_namespace, named_guids
/////////////////////////////////////////////
// include the error definitions for the PNA so we can implement
// error handling.
/////////////////////////////////////////////
#include "C:\Program Files\Agilent\Network Analyzer\errorsystemmessage.h"

IApplicationPtr pNA; // top level application pointer
float fScalarData [1601]; // global buffer for data retrieval
float fScalarData2[1601];

DWORD dwCookie;

/////////////////////////////////////////////
// SetupChannel:
//
// input: pointer to the channel
//
// function: sets properties on the channel
/////////////////////////////////////////////
void SetupChannel(IChannelPtr pChannel)
{
pChannel->put_StartFrequency( 1.2E9 );
pChannel->put_StopFrequency ( 4.2E9 );
pChannel->put_NumberOfPoints ( 201);

}

/////////////////////////////////////////////
// AcquireData:
//
// input: pointer to the channel
//
// function: single sweeps the channel
/////////////////////////////////////////////
void AcquireData( IChannelPtr pChannel )
{
pChannel->Single( TRUE );
}

/////////////////////////////////////////////
// ReadData:
//
// input: pointer to the Measurement object
//
// function: reads data from the measurment's formatted
// result data buffer
/////////////////////////////////////////////
void ReadScalarData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pData = fScalarData;

if(pDataTransfer){

pDataTransfer->getScalar( naMeasResult, naDataFormat_LogMag,
 &numVals, pData);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\n",i,pData[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}

void ReadComplexData(IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 1601;
float* pReal= fScalarData;
float* pImag = fScalarData2;

if(pDataTransfer){

pDataTransfer->getPairedData( naRawData, naRealImaginary, &numVals,
 pReal, pImag);

for (int i = 0; i < numVals; i++)
printf("%d\t%f\t%f\n",i,pReal[i], pImag[i]);
}
TCHAR msg[100];
BSTR param;
pMeas->get_Parameter(&param);
swprintf(msg,L"Review %s data",param);
MessageBox(NULL,msg,L"User Message",0);
::SysFreeString(param);
}
/////////////////////////////////////////////
// PutData:
//
// input: pointer to the Measurement object
//
// function: writes data to the measurment's raw data
// buffer
/////////////////////////////////////////////
void PutData( IMeasurementPtr pMeas )
{
IArrayTransferPtr pDataTransfer;
pDataTransfer = pMeas;
long numVals = 201;

if(pDataTransfer){

NAComplex* pComplex = new NAComplex[numVals];

pComplex[0].Im = 0;
pComplex[0].Re = 1;
for (int i = 1; i < numVals; i++)
{
pComplex[i].Im = (float)sin(i)/i;
pComplex[i].Re = (float)cos(i)/i;
}

pDataTransfer->putNAComplex( naRawData, numVals, pComplex, naDataFormat_Polar);
delete [] pComplex;
}
}

/////////////////////////////////////////////
// printError
/////////////////////////////////////////////
void printError( HRESULT hr)
{
BSTR text;

hr = pNA->get_MessageText ((NAEventID) hr, &text);
MessageBox(NULL,text,L"Network Analyzer error",0);
::SysFreeString(text);
}

/////////////////////////////////////////////
// main
/////////////////////////////////////////////
int main(int argc, char* argv[])
{
HRESULT hr;
const long channel1 = 1;
const long window1 = 1;
const long srcport = 1;
IMeasurementPtr pMeasurement;
IChannelPtr pChannel;

// initialize COM libraries
CoInitialize(NULL);

try {
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

pNA->put_Visible(TRUE);
pNA->Reset();

pNA->CreateMeasurement (channel1, "S21",srcport, 5);
hr = pNA->get_ActiveChannel( &pChannel);

if (SUCCEEDED (hr))
{
SetupChannel( pChannel);
AcquireData(pChannel);
}

hr= pNA->get_ActiveMeasurement( &pMeasurement);
if (SUCCEEDED(hr))
{
pMeasurement->put_Format( naDataFormat_Polar);
ReadScalarData( pMeasurement);
ReadComplexData( pMeasurement);
PutData(pMeasurement);
}
if (FAILED(hr))
{
printError(hr);
}

// make sure to release the remaining pointers
// before calling CoUninitialize

pMeasurement.Release();
pChannel.Release();
pNA.Release();
}
catch (_com_error err)
{
printError( err.Error() );
}

CoUninitialize();
return 0;
}


COM Fundamentals

The following is terms are discussed in this topic:

Objects

Collections

Methods

Properties

Events

Note: The information contained in this topic is intended to help an experienced SCPI programmer transition to COM programming. This is NOT a comprehensive tutorial on COM programming.

Objects

The objects of the Network Analyzer (Application) are arranged in a hierarchical order. The Network Analyzer object model lists the objects and their relationship to one another.

In SCPI programming, you must first select a measurement before making settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read settings.

For more information on working with objects, see Getting a Handle to an Object.

Collections

A collection is an object that contains several other objects of the same type. For example, the Channels collection contains all of the channel objects.

Note: In the following examples, the collections are referred to as a variable. Before using a collection object, you must first get an instance of that object. For more information, see Getting a Handle to an Object

Generally, items in a collection can be identified by number or by name. The order for objects in a collection cannot be assumed. They are always unordered and begin with 1. For example, in the following procedure, chans(1) is used to set averaging on the first channel in the Channels collection (not necessarily channel 1).

Sub SetAveraging()
chans(1).AveragingFactor = 10
End Sub

The following procedure uses the measurement string name to set the display format for a measurement in the measurements collection.

meass("CH1_S11_1").Format = 1

You can also manipulate an entire collection of objects if the objects share common methods. For example, the following procedure sets the dwell time on all of the segments in the collection.

Sub setDwell()
segs.DwellTime = 30e-3
End Sub

Methods

A method is an action that is performed on an object. For example, Add is a method that applies to the Channel object. The following procedure uses the Add method to add a new channel named NewChan.

Sub AddChan(newChan as String)
Chan.Add NewChan
End Sub

Properties

A property is an attribute of an object that defines one of the object's characteristics, such as size, color, or screen location. A property can also change an aspect of the object's behavior, such as whether the object is visible. In either case, to change the characteristics of an object, you change the values of its properties.

To change the value of a property, follow the reference to an object with:

  • a period (.)

  • the property name

  • an equal sign (=)

  • the new property value.

For example, the following statement sets the IFBandwidth of a channel.

Chan.IFBandwidth = 1KHz

You can also read the current value of a property. The following statement reads the current IFBandwidth of a channel into the variable Ifbw.

Ifbw = Chan.IFBandwidth

Some properties cannot be set and some cannot be read. The Help topic for each property indicates if you can:

  • Set and read the property (Write/Read)

  • Only read the property (Read-only)

  • Only set the property (Write-only)

Events

An event is an action recognized by an object, such as clicking the mouse or pressing a key. Using events, your program can respond to a user action, program code, or triggered by the analyzer. For example:

OnChannelEvent

For more information, see Working with the Analyzer's Events.


Getting a Handle to an Object

The following are discussed in this topic:

What is a Handle

Declaring an Object Variable

Assigning an Object Variable

Navigating the Object Hierarchy

Getting a Handle to a Collection

What is a Handle

In SCPI programming, you must first select a measurement before changing or reading settings. With COM, you first get a handle to the object (or collection) and refer to that object in order to change or read its settings. The following analogy illustrates this:

A car could be called an object. Like all objects, it has many properties. One of its properties is "Color". You can read (by looking) or set (by painting) the color property of a car object. However, the color value (such as Red or Green) depends on what SPECIFIC car object you are referring to. "Car" is a class of objects. You can only read or set the properties of a specific car object; not the entire car class. Therefore, before reading or setting an object's properties, you need to get "a handle" to a specific object.

You can have handles to many objects at the same time. It does NOT have to be the Active or Selected object.

Note: This process is also called "getting an instance of an object", and "returning an object".

There are two steps for getting a handle to analyzer objects:

  1. Declaring a Variable As an Object

  2. Assigning an Object to the Variable

Note: Before doing this, you must first register the analyzer's type library on your PC. See Connecting to the Analyzer

Declaring a Variable As an Object

Note: The examples in these topics use the Visual Basic Programming Language. The Green text following an apostrophe (') is a comment.

Use the Dim statement or one of the other declaration statements (Public, Private, or Static) to declare a variable. The type of variable that refers to an object must be a Variant, an Object, or a specific type of object. For example, all three of the following declarations are valid:

  • Dim RFNA ' Declare RFNA as Variant data type.

  • Dim RFNA As Object ' Declare RFNA as Object data type.

  • Dim RFNA As AgilentPNA835x.Application ' Declare RFNA As AgilentPNA835x.Application type

Note: If you use a variable without declaring it first, the data type of the variable is Variant by default.

If you know the specific object type, you should declare the object variable as that object type. Declaring specific object types provides automatic type checking, faster code, and improved readability.

Assigning an Object to a Variable

The first and most important object to assign to a variable is the Application object (the Network Analyzer). When assigning an object to a variable, use the Set keyword before the object variable that was declared previously. In the following example, "RFNA" is the variable we declared in the previous examples. So we assign the current AgilentPNA835x Application to "RFNA".

Set RFNA = AgilentPNA835x.Application

However, because the AgilentPNA835x object is the Application server, we must use the CreateObject keyword with the (classname,server name) parameters.

  • The classname for the analyzer object is always "AgilentPNA835x.Application".

  • To find your analyzer's server name, see Sharing Files between your PC and the Analyzer.

For example, the following statements would create an instance of the Analyzer object.

Dim RFNA AS AgilentPNA835x.Application
Set RFNA = CreateObject("AgilentPNA835x.Application", "Analyzer46")

Note: These statements will start the Analyzer application if it is not already running on your instrument.

Once created, you can treat an object variable exactly the same as the object to which it refers. You can set or return the properties of the object or use any of its methods. For example:

RFNA.Visible = True 'Makes the Network Analyzer Application visible on the screen

Navigating the Object Hierarchy

To read and set properties of objects below the Analyzer Application, you do not have to "Create" the object as we did with the Application. But you DO have to navigate the object model hierarchy. (Refer to the Analyzer Object Model).

You could do refer to an object in the hierarchy directly, without declaring and assigning a variables. The following example navigates through the Application object to the Active Measurement which is a 'child' object of the Application. (The ACTIVE measurement is the measurement that is acted on if you change settings from the front panel.)

Application.ActiveMeasurement.SmoothingAperture = 10

You can see that this method makes for a very long statement. Making additional changes to the Active Measurement would require equally long statements.

The following example gets a handle to the Active Measurement object by assigning it to a variable.

The first step is to Declare an object variable:

Public meas AS Measurement

The next step is to Set the object variable:

We already assigned an instance of the (analyzer) Application to the variable RFNA. Therefore, we can use the RFNA variable to refer to a specific instance of the Application object.

Set meas = RFNA.ActiveMeasurement

The variable meas now contains a handle to the Application object (RFNA) and the ActiveMeasurement object. We can now set properties of the ActiveMeasurement as follows:

meas.SmoothingAperature = 10

Getting a Handle to a Collection

The analyzer has several collections of objects which provide a convenient way of setting or reading all of the objects in the collection with a single procedure. Also, there are objects (limit lines for example) that can only be accessed through the collection.

To get a handle to an item in a collection, you can refer to the object by item number or sometimes by name. However, you first have to get a handle to the collection. To assign the collection to a variable, use the same two step process (1. declare the variable, 2. assign the variable using 'Set').

Dim meass As Measurements 'the collection of all measurements currently on the analyzer
Set meass = RFNA.Measurements

Then you can iterate through the entire collection of measurements to read or set properties or execute methods.

meass.Format = naLinMag

Or you can read or set a property on an individual object in the collection:

meass(1).Format = naLinMag

Note: Each object and collection has its own unique way of dealing with item names, and numbers. Refer to the Analyzer Object Model for details.


Collections in the Analyzer

Collections are a gathering of similar objects. They are a convenience item used primarily to iterate through the like objects in order to change their settings. Collections generally provide the following generic methods and properties:

Item(n)
Count
Add(n)
Remove(n)

where (n) represents the number of the item in the collection. Some collections may have unique capabilities pertinent to the objects they collect.

Collections are Dynamic

A collection does not exist until you ask for it. When you request a Channels object (see Getting a Handle to an Object / Collection), handles to each of the channel objects are gathered and placed in an array.

For example, if channels 2 and 4 are the only channels that exist, then the array will contain only 2 items. The command 'channels.Count' will return the number 2, and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 4 object.

The ordering of objects within the collection should not be assumed. If you add a channel to the previous example, as in:

Pna.Channels.Add(3)

'channels.Count' will now return 3 and:

  • Channels(1) will contain the channel 2 object.

  • Channels(2) will contain the channel 3 object.

  • Channels(3) will contain the channel 4 object.

Primarily, collections are useful for making this type of iteration possible:

Dim ch as Channel
For each ch in pna.Channels
Print ch.Number
Print ch.StartFrequency
Print ch.StopFrequency
Next ch

As soon as this for-each block has been executed, the Channels object goes out of scope.


Siehe auch...

Einrichten des Analysators für COM-DCOM-Programmierung

Überblick

Zugriffs-
erlaubnisse

Zugriffs-
prozedur

Registrieren

Probleme?

Bevor Sie COM-Programme entwickeln oder ausführen, müssen Sie eine Kommunikation zwischen Ihrem PC und dem Analysator aufbauen. Erst dann haben Sie "Zugriff auf den Analysator". Im nächsten Schritt müssen Sie die Typenbibliothek des Analysators auf Ihrem PC registrieren.
Zugriffserlaubnisse

Zugriffsprozedur

Registrieren des Analysators auf dem PC

Probleme?

Standardmäßig ist der Analysator so konfiguriert, dass jeder die Erlaubnis hat, die PNA-Anwendung über COM/DCOM zu starten und darauf zuzugreifen. Die Bedeutung des Begriffs jeder hängt davon ab, ob der PNA Mitglied einer Domain oder einer Arbeitsgruppe ist (er kann nur zu einer dieser Kategorien zählen, nicht zu beiden gleichzeitig).

Hinweis: "DCOM (Distributed Component Object Model)" betrifft den Zugriff auf den Analysator von einem vernetzten PC aus.
"COM" betrifft den Zugriff auf den Analysator vom analysatorinternen PC aus.

Arbeitsgruppe

Eine Arbeitsgruppe wird vom PNA-Verwalter eingerichtet; dieser spezifiziert den Arbeitsgruppennamen und erklärt den PNA zu einem Mitglied der Arbeitsgruppe. Eine Arbeitsgruppe benötigt keinen Netzwerkverwalter, um sich selbst einzurichten oder die Mitgliedschaft zu verwalten.

Zur Kategorie jeder gehören nur solche Benutzer, für die "Logon Accounts" auf dem PNA eingerichtet wurden.

Standardmäßig ist der PNA als Mitglied einer Arbeitsgruppe mit dem Namen WORKGROUP eingerichtet.

Hinweis: Informationen zum Einrichten eines "Logon accounts" für einen neuen Benutzer siehe Weitere Netzwerkanalysatorbenutzer.
Für den DCOM-Zugriff müssen der Account-Name und das Passwort des Benutzers EXAKT mit dem PC-"Logon Account"-Namen und -Passwort übereinstimmen.

Domain

Eine Domain ist typischerweise eine große, organisierte Gruppe von Computern. Domains und deren Mitgliedschaften werden vom Netzwerkverwalter verwaltet.

Zur Kategorie jeder gehören solche Personen, die Mitglied der betreffenden Domain sind. Zusätzlich können auch solche Personen, für die ein entsprechendes "Logon account" eingerichtet ist, auf den Analysator zugreifen.

Zusammenfassung:

  • Eine Arbeitsgruppe erfordert keinen Verwalter; nur solche Benutzer, für die ein "Logon account" für den PNA eingerichtet wurde, haben DCOM-Zugriff auf den Analysator.

  • Eine Domain erfordert einen Verwalter; alle Mitglieder der Domain sowie Personen mit "Logon account" für den PNA haben DCOM-Zugriff auf den Analysator.

Auf der nächsten Sicherheitsstufe können die DCOM-Access- und Launch-Zugriffserlaubnisse auf ausgewählte ("selected") statt alle ("Everyone") Domains und Arbeitsgruppen beschränkt werden.

Hinweis: Diese Prozedur setzt voraus, dass für den Benutzer ein "Logon account" auf dem PNA eingerichtet wurde. Siehe Weitere Netzwerkanalysatorbenutzer

Diese Prozedur dient dazu,

  • die DCOM-"Access"- und "Lauch"-Erlaubnisse auf ausgewählte Benutzer (statt "everyone") zu beschränken. (Die "Launch"-Erlaubnis ermöglicht es dem betreffenden Benutzer, die Analysatoranwendung zu starten, falls sie nicht bereits läuft).

  • zu verifizieren, dass Sie die DCOM-"Access"-Erlaubnis für den Zugriff auf den Analysator haben.

Führen Sie die folgenden Schritte sowohl für die "Access"- als auch für die "Launch"-Erlaubnis aus:

  1. Klicken Sie am PNA auf die Windows-Start-Schaltfläche.

  2. Klicken Sie auf Run.

  3. Geben Sie in das Feld Open: folgendes ein: dcomcnfg.

  4. Klicken Sie auf OK.

  5. Klicken Sie in dem Fenster "Distributed COM Configuration Properties" in der Liste "Applications" auf Agilent PNA Series. Klicken Sie anschließend auf die Schaltfläche Properties...

  6. Klicken Sie auf die Registerkarte Security.

"Access"-Erlaubnis

Die folgende Prozedur richtet auf dem PNA für bestimmte Benutzer eine DCOM-"Access"-Erlaubnis ein:

Navigieren Sie zum Dialogfenster Agilent PNA Series Properties:

  1. Klicken Sie auf Use custom access permissions.

  2. Klicken Sie auf Edit&ldots; neben (Use custom access permissions).

  3. Wählen Sie im Feld "Registry Value Permissions" Everyone.

  4. Klicken Sie auf Remove.

  5. Klicken Sie auf Add.

  6. Sie können bestimmte Benutzer oder eine oder mehrere Benutzergruppen auswählen, um ihnen die "Access"-Erlaubnis für die PNA-Anwendung zu gewähren.

    1. Wenn Sie einer Gruppe die "Access"-Erlaubnis gewähren möchten, wählen Sie die betreffende Gruppe aus der Liste.

    2. Wenn Sie bestimmten Benutzern die "Access"-Erlaubnis gewähren möchten, klicken Sie auf Show users oder Members, und wählen Sie die betreffenden Namen aus der Liste.

  7. Klicken Sie auf Add.

  8. Klicken Sie auf OK
    9. .

"Launch"-Erlaubnis

Die folgende Prozedur richtet auf dem PNA für bestimmte Benutzer eine "Launch"-Erlaubnis (zum Starten der PNA-Anwendung) ein. Die Prozedur ist die gleiche wie die zum Einrichten einer "Access"-Erlaubnis.

Navigieren Sie zu Agilent PNA Series Properties:

  1. Klicken Sie auf Use custom launch permissions.

  2. Klicken Sie auf Edit&ldots; (neben Use custom launch permissions).

  3. Wählen Sie im Feld "Registry Value Permissions" Everyone.

  4. Klicken Sie auf Remove.

  5. Klicken Sie auf Add

  6. Sie können bestimmte Benutzer oder eine oder mehrere Benutzergruppen auswählen, um ihnen die "Launch"-Erlaubnis zum Starten der PNA-Anwendung zu gewähren.

    1. Wenn Sie einer Gruppe die "Launch"-Erlaubnis gewähren möchten, wählen Sie die betreffende Gruppe aus der Liste.

    2. Wenn Sie bestimmten Benutzern die "Launch"-Erlaubnis gewähren möchten, klicken Sie auf Show users oder Members, und wählen Sie die betreffenden Namen aus der Liste.

  7. Klicken Sie auf Add.

  8. Klicken Sie auf OK.

Navigieren Sie zu Agilent PNA Series Properties:

  1. Klicken Sie auf die Registerkarte Identity.

  2. Klicken Sie auf The interactive user. Diese Funktion unterstützt Events in PNA COM.

Registrierung der Type Library des Analysators auf Ihrem PC

Die Type Library enthält das Objektmodell des Analysators. Objektmodelle müssen in der Registry-Datei des PCs, den Sie zur Entwicklung und Ausführung von Programmen verwenden möchten, angemeldet werden. Deshalb müssen Sie die Type Library des Analysators auf Ihrem PC registrieren. Es ist sehr zu empfehlen, die Type Library schon zur Entwurfszeit zu registrieren, BEVOR Sie Ihr COM-Programm starten.

Tun Sie vorab folgendes:

  1. Schließen Sie sowohl Ihren PC als auch den Analysator an das LAN an.

  2. Sie können entweder ein Netzlaufwerk auf den Analysator abbilden oder die Type-Library-Dateien auf eine Diskette oder sonstiges Medium kopieren. Informationen über das Abbilden eines Netzlaufwerks siehe Abbilden von Netzlaufwerken.

Hinweis: Um die Type Library auf Ihrem PC registrieren zu können, müssen Sie bei Ihrem PC als Verwalter angemeldet sein.

Diese Prozedur setzt voraus, dass ein Netzlaufwerk Ihres PCs auf dem Analysator abgebildet ist. Diese Prozedur bewirkt folgendes:

  • Die PNA-Anwendung wird auf dem PC registriert.

  • Die "proxystub"-Datei (835xps.DLL) wird auf den PC kopiert und dort registriert.

  • Die Type Library (835x.tlb) wird auf den PC kopiert und dort registriert.

  1. Ermitteln Sie auf Ihrem PC im Windows-Explorer den Freigabenamen des Analysator-Laufwerks "C:" drive. Der Freigabename auf dem PC lautet nicht "C:", sondern entspricht der Laufwerksbezeichnung, die Sie beim Abbilden des Laufwerks vergeben haben.

  2. Navigieren Sie zu Program Files \ Agilent \ Network Analyzer \ Automation.

  3. Doppelklicken Sie auf Automation.vbs.

Hinweis: Wenn das Dialogfenster "Open With" erscheint, bedeutet das, dass der Windows Scripting Host nicht auf Ihrem PC installiert ist. Den Windows Scripting Host können Sie kostenlos von der Microsoft-Website herunterladen. Die URL lautet: http://www.microsoft.com/msdownload/vbscript/scripting.asp

  4. Das Visual Basic Script-Programm fragt nach dem Analysatornamen. (Sie finden den Analysatornamen in der Systemsteuerung des Analysators unter "System \ Network Identification \ Full Computer name:". Geben Sie an der Eingabeaufforderung den Analysatornamen ein.

  5. Klicken Sie, wenn das Script ausgeführt wird, auf OK. Die Type Library des Analysators wird jetzt auf Ihrem PC registriert.

Hinweis: Ihre Programmierumgebung erfordert eventuell, dass Sie eine Referenz auf die Type Library auf Ihrem PC einrichten.

Beim Installieren der PNA-Anwendung auf dem Analysator werden die Anwendung und alle zugehörigen Objekte auf diesem System registriert. Der Analysator kann anschließend als Remote Server fungieren.

Sollte der Analysator nicht ordnungsgemäß funktionieren, versuchen Sie, die Anwendung und die zugehörigen Bibliotheken manuell nochmals auf dem Analysator zu registrieren. Gehen Sie folgendermaßen vor:

Hinweis: Die folgenden Schritte müssen unbedingt in der angegebenen Reihenfolge ausgeführt werden.

Tun Sie auf Ihrem PC mit einem darauf abgebildeten PNA-Netzlaufwerk folgendes:

Suchen Sie nach 835x.exe in C:\Program Files\Agilent\NetworkAnalyzer

  1. Wählen Sie die folgende Datei und doppelklicken Sie darauf: 835x.exe.

  2. Wählen Sie zum Registrieren der Anwendung Register COM Server.

  3. Wählen Sie die folgende Datei und doppelklicken Sie darauf: 835xps.DLL.

  4. Wählen Sie Register COM Server.

Führen Sie anschließend die "Access procedure" aus (starten Sie "dcomcnfg").


COM Data Types

The Analyzer uses several data types to communicate with the host computer. Before using a variable, it is best to declare the variable as the type of data it will store. It saves memory and is usually faster to access. The following are the most common data types:

Long Integer

Single Precision (Real)

Double Precision (Real)

Boolean

String

Object

Enumeration

Variant

Long (long integer) variables are stored as signed 32-bit (4-byte) numbers ranging in value from -2,147,483,648 to 2,147,483,647.

Double (double-precision floating-point) variables are stored as IEEE 64-bit (8-byte) floating-point numbers ranging in value from -1.79769313486232E308 to -4.94065645841247E-324 for negative values and from 4.94065645841247E-324 to 1.79769313486232E308 for positive values.

Single (single-precision floating-point) variables are stored as IEEE 32-bit (4-byte) floating-point numbers, ranging in value from -3.402823E38 to -1.401298E-45 for negative values and from 1.401298E-45 to 3.402823E38 for positive values.

Boolean variables are stored as 16-bit (2-byte) numbers, but they can only be True or False. Use the keywords True and False to assign one of the two states to Boolean variables.

When other numeric types are converted to Boolean values, 0 becomes False and all other values become True. When Boolean values are converted to other data types, False becomes 0 and True becomes -1.

String variables hold character information. A String variable can contain approximately 65,535 bytes (64K), is either fixed-length or variable-length, and contains one character per byte. Fixed-length strings are declared to be a specific length. Variable-length strings can be any length up to 64K, less a small amount of storage overhead.

Object variables are stored as 32-bit (4-byte) addresses that refer to objects within the analyzer or within some other application. A variable declared as Object is one that can subsequently be assigned (using the Set statement) to refer to any actual analyzer object.

Enumerations (Enum) are a set of named constant values. They allow the programmer to refer to a constant value by name instead of by number. For example:

Enum DaysOfWeek
Sunday = 0
Monday = 1
Tuesday = 2
Wednesday = 3
Thursday = 4
Friday = 5
Saturday = 6
End Enum

Given this set of enumerations, the programmer can then pass a constant value as follows:
SetTheDay(Monday)
rather than
SetTheDay(1)
where the reader of the code has no idea what the value 1 refers to.

However, the analyzer RETURNS a long integer, not the text.
Day = DaysofWeek(today) 'Day = 1

Variant - If you don't supply a data type, the variable is given the Variant data type. The Variant data type is like a chameleon — it can represent many different data types in different situations.

The analyzer provides and receives Variant data in several instances because there a programming languages that cannot send or receive "typed" data. Variant data transfers at a slower rate than "typed" data.


Working with the Analyzer's Events

Working with Events

What are Events?

Using the Analyzer's Events

Event ID's

Filtering Events

List of Events

Out of Range Errors

Troubleshooting Problems with Events

What are Events?

Windows applications work from user-initiated events such as mouse moves and mouse clicks. A mouse-click produces an event that the programmer can either ignore or "handle" by providing an appropriate subroutine like this:

Sub DoThis_onClick
Perform something
End Sub

If this subroutine were in your program and the mouse-click event occurs on your PC, it would generate a "Callback" to the client and interupt whatever it was doing and handle the event.

A more practical example of an event in the analyzer is Limit test. If limit test is on and the measurement fails, the analyzer produces a '"Limit-failed" event. If the measurement passed, the analyzer produces a "Limit-succeeded" event.

The Analyzer has a very sophisticated Event structure. Your program CAN be notified when one or more events occur. However, it may not be necessary.

For example, the analyzer has an event that will notify your program when a sweep is complete. A simpler alternative is to use a synchronous command which waits for the sweep to complete.

sync = True
app.ManualTrigger sync
chan.StartFrequency = 4.5E6

This would NOT work if you want the controller to do other things while waiting, like setup a power meter or sort some data. In this case you would like a "callback" from the analyzer to let your program know that the sweep has completed.

Another reason to use events is when you want to be notified of several conditions when they occur, such as errors or source unlock conditions. It would not be practical to routinely poll these conditions while executing your program.

Using Events

If you decide to use the COM events to get a callback, your program must do two things:

1. Subscribe to events:

All events in the analyzer are a child of the Application object through the INetworkAnalyzerEvents Interface. You must tell the Application object that you are interested in receiving event callbacks. This process is called subscription.

In Visual Basic, this is done by including "WithEvents" in the declaration statement. The declaration below dimensions an Application object (myPNA) and subscribes to the events produced by the Application.

Dim WithEvents myPNA as AgilentPNA835x.Application

In C++, this is a bit more involved. You must queryInterface for the IconnectionPointContainer interface, locate the InetworkAnalyzerEvents interface via a call to FindConnectionPoint and call Advise().

2. Implement the Event Handler

When an event occurs, the Application object will "callback" to the client through the InetworkAnalyzerEvents interface.

In VB, click on the object window (upper left pane). Find the Application object and click it. The event interfaces will appear in the upper right pane. As you click on them, VB supplies the first line of code. You fill in the rest of the handler routine to service the event. The following is an example of a event handler subroutine.

Note: In C++, you must type the callback.

Private Sub OnChannelEvent( eventID as Variant, channelNumber as Variant)
Select Case (eventID)
Case naEventID_CHANNEL_TRIGGER_COMPLETE:
GetData( channelNumber )
Case naEventID_CHANNEL_TRIGGER_ABORTED:
MsgBox( "Hey don't touch the front panel!")
End Select
End Sub

When the trigger is complete, the application object "fires" the event by making a callback to the event handler Sub OnChannelEvent().

Event IDs

3 | 3 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 2 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Sev |  | C | R | Facility |  |  |  |  |  |  |  |  |  |  | Code
Sev | Severity Code
C | Customer code flag (not used)
R | Reserved bit (not used)
Facility | Category code
Code | Event ID

Filtering Events

There are over 140 different events that you subscribe to when you "Dim WithEvents..." (or the equivalent in your programming language). Monitoring all of these conditions slows the speed of the analyzer significantly. The following methods allow you to filter the events so that you only monitor specific conditions.

  • AllowEventMessage - monitor a specific event

  • AllowAllEvents - monitor ALL events

  • DisallowAllEvents - monitor NO events

  • AllowEventCategory - monitor specific event categories (discussed later)

  • AllowEventSeverity - monitor events having one or more of the following severity levels associated with them.
Code | Severity Enumeration
00 | naEventSeveritySUCCESS - the operation completed successfully
01 | naEventSeverityINFORMATIONAL - events that occur without impact on the measurement integrity
10 | naEventSeverityWARNING - events that occur with potential impact on measurement integrity
11 | naEventSeverityERROR - events that occur with serious impact on measurement integrity

List of Events

The following is a list of categories and the general types of events they include. Click the link view the event details.

Category Enumeration | Callback
naEventCategory_PARSER | OnSCPIEvent
naEventCategory_MEASURE | OnMeasurementEvent
naEventCategory_CHANNEL | OnChannelEvent
naEventCategory_HW | OnHardwareEvent
naEventCategory_CAL | OnCalEvent
naEventCategory_USER | OnUserEvent
naEventCategory_DISPLAY | OnDisplayEvent
naEventCategory_GENERAL | OnSystemEvent

Note: Use the MessageText Method to get a text message describing the event.

Out of Range Errors

When you attempt to set a value on an active function that is beyond the range (min or max) of the allowable values, the analyzer limits that value to an appropriate value (min or max) and sets the function to the limited value. From the front panel controls this is visually evident by the limited value in the edit box or by the annotation on the display. An example would be attempting to set the start frequency below 300kHz. The edit control doesn't allow the number to fall below 300kHz.

When the automation user programs a setting (such as start frequency below the allowable limits) the same behavior takes place. The analyzer accepts the limited value. However, in order to learn what setting took place, you have to read the HRESULT.

All automation calls return HRESULTs. By default the HRESULT returned when an overlimit occurs is S_NA_LIMIT_OUTOFRANGE. This value is a success code, meaning that bit 31 in this 32 value is 0. Programmers should check the return code from all automation calls to determine success or failure.

Some C++ macros (like SUCCEEDED(hr) or FAILED(hr) ) only check bit 31. So if you are interested in trapping this outOfRange error you will have to check for S_NA_LIMIT_OUTOFRANGE explicity.

Alternatively, you can configure the analyzer to report outOfRange conditions with an error code. Use the method: App.SetFailOnOverRange (true). With this method set TRUE, any overrange error will return E_NA_LIMIT_OUTOFRANGE_ERROR.

This method is provided for the benefit of VB clients. VB users can't detect specific success codes because the VB runtime strips off the HRESULT and only raises a run time error if bit 31 is set, indicating a fail code.

Troubleshooting Problems with Callbacks

When you do callbacks, the client PC becomes the server and the analyzer (server) becomes the client. Callbacks can only take place when both server and client are in the same workgroup or in the same domain. See Configure for COM.


C++ and the COM Interface

Programming The PNA with C++

The programming information contained in this Help system is aimed at the Visual Basic programmer. VB does a lot of work for the programmer when it comes to managing and accessing components. Using a lower level language like C++ requires a more thorough understanding of the underlying tenets of COM. It is not the intent of this section to teach COM programming. The following is intended to acquaint you with some of the basic concepts you need to know in order to program against COM.

Initializing COM

Importing the Type Library

Creating the Application Object

Errors

Events

Additional Reading

Example

Note: The information in this section assumes development on a Windows OS using Microsoft tools.

Initializing COM

The first thing you must do before performing any COM transactions is to initialize the COM library. You can do this in a number of ways. The most basic of these is a call to CoInitialize( ) or CoIntializeEx( ). Alternatively you can use the MFC (Microsoft Foundation Classes) AfxOleInit( ).

Conversely, before your program exits you must uninitialize COM. You can accomplish this with CoUninitialize( ) or the MFC routine AfxOleTerm( ).

Importing the Type Library

To make a component available to the client, the server exports what is called the type library. For the PNA, this file is 835x.tlb. It is located on the PNA's hard drive at C:\Program Files\ Agilent\ Network Analyzer\ Automation. See Configure for COM-DCOM Programming.

The type library can be read and deciphered using another COM interface called ITypeLib. VB uses this interface to present, for example, its object browser. Visual C++ can also read type libraries. This is done by importing the type library into your project with a compiler directive:

#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb", named_guids

When you compile your program with this statement in it, the compiler creates two other files: 835x.tlh and 835x.tli. The first is a header file that contains the type definitions for the PNA's COM interfaces and their methods. The second file contains inline functions that wrap the PNA's interface methods. The wrappers are beneficial in that they contain error reporting for each of the method calls.

The .tlh file defines a smart pointer which you can use to access the PNA's objects. The smart pointer definition looks like this:

_com_smartptr_typedef(Iapplication, _uuidof(Iapplication))

A smart pointer is a term used for a C++ object that encapsulates a pointer used to refer to a COM object. All COM objects derive from the interface IUnknown. This interface has three methods: QueryInterface( ), AddRef( ), and Release( ). The function of the AddRef and Release methods is to maintain a reference count on the object and thus control the object's lifetime. Anytime you copy or create a reference to a COM object, you are responsible for incrementing its reference count. And likewise, when you are finished using that reference, it is your responsibility to Release it. Smart pointers do this work for you, as shown in the example program. In addition, smart pointers will also perform the QueryInterface call when required. QueryInterface is a method that requests a specific interface from an object. In the example program we gain access to the IArrayTransfer interface of the Measurement object. In the ReadMethod routine, we see this:

PTransferData = pMeas;

The assignment operator is overloaded for the smart pointer and in reality, this simple statement does this:

HRESULT hr = pMeas->QueryInterface( IID_IArrayTransfer,(void**)&pTransferData);

Using the existing interface pointer (pMeas) to the object, this call asks the object if it supports the IArrayTransfer interface, and if so to return a pointer to it in pTransferData. Smart pointer makes life easier for the C++ programmer. Read more about smart pointers in Microsoft Developer's Network Library (MSDN).

Creating the Application Object

The only createable object exported by the PNA is the Application object. Typically this would be done with a call to CoCreateInstance:

STDAPI CoCreateInstance(
CLSID__IApplication, //Class identifier (CLSID) of the object
NULL, //Pointer to controlling IUnknown
CLS_CTX_SERVER, //Context for running executable code
IID_IApplication, //Reference to the IID of the interface
(void**)&pNA //Address of output variable that receives
// the interface pointer requested in riid
);

With the smart pointer, this is taken care of with the following call:

IApplicationPtr pNA; // declare the smart pointer
pNA = IApplicationPtr("AgilentPNA835x.Application.1");

Errors

All COM method calls are required to return an HRESULT. This is 32 bit long with a specific format.

  • The most significant bit indicates success(0) or failure(1).

  • The lower 16 bits indicate the specific failure.

Visual Basic strips off the returned HRESULT and raises an error object for non-successful returns. The C++ programmer must himself be diligent about handling errors. You must check the return value of each COM call to ensure its success.

Events

The Application object sources the INetworkAnalyzerEvents interface. This object is the source for all events. To use events in C++, you must do two things:

  1. Implement the INetworkAnalyzerEvents interface - derive an object from INetworkAnalyzerEvents and implement the methods described there.

  2. Subscribe to the IconnectionPoint interface of the Application object. - obtain a pointer to the IConnectionPointContainer interface of the Application object and making the following request:

FindConnectionPoint( IID_InetworkAnalyzerEvents, &pConnection );

A successful call to this interface will return a valid pointer in pConnection. Use this pointer to subscribe to the Application object:

pConnect->Advise( IUnknown* punk, DWORD dwCookie);

This call provides the server object with a callback address. The Iunkown pointer in this call is the IUnkown pointer of the object that implements the INetworkAnalyzerEvents interface. This is the event sink. The application object needs a pointer to this object in order to call your interface when an event occurs. The dwCookie is your subscription key. Use it to unsubscribe (see Unadvise( ) ).

Additional Reading

"MSDN" - Microsoft Developer's Network Library

"Learning DCOM", by Thuan L. Thai, published by O'Reilly(1999)

"Inside COM", by Dale Rogerson, published by Microsoft Press (1997),

"Understanding ActiveX and OLE", by David Chappell, also published by Microsoft Press (1996), and

"Beginning ATL COM Programming", published by Wrox Press (1998).

Example

The example uses the smart pointer created by Microsoft Visual Studio. The calls to CoInitialize and CoUninitialize open and close the COM libraries. In the example, notice that the pointers local to the main routine are explicitly released. When smart pointers go out of scope, they will perform this duty implicitly. However, we are calling CoUninitialize before they have the chance to be destroyed, so we are obliged to release them.

See the example program.


SCPI Command Tree

:CORRection

Sets Electrical Delay and Phase Offset

:DATA?

Queries measurement data.

:FILTer

Sets time domain gating

:FORMat

Sets the display format

:FUNCtion

Controls Trace Statistics

:LIMit

Controls limit lines for pass / fail testing

:MARKer

Controls the marker settings

:MATH

Performs math on the memory trace

:PARameter

Creates and deletes measurements

:RDATa?

Queries receiver data

:SMOothing

Controls point-to-point smoothing

:TRANsform

Controls time domain transform settings

:AVErage

Sets sweep averaging parameters

:BANDwidth

Specifies the IF filter bandwidth

:CORRection

Provides calibration capability.

:CORR:COLL:CKIT

Defines calibration standards

:COUPle

Sets sweep as Chopped or Alternate

:FREQuency

Controls frequency sweep functions

:POWer

Sets receiver attenuation and overpower protection

:ROSCillator

Returns the source of the reference oscillator.

:SEGMent

Defines the segment sweep settings.

:SWEep

Specifies the sweep modes of the analyzer.

See Also...

SCPI Command Tree

IEEE- 488.2 Common Commands

SCPI Commands

ABORt

Stops all sweeps

CALCulate __Click to show CALC commands

DISPlay

Controls the display settings

FORMat

Sets the format for data transfer

HCOPy

Controls hardcopy printing

INITiate

Sets continuous or manual triggering

MMEMory

Saves and recalls instrument states

OUTPut

Turns RF power ON and OFF

SENSe __Click to show SENSe commands

SOURce

Controls the power to the DUT

STATus

Reads the analyzer status registers

SYSTem

Controls the analyzer defaults

TRIGger

Starts or ends a measurement


About Triggering

Abort Command

ABORt

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep.
Examples | ABOR abort
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:ABORt


Common Commands

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Agilent Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TRG - Trigger

Triggers a sweep on the active measurement channel when in trigger hold mode (ignored if the analyzer is in continuous sweep mode).

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status. An 0 indicates no failures found. Any other value indicates one or more of the following conditions exist. The value returned is the Weight (or sum of the Weights) of the existing conditions. For example:

  • If 4 is returned from *TST?, an Overpower condition exists.

  • If 6 is returned, both Unleveled and Overpower conditions exists.
Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Phase Unlock | the source has lost phaselock. This could be caused by a reference channel open or a hardware failure.
1 | 2 | Unleveled | the source power is unleveled. This could be a source is set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
2 | 4 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
3 | 8 | EE Write Failed | an attempted write to the EEPROM has failed. This is possibly caused by a hardware failure.
4 | 16 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
5 | 32 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
6 | 64 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization


Correction

About Phase Accuracy

Calc:Correction Commands

Controls Electrical Delay and Phase Offset

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. To select the measurement use CALC<ChanNum>:PAR:SEL <MeasName>.

CALCulate<cnum>:CORRection:EDELay:TIME <num>

(Read-Write) Sets the electrical delay for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor.
Examples | CALC1:CORR:EDEL:TIME 1NS calculate2:correction:time 0.5e-12
Query Syntax | CALCulate:CORRection:EDELay:TIME?
Return Type | Character
Overlapped? | No
Default | 0 seconds

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>]

(Read-Write) Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:CORR:OFFS:PHAS 10 calculate:correction:offset:phase 20rad
Query Syntax | CALCulate:CORRection:OFFSet:PHASe?
Return Type | Character, returned value always in degrees
Overlapped? | No
Default | 0 degrees

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:CORRection:EDELay:TIME 10e-12
:CALCulate1:CORRection:EDELay:TIME?
:CALCulate 1:CORRection:OFFSet:PHASe 90deg
:CALCulate 1:CORRection:OFFSet:PHASe?


Data

FDATA - one number per trace point
SDATA - two numbers per trace point
FMEM - one number per trace point
SMEM - two numbers per trace point
All Error Terms - two numbers per trace point

Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflect.Tracking | 1
SCORR4 | Isolation | 1
SCORR5 | Load Match | 1
SCORR6 | Trans.Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflect.Tracking | 2
SCORR10 | Isolation | 2
SCORR11 | Load Match | 2
SCORR12 | Trans.Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Directivity | 1
SCORR2 | Source Match | 1
SCORR3 | Reflection Tracking | 1
SCORR7 | Directivity | 2
SCORR8 | Source Match | 2
SCORR9 | Reflection Tracking | 2
Specify this <char>... | to get this Term... | from this Port.
SCORR1 | Reflect.Tracking | 1
SCORR7 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR2 | Reflect.Tracking | 1
SCORR8 | Reflect.Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR12 | Transmission Tracking | 2
Specify this <char>... | to get this Term... | from this Port
SCORR6 | Transmission Tracking | 1
SCORR4 | Isolation | 1
SCORR12 | Transmission Tracking | 2
SCORR10 | Isolation | 2

See Also...

About Accessing Data

Calc:Data Command

CALCulate<cnum>:DATA <char>

Write Measurement data, Memory data, or Error terms.

CALCulate<cnum>:DATA? <char>
Read Measurement data, Memory data, or Error terms.
Return Data Format:

Parameters

<cnum> - Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char> - To write or read Measurement and Memory Data, choose from:

FDATA - formatted trace data from measResult location
SDATA - corrected complex trace data from rawMeas location
FMEM - formatted memory data from memResult location
SMEM - corrected complex data from rawMemory location

<char> - To write or read Error Terms...

For 2-Port SOLT and TRL calibrations,

For 1-Port calibrations:

For Response Open calibrations:

For Response Short calibrations:

For Response Thru calibrations:

For Response Thru and Isolation calibrations:

EXAMPLE - See an example using this command.

Overlapped? - No

Default - Not Applicable

Notes:

  • When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • When querying error terms, there must be error terms in the analyzer.

  • If interpolation is ON and the number of points changes after the initial calibration, the error terms will then be the interpolated results.

  • To get and put receiver data, see CALC:RDATA?

  • To get uncorrected ratioed data, turn correction OFF and use Calc:Data SDATA.

  • CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Learn more about Error Terms


Filter

About Gating

Calc:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start / stop) or (center / span) commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

(R ead-Write) Sets the gate filter center time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:CENT -5 ns calculate2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

(R ead-Write) Sets the gating filter shape when in time domain. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE - NORMal - MINimum - the narrowest gate filter available
Examples | CALC:FILT:GATE:TIME:SHAP MAX calculate2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

(R ead-Write) Sets the gate filter span time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Time span in seconds; Choose any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:SPAN 5 ns calculate2:filter:time:span maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

(R ead-Write) Turns gating state ON or OFF. Critical Note: Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<boolean> | ON (or 1) - turns gating ON. OFF (or 0) - turns gating OFF.
Examples | CALC:FILT:TIME:STAT ON calculate2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

(R ead-Write) Sets the gate filter start time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STAR 1e-8 calculate2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

(R ead-Write) Sets the gate filter stop time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STOP -1 ns calculate2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

(R ead-Write) Sets the type of gate filter used. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:FILT:TIME BPAS calculate2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Overlapped? | No
Default | BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:FILTer:GATE:TIME:CENTer 10ms
:CALCulate1:FILTer:GATE:TIME:CENTer?
:CALCulate1:FILTer:GATE:TIME:SHAPe MAX
:CALCulate1:FILTer:GATE:TIME:SHAPe?
:CALCulate1:FILTer:GATE:TIME:SPAN 10ms
:CALCulate1:FILTer:GATE:TIME:SPAN?
:CALCulate1:FILTer:GATE:TIME:STARt 10ms
:CALCulate1:FILTer:GATE:TIME:STARt?
:CALCulate1:FILTer:GATE:TIME:STATe ON
:CALCulate1:FILTer:GATE:TIME:STATe?
:CALCulate1:FILTer:GATE:TIME:STOP 10ms
:CALCulate1:FILTer:GATE:TIME:STOP?
:CALCulate1:FILTer:GATE:TIME:TYPE NOTCh
:CALCulate1:FILTer:GATE:TIME:TYPE?


Format Calc

About Data Format

Calc:Format Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

  • See an example us ing this command.

CALCulate<cnum>:FORMat <char>

(Read-Write) Sets the display format for the measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

  • MLINear

  • MLOGarithmic

  • PHASe

  • IMAGinary

  • REAL

  • POLar

  • SMITh

  • SWR

  • GDELay

Examples

CALC:FORM MLIN
calculate2:format polar

Query Syntax

CALCulate<cnum>:FORMat?

Return Type

Character

Overlapped?

No

Default

MLINear

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FORMat MLIN
:CALCulate 1:FORMat?


Function

About Trace Statistics

Calc:Function Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FUNCtion:DATA?

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Return Type

Character

Example

CALCulate2:FUNCtion:DATA?

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

(Read-Write) Sets the range used to calculate trace statistics. Each channel shares 10 domain ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<range>

Range number. Choose from: 0 to 9

  • 0 is Full Span of the current x-axis range

  • 1 to 9 are user-specified ranges

Examples

CALC:FUNC:DOM:USER 4
calculate2:function:domain:user:range 0

Query Syntax

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe]?

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

(Read-Write) Sets the start of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:STOP. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 9
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STAR 1,1e9 calculate2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

(Read-Write) Sets the stop of the user-domain range. Must also set CALC:FUNC:DOM:USER and CALC:FUNC:DOM:USER:START. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 9
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STOP 4,5e9 calculate2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:FUNCtion:TYPE <char>

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace
Examples | CALC:FUNC:TYPE PTP calculate2:function:type stdev
Query Syntax | CALCulate<cnum>:FUNCtion:TYPE?
Return Type | Character
Overlapped? | No
Default | PTPeak

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:FUNCtion:DATA?
:CALCulate 1:FUNCtion:DOMain:USER:RANGe 0
:CALCulate 1:FUNCtion:DOMain:USER:RANGe?
:CALCulate 1:FUNCtion:DOMain:USER:STARt 1, 1e9
:CALCulate 1:FUNCtion:DOMain:USER:STARt? 1
:CALCulate 1:FUNCtion:DOMain:USER:STOP 4, 5e9
:CALCulate 1:FUNCtion:DOMain:USER:STOP? 4
:CALCulate 1:FUNCtion:TYPE PTP
:CALCulate 1:FUNCtion:TYPE?


Limit

About Limit Lines

Calc:Limit Commands

Controls the limit segments used for pass / fail testing.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:LIMit:DATA <block>

(Read-Write) Sets data for limit segments. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

"CALC:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30"

Query Syntax

CALCulate<cnum>:LIMit:DATA?

Return Type

Definite length block - All 100 predefined limit segments are returned.

Overlapped?

No

Default

100 limit segments - all values set to 0

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

(Read-Write) Turns the display of limit segments ON or OFF (if the data trace is turned ON). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns the display of limit segments ON. OFF (or 0) - turns the display of limit segments OFF.
Examples | CALC:LIM:DISP:STAT ON calculate2:limit:display:state off
Query Syntax | CALCulate<cnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STAR 10 calculate2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

(Read-Write) Sets the start (beginning) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:STIM:STAR 10 calculate2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

(Read-Write) Sets the stop (end) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

(Read-Write) Sets the type of limit segment. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:LIM:SEGM:TYPE LMIN calculate2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE?
Return Type | Character
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

(Read-Write) Turns limit testing fail sound ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns sound ON. OFF (or 0) - turns sound OFF.
Examples | CALC:LIM:SOUN ON calculate2:limit:sound:state off
Query Syntax | CALCulate<cnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:STATe <ON | OFF>

(Read-Write) Turns limit segment testing ON or OFF. Use CALC:LIM:DISP to turn ON and OFF the display of limit segments. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns limit testing ON. OFF (or 0) - turns limit testing OFF.
Examples | CALC:LIM:STAT ON calculate2:limit:state off
Query Syntax | CALCulate<cnum>:LIMit:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:LIMit:DATA <block>
:CALCulate1:LIMit:DATA?
:CALCulate 1:LIMit:DISPlay:STATe ON
:CALCulate 1:LIMit:DISPlay:STATe?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STARt?
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP 0
:CALCulate 1:LIMit:SEGMent 1:AMPLitude:STOP?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt 1e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STARt?
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP 3e9
:CALCulate 1:LIMit:SEGMent 1:STIMulus:STOP?
:CALCulate 1:LIMit:SEGMent 1:TYPE LMAX
:CALCulate 1:LIMit:SEGMent 1:TYPE?
:CALCulate 1:LIMit:SOUNd:STATe OFF
:CALCulate 1:LIMit:SOUNd:STATe?
:CALCulate 1:LIMit:STATe ON
:CALCulate 1:LIMit:STATe?


Marker

About Markers

Calc:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Note: The Reference Marker is Marker Number 10

CALCulate<cnum>:MARKer:AOFF

(Write-only) Turns all markers off for selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MARK:AOFF calculate2:marker:aoff
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:MARKer:BWIDth <num>

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

This feature activates markers 1 through 4. To turn off these markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.
Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between:
-500 and 500

Examples

CALC:MARK:BWID -3
calculate2:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Overlapped?

No

Default

-3

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MARK:REF:STATE. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker is a Delta marker OFF (or 0) - Specified marker is an ABSOLUTE marker
Examples | CALC:MARK:DELT ON calculate2:marker8:delta off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DELTa?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker displays the actual data points OFF (or 0) - Specified marker displays calculated data between the actual data points.
Examples | CALC:MARK:DISC ON calculate2:marker8:discrete off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<char> | Choose from: DEFault - The format of the selected measurement MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude IMPedance - (R+jX) ADMittance - (G+jB) PHASe - Phase IMAGinary - Imaginary part (Im) REAL - Real part (Re)l POLar - (Re, Im) GDELay - Group Delay
Examples | CALC:MARK:FORMat MLIN calculate2:marker8:format Character
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FORMat?
Return Type | Character
Overlapped? | No
Default | DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Character
Overlapped? | No
Default | -100

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel shares 10 domain ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<span>

User span. Choose any Integer from 0 to 9.

0 is Full Span of the analyzer
1 to 9 are available for user-defined x-axis span

Examples

CALC:MARK:FUNC:DOM:USER 1
calculate2:marker8:function:domain:user 1

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER?
Returns the user span number that the specified marker is assigned to.

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.
Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MARK:FUNC:DOM:USER:START 500E6
calculate2:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Character

Overlapped?

No

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STARt to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STOP

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<stop>

Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.

Examples

CALC:MARK:FUNC:DOM:USER:STOP 500e6
calculate2:marker8:function:domain1:user:stop 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?

Return Type

Character

Overlapped?

No

Default

The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

(Write-only) Immediately executes (performs) the specified search function. If no function is specified, executes the selected function. Select the function with CALC:MARK:FUNCtion:SEL. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<func>

Optional argument. The function that is to be performed. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right, wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC:EXEC
calculate2:marker2:function:execute maximum

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

(Read-Write) Sets the search function that the specified marker will perform when executed. To execute (or perform) the function, use:
CALC:MARK:FUNC:EXEC or
CALC:MARK:FUNC:TRAC ON to automatically execute the search every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right; wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC MAX
calculate2:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect]?

Overlapped?

No

Default

MAX

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

(Read-Write) Sets the target value for the specified marker when doing Target Searches (CALC:MARK:FUNC:SEL <TARGet | RTARget | LTARget> Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Target value to search for; Units are NOT allowed.
Examples | CALC:MARK:TARG 2.5 calculate2:marker8:target -10.3
Query Syntax | CALCulate<cnum>:MARKer<mkr>:TARGet?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

(Read-Write) Sets the tracking capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MARK:FUNC:EXECute command every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - The specified marker will "Track" (find) the selected function every sweep.

OFF (or 0) - The specified marker will find the selected function only when the CALC:MARK:FUNC:EXECute command is sent.

Examples

CALC:MARK:FUNC:TRAC ON
calculate2:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

(Read-Write) Turns the reference marker (marker 10) ON or OFF. When turned OFF, existing Delta markers revert to absolute markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns reference marker ON OFF (or 0) - turns reference marker ON
Examples | CALC:MARK:REF ON calculate2:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MARKer:REFerence[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer:REFerence:X <num>

(Read-Write) Sets and returns the absolute x-axis value of the reference marker (marker 10). Critical Note:

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

X-axis value. Choose any number within the operating domain of the reference marker.

Examples

CALC:MARK:REF:X 1e9

calculate2:marker:reference:x 1e6

Query Syntax

CALCulate<cnum>:MARKer:REFerence:X?

Return Type

Character

Overlapped?

No

Default

If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MARKer:REFerence:Y?

(Read-only) Returns the absolute Y-axis value of the reference marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:MARK:REF:Y?

calculate2:marker:reference:y?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

(Read-Write) Sets the type of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
NORMal - a marker that stays on the assigned X-axis position unless moved or searching.
FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MARK:TYPE NORM
calculate2:marker2:type fixed

Query Syntax

CALCulate<cnum>:MARKer<mkr>:TYPE?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MARKer<mkr>:SET <char>

(Read-Write) Sets the selected instrument setting to assume the value of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
CENTer - changes center frequency to the value of the marker
SPAN - changes the frequency span to the value of the marker's domain
STARt - changes the start frequency to the value of the marker
STOP - changes the stop frequency to the value of the marker
RLEVel - changes the reference level to the value of the marker
DELay - changes the xxx delay to the value of the marker

Examples

CALC:MARK:SET CENT
calculate2:marker8:set span

Query Syntax

CALCulate<cnum>:MARKer<mkr>:SET?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

(Read-Write) Turns the specified marker ON or OFF. Marker 10 is the Reference Marker. To turn all markers off, use CALC:MARK:AOFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - turns marker ON. OFF (or 0) - turns marker OFF.
Examples | CALC:MARK ON calculate2:marker8 on
Query Syntax | CALCulate<cnum>:MARKer<mkr>:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

CALCulate<cnum>:MARKer<mkr>:X <num>

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Any X-axis position within the measurement span of the marker. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:X 100Mhz calculate2:marker8:x maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:X?
Return Type | Character
Overlapped? | No
Default | First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

CALCulate<cnum>:MARKer<mkr>:Y?

(Read-only) Sets the marker's Y-axis value. The format of the value depends on the current CALC:MARKER:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • All other formats - (Value,0)

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

Examples

CALC:MARK:Y?
calculate2:marker3:y?

Query Syntax | CALCulate<cnum>:MARKer<mkr>:Y?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MARKer:AOFF
:CALCulate 1:MARKer:BWIDth -2.513
:CALCulate 1:MARKer:BWIDth?
:CALCulate 1:MARKer 1:DELTa ON
:CALCulate 1:MARKer 1:DELTa?
:CALCulate 1:MARKer 1:DISCrete ON
:CALCulate 1:MARKer 1:DISCrete?
:CALCulate 1:MARKer 1:FORMat DEF
:CALCulate 1:MARKer 1:FORMat?
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:EXCursion?
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold 0
:CALCulate 1:MARKer 1:FUNCtion:APEak:THReshold?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER 1
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STARt?
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP 1e12
:CALCulate 1:MARKer 1:FUNCtion:DOMain:USER:STOP?
:CALCulate 1:MARKer 1:FUNCtion:EXECute MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect MAX
:CALCulate 1:MARKer 1:FUNCtion:SELect?
:CALCulate 1:MARKer 1:TARGet -10.3
:CALCulate 1:MARKer 1:TARGet?
:CALCulate 1:MARKer 1:FUNCtion:TRACking ON
:CALCulate 1:MARKer 1:FUNCtion:TRACking?
:CALCulate 1:MARKer:REFerence:STATe ON
:CALCulate 1:MARKer:REFerence:STATe?
:CALCulate 1:MARKer:REFerence:X 10
:CALCulate 1:MARKer:REFerence:X?
:CALCulate 1:MARKer:REFerence:Y?
:CALCulate 1:MARKer 1:TYPE NORM
:CALCulate 1:MARKer 1:TYPE?
:CALCulate 1:MARKer 1:SET CENT
:CALCulate 1:MARKer 1:SET?
:CALCulate 1:MARKer 1:STATe ON
:CALCulate 1:MARKer 1:STATe?
:CALCulate 1:MARKer 1:X 1Ghz
:CALCulate 1:MARKer 1:X?
:CALCulate1:MARKer1:Y?


Math Calc

About Math Operations

Calc:Math Commands

Controls math operations on the currently selected measurement and memory.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:MATH:FUNCtion <char>

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

The math operation to be applied. Choose from the following:

NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory

Examples

CALC:MATH:FUNC NORM
calculate2:math:function subtract

Query Syntax

CALCulate<cnum>:MATH:FUNCtion?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MATH:MEMorize

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MATH MEM calculate2:math:memorize
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:MATH:FUNCtion NORM
:CALCulate 1:MATH:FUNCtion?
:CALCulate 1:MATH:MEMorize


Parameter

About Measurement Parameters

Calc:Parameter Commands

Lists, creates, selects and deletes measurements

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:PARameter:CATalog?

(Read-only) Returns the names and parameters of existing measurements for the specified channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurements to be listed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:CAT? calculate2:parameter:catalog?
Query Syntax | CALCulate<cnum>:PARameter:CATalog?
Return Type | String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"
Overlapped? | No
Default | "CH1_S11_1,S11"

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>

(Write-only) Creates a measurement but NOT display it.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND<wnum>:TRAC<tnum>:FEED <Mname> to display the measurement.

You must select the measurement (CALC<cnum>:PAR:SEL <mname>) before making additional settings. Critical Note:

Parameters

<cnum>

Channel number of the new measurment. Choose any number between:
1 and 4
If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes

<param>

Parameter; Choose from the following for S-Parameter measurements:
S11 | S12 | S21 | S22

Or choose from the following for non S-Parameter measurements. Specify the source port with SENSe:SWEep:SRCPort <1|2>

A | B | R1 | R2 | A/B | B/A

Examples

CALC:PAR:DEF "Test,S12
calculate2:parameter:define "test,s22

Query Syntax

Not Applicable; see Calc:Par:Cat?

Overlapped?

No

Default

Not Applicable

CALCulate<cnum>:PARameter:DELete <Mname>

(Write-only) Deletes the specified measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement
Examples | CALC:PAR:DEL TEST calculate2:parameter:delete "test"
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:SELect <Mname>

(Read-Write) Sets the selected measurement. Most CALC: commands require that this command be sent before a setting change is made. One measurement on each channel can be selected at the same time. To obtain a list of currently named measurements, use CALC:PAR:CAT? Critical Note:
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement. (Do NOT include the parameter name.)
Examples | CALC:PAR:SEL TEST calculate2:parameter:select "test"
Query Syntax | CALCulate:PARameter:SELect?
Return Type | String
Overlapped? | No
Default | No Selection

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:PARameter:CATalog?
:CALCulate 1:PARameter:DEFine "CH1_S21,S21"
:CALCulate 1:PARameter:DELete "CH1_S21"
:CALCulate 1:PARameter:SELect "CH1_S11"
:CALCulate 1:PARameter:SELect?


RData

About Unratioed Measurements

Calc:RData Command

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:RDATA? <char>

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA? Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from receivers: A B R1 R2 REF - returns either R1 or R2 data depending on the source port of the CALC-selected measurement.
Example | GPIB.Write "INITiate:CONTinuous OFF" GPIB.Write "INITiate:IMMediate;*wai" GPIB.Write "CALCulate:RDATA? A"
Return Type | Character - Two numbers per data point
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:RDATA? A


Smoothing Calc

About Smoothing

Calc:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:SMOothing:APERture <num>

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:SMO:APER 2 calculate2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Character
Overlapped? | No
Default | 1.5

CALCulate<cnum>:SMOothing:POINts <num>

(Read-Write) Sets the number of adjacent data points to average. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:SMO:POIN 50 calculate2:smoothing:points 21
Query Syntax | CALCulate<cnum>:SMOothing:POINts?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

(Read-Write) Turns data smoothing ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns smoothing ON. OFF (or 0) - turns smoothing OFF.
Examples | CALC:SMO ON calculate2:smoothing:state off
Query Syntax | CALCulate<cnum>:SMOothing[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:SMOothing:APERture 25
:CALCulate1:SMOothing:APERture?
:CALCulate1:SMOothing:POINts 10
:CALCulate1:SMOothing:POINts?
:CALCulate1:SMOothing:STATe ON
:CALCulate1:SMOothing:STATe?


Transform Calc

About Time Domain

Calc:Transform Commands

Specifies the settings for time domain transform.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

(Read-Write) Sets the center time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:CENT 1e-8 calculate2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDth <num>

(Read-Write) Sets the impulse width for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:TRAN:TIME:IMP:WIDTh 10 calculate2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Character
Overlapped? | No
Default | .98 / Default Span

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

(Read-Write) Sets the parametric window for the Kaiser Bessel window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:TRAN:TIME:KBES 10 calculate2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:KBESsel?
Return Type | Character
Overlapped? | No
Default | 6

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

(Write-only) Sets the start frequencies in LowPass Mode. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:TRAN:TIME:LPFR calculate2:transform:time:lpfrequency
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

(Read-Write) Sets the span time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:SPAN 1e-8 calculate2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:TRANsform:TIME:STARt <num>

(Read-Write) Sets the start time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STAR 1e-8 calculate2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | -10 ns

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

(Read-Write) Turns the time domain transform capability ON or OFF. Critical Note: Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON|OFF> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:TRAN:TIME:STAT ON calculate2:transform:time:state off
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:TRANsform:TIME:STOP <num>

(Read-Write) Sets the stop time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STOP 1e-8 calculate2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

(Read-Write) Sets the step rise time for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:TRAN:TIME:STEP:RTIM 1e-8 calculate2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Character
Overlapped? | No
Default | .99 / Default Span

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:
STEP - simulates a step DUT stimulus
IMPulse - simulates a pulse DUT stimulus

STEP can ONLY be used when CALC:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME:STIM STEP
calculate2:transform:time:stimulus impulse

Query Syntax

CALCulate<cnum>:TRANsform:TIME:STIMulus?

Return Type

Character

Overlapped?

No

Default

IMPulse

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

(Read-Write) Sets the type of time domain measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

  • :STIM STEP will set :TYPE to LPASs

  • :TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME LPAS
calculate2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Overlapped?

No

Default

BPAS

List of all commands in this block:
(Parameters in bold italics)

:CALCulate 1:TRANsform:TIME:CENTer 10ms
:CALCulate 1:TRANsform:TIME:CENTer?
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth 110ps
:CALCulate 1:TRANsform:TIME:IMPUlse:WIDth?
:CALCulate 1:TRANsform:TIME:KBESsel 6
:CALCulate 1:TRANsform:TIME:KBESsel?
:CALCulate 1:TRANsform:TIME:LPFREQuency
:CALCulate 1:TRANsform:TIME:SPAN 20ms
:CALCulate 1:TRANsform:TIME:SPAN?
:CALCulate 1:TRANsform:TIME:STARt 10ms
:CALCulate 1:TRANsform:TIME:STARt?
:CALCulate 1:TRANsform:TIME:STATe ON
:CALCulate 1:TRANsform:TIME:STATe?
:CALCulate 1:TRANsform:TIME:STEP:RTIMe 110ps
:CALCulate 1:TRANsform:TIME:STEP:RTIMe?
:CALCulate 1:TRANsform:TIME:STIMulus STEP
:CALCulate 1:TRANsform:TIME:STIMulus?
:CALCulate 1:TRANsform:TIME:STOP 20ms
:CALCulate 1:TRANsform:TIME:STOP?
:CALCulate 1:TRANsform:TIME:TYPE LPASs
:CALCulate 1:TRANsform:TIME:TYPE?


Display

About Screen Setup

DISPlay Commands

Controls the settings of the front panel screen.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<ON | OFF> | ON (or 1) - turns frequency annotation ON. OFF (or 0) - turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

(Write-only) Enables and disables error pop-up messages on the display.
Parameters |
<ON | OFF> | ON (or 1) - enables error pop-up messages OFF (or 0) - disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:STATus <ON|OFF>

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<ON | OFF> | ON (or 1) - turns status bar ON. OFF (or 0) - turns status bar OFF.
Examples | DISP:ANN:STAT ON display:annotation:status off
Query Syntax | DISPlay:ANNotation:STATus?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:CATalog?

(Read-only) Returns the existing Window numbers.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Overlapped? | No
Default | Not applicable

DISPlay:ENABLE <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay[:TILE]

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the left of the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the buttons ON. OFF (or 0) - turns the buttons OFF.
Examples | DISP:WIND:ANN:TRAC:STAT ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation:TRACe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Marker data (when markers are ON) on the selected window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns marker data ON. OFF (or 0) - turns marker data OFF.
Examples | DISP:WIND:ANN:MARK:STAT ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:CATalog?

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
Return Type | String of Character values, separated by commas
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

Write to create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between: 1 and 4
<ON | OFF> | ON (or 1) - The window <wnum> is created. OFF (or 0) - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA "hello" display:window2:title:data "hello"
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be redisplayed when turned back ON.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the title string ON. OFF (or 0) - turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

(Write-only) Creates a new trace <tnum> and associates (feed) a measurement <name> to the specified window<wnum>. This command should be executed immediately after creating a new measurement with CALC:PAR:DEF<name>,<parameter>.

To feed the same measurement to multiple traces, create another measurement with the same <name>,<parameter> using the CALC:PAR:DEF command. The analyzer will collect the data only once.

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Trace number to be created. Choose any Integer between:
1 and 4

<name>

Name of the measurement that was defined with CALC:PAR:DEF<name>,<parameter>

Examples

DISP:WIND:TRAC:FEED "test"
display:window2:trace2:feed "test

Query Syntax

Not applicable

Overlapped?

No

Default

"CH1_S11"

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

(Read-Write) Turns the memory trace ON or OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the memory trace ON. OFF (or 0) - turns the memory trace OFF.
Examples | DISP:WIND:TRAC:MEM ON display:window2:trace2:memory:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>:MEMory[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

(Write-only) Activates the specified trace in the specified window for front panel use.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:SEL display:window2:trace2:select
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

(Read-Write) Turns the display of the specified trace in the specified window ON or OFF. When OFF, the measurement behind the trace is still active.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the trace ON. OFF (or 0) - turns the trace OFF.
Examples | DISP:WIND:TRAC ON display:window2:trace2:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

(Write-only) Performs an Autoscale on the specified trace in the specified window, providing the best fit display. Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:Y:AUTO display:window2:trace2:y:scale:auto
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

(Read-Write) Sets the Y axis Per Division value of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:PDIV 1 display:window2:trace2:y:scale:pdivision maximum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision?
Return Type | Character
Overlapped? | No
Default | 10

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

(Read-Write) Sets the Y axis Reference Level of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Reference level value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:RLEV 0 display:window2:trace2:y:scale:rlevel minimum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel?
Return Type | Character
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

(Read-Write) Sets the Reference Position of the specified trace in the specified window

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Any existing trace number; if unspecified, value is set to 1

<num>

Reference position on the screen measured in horizontal graticules from the bottom. The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:WIND:TRAC:Y:RPOS 0
display:window2:trace2:y:rposition maximum

Query Syntax

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition?

Return Type

Character

Overlapped?

No

Default

5

List of all commands in this block:
(Parameters in bold italics)

:DISPlay:ANNotation:FREQuency:STATE ON
:DISPlay:ANNotation:FREQuency:STATE?
:DISPlay:ANNotation:STATus ON
:DISPlay:ANNotation:STATus?
:DISPlay:CATalog?
:DISPlay:ENABLE ON
:DISPlay:ENABLE?
:DISPlay:TILE
:DISPlay:WINDow 1:ANNotation:TRACe:STATe ON
:DISPlay:WINDow 1:ANNotation:TRACe:STATe?
:DISPlay:WINDow 1:ANNotation:MARKer:STATe ON
:DISPlay:WINDow 1:ANNotation:MARKer:STATe?
:DISPlay:WINDow 1:CATalog?
:DISPlay:WINDow 1:ENABle ON
:DISPlay:WINDow 1:ENABle?
:DISPlay:WINDow 1:STATe ON
:DISPlay:WINDow 1:STATe?
:DISPlay:WINDow 1:TABLe OFF
:DISPlay:WINDow 1:TABLe?
:DISPlay:WINDow 1:TITLe:DATA "hello"
:DISPlay:WINDow 1:TITLe:DATA?
:DISPlay:WINDow 1:TITLe:STATe ON
:DISPlay:WINDow 1:TITLe:STATe?
:DISPlay:WINDow 1:TRACe 1:DELete
:DISPlay:WINDow 1:TRACe 1:FEED "test"
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe ON
:DISPlay:WINDow 1:TRACe 1:MEMory:STATe?
:DISPlay:WINDow 1:TRACe 1:SELect
:DISPlay:WINDow 1:TRACe 1:STATe ON
:DISPlay:WINDow 1:TRACe 1:STATe?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:AUTO
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision 20
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:PDIVision?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RLEVel?
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition -10
:DISPlay:WINDow 1:TRACe 1:Y:SCALe:RPOSition?


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data. These commands will effect data that is transferred with the CALC:DATA and CALC:RDATA commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

FORMat:BORDer <char>

(Write-only) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.

Parameters

<char>

Choose from:
NORMal - Use when your controller is anything other than an IBM compatible computers
SWAPped - for IBM compatible computers

Examples

FORM:BORD SWAP
format:border normal

Query Syntax

FORMat:BORDer?

Overlapped?

No

Default

Normal

FORMat[:DATA] <char>

(Read-Write) Sets the data format for use during transfer of measurement data.
Parameters |
<char> | Choose from: REAL,32 - (default value for REAL) Best for transfering large amounts of measurement data. REAL,64 - Slower but has more significant digits than REAL,32. Use REAL,64 if you have a computer that doesn't support REAL,32. ASCii,0 - The easiest to implement, but very slow. Use if small amounts of data to transfer.
Examples | FORM REAL,64 format:data ascii
Query Syntax | FORMat:DATA?
Return Type | Character,Character
Overlapped? | No
Default | REAL,32

List of all commands in this block:
(Parameters in bold italics)

FORMat:BORDer NORMal
FORMat:BORDer?
FORMat:DATA ASCii,0
FORMat:DATA?


Hardcopy

About Printing

Hardcopy Command

HCOPy[:IMMediate]

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable


Initiate

About Triggering

Initiate Commands

Controls triggering signals

INITiate:CONTinuous <boolean>

(Read-Write) Specifies whether the analyzer sends Continuous sweep triggers to triggerable channels or enables Manual triggering.
Parameters |
<boolean> | ON (or 1) - Continuous sweep mode. OFF (or 0) - Manual sweep mode.
Examples | INIT:CONT ON initiate:continuous off
Query Syntax | INITiate:CONTinuous?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

INITiate<cnum>[:IMMediate]

(Write-only) Stops the current sweeps and immediately sends a trigger to the specified channel. (Same as Sweep \ Trigger \ Restart on the front panel.)

  • If the specified channel is in HOLD, it will sweep one time and return to HOLD when complete.

  • If Trigger:Scope = Global, all channels will receive a trigger.

  • If Trigger:Scope = Channel (only the active channel receives a trigger) and the specified channel is not the active channel, the specified channel will NOT receive a trigger signal.

  • If the specified channel is NOT in Manual trigger (INIT:CONT OFF), the analyzer will return an error.

  • If channel <cnum> does not exist, the analyzer will return an error.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not applicable

Overlapped?

Yes

Default

Not applicable

List of all commands in this block:
(Parameters in bold italics)

:INITiate:CONTinuous ON
:INITiate:CONTinuous?
:INITiate 2:IMMediate


Memory

About Save / Recall

Memory Commands

The memory commands control saving and loading instrument states to the hard drive.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

All MMEM files have an extension according to their type.

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

The default folder is "C:\Program Files\Agilent\Network Analyzer\Documents"

You can change the active directory using MMEMory:CDIRectory, or you can use an absolute path name to specify all MMEM files and folders.

MMEMory:CATalog[:<char>]? [<folder>]

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned.
Parameters |
<char> | The type of files to list. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified then ALL file types (even unknown types) are listed.
<folder> | Any existing folder name. If unspecified C:\Program Files\Agilent\Network Analyzer\Documents is used.
Examples | MMEM:CAT? 'lists all files from the current folder mmemory:catalog:correction? "C:\Program Files\Agilent\Network Analyzer\Documents" 'lists .cal files from the specified folder
Overlapped? | No
Default | Not applicable

MMEMory:CDIRectory <folder>

(Read-Write) Changes the folder name.

Parameters

<folder>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:CDIR Service

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory "\automation" 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory "c:\automation\service"

Query Syntax

MMEMory:CDIRectory? 'Returns the current folder name

Return Type

String

Overlapped?

No

Default

"C:\Program Files\Agilent\Network Analyzer\Documents"

MMEMory:COPY <file1>,<file2>

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | Name of the file to be copied.
<file2> | Name of the file to be created from file1.
Examples | MMEM:COPY "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:DELete <file>

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | Name of the file to be deleted.
Examples | MMEM:DEL "MyFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:LOAD[:<char>] <file>

(Write-only) Loads the specified file.
Parameters |
<char> | The type of file to load. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If <char> is unspecified, the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of the file to be loaded. The default folder is used if unspecified in the filename.
Examples | MMEM:LOAD "MyFile.cst" mmemory:load:state "MyInstState"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MDIRectory <folder>

(Write-only) Makes a folder.
Parameters |
<folder> | Name of the folder to make.
Examples | MMEM:MDIR "MyFolder" mmemory:mdirectory "c:\NewFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MOVE <file1>,<file2>

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | Name of the file to be renamed.
<file2> | Name of the new file.
Examples | MMEM:MOVE "MyFile.cst","YourFile.cst"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:RDIRectory <folder>

(Write-only) Removes the specified folder.
Parameters |
<folder> | Name of the folder to remove.
Examples | MMEM:RDIR "MyFolder"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe[:<char>] <file>

(Write-only) Stores the specified file.
Parameters |
<char> | The type of file to store. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified, then the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | Name of any valid file that is not already in existance.
Examples | MMEM:STOR:STAT "myState" mmemory:store "c:\bin\myState.sta"
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:MMEMory:CATalog:STATe? "C:\Program Files\Agilent\Network Analyzer\Documents"
:MMEMory:CDIRectory "\documents"
:MMEMory:CDIRectory?
:MMEMory:COPY "myState.sta","yourState"
:MMEMory:DELete "myState.sta"
:MMEMory:LOAD:STATe "myState"
:MMEMory:MDIRectory"myFolder"
:MMEMory:MOVE "myState.sta","yourState.sta"
:MMEMory:RDIRectory "myFolder"
:MMEMory:STORe:STATe "myState"


Output

About Power

Output Command

OUTPut[:STATe] <ON | OFF>

(Read-Write) Turns RF power from the source ON or OFF.
Parameters |
<ON | OFF> | ON (or 1) - turns RF power ON. OFF (or 0) - turns RF power OFF.
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

List of all commands in this block:
(Parameters in bold italics)

:OUTPut:STATe ON?
:OUTPut:STATe?


Average SCPI

About Averaging

Sens:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:AVERage:CLEar

(Write-only) Clears and restarts averaging of the measurement data. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

(Read-Write) Sets the number of measurement sweeps to combine for an average. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurement sweeps to average. Choose any number between: 1 and 1024
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns averaging ON. OFF (or 0) - turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:AVERage:CLEar
:SENSe 1:AVERage:COUNt 10
:SENSe 1:AVERage:COUNt?
:SENSe 1:AVERage:STATe ON
:SENSe 1:AVERage:STATe?


Sense Bandwidth

About IF Bandwidth

Sense:Bandwidth Command

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. The keywords BAND or BWID are interchangeable.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

IF Bandwidth in Hz. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Examples

SENS:BWID 1KHZ
sense2:bandwidth:resolution 1000

Query Syntax

SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:BANDwidth:RESolution 1000
:SENSe 1:BANDwidth:RESolution?


Sense Correction

About Measurement Calibration

Sense:Correction Commands

Performs and applies measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe:CORRection:COEFficient <term>[,port]

(Write-only) Displays the selected error term as trace data. Correction must be turned on.

Note: This command displays error terms for only Channel 1 measurements

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<term>

Error term to be displayed:

Specify this: | to get this Term...
1 | Directivity
2 | Source Match
3 | ReflectionTracking
4 | Isolation
5 | Load Match
6 | Transmission Tracking

[port]

Optional Parameter - Port number of the source drive. If unspecified, value is set to 1.

Examples

SENS:CORR:COEF 1
'Displays the directivity term for port 1 source

SENS:CORR:COEF 2,2
'Displays the source match for port 2 source

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <char>

(Write-only) Measures the specified standard from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

<char> | Measures the standards associated with these class labels:
STAN1 | S11A and S22A
STAN2 | S11B and S22B
STAN3 | S11C and S22C
STAN4 | S21T and S12T - usually the THRU standard
STAN5 | Generic Isolation; not associated with calibration kit definition
ECALA | ECAL module A
ECALB | ECAL module B

Examples

SENS:CORR:COLL STAN1
sense2:correction:collect:acquire stan5

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:METHod <char>

(Read-Write) Sets the calibration method. (Also known as 'Calibration Type' on calibration dialog box.)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
REFL1OPEN | Response Open
REFL1SHORT or REFL1 | Response Short
REFL3 | Full 1 port
TRAN1 | Response Thru
TRAN2 | Response Thru and Isolation
SPARSOLT | Full SOLT 2 port

Examples

SENS:CORR:COLL:METH REFL1
sense2:correction:collect:method sparsolt

Query Syntax

SENSe<cnum>:CORRection:COLLect:METHod?

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

(Write-only) Calculates the error terms using the selected :METHod and applies the error terms to the selected measurement (turns error correction ON.) Does NOT save the calibration error-terms.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:SAVE sense2:correction:collect:save
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:CSET[:SELect] <char>

(Read-Write) Restores a correction data set from memory. The file name is "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: DEF - Presets the analyzer USER01- Restores User01 calibration data USER02 - Restores User02 calibration data through... USER10 - Restores User10 calibration data
Examples | SENS:CORR:CSET DEF sense2:correction:cset:select user02
Query Syntax | SENSe<cnum>:CORRection:CSET[:SELect]?
Return Type | Charact er
Overlapped? | No
Default | DEF

SENSe<cnum>:CORRection:CSET:SAVE <char>

Write a correction data set to memory or Read the last correction set saved. The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: USER01 USER02... USER10
Examples | SENS:CORR:CSET:SAVE USER03 sense2:correction:cset:save user09
Query Syntax | SENSe<cnum>:CORRection:CSET:SAVE? Queries the last correction set saved.
Return Type | Charact er
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified port. Must also set SENS:CORR:EXT ON.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Number of the port that will receive the extension. If unspecified, value is set to 1. Choose from:

1 | Port 1
2 | Port 2

<num>

The port extension in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:PORT 2MS
sense2:correction:extension:port2 .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified receiver. Must also set SENS:CORR:EXT ON .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<Rnum>

Number of the receiver that will receive the extension. If unspecified, value is set to 1
Choose from:

1 | Receiver A
2 | Receiver B

<num>

The electrical length in seconds; may include suffix. Choose a number between:
-10 and 10

Examples

SENS:CORR:EXT:REC 2MS
sense2:correction:extension:receiver2:time .00025

Query Syntax

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum> [:TIME]?

Return Type

Character

Overlapped?

No

Default

0

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

(Read-Write) Turns port extensions ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port entensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance: INPut:MAGNitude?
Return Type | Character
Overlapped? | No
Default | 50

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

(Read-Write) Turns correction interpolation ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolation:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

(Read-Write) Turns isolation cal ON or OFF during Full 2-port calibration. If this comand is not sent, the default state is to disable Isolation.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns isolation ON. OFF (or 0) - turns isolation OFF.
Examples | SENS:CORR:ISOL ON sense2:correction:isolation:state off
Query Syntax | SENSe<cnum>:CORRection:ISOLation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF - (Isolation disabled)

SENSe<cnum>:CORRection:RVELocity:COAX <num>

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between: 0 and 10 (.66 polyethylene dielectric; .7 teflon dielectric) Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

(Read-Write) Specifies whether or not correction data is applied to the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the measurement. OFF (or 0) - correction is NOT applied to the measurement.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COEFficient 2,1
:SENSe1:CORRection:COLLect:ACQuire STAN1
:SENSe1:CORRection:COLLect:ACQuire?
:SENSe1:CORRection:COLLect:APPLy
:SENSe1:CORRection:COLLect:AVERage:COUNt 4
:SENSe1:CORRection:COLLect:AVERage:COUNt?
:SENSe1:CORRection:COLLect:METHod SPARSOLT
:SENSe1:CORRection:COLLect:METHod?
:SENSe1:CORRection:COLLect:SAVE
:SENSe1:CORRection:CSET:SELect USER05
:SENSe1:CORRection:CSET:SELect?
:SENSe1:CORRection:CSET:SAVE USER03
:SENSe 1:CORRection:CSET:SAVE?
:SENSe1:CORRection:EXTension:PORT2:TIME 2ms
:SENSe1:CORRection:EXTension:PORT2:TIME?
:SENSe1:CORRection:EXTension:RECeiver2:TIME 2ms
:SENSe1:CORRection:EXTension:RECeiver2:TIME?
:SENSe1:CORRection:EXTension:STATe ON
:SENSe1:CORRection:EXTension:STATe?
:SENSe1:CORRection:INTerpolation:STATe ON
:SENSe1:CORRection:INTerpolation:STATe?
:SENSe1:CORRection:ISOLation:STATe ON
:SENSe1:CORRection:ISOLation:STATe?
:SENSe1:CORRection:RVELocity:COAX .66
:SENSe1:CORRection:RVELocity:COAX?
:SENSe1:CORRection:STATe ON
:SENSe1:CORRection:STATe?


CorrCollCKIT

About Modifying Cal Kits

Sense:Correction:Collect:CKit Commands

Use to change the definitions of calibration kit standards.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL .

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

SENSe:CORRection:COLLect:CKIT:NAME <name>

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME MYAPC35 sense:correction:collect:ckit:name mytypen
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <standard>

(Read-Write) Sets a standard number to a calibration class. Does NOT set or dictate the order for measuring the standards. For more information, see Calibration Standards / Fabricating Calibration Standards / Assigning Standards to a Calibration Class

Parameters

<class>

Number of the calibration class that is assigned to <standard>. Choose a number between:
1 and 8
The <class> numbers are associated with the following calibration classes:

<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard

<standard>

Standard number between 1 and 8

Examples

Assigns standard 3 to S11A class:
SENS:CORR:COLL:CKIT:ORD1 3
Assigns standard 2 to S21T class class:
sense:correction:collect:ckit:order4 2

Query Syntax

SENSe:CORRection:COLLect:CKIT:ORDer?

Return Type

Character; returns the <class> number of the selected standard.

Overlapped?

No

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:RESet <num>

(Write-only) Resets the selected calibration kit to factory default definition values.
Parameters |
<num> | The number of the calibration kit to be reset. Choose any integer between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:RESet 1 sense:correction:collect:ckit:reset 4
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

(Read-Write) Selects (makes active) a calibration kit. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>

Parameters

<num>

The number of the calibration kit. The following are the default settings. Choose from:

<num> | Name | Model
1 | Type N 85032F | 85032F
2 | 3.5mm 85033E | 85033E
3 | Type N | 85032B
4 | 3.5mm 85033D | 85033D
5 | 7-16 85038A | 85038A
6 | 3.5mm TRL | 85052C
7 | User Defined 7 | NA
8 | User Defined 8 | NA
9 | User Defined 9 | NA
10 | User Defined 10 | NA
99 | ECAL module | NA

Examples

SENS:CORR:COLL:CKIT 2
sense2:correction:collect:ckit:select 7

Query Syntax

SENSe:CORRection:COLLect:CKIT?

Return Type

Charact er

Overlapped?

No

Default

1

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard.
Parameters |
<num> | Value for C0 in picofarads
Examples | The following commands set C0=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard.
Parameters |
<num> | Value for C1 in picofarads
Examples | The following two commands set C1=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard.
Parameters |
<num> | Value for C2 in picofarads
Examples | The following two commands set C2=(-15) picofarads: SENS:CORR:COLL:CKIT:STAN:C2 -15 sense:correction:collect:ckit:standard:c2 -15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard.
Parameters |
<num> | Value for C3 in picofarads
Examples | The following two commands set C3=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | String
Overlapped? | No
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in seconds
Examples | SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmax 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

(Read-Write) Sets the minumum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fmin 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Character
Overlapped? | No
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard.
Parameters |
<num> | Value for L0 in picohenries
Examples | The following two commands set L0=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard.
Parameters |
<num> | Value for L1 in picohenries
Examples | The following two commands set L1=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard.
Parameters |
<num> | Value for L2 in picohenries
Examples | The following two commands set L2=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard.
Parameters |
<num> | Value for L3 in picohenries
Examples | The following two commands set L3=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB "OPEN" sense:correction:collect:ckit:standard:label "Short2"
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Character
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD THRU (Through)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:CORRection:COLLect:CKIT:NAME mytypen
:SENSe:CORRection:COLLect:CKIT:NAME?
:SENSe:CORRection:COLLect:CKIT:ORDer 4 2
:SENSe:CORRection:COLLect:CKIT:ORDer?
:SENSe:CORRection:COLLect:CKIT:RESet 1
:SENSe:CORRection:COLLect:CKIT:SELect 7
:SENSe:CORRection:COLLect:CKIT?
:SENSe:CORRection:COLLect:CKIT:STANdard:C0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C0?
:SENSe:CORRection:COLLect:CKIT:STANdard:C1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C1?
:SENSe:CORRection:COLLect:CKIT:STANdard:C2 -15
:SENSe:CORRection:COLLect:CKIT:STANdard:C2?
:SENSe:CORRection:COLLect:CKIT:STANdard:C3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:C3?
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter COAX
:SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay 50ps
:SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9Ghz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 1khz
:SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50.3
:SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
:SENSe:CORRection:COLLect:CKIT:STANdard:L0 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L0?
:SENSe:CORRection:COLLect:CKIT:STANdard:L1 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L1?
:SENSe:CORRection:COLLect:CKIT:STANdard:L2 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L2?
:SENSe:CORRection:COLLect:CKIT:STANdard:L3 15
:SENSe:CORRection:COLLect:CKIT:STANdard:L3?
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel "Short2"
:SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 3.5e9
:SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT 8
:SENSe:CORRection:COLLect:CKIT:STANdard:SELECT?
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE LOAD
:SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?


Couple

About Alternate Sweep

Sense:Couple Command

SENSe<cnum>:COUPle <ALL | NONE>

(Read-Write) Sets the sweep mode as Chopped or Alternate.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ALL | NONE> | ALL - Sweep mode set to Chopped - reflection and transmission measured on the same sweep. NONE - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases sweep time
Examples | SENS:COUP ALL sense2:couple none
Query Syntax | SENSe<cnum>:COUPle?
Return Type | Character
Overlapped? | No
Default | ALL

List of all commands in this block:
(Parameters in bold italics)

:SENSe1:COUPle ALL
:SENSe1:COUPle?


Frequency

About Frequency Sweep

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

SENSe<cnum>:FREQuency:CENTer <num>

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000
sense2:frequency:center 1mhz

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

(Read-Write) Sets the Continuous Wave (or Fixed) frequency. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Character

Overlapped?

No

Default

1 GHz

SENSe<cnum>:FREQuency:SPAN <num>

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span. Choose any number between:
0 (minimum) and the maximum frequency span of the anal yzer.
Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

(Read-Write) Sets the start frequency of the analyzer.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz Note: If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START. Note: This command will accept MIN or M AX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:FREQ:STAR 1000000 sense2:frequency:start MIN
Query Syntax | SENSe<cnum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer. Units are Hz

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

Return Type

Character

Overlapped?

No

Default

Maximum frequency of the analyzer

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:FREQuency:CENTer 1mhz
:SENSe 1:FREQuency:CENTer?
:SENSe1:FREQuency:CW 100e6
:SENSe1:FREQuency:CW?
:SENSe 1:FREQuency:SPAN 10e6
:SENSe 1:FREQuency:SPAN?
:SENSe 1:FREQuency:STARt 10e6
:SENSe 1:FREQuency:STARt?
:SENSe 1:FREQuency:STOP 1e9
:SENSe 1:FREQuency:STOP?


Power

About Receiver Attenuation

Sense:Power Command

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

(Read-Write) Sets the attenuation level for the specified receiver. Note: Attenuation cannot be set with Sweep Type set to Power
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<recvr> | Receiver to get attenuation. Choose from: ARECeiver - receiver A BRECeiver - receiver B
<num> | Choose from: 0 to 35 dB - in 5 dB steps If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 15 dB attenuation.
Examples | SENS:POW:ATT AREC,10 sense2:power: attentuation breceiver,30
Query Syntax | SENSe<cnum>:POWer :ATTenuation? <rec>
Return Type | Character
Overlapped? | No
Default | 0

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:POWer:ATTenuation AREC,10
:SENSe1:POWer:ATTenuation? AREC


Roscillator

About the Reference Osc.

Sense:Roscillator Command

SENSe:ROSCillator:SOURce?

(Read-only) Applying a signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked. EXT is returned when a signal is present at the Reference Oscillator connector. INT is returned when NO signal is present at the Reference Oscillator connector.
Examples | SENS:ROSC:SOUR? sense:roscillator:source?
Return Type | Character
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SENSe:ROSCillator:SOURce?


Segment

About Segment Sweep

Sense:Segment Commands

Defines the segment sweep settings. Enable segment sweep with SENS:SWE:TYPE SEGMent.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SEGMent<snum>:ADD

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

(Read-Write) Sets the IFBandwidth for the specified segment. First set SENS:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |
If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ
sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment OFF (or 0) - turns Bandwidth control OFF. Use channel bandwidth setting
Examples | SENS:SEGM:BWID:CONT ON sense2:segment:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent:COUNt?

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Character
Overlapped? | No
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

(Write-only) Deletes the specified sweep segment.
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Number of the segment to delete. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:DELete:ALL

(Write-only) Deletes all sweep segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

(Read-Write) Sets the Start Frequency for the specified sweep segment. Note: All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STAR 1MHZ sense2:segment2:frequency:start minimum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

(Read-Write) Sets the Stop Frequency for the specified sweep segment. Note: All other segment's Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STOP 1MHZ sense2:segment2:frequency:stop maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?
Return Type | Character
Overlapped? | No
Default | If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON. All subsequent segments that are added assume the new Power Level value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<port> | Port number of the source. Choose from 1 or 2. If unspecified, value is set to 1.
<num> | Power level. Choose from any number between: -90 and 20
Examples | SENS:SEGM:POW 0 sense2:segment2:power1:level -10
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Power Level control ON. Power level can be set for each segment. OFF (or 0) - turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF
<ON | OFF> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent[:STATe]? <snum>
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:POIN 51 sense2:segment2:sweep:points maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to sweep the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Sweep time in seconds. Choose a number between 0 and 100 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Sweep Time control ON. Sweep Time can be set for each segment. OFF (or 0) - turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIM:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SEGMent 1:ADD
:SENSe 1:SEGMent 1:BWIDth:RESolution 1000
:SENSe 1:SEGMent 1:BWIDth:RESolution?
:SENSe 1:SEGMent:BANDwidth:CONTrol ON
:SENSe 1:SEGMent:BANDwidth:CONTrol?
:SENSe 1:SEGMent:COUNt?
:SENSe 1:SEGMent 1:DELete
:SENSe 1:SEGMent:DELete:ALL
:SENSe 1:SEGMent 1:FREQuency:CENTer 1e6
:SENSe 1:SEGMent 1:FREQuency:STARt?
:SENSe 1:SEGMent 1:FREQuency:SPAN 1e6
:SENSe 1:SEGMent 1:FREQuency:SPAN?
:SENSe 1:SEGMent 1:FREQuency:START 1e6
:SENSe 1:SEGMent 1:FREQuency:START?
:SENSe 1:SEGMent 1:FREQuency:STOP 1e6
:SENSe 1:SEGMent 1:FREQuency:STOP?
:SENSe 1:SEGMent 1:POWer 1:LEVel -10
:SENSe 1:SEGMent 1:POWer 1:LEVel?
:SENSe 1:SEGMent:POWer:LEVel:CONTrol ON
:SENSe 1:SEGMent:POWer:LEVel:CONTrol?
:SENSe 1:SEGMent 1:STATe ON
:SENSe1:SEGMent1:STATe?
:SENSe 1:SEGMent 1:SWEep:POINts 400
:SENSe 1:SEGMent 1:SWEep:POINts?
:SENSe 1:SEGMent 1:SWEep:TIME .001
:SENSe 1:SEGMent 1:SWEep:TIME?
:SENSe 1:SEGMent:SWEep:TIME:CONTrol ON
:SENSe 1:SEGMent:SWEep:TIME:CONTrol?


Sweep SCPI

About Sweeping

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SENSe<cnum>:SWEep:DWELl <num>

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENSe:SWEep:GENeration set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dwell min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Character

Overlapped?

No

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:GENeration <char>

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Overlapped?

No

Default

Analog

SENSe<cnum>:SWEep:GROups:COUNt <num>

(Read-Write) Sets the trigger count (groups) for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:MODE <char>

(Read-Write) Sets the trigger mode for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Trigger mode. Choose from: HOLD - channel will not trigger CONTinuous - channel triggers indefinitely GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>
Examples | SENS:SWE:MODE CONT sense2:sweep:mode hold
Query Syntax | SENSe<cnum>:SWEep:MODE?
Return Type | Character
Overlapped? | YES - SENS:SWE:MODE GROUPS (when INIT:CONT is ON) NO - HOLD and CONTinuous
Default | CONTinuous

SENSe<cnum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 2 and 1601 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SWEep:SRCPort <1 | 2>

(Read-Write) Sets the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<1 | 2> | 1 - Source power comes out Port 1 2 - Source power comes out Port 2
Examples | SENS:SWE:SRCP 1 sense2:sweep:srcport 2
Query Syntax | SENSe<cnum>:S WEep:SRCPort?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to complete one sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Sweep time in seconds. Choose a number between 0 and 86,400 (24hrs) Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:TIME 1ms sense2:sweep:time .001
Query Syntax | SENSe<cnum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | NA

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

(Read-Write) Specifies whether the specified channel will measure one point for each trigger or all of the measurements in the channel. Setting any channel to POINt mode will automatically set the TRIGger:SCOPe = CURRent.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - Channel measures one data point per trigger. OFF (or 0) - All measurements in the channel made per trigger.
Examples | SENS:SWE:TRIG:POIN ON sense2:sweep:trigger:point off
Query Syntax | SENSe<cnum>:SWEep:TRIGger:POINt?
Return Type | Boolean (1 = Point, 0 = Measurement)
Overlapped? | No
Default | 0 - Measurement

SENSe<cnum>:SWEep:TYPE <char>

(Read-Write) Sets the type of analyzer sweep mode.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Overlapped? | No
Default | LINear

List of all commands in this block:
(Parameters in bold italics)

:SENSe 1:SWEep:DWELL 2ms
:SENSe 1:SWEep:DWELL?
:SENSe 1:SWEep:DWELL:AUTO ON
:SENSe 1:SWEep:DWELL:AUTO?
:SENSe 1:SWEep:GENeration STEP
:SENSe 1:SWEep:GENeration?
:SENSe 1:SWEep:GROups:COUNt 50
:SENSe 1:SWEep:GROups:COUNt?
:SENSe 1:SWEep:MODE CONT
:SENSe 1:SWEep:MODE?
:SENSe 1:SWEep:POINts 201
:SENSe 1:SWEep:POINts?
:SENSe 1:SWEep:SRCPort 1
:SENSe 1:SWEep:SRCPort?
:SENSe 1:SWEep:TIME 2ms
:SENSe 1:SWEep:TIME?
:SENSe 1:SWEep:TIME:AUTO ON
:SENSe 1:SWEep:TIME:AUTO?
:SENSe 1:SWEep:TRIGger:POINt ON
:SENSe 1:SWEep:TRIGger:POINt?
:SENSe 1:SWEep:TYPE LINear
:SENSe 1:SWEep:TYPE?


source

About Power Settings

Source Commands

Controls the power delivered to the DUT.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SOURce<cnum>:POWer<port>:ATTenuation <num>

(Read-Write) Sets the attenuation level for the selected channel. Sending this command turns automatic attenuation control (SOUR:POW:ATT:AUTO) to OFF. If the ports are coupled, changing the attenuation on one port will also change the attenuation on the other port. To turn port coupling OFF use SOURce:POWer:COUPle OFF.

Note: Attenuation cannot be set with Sweep Type set to Power

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Choose a number between 0 and 70 dB, in 10 dB steps.
If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 10 dB attenuation.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW:ATT 10
source2:power:attentuation maximum

Query Syntax

SOURce<cnum>:POWer<port>:ATTenuation?

Return Type

Character

Overlapped?

No

Default

0

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

(Read-Write) Turns automatic attenuation control ON or OFF. Setting an attenuation value (using SOURce:POWer:ATTenuation <num>) sets AUTO OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns coupling ON. The analyzer automatically selects the appropriate attenuation level to meet the specified power level. OFF (or 0) - turns coupling OFF. Attenuation level must be set using SOURce:POWer:ATTenuation <num>.
Examples | SOUR:POW2:ATT:Auto On source2:power: attentuation:auto off
Query Syntax | SOURce<cnum>:POWer:ATTenuation:Auto?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:CENTer <num>

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Choose a number between -90 and 20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:COUPle <ON | OFF>

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns coupling ON. Power level can be set individually for each source port. OFF (or 0) - turns coupling OFF. The same power level is used for both source ports.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

(Read-Write) Sets the source leveling loop as Internal or External.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<INTernal | EXTernal> | INTernal - Internal leveling is applied to the source EXTernal - External leveling is applied to the source through a rear-panel jack.
Examples | SOUR:POW:DET INT source2:power:detector external
Query Syntax | SOURce<cnum>:POWer:DETector?
Return Type | Character
Overlapped? | No
Default | INTernal

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate]
[:AMPLitude] <num>

(Read-Write) Sets the RF power output level.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Source power in dBm. Choose any value between -90 and +20 dBm
Actual achievable leveled power depends on frequency.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW1 5DB
source2:power:level
:immediate:amplitude maximum

Query Syntax

SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

(Read-Write) Sets the RF power slope value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<int> | Slope value in db/GHz. Choose any integer between -2 and 2 (0 is no slope).
Examples | SOUR:POW:SLOP 2 source2:power:slope -2
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Character
Overlapped? | No
Default | 0

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

(Read-Write) Turns Power Slope ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SOURce<cnum>:POWer:SPAN <num>

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Span power. Choose a number between:
-90 and 20 dBm
(actual achievable leveled power depends on frequency)

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer:STARt <num>

(Read-Write) Sets the power sweep start power. Must also set SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:STOP <num>

(Read-Write) Sets the power sweep stop power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Character
Overlapped? | No
Default | 0 dBm

List of all commands in this block:
(Parameters in bold italics)

:SOURce 1:POWer1:ATTenuation 5
:SOURce 1:POWer1:ATTenuation?
:SOURce 1:POWer1:ATTenuation:AUTO ON
:SOURce 1:POWer1:ATTenuation:AUTO?
:SOURce 1:POWer:CENTer -7
:SOURce 1:POWer:CENTer?
:SOURce1:POWer:COUPle ON
:SOURce1:POWer:COUPle?
:SOURce 1:POWer:DETector INTernal
:SOURce 1:POWer:DETector?
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude 5
:SOURce 1:POWer 1:LEVel:IMMediate:AMPLitude?
:SOURce 1:POWer:LEVel:SLOPe -2
:SOURce 1:POWer:LEVel:SLOPe?
:SOURce 1:POWer:LEVel:SLOPe:STATe ON
:SOURce 1:POWer:LEVel:SLOPe:STATe?
:SOURce 1:POWer:SPAN -7
:SOURce 1:POWer:SPAN?
:SOURce 1:POWer:STARt 0
:SOURce 1:POWer:STARt?
:SOURce 1:POWer:STOP 5
:SOURce 1:POWer:STOP?


Status

About Status Registers

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

Click on a blue register to view the details

Note: Any bit not shown in the registers is not used but may be reserved for future use.

Status Byte Register

Summarizes the states of the other registers and monitors the analyzer's output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

Questionable Summary Register

Summarizes conditions that monitor the quality of measurement data.

STATus:QUEStionable:<keyword>

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

Integrity Summary Register

Summarizes conditions in the Measurement Integrity register.

STATus:QUEStionable:INTegrity <keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
0 | 2 | Hardware Summary | any bit in the Hardware event register is set to 1

Hardware Register

Monitors the status of hardware failures.

STATus:QUEStionable:INTegrity:HARDware<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:HARD:COND?

:ENABle <bits>

STAT:QUES:INT:HARD:ENAB 1024

[:EVENt]?

STAT:QUES:INT:HARD?

:NTRansition <bits>

STAT:QUES:INT:HARD:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:HARD:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Phase Unlock | the source has lost phaselock, possibly caused by a reference channel open or a hardware failure.
2 | 4 | Unleveled | the source power is unleveled. This could be caused by a source set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
3 | 8 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
4 | 16 | EE Write Failed | an attempted write to the EEPROM has failed, possibly caused by a hardware failure.
5 | 32 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
6 | 64 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
7 | 128 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

Measurement Register

Monitors the lag between changing a channel settings and when the data is ready to query out.

When you change the channel state (start/stop freq, bandwidth, and so on), then the questionable bit for that channel gets set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next complete sweep has been taken (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

STATus:QUEStionable:INTegrity:MEASurement<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS?

:NTRansition <bits>

STAT:QUES:INT:MEAS:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Channel1 | a channel1 setting change has occured and the data does not yet reflect that change.
1 | 2 | Channel2 | a channel2 setting change has occured and the data does not yet reflect that change.
2 | 4 | Channel3 | a channel3 setting change has occured and the data does not yet reflect that change.
3 | 8 | Channel4 | a channel4 setting change has occured and the data does not yet reflect that change.

Limit1 Register

Monitors the status of limit line failures and summarizes the Limit2 event register. When a trace fails, or any bit in the Limit2 event register fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note:The '1' on 'LIMit1 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit1<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM1:COND?

:ENABle <bits>

STAT:QUES:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LIM1?

:NTRansition <bits>

STAT:QUES:LIM1:NTR 1024

:NTRansition?

STAT:QUES:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LIM1:PTR 0

:PTRansition?

STAT:QUES:LIM1:PTR?

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Limit 2 Reg summary | any point from limit2 event register fails
1 | 2 | Trace 1 | any point on trace fails the limit test
2 | 4 | Trace 2 | any point on trace fails the limit test
3 | 8 | Trace 3 | any point on trace fails the limit test
4 | 16 | Trace 4 | any point on trace fails the limit test
5 | 32 | Trace 5 | any point on trace fails the limit test
6 | 64 | Trace 6 | any point on trace fails the limit test
7 | 128 | Trace 7 | any point on trace fails the limit test
8 | 256 | Trace 8 | any point on trace fails the limit test
9 | 512 | Trace 9 | any point on trace fails the limit test
10 | 1024 | Trace 10 | any point on trace fails the limit test
11 | 2048 | Trace 11 | any point on trace fails the limit test
12 | 4096 | Trace 12 | any point on trace fails the limit test
13 | 8192 | Trace 13 | any point on trace fails the limit test
14 | 16384 | Trace 14 | any point on trace fails the limit test

Limit2 Register

Monitors the status of limit line failures. When trace 15 or 16 fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note: The '2' on 'LIMit2 is a parameter. If unspecified, the value is set to 1.

STATus:QUEStionable:LIMit2<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:LIM2:COND?

:ENABle <bits>

STAT:QUES:LIM2:ENAB 1024

[:EVENt]?

STAT:QUES:LIM2?

:NTRansition <bits>

STAT:QUES:LIM2:NTR 1024

:PTRansition <bits>

STAT:QUES:LIM2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace15 | any point on trace fails the limit test
2 | 4 | Trace16 | any point on trace fails the limit test

Define Summary Register

Summarizes conditions in the Questionable:Define:User<1|2|3> event registers.

STATus:QUEStionable:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:QUES:DEF:COND?

:ENABle <bits>

STAT:QUES:DEF:ENAB 1024

[:EVENt]?

STAT:QUES:DEF?

:NTRansition <bits>

STAT:QUES:DEF:NTR 1024

:PTRansition <bits>

STAT:QUES:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Questionable User Registers

Monitors conditions that you define and map in any of the three QUES:DEF:USER event registers.

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:QUES:DEF:USER1:ENABle 1024

[:EVENt]?

STAT:QUES:DEF:USER1?

:MAP <bit>,<error>

STAT:QUES:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

Standard Event Status Register

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

Operation Summary Register

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

STATus:OPERation<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |

Averaging1 Register

Monitors Averaging of Traces 1 to 14 and summarizes Traces 15 and 16.

Note:The '1' on 'AVERaging1 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging1<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | AVER2 summary | any enabled bit in AVERaging2 event register is set to 1
1 | 2 | Trace 1 | Averaging is complete
2 | 4 | Trace 2 | Averaging is complete
3 | 8 | Trace 3 | Averaging is complete
4 | 16 | Trace 4 | Averaging is complete
5 | 32 | Trace 5 | Averaging is complete
6 | 64 | Trace 6 | Averaging is complete
7 | 128 | Trace 7 | Averaging is complete
8 | 256 | Trace 8 | Averaging is complete
9 | 512 | Trace 9 | Averaging is complete
10 | 1024 | Trace 10 | Averaging is complete
11 | 2048 | Trace 11 | Averaging is complete
12 | 4096 | Trace 12 | Averaging is complete
13 | 8192 | Trace 13 | Averaging is complete
14 | 16384 | Trace 14 | Averaging is complete

Averaging2 Register

Monitors Averaging of Traces 15 and 16.

Note:The '2' on 'AVERaging2 is a parameter. If unspecified, the value is set to 1.

STATus:OPERation:AVERaging2<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:AVER2:COND?

:ENABle <bits>

STAT:OPER:AVER2:ENAB 1024

[:EVENt]?

STAT:OPER:AVER2?

:NTRansition <bits>

STAT:OPER:AVER2:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace 15 | Averaging is complete
2 | 4 | Trace 16 | Averaging is complete

Define Summary Register

Summarizes conditions in the OPERation:Define:User<1|2|3> event registers.

STATus:OPERation:DEFine<keyword>

<keyword>

Example

:CONDition?

STAT:OPER:DEF:COND?

:ENABle <bits>

STAT:OPER:DEF:ENAB 12

[:EVENt]?

STAT:OPER:DEF?

:NTRansition <bits>

STAT:OPER:DEF:NTR 12

:PTRansition <bits>

STAT:OPER:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

Operation User Registers

Monitors conditions that you define and map in any of the three OPER:DEF:USER event registers.

STATus:OPERation:DEFine:USER<1|2|3><keyword>

<keyword>

Example

:ENABle <bits>

STAT:OPER:DEF:USER1:ENAB 1024

[:EVENt]?

STAT:OPER:DEF:USER1?

:MAP <bit>,<error>

STAT:OPER:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined


System

About Preset

System Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

SYSTem:ERRor?

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Examples

SYST:ERR?
system:error?

Overlapped?

No

Default

Not applicable

SYSTem:ERRor:COUNt?

(Read-only) Returns the number of errors in the error queue.Use SYST:ERR? to read an error.
Examples | SYST:ERR:COUN? system:error:count?
Overlapped? | No
Default | Not applicable

SYSTem:PRESet

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Default.
Examples | SYST:PRES system:preset
Overlapped? | No
Default | Not applicable

List of all commands in this block:
(Parameters in bold italics)

:SYSTem:ERRor?
:SYSTem:ERRor:COUNt?
:STSTem:PRESet


Trigger SCPI

About Triggering

Trigger Commands

Starts or ends a measurement sequence. These commands are an important part of synchronizing measurements.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

TRIGger[:SEQuence]:SCOPe <char>

(Read-Write) Specifies whether triggers are applied to all channels or the current channel.
Parameters |
<char> | Choose from: ALL - triggers all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels. CURRent - trigger only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel. You can use CURRent only when TRIG:SOURCE = MANual.
Examples | TRIG:SCOP ALL trigger:sequence:scope current
Query Syntax | TRIGger[:SEQuence]:SCOPe?
Return Type | Character
Overlapped? | No
Default | ALL

TRIGger[:SEQuence]:SLOPe <char>

(Read-Write) Triggers either on the positive going or negative going trigger signal edge. This setting only has an effect when TRIG:SOURce EXTernal is selected.
Parameters |
<char> | Choose from: POSitive - external (rear panel) source NEGative - internal source sends indefinite trigger signals
Examples | TRIG:SLOP POS trigger:sequence:source negative
Query Syntax | TRIGger[:SEQuence]:SLOPe?
Return Type | Character
Overlapped? | No
Default | NEGative

TRIGger[:SEQuence]:SOURce <char>

(Read-Write) Sets the source of the sweep trigger signal. This command is a superset of INITiate:CONTinuous, which can NOT set the source to External.
Parameters |
<char> | Choose from: EXTernal - external (rear panel) source IMMediate - internal source sends continuous trigger signals MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.
Examples | TRIG:SOUR EXT trigger:sequence:source immediate
Query Syntax | TRIGger[:SEQuence]:SOURce?
Return Type | Character
Overlapped? | No
Default | IMMediate

List of all commands in this block:
(Parameters in bold italics)

:TRIGger:SEQuence:SCOPe ALL
:TRIGger:SEQuence:SCOPe?
:TRIGger:SEQuence:SLOPe POS
:TRIGger:SEQuence:SLOPe?
:TRIGger:SEQuence:SOURce EXT
:TRIGger:SEQuence:SOURce?


Channels, Windows, and Measurements using GPIB

SOURce and most SENSe commands act on the channel that is specified in the command. Channel 1 is default if not specified. There can be up to four channels present (numbers 1 to 4) in the analyzer at the same time.

Most DISPlay commands act on the window and trace specified in the command. Window1 and Trace1 are default if not specified. There can be up to four windows present (numbers 1 to 4) and up to four traces present in each window (numbers 1 to 4) at the same time.

CALCulate commands act on the selected measurement in the specified channel. Select the measurement for each channel using CALCulate<channel number>:PARameter:SELect <meas name>. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time.

The following Visual Basic program does the following:

  • Presets the analyzer

  • Create 2 windows

  • Create 2 Measurements

  • Feed the measurements to windows / traces

  • Change frequency ranges for channels

  • Select both measurements

  • Turn marker 1 ON for each measurement

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PREset"

'Create Measurements
GPIB.Write "CALCulate1:PARameter:DEFine 'Meas1',S11"
GPIB.Write "CALCulate2:PARameter:DEFine 'Meas2',S21"

' Turn on windows - creates if new
GPIB.Write "DISPlay:WINDow1:STATE ON"
GPIB.Write "DISPlay:WINDow2:STATE ON"

'Associate ("FEED") the measurement name('Meas1') to WINDow(1), and give the new TRACe a number(1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'Meas1'"
GPIB.Write "DISPlay:WINDow2:TRACe2:FEED 'Meas2'"

'Change each channel's frequency range
GPIB.Write "SENSe1:FREQuency:SPAN 1e9"
GPIB.Write "SENSe2:FREQuency:SPAN 2e9"

'Select both measurements
GPIB.Write "CALCulate1:PARameter:SELect 'Meas1'"
GPIB.Write "CALCulate2:PARameter:SELect 'Meas2'"

'Turn marker 1 ON for each measurement
GPIB.Write "CALCulate1:MARKer:STATe ON"
GPIB.Write "CALCulate2:MARKer:STATE ON"


Create a Measurement using GPIB

This Visual Basic program creates a new S21 measurement and displays it on the display. Use the links to see the command details.

To run this program, you need:

  • An established GPIB interface connection

'Preset the analyzer
GPIB.Write "SYSTem:PReset"

' Turn on window 1 - if new, creates it
GPIB.Write "DISPlay:WINDow1:STATE ON"

'Define a measurement name, parameter
GPIB.Write "CALCulate:PARameter:DEFine 'MyMeas',S21"

'Associate ("FEED") the measurement name ('MyMeas') to WINDow (1), and give the new TRACe a number (1).
GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'MyMeas'"


Catalog Measurements using GPIB

This Visual Basic Program does the following:

  • Catalogs the currently defined measurements, windows, and traces

  • Selects a measurement for further definition

  • Adds a Title to the window

To run this program, you need:

  • An established GPIB interface connection

Dim Meas as String
Dim Win as String
Dim Trace as String

'Read the current measurements in Channel 1
GPIB.Write "CALCulate1:PARameter:CATalog?"
Meas = GPIB.Read
MsgBox ("Ch1 Measurments: " & Meas)

'Read the current windows
GPIB.Write "DISPlay:CATalog?"
Win = GPIB.Read
MsgBox ("Windows: " & Win)

'Read current traces in window 1
GPIB.Write "DISPlay:WINDow1:CATalog?"
Trace = GPIB.Read
MsgBox ("Traces in Window1: " & Win)


Perform a Calibration using GPIB

This Visual Basic program does a Full 2-Port Calibration, including Isolation

To run this program, you need:

  • An established GPIB interface connection

  • A 2-port measurement set up with desired frequency range, power, and so forth, ready to be calibrated.

Sub SOLTCal()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'Select 2-Port Calibration
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Select a cal kit
Calkitnum = 3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Measure the standards
MsgBox "Connect OPEN's to Ports 1 and 2; then press OK"
Call Measurestandard("stan1")
MsgBox "Connect SHORT's to Ports 1 and 2; then press OK"
Call Measurestandard("stan2")
MsgBox "Connect LOAD's to Ports 1 and 2; then press OK"
Call Measurestandard("stan3")
MsgBox "Connect THRU between Ports 1 and 2; then press OK"
Call Measurestandard("stan4")
MsgBox "Disconnect Ports 1 and 2 for isolation; then press OK"
Call Measurestandard("stan5")

'Compute the coefficients and turn on error correction
GPIB.Write "SENSe:CORRection:COLLect:SAVE"

'Resume continuous sweep.
GPIB.Write "INITialize:CONTinuous ON"
End Sub

Sub Measurestandard(Std$)
'Store the results of a sweep as correction data
GPIB.Write "SENSe:CORRection:COLLect " & Std$

'Take a sweep;return when complete
GPIB.Write "INITiate:IMMediate;*OPC?"
OPCreply = GPIB.Read

End Sub


ECALibrate Using GPIB

The following program does an Electronic Calibration using an Agilent ECAL module
These commands do the following:

  • Acquire the standards

  • Move the error terms back into the analyzer

  • Enable the calibration

Note: A separate :SENS:CORR:COLL:SAVE is not needed.

To run this program, you need:

  • An established GPIB interface connection

Private Sub Command5_Click()
'Turn off continuous sweep
GPIB.Write "INITiate:CONTinuous OFF"

'ECal full 1 port and 2 port
'This program assumes you have already set up the analyzer for an S11 measurement over the frequency range, power, etc. that you want.

'Select the Ecal "Kit"
GPIB.Write "SENSe:CORRection:COLLect:CKIT 99"

'Choose a Calibration Type (comment out one of these)
GPIB.Write "SENSe:CORRection:COLLect:METHod refl3"
GPIB.Write "SENSe:CORRection:COLLect:METHod SPARSOLT"

'Enable or disable (comment out one) measurement of isolation
GPIB.Write "SENSe:CORRection:ISOLation ON"
GPIB.Write "SENSe:CORRection:ISOLation OFF"

'Prompt for the ECal module
MsgBox ("Connect ECal module to Port 1, then press enter")

'Acquire and store the calibration terms - return (*OPC) when finished
GPIB.Write "SENSe:CORRection:COLLect:ACQuire ECALA;*OPC?"
X = GPIB.Read
MsgBox ("Done with calibration.")

End Sub


Modify a Calibration Kit using GPIB

This Visual Basic program:

  • Modifies Calibration kit number 3

  • Completely defines standard #4 (thru)

To run this program, you need:

  • An established GPIB interface connection

'Modifying cal kit number 3
Calkitnum = 3

'Designate the kit selection to be used for performing cal's
GPIB.Write "SENSe:CORRection:COLLect:CKIT:SELect " & Val(Calkitnum)

'Reset to factory default values.
GPIB.Write "SENSe:CORRection:COLLect:CKIT:RESet " & Val(Calkitnum)

'Name this kit with your own name
GPIB.Write "SENSe:CORRection:COLLect:CKIT:NAME 'My Cal Kit'"

'Assign standard numbers to calibration classes
'Set Port 1, class 1 (S11A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer1 8"
'Set Port 1, class 2 (S11B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer2 7"
'Set Port 1, class 3 (S11C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer3 3"
'Set Port 1, class 4 (S21T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer4 4"
'Set Port 2, class 1 (S22A) to be standard #8
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer5 8"
'Set Port 2, class 2 (S22B) to be standard #7
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer6 7"
'Set Port 2, class 3 (S22C) to be standard #3
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer7 3"
'Set Port 2, class 4 (S12T) to be standard #4
GPIB.Write "SENSe:CORRection:COLLect:CKIT:ORDer8 4"

'Set up Standard #4 completely
'Select Standard #4; the rest of the commands act on it
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard 4"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMIN 300KHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:FMAX 9GHz"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance 50"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:DELay 1.234 ns"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LOSS 23e6"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C0 0"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C1 1"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C2 2"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:C3 3"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L0 10"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L1 11"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L2 12"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:L3 13"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:LABel 'My Special Thru'"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:TYPE THRU"
GPIB.Write "SENSe:CORRection:COLLect:CKIT:STANdard:CHARacteristic Coax"


Setup Sweep Parameters using GPIB

This Visual Basic program sets up sweep parameters on the Channel 1 measurement.

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"
'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'Set sweep type to linear
GPIB.Write "SENSe1:SWEep:TYPE LIN"

'Set IF Bandwidth to 700 Hz
GPIB.Write "SENSe1:BANDwidth 700"

'Set Center and Span Freq's to 4 GHz
GPIB.Write "SENSe1:FREQuency:CENTer 4ghz"
GPIB.Write "SENSe1:FREQuency:SPAN 4ghz"

'Set number of points to 801
GPIB.Write "SENSe1:SWEep:POINts 801"

'Set sweep generation mode to Analog
GPIB.Write "SENSe1:SWEep:GENeration ANAL"

'Set sweep time to Automatic
GPIB.Write "SENSe1:SWEep:TIME:AUTO ON"

'Query the sweep time
GPIB.Write "SENSe1:SWEep:TIME?
SweepTime = GPIB.Read


Setup the Display using GPIB

This Visual Basic program:

  • Sets data formatting

  • Turns ON the Trace, Title, and Frequency Annotation

  • Autoscales the Trace

  • Queries Per Division, Reference Level, and Reference Position

  • Turn ON and set averaging

  • Turn ON and set smoothing

To run this program, you need:

  • An established GPIB interface connection

GPIB.Write "SYSTem:PRESet"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Set the Data Format to Log Mag
GPIB.Write ":CALCulate1:FORMat MLOG"

'Turn ON the Trace, Title, and Frequency Annotation
GPIB.Write "Display:WINDow1:TRACe1:STATe ON"
GPIB.Write "DISPlay:WINDow1:TITLe:STATe ON"
GPIB.Write "DISPlay:ANNotation:FREQuency ON"

'Autoscale the Trace
GPIB.Write "Display:WINDow1:TRACe1:Y:Scale:AUTO"

'Query back the Per Division, Reference Level, and Reference Position
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:PDIVision?"
Pdiv = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RLEVel?"
Rlev = GPIB.Read
GPIB.Write "DISPlay:WINDow1:TRACe1:Y:SCALe:RPOSition?"
Ppos = GPIB.Read

'Turn ON, and average five sweeps
GPIB.Write "SENSe1:AVERage:STATe ON"
GPIB.Write "SENSe1:AVERage:Count 5"

'Turn ON, and set 20% smoothing aperture
GPIB.Write "CALCulate1:SMOothing:STATe ON"
GPIB.Write "CALCulate1:SMOothing:APERture 20"


Getting and Putting Data using GPIB

This Visual Basic Program does the following:

  • Reads data from the analyzer

  • Puts the data back into memory

  • To see the data, on the analyzer after running the program, from the front panel click:

Trace - Math / Memory - Memory Trace

To run this program, you need:

  • An established GPIB interface connection

Note: To change the read and write location of data, removing the comment from the beginning of ONE of the lines, and replace the comment in the beginning of the SDATA and SMEM lines.

Private Sub ReadWrite_Click()
Dim i As Integer
Dim t As Integer
Dim q As Integer
Dim dat As String
Dim cmd As String
Dim datum() As Double

GPIB.Configure
GPIB.Write "SYSTem:PRESet;*wai"

'Select the measurement
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"

'Read the number of data points
GPIB.Write "SENSe1:SWEep:POIN?"
numpts = GPIB.Read

'Turn continuous sweep off
GPIB.Write "INITiate:CONTinuous OFF"

'Take a sweep
GPIB.Write "INITiate:IMMediate;*wai"

'Ask for the Data

'PICK ONE OF THESE TO READ
'GPIB.Write "CALCulate:DATA? FDATA" 'Formatted Meas
'GPIB.Write "CALCulate:DATA? FMEM" 'Formatted Memory
GPIB.Write "CALCulate:DATA? SDATA" 'Corrected, Complex Meas
'GPIB.Write "CALCulate:DATA? SMEM" 'Corrected, Complex Memory
'GPIB.Write "CALCulate:DATA? SCORR1" 'Error-Term Directivity

'Number of values returned per data point
'q = 1 ' Pick this if reading FDATA or FMEM
q = 2 ' Otherwise pick this

'Parse the data
ReDim datum(q, numpts)
For i = 0 To numpts - 1
  For t = 0 To q - 1
  'Read the Data
  dat = GPIB.Read(20)
  'Parse it into an array
  datum(t, i) = Val(dat)
  Next t
Next i

'PUT THE DATA BACK IN
GPIB.Write "format ascii"

'PICK ONE OF THESE LOCATIONS TO PUT THE DATA
'cmd = "CALCulate:DATA FDATA," 'Formatted Meas
'cmd = "CALCulate:DATA FMEM," 'Formatted Memory
'cmd = "CALCulate:DATA SDATA," 'Corrected, Complex Meas
cmd = "CALCulate:DATA SMEM," 'Corrected, Complex Memory
'cmd = "CALCulate:DATA SCORR1," 'Error-Term Directivity

For i = 0 To numpts - 1
  For t = 0 To q - 1
  If i = numpts - 1 And t = q - 1 Then
  cmd = cmd & Format(datum(t, i))
  Else
  cmd = cmd & Format(datum(t, i)) & ","
  End If
  Next t
Next i

GPIB.Write cmd
End Sub


Status Reporting

See Other GPIB Example Programs

Status Reporting using GPIB

This Visual Basic program demonstrates two methods of reading the analyzer's status registers:

  • Polled Bit Method - reads the Limit1 register continuously.

  • SRQ Method - enables an interupt of the program when bit 6 of the status byte is set to 1. The program then queries registers to determine if the limit line failed.

To run this program, you need:

  • An established GPIB interface connection

  • A form with two buttons: Poll and SRQMethod

  • A means of causing the limit line to fail, assuming it passes initially.

Private Sub Poll_Click()
' POLL THE BIT METHOD
' Clear status registers
GPIB.Write "*CLS"

'Loop FOREVER
Do
DoEvents
GPIB.Write "STATus:QUEStionable:LIMit1:EVENt?"
onn = GPIB.Read
Loop Until onn = 2

MsgBox "Limit 1 Failed "
End Sub

--------------------------------------------------------

Private Sub SRQMethod_Click()
'SRQ METHOD
GPIB.Write "SYSTem:PRESet"
GPIB.Write "CALCulate:PARameter:SELect 'CH1_S11_1'"
'slow down the trace
GPIB.Write "SENS:BWID 150"

'Setup limit line
GPIB.Write "CALC:LIM:DATA 2,3e9,6e9,-2,-2"
GPIB.Write "CALC:LIMit:DISP ON"
GPIB.Write "CALC:LIMit:STATe ON"

' Clear status registers.
GPIB.Write "*CLS;*wai"
' Clear the Service Request Enable register.
GPIB.Write "*SRE 0"
' Clear the Standard Event Status Enable register.
GPIB.Write "*ESE 0"

' Enable questionable register, bit(10) to report to the status byte.
GPIB.Write "STATus:QUEStionable:ENABle 1024"

' Enable the status byte register bit3 (weight 8) to notify controller
GPIB.Write "*SRE 8"

' Enable the onGPIBNotify event
GPIB.NotifyMask = cwGPIBRQS
GPIB.Notify
End Sub

----------------------------------------------------
Private Sub GPIB_OnGPIBNotify(ByVal mask As Integer)
' check to see what failed
' was it the analyzer?
GPIB.Write "*STB?"
onn = GPIB.Read
If onn <> 0 Then
' If yes, then was it the questionable register?
GPIB.Write "STATus:QUEStionable:EVENt?"
onn = GPIB.Read
' Determine if the limit1 register, bit 8 is set.
If onn = 1024 Then
'if yes, then was it trace 1?
GPIB.Write "STAT:QUES:LIMIT1:EVEN?"
onn = GPIB.Read
If onn = 2 Then MsgBox ("Limit Line1 Failed")
End If
End If
End Sub


GP-IB Fundamentals

GPIB Fundamentals

The General Purpose Interface Bus (GPIB) is a system of hardware and software that allows you to control test equipment to make measurements quickly,Graphical User Interface accurately, and repeatably. This topic contains the following introductory information that explains GPIBhardware and software and how they fit together.

The GPIB Hardware Components

Instruments

Addresses

Controllers

Cables

The GPIB Programming Elements

Commands

Messages

Programming Statements

Instrument Drivers

Specifications

GPIB Interface Capability Codes

Note: All of the topics related to programming assume that you already know how to program, preferably using a language that can control instruments.

The GPIB Hardware Components

The system bus and its associated interface operations are defined by the IEEE 488 standard. The following sections list and describe the main pieces of hardware in a GPIB system:

Instruments

The analyzer is configured as a Talker / Listener by default.

  • Talkers are instruments that can be addressed to send data to the controller.

  • Listeners are instruments that can be addressed to receive a command, and then respond to the command. All devices on the bus are required to listen.

GPIB Addresses

Every GPIB instrument must have its own unique address on the bus. The analyzer address (716) consists of two parts:

  • The Interface select code (typically 7) indicates which GPIB port in the system controller is used to communicate with the device.

  • The primary address (16) is set at the factory. You can change the primary address of any device on the bus to any number between 0 and 30. The analyzer address can be changed through System \ Configure \ SICL-GPIB menu

  • The secondary address is sometimes used to allow access to individual modules in a modular instrument system, such as a VXI mainframe. The analyzer does not have secondary addresses.

Controllers

Controllers specify the instruments that will be the talker and listener in a data exchange. The controller of the bus must have a GPIB interface card to communicate on the GPIB.

  • The Active Controller is the computer or instrument that is currently controlling data exchanges.

  • The System Controller is the only computer or instrument that can take control and give up control of the GPIB to another computer or instrument, which is then called the active controller. Becuase the analyzer cannot be both Talker/Listener and System Controller, you cannot have a GPIB program running on the analyzer (controller) and have the analyzer responding to commands. To accomplish this, use COM programming.

Cables

GPIB Cables are the physical link connecting all of the devices on the bus. There are eight data lines in a GPIB cable that send data from one device to another. There are also eight control lines that manage traffic on the data lines and control other interface operations.

You can connect instruments to the controller in any arrangement with the following limitations:

  • Do not connect more than 15 devices on any GPIB system. This number can be extended with the use of a bus extension.

  • Do not exceed a total of 20 meters of total cable length or 2 meters per device, whichever is less.

  • Avoid stacking more than three connectors on the back panel of an instrument. This can cause unnecessary strain on the rear-panel connector.

The GPIB Programming Elements

The following software programming elements combine to become a GPIB program:

GPIB Commands

Messages

Programming Statements

Instrument Drivers

GPIB Commands

The GPIB command is the basic unit of communication in a GPIB system. The analyzer responds to three types of GPIB commands:

  • IEEE 488.1 Bus-management Commands

  • IEEE 488.2 Common Commands

  • SCPI Commands

IEEE 488.1 Bus-management Commands

These commands are used primarily to tell some or all of the devices on the bus to perform certain interface operations.

All of the functions that can be accomplished with these commands can also be done with IEEE 488.2 or SCPI commands. Therefore, these commands are not documented in this Help system. For a complete list of IEEE 488.1 commands refer to the IEEE 488 standard.

Examples of IEEE 488.1 Commands

  • CLEAR - Clears the bus of any pending operations

  • LOCAL - Returns instruments to local operation

IEEE 488.2 Common Commands

These commands are sent to instruments to perform interface operations. An IEEE 488.2 common command consists of a single mnemonic and is preceded by an asterisk ( * ). Some of the commands have a query form which adds a "?" after the command. These commands ask the instrument for the current setting. For a complete list of the common commands that are recognized by the analyzer, see GPIB Command Finder.

Examples of IEEE 488.2 Common Commands

  • *OPC - Operation Complete

  • *RST - Reset

  • *OPT? - Queries the option configuration

SCPI Commands

The Standard Commands for Programmable Instruments (SCPI) is a set of commands developed in 1990. The standardization provided in SCPI commands helps ensure that programs written for a particular SCPI instrument are easily adapted to work with a similar SCPI instrument. SCPI commands tell instruments to do device specific functions. For example, SCPI commands could tell an instrument to make a measurement and output data to a controller.

The Rules and Syntax of SCPI Commands provides more detail of the SCPI command structure. For a complete list of the SCPI commands that are recognized by the analyzer, see GPIB Command Finder.

Example of SCPI Commands:

  • CALCULATE:AVERAGE:STATE ON

  • SENSE:FREQUENCY:START?

GPIB Messages

A message is made up of one or more GPIB commands, punctuation, data, and an appropriate termination. There are two types of messages:

  • Program messages are sent from the controller to an instrument.

  • Response messages are sent from an instrument to the controller.

Programming Statements

GPIB messages are included with the language specific I/O statements to form program statements. The programming language determines the syntax of the programming statements. GPIB programs can be written in a variety of programming languages such as VEE, HP BASIC, or C++. Because most programmers are familiar with the BASIC language, all of the programming examples in this help system use HP BASIC. To modify these examples to work with your programming language, just substitute your language I/O statements for the HP BASIC OUTPUT and ENTER statements.

The following is an example of a message included in a Visual Basic statement to form a programming statement.

GPIB.Write "SOURCE:FREQUENCY:FIXED 1000 MHz"

sets the source frequency to 1000 Megahertz.

Note about examples

Instrument Drivers

Instrument drivers are subroutines that provide routine functionality and can be reused from program to program. GPIB industry leaders have written standards for use by programmers who develop drivers. When programmers write drivers that comply with the standards, the drivers can be used with predictable results. To comply with the standard, each instrument driver must include documentation describing its functionality and how it should be implemented.

GPIB Specifications

  • Interconnected devices - Up to 15 devices (maximum) on one contiguous bus.

  • Interconnection path - Star or linear (or mixed) bus network, up to 20 meters total transmission path length or 2 meters per device, whichever is less.

  • Message transfer scheme - Byte-serial, bit-parallel, asynchronous data transfer using an interlocking 3-wire handshake.

  • Maximum data rate - 1 megabyte per second over limited distances, 250 to 500 kilobytes per second typical maximum over a full transmission path. The devices on the bus determine the actual data rate.

  • Address capability - Primary addresses, 31 Talk and 31 Listen; secondary addresses, 961 Talk and 961 Listen. There can be a maximum of 1 Talker and up to 14 Listeners at a time on a single bus. See also previous section on GPIB addresses.

GPIB Interface Capability Codes

The IEEE 488.1 standard requires that all GPIB compatible instruments display their interface capabilities on the rear panel using codes. The codes on the analyzer, and their related descriptions, are listed below:

SH1 | full source handshake capability
AH1 | full acceptor handshake capability
T6 | basic talker, serial poll, no talk only, unaddress if MLA (My Listen Address)
TEO | no extended talker capability
L4 | basic listener, no listen only, unaddress if MTA (My Talk Address)
LEO | no extended listener capability
SR1 | full service request capability
RL1 | full remote / local capability
PPO | no parallel poll capability
DC1 | full device clear capability
DT1 | full device trigger capability
C1 | system controller capability
C2 | send IFC (Interface Clear) and take charge controller capability
C3 | send REN (Remote Enable) controller capability
C4 | respond to SRQ (Service Request)


The Rules and Syntax of SCPI Commands

The Rules and Syntax of SCPI

Most of the commands used for controlling instruments on the GPIB are SCPI commands. The following sections will help you learn to use SCPI commands in your programs.

Branches on the Command Tree

Command and Query

Multiple Commands

Command Abbreviation

Bracketed (Optional) Keywords

Vertical Bars (Pipes)

MIN and MAX Parameters

Note: For background information on SCPI Commands, see GPIB Fundamentals / Commands

Branches on the Command Tree

All major functions on the analyzer are assigned keywords which are called ROOT commands. (See GPIB Command Finder for a list of SCPI root commands). Under these root commands are branches that contain one or more keywords. The branching continues until each analyzer function is assigned to a branch. A root command and the branches below it is sometimes known as a subsystem.

For example, the following graphic shows the SOURce subsystem. Under the SOURce and POWer keywords are several brach commands.

Sometimes the same keyword, such as START, is used in several branches of the command tree. To keep track of the current branch, the analyzer's command parser uses the following rules:

  • Power On and Reset - After power is cycled or after *RST, the current path is set to the root level commands.

  • Message Terminators - A message terminator, such as a <NL> character, sets the current path to the root command level. Many programming language output statements send message terminators automatically. Message terminators are described in Sending Messages to the Analyzer.

  • Colon (:) - When a colon is between two command keywords, it moves the current path down one level in the command tree. For example, the colon in :SOURCE:POWER specifies that POWER is one level below SOURCE. When the colon is the first character of a command, it specifies that the following keyword is a root level command. For example, the colon in :SOURCE specifies that source is a root level command.

Note: You can omit the leading colon if the command is the first of a new program line. For example, the following two commands are equivalent:
SOUR:POW:ATT:AUTO
:SOUR:POW:ATT:AUTO

  • <WSP> - Whitespace characters, such as <tab> and <space>, are generally ignored. There are two important exceptions:

    • Whitespace inside a keyword, such as :CALC ULATE, is not allowed.

    • You must use white space to separate parameters from commands. For example, the <WSP> between STATE and ON in the command CALCULATE:SMOOTHING:STATE ON is mandatory. Whitespace does not affect the current path.

  • Comma (,) - If a command requires more than one parameter, you must separate adjacent parameters using a comma. For example, the SYSTEM:TIME command requires three values to set the analyzer clock: one for hours, one for minutes, and one for seconds. A message to set the clock to 8:45 AM would be SYSTEM:TIME 8,45,0. Commas do not affect the current path.

  • Semicolon(;) - A semicolon separates two commands in the same message without changing the current path. See Multiple Commands later in this topic.

  • IEEE 488.2 Common Commands - Common commands, such as *RST, are not part of any subsystem. An instrument interprets them in the same way, regardless of the current path setting.

Command and Query

A SCPI command can be an Event command, Query command (a command that asks the analyzer for information), or both. The following are descriptions and examples of each form of command. GPIB Command Finder lists every SCPI command that is recognized by the analyzer, and its form.

Form | Examples
Event commands - cause an action to occur inside the analyzer. | :INITIATE:IMMEDIATE
Query commands - query only; there is no associated analyzer state to set. | :SYSTem:ERRor?
Command and query - set or query an analyzer setting. The query form appends a question mark (?) to the set form | :FORMat:DATA ! Command :FORMat:DATA? ! Query

Multiple Commands

You can send multiple commands within a single program message. By separating the commands with semicolons the current path does not change. The following examples show three methods to send two commands:

  1. Two program messages:

SOURCE:POWER:START 0DBM
SOURCE:POWER:STOP 10DBM

  2. One long message. A colon follows the semicolon that separates the two commands causing the command parser to reset to the root of the command tree. As a result, the next command is only valid if it includes the entire keyword path from the root of the tree:

SOURCE:POWER:START 0DBM;:SOURCE:POWER:STOP 10DBM

  3. One short message. The command parser keeps track of the position in the command tree. Therefore, you can simplify your program messages by including only the keyword at the same level in the command tree.

SOURCE:POWER:START 0DBM;STOP 10DBM

Common Commands and SCPI Commands

You can send Common commands and SCPI commands together in the same message. (For more information on these types of commands see GP-IB Fundamentals.) As in sending multiple SCPI commands, you must separate them with a semicolon.

Example of Common command and SCPI commands together

*RST;SENSE:FREQUENCY:CENTER 5MHZ;SPAN 100KHZ

Command Abbreviation

Each command has a long form and an abbreviated short form. The syntax used in this Help system use uppercase characters to identify the short form of a particular keyword. The remainder of the keyword is lower case to complete the long form.

SOUR - Short form
SOURce - Long form

Either the complete short form or complete long form must be used for each keyword. However, the keywords used to make a complete SCPI command can be a combination of short form and long form.

The following is unacceptable - The first three keywords use neither short or long form.

SOURc:Powe:Atten:Auto on

The following is acceptable - All keywords are either short form or long form.

SOUR:POWer:ATT:AUTO on

In addition, the analyzer accepts lowercase and uppercase characters as equivalent as shown in the following equivalent commands:

source:POW:att:auto ON
Source:Pow:Att:Auto on

Optional [Bracketed] Keywords

You can omit some keywords without changing the effect of the command. These optional, or default, keywords are used in many subsystems and are identified by brackets in syntax diagrams.

Example of Optional Keywords

The HCOPy subsystem contains the optional keyword IMMediate at its first branching point. Both of the following commands are equivalent:

"HCOPY:IMMEDIATE"
"HCOPY"

The syntax in this Help system looks like this:

HCOPy[:IMMediate]

Vertical Bars | Pipes

Vertical bars, or "pipes", can be read as "or". They are used in syntax diagrams to separate alternative parameter options.

Example of Vertical Bars:

SOURce:POWer:ATTenuation:AUTO <on|off>

Either ON or OFF is a valid parameter option.

MIN and MAX Parameters

The special form parameters "MINimum" and "MAXimum" can be used with numerous commands in the analyzer, as noted in the command documentation. The short form (min) and long form (minimum) of these two keywords are equivalent.

  • MAXimum refers to the largest value that the function can currently be set to

  • MINimum refers to the smallest value that the function can currently be set to.

For example, the following command sets the start frequency to the smallest value that is currently possible:

SENS:FREQ:START MIN

In addition, the max and min values can also be queried for these commands.

For example, the following command returns the smallest value that Start Frequency can currently be set to:

SENS:FREQ:START? MIN

An error will be returned if a numeric parameter is sent that exceeds the MAX and MIN values.

For example, the following command will return an "Out of range" error message.

SENS:FREQ:START 1khz


Getting Data from the Analyzer

Data is sent from the analyzer in response to program queries. Data can be short response messages, such as analyzer settings, or large blocks of measurement data. This topic discusses how to read query responses and measurement data from the analyzer in the most efficient manner.

Response Message Syntax

Clearing the Output Queue

Response Data Types

Numeric Data

Character Data

String Data

Block Data

Transferring Measurement Data

Note: Some PCs use a modification of the IEEE floating point formats with the byte order reversed. To reverse the byte order for data transfer into a PC, the FORMat:BORDer command should be used. See GPIB Command Finder for details.

Response Message Syntax

Responses sent from the analyzer contain data, appropriate punctuation, and message terminators.

<NL><^END> is always sent as a response message terminator. Most programming languages handle these terminators transparent to the programmer.

Response messages use commas and semicolons as separators in the following situations:

  • a comma separates response data items when a single query command returns multiple values

FORM:DATA? 'Query
ASC, +0 'Analyzer Response

  • a semicolon separates response data when multiple queries are sent within the same messages

SENS:FREQ:STAR?;STOP? --Example Query

+1.23000000E+008; +7.89000000E+008<NL><^END> 'Analyzer Response

Clearing the Output Queue

After receiving a query, the analyzer places the response message in it's output queue. Your program should read the response immediately after the query is sent. This ensures that the response is not cleared before it is read. The response is cleared when one of the following conditions occur:

  • When the query is not properly terminated with an ASCII carriage return character or the GPIB <^END> message.

  • When a second program query is sent.

  • When a program message is sent that exceeds the length of the input queue

  • When a response message generates more response data than fits in the output queue.

  • When the analyzer is switched ON.

Response Data Types

The analyzer sends different response data types depending on the parameter being queried. You need to know the type of data that will be returned so that you can declare the appropriate type of variable to accept the data. For more information on declaring variables see your programming language manual. The GPIB Command Finder lists every GPIB command and the return format of data in response to a query. The analyzer returns the following types of data:

Numeric Data

Character Data

String Data

Block Data

Numeric Data

The analyzer sends ASCII character data that looks like numeric data. All numeric data sent over the GPIB is character data.

Character Data

Character data consists of ASCII characters grouped together in mnemonics that represent specific analyzer settings. The analyzer always returns the short form of the mnemonic in upper-case alpha characters. Character data looks like string data. Therefore, refer to the GPIB Command Finder to determine the return format for every command that can be queried.

Example of Character Data

MLOG

String Data

String data consists of ASCII characters. The analyzer always encloses data in double quotes when it returns string data.

Example of String Data

GPIB.Write "DISP:WINDow:TITLe:DATA?"

“This is string response data.”

Block Data

Block data is used to transfer measurement data. Although the analyzer will accept either definite length blocks or indefinite length blocks, it always returns definite length block data in response to queries unless the specified format is ASCII. The following graphic shows the syntax for definite block data:

<num_digits> specifies how many digits are contained in <byte_count>
<byte_count> specifies how many data bytes will follow in <data bytes>

Example of Definite Block Data

#17ABC+XYZ<nl><end>

# - always sent before definite block data

1 - specifies that the byte count is one digit (7)

7 - specifies the number of data bytes that will follow, not counting <NL><END>

<NL><END> - always sent at the end of block data

Transferring Measurement Data

Measurement data is blocks of numbers that result from an analyzer measurement. Measurement data is available from various processing arrays within the analyzer. For more information on the analyzer's data processing flow, see Accessing the Data Arrays. Regardless of which measurement array is read, transferring measurement data is done the same.

When transferring measurement data, there are two data types to choose from:

  • REAL

  • ASCII

The following graphic shows the differences in transfer times between the two:

REAL Data

REAL data (also called floating-point data) types transfer faster. This is because REAL data is binary and takes about half the space of ASCII data. The disadvantage of using REAL data is that it requires a header that must be read. See definite length block data. The binary floating-point formats are defined in the IEEE 754-1985 standard. The following choices are available in REAL format:

  • REAL,32 - IEEE 32-bit format - single precision (not supported by HP BASIC)

  • REAL,64 - IEEE 64-bit format - double precision

These data types are selected using the FORMat SCPI command.

ASCII Data

The easiest and slowest way to transfer measurement data is to use ASCII data. If the data contains both numbers and characters, the setting of FORMat:DATA is ignored. ASCII data is separated by commas.


Understanding Command Synchronization

Thi s program determines which frequency contains the maximum amplitude.

GPIB.Write "ABORT; :INITIATE:IMMEDIATE"! Restart the measurement
GPIB.Write "*OPC?" 'Wait until complete
Meas_done = GPIB.Read 'Read output queue, throw away result
GPIB.Write "CALCULATE:MARKER:MAX" 'Search for max amplitude
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?
Marker_x = GPIB.Read
PRINT "MARKER at " & Marker_x & " Hz"

See Also...

Understanding Command Synchronization

The analyzer takes more time to process some commands than others:

  • Sequential commands are processed quickly and in the order in which they are received.

  • Overlapped commands take longer to process. Therefore, they allow the program to do other tasks while waiting. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

Note: The analyzer has two overlapped commands:
- INITitate:IMMediate
- SENSe:SWEep:MODE GROUPS (when INIT:CONT is ON)

The analyzer's queues store commands and responses waiting to be processed. Using the analyzer's queues and controlling the processing sequence of overlapped commands is called synchronizing the analyzer and the controller. This topic discusses how and when synchronizing should be performed.

Analyzer Queues

Input Queue

Output Queue

Error Queue

Synchronizing Overlapped Commands

Synchronization Methods

When To Synchronize

Analyzer Queues

Queues are memory buffers that store messages until they can be processed. The analyzer has the following queues:

Input Queue

Output Queue

Error Queue

Input Queue

The controller sends statements to the analyzer without regard to the amount of time required to execute the statements. The input queue is very large (31k bytes). It temporarily stores commands and queries from the controller until they are read by the analyzer's command parser. The input queue is cleared when the analyzer is switched ON.

Output Queue

When the analyzer parses a query, the response is placed in the output queue until the controller reads it. Your program should immediately read the response or it may be cleared from the output queue. The following conditions will clear a query response:

  • When a second query is sent before reading the response to the first. This does not apply when multiple queries are sent in the same statement.

  • When a program statement is sent that exceeds the length of the input queue.

  • When a response statement generates more data than fits in the output queue.

  • When the analyzer is switched ON.

Error Queue

Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Synchronizing Overlapped Commands

GPIB commands are executed and processed by the analyzer in the order they are received. Commands can be divided into two broad classes:

  • Overlapped commands generally take extended time to process by the analyzer. Examples of functions that have overlapped commands are printing and making measurements. Because they take longer to process, they allow the execution of subsequent commands while the overlapped command is still in progress. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. This is called "synchronizing" the analyzer and controller.

  • Sequential commands are generally processed quickly by the analyzer. Therefore, they prevent the processing of subsequent commands until the sequential command has been completely processed. These commands do NOT require synchronization.

Synchronization Methods

When To Synchronize

Synchronization Methods

The following common commands are used to synchronize the analyzer and controller. Examples are included that illustrate the use of each command in a program. See the SCPI command details to determine if a command is an overlapped command.

*WAI

*OPC?

*OPC

*WAI

The *WAI command:

  • Stops the analyzer from processing subsequent device commands until all overlapped commands are completed.

  • It does NOT stop the controller from sending commands to this and other devices on the bus. This is the easiest method of synchronization.

Example of the *WAI command

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "CALCULATE:MARKER:SEARCH:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?

The following timeline shows how the processing times of the three commands relate to each other:

INITIATE:IMMEDIATE is an overlapped command; it allows the immediate processing of the sequential command, CALCULATE:MARKER:SEARCH:MAXIMUM. However, the INITIATE:IMMEDIATE is not considered complete until the measurement is complete. Therefore, the marker searches for maximum amplitude before the measurement completes. The CALCULATE:MARKER:X? query could return an inaccurate value.

To solve the problem, insert a *WAI command.

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "*WAI" 'Wait until complete.
GPIB.Write "CALCULATE:MARKER:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency

The timeline now looks like this:

The *WAI command keeps the MARKER:SEARCH:MAXIMUM from taking place until the measurement is completed. The CALCULATE:MARKER:X? query returns the correct value.

Note: Although *WAI stops the analyzer from processing subsequent commands, it does not stop the controller. The controller could send commands to other devices on the bus.

*OPC?

The *OPC? query stops the controller until all pending overlapped commands are completed.

In the following example, the Read statement following the *OPC? query will not complete until the analyzer responds, which will not happen until all pending overlapped commands have finished. Therefore, the analyzer and other devices receive no subsequent commands. A "1" is placed in the analyzer output queue when the analyzer completes processing an overlapped command. The "1" in the output queue satisfies the Read command and the program continues.

Example of the *OPC? query [image] Click

*OPC

The *OPC command allows the analyzer and the controller to process commands while processing the overlapped command.

When the analyzer completes processing an overlapped command, the *OPC command sets bit 0 of the standard event register to 1 . This requires polling of status bytes or use of the service request (SRQ) capabilities of your controller. See Reading the Analyzer's Status Registers for more information about the standard event status register, generating SRQs, and handling interrupts.

Note: Be careful when sending commands to the analyzer between the time you send *OPC and the time you receive the interrupt. Some commands could jeopardize the integrity of your measurement. It also could affect how the instrument responds to the previously sent *OPC.

Example of polled bit and SRQ processes.

When To Synchronize the Analyzer and Controller

Although a command may be defined as an overlapped command, synchronization may not be required. The need to synchronize depends upon the situation in which the overlapped command is executed. The following section describes situations when synchronization is required to ensure a successful operation.

Completion of a Measurement

Measurements with External Trigger

Averaged Measurements

Completion of a Measurement

To synchronize the analyzer and controller to the completion of a measurement, use the ABORT;INITIATE:IMMEDIATE command sequence to initiate the measurement.

This command sequence forces data collection to start (or restart) under the current measurement configuration. A restart sequence, such as ABORT;INITIATE:IMMEDIATE is an overlapped command. It is complete when all operations initiated by that restart command sequence, including the measurement, are finished. The *WAI,*OPC? and *OPC commands allow you to determine when a measurement is complete. This ensures that valid measurement data is available for further processing.

Measurements with External Trigger

To use an external trigger, synchronize the analyzer and controller before the trigger is supplied to the measurement. Setup the analyzer to receive a trigger from an external source (wired to the EXTERNAL TRIGGER connector on the rear panel. The trigger system is armed by GPIB with INITIATE:IMMEDIATE. (Because the source of the trigger has been specified as external, this command "readies" the analyzer for a trigger but it does not actually generate the trigger.).

Averaged Measurements

Averaged measurements are complete when the average count is reached. The average count is reached when the specified number of individual measurements is combined into one averaged measurement result. Use synchronization to determine when the average count has been reached.

If the analyzer continues to measure and average the results after the average count is reached, use synchronization to determine when each subsequent measurement is complete.


Reading the Analyzer's Status Registers

Status Commands

Reading the Analyzer's Status Register

The analyzer has several status registers that your program can read to know when specific events occur. There are two methods of reading the status registers in the analyzer: the Polled Bit method and the Service Request method.

Polled Bit Method

Service Request Method

Setting and Reading Bits in Status Registers

Positive and Negative Transitions

Most of the status registers in the analyzer are sixteen bits. For simplicity, this topic will illustrate their use with 8-bit registers. Bits in registers represent the status of a different conditions inside of the analyzer. In the following graphic, a register is represented by a row of boxes; each box represents a bit. Bit 3 is ON.

The Polled Bit Method

With the Polled Bit Method, your program continually monitors a bit in the status register that represents the condition of interest to you. When the analyzer sets the bit to 1, your program immediately sees it and responds accordingly.

Advantage: This method requires very little programming.

Disadvantage: This method renders your program unavailable to do anything other than poll the bit of interest until the condition occurs.

Procedure:

1. Decide which condition to monitor. The Status Commands topic lists all of the possible conditions that can be monitored in the analyzer.

2. Determine the command and the bit that will monitor the command.

3. Construct a loop to poll that bit until it is set.

4. Construct the routine to respond when the bit is set.

The Service Request (SRQ) Method

Your program enables the bits in the status registers representing the condition of interest. When the condition occurs, the analyzer actively interupts your program from whatever it is doing, and an event handler in your program responds accordingly. Do this method if you have several conditions you want to monitor or the conditions are such that it is not practical to wait for the condition to occur.

Advantage: This method frees your program to do other things until the condition occurs. The program is interupted to respond to the condition.

Disadvantage: This method can require extensive programming depending on the number and type of conditions that you want to monitor.

Procedure:

1. Decide which conditions to monitor. The Status Commands topic lists all of the possible analyzer conditions that can be monitored.

2. Set the enable bits in the summary registers and the status byte register.

Enabling is like making power available to a light - without power available, the switch can be activated, but the light won't turn ON. In the analyzer, without enabling, the condition may occur, but the controller won't see it unless it is enabled.

The condition, and the bit in the summary registers in the reporting path, must be enabled. Summary This is like streams (conditions) flowing into rivers (summary registers), and rivers flowing into the ocean (controller). See the diagram of status registers in Status Commands.

Bit 6 of the status byte register is the only bit that can interrupt the controller. When any representative bit in the status byte register goes ON, bit 6 is automatically switched ON.

4. Enable your program to interupt the controller, This is done several ways depending on the programming language and GPIB interface card you use. An example program is provided showing how this is done with in Visual Basic with a National Instruments GPIB card.

5. Construct a subroutine to handle the interrupt event. If you are monitoring more than one condition in your system, your event handler must determine which condition caused the interupt. Use the *SPE command to determine the instrument that caused the interupt and then poll the summary registers, and then condition registers to determine the cause of the interupt.

Setting and Reading Bits in Status Registers

Both methods for reading status registers requires that you read bits out of the status registers. Most of the analyzers status registers contain 16 bits, numbered 0 to 15. Each bit has a weighted value. The following example shows how to set the bits in a 8-bit status register.

8-bit register

Bit | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Weight | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128

We want to set bits 4 and 5 in the Standard Event Status Enable register.

Step | Example
1. Read the weighted bit value for these bits | weights 16 and 32 (respectively)
2. Add these values together | 16 + 32 = 48
3. Send this number as an argument in the appropriate command. (see Status Commands) | STAT:QUES:LIMIT1:ENAB 1026

Positive and Negative Transitions

Transition registers control what type of in a condition register will set the corresponding bit in the event register.

  • Positive transitions (0 to 1) are only reported to the event register if the corresponding positive transition bit is set to 1.

  • Negative transitions (1 to 0) are only reported to the event register if the corresponding negative transition bit is set to 1.

  • Setting both transition bits to 1 causes both positive and negative transitions to be reported.

Transition registers are read-write and are unaffected by *CLS (clear status) or queries. They are reset to their default settings at power-up and after *RST and SYSTem:PRESet commands. The following are the default settings for the transition registers:

  • All Positive Transition registers = 1

  • All Negative Transition registers = 0

This means that by default, the analyzer will latch all event registers on the negative to positive transition (0 to 1).

The following is an example of why you would set transitions registers:

A critical measurement requires that you average 10 measurements and then restart averaging. You decide to poll the averaging bit. When averaging is complete, the bit makes a positive transition. After restart, you poll the bit to ensure that it is set back from 1 to 0, a negative transition. You set the negative transition bit for the averaging register.


COM Example Intro

Communicating with Other Applications

See the list of examples.

The analyzer’s support for DCOM (Distributed Component Object Model) over the LAN provides control of the analyzer using a variety of platforms. DCOM acts as an interface to the analyzer for external applications. With DCOM, the programmer can develop an application on an external computer. During development, the application will interface to the analyzer over the LAN through the DCOM interface. Once the developer has finished the application, it can be distributed to (installed on) the analyzer. After it has been distributed to the analyzer, the application interfaces with the analyzer using COM.

The example applications referred to in this topic were developed in a number of different programming languages to show the differences between development platforms. The table below outlines the setup parameters that the applications will use to configure the PNA network analyzer for a measurement.

Parameter | Value
Start Frequency | 1 GHz
Stop Frequency | 2 GHz
Number of Points | 11
Measurement | S 11
Data Storage Area | Uncorrected (Raw Data)
Data Format | Log Magnitude
Trigger Mode | Single
The device tested was a 50 ohm standard load on port 1 of the analyzer

You can download the example programs and obtain more detailed information for each development environment from http://agilent.com/find/pna_applications

The development environment should reference the type library associated with the PNA Series. For example, in Visual Basic, add the Agilent PNA 835x type library as a reference. This will allow the program to “see” the various classes and methods for use with the PNA Series network analyzer during development.

List of Examples

Agilent VEE Example

Microsoft Excel Example

Microsoft Visual Basic Example

Microsoft Visual Basic Script Example

Microsoft Visual C++ Example

Microsoft Word Example

National Instruments LabVIEW Example


Intro to Examples

Agilent VEE Example

Application Configuration

For this example use Agilent VEE version 6.0 or above which contains the Variant data type used to transfer data from the PNA. The type library for the PNA should be referenced in the Agilent VEE development environment.

Using the Agilent VEE Object Browser the developer can see the classes and methods which are available for development of applications for the PNA Series analyzer.

Application Code

There is a runtime version of Agilent VEE that may be used if the application has been saved as “runtime”. A free version of Agilent VEE can be found on the following web site: http://www.agilent.com/find/vee/. The application may be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


Intro to Examples

Microsoft Visual Basic Example

Application Configuration

The type library for the PNA should be referenced in the Visual Basic development environment.

Using the Visual Basic Object Browser the developer can see what classes and methods are available for development of applications for the analyzer.

Application Code

The application code is contained below. To run the application, first generate the executable file. Once this is complete, it can be copied and executed on the analyzer or run on the PC. The application can also be run from the development environment.

Option Explicit

Dim app As AgilentPNA835x.Application
Dim chan As AgilentPNA835x.Channel
Dim meas As AgilentPNA835x.Measurement
Dim result As Variant
Dim i As Integer
Dim num_points As Integer
Dim message As String

Private Sub Main()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCrLf
Next

If MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") Then
Set chan = Nothing
app.Quit
End If

End Sub


Intro to Examples

Microsoft Visual Basic Script Example

Application Configuration

Some operating systems may require that the Visual Basic Scripting engine be installed before running the application on a PC. To download a free copy of a Visual Basic Scripting engine, visit the following web site: http://msdn.microsoft.com/scripting/

Application Code

The application code is contained below. The developer must save the file in a text file (i.e. using notepad) and save it with the “.vbs” extension. The “.vbs” extension will tell the operating system to execute the code using the Visual Basic Scripting engine.

In order to run the application, double-click on the saved .vbs file. The application can be run on a PC or copied and run on the PNA Series network analyzer.

Option Explicit

' Shell objects
Dim app
Dim chan
Dim meas
Dim result
Dim message
Dim num_points
Dim i

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = 3
chan.TriggerMode = 1

' Make the PNA application
 visible
app.Visible = True
' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000)
chan.StopFrequency = (2000000000)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(0, 1)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
message = message & result(i) & vbCRLF
Next

if MsgBox(message, vbOKOnly, "S11(dB) - VBS COM
Example for PNA") then
Set chan = Nothing
app.quit

end if


Intro to Examples

Microsoft Visual C++ Example

Application Configuration

Microsoft Visual C++ version 6 was used for this example. In order to perform this example, create a new project in Microsoft Visual C++. Add a C++ file to the project and paste the following code into the file. The path for the type library in the code below should be changed to reference its location on the development PC.

Application Code

The application can be run on a PC or on the PNA.

#include "stdafx.h"

// import the Tsunami type library
//--------------------------
#import "C:\Program Files\Agilent\Network Analyzer\835x.tlb"
no_namespace, named_guids
int main(int argc, char* argv[])
{
// interface pointers to retrieve COM interfaces
IUnknown* pUnk = 0;
IApplication* pNA = 0;
IChannel* pChan = 0;
IMeasurement* pMeas = 0;
IArrayTransfer* pTrans = 0;
int i, num_points = 0;
float* pScalarData;

HRESULT hr;

// Initialize the COM subsystem
CoInitialize(NULL);

// Create an instance of the network analyzer
// Request the NA's IUnknown interface
hr = CoCreateInstance(CLSID_Application,0,
CLSCTX_ALL,IID_IUnknown, (void**) &pUnk);
if (!FAILED(hr)) {

// QueryInterface for the INetworkAnalyzer interface
of the NetworkAnalyzer object
hr = pUnk->QueryInterface(IID_IApplication,
(void**)&pNA);

if (!FAILED(hr)) {

// Reset the analyzer to instrument preset
pNA->Reset();

// Create S11 measurement
pNA->CreateSParameter(1,1,1,1);

// Set pChan variable to point to the active
channel
pNA->get_ActiveChannel(&pChan);

if (pChan) {

// Set pMeas variable to point to the active
measurement
pNA->get_ActiveMeasurement(&pMeas);

if(pMeas) {

// Setup the channel for a single trigger
pChan->Hold(true);
pNA->TriggerSignal = naTriggerManual;
pChan->TriggerMode =
naTriggerModeMeasurement;

// Make the PNA application visible
pNA->put_Visible(true);

// Set channel parameters
pChan->NumberOfPoints = 11;
pChan->StartFrequency = 1e9;
pChan->StopFrequency = 2e9;

// Send a manual trigger to initiate a single
sweep
pChan->Single(true);

// QueryInterface for the IArrayTransfer
interface of the NetworkAnalyzer object
hr = pMeas->QueryInterface(IID_IArray
Transfer, (void**)&pTrans);

if (!FAILED(hr)) {

// Store the data in the "result"
 variable
num_points = pChan->NumberOfPoints;
pScalarData = new float[num_points];
pTrans->getScalar(naRawData, naData
Format_LogMag, (long *)&num_points,
pScalarData);

// Display the result
printf("S11(dB) - Visual C++ COM
Example for PNA\n\n");
for (i = 0; i < num_points; i++)
printf("%f\n",pScalarData[i]);

}
}
}
}

pUnk->Release();
pMeas->Release();
pChan->Release();
pTrans->Release();
pNA->Release();
}
CoUninitialize();
return 0;
}


Intro to Examples

Microsoft Word Example

Application Configuration

Microsoft® Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Word documents. The type library for the PNA Series network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into a table in a Word document. To run the application, open the document using Microsoft Word. Enable the macros when prompted. Once this is complete, the application will execute and update the document. The application can be run on a PC or the analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Document_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
ThisDocument.Tables(1).Cell(i + 2, 2).Range = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


Intro to Examples

Microsoft Excel Example

Application Configuration

Microsoft Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Excel documents. The type library for the PNA network analyzer should be referenced in the Visual Basic development environment.

Application Code

The application code is contained below. The program inserts the data retrieved from the analyzer into cells in the Excel document. The cells are then used to update a graph in the Excel document. To run the application, open the document using Microsoft Excel. Enable macros when prompted by the application. Once this is complete, the application will execute and update the document. It can be run on a PC or the PNA analyzer.

Option Explicit

Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Workbook_Open()

' Connect to the PNA application; change analyzerName to your analyzer's full computer name

Set app = CreateObject("AgilentPNA835x", "analyzerName")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = naTriggerManual
chan.TriggerMode = naTriggerModeMeasurement

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000#)
chan.StopFrequency = (2000000000#)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(naRawData,
naDataFormat_LogMag)

' Display the result
num_points = chan.NumberOfPoints 14

For i = 0 To num_points - 1
Sheet1.Cells(3 + i, 1) = result(i)
Next

Set chan = Nothing
app.Quit

End Sub


National Instruments LabVIEW Example

Intro to Examples

National InstrumentsTM LabVIEW Example

Application Configuration

Use National Instruments™ Lab VIEW version 5.0 or above for this example. See the National Instruments™ LabVIEW documentation for information on using ActiveX objects in the LabVIEW development environment.

Application Code

National Instruments™ LabVIEW 5.0 or higher must be installed to run the application. The application can be run on a PC or on the PNA Series analyzer.

The application file is located at http://agilent.com/find/pna_applications.


GPIB using Visual C++

/*
* This example assumes the user's PC has a National Instruments GPIB
 board. The example is comprised of three basic parts:
*
* 1. Initialization
* 2. Main Body
* 3. Cleanup
*
* The Initialization portion consists of getting a handle to the
 PNA and then doing a GPIB clear of the PNA.
*
* The Main Body consists of the PNA SCPI example.
*
* The last step, Cleanup, releases the PNA for front panel control.
*/

#include <stdio.h>
#include <stdlib.h>

/*
* Include the WINDOWS.H and DECL-32.H files. The standard Windows
* header file, WINDOWS.H, contains definitions used by DECL-32.H
 and
* DECL-32.H contains prototypes for the NI GPIB routines and constants.
*/
#include <windows.h>
#include "decl-32.h"

#define ERRMSGSIZE 1024 // Maximum size of SCPI command string
#define ARRAYSIZE 1024 // Size of read buffer

#define BDINDEX 0 // Board Index of GPIB board
#define PRIMARY_ADDR_OF_PNA 16 // GPIB address of PNA
#define NO_SECONDARY_ADDR 0 // PNA has no Secondary address
#define TIMEOUT T10s // Timeout value = 10 seconds
#define EOTMODE 1 // Enable the END message
#define EOSMODE 0 // Disable the EOS mode

int pna;
char ValueStr[ARRAYSIZE + 1];
char ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL",
 "EADR", "EARG",
"ESAC", "EABO", "ENEB", "EDMA",
 "",
"EOIP", "ECAP", "EFSO", "",
 "EBUS",
"ESTB", "ESRQ", "", "",
 "", "ETAB"};

void GPIBWrite(char* SCPIcmd);
char *GPIBRead(void);
void GPIBCleanup(int Dev, char* ErrorMsg);

int main()
{

char *opc;
char *result;
char *value;

/*
* =========================================
* INITIALIZATION SECTION
* =========================================
*/

/*
* The application brings the PNA online using ibdev. A device handle,pna,
 is returned and is used in all subsequent calls to the PNA.
*/
pna = ibdev(BDINDEX, PRIMARY_ADDR_OF_PNA, NO_SECONDARY_ADDR,
TIMEOUT, EOTMODE, EOSMODE);
if (ibsta & ERR)
{
printf("Unable to open handle to PNA\nibsta = 0x%x iberr =
 %d\n",
ibsta, iberr);
return 1;
}

/*
* Do a GPIB Clear of the PNA. If the error bit ERR is set in ibsta,
 call GPIBCleanup with an error message.
*/
ibclr (pna);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to perform GPIB clear of the PNA");
return 1;
}

/*
* =========================================
* MAIN BODY SECTION
* =========================================
*/

// Reset the analyzer to instrument preset
GPIBWrite("SYSTem:FPRESET");

// Create S11 measurement
GPIBWrite("CALCulate1:PARameter:DEFine 'My_S11',S11");

// Turn on Window #1
GPIBWrite("DISPlay:WINDow1:STATe ON");

// Put a trace (Trace #1) into Window #1 and 'feed' it from the
 measurement
GPIBWrite("DISPlay:WINDow1:TRACe1:FEED 'My_S11'");

// Setup the channel for single sweep trigger
GPIBWrite("INITiate1:CONTinuous OFF;*OPC?");
opc = GPIBRead();
GPIBWrite("SENSe1:SWEep:TRIGger:POINt OFF");

// Set channel parameters
GPIBWrite("SENSe1:SWEep:POINts 11");
GPIBWrite("SENSe1:FREQuency:STARt 1000000000");
GPIBWrite("SENSe1:FREQuency:STOP 2000000000");

// Send a trigger to initiate a single sweep
GPIBWrite("INITiate1;*OPC?");
opc = GPIBRead();

// Must select the measurement before we can read the data
GPIBWrite("CALCulate1:PARameter:SELect 'My_S11'");

// Read the measurement data into the "result" string
 variable
GPIBWrite("FORMat ASCII");
GPIBWrite("CALCulate1:DATA? FDATA");
result = GPIBRead();

// Print the data to the display console window
printf("S11(dB) - Visual C++ SCPI Example for PNA\n\n");
value = strtok(result, ",");
while (value != NULL)
{
printf("%s\n", value);
value = strtok(NULL, ",");
}

/*
* =========================================
* CLEANUP SECTION
* =========================================
*/

/* The PNA is returned to front panel control. */
ibonl(pna, 0);

return 0;
}

/*
* Write to the PNA
*/
void GPIBWrite(char* SCPIcmd)
{
int length;
char ErrorMsg[ERRMSGSIZE + 1];
length = strlen(SCPIcmd) ;

ibwrt (pna, SCPIcmd, length);
if (ibsta & ERR)
{
strcpy(ErrorMsg, "Unable to write this command to PNA:\n");
strcat(ErrorMsg, SCPIcmd);

GPIBCleanup(pna, ErrorMsg);
exit(1);
}
}

/*
* Read from the PNA
*/
char* GPIBRead(void)
{
ibrd (pna, ValueStr, ARRAYSIZE);
if (ibsta & ERR)
{
GPIBCleanup(pna, "Unable to read from the PNA");
exit(1);
}
else
return ValueStr;
}

/*
* After each GPIB call, the application checks whether the call succeeded.
 If an NI-488.2 call fails, the GPIB driver sets the corresponding bit
 in the global status variable. If the call failed, this procedure prints
 an error message, takes the PNA offline and exits.
*/
void GPIBCleanup(int Dev, char* ErrorMsg)
{
printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n",
ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]);
if (Dev != -1)
{
printf("Cleanup: Returning PNA to front panel control\n");
ibonl (Dev, 0);
}
}


GPIB using Visual Basic

To run this program, you need:

  • An established GPIB interface connection

Option Explicit

Dim opc As Integer
Dim result As String
Dim i As Integer
Dim num_points As Integer
Dim commaPosition As Integer
Dim message As String
'
' Program executes when the 'Run' button is clicked.
Private Sub cmdRun_Click()
  ' National Instruments ComponentWorks 'Instr' ActiveX Control, Version 2.0.1

  ' Default board number for National Instruments GPIB boards
  GPIB.BoardNumber = 0

  ' Default GPIB address of PNA
  GPIB.PrimaryAddress = 16

  ' Initialize the GPIB connection
  GPIB.Configure

  ' Reset the analyzer to instrument preset
  GPIB.Write "SYSTem:FPRESET"

  ' Create S11 measurement
  GPIB.Write "CALCulate1:PARameter:DEFine 'My_S11',S11"

  ' Turn on Window #1
  GPIB.Write "DISPlay:WINDow1:STATe ON"

  ' Put a trace (Trace #1) into Window #1 and 'feed' it from the measurement
  GPIB.Write "DISPlay:WINDow1:TRACe1:FEED 'My_S11'"

  ' Setup the channel for single sweep trigger
  GPIB.Write "INITiate1:CONTinuous OFF;*OPC?"
  opc = GPIB.Read
  GPIB.Write "SENSe1:SWEep:TRIGger:POINt OFF"

  ' Set channel parameters
  GPIB.Write "SENSe1:SWEep:POINts 11"
  GPIB.Write "SENSe1:FREQuency:STARt 1000000000"
  GPIB.Write "SENSe1:FREQuency:STOP 2000000000"

  ' Send a trigger to initiate a single sweep
  GPIB.Write "INITiate1;*OPC?"
  opc = GPIB.Read

  ' Must select the measurement before we can read the data
  GPIB.Write "CALCulate1:PARameter:SELect 'My_S11'"

  ' Read the measurement data into the "result" string variable
  GPIB.Write "FORMat ASCII"
  GPIB.Write "CALCulate1:DATA? FDATA"
  result = GPIB.Read

  ' Display the result
  GPIB.Write "SENSe1:SWEep:POINts?"
  num_points = GPIB.Read
  For i = 0 To num_points - 2
  commaPosition = InStr(result, ",")
  message = message & Left(result, commaPosition - 1) & vbCrLf
  result = Right(result, Len(result) - commaPosition)
  Next
  message = message & result

  MsgBox message, vbOKOnly, "S11(dB) - VB SCPI Example for PNA"

End Sub
Private Sub cmdExit_Click()
  End
End Sub


COM versus SCPI

There are two methods you can use to remotely control the analyzer: COM and SCPI. The following topics are intended to help you choose the method that best meets your needs:

Software Connection

Physical Connection

Selecting a Method

Programming Languages

Software Connection

COM uses a binary protocol, allowing the user to directly invoke a feature of the Network Analyzer. This is more efficient than SCPI. For example, the following statement calls directly into the Network Analyzer, executing the routine GetIDString.

PNA.GetIDString()

SCPI is a text based instrument language. To retrieve the ID string, you would send the following text string to the network analyzer:

IbWrite( "*IDN?")

The network analyzer's SCPI parser would first decode this text string to determine that the user has asked for the network analyzer to identify itself. Then the parser would call GetIDString().

The Physical Connection

Internal Control

With either COM or SCPI, the best throughput is attained by using the analyzer's internal PC to execute your test code. However, if your test code uses too much system resources (CPU cycles and/or memory), this will slow the Analyzer's performance.

Using the SICL I/O Libraries, you can also connect to the Analyzer from a program running on the Analyzer.

External Control

You can control the analyzer from a remote PC using either COM or SCPI.

COM - (Component Object Model) can be used to access any program like the analyzer (835x.exe) or library (.dll) that exposes its features using a COM compliant object model. These programs or libraries are called "servers". Programs (like your remote program on your PC) that connect to and use the features of these servers are called "clients."

With COM, the server and the client do not need to reside on the same machine. DCOM, or distributed COM, is easy to configure and makes the location of the server transparent to the client. When you access the Analyzer from a remote computer, you are using DCOM. In this case, the mechanical transport is a LAN (local area network).

SCPI - Using a GPIB interface card in a remote computer, you can connect to the instrument using a GPIB cable. There are some constraints on the length of this cable and the number of instruments that can be daisy-chained together.

Using the Agilent SICL I/O libraries, you can connect to the instrument over a LAN connection.

(LAN or INTERNAL) You can send SCPI commands using COM with an object called the ScpiStringParser. This object provides access to the SCPI parser (or command decoder) so that you can send SCPI text commands using automation.

Selecting a Method

You should almost always choose COM for the following reasons:

  • COM executes faster most of the time.

  • COM is generally easier to use. The latest development tools embrace COM and know how to make your life easier with integrated development environments that show automation syntax as you type.

  • As time goes on, more emphasis will be put on the COM as the preferred programming paradigm. As new capability is developed, it may not be made available through SCPI.

But choosing a connection method depends on your situation. Here are some additional things to consider:

  1. If you want to use the Analyzer to control other GPIB instruments, you may want to use COM as the means of talking to the instrument. In GPIB, the analyzer can not be configured as both System Controller and talker/listener. Because the Analyzer does not support pass control mode, only one mode can be used at a time.

  2. If you have legacy code written in SCPI for another network analyzer, you may be able to leverage that code to control to the Analyzer. A word of warning: the PNA uses a different platform than previous Agilent Network Analyzers. Therefore, not all commands have a direct replacement. See the 8753 command finder.

Programming Languages

You can program the Analyzer with either COM or SCPI using several languages. The most common include:

Agilent VEE - With this language you can send text based SCPI commands and also use automation. VEE 6.0 or later is recommended.

Visual Basic - This language has great support for automation objects and can be used to drive SCPI commands. The use of VISA drivers for your GPIB hardware interface will make the task of sending SCPI commands easier.

C++ - This language can do it all. It is not as easy to use as the above two, but more flexible.


Accessing Data Descriptions

Click a box to view process details:

Raw Measurement Data - Complex trace data which is ratioed if required by the parameter, such as S11 or A/B. Otherwise it is raw receiver data, such as A or B. This data is averaged if Averaging is ON. See Measurement Parameters

Standard Acquisition Data - Raw Complex Data resulting from measuring calibration standards or recalling a calibration. See Measurement Calibration.

Error Term Data - Data that is calculated from Acquisition data using formulas which are appropriate for the selected calibration method.

Error Correction - Error terms are applied to the raw measurement data if error correction is ON. Otherwise this data is identical to Raw Measurement Data.

Trace Math - If turned ON, memory data is combined with measurement data using the selected math function. Available functions are: Data+Mem, Data-Mem, Data*Mem, and Data/Mem. See Math Operations.

Memory Data - Complex trace data resulting from a Data-To-Memory operation. Each measurement can have one memory trace. The memory data parallels the measurement data through the remaining post processing blocks. For example, turning smoothing ON will smooth both the measurement and memory traces.

Gating - If turned ON, Filter Gating is applied to the measurement data. The gates are used to select regions of the trace where a subsequent transform will be applied. See Gating.

Phase Correction - If turned ON, applies electrical delay, phase offset, and port extensions. These are all separate features that are controlled individually. See Phase Measurement Accuracy.

Time Domain - If turned ON, transforms the data from the frequency domain to the time domain. See Time Domain

Formatter - Complex data is converted into scalar data formats for screen display and remote access. For smoothed data, request the data in the same format as the displayed data. See Data Format

Memory Result Data- Memory data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Measurement Result Data - Measurement data is formatted and available for remote access from access point 1. To get smoothed data, request the data in the same format as the displayed data. The data will then come from access point 2.

Smoother - If turned ON, removes discontinuities in the measurement and memory trace. See Smoothing.

Display - Displays the processed measurement and / or memory data in the format of your choice. If remotely requested data is the same format as the displayed data, the requested data comes from this buffer.


Spezifikationen

Siehe auch....

Dies sind die vollständigen Spezifikationen der Netzwerkanalysator-Familie Agilent PNA. Über dieses Link gelangen Sie zu einer druckbaren PDF- (Portable Document File) -Version dieses Dokuments.

Durch Anklicken der Schaltfläche gelangen Sie zu den aufgelisteten Informationen.

Definitionen

Korrigierte Systemgenauigkeit

Dynamikbereich

Type-N-Steckverbinder

3,5 mm-Steckverbinder

Nicht-korrigierte Systemgenauigkeit

Messanschlussausgang (Quelle)

Messanschlusseingang und Empfängereingang

Allgemeine Informationen

Messdurchsatz

Definitionen

Alle Spezifikationen und Charakteristiken gelten bei einer Temperatur von 25°C ±5°C (sofern nicht ausdrücklich anders vermerkt) und nach 90-minütigem Warmlaufen.

Spezifikationen (Spez.): Dies sind Produkteigenschaften, die von Agilent Technologies garantiert werden. Spezifikationen beinhalten Toleranzbereiche, die den zu erwartenden statistischen Performance-Schwankungen, Messunsicherheiten bei der Werkskalibrierung sowie Performance-Änderungen infolge von veränderlichen Umgebungsbedingungen Rechnung tragen.

Charakteristiken (Char.): Dies sind Leistungsmerkmale, die das Produkt beim Verlassen des Werkes normalerweise aufweist. Diese Leistungsmerkmale werden jedoch nicht serienmäßig verifiziert und nicht garantiert. Auch zu den Charakteristiken werden, wie zu den Spezifikationen, Toleranzbereiche angegeben.

Typische Daten (typ.): Dies sind statistische Mittelwerte, zu denen keine Toleranzbereiche angegeben werden. Diese Werte werden nicht garantiert.

Nennwerte (Nennw.): Dies sind allgemeine, informative Angaben, die keine Leistungsmerkmale darstellen. Diese Werte werden nicht garantiert.

Kalibrierung: Dies ist ein Prozess, bei dem die systematischen (reproduzierbaren) Messfehler des Netzwerkanalysators mit Hilfe von Referenzmessungen an Kalibriernormalen charakterisiert werden.

Korrigierte Genauigkeit (korr.): Die ist die Genauigkeit nach F ehlerkorrektur (Kalibrierung). Die korrigierte Genauigkeit ist von der Qualität der verwendeten Kalibriernormale abhängig und davon, wie genau die Eigenschaften der Kalibriernormale bekannt sind, außerdem von Systemreproduzierbarkeit, -stabilität und -rauschen.

Nicht-korrigierte Genauigkeit (nicht-korr.): Dies ist die ohne Fehlerkorrektur erzielte Messgenauigkeit. Die nicht-korrigierte Genauigkeit beeinflusst die Stabilität der Kalibrierung.

Standard(ausführung): In Bezug auf den Analysator schließt dies alle Optionen ein, sofern nicht ausdrücklich anders vermerkt.

Korrigierte Systemgenauigkeit

Die Spezifikationen in diesem Abschnitt gelten für Messungen mit einem Netzwerkanalysator der Familie Agilent PNA unter folgenden Bedingungen:

  • 10 Hz ZF-Bandbreite

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur max. 1°C

  • Isolationskalibrierung nicht ausgelassen

Systemdynamikbereich

Type-N-Steckverbinder

3,5 mm-Steckverbinder

Tabelle 1. Systemdynamikbereich

Beschreibung | Spezifikation (dB) | Charakteristik (dB)
Dynamikbereicha (am Messanschluss)
300 kHz bis 25 MHzb | 125 |
25 MHz bis 3 GHzb | 128 |
3 GHz bis 6 GHz | 118 |
6 GHz bis 9 GHz | 113 |
Dynamikbereichc (am Empfängereingang)
300 kHz bis 25 MHzd |  | 140
25 MHz bis 3 GHzd |  | 143
3 GHz bis 6 GHz |  | 133
6 GHz bis 9 GHz |  | 128

a Der Dynamikbereich am Messanschluss berechnet sich als Differenz zwischen der effektiven Rauschleistung am Messanschluss und der maximalen Signalquellenausgangsleistung. Bei der Abschätzung des effektiven Dynamikbereichs müssen Messunsicherheiten und Störsignale berücksichtigt werden.
b Kann infolge von Empfänger-Nebenwellen bei bestimmten Frequenzen unterhalb 750 MHz auf 100 dB begrenzt sein.
c Der Dynamikbereich am Empfängereingang berechnet sich als Differenz zwischen der effektiven Rauschleistung am Empfängereingang und der maximalen Signalquellenausgangsleistung. Bei der Abschätzung des effektiven Dynamikbereichs müssen Messunsicherheiten und Störsignale berücksichtigt werden. Diese Einstellung sollte nur verwendet werden, wenn gewährleistet ist, dass der maximal zulässige Empfängereingangspegel niemals überschritten wird. In der Betriebsart Segmentwobbelung kann für solche Frequenzsegmente, in denen das Messobjekt eine hohe Einfügedämpfung aufweist (und ein großer Dynamikbereich erforderlich ist) ein höherer Messsignalpegel verwendet werden, und für solche Segmente, in denen das Messobjekt eine geringe Einfügedämpfung aufweist (und der Empfängereingang überlastungsgefährdet ist) ein niedrigerer Messsignalpegel.
d Kann infolge von Empfänger-Nebenwellen bei bestimmten Frequenzen unterhalb 750 MHz auf 115 dB begrenzt sein.

Korrigierte Systemgenauigkeit bei Analysatoren mit Type-N-Steckverbindern

Kalibrier-Kit 85032F

Option 015 mit Kalibrier-Kit 85032F

Kalibrier-Kit 85092B

Option 015 mit Kalibrier-Kit 85092B

Tabelle 2. Korrigierte Systemgenauigkeit bei Analysatoren mit Type-N-Steckverbindern, Kalibrier-Kit 85032F

Gilt für Netzwerkanalysatoren der Familie PNA, Kalibrier-Kit 85032F (Type-N, 50 W), Messkabel N6314A und vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHz
R ichtverhältnis | 49 | 46 | 40 | 38
Quellenanpassung | 41 | 40 | 36 | 35
L astanpassung | 49 | 46 | 40 | 38
Reflexions-Frequenzgang-Gleichlauf | ±0,011 | ±0,021 | ±0,032 | ±0,054
Transmissions-Frequenzgang-Gleichlauf | ±0,011 | ±0,018 | ±0,040 | ±0,049

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 3. Korrigierte Systemgenauigkeit, Type-N Steckverbinder, Option 015, Kalibrier-Kit 85032F

Gilt für Netzwerkanalysatoren der Familie PNA mit Option 015,Kalibrier-Kit 85032F (Type-N, 50 W), Messkabel N6314A und vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHz
Richtverhältnis | 49 | 46 | 40 | 38
Quellenanpassung | 41 | 40 | 36 | 35
Lastanpassung | 49 | 46 | 40 | 38
Reflexions-Frequenzgang-Gleichlauf | ±0,011 | ±0,021 | ±0,032 | ±0,054
Transmissions-Frequenzgang-Gleichlauf | ±0,011 | ±0,023 | ±0,050 | ±0,062

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 4. Korrigierte Systemgenauigkeit, Type-N Steckverbinder, ECal-Modul 85092B

Gilt für Netzwerkanalysatoren der Familie PNA, ECal-Modul 85092B (Type-N, 50 W), Messkabel N6314A und vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHza
Richtverhältnis | 52 | 54 | 52 | 47
Quellenanpassung | 45 | 44 | 41 | 34
Lastanpassung | 47 | 47 | 44 | 44
Reflexions-Frequenzgang-Gleichlauf | ±0,037 | ±0,037 | ±0,068 | ±0,100
Transmissions-Frequenzgang-Gleichlauf | ±0,060 | ±0,055 | ±0,13 | ±0,23
Typischer Transmissions-Frequenzgang-Gleichlauffehler | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Die Spezifikation gilt für 28% Luftfeuchtigkeit. Höhere Luftfeuchtigkeitswerte können die Genauigkeit negativ beeinflussen.

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 5. Korrigierte Systemgenauigkeit, Type-N Steckverbinder, Option 015, ECal-Modul 85092B

Gilt für Netzwerkanalysatoren der Familie PNA mit Option 015, ECal-Modul 85092B (Type-N, 50 W), Messkabel N6314A, vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHza
Richtverhältnis | 52 | 54 | 52 | 47
Quellenanpassung | 45 | 44 | 41 | 34
Lastanpassung | 47 | 47 | 44 | 39
Reflexions-Frequenzgang-Gleichlauf | ±0,037 | ±0,037 | ±0,068 | ±0,100
Transmissions-Frequenzgang-Gleichlauf | ±0,060 | ±0,055 | ±0,13 | ±0,23
Typischer Transmissions-Frequenzgang-Gleichlauffehler | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Die Spezifikation gilt für 28% Luftfeuchtigkeit. Höhere Luftfeuchtigkeitswerte können die Genauigkeit negativ beeinflussen.

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Korrigierte Systemgenauigkeit von Analysatoren mit 3,5 mm-Steckverbindern

Kalibrier-Kit 85033E

Option 015 mit Kalibrier-Kit 85033E

Kalibrier-Kit 85093B

Option 015 mit Kalibrier-Kit 85093B

Tabelle 6. Korrigierte Systemgenauigkeit von Analysatoren mit 3,5 mm-Steckverbindern, Kalibrier-Kit 85033E

Gilt für Netzwerkanalysatoren der Familie PNA, Kalibrier-Kit 85033E (3,5 mm, 50 W), Messkabel N6314A, vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHz
Richtverhältnis | 46 | 44 | 38 | 38
Quellenanpassung | 43 | 40 | 37 | 36
Lastanpassung | 46 | 44 | 38 | 38
Reflexions-Frequenzgang-Gleichlauf | ±0,006 | ±0,007 | ±0,009 | ±0,010
Transmissions-Frequenzgang-Gleichlauf | ±0,010 | ±0,020 | ±0,041 | ±0,046

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 7. Korrigierte Systemgenauigkeit, 3,5 mm-Steckverbinder, Option 015, Kalibrier-Kit 85033E

Gilt für Netzwerkanalysatoren der Familie PNA mit Option 015, Kalibrier-Kit 85033E (3,5 mm, 50 W), Messkabel N6314A, vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHz
Richtverhältnis | 46 | 44 | 38 | 38
Quellenanpassung | 43 | 40 | 37 | 36
Lastanpassung | 46 | 44 | 38 | 38
Reflexions-Frequenzgang-Gleichlauf | ±0,006 | ±0,007 | ±0,009 | ±0,010
Transmissions-Frequenzgang-Gleichlauf | ±0,010 | ±0,025 | ±0,052 | ±0,058

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 8. Korrigierte Systemgenauigkeit von Analysatoren mit 3,5 mm-Steckverbinder, ECal-Modul 85093B

Gilt für Netzwerkanalysatoren der Familie PNA, ECal-Modul 85093B (3,5 mm, 50 W), Messkabel N6314A, vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHza
Richtverhältnis | 50 | 52 | 51 | 45
Quellenanpassung | 45 | 43 | 40 | 34
Lastanpassung | 47 | 47 | 44 | 39
Reflexions-Frequenzgang-Gleichlauf | ±0,043 | ±0,043 | ±0,055 | ±0,100
Transmissions-Frequenzgang-Gleichlauf | ±0,050 | ±0,045 | ±0,13 | ±0,23
Typischer Transmissions-Frequenzgang-Gleichlauffehler | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Die Spezifikation gilt für 28% Luftfeuchtigkeit. Höhere Luftfeuchtigkeitswerte können die Genauigkeit negativ beeinflussen.

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 9. Korrigierte Systemgenauigkeit von Analysatoren mit 3,5 mm-Steckverbindern, Option 015, ECal-Modul 85093B

Gilt für Netzwerkanalysatoren der Familie PNA mit Option 015, ECal-Modul , 85093B (3,5 mm, 50 W), Messkabel N6314A, vollständige 2-Port-Kalibrierung. Gilt außerdem unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Keine Messdatenmittelung

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

  • Isolationskalibrierung nicht ausgelassen
Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHza
R ichtverhältnis | 50 | 52 | 51 | 45
Quellenanpassung | 45 | 43 | 40 | 34
L astanpassung | 47 | 47 | 44 | 39
Reflexions-Frequenzgang-Gleichlauf | ±0,043 | ±0,043 | ±0,055 | ±0,100
Transmissions-Frequenzgang-Gleichlauf | ±0,050 | ±0,045 | ±0,13 | ±0,23
Typischer Transmissions-Frequenzgang-Gleichlauffehler | ±0,028 | ±0,045 | ±0,08 | ±0,105

a Die Spezifikation gilt für 28% Luftfeuchtigkeit. Höhere Luftfeuchtigkeitswerte können die Genauigkeit negativ beeinflussen.

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Transmissions-Messunsicherheit (Spezifikation)

Reflexions-Messunsicherheit (Spezifikation)

Tabelle 10. Nicht-korrigierte Systemgenauigkeit

Beschreibung | Spezifikation (dB)
 | 300 kHz bis 1 MHz | 1 MHz bis 1,3 GHz | 1,3 GHz bis 3 GHz | 3 GHz bis 6 GHz | 6 GHz bis 9 GHz
Richtverhältnis | 30 | 33 | 27 | 20 | 13
Quellenanpassung | 20 | 20 | 17 | 15 | 14
Quellenanpassung (Opt. 015) | 20 | 20 | 15 | 13 | 12
Lastanpassung | 20 | 20 | 17 | 15 | 15
Lastanpassung (Opt. 015) | 20 | 20 | 15 | 13 | 13
Reflexions-Frequenzgang-Gleichlauf | ±1,5 | ±1,5 | ±1,5 | ±2,5 | ±3,0
Transmissions-Frequenzgang-Gleichlauf | ±1,5 | ±1,5 | ±1,5 | ±2,5 | ±3,0

Messanschlussausgang (Quelle)

Ausgangsfrequenz

Ausgangspegel

Ausgangssignal-Reinheit

Tabelle 11. Messanschlussausgang-Frequenz

Beschreibung | Spezifikation | Ergänzende Informationen
Bereich E8356A E8357A E8358A Auflösung | 300 kHz bis 3,0 GHz 300 kHz bis 6,0 GHz 300 kHz bis 9,0 GHz 1 Hz |
Quellenstabilität |  | ±1 ppm, 0° bis 40 °C (typ.) ±0,2 ppm/Jahr (typ.)
CW-Genauigkeit | ±1 ppm |

Tabelle 12. Messanschlussausgang-Pegela

Beschreibung | Spezifikation | Ergänzende Informationen
Pegelgenauigkeit 300 kHz bis 6 GHz 6 GHz bis 9 GHz | ±1,0 dB ±2,0 dB | Abweichung von 0 dBm in Pegelbereich 0 (Stufenabschwächer-Einstellung 0 dB) ±1,5 dB unterhalb 10 MHz
Pegellinearität 300 kHz bis 9 GHz 300 kHz bis 1 MHz 1 MHz bis 6 GHz | ±0,3 dB ±1,0 dB ±0,5 dB | Abweichung von 0 dBm in Pegelbereich 0 -15 bis +5 dBm +5 bis +10 dBm +5 bis +10 dBm
Bereichb 300 kHz bis 6 GHz 6 GHz bis 9 GHz | 85 bis +10 dBm 85 bis +5 dBm |
Wobbelbereich 300 kHz bis 6 GHz 6 GHz bis 9 GHz | 25 dB 20 dB |
Pegelauflösung | 0,01 dB |

a Die Messanschlussausgang-Spezifikationen gelten nur für Port 1. Für Port 2 gelten diese Daten als Charakteristiken.

b Pegel, auf den die Signalquelle eingestellt werden kann und bei dem die PLL-Synchronisation gewährleistet ist.

Tabelle 13. Messsignalreinheit

Beschreibung | Spezifikation | Ergänzende Informationen
Oberwellen (2. oder 3. Ordnung) bei maximalem Ausgangspegel bei 0 dBm Ausgangspegel bei 10 dBm Ausgangspegel |  | < 25 dBc, charakteristischa < 35 dBc, typisch, im Pegelbereich 0 < 38 dBc, typisch, im Pegelbereich 0 (Stufenabschwächer-Einstellung 0 dB)
Nicht-harmonische Nebenwellen bei maximalem Ausgangspegel bei 10 dBm Ausgangspegel |  | 30 dBc, typisch für Frequenzoffset >1kHz 50 dBc, typisch für Frequenzoffset >1kHz

a Typisch unterhalb 25 MHz.

Messanschluss- und Empfängereingang-Charakteristiken

Eingangspegel

Rauschpegel

Messkurvenrauschen

Referenzpegel und Stabilität

Dynamische Genauigkeit

Gruppenlaufzeit

Tabelle 1 4. Messanschluss-Eingangspegel

Beschreibung | Spezifikation | Ergänzende Informationen
Übersteuerungsgrenze
300 kHz bis 25 MHz 25 MHz bis 3 GHz 3 GHz bis 6 GHz 6 GHz bis 9 GHz | +10 dBm +10 dBm +10 dBm +5 dBm | <0,6 dB Kompression <0,4 dB Kompression <0,7 dB Kompression <0,7 dB Kompression
Maximal zulässiger Eingangspegel
Port 1, 2 R1, R2 IN A, B IN (Standard) A, B IN (Opt. 015) Coupler IN (Opt. 015) |  | +30 dBm oder ±30 VDC, typ. +15 dBm oder ±15 VDC, typ. +15 dBm oder ±15 VDC, typ. +15 dBm oder ±0 VDC, typ. +36 dBm oder ±25 VDC, typ.
Messanschluss-Rauschpegela
300 kHz bis 25 MHzb 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite | £ 115 dBm £ 95 dBm |
25 MHz bis 3 GHzb 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite | £ 118 dBm £ 98 dBm |
3 GHz bis 9 GHz 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite | £ 108 dBm £ 88 dBm |
Empfänger-Rauschpegela
300 kHz bis 25 MHzc 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite |  | £ 130 dBm, charakteristisch £ 110 dBm, charakteristisch
25 MHz bis 3 GHzc 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite |  | £ 133 dBm, charakteristisch £ 113 dBm, charakteristisch
6 GHz bis 9 GHz 10 Hz ZF-Bandbreite 1 kHz ZF-Bandbreite |  | £ 123 dBm, charakteristisch £ 103 dBm, charakteristisch
Übersprechen
300 kHz bis 1 MHz 1 MHz bis 25 MHz 25 MHz bis 3 GHz 3 GHz bis 6 GHz 6 GHz bis 9 GHz | <120 dB <125 dB <128 dB <118 dB <113 dB | Zwischen den Ports 1 und 2, beide Ports kurzgeschlossen;
Maximal zulässiger Empfängereingangspegel (A, B, R1, R2)
300 kHz bis 6 GHz 6 GHz bis 9 GHz |  | 6 dBm, typisch 11 dBm, typisch
Referenzeingangspegel (R1, R2)d
300 kHz bis 9 GHz |  | 10 bis 35 dBm, typisch
Maximal zulässiger Kopplereingangspegel (Opt 015)
300 kHz bis 9 GHz |  | +33 dBm, typisch

a Effektivwert einer linear skalierten Amplitudenmesskurve, ausgedrückt in dBm.

b Kann infolge von Empfänger-Nebenwellen bei bestimmten Frequenzen unterhalb 750 MHz auf -90 dBm begrenzt sein.

c Kann infolge von Empfänger-Nebenwellen bei bestimmten Frequenzen unterhalb 750 MHz auf -105 dBm begrenzt sein.

d Zur Aufrechterhaltung der PLL-Synchronisation erforderlicher Eingangspegel.

Tabelle 1 5. Messanschlusseingang (Messkurvenrauschen)

Beschreibung | Spezifikation | Ergänzende Informationen
Messkurvenrauschena Amplitude
1 kHz ZF-Bandbreite 10 kHz ZF-Bandbreite | <0,002 dB eff. < 0,005 dB eff. |
Messkurvenrauschena Phase
1 kHz ZF-Bandbreite 10 kHz ZF-Bandbreite | < 0,010° eff. < 0,035° eff. |

a Das Messkurvenrauschen ist definiert als eine Verhältnismessung eines Durchgangs oder einer Totalreflexion mit einem Messsignalpegel von 0 dBm.

Tabelle 1 6. Messanschluss-Eingangspegel (Referenzpegel und Stabilität)

Beschreibung | Spezifikation | Ergänzende Informationen
Referenzpegel (Amplitude)
Bereich Auflösung | ±200 dB 0,001 dB |
Referenzpegel (Phase)
Bereich Auflösung | ±500° 0,01° |
Stabilität (Amplitude) a
300 kHz bis 3 GHz 3 GHz bis 6 GHz 6 GHz bis 9 GHz |  | 0,02 dB/°C, typisch 0,04 dB/°C, typisch 0,06 dB/°C, typical
Stabilität (Phase) a
300 kHz bis 3 GHz 3 GHz bis 6 GHz 6 GHz bis 9 GHz |  | 0,2°/°C, typisch 0,3°/°C, typisch 0,6°/°C, typisch

a Die Stabilität ist definiert als eine Verhältnismessung am Messanschluss.

Tabelle 1 7. Messanschlusseingang (dynamische Genauigkeit)

Die Genauigkeit des Messwertes für den Messanschluss-Eingangspegel ist auf den Signalpegel am Referenzeingang bezogen. Gilt für die Eingangsports 1 und 2 unter folgenden Bedingungen:

  • ZF-Bandbreite = 10 Hz

  • Umgebungstemperatur 25°C ±5°C, Abweichung von der Kalibriertemperatur < 1°C

Klicken Sie auf ein Diagramm, um es zu vergrößern.

Spezifikation 300 kHz bis 3 GHz | Charakteristik 300 kHz bis 3 GHz
300 kHz bis 6 GHz | 300 kHz bis 6 GHz
300 kHz bis 9 GHz | 300 kHz bis 9 GHz

Tabelle 1 8. Messanschluss-Eingang (Gruppenlaufzeit)a

Beschreibung

Spezifikation

Ergänzende Informationen

A pertur (wählbar)

(Wobbelbandbreite)/(Anzahl der Messpunkte 1)

Maximale Apertur

20% der Wobbelbandbreite

Bereich

0,5 x (1/minimale Apertur)

Maximale Gruppenlaufzeit

Dadurch begrenzt, dass innerhalb der minimalen Apertur keine Phasenverschiebungen von mehr als 180° gemessen werden können.)

Genauigkeit

Siehe folgendes Diagramm. Char.

Das folgende Diagramm zeigt die Gruppenlaufzeitgenauigkeit eines Analysators mit Type-N-Steckverbindern nach vollständiger 2-Port Kalibrierung bei 10 Hz ZF-Bandbreite. Es wird eine Einfügedämpfung von < 2 dB und eine elektrische Länge von zehn Metern vorausgesetzt.

Klicken Sie auf das Diagramm, um es zu vergrößern.

Ganz allgemein lässt sich die Genauigkeit (in Sekunden) einer bestimmten Gruppenlaufzeitmessung nach folgender Formel bestimmen:

±Phasengenauigkeit (Grad)/[360 × Apertur (Hz)]

Je nach Apertur und elektrischer Länge wird entweder die inkrementelle Phasengenauigkeit oder die "Worst-Case"-Phasengenauigkeit verwendet.

a Die Gruppenlaufzeit wird berechnet, indem die Phasenänderung innerhalb eines bestimmten Frequenzbandes durch die Breite dieses Frequenzbandes dividiert wird. Die Breite des Frequenzbandes ist von der Wobbelbandbreite und der Anzahl der Messpunkte abhängig.

Allgemeine Informationen

Systembandbreiten

Frontplatte

Rückwand

Umgebungsbedingungen und Abmessungen

Tabelle 1 9. Systembandbreiten

Beschreibung | Spezifikation | Ergänzende Informationen
ZF-Bandbreite-Einstellungen
Bereich |  | 1 Hz bis 40 kHz Einstellbare nominelle Werte: 1, 2, 3, 5, 7,10, 15, 20, 30, 50, 70, 100, 150, 200, 300, 500, 700 Hz 1k, 1,5k, 2k 3k, 5k, 7k, 10k, 15k, 20k, 30k, 50k, 35k, 40kHz

Tabelle 20. Informationen zur Frontplatte

Beschreibung | Ergänzende Informationen
HF-Anschlüsse
Typ | Type-N, weiblich; 50 W (Nennwert)
Mittelleiter-Pin-Überstand | 5,18 mm bis 5,26 mm (0,204 bis 0,207 in.), charakteristisch
Tastkopf-Betriebsspannungsanschluss
Steckverbinder | 3-polig, männlich
Positive Betriebsspannung | +15 VDC ±2%, max. 400 mA, charakteristisch
Negative Betriebsspannung | 12,6 VDC ±2%, max. 300 mA, charakteristisch
Bildschirm
Abmessungen | Aktiv-Matrix-Farb-LCD mit 21,3 cm (8,4 in) Diagonale; Auflösung 640 (horizontal) X 480 (vertikal)
Wiederholrate | Vertikal 59,83 Hz; horizontal 31,41 Hz
Darstellungsbereich
Amplitudenbetrag | max. ±200 dB (bei 20 dB/div)
Phase | max. ±180°
Polar | min. 10 pUnits max. 1000 Units
Bildschirmauflösung
Amplitudenbetrag | min. 0,001 dB/div
Phase | min. 0,01°/div
Marker-Auflösung
Amplitudenbetrag | min. 0,001 dB
Phase | min. 0,01°
Polar | min. 0,01 mUnit, min. 0,01°

Tabelle 21. Informationen zur Rückwand

Beschreibung | Ergänzende Informationen
DC-Bias-Eingang für Messanschlüsse
Steckverbinder | BNC, weiblich
Maximale Spannung | ±30 VDC (typ.)
Maximale Stromstärke (ohne Verschlechterung der HF-Spezifikationen) | ±200 mA (typ.)
Maximale Stromstärke | ±1 A (typ.)
10 MHz Reference In
Steckverbinder | BNC, weiblich
Eingangsfrequenz | 10 MHz ± 1 ppm (typ.)
Eingangspegel | 15 dBm bis +20 dBm (typ.)
Eingangsi mpedanz | 200 W (Nennwert)
10 MHz Reference Out
Steckverbinder | BNC, weiblich
Ausgangsfrequenz | 10 MHz ± 1 ppm (typ.)
Signalform | Sinus (typ.)
Ausgangssignalpegel | +10 dBm ± 4 dB an 50 W (typ.)
Ausgangsimpedanz | 50 W (Nennwert)
Oberwellenabstand | <40 dBc (typ.)
VGA Video Output
Steckverbinder | Mini D-Sub 15-polig; zur Ansteuerung eines VGA-Bildschirms vorgesehen
Unterstützte Bildschirme Flachbildschirm (TFT) Flachbildschirm (DSTN) Röhrenbildschirm | Auflösungen 1024 X 768, 800 X 600, 640 X 480 800 X600, 640 X 480 1280 X 1024, 1024 X 768, 800 X 600, 640 X 480 Der gleichzeitige Betrieb des internen und eines externen Bildschirms ist möglich, jedoch nur bei einer Auflösung von 640 X 480. Wenn Sie eine andere Auflösung wählen, wird der interne Bildschirm abgeschaltet.
GPIB | D-sub 24-polig (Type D-24), weiblich; IEEE-488-konform
Parallelschnittstelle (LPT1) | D-sub 36-polig (Type 1284-C), weiblich; für den Anschluss eines Druckers oder sonstigen Peripheriegerätes mit Parallelschnittstelle vorgesehen
Serielle Schnittstelle (COM 1) | D-sub 9-polig, männlich; RS-232-konform
USB-Schnittstelle
Kontakt 1 Kontakt 2 Kontakt 3 Kontakt 4 | USB- (Universal Serial Bus) Schnittstelle in der "Type A"-Konfiguration (4 Kontakte in einer Reihe; Kontakt 1 auf der linken Seite, weiblicher Steckverbinder) Vcc: 4,75 bis 5,25 VDC, max. 500 mA -Daten +Daten Masse
LAN-Schnittstelle | 10/100BaseT Ethernet, 8-polige Konfiguration; automatische Wahl zwischen den beiden Datenraten
Netzanschlussa
Frequenz | 48 Hz bis 66 Hz
Netzspannungsbereich in der 115 V-Einstellung | 90 bis 132 VAC; 120 VAC (Nennwerte)
Netzspannungsbereich in der 220 V-Einstellung | 198 bis 264 VAC; 240 VAC (Nennwerte)
Leistungsaufnahme | max. 600 VA

a Schutzleiteranschluss erforderlich.

Tabelle 22. Informationen zur Rückwand

Beschreibung | Ergänzende Informationen
External AM Input
Beschreibung | Dieser Eingang ermöglicht es, das Messanschluss-Ausgangssignal mit einem externen NF-Signal zu amplitudenmodulieren oder den Messsignalpegel zwischen zwei Werten umzuschalten. Eine Eingangsspannung von 0 V ergibt den am Analysator eingestellten Messsignalpegel; eine positive Spannung ergibt einen höheren Pegel, eine negative Spannung einen niedrigeren Pegel.
Steckverbinder | BNC, weiblich
Eingangsempfindlichkeit | 8 dB/Volt (typ.)
Bandbreite | 1 kHz (typ.)
Eingangsimpedanz | 1 kW (typ.)
External Detector Input
Beschreibung | Über diesen Eingang kann der Messsignalpegel durch ein externes Diodendetektorsignal (mit negativer Polarität) gesteuert werden. Auf diese Weise kann eine externe Pegelregelung realisiert werden.
Steckverbinder | BNC, weiblich
Eingangsempfindlichkeit | Eine Eingangsspannung von 500 mV ergibt einen Messsignalpegel von etwa 3 dBm (typ.)
Bandbreite | 50 kHz (typ.)
Eingangsimpedanz | 1 kW (typ.)
External Trigger
 | Siehe Trigger

Tabelle 2 3. Betriebsumgebung und Abmessungen

Beschreibung | Ergänzende Informationen
Umgebung allgemein
Elektromagnetische Verträglichkeit – Einstrahlfestigkeit | Gemäß CISPR Pub. 11, Group 1, Class A, und IEC 50082-1
Elektrostatische Entladung | Minimieren Sie das Risiko elektrostatischer Entladungen, indem Sie eine Antistatik-Tischmatte verwenden und die allgemein bekannten Regeln zur Vorbeugung gegen statische Elektrizität beachten.
Staub | Halten Sie das Gerät möglichst staubfrei, um optimale Zuverlässigkeit zu gewährleisten.
Betriebsumgebung
Temperatur | 0°C bis +40°C Innerhalb dieses Temperaturbereichs lässt sich das Gerät normal in Betrieb nehmen; korrekte PLL-Synchronisation ist gewährleistet, und es werden keine Fehlermeldungen angezeigt.
Fehlerkorrigierter Temperaturbereich | 25°C ± 5°C bei weniger als 1°C Abweichung von der Kalibriertemperatur
Luftfeuchtigkeit | 5% bis 95% bei +40°C
Höhe | 0 bis 4500 m (14.760 ft.)
Umgebungsbedingungen für Lagerung und Versand
Temperatur | -40°C bis +70°C
Luftfeuchtigkeit | 0% bis 90% bei +65°C (nicht kondensierend)
Höhe | 0 bis 15.240 m (50.000 ft.)
Gehäuseabmessungen
Höhe x Breite x Tiefe | 222 x 425 x 426 mm (8,75 x 16,75 x 16,8 in) (Nennwerte); die genannten Werte schließen nicht die aus der Frontplatte und Rückwand herausragenden Bauteile ein.
Gewicht
Netto | 24 kg (54 lb) (Nennwert)
Einschließlich Verpackung | 32 kg (70 lb) (Nennwert)

Messdurchsatz

Typische Wobbelzyklusdauer

Wobbelzyklusdauer in Abhängigkeit von der ZF-Bandbreite

Wobbelzyklusdauer in Abhängigkeit von der Anzahl der Messpunkte

Datenübertragungsdauer

Geschwindigkeit für "Recall"-Operation und Wobbelung

Tabelle 2 4. Typische Wobbelzyklusdauer a,b (ms)

 | Anzahl der Messpunkte
 | 51 | 201 | 401 | 1601
Start 800 MHz, Stop 1000 MHz, 35 kHz ZF-Bandbreite
Nicht-korrigiert, 1-Port-Kalibrierung | 6 | 10 | 17 | 53
2-Port-Kalibrierung | 18 | 27 | 39 | 113
Start 300 kHz, Stop 3 GHz, 35 kHz ZF-Bandbreite
Nicht-korrigiert, 1-Port-Kalibrierung | 32 | 43 | 52 | 93
2-Port-Kalibrierung | 73 | 97 | 117 | 201
Start 300 kHz, Stop 6 GHz, 35 kHz ZF-Bandbreite
Nicht-korrigiert, 1-Port-Kalibrierung | 40 | 50 | 57 | 98
2-Port-Kalibrierung | 88 | 109 | 125 | 210
Start 300 kHz, Stop 9 GHz, 35 kHz ZF-Bandbreite
Nicht-korrigiert, 1-Port-Kalibrierung | 45 | 55 | 61 | 99
2-Port-Kalibrierung | 99 | 119 | 133 | 212
Zeitbereichc (zusätzliche Dauer im Vergleich zu nicht-korrigierte Wobbelung)
Transformation | <1 | <1 | 4 | 13
Zeittor | <1 | <1 | 4 | 17

a Typische Werte.
b Einschließlich Wobbelzeit, Rücklaufzeit und Bandumschaltzeit. Bildschirm durch DISPLAY:ENABLE OFF abgeschaltet. Bei eingeschaltetem Bildschirm verlängert sich die Zyklusdauer um 21 ms. Daten für eine einzige S11-Messung.
c Nur für Geräte mit Option 010. Bildschirm durch DISPLAY:ENABLE OFF abgeschaltet. Bei eingeschaltetem Bildschirm verlängert sich die Zyklusdauer um 21 ms. Daten für
eine einzige S11-Messung.

Tabelle 2 5. Wobbelzyklusdauer in Abhängigkeit von der ZF-Bandbreitea

Gilt für den Preset-Zustand (201 P unkte, keine Fehlerkorrektur) mit folgenden Ausnahmen:

  • CF = 1 GHz

  • Span = 100 MHz

  • Bildschirm aus (Bei eingeschaltetem Bildschirm verlängert sich die Zyklusdauer um 21 ms.)
ZF-Bandbreite (Hz) | Wobbelzyklusdauer (ms)b
40.000 | 8
35.000 | 9
30.000 | 11
20.000 | 13
10.000 | 28
7000 | 36
5000 | 48
3000 | 72
1000 | 196
300 | 620
100 | 1875
30 | 8062
10 | 17877

a Typische Werte.
b Die Wobbelzyklusdauer setzt sich aus der Wobbelzeit und der Rücklaufzeit zusammen.

Tabelle 26. Wobbelzyklusdauer in Abhängigkeit von der Anzahl der Messpunktea

Gilt für den Preset-Zustand (35 kHz ZF-Bandbreite, Fehlerkorrektur aus) mit folgenden Ausnahmen:

  • CF = 1 GHz

  • Span = 100 MHz

  • Bildschirm aus (Bei eingeschaltetem Bildschirm verlängert sich die Zyklusdauer um 21 ms.)
Anzahl der Messpunkte | Wobbelzyklusdauer (ms)b
3 | 4
11 | 4
51 | 5
101 | 6
201 | 9
401 | 16
801 | 29
1601 | 52

a Typische Werte.
b Die Wobbelzyklusdauer setzt sich aus der Wobbelzeit und der Rücklaufzeit zusammen.

Tabelle 27. Datenübertragungsdauera (ms)

 | Anzahl der Messpunkte
 | 51 | 201 | 401 | 1601
SCPI über GPIB (Programmausführung auf externem PC)b
32-bit-Gleitkomma-Format | 4 | 7 | 13 | 41
64-bit-Gleitkomma-Format | 7 | 14 | 24 | 81
ASCII-Format | 25 | 98 | 189 | 804
SCPI über 10 Mbit/s LAN (Programmausführung auf externem PC)b
32-bit-Gleitkomma-Format | 5 | 6 | 8 | 21
64-bit-Gleitkomma-Format | 5 | 9 | 22 | 38
ASCII-Format | 18 | 53 | 98 | 362
SCPI über 100 Mbit/s LAN (Programmausführung auf externem PC)c
32-bit-Gleitkomma-Format | 3 | 5 | 6 | 12
64-bit-Gleitkomma-Format | 4 | 6 | 9 | 20
ASCII-Format | 17 | 51 | 92 | 339
SCPI (Programmausführung innerhalb des Analysators)d
32-bit-Gleitkomma-Format | 2 | 3 | 4 | 7
64-bit-Gleitkomma-Format | 4 | 5 | 6 | 15
ASCII-Format | 26 | 99 | 198 | 781
COM (Programmausführung innerhalb des Analysators)e
32-bit-Gleitkomma-Format | 1 | 1 | 1 | 2
Typ "Variant" | 1 | 3 | 4 | 19
DCOM über 10 Mbit/s LAN (Programmausführung auf externem PC)f
32-bit-Gleitkomma-Format | 2 | 3 | 5 | 14
Typ "Variant" | 5 | 14 | 26 | 100
DCOM über 100 Mbit/s LAN (Programmausführung auf externem PC)f
32-bit-Gleitkomma-Format | 2 | 2 | 2 | 4
Typ "Variant" | 3 | 5 | 9 | 35

a Typische Werte.
b Gemessen unter Verwendung eines VEE 5.0 Programms, das auf einem 600 MHz HP Kayak läuft, und einer National InstrumentsTM GPIB Karte.
Mit dem Befehl "CALC:DATA?SDATA" wurden komplexe S11-Messdaten eingelesen.
c Gemessen unter Verwendung eines VEE 5.0 Programms, das auf einem 600 MHz HP Kayak ausgeführt wurde. Mit dem Befehl
"CALC:DATA?SDATA" wurden komplexe S11-Messdaten eingelesen. Wenn der Analysator an einem lokalen Netzwerk betrieben wird, ist die Übertragungsgeschwindigkeit vom LAN-Verkehr abhängig.
d Gemessen unter Verwendung eines VEE 5.0 Programms, das innerhalb eines Netzwerkanalysators der Familie PNA ausgeführt wurde. Mit dem Befehl "CALC:DATA?SDATA"wurden komplexe S11-Messdaten eingelesen.
e Gemessen unter Verwendung eines Visual Basic 6.0 Programms, das innerhalb eines Netzwerkanalysators der Familie PNA ausgeführt wurde. Es wurden komplexe S11-
Messdaten übertragen.

f Gemessen unter Verwendung eines Visual Basic 6.0 Programms, das auf einem 600 MHz HP Kayak ausgeführt wurde. Es wurden komplexe S11-Messdaten übertragen. Wenn der Analysator an einem lokalen Netzwerk betrieben wird, ist die Übertragungsgeschwindigkeit vom LAN-Verkehr abhängig.

g Für Daten im 32-bit-Gleitkomma-Format wurde die Methode "IArray Transfer.getComplex" verwendet.

h Für Daten des Typs "Variant" wurde die Methode "meas.getData" verwendet.

Tabelle 28. Geschwindigkeit für "Recall"-Operation und Wobbelung

Operationen | Anzahl der Fenster | Anzahl der Messkurven | "Recall"-Zeit (ms)
"Recall" | 1 | 1 | 140
"Recall" und Wobbelung | 1 | 1 | 198
"Recall" | 1 | 2 | 259
"Recall" und Wobbelung | 1 | 2 | 341
"Recall" | 1 | 4 | 588
"Recall" und Wobbelung | 1 | 4 | 723
"Recall" | 2 | 2 | 282
"Recall" und Wobbelung | 2 | 2 | 373
"Recall" | 3 | 4 | 610
"Recall" und Wobbelung | 3 | 4 | 788
"Recall" | 4 | 4 | 613
"Recall" und Wobbelung | 4 | 4 | 790
"Recall" | 4 | 8 | 1236
"Recall" und Wobbelung | 4 | 8 | 1463


Ressourcen

Weitere Informationsquellen

Siehe auch...

Hier eine Liste mit weiteren Informationsquellen zum Thema Netzwerkanalyse.

Technische Dokumentation von Agilent Technologies

Informationsmaterial von Dritten

Technische Dokumentation von Agilent Technologies

Applikationsberichte

Zu Ihrem Netzwerkanalysator sind diverse Applikationsberichte verfügbar.

  1. Klicken Sie im Help-Menü auf Product Overview.

  2. Die Produktübersicht beginnt mit einer Einführung. Diese können Sie überspringen, indem Sie auf Main Menu klicken.

  3. Klicken Sie im Hauptmenü auf Literature und zum Öffnen des interessierenden Dokuments auf den betreffenden Titel.

Unter der folgenden URL finden Sie die nachfolgend aufgelisteten Applikationsberichte und Product Notes:

http://www.agilent.com/find/PNA

  • Application Development with the Agilent PNA Series of Network Analyzers, (Literaturnummer 5980-2666ENUS).

  • Understanding and Improving Network Analyzer Dynamic Range, Agilent Application Note 1363-1 (Literaturnummer 5980-2778EN).

  • The "Need for Speed" in Component Manufacturing Test, (Literaturnummer 5980-2783EN).

  • Generate Component Data Sheets with Agilent's BenchLinkXL, (Literaturnummer 5980-2781EN).

  • Connectivity Advances in a LAN-enabled Instument, (Literaturnummer 5980-2782EN).

  • De-embedding and Embedding S-Parameter Networks Using the PNA Series Network Analyzer, Agilent Application Note 1364-1 (Literaturnummer 5980-2784EN).

  • Advanced Filter Tuning Using Time Domain, Agilent Application Note 1287-10 (Literaturnummer 5980-2785EN).

  • Understanding the Fundamental Principles of Vector Network Analysis, Agilent Application Note 1287-1 (Literaturnummer 5965-7707E).

  • Exploring the Architectures of Network Analyzers, Agilent Application Note 1287-2 (Literaturnummer 5965-7708E).

  • Applying Error Correction to Network Analyzer Measurements, Agilent Application Note 1287-3 (Literaturnummer 5965-7709E).

  • Network Analyzer Measurements: Filter and Amplifier Examples, Agilent Application Note 1287-4 (Agilent Literaturnummer 5965-7710E).

  • Improving Throughput in Network Analyzer Applications, Agilent Application Note 1287-5 (Literaturnummer 5966-3317E)

  • Using a Network Analyzer to Characterize High-Power Components, Agilent Application Note 1287-6 (Literaturnummer 5966-3319E)

  • Simplified Filter Tuning Using Time-Domain Analysis, Agilent Application Note 1287-8 (Literaturnummer 5968-5328E).

  • In-Fixture Measurements Using Vector Network Analysis, Agilent Application Note 1287-9 (Literaturnummer 5968-5329E).

  • 8 Hints for Making Better Network Analyzer Measurements, Agilent Application Note AN 1291-1 (Literaturnummer 5965-8166E)

  • Specifying Calibration Standards for the Agilent 8510 Network Analyzer, Agilent Product Note 8510-5A, (Literaturnummer 5956-4352, oder Agilent-Teilenummer 08510-90352, Februar 1988).

  • In-Fixture Microstrip Device Measurements Using TRL* Calibration, Agilent Product Note 8720-2, (Literaturnummer 5091-1943E, August 1991).

Informationsmaterial von Dritten

Informationen über Testadapter und Bauteil-Handler erhalten Sie durch:

Inter-Continental Microwave
1515 Wyatt Drive
Santa Clara, CA 95054-1524 USA
Telefon: (+01 408) 727-1596
Fax: (+01 408) 727-0105
Website: www.icmicrowave.com
E-Mail: icmfixture@aol.com

Informationen über Wafer-Prober und Zubehör erhalten Sie durch:

Cascade Microtech, Inc.
2430 NW 206th Avenue
Beaverton, OR 97006 USA
Telefon: (+01 503) 601-1000
Fax: (+01 503) 601-1002
Website: www.cascademicrotech.com
E-Mail: sales@cmicro.com

Informationen über Zubehör für symmetrische und Multiport-Messungen erhalten Sie durch:

ATN Microwave, Inc.
85 Rangeway Road
N. Billerica, MA 01862-2105 USA
Telefon (+01 978) 667-4200
Fax: (+01 978) 667-8548
Website: www.atnmicrowave.com


Optionen

Netzwerkanalysator-Optionen

Siehe auch...

Im Lieferumfang des Gerätes sind enthalten: eine Maus, eine Tastatur, eine CD-ROM mit einer Kopie der Benutzer- und Programmierhandbücher sowie ein Adapter Mini-Parallel/Parallel. Auf das Gerät erhalten Sie standardmäßig drei Jahre Gewährleistung. Nachfolgend werden die verfügbaren Optionen beschrieben.

Geräteoptionen

Nachrüstung von Optionen

Dokumentation und Lokalisierung

Service- und Support-Optionen

Geräteoptionen

Option 010 | Zeitbereichtransformation Diese Option ermöglicht es, Reflexions- und Transmissionsmessdaten in den Zeitbereich zu transformieren und dort zu analysieren. Siehe Überblick über Zeitbereichmessungen.
Option 015 | Konfigurierbares Testset Das konfigurierbare Testset ermöglicht es, über die Frontplatte direkt auf den Signalquellenausgang und den Kopplereingang von Port 1 und Port 2 zuzugreifen. Diese Option beinhaltet außerdem 35 dB-Stufenabschwächer zwischen den Kopplern und den Empfängern. Diese Option bietet Ihnen die Möglichkeit, unter Verwendung externer Komponenten die Messempfindlichkeit zu erhöhen oder die Messanordnung an spezielle Anforderungen anzupassen. Siehe "Messungen an Leistungsbauteilen".
Option 1CM | Gestelleinbausatz Diese Option beinhaltet einen Gestelleinbausatz (Agilent-Teilenummer 5063-9216) und einen Gleitschienensatz (E3663AC) für Geräte ohne Griffe.
Option 1CP | Gestelleinbausatz Diese Option beinhaltet einen Gestelleinbausatz (Agilent-Teilenummer 5063-9236) und einen Gleitschienensatz (E3663AC) für Geräte mit (bereits vorhandenen) Griffen.
Option AM8 | CD-RW-Laufwerk Diese Option beinhaltet ein externes, schreib-/lesefähiges CD-Laufwerk einschließlich USB-Kabel.
Option B30 | USB-Hub Diese Option beinhaltet einen USB-Hub mit vier Ports zum Anschluss zusätzlicher Peripheriegeräte mit USB-Schnittstelle.

Nachrüstung von Optionen

Auch nach dem Kauf eines Analysators können Sie die Optionen unter Verwendung von Upgrade-Kits nachrüsten. Wenn Sie ein Upgrade-Kit für einen E8356A, E8357A oder E8358A bestellen möchten, geben Sie in Ihrem Auftrag die Modellnummer Ihres Analysators an, gefolgt von einem "U" und der gewünschten Option:

Option 010 | Upgrade-Kit für Zeitbereichtransformation-Option (Agilent-Teilenummer E8356-60101) Bei Bestellung dieses Kits müssen Sie die Seriennummer Ihres E8356A, E8357A oder E8358A angeben. Die Installation des Upgrade-Kits ist nicht im Lieferumfang enthalten.
Option 015 | Upgrade-Kit für konfigurierbares Testset (Agilent-Teilenummer E8356-60102) Die Installation in einem Agilent-Service-Zentrum ist im Lieferumfang enthalten.
Option AM8 | CD-RW-Laufwerk Diese Option beinhaltet ein externes, schreib-/lesefähiges CD-Laufwerk einschließlich USB-Kabel.
Option B30 | USB-Hub Diese Option beinhaltet einen USB-Hub mit vier Ports zum Anschluss zusätzlicher Peripheriegeräte mit USB-Schnittstelle.
Option 099 | Firmware-Upgrade-Kit (Agilent-Teilenummer E8356-60103) Diese Option beinhaltet die neueste Firmware-Version für den Netzwerkanalysator der Familie PNA auf CD-ROM. Die Firmware kann vom Benutzer installiert werden. Zur Installation ist ein CD-ROM-Laufwerk mit USB-Schnittstelle oder ein externer, mit dem Analysator über ein LAN vernetzter Computer erforderlich. Die neueste Firmware können Sie sich auch von der Website von Agilent Technologies herunterladen. Besuchen Sie unsere Website www.agilent.com/find/pna. Informationen über die Installation der Firmware siehe Firmware-Upgrades.

Upgrades, die eine Änderung der Modellnummer erfordern, werden gegen Berechnung durchgeführt. Weitere Informationen hierzu erhalten Sie vom nächstgelegen Agilent Vertriebs- und Service-Zentrum. Siehe Agilent Kontaktadressen.

Dokumentation und Lokalisierung

Option AVK | Diese Option beinhaltet eine gedruckte Version der Online-Hilfe (Benutzer- und Programmierhandbücher). (Agilent-Teilenummer E8356-90028)
Option 0BW | Diese Option beinhaltet ein gedrucktes Exemplar der Service-Handbuchs für Reparaturen auf der Baugruppenebene. (Agilent-Teilenummer E8356-90002)
Option ABD | Diese Option beinhaltet eine gedruckte Version der Online-Hilfe in deutscher Sprache. (Agilent-Teilenummer E8356-90032)
Option ABE | Diese Option beinhaltet eine gedruckte Version der Online-Hilfe in spanischer Sprache. (Agilent-Teilenummer E8356-90031)
Option ABF | Diese Option beinhaltet eine gedruckte Version der Online-Hilfe in französischer Sprache. (Agilent-Teilenummer E8356-90029)
Option ABJ | Diese Option beinhaltet eine gedruckte Version der Online-Hilfe in japanischer Sprache. (Agilent-Teilenummer E8356-90032)

Service- und Support-Optionen

Option W01 | Diese Option ersetzt die standardmäßige dreijährige "Return-to-Agilent"-Gewährleistung (Reparatur im Agilent Service-Zentrum) durch einen einjährigen Vor-Ort-Service. (Bitte fragen Sie bei dem nächstgelegen Agilent Vertriebs- und Service-Zentrum an, ob diese Option in Ihrem Land verfügbar ist). Siehe Agilent Kontaktadressen.
Option W31 | Diese Option ersetzt die standardmäßige dreijährige "Return-to-Agilent"-Gewährleistung (Reparatur im Agilent Service-Zentrum) durch einen dreijährigen Vor-Ort-Service. (Bitte fragen Sie bei dem nächstgelegen Agilent Vertriebs- und Service-Zentrum an, ob diese Option in Ihrem Land verfügbar ist). Siehe Agilent Kontaktadressen.
Option W32 | Diese Option beinhaltet eine einen Drei-Jahres-Vertrag über die Kalibrierung des Gerätes nach kommerziellen Standards im Agilent Service-Zentrum.
Option W34 | Diese Option beinhaltet eine einen Drei-Jahres-Vertrag über die normgerechte Kalibrierung des Gerätes im Agilent Service-Zentrum.
Option W50 | Diese Option erweitert die "Return-to-Agilent"-Gewährleistung auf fünf Jahre.
Option W51 | Diese Option ersetzt die standardmäßige dreijährige "Return-to-Agilent"-Gewährleistung (Reparatur im Agilent Service-Zentrum) durch einen fünfjährigen Vor-Ort-Service. (Bitte fragen Sie bei dem nächstgelegen Agilent Vertriebs- und Service-Zentrum an, ob diese Option in Ihrem Land verfügbar ist). Siehe Agilent Kontaktadressen.
Option W52 | Diese Option beinhaltet eine einen Fünf-Jahres-Vertrag über die Kalibrierung des Gerätes nach kommerziellen Standards im Agilent Service-Zentrum.
Option W54 | Diese Option beinhaltet eine einen Fünf-Jahres-Vertrag über die normgerechte Kalibrierung des Gerätes im Agilent Service-Zentrum.


Technische Unterstützung

Siehe auch...

    • Klicken Sie auf die interessierende Region.

  • Technische Unterstützung zu Messgeräten und Testsystemen von Agilent Technologies finden Sie im Internet unter www.agilent.com/find/assist.

  • Oder setzen Sie sich mit den Mess- und Prüftechnik-Experten von Agilent Technologies in Verbindung.

USA:

(Tel.) 1 800 452 4844

Kanada:

(Tel.) 1 877 894 4414

(Fax) 1 (905) 206 4120

Europa:

(Tel.) (31 20) 547 2000

Japan:

(Tel.) (81) 426 56 7832

(Fax) (81) 426 56 7840

Lateinamerika:

(Tel.) (305) 267 4245

(Fax) (305) 267 4286

Australien:

(Tel.) 1 800 629 485

(Fax) (61 3) 9272 0749

Neuseeland

(Tel.) 0 800 738 378

(Fax) 64 4 495 8950

Asiatisch-pazifischer Raum:

(Tel.) (852) 3197 7777

(Fax) (852) 2506 9284


Fehlersuche

Siehe auch...

Mit Hilfe einiger einfacher Tests können Sie überprüfen, ob der Analysator defekt ist. Bevor Sie bei Agilent Technologies anrufen oder das Gerät zur Reparatur einsenden, sollten Sie die folgenden Schnell-Checks durchführen.
Schnell-Checks

Überprüfung der Fehlerterme

Nachschlagen im "Service Guide"

Schnell-Checks

Ein Problem lässt sich oft schon dadurch beheben, dass Sie die Prozedur, bei der das Problem auftrat, wiederholen. Bevor Sie bei Agilent Technologies anrufen oder das Gerät zur Reparatur einsenden, sollten Sie die folgenden Schnell-Checks durchführen:

  1. Führt die Netzsteckdose Spannung? Ist der Analysator an das Netz angeschlossen?

  2. Ist das Gerät eingeschaltet? Prüfen Sie, ob der Netzschalter auf der Frontplatte sich in Stellung ON befindet und mindestens eine der LEDs im Bereich der Messanschlüsse grün leuchtet. Dies signalisiert, dass das Gerät eingeschaltet ist.

  3. Falls andere Geräte, Kabel usw. an das Gerät angeschlossen sind, überprüfen Sie, ob die Verbindungen in Ordnung sind und die externen Geräte funktionieren.

  4. Überprüfen Sie die Messprozedur, während der das Problem aufgetreten ist. Sind alle Einstellungen korrekt?

  5. Wenn das Gerät nicht wie erwartet funktioniert, bringen Sie es durch Drücken der Taste Preset in die Grundeinstellung.

  6. Sind die durchgeführte Messung und die zu erwartenden Messergebnisse innerhalb der Spezifikationen und Messmöglichkeiten des Gerätes?

  7. Wenn Sie die Firmware als Problemursache vermuten, überprüfen Sie, bevor Sie nach weiteren Fehlern suchen, ob die neueste Firmware installiert ist.

  8. Überprüfen Sie, ob die Kalibrierung gültig ist. Weitere Informationen hierzu siehe unter Genaue Kalibrierung.

  9. Falls Sie über die dazu notwendigen Messgeräte verfügen, führen Sie die im Kapitel 2 des "PNA Service Guide" unter "System Tests, Verifications, and Adjustments," beschriebenen Tests durch. (Der "Service Guide" ist in elektronischer Form auf der mit dem Analysator gelieferten CD-ROM enthalten).

Überprüfung der Fehlerterme

Wenn Sie die Fehlerterme in regelmäßigen Zeitabständen (wöchentlich, monatlich usw.) ausdrucken, können Sie die aktuellen Fehlerterme mit diesen Aufzeichnungen vergleichen. Ein stabiles, reproduzierbares System sollte über einen längeren Zeitraum, beispielsweise sechs Monate, reproduzierbare Fehlerterme liefern. Falls Sie einen subtilen Fehler oder eine subtile Verschlechterung der Genauigkeit vermuten, sollten Sie die Fehlerterme mit früheren Fehlertermen vergleichen, die mit dem gleichen Messgerät und dem gleichen Kalibrier-Kit gemessen wurden. Informationen zur Überwachung von Fehlertermen siehe Überwachung der Fehlerterme.

  • Ein Langzeit-Trend bei den Fehlertermen kann auf Alterung von Bauteilen oder allmählichen Verschleiß von Steckverbindern, Kabeln usw. hindeuten. In solchen Fällen sollten Sie der Ursache auf den Grund gehen und vorbeugende Maßnahmen ergreifen. (Auch dann, wenn das System noch die Spezifikationen einhält). Oft genügt es, einfach nur die Steckverbinder zu reinigen oder zu richten und die Kabel genau zu inspizieren, um das Problem zu beheben.

  • Wenn sich die Fehlerterme plötzlich ändern, deutet dies auf eine abrupte Änderung der systematischen Fehler hin; in diesem Fall müssen Sie die Ursache ergründen.

Beachten Sie bei der Fehlersuche folgendes:

  • Alle Komponenten des Systems, einschließlich der Kabel und Kalibriernormale, können systematische Fehler verursachen und sich auf die Fehlerterme auswirken.

  • Die verwendeten Steckverbinder müssen sauber und korrekt gerichtet sein und innerhalb der Spezifikationen liegen; nur dann ist die Fehlertermanalyse aussagekräftig. Informationen zur Reinigung und zum Richten von Steckverbindern siehe Kapitel 2 des "PNA Service Guide".

    • Vermeiden Sie es, die Kabel nach der Kalibrierung unnötig zu biegen; dadurch minimieren Sie die Fehler durch Kabelinstabilität.

    • Achten Sie bei der Kalibrierung darauf, dass die verwendeten Komponenten korrekt angeschlossen sind. Die elektrischen Eigenschaften der Steckverbindungen müssen reproduzierbar sein. Informationen hierzu siehe "PNA Service Guide".

  • Oft lohnt es sich, die Kalibrierung zweimal (unter Verwendung jeweils unterschiedlicher Normale) durchzuführen, um die Reproduzierbarkeit zu überprüfen. Wenn die Ergebnisse der beiden Kalibrierungen signifikant voneinander abweichen, überprüfen Sie alle Steckverbinder und Kabel.

  • Bei einer subtilen, allmählichen Verschlechterung der Messgenauigkeit sollten Sie die Fehlerterme analysieren. Bei offensichtlichen, eklatanten Messfehlern siehe Kapitel 3, "Troubleshooting," im "PNA Service Guide".

Nachschlagen im "Service Guide"

Im "PNA Service Guide" werden spezielle Prozeduren zur Fehlerdiagnose beschrieben. Dieses Handbuch ist in elektronischer Form auf der mit dem Analysator gelieferten CD-ROM enthalten. Sie können den "Service Guide" auch von folgender Website herunterladen: http://www.agilent.com/find/pna


Zubehör

Siehe auch...

Kalibrier-Kits

Verifikations-Kits

Steckeradapter- und Zubehör-Kits

Messkabel

Im "Agilent RF and Microwave Test Accessories Catalog" (Literaturnummer 5968-4314EN) oder auf unserer Website www.agilent.com/find/mta finden Sie eine große Auswahl an HF-Messzubehör.

Es sind Zubehörprodukte mit folgenden Anschlüssen verfügbar:

  • 50 Ohm Type-N

  • 3,5 mm

  • 7 mm

  • 7-16

Zu einem vollständigen Messsystem gehören auch Messkabel und ein Kalibrierungskit. Zur Verifikation der korrigierten Systemgenauigkeit wird ein Verifikations-Kit benötigt.

Kalibrier-Kits

Type-N, 50 Ohm Mechanisch | Agilent 85032F
Type-N, 50 Ohm Modul für die Elektronische Kalibrierung (ECal) | Agilent 85092B
3,5 mm Mechanisch | Agilent 85033E
3,5 mm ECal-Modul für elektronische Kalibrierung | Agilent 85093B
7mm | Agilent 85031B
7mm ECal-Modul für elektronische Kalibrierung | Agilent 85091B
7-16 | Agilent 85038A
7-16 ECal-Modul für elektronische Kalibrierung | Agilent 85098B

Verifikations-Kits

Type-N | Agilent 85055A
3,5 mm | Agilent 85053B

Steckeradapter- und Zubehör-Kits

3,5 mm Adapter-Kit | Agilent 11878A
Koaxial-Adapter APC-7 auf Type-N (w) | Agilent 11524A
Koaxial-Adapter APC-7 auf Type-N (m) | Agilent 11525A
Adapter-Kit 7-16 auf 7-16 | Agilent 11906A
Adapter-Kit 7-16 auf Type-N | Agilent 11906B
Zubehör-Kit, Type-N, 50 Ohm | Agilent 11853A
Zubehör-Kit BNC, 50 Ohm | Agilent 11854A

Messkabel

Type-N (m-m), 50 Ohm, 40 cm | Agilent N3839A
Type-N (m-m), 50 Ohm, 60 cm | Agilent N6314A
Type-N (m-w), 50 Ohm, 40 cm | Agilent N6315A


Kalibrierung und Verifikation der Messgenauigkeit

Gerätekalibrierung und Systemverifikation

Siehe auch...

Sie können auf zweierlei Weise sicherstellen, dass der Analysator ordnungsgemäß funktioniert:

Gerätekalibrierung

Systemverifikation

Gerätekalibrierung

Warum sollten Sie den Analysator regelmäßig kalibrieren lassen?

Durch allmähliches Altern der aktiven Bauteile im Analysator kann sich die Messgenauigkeit im Laufe der Zeit verschlechtern (Langzeitdrift). Um sicherzustellen, dass der Analysator die Spezifikationen einhält, müssen Sie regelmäßig eine Gerätekalibrierung vornehmen lassen.

Was geschieht während einer Gerätekalibrierung?

Bei einer Gerätekalibrierung wird überprüft, ob die Messgenauigkeit des Analysators innerhalb der Spezifikationen liegt. Etwaige Abweichungen von den Spezifikationen werden durch einen Neuabgleich der betreffenden Baugruppen korrigiert. (Die Gerätekalibrierung darf nicht mit der Messkalibrierung verwechselt werden, die Sie selbst vor Beginn Ihrer Messungen vornehmen; die Messkalibrierung wird in dieser Dokumentation der Einfachheit halber als Kalibrierung bezeichnet).

Wie oft sollten Sie den Analysator kalibrieren lassen?

Die Spezifikationen berücksichtigen die Drift über einen Zeitraum von 12 Monaten. Wenn Sie Ihren Analysator alle 12 Monate rekalibrieren lassen, können Sie sicher sein, dass das Gerät den Spezifikationen entspricht. Falls Sie besonders hohe Anforderungen an die Konsistenz Ihrer Messergebnisse stellen, sollten Sie das Gerät eventuell in kürzeren Zeitabständen rekalibrieren lassen.

Was muss ich tun, um den Analysator kalibrieren zu lassen?

Zur Gerätekalibrierung müssen Sie den Analysator in ein Service-Zentrum von Agilent Technologies einsenden. Siehe Technische Unterstützung. Wenn Sie die Gerätekalibrierung selbst durchführen möchten, benötigen Sie folgendes:

  • Messgeräte für die Gerätekalibrierung

  • Performance-Test-Software

Zwischen welchen Optionen können Sie bei der Gerätekalibrierung wählen?

Agilent Technologies bietet folgende Kalibrieroptionen an:

Standard | Bei der Standard-Gerätekalibrierung erhalten Sie ein Zertifikat, das bestätigt, dass das Gerät kalibriert wurde und den publizierten Spezifikationen entspricht.
Option UK6 | Wenn Sie diese Option wählen, erhalten Sie ein Messprotokoll der Kalibrierergebnisse und ein Zertifikat, das bestätigt, dass das Gerät kalibriert wurde und den publizierten Spezifikationen entspricht.
Option M40 (Spezial) | Wenn Sie diese Option wählen, erhalten Sie ein Messprotokoll der Kalibrierergebnisse und ein Zertifikat, das bestätigt, dass das Gerät nach einem ANSI Z540-konformen Verfahren kalibriert wurde und den publizierten Spezifikationen entspricht.

Systemverifikation

Bei dieser Prozedur werden die Amplituden- und Phasenfrequenzgänge aller vier S-Parameter unter Verwendung eines Verifikations-Kits gemessen und verglichen mit

  • im Werk gemessenen Referenzdaten (in Form von Dateien auf der Verifikationsdiskette)

  • Grenzwertlinien auf der Basis der Messunsicherheit

Diese Prozedur gewährleistet folgendes:

  • Der Analysator kann über den gesamten Frequenzbereich genaue Messungen durchführen.

  • Der Analysator kann innerhalb des am häufigsten benötigten Dynamikbereichs genaue Messungen durchführen.

  • Die Fehlerkorrektur anhander der gespeicherten Kalibrierdaten funktioniert ordnungsgemäß.


Firmware-Upgrade

Aktualisierung der Firmware und der Online-Hilfe

Siehe auch...

Das neueste Firmware-Upgrade für die Netzwerkanalysatoren der Familie PNA finden Sie auf der Website von Agilent Technologies. Sie können kostenlos auf das Upgrade zugreifen und es herunterladen. Falls Sie keinen Internet-Zugang haben, können Sie Firmware-Upgrades auch auf CD-ROM beziehen. Bestellinformationen siehe Netzwerkanalysator-Optionen.

Upgrades werden in Form einer selbstextrahierenden InstallShield-Datei geliefert. Diese Datei enthält folgendes:

  • PNA-Messanwendung

  • Online-Hilfe

  • Dienstprogramme

Die Dateien beanspruchen zusammen etwa 20 MByte. Zum Herunterladen von Upgrades können Sie Ihren Netzwerkanalysator der Familie PNA oder einen externen PC verwenden.

Herunterladen vom Analysator aus

Stellen Sie von Ihrem Netzwerkanalysator mit Hilfe des Web-Browsers über Ihr LAN eine Verbindung zur Website von Agilent Technologies her.

  1. Navigieren Sie zu der Web-Seite http://www.agilent.com/find/PNA.

  2. Klicken Sie auf Support.

  3. Klicken Sie auf Download Firmware.

  4. Jetzt haben Sie folgende Möglichkeiten:

    • Das Programm auf dem Server ausführen. [Empfohlene Vorgehensweise].

    • Das Programm auf die Festplatte des Analysators abspeichern.

Falls Sie das Programm auf die Festplatte Ihres Analysators abspeichern, öffnen Sie die Datei auf Ihrem Analysator und befolgen Sie die auf dem Bildschirm erscheinenden Anweisungen. Die Datei ist selbstextrahierend.

Herunterladen von einem externen PC aus

Falls Ihr Analysator keinen direkten Internet-Zugang hat, können Sie zum Herunterladen der Upgrade-Datei auch einen externen PC mit Internet-Zugang benutzen. Anschließend können Sie die heruntergeladene Datei über das LAN zu Ihrem Analysator übertragen.

  1. Navigieren Sie zu der Web-Seite http://www.agilent.com/find/PNA.

  2. Klicken Sie auf Support.

  3. Klicken Sie auf Download Firmware.

  4. Speichern Sie das Programm auf die Festplatte Ihres PCs ab.

  5. Übertragen Sie die heruntergeladene Datei über das LAN zu Ihrem Analysator.

    • Führen Sie das Programm auf dem externen PC aus.

    • Speichern Sie das Programm auf die Festplatte des Analysators ab.

Warnung: Sie können zwar die Upgrade-Datei auf dem externen PC speichern, aber nicht die PNA-Anwendung auf dem externen PC installieren. Die PNA-Anwendung ändert wichtige Systemeinstellungen und kann den PC zum Absturz bringen.


Glossar

Inhalt

Glossar

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

12-Term-Fehlerkorrektur Siehe Fehlerkorrektur, 12-Term-.

Eintor-Bauteil Ein Bauteil mit einem einzigen Anschluss oder einem einzigen Pfad zur internen Schaltung. Typische Beispiele sind ein Oszillator oder eine Last.

2-Port-Fehlerkorrektur Siehe Fehlerkorrektur, 12-Term-.

Zweitor-Bauteil Ein Bauteil mit zwei Anschlüssen oder Pfaden zur internen Schaltung. Typische Beispiele sind Filter, SAW-Bauteile, Abschwächer, Anpassungsnetzwerke und Verstärker.

3-Term-Fehlerkorrektur Siehe Fehlerkorrektur, 3-Term-.

A

Aktiver Kanal Der durch erhöhte Helligkeit hervorgehobene Kanal, dessen Einstellungen über die Frontplatte verändert werden können.

Eingabekontrollfeld Der Bereich des Bildschirms, in dem der Wert des aktiven Parameters und/oder der Zustand der aktiven Funktion angezeigt werden. Die aktive Funktion ist diejenige Funktion, die durch den letzten Tastendruck oder den letzten Fernsteuerungsbefehl abgeschlossen wurde.

Aktiver Marker Der Messkurven-Marker, der über die Frontplatte oder per Fernsteuerungsbefehl verschoben werden kann.

Aktive Messkurve Eine Messkurve, die gewobbelt (d. h. anhand aktueller Messdaten fortlaufend aktualisiert) wird.

ADC Analog/Digital Converter, A/D-Wandler.

Adresse Der Identifizierer (dies kann ein Name, eine Bezeichnung oder eine Nummer sein) für ein Register, einen Speicherort oder eine sonstige Datenquelle oder ein sontiges Datenziel. Typische Beispiele sind die IP-Adresse eines Knotens in einem Kommunikationsnetz oder die GPIB-Adresse eines vernetzten Messgerätes.

ADM Add-Drop Multiplexer.

Admittanz (Y) Leitwert (= Kehrwert einer Impedanz, d. h. das Verhältnis von Stromstärke zu Spannung). Komplexe Impedanzen lassen sich darstellen durch Y = G + jB(t).

ALC Automatic Level Control. Siehe Automatic Gain Control.

AM Amplitudenmodulation.

AM-Gruppenlaufzeit Ein Verfahren zur Messung der Gruppenlaufzeit mit Hilfe eines amplitudenmodulierten Messsignals. Hinweis: Bei diesem Verfahren wird die Verzögerung der Modulationshüllkurve direkt mit Hilfe eines externen skalaren Detektors gemessen. Dieses Messverfahren ist daher nicht anwendbar auf Bauteile, die Amplitudenverzerrungen verursachen. Hierzu zählen beispielsweise Verstärker mit automatischer Pegelregelung (AGC) oder Bauteile, die in die Sättigung oder Begrenzung geraten können.

Amplitudenmodulation Der Prozess (oder das Ergebnis dieses Prozesses) der Veränderung der Amplitude eines Trägersignals in Abhängigkeit von einem anderen Signal mit niedrigerer Frequenz. Das resultierende modulierte Trägersignal enthält Information, die durch Demodulation zurückgewonnen werden kann. Siehe auch Modulation.

Analogbauteile/-schaltungen Eine Klasse von Bauteilen oder Schaltungen, die dadurch gekennzeichnet ist, dass das Ausgangssignal den Änderungen des Eingangssignals kontinuierlich folgt.

Anzeige Eine auf dem Bildschirm erscheinende Information der Form <Parametername><Wert>. Beispiel: CENTER 1 GHz oder POWER 0 dBm.

ANSI American National Standards Institute: Eine nationale Mitgliedsorganisation (offen für Hersteller, Organisationen, Benutzer und Netzbetreiber), die Standards verabschiedet, Arbeitsgruppen zur Entwicklung von Standards sowie Zertifizierungsprogramme akkreditiert, und US-Interessen in nicht-internationalen und nicht-behördlichen Normeninstituten vertritt.

Apertur Die vom Analysator zur Berechnung der Gruppenlaufzeit verwendete Frequenzspanne. Je kleiner die Apertur, desto höher die Gruppenlaufzeit-Auflösung; je größer die Apertur, desto geringer das Rauschen.

Array Eine Zahlen- oder Zeichenmenge, die eine gegebene Funktion repräsentiert.

ASCII American Standard Code for Information Interchange.

Abschwächung Eine Reduktion der Signalamplitude. Die auf Verluste in Geräten, Leitungen oder sonstigen Übertragungsmedien zurückzuführende Differenz (in dB) zwischen der transmittierten und der empfangenen Leistung.

Abschwächer Ein HF/Mikrowellen-Bauteil, das dazu dient, den Ausgangspegel einer Signalquelle über deren gesamten Frequenzbereich um einen exakt definierten, einstellbaren Betrag zu reduzieren.

Automatic Calibration System AutoCal: Eine Funktion bei Netzwerkanalysatoren von Rohde&Schwarz.

Automatic Gain Control (AGC) Eine in Verstärkern und anderen aktiven Komponenten verwendete Schaltung, die den HF-Ausgangspegel konstant hält, wenn andere Parameter (beispielsweise die Frequenz) sich ändern. Synonym: Automatic Leveling Control (ALC)

Autoscale Eine Analysatorfunktion, welche die Y-Achse (und manchmal auch die X-Achse) in Abhängigkeit von den Messdaten automatisch so skaliert, dass die Messkurve in einem optimalen Maßstab angezeigt wird.

AUX Auxiliary; ein Hilfseingang auf der Rückwand des Analysators.

Mittelung (Averaging) Ein Verfahren zur Rauschreduktion, das die Messkurve punktweise aus den Ergebnissen mehrerer aufeinanderfolgender Wobbelmessungen berechnet. Die Anzahl der zur Mittelung herangezogenen Wobbelmessungen wird durch den benutzerdefinierten Mittelungsfaktor bestimmt. Sobald die Anzahl der durchgeführten Messungen größer ist als der Mittelungsfaktor, fallen die jeweils ältesten Messergebnisse aus der Mittelung heraus.

B

B/R Das Verhältnis der Leistung am Eingang B zur Leistung am Eingang R.

Bandpass Ein Filter, das nur Frequenzen innerhalb eines bestimmten Bereichs durchlässt. Außerhalb des Durchlassbereichs liegende Frequenzen werden abgeschwächt. Siehe auch Grenzfrequenz.

Bandbreite (BW, Bandwidth) Die Differenz zwischen der oberen und der unteren Eckfrequenz eines kontinuierlichen Frequenzbandes, innerhalb dessen die Performance eines Bauteils den Spezifikationen entspricht.

Bandbreitenbegrenzung Der Zustand, der vorliegt, wenn die Systembandbreite überschritten wird und Signalverzerrungen auftreten, die außerhalb der Spezifikation liegen.

Formfaktor Ein Maß für die Fähigkeit eines Filters, Signale mit ungleichen Amplituden einzeln aufzulösen. Bei einem Netzwerkanalysator ist der Formfaktor das Verhältnis der –60-dB-Bandbreite zur –3-dB-Bandbreite eines gegebenen Auflösebandbreitenfilters (ZF-Filters). Der Formfaktor ist auch ein Maß für die Steilheit der Filterflanken. Der Formfaktor wird manchmal auch als Bandbreitenselektivität bezeichnet.

Binärformat Eine Methode zur Darstellung von Zahlen als eine Summe von Zweierpotenzen, wobei die Ziffern 0 und 1 durch Ein-/Aus-Zustände oder HIGH/LOW-Pegel repräsentiert werden können. Ein kompaktes Format für die schnelle Datenübertragung von und zum Analysator.

BMP Bit-Mapped. Darstellung einer Abbildung oder Grafik durch Bildpunkte (Pixel).

Helligkeit Siehe Farbsättigung.

Breitbandbauteil Ein Bauteil, das innerhalb eines weiten Frequenzbereichs eingesetzt werden kann und dessen Frequenzgang innerhalb dieses Bereichs nur geringe Schwankungen aufweist.

Puffer Ein Bauteil oder Gerät zur Zwischenspeicherung von Daten bei der Kommunikation zwischen Geräten, die sich hinsichtlich ihrer Datenübertragungs-/verarbeitungsraten unterscheiden.

Burst-Träger Ein Trägersignal, das periodisch ein-/ausgeschaltet wird. Ein Burst-Träger kann, muss aber nicht moduliert sein.

BUS Basic Utility System.

Bus Ein oder mehrere Leiter, die als Signalpfad(e) zur Informationsübertragung von einer beliebigen von mehreren Quellen zu einem beliebigen von mehreren Zielen dienen.

BW (Bandwidth) Bandbreite.

Byte Acht Datenbits, die zusammen ein Zeichen repräsentieren, das als eine Einheit verarbeitet wird.

C

CAD Computer Aided Design, Computerunterstützter Entwurf.

CAE Computer Aided Engineering, Computerunterstützte Konstruktion.

Kalibrierung Es ist zwischen Gerätekalibrierung und (Mess-) Kalibrierung zu unterscheiden. Unter Gerätekalibrierung ist bei Messgeräten von Agilent Technologies folgendes zu verstehen: Der Prozess der periodischen (meist jährlichen) Überprüfung des Gerätes auf Einhaltung der Spezifikationen. Der Kunde erhält nach der Gerätekalibrierung ein Kalibrierzertifikat.

Bei einem Netzwerkanalysator ist unter der (Mess-) Kalibrierung die Korrektur systematischer Messfehler zu verstehen. Siehe Fehlerkorrektur.

Kalibrier-Kit Die Hard- und Software, die benötigt wird, um einen Netzwerkanalysator für bestimmte Messungen oder ein bestimmtes Testset zu kalibrieren.

Kalibrierung, 2-Port Siehe Fehlerkorrektur, 12-Term-.

Kalibrierung, Blackburn- Kalibrierung des Übertragungspfades bei korrekter Quellenanpassung unter Verwendung von 15 Kalibriertermen. Synonym: 15-Term-Fehlerkorrektur.

Kalibrierung, Frequenzgang- Die am einfachsten durchzuführende Fehlerkorrektur, die allerdings nur einige der insgesamt zwölf systematischen Fehlerterme korrigiert. Eine Frequenzgangkalibrierung kann für Reflexionsmessungen, Transmissionsmessungen und Isolationsmessungen durchgeführt werden.

Kalibrierung, Interpolation Eine (abschaltbare) Netzwerkanalysator-Funktion, die bei einer Änderung von Messparametern wie z. B. ZF-Bandbreite, Signalquellenpegel oder Wobbelzeit fehlende Fehlerkorrekturdaten aus vorhandenen durch Interpolation berechnet. Die resultierende Fehlerkorrektur ist nicht so genau wie eine vollständige 2-Port-Kalibrierung mit den neuen Einstellungen.

Kalibrierung, Messebenenverschiebung Siehe Messebenenverschiebung.

Kalibrierung, Messebene Siehe Messebene.

Kalibrierung, "Set Z" Gibt die Systemimpedanz vor (normalerweise 50 oder 75 Ohm).

Kalibrierung, SOLT Eine Kalibrierung unter Verwendung von vier Normalen: Kurzschluss (Short), Leerlauf (Open), Last (Load) und Durchgang (Through). Dieses Kalibrierverfahren wird auch als vollständige 2-Port-Kalibrierung oder 12-Term-Fehlerkorrektur bezeichnet. Siehe auch Fehlerkorrektur.

Kalibrierung, TRL und LRM Eine Kalibrierung, die in Umgebung angewandt wird, in denen das Messobjekt nicht direkt an die Messanschlüsse des Netzwerkanalysators angeschlossen werden kann (MMIC, Microstrip, Beam-Lead-Dioden usw.) "Thru-Reflect-Line"- (TRL) und M- (Match) Normale werden hergestellt und verwendet, weil bekannt-hochwertige Normale nicht leicht zu beschaffen sind. Die Anforderungen bei der Charakterisierung dieser Normale sind weniger hoch, dafür ist allerdings auch die Kalibrierung nicht so genau wie die herkömmliche vollständige 2-Port-Kalibrierung unter Verwendung von SOLT-Normalen. Die Begriffe TRL, LRL, LRM usw. sind austauschbar und bezeichnen im wesentlichen alle das gleiche Kalibrierverfahren.

Wellenwiderstand Die Impedanz am Ende eines unendlich langen, verlustlosen Wellenleiters.

Farbbrillanz Ein Maß für die Helligkeit einer Farbe.

Befehl Eine Anzahl von Anweisungen, die von einem Messgerät in Aktionen umgesetzt werden. Solche Aktionen bestehen normalerweise aus einzelnen Schritten, die zusammen eine Operation ergeben.

Kontinuierliche Wobbelung Eine Analysatorbetriebsart, in der automatisch ein neuer Wobbelzyklus gestartet wird, sobald die Triggerbedingungen erfüllt sind.

Controller Ein Gerät, das in der Lage ist, andere Geräte zum Sender oder Empfänger für eine Datenübertragung zu bestimmen. Ein externer Computer, der mit einem Messgerät verbunden ist und dieses steuert.

Korrigierte Messung Eine Messung nach erfolgter Fehlerkorrektur.

Koppler Siehe Richtkoppler.

CPU Central Processing Unit. Zentrale Verarbeitungseinheit; in der Regel ist dies ein Mikroprozessor.

Übersprechen Das Auftreten eines unerwünschten, aus einem anderen Signalpfad stammenden Signals an einem Bauteilanschluss. Ein Maß für das Übersprechen ist die Isolation.

Cursor Ein elektronisch erzeugter Zeiger, der sich über den Bildschirm bewegen lässt und dazu benutzt wird, Einstellungen zu ändern.

Grenzfrequenz Bei einem Filter die Frequenz, bei welcher der Frequenzgang gegenüber dem Durchlassbereich um 3 dB abfällt.

CW Continuous Wave: Ein Signal mit einer festen (nicht gewobbelten) Frequenz.

D

DAC Digital/Analog Converter, D/A-Wandler.

dB Decibel: eine relative Maßeinheit. Das Leistungsverhältnis in dB wird folgendermaßen berechnet: 10 log10 (P1/P2) wobei P1 und P2 die gemessenen Leistungen sind. Die Maßeinheit dB wird gegenüber dem arithmetischen Verhältnis oder einer Prozentangabe bevorzugt, weil sich dann die Dämpfung oder Verstärkung einer Serienschaltung mehrerer Bauteile durch einfaches Addieren der entsprechenden dB-Werte berechnen lässt. Wenn beispielsweise ein 3-dB-Abschwächer an einen 10-dB-Verstärker angeschlossen ist, beträgt die Nettoverstärkung dieser Serienschaltung +7 dB (–3dB + 10dB).

dBm Eine absolute Leistungsmaßeinheit: 0 dBm = 1 mW. Die Konventionen bezüglich dB (Addieren und Subtrahieren) gelten auch für Absolutleistungsberechnungen in dBm.

DBMS Database Management System. Datenbankverwaltungssystem.

DC Direct Current. Gleichstrom oder Gleichspannung.

Standardwert Ein Wert, der immer dann verwendet wird, wenn kein Wert explizit angegeben wird.

Verzögerung Siehe Gruppenlaufzeit.

Demodulation Die Rückgewinnung eines Signals aus einem modulierten Trägersignal, das im wesentlichen dem ursprünglichen Modulationssignal entspricht. Die Rückgewinnung des Modulationssignals erfolgt durch Signaldetektion.

Detektion Der Prozess der Demodulation eines modulierten Trägersignals. Bei Netzwerkanalysatoren werden zwei verschiedene Detektionsverfahren angewandt: Diodendetektoren (für breitbandige Messungen) und Überlagerungsempfänger- (Heterodyne) Verfahren (für schmalbandige Messungen).

Detektor, Dioden- Ein Bauteil, das ein HF-Signal in eine entsprechende Gleichspannung umsetzt. Falls das HF-Signal amplitudenmoduliert ist, entspricht das Dioden-Ausgangssignal der Hüllkurve des Trägersignals. Skalare Netzwerkanalysatoren verwenden für Gruppenlaufzeitmessungen oft ein mit 27,778 kHz amplitudenmoduliertes Messsignal, das dann im Empfangsteil des Analysators detektiert wird. Die Phaseninformation des Trägersignals geht bei der Diodendetektion verloren.

Phasenlinearitätsabweichung Wenn der Phasenfrequenzgang eines Bauteils im linearen Maßstab eine gerade Linie ist, spricht man von "linearer Phase". Abweichungen des Phasenfrequenzgangs von einer Geraden verursachen Signalverzerrungen.

Digital Eine Klasse von Bauteilen oder Schaltungen, deren Ausgangssignal in diskreten Schritten veränderlich ist.

Digital-Demodulation Ein Verfahren zur Extraktion der einem Signal aufmodulierten Information. Nach der Analog/Digital-Umsetzung (Digitalisierung) wird das Signal mit Hilfe digitaler Signalverarbeitungsalgorithmen weiterverarbeitet.

Dimension Die Größe eines Arrays. Die Anzahl der Zeilen oder Spalten eines Arrays.

Richtverhältnis Bei einem 3-Port-Richtkoppler das Verhältnis der am Hilfsanschluss auftretenden Leistung während des Signalflusses in Vorwärtsrichtung zu der am Hilfsanschluss auftretenden Leistung während des Signalflusses in Rückwärtsrichtung.

Richtkoppler Ein 3-Port-Bauteil, das typischerweise dazu verwendet wird, um bei einem Wellenleiter die reflektierte Welle von der hinlaufenden Welle zu trennen.

Platte Ein rundes, magnetisches Speichermedium.

Display Siehe Bildschirm.

Anzeigedetektorbetriebsart Die Art und Weise, wie analoge Video-Information verarbeitet wird, bevor sie digitalisiert und abgespeichert wird.

Dynamische Anzeigegenauigkeit Die Amplitudenunsicherheit (normalerweise in dB) über den angezeigten Dynamikbereich.

Anzeigedynamikbereich Der Amplitudenbereich (in dB), innerhalb dessen die dynamische Anzeigegenauigkeit gilt.

Darstellungsformate Grafische Formate für die Darstellung der Messdaten. Beispiele: Einkanaldarstellung, Überlagerungsdarstellung (mehrere Messkurven innerhalb eines Gitterrasters), "Split" (jede Messkurve innerhalb eines eigenen Gitterrasters).

Anzeigebetriebsarten Die Art und Weise, wie die Messdaten grafisch dargestellt werden können. Bei einem Netzwerkanalysator stehen folgende Betriebsarten zur Auswahl: Kartesisch/rechtwinklig (XY-Diagramm mit logarithmischer oder linearer Amplitudenskala, Phase, Gruppenlaufzeit, SWR, Real- und Imaginärteil, dBV, dBmV und dBuV), Polar (Amplitudenbetrag und Phase), Amplitudenbetrag und Phase, Smith-Diagramm. Nicht alle Bildschirmbetriebsarten sind bei allen Netzwerkanalysatoren verfügbar. Darüber hinaus können Bildschirme diese Information in verschiedenen Kombinationen von Messkurven anzeigen. Gängige Betriebsarten sind: "Dual", (mehr als eine Messkurve, üblicherweise über den gleichen Frequenzbereich) und "Alternate" (mehr als eine Messkurve, jeweils mit individuell gewähltem Frequenzbereich und Typ).

Dynamische Anzeige-Phasengenauigkeit Die Phasenmessunsicherheit, üblicherweise in Grad, für Messungen mit der Phaseneinheit Grad.

Anzahl der Messpunkte Die Gesamtanzahl der Messpunkte für eine einzelne Messung. Die Punkte können eine Frequenz, eine Leistung oder eine Zeit repräsentieren. Die Anzahl der Messpunkte bestimmt oft die Messgeschwindigkeit, Auflösung und Apertur.

Messkurvenrauschen, Betrag Die Amplitudenunsicherheit der Messkurve (in dB) aufgrund von zufälligem Systemrauschen.

Messkurvenrauschen, Phase Die Phasenunsicherheit der Messkurve (in Grad) aufgrund von zufälligem Systemrauschen.

Bildschirmtyp Der Typ des im Analysator eingebauten Bildschirms. Messdaten können als Rastergrafik (in Form von Pixeln wie bei einem Computer) oder als Vektorgrafik (wobei Linien auf den Bildschirm geschrieben werden) angezeigt werden. Weitere Typen sind: Monochrombildschirm (eine einzige Farbe) oder Farbbildschirm (zwei oder mehrere Farben). Eine weitere Spezifikation ist das Format, beispielsweise VGA oder SVGA für IBM-kompatible PCs.

Verzerrung Die Verschlechterung der Signalqualität aufgrund der Nichtlinearität der Übertragungsfunktion eines Bauteils oder Systems. Die Verzerrungen werden charakterisiert durch die Amplituden-, Frequenz- und Phasendifferenzen des Signals am Ausgang eines Bauteils oder Systems relativ zum Eingangssignal.

Drift Eine allmähliche Frequenzänderung.

DSP Digital Signal Processing. Digitale Signalverarbeitung.

DUT Device Under Test. Messobjekt.

DVM Digitalvoltmeter.

Dynamikbereich Bei einem Empfänger der Signalpegelbereich, innerhalb dessen zwei Signale liegen müssen, damit sie gleichzeitig zuverlässig gemessen werden können. Ein großer Dynamikbereich erlaubt es, schwache und starke Signale gleichzeitig zu messen. Nach oben wird der Dynamikbereich in der Regel durch den maximalen Signalquellenpegel und den Empfängerkompressionsbereich begrenzt. Nach unten wird der Dynamikbereich üblicherweise durch Empfängernebenwellen und das Systemrauschen begrenzt.

E

ECal Siehe Elektronische Kalibrierung.

Elektrische Länge Ein simulierter, verlustloser Wellenleiter mit veränderlicher Länge, der einem Empfängereingang "vorgeschaltet" wird, um die Laufzeit von Verbindungskabeln zu kompensieren. Das Firmware-Äquivalent eines mechanischen oder analog-elektrischen "Leitungsstreckers" bei älteren Netzwerkanalysatoren.

Elektronische Kalibrierung (ECal) Ein Kalibrierungssystem für die elektronische Kalibrierung von HF/Mikrowellen-Netzwerkanalysatoren. Das elektronische Kalibrierungssystem erstellt ein 2-Port-Fehlermodell mit 12 Termen und überprüft die Kalibrierung auf Vertrauenswürdigkeit. Das Ecal-System besteht aus einem reproduzierbaren Halbleiter-Kalibriernormal mit variabler Impedanz und einer Steuereinheit. Die Steuereinheit kann direkt an einen Netzwerkanalysator 8510, Serie 8720 oder 8753 angeschlossen werden, oder über ein USB-Modul an einen Netzwerkanalysator der Familie PNA.

EMC Electro-Magnetic Compatibility. Elektromagnetische Verträglichkeit.

EMI Electro-Magnetic Interference: Unerwünschte gegenseitige Beeinflussung von Signalen, die innerhalb oder außerhalb von elektronischen Geräten erzeugt werden. Typische Quellen sind beispielsweise: Netztransienten, Störimpulse aus Schaltnetzteilen und/oder Ober-/Nebenwellen von Oszillatoren. EMI lässt sich mit Hilfe von Netzfiltern, Abschirmung usw. unterdrücken.

Aktivieren Eine Funktion aktivieren.

Eingabe Der Prozess der Dateneingabe.

EPROM Electronically Programmable, Read-Only Memory. Elektronisch programmierbarer Nur-Lese-Speicher.

Fehlerkorrektur Bei Netzwerkanalysatoren ein Prozess, der systematische (reproduzierbare) Messfehler mit Hilfe von Referenzmessungen an Kalibriernormalen mit genau bekannten Eigenschaften eliminiert oder reduziert. Synonym: (Mess-) Kalibrierung.

Fehlerkorrektur, 3-Term- Wird zur Korrektur systematischer Messfehler bei Eintor-Bauteilen (beispielsweise Last) verwendet.

Fehlerkorrektur, 12-Term- Fehlerkorrektur für Zweitor-Bauteile unter Verwendung von sechs Parametern:
Richtverhältnis
Quellenanpassung
Lastanpassung
Reflexionsfrequenzgang
Transmissionsfrequenzgang
Isolation

Zur vollständigen Charakterisierung eines Zweitor-Bauteils ist es erforderlich, diese sechs Parameter in Vorwärts- und Rückwärtsrichtung zu messen; dies ergibt insgesamt 12 Terme. Der Benutzer hat meist die Möglichkeit, der Isolationsteil der Kalibrierung auszulassen. Synonym: Vollständige 2-Port-Fehlerkorrektur.

Fehlerkorrektur, 1-Port- Korrigiert bei einem Testset die Richtverhältnis-, Frequenzgang- und Quellenanpassungsfehler für Port 1 oder Port 2. Der Prozess erfordert drei Kalibriernormale, beispielsweise Leerlauf, Kurzschluss und Last.

Fehlermeldung Eine auf dem Bildschirm angezeigte Meldung, die auf einen Fehler hinweist. Fehlermeldungen können verursacht werden durch fehlende oder defekte Hardware, Fehlbedienung oder sonstiger Zustände, die besondere Beachtung erfordern. Im allgemeinen kann die gewünschte Aktion oder Operation erst dann ausgeführt werden, wenn der fehlerhafte Zustand beseitigt ist.

ESD Electro Static Discharge. Elektrostatische Entladung.

Ethernet Ein Netzwerk, das dem LAN-Standard IEEE 802.3 entspricht.

Ethernet-Adresse Eine Hexadezimalzahl, die zur Identifikation eines vernetzten Gerätes dient. Jedem Analysator wird im Werk eine eindeutige Ethernet-Adresse zugeordnet, die im ROM des Analysators abgelegt wird.

Externes Triggersignal Ein TTL-Signal, das an den Analysator angelegt wird und eine Wobbelmessung oder ein ähnliches Ereignis auslöst; externe Triggerung dient dazu, den Analysator mit der externen Triggersignalquelle zu synchronisieren.

F

Filter Ein passives Bauteil, das bestimmte Frequenzen durchlässt und andere Frequenzen unterdrückt (je nach Filtertyp und Spezifikationen). Ein Hochpassfilter lässt nur Frequenzen oberhalb seiner Grenzfrequenz durch, ein Tiefpassfilter nur Frequenzen unterhalb seiner Grenzfrequenz, und ein Bandpassfilter nur Frequenzen zwischen zwei bestimmten Frequenzen.

Firmware Eine aus Hardware und Befehlscode bestehende Baugruppe. Die Hardware und der Befehlscode sind miteinander integriert und bilden eine funktionale Einheit, die während des normalen Betriebs nicht verändert werden kann. Der Befehlscode ist dauerhaft in der Schaltung oder in dem Gerät gespeichert und als ROM (Read Only Memory) klassifiziert. Die Firmware bestimmt das Betriebsverhalten des Messgerätes oder sonstigen Gerätes.

Frequenzgang Der Amplituden- und Phasenverlauf eines Messobjekts (DUT), einer Signalquelle, eines Empfängers, oder einer Kombination dieser Komponenten, über der Frequenz. Siehe auch Frequenzgang.

FM Frequenzmodulation.

Frequenz Die Anzahl der periodischen Schwingungen, Vibrationen oder Wellen pro Zeiteinheit, normalerweise in Schwingungen pro Sekunde oder Hertz (Hz) angegeben.

Frequenzgenauigkeit Die Unsicherheit, mit der die Frequenz eines Signals oder einer spektralen Komponente angezeigt wird (entweder absolut oder relativ zu einem anderen Signal oder einer anderen spektralen Komponente). Die absoluten und relativen Frequenzgenauigkeiten werden individuell spezifiziert.

Frequenzbereich Der Bereich von Frequenzen, über den die Performance eines Gerätes oder Messgerätes spezifiziert ist.

Frequenzauflösung Die Fähigkeit eines Netzwerkanalysators, Bauteilcharakteristiken bei nahe benachbarten Frequenzen zu messen und separat anzuzeigen. Die Auflösung für Antworten mit gleicher Amplitude wird durch die ZF-Bandbreite bestimmt. Die Auflösung für Antworten mit verschiedenen Amplituden wird durch die ZF-Bandbreite und den Formfaktor bestimmt.

Frequenzgang Die Spitze-Spitze-Schwankung der angezeigten Amplitude über einen bestimmten Frequenzbereich. Der Frequenzgang wird üblicherweise in "plusminus dB" angegeben.

Wobbelbandbreite Die Breite des von einer Messung erfassten Frequenzbereichs. Die Wobbelbandbreite entspricht der horizontalen Achse des Koordinatensystems. Im allgemeinen ist die Wobbelbandbreite auf die volle Bildschirmbreite bezogen. Einige Analysatoren beziehen die Wobbelbandbreite auf ein Skalenteil.

Frequenzstabilität Die Fähigkeit einer Frequenzkomponente, über kurze oder lange Zeitintervalle hinweg eine konstante Frequenz oder Amplitude beizubehalten. Die Stabilität bezieht sich auf die Fähigkeit eines Oszillators, eine bestimmte Frequenz über längere Zeit beizubehalten.

Frontplattentaste Eine Taste, die sich auf der Frontplatte eines Messgerätes befindet. Die Tastenbeschriftung gibt die Funktion der betreffenden Taste an. Beispiele für Frontplattentasten sind die Zifferntasten oder die Pfeiltasten.

Vollständige 2-Port-Fehlerkorrektur Siehe Fehlerkorrektur, 12-Term-.

Funktion Die Aktion oder der Zweck, für die/den ein bestimmtes Element vorgesehen ist. Der Netzwerkanalysator bietet Funktionen, die über die Frontplatte ausgeführt oder per Befehl ferngesteuert werden können. Die Charakteristiken dieser Funktionen werden von der Firmware des Gerätes bestimmt. In einigen Fällen sind komplexe Funktionen als DLP (Downloadable Program) implementiert, die dann ebenfalls über Frontplattentasten aufgerufen werden können.

Grundfrequenz Die Signalkomponente mit der niedrigsten Frequenz; alle übrigen Komponenten sind Oberwellen. Ein sinusförmiges Signal besteht nur aus einer einzigen Komponente, der Grundfrequenz.

G

Gb Gigabit

GB Gigabyte

GHz Gigahertz

GIF Graphics Interchange Format - Ein Standard-Dateiformat für Bitmap-Grafiken.

Giga Präfix für eine Milliarde.

GP I/0 General Purpose Input / Output; ein üblicherweise auf der Rückwand eines Messgerätes befindlicher Anschluss für die Kommunikation mit anderen Messgeräten, externen Testsets, Schaltern oder Computern. Über diesen Anschluss kann das Messgerät externe Geräte triggern oder von externen Geräten getriggert werden. Ein typisches Beispiel ist ein Fußschalter, mit dem die Messung angehalten und dann fortgesetzt werden kann, so dass der Benutzer beide Hände frei hat.

GPIB General Purpose Interface Bus - Der IEEE 488 Standard definiert ein Bussystem und ein Protokoll für die Kommunikation zwischen Messgeräten und einem Computer.

Gitterraster Ein von einem Gitter überzogener Bereich des Bildschirms, in dem die Messkurve dargestellt wird. Teilstriche am Rahmen oder auf den Achsen erleichtern das Ablesen interessierender Werte.

Gruppenlaufzeit Ein Maß für die Laufzeit eines Signals durch das Messobjekt, dargestellt über der Frequenz. Die Gruppenlaufzeit kann durch Bildung der ersten Ableitung des Transmissions-Phasenfrequenzgangs nach der Frequenz berechnet werden. Siehe auch AM-Gruppenlaufzeit und Phasenlinearitätsabweichung.

GUI Graphical User Interface. Grafische Benutzerschnittstelle.

H

Hardcopy Ausdruck von Daten auf Papier.

Hardkey Eine Frontplattentaste, die einer festen Funktion zugeordnet ist oder mit der ein einziges Softkey-Menü aufgerufen werden kann.

Horizontalreferenz Siehe Referenzpegel.

Horizontalauflösung Die Fähigkeit des Analysators, nahe benachbarte horizontale Datenpunkte über die volle Wobbelbandbreite aufzulösen.

Host-Computer Ein Computer oder ein Gerät innerhalb eines Netzwerks, der/das dem Endbenutzer Dienste wie z. B. Berechnungen oder Datenbankzugriff bereitstellt und üblicherweise Netzwerksteuerungsfunktionen ausführt.

Host-Name Ein eindeutiger Name zur Identifikation eines Host-Computers in einem Netzwerk. Der Host-Name ist direkt mit der IP-Adresse verknüpft und kann üblicherweise an deren Stelle verwendet werden. Der Host-Name wird üblicherweise vom Benutzer oder Systemverwalter vergeben.

HP Hewlett-Packard Company.

HPGL Hewlett-Packard Graphics Language.

HP-IB Hewlett-Packard Interface Bus. Eine Parallelschnittstelle, die es ermöglicht, mehrere Geräte in einer-"Daisy-Chain"-Konfiguration an einen Computer oder ein Messgerät anzuschließen. Das Schnittstellenprotokoll ist im Standard IEEE 488.2 spezifiziert; dieser ist zum Industriestandard GPIB äquivalent.

HTTP HyperText Transfer Protocol: Protokoll zur Übertragung von WWW- (World Wide Web) Datenverkehr.

Farbton (Hue). Die Farbdimension bezogen auf eine Wahrnehmungsskala, die von rot über gelb, grün und blau bis wieder zu rot reicht. Eine bestimmte Tönung oder Färbung.

I

I/O Input/Output. Ein-/Ausgang.

I/O Path Input/Output Path. Ein-/Ausgangspfad.

IEEE Institute of Electrical and Electronic Engineers.

ZF Zwischenfrequenz: Die Frequenz, die sich durch Mischen des HF-Eingangssignals mit dem Lokaloszillatorsignal ergibt.

Impedanz Das Verhältnis der Spannung zur Stromstärke an einem Anschluss einer Schaltung, ausgedrückt in Ohm.

Initialisieren Der Prozess, bei dem auf einem magnetischen Medium Speicherbereiche angelegt werden; dies ist Voraussetzung dafür, dass auf dem Medium später Dateien angelegt werden können.

Eingang Ein Signalpfad in einem Messgerät, der zum Anlegen eines externen Signals bestimmt ist.

Die meisten Netzwerkanalysatoren besitzen entweder drei Eingänge (A, B und R) oder vier Eingänge (A, B, R1 und R2). Eingänge sind nicht das gleiche wie Kanäle.

Eingangsabschwächer Ein Abschwächer zwischen dem Eingangssteckverbinder und dem ersten Mischer eines Spektrumanalysators (auch als HF-Abschwächer bezeichnet). Der Eingangsabschwächer dient dazu, den Signalpegel am Eingang des ersten Mischers auf einen geeigneten Wert einzustellen, und Verstärkungskompression durch hochpegelige oder breitbandige Signale zu verhindern. Er wird auch dazu benutzt, die Eigenverzerrungen des Analysators zu reduzieren und dadurch den Dynamikbereich zu optimieren. Bei einigen Analysatoren ändert sich beim Ändern der Eingangsabschwächung die Vertikalposition des Signals auf dem Bildschirm und damit auch der Referenzpegel. Bei den mikroprozessorgesteuerten Analysatoren von Agilent werden Änderungen der Eingangsabschwächung automatisch durch eine entsprechende Anpassung der ZF-Verstärkung kompensiert. Deshalb ändert sich die Signalposition auf dem Bildschirm nicht, und auch der Referenzpegel ändert sich nicht.

Einfügedämpfung Die Differenz der Leistungen vor und nach dem Einfügen eines Bauteils. Die Abschwächung zwischen dem Eingang und dem Ausgang eines Bauteils.

Intensität Helligkeit; Aussenden oder Reflektieren von Licht; Leuchtkraft.

Schnittstelle Ein Anschluss, der eine Kommunikationsverbindung zwischen zwei oder mehr Geräten ermöglicht.

Intermodulationsverzerrung Unerwünschte Frequenzkomponenten, resultierend aus der Interaktion von zwei oder mehr spektralen Komponenten, die ein Bauteil mit nichtlinearer Kennlinie (beispielsweise Mischer oder Verstärker) durchlaufen. Die Frequenzen der unerwünschten Komponenten sind darstellbar als Summen und Differenzen der Grundfrequenzen und diverser Oberwellen. Der Algorithmus lautet: f1 ±f2, 2xf1 ±f2, 2xf2±f1, 3xf1 ±2x f2 usw.

Internet Die Verbindung von zwei oder mehr Einzelnetzen. Oft wird die Verbindung über ein Gateway oder einen Router hergestellt.

Interpolation Die Bestimmung eines zwischen zwei benachbarten Punkten liegenden Signalwertes mit Hilfe einer Prozedur oder eines Algorithmus.

IP Internet Protocol.

IP-Adresse Internet Protocol Address: Eine eindeutige Nummer, die jedem Gerät zugeordnet wird, das an ein TCP/IP-Netzwerk angeschlossen wird. Bevor Sie einen Analysator an einem Netzwerk betreiben können, muss Ihr Netzwerkverwalter ihm eine IP-Adresse zuweisen. Eine IP-Adresse besteht aus einem 32-bit-Wert in Dezimalpunkt-Notation: 4 Oktette (Bytes), getrennt durch einen Punkt.

ISDN Integrated Services Digital Network: Ein Standard-Digitaldienst mit einem oder mehr verbindungsorientierten Kommunikationskanälen zur Übertragung digitaler Sprach-, Daten- oder Bildsignale sowie einem paketorientierten Kanal für Außerband-Signalisierung und Steuerung. Zusätzlich bietet ISDN eine Reihe von standardmäßigen und optionalen Leistungsmerkmalen, die die Informationsproduktivität für den Benutzer steigern, indem sie einen schnelleren Internet-Zugang als analoge Systeme ermöglichen.

ISO International Standards Organization.

Isolation Eine Spezifikation oder ein Maß für die Immunität eines Signals gegenüber einem anderen, benachbarten Signal. Das Auftreten ist als Übersprechen bekannt.

Isolator Ein HF-Bauteil, das zur Isolation zwischen Pfaden und Bauteilen verwendet wird. Einen Isolator erhält man, wenn man bei einem 3-Port-Zirkulator den dritten Port mit einer 50-Ohm-Last abschließt.

J

K

Kilo Präfix für Eintausend.

KB Kilobyte

Kb/s Kilobyte pro Sekunde.

L

LAN Local Area Network. Lokales Netzwerk.

LANS LAN-System.

LCDFlüssigkristallanzeige.

LED Leuchtdiode.

LIF Logical Interchange Format (von älteren HP-Diskettenlaufwerke/Computern verwendet).

Grenzwertlinien Vom Benutzer definierte Linien, die der Messkurve überlagert werden und den zulässigen Toleranzbereich kennzeichnen; der Analysator kann die Messkurve automatisch mit den Grenzwertlinien vergleichen und erkennen, wenn sie außerhalb des zulässigen Bereichs liegt. Bei einer Grenzwertverletzung kann das Gerät eine "Fail"-Meldung anzeigen, einen Alarmton erzeugen oder ein Steuersignal ausgeben, um den Benutzer oder einen Computer über die Grenzwertverletzung zu unterrichten.

Grenzwertliniendatei Die im Benutzerspeicher abgelegte Datei mit den Grenzwerttabellen-Einträgen.

Grenzwerttabelle Die Segmente, aus denen sich eine Grenzwertlinie zusammensetzt, werden in der Grenzwerttabelle gespeichert. Zur Bearbeitung der Segmente kann die Tabelle auf dem Bildschirm angezeigt werden. Nach der Bearbeitung kann sie wieder in die Datei zurückgespeichert werden.

Lineares Bauteil Ein Bauteil, bei dem die Ausgangsspannung proportional zur Eingangsspannung ist.

LO Lokaloszillator. In einem Superhet- (Überlagerungsempfänger) System wird das LO-Ausgangssignal mit dem HF-Eingangssignal gemischt; das resultierende Summen- oder Differenzsignal ergibt die Empfänger-Zwischenfrequenz (ZF).

LO-Durchgriff Das Response-Signal, das sich in einem Superhet-System ergibt, wenn die Frequenz des ersten Lokaloszillators gleich der ersten Zwischenfrequenz ist.

Last Ein Eintor-Mikrowellenbauteil, das dazu verwendet wird, einen Pfad mit der Systemimpedanz abzuschließen.

Lastanpassung Ein Maß dafür, wie nahe die Abschlussimpedanz des Bauteils dem idealen Systemimpedanzwert kommt. Die Anpassung wird üblicherweise als Rückflussdämpfung oder Stehwellenverhältnis (SWR) der Last gemessen.

"Local Lock Out" Ein Zustand oder Befehl, der die Frontplatte des Analysators gegen manuelle Eingaben sperrt (und die Taste "Local" deaktiviert).

Lokalbetrieb Manuelle Bedienung über die Frontplatte.

Log Logarithmus.

"Log"-Format Ein Darstellungsformat, bei dem die vertikale Auslenkung eine logarithmische Funktion der Eingangssignalamplitude ist. Das "Log"-Format wird auch als logarithmisches Format bezeichnet. Die Skala wird durch die Referenzpegelposition und den Skalenfaktor in dB pro Skalenteil bestimmt.

LRM Line-Reflect-Match. Siehe Kalibrierung, TRL und LRM.

M

Amplitudenbetrag Die Amplitude eines Signals, gemessen bei Abschluss mit der Systemimpedanz ohne Berücksichtigung der Phase. Siehe auch Skalar.

Marker Ein grafisches Symbol auf der Messkurve mit einer zugeordneten Anzeige zur Bestimmung der numerischen Messdaten an dem markierten Punkt.

Marker-Funktionen Mathematische oder statistische Berechnungen auf den Messdaten von einem oder mehreren Markern, die dem Benutzer zusätzliche Informationen liefern. Die Marker-Delta-Funktion, beispielsweise, berechnet die Differenz zwischen zwei Markern und zeigt diese an.

Maximal zulässiger Eingangssignalpegel Der maximale Signalpegel, der an den Analysatoreingang angelegt werden darf, ohne eine Beschädigung des Eingangs zu riskieren. Der maximal zulässige Eingangssignalpegel beträgt bei Spektrumanalysatoren von Agilent typischerweise 1 W (+30 dBm).

MB Megabyte.

Messunsicherheit Der quantifizierte Betrag des Fehlers in einer Messsituation. Kalibrierungen sind dazu gedacht, die Messunsicherheit zu reduzieren. Dies sind die Quellen für Messfehler, die zu Messunsicherheit führen:

  • Systematische Fehler (Unzulänglichkeiten von Kalibriernormalen, Steckverbindern, Kabeln und Messgeräten)

  • Zufällige Fehler (Rauschen, Steckverbinder-Reproduzierbarkeit)

  • Drift (Quelle und Messgerät)

Mega Präfix für eine Million.

Speicher Ein Speichermedium, Speichergerät oder Aufzeichnungsmedium, auf das Daten abgespeichert und von dem die ursprünglichen Daten später wieder gelesen werden können.

Speicherkarte Ein kleines Speichergerät mit den Abmessungen einer Kreditkarte, auf dem Daten oder Programme gespeichert werden können.

Menü Die Analysatorfunktionen, die auf dem Bildschirm angezeigt und durch Drücken von Frontplattentasten gewählt werden können. Beim Wählen einer solchen Funktion werden u. U. andere, verwandte Funktionen aufgerufen, die zusammen Gruppen bilden; diese werden als Menüs bezeichnet.

MHz Megahertz.

milli Präfix für ein Tausendstel.

Modem Modulator/Demodulator.

Modulation Der Prozess (oder das Ergebnis dieses Prozesses) der Veränderung einer Charakteristik eines Trägersignals in Abhängigkeit von einem anderen Signal, mit dem Ziel, dem Trägersignal eine Information aufzuprägen. Siehe AM und FM.

Monitor Ein externer Bildschirm.

Monochrom Ein Bildschirm, der nur eine Farbe darstellen kann.

ms Millisekunden.

mW Milliwatt: ein tausendstel Watt.

Multisync Ein Monitortyp, der seine Horizontalfrequenz automatisch auf unterschiedliche Frequenzen innerhalb eines spezifizierten Bereichs einstellen kann.

N

Schmalband In der Netzwerkanalyse die ZF-Bandbreite des analysatorinternen Empfängers, die ausreichend klein ist, um die Amplituden- und Phasencharakteristiken schmalbandiger Bauteile messen zu können. Durch Reduzieren der ZF-Bandbreite lässt sich das Eigenrauschen des Empfängers verringern und dadurch der Dynamikbereich vergrößern.

Schmalband-Bauteil Ein Bauteil, dessen Übertragungscharakteristiken für den Betrieb innerhalb eines sehr schmalen Frequenzbereichs ausgelegt sind, und das innerhalb dieses Frequenzbereichs einen exakt definierten Amplitudenfrequenzgang aufweist. Ein typisches Beispiel ist ein Bandpassfilter.

Netzwerkanalyse Die Charakterisierung eines Bauteils, einer Schaltung oder eines Systems durch Vergleichen des Ausgangssignals mit dem Eingangssignal.

NIST National Institute of Standards and Technology.

Nit Luminanz-Maßeinheit (photometrische Helligkeit) 1 Nit = 1 Candela pro Quadratmeter.

Rauschen Zufällige Schwankungen von unerwünschter oder störender Energie in einem Kommunikationssystem, welche die vom Signal transportierte Information beeinträchtigen oder verfälschen können. Rauschen kann aus technischen oder natürlichen Quellen stammen. Siehe auch Signal/Rauschabstand.

Rauschzahl (F): Bei einem Zweitor-Bauteil ein Maß dafür, wie stark das Eigenrauschen des Bauteils den Signal/Rauschabstand eines mit 290 Grad durch das Bauteil fließenden Signals verschlechtert. Die Rauschzahl wird üblicherweise in dB ausgedrückt.

Eigenrauschen Das vom Analysator selbst erzeugte Rauschen. Der kleinste messbare Signalpegel wird oft durch das Eigenrauschen bestimmt. Bei der Netzwerkanalyse werden zur Messung des Eigenrauschens die Messanschlüsse mit der Systemimpedanz abgeschlossen; es wird eine vollständige 2-Port-Kalibrierung durchgeführt; die Messung erfolgt mit einer ZF-Bandbreite von 10 Hz bei maximalem Signalquellenpegel und ohne Mittelung.

Nicht direkt anschließbare Bauteile Bei der Kalibrierung: ein Bauteil, das nicht direkt anstelle eines Durchgangs der Länge Null angeschlossen werden kann. Es besitzt an beiden Anschlüssen Steckverbinder des gleichen Typs und Geschlechts, oder an jedem Anschluss einen unterschiedlichen Steckverbindertyp.

Nichtflüchtiger Speicher Ein Speicher, bei dem die gespeicherten Daten auch beim Abschalten des Gerätes oder bei einem Ausfall der Netzspannung erhalten bleiben. Solche Speicher werden typischerweise durch eine Batterie gespeist. Sie werden auch als batteriegepuffertes RAM bezeichnet.

Normieren Eine Messkurve von einer anderen subtrahieren, um Kalibrierdatenfehler zu eliminieren oder relative Werte zu erhalten.

O

Offset Verschiebung einer Größe um einen bestimmten Betrag. Wird in Messgeräten zur Verschiebung von Frequenzen, Grenzwerten, Verzögerungen, Dämpfungen, Impedanzen usw. verwendet.

Ausgangsabschwächung Die Fähigkeit, das Signal, die Quelle, abzuschwächen, um deren Signalpegel zu steuern.

P

PC Personal Computer.

PDF Portable Document Format (hauptsächlich im World Wide Web verwendet).

Parser, Befehls- Eine Software-Routine, die Fernsteuerungsbefehle aus dem Eingangspuffer eines Gerätes in der gleichen Reihenfolge ausliest, wie sie vom Controller hineingeschrieben wurden. Der Parser bestimmt, welche Aktionen der Analysator auszuführen hat. Eine der wichtigsten Funktionen des Befehlsparsers ist, die Position eines Fernsteuerungsbefehls innerhalb des SCPI-Befehlsbaums des Analysators zu bestimmen. Wenn der Befehlsparser zurückgesetzt wird, nimmt er an, dass das nächste empfangene Element von der Wurzel des Befehlsbaums stammt.

"Peak Search"-Funktion Eine Analysatorfunktion, die das stärkste Signal in der Messkurve sucht und einen Marker darauf setzt.

Phase Der Bruchteil eines Zyklus, den eine Schwingung zurückgelegt hat, bezogen auf einen beliebig wählbaren Ausgangspunkt; wird üblicherweise in rad oder Grad gemessen. Bei der Netzwerkanalyse ist der Phasenfrequenzgang des Messobjekts die Phasenverschiebung zwischen dem Ausgangssignal und dem Eingangssignal des Messobjekts, dargestellt über der Frequenz.

Port Ein Anschluss (Eingang oder Ausgang) eines Messgerätes oder Bauteils.

Messebenenverschiebung Die (mathematische) Verschiebung der Messebene gegenüber deren Position während der Kalibrierung. Eine neue Messebene wird definiert in Sekunden Laufzeit, bezogen auf den Messanschluss.

Positive Spitze Der maximale Momentanwert eines Eingangssignals.

Postscript (.ps Dateien) Solche Dateien speichern Bitmap-Grafikdateien in einem eingekapselten Format, das von postscript-fähigen Druckern direkt verarbeitet werden kann.

Eingangspegel, Übersteuerungs- Der maximale Eingangspegel, für den die Spezifikationen gelten. Einige Spezifikationen beziehen sich auf unterschiedliche maximale Eingangspegel. Beispielsweise ist der Kompressions-Übersteuerungspegel üblicherweise höher als der maximale Oberwellenverzerrungs-Übersteuerungspegel.

Eingangspegel, maximal zulässiger Der Eingangspegel (üblicherweise in dBm), der auf keinen Fall überschritten werden darf, da das Gerät sonst beschädigt werden kann.

Preset Ein vordefinierter Gerätezustand (der auch einen Analysator-Selbsttest initiiert). Durch Drücken der Taste "Preset" können Sie den Analysator in diesen Zustand bringen.

Protokoll Eine Gesamtheit von Konventionen, die spezifizieren, wie Informationen formatiert und über ein Netzwerk übertragen werden, und wie die an einem Netzwerk angeschlossenen Geräte kommunizieren.

Q

Q oder Gütefaktor Das Verhältnis der gespeicherten Energie zur verlorenen Energie in einem Resonanzkreis. Ein hoher Q-Wert ergibt eine ausgeprägte Resonanz im Frequenzgang.

Abfrage Ein Fernsteuerungsbefehl, der das adressierte Gerät zum Senden einer Antwort auffordert. Diese Befehle enden mit einem Fragezeichen (?). Abfragebefehle liefern eine Information an den Computer zurück.

R

r + jx Ausdruck für die komplexe Impedanz, wobei r die resistive Komponente und x die reaktive Komponente repräsentiert.

R Channel Referenzkanal.

RAM Random Access Memory, ein Schreib-/Lese-Speicher. Ein Speicherbereich, der den Zugriff auf einen beliebigen seiner Speicherplätze erlaubt. Daten können in ein RAM geschrieben und von dort gelesen werden; die Datenspeicherung ist jedoch flüchtig. Wenn die Betriebsspannung unterbrochen wird, gehen die Daten verloren. Vom Benutzer generierte Informationen, die auf einem Bildschirm angezeigt werden, sind RAM-Daten.

ROM Read Only Memory: Nur-Lese-Speicher. Ein Speicherbereich, der nur gelesen, aber nicht vom Benutzer verändert oder beschrieben werden kann. Bei Messgeräten der Speicherbereich, der die Firmware enthält.

Empfänger Eine Schaltung oder ein System, das für den Empfang und/oder die Messung von Signalen innerhalb eines bestimmten Frequenzbereichs bestimmt ist.

Empfängerdynamikbereich Siehe Dynamikbereich.

Referenzpegel Eine Messgerätefunktion, die es dem Benutzer erlaubt, den Amplitudenwert für die Referenzposition einzustellen. Bei Netzwerkanalysatoren ist auch die Referenzposition wählbar. Bei einigen Spektrumanalysatoren ist die Referenzpegel fest bei der obersten Gitterrasterlinie.

Messebene Die elektrische Position, die der Netzwerkanalysator als das Ende der Systemsteckverbinder und Testadapter und den Anfang des Messobjekts betrachtet. Die Messebene wird durch Verwendung von Kalibriernormalen mit bekannter elektrischer Länge vorgegeben. Je näher die Messebene am Messobjekt liegt, desto genauer sind die Messungen, weil die systematische Messunsicherheit geringer ist.

Reflexion Das Phänomen, bei dem eine sich fortpflanzende Welle auf eine Diskontinuität trifft und ein Teil der Energie zum Ausgangspunkt zurückkehrt.

Reflexionskoeffizient Das Verhältnis der von einem Wellenleiter oder einer Schaltung reflektierten Spannung zu der in den Wellenleiter oder die Schaltung einfallenden Spannung. Der Reflexionskoeffizient eines mit seinem Wellenwiderstand abgeschlossenen Wellenleiters ist Null. Der Reflexionskoeffizient eines kurzgeschlossenen Wellenleiters ist 1. Siehe auch Rückflussdämpfung und SWR.

Reflexionsmessungen Messungen, die das Eingangs- und/oder Ausgangsverhalten des Messobjekts charakterisieren. Gemessen als das Verhältnis des reflektierten Signals zum einfallenden Signal als Funktion der Frequenz. Die werden werden Rückflussdämpfung, Reflexionskoeffizient, Impedanz und Stehwellenverhältnis (SWR) genannt, alle als Funktion der Frequenz. Siehe auch S-Parameter.

Fernsteuerungsbetrieb Eine Betriebsart, in der ein Messgerät von einem anderen Gerät (oder Computer) über die GPIB-Schnittstelle ferngesteuert wird. In dieser Betriebsart sind die Frontplattentasten ohne Funktion. Die Bedienung über die Frontplatte wird als Lokalbetrieb bezeichnet.

Fernsteuerung Die Steuerung eines Messgerätes durch einen Computer, üblicherweise über eine GPIB-, LAN- oder RS-232-Verbindung.

Auflösung Die Fähigkeit eines Empfängers, zwei Signale separat aufzulösen.

Auflösebandbreite Die Fähigkeit eines Spektrumanalysators, benachbarte Signale separat anzuzeigen (Hertz, Hertz Decibel nach unten). Dieser Term identifiziert die Breite des Auflösebandbreitenfilters eines Spektrumanalysators bei einem Pegel unterhalb dem Punkt minimaler Einfügedämpfung (Punkt maximaler Ablenkung auf dem Bildschirm). Typischerweise ist dies die spezifizierte 3 dB-Auflösebandbreite, aber in einigen Fällen wird die 6 dB-Auflösebandbreite spezifiziert.

Rückflussdämpfung Der Betrag in dB, um den das reflektierte Signal unter dem einfallenden Signal liegt. Falls kein Signal reflektiert wird, ist die Impedanz des Bauteils gleich der Systemimpedanz des Übertragungssystems, und die Rückflussdämpfung unendlich. Falls das gesamte einfallende Signal reflektiert wird, ist die Rückflussdämpfung null. Siehe auch S-Parameter, Reflexionskoeffizient und SWR.

Rückwärtsmessung Die Messung eines Bauteils vom Ausgang zum Eingang.

HF Hochfrequenz (von etwa 50 kHz bis etwa 3 GHz). Bezeichnet üblicherweise ein drahtlos übertragenes Signal.

ROM Read Only Memory

S

S/N Signal-to-Noise Ratio. Signal/Rauschabstand.

Sampler Eine elektronische Baugruppe, die den Signalpegel und die Phase an einer bekannten Impedanz in gleichmäßigen Zeitabständen erfasst. Bei Netzwerkanalysatoren muss die Abtastrate groß genug sein und genau genug eingehalten werden, damit genaue Messungen möglich sind. Netzwerkanalysatoren enthalten typischerweise drei oder vier Sampler oder Mischer.

"Sampler Bounce" Das Übersprechen zwischen den Samplern in einem Netzwerkanalysator. Verzögerung in diesem Übersprechen, verursacht durch Lecktransmissionspropagation gibt dem Übersprechen sein "bounce"-artiges Aussehen. Das "Sampler bounce" vergrößert den Rauschpegel des betroffenen Kanals und verringert dadurch die Empfindlichkeit des Analysators.

Sättigung Der Grad der Farbreinheit, auf einer Skala von weiß bis zu reiner Farbe.

Skalar Eine Größe, die einen Betrag, aber keine Phase besitzt. Ein Skalar-Netzwerkanalysator kann nur den Amplitudenbetrag messen.

Skalierung Die Kalibrierung der Y-Achse in Einheiten pro Skalenteil.

SCPI Standard Commands for Programmable Instruments.

Bildschirm Die physische Oberfläche des Kathodenstrahlröhren- oder Flachbildschirms, auf dem die Messergebnisse, Setup-Informationen, Softkey-Funktionen und andere Messgeräte-Kommunikation angezeigt werden.

Selbsttest Eine Reihe von Tests, die das Gerät nach dem Einschalten (oder nach einem Preset) automatisch durchführt und die dazu dienen, die Funktionsfähigkeit des Gerätes zu verifizieren.

Empfindlichkeit Der Mindest-Eingangssignalpegel, der notwendig ist, um ein spezifiziertes Ausgangssignal zu erzeugen, das einen spezifizierten Signal/Rauschabstand aufweist oder einem sonstigen spezifizierten Kriterium entspricht.

Bei einem Spektrumanalysator das schwächste Sinussignal, das beobachtet werden kann, üblicherweise unter optimierten Bedingungen – minimale Auflösebandbreite, 0 dB Eingangsabschwächung und minimale Videobandbreite.

Die normierte Änderung der Mittenfrequenz des YIG-Filters, die aus einer Änderung des Abstimmspulenstroms resultiert, spezifiziert in MHz/mA.

Seriennummern-Präfix Die Geräte-Seriennummer beginnt mit einem aus fünf Zeichen bestehenden Präfix, der dazu dient, zwischen verschiedenen Firmware-Versionen oder Hardware-Änderungen zu unterscheiden.

Server Ein Gerät, das dazu bestimmt ist, anderen Geräten in einem Netzwerk bestimmte Dienste zur Verfügung zu stellen, beispielsweise den gemeinsamen Zugriff auf ein Dateisystem oder einen Drucker.

Signal/Rauschabstand SNR: Das Verhältnis der Amplitude des Nutzsignals zur Amplitude des unerwünschten Signals, normalerweise ausgedrückt in dB und als Spitzenwerte für Impulsrauschen bzw. Effektivwerte für zufälliges Rauschen.

Einzelwobbelung Der Spektrumanalysator führt eine einzige Wobbelmessung durch, sobald die Triggerbedingungen erfüllt sind. Jede Wobbelung wird ausgelöst durch Drücken der entsprechenden Taste oder durch einen Fernsteuerungsbefehl.

Kleinsignalverstärkung Eine Situation, wenn die gemessene Amplitude des Eingangssignals aufgrund einer Übersteuerung des Netzwerkanalysator-Eingangsmischers kleiner ist als deren tatsächlicher Wert. Der Analysator arbeitet in diesem Fall im nichtlinearen Bereich. Bei Breitbanddetektoren kann ein Störsignal den Analysator in den Bereich der Signalkompression treiben; dies kann bewirken, dass schwache Signale noch schwächer erscheinen, als sie tatsächlich sind. In der Breitbandbetriebsart wird die gesamte Leistung am Empfängereingang gemessen, nicht nur die Leistung der Signale mit der jeweils interessierenden Frequenz.

Smith-Diagramm Eine grafische Darstellung des komplexen Reflexionskoeffizienten, abgebildet auf die normierte komplexe Impedanz. Die Kreise in dem Diagramm repräsentieren Ortskurven konstanten Widerstands; die Linien senkrecht zu den Kreisen repräsentieren Ortskurven konstanter Reaktanz. Der Mittelpunkt des Diagramms repräsentiert die Systemimpedanz. Jeder Punkt in dem Diagramm entspricht einer bestimmten komplexen Impedanz. EIne Line im Diagramm repräsentiert eine Impedanzänderung über der Frequenz.

SOLT "Source-Open-Load-Through"-Kalibrierung. Siehe auch Calibration, SOLT.

Signalquelle Ein Gerät, das eine Signalleistung liefert – beispielsweise ein Wobbelgenerator oder Synthesizer-Wobbelgenerator.

Signalquellen-Amplitudengenauigkeit Die Amplitudenunsicherheit (in dB) des angezeigten Signalquellenpegels.

Signalquellenfrequenzgang Der Amplitudenfrequenzgang (in dB) der Signalquelle über den spezifizierten Frequenzbereich.

Signalquellenfrequenzauflösung Die kleinste Frequenzschrittweite (in Hz), die eingestellt und/oder gemessen werden kann.

Signalquellen-Zeitbasisgenauigkeit Ein Maß für die Frequenzstabilität des Analysators, ausgedrückt in ppm (parts per million, 1 zu 10E6). Eine Stabilität von ±5,0 ppm, beispielsweise, bedeutet, dass der Analysator eine Frequenz von 1 MHz mit einer Genauigkeit von ±5 x 10-6 x 10E6 Hz = +5 Hz bestimmt.

Signalquellen-Zeitbasisstabilität Ein Maß für die Zeitbasisgenauigkeit des Analysators in Abhängigkeit von Zeit und Temperatur. Die Zeitbasisgenauigkeit wird typischerweise für einen Zeitraum von einem Jahr spezifiziert. Eine typische Frequenzstabilität in Abhängigkeit von der Temperatur ist ±10 ppm für 250 C±50 C.

Signalquellen-Oberwellen Der Pegel der von der analysatorinternen Signalquellen erzeugten Oberwellen, in dBc (= dB bezogen auf Grundwellenpegel).

Quellenanpassung Ein Maß dafür, wie nahe die Ausgangsimpedanz der Signalquelle der Systemimpedanz kommt. Die Anpassung wird üblicherweise als Rückflussdämpfung oder Stehwellenverhältnis (SWR) der Quelle gemessen.

Wobbelbandbreite Die Differenz zwischen Stop-Frequenz und Start-Frequenz. Die Wobbelbandbreiteneinstellung bestimmt die horizontale Skalierung der Messkurve.

Frequenzabstandsgenauigkeit Die Unsicherheit des angezeigten Frequenzabstands zweier auf dem Bildschirm angezeigter Signale.

S-Parameter (Streuparameter) Eine Konvention, mit Hilfe eines Netzwerkanalysators die Art und Weise zu charakterisieren, in welcher ein Bauteil den Signalfluss verändert. Ein Zweitor-Bauteil besitzt vier S-Parameter: Vorwärtsübertragungskoeffizient (S21), Rückwärtsübertragungskoeffizient (S12), Vorwärtsreflexionskoeffizient (S11) und Rückwärtsreflexionskoeffizient (S22).

Stop/Start-Frequenz Begriffe, die in Verbindung mit den Start- und Stop-Punkten des Frequenzmessbereichs verwendet werden. Zusammen bestimmen sie die Wobbelbandbreite.

Speicherzustände Die Anzahl der Einstellungen, Programme, Messkurven und sonstiger Parameter, die zu einem bestimmten Zeitpunkt verfügbar sind, um abgespeichert, katalogisiert und zurückgeladen zu werden.

Speicherlaufwerk Ein internes oder externes Laufwerk zum Speichern von Messdaten, Geräteeinstellungen, IBASIC-Programmen und sonstigen Messparametern. Unterstützte Speicherformate: MS-DOS (R) und HP-Standard LIF mit Binär-, PCX-, HP-GL oder ASCII-Datenformaten.

Strukturelle Rückflussdämpfung Schlechte Rückflussdämpfung in einem Kabel aufgrund eines periodischen Fehlers wie z. B. einer periodischen Delle, die dadurch entstand, dass die Kabelrolle hingefallen ist, oder die auf das Ziehen des Kabels während der Herstellung zurückzuführen ist.

Ergänzende technische Daten Typische, aber nicht garantierte technische Daten, bezeichnet als "typisch", "Nennwert" oder "ca.".

Wobbelung Die Fähigkeit der Signalquelle, einen spezifizierten Signalpegel über einen spezifizierten Frequenzbereich innerhalb einer spezifizierten Zeitdauer bereitzustellen. Siehe auch Wobbelbetriebsart und Wobbelungstyp.

Im Datenverarbeitungsmodus eine Folge von Messungen bei aufeinanderfolgenden Datenpunkten über eine Folge von Stimuluswerten.

"Sweep Mode" Die Art und Weise, wie eine Wobbelung initiiert oder gewählt wird, beispielsweise "single", "continuous", "alternate" oder "chopped".

"Sweep Type" Die Wobbelcharakteristik, beispielsweise linear, logarithmisch oder stufenweise.

Wobbelgenerator Eine Signalquelle, die ein Signal mit kontinuierlich durchgestimmter Frequenz liefert.

SWR Standing Wave Ratio, Stehwellenverhältnis. SWR = (1 + p) / (1 -p) wobei p den Reflexionskoeffizienten bezeichnet.

Sync Synchronisation oder synchronisiert.

Syntax Die grammatischen Regeln, die spezifizieren, wie die Befehle eines Betriebssystems, einer Programmierspannung oder einer Anwendung strukturiert sein müssen.

System-Dynamikbereich Die Differenz zwischen dem maximal zulässigen Empfängereingangspegel und dem Empfängereigenrauschpegel. Der System-Dynamikbereich gilt nur für Transmissionsmessungen; bei Reflexionsmessungen wird der Dynamikbereich durch das Richtverhältnis begrenzt.

T

T/R Siehe Transmission/Reflexion.

Abschluss Eine an einem Wellenleiter oder einem sonstigen Bauteil angeschlossene Last.

Toleranz (zulässige) Der Bereich, in dem die Messwerte liegen müssen, damit sie als akzeptabel gelten.

Messanschluss Siehe Port.

Testset Eine für S-Parameter-Messungen verwendete Hardware-Kombination (bestehend aus Schaltern, Kopplern, Steckverbindern und Kabeln), welche den Eingang und den Ausgang des Messobjekts mit der Signalquellenausgang bzw. dem Empfängereingang des Analysators verbindet.

Third Order Intercept TOI: Intercept-Punkt 3. Ordnung. Der Pegel am Eingang eines nichtlinearen Bauteils, bei dem der Pegel der Oberwellenverzerrungen gleich dem Eingangspegel ist. Die TOI-Spezifikation ist ein Maß für das Verzerrungsverhalten eines Mischers oder Empfängers. Je größer der Wert ist, desto weniger Eigenverzerrungen produziert der Empfänger.

Thru Durchgangsverbindung: Ein Kalibriernormal. Siehe Calibration, SOLT.

"Tint" Ein Farbton.

Umschalter Ein Schalter, mit dem Sie zwischen zwei Zuständen umschalten (beispielsweise eine Funktion ein-/ausschalten) können.

TOM Thru-Open-Match: Eine von Rohde&Schwarz verwendete Bezeichnung für ein Kalibrierverfahren.

Messkurve Eine Folge von Datenpunkten, die Frequenz- und Response-Informationen repräsentieren. Die Folge von Datenpunkten wird häufig als ein "Array" bezeichnet. Die Anzahl der Messpunkte ist gerätespezifisch.

Gleichlauf Die Fähigkeit des analysatorinternen Empfängers, während der Wobbelung seine Mittenfrequenz der Frequenz des Stimulussignals nachzuführen. Ein schlechter Gleichlauf verursacht Amplituden- und Phasenfehler.

Übertragungsfunktion Das Verhältnis der Ausgangssignalleistung zur Stimulussignalleistung in Abhängigkeit von der Frequenz.

Transmission Siehe Transmissionsmessungen.

Transmissions-Intermodulationsnebenwellen Ein Maß für die Fähigkeit des Senders, die Erzeugung von Intermodulationsverzerrungen zu verhindern. Die Intermodulationsoberwellen werden manchmals auch als Intermodulationsdämpfung bezeichnet.

Transmissionsmessungen Die Charakterisierung der Übertragungsfunktion eines Bauteils, d. h. des Verhältnisses der Ausgangssignalleistung zur Eingangssignalleistung. Die häufigsten Messungen sind: Verstärkung, Einfügedämpfung, Transmissionskoeffizient, Phase und Gruppenlaufzeit, jeweils über der Frequenz gemessen. Siehe auch S-Parameter.

Transmission/Reflexion (T/R) Bezieht sich auf die Folge von Messungen mit einem Skalar- oder Vektornetzwerkanalysator zur Charakterisierung des Frequenzverhaltens eines Bauteils. Siehe auch S-Parameter.

Transparent Etwas, das für den Benutzer unsichtbar ist. Üblicherweise eine Prozedur, die auftritt, ohne dass der Benutzer sie initialisiert oder davon weiß.

Trigger Ein Signal, das den Analysator zu einer Messung veranlasst. Der Benutzer kann zwischen mehreren Trigger-Optionen wählen, beispielsweise manuell, kontinuierlich oder extern (für die Synchronisation von Messungen mit einer externen Signalquelle).

TRL Through-Reflect-Line. Siehe Kalibrierung, TRL und LRM.

TTL Transistor-Transistor-Logik.

2-Port-Fehlerkorrektur Siehe Fehlerkorrektur, 12-Term-.

U

Nicht-korrigierte Messung Eine ohne Fehlerkorrektur durchgeführte Messung.

Entkoppelte Kanäle Die Signalquellen- oder Empfängereinstellungen können für jeden Kanal individuell vorgegeben werden.

UNI User-Network Interface: Der Punkt, an dem die Benutzer an das Netzwerk angeschlossen sind.

Einheiten Maßeinheiten der gemessenen Größen. "Einheiten" bezieht sich meist auf Amplitudeneinheiten, weil diese geändert werden können. Bei Analysatoren mit Mikroprozessoren sind folgende Maßeinheiten verfügbar: dBm (dB bezogen auf 1 mW Leistung an einer Last mit Systemimpedanz), dBmV (dB bezogen auf 1 mV), dBW (dB bezogen auf 1 1W), V (Volt), W (Watt).

V

Variable Ein Symbol, dessen Wert sich entweder von einer Iteration eines Programms zum nächsten ändert oder innerhalb jeder Iteration eines Programms.

Vektor Eine Größe, die sowohl einen Betrag als auch eine Phase besitzt.

Ein Vektornetzwerkanalysator kann sowohl den Amplitudenbetrag als auch die Phase messen.

VEE Visual Engineering Environment (ein Softwareprodukt von Agilent).

Vertikalauflösung Der Grad, zu dem ein Messgerät die Amplitude zwischen zwei Signalen unterscheiden kann.

Ausbreitungsgeschwindigkeitsfaktor Ein numerischer Wert, der das Verhältnis der Signalausbreitungsgeschwindigkeit in einem Dielektrikum zur Lichtgeschwindigkeit im Vakuum angibt. Der Ausbreitungsgeschwindigkeitsfaktor von Polyethylen ist 0,66). Dieser Wert wird in Zeitbereichmessungen verwendet.

Video Ein elektrisches Signal, das Timing-, Intensitäts- und oft auch Farbinformationen enthält, die auf einem Bildschirm dargestellt, ein Bild ergeben.

Videobandbreite Bei Spektrumanalysatoren die Grenzfrequenz (–3-dB-Punkt) eines einstellbaren Tiefpassfilters in der Video-Baugruppe. Wenn die Videobandbreite kleiner oder gleich der Auflösebandbreite ist, kann die Video-Baugruppe den schnelleren Schwankungen der Hüllkurvendetektor-Ausgangssignals nicht schnell genug folgen. Dies bewirkt eine Glättung der Messkurve bzw. bei breitbandigen Signalen wie Rauschen oder gepulster HF in Breitbanddarstellung eine Reduktion der Spitze-Spitze-Auslenkung. Das Ausmaß der Mittelung oder Glättung ist eine Funktion des Verhältnisses der Videobandbreite zur Auflösebandbreite.

Video-Filter Bei Spektrumanalysatoren ein hinter dem Detektor angeordnetes Tiefpassfilter, das die Bandbreite des Video-Verstärkers bestimmt. Es wird zur Mittelung oder Glättung der Messkurve verwendet. Siehe auch Videobandbreite.

VNA Vektornetzwerkanalysator.

W

Signalform Eine Darstellung der Amplitude eines Signals über der Zeit.

Drahtlos Ein Begriff, der sich auf ein breites Spektrum von Technologien bezieht, die Mobilkommunikation für Heim- und Büroanwendungen ermöglichen, und auf Produkte für hausinterne Anwendungen zur Verbesserung des Mobilität am Arbeitsplatz, im Campus oder innerhalb eines Bürokomplexes. Der Begriff wird auch in der Bedeutung "zellular" für mobile Dienste in Gebäuden und im Freien gebraucht.

WWW World Wide Web.

X

Y

Z

Durchgangsverbindung der Länge Null Bei einer Kalibrierung, wenn die beiden Messkabel direkt (ohne zwischengeschalteten Adapter oder zwischengeschaltetes Durchgangsnormal) miteinander verbunden werden. Siehe auch Nicht direkt anschließbare Bauteile.


Inhalt

Glossar


Home

(Rev. 20001220)

Willkommen auf der Startseite !

Online-Hilfe zu den Netzwerkanalysatoren der Familie Agilent PNA

Machen Sie einen Vorschlag und GEWINNEN Sie!


Index

Hauptindex

COM-Index

SCPI-Index


Vorschläge

Wir freuen uns auf Ihre Vorschläge!

Bitte lassen Sie uns doch wissen, was Sie von unserem Hilfe-System halten. Wenn Sie an einer monatlichen Verlosung teilnehmen möchten, geben Sie bitte Ihre E-Mail-Adresse an. (Dieses Angebot gilt bis zum 1. Mai 2001.) Senden Sie Ihre Kommentare an: pna_help@am.exch.agilent.com

Bitte äußern Sie Ihre Meinung zu beliebigen Aspekten des Hilfe-Systems. Hier einige Punkte, die Sie eventuell bewerten könnten:

  • Funktioniert etwas nicht richtig?

  • Haben Sie die gesuchten Informationen gefunden?

  • Waren die Informationen für Sie von Nutzen?

  • Haben Sie Vorschläge, wie wir das Hilfe-System verbessern könnten?

Ihre Kommentare gehen direkt an die Autoren des Hilfe-Systems. Wenn Sie Unterstützung in technischen Fragen benötigen, siehe Technische Unterstützung.


3,8 GHz-Frequenzabgleich

Diese Routine gleicht den internen YIG-Festfrequenzoszillator durch Ändern eines DAC-Wertes auf 3,8 GHz ab. Dieser DAC-Wert ist im nichtflüchtigen Internspeicher des Analysators abgelegt.

Der Oszillator kann um bis zu 12 kHz gegenüber der Sollfrequenz 3,8GHz verstimmt werden; er muss nicht unbedingt exakt auf 3,8GHz eingestellt sein.

Kompatibilität zu Spektrumanalysatoren

Diese Routine ist mit den Spektrumanalysatoren der Familien Agilent 856x und 859x kompatibel.

Falls kein kompatibler Spektrumanalysator verfügbar ist, wählen Sie im Feld für den Spektrumanalysator "NONE". Sie können dann den DAC manuell abgleichen, indem Sie das 3,8 GHz-Signal auf einem anderen Spektrumanalysator beobachten.

Prozedur (nur für kompatible Spektrumanalysatoren)

Hinweis: Das vom Spektrumanalysator angezeigte 3,8 GHz-Signal hat einen Pegel von nur etwa –70 dBm. Verwenden Sie für diesen Abgleich keinen anderen Abschwächer als den bei den meisten Spektrumanalysatoren standardmäßig vorhandenen 10 dB-Abschwächer.

  1. Verbinden Sie den Spektrumanalysatoreingang mit dem Netzwerkanalysatorausgang PORT 1.

  2. Verbinden Sie die GPIB-Schnittstelle des Analysators mit der des Zählers. Stellen Sie sicher, dass an diesem Bus keine anderen aktiven Controller angeschlossen sind.

  1. Stellen Sie die GPIB-Adresse des Spektrumanalysators auf 18 ein.

  2. Zeigen Sie im System-Menü auf Service, Adjustments, und klicken Sie auf 3.8 GHz Freq. Adjust.

  3. Klicken Sie auf Begin Adj. Die Routine gleicht daraufhin den internen Oszillator auf minimale Frequenzabweichung ab und speichert die ADC-Werte ab. Warten Sie, bis in der Statuszeile angezeigt wird, dass der Abgleich beendet ist, und wählen Sie dann Exit.

Prozedur (nur für nicht-kompatible Spektrumanalysatoren)

Hinweis: Das vom Spektrumanalysator angezeigte 3,8 GHz-Signal hat einen Pegel von nur etwa –70 dBm. Verwenden Sie für diesen Abgleich keinen anderen Abschwächer als den bei den meisten Spektrumanalysatoren standardmäßig vorhandenen 10 dB-Abschwächer.

  1. Verbinden Sie den Spektrumanalysatoreingang mit dem Netzwerkanalysatorausgang PORT 1.

  2. Stellen Sie den Spektrumanalysator folgendermaßen ein:

    • Mittenfrequenz = 3,8 GHz

    • Wobbelbandbreite = 100 MHz

    • Bandbreite = 10 kHz

    • Skalierung passend für die Darstellung eines Signals mit einem Pegel von –70 dBm

  3. Zeigen Sie im System-Menü auf Service, Adjustments, und klicken Sie auf 3.8 GHz Freq. Adjust.

  4. Wählen Sie unter Spectrum Analyzer die Option NONE.

  5. Klicken Sie auf Begin Adj.

  6. Zunächst wird der derzeit gespeicherte DAC-Wert angewandt. Lesen Sie die vom Spektrumanalysator angezeigte Frequenz ab.

    • Falls der Frequenzmesswert über 3,8 GHz liegt, schieben Sie den Regler nach links, um den DAC-Wert zu verkleinern.

    • Falls der Frequenzmesswert unter 3,8 GHz liegt, schieben Sie den Regler nach rechts, um den DAC-Wert zu vergrößern.

Hinweis: Der DAC-Wert muss zwischen 0 und 4095 liegen. Bei einer Änderung des DAC-Wertes um eine Einheit ändert sich die Oszillatorfrequenz um etwa 23 kHz.

  6. Stellen Sie den DAC-Wert so ein, dass die Frequenz möglichst nahe bei 3,8 GHz liegt. Falls Sie den DAC-Wert erheblich verändert haben, warten Sie mit der Frequenzmessung ein paar Sekunden lang, damit sich die Temperatur stabilisieren kann.

  7. Ändern Sie die Spektrumanalysator-Einstellungen so, dass das Signal mit höherer Auflösung dargestellt wird:

    • Wobbelbandbreite = 500 kHz

    • Auflösebandbreite = 3 kHz

  8. Stellen Sie den DAC-Wert so ein, dass das gemessene Signal exakt bei 3,8 GHz liegt.

  9. Klicken Sie auf SAVE DAC, um den so ermittelten, endgültigen DAC-Wert in das nichtflüchtige EEPROM abzuspeichern. Klicken Sie auf Exit.

Hinweis: Falls Sie den DAC-Wert erheblich ändern mussten, sollten Sie diese Prozedur nach etwa 15 bis 30 Minuten wiederholen. Bis dahin hat sich die Temperatur stabilisiert.


10 MHz-Abgleich

10 MHz-Frequenzreferenz-Abgleich

Diese Routine gleicht die interne Zeitbasis durch Ändern eines DAC-Wertes auf exakt 10 MHz ab. Dieser DAC-Wert ist im nichtflüchtigen Internspeicher des Analysators abgelegt. Diese Routine muss nur in folgenden Situationen ausgeführt werden:

  • Wenn die Frequenzreferenz-Baugruppe ausgetauscht wurde.

  • Wenn die 10 MHz-Referenzfrequenz erheblich von dem im Werk eingestellten Wert abweicht.

WARNUNG: Der Einstellbereich für die Referenzfrequenz beträgt nur 20 Hz. Es wird dringend empfohlen, für die Messung dieses 10 MHz-Signal ein hochgenaues Normal zu verwenden, beispielsweise eine Haus-Frequenzreferenz oder eine sonstige, temperaturstabilisierte Frequenzreferenz.

Kompatibilität mit Frequenzzählern

Diese Routine ist kompatibel mit SCPI-konformen Frequenzzählern wie z. B. Agilent 53181A. Sie sollte auch mit der älteren Frequenzzählerfamilie 5350 kompatibel sein.

Falls kein kompatibler Frequenzzähler verfügbar ist, wählen Sie "Manual". Wenn Sie die manuelle Vorgehensweise wählen, können Sie die gemessene Frequenz manuell eingeben.

Prozedur (nur für kompatible GPIB-Frequenzzähler)

  1. Verbinden Sie den Frequenzzählereingang mit dem "10 MHz Reference Output" auf der Rückwand des Analysators.

  2. Verbinden Sie die GPIB-Schnittstelle des Analysators mit der des Zählers. Stellen Sie sicher, dass an diesem Bus keine anderen aktiven Controller angeschlossen sind.

  3. Falls Sie über eine Haus-Frequenzreferenz verfügen, schließen Sie diese an den Referenzeingang des Frequenzzählers an.

  4. Stellen Sie die GPIB-Adresse des Frequenzzählers auf 03 ein. Diese Routine setzt voraus, dass ein Gerät mit dieser Adresse ein Frequenzzähler ist. Stellen Sie sicher, dass außer dem Frequenzzähler kein weiteres GBIP-Gerät auf diese Adresse eingestellt ist.

  5. Zeigen Sie im System-Menü auf Service, Adjustments, und klicken Sie auf 10 MHz Freq. Adjust.

  6. Klicken Sie auf Begin Adj. Diese Routine stellt die interne Frequenzreferenz möglichst genau auf die Sollfrequenz ein und speichert den dafür notwendigen ADC-Wert ab.

    • Klicken Sie auf Read Freq, um das 10 MHz-Signal nochmals zu messen.

    • Klicken Sie auf Read DAC; daraufhin wird der derzeit im nichtflüchtigen Speicher des Analysators gespeicherte DAC-Wert (zwischen 0 und 4095) angezeigt.

  7. Warten Sie, bis in der Statuszeile angezeigt wird, dass der Abgleich beendet ist, und wählen Sie dann Exit.

Prozedur (nur für nicht-kompatible GPIB-Frequenzzähler)

  1. Verbinden Sie den Frequenzzählereingang mit dem "10 MHz Reference Output" auf der Rückwand des Analysators.

  2. Stellen Sie den Frequenzzähler auf eine Frequenzauflösung von 1 Hz oder besser ein.

  3. Falls Sie über eine Haus-Frequenzreferenz verfügen, schließen Sie diese an den Referenzeingang des Frequenzzählers an.

  4. Zeigen Sie im System-Menü auf Service, Adjustments und klicken Sie auf 10 MHz Freq. Adjust.

  5. Wählen Sie unter Frequency Counter die Option Manual.

  6. Klicken Sie auf Begin Adj.

  7. Zunächst wird der derzeit gespeicherte DAC-Wert angewandt. Geben Sie die Frequenzabweichung vom Sollwert (10 MHz) ein. Wenn die gemessene Frequenz unter 10 MHz liegt, geben Sie die Abweichung als negativen Wert ein.

Beispiel:

  • Wenn der Frequenzzähler 10000003.5 Hz anzeigt, geben Sie 3.5 (oder +3.5) in das entsprechende Feld ein.

  • Wenn der Frequenzzähler 9999997.8 Hz anzeigt, geben Sie –2.2 in das entsprechende Feld ein.

  6. Es sind mindestens drei Abgleich-Iterationen erforderlich, bis der eingegebene Wert exakt Null ist.

    • Klicken Sie auf Read Freq, um das 10 MHz-Signal nochmals zu messen.

    • Klicken Sie auf Read DAC; daraufhin wird der derzeit im nichtflüchtigen Speicher des Analysators gespeicherte DAC-Wert (zwischen 0 und 4095) angezeigt.

  7. Warten Sie, bis in der Statuszeile angezeigt wird, dass der Abgleich beendet ist, und wählen Sie dann Exit.

Hinweis: Falls der Frequenzzähler einen falschen Frequenzwert anzeigt, müssen Sie eventuell das Eingangssignal abschwächen und/oder die Eingangsimpedanz auf 50 Ohm einstellen.


Erweiterte Marker-Funktionen

Siehe auch...

Definiert Marker-Eigenschaften.

Marker. Spezifiziert den Marker, dessen Eigenschaften Sie definieren möchten.

ON. Wenn dieses Kontrollkästchen angeklickt ist, erscheint der Marker auf dem Bildschirm und zeigt die Daten der markierten Position an.

Format. Definiert das Darstellungsformat für die Marker-Daten. Das Marker-Format muss nicht mit dem Gitterrasterformat übereinstimmen. In der Standardeinstellung sind die Marker- und Gitterrasterformate identisch.

Discrete Marker. Wenn "Discrete Marker" angeklickt ist, entsprechen die angezeigten Marker-Werte den tatsächlichen (nicht-interpolierten) Messpunktwerten; anderenfalls werden die Marker-Werte durch Interpolation aus den Messpunktwerten berechnet.

Marker Type

Normal. Der Marker erscheint auf der Messkurve bei dem von Ihnen gewählten Stimuluswert.

Fixed. Der Marker erscheint bei den von Ihnen gewählten X- und Y-Werten.


AgileUpdate

Siehe auch...

Dieses Update-Utility ermöglicht es Ihnen, neue Firmwareversionen, Hilfedateien, Anwendungen und sonstige PNA-spezifische Dateien schnell und einfach aus dem Internet herunterzuladen.

Aktualisieren von Analysatordateien (einfache Prozedur)

Hinweis: Dieses Hilfsprogramm können Sie nur ausführen, wenn Sie bei Ihrem Analysator als Verwalter angemeldet sind.

In den meisten Fällen genügt die nachfolgend beschriebene, vereinfachte Prozedur, um die neueste Version einer interessierenden PNA-Datei herunterzuladen. Eine ausführlichere Prozedur wird weiter unten beschrieben.

  1. Klicken Sie im System-Menü auf Service, AgileUpdate.

  2. Klicken Sie auf Check for Updates.

  3. Klicken Sie auf Download & Install.

Aktualisieren von Analysatordateien (ausführliche Prozedur)

Einrichten der Internet-Verbindung

Hinweis: Dieses Hilfsprogramm können Sie nur ausführen, wenn Sie bei Ihrem Analysator als Verwalter angemeldet sind.

  1. Schließen Sie den Analysator an das Internet an. Es wird eine LAN-Verbindung empfohlen, da ein Firmware-Download über ein Modem bis zu zwei Stunden dauern kann.

  2. Wählen Sie den Proxy-Namen und -Port:

    • Bei einer LAN-Verbindung verwendet das Programm den gleichen Proxy-Server, den der Internet Explorer als Standard-Proxy-Server verwendet.

    • Wenn Sie einen Nicht-Standard-Proxy-Server oder Proxy-Port verwenden möchten, klicken Sie auf Configure und geben Sie den Proxy-Namen und -Port ein, und zwar in folgendem Format: proxyName:portNummer. (Die Proxy-Port-Nummer lautet normalerweise 8088.) Klicken Sie auf OK.

  3. Wählen Sie das Internet-Timeout:

    • Falls der Aufbau einer Internet-Verbindung normalerweise nicht länger als 30 Sekunden dauert, behalten Sie den Standard-Timeout-Wert von 30 Sekunden bei.

    • Falls Sie eine automatische Internet-Wählverbindung verwenden, müssen Sie eventuell das Timeout verlängern. Klicken Sie auf Configure und geben Sie den gewünschten Timeout-Wert ein. Klicken Sie auf OK.

Überprüfung auf neue Dateien und Herunterladen der Dateien

  4. Wählen Sie die Quelle, von der Sie die Aktualisierungsdateien beziehen möchten.

    • Wenn Sie die Dateien noch nicht heruntergeladen haben, wählen Sie Default Website.

    • Falls Sie die Dateien schon auf die Festplatte des Analysators heruntergeladen haben, wählen Sie Install from File.

    • Wenn Sie von Agilent den Hinweis erhalten haben, dass die Dateien nicht von der Standard-Website, sondern von einer anderen Website heruntergeladen werden sollen, wählen Sie Other specified URL.

  5. Falls Sie von Agilent ein Zugangspasswort erhalten haben, geben Sie dieses in das Feld "Access Code" ein.

  6. Klicken Sie auf Check for Updates. Falls neuere Versionen der betreffenden Dateien existieren, werden diese aufgelistet, sofern das Kontrollkästchen aktiviert ist. Falls Sie keine der aufgelisteten Dateien aktualisieren möchten, deaktivieren Sie das Kontrollkästchen.

Hinweis: Weil die Firmware die Hilfe-Datei enthält, ist nur das Kontrollkästchen "Firmware" aktiv, wenn sowohl für die Firmware als auch für die Hilfe neue Dateien verfügbar sind.

  6. Werten Sie die angezeigten Informationen aus:

    1. Klicken Sie auf Firmware History und lesen Sie die Beschreibungen der früheren Firmware-Versionen. Eventuell finden Sie Änderungen, die für Ihre Anwendung von Bedeutung sind.

    2. Klicken Sie auf ReadMe, falls diese Option verfügbar ist. Die "ReadMe"-Datei enthält Informationen über Aktualisierungsprozeduren, bekannte Probleme und Lösungen, und dergleichen mehr.

  7. Wählen Sie die gewünschte Download-Operation:

    • Klicken Sie auf Download & Install, falls die im Analysator vorhandenen Dateien automatisch durch die heruntergeladenen, aktuellen Dateien überschrieben werden sollen.

    • Klicken Sie auf Download Only, wenn die aktuellen Dateien nur auf die Festplatte des Analysators heruntergeladen und später installiert werden sollen.

Hinweis: Das Programm speichert die heruntergeladenen Dateien in ein speziell dafür vorgesehenes Verzeichnis auf der Festplatte des Analysators ab. Wenn Sie das Update-Utility regelmäßig ausführen, werden unter Umständen zahlreiche Dateien in diesem Verzeichnis abgelegt. Mit dem Befehl Clean-Up können Sie alle Dateien außer den beiden neuesten Versionen aus diesem Verzeichnis löschen.


Avg

"Average"

Siehe auch...

Average ON. Wenn dieses Kontrollkästchen angeklickt ist, wird statt der aktuellen Messkurve der (punktweise berechnete) gleitende Mittelwert aus mehreren aufeinanderfolgenden Messungen angezeigt; dies bewirkt eine Rauschunterdrückung.

Average Factor. Spezifiziert die Anzahl der zur Mittelung herangezogen Wobbelmessungen. Wertebereich: 1 bis 1024.

Restart. Startet eine neue Messreihe für die Mittelung. Die Anzahl der zu mittelnden Messungen wird durch den "Average factor" bestimmt.


Kalibrierungsassistent

"Calibration Wizard"

Siehe auch...

Der Kalibrierungsassistent führt Sie durch den Kalibrierprozess.

Cal Type. Präsentiert eine Auswahlliste der verfügbaren Kalibrierverfahren.

Modify. Präsentiert ein Dialogfenster, in dem Sie vor der Durchführung einer Kalibrierung die Start- und Stop-Frequenzen ändern können.

Measure ECal Stds. Präsentiert den Teil des Assistenten, der Sie durch den elektronischen Kalibrierprozess (unter Verwendung eines ECal-Moduls als Kalibriernormal) führt.

Measure Stds. Präsentiert den Teil des Assistenten, der Sie durch den herkömmlichen Kalibrierprozess (unter Verwendung mechanischer Kalibriernormale) führt.

Have 2 sets of standards. Wenn Sie über zwei Kalibriernormalsätze (beispielsweise zwei Leerlaufnormale) verfügen und dieses Kontrollkästchen anklicken, werden bei einer 2-Port-Kalibrierung die Messungen an Port 1 und 2 gleichzeitig durchgeführt.


Mittenfrequenz und Wobbelbandbreite

"Center" und "Span"

Siehe auch...

Center. Definiert die Mitte des Frequenzwobbelbereichs. Dieser Wert kann an einer beliebigen Stelle des vom Analysator abgedeckten Gesamtmessbereichs liegen.

Span. Definiert die Breite des Frequenzwobbelbereichs (links und rechts vom Mittenwert).


Festfrequenz

"CW Frequency"

Siehe auch...

Ermöglicht es Ihnen, die Signalquelle auf eine feste Frequenz einzustellen (wird in Verbindung mit Signalpegelwobbelung und CW-Zeitwobbelung benutzt). Diese Frequenz kann an einer beliebigen Stelle des vom Analysator abgedeckten Frequenzbereichs liegen.


Elektrische Länge

"Electrical Delay"

Siehe auch...

Electrical Delay. Spezifiziert den zu addierenden oder zu subtrahierenden Laufzeitwert in Zeiteinheiten Die elektrische Länge dient zur Kompensation einer linearen Phasenverschiebung in einem Bauteil. Sie können die elektrische Länge für jeden Kanal individuell spezifizieren.

Velocity Factor. Spezifiziert die relative Ausbreitungsgeschwindigkeit in dem hinzugefügten Bauteil. Der Wert für ein Kabel mit Polyethylen-Dielektrikum beträgt 0,66 und für ein Kabel mit Teflon-Dielektrikum der 0,7.


EXT-TRIG-Eingang

Externer Trigger

Siehe auch...

Positive. Der Analysator triggert, wenn das TTL-Signal am rückseitigen Extern-Trigger-Eingang von 0 (LOW) auf 1 (HIGH) wechselt.

Negative. Der Analysator triggert, wenn das TTL-Signal am rückseitigen Extern-Trigger-Eingang von 1 (HIGH) auf 0 (LOW) wechselt.


"Format"

Siehe auch...

Log Magnitude. Es wird nur der Amplitudenbetrag (in dB) der Einfügedämpfung, Verstärkung, Rückflussdämpfung oder Absolutleistung über der Frequenz dargestellt.

Phase. Es wird die Phase (in Grad) über der Frequenz dargestellt.

Group Delay. Es wird die Zeit dargestellt, die das Messsignal zum Durchlaufen des Messobjekts benötigt. Der Messwert ergibt sich aus der Phasenänderung über eine bestimmte Frequenzspanne (Apertur).

Smith Chart. Es wird die Impedanz des Messobjekts über der Frequenz dargestellt. Die punktierten Linien im Smith-Diagramm sind Ortskurven konstanten Widerstandes und konstanter Reaktanz, normiert auf die Systemimpedanz Z0. Die Reaktanzwerte in der oberen (positiven) Hälfte des Smith-Diagramms repräsentieren induktive Blindwiderstände; die Reaktanzwerte in der unteren (negativen) Hälfte des repräsentieren kapazitive Blindwiderstände.

Polar. Zu jedem Messpunkt wird der Amplitudenwert und der Phasenwert angezeigt. Das Messdiagramm ist vektoriell zu lesen: Der Abstand eines Punktes vom Mittelpunkt (Nullpunkt) des Diagramms entspricht dem Amplitudenbetrag; der Winkel (entgegen dem Uhrzeigersinn) zur positiven X-Achse entspricht der Phase. Der Betrag ist linear skaliert; der äußere Kreis repräsentiert normalerweise den Verhältniswert 1. Da es keine Frequenzachse gibt, muss die Frequenz mit Hilfe der Marker bestimmt werden. Das Standard-Markeranzeigeformat für das Polardiagramm ist "Linear mag" und "Phase".

Linear Magnitude. Es wird ein Gitterraster für dimensionslose Messwerte mit linear skalierter Y-Achse angezeigt; dimensionslos sind beispielsweise der Betrag des Reflexionskoeffizienten oder Transmissionskoeffizienten. Auch zeitbereichtransformierte Daten werden in diesem Format dargestellt.

SWR. Aus den Reflexionsmessdaten wird das entsprechende Stehwellenverhältnis (SWR, Standing Wave Ratio) berechnet und dargestellt.

Real. Es wird nur der Realteil (Widerstand, Betrag) der Messdaten dargestellt; die Werte können positiv oder negativ sein. Dieses Format wird vorzugsweise für die Darstellung der Zeitbereichantwort verwendet.

Imaginary. Es wird nur der Imaginärteil (reaktive Komponente, Phase) der Messdaten dargestellt.


ZF-Bandbreite

"IF Bandwidth"

Siehe auch...

Spezifiziert die ZF- (Empfänger-) Bandbreite im Bereich von 10 Hz bis 40 kHz. Je kleiner Sie die ZF-Bandbreite wählen, desto geringer ist der Rauschpegel, desto länger allerdings die Wobbelzeit. Durch Wahl einer größeren ZF-Bandbreite können Sie die Wobbelgeschwindigkeit erhöhen. Der Standardwert ist 35 kHz.


Grenzwerttest

"Limit Test"

Siehe auch...

Vergleicht die aktuellen Messdaten mit den von Ihnen vorgegebenen Grenzwertlinien. Je nach Ergebnis dieses Vergleichs wird PASS (Test bestanden) oder FAIL (Test nicht bestanden) angezeigt.

Limit Test ON. Wenn dieses Kontrollkästchen angeklickt ist, vergleicht der Analysator die aktuellen Messdaten mit den Grenzwertlinien.

Limit Line ON. Wenn dieses Kontrollkästchen angeklickt ist, sind die Grenzwertlinien auf dem Bildschirm zu sehen.

Sound ON Fail. Wenn dieses Kontrollkästchen angeklickt ist, ertönt ein Signalton, wenn die Messdaten nicht vollständig innerhalb des durch die Grenzwertlinien definierten Bereichs liegen.

Show Table. Die Tabelle zum Erstellen und Bearbeiten von Grenzwerten wird angezeigt.

Hide Table. Die Grenzwerttabelle verschwindet vom Bildschirm.


LO-Pegelabgleich

Diese Routine gleicht den Lokaloszillator des Empfängers durch Ändern von DAC-Werten auf bestimmte Ausgangspegel bei bestimmten Frequenzen ab. Die DAC-Werte werden im nichtflüchtigen Internspeicher des Analysators abgelegt.

Der Abgleichbereich beträgt etwa ±3 dB. Die Sollpegel betragen, je nach Frequenzband, 0 dBm ± ein paar dB.

  • Bands 1, 2 und 3 werden abgeglichen.

  • Für Band 4 wird der gleiche DAC-Wert wie für Band 2 verwendet.

  • Für die Bänder 5 und 6 wird der gleiche DAC-Wert wie für Band 3 verwendet.

  • Für die Bänder 0 und 7 wird ein fester DAC-Wert verwendet.

Kompatibilität mit Leistungsmessgeräten

Diese Routine ist NUR mit den Leistungsmessgeräten der Familie Agilent EPM kompatibel. Als Leistungssensor MUSS ein Sensor der "E"-Serie verwendet werden. (Bei Zweikanal-Leistungsmessgeräten muss der Leistungssensor an den Kanal A angeschlossen werden.) Die Kalibrierfaktoren dieser Leistungssensoren sind im Sensor gespeichert und werden vom Leistungsmessgerät abgefragt. Sie brauchen deshalb keine Kalibrierfaktoren manuell einzugeben. Die Option "None" unter "Power Meter" ist derzeit noch ohne Funktion.

Prozedur

  1. Lassen Sie den Analysator und das Leistungsmessgerät 30 Minuten lang warmlaufen.

  2. Führen Sie einen manuellen Leistungssensor-Nullpunktabgleich und eine manuelle Leistungssensor-Kalibrierung durch.

  3. Verbinden Sie die GPIB-Schnittstelle des Analysators mit der des Leistungsmessgeräts. Stellen Sie sicher, dass an diesem Bus keine anderen aktiven Controller angeschlossen sind.

  4. Stellen Sie die GPIB-Adresse des Leistungsmessgeräts auf 13 ein.

  5. Nehmen Sie die Gehäuseabdeckung vom Analysator ab.

  6. Trennen Sie das halbstarre Kabel vom Anschluss A17J70 ab und schließen Sie den Leistungssensor an den LO-Ausgang der LO-Verteilungsbaugruppe an (A17J70); verwenden Sie Adapter, falls erforderlich. Falls ein Kabel erforderlich ist, sollte dieses – wenn möglich – kürzer als 25 cm sein.

  7. Zeigen Sie im System-Menü des Analysators auf Service, Adjustments und klicken Sie auf LO Power Adjust.

  8. Klicken Sie zum Starten der Abgleichroutine auf Begin Adj. Die Routine misst daraufhin den LO-Ausgangspegel bei verschiedenen Frequenzen in den Bändern 1 bis 3 und gleicht ihn erforderlichenfalls so ab, dass er innerhalb eines bestimmten Toleranzbandes liegt. Falls ein Abgleich erforderlich ist, werden die neuen DAC-Werte automatisch abgespeichert.

    • Klicken Sie auf Read DAC; daraufhin werden die derzeit im nichtflüchtigen Speicher des Analysators gespeicherten DAC-Werte (zwischen 0 und 4095) für die einzelnen Bänder (0 bis 7) angezeigt.

  9. Warten Sie, bis in der Statuszeile angezeigt wird, dass der Abgleich beendet ist, und wählen Sie dann Exit.

  10. Schließen Sie das halbstarre Kabel wieder an A17J70 an.


Macro

Siehe auch...

Die Macro-Funktion ermöglicht es Ihnen, bis zu 12 Macros zu definieren, mit denen Sie andere Anwendungsprogramme aus der PNA-Anwendung heraus starten können.

Macro Title. Zeigt die Titel an, die in der Aktuelle-Eingabe-Symbolleiste erscheinen, wenn Sie die Taste "Macro" drücken. Diese Titel sind den ausführbaren Dateien zugeordnet und sollten so gewählt werden, dass Sie das jeweilige Anwendungsprogramm leicht identifizieren können. Wenn Sie beispielsweise Ihren Browser mit der "Agilent Home Page" per Macro starten möchten, könnte der Titel "Agilent Home" lauten.

Macro Executable. Der vollständige Pfad zu der ausführbaren Datei. Um bei dem obigen Beispiel zu bleiben: Der Pfad zum Starten des Browsers, der dann die "Agilent PNA Series Home Page" anzeigt, könnte beispielsweise "C:\Program Files\Internet Explorer\iexplore.exe" lauten.

Macro Runstring Parameters. Die an die ausführbare Datei übergebenen Befehlszeilenparameter. Um wiederum bei dem obigen Beispiel zu bleiben: Der Befehlszeilenparameter könnte in diesem Fall "http://www.agilent.com/find/pna" lauten.

Edit. Es erscheint das Dialogfenster "Macro Edit", in dem Sie den Titel, die Befehlszeilenparameter und den Namen/Pfad der ausführbaren Datei modifizieren können.

Delete. Das gewählte Macro wird gelöscht.

Up. Hiermit können Sie die Reihenfolge der Macros ändern; das gewählte Macro wird jeweils um eine Zeile nach oben verschoben. Es sind insgesamt 12 Zeilen für die 12 möglichen Macros verfügbar; diese Liste gibt die Reihenfolge vor, in der die Macros in der Aktuelle-Eingabe-Symbolleiste erscheinen, wenn Sie die Taste "Macro" drücken. Es können immer nur vier Titel gleichzeitig in der Aktuelle-Eingabe-Symbolleiste angezeigt werden. Wenn Sie die Taste "Macro" wiederholt drücken, wird in der Aktuelle-Eingabe-Symbolleiste die jeweils nächste Vierergruppe von Macros angezeigt.

Down. Der gewählte Titel wird in der Liste um eine Zeile nach unten verschoben.


Macro-Editor

"Macro Edit"

Siehe auch...

Ermöglicht es Ihnen, den Titel, die Befehlszeilenparameter und den Dateinamen/Pfad des im Dialogfenster "Macro Setup" gewählten Macros zu bearbeiten.

Macro Title. Ermöglicht es Ihnen, den in der Aktuelle-Eingabe-Symbolleiste angezeigten Macro-Titel zu bearbeiten.

Macro Executable. Ermöglicht es Ihnen, den vollständigen Pfad zu der ausführbaren Datei zu bearbeiten.

Browse. Ermöglicht es Ihnen, Laufwerke und Verzeichnisse schnell nach der gewünschten ausführbaren Datei zu durchsuchen und den vollständigen Pfad zu dieser Datei zu übernehmen.

Macro run string parameters. Ermöglicht es Ihnen, die Befehlszeilenparameter zu bearbeiten, die der ausführbaren Datei übergeben werden.


Einrichten von Markern

"Marker"

Siehe auch...

Diese Funktionen definieren einen Marker zum Ablesen numerischer Messdaten.

Marker. Spezifiziert den Marker, dessen Eigenschaften Sie definieren möchten.

Stimulus. Spezifiziert den Stimuluswert (X-Achsen-Wert), auf den der Marker gesetzt wird.

ON. Wenn dieses Kontrollkästchen angeklickt ist, erscheint der Marker auf dem Bildschirm und zeigt die Daten der markierten Position an.

Delta Marker. Wenn dieses Kontrollkästchen angeklickt ist, sind die angezeigten Marker-Werte auf den Wert eines anderen, bereits aktiven Markers bezogen.

Advanced... Es erscheint ein Dialogfenster, in dem Sie noch weitere Marker-Eigenschaften definieren können.

All Off. Alle Marker für die aktive Messkurve werden deaktiviert.


Marker-Funktionen

"Marker Functions"

Siehe auch...

Definiert eine Stimulus-Einstellung auf der Basis des Wertes des aktiven Markers.

Marker->Start. Stellt den Start-Wert für die Wobbelung auf den Wert des aktiven Markers ein.

Marker->Stop. Stellt den Stop-Wert für die Wobbelung auf den Wert des aktiven Markers ein.

Marker->Center. Stellt den Mitten-Wert für die Wobbelung auf den Wert des aktiven Markers ein.

Marker->Ref Level. Stellt den Referenzpegel auf den Wert des aktiven Markers ein.

Marker->Delay. Stellt die elektrische Länge auf den Wert des aktiven Markers ein.

Marker->Span. Stellt die Wobbelbandbreite auf die vom Delta-Marker und dem zugehörigen Referenz-Marker definierte Bandbreite ein.


Marker-Suche

"Marker Search"

Siehe auch...

Diese Parameter definieren das Marker-Verhalten und die zu durchsuchenden Messkurvenbereiche.

Marker. Spezifiziert den Marker, dessen Eigenschaften Sie definieren möchten.

Search Domain. Definiert den Bereich, innerhalb dessen der Marker sucht oder verschoben werden kann. Wenn Sie "full span" wählen, sucht der Marker innerhalb der vollen Wobbelbandbreite nach den spezifizierten Werten. Wenn Sie "user span" wählen, sucht der Marker innerhalb des von Ihnen spezifizierten Frequenzbereichs nach den spezifizierten Werten.

Search Type

Maximum. Der Marker sucht den größten Messwert (Messkurvenmaximum).

Minimum Der Marker sucht den kleinsten Messwert (Messkurvenminimum).

Next Peak. Der Marker sucht die Signalspitze mit dem nächstniedrigeren Amplitudenwert.

Threshold. Die Mindestamplitude (in dB), die ein Wert aufweisen muss, damit er als "Peak" gewertet werden kann.

Excursion. Der vertikale Abstand (dB) zwischen der Spitze und den "Tälern" auf beiden Seiten.

Peak Right. Der Marker sucht die nächste gültige Signalspitze rechts von seiner aktuellen Position.

Peak Left. Der Marker sucht die nächste gültige Signalspitze links von seiner aktuellen Position.

Target. Der Marker sucht den Datenpunkt, der dem spezifizierten Suchkriterien entspricht.

Bandwidth. Die Bandbreite des gemessenen Filters wird mit Hilfe zweier Marker bestimmt.

Execute. Der Marker wird auf die Stelle der Messkurve gesetzt, die dem Suchkriterium entspricht.

Tracking. Wenn dieses Kontrollkästchen angeklickt ist, sucht der Marker in jedem Wobbelzyklus erneut nach dem spezifizierten Wert.


Math/Memory-Operationen

"Math/Memory"

Siehe auch...

Data->Memory. Die aktive Messkurve wird in den Internspeicher abgespeichert.

Data Math

Data. Es werden keine mathematischen Berechnungen durchgeführt.

Data / Memory. Die aktuellen Messdaten werden punktweise durch die gespeicherten Messdaten dividiert.

Data * Memory. Die aktuellen Messdaten werden punktweise mit den gespeicherten Messdaten multipliziert.

Data – Memory. Die gespeicherten Messdaten werden punktweise von den aktuellen Messdaten subtrahiert.

Data + Memory. Die aktuellen Messdaten werden punktweise zu den gespeicherten Messdaten addiert.

"Trace View"-Optionen

Data Trace. Die aktuelle Messkurve wird angezeigt.

Memory Trace. Die gespeicherte Messkurve wird angezeigt.

Data and Memory Trace. Die aktuelle Messkurve und die gespeicherte Messkurve werden angezeigt.


Measure-Taste

"Measure"

Siehe auch...

Diese Funktionen betreffen die aktive Messkurve.

Trace Type: S-Parameters. Spezifiziert die Signalflussrichtung durch das Messobjekt. Die Konvention lautet "S aus ein": Die erste Ziffer (aus) bezieht sich auf den Messobjekt-Anschluss, aus dem das Signal austritt; die zweite Ziffer (ein) bezieht sich auf den Messobjekt-Anschluss, in den das Signal einfällt.

S11. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 1 austretenden Signals zu dem am Messobjekt-Anschluss 1 einfallenden Signal.

S21. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 2 austretenden Signals zu dem am Messobjekt-Anschluss 1 einfallenden Signal.

S12. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 1 austretenden Signals zu dem am Messobjekt-Anschluss 2 einfallenden Signal.

S22. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 2 austretenden Signals zu dem am Messobjekt-Anschluss 2 einfallenden Signal.


Leistungsverhältnismessung

Measure: Arbitrary Ratio"

Siehe auch...

Diese Funktionen betreffen die aktive Messkurve.

Trace Type: Arbitrary Ratio. Benutzerdefinierte Leistungsverhältnismessung.

Source Port. Spezifiziert den als Signalquellenausgang verwendeten Port.

Input. Spezifiziert den als Empfängereingang verwendeten Port. Über diesen Port gelangt das Response-Signal des Messobjekts zum Analysator. Sie können auf die Eingangsports zugreifen, indem Sie die Frontplattenkabel abtrennen.

Reference. Spezifiziert den Referenzeingang des Analysators. Über diesen Eingang gelangt ein ausgekoppelter Teil des Stimulussignals zum Referenzsignalempfänger (Kanal R) des Analysators. Dieses Signal wird mit dem Response-Signal des Messobjekts verglichen. Der Referenzsignalpegel muss zwischen 0 dBm und –35 dBm betragen.


Absolutleistungsmessung

"Measure: Unratioed Power"

Siehe auch...

Diese Funktionen betreffen die aktive Messkurve.

Trace Type: Unratioed Power. Spezifiziert eine Absolutleistungsmessung an einem einzigen Port. Bei Messungen an einem einzigen Port ist die Messdatenmittelung nicht verfügbar; auch Phasen- und Gruppenlaufzeitmessungen sind dann nicht möglich.

Source Port. Spezifiziert den als Signalquellenausgang verwendeten Port.

Input. Spezifiziert den als Empfängereingang verwendeten Port. Über diesen Port gelangt das Response-Signal des Messobjekts zum Analysator. Sie können auf die Eingangsports zugreifen, indem Sie die Frontplattenkabel abtrennen.


Kalibrier-Kit-Definition modifizieren

"Modify Calibration Kit"

Siehe auch...

Dieses Menü ermöglicht es Ihnen, die Definitionen der in einem Kalibrier-Kit enthaltenen Kalibriernormale abzuändern.

Calibration Kit

Cal Kit ID. Spezifiziert das Kalibrier-Kit, das Sie modifizieren möchten. Die Kits 1 bis 6 sind vordefiniert. Die Kits 7 bis 10 sind benutzerdefinierbar.

Cal Kit Name. Spezifiziert den Steckverbindertyp und die Modellnummer oder den Namen des zu modifizierenden Kalibrier-Kits.

Restore Default Kit. Dem gewählten Kalibrier-Kit werden wieder die vordefinierten Standardwerte zugewiesen.

Restore All Default Kits. Allen Kalibrier-Kits werden wieder die vordefinierten Standardwerte zugewiesen.

Assign Standards to Ports

Port 1, Port 2. Spezifiziert den Steckverbindertyp der Messanschlüsse.

S11A, S11B, S11C, S21T. Klassen für die Zuordnung der Kalibriernormale für Port 1: dreimal Reflexion, einmal Transmission.

S22A, S22B, S22C, S12T. Klassen für die Zuordnung der Kalibriernormale für Port 2: dreimal Reflexion, einmal Transmission.

Modify Standard Definition

Standard No. Spezifiziert, für welches Kalibriernormal die Definition gilt.

Min Freq., Max Freq. Spezifiziert den Frequenzbereich des betreffenden Kalibriernormals.

Z0. Spezifiziert die Systemimpedanz.

Delay. Spezifiziert einen homogenen Wellenleiter bestimmter Länge zwischen dem zu definierenden Kalibriernormal und der tatsächlichen Messebene.

Loss. Spezifiziert den Energieverlust infolge des Skin-Effekts entlang eines Signalweges in einem Koaxialkabel.

Type. Spezifiziert, welcher Kalibriernormaltyp modifiziert werden soll.

Character. Spezifiziert, ob es sich um ein Koaxial- oder Wellenleiter-Kalibriernormal handelt.

Label. Spezifiziert eine Beschreibung des Kalibriernormals, das modifiziert werden soll.

C0, C1, C2, C3. Spezifiziert die Randkapazität des Leerlaufnormals.

L0, L1, L2, L3. Spezifiziert die Restinduktivität des Kurzschlussnormals.


Neue Messkurve

"New Trace"

Siehe auch...

Erstellt und definiert eine weitere Messung.

Trace Type: S-Parameters. Spezifiziert die Signalflussrichtung durch das Messobjekt. Die Konvention lautet "S aus ein": Die erste Ziffer (aus) bezieht sich auf den Messobjekt-Anschluss, aus dem das Signal austritt; die zweite Ziffer (ein) bezieht sich auf den Messobjekt-Anschluss, in den das Signal einfällt.

S11. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 1 austretenden Signals zu dem am Messobjekt-Anschluss 1 einfallenden Signal.

S21. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 2 austretenden Signals zu dem am Messobjekt-Anschluss 1 einfallenden Signal.

S12. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 1 austretenden Signals zu dem am Messobjekt-Anschluss 2 einfallenden Signal.

S22. Spezifiziert eine Messung des komplexen Verhältnisses des aus dem Messobjekt-Anschluss 2 austretenden Signals zu dem am Messobjekt-Anschluss 2 einfallenden Signal.

Channel Number. Spezifiziert, in welchem Kanal die neue Messung durchgeführt wird.

Create in New Window. Wenn dieses Kontrollkästchen angeklickt ist, wird eine neue S-Parameter-Messung in einem neuen Fenster erstellt. Wenn es nicht angeklickt ist, wird die Messung im aktiven Fester erstellt.


Neue Messkurve / Leistungsverhältnismessung

"New Trace: Arbitrary Ratio"

Siehe auch...

Erstellt und definiert eine weitere Messung.

Trace Type: Arbitrary Ratio. Benutzerdefinierte Leistungsverhältnismessung.

Source Port. Spezifiziert den als Signalquellenausgang verwendeten Port.

Input. Spezifiziert den als Empfängereingang verwendeten Port. Über diesen Port gelangt das Response-Signal des Messobjekts zum Analysator. Sie können auf die Eingangsports zugreifen, indem Sie die Frontplattenkabel abtrennen.

Reference. Spezifiziert den Referenzeingang des Analysators. Über diesen Eingang gelangt ein ausgekoppelter Teil des Stimulussignals zum Referenzsignalempfänger (Kanal R) des Analysators. Dieses Signal wird mit dem Response-Signal des Messobjekts verglichen. Der Referenzsignalpegel muss zwischen 0 dBm und –35 dBm betragen.

Channel Number. Spezifiziert, in welchem Kanal die neue Messung durchgeführt wird.

Create in New Window. Wenn dieses Kontrollkästchen angeklickt ist, wird eine neue Messung in einem neuen Fenster erstellt. Wenn es nicht angeklickt ist, wird die Messung im aktiven Fester erstellt.


Neue Messkurve / Absolutleistungsmessung

"New Trace: Unratioed Power"

Siehe auch...

Erstellt und definiert eine weitere Messung.

Trace Type: Unratioed Power. Spezifiziert eine Absolutleistungsmessung an einem einzigen Port. Bei Messungen an einem einzigen Port ist die Messdatenmittelung nicht verfügbar; auch Phasen- und Gruppenlaufzeitmessungen sind dann nicht möglich.

Source Port. Spezifiziert den als Signalquellenausgang verwendeten Port.

Input. Spezifiziert den als Empfängereingang verwendeten Port. Über diesen Port gelangt das Response-Signal des Messobjekts zum Analysator. Sie können auf die Eingangsports zugreifen, indem Sie die Frontplattenkabel abtrennen.

Channel Number. Spezifiziert den Kanal, dessen Attribute für die neue Messung gelten.

Create in New Window. Wenn dieses Kontrollkästchen angeklickt ist, wird eine neue S-Parameter-Messung in einem neuen Fenster erstellt. Wenn es nicht angeklickt ist, wird die Messung im aktiven Fester erstellt.


Anzahl der Messpunkte

"Number of Points"

Siehe auch...

Spezifiziert Anzahl der Messpunkte pro Wobbelung. Sie können einen beliebigen Wert zwischen 2 und 1601 eingeben. Der Standardwert ist 201.


Öffnen

"Recall"

Siehe auch...

Lädt eine Datei in den Analysator.

Look in. Ermöglicht es Ihnen, das Verzeichnis zu wählen, das die zu ladende Datei enthält.

File name: Es wird der Dateiname angezeigt, den Sie eingegeben oder in der Dateiliste angeklickt haben.

Files of type. Ermöglicht es Ihnen, Dateien eines bestimmten Typs anzuzeigen und auszuwählen.

Recall. Die im Feld "file name" angezeigte Datei wird geladen.


Schnell-Check

"Operator's Check"

Die im Fenster "Operator's Check" verfügbaren Tests ermöglichen es Ihnen, die folgenden Baugruppen der Analysator-Hardware auf offensichtliche Fehler zu überprüfen:

  • HF-Schalter im Testset

  • Abschwächer an den Messanschlüssen

Prozedur

  1. Zeigen Sie im System-Menü auf Service und klicken Sie auf Operator's Check. Es erscheint das Fenster "Operator's Check".

  2. Wählen Sie unter Sequencing die Option Automatic oder Prompted.

    • Automatic richtet die Routine so ein, dass die Wiederholgenauigkeit der Schalter und aller sieben Abschwächerbereiche automatisch getestet wird; die Zeitabstände zwischen den einzelnen Tests betragen jeweils 0,25 Sekunden.

    • Prompted richtet die Software so ein, dass Sie vor jedem Abschwächerbereich-Test um Bestätigung gebeten werden.

  3. Klicken Sie auf Start-Port 1. Schließen Sie, wenn Sie dazu aufgefordert werden, ein Kurzschlussnormal aus einem Kalibrier-Kit an den Port 1 an.

  • Nach jedem Test wird das Ergebnis (PASS = bestanden, oder FAIL = nicht bestanden) angezeigt.

  • Nach Abschluss aller Tests erscheint wieder das Fenster "Operator's Check" mit einer Zusammenfassung der Ergebnisse für den betreffenden Port. Falls einer der Tests fehlschlägt, lesen Sie bitte im Kapitel 3 des "Service Guide" nach.


Option-Enable-Hilfsprogramm

Hilfsprogramm "Option Enable Utility"

Das Hilfsprogramm "Option Enable Utility" ermöglicht folgendes:

  • Hinzufügen oder Entfernen von Software-Optionen und bestimmten Hardware-Optionen.

  • Wiederherstellen optionsbezogener Daten nach einem etwaigen Austausch der Festplatte oder eines anderen Datenspeichers.

  • Eingabe oder Änderung einer Seriennummer.

Durch Anklicken der Schaltfläche gelangen Sie zu weiteren Informationen.

Passwörter

Ausführung des Programms

Entfernen einer Option

Installieren einer Option

Wiederherstellen von optionsbezogenen Daten

Eingeben oder Ändern der Seriennummer

Passwörter

Zum Installieren bestimmter Optionen benötigen Sie ein Passwort, das Sie von Agilent erhalten. Es gibt zwei Arten von Passwörtern:

  • Options-Passwörter zum Hinzufügen einer Software-Option.

  • Modell-Passwörter zum Ersetzen bestimmter Baugruppen.

Temporäre und permanente Optionen

Sie können alle Software-Optionen temporär installieren, um sie kostenlos auszuprobieren.

Wenn das Passwort, das Sie von Agilent erhalten, ein Verfallsdatum besitzt, müssen Sie die Optionsart "temporary" wählen und das Verfallsdatum exakt so eingeben, wie es in der Lizenzvereinbarung steht. Falls Sie die Option nach dem Testen käuflich erwerben, erhalten Sie von Agilent ein neues Passwort, das aus dieser Option eine permanente Option macht.

Sowohl für eine permanente als auch für eine temporäre Option benötigen Sie ein Passwort.

Ausführung des Programms

  1. Zeigen Sie im System-Menü auf Service und klicken Sie auf Option Enable.

  2. Es erscheint ein Bildschirmfenster, in dem die Modellnummer und die Seriennummer des Gerätes sowie alle installierten Optionen angezeigt werden. Zum Hinzufügen oder Entfernen einer Option wählen Sie diese aus der Drop-Down-Liste der verfügbaren Optionen.

    • Falls die gewünschte Option nicht in der Liste enthalten ist, wählen Sie die letzte Auswahlmöglichkeit in der Liste: Enter Unlisted Option.

Falls Sie eine Software-Option gewählt haben, geschieht folgendes:

  • Die Schaltfläche "Remove" wird verfügbar.

  • Das Feld zur Eingabe des Passwortes wird sichtbar.

  • Die Auswahlmöglichkeit "permanent/temporary" wird verfügbar.

Falls Sie eine Hardware-Option gewählt haben, geschieht folgendes:

  • Wenn die betreffende Hardware-Option bereits installiert ist, wird die Schaltfläche "Remove" verfügbar.

  • Wenn die betreffende Hardware-Option noch nicht installiert ist, wird die Schaltfläche "Install" verfügbar.

Entfernen einer Option

  1. Klicken Sie zum Entfernen einer Option auf Remove.

  2. Nach dem Entfernen der Option müssen Sie den Analysator neu starten, damit die Änderung wirksam wird.

Installieren einer Option

  1. Falls das Passwort-Eingabefeld sichtbar ist, geben Sie das Passwort ein. (Der Analysator unterscheidet beim Passwort nicht zwischen Groß- und Kleinschreibung.)

  2. Klicken Sie auf "Install".

  3. Nach dem Installieren der Option müssen Sie den Analysator neu starten, damit die Änderung wirksam wird.

Wiederherstellen von optionsbezogenen Daten

Diese Routine des Hilfsprogramms "Option Enable Utility" benötigen Sie in folgenden Situationen:

  • Nach einem Austausch des Festplattenlaufwerks

  • Nach einem Austausch der Frequenzreferenz-Baugruppe

Diese Routine stellt die auf der Festplatte und in der Frequenzreferenz-Baugruppe enthaltenen optionsbezogenen Informationen (primäre Daten und Sicherungskopie) wieder her.

  1. Wählen Sie in der Menüleiste des Hilfsprogramms Option Enable Utility den Befehl Repair.

Hinweis: Falls Sie sich nicht sicher sind, ob eine Wiederherstellung erforderlich ist oder nicht, sollten Sie diese Routine auf jeden Fall ausführen – Sie können dadurch keinen Schaden anrichten.

  2. Es werden die Modellnummer und die Seriennummer des Gerätes sowie vier Kontrollkästchen angezeigt.

  3. Wählen Sie die zutreffenden Kontrollkästchen.

  4. Klicken Sie auf Begin Repair. Die Routine überprüft alle in Frage kommenden Dateien und führt alle notwendigen Reparaturen aus. Eventuell werden Sie gebeten, bestimmte Informationen und Operationen zu bestätigen.

  5. Falls die Routine entdeckt, dass die Modellnummer falsch oder ungültig ist, werden Sie aufgefordert, die korrekte Modellnummer einzugeben.

    • Außer der Modellnummer müssen Sie auch noch ein Modell-Passwort eingeben.

    • Falls dieses Passwort nicht auf dem Analysator angegeben oder sonstwie bekannt ist, setzen Sie sich bitte mit Agilent in Verbindung.

    • Klicken Sie nach Eingabe der erforderlichen Daten auf Change Model. Dieser Prozess dauert etwa 30 Sekunden.

  6. Klicken Sie danach auf Exit Repair.

  7. Falls Sie keine weitere Option installieren möchten, klicken Sie auf Exit.

Eingeben oder Ändern der Seriennummer

Nach dem Austausch bestimmter Baugruppen müssen Sie eventuell eine Seriennummer eingeben oder ändern.

  1. Wählen Sie zum Ändern einer Seriennummer in der Menüleiste "Option Enable" den Befehl "Change Serial". Daraufhin wird die aktuelle Seriennummer angezeigt. Falls noch keine Seriennummer eingegeben wurde, wird "NONE" angezeigt.

  2. Geben Sie die neue Seriennummer in das dafür vorgesehene Feld ein und klicken Sie auf "Change Serial". (Der Analysator unterscheidet bei der Seriennummer nicht zwischen Groß- und Kleinschreibung.)

Hinweis: Seien Sie bei der Eingabe der Seriennummer äußerst sorgfältig – diese Information kann nur einmal eingegeben werden!

  3. Um eine falsch eingegebene Seriennummer ändern zu können, benötigen Sie ein "Clear Code"-Passwort. Falls Sie ein "Clear Code"-Passwort benötigen, setzen Sie sich mit Agilent in Verbindung und halten Sie die existierende Seriennummer bereit.

  4. Geben Sie zum Ändern der Seriennummer den "Clear Code" und die neue Seriennummer in die dafür vorgesehenen Felder ein und klicken Sie anschließend auf Change Serial.


Phasenoffset

"Phase Offset"

Siehe auch...

Diese Funktion addiert zu den Phasenmessdaten einen von Ihnen spezifizierten (positiven oder negativen) Offset von maximal 360°.


Messebenenverschiebung

"Port Extensions"

Siehe auch...

Diese Funktion verschiebt die Messebene. Wenn Sie nach einer Kalibrierung die Messanordnung ändern, können Sie mit Hilfe dieser Funktion die zusätzliche Signallaufzeit kompensieren und dadurch eine neue Kalibrierung vermeiden.

Port Extensions. Wenn dieses Kontrollkästchen angeklickt ist, wird die "Port extension"-Funktion auf den spezifizierten Port oder die spezifizierten Ports angewandt.

Input A. Spezifiziert die Strecke, um welche die Messebene für den Eingang A verschoben wird.

Input B. Spezifiziert die Strecke, um welche die Messebene für den Eingang B verschoben wird.

Port 1. Spezifiziert die Strecke, um welche die Messebene für den Port 1 verschoben wird.

Port 2. Spezifiziert die Strecke, um welche die Messebene für den Port 2 verschoben wird.

Velocity Factor. Spezifiziert den Ausbreitungsgeschwindigkeitsfaktor des nach der Kalibrierung eingefügten Bauteils. Der Wert für ein Kabel mit Polyethylen-Dielektrikum beträgt 0,66 und für ein Kabel mit Teflon-Dielektrikum der 0,7.


Signalpegel

"Power Level"

Siehe auch...

Definiert und steuert den Signalquellenpegel.

Power On. Schaltet die Signalquelle ein/aus.

Port Selection

Port. Spezifiziert den Port, für den die Werte gelten.

Port Power Coupled. Schaltet zwischen gekoppelten und entkoppelten Port-Signalpegeln um. Bei gekoppelten Port-Signalpegeln sind die Signalpegel an beiden Ports immer gleich groß. Bei entkoppelten Port-Signalpegeln können Sie den Signalpegel für jeden Port individuell einstellen.

Test Port Power. Spezifiziert den Signalpegel an dem betreffenden Ausgangsport.

Attenuator Control

Auto Couple Attenuation. Schaltet zwischen gekoppeltem und entkoppeltem Abschwächer/Signalquellenpegel um. Wenn der Abschwächer und der Signalquellenpegel gekoppelt sind, schaltet der Abschwächer automatisch in den passenden Bereich um, wenn Sie einen beliebigen Signalquellenpegel innerhalb des Arbeitsbereichs des Analysators wählen. Wenn der Abschwächer und der Messsignalpegel entkoppelt sind, können Sie den Abschwächungsfaktor und den Signalquellenpegel separat einstellen.

Attenuation. Spezifiziert den Abschwächungsfaktor des Abschwächers am Signalquellenausgang. Dieser Wert gilt nur für den Fall, dass der Abschwächer und der Signalquellenpegel voneinander entkoppelt sind.

Power Slope

Slope. Schaltet die "Power slope"-Funktion ein/aus.

Slope dB/GHz. Der spezifizierte "Power slope"-Wert kompensiert den Frequenzgang eines Bauteils innerhalb der Messanordnung durch eine spiegelbildliche, frequenzabhängige Anhebung des Signalquellenpegels.


Signalpegelwobbelung / Start-Stop

"Power Sweep"

Siehe auch...

Start Power. Spezifiziert den Signalpegel am Anfang des Signalpegelwobbelbereichs.

Stop Power. Spezifiziert den Signalpegel am Ende des Signalpegelwobbelbereichs.

Attenuation. Spezifiziert eine Abschwächung für Signalpegelwobbelung mit kleineren Signalpegeln.


Empfängerkalibrierung

Bei der Empfängerkalibrierung werden die analysatorinternen Empfänger auf einen ebenen Frequenzgang über den gesamten Frequenzbereich abgeglichen.

Erforderliche Messgeräte

  • Leistungsmessgerät: HP/Agilent E4419B (empfohlen), E4419A oder EPM-442A

  • Leistungssensor HP/Agilent 8482A

  • Leistungssensor HP/Agilent E4412A (wird in Verbindung mit dem Netzwerkanalysator E8356A nicht benötigt)

  • HF-Kabel HP/Agilent N6314A

  • Adapter Type-N weibl./weibl. HP/Agilent 1250-0777

Prozedur

  1. Vergewissern Sie sich, dass am Leistungsmessgerät die korrekten Kalibrierfaktoren für den Leistungssensor 8482A in die Tabelle "HP8482A" eingegeben wurden.

  2. Verbinden Sie das Leistungsmessgerät über ein GPIB-Kabel mit dem Netzwerkanalysator.

  3. Vergewissern Sie sich, dass der Leistungssensor 8482A (und bei Netzwerkanalysatoren E8357A/58A der Leistungssensor E4412A) korrekt an das Leistungsmessgerät angeschlossen ist.

  4. Zeigen Sie im System-Menü des Analysators auf Service, Adjustments und klicken Sie auf Receiver Calibration.

  5. Die Software identifiziert zunächst das Netzwerkanalysatormodell. Anschließend haben Sie drei Wahlmöglichkeiten:

    • Wenn Sie auf die Schaltfläche Inspect Flatness klicken, wird der Empfängerfrequenzgang angezeigt. Wenn Sie jeweils vor und nach der Kalibrierung auf diese Schaltfläche klicken, können Sie sich den Unterschied anschauen; nach der Kalibrierung ist der Frequenzgang begradigt.

    • Wenn Sie auf die Schaltfläche Calibrate klicken, beginnt die Empfängerkalibrierung. Die Software fordert Sie dazu auf, die Leistungssensoren, Kabel und Adapter anzuschließen (siehe Abbildungen 1 bis 3).

Anschluss des Leistungssensors an den Messanschluss des Analysators

Anschluss des Adapters und Kabels zwischen Leistungssensor und Messanschluss des Analysators

Durchgangsverbindung über Type-N-Kabel

Fehlersuche

Falls bei der Empfängerkalibrierung ein Problem auftritt, schlagen Sie bitte in Kapitel 3 des "E8356A/57A/58A Network Analyzer Service Guide" nach.


Speichern unter

"Save As"

Siehe auch...

Speichert eine Datei unter dem von Ihnen vorgegebenen Namen in das von Ihnen gewählte Verzeichnis ab.

Save in. Ermöglicht es Ihnen, das Verzeichnis zu wählen, in das die Datei abgespeichert wird.

File name: Es wird der Dateiname angezeigt, den Sie eingegeben oder in der Dateiliste angeklickt haben.

Save as type. Ermöglicht es Ihnen, aus der Liste der vom Analysator unterstützten Dateitypen einen Typ auszuwählen. Es können nur die Dateitypen "*.cst", "*.sta" und "*.cal" in den Analysator zurückgeladen werden. (Messkurven können nur im "Hold"-Zustand abgespeichert werden.)

Save. Die Datei wird unter dem von Ihnen vorgegebenen Namen in das von Ihnen gewählte Verzeichnis abgespeichert.


Scale-Feld

"Scale"

Siehe auch...

Spezifiziert die Skalierung der Messergebnisse.

Scale

Per Division. Spezifiziert den Wert eines Skalenteils (Abstand zwischen je zwei Gitterrasterlinien).

Auto. Die Messkurve wird automatisch so skaliert, dass sie in das Gitterraster passt.

Auto All. Innerhalb des aktiven Fensters werden alle Messkurven automatisch so skaliert, dass sie in das Gitterraster passen.

Reference

Level. Spezifiziert den Referenzpegelwert (für kartesische Darstellungsformate) bzw. den Wert des äußeren Kreises (für polare Darstellungsformate).

Position. Spezifiziert die Position der Referenzlinie (10 = oberste Gitterrasterlinie, 0 = unterste Gitterrasterlinie). Die Standardposition ist die mittlere Gitterrasterlinie (5).


Serieller Bus

"Serial Bus Test"

Dieser Test setzt voraus, dass die Analysator-Hardware genau die gleiche ist wie zum Zeitpunkt der Auslieferung des Gerätes. Falls eine der folgenden Baugruppen ausgetauscht wurde, liefert der Test eventuell falsche PASS/FAIL-Ergebnisse.

  • A8

  • A10

  • A11

  • A12

Dieser Test überprüft nacheinander 32 Messpunkte bei einer Frequenz von 300 kHz und anschließend alle Messpunkte, deren Werte frequenzabhängig sind, bei elf weiteren Frequenzen. Alle Messwerte werden in eine ASCII-Datei im Verzeichnis "service" geschrieben; alle außerhalb des Toleranzbereichs liegenden Messwerte werden in der Anwendung und in der Protokolldatei markiert.

Die nachfolgende Tabelle zeigt die getesteten Baugruppen und die Nummern der zugehörigen Messpunkte:

Baugruppe | Messpunktnummern
A12 Signalquelle | 111 bis 118
A10 Frequenzreferenz | 211 bis 218
A11 PLL-Schaltung | 311 bis 318
A8 Fractional-N-Synthesizer | 411 bis 418

Prozedur

Zeigen Sie im System-Menü auf Service und klicken Sie auf Serial Bus Test, Run.

Hinweis: Falls Fehler gemeldet werden, lesen Sie bitte im "Service Guide" nach.


"SICL/GPIB"

Siehe auch...

GPIB

Talker/Listener. Der Analysator wird so konfiguriert, dass er GPIB/SCPI-Nachrichten sowohl an den Systemcontroller (externer Computer) senden als auch von diesem empfangen kann.

Talker/Listener Address. Die GPIB-Adresse des als Talker/Listener konfigurierten Analysators.

System Controller. Der Analysator wird als Systemcontroller konfiguriert. (Der Systemcontroller kann externe GPIB-Geräte steuern).

System Controller Address. Die GPIB-Adresse des als Systemcontroller konfigurierten Analysators.

SICL

SICL Enabled. Wenn dieses Kontrollkästchen angeklickt ist, kann der Analysator GPIB-Programme auf seinem internen Computer ausführen, die Analysatorfunktionen steuern. Die Programme müssen aus einer GPIB-fähigen Programmierumgebung (beispielsweise VEE oder Visual Basic) heraus ausgeführt werden. Diese Betriebsart unterstützt keine Steuerung externer GPIB-Geräte.

Address. Die Adresse des Analysators.

GPIB Command Processor Console. Öffnet ein Fenster zum Senden einzelner SCPI/GPIB-Befehle.

  • Geben Sie einen gültigen Befehl mit gültigen Argumenten ein und drücken Sie "Enter".

  • Mit den Pfeiltasten können Sie zuvor eingegebene Befehle abrufen.

  • Drücken Sie zum Schließen des Konsolenfensters Control+Z.

  • Das Konsolenfenster wird eventuell durch das Fenster der Analysator-Anwendung verdeckt. Drücken Sie in diesem Fall Control+Tab, um das Konsolenfenster in den Vordergrund zu bringen.


Messkurvenglättung

"Smoothing"

Siehe auch...

Smoothing ON. Wenn dieses Kontrollkästchen angeklickt ist, werden die Messdaten punktweise über eine bestimmte Anzahl benachbarter Punkte (links und rechts des betreffenden Punktes) gemittelt. Die Anzahl der zur Mittelung herangezogen Punkte wird durch den Apertur-Wert bestimmt.

Per Cent of Span. Spezifiziert den Apertur-Wert für die "Smoothing"-Funktion in Prozent der Wobbelbandbreite. Wertebereich: 1.9% bis 25%.

Points. Spezifiziert den Apertur-Wert für die "Smoothing"-Funktion in Prozent der Gesamtanzahl der Messpunkte.


Signalquellenkalibrierung

Bei der Signalquellenkalibrierung wird die analysatorinterne Signalquelle auf einen ebenen Frequenzgang über den gesamten Frequenzbereich abgeglichen.

Erforderliche Messgeräte

  • Leistungsmessgerät: HP/Agilent E4419B (empfohlen), E4419A oder EPM-442A

  • Leistungssensor HP/Agilent 8482A

  • Leistungssensor HP/Agilent E4412A (wird in Verbindung mit dem Netzwerkanalysator E8356A nicht benötigt)

  • HF-Kabel HP/Agilent N6314A

Prozedur

  1. Vergewissern Sie sich, dass am Leistungsmessgerät die korrekten Kalibrierfaktoren für den Leistungssensor 8482A in die Tabelle HP8482Aeingegeben wurden.

  2. Verbinden Sie das Leistungsmessgerät über ein GPIB-Kabel mit dem Netzwerkanalysator.

  3. Vergewissern Sie sich, dass der Leistungssensor 8482A (und bei Netzwerkanalysatoren E8357A/58A der Leistungssensor E4412A) korrekt an das Leistungsmessgerät angeschlossen ist.

  4. Zeigen Sie im Service-Menü des Analysators auf Adjustments und klicken Sie auf Source Calibration.

  5. Die Software identifiziert zunächst das Netzwerkanalysatormodell. Anschließend haben Sie drei Wahlmöglichkeiten:

    1. Wenn Sie auf Inspect Linearity klicken, wird die Linearität der Signalquellenpegeländerung über der Frequenz angezeigt. Wenn Sie jeweils vor und nach der Signalquellenkalibrierung auf diese Schaltfläche klicken, können Sie den Unterschied beobachten: durch die Kalibrierung verbessert sich die Pegellinearität über der Frequenz.

    2. Wenn Sie auf Inspect Amplitude klicken, wird die Linearität des Signalquellenpegels über der Frequenz für drei verschiedene Signalpegel angezeigt: –5 dBm, 0 dBm und +5 dBm. Wenn Sie jeweils vor und nach der Signalquellenkalibrierung auf diese Schaltfläche klicken, können Sie den Unterschied beobachten: durch die Kalibrierung verbessert sich die Pegellinearität bei den drei Pegeln.

    3. Wenn Sie auf die Schaltfläche Calibrate klicken, beginnt die Kalibrierung. Die Software fordert Sie dazu auf, die Leistungssensoren und Kabel wie erforderlich anzuschließen (siehe Abbildungen 1 bis 2).

Anschluss des Leistungssensors an den Messanschluss des Analysators

Durchgangsverbindung über spezifiziertes Type-N-Kabel

Ergänzende Informationen

Die Kalibrierung ermittelt nur die für Port 1 erforderlichen DAC-Werte; es wird vorausgesetzt, dass die beiden Ports das gleiche Verhalten zeigen.

Hinweis: Die Signalquellenkalibrierung dauert mindestens 20 Minuten (beim E8356A) und höchstens 45 Minuten (beim E8358A).

Fehlersuche

Falls bei der Signalquellenkalibrierung ein Problem auftritt, schlagen Sie bitte in Kapitel 3 des "E8356A/57A/58A Network Analyzer Service Guide" nach.


Start- und Stop-Frequenzen

"Start" und "Stop"

Siehe auch...

Start. Spezifiziert die Frequenz am Anfang des Frequenzwobbelbereichs.

Stop. Spezifiziert die Frequenz am Ende des Frequenzwobbelbereichs.


Einrichten der Wobbelung

"Sweep Setup"

Siehe auch...

Channel. Spezifiziert den Kanal, für den die Einstellungen gelten.

Stepped Sweep. Wenn dieses Kontrollkästchen angeklickt ist, wird die Signalquellenfrequenz stufenweise gewobbelt.

Dwell Time. Spezifiziert die Verweildauer für stufenweise Wobbelung. Der Analysator verweilt an jedem Messpunkt so lange, wie dieser Wert vorgibt.

Alternate Sweeps. Wenn dieses Kontrollkästchen angeklickt ist, misst der Analysator in aufeinanderfolgenden Wobbelzyklen abwechselnd über den einen oder den anderen Empfänger.

External ALC. Wenn dieses Kontrollkästchen angeklickt ist, erwartet der Analysator ein externes Pegelregelungssignal am "External Detector Input" auf der Rückwand.


Wobbelzeit

"Sweep Time"

Siehe auch...

Spezifiziert die Wobbelzeit, d. h. die Dauer einer Wobbelmessung. In der Standardeinstellung wählt der Analysator automatisch die größtmögliche Wobbelgeschwindigkeit, die mit den übrigen Messparametern vereinbar ist. Sie können jedoch eine davon abweichende Wobbelzeit wählen, die innerhalb der Möglichkeiten des Analysators liegt. Wenn Sie eine Wobbelzeit von 0 Sekunden eingeben, schaltet der Analysator wieder auf automatische Wobbelzeitwahl um.


Wobbelungstyp

Siehe auch...

Channel. Spezifiziert den Kanal, für den die Einstellungen gelten.

Sweep Type

Linear Frequency Aktiviert eine lineare Frequenzwobbelung; das Messergebnis wird im Standardgitterraster mit zehn äquidistanten horizontalen Skalenteilen angezeigt. Dies ist der Standard-Wobbelungstyp (Preset-Einstellung).

Start. Definiert die Start-Frequenz des Wobbelbereichs.

Stop Definiert die Stop-Frequenz des Wobbelbereichs.

Points. Spezifiziert Anzahl der Messpunkte pro Wobbelung. Sie können einen Wert zwischen 2 und 1601 eingeben. Der Standardwert ist 201.

Power Sweep. Aktiviert eine Signalpegelwobbelung bei der von Ihnen spezifizierten Festfrequenz. In der Grundeinstellung beträgt der Start-Pegel –10 dBm und der Stop-Pegel 0 dBm. Sie können einen beliebigen Pegelbereich < 25 db vorgeben.

Start. Definiert den Start-Pegel des Wobbelbereichs.

Stop. Definiert den Stop-Pegel des Wobbelbereichs.

CW Frequency. Definiert die Festfrequenz, bei der die Pegelwobbelung erfolgt.

CW Time. Aktiviert eine Betriebsart, in welcher der Analysator auf eine feste Frequenz eingestellt ist und die Messdaten über der Zeit dargestellt werden.

CW Frequency. Definiert die Festfrequenz, bei welcher der Analysator während der Messung verbleibt.

Sweep Time. Definiert die Dauer der Messung.

Points. Spezifiziert Anzahl der Messpunkte pro Wobbelung. Sie können einen Wert zwischen 2 und 1601 eingeben. Der Standardwert ist 201.

Segment Sweep. Aktiviert eine Wobbelung über diskrete Frequenzpunkte oder Frequenzbereiche. Sie können bis zu 30 solcher Frequenzbereiche ("Segmente") spezifizieren. Für jedes Segment können Sie den Messsignalpegel und die ZF-Bandbreite individuell vorgeben.

Independent Power Levels. Wenn dieses Kontrollkästchen angeklickt ist, können Sie den Messsignalpegel für jedes Segment individuell spezifizieren.

Independent IF Bandwidth. Wenn dieses Kontrollkästchen angeklickt ist, können Sie die ZF-Bandbreite für jedes Segment individuell spezifizieren.

Independent Sweep Time. Definiert die Dauer der Messung für jedes einzelne Segment.

Show Table. Die Tabelle zum Erstellen und Bearbeiten von Segmenten wird angezeigt.

Hide Table. Die Segmenttabelle verschwindet vom Bildschirm.


Systemverifikation

Die nachfolgend beschriebene Prozedur dient dazu, die Systemgenauigkeit des Analysators zu verifizieren. Bei dieser Prozedur werden die Amplituden- und Phasenfrequenzgänge aller vier S-Parameter sämtlicher Verifikationsgeräte gemessen und verglichen mit

  • im Werk gemessenen Referenzdaten (in Form von Dateien auf der Verifikationsdiskette)

  • Grenzwertlinien für die Messunsicherheit

Hinweis: Obwohl bei dieser Prozedur alle vier S-Parameter gemessen werden, bleiben die Phasenmessunsicherheiten der Parameter S11 und S22 unberücksichtigt (und erscheinen auch nicht auf den Ausdrucken), weil sie für die Systemgenauigkeit von untergeordneter Bedeutung sind.

Durch Anklicken der Schaltfläche gelangen Sie zu weiteren Informationen.

Benötigte Geräte

Messkabel von anderen Herstellern

Kalibrier-Kits von anderen Herstellern

Vorsichtsmaßnahmen beim Umgang mit Rohrleitungen

Flussdiagramm der Prozedur

Prozedur zur Systemverifikation

Falls das System den Verifikationstest nicht besteht

Interpretation der Verifikationsergebnisse

Benötigte Geräte

Kalibrier-Kit (Type-N)1,2 | 85032F
ECal-Modul (Type-N)3 | 85092B
Verifikations-Kit (Type-N) | 85055A
HF-Kabel (Type-N) | N6314A
1 Verwenden Sie entweder das Kalibrier-Kit oder das ECal-Modul.
2 Alternative: 3,5 mm-Kalibrier-Kit 85033E.
3 Alternative: 3,5 mm-ECal-Modul 85093B.

Messkabel von anderen Herstellern

Die für das Netzwerkanalysatorsystem spezifizierten Messkabel wurden charakterisiert hinsichtlich Wiederholgenauigkeit der Steckverbinder, Amplituden- und Phasenstabilität beim Biegen, Rückflussdämpfung, Einfügedämpfung und Alterungsrate. Die Qualität der Messkabel ist von großer Bedeutung für die Systemgenauigkeit. Minderwertige Messkabel vergrößern die Messunsicherheit. Es wird dringend empfohlen, die Messkabel regelmäßig zu überprüfen.

Falls Sie für die Systemverifikation ein Messkabel von einem anderen Hersteller als Agilent verwenden, vergewissern Sie sich, dass dieses die Spezifikationen des Type-N-Kabels Agilent N6314A einhält oder übertrifft. Die Spezifikationen des Kabels N6314A finden Sie im zugehörigen Benutzerhandbuch.

Kalibrier-Kits von anderen Herstellern

Kalibrier-Kits von anderen Herstellern als Agilent werden weder empfohlen noch unterstützt.

Vorsichtsmaßnahmen beim Umgang mit Rohrleitungen

Beachten Sie beim Umgang mit den im Kalibrier-Kit enthaltenen Rohrleitungen unbedingt die folgenden Hinweise.

  • Achten Sie sorgfältig darauf, dass der Innen- oder Außenleiter der Rohrleitung nicht hinfällt. Beim Hinfallen können diese Bauteile sehr leicht beschädigt werden.

  • Wenden Sie die allgemein bekannten Schutzmaßnahmen gegen elektrostatische Entladung (ESD) an.

  • Waschen Sie sich die Hände oder ziehen Sie Handschuhe an, da Hautfett die elektrischen Eigenschaften dieser Präzisionsteile verändern kann.

Flussdiagramm der Prozedur

Das folgende Software-Flussdiagramm zeigt den Ablauf der Verifikationsprozedur.

Prozedur zur Systemverifikation

  1. Schließen Sie ein Kabel an den Analysator-Port 2 an. Falls Sie die Testergebnisse ausdrucken möchten, schließen Sie einen Drucker an den Analysator an. Lassen Sie den Analysator mindestens 30 Minuten lang warmlaufen.

Messanordnung für die Systemverifikation

  2. Legen Sie die mit dem PNA-Verifikations-Kit gelieferte Diskette in das Diskettenlaufwerk des Analysators.

  3. Zeigen Sie im System-Menü auf Service, und klicken Sie auf System Verification. Es erscheint das Fenster "System Verification".

Fenster "System Verification"

  4. Wählen Sie in dem Feld Calibration Kit das verwendete Kalibrier-Kit. Im Feld Verification Kit wird das zu verwendende Verifikations-Kit angezeigt.

  5. Klicken Sie unter Printer Output auf eine der folgenden Optionen:

    • "None" Die Ergebnisse werden nicht ausgedruckt.

    • "Tabular Data": Die Messdaten und Unsicherheitsgrenzen werden in Tabellenform ausgedruckt. Weiter unten finden Sie ein Beispiel für eine solche Tabelle.

    • "Measurement Plots": Die Messergebnisse werden in Form einer Grafik ausgedruckt. Die Grafik enthält die aktuellen Messkurven, die im Werk gemessenen Kurven und die Unsicherheitsgrenzen. Weiter unten finden Sie ein Beispiel für eine solche Grafik.

    • "Both": Die Messergebnisse werden als Tabelle und als Grafik ausgedruckt.

Hinweis: Für den Fall, dass Sie die Ergebnisse ausdrucken möchten, wird hier vorausgesetzt, dass der Windows-2000-Treiber für Ihren Drucker bereits installiert ist und Sie überprüft haben, dass die Druckausgabe vom Analysator an den Drucker ordnungsgemäß funktioniert. Die Verifikationssoftware sendet die Druckdaten stets zu dem als "Windows-Standarddrucker" eingerichteten Drucker (siehe "Drucker" in der Windows-Systemsteuerung).

  6. Im System Verification Configure-Menü können Sie die Prozedur zur Systemverifikation folgendermaßen beeinflussen:

    • Im Calibration-Untermenü können Sie zwischen zwei Kalibrierverfahren wählen.

      • Perform a calibration (Standardeinstellung) – Die Software führt Sie durch eine 2-Port-Kalibrierung unter Verwendung des gewählten Kalibrier-Kits.

      • Load previous calibration – Die Software fordert Sie auf, eine Kalibrierdaten-Datei (*.cst) zu laden, die bei einer früheren Systemverifikation angelegt wurde.

    • Im Devices to Measure-Untermenü können Sie wählen, welche Kalibriernormale während der Systemverifikation gemessen werden. Standardmäßig werden alle im Kalibrier-Kit enthaltenen Normale gemessen. Nur dann ist die Systemverifikation vollständig und aussagekräftig.

  7. Klicken Sie auf Run.

  8. Wenn Sie während der Systemverifikation aufgefordert werden, die Verifikationsgeräte anzuschließen, schließen Sie diese gemäß der folgenden Abbildung an.

Anschluss der Verifikationsgeräte

Schritt-für-Schritt-Beschreibung des Verifikationsprozesses

  1. Je nachdem, welche Option Sie im "Calibration"-Untermenü des "Configure"-Menüs gewählt haben, werden Sie entweder aufgefordert, eine zuvor gespeicherte Kalibrierdaten-Datei zu laden, oder Sie werden durch eine vollständige 2-Port-Kalibrierung unter Verwendung des gewählten Kalibrier-Kits geführt. Bei Verwendung eines ECal-Moduls wird das Modul nur einmal angeschlossen; während die Software die Kalibrierung durchführt, wird eine "Standby"-Meldung (bitte warten) angezeigt.

  2. Sie werden aufgefordert, das erste Verifikationsgerät anzuschließen.

  3. Die Software liest aus der mit dem Verifikations-Kit gelieferten Datei (im CITIfiles-Format) die im Werk abgespeicherten Messdaten zu diesem Normal und die Unsicherheitswerte zu diesen Daten.

  4. Die Software sendet diese Daten zusammen mit Kalibrier-Kit- und Gerätezustandsinformationen an eine spezielle DLL, die daraus die für Ihren Analysator geltenden (gerätespezifischen) Unsicherheitswerte berechnet.

  5. Der Analysator wird zunächst für die Messung der Amplituden aller vier S-Parameter in jeweils unterschiedlichen Fenstern eingerichtet (Darstellungsformate: "Lin mag" für S11 und S22, "Log mag" für S21 und S12). Die im Werk gemessenen S-Parameter werden als gespeicherte Messkurven für das betreffende Fenster geladen. Durch Addieren der im Werk ermittelten Messdatenunsicherheiten und der von der DLL berechneten gerätespezifischen Unsicherheiten berechnet die Software die anzuwendenden Grenzwertlinien-Offsets. Es werden obere und untere Grenzwertlinien angezeigt (im Werk ermittelte Messunsicherheitsdaten + gerätespezifische Unsicherheit bzw. im Werk ermittelte Messunsicherheitsdaten – gerätespezifische Unsicherheit). Der Analysator führt eine Wobbelmessung und einen automatischen Grenzwerttest durch. Die Ergebnisse der Grenzwerttests (PASS oder FAIL) werden in den vier Fenstern angezeigt.

  6. Wenn Sie bereit sind, die Phasenmessungen zu starten, klicken Sie auf eine Schaltfläche. Daraufhin werden die vier Fenster für Phasenmessungen eingerichtet, es werden die Phasenmessungen durchgeführt, die im Werk ermittelten Phasenmessdaten geladen, Grenzwerttests durchgeführt und deren Ergebnisse angezeigt.

  7. Falls einer der insgesamt acht Grenzwerttests das Ergebnis FAIL liefert, gibt die Software Hinweise zur Fehlerdiagnose und fragt Sie, ob die Messungen an dem betreffenden Verifikationsgerät wiederholt werden sollen, oder ob mit den Messungen am nächsten Verifikationsgerät fortgefahren werden soll. Wenn Sie mit den Messungen am nächsten Verifikationsgerät fortfahren, werden die im Werk gemessenen Daten und Unsicherheiten von der Diskette geladen, die DLL berechnet wiederum die gerätespezifischen Unsicherheiten, die vier Fenster werden für Amplitudenmessungen am nächsten Verifikationsgerät eingerichtet, und die Messungen und Grenzwerttests werden durchgeführt.

  8. Dies geht so weiter, bis alle Messungen an allen gewählten Verifikationsgeräten abgeschlossen sind. Danach öffnet sich ein Fenster mit einer Zusammenfassung der PASS/FAIL-Ergebnisse für alle vier S-Parameter jedes einzelnen Verifikationsgeräts.

Falls das System den Verifikationstest nicht besteht

WICHTIG: Überprüfen Sie alle Verbindungen. Entfernen Sie das Messkabel nicht vom Messanschluss des Analysators. Dadurch würde die zuvor durchgeführte Kalibrierung ungültig werden.

  1. Wiederholen Sie die Verifikationsprozedur. Achten Sie darauf, dass die Befestigungsmuttern der Steckverbinder mit dem vorgeschriebenen Drehmoment angezogen werden.

  2. Trennen Sie das Verifikationsgerät, bei dem der Grenzwerttest das Ergebnis FAIL lieferte, ab und reinigen Sie es; schließen Sie es dann wieder an. Führen Sie die betreffende Messung nochmals durch.

  3. Falls der Grenzwerttest danach immer noch das Ergebnis FAIL liefert, überprüfen Sie die Kalibrierung anhand der Fehlerterme (siehe "Front Panel Access to Error Terms" auf Seite 4-7 des "Service Guide").

  4. Die folgende Grafik enthält weitere Hinweise zur Vorgehensweise bei fehlgeschlagener Verifikation.

Vorgehensweise bei fehlgeschlagener Verifikation

Interpretation der Verifikationsergebnisse

Die folgende Abbildung zeigt ein typisches Beispiel für eine Verifikationsergebnis-Tabelle, wie sie erstellt wird, wenn Sie im Bereich Printer Output des Fensters System Verification die Option Tabular Data gewählt haben. Weiter unten ist eine Verifikationsergebnis-Grafik dargestellt, wie sie erstellt wird, wenn Sie im Bereich Printer Output des Fensters System Verification die Option Measurement Plots gewählt haben. Diese Ausdrucke enthalten einen Vergleich der bei Ihren Messungen ermittelten Daten mit den im Werk ermittelten (auf internationale Normale rückführbaren) Messdaten und Unsicherheitsspezifikationen. Anhand dieser Ausdrucke können Sie schnell und einfach feststellen, ob Ihre Messdaten bei allen Frequenzen innerhalb der spezifizierten Gesamt-Unsicherheitsgrenzen liegen.

Die Verifikationsergebnis-Tabelle enthält folgende Informationen:

  • Frequenz des jeweiligen Datenpunkts (in MHz).

  • Unterer Grenzwert gemäß Gesamtsystem-Messunsicherheitsspezifikation.

  • Messergebnis

  • Oberer Grenzwert gemäß Gesamtsystem-Messunsicherheitsspezifikation.

  • Ergebnis des automatischen Grenzwerttests (PASS oder FAIL) für den betreffenden Messpunkt.

Ausgedruckte Verifikationsergebnis-Tabelle

Die ausgedruckte Verifikationsergebnis-Grafik enthält folgende Informationen:

  • Obere Grenzwertlinie gemäß Gesamtsystem-Messunsicherheitsspezifikation.

  • Untere Grenzwertlinie gemäß Gesamtsystem-Messunsicherheitsspezifikation.

  • Die im Werk gemessenen Daten.

  • Ergebnisse der Verifikationsmessungen.

  • Messparameter-Namen und -Formate ("Lin Mag" oder "Log Mag").

  • Seriennummer des jeweiligen Verifikationsgeräts (00810).

  • Bezeichnung des jeweiligen Verifikationsgeräts (Sys Ver 20 dB attenuator).

Ausgedruckte Verifikationsergebnis-Grafik


Messkurvenstatistiken

"Trace Statistics"

Siehe auch...

Statistics. Wenn dieses Kontrollkästchen angeklickt ist, werden der Mittelwert, die Standardabweichung und die Spitze-Spitze-Werte der aktiven Messkurve berechnet und angezeigt.

Span. Spezifiziert das Frequenzband innerhalb der aktiven Messkurve, auf dem die mathematische Operation durchgeführt wird. Sie können für jede Messkurve bis zu neun benutzerdefinierte Frequenzbänder definieren. (Benutzerdefinierte Frequenzbänder können auch im Dialogfenster "Marker Search" definiert werden.)

Start. Definiert die Start-Frequenz eines benutzerdefinierten Frequenzbandes.

Stop. Definiert die Stop-Frequenz eines benutzerdefinierten Frequenzbandes.


Transformation

"Time Domain Transform"

Siehe auch...

Diese Funktionen ermöglichen es, die Zeitbereichantwort eines Bauteils darzustellen.

Transform. Wenn dieses Kontrollkästchen angeklickt ist, wendet der Analysator einen Algorithmus an, der die Frequenzbereich-Messdaten in den Zeitbereich transformiert.

Start. Spezifiziert den Anfang der gemessenen Zeitspanne. Bei einem Start-Zeit-Wert von 0 Sekunden beginnt die Messzeitspanne unmittelbar an der Messebene.

Stop. Spezifiziert das Ende der gemessenen Zeitspanne. Dieser Wert bezieht sich auf den Zeitpunkt, da das Stimulussignal gesendet wurde.

Center. Spezifiziert die Mitte des Messbereichs. Dieser Wert kann an einer beliebigen Stelle des vom Analysator abgedeckten Gesamtmessbereichs liegen.

Span. Spezifiziert die gemessene Zeitspanne (links und rechts vom Mittenwert).

Transform Mode

Low Pass Impulse. Spezifiziert das Transformationsverfahren "Tiefpass-Impuls-Stimulus". Dieses eignet sich für Messobjekte, die Frequenzen bis hinab zu 0 Hz durchlassen. Ergebnis der Messung ist die Impulsantwort des Messobjekts.

Low Pass Step. Spezifiziert das Transformationsverfahren "Tiefpass-Sprung-Stimulus". Dieses eignet sich für Messobjekte, die Frequenzen bis hinab zu 0 Hz durchlassen. Ergebnis der Messung ist die Sprungantwort des Messobjekts.

Band Pass. Spezifiziert das Transformationsverfahren "Bandpass". Dieses eignet sich für bandbegrenzte Messobjekte mit einer unteren Grenzfrequenz ungleich Null. Ergebnis der Messung ist die Impulsantwort. (Die Sprungantwort kann in dieser Betriebsart nicht gemessen werden).

Set Frequency Low Pass. Die Messpunkte werden gleichmäßig über den Bereich verteilt, wenn die Betriebsart "Low pass" benutzt wird. Dies ermöglicht es Ihnen, vor der Zeitbereichtransformation eine Kalibrierung durchzuführen.


Zeittor

"Time Domain Gate"

Siehe auch...

Diese Funktionen ermöglichen es Ihnen, ausgewählte Zeitbereichantworten rechnerisch zu unterdrücken.

Gating. Es wird ein Zeittorfilter angewandt, das die ausgewählten Zeitbereichantworten unterdrückt.

Start. Spezifiziert die Start-Zeit für das Zeittorfilter.

Stop. Spezifiziert die Stop-Zeit für das Zeittorfilter.

Center. Spezifiziert die Mitte des Zeittors. Dieser Wert kann an einer beliebigen Stelle des vom Analysator abgedeckten Gesamtmessbereichs liegen.

Span. Spezifiziert die Länge des Zeittors.

Gate Type: Definiert die Art der von der "Gating"-Funktion durchgeführten Filterung.

Gate Shape. Definiert die Filtercharakteristiken der "Gating"-Funktion.


Zeitbereichfenster

"Time Domain Window"

Siehe auch...

Es wird ein Filter angewandt, das Ihnen hilft, einzelne Antworten im Zeitbereich zu identifizieren.

Minimum. Dieses Filter ergibt eine kleine Impulsbreite und die bestmögliche Auflösung.

Maximum. Dieses Filter reduziert die Seitenkeulenamplituden und ergibt den größtmöglichen Dynamikbereich.

Kaiser Beta. Spezifiziert die Fenstercharakteristiken durch einen Kaiser-Beta-Wert.

Impulse Width. Spezifiziert die Fenstercharakteristiken durch einen Impulsbreitenwert.


Trigger

Siehe auch...

Die Triggerbedingung definiert, wann und wie die analysatorinterne Stimulussignalquelle das Messsignal ausgibt. Siehe Trigger-Animation.

Triggerquelle

Internal Der Analysator erzeugt nach Abschluss einer Messung automatisch einen internen Trigger. Dadurch wird eine kontinuierliche Folge von Messungen ausgelöst.

Manual. Der Analysator wird manuell durch Drücken der Taste Trigger getriggert.

External. Der Analysator wird durch ein externes Triggersignal getriggert.

Trigger Scope (betrifft nur die Triggerbetriebsarten Manual und External)

Global. Bei Empfang eines Triggers führt der Analysator in jedem Kanal eine Wobbelmessung durch.

Channel. Bei Empfang eines Triggers führt der Analysator in einem einzigen Kanal eine Wobbelmessung durch. Der darauffolgende Trigger löst eine Messung im nächsten Kanal aus, usw.

Channel Trigger State

Channel. Spezifiziert den Kanal, für den die Einstellungen gelten.

Continuous. Bei Empfang eines Triggers führt der Analysator in dem betreffenden Kanal eine Wobbelmessung durch.

Enable Groups. Bei Empfang eines Triggers führt der Analysator in dem betreffenden Kanal die zuvor spezifizierte Anzahl von Wobbelmessungen durch.

Number of Groups. Spezifiziert die Anzahl von Wobbelmessungen, die der Analysator nach Empfang eines Triggers durchführt, bevor er in den "Hold"-Zustand übergeht.

Single. Bei Empfang eines Triggers führt der Analysator in dem betreffenden Kanal eine Einzelwobbelung durch und geht dann in den "Hold"-Zustand über.

Hold. Der Analysator führt in dem betreffenden Kanal keine weitere Wobbelmessung durch, sondern zeigt dauerhaft die zuletzt erfassten Messdaten an.

Point Sweep. (Betrifft nur die Triggerquelle "Manual" und den "Trigger State Channel". ) Jedesmal, wenn Sie die Taste Trigger drücken, führt der Analysator eine Einzelmessung am nächsten Datenpunkt durch.


Fenstertitel

"Window Title"

Siehe auch...

Ermöglicht es Ihnen, dem aktuellen Fenster einen Titel zu geben.


Systemimpedanz

"System Z0"

Siehe auch...

Ermöglicht es Ihnen, die (rechnerische) Systemimpedanz gegenüber dem Standardwert 50 Ohm abzuändern; alle Berechnungen werden dann auf der Basis des eingegebenen Systemimpedanzwertes durchgeführt.

Wenn Sie beispielsweise Messungen an 75-Ohm-Bauteilen durchführen möchten:

  • Ändern Sie die Systemimpedanz Z0 auf 75 Ohm ab.

  • Schließen Sie das 75-Ohm-Bauteil beidseitig über je ein Minimaldämpfungsglied an den Analysator an.

  • Führen Sie eine Kurzschluss-, Leerlauf- und 75-Ohm-Lastkalibrierung durch; verwenden Sie hierfür ein Kalibrier-Kit mit 75-Ohm-Kalibriernormaldefinitionen.


LAN-Anschluss

Einbinden des Analysators in ein lokales Netzwerk

Siehe auch...

Klicken Sie auf eine Schaltfläche, um Informationen darüber zu erhalten, wie der Analysator in ein lokales Netzwerk eingebunden wird.

Weitere Netzwerkanalysatorbenutzer

Abbilden eines Netzlaufwerks

Konfigurieren des Analysators für COM/DCOM-Programmierung

Besonderheiten von Windows 2000


Einführung

Kurze Einführung

Siehe auch...

Klicken Sie auf eine Schaltfläche, um den Analysator schnell kennen zu lernen.

Übersicht über die Frontplatte

Übersicht über die Rückwand

Benutzerschnittstelle

Bedienungskonzept

Allgemeine Messprozedur

Benutzung der Online-Hilfe

Vernetzung und Netzwerkfähigkeiten des Analysators

Notfall-Wiederherstellungsdiskette


Besonderheiten von Windows 2000

Siehe auch...

Nachfolgend werden einige Unterschiede von Windows 2000 im Vergleich zu älteren Windows-Versionen erläutert, die Ihnen bei der Benutzung des Analysators vielleicht auffallen werden. Ausführliche Informationen über diese und verwandte Themen finden Sie in der Online-Hilfe zu Windows 2000.

Verwendung der USB-Schnittstelle

Der PNA besitzt zwei USB-Schnittstellen zum Anschluss anderer Geräte: eine auf der Frontplatte und eine auf der Rückwand. Die wichtigsten Vorteile der USB-Schnittstelle sind die hohe Datenübertragungsrate und die Möglichkeit, Geräte während des Betriebs anzuschließen oder abzutrennen. Die ECal-Module für die elektronische Kalibrierung sind jetzt auch in Versionen mit USB-Schnittstelle erhältlich.

Wenn Sie zum ersten Mal ein Gerät an die USB-Schnittstelle anschließen, müssen Sie kurze Zeit warten. Windows 2000 meldet, dass es die Hardware identifiziert, dann den passenden Treiber sucht und dann den Treiber installiert (falls er gefunden wurde).

Wenn Sie das gleiche Gerät später nochmals an die gleiche USB-Schnittstelle anschließen, geht dies schnell und einfach vonstatten. Wenn Sie es allerdings an eine andere USB-Schnittstelle anschließen, müssen Sie nochmals die Hardware-Erkennung und die Treibersuche abwarten.

Plug & Play-Stabilität und -Sicherheit

Die Plug & Play-Funktionalität von Windows 2000 ist ganz ähnlich wie die von Win 95 oder 98; sie gewährleistet eine stabile und sichere Betriebsumgebung. Sie werden außerdem feststellen, dass sie die Anzahl der erforderlichen Systemneustarts erheblich verringert.

LAN-Anschluss

Windows 2000 unterstützt DHCP und feste IP-Adressen. Das LAN-Kabel kann während des Betriebs angeschlossen oder abgetrennt werden; der aktuelle LAN-Status wird in der "System Tray" angezeigt; dies macht den LAN-Anschluss intuitiver. Zusätzlich ist ein Hardware-Assistent verfügbar, der Sie beim Konfigurieren der Systemhardware unterstützt.

Einfach- und Doppelklick-Option

Bei Windows 2000 lassen sich die durch Symbole repräsentierten Funktionen standardmäßig durch einfaches Anklicken des Symbols starten. Wenn Sie möchten, dass hierzu ein Doppelklick erforderlich ist, gehen Sie in die Systemsteuerung (Startmenü -> Einstellungen -> Systemsteuerung) und klicken Sie auf "Maus". Wählen Sie im Dialogfenster "Mauseigenschaften" "Doppelklick zum Öffnen". Klicken Sie anschließend auf OK.


3,5-Zoll-Diskettenlaufwerk

Das Diskettenlaufwerk kann dazu verwendet werden, Dateien auf das Festplattenlaufwerk des Analysators zu installieren oder vom Analysator generierte Dateien auf Diskette abzuspeichern. Sie können über den NT Explorer auf das Diskettenlaufwerk zugreifen.

  • Speicherkapazität (unformatiert): 2 MB
  • Kompatibel mit: Disketten der Typen High Density (2HD) und Normal Density (2DD)
  • Datenübertragungsrate: 500 kbit/s

Zurück zur Frontplatte


Fensteranordnungen

Taste "Arrange"

Ermöglicht es Ihnen, zwischen vier Fensteranordnungen zu wählen: "Overlay", "Stack 2", "Split 3" oder "Quad 4".


Aux-Ausgang 2

Hilfsausgang (Port 2)

Siehe auch...

Diese SMA-Steckverbindungen (weiblich) ermöglichen es Ihnen, benutzerspezifische Messanordnungen zu realisieren.

Direktzugriff-Brücke für Empfänger B

  • Der obere "B"-Anschluss ist der Ausgang des Koppelarms des Port-2-Kopplers.

  • Der untere Anschluss führt direkt zum Eingang des Empfängers "B". Bei Geräten mit Option 015 führt der Pfad direkt zu einem schaltbaren Abschwächer und dann zum Empfängereingang.

Empfängereingang:

Maximaler Eingangssignalpegel (Übersteuerungsgrenze):

–6 dBm; <0,4 dB Kompression (300 kHz bis 3 GHz)
–6 dBm; <0,8 dB Kompression (3 GHz bis 6 GHz)
–11 dBm; <0,8 dB Kompression (6 GHz bis 9 GHz)

Eigenrauschpegel (eff., 10 Hz Bandbreite):

<–133 dBm (300 kHz bis 3 GHz)
<–123 dBm (3 GHz bis 6 GHz)
<–123 dBm (6 GHz bis 9 GHz)

Absoluter Leistungsgrenzwert: +26 dBm

Maximal zulässige DC-Eingangsspannung: 40 V (Standard), 0 V (Option 015)

Rückflussdämpfung:

>17 dB (300 kHz bis 3 GHz)
>12 dB (3 GHz bis 6 GHz)
>7 dB (6 GHz bis 9 GHz)

Referenzkanal-Brücke

  • Die obere Steckverbindung führt das Signal vom Richtungsumschalter-Ausgang "Reference 2".

  • Die untere Steckverbindung ist direkt mit dem Empfängereingang R2 verbunden.

Empfängereingang:

Maximaler Eingangssignalpegel (Übersteuerungsgrenze):

–6 dBm; <0,4 dB Kompression (300 kHz bis 3 GHz)
–6 dBm; <0,8 dB Kompression (3 GHz bis 6 GHz)
–11 dBm; <0,8 dB Kompression (6 GHz bis 9 GHz)

Absoluter Leistungsgrenzwert: >+26 dBm

Für PLL-Synchronisation erforderlicher Mindest-Eingangssignalpegel:

–35 dBm (300 kHz bis 3 GHz)
–25 dBm (3 GHz bis 9 GHz)

Referenzausgang: (bei Verwendung eines externen Eingangssignals zur Synchronisation der Signalquelle)

Ausgangssignalpegel:

–5 bis –30 dBm (300 kHz bis 6 GHz)
–10 bis –35 dBm (6 GHz bis 9 GHz)

Rückflussdämpfung infolge Quellenanpassung:

16 dB (300 kHz bis 3 GHz)
14 dB (3 GHz bis 9 GHz)

Absoluter Leistungsgrenzwert: >+26 dBm

Maximal zulässige DC-Eingangsspannung: 40 V

Messanschluss-Brücke (nur für Geräte mit Option 015)

  • Der obere "R2"-Anschluss ist der Ausgang des Richtungsumschalters des Port-2-Kopplers.

  • Die untere Steckverbindung führt direkt zum Haupteingang des Port-2-Kopplers. An diesem Punkt kann ein Abschwächer zum Schutz des Empfängereingangs eingeschleift werden.

Quellenausgang:

Ausgangssignalpegel:

+12 bis –83 dBm (300 kHz bis 6 GHz)
+7 bis –88 dBm (6 GHz bis 9 GHz)

Quellenanpassung: 15 dB bei 9 GHz

Eingang zum Koppler:

Einfügedämpfung zu Port 1:

<3,5 dB bei 3 GHz
<5 dB bei 9 GHz

Maximale Eingangsleistung (Übersteuerungsgrenze): 2 Watt, CW

Absoluter Leistungsgrenzwert: 4 Watt, CW

Zurück zur Frontplatte


Aux-Ausgang 1

Hilfsausgang (Port 1)

Siehe auch...

Diese SMA-Steckverbindungen (weiblich) ermöglichen es Ihnen, benutzerspezifische Messanordnungen zu realisieren.

Direktzugriff-Brücke für Empfänger A

  • Der obere "A"-Anschluss ist der Ausgang des Koppelarms des Port-1-Kopplers.

  • Der untere Anschluss führt direkt zum Eingang des Empfängers "A". Bei Geräten mit Option 015 führt der Pfad direkt zu einem schaltbaren Abschwächer und dann zum Empfängereingang.

Empfängereingang:

Maximaler Eingangssignalpegel (Übersteuerungsgrenze):

–6 dBm; <0,4 dB Kompression (300 kHz bis 3 GHz)
–6 dBm; <0,8 dB Kompression (3 GHz bis 6 GHz)
–11 dBm; <0,8 dB Kompression (6 GHz bis 9 GHz)

Eigenrauschpegel (eff., 10 Hz Bandbreite):

<–133 dBm (300 kHz bis 3 GHz)
<–123 dBm (3 GHz bis 6 GHz)
<–123 dBm (6 GHz bis 9 GHz)

Absoluter Pegelgrenzwert: +26 dBm

Maximal zulässige DC-Eingangsspannung: 40 V (Standard), 0 V (Option 015)

Rückflussdämpfung:

>17 dB (300 kHz bis 3 GHz)
>12 dB (3 GHz bis 6 GHz)
>7 dB (6 GHz bis 9 GHz)

Referenzkanal-Brücke

  • Die obere Steckverbindung führt das Signal vom Richtungsumschalter-Ausgang "Reference 1".

  • Die untere Steckverbindung ist direkt mit dem Empfängereingang R1 verbunden.

Empfängereingang:

Maximaler Eingangssignalpegel (Übersteuerungsgrenze):

–6 dBm; <0,4 dB Kompression (300 kHz bis 3 GHz)
–6 dBm; <0,8 dB Kompression (3 GHz bis 6 GHz)
–11 dBm; <0,8 dB Kompression (6 GHz bis 9 GHz)

Absoluter Pegelgrenzwert: >+26 dBm

Für PLL-Synchronisation erforderlicher Mindest-Eingangssignalpegel:

–35 dBm (300 kHz bis 3 GHz)
–25 dBm (3 GHz bis 9 GHz)

Referenzausgang: (bei Verwendung eines externen Eingangssignals zur Synchronisation der Signalquelle)

Ausgangssignalpegel:

–5 bis –30 dBm (300 kHz bis 6 GHz)
–10 bis –35 dBm (6 GHz bis 9 GHz)

Rückflussdämpfung infolge Quellenanpassung:

16 dB (300 kHz bis 3 GHz)
14 dB (3 GHz bis 9 GHz)

Absoluter Pegelgrenzwert: >+26 dBm

Maximal zulässige DC-Eingangsspannung: 40 V

Messanschluss-Brücke (nur für Geräte mit Option 015)

  • Die obere Steckverbindung führt das Signal von der an Port 1 angeschlossenen Quelle.

  • Die untere Steckverbindung führt direkt zum Haupteingang des Port-1-Kopplers. An diesem Punkt kann ein Leistungsverstärker zur Verstärkung des Messignalpegels eingeschleift werden.

Quellenausgang:

Ausgangssignalpegel:

+12 bis –83 dBm (300 kHz bis 6 GHz)
+7 bis –88 dBm (6 GHz bis 9 GHz)

Quellenanpassung: 15 dB bei 9 GHz

Eingang zum Koppler:

Einfügedämpfung zu Port 1:

<3,5 dB bei 3 GHz
<5 dB bei 9 GHz

Maximale Eingangsleistung (Übersteuerungsgrenze): 2 Watt, CW

Absoluter Leistungsgrenzwert: 4 Watt, CW

Zurück zur Frontplatte


Mittelung

Taste "Average"

Mit dieser Taste können Sie die Messdatenmittelung aktivieren und dadurch das Rauschen verringern. Die Mittelung erfolgt auf der Basis der komplexen Messdaten über die von Ihnen spezifizierte Anzahl von Messungen nach einem exponentiell gewichtenden Verfahren.


Cal Pop

Taste "Calibration"

Durch Drücken dieser Taste können Sie eine Kalibrierung starten. Wenn Sie "Menu/Dialog", "Cal" drücken, erscheint der Kalibrierungsassistent, ansonsten die Aktuelle-Eingabe-Symbolleiste für Kalibrierung.


Cancel pop

Taste "Cancel"

Wenn Sie diese Taste drücken, wird das Dialogfenster geschlossen.


Channel Pop

Taste "Channel"

Mit dieser Taste können Sie einen Kanal zum aktiven Kanal machen oder einen Kanal entfernen. Es können immer nur die Einstellungen für den jeweils aktiven Kanal geändert werden.


Kanal-Setup

CHANNEL SETUP-Tasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Mit diesen Tasten können Sie

  • diverse Stimulus-Einstellung für einen gewählten Kanal konfigurieren;

  • eine Kalibrierung durchführen.

Zurück zur Frontplatte


COMMAND-Tasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Mit diesen Tasten können Sie

  • in einem Dialogfenster Befehle eingeben;

  • Menüs oder Dialogfenster aufrufen;

  • die Online-Hilfe aufrufen.

Zurück zur Frontplatte


Decimal Pop

Dezimalpunkt-Taste

Mit dieser Taste können Sie den Dezimalpunkt (zur Trennung von ganzzahligem Anteil und Dezimalbruch-Anteil einer Zahl) eingeben.


DISPLAY-Tasten

Siehe auch...

Mit diesen Tasten können Sie

  • Messkurven und Fenster erstellen und verwalten;
  • schnell und einfach eine Gruppe von Messungen konfigurieren;
  • die aktuellen Messungen auf dem Bildschirm anordnen.

Zurück zur Frontplatte


Enter Pop

Taste "Enter"

Wenn Sie diese Taste drücken, wird der Wert, den Sie für eine Einstellung gewählt haben, wirksam.


ENTRY-Tasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Diese Tasten dienen zur Eingabe von Werten für Messparameter.

Zurück zur Frontplatte


F keys pop

Funktionstasten F1, F2, F3, F4

Diese Tasten dienen zur Auswahl von Optionen aus der Aktuelle-Eingabe-Symbolleiste. Die Tasten haben die gleichen Farben wie die zugeordneten Optionen in der Aktuelle-Eingabe-Symbolleiste.


Format Pop

Taste "Format"

Mit dieser Taste können Sie das Format für die Darstellung der Messdaten wählen.


Help pop

Taste "Help"

Mit dieser Taste können Sie die Online-Hilfe (integrierte Dokumentation) aufrufen.


Limit Pop

Taste "Limit Table"

Mit dieser Taste können Sie die Grenzwerttabelle aufrufen. In dieser Tabelle können Sie Grenzwerte für automatische PASS/FAIL-Tests definieren.


Macro Pop

Taste "Macro / Local"

  • Wenn der Analysator sich im Fernsteuerungsbetrieb befindet, können Sie ihn durch Drücken dieser Taste wieder auf manuelle Bedienung zurückschalten.

  • Wenn der Analysator sich in der manuellen Betriebsart befindet, können Sie mit dieser Taste auf eine Reihe von benutzerdefinierten Macros zum Starten anderer Anwendungsprogramme zugreifen. Sie können bis zu zwölf Macros erstellen. In der Aktuelle-Eingabe-Symbolleiste können immer nur vier Macro-Titel gleichzeitig angezeigt werden. Wenn Sie diese Taste wiederholt drücken, wird die jeweils nächste Vierergruppe angezeigt.

Hinweis: Die ausführbaren Dateien, auf welche die Macros verweisen, müssen auf der Festplatte des Analysators installiert sein.


Math/Mem-Taste

Taste "Math / Memory"

Mit dieser Taste können Sie auf mathematische Funktionen und Speicherfunktionen zur Messdatenverarbeitung zugreifen.


Measure-Taste

Taste "Measure"

Mit dieser Taste können Sie die gewünschte S-Parameter-Messfunktion wählen. Alternativ können Sie über das Dialogfenster eine benutzerdefinierte Leistungsverhältnismessung oder Absolutleistungsmessung wählen.


Measure-Setups-Taste

Taste "Measure Setups"

Mit dieser Taste können Sie zwischen vier vordefinierten Setups wählen.


Menu/Dialog-Taste

Taste "Menu / Dialog"

Nach Drücken dieser Taste können Sie mit Hilfe der Navigationstasten durch die Menüs navigieren. Mit dieser Taste können Sie außerdem Dialogfenster aufrufen, indem Sie nach Drücken der Taste "Menu/Dialog" eine der Tasten in den Tastenfeldern "Channel", "Trace" oder "Utility" drücken.


Fenster minimieren/maximieren

Taste "Restore Up/Down"

Mit dieser Taste können Sie das gewählte Fenster auf volle Bildschirmgröße vergrößern oder wieder auf die vorige Größe verkleinern.


Marker-Taste

Taste "Marker"

Mit dieser Taste können Sie einen Marker aktivieren und dessen Zielwert vorgeben. Marker dienen zum Bestimmen numerischer Messwerte.


Marker-Function-Taste

Taste "Marker Function"

Mit dieser Taste können Sie bestimmten Analysatoreinstellungen den Wert des aktiven Markers zuordnen. Falls kein Marker vorhanden ist, wird bei Betätigung dieser Taste ein Marker aktiviert.


Marker-Search-Taste

Taste "Marker Search"

Mit dieser Taste können Sie auf die Marker-Suche-Funktionen zugreifen. Falls kein Marker vorhanden ist, wird bei Betätigung dieser Taste ein Marker aktiviert.


Marker-Table-Taste

Taste "Marker Table"

Im Tabellenbereich können drei verschiedene Tabellen angezeigt werden: 1) Die Marker-Tabelle mit den Werten aller auf der aktiven Messkurve befindlichen Marker. 2) Die Segmenttabelle mit den Definitionen der Wobbelsegmente. 3) Die Grenzwerttabelle mit den Werten der beiden Grenzwertlinien.


nav_pop

Navigationstasten

Pfeiltasten

Mit den Pfeiltasten können Sie den Cursor durch die Menüs und Dialogfenster hindurch bewegen.

Links / Rechts

  • Mit diesen Tasten können Sie sich innerhalb von Menüs nach links bzw. rechts bewegen.

  • Innerhalb von Dialogfenstern haben diese Tasten die Funktionen Tab-links bzw. Tab-rechts.

Oben / Unten

  • Mit diesen Tasten können Sie sich innerhalb von Menüs nach oben bzw. unten bewegen.

  • In Dialogfenstern haben diese Tasten folgende Funktionen:

    • Ändern eines numerischen Wertes

    • Navigieren durch die Elemente einer Drop-down-Liste

    • Navigieren durch die *****options buttons in einer Gruppe von option buttons

Click

Diese Taste hat die gleiche Auswahlfunktion wie die linke Maustaste.


Navigationstasten 2

Navigationstasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Mit diesen Tasten können Sie

  • Optionen aus der Aktuelle-Eingabe-Symbolleiste auswählen

  • durch Menüs und Dialogfenster hindurchnavigieren

Zurück zur Frontplatte


Zifferntastatur

Wählen Sie die gewünschten Messparameterwerte und schließen Sie die Eingabe durch Drücken der Taste Enter oder G/n oder M/u ab.


OK pop

Taste "OK"

Wenn Sie diese Taste drücken, werden die im Dialogfenster eingegebenen oder gewählten Werte wirksam, und das Dialogfenster wird geschlossen.


Ein-/Aus-Schalter

Mit diesem Schalter können Sie zwischen den Zuständen "On" (ein) und "Hibernate" (Ruhezustand) wählen.

  • Im "On"-Zustand leuchtet die Kontrollleuchte grün.

  • Im "Hibernate"-Zustand leuchtet die Kontrollleuchte organgegelb.

  • Wenn Sie den Analysator "ausschalten" (d. h. in den "Hibernate"-Zustand schalten), werden zuerst die aktuellen Zustände aller laufenden Programme abgespeichert; anschließend wird die Betriebsspannung abgeschaltet.

  • Wenn Sie den Ein-/Aus-Schalter nochmals drücken, wird der Analysator automatisch wieder in den gleichen Zustand gebracht, in dem er sich vor dem Ausschalten befand.

Mit diesem Schalter können Sie das Gerät NICHT vom Stromnetz trennen.

Zurück zur Frontplatte


PMB Pop

Taste "Plus - Minus - Rückschritt"

  • Wenn Sie diese Taste zu Beginn der Eingabe drücken, wechselt sie zwischen positivem und negativem Vorzeichen.

  • Ansonsten dient sie zum Löschen des jeweils zuletzt eingegebenen Zeichens.


Power Pop

Taste "Power"

Mit dieser Taste können Sie den Messsignalpegel spezifizieren.


Preset Pop

Taste "Preset"

Mit dieser Taste können Sie den Analysator in die Grundeinstellung bringen.


Print Pop

Taste "Print"

Mit dieser Taste können Sie auf Funktionen zur Wahl des Druckers und der zu druckenden Informationen zugreifen.


Tastkopfbetriebsspannung

"Probe Power"-Anschluss

Dieser 3-polige Anschluss (männlich) dient zur Stromversorgung eines aktiven Tastkopfs.

  • Oberer Pin: Masse

  • Linker Pin: +15 VDC ±2%, max. 400 mA; PTC-Überstromsicherung (0,5 A)

  • Rechter Pin: –12,6 VDC ±5%, max. 300 mA; PTC-Überstromsicherung (0,5 A)

(PTC = selbstrücksetzende träge Sicherung)

Zurück zur Frontplatte


Recall Pop

Taste "Recall"

Mit dieser Taste können Sie eine Datei, die einen Gerätezustand, einen Kalibrierdatensatz und Messdaten enthält, in den Analysator zurückladen.


Drehknopf

Mit dem Drehknopf können Sie den Wert des aktiven Parameters verkleinern oder vergrößern.


Save Pop

Taste "Save"

Mit dieser Taste können Sie Gerätezustände, Kalibrierdatensätze und Messdaten in eine Datei abspeichern.


Scale-Taste

Taste "Scale"

Mit dieser Taste können Sie die Skalierung der Y-Achse spezifizieren. Alternativ können Sie die "Autoscale"-Funktion wählen; der Analysator skaliert dann die Y-Achse automatisch so, dass die gesamte Messkurve zu sehen ist.


Bildschirm

Siehe auch...

  • Erkunden Sie die Grafik mit Hilfe der Maus.

Der Bildschirm des Analysators hat folgende Eigenschaften:

  • Aktiv-Matrix (TFT), 8,4 Zoll (21,3 cm), LCD

  • Auflösung: 640 x 480 Pixel

  • Bildwiederholfrequenz: 59,83 Hz

  • Horizontalfrequenz: 31,41 kHz

  • Helligkeit: >250 NIT

Zurück zur Frontplatte.


Stop/Span-Taste

Taste "Stop / Span"

Mit dieser Taste können Sie die Stop-Frequenz oder die Wobbelbandbreite spezifizieren.


Start/Center-Taste

Taste "Start / Center"

Mit dieser Taste können Sie die Start-Frequenz oder die Mittenfrequenz des Wobbelbereichs spezifizieren.


Sweep-Setup-Taste

Taste "Sweep Setup"

Mit dieser Taste können Sie definieren, wann und wie die analysatorinterne Stimulussignalquelle das Messsignal ausgibt.


Sweep-Type-Taste

Taste "Sweep Type"

Mit dieser Taste können Sie den Wobbelungstyp und andere Wobbeleinstellungen wählen.


Messanschlüsse

Siehe auch...

Die beiden 50-Ohm-Anschlüsse (Type-N, weiblich) Port 1 und Port 2 werden, je nach Messfunktion, automatisch als Signalquellenausgang oder Empfängereingang konfiguriert; dadurch sind bidirektionale Messungen möglich, ohne dass das Messobjekt umgepolt werden muss.

  • Wenn die LED grün leuchtet, ist der betreffende Anschluss als Signalquellenausgang konfiguriert.

  • Wenn die LED orangefarben leuchtet, ist der betreffende Anschluss als Empfänger konfiguriert.

Maximal zulässige Eingangssignalpegel:

CW-Pegel: +15 dBm
Gleichspannung: ±30V

Zurück zur Frontplatte


Trace pop

Taste "Trace"

Bei erstmaliger Betätigung dieser Taste erscheint die Aktuelle-Eingabe-Symbolleiste. Danach können Sie durch wiederholtes Drücken dieser Taste nacheinander die einzelnen Messkurven innerhalb eines Fensters aktivieren. Änderungen können Sie immer nur an der jeweils aktiven Funktion vornehmen. Nach Betätigung dieser Taste können Sie außerdem mit Hilfe der Funktionstasten Messungen erstellen oder entfernen.


Trace-Setup-Tasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Mit diesen Tasten können Sie

  • eine Messfunktion konfigurieren;

  • die Messergebnisse analysieren.

Zurück zur Frontplatte


Trigger Pop

Taste "Trigger"

Mit dieser Taste können Sie spezifizieren, wann eine Wobbelmessung gestartet wird.


Units Pop

Maßeinheitentasten

Diese Tasten dienen zur Wahl einer Maßeinheit. Drücken Sie zum Abschließen der Eingabe die Taste Enter.


USB-Schnittstelle

Über die USB- (Universal Serial Bus) Schnittstelle können Sie den Analysator mit Hilfe einer Tastatur oder eines Zeigegerätes bedienen. Diese Schnittstelle kann auch zum Anschluss von ECal-Modulen (für die elektronische Kalibrierung) verwendet werden.

Kontakt 1: Vcc; 4,75 bis 5,25 VDC, max. 500 mA
Kontakt 2: – Daten
Kontakt 3: +Daten
Kontakt 4: Masse

Zurück zur Frontplatte


UTILITY-Tasten

Siehe auch...

Erkunden Sie die Grafik, um die Funktionen der verschiedenen Tasten kennenzulernen:

Mit diesen Tasten können Sie

  • Messergebnisse ausdrucken;

  • folgende Daten abspeichern oder zurückladen:

    • Analysatoreinstellungen

    • Kalibrierdaten

    • Messdaten

  • Makros starten;

  • Die Fenstergröße verändern;

  • den Analysator in der "Preset"-Zustand bringen.

Zurück zur Frontplatte


Window pop

Taste "Window"

Bei erstmaliger Betätigung dieser Taste erscheint die "Window Active"-Symbolleiste, die es Ihnen ermöglicht, mit Hilfe der Funktionstasten Bildschirmfenster zu erstellen, auszuwählen und zu entfernen. Danach können Sie durch wiederholtes Drücken dieser Taste nacheinander die einzelnen Fenster aktivieren. Größenänderungen können Sie immer nur an dem jeweils aktiven Fenster vornehmen. Auch zum sequentiellen Aktivieren der Messkurven in einem Fenster muss das betreffende Fenster aktiv sein.


Benutzung der Online-Hilfe

Wie benutzt man die Online-Hilfe?

Siehe auch...

Die Online-Hilfe enthält die gesamte Dokumentation zum Analysator. Klicken Sie auf eine der Schaltflächen, um Informationen darüber zu erhalten, wie die Online-Hilfe benutzt wird und wie sie Ihre Fragen zum Analysator beantwortet.

Auffinden von Informationen in der Online-Hilfe

Ausdrucken des aktuellen Hilfethemas

Verschieben oder Ändern der Größe des Hilfefensters

Schließen des Hilfefensters


Bias-Eingang

DC-Bias-Eingänge

DC-Bias-Eingang für Port 1 und Port 2:

Dieser BNC-Steckverbinder (weiblich) ermöglicht es Ihnen, den Messanschluss mit einer externen DC-Bias-Spannung zu beaufschlagen.

  • Maximale Spannung: ±30 VDC (typ.)

  • Maximaler Strom: ±1 A, (±200 mA ohne Beeinträchtigung der HF-Spezifikationen)*

Bias-Eingang-Absicherung:

Flinke "Bipin"-Sicherung 1A, 125 V

*Bei DC-Bias-Strömen bis zu 200 mA hält das Gerät alle HF-Spezifikationen ein. Bei höheren DC-Bias-Strömen verschlechtern sich die korrigierte Niederfrequenz-Quellenanpassung und das Richtverhältnis; dieser Effekt tritt typischerweise bei Frequenzen unterhalb 100 MHz auf, vor allem im Bereich über 10 MHz. Oberhalb 100 MHz verschlechtern sich die korrigierte Quellenanpassung und das Richtverhältnis bei Bias-Strömen bis zu 1 A nur minimal.

Zurück zur Rückwand


Ext-AM-Eingang

EXT AM INPUT Anschluss

Dieser BNC-Steckverbinder (weiblich) ermöglicht es Ihnen, das Messsignal durch ein externes, niederfrequentes Signal zu amplitudenmodulieren. Diese externe Steuerspannung kann auch zur Steuerung des Messsignalpegels verwendet werden. Eine Eingangsspannung von 0 Volt lässt den Messignalpegel unverändert. Eine positive Spannung erhöht den Messignalpegel. Eine negative Spannung verringert den Messignalpegel.

  • Eingangsempfindlichkeit: 8 dB/Volt (typ.)

  • Bandbreite : 1 kHz (typ.)

  • Eingangsimpedanz: 1kW (typ.)

Zurück zur Rückwand


EXT-DETECTOR-Eingang

EXT DETECTOR INPUT Anschluss

Dieser BNC-Steckverbinder (weiblich) ermöglicht es Ihnen, den Signalpegel an den Messanschlüssen durch eine externe Gleichspannung, die von einem Diodendetektor (mit negativer Polarität) geliefert wird, zu steuern. Damit der Analysator dieses Steuersignal akzeptiert, müssen Sie das Kontrollkästchen External ALC im Dialogfenster Sweep Setup aktivieren.

  • Eingangsempfindlichkeit: Eine Steuerspannung von –500 mV ergibt am Detektoreingang einen Signalpegel von etwa –3 dBm

  • Bandbreite: 50 kHz (typ.)

  • Eingangsimpedanz: 1kW (typ.)

Zurück zur Rückwand


Extern-Trigger

"Auxiliary Input/Output"-Anschluss

Dieser Ein-/Ausgang ermöglicht es, den Analysator durch ein externes TTL-Signal zu triggern und dadurch eine Messung auszulösen. Damit der Analysator das externe Triggersignal erkennen kann, müssen Sie "Trigger source external" wählen und den Triggerpegel (positiv oder negativ) spezifizieren (siehe TTL-Pegel).

  • "Ready for trigger"-TTL-Ausgang (Pin 18)

  • Eingang (Pin 19) für externes Triggersignal mit TTL-Pegel, Triggerung wahlweise auf positiven oder negativen Pegel

Zurück zur Rückwand


Frequenzreferenz

10 MHz REF INPUT/OUTPUT Anschlüsse

10 MHz REF INPUT Anschluss

Dieser BNC-Steckverbinder (weiblich) dient zum Anschluss einer externen Frequenzreferenz. Das externe Referenzsignal muss folgenden Anforderungen genügen:

  • Frequenz: 10 MHz ± 1ppm (typ.)

  • Pegel: –15 bis +20 dBm (typ.)

  • Eingangsimpedanz: 200 W (typ.)

10 MHz REF OUTPUT Anschluss

An diesem BNC-Steckverbinder (weiblich) ist das interne Frequenzreferenzsignal verfügbar; dieses hat folgende Charakteristiken:

  • Frequenz: 10 MHz ±10ppm

  • Signalform: Sinus

  • Pegel: 10 dBm ±4 dB an 50 Ohm

  • Ausgangsimpedanz: 50 Ohm

  • Oberwellenabstand: < –40 dBc

Zurück zur Rückwand


GPIB

GPIB- (General Purpose Interface Bus) Schnittstelle

Dieser 24-polige D-24-Steckverbinder (weiblich) ist eine IEEE-488-konforme Schnittstelle.

Zurück zur Rückwand


LAN-Schnittstelle

LAN- (Local Area Network) Schnittstelle

Diese 10/100BaseT-Ethernet-Schnittstelle ist als standardmäßige 8-polige Steckverbindung ausgeführt und wählt automatisch zwischen den beiden möglichen Datenraten.

Zurück zur Rückwand


Parallelschnittstelle

Parallelschnittstelle (LPT1)

Dieser 36-polige Mini-D/1284-C Steckverbinder (weiblich) ist eine Parallelschnittstelle zum Anschluss eines Druckers oder sonstigen Peripheriegerätes mit Parallelschnittstelle.

Ein Adapter auf Centronics-Schnittstelle wird mitgeliefert.

Zurück zur Rückwand


Serielle Schnittstelle

Serielle Schnittstelle (COM1)

Dieser 9-polige D-Sub-Steckverbinder (männlich) ist eine RS-232-kompatible serielle Schnittstelle.

Zurück zur Rückwand


USB-Schnittstelle

USB- (Universal Serial Bus) Schnittstelle

Dies ist eine USB-Schnittstelle in der "Type A"-Konfiguration (4 Kontakte in einer Reihe; Kontakt 1 auf der linken Seite, weiblicher Steckverbinder):

  • Kontakt 1: Vcc: 4,75 bis 5,25 VDC, max. 500 mA

  • Kontakt 2: – Daten

  • Kontakt 3: +Daten

  • Kontakt 4: Masse

Kontakt 1 ist durch eine selbstrücksetzende 1-A-Sicherung abgesichert. An diesen Anschluss können Sie eine Tastatur, eine Maus oder ein sonstiges Zeigegerät mit USB-Schnittstelle anschließen.

Zurück zur Rückwand


VGA-Ausgang

VGA- (Video Graphics Adapter) Anschluss

Dieser 15-polige D-Sub-Anschluss (weiblich) ermöglicht den Anschluss eines externen VGA-Bildschirms mit den nachfolgend beschriebenen Eigenschaften. In der Standardeinstellung des Analysators liefert der eingebaute Bildschirm auch bei angeschlossenem externen Bildschirm weiterhin ein Bild.

Bildschirm | Auflösung
Flachbildschirm (TFT) | 1024x768, 800x600, 640x480
Flachbildschirm (DSTN) | 800x600, 640x480
Röhrenbildschirm | 1280x1024, 1024x768, 800x600, 640x480

Hinweis: Wenn der Analysator auf die Standard-Bildschirmauflösung (640 x 480) eingestellt ist, ist sowohl auf dem eingebauten Bildschirm als auch auf dem externen Bildschirm ein Bild zu sehen. Wenn Sie die Bildschirmauflösung in der Systemsteuerung auf einen anderen Wert einstellen, liefert nur der externe Bildschirm ein Bild. Folgendermaßen können Sie die Auflösung ändern: Klicken Sie im System-Menü auf Windows Taskbar, Settings, Control Panel. Klicken Sie anschließend auf das Display-Symbol und die Registerkarte Settings.

Zurück zur Rückwand


Übersprechen

Siehe auch...

Empfängerübersprechen

Überblick

Konzepte

Wie verringert man
das Übersprechen?

Übersprechen ist eine unerwünschte Energieübertragung zwischen verschiedenen Analysator-Signalpfaden. Bei Messungen an Bauteilen mit hoher Einfügedämpfung kann das Übersprechen signifikante Messfehler hervorrufen. Sie können jedoch die Auswirkungen des Übersprechens durch Wahl einer geeigneten Wobbelbetriebsart und durch Kalibrierung reduzieren.
Konzepte

Wie reduziert man das Empfängerübersprechen?

Beachten Sie die folgenden Aspekte des Übersprechens:

  • Übersprechen zwischen den Signalpfaden führt zu Fehlern bei Transmissionsmessungen.

  • Übersprechen kann sich bei folgenden Messungen auswirken:

    • Messungen an Bauteilen mit großer Dämpfung (beispielsweise offener Schalter)

    • Messungen über einen weiten Dynamikbereich (beispielsweise an einem Filter)

Sie können das Empfängerübersprechen folgendermaßen reduzieren:
Betriebsart "Sweep Alternate" wählen

Eine Kalibrierung durchführen.

Betriebsart "Alternate Sweep" wählen

Diese Wobbelbetriebsart reduziert das Empfänger ü bersprechen aus folgenden Gründen:

  • In der Betriebsart "Alternate Sweep" wird in jedem Wobbelzyklus immer nur jeweils ein Empfänger für die Messung benutzt.

  • Der jeweils andere Empfänger wird abgeschaltet.

Tipps:

  • Das Reflexionssignal (Empfänger A) und das Transmissionssignal (Empfänge r B) werden jeweils während unterschiedlicher Wobbelzyklen gemessen.Deshalb verdoppelt sich in der Betriebsart "Alternate Sweep" die Wobbelzeit, falls sowohl Reflexions- als auch Transmissionsmessungen durchgeführt werden.

  • Wenn Sie nur Transmissionsmessungen oder nur Reflexionsmessungen durchführen, können Sie durch Wahl der Wobbelbetriebsart "Alternate Sweep" die Auswirkungen des Übersprechens minimieren, ohne die Wobbelzyklusdauer zu beeinflussen.

  • Das Übersprechen wird erst nach einer beträchtlichen Verringerung des Eigenrauschens sichtbar. Hierzu können Sie entweder die Mittelungsfunktion aktivieren oder die ZF-Bandbreite reduzieren.

Eine Kalibrierung durchführen.

Bei Transmissionsmessungen trägt eine Frequenzgang- und Isolations kalibrierung aus folgenden Gründen zur Reduktion des Übersprechens bei:

  • Der Analysator misst während der Kalibrierung das Übersprechen und subtrahiert es bei den anschließenden Messungen.

  • Die Kalibrierung verbessert die Isolation so weit, dass sie vom Eigenrauschen dominiert wird.

Unter Systematische Fehler / Isolation finden Sie Informationen darüber, wie Sie das Übersprechen mittels Kalibrierung reduzieren können.

Tipp:

  • Im allgemeinen geht die Isolation im Eigenrauschen unter. Deshalb sollten Sie während einer Isolationskalibrierung ein Rauschreduktionsverfahren wie z. B. Messkurvenmittelung oder Reduktion der ZF-Bandbreite anwenden.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zur Reduktion des Empfänger-Ü berspechens.
Wahl der Betriebsart "Sweep Alternate"

Durchführung einer Frequenzgang- und Isolationskalibrierung

Wahl der Betriebsart "Sweep Alternate"
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Sweep-Menü auf Sweep Setup..

  2. Falls die Betriebsart "Alternate Sweep" noch nicht aktiv ist, aktivieren Sie das Kontrollkästchen Alternate Sweeps.

  3. Klicken Sie auf OK.

Hinweis: Die Betriebsart "Alternate Sweep" kann für jeden Kanal individuell aktiviert und konfiguriert werden. Falls mehrere Kanäle benutzt werden, müssen Sie diese Prozedur gegebenenfalls für jeden Kanal wiederholen.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  3. Falls die Betriebsart "Alternate Sweep" noch nicht aktiv ist, drücken Sie die Tab-rechts-Taste im Tastenfeld NAVIGATION, um zum Feld Alternate Sweeps zu gelangen, und drücken Sie anschließend Click.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Hinweis: Die Betriebsart "Alternate Sweep" kann für jeden Kanal individuell aktiviert und konfiguriert werden. Falls mehrere Kanäle benutzt werden, müssen Sie diese Prozedur gegebenenfalls für jeden Kanal wiederholen.

Durchführung einer Frequenzgang- und Isolationskalibrierung
Mausprozedur

Tastenprozedur

Mausprozedur

Hinweis: Diese Prozedur ist nur für Transmissionsmessungen erforderlich.

  1. Klicken Sie im Menü Calibration auf Calibration Wizard.

  2. Klicken Sie unter Select Calibration Type auf Cal Type.

  3. Klicken Sie auf THRU Resp and Isol, OK.

  4. Folgen Sie den Hinweisen zur Durchführung des übrigen Teils der Kalibrierung; wählen Sie die Kalibriernormaltypen und den Steckverbindertyp, und führen Sie anschließend die Messungen an den Kalibriernormalen durch. Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.

Tastenprozedur

Hinweis: Diese Prozedur ist nur für Transmissionsmessungen erforderlich.

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Cal und dann F1 (Cal Wizard).

  2. Drücken Sie im Tastenfeld NAVIGATION die Taste Click; navigieren Sie dann mit den Pfeil-oben/unten-Tasten zu THRU Resp and Isol, und drücken Sie dann Click.

  3. Drücken Sie im Tastenfeld COMMAND die Taste OK.

  4. Folgen Sie den Hinweisen zur Durchführung des übrigen Teils der Kalibrierung (verwenden Sie hierzu die Tasten im Tastenfeld NAVIGATION); wählen Sie die Kalibriernormaltypen und den Steckverbindertyp, und führen Sie anschließend die Messungen an den Kalibriernormalen durch. Weitere Informationen siehe Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung.


Siehe auch...

Anzahl der Messpunkte

Überblick

Konzepte

Wie vergrößert man
die Anzahl der Messpunkte?

Ein Messpunkt oder "Punkt" repräsentiert einen Messwert für einen bestimmten Stimuluswert. Sie können die Anzahl der Messpunkte pro Wobbelzyklus vorgeben.
Konzepte

Wie vergrößert man die Anzahl der Messpunkte?

  • Je größer die Anzahl der Messpunkte, desto höher ist die vertikale Auflösung der Messkurve.

  • Die meisten Datenverarbeitungsoperationen werden Punkt für Punkt ausgeführt. Eine Wobbelmessung setzt sich aus der spezifizierten Anzahl von Messpunkten zusammen, wobei der Stimuluswert über einen bestimmten Bereich verändert wird.

  • Der Standardwert für die Anzahl der Messpunkte beträgt 201 Punkte pro Wobbelung.

51 Punkte | 101 Punkte | 401 Punkte

Die Wobbelzeit ist proportional zur Anzahl der Messpunkte. Dies gilt jedoch nicht für die Gesamt-Messzyklusdauer. Weitere Informationen darüber, wie die Anzahl der Messpunkte und andere Einstellungen die Wobbelzeit beeinflussen, siehe Erläuterungen zu den Spezifikationen.

Tipps:

  • Die größtmögliche Messkurvenauflösung erzielen Sie mit der größten Anzahl von Messpunkten.

  • Wenn die Messgeschwindigkeit im Vordergrund steht, sollten Sie die kleinste Anzahl der Messpunkte wählen, die eine akzeptable Auflösung ergibt.

  • Sie können die optimale Anzahl von Messpunkten herausfinden, indem Sie von einem kleinen Wert ausgehen und diesen so weit vergrößern, bis eine weitere Vergrößerung keine nennenswerte Verbesserung mehr bringt.

  • Um eine genaue Kalibrierung sicherzustellen, sollten Sie die Kalibrierung mit der gleichen Anzahl von Messpunkten durchführen, mit der Sie die späteren Messungen am Messobjekt durchführen.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen der Prozeduren zum Vergrößern der Anzahl der Messpunkte und Verbessern der Messgenauigkeit.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Number of Points.

  2. Wählen Sie einen der aufgelisteten Werte oder geben Sie in das Feld Custom einen beliebigen Wert ein.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  2. Drücken Sie im Tastenfeld NAVIGATION die Taste F2 (Points). Wählen Sie anschließend mit den Pfeil-oben/unten-Tasten den gewünschten Wert, und drücken Sie dann Click.

  3. Oder geben Sie über die Tasten im Tastenfeld ENTRY einen beliebigen Wert ein, und drücken Sie Enter.


Messgeschwindigkeit

Steigerung der Messgeschwindigkeit

Siehe auch...

Klicken Sie auf eine Schaltfläche, um zu erfahren, wie Sie die Messgeschwindigkeit steigern können.

Maximierung der Wobbelgeschwindigkeit

Schnelles Umschalten zwischen mehreren Messzuständen

Maximierung der Datenübertragungsrate


Optimieren

Optimieren der Messgenauigkeit und Messgeschwindigkeit

Siehe auch...

Sie können zahlreiche, voneinander unabhängige Messparameter wählen. Durch Wahl geeigneter Messparameter können Sie die Messgeschwindigkeit oder die Messgenauigkeit optimieren. Durch sorgfältiges Einrichten der Messung können Sie einen optimalen Kompromiss zwischen Geschwindigkeit und Genauigkeit erzielen.
Steigerung der Messgeschwindigkeit

Maximierung der Wobbelgeschwindigkeit

Umschalten zwischen mehreren Messzuständen

Maximierung der Datenübertragungsrate

Verbessern der Messgenauigkeit

Vergrößern des Dynamikbereichs

Vergrößern der Anzahl der Datenpunkte

Verbessern der Phasengenauigkeit

Verbessern der Messgenauigkeit für Bauteile mit großer elektrischer Länge

Verbessern der Reflexionsmessgenauigkeit für Zwei-Tor-Bauteile mit geringer Einfügedämpfung

Verbessern der Stabilität der Messergebnisse

Verringern des Messkurvenrauschens

Verringern des Empfängerübersprechens

Verringern von Messfehlern durch Messzubehör


Stabilität

Siehe auch...

Stabilität der Messergebnisse

Überblick

Konzepte

Wie verbessert man die
Stabilität der Messergebnisse?

In bestimmten Situationen erhalten Sie u. U. instabile Messergebnisse. Sie können verschiedene Maßnahmen ergreifen, um eine stabile Messumgebung zu schaffen und dadurch reproduzierbare Messergebnisse zu gewährleisten.
Konzepte

Wie verbessert man die Stabilität der Messergebnisse?

Die nachfolgenden Effekte können die Messgenauigkeit negativ beeinflussen. Klicken Sie auf eine der Schaltflächen, um sich über das jeweilige Thema genauer zu informieren.
Frequenzdrift

Temperaturdrift

Ungenaue Kalibrierung

Kabel und Steckverbinder

Frequenzdrift

Die Frequenzgenauigkeit des Analysators beruht auf einem internen 10 MHz-Referenzoszillator. Die Stabilitäts- und Drift-Spezifikationen dieses Oszillators finden Sie unter Erläuterungen zu den Spezifikationen.

Wenn Ihre Anwendung eine erhöhte Frequenzgenauigkeit und -stabilität erfordert, können Sie die interne Frequenzreferenz umgehen und an den "10 MHz Reference-Input"-Anschluss auf der Rückwand des Gerätes eine externe, hochstabile Frequenzreferenz anschließen.

Temperaturdrift

Die elektrischen Charakteristiken folgender Komponenten können sich durch Wärmeausdehnung in Abhängigkeit von der Temperatur ändern:

  • Bauteile innerhalb des Analysators

  • K alibrierung skit-Normale

  • Messobjekte

  • Kabel

  • Adapter

Sie können die Auswirkungen der Temperaturdrift auf die Messergebnisse durch folgende Maßnahmen reduzieren:

  • Führen Sie Ihre Messungen in einer Umgebung mit konstanter Temperatur durch.

  • Stellen Sie sicher, dass die Kalibriernormale während der Kalibrierung stets die gleiche Temperatur aufweisen.

  • Vermeiden Sie während der Kalibrierung jede unnötige Handhabung der Kalibriernormale.

  • Stellen Sie sicher, dass die Umgebungstemperatur bei den Messungen um nicht mehr als ±1°C von der Temperatur zum Zeitpunkt der Kalibrierung abweicht.

Ungenaue Kalibrierung

Falls eine Kalibrierung ungenau ist, messen Sie nicht die tatsächlichen Charakteristiken des Messobjekts. Um eine genaue Kalibrierung sicherzustellen, sollten Sie folgende Richtlinien beachten:

  • Führen Sie die Kalibrierung an den Punkten durch, an denen Sie später das Messobjekt anschließen, also an der Messebene .

  • Falls Sie nach einer Kalibrierung zusätzliche Komponenten (Kabel, Adapter, Abschwächer usw.) in die Messanordnung einbringen, kompensieren Sie deren elektrische Länge und die daraus resultierende Signallaufzeit mit Hilfe der "Port extension s"-Funktion.

  • Verwenden Sie ausschließlich Kalibriernormale, die den während der Kalibrierung verwendeten Kalibriernormal-Definitionen entsprechen.

Ausführliche Informationen hierzu siehe Genaue Kalibrierung.

Kabel und Steckverbinder

Korrekte Verbindungen zwischen den einzelnen Komponenten der Messanordnung sind eine notwendige Voraussetzung für reproduzierbare Messungen. Um korrekte Verbindungen sicherzustellen, sollten Sie folgende Richtlinien beachten:

  • Überprüfen und reinigen Sie alle in der Messanordnung verwendeten Steckverbinder.

  • Verwenden Sie geeignete Anschlusstechniken.

  • Vermeiden Sie es, die Kabel während einer Messung zu bewegen.

Durch Anklicken der Schaltflächen gelangen Sie zu Beschreibungen von Prozeduren zur Verbesserung der Messergebnis-Stabilität.
Externe Frequenzreferenz

Konstante Umgebungstemperatur

Konstante Temperatur der Kalibriernormale

Siehe Prozeduren für Genaue Kalibrierung

Korrekte Verbindungen

Externe Frequenzreferenz

  1. Schließen Sie die externe Frequenzreferenz gemäß der Abbildung an den Analysator an.

  • Frequenz: 10 MHz ± 10 ppm

  • Pegel: –15 bis +20 dBm

  • Eingangsimpedanz: 200 Ohm

Konstante Umgebungstemperatur

  1. Schalten Sie den Analysator mindestens eine halbe Stunde vor Beginn einer Kalibrierung oder Bauteilmessung ein.

  2. Führen Sie Ihre Messungen bei konstanter Raumtemperatur durch. Alle Spezifikationen und Charakteristiken gelten über einen Temperaturbereich von 25°C ±5°C (sofern nicht ausdrücklich anders vermerkt).

  3. Stellen Sie sicher, dass die Umgebungstemperatur bei den Messungen um nicht mehr als ±1°C von der Temperatur zum Zeitpunkt der Kalibrierung abweicht.

Konstante Temperatur der Kalibriernormale

  1. Öffnen Sie eine Stunde vor Beginn der Kalibrierung den Kalibrier-Kit-Behälter und nehmen Sie die Kalibriernormale aus der Schaumstoffverpackung.

  2. Vermeiden Sie während der Kalibrierung jede unnötige Handhabung der Kalibriernormale.

Korrekte Verbindungen

  1. Überprüfen Sie alle Steckverbinder unter einer Lupe. Achten Sie auf folgende Schäden:

    • Abgenutzte Oberflächenbeschichtung

    • Verbogene, abgebrochene oder dezentrierte Mittelleiter

    • Tiefe Kratzer, Beulen, gerundete Kanten

    • Staub oder Metallpartikel

  2. Reinigen Sie alle Steckverbinder mit Hilfe von fusselfreier Watte und Isopropylalkohol.

    1. Lassen Sie den Alkohol verdunsten.

    2. Trocknen Sie den Steckverbinder vorsichtig mit Druckluft.

  3. Schließen Sie die Bauteile ordnungsgemäß an.

    1. Erden Sie sich selbst und alle Geräte über eine Anstistatik-Matte und ein Erdungsarmband.

    2. Richten Sie die Steckverbinder sorgfältig aneinander aus und stecken Sie sie gerade aufeinander.

    3. Drehen Sie nur an der Steckverbinder-Befestigungsmutter.

    4. Verwenden Sie zum endgültigen Festziehen der Mutter einen Drehmomentschlüssel.


Zeitbereichmessungen

Siehe auch...

Falls Ihr Analysator mit der Zeitbereich-Option 010 ausgestattet ist, können Sie damit das Zeitbereichverhalten eines Bauteils analysieren. Klicken Sie die Schaltflächen an, um weitere Informationen zu erhalten.
Überblick über Zeitbereichmessungen

Zeitbereichbetriebsarten "Bandpass" und "Lowpass"

Auflösung und Bereich bei Zeitbereichmessungen

Fensterfilter

Zeittorfilter

Zeitbereichmessdaten


3_Tab

3-Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4_Tab

4-Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6_Tab

6-Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


Aux Out1

Type topic text here.


 Active Entry Toolbar Measurement Toolbar Sweep Control Toolbar Stimulus Toolbar Marker Toolbar Trace Status Bar Tables

Siehe auch...

Anpassen der Bildschirmanzeigen

Überblick

Symbolleisten
und Tabellen

Messung-
Status

Wie ändert man
die Anzeigeeinstellungen?

Sie können Ihren Analysator so konfigurieren, dass bestimmte Anzeigeelemente (Symbolleisten, Tabellen, Anzeigefelder) entweder angezeigt oder verborgen werden.
Symbolleisten und Tabellen

Messung-Status

Wie ändert man die Anzeigeeinstellungen?

Erkunden Sie die Grafik mit Hilfe der Maus, um die verschiedenen Bereiche des Bildschirms kennen zu lernen:
Statuszeile

Symbolleisten

Aktuelle Eingabe

Marker

Messung

Wobbelsteuerung

Stimulus

Alle aus

Tabellen

Marker-Tabelle

Grenzwerttabelle

Segmenttabelle

Statuszeile

Die Statuszeile wird am unteren Bildschirmrand angezeigt.

Sie enthält folgende Informationen:

  8. A ktiver Kanal

  9. Messparameter für die aktive Messkurve

  10. F ehlerkorrektur-Status für die aktive Messkurve

  11. M ittelungsstatus des aktiven Kanals ("On" oder "Off")

  12. GPIB-Status ("local" oder "remote")

Symbolleisten

Es können bis zu sechs verschiedene Symbolleisten angezeigt werden. Durch Anklicken der entsprechenden Symbole können Sie schnell und einfach Messungen einrichten oder ändern.

Aktuelle-Eingabe-Symbolleiste

Die Aktuelle-Eingabe-Symbolleiste wird am oberen Bildschirmrand (unterhalb der Menüleiste) angezeigt. Sie ermöglicht es Ihnen, Optionen für die aktive Funktion zu wählen.

Sie enthält folgende Symbole:

  • Softkey-Optionen für die aktive Funktion

Marker-Symbolleiste

Die Marker-Symbolleiste wird unmittelbar oberhalb des obersten Bildschirmfensters angezeigt. Sie ermöglicht es Ihnen, Marker einzurichten oder zu ändern.

Sie enthält folgende Anzeigen und Symbole:

  • Marker-Nummer

  • Stimuluswert

  • Marker-Funktionen

    • "Delta"

    • "Start/Stop"

    • "Center/Span"

Messung-Symbolleiste

Die Messung-Symbolleiste wird oberhalb des obersten Bildschirmfensters angezeigt. Sie ermöglicht folgendes:

  • Erstellen einer neuen Messkurve für eine S-Parameter-Messung in einem

    • aktuellen Fenster

    • neuen Fenster

Symbolleiste für Wobbelsteuerung

Die Symbolleiste für die Wobbelsteuerung wird oberhalb des obersten Bildschirmfensters angezeigt. Die in dieser Symbolleiste enthaltenen Symbole ermöglichen es Ihnen, folgende Betriebsarten zu wählen (die Betriebsarten sind in der Reihenfolge der Symbole aufgelistet):

  • Hold

  • Single, anschließend "Hold"

  • Continuous

Weitere Informationen siehe unter Trigger.

Stimulus-Symbolleiste

Die Stimulus-Symbolleiste wird oberhalb des obersten Bildschirmfensters angezeigt. Sie ermöglicht es Ihnen, die Stimulusparameter für die Wobbelung zu überprüfen, einzurichten oder zu modifizieren.

Sie zeigt folgende Informationen:

  • Start-Wert

  • Stop-Wert

  • Anzahl der Punkte

Alle aus

Durch Anklicken dieses Symbols können Sie alle Symbolleisten verbergen.

Tabellen

Es können Tabellen für Marker, Grenzwerte oder Segmente angezeigt werden. In allen Tabellen außer Marker-Tabellen können Sie Einträge vornehmen oder vorhandene Einträge modifizieren.

  • Tabellen werden im unteren Bereich des gewählten Fensters angezeigt.

  • In jedem Fenster kann immer nur jeweils eine Tabelle angezeigt werden.

Marker-Tabelle

Folgende Marker-Einstellungen können in Form einer Tabelle angezeigt werden:

  • Marker-Nummer

  • Marker-Referenz (für Delta-Messungen)

  • Frequenz

  • Response

Grenzwerttabelle

Folgende Grenzwerttest-Einstellungen können als Tabelle angezeigt und in der Tabelle editiert werden:

  • Typ (MIN, MAX oder OFF)

  • Start- und Stop-Stimuluswerte

  • Start- und Stop-Responsewerte

Segmenttabelle

Folgende Wobbel-Einstellungen können als Tabelle angezeigt und in der Tabelle editiert werden:

  • Zustand (ein/aus)

  • Start- und Stop-Frequenzen

  • Anzahl der Messpunkte

  • ZF-B andbreite (falls unabhängig einstellbar)

  • Signalpegel (falls unabhängig einstellbar)

  • Wobbelzeit (falls unabhängig einstellbar)

Messung-Status

Messkurvenstatus

Frequenz-Stimulus

Marker-Anzeige

Grenzwerttestergebnisse

Grenzwertlinien

Titel

Aktuelle Messkurve

Gespeicherte Messkurve

Titelleisten

Messung-Status

Folgende, die Messung betreffenden Anzeigen können angezeigt oder verborgen werden:

  • Messkurvenstatus

  • Frequenz-/Stimulus-Werte

  • Marker-Anzeige

  • Grenzwerttestergebnisse

  • Grenzwertlinien

  • Titel

Messkurvenstatus

Der Messkurvenstatus wird am linken Rand des jeweiligen Bildschirmfensters angezeigt.

Es werden folgende Informationen angezeigt:

  • Messparameter

  • Format

  • Skalierung

  • Referenzpegel

Frequenz/Stimulus

Frequenz-/Stimulus-Informationen werden am unteren Rand des jeweiligen Bildschirmfensters angezeigt. Sie können diese Anzeige aus Sicherheitsgründen verbergen. Es werden folgende Informationen angezeigt:

  • Kanalnummer

  • Start-Wert

  • Stop-Wert

Marker-Anzeige

Die Marker-Werte werden in der oberen rechten Ecke des jeweiligen Bildschirmfensters angezeigt. Es werden folgende Informationen angezeigt:

  • Marker-Nummer

  • Stimulus-Wert

  • Response-Wert im jeweils gewählten Marker-Anzeigeformat

Grenzwerttestergebnisse

Die Grenzwerttestergebnisse werden am rechten Rand des betreffenden Bildschirmfensters angezeigt. Es werden folgende Informationen angezeigt:

  • "Pass" oder "Fail"

Grenzwertlinien

Grenzwertlinien werden für die aktive Messkurve in dem betreffenden Fenster angezeigt. Ihre Position ist von folgenden Parametern abhängig:

  • Grenzwerte

  • Format

  • Skalierung

  • Referenzpegel

Titel

Sie können einen Titel für ein Bildschirmfenster eingeben, der dann in der Titelleiste angezeigt wird. Die Abbildung zeigt das Dialogfenster zur Eingabe eines Titels.

Der Titel wird in der linken oberen Ecke des betreffenden Fensters angezeigt.

Aktuelle Messkurve

Sie können eine ausgewählte aktuelle Messkurve verbergen.

Gespeicherte Messkurve

Sie können eine ausgewählte gespeicherte Messkurve verbergen.

Titelleisten

Die Titelleiste wird ganz oben in jedem Bildschirmfenster angezeigt. Sie enthält folgende Informationen:

  • Fensternummer

Wenn Sie "Titelleisten verbergen" wählen, werden die Titelleisten sämtlicher Bildschirmfenster verborgen, sodass für die Darstellung der Messergebnisse die maximale Bildschirmfläche zur Verfügung steht.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im View-Menü auf die gewünschte Bildschirmanzeige.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Wählen Sie durch Drücken der Tab-rechts-Taste View.

  3. Wählen Sie mit der Pfeil-unten-Taste die gewünschte Bildschirmanzeige.

  4. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Siehe auch...

Darstellungsformat und Skalierung

Überblick

Konzepte

Wie wählt man das Darstellungsformat und die Skalierung?

Das "Darstellungsformat" ist die Art und Weise, wie der Analysator die Messdaten grafisch darstellt. Die "Scale"-Funktion ermöglicht es Ihnen, den optimalen Maßstab für die Darstellung der Messergebnisse zu wählen.
Konzepte

Wie wählt man das Darstellungsformat und die Skalierung?

Sie sollten ein möglichst aussagekräftiges Darstellungsformat wählen, d. h. ein Darstellungsformat, das die interessierenden Eigenschaften des Messobjekts deutlich erkennen lässt. Die nachfolgenden Erläuterungen helfen Ihnen, die neun zur Auswahl stehenden Darstellungsformate zu verstehen und dadurch möglichst viele Informationen aus Ihren Messdaten "herauszuholen". Außerdem lernen Sie, wie Sie die Skalierung so wählen können, dass diese Informationen auf optimale Weise angezeigt werden.
Rechtwinklige (kartesische) Darstellungsformate

"Log Mag"-Format

"Phase"-Format

"Group Delay"-Format

"Linear Mag"-Format

"SWR"-Format

"Real"-Format

"Imaginary"-Format

"Polar"-Format

"Smith Chart"-Format

Skalierung

"Auto Scale"

"Auto Scale All"

"Reference Level"

"Reference Position"

Rechtwinklige Darstellungsformate

Sieben der insgesamt neun zur Auswahl stehenden Darstellungsformate verwenden ein rechtwinkliges Koordinatensystem. Diese Darstellungsformate werden auch als kartesische, X/Y oder rechtwinklige Darstellungsformate bezeichnet. Beim rechtwinkligen Koordinatensystem

  • wird die Stimulusgröße (Frequenz, Leistung oder Zeit) im linearen Maßstab entlang der X-Achse dargestellt.

  • ist der Frequenzgang des Messobjekts deutlich erkennbar.

Die sieben Darstellungsformate unterscheiden sich hinsichtlich der Datendarstellung entlang der Y-Achse.

"Log Mag"-Format (Betrag im logarithmischen Maßstab)

  • Es wird nur der Amplitudenbetrag (und nicht die Phase) dargestellt.

  • Y-Achse: dB

  • Typische Messungen:

    • Rückflussdämpfung

    • Einfügedämpfung oder Verstärkung

"Phase"-Format

  • Es wird nur die Phase (und nicht der Amplitudenbetrag) dargestellt.

  • Y-Achse: Phase (Grad)

  • Typische Messungen:

  • Phasenlinearitätsfehler

"Group Delay"-Format

  • Es wird die Signallaufzeit des Messobjekts über der Frequenz dargestellt.

  • Y-Achse: Zeit (Sekunden)

  • Typische Messungen:

    • Gruppenlaufzeit

"Linear Magnitude"-Format

  • Es werden nur positive Werte angezeigt.

  • Y-Achse: dimensionslos

  • Typische Messungen:

    • Reflexions- und Transmissionskoeffizienten (Betrag)

    • Zeitbereichtransformation

"SWR"-Format

  • Es werden Reflexionsmessdaten dargestellt, die nach der Formel (1+r)/ (1r) berechnet werden, wobei p der Reflexionskoeffizienten ist.

  • Nur für Reflexionsmessungen gültig.

  • Y-Achse: dimensionslos

  • Typische Messungen:

    • SWR

"Real"-Format

  • Es wird nur der Realteil (resistive Komponente) der komplexen Messdaten dargestellt.

  • Die Werte können sowohl positiv als auch negativ sein.

  • Y-Achse: dimensionslos

  • Typische Messungen:

    • Zeitbereich

    • Hilfs-Eingangssignal für Service-Zwecke

"Imaginary"-Format

  • Es wird nur der Imaginärteil (reaktive Komponente) der komplexen Messdaten dargestellt.

  • Y-Achse: dimensionslos

  • Typische Messungen:

    • Impedanzmessung im Rahmen der Entwicklung von Anpassungsnetzwerken

"Polar"-Format

Das Polarformat enthält sowohl Amplituden- als auch Phaseninformationen. Die verschiedenen Größen lassen sich folgendermaßen aus der vektoriellen Darstellung ablesen:

  • Der Betrag an einem bestimmten Punkt entspricht dem Abstand des betreffenden Punktes vom Mittelpunkt (Nullpunkt). Der Betrag ist linear skaliert, wobei dem äußeren Kreis der Verhältniswert 1 zugeordnet ist.

  • Die Phase entspricht dem Winkel relativ zur positiven X-Achse.

  • Eine Frequenzachse gibt es in diesem Fall nicht; die jeweilige Frequenz lässt sich mit Hilfe der Marker bestimmen.

Betrag und Phase sind linear skaliert. Der logarithmische Betrag und die Real-/Imaginärteile können im "Polar marker"-Menü abgefragt werden.

"Smith Chart"-Format

Die Impedanz des Messobjekts lässt sich aus den Ergebnissen von Reflexionsmessungen anhand des Smith-Diagramm bestimmen. Das Smith-Diagramm ist eine auf die polare Ebene abgebildete Impedanzebene.

Interpretation des Smith-Diagramms

Jeder Punkt im Smith-Diagramm repräsentiert eine komplexe Impedanz, bestehend aus einem (resistiven) Realteil (r) und einem (reaktiven) Imaginärteil (r+-jX).

Die punktiert dargestellten Kreise sind Ortskurven konstanten Widerstandes. Die horizontale Linie durch den Mittelpunkt repräsentiert eine rein resistive Impedanz (ohne reaktive Komponente).

  • Der rechte Endpunkt repräsentiert den Widerstandwert unendlich (Leerlauf).

  • Der linke Endpunkt repräsentiert den Widerstandwert Null (Kurzzschluss).

Die punktiert dargestellten Bögen sind Ortskurven konstanten Blindwiderstandes.

  • Die Blindwiderstand- (Reaktanz) Bögen in der oberen (positiven) Hälfte des Kreises repräsentieren induktive Blindwiderstände.

  • Die Blindwiderstand-Bögen in der unteren (negativen) Hälfte des Kreises repräsentieren kapazitive Blindwiderstände.

Die vom Analysator angezeigten Werte sind auf die Systemimpedanz bezogen. Der Mittelpunkt des Diagramms repräsentiert die Systemimpedanz.

"Scale"

Mit dieser Funktion können Sie die vertikale Skalierung des Koordinatensystems vorgeben. In den Formaten "Polar" und "Smith Chart" , wird hiermit der dem äußersten Kreis zugeordnete Wert vorgegeben.

Bereich: 0.001dB/div bis 500 dB/div

"Autoscale"

Die "Autoscale"-Funktion skaliert die Messkurve automatisch so, dass sie in das Gitterraster passt. Die automatische Skalierung betrifft nur die Mess- und Referenzwerte (Y-Achse), nicht jedoch die Stimuluswerte.

  • Der Analysator wählt eine Skalierung, bei der alle sichtbaren Messkurvenpunkte in einem Bereich von 80% der vertikalen Skala liegen.

  • Der Referenzwert wird so gewählt, dass die Messkurve vertikal zentriert dargestellt wird.

"Autoscale All"

Diese Funktion unterscheidet sich von der Autoscale-Funktion nur dadurch, dass alle in dem gewählten Fenster dargestellten Messkurven so skaliert werden, dass sie in das Gitterraster passen.

"Reference Level"

Der "Reference Level"-Wert (Referenzpegel) spezifiziert bei den kartesischen Formaten den Wert der Referenzlinie bzw. bei den polaren Formaten den Wert des äußersten Kreises.

Bereich: –500 dB bis 500 dB.

"Reference Position"

Der "Reference Position"- (Referenzposition) Wert spezifiziert die Position der Referenzlinie im Gitterraster eines kartesischen Formats; Null entspricht der untersten Gitterrasterlinie und 10 der obersten Gitterrasterlinie. Die Standard-Referenzposition ist 5.

Durch Anklicken der Schaltfläche gelangen Sie zu Beschreibung von Prozeduren für die Datenformatierung und -skalierung.
Wahl des Darstellungsformats

Manuelle Wahl der Skalierung

Automatische Wahl der Skalierung

Positionieren der Referenzlinie

Wahl des Darstellungsformats
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Trace auf Format.

  2. Klicken Sie auf das gewählte Darstellungsformat.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Format.

  2. Um das Format "Log Mag" zu wählen, drücken Sie F1 (LogMag).

  3. Um das Format "Smith Chart" zu wählen, drücken Sie F2 (Smith).

  4. Um das Format "Phase" zu wählen, drücken Sie F3 (Phase).

  5. Um das Format "Group Delay" zu wählen, drücken Sie F4 (Delay).

  6. Wenn Sie eines der fünf übrigen Formate wählen möchten, fahren Sie mit Schritt 7 dieser Prozedur fort.

  7. Drücken Sie die Taste Menu/Dialog im Tastenfeld COMMAND.

  8. Drücken Sie im Tastenfeld TRACE SETUP die Taste Format.

  9. Wählen Sie mit der Tab-rechts-Taste im Tastenfeld NAVIGATION das gewünschte Darstellungsformat. Drücken Sie die Taste OK im Tastenfeld COMMAND.

Manuelle Wahl der Skalierung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Scale auf Scale. Es erscheint das Dialogfenster Scale.

  2. Klicken Sie im Bereich Scale des Dialogfensters auf das Feld Per Division. Geben Sie den gewünschten Skalierungsfaktor ein oder wählen Sie diesen Wert durch Anklicken der Pfeiltasten.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Scale.

  2. Drücken Sie F2 (Scale) und geben Sie den gewünschten Skalierungsfaktor ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten im Tastenfeld NAVIGATION.

Automatische Wahl der Skalierung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Scale auf Autoscale oder Autoscale All.

Sie können die Skalierung auf nach der folgenden alternativen Methode wählen:

  1. Klicken Sie im Menü Scale auf Scale.

  2. Klicken Sie im Bereich Scale des Dialogfensters auf die Schaltfläche AutoScale, um die automatische Skalierung für die gewählte Messkurve zu aktivieren. Oder klicken Sie auf die Schaltfläche AutoAll, um die automatische Skalierung für alle im aktiven Fenster dargestellten Messkurven zu aktivieren.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Scale.

  2. Drücken Sie F1 (AutoScale), um die gewählte Messkurve automatisch zu skalieren. Wenn Sie alle Messkurven automatisch skalieren möchten, fahren Sie mit Schritt 3 dieser Prozedur fort.

  3. Drücken Sie die Taste Menu/Dialog im Tastenfeld COMMAND.

  4. Drücken Sie im Tastenfeld TRACE SETUP die Taste Scale.

  5. Wählen Sie mit der Tab-rechts-Taste im Tastenfeld NAVIGATION die Schaltfläche AutoAll. Drücken Sie die Taste OK im Tastenfeld COMMAND.

Positionieren der Referenzlinie
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Scale auf Scale.

  2. Klicken Sie im Bereich Reference des Dialogfensters auf das Feld Level. Geben Sie den gewünschten Positionswert ein oder wählen Sie diesen Wert durch Anklicken der Pfeiltasten.

  3. Klicken Sie im Bereich Reference des Dialogfensters auf das Feld Position. Geben Sie den gewünschten Positionswert ein oder wählen Sie diesen Wert durch Anklicken der Pfeiltasten.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Scale.

  2. Drücken Sie F3 (Ref Level) und geben Sie den gewünschten Referenzpegel ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten im Tastenfeld NAVIGATION.

  3. Drücken Sie F3 (Ref Pos) und geben Sie die gewünschte Referenzposition ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten im Tastenfeld NAVIGATION.


Siehe auch...

Frequenzbereich

Überblick

Konzepte

Wie stellt man den
Frequenzbereich ein? Bereich

Der Frequenzbereich ist der Bereich, über den die Frequenz während der Messung gewobbelt wird.
Konzepte

Wie stellt man den Frequenzbereich ein?

Frequenzbereich

Frequenzauflösung

CW-Frequenzen

Frequenzbereiche der verschiedenen Modelle der Produktfamilie PNA:

E8356A

300 kHz bis 3 GHz

E8357A

300 kHz bis 6 GHz

E8358A

300 kHz bis 9 GHz

Frequenzauflösung

Die Frequenzauflösung (d. h. die kleinstmögliche Schrittweite beim Einstellen der Frequenz) beträgt 1 Hz.

CW-Frequenzen

Messungen in der Betriebsart CW Time Sweep (CW-Zeitwobbelung) oder Power Sweep (Pegelwobbelung) erfolgen bei einer festen Frequenz und nicht über einen Frequenzbereich.

Hinweis: Der Analysator bietet die Möglichkeit, Frequenzwerte und bestimmte andere Werte aus Sicherheitsgründen zu verbergen.

Sie können den Frequenzbereich auf zweierlei Weise einstellen:

  • durch Spezifizieren der Start- und Stop-Frequenzen des Frequenzbereichs;

  • durch Spezifizieren der Mittenfrequenz des Frequenzbereichs und der Wobbelbandbreite.
Mausprozedur

Tastenprozedur

Mausprozedur

So stellen Sie den Frequenzbereich durch Spezifizieren der Start- und Stop-Frequenzen ein:

  1. Klicken Sie im Menü Channel auf Start/Stop....

  2. Klicken Sie auf das Feld Start. Geben Sie die gewünschte Start-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Klicken Sie auf das Feld Stop. Geben Sie die gewünschte Stop-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf OK.

So stellen Sie den Frequenzbereich durch Spezifizieren der Mittenfrequenz und Wobbelbandbreite ein:

  1. Klicken Sie im Menü Channel auf Center/Span....

  2. Klicken Sie auf das Feld Center. Geben Sie die gewünschte Mittenfrequenz des Wobbelbereichs ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Klicken Sie auf das Feld Span. Geben Sie die gewünschte Wobbelbandbreite ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf "OK".

Tastenprozedur

So stellen Sie den Frequenzbereich durch Spezifizieren der Start- und Stop-Frequenzen ein:

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Center oder Stop/Span.

  2. Drücken Sie F1 (Start).

  3. Geben Sie die gewünschte Start-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie F2 (Stop).

  5. Geben Sie die gewünschte Stop-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  6. Drücken Sie Enter.

So stellen Sie den Frequenzbereich durch Spezifizieren der Mittenfrequenz und Wobbelbandbreite ein:

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Center oder Stop/Span.

  2. Drücken Sie F3 (Center).

  3. Geben Sie die gewünschte Mittenfrequenz des Wobbelbereichs ein oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie F4 (Span).

  5. Geben Sie die gewünschte Wobbelbandbreite ein oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  6. Drücken Sie Enter.


Siehe auch...

Messparameter

Überblick

Konzepte

Wie stellt man die
Messparameter ein?

Sie können den Netzwerkanalysator für folgende Arten von Messungen konfigurieren:

  • S-Parameter-Messungen (vordefinierte Leistungsverhältnismessungen)

  • Benutzerdefinierte Leistungsverhältnismessungen ("Arbitrary Ratio")

  • Absolutleistungsmessungen ("Unratioed Power").
Konzepte

Wie stellt man die Messparameter ein?

S-Parameter

S-Parameter-basierte Messungen

S-Parameter-Flussdiagramm

Leistungsverhältnis

Absolutleistung

S-Parameter

Die S-Parameter (Scattering-Parameter, Streuparameter) beschreiben die Transmissions- und Reflexionscharakteristiken des Messobjekts. Jeder der vier S-Parameter gibt das Verhältnis zweier komplexer Größen an. Bezüglich der Nummerierung der S-Parameter gilt die folgende Konvention:

S aus ein
wobei:

aus = | Signalausgang (d. h. der Anschluss am Messobjekt, an dem das Response-Signal gemessen wird)
ein = | Signaleingang (d. h. der Anschluss am Messobjekt, an den das Stimulussignal angelegt wird)

Wenn Sie in der folgenden Grafik die Maus auf eine der S-Parameter-Bezeichnungen setzen, wird der Signalfluss bei der entsprechenden Messung angezeigt.

Der Analysator besitzt zwei Messanschlüsse und kann für Messungen an Ein- oder Zweitor-Bauteilen verwendet werden. Sie können den als Eingang zu verwendenden Messanschluss definieren. Je nachdem, welchen Port Sie als Eingang definieren, schaltet der Analysator automatisch die Signalflussrichtung (vorwärts oder rückwärts) entsprechend um. Der Analysator kann dadurch alle vier S-Parameter eines Zweitor-Bauteils in einem einzigen Durchgang (ohne dass das Messobjekt umgepolt werden muss) messen.

Ein Zweitor-Bauteil hat vier S-Parameter: S11, S21, S12 und S22. Wenn Sie in der animierten Grafik die Maus über eine der S-Parameter-Bezeichnungen, wird der Signalfluss bei der entsprechenden Messung angezeigt.

Die S-Parameter eines Zweitor-Bauteils werden in der folgenden Abbildung genauer erläutert.

  • a = das in das Messobjekt eintretende Signal,

  • b = das aus dem Messobjekt austretende Signal.

Hinweis: Alle S-Parameter sind komplexe Werte in linearer Darstellung.

Hinweis: Die Messgenauigkeit ist von der Qualität der für die Kalibrierung verwendeten Normale und von der Messanordnung abhängig.

Hinweis: Die Genauigkeit von S-Parameter-Messungen ist zum Teil davon abhängig, wie der Lastanschluss (d. h. der nicht-stimulierte Anschluss) abgeschlossen ist. Eine nicht-perfekte Last ergibt für a 1 oder a 2 einen Wert ungleich Null (was der S-Parameter-Definition zuwiderläuft). Eine 2-Port-F ehlerkorrektur, die sowohl Quellen- als auch L astanpassung sfehler korrigiert, ist für genaue S-Parameter-Messungen äußerst wichtig. Weitere Informationen siehe unter "Kalibrierung".

S-Parameter-basierte Messungen

Hier die Definitionen und "Klartextbezeichnungen" der vier S-Parameter von Zweitor-Bauteilen.

S-Parameter | Definition | Beschreibung | Richtung
S11 | b1/a1 wobei a2 = 0 | Reflexions- koeffizient (Eingangsanpassung) | vorwärts
S21 | b2/a1 wobei a2 = 0 | Transmissionskoeffizient (Verstärkung oder Dämpfung) | vorwärts
S12 | b1/a2 wobei a1 = 0 | Transmissionskoeffizient (Isolation) | rückwärts
S22 | b2/a2, a1 = 0 | Reflexionskoeffizient (Ausgangsanpassung) | rückwärts

Zu den wichtigsten S-Parameter-basierten Messungen zählen u. a.:

Reflexionsmessungen

Transmissionsmessungen

  • Rückflussdämpfung

  • Stehwellenverhältnis (SWR)

  • Reflexionskoeffizient

  • Im pedanz

  • S11, S22

  • Einfügedämpfung

  • Transmissionskoeffizient

  • Verstärkung/Dämpfung

  • Gruppenlaufzeit

  • Abweichung von der linearen Phase

  • E lektrische Länge

  • S21, S12

S-Parameter-Flussdiagramm

Das folgende Diagramm zeigt den Signalfluss in einem Zweitor-Bauteil oder -Netzwerk bei den verschiedenen S-Parameter-Messungen. Dieses Diagramm ist auch auf die Frontplatte des Analysators aufgedruckt.

Leistungsverhältnis

Die Leistungsverhältnis-Messfunktion ("Arbitrary Ratio", Leistungsverhältnis zwischen beliebigen Signalen) ermöglicht es Ihnen, Leistungsverhältnisse beliebiger Eingangs- und/oder Referenzsignale (A, B, R1 oder R2) zu messen. Typische Anwendungen der "Arbitrary Ratio"-Funktion sind beispielsweise:

  • Messung des Leistungsverhältnissen von Signalen, die direkt den Empfängern A, B, R1 und R2 zugeführt werden.

  • Messungen, die einen größeren D ynamikbereich erfordern, als der Analysator bei S-Parameter-Messungen bietet.

Die Eingänge der Empfänger A, B, R1 und R2 sind über Anschlüsse auf der Frontplatte des Analysators zugänglich.

  • Über die Anschlüsse A (in) und B (in) auf der Frontplatte des Analysators können Sie Signale direkt den Empfängern A und B zuführen. Dies bietet folgende Vorteile:

    • Höhere Eingangsempfindlichkeit (weil die vor den Messanschlüssen befindlichen Koppler umgangen werden)

    • Eine um etwa 15 dB geringere Dämpfung in den Empfängerpfaden A und B.

  • Die Anschlüsse A (out) und B (out) auf der Frontplatte ermöglichen einen direkten Zugriff auf die Koppelarme der Koppler für Port 1 und Port 2.

  • Die Anschlüsse R1 und R2 ermöglichen es, spezielle Messanordnungen zu realisieren, beispielsweise Anordnungen für Messungen mit erhöhtem Messignalpegel unter Verwendung externer (nicht im Lieferumfang des Analysators enthaltener) Komponenten wie Verstärker oder Koppler.

Die folgende Abbildung zeigt die Signalpfade innerhalb des Analysators:

Die folgenden Abbildungen zeigen die Positionen der Anschlüsse auf der Frontplatte des Analysators:

Option 015

Geräte mit Option 015 (konfigurierbares Testset) ermöglichen einen direkten Zugriff auf den Signalpfad zwischen dem Signalquellenausgang und dem Kopplereingang. Diese Option beinhaltet außerdem 35 dB-Abschwächer (mit einer Schrittweite von 5 dB) in den Empfängerpfaden beider Ports. Dadurch ist es möglich, unter Verwendung externer Komponenten die Messempfindlichkeit zu erhöhen oder die Messanordnung an spezielle Anforderungen anzupassen. Siehe hierzu das Tutorial Messungen an Bauteilen mit hoher Ausgangsleistung.

Absolutleistung

Die "Unratioed Power"-Messfunktion ermöglicht die Messung der Absolutleistung am Empfängereingang A, B, R1 oder R2.

Hinweis: Phase nmessungen, Gruppenlaufzeitmessungen oder Messungen, bei denen die Mittelung aktiv ist, können nicht über einen einzigen Eingang durchgeführt werden.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
S-Parameter-Messung

Leistungsverhältnismessung

Absolutleistungsmessung

S-Parameter-Messung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Trace auf Measure.

  2. Klicken Sie auf den gewünschten S-Parameter.

Tastenprozedur

  1. Drücken Sie im Tastenfeld TRACE SETUP die Taste Measure.

  2. Drücken Sie F1 zur Wahl des Parameters S11, oder

  3. Drücken Sie F2 zur Wahl des Parameters S21, oder

  4. Drücken Sie F3 zur Wahl des Parameters S12, oder

  5. Drücken Sie F4 zur Wahl des Parameters S22.

  6. Drücken Sie Enter.

Leistungsverhältnismessung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Trace auf Measure.

  2. Klicken Sie auf Measure....

  3. Wählen Sie im Feld Trace Type die Funktion Arbitrary Ratio.

  4. Wählen Sie im Feld Source Port den gewünschten Port.

  5. Wählen Sie im Feld Input den gewünschten Eingang.

  6. Wählen Sie im Feld Output den gewünschten Ausgang.

  7. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Measure.

  3. Wählen Sie mit der Pfeil-unten-Taste Arbitrary Ratio im Feld Trace Type.

  4. Drücken Sie die Tab-rechts-Taste, um zum Feld Source Port zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Quellen-Port.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Input zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Eingang.

  6. Drücken Sie die Tab-rechts-Taste, um zum Feld Output zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Ausgang.

  7. Drücken Sie im Tastenfeld COMMAND die Taste OK.

Absolutleistungsmessung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Trace auf Measure.

  2. Klicken Sie auf Measure....

  3. Wählen Sie im Feld Trace Type die Funktion Unratioed Power.

  4. Wählen Sie im Feld Source Port den gewünschten Port.

  5. Wählen Sie im Feld Input den gewünschten Eingang.

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld TRACE SETUP die Taste Measure.

  3. Wählen Sie mit der Pfeil-unten-Taste Unratioed Power im Feld Trace Type.

  4. Drücken Sie die Tab-rechts-Taste, um zum Feld Source Port zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Quellen-Port.

  5. Drücken Sie die Tab-rechts-Taste, um zum Feld Input zu gelangen. Wählen Sie mit Hilfe der Pfeil-oben- oder Pfeil-unten-Taste den gewünschten Eingang.

  6. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Mehrere Messkurven und Kanäle

Siehe auch...

Anzeigen mehrerer Messkurven und Kanäle

Überblick

Setups

Organisieren
des Bildschirms

Wie wird ... angezeigt?

Sie können Mehrfachmessungen in vielfältiger Weise konfigurieren. Nach erfolgter Konfiguration können Sie Fenster schnell und einfach in ihrer Größe verändern oder verschieben, um das Darstellungsformat Ihren individuellen Bedürfnissen anzupassen.
Setups

Organisieren des Bildschirms

Wie lassen sich mehrere Messkurven und Kanäle anzeigen?

Mehrere Kanäle, Messkurven und Fenster

Grenzen der Darstellungsmöglichkeiten

Vorkonfigurierte Setups

Setup A: 4 Messkurven, 1 Fenster

Setup B: 4 Messkurven, 4 Fenster

Setup C: 3 Messkurven, 3 Fenster

Setup D: 4 Messkurven, 2 Kanäle, 2 Fenster

Mehrere Kanäle, Messkurven und Fenster

  • Ein Kanal besitzt bestimmte, voneinander unabhängige Attribute, welche die Messdatenerfassung betreffen. Diese Attribute gelten für alle Messkurven dieses Kanals. Der Analysator unterstützt maximal vier voneinander unabhängige Kanäle.

  • Eine Messkurve besitzt bestimmte Attribute, die mathematische Operationen auf der Basis der erfassten Messdaten betreffen. Der Analysator unterstützt bis zu 16 Messkurven auf dem Bildschirm.

  • Die Messkurven werden in einem Fenster angezeigt. Es können wahlweise 1, 2, 3 oder 4 Fenster gleichzeitig auf dem Bildschirm sichtbar sein.

Sie können folgende Objekte erstellen:

  • Mehrere Messkurven und Kanäle, um alle relevanten Charakteristiken Ihres Prüflings zu erfassen

  • Mehrere Fenster, um die Messdaten optimal darzustellen

Grenzen der Darstellungsmöglichkeiten

  • Maximal vier Fenster auf dem Bildschirm

  • Maximal vier aktuelle Messkurven und vier gespeicherte Messkurven pro Fenster.

  • 16 Messkurven auf dem Bildschirm

  • Vier voneinander unabhängige Messkanäle

Vorkonfigurierte Setups

Die vorkonfigurierten Setups bieten einen schnellen und einfachen Weg zum Erstellen von Messungen mit mehreren Messkurven, Kanälen und Fenstern.

  • Sie haben die Wahl zwischen vier vorkonfigurierten Setups.

  • Jeder dieser Setups erstellt neue Messkurven.

  • Vorhandene Messkurven und zugehörige Einstellungen gehen verloren, falls Sie sie nicht zuvor abspeichern.

Setup A

  • Vier Messkurven: S11, S21, S12, S22

  • Ein Fenster, "Log Mag"-Format

  • Ein Kanal

    • S11, S21, S12, S22 in Fenster 1

Setup B

  • Vier Messkurven

  • Vier Fenster, "Log Mag"-Format

  • Ein Kanal

    • S11 in Fenster 1

    • S21 in Fenster 2

    • S12 in Fenster 3

    • S22 in Fenster 4

Setup C

  • Drei Messkurven

  • Drei Fenster, zwei davon im "Smith Chart"-Format und eines im "Log Mag"-Format

  • Ein Kanal

    • S11 in Fenster 1, "Smith Chart"-Format

    • S22 in Fenster 2, "Smith Chart"-Format

    • S21 in Fenster 3, "Log Mag"-Format

Setup D

  • Vier Messkurven

  • Zwei Fenster, beide "Log Mag"-Format

  • Zwei Kanäle

    • S11 und S21 für Kanal 1 in Fenster 1

    • S11 und S21 für Kanal 2 in Fenster 2

Organisieren des Bildschirms

Fenster: "Tile" (nebeneinander), "Cascade" (Überlappend), "Arrange" (alle anordnen), "Maximize/Restore" (maximieren/wiederherstellen)

"Arrange"-Funktion

"Overlay"

"Stack 2"

"Split 3"

"Quad 4"

"Sort Algorithm"

Organisieren des Bildschirms

Der Analysator bietet folgende Möglichkeiten:

  • Fenster mit Hilfe der Maus verschieben oder verkleinern/vergrößern.

  • Fenster mit Hilfe der im Menü Window verfügbaren Funktionen "Tile", "Cascade", "Minimize" und "Maximize" anordnen.

  • Fenster mit Hilfe der Funktion Arrange Windows in einer von vier unterschiedlichen Konfigurationen anordnen.

  • Fenster mit Hilfe der Microsoft Windows-Funktionen Maximieren, Wiederherstellen oder Minimieren (Symbole am oberen rechten Rand eines jeden Fensters) in ihrer Größe verändern oder verbergen

  • Ein einzelnes Fenster aus einer Mehrfenster-Konfiguration maximieren, wobei Sie zwischen folgenden Möglichkeiten wählen können:

    • "Maximieren"-Symbol in der Fensterecke

    • Taste "Maximize/Restore" im Tastenfeld UTILITY (wählen Sie das gewünschte Fenster mit Hilfe der Taste Window im Tastenfeld DISPLAY)

"Arrange Windows"-Funktion

Die "Arrange Windows"-Funktion

  • bietet vier Fensteranordnungen zur Auswahl:

    • "Overlay"

    • "Stack 2"

    • "Split 3"

    • "Quad 4"

  • lässt vorhandene Messkurven, Kanäle und Formate unverändert

  • ordnet Messkurven und Kanäle in den Fenstern gemäß einem Sortieralgorithmus an

"Overlay"

  • Bei dieser Konfiguration werden alle vorhanden Messkurven in einem einzigen Fenster überlagert dargestellt.

  • Falls mehr als vier Messkurven existieren, ist diese Konfiguration nicht verfügbar.

"Stack 2"

  • Alle vorhandenen Messkurven werden in zwei "aufeinander gestapelten" Fenstern dargestellt.

  • Falls mehr als acht Messkurven existieren, ist diese Konfiguration nicht verfügbar.

"Split 3"-Anordnung

  • Bei dieser Konfiguration werden alle vorhanden Messkurven in drei Fenstern – zwei im oberen Teil des Bildschirms und eines darunter – dargestellt.

  • Falls mehr als zwölf Messkurven existieren, ist diese Konfiguration nicht verfügbar.

"Quad 4"

  • Bei dieser Konfiguration werden alle vorhanden Messkurven in vier Fenstern (jeweils ein Fenster in jedem Quadranten des Bildschirms) dargestellt.

"Sort Algorithm"

Der Sortieralgorithmus für die Funktion "Arrange Windows" leistet folgendes:

  • Aufteilung der Messkurven (entsprechend deren Eigenschaften) auf die Fenster

  • Gruppierung von Messkurven mit gemeinsamen Eigenschaften

Die Sortierung erfolgt nach den folgenden Eigenschaften (in der angegebenen Reihenfolge):

  1. Format: zirkular ("Polar" oder "Smith") oder rechtwinklig ("log mag", "lin mag", "group delay" usw.)

  2. Kanalnummer

  3. Transmission oder Reflexion

Hinweis: Die grundsätzliche Beschränkung auf maximal vier Messkurven pro Fenster hat Vorrang vor dem Sortieralgorithmus.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Wählen eines vorkonfigurierten Setups

Wählen einer "Arrange Windows"-Konfiguration

Maximieren eines einzelnen Fensters einer Mehrfenster-Konfiguration

Vorkonfigurierter Setup
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Windows auf Meas Setups,

  2. Klicken Sie auf den gewünschten Setup.

Tastenprozedur

  1. Drücken Sie im Tastenfeld DISPLAY die Taste Measure Setups und anschließend eine der folgenden Tasten:

  2. F1 (Setup A) für vier Messkurven in einem Fenster.

  3. F2 (Setup B) für vier Messkurven in vier Fenstern.

  4. F3 (Setup C) für vier Messkurven in drei Fenstern.

  5. F4 (Setup D) für vier Messkurven in zwei Fenstern.

Wählen einer "Arrange Windows"-Konfiguration
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Window auf Arrange.

  2. Klicken Sie auf die gewünschten Fensteranordnung.

Tastenprozedur

  1. Drücken Sie im Tastenfeld DISPLAY die Taste Arrange Windows und anschließend eine der folgenden Tasten:

  2. F1 (Overlay) für alle Messkurven in einem Fenster.

  3. F2 (Stack) für alle Messkurven in zwei übereinandergestapelten Fenstern.

  4. F3 (Setup C) für alle Messkurven in drei Fenstern.

  5. F4 (Setup D) für alle Messkurven in vier Fenstern.

Maximieren eines einzelnen Fensters einer Mehrfenster-Konfiguration
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie in dem Fenster, das Sie maximieren möchten, auf das Symbol Maximieren.

  2. Wenn Sie die ursprüngliche Fenstergröße wiederherstellen möchten, klicken Sie nochmals auf das Symbol Maximieren.

Tastenprozedur

  1. Wählen Sie im Tastenfeld DISPLAY mit der Taste Window das Fenster, das Sie maximieren möchten.

  2. Drücken Sie im Tastenfeld UTILITY die Taste Maximize/Restore.

  3. Durch nochmaliges Drücken der Taste Maximize/Restorekönnen Sie die ursprüngliche Fenstergröße wiederherstellen.


Siehe auch...

Signalpegel

Überblick

Konzepte

Wie stellt man den
Signalpegel ein?

Der "Power Level"-Wert spezifiziert den Signalpegel des über den Stimulus-Port ausgegebenen Signals.
Konzepte

Wie stellt man den Signalpegel ein?

Die nachfolgenden Themen betreffen verschiedene Aspekte des Signalpegels. Klicken Sie auf eine der Schaltflächen, um sich über das jeweilige Thema genauer zu informieren.
Pegelbereich

Signalpegelkopplung zwischen den Ports

Signalquellenabschwächer

Automatische Einstellung der Abschwächung

Manuelle Einstellung der Abschwächung

Abschwächung bei entkoppelten Ports

Frequenzabhängiger Signalpegel

Empfänger-Abschwächung

Signalpegelbereiche

SIGNALPEGELBEREICHE UND -AUFLÖSUNG
Frequenz | Signalpegel- bereich (dBm) | Pegel- auflösung (dB)
300 kHz bis 6 GHz | –85 bis +10 | 0.01
>6 GHz bis 9 GHz | –85 bis +5 | 0.01

Hinweis: Die Frequenzbereiche der einzelnen PNA-Modelle finden Sie unter Frequenzbereich.

Signalpegelkopplung zwischen den Ports

Standardmäßig sind die Signalpegel für PORT 1 und PORT 2 miteinander gekoppelt, d. h. die Pegel sind für beide Ports gleich. Einige Anwendungen erfordern unterschiedliche Signalpegel an PORT 1 und PORT 2. Der Analysator bietet die Möglichkeit, die beiden Ports zu entkoppeln und dann die Signalpegel für jeden Port individuell einzustellen.

Wenn Sie beispielsweise die Verstärkung und Ausgangsrückwirkung (Isolation in Rückwärtsrichtung) eines Verstärkers mit hoher Verstärkung messen möchten, müssen Sie die Signalpegel für beide Ports individuell einstellen. Der Grund dafür ist, dass am Eingang des Verstärkers ein viel geringerer Signalpegel benötigt wird als am Ausgang. Siehe Abschwächung bei entkoppelten Ports.

VORSICHT! Die Empfänger im Analysator können beschädigt werden, wenn die Eingangspegel folgende Grenzwerte überschreiten: Max. Signalpegel an den Messanschlüssen (PORT 1 und PORT 2): +30 dBm (1,0 Watt). Max. Signalpegel an den Empfängereingängen: +15 dBm (31,6 mW)

Ausgangsabschwächer

Der Analysator enthält einen programmierbaren Ausgangs-Stufenabschwächer und bietet einen Signalpegel-Einstellbereich von insgesamt 95 dB. Der Abschwächer beeinflusst lediglich den Signalpegel am Eingang des Messobjekts, aber nicht den Pegel des einfallenden Signals im Referenzpfad. Dies bringt folgende Vorteile:

  • höhere Genauigkeit und Reproduzierbarkeit des Messsignals

  • genauere Quellenanpassung

Der Abschwächer ermöglicht die Wahl zwischen acht verschiedenen Signalpegelbereichen.

  • Der spezifizierte Einstellbereich innerhalb der einzelnen Abschwächerbereiche beträgt jeweils 25 dB.

  • Der optimale Einstellbereich innerhalb eines Pegelbereichs ist das 10 dB-Band in der Mitte des Abschwächerbereichs. Dies ist der Bereich optimaler Signalpegelgenauigkeit und -reproduzierbarkeit. Siehe hierzu die Grafiken unter Signalpegelbereiche.

  • Die Abschwächereinstellung kann manuell oder automatisch gewählt werden.

Hinweis: Die F ehler k orrektur bietet nur bei dem Signalpegel, bei dem die Kalibrierung erfolgte, die volle Genauigkeit. Wenn Sie jedoch den Signalpegel nur innerhalb des Bereichs ändern, in dem die Kalibrierung durchgeführt wurde, erzielen Sie bei Verhältnismessungen fast die volle Genauigkeit (bei Nicht-Verhältnismessungen vermindert sich die Genauigkeit signifikant).

Automatische Wahl der Abschwächung

In der Abschwächerbetriebsart Auto (Standardbetriebsart)

  • erlaubt Ihnen der Analysator, einen beliebigen Signalpegel innerhalb des spezifizierten Gesamt-Signalpegelbereichs des Gerätes einzustellen

  • wählt der Analysator die Abschwächereinstellung und den Signalpegel automatisch so, dass der Signalpegel im optimalen Bereich des gesamten Abschwächerbereichs liegt.

Siehe Abschwächerbereiche und Umschaltpunkte.

Manuelle Einstellung der Abschwächung

In bestimmten Anwendungen ist es erforderlich, den Signalpegel und den Abschwächer manuell einzustellen. Hier einige Beispiele für solche Anwendungen:

  • Reflexionsmessungen an Verstärkern, die unter bestimmten Bedingungen instabil sind

Solche Messungen erfordern eine sehr gute Impedanzanpassung an die Signalquelle (20 dB Rückflussdämpfung) über einen weiten Frequenzbereich. Bei Messungen über einen weiten Frequenzbereich bietet der Abschwächer eine bessere Impedanzanpassung als die nicht-abgeschwächte Signalquelle. Siehe hierzu das Tutorial Messungen an Leistungsbauteilen.

    • Die beste Quellenanpassung erzielen Sie in der Betriebsart Auto Off bei einem Abschwächungsfaktor von 10 oder 20 dB (oder mehr).

  • Signalpegelwobbelung

Während einer Signalpegelwobbelung wird das automatische Umschalten des Abschwächers unterbunden, um einen vorzeitigen Verschleiß des Abschwächers durch allzu häufiges Umschalten zu vermeiden. Deshalb ist es in der Abschwächerbetriebsart "Auto" u. U. nicht möglich, eine Signalpegelwobbelung über den vollen gewünschten Bereich durchzuführen.

    • Wählen Sie Auto Off und eine Kombination aus Signalpegel und Abschwächereinstellung, mit der Sie den gewünschten Signalpegel-Wobbelbereich erzielen.

In der Abschwächerbetriebsart Manual müssen Sie

  • den Signalpegel manuell wählen;

  • die Abschwächereinstellung manuell wählen;

  • die Kombination der beiden Einstellungen so wählen, dass der Signalpegel im optimalen Bereich für die jeweilige Abschwächereinstellung liegt.

ABSCHWÄCHERBEREICHE, 300 kHz bis 6 GHz

ABSCHWÄCHERBEREICHE, 6 GHz bis 9 GHz

ABSCHWÄCHERBEREICHE UND UMSCHALTPUNKTE 300 kHz bis 6 GHz
 |  |  | Optimaler Bereich |  |
Abschw.- faktor (dB) | Minimal einstellbarer Pegel (nicht spez.) (dBm) | Minimaler spezifizierter Pegel (dBm) | Unterer Umschaltpunkt (dBm) | Oberer Umschaltpunkt (dBm) | Maximaler spezifizierter Pegel (dBm)
0 | -20 | -15 | -5 | +5 (keine Umschaltung) | +10
10 | -30 | -25 | -15 | -5 | 0
20 | -40 | -35 | -25 | -15 | -10
30 | -50 | -45 | -35 | -25 | -20
40 | -60 | -55 | -45 | -35 | -30
50 | -70 | -65 | -55 | -45 | -40
60 | -80 | -75 | -65 | -55 | -50
70 | -85 | ---- | -85 (keine Umschaltung) | -65 | -60
ABSCHWÄCHERBEREICHE UND UMSCHALTPUNKTE 6 GHz bis 9 GHz
 |  |  | Optimaler Bereich |  |
Abschw-. faktor (dB) | Minimal einstellbarer Pegel (nicht spez.) (dBm) | Minimaler spezifizierter Pegel (dBm) | Unterer Umschaltpunkt (dBm) | Oberer Umschaltpunkt (dBm) | Maximaler spezifizierter Pegel (dBm)
0 | -20 | -15 | -5 | +5 (keine Umschaltung) | +5
10 | -30 | -25 | -15 | -5 | -5
20 | -40 | -35 | -25 | -15 | -15
30 | -50 | -45 | -35 | -25 | -25
40 | -60 | -55 | -45 | -35 | -35
50 | -70 | -65 | -55 | -45 | -45
60 | -80 | -75 | -65 | -55 | -55
70 | -85 | ---- | -85 (keine Umschaltung) | -65 | -65

Abschwächung bei entkoppelten Ports

Wenn die beiden Ports 1 und 2 voneinander entkoppelt sind, können unterschiedliche Stufenabschwächereinstellungen für die beiden Ports gewählt werden. Zur Vorbeugung gegen vorzeitiges Verschleißen des mechanischen Stufenabschwächers

  • verhindert der Analysator ein ständiges Umschalten zwischen den beiden Bereichen.

  • geht der Analysator automatisch in den Hold-Modus über, nachdem jeder Kanal einmal gemessen wurde.

Bei aktiver Mittelungsfunktion geht der Analysator erst dann in den Hold-Modus über, wenn für jeden Kanal die vorgegebene Anzahl von Wobbelzyklen ausgeführt wurde.

Frequenzabhängiger Signalpegel

Die "Power Slope"-Funktion ermöglicht es, die mit steigender Frequenz zunehmende Dämpfung von Kabeln, Testadaptern usw. durch einen entsprechend höheren Signalpegel zu kompensieren.

  • Wenn die "Power Slope"-Funktion aktiv ist, wird der Signalpegel mit zunehmender Frequenz erhöht (bzw. bei negativem "Power Slope"-Wert verringert).

  • Die Maßeinheit für "Power Slope" ist dB/GHz.

  • Für "Power Slope" sind nur die Werte 0.5, 1, 1.5 oder 2 (jeweils positiv oder negativ) zulässig.

Eingangsabschwächer (nur für Geräte mit Option 015)

VORSICHT! Die Empfänger im Analysator können beschädigt werden, wenn die Eingangspegel folgende Grenzwerte überschreiten: Max. Signalpegel an den Messanschlüssen (PORT 1 und PORT 2): +30 dBm (1,0 Watt). Max. Signalpegel an den Empfängereingängen: +15 dBm (31,6 mW)

Zum Schutz der Empfänger vor Beschädigung muss u. U. der Ausgangspegel des Messobjekts reduziert werden. Option 015 beinhaltet interne Abschwächer für beide Empfänger.

  • Bereich: 0 bis 35 dB

  • Auflösung: 5 dB

Durch Anklicken einer der Schaltflächen gelangen Sie zur Beschreibung der betreffenden Prozedur.
Einstellen des Signalpegels

Abschalten des Messsignals

Manuelles Einstellen der Abschwächung

Einstellen des "Power Slope"-Wertes

Einstellen der Eingangsabschwächung (nur für Geräte mit Option 015)

Einstellen des Signalpegels

Mausprozedur

Tastenprozedur

VORSICHT! Die Empfänger im Analysator können beschädigt werden, wenn die Eingangspegel folgende Grenzwerte überschreiten: Max. Eingangspegel an den Messanschlüssen (PORT 1 und PORT 2): +30 dBm (1,0 Watt). Max. Eingangspegel an den Empfängereingängen: +15 dBm (31,6 mW)

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Geben Sie in das Feld Test Port Power den gewünschten Signalpegel für Port 1 ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile. Die Signalpegel für die beiden Ports sind standardmäßig miteinander gekoppelt; das bedeutet, dass der Signalpegel für Port 2 automatisch auf den gleichen Wert eingestellt wird.

  3. Wenn Sie die Signalpegel für beide Ports individuell einstellen möchten, klicken Sie zum Entkoppeln der beiden Ports auf Port Power Coupled. Wählen Sie im Feld Port den gewünschten Port. Wiederholen Sie den Schritt 2 dieser Prozedur.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie F1 (Level) und geben Sie den gewünschten Signalpegel ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  3. Drücken Sie Enter.

Abschalten des Messsignals
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Klicken Sie zum Abschalten des Messsignals in das Kontrollkästchen Power On.

  3. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie F2 (ON/off); der Softkey befindet sich jetzt in der Stellung OFF.

Manuelles Einstellen der Abschwächung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Klicken Sie im Bereich Attenuator Control des Dialogfensters auf das Feld Auto, um von automatischer Wahl der Abschwächung auf manuelle Einstellung umzuschalten.

  3. Klicken Sie in das Feld Attenuator Control und geben Sie den gewünschten Abschwächungsfaktor ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie F3 (Atten-Auto), um von automatischer Wahl der Abschwächung auf manuelle Einstellung umzuschalten.

  3. Geben Sie den gewünschten Abschwächungswert ein, oder wählen Sie diesen mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie Enter.

Einstellen des "Power Slope"-Wertes
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Klicken Sie im Bereich Power Slope des Dialogfensters auf das Feld Slope.

  3. Klicken Sie in das Feld Slope (dB/GHz) und geben Sie den gewünschten "Slope"-Wert ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  2. Drücken Sie F4 (Slope) und geben Sie den gewünschten "Slope"-Wert ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  3. Drücken Sie Enter.

Einstellen der Eingangsabschwächung (nur für Geräte mit Option 015)
Mausprozedur

Tastenprozedur

VORSICHT! Die Empfänger im Analysator können beschädigt werden, wenn die Eingangspegel folgende Grenzwerte überschreiten: Max. Signalpegel an den Messanschlüssen (PORT 1 und PORT 2): +30 dBm (1,0 Watt). Max. Signalpegel an den Empfängereingängen: +15 dBm (31,6 mW)

Mausprozedur

  1. Klicken Sie im Menü Channel auf Power.

  2. Klicken Sie im Bereich Receiver Attenuation des Dialogfensters auf das Feld "Receiver A" oder "Receiver B". Geben Sie die gewünschte Eingangsabschwächung ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  3. Drücken Sie Enter.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog.

  2. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  3. Wählen Sie im Bereich Receiver Attenuation des Dialogfensters Power mit der Tab-rechts-Taste den Empfänger A oder B. Geben Sie den gewünschten Abschwächungswert ein, oder wählen Sie diesen mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie Enter.

  5. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Schritt 1 – Einrichten des Analysators

Einrichten des Analysators

Siehe auch...

Klicken Sie auf eine Schaltfläche, um Informationen darüber zu erhalten, wie der Analysator für Messungen eingerichtet wird.
Einbinden des Analysators in ein lokales Netzwerk

Analysator-Voreinstellungen

Einrichten von Messungen

Messparameter wählen

Frequenzbereich wählen

HF-Signalpegel wählen

Wobbelungstyp wählen

Trigger wählen

Darstellungsformat und Skalierung wählen

Einrichten des Bildschirms

Anzeigen mehrerer Messkurven und Kanäle

Anpassen der Bildschirmanzeigen

Abschalten der Frequenz-/Stimulus-Anzeigen


Siehe auch...

Wobbelung

Überblick

Konzepte

Wie richtet man eine lineare, Pegel- oder CW-Wobbelung ein?

Wie richtet man eine Segmentwobbelung ein?

Eine Wobbelmessung ist eine Folge von Einzelmessungen, bei denen der Stimuluswert jeweils um eine vorgegebene Schrittweite verändert wird.
Konzepte

Wie richtet man eine lineare Wobbelung, Pegelwobbelung oder CW-Wobbelung ein?

Wie richtet man eine Segmentwobbelung ein?

Wobbeltypen

Lineare Frequenzwobbelung

Pegelwobbelung

CW-Zeitwobbelung

Segmentwobbelung

Symbolleiste für Wobbelfunktionen

Wobbeltypen

Der Analysator bietet vier Wobbeltypen zur Auswahl.

Lineare Frequenzwobbelung

Dies ist der Standard-Wobbeltyp. Die Frequenz wird kontinuierlich und linear über den vorgegebenen Frequenzbereich gewobbelt.

Die folgende Abbildung zeigt das Ergebnis einer linearen Wobbelmessung an einem Filter; der Wobbelbereich beträgt in diesem Fall 50.000 MHz bis 200.000 MHz.

Pegelwobbelung

Pegelwobbelung dient zur Charakterisierung von Schaltungen, deren elektrische Eigenschaften vom Signalpegel abhängig sind; typische Anwendungen für Pegelwobbelung sind beispielsweise Verstärkungskompressionsmessungen oder die Charakterisierung von Schaltungen zur automatischen Verstärkungregelung (AGC).

  • Der Signalpegel wird von einem vorgegebenen Startwert zu einem vorgegebenen Endwert verändert, wobei die Frequenz konstant bleibt.

  • Pegelwobbelung erfolgt immer schrittweise.

    • Der Stimulussignalpegel wird in diskreten Schritten über den vorgegebenen Pegelbereich verändert.

    • Die Schrittweite wird durch die Anzahl der Datenpunkte und den Pegelbereich bestimmt.

  • Wählen Sie eine Kombination aus Signalquellen-Ausgangspegelbereich und manueller Abschwächereinstellung, die den gewünschten Pegelwobbelbereich ergibt. Siehe Signalpegel .

Die folgende Abbildung zeigt das Ergebnis einer Pegelwobbelmessung an einem Verstärker; der Wobbelbereich beträgt in diesem Fall –5.0 dBm bis +10 dBm.

CW-Zeitwobbelung

In der Wobbelbetriebsart CW Zeitwobbelung arbeitet der Analysator ähnlich wie ein Oszilloskop.

  • Der Analysator ist auf eine feste Frequenz eingestellt.

  • Das Ausgangssignal des Messobjekts wird über der Zeit dargestellt.

  • Das Signal wird kontinuierlich in konstanten Zeitabständen abgetastet; der Zeitabstand ist gleich der Wobbelzeit dividiert durch die Anzahl der Messkurvenpunkte minus eins.

Die folgende Abbildung zeigt das Ergebnis einer CW-Zeitmessung an einem Verstärker; der Wobbelbereich beträgt in diesem Fall 0 bis 6 ms.

Segmentwobbelung

In der Betriebsart Segmentwobbelung erfolgt die Wobbelung über beliebig wählbare Frequenzpunkte; Anzahl und Frequenzen dieser Punkte werden durch eine benutzerdefinierte Liste vorgegeben. Dabei können kontinuierlich zu wobbelnde Frequenzbereiche (sogenannte Segmente) spezifiziert werden. Eine auf diese Weise zusammengesetzte Messkurve kann bis zu 1601 Datenpunkte enthalten. Eine Segmentwobbelung betrifft alle Messkurven eines Kanals. Der Frequenzbereich und die Anzahl der Punkte können für jedes Segment individuell vorgegeben werden. Auch die folgenden Parameter können für jedes Segment individuell vorgegeben werden:

  • ZF-Bandbreite (Siehe Messgenauigkeit und Messgeschwindigkeit optimieren.)

  • Signalpegel

  • Wobbelzeit

Wenn eine Kalibrierung über den gesamten Wobbelbereich oder sämtliche Segmente durchgeführt wurde, können Sie kalibrierte Messungen über ein oder mehrere Segmente durchführen.

Der Netzwerkanalysator

  • sortiert automatisch alle definierten Segmente nach steigender Frequenz;

  • führt an jedem einzelnen Punkt eine Messung durch;

  • zeigt eine einzige Messkurve an, die sich aus den einzelnen Punkten zusammensetzt.

Beim Definieren einer Segmentwobbelung ist folgendes zu beachten:

  • Der Frequenzbereich eines Segments darf sich nicht mit dem Frequenzbereich eines anderen Segments überlappen.

  • Um einen vorzeitigen Verschleiß des Stufenabschwächers zu vermeiden, müssen die Signalpegel aller Segmente im gleichen Signalpegelbereich liegen. Siehe Signalpegel.

Symbolleiste für Wobbelfunktionen

Die Symbolleiste für den Zugriff auf die Wobbelfunktionen befindet sich oberhalb der obersten Bildschirmfenster. Die in dieser Symbolleiste enthaltenen Symbole ermöglichen es Ihnen, folgende Betriebsarten zu wählen (die Betriebsarten sind in der Reihenfolge der Symbole aufgelistet):

  • Hold-Betriebsart

  • Single-Betriebsart, anschließend "Hold"-Betriebsart

  • Continuous-Betriebsart

Weitere Informationen siehe unter Trigger.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Einrichten einer linearen Frequenzwobbelung

Einrichten einer Pegelwobbelung

Einrichten einer CW-Zeitwobbelung

Lineare Frequenzwobbelung

Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Sweep Type.

  2. Klicken Sie im Feld Sweep Type auf Linear Frequency.

  3. Klicken Sie auf das Feld Start im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte Start-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf das Feld Stop im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte Stop-Frequenz des Wobbelbereichs ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  5. Klicken Sie auf das Feld Points im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte Anzahl von Datenpunkten im Wobbelbereich ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Type.

  2. Drücken Sie F1 (Linear).

  3. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  4. Drücken Sie F2 (Points) und geben Sie die gewünschte Anzahl der Datenpunkte ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  5. Drücken Sie Enter.

Pegelwobbelung

Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Sweep Type.

  2. Klicken Sie im Feld Sweep Type auf Power Sweep.

  3. Klicken Sie auf das Feld Start im Bereich Sweep Properties des Dialogfensters. Geben Sie den gewünschten Start-Pegel für die Wobbelung ein oder wählen Sie diesen durch Anklicken der Pfeile.

  4. Klicken Sie auf das Feld Stop im Bereich Sweep Properties des Dialogfensters. Geben Sie den gewünschten Stop-Pegel für die Wobbelung ein oder wählen Sie diesen durch Anklicken der Pfeile.

  5. Klicken Sie auf das Feld CW Freq im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte CW-Frequenz für die Pegelwobbelung ein, oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  6. Klicken Sie auf OK.

  7. Klicken Sie im Menü Sweep auf Number of Points. Geben Sie die gewünschte Anzahl von Datenpunkten im Pegelwobbelbereich ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  8. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Type.

  2. Drücken Sie F2 (Pwr Sweep).

  3. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Power.

  4. Drücken Sie F1 (Start Power) und geben Sie den gewünschten Start-Pegelwert ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  5. Drücken Sie Enter.

  6. Drücken Sie F2 (Stop Power) und geben Sie den gewünschten Stop-Pegelwert ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  7. Drücken Sie Enter.

  8. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Center oder Stop/Span.

  9. Drücken Sie F3 (CW Freq) und geben Sie die gewünschte CW-Frequenz für die Wobbelung ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  10. Drücken Sie Enter.

CW-Zeitwobbelung
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Sweep Type.

  2. Klicken Sie im Feld Sweep Type auf CW Time.

  3. Klicken Sie auf das Feld CW Freq im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte CW-Frequenz für die Wobbelung ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  4. Klicken Sie auf das Feld Sweep Time im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte Wobbelzeit ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  5. Klicken Sie auf das Feld Points im Bereich Sweep Properties des Dialogfensters. Geben Sie die gewünschte Anzahl von Datenpunkten im Pegelwobbelbereich ein oder wählen Sie diesen Wert durch Anklicken der Pfeile.

  6. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Type.

  2. Drücken Sie F3 (CW Time).

  3. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Start/Center.

  4. Drücken Sie F1 (CW Freq) und geben Sie die gewünschte CW-Frequenz für die Wobbelung ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  5. Drücken Sie Enter.

  6. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Setup.

  7. Drücken Sie F1 (Time) und geben Sie die gewünschte Wobbelzeit ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  8. Drücken Sie Enter.

  9. Drücken Sie F2 (Points) und geben Sie die gewünschte Anzahl der Datenpunkte für die Wobbelung ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  10. Drücken Sie Enter.

Einrichten einer Segmentwobbelung
Mausprozedur

Tastenprozedur

Mausprozedur

Wählen Sie den Wobbeltyp Segmentwobbelung:

  1. Klicken Sie im Menü Sweep auf Sweep Type.

  2. Klicken Sie im Feld Sweep Type auf Segment Sweep.

  3. Falls Sie die Signalpegel für die einzelnen Segmente individuell vorgeben möchten, klicken Sie auf das Kontrollkästchen Independent Power Levels im Bereich Sweep Properties des Dialogfensters.

  4. Falls Sie die ZF-Bandbreite für die einzelnen Segmente individuell vorgeben möchten, klicken Sie auf das Kontrollkästchen Independent IF Bandwidth im Bereich Sweep Properties des Dialogfensters.

  5. Falls Sie die Verweilzeiten für die einzelnen Segmente individuell vorgeben möchten, klicken Sie auf das Kontrollkästchen Independent Dwell Time im Bereich Sweep Properties des Dialogfensters.

  6. Klicken Sie auf das Feld Show Table im Bereich Sweep Properties des Dialogfensters.

  7. Klicken Sie auf OK.

Definieren Sie die Segmente:

  1. Wenn Sie ein Segment hinzufügen möchten, klicken Sie auf Insert Segment in dem Untermenü Segment Table des Menüs Sweep.

  2. Wenn Sie ein Segment löschen möchten, wählen Sie es zunächst, indem Sie auf die betreffende Segmentnummer klicken. Klicken Sie auf Delete Segmentim Untermenü Segment Table des Menüs Sweep.

  3. Klicken Sie auf das Feld STATE für das erste Segment in der Segmenttabelle. Drücken Sie die Pfeiltaste, um das Segment zu aktivieren (ON).

  4. Klicken Sie auf das Feld START für das erste Segment in der Segmenttabelle. Geben Sie den gewünschten Start-Frequenzwert für dieses Segment ein.

  5. Klicken Sie auf das Feld STOP für das erste Segment in der Segmenttabelle. Geben Sie den gewünschten Stop-Frequenzwert für dieses Segment ein.

  6. Klicken Sie auf das Feld POINTS für das erste Segment in der Segmenttabelle. Geben Sie die gewünschte Anzahl von Datenpunkten für dieses Segment ein.

  7. Wenn Sie in Schritt 4 dieser Prozedur die Option "independent power levels" gewählt haben, klicken Sie auf das Feld POWER für das erste Segment in der Segmenttabelle. Geben Sie den gewünschten Signalpegelwert für dieses Segment ein.

  8. Wenn Sie in Schritt 5 dieser Prozedur die Option "independent IF bandwidths" gewählt haben, klicken Sie auf das Feld IFBW für das erste Segment in der Segmenttabelle. Geben Sie die gewünschte ZF-Bandbreite für dieses Segment ein.

  9. Wenn Sie in Schritt 6 dieser Prozedur die Option "independent dwell times" gewählt haben, klicken Sie auf das Feld DWL TIME für das erste Segment in der Segmenttabelle. Geben Sie die gewünschte Verweilzeit für dieses Segment ein.

  10. Klicken Sie auf OK.

Tastenprozedur

Wählen Sie den Wobbeltyp Segmentwobbelung:

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Sweep Type.

  2. Drücken Sie F4 (Segments).

  3. Drücken Sie zum Definieren oder Ändern von Segmentwobbelungsparametern die Taste Menu/Dialog im Tastenfeld COMMAND und anschließend die Taste Sweep Type im Tastenfeld CHANNEL SETUP. Daraufhin erscheint das Dialogfenster Sweep Type.

  4. Drücken Sie die Tab-rechts-Taste, um zum Bereich "Sweep Type" des Dialogfensters zu gelangen. Wählen Sie durch Drücken der Pfeil-unten-Taste die Option "Segment Sweep".

  5. Falls Sie die Signalpegel für die einzelnen Segmente individuell vorgeben möchten, drücken Sie die Pfeil-rechts-Taste, um zu dem Kontrollkästchen Independent Power Levels im Bereich Sweep Type des Dialogfensters zu gelangen. Drücken Sie "Click".

  6. Falls Sie die ZF-Bandbreiten für die einzelnen Segmente individuell vorgeben möchten, drücken Sie die Pfeil-rechts-Taste, um zu dem Kontrollkästchen Independent IF Bandwidth im Bereich Sweep Type des Dialogfensters zu gelangen. Drücken Sie "Click".

  7. Falls Sie die Verweilzeiten für die einzelnen Segmente individuell vorgeben möchten, drücken Sie die Pfeil-rechts-Taste, um zu dem Kontrollkästchen Independent Dwell Time im Bereich Sweep Type des Dialogfensters zu gelangen. Drücken Sie "Click".

  8. Drücken Sie die Tab-rechts-Taste, um zum Kontrollkästchen Show Table im Bereich Sweep Properties des Dialogfensters zu gelangen und die Segmenttabelle anzuzeigen.

So definieren Sie Segmente:

  1. Drücken Sie "Click". Jetzt können Sie für STATE zwischen den Optionen ON und OFF wählen. Wählen Sie mit den Pfeil-oben/unten-Tasten den gewünschten Zustand.

  2. Drücken Sie die Tab-rechts-Taste, um zum Eintrag START in der Segmenttabelle zu gelangen. Geben Sie den gewünschten Start-Frequenzwert für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  3. Drücken Sie die Tab-rechts-Taste, um zum Eintrag STOP in der Segmenttabelle zu gelangen. Geben Sie den gewünschten Stop-Frequenzwert für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  4. Drücken Sie die Tab-rechts-Taste, um zum Eintrag POINTS in der Segmenttabelle zu gelangen. Geben Sie die gewünschte Anzahl von Datenpunkten für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  5. Falls Sie das Kontrollkästchen Independent IF Bandwidth im Dialogfenster Sweep Type angeklickt haben, drücken Sie die Tab-rechts-Taste, um zum Eintrag "IFBW" in der Segmenttabelle zu gelangen. Geben Sie den gewünschten ZF-Bandbreite-Wert für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  6. Falls Sie das Kontrollkästchen Independent Power Levels im Dialogfenster Sweep Type angeklickt haben, drücken Sie die Tab-rechts-Taste, um zum Eintrag POWER in der Segmenttabelle zu gelangen. Geben Sie den gewünschten Signalpegelwert für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  7. Falls Sie das Kontrollkästchen Independent Dwell Time im Dialogfenster Sweep Type angeklickt haben, drücken Sie die Tab-rechts-Taste, um zum Eintrag "IFBW" in der Segmenttabelle zu gelangen. Geben Sie die gewünschte Verweilzeit für dieses Segment ein, oder wählen Sie diesen Wert mit Hilfe der Pfeil-oben/unten-Tasten.

  8. Wenn Sie Segmente hinzufügen möchten, drücken Sie die Tab-rechts-Taste, um zum "Sweep"-Menü zu gelangen. Drücken Sie die Pfeil-unten-Taste, um zu Segment Table zu gelangen. Rufen Sie durch Drücken der Tab-rechts-Taste das Segment Table-Menü auf. Drücken Sie die Pfeil-unten-Taste, um zum Eintrag Insert Segment zu gelangen. Drücken Sie die Taste "Click" oder "OK" im Tastenfeld COMMAND, um Insert Segment zu wählen.

  9. Wenn Sie ein Segment löschen möchten, wählen Sie das betreffende Segment zunächst in der Segmenttabelle. Drücken Sie die Tab-rechts-Taste, um zum "Sweep"-Menü zu gelangen. Drücken Sie die Pfeil-unten-Taste, um zu Segment Table zu gelangen. Rufen Sie durch Drücken der Tab-rechts-Taste das Segment Table-Menü auf. Drücken Sie die Pfeil-unten-Taste, um zum Eintrag Delete Segment zu gelangen. Drücken Sie die Taste "Click" oder "OK" im Tastenfeld COMMAND, um Delete Segment zu wählen.

  10. Wiederholen Sie die Schritte 10 bis 16 für jeden Eintrag in der Segmenttabelle.

  11. Klicken Sie auf die Taste "OK" im Tastenfeld COMMAND.


Siehe auch...

Trigger

Überblick

Konzepte

Wie konfiguriert man Trigger?

Ein Trigger ist ein Signal, das den Analysator zum Starten einer Wobbelmessung veranlasst. Die Triggereinstellungen bestimmen außerdem, wie die Messung gestartet wird und wann der Analysator die Wobbelung beendet und in den Hold-Zustand übergeht.
Konzepte

Wie konfiguriert man Trigger?

Der Analysator bietet vielfältige Möglichkeiten zum Konfigurieren der Triggerbedingungen.
Triggermodell

Triggerquelle

"Internal"

"Manual"

"External"

"Trigger Scope"

"Global"

"Channel"

"Channel Trigger State"

"Continuous"

"Group"

"Single"

"Hold"

"Point"

Triggereinstellungen und RESTART

Triggermodell

In dem animierten Triggermodell werden Triggersignale durch Bälle versinnbildlicht. Das Ziel besteht darin, die Bälle zu den Kanälen zu leiten. Das Modell enthält drei Kanäle. Wenn ein Kanal einen Ball akzeptiert, führt er eine Messung durch. Hier geht es zum animierten Triggermodell.

  • Der obere Kasten (Triggerquelle) enthält Bälle. Ein gültiges Triggerereignis gibt einen Ball frei, der dann zu einem der drei Kanäle geleitet wird. (Ein Triggerereignis ist nur dann gültig, wenn es zu einem Zeitpunkt stattfindet, da keine Wobbelmessung in Gang ist). Die Trigger Source-Einstellungen bestimmen, woher die Bälle kommen:

    • aus einem internen Kasten,

    • aus einem externen Kasten,

    • nacheinander manuell eingeworfen.

  • Wenn der Ball in den mittleren Kasten fällt, bestimmt die Trigger Scope-Einstellung, wie er innerhalb des Systems weitergeleitet wird.

    • Wenn die Einstellung Global gewählt wurde, werden aus dem einen Ball drei Bälle (jeweils einer für jeden Kanal). Die Rutschbahnen leiten dann diese Bälle nacheinander zu den richtigen Kanälen.

    • Wenn die Einstellung Channel gewählt wurde, wird der eine Ball zum nächsten verfügbaren Kanal geleitet.

  • Die Channel Trigger State-Einstellung eines Kanals bestimmt, ob der betreffende Kanal Bälle akzeptiert, und wenn ja, wieviele.

Triggerquelle

Sie können zwischen drei Triggerquellen wählen: "internal", "external" oder "manual". Diese Auswahl gilt für sämtliche Kanäle. Siehe hierzu das animierte Triggermodell.

  • Ein Triggerereignis ist nur dann gültig, wenn es zu einem Zeitpunkt stattfindet, da keine Wobbelmessung in Gang ist.

"Internal Trigger" (Standardeinstellung)

  • Die Triggerung wird vom Analysator selbst gesteuert.

  • Ein Trigger wird ausgelöst, sobald der Analysator eine Messung abgeschlossen hat.

"Manual Trigger"

Einen manuellen Trigger können Sie auf verschiedene Weise auslösen:

  • Klicken Sie auf Trigger! im Trigger-Menü oder -Dialogfenster, oder

  • Senden Sie einen Triggerbefehl über die Fernsteuerungsschnittstelle, oder

  • Drücken Sie die Taste Trigger.

Wenn Sie versuchen, während einer laufenden Messung einen manuellen Trigger zu senden, wird die Triggeranforderung ignoriert. Erst nach Abschluss der Wobbelmessung wird ein Trigger erkannt.

"External Trigger"

  • Zur externen Triggerung ist ein geeignetes externes Signal am rückseitigen Anschluss "Auxiliary I/O" (Pin 19) erforderlich.

  • TTL-Signal

  • Pegelsensitiv: "active high" oder "active low"

  • Der Triggerimpuls muss mindestens 1 us lang sein und darf nicht länger als die Wobbelzeit sein. (Triggerimpulse, die länger sind als die Wobbelzeit, können mehrere Trigger auslösen).

  • Wenn das externe Triggersignal dauerhaft größer als der Triggerpegel ist, bewirkt dies eine kontinuierliche Wobbelung. Dies können Sie verhindern, indem Sie im "External Trigger"-Menü die Betriebsart "Single" wählen. In der Betriebsart "Single" reagiert der Analysator auf die erste gültige Triggerflanke, geht anschließend in den "Hold"-Zustand über und verbleibt in diesem Zustand, bis nochmals die Betriebsart "Single" gewählt wird.

"Triggerbereit"-Signal

  • Das "Triggerbereit"-Signal ist auch an dem rückseitigen "Auxiliary I/O" Anschluss (Pin 18) verfügbar.

  • TTL-Signal ("active low").

  • Wenn die "Triggerbereit"-Leitung im LOW-Zustand ist und der Analysator ein gültiges externes Triggersignal empfängt, wird die "Triggerbereit"-Leitung für die Dauer der Messung auf HIGH gezogen. Wenn der Analysator sich, beispielsweise, in der Betriebsart alternierende Wobbelung mit 2-Port-Kalibrierung befindet, sind zur Aktualisierung der Messdaten vier Wobbelzyklen erforderlich. Die "Triggerbereit"-Leitung verbleibt in diesem Fall so lange im HIGH-Zustand ("nicht triggerbereit"), bis alle vier Wobbelzyklen beendet sind und die Messdaten aktualisiert wurden.

"Trigger Scope"

Die "Trigger Scope"-Einstellung bestimmt, welche Kanäle ein Triggersignal empfangen. ("Scope" hat in diesem Fall nichts mit einem Oszilloskop zu tun, sondern bedeutet "Reichweite" im übertragenen Sinne). Sie haben die Wahl zwischen den "Trigger Scope"-Einstellungen Global und Channel. Das animierte Triggermodell zeigt, wie die "Trigger Scope"-Einstellung den Triggersignalfluss beeinflusst.

"Global" (Standardeinstellung)

  • Das von der Triggerquelle gesendete Triggersignal wird an alle benutzten Kanäle geleitet.

  • Ein einziges Triggersignal startet Messungen in allen benutzten Kanälen (mit Ausnahme solcher Kanäle, die sich im "Hold"-Zustand befinden)

"Channel"

  • Das von der Triggerquelle gesendete Signal wird nur zum aktiven Kanal geleitet.

  • Diese Einstellung wird automatisch gewählt, wenn sich mindestens einer der Kanäle in der "Trigger State"-Einstellung Point befindet.

Wenn der aktive Kanal seinen Messzyklus abgeschlossen hat, wird automatisch der nächste Kanal gewählt. Die Kanäle werden nacheinander gewählt, es sei denn, ein Kanal befindet sich im Kanaltrigger-"Hold"-Zustand. Falls nur ein Kanal benutzt wird oder nur ein Kanal sich nicht im "Hold"-Zustand befindet, bleibt der aktive Kanal unverändert.

"Channel Trigger State"

Sie haben die Wahl zwischen vier "Channel Trigger States", die die Anzahl der Trigger bestimmen, die ein Kanal akzeptiert: "Continuous", "Group", "Single" und "Hold".

  • Ein Kanal akzeptiert Triggersignale, sofern er sich NICHT im Hold-Zustand befindet.

Jeder Trigger, der empfangen wird, veranlasst den betreffenden Kanal dazu, alle vorgegebenen Messungen in diesem Kanal zu starten (sofern der Kanal sich nicht im Point-Zustand befindet). Wenn Kanal 3 beispielsweise für S21- und S22-Messungen konfiguriert ist, startet ein einziger Trigger beide Messungen. Das animierte Triggermodell zeigt, wie die "Channel Trigger State"-Einstellung den Triggersignalfluss beeinflusst.

Wenn ein Kanal die spezifizierte Anzahl von Triggern akzeptiert hat, geschieht folgendes:

  • Der Kanal geht in einen nicht-triggerbereiten Hold-Zustand über.

  • Der Kanal ignoriert nachfolgende Trigger.

"Continuous" (Standardeinstellung)

Der Kanal akzeptiert eine unbegrenzte Anzahl von Triggern.

"Group"

Der Kanal akzeptiert nur die spezifizierte Anzahl von Triggern.

"Single"

Der Kanal akzeptiert nur einen einzigen Trigger.

"Hold"

Alle Trigger werden ignoriert. Etwaige Trigger, die der Analysator empfängt, haben keinen Einfluss auf Kanäle, die sich im "Hold"-Zustand befinden. Wenn ein Kanal sich im "Hold"-Zustand befindet, erfasst er keine neuen Messdaten. (Der Bildschirm wird jedoch u. U. weiterhin aktualisiert, falls "Post-processing"-Funktionen wie z. B. "Smoothing", "Time Domain" usw. aktiv sind).

"Point"

Der betreffende Kanal wird punktweise gewobbelt. Wenn ein im Point-Zustand befindlicher Kanal einen Trigger empfängt, erfasst er den nächsten Punkt des aktuellen Wobbelzyklus. Ein im "Point"-Zustand befindlicher Kanal akzeptiert so lange Trigger, bis alle Messungen in dem betreffenden Kanal abgeschlossen sind..

Die Zustände Single und Group funktionieren bei einem Kanal, der sich außerdem im Point-Zustand befindet, anders, und zwar folgendermaßen:

  • Single: Der Kanal akzeptiert so lange Trigger, bis alle Messungen in dem betreffenden Kanal ein einziges Mal ausgeführt wurden. Ein Kanal, der beispielsweise für eine Messkurve mit 101 Datenpunkten konfiguriert ist, akzeptiert genau 101 Trigger.

  • Group: Der Kanal akzeptiert so lange Trigger, bis die spezifizierte Anzahl von Messungen in diesem Kanal ausgeführt wurde. Ein Kanal, der beispielsweise für eine Messkurve mit 101 Datenpunkten und "Group" = 3 konfiguriert ist, akzeptiert genau 303 Trigger.

Bei jedem Wobbelzyklus werden die Signale an den Eingängen A und B gemessen. Deshalb gilt folgendes:

  • S11- und S21-Messungen werden während des gleichen Wobbelzyklus durchgeführt.

  • S12- und S22-Messungen werden während des gleichen Wobbelzyklus (am entgegengesetzten Port) durchgeführt.

Das bedeutet, dass S11- und S21-Messungen (oder S12- und S22-Messungen) gleichzeitig Punkt für Punkt durchgeführt werden können, wenn der Analysator sich im Point-Zustand befindet.

Hinweis: Die Wobbeleinstellungen sind kanalabhängig. Wenn der Kanal für alternierende Wobbelung ("Alternate Sweep") konfiguriert ist, wird pro Wobbelzyklus nur das Signal an einem Eingang gemessen. Wenn der Kanal für alternierende Wobbelung konfiguriert ist, kann immer nur jeweils eine Messung Punkt für Punkt durchgeführt werden.

Hinweis: Der "Point"-Zustand ist nicht mit der "Trigger Scope"-Einstellung Global kompatibel. Wenn ein Kanal in den "Point"-Zustand gebracht wird, wird "Trigger Scope" automatisch auf "Channel" abgeändert.

Triggereinstellungen und RESTART

RESTART wird auf alle vorhandenen Kanäle angewandt. Wenn der Analysator den Befehl RESTART empfängt, bricht er die Wobbelung ab und nimmt automatisch folgende Einstellungen vor:

  • Alle Kanäle, die sich zum Zeitpunkt, da der Analysator den RESTART-Befehl empfängt, im Point-Zustand befinden, werden aus dem Point-Zustand herausgenommen.

  • Wenn ein Kanal sich im Hold-Zustand befindet, wird der "Trigger count"-Wert auf 1 zurückgesetzt. (Der betreffende Kanal akzeptiert anschließend nur noch einen einzigen Trigger).

  • Wenn ein Kanal sich im Group-Zustand befindet, bleibt der zum Zeitpunkt des RESTART-Befehls geltende "Trigger count"-Wert erhalten.

  • Wenn ein Kanal sich im Continuous-Zustand befindet, bleibt dieser Zustand erhalten; d. h. der Analysator akzeptiert eine unbegrenzte Anzahl von Triggern.

Anschließend nimmt der Analysator die Wobbelung wieder auf. Wenn als Triggerquelle Manual gewählt wurde, wird ein Einzeltrigger ausgelöst. Alle Kanäle reagieren darauf gemäß der jeweiligen "Channel Trigger State"-Einstellung. Alle Messkurven werden mindestens einmal aktualisiert.

Durch Anklicken der Schaltfläche gelangen Sie zu einer Beschreibung der Prozeduren.
Einfache Triggereinstellungen

Trigger konfigurieren

Einfache Triggereinstellungen
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Trigger.

  2. Klicken Sie auf die gewünschte Einstellung: Continuous, Single, Hold oder Restart.

Tastenprozedur

  1. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Trigger.

  2. Drücken Sie F1 für Continuous, oder

  3. Drücken Sie F2 für Single, oder

  4. Drücken Sie F3 für Hold, oder

  5. Drücken Sie F4 für Restart.

Trigger konfigurieren
Mausprozedur

Tastenprozedur

Mausprozedur

  1. Klicken Sie im Menü Sweep auf Trigger.

  2. Klicken Sie auf Trigger....

  3. Wählen Sie im Bereich Trigger Source des Dialogfensters die gewünschte Einstellung: Internal, External oder Manual.

  4. Wählen Sie im Bereich Trigger Scope des Dialogfensters die gewünschte Einstellung: Global oder Channel.

  5. Wählen Sie im Bereich Trigger State des Dialogfensters den gewünschten Kanal.

  6. Wählen Sie im Bereich Trigger State des Dialogfensters Continuous, Enable Groups, Single, Point Sweep oder Hold. Geben Sie im Falle Enable Groups auch die gewünschte Anzahl der Gruppen ein.

  7. Klicken Sie auf OK.

Tastenprozedur

  1. Drücken Sie im Tastenfeld COMMAND die Taste Menu/Dialog. Drücken Sie im Tastenfeld CHANNEL SETUP die Taste Trigger.

  2. Wählen Sie im Tastenfeld NAVIGATION durch Drücken der Pfeil-unten-Taste die gewünschte Einstellung: Internal, External oder Manual.

  3. Drücken Sie die Tab-rechts-Taste, um zum Bereich Trigger Scope des Dialogfensters zu gelangen.

  4. Wählen Sie mit der Pfeil-unten-Taste die gewünschte Einstellung: Global oder Channel.

  5. Drücken Sie die Tab-rechts-Taste, um zum Bereich Trigger State des Dialogfensters zu gelangen.

  6. Wählen Sie den gewünschten Kanal.

  7. Navigieren Sie mit der Pfeil-unten-Taste zu der gewünschten Einstellung: Continuous, Single, Hold, Point Sweep oder Enable Groups. Wählen Sie die Einstellung durch Drücken der Taste "Click". If Enable Groups is selected, enter the desired number of groups. (Die Einstellung "Point" ist nur in Verbindung mit Manual and Channel möglich).

  8. Drücken Sie im Tastenfeld COMMAND die Taste OK.


Trigger-Text

  • Das Modell reagiert auf Einstellungen etwas anders als der Analysator. Wenn Sie beispielsweise am Analysator auf die Betriebsart "Manual" umschalten, reagiert der Analysator sofort. Das Modell wartet mit der Umschaltung, bis der aktuelle Wobbelzyklus beendet ist.

  • Das Modell unterstützt keine externe Triggerung.

Animiertes Trigger-Modell

Dieses VEREINFACHTE Modell soll Ihnen helfen, die vielseitigen Triggermöglichkeiten des Analysators kennenzulernen. Es ist KEIN exaktes Modell des Analysators, allerdings sind die Unterschiede minimal.

Hinweis: Wenn ein Kanal ein Triggersignal empfängt, werden alle in dem betreffenden Kanal eingerichteten Messungen durchgeführt – zuerst werden gleichzeitig die Vorwärtsmessungen (S11,S21) durchgeführt, anschließend die Rückwärtsmessungen (S12,S22). Dies gilt NICHT in folgenden Betriebsarten:
1. "Alternate Sweep"
2. "Point trigger".

Die Trigger Source-Einstellungen bestimmen, woher das Triggersignal kommt:

Internal – Die Analysator-Firmware generiert nach Abschluss einer jeden Wobbelmessung automatisch einen Trigger.

Manual – Folgende Aktionen lösen einen Einzeltrigger aus: Betätigung der Taste "Trigger", Triggerung über die Aktuelle-Eingabe-Symbolleiste, Programmierbefehl.

External – Die Triggerung erfolgt durch ein externes Triggersignal am rückseitigen Extern-Trigger-BNC-Eingang. Die Triggerschaltung ist pegelsensitiv; der Triggerpegel (TTL HIGH oder LOW) ist wählbar.

Die Trigger Scope-Einstellungen bestimmen, was getriggert wird:

Global – Alle "triggerbaren" Kanäle empfangen den Trigger (Standardeinstellung)

Channel – Nur der nächste "triggerbare" Kanal empfängt den Trigger. (Nur in Verbindung mit "Trigger Source = MANUAL" erlaubt.)

Die Individual Channel-Einstellungen bestimmen, wieviele Trigger der betreffende Kanal akzeptiert:

Continuous – Der Kanal akzeptiert eine unbegrenzte Anzahl von Triggern

Groups – Der Kanal akzeptiert nur die spezifizierte Anzahl (= eine "Gruppe") von Triggern und geht danach in den "Hold"-Zustand über.

Single – Der Kanal akzeptiert nur einen einzigen Trigger und geht danach in den "Hold"-Zustand über.

Hold – Der Kanal akzeptiert KEINE Trigger.

Point – Bei Empfang eines Triggers führt der Kanal eine Messung bei dem nächstfolgenden Datenpunkt durch. Aufeinanderfolgende Trigger werden so lange zum gleichen Kanal geleitet, bis der letzte Datenpunkt gemessen wurde. Anschließend wird der nächste triggerbare Kanal getriggert. (Nur in Verbindung mit "Trigger Source = MANUAL" und "Trigger Scope = CHANNEL" erlaubt).

Restart – Der Analysator bricht die Wobbelung ab. (Im Gegensatz dazu bricht das Modell die Wobbelung nicht sofort ab). Die kanalspezifischen Trigger-Einstellungen sind davon folgendermaßen betroffen:

  • Bei Kanälen, die sich in der Betriebsart Point Sweep befinden, wird die Betriebsart Point Sweep deaktiviert.

  • Kanäle, die sich in der Betriebsart Hold befinden, werden in die Betriebsart Single Trigger geschaltet (der betreffende Kanal akzeptiert anschließend einen einzigen Trigger ).

Alle übrigen Einstellungen werden durch den RESTART nicht beeinflusst; auch der Triggerzähler wird nicht dekrementiert. Anschließend nimmt der Analysator die Wobbelung wieder auf.

Tachometer – Hiermit können Sie die Geschwindigkeit der Animation verändern:

Klicken Sie zum Verlangsamen auf -
Klicken Sie zum Beschleunigen auf +


TrigModel

Speedometer | Trigger Source Internal Manual
 | Trigger Scope Global Channel

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point

Continuous
Groups
Single
Hold
Point


Messdatenanalyse

Siehe auch...

Klicken Sie auf eine Schaltfläche, um nähere Informationen über die Analyse von Messdaten zu erhalten.
Verwendung der Marker

Manipulieren von Daten mit Hilfe der mathematischen Funktionen

Automatische Grenzwerttests


COM Index

Main Index

COM Index

SCPI Index


Programming Guide

Click a button to access the following Programming topics:

Command Finder

8753 Converter

COM versus SCPI

Analyzer Connectivity

Help Tips

GPIB / SCPI Only

SCPI Command Tree

Example Programs

Create a Measurement

Catalog Measurements

Setup Sweep Parameters

Setup the Display

Getting and Putting Data using GPIB

Status Reporting

ECALibrate using GPIB

Perform a Calibration

Modify a Cal Kit

GPIB Concepts

GPIB Fundamentals

The Rules and Syntax of SCPI

Getting Data from the Analyzer

Reading the Analyzer's Status Register

Understanding Command Synchronization

COM Only

Object Model - Commands

Example Programs

Getting Trace Data from the Analyzer

Limit Line Testing

Communicating with Other Applications

COM Concepts

COM Fundamentals

Getting a Handle to an Object

Collections in the Analyzer

Working with Events

Configure for COM-DCOM Programming

COM Data Types

C++ and the COM Interface


SCPI Index

Main Index

COM Index

SCPI Index


CalTopic

Perform a Calibration

SENS:CORR:COLL:METH

Set Cal Information

SENS:CORR:COLL:CKIT:SEL

Select a Cal Kit

Get a Handle to the Active Cal Kit

Simultaneous 2-Port Calibration

Acquisition Direction

SENS:CORR:COLL:ACQ

Measure a Standard

SENS:CORR:COLL:SAVE

Calculate Errors

SENS:CORR:COLL:ISOL

Isolation ON|OFF

SENS:CORR:COEF

Display an Error Term

Perform an ECAL

SENS:CORR:COLL:CKIT

Do ECAL 1-Port

SENS:CORR:COLL:CKIT

Do ECAL 2-Port

Get ECAL Module Info

Recall / Save / Apply a Calibration or Error Term

SENS:CORR:CSET

Recall a Calibration

Apply a Calibration to a measurement

SENS:CORR:CSET:SAVE

Save a Calibration

To Save or Recall an Error Term, see DATA

SENS:CORR:COLL:APPLy

Apply an Error Term after Uploading

Correction Settings

SENS:CORR:STAT

Correction ON|OFF for a measurement

SENS:CORR:INT:STAT

Interpolation ON|OFF

SENS:CORR:EXT:STAT

Extensions ON|OFF

SENS:CORR:EXT:PORT

Port 1 Extensions Value

SENS:CORR:EXT:PORT

Port 2 Extensions Value

SENS:CORR:EXT:REC

Receiver A Extensions Value

SENS:CORR:EXT:REC

Receiver B Extensions Value

SENS:CORR:RVEL:COAX

Relative Velocity

Modify Cal Kits

SENS:CORR:COLL:CKIT:SEL

Set a Cal Kit Active

Get a Handle to the Active Cal Kit

Save All Cal Kits after Modifying

Load (Recall) All Cal Kits

SENS:CORR:COLL:CKIT:SEL

Restore Cal Kit Default

Restore ALL Cal Kits Default

Build a Hybrid Cal Kit

SENS:CORR:COLL:CKIT:NAME

Set the Name of a Cal Kit

Get the Number of Cal Kit

Set the Port Label of a Cal Kit

Modify Cal Standards

SENS:CORR:COLL:CKIT:STAN:SEL

Select a Cal Standard

SENS:CORR:COLL:CKIT:ORDER

Assign a Class to a Standard

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Standard Type

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Delay

SENS:CORR:COLL:CKIT:STAN:LOSS

Set Loss

SENS:CORR:COLL:CKIT:STAN:IMP

Set Impedance

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Max Frequency

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Min Frequency

SENS:CORR:COLL:CKIT:NAME

Set Label

SENS:CORR:COLL:CKIT:STAN:TYPE

Set Medium (coax|waveguide)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.C0

Set Capacitance (C0 to C3)

SENS:CORR:COLL:CKIT:STAN:TYPE

CalStandard.L0

Set Inductance (L0 to L3)


CFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


ChanTopic

Preset

Start Freq

Stop Freq

Center Freq

Span

CW Frequency

Power Settings

Power ON | OFF

Power Value

Port Selection

Couple Ports OFF | ON

Attenuator Mode Auto|Manual

Attenuation Value

Power Slope Mode Manual | Auto

Power Slope Value

Receiver Attenuation

Averaging

Average ON|OFF

Average Count

Average Restart

Manage Channels

Add

Make Active

Read Channel Number

Read Number of Channels


Data Access Map

 Raw Measurement Data Standard Acquisition Data Calibration Error Terms Memory Measurement Results Memory Results Error Correction Trace Math Filter Gating Phase Correction Time Domain Transform Display Formatting Data Smoothing Display


DataTopic

See a map of the measurement processing chain with data access locations

Retrieve Measurement Data FROM the Analyzer

Retrieve complex data from the specified location.

Retrieve typed NAComplex data from the specified location.

Retrieve data pairs from the specified location.

Retrieve scalar data from the specified location.

Retrieve variant data from the specified location

Specifies ASCII or REAL type for data transfers

Retrieve complex or formatted data from the measurement or memory result buffer

Put Measurement Data INTO the Analyzer

Put complex data into the specified location.

Put typed NAComplex data into the specified location.

Put scalar data into the measurement result location.

Put complex Variant data into the specified location.

Put complex or formatted data into the measurement or memory result buffer

Retrieve Calibration Data FROM the Analyzer

Retrieve complex Error Term data

Retrieve variant Error Term data

Retrieve Error Term data

Retrieve complex Standard aquisition data

Retrieve variant Standard aquisition data

Put Calibration Data INTO the Analyzer

Put complex Error Term data

Put variant Error Term data

Put Error Term data

Put complex Standard aquisition data

Put variant Standard aquisition data


DFBanner

File

View

Chan

Sweep

Cal

Trace

Scale

Mark

Sys

Data

SCPI
COM

Command Finder


FileTopic

Save States (Inst | Cal | Both)

Recall States (Inst | Cal | Both)

Manage Files

List Files

Copy Files

Move Files

Delete Files

Manage Folders

Change

Delete

Make

Print

Print

Print to File


Help Tips

Functionality Help

The link in the upper right corner of most commands goes to a help topic about the analyzer function related to the command.

Copy Help

Copy this Help system to your development workstation. The file is located on your PNA hard-drive (C:\ Winnt\ Help\ PNAHelp.chm). It is also on the CDROM that shipped with the PNA.

Copy 'n Paste

Copy and Paste code from this Help system directly into your programming environment. There is paste-able code in the following places:

  • SCPI and COM Example programs.

  • List of SCPI commands at the bottom of each SCPI topic


MarkerTopic

ON|OFF

Delete All Markers

Delete Marker

Interpolate All Markers

Interpolate Individ. Marker

Type (Normal | Fixed)

Marker=> Center, Span, and so forth

Marker=> Center (Freq)

Marker=> CW Freq

Marker=> Start (Freq)

Marker=> Stop (Freq)

Marker=> Elect. Delay

Marker=> Ref. Level

Format All Markers

Format Individ. Marker

Assign Marker to Domain

Domain Range Start

Domain Range Stop

Get a handle to Ref marker

Reference Marker On | Off

Delta Marker

Read/Set Data Point number

Read/Set X-axis value

Read/Set Y-axis value

Search

Execute Search

Select Search Function

Maximum

Minimum

Target (Value)

Excursion Value

Threshold Value

Tracking

Bandwidth (Target)

Search Filter Bandwidth

Read Filter BandWidth

Read Filter Center Freq

Read Filter Loss

Read Filter Q


Refl Meas

Reflection Measurements

Reflection measurements are an important part of network analysis. This topic discusses the following:

What are Reflection Measurements?

Why Make Reflection Measurements?

Expressing Reflected Waves

Return Loss

VSWR

Reflection Coefficient

Impedance

Summary of Expressions

Accuracy Considerations

What are Reflection Measurements?

To understand reflection measurements, it is helpful to think of traveling waves along a transmission line in terms of a lightwave analogy. We can imagine incident light striking some optical component like a clear lens. Some of the light is reflected off the surface of the lens, but most of the light continues on through the lens. If the lens had mirrored surfaces, then most of the light would be reflected and little or none would be transmitted.

With RF energy, reflections occur when the impedance of two mated devices are not the same. A reflection measurement is the ratio of the reflected signal to the incident signal. Network analyzers measure the incident wave with the R (for reference) channel and the reflected wave with the A channel. Therefore, reflection is often shown as the ratio of A over R (A/R). We can completely quantify the reflection characteristics of our device under test (DUT) with the amplitude and phase information available at both the A and R channel. In S-parameter terminology, S11 is a reflection measurement of port1 of the device (the input port); S22 is a reflection measurement of the port 2 (the output port)

Why Make Reflection Measurements?

One reason we make reflection measurements to assure efficient transfer of RF power. We do this because:

  1. RF energy is not cheap. When energy is reflected, that means less energy is transmitted to where it is intended to go.

  2. If the reflected energy is large, it can damage components, like amplifiers.

For example, in the following graphic, the radio station on the left is not operating at peak efficiency. The amplifier impedance is not the same as the transmission line, and the transmission line impedance is not the same as the antenna. Both of these conditions cause high reflected power. This condition results in less transmitted power, and the high reflected power could damage the amplifier.

The radio station on the right installed properly "matched" transmission line and antenna. Very little of the transmitted signal is reflected, resulting in increased broadcast power, more listeners, more advertising revenue, and more profit. The amplifier, transmission, and antenna all need to be measured to ensure that reflected power is minimized.

Expressing Reflected Waves

After making a reflection measurement, the reflection data can be expressed in a number of ways, depending on what you are trying to learn. The various expressions are all calculated by the analyzer from the same reflection measurement data. Each method of expressing reflection data can be graphically displayed in one or more formats. For more information, see display formats.

Return Loss

The easiest way to convey reflection data is return loss. Return loss is expressed in dB, and is a scalar (amplitude only) quantity. Return loss can be thought of as the absolute value or dB that the reflected signal is below the incident signal. Return loss varies between infinity for a perfect impedance match and 0 dB for an open or short circuit, or a lossless reactance. For example, using the log magnitude format on the analyzer, the measured reflection value on the screen may be -18dB. The minus sign is ignored when expressing return loss, so the component is said to have 18dB of return loss.

VSWR

Two waves traveling in opposite directions on the same transmission line cause a "standing wave". This condition can be measured in terms of the voltage standing wave ratio (VSWR or SWR for short). VSWR is defined as the maximum reflected voltage over the minimum reflected voltage at a given frequency. VSWR is a scalar (amplitude only) quantity. VSWR varies between one for a perfect match, and infinity for an open or short circuit or lossless reactance.

Reflection Coefficient

Another way of expressing reflection measurements is reflection coefficient gamma (G). Gamma includes both magnitude and phase.

The magnitude portion of gamma is called rho (r). Reflection coefficient is the ratio of the reflected signal voltage to the incident signal voltage. The range of possible values for r is between zero and one. A transmission line terminated in its characteristic impedance will have all energy transferred to the load; zero energy will be reflected and r = 0. When a transmission line terminated in a short or open circuit, all energy is reflected and r = 1. The value of rho is unitless.

Now for the phase information. At high frequencies, where the wavelength of the signal is smaller than the length of conductors, reflections are best thought of as waves moving in the opposite direction of the incident waves. The incident and reflected waves combine to produce a single "standing" wave with voltage that varies with position along the transmission line.

  • When a transmission line is terminated in its characteristic impedance (Zo) there is no reflected signal. All of the incident signal is transferred to the load. There is energy flowing in one direction along the transmission line.

  • When a transmission line is terminated in a short circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). The voltage across any short circuit is zero volts. Therefore, the voltage of the reflected wave will be 180 degrees out of phase with the incident wave, canceling the voltage at the load.

  • When a transmission line is terminated in an open circuit termination, all of the energy is reflected back to the source. The reflected wave is equal in magnitude to the incident wave (r = 1). However, no current can flow in an open circuit. Therefore, the voltage of the reflected wave will be in phase with the voltage of the incident wave.

  • When a transmission line is terminated in a 25 ohm resistor, some but not all of the incident energy will be absorbed, and some will be reflected back towards the source. The reflected wave will have an amplitude 1/3 that of the incident wave and the voltage of the two waves will be out of phase by 180 degrees at the load. The phase relationship will change as a function of distance along the transmission line from the load. The valleys of the standing wave pattern will no longer go to zero, and the peaks will be less than that of the open / short circuit.

For more information, see Phase Measurements.

Impedance

Impedance is another way of expressing reflection data. For more information on Impedance, see Display formats / Smith Chart.

Summary of the Expressions of Reflection Measurements:

Accuracy Considerations

Reflection measurements can be made with the same setup as transmission measurements. If external attenuation is needed for gain measurements, calibrate with the attenuator in the system to remove its effects. Since reflection measurements involve loss instead of gain, power levels are lower at the receiver inputs. Therefore, it may be necessary to increase power levels for reflection measurements.

ANOTHER TAKE

The uncertainty of relection measurement is affected by directivity, source match, load match, and the reflection tracking of the test system. With a full 2-port calibration, the effects of these factors are minimized. A 1-port calibration provides the same accuracy if the output of the amplifier is well terminated. An example using the amplifier described earlier best illustrates this improvement. Total measurement uncertainty of input reutrn loss (worst case):

Response only calibration: ± 3.0 dB

Full 2-port calibration: ± 0.6 dB

Since the magnitude of the mismatch uncertainty depends on the input and output match of an amplifier, a measurement of a better matched amplifier will contain less uncertainty.

AND ANOTHER TAKE


ScaleTopic

AutoScale

AutoScale All

Per Division

Reference Level

Reference Position

Electrical Delay

Phase Offset


SweepTopic

Sweep Time Value

IF Bandwidth

Previous IF Bandwidth

Next IFBandwidth

Number of Points

Sweep Type (Lin | Pwr | CW | Seg)

Sweep Generation (Stepped | Analog)

Dwell Time Value

Alternate Sweeps

External ALC

Power Sweep

Start Power

Stop Power

Center

Span

Segment Sweep

ON|OFF

Add a segment

Delete a segment

Delete all segments

Count the segments

Read the segment number

Segment Center Frequency

Segment Frequency Span

Segment Start Frequency

Segment Stop Frequency

IF Bandwidth

IF Bandwidth Option

Source Power

Source Power Option

Trigger

Source (where trigger comes from)

Trigger Source (Int | Ext | Manual)

Internal | Manual

Trigger! (for Manual Source)

Ext. Trigger Slope (Positive | Negative)

Scope (what is triggered)

Trigger Scope (Global | Channel)

Channel Settings (how the channel responds to triggers)

Cont | Groups | Hold

Continuous

Number of Groups

Hold

Single

Trigger Mode (Point | Measurement)

Restart

Abort


SystemTopic

Quit application

Preset

Reset

Status Commands

Status Registers

*OPC;*WAI

Events

AllowAllEvents Method

AllowEventCategory Method

AllowEventMessage Method

AllowEventSeverity Method

DisallowAllEvents Method

MessageText Method

OnCalEvent

OnChannelEvent

OnDisplayEvent

OnHardwareEvent

OnMeasurementEvent

OnSCPIEvent

OnSystemEvent

OnUserEvent

SetFailOnOverRange

Macro

Execute Macro

Get Macro

Delete Macro

Put Macro


TraceTopic

Create S-Parameter Meas.

Create Measurement

Add Measurement

List Measurements

Delete a Measurement

Get a handle to a Trace

Select a Measurement

Read Channel Number

Read Number of Measurements

Read Measurement Parameter

Set / Read Measurement Name

Read Measurement Number

Change Parameter

Measurement Format

Math

Data Trace ON|OFF

Memory Trace ON|OFF

View Trace Type (Data|Memory|None)

Data =>Memory

Trace Math (Add|Sub|Mult|Div)

Smoothing

Smoothing ON|OFF

Smoothing Aperture

Smoothing Points

Statistics

Statistics ON|OFF

Statistics Range

Domain Range Start

Domain Range Stop

Set Type (Pk-Pk|StdDev|Mean)

Get All Statistics Data

Get Standard Deviation

Get Mean

Get Peak to Peak

Limit Lines

Display Lines ON|OFF

Fail Sound ON|OFF

Testing ON|OFF

Limit Test Failed

Count Limit Lines

Read Test Results

Make Limit Lines

Limit Line Type (Max|Min)

Begin Stimulus

End Stimulus

Begin Response

End Response

Transform

Transform ON|OFF

Mode (LowPass, BandPass)

Start Time

Stop Time

Center

Span

Step Rise Time

Set Low Pass Frequency

Gating

ON|OFF

Type (BandPass, Notch)

Shape

Start

Stop

Center

Span

Window

Kaiser Beta

Impulse Width


ViewTopic

Status Bar On|Off

Toolbars On|Off

Tables On|Off

Title Bars On|Off

X-axis values On|Off

Measurement Trace On|Off

Memory Trace On|Off

Title Annotation On|Off

Make a Title Annotation

Display Update ON|OFF

Window Update ON|OFF

Analyzer Visible

Add a Window

Activate a Window

Arrange Measurement Windows

Analyzer Window (Max|Min|Normal)


53 Finder

Indicates the most common of the network analyzer commands that have been mapped to a corresponding command in PNA. Since the commands listed on this page are base commands, commands that are derived from these base commands may not have a corresponding command in PNA.

Indicates a command that has not been mapped to a corresponding command in PNA, but may be in future revisions. However, this does not always indicate that the required functionality does not exist in PNA. See the 8753 Programming Guide for a description of the command functionality.

Description of Symbol Conventions

Legend

AB

ADAP1

ADDR

ADPT

ALC

ALTAB

ANAB

ANAI

AR

ASEG

ASSS

ATT

AUTO

AUXC

AVER

BACI

BANDPASS

BEEP

BLAD

BR

CAL1

CALF

CALI

CALK

CALN

CALSPORT

CALZ

CBRI

CENT

CHAN

CHOPAB

CLAD

CLASS

CLEA

CLEAL

CLEABIT

CLEASEQ

CLEL

CLES

CLS

COAD

COAX

COLO

COLOR

CONS

CONT

CONV

COPY

CORI

CORR

COU

CSWI

CWFREQ

CWTIME

D1DIVI2

D2XUPCH

D4XUPCH

DATI

DCONV

DEBU

DECRLOOC

DEFC

DEFLPRINT

DEFLTCPIO

DEFS

DEL

DELA

DEMO

DFLT

DIRS

DISC

DISM

DISP

DIVI

DONE

DONM

DOSEQ

DOWN

DUAC

DUPLSEQ

EDIT

ELED

EMIB

ENTO

ERCDONE

ESB?

ESE

ESNB

ESR?

EXTD

EXTM

EXTRCHAN

EXTT

FIXE

FORM

FORMAT

FREQ

FREQOFFS

FRER

FLUP

FWD

GATE

GATS

GOSUB

HARM

HOLD

IDN?

IF

IFBW

IMAG

INCRLOOC

INI

INPU

INSM

INT

INTE

ISO

J

KEY

KITD

KOR?

LAB

LABE

LEF

LIM

LIMI

LIMT

LINFREQ

LINM

LINT

LIS

LISTTYPE

LISV

LO

LOA

LOAD

LOADSEQ

LOGFREQ

LOGM

LOOC

LOWP

LRN

MANTRIG

MARK

MAXF

MEAS

MEASTAT

MENU

MINF

MINMAX

MINU

MODI1

MODS

NEWSEQ

NEXP

NOOP

NUMG

NUMR

OF

OFS

OMII

OPC

OPEP

OUTP

PARA

PARAL

PAUS

PCB

PCOL

PENN

PHAO

PHAS

PLOS

PLOT

PLT

PMTRTTIT

POIN

POL

PORE

PORT

PORTP

POWE

POWL

POWM

POWR

POWS

POWT

PRAN

PREP

PRES

PRI

PRIN

PRINTALL

PRN

PTOS

PURG

PWMC

PWRLOSS

PWRMCAL

PWRR

Q

RAI

RAWOFFS

READ

REAL

RECA

RECO

REF

REFT

REIC

RERCDONE

RESC

RESD

RESPDONE

REST

RETP

REV

RF

RFLP

RIG

RSCO

RST

S

SADD

SAMC

SAV

SAVE

SAVEUSEK

SAVU

SCAL

SCAP

SDEL

SDON

SEA

SEDI

SEG

SEL

SELL

SEQ

SEQWAIT

SET

SHOM

SING

SLI

SLOP

SM8

SMI

SMOO

SOFR

SOFT

SOUP

SPAN

SPEC

SPEG

SPLD

SPLID

SRE

SSEG

STAN

STAR

STB?

STDD

STDT

STEPSWP

STOP

STOR

STORSEQ

STPSIZE

SVCO

SWE

SWPSTART

SWR

TAK

TAKE4

TALKLIST

TESS?

TIMDTRAN

TIMESTAM

TINT

TIT

TITT

TRA

TRACK

TRAP

TRL

TSSWI

TST?

TSTIO

TSTP

TTL

UCONV

UP

USEPASC

USESENS

VELOFACT

VIEM

VOFF

WAIT

WAVD

WAVE

WID

WIND

WRSK


53Banner

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O

P

R

S

T

U

V

W

8753 Cross-Reference


ANotes

AB

8753 Command

Description

Range

Query Response

AB

Measures and displays A/B on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ALTAB

8753 Command

Description

Range

Query Response

ALTAB

Places the analyzer in the alternate inputs measurement mode, where A and B measurements are made on alternate sweeps. See also "CHOPAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Sets sweeps to either alternate or chopped.

PNA COM Equivalent - Notes

Sets sweeps to either alternate or chopped.

AR

8753 Command

Description

Range

Query Response

AR

Measures and displays A/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

ASEG

8753 Command

Description

Range

Query Response

ASEG

Uses all segments for list frequency sweep. See also "SSEG".

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turn on each segment to be used with list frequency sweep.

PNA COM Equivalent - Notes

LimitSegment object.

ATT

8753 Command

Description

Range

Query Response

ATTP1><num>[DB]

Selects the amount of attenuation at PORT 1.

0–70 dB

<num><LF

ATTP2><num>[DB]

Selects the amount of attenuation at PORT 2.

0–70 dB

<num><LF

Note: These commands only apply to 8753ES Option 011 analyzers.

PNA SCPI Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

PNA COM Equivalent - Notes

Step 1

Set Port Power Coupling OFF.

Step 2

Set the attenuation level for the selected port.

AUTO

8753 Command

Description

Range

Query Response

AUTO

Auto scale the active channel.

N/A

N/A

PNA SCPI Equivalent - Notes

Auto scale on the specified trace in the specified window.

PNA COM Equivalent - Notes

Auto scales the trace or all of the traces in the selected window.

AVER

8753 Command

Description

Range

Query Response

AVERREST

Restarts the averaging on the active channel.

N/A

N/A

AVERFACT<num>

Sets the averaging factor on the active channel.

integers 0–999

<num><LF

AVERO<ON|OFF>

Turns averaging on and off on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.

PNA COM Equivalent - Notes

Restart averaging.

Read-Write the averaging factor.

Read-Write averaging ON or OFF.


BNotes

BLAD

8753 Command

Description

Range

Query Response

BLAD<ON|OFF>

Blanks the display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Blanks the display information in all windows.

Blanks the display information in a specified window.

PNA COM Equivalent - Notes

Makes the Network Analyzer application visible or not visible.

BR

8753 Command

Description

Range

Query Response

BR

Measures and displays B/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.


CNotes

CALI

CALIERC

CALIRERC

CALIFUL2

CALIRAI

CALIRESP

CALIS111

CALIS221

CALITRL2

8753 Command

Description

Range

Query Response

CALIFUL2

Begins the sequence for a short, load, open, thru (SLOT) 2-port calibration.

N/A

<0|1><LF>

CALIRAI

Begins the sequence for a response and isolation calibration.

N/A

<0|1><LF>

CALIRESP

Begins the sequence for a response calibration.

N/A

<0|1><LF>

CALIS111

Begins the sequence for an S11 1-port calibration (ES models), or a reflection 1-port calibration (ET models).

N/A

<0|1><LF>

CALIS221

Begins the sequence for an S22 1-port calibration.

N/A

<0|1><LF>

CALITRL2

Begins the sequence for a thru, reflect, line or line, reflect, match (TRL*/LRM*) 2-port calibration.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

If a calibration kit is not selected, select a calibration kit.

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

CALIERC

Begins the sequence for a forward enhanced response calibration.

N/A

<0|1><LF>

CALIRERC

Begins the sequence for a reverse enhanced response calibration.

N/A

<0|1><LF>

Notes

These commands currently are not available.

CALK

8753 Command

Description

Range

Query Response

CALK24MM

Selects a 2.4-mm calibration kit (85056A/D) as the default cal kit.

N/A

<0|1>><LF

CALK292MM

Selects a 2.92-mm calibration kit as the default cal kit.

N/A

<0|1>><LF

CALK292S

Selects a 2.92* calibration kit (85056K) as the default cal kit.

N/A

<0|1>><LF

CALK35MD

Selects a 3.5-mm calibration kit (85052B/D for 8720E series analyzers, and 85033D for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALK35MC

Selects a 3.5-mm calibration kit (85033C) as the default cal kit. CALK35MM selects the 85033C cal kit for the 8752C and 8753D analyzers.

N/A

<0|1>><LF

CALK716

Selects a 7-16 calibration kit (85038) as the default cal kit.

N/A

<0|1>><LF

CALK7MM

Selects a 7-mm calibration kit (85050 series for 8720E series analyzers, and 85031B for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN50

Selects a type-N 50 ohm calibration kit (85054 for 8720E series analyzers, and 85032B/E for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN75

Selects a type-N 75 ohm calibration kit (85036B/E) as the default cal kit.

N/A

<0|1>><LF

CALKTRLK

Selects a TRL 3.5-mm calibration kit (85052C) as the default cal kit.

N/A

<0|1>><LF

CALKUSED

Selects a user-defined calibration kit.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Select the appropriate calibration kit. If the specific calibration kit is not listed, one can be created and stored in the User Defined section.

3 = CALKN50

4 = CALK35MD

5 = CALK716

6 = CALKTRLK

PNA COM Equivalent - Notes

Specifies the type of calibration kit to use in the calibration process.

CALN

8753 Command

Description

Range

Query Response

CALN

Turns calibration type to "off." See also "CORR."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the calibration method. Set to "NONE" to turn calibration off.

PNA COM Equivalent - Notes

Specifies and returns the type of calibration to be applied to the measurement. Set to "NONE" to turn calibration off.

CENT

8753 Command

Description

Range

Query Response

CENT<num>[HZ|DB]

Sets the center stimulus value. If a list frequency segment is being edited, sets the center of the list segment.

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To set the center frequency value.

To set the center frequency value for a segment.

PNA COM Equivalent - Notes

Read-Write the center frequency of all measurements in a channel or for a specified sweep segment.

CHAN

8753 Command

Description

Range

Query Response

CHAN1

Makes channel 1 the active channel. OPC-compatible.

N/A

N/A

CHAN2

Makes channel 2 the active channel. OPC-compatible.

N/A

N/A

CHAN3

Makes channel 3 the active channel. OPC-compatible.

N/A

N/A

CHAN4

Makes channel 4 the active channel. OPC-compatible.

N/A

N/A

Notes

Unlike the 8753 network analyzer, the PNA Series Network Analyzers do not need a separate channel to display each parameter. While the PNA Series has four independent measurement channels, only one channel is needed to display all four measurement parameters. In addition, up to four windows are available to view four active and four memory traces per window.

CHOPAB

8753 Command

Description

Range

Query Response

CHOPAB

Places the analyzer in the chop measurement mode. See also "ALTAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

PNA COM Equivalent - Notes

Read-Write the sweep mode as Chopped or Alternate.

CLASS

8753 Command

Description

Range

Query Response

CLASS11A

S11A: S11 (forward reflection) 1-port, open

N/A

N/A

CLASS11B

S11B: S11 (forward reflection) 1-port, short

N/A

N/A

CLASS11C

S11C: S11 (forward reflection) 1-port, load

N/A

N/A

CLASS22A

S22A: S22 (reverse reflection) 1-port, open

N/A

N/A

CLASS22B

S22B: S22 (reverse reflection) 1-port, short

N/A

N/A

CLASS22C

S22C: S22 (reverse reflection) 1-port, load

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

CLEAL

8753 Command

Description

Range

Query Response

CLEAL

Clears the limit line list. Should be preceded by EDITLIML.

N/A

N/A

PNA SCPI Equivalent - Notes

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF or make a new limit line.

PNA COM Equivalent - Notes

Delete the limit test collection.

CLEL

8753 Command

Description

Range

Query Response

CLEL

Clears the currently selected list. This could be a frequency list, power loss list, or limit test list. Must be preceded by an "EDIT" command.

N/A

N/A

PNA SCPI Equivalent - Notes

Clear a single sweep segment.

Clear all sweep segments.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

CLES

8753 Command

Description

Range

Query Response

CLES

Clears the status byte register, the event-status registers, and the enable registers. Same as CLS.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers.

PNA COM Equivalent - Notes

No equivalent command at present.

CLS

8753 Command

Description

Range

Query Response

CLS

Clears the status byte register, the event-status registers, and the enable registers. Same as CLES.

N/A

N/A

PNA SCPI Equivalent - Notes

Clears the instrument status byte by emptying the error queue and clearing all event registers. Replace "CLS" with "*CLS".

PNA COM Equivalent - Notes

No equivalent command at present.

CONT

8753 Command

Description

Range

Query Response

CONT

Places the analyzer in continuous sweep trigger mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

CORI

8753 Command

Description

Range

Query Response

CORI<ON|OFF>

Turns interpolative error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write correction interpolation ON or OFF.

PNA COM Equivalent - Notes

No equivalent command at present.

CORR

8753 Command

Description

Range

Query Response

CORR<ON|OFF>

Turns error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether or not correction data is applied to the measurement.

PNA COM Equivalent - Notes

Sets (or returns) error correction ON or OFF

CWFREQ

8753 Command

Description

Range

Query Response

CWFREQ<num>[HZ|DB]

Sets the CW frequency for power sweep and CW frequency modes. While the list frequency table segment is being edited, it sets the center frequency of the current segment. See also "MARKCENT."

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in the analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Continuous Wave (or Fixed) frequency.

PNA COM Equivalent - Notes

CW Frequency property.

CWTIME

8753 Command

Description

Range

Query Response

CWTIME

Selects CW time as the sweep type.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.


DENotes

DATI

8753 Command

Description

Range

Query Response

DATI

Stores the data trace in channel memory. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only the currently selected measurement trace into memory.

PNA COM Equivalent - Notes

Stores the active measurement into memory.

DEL

8753 Command

Description

Range

Query Response

DELO

Turns delta marker mode off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether marker is relative to the reference or not.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

DELR<num>

Makes the indicated marker the delta reference.

Integers 15

<0|1>><LF

DELRFIXM

Makes the fixed marker the delta reference.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If the reference marker is not turned ON, use this command to set the reference marker to ON.

Step 2

Set the reference marker to the correct position.

Step 3

Turn marker delta mode ON for the marker that will report the delta value measured from the reference marker.

PNA COM Equivalent - Notes

No equivalent command at present.

DELA

8753 Command

Description

Range

Query Response

DELA

Displays the data formatted as group delay.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

DISP

8753 Command

Description

Range

Query Response

DISPDATA

Data only.

N/A

<0|1>><LF

DISPDATM

Data and memory.

N/A

<0|1>><LF

DISPDDM

Data divided by memory (linear division, log subtraction). See also "DIVI."

N/A

<0|1>><LF

DISPDMM

Data minus memory (linear subtraction). See also "MINU."

N/A

<0|1>><LF

DISPMEMO

Memory only.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DIVI

8753 Command

Description

Range

Query Response

DIVI

Data divided by memory (linear division, log subtraction). See also "DISPDDM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.

DONE

8753 Command

Description

Range

Query Response

DONE

Done with a class of standards, during a calibration. Only needed when multiple standards are measured to complete the class.

N/A

N/A

Notes

Since this action is performed automatically in PNA, this command is no longer necessary.

EDIT

8753 Command

Description

Range

Query Response

EDITDONE

Done editing list frequency, limit table, cal sensor table, or power loss list.

N/A

N/A

EDITLIML

Begins editing limit table.

N/A

N/A

EDITLIST

Begins editing list frequency table.

N/A

N/A

Notes

Since these actions are performed automatically in PNA when working with a limit table, these commands are no longer necessary.

ELED

8753 Command

Description

Range

Query Response

ELED<num>[S]

Sets the electrical delay offset.

±10 seconds

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the electrical delay for the selected measurement.

PNA COM Equivalent - Notes

Sets the Electrical Delay

ESE

8753 Command

Description

Range

Query Response

ESE<num>

Enables the selected event-status register bits to be summarized by bit 5 in the status byte. An event-status register bit is enabled when the corresponding bit in the operand <num> is set.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Sets bits in the standard event status enable register. Replace "ESE" with "*ESE".

PNA COM Equivalent - Notes

No equivalent command at present.

ESR?

8753 Command

Description

Range

Query Response

ESR?

Query only. Outputs event-status register.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Returns the results of the standard event enable register. The register is cleared after reading it. Replace "ESR?" with "*ESR?".

PNA COM Equivalent - Notes

No equivalent command at present.

EXTM

8753 Command

Description

Range

Query Response

EXTMDATA

Adds error corrected data (real and imaginary pairs) along with the other files.

N/A

<0|1>><LF

EXTMDATO

Selected data arrays only (real and imaginary pairs), without instrument states or calibrations. Always saves the data array, even if it hasnt been selected.

N/A

<0|1>><LF

EXTMFORM

Formatted trace data. Uses currently selected format for data.

N/A

<0|1>><LF

EXTMRAW

Raw data arrays (real and imaginary pairs).

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data.

PNA COM Equivalent - Notes

Retrieves data.

8753 Command

Description

Range

Query Response

EXTMGRAP

User graphics.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Saves the screen data to bitmap (.bmp) file of the screen.

EXTT

8753 Command

Description

Range

Query Response

EXTT

Activates or deactivates the external trigger mode. OPC-compatible.

N/A

<0|1>><LF

EXTTPOIN

Sets the external trigger to auto-trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the source of the sweep trigger signal.

Read-Write whether the specified channel will measure one point when triggered or all of the measurements in the channel.

PNA COM Equivalent - Notes

Sets or returns the trigger source.

Determines the measurement that occurs when a trigger signal is sent to the channel.

8753 Command

Description

Range

Query Response

EXTTHIGH

Sets the external trigger line high.

N/A

N/A

EXTTLOW

Sets the external trigger line low.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

No equivalent command at present.


FGHNotes

FORM

8753 Command

Description

Range

Query Response

FORM1

The analyzer's internal binary format, 6 bytes-per-data point. The array is preceded by a four-byte header. The first two bytes represent the string "#A", the standard block header. The second two bytes are an integer representing the number of bytes in the block to follow. FORM1 is best applied when rapid data transfers, not to be modified by the computer nor interpreted by the user, are required.

N/A

N/A

FORM2

IEEE 32-bit floating-point format, 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 8-bit biased exponent, and a 23-bit mantissa. FORM2 is the format of choice if your computer is not a PC, but supports single-precision floating-point numbers.

N/A

N/A

FORM3

IEEE 64-bit floating-point format, 8 bytes-per-number, 16 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 11-bit biased exponent, and a 52-bit mantissa. This format may be used with double-precision floating-point numbers. No additional precision is available in the analyzer data, but FORM3 may be a convenient form for transferring data to your computer.

N/A

N/A

FORM4

ASCII floating-point format. The data is transmitted as ASCII numbers. There is no header. The analyzer always uses FORM4 to transfer data that is not related to array transfers (i.e. marker responses and instrument settings). Data is comma delimited.

N/A

N/A

FORM5

PC-DOS 32-bit floating-point format with 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. The byte order is reversed with respect to FORM2 to comply with PC-DOS formats. If you are using a PC-based controller, FORM5 is the most effective format to use.

N/A

N/A

PNA SCPI Equivalent - Notes

FORM1, the 8753 analyzer's internal binary format, is not compatible with PNA.

For FORM2, FORM3, and FORM4, use this SCPI command.

Step 1

For FORM5, format the data to 32-bit with the SCPI command in Step 1. Then, swap the bits with the SCPI command in Step 2.

Step 2

PNA COM Equivalent - Notes

No equivalent command at present.

FRER

8753 Command

Description

Range

Query Response

FRER

Places the analyzer in GPIB free run mode. (Same as continuous sweep trigger mode.) See "CONT."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Read-Write the sweep triggering mode.

FWD

8753 Command

Description

Range

Query Response

FWDI

Selects the forward isolation calibration class during a 2-port calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Measure the specified standard from the selected calibration kit. See "STAN5".

PNA COM Equivalent - Notes

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

FWDM

Selects the forward match calibration class during a 2-port calibration sequence.

N/A

N/A

FWDT

Selects the forward transmission calibration class during a 2-port calibration sequence.

N/A

N/A

Notes

Both the forward match and the forward transmission are measured automatically during a 2-port calibration on the PNA Series Network Analyzers.

HOLD

8753 Command

Description

Range

Query Response

HOLD

Puts the sweep trigger into hold mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the sweep triggering mode. Set the sweep trigger mode to "OFF".

PNA COM Equivalent - Notes

Put the sweep trigger into hold mode.


INotes

IDN?

8753 Command

Description

Range

Query Response

IDN?

Query only. Outputs the identification string: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument.

N/A

See command description.

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer. Replace "IDN?" with "*IDN?".

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

IFBW

8753 Command

Description

Range

Query Response

IFBW<num>[HZ]

Sets the IF bandwidth.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the bandwidth of the digital IF filter to be used in the measurement.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.

IMAG

8753 Command

Description

Range

Query Response

IMAG

Selects the imaginary display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

INPU

INPUCALC

INPUCALK

INPUDATA

INPUFORM

INPULEAS

INPUPMCAL1

INPUPMCAL2

INPURAW1

INPURAW2

INPURAW3

INPURAW4

8753 Command

Description

Range

Query Response

INPUDATA

Inputs an error corrected data array, using the current setting of the FORM command.

N/A

N/A

INPUFORM

Inputs a formatted data array, using the current setting of the FORM command.

N/A

N/A

INPURAW1

Inputs raw data array 1 (S11 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW2

Inputs raw data array 2 (S21 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW3

Inputs raw data array 3 (S12 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW4

Inputs raw data array 4 (S22 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Input the data array.

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

PNA COM Equivalent - Notes

Step 1a

Input raw data.

Step 1b

Input formatted data

Step 2

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

8753 Command

Description

Range

Query Response

INPUCALC<num><array>

Inputs an error coefficient array <num>.

Two-digit integers 01–12

N/A

INPUCALK<array>

Inputs a cal kit array in FORM1 only. Can be read out with the OUTCALK command. After the transfer, the data should be saved into the user cal kit area with the SAVEUSEK command.

N/A

N/A

INPULEAS<learnstring>

Inputs a learn string in FORM1 only. Can be read out with the OUTPLEAS command, or with INPULEAS?.

N/A

<data><LF >

INPUPMCAL1<array>

Inputs power meter calibration arrays for channel 1 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

INPUPMCAL2<array>

Inputs power meter calibration arrays for channel 2 into the analyzer in FORM4 only. Values should be entered as 100 ´ power meter reading in dB.

N/A

N/A

Notes

These commands currently are not available.


LNotes

LIM

8753 Command

Description

Range

Query Response

LIMS

Sets the limit stimulus break point.

Stimulus range.

Currently this command can be queried by sending the command by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the start (beginning) of the X-axis stimulus value.

Read-Write the stop (end) of the X-axis stimulus value.

PNA COM Equivalent - Notes

Specifies the beginning X-axis value of the Limit Line.

Specifies the end X-axis value of the Limit Line.

8753 Command

Description

Range

Query Response

LIMD

Sets the limit delta value while editing a limit line segment.

Amplitude range.

Currently this command can be queried by sending the command by the OUTPACTI command.

LIML

Sets the lower limit value.

Amplitude range.

Same as above.

LIMM

Sets the middle limit value.

Amplitude range.

Same as above.

LIMU

Sets the upper limit value.

Amplitude range.

Same as above.

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LIMI

LIMIAMPO

LIMILINE

LIMIMAOF

LIMISTIO

LIMITEST

8753 Command

Description

Range

Query Response

LIMILINE<ON|OFF>

Turns the display of the limit lines on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display of limit lines ON or OFF.

PNA COM Equivalent - Notes

Turns the display of limit lines ON or OFF.

8753 Command

Description

Range

Query Response

LIMITEST<ON|OFF>

Turns limit testing on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write limit line testing ON or OFF.

PNA COM Equivalent - Notes

Turns an object ON and OFF.

8753 Command

Description

Range

Query Response

LIMIAMPO<num>[HZ|DB]

Enters the limit line amplitude offset.

Amplitude range.

<num>><LF

LIMIMAOF

Marker to limit offset. Centers the limit lines about the current marker position using the limit amplitude offset function.

N/A

N/A

LIMISTIO<num>[HZ|DB]

Enters the stimulus offset of the limit lines.

Stimulus range.

<num>><LF

Notes

These commands currently are not available.

LIMT

8753 Command

Description

Range

Query Response

LIMTFL

Makes the segment a flat line.

N/A

<0|1>><LF

LIMTSL

Makes the segment a sloping line.

N/A

<0|1>><LF

LIMTSP

Makes the segment a single point.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write data for limit lines.

PNA COM Equivalent - Notes

Make a limit line object.

LINFREQ

8753 Command

Description

Range

Query Response

LINFREQ

Selects a linear frequency sweep.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

LINM

8753 Command

Description

Range

Query Response

LINM

Selects the linear magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

LIS

LISFREQ

LISIFBWM

LISPWRM

8753 Command

Description

Range

Query Response

LISFREQ

Selects the list frequency sweep mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the sweep type.

PNA COM Equivalent - Notes

Selects the sweep type.

8753 Command

Description

Range

Query Response

LISIFBWM<ON|OFF>

Enables/disables the IFBW setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether the IF Bandwidth resolution can be set independently for each segment.

Read-Write the IFBandwidth for the specified segment.

PNA COM Equivalent - Notes

Enables the IFBandwidth to be set on individual sweep segments.

Sets or returns the IF Bandwidth of the segment.

8753 Command

Description

Range

Query Response

LISPWRM<ON|OFF>

Enables/disables the power setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write whether Power Level can be set independently for each segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Enables the source power to be set on individual sweep segments.

Sets or returns the RF power level of the segment.

LISTTYPE

8753 Command

Description

Range

Query Response

LISTTYPELSTP

Selects the stepped list mode for use with a list-frequency table.

N/A

<0|1><LF>

LISTTYPELSWP

Selects the swept list mode for use with a list-frequency table.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Read-Write sweep as Stepped or Analog.

PNA COM Equivalent - Notes

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

LOAD

8753 Command

Description

Range

Query Response

LOAD<num>

Loads the file from disk using the file name provided by the preceding TITF<num>; command. The actual file loaded depends on the file title in the file position specified by the TITF<num> command. Requires pass control mode when using the GPIB port.

integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to load the specified file.

PNA COM Equivalent - Notes

Recalls a measurement state, calibration state, or both.

LOGM

8753 Command

Description

Range

Query Response

LOGM

Selects the log magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


MNotes

MANTRIG

8753 Command

Description

Range

Query Response

MANTRIG

Sets the trigger mode to manual trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

PNA COM Equivalent - Notes

Step 1

Set the trigger source to manual.

Step 2

Set the trigger mode to point.

MARK

MARK<1|2|3|4|5> | MARKMAXI
MARKBUCK | MARKMIDD
MARKCENT | MARKMINI
MARKCONT | MARKOFF
MARKCOUP | MARKREF
MARKCW | MARKSPAN
MARKDELA | MARKSTAR
MARKDISC | MARKSTIM
MARKFAUV | MARKSTOP
MARKFSTI | MARKUNCO
MARKFVAL | MARKZERO

8753 Command

Description

Range

Query Response

MARK<1|2|3|4|5><num>

Makes the selected marker active and sets its stimulus value.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Set the specified marker ON. Note: CALCulate commands act on the selected measurement. You must have a measurement defined and selected before a marker can be turned on. To define a measurement use CALCulate<cnum>:PARameter:DEFine <Mname>,<param>. Select the measurement for each channel using CALCulate<cnum>:PARameter:SELect <Mname>.

Step 2

Set the marker's X-axis value (frequency, power, or time).

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKBUCK<num>

Places the active marker on a specific sweep point (bucket). <num> is the bucket number.

0 to (number-of-points - 1). For example, on a 201 point sweep, <num> can range from 0 to 200.

<num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Sets or returns the bucket number (data point) for the active marker.

8753 Command

Description

Range

Query Response

MARKCENT

Sets the center stimulus value to that of the active marker's stimulus value.

N/A

N/A

MARKSTAR

Sets the start stimulus to that of the active marker's.

N/A

N/A

MARKSTOP

Sets the stop stimulus to that of the active marker's.

N/A

N/A

MARKREF

Sets the reference value to that of the active marker's amplitude.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the selected instrument setting to assume the value of the specified marker.

PNA COM Equivalent - Notes

Changes the analyzer's center frequency to the X-axis position of the marker. The start frequency stays the same and the stop frequency adjusts.

Changes the analyzer's start frequency to the X-axis position of the marker. The stop frequency stays the same and the frequency span adjusts.

Changes the analyzer's stop frequency to the X-axis position of the marker. The start frequency stays the same and the frequency span adjusts.

Changes the measurement's reference level to the marker's Y-axis value.

8753 Command

Description

Range

Query Response

MARKDELA

Sets electrical length so group delay is zero at the active marker's stimulus.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the measurement's electrical delay value to the marker's delay value.

8753 Command

Description

Range

Query Response

MARKMAXI

Search for trace maximum on the current channel. Same as SEAMAX.

N/A

<0|1>><LF

MARKMINI

Search for trace minimum on the current channel. Same as SEAMIN.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1

If a marker is not currently turned ON, set marker to ON with this command.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

MARKCONT

Places the markers continuously on the trace, not on discrete points (interpolates the marker values between discrete points).

N/A

<0|1>><LF

MARKDISC

Places the markers on the discrete measurement points.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the specified marker as either interpolate data or not.

PNA COM Equivalent - Notes

Turns All Marker Interpolation ON and OFF for the measurement.

8753 Command

Description

Range

Query Response

MARKOFF

Turns all markers and marker functions off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Write-only all markers off for selected measurement.

PNA COM Equivalent - Notes

Turn markers OFF by deleting all of the markers from the measurement.

8753 Command

Description

Range

Query Response

MARKCW

Sets the CW frequency to the active marker's frequency.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

8753 Command

Description

Range

Query Response

MARKFSTI<num>

Sets the stimulus position of the fixed marker.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

If the marker is not turned ON, set the marker ON.

Step 2

Set the marker type to "Fixed".

Step 3

Set the position of the marker.

PNA COM Equivalent - Notes

Step 1

Sets and reads the marker type.

Step 2

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKMIDD

Makes the marker amplitude the limit segment middle value during a limit segment edit.

N/A

N/A

MARKSPAN

Sets the span for the entire trace to that of the span between the active marker and the delta reference marker.

N/A

N/A

MARKSTIM

During a limit segment edit, sets the limit stimulus break point to that of the active marker's.

N/A

N/A

MARKZERO

Places the fixed marker at the active marker position and makes it the delta reference.

N/A

N/A

Notes

These functions require multiple SCPI or COM commands along with appropriate math calculations.

8753 Command

Description

Range

Query Response

MARKCOUP

Couples the markers between the channels, as opposed to MARKUNCO.

N/A

<0|1>><LF

MARKUNCO

Uncouples the markers between channels, as opposed to MARKCOUP.

N/A

<0|1>><LF

MARKFAUV

Sets the auxiliary value of the fixed marker position. Works in coordination with MARKFVAL and MARKFSTI.

Amplitude range. Same as MARKFVAL.

<num><LF

MARKFVAL

Sets the value of the fixed marker position.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

Notes

These commands are currently not supported.

MEAS

8753 Command

Description

Range

Query Response

MEASA

Measures and displays input A on the active channel.

N/A

<0|1>><LF

MEASB

Measures and displays input B on the active channel.

N/A

<0|1>><LF

MEASR

Measures and displays input R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

MEASTAT

8753 Command

Description

Range

Query Response

MEASTAT<ON|OFF>

Turns trace statistics on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

MINMAX

8753 Command

Description

Range

Query Response

MINMAX<ON|OFF>

Enables/disables min/max recording per segment. Min and max values are recorded per limit segment. Limit testing need not be active.

N/A

<0|1>><LF

Notes

This command is not available on PNA.

MINU

8753 Command

Description

Range

Query Response

MINU

Data minus memory (linear subtraction). See also "DISPDMM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Performs math operations on the measurement object and the trace stored in memory.


NONotes

NUMG

8753 Command

Description

Range

Query Response

NUMG<num>

Activates the indicated number of groups of sweeps. A group is whatever is needed to update the current parameter once. This function restarts averaging if it is enabled. OPC-compatible.

Integers 1999.

N/A

PNA SCPI Equivalent - Notes

Step 1

Set the number of groups.

Step 2

Set the trigger mode to groups.

PNA COM Equivalent - Notes

No equivalent command at present.

OMII

8753 Command

Description

Range

Query Response

OMII

Omits the isolation step of a calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write isolation cal ON or OFF during Full 2-port calibration.

PNA COM Equivalent - Notes

No equivalent command at present.

OPC

8753 Command

Description

Range

Query Response

OPC

Operation complete. Reports the completion of the next command received by setting bit 0 in the event-status register, or by replying to an interrogation if OPC? is issued.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Operation complete command. Replace "OPC" with "*OPC".

Operation complete query. Replace "OPC?" with "*OPC?".

PNA COM Equivalent - Notes

No equivalent command at present.

OUTP

OUTPACTI | OUTPFAIP | OUTPMARK | OUTPRAF
OUTPAMAX | OUTPFORE | OUTPMEMF | OUTPRAW
OUTPAMIN | OUTPFORM | OUTPMEMO | OUTPRFFR
OUTPAPER | OUTPICAL | OUTPMSTA | OUTPSEGAF
OUTPCALC | OUTPIDEN | OUTPMWID | OUTPSEGAM
OUTPCALK | OUTPIPMCL | OUTPMWIL | OUTPSEGF
OUTPCHAN | OUTPKEY | OUTPOPTS | OUTPSEGM
OUTPDATA | OUTPLEAS | OUTPPLOT | OUTPSEQ
OUTPDATF | OUTPLIM | OUTPPMCAL | OUTPSERN
OUTPDATP | OUTPLIMF | OUTPPRE | OUTPSTAT
OUTPDATR | OUTPLIML | OUTPPRIN | OUTPTITL
OUTPERRO | OUTPLIMM | OUTPPRNALL |

8753 Command

Description

Range

Query Response

OUTPAPER

Outputs the smoothing aperture in stimulus units, rather than as a percentage.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

PNA COM Equivalent - Notes

Step 1

Output the smoothing aperture.

Step 2

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

8753 Command

Description

Range

Query Response

OUTPCALC

Outputs the selected error coefficient array for the active cal on the active channel.

Two-digit integers 0112

<array><LF

PNA SCPI Equivalent - Notes

Output the error coefficient array.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPCALK

Outputs the currently active calibration kit, as a string of less than 1000 bytes. The data is in FORM1.

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Read-Write a name for the selected calibration kit.

PNA COM Equivalent - Notes

Sets and Returns a name for the selected calibration kit.

8753 Command

Description

Range

Query Response

OUTPDATA

Outputs the error-corrected data from the active channel in real/imaginary pairs.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the error-corrected data array.

PNA COM Equivalent - Notes

Output the error-corrected data array.

8753 Command

Description

Range

Query Response

OUTPFORM

Outputs the formatted display data array from the active channel, in current display units.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPIDEN

Outputs the identification string for the analyzer in the form: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument. (Same as the "IDN?" command.)

N/A

<$><LF >

PNA SCPI Equivalent - Notes

Returns a string that uniquely identifies the analyzer.

PNA COM Equivalent - Notes

Returns the name of the Analyzer making measurements on the channel.

8753 Command

Description

Range

Query Response

OUTPLIM

Outputs the status of the limit test for the channel selected with <num>.

Integers 14

<0|1|-1><LF

PNA SCPI Equivalent - Notes

Check status bit to determine status of the limit test.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPLIML

Outputs the limit test results for each point in the sweep. This is an ASCII transfer.

N/A

<array><LF

OUTPLIMM

Outputs the limit test results at the active marker.

N/A

<num,num,num,num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Returns the result of limit line testing.

8753 Command

Description

Range

Query Response

OUTPMARK

Outputs the active marker values. The first two numbers are the marker response values, and the last is the stimulus value.

N/A

<num,num,num><LF >

PNA SCPI Equivalent - Notes

Read-Write the marker's X-axis value (frequency, power, or time).

Read-only the marker's Y-axis value.

PNA COM Equivalent - Notes

Sets and reads the X-Axis value of the marker.

Reads the Y-Axis value of the marker.

8753 Command

Description

Range

Query Response

OUTPMEMO

Outputs the memory trace from the active channel. The data is in real/imaginary pairs, and can be treated the same as data read with the OUTPDATA command.

N/A

<array><LF

PNA SCPI Equivalent - Notes

Read-Write either measurement data or memory data. When querying memory, you must first store a trace into memory using CALCuate<cnum>:MATH:MEMorize

PNA COM Equivalent - Notes

If the data is not in memory, store data into memory.

Output memory data.

8753 Command

Description

Range

Query Response

OUTPMSTA

Outputs the marker statistics in ASCII format: mean, standard deviation, and peak-to-peak variation in that order. If statistics is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num><LF

PNA SCPI Equivalent - Notes

Step 1

Select the statistic TYPE that you can then query.

Step 2

Read the selected trace statistic.

PNA COM Equivalent - Notes

Returns the Trace Statistics.

8753 Command

Description

Range

Query Response

OUTPMWID

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, and Q in that order. If widths is not on, it is turned on to generate current values and then turned off again.

N/A

<num,num,num><LF>

OUTPMWIL

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, Q, and loss in that order. If widths is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num,num><LF>

PNA SCPI Equivalent - Notes

Use command to set and return filter statistics.

PNA COM Equivalent - Notes

Returns the Filter Statistics resulting from a SearchFilterBandwidth method.

8753 Command

Description

Range

Query Response

OUTPOPTS

Outputs an ASCII string of the options installed in the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Returns a string identifying the analyzer option configuration.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPPRIN

Outputs a PCL raster dump of the display, intended for a graphics printer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

8753 Command

Description

Range

Query Response

OUTPRAW

Outputs the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

PNA SCPI Equivalent - Notes

Output the data array.

PNA COM Equivalent - Notes

Output the data array.

8753 Command

Description

Range

Query Response

OUTPSERN

Outputs a string that contains the serial number of the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Output the serial number.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPSTAT

Returns the status byte as an ASCII integer (0255) that can be interpreted as the 8-bit status byte. This command is the same as "STB?."

N/A

<num><LF

PNA SCPI Equivalent - Notes

Reads the value of the instrument status byte.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPTITL

Outputs the display title in ASCII format.

N/A

<$><LF

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

OUTPDATF

Fast data transfer command for OUTPDATA.

N/A

<array><LF

OUTPFORE

Fast data transfer command for OUTPFORM.

N/A

<array><LF

OUTPMEMF

Fast data transfer command for OUTPMEMO.

N/A

<array><LF

OUTPRAF<num>

Fast data transfer of the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

Notes

The PNA Series Network Analyzer outputs data at the fastest possible data rate at all times. Therefore, there are not any commands in the PNA Series that correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPACTI

Outputs the value of the active function, or the last active function if the active entry area is off. The value is returned in ASCII format.

N/A

<$><LF>

OUTPCHAN

Outputs the active channel number: 1, 2, 3, or 4.

N/A

<num><LF

OUTPDATP

Outputs the trace data indexed by point (see "SELPT").

N/A

<num,num><LF

OUTPDATR

Outputs the trace data for a range of points (see "SELMINPT," "SELMAXPT"). This is an ASCII (FORM4) transfer.

N/A

<array><LF

Notes

The PNA Series Network Analyzer has features to output data and state information much different than earlier network analyzers. Therefore, there are not any commands in the PNA Series that directly correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPAMAX

Outputs the max values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPAMIN

Outputs the min values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPLIMF

Outputs the limit test results for each failed point, followed by the number of failed points. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAF

Outputs the segment number and its limit test status for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAM

Outputs the limit test min/max for all segments. Outputs the segment number, max stimulus, max value, min stimulus, min value for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGF

Outputs the limit test status for a specified segment. See also "SELSEG."

N/A

<0|1|-1><L F> Values returned for limit test status are: 0 (fail), 1 (pass), or -1 (no limit).

OUTPSEGM

Outputs limit test min/max for a specified segment. See also "SELSEG."

N/A

<num,num><LF

Notes

These limit and segment commands currently are not available.

8753 Command

Description

Range

Query Response

OUTPERRO

Outputs the oldest error message in the error queue. Sends the error number first, and then the error message itself, as an ASCII (FORM4) string no longer than 50 characters.

N/A

<num,$><LF

OUTPFAIP

This command is similar to OUTPLIMF except that it reports the number of failures first, followed by the stimulus and trace values for each failed point in the test. ASCII format.

N/A

<array><LF

OUTPICAL

Outputs the selected interpolated error coefficient array for the active cal on the active channel.

Two-digit integers 0112.

<array><LF

OUTPIPMCL

Outputs the interpolated power meter calibration array for channel 1 or channel 2. Values are returned as 100 times the interpolated power meter reading in dB. This is an ASCII transfer (FORM4).

Integers 1 or 2.

<array><LF

OUTPKEY

Outputs the key code of the last key pressed in ASCII format. An invalid key is reported with a 63, a knob turn with a -1. See programming manual for additional information.

N/A

<num><LF

OUTPLEAS

Outputs the learn string, which contains the entire front panel state, the limit table, and the list frequency table. It is always in binary format not intended for decoding.

N/A

<learnstring><LF

OUTPPLOT

Outputs the HP-GL plot string in ASCII format to the GPIB port. Can be directed to a plotter, or read into the computer.

N/A

<$><LF>

OUTPPMCAL

Outputs the power meter calibration array for channel 1 or channel 2. See programming manual for additional information.

Integers 1 or 2.

<array><LF

OUTPPRE

Outputs pre-raw data array <num>. See programming manual for additional information.

integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

OUTPPRNALL

Outputs all of the list values or the current page of operating parameters in ASCII format. See programming manual for additional information.

N/A

Rows of data separated by a <LF>. Ends with <LF><LF>.

OUTPRFFR

Outputs the external source RF frequency. The instrument must be in external source mode, using either INSMEXSA or INSMEXSM.

N/A

<num><LF

OUTPSEQ

Outputs the specified sequence listing to the GPIB port.

Integers 16.

<$><LF>

Notes

These commands currently are not available.


PNotes

PHAO

8753 Command

Description

Range

Query Response

PHAO<num>

Sets the phase offset.

0360 degrees

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the phase offset for the selected measurement.

PNA COM Equivalent - Notes

Sets the Phase Offset.

PHAS

8753 Command

Description

Range

Query Response

PHAS

Selects the phase display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

POIN

8753 Command

Description

Range

Query Response

POIN<num>

Sets the number of points in the sweep, or in a sweep segment.

Choose from: 3, 11, 21, 26, 51, 101, 201, 401, 801, 1601

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the number of data points for the measurement.

PNA COM Equivalent - Notes

Sets or returns the Number of Points.

POL

8753 Command

Description

Range

Query Response

POLA

Selects the polar display format.

N/A

<0|1>><LF

POLMLIN

Selects linear as the marker readout format for polar display.

N/A

<0|1>><LF

POLMLOG

Selects log as the marker readout format for polar display.

N/A

<0|1>><LF

POLMRI

Selects real/imaginary as the marker readout format for polar display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the polar display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the polar display format.

Selects the appropriate marker readout format.

PORE

8753 Command

Description

Range

Query Response

PORE<ON|OFF>

Turns port extensions on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write port extensions ON or OFF.

PNA COM Equivalent - Notes

Turns port extensions ON or OFF.

PORT

8753 Command

Description

Range

Query Response

PORT1<num>[S]

Set the port extension length for Port 1

±10 seconds

<0|1>><LF

PORT2<num>[S]

Set the port extension length for Port 2

±10 seconds

<0|1>><LF

PORTA<num>[S]

Set the port extension length for Input A

±10 seconds

<0|1>><LF

PORTB<num>[S]

Set the port extension length for Input B

±10 seconds

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the extension value at the specified port.

Read-Write the extension value at the specified receiver.

PNA COM Equivalent - Notes

Sets the port extension value for Port 1.

Sets the port extension value for Port 2.

Sets the port extension value for Receiver A.

Sets the port extension value for Receiver B.

PORTP

8753 Command

Description

Range

Query Response

PORTP<CPLD|UNCPLD>

Selects either coupled or uncoupled for the port powers of a given channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write Port Power Coupling ON or OFF.

PNA COM Equivalent - Notes

Turns ON and OFF source power coupling.

POWE

8753 Command

Description

Range

Query Response

POWE<num>[DB]

Sets the output power level.

output power range of your analyzer. The output power range of your analyzer depends upon the model and installed options. Refer to your analyzers users guide to determine the power range of your analyzer.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the RF power output level.

PNA COM Equivalent - Notes

Read-Write the RF power output level.

POWR

8753 Command

Description

Range

Query Response

POWR<num>

Sets the source power range. See also "PRAN."

Use two-digit integers 0007.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

POWS

8753 Command

Description

Range

Query Response

POWS

Selects power sweep from the sweep type menu.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sets the type of X-axis sweep that is performed on a channel.

POWT

8753 Command

Description

Range

Query Response

POWT<ON|OFF>

Sets source power on or off. Works the opposite of the SOUP command. Sending POWTON turns source power off. Sending POWTOFF turns source power on.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Turns ON and OFF Source Power.

PNA COM Equivalent - Notes

Turns ON and OFF Source Power.

PRAN

8753 Command

Description

Range

Query Response

PRAN<num>

Sets the source power range. See also "POWR."

integers 07.

N/A

PNA SCPI Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Setting the attenuation is equivalent to setting the source power range.

PRES

8753 Command

Description

Range

Query Response

PRES

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Preset.

PNA COM Equivalent - Notes

Preset

PRIN

8753 Command

Description

Range

Query Response

PRINALL

Copies the display, in raster graphics mode, to a printer. Requires pass control when using the GPIB port. (Use PRINTALL to send ASCII data to the printer.)

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Prints the screen to the active printer.

Saves the screen data to a bitmap (.bmp) file.

PWRR

8753 Command

Description

Range

Query Response

PWRR<PMAN|PAUTO>

Selects whether the power range is in auto or manual mode.

N/A

<0|1>><LF 0 = manual mode; 1 = auto mode

PNA SCPI Equivalent - Notes

Read-Write automatic attenuation control ON or OFF. Setting the automatic attenuation control is equivalent to setting the source power range mode.

PNA COM Equivalent - Notes

Sets or returns the mode of operation of the attenuator control. Setting the automatic attenuation control is equivalent to setting the source power range mode.


RNotes

RAI

8753 Command

Description

Range

Query Response

RAID

Completes the response and isolation cal sequence. OPC-compatible.

N/A

N/A

RAIISOL

Calls the isolation class for the response and isolation calibration.

N/A

N/A

RAIRESP

Calls the response class for the response and isolation calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

REAL

8753 Command

Description

Range

Query Response

REAL

Sets the display format to real.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.

REF

8753 Command

Description

Range

Query Response

REFP<num>

Enters the reference position. 0 is the bottom, 10 is the top of the graticule.

Integers 0–10

<num><LF

REFV<num>

Enters the reference line value.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Reference Position of the specified trace in the specified window.

Read-Write the Y axis Reference Level of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Reference Position of the active trace.

Sets or returns the value of the Y-axis Reference Level of the active trace.

RESPDONE

8753 Command

Description

Range

Query Response

RESPDONE

Completes the response calibration sequence. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data.

PNA COM Equivalent - Notes

Calculates the correction data.

REST

8753 Command

Description

Range

Query Response

REST

Measurement restart.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Abort the current sweep with the command in Step 1.

Step 2

Initiate a new sweep with the command in Step 2.

PNA COM Equivalent - Notes

No equivalent command at present.

REV

8753 Command

Description

Range

Query Response

REVI

Calls the reverse isolation calibration class during a full 2-port calibration.

N/A

N/A

REVM

Calls the reverse match calibration class during a full 2-port calibration.

N/A

N/A

REVT

Calls the reverse transmission calibration class during a full 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

Write-only to measure the specified standard from the selected calibration kit.

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculates the correction data using the selected Cal Type and turns error correction ON.

Measures the specified standard from the selected calibration kit.

Specifies the type of calibration to perform.

RST

8753 Command

Description

Range

Query Response

RST

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

Executes a device reset and cancels any pending *OPC command or query. Replace "RST" with "*RST".

PNA COM Equivalent - Notes

Resets instrument. Clears all existing windows and measurements.


SNotes

S

8753 Command

Description

Range

Query Response

S11

Forward reflection measurement.

N/A

<0|1>><LF

S12

Reverse transmission measurement.

N/A

<0|1>><LF

S21

Forward transmission measurement.

N/A

<0|1>><LF

S22

Reverse reflection measurement.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1

Create the measurement.

Step 2

If a new window will be used to display the measurement, then create a window.

Step 3

Display the measurement in the window.

PNA COM Equivalent - Notes

Create and display the measurement.

SADD

8753 Command

Description

Range

Query Response

SADD

Adds a new segment to the table during a list-frequency, limit-table, cal sensor table, or power loss table edit.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to add a segment. A segment must be added prior to setting data in the segment.

PNA COM Equivalent - Notes

Add a segment.

SCAL

8753 Command

Description

Range

Query Response

SCAL<num>

Sets the trace scale factor.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the Y axis Per Division value of the specified trace in the specified window.

PNA COM Equivalent - Notes

Sets or returns the Y-axis Per Division value of the active trace.

SDEL

8753 Command

Description

Range

Query Response

SDEL

Deletes the current segment while editing a list frequency, a limit table, or a power loss list.

N/A

N/A

PNA SCPI Equivalent - Notes

Write-only to delete the specified segment number.

Write-only to delete all segments.

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF.

PNA COM Equivalent - Notes

Removes an item from a collection of objects.

SEA

SEAL

SEAMAX

SEAMIN

SEAOFF

SEAR

SEATARG

8753 Command

Description

Range

Query Response

SEAL

Search left for next occurrence of the target value.

N/A

N/A

SEAR

Search right for next occurrence of the target value.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1

Read-Write the target value for the specified marker when doing Target Searches.

Step 2

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Step 1

Sets the target value for the marker when doing Target Searches.

Step 2a

Moving to the left of the marker position, searches the marker's domain for the target value.

Step 2b

Moving to the right of the marker position, searches the marker's domain for the target value.

8753 Command

Description

Range

Query Response

SEAMAX

Search for trace maximum on the current channel.

N/A

<0|1><LF>

SEAMIN

Search for trace minimum on the current channel.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Searches the marker domain for the maximum value.

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

SEAOFF

Turns the marker search off.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

Turn marker search off by turning OFF the marker.

PNA COM Equivalent - Notes

Turn marker search off by turning OFF the marker.

8753 Command

Description

Range

Query Response

SEATARG<num>

Set the search target amplitude.

Amplitude range.

<num><LF>

PNA SCPI Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

PNA COM Equivalent - Notes

Sets the target value for the marker when doing Target Searches.

SEDI

8753 Command

Description

Range

Query Response

SEDI<num>

During either a frequency, limit, or power loss table edit, selects segment <num> for editing.

State dependent. Range for frequency segment = 1 to 30; Range for limit test segment = 1 to 18; Range for power loss table segment = 1 to 12

<num><LF>

PNA SCPI Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. To edit a segment or limit line, see the following commands:

Commands to edit a segment.

Commands to edit a limit line.

PNA COM Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. See the appropriate methods and properties for segments and limit lines.

SEG

8753 Command

Description

Range

Query Response

SEGIFBW<num>

Sets the IFBW for the active segment of a list-frequency table in swept list mode.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000.

see "Note" below

SEGPOWER<num>

Sets the power for the active segment of a list-frequency table in swept list mode.

Output power range of your analyzer. The output power range is dependent upon the model and option configuration of your analyzer. Refer to your analyzers users guide to determine the output power range of your analyzer.

see "Note" below

Note: Currently these commands can be queried by sending the command followed by the OUTPACTI command.

PNA SCPI Equivalent - Notes

Read-Write the IFBandwidth for the specified segment.

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the IF Bandwidth of all measurements in a channel.
OR
Sets or returns the IF Bandwidth of a specified sweep segment.

Sets or returns the RF power level of all measurements in a channel
or
Sets or returns the RF power level of a specified sweep segment.

SING

8753 Command

Description

Range

Query Response

SING

Single sweep. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

If sweep is not is single sweep mode, put the analyzer in single sweep mode by setting continuous OFF.

Trigger one sweep.

PNA COM Equivalent - Notes

Single sweep.

SMI

8753 Command

Description

Range

Query Response

SMIC

Selects Smith chart display format.

N/A

<0|1>><LF

SMIMGB

Selects G+jB (conductance and susceptance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLIN

Selects linear magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLOG

Selects log magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRI

Selects real/imaginary pairs (resistance and reactance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRX

Selects R + jX marker readout on a Smith chart.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Selects the Smith chart display format.

Use this command to turn on a marker.

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Selects the Smith chart display format.

Selects the appropriate marker readout format.

SMOO

8753 Command

Description

Range

Query Response

SMOOAPER<num>

Sets the smoothing aperture as a percent of the trace.

0.05 to 20%

<num><LF

SMOOO<ON|OFF>

Selects whether smoothing is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the amount of smoothing.

Read-Write data smoothing ON or OFF.

PNA COM Equivalent - Notes

Specifies or returns the amount of smoothing.

Turns data smoothing ON and OFF.

SOUP

8753 Command

Description

Range

Query Response

SOUP<ON|OFF>

Selects whether the source power is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write RF power from the source ON or OFF.

PNA COM Equivalent - Notes

Turns source power ON and OFF.

SPAN

8753 Command

Description

Range

Query Response

SPAN<num>[HZ|DB]

Sets the stimulus span value. If a list frequency segment is being edited, sets the span of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the frequency span of the analyzer.

Read-Write the frequency span for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the frequency span of all measurements in a channel
or
Sets or returns the frequency span of a specified sweep segment.

SRE

8753 Command

Description

Range

Query Response

SRE<num>

Service request enable. A bit set in <num> enables the corresponding bit in the status byte to generate an SRQ.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "SRE" with "*SRE".

PNA COM Equivalent - Notes

No equivalent command at present.

SSEG

8753 Command

Description

Range

Query Response

SSEG<num>

Selects the desired segment of the frequency list for a list frequency sweep. See also "ASEG".

Integers 130

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the specified segment ON or OFF.

The segment will not be turned on until the sweep type is set to "SEGMent" sweep with this command.

PNA COM Equivalent - Notes

Segment collection object.

STAR

8753 Command

Description

Range

Query Response

STAR<num>[HZ|DB]

Sets the start stimulus value. If a list frequency segment is being edited, sets the start of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the start frequency of the analyzer.

Read-Write the start frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the start frequency of all measurements in a channel
or
Sets or returns the start frequency of a specified sweep segment.

STB?

8753 Command

Description

Range

Query Response

STB?

Query only. Outputs the status byte in ASCII format (FORM4). Same as OUTPSTAT.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Enables bits in the service request register. Replace "STB?" with "*STB?".

PNA COM Equivalent - Notes

No equivalent command at present.

STOP

8753 Command

Description

Range

Query Response

STOP<num>[HZ|DB]

Sets the stop stimulus value. If a list frequency segment is being edited, sets the stop of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

To Read-Write the stop frequency of the analyzer.

To Read-Write the stop frequency for the specified segment.

PNA COM Equivalent - Notes

Sets or returns the stop frequency of all measurements in a channel
or
Sets or returns the stop frequency of a specified sweep segment.

STOR

8753 Command

Description

Range

Query Response

STOR<num>

Stores the current instrument state to disk using the file name provided by the preceding TITF<num> command.

Integers 15

N/A

PNA SCPI Equivalent - Notes

Write-only to store the specified file.

PNA COM Equivalent - Notes

Saves a measurement state, calibration state, or both.

SWE

8753 Command

Description

Range

Query Response

SWEA

Automatically selects the fastest sweep time based on the current analyzer settings for number of points, IF bandwidth, sweep mode, averaging condition and frequency span.

N/A

N/A

SWET<num>[S]

Sets the sweep time. (Setting SWET0 is equivalent to sending the SWEA command.)

086,400 s

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the automatic sweep time function ON or OFF.

Read-Write the time the analyzer takes to complete one sweep.

PNA COM Equivalent - Notes

Sets the Sweep time of the analyzer. Setting sweep time to 0 will result in the fastest possible sweep time with the current settings.

SWR

8753 Command

Description

Range

Query Response

SWR

Selects the SWR display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Sets (or returns) the display format of the measurement.


Symbol Conventions

Symbol

Description

<num>

Required numerical data.

<a1| a2>

An appendage that is part of the command. For example, FORMAT<DOS|LIF> indicates that the actual commands are FORMATDOS and FORMATLIF.

<$>

Indicates a character string operand which must be enclosed by double quotes.

|

An either/or choice in appendages or optional data.

[ ]

Optional data.

<LF>

Line feed.


TZNotes

TALKLIST

8753 Command

Description

Range

Query Response

TALKLIST

Selects the talker listener mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Selects the talker listener mode.

TIT

8753 Command

Description

Range

Query Response

TITL<$>

Enters a new display title.

48 characters max

N/A

PNA SCPI Equivalent - Notes

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

TITF

Titles the indicated file numbers.

<num>: 15 <$>: 10 char. max.

N/A

TITP

Titles the plot to disk file.

10 characters max

N/A

TITR

Titles the indicated internal register.

<num>: 15 <$>: 10 char. max.

N/A

TITREG

Titles save/recall registers 01 through 31. TITREG01 through TITREG05 are the same as TITR1 through TITR5.

<num>: 0131 <$>: 10 char. max.

N/A

TITSEQ

Selects the sequence to be titled.

<num>: 16 <$>: 10 char. max.

N/A

TITSQ

Provides access to the sequence title functions.

N/A

N/A

Notes

These commands currently are not available.

TRACK

8753 Command

Description

Range

Query Response

TRACK<ON|OFF>

Turns marker search tracking on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Read-Write tracking capability for the specified marker.

PNA COM Equivalent - Notes

Turns marker search tracking on and off.

TRL

8753 Command

Description

Range

Query Response

TRLL1

Measures TRL Line/match for Port 1 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLL2

Measures TRL Line/match for Port 2 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR1

Measures TRL S11 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR2

Measures TRL S22 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLT

Measures TRL thru during a TRL/LRM 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the calibration method.

Write-only to measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

Specifies the type of calibration to perform.

Measures the specified standard from the selected calibration kit.

TST?

8753 Command

Description

Range

Query Response

TST?

Query only. Causes a self test and returns a zero if the test is passed.

N/A

<num><LF>

PNA SCPI Equivalent - Notes

Returns the result of a complete self-test. An ASCII 0 indicates no failures found.

PNA COM Equivalent - Notes

No equivalent command at present.

TSTP

8753 Command

Description

Range

Query Response

TSTP<P1|P2>

Selects test port 1 or 2 for non-S-parameter measurements.

N/A

N/A

PNA SCPI Equivalent - Notes

Read-Write the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.

PNA COM Equivalent - Notes

Create and display the measurement. Method parameter allows one to select the specific port.

VELOFACT

8753 Command

Description

Range

Query Response

VELOFACT<num>

Enters the velocity factor of the transmission medium.

0 to 10

<num><LF

PNA SCPI Equivalent - Notes

Read-Write the velocity factor to be used with Electrical Delay and Port Extensions.

PNA COM Equivalent - Notes

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

WAIT

8753 Command

Description

Range

Query Response

WAIT

Waits for a clean sweep when used with the OPC command.

N/A

N/A

PNA SCPI Equivalent - Notes

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed.

PNA COM Equivalent - Notes

No equivalent command at present.

WID

8753 Command

Description

Range

Query Response

WIDT<ON|OFF>

Turns the bandwidth search on and off.

N/A

<0|1><LF

WIDV<num>

Enters the widths search parameter.

Amplitude range.

<num><LF

PNA SCPI Equivalent - Notes

Step 1

Turn ON bandwidth search. Also, can return statistics.

Step 2

Turn marker tracking ON.

Step 3

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

PNA COM Equivalent - Notes

Step 1

Enter the bandwidth target value.

Step 2

Turn ON bandwidth search.

Step 3

Turn marker tracking ON.

The filter statistics can be returned with this method.

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with DeleteMarker method.


Number of Points Property

About ...

NumberOfPoints Property

Write/Read

Description

Sets or returns the Number of Points of the channel.
Sets or returns the Number of Points of the segment.

VB Syntax

object.NumberOfPoints = value

Variable

(Type) - Description

object

A Channel (object) or
A Segment (object)

value

(long) - Number of Points. Choose any number from 1 to 1601

Return Type

Long Integer

Default

201

Examples

chan.NumberOfPoints = 201 'sets the number of points for all measurements in the channel. -Write

numofpts = chan.NumberOfPoints 'Read

C++ Syntax

HRESULT get_NumberOfPoints(long *pVal)
HRESULT put_NumberOfPoints(long newVal)

Interface

IChannel
ISegment


About Modifying Cal Kits

CalKitType Property

Write/Read

Description

Sets and returns a calibration kit type for calibration or to be used for kit modification. To get a handle to this kit, use app.ActiveCalKit

VB Syntax

object.CalKitType = value

Variable

(Type) - Description

object

Use either of these:
A calkit (object).
An Application (object).

Note: app.CalKitType and calkit.calKitType perform exactly the same function.

value

(enum naCalKit) - Calibration Kit type. Choose from:

1 - naCalKit_85032F_N50
2 - naCalKit_85033E_3_5
3 - naCalKit_85032B_N50
4 - naCalKit_85033D_3_5
5 - naCalKit_85038A_7_16
6 - naCalKit_85052C_3_5_TRL
7 - naCalKit_User7
8 - naCalKit_User8
9 - naCalKit_User9
10 - naCalKit_User10

Return Type

naCalKit

Default

Not Applicable

Examples

calkit.CalKitType = naCalKit_85038A_7_16

kitype = app.CalKitType

C++ Syntax

HRESULT get_CalKitType(tagNACalKit *pVal)
HRESULT put_CalKitType(tagNACalKit newVal)

Interface

IApplication
ICalKit


CalType (perform) Property

About Performing a Calibration

SetCalInfo Property

Write-only

Description

Specifies the type of calibration to perform. This method should be the first method called on the calibrator object. It prepares the internal state for the rest of the calibration.

VB Syntax

cal.SetCalInfo(type,rcvPort,srcPort)

Variable

(Type) - Description

cal

A Calibrator (object)

type

(enum NACalType) - Calibration type. Choose from:

0 - naCalType_Response_Open
1 - naCalType_Response_Short
2 - naCalType_Response_Thru
3 - naCalType_Response_Thru_And_Isol
4 - naCalType_OnePort
5 - naCalType_TwoPort_SOLT
6 - naCalType_TwoPort_TRL
7 - naCalType_None

Note: The analyzer can measure both ports simultaneously, assuming you have two of each standard type. For a 2-port cal, See cal.Simultaneous2PortAcquisition

Note: For 1-port cals, the source port = receiver port. For 2-port SOLT and TRL, it doesn't matter which port is specified as source and receiver

rcvPort

(long integer) - Receiver Port

srcPort

(long integer) - Source Port

Return Type

NACalType

Default

7- naCalType_None

Examples

cal.setCalInfo(naCalType_Response_Open,1,1)

C++ Syntax

HRESULT put_setCalInfo(tagNACalType calType,long portA, long portB,)

Interface

ICalibrator


About Limit Testing

LimitTestFailed Property

Read-only

Description

Returns the results of limit testing for the measurement.

VB Syntax

testFailed = meas.LimitTestFailed

Variable

(Type) - Description

testFailed

(boolean) Variable to store the returned value

False (0) - Limit Test Passed
True (1) - Limit Test Failed

meas

A Measurement (object)

Return Type

Boolean

Default

False returned if there is no testing in progress

Examples

Dim testRes As Boolean
testRes = meas.LimitTestFailed
MsgBox (testRes)

C++ Syntax

HRESULT get_LimitTestFailed(VARIANT_BOOL* trueIfFailed)

Interface

IMeasurement


Reference Marker Property

About Reference Markers

ReferenceMarker Property

Write/Read

Description

Sets (or releases) a marker as a Delta marker. A delta marker reads out data relative to the reference marker. If making a marker a delta marker, you must also turn the reference marker (always marker 10) ON using meas.marker(10)

VB Syntax

mark.ReferenceMarker = value

Variable

(Type) - Description

mark

A Marker (object)

value

(long integer) - Reference Marker number. Choose from:
0 - Makes the marker NOT a delta marker
10 - Makes the marker a delta marker

Return Type

Long Integer

Default

0 - absolute marker

Examples

mark.ReferenceMarker = 0 'makes the active marker absolute (not delta) -Write

refMark = mark.ReferenceMarker 'returns the reference marker number -Read

C++ Syntax

HRESULT get_ReferenceMarker(long *pVal)
HRESULT put_ReferenceMarker(long newVal)

Interface

IMarker


Reference Stimulus Property

About Reference Markers

ReferenceStimulus Property

Write/Read

Description

Sets or Reads the stimulus (X-Axis) value of the reference marker.

VB Syntax

mark.ReferenceStimulus = value

Variable

(Type) - Description

mark

A Marker (object) that is a delta marker.

value

(double) - stimulus value of the reference maker.

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceStimulus = 4.5e9 'Write

RefStim = mark.ReferenceStimulus 'Read

C++ Syntax

HRESULT get_ReferenceStimulus(double *pVal)
HRESULT put_ReferenceStimulus(double newVal)

Interface

IMarker


About Reference Markers

Reference Value (Marker) Property

Read-only

Description

Returns the Y-Axis value of the reference marker.

VB Syntax

yval = mark.ReferenceValue(format)

Variable

(Type) - Description

yvalue

A variable to store the Y-axis value of the reference marker

mark

A Marker (object) that is a delta marker.

format

(enum NAMarkerFormat) -format of the returned value. Choose from:

naMarkerFormat_LinMag
naMarkerFormat_LogMag
naMarkerFormat_Phase
naMarkerFormat_Delay
naMarkerFormat_Real
naMarkerFormat_Imaginary
naMarkerFormat_SWR
naMarkerFormat_LinMagPhase
naMarkerFormat_LogMagPhase
naMarkerFormat_RealImaginary
naMarkerFormat_ComplexImpedance
naMarkerFormat_ComplexAdmittance

value

(double) - Reference Value

Return Type

Double

Default

Not applicable

Examples

mark.ReferenceValue(naMarkerFormat_LinMag) = 10 'Write

RefVal = mark.ReferenceValue 'Read

C++ Syntax

HRESULT get_ReferenceValue(tagNAMarkerFormat format, VARIANT *pVal)

Interface

IMarker


Status Keywords

Status Command Keywords

About Status Registers

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

:CONDition?

:ENABle

:ENABle?

:EVENt?

:MAP

:NTRansition

:PTRansition

:CONDition?

Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

Query only - This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


PowerTrip

If this stuff ever gets implemented, here it is: (The image map is the same file name)

SENSe:POWer:AC:PROTect:CLEar

(Write-only) Clears a power trip
Examples | SENS:POW:AC:PROT CLE sense:power:ac:protect clear
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:POWer:AC:PROTect:STATe <ON | OFF>

(Read-Write) Enables or disables the protection circuit.
Parameters |
<ON | OFF> | ON (or 1) - Protection circuit is enabled OFF(or 0) - Protection circuit is disabled
Examples | SENS:POW:AC:PROT:STAT ON sense:power:ac:protect:state off
Query Syntax | SENSe:POWer:AC:PROTect:STATe?
Return Type | Boolean 1 - Protection circuit is enabled 0 - Protection circuit is disabled
Overlapped? | No
Default | ON

SENSe:POWer:AC:PROTect:TRIPped?

(Read-only) Queries whether the power is OFF due to an overpower condition.
Examples | SENSe:POWer:AC:PROTect:TRIPped? sense:power:ac:protect:tripped?
Query Syntax | SENSe:POWer:AC:PROTect:TRIPped?
Return Type | Boolean
Overlapped? | No
Default | Not Applicable


Kalibrierung

Siehe auch...

Klicken Sie auf eine Schaltfläche, um zu erfahren, wie Sie die systematischen Messfehler durch eine Kalibrierung reduzieren können.

Überblick über die Kalibrierung

Messfehler

Kalibriernormale

Wahl des Kalibrierverfahrens und Durchführung der Kalibrierung

Genaue Kalibrierung

Gültigkeit einer Kalibrierung


Datenausgabe

Drucken, Abspeichern und Zurückladen von Messdaten

Siehe auch...

Klicken Sie auf eine Schaltfläche, um nähere Informationen über die Ausgabe von Messdaten zu erhalten.

Abspeichern und Zurückladen einer Datei

Drucken einer angezeigten Messung

Abbilden von Netzlaufwerken


6_Tab

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


3 Tab Model

Three Tab Model

Overview

Concepts

Procedure

This is where the introductory paragraph goes that give the overview what part of the screen annotation is possible to change and the possible benefits to the reader.
Concepts

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

Click on the numbered buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


4 Tab Model

Tab Model

Overview

Concepts

Setting
Location

Procedure

This is where the introductory paragraph goes that give the overview various arrangements are possible for viewing multiple traces and channels and what the possible benefits are to the reader.
Concepts

Setting Location

Procedure

This is where we can mention the rules and considerations in a general way, then put them in the list following that is also a set of links that jumps to the sections of this "tabbed" section. (An advanced organizer.)
First Section Title

Second Section Title

Third Section Title

First Section Title

If any of the formatting is lost:

Second Section Title

This is where you can say all sorts of cool stuff that the customers would find fasinating.

Third Section Title

This is where you just dazzle 'em.

This is where you show the graphics (possibly with callouts) that show where one can access the setting being discussed.

  • Front panel key and softkey

  • Drop-down menu choice

  • Dialog box entry field/button/check

Click on the buttons to access procedures for xxx.
First procedure

Second procedure

Third procedure

Make the buttons into hyperlinks, connecting to the procedure headings.

First Procedure Heading

Caution! If there is any warning or caution message necessary.
Mouse Procedure

Front Panel Keys Procedure

Make the buttons hyperlinks, connecting to the headings for the two types of procedures.

Mouse Procedure

Front Panel Keys Procedure

  1. .


6 Tab Model

Six Tab Model

Overview

Concepts

Procedure

Step3

Step4

Step5

This procedure describes how to edit this model with topic-specific information.

This overview section is where the high-level information for the topic goes. The list below correlates with the tabs across the top.
Concepts

Procedure

3. Step 3

4. Step 4

5. Step 5

In the top right cell, change the text, "Learn about Markers" . The formatting should remain. Edit the link as you would any link.

If any of the formatting is lost:

  • the font becomes blue underline, change the font using "format, character, font" to white comic sans 8.0." and remove the underline. (Blue underline is the default link style with "document")

  • The green background for the paragraph is in the style sheet under "Heading 5".

  • The red mouseover is supplied with DHTML rollover text.

To Remove Tabs:

This model is supplied with 6 tabs. The first should always be "Overview". You should not use more than five steps, but you will probably have less than five.

In the top row of this table, (the tab labels) remove the appropriate number of colums from the right side. For example, if you need 3 steps, remove the columns fortabs 4 and 5.

You don't have to remove the corredsonding rows below, like where this row is. You simply will not use it, and it will not cause any problems. Except in the last step, (if you have 3 steps, at the end of the third step, remove the "Continue and arrow".

In true code, remove the VBscript for the removed steps.

Under "sub all in", remove the lines that have reference to the removed steps. There is one for the tab and one for the text. For example:

  • tab4.classname="Tab-In"

  • tab5.classname="Tab-In"

  • txt4.style.display="none"

  • txt5.style.display="none

How it works:

The following rows in this table are for the corresponding text for each of the tabs. When a cell in the top row of this table (a "tab") is clicked , the VBscript subroutine "tabclick is called. The "tab" that was clicked is passed as the 'x' parameter. Immediately, the "all in" subroutine is called which "hides" the text in all of the rows and changes the style of tab to tab in. Then the case for the "x" parameter, the tab number, is executed which displays the text (display " " ) and changes the style to tab-out.

The continue and overview links call the tab-out procedure, which then behaves exactly like one of the tabs were clicked.

The header table is actually two tables and the style sheet (proceduretab) contains the "indented" styles (table-top & table-bottom) for both tables..

Anything else??


Reference Body

Power can be defined as the energy transfer per unit time averaged over many periods of the lowest frequency (RF or microwave) involved. The term "average power" is used in specifying almost all RF and microwave systems. Power level is expressed in decibels based on 1 milliwatt (dBm) or 1 watt (dBw).

Power Ranges

Automatic mode

Manual mode

Power coupling options

Power slope

Power sweep

Power Ranges

The built-in synthesized source contains a programmable step attenuator that allows you to directly and accurately set power levels in eight different power ranges. Each range has a total span of 25 dB. The eight ranges cover the instrument's full operating range from +10 dBm to -85 dBm. You can select a power range either manually or automatically.

Automatic Mode

You can select any power level within the total operating range of the instrument and the source attenuator will automatically switch to the corresponding range.

Each range overlaps its adjacent ranges by 15 dB, therefore, certain power levels are designated to cause the attenuator to switch to the next range so that optimum (leveled) performance is maintained. These transition points exist at -10 dB from the top of a range and at +5 dB from the bottom of a range. This leaves 10 dB of operating range.

Manual Mode

If you use the manual power range mode, you must first select the power range that corresponds to the power level you want to set. Consequently, you will not be able to set a power level that is outside the range limits. This feature is necessary to maintain accuracy once a measurement error-correction is switched on.

Power Coupling Options

You can couple the measurement channels settings, making the measurement stimulus the same. By default the power at the test ports are coupled, making the power levels at both ports the same. Uncoupling the channels will separate the sources. You can also uncouple the test ports, allowing you to have different power levels on each port.

Power Slope

Power slope compensates for power loss versus the frequency sweep. Starting at the selected power level, the output power increases by sloping the output power upwards proportionally to frequency. Enter the power slope in dB per GHz of sweep.

Power Sweep

Power is swept at a single frequency, from a start power value to a stop power value. You select the start and stop power values, using the start and stop functions. To set the frequency of the power sweep, you use the CW frequency function. The span of the swept power is limited to being equal to or within one of the eight pre-defined power ranges.

The attenuator will not switch to a different power range while in the power sweep mode.

Tell Me More


Reference Mini Guide

Guide to Learning About XYZ

Introduction text goes here...

In this Topic...

You will learn...

Topic Title

the basics of...

Topic Title

when to...

Topic Title

when to...

Topic Title

the basics of...

Topic Title

when to...