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General Safety Summary 

Review the following safety precautions to avoid injury and prevent damage to 
this product or any products connected to it. To avoid potential hazards, use this 
product only as specified. 

Only qualified personnel should perform service procedures. 

While using this product, you may need to access other parts of the system. Read 
the General Safety Summary in other system manuals for warnings and cautions 
related to operating the system. 

To Avoid Fire or Personal Injury: 

Connect and Disconnect Properly: Do not connect or disconnect probes or test 
leads while they are connected to a voltage source. 

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all 
ratings and markings on the product. Consult the product manual for further 
ratings information before making connections to the product. 

Do Not Operate With Suspected Failures: If you suspect there is damage to 
this product, have it inspected by qualified service personnel. 

Symbols and Terms: The following terms and symbols may appear in the online 
help. 

 

 

 

 

 

Terms on the Product: The following terms may appear on the product: 

� DANGER indicates an injury hazard immediately accessible as you read the 
marking. 

� WARNING indicates an injury hazard not immediately accessible as you 
read the marking. 

� CAUTION indicates a hazard to property including the product. 

 

 
WARNING. Warning statements identify conditions or practices that could 
result injury or loss of life.   

 
CAUTION. Caution statements identify conditions or practices that could 
result in damage to this product or other property.   
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Symbols on the Product: The following symbol(s) may appear in the product: 

 CAUTION  
Refer to Help 
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Introduction 

Using Online Help 
Online help has many advantages over a printed manual because of advanced 
search capabilities. You can select Help> Topics on the right side of the 
application menu bar to display the Help file.  

The main (opening) Help screen shows three tabs across the top, each of which 
offers a unique mode of assistance: 

� Contents (TOC) tab - organizes the help into book-like sections. Select a 
book icon to open a section; select any of the topics listed under the book. 

� Index tab - enables you to scroll a list of alphabetical keywords. Select the 
topic of interest to display the corresponding help page. 

� Find tab - allows a text-based search. Follow these steps: 

1. Type the word or phrase you want to find in the search box. 

2. If the word or phrase is not found, try the Index tab. 

3. Select some matching words in the next box to narrow your search. 

4. Choose a topic in the lower box, and then select the Display button. 

Note: The Find tab function does not include words found in graphics 
 

� To print a topic, select the Print button from the help topics menu bar. 

Select the Back button to return to the previous help window. Sometimes you can 
jump from one topic to another through a hyperlink. If the Back button is grayed 
out, or a jump is not available, choose the Help Topics button to return to the 
originating help folder. 
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� Browse buttons (Next >> and << Previous) allow you to move forward and 
backward through topics in the order of the Table of Contents (TOC). 

� A Note: in the topic text indicates important information.  

Note: Green-underlined text indicates a jump (hyperlink) to another topic. Select 
the green text to jump to the related topic. For example, select the green text to 
jump to the topic on Feedback to contact Tektronix.  
 

 You can tell when the cursor is over an active hyperlink (button, jump, or 
popup), because the arrow cursor changes to a small pointing hand cursor. 

The light bulb icon and word Tip in the graphic above indicates additional 
information to help you operate the application more efficiently. 

Related Documentation 
In addition to the online help, the Serial ATA and SAS test modules, Optional 
Applications Software on a Windows-Based Oscilloscope CD-ROM includes a 
Quick Reference guide in PDF format. Refer to the Option SST Serial ATA and 
Serial Attached SCSI Test Module Application Reference for the following 
information: 

� A short tutorial to help you quickly take measurements  

� An overall menu map of the entire application  

In addition to the online help for the SATA and SAS test modules, you can refer 
to the RT-Eye Serial Data Compliance and Analysis Application online help for 
information about how to use the RT-Eye application. 

Refer to the Optional Applications Software on  Windows-Based Oscilloscope 
Installation Manual for the following information: 

� Software warranty 

� List of all available applications, compatible oscilloscopes, and relevant 
software and firmware version numbers
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� Applying a new label 

� Installing an application 

� Enabling an application  

� Downloading updates from the Tektronix Web site 

Note: You can view PDF file of the installation manual from the CD Installation 
Browser and from the Documents directory on the Optional Applications 
Software on a Windows-Based Oscilloscope CD-ROM. 
 

For complete information on Tektronix Methods of Implementation (MOI) for 
SATA Interoperability tests, refer to the document titled Serial ATA 
Interoperability Program - Tektronix MOI for Device PHY, TSG and OOB 
Tests located at 
http://www.tek.com/Measurement/applications/serial_data/sata.html 

Reference to Standards 

� Serial ATA-II specifications PHYii Spec Rev 1_0 052604.pdf. 

� SAS specifications ANSI INCITS 376-2003 dated 30th October 2003 

Conventions 
Online help topics use the following conventions: 

� The term "module", "SATA or SAS test module" or "application" refers to 
the Serial ATA or SAS plug-in software modules.  

� The term "RT-Eye application" refers to the Tektronix RT-Eye Serial Data 
Compliance and Analysis Application with which the Serial ATA and SAS 
modules can be run. 

� The term "oscilloscope" refers to any product on which this application runs.  

� The term "select" is a generic term that applies to the two mechanical 
methods of choosing an option: with a mouse or with the touch screen.  

� The term "channel" is context dependent. It can refer to the transmit channel 
of the device under test or to an oscilloscope channel. 

� The term "DUT" is an abbreviation for Device Under Test.  
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� When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as File> Recall. 
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Updates through the Web Site 
You can find information about this and other applications at the Tektronix Inc. 
Web site, www.tektronix.com. Check this site for firmware updates and other 
information about our application.  

Feedback 
Tektronix values your feedback on our products. To help us serve you better, 
please send us your suggestions, ideas, or comments on the application. 

Direct your feedback via email to techsupport@tektronix.com or sata2-
feedback@tek.com or FAX at (503) 627-5695 and include the following 
information. Please be as specific as possible. 

General information: 

� Instrument model number and hardware options if any, with serial number 

� Probes used 

� Your name, company, mailing address, phone number, FAX number, email 
address 

� Please indicate if you would like to be contacted by Tektronix about your 
suggestion or comments 

Application specific information: 

� Software version number 

� Description of the problem such that technical support can duplicate the 
problem 

� The setup file of the oscilloscope and the application is also required to 
identify the problem 

� If possible, save the waveform on which you are performing the 
measurement as a .wfm file 

Note: To find the Software version number, click Help> About in the application. 
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Once you have gathered this information, you can contact technical support by 
fax or through email. If using email, be sure to enter "Option SST Software 
Problem" in the subject line, and attach the .wfm files. 

You can then attach the file to your email (depending on the capabilities of your 
email editor). 
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Getting Started 

About the Option SST Analysis Modules 
The Option SST Analysis Modules consist of two modules−Serial ATA and 
SAS− that are plug-in software modules to the Tektronix RT-EYE Serial 
Compliance and Analysis application that runs on some Tektronix Windows-
based oscilloscopes.  

You can use these modules to test storage devices as per the Serial Advanced 
Technology Attachment or SATA (Gen I and Gen II) and Serial Attached SCSI 
(SAS) standards. After the measurements are taken, the results are displayed to 
show whether the device has passed or failed the test.  

Other features include:  

� Performs Eye, Timing, and Amplitude measurements, and OOB tests 
according to industry standard methods 

� Selects and configures multiple measurements using differential or single-
ended probe inputs for receiver and transmitter devices 

� Creates, formats, and generates reports 

The measurements that are available in the Serial ATA module are: Eye, Bit 
Rate, Differential Skew, Rise and Fall Time, Unit Interval, Differential Voltage, 
AC CM Voltage, COMINIT, COMWAKE, and COMRESET.  

The measurements that are available in the SAS module are: Eye, Bit Rate, Rise 
and Fall Time, Differential Skew, COMINIT, COMWAKE, and COMRESET. 

Compatibility 
For information on oscilloscope compatibility, refer to the Optional Applications 
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part 
number 071-1888-XX. The manual is available as a PDF file. 
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Recommended Accessories 
The Option SST Test Modules support the following probes: 

� P7380SMA 

� P7380 

� SMA Cables  

� 14dB Attenuator: Tektronix 5X Attenuator (SMA male-to-female) - (Order 
015-1002-01.) 

Test fixtures: Crescent Heart Software (www.c-h-s.com) 

Requirements and Restrictions 
� The RT-EYE Serial Compliance and Analysis application must be installed 

for the Option SST Test Modules to run.  

� The Sun Java Run-Time Environment (JRE) V1.4.0 and The Mathworks 
MATLAB Run-Time Server are components of the Option SST test 
modules. When you install the application, the InstallShield Wizard 
automatically installs the proper software components.  

MATLAB Server. The MATLAB server is dedicated to the RT-Eye application 
and cannot be used for other purposes. Do not close the MATLAB Server icon in 
the oscilloscope task bar because this will disrupt the operation of the Option 
SST Test Modules. The application will close the MATLAB sever when you exit 
the application. 
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Starting the Application 
For supported non-B series oscilloscopes, on the oscilloscope menu bar, select 
File> Run Application> RT-Eye Serial Compliance and Analysis. For supported 
B-series oscilloscopes, on the oscilloscope menu bar, click App> RT-Eye Serial 
Compliance and Analysis. For DPO oscilloscopes, select Analyze> RT-Eye 
Serial Compliance and Analysis. 

� To start the Serial ATA module, from the RT-EYE Serial Compliance and 
Analysis application, select Module> Serial ATA.  

� To start the SAS module, from the RT-EYE Serial Compliance and Analysis 
application, select Module> SAS. 

The application starts and displays the Measurements Select menu.  

You can move between modules by selecting the module name from the Modules 
menu in the application menu bar. 

Maximizing and Minimizing the Application 
To minimize the application and selected module, select File> Minimize in the 
application menu bar.  

To maximize the application and selected module, select  in the 
task bar.  

To hide the application and the selected module, select the  Hide button. 

Returning to the Application 
For supported non-B series oscilloscopes, to return to the application, click the 
APP button on the top right of the oscilloscope display. For supported B-series 
oscilloscopes, click App> Restore Application from the menu bar.  

Exiting the Application 
To exit the RT-Eye application and the selected module, select File> Exit or the 
(Exit) command button in the application menu bar. When you exit the  
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application, you can elect to keep the oscilloscope setup currently in use with the 
application or to restore the oscilloscope setup that was present before you started 
the application.  

Application Directories and Usage 
The modules use directories to save and recall setup files and use file name 
extensions to identify the file type.  

The following table lists the default directory names:  

Table 1: Default directory names and their use 
Default directory names* Directory use
C:\Program
Files\TekApplications\tdsrt-
eye\modules\SATA

Serial ATA application home location

\modules\SATA\AWGFiles AWG files used by Serial ATA
\modules\SATA\limits Limit files for Pass or Fail compliance tests for Serial

ATA
\modules\SATA\setup Setup files for Serial ATA
C:\Program
Files\TekApplications\tdsrt-
eye\modules\SAS

SAS application home location

\modules\SAS\AWGFiles AWG files used by SAS
\modules\SAS\limits Limit files for Pass or Fail compliance tests for SAS
\modules\SAS\setup Setup files for SAS
\Examples\Masks Mask files for serial data standards
\Examples\RemoteCtrl Sample remote control program
\Examples\WFMS Waveforms for learning
\temp Temporary files
\images Plot files
\ReportGenerator\modules\SATA
\Reports

Files created for the Serial ATA module by the Report
Generator utility

\ReportGenerator\modules\SAS\
Reports

Files created for the SAS module by the Report
Generator utility

* All subdirectories are located in the c:\TekApplications\tdsrt-eye directory, except
the home location of the Option SST test modules.  
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File Name Extensions 
The following table lists the file name extensions and their descriptions: 

Table 2: File name extensions and their descriptions 
Extension Description
.bmp File that uses a "bitmap" format
.csv File that uses a "comma separated variable" format
.dat File with binary format
.fig Plot file with binary data
.gif File that uses a "graphic interchange format"
.ini Application setup file
.jpg File that uses the a "joint photographic experts group"

format; also known as JPEG
.lim Limits file used with Pass/Fail compliance
.mat MATLAB waveform vector header saved to the hard disk
.msk Waveform mask file used with plots
.pdf File that uses a "portable data format"
.png File that uses a "portable network graphics" format
.rgt File that defines the report template
.rpl File that defines the report layout
.rpt File created by the Report Generator utility
.rtf File that uses a "rich text format"
.set Oscilloscope setup file saved that is recalled with an

application .ini file; both files will have the same name
.wfm Waveform file; can be recalled into Reference memory  
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Operating Basics 

Opt. SST Application View 

 
Figure 1: Application view 
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Application User Interface Items 

Table 3: Application user interface and their description 
Item Description
Area Visual frame that encloses a set of related options
Box Use to define an option; enter a value with the keypad or

multipurpose knob
Browse Displays a window where you can look through a list of directories

and files
Button Use to define an options; not a command button
Check box Use to select or clear an option
Command button Initiates an immediate action, such as the Start command button in

the Control panel
Control panel Located to the right of the application; contains command buttons that

you use often
List box Use to define from a list
Menu All options in the application window (except the Control panel) that

display when you select a menu bar item
Menu bar Located at the top of the application display and contains the

application menus
Option Any named button (other than the command button) or any named

box that defines a control or task
Status bar Line located at the bottom of the application display that shows the

name of the current menu (location) and the next step that you might
take (action)

Scroll bar Vertical or horizontal bar at the side or bottom of a display area that
you use to move around in that area

Tab Short cut to a menu in the menu bar or a category of menu options;
most tabs are short cuts

Virtual keyboard On-screen keyboard that you can use to enter values (numeric
keyboard) or alphanumeric strings (text) for descriptions and file
names  



 
 
Operating Basics 
 

 Option SST Serial ATA and Serial Attached SCSI Analysis Module 
 
16

Serial ATA and SAS Measurements 
The following tables list the Serial ATA and SAS measurements that the modules 
support. 

Table 4: Default directory names and their use 
Measurement Description
Eye Measures, analyzes, and characterizes the differential

output voltage, jitter, rise and fall time for transition and
non-transition bits

Bit Rate Measures the inverse of the average bit time for the
clock recovery window

Differential Skew Measures the time difference between the single-ended
mid-point of the TX+/RX+ signal rising/falling edge and
the single-ended mid-point of the TX−/RX− signal
falling/rising edge

Rise and Fall Time Measures the rise and fall times of the waveform. The
rise and fall times are defined over a 20%-80% output
level change from the High and Low reference levels

Unit Interval Measures the time required to transmit one bit
Differential Voltage Measures the minimum and maximum differential

voltage amplitude for a given data pattern
AC Common Mode Voltage Measures the maximum sinusoidal amplitude
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Out Of Band Tests  

Table 5: Default directory names and their use 
Out of Band Tests Description
COMINIT Is used by the device to request a reset from the host in

accordance with a particular sequence of bursts
COMRESET Is indicated by transmitting bursts of data separated by

an idle bus condition. The OOB COMRESET signal
consists of no less than six data bursts with inter-burst
temporal spacing

COM WAKE The OOB COMWAKE signaling consists of no less than
six data bursts including inter-burst spacing

 

Menus 

Menus 

The Option SST application consists of two software plug-in modules that run on 
the RT-Eye Serial Data Compliance and Analysis application − Serial ATA 
(SATA) and SAS. Each module has a menu that allows you to save and recall 
files, select measurements and configure them, view results, and generate reports. 
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Figure 2: Default directory names and their use 

File Menu 

You can use the File menus to save and recall different application setups and 
recently accessed files.  

Note: The File> Save function saves application settings in an .ini file and the 
settings of the oscilloscope application in a .set file with a matching name. 
 

If an oscilloscope .set file with a matching name is found when you recall an 
application setup file, then the oscilloscope settings are also recalled. If the .set 
file is missing or cannot be opened by the oscilloscope, then the application 
recalls the application settings and displays a message that the Recall of the .set 
file failed. 

Do not edit a setup file or recall a file not generated by the application. 

Click File from the application menu bar.  



 
 

Operating Basics 

Option SST Serial ATA and Serial Attached SCSI Analysis Module  
 

19

The File menu has the following selections: 

Table 6: File menu and their descriptions 
Menu/function Description or function
Recall Default Recalls most default parameters for the active

module (Serial ATA or SAS)
Recall* Browse to select an application setup (.ini) file to

recall the setup file. Recall restores the application
to the values saved in the setup

Save* Saves the current application settings in a .ini file
Recall Recent Select from the list of four most recently accessed

setup files (saved or recalled) and recall that setup
Preferences Displays the Preferences menu, settings apply until

you exit the application; saved setup files include
the settings

Minimize Minimizes the application
Exit Exits the application; you can choose to retain the

current oscilloscope settings or restore the
oscilloscope to the settings prior to starting the
application

* Save or Recall functions also save or recall the associated oscilloscope
setup file (.ini); an oscilloscope file is recalled if the application finds a .set
with a matching name

 

Measurements Menu 

You can use the Measurements Menu to select and configure the measurement 
that you want to make.  

Click Measurement from the application menu bar. The Measurement menu has 
the following selections: 

Table 7: Measurement menu and their descriptions 
Menu/function Description or function
Select Displays the Measurements for the selected module
Configure Displays the configuration tabs for the selected

measurements
Limits Displays the Limits file

 
Click Measurement > Configure from the application menu bar. You can use the 
Configure menu item to select and configure the measurements that you have 
selected.  
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The Configure menu item has the following selections:  

Table 8: Configure menu and their descriptions 
Menu item Description
Source Displays the source parameters to configure for

the selected tests
General Config Displays the general parameters to configure for

the selected tests
Clock Config* Displays the clock parameters to configure for

the selected tests
Plot Config** Displays the plot parameters to plot an eye

diagram
* This tab is not available for SAS measurements
** This tab is enabled only for Eye measurement

 

Results Menu 

You can view the results of the measurements using the Results Menu.  

Click Results from the application menu bar. The Results Menu has the 
following selections: 

Table 9: Results menu and their descriptions 
Menu item Description
Summary Displays a summary of the results of the

measurement or test
Details Displays the details of the results of the

measurement or test
Worst Case Eye* Displays the plot of the Eye Diagram
* This selection is not available for the SAS module

 

Utilities Menu 

You can use the Utility Menu to open the report generator pane. You can create 
custom layouts and templates to generate custom reports. Click Utilities from the 
application menu bar. 

Help Menu 

You can use the Help Menu to open the common help file for the plug-in SATA 
and SAS modules, and version information about the modules.  

Click Help from the application menu bar.  

The Help menu has the following selections: 
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Table 10: Help menu and their descriptions 
Menu item Description
Help Topics Displays the help file for the modules
PDF Help Displays the PDF file adapted from the online help
About RT-EYE Displays the About box with version information

 

Saving and Recalling Files 

To save the application and oscilloscope settings to a setup file, follow these 
steps: 

1. Select File> Save. View the Save browser.  

2. The Save dialog box appears. To view details about the file, such as size, 
type, and date modified, select the Details tool. 

3. In the file browser, select the directory in which to save the setup file or use 
the current directory. 

4. Select or use the keyboard to enter a new file name. The application appends 
an ".ini" extension to the name of the application setup file. 

5. Select the  command button. 

Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application .ini file and oscilloscope .set file 
have the same file name. 
 

To recall the application and oscilloscope settings from saved setup files, follow 
these steps: 

1. Select File> Recall. View the Recall browser.  

2. The Recall dialog box appears. To view details about the file, such as size, 
type, and date modified, select the Details tool.  

3. In the Recall dialog box, select the directory from which to recall the setup 
file.  

4. Select a setup file name, and then select Open. 

Note: The application recalls the .ini setup file and the associated oscilloscope 
setup if the application can find a .set file with a matching name.  
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To recall the default application settings, select File> Recall Default. 

Note: Most of the settings for the active module are recalled to the default state.  
 

To recall a recently saved or accessed setup file, select File> Recall Recent… and 
then select the file from the drop down list of setup file names. 

Note: The application also recalls the associated oscilloscope setup if the 
application can find a .set file with a matching name.  
 

 

 

 

 

 

Taking Measurements 

Setting Preferences 

You can set preferences for the selected module. To set preferences, select File> 
Preferences from the application menu.  

The following diagram and table list the preferences that you can set for the 
Serial ATA module and their descriptions: 

 

 
CAUTION. Do not edit setup files. If you try to recall a setup file that has 
been edited, the recall operation fails.  

 
CAUTION.  If a matching .set file is not found or if the .set file does not 
recall correctly to the oscilloscope, then you are notified that the oscilloscope 
recall failed while the application recall succeeded.  

 
CAUTION. Do not edit setup files. If you try to recall a setup file that has 
been edited, the recall operation fails.  

 
CAUTION.  If a matching .set file is not found or if the .set file does not 
recall correctly to the oscilloscope, then you are notified that the oscilloscope 
recall failed while the application recall succeeded.  
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Figure 3: SATA Preferences 

Table 11: Preferences for SATA measurements 
Preference Description
Do not override the setup in BIST
FIS/User method

Enable this to use the default BIST FIS/User
method setup. The oscilloscope setup will not
be overwritten

Prompt for correct waveform
confirmation during run

Enable this to be prompted for the correct
waveform after acquiring the data

Refine filter initial condition for
SATA AC CM

Enable this to calculate the initial conditions for
the low pass filter

Overcome the filter transient
response by discarding the fixed
time constants of data

Enable this to discard a fixed number of data
points for filtering the acquired data. The first
five time constants are discarded  

Options two, three, and four are selected by default. If options three and four 
have been cleared, we recommend that you select them to get accurate results.  

If neither option is selected then, filter operation will start from an arbitrary 
sample point and filtered data can be affected by the filter transient response. The 
filter transient response depends on the initial jitter on the data. 

The following diagram and table list the preferences that you can set for the SAS 
module and their descriptions. 
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Figure 4: SAS Preferences 

Table 12: Preferences for SAS measurements 
Preference Description
Do not override the setup in BIST
FIS/User method

Enable this to use the default BIST FIS/User
method setup. The oscilloscope setup will not
be overwritten

Prompt for correct waveform
confirmation during run

Enable this to be prompted for the correct
waveform after acquiring the data

Enable Transient Time input for
clock recovery

Enable this to select the desired data point for
filtering from the acquired data. All data points
before the desired point will be discarded. You
can enter the transient time value in the
general configuration tab

Refine filter initial conditions for
SAS Eye

Enable this to calculate the initial conditions for
the low pass filter  

Options two, three, and four are selected by default. If options three and four 
have been cleared, we recommend that you select them to get accurate results for 
the Eye measurement for the SAS module.  

If neither option is selected then, filter operation will start from an arbitrary 
sample point and filtered data can be affected by the filter transient response. The 
filter transient response depends on the initial jitter on the data. 

When you select option three, the configured transient time should be greater 
than three times the number of clock transitions. The number of transitions is 550 
otherwise the application displays the error message indicating that enough UI 
edges are not available to calculate eye height. The eye generation fails to 
complete successfully. For example, in the TDS7704B oscilloscope for align.pat 
the recommended horizontal scale is > 40 ns for sufficient clock transitions. 

When you select option four, ensure that the acquired waveform has more than 
550 clock transitions otherwise the application displays the error message 
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indicating that enough UI edges are not available to calculate eye height. The eye 
generation fails to complete successfully. 

The SAS Eye measurement requires at least three data packets that has ≥ 550 
clock transitions in the acquired data to calculate clock recovery correctly. If the 
acquired pattern has insufficient clock transitions (550) then you need to acquire 
more packets for sufficient clock transitions. 

Using a Limit File 

Each module (SATA and SAS) provides a limit file that includes the 
measurements and their range of permitted values. The module uses the limit file 
to determine the Pass or Fail status for the measurements.  

To change the limit file that your module uses, select Measurements> Limits. 
Browse to the directory and select a limit file to use with a .lim file name 
extension.  

For the Serial ATA module, the files SerialATA-6k.lim and SerialATA-7k.lim 
are available for the TDS6000 and TDS7000 series of supported oscilloscopes. 
For the SAS module, the files SAS-6k.lim and SAS-7k.lim are available for the 
TDS6000 and TDS7000 series of supported oscilloscopes. 

  
Figure 5: Changing Limit Files 

Note: You must not edit the limits file. If you edit the limit file, the measurements 
will not execute. 
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Control Panel 

You use the Control Panel to start or stop the sequence of processes for the 
application and oscilloscope to acquire information from a waveform. The 
application then determines if the algorithm for the selected measurement can be 
applied to the waveform information. Sequencing is the steps to acquire 
waveform information, determine if the information is usable for the 
measurement, take the measurement, and display the results. 

  
Figure 6: Control panel 

Table 13: Control panel buttons and their descriptions 
Command button Description
Start Start command button; use to start the sequencing

based on the selected Sequence Mode
Stop Stop command button; use to stop sequencing
Clear Results Clear results command button; use to clear all

previous results in the Results Summary menu,
Results Details menu

Mode Select Mode; Single or Single No Acq  

Sequence Mode 

There are two Sequencing modes: Single Run and Single No Acq. The following 
table lists the modes and their descriptions: 
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Table 14: Sequence modes and their descriptions 
Mode Description
Single Run Acquires a new waveform if the source is Ch1, Ch2,

Ch3, or Ch4, Ref waveforms, or from file; for all
sources the application sequences until complete

Single No Acq Recalculates the selected measurements without
acquiring new data  

Acquiring Data 

To acquire data from waveforms and take measurements, follow these steps: 

1. In the Control Panel (on the right side of the application display), select a 
Sequence mode.  

2. The application uses the Sequence mode to acquire waveforms and take 
measurements when you select the Start command button. The choices are: 
Single Run and Single No Acq. 

3. Select the  button for continuous acquisitions or for measurements 
on a new or existing acquisition. 

4. If you select the Single Run or the Single No Acq mode, the application 
displays the results when the sequencing is complete. 

5. Select the  Stop button to stop the sequencing.  

Note: Use the  command button to delete all measurement results. 

Editing a Serial ATA Mask File 

The mask files for Serial ATA are located in C:\Program 
Files\TekApplications\tdsRT-Eye\lib\RTEye. The mask file name indicates the 
technology, test point, number of unit intervals, and the device usage model. For 
example, for the file SataTX250G1i.msk, "Sata" indicates the technology, "TX" 
indicates transmitter, "250" indicates the number of unit intervals, and 
"G1i"indicates the device usage model.  
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Figure 7: Example of a mask file 
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The following diagram shows a typical eye mask, the segments, and vertices.  

 
Figure 8: Example of mask template 

The Serial ATA specifications do not specify eye mask geometry. The Serial 
ATA module provides tentative mask geometry for the eye mask test. You can 
edit the mask file (.msk) and modify the segment vertices to suit your needs. You 
can open the .msk file in Notepad, and after editing, save it in the same location 
with the same file name.  

Note: Before you overwrite the mask file, ensure that you backup the file.  
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The following Serial ATA mask files are available for a transmitter and receiver: 

Transmitter mask files  Receiver mask files 

SataTX250G1i SataRX250G1i 

SataTX250G1m SataRX250G1m 

SataTX250G1x SataRX250G1x 

SataTX250G2i SataRX250G2i 

SataTX250G2m SataRX250G2m 

SataTX250G2x SataRX250G2x 

SataTX5G1i SataRX5G1i 

SataTX5G1m SataRX5G1m 

SataTX5G1x SataRX5G1x 

SataTX5G2i SataRX5G2i 

SataTX5G2m SataRX5G2m 

SataTX5G2x SataRX5G2x 
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How To... 

Set up the DUT 

Methods to Test a DUT 

You can set up the Device Under Test (DUT) and test it in two ways: using the 
Arbitrary Waveform Generator (AWG), or the BIST FIS/User-defined method.  

In the AWG method, the AWG provides an external stimulus to the DUT. The 
DUT, in turn, responds with the OOB signals and Align Patterns on which the 
Serial ATA and SAS test modules can make measurements.   

In the BIST FIS/User method, you can program the DUT to emit or transmit 
various patterns on which the Serial ATA and SAS test modules can make 
measurements. 

The following table lists the test fixture connectors and the signals that are 
connected to the test fixture: 

Table 15: Test fixture, host, and drive connections 
Test fixture
connectors

Host connections Drive connections

J2 Tx+ Rx+
J3 Tx− Rx−
J4 Rx− Tx−
J5 Rx+ Tx+  
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Test the Transmitter Host DUT using AWG Method 

To test a transmitter host device using an AWG, set up the equipment as follows: 

  
Figure 9: Test the transmitter host DUT using AWG method 

You can use SMA cables or P7380SMA cables to connect the DUT to the 
oscilloscope and the AWG.  

For a Host as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� AWG Marker 1 to J5 (Rx+) 

� AWG Marker 2 to J4 (Rx−) 

� Oscilloscope Channel 1 to J2 (Tx+) 

� Oscilloscope Channel 3 to J3 (Tx−) 
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Figure 10: Test the transmitter host DUT using AWG method 

For a Host as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� AWG Marker 1 to J5 (Rx+) 

� AWG Marker 2 to J4 (Rx−) 

� Oscilloscope Channel 1 or 3 to J2 (Tx+) or J3 (Tx−) 

Note: If you use oscilloscope channels 1 and 3 for Tx+ and Tx−, then use 
oscilloscope channels 2 or 4 as trigger. If you use oscilloscope channels 2 and 4 
for Tx+ and Tx−, then use oscilloscope channels 1 or 3 as trigger. 
 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Transmitter Drive DUT using AWG Method 

To test a transmitter drive device using an AWG, set up the equipment as 
follows: 

 

  
Figure 11: Test the transmitter drive DUT using AWG method 

You can use SMA cables or P7380SMA cables to connect the DUT to the 
oscilloscope and the AWG.  

For a Drive as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� AWG Marker 1 to J2 (Rx+) 

� AWG Marker 2 to J3 (Rx−) 

� Oscilloscope Channel 1 to J5 (Tx+) 

� Oscilloscope Channel 3 to J4 (Tx−) 
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Figure 12: Test the transmitter drive DUT using AWG method 

For a Drive as the DUT, connect the P7380SMA cables (differential single-ended 
probes) as follows: 

� AWG Marker 1 to J2 (Rx+) 

� AWG Marker 2 to J3 (Rx−) 

� Oscilloscope Channel 1 or 3 to J5 (Tx+) and J4 (Tx−) 

Note: If you use oscilloscope channels 1 and 3 for Tx+ and Tx−, then use 
oscilloscope channels 2 or 4 as trigger. If you use oscilloscope channels 2 and 4 
for Tx+ and Tx−, then use oscilloscope channels 1 or 3 as trigger. 
 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Transmitter Host DUT using BIST FIS/User Method 

To test a transmitter host device using a vendor-specific method (or BIST FIS), 
set up the equipment as follows: 

  
Figure 13: Test the transmitter host DUT using BIST FIS/User method 

For a Host as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� Oscilloscope Channel 1 to J2 (Tx+) 

� Oscilloscope Channel 3 to J3 (Tx−) 
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Figure 14: Test the transmitter host DUT using BIST FIS/User method 

For a Host as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� Oscilloscope Channel 1 or 3 to J2 (Tx+) or J3 (Tx−) 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Transmitter Drive DUT using BIST FIS/User Method 

To test a transmitter drive device using a vendor-specific method (or BIST FIS), 
set up the equipment as follows: 

  
Figure 15: Test the transmitter drive DUT using BIST FIS/User method 

For a Drive as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� Oscilloscope Channel 1 to J5 (Tx+) 

� Oscilloscope Channel 3 to J4 (Tx−) 
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Figure 16: Test the transmitter drive DUT using BIST FIS/User method 

For a Drive as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� Oscilloscope Channel 1 or 3 to J5 (Tx+) and J4 (Tx−) 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Receiver Host DUT using AWG Method 

To test a receiver host device using an AWG, set up the equipment as follows: 

  
Figure 17: Test the receiver host DUT using AWG method 

You can use SMA cables or P7380SMA cables to connect the DUT to the 
oscilloscope and the AWG.  

For a Host as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� AWG Marker 1 to J5 (Rx+) 

� AWG Marker 2 to J4 (Rx−) 

� Oscilloscope Channel 1 to J2 (Tx+) 

� Oscilloscope Channel 3 to J3 (Tx−) 
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Figure 18: Test the receiver host DUT using AWG method 

For a Host as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� AWG Marker 1 to J5 (Rx+) 

� AWG Marker 2 to J4 (Rx−) 

� Oscilloscope Channel 1 or 3 to J2 (Tx+) or J3 (Tx−) 

Note: If you use oscilloscope channels 1 and 3 for Tx+ and Tx−, then use 
oscilloscope channels 2 or 4 as trigger. If you use oscilloscope channels 2 and 4 
for Tx+ and Tx−, then use oscilloscope channels 1 or 3 as trigger. 
 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Receiver Drive DUT using AWG Method 

To test a receiver drive device using an AWG, set up the equipment as follows: 

  
Figure 19: Test the receiver drive DUT using AWG method 

For a Drive as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� AWG Marker 1 to J2 (Rx+) 

� AWG Marker 2 to J3 (Rx−) 

� Oscilloscope Channel 1 to J5 (Tx+) 

� Oscilloscope Channel 3 to J4 (Tx−) 
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Figure 20: Test the receiver drive DUT using AWG method 

For a Drive as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� AWG Marker 1 to J2 (Rx+) 

� AWG Marker 2 to J3 (Rx−) 

� Oscilloscope Channel 1 or 3 to J5 (Tx+) and J4 (Tx−) 

Note: If you use oscilloscope channels 1 and 3 for Tx+ and Tx−, then use 
oscilloscope channels 2 or 4 as trigger. If you use oscilloscope channels 2 and 4 
for Tx+ and Tx−, then use oscilloscope channels 1 or 3 as trigger. 
 

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Receiver Host DUT using BIST FIS/User Method 

To test a receiver host device using a vendor-specific method (or BIST FIS), set 
up the equipment as follows: 

  
Figure 21: Test the receiver host DUT using BIST FIS/User method 

For a Host as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� Oscilloscope Channel 1 to J2 (Rx+) 

� Oscilloscope Channel 3 to J3 (Rx−) 
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Figure 22: Test the receiver host DUT using BIST FIS/User method 

For a Host as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� Oscilloscope Channel 1 to J2 and J3  

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Test the Receiver Drive DUT using BIST FIS/User Method 

To test a receiver drive device using a vendor-specific method (or BIST FIS), set 
up the equipment as follows: 

  
Figure 23: Test the receiver drive DUT using BIST FIS/User method 

For a Drive as the DUT, connect the SMA cables (single-ended probes) as 
follows: 

� Oscilloscope Channel 1 to J5 (Tx+) 

� Oscilloscope Channel 3 to J4 (Tx−) 
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Figure 24: Test the receiver drive DUT using BIST FIS/User method 

For a Drive as the DUT, connect the P7380SMA cables (differential probes) as 
follows: 

� Oscilloscope Channel 1 to J4 and J5  

Note: When you use a P7380SMA probe, and if the peak-to-peak signal 
amplitude is more than 625 mV, set Attenuation Dynamic Range of the probe to 
12.5X. If the signal peak to peak amplitude is less than 625 mV, set Attenuation 
Dynamic Range of the probe to 2.5X. Ensure that the V term Source is set to 
Auto. 
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Select and Configure SATA Measurements 

Select SATA Measurements 

To select a measurement, select Measurements> Select from the menu bar. The 
following screen appears:  

  
Figure 25: Measurements screen 

The Serial ATA measurements that are available for transmitter and receiver 
devices are as follows:  

Table 16: SATA measurements for transmitter and receiver 
MeasurementsDevice

Timing Amplitude Out Of Band
Transmitter Eye, Bit Rate,

Differential Skew*, Rise
and Fall Time, Unit
Interval

Differential
Voltage, AC CM
Voltage*

COMINIT,
COMWAKE,
COMRESET

Receiver Eye, Bit Rate,
Differential Skew*, Rise
and Fall Time, Unit
Interval

Differential
Voltage, AC CM
Voltage*

−

* These measurements are available only when you use a single-ended probe
(SMA cable).  

You can select one or more Timing measurements at a time by clicking the 
buttons. You can select all Timing measurements by clicking the Select All 
button. 
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Configure SATA Measurements 

To configure one or more measurements, select Measurements> Configure from 
the application menu bar, or click the Configure button in the Measurement 
screen.  

The Configure screen has the following tabs: Source, General Config, Clock 
Config, and Plot Config. The Plot Config tab, with parameters to generate an eye 
diagram, is available only for the Eye Measurement.  

 
Figure 26: Configure Source panel for a single-ended probe 

 
Figure 27: Configure Source panel for a differential probe 
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Figure 28: Configure General Config panel 

 
Figure 29: Configure Clock Config panel 
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Figure 30: Configure Plot Config panel 

The following table lists the configuration parameters for the Serial ATA 
measurements:  
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Enter Device Details 

You can enter the details of the device that you are testing.  

 
Figure 31: Enter device details 

To do this, follow these steps: 

1. Select Measurements> Select from the application menu. 

2. Under Device, type the device ID that you want to use. You can also use the 
virtual keyboard to enter the text. 

3. Click Edit Description to type in a description of the device or edit an 
existing description. You can also use the virtual keyboard to enter the text.  

Virtual Keyboard 

Virtual Keyboard - Numeric 

1. Click any number box to display the icon for the numeric keyboard. 

2. Click the icon to display the numeric keyboard. 
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Figure 32: Virtual keyboard - Numeric 

3. Click the number keys to enter the desired value. 

4. Select a unit of measure. 

5. Click Enter to confirm your entry. Selections are not effective until you 
click Enter. 

Virtual Keyboard - Text 

1. Click any text box to display the icon for the text keyboard. 

2. Click the icon to display the text keyboard. 
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Figure 33: Virtual keyboard - Text 

3. Use the text keyboard to enter the required text (such as a file name). 

4. Click Enter to confirm your entry. Selections are not effective until you 
click Enter. 

Set up the AWG 
You can set up the Arbitrary Waveform Generator (AWG) in three ways: GPIB, 
Network, and Manual. From the Source tab, select the Test method as AWG and 
click Setup. The following options are available: 

Table 17: AWG setup modes 
Options To Do
Network Connect to the AWG using the LAN or peer-to-peer

and set up the connection automatically
GPIB Connect to the AWG using the GPIB and set up the

connection automatically
Manual Connect to the AWG manually

 
To connect to and set up the AWG using the Network option, follow these steps: 

1. Click Network from the AWG Setup screen.  

2. Enter the IP Address of the AWG. 

3. Select the AWG Drive (Floppy or Main) on which the source pattern files 
for the test is located.  
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4. Click Test Connection to verify whether the oscilloscope is connected 
correctly to the AWG. When you click Test Connection, the application: 

� Detects the AWG model  

� Sets the AWG marker values 

� Sets the AWG clock speed 

To connect to and set up the AWG using the GPIB option, follow these steps: 

1. Click GPIB from the AWG Setup screen.  

2. Select the Board Type, GPIB Address (Primary and Secondary), and the 
Time Out value. 

3. Select the AWG Drive (Floppy or Main) on which the source pattern files 
for the test is located.  

4. Click Test Connection to verify whether the oscilloscope is connected 
correctly to the AWG. When you click Test Connection, the application: 

� Detects the AWG model  

� Sets the AWG marker values 

� Sets the AWG clock speed 

To connect to and set up the AWG using the Manual option, follow these steps: 

1. Click Manual from the AWG Setup screen.  

2. Select the AWG Type from the AWG Setup screen. 

3. Follow the on-screen prompts to connect the AWG and the oscilloscope. 

Perform SATA Tests for Transmitter 

Transmitter Measurements 

Timing measurements that are available for a Serial ATA Transmitter are Eye, 
Bit Rate, Differential Skew, Rise and Fall Time, and Unit Interval. You can 
select one or more measurements at a time. You can select all measurements by 
clicking the Select All button. The Differential Skew measurement is available 
only when you use a single-ended probe (SMA cable).  

Amplitude measurements that are available for a Serial ATA Transmitter are 
Differential Voltage and AC CM Voltage. The AC CM Voltage measurement is 
available only when you use a single-ended probe (SMA cable). 
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Out Of Band (OOB) Signaling Tests are available for a Serial ATA Transmitter. 
The OOB tests that are supported by the Serial ATA module are COMINIT, 
COMWAKE, and COMRESET. 

Perform Transmitter Eye, Unit Interval, and Bit Rate Tests 
Follow these steps to measure the Eye, Unit Interval, and Bit Rate for a 
transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Transmitter and Probe Type as Single-ended or 
Differential. 

4. Click Eye, Unit Interval, and Bit Rate. You can select any one or all of 
them.  

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−, and the Trigger channel. The 
trigger channels available exclude those channels that you have selected as 
D+ D−. Select the Test Method. For the BIST FIS/User test method, Trigger 
option is not available. 
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Table 18: Source parameters for a single-ended probe 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
For a differential probe, the source parameters are: 

Table 19: Source parameters for a differential probe 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel from which to acquire data, then 
the Trigger selection is not available. 

In the General Config tab, set the Device Type, Usage model, Number of UI, and 
Cable Attenuation.  
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Table 20: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
In the Clock Config tab, set the Clock Recovery parameters, and Analysis 
Window size.  

Table 21: Clock configuration parameters 
Parameter Options To do
Window Size Range: 1000-5000 UI Type the clock recovery

window size or enter the value
from the numeric keypad

Scan Incr Range: 1-250 UI Type the scan increment value
or enter it from the numeric
keypad

Method Const Clk: Mean
Const Clk: Median

Select the clock recovery
method to use to recover the
signal clock

Analysis Window 250 UI, 5 UI Set the analysis window to one
of the two

 

Note: If the Analysis Window is set to 5 UI, sufficient number of unit intervals 
may not be available to calculate the transition and non-transition eye heights. 
While scanning, these two calculations may fail to complete. You can expect the 
message "Unable to calculate transition eye height/non-transition eye height". It 
is recommended that you select All Bits option in the plot configuration when the 
Analysis Window is 5 UI. 
 

 

6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results and plots are 
displayed. 
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8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 

Perform Transmitter Differential Skew Test 
Follow these steps to measure the Differential Skew for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. Refer to the setup that uses single-ended probes (SMA cable).  

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Transmitter and Probe Type as Single-ended. This 
measurement is not available for a Differential probe. 

4. Click Differential Skew. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. Select the Test Method. For the 
BIST FIS/User test method, Trigger option is not available. 
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Table 22: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
In the General Config tab, set the Device Type, Cable Attenuation, and Usage 
model. 
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Table 23: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

Test Method AWG, BIST FIS/User Select the test method to
use. The module uses the
source pattern files located
on the AWG, or uses a
vendor-specific method to
test the DUT

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 

Perform Transmitter Rise and Fall Time Test 
Follow these steps to measure the Rise and Fall Time for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Transmitter and Probe Type as Single-ended or 
Differential.  

4. Click Rise and Fall Time. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  
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In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−, and the Trigger channel. The 
trigger channels available exclude those channels that you have selected as 
D+ D−. Select the Test Method. For the BIST FIS/User test method, Trigger 
option is not available. 

Table 24: Source configuration parameters for a single-ended probe 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files
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For a differential probe, the parameters are: 

Table 25: Source configuration parameters for a differential probe 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel from which to acquire data, then 
the Trigger selection is not available.  

In the General Config tab, set the Device Type, Cable Attenuation, Number of 
UI, and Usage model.  

Table 26: General configuration 
Parameter Options To Do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k,12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 
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Perform Transmitter Differential Voltage Test 
Follow these steps to measure the Differential Voltage for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar. 

3. Select Test Point as Transmitter and Probe Type as Single-ended or 
Differential. 

4. Click Differential Voltage. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−. Select the Test Method. 
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Table 27: Source configuration parameters 
Select Parameter Options To Do
Test Method BIST FIS/User Select the test method

BIST FIS/User to use.
The AWG method is not
available for this
measurement

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Ref Select D+ D− Ref1 Ref2, Ref1Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File
Prefix

Browse Set the path and
alphanumeric prefix for
the files that you want to
load

File Type CSV, wfm Select the type of file that
you want to load. The
application uses the File
Prefix and the .wfm or
.csv file name extension
to search for the specified
file type

Help Select the Help button to
get a brief description of
how to load files with a
prefix and specified type
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For a differential probe, the source parameters are: 

Table 28: Source configuration parameters 
Select Parameter Options To Do
Test Method BIST FIS/User Select the test method

BIST FIS/User to use.
The AWG method is not
available for this
measurement

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel from
which to acquire data

File Select File
Prefix

Browse Set the path and
alphanumeric prefix for
the files that you want to
load

File Type CSV, wfm Select the type of file that
you want to load. The
application uses the File
Prefix and the .wfm or
.csv file name extension
to search for the specified
file type

Help Select the Help button to
get a brief description of
how to load files with a
prefix and specified type
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When you click the Help button, the following help text is displayed. It describes 
how the module uses the File Prefix and the File Type that you specified to 
search for the pattern files. Ensure that four pattern files: HFTP.csv, MFTP.csv, 
LFTP.csv, and LBP.csv, are present in the path you specified. 

  
Figure 34: Help screen for differential output voltage measurement 
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In the General Config tab, set the Device Type, Cable Attenuation, Usage model, 
Number of UI, and Differential Volt Option.  

Table 29: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

Diff Volt Option Option1, Option2 Select Option1 to use the
lone bit pattern, and Option2
to if no lone bit pattern is
available

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. The Time Units option is the results summary is not 
available for this test. To view detailed results, select Results> Details. 

The following warnings might appear while performing this test. The possible 
solutions and explanations are also given. 

� Min. Voltage sample criteria failed. For details refer OLH.  
Solution: Increase the number of unit intervals and try again. 

� Max. Voltage sample criteria failed. For details refer OLH.  
Solution: Increase the number of unit intervals and try again. 

� LBP pattern mismatch. Performing Minimum voltage measurement 
using Option 2. 
Explanation: If LBP pattern is not available or not compliant, the application 
performs the measurement using differential voltage Option2. 

� The input pattern is not spec-compliant. The software selected 
compliant bit transitions in order to approximate the differential 
voltage measurement. 
Explanation: When the input pattern does not match with the standard 
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definition, the application approximates the pattern definition and displays 
the results.  

Perform Transmitter AC CM Voltage Test 
Follow these steps to measure the AC Common Mode Voltage for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. Refer to the setup that uses single-ended probes.  

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Transmitter and Probe Type as Single-ended.  

4. Click AC CM Voltage. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. Select the Test Method.  
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Table 30: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
In the General Config tab, set the Device Type, Cable Attenuation, Usage model, 
and Number of UI.  

Table 31: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. The Time Units option is the results summary is not 
available for this test. To view detailed results, select Results> Details. 
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Perform Transmitter COMINIT, COMWAKE, and COMRESET Tests 
Follow these steps to perform the COMINIT, COMWAKE, and COMRESET 
Tests for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. Refer to the test setup for transmitter device that uses the AWG test 
method.  

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Transmitter and Probe Type as Single-ended or 
Differential.  

4. Click any one of the OOB tests: COMINIT, COMWAKE, or COMRESET.  

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live. If you are using a single-ended probe, select 
the channels for D+ and D−, and the Trigger channel. The trigger channels 
available exclude those channels that you have selected as D+ D−. Select the 
Test Method. 
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Table 32: Source configuration parameters 
Probe Type Parameter Options To Do
Test Method AWG Select the test method to

connect to and set up the
AWG

Single-ended Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Differential Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

 

Note: Trigger is not available for the combination⎯COMRESET test for Device 
Type as host and OOB Type as Inter-burst. 
 

In the General Config tab, set the Device Type, Usage model, and 
COMINIT/COMWAKE/ COMRESET Type. 

Table 33: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

OOB Type In Spec, Out Of Spec, Inter Burst Select the type of OOB test
to perform

 
6. From the Control panel, select the mode as Single Run or Single No Acq. 

The Single No Acq mode works similar to the Single Run mode. 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details.  
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Perform SATA Tests for Receiver 

Receiver Measurements 

Timing measurements that are available for a Serial ATA Receiver are Eye, Bit 
Rate, Differential Skew, Rise and Fall Time, and Unit Interval. You can select 
one or more measurements at a time. You can select all measurements by 
clicking the Select All button. The Differential Skew measurement is available 
only when you use a single-ended probe. 

Amplitude measurements that are available for a Serial ATA Receiver are 
Differential Voltage and AC CM Voltage. The AC CM Voltage measurement is 
available only when you use a single-ended probe.  

Perform Receiver Eye, Unit Interval, and Bit Rate Tests 
Follow these steps to measure the Eye, Unit Interval, and Bit Rate for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section.  

2. Select Measurements> Select from the menu bar. 

3. Select Test Point as Receiver and Probe Type as Single-ended or 
Differential. 

4. Click Eye, Unit Interval, and Bit Rate. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−, and the Trigger channel. The 
trigger channels available exclude those channels that you have selected as 
D+ D−. 
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Table 34: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
For a differential probe, the source parameters are: 

Table 35: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel from which to acquire data, then 
the Trigger selection is not available. 
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In the General Config tab, set the Usage model, Device Type, Cable Attenuation, 
and select the Test Method. 

Table 36: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
In the Clock Config tab, set the Clock Recovery parameters, and Analysis 
Window size.  

Table 37: Clock configuration parameters 
Parameter Options To do
Window Size Range: 1000-5000 UI Type the clock recovery

window size or enter the value
from the numeric keypad

Scan Incr Range: 1-250 UI Type the scan increment value
or enter it from the numeric
keypad

Method Const Clk: Mean,
Const Clk: Median

Select the clock recovery
method to use to recover the
signal clock

Analysis Window 250 UI, 5 UI Set the analysis window to one
of the two

 
If you have selected Eye, in the Plot Config tab, set the parameters to plot the 
Eye diagram. 

Table 38: Plot configuration parameters 
Parameter To Do
Transition and Non-Transition Bits Plot the transition and non-transition bits as two

separate eye diagrams
All Bits Plot all bits (transition and non-transition) in a

single eye diagram
 

6. From the Control panel, select the mode (Single Run or Single No Acq). 
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7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. For an 
Eye measurement, you can view a plot of the transition and non-transition 
bits as separate plots or all bits as a single plot.  

Perform Receiver Differential Skew Test 
Follow these steps to measure the Differential Skew for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar. 

3. Select Test Point as Receiver and Probe Type as Single-ended.  

4. Click Differential Skew. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. Select the Test Method. 
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Table 39: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
In the General Config tab, set the Usage model, Device Type, Number of Unit 
Intervals, Cable Attenuation.  

Table 40: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation or
enter the value with the range
from the numeric keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 
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Perform Receiver Rise Time and Fall Time Test 
Follow these steps to measure the Rise and Fall Time for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Receiver and Probe Type as Single-ended or 
Differential.  

4. Click Rise and Fall Time. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−, and the Trigger channel. The 
trigger channels available exclude those channels that you have selected as 
D+ D−. Select the Test Method. 

Table 41: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files
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For a differential probe, the source parameters are: 

Table 42: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel from which to acquire data, then 
the Trigger selection is not available. 

In the General Config tab, set the Device Type, Usage model, and Number of UI.  

Table 43: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq) 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 
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Perform Receiver Differential Voltage Test 
Follow these steps to measure the Differential Voltage for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar. 

3. Select Test Point as Receiver and Probe Type as Single-ended or 
Differential. 

4. Click Differential Voltage. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 
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In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe, select the channels for D+ and D−. Select the Test Method. 

Table 44: Source configuration parameters 
Select Parameter Options To Do
Test Method BIST FIS/User Select the test method

BIST FIS/User to use.
The AWG method is not
available for this
measurement

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File
Prefix

Browse Set the path and
alphanumeric prefix for
the files that you want to
load

File Type CSV, wfm Select the type of file that
you want to load. The
application uses the File
Prefix and the .wfm or
.csv file name extension
to search for the specified
file type

Help Select the Help button to
get a brief description of
how to load files with a
prefix and specified type
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For a differential probe, the source parameters are: 

Table 45: Source configuration parameters 
Select Parameter Options To Do
Test Method BIST FIS/User Select the test method

BIST FIS/User to use.
The AWG method is not
available for this
measurement

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel to
acquire data from

File Select File
Prefix

Browse Set the path and
alphanumeric prefix for
the files that you want to
load

File Type CSV, wfm Select the type of file that
you want to load. The
application prefixes the
File Prefix you entered to
and searches for the
specified file type

Help Select the Help button to
get a brief description of
how to load files with a
prefix and specified type
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When you click the Help button, the following help text is displayed. It describes 
how the module uses the File Prefix and the File Type that you specified to 
search for the pattern files. Ensure that four pattern files: HFTP.csv, MFTP.csv, 
LFTP.csv, and LBP.csv, are present in the path you specified. 

  
Figure 35: Help screen for differential output voltage measurement 
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In the General Config tab, set the Device Type, Cable Attenuation, Usage model, 
Number of UI, and Differential Volt Option. 

Table 46: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

Diff Volt Option Option1, Option2 Select Option1 to use the
lone bit pattern, and Option2
to if no lone bit pattern is
available

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. The Time Units option is the results summary is not 
available for this test. To view detailed results, select Results> Details. 

The following warnings might appear while performing this test. The possible 
solutions and explanations are also given. 

� Min. Voltage sample criteria failed. For details refer OLH.  
Solution: Increase the number of unit intervals and try again. 

� Max. Voltage sample criteria failed. For details refer OLH.  
Solution: Increase the number of unit intervals and try again. 

� LBP pattern mismatch. Performing Minimum voltage measurement 
using Option 2. 
Explanation: If LBP pattern is not available or not compliant, the application 
performs the measurement using differential voltage Option2. 

� The input pattern is not spec-compliant. The software selected 
compliant bit transitions in order to approximate the differential 
voltage measurement. 
Explanation: When the input pattern does not match with the standard 
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definition, the application approximates the pattern definition and displays 
the results.  

Perform Receiver AC CM Voltage Test 
Follow these steps to measure the AC Common Mode Voltage for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as Receiver and Probe Type as Single-ended.  

4. Click AC CM Voltage. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. For the BIST FIS/User test 
method, Trigger option is not available. Select the Test Method. 
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Table 47: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
file

 
In the General Config tab, set the Device Type, Cable Attenuation, Usage model, 
and Number of UI.  

Table 48: General configuration parameters 
Parameter Options To do
Usage Model Gen1i, Gen1x, Gen1m,

Gen2i, Gen2x, Gen2m
Select the generation to
which the device belongs

Device Type Host, Drive Select the type of device to
test

Num of UI 6k, 12k, 30k, 60k, 120k Select the number of unit
intervals for which to acquire
data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. The Time Units option is the results summary is not 
available for this test. To view detailed results, select Results> Details. 
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View SATA Test Results 

Summary Results 

You can view the summary results of the measurements by selecting Results> 
Summary. The application displays results for the measurements for the current 
acquisition. 

The Results Summary menu shows the current data and all acquisition data for 
each statistical value.  

The Results Summary menu displays the following information as a table. 
Wherever measurement limits are not available, those fields in the table are 
blank. 

Table 49: Results Summary table 
Option Description
Measurement Displays the selected measurements
Statistic Displays the type of statistic used
Value Displays the measured value of the measurement
Lower Lim Displays the measured lower limit of the

measurement
Upper Lim Displays the measured upper limit of the

measurement
Status Displays the status of the measurement as Pass or

Fail
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Other options in the Results Summary screen include:  

Table 50: Results Summary options 
Option Description
Show Plot Displays the plot of the eye diagram
Worst Case Eye Displays all the worst cases for high rail, low rail, top

margin, bottom margin, and jitter
Details Shortcut to the Results Details menu
Time Units Displays results in Unit Intervals or seconds

 

Detailed Results 

You can view the detailed results of the measurements by selecting Results> 
Details. The application displays results for the measurements for the current 
acquisition. 

For a selected measurement, the Results Details menu displays the following 
information as a table. Wherever measurement limits are not available, those 
fields in the table are blank. 

Table 51: Results Details table 
Option Description
Result, Statistic Displays the different statistics for the

measurement⎯Population, Mean, Standard Deviation,
Maximum, Minimum, Peak-Peak Value.

Value Displays the measured value of the measurement
Lower Lim Displays the measured lower limit of the measurement
Upper Lim Displays the measured upper limit of the measurement
Status Displays the status of the measurement as Pass or Fail
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Other options in the Results Details screen include:  

Table 52: Results Details options 
Option Description
Show Plot Displays the plot of the eye diagram
Worst Case Eye Displays all the worst cases for high rail, low rail, top

margin, bottom margin, and jitter
Details Shortcut to the Results Details menu
Time Units Displays results in Unit Intervals or seconds
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Eye Results 

You can view the eye results of the measurements by selecting Results> 
Summary or Results> Details. The application displays results for the eye 
measurement for the current acquisition.  

  
Figure 36: Eye result details with transition and non-transition bits 

You can also view this by clicking the Show Plot button in the Results Summary 
or Results Details screen. If you have selected the Transition and Non-transition 
Bits option in the plot configuration tab, then the application displays the data 
acquired in two separate plots. If you have selected the All Bits option, then the 
application displays the data acquired in one plot.  
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Figure 37: Eye result summary with all bits 
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Figure 38: Eye Results 
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In the figure, the following buttons are available. 

Table 53: Eye Results 
Options Description
All Eyes Click All Eyes to display all the worst cases for high rail,

low rail, top margin, bottom margin, and jitter
High Rail Click High Rail to display the worst case signal values

(maximum overshoot) at the high rail or top mask
Low Rail Click Low Rail to display the worst case signal values

(maximum overshoot) at the low rail or bottom mask
Top Margin Click Top Margin to display the worst case signal values

(maximum undershoot) at the top margin of the middle
mask

Bottom Margin Click Bottom Margin to display the worst case signal
values (maximum undershoot) at the bottom margin of
the middle mask

Jitter Click Jitter to display the worst case jitter values at the
crossovers

 
The eye results are displayed in a table that shows the statistic, the upper and 
lower limits, and the status (pass/fail) of the measurement. 

Select Results> Worst Case Eye from the menu or click the Worst Case Eye 
button. This shows all the worst cases⎯Worst Top Margin, Worst Bottom 
Margin, Worst Upper Rail, Worst Lower Rail, and Worst Jitter.  
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Figure 39: Eye plot of Worst Case 

Results Plot 

The following figure displays the Eye plot for transition bits. You can view this 
plot if you have set the option−Transition and Non-Transition Bits−in 
Configure> Plot Config.  
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Figure 40: Eye plot of transition bits 

The following figure displays the Eye plot for non-transition bits. You can view 
this plot if you have set the option−Transition and Non-Transition Bits−in 
Configure> Plot Config. 

 
Figure 41: Eye plot of non-transition bits 
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The following figure displays the Eye plot for All bits. You can view this plot if 
you have set the option−All Bits−in Configure> Plot Config. 

 
Figure 42: Eye plot of All bits 

Bit Rate Results for a SATA Device 

  
Figure 43: Bit Rate result details 
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Differential Skew Results for a SATA Device 

  
Figure 44: Differential Skew result details 

Rise and Fall Time Results for a SATA Device 

  

Figure 45: Rise Time result details 
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Figure 46: Fall Time result details 

Unit Interval Results for a SATA Device 

  
Figure 47: Unit Interval result details 
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Differential Voltage Results for a SATA Device 

  
Figure 48: Differential Voltage result summary 

  
Figure 49: Differential Voltage (maximum voltage) result details 
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Figure 50: Differential Voltage (minimum voltage) result details 
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AC CM Voltage Results for a SATA Device 

  
Figure 51: AC CM Voltage result summary 

  
Figure 52: AC CM Voltage result details 
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COMINIT Results for a SATA Device 

  
Figure 53: COMINIT result summary 

  
Figure 54: COMINIT result details 
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COMWAKE Results for a SATA Device 

 
Figure 55: COMWAKE result summary 

  
Figure 56: COMWAKE result details 
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COMRESET Results for a SATA Device 

  
Figure 57: COMRESET result summary 

  
Figure 58: COMRESET result details 
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Select and Configure SAS Measurements 

Select SAS Measurements 

To select a measurement, select Measurements> Select from the menu bar. The 
following screen is displayed: 

  
Figure 59: SAS measurements for receiver 

 
Figure 60: SAS measurements for transmitter 
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The SAS measurements that are available for transmitter and receiver devices are 
as follows: 

Table 54: SAS measurements for transmitter and receiver devices 
MeasurementsDevice

Timing Out Of Band
Transmitter
(Test points⎯IT,
CT, XT)

Rise and Fall Time,
Differential Skew*

COMINIT, COMWAKE,
COMRESET

Receiver
(Test points⎯IR,
CR, XR)

Eye, Bit Rate, Rise
and Fall Time,
Differential Skew*

−

* Available only when you use a single-ended probe.
 

The test points for a transmitter are: IT (internal connector), CT (external 
connector), and XT (expander). The test points for a receiver are: IR (internal 
connector), CR (external connector), and XR (expander).  

Configure SAS Measurements 

To configure one or more measurements, select Measurements> Configure from 
the application menu bar, or click the Configure button in the Measurement 
screen.  

The Configure screen has the following tabs: Source, General Config, and Plot 
Config. The Plot Config tab, with parameters to generate an eye diagram, is 
available only for the Eye Measurement. 

 
Figure 61: Configure Source panel for a single-ended probe 
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Figure 62: Configure Source panel for a differential probe 

 
Figure 63: General configuration 
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Figure 64: Plot parameters 
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The following table lists the configuration parameters for the SAS measurements: 
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Perform SAS Tests for Transmitter 

Transmitter Measurements 

The measurements that are available for a SAS Transmitter are Rise and Fall 
Time and Differential Skew.  

Out Of Band (OOB) Signaling Tests are available for a SAS Transmitter. The 
OOB tests that are supported by the SAS module are COMINIT, COMWAKE, 
and COMRESET. 

Perform Transmitter Rise Time and Fall Time Test 
Follow these steps to measure the Rise and Fall Time for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as IT, CT, or XT and Probe Type as Single-ended or 
Differential.  

4. Click Rise and Fall Time. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe (SMA cable), select the channels for D+ and D−, and the Trigger 
channel. The trigger channels available exclude those channels that you 
have selected as D+ D−. Select the Test Method to use. 
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Table 55: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
For a differential probe, the source parameters are: 

Table 56: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel from which to acquire data, then 
the Trigger selection is not available.  
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In the General Config tab, set the Device Type, Cable Attenuation, Usage model, 
and Clock Method. 

Table 57: General configuration parameters 
Parameter Options To Do
Usage Model 1.5 Gbps, 3.0 Gbps Select the speed at which

the device transmits or
receives data

Device Type Initiator, Target, Expander* Select the type of device to
test

Clock Method Const Clk: Mean,
Const Clk: Median

Select the clock recovery
method to use to recover the
signal clock

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

* The option, Expander, is the only available option when the test point chosen is
XT.

 
6. From the Control panel, select the mode (Single Run or Single No Acq).  

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 

Perform Transmitter Differential Skew Test 
Follow these steps to measure the Differential Skew for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as IT, CT, or XT and Probe Type as Single-ended.  

4. Click Differential Skew. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. Select the Test Method. 
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Table 58: Source configuration parameters 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
from which to acquire
data

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
In the General Config tab, set the Device Type, Cable Attenuation, and Usage 
model.  

Table 59: General configuration parameters 
Parameter Options To do
Device Type Initiator, Target Select the type of device to

test
Usage Model 1.5 Gbps, 3.0 Gbps Select the speed at which

the device transmits or
receives data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 
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Perform Transmitter COMINIT, COMWAKE, and COMRESET Tests 
Follow these steps to perform the COMINIT, COMWAKE, and COMRESET 
Tests for a transmitter.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as IT or CT, and Probe Type as Single-ended or 
Differential.  

4. Click any one of the OOB tests: COMINIT, COMWAKE, or COMRESET.  

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 
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In the Source tab, click Live. If you are using a single-ended probe (SMA 
cable), select the channels for D+ and D−, and the Trigger channel. The 
trigger channels available exclude those channels that you have selected as 
D+ D−. Select the Test Method. 

Table 60: Probe type 
Probe Type Parameter Options To Do

Test Method AWG Select the test method to
connect to and set up the
AWG

Single-ended Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair from
which to acquire data fro

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

Differential Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel from
which to acquire data

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel from
which to acquire trigger
data

 

Note: Trigger is not available for the combination⎯COMRESET test for Device 
Type as host and OOB Type as Inter-burst. 
 

In the General Config tab, set the Device Type, Usage model, and 
COMINIT/COMWAKE/ COMRESET Type. 

Table 61: General Config tab 
Parameter Options To do
Device Type Initiator, Target Select the type of device to

test
Usage Model 1.5 Gbps, 3.0 Gbps Select the speed at which

the device transmits or
receives data

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

OOB Type In Spec, Out Of Spec, Inter Burst Select the type of OOB test
to perform

 
6. From the Control panel, select the mode as Single Run or Single No Acq. 

The Single No Acq mode works similar to the Single Run mode. 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 
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8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details.  

Perform SAS Tests for Receiver 

Receiver Measurements 

Measurements that are available for a SAS Receiver are Eye, Bit Rate, Rise and 
Fall Time, and Differential Skew. You can select one measurement at a time.  

Perform Receiver Eye and Bit Rate Tests 
Follow these steps to measure the Eye, Bit Rate, or both for a receiver:  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as IR, CR, XR, and Probe Type as Single-ended or 
Differential.  

4. Click Eye and Bit Rate.  

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe (SMA cable), select the channels for D+ and D−, and the Trigger 
channel. The trigger channels available exclude those channels that you 
have selected as D+ D−. Select the Test Method. 
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Table 62: Source tab 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
files
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In the General Config tab, set the Device Type, Usage model, Clock Recovery 
Method, Cable Attenuation and Transient Time.  

Table 63: General Config tab 
Parameter Options To do
Usage Model 1.5 Gbps, 3.0 Gbps Select the speed at which

the device transmits or
receives data

Device Type Initiator, Target, Expander* Select the type of device to
test

Clock Method Const Clk: Mean,
Const Clk: Median

Select the clock recovery
method to use to recover the
signal clock

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

Transient Time** .25 - 10 time constants The transient time value
should be at least five times
the acquisition duration.

Type the transient time or
enter the value within the
range from the numeric
keypad. The corresponding
settling time of Unit Intervals
will be removed from the
filtered data

* The Expander option is the only available option when the XR test point is
chosen.
** Available for Eye measurement only if enabled in the Preferences.

 
If you have selected Eye, in the Plot Config tab, set the parameters to plot the 
Eye diagram. If you have selected Eye, and in the Preferences menu, selected 
Enable Transient Response input for clock recovery, you can enter the Transient 
Time. 
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Table 64: Plot Config tab 
Parameter To Do
Transition and Non-Transition Bits Plot the transition and non-transition bits as two

separate eye diagrams
All Bits Plot all bits (transition and non-transition) in a

single eye diagram
 

6. From the Control panel, select the mode (Single Run or Single No Acq).  

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 

Note: The SAS Eye measurement requires at least three data packets that has  
≥ 550 clock transitions in the acquired data to calculate clock recovery correctly. 
If the acquired pattern has insufficient clock transitions (550) then you need to 
acquire more packets for sufficient clock transitions. 
 

Perform Receiver Differential Skew Test 
Follow these steps to measure the Differential Skew for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar. 

3. Select Test Point as IR, CR, or XR and Probe Type as Single-ended.  

4. Click Differential Skew. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button. 

In the Source tab, click Live, Ref, or File. Select the channels for D+ and 
D−, and the Trigger channel. The trigger channels available exclude those 
channels that you have selected as D+ D−. Select the Test Method. 
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Table 65: Source tab 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
In the General Config tab, set the Device Type, Usage model, and Cable 
Attenuation. 

Table 66: General Config tab 
Parameter Options To do
Usage Model 1.5 Gbps, 3 Gbps Select the speed at which the

device transmits or receives
data

Device Type Initiator, Target Select the type of device to
test

Cable Attn Range: 100 p-10 G Type the cable attenuation or
enter the value with the range
from the numeric keypad

 
6. From the Control panel, select the mode (Single Run or Single No Acq). 

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 
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Perform Receiver Rise Time and Fall Time Test 
Follow these steps to measure the Rise and Fall Time for a receiver.  

1. Set up the DUT (Host or Drive) as shown in the How To Set up the DUT 
section. 

2. Select Measurements> Select from the menu bar.  

3. Select Test Point as IR, CR, or XR, and Probe Type as Single-ended or 
Differential.  

4. Click Rise and Fall Time. 

5. To change the configuration settings, select Measurements> Configure from 
the menu bar or click the Configure button.  

In the Source tab, click Live, Ref, or File. If you are using a single-ended 
probe (SMA cable), select the channels for D+ and D−, and the Trigger 
channel. The trigger channels available exclude those channels that you 
have selected as D+ D−. Select the Test Method. 
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Table 67: Source tab 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live Select D+ D− Ch1 Ch3, Ch1 Ch4,
Ch2 Ch3, Ch2 Ch4

Set the channel pair to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

Ref Select D+ D− Ref1 Ref2, Ref1 Ref3,
Ref1 Ref4, Ref2 Ref1,
Ref2 Ref3, Ref2 Ref4,
Ref3 Ref1, Ref3 Ref2,
Ref3 Ref4, Ref4 Ref1,
Ref4 Ref2, Ref4 Ref3

Set the Ref channel pair
to acquire data from

File Select File(s)
D+ D−

Browse Load the data from .csv
files

 
For a differential probe, the source parameters are: 

Table 68: Differential probe 
Select Parameter Options To Do
Test Method AWG, BIST FIS/User Select the test method to

use. The module uses the
source pattern files
located on the AWG, or
uses a vendor-specific
method to test the DUT

Live/Ref Select Ch1, Ch2, Ch3, Ch4,
Ref1, Ref2, Ref3, Ref4

Set the channel to
acquire data from

Trigger Ch1, Ch2, Ch3, Ch4 Set the channel to
acquire trigger data from

File Select File Browse Load the data from a .csv
file

 
If you choose Live/Ref and select a Ref channel to acquire data from, then the 
Trigger selection is not available. 

In the General Config tab, set the Device Type, Usage model, and Cable 
Attenuation. 
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Table 69: General Config tab 
Parameter Options To do
Usage Model 1.5 Gbps, 3.0 Gbps Select the speed at which

the device transmits or
receives data

Device Type Initiator, Target, Expander* Select the type of device to
test

Cable Attn Range: 100 p-10 G Type the cable attenuation
or enter the value within the
range from the numeric
keypad

* The Expander option is the only available option when XR test point is chosen.
 

6. From the Control panel, select the mode (Single Run or Single No Acq).  

7. Click the Start button to start taking the measurement. When the 
measurement is complete, the summary of the results is displayed. 

8. If the results are not automatically displayed, select Results> Summary to 
view the results. To view detailed results, select Results> Details. 

View SAS Tests Results 

Summary Results 

You can view the summary results of the measurements by selecting Results> 
Summary. The application displays results for the measurements for the current 
acquisition. 

The Results Summary menu shows the current data and all acquisition data for 
each statistical value.  

The Results Summary menu displays the following information as a table. 
Wherever measurement limits are not available, those fields in the table are 
blank. 
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Table 70: Results Summary menu 
Option Description
Measurement Displays the selected measurements
Statistic Displays the type of statistic used
Value Displays the measured value of the measurement
Lower Lim Displays the measured lower limit of the

measurement
Upper Lim Displays the measured upper limit of the

measurement
Status Displays the status of the measurement as Pass or

Fail
 

Other options in the Results Summary screen include: 

Table 71: Results Summary screen 

Option Description
Show Plot Displays the plot of the eye diagram
Details Shortcut to the Results Details menu
Time Units Displays results in Unit Intervals or seconds  

Detailed Results 

You can view the detailed results of the measurements by selecting Results> 
Details. The application displays results for the measurements for the current 
acquisition. 

For a selected measurement, the Results Details menu displays the following 
information as a table. Wherever measurement limits are not available, those 
fields in the table are blank. 
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Table 72: Results Details menu 
Option Description
Result, Statistic Displays the different statistics for the

measurement⎯Population, Mean, Standard
Deviation, Maximum, Minimum, Peak-Peak Value.

Value Displays the measured value of the measurement
Lower Lim Displays the measured lower limit of the

measurement
Upper Lim Displays the measured upper limit of the

measurement
Status Displays the status of the measurement as Pass or

Fail
 

Other options in the Results Details screen include: 

Table 73: Results Details screen 
Option Description
Show Plot Displays the plot of the eye diagram
Details Shortcut to the Results Details menu
Time Units Displays results in Unit Intervals or seconds  

Eye Results 

You can view the eye results of the measurements by selecting Results> 
Summary or Results> Details. The application displays results for the eye 
measurement for the current acquisition.  

You can also view this by clicking the Show Plot button in the Results Summary 
or Results Details screen. If you have selected the Transition and Non-transition 
bits option in the plot configuration tab, then the application displays the data 
acquired in two separate plots.  
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Figure 65: Eye Plot with transition and non-transition bits 

If you have selected the All Bits option, then the application displays the data 
acquired in one plot.  
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Figure 66: Eye Plot with All bits 

The eye results are displayed in a table that shows the statistic, the upper and 
lower limits, and the status (pass/fail) of the measurement. 

Results Plot 

The following figure displays the Eye plot for transition bits and non-transition 
bits. You can view this plot if you have set the option−Transition and Non-
Transition Bits−in Configure> Plot Config. 
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Figure 67: Eye Plot with transition and non-transition bits 

The following figure displays the Eye plot for all bits. You can view this plot if 
you have set the All Bits option in Configure> Plot Config.  

  
Figure 68: Eye Plot with all bits 
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Bit Rate Results for a SAS Device 

 
Figure 69: Bit Rate result summary 

 
Figure 70: Bit Rate result details 
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Rise and Fall Time Results for a SAS Device 

  
Figure 71: Rise Time result details 

  
Figure 72: Fall Time result details 
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Differential Skew Results for a SAS Device 

  
Figure 73: Differential Skew result details 
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COMINIT for a SAS Device 

  
Figure 74: COMINIT result summary 

  
Figure 75: COMINIT result details 
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COMWAKE Results for a SAS Device 

  
Figure 76: COMWAKE result summary 

  
Figure 77: COMWAKE result details 
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COMRESET Results for a SAS Device 

  
Figure 78: COMRESET result summary 

  
Figure 79: COMRESET result details 
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Generating a Report 

About Generating a Report 
You can use the Report Generator utility to customize and generate a compliance 
report to view later or to share with others. The utility is independent from the 
RT-Eye application, yet is accessible from the application.  

Note: The utility yields a .rpt file that can only be viewed from the Report 
Generator. You can select to export to an .rtf formatted file. 

Report Generator File Directories 

Table 74: Report Generator File Directories 
Directory Description
Reports Default location where the utility stores the reports
Templates Each .rgt template defines the contents and layout of one

page in the report; you can use existing page templates, edit
templates, or create new templates

Layouts Each .rpl layout file defines all the pages (template files) to
include in the report; you can use an existing report layout,
edit layouts, or create new layouts

 

Starting the Report Generator and Accessing the Online Help 
The online help for the Report Generator utility contains all the information you 
need to design and produce compliance report files. To start the report generator 
utility from the module and access the online help, follow these steps: 

1. Select Utilities> Reports. 

2. Select the Define Test Template or the Define Report Layout tab. 

3. Select the  command button.  

4. From the menu bar in the Report Generator window, select Help> Help 
Topics. The help system for the Report Generator utility starts and opens. 
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You can refer to the online help topics for the Report Generator utility for 
information on how to do the following tasks: 

� Use an existing test template or report layout 

� Edit an existing test template or report layout 

� Create a new test template or report layout 

� Add Fields: Native, Oscilloscope, module-specific fields 

Setting Up a Test Template and Layout for a Report 
The Report Generator utility allows you to design the contents and layout of a 
report that reflects your unique needs. In addition to a predefined template for 
each page, there is also a predefined report that includes all the predefined pages.  

Generating and Printing a Report 
To generate and print a report, follow these steps: 

1. Select Utilities> Reports. 

2. Select the  tab. 

Do not touch the screen. Wait while the Report Generator creates the report. 
The oscilloscope fills the display while the application takes a screen print. 
When complete, the oscilloscope shrinks to half size and automatically 
redisplays the module that you are running.  

The report displays when it is complete. You may need to use the Alt+Tab 
key combination to bring the Report Generator window to the front. 

3. You need to save the report to retain the file. To save the report, select File> 
Save from the menu bar of the Report Viewer. The report file is in a .rpt 
format and can only be viewed with the Report Viewer. 

Later, you can use the Browse and View buttons in the Generate Report 
menu to open your saved report file. 

4. To use a different file, edit a file, or create a new report layout (or test 
template) file, refer to the Report Generator online help.  

5. To print the report, first verify that a printer is configured from the 
oscilloscope task bar. 



 
 
Generating a Report 
 

 Option SST Serial ATA and Serial Attached SCSI Analysis Module 
 
140

6. From the Report Generator menu, select the  button.  

You can also navigate to the saved file in the Report Generator window and 
send the file to a printer without having to open the file in the Report 
Viewer. 

To share a report with others, you may want to generate a smaller file. To do 
so, refer to the Creating a PDF File of the Compliance Report topic.  

7. To export the report as an .rtf file, select File> Export to RTF from the menu 
bar of the Report Generator window. You can transfer the .rtf file to a 
personal computer, and view or print the file from a word processing 
program. 

Creating a PDF File of the Compliance Report 
You can send a report file to a "virtual" printer to create a smaller and more 
portable PDF file of your compliance report. To create a PDF file, follow these 
steps: 

1. Verify that a distiller program (for example, Adobe Acrobat Distiller 6.0) is 
configured from the oscilloscope task bar.  

2. From the Report Generator menu in the selected module, select the 

 button.  

3. Select the Distiller from the Printer Name selection menu. 
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Figure 80: Creating a PDF file 

4. Send the report to the distiller (select OK). 

5. When the PDF file is complete, you can use other features of the distiller to 
enhance the report, such as add watermarks if available. 

Test Template Menu 

Note: Refer to the online help topics for the Report Generator utility for 
information on how to create a new test template or on how to edit an existing 
test template. 
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Figure 81: Defining a test template 

Report Layout Menu 

Note: Refer to the online help topics for the Report Generator utility for 
information on how to create a new report layout or how to edit an existing 
report layout. 
 

 
Figure 82: Defining a report layout 
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Report Generator Menu Options 

Table 75: Report Generator menu options 
Option Description
Browse Select the directory in which to save the report file and

enter a file name; select a file for a template or layout
and edit as needed

Generate Create a report
View View a report
Print Print a report

 

Report Generate Menu 

 
Figure 83: Generating a report 

Report Generator Fields 
You can use the fields in the report generator utility to customize the contents 
and layout of a report. The utility has the following groups of fields: 

� Oscilloscope 

� Application 

� Native 
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Application Fields General Information List 
This is an example of the fields available for the general oscilloscope information 
in the report. 

  
Figure 84: Example of application fields in a report 
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Application Fields Configuration List and an Example 
This is an example of the fields available for the configuration information. This 
example also shows the expanded list of fields available for Source in the report. 

   
Figure 85: Example of configuration fields 



 
 
Generating a Report 
 

 Option SST Serial ATA and Serial Attached SCSI Analysis Module 
 
146

Application Fields Results List and Specific Measurements Example 
This is an example of the fields available for the measurement results 
information. This example also shows the expanded list of fields available for the 
Eye measurement in the report. 

 

   
Figure 86: Example of fields for Eye results 
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Oscilloscope Fields and Native Fields Lists 
This is an example of the fields available for the oscilloscope controls and other 
miscellaneous accoutrements in the report, such as lines. 

    
Figure 87: Example of oscilloscope and native fields 
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Reference 

Shortcut Keys 

Table 76: Shortcut keys 
Menu item Shortcut keys
File Alt F
File> Recall Default Alt F + D
File> Recall Alt F + R
File> Save Alt F + S
File> Recall Recent Alt F + C
File> Preferences Alt F + P
File> Minimize Alt F + N
File> Exit Alt F + X
Modules Alt D
Modules> InfiniBand Alt D + B
Modules> PCI Express Alt D + P
Modules> SAS Alt D + A
Modules> Serial ATA Alt D + T
Modules> Serial Analysis Alt D + S
Measurements Alt M
Measurements> Select Alt M + C
Measurements> Configure Alt M + C
Measurements> Configure> Source Alt M + C + S
Measurements> Configure> General Config Alt M + C + G
Measurements> Configure> Clock Config Alt M + C + C
Measurements> Configure> Plot Config Alt M + C + P
Measurements> Limits Alt M + L
Results Alt R
Results> Summary Alt R + S
Results> Details Alt R + D
Results> Worst Case Eye Alt R + E
Utilities Alt U
Utilities> Reports Alt U + R
Help Alt H
Help> Help Topics Alt H + T
Help> PDF Help Alt H + P
Help> About RT-Eye Alt H + A  
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Error Messages 
In addition to the error messages available in the RT-Eye Serial Data Compliance 
and Analysis software, the following error messages are available for the Option 
SST analysis modules. 

Table 77: Error messages 
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Default Settings 

Default Settings for SATA Measurements (Part 1) 

Table 78: Default settings 
Menu/Parameter  Selection  Default 
File> Preferences • Do not override the setup in 

BIST FIS/User method 
• Prompt for correct waveform 

confirmation during run 
• Refine filter initial condition for 

SATA AC CM 
• Overcome the filter transient 

response by discarding the fixed 
time constants of data 

Not selected 
 
Selected 
 
 
Selected 
 
Selected 

Measurements Eye, Bit Rate, Rise and Fall Time, 
Unit Interval, Differential Skew, 
Differential Voltage, AC CM Voltage, 
COMINIT, COMWAKE, COMRESET 

Eye 

Test Point  Transmitter, Receiver Transmitter 
Probe Type Single Ended, Differential  Single Ended 
Device Details  None SATA_0001 
Eye> Configure> Source tab 
Test Method AWG, BIST FIS/User AWG 
Source Type  Live, Ref, File Live 
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3 
Trigger Ch1 to Ch4 Ch2 
Eye> Configure> General Config tab 
Usage Model  Gen1i, Gen1x, Gen1m, Gen2i, 

Gen2x, Gen2m 
Gen1i 

Device Type  Host, Drive Host 
Cable Attn 100 p-10 G 1 
Eye> Configure> Clock Config tab 
Clock Recovery: Window 
Size 

1000-5000 UI 2k 

Clock Recovery: Scan Incr 1-250 UI 100 
Clock Recovery: Method Const Clk: Mean,  

Const Clk: Median 
Const Clk: Mean 

Analysis Window 250 UI, 5 UI 250 UI 
Eye> Configure> Plot Config tab 
Plot Type Selection Transition and Non-transition Bits, All 

Bits 
All Bits 
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Default Settings for SATA Measurements (Part 2) 

Table 79: Default settings 

Menu/Parameter Selection Default
Rise and Fall Time> Configure> Source tab
Test Method AWG, BIST FIS/User AWG
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
Rise and Fall Time> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
Bit Rate > Configure> Source tab
Test Method AWG, BIST FIS/User AWG
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
Bit Rate> Configure> General Config tab

Usage Model Gen1i, Gen1x, Gen1m, Gen2i,
Gen2x, Gen2m

Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
Bit Rate> Configure> Clock Config tab
Clock Recovery: Window
Size

1000-5000 UI 2k

Clock Recovery: Scan Incr 1-250 UI 100
Clock Recovery: Method Const Clk: Mean,

Const Clk: Median
Const Clk: Mean

Analysis Window 250 UI, 5 UI 250 UI
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Table 80: Default settings 

Menu/Parameter Selection Default
Unit Interval> Configure> Source tab
Test Method AWG, BIST FIS/User AWG
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
Unit Interval> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
Unit Interval> Configure> Clock Config tab
Clock Recovery: Window
Size

1000-5000 UI 2k

Clock Recovery: Scan Incr 1-250 UI 100
Clock Recovery: Method Const Clk: Mean,

Const Clk: Median
Const Clk: Mean

Analysis Window 250 UI, 5 UI 250 UI
Differential Skew> Configure> Source tab*

Test Method AWG, BIST FIS/User AWG
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
Differential Skew> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
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Default Settings for SATA Measurements (Part 3) 

Table 81: Default settings 
Menu/Parameter Selection Default
Differential Voltage > Configure> Source tab
Test Method BIST FIS/User BIST FIS/User
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Differential Voltage> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
Diff Volt Option Option1, Option2 Option1
AC CM Voltage> Configure> Source tab*
Test Method BIST FIS/User, AWG AWG
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
AC CM Voltage> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
Num of UI 6k, 12k, 30k, 60k, 120k 6k
Cable Attn 100 p-10 G 1
* These measurements are available only for single-ended probes
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Default Settings for SATA Measurements (Part 4) 

Table 82: Default settings 
Menu/Parameter Selection Default
OOB Measurements
Test Point Transmitter Transmitter
COMINIT> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
COMINIT> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
COMINIT Type In Spec, Out of Spec In Spec
Cable Attn 100 p-10 G 1
COMWAKE> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
COMWAKE> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
COMWAKE Type In Spec, Out of Spec In Spec
Cable Attn 100 p-10 G 1
COMRESET> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
COMRESET> Configure> General Config tab
Usage Model Gen1i, Gen1x, Gen1m, Gen2i,

Gen2x, Gen2m
Gen1i

Device Type Host, Drive Host
COMWAKE Type InterBurst InterBurst
Cable Attn 100 p-10 G 1
Results Summary, Details, Worst Case Eye Summary
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Default Settings for SAS Measurements (Part 1) 

Table 83: Default settings 

Menu/Parameter Selection Default
File> Preferences • Do not override the setup in

BIST FIS/User method
• Prompt for correct waveform

confirmation during run
• Enable Transient Time input

for clock recovery
• Refine filter initial conditions

for SAS Eye

Not selected

Selected

Selected

Selected

Measurements Eye, Bit Rate, Rise and Fall
Time, Differential Skew,
COMINIT, COMWAKE,
COMRESET

Eye

Test Point IT, CT, XT, IR, CR, XR IR
Probe Type Single Ended, Differential Single Ended
Device Details None SAS_0001
Eye> Configure> Source tab
Test Method BIST FIS/User BIST FIS/User
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3,

Ch2Ch4
Ch1Ch3

Eye> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
Clock Method Const Clk: Mean,

Const Clk: Median
Const Clk: Mean

Cable Attn 100 p-10 G 1
Transient Time .25 - 10 time constants
Eye> Configure> Plot Config tab
Plot Type Selection Transition and Non-transition

Bits, All Bits
All Bits

Rise and Fall Time> Configure> Source tab
Test Method BIST FIS/User BIST FIS/User
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3,

Ch2Ch4
Ch1Ch3

Rise and Fall Time> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
Cable Attn 100 p-10 G 1
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Default Settings for SAS Measurements (Part 2) 

Table 84: Default settings 

Menu/Parameter Selection Default
Bit Rate> Configure> Source tab
Test Method BIST FIS/User BIST FIS/User
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Bit Rate> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
Cable Attn 100 p-10 G 1
Differential Skew> Configure> Source tab*
Test Method BIST FIS/User BIST FIS/User
Source Type Live, Ref, File Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Differential Skew> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
Cable Attn 100 p-10 G 1
* This measurement is available only for single-ended probes
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Table 85: Default settings 

Menu/Parameter Selection Default
COMINIT> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
COMINIT> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
COMINIT Type In Spec, Out of Spec In Spec
Cable Attn 100 p-10 G 1
COMRESET> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
COMRESET> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
COMRESET Type InterBurst InterBurst
Cable Attn 100 p-10 G 1
COMWAKE> Configure> Source tab
Test Method AWG AWG
Source Type Live Live
Select D+D− Ch1Ch3, Ch1Ch4, Ch2Ch3, Ch2Ch4 Ch1Ch3
Trigger Ch1 to Ch4 Ch2
COMWAKE> Configure> General Config tab
Usage Model 1.5 Gbps, 3.0 Gbps 1.5 Gbps
Device Type Initiator, Target Initiator
COMWAKE Type In Spec, Out of Spec, InterBurst In Spec
Cable Attn 100 p-10 G 1
Results Summary, Details Summary
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GPIB Commands 

GPIB Information 

For information on how to operate the oscilloscope using the application-specific 
GPIB commands, refer to the following documents: 

� The user manual for your oscilloscope provides general information on how 
to operate the oscilloscope 

� The online help for your oscilloscope can provide details on how to use 
GPIB commands to control the oscilloscope if you install the GPIB 
Programmer guide (and code examples) from the oscilloscope CD-ROM. 

Remote GPIB Support 

The remote GPIB support for the Serial ATA and SAS modules is limited to 
saving and recalling the setup, running the measurement, and querying for 
results. 

Your GPIB program should comply with the following guidelines: 

� The application startup must complete before sending additional GPIB 
commands to the application. Query the variable application; it will return 
"TDSRT-EYE" when the application startup is complete 

� Recall a setup file from GPIB to select measurements and set up the 
application 

� The measurements cycle must complete before data is queried. Query the 
variable SequencerState; it will return "Ready" when sequencing is 
complete 

� The resultFor variable must be set before querying results; pause a second 
after setting each variable 

� The error variable should be checked to ensure that an error has not occurred 
because of a measurement command problem; the measError variable 
returns errors specific to the measurement selected by resultFor 

Introduction to GPIB Command Syntax 

With knowledge of the GPIB command syntax, you can design a GPIB program 
to do the following tasks: 

� Start the RT-Eye application 
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� Recognize an active application with GPIB protocol 

� Program and read application setup parameters 

� Sequence measurements 

� Read measurement results 

� Generate reports 

GPIB Reference Materials 

To use GPIB commands with your oscilloscope, you can refer to the following 
materials: 

� The rt-eyectrl.c file on the oscilloscope hard drive (located in the 
c:\TekApplications\tdsrt-eye\Examples\RemoteCtrl directory) provided an 
example of a GPIB program that can execute the application 

� The GPIB Program Example topic provides guidelines to use while 
designing a GPIB program 

� The programmer information in the online help of your oscilloscope 

Starting and Setting Up the Application Using GPIB 

To start the RT-Eye application, you must send the oscilloscope the following 
GPIB command: 

application:activate "RT-Eye Serial Compliance and Analysis" 

Note: The name of the application in the previous string is identical to the name 
of the application from the oscilloscope Run Application list. 
 

The application uses the GPIB VARIABLE:VALUE command with arguments 
to execute some features. The set of GPIB commands does not include the 
variable names and variable values necessary to select and configure the 
measurements in the GPIB program. 

You must manually set up the application and oscilloscope, selecting and 
configuring the measurements that you want to use with your GPIB program, and 
save them in a setup file in the default setup folder for that module. Use the name 
of the saved setup file as the value for the "recallName" variables in your GPIB 
program. 
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Variable:Value RT-Eye Command 

Description 

This command accepts string arguments for a control or data variable and a value 
to which to set the argument.  

Syntax 

VARIABLE:VALUE "<variable name>","<variable value>" 

Note: The arguments <variable name> and <variable value> are required in the 
order indicated. 
 

VARIABLE:VALUE? <variable name> for query. 

 

 

 
CAUTION. Commands are case and space sensitive. Your program will not 
operate correctly if you do not follow the capitalization and spacing 
precisely.  
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Variable:Value Command Arguments and Queries (Part 1) 

Table 86: Command arguments and queries 
Group /Name Value Function Query returns
application {exit} Terminates the

active application
Returns TDSRT-EYE
when the application is
active

version Query only Returns the version
number of the
application

Sequencer
sequencerMode {Single No Acq,

Single}
Sets the sequencer
mode

Returns the sequencer
mode

sequencerState {Stop, Sequencing} Sends the
measurement
sequencing
command

Returns {Most recent
setting, Ready}; Ready
indicates that the value
was processed

reset {Results} Clears the active
measurements
results and plots

Returns {Most recent
setting, Ready}; Ready
indicates that the value
was processed

Active module
module {SerialAnalysis,

InfiniBand,
PCIExpress, SATA,
SAS}

Switches to the
module specified

Returns the active
module

Recall setup
setup {Default, Recall} Performs the Recall

Default setup
function

Returns {Most recent
setting, Ready}; Most
recent setting indicates
that the value is being
processed; Ready
indicates that the value
was processed

recallName Any string from 1 to
40 characters: A to Z,
0 to 9, or special
characters like “.”

Sets the Recall
setup file name; file
name extension of
.ini is optional

Returns the name of the
setup file to be recalled
(without an extension)

recallDirectory Query only Returns the current
setting (determined from
module command) of
recall directory default,
such as SATA\setup
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Variable:Value Command Arguments and Queries (Part 2) 

Table 87: Command arguments and queries 
Group /Name Value Function Query returns
reportGen {Now} Exports content from

current
measurements into a
report template/layout
where the
template/layout are
default or as specified
in the recalled setup
file; concatenates the
Template name and a
Time stamp for the file
name

{Most recent setting,
Ready} Ready indicates
report has been created
and saved.

Compliance module only
satareportDeviceID Any string from 1 to

40 characters: A to Z,
0 to 9, or special
characters like “.”

Specifies the device
ID field
for report generation
for the SATA module

Returns the specified
DeviceID; applies to
only the SATA module

sasreportDeviceID Any string from 1 to
40 characters: A to
Z, 0 to 9, or special
characters like “.”

Specifies the device
ID field
for report generation
for the SAS module

Returns the specified
DeviceID; applies to
only  the SAS module

Result variables
resultFor {Measurement Name} Specifies the

measurement that is
the source for detailed
results queries; refer
to the tables between
this one and the error
codes table

Returns the selected
measurements for the
queries associated with
the resultFor command

resultForWorstEye {Worst Case Eye
Measurement Name}

Specifies the
measurement that is
the source for detailed
results queries; refer
to the tables between
SATA Measurement
Names  table and the
SATA Measurement
Names table

Returns the selected
Worst Case Eye
measurements for the
queries associated with
the resultForWorstEye
command
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Variable name Query return for measurement
Statistics for all measurements selected with resultFor
max Returns the maximum measurement value
mean Returns the mean measurement value
min Returns the minimum measurement value
pkpk Returns the peak-to-peak measurement value
population Returns the number of measurements used to the current

statistics
stdDev Returns the standard deviation measurement set
Other non-statistical information that appears in the Results menus
maskUIControl Returns the number of UIs examined for mask hits
maskHits Returns the number of UIs containing one or more mask hit
Query results for Worst Case Eye Measurement
worstValue Returns measurement value for the worst eye measurement set
worstStartAnalyWindow Returns the Start analysis window position
worstStartClockRecovery Returns the Start clock recovery window position
worstUI Returns measurement value in terms of UI for the worst eye

measurement set
Limits
status Pass or Fail status; Pass when the measurement passes the test

or Fail with limits defined
Misc
measUnits Return a units string for the measurement, such as s for seconds
Messages that return strings
resultForStatus Returns one of the following strings:

“Active” when the value of resultFor is an active measurement
“Inactive” when the value of resultFor is a known measurement
that is not active
“Unknown” when the value of resultFor is an unknown
measurement
Any of the results specified in this table are not valid unless this
variable is “Active”

error Returns a general error
warning Returns a warning from the most recent measurement
measError Returns a measurement specific error

 

Measurements Results Queries 

 

 
 

CAUTION. Before doing measurement queries, be sure to insert a one 
second delay after the resultFor command to allow the statistics variable to 
refresh.  
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You need to use the VARIABLE:VALUE? form to enter measurement results 
queries in your GPIB program. Before you can do this, you must first set the 
measurement with the resultFor command.  

The next several tables list the measurement results queries for the measurement 
selected in the resultFor variable. 

Worst Case Eye Measurement Names for the resultForWorstEye Variable 

Table 88: Worst case eye measurement names 
Worst Case Eye
Measurement
Names

Value Start Analysis
Window

Start Clock
Recovery

UI

Worst Top Margin Yes Yes Yes Yes
Worst Bottom
Margin

Yes Yes Yes Yes

Worst Upper Rail Yes Yes Yes Yes
Worst Lower Rail Yes Yes Yes Yes
Worst Jitter Yes Yes Yes Yes  

SATA Measurement Names for the resultFor Variable 

Table 89: SATA measurement names 
Measurement Names Stats And…
Eye Width Yes
Eye Height Yes maskUICount,maskHits
Eye Height Transition Bits Yes maskUICount,maskHits
Eye Height Non-Transition Bits Yes maskUICount,maskHits
TIE Jitter Yes
Fall Time Yes
Rise Time Yes
Unit Interval Yes
Bit Rate Yes
Differential Skew Yes
AC CM Voltage Yes  
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SAS Measurement Names for the resultFor Variable 

Table 90: SAS measurement names 
Measurement Names Stats And…
Eye Width Yes
Eye Height Yes maskUICount, maskHits
Eye Height Transition Bits Yes maskUICount, maskHits
Eye Height Non-Transition Bits Yes maskUICount, maskHits
Fall Time Yes
Rise Time Yes
Bit Rate Yes
Differential Skew Yes  

Measurement Algorithms 

Eye Diagram for Serial ATA 

The Serial ATA signal consists of Spread Spectrum Clocking (SSC). The Eye 
will not be accurate if generated on a large number of Unit Intervals. The 
algorithm uses a sliding window or the scan mode, to reduce the effect of SSC. 

Scan mode: 

The scan mode method is as follows:  

1. Select a large window, for example 2000 UI, for clock recovery.  

2. Recover the clock on the 2000 UI window. 

3. Calculate the UI values. 

4. Go to the center 250 UI or 5 UI (Analysis Window) according to the user 
selection. 

5. Adjust the phase values at this 250/5 UI. 

6. Create Eye diagram on analysis window.  

7. Calculate the five values: 

� Jitter 

� Top rail  

� Bottom rail 
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� Bottom opening  

� And top opening 

Move the window by a certain number of unit intervals, for example 100 UI. 
Repeat all the earlier steps mentioned. Compare all the results computed in the 
current window with that of the previous window and keep the worst values. 
Keep moving the window until it reaches end of the data and repeat the same 
process to get the worst five values and corresponding eye.  

The algorithm calculates the Eye Width and Eye Height values to generate the 
Eye diagram.  

Eye Width: 

The Eye Width measurement is the measured minimum horizontal eye opening at 
the zero reference level as shown in the eye diagram.  

PkPkAVGWIDTHEYE TIEUIT −− −=  

Where: 

TEYE−WIDTH is the average UI 

TIEPK−PK is the Peak-Peak Time Interval Error 

 

Eye Height: 

The Eye Height measurement is the measured minimum vertical eye opening at 
the UI center as shown in the plot of the eye diagram. There are three types of 
Eye Height values: Eye Height, Eye Height Transition, and Eye Height Non-
Transition. 

MAXLOEYEMINHIEYEHEIGHTEYE VVT −−−−− −=  

Where: 

VEYE−HI−MIN is the minimum of the High voltage at mid UI 

VEYE−LO−MAX is the maximum of the Low voltage at mid UI 

 

Eye Height − Transition: 

MAXTRANLOEYEMINTRANHIEYETRANHEIGHTEYE VVT −−−−−−−− −=  
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Where: 

VEYE−HI−TRAN−MIN is the minimum of the High transition bit eye voltage at mid UI 

VEYE−LO−TRAN−MAX is the maximum of the Low transition bit eye voltage at mid UI 

 

Eye Height − Non-transition: 

MAXNTRANLOEYEMINNTRANHIEYENTRANHEIGHTEYE VVT −−−−−−−− −=  

Where: 

VEYE−HI−NTRAN−MIN is the minimum of the High non-transition bit eye voltage at mid 
UI 

VEYE−LO−NTRAN−MAX is the maximum of the Low non-transition bit eye voltage at 
mid UI 

Eye Diagram for SAS 

The Clock Recovery Module recovers the clock using the CCR Mean/Median 
technique. Recalculate the clock by adjusting the Low Pass Filter TIE to get the 
corrected clock. This clock is used to calculate TIE and Eye. The filter used is the 
Low Pass Filter first order Butterworth.  

  
The output/input is graphed over time (unit interval). The response shows the 
filter behavior. At first, the filter ramps up and then tries to settle down after the 
dotted line. This ramping up is due to initial conditions used for the filter. To 
overcome this, the simplest method is to discard the Td time duration of filtered 
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data. The Td is called as variable of time constant and one time constant (tau) = 
1/(2*pi*fc) where fc is the filter cut off frequency. fc is bitrate/1667. 

CCRsedDataEdgeInterpolatTIE −=  

The algorithm calculates the Eye Width and Eye Height values to generate the 
Eye diagram.  

Eye Width: 

The Eye Width measurement is the measured minimum horizontal eye opening at 
the zero reference level as shown in the eye diagram.  

PkPkAVGWIDTHEYE TIEUIT −− −=  

Where: 

TEYE−WIDTH is the average UI 

TIEPK−PK is the Peak-Peak Time Interval Error 

Eye Height: 

The Eye Height measurement is the measured minimum vertical eye opening at 
the UI center as shown in the plot of the eye diagram. There are three types of 
Eye Height values: Eye Height, Eye Height Transition, and Eye Height Non-
Transition. 

MAXLOEYEMINHIEYEHEIGHTEYE VVT −−−−− −=  

Where: 

VEYE−HI−MIN is the minimum of the High voltage at mid UI 

VEYE−LO−MAX is the maximum of the Low voltage at mid UI 

 

Eye Height − Transition: 

MAXTRANLOEYEMINTRANHIEYETRANHEIGHTEYE VVT −−−−−−−− −=  

Where: 

VEYE−HI−TRAN−MIN is the minimum of the High transition bit eye voltage at mid UI 

VEYE−LO−TRAN−MAX is the maximum of the Low transition bit eye voltage at mid UI 
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Eye Height − Non-transition: 

MAXNTRANLOEYEMINNTRANHIEYENTRANHEIGHTEYE VVT −−−−−−−− −=  

Where: 

VEYE−HI−NTRAN−MIN is the minimum of the High non-transition bit eye voltage at mid 
UI 

VEYE−LO−NTRAN−MAX is the maximum of the Low non-transition bit eye voltage at 
mid UI 

When the preference "Refine Filter initial condition for SAS Eye" is selected the 
algorithm uses four-point forward averaging technique from the first clock edge 
up to two time constants (tau) of clock edges, and the first order backward 
filtering to calculate the filter initial conditions.  

Cf
Tau

π2
11 =  

where fc is the cut-off frequency and is equal to fBaud/1667. Depending on the 
device speed, the cut-off frequency changes.  

For a 3 Gbps device speed, the algorithm averages TIE values till the index 
2*tau/average_Period, where the average_Period is 1/calculated device speed. 
The number of indexes is ~550. 

For a 1.5 Gbps device speed, the number of indexes is ~550. 

How to calculate the record length to set in case of non automated mode? 

Set the record length as follows to ensure that the acquired waveform is greater 
than the clock transitions as mentioned for the device speeds. To retain the shape 
of the bit transmitted eight sample points should be available during each rise and 
fall slope and >=8 samples in each unit interval. An ideal record length would be 
550*8 which is approximately 10 K. 

Rise Time 

Rise time is the time difference between 20% and 80% of the normalized 
amplitude of the captured signal at the rising edge. 
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)()()( jtitnt LOHIRISE ++ −=  

Where:  

tRISE is a Rise Time measurement 

tHI+ is a set of tHI for rising edges only 

tLO+ is a set of tLO for rising edges only 

i and j are indexes for nearest adjacent pairs of tLO+ and tHI+ 

n is the index of rising edges in the waveform 

Rise Time is as follows: 

)()()( ___ jtitnt LODIFFHIDIFFRISEDIFF ++ −=  

Fall Time 

Fall time is the time difference between 20% and 80% of the normalized 
amplitude of the captured signal at the falling edge. 
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)()()( jtitnt HILOFALL −− −=  

Where:  

TFALL is a Fall Time measurement 

tHI− is a set of tHI for falling edges only 

tLO− is a set of tLO for falling edges only 

i and j are indexes for nearest adjacent pairs of tLO− and tHI− 

n is the index of falling edges in the waveform 

 

Fall Time is as follows: 

)()()( ___ jtitnt HIDIFFLODIFFFALLDIFF −− −=  

Bit Rate 

The Bit Rate measurement calculates the baud (such as frequency) of the 
recovered clock. 

)(
1

nUI
BR =  

Where:  

UI is the associated Unit Interval measurement 

n is the index to UI in the waveform 
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Unit Interval 

The Unit Interval measurement calculates the cycle duration of the recovered 
clock. 

)()1()( ntntnUI CLKRCLKR −− −+=  

))(( nUIMeanUI AVG =   

Where:  

tR−CLK is a recovered clock edge 

n is the index to UI in the waveform 

Differential Skew 

The Skew measurement is the time delay between the two single-ended 
waveform sources.  

)()()( ntntnT MIDDMIDDSKEW −+ −=  

Where:  

tSKEW is the Skew measurement 

tD+MID is the mid level crossing time of vD+ 

tD−MID is the mid level crossing time of vD- 

n is the index to edges in the waveform 

Differential Voltage 

The algorithm calculates the minimum and maximum differential voltages. The 
calculations are performed on a series of patterns and the first few are common to 
Option1 and Option2. 

In the following equations, 

is the mean of the voltage samples in the histogram 

s is the standard deviation of the voltage samples in the histogram 

n is the number of samples that contribute to the histogram  
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Steps 1 and 2 for an HFTP pattern: 

]96.1[
n

sxUH −=  

]96.1[
n

sxLH +=  

Steps 3 and 4: for an MFTP pattern: 

]96.1[
n

sxUM −=  

]96.1[
n

sxLM +=  

Step 5: 

LHUHDH −=  

LMUMDM −=  

),min( DMDHDHM =  

 

Step 6 using an LBP pattern, Option 1: 

]96.1[
n

sxA −=  

]96.1[
n

sxB +=  

Step 7: 

BAVTestLBP −=  

),min( DHMVTestLBPVTest =  

Step 6 using an LFTP pattern, Option 2: 

]96.1[
n

sxA −=  

]96.1[
n

sxB +=  
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Steps 8-11: Calculate the mean of voltage samples in the histogram at points 
C, D, E, and F.  

  
 

Step 12:  

)()( EDBFCAVTestAPP ++−++=  

),min( DHMVTestAPPVTest =  

Maximum Differential Voltage: 

Step 1: High Test UI 

(max)
2
1

DIFFTXVVU =  

NU is the number of histogram hits between 0 and VU millivolts: nu is the 
number of histogram hits between VU and VU+300 millivolts. 

 

Step 2: Low Test UI 

(max)
2
1

DIFFTXVVL −=  

NL is the number of histogram hits between VL and 0 millivolts: nl is the 
number of histogram hits between VL − 300 millivolts and VL. 
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Step 3: 

NUnu
nupu
+

=  

NLnl
nlpl
+

=  

AC Common Mode Voltage 

The AC Common Mode Voltage measurement calculates the AC statistics of the 
Common Mode voltage waveform with the DC value removed. This vAC−CM is 
filtered with a filter having a cut-off frequency of Bitrate/2.  

CMCMCMAC Viviv −=− )()(  

Where: 

i is the index of all waveform values 

vAC−CM is the AC Common Mode voltage signal 

vCM is the Common Mode voltage signal 

VCM is the DC Common Mode voltage signal 
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Jitter Measurements using TDSJIT3 v2 

Serial ATA Transmitter Jitter Measurements using TDSJIT3 v2 

Jitter is an accumulation of short-term variations of the zero crossings from ideal 
positions in time. A Reference Clock defines the ideal positions in time. The 
Reference Clock method separates jitter from SSC, tracks SSC and other low 
frequency modulation but not jitter. Reference Clock extraction is performed 
using either hardware or software PLLs.  

Two Reference Clock PLLs are defined as type 2 PLL with a -3 dB corner 
frequency  

fc3dB = fBAUD/N (N = 10 (Gen2i), 500 (Gen2i), 1667 (Gen1x, Gen2x)) given a 
transition density of 1.0 (corresponding to a 1010101010 clock-like pattern) and 
damping factor î = 0.707 min to 1.00 max. 

For Gen1i and Gen1x,  

fBAUD = 1.5 Gbps and for Gen2i and Gen2x, fBAUD = 3 Gbps. 

There are several types of jitter which are separated into two classes: 
deterministic and random. Deterministic jitter is bounded and random jitter is 
not. The amount of tolerable jitter is limited by the desired bit error rate 
performance of the channel. Two classes of jitter are used in analysis because 
they accumulate differently. 

You can configure the reference clock in the TDSJIT3 v2 application as a second 
order PLL. 
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The following table lists the measurements for the Serial ATA devices that you 
can use with the TDSJIT3 v2 application. 

Table 91: Measurements for SATA devices used with TDSJIT3 v2 
Parameters Serial ATA Measurements

with TDSJIT3
Transmitter Gen1i Gen1x Gen2i Gen2x 9
Tj at Connector, Data-Data,
5UI
Dj at Connector, Data-Data,
5UI

9 9

Tj at Connector, Data-Data,
250UI
Dj at Connector, Data-Data,
250UI

9 9

Tj at Connector, Clk-Data,
fBAUD/10
Dj at Connector, Clk-Data,
fBAUD/10

9 9

Tj at Connector, Clk-Data,
fBAUD/500
Dj at Connector, Clk-Data,
fBAUD/500

9 9

Tj after CIC, Clk-Data,
fBAUD/1667
Dj after CIC, Clk-Data,
fBAUD/1667

9 9 9

 
The patterns to be used for testing timing, amplitude, and jitter measurements 
according to Serial ATA specification SATA II rev 1.0 05 26 2004 are:  

� HFTP, LFTP, and LBP for Rise time and Fall time. 

� HFTP, MFTP, and LFTP (option 1) or HFTP, MFTP, and LBP (option 2) 
for Amplitude tests. 

� LTDP, HTDP, LFSCP, SSOP, LBP, COMP for Jitter tests.  

Serial ATA SSC time domain profile extraction using TDSJIT3 v2 

The SSC time domain profile is extracted by clock period measurement.  The 
SSC profile is measured at different cut off frequencies by applying Butterworth 
1st order with the following characteristics (3 dB, 20 dB/decade rolloff) 35 KHz 
(CP1), 50 KHz (CP2), 100 KHz (CP3), 500 KHz (CP4), 1 MHz (CP5), 5 MHz 
(CP6) on the clock period measurements. 
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TDSJIT3 v2 setup and configuration: 

1. Select SelectMeas and select Clock Period.  

2. Select ConfigureMeas and select the Filters tab.  

3. Select Low-pass filter (f2, first order) and configure the cutoff frequencies 
⎯ 35 KHz (CP1), 50 KHz (CP2), 100 KHz (CP3), 500 KHz (CP4), 1 MHz 
(CP5), 5 MHz (CP6). 

4. From the main menu, select Plot> Create. From Add Plot, select Cycle 
Trend.  

Note: Do not configure the High Pass Filter.  
 

5. Select Advanced and configure the Settling Time. Based on the settling 
time, the initial filtered data will be discarded.  

6. Select Go to Results and select Run/Stop or Single. Select the clock periods 
one after another to see the results and plot for each clock period.  

 
Figure 88: SSC time domain profile extraction 
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TDSJIT3 v2 Setup to measure Tj/Dj, 5 UI for a Gen1i device 

Follow the steps to measure the Tj at Connector, Data-Data, 5 UI and Dj at 
Connector, Data-Data, 5 UI for a Gen1i device: 

1. Select SelectMeas> Data tab. Select TIE. 

 
Figure 89: Selecting measurement 

2. From ConfigureMeas, select the Filters tab. In High Pass (F1), set Freq (F1) 
to 300 Mhz. 

  
Figure 90: Configuring filters 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 
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Figure 91: Configuring general parameters 

4. Select Go to Results and select Run/Stop or Single. 

 
Figure 92: Measurement results 

Note: The maximum PLL Bandwidth is equal to Baudrate/10, which is 1.5e9 /10 
or 150 MHz. Since the Loop Bandwidth is 300 MHz, you cannot perform this test 
using PLL. You can do the equivalent by recovering the clock using Constant 
Clock Recovery (CCR) and applying a high-pass filter on the TIE.  
 

TDSJIT3 v2 Setup to measure Tj/Dj, 250 UI for a Gen1i device 

Follow the steps to measure the Tj at Connector, Data-Data, 250 UI and Dj at 
Connector, Data-Data, 250 UI for a Gen1i device: 

1. Select SelectMeas> Data tab. Select PLL TIE. 
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Figure 93: Selecting measurements 

2. Select ConfigureMeas. Select the Clock Recovery tab. Set Loop BW-
Custom to 6 MHz (250 UI). You can configure the Damping Factor between 
0.707 - 1.0 (default 0.707). Setting the Damping Factor is optional. 

 

  
Figure 94: Configuring clock recovery 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 

  
Figure 95: Configuring general parameters 

4. Select Go to Results and select Run/Stop or Single. 
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Figure 96: Measurement results 

TDSJIT3 v2 Setup to measure Tj/Dj for a Gen1x device 

Follow the steps to measure the Tj after CIC, Clk-Data, fBAUD/1667, and Dj 
after CIC, Clk-Data, fBAUD/1667 for a Gen1x device: 

1. Select Measurements> Data tab. Select PLL TIE. 

2. Select ConfigureMeas. Select the Clock Recovery tab. Set Loop BW-
Custom to 890  KHz (fBaud/1667). You can configure the damping factor 
between 0.707 - 1.0 (default 0.707). Setting the Damping Factor is optional. 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 

4. Select Go to Results and select Run/Stop or Single. 

TDSJIT3 v2 Setup to measure Tj/Dj, Clk-Data, fBaud/500 for a Gen2i device 

Follow the steps to measure the Tj at Connector, Clk-Data, fBAUD/500, and Dj 
at Connector, Clk-Data, fBAUD/500 for a Gen2i device: 

1. Select SelectMeas> Data tab. Select PLL TIE. 

2. Select ConfigureMeas. Select the Clock Recovery tab. Set Loop BW-
Custom to 6 MHz (500 UI). You can configure the damping factor between 
0.707 - 1.0 (default 0.707). Setting the Damping Factor is optional. 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 

4. Select Go to Results and select Run/Stop or Single. 



 
 

Reference 
 

Option SST Serial ATA and Serial Attached SCSI Analysis Module  
 

183

TDSJIT3 v2 Setup to measure Tj/Dj for a Gen2x device 

Follow the steps to measure the Tj after CIC, Clk-Data, fBAUD/1667, and Dj 
after CIC, Clk-Data, fBAUD/1667for a Gen2x device: 

1. Select SelectMeas> Data tab. Select PLL TIE. 

2. Select ConfigureMeas. Select the Clock Recovery tab. Set Loop BW-
Custom to 1.8 MHz (fBaud/1667). You can configure the damping factor 
between 0.707 - 1.0 (default 0.707). Setting the Damping Factor is optional. 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 

4. Select Go to Results and select Run/Stop or Single. 

TDSJIT3 v2 Setup to measure Tj/Dj, Clk-Data for a Gen2i device 

Follow the steps to measure the Tj at Connector, Clk-Data, fBAUD/10, and Dj at 
Connector, Clk-Data, fBAUD/10 for a Gen2i device: 

1. Select SelectMeas> Data tab. Select PLL TIE. 

2. Select ConfigureMeas. Select the Clock Recovery tab. Set Loop BW-
Custom to 300 MHz (10 UI). You can configure the Damping Factor 
between 0.707 - 1.0 (default 0.707). Setting the Damping Factor is optional. 

3. Select the General tab. Set Rj/Dj Analysis to On, set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the Serial ATA 
specification. 

4. Select Go to Results and select Run/Stop or Single. 
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SAS Receiver Jitter Measurements using TDSJIT3 v2 

You can use TDSJIT3 v2 to measure jitter for a SAS Receiver. 

Table 92: Measure jitter 
SAS 1.5 Gbps and 3 Gbps

Parameters IR CR XR
Total Jitter 9 9 9

Deterministic Jitter 9 9 9  

TDSJIT3 v2 Setup for a SAS 1.5 Gbps device 

Follow the steps to measure the jitter for a SAS 1.5 Gbps receiver: 

  
Figure 97: Configuring filters for a 1.5 Gbps SAS device 

1. Select Data> Data tab. Select TIE. Select ConfigureMeas and select the 
Filter tab.  

2. Select F1 (high-pass filter).  

3. Set the cutoff High Pass Frequency to 890 KHz (fBaud/1667) and F2 (off).  

Note: Do not configure the Low Pass Filter. 
 

4. Select the General tab. Set Rj/Dj Analysis to On. Set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the SAS 
specification. 

5. Select Go to Results and select Run/Stop or Single. 
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TDSJIT3 v2 Setup for a SAS 3.0 Gbps device 

Follow the steps to measure the jitter for a SAS 3.0 Gbps receiver: 

  
Figure 98: Configuring filters for a 1.5 Gbps SAS device 

1. Select Data> Data tab. Select TIE. Select ConfigureMeas and select the 
Filter tab. 

2. Select F1 (high-pass filter). 

3. Set the cutoff High Pass Frequency to 1.8 MHz (fBaud/1667) and F2 (off).  

Note: Do not configure the Low Pass Filter. 
 

4. Select the General tab. Set Rj/Dj Analysis to On. Set Data Pattern Type to 
Repeating, and configure the Pattern Length according to the SAS 
specification. 

5. Select Go to Results and select Run/Stop or Single. 
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