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Report Generator

About the Report Generator

The Report Generator application allows you to generate and print reports
directly from supported oscilloscope applications. The Report Generator is
integrated with applications and enhances the application capabilities by
simplifying the process of creating and maintaining reports.

The Report Generator application includes the following features:

� Automates the process of compiling the test results

� Automates the process of generating the reports

� Sets up the layout using the factory default templates or user defined
templates

� Creates custom templates

� Saves files in the custom file formats such as .rgt, .rpl, or .rpt

� Exports files in .rtf file format

� Prints Template or Report to a file

Starting the Report Generator

You can generate and print reports directly from the oscilloscope. To start the
Report Generator, go to Utilities > Reports.
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See also

Create a new or edit an existing test template (see page 2)

Define a new or edit an existing report layout (see page 4)

Generate, print, or view a report (see page 6)

Steps to set up the Report Generator

Figure 1-1: Steps to set up the Report Generator

Definitions of the User Interface Items

Table 1-1: User interface items and their definitions

Item Description
Test Template A factory template or a test template defined by the user with

fields pertaining to the test desired.
Report Layout The layout for the test templates. This is the blueprint for report

generation.
Palette The palette list is a tree of data items or "Fields" that can be

dragged and dropped on to the templates to design the reports.
Native Fields A part of the palette list that contains parameters to create the

report.
Oscilloscope Fields Groups of oscilloscope data or parameter fields.
Custom Groups Group of fields created by the user.
Client Area The area in the template editor into which you can drag and drop

items from the palette list.
Tile The area in the Report layout that contains the template. The

report layout can be divided into four tiles.
Pane The Report Layout editor window is divided into two areas. These

areas are referred to as panes.
Separator The template separators in report viewer. You can hide or show

the separators.
Report The result of the test template populated with data.
Grid Lines The lines that appear on the test template that help position the

fields.
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Application Directories and File Names

Table 1-2: Application directories

Directory Action
C:\TekApplications\tdsrt-eye\ReportGenerator\modules\
<modulename>\Templates

Stores the default
Report Generator
templates

C:\TekApplications\tdsrt-eye\ReportGenerator\modules\
<modulename>\Reports

Stores the reports

C:\TekApplications\ tdsrt-eye\ReportGenerator\modules\
<modulename>\Layouts

Stores the report layouts

The <moduleName> can be SerialAnalysis, InfiniBand, or PCIExpress.

File Name Extensions

Table 1-3: File name extensions and their descriptions

Extension Description
.rgt Customized Report Generation file format indicates the

generated template
.rpl Customized Report Generation file format indicates the

defined layout files
.rpt Customized Report Generation file format indicates the report

files
.rtf File format that uses a “rich text format”
.rgp Custom report group format.
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Operating the Report Generator

Create or Edit a Test Template

To create a new test template, or edit an existing template, go to Utilities >
Report > Define Test Template.

Figure 2-1: Creating and editing a test template

To create a new test template:

1. Under the Define Test Template tab, select New. The Template Editor
window appears with an empty client area.

2. Create the template using the Palette list.

3. After you have completed creating a new test template, select Done.

To edit an existing test template:

1. Under the Define Test Template tab, select Browse.
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Figure 2-2: Selecting a test template

2. The open window displays the existing factory default templates and
customized templates in C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<moduleName>\Templates, where
modulename can be SerialAnalysis, InfiniBand, or PCIExpress.

3. Select the template that you want to use.

4. Select Open.

5. In the Define Test Template tab, select Edit Template. The Template Editor
window appears with the client area displaying the selected template.

6. Edit the template using the Palette list.

7. After you have completed editing an existing test template, select Done.

See Template Editor on page 10 for more information about the Template Editor.
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Define or Edit a Report Layout

To create a new report layout, or edit an existing report layout go to Utilities >
Reports > Define Report Layout.

Figure 2-3: Defining or editing a report layout

To create a new report layout:

1. Under the Define Report Layout tab, select New. The Report Layout
Editor window appears with an empty report layout area.

2. Create the report by defining the report layout and dragging and dropping
the templates to the report layout area.

3. After you have completed creating a new report layout, select Done.

See Report Layout Editor on page 30, for more information about the Report
Layout Editor.

To edit an existing report layout:

1. Under the Define Report Layout tab, select Browse.
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Figure 2-4: Selecting a report layout

2. The Open window displays the existing factory default report layout and
customized report layouts in C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Layouts, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

3. Select the report layout that you want to use.

4. Select Open.

5. In the Define Report Layout tab, select Edit Layout.

6. The Report Layout Editor window appears with the report layout area
displaying the customized report layout and the selected template files.

7. Edit the report layout using the List of Templates and defining the Report
Layout.

8. After you have completed editing an existing report layout, select Done.

See Report Layout Editor on page 30 for more information about the Report
Layout Editor.
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Generate, Print or View a Report

To generate, print, or view a report go to Utilities > Reports > Generate
Report.

Figure 2-5: Generating, printing, and viewing a report

To generate a report:

1. Under the Generate Report tab, select Browse.

Figure 2-6: Selecting a report layout

2. The Open window displays the existing reports in 
C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Layouts, where
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

3. Select the report that you want to generate.
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4. Select Open.

To print a report

1. Under the Generate Report tab, select Browse.

Figure 2-7: Selecting a report

2. The Open window displays the existing reports in C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Reports, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

3. Select the report that you want to print and select Open. The Report Viewer
displays the selected report with current data from the application.

� If the page settings do not match the page settings for the Report, a
Page Size Mismatch message box displays a message — The current
page settings do not match the page settings for the Report. Do you
want to continue?

� Select Yes to continue.

� Select No to not send the report to the printer.

� If the printer is installed, the report is printed.
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To view a report:

1. Select File > Open. The Open dialog box displays all the reports in the
default directory C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Reports, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

2. Select the report that you want to view and select Open.

Note: You can also use these steps to open a report or a test template.
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Template Editor

About the Template Editor

The Report Generator provides a number of factory default test templates. The
Template editor allows you to create custom test templates.

You can use the Template Editor to do the following tasks:

� Create test templates

� Edit test templates in the .rgt format (report generator template)

� Cut, copy, and paste items across templates

� Save the test templates that you created

� Reuse the test templates in other reports

When the report is generated, the application fills in the fields of the template
using the acquired data from the oscilloscope.

The Template Editor has a palette list that displays the following groups of fields:
the Application Fields, Oscilloscope Fields, and Native Fields. The template
editor provides you with the option to create custom groups; these groups once
created, appear in the palette list. The fields are listed according to the group
selected. You can use these fields to design and create a template.

You can place the fields in the template, and then move and size them
appropriately. Multiple fields can be selected and placed in the template. You can
select more than one field and make the following changes: cut, copy, paste,
align, delete, size, edit font, and change the caption of the fields.

Once a template is defined and saved, either select Done to close the template
editor, or use the Layout icon to directly go to the report layout editor.
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Figure 3-1: The Template Editor

The Template Editor Window

The Template Editor window contains a menu bar, a toolbar, a client area, a
palette list, and a status bar. When you select the New Template button in your
application, the client area in the Template Editor Window is empty. When you
select the Edit Template button in your application, the client area displays the
selected template.
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Figure 3-2: The Template Editor window

In the template editor, you can select a field and right-click on it. This brings up a
context menu for the field with the following items: Cut, Copy, Delete, Bring
To Front, Send To Back, Hide Text, Position Caption on Top, Edit Caption,
Change Font, Align Fields, and Make Same Size.

See also

Menus (see page 25)

Toolbars (see page 28)

Palette List (see page 17)

Status bar (see page 29)
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Default Template Editor Settings

Table 3-1: Default setting for the Template Editor

Parameter Default setting Option
Page Size 8.5x11 inches Change Template Size
Palette List Displays application

fields by default. If
there are no
application fields, the
oscilloscope fields are
displayed.

None

Static Text Inserts static text Static Text
Fields The default size of the

field dragged into the
template is 200x300
pixels.

None

Using the Template Editor

To create a new template:

1. From the Palette List, drag and drop the fields that you want in the report.

2. If you drag and drop a group from the Palette List, all the fields within the
group are placed in the test template.

3. Organize the fields, as you want them to appear in the report.

4. After you have finished creating the template, select File > Save.

To edit an existing template:

1. Open an existing template using Browse > Open. Select the template to edit.

2. Organize the fields, as you want them to appear in the report.

3. From the Palette List, drag and drop the fields that you want in the report. If
you drag and drop a group from the Palette List, all the fields within the
group are placed in the test template.

4. Organize the fields, as you want them to appear in the report.

5. After you have finished editing the template, select File > Save.

See also

Change Template Size (see page 14)

Edit Caption (see page 14)

Change Font (see page 16)
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Align Fields (see page 16)

Make Same Size (see page 17)

Create Custom Groups (see page 21)

Edit Custom Groups (see page 23)

Position Caption

You can position the caption of the selected fields on either the left or on the top
of the field. To position caption:

1. Go to Object > Position Caption to the Left, or on Top.

Edit Caption

You can edit the caption of the selected parameter or object. To edit the caption
go to Object > Edit Caption.

Figure 3-3: Editing a caption

1. Select the caption you want to edit.

2. Select Edit Caption.

3. In the Edit Caption dialog box, select  to enter the caption using the
Virtual Keyboard. You can also type in the new caption.

4. Select OK.

Change Template Size

To change template size:

1. Go to Edit > Change Template Size.
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Figure 3-4: Changing the template size

2. In the Change Template dialog box, select the Template Size as 1/4 page, 1/2
page, or Full page. If the printer is not available, select the Page Size as
Default (8.5" x 11"); otherwise, select Configure Page.

Figure 3-5: Setting up the page

3. In Page Setup dialog box, select the paper size, source, orientation, and
margins.
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4. Select OK to return to Change Template Size dialog box.

5. Select OK.

Note: Do not reduce the template size beyond the content filled in the template.
You may lose information.

Change Font

You can change the font used for the selected field or fields in the template. To
change the font:

1. Select the fields or fields in the test template.

2. Go to Object > Change Font or right click the field to display the options.

Figure 3-6: Changing the font

3. In the Font dialog box, choose the font, font style, size, effects, and script.

4. Select OK.

Align Fields

You can align the text displayed in fields to the top, bottom, left, or right of the
field. To align text in fields, go to Object > Align Fields.

1. Select the fields in the test template.

2. Select Object > Align Fields > Top, Bottom, Left, or Right to align the
field text accordingly.
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Make Same Size

To make two or more fields of the same size, go to Object > Make Same Size.
Select one field as the dominant field to which the other fields will be sized.

1. You can set the selected fields to same height, width, or both.

2. Select the fields in the test template.

3. Select Object > Make Same Size > Height, Width, or Both to make the
selected fields the same size.

Bring to Front

You can bring the selected fields to the front. To bring to front, go to
Object > Bring To Front.

Send to Back

You can send the selected fields to the back. To send to back, go to
Object > Send To Back.

Show/Hide Text

You can show or hide the captions for the selected fields. Go to
Object > Show/Hide Text.

Position Caption

You can position the caption of the selected fields on either the left or on the top
of the field. To position caption text, go to Object > Position Caption to the
Left, or on Top.

Palette List

To view the palette list go to View> Palette Toolbar.

The palette list is a tree of data items or "Fields" that can be dragged and dropped
on to the templates to design the reports.

The Palette list includes the following categories of fields:

� Native Fields; lists fields used mainly to enhance the appearance of the
report, such as Line, Rectangle, and Date.

� <Application> Fields; fields related to the application. The <Application> is
replaced with the name of the application from which you opened Report
Generator.
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� Oscilloscope Fields; groups of fields related to the data acquired from the
oscilloscope.

� Custom Groups; lists fields for new groups not included with the base
Report Generator application.

Figure 3-7: Palette List

The fields often contain a hierarchy. For example, a Horizontal field will have
subordinate fields such as Position, Scale, and so on. If a Field has subordinate
fields under it, a + symbol will precede the field name in the palette list.

Native Fields

You can enhance the report using the following parameters from the Native fields
Static Text, Rectangle, Line, Logo, Table, Date, and Time.

You can drag any of the fields from the Native field and drop it in the test
template.

Static Text

1. From the Native fields, drag and drop the static text field.
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Figure 3-8: Editing text

2. In the Edit Text dialog box, select the virtual keyboard

3. Enter the static text.

4. Select OK.

Rectangle

1. From the Native Fields, drag and drop the Rectangle object into the test
template.

The black squares that appear at the corners of the rectangle allow you to change
the rectangle size.

Line

1. From the Native Fields, drag and drop the Line object into the test template.

The black squares that appear at the corners of the line allow you to change the
line size.

Logo

1. From the Native Fields, drag and drop the Logo field into the test template.

Figure 3-9: Editing an image

2. In the Edit Image dialog box,
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� Select . In the Virtual Keyboard enter the path and filename and
select Enter.

Or

� Select Browse to navigate to the location of the logo graphic image.

3. Select OK.
Table

1. From the Native Fields, drag and drop the table field into the test template.

Figure 3-10: Editing a table

2. In the Edit Table dialog box, you can select the number of rows and columns.

3. Select  next to Number of Rows and Number of Columns to open the
Virtual Keypad.

4. In the Virtual Keypad, enter the number and select Enter.

5. Select OK.

Date and Time

From the Native fields, drag and drop the Date and Time field. The Date and
Time are taken from the oscilloscope system information at the time the report is
generated.

Application Fields

These fields are unique for each application. When you select the applications
field tab, a list appears with the names of the currently available applications.
Refer to the online help that corresponds with each application for descriptions of
the application fields for which you are generating a report.

Oscilloscope Fields

These oscilloscope fields are grouped into ten subgroups:
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� Waveform Group: The Waveform group has the entire active live channels
and independent channels (only CH1 to CH4) waveforms in both jpeg and
bmp. These waveforms are generated to smoothen out the stair-step effect
seen on the display.

� Vertical Group: The Vertical group has all vertical related fields such as
the vertical scale, position, offset, and others.

� Horizontal Group: The Horizontal group has all horizontal related fields
such as the horizontal divisions, scale, record length, position, sample rate,
and others.

� Math Group: The Math group has all the math related fields such as the
math definition for a specified math channel, magnitude, spectral gate,
spectral phase, spectral window, spectral frequencies of the math channel,
and others.

� Trigger Group: The Trigger group has all trigger related fields such as the
trigger type, mode, level, and various fields related to different trigger types.

� Measurement Group: The Measurement group has all the measurements
such as the eight automated measurements and the immediate
measurements.

� Acquisition Group: The Acquisition group has all acquisition related fields
such as the acquisition mode, acquisition state, repetitive mode, fast
acquisition mode, and others.

� Cursor Group: The Cursor group has all the cursor related fields such as
the cursor mode, source, state and type of the cursor, H Bars, V Bars, and
others.

� Zoom Group: The Zoom group has all zoom related fields such as the
zoom horizontal position, horizontal scale, and others.

� Histogram Group: The Histogram group has all histogram fields such as
the coordinates of the histogram box, mode, size, source, and others.

� Screen snapshot: The Screen Snapshot group has two variations: one in
color and the other in black-and-white. For these screenshots, the attributes
are graticule, ink-saver, and jpeg.

Create Custom Group

You can create custom groups using fields from the Palette List. To create
custom groups:

1. Go to Edit > Create Custom Group.
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Figure 3-11: Creating a custom group, step 1

2. In the Create Custom Group dialog box, enter the group name. You can

enter the group name using the Virtual Keyboard .

3. Select Next. The Select Fields dialog box displays all the fields of the
Palette List.

4. Select fields in the Available Groups and Fields: area to add to the custom
group.

Figure 3-12: Creating a custom group, step 2

5. Use Add>> to add selected fields to the new group. Use Add All to add all
available fields to the new group.

6. Use <<Remove to remove selected fields form the selected group. Use
Remove All to remove all the fields from the selected group.
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7. Select Finish.

Edit Custom Groups

To edit custom groups:

1. Go to Edit > Edit Custom Group.

Figure 3-6: Editing custom groups, step 1

2. In the Edit Custom Group dialog box, select a group to edit.

3. Select Next.
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Figure 3-13: Editing custom groups, step 2

4. Use Add>> to add selected fields to the new group. Use Add All to add all
available fields to the new group.

5. Use <<Remove to remove selected fields form the selected group. Use
Remove All to remove all the fields from the selected group.

6. Select Finish.

Delete Custom Groups

To delete custom groups:

1. Go to Edit > Edit Custom Group.
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Figure 3-13: Deleting custom groups

2. In Edit Custom Group dialog box, select a group to delete.

3. Select Delete. A message box appears asking you to confirm your choice.

4. Select Yes to delete.

Template Editor Menus

The menu bar has the following menus.

File (see page 25)

Edit (see page 26)

View (see page 26)

Object (see page 26)

Window (see page 27)

Help (see page 27)

Template Editor: File Menu

Table 3-2: File menu options and their functions

Menu Function
New Creates a new template
Open Opens a template
Close Closes the template
Save Saves changes to the file
Save As Saves the template as a different file using the save as

dialog box
Print Prints all or part of the template
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Print Preview Displays a sample view of the template
List of Recent Templates Opens a previously (recently) opened template
Exit Closes the template editor

Template Editor: Edit Menu

The available Edit menu selections depend on whether a template is active or not.
In other words, the client area is empty or has a template open.

Table 3-3: Edit menu options and their functions

Menu Function
Cut Cuts the selected fields.
Copy Copies the selected fields
Paste Pastes the clipboard content
Delete Deletes the selected fields
Select All Selects all fields
Create Custom Groups Creates a custom group
Edit Custom Groups Edits a custom group
Change Template Size Changes the template size
Find Finds the data matching the search criteria
Replace Replaces the data matching the search criteria with a

specified data.

Template Editor: View Menu

Table 3-4: View menu options and their functions

Menu Function
Tool Bar Displays/Hides the toolbars selected such as Standard,

Align, Size, Layout, and Action
Status Bar Displays/Hides the Status bar.
Palette Bar Displays/Hides the Palette bar.
Grid Lines Displays/Hides the Grid Lines in the client area.

Template Editor: Object Menu

The available object menu selections depend on whether a parameter in the client
area is selected or not.

Table 3-5: Object menu options and their functions

Menu Function
Bring to Front Brings the selected fields to the front
Send to Back Sends the selected fields to the back
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Hide Text/Show Text Show or hides the caption of the selected parameter
Position Text on top/to the
left

Allows you to change the font of the selected parameter or
the caption using the change font dialog box.

Edit Caption Allows you to edit the caption of the selected parameter.
Change Font Allows you to change the font of the selected parameter or

the caption using the Change Font dialog box.
Align Fields Aligns fields to top, bottom, left, or right.
Make Same Size Resizes the selected objects to the same size by height,

width, or both.

Template Editor: Window Menu

Table 3-6: Window menu options and their functions

Menu Function
New Window Opens a new window duplicating the current active

window.
Cascade Arranges the open templates in the client area from the

upper, left side to the lower right side so that they overlap
one another

Tile Arranges the open templates horizontally and vertically in
the application client area without overlapping.

Arrange Icons Positions the icons of any templates you have minimized
to the bottom-left of the window.

List of open Templates Allows you to display another open template.

Template Editor: Help Menu

Table 3-7: Help menu options and their functions

Menu Function
Help Topics Displays the online help
About Template Editor Displays Version and Copyright information
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Template Editor: Toolbars

You can choose to display or hide these toolbars using View > Toolbars. The
Template Editor has the following toolbars.

Standard (see page 28)

Align/Size (see page 28)

Layout (see page 29)

Action (see page 29)

Template Editor: Standard Toolbar

To view the standard toolbar:

Go to View > Toolbar > Standard.

Template Editor: Align or Size Toolbar

To view the align or size toolbar:

Go to View > Toolbar > Align/Size.
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Template Editor: Layout Toolbar

To view the layout toolbar:

Go to View > Toolbar > Layout.

Template Editor: Action Toolbar

To view the action toolbar

Go to View > Toolbar > Action.

The Layout button also prompts you to save documents.

Template Editor: Status Bar

The Status bar displays the status of the application and tool tips for selected
options.
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Report Layout Editor

About the Report Layout Editor

The Report Layout Editor helps you define the report layout for generating
reports. The report layout, once created can be reused for generating multiple
reports.

You can use the Report Layout Editor to do the following tasks:

� Select the number of test templates per page

� Position the templates in the report

� Create a report with up to five pages with different layout sizes

� Enter unique, easy to recognize layout names for subreports with a unique
test title. This unique test title helps you to select the required template when
generating a report.

� Reuse layouts in other test templates

� Define headers and footers
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To display the Report Layout Editor, select Define Report Layout > New
Report Layout.

Figure 4-1: The Report Layout Editor

The Report Layout Editor window has two panes:

� List of Templates: Displays a list of templates, template sizes, template
folders, and buttons that allow you to clear or place a template in a report
layout tile.

� New: Opens a new template

� Directory: Opens a Browse window to select the template folder.

� Place on Tile: Places the selected template on the tile.

� Clear Tile: Clears the selected template from the tile.

� Report Layout: Displays the selected report layout and the header/footer
definition.
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Report Layout Editor Window

The Report Layout Editor window contains a menu bar, a tool bar, a list of
templates pane, and a report layout pane.

Figure 4-2: The Report Layout Editor window

See also

List of Templates Pane (see page 33)

Report Layout Pane (see page 33)

Menu (see page 38)

Toolbars (see page 40)

Status Bar (see page 42)
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List of Templates Pane

The List of Templates Pane displays the path of the template, templates in the
folder, file names, and template sizes. You can select the template from this list
and place it in the Report Layout pane.

Figure 4-3: The List of Templates pane

In the List of Templates Pane you can do the following:

� Use the Virtual Keypad to select a different path where you have saved
customized templates. Select the Directory button to display a Browse for
Folder window.

� Create a new template by selecting New. The Template Editor Window is
displayed, where you can create a new template.

� Drag and drop the Template File into the report layout pane's tile or select
the template file and select Place on Tile >>.

� Clear the selected tile in the report layout pane by selecting << Clear Tile.

Report Layout Pane

Depending on the number of tests selected per page, the Report Layout pane
appears as shown in the following figure:
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Figure 4-4: The Report Layout pane

In the Report Layout pane, you can do the following:

� Specify a title for each test.

� Define or modify the header and footer.

� Navigate between pages of the report layout.

Using the Report Layout Editor

To define a report layout, perform the following steps:

1. Set the report layout.

� Select Layout > One Test Per Page / Two Tests Per Page / Three
Tests Per Page. The Report Layout pane displays tiles depending on
the selected number of tests per page.

2. Add the templates.

� The List of Templates pane displays the templates in the default
directory C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Templates, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.
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� From the List of Templates pane, drag and drop the templates into the
tiles in the Report Layout pane. You can use the Place on Tile and
Clear Tile buttons to move the templates to the tiles and to clear the
tiles.

� If you want to define a new template, select New in the List of
Templates pane.

� To browse for a folder other than the default templates, select Directory
to display Browse for Folder dialog box. Navigate to the folder where
you have the templates stored and select OK.

3. Define the Header and Footer.

4. Save the report layout.

� Select File > Save to display the Save dialog box. Enter the report
layout name and select Save.

� The report layout is saved in the .rpl format.

To edit an existing report layout, perform the following steps:

1. Change the report layout.

� Select Layout > One Test Per Page / Two Tests Per Page / Three
Tests Per Page. The Report Layout pane displays tiles depending on
the selected number of tests per page.

� The application displays an alert message — All the Test(s)
information in the current page will be lost. Do you want to
continue?

Select Yes to continue or No to stop.

2. Add or Remove the templates.

� In the Report Layout pane, select the tile to which you want to add or
remove the template.

� To remove a template from the Report Layout, complete the following
steps:

� In the List of Templates pane, select Clear Tile.

� The application displays an alert message — The test is already filled
with data. Do you want to remove it?

� Select Yes to continue or No to stop.

� To add a template to the Report Layout, complete the following steps:

� The List of Templates pane displays the templates in the default
directory C:\TekApplications\tdsrt-
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eye\ReportGenerator\modules\<modulename>\Templates, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

� From the List of Templates pane, drag and drop the templates into the
tiles in the Report Layout pane.

� Select the Place on Tile button to move the template to the selected tile.

� If you want to define a new template, select New in the List of
Templates pane.

� To browse for a folder other than the default templates, select Directory
to display the Browse for Folder dialog box. Navigate to the folder
where you have the templates stored and select OK.

3. Modify the Header and Footer

4. Save the report layout.

� Select File > Save to display the Save dialog box. Enter the report layout
name and select Save.

� The report layout is saved in the .rpl format.

Define Header and Footer

To modify the Header Definition, do the following:

1. In the Report Layout pane, select Header - Click to Modify.

Figure 4-5: Defining header and footer

2. In the Header/Footer Definition dialog box, select the header position -
Header Left, Header Center, or Header Right.

3. Enter the Header definition in the text box.

� Select  to display the Virtual Keyboard. In the Virtual Keyboard,
select the text and Enter.

Or
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� To insert the special text, select the Insert Special Text button to display a
sub menu. Select Date, File Name, Author, Page X of Y, Page X, or Logo.

4. Select Set Font to change the font style, size, effects, color, and script for
each field separately, then select OK.

5. In the Header/Footer Definition dialog box, select OK.

To modify Footer Definition, do the following:

1. In the Report Layout pane, select Footer - Click to Modify.

2. In the Header/Footer Definition dialog box, select the footer position - Footer
Left, Footer Center, or Footer Right.

3. Enter the Footer definition in the text box.

Select  to display the Virtual Keyboard. In the Virtual Keyboard, select
the text and select Enter.
Or
To insert the special text, select the Insert Special Text button to display a
sub menu. Select Date, File Name, Author, Page X of Y, Page X, or Logo.

4. Select Set Font to change the font style, size, effects, color, and script for
each field separately, then select OK.

5. In the Header/Footer Definition dialog box, select OK.

To View a Report

To display the selected report:

1. Select File > Open. The Open dialog box displays all the reports in the
default directory C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Reports, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.

2. Select the report that you want to view and select Open.

Change Report Layout

You can change the report layout to fit one, two or four tests per page.

Go to Layout > One Test Per Page / Two Tests Per Page / Four Tests Per
Page

or
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Insert Pages

To insert pages:

� Select Page> Insert Blank > Before Current Page / After Current Page
to insert a new page before the current page or after the current page

� Select Page> Insert Copy > Before Current Page / After Current Page to
insert copy of the current page. You can insert the page, before the current
page or after the current page.

Note: When you insert a copy of a page before or after the current page, the
layout of the current page is the same layout as the new page.

Default Report Layout Editor Settings

Table 4-1: Default settings for the Report Layout Editor

Parameter Default setting Option
Report Size Four tests per page Layout
Page Size 8.5x11 inches Page Setup
Layout Editor One page None
Go To Displays the current

page number in the
page layout.

Edit

Font Arial>Regular 9 None
Default Margin Margin size on all

sides of the paper is
0.8 inches.

None

Report Layout Editor: Menus

The menu bar has the following menus.

File (see page 39)

Edit (see page 39)

View (see page 39)

Layout (see page 39)
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Page (see page 40)

Help (see page 40 )

Report Layout Editor: File Menu

Table 4-2: File menu options and their functions

Menu Function
New Creates a new report layout
Open Opens a report layout file
Save Save changes to the file
Save As Saves the template as a different file name using the

save as dialog box.
Page Setup
          Configure page

          Default (8.5X11inches)

Prints all or part of the contents of the test template.
Configures the paper size, source, orientation, and
margins using the Page Setup dialog box.
Configures the page setup to default — 8.5" X 11"

Layout Preview Displays a sample view of the active report layout as it
would be printed.

List of Recent reports Opens a previously (recently) opened report layouts.
Exit Closes the Report Layout Editor.

Report Layout Editor: Edit Menu

Table 4-3: Edit menu options and their functions

Menu Function
Go To Goes to the page entered in the Go to Page dialog box.

Report Layout Editor: View Menu

A (√) appears next to the menu item selected.

Table 4-4: View menu options and their functions

Menu Function
ToolBar Displays or hides the selected toolbars such as

standard, page, layout and action.
Status Bar Displays or hides the status bar
Refresh Template List Updates the template list in the List of templates pane.

Report Layout Editor: Layout Menu

A (√) appears next to the menu item selected.

Table 4-5: Layout menu options and their functions
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Menu Function
One test per page Changes the report layout to fit one test per page
Two tests per page Changes the report layout to fit two tests per page
Four tests per page Changes the report layout to fit four tests per page

Report Layout Editor: Page Menu

Table 4-6: Page menu options and their functions

Menu Function
Insert Blank Page
    Before Current Page
    After Current Page

Inserts a blank page before the current page
Inserts a blank page after the current page

Insert Copy
    Before Current Page
    After Current Page

Inserts a copy of the page before the current page
Inserts a copy of the page after the current page

Delete Deletes the current page

Report Layout Editor: Help Menu

Table 4-7: Help menu options and their functions

Menu Function
Help Topics Displays the online help
About Report Layout Editor Displays Version and Copyright information

Report Layout Editor: Toolbars

You can choose display or hide the toolbars using View > Toolbars. The Report
Layout Editor has the following toolbars.

Standard (see page 40)

Layout (see page 41)

Page (see page 41)

Action (see page 41)

Report Layout Editor: Standard Toolbar

To view the standard toolbar go to View > Toolbars > Standard.



Report Layout Editor

Report Generator Reference Manual 41

Report Layout Editor: Layout Toolbar

To view the layout toolbar go to View > Toolbars > Layout.

Report Layout Editor: Page Toolbar

To view the page toolbar go to View > Toolbars > Page.

Report Layout Editor: Action Toolbar

To view the action toolbar go to View > Toolbars > Action.
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Status Bar

The Status bar displays the status of the application and tool tips for the selected
options.

Report Layout Editor: Adding a Template

Using the Report Layout Editor, you can add a template to an existing report.
Follow these steps to add a template to the report:

1. Open a new layout using Define Report Layout.

2. Select File > Open and browse for generated reports. The report is displayed
in the Report Layout pane.

3. From the standard toolbar, select Insert New Page before Current Page or
Insert New Page after Current Page.

4. From the List of Templates pane, select the template that you want to add to
the current page layout. Drag and drop the template file on to the report or
use Place on Tile to add the template.

5. Add test titles for this layout.

6. Select File > Save to save the modified report as a .rpl or .rpt file.

7. Generate a report for the unfilled template from the .rpl or .rpt file using
Generate Report.
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Report Viewer

About the Report Viewer

The Report Viewer allows you to view the generated report.

Under the Generate Report tab, select Generate or View to display the Report
Viewer and browse for the report that you want to generate or view.

Figure 5-1: The Report Viewer
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Report Viewer Window

The Report Viewer window comprises a menu bar, a toolbar, an align/size bar,
and a client area.

Figure 5-2: The Report Viewer window

See also

Menus (see page 50)

Toolbars (see page 53)

Status bar (see page 54)
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Using the Report Viewer

Click on each of these links to use the Report Viewer:

To View a Report (see page 49)

To Edit Text (see page 48)

To Find Text (see page 49)

To Replace Text (see page 49)

Bring to Front (see page 46)

Send to Back (see page 46)

Show/Hide Text (see page 47)

Export to RTF (see page 48)

You can select some objects and bring to front or send to back. You can
show/hide text, position caption to the left, or on top. You can change font, align
selected fields or make the selected fields to same size. You can also export a
report as an rtf.

Select All

To cut, copy, or delete the fields from the test template, you need to select the
fields. You can also select the fields from the test template by selecting CTRL+
selecting the fields.

To select all:

1. Go to Edit > Select All

Bring to Front

You can bring the selected fields to the front. To bring to front:

1.  Go to Object > Bring To Front

Send to Back

You can send the selected fields to the back. To send to back

1. Go to Object > Send To Back
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Show/Hide Text

You can show or hide the captions for the selected fields.

1. Go to Object > Show/Hide Text.

Configure Page

You can configure the paper size, source, orientation, and margins. To configure
page go to File > Page Setup > Configure Page.

Figure 5-3: Page Setup dialog box

After you have configured the page setup, select OK.

Go To Page

You can go to different pages in the report layout using the Go To Page dialog
box. To go to page select Edit  > Go To.

1. In the Enter Page Number field, enter the page number or select  to
display the Virtual Keyboard.

2. Select Go To. The Report Layout pane displays the relevant page.
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Export to RTF

You can export a report generated by the Report Generator to rich text format. To
export a file to rtf, go to File > Export to RTF

Note: Text and Images in the rtf file may not be completely visible. To make the
text and images visible, select the text or image and re-size it.

To Edit Text

Select Edit > Add Text Field. The Edit Text dialog box appears.

1. In the Text field, enter the text or select  to display the Virtual Keyboard.

2. In the Virtual Keyboard, enter the text and select Enter.

3. In the Edit Text dialog box, select OK.
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To Find text

Select Edit > Find. The Find dialog box appears.

1. In the Find what field, enter the text or select  to display the Virtual
Keyboard.

2. In the Virtual Keyboard, enter the text and select Enter.

3. In the Find dialog box, select Find Next until you find that text that you are
searching for.

To Replace text

You can search and replace the text in the test template

1. Select Edit > Replace.

Figure 5-4: Finding text

2. In Replace dialog box, enter the search string using the Virtual Keyboard in
the Find what field.

3. In Replace with field, using the Virtual Keyboard enter the replacement
string.

4. Select Find Next until you find the required search string.

5. Select Replace to replace one instance of the string.
Or
Select Replace All to replace all instances of the string.

6. Click Cancel after you have replaced the strings.

View a report

To display the selected report:

1. Select File > Open. The Open dialog box displays all the reports in the
default directory C:\TekApplications\tdsrt-
eye\ReportGenerator\modules\<modulename>\Reports, where the
"modulename" can be SerialAnalysis, InfiniBand, or PCIExpress.
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2. Select the report that you want to view and select Open.

Align Fields

You can align the fields to top, bottom, left, or right. To align fields go to
Object > Align Fields.

1. Select the fields in the test template.

2. Select Object > Align Fields > Top, Bottom, Left, or Right to align the
fields accordingly.

Report Viewer: Change Font

 You can change font for the selected field in the template. To change font:

1. Select the fields or fields in the test template.

2. Select Object > Change Font or right-click on the field to display the
options.

3. In the Font dialog box, choose the font size, color, style, and effects.

4. Select OK.

Report Viewer: Make Same Size

 You can make two or more selected fields of the same height, width, or both go
to
Object > Make Same Size. Select one field as the dominant field to which the
other fields will be sized. Use the Ctrl key to select the fields.

1. Select the fields in the report.

2. Select Object > Make Same Size > Height, Width, or Both to make the
selected fields to the same size.

Report Viewer: Menus

The menu bar has the following menus.

File (see page 51)

Edit (see page 51)

View (see page 51)

Object (see page 52)

Help (see page 52)
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Report Viewer: File Menu

Table 5-1: File menu options and their functions

Menu Function
Open Opens a template or report file
Save Save changes to the file.
Save As Saves the template to a different file name using the Save

As dialog box.
Print Prints all or part of the contents of the report.
Print Preview Displays a sample view of the report
Print Setup Prompts you to setup the printer
Export to RTF Exports the report in .rtf (rich text format).
List of Recent Templates Lists the last four recently saved reports.
Exit Closes the Report Viewer.

Report Viewer: Edit Menu

The available edit menu selections depend on whether a field is selected or not.

Table 5-2: Edit menu options and their functions

Menu Function
Cut Cuts the selected fields and places them on the clipboard.
Copy Copies the selected fields to the clipboard.
Paste Pastes the clipboard contents
Delete Deletes the selected fields
Select All Selects all fields
Add Text Field Adds a text field to the report.
Find Finds the data matching the search criteria entered.
Replace Replaces the data matching the search criteria with the

specified data.
Go To Goes to the page number specified in the Go To Page

dialog box.

Report Viewer: View Menu

A (√) appears next to the menu item selected.

Table 5-3: View menu options and their functions

Menu Function
Tool Bar Displays/Hides the standard toolbar.
Align/Size Bar Displays/Hides the Align/Size toolbar.
Status Bar Displays/Hides the status bar.
Separators Displays/Hides the separators.
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Report Viewer: Object Menu

The available object menu selections depend on whether a field in the client area
is selected or not.

Table 5-4: Object menu options and their functions

Menu Function
Bring to Front Brings selected fields to the front
Send to Back Sends the selected fields to the back
Hide Text/Show Text Show or hides the caption of the selected parameter
Position Text on top/to the
left

Positions the caption of the selected field to left or on top.

Edit Text Allows you to edit the text in the selected field.
Change Font Allows you to change the font of the selected parameter

or the caption using the Change Font dialog box.
Align Fields Aligns fields to top, bottom, left, or right.
Make Same Size Resizes the selected objects to the same size by height,

width, or both.

Report Viewer: Help Menu

Table 5-5: Help menu options and their functions

Menu Function
Help Topics Displays the online help
About Report Viewer Displays the Version and Copyright information
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Report Viewer: Toolbars

You can choose to display or hide these toolbars using View > Toolbars. The
Report Viewer has the following toolbars:

Standard (see page 53)

Align/Size Bar (see page 54)

Separators (see page 54)

Status Bar (see page 54)

Report Viewer: Standard Toolbar

To view the standard toolbar, go to View>Toolbar.
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Report Viewer: Align/Size Bar

To view the align/size bar, go to View > Toolbar.

Report Viewer: Separators

To view the separators, go to
View > Separators. Shows or hides the template separators.

Report Viewer: Status Bar

The Status bar displays the status of the application and tool tips for the selected
options.
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Appendix

Shortcut Keys

Shortcut Keys for the Report Generator

Table 6-1: Shortcut Keys

Action Shortcut Keys
Common keys
Open Ctrl+O
Save Ctrl+S
Template Editor
New Ctrl+N
Find Ctrl+F
Replace Ctrl+H
Print Ctrl+P
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del
Select All Ctrl+A
Bring to Front Ctrl+Plus
Send to Back Ctrl+Minus
Edit Text ALT+Enter
Report Layout
New Ctrl+N
Go To Ctrl+G
Refresh Template List F5
Report Viewer
Find Ctrl+F
Select All Ctrl+A
Del Del
Bring to Front Ctrl+Plus
Send to Back Ctrl+Minus
Edit Text ALT+Enter
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Report Generator Error Codes

Table 6-2: Error codes and their descriptions

Error Code Error Message Description Possible Solution
Report Generator Interface Error Codes
741 Some installation files

are missing or corrupted,
try reinstalling the
application. The
application will now exit.

The Application FDB
File path retrieved
from registry is
corrupted or invalid
file path.

Uninstall the application and
try reinstalling.

742 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will now exit.

Application Id
retrieved from
registry is invalid.
(<0)

Uninstall the application and
try reinstalling.

743 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will now exit.

Application version is
invalid.

Uninstall the application and
try reinstalling.

744 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will now exit.

Not able to spawn
Report Viewer.

Report Viewer executable
file is missing, or there might
be resource crunch if there
are many applications
running currently.
Try closing some of the
other applications. If this
does not work, then uninstall
and reinstall the application.

745 Internal initialization
error. The application will
exit now.

The Memory Map
File or
synchronization
events for
communication with
RGScope are already
open. The application
was previously not
shut down
completely. Try
closing RGScope.

The application was not
closed completely last time.
A module RGScope might
be still running in the
background. Try closing it.

746 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will exit now.

Not able to spawn
Oscilloscope
Interface.

RGScope file is missing, or
there might be resource
crunch if there are many
applications running
currently.
Try closing some of the
other applications. If this
does not work, then uninstall
and reinstall the application.

747 Some installation files
are missing or corrupted,

The application FDB
File read failed. The

Uninstall the application and
try reinstalling.
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try reinstalling the
application. The
application will exit now.

file may be read only.

748 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will exit now.

The Acc application
FDB File read failed.
The file may be read
only.

Uninstall the application and
try reinstalling.

749 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will exit now.

Not invoked by
application. The
application name
passed by the
invoking application
not found in the
registry.

Uninstall the application and
try reinstalling.

750 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will exit now.

Not able to spawn the
Report Layout Editor.

The Report Layout Editor
executable file is missing, or
there might be resource
crunch if there are many
applications running
currently.

Try closing some of the
other applications. If this
does not work, then uninstall
and reinstall the application.

751 Some installation files
are missing or corrupted,
try reinstalling the
application. The
application will exit now.

Not able to spawn the
Template Editor.

Template Editor executable
file is missing, or there might
be resource crunch if there
are many applications
running currently.
Try closing some of the
other applications. If this
does not work, then uninstall
and reinstall the application.

Error Code Error Message Description Possible Solution
Report Layout Editor Error Codes
721 Some installation files

are missing or corrupted,
try reinstalling the
application.

Not Invoked by the
desired application.
The application
Name passed by
invoking the
application is not
found in the registry.

Try uninstalling and
reinstalling the application.

722 The selected file is not a
valid layout for this
application.

The layout belongs to
some other
application.

The layout file being opened
belongs to an older
application. It is not possible
to open a file belonging to
another application.

723 Layout file is not valid for The layout was The opened layout file
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the current version of the
Application.

created for some
other version of the
application.

belongs to a different
version of the same
application. It is not possible
to open a file belonging to
another version.

Error Code Error Message Description Possible Solution
Template Editor Error Codes
761 Error in Initialization of

Application.
The Dlls and
application
executables are not
properly installed.

Try uninstalling and
reinstalling the application.

762 Error!! : Invalid
Application Name

Registry Entries are
not appropriate.

Try uninstalling and
reinstalling the application.

763 Error!! The Selected file
is not a valid template for
this application.

The template belongs
to some other
application

The opened template file
belongs to a different
version of the same
application. It is not possible
to open a file belonging to
another version.

764 Error !!: Template file is
not valid for the current
version of the
Application.

The template was
created for some
other version of the
application.

The opened template file
belongs to a different
version of the same
application,. It is not
possible to open a file
belonging to another
version.

765 A Group with the
specified name already
exists.

User tried to create a
custom group with
the same name as an
existing group.

Try using a different name
than the existing groups.

Error Code Error Message Description Possible Solution
Oscilloscope Interface Error Codes
781 The MFC Dlls are not

properly installed.
The MFC Dlls are not
properly installed.

Reinstall the application.

782 The system resources
required for
communication are
already open.

The system
resources required
for communication
are already open.

Close all application related
executables and try again.

783 RGScope.exe is already
running on the system.

Illegal memory
access.

Close RGScope and restart
the application.

784 illegal memory access. illegal memory
access.

Close the application and
restart.

785 An unknown exception
occurred in the
application.

An unknown
exception occurred in
the application

Close the application and
restart.

786 Exception occurred while
accessing a file

Exception occurred
while accessing a file

Close the application and
restart.

787 The application was not
able to acquire windows
resources such as GDI
objects.

The application was
not able to acquire
Windows resources
such as GDI objects.

Close the application and
restart.
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788 The application was not
able to connect to the
oscilloscope. Make sure
the TekScope.exe is
running.

The application was
not able to connect to
the oscilloscope.
Make sure the
TekScope.exe is
running.

If this does not solve the
problem reinstall the
application.

789 The required registry key
doesn’t exist or an error
occurred while getting
it’s value.

The required registry
key doesn’t exist or
an error occurred
while getting it’s
value.

Close the application and
restart. If this does not solve
the problem reinstall the
application.

790 The FDB file doesn’t
exist or it may be read-
only.

The FDB file doesn’t
exist or it may be
read-only.

Make sure the FDB file is
present and not read-only. If
this does not solve the
problem reinstall the
application.

791 Oscilloscope interface
received an invalid
message from RG
interface.

Oscilloscope
interface received an
invalid message from
RG interface.

Close the application and
restart.

792 Error in getting memory
from the system

Error in getting
memory from the
system.

Quit one or more
applications running on the
system and restart RGApp.

793 Error in creating the jpeg
file.

Error in creating the
jpeg file.

Make sure the “temp” folder
exists and there is space on
the hard disk drive.

Error Code Error Message Description Possible Solution
Message boxes and dialog boxes in the user interface
701 Error Initializing Report

Generator.
System resources
can't be allocated Try
closing some of the
other applications.

If this does not work, then
uninstall and reinstall the
application.

702 No valid file name was
provided.

This happens when
no filename is
selected in
Application for
generating a report.

Select a valid file.

703 <Path of the file
selected>.
The template file name
is invalid.

The reading of the
template file fails.
This will happen if the
application fails to
read the rgt file.

Select another valid
template file.

704 <filename> is not a valid
Report Layout..

An invalid report
layout was provided.
This happens if the
application fails to
read the layout file.

Select another valid layout
file.

705 <filename> is not a valid
Report Layout file for the
Application.

The layout is not valid
for the application.
This means that the
file was read properly
but the application
and version for the rpl

Select another valid layout
file for the application.
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file don’t match the
application.

706 Invalid Report file
specified.

A file other than the
Report Generator
file(s) is selected with
the extension (rpt rgt
rpl) used by Report
Generator files.

Select another valid file.

707 Invalid File Format. Other file types such
as text are selected

Select another valid file.

708 <filename> is not a valid
report file for
<AppName>

The application name
and version for the
report file do not
match that of
application.

Select another valid report
file for that application.

709 Unable to read the
Report file.

An exception occurs
for a rpt file. This
happens if the
application cannot
read the report .rpt
file.

Select another valid report
file for that application.
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Virtual Keyboard

Selecting  displays the Virtual Keyboard similar to the keyboard. The field on
the top displays what you have selected. After you have selected the required
content, select Enter.
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